Chapter 5
Combining Multiple Objects
Grouping, Combining, Merging, and Positioning
Copyright

This document is Copyright © 2011–2014 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

John Cleland  Martin Fox  Jean Hollis Weber
John A Smith  Peter Schofield  Hazel Russman

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments

This chapter is based on an original French document written for OpenOffice.org 1.x by Michel Pinquier (translated into English by Alex Thurgood) and previous content revised by Jim Taylor. The chapter was revised for OpenOffice.org 2.0 by Linda Worthington, Daniel Carrera, Jean Hollis Weber, and Agnes Belzunce, and later translated into German by Wolfgang Uhlig. The German revisions were then translated into English and revised for OpenOffice.org 3.3 and LibreOffice 3.3 by Martin Fox. Other contributors included Peter Hillier-Brook, Hazel Russman, Gary Schnabl, and Claire Wood.

Publication date and software version

Published 13 December 2014. Based on LibreOffice 4.3.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click or right-click depending on computer setup</td>
<td>Opens a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+⌘+F5</td>
<td>Opens the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Opens the Styles and Formatting window</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
Contents

Copyright ........................................................................................................................................... 2  
Contributors .................................................................................................................................. 2  
Feedback ........................................................................................................................................ 2  
Acknowledgments .......................................................................................................................... 2  
Publication date and software version ......................................................................................... 2

Note for Mac users ......................................................................................................................... 2

Grouping objects ............................................................................................................................. 4  
  Temporary grouping ....................................................................................................................... 4  
  Grouping ....................................................................................................................................... 4  
  Ungrouping .................................................................................................................................. 4  
  Editing individual objects ............................................................................................................. 5  
  Nesting groups ............................................................................................................................. 5

Combining objects .......................................................................................................................... 5  
  Combining .................................................................................................................................... 6  
  Splitting combined objects .......................................................................................................... 6  
  Breaking combined objects ......................................................................................................... 7  
  Connecting lines ......................................................................................................................... 7

Merging, subtracting, or intersecting objects .................................................................................. 7  
  Merge ........................................................................................................................................... 8  
  Subtract ...................................................................................................................................... 8  
  Intersect ...................................................................................................................................... 8  
  Practical example ....................................................................................................................... 8

Duplication and cross fading ......................................................................................................... 9  
  Duplication .................................................................................................................................. 9  
  Cross fading ................................................................................................................................ 11

Positioning objects ........................................................................................................................ 12  
  Arranging objects ....................................................................................................................... 12  
  Aligning objects .......................................................................................................................... 12  
  Distributing objects .................................................................................................................... 13
Grouping objects

Grouping of objects is similar to putting objects into a container. You can move the objects as a group and apply global changes to the objects within the group. A group can always be undone and the objects that make up the group can always be manipulated separately.

Temporary grouping

A temporary grouping is when several objects are selected. Any changes to object parameters that you carry out are applied to all of the objects within the temporary group. For example, you can rotate a temporary group of objects in its entirety.

To cancel a temporary grouping of objects, simply click outside of the selection handles displayed around the objects.

Grouping

To group objects together permanently:

1) Select the objects by clicking on each object in turn while holding down the Shift key, or use the Select icon on the Drawing toolbar and draw a selection rectangle around the objects using the cursor. Selection handles will then appear around all the objects within the group (Figure 1).

2) Right-click on the group and select Group from the context menu, or go to Modify > Group on the main menu bar, or use the keyboard shortcut Control+Shift+G.

![Figure 1: Grouping objects](image)

When objects are grouped, any editing operations carried out on that group are applied to all objects within the group. If you click on one object in the group, the whole group is selected.

The objects within a group also retain their own individual properties and can be edited independently. See “Editing individual objects” on page 5 for more information.

Ungrouping

To undo or ungroup a group of objects:

1) Select the group of objects which is indicated by selection handles appearing around the group.

2) Right-click on the group and select Ungroup from the context menu, or go to Modify > Ungroup on the main menu bar, or use the keyboard shortcut Control+Alt+Shift+G.
Editing individual objects

You can individually edit an object within a group without ungrouping the group.

1) Right-click on the group and select Enter group from the context menu, or go to Modify > Enter Group on the main menu bar, or press the F3 key, or double-click on the group. When you enter a group, objects outside the group cannot be selected for editing and appear pale (Figure 2).

2) Once inside the group, click on any object to individually edit it (Figure 3).

3) To leave a group, right-click on the group and select Exit group from the context menu, or go to Modify > Exit Group on the main menu bar, or use the keyboard combination Ctrl+F3 key, or double-click outside the group.

Nesting groups

You can create a group of groups, which is more commonly known as nesting groups. When you create nested groups, Draw retains the individual group hierarchy and remembers the order in which groups were selected. That is, the last individual group selected will be on top of all the other groups within a nested group.

Ungrouping and entering a nested group works in exactly the same way as for individual groups in “Grouping” and “Ungrouping” as above.

Combining objects

Combining objects is a permanent merging of objects that creates a new object. The original objects are no longer available as individual entities and cannot be edited as individual objects. Any editing of a combined object affects all the objects that were used when combination was carried out.
Combining

1) Select the objects you want to combine.
2) Right-click on the selection and select Combine from the context menu, or go to Modify > Combine on the main menu bar, or use the keyboard combination Control+Alt+Shift+K.

![Figure 4: Combining objects](image)

At first glance, the results can seem rather surprising, but once you understand the rules governing combination in Draw, combining objects will become clearer.

- The attributes (for example, area fill) of the resulting object are those of the object furthest back. In Figure 4, it is the circle and Figure 5 it is the yellow rectangle.
- Where the objects overlap, the overlapping zone is either filled or empty depending on whether the overlap is even numbered or odd numbered. Figure 5 shows that where the overlap number is even, you get an empty space and where the overlap number is odd, you get a filled area.

![Figure 5: Area fill on overlapping objects](image)

**Tip**
You can reorder objects so they are further back or further forward in the arrangement order. Right-click on the object and select Arrangement from the context menu. For more information, see “Arranging objects” on page 12.

Splitting combined objects

An object which has been combined from several objects can be split into individual objects by going to Modify > Split on the main menu bar, or right-clicking on the combined object and selecting Split from the context menu, or using the keyboard shortcut Control+Alt+Shift+K. However, the original objects will retain the formatting of the combined object and will not revert back to their original formatting.

In Figure 6, the left graphic is the original object, as shown on the left in Figure 5. The right graphic is the result of splitting and the individual objects have taken the formatting of the combined object, as shown on the right in Figure 5.
Breaking combined objects

When an object is combined from several objects, the combined object can be broken into its constituent parts by going to Modify > Break on the main menu bar. This means that the original objects are broken into their constituent parts; for example, a rectangle will be broken into four separate lines and the area fill will be lost, as shown by the right graphic in Figure 7. The left graphic in Figure 7 is the original combined object.

Connecting lines

The constituent parts of an object can be connected together by selecting all the constituent parts of the object and going to Modify > Connect on the main menu bar. This connects the parts together and closes the object resulting in the area becoming filled with the area fill it had before the object was broken.

Merging, subtracting, or intersecting objects

After you have selected more than one object, the Merge, Subtract, and Intersect functions become available, allowing you to create a new object with a new shape. After selecting several objects, go to Modify > Shapes on the main menu bar or right-click on the selected objects and select Shapes from the context menu.
Merge
When you merge objects, a new object is created with a shape that follows the shape of the merged objects. The area fill of the merged object is determined by the area fill of the object that is at the rear of all the other objects, as shown in Figure 8.

Subtract
When you subtract objects, the objects at the front are subtracted from the object behind. This leaves a blank space that the subtracted objects occupied (Figure 9).

Intersect
When you intersect objects, the front objects and the exposed area of the object at the rear are removed. This creates a new object from the area of the object at the rear that was covered by the objects at the front (Figure 10).

Practical example
The example in Figure 11 shows how you can use the merge, subtract, and intersect functions to create a knife with a wooden handle.

Figure 11: Creating a knife

<table>
<thead>
<tr>
<th>Draw an ellipse and then a rectangle overlapping half of its width.</th>
<th></th>
</tr>
</thead>
</table>

Combining Multiple Objects
Select both shapes, right-click, and select \texttt{Shapes > Subtract} from the context menu.

Draw another rectangle and put it over the top half of the ellipse.

Select both shapes, right-click, and select \texttt{Shapes > Subtract} from the context menu.

Draw a small ellipse covering just the lower right corner.

Select both shapes, right-click, and select \texttt{Shapes > Subtract} from the context menu. The knife blade shape is now complete.

To make the handle, draw a rectangle and an ellipse.

Merge the shapes together.

Position the handle on the blade. Select the handle and blade, then group together to create a drawing of the knife.

\section*{Duplication and cross fading}

\subsection*{Duplication}

Duplication makes copies of an object while applying a set of changes (such as color or rotation) to the duplicates.

\begin{figure}
\centering
\includegraphics[width=0.5\textwidth]{DuplicateDialog.png}
\caption{Duplicate dialog}
\end{figure}
To duplicate an object or group of objects:
1) Select an object or group of objects.
2) Go to **Edit > Duplicate** on the main menu bar or use the keyboard shortcut Shift+F3 to open the **Duplicate** dialog (Figure 12).
3) Select the number of copies, placement, enlargement, and the start and end colors for your duplicate copies.
4) Click **OK** and your duplicate copies are created. An example of a duplication is shown in Figure 13. Each duplicate object is a separate object.
5) To group the duplicate objects into one group, see "Grouping objects" on page 4.
6) To combine the duplicate objects into one object, see "Combining objects" on page 5.

The **Duplicate** dialog (Figure 12) has the following options:

- **Number of copies** – enter the number of copies you want to make.
- **Placement** – sets the position and rotation of a duplicate object with respect to the selected object.
  - **X axis**– enter the horizontal distance between the centers of the selected object and the duplicate object. Positive values shift the duplicate object to the right and negative values shift the duplicate object to the left.
  - **Y axis** – enter the vertical distance between the centers of the selected object and the duplicate object. Positive values shift the duplicate object down and negative values shift the duplicate object up.
  - **Angle** – enter the angle (0 to 359 degrees) by which you want to rotate the duplicate object. Positive values rotate the duplicate object in a clockwise direction and negative values in a counterclockwise direction.
- **Enlargement** – sets the size of a duplicate object.
  - **Width** – enter the amount by which you want to enlarge or reduce the width of the duplicate object.
  - **Height** – enter the amount by which you want to enlarge or reduce the height of the duplicate object.
- **Colors** – sets the colors for the selected object and the duplicate object. If you make more than one copy, these colors define the start and end points of a color gradient.
  - **Start** – choose a color for the selected object.
  - **End** – choose a color for the duplicate object. If you are making more than one copy, this color is applied to the last copy.
Cross fading

Cross-fading transforms one object shape into another object shape. The result is a new group of individual objects that includes the start and end objects with the intermediate steps show the transformation from one object shape to another object shape.

To cross-fade two objects:

1) Select two objects and go to Edit > Cross-fading on the main menu bar to open the Cross-fading dialog (Figure 14).
2) Select the number of increments for the transformation.
3) If necessary, select Cross-fade attributes and Same orientation.
4) Click OK to perform the cross-fading. An example of cross-fading is shown in Figure 15. The object created is a group of objects.
5) To ungroup this group of objects so that you can use the individual objects, see “Ungrouping” on page 4.

The Cross-fading dialog (Figure 14) has the following options:
- **Increments** – enter the number of shapes you want between the two selected objects.
- **Cross-fade attributes** – applies cross-fading to the line and fill properties of the selected objects. For example, if the selected objects are filled with different colors, a color transition between the two colors is applied.
- **Same orientation** – applies a smooth transition between the selected objects.
Positioning objects

Arranging objects
When you combine, merge, subtract, or intersect objects, the end result varies depending on which object is at the front and which object is at the back. Each new object that you place on a drawing automatically becomes the front object and all the other objects move backwards in the positioning order. Arranging objects allows you to change the order in which objects are positioned.

First select one or more objects, then click on small triangle to the right of the Arrange icon on the Line and Filling toolbar to open a drop down list of positioning tools (Figure 16). The positioning tools available are as follows:

- **Bring to Front** – brings the selected object to the front of the group.
- **Bring Forward** – brings the selected object forward one step.
- **Send Backward** – sends the selected object one step backward.
- **Send to Back** – sends the selected object to the back of the group.
- **In Front of Object** – moves the selected object in front of another selected object.
- **Behind Object** – moves the selected object behind another selected object.
- **Reverse** – reverses the order of the selected objects. This tool is grayed out if only one object is selected.

![Figure 16: Positioning tools](image)

**Note**
The drop down list of positioning tools can be turned into a floating toolbar by clicking at the bottom of the list and dragging it to a new position on your drawing workspace.

Aligning objects
To make your drawing look more professional, you can align objects with each other. Select one or more objects and click on small triangle to the right of the Align icon on the Line and Filling toolbar to open a drop down list of alignment tools (Figure 17). The alignment available tools are as follows:

- **Left** – aligns the left edges of the selected objects. If only one object is selected, the left edge of the object is aligned to the left page margin.
**Figure 17: Alignment tools**

- **Centered** – horizontally centers the selected objects. If only one object is selected, the center of the object is aligned to the horizontal center of the page.
- **Right** – aligns the right edges of the selected objects. If only one object is selected, the right edge of the object is aligned to the right page margin.
- **Top** – vertically aligns the top edges of the selected objects. If only one object is selected, the top edge of the object is aligned to the upper page margin.
- **Center** – vertically centers the selected objects. If only one object is selected, the center of the object is aligned to the vertical center of the page.
- **Bottom** – vertically aligns the bottom edges of the selected objects. If only one object is selected, the bottom edge of the object is aligned to the lower page margin.

**Note**
The drop down list of alignment tools can be turned into a floating toolbar by clicking at the bottom of the list and dragging it to a new position on your drawing workspace.

**Distributing objects**

Distributing objects allows you to space three or more objects evenly along the horizontal axis or the vertical axis. Objects are distributed using the outermost objects in the selection as base points for spacing.

Select at least three objects, then go to **Modify > Distribution** on the main menu bar or right-click and select **Distribution** from the context menu to open the Distribution dialog (Figure 18). The options available are explained as follows:

- **Horizontal** distribution specifies the horizontal distribution between the selected objects.
  - **None** – does not distribute the objects horizontally.
  - **Left** – distributes the selected objects so that the left edges of the objects are evenly spaced from one another.
  - **Center** – distributes the selected objects so that the horizontal centers of the objects are evenly spaced from one another.
  - **Spacing** – distributes the selected objects horizontally so that the objects are evenly spaced from one another.
  - **Right** – distributes the selected objects so that the right edges of the objects are evenly spaced from one another.
Vertical distribution specifies the vertical distribution between the selected objects.
- None – does not distribute the objects vertically.
- Top – distributes the selected objects so that the top edges of the objects are evenly spaced from one another.
- Center – distributes the selected objects so that the vertical centers of the objects are evenly spaced from one another.
- Spacing – distributes the selected objects vertically so that the objects are evenly spaced from one another.
- Bottom – distributes the selected objects so that the bottom edges of the objects are evenly spaced from one another.