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Introduction

By default, commands and tools used in LibreOffice Draw are grouped in a user interface 
consisting of cascading menus and toolbars. The functions and use of these cascading menus 
and toolbars are described in previous chapters of this user guide.

This chapter describes the user interface variants that are available for LibreOffice Draw. A user 
then has the option to select the user interface that suits their requirements and methods of 
creating drawings in LibreOffice Draw.

Note

When changing the user interface, the variant can be applied only to LibreOffice 
Draw, or applied to all the modules in LibreOffice.

Selecting user interface

To select a user interface variant or switching between the user interface variants:

1) Go to View > User Interface on the Menu bar to open the Select Your Preferred User 
Interface dialog (Figure 1).

2) In UI variants, select one of the variants. An example of the selected variant is shown in 
the Preview box, along with a short description.

3) Click on Apply to Draw to apply the variant selection to LibreOffice Draw only, or click on 
Apply to All to apply the variant to all the LibreOffice modules. The LibreOffice window 
changes to match the selected variant.

4) Click Close to close the dialog.

Figure 1: Select Your Preferred User Interface dialog

Note

If the option Enable experimental features has been selected in the Tools > 
Options > Advanced dialog, several more variants appear in UI variants. Being 
experimental, these variants are not described in this user guide.
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Figure 2: Standard Toolbar user interface in LibreOffice Draw

Note

In all the user interface variants, the Sidebar can be hidden or shown by clicking on 
the Hide/Show button on the left of the Sidebar,

Standard Toolbar UI

The Standard Toolbar user interface is the default view when LibreOffice is installed and the 
Workspace opened for the first time. Figure 2 shows an example of the default Workspace view 
in LibreOffice Draw, which normally consists of the following.

• Menu bar at the top of the Workspace.

• Standard toolbar positioned below the Menu bar.

• Line and Filling toolbar positioned below the Standard toolbar.

• Drawing toolbar positioned vertically on the left of the Workspace.

• Sidebar positioned on the right of the Workspace.

For more information on the Draw Workspace, see Chapter 1, Introducing Draw.

Tabbed UI

The Tabbed user interface provides a familiar interface for users coming from proprietary office 
suites, for example Microsoft Office. This user interface is divided into tabs, where each tab 
displays a set of tools grouped by context. The context changes depending on the object 
selected and the LibreOffice module being used.

It includes a Menu bar, a Tab bar, and tool icons grouped in context that would be normally used 
in LibreOffice Draw. If the tool icons on a tab page do not fit into the width of the Draw window, a 
double chevron >> appears at the right end of the row. Click the double chevron >> to display 
more commands.
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Figure 3: Quick menu options

Figure 4: Icon bar

On Windows and Linux operating systems, the Menu bar can be hidden or displayed by clicking 
on Menubar at the left end of the Tab bar.

On the right of the Tab bar, a Quick menu (≡) (Figure 3) is available giving access to some 
commonly used commands and links. Some of the Quick menu items have submenus, indicated 
by a small triangle ► on the right. The Quick menu is the same for all tabs.

On the left of the Tab bar, an Icon bar (Figure 4) is available giving access to some commonly 
used tools – Menu bar; Open (Ctrl+O); Save (Ctrl+S);Undo (Ctrl+Z); Redo (Ctrl+Y).

The Tabbed user interface can be customized using the Notebookbar page of the Customize 
dialog to show or hide the individual tools on the various tabs. For more information on 
customization of LibreOffice, see the Getting Started Guide and the Writer Guide.

Note

When using the Tabbed user interface, the Draw toolbars are removed from view. If it
is necessary, toolbars can be opened and used by going to View > Toolbars on the 
Menu bar or Quick menu > Toolbars.

Fixed tabs
The fixed tabs in the Tabbed user interface for Draw are described on the following pages. The 
illustrations show the left and right ends of the tabs separately so they are large enough to more 
easily see the commands.

File tab

The File tab (Figure 5) is a fixed tab providing commands to create new documents; open, save, 
print, and close documents; manage templates; export to PDF and EPUB; display document 
properties; add a digital signature; and sign an existing PDF. 

The File tab has two menus (Figures 6 and 7): File and Help. The File tab menu contains the 
same commands as the tools available on the tab. The Help tab menu provides links to a variety 
of resources.
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Figure 5: Tabbed user interface - File tab

Figure 6: File tab menu

Figure 7: Help tab menu
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Home tab

The Home tab (Figure 8) is a fixed tab providing commands to cut, copy, paste, and format text; 
insert common items (for example images, tables, charts); apply, update, and edit drawing styles;
and so on. The Home tab menu (Figure 9) at the right end of the Tab bar provides additional 
commands that are not on the tab.

Figure 8: Tabbed user interface - Home tab

Figure 9: Home tab menu

Insert tab

The Insert tab (Figure 10) is a fixed tab providing commands to insert many commonly used 
items. The Insert tab menu (Figure 11) at the right end of the Tab bar provides some of the same
commands.

Figure 10: Tabbed user interface - Insert tab
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Figure 11: Insert tab menu

Layout tab

The Layout tab (Figure 12) is a fixed tab providing commands to create the drawing page layout.
The Layout tab menu (Figure 13) provides extra commands to create the drawing page layout.

Figure 12: Tabbed user interface - Layout tab
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Figure 13: Layout tab menu

Review tab

The Review tab (Figure 14) is a fixed tab providing commands for spell checking text; inserting 
and deleting review comments; and redaction. The Review tab menu (Figure 15) provides 
additional text editing commands. Some of these commands appear only if Asian or Complex 
Text Layout are selected in Tools > Options > Language Settings > Languages.

Figure 14: Tabbed user interface - Review tab

Figure 15: Review tab menu
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View tab

The View tab (Figure 16) is a fixed tab providing commands for the display of a drawing on 
screen. The View tab menu (Figure 17) provides additional commands relating to the display on 
a drawing on screen.

Figure 16: Tabbed user interface - View tab

Figure 17: View tab 
menu
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Extension tab

The Extension tab (Figure 18) is a fixed tab containing only the command to access the 
Extension Manager allowing the installation of extensions that are compatible for use in 
LibreOffice.

Figure 18: Tabbed user interface - 
Extension tab

Tools tab

The Tools tab (Figure 19) is a fixed tab providing several tools for macros; color replacer; media 
player; and form creation. The Tools tab menu (Figure 20) provides some of the same 
commands, plus extra tools for organizing macros and dialogs; image map; data sources; filter 
settings; extension manager; and options.

Figure 19: Tabbed user interface - Tools tab

Figure 20: Tools tab 
menu
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Additional tabs
Additional tabs appear when an object in Draw is selected and are displayed between the View 
and Extension tabs. The illustrations show the left and right ends of the tabs separately so they 
are large enough to more easily see the commands.

Draw tab

The Draw tab (Figure 21) is only available when a draw object is selected in a drawing. It 
provides commands for editing, transforming, grouping, aligning, and distributing draw objects. 
The Draw tab menu (Figure 22) provides a similar set of commands for editing, transforming and 
converting draw objects.

Figure 21: Tabbed user Interface - Draw tab

Figure 22: Draw tab 
menu
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Image tab

The Image tab (Figure 23) only becomes available when an image is selected in a drawing such 
as a photograph, Fontwork, OLE object, or QR code. It provides commands for working with 
these images, including captions, cropping, borders and area styles and colors, anchors, 
wrapping, positioning, and filtering. The Image tab menu (Figure 24) provides links to dialogs for 
working with images.

Figure 23: Tabbed user interface - Image tab

Figure 24: Image tab menu

Figure 25: Tabbed user interface - Object tab
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Object tab

The Object tab (Figure 25) only becomes available when an object, such as a chart, is selected. 
It provides commands to position, resize, choose colors and borders for the selected object. The 
Object tab menu (Figure 26) provides extra commands to match the type of object selected.

Figure 26: Object tab 
menu

Table tab

The Table tab (Figure 27) only becomes available when a table is selected in a drawing. It 
provides tools to format a table to the drawing requirements. The Table tab menu (Figure 28) 
includes extra commands for editing a table.

Figure 27: Tabbed user interface - Table tab

Figure 28: Table tab menu

Media tab

The Media tab (Figure 29) only becomes available when a media object is selected in a drawing. 
It provides commands for positioning and running an audio or video file. The Media tab menu 
(Figure 30) includes extra commands for editing a media object.

Chapter 12, User Interface Variants | 15



Figure 29: Tabbed user interface - Media tab

Figure 30: Media tab 
menu

Tabbed Compact UI

The Tabbed Compact user interface has the same tabs as the Tabbed user interface, but the 
commands on each tab are arranged as a single row of tools. Some of these tools have 
drop-down menus with extra options. Figure 31 shows an example of the File tab in the Tabbed 
Compact user interface.

The tab menu on the right of the Tabbed Compact user interface provides the same options as 
the tab menus in the Tabbed user interface, see “Tabbed UI” on page 5 for more information.

Figure 31: Tabbed Compact user interface - File tab

Groupedbar Compact UI

The Groupedbar Compact user interface is divided into groups that contain commands 
organized as sets of tools and menus. The tools and menus that are available change to suit the 
type of object that has been selected. Figure 32 shows an example of Groupedbar Compact 
user interface when a draw object is selected.

Clicking on the double chevron >> displays more tools for editing an object. Figure 33 shows an 
example of these tools when a draw object is selected.

The Groupedbar menu (Figure 34) on the right-hand end of this interface provides extra 
commands for working with LibreOffice Draw, including convenient ways to change the user 
interface and access toolbars.
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Figure 32: Example of Groupedbar Compact user interface with draw object selected 

Figure 33: Example of more tools with draw object selected

Figure 34: Groupedbar 
menu

Contextual Single UI

The Contextual Single user interface displays a single toolbar to suit the type of object that has 
been selected. Figure 35 shows an example of Contextual Single user interface when a draw 
object is selected.

Clicking on the double chevron >> displays more tools for editing an object. Figure 36 shows an 
example of these tools when a draw object is selected.

Figure 35: Example of Contextual Single user interface with draw object selected

Figure 36: Example of more tools with draw object selected

Single Toolbar UI & Sidebar UI

When selected, the Single Toolbar and Sidebar user interfaces only show the Menu bar with no
toolbars. However, toolbars can be added to either of these user interfaces by going to View > 
Toolbars on the Menu bar and selecting the required toolbar from the options available. For 
more information on toolbars, see Appendix B, Toolbars in this guide and the Getting Started 
Guide.

Chapter 12, User Interface Variants | 17


	Copyright
	Contributors
	Feedback
	Publication date and software version
	Using LibreOffice on macOS

	Introduction
	Selecting user interface
	Standard Toolbar UI
	Tabbed UI
	Fixed tabs
	File tab
	Home tab
	Insert tab
	Layout tab
	Review tab
	View tab
	Extension tab
	Tools tab

	Additional tabs
	Draw tab
	Image tab
	Object tab
	Table tab
	Media tab


	Tabbed Compact UI
	Groupedbar Compact UI
	Contextual Single UI
	Single Toolbar UI & Sidebar UI

