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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click

Opens context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Opens the Navigator

F11

z+T

Opens Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Introduction
Pictures are often used in presentations as they can convey a large amount of information more
quickly than the written word. You can also give a more professional look to your presentation by
adding a company logo. Also, you may want to use Impress to create a presentation consisting
only of pictures, such as a slideshow of holiday snapshots to share with friends.
This chapter describes how to insert and format pictures.

Inserting pictures
This section describes several ways to insert a picture from an external source into the
presentation. Once the picture has been inserted, it can be formatted extensively as explained later
in this chapter.

Inserting a picture from a file
Inserting a picture from a file is quick and easy. First choose a slide layout, as described in
Chapter 1, Introducing Impress. Most layouts include a set of icons for inserting objects, but you
can insert a picture into any slide.
Whether you are using an AutoLayout for the placement of the picture, or you are just inserting a
picture, follow these steps:
1) Go to Insert > Picture > From file on the menu bar or click on the Insert Picture icon
(Figure 1) if you have inserted a slide and the Insert picture dialog opens (Figure 2).
2) Navigate to the directory containing the desired picture and select the file. LibreOffice
recognizes a large number of image types. If the Preview option is selected, a thumbnail of
the selected file will be displayed in the preview pane on the right.
3) Click Open to place the picture on the current (selected) slide. The picture is now displayed
on the slide with colored resizing handles around it.

Figure 1: Slide showing the placeholder for inserting objects
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Figure 2: Insert picture dialog

Note

The Insert picture dialog has two options Link and Preview. The position of these
options is determined by the operating system, but they are normally in the bottomleft part of the dialog.

Select the Link option to insert the picture as a link to the file rather than embedding the file itself.
In general it is preferable to embed images so that the presentation can be copied for use on other
computers. On some occasions, however, it makes sense to link the image rather than embed it.
These include:

• When the image file is quite large and linking rather than embedding will dramatically
reduce the size of the presentation file.

• When the same image file is used in many presentations. For example, when using the
same background image for all the presentations created.

• When the linked file will be available when loading the presentation. For example, if the
presentation is a slide show of holiday pictures.

Inserting a picture from a scanner
Inserting an image from a scanner is normally a simple process if one or more than one of the
following are valid.

• The scanner software driver has been installed on the computer.
• The scanner is supported by the SANE system if the computer operating system is Linux or
other UNIX-like operating system

• The scanner is TWAIN compatible and the computer is operating Windows or Mac OS.
• The scanner is configured on the computer with LibreOffice software installed.
To insert an image from the scanner:
1) Prepare the image for the scanner and make sure that the scanner is switched on.
2) If more than one scanning device is connected to the computer, select the source from
Insert > Picture > Scan > Select Source.
3) Choose Insert > Picture > Scan > Request.

Inserting pictures
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4) The rest of the procedure depends on the scanner driver and interface that is being used.
Normally, and after a preview scan, you will be required to specify the scan resolution,
selected what to scan on the preview and other parameters for example color or greyscale.
Consult the documentation for the scanner for more information.
5) When the image has been scanned, Impress places it into the selected slide. At this point it
can be edited as any other image.

Inserting a picture from the Gallery
The Gallery contains a collection of images that you can use in a presentation. You can also add
your own images to the Gallery, making it an essential tool for creating presentations quickly and
with a consistent look. The Gallery is available in all components of LibreOffice. For an introduction
to the Gallery, see Getting Started guide, Chapter 11, Graphics, the Gallery, and Fontwork.
Choose Tools > Gallery or click the Gallery icon
on the Drawing toolbar to open the Gallery
dialog (Figure 3). The Gallery displays categories of themes with images stored under each
category.
1) Select a theme category from the left pane and then scroll through the right pane to find a
suitable image.
2) Click on the image and drag it onto the workspace.
3) Release the mouse button and the image will be placed in your slide. If necessary, resize
the image as described in “Resizing a picture” on page 10.

Figure 3. Inserting an image from the Gallery
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Positioning the Gallery
To expand the Gallery, position the pointer over the line that divides it from the top of the
workspace. When the pointer changes to parallel lines with arrows, click and drag downward. The
workspace will resize in response.
By default, the Gallery is docked above the Impress workspace. To undock it, hold down the
Control key and double-click on the upper part of the Gallery next to the View icons. Double-click in
the same area to dock it again (restore it to its position over the workspace).
When the Gallery is docked, to hide it and view the full Impress workspace, click the Hide/Show
button in the middle of the thin bar separating the Gallery from the workspace (highlighted in
Figure 4). The Hide/Show button lets you keep the Gallery open for quick access while you create
your slide show, yet out of the way when you need it to be.

Figure 4: Gallery with Hide/Show selector highlighted

Managing Gallery themes
Graphics in the Gallery are grouped by themes, such as Bullets, Rulers, and 3D Effects. The left
pane of the gallery window lists the available themes. Click on a theme to see its images displayed
in the right pane of the Gallery dialog.
The default themes are read only; no images or graphics can be added to or deleted from these
themes. The default themes are easily recognizable by right-clicking on each category and the only
available option in the pop-up menu is Properties.
In a default installation of LibreOffice, the My themes is the only category that is customizable and
allows you add or delete your own images. You can also create new theme categories where you
can add or delete your own images and this is explained on page 9.

Adding images to My themes
You can only add images to My themes or themes that you have created.
1) Right-click on My themes or the theme name that you created in the list of theme
categories and choose Properties from the pop-up menu to open the Properties dialog
(Figure 5).
2) Click on the Files tab.
3) Click on Find Files to open the Select Path dialog (Figure 6).
4) Browse to the folder that contains the images you want to use.
5) Click on OK to select the files contained in the folder and the Select Path dialog closes.
The list of files contained in the folder now appear in the Theme Properties dialog.
6) Select the files you want to use in My themes and click on Add. The added files will
disappear from the file list and the images will appear in the Gallery.

Managing Gallery themes
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Figure 5. Theme Properties Dialog

Figure 6. Selecting path for new images in themes
7) If you want to add all the files in the list, then click on Add All. All the files will disappear
from the list and the images will appear in the Gallery.
8) Click OK when finished and the Theme Properties dialog will close.

Deleting images from the Gallery
You can only delete images from My themes or themes that you have created.
1) Right-click on the image in the Gallery window.
2) Choose Delete from the pop-up menu.
3) A confirmation message appears, asking if you want to delete this object. Click Yes.
8
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Note

The image is a linked file and is deleted from the Gallery only. The original image file
is not deleted.

All the images in a gallery are linked files. From time to time it is beneficial to update the gallery
theme to make sure that all the files are still there. To do so, right-click on the theme where you
added at least one file and then select Update from the pop-up menu.

Adding a new theme to the Gallery
You can add a new theme to the list of theme categories in the gallery as follows:
1) Click the New Theme button above the list of theme categories and the Properties dialog
opens.
2) Click the General tab and type a name for the new theme in the text box (Figure 7).
3) Click the Files tab and follow Steps 3 through to 8 in “Adding images to My themes” on
page 7.
4) The new theme will now be displayed in the list of theme categories in the Gallery.

Figure 7. Adding new theme to the Gallery

Note

If you wish, you can rename this new theme by manually by right-clicking the theme
name and selecting Rename.

Formatting pictures
This section discusses the formatting of pictures inserted with one of the methods explained in
“Inserting pictures” on page 4.

Moving a picture
1) Click on the picture to select it and colored selection handles are displayed.
Formatting pictures

9

2) If necessary, move the mouse cursor over the picture until it changes shape. The cursor
shape depends on the computer operating system, for example a four headed arrow or a
hand.
3) Click and drag the picture to the desired position.
4) Release the mouse button.
For a more accurate placement of a picture, use the Position and Size dialog described in Chapter
6, Formatting Graphic Objects.

Resizing a picture
1) Click the picture to show the colored selection handles.
2) Position the cursor over one of the colored selection handles. The cursor changes shape
giving a graphical representation of the direction of the resizing.
3) Click and drag to resize the picture.
4) Release the mouse button when satisfied with the new size.
For more accurate resizing of a picture, use the Position and Size dialog described in Chapter 6,
Formatting Graphic Objects.

Note

Tip

Caution

The corner handles resize both the width and the height of the graphic object
simultaneously, while the other four handles only resize one dimension at a time.

To retain the original proportions of the graphic, Shift+click one of the corner handles,
then drag. Make sure to release the mouse button before releasing the Shift key.

Be aware that re-sizing a bit-mapped (raster) image will adversely affect the
resolution, causing some degree of blurring. It is better to use a specialized graphics
manipulation program to correctly scale the picture to the desired size before inserting
it into your presentation. We recommend you use a tool such as Gimp
(http://www.gimp.org/).

Rotating a picture
As with the position of the image on the page, rotation of a picture can be done manually or using a
dedicated dialog. The Rotation dialog is described in Chapter 6, Formatting Graphic Objects.
Rotate a picture manually as follows:
1) Select the picture to display the colored selection handles.
2) Click the Rotate icon
on the Drawing toolbar and the selection handles change color
(Figure 8). The color change will depend on the computer operating system and how the
computer has been setup.

Note
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The icons representing the functions in the toolbars depend on the computer
operating system used and how the computer has been setup, or whether LibreOffice
has been customized or not. When in doubt, hover the mouse over the icons and
wait for the tooltip to appear showing the name of the button.
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Figure 8: Rotating pictures
3) A circle or circle with crosshairs (depending on computer system) appears in the centre of
the picture indicating the rotation point. The center of the picture is the normal rotation
point, but this rotation point can be moved to change the rotation center to a corner or to a
point outside the picture. To do this, click on the rotation point and drag it to the desired
position before applying the rotation.
4) The selection handles in each corner are the rotation handles and the cursor shape will
change when moved over one of them. Click the mouse and move in the direction in which
you want to rotate the picture.
5) When satisfied, release the mouse button.

Tip

To restrict the rotation angles to multiples of 15 degrees, press the Shift key while
rotating the graphic. This is very handy to rotate pictures of right angles, for example
from portrait to landscape or from landscape to portrait.

Formatting using the Picture toolbar
When a picture is selected, the Picture toolbar becomes available. This toolbar provides a number
of formatting options which are described in this section. If the picture toolbar does not appear
when an image is selected, display it by selecting View > Toolbars > Picture from the menu bar
(Figure 9).

Figure 9: Picture toolbar

Applying filters
Use the filter icon
on the Picture toolbar to apply various filters to the selected picture. The
best way to judge if a filter works for your picture is to try it. To apply a filter:
1) Select the pictures so that the colored selection handles are displayed.

Formatting pictures
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2) Click on the filter icon
to show the different filters that are available. Table 1 describes
briefly each of the available graphic filters and their effects. See the Draw Guide for more
information and examples of the effects.
3) Select the filter you wish to apply. To show the name of the filter, hover the cursor over the
icon and wait for the tooltip to appear.
4) If you are not satisfied with the effect obtained or you want to try a different one, before
doing anything else click the Undo icon in main toolbar or select Edit > Undo: Bitmap
Graphic Filter from the menu bar or press Control+Z.
Table 1: Graphic filters and their effects
Icon

Name

Effect

Invert

Inverts the color values of a color image, or the brightness values
of a grayscale image.

Smooth

Softens the contrast of an image.

Sharpen

Increases the contrast of an image.

Remove noise

Removes single pixels from an image.

Solarization

Mimics the effects of too much light in a picture. A further dialog
opens to adjust the parameters.

Aging

Simulates the effects of time on a picture. Can be applied several
times. A further dialog will open to adjust the aging level.

Posterize

Makes a picture appear like a painting by reducing the number of
colors used.

Pop Art

Modifies the picture dramatically.

Charcoal sketch

Displays the image as a charcoal sketch.

Relief

A dialog is displayed to adjust the light source that in turn will
create the shadow and hence the relief effect.

Mosaic

Joins groups of pixels into a single area of one color.

Changing graphics mode
Use the graphics mode drop-down list
in the Picture toolbar (Figure 9) to change the
mode of the image. Choose between the following:

• Default: no changes to the graphic object.
• Grayscale: the image is converted to scales of gray.
• Black/White: each pixel of the image is converted to black or white depending on the
brightness value.

• Watermark: adjusts the brightness of the image making it suitable to be used as a
watermark. For more information on inserting watermarks in the presentation, refer to
Chapter 2, Using Slide Masters, Styles, and Templates.
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Adjusting the color
Clicking on the color icon
(Figure 10).

in the Picture toolbar (Figure 9) opens the color adjustment dialog

Figure 10: Color Adjustment dialog
Use this dialog to modify the individual color components of the image (red, green, blue) as well as
the brightness, contrast, and gamma of the image. If the result is not satisfactory, press Control+Z
to restore the default values.
Increasing the gamma value of a picture makes it more suitable to be used as a background or
watermark as it will interfere less with a dark text.

Setting the object transparency
Modify the percentage value in the Transparency box
on the Picture toolbar (Figure 9)
to make the image more transparent. Note that this is different from the transparency settings for a
line or a shape (described in Chapter 5 Managing Graphic Objects). As with the gamma value,
increasing the transparency of a picture makes the picture blend more smoothly in the background
making the overlay text easier to read.

Adjusting the line, area and shadow settings
These settings are not very commonly used for images, with the exception of the shadow setting,
which applies a shadow to the image.

Cropping pictures
Impress provides two ways to crop a picture: interactively or using a dialog. The interactive method
is easier to use, but the dialog provides more precise control. You can use both methods: first
cropping interactively, then use the dialog to fine tune the result.
To crop a selected picture interactively, click the Crop icon
set of crop marks appears around the picture (Figure 11).

on the Picture toolbar (Figure 9). A

Figure 11: Interactive crop marks
When you place the cursor over any of the crop marks, the cursor changes shape. Drag the mark
to crop the picture. Click outside the picture to deactivate cropping mode.
Press the Shift button while working on the crop marks to produce the following effects:

• For a corner mark, the two sides of the picture forming the corner are cropped
proportionally with the picture anchored to the opposite corner mark.

Formatting pictures
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Figure 12: Crop dialog options available when cropping a picture

• For a side mark, both dimensions are changed proportionally with the image anchored to
the opposite side mark.
The interactive crop mode operates in Keep Scale mode (see below).
To crop using the dialog, right-click a selected picture and choose Crop Picture or choose Format
> Crop Picture from the menu bar. The Crop dialog (Figure 12) has the following options:

• Keep scale/Keep image size: when Keep scale is selected (default), cropping the image
does not alter the scale of the picture. When Keep image size is selected, cropping
produces enlargement (for positive cropping values), shrinking (for negative cropping
values), or distortion of the image so that the image size remains constant.

• Left, Right, Top, and Bottom: the function of these boxes changes according to the choice
made between Keep scale and Keep image size. In both cases, when a value is entered in
one of these boxes, the image is cropped by that amount. For example, a value of 3cm in
the Left box will cut 3cm from the left side of the picture.
When Keep scale is selected, the size of the image also changes, so in this example the
width will be reduced by 3 cm. If Keep image size is selected instead, the remaining part of
the image is enlarged (positive values for cropping) or shrunk (negative values for
cropping) so that the width and height of the image remains unchanged.
Note that the Width and Height fields change as you enter the values when in this mode.
Use the thumbnail next to these fields to determine the correct amount by which to crop.

• Scale Width and Height: specifies in percentages the scaling of the picture. The size of
the image changes accordingly.

• Image size: specifies the size of the image in your preferred unit of measurement. The
image enlarges or shrinks accordingly.

• Original size: when clicked, restores the original image size.

Deleting a picture
1) Click on the picture and the colored selection handles are displayed.
2) Press Delete.
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Creating an image map
An image map defines areas of the image (called hotspots) associated with a URL (a web address
or a file on the computer). Hotspots are the graphic equivalent of text hyperlinks. Clicking on a
hotspot causes Impress to open the linked page in the appropriate program (for example, default
browser for HTML pages; LibreOffice Writer for .ODT files; PDF viewer for PDF files).
You can create hotspots of various shapes, such as hotspots: rectangles, ellipses, and polygons.
You can also include several hotspots in the same image. When you click on a hotspot, the URL
opens in a browser window or frame that you have specified. You can also specify the text that
appears when your mouse cursor hovers over the hotspot.

Figure 13: Image Map Editor dialog for creating hotspots
To use the image map tool to create or edit a hotspot:
1) Select the picture on a slide where hotspots are going to be defined.
2) Go to Edit > ImageMap on the main menu bar and the ImageMap Editor dialog opens
(Figure 13). The main part of the dialog shows the image on which the hotspots will be
defined.
3) Active hotspots are indicated by a colored border, while inactive hotspots are indicated by a
black or grayed out border.
4) Use the tools at the top of the dialog and the fields to define hotspots and their links.
5) Click the Apply icon

to apply the settings.

6) When done, click the Save icon
to save the image map to a file, then click the X in the
upper right corner to close the dialog.
The top part of the dialog, from left to right, contains the following tools:

• Apply icon: click this icon to apply any changes made.
• Open, Save, and Select icons.

Creating an image map
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• Rectangle, Ellipse, Polygon and FreeForm Polygon tools for drawing a hotspot shape.
These tools work in exactly the same way as the corresponding tools in the Drawing
toolbar (described in Chapter 5 Managing Graphic Objects).

• Edit, Move, Insert, Delete Points are advanced editing tools to manipulate the shape of a
polygon hotspot. Select Edit Points tool to activate the other tools.

• Active icon: toggles the status of the hotspot activating a selected hotspot or deactivating it
if active.

• Undo and Redo icons.
• Macro: associates a macro with the hotspot instead of a hyperlink.
• Properties: sets the hyperlink properties and adds the Name attribute to the hyperlink.
Below the toolbar are fields which specify the properties of a hotspot:

• Address: the URL address that points to a hyperlink. You can also point to an anchor in a
document such as a specific slide number; to do this, write the address in this format:
file:///<path>/document_name#anchor_name

• Text: enter the text that will be displayed when the mouse is moved over the hotspot.
• Frame: where the target of the hyperlink will open: _blank (opens in a new browser
window), _self (default selection and opens in an active browser window), _top or _parent.

Tip
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The value _self for the target frame will work on the vast majority of the occasions. It
is not recommended to use the other values unless absolutely necessary.
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