Chapter 14
Customizing LibreOffice
Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this document. For a detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open the Styles deck in the Sidebar</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/
Contents

Copyright............................................................................................................................ 2
Contributors.......................................................................................................................... 2
Feedback.............................................................................................................................. 2
Publication date and software version.............................................................................. 2
Using LibreOffice on macOS............................................................................................ 2

Introduction....................................................................................................................... 4

Customizing menu content................................................................................................. 4
  Modifying an existing menu.............................................................................................. 5
  Creating a new menu....................................................................................................... 5
  Creating an accelerator.................................................................................................... 6

Customizing toolbars.......................................................................................................... 7
  Modifying existing toolbars............................................................................................. 8
  Creating a new toolbar.................................................................................................... 8
  Choosing icons for toolbar commands.......................................................................... 9

Customizing the Tabbed interface....................................................................................... 9

Assigning shortcut keys.................................................................................................... 10
  Saving changes to a file.................................................................................................. 11
  Loading a saved keyboard configuration........................................................................ 12
  Resetting the shortcut keys............................................................................................ 12

Assigning macros to events............................................................................................... 12

Adding functionality with extensions............................................................................... 12
  Installing extensions..................................................................................................... 12
  Updating extensions....................................................................................................... 12
  Removing and disabling extensions.............................................................................. 13

Adding custom colors....................................................................................................... 14

Adding fonts...................................................................................................................... 15
  Finding free-licensed fonts............................................................................................. 15

User interface variants...................................................................................................... 15
  Selecting the user interface............................................................................................ 16
  Standard interfaces........................................................................................................ 16
  Tabbed interface............................................................................................................ 17
    Icon bar......................................................................................................................... 17
    Quick menu.................................................................................................................. 18
    Example: File tab in Writer.......................................................................................... 18
  Tabbed Compact interface.............................................................................................. 19
  Groupedbar Compact interface...................................................................................... 20
  Contextual Single interface............................................................................................ 20
Introduction

This chapter describes some common customizations that you may wish to carry out.

You can customize menus, toolbars, keyboard shortcuts, and the tabbed interface in LibreOffice, add new menus and toolbars, assign macros to events, and choose among several user interface variants.

Other customizations are made easy by extensions that you can install from the LibreOffice website or from other providers; see “Adding functionality with extensions” on page 12.

Note

Customized menus and toolbars can be saved in a template. To do so, first save them in a document and then save the document as a template as described in Chapter 3, Using Styles and Templates.

Customizing menu content

You can add and rearrange menus on the Menu bar or context (right-click) menus; add, rearrange, and remove commands on menus, and make other changes.

To customize menus, choose Tools > Customize on the Menu bar. On the Customize dialog, go to the Menus tab (Figure 1) or the Context Menus tab.

Figure 1: The Menus tab of the Customize dialog
Modifying an existing menu

In this example, we are customizing a menu in the Calc component of LibreOffice.

1) In the Scope drop-down list in the upper right of the Customize dialog, choose whether to save this changed menu for Calc or for a selected document.

2) In the Target drop-down list, select the menu that you want to customize. The list includes all the submenus as well as the main menus. The commands on the selected menu are shown in the Assigned Commands list.

3) To add a command to the selected menu, click on a command in the Available Commands list and then click the large right arrow. You can narrow the search by using the Search box on the top left or selecting the Category in the drop-down list. Use the up and down arrows on the far right-hand side to move the command into the position where you want it in the list.

4) To remove a command from the selected menu, click on it in the Assigned Commands list and then click the large left arrow.

5) To insert a separator or submenu, select the item directly before where you want the inserted item to appear, and use the commands in the Insert drop-down list.

6) To rename a menu item, select it in the Assigned Commands list and choose Rename in the Modify drop-down list.

7) When you have finished making all your changes, click OK to save them.

Creating a new menu

On the Menus tab of the Customize dialog, click the button next to Target and select Add in the drop-down list (Figure 4), to display the New Menu dialog (Figure 5).

1) Type a name for the new menu in the Menu name box.

2) Use the up and down arrow buttons to move the new menu into the required position on the Menu bar.

3) Click OK to save and return to the Customize dialog.

The new menu now appears on the list of menus in the Customize dialog. It will appear on the Menu bar itself after you save your customizations.

After creating a new menu, you need to add some commands to it, as described above for modifying a menu.
Creating an accelerator

You can allocate a letter in a custom menu’s name to be used as a keyboard shortcut. That letter will become underlined. When you press Alt+that letter, the corresponding menu or command will be invoked. Existing submenus can also be edited to change the letter which is used to select them using the keyboard when the menu is open.

To create an accelerator:

1) Select a menu item in the Assigned Commands list on the Customize dialog.
2) Click the Modify button and select Rename.
3) Add a tilde (~) in front of the letter to use as an accelerator.
4) Click OK to save the change.

If for example you put a tilde before the “A” in a menu item Art, the “A” would now be underlined. Press Alt+A and either the Art submenu will open or the Art button will be actioned (as appropriate).
Caution

When assigning an accelerator, be careful not to use a letter that is already assigned to a menu or command associated with a menu item. The same letter-key combinations can be used for commands associated with different menu items but not for those associated with the same menu or menu item.

Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and locking the position of a docked toolbar (as described in Chapter 1, Introducing LibreOffice), and adding or deleting icons (commands) in the list of those available on a toolbar. You can also create new toolbars. This section describes how to create new toolbars and add or delete icons on existing toolbars.

To get to the Toolbars tab of the Customize dialog (Figure 6), do any of the following:

- On the toolbar, right-click on the toolbar and choose Customize Toolbar.
- Choose View > Toolbars > Customize on the Menu bar.
- Choose Tools > Customize on the Menu bar and click on the Toolbars tab.

![Customize dialog](image)

Figure 6: The Toolbars tab of the Calc Customize dialog
Modifying existing toolbars

The procedures for creating and modifying a toolbar are similar to those for menus. In this example, we are customizing a toolbar in the Calc component of LibreOffice.

To modify an existing toolbar:

1) In the Scope drop-down list on the upper right of the Customize dialog, choose whether to save this changed toolbar for Calc or for a selected document.

2) In the Target drop-down list, select the toolbar that you want to customize. The current toolbar content is displayed in the Assigned Commands list.

3) Select a command in the Available Commands list on the left. You can narrow your search by using the Search box on the top left or choosing a category in the drop-down list just below.

4) Click on the large right arrow to add the selected command to the Assigned Commands list for the toolbar (on the right). Use the up and down arrows in the far right to position the command in the toolbar.

5) To remove a command from a toolbar, select it in the Assigned Commands list on the right and click the large left arrow.

6) To show or hide a command assigned to a toolbar, mark or clear the checkbox by its icon in the Assigned Commands list on the right.

7) To insert a separator, select the item directly before where you want the separator to appear, and use the command in the Insert drop-down list.

8) To rename a toolbar item, select it in the Assigned Commands list and choose Rename in the Modify drop-down list.

9) When you have finished making all your changes, click OK to save them.

Creating a new toolbar

To create a new toolbar:

1) Choose Tools > Customize on the Menu bar.

2) On the Toolbars page of the Customize dialog, click the button next to Target and select Add in the list, to display the Name dialog (Figure 7).

3) On the Name dialog, type the new toolbar’s name and choose in the Save In drop-down list where to save this new toolbar: for the application (for example, Writer) or for a selected document.

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new toolbar, you need to add some commands to it, as described above.

![Figure 7: Naming a new toolbar](image-url)
Choosing icons for toolbar commands

Toolbar buttons usually have icons, not words, on them, but not all of the commands have associated icons.

To choose an icon for a command, select the command and click Modify > Change Icon. On the Change Icon dialog (Figure 8), scroll through the available icons, select one, and click OK to assign it to the command.

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the Import button on the Change Icon dialog. For best quality, custom icons should be 24 x 24 pixels in size; other sizes will be scaled automatically.

![Change Icon dialog](image)

Figure 8: Change Icon dialog

Customizing the Tabbed interface

By default, LibreOffice’s commands are grouped in cascading menus and in toolbars filled with icons. In addition, LibreOffice provides other user interface variants, displaying contextual groups of commands and contents. (See “User interface variants” on page 15.)

One of the variants is Tabbed. In this variant, the area at the top of the workspace is divided into tabs, where each tab displays a set of icons grouped by context. The context can change depending on the object selected in the document, for example a table or an image.

Use the checkboxes on the Notebookbar tab of the Customize dialog (Figure 9) to show and hide the individual options on the various tabs that are provided in the Tabbed user interface. This is the only variant that can be customized.

Use the Reset button to reset the Tabbed configuration to the default settings.
Assigning shortcut keys

In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your own. You can assign shortcuts to standard LibreOffice functions or your own macros and save them for use with the entire LibreOffice suite.

Caution

Avoid reassigning your operating system’s predefined shortcut keys.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.

1) Select Tools > Customize and then click the Keyboard tab (Figure 10).
2) To have the shortcut key assignment available in all components of LibreOffice, select LibreOffice in the upper right section of the dialog.
3) Next select the required function in the Category and Function lists.
4) Now select the desired shortcut keys in the Shortcut Keys list and click the Modify button.
5) Click OK to accept the change. Now the chosen shortcut keys will execute the function chosen in step 3 above whenever they are pressed.
Note

All existing shortcut keys for the currently selected function are listed in the Keys selection box. If the Keys list is empty, it indicates that the chosen key combination is free for use. If it were not, and you wanted to reassign a shortcut key combination that is already in use, you must first delete the existing key.

Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1, F6, and F10 in Figure 10, are not available for reassignment.

Figure 10: Customizing a keyboard shortcut

Saving changes to a file

Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a later time, thus permitting you to create and apply different configurations as the need arises, or to create a standard keyboard configuration file to be distributed among many users. To save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button at the right side of the Customize dialog (Figure 10).

2) In the Save Keyboard Configuration dialog, enter a name for the keyboard configuration file in the File name box, or select an existing file in the list. If you need to, browse to find a file from another location (the file extension is .cfg for Configuration).

3) Click Save. A confirmation dialog appears if you are about to overwrite an existing file, otherwise there will be no feedback and the file will be saved.
Loading a saved keyboard configuration

To load a saved keyboard configuration file and replace your existing configuration, click the Load button at the right side of the Customize dialog, and then select the configuration file in the Load Keyboard Configuration dialog.

Resetting the shortcut keys

To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom right of the Customize dialog. Use this feature carefully; no confirmation dialog will be displayed.

Assigning macros to events

In LibreOffice, when something happens, we say that an event occurred. For example, a document was opened, a key was pressed, or the mouse moved. You can associate a macro with an event, so the macro is run when the event occurs. A common use is to assign the “open document” event to run a macro that performs certain setup tasks for the document.

To associate a macro with an event, use the Events tab of the Customize dialog. For more information, see Chapter 13, Getting Started with Macros.

Adding functionality with extensions

An extension is a program that can be installed into LibreOffice to add new functionality and improve your productivity. Template sets, spelling dictionaries, clipart galleries, macros, and dialog libraries can be packaged as LibreOffice extensions.

Several extensions are bundled with LibreOffice and are installed with the program. These can only be removed by changing the installation options. Others can be downloaded from various websites. The official extension repository is located at https://extensions.libreoffice.org/. These extensions are free of charge.

Some extensions from other sources are free of charge; others are available for a fee. Check the descriptions to see what licenses and fees apply to the ones that interest you.

Installing extensions

To install an extension that is listed in the repository, follow these steps:

1) In LibreOffice, select Tools > Extension Manager on the Menu bar. In the Extension Manager dialog (Figure 11), click the Get more extensions online link.

2) A browser window will open. Find the extension you want and download it to your computer.

3) After the extension is downloaded and saved, return to the Extension Manager dialog and click Add. Find and select the extension you want to install and click Open. The extension begins installing. You may be asked to accept a license agreement.

4) When the installation is complete, the extension is listed in the Extension Manager dialog.

To install an extension that is not listed in the repository, download the extension, then continue with step 3 above.

Updating extensions

Click the Check for Updates button on the Extension Manager dialog to check for updates to installed extensions.
Removing and disabling extensions

To remove (uninstall) an extension that you installed, select the extension in the main window of the Extension Manager dialog and click the Remove button.

To disable an extension without removing (uninstalling) it, select the extension in the Extension Manager dialog and click the Disable button, which then changes to Enable.

![Figure 11: Extension Manager dialog](image)

**Tip**

Extensions can be installed from some other places in LibreOffice, such as the Gallery on the Sidebar, the Templates dialog, the Language Settings > Writing Aids page of the Tools > Options dialog and the Icon Style section in the View page of the Tools > Options dialog. In each of these places you will find a small button leading to a filtered view of the items in the Extensions dialog.

**Note**

In some cases, the Remove and Disable buttons may be unavailable, for example when you have selected one of the extensions that was bundled with your LibreOffice installation.
Adding custom colors

To add custom colors to a color palette, for example to exactly match a corporate color scheme, follow this procedure:

1) Insert any drawing object, such as a square, into any document.
2) Right-click on the object and choose Area in the context menu.
3) Go to the Color tab (Figure 12). In the Palette drop-down list in the Colors area, choose which palette you wish to add the new color to. Under New, define the new color using RGB or Hex notation, or click the Pick button to select the color on the Pick a Color dialog (Figure 13).
4) Click Add in the lower left corner, enter a name for the new color in the pop-up dialog, and click OK to save.
5) Delete the drawing object from the document, if it is not needed.

![Figure 12: Defining a new color](image-url)
Adding fonts

LibreOffice supports PostScript (.pfb), TrueType (.ttf), and OpenType (.otf) font file formats. Other font formats exist, and may be supported by your operating system, but these formats may be limited in selection and quality.

If you have administration privileges, you can install additional fonts through your operating system; they will then be available for use by all components of LibreOffice.

Finding free-licensed fonts

In addition to proprietary fonts from sources like Adobe, hundreds of free-licensed fonts are available. You can use, share, and edit free-licensed fonts as you please. Most are available at no cost. Many are clones or near-variations of classic fonts, but some are original fonts.

Many Linux distributions include a few free-licensed fonts in their package repositories. Other places where you can find free-licensed fonts include The League of Movable Type (theleagueofmoveabletype.com), Open Font Library (fontlibrary.org).

User interface variants

By default, commands in LibreOffice are grouped in cascading menus and in toolbars filled with icons—the standard user interface described in Chapter 1. These menus and toolbars are described in the chapters that discuss the related tasks and functions.

In addition, LibreOffice Writer, Calc, Draw, and Impress provide other user interface variants, displaying contextual groups of commands and contents. This section describes these user interface variants and provides a quick reference to the location of the tools and functions when using each of the variants. For details, see the user guides for the LibreOffice components.
Selecting the user interface

When you set up LibreOffice, you can choose one of the user interfaces, and you can switch between them and the standard interface at any time.

1) Choose View > User Interface on the Menu bar.
2) On the Select Your Preferred User Interface dialog (Figure 14), choose one of the variants on the left. An example of the variant is shown in the Preview box on the right, along with a short description.
3) Choose the relevant button to apply your selection to all components of LibreOffice, or only to the open component. The window changes to match your selection.
4) Click Close to close the dialog.

![Figure 14: Selecting a user interface](image)

If you have activated experimental features (Tools > Options > Advanced), several more choices may appear on the left-hand side. These choices are not described here.

Standard interfaces

Three of the user interface choices in Figure 14 are described in Chapter 1, Introducing LibreOffice.

- **Standard toolbar**
  Classic mode with two visible toolbars: standard and formatting. The sidebar shows only its tabs.

- **Single toolbar**
  Only one toolbar with frequently used features. The sidebar shows only its Show button.

- **Sidebar**
  The sidebar is fully opened and only one toolbar (Formatting) is showing.

The elements on each of these standards user interfaces can be modified using the View menu on the Menu bar.
Tabbed interface

The Tabbed interface (Figure 15) provides a familiar interface for users coming from proprietary office suites such as Microsoft Office. It includes a Menu bar, an Icon bar, a Tab bar, icons for the active tab, one or more tab-specific menus, and a Quick Menu. On Windows and Linux, the Menu bar can be hidden or displayed by clicking on the Menu Bar icon in the Icon bar (Figure 17).

Figure 15: Tabbed Interface with Menu bar hidden

The Tabbed interface includes fixed tabs and additional tabs that vary depending on the item selected (for example, a table or image).

Each tab displays a set of icons grouped by context. The context can change depending on the location of the cursor or the item selected. Each tab also includes one or more tab-specific drop-down menus at the right-hand end. The Quick Menu is the same for all tabs.

The Tabbed interface can be customized using the Notebookbar tab of the Customize dialog to show and hide the individual icons on the various tabs. See “Customizing the Tabbed interface” on page 9 for more information.

If the icons on a tab do not fit into the width of the LibreOffice window, >> appears at the end of the row. Click it to display the other commands (Figure 16).

Figure 16: Displaying more commands on a tab

<table>
<thead>
<tr>
<th>Icon bar</th>
<th>Active tab</th>
<th>Icons on active tab</th>
<th>Tabs</th>
<th>Tab menus</th>
<th>Quick menu</th>
</tr>
</thead>
</table>

Icon bar

The icon bar (Figure 17) is located at the top left of the tabs. The sixth icon varies between components; the illustration shows it for Writer.

Figure 17: Tabs – Icon bar

1 Menu bar – Show / Hide the menu bar.  
2 Open (Ctrl+O) – Open a file browser.  
3 Save (Ctrl+S) – Save the open file.  
4 Undo (Ctrl+Z) – Undo the last action.  
5 Redo (Ctrl+Y) – Redo the last undone action.  
6 Print (Ctrl+P) – Open the Print dialog.
Quick menu

At the right-hand end of the tab bar is a Quick menu (Figure 18) containing some commonly used commands and links. Some of the Quick menu items have submenus, indicated by arrows on the right.

![Quick menu](image)

*Figure 18: Quick menu*

Example: File tab in Writer

The **File** tab (Figure 19) includes commands to create new documents; open, save, print, and close documents; manage templates; export to PDF and EPUB; display document properties; add a digital signature; and sign an existing PDF.

The illustration shows the left and right ends of the tabs separately so they are large enough to more easily see the commands.

![Tabbed Interface - File tab in Writer](image)

*Figure 19: Tabbed Interface – File tab in Writer*

The File tab has two menus (Figure 20): **File** and **Help**. The **File** menu contains the same commands as the icons on the tab. The **Help** menu provides links to a variety of resources.
Tabbed Compact interface

The Tabbed Compact interface has the same tabs as the Tabbed interface, but the commands on each tab are arranged in a single row of icons, many with drop-down menus of choices.
Groupedbar Compact interface

The Groupedbar Compact interface (Figure 22) is divided into groups that contain commands organized as sets of icons and menus.

![Groupedbar Compact interface example in Writer](image)

**Figure 22: Groupedbar Compact interface example in Writer**

The Groupedbar menu (Figure 23) on the right-hand end of this interface provides a subset of commands, including a convenient way to change the user interface.

![Groupedbar menu in Writer](image)

**Figure 23: Groupedbar menu in Writer**

Contextual Single interface

The Contextual Single interface displays a standard Menu bar and a single toolbar with context-dependent content.