Writer 6.0 Guide

Chapter 8
Introduction to Styles

Copyright
This document is Copyright © 2018 by the LibreOffice Documentation Team. Contributors are listed
below. You may distribute it and/or modify it under the terms of either the GNU General Public
License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons
Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.
All trademarks within this guide belong to their legitimate owners.

Contributors
Jean Hollis Weber

Bruce Byfield

Gillian Pollack

Acknowledgments
This chapter is updated from previous versions of the LibreOffice Writer Guide. Contributors to
earlier versions are:
Jean Hollis Weber

John A Smith

Ron Faile Jr.

This chapter is adapted from Chapter 6 of the OpenOffice.org 3.3 Writer Guide. The contributors to
that chapter are:
Jean Hollis Weber
Peter Hillier-Brook
Janet Swisher

Agnes Belzunce
Peter Kupfer
Michele Zarri

Daniel Carrera
Gary Schnabl

Feedback
Please direct any comments or suggestions about this document to the Documentation Team’s
mailing list: documentation@global.libreoffice.org

Note
Everything you send to a mailing list, including your email address and any other
personal information that is written in the message, is publicly archived and cannot be
deleted.

Publication date and software version
Published July 2018. Based on LibreOffice 6.0.

Note for macOS users
Some keystrokes and menu items are different on macOS from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this book. For a more
detailed list, see the application Help.
Windows or Linux

macOS equivalent

Effect

Tools > Options
menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click and/or right-click
depending on computer setup

Open a context menu

Ctrl (Control)

⌘ ( (Command)

Used with other keys

F5

Shift+⌘ (+F5

Open the Navigator

F11

⌘ (+T

Open the sidebar Styles and Formatting deck

Documentation for LibreOffice is available at http://documentation.libreoffice.org/en/

Contents
Copyright..............................................................................................................................2
Contributors................................................................................................................................. 2
Acknowledgments........................................................................................................................ 2
Feedback..................................................................................................................................... 2
Publication date and software version.........................................................................................2
Note for macOS users................................................................................................................. 2

What are styles?...................................................................................................................5
Why use styles?........................................................................................................................... 5
Style categories........................................................................................................................... 5

The Styles deck in the sidebar...........................................................................................5
Filtering the visible styles............................................................................................................. 6

Applying styles.....................................................................................................................6
Applying paragraph styles............................................................................................................ 6
Using the Styles and Formatting deck.....................................................................................7
Using the Styles menu............................................................................................................7
Using the Set Paragraph Style list...........................................................................................7
Using Fill Format mode........................................................................................................... 8
Using keyboard shortcuts........................................................................................................8
Applying character styles.............................................................................................................8
Using the Styles and Formatting deck.....................................................................................9
Removing or replacing character styles..................................................................................9
Applying frame styles................................................................................................................... 9
Applying page styles....................................................................................................................9
Example: Page with special formatting..................................................................................11
Example: A book chapter sequence of pages........................................................................11
Applying list styles..................................................................................................................... 15
Restarting or continuing the numbering.................................................................................15
Applying table styles.................................................................................................................. 16
Assigning styles to shortcut keys...............................................................................................16

Creating and modifying styles..........................................................................................16
Using New Style from Selection, Update Style, and Load Styles...............................................16
New Style from Selection......................................................................................................17
Update Style (from a selection).............................................................................................17
Load Styles (from a template or document)..........................................................................18
Drag-and-drop a selection to create a style...............................................................................19
Changing a style using the Style dialog.....................................................................................19
Using AutoUpdate...................................................................................................................... 19

Deleting styles....................................................................................................................19
Example: creating and modifying paragraph styles......................................................20
Creating the Poem paragraph style...........................................................................................20
Creating the Poem Heading style..............................................................................................21
Changing the formatting of your styles.......................................................................................22

Using paragraph styles to define a hierarchy of headings...........................................23
Choosing paragraph styles for heading levels...........................................................................23
Chapter 8 Introduction to Styles | 3

Assigning outline levels to other styles......................................................................................23
Setting up heading numbering...................................................................................................24
Setting up the indentation of headings.......................................................................................26

4| Chapter 8 Introduction to Styles

What are styles?
Most people are used to writing documents according to physical attributes. For example, you
might specify the font family, font size, and weight (for example: Helvetica 12pt, bold). In contrast,
styles are logical attributes. For example, you can define a set of font characteristics and call it
“Title” or “Heading 1”. In other words, styles mean that you shift the emphasis from what the text
looks like to what the text is.

Why use styles?
Styles help improve consistency in a document. They also make major formatting changes easy.
For example, you might decide to change the indentation of all paragraphs or change the font of all
titles. For a long document, this simple task could be prohibitive. Styles make the task easy. In
addition, Writer uses styles for other purposes, such as compiling a table of contents; see “Using
paragraph styles to define a hierarchy of headings” on page 23.

Style categories
LibreOffice Writer has six style categories:
•

Paragraph styles affect entire paragraphs and are also used for purposes such as
compiling a table of contents.

•

Character styles affect a block of text inside a paragraph; they provide exceptions to
paragraph styles.

•

Page styles affect page formatting (page size, margin, and the like).

•

Frame styles affect frames and graphics.

•

List styles affect outlines, numbered lists, and bulleted lists.

•

Table styles affect the appearance of tables of data.

Paragraphs are the building blocks of every document: headings are paragraphs; headers, footers,
and items in numbered lists are also paragraphs. Paragraph styles are, therefore, the most
frequently used styles and are the ones treated in most detail in this chapter.

Caution
Manual formatting (also called direct formatting) overrides styles. You cannot get rid of
manual formatting by applying a style to it.
To remove manual formatting, select the text and choose Format > Clear Direct
Formatting from the Menu bar, or select the text and press Ctrl+M.

The Styles deck in the sidebar
Styles management is primarily available through the Styles deck (called Styles and Formatting in
some installations) in the Sidebar (Figure 1). Here you can apply styles, modify styles, and create
new styles.
To begin, do any of the following:
•

Click the Styles and Formatting icon on the Sidebar.

•

Choose Styles > Manage Styles from the Menu bar.

•

Press F11 (⌘ (+T on Mac).

The first six icons at the top of the Styles and Formatting deck select the category of styles. Click
one of these icons to display a list of styles in that category, such as paragraph or character styles.
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Select the Show Previews option to display the style names as examples of their formatting.

Paragraph Styles
Character Styles
Frame Styles

New Style from Selection
Update Style
Load Styles
Fill Format Mode

Page Styles
List Styles
Table Styles

Figure 1: The Styles and Formatting deck, showing paragraph styles and filter

Filtering the visible styles
At the bottom of the Styles and Formatting deck, use the drop-down menu to select a filter for the
list of styles. Normally, you will need only a few styles in any document, so it’s useful to have only
these styles shown.
At the beginning of the writing process, you may want to have access to all the available styles (by
selecting All Styles), and then hide some of them (Ctrl+click to select each style to be excluded
and finally right-click one of these styles and select Hide from the context menu). As the document
develops, it is quicker to reduce the list displayed to only the styles already in use (by selecting
Applied Styles). If you work on a document where you want to apply custom styles only, select
instead Custom Styles. The Hierarchical Styles view is most useful when modifying styles as it
reveals which styles are linked together. This topic is discussed in Chapter 9, Working with Styles.
In the Paragraph Styles view, the drop-down menu contains several more filtering options so you
can view, for example, only Text Styles, Special Styles, and so on.

Applying styles
Styles can be applied easily using the Styles and Formatting deck. In addition, you can apply
certain styles using other methods, as explained in this section.

Applying paragraph styles
When drafting a document, the most used style is the paragraph style. LibreOffice offers three
quick alternatives to the Styles and Formatting deck to apply this category of style: the Styles
menu (with a limited selection of commonly used styles), the Set Paragraph Style list, and the Fill
Formatting icon.
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Using the Styles and Formatting deck
Put the cursor in the paragraph and double-click the name of the style in the Paragraph Styles
section of the Styles and Formatting deck. You can select more than one paragraph and apply the
same style to all of them at the same time.

Using the Styles menu
The Styles menu on the Menu bar (Figure 2) provides the most commonly used paragraph and
character styles, plus quick links to create and edit styles. To apply a paragraph style, put the
cursor in the paragraph and click Styles > [name of paragraph style] on the Menu bar.

Figure 2: The Styles menu

Note
You cannot add styles to the Styles menu.

Using the Set Paragraph Style list
When a paragraph style is in use in a document, the style name appears on the Set Paragraph
Style list near the left end of the Formatting bar (see Figure 3).
To apply a style from this menu, put the cursor in the paragraph to change, and then click the arrow
to drop down the list of styles and click the desired style to apply it; or drop down the list and use
the up or down arrow keys to move through the list, then press Enter to apply the highlighted style.

Tip
Select More at the bottom of the list (not shown in illustration) to open the Styles and
Formatting deck.
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Figure 3: The Set Paragraph
Style list on the Formatting bar

Using Fill Format mode
You can use Fill Format mode to apply a style to many areas quickly without having to go back to
the Styles and Formatting deck and double-click each time. This method is useful for formatting
scattered paragraphs, words, or other items with the same style, and it may be easier to use than
making multiple selections first and then applying a style to all of them.
1)

Open the Styles and Formatting deck (Figure 1) and select a style.

2)

Click the Fill Format Mode icon.

3)

To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or
frame and click. To apply a character style, hold down the mouse button while selecting the
characters. Clicking on a word applies the character style to that word.

4)

Repeat step 3 until you have made all the changes for that style.

5)

To quit Fill Format mode, click the icon again or press the Esc key.

Caution
When this mode is active, a right-click anywhere in the document undoes the last Fill
Format action. Be careful not to accidentally right-click and undo actions you want to
keep.

Using keyboard shortcuts
Some keyboard shortcuts for applying styles are predefined. For example, Ctrl+0 applies the Text
body style, Ctrl+1 applies the Heading 1 style, and Ctrl+2 applies the Heading 2 style. You can
modify these shortcuts and create your own; see Chapter 21, Customizing Writer, for instructions.

Applying character styles
Writer provides two ways to apply character styles, as described in this section.
You may need to remove direct formatting before applying character styles. Select the text, then
choose Format > Clear Direct Formatting from the Menu bar.
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Using the Styles and Formatting deck
Open the Styles and Formatting deck and click the second icon in the top bar. The list of available
character styles is displayed. To apply a character style:
1)

Select the block of text, or put the cursor into the single word, where you wish to apply the
style.

2)

Double-click the appropriate character style in the Styles and Formatting deck.

Note
To apply a character style to more than a single word, you need to select all of the text
to be changed. To apply the style to a single word, you only have to place the cursor in
the word. In contrast, paragraph styles are applied to the whole of the paragraph in
which the cursor is placed.

Removing or replacing character styles
Sometimes, you will want to remove the character style formatting from some text, or change the
character style to a different style. To do this:
1)

Select the text.

2)

On the Styles and Formatting deck, click the Character Styles icon in the top bar.

3)

Double-click the required character style, or double-click Default Style to remove the
character style.

Applying frame styles
When you insert an object (such as a graphic) into a document, it will automatically have an
invisible frame around it. Some designers like to add frame styles to introduce variety. For
example, you could have one frame style for photographs and a different frame style for other
graphics such as line drawings. The one for photographs might have a border with a drop shadow,
while the one for drawings might have only a border.
To apply a style to a frame:
1)

Select the frame.

2)

Open the Styles and Formatting deck.

3)

Click the Frame Styles icon (the third one from the left).

4)

Double-click the frame style you want.

Having applied a style to a frame, you can now modify the frame to be just how you want it. Most of
a frame’s design can be set in a style, but the following options must be set manually:
•

Anchoring: how the frame is positioned in relation to the rest of the page’s contents
(Format > Anchor).

•

Arrangement: the frame’s position in a stack of objects (Format > Arrange).

•

Adding a hyperlink: so that a click on the frame opens a Web page or another document
(Insert > Hyperlink).

When a frame is selected, the Frame toolbar replaces the Formatting toolbar, and the right-click
(context) menu has items for anchoring, arrangement, wrap, and alignment.

Applying page styles
Put the cursor anywhere on the page. The applied page style is shown on the status bar.

Applying styles | 9

Figure 4: The current page style is displayed on the status bar
To apply a different style, either right-click the style in the status bar and select a style from the
context menu, or open the Styles and Formatting deck, select the page style icon at the top (fourth
icon), and then double-click the desired page style.

Caution
Changing a page style may also cause the style of subsequent pages to change. The
results may not be what you want. To change the style of only one page, you may
need to insert a manual page break, as described below.
As discussed in Chapter 9, Working with Styles, a correctly set up page style will, in most cases,
contain information on what the page style of the next page should be. For example, when you
apply a Left page style to a page, you can indicate in the page style settings that the next page has
to apply a Right page style, a First page style could be followed by either a Left page style or a
Default page style, and so on.
Another way to change the page style is to insert a manual page break and specify the style of the
subsequent page. The idea is simple: you break a sequence of page styles and start a new
sequence. To insert a page break, choose Insert > Manual Break and choose Page break. This
section illustrates two common scenarios where page breaks are useful.
Example: Chapters
A possible scenario: You are writing a book that is divided into chapters. Each chapter starts with a
page style called First Page. The following pages use the Default page style. At the end of each
(except the last) chapter, we return to the First Page style for the next chapter.
Figure 5 illustrates the flow of page styles when using page breaks.

Figure 5: Dividing a document into chapters using page styles
At some point, you will want to start a new chapter. Follow these steps:
1)

Put the cursor at the end of the chapter, on a blank line (empty paragraph) of its own.

2)

Choose Insert > Manual Break. The Insert Break dialog (Figure 6) appears.

3)

Under Type, choose Page break and under Style, select First Page.

Tip
You can automate these breaks by defining the paragraph style of the chapter’s title
(usually Heading 1) to include a page break.
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Figure 6: Choose Page break and select the First Page style

Example: Page with special formatting
Sometimes you may need to insert a page with special formatting, for example a landscape page
or a page with more columns. This can also be done with page breaks. Suppose that the current
page has the Default Style page style.
1)

Choose Insert > Manual Break.

2)

Select the desired page style (say, Special Page) in the Insert Break dialog.

3)

Type something on this page. Then insert another page break, selecting Default Style
again.

This concept is illustrated in Figure 7.

Figure 7: Inserting a page with special formatting

Example: A book chapter sequence of pages
Book chapters typically start on a right-hand page, with the first page of the chapter having a
different layout from the rest of the pages. The other pages in the chapter are “mirrored” for
double-sided printing. For example, page numbers in the header or footer may be positioned on
the outside edge of pages and in this instance a wider margin (allowing for binding) is placed on
the inside edge.
Table 1 shows the properties of two page styles (First Page and Default) set up for a typical book
chapter’s sequence of pages.
Table 1: Properties of customized page styles for a book chapter
Page Style

Desired effect

Property: setting

First Page

First page always on the right (an
odd-numbered page)

Page > Page layout > Only right

No header or footer

Header > Header on: Not selected

Top margin of page larger than on
other pages

Page > Margins > Top: 6.00cm
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Page Style

Desired effect

Property: setting

Default

Mirrored margins

Page > Page layout: Mirrored

Header with page number on the top
outside of the page and chapter title
in the top middle center of the page

Header > Header on: Selected
Header > Header > Same content left/right:
Not selected

Figure 8 illustrates the transitions from the First Page to Default page styles, with the change of
header between left and right pages shown by the # symbol.

Figure 8: First Page and then the Default page style
with different headers for alternate pages
Step 1. Set up the First Page style.
1)

On the Styles and Formatting deck, click the Page Styles icon to display a list of page
styles.

2)

Right-click First Page and select Modify from the pop-up menu.

3)

On the Organizer page of the Page Style: First Page dialog, change Next Style to Default.

Figure 9: Specifying the next style after the first page of a chapter
4)

On the Page page, specify a larger left margin for binding, and a larger top margin to move
the chapter title down the page.

Figure 10: Setting page margins and layout for the First Page style
5)

On the Header and Footer pages, be sure the Header on and Footer on options are not
selected. Click OK to save your changes.

Step 2. Set up the Default page style.
1)

On the Styles and Formatting deck, in the list of page styles, right-click Default and select
Modify from the pop-up menu.
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2)

On the Organizer page of the Page Style: Default dialog, be sure Next Style is set to
Default.

3)

On the Page page of the Page Style: Default dialog, select Mirrored for Page layout and
set the Inner and Outer margins to the same width as the Left and Right margins,
respectively, on the First Page style.

Figure 11: Setting page margins and layout for the Default page style
4)

On the Header page of the Page Style: Default dialog, select the Header on option and
deselect the Same content left/right option. Click OK to save your changes.

Figure 12: Setting up the header properties for the Default page style
Step 3. Set up the Heading 1 paragraph style to start on a new first page.
1)

In the Styles and Formatting deck, on the Paragraph Styles page, right-click Heading 1 and
select Modify.

2)

On the Text Flow page of the Paragraph Style dialog, in the Breaks section, select Insert,
With Page Style, and First Page. Click OK to save your changes.
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Figure 13: Setting a paragraph style to start on a page of a selected style
Step 4. Start a new chapter.
Apply the Heading 1 paragraph style to the first paragraph, which is the title of the chapter.

Note
By default, the Heading 1 paragraph style is assigned to Outline Level 1. The
assignment of paragraph styles to outline levels is done through Tools > Chapter
Numbering.
Step 5. Set up the page headers.
1)

On a left page, put the cursor in the header and insert a page number field on the left
(Insert > Fields > Page Number).

2)

Press Tab to put the cursor in the middle and insert a Chapter reference:
Press Ctrl+F2 (or choose Insert > Fields > Other from the Menu bar) to display the Fields
dialog (Figure 14).
On the Document page, for Type, select Chapter and for Format, select Chapter name.
Make sure that Level is set to 1 and then click Insert.

Figure 14: Inserting a chapter title into the header of a page
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3)

On a right page, put the cursor in the header, press the Tab key, insert a Chapter reference,
press Tab again, and insert a page number field.

4)

If you need to adjust the tab stops for the header, modify the Header paragraph style. Do
not manually adjust the tab stops.

Applying list styles
List styles define properties such as indentation, numbering style (for example, 1,2,3; a,b,c; or
bullets), and punctuation after the number, but they do not by themselves define properties such as
font, borders, text flow, and so on. The latter are properties of paragraph styles.
Writer has two series of predefined list styles, named List and Numbering. List styles are for bullet
points by default; Numbering styles for numbered lists by default. Each series contains five list
styles, intended for the different levels of a nested list. As with any style, you can redefine the
properties of these styles, for example the numbering or bullet symbol and the indentation. You can
also define other list styles in these series or create your own series.
Each of the list styles predefined in Writer has four associated paragraph styles. For more
information, see Chapter 9, Working with Styles. Much more information about list styles is in
Chapter 12, Lists: Tips and Tricks.
If you only want to apply a list style (that is, the numbering or bullet symbol and the indentation),
then place the cursor in the paragraph and double-click the desired list style in the List Styles
section of the Styles and Formatting tab in the sidebar. However, a better strategy is to embed the
list style into one or more paragraph styles, as explained in Chapter 9. You can then create a list by
applying paragraph styles alone.
List styles can have up to ten levels, used for nested lists. To switch from one level to another, use
the Promote One Level or Demote One Level icons on the Bullets and Numbering toolbar, or
press the Tab key (one level down) or Shift+Tab keys (one level up), or right-click the list element
and select Promote One Level or Demote One Level from the context menu.

Restarting or continuing the numbering
When creating more than one numbered list of the same type within the same chapter, Writer
applies sequential numbering to all the lists. Sometimes this is what you want (for example, when
placing illustrations between the numbered paragraphs), while at other times you want to restart
the numbering.
To restart numbering from 1, you can do any of the following:
•

Click the Restart numbering icon on the Bullets and Numbering toolbar.

•

Right-click the first element of the list and choose Restart numbering from the context
menu.

•

Right-click the first element of the list, choose Paragraph from the context menu, and go to
the Outline & Numbering tab of the Paragraph dialog. In the Numbering section, select the
options Restart at this paragraph and Start with, and set the number (see Figure 15).

If you find that the numbering does not restart as intended using the first or second method, or if
you want to restart from a number greater than 1, use the third method.
When editing a document, you may want to change from restarting numbering to continuing the
numbering from a previous list. To do so, right-click the list element and choose Continue
previous numbering from the context menu.
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Figure 15: Restarting numbering

Applying table styles
Table styles define properties such as the font, paragraph spacing, number of columns, borders,
and background color.
To apply a table style, position the cursor anywhere in the table, go to the Styles and Formatting
deck on the Sidebar, choose Table Styles, then double-click the name of a style on the list.
See Chapter 13, Tables of Data, for information on creating a table style.

Assigning styles to shortcut keys
You can configure shortcut keys to quickly assign styles in your document. Some shortcuts are
predefined, such as Ctrl+1 for the Heading 1 paragraph style and Ctrl+2 for Heading 2. You can
modify these shortcuts and create your own. See Chapter 21, Customizing Writer, for details.

Creating and modifying styles
Writer provides many predefined styles, which are useful when sharing a document to another
machine, especially one with a different language version of LibreOffice, but you may find that they
do not fit your preferences. You can modify the predefined styles or build your own library of
custom styles to use in addition to or in place of the predefined ones.
Writer offers these mechanisms to modify both both predefined and custom (user-created) styles:
•

Update a style from a selection.

•

Load or copy styles from another document or template.

•

Change a style using the Style dialog.

•

Use AutoUpdate (paragraph and frame styles only).

•

Use AutoFormat (table styles only). See Chapter 13, Tables of Data.

Using New Style from Selection, Update Style, and Load Styles
Styles are part of the document properties, therefore new styles you create or formatting changes
you make to an existing style are available only within the document they belong to. Styles always
stay with a document.
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Tip
If you want to reuse modified or new styles in other documents, either save the styles
in a template (see Chapter 10, Working with Templates) or copy the styles into the
other documents, as described in “Load Styles (from a template or document)” on
page 18.
The last icon at the top of the Styles and Formatting deck gives access to a menu of three
functions: New Style from Selection, Update Style, and Load Styles.

New Style from Selection
Use New Style to create a new style from the formatting of an item in the current document. For
example, you can change the formatting of a paragraph until it appears as you like, and then you
can turn that formatting into a new style. This procedure can save time because you do not have to
remember all the formatting settings you want, as is necessary when creating a new style with the
Style dialog. In addition, you can immediately see how the item will look when formatted with the
style you are creating.
Follow these steps to create a new style from a selection:
1)

Change the formatting of the object (paragraph, frame, and so on) to your liking.

2)

From the icons at the top of the window, choose the category of style to create (paragraph,
character, and so on).

3)

In the document, select the item to save as a style.

4)

Go back to the Styles and Formatting deck and click the New Style from Selection icon,
then select New Style from the menu.

5)

The Create Style dialog opens. Type a name for the new style. The list shows the names of
existing custom styles of the selected type, if any. Click OK to save the new style.

Update Style (from a selection)
Let’s use paragraph styles as an example.
1)

Create a new paragraph (or select an existing paragraph) and edit all the properties you
want to alter in the style (such as indentation, font properties, alignment, and others).

Caution
Make sure that theproperties in this paragraph are uniform. For example, if there are
two different font sizes in the paragraph, that property will not be updated.
2)

Select the paragraph by clicking anywhere in the paragraph.

3)

In the Styles and Formatting deck, select the style you want to update (single-click, not
double-click) and then click the New Style from Selection icon and select Update Style.

The procedure to update another category of style (character, page, or frame styles) is the
same: select the item in question, modify it, select the style you want to update, and
choose Update Style.
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Figure 16: Updating a style from a selection

Load Styles (from a template or document)
The last option under the New Style from Selection icon is used to copy styles into the current
document by loading them from a template or another document. Using this method, you can copy
all styles, or groups of styles, at one time.
1)

Open the document to copy styles into.

2)

In the Styles and Formatting deck, click the New Style from Selection icon and then on
Load Styles (see Figure 16).

3)

In the Load Styles dialog (Figure 17), find and select the template or document to copy
styles from.

Figure 17: Loading styles from a template
Click the From File button if the styles you want are contained in a text document rather
than a template. In this case, a standard file selection dialog opens up, where you can
select the desired document.
4)

Select the options for the types of styles to be copied: Text (Paragraph and Character
styles), Frame, Pages, Numbering (List styles). If you select Overwrite, the styles being
copied will replace any styles of the same names in the target document.

5)

Click OK to copy the styles.
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Drag-and-drop a selection to create a style
Another way to create a new style is to drag-and-drop a text selection into the Styles and
Formatting deck.
1)

Open the Styles and Formatting deck.

2)

Select the style category you are going to create (for example a character style) using one
of the icons near the top of the deck.

3)

Select the object on which you want to base the style and drag it to the Styles and
Formatting deck. The cursor changes to indicate whether the operation is possible.

4)

In the Create Style dialog, type a name for the new style and click OK to save the style.

Note
You cannot use the drag-and-drop method to create a new page style or table style.

Changing a style using the Style dialog
To change an existing style (but not a table style) using the Style dialog, right-click the style in the
Styles and Formatting deck and select Modify from the pop-up menu.
The dialog displayed depends on the type of style selected. Each style’s dialog has several tabs.
The properties on these dialogs are described in Chapter 9.
You can click the Help button at any time to bring up the online help where all the options of the
current page are briefly described. When you are done, click OK to close the dialog.

Using AutoUpdate
On the Organizer page of the Paragraph Style and Frame Style dialogs is an AutoUpdate option. If
this option is selected, then LibreOffice will apply to the style any modification made manually to a
paragraph formatted with that style.

Caution
If you are in the habit of manually overriding styles in your document, be sure that
AutoUpdate is not enabled, or you will suddenly find whole sections of your document
reformatting unexpectedly.

Figure 18: The Organizer page of the Paragraph Style dialog

Deleting styles
It is not possible to delete LibreOffice’s predefined styles from a document or template, even if they
are not in use. However, custom styles can be deleted.
To delete any unwanted styles, in the Styles and Formatting deck select each one to be deleted
(hold Ctrl while selecting multiple styles), and then right-click a selected style and select Delete in
the context menu. If the style is in use, a message appears warning you that the style is in use and
asking you to verify that you really want to delete the style.
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If the style is not in use, it is deleted immediately without confirmation.

Caution
If you delete a style that is in use, all objects with that style will return to the style it was
based on (inherited from) but may retain some of the deleted style’s formatting as
manual formatting.

Tip
If an unwanted paragraph style is in use, you can use Find & Replace to replace it with
a substitute style before deleting it. See Chapter 3, Working with Text: Advanced, for
more information.

Example: creating and modifying paragraph styles
This section provides an example of a typical use of custom paragraph styles. We will create a
Poem paragraph style and a Poem Header paragraph style, with the following properties:
•

Poem: Centered, with a font size of 10pt.

•

Poem Heading: Centered, bold, with a 12pt font size.

In addition, a Poem Heading style is to be followed by a Poem style. In other words, when you
press Enter, the next paragraph style in the document changes to Poem.

Note
You may have noticed this behavior already. After you enter a heading using a
Heading paragraph style and press Enter, the next style switches to Text body.

Creating the Poem paragraph style
We will use the Default style as a starting point.
1)

In the Styles and Formatting deck, click the Paragraph Styles icon.

2)

Right-click Default Style and choose New.

The Paragraph Style dialog opens, with the Organizer page selected. To create a custom style, you
need to configure the top three entries.
Style fields

Description

Name

The name of the style itself, like Heading 1 or Text body.
Type the name Poem.

Next Style

The style of a paragraph that follows the paragraph that is in Poem style. When you
press Enter while typing text in the Poem style, this style is automatically applied to
the new paragraph.
Set this value to Poem. When you press Enter, the text of the new paragraph will
remain in the Poem style.

Inherit from

If the properties of the Poem style are inherited from another style, say Default Style,
then any change in Default will affect Poem.
For our example, this is not the behavior we want. Set this entry to – None –. This
means that Poem is not inherited from any other style.

Select the Custom Styles category for new styles. Do not select the AutoUpdate option.
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After making these changes, your dialog should look like Figure 19.

Figure 19: Initial configuration for the Poem style. Set the first three entries as shown.
The next step is to configure the alignment and font properties of this style.
•

On the Alignment page, select the Center option.

•

On the Font page, select the 12pt font size.

Click OK to save the new Poem style.

Creating the Poem Heading style
To create a new Poem Heading style, use the same procedure as above, with these changes:
•

Next Style: Select Poem, not Poem Heading. When you press Enter while typing text in the
PoemHeading style, this Poem style is automatically applied to the new paragraph.

•

Inherit from: Heading.

The dialog should look like Figure 20.

Figure 20: Settings for the PoemHeading style
Now set the settings of the new style:
1)

On the Alignment page, select Center.

2)

On the Font page, choose Bold and size 14pt.

Click OK to save the new PoemHeading style.
Sample poem
It is a good idea to test out your new styles and see if you are happy with them. Typing a poem
using the styles we have just defined should produce the results in Figure 21.
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Figure 21: Sample poem

Changing the formatting of your styles
One of the main advantages of styles is that they allow the document formatting to be changed
after the content has been written. For example, suppose you have written a 100-page book of
poetry. Then you (or your publisher) decide you don’t like the way the poems look.
To learn about reconfiguring styles, we add an indentation to the Poem style instead of centering it.
First, set the Poem style to left alignment:
1)

In the Styles and Formatting deck, right-click Poem and select Modify.

2)

On the Alignment page, select Left.

Set the indentation:
1)

Select the Indents & Spacing tab.

2)

Under Indent, set the indentation before the text to 0.5in.

Click OK, and you should see the text change. The poem should now look similar to Figure 22.
Note in the figure that a third style has been created for the author of the poem.

Figure 22: Final result, using three custom styles
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Using paragraph styles to define a hierarchy of headings
Paragraph styles are the key to Writer’s table of contents feature. Tools > Chapter Numbering
defines the hierarchy of headings in a document. The default paragraph styles assigned to heading
levels are the heading styles supplied with Writer: Heading 1, Heading 2, and so on. However, you
can substitute any styles you wish, including custom (user-defined) styles.
The headings defined using the chapter numbering feature can be used for more than the table of
contents (described in Chapter 15). For example, fields are commonly used to display headings in
headers and footers of pages (see Chapter 17, Fields).

Choosing paragraph styles for heading levels
If you are using the default heading styles for the headings in your outline, and you do not want to
use heading numbering, you do not need to do anything on the Chapter Numbering dialog. The
default outline numbering scheme uses the default heading styles.
To use custom styles in place of one or more of the default heading styles:
1)

Choose Tools > Chapter Numbering to open the Chapter Numbering dialog.

2)

Click the number in the Level box corresponding to the heading for which you want to
change the paragraph style.

Figure 23: Choosing paragraph styles for numbering levels
3)

In the Numbering: Paragraph Style section, choose from the drop-down list the paragraph
style you want to assign to that heading level. In this example, you might choose
My Heading 1 to replace Heading 1 and for Level 2, My Heading 2 to replace Heading 2.

4)

Repeat for each numbering level that you want to change. Click OK when done.

Assigning outline levels to other styles
In Writer, you can assign an outline level to any paragraph style. This feature enables you to create
a table of contents that includes those headings along with the headings using styles listed in the
Chapter Numbering dialog. For example, you might use a different sequence of styles for
appendixes, but you want the appendix headings and subheadings to appear in the table of
contents at the same levels as the chapter headings and subheadings.
To assign an outline level to a paragraph style, go to the Outline & Numbering page for the style,
and select the required outline level from the drop-down list. Click OK to save this change.
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Figure 24: Specifying an outline level for a paragraph style

Setting up heading numbering
If you want one or more heading levels to be numbered, many choices are available; this example
defines a scheme to create headings that look like those in the illustration below.

Figure 25: The numbering scheme to be set up

24 | Chapter 8 Introduction to Styles

Use the Numbering page of the Chapter Numbering dialog to define the numbering scheme and its
appearance. Figure 26 shows the default settings.

Figure 26: Default settings on the Chapter Numbering dialog
1)

In the Level list, choose 1. In the Number list, choose 1, 2, 3, …. The result is shown in the
preview box on the right in Figure 27.

Figure 27: Specifying numbering of Level 1 headings
2)

In the Level list, choose 2. In the Number list, choose 1, 2, 3, …. The Show sublevels list is
now active; it should show 2 (if not, choose 2). The result is shown in Figure 28.

Figure 28: Specifying numbering of Level 2 headings
3)

In the Level list, choose 3. In the Number list, choose 1, 2, 3, …. The Show sublevels list
should show 3 (if not, choose 3). The result is shown in Figure 29.
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Figure 29: Specifying numbering of Level 3 headings
These choices produce the layout shown in Figure 30.

Figure 30: Results of numbering choices for headings

Setting up the indentation of headings
Whether or not the headings are numbered, you may want to change some of their formatting. For
example, you may want the second-level and third-level headings to be indented from the margin.
For numbered headings, you may also want the second line of long headings to line up with the
first word of the heading, not the number. For these changes, use the Position page of the Chapter
Numbering dialog.
As an example, we will change the position and wrapping of a Heading 2:
1)

In the Level list on the left, choose 2. Change the values for Numbering followed by, at and
Aligned at, as shown in Figure 31. You may want to use a different value. This indents the
entire heading but does not affect the way long headings wrap around (see Figure 32).

Figure 31: Indenting Level 2 headings
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Figure 32: Result of changes to indentation of Level 2 headings
2)

To change the wrapping behavior of long headings, change Indent at to a larger value, as
shown in Figure 33. The result is shown in Figure 34.

Figure 33: Wrapping long headings

Figure 34: Result of changing Indent at value
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