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Using LibreOffice on macOS
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Windows or Linux

macOS equivalent

Effect
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F11

⌘ +T
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Documentation for LibreOffice is available at http://documentation.libreoffice.org/en/

Contents
Copyright..............................................................................................................................2
Contributors................................................................................................................................. 2
To This Edition......................................................................................................................... 2
To Previous Editions................................................................................................................ 2
Feedback..................................................................................................................................... 2
Publication date and software version.........................................................................................2
Using LibreOffice on macOS........................................................................................................2

Printing..................................................................................................................................4
Quick printing............................................................................................................................... 4
Controlled printing........................................................................................................................ 5
General options....................................................................................................................... 5
LibreOffice Draw options......................................................................................................... 5
Printing multiple pages on a single sheet.....................................................................................6
Selecting pages to print...............................................................................................................7
Individual page........................................................................................................................ 7
Range of pages....................................................................................................................... 7
Selection printing..................................................................................................................... 7
Brochure or booklet printing.........................................................................................................7
Single-sided printer................................................................................................................. 8
Double-sided printer................................................................................................................ 8
Black and white or grayscale printing...........................................................................................9
Printer settings........................................................................................................................ 9
LibreOffice settings............................................................................................................... 10
Draw settings........................................................................................................................ 10

Exporting.............................................................................................................................10
Directly as PDF.......................................................................................................................... 11
Controlling PDF content and quality...........................................................................................11
Other formats............................................................................................................................. 11
Web pages................................................................................................................................. 12

E-mailing documents.........................................................................................................12
OpenDocument format...............................................................................................................13
PDF format................................................................................................................................ 13

Printing, Exportin and Emailing | 3

Printing
Quick printing
To quickly print a document or drawing, click on the Print Directly icon on the Standard toolbar
(Figure 1) to send the entire document to the default printer that is defined for your computer.

Figure 1: Standard toolbar

Note
You can change the action of the Print Directly icon by sending a document to the
printer defined for the document instead of the default printer for the computer. Go to
Tools > Options > Load/Save > General and select the Load printer settings with the
document option.
If the Print Directly icon is not visible on the Standard toolbar, right click in an empty
area on the toolbar and select Visible Buttons from the context menu. Select Print
Directly from the displayed list and the icon is added to the toolbar.

Figure 2: Print dialog - General options
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Note
Due to different computer setups and different operating systems, the Print dialog
(Figure 2) that appears on your monitor may differ from the one shown above.
However, the printing options available for LibreOffice will remain the same.

Controlled printing
For more control over printing, open and use the Print dialog (Figure 2) using one of the following
methods:
•

Go to File > Print on the main menu bar.

•

Use the keyboard Ctrl+P .

•

Click on the Print icon on the Standard toolbar.

Note
The options selected in the Print dialog only apply to the printing of the current
document that is open in Draw. To specify default print settings for LibreOffice, go to
Tools > Options > LibreOffice > Print on the main menu bar.

General options
The following general options are an example of what you may see on the Print dialog (Figure 2).
•

Printer – select the printer to use from the printers available in the drop down list.

•

Range and Copies – select from the following options:
— All Pages; Pages (select page number); Even pages; Odd pages; Selection
— Paper sides: Print on one side (simplex); Print on both sides (duplex long edge binding);
Print on both sides (duplex short edge binding)
— Number of copies: enter number of copies required for document
— Collate: collates multiple copies into separate printed documents
— Order: print pages of document in reverse order

•

Page Layout – select from the following options:
— Paper size: select from drop down list
— Orientation: select automatic, portrait or landscape
— Pages per sheet: select how many pages are printed on a sheet of paper
— Order: printing order of multiple pages on a sheet of paper
— Draw a border around each page
— Brochure: prints the document so you can fold the pages like a booklet

LibreOffice Draw options
The following options are available LibreOffice Draw page of the Print dialog (Figure 3) where you
can define settings that are specific to the current document type:
•

Contents – prints the Page name and/or Date and time on the drawing

•

Colors – print the drawing in Original colors, Grayscale, or Black & white.

•

Size – print the drawing using one of the following options:
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— Original size
— Fit to printable page
— Distribute on multiple sheets of paper: used if the drawing is too large for the paper size
being used.
— Tile sheet of paper with repeated pages: used to print multiple copies of a drawing on a
page.

Figure 3: Print dialog - LibreOffice Draw options

Note
The following printing instructions are examples only. Actual method of printing
depends on computer operating system, computer setup and the printer being used.

Printing multiple pages on a single sheet
To print multiple pages of a document on one sheet of paper:
1)

Open and use the Print dialog (Figure 2 on page 4) using one of the following methods:
— Go to File > Print on the main menu bar.
— Use the keyboard Ctrl+P .
— Click on the Print icon on the Standard toolbar.

2)

In the Page Layout section, select from the Pages per sheet drop-down list the number of
pages to print per sheet. The preview panel on the right shows how the pages will look in
the printed document.

6 | Printing, Exportin and Emailing

3)

In the Page Layout section, select from the Order: drop down list how you want the
multiple pages printed on the sheet of paper.

4)

To distinguish each page on a sheet, select Draw a border around each page.

5)

Click OK to print the document and close the dialog.

Selecting pages to print
In addition to printing a full document, you can choose whether to print individual pages, a range of
pages, or a highlighted selection within a document.

Individual page
1)

Open and use the Print dialog (Figure 2 on page 4) using one of the following methods:
— Go to File > Print on the main menu bar.
— Use the keyboard Ctrl+P .
— Click on the Print icon on the Standard toolbar.

2)

In the Ranges and Copies section, select the Pages option.

3)

Enter the page number of the page to print.

4)

Click OK to print the document and close the dialog.

Range of pages
1)

Open and use the Print dialog (Figure 2 on page 4) using one of the following methods:
— Go to File > Print on the main menu bar.
— Use the keyboard Ctrl+P .
— Click on the Print icon on the Standard toolbar.

2)

In the Ranges and Copies section, select the Pages option.

3)

Enter the page number of the pages to print (for example 1-4 or 1,3,7,11), or any
combination of the two (for example: 1-4,7-9,10).

4)

Click OK to print the document and close the dialog.

Selection printing
1)

Open and use the Print dialog (Figure 2 on page 4) using one of the following methods:
— Go to File > Print on the main menu bar.
— Use the keyboard Ctrl+P .
— Click on the Print icon on the Standard toolbar.

2)

In the Ranges and Copies section, select the Even pages, Odd pages or Selection
options.

3)

Click OK to print the document and close the dialog.

Brochure or booklet printing
In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of
paper, arranged so that when the printed pages are folded in half, the pages are in the correct
order to form a booklet or brochure.
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Tip
Plan your document so it will look good when printed half size; choose appropriate
margins, font sizes, and so on. You may need to experiment.

Single-sided printer
To print a brochure or booklet on a printer only capable of single-sided or simplex printing:
1)

Open and use the Print dialog (Figure 2 on page 4) using one of the following methods:
— Go to File > Print on the main menu bar.
— Use the keyboard Ctrl+P .
— Click on the Print icon on the Standard toolbar.

2)

Select the printer you want to use if more than one printer is connected to your computer.

3)

Click Properties to open the properties dialog for the selected printer.

4)

Check the printer is set to the same orientation (portrait or landscape) as specified in the
page setup for your document. Usually the orientation does not matter, but it does for
brochures and booklets.

5)

Click OK to return to the Print dialog.

6)

Select the Brochure option in the Page Layout section.

7)

Select Even pages or Odd pages in the Range and Copies section.

8)

Click OK to print the even or odd pages.

9)

Take the printed pages out of the printer, turn the pages over, and put them back into the
printer in the correct orientation to print on the blank side. You may need to experiment a bit
to find out what the correct arrangement is for your printer.

10)

If you selected Even pages, now select Odd pages in the Range and Copies section. If
you selected Odd pages, now select Even pages in the Range and Copies section.

11)

Click OK to finish printing the document.

Double-sided printer
To print a brochure or booklet on a printer that is capable of double-sided or duplex printing:
1)

Open and use the Print dialog (Figure 2 on page 4) using one of the following methods:
— Go to File > Print on the main menu bar.
— Use the keyboard Ctrl+P .
— Click on the Print icon on the Standard toolbar.

2)

Select the printer you want to use if more than one printer is connected to your computer.

3)

Click Properties to open the properties dialog for the selected printer.

4)

Check the printer is set to the same orientation (portrait or landscape) as specified in the
page setup for your document. Usually the orientation does not matter, but it does for
brochures and booklets.

5)

Click OK to return to the Print dialog.

6)

In the Paper sides option, select Print on both sides (duplex long edge) printing from the
drop down list. Actual options available for duplex printing depend on the printer model and
the computer system being used.

7)

Select the Brochure option in the Page Layout section.
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8)

In the Range and Copies section, select the All pages option.

9)

Click OK to print the document.

Black and white or grayscale printing
You may wish to print documents in black and white or grayscale on a color printer. However, some
color printers may only allow you to print in color regardless of the settings you choose. More
details can be found in the information that came with your printer.

Printer settings
To change the printer settings to print in black and white or grayscale:
1)

Open and use the Print dialog (Figure 2 on page 4) using one of the following methods:
— Go to File > Print on the main menu bar.
— Use the keyboard Ctrl+P .
— Click on the Print icon on the Standard toolbar.

2)

Select the printer you want to use if more than one printer is connected to your computer.

3)

Click Properties to open the properties dialog for the printer. The available choices
available depend on printer model and computer operating system, but you should easily
find options for the Color settings. An example of what you may see is shown in Figure 4.

Figure 4: Example printer properties dialog
4)

In Color or Additional Features, select either Black & White or Grayscale from the
available options.

5)

Click OK to close the properties dialog and return to the Print dialog.

6)

Click OK to print the document and close the dialog.
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Tip
Grayscale is the best option if you have any colored text or graphics in the document.
Colors will print in shades of gray giving more detail. When printing color in black and
white some of this detail maybe lost.

LibreOffice settings
To change the LibreOffice settings to print all colored text and graphics as grayscale:
1)

Go to Tools > Options > LibreOffice > Print on the main menu bar.

2)

In Defaults, select Convert colors to grayscale option.

3)

Click OK to save the change and close the dialog.

4)

Open and use the Print dialog (Figure 2 on page 4) using one of the following methods:
— Go to File > Print on the main menu bar.
— Use the keyboard Ctrl+P .
— Click on the Print icon on the Standard toolbar.

5)

Click OK to print the document and close the dialog.

Draw settings
To change the Draw settings to print all color text and graphics as either black and white or
grayscale:
1)

Go to Tools > Options > LibreOffice Draw> Print on the main menu bar.

2)

In the Quality section, select either Grayscale or Black & white option.

3)

Click OK to save the change and close the dialog.

4)

Open and use the Print dialog (Figure 2 on page 4) using one of the following methods:
— Go to File > Print on the main menu bar.
— Use the keyboard Ctrl+P .
— Click on the Print icon on the Standard toolbar.

5)

Click OK to print the document and close the dialog.

Exporting
LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file
format is ideal for sending a file for someone else to view using Adobe Reader or other PDF
viewers. The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few
minor differences mentioned in this section.
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Figure 5: PDF Options dialog

Directly as PDF
Click on the Export Directly as PDF icon on the Standard toolbar to export the entire document
using your default PDF settings. You are asked to enter the file name and location for the PDF file,
but you cannot choose page range, image compression, or other options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, you have to use the option
Export as PDF. For more information on available options, see the Getting Started Guide.
1)

Go to File > Export As > Export as PDF on the main menu bar to open the PDF Options
dialog (Figure 5).

2)

Use this dialog to select options in the General, Initial View, User Interface, Links,
Security and Digital Signatures pages.

3)

When you have selected the appropriate options, click Export.

4)

In the dialog that opens, enter the location and file name of the PDF to be created.

5)

Click Export to save the file in PDF format.

Other formats
LibreOffice uses the term “export” for some file operations involving a change of file type. If you
cannot find what you want in File > Save As, look in File > Export. LibreOffice can export files in
various formats, which are listed in the drop-down list for file format. See Chapter 6 Editing
Pictures in this guide for more information on exporting graphics.
To export a file in another format:
1)

Go to File > Export on the main menu bar to open the Export dialog (Figure 6).
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Figure 6: Export dialog
2)

Navigate to the directory where you want to export your drawing.

3)

Specify a file name for the exported document in the File name text box.

4)

Select the required format from the File format drop-down list.

5)

Click Export to save the file and close the dialog.

Note
The content of the exported file will depend on the elements selected on the page. No
selection results in the entire image being exported. For most export formats, only the
image on the current page will be exported.

Web pages
To export a multi-page Draw document to a series of web pages, go to File > Export on the main
menu bar and select HTML Document as the file type to open the HTML Export dialog. Follow the
prompts to create the web pages. If required, a navigation aid can be generated to help in moving
from page to page. For more information, see Chapter 12 Creating Web Pages in the Getting
Started Guide.

E-mailing documents
LibreOffice provides several ways to send documents quickly and easily as an e-mail attachment in
OpenDocument format (LibreOffice default format), or as a PDF. You can email a document to
several recipients. For more information, see Chapter 10 Printing, Exporting, and E-mailing in the
Getting Started Guide.

Note
Documents can only be sent from the LibreOffice menu if a mail profile has been set
up.
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OpenDocument format
To email the current document in OpenDocument format:
1)

Go to File > Send > Email Document on the main menu bar. LibreOffice opens your
default e-mail program with the document attached.

2)

In your e-mail program, enter the recipient, subject, and any text you want to add, then
send the e-mail.

PDF format
To email the current document as a PDF file:
1)

Go to File > Send >-E-mail as PDF on the main menu bar. LibreOffice creates a PDF
using the default PDF settings and then opens your email program with the PDF file
attached.

2)

In your e-mail program, enter the recipient, subject, and any text you want to add, then
send the e-mail.
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