Chapter 11
Images and Graphics
Pictures, Drawing Tools, Gallery, Fontwork
Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this document. For a detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>%€ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F11</td>
<td>%€ + T</td>
<td>Open the Styles deck in the Sidebar</td>
</tr>
</tbody>
</table>
# Contents

Copyright.................................................................................................................................................. 2
Contributors........................................................................................................................................... 2
Feedback.................................................................................................................................................. 2
Publication date and software version..................................................................................................... 2
Using LibreOffice on macOS.................................................................................................................... 2

Introduction.............................................................................................................................................. 5

Creating and editing images....................................................................................................................... 5

Adding images to a document..................................................................................................................... 5
  Inserting an image file............................................................................................................................... 5
  Drag and drop........................................................................................................................................... 5
  Insert Image dialog.................................................................................................................................. 5
  Copy and paste......................................................................................................................................... 6
  Linking an image file............................................................................................................................... 7
  Embedding linked images....................................................................................................................... 7
  Inserting an image using a scanner........................................................................................................ 8
  Inserting an image from the Gallery....................................................................................................... 8

Modifying, handling, and positioning images............................................................................................ 9
  Using the Image toolbar............................................................................................................................ 9
  Cropping images..................................................................................................................................... 9
  Resizing an image.................................................................................................................................... 9
  Rotating or flipping an image................................................................................................................ 10
  Other settings.......................................................................................................................................... 10
  Exporting (saving) images..................................................................................................................... 10
  Compressing images............................................................................................................................. 10
  Positioning images.................................................................................................................................. 11
  Adding captions to images...................................................................................................................... 12

Managing the LibreOffice Gallery............................................................................................................. 12
  Adding a new theme to the Gallery......................................................................................................... 12
  Adding objects to the Gallery................................................................................................................. 13
  Deleting images and themes from the Gallery....................................................................................... 13
  Location of the Gallery and the objects in it.......................................................................................... 14

Creating an image map............................................................................................................................... 14

Using LibreOffice’s drawing tools................................................................................................................ 16
  Creating drawing objects......................................................................................................................... 16
  Setting or changing properties for drawing objects................................................................................ 17
  Resizing a drawing object...................................................................................................................... 17
  Grouping drawing objects...................................................................................................................... 18

Using Fontwork...................................................................................................................................... 18
  Creating a Fontwork object..................................................................................................................... 18
  Editing a Fontwork object...................................................................................................................... 19
  Using the Fontwork toolbar................................................................................................................... 19
  Using the Formatting toolbar.................................................................................................................. 21
Using menu options ........................................................................................................... 21
Using the 3D-Settings toolbar ......................................................................................... 21
Moving and resizing Fontwork objects ............................................................................ 21
Generating a QR code ....................................................................................................... 22
Introduction

You can add graphic and image files, including photos, drawings, and scanned images, to LibreOffice documents. Images in LibreOffice are of these basic types:

- Image files, such as photos, drawings, PDF documents, and scanned images
- Diagrams created using LibreOffice's drawing tools
- Artwork created using clip art or Fontwork
- Charts created using LibreOffice's Calc component

This chapter covers images, diagrams, and Fontwork. For more detailed instructions on working with drawing tools, see the Draw Guide and Impress Guide. Instructions on how to create charts are given in the Calc Guide.

Creating and editing images

You might create images using a graphics program, scan them, or download them from the Internet (make sure you have permission to use them), or use photos taken with a digital camera. LibreOffice can import various vector (line drawing) images, and can rotate and flip such images. LibreOffice also supports raster (bitmap) file formats, the most common of which are GIF, JPG, PNG, and BMP. See Appendix B for a full list of the graphic formats LibreOffice can import.

LibreOffice can also import SmartArt images from Microsoft Office files. For example, Writer can open a Microsoft Word file that contains SmartArt, and you can use Writer to edit the images.

To edit photos and other bitmap images, use a bitmap editor. To edit line drawings, use a vector drawing program. You do not need to buy expensive programs. For many graphics, LibreOffice Draw is sufficient. Open-source (and usually no-cost) tools such as GIMP (bitmap editor) and Inkscape (vector drawing program) are excellent. These and many other programs work on Windows, macOS, and Linux.

Adding images to a document

Images can be added to a document in several ways: by inserting an image file, directly from a graphics program or a scanner, by dragging them from the clip art internal gallery, or by copying and pasting from a source being viewed on your computer.

Inserting an image file

When the image is in a file stored on the computer, you can insert it into a LibreOffice document using one of the following methods:

**Drag and drop**

This method embeds (saves a copy of) the image file in the document. To link the file instead of embedding it, hold down the Ctrl+Shift keys while dragging the image.

1) Open a file browser window and locate the image you want to insert.
2) Drag the image into the LibreOffice document and drop it where you want it to appear. A faint vertical line marks where the image will be dropped.

**Insert Image dialog**

1) Click in the LibreOffice document where you want the image to appear.
2) Choose **Insert > Image** on the Menu bar or click the **Insert Image** icon on the Standard toolbar.
3) On the Insert Image dialog, navigate to the file to be inserted, and select it.

4) At the bottom of the dialog (Figure 1) is a Link option. See “Linking an image file” on page 7 for the use of Link.

5) Click Open.

**Note**

If you choose the Link option, a message box appears when you click Open. It asks if you want to embed the graphic instead. Choose Keep Link if you want the link, or Embed Graphic if you do not. To prevent this message from appearing again, deselect the option Ask when linking a graphic at the bottom of the message.

**Figure 1: Insert Image dialog**

**Copy and paste**

Using the clipboard, you can copy images into a LibreOffice document from another LibreOffice document and from other programs. To do this:

1) Open both the source document or program and the target LibreOffice document.
2) In the source document, select the image to be copied.
3) Copy the image to the clipboard.
4) Switch to the target document.
5) Click to place the cursor where the image is to be inserted.
6) Press Ctrl+V, or right-click and select Paste in the context menu, or click the Paste icon on the Standard toolbar, to insert the image.

**Caution**

If the application from which the image was copied is closed before the image is pasted into the target, the image stored in the clipboard could be lost.
Linking an image file

If the **Link** option in the Insert Image dialog is selected, LibreOffice creates a link to the file containing the image instead of saving a copy of the image in the document. The result is that the image is displayed in the document, but when the document is saved, it contains only a reference to the image file, not the image itself. The document and the image remain as two separate files, and they are merged together only when you open the document again.

Linking an image has two advantages and one disadvantage:

- **Advantage** – You can modify the image file separately, and the modified image will appear when you next open the document. This can be a big advantage if you (or someone else, perhaps a graphic artist) is updating images.

- **Advantage** – Linking can reduce the size of the document when it is saved, because the image file itself is not included. However, file size is usually not a problem on a modern computer, and LibreOffice can handle quite large files.

- **Disadvantage** – If you send the document to someone else, or move it to a different computer, you must also send the image files, or the receiver will not be able to see the linked images. You need to keep track of the location of the images and make sure the recipient knows where to put them, so that the document can find them. For example, you might keep images in a subfolder named Images (under the folder containing the document); the recipient of the file needs to put the images in a subfolder with the same name and in the same place relative to the document.

### Note

When inserting the same image several times in the document, LibreOffice embeds only one copy of the image file.

**Embedding linked images**

If you originally linked the images, you can easily embed one or more of them later if you wish.

![Edit Links dialog](image)

*Figure 2: The Edit Links dialog*
1) Open the document in LibreOffice and choose Edit > Links to External Files.
2) In the Edit Links dialog (Figure 2), select the files you want to change from linked to embedded.
3) Click the Break Link button and then click Yes to confirm embedding the image.

**Inserting an image using a scanner**

If a scanner is connected to your computer, LibreOffice can call the scanning application and insert the scanned item into your document as an image. To start this procedure, choose Insert > Media > Scan > Select Source on the Menu bar. Select the scan source from the list of available devices, then click in the document where you want the graphic to be inserted, and choose Insert > Media > Scan > Request to open the imaging software where you can adjust settings for image quality, size, and other attributes.

Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct size. You may get better results by scanning material into a graphics program and cleaning it up there before inserting the resulting image into LibreOffice.

**Inserting an image from the Gallery**

The Gallery (Figure 3) provides a convenient way to group reusable objects such as graphics and sounds that you can insert into your documents. The Gallery is available in the Writer, Calc, Impress, and Draw components of LibreOffice. See “Managing the LibreOffice Gallery” on page 12. You can copy or link an object from the Gallery into a document.

![Figure 3: The Gallery in Icon View](image)

To insert an object from the Gallery into a document:

1) Click the Gallery icon on the Sidebar.
2) Select a theme in the list provided, and select an object with a single click.
3) Drag and drop the image into the document, or right-click on the object and choose **Insert** in the context menu.

To insert an object as a link, hold down the **Shift** and **Ctrl** keys and drag and drop the object into the document.

**Modifying, handling, and positioning images**

LibreOffice provides many tools for cropping, resizing, modifying, filtering, and positioning images; wrapping text around images; and using images as backgrounds and watermarks. These tools are described in relevant chapters of the other guides. Some sophisticated adjustments are best done in an image manipulation program and the results brought into LibreOffice, rather than using LibreOffice’s built-in tools.

**Using the Image toolbar**

When you insert an image or select one already present in the document, the Image toolbar appears. Two other toolbars can be opened from this one: the Image Filter toolbar, which can be torn off and placed elsewhere on the window, and the Color toolbar, which opens as a separate floating toolbar. From these three toolbars, you can apply small corrections to the image or obtain special effects: transparency, color adjustment, flipping and rotating, and applying special-effects filters. For more information, see the **Writer Guide**.

**Cropping images**

When you are only interested in a section of the image for the purpose of your document, you may wish to crop (cut off) parts of it. LibreOffice provides two ways to crop an image: the **Crop** tool and the **Crop** tab of the Image dialog in Writer (accessed by right-clicking on the image and selecting **Properties** in the context menu). The Crop tool provides a quick and easy way to crop an image; but for more control, use the Image dialog. For more information, see the **Writer Guide**.

**Note**

If you crop an image in LibreOffice, the image itself is not changed. LibreOffice hides, but does not cut off, part of the image. If you export the document to HTML, the original image is exported, not the cropped image. For exporting individual cropped images, see “Exporting (saving) images” on page 10.

**Resizing an image**

To fit the image into your document, you may need to resize it. A quick and easy way to resize is by dragging the image’s sizing handles:

1) Click the image, if necessary, to show the sizing handles.
2) Position the pointer over one of the sizing handles. The pointer changes shape, giving a graphical representation of the direction of the resizing.
3) Click and drag to resize the image.

**Tip**

The corner handles resize both the width and the height of the image simultaneously, while the other four handles resize only one dimension at a time. To retain the original proportions of the image, hold down the **Shift** key while dragging one of these handles.

For more accurate resizing of images, use the **Type** tab of the Image dialog.
Rotating or flipping an image

To quickly flip an image vertically or horizontally, or rotate it, right-click the image and select **Rotate or Flip** in the context menu, then choose the desired option in the submenu.

Writer provides more rotation options than the other LibreOffice components. See the **Writer Guide** for more information.

Other settings

The Image dialog in Writer has ten tabs:

- **Type**: define the size and anchor of the image and its position on the page.
- **Options**: give the image a descriptive name, define the alternative text to be displayed when the mouse hovers over the image, and protect some of the image settings from changes.
- **Wrap**: choose how text wraps around the image, and the spacing between the image and the text.
- **Hyperlink**: associate a hyperlink to the image, or create an image map.
- **Image**: flip or rotate the image, and display the original location of the file in case the image is linked rather than embedded.
- **Crop**: cut off portions of the image, scale it and set its size.
- **Borders**: create borders around the image and add a shadow.
- **Area**: change the background (color, bitmap, gradient, pattern, or hatching) of the image. This setting produces the desired results only for images with a transparent color.
- **Transparency**: set the transparency and gradient options for the image.
- **Macro**: associate a macro to the image. You can choose among the predefined macros or write your own.

Exporting (saving) images

To make complex adjustments to the image in another program, or to save the image for use in another document, you can export it directly from the document. Right-click on the image and choose **Save** in the context menu to open the Image Export dialog. LibreOffice will let you save the picture in several formats. Name the image, select the desired image format in the File type list, and click **Save**.

Before the image is saved another dialog opens, where you can choose various image size and format options. The content of this dialog depends on the output file type selected. If the image has been modified within Writer, you will also see a confirmation dialog where you can choose to save the original version or the modified version of the image.

Compressing images

If you insert a large image in a document and resize it to fit into the layout of the page, the complete full-size original image is stored in the document file to preserve its content, possibly resulting in a large document file to store or send by mail.

If you can accept some loss of quality of the image rendering or want to resize it, you can compress or resize the image object to reduce its data volume while preserving its display in the page layout.

Right-click to select the image and open the context menu. Then choose **Compress** to open the Compress Image dialog (Figure 4). Use the **Calculate New Size** button to update the image information on the dialog on each parameter set you change.
Click **OK** to apply the compression settings. If the resulting image is not acceptable, press **Ctrl+Z** to undo and choose another compression setting. For more information, see the Help.

![Image of Compress Image dialog]

*Figure 4: The Compress Image dialog*

**Positioning images**

When you add an image to a document, you need to choose how to position it with respect to the text and other images. For details, see the relevant component guide (Writer, Calc, and so on).

Positioning is controlled by four settings:

- **Arrangement** refers to the placement of an image on an imaginary vertical axis. Arrangement controls how images are stacked upon each other or relative to the text.
- **Alignment** refers to the vertical or horizontal placement of an image in relation to the chosen anchor point.
- **Anchoring** refers to the reference point for the images. This point could be the page, the frame or cell where the object is, a paragraph, or even a character. An image always has an anchor point.
- **Text wrapping** in a Writer document refers to the relation of images to the surrounding text, which may wrap around the image on one or both sides, be overprinted behind or in front of the image, or treat the image as a separate paragraph or character.

In Writer, the settings can be accessed in several ways, depending on the nature of the graphic:

- In the **Format** menu: **Anchor**, **Wrap**, and **Arrange** (for images and drawing objects).
- In the context menu displayed when you right-click the graphic; this menu also includes an **Align** option.
- For images, on the **Type** and **Wrap** tabs of the Image dialog. Note that you cannot control the arrangement using the dialog.
- For drawing objects, on the **Position and Size** tab of the Position and Size dialog.
- For an embedded object (such as a Calc spreadsheet or Draw document), on the OLE-Object toolbar.
Adding captions to images
You can add captions to Writer images in three ways: automatically, by using the Caption dialog, or manually. See the Writer Guide for details.

Managing the LibreOffice Gallery
Graphics in the Gallery are grouped by themes, such as Arrows, Diagrams, and Icons. You can create other groups or themes and add your own pictures or find extensions containing more graphics. Click on a theme to see its contents displayed in the Gallery window.

You can display the Gallery in Icon View (Figure 3) or Detailed View (Figure 5), and you can hide or show the Gallery by clicking on the Sidebar’s Hide button.

Figure 5: Gallery in Detailed View

Note
The default themes supplied with LibreOffice can not be customized, although new themes can be added; see "Adding a new theme to the Gallery" below. The locked themes are easily recognizable by right-clicking on them; the only option in the context menu is Properties.

Adding a new theme to the Gallery
You may wish to add your own theme to the Gallery to hold any images or other objects that you use frequently, for example, a company logo. Or you may wish to add several themes, each holding images for a specific project.

To add a new theme to the Gallery:
1) Click the New button below the list of themes (Figure 5).
2) In the Properties of New Theme dialog, click the General tab and type a name for the new theme.

3) Click the Files tab and add images to the theme, as described below.

**Tip**

You can also get more gallery themes from the LibreOffice extensions website at [https://extensions.libreoffice.org/](https://extensions.libreoffice.org/), including themes from previous versions of LibreOffice, that are no longer installed by default with the program. See Chapter 14, Customizing LibreOffice, for instructions on how to manage extensions.

**Adding objects to the Gallery**

To add objects to a theme that you have created:

1) Right-click on the name of the theme and select Properties in the context menu.

2) In the theme's Properties dialog, click the Files tab (Figure 6).

![Figure 6: Gallery Properties dialog](image)

To add several files at once:

1) In the Properties dialog, click the Find Files button.

2) The Select Path dialog (not shown) opens. You can enter the path for the file's directory in the path text box, or you can navigate to locate the file's directory.

3) Click the Select button to start the search. A list of files is then displayed in the Properties dialog. You can use the file type drop-down list to limit the files displayed.

4) To add all of the files shown in the list, click Add All. Otherwise, select the files to add and then click Add (hold down either the Shift key or the Ctrl key while clicking on the files).

To add a single file:

1) In the Properties dialog, click Add to open the Gallery dialog.

2) Use the navigation controls to locate the image to add to the theme. Select it and then click Open to add it to the theme.

3) Click OK on the Properties dialog to close it.

**Deleting images and themes from the Gallery**

To delete an image from a theme, right-click on the name of the image file or its thumbnail in the Gallery, then click Delete in the context menu. A message appears, asking if you want to delete this object. Click Yes.
To delete a theme from the Gallery, select it from the list of themes, right-click, then click **Delete** in the context menu. You cannot delete a theme supplied with LibreOffice.

**Note**

Deleting the name of a file from the list in the Gallery does not delete the file from the hard disk or other location.

**Location of the Gallery and the objects in it**

Graphics and other objects shown in the Gallery can be located anywhere on your computer’s hard disk, on a network drive, or other removable media. When you add graphics to the Gallery, the files are not moved or copied; the location of each new object is simply added as a reference.

In a workgroup, you may have access to a shared Gallery (where you cannot change the contents unless authorized to do so) and a user Gallery, where you can add, change, or delete objects.

The location of the user Gallery is specified in **Tools > Options > LibreOffice > Paths**. You can change this location, and you can copy your gallery files (*.sdv) to other computers.

Gallery contents provided with LibreOffice are stored in a different location. You cannot change this location.

**Note**

The locations of Gallery themes distributed through LibreOffice extensions are determined by the extensions’ settings.

**Creating an image map**

An image map defines areas of an image (called hotspots) with hyperlinks to web addresses, other files on the computer, or parts of the same document. Hotspots are the graphic equivalent of text hyperlinks (described in Chapter 12, Creating HTML Files). Clicking on a hotspot causes LibreOffice to open the linked page in the appropriate program (for example, the default browser for an HTML page; LibreOffice Calc for an ODS file; a PDF viewer for a PDF). You can create hotspots of various shapes and include several hotspots in the same image.

To use the image map editor:

1) In the LibreOffice document, click on the image in which you want to define the hotspots.

2) **Choose Tools > ImageMap** on the Menu bar. The ImageMap Editor dialog (Figure 7) opens. The main part of the dialog shows the image on which the hotspots are defined.

3) **Use the tools and fields in the dialog (described below) to define the required hotspots and links.** A hotspot is identified by a line indicating its shape. The information needed for the hotspot includes the address pointed to by the hyperlink and the text you want to be displayed when the mouse pointer is moved over the hotspot.

4) **Click the Apply icon** to apply the settings.

5) When done, **click the Save icon** to save the image map to a file, then close the dialog.
The dialog at the top of the dialog contains the following tools:

- **Apply**: applies the changes.
- **Open, Save, Close, and Select**.
- **Rectangle, Ellipse, Polygon, and Freeform Polygon**: tools for drawing a hotspot shape. These tools work in the same way as the tools in the Drawing toolbar.
- **Edit, Move, Insert, Delete Points**: advanced editing tools to manipulate the shape of a polygon hotspot. Select the **Edit Points** tool to activate the other tools.
- **Undo** and **Redo**: cancels the previous action or reappplies the previous canceled action.
- **Active**: toggles the status of a selected hotspot between active and inactive.
- **Macro**: associates a macro with the hotspot instead of just associating a hyperlink.
- **Properties**: sets the hyperlink properties and adds the Name attribute to the hyperlink.

Below the toolbar, specify for the selected hotspot:

- **Address**: the address pointed to by the hyperlink. You can also point to an anchor in a document; to do this, write the address in this format: file:///<path>/document_name#anchor_name
- **Text**: type the text that you want to be displayed when the cursor is moved over the hotspot.
- **Frame**: where the target of the hyperlink will open: pick among _blank (opens in a new browser window), _self (opens in the active browser window), _top or _parent.

**Tip**

The value _self for the target frame will work in the vast majority of occasions. It is therefore not recommended to use the other choices unless absolutely necessary.
Using LibreOffice's drawing tools

You can use LibreOffice's drawing tools to create graphics such as simple diagrams using rectangles, circles, lines, text, and other predefined shapes. You can also group several drawing objects to make sure they maintain their relative position and proportion.

You can place the drawing objects directly on a page in the document or insert them into a frame. You can also use the drawing tools to annotate photographs, screen captures, or other illustrations produced by other programs, but this is not recommended because:

- You cannot include images in a group with drawing objects, so they may not remain aligned in your document.
- If you convert a document to another format, such as HTML, the drawing objects and the images will not remain associated; they are saved separately.

In general, if you need to create complex drawings, it is recommended to use LibreOffice Draw, which includes many more features, such as layers and styles.

Creating drawing objects

To begin using the drawing tools, display the Drawing toolbar (Figure 8) by clicking View > Toolbars > Drawing or by clicking on the Show Draw Functions icon on the Standard toolbar.

Tip

If you are planning to use the drawing tools repeatedly, you can tear off (undock) this toolbar and move it to a convenient place as a floating toolbar in the window.

To use a drawing tool:

1) Click in the document where you want the drawing to be anchored. You can change the anchor later, if necessary.

2) Choose the tool on the Drawing toolbar (Figure 8). The mouse pointer changes to a drawing-functions pointer and the normal Formatting toolbar changes to Drawing Object Properties toolbar (Figure 9).

3) Move the cross-hair pointer to the place in the document where you want the graphic to appear and then click and drag to create the drawing object. Release the mouse button. The selected drawing function remains active, so that you can draw another object of the same type.

4) To cancel the selected drawing function, press the Esc key or click on the Select icon (the arrow at the left-hand end of the Drawing toolbar).
5) You can now change the properties (fill color, line type and weight, anchoring, and others) of the drawing object using either the Drawing Object Properties toolbar (Figure 9) or the choices and dialogs reached by right-clicking on the drawing object.

**Setting or changing properties for drawing objects**

To set the properties for a drawing object before you draw it:

1) On the Drawing toolbar (Figure 8), click the **Select** tool.
2) On the Drawing Object Properties toolbar (Figure 9), click on the icon for each property and select the value you want for that property.
3) For more control, or to define new attributes, you can click on the **Area** or **Line** icons on the toolbar to display detailed dialogs.

The default you set applies to the current document and session. It is not retained when you close the document or close LibreOffice, and it does not apply to any other document you open. The defaults apply to all the drawing objects except text objects.

To change the properties for an existing drawing object, select the object and continue as described above.

You can also specify the position and size, rotation, and slant and corner radius properties of the drawing object: right-click on the drawing object and then choose **Position and Size** in the context menu. Choose any properties, as required.

![Figure 9: Drawing Object Properties toolbar](image)

1 Line Color 8 Wrap Off 15 Align 22 Group
2 Arrow Style 9 Page Wrap 16 Bring to Front 23 Enter Group
3 Line Style 10 Optimal Page Wrap 17 Forward One 24 Exit Group
4 Line Width 11 Wrap Left 18 Back One 25 Ungroup
5 Area Style/Filling 12 Wrap Right 19 Send to Back 26 Insert Caption
6 Fill Color 13 Wrap Through 20 To Foreground
7 Anchor 14 Rotate 21 To Background

**Resizing a drawing object**

An object is resized in a similar way to an image. Select the object, click on one of the eight handles around it and drag it to its new size. The object will be scaled up or down. When you grab the handle of an object and drag it, LibreOffice will resize disproportionately; if you also press the **Shift** key, the resizing will keep object proportions.

For more sophisticated control of the size of the object, right-click on the object and choose **Position and Size** in the context menu. Use the **Position and Size** tab to set the position and size independently. If the **Keep ratio** option is selected, then the two dimensions change so that the proportion is maintained, resulting in a scaled resizing.
Grouping drawing objects

Grouping drawing objects makes it easier to handle several objects as a single entity, while preserving their relative sizes and positions. When objects are grouped, any editing operations carried out on that group are applied to all members of the group. If you click on one member of the group, the whole group is selected.

To group drawing objects:

1) Select one object, then hold down the Shift key and select the others you want to include in the group. The bounding box expands to include all the selected objects.

2) With the objects selected, hover the mouse pointer over one of the objects and choose Format > Group > Group on the Menu bar, or click the Group icon on the Drawing Object Properties toolbar, or right-click and choose Group in the context menu.

Note

You cannot include an embedded or linked image in a group with drawing objects.

You can edit an individual member of a group without ungrouping or breaking the group. Select the group and go to Format > Group > Enter Group on the Menu bar, or right-click and select Enter Group in the context menu, or click the Enter Group icon on the Drawing Object Properties toolbar. When you have finished editing an individual member of a group, go to Format > Group > Exit Group on the Menu bar, or right-click and select Exit Group in the context menu, or click the Exit Group icon on the Drawing Object Properties toolbar.

To ungroup or break apart a group of objects, select the group then go to Format > Group > Ungroup on the Menu bar, or right-click and select Ungroup in the context menu, or click the Ungroup icon on the Drawing Object Properties toolbar.

Using Fontwork

With Fontwork you can create graphical text art objects to make your work more attractive. There are many different settings for text art objects (line, area, position, size, and more), so you have a large choice.

Fontwork is available with the Writer, Calc, Impress, and Draw components of LibreOffice, but you will notice small differences in the way that each component displays it.

Creating a Fontwork object

1) On the Fontwork toolbar (View > Toolbars > Fontwork) or the Drawing toolbar (View > Toolbars > Drawing), click the Fontwork Gallery icon, or choose Insert > Fontwork on the Menu bar.

2) In the Fontwork Gallery dialog (Figure 10), select a Fontwork style (scroll down to see more choices), then click OK.

   The Fontwork object will appear in your document. Notice the squares around the edge (indicating that the object is selected) and the differently colored dot; these are discussed in "Moving and resizing Fontwork objects" on page 21.

3) Resize the object using one of the corner handles (hold down the Shift key to keep the sides proportional), or right-click and choose Position and Size in the context menu for more precise sizing.
4) Double-click the object to edit the Fontwork text (Figure 11). Type your own text in place of the black text that appears over the object.

5) Click anywhere in a free space or press Esc to apply your changes.

**Editing a Fontwork object**

Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use the Fontwork toolbar, the Fontwork panel on the Properties deck on the Sidebar, the Formatting toolbar, or menu options as described in this section. If the selected Fontwork object is a 3-D object, you can also use the 3D-Settings toolbar.

**Using the Fontwork toolbar**

Make sure that the Fontwork toolbar, shown in Figure 12, is visible. If you do not see it, go to View > Toolbars > Fontwork. Click on the different icons to edit Fontwork objects. Icons 2–6 also appear in the Fontwork panel on the Properties deck on the Sidebar.
1 **Fontwork Gallery**: Opens the Fontwork Gallery (Figure 10).

2 **Fontwork Shape**: Edits the shape of the selected object. You can choose from a palette of shapes.

3 **Fontwork Same Letter Heights**: Changes the height of characters in the object. Toggles between normal height (some characters taller than others, for example capital letters, d, h, l and others) and all letters the same height.

4 **Fontwork Alignment**: Changes the alignment of characters. Choices are *Left Align, Center, Right Align, Word Justify,* and *Stretch Justify.* The effects of the text alignment can only be seen if the text spans over two or more lines. In the Stretch Justify mode, all the lines are filled completely.

5 **Fontwork Character Spacing**: Changes the character spacing and kerning in the object. Select from the choices in the drop-down list. Choices are *Very Tight, Tight, Normal, Loose, Very Loose,* and *Custom...*, which opens a small dialog where you can specify a percentage.

6 **Toggle Extrusion**: changes a 2D Fontwork object into a 3D object or a 3D object into a 2D object.
Using the Formatting toolbar
You can customize the Fontwork object with several more attributes. Click on the object; the Formatting toolbar changes to show the options for customizing the object. These choices are the same as the ones for other drawing objects, described earlier in this chapter. See also the Draw Guide for details.

Using menu options
You can use some of the choices on the Format menu to anchor, align, arrange, and group selected Fontwork objects, wrap text around them, and flip them horizontally and vertically.

You can also right-click on a Fontwork object and choose many of the same options in the context menu. The context menu also provides quick access to the Line, Area, and Position and Size dialogs. On the Position and Size dialog, you can enter precise values for size and position. For more information on all of these menu options, see the Draw Guide.

Using the 3D-Settings toolbar
If the selected Fontwork object is a 3-D object, you can also use the options on the 3D-Settings toolbar. You can also change a 2-D Fontwork object into a 3-D object (or change a 3-D object into a 2-D object) by clicking the Toggle Extrusion icon on the Fontwork toolbar. For more information, see the Draw Guide.

Moving and resizing Fontwork objects
When you select a Fontwork object, eight colored squares (known as handles) appear around the edge of the object, as shown below. You can drag these handles to resize the object.

A dark or colored dot also appears on the object. This dot may be in the same place as a handle, or it may be somewhere else. If you hover the cursor over this dot, the cursor changes shape. You can drag the dot in different directions to distort the object.

Hovering the cursor over other parts of the object turns the cursor into the usual symbol for dragging the object to another part of the page.

For precise control of the location and size of the object, and to rotate the object, use the Position and Size dialog.

![Figure 14: Handles and distortion dot on Fontwork object](image)
Generating a QR code

A QR code (short for Quick Response code) is a type of barcode. QR codes often contain data that points to a website or application. Writer, Calc, Impress, and Draw can generate QR codes.

1) Choose **Insert > Object > QR Code** on the Menu bar to open the QR Code Generator dialog (Figure 15).

2) Fill in the **URL/Text** field, select a correction factor (the complexity of the graphic generated), and the width of the border around it, then click **OK**. Figure 16 shows the code generated by the input in Figure 15.

![QR Code Generator dialog](image1.png)

![QR code example](image2.png)

After the QR code has been generated, you can edit it by right-clicking in the code and selecting **Edit QR Code**.