Copyright
This document is Copyright © 2022 by the LibreOffice Documentation Team. Contributors are
listed below. You may distribute it and/or modify it under the terms of either the GNU General
Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative
Commons Attribution License (https://creativecommons.org/licenses/by/4.0/), version 4.0 or later.
All trademarks within this guide belong to their legitimate owners.

Contributors
To this edition
Jean Hollis Weber
Vasudev Narayanan

Kees Kriek

Peter Schofield

Rafael Lima
Steve Fanning
Amanda Labby
Dave Barton
Olivier Hallot
Kees Kriek
Dave Barton
Kevin O’Brien
JiHui Choi
Christian Kühl
Jochen Schiffers
Miklos Vajna
Claire Wood

Felipe Viggiano
Jean Hollis Weber
Cathy Crumbley
Pulkit Krishna
Paul Figueiredo
Martin Saffron
Hazel Russman
Magnus Adielsson
Regina Henschel
Florian Reisinger
Frédéric Parrenin
Valerii Goncharuk
John A Smith

To previous editions
Mitchell Camfield
Rafael Lima
Andrew Jensen
Dan Lewis
Jorge Rodriguez
Peter Schofield
Steve Schwettman
Ron Faile Jr.
Iain Roberts
Laurent Balland-Poirier
Gisbert Friege (Dmaths)
Bernard Siaud
Andrew Pitonyak
Roman Kuznetsov

Feedback
Please direct any comments or suggestions about this document to the Documentation Team’s
mailing list: documentation@global.libreoffice.org

Note
Everything you send to a mailing list, including your email address and any other
personal information that is written in the message, is publicly archived and cannot
be deleted.

Publication date and software version
Published February 2022. Based on LibreOffice 7.3 Community.
Other versions of LibreOffice may differ in appearance and functionality.

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/

Contents
Copyright................................................................................................................................... 2

Preface...............................................................................................................................9
Who is this book for?............................................................................................................... 10
What is in this book?............................................................................................................... 10
Where to get more help........................................................................................................... 10
What you see may be different................................................................................................12
Using LibreOffice on macOS...................................................................................................12
What are all these things called?............................................................................................13
Frequently asked questions....................................................................................................14
What is new in LibreOffice 7.3 Community?............................................................................15

Chapter 1 Introducing LibreOffice.................................................................................16
What is LibreOffice?................................................................................................................ 17
Advantages of LibreOffice.......................................................................................................18
Minimum requirements............................................................................................................ 19
How to get the software.......................................................................................................... 19
How to install the software......................................................................................................19
Extensions and add-ons.......................................................................................................... 19
Starting LibreOffice................................................................................................................. 20
Parts of the main window........................................................................................................21
Starting new documents.......................................................................................................... 27
Opening existing documents...................................................................................................27
Saving documents................................................................................................................... 28
Using password protection and OpenPGP encryption.............................................................29
Saving documents automatically.............................................................................................31
Opening and saving files on remote servers...........................................................................31
Using the Navigator................................................................................................................. 32
Displaying multiple view of a document...................................................................................33
Undoing and redoing changes................................................................................................33
Reloading a document............................................................................................................ 34
Using document properties.....................................................................................................34
Classifying document contents................................................................................................36
Closing a document................................................................................................................ 36
Closing LibreOffice.................................................................................................................. 36
Problem solving using Safe Mode...........................................................................................37

Chapter 2, Setting up LibreOffice..................................................................................39
Introduction............................................................................................................................. 40
Choosing options for all of LibreOffice.....................................................................................40
Choosing options for loading and saving documents..............................................................53
Choosing language settings....................................................................................................58
Choosing Internet options.......................................................................................................63
Controlling LibreOffice’s AutoCorrect functions.......................................................................64

LibreOffice 7.3 Getting Started Guide | 3

Chapter 3, Styles and Templates...................................................................................65
Introduction............................................................................................................................. 66
What are styles?..................................................................................................................... 66
Applying styles........................................................................................................................ 67
Modifying styles...................................................................................................................... 70
Creating new (custom) styles..................................................................................................72
Copying styles from a template or document (Writer)..............................................................74
Renaming styles..................................................................................................................... 74
Deleting styles......................................................................................................................... 74
Using the Style Inspector (Writer)............................................................................................75
What are templates? Why use them?.....................................................................................75
Creating a document from a template.....................................................................................76
Creating a template.................................................................................................................77
Adding templates obtained from other sources.......................................................................78
Editing a template................................................................................................................... 80
Changing the template assigned to a document.....................................................................80
Setting a default template....................................................................................................... 81
Organizing templates.............................................................................................................. 82
Other ways to manage templates............................................................................................84
Examples of style use.............................................................................................................84

Chapter 4, Getting Started with Writer..........................................................................86
What is Writer?........................................................................................................................ 87
The Writer interface.................................................................................................................87
Changing document views......................................................................................................91
Working with documents......................................................................................................... 92
Working with text..................................................................................................................... 94
Formatting text...................................................................................................................... 104
Formatting pages................................................................................................................... 111
Adding comments to a document..........................................................................................116
Using built-in language tools.................................................................................................117
Creating a table of contents...................................................................................................118
Creating indexes and bibliographies......................................................................................119
Using footnotes and endnotes...............................................................................................119
Inserting material from other documents...............................................................................120
Working with images (graphics)............................................................................................120
Working with tables............................................................................................................... 120
Printing and exporting to PDF or EPUB................................................................................121
Using mail merge..................................................................................................................121
Tracking changes to a document..........................................................................................121
Using fields........................................................................................................................... 122
Linking and cross-referencing within a document..................................................................122
Using master documents.......................................................................................................124
Creating fill-in forms..............................................................................................................124

4 | LibreOffice 7.3 Getting Started Guide

Chapter 5, Getting Started with Calc...........................................................................125
What is Calc?........................................................................................................................ 126
Compatibility with other spreadsheet applications.................................................................126
Spreadsheets, sheets, and cells...........................................................................................127
Calc main window................................................................................................................. 127
Opening a CSV file................................................................................................................ 131
Saving spreadsheets............................................................................................................. 132
Importing external data – Web Query....................................................................................135
Navigating within spreadsheets.............................................................................................136
Selecting items in a spreadsheet..........................................................................................138
Working with columns and rows............................................................................................140
Working with sheets.............................................................................................................. 142
Viewing a spreadsheet.......................................................................................................... 144
Entering data using the keyboard..........................................................................................146
Speeding up data entry......................................................................................................... 151
Sharing content between sheets...........................................................................................154
Validating cell contents.......................................................................................................... 154
Editing data........................................................................................................................... 154
Formatting data..................................................................................................................... 157
AutoFormatting of cells......................................................................................................... 161
Using themes........................................................................................................................ 162
Using conditional formatting..................................................................................................163
Filtering data......................................................................................................................... 163
Cell protection....................................................................................................................... 164
Sorting records...................................................................................................................... 165
Cell comments...................................................................................................................... 166
Using formulas and functions................................................................................................166
Analyzing data...................................................................................................................... 167
Pivot tables and pivot charts.................................................................................................167
Printing.................................................................................................................................. 168

Chapter 6, Getting Started with Impress.....................................................................172
What is Impress?.................................................................................................................. 173
Starting Impress.................................................................................................................... 173
Main Impress window............................................................................................................ 174
Workspace views.................................................................................................................. 180
Creating presentations.......................................................................................................... 183
Adding and formatting text....................................................................................................189
Inserting images, tables, charts, or media.............................................................................197
Working with master slides....................................................................................................202
Adding comments................................................................................................................. 209
Printing handouts.................................................................................................................. 212
Creating a photo album.........................................................................................................212
Presentations (slide shows)..................................................................................................213

LibreOffice 7.3 Getting Started Guide | 5

Chapter 7, Getting Started with Draw..........................................................................222
What is Draw?....................................................................................................................... 223
Draw main window................................................................................................................224
Drawing basic shapes...........................................................................................................227
Glue points and connectors...................................................................................................234
Geometric shapes................................................................................................................. 236
Adding and formatting text....................................................................................................238
Selecting objects................................................................................................................... 241
Positioning and adjusting objects..........................................................................................242
Grouping and combining multiple objects..............................................................................248
Inserting and exporting images.............................................................................................250
Working with 3D objects........................................................................................................251
Working with layers............................................................................................................... 251
Selecting colors..................................................................................................................... 253
Adding comments to a drawing.............................................................................................255

Chapter 8, Getting Started with Base..........................................................................256
Introduction........................................................................................................................... 257
Planning a database.............................................................................................................258
Creating a new database......................................................................................................258
Creating database tables......................................................................................................261
Creating a database form......................................................................................................272
Modifying a form....................................................................................................................276
Entering data in a form..........................................................................................................288
Creating queries....................................................................................................................291
Creating reports.................................................................................................................... 299
Accessing other data sources...............................................................................................303
Using data sources in LibreOffice..........................................................................................304

Chapter 9, Getting Started with Math..........................................................................309
Introduction........................................................................................................................... 310
Getting started...................................................................................................................... 310
Creating formulas..................................................................................................................312
Editing formulas.................................................................................................................... 316
Formula layout...................................................................................................................... 317
Changing formula appearance..............................................................................................323
Formula library...................................................................................................................... 330
Formulas in Writer................................................................................................................. 331
Formulas in Calc, Draw, and Impress....................................................................................337
Customization....................................................................................................................... 338
Exporting and Importing........................................................................................................343

Chapter 10, Printing, Exporting, Emailing and Signing Documents........................344
Quick printing........................................................................................................................ 345
Controlling printing................................................................................................................345
Previewing pages/sheets before printing...............................................................................354
Exporting to PDF................................................................................................................... 355
6 | LibreOffice 7.3 Getting Started Guide

Exporting to EPUB format (Writer only).................................................................................362
Exporting to other formats.....................................................................................................363
Emailing documents.............................................................................................................. 364
Digital signing of documents.................................................................................................364
Removing personal data.......................................................................................................367
Redaction.............................................................................................................................. 367

Chapter 11, Images and Graphics...............................................................................369
Introduction........................................................................................................................... 370
Creating and editing images..................................................................................................370
Adding images to a document...............................................................................................370
Modifying, handling, and positioning images.........................................................................374
Managing the LibreOffice Gallery..........................................................................................377
Creating an image map.........................................................................................................379
Using LibreOffice’s drawing tools..........................................................................................381
Using Fontwork..................................................................................................................... 383
Generating a barcode or QR code........................................................................................387

Chapter 12, Creating HTML Files.................................................................................388
Introduction........................................................................................................................... 389
Relative and absolute hyperlinks...........................................................................................389
Creating hyperlinks............................................................................................................... 390
Saving and exporting documents as HTML files....................................................................395
Creating, editing, and saving HTML files using Writer/Web...................................................401
Checking a web page in a browser.......................................................................................403

Chapter 13, Getting Started with Macros....................................................................404
Introduction........................................................................................................................... 405
Your first macros................................................................................................................... 405
Creating a macro................................................................................................................... 413
Limitations of the macro recorder..........................................................................................418
Macro organization................................................................................................................ 419
How to run a macro............................................................................................................... 422
Using extensions................................................................................................................... 424
Writing macros without the recorder......................................................................................425
The ScriptForge library.......................................................................................................... 427
UNO Object Inspector........................................................................................................... 428
Overview of Python, BeanShell, and JavaScript macros.......................................................430
Finding more information.......................................................................................................435

Chapter 14, Customizing LibreOffice..........................................................................437
Introduction........................................................................................................................... 438
Customizing menu content....................................................................................................438
Customizing toolbars............................................................................................................. 441
Customizing user interface variants......................................................................................443
Assigning shortcut keys........................................................................................................ 444
Assigning macros to events..................................................................................................446
Adding functionality with extensions......................................................................................446
LibreOffice 7.3 Getting Started Guide | 7

Adding custom colors............................................................................................................ 448
Adding fonts.......................................................................................................................... 449
User interface variants.......................................................................................................... 449

Appendix A Keyboard Shortcuts.................................................................................455
Introduction........................................................................................................................... 456
Assistive tools in LibreOffice.................................................................................................457
Information for macOS users................................................................................................458
Keyboard shortcuts...............................................................................................................458
Sidebar keyboard shortcuts...................................................................................................463
Database table keyboard shortcuts.......................................................................................464
Controlling macros................................................................................................................464
Entering Unicode numbers....................................................................................................465
Defining keyboard shortcuts..................................................................................................465
Further reading..................................................................................................................... 465

Appendix B, Open Source, Open Standards, OpenDocument.................................466
Introduction........................................................................................................................... 467
A short history of LibreOffice.................................................................................................467
The LibreOffice community...................................................................................................467
How is LibreOffice licensed?.................................................................................................468
What is open source?...........................................................................................................468
What are open standards?....................................................................................................468
What is OpenDocument?......................................................................................................468
File formats LibreOffice can open..........................................................................................469
File formats LibreOffice can save to......................................................................................471
Exporting to other formats.....................................................................................................472

8 | LibreOffice 7.3 Getting Started Guide

Getting Started Guide 7.3

Preface

Preface | 9

Who is this book for?
Anyone who wants to get up to speed quickly with LibreOffice will find this Getting Started Guide
valuable. You may be new to office software, or you may be familiar with another office suite.

What is in this book?
This book introduces the main components of LibreOffice:
•

Writer (word processing)

•

Calc (spreadsheets)

•

Impress (presentations)

•

Draw (vector graphics)

•

Base (database)

•

Math (equation editor)

It also covers some of the features common to all components, including setup and
customization, styles and templates, macro recording, and printing. For more detail, see the user
guides for the individual components.

Where to get more help
This book, the other LibreOffice user guides, the Help system, and user support systems assume
that you are familiar with your computer and basic functions such as starting a program, opening
and saving files.

Help system
LibreOffice comes with an extensive online Help system. This is your first line of support.
Windows and Linux users can choose to download and install the offline Help for use when not
connected to the Internet; the offline Help is installed with the program on macOS.
To display the Help system, press F1 or select Help > LibreOffice Help on the Menu bar. If you
do not have the offline help installed on your computer and you are connected to the Internet,
your default browser will open the online Help pages on the LibreOffice website.
The Help menu also includes links to other LibreOffice information and support resources. The
options marked by a ‡ sign in the list below are only accessible if your computer is connected to
the Internet.
•

What's This? For quick tips when a toolbar is visible, place the mouse pointer over any of
the icons to see a small box (“tooltip”) with a brief explanation of the icon’s function. For a
more detailed explanation, select Help > What's This? and hold the pointer over the
icon. In addition, you can choose whether to activate Extended Tips using Tools >
Options > LibreOffice > General.

•

User Guides ‡ Opens your default browser at the Documentation page of the LibreOffice
website, https://documentation.libreoffice.org/en/english-documentation/. There you will
find copies of user guides and other useful information.

•

Show Tip of the Day Opens a small window with a random tip on how to use LibreOffice.

•

Search Commands Opens a window where you can type a few letters or the name of a
Menu bar command, to quickly find where the command is located. Clicking on a
command in the resulting list may open a relevant dialog or have other effects.
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•

Get Help Online ‡ Opens your default browser at the Ask LibreOffice forum of questions
and answers from the LibreOffice community, https://ask.libreoffice.org/en/questions/.

•

Send Feedback ‡ Opens your default browser at the Feedback page of the LibreOffice
website, https://www.libreoffice.org/get-help/feedback/. From there you can report bugs,
suggest new features and communicate with others in the LibreOffice community.

•

Restart in Safe Mode Opens a dialog where you can restart LibreOffice and reset the
software to its default settings.

•

Get Involved ‡ Opens your default browser at the Get Involved page of the LibreOffice
website, https://www.libreoffice.org/community/get-involved/. There you can choose a
topic of interest to help improve the program.

•

Donate to LibreOffice ‡ Opens your default browser at the Donation page of the
LibreOffice website, https://donate.libreoffice.org/. There you can choose to make a
donation to support LibreOffice.

•

License Information Outlines the licenses under which LibreOffice is made available.

•

Check for Updates ‡ Opens a dialog and checks the LibreOffice website for updates to
your version of the software.

•

About LibreOffice Opens a dialog and displays information about the version of
LibreOffice and the operating system you are using. This information will often be
requested if you ask the community for help or assistance with the software. (On macOS,
this item is under LibreOffice on the Menu bar.)

Other free online support
The LibreOffice community not only develops software, but provides free, volunteer-based
support. In addition to the Help menu links above, there are other online community support
options available, see the table below.
Free LibreOffice support
FAQs

Answers to frequently asked questions
https://wiki.documentfoundation.org/Faq

Mailing lists

Free community support is provided by a network of experienced
users
https://www.libreoffice.org/get-help/mailing-lists/

Questions &
Answers and
Knowledge Base

Free community assistance is provided in a Question & Answer
format. Search similar topics or ask a new question in
https://ask.libreoffice.org/en/questions
The service is available in several other languages; just replace
/en/ with de, es, fr, ja, ko, nl, pt, tr, and many others in the web
address above.

Native language
support

The LibreOffice website in various languages
https://www.libreoffice.org/community/nlc/
Mailing lists for native languages
https://wiki.documentfoundation.org/Local_Mailing_Lists
Information about social networking
https://wiki.documentfoundation.org/Website/Web_Sites_services

Accessibility options

Information about available accessibility options
https://www.libreoffice.org/get-help/accessibility/
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Paid support and training
You can also pay for support through service contracts from a vendor or consulting firm
specializing in LibreOffice. For information about certified professional support, see The
Document Foundation’s website: https://www.documentfoundation.org/gethelp/support/
For schools, educational and research institutions, and large organizations, see
https://www.libreoffice.org/download/libreoffice-in-business/.

What you see may be different
Illustrations
LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several
versions and can be customized by users (fonts, colors, themes, window managers). The
illustrations in this guide were taken from a variety of computers and operating systems.
Therefore, some illustrations will not look exactly like what you see on your computer display.
Also, some of the dialogs may be different because of the settings selected in LibreOffice. In
some cases (mainly Open, Save, and Print dialogs), you can choose to use dialogs from your
computer’s operating system or from LibreOffice. To change which dialogs are used, go to Tools
> Options > LibreOffice > General and select or deselect the option Use LibreOffice dialogs.

Icons
The LibreOffice community has created icons for several icon sets: Breeze, Colibre, Elementary,
Karasa Jaga, Sifr, and Sakapura; some are also available in a dark version. As a user, you can
select your own preferred set. The icons in this guide have been taken from a variety of
LibreOffice installations that use different sets of icons. The icons for some of the many tools
available in LibreOffice may differ from the ones used in this guide.
To change the icon set used, go to Tools > Options > LibreOffice > View. In the Icon style
section, choose from the drop-down list.

Notes
Some Linux distributions include LibreOffice as part of the installation and may not
include all the icon sets mentioned above. You should be able to download other
icon sets from the software repository for your Linux distribution if you wish to use
them.
The Galaxy, Oxygen, and Tango icon sets are no longer included as part of the
standard installation package. You can download and install them as extensions from
https://extensions.libreoffice.org/en/extensions/.
Some of the previously included gallery sets are now available only as extensions;
see https://extensions.libreoffice.org/?Tags%5B%5D=49 or search for specific ones.
For example, the People Gallery is available from
https://extensions.libreoffice.org/en/extensions/show/people-gallery

Using LibreOffice on macOS
Some keystrokes and menu items are different on macOS from those used in Windows and
Linux. The table below gives some common substitutions for the instructions in this book. For a
more detailed list, see the application Help.
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Windows or Linux

macOS equivalent

Effect

Tools > Options

LibreOffice > Preferences

Access setup options

Right-click

Control+click and/or right-click
depending on computer setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

Alt

⌥ (Option) or Alt, depending on
keyboard

Used with other keys

F11

⌘+T

Open Styles deck in Sidebar

What are all these things called?
The terms used in LibreOffice for most parts of the user interface (the parts of the program you
see and use, in contrast to the behind-the-scenes code that actually makes it work) are the same
as for most other programs.
A dialog is a special type of window. Its purpose is to inform you of something, or request input
from you, or both. The technical names for common controls are shown in Figure 1. In most
cases the technical terms are not used in this book, but it is useful to know them because the
Help and other sources of information often use them.

Figure 1: Dialog showing common controls
1) Tabbed page (not strictly speaking a control).
2) Radio buttons (only one can be selected at a time).
3) Checkbox (more than one can be selected at a time).
4) Spin box (click the up and down arrows to change the number shown in the adjacent text
box, or type in the text box).
5) Thumbnail or preview.
6) Drop-down list from which to select an item.
7) Push buttons.
Preface | 13

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog
remains open. When you close the dialog after use (usually, clicking OK or another button saves
your changes and closes the dialog), then you can again work with the document.
Some dialogs can be left open as you work, so you can switch back and forth between the dialog
and the document. An example of this type is the Find & Replace dialog.

Frequently asked questions
How is LibreOffice licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public
License (MPL). See https://www.libreoffice.org/about-us/licenses/
It is based on code from Apache OpenOffice made available under the Apache License 2.0
but also includes software that differs from version to version under a variety of other Open
Source licenses. New code is available under LGPL 3.0 and MPL 2.0.
May I distribute LibreOffice to anyone? May I sell it? May I use it in my business?
Yes.
How many computers may I install it on?
As many as you like.
Is LibreOffice available in my language?
LibreOffice has been translated (localized for more than 80%, both UI and Help) into over
46 languages, so your language probably is supported. Localization is well under way for
another 30+ languages (50-80%) and for another 50+ languages help is more than
welcome. In addition, over 70 spelling, hyphenation, and thesaurus dictionaries are
available for languages and dialects that do not have a localized program interface. The
dictionaries are available from the LibreOffice website at: www.libreoffice.org.
How can you make it for free?
LibreOffice is developed and maintained by volunteers and has the backing of several
organizations.
I am writing a software application. May I use programming code from LibreOffice in my
program?
You may, within the parameters set in the MPL and/or LGPL. Read the licenses:
https://www.mozilla.org/MPL/2.0/.
Why do I need Java to run LibreOffice? Is it written in Java?
LibreOffice is not written in Java; it is written in the C++ language. Java is one of several
languages that can be used to extend the software. The Java JDK/JRE is only required for
some features. The most notable one is the HSQLDB relational database engine. If you do
not want to use Java, you can still use nearly all of the LibreOffice features. For more
information, see “Minimum requirements” in Chapter 1, Introducing LibreOffice.
How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you
do not need to be a programmer. To start, check out this webpage:
https://www.libreoffice.org/community/get-involved/
May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement
at the beginning of this book. You do not have to request special permission. We request
that you share with the project some of the profits you make from sales of books, in
consideration of all the work we have put into producing them.
Donate to LibreOffice: https://www.libreoffice.org/donate/
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What is new in LibreOffice 7.3 Community?
LibreOffice 7.3 Community includes many changes not visible in the user interface. These
changes include further improvements in interoperability with Microsoft’s proprietary file formats,
including new features targeted at users migrating from Microsoft Office to LibreOffice, or
exchanging documents between the two office suites. These improvements include:
•

New handling of change tracking in tables and when text is moved.

•

Performance improvements when opening large DOCX and XLSX/XLSM files, improved
rendering speed of some complex documents, and new rendering speed improvements
when using the Skia back-end introduced with LibreOffice 7.1.

•

Improvements to import/export filters.

•

ScriptForge libraries, which make it easier to develop macros, have been extended with
various features.

In addition, LibreOffice’s Help has been improved to support all users, with particular attention for
those switching from Microsoft Office.
More information is in the announcement:
https://blog.documentfoundation.org/blog/2022/02/02/libreoffice-73-community/ and in the
Release Notes: https://wiki.documentfoundation.org/ReleaseNotes/7.3.
This user guide has been updated from Getting Started Guide 7.2. It covers some of the new
features that are visible in the user interface, but not all; others are covered in the individual
component guides. Portions of this guide have been rewritten for clarity, and some topics not in
previous editions have been included.
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Chapter 1
Introducing LibreOffice

What is LibreOffice?
LibreOffice is a freely available, fully-featured, open source office productivity suite that is
compatible with other major office suites and is available on a variety of platforms. Its native file
format is Open Document Format (ODF), and it can also open and save documents in many
other formats, including those used by several versions of Microsoft Office. For more information,
see Appendix B, Open Source, Open Standards, OpenDocument.
LibreOffice includes the following components.

Writer (word processor)
Writer is a feature-rich tool for creating letters, books, reports, newsletters, brochures, and other
documents. You can insert graphics and objects from other components into Writer documents.
Writer can export files to HTML, XHTML, XML, Portable Document Format (PDF), and EPUB;
and it can save files in many formats, including several versions of Microsoft Word files. It also
connects to your email client.

Calc (spreadsheet)
Calc has all of the advanced analysis, charting, and decision making features expected from a
high-end spreadsheet. It includes over 500 functions for financial, statistical, and mathematical
operations, among others. The Scenario Manager provides “what if” analysis. Calc generates 2D
and 3D charts, which can be integrated into other LibreOffice documents. You can also open and
work with Microsoft Excel workbooks and save them in Excel format. Calc can also export
spreadsheets in several formats, including for example Comma Separated Value (CSV), Adobe
PDF and HTML formats.

Impress (presentations)
Impress provides all the common multimedia presentation tools, such as special effects,
animation, and drawing tools. It is integrated with the advanced graphics capabilities of
LibreOffice Draw and Math components. Slideshows can be further enhanced using Fontwork
special effects text, as well as sound and video clips. Impress can open, edit, and save Microsoft
PowerPoint presentations and can also save your work in numerous graphics formats.

Draw (vector graphics)
Draw is a vector drawing tool that can produce everything from simple diagrams or flowcharts to
3D artwork. Its Smart Connectors feature allows you to define your own connection points. You
can use Draw to create drawings for use in any of the LibreOffice components, and you can
create your own clip art and then add it to the Gallery. Draw can import graphics from many
common formats and save them in many formats, including PNG, GIF, JPEG, BMP, TIFF, SVG,
HTML and PDF.

Base (database)
Base provides tools for day-to-day database work within a simple interface. It can create and edit
forms, reports, queries, tables, views, and relations, so that managing a relational database is
much the same as in other popular database applications. Base provides many new features,
such as the ability to analyze and edit relationships from a diagram view. Base incorporates two
relational database engines, HSQLDB and Firebird. It can also use PostgreSQL, dBASE,
Microsoft Access, MySQL, Oracle, or any ODBC compliant or JDBC compliant database. Base
also provides support for a subset of ANSI-92 SQL.
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Math (formula editor)
Math is a formula or equation editor. You can use it to create complex equations that include
symbols or characters not available in standard font sets. While it is most commonly used to
create formulas in other documents, such as Writer and Impress files, Math can also work as a
standalone tool. You can save formulas in the standard Mathematical Markup Language
(MathML) format for inclusion in web pages and other documents not created by LibreOffice.

Advantages of LibreOffice
Here are some of the advantages of LibreOffice over other office suites:
•

No licensing fees. LibreOffice is free for anyone to use and distribute at no cost. Many
features that are available as extra cost add-ins in other office suites (like PDF export)
are free with LibreOffice. There are no hidden charges now or in the future.

•

Open source. You can distribute, copy, and modify the software as much as you wish, in
accordance with the LibreOffice Open Source licenses.

•

Cross-platform. LibreOffice runs on several hardware architectures and under multiple
operating systems, such as Microsoft Windows, macOS, and Linux.

•

Extensive language support. The LibreOffice user interface, including spelling,
hyphenation, and thesaurus dictionaries, is available in over 100 languages and dialects.
LibreOffice also provides support for both Complex Text Layout (CTL) and Right to Left
(RTL) layout languages (such as Urdu, Hebrew, and Arabic).

•

Consistent user interface. All the components have a similar “look and feel”, making
them easy to use and master.

•

Integration. The components of LibreOffice are well integrated with one another.
– All the components share a common spelling checker and other tools, which are used
consistently across the suite. For example, the drawing tools available in Writer are
also found in Calc, with similar but enhanced versions in Impress and Draw.
– You do not need to know which application was used to create a particular file. For
example, you can open a Draw file from Writer; it will open automatically in Draw.

•

Granularity. Usually, if you change an option, it affects all components. However,
LibreOffice options can be set at a component level or even at document level.

•

File compatibility. In addition to its native OpenDocument formats, LibreOffice includes
support for opening and saving files in many common formats including Microsoft Office,
HTML, XML, WordPerfect, Lotus 1-2-3, and PDF. See Appendix B for a list.

•

No vendor lock-in. LibreOffice uses OpenDocument, an XML (eXtensible Markup
Language) file format developed as an industry standard by OASIS (Organization for the
Advancement of Structured Information Standards). These files can easily be unzipped
and read by any text editor, and their framework is open and published.

•

You have a voice. Enhancements, software fixes, and release dates are communitydriven. You can join the community and affect the course of the product you use.

You can read more about LibreOffice and The Document Foundation on their websites at
https://www.libreoffice.org/ and https://www.documentfoundation.org/.
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Minimum requirements
LibreOffice 7.3 requires one of the following operating systems:
•

Microsoft Windows: Windows 7 SP1, Windows 8, Windows Server 2012, or Windows 10.
Administrator rights are needed for the installation process.

•

GNU/Linux: Kernel version 3.10 or higher and glibc2 v2.17 or higher.

•

macOS 10.12 (Sierra) or higher.

For a detailed list of hardware and software requirements, see the LibreOffice website,
https://www.libreoffice.org/get-help/system-requirements/.

Note regarding Java
Some LibreOffice features (wizards and the HSQLDB database engine) require that
the Java Runtime Environment (JRE) or, for macOS, the Java Development Kit
(JDK) is installed on your computer. If you do not want to use Java, you can still use
nearly all of the LibreOffice features.
Java is available at no cost. More information and download links to the appropriate
edition for your operating system can be found at:
https://java.com/en/download/manual.jsp.
For macOS, you need to install Oracle’s Java Development Kit (JDK), not just
the Java Runtime Environment (JRE). Download links can be found at:
https://www.oracle.com/java/technologies/downloads/.
If you want to use LibreOffice features that require Java, it is important that the
correct 32-bit or 64-bit edition matches the installed version of LibreOffice. See the
Advanced Options in Chapter 2, Setting up LibreOffice.

How to get the software
Versions of LibreOffice Community for Windows, Linux, and macOS can be downloaded free
from https://www.libreoffice.org/download. You can also download the software by using a Peerto-Peer client, such as BitTorrent, at the same address.
Linux users will also find LibreOffice included in many of the latest Linux distributions; Ubuntu is
just one example. Portable and other versions of LibreOffice are listed on the download page.
Linux, Enterprise, Online, and other versions may differ in appearance and functionality from the
descriptions in this book.

How to install the software
Information on installing LibreOffice on the various supported operating systems is given here:
https://www.libreoffice.org/get-help/install-howto/. After installation, you can change the default
settings (options) in LibreOffice to suit your preferences; see Chapter 2, Setting up LibreOffice.

Extensions and add-ons
You can add functionality to LibreOffice with extensions and add-ons. Several extensions are
installed with the program and you can get others from the official extensions repository,
https://extensions.libreoffice.org/ and from other sources. See Chapter 14, Customizing
LibreOffice, for more information on installing extensions and add-ons.

Chapter 1 Introducing LibreOffice | 19

Starting LibreOffice
In general, you start LibreOffice the same way you start any other program on your computer.
On Windows and Linux, entries for LibreOffice and each of its components appear in the system
menu of your computer. On macOS, only an entry for LibreOffice is added to the Applications
menu. You can make a desktop icon for LibreOffice or a component in the same way you can
make a desktop icon for any other program; see your operating system’s help for how to do this.
Clicking on the LibreOffice menu entry, desktop icon, or tile opens the LibreOffice Start Center
(Figure 2) from where you can select the individual components of LibreOffice. You can also
open an existing file, use a template, or access Help and extensions. The thumbnails in the Start
Center include an icon showing the type of file (text, spreadsheet, drawing, presentation).

Figure 2: LibreOffice Start Center
You can also start LibreOffice by double-clicking the filename of an ODF document on the
desktop, or in a file manager such as Windows Explorer or macOS Finder. The appropriate
component of LibreOffice will start and the document will be loaded.
You can open files stored in remote servers running Content Management Interoperability
Services (CMIS). CMIS, like OpenDocument Format, is an OASIS standard. When using CMIS
servers, the service will ask you for the necessary credentials for file access. See “Opening and
saving files on remote servers” on page 31.
For more information on opening files, see “Opening existing documents” on page 27.
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Parts of the main window
The main window is similar for each component of LibreOffice, although some details vary. See
the relevant chapters in this guide about Writer, Calc, Draw, Impress, Base, and Math for
descriptions of those details.
Common features include the Title bar, Menu bar, Standard toolbar, and Formatting toolbar
(Writer and Calc only) at the top of the window and the Status bar at the bottom.

Note
By default, LibreOffice’s commands are grouped in menus and toolbars, as
described in this section. You can choose other user interface variants, displaying
contextual groups of commands and contents (View > User Interface) For more
information, see Chapter 14, Customizing LibreOffice.

Title bar
The Title bar is located at the top of the LibreOffice window. It shows the file name of the current
document. When the document is not yet named, the document name will appear as Untitled X,
where X is a number. Untitled documents are numbered in the order in which they are created.

Menu bar
The Menu bar is located just below the Title bar in Windows and Linux and at the top of the
screen in macOS. When you select one of the menus, a submenu drops down to show further
options, including:
•

Commands that directly cause an action, such as Close or Save in the File menu.

•

Commands that open dialogs. These are indicated by three dots following a command,
such as Find and Replace... in the Edit menu.

•

Commands that open further submenus. These are indicated by a right-pointing arrow
following a command, such as Toolbars and Zoom, in the View menu. Moving the
cursor onto one of these items causes its submenu to open.

As an example, the default Menu bar for Writer contains the following:
•

File – commands that apply to the entire document such as Open, Save, and Print.

•

Edit – commands for editing the document such as Undo, Find and Replace, Cut,
Copy, Paste, and Track Changes.

•

View – commands for controlling the display of the document such as User Interface,
Toolbars, Text Boundaries, Rulers, and Zoom.

•

Insert – commands for inserting elements into your document such as Image,
Comment, Header and Footer, and Table of Contents and Index.

•

Format – commands for formatting the layout of your document.

•

Styles – commands for quickly applying common styles; for editing, loading, and creating
styles; and for managing styles.

•

Table – commands to insert and edit a table in a text document.

•

Form – commands to create fill-in forms.

•

Tools – functions such as Spelling, AutoCorrect, Customize, and Options.

•

Window – commands for the display window.

•

Help – links to the LibreOffice Help, What’s This?, and information about the program.
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Toolbars
LibreOffice has two types of toolbars: docked (fixed in place) and floating. Docked toolbars can
be moved to different locations or made to float, and floating toolbars can be docked.
In a default LibreOffice installation, the top docked toolbar, just under the Menu bar, is called the
Standard toolbar. It is consistent across the LibreOffice applications.
The second toolbar at the top for Writer and Calc, in a default LibreOffice installation, is the
Formatting toolbar. It is context-sensitive; that is, it shows the tools relevant to the current
position of the cursor or the object selected. For example, when the cursor is on a graphic, the
Formatting toolbar provides tools for formatting graphics; when the cursor is in text, the tools are
for formatting text.
In some cases it is convenient to reduce the number of toolbars displayed and get more space
for the document. LibreOffice provides a single-toolbar alternative to the default double-toolbar
setup. It contains the most-used commands. To activate it, enable View > User Interface >
Single Toolbar.

Displaying or hiding toolbars
To display or hide toolbars in a standard setup, go to View > Toolbars on the Menu bar, then
click on the name of a toolbar in the submenu. An active toolbar shows a checkmark beside its
name. Toolbars created from tool palettes are not listed in the View menu.
To close a toolbar, go to View > Toolbars on the Menu bar and deselect the toolbar, or right-click
in an empty space between the icons on a toolbar and select Close Toolbar in the context menu.

Sub-menus and tool palettes
Toolbar icons with a small triangle to the right will display sub-menus, tool palettes, and
alternative methods of selecting items, depending on the icon.
A tool palette is a pop-up collection of tools attached to a single tool in a toolbar. Tool palettes can
be made into floating toolbars. Figure 3 shows an example of a tool palette from the Drawing
toolbar made into a floating toolbar. Once removed from the parent toolbar, the palette displays a
Title bar. Floating tool palettes can be left floating or docked along an edge of the screen or in
one of the existing toolbar areas. See “Moving toolbars” and “Floating toolbars” below for more
information.

Figure 3: Example of tearing off a tool palette: click on
the dots and drag to form a floating toolbar

Tip
If you cannot see the dots at the top of the tool palette, you need to unlock the
toolbar before you can float the palette. See “Locking and unlocking toolbars” below.
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Locking and unlocking toolbars
You can lock all toolbars, or individual toolbars, into place so they cannot be moved. When all
toolbars are locked, you cannot unlock individual ones.
To lock all toolbars in place, go to View > Toolbars on the Menu bar and select Lock Toolbars
at the bottom of the submenu. You will need to restart LibreOffice for this change to take effect.
To unlock all toolbars, click on Lock Toolbars again.
To lock an individual toolbar into place, be sure Lock Toolbars is not selected on View > Toolbars,
then right-click on the toolbar and select Lock Toolbar Position on the context menu.

Moving toolbars
Docked toolbars are not locked in place. They are indicated by dotted handles on the left end
(Figure 4). Docked toolbars can be undocked and moved to a new docked position or left as a
floating toolbar.
1) Move the mouse cursor over the toolbar handle, which is the small vertical bar of dots to
the left of a docked toolbar, highlighted in Figure 4.
2) Hold down the left mouse button and drag the toolbar to the new location.
3) Release the mouse button.
To move a floating toolbar, click on its title bar and drag it to a new floating location or dock the
toolbar at the top or bottom of the main window.

Figure 4: Toolbar handles

Floating toolbars
LibreOffice includes several additional toolbars, whose default settings have them appear as
floating toolbars in response to the current position of the cursor or selection. You can dock these
toolbars to the top or bottom of the main window, or reposition them on your computer display
(see “Moving toolbars” above).
Some of these additional toolbars are context sensitive and will automatically appear depending
on the position of the cursor. For example, when the cursor is in a table, a Table toolbar appears,
and when the cursor is in a numbered or bullet list, the Bullets and Numbering toolbar appears.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and
locking the position of a docked toolbar. You can also add icons and create new toolbars, as
described in Chapter 14, Customizing LibreOffice. To access the customization options for a
toolbar, right-click in an empty space between the icons on a toolbar to open a context menu.
•

To show or hide icons defined for the selected toolbar, point to Visible Buttons (in the
context menu). Visible icons on a toolbar are indicated by an outline around the icon
(Figure 5) or by a check mark beside the icon, depending on your operating system.
Select or deselect icons to hide or show them on the toolbar.

•

Click Customize Toolbar to open the Customize dialog; See Chapter 14, Customizing
LibreOffice, for more information.

•

Click Dock Toolbar to dock the selected floating toolbar. You can reposition the toolbar to
a different docked position.
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•

Click Dock All Toolbars to dock all floating toolbars. You can reposition the toolbars to
different docked positions.

•

Click Lock Toolbar Position to lock a docked toolbar into its docked position.

•

Click Close Toolbar to close the selected toolbar.

Figure 5: Toolbar context menu and selection of visible toolbar icons:
1) Right-click anywhere on the toolbar; 2) Point to Visible Buttons;
3) Visible icons are marked.

Context menus
Context menus provide quick access to many menu functions. They are opened by right-clicking
on a paragraph, graphic, or other object. When a context menu opens, the functions or options
available will depend on the object that has been selected. A context menu can be the easiest
way to reach a function, especially if you are not sure where the function is located in the menus
or toolbars. Context menus may display an applicable keyboard shortcut if one has been set; you
can toggle this visibility off or on in Tools > Options > LibreOffice > View > Visibility.

Status bar
The Status bar is located at the bottom of the workspace. It provides information about the
document and convenient ways to change some features quickly. It is similar in Writer, Calc,
Impress, and Draw, but each LibreOffice component includes some component-specific items. An
example of the Writer Status bar is shown in Figures 6 and 7.
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Figure 6: Writer Status bar, left end

Figure 7: Writer Status bar, right end
Document changes status
This icon changes color to indicate whether the document has no unsaved changes or it
has been modified but not been saved. In other components of LibreOffice, this icon is
located to the right of Selection Mode. Click this icon to save the document.
Page, sheet, or slide number and page count
Shows the current page, sheet, or slide number and the total number of pages, sheets, or
slides in the document. Click on this field to open the Go to Page dialog. Other uses of this
field depend on the LibreOffice component.
Word & character count
Shows the total number of words and characters in the document or in the selection.
Page style or slide design
Shows the current page style or slide design. To edit the current page style or slide design,
double-click on this field. To choose a different page style or slide design, right-click on this
field and select from the list that pops up.
Language
Shows the current language of the text at the current cursor position.
Insert mode
Shows the type of insert mode the program is in. Each time the Ins key is pressed, or this
field is clicked, the mode toggles between Insert and Overwrite. When Track Changes is
on, Overwrite mode is inactivated.
Selection mode
Click to choose different selection modes. The icon does not change, but when you hover
the mouse pointer over this field, a tooltip indicates which mode is active.
Digital signature
If the document has been digitally signed, an icon shows here. You can click the icon to
sign the document, or to view the existing certificate.
Object information
Displays information relevant to the position of the cursor or the selected element of the
document.
View layout
Select between Single-page view, Multiple-page view, and Book view to change how your
document is displayed.
Zoom slider
Drag the Zoom slider, or click on the + and – signs to change the view magnification of your
document.
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Zoom percentage
Indicates the magnification level of the document. Right-click on the percentage figure to
open a list of magnification values from which to choose. Clicking on this percentage figure
opens the Zoom & View Layout dialog.

Sidebar
The Sidebar (Figure 8) is normally open by default on the right side of the workspace in Writer,
Calc, Impress, and Draw. Select View > Sidebar on the Menu bar to display or hide it. It contains
one or more decks, based on the current document context. Decks are organized into panels. A
tab bar on the right side of the sidebar allows you to switch between different decks.
All four components contain the Properties, Styles, Gallery, and Navigator decks. Some
components have additional decks, such as Page and Style Inspector for Writer; Master Slides,
Animation, Shapes, and Slide Transition for Impress; Shapes for Draw; and Functions for Calc.
Toolbars and Sidebar panels share many functions. For example, the buttons for making text
bold or italic exist in both the Formatting toolbar and the Properties panel. Some panels contain a
More Options button, which opens a dialog with additional editing controls.
For more detail, see the Sidebar explanation in the relevant LibreOffice component’s user guide.
To hide the Sidebar, click on the gray Hide button on the left. Click on the same button to show
the Sidebar again.
To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the choices on
the Sidebar Settings drop-down list at the top of the tab bar.

Figure 8: Properties panel of the Sidebar in Writer
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Starting new documents
You can start a new, blank document in LibreOffice in several ways.
•

When LibreOffice is running but no document is open, the Start Center (Figure 2 on page
20) is shown. Click one of the icons to open a new document of that type, or click the
Templates icon to start a new document using a template.

•

Use File > New on the Menu bar and select the type of document in the sub menu.

•

Use the keyboard shortcut Ctrl+N to create a new document. The type of document
created depends on which LibreOffice component is open and active. For example, if
Calc is open and active, a new spreadsheet is created.

•

Use File > Wizards on the Menu bar and select the type of document in the context
menu.

•

If a document is already open in LibreOffice, click the New icon on the Standard toolbar
and a new document of the type shown on the icon is created in a new window. The New
icon changes depending on which component of LibreOffice was last created.

•

If a document is already open in LibreOffice, click on the small triangle to the right of the
New icon on the Standard toolbar and select the type of document in the context menu.

Note
If all documents are closed without exiting from LibreOffice, then the Start Center will
be displayed.

Opening existing documents
You can open an existing document in several ways.
When no document is open:
•

Click Open File or Remote Files in the Start Center.

•

Go to File > Open or File > Open Remote on the Menu bar.

•

Use the keyboard shortcut Ctrl+O.

•

Click on a thumbnail in the list of recently opened documents displayed in the Start
Center. You can scroll up or down in the Start Center to locate a recently opened
document.

Note
Renamed or relocated documents can still be listed in the Start Center. Selecting
one gives an error message that the file does not exist. To remove the thumbnail
from the Start Center, hover the mouse pointer over the thumbnail until an X appears
in the upper right corner, and then click on the X.
If a document is already open:
•

Click the Open icon on the Standard toolbar.

•

Click the small triangle to the right of the Open icon and select from a list of recently
opened documents, or select Open Remote File.

•

Use File > Recent Documents to make a selection from the submenu.

When using the Open dialog, navigate to the folder you want, select the file, and then click Open.
If a document is already open in LibreOffice, the second document opens in a new window.
Chapter 1 Introducing LibreOffice | 27

In the Open dialog, you can reduce the list of files by selecting the type of file you are looking for.
For example, if you choose Text documents as the file type, you will only see documents Writer
can open (including .odt, .doc, .txt); if you choose Spreadsheets, you will see .ods, .xls, and other
files that Calc opens.

Opening files not in an OpenDocument format
You can also open an existing document that is in a format that LibreOffice recognizes by doubleclicking on the file icon on the desktop or in a file manager such as Windows Explorer or macOS
Finder. LibreOffice may need to be associated with file types that are not ODF files for the
appropriate LibreOffice component to open.
For example, on a Windows computer, if you do not have Microsoft Office installed or if Microsoft
Office is installed but you have associated Microsoft Office file types with LibreOffice, then when
you double-click on the following files, they open in LibreOffice:
•

A Word file (*.doc or *.docx) opens in Writer.

•

An Excel file (*.xls or *.xlsx) opens in Calc.

•

A PowerPoint file (*.ppt or *.pptx) opens in Impress.

If you did not associate the file types with LibreOffice, and Microsoft Office is installed on your
computer, then when you double-click on a Microsoft Office file, it opens using the appropriate
Microsoft Office component.
On macOS, if Microsoft Office is not installed and you have not associated those file types with
LibreOffice, the files may open in Apple’s Pages, Numbers, or Keynote applications.
See the LibreOffice Help for more about file associations.

Saving documents
You can save documents as follows:
•

Save – use if you are keeping the document, its current filename and location.

•

Save As – use to create a new document, or change the filename and/or file format, or
save the file in a different location on your computer.

•

Save Remote – use if your document is already stored in a remote server or will be
stored in a remote server.

•

Save a Copy – use to save a copy of your current document and keep it open for more
editing.

•

Save All – use to save all the files open in your current session.

Save command
To save a document if you are keeping the document’s current filename and location, do one of
the following:
•

Use the menu option File > Save.

•

Use the keyboard shortcut Ctrl+S.

•

Click the Save icon on the Standard toolbar.

•

Use the menu option File > Save All.

•

Use the menu option File > Save Remote.

•

Use the menu option File > Save a Copy (similar to the Save As command).

Using the Save command will immediately overwrite the last saved version of the file.
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Save As command
If you want to create a new document file, change the filename and/or file format, or save the file
in a different location on your computer:
•

Use the keyboard shortcut Ctrl+Shift+S.

•

Use the menu option File > Save As.

•

Click the arrow to the right of the Save icon and select Save As from the context menu.

When the Save As dialog or Save dialog opens, enter the file name, change the file type (if
applicable; for example, to a Microsoft Office format), navigate to a new location (if applicable),
and click Save.

Using password protection and OpenPGP encryption
LibreOffice provides two types of document protection: password protection and OpenPGP
encryption. Files encrypted with the Save password cannot be decrypted without the password,
which must be sent to each user who needs to decrypt the document. With OpenPGP encryption,
the document is encrypted using an algorithm, which requires a key. Each key is used only once
and is sent to the recipient along with the document.

Password protection
LibreOffice provides two levels of password protection: read-protect (file cannot be viewed
without a password) and write-protect (file can be viewed in read-only mode but cannot be
changed without a password). Thus you can make the content available for reading by one group
of people and for reading and editing by a different group. This behavior is compatible with
Microsoft Word file protection. The two levels can also be combined.

Figure 9: Save with password and Encrypt with GPG key options
To protect a document with passwords:
1) Using the Save As command, select the Save with password option in the lower left of
the Save As dialog or Save dialog (Figure 9).
2) Click Save and the Set Password dialog opens (Figure 10).
3) In the File Encryption Password section, enter a password to open the document and
then enter the same password as confirmation.
4) To restrict who can edit the document, click Options.
5) In the File Sharing Password section, select Open file read-only, enter a password to
allow editing, and then enter the same password as confirmation.
6) Click OK and the dialog closes. If the passwords match, the document is saved
password-protected. If either pair of passwords do not match, you receive an error
message.
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Caution
LibreOffice uses a very strong encryption mechanism that makes it almost
impossible to recover the contents of a document if you lose or forget the password.

Figure 10: Set Password dialog

Changing the password
When a document is password-protected, you can change the password while the document is
open. Go to File > Properties > General on the Menu bar and click the Change Password
button. This opens the Set Password dialog where you can enter a new password.

OpenPGP encryption
LibreOffice uses the OpenPGP software installed on your computer. If no OpenPGP software is
available, you must download and install one suitable for your operating system before you can
use this option.
You must define a personal pair of cryptography keys with the OpenPGP application. Refer to the
OpenPGP software installed on how to create a pair of keys. For more information on using this
form of encryption, see the supplied Help.
OpenPGP encryption requires the use of the public key of the recipient; this key must be
available in the OpenPGP key chain stored in your computer.1
To encrypt a document:
1) Choose File > Save As,
2) In the Save As dialog, enter a name for the file.
3) Select the Encrypt with GPG key option (see Figure 9).
4) Click Save. The OpenPGP public key selection dialog opens.
5) Choose the public key of the recipient. You can select multiple keys.
6) Click OK to close the dialog and save the file encrypted with the selected public keys.
1

GPG (GNU Privacy Guard) is an implementation of the Open PGP standard.
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Saving documents automatically
LibreOffice can save files automatically as part of the AutoRecovery feature. Automatic saving,
like manual saving, overwrites the last saved state of the file.
To set up automatic file saving:
1) Go to Tools > Options > Load/Save > General on the Menu bar.
2) Select Save AutoRecovery information every and set the time interval.
3) Click OK.

Opening and saving files on remote servers
LibreOffice can open and save files stored on remote servers. Keeping files on remote servers
allows you to work with the documents using different computers. For example, you can work on
a document in the office during the day and edit it at home for last-minute changes. Storing files
on a remote server also backs up documents from computer loss or hard disk failure. Some
servers are also able to check-in and check-out files, thus controlling their usage and access.
LibreOffice supports many document servers that use well known network protocols such as FTP,
WebDav, Windows share, and SSH. It also supports popular services like Google Drive and
Microsoft OneNote, as well as commercial and open source servers that implement the OASIS
CMIS standard.
To enable a remote server connection, use one of these methods:
•

Click on the Remote Files button in the Start Center.

•

Select File > Open Remote in any open document.

•

Select File > Save Remote in any open document.

On the Remote Files dialog (Figure 11), click Manage Services / Add Service button in the
upper right to open the File Services dialog (Figure 12). Depending on the type of file service you
choose in the Type listbox, different parameters are necessary to fully qualify the connection to
the remote server.

Figure 11: Remote Files dialog when connected to a server
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Once the connection is defined, click OK to connect. The dialog will dim until the connection is
established with the server. A dialog asking for the user name and the password may pop up to
let you log in the server. Proceed entering your credentials.
The Remote Files dialog (Figure 11) which then appears has many parts. The upper list box
contains the list of remote servers you have previously defined. The line below the list box shows
the path to access the folder. On the left is the folder structure of the user space in the server.
The main pane displays the files in the remote folder. Click the Open or Save button to proceed.

Figure 12: Remote server configuration

Using the Navigator
The Navigator lists objects contained in a document, collected into categories. For example, in
Writer it shows Headings, Tables, Frames, Comments, Images, Bookmarks, and other items, as
shown in Figure 13. In Calc it shows Sheets, Range names, Database ranges, Images, Drawing
objects, and other items. In Impress and Draw it shows Slides, Pages, and other items.
In a default installation of LibreOffice, the Navigator is a Sidebar deck. If necessary, press the F5
key, or go to View > Navigator on the Menu bar, or click the Navigator icon on the Sidebar, to
open it.

Figure 13: Navigator in Writer
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Click the marker (+ or triangle) by any of the categories to display the list of objects in that
category.
The Navigator provides several convenient ways to move around a document and find items in it:
•

When a category is showing the list of objects in it, double-click on an object to jump
directly to that object’s location in the document.

•

Objects are much easier to find if you have given them recognizable names when
creating them, instead of keeping the default names such as Sheet1, Table1, or Table2.
The default names may not correspond to the actual position of the object in the
document.

•

Navigator also provides the facility to move, promote, demote items within a document.

•

Each Navigator in the individual LibreOffice components has a different range of
functions. These functions are further explained in the user guide for each LibreOffice
component.

Displaying multiple view of a document
You can open, view, and edit several views of the same document in LibreOffice at the same
time. These views are displayed in windows that can display different pages or use different
zoom levels or other settings. A change to the document in one window is immediately reflected
in the other windows. In Writer, for example, you might find this useful for copying or moving
information from one page to another.
To open a new window showing the document, go to Window > New Window on the Menu bar.
In each window opened, the filename in the title bar is automatically numbered as shown by the
example in Figure 14. If other LibreOffice documents are open at the same time, the list of
windows also includes them. The active window has a marker by its filename in the list. You can
switch between windows by clicking on a name in the list, or by clicking on the window itself if it is
visible on the display.
To close a window, go to Window > Close Window on the Menu bar, or use the keyboard
shortcut Ctrl+W, or click the Close icon on the Menu bar or Title bar of the window.

Figure 14: List of open windows

Undoing and redoing changes
To undo the most recent unsaved change in a document, use the keyboard shortcut Ctrl+Z, or
click the Undo icon on the Standard toolbar, or go to Edit > Undo on the Menu bar. Click the
small triangle to the right of the Undo icon to get a list of all the changes that can be undone. You
can select multiple changes and undo them at the same time.
After changes have been undone, you can redo changes. To redo a change use the keyboard
shortcut Ctrl+Y, or click the Redo icon, or go to Edit > Redo on the Menu bar. As with Undo, click
on the triangle to the right of the Redo icon to get a list of the changes that can be reapplied.
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To repeat the last command applied to your document, use the shortcut Ctrl+Shift+Y or go to Edit
> Repeat on the Menu bar. This can save several repetitive menu navigation clicks or keyboard
shortcuts, especially when the command is taken from a secondary menu.

Reloading a document
Reloading is useful in two situations.
•

You may want to discard all the changes made in an editing session after the last
document save.

•

You may have made some formatting changes that do not show until the document has
been closed and reopened; reloading has the same result.

To reload a document, go to File > Reload on the Menu bar. If you have made changes to a file
since the last save, a confirmation dialog will warn you that reloading will discard your last
changes. Choose whether to save or discard the changes.
On reloading the document, the File dialog does not open, because the file is already selected.

Using document properties
To open the Properties dialog for a document, go to File > Properties on the Menu bar. The
Properties dialog provides information about the document and allows you to set some of its
properties. The dialog and its tabs are described below.

General
Contains basic information about the current file: file name and type; storage location; file size;
date, time, and author of file creation and last modification; template used to create the file; date,
time, and author of digital signature; date, time, and user name when the file was last printed;
total editing time; and revision number.
Controls available:
•

Change Password – opens a dialog to change the password. It is only active if a
password has been set for the file.

•

Digital Signatures – opens the Digital Signatures dialog where you can manage digital
signatures for the current document.

•

Apply user data – saves the full name of the user with the file. You can edit the name by
going to Tools > Options > LibreOffice > User Data on the Menu bar.

•

Save preview image with this document – saves a thumbnail.png inside the document.
These images may be used by a file manager under certain conditions.

•

Reset Properties – resets the editing time to zero, the creation date to the current date
and time, and the version number to 1. The modification and printing dates are also
deleted.

Description
Contains optional editable descriptive information about the document, which may be exported
as metadata to other file formats.
•

Title – enter a title for the document.

•

Subject – enter a subject for the document. You can use a subject to group documents
with similar contents.
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•

Keywords – enter the words that you want to use to index the content of the document.
Keywords must be separated by commas. A keyword can contain white space characters
or semicolons.

•

Comments – enter comments to help identify the document.

Custom Properties
Use this page to assign custom information fields to the document. In a new document, this page
may be blank. If the new document is based on a template, this page may contain fields. You can
change the name, type, and contents of each row. The information in the fields will be exported
as metadata to other file formats.
Click Add Property to add a new custom property. Click Reset to delete all custom properties.

CMIS Properties
Used for documents stored on remote servers; not shown otherwise. See the Help for more
information.

Security
Enables two password-protected security options.
•

Open file read-only – select to allow this document to be opened only in read-only
mode. This file sharing option protects the document against accidental changes. It is still
possible to edit a copy of the document and save that copy with the same name as the
original.

•

Record changes – select to require that all changes be recorded. To protect the
recording state with a password, click Protect and enter a password. This is similar to
Edit > Track Changes > Record on the Menu bar. However, while other users of this
document can apply their changes, they cannot disable change recording without
knowing the password.

Protect or Unprotect button protects the change recording state with a password. If change
recording is protected for the current document, the button is named Unprotect. Click Unprotect
and type the correct password to disable the protection.

Font
When Embed fonts in the document is selected, any fonts used in the document will be
embedded into the document when it is saved. This may be useful if you are creating a PDF and
want to control how it will look on other computer systems.
Only embed fonts that are used in documents – If fonts have been defined for the document
(for example, in the template), but have not been used, select this option to not embed them.
Font scripts to embed – You can choose which types of fonts are embedded: Latin, Asian,
Complex.

Statistics
Displays statistics for the current file, such as the number of pages, words, and characters.
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Classifying document contents
Document classification and security are important for businesses and governments. Where
sensitive information is exchanged between users and organizations, the parties agree how such
information will be identified and handled. LibreOffice provides standardized means for sensitive
information to be identified and protected, using a set of standard fields that can be used to hold
sensitive information.
LibreOffice implemented the open standards produced by TSCP (Transglobal Secure
Collaboration Participation, Inc.). It contains three BAF (Business Authentication Framework)
categories: Intellectual Property, National Security and Export Control. Each category has four
BAILS (Business Authorization Identification and Labeling Scheme) levels: Non-Business,
General Business, Confidential, and Internal Only.
To enable document classification, open the TSCP bar (View > Toolbars > TSCP
Classification). This toolbar contains list boxes to help in selecting the security of the document.
LibreOffice then adds custom fields in the document properties (File > Properties, Custom
Properties tab) to store the classification policy as document metadata.
To prevent a breach in security policy, contents with a higher classification level cannot be pasted
into documents with a lower classification level.

Closing a document
If only one document is open and you want to close that document, go to File > Close on the
Menu bar or click on the X on the right or left end of the Menu bar. On Windows and Linux, the
document closes and the LibreOffice Start Center opens. On macOS, the document closes and
only the Menu bar remains at the top of the screen.
If more than one document is open and you want to close one of them, go to File > Close on the
Menu bar or click on the X on the right or left end of the title bar of that document’s window.
If the document has not been saved since the last change, a message box is displayed. Choose
whether to save or discard your changes.

Closing LibreOffice
To close LibreOffice completely, go to File > Exit LibreOffice on the Menu bar in Windows and
Linux. In macOS, go to LibreOffice > Quit LibreOffice on the Menu bar.
In Windows and Linux, when you close the last document using the X on the title bar of the
window, then LibreOffice will close completely. In macOS, you need to use LibreOffice > Quit
LibreOffice.
You can also use a keyboard shortcut:
•

In Windows and Linux – Ctrl+Q

•

In macOS – ⌘+Q

If any documents have not been saved since the last change, a message box is displayed.
Choose whether to save or discard your changes.
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Problem solving using Safe Mode
You can use Safe Mode (Figure 15) to help restore an instance of LibreOffice that has become
corrupted and stopped working, fails to launch, or crashes in some situations.
To access Safe Mode, do one of the following:
•

Choose Help > Restart in Safe Mode on the Menu bar.

•

Start LibreOffice from the command line with the --safe-mode option.

•

In Windows only, choose LibreOffice (Safe Mode) from the Start Menu.

Figure 15: LibreOffice Safe Mode
The following Safe Mode options get more extreme from the top down, so it is recommended that
you try them successively.
•

Restore from backup – LibreOffice keeps backups of previous configurations and
activated extensions. Use this option to restore the user configuration, installed
extensions, or both, to a previous known working state if you suspect that your problems
were caused by recent changes to either.

•

Configure – Use this option to disable all user extensions, hardware acceleration, or
both. This is a good choice if you are experiencing crashes on startup or visual glitches
that are often related to hardware acceleration.

•

Extensions – If you suspect that a corrupted extension is blocking or causing LibreOffice
to crash, you can use this option to uninstall all user extensions and reset the state of
any shared or bundled extensions. In the case of shared or bundled extensions, the
option will only work if you have the proper system access rights. It should be exercised
with caution.

•

Reset to factory settings – If all of the above fails, you can reset your settings and your
user interface modifications, or your entire profile, back to factory defaults.

•

Reset settings and user interface modifications – this will reset your User Interface
and configuration changes, but keep things like your personal dictionary, templates, etc.
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•

Reset entire user profile – this will erase all customized options and return your user
profile to the factory default state.

•

Continue in Safe Mode – Continuing in Safe Mode will allow you to work in LibreOffice,
using a temporary profile that was created on startup. Any extensions or configuration
options you had set up previously will have to be reconfigured in order to be used,
bearing in mind that any changes made to the temporary user profile will be lost after any
restart.

•

Restart in Normal Mode – If you arrived in Safe Mode accidentally, this option will
discard any changes, terminate Safe Mode, and restart LibreOffice normally.

•

Apply Changes and Restart – Choose this option to apply any of the above changes
and restart LibreOffice.

Note
If you are unable to solve your problem using Safe Mode, the Advanced tab provides
instructions on receiving further aid.
In the Advanced tab you can also create a .zip file of your corrupted user profile
which can then be uploaded to the bug tracking system where it can be further
investigated by the developers.
However, be aware that your uploaded user profile may contain sensitive information
such as installed extensions, personal dictionaries, and settings.
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Getting Started Guide 7.3

Chapter 2,
Setting up LibreOffice
Choosing options to suit the way you work

Introduction
This chapter briefly describes some of the setup options found under Tools > Options on the
Menu bar (LibreOffice > Preferences on macOS). Additional options, and more details about
the ones given here, are covered in the Help.

Tip
Many options are intended for power users and programmers. If you do not
understand what an option does, it is usually best to leave it on the default setting
unless instructions in this book recommend changing the setting.

Choosing options for all of LibreOffice
This section covers some of the settings that apply to all the components of LibreOffice. For
information on settings not discussed here, see the Help.
Click Tools > Options. The list in the left-hand box of the Options – LibreOffice dialog varies
depending on which component of LibreOffice is open. The illustrations in this chapter show the
list as it appears when a Writer document is open. If you are using a version of LibreOffice other
than US English, some field labels may be different from those shown in the illustrations.
Click the expansion symbol (+ or triangle) next to LibreOffice. Select an item in the drop-down
list to display the relevant page on the right-hand side of the dialog.

Figure 16: LibreOffice options

Note
The Reset button, located in the lower right of the Options dialog, resets the values
on that page to the values that were in place when you opened the dialog. It may be
called Revert on some installations.
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User data
Because LibreOffice can use the name or initials stored in the LibreOffice – User Data page for
several things, including document properties (“created by” and “last edited by” information), the
name of the author of comments and changes, and the sender address in mailing lists, you will
want to ensure that the correct information appears here.
Fill in the form, or amend or delete any existing information. If you do not want user data to be
part of the document’s properties, deselect Use data for document properties.

Figure 17: User Data page
In the Cryptography section, you can set the preferred public key for OpenPGP encryption and
digital signature. These preferred keys will be pre-selected in the key selection dialog when you
sign or encrypt a document (see Chapter 10, Printing, Exporting, Emailing, and Signing
Documents).

General
The options on the LibreOffice – General page (Figure 18) are described below.
Help
Extended tips
When Extended tips is active, a brief description of the function of an icon or menu
command or a field on a dialog appears when you hold the mouse pointer over that item.
Show “No offline help installed” popup
Deselect to disable this popup dialog when you select Help, if offline help is not installed.
Show “Tip of the Day” dialog on start-up
Deselect to disable the “Tip of the Day” dialog. You can also disable this from the dialog.
Open/Save Dialogs – Use LibreOffice dialogs
Select this option to use the Open and Save dialogs supplied with LibreOffice. Deselect to
use the standard Open and Save dialogs of your operating system. This guide uses the
LibreOffice Open and Save dialogs in illustrations.
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Figure 18: Setting general options for LibreOffice
Document Status – Printing sets “document modified” status
If this option is selected, then the next time you close the document after printing, the print
date is recorded in the document properties as a change and you will be prompted to save
the document again, even if you did not make any other changes.
Year (Two Digits)
Specifies how two-digit years are interpreted. For example, if the two-digit year is set to
1930, and you enter a date of 1/1/30 or later into your document, the date is interpreted as
1/1/1930 or later. An “earlier” date is interpreted as being in the following century; that is,
1/1/20 is interpreted as 1/1/2020.
Help Improve LibreOffice
Collect usage data and send it to The Document Foundation
(Linux only.) Send usage data to help The Document Foundation improve usability of the
software. The usage data is sent anonymously and carries no document contents, only the
commands used.
Send crash reports to The Document Foundation
(Windows only.) If this option is selected, the Error Report Tool starts automatically when a
program crash occurs. The tool gathers all necessary information that can help the program
developers to improve the code. You can include some additional information that may help
the developers to localize the error. For more information, see the Help.
LibreOffice Quickstarter – Load LibreOffice during system start-up
When this option is selected, the necessary library files are loaded when the computer is
started, resulting in a shorter startup time for LibreOffice components. The old menu in the
system tray is no longer used. Not available on macOS.
LibreOffice File Associations – Windows Default apps button
(Windows only.) Opens Default apps dialog in Windows.
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Perform check for default file associations on start-up
(Windows only.) When selected, LibreOffice checks file associations on startup and
displays a message if any relevant formats are not registered to be opened by default in
LibreOffice.

View
The options on the LibreOffice – View page affect how the document window looks and behaves.
Some of these options are described below Figure 19. Set them to suit your personal
preferences. Some of the available options vary with your computer’s operating system; the
figure shows the options on Windows 10.

Figure 19: Choosing View options for LibreOffice applications
Icon style
Choose the icon style used in toolbars and dialogs. The Automatic option uses an icon set
compatible with your operating system and choice of desktop. Several icon sets are
available: Breeze, Breeze Dark, Colibre, Elementary, Karasa Jaga, Sifr, Sifr Dark,
Sakapura, and others. You can add other icon sets using extensions; see Chapter 14,
Customizing LibreOffice. Click the Extensions icon to display relevant extensions.
Icon size – Toolbar, Notebookbar, Sidebar
Choose the display size of toolbar icons: Automatic, Small, Large, Extra Large (only for
toolbar). The Automatic icon size option uses the setting for your operating system. The
toolbars, sidebar, and notebookbar (tabbed, grouped, and contextual versions) can have
different settings.
Visibility – Menu icons, Shortcuts
You can choose to hide or show icons as well as text on Menu bar and context menu items.
Mouse – Positioning
Specifies if and how the mouse pointer will be positioned in newly opened dialogs.
Mouse – Middle button
Defines the function of the middle mouse button (if present).
– Automatic scrolling – dragging while pressing the middle mouse button shifts the view.
– Paste clipboard – pressing the middle mouse button inserts the contents of the
Selection clipboard at the cursor position.
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The Selection clipboard is independent of the normal clipboard that you use by Edit >
Copy/Cut/Paste. Clipboard and Selection clipboard can contain different contents at the
same time.
Function

Clipboard

Selection clipboard

Copy content

Edit > Copy Ctrl+C

Select text, table, or object.

Paste content

Edit > Paste Ctrl+V pastes
at the cursor position.

Clicking the middle mouse button
pastes at the mouse pointer position.

Pasting into
another document

No effect on the clipboard
contents.

The last marked selection is the
content of the Selection clipboard.

Graphics Output
These selections are not supported on all operating systems and LibreOffice distributions.
Use hardware acceleration
Directly accesses hardware features of the graphical display adapter to improve the screen
display.
Use anti-aliasing
Enables and disables anti-aliasing, which makes the display of most graphical objects look
smoother and with fewer artifacts.

Tip
Press Shift+Ctrl+R to restore or refresh the view of the current document after
changing the anti-aliasing settings, to see the effect.
Use Skia for all rendering
Enables and disables the use of the 3D graphics language Skia.
Force Skia software rendering
Forces the use of Skia even if the graphics device is blacklisted. A device is blacklisted
when it is buggy or may render graphics with poor quality.
Font Lists
Show preview of fonts
Causes the font list to look like Figure 20, Left, with the font names shown as an example
of the font; with the option deselected, the font list shows only the font names (Figure 20,
Right). The fonts listed are those that are installed on your system. Some fonts show an
additional preview of some sample text.

Figure 20: Font list (Left) with preview; (Right) without preview
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Screen font anti-aliasing
Select this option to smooth the screen appearance of text. Enter the smallest font size to
apply anti-aliasing.
Run Graphics Tests button
Click this button to run some tests to help determine the efficiency of LibreOffice’s graphics
rendering. Results are saved in a log, which is displayed in a pop-up window and can be
downloaded.

Print
On the LibreOffice – Print page (Figure 21), you can set the print options to suit your default
printer and your most common printing method. Most of these options should be self-explanatory.

Figure 21: Choosing general printing options for all components
In the Warnings section, you can choose whether to be warned if the paper size or orientation
specified in your document does not match the paper size or orientation available for your printer.
Having these warnings turned on can be quite helpful, particularly if you work with documents
produced by people in other countries where the standard paper size is different from yours.

Tip
If your printouts are incorrectly placed on the page or chopped off at the top, bottom,
or sides, or the printer is refusing to print, a likely cause is page size incompatibility.

Note
Linux installations have an extra option (not shown in Figure 21): PDF as Standard
Print Job Format. Select this option to change the internal print job format from a
Postscript document description to a PDF description. This format has a number of
advantages over Postscript. For more information, see
https://www.linuxfoundation.org/collaborate/workgroups/openprinting/
pdf_as_standard_print_job_format
Deselecting this option reverts to a Postscript document workflow.

Chapter 2, Setting up LibreOffice | 45

Paths
On the LibreOffice – Paths page, you can change the location of files associated with, or used by,
LibreOffice to suit your working situation. For example, you might want to store documents by
default somewhere other than My Documents.
To make changes, select an item in the list shown in Figure 22 and click Edit. On the Select Path
dialog (not shown; may also be titled Edit Paths), add or delete folders as required, and then click
OK to return to the Options dialog.
Some items can have at least two paths listed: the User Path is to a user-specific folder (normally
on the user’s personal computer) and the Internal Path is to a shared folder where LibreOffice is
installed (which might be on a network).

Tip
You can use the entries on the LibreOffice – Paths page to compile a list of files,
such as those containing AutoText, that you need to back up or copy to another
computer.

Figure 22: Viewing the paths of files used by LibreOffice

Fonts
You can define replacements for any fonts that might appear in your documents. If you receive
from someone else a document containing fonts that you do not have on your system,
LibreOffice will substitute fonts for those it does not find. You might prefer to specify a different
font from the one that the program chooses.

Note
These choices do not affect the default font for your documents. To do that, you need
to change the default template for documents, as described in Chapter 3, Using
Styles and Templates. In Writer, some basic fonts can be changed using the Basic
Fonts options pages; see the Writer Guide or Help for more information.
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On the LibreOffice – Fonts page (Figure 23):
1) Select the Apply replacement table option.
2) Select or type the name of the font to be replaced in the Font box. (If you do not have this
font on your system, it will not appear in the drop-down list in this box, so you need to
type it in.)
3) In the Replace with box, select a suitable font from the drop-down list of fonts installed on
your computer.
4) Click on the tick (check) icon to the right of the Replace with box. A row of information
now appears in the larger box below the input boxes. Select Always to replace the font,
even if the original font is installed on your system. Select Screen only to replace the
screen font only and never replace the font for printing. The results of combining these
selections are given in Table 1.
5) In the bottom section of the page, you can change the typeface and size of the font used
to display source code such as HTML and Basic (in macros).

Figure 23: Defining a font to be substituted for another font
Table 1. Font substitution replacement actions
Always
checkbox
checked
checked
blank
blank

Screen only
checkbox
blank
checked
checked
blank

Replacement action
Font replaced on screen and when printing, whether the
font is installed or not.
Font replaced only on screen, whether the font is
installed or not.
Font replaced only on screen, but only if font is not
available.
Font replaced on screen and when printing, but only if
font is not available.
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Security
Use the LibreOffice – Security page (Figure 24) to choose security options for saving documents
and for opening documents that contain macros.
Security Options and Warnings
If you record changes, save multiple versions, or include hidden information or notes in
your documents, and you do not want some of the recipients to see that information, you
can set warnings to remind you to remove it, or you can have LibreOffice remove some of it
automatically. Note that (unless removed) much of this information is retained in a file
whether the file is in LibreOffice’s default OpenDocument format, or has been saved to
other formats, including PDF.
Click the Options button to open a separate dialog with specific choices (Figure 25). See
“Security options and warnings” on page 49.

Figure 24: Choosing security options for opening and saving documents
Passwords for Web Connections
You can enter a master password to enable easy access to websites that require a user
name and password. LibreOffice will securely store all passwords that you use to access
files from web servers. You can retrieve the passwords from the list after you enter the
master password.
Macro Security
Click the Macro Security button to open the Macro Security dialog (not shown here),
where you can adjust the security level for executing macros and specify trusted sources.
Certificate Path (Not available on Windows)
Users can digitally sign documents using LibreOffice. A digital signature requires a personal
signing certificate. Most operating systems can generate a self-signed certificate. However,
a personal certificate issued by an outside agency (after verifying an individual’s identity)
has a higher degree of trust associated with it than does a self-signed certificate.
LibreOffice does not provide a secure method of storing these certificates, but it can access
certificates that have been saved using other programs. Click the Certificate button and
select which certificate store to use. Not available on Windows; LibreOffice uses the default
Windows location for storing and retrieving certificates.
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TSAs –Time Stamping Authorities
You can optionally select a Time Stamping Authority (TSA) URL for PDF documents
created by LibreOffice. Recipients of PDF documents with a trusted timestamp can verify
when the document was digitally or electronically signed, as well as verify that the
document was not altered after the date the timestamp vouches for.

Security options and warnings
Most of the options on the Security Options and Warnings dialog (Figure 25) should be selfexplanatory.

Figure 25: Security Options and Warnings dialog
Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file.
To save personal information with documents and still be able to manually remove personal
information from specific documents, deselect this option.
Ctrl+click required to open hyperlinks
The default behavior to open a hyperlink in LibreOffice is to Ctrl+click on the hyperlink.
Many people find creation and editing of documents easier when accidental clicks on links
do not activate the links. To set LibreOffice to activate hyperlinks using an ordinary click,
deselect this option.

Personalization
You can customize the overall appearance of LibreOffice with themes.
On the LibreOffice – Personalization page, select Preinstalled Theme and then click on a theme
thumbnail and click Apply. After a brief pause the appearance of LibreOffice will refresh and
reflect the selected theme.
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Figure 26: Selecting a preinstalled theme

Application colors
Writing, editing, and page layout are often easier when you can see the page margins (text
boundaries), the boundaries of tables and sections (in Writer documents), page breaks in Calc,
grid lines in Draw or Writer, and other features. In addition, you might prefer to use colors that are
different from LibreOffice’s defaults for such items as comment indicators or field shadings.
On the LibreOffice – Application Colors page (Figure 27), you can specify which items are visible
and the colors used to display various items.

Figure 27: Showing or hiding text, object, and table boundaries
•

To show or hide items such as text boundaries, select or deselect the checkboxes next to
the names of the items.
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•

To change the default colors for items, click the down-arrow in the Color setting column
by the name of the item and select a color from the list box. Note that you can change
the list of available colors by selecting other available palettes from the drop-down list.

•

To save your color changes as a color scheme, click Save, type a name in the Name of
color scheme box in the popup dialog (not shown), and then click OK.

Note
To change the color settings used in Track Changes mode, go to Tools > Options >
LibreOffice Writer > Changes.

Accessibility
Accessibility options include whether to allow animated graphics or text, some options for high
contrast display, and a way to change the font for the LibreOffice user interface.
Accessibility support relies on the Java Runtime Environment for communication with assistive
technology tools. The Support assistive technology tools option is not shown on all LibreOffice
installations. See Assistive Tools in LibreOffice in the Help for other requirements and
information.
Select or deselect the options on the LibreOffice – Accessibility page (Figure 28) as required.

Figure 28: Choosing accessibility options

Advanced
LibreOffice needs Java to run several wizards, the Mediawiki Publisher (if available; see
“Choosing Internet options” on page 63), and some functions in the Base component.

Note
Users of Windows should find a suitable Java Runtime Environment (JRE) already
installed on their machines. Linux users may need to get one from their distribution’s
software repository if it is not already installed. Users of macOS need to install
Oracle’s Java Development Kit (JDK), not just the JRE. To get the required JDK,
select the macOS option at https://www.oracle.com/java/technologies/downloads/
Java Options
If you install or update a JRE or JDK after you install LibreOffice, or if you have more than
one JRE installed on your computer, you can use the LibreOffice – Advanced options page
to choose the JRE for LibreOffice to use.
If LibreOffice finds one or more JREs on your computer, it will display them in the large box.
You can then choose one of the JREs listed.
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If you are a system administrator, programmer, or other person who customizes JRE
installations, you can use the Parameters and Class Path dialogs (reached using the
buttons on the right) to specify this information.

Figure 29: Choosing a Java runtime environment
Optional Features
Enable experimental features (may be unstable)
Select this option to enable features that are not yet complete or contain known bugs. The
list of these features is different version by version.
Enable macro recording (may be limited)
This option enables macro recording, with some limitations. Opening a window, switching
between windows, and recording in a different window to that in which the recording began,
are not supported. Only actions relating to document contents are recordable, so changes
in options or customizing menus are not supported. For more about macro recording, see
Chapter 13, Getting Started with Macros.
Open Expert Configuration
Most users will have no need to use this. Click this button to open a new dialog in which
you can fine-tune the LibreOffice installation. The dialog offers detailed configuration
options for many aspects of LibreOffice’s appearance and performance. Double-click on a
listed preference to enter a value to configure the preference.

Caution
The Expert Configuration dialog lets you access, edit, and save configuration
preferences that can turn the user profile of LibreOffice unstable, inconsistent, or
even unusable. If you do not know what an option does, you can best leave it as the
default.
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Online update
On the LibreOffice – Online Update page (Figure 30), you can choose whether and how often to
have the program check the LibreOffice website for program updates. If the Check for updates
automatically option is selected, an icon appears at the right-hand end of the Menu bar when an
update is available. Click this icon to open a dialog where you can download the update.
If the Download updates automatically option is selected, the download starts when you click
the icon. To change the download destination, click the Change button and select the required
folder in the file browser window.
If the Send OS version and basic hardware information option is selected, information about
the computer architecture and operating system will be sent to the server for statistics collection.

Figure 30: Online update options

OpenCL
OpenCL (Open Computing Language) is a software architecture used to write programs that run
in different processors of the computer, such as the CPU and GPU (graphics processing unit) of
the video card. With OpenCL enabled, LibreOffice can benefit from the very fast numerical
calculations performed in the GPU, which is especially useful in very large spreadsheets with
extensive calculations. The computer’s video card driver must have support for OpenCL to use
this feature.

Choosing options for loading and saving documents
You can set the options for loading and saving documents to suit the way you work.
If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or
triangle) to the left of Load/Save.

General
Most of the choices on the Load/Save – General page (Figure 31) are familiar to users of other
office suites. Some items of interest are described below.
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Figure 31: Choosing Load and Save options
Load user-specific settings with the document
A LibreOffice document contains settings that are read from the user’s system. When you
save a document, these settings are saved with it. Select this option so that when a
document loads, it ignores the stored settings in favor of the settings on your computer.
Even if you do not select this option, some settings are taken from your LibreOffice
installation:
•

Settings in File > Print > Options.

•

Spacing options for paragraphs before text tables.

•

Information about automatic updating for links, field functions, and charts.

•

Information about working with Asian character formats.

•

Data source linked to the document and its view.

If you deselect this option, the user’s personal settings do not overrule the settings in the
document. For example, your choice (in the options for LibreOffice Writer) of how to update
links is affected by the Load user-specific settings with the document option.
Load printer settings with the document
If enabled, the printer settings will be loaded with the document. This can cause a
document to be printed on a distant printer (perhaps in an office setting), if you do not
change the printer manually in the Print dialog. If disabled, your default printer will be used
to print this document. The current printer settings will be stored with the document whether
or not this option is selected.
Save AutoRecovery information every __ minutes
Choose whether to enable AutoRecovery and how often to save the information used by
the AutoRecovery process. AutoRecovery in LibreOffice saves the information needed to
restore all open documents in case of a crash. If you have this option set, recovering your
document after a system crash will be easier.
Edit document properties before saving
If you select this option, the Document Properties dialog pops up to prompt you to enter
relevant information the first time you save a new document (or whenever you use Save
As).
54 | LibreOffice 7.3 Getting Started Guide

Always create backup copy
Saves the previously-saved version of a document as a backup copy in a separate folder
whenever you save a document. When LibreOffice creates a new backup copy, the
previous backup copy is replaced. The backup copy gets the extension BAK. Authors
whose work may be very lengthy should always consider using this option.
To see or change the backup folder, go to Tools > Options > LibreOffice > Paths. When
opening a backup file, you will be prompted to specify the program to open it with; choose
LibreOffice.
Save URLs relative to file system / internet
Use these options to select the default for relative addressing of URLs in the file system
and on the Internet. Relative addressing is only possible if the source document and the
referenced document are both on the same drive.
A relative address always starts from the directory in which the current document is
located. In contrast, absolute addressing always starts from a root directory. The following
table demonstrates the difference in syntax between relative and absolute referencing.
Examples

File system

Internet

relative

../images/img.jpg

../images/img.jpg

absolute

file:///c|/work/images/img.jpg

http://myserver.com/work/images/img.jpg

If you choose to save relatively, the references to embedded graphics or other objects in
your document will be saved relative to the location in the file system. In this case, it does
not matter where the referenced directory structure is recorded. The files will be found
regardless of location, as long as the reference remains on the same drive or volume. This
is important if you want to make the document available to other computers that may have
a completely different directory structure, drive or volume names. It is also recommended to
save relatively if you want to create a directory structure on an Internet server.
If you prefer absolute saving, all references to other files will also be defined as absolute,
based on the respective drive, volume or root directory. The advantage is that the
document containing the references can be moved to other directories or folders, and the
references remain valid.
Default File Format and ODF Settings
ODF format version. LibreOffice by default saves documents in OpenDocument Format
(ODF) version 1.3 Extended. While this allows for improved functionality, there may be
backwards compatibility issues. When a file saved in ODF 1.3 Extended is opened in an
editor that uses an earlier version of ODF, some of the advanced features may be lost. If
you plan to share documents with people who use editors that use older versions of ODF
(such as Apache OpenOffice or LibreOffice 3.x), you may wish to save the document using
ODF 1.2 Extended (compatibility mode).
Document type. If you routinely share documents with users of Microsoft Office, you might
want to change the Always save as attribute for documents to the Microsoft Office formats.
Current versions of Microsoft Word can open ODT files, so this may no longer be needed.

VBA properties
On the Load/Save – VBA Properties page, you can choose whether to keep any macros in
Microsoft Office documents that are opened in LibreOffice.
If you choose Load Basic code, you can edit the macros in LibreOffice. The changed code is
saved in an ODF document but is not retained if you save into a Microsoft Office format.
If you choose Save original Basic code, the macros will not work in LibreOffice but are retained
unchanged if you save the file into Microsoft Office format.
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If you are importing a Microsoft Word or Excel file containing VBA code, you can select the option
Executable code. Whereas normally the code is preserved but rendered inactive (if you inspect
it with the Basic IDE you will notice that it is all commented), with this option the code is ready to
be executed.

Figure 32: Choosing Load/Save
VBA Properties
Save original Basic code takes precedence over Load Basic code. If both options are selected
and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved
when saving in a Microsoft Office format.
To remove any possible macro viruses from the Microsoft Office document, deselect Save
original Basic code. The document will be saved without the Microsoft Basic code.

Microsoft Office
On the Load/Save – Microsoft Office page (Figure 33), you can choose what to do when
importing and exporting Microsoft Office OLE objects (linked or embedded objects or documents
such as spreadsheets or equations).
The Embedded Objects section specifies how to import and export Microsoft Office OLE objects.
These settings are valid when no Microsoft OLE server exists (for example, in UNIX) or when
there is no LibreOffice OLE server ready for editing the OLE objects. If an OLE server is active
for the embedded object, then the OLE server will be used to handle the object.
Select the [L] options to convert Microsoft OLE objects into the corresponding LibreOffice OLE
objects when a Microsoft document is loaded into LibreOffice (mnemonic: “L” for “load”).
Select the [S] options to convert LibreOffice OLE objects into the corresponding Microsoft OLE
objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”). Linux
installations may include selectable [S] options not shown in the illustration for the last three
items.
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Figure 33: Choosing Load/Save Microsoft Office options
Character Highlighting – Export as
Microsoft Office has two character attributes similar to LibreOffice character background.
Select the appropriate attribute (Highlighting or Shading) to use during export to Microsoft
Office file formats.
Lock files – Create MSO lock file
LibreOffice can report which Microsoft Office user has locked a document by reading the
lock files generated by MSO; and when the Create MSO lock file option is selected,
LibreOffice will generate such files in addition to its own lock files, so MSO users can know
who has locked a document.

HTML compatibility
Choices made on the Load/Save – HTML Compatibility page (Figure 34) affect HTML pages
imported into LibreOffice and those exported from LibreOffice. See HTML documents;
importing/exporting in the Help for more information.

Figure 34: Choosing HTML compatibility options
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Font Sizes
Use these fields to define the respective font sizes for the HTML <font size=”1”> to <font
size=”7”> tags, if they are used in the HTML pages. (Many HTML pages no longer use
these tags.)
Import
Use 'English (USA)' locale for numbers
When importing numbers from an HTML page, the decimal and thousands separator
characters differ according to the locale of the HTML page. The clipboard, however,
contains no information about the locale. If this option is not selected, numbers will be
interpreted according to the Locale setting in Tools > Options > Language Settings >
Languages (see “Change some locale and language settings” on page 59). If this option is
selected, numbers will be interpreted as for the English (USA) locale.
Import unknown HTML tags as fields
Select this option if you want tags that are not recognized by LibreOffice to be imported as
fields. For an opening tag, an HTML_ON field will be created with the value of the tag
name. For a closing tag, an HTML_OFF will be created. These fields will be converted to
tags in the HTML export.
Ignore font settings
Select this option to have LibreOffice ignore all font settings when importing. The fonts that
were defined in the HTML page style will be used.
Export
LibreOffice Basic
Select this option to include LibreOffice Basic macros (scripts) when exporting to HTML
format. You must activate this option before you create the LibreOffice Basic macro;
otherwise the script will not be inserted. LibreOffice Basic macros must be located in the
header of the HTML document. Once you have created the macro in the LibreOffice Basic
IDE, it appears in the source text of the HTML document in the header. If you want the
macro to run automatically when the HTML document is opened, choose Tools >
Customize > Events. See Chapter 13, Getting Started with Macros, for more information.
Display warning
When the LibreOffice Basic option (see above) is not selected, the Display warning
option becomes available. If the Display warning option is selected, then when exporting
to HTML a warning is shown that LibreOffice Basic macros will be lost.
Print layout
Select this option to export the print layout of the current document as well. The HTML filter
supports CSS2 (Cascading Style Sheets Level 2) for printing documents. These
capabilities are only effective if print layout export is activated.
Copy local images to Internet
Select this option to automatically upload the embedded pictures to the Internet server
when uploading using FTP.
Character set
Select the appropriate character set for the export.

Choosing language settings
To customize the language settings in LibreOffice, you can do any of the following:
•

Install the required dictionaries

•

Change some locale and language settings

•

Choose spelling options
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Install the required dictionaries
LibreOffice automatically installs many language modules with the program. A language module
can contain up to three submodules: spelling dictionary, hyphenation dictionary, and thesaurus.
These are usually referred to as “dictionaries” in LibreOffice. To add other language modules, be
sure you are connected to the Internet, and then choose Tools > Language Settings > Writing
Aids and click the Get more dictionaries online link (Figure 37). LibreOffice will open a window
containing links to additional dictionaries. Select and install the ones you want.

Change some locale and language settings
You can change some details of the locale and language settings that LibreOffice uses for all
documents, or for specific documents.
In the Options dialog, click the expansion symbol (+ or triangle) by Language Settings (Figure
35). The exact list shown depends on the language support settings (Figure 36).

Figure 35: LibreOffice language options, without and with Asian and
CTL options enabled
On the right-hand side of the Language Settings – Languages page (Figure 36), change the User
interface, Locale setting, Default currency, and Default Languages for Documents as required. In
the example, English (USA) has been chosen for all the appropriate settings.
Language Of
User interface
The language of the user interface is usually set at the time LibreOffice is installed to match
the language of the operating system. If more than one language has been installed for
LibreOffice, you can select which language will be used for menus, dialogs, and help files.
Formats
Locale setting
The locale setting is the basis for many other settings within LibreOffice, for example
defaults for numbering, currency, and units of measure. Unless you select something else
here, the locale of the operating system will be set as default.
Default currency
The default currency is that used in the country entered as locale. The default currency
determines the proper formatting of fields formatted as currency. If the locale setting is
changed, the default currency changes automatically. If the default currency is changed, all
dialogs involving currency and all currency icons will be changed in all open documents.
Documents that were saved with one currency as the default will open using the new
currency defaults.
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Decimal separator key
If the Decimal separator key – Same as locale setting option is selected, LibreOffice uses
the character defined by the default locale. If this option is not selected, the keyboard driver
defines the character used.

Figure 36: Choosing language options
Date acceptance patterns
Date acceptance patterns define how LibreOffice recognizes input as dates. Locale also
defines the default expression of dates. You can define additional date patterns, separated
by semicolons, using Y, M, & D for Year, Month, and Day. LibreOffice will always correctly
interpret dates entered in ISO 8601 format as Y-M-D and YYYY-MM-DD.

Caution
Data entered into a Calc spreadsheet or a Writer table must be entered in a format
defined by locale in order to be recognized as dates.
Default Languages for Documents
Select the languages used for the spelling checker, thesaurus, and hyphenation features of
LibreOffice. If these options are only for the current document, select For the current
document only.
Select Asian: to enable support for Asian languages (Chinese, Japanese, Korean). Select
Complex Text Layout: to enable support for languages such as Urdu, Thai, Hebrew, and
Arabic. If you select either of these options, you will see some extra choices under
Language Settings the next time you open this dialog, as shown in Figure 35. These
choices (Searching in Japanese, Asian Layout, and Complex Text Layout) are not
discussed here.

Note
An ABC icon in front of a language indicates that a spelling dictionary, thesaurus, and
hyphenation dictionary are activated for this language.
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Enhanced Language Support
Ignore system input language
Default language settings depend on the locale setting. The default locale is based on that
of the computer’s operating system. A keyboard layout is normally based on the language
used by the operating system but can be changed by the user. If this option is not selected,
and there is a change in keyboard layout, input from the keyboard will be different from
what is expected.

Choose spelling options
To choose the options for checking spelling, click Language Settings > Writing Aids.
For details on using the Available Language Modules and User-defined Dictionaries sections,
please see the Help.
In the Options section of the page (Figure 37), choose the settings that are useful for you.

Figure 37: Choosing languages, dictionaries, and options for checking spelling
Some considerations:
•

If you want spelling checked while you type, you must have Check spelling as you type
enabled.

•

If you want grammar to be checked as you type, you must have both Check grammar as
you type and Check spelling as you type enabled.

•

If you use a custom dictionary that includes words in all uppercase and words with
numbers (for example, AS/400), select Check uppercase words and Check words
with numbers.

•

Check special regions means that text in headers, footers, frames, and tables are also
checked when checking spelling.

Here you can also select which user-defined (custom) dictionaries are active by default, and add
or remove user-installed dictionaries, by clicking the New or Delete buttons. Dictionaries installed
by the system cannot be deleted.
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English sentence checking
On the Language Settings – English Sentence Checking page (Figure 38), you can choose which
items are checked for, reported to you, or converted automatically.
After selecting the additional grammar checks, you must restart LibreOffice, or reload the
document, for them to take effect.

Figure 38: Choosing options for checking sentences in English

Grammar checking
Possible mistakes
Checks for things such as subject-verb conflict, mood, tense; “with it’s”, “he don’t”, “this
things” and so on.
Capitalization
Checks for the capitalization of sentences. The sentence boundary detection depends on
abbreviations.
Word duplication
Checks for all word duplication, rather than just the default words ‘and’, ‘or’, ‘for’, and ‘the’.
Parentheses
Checks for pairs of parentheses and quotation marks.

Punctuation
Word spacing
This option is selected by default. It checks for single spaces between words, indicating
instances of double or triple spaces, but not of more spaces than that.
Quotation marks
Checks for correct typographical double quotation marks.
Sentence spacing
Checks for a single space between sentences, indicating when one or two extra spaces are
found.
Apostrophe
Replaces an apostrophe with the correct typographical character.
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More spaces
Checks word and sentence spacing for more than two extra spaces.
Em dash; En dash
These options force a non-spaced em dash to replace a spaced en dash, or force a spaced
en dash to replace a non-spaced em dash.
Multiplication sign
This option is selected by default. It replaces an ‘x’ used as a multiplication symbol with the
correct typographical symbol.
Ellipsis
Replaces three consecutive periods (full stops) with the correct typographical symbol.
Minus sign
Replaces a hyphen with the correct minus typographical character.

Others
Convert to metric; Convert to non-metric
Converts quantities in a given type of unit to quantities in the other type of unit: metric to
imperial or imperial to metric.
Thousands separation of large numbers
Converts a number with five or more significant digits to a common format, depending on
the locale setting for the document. One uses the comma as a thousands separator; the
other is ISO format, which uses a narrow space as a separator.

Sentence checking in other languages
LibreOffice can check sentences in many languages. These checkers are enabled by default if
the language is the computer’s default language, and others can be added using the Extension
Manager. The set of rules available for these sentence checkers depends on the language.

Choosing Internet options
The Internet options available depend on your operating system.
Use the Proxy page (if available) to save proxy settings for use with LibreOffice.
If you are using Linux or macOS, an additional page of Email options is available, where you can
specify the program to use when you send the current document as email. Under Windows, your
default email program is always used.
To suppress (exclude) hidden elements such as tracked changes, hidden sections, hidden tabs in
a spreadsheet, or hidden layers in a drawing, select the Suppress hidden elements of
documents option.

Figure 39: Internet options, showing Email page available to Linux and macOS users
A MediaWiki publisher is included on Windows and Linux. To enable it, select MediaWiki in the
Internet options, then click the Add button to open a dialog where you can specify the address
(URL) and login information for a wiki. You can add several wikis to the list. A JRE (Java Runtime
Environment) is needed for this feature to work.
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Controlling LibreOffice’s AutoCorrect functions
LibreOffice’s AutoCorrect functions automatically detect and replace common symbols, spelling
mistakes, and grammar mistakes. Sometimes, AutoCorrect changes something that should have
been kept. If unexplained changes appear in your document, the AutoCorrect settings are often
the cause.
Click Tools > AutoCorrect > AutoCorrect Options to customize AutoCorrect. You must have a
document open for this menu item to appear. Use the tabs to add, edit, and delete AutoCorrect
options. In Writer, this dialog has five tabs. In other components of LibreOffice, the dialog has
only four tabs. Find more details in the relevant component guides.
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Getting Started Guide 7.3

Chapter 3,
Styles and Templates
Using consistent formatting in your documents

Introduction
There are two basic ways to format text and other elements. Understanding these two
alternatives is essential for unlocking the power of LibreOffice.
Direct (or manual) formatting
Applies formatting directly to specific paragraphs, characters, pages, frames, lists, tables,
cells, and other elements. For example, you can select a word, then click on an icon on the
Formatting toolbar or the Sidebar to format the text as bold or italic.
Styles
Bundles formatting attributes under one name. For example, a paragraph style defines
numerous settings such as font type and size, whether paragraphs should be indented, the
space between lines, how paragraphs should be aligned on the page, and many others.

Using styles is highly recommended
LibreOffice is a styles-based program. It may work somewhat differently from other programs you
are familiar with. Using styles effectively requires some planning, but the time spent in planning
can save time and effort over the longer term.
Because styles apply whole groups of attributes at the same time, you can easily format a
document consistently and change the formatting of an entire document with minimal effort.
Styles are also used by LibreOffice for many processes, even if you are not aware of them. For
example, Writer relies on heading styles (or other styles you specify) when it compiles a table of
contents. Some common uses of styles are given in “Examples of style use” on page 84.

Note
Direct formatting overrides styles. You cannot remove manual formatting by applying
a style to it. To remove direct formatting, select the text, right-click, and choose Clear
Direct Formatting in the context menu. Alternatively you can clear direct formatting
from selected text by pressing Ctrl+M (Ctrl+Shift+M in Impress), by selecting Format
> Clear Direct Formatting on the Menu bar, by selecting the Clear Direct
Formatting icon on Writer’s Formatting toolbar, or by selecting the Clear Direct
Formatting icon on Calc’s Standard toolbar.

What are styles?
A style is a set of formats that you can apply to selected elements such as pages, text, frames,
cells, and others in a document to quickly set or change their appearance. Applying a style often
means applying a group of formats at the same time.
Many people manually format paragraphs, words, tables, page layouts, and other parts of their
documents without paying any attention to styles. They are accustomed to manually applying
attributes such as the font family, font size, and any formatting such as bold or italic.
Using styles means that instead of applying “font size 14pt, Times New Roman, bold, centered”
you can apply (for example) a “Title” style, because you have defined the “Title” style to have
those characteristics. In other words, using styles means that you shift the emphasis from what
the text (or page, or other element) looks like, to what the text is.
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Types of styles in LibreOffice
LibreOffice supports the following types of styles:
•

Page styles include margins, headers and footers, borders and backgrounds. In Calc,
page styles also define the sequence for printing sheets.

•

Paragraph styles control all aspects of a paragraph’s appearance, such as text
alignment, tab stops, line spacing, and borders, and can include character formatting.

•

Character styles affect selected text within a paragraph, such as the font and size of
text, or bold and italic formats.

•

Table styles apply predefined formats to tables and table elements in a text document.

•

Frame styles are used to format graphic and text frames, including text wrap, borders,
backgrounds, and columns.

•

List styles allow you to select, format, and position numbers or bullets in lists.

•

Cell styles include fonts, alignment, borders, background, number formats (for example,
currency, date, number), and cell protection.

•

Drawing styles in drawings and presentations include line, area, shadowing,
transparency, font, connectors, dimensioning, and other attributes.

•

Presentation styles include attributes for font, indents, spacing, alignment, and tabs.

Different styles are available in the various components of LibreOffice, as listed in Table 2.
Details are given in the user guide for each component.
LibreOffice comes with many predefined styles. You can use the styles as provided, modify them,
or create new ones, as described in this chapter.
Table 2. Styles available in LibreOffice components
Style Type

Writer

Calc

Draw

Impress

Page

X

X

Paragraph

X

Character

X

Frame

X

List

X

Table

X

Presentation

X

X

Drawing

X

X

Cell

X

Applying styles
LibreOffice provides several ways for you to select and apply styles:
•

Styles deck on the Sidebar

•

Styles menu on the Menu bar (Writer and Calc)

•

Set Paragraph Style list (Writer) and Apply Style list (Calc) on the Formatting toolbar

•

Right-click context menu (Writer and Calc)

•

Fill Format mode (Writer and Calc)

•

Keyboard shortcuts
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Styles deck in the Sidebar
The Styles deck includes the most complete set of tools for styles. To use it for applying styles:
1) Select View > Styles or Styles > Manage Styles on the Menu bar, or press F11 (⌘+T on
macOS), or click the Styles tab on the Sidebar (View > Sidebar to open it).
The Styles deck optionally shows previews of the styles available. Figure 40 shows the
panel for Writer, with Paragraph Styles visible and with previews off.
2) Select one of the icons at the top left of the Styles deck to display a list of styles in that
category.
3) To apply an existing style, position the cursor in the paragraph, frame, page, word, or cell,
and then double-click the name of the style in one of these lists. To apply a character
style to more than one word, select the characters first.

Tip
At the bottom of the Styles deck is a drop-down list where you can select what styles
will be listed in the Styles panel. In Figure 40 the list shows All Styles defined for the
document. It could show Applied Styles (only the styles used in the document) or
other groups of styles, for example Custom Styles.

Figure 40: The Styles deck for Writer, showing paragraph styles and filter

Styles menu (Writer and Calc)
In Writer, the Styles menu has the most commonly used paragraph, character, and list styles for
text documents, as well as entries for style management. The Styles menu does not have styles
for frames, pages, or tables.
To apply a paragraph style, position the cursor anywhere in the paragraph, and then select one of
the paragraph styles in the Styles menu. To apply a character style to several characters or more
than one word, select the characters first and apply the character style from the menu.
In Calc, the Styles menu has cell styles and style management entries. To apply a cell style,
select the cell or group of cells to be formatted, and then select the required style.
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Set Paragraph Style list (Writer) and Apply Style list (Calc)
In Writer, after you have used a paragraph style at least once in a document, the style name
appears in the Set Paragraph Style list at the left-hand end of the Formatting toolbar.
In Calc, after you have used a cell style at least once in a spreadsheet, the style name appears in
the Apply Style list at the left-hand end of the Formatting toolbar. If the Apply Style list is not
visible, you can enable it using one of the methods given in “Customizing toolbars” in Chapter 1,
Introducing LibreOffice.
You can open this list and click the style you want, or you can use the up and down arrow keys to
move through the list and then press Enter to apply the highlighted style.

Tip
Select More Styles at the bottom of the list (not shown in illustration) to open the
Styles deck on the Sidebar. You may need to scroll down the list to see it.

Figure 41: The Set Paragraph
Style list in Writer

Context (right-click) menu (Writer and Calc)
In Writer, right-click anywhere in a paragraph to open the context menu; choose Paragraph. Or,
right-click in a word and choose Character in the context menu. In Calc, right-click in a cell and
choose Styles in the context menu.
In each case, the submenu includes some commonly used styles. You can add styles to this
submenu; see Chapter 14, Customizing LibreOffice.

Fill Format mode (Writer and Calc)
You can use Fill Format mode to apply a style to many different areas quickly without having to
go back to the Styles deck and double-click every time. This method is quite useful when you
need to format many scattered paragraphs, cells, or other items with the same style.
1) Open the Styles deck on the Sidebar and select the style you want to apply.
2) Click the Fill Format Mode icon at the top of the Styles deck.
3) To apply a paragraph, page, frame, or cell style, hover the mouse over the paragraph,
page, frame, or cell and click.
To apply a character style, hold down the mouse button while selecting the characters.
Clicking on a word applies the character style to that word.
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4) Repeat step 3 until you have applied that style everywhere you desire.
5) To quit Fill Format mode, click the Fill Format Mode icon again or press the Esc key.

Keyboard shortcuts
Some keyboard shortcuts for applying styles are predefined. For example, in Writer Ctrl+0 applies
the Text Body style, Ctrl+1 applies the Heading 1 style, and Ctrl+2 applies the Heading 2 style.
You can modify these shortcuts and create your own; see Chapter 14, Customizing LibreOffice,
for more details.

Modifying styles
LibreOffice includes some predefined styles, and you can create custom styles (see page 72).
You can modify both predefined and custom styles in several ways:
•

Change a style using the Styles deck in the Sidebar

•

Update a style from a selection

•

Use AutoUpdate (paragraph and frame styles only)

•

Load styles from another document or template

Note
Any changes you make to a style are effective only in the current document. To
change styles in more than one document, you need to change the template or load
styles from one document to another.

Changing a style using the Styles deck
To change an existing style using the Styles deck on the Sidebar, right-click on the required style
and select Modify in the context menu.
A Style dialog is displayed with title, content, and layout dependent on the type of style selected.
Each variant of the dialog has several tabs. See the chapters on styles in the component user
guides for more information.

Tip
You can also access the relevant Style dialogs through the Set Paragraph Style
(Writer) and Apply Style (Calc) lists. Click the arrow at the right of the entry for the
style to be modified and select Edit Style in the context menu. You can access the
appropriate Style dialog for the style of the current selection by going to Styles >
Edit Style on the Menu bar.

Updating a style from a selection
To update a style from a selection:
1) Open the Styles deck on the Sidebar.
2) In the document, select an item that has the format you want to adopt as a style.

Caution
When updating a paragraph style, make sure that the selected paragraph contains
unique properties. If it mixes font sizes or font styles, those mixed properties will
remain the same as before.
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3) On the Styles deck, select the style to update, then click on the arrow next to the Styles
actions icon and select Update Selected Style (Figure 42).

Figure 42: Updating a style from a selection

Tip
Other ways to modify the current style include pressing Ctrl+Shift+F11 (Writer),
selecting Styles > Update Selected Style on the Menu bar (Writer and Calc), or
clicking the Update Selected Style icon on the Formatting toolbar (Writer).
You can also modify a style through the Set Paragraph Style (Writer) and Apply
Style (Calc) lists. Click the arrow at the right of the entry for the style to be modified
and select Update to Match Selection in the drop-down menu (Figure 43).

Figure 43: Modifying a style from the Set Paragraph Style list

Using AutoUpdate (Writer)
AutoUpdate applies to paragraph and frame styles only. If the AutoUpdate option is selected on
the Organizer page of the Paragraph Style or Frame Style dialog, applying direct formatting to a
paragraph or frame using this style in the document automatically updates the style itself.

Tip
If you are in the habit of manually overriding styles in your document, be sure that
AutoUpdate is not enabled.
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Creating new (custom) styles
You may want to add some new styles. You can do this by using the Style dialog, or the New
Style from Selection tool, or by dragging and dropping, as explained below.

Creating a new style using the Style dialog
To create a new style using the Style dialog, open the Styles deck on the Sidebar and select the
category of the style you wish to create by clicking one of the icons at the top of the deck. Then
right-click on any style name and select New in the context menu.
The new style will inherit characteristics from the style that you selected. If you later change the
base style (for example, by changing the font from Times to Helvetica), all the linked styles will
change as well. Sometimes this is exactly what you want; other times you do not want the
changes to apply to all the linked styles. You can change any of those characteristics using the
Style dialog.
The dialogs and choices are the same for defining new styles and for modifying existing styles.
See the chapters on styles in the user guides for details.

Creating a new style from a selection
You can create a new style by copying an existing manual format. This new style applies only to
this document; it will not be saved in the template.
1) Open the Styles deck on the Sidebar and choose the category of style you want to
create.
2) In the document, select the item you want to save as a style.
3) On the Styles deck, click on the Styles actions icon and click the New Style from
Selection menu item in Writer or the New Style from Selection icon in Calc, Draw, and
Impress.
4) In the New Style from Selection dialog (Figure 44), type a name for the new style. The list
shows the names of existing custom styles of the selected category. Click OK to save the
new style.

Figure 44: Naming a new style created from a selection
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Tip
You can also create a new style from a selection by pressing Shift+F11 (Writer), by
selecting Styles > New Style from Selection (Writer, Calc), or by clicking the New
Style from Selection icon on the Formatting toolbar (Writer).

Dragging and dropping to create a style
You can drag and drop a selection into the Styles deck to create a new style. The element to drag
depends upon the LibreOffice application.
Writer
Select some text and drag it to the Styles deck to open the Create Style dialog. If
Paragraph Styles are active, the paragraph style will be added to the list. If Character
Styles are active, the character style will be added to the list.
Calc
Drag a cell selection to the Styles deck to open the Create Style dialog and create a cell
style. (Click and then Shift+Click to select the cell.)

Adding table styles in Writer
Table styles are stored in the LibreOffice user profile, and are available to all Writer documents.
You can define new table styles following these steps:
1) Create a table and apply formatting for cells, backgrounds, borders, and more.
2) Select the whole table.
3) Drag the table and drop it in the Table Styles category of the Styles deck in the Sidebar.
Alternatively:
1) Create a table and apply formatting for cells, backgrounds, borders, and more.
2) Click in the table and select Table > AutoFormat Styles on the Menu bar. On the
AutoFormat dialog (Figure 45), click the Add button.
3) In the pop-up dialog, enter a name for the new table style, and then click OK.
4) The new table style is now listed in the left pane of the AutoFormat dialog. Click OK again
to close the dialog.
The new table style can be applied to tables as described in “Applying styles” on page 67.

Figure 45: Table AutoFormat dialog
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Copying styles from a template or document (Writer)
In Writer, you can copy styles into a document by loading them from a template or from another
document:
1) Open the document you want to copy styles into.
2) On the Styles deck, click the Style actions icon, and then select Load Styles from
Template.
3) On the Load Styles from Template dialog (Figure 46), find a template from which to copy
styles. To copy styles from a document that is not a template, click the From File button
to open a file selection dialog and locate the required document.
4) Select the categories of styles to copy from the checkboxes at the bottom of the dialog.
5) Select Overwrite if you want to replace styles in the original document that have the
same name as styles in the template or document from which you are importing styles. If
this box is not selected, you will only copy styles whose names are not used in the
original document.
6) Click OK to copy the styles.

Figure 46: Copying styles from a template into the open document

Tip
You can also access the Load Styles dialog by selecting Styles > Load Styles from
Template on the Menu bar.

Renaming styles
You can rename custom styles, but not the styles supplied with LibreOffice. To do so, go to the
Styles panel on the Sidebar and click the icon for the type of style you want to rename. Rightclick on the style and select Modify in the context menu to open the Styles dialog. On the
Organizer tab, rename the style and click OK.

Deleting styles
You cannot delete any of LibreOffice’s predefined styles from a document or template, even if
they are not in use. You can delete any user-defined (custom) styles; but before you do, you
should make sure the styles are not in use in the current document.
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To delete any unwanted styles, on the Styles deck select each one to be deleted (hold down the
Control key while selecting multiple styles), and then right-click and select Delete in the context
menu.
If the style is not in use, it is deleted immediately without confirmation. If the style is in use, you
receive a warning message asking you to confirm deletion. Select Yes to continue with the
deletion.

Caution
If you delete a style that is in use, all objects with that style will return to the default
style.

Using the Style Inspector (Writer)
The Style Inspector (Figure 47) is located on the Sidebar in Writer. It displays all the attributes of
the styles (paragraph and character) and any direct formatting present in the paragraph or word
where the cursor is located. For more information, see the Writer Guide.

Figure 47: Style Inspector example

What are templates? Why use them?
A template is a model document that you use to create other documents. For example, you can
create a template for business reports that has your company’s logo on the first page. New
documents created from this template will always have your company’s logo on the first page.
Templates can contain anything that regular documents can contain, such as text, graphics, a set
of styles, and user-specific setup information such as measurement units, language, the default
printer, and toolbar and menu customization.
All documents in LibreOffice are based on templates. You can create, or download and install, as
many templates as you wish, and you can specify a template as the default for each type of
document (text, spreadsheet, drawing, presentation). If you do not choose a template when you
start a new document, then the new document is based on the default template for that type of
document. If you have not specified a default template, LibreOffice uses the blank template for
that type of document that is installed with LibreOffice. See “Setting a default template” on page
81 for more information.
In Writer, you can create templates for master documents as well as for ordinary documents.
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Creating a document from a template
A new installation of LibreOffice may not include many templates, but you can create your own
(see “Creating a template” on page 77) or install templates obtained from other sources (see
“Adding templates obtained from other sources” on page 78).
To create a document from a template using the Templates dialog:
1) Select File > New > Templates or File > Templates > Manage Templates on the Menu
bar, or press Ctrl+Shift+N, or click on the small arrow next to the New icon on the
Standard toolbar and select Templates in the drop-down menu, or select Templates >
Manage Templates in the Start Center. The Templates dialog opens.
2) In the Filter lists at the top of the Templates dialog, select the type and category of
template you want to use. The relevant templates are listed on the dialog. Click on the
icons in the lower left of the dialog to switch between thumbnail view (Figure 48) and list
view (Figure 49).
3) Double-click on the required template, or right-click on the template and click Open. A
new document based on the template opens in LibreOffice.
The template the document is based upon is listed in File > Properties > General. The
connection between the template and the document remains until the template is modified and,
the next time that the document is opened, you choose not to update it to match the template.

Tip
In the Start Center, you can click on the Templates button, or open the drop-down
menu and select a type of template, to view the available templates without opening
the Templates dialog. Click on the required template to create a new document.

Figure 48: Thumbnail view of Templates dialog, showing the context menu for a
selected user-created template
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Figure 49: List view of Templates dialog

Creating a template
You can create templates by saving a document as a template or (in Writer) by using a wizard.

Creating a template from a document
In addition to formatting, any settings that can be added to or modified in a document can be
saved within a template. For example, you can also save printer settings; general behaviors set
in Tools > Options, such as paths and colors; and menu and toolbar customizations.
Templates can also contain predefined text, saving you from having to type it every time you
create a new document. For example, a letter template may contain your name and address.
To create a template from a document:
1) Open a new or existing document of the type you want to make into a template (text
document, spreadsheet, drawing, or presentation).
2) Add any content that you want to appear in any document you create from the new
template, for example company logo, copyright statement, and so on.
3) Create or modify any styles that you want to use in the new template.
4) On the Menu bar, choose File > Templates > Save as Template. The Save As Template
dialog (Figure 50) opens, displaying the existing categories and a name box.

Figure 50: Save As Template dialog
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5) Optionally select a Template category, such as My Templates or Business
Correspondence. You can also set this template as a default template at this time or do it
later.
6) Click Save. The template is saved and the dialog closes.

Creating a template using a wizard (Writer)
In Writer, you can use wizards to create templates for letters, faxes, and agendas.
1) On the Menu bar, choose File > Wizards > [type of template required] (Figure 51).
2) Follow the instructions on the pages of the wizard. This process is slightly different for
each type of template, but the format is similar.

Figure 51: Creating a template using a wizard
3) In the last section of the wizard, you can specify the template name that will show in the
Templates dialog, and also the name and location for saving the template. The two
names can be different but this may later cause confusion. The default location is your
user templates directory, but you can choose a different location.
4) To set the file name or change the directory, select the Path button (the three dots to the
right of the location). The Save As dialog opens. Make your selections and click Save to
close the dialog.
5) Finally, you can choose whether to create a new document from the template
immediately, or manually change the template. Click Finish to save the template.

Adding templates obtained from other sources
LibreOffice refers to sources for templates as repositories. A repository can be local (a directory
on your computer to which you have downloaded templates) or remote (a URL from which you
can download templates).
To get to the official LibreOffice template repository, type https://extensions.libreoffice.org/ in your
browser’s address bar or click the Get more extensions online... link in the Extension Manager,
described in Chapter 14, Customizing LibreOffice. This opens the Extensions web page (Figure
52). In the Search section, click the Templates tag filter. You can narrow your search by also
choosing other tag filters. such as Writer.
After setting the filters, click the Search button. In the search results, find the required template
and click on its name to display a page with details; click the Download button to put the
template anywhere on your computer. Proceed to “Installing templates” on page 79.
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Figure 52: Searching for templates in the repository
You can also select Extensions in the submenu of the Manage button on the upper right of the
Templates dialog (Figure 53) to open an Extensions: Templates dialog, where you can scroll
through a list of extensions. In this version of LibreOffice, there is no easy way to filter this list, so
you may prefer to go directly to the web page, as described above.

Figure 53: Getting more templates for LibreOffice
On other websites, you may find collections of templates that have been packaged into extension
(.OXT) files.

Installing templates
You can install templates using either the Templates dialog or the Extension Manager dialog.
To install templates using the Templates dialog:
1) Download the template or package and save it anywhere on your computer.
2) In the Templates dialog, click the Manage button on the upper right (Figure 53) and select
Import in the submenu. The Select Category dialog appears.
3) Select the category where you want to import the template and click OK. A standard file
browser window opens.
4) Find and select the template that you want to import and click Open. The file browser
window closes and the template is imported and appears in the selected category.
To install templates using the Extension Manager:
1) Download the template or package and save it anywhere on your computer.
2) In LibreOffice, select Tools > Extension Manager on the Menu bar. In the Extension
Manager dialog, click Add to open a file browser window.
3) Find and select the template or package of templates you want to install and click Open.
The package begins installing. You may be asked to accept a license agreement.
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4) When the package installation is complete, restart LibreOffice. The templates are
available for use through the Templates dialog and the extension is listed in the Extension
Manager.
See Chapter 14, Customizing LibreOffice, for more information about the Extension Manager.

Tip
You can manually copy new templates into the template folders. The location varies
with your computer’s operating system. To learn where the template folders are
stored on your computer, go to Tools > Options > LibreOffice > Paths. You can
also add new template folders in other locations; see Chapter 2, Setting up
LibreOffice, for more information.

Editing a template
You cannot edit a template that was supplied with LibreOffice. You can only edit templates that
you created or imported.
You can edit a template’s styles and content, and then, if you wish, you can reapply the
template’s styles to documents that were created from that template. You cannot reapply content.
To edit a template:
1) In the Templates dialog, find the template that you want to edit. Right-click on it and then
click Edit in the context menu (Figure 48). The template opens in LibreOffice.
2) Edit the template and save your changes as you would for any other document.

Updating a document from a changed template
If you make any changes to a template and its styles, the next time you open a document that
was created from the template before the changes, a confirmation message is displayed.
To update the document:
1) Click Update Styles to apply the changed styles in the template to the document.
2) Select Keep Old Styles if you do not want to apply the changed styles in the template to
the document (but see the Caution notice below).

Caution
If you choose Keep Old Styles, the document is no longer connected to the
template, even though the template is still listed under File > Properties > General.
To connect the document to the template again, use the procedure described in
“Changing the template assigned to a document” below.

Changing the template assigned to a document
At times you might want to associate a document with a different template, or perhaps you’re
working with a document that did not start from a template or one that has become detached
from its template.
You can change the template assigned to a document, or reconnect a document to a template, in
two ways: manually or using the Template Changer extension to LibreOffice.
•

To change or reassign a template manually, first create a new, blank document from the
required template, as described in “Creating a document from a template” on page 76.
Then copy the contents of the old document into the new document.
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•

To use the Template Changer extension, first you need to download and install it, then
restart LibreOffice to activate it. After that, you can open the document and use File >
Templates > Change template (current document) on the Menu bar.

Note
Changing or updating a template affects only the formatting used in styles. It does
not affect any content. You may also need to manually update content, for example a
logo, copyright notice, or the layout of a copyright page.

Setting a default template
If you create a Writer, Calc, Impress, or Draw document by choosing File > New > [Type of
Document] on the Menu bar, or by selecting one of the buttons in the Create area of the Start
Center, LibreOffice creates the document from the default template for that type of document.
You can, however, change the default whenever you choose.

Setting a template as the default
Most default settings, such as page size and page margins, can be changed in Tools > Options,
but those changes apply only to the document you are working on. To make those changes the
default settings for that document type, you need to replace the default template with a new one.
You can set any template displayed in the Templates dialog to be the default for that document
type:
1) In the Templates dialog, open the category containing the template that you want to set
as the default, then select the template.
2) Right-click on the selected template and click Set as Default in the context menu (Figure
48). An icon marks the template as the default.
The next time that you create a document of that type by choosing File > New (or equivalent),
the document will be created from this template.

Resetting the default template
To re-enable LibreOffice’s original default template for a document type:
1) In the Templates dialog, click the Manage button on the upper right (Figure 54).
2) Click Reset Default Text Document (or other document type). This choice does not
appear unless a custom template has been set as the default, as described in the
previous section.

Figure 54: Resetting the default template for text documents
You can also reset a default template as follows:
1) In the Templates dialog, open the category containing the template you set as default.
The default template is indicated by a green check mark.
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2) Right-click on this template and select Reset Default in the context menu.
The next time that you create a document by choosing File > New (or equivalent), the document
will be created from the original default template for the document type.

Organizing templates
LibreOffice can manage only those templates that are in its template folders (categories),
although you can create a document from a template that is not in one of these folders (see
“Other ways to manage templates” on page 84). You can create new template categories and
use them to organize your templates. For example, you might have one template category for
report templates and another for letter templates. You can also import and export templates.
To begin, open the Templates dialog as described in step 1) of “Creating a document from a
template” on page 76.

Creating a template category
To create a template category:
1) Click the Manage button in the upper right of the Templates dialog.
2) Click New Category in the submenu (Figure 54).
3) In the pop-up dialog, type a name for the new category and click OK. The new category
now appears in the list of categories.

Deleting a template category
You cannot delete template categories supplied with LibreOffice. Nor can you delete any
categories added by the Extension Manager unless you first remove the extension that installed
them.
To delete a category that you created:
1) On the Templates dialog, select the category in the Filter list at the top.
2) Click the Manage button and select Delete Category in the submenu (Figure 55). When
a message box appears asking you to confirm the deletion, click Yes.

Figure 55: Manage menu for a user-created template category

Renaming a template category
You cannot rename template categories supplied with LibreOffice. You can only rename
categories that you created.
Open the Templates dialog, select the category in the Filter list at the top, then click the Manage
button and select Rename Category in the submenu (Figure 55). In the Rename Category
dialog, type the new name and click OK.
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Renaming a template
You cannot rename templates supplied with LibreOffice. You can only rename a template that
you have created or imported.
Open the Templates dialog, find and select the template you want to rename, then right-click on
the template and select Rename in the context menu. In the small dialog that opens, type a
name in the Enter New Name text box and click OK.
This action changes the Title on the Description tab of the template’s document properties. It
does not change the file name of the template.

Moving a template
To move a template from one template category to another, select it in the Templates dialog,
right-click and select Move in the context menu (Figure 48). The Select Category dialog opens.
Select the destination category and click OK. The template is moved to the selected category. On
this dialog, you can also create a new category into which to move the template.

Deleting a template
You cannot delete templates supplied with LibreOffice. Nor can you delete any templates
installed by the Extension Manager except by removing the extension that installed them.
However, you can delete templates that you have created or imported:
1) Select the template to delete.
2) Right-click on the template to open the context menu and click Delete (Figure 48).
3) A message box appears and asks you to confirm the deletion. Click Yes.

Tip
You can also press the Delete key on the keyboard to delete the selected template
on the Templates dialog.

Exporting a template
To export a template from a template category to another location in your computer or network:
1) In the Templates dialog, select the template that you want to export.
2) Right-click on the template and click Export in the submenu. A file browser window
opens.
3) Find the folder where you want to export the template and click Select Folder or OK.
4) Click OK on the displayed information dialog.

Note
Exporting a template does not remove it from the Templates dialog. The action
places a copy of the template in the location you specify.
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Other ways to manage templates
You can create and use templates stored anywhere on your computer, without using the
Templates dialog. However, some results are different from those described earlier in this
chapter.

Creating a document from a template
You can create a document from a template by double-clicking the template in your computer’s
file browser window.
The resulting document is not associated with (linked to) the template from which it was created.
The template is not listed in the document’s properties and any changes to the template cannot
be directly applied to the document. For many purposes, such as writing a letter, this may be
what you want.

Creating a template from a document
You can create a template from a document using File > Save As and selecting the relevant
template file type, then saving it anywhere you want, for example in a project folder.
The resulting template will not be visible in the Templates dialog, unless you import it or add the
project folder to the locations shown for templates on the LibreOffice – Paths page of the Tools >
Options dialog (see “Paths” in Chapter 2, Setting Up LibreOffice).

Examples of style use
The following examples of common use of page and paragraph styles are taken from Writer.
There are many other ways to use styles; see the guides for the various components for details.

Defining a different first page for a document
Many documents, such as letters and reports, have a first page that is different from the other
pages in the document. For example, the first page of a letterhead typically has a different
header, or the first page of a report might have no header or footer, while the other pages do.
With LibreOffice, you can define the page style for the first page and specify the style for the
following pages to be applied automatically.
As an example, we can use the First Page and Default Style page styles that come with
LibreOffice. Figure 56 shows what we want to happen: the first page is to be followed by the
default page, and all the following pages are to be in the default page style. Details are in
Chapter 5, Formatting Pages: Basics, in the Writer Guide.

Figure 56: Flow of page styles
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Dividing a document into chapters
In a similar way, you can divide a document into chapters. Each chapter might start with the First
Page style, with the following pages using the Default Style page style, as above. At the end of
the chapter, insert a manual page break and specify the next page to have the First Page style to
start the next chapter, as shown in Figure 57.

Figure 57: Dividing a document into chapters using page styles

Changing page orientation within a document
A Writer document can contain pages in more than one orientation. A common scenario is to
have a landscape page in the middle of a document, where the other pages are in a portrait
orientation. This setup can also be created with page breaks and page styles.
To insert a landscape page in the middle of your document, position the cursor at the point where
you want to start the new (landscape) page. Click Insert > More Breaks > Manual Break on the
Menu bar. In the Insert Break dialog, select Page Break under Type, and select a page style with
landscape orientation in the Page Style list. Click OK to insert the page. To go back to the portrait
page style, insert another page break and select the portrait page style you are using (which may
be Default Page Style, if you haven’t selected or created a different one). See the Writer Guide
for more information.

Controlling page breaks automatically
Writer automatically flows text from one page to the next. If you do not like the default settings,
you can change them. For example, you can require a paragraph to start on a new page or
column and specify the style of the new page. A typical use is for chapter titles to always start on
a new right-hand (odd-numbered) page.

Compiling an automatic table of contents
To compile an automatic table of contents, first apply styles to the headings you want to appear in
the contents list, then use Tools > Chapter Numbering to tell Writer which styles go with which
level in the table of contents. By default, tables of contents use Heading styles, but you can use
whatever combination of styles you prefer. See Chapter 4 in this guide for more information.

Defining a sequence of paragraph styles
You can set up one paragraph style so that when you press Enter at the end of that paragraph,
the following paragraph automatically has the style you wish applied to it. For example, you could
define a Heading 1 paragraph to be followed by a Text Body paragraph. A more complex
example would be: Title followed by Author followed by Abstract followed by Heading 1 followed
by Text Body. By setting up these sequences, you can usually avoid having to apply styles
manually.
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Getting Started Guide 7.3

Chapter 4,
Getting Started with Writer
Word processing with LibreOffice

What is Writer?
Writer is the word processor component of LibreOffice. In addition to the usual features of a word
processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic
generation of tables of contents and indexes, mail merge, and others), Writer provides these
important features, which are covered in detail in the Writer Guide:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Templates and styles (see Chapter 3)
Page layout methods, including styles, frames, columns, and tables
Automated tables of contents and indexes
Embedding or linking of images, equations, spreadsheets, and other objects
Built-in drawing tools
Master documents, to group a collection of documents into a single document
Change tracking during revisions
Lists
Tables of data
Database integration, including a bibliography database
Mail merge
Export to PDF and EPUB (see Chapter 10)
Document digital signatures
Form design and filling
And many more

The Writer interface
The main Writer workspace is shown in Figure 58. The default menus and toolbars are described
in Chapter 1, Introducing LibreOffice. Some other features of the Writer interface are covered in
this chapter. Other user interface variants are described in Chapter 14, Customizing LibreOffice.

Figure 58: The main Writer workspace
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Status bar
The Writer Status bar provides information about the document and convenient ways to change
some document features quickly.

Figure 59: Writer Status bar, left end

Figure 60: Writer Status bar, right end
Document changes status
The icon changes color to indicate whether the document has no unsaved changes or it
has been edited and the changes have not been saved. When there are unsaved changes,
you can click on this icon to save the document.
Page number
Shows the sequence number of the current page, and the total number of pages in the
document, and the current page number (if different from the sequence number). For
example, if you restarted page numbering at 1 on the third page, its page number is 1 and
its sequence number is 3.
If any bookmarks have been defined in the document, a right-click on this field pops up a
list of bookmarks; click on one to go to that location.
To jump to a specific page in the document, click on this field. A small Go to Page dialog
pops up. Type the required page number and click OK or press Enter.
Word and character count
The word and character counts of the document are kept up to date as you edit. When text
is selected, the word and character counts for the selection will appear here.
The character count includes spaces. To display the character count excluding spaces,
click on the word count in the Status bar, or choose Tools > Word Count.
You can also see the number of words and characters (and other information including the
number of pages, tables, and graphics) in the entire document in File > Properties,
Statistics tab.
Page style
Shows the style of the current page. To select a different page style, right-click on this field.
A list of page styles pops up; click on one to select it. To edit the attributes of the current
page style, left-click on this field. The Page Style dialog opens.

Caution
Changing the page style here may affect the styles of subsequent pages, depending
on how the page styles are set up. See the Writer Guide for details.
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Text language
Shows the language and localization at the cursor position, or for the selected text, that is
used for checking spelling, grammar, hyphenation, and the thesaurus.
Click to open a menu where you can choose another language or localization for the
selected text or for the paragraph where the cursor is located. You can also choose None
(Do not check spelling) to exclude the text from a spelling check or choose More to open
the Character dialog. Any directly formatted language settings can be reset to the default
language from this menu.
Insert mode
Click to change to Overwrite mode; click again to return to Insert mode. In Insert mode, any
text after the cursor position moves forward to make room for the text you type; in
Overwrite mode, text after the cursor position is replaced by the text you type. This feature
is disabled when in Record Changes mode.
Selection mode
Click to cycle between the selection modes; right-click to select the required mode from a
context menu. The icon does not change, but when you hover the mouse pointer over this
field, a tooltip indicates which mode is active.
Mode

Effect

Standard selection

Click in the text where you want to position the cursor and
drag to where you want the selection to end. Any previous
selection is deselected.

Extending selection (F8)

Clicking in the text extends or crops the current selection.

Adding selection (Shift+F8)

A new, separate selection is added to an existing selection.
The result is a multiple selection.

Block selection
(Alt+Shift+F8)

A block of text can be selected.

On Windows systems, you can hold down the Alt key while dragging to select a block of
text. You do not need to enter the block selection mode.
Digital signature
If the document has been digitally signed, an icon is displayed here; otherwise, it is blank.
To sign the document, or to view the certificate, click the area or icon. See Chapter 10,
Printing, Exporting, Emailing, for more information.
Section or object information
When the cursor is on a section, heading, or list item, or when an object (such as a picture
or table) is selected, information about that item appears in this field. Clicking in this area
opens a relevant dialog. For details, consult the Help or the Writer Guide.
View layout
Click an icon to change between single page, multiple pages, and book layout views
(Figure 61). You can edit the document in any view. Zoom settings interact with the
selected view layout and the window width to determine how many pages are visible in the
window.
Zoom
To change the view magnification, drag the Zoom slider, or click on the + and – signs, or
right-click on the zoom level percent (Zoom factor) to pop up a menu of magnification
values from which to choose, or click on the zoom level percent to pop up the Zoom & View
Layout dialog where you can specify other magnification values.
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Figure 61: View layouts: single page, multiple pages, book

Sidebar
The Sidebar is normally open by default on the right side of the Writer window. If necessary,
select View > Sidebar on the Menu bar, or press Ctrl+F5, to display it. An example is shown in
Chapter 1, Introducing LibreOffice.
The Writer Sidebar contains six decks by default: Properties, Styles, Gallery, Navigator, Page,
and Style Inspector. Each deck has a corresponding icon on the Tab bar on the right of the
Sidebar, allowing you to switch between them. The decks are described below.
Each deck consists of a title bar and one or more content panels. Some panels contain a small
More Options button, which opens a dialog to give greater choice of editing controls. When a
dialog is open, the document is locked for editing until the dialog is closed.

Properties deck
Contains tools for direct formatting of content.
When text is selected, these panels appear:
– Style: Apply a paragraph style at the cursor position. Create or update a style.
– Character: Modify text by the font type, size, color, weight, style, and spacing.
– Paragraph: Modify the paragraph by alignment, lists or bullets, background color,
indent, and spacing.
– Table: If the cursor is in a table, this panel also appears. You can insert, select, delete
rows and columns; split/merge cells; set row height and column width; others.
When a graphic or image is selected, these panels appear:
– Area: Modify the image background fill and transparency. Further colors, gradients,
hatching, patterns, and bitmap selection and importing are available in More Options.
– Wrap: Modify wrap and spacing where these are available.
– Image: Modify the image brightness, contrast, color mode, and transparency.
– Position and Size: Modify width, height, rotation, and flip attributes.
When a drawing object is selected, these panels appear:
– Area: Modify fill and transparency.
– Wrap: Modify wrap and spacing where these are available.
– Position and Size: Modify width, height, rotation, and flip attributes.
– Effect: Add and adjust a Glow or Soft Edge effect to the object.
– Line: Modify style, width, color, and transparency.
When a frame is selected, then the Area and Wrap panels appear.
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When a video or audio clip is selected, these panels appear:
– Media Playback: Control for play, pause, stop, seek, loop, and volume.
– Position and Size: Modify width and height.

Styles deck
Manages the styles used in the document. This includes applying existing styles, modifying them,
or creating new ones. See Chapter 3, Styles and Formatting, for more information.

Gallery deck
Contains images and diagrams included in the Gallery themes. The Gallery has two sections.
The first lists the themes by name (Arrows, Bullets, Diagrams, etc.) and the second displays the
images in the selected category. Select the New button to create new categories. To insert an
image into a file, or add a new image to the new category, drag and drop the selected image.
See Chapter 11, Images and Graphics, for more information.

Navigator deck
Makes it easy to navigate to specific types of content and to reorganize contents based on
categories, such as headings, tables, frames, images, and so on. See page 93 for more
information.

Page deck
Modifies the page style to change the most commonly used page properties. It has four panels:
•

Format modifies the size, width, height, orientation, and page margins.

•

Styles modifies the numbering scheme, background, page layout (specifies whether the
page style should apply to odd or even pages or to both), and columns.

•

Header and Footer activate/deactivate and modify the respective margins, spacing, and
content.

Caution
Be aware that by changing the options on the Page deck, you will change the page
style in use, modifying not only the current page but all pages in the document using
the same page style.

Style Inspector deck
Displays all the attributes of paragraph styles, character styles, and manual (direct) formatting for
selected text. For more information, see Chapter 7, Working with Styles, in the Writer Guide.

Changing document views
Writer has three ways to view a document: Normal, Web, and Full Screen. To change the view,
go to the View menu and select the desired view.
Normal view
Normal view is the default view in Writer. It shows how the document will look when you
print it or create a PDF. In this view, you can hide or show the headers and footers and the
gap between pages by choosing View > Show Whitespace on the Menu bar. This works
only when single-page view is activated in the Status Bar. Hiding whitespace also works in
Full Screen view.
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Web view
Web view shows how the document will look if viewed in a Web browser; this is useful
when you create HTML documents. In Web view, you can use only the Zoom slider; the
View Layout buttons on the Status Bar are disabled, and most of the choices on the Zoom
& View Layout dialog are not available. There is no visual indication of page boundaries.
Full Screen view
In Full Screen view, no toolbars or sidebar are displayed; the document takes up the full
area available, using the zoom and layout settings previously selected. To exit Full Screen
view and return to the previous view, press the Esc key or click the Full Screen button on
the floating toolbar in the top left-hand corner. You can also use Ctrl+Shift+J to toggle
between Full Screen and the previous views.

Working with documents
Chapter 1, Introducing LibreOffice, includes instructions on creating new documents, opening
existing documents, saving documents, accessing remote servers, and password-protecting
documents. Chapter 3, Styles and Templates, covers how to create a document from a template.
By default, LibreOffice creates and saves files in the OpenDocument format (ODF). Writer
documents have the extension .ODT.

Tip
Whenever it is possible to choose the document file format, you should choose to
work with the default ODF format. This reduces the likelihood of errors and
compatibility issues.

Saving as a Microsoft Word file
You may need to open, edit, and save documents in Microsoft Word formats. You can also create
and edit .ODT files and then save them as .DOCX or .DOC files. To do this:
1) Important—First save your document in the file format used by LibreOffice Writer (.ODT).
If you do not, any changes you made since the last time you saved will appear only in the
Microsoft Word version of the document. Also, saving in ODF format enables you to resave or modify the document if the recipient of your document experiences trouble with
the Microsoft format.
2) Then choose File > Save As.
3) On the Save As dialog, in the File type drop-down menu, select the type of Word format
you need. You may also choose to change the file name.
4) Click Save.
This creates a separate document with a different file extension (such as .DOCX). From this point
on, all changes you make to the document will occur only in the new document. If you want to go
back to working with the .ODT version of your document, you must open it again.

Tip
To have Writer save documents by default in a Microsoft Word file format, go to
Tools > Options > Load/Save > General. In the section named Default File Format
and ODF Settings, under Document type, select Text document, then under Always
save as, select your preferred file format.
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Exchanging documents with users of Apple Pages
Although Writer can open and edit files in Apple Pages format (*.pages), it cannot save in that
format or export to that format. Apple Pages cannot open files in OpenDocument format, so if you
need to share files with users of Pages, save your .odt file in a compatible format, such as
.rtf or .docx. If you attempt to save an edited .pages file, the Save As dialog opens.
Pages users can also export (not save) a copy of a Pages document in a format compatible with
Writer, such as .docx or .rtf, which Writer can then open, edit, and save to.

Moving quickly through a document
Using the Navigator
The Navigator provides several convenient ways to move around a document and find items in it.
It lists the headings, tables, text frames, graphics, bookmarks, and other objects in the document.
•

When a category is showing the list of objects in it, double-click on an object to jump
directly to that object’s location in the document.

•

In the top left of the Navigator is a Navigate By drop-down list. You can pick a type of
object (such as a bookmark, table, or index entry) and then use the Previous (^) and
Next (v) buttons to jump from one to the next (Figure 62).

•

On the top right of the Navigator is a Go to Page field, which you can use to jump directly
to a specific page.

For more uses of the Navigator in Writer, see Chapter 1 of the Writer Guide.

Figure 62: Navigate By list on Navigator

Using the Go to Page dialog
To jump to a specific page in the document:
•

Use the Go to Page field on the top right of the Navigator (see above).

•

Use the Go to Page dialog (Figure 63), which shows the current page number and the
number of pages in the document. Type the number of the destination page in the text
box and click OK. To open this dialog, do any of the following:
– Click on the page number field in the Status bar.
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– Choose Edit > Go to Page on the Menu bar.
– Press Ctrl+G on the keyboard.

Figure 63: Go to Page dialog

Working with text
Selecting, copying, pasting, or moving text in Writer is similar to working with text in other
programs. LibreOffice also has some convenient ways to select items that are not next to each
other, select a vertical block of text, and paste unformatted text.

Selecting items that are not consecutive
To select non-consecutive items (as shown in Figure 64) using the mouse:
1) Select the first piece of text.
2) Hold down the Ctrl key and use the mouse to select the next piece of text.
3) Repeat as often as needed.
To select non-consecutive items using the keyboard:
1) Select the first piece of text.
2) Press Shift+F8. This puts Writer in “Adding selection” mode.
3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold
down the Shift key and select the next piece of text.
4) Repeat as often as required.
Now you can work with the selected text (copy it, delete it, change the style, and so on).
Press Esc to exit from this mode.

Figure 64: Selecting items that are not next to each other
For more information about keyboard selection of text, see the topic “Navigating and selecting
with the keyboard” in LibreOffice Help (F1).
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Selecting a vertical block of text
You can select a vertical block or “column” of text that is separated by spaces or tabs (as you
might see in text pasted from e-mails, program listings, or other sources), using Block selection
mode. To change to Block selection mode, use Edit > Selection Mode > Block Area, or press
Alt+Shift+F8, or right-click on the Selection icon on the Status bar and select Block selection in
the pop-up menu.

Figure 65: Selection icon
Now highlight the selection, using mouse or keyboard, as shown below.

Figure 66: Selecting a vertical block of text

Cutting, copying, and moving text
Cutting and copying text in Writer is similar to cutting and copying text in other applications. You
can use the mouse or the keyboard. You can copy or move text within a document, or between
documents, by dragging or by using menu selections, toolbar buttons, or keyboard shortcuts. You
can also copy text from other sources such as Web pages and paste it into a Writer document.
To move (drag and drop) selected text using the mouse, drag it to the new location and release it.
To copy selected text, hold down the Ctrl key while dragging. The text retains the formatting it had
before dragging.
To move (cut and paste) selected text, use Ctrl+X to cut the text, insert the cursor at the paste-in
point and use Ctrl+V to paste. Alternatively, use the Copy / Paste buttons on the Standard
toolbar, or the options under Edit on the Menu bar.

Pasting text
When you paste text, the result depends on the source of the text and how you paste it. If you
click on the Paste button on the Standard toolbar or use Ctrl+V, any formatting the text has (such
as bold or italics) is retained. Text pasted from websites and other sources may also be placed
into frames or tables. If you do not like the results, click the Undo button or press Ctrl+Z.
To make the pasted text inherit the paragraph style at the insertion point, do any of the following:
•

Choose Edit > Paste Special.

•

Click the arrow on the Paste button on the Standard toolbar.

•

Double-click the Paste button without releasing the left mouse button.

•

Press Ctrl+Shift+V.

Then select Paste Unformatted Text or Unformatted text in the resulting menu. Unformatted
text can also be pasted directly by pressing Ctrl+Alt+Shift+V on the keyboard.
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Finding and replacing text and formatting
Writer has two ways to find text and formatting within a document: the Find toolbar for fast
searching and the Find and Replace dialog. In the dialog, you can:
•

Find and replace words and phrases

•

Use wildcards and regular expressions to fine-tune a search

•

Find and replace specific attributes or formatting

•

Find and replace paragraph styles

Using the Find toolbar
By default, the Find toolbar is docked at the bottom of the LibreOffice window (just above the
Status bar) as shown in Figure 67, but you can float it or dock it in another location. If the Find
toolbar is not visible, you can display it by choosing View > Toolbars > Find on the Menu bar,
selecting Edit > Find on the Menu bar, or by pressing Ctrl+F. For more information on floating
and docking toolbars, see Chapter 1, Introducing LibreOffice.

Figure 67: Docked position of Find toolbar
To use the Find toolbar, click in the box and type your search text, then press Enter to find the
next occurrence of that term. Click the Find Next or Find Previous (arrow) buttons as needed.
Click the Find All button to select all instances of the search term within the document. Select
Match Case to find only the instances that also match the case (capitalization). To open the Find
and Replace dialog, click the icon to the right of Match Case.
To close the Find toolbar, click the X button on the left, or press Esc on the keyboard when the
cursor is in the search box.

Using the Find and Replace dialog
To display the Find & Replace dialog (Figure 68), use any of the following methods:
•

Press Ctrl+H on the keyboard.

•

Choose Edit > Find and Replace on the Menu bar.

•

Click the Find and Replace icon on the Find toolbar.

When the Find and Replace dialog is open, optionally click Other options to expand it.
1) Type the text you want to find in the Find box.
2) To replace the text with different text, type the new text in the Replace box.
3) You can select various options such as matching the case or matching whole words only.
The other options include searching only in selected text, searching from the current
cursor position backwards toward the beginning of the file, searching for similar words,
searching in comments, and using regular expressions (wildcards). The exact options
may vary with your language settings (Tools > Options > Language Settings >
Languages).
4) When you have set up the search, click Find Next. To replace the found text, click
Replace. If you click Find All, LibreOffice selects all instances of the search text in the
document. Similarly, if you click Replace All, LibreOffice replaces all matches, without
stopping for you to accept each instance.
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Caution
Use Replace All with caution; otherwise, you may end up with mistakes that you
won’t be able to undo later if you save and close the file. (Ctrl+Z works only before
the file is saved.) A mistake with Replace All might require a manual, word-by-word,
search to fix.

Tip
Regular expressions offer powerful ways to search and replace text. For example,
they can find all instances where any number is followed by specific letters.
However, they can be challenging to understand. Refer to the Help files for guidance.
For more information on using Find and Replace, see the Writer Guide.

Figure 68: Expanded Find & Replace dialog

Inserting special characters
A special character is one not found on a standard user’s keyboard. For example, © ¾ æ ç ñ ö ø
¢ are all special characters not available on an English keyboard.
To insert one or more special characters, place the cursor where you want the character to
appear. Then do one of the following:
•

Click the Special Character icon on the Standard toolbar to open a list of favorite and
recently used characters and click on the one you wish to insert (Figure 69). You can also
open the Special Characters dialog (Figure 70) by clicking the More Characters button.
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Figure 69: Insert Special Characters
icon oin the standard toolbar
•

Choose Insert > Special Character on the Menu bar, to open the Special Characters
dialog (Figure 70). Double-click the characters (from any font or mixture of fonts) you
wish to insert, in order, then click Insert.

Figure 70: The Special Characters dialog
The Special Characters dialog (Figure 70) includes areas to select Recent Characters and
Favorite Characters. To add a new character to the Favorite Characters list, click on a character
and click the Add to Favorites button.

Tip
Different fonts have their own distinct special characters. If you do not find a
particular special character, try changing the Font selection.
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Inserting non-breaking spaces and hyphens
Non-breaking spaces
To prevent two words from being separated at the end of a line, press Ctrl+Shift when you
type the space between the two words. This inserts a non-breaking space. You can also
use Insert > Formatting Mark > Insert non-breaking space on the Menu bar.
Non-breaking hyphens
In cases where you do not want the hyphen to appear at the end of a line, for example in a
number such as 123-4567, you can press Shift+Ctrl+minus sign or use Insert > Formatting
Mark > Insert non-breaking hyphen.

Inserting en and em dashes
To enter en and em dashes as you type, you can use Replace dashes on the Options tab in the
AutoCorrect dialog (Tools > AutoCorrect > AutoCorrect Options). This option replaces one or
two hyphens, under certain conditions, with the corresponding dash. See the Help or the Writer
Guide for more details and other methods of inserting dashes.
–

An en-dash is a dash the width of the letter “n” in the font you are using. Type at least one
character, a space, a hyphen, another space, and at least one more letter. The hyphen will
be replaced by an en-dash.

— An em-dash is a dash the width of the letter “m” in the font you are using. Type at least one
character, two hyphens, and at least one more character. The two hyphens will be replaced
by an em-dash. Exception: if the characters are numbers, as in a date or time range, the two
hyphens are replaced by an en-dash.

Checking spelling and grammar
By default, four dictionaries are installed for each language, if they are available for that
language: a spelling checker, a grammar checker, a hyphenation dictionary, and a thesaurus.
The spelling checker determines if each word in the document is in the installed dictionary. The
grammar checker works in combination with the spelling checker. You can choose to check
spelling and grammar automatically as you type, or at any other time, or both.

Checking spelling and grammar automatically
When Automatic Spell Checking is selected in the Tools menu, Standard toolbar, or Options
dialog, each word is checked as it is typed and a wavy red line appears under any unrecognized
words. If Check grammar as you type has also been enabled, errors are marked with a wavy
blue underline. See “Checking grammar” on page 101.
At any time, you can right-click on an unrecognized word to open a context menu (Figure 71),
where you can choose one of the suggested words to replace it. When the word is corrected, the
line disappears. If the word is correct but not in the dictionary, you can chose Add to dictionary.
If the list does not contain the word you want, click Spelling to open the Spelling dialog (Figure
72).

Chapter 4, Getting Started with Writer | 99

Figure 71: Spelling context menu

Using the Spelling dialog
In addition to automatic checking, or in place of it, you can perform a combined spelling and
grammar check on the document (or a text selection). Click the Check Spelling button on the
Standard toolbar, or choose Tools > Spelling, or press F7 on the keyboard. This checks the
document or selection and opens the Spelling dialog if any unrecognized words are found. To
also identify potential grammar problems, select the Check grammar checkbox.

Figure 72: Spelling dialog
Here are some more features of the spelling checker:
Text language
The language to be used for checking spelling can be selected in this drop-down list.
Add a word to the dictionary
Add a word to the dictionary by clicking Add to Dictionary in the Spelling dialog or in the
context menu. The word will be added to the Standard dictionary, unless you have created
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another dictionary in the same language. If you have created a new dictionary, you will be
given a choice of dictionaries to add the word to.
Choose text for spell checking
Choose whether to check uppercase words or words that contain numbers, by clicking the
Options button on the Spelling dialog to open a dialog similar to the one in Tools >
Options > Language Settings > Writing Aids, described in Chapter 2.
Manage custom dictionaries
Create, edit, or delete dictionaries and edit words in the dictionary in the same Options
dialog.
Specify language for specific paragraphs
Set paragraphs to be checked in a language (different from the rest of the document) using
several methods—for example, by clicking on the Text Language field on the Status Bar or
by creating paragraph styles for specific languages. See “Using built-in language tools” on
page 117 or refer to the Writer Guide for more information.
See the Writer Guide for more information about the spelling and grammar checking options.

Checking grammar
If any grammar errors are detected, they are shown underlined by a wavy blue line. Right-click on
this line to open a context menu.
The first entry in the context menu describes the suspected broken grammatical rule.

Figure 73: Context menu for grammar errors
The second menu item may be Explanations, which opens your browser to a web page offering
more information about the error. Next may be the suggested correction. Clicking this changes
the text to the suggestion.
In the third section of the context menu, you can choose to ignore the indicated error, or open the
Spelling dialog (Figure 72). In the final section of the menu, you can set the language for the
selection or the paragraph.
You can select additional grammar checking rules through Tools > Options > Language
Settings > English Sentence Checking, or through Tools > Extension Manager > English
spelling dictionaries > Options. See Chapter 2, Setting up LibreOffice, for details.

Using synonyms and the thesaurus
To access a short list of synonyms, right-click on a word and point to Synonyms in the context
menu. A submenu of alternative words and phrases is displayed. Click on a word or phrase in the
submenu to have it replace the highlighted word or phrase in the document.
The thesaurus gives a more extensive list of alternative words and phrases. To use the
thesaurus, click on Thesaurus in the Synonyms submenu. If the current language does not
have a thesaurus installed, this feature is disabled.
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Using AutoCorrect
Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it
corrects automatically. It also includes codes for inserting special characters, emoji, and other
symbols.
AutoCorrect is turned on by default. You may wish to disable some of its features, modify others,
or turn it off completely. To turn AutoCorrect off, uncheck Tools > AutoCorrect > While Typing.
You can add your own corrections or special characters or change those supplied with
LibreOffice. Choose Tools > AutoCorrect > AutoCorrect Options to open the AutoCorrect
dialog. On the Replace tab, you can define which strings of text are corrected and how. In most
cases, the defaults are fine.
To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word pair, and
click Delete. To add a new spelling to the list, type it into the Replace and With boxes on the
Replace tab, and click New.
See the different tabs of the dialog for the other options available to fine-tune AutoCorrect.

Tip
LibreOffice has an extensive list of special characters accessible with AutoCorrect.
For example, type :smiling: and AutoCorrect will replace it with ☺. Or, (c) will be
changed to ©. You can add your own special characters.

Using Word Completion
If Word Completion is enabled, Writer tries to guess which word you are typing and offers to
complete the word for you. To accept the suggestion, press Enter. Otherwise, continue typing.
To turn off Word Completion, select Tools > AutoCorrect > AutoCorrect Options and deselect
Enable word completion on the Word Completion tab.
Options for customizing word completion from the AutoCorrect dialog include:
•

Add (append) a space automatically after an accepted word.

•

Show the suggested word as a tip (hovering over the word) rather than completing the
text as you type.

•

As you add words when working on documents, you can either save them for later use in
other documents or select the option to remove them from the list when closing
documents.

•

Change the maximum number of words remembered for word completion and the length
of the smallest words to be remembered.

•

Delete specific entries from the word completion list.

•

Change the key that accepts a suggested entry—the options are right arrow, End key,
Return (Enter), Space bar, and Tab.

Note
Automatic word completion only occurs after you type a word for the second time in
a document.
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Using AutoText
Use AutoText to store text, tables, fields, and other items for reuse and assign them to a key
combination for easy retrieval. For example, rather than typing “Senior Management” every time
you use that phrase, you can set up an AutoText entry to insert those words when you type “sm”
and press F3.
To store some text as AutoText:
1) Type the text into your document, then select the text.
2) Choose Tools > AutoText on the Menu bar (or press Ctrl+F3).
3) In the AutoText dialog (Figure 74), type a name for the AutoText in the Name box. Writer
will suggest a one-letter shortcut, which you can change.
4) Choose the category for the AutoText entry, for example My AutoText.
5) Click the AutoText button at the bottom of the dialog and select in the menu either New,
to have the AutoText retain specific formatting, no matter where it is inserted, or New
(text only), to have the AutoText take on the existing formatting around the insertion
point.
6) Click Close to return to your document.
To insert AutoText, type the shortcut and press F3.

Tip
If the only option under the AutoText button is Import, either you have not entered a
name for your AutoText or there is no text selected in the document.

Figure 74: Creating an AutoText entry
AutoText is especially powerful when assigned to fields. See Chapter 17, Fields, in the Writer
Guide for more information.
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Changing the case of selected text
To quickly change the case of text, select it, choose Format > Text on the Menu bar, and then
choose one of the items on the submenu. The most common are:
•

UPPERCASE, where all letters are capitalized.

•

lowercase, where no words (except proper nouns) are capitalized.

•

Sentence case, where only the first word is capitalized (together with any proper nouns).

•

Capitalize Every Word, where every word is capitalized.

•

Small capitals, which capitalizes all letters in a reduced font size.

Writer does not have an automated way to do Title Case, where all words are capitalized except
for certain subsets defined by rules that are not universally standardized. However, you can use
Capitalize Every Word and then restore those words that you do not want capitalized.

Formatting text
You can format text in two ways. See Chapter 4, Formatting Text, in the Writer Guide for details.
Direct (or Manual) formatting
Applies formatting directly to specific paragraphs, characters, pages, frames, lists, or
tables. For example, you can select a word, then click on a button on the Formatting
toolbar to format the text as bold or italics.
Styles
Bundles formatting options. For example, a paragraph style defines numerous settings for
options such as font type and size, whether paragraphs should be indented, the space
between lines, how paragraphs should be aligned on the page, and many others.

Using styles is highly recommended
Writer is a style-based program. Because styles apply whole groups of formats at the same time,
you can easily format a document consistently and change the formatting of an entire document
with minimal effort. In addition, LibreOffice uses styles for many processes, even if you are not
aware of them. For example, Writer relies on heading styles (or other styles you specify) when it
compiles a table of contents.
Writer defines six types of styles: paragraph, character, frame, page, list, and table. See Chapter
3, Styles and Templates, in this book and also refer to the Writer Guide.

Formatting paragraphs using styles
Styles can be applied to paragraphs in several ways:
•

Styles drop-down selection list at the left end of the Formatting toolbar

•

Styles deck of the Sidebar

•

Styles menu on the Menu bar (limited to common styles)

•

Keyboard shortcuts Ctrl+1 to Ctrl+5 (paragraph styles Heading 1 to Heading 5)

You can also open a Formatting (Styles) toolbar using View > Toolbars > Formatting (Styles);
see Figure 75.

Figure 75: Formatting (Styles) toolbar
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Formatting paragraphs directly
You can manually apply many direct formats to paragraphs using the buttons on the Formatting
toolbar and by using the Paragraph panel of the Sidebar’s Properties deck. Not all buttons are
visible in a standard installation, but you can customize the toolbar to include those you use
regularly. These buttons and formats include:
•

Set Paragraph Style

•

Toggle Unordered List (with a palette of bullet styles)

•

Toggle Ordered List (with a palette of numbering styles)

•

Align Left, Align Center, Align Right, Justified

•

Align Top, Center Vertically, Align Bottom

•

Line Spacing (choose from 1, 1.15, 1.5, 2, or custom spacing)

•

Increase Paragraph Spacing, Decrease Paragraph Spacing

•

Increase Indent, Decrease Indent, Hanging Indent

•

Paragraph (to open the Paragraph dialog)

•

Set Line Spacing

Note
Direct formatting (also called manual formatting) overrides styles. This means that
when a new style is applied, direct formatting is not removed and still determines the
displayed format.

Removing direct formatting
To remove direct formatting, select the text and choose Format > Clear Direct Formatting on
the Menu bar, or right-click and choose Clear Direct Formatting in the context menu, or press
Ctrl+M on the keyboard, or select the Clear Direct Formatting icon on the Formatting toolbar.

Note
When clearing direct formatting, the text formatting will return to the applied
paragraph and character style and not the default paragraph style or default
character style (unless these styles are actually applied to the text).

Formatting characters using styles
To apply a character style, highlight the characters or words and apply the selected character
style from the Character Styles tab of the Styles deck on the Sidebar, in the Styles menu on the
Menu bar (limited), or from the right-click context menu (limited).

Formatting characters directly
It is recommended that you use styles to format characters as much as possible rather than
formatting characters directly, as described in this section.
You can directly apply many formats to characters using the buttons on the Formatting toolbar
and by using the Character panel of the Sidebar’s Properties deck. Not all buttons are visible in a
standard installation, but you can customize the toolbar to include those you use regularly. These
buttons and formats include:
•

Font Name, Font Size

•

Bold, Italic, Underline, Overline, Strikethrough, Outline Font Effect, Shadow
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•

Superscript, Subscript

•

Uppercase, Lowercase

•

Increase Font Size, Decrease Font Size

•

Font Color (with a palette of colors)

•

Background Color (with a palette of colors)

•

Character Highlighting Color (with a palette of colors)

Note
Just as direct paragraph formatting overrides the current paragraph style, applying
direct character formatting to characters overrides the current character style
formatting.

Formatting tables
Tables in a Writer document share the same sets of formatting elements as spreadsheets in
LibreOffice Calc.
To apply table styles, click in the table to be formatted and double-click on a style listed in the
Table Styles tab of the Sidebar’s Styles deck. Alternatively, click in the table to be formatted,
choose Table > AutoFormat Styles on the Menu bar and select a style from the dialog that
opens. For more information, refer to Chapter 13, Tables of Data, in the Writer Guide.

Autoformatting
You can set Writer to format or correct parts of a document automatically as you type, according
to the choices made on the Options and Localized Options tabs of the AutoCorrect dialog (Tools
> AutoCorrect > AutoCorrect Options).
Autoformatting on the Options tab includes URL recognition, bulleted and numbered lists,
capitalizing the first letter of every sentence, and correcting two initial capitals on words.
A bulleted (unordered) list is created when you type a hyphen (-), star (*), or plus sign (+),
followed by a space or tab at the beginning of a paragraph. A numbered (ordered) list is created
when you type a number followed by a period (.), followed by a space or tab at the beginning of a
paragraph.
The Localized Options tab controls the formatting of quotation marks and apostrophes (which
look like a closing single quote). Most fonts include curly quotation marks (also known as “smart
quotes”), but for some purposes (such as marking minutes and seconds of latitude and longitude)
you may wish to format them as straight quotes.
Straight quotes

'' ""

Smart quotes

‘’ “”

Tip
If you notice unexpected formatting changes occurring in your document, this is the
first place to look for the cause. In most cases Edit > Undo (Ctrl+Z) fixes the issue.

Creating lists with styles
For more about creating lists using styles, see Chapter 12, Lists: Tips and Tricks, in the Writer
Guide.
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Creating unordered (bulleted) and ordered (numbered) lists
Whenever possible, use paragraph styles for creating unordered (bulleted) and ordered
(numbered) lists. Writer comes with two sets of paragraph styles for this purpose. However, these
styles do not include options for settings such as the type of bullet or position of numbers. Those
settings come from list styles, which are a different type of style than paragraph styles. It is
recommended to use them together in these ways:
•

Use paragraph styles List 1, List 2, List 3, and so on for creating unordered lists. These
styles use Bullet list styles.

•

Use paragraph styles Numbering 1, Numbering 2, Numbering 3, etc, for creating ordered
lists. These styles use the list styles called Numbering 1, Numbering 2, etc.

To assign a list style to one of these paragraph styles, go to the Styles deck in the Sidebar, rightclick on the paragraph style you want to use, then choose Modify. On the Outline & List tab on
the Paragraph Style dialog, in the List style drop-down list, choose the appropriate list style
(Figure 76).
Paragraph styles such as List 1 Start and List 1 End enable you to adjust specific properties
(such as the space between paragraphs) for items at the beginning or end of the list.

Note
List styles are not meant to be used on their own. Rather, they are designed to be
attached to paragraph styles.

Figure 76: Assigning a list style to a paragraph style

Creating nested lists using styles
With paragraph styles, you can easily create nested lists, in which list items have sub-items
under them, as in an outline. This requires specifying the settings for the additional levels. To do
this, right-click on the list style (not the paragraph style) on the Styles deck in the Sidebar, select
Modify, and specify how each level will be labeled, using the Customize tab. Also specify the
position and spacing for each level on the Position tab. Refer to the Writer Guide for details.
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Once you have set up nested lists, you can readily change the hierarchy of an item. To demote
an item one level, position the cursor at the beginning of the line (after the bullet or number) and
press the Tab key. To promote an item one level, press Shift+Tab.

Creating lists with direct formatting
Creating unordered and ordered lists
Bullets and numbers can be manually applied in three ways:
•

Use AutoCorrect to autoformat text, as described above

•

Use the Toggle Unordered List and Toggle Ordered List buttons on the Formatting
toolbar

•

Use the Paragraph panel of the Sidebar’s Properties deck

Bullets and numbering can be applied to already selected text or they can be applied as you
type.

Tip
Bullets and numbering applied in these ways cannot be removed with Format >
Clear Direct Formatting on the Menu bar, or with the Clear Direct Formatting icon
on the Formatting toolbar, or by using Ctrl+M. Rather, they are turned off or removed
from selected text by toggling the relevant buttons on the Formatting toolbar, or on
the Sidebar’s Properties deck.

Creating nested lists
Use the buttons on the Bullets and Numbering toolbar to move items up or down the list, create
sub-items, change the style of bullets, and access the Bullets and Numbering dialog, which
contains more detailed controls. Use View > Toolbars > Bullets and Numbering to see the
toolbar.

Tip
If numbering or bullets are being applied automatically in a way that youdo not want,
you can disable them by going to Tools > AutoCorrect > AutoCorrect Options and
deselecting Bulleted and Numbered List on the Options tab.
The Toggle Unordered List and Toggle Ordered List buttons on the Sidebar’s Properties deck
can also be used to create nested lists. Click the down arrow next to the relevant button, then
click More Bullets/Numbering to access the Bullets and Numbering dialog. However, the
Sidebar does not include tools for promoting and demoting items in the list, as found on the
Bullets and Numbering toolbar.

Setting tab stops and indents
The horizontal ruler shows the tab stops. Any tab stops that you have defined will overwrite the
default tab stops. Tab settings affect indentation of full paragraphs (using the Increase Indent
and Decrease Indent buttons on the Formatting toolbar) as well as indentation of parts of a
paragraph (by pressing the Tab key on the keyboard).
Using the default tab spacing can cause formatting problems if you share documents with other
people. If you use the default tab spacing and then send the document to someone else who has
chosen a different default tab spacing, tabbed material will change to use the other person’s
settings. Instead of using the defaults, define your own tab settings, as described in this section.
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To define indents and tab settings for one or more selected paragraphs, right-click and choose
Paragraph > Paragraph. On the Paragraph dialog, go to the Tabs tab.
A better strategy is to define tabs for the paragraph style. This is done on the Tabs tab of the
Paragraph Style dialog.

Tip
Using tabs to space out material on a page is not recommended. Depending on what
you are trying to accomplish, a table or frame might be a better choice.

Changing the default tab stop interval
Caution
Any changes to the default tab setting will affect the existing default tab stops in any
document you open afterward, as well as tab stops you insert after making the change.
To set the spacing of default tab stop intervals, go to Tools > Options > LibreOffice Writer >
General.

Figure 77: Selecting a default tab stop interval

Changing measurement units for tab stops and rulers
Change the measurement unit for rulers in the current document by right-clicking on the ruler to
open a list of units. Click on one of them to change the ruler to that unit. The selected setting
applies only to that ruler.

Figure 78: Changing the measurement unit for a ruler

Hyphenating words
You can hyphenate words at the end of a line in two ways: let Writer do it automatically (using
styles and its hyphenation dictionaries), or insert soft hyphens manually where needed. Or, you
can choose to not hyphenate at all.

Automatic hyphenation using styles
To turn automatic hyphenation of words on or off:
1) On the Styles deck on the Sidebar, go to Paragraph Styles, right-click on Default
Paragraph Style (or another style you want to use) and select Modify.
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2) On the Paragraph Style dialog (Figure 79), go to the Text Flow tab.
3) Under Hyphenation, select or deselect Automatically. When automatic hyphenation is
on, you can also set the criteria for when it should occur. Click OK to save.

Note
Turning on hyphenation for the Default Style paragraph style affects all other
paragraph styles that are based on Default Style. You can individually change other
styles so that hyphenation is not active; for example, you might not want headings to
be hyphenated.
Any styles not based on Default Style are not affected. See Chapter 3, Styles and
Templates, for more about styles based on styles other than Default Style.

Figure 79: Turning on automatic hyphenation in a paragraph style

Setting hyphenation with Writing Aids
You can also set hyphenation options through Tools > Options > Language Settings > Writing
Aids. These choices apply when there is no specific setting in a paragraph style.
In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.

Figure 80: Setting hyphenation options
To change the minimum number of characters for hyphenation, or the minimum number of
characters before or after a line break, select the item, and then click the Edit button in the
Options section.

Note
Hyphenation options set in Writing Aids are effective only if hyphenation is turned on
through paragraph styles.

Manual hyphenation
Manually hyphenate words when you want only a specific word hyphenated at the end of a line.
Do not use a normal hyphen, which will remain visible even if the word is no longer at the end of
110 | LibreOffice 7.3 Getting Started Guide

a line when you add or delete text, or change margins or font size. Instead, use a soft hyphen,
which is visible only when required.
To insert a soft hyphen inside a word, click where you want the hyphen to appear (when needed)
and press Ctrl+hyphen or use Insert > Formatting Mark > Insert soft Hyphen. When the word
is at the end of the line it will be hyphenated at this position, even if automatic hyphenation for
this paragraph is switched off.

Formatting pages
Every page in Writer is based on a page style. Page styles define basic layout, including page
size, margins, headers and footers, borders, backgrounds, and so on. Changes to these settings
automatically change the page style. This means that, in contrast to paragraph styles, these
settings cannot be used to directly format individual pages.
As with other styles, Writer comes with a number of page styles. You can modify these styles or
create new ones. The Default Style page style is used when no other page style has been
specified.
In addition to page styles, several features enable you to further control page layouts, including
columns, frames, tables, and sections. For more information, see Chapter 5, Formatting Pages:
Basics, and Chapter 6, Formatting Pages: Advanced, in the Writer Guide.

Tip
Page layout is usually easier if you show text, object, table, and section boundaries in
Tools > Options > LibreOffice > Application Colors, and paragraph ends, tabs,
breaks, and other items in Tools > Options > LibreOffice Writer > Formatting Aids.

Creating headers and footers
A header is an area that appears at the top of a page above the margin. A footer appears at the
bottom of the page below the margin. Information such as a page number is placed in the header
or footer of a page style. That information is then displayed on every page with the same page
style (unless the page style specifies separate settings for the first page or for left and right
pages).

Inserting a header or footer
You can insert a header in several ways. Here is the easiest:
•

Click above the top margin (or below the bottom margin) to make the Header or Footer
marker appear (Figure 81), and then click on the + sign.

Figure 81: Header marker at top of text area
After a header/footer has been created, a down-arrow appears on the marker. Click on this arrow
to drop down a menu of choices for working with the header (Figure 82).
Alternatively, you can choose Insert > Header and Footer > Header > Default Page Style (or
some other page style, if not Default Page Style).
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Figure 82: Header menu

Displaying different headers on right and left pages
Page styles can be set up to have the facing left and right pages mirrored or only right (first
pages of chapters are often defined to be right-page only) or only left. When you insert a header
on a page style set up for mirrored pages or right-and-left pages, you can have the contents of
the header be the same on all pages or be different on the right and left pages. For example, you
can put the page number on the left-hand edge of the left pages and on the right-hand edge of
the right pages, put the document title on the right-hand page only, or make other changes.

Determining header and footer appearance
To format a header (use similar settings for a footer), you can either click on Format Header in
the menu shown in Figure 82 or go to Format > Page Style, Header tab. Both methods take you
to the same tab on the Page Style dialog.
Here you can specify if headings on the left and right pages should be the same or different. You
can also specify whether the first page will have no header or a different header than other
pages.
In this dialog, you can also turn the header on or off, set the margins, and set the spacing
between the header and document text.

Figure 83: Page Style dialog, Header tab

112 | LibreOffice 7.3 Getting Started Guide

Inserting document title in headers and footers
Information such as a document title is often put into the header or footer. These items are best
added as fields. That way, if something (such as the name) changes, the headers and footers are
updated automatically. Here is one common way to use fields to insert the document title into the
header:
1) Choose File > Properties. On the Description tab, type a title for your document, and
click the OK button.
2) Place the cursor in the header area at the top of the page.
3) Choose Insert > Field > Title. The title may appear on a gray background. The
background does not show when printed and can be turned off in Tools > Options >
LibreOffice > Application Colors.
For more about headers, footers, and fields, see the Writer Guide.

Numbering pages
Displaying the page number
To display page numbers automatically:
1) Insert a header or footer as described in “Creating headers and footers” on page 111.
2) Place the cursor in the header or footer where you want the page number to appear and
choose Insert > Page Number.
3) Change the alignment of the number if you wish (left, right, or center).

Including the total number of pages
To include the total number of pages (as in “page 1 of 12”):
1) Type the word “page” and a space, then insert the page number as above.
2) Press the space bar once, type the word “of” and a space, then choose Insert > Field >
Page Count.

Note
The Page Count field inserts the total number of pages in the document, as shown
on the Statistics tab of the document’s Properties dialog (File > Properties). If you
restart page numbering anywhere in the document, then the total page count may
not be what you want. See the Writer Guide for more information.

Restarting page numbering
Often you will want to restart the page numbering at 1, for example on the page following a title
page or a table of contents. In addition, many documents have the “front matter” (such as the
table of contents) numbered with Roman numerals and the main body of the document
numbered in Arabic numerals, starting with 1. To restart page numbering:
Place the cursor in the first paragraph of the new page.
1) Choose Format > Paragraph.
2) On the Text Flow tab of the Paragraph dialog (Figure 79 on page 110), select Insert in
the Breaks area, and then select With page style and specify the page style to use.
3) Specify the page number to start from, and then click OK.
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Tip
This is also useful for numbering the first page of a document with a page number
greater than 1.

Line numbering
Line numbers in the margin are often used in legal documents, poetry, and lists of programming
code. Writer can insert line numbers in an entire document or for selected paragraphs. Line
numbers are included when you print the document.
You can choose how many lines are numbered (for example, every line or every tenth line), the
numbering type, and whether numbers restart on each page.
To add line numbers to a document, choose Tools > Line Numbering and select the Show
numbering option in the top left corner of the Line Numbering dialog. Then select any options
you want and click OK.
You can also create a paragraph style that includes line numbering, and apply it to the
paragraphs that you want to add line numbers to. For example, to number the lines of example
code in a document, you will probably want to use a font or indentation that is different from
normal text.

Changing page margins
You can change page margins in three ways:
•

Using the page rulers—quick and easy, but does not allow fine control.

•

Using the Page Style dialog—you can specify margins with precision of up to two decimal
places.

•

Using the Page deck of the Sidebar.

Caution
When you change the margins, the page style is also changed and the changed
margins apply to all pages using that style.
To change margins using the rulers:
1) The gray sections of the rulers are the margins. Put the mouse cursor over the line
between the gray and white sections. The pointer turns into a double-headed arrow and
displays the current setting in a tool-tip.
2) Hold down the left mouse button and drag the mouse to move the margin.

Caution
The two small gray triangles on the ruler are used for indenting paragraphs. The
double-headed arrows shown in Figure 84 are mouse pointers shown in the correct
position for moving the margin markers. Because the triangles and arrows are often
in the same place, when changing page margins you need to be careful to move the
arrows, not the gray triangles.
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Figure 84: Moving the margins
To change margins using the Page Style dialog:
1) Right-click anywhere in the text area on the page and select Page Style in the context
menu.
2) On the Page tab of the dialog, type the required distances in the boxes in the Margins
area.
To change margins using the Page deck of the Sidebar:
1) On the Sidebar, open the Page deck.
2) On the Format panel, use the Margins drop-down list to select the desired margins from
the defaults provided. Click the More Options button to open the Page Style dialog
where you can enter exact margin distances.

Choosing a page background
You can apply backgrounds to many elements in Writer, including pages. On the Area tab of the
Page Style dialog, choose a background type (color, gradient, bitmap, pattern, or hatch). On the
Page tab of the dialog, you can choose whether the background covers only the text area (the
area inside the margins) or the entire page. For more about backgrounds, see Chapter 6,
Formatting Pages: Advanced in the Writer Guide.

Adding a custom watermark to the page background
To add a watermark to a page background:
1) Choose Format > Watermark.
2) In the Watermark dialog (Figure 85), type the text and select the font, angle, transparency
and color of the watermark. Then click OK.

Note
The watermark will automatically become part of the page style where it is inserted
and all other pages of the same style will have the watermark. Pages with different or
no watermarks need different Page Styles for those pages.
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Figure 85: The Watermark dialog

Defining a different first page for a document
Many documents, such as letters and memos, have a first page that is different from the other
pages in the document. For example, the first page of a letterhead typically has a different
header, or the first page of a report might have no header or footer, while the other pages do.
You can do this in several ways, as described in Chapter 5, Formatting Pages, in the Writer
Guide:
•

Use the Default (or any other) page style for your document. Deselect the Same content
on first page option on the Header/Footer tabs in the Page Style dialog, and then add
different headers/footers to the first page and to the other pages of the document.

•

Use different page styles for the first page and for the following pages. Set the Next Page
attribute for the first page so the next page automatically becomes the style for following
pages.

•

Add a title page at the beginning of the document. Writer provides a fast and convenient
way to add one or more title pages to a document and optionally to restart the page
number at 1 for the body of the document, using Format > Title Page on the Menu bar.

Adding comments to a document
Authors and reviewers often use comments to exchange ideas, ask for suggestions, or mark
items needing attention.
You can connect a comment to multiple paragraphs or a single point. To insert a comment, select
the text, or place the cursor in the place the comment refers to, and choose Insert > Comment
on the menu bar, click the Insert Comment icon on the Standard toolbar, or press Ctrl+Alt+C.
The anchor point of the comment is connected by a dotted line to a box on the right-hand side of
the page where you can type the text of the comment. A Comments button is also added to the
right of the horizontal ruler at the top of the page; you can click this button to toggle the display of
the comments.

Formatting comments
At the bottom of the comment, Writer automatically adds the author’s name and a time stamp
indicating when the comment was created. If more than one person edits the document, each
author is automatically allocated a different background color. Figure 86 shows an example of
text with comments from two different authors.

116 | LibreOffice 7.3 Getting Started Guide

Figure 86: Example of comments
Choose Tools > Options > LibreOffice > User Data to provide the name you want to appear in
the Author field of comments.
Right-click on a comment to open a context menu where you can delete the current comment, all
the comments from the same author, or all the comments in the document. On this menu, you
can also reply to a comment, open a dialog to apply some basic formatting to the text, and mark
comments as Resolved. These options are also available on a drop-down menu accessed by
clicking the down arrow icon at the bottom right of the comment.

Navigating through comments
To navigate from one comment to another, open the sidebar Navigator, expand the Comments
section, and click on the comment text to move the cursor to the anchor point of the comment in
the document. Click the comment directly to edit it and right-click on the comment to delete it.
You can also navigate through the comments using the keyboard. Use Ctrl+Alt+Page Down to
move to the next comment and Ctrl+Alt+Page Up to move to the previous comment.

Printing comments
When a document contains comments, the print dialog has an option for comments to be printed
next to the text in the right margin, as they appear on the screen. In that case, the text on each
page is scaled down to make space for the comments. The Print dialog also has options for
placing comments at the end of the page or at the end of the document, or for printing only the
comments.

Using built-in language tools
Writer provides some tools that make work easier if you use more than one language in the same
document or if you write documents in various languages. Changing the language for specific
text enables you to use the correct dictionaries and rules to check spelling, grammar, and
hyphenation. It also applies the localized versions of AutoCorrect replacement options and uses
the appropriate thesaurus.

Options for applying languages
Tip
The language used at the location of the cursor is shown in the Status bar, next to
the page style in use.
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Using styles
Languages can be set on the Font tab of the Paragraph Style dialog or the Character Style
dialog. See the Writer Guide for information on how to manage the language settings of a style.

Caution
Be careful when changing a language in character or paragraph styles, as this will
change the language for all characters or paragraphs using that style. It may be
useful to include the language in the name of the style.
Languages set with direct formatting will override languages set using styles.

Using direct formatting
The language of a whole document can be set by using Tools > Options > Language Settings
> Languages. In the Default Languages for Documents section, you can choose the language
for all the text that is not explicitly marked as a different language.
Set the language for the whole document, for individual paragraphs, or even for individual words
and characters, in Tools > Language on the Menu bar, and select For Selection, For
Paragraph or For All Text. If the required language is not available in the submenu, click More.
The Tools > Options > Language Settings > Languages menu opens, where you can select
the language as described above.
Alternatively, you can set the language for individual paragraphs and characters by selecting text
or putting the cursor in a paragraph and changing the language on the Status bar. There is also
an option More, in case the text is not directly available.

Note
Although these methods are a type of direct formatting, they cannot be cleared by
using Format > Clear Direct Formatting on the Menu bar, clicking the Clear Direct
Formatting icon on the Formatting toolbar, selecting Clear Direct Formatting in the
context menu, or using Ctrl+M.

Preventing text from being checked for spelling
You can set the language for a paragraph or a group of characters as None (Do not check
spelling) using any of the methods described above. This option is especially useful for text such
as web addresses or programming language snippets that you do not want to check for spelling.

Obtaining resources for additional languages
The spelling checker works only for those languages in the Spelling dialog list that have a
dictionary installed. You can install additional dictionaries using Tools > Language > Writing
Aids > More Dictionaries Online.

Creating a table of contents
Writer can generate a table of contents from the headings in your document. Before you start,
make sure that the headings are styled consistently. For example, you can use the Heading 1
style for chapter titles and the Heading 2 and Heading 3 styles for chapter subheadings.
Although tables of contents can be customized extensively in Writer, often the default settings are
all you need. Creating a quick table of contents is simple:

118 | LibreOffice 7.3 Getting Started Guide

1) When you create your document, use the following paragraph styles for hierarchical
heading levels (such as chapter and section headings): Heading 1, Heading 2, Heading
3, and so on. These headings are what will appear in your table of contents.
2) Place the cursor where you want the table of contents to appear.
3) Choose Insert > Table of Contents and Index > Table of Contents, Index or
Bibliography.
4) Change nothing in the Table of Contents, Index, or Bibliography dialog (unless you want
to change the number of levels shown). Click OK.
If you add or delete text (so that headings move to different pages) or you add, delete, or change
headings, you need to update the table of contents. To do this, right-click anywhere within the
table of contents and choose Update index in the context menu.
You can define your own heading styles and set them up in Tools > Chapter Numbering. You
can also include other paragraph styles in the table of contents by assigning outline levels to
those styles on the Outline & Numbering tab of the paragraph style dialog.
You can customize an existing table of contents at any time. Right-click anywhere in it and
choose Edit Index in the context menu. Chapter 15, Tables of Contents, Indexes, Bibliographies,
in the Writer Guide describes in detail all the customization options you can choose.

Creating indexes and bibliographies
Indexes and bibliographies work in a similar way to tables of contents. In addition to alphabetical
indexes, other types of index supplied with Writer include those for illustrations, tables, and
objects.
You can also create a user-defined index. For example, you might want an index containing only
the scientific names of species mentioned in the text, and a separate index containing only the
common names of species.
Before creating an index, you first need to create index entries in your Writer document. Chapter
15, Tables of Contents, Indexes, Bibliographies, in the Writer Guide describes how to do this.

Using footnotes and endnotes
Footnotes appear at the bottom of the page on which they are referenced. Endnotes are
collected at the end of a document.
To work effectively with footnotes and endnotes, you need to:
•

Insert footnotes and define their format.
To insert a footnote or an endnote, put the cursor where you want the footnote or endnote
marker to appear. Then select Insert > Footnote and Endnote on the Menu bar and
choose Footnote or Endnote, or click the Insert Footnote or Insert Endnote button on
the Standard toolbar.
A footnote or endnote marker is inserted in the text and, depending on your choice, the
cursor is relocated either to the footnote area at the bottom of the page or to the endnote
area at the end of the document. Type the footnote or endnote content in this area.
To format the footnotes themselves, click Tools > Footnotes and Endnotes. On the
Settings of Footnotes and Endnotes dialog, choose settings as required.
See Chapter 3, Working with Text: Advanced, in the Writer Guide for more details.
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•

Define the location of footnotes on the page, and the color and line styles for separator
lines, if the defaults do not meet your needs. These are found on the Footnote tab of the
Page Style dialog; see Chapter 5, Formatting Pages: Basics, in the Writer Guide.

Inserting material from other documents
You may wish to reuse material from other files in the document you are writing. For example,
you might be writing a set of instructions that include some common paragraphs. You could, of
course, retype or copy and paste the common paragraphs into each document. However, if the
common paragraphs are edited, you may need to update that information in every document
where it occurs.
Writer provides some tools for making these tasks easier:
•

The Section dialog, described in Chapter 6, Formatting Pages: Advanced, in the Writer
Guide.

•

Two items in the Navigator’s drag modes: Insert as Link and Insert as Copy. See Chapter
3, Working with Text: Advanced, in the Writer Guide.

Working with images (graphics)
Images in Writer are of these basic types:
•

Image files, including photos, drawings, and scanned images

•

Diagrams created using LibreOffice’s drawing tools

•

Artwork created using clip art or Fontwork

•

Charts created using LibreOffice’s Chart facility

See Chapter 11, Images and Graphics, in this book and Chapter 11 in the Writer Guide.

Working with tables
Tables are a useful way to organize and present large amounts of information. A well-designed
table can often help readers understand better what you are saying. In addition to using tables for
text or numbers, you could put other objects, such as pictures, in cells. Writer’s tables can often
be used as an alternative to spreadsheets, and they provide limited spreadsheet functions.
To directly insert a table with the default properties, click the Insert Table icon on the Standard
toolbar. On the drop-down graphic, choose the size of the table.
To insert a new table using the Insert Table dialog, where you can specify the properties for the
table, position the cursor where you want the table to appear, then use any of the following
methods to open the dialog:
•

Choose Table > Insert Table on the Menu bar.

•

Press Ctrl+F12.

•

On the Standard toolbar, click the Insert Table icon and select More Options at the
bottom of the drop-down graphic.

Writer provides many methods to format tables and the contents of cells. Refer to Chapter 13,
Tables of Data, in the Writer Guide.
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Printing and exporting to PDF or EPUB
See Chapter 10, Printing, Exporting, Emailing, and Signing Documents, in this book and Chapter
7 in the Writer Guide for details on:
•

Previewing pages before printing, selecting print options, printing in black and white on a
color printer, printing brochures, and other printing features.

•

Exporting a Writer document to PDF (Portable Document Format) or EPUB (a popular
ebook format).

Using mail merge
Writer provides very useful features to create and print:
•

Multiple copies of a document to send to a list of different recipients (form letters)

•

Mailing labels

•

Envelopes

All these features use data from a registered data source (a spreadsheet or database containing
name and address records or other information). Chapter 14 in the Writer Guide describes the
merge processes.

Tracking changes to a document
You can use several methods to keep track of changes made to a document. Details are in
Chapter 3, Working with Text: Advanced, in the Writer Guide.
Method 1 (Recommended)
Use Writer’s change marks (often called “redlines” or “revision marks”) to show added or deleted
material or changed formatting. Comments can be recorded to explain the changes; these are
handled a bit differently from the comments discussed in “Adding comments to a document” on
page 116.
1) Open the document and choose Edit > Track Changes > Record before starting to edit.
2) Later, you or another person can review and accept or reject each change. Choose Edit
> Track Changes > Show. Right-click on an individual change and choose Accept
Change or Reject Change in the context menu, or choose Edit > Track Changes >
Manage to view the list of changes and accept or reject them. You can also use the icons
on the Track Changes toolbar.
Method 2
Make your changes to a copy of the document (stored in a different folder, or under a different
name, or both), then use Writer to combine the two files and show the differences. Choose Edit >
Track Changes > Compare Document or Edit > Track Changes > Merge Document.
Method 3
Save versions that are stored as part of the original file. However, this method can cause
problems with documents of non-trivial size or complexity, especially if you save a lot of versions.
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Note
Writer 7.3 includes improvements in change tracking, including marking of moved
text (paragraphs, sentences, and list elements), change of paragraph style, insertion
and deletion of empty table rows, and others. However, not all changes are
recorded. For example, changing a tab stop from align left to align right, and
changes in formulas (equations) or linked graphics are not recorded.

Tip
In addition to the Edit > Track Changes menu, Writer provides the same commands
on the Track Changes toolbar (View > Toolbars > Track Changes).

Caution
A document with track changes activated but with the changes not shown carries an
invisible history of document editing that the current user may not be aware of.
Contents deleted or modified can be recovered. While this is a feature, it is also a
potential privacy risk.

Using fields
Fields are extremely useful features of Writer. You can use them for data that changes (such as
the current date or the total number of pages) and for inserting document properties such as
name, author, and date of last update. Fields are the basis of cross-referencing (see below);
automatic numbering of figures, tables, headings, and other elements; and a wide range of other
functions. See Chapter 17, Fields, in the Writer Guide for details.

Linking and cross-referencing within a document
If you manually type in cross-references to other parts of a document, those references can
easily get out of date if you reorganize the order of topics, add or remove material, or reword a
heading. Writer provides two ways to ensure that your references are up to date: hyperlinks and
cross-references.
Both methods insert links to other parts of the same document or to an external source, taking
you directly to the cross-referenced item. However, they have major differences:
•

The text in a hyperlink does not automatically update if you change the text of the linked
item (although you can change it manually), but changed text does automatically update
in a cross-reference.

•

When using a hyperlink, you do not have a choice about the type of content linked to
(such as text or page number), but when using a cross-reference, you have several
choices, including bookmarks.

•

To hyperlink to an object such as a graphic, and have the hyperlink show useful text such
as Figure 6, you need to give such an object a useful name (instead of a default name
like Graphics6), or use the Hyperlink dialog to modify the visible text. In contrast, crossreferences to figures with captions can automatically show useful text, and you have a
choice of several variations of the name.

•

If you save a Writer document to HTML, hyperlinks remain active but cross-references do
not. Both remain active when the document is exported to PDF.
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Using hyperlinks
See Chapter 12, Creating HTML Files, for details on creating hyperlinks within a document and to
other documents and websites.

Creating and using cross-references
The Cross-references tab of the Fields dialog lists some items, such as headings, bookmarks,
figures, tables, or numbered items such as steps in a procedure. You can also create your own
reference items; see Chapter 17, Fields, in the Writer Guide.
To insert a cross-reference:
1) In the document, place the cursor where you want the cross-reference to appear.
2) If the Fields dialog is not open, click Insert > Cross-reference. On the Cross-references
tab (Figure 87), in the Type list, select the type of item to be referenced (for example,
Headings or Figure).
3) Click on the required item in the Selection list, which shows all the items of the selected
type. You can type some characters in the top box under Selection to filter the list in the
selection box.

Figure 87: The Cross-references tab of the Fields dialog
4) In the Insert reference to list, select the option needed. The options determine the text
inserted for the hyperlink and how it is formatted. The list varies according to the Type
chosen. The most commonly used options are Reference (to insert the full text of a
heading or caption), Category and Number (to insert a figure number preceded by the
word Figure or Table, but without the caption text), Numbering (to insert only the figure or
table number, without the word Figure or Table), or Page (to insert the number of the
page the referenced text is on).
5) Click Insert.
You can leave this dialog open while you insert many cross-references.
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Using bookmarks
You can use bookmarks to rapidly navigate or link to specific locations in a document. They are
listed in the Navigator and can be accessed directly from there with a single mouse click. You can
cross-reference to bookmarks and create hyperlinks to bookmarks, as described above.
To create a bookmark:
1) Select the text you want to bookmark. Click Insert > Bookmark.
2) On the Insert Bookmark dialog, the larger box lists any previously defined bookmarks.
Type a name for this new bookmark in the top box, and then click Insert.

Using master documents
A master document joins separate text documents into one larger document, and unifies the
formatting, table of contents, bibliography, index, and other tables or lists. Master documents are
typically used for producing long documents such as a book, thesis, or long report. They are
especially handy when different people are writing different sections of a document, eliminating
the need to continually share the full document. For details on using master documents, see
Chapter 16 in the Writer Guide.

Creating fill-in forms
In a standard text document, such as a report, any text can be edited. By contrast, a form has
sections that are not to be edited, and other sections that are designed for the reader to fill in
information. For example, a questionnaire has an introduction and questions (which do not
change) and spaces for the reader to enter answers.
Forms are used in three ways:
•

To create a simple document for the recipient to complete, such as a questionnaire sent
out to a group of people who fill it in and return it.

•

To enter information directly into a database or data source. Someone taking orders
might enter the information for each order into a database using a form.

•

To view information held in a database or data source. A librarian might call up
information about books.

Writer offers several ways to organize information fields in a form, including check boxes, option
buttons, text boxes, pull-down lists, and spinners. Two toolbars are used to create forms: Form
Controls and Form Design. See Chapter 18, Forms, in the Writer Guide for more information.
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Getting Started Guide 7.3

Chapter 5,
Getting Started with Calc
Using spreadsheets in LibreOffice

What is Calc?
Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a
spreadsheet and then manipulate this data to produce certain results.
Alternatively, you can enter data and then use Calc in a “What if...” manner by changing some of
the data and observing the results without having to retype the entire spreadsheet or sheet.
Other features provided by Calc include:
•

Functions, which can be used to create formulas to perform complex calculations on
data.

•

Database functions, to arrange, store, and filter data.

•

Dynamic charts, including a wide range of 2D and 3D charts.

•

Macros, for recording and executing repetitive tasks; scripting languages supported
include LibreOffice Basic, Python, BeanShell, and JavaScript.

•

Ability to open, edit, and save Microsoft Excel spreadsheets.

•

Import and export of spreadsheets in multiple formats, including HTML, CSV (without or
with formulas), dBase, PDF, and PostScript.

•

Collaborate with others seamlessly by sharing the spreadsheet.

Compatibility with other spreadsheet applications
Wildcards
Simple wildcards such as the asterisk (*), question mark (?), and tilde (~) from other spreadsheet
applications are recognized by LibreOffice in formula expressions.

Formula syntax
By default, LibreOffice Calc uses its own formula syntax, referred to as Calc A1, rather than the
Excel A1 syntax used by Microsoft Excel. LibreOffice will translate seamlessly between the two.
However, if you are familiar with Excel you may wish to change the default syntax in Calc by
going to Tools > Options > LibreOffice Calc > Formula and choosing Excel A1 or Excel R1C1
in the Formula syntax drop-down menu.
For more information on formula syntax, see Chapter 7, Using Formulas and Functions, in the
Calc Guide.

Macros
Microsoft Office uses Visual Basic for Applications (VBA) code, and LibreOffice uses Basic code
based on the LibreOffice API. Although the programming languages are the same, the objects
and methods are different and therefore not entirely compatible.
LibreOffice can run some Excel Visual Basic scripts if you enable this feature at Tools > Options
> Load/Save > VBA Properties.
If you want to use macros written in Microsoft Excel using the VBA macro code in LibreOffice,
you must first edit the code in the LibreOffice Basic IDE editor.
For more information, refer to Chapter 12, Calc Macros, in the Calc Guide.
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Spreadsheets, sheets, and cells
Calc works with documents called spreadsheets. Spreadsheets consist of a number of individual
sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified
by its row number and column letter.
Cells hold the individual elements – text, numbers, formulas, and so on – that make up the data
to display and manipulate.
Each spreadsheet can have up to 10,000 sheets, and each sheet can have a maximum of
1,048,576 rows and a maximum of 1024 columns.

Calc main window
When Calc is started, the main window opens (Figure 88). The parts of this window are
described below. You can show or hide many of the parts as desired, using the View menu on the
Menu bar.

Figure 88: Calc main window

Title bar
The Title bar, located at the top, shows the name of the current spreadsheet. When a
spreadsheet is newly created from a template or a blank document, its name is Untitled X, where
X is a number. When you save a spreadsheet for the first time, you are prompted to enter a name
of your choice.

Menu bar
Under the Title bar is the Menu bar. When you select one of the menu items, a sub-menu drops
down to show commands. You can also customize the Menu bar; see Chapter 14, Customizing
LibreOffice, for more information.
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Most of the menus are similar to those in other components of LibreOffice, although the specific
commands and tools may vary. The menus specific to Calc are Sheet and Data; in addition,
several important data analysis tools are found in the Tools menu.
Sheet
The most often used commands for handling sheets, such as Insert and Delete Cells,
Columns, Rows and Sheets; select Cell Reference Type; and Link to External Data.
Data
Commands for manipulating data in the spreadsheet; for example, Define Range, Sort,
Filters, Statistics, Pivot Tables, Consolidate, Forms, Groups and Outlines.
Tools
Functions to help you check and customize the spreadsheet; for example, Spelling,
Macros, Goal Seek, Solver, Scenarios, Detective, Protect Sheet, XML Filter Settings, and
Extension Manager.
View
Two commands of particular interest on the Calc View menu are:
Value Highlighting (Ctrl+F8) – when active, Calc can show or hide cell contents in different
colors, depending on type. The default colors can be customized in Tools > Options >
LibreOffice > Application Colors.
Show Formula (Ctrl+`) – when active, Calc shows formulas instead of calculated results.

Toolbars
In a default LibreOffice installation, the top docked toolbar, just under the Menu bar, is called the
Standard toolbar. It is consistent across the LibreOffice applications. The position and use of it
and other toolbars are described in Chapter 1, Introducing LibreOffice.

Formula bar
The Formula Bar (Figure 89) is located at the top of the sheet in the Calc workspace. It is
permanently docked in this position and cannot be used as a floating toolbar. However, it can be
hidden or made visible by selecting or deselecting View > Formula Bar on the Menu bar.

Figure 89: Formula Bar
From left to right, the Formula Bar includes the following:
Name Box – gives the current active cell reference using a combination of a letter and
number, for example A1. The letter indicates the column and the number indicates the row
of the selected cell. If you have selected a range of cells that is also a named range, the
name of the range is shown in this box. You can also type a cell reference in the Name Box
to jump to the referenced cell. If you type the name of a named range and press the Enter
key, the named range is selected and displayed.
Function Wizard – opens a dialog from which you can search through lists of available
functions and formulas. This can be very useful because it also shows how the functions
are formatted.
Select Function – this drop-down list provides five choices: Sum, Average, Min, Max, and
Count (Figure 90).
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Figure 90: Select Function drop-down
Formula – inserts an equals (=) sign into the selected cell and the Input line, allowing a
formula to be entered. The Name Box now displays a drop-down list of the most frequently
used functions, for a quick access to the function name and syntax.
Input line – displays the contents of the selected cell (data, formula, or function) and
allows you to edit the cell contents. To turn it into a multi-line input area for very long
formulas, click the down arrow on the far right-hand end of the Input line.
You can also directly edit the contents of a cell by double-clicking on the cell. When you enter or
edit data in a cell, the Select Function and Formula icons change to Cancel and Accept icons.

Note
In a spreadsheet, the term “function” covers much more than just mathematical
functions. See Chapter 7, Using Formulas and Functions, in the Calc Guide for more
information.

Status bar
The Calc Status bar (Figures 91 and 92) provides information about the spreadsheet as well as
quick and convenient ways to change some of its features. Most of the fields are similar to those
in other components of LibreOffice. See Chapter 1, Introducing LibreOffice, for more information.

Figure 91: Calc Status bar (left)

Figure 92: Calc Status bar (right)
The Status bar has a quick way to do some math operations on selected cells in the
spreadsheet. You can view the calculated average and sum, count of elements, and more on the
selection by right-clicking over the Cell/Object Information area and selecting the operations you
want to display in the Status bar (Figure 93).
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Figure 93: Selecting math operations to show on Status bar

Sidebar
The Calc Sidebar (View > Sidebar or Ctrl+F5) is located on the right side of the window. It is a
mixture of toolbar and dialog. It is similar to the Sidebar in Writer (shown in Chapter 1 and
Chapter 4 of this book) and consists of five decks: Properties, Styles, Gallery, Navigator, and
Functions. Each deck has a corresponding icon on the Tab panel to the right of the sidebar,
allowing you to switch between them. The decks are described below.
Properties
This deck includes five content panels. These panels, with the exception of the Style panel,
have a More Options button that opens a dialog with additional options. These dialogs lock
the document for editing until they are closed.
Style: Access to the available cell styles, update cell styles, and new cell styles.
Character: Controls for formatting the text, such as font family, size, and color. Some
controls, such as superscript, become active only when the text cursor is active in the Input
line of the Formula bar or the cell.
Number Format: Quickly change the format of numbers including decimals, currency,
dates, percentage, or numeric text; and leading zeroes.
Alignment: Controls to align the text in various ways, including horizontal and vertical
alignment, wrapping, indenting, merging, text orientation, and vertical stacking.
Cell Appearance: Controls to set the appearance of cells, including cell background color,
cell border formats including line color and style, and grid lines.
Styles, Gallery, Navigator
These decks are similar to those in Writer. Their use is described in the Calc Guide.
Functions
This deck contains a list of functions organized by category. It is a simpler version of the
Function Wizard, which is opened by selecting Insert > Function on the Menu bar,
pressing the Function Wizard icon on the Formula Bar, or by pressing Ctrl+F2.

Spreadsheet layout
Individual cells
The main section of the workspace in Calc displays the cells in the form of a grid. Each cell is
formed by the intersection of one column and one row in the spreadsheet.
At the top of the columns and the left of the rows are a series of header boxes containing letters
and numbers. The column headers use an alpha character starting at A and go on to the right.
The row headers use a numerical character starting at 1 and go down.
These column and row headers form the cell references that appear in the Name Box on the
Formula Bar (Figure 89). If the headers are not visible on the spreadsheet, choose View > View
Headers on the Menu bar.
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Sheet tabs
Each Calc spreadsheet can contain multiple sheets. At the bottom of the grid of cells are sheet
tabs indicating how many sheets are in the spreadsheet. By default, a new spreadsheet is
created with one sheet named Sheet1. Click on a tab to display that sheet. An active sheet is
indicated with a white tab (default Calc setup). You can also select multiple sheets by holding
down the Ctrl key while clicking on the sheet tabs.
To change the default name for a sheet (Sheet1, Sheet2, and so on), right-click on a sheet tab
and select Rename Sheet in the context menu, or double-click on the sheet tab, to open the
Rename Sheet dialog where you can type a new name for the sheet.
To change the color of a sheet tab, right-click on the tab and select Tab Color in the context
menu to open the Tab Color dialog. Select a color and click OK. To add new colors to this color
palette, see Chapter 14, Customizing LibreOffice.

Opening a CSV file
Comma-separated values (CSV) files are spreadsheet files in a text format where cell contents
are separated by a character, for example a comma or semicolon or any other character like
vertical bar. Each line in a CSV text file represents a row in a spreadsheet. Text is entered
between quotation marks; numbers are entered without quotation marks. It treats data as a
formula if the column value begins with an equal sign (=).

Figure 94: Text Import dialog
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Note
Most CSV files come from database tables, queries, or reports, where further
calculations and charting are required.
To open a CSV file in Calc:
1) Choose File > Open on the Menu bar and locate the CSV file. Most CSV files have the
extension .csv. However, some CSV files may have a .txt extension.
2) Select the file and click Open.
3) On the Text Import dialog (Figure 94), select the required options for importing the CSV
file into the Calc spreadsheet. For details about these options, see Chapter 1, Introducing
Calc, in the Calc Guide.
4) Click OK to import the file.

Saving spreadsheets
For information on how to save files manually or automatically, see Chapter 1, Introducing
LibreOffice. Calc can save spreadsheets in a range of formats and also export spreadsheets to
PDF, HTML, XHTML file formats and JPEG and PNG images formats; see Chapter 6, Printing,
Exporting, E-mailing, and Signing, in the Calc Guide for more information.

Saving in other spreadsheet formats
You can save a spreadsheet in another format:
1) Save the spreadsheet in Calc spreadsheet file format (*.ods).
2) Select File > Save As on the Menu bar to open the Save As dialog.
3) In the File name field, you can enter a new file name for the spreadsheet.
4) In the File type drop-down list, select the type of spreadsheet format you want to use.
5) If Automatic file name extension is present and selected, the correct file extension for
the spreadsheet format you have selected will be added to the file name.
6) Click Save.
When a spreadsheet file is saved in a format other than .ods, the Confirm File Format dialog
opens (Figure 95). Click Use [xxx] Format to continue saving in your selected spreadsheet
format or click Use ODF Format to save the spreadsheet in Calc .ods format. If you uncheck Ask
when saving in ODF or default format, this dialog no longer appears when saving in another
format.

Figure 95: Confirm File Format dialog
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If you select Text CSV format (*.csv) for your spreadsheet, the Export Text File dialog (Figure
96) opens. Here you can select the character set, field delimiter, string (text) delimiter, and so on
to be used for the CSV file.

Figure 96: Export Text File dialog for CSV files

Note
Once you have saved a spreadsheet in another format, all changes you make to the
spreadsheet will now occur only in the format you are using. If you want to go back
to working with a *.ods version, you must save the file as a *.ods file.

Tip
To have Calc save spreadsheets by default in a file format other than .ods, go to
Tools > Options > Load/Save > General. In the Default File Format and ODF
Settings area, select Spreadsheet in Document type, then in Always save as, select
your preferred file format.

Exporting values and formulas as a CSV file
Calc can export raw data and calculated data as a CSV file. An example of data for export is
shown in Figure 97, and the resulting CSV file is shown in Figure 98.
The steps to export are:
1) Click the sheet to be written as a CSV file.
2) Choose Tools > Options > LibreOffice Calc > View on the Menu bar.
3) Under Display, mark the Formulas check box. Click OK.
4) Choose File > Save as.
5) On the Save as dialog, select Text CSV in the File type field.
6) Enter a filename and click Save.
7) From the Export of text files dialog that appears, select the character set and the field and
text delimiters for the data to be exported, and confirm with OK.
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Figure 97: Exporting raw and calculated values

Figure 98: CSV file containing raw and calculated values

Exporting contents as an image
To send a fragment of a spreadsheet to someone or publish it on the Internet, you can export a
range selection or a selected group of shapes (images) to a PNG or JPG graphics format:
1) Select the cell range or the group of shapes, then select File > Export.
2) In the Export dialog, type a name for the image, select the graphics file format, and mark
the Selection checkbox.
3) Click Export or Save, as appropriate.
Calc may open a further dialog for you to configure the settings associated with the selected
graphics format.

Exporting a whole sheet as one page
Calc can export the entire contents of a sheet as a PDF in one page. It is easier to preview the
contents on one page to understand if it requires any changes.
The steps to export the contents to one page:
1) From the Menu bar, select File > Export as PDF.
2) On the General tab of the PDF options dialog (Figure 99), select the option Whole sheet
export.
3) Click the Export button, and choose a location for the PDF.
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Figure 99: Exporting sheets to PDF as one page

Importing external data – Web Query
Calc can import data using web query by linking to an external data source. You can filter or
choose the table to import by HTML caption:
1) Position the cursor in the cell where you want the new content to be imported.
2) Choose Sheet > Link to External Data to open the External Data dialog (Figure 100).
3) Enter the URL of the HTML document or the name of the spreadsheet, then press Enter.
You can also click the Browse button to open a file selection dialog.
4) In the Available Tables/Ranges list box, select the named ranges or tables you want to
insert. You can also specify that the ranges or tables are updated every n seconds. These
tables are now listed in the order they appear in the source.
5) Click OK to finish.

Figure 100: Link to external data
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Navigating within spreadsheets
Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet.
You can generally use the method you prefer.

Cell navigation
When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is
selected, the cell area is colored. The color of the cell border emphasis and the color of a group
of selected cells depends on the operating system being used and how you have set up
LibreOffice.
Mouse: place the mouse pointer over the cell and click the left mouse button.
Cell reference: delete the existing cell reference in the Name Box on the Formula Bar
(Figure 89 on page 128). Type the new cell reference and press Enter. Cell references are
case-insensitive.
Navigator: press F5 to open the Navigator (Figure 101) or click the Navigator button on
the Sidebar. Type the cell reference into the Column and Row fields, or use the adjacent
increment / decrement buttons, and press Enter.

Figure 101: Calc Navigator
Enter key: moves the cell focus down in a column to the next row. Shift+Enter moves the
focus up in a column to the previous row. You can change the action of the Enter key; see
“Customizing the Enter key” on page 138.
Tab key: moves the cell focus right in a row to the next column. Shift+Tab moves the focus
to the left in a row to the previous column.
Arrow keys: the arrow keys on the keyboard move the cell focus in the direction of the
arrow pressed.
Home, End, Page Up, and Page Down keys:
– Home moves the cell focus to the start of a row.
– End moves the cell focus to the last cell on the right in the row in the right-most
column that contains data.
136 | LibreOffice 7.3 Getting Started Guide

– Page Down moves the cell focus down one complete screen display.
– Page Up moves the cell focus up one complete screen display.

Sheet navigation
Each sheet in a spreadsheet is independent of the other sheets, though references can be linked
from one sheet to another. To navigate between sheets in a spreadsheet:
Navigator – double-click on any of the listed sheets to select the sheet.
Keyboard – Ctrl+Page Down moves one sheet to the right and Ctrl+Page Up moves one
sheet to the left.
Mouse – click on a sheet tab at the bottom of the spreadsheet to select that sheet.
If your spreadsheet contains a lot of sheets, then some of the sheet tabs may be hidden. If this is
the case:
•

Using the four buttons to the left of the sheet tabs can move the tabs into view (Figure
102).

•

Right-clicking on any of the arrows, or the +, opens a context menu where you can select
a sheet (Figure 103).

Figure 102: Navigating sheet tabs

Figure 103: Right-click any active arrow button

Note
When you insert a new sheet into a spreadsheet, Calc automatically uses the next
number in the numeric sequence as a name. Depending on which sheet is open
when you insert a new sheet, the new sheet may not be in its correct numerical
position. It is recommended to rename sheets in a spreadsheet to make them more
recognizable.
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Keyboard navigation
You can navigate a spreadsheet using the keyboard, by pressing a key or a combination of keys.
See Chapter 1, Introduction, and Appendix A, Keyboard Shortcuts, in the Calc Guide for the keys
and key combinations you can use for spreadsheet navigation in Calc.

Customizing the Enter key
You can choose the direction in which the Enter key moves the cell focus by going to Tools >
Options > LibreOffice Calc > General. Use the first two options under Input Settings (Figure
104) to change the Enter key settings.

Figure 104: Customizing the Enter key
Select the direction cell focus moves from the drop-down list. The Enter key can also be used to
switch into and out of editing mode. You can enable or disable the use of Enter to paste the
content of a cell that has been copied to the clipboard.

Selecting items in a spreadsheet
Selecting cells
Single cell
Click in the cell. You can verify your selection by looking in the Name Box on the Formula Bar
(Figure 89 on page 128).
Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.
To select a range of cells by dragging the mouse cursor:
1) Click in a cell.
2) Press and hold down the left mouse button.
3) Move the mouse to highlight the desired block of cells, then release the mouse button.
To select a range of cells without dragging the mouse:
1) Click in the cell that is to be one corner of the range of cells.
2) Hold down the Shift key and click in the opposite corner cell of the block of cells.
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Tip
You can also select a contiguous range of cells by first clicking in the Selection mode
field on the Status bar (Figure 92 on page 129) and selecting Extending selection
before clicking in the opposite corner of the range of cells. Make sure to change back
to Standard selection or you may extend a cell selection unintentionally.
To select a range of cells without using the mouse:
1) Select the cell that will be one of the corners in the range of cells.
2) While holding down the Shift key, use the cursor arrows to select the rest of the range.

Tip
You can also directly select a range of cells using the Name Box. Click in the Name
Box on the Formula Bar (Figure 89 on page 128). Enter the cell reference for the
upper left-hand cell, followed by a colon (:), and then the lower right-hand cell
reference. For example, to select the range that would go from A3 to C6, you would
enter A3:C6.
Range of non-contiguous cells
1) Select the cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single cell.
3) Hold down the Ctrl key and click or click-and-drag to select another range of cells to add
to the first range.
4) Repeat as necessary.

Selecting columns and rows
Single column or row
To select a single column, click on the column header (Figure 88 on page 127). To select a single
row, click on the row header.
Multiple columns or rows
To select multiple columns or rows that are contiguous:
1) Click on the first column or row in the group.
2) Hold down the Shift key.
3) Click the last column or row in the group.
To select multiple columns or rows that are not contiguous:
1) Click on the first column or row in the group.
2) Hold down the Ctrl key.
3) Click on all of the subsequent columns or rows while holding down the Ctrl key.
Entire sheet
To select the entire sheet, click on the corner box between the column header A and the row
header 1 (Figure 105), or use the key combination Ctrl+Shift+Space to select the entire sheet, or
use Edit > Select All on the Menu bar.
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Figure 105: Select All box

Selecting sheets
You can select one or multiple sheets in Calc. It can be advantageous to select multiple sheets,
especially when you want to make changes to many sheets at once.
Single sheet
Click on the sheet tab for the sheet you want to select. The tab for the selected sheet becomes
white (default Calc setup).
Multiple contiguous sheets
To select multiple contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) Hold down the Shift key and click on the sheet tab for the last desired sheet.
3) All tabs between these two selections will turn white (default Calc setup). Any actions that
you perform will now affect all the highlighted sheets.
Multiple non-contiguous sheets
To select multiple non-contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) Hold down the Ctrl key and click on the sheet tab for the each additional desired sheet.
3) The selected tabs will turn white (default Calc setup).
All sheets
Right-click a sheet tab and choose Select All Sheets in the context menu, or select Edit >
Select > Select All Sheets on the Menu bar.

Working with columns and rows
Inserting columns and rows
Single column or row
Using the Sheet menu:
1) Select a cell, column, or row where you want the new column or row inserted.
2) Go to Sheet on the Menu bar and select either Insert Columns > Columns Before, or
Insert Columns > Columns After, or Insert Rows > Rows Above, or Insert Rows >
Rows Below.
Using the mouse:
1) Select a column or row where you want the new column or row inserted.
2) Right-click the column or row header.
3) Select Insert Columns Before, Insert Columns After, Insert Rows Above, or Insert
Rows Below in the context menu.
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Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a time.
1) Highlight the required number of columns or rows by holding down the left mouse button
on the first one and then dragging across the required number of identifiers.
2) Proceed as for inserting a single column or row above.

Hiding and showing columns and rows
To hide columns or rows:
1) Select the row or column you want to hide.
2) Go to Format on the Menu bar and select Rows or Columns.
3) Select Hide in the submenu. Alternatively, right-click on the row or column header and
select Hide Rows or Hide Columns in the context menu.
To show hidden columns or rows:
1) Select the rows or columns on each side of the hidden row or column.
2) Go to Format on the Menu bar and select Rows or Columns.
3) Select Show in the submenu. Alternatively, right-click on a row or column header and
select Show Rows or Show Columns in the context menu.

Deleting columns or rows
1) Select the columns or rows you want to delete.
2) Go to Sheet on the Menu bar and select Delete Rows or Delete Columns, or right-click
on the column or row header and select Delete Columns or Delete Rows in the context
menu.

Deleting cells
1) Select the cells you want to delete.
2) Go to Sheet > Delete Cells, or press Ctrl+-. Or, right-click on a cell and select Delete in
the context menu.
3) Select the option you require from the Delete Cells dialog (Figure 106) and click OK.

Figure 106: Delete Cells dialog
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Working with sheets
Inserting new sheets
Click on the Add Sheet (+) icon next to the sheet tabs to insert a new sheet after the last sheet in
the spreadsheet without opening the Insert Sheet dialog.
The following methods open the Insert Sheet dialog (Figure 107), where you can position the
new sheet, create more than one sheet, name the new sheet, or select a sheet from a file.
•

Select the sheet where you want to insert a new sheet, then go to Sheet > Insert Sheet
on the Menu bar.

•

Right-click on the sheet tab where you want to insert a new sheet and select Insert
Sheet in the context menu.

•

Click in the empty space at the end of the sheet tabs.

•

Right-click in the empty space at the end of the sheet tabs and select Insert Sheet in the
context menu.

Figure 107: Insert Sheet dialog

Moving and copying sheets
You can move or copy sheets within the same spreadsheet by dragging and dropping, or by
using the Move/Copy Sheet dialog. To move or copy a sheet into a different spreadsheet, you
have to use the Move/Copy Sheet dialog.
In the Move/Copy Sheet dialog (Figure 108), you can specify exactly whether you want the sheet
in the same or a different spreadsheet, its position within the spreadsheet, and the sheet name
when you move or copy it.
1) In the current document, right-click on the sheet tab you wish to move or copy and select
Move or Copy Sheet in the context menu, or go to Sheet > Move or Copy Sheet on the
Menu bar.
2) In the Action area, select Move to move the sheet or Copy to copy the sheet.
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Figure 108: Move/Copy Sheet dialog
3) Select the spreadsheet where you want the sheet to be placed in the drop-down list in To
document. This can be the same spreadsheet, another spreadsheet already open, or a
new spreadsheet.
4) Select the position in Insert before where you want to place the sheet.
5) Type a name in the New name box if you want to rename the sheet when it is moved or
copied. If you do not enter a name, Calc creates a default name (Sheet2, Sheet3, ...).
6) Click OK to confirm the move or copy and close the dialog.

Caution
When you move or copy to another spreadsheet or a new spreadsheet, a conflict
may occur with formulas linked to other sheets in the previous location.

Hiding and showing sheets
Sometimes you may want to hide the contents of a sheet to preserve data from accidental editing
or because its contents are not important to display.
To hide a sheet or many sheets, select the sheet or sheets as above, right-click to open the
context menu, and select Hide Sheet.
To show hidden sheets, right-click any sheet tab and select Show Sheet in the context menu. A
dialog will open with all hidden sheets listed. Select the desired sheets and then click OK. It is not
possible to hide the last visible sheet.
For more information on how to hide and show data, including how to use outline groups and
filtering, see Chapter 2, Entering, Editing, and Formatting Data, in the Calc Guide.
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Note
Hidden elements are neither visible on a computer display nor printed when a
spreadsheet is printed. However, they can still be selected for copying if you select
the elements around them. For example, if column B is hidden, it is copied when you
select columns A to C. When you require a hidden element again, you can reverse
the process and show the element.

Renaming sheets
By default, the name for each new sheet added is SheetX, where X is the sequential number of
the next sheet to be added. While this works for a small spreadsheet with only a few sheets, it
can become difficult to identify each one when a spreadsheet contains many sheets.
To rename a sheet, use one of these methods:
•

Enter the name in the Name text box when you create the sheet using the Insert Sheet
dialog (Figure 107 on page 142).

•

Right-click on a sheet tab and select Rename Sheet in the context menu to replace the
existing name with a different one.

•

Double-click on a sheet tab to open the Rename Sheet dialog.

Note
Sheet names must start with either a letter or a number; other characters, including
spaces, are not allowed. Apart from the first character of the sheet name, permitted
characters are letters, numbers, spaces, and the underscore character. Attempting to
rename a sheet with an invalid name will produce an error message.

Deleting sheets
To delete a single sheet, right-click on the sheet tab you want to delete and select Delete Sheet
in the context menu, or go to Sheet > Delete Sheet on the Menu bar. Click Yes to confirm the
deletion.
To delete multiple sheets, select the sheets (see “Selecting sheets” on page 140), then right-click
on one of the sheet tabs and select Delete Sheet in the context menu, or go to Sheet > Delete
Sheet on the Menu bar. Click Yes to confirm the deletion.

Viewing a spreadsheet
Changing document view
Use the zoom function (View > Zoom) to show more or fewer cells in the window when you are
working on a spreadsheet. For more about zoom, see Chapter 1, Introducing LibreOffice.

Freezing rows and columns
Freezing is used to lock rows across the top of a spreadsheet or to lock columns on the left of a
spreadsheet. Then, when moving around within a sheet, the cells in frozen rows and columns
remain in view.
Figure 109 shows some frozen rows and columns. The heavier horizontal line between rows 3
and 23 and the heavier vertical line between columns F and Q indicate that rows 1 to 3 and
columns A to F are frozen. The rows between 3 and 23 and the columns between F and Q have
been scrolled off the page.
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Figure 109: Frozen rows and columns
Often the first row and column contain headings, which you may wish to be visible when scrolling
through a long or wide spreadsheet. To quickly freeze either or both of these, use the Freeze
Rows and Columns icon on the Standard toolbar for both, or the commands in the drop-down
menu of the Freeze Rows and Columns icon: Freeze First Row and Freeze First Column for
one of them.
To freeze either rows or columns (single or multiple):
1) Click on the row header below the rows you want the freeze or click on the column
header to the right of the columns where you want the freeze.
2) Right-click and choose Freeze Rows and Columns in the context menu, or choose View
> Freeze Rows and Columns on the Menu bar, or click the Freeze Rows and Columns
icon on the Standard toolbar.
To freeze both rows and columns (single or multiple):
1) Click in the cell that is immediately below the rows you want to freeze and immediately to
the right of the columns you want frozen.
2) Choose View > Freeze Rows and Columns on the Menu bar, or click the Freeze Rows
and Columns icon on the Standard toolbar.

Unfreezing
To unfreeze rows or columns, either use View > Freeze Rows and Columns on the Menu bar,
or click on the Freeze Rows and Columns icon on the Standard toolbar. The heavier lines
indicating freezing will disappear.

Splitting the screen
Another way to change the view is by splitting the screen your spreadsheet is displayed in (also
known as splitting the window). The screen can be split horizontally, vertically, or both, giving you
up to four portions of the spreadsheet in view at one time. An example of splitting the screen is
shown in Figure 110, where a split is indicated by additional window borders within the sheet.
This could be useful, for example, when a large spreadsheet has one cell containing a number
that is used by three formulas in other cells. By splitting the screen, you can position the cell
containing the number in one section of the view and the cells with formulas in other sections.
This makes it easy to see how changing the number in one cell affects each of the formulas.

Figure 110: Split screen example
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Splitting horizontally or vertically
There are two ways to split a screen horizontally or vertically.
Method 1
To split either horizontally or vertically:
1) Click on the row header below the rows where you want to split the screen horizontally or
click on the column header to the right of the columns where you want to split the screen
vertically.
2) Right-click and choose Split Window in the context menu, or choose View > Split
Window on the Menu bar. Window borders appear between the rows or columns
indicating where the split has been placed, as shown in Figure 110.
To split both horizontally and vertically at the same time:
1) Click in the cell that is immediately below the rows where you want to split the screen
horizontally and immediately to the right of the columns where you want to split the
screen vertically.
2) Choose View > Split Window on the Menu bar.
Method 2
For a horizontal split, click on the thick black line at the top of the vertical scroll bar (Figure 111)
and drag the split line below the row where you want the horizontal split positioned.
Similarly, for a vertical split, click on the thick black line at the right of the horizontal scroll bar and
drag the split line to the right of the column where you want the vertical split positioned.

Figure 111. Split screen bars

Removing split views
To remove a split view, do one of the following:
•

Double-click on each split line.

•

Click and drag the split lines back to their default positions at the ends of the scroll bars.

•

Go to View on the Menu bar and deselect Split Window.

•

Right-click on a column or row heading and deselect Split Window in the context menu.

Entering data using the keyboard
Most data entry in Calc can be done using the keyboard.

Numbers
Click in the cell and type the number using the number keys on either the main keyboard or the
numeric keypad. By default, numbers are right-aligned in a cell.
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Negative numbers
To enter a negative number, either type a minus (–) sign in front of the number or enclose the
number in parentheses, for example (1234). The result for both methods of entry will be the
same; in this example, –1234.

Leading zeroes
If a number is entered with leading zeroes, for example 01481, by default Calc will drop the
leading zero. To retain a minimum number of characters in a cell when entering numbers and
retain the number format, for example 1234 and 0012, use one of these methods to add leading
zeroes.
Method 1
1) With the cell selected, right-click on the cell, select Format Cells in the context menu, or
go to Format > Cells on the Menu bar, or use the keyboard shortcut Ctrl+1, to open the
Format Cells dialog (Figure 112). Make sure the Numbers tab is selected, then select
Number in the Category list.
2) In the Leading zeroes field within the Options area, enter the minimum number of
characters required. For example, for four characters, enter 4. Any number less than four
characters will have leading zeroes added, for example 12 becomes 0012.
3) Click OK. The number entered retains its number format and any formula used in the
spreadsheet will treat the entry as a number in formula functions.

Figure 112: Format Cells dialog – Numbers tab
Chapter 5, Getting Started with Calc | 147

Method 2
1) Select the cell.
2) On the Sidebar, go to the Properties deck.
3) In the Number Format panel (Figure 113), select Number in the drop-down list, and enter
4 in the Leading zeroes box. Formatting is applied immediately.

Figure 113: Set leading zeroes in Sidebar

Tip
To format numbers with only decimal places, but without a leading zero (for example,
.019 instead of 0.019), type a . (period or full stop) followed by ? (question mark) in
the Format code box (Figure 112), to represent the number of decimal places
required. For example, for 3 decimal places, type .??? and click OK. Any number
with only decimal places will then have no leading zero.

Tip
If numerical characters do not need to be treated as numbers in calculations (for
example when entering zip codes), you can type an apostrophe (') before the
number, for example '01481. When you move the cell focus, the apostrophe is
removed, the leading zeroes are retained, and the number is converted to leftaligned text.

Numbers as text
Numbers can also be entered as text using one of the following methods.
Method 1
1) With the cell selected, right-click on the cell and select Format Cells in the context menu,
or go to Format > Cells on the Menu bar, or use the keyboard shortcut Ctrl+1, to open
the Format Cells dialog (Figure 112).
2) Make sure the Numbers tab is selected, then select Text in the Category list.
3) Click OK. The number is converted to text and, by default, left-aligned.
Method 2
1) Select the cell.
2) On the Sidebar, go to the Properties deck. If necessary, click the Open Panel icon (+ or
arrow) by Number Format to open that panel (Figure 113).
3) Select Text in the category drop-down list. Formatting is applied to the cell immediately.
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Note
By default, any numbers that have been formatted as text in a spreadsheet will be
treated as a zero by any formulas used in the spreadsheet. Formula functions will
ignore text entries. You can change this feature in Tools > Options > LibreOffice
Calc > Formula. In Detailed Calculation Settings, select Custom (conversion of
text to numbers and more). Click the Details button, and then select the proper
treatment in the Detailed Calculation Settings dialog.

Text
Click in the cell and type the text. By default, text is left-aligned in a cell. Cells can contain several
lines of text. If you want to use paragraphs, press Ctrl+Enter to create another paragraph.
On the Formula bar, you can extend the Input line if you are entering several lines of text. Click
on the Expand Formula Bar icon located on the right-hand end of the Formula bar and the Input
line becomes multi-line.

Date and time
Select the cell and type the date or time. You can separate the date elements with a slash (/) or a
hyphen (–), or use text, for example 10 Oct 2020. The date format automatically changes to the
selected format used by Calc.
When entering a time, separate time elements with colons, for example 10:43:45. The time
format automatically changes to the selected format used by Calc.
To change the date or time format used by Calc:
1) With the cell selected, open the Format Cells dialog (Figure 112).
2) Make sure the Numbers tab is selected, then select Date or Time in the Category list.
3) Select the date or time format you want to use in the Format list. Click OK.

Cell fields
You can insert a field linked to the date, sheet name, or document name in a cell.
1) Select a cell and double-click to activate edit mode.
2) Right-click and select Insert Field > Date, or Sheet Name, or Document Title in the
context menu.
Above those three options are other Date and Time buttons, which will insert the same
information but it will not be updated or recalculated as the options mentioned above.

Note
The Insert Field > Document Title command inserts the name of the spreadsheet
and not the title defined in the Description tab in the Properties dialog for the file.

Tip
The fields are refreshed when the spreadsheet is saved or recalculated when using
the Ctrl+Shift+F9 shortcut.
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AutoCorrect Options
Calc automatically applies many changes during data input using AutoCorrect, unless you have
deactivated any AutoCorrect changes. You can also undo any AutoCorrect changes by using
Edit > Undo on the Menu bar, pressing the keyboard shortcut Ctrl+Z, or manually by going back
to the change and replacing the AutoCorrection with what you want to actually see.
To change the AutoCorrect options, go to Tools > AutoCorrect Options on the Menu bar to
open the AutoCorrect dialog (Figure 114).
Replace tab
Edit the replacement table for automatically correcting or replacing words or abbreviations.
Exceptions tab
Specify the abbreviations or letter combinations that you do not want corrected
automatically.
Options tab
Select the options for automatically correcting errors as you type.
Localized Options tab
Specify the AutoCorrect options for quotation marks and for options that are specific to the
language of the text.
Reset button
Reset modified values back to their previous values.

Figure 114: AutoCorrect dialog
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Deactivating automatic changes
Some AutoCorrect settings are applied when you press the space bar after you enter data. To
turn off or on Calc AutoCorrect, go to Tools on the Menu bar and deselect or select AutoInput.
See also “AutoInput tool” below.

Speeding up data entry
Entering data into a spreadsheet can be very labor-intensive, but Calc provides several tools for
removing some of the drudgery from input.
The most basic ability is to drag and drop the contents of one cell to another with a mouse. Many
people also find AutoInput helpful. Calc also includes several other tools for automating input,
especially of repetitive material. They include the Fill tool, selection lists, and the ability to input
information into multiple sheets of the same document.

AutoInput tool
The AutoInput tool in Calc automatically completes entries, based on other entries in the same
column. When text is highlighted in a cell, AutoInput can be used as follows:
1) To accept the completion, press Enter or F2, or click the left mouse button.
2) To view more completions that start with the same characters, use the key combinations
Ctrl+Tab to scroll forward, or Ctrl+Shift+Tab to scroll backward.
3) To see a list of all available AutoInput text items for the current column, use the keyboard
combination Alt+Down Arrow.
When typing formulas using characters that match previous entries, a Help tip will appear listing
the available functions that start with matching characters. AutoInput ignores the case sensitivity
of any data you enter.
By default, AutoInput is activated in Calc. To turn it off, go to Tools on the Menu bar and deselect
AutoInput.

Fill tool
You can use the Fill tool to duplicate existing content or create a series in a range of cells (Figure
115).
1) Select the cell containing the contents you want to copy or start the series from.
2) Drag the cursor in any direction or hold down the Shift key and click in the last cell you
want to fill.
3) Go to Sheet > Fill Cells on the Menu bar and select the direction in which you want to
copy or create data (Fill Up, Fill Down, Fill Left, or Fill Right), or Fill Series, or Fill
Random Number in the submenu.

Tip
You can use the keyboard shortcut Ctrl+D as an alternative to selecting Sheet > Fill
Cells > Fill Down on the Menu bar.
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Figure 115: Using the Fill tool
Alternatively, you can use a shortcut to fill cells.
1) Select the cell containing the contents you want to copy or start the series from.
2) Move the cursor over the small square in the bottom right corner of the selected cell. The
cursor will change shape.
3) Click and drag in the direction you want the cells to be filled. If the original cell contained
text, then the text will automatically be copied. If the original cell contained a number, a
series will be created.

Caution
When you are selecting cells so you can use the Fill tool, make sure that none of the
cells contain data, except for the cell data you want to use. When you use the Fill
tool, any data contained in the selected target cells is overwritten.

Using a fill series
When you select a series fill from Sheet > Fill Cells > Fill Series, the Fill Series dialog (Figure
116) opens. Here you can select the type of series you want.

Figure 116: Fill Series dialog
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Defining a fill series
If you select the AutoFill option on the Fill Series dialog, type some text in the Start value field,
and press OK, Calc will check if one of your predefined sort lists contains that text. If there is a
sort list containing that text, Calc uses the entries in that sort list to fill cells. Go to Tools >
Options > LibreOffice Calc > Sort Lists to view your currently defined sort lists.
To define your own sort list, which can later be used as a fill series:
1) Go to Tools > Options > LibreOffice Calc > Sort Lists to open the Sort Lists dialog
(Figure 117). This dialog shows the previously-defined series in the Lists box and the
contents of the highlighted list in the Entries box.
2) Click New and the Entries box is cleared.
3) Type the series for the new list in the Entries box (one entry per line).
4) Click Add and the new list will now appear in the Lists box.
5) Click OK to save the new list.

Selection lists
Selection lists are available only for text and are limited to using only text that has already been
entered in the same column.
1) Select a blank cell in a column that contains cells with text entries.
2) Right-click and select Selection Lists in the context menu, or press Alt+Down Arrow. A
drop-down list appears listing any cell in the same column that either has at least one text
character or whose format is defined as text.
3) Click on the text entry you require and it is entered into the selected cell.

Figure 117: Sort Lists dialog
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Sharing content between sheets
You might want to enter the same information in the same cell on multiple sheets, for example to
set up standard listings for a group of individuals or organizations. Instead of entering the list on
each sheet individually, you can enter the information in several sheets at the same time.
1) Go to Edit > Select > Select Sheets on the Menu bar to open the Select Sheets dialog.
2) Select the individual sheets where you want the information to be repeated.
3) Click OK to select the sheets and the sheet tabs will change color.
4) Enter the information in the cells on the first sheet where you want it to appear and it will
be repeated in all the selected sheets.

Caution
This technique automatically overwrites, without any warning, any information that is
already in the cells on the selected sheets. Make sure you deselect the additional
sheets when you are finished entering information that is going to be repeated before
continuing to enter data into the spreadsheet.

Validating cell contents
When creating spreadsheets for other people to use, you may wish to ensure that they enter data
that is valid and appropriate for the cell. You can also use validation in your own work as a guide
to entering data that is either complex or rarely used.
Fill series and selection lists can handle some types of data, but are limited to predefined
information. To validate new data entered by a user, select a cell and go to Data > Validity on the
Menu bar to define the type of contents that can be entered in that cell. For example, a cell may
require a date or a whole number with no alphabetic characters or decimal points, or a cell may
not be left empty.
Depending on how validation is set up, it can also define the range of contents that can be
entered, provide help messages explaining the content rules set up for the cell and what users
should do when they enter invalid content. You can also set the cell to refuse invalid content,
accept it with a warning, or start a macro when an error is entered. See Chapter 2, Entering,
Editing, and Formatting Data, in the Calc Guide for more information.

Editing data
Deleting data
Deleting data only
To delete only the data in a cell or range of cells, without deleting any of the cell formatting, select
the cells and then press the Delete key.
To completely delete cells, rows, or columns, see the instructions on page 141.

Deleting data and formatting
Data and cell formatting can be deleted from a cell at the same time. To do this:
1) Select a cell or a range of cells.
2) Press the Backspace key, or right-click in the cell selection and choose Clear Contents in
the context menu, or select Sheet > Clear Cells on the Menu bar.
3) In the Delete Contents dialog (Figure 118), choose any of the options or Delete all.
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4) Click OK.

Figure 118: Delete Contents dialog

Replacing data
To completely replace data in a cell and insert new data, select the cell and type in the new data.
The new data will replace the old data but will retain the cell formatting.
Alternatively, select the cell and click in the Input line on the Formula bar (Figure 89 on page
128), then double-click on the data to highlight it completely and type the new data.

Changing data
Sometimes it is necessary to edit the contents of a cell without removing all of the data from the
cell. For example, changing the phrase “Sales in Qtr. 2” to “Sales rose in Qtr” can be done as
follows.

Using the keyboard
1) Click in the cell to select it.
2) Press F2 to switch the cell to edit mode. The cursor is placed at the end of the content in
the cell.
3) Use the keyboard arrow keys to position the cursor where you want to start entering the
new data in the cell, then press the Delete key or Backspace key to delete any unwanted
data before typing the new data.
4) When you have finished editing, press the Enter key to save the changes.

Tip
You may want to enable Tools > Options > LibreOffice Calc > General > Press
enter to switch to edit mode. Then, when you press the Enter key in a selected
cell, the cell switches to edit mode, eliminating the need to press F2.

Using the mouse
1) Double-click on the cell to select it and place the cursor in the cell for editing. You can
also use Edit > Cell Edit Mode on the Menu bar to put the cell in edit mode.
2) Either:
– Reposition the cursor to where you want to start entering the new data in the cell.
– Single-click to select the cell, then move the cursor to the Input line on the Formula
bar and click at the position where you want to start editing data in the cell.
3) When you have finished, click away from the cell to deselect it and save the changes.
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Paste Special function
To copy text, numbers, or formulas to the target cell or cell range:
1) Select the source cell or cell range and copy the data by pressing Ctrl+C or using Edit >
Copy on the Menu bar.
2) Select the target cell or cell range.
3) Right-click on the target cell or cell range and select Paste Special in the context menu,
then select Unformatted Text, Text, Number, or Formula.
Or, use the submenu items reached from Edit > Paste Special on the Menu bar.
You can also use the Paste Special function to paste into another cell selected parts of the data
in the original cell or cell range, for example its format or the result of its formula. To do this:
1) Select a cell or a cell range.
2) Go to Edit > Copy on the Menu bar, or press Ctrl+C, or right-click and select Copy in the
context menu.
3) Select the target cell or cell range.
4) Go to Edit > Paste Special > Paste Special on the Menu bar, or use the keyboard
shortcut Ctrl+Shift+V, or right-click and select Paste Special > Paste Special in the
context menu to open the Paste Special dialog (Figure 119).
5) In the preset buttons on the left side of the dialog, you can choose to paste Values Only,
Values & Formats, Formats Only, or to Transpose All the data in the target cells. On
the right side of the dialog, select the options for Paste, Options, Operations, and Shift
Cells. These are described in the Help and in Chapter 2, Entering, Editing, and
Formatting Data, of the Calc Guide.
6) Click OK to paste the data into the target cell or range of cells and close the dialog.

Figure 119: Paste Special dialog
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Tip
To see which combination of options on the right side would apply if one of the
Preset buttons is selected, deselect the Run immediately option below the Presets.
With the Run immediately option selected, clicking on a Preset button applies that
combination of options and closes the dialog.

Formatting data
Note
All the settings discussed in this section can also be set as a part of the cell style.
See Chapter 4, Using Styles and Templates, in the Calc Guide for more information.

Multiple lines of text
Multiple lines of text can be entered into a single cell using automatic wrapping or manual line
breaks. Each method is useful for different situations.

Automatic wrapping
To automatically wrap multiple lines of text in a cell, use one of the following methods.
Method 1
1) Right-click on the cell and select Format Cells in the context menu to open the Format
Cells dialog.
2) On the Alignment tab (Figure 120), under Properties, select Wrap text automatically and
click OK.

Figure 120: Format Cells dialog – Alignment tab

Chapter 5, Getting Started with Calc | 157

Method 2
1) Select the cell.
2) On the Properties deck of the Sidebar, open the Alignment panel (Figure 121).
3) Select the Wrap text option to apply the formatting immediately.

Figure 121: Wrap text formatting

Manual line breaks
To insert a manual line break while typing in a cell, press Ctrl+Enter. When editing text, doubleclick the cell, then reposition the cursor to where you want the line break. In the Input line of the
Formula bar, you can also press Shift+Enter.
When a manual line break is entered in a cell, the cell row height changes but the cell width does
not change and the text may still overlap the end of the cell. You have to change the cell width
manually or reposition the line break.

Shrinking text to fit the cell
The font size of the data in a cell can automatically adjust to fit inside cell borders. To do this,
select the Shrink to fit cell size option under Properties on the Alignment tab of the Format
Cells dialog (Figure 120).

Merging cells
You can select contiguous cells and merge them into one as follows:
1) Select the range of contiguous cells you want to merge.
2) Right-click on the selected cells and select Merge Cells in the context menu, or go to
Format > Merge Cells > Merge Cells or Merge and Center Cells on the Menu bar, or
click on the Merge and Center Cells icon on the Formatting toolbar. Using Merge and
Center Cells will center align any contents in the cells.
3) If the cells contain any data, a small dialog (Figure 122) opens, showing choices for
moving or hiding data in the hidden cells. Make your selection and click OK.

Caution
Merging cells can lead to calculation errors in formulas used in the spreadsheet.
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Figure 122: Merge choices for non-empty cells

Splitting cells
You can split a cell that was created from several cells by merging.
1) Select a merged cell.
2) Go to Format > Merge Cells > Split Cells on the Menu bar, or right-click and select Split
Cells in the context menu, or click on the Merge and Center Cells icon on the
Formatting toolbar.
3) Any data in the cell will remain in the first cell. If the hidden cells did have any contents
before the cells were merged, then you have to manually move the contents in to the
correct cell.

Formatting numbers
Several number formats can be applied to cells by using icons on the Formatting toolbar. Select
the cell, then click the relevant icon to change the number format.
For more control or to select other number formats, use the Numbers tab of the Format Cells
dialog (Figure 112 on page 147):
•

Apply any of the data types in the Category list to the data.

•

Control the number of decimal places and leading zeroes in the Options area.

•

Enter a custom format code.

•

The Language setting controls the local settings for the different formats such as the date
format and currency symbol.

Some number formats are available on the sidebar’s Number Format panel of the Properties
deck. Click the More Options button to open the Format Cells dialog.

Formatting fonts and text in cells
Tip
For consistency in a spreadsheet, use cell styles whenever possible.
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To manually select a font and format text for use in a cell:
1) Select a cell or cell range.
2) Click the small triangle on the right of the Font Name box on the Formatting toolbar and
select a font in the drop-down list, or use the Font Name box in the Character panel of the
Properties deck on the Sidebar.
3) Click on the small triangle on the right of the Font Size box on the Formatting toolbar and
select a font size in the drop-down list, or use the Font Size box in the Character panel of
the Properties deck on the Sidebar.
4) To change the character format, click on the Bold, Italic, or Underline icons on the
Formatting toolbar or on the Character panel of the Properties deck of the Sidebar. On
the Sidebar it is possible to change the underline appearance and add some extra effects
to the font, such as Strikethrough and Shadow.
5) To change the horizontal paragraph alignment, click on one of the four alignment icons
(Align Left, Align Center, Align Right, Justified) on the Formatting toolbar or on the
Alignment panel of the Properties deck on the Sidebar. For more options, go to Format >
Cells > Alignment and select one of the options in the Horizontal drop-down list.
6) To change the vertical alignment of the text in the cell, go to Format > Cells > Alignment
and select one of the options in the Vertical drop-down list.
7) To change the font color, click the arrow next to the Font Color icon on the Formatting
toolbar, or on the Character panel on the Properties deck of the Sidebar, to display the
color palette, then select the desired color.
8) To specify the language used in the cell, use the Font tab on the Format Cells dialog.
9) Use the Font Effects tab on the Format Cells dialog to set other font characteristics.

Formatting cell borders
To format the borders of a cell or a group of selected cells, click the Borders icon on the
Formatting toolbar and select a border from the palette.
To format the border line style, click the Border Style icon on the Formatting toolbar and select
the line style in the palette. For the color of the border lines, click the arrow at the right of the
Border Color icon on the Formatting toolbar and choose from the selected color palette.
The Cell Appearance panel of the Properties deck on the Sidebar also contains cell border, line
style and line color controls.
For more control, including the spacing between cell borders and any data in the cell, use the
Borders tab of the Format Cells dialog, where you can also define a shadow style. Clicking the
More Options button on the Cell Appearance panel, or clicking More Options in the panel’s line
style drop-down list, opens the Format Cells dialog at the Borders tab.
See Chapter 4, Using Styles and Templates, in the Calc Guide for more information.

Note
Cell border properties apply only to the selected cells and can be changed only when
you are editing those cells. For example, if cell C3 has a top border, that border can
only be removed by selecting C3. It cannot be removed in C2 despite also appearing
to be the bottom border for cell C2.
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Formatting cell background
To format the background color for a cell or a group of cells, click the small arrow next to the
Background Color icon on the Formatting toolbar. A color palette, similar to the Font Color
palette, is displayed. You can also use the Background tab of the Format Cells dialog. The Cell
Appearance panel of the Properties deck on the Sidebar contains a cell background control with
a color palette. See Chapter 4, Using Styles and Templates, in the Calc Guide for more
information.

Formatting default cell styles
To add default styles for a cell or a group of cells, click Styles on the Menu bar and a menu
displays the default styles. The default styles can be applied, or modified in the Styles deck on
the Sidebar. You can create custom cell styles by clicking Styles > New Style from Selection on
the Menu bar, or by clicking the New Style from Selection icon on the Styles deck of the
Sidebar, or by right-clicking a style in the Styles deck of the Sidebar and selecting New in the
context menu. Type a new name for the style or click an existing style name to update that style.
Apply, delete, or modify the custom style on the Styles deck.

AutoFormatting of cells
Using AutoFormat
You can use Calc’s AutoFormat feature to format a table (range of cells) quickly and easily. It also
lets you format different tables of the sheet with the same look and feel very easily. All formatting
applied is direct formatting.
1) Select the cells in at least three columns and rows, including column and row headers,
that you want to format.
2) Go to Format > AutoFormat Styles on the Menu bar to open the AutoFormat dialog
(Figure 123).
3) Select the type of format and format color in the list.
4) Select the formatting properties to be included in the AutoFormat style. Click OK.

Figure 123: AutoFormat dialog
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Defining a new AutoFormat
You can define a new AutoFormat so that it becomes available for use in all spreadsheets.
1) Format the data type, font, font size, cell borders, cell background, and so on for a range
of cells.
2) Select the range, of at least 4 x 4 cells.
3) Go to Format > AutoFormat Styles to open the AutoFormat dialog. Click Add.
4) In the Name box of the Add AutoFormat dialog that opens, type a meaningful name for
the new format.
5) Click OK to save. The new AutoFormat is now available in the Format list in the
AutoFormat dialog.

Note
The new AutoFormat is stored in your computer user profile and is not available to
other users. However, other users can import the new AutoFormat by selecting the
table range in the spreadsheet document and defining it as a new AutoFormat.

Using themes
Calc comes with a predefined set of formatting themes (set of styles) that you can apply to
spreadsheets. It is not possible to add new themes to Calc, but you can modify the theme styles
after the theme is applied to the spreadsheet. The modified styles are available for use only in
that spreadsheet.
To apply a theme to a spreadsheet:
1) Go to Format > Spreadsheet Theme on the Menu bar or click the Spreadsheet Theme
icon on the Tools toolbar to open the Theme Selection dialog (Figure 124).
2) Select the theme that you want to apply. The theme styles are immediately visible on the
underlying spreadsheet.
3) Click OK.
If you wish, you can now open the Styles deck on the Sidebar to modify specific styles. These
changes do not modify the theme; they only change the appearance of the style in the specific
spreadsheet you are using. For more about modifying styles, see Chapter 3, Using Styles and
Templates.

Caution
Applying a new theme over an existing one will override all existing theme styles
customization with the new theme styles.
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Figure 124: Theme Selection dialog

Using conditional formatting
You can set up cell formats to change depending on conditions that you specify. For example, in
a table of numbers, you can show all the values above the average in green and all those below
the average in red. Multiple formatting options can be entered and arranged using assigned
priority rules to order the importance of the conditions, allowing certain formatting options to take
place before others.
Conditional formatting depends upon the use of styles, and the AutoCalculate feature (Data >
Calculate > AutoCalculate) must be enabled. See Chapter 2, Entering, Editing, and Formatting
Data, in the Calc Guide for details.

Filtering data
A filter is a list of conditions that each entry has to meet to be displayed. Calc provides three
types of filter:
Standard – Specifies the logical conditions to filter the data. It allows filtering by text color
or background color.
AutoFilter – Filters data according to a specific value or string. Automatically filters the
selected cell range and adds list boxes to the top row, where you can choose the items that
you want to display.
Advanced – Uses filter criteria from specified cells.
Setting up and using filters are explained in Chapter 2, Entering, Editing, and Formatting Data, of
the Calc Guide.
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Cell protection
All or some of the cells in a spreadsheet can be password protected to prevent changes being
made by unauthorized users. This can be useful when multiple people have access to the
spreadsheet itself, but only a few are allowed to modify the data it contains. Protected cells can
optionally be hidden.
Use the Cell Protection tab of the Format Cells dialog (Figure 125) to set up cell protection and
toggle the hidden status of protected cells.

Figure 125: Cell Protection tab in Format Cells dialog
When all desired cells have been flagged with either a protected or unprotected status:
1) Go to Tools > Protect Sheet, or right-click on the sheet’s tab in the Sheet tabs area and
select Protect Sheet in the context menu. The Protect Sheet dialog opens (Figure 126).
2) Select Protect this sheet and the contents of protected cells.
3) Type a password and then confirm the password.
4) Select or deselect the user selection options for cells.
5) Click OK.

Figure 126: Protect Sheet dialog
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Any cells that had been toggled as protected will no longer be editable by anyone that does not
have the password.
The protected sheet has a lock icon in its tab, as shown in Figure 127.

Figure 127: The lock icon in a
protected sheet
Alternatively, you can protect the structure of the entire spreadsheet rather than individual cells
on individual sheets by selecting Tools > Protect Spreadsheet Structure on the Menu bar. This
option enables you to protect your spreadsheet against adding, deleting, moving, or renaming
sheets. You can optionally enter a password on the Protect Spreadsheet Structure dialog.

Sorting records
Sorting within Calc arranges the cells in a sheet using the sort criteria that you specify. Several
criteria can be used and a sort applies each criteria consecutively. Sorts are useful when you are
searching for a particular item and become even more useful after you have filtered data.
Also, sorting is useful when you add new information to your spreadsheet. When a spreadsheet
is long, it is usually easier to add new information at the bottom of the sheet, rather than adding
rows in their correct place. After you have added information, you can then sort the records to
update the spreadsheet.
For more information on how to sort records and the sorting options available, see Chapter 2,
Entering, Editing, and Formatting Data, in the Calc Guide.
To sort cells in a spreadsheet using the Sort dialog:
1) Select the cells to be sorted.
2) Go to Data > Sort on the Menu bar, or click the Sort icon on the Standard toolbar, to
open the Sort dialog (Figure 128).

Figure 128: Sort dialog, Sort Criteria tab
3) On the Sort Criteria tab, select the sort criteria in the drop-down lists. The selected lists
are populated from the selected cells.
4) Select either ascending order (A-Z, 0-9) or descending order (Z-A, 9-0).
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5) Adjust the settings as required on the Options tab. For details, see the Help or Chapter 2,
Entering, Editing, and Formatting Data, of the Calc Guide.
6) Click OK and the sort is carried out on the spreadsheet.

Cell comments
Comments are small notes and text that can serve as a reminder or an aside to the user. A
comment is not considered a part of the spreadsheet for calculation or printing purposes, and will
only appear when hovering the mouse over the particular cell that has been commented.
The easiest way to insert a comment is by right-clicking on the desired cell and selecting Insert
Comment in the context menu. Alternatively, you can select Insert > Comment on the Menu bar,
or use Ctrl+Alt+C, or click the Insert Comment icon on the Standard toolbar.
By default, comments will remain hidden and only appear when hovering the mouse. Cells that
contain comments are marked with a red square in the upper right corner. To toggle the visibility
of comments, select View > Comments on the Menu bar.
For more information, see Chapter 11, Sharing and Reviewing Spreadsheets, in the Calc Guide.

Using formulas and functions
You may need more than numbers and text in a spreadsheet. Often the contents of one cell
depend on the contents of other cells. Formulas are equations that use numbers and variables to
produce a result. Variables are placed in cells to hold data required by equations.
A function is a predefined calculation entered in a cell to help you analyze or manipulate data. All
you have to do is enter the arguments and the calculation is made automatically. Functions help
you create the formulas required to get the results that you are looking for.

Creating formulas
Functions and formulas can be entered directly into the Formula bar or by accessing the Function
Wizard. To launch the function wizard, click the Function Wizard icon to the right of the Name
Box, or select Insert > Function on the Menu bar, or press Ctrl+F2.
Inside the Function Wizard, you can search, list, and narrow down the many Calc functions
available. You can also choose to complete functions from within the wizard rather than having to
type full formulas into the Formula bar.
Each function, when selected, will display a brief explanation of its use and acceptable syntax. It
will also display dialog boxes where you can enter the information required by that function and a
result window showing the expected calculation from the data entered.

Note
A fast alternative to the Function Wizard is the Functions deck on the Sidebar, where
you can quickly list and narrow down functions. It provides brief explanations on their
use and syntax, but does not provide the search or data entry capabilities of the full
wizard.
LibreOffice Calc offers powerful built-in functions under multiple domains or categories. They are:
Database, Date & Time, Financial, Information, Logical, Mathematical, Array, Statistical,
Spreadsheet, Text, and Add-in functions.
For a more in-depth introduction to formulas and the Function Wizard, see Chapter 7, Using
Formulas and Functions, in the Calc Guide.
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Figure 129: Function Wizard

Analyzing data
Calc includes several tools to help you analyze the information in your spreadsheets, ranging
from features for copying and reusing data, to creating subtotals automatically, to varying
information to help you find the answers you need. These tools are divided between the Tools
and Data menus.
Calc also includes many tools for statistical analysis of data, where you can obtain important
numerical information on data obtained from physical measurements, polls, or even business
transactions such as sales, stock quotations, and so on. These statistical data analyses are
available in the menu Data > Statistics.
See Chapter 9, Data Analysis, in the Calc Guide for more information on the tools available.

Pivot tables and pivot charts
One of the most useful tools for analyzing data is the pivot table, a way to organize, manipulate,
and summarize large amounts of data to make it much easier to read and understand while also
allowing you to answer different questions about a spreadsheet by rearranging – or pivoting – the
data in it. Using a pivot table, you can view different summaries of the source data, display the
details of areas of interest, and create reports. You can also create a pivot chart to view a
graphical representation of the data in a pivot table.
For example, you might have a spreadsheet containing a list of donations to various charities by
a group of recruiters in various months, but you are only interested in how much money each
recruiter has collected in total. You could manually calculate that amount by using the sorting and
formatting options provided by Calc. Alternatively, you could arrange a pivot table to make that
data easier to organize and read.
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To create a pivot table, choose Data > Pivot Table > Insert or Edit on the Menu bar, or click the
Insert or Edit Pivot Table icon on the Standard toolbar. The Pivot Table Layout dialog will
intelligently guess the column headings from the provided raw data and insert them into the
Available Fields selection box. From there, you can drag and drop your desired information into
column, row, data, or filter fields to organize accordingly and click OK to view the results.
To choose new information to display, or to alter the layout of the existing information, right-click
anywhere in the existing pivot table to bring up the context menu and choose Properties. You
can also access the same dialog by selecting Data > Pivot Table > Insert or Edit on the Menu
bar, or clicking the Insert or Edit Pivot Table icon on the Standard toolbar.
For an in-depth explanation of pivot tables and the preconditions necessary to use them, see
Chapter 8, Using Pivot Tables, in the Calc Guide.

Pivot charts
To get a quick visual representation of the data contained in a pivot table, you can generate a
pivot chart. Functionally, pivot charts are nearly identical to regular charts except in two key
areas. First, as the data in the pivot table is altered, the pivot chart will adjust itself automatically.
Second, it includes field buttons, graphical elements that allow you to filter the content of the
pivot table from within the pivot chart itself.
For more information on pivot charts and charts in general, see Chapter 3, Creating Charts and
Graphs, and Chapter 8, Using Pivot Tables, in the Calc Guide.

Printing
Printing from Calc is much the same as printing from other LibreOffice components (see Chapter
10, Printing, Exporting, E-mailing, and Signing Documents). However, some details of printing in
Calc are different, especially regarding preparation for printing.
After print ranges have been defined, they are formatted with automatic page breaks. To view the
page breaks, go to View > Page Break on the Menu bar.

Print ranges
Print ranges have several uses, including printing only a specific part of the data or printing
selected rows or columns on every page. For more information about using print ranges, see
Chapter 6, Printing, Exporting, Emailing, and Signing in the Calc Guide.

Defining a print range
To define a new print range or modify an existing print range:
1) Select the range of cells to be included in the print range.
2) Go to Format > Print Ranges > Define on the Menu bar. Automatic page break lines are
displayed on screen.
3) To check the print range, go to File > Print Preview on the Menu bar, press Ctrl+Shift+O,
or click the Toggle Print Preview icon on the Standard toolbar. Calc will display only the
cells in the print range.

Adding to a print range
After defining a print range, you can add more cells to it by creating another print range. This
allows multiple, separate areas of the same sheet to be printed while not printing the whole
sheet.
1) After defining a print range, select an extra range of cells for adding to the print range.
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2) Go to Format > Print Ranges > Add on the Menu bar to add the extra cells to the print
range. The page break lines are no longer displayed on the screen.
3) To check the print ranges, go to File > Print Preview on the Menu bar, press
Ctrl+Shift+O, or click the Toggle Print Preview icon on the Standard toolbar. LibreOffice
will display the print ranges as separate pages.

Note
The additional print range will print as a separate page, even if both ranges are on
the same sheet.

Removing a print range
It may become necessary to remove a defined print range, for example, if the whole sheet needs
to be printed later.
To remove all the defined print ranges, go to Format > Print Ranges > Clear on the Menu bar.
After the print ranges have been removed, the default page break lines will appear on the screen.

Editing a print range
At any time, you can directly edit the print range, for example to remove or resize part of the print
range. Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges
dialog where you can define the print range.

Printing options
To select the printing options for page order, details, and scale to be used when printing a
spreadsheet:
1) Go to Format > Page Style on the Menu bar to open the Page Style dialog (Figure 130).
2) Select the Sheet tab and make your selections from the available options. Click OK.

Figure 130: Page Style dialog – Sheet tab
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Repeat printing of rows or columns
If a sheet is printed on multiple pages, you can set up certain rows or columns to repeat on each
printed page. For example, if the top two rows of the sheet as well as column A need to be
printed on all pages, do the following:
1) Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges
dialog (Figure 131).
2) Type the row identifiers in the Rows to Repeat box. For example, to repeat rows 1 and 2,
type $1:$2. This automatically changes Rows to Repeat from - none - to
- user defined -.
3) Type the column identifiers in the Columns to Repeat box. For example, to repeat column
A, type $A. In the Columns to Repeat list, - none - changes to - user defined -.
4) Click OK.
For more information on editing print ranges, see Chapter 6, Printing, Exporting, E-mailing, and
Signing, in the Calc Guide.

Figure 131: Edit Print Ranges dialog

Page breaks
While defining a print range can be a powerful tool, it may sometimes be necessary to manually
adjust the Calc printout manually using a manual or page break. A page break helps to ensure
that the data prints properly according to the page size and page orientation. You can insert a
horizontal page break above or a vertical page break to the left of the active cell.

Inserting a break
To insert a page break:
1) Navigate to the cell where the page break will begin.
2) Go to Sheet > Insert Page Break on the Menu bar.
3) Select Row Break to create a page break above the selected cell. Select Column Break
to create a page break to the left of the selected cell.

Deleting a break
To remove a page break:
1) Navigate to a cell that is next to the break you want to remove.
2) Go to Sheet > Delete Page Break on the Menu bar.
3) Select Row Break or Column Break as needed.
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Note
Multiple manual row and column breaks can exist on the same page. When you want
to remove them, you have to remove each break individually.
For more information on manual breaks, see Chapter 6, Printing, Exporting, E-mailing, and
Signing, in the Calc Guide.

Headers and footers
Headers and footers are predefined pieces of text that are printed at the top or bottom of a page
when a spreadsheet is printed. Headers and footers are set and defined using the same method.
For more information on setting and defining headers and footers, see Chapter 6, Printing,
Exporting, E-mailing, and Signing, in the Calc Guide.
Headers and footers are also assigned to a page style. You can define more than one page style
for a spreadsheet and assign different page styles to different sheets within a spreadsheet. For
more information, see Chapter 4, Using Styles and Templates, in the Calc Guide.

Setting a header or footer
To set a header or footer:
1) Select the sheet that you want to set the header or footer for.
2) Go to Format > Page Style on the Menu bar to open the Page Style dialog (Figure 132)
and select the Header or Footer tab (Figure 132).
3) Select the Header on or Footer on option.
4) Select Same content on left and right pages if you want the same header or footer to
appear on all the printed pages.
5) Set the margins, spacing, and height for the header or footer. You can also select AutoFit
height to automatically adjust the height of the header or footer.
6) To change the appearance of the header or footer, click on More to open the Border /
Background dialog.
7) To set the contents, for example page number, date and so on, that appear in the header
or footer, click Edit to open the Header (or Footer) dialog.

Figure 132: Header tab of Page Style dialog
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Getting Started Guide 7.3

Chapter 6,
Getting Started with Impress
Presentations in LibreOffice

What is Impress?
Impress is the presentation (slide show) program included in LibreOffice. Impress creates
presentations in the Open Document Presentation (ODP) format, which can be opened by other
presentation software or can be exported in different presentation formats.
Slides can be created that contain many different elements, including text, bulleted and
numbered lists, tables, charts, and a wide range of graphic objects such as clipart, drawings, and
photographs. Impress also includes a spelling checker, a thesaurus, text styles, and background
styles.
This chapter introduces some features of Impress and does not attempt to cover all of the
features available in Impress that can be used to create presentations. See the Impress Guide
and LibreOffice Help for more information.
To use Impress for more than very simple presentations requires some knowledge of the
elements which the slides contain. Slides containing text use styles to determine the appearance
of that text. Creating drawings in Impress is similar to the Draw module included in LibreOffice.
For more information, refer to Chapter 3, Using Styles and Templates, and Chapter 7, Getting
Started with Draw, in this guide. It is recommended to consult the Draw Guide for more details on
how to use the drawing tools.

Starting Impress
Start Impress using any of the methods described in Chapter 1, Introducing LibreOffice. The
main Impress window opens and, by default, the Select a Template dialog (Figure 133) is
displayed.
Templates included with Impress are designed to fit the two standard sizes of presentation slides:
4:3 and 16:9 ratios. However, templates will adapt to other available sizes, which can be selected
by going to Slide > Slide Properties > Paper Format on the Menu bar or Format in the Slide
panel in the Properties deck on the Sidebar.

Figure 133: Select a Template dialog
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Tip
To start Impress without the Select a Template dialog, deselect Show this dialog box
at startup in the lower left of the dialog.
In Windows or Linux, go to Tools > Options > LibreOffice Impress > General on
the Menu bar and deselect Start with Template Selection under New Document.
In macOS, go to LibreOffice > Preferences > LibreOffice Impress > General on
the Menu bar and deselect Start with Template Selection under New Document.

Main Impress window
The main Impress window (Figure 134) has three main sections: Slides pane, Workspace, and
Sidebar. At the top is the Menu bar and toolbars. Toolbars can be displayed, hidden, locked in
position, or floating during the creation of a presentation.

Tip
The Slides pane and/or Sidebar can be closed by clicking the X in the upper right
corner of each pane, or go to View > Slide Pane or View > Sidebar on the Menu
bar to deselect. To reopen a pane, select View > Slide Pane or View > Sidebar on
the Menu bar.

Tip
To maximize the Workspace area, click on the Hide/Show marker in the middle of
the vertical separator line (highlighted in Figure 134). Using the Hide/Show marker
hides, but does not close, the Slides pane or Sidebar. To restore a pane, click again
on its Hide/Show marker.

Figure 134: Impress main window
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Menu bar
The Impress Menu bar, at the top of the main window, provides several menus common to all
LibreOffice modules. The commands may differ between each LibreOffice module for File, Edit,
View, Insert, Format, Tools, Window, and Help. Impress has two extra menus for Slide and
Slide Show. When a menu item is selected, a submenu drops down to show commands. The
Menu bar can be customized; see Chapter 14, Customizing LibreOffice.

Workspace
The Workspace (normally the center of the main window) opens in Normal view. It has four
standard views of Normal, Outline, Notes, and Slide Sorter. For more information, see
“Workspace views” on page 180.
If master slides are being used, then master views become available: Master Slide, Master
Notes and Master Handout. There are no tabs for master views, which are selected by going to
View on the Menu bar. For more information on master slides, see the Impress Guide.

Slides pane
The Slides pane contains thumbnail images of slides in a presentation in the order in which the
slides are shown. Clicking on a slide image in the Slides pane selects it and places the slide in
the Workspace where changes are made to the displayed slide.
•

To display or close the Slides pane, go to View > Slide Pane on the Menu bar.

•

To close the Slides pane, click on the X in the right top corner of the Slides pane.

•

To display or hide the Slides pane, use the Hide/Show marker on the left of the
Workspace.

Several additional operations can be carried out on one or more slides in the Slides pane. Also,
these additional operations are available from a context menu when right-clicking on a slide in
the Slides pane.
•

Add new slides to a presentation.

•

Hide a slide so that it will not show in a presentation.

•

Delete a slide from a presentation.

•

Rename a slide.

•

Duplicate a slide (copy and paste).

•

Move a slide to another position in the slide order by dragging and dropping it to the
desired position.

Also, the following operations can be carried out, although there are more efficient methods than
using the Slides pane:
•

Change the slide transition following the selected slide or after each slide in a group.

•

Change the sequence of slides in the presentation.

•

Change the slide design.

•

Change slide layout for a group of slides simultaneously.

Sidebar
The Impress Sidebar, normally located on the right side of the Workspace, is similar to the
Sidebar in the other LibreOffice modules. It consists of seven decks, as described below. To open
a deck, use one of the following methods:
•

Click on its icon on the right side of the Sidebar.
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•

Click on Sidebar Settings at the top of the Sidebar and select a deck in the drop-down
list.

•

Go to View on the Menu bar and select the deck required in the submenu.

Properties
The Properties deck has ten panels, allowing the slide layout to be changed and the formatting of
any objects on a slide.
•

When a slide is selected and appears in the Workspace, the Properties deck opens with
the Slide and Layouts panels available.

•

When an object on a slide is selected, the Properties deck has the following panels
available: Character, Lists, Paragraph, Area, Shadow, Line, Position and Size,
Columns, Effect, and Image. Actual panels displayed depends on the type of object
selected.

Styles
On the Styles deck, drawing and presentation styles can be applied to a selected object, new
styles created for drawing and presentation, and both types of styles can be modified. When
saving changes to a style, the changes are applied to all of the elements formatted with that style
in the presentation. For more information on styles, see “Styles” on page 202 and the Impress
Guide.

Gallery
On the Gallery deck, an object can be inserted into a presentation either as a copy or as a link. A
copy of an object is independent of the original object. Changes to the original object have no
effect on the copy. A link remains dependent on the original object. Changes to the original object
are also reflected in the link. See the Impress Guide for more information.

Navigator
The Navigator deck displays all objects contained in a presentation. It provides a convenient way
to move between slides in a presentation or select an object on a slide. It is recommended to
give slides and objects in a presentation meaningful names so that they are easily identified
when using the Navigator. For more information, see “Navigator” on page 179 and the Impress
Guide.

Shapes
The Shapes deck provides panels quick selection of most items that are available on the Drawing
toolbar: Lines and Arrows, Curves and Polygons, Connectors, Basic Shapes, Symbol
Shapes, Block Arrows, Flowchart, Callout Shapes, Stars and Banners, and 3D Objects.

Slide transition
The Slide Transition deck provides a selection of slide transitions available in Impress, also
controls to adjust transition speed, automatic or manual transition, and how long a selected slide
is shown (automatic transition only). For more information on transitions, see “Slide transition” on
page 215 and the Impress Guide.

Animation
The Animation deck provides an easy way to add, change, or remove animations to different
elements or objects on a slide and how they appear during a slide show. For more information on
animation, see “Animation effects” on page 217 and the Impress Guide.
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Master slides
Using the Master Slides deck, the slide design can be selected for a presentation. Impress
includes several designs of master slides. The default master slide is blank, but the remaining
master slides have backgrounds and styled text. For more information on master slides, see
“Working with master slides” on page 202 and the Impress Guide.

Rulers
Rulers are positioned on the upper and left-hand sides of the Workspace. If they are not visible,
go to View > Rulers on the Menu bar. The rulers show the size of a selected object on the slide
using double lines (highlighted in Figure 135). Rulers are also used to manage object handles
and guide lines when positioning objects.
To change the measurement units of the rulers, right-click on a ruler and select the measurement
unit from the drop-down list, as shown in Figure 136 for the horizontal ruler. The horizontal and
vertical rulers can be set to different measurement units.
The page margins in the drawing area are also represented on the rulers. The margins can be
changed directly on the rulers by dragging them with the mouse. The margin area is indicated by
either a grayed out area on the rulers or borders around the unused area of the ruler. This margin
indication depends on computer setup and operating system.

Figure 135: Rulers showing object size

Figure 136: Changing ruler units

Note
The sizes are given in the current measurement unit and might not be the same as
the ruler units. The measurement unit on the Status bar is defined in Tools >
Options > LibreOffice Impress > General.
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Status bar
The Status bar (Figure 137), located at the bottom of the Impress window, contains information
that may be useful when working on a presentation. Several of the fields are the same as those
in other components of LibreOffice. Some Impress-specific fields are described briefly below.
For details on the contents and use of these fields, see Chapter 1, Introducing LibreOffice, in this
guide and the Impress Guide. To hide the Status bar, go to View on the Menu bar and deselect
Status Bar.

Figure 137: Status bar
Slide number
The slide number currently displayed in the Workspace and the total number of slides in the
presentation.
Information area
This changes depending on the object selected on the slide. Examples are shown in
Table 3.
Table 3: Examples of information
Example selection
Examples of information shown
Text area
Text Edit: Paragraph x, Row y, Column z
Charts, spreadsheets
Embedded object (OLE) “ObjectName” selected
Graphics
Bitmap with transparency selected
Master slide name
The master slide associated with the slide or notes page displayed in the Workspace.
Right-click to pop up a list of available master slides and select one to apply it to the
selected slide. Double-click to open the Available Master Slides dialog. For more
information on master slides, see “Working with master slides” on page 202 and the
Impress Guide.
Cursor position/Object size
Shows different information depending on whether objects are selected or not.
– When no object is selected, the position numbers show the current position (X and Y
coordinates) of the mouse cursor.
– When an object is selected and being resized with the mouse, the object size
numbers show the size of the object (width and height).
– If an object is selected, the position numbers shows X and Y coordinates of the
upper-left corner and the object size number pair displays the size of the object.
These numbers do not relate to the object itself, but to the selection outline, which is
the smallest possible rectangle that can contain the visible parts of the object.
– When an object is selected, clicking in either of these areas opens the Position and
Size dialog.
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Unsaved changes
Indicates if there are any unsaved changes in the presentation. Clicking this icon saves the
document. If the presentation has not been saved before, the Save As dialog opens giving
the opportunity to save the presentation.
Digital signatures
Indicates if the presentation has a digital signature.
Text language
Indicates the language used for any text on a presentation.
Fit slide
When this icon is clicked on, the slide in the workspace zooms to fit in the Workspace.
Zoom slider
When moved, the slide changes its viewing zoom in the Workspace.
Zoom percentage
Indicates the zoom level of the slide displayed in the Workspace. Clicking on zoom
percentage opens the Zoom & View Layout dialog where the settings for zoom factor and
view layout are adjusted.

Navigator
The Navigator displays all objects contained in a presentation. It provides another convenient
way to move around a presentation and find items in it.
To open the Navigator dialog (Figure 138) go to View > Navigator on the Menu bar, or use the
keyboard shortcut Ctrl+Shift+F5 (macOS ⌘+Shift+F5). Alternatively, click on Navigator in the
Sidebar to open the Navigator deck that is similar in appearance and function as the Navigator
dialog.

Figure 138: Navigator dialog
The Navigator is more useful if slides and objects (pictures, spreadsheets, and so on) are given
meaningful names, instead of leaving them with default names, such as “Slide 1” and “Shape 1”
and so on (as shown in Figure 138). Using meaningful names allows for a slide or object to be
easily located in a presentation.
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Toolbars
Many toolbars can be used during slide creation. To display or hide the various toolbars in
Impress, go to View > Toolbars on the Menu bar and select the required toolbar in the submenu
that appears. For example, the Standard and Drawing toolbars are displayed by default, but the
Line and Filling, and Text Formatting toolbars are not shown. For more information on toolbars
and how to use them, see Chapter 1, Introducing LibreOffice, and the Impress Guide.

Note
The icons used on toolbars vary depending on the computer operating system and
the selection of icon size and style in Tools > Options > LibreOffice > View.

Workspace views
The Impress workspace has four standard views selected using tabs: Normal, Outline, Notes,
and Slide Sorter. These tabs are normally displayed the top of the Workspace. If the tabs are
not displayed, then go to View > Views Tab Bar on the Menu bar. Also, different workspace
views can be selected by going to View on the Menu bar and selecting a view in the submenu.
Each of the workspace views is designed to ease the completion of certain tasks.
Master views only become available in the Workspace when Master Slide, Master Notes or
Master Handout are selected. There are no tabs for master views and can only be selected by
going to View on the Menu bar.

Note
Each workspace view displays a different set of toolbars when selected. To
customize these toolbar sets, go to View > Toolbars on the Menu bar, then check or
uncheck the toolbars to add or remove.

Normal view
Normal view is the main standard view for creating individual slides in a presentation. In Normal
view slides are designed, text or graphics added and formatted, and any animation effects added
to text or graphics.
To place a slide in Normal view of the Workspace, either click on the slide thumbnail in the Slide
Pane or click on the slide name in the Navigator.

Outline view
Outline view (Figure 139) contains all the slides of the presentation in their numbered sequence.
It shows topic titles, bulleted lists, and numbered lists for each slide in outline format. Only the
text contained in the default text boxes in each slide is shown. If you have added text boxes or
graphic objects to the slides, then these objects are not displayed. Slide names are not included.
•

Use Outline view for the following tasks:
– Make changes in the text of a slide:
– Add or delete text in a slide as in Normal view.
– Move a paragraph in a slide up or down by using the movement arrows on the Outline
toolbar (Figure 140).
– Change the outline level of a paragraph in a slide using the left and right arrow
buttons on the Outline toolbar.
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•

Compare slides with in an outline. If it is noticed in an outline that another slide is
required, create it directly in Outline view, or return to Normal view to create it.

Figure 139: Example of Outline view in Workspace

Figure 140: Outline toolbar

Notes view
Use Notes view (Figure 141) to add notes to a slide. These notes are not seen when the
presentation is shown to an audience using an external display connected to a computer. Click
on the words Click to add Notes and begin typing.
The Click to add notes text box can be resized using the resizing handles which appear when the
edge of the notes box is selected. Move or change the size of the box by clicking and dragging
on the box border.

Figure 141: Example Notes in Workspace
When text is inserted in the Click to add notes text box, it is automatically formatted using the
predefined Notes style in Presentation Styles in the Styles deck on the Sidebar. The Notes style
can be formatted to the presentation requirements. For more information on editing styles, see
Chapter 3, Styles and Templates, in this guide and the Impress Guide.
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Slide sorter view
Slide Sorter view (Figure 142) contains all the thumbnails of slides used in a presentation. Use
this view to work with one slide or a group of slides.

Customizing Slide Sorter view
To change the number of slides per row in Slide Sorter view:
1) Go to View > Toolbars > Slide View on the Menu bar to show the Slide View toolbar
(Figure 143).
2) Adjust the number of slides, up to a maximum of 15, in the Slides per Row box.

Changing slide order
To change the slide order of one or a group of slides in a presentation using Slide Sorter view:
1) Select a slide or a group of slides.
2) Drag and drop the slide or group of slides at the location required.

Selecting a group of slides
To select a group of slides, use one of these methods:
•

Ctrl key – click on the first slide and, while holding the Ctrl key (macOS ⌘), select the
required slides. The selected slides do not have to be next to each other.

•

Shift key – click on the first slide, and while holding the Shift key, select the final slide for
the group. This selects all of the slides between the first and the last slide selected.

•

Mouse – position the cursor slightly outside the first slide, then click and hold the left
mouse button and drag the cursor until all of slides required for the group are selected.

Figure 142: Example of Slide Sorter view in Workspace

Figure 143: Slide View toolbar

Working in Slide Sorter view
Working with slides in Slide Sorter view is similar to working with slides in the Slide Pane. To
make changes, right-click on a slide in Slide Sorter view and choose one of the following in the
context menu:
•

Cut – removes the selected slide and saves it to the clipboard.
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•

Copy – copies the selected slide to the clipboard without removing it.

•

Paste – inserts a slide from the clipboard after the selected slide.

•

New Slide – adds a new slide after the selected slide.

•

Duplicate Slide – creates a duplicate of the selected slide and places the new slide
immediately after the selected slide.

•

Rename Slide – renames the selected slide.

•

Hide Slide – any slides that are hidden are not shown in the slide show.

•

Delete Slide – deletes the selected slide.

•

Layout – allows changes to the layout of the selected slide.

•

Move – allows moving or repositioning the slide in the presentation order.

Creating presentations
By default, Impress opens with the Select a Template dialog displayed to select a template for a
new presentation. To create a new presentation without a template, click on Cancel in the Select
a Template dialog and a blank slide opens in the Workspace and Slides pane. For more
information on creating presentations, slide show options, and presentation settings, see the
Impress Guide.
To prevent the Select a Template dialog from opening, go to Tools > Options > LibreOffice
Impress > General on the Menu bar to open Options LibreOffice Impress General dialog
(Figure 144) and deselect the option Start with New Template Selection.

Figure 144: Options LibreOffice Impress General dialog

Tip
The first thing to do is decide on the purpose of a presentation and plan accordingly.
Having an idea of the audience type, the structure, the content, and how the
presentation will be delivered, will save a lot of time from the start.

New presentation
When creating a new presentation, Impress shows only one slide in the Slides pane and
Workspace.
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Inserting new slide
To insert a new slide into a presentation, use one of the following methods.
•

Go to Slide > New Slide on the Menu bar.

•

Right-click in the Slides pane and select New Slide in the context menu.

•

Use the keyboard shortcut Ctrl+M.

•

Go to Slide Sorter view in the Workspace, right-click on a slide and select New Slide in
the context menu.

•

Click on New Slide in the Presentation toolbar (Figure 145). If the Presentation toolbar is
not visible, go to View > Toolbars on the Menu bar and select Presentation in the
drop-down list.

Figure 145:
Presentation toolbar

Note
A new slide is inserted after the selected slide in the presentation. If a slide is not
selected, then the new slide is inserted as the last slide in the presentation.

Duplicating slides
To duplicate a slide, select a slide for duplication in the Slides pane and use one of the following
methods. A duplicate slide is inserted after the selected slide in the presentation.
•

Right-click on a slide in the Slides pane and select Duplicate Slide in the context menu.

•

Go to Slide Sorter view in the Workspace, right-click on a slide and select Duplicate
Slide in the context menu.

•

Go to Slide > Duplicate Slide on the Menu bar.

•

Click on the Duplicate Slide icon on the Presentation toolbar.

Slide format
Click on Properties on the Sidebar and open the Slide panel (Figure 146) to display the format
options available for a presentation. The Slide panel allows for quick formatting of all slides
included in a presentation and selecting master slides for a presentation. For more information on
formatting slides and using master slides, see the Impress Guide.

Slide layout
By default in Impress, the Title Slide layout is used for the first slide when a new presentation is
created. The layouts included in Impress range from a blank slide to a slide with six contents
boxes and a title. For more information on slide layouts and slide contents, see the Impress
Guide.
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Figure 146: Slide and Layouts panels in
Properties deck on Sidebar
The first slide in a presentation is normally a title slide. The layouts Title Slide, which also
contains a section for a subtitle, or Title Only are the most suitable layouts for the first slide in a
presentation. For the remaining slides, select the most suitable layout to use for the slide
contents.
Impress does not have the functionality to create custom layouts. However, the different
elements in a slide layout can be resized and moved. For more information, see the Impress
Guide.

Selecting slide layout
The available layouts are shown in the Layouts panel on the Properties deck on the Sidebar.
After selecting a slide, select the slide layout using one of the following methods:
•

Go to the Properties deck on the Sidebar to open the Layouts panel (Figure 146).

•

Click on Slide Layout on the Presentation toolbar to open a pop-up Layouts panel.

•

Click on Slide > Layout on the Menu bar to open a drop-down list showing the layouts by
name.

•

Right-click on the selected slide and select Layout in the context menu to open a
drop-down list of slide layouts.

Tip
To view the names for slide layouts, use the tooltip feature. Position the cursor on an
icon in the Layouts panel (or on any other tool icon) in the Properties deck on the
Sidebar and its name is displayed in a small rectangle.
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Changing slide layout
Change the slide layout for a slide in a presentation as follows:
1) Select a slide in the presentation.
2) Select a new layout for the slide using one of the methods described in “Selecting slide
layout” above.

Slide contents
Several layouts can contain one or more content boxes. Each of these content boxes can be
configured to contain the following elements. For more information on layout content boxes, see
the Impress Guide.
•

Slide title – click on Click to add Title and type a title in the text box. Impress enters text
editing mode and the Text Formatting toolbar automatically opens.

•

Text – click on Click to add Text and type the contents into the text box. Impress enters
text editing mode and the Text Formatting toolbar automatically opens.

•

Table – go to Insert > Table on the Menu bar and the Insert Table dialog opens. Enter
the number of columns and rows, then click OK. The dialog closes and a table is inserted
into the slide. Impress enters text editing mode and the Text Formatting and Table
toolbars automatically open.

•

Chart – go to Insert > Chart on the Menu bar and the Impress default chart is inserted in
the slide. The Chart Type panel opens in the Properties deck on the Sidebar allowing
editing of the chart to the presentation requirements.

•

Image – go to Insert > Image on the Menu bar and a file browser opens. Navigate to
where the required image is located. Select the file and click on Open. The image is
placed into the slide and the file browser closes. The Image panel opens in the
Properties deck on the Sidebar allowing editing of the image file.

•

Audio or video – go to Insert > Audio or Video on the Menu bar and a file browser
opens. Navigate to where the required audio or video file is located. Select the file and
click on Open. The audio or video file is inserted into the slide and the file browser
closes. The Media Playback toolbar opens allowing operation of the audio or video file.

Note
Text and graphic elements can be readjusted at any time during the preparation of a
presentation. However, changing slide layout that already has contents can have a
dramatic effect. If the layout is changed after contents have been added, the
contents are not lost, but they may need to be reformatted.

Modifying slide elements
When a slide is inserted into a presentation, it contains elements that were included in the
selected slide layout. However, it is unlikely that the predefined layouts will suit all requirements
for a presentation. Elements required maybe removed or objects inserted such as text and/or
graphics.
Although Impress does not have the functionality to create new layouts, it allows for the resizing
and moving of the slide elements. It is also possible to add slide elements without being limited to
the size and position of content boxes.
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Note
It is recommended that changes to slide elements in the layouts included in Impress
are only made using Normal view, which is the default. Attempting any changes to a
slide element when in Master view is possible, but may produce unpredictable
results and requires extra care as well as a certain amount of trial and error.

Moving contents box
1) Click on the outer frame of the contents box so that the selection handles are displayed.
2) Place the cursor on the frame so the cursor changes shape. This is normally a clenched
hand, but depends on the computer setup.
3) Click and drag the contents box to its new position on the slide, then release the mouse
button.

Resizing contents box
1) Click on the outer frame of the contents box so that the selection handles are displayed.
2) Place the cursor on the frame so that the cursor changes shape.
3) Click and drag the selection handle on the frame to resize the contents box, then release
the mouse button.
– Top and bottom selection handles change the height of a contents box.
– Left and right selection handles change the width of a contents box.
– Corner selection handles change width and height of a contents box.

Removing elements
1) Click a contents box or an element to highlight it and the selection handles are displayed.
2) Press the Delete or Backspace key to remove the contents box or element.

Adding text
There are two ways of adding text to a slide – contents box or text box. For more information, see
“Adding and formatting text” on page 189 and the Impress Guide.
•

Contents box – click Click to add Text in the contents box and type the text. Outline
styles are automatically applied to the text as it is inserted. If required, change the outline
level of each paragraph as well as its position within the contents box by using the arrow
buttons on the Outline toolbar and Workspace Outline view.

•

Text box – click on Insert Text Box on the Standard toolbar or Drawing toolbar to select
text mode, then click on the slide. A text box is created and the Text Formatting toolbar
automatically opens. Type the text and click outside the text box to end text mode.

Adding images or objects
To add images or objects to a slide, for example a picture, clipart, drawing, photograph, or
spreadsheet, click on Insert on the Menu bar and select in the drop-down menu the image or
object type required. See “Inserting images, tables, charts, or media” on page 197 and the
Impress Guide.

Modifying slide appearance
To change the background and other characteristics of all slides in the presentation, the master
slide has to be modified or a different master slide selected, as explained in “Working with master
slides” on page 202.
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Figure 147: Slide Properties dialog - Background page
A master slide has a specified set of characteristics that acts as a template and is used as the
starting point for creating other slides. These characteristics include slide background, objects in
the background, formatting of any text used, and any background graphics.
Impress has a range of master slides, which are found in the Master Slides deck on the Sidebar.
Additional master slides can be created or and saved, or added from other sources. See the
Impress Guide for more information.
For example, to change the background of an individual slide or a master slide:
1) Right click on a slide or master slide and select Slide Properties in the context menu to
open the Slide Properties dialog (Figure 147).
2) Select the Background tab and then select the type of background to use from None,
Color, Gradient, Bitmap, Pattern and Hatch.
3) Make a selection from the various properties that are available for each type of
background.
4) Click OK to save the change and close the dialog.
For more information on inserting, formatting, and changing a background, see the Impress
Guide or Draw Guide.

Modifying presentations
By default, a presentation displays all the slides in the same order as they appear in Slide Sorter
view on the Workspace. It is recommended to review the entire presentation and answer some
questions. Run the presentation at least once, then answer the following questions. Also there
maybe more questions after running a presentation for the first time, for example:
•

Are the slides in the correct order? If not, some of the slides have to be moved.

•

Is the information well spaced and visible to members of an audience at the back of a
large room? The audience may not be able to see information at the bottom of a slide, so
redesign the presentation to fit the top three-quarters of a screen.

•

Would an additional slide make a particular point clearer? If so, create another slide.
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•

Are some of the slides unnecessary? Hide or delete the slides not required.

•

Would animations help some of the slides? This is considered an advanced technique.

•

Should some of the slides have a different slide transition than others? The transition of
those slides should be changed.

Once the questions have been answered, make the necessary changes. Making changes can be
carried out in Slide Sorter view on the Workspace. For more information on running a
presentation, see the Impress Guide.

Adding and formatting text
Most of the slides in a presentation are likely to contain some text. This section gives some
guidelines on how to add text and change its appearance. Text used in slides is contained in text
boxes. For more information on adding and formatting text, see the Impress Guide.
Two types of text boxes (AutoLayout text box and text box) are available in Impress for use on
slides. Both types of text boxes can be moved, resized, and deleted.
•

Choose a predefined layout from the Layouts panel on the Properties deck on the
Sidebar and do not select any special content type. These text boxes are called
AutoLayout text boxes.

•

Use Insert Text Box for horizontal text, or Insert Vertical Text for vertical text on the
Standard toolbar, Drawing toolbar, or Text toolbar (Figure 148) to create text boxes on a
slide.

•

Use the keyboard shortcut F2 to create text boxes on a slide for horizontal text.

When adding and formatting text, the Text Formatting toolbar (Figure 149) normally opens,
automatically providing a range of tools to add and format text.

Note
If the toolbars are not visible, go to View > Toolbars on the Menu bar and select the
required toolbars in the drop-down list.

Note
The area fill and borders in AutoLayout text boxes and text boxes can be edited
using the same methods that are used for graphic objects. For more information, see
the Impress Guide.

Figure 148: Text toolbar

Figure 149: Text Formatting toolbar
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AutoLayout text boxes
AutoLayout text boxes are automatically created when one of the slide layouts available in
Impress is selected.
1) Make sure Normal view is selected in the Workspace.
2) Select the slide where text is to be added into an AutoLayout text box.
3) Click on Click to add Title or Click to add text in an AutoLayout text box. The text
automatically disappears and is replaced by a flashing text cursor. The Text Formatting
toolbar automatically opens replacing the Line and Filling toolbar.
4) Type or paste text into the AutoLayout text box and, if necessary, format the text to the
presentation requirements.
5) Click outside the AutoLayout text box to deselect it.

Text boxes
1) Make sure Normal view is selected in the Workspace.
2) Select the slide where the text is to be added.
3) For horizontal text: click on the selected slide and create a text box using one of the
following methods:
– Single line text box: select Insert Text Box, click on the slide and then type or paste
the text. The width of the text box increases as text is added creating a single line of
horizontal text.
– Single line text box: use the keyboard shortcut F2, click on the slide and then type or
paste the text. The width of the text box increases as text is added creating a single
line of horizontal text.
– Multiple line text box: select Insert Text Box, or use the keyboard shortcut F2, click
on the slide and drag to the approximate width required for the text box, then type or
paste the text into the text box. The width of the text box is fixed and the height of the
text box increases automatically as text is added creating multiple lines of horizontal
text.
– Multiple line text box from a single line text box: use the Enter key to create a new
paragraph, or the keyboard combination Shift+Enter to create a line break in the text.
4) Release the mouse button and the cursor appears in the text box, which is now in edit
mode and indicated by a colored border (Figure 150). The width and final position of the
text box can be adjusted after adding text into the text box.
5) Click outside the text box to deselect it.

Figure 150: Example of a text
box in edit mode

Vertical text
In addition to normal text boxes where text is horizontally aligned, it is possible to insert text
boxes where the text is vertically aligned. Vertical text is available only when Asian languages are
enabled in Tools > Options > Language Settings > Languages.
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Creating vertical text boxes is similar to creating horizontal text boxes. Use the Insert Vertical
Text tool on the Standard, Drawing, or Text toolbars to create a vertical text box with single or
multiple lines. The height of the text box is fixed and the width of a vertical text box increases
automatically as text is added to a multi-line text box.

Quick font resizing
To quickly increase or decrease the font size of selected text by using the tools Increase Font
Size (Ctrl+]) (macOS ⌘+]) and Decrease Font Size (Ctrl+[) (macOS ⌘+[) on the Text Formatting
toolbar. The amount by which the font size changes depends on the standard sizes available for
the font in use.

Note
AutoLayout text boxes automatically adjust font size of any text inserted into the box.
For example, if a long piece of text is inserted into an AutoLayout text box, the font
size may decrease in size to fit into the box.

Pasting text
Text can be added to an AutoLayout or normal text box by copying it from another document and
pasting it into Impress. However, the formatting of the pasted text will probably not match the
formatting of the surrounding text or that of the other slides in the presentation. This may be what
is required on some occasions. However, to make sure that the presentation style is consistent
and does not become a patchwork of different styles, font types, bullet points, and so on, the text
has to be formatted to match the rest of the presentation.

Unformatted text
It is good practice to paste text without formatting and apply the formatting later.
1) Highlight and copy the text from another document or slide.
2) Create a text box on a slide and make sure the text cursor is flashing in the text box.
Alternatively, select an AutoLayout text box on a slide. See “Text boxes” on page 190 and
see “AutoLayout text boxes” on page 190 and the Impress Guide for more information.
3) Paste unformatted text into the text box using one of the following methods. Text is
pasted at the cursor position in the text box formatted using the Default Drawing Style or
Presentation Style if text was pasted into an AutoLayout text box.
– Go to Edit > Paste Special > Paste Unformatted Text on the Menu bar.
– Click on the triangle ▼to the right of the Paste tool on the Standard toolbar and select
Unformatted Text in the context menu.
– Use the keyboard shortcut Ctrl+Shift+V (macOS ⌘+Shift+V) and select Unformatted
text on the dialog that opens.
4) Format the text to the presentation requirements using the tools on the Text Formatting
toolbar or the options in Format on the Menu bar.

Note
The Presentation style used in AutoLayout text boxes cannot be changed by
selecting another presentation style. Make sure the AutoLayout text box uses the
presentation style required. Change outline levels and outline styles using the Tab
key or Shift+Tab key combination. See the Impress Guide for more information.
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AutoLayout text box formatting of pasted text
If text is being pasted into an AutoLayout text box, the appropriate outline style has to be applied
to the text giving it the same look and feel as the rest of the presentation.
1) Highlight and copy the text from another document or slide.
2) Paste the text into the AutoLayout text box, then select the pasted text.
3) Select Format > Clear Direct Formatting on the Menu bar, or use the keyboard shortcut
Ctrl+Shift+M (macOS ⌘+Shift+M) to make sure any formatting is removed from the
pasted text.
4) Use the four arrow buttons on the Outline toolbar to move the text to the appropriate
position and give it the appropriate outline level.
– Left arrow promotes a list entry by one level (for example from Outline 3 to Outline 2).
Alternatively, place the cursor at the beginning of the paragraph and use the Shift+Tab
keys.
– Right arrow demotes a list entry by one level. Alternatively, place the cursor at the
beginning of the paragraph and use the Tab key.
– Up arrow moves a list entry up in the list order.
– Down arrow moves a list entry down in the list order.
5) If necessary, modify the presentation style to format the text to the presentation
requirements to change font attributes, tabs, and so on. See the Impress Guide for more
information. Alternatively, apply any necessary manual or direct formatting to the text.

Text box formatting of pasted text
Pasting formatted text into a text box overwrites any formatting and replaces the text box style.
1) Highlight and copy the text from another document or slide.
2) If necessary, create a text box on a slide and make sure the text cursor is flashing in the
text box. See “Text boxes” on page 190 and the Impress Guide for more information.
3) Paste formatted text into the text box. Text is pasted at the cursor position in the text box
and the text formatting of the pasted text overwrites any style formatting of the text box.
4) Select Format > Clear Direct Formatting on the Menu bar or use the keyboard shortcut
Ctrl+Shift+M (macOS ⌘+Shift+M) to make sure any formatting is removed from the
pasted text.
5) Select the required drawing style to format the text from the available drawing styles.
6) If necessary, modify a drawing style or create a new drawing style to format the text to the
presentation requirements. See the Impress Guide for more information.

Note
Drawing styles can be created in Impress and are only available for the presentation
which is being created and has been saved. Templates can also be created that
include any drawing styles required. For more information, see the Impress Guide.

Creating lists
The procedure to create an unordered (bulleted) or ordered (numbered) list varies depending on
the type of text box used. The tools to manage and format a list are the same. To change the
appearance of a list, see Changing list type” on page 194.
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Figure 151: Example of outline levels in AutoLayout text
box

AutoLayout text boxes
In AutoLayout text boxes and by default, the outline styles available are unordered lists. An
example of these outline styles is shown in Figure 151. These outline styles are presentation
styles and cannot be deleted, but can be modified or updated to the presentation requirements.
See the Impress Guide for more information.
Create a slide using an AutoLayout text box with an unordered list as follows:
1) Go to View > Normal on the Menu bar to open Normal view.
2) Select a layout for the slide using one of the following methods:
– Right-click in a blank area on the slide and select a layout in the context menu.
– Go to Slide > Layout on the Menu bar and select a layout in the drop-down list.
– Select a layout in the Layouts panel on the Properties deck in the Sidebar.
3) Click on the text ● Click to add Text and start typing the first list item.
4) Press Enter to start a new list point or use the keyboard combination Shift+Enter to start a
new line without creating a new list point. The new line will have the same indentation as
the list point.

Tip
To switch off bullets altogether, click on Toggle Unordered List on the Text
Formatting toolbar.

Changing outline level
In AutoLayout text boxes, change the outline level as follows:
1) To demote the outline level of a list point, use one of the following methods:
– Press the Tab key.
– Click on Demote on the Outline toolbar.
– Click on Demote in the Lists panel on the Properties deck in the Sidebar.
– Go to Format > Lists on the Menu bar and select Demote in the submenu.
– Use the keyboard shortcut Alt+Shift+Right Arrow (macOS ⎇+Shift+Right Arrow)
2) To promote the outline level of a list point, use one of the following methods:
– Use the keyboard shortcut Shift+Tab.
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– Click on Promote on the Outline toolbar.
– Click on Promote in the Lists panel on the Properties deck in the Sidebar.
– Go to Format > Lists on the Menu bar and select Promote in the submenu.
– Use the keyboard shortcut Alt+Shift+Left Arrow (macOS ⎇+Shift+Left Arrow)
3) To move a list point lower or higher in the list order without changing the outline level, use
one of the following methods:
– Click on Move Down or Move Up on the Outline toolbar.
– Click on Move Down in the Lists panel on the Properties deck in the Sidebar.
– Go to Format > Lists on the Menu bar and select Move Down or Move Up in the
submenu.
– Use the keyboard shortcut Alt+Shift+Down Arrow (macOS ⎇+Shift+Down Arrow) or
Alt+Shift+Up Arrow (macOS ⎇+Shift+Up Arrow).

Note
In AutoLayout text boxes, promoting or demoting an item in the list corresponds to
applying a different outline style. The second outline level corresponds to Outline 2
style, the third outline level to Outline 3 style, and so on. A change in level and style
produces other changes, for example, to font size, bullet type, and so on.

Text boxes
Create an unordered or ordered list in a text box as follows:
1) Create a text box on a slide and make sure the cursor is flashing in the text box. See
“Text boxes” on page 190 on how to create a text box.
2) Create a list using one of the following methods:
– Click on Toggle Unordered List or Toggle Ordered List on the Text Formatting
toolbar.
– Click on Toggle Unordered List or Toggle Ordered List in the Lists panel on the
Properties deck in the Sidebar.
– Go to Format > Lists on the Menu bar and select Unordered List or Ordered List in
the submenu.
3) Type the text and press Enter to start a new list point or use the keyboard combination
Shift+Enter to start a new line without creating a new list point. The new line will have the
same indentation as the list point.
4) To increase or decrease the indent level of a list point, or move a list point up or down,
see “Changing outline level” on page 193.

Changing list type
The list type can be changed for an unordered or ordered type for the entire list or for a single
point only as follows:
1) Select a point in a list, or select the entire list in the text box. Alternatively, click on the
border of the text box so that the resizing handles are displayed to select the entire list.
2) Change the list type from unordered to ordered list, or ordered to unordered as described
in “Text boxes” above.
3) If required, change the type of bullet or number used for the list:
a) Click on the triangle ▼ to the right of the Toggle Unordered List or Toggle Ordered
List on the Text Formatting toolbar or the Lists panel on the Properties deck in the
Sidebar.
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b) Select a bullet or number type from the options available in the drop-down window as
shown in Figure 152.
c) If necessary, click on More Bullets or More Numbering in the drop-down window to
open the Bullets and Numbering dialog for further options to change the list
appearance. See the Impress Guide for more information.

Figure 152: Available types for bullet and number lists

Changing bullet or number format
The bullet or number format used in a list can be changed for the entire list or for a single point
only as follows:
1) Select a point in a list, or select the entire list in the text box. Alternatively, click on the
border of the text box so that the resizing handles are displayed to select the entire list.
2) Click on the triangle ▼ to the right of the Toggle Unordered List or Toggle Ordered List
on the Text Formatting toolbar or the Lists panel on the Properties deck in the Sidebar to
open a drop-down dialog displaying the format options available.
3) Select a bullet or number type from the options available in the drop-down window as
shown in Figure 152.
4) If necessary, click on More Bullets or More Numbering in the drop-down window to
open the Bullets and Numbering dialog for further options to change the list appearance.
See the Impress Guide for more information.

Note
The Bullets and Numbering dialog can also be opened by going to Format > Bullets
and Numbering on the Menu bar, or by right-clicking on a list point and selecting
Bullets and Numbering in the context menu.

Note
If a list was created in an AutoLayout text box, then the Outline styles can be
modified to change the list type and/or format. Changes made to an Outline style
apply to all the slides that use that style. For details, see the Impress Guide.

Text columns
Text in a presentation can be formatted into columns inside text boxes and objects. However,
columns cannot be used on separate parts of text inside a text box or object. The whole of the
text box or object has to be used for columns.
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Figure 153: Text dialog - Text Columns page

Figure 154: Columns panel in Properties deck on
Sidebar
The type of columns used in Impress are continuous flow columns. This means that when text
reaches the bottom of a column, it automatically flows into the next column as text is added. This
type of columns is also known as newspaper columns.
Columns in text boxes and graphic objects are created as follows:
1) For text boxes – click the border of a text box to select it so that the selection handles are
displayed indicating that the text box is in edit mode.
2) For graphic objects – double-click on a graphic object to select it so that the selection
handles are displayed and the cursor flashes in the center of the object indicating that the
object is in text edit mode.
3) Open the options for text columns using one of the following methods:
– Right-click in the text box or graphic object and select Text Attributes in the context
menu to open the Text dialog, then click on the Text Columns tab to open the Text
Columns page (Figure 153),
– Click on Columns in Properties on the Sidebar to open the Columns panel
(Figure 154).
4) Set the number of columns required in the Number of columns box and the required
spacing between the columns in the Spacing box.
5) Save the changes and deselect the text box or graphic object using one of the following
methods:
– For the Text dialog, click OK to save the changes and close the dialog, then click
outside the text box to deselect it.
– For the Columns panel in the Properties deck on the Sidebar, click outside the text
box or graphic object to deselect it and save the changes.
6) Type in the required text or use copy and paste to enter the required text into the text box
or graphic object. Any text entered will be in column format.
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7) If necessary, format the text to the presentation requirements.
8) Click outside the text box or graphic object to deselect it and save the changes.

Note
Any text inside a text box or graphic object automatically flows into column format
when the changes are saved.

Inserting images, tables, charts, or media
A contents box on a slide can contain images, tables, charts, or media as well as text. The Insert
toolbar (Figure 155) provides quick access to relevant tools. This section provides an overview of
how to work with these objects. For more information, see the Impress Guide.

Inserting images
1) Open the slide in Normal view on the Workspace where the image is going to be
inserted.
2) Open the Insert Image file browser using one of the following methods:
– Go to Insert > Image on the Menu bar.
– Click on Insert Image on the Insert toolbar (Figure 155).
– Click on Insert Image on the Standard toolbar.
3) Navigate to the location of the file and select the image file required.
4) Click Open to place the image in the center of the slide.
5) Reposition and resize the image to the presentation requirements.

Figure 155: Insert toolbar

Inserting tables
When a table is inserted into a slide, the Table toolbar (Figure 156) automatically opens. This
toolbar in Impress offers the same functions as the Table toolbar in Writer, with the exception of
the calculation functions Sort and Sum. To use Sum and Sort in a presentation, a Calc
spreadsheet has to be inserted into the slide.

Note
If the Table toolbar does not automatically open, go to View > Toolbars on the Menu
bar and select the Table toolbar.

Chapter 6, Getting Started with Impress | 197

Figure 156: Table toolbar
Entering data into table cells is similar to working with text box objects. Click in a cell and begin
typing. To move around cells quickly, use the following keyboard options:
•

Use the arrow keys to move the cursor to another cell if the cell is empty, or to the next
character if the cell already contains text.

•

Press the Tab key to move to the next cell on the right and press Shift+Tab to move to the
next cell on the left.

Using the Menu bar
1) Open the slide in Normal view on the Workspace and go to Insert > Table on the Menu
bar to open the Insert Table dialog (Figure 157).
2) Select the Number of columns and the Number of rows required for the table.
3) Click OK to place the table in the center of the slide and close the Insert Table dialog.
4) The Table Design panel on the Properties deck on the Sidebar opens (Figure 158).
Select a table design, the type of rows, and the type of columns required.
5) If necessary, reposition and format the table on the slide to the presentation
requirements.

Figure 157: Insert Table dialog
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Figure 158: Table Design panel in
Properties deck on Sidebar

Figure 159: Insert Table grid

Using Insert or Standard toolbar
1) Open the slide in Normal view on the Workspace and click on Table on the Insert toolbar
or the Standard toolbar to open the Insert Table grid (Figure 159).
2) Click and drag the cursor to create the number of columns and rows required.
3) Click the mouse button to place the table in the center of the slide and the Insert Table
grid closes.
4) The Table Design panel on the Properties deck in the Sidebar opens (Figure 158). Select
a table design, the type of rows, and the type of columns from the options available.
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5) If necessary, reposition and format the table on the slide to the presentation
requirements.

Note
Select More Options at the bottom of the Insert Table grid (Figure 159) to open the
Insert Table dialog (Figure 157) where the number of rows and columns required can
be selected.

Inserting charts
To insert a chart into a selected slide in Normal view on the Workspace, use one of the following
methods:
•

Go to Insert > Chart on the Menu bar.

•

Click on Insert Chart on the Insert toolbar.

•

Click on Insert Chart on the Standard toolbar.

Impress switches to chart view, the Formatting toolbar (Figure 160) automatically opens, and the
Chart Type panel on the Properties deck on the Sidebar opens (Figure 161). To change the chart
type, insert the required data, and change the formatting, see the Impress Guide and the Calc
Guide.

Figure 160: Formatting toolbar

Figure 161: Chart Type panel in the
Properties deck on the Sidebar
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Figure 162: Gallery deck on Sidebar

Inserting audio or video
Using file browser
1) Go to Insert > Audio or Video on the Menu bar, or click on Insert Audio or Video on the
Insert toolbar and the Insert Audio or Video file browser opens.
2) Navigate to the folder where the file is located and select the audio or video file you want
to insert onto a slide. Only the audio and video files that are compatible with Impress will
be highlighted in the file browser.
3) Click Open to place the audio or video file in the center of the slide. The Media Playback
toolbar opens while the audio or video file is selected.
4) Reposition and/or resize the audio or video file. See the Impress Guide for more
information.

Using the Gallery
1) If the Gallery deck (Figure 162) is not already open, use one of the following methods:
– Go to View > Sidebar on the Menu bar to open the Sidebar, then select Gallery.
– Go to View > Gallery on the Menu bar.
2) Browse to a category containing media files, for example Sounds.
3) Click on the audio or video file required and drag it onto the slide. The Media Playback
toolbar automatically opens.
4) Reposition and/or resize the audio or video file. See the Impress Guide for more
information.
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Inserting graphics, spreadsheets, and OLE objects
Graphics
Graphics, such as shapes, callouts, and arrows, are often useful to complement the text on a
slide. These objects are handled much the same way as graphics in Draw. For more information
on inserting graphics, see Chapter 7, Getting Started with Draw in this guide, the Impress Guide,
or the Draw Guide.

Spreadsheets
Spreadsheets embedded in Impress include most of the functionality of Calc spreadsheets and
are capable of performing complex calculations and data analysis. If the data has to be analyzed
or formulas applied, then these operations are best performed in a Calc spreadsheet and the
results displayed in an embedded Calc spreadsheet or in an Impress table. For more information
on spreadsheets, see the Impress Guide and the Calc Guide.

OLE objects
Object Linking and Embedding (OLE) is a software technology that allows linking and embedding
of spreadsheets, charts, drawings, formulas, and text files into an Impress presentation.
The major benefit of using OLE objects is that it provides a quick and easy method of editing the
object using tools from the software used to create the object. These file types can all be created
using LibreOffice and OLE objects can be created from new or from an existing file.
When inserting a new OLE object into a presentation, it is only available in that presentation and
can only be edited using Impress. For more information on inserting and formatting OLE objects,
see the Impress Guide.

Working with master slides
A master slide is a slide that is used as the starting point for other slides. It is similar to a page
style in LibreOffice Writer as it controls the basic formatting of all slides based on it. A
presentation can have more than one master slide.
A master slide has a defined set of characteristics, including the background color, graphic, or
gradient. It also can include objects (for example, logos, decorative lines) in the background;
headers and footers; placement and size of text frames; and text formatting.

Styles
All of the characteristics of master slides are controlled by styles. The styles of any new slide
created are inherited from the master slide from which it was created. In other words, the styles
of the master slide are available and applied to all slides created from that master slide.
Changing a style in a master slide results in changes to all the slides based on that master slide.
It is possible to modify each individual slide without affecting the master slide.
Master slides have two types of styles: presentation styles and drawing styles. The presentation
styles included with Impress can be modified, but new presentation styles cannot be created or
deleted. The drawing styles included with Impress can be modified, but cannot be deleted.
However, new drawing styles can be created and these drawing styles can be deleted.

Note
It is highly recommended to use the master slides whenever possible. However,
there are occasions where manual changes are needed for a particular slide, for
example editing an individual slide to enlarge the chart area when the text and chart
layout is used.
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Master slides
Impress comes with a collection of master slides, which are are shown on the Master Slides deck
of the Sidebar (Figure 163).

Figure 163: Master Slides deck on Sidebar

Figure 164: Default master slide
This deck has three panels: Used in This Presentation, Recently Used, and Available for
Use. Click the expand marker on the title bar of a panel to expand it and show thumbnails of the
master slides, or click the collapse marker to collapse the panel to hide the thumbnails.
Each of the master slides shown in the Available for Use panel is from a template of the same
name. These presentation templates are included when LibreOffice is installed on a computer. If
templates have been created or added from other sources, master slides from those templates
also appear in this list.
If a new presentation is created without using one of the templates available, then a default
master slide is available. This default master slide is a good starting point for creating master
slides. An example of the default master slide is shown in Figure 164.
Chapter 6, Getting Started with Impress | 203

Creating master slides
1) Go to View > Master Slide on the Menu bar to open Master view in the Workspace. The
Master View toolbar also opens (Figure 165). If the Master View toolbar does not open,
go to View > Toolbars on the Menu bar and select Master View.
2) Create a new master slide using one of the following methods. The new master slide
appears in the Slides pane:
– Click on New Master in the Master View toolbar.
– Right-click on a master slide in the Slides pane and select New Master in the context
menu.
– Go to Slide > New Master on the Menu bar.
3) Rename the new master slide using one of the following methods to open the Rename
Master Slide dialog:
– Click on Rename Master on the Master View toolbar.
– Right-click on the new master slide in the Slides Pane and select Rename Master in
the context menu.

Figure 165: Master
View toolbar
4) Enter a memorable name for the new master slide, then click OK to save the changes
and close the dialog.
5) Make sure the new master slide is selected in the Slides pane and add all the text,
graphics and master elements that are required. For more information on adding, editing,
formatting and managing the different types of objects on a master slide, see the Impress
Guide.
6) When the new master slide has been created, use one of the following methods to return
to Normal view:
– Click Close Master View on the Master View toolbar.
– Go to View > Normal on the Menu bar.
7) Save the presentation file before continuing.

Applying master slides
To apply a master slide to all slides or selected slides in a presentation:
1) Click on Master Slides on the right of the Sidebar to open the Master Slides deck.
2) Right-click on the required master slide in the Used in This Presentation panel.
3) Select Apply to All Slides or Apply to Selected Slides in the context menu.

Loading additional master slides
In a presentation, it may be necessary to mix multiple master slides that belong to different
templates (for more information on templates, see the Impress Guide). For example, a
completely different layout for the first slide of the presentation maybe required, or a slide from a
different presentation maybe added to the current presentation.
1) Select the slide or slides on the Slides pane where the master slide is to be changed.
2) Go to Slide > Change Slide Master on the Menu bar to open the Available Master Slides
dialog (Figure 166).
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Figure 166: Available Master Slides dialog

Figure 167: Load Master Slide dialog
3) To add master slides, click on Load to open the Load Master Slide dialog (Figure 167).
4) In the Load Master Slide dialog, select the template category and the template from which
to load the master slide
5) Click OK to close the Load Master Slide dialog and the master slides from the selected
template appear in the Available Master Slides dialog.
6) In the Available Master Slides dialog, select the master slide required in the Select a
Slide Design box.
7) To apply the selected master slide to all slides in the presentation, select the Exchange
background page check box. To apply the slide design to the selected slides only,
deselect the Exchange background page check box.
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8) Click OK to apply the selection to the slides and close the dialog.

Note
The master slides in the template selected are now shown in the Available for use
panel on the Master Slides deck on the Sidebar.

Modifying master slides
The following items can be changed on a master slide. For more information, see the Impress
Guide:
•

Background (color, gradient, hatching, or bitmap).

•

Background objects (for example, adding a logo or decorative graphics).

•

Text attributes for the main text area and notes.

•

Size, placement, and contents of header and footer elements to appear on every slide.

•

Size and placement of default frames for slide titles and content.

To modify a master slide, follow these steps:
1) Select View > Master Slide on the Menu bar. This also opens the Master View toolbar.
2) Select a master slide for editing in the Slides pane so that it appears in the Workspace.

Figure 168: Slide Properties dialog - Slide page
3) Go to Slide > Slide Properties on the Menu bar or right-click in the Workspace and
select Slide Properties in the context menu to open the Slide Properties dialog
(Figure 168).
4) Use the various options in the Slide, Background, and Transparency pages in the Slide
Properties dialog to make changes to the format of the master slide.
5) Click OK to save the changes and close the Slide Properties dialog.
6) Select an object on the master slide, then right-click on the object to open a context
menu.
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7) Select one of the options in the context menu to edit the object. Selecting an option may
open another context menu, a dialog, an application or file browser window to make the
necessary changes to the selected object.
8) Click Close Master View on the Master View toolbar or go to View > Normal on the
Menu bar to exit from editing master slides.
9) Save the presentation file before continuing.

Note
Any changes made to one slide when in Master Slide mode appears on all slides
using this master slide. Always make sure to close Master Slide and return to
Normal view before working on any of the presentation slides.

Note
The changes made to an element on a slide in Normal view is not overridden by
subsequent changes to the master slide. There are cases, however, where it is
desirable to change a manually modified element of a slide to the style defined in the
master slide. To change to default formatting, select the element and select Format
> Clear Direct Formatting on the Menu bar.

Adding text, footers, and fields to master slides
Text, footers, or fields can be added to a master slide so those elements appear on every slide in
a presentation. Headers are not normally added to slides.

Text
1) Go to View > Master Slide on the Menu bar to open Master View.
2) Insert a text box on the master slide, see “Text boxes” on page 190 for more information.
3) Type or paste the text into the text box.
4) Click outside the text box when finished adding text.
5) Go to View > Normal on the Menu bar or click Close Master View on the Master View
toolbar when finished.

Default footers
By default, a slide footer consists of three sections, each containing a default field:
•

Left section – date and time, labelled Date Area. Field name is <date/time>.

•

Center section – footer text, labelled Footer Area. Field name is <footer>. This section
could be the presentation title, file name, or other information.

•

Right section – slide number, labelled Slide Number Area. Field name is <number>.

The default footer fields are set up as follows using the Header and Footer dialog (Figure 169):
1) Go to View > Master Slide on the Menu bar to open Master View.
2) Go to Insert > Header and Footer on the Menu bar to open the Header and Footer
dialog.
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Figure 169: Header and Footer dialog - Slides page
3) Click on the Slides tab to open the options available for inserting footers onto a slide.
4) Select Date and Time for the date and time to appear in the left section of the footer.
– For a fixed date and time, select Fixed and enter the date required in the Fixed text
box.
– For a variable date and time, select Variable, then select the format and language in
the Format and Language drop-down lists. Using a variable date and time means that
each time the presentation is opened, the date and time are updated.
5) To place text in the footer center section, select Footer and then type or paste the text
into the Footer text input field.
6) To place the slide number in the right section of the footer, select Slide number.
7) If the footer is not going to appear on the first slide of a presentation, select Do not show
on the first slide. The first slide is normally the title slide of a presentation.
8) Click Apply to save the changes and close the Header and Footer dialog.
9) To format the text used for the default footer fields, see the Impress Guide.
10) Click Close Master View on the Master View toolbar or go to View > Normal on the
Menu bar when setting up the default footer fields is completed.

Note
The default sections in a footer can be formatted, resized, and repositioned. See
“Adding and formatting text” on page 189 for more information.
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Custom footers
The default fields in a footer section can be replaced with text or manual fields as follows:
1) Go to View > Master Slide on the Menu bar to open the master slide view.
2) Highlight the default field in the footer section and press the Delete or Backspace key. A
flashing text cursor will appear in the footer section and the Text Formatting toolbar
automatically opens replacing the Line and Filling toolbar.
3) Type in the required text or insert a manual field into the footer section. For more
information, see “Manual fields” on page 209.
4) Format the text or manual field placed in the footer section. See “Adding and formatting
text” on page 189 and the Impress Guide for more information.
5) Click outside the footer section to close the Text Formatting toolbar and reopen the Line
and Filling toolbar.
6) Click Close Master View on the Master View toolbar or go to View > Normal on the
Menu bar when setting up a custom footer section is completed.

Manual fields
Manual fields can be added as text objects on a master slide or replace one of the default footer
fields and are as follows:
•
•
•
•
•
•
•
•
•

Date (fixed)
Date (variable) – updates automatically each time the presentation is opened.
Time (fixed)
Time (variable) – updates automatically each time the presentation is opened and each
time a slide is opened more than once during a presentation.
Author – first and last names listed in the LibreOffice user data.
Slide number – the sequence number of the slide, without the word “Slide”.
Slide Title – defaults to Slide 1, Slide 2, and so on if the slides have not been renamed.
Slide Count – the number of slides in the presentation.
File Name

Tip
To change the author information, go to Tools > Options > LibreOffice > User Data
on the Menu bar.

Adding comments
Impress supports comments similar to those in Writer and Calc. For more about adding,
navigating, and replying to comments, see Chapter 4, Getting Started with Writer.
Before using comments, make sure that the user name and initials are entered into Tools >
Options > LibreOffice > User Data. The name and initials then appear in the comment marker
and in the Author field of the comment. If more than one person edits the document, each person
is automatically allocated a different background color.
1) In Normal View, go to Insert > Comment on the Menu bar or use the keyboard shortcut
Ctrl+Alt+C to open a blank comment (Figure 170).
A small box containing the user initials appears in the upper left-hand corner of the slide,
with a larger text box beside it. Impress automatically adds the user name and current
date at the bottom of the text box.
2) Type or paste the comment into the text box.
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3) Move the small comment markers to the required position on the slide. Normally, this is
on or near the text or object being referred to in the comment.
4) To show or hide the comment markers, choose View > Comments on the Menu bar.
5) Select Tools > Options > LibreOffice > User Data to configure the name and initials
that appear in comments.

Figure 170: Adding a comment

Figure 171: Example of Master Handout layout
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Figure 172: Header and Footer dialog - Notes and Handouts page

Figure 173: Example of Print dialog – LibreOffice Impress page
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Printing handouts
Handouts are used for distributing copies of presentation slides to each member of the audience.
Handouts are only available in View > Handout on the Menu bar and are printed using the
printing options in Impress.
The printing of handouts depends on the printer, computer operating system, and how a
computer is set up. The following is only an example of how to print handouts.
1) Go to View > Master Handout on the Menu bar to open the Master Handout layout in the
Workspace. An example Master Handout is shown in Figure 171.
2) Go to Insert > Header and Footer on the Menu bar to open the Header and Footer
dialog (Figure 172).
3) Click on Notes and Handouts tab, the select the required header and footer options as
follows:
– Select Header and then enter text in the Header text: text box.
– Select Date and time and then select either Fixed or Variable for the date and time.
– If a fixed date and time was selected, enter the date and/or in the text box.
– If a variable date and time was selected, select the Format for the date and time in the
drop-down list.
– If a variable date and time was selected, select the Language to set the options for the
date and time format in the drop-down list.
– Select Footer and then enter text in the Footer text: text box.
– Select Page Number if you want the handout pages numbered.
4) Click on Apply to All to save the options for the handouts and close the Header and
Footer dialog.
5) Go to File > Print on the Menu bar or use the keyboard shortcut Ctrl+P (macOS ⌘+P) to
open the Print dialog and click on the LibreOffice Impress tab to open the page for
printing options of handouts. An example Print dialog is shown in Figure 173.
6) In Document, select the required options in the drop-down lists as follows:
– Type: – select Handouts in the drop-down list.
– Slides per page: – select how many slides are printed on a sheet of paper.
– Order: – select the order in which the slides are printed on a sheet of paper.
7) In Contents, select Slide name, Date and time, and/or Hidden pages if these items are to
be printed.
8) In Color, select how the handouts are printed.
9) In Size, select the size for how the handouts are printed.
10) Click on Print to print the handouts and close the Print dialog.

Creating a photo album
Impress can create a photo album from a set of photographs and images. The photo album can
be a multimedia show with vacation pictures and/or graphics and images as a presentation file.
1) Create a new presentation or open an existing presentation.
2) Select the slide that is going to precede the photo album. In a new presentation, this will
be the first slide.
3) Go to Insert > Media > Photo Album on the Menu bar to open the Create Photo Album
dialog (Figure 174).
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4) Click on Add to open a file browser and navigate to the folder where the images are
located.
5) Select the images required and click Open. This closes the file browser and the selected
files appear in the Create Photo Album dialog.

Figure 174: Create Photo Album dialog
6) Select the number of images per slide in the Slide layout: drop-down list.
7) If required, select Add caption to each slide. This inserts a text box on each slide allowing
captions to be added to the images.
8) If required and there is only one image per slide, select Fill Screen for each image to fill
the entire slide.
9) Create the required sequence of photos or pictures by moving image files up or down in
the list of images.
10) When the sequence of images is ready, click Insert Slides to create the number of slides
required for the photo album. The sequence can be changed later.
11) If required, copy and paste images between slides as with any other elements that can be
placed on a slide.
12) If required, set up the photo album to run as a presentation. See “Presentations (slide
shows)” below, “Running presentations” on page 219, and the Impress Guide.

Presentations (slide shows)
Impress allocates reasonable default settings for presentations, while at the same time allowing
for customizing many aspects of the presentation experience. This section provides an
introduction to presentations. For more information on creating, formatting and running
presentations, see the Impress Guide.
Most of the tasks are best done in Slide Sorter view in the Workspace where the majority of the
slides in a presentation can be viewed. Go to View > Slide Sorter on the Menu bar or click on
the Slide Sorter tab at the top of the Workspace.

Chapter 6, Getting Started with Impress | 213

Multiple presentations – single set of slides
There may be more slides than the time available for a presentation, or only a brief overview is
required first and then a more detailed presentation at a later date. Impress provides two tools for
this: hiding slides and custom slide shows.

Hiding slides
1) Select slides for hiding in the Slides pane or Slide Sorter view in the Workspace.
2) Hide the selected slides using one of the following methods. Hidden slides are greyed out
in the Slides pane or Slide Sorter view in the Workspace.
– Go to Slide > Hide Slide on the Menu bar.
– Right-click on the slide thumbnail and select Hide Slide in the context menu.
– Click on Hide Slide in the Slide View toolbar.
3) To show a hidden slide, use one of the following methods.
– Go to Slide > Show Slide on the Menu bar.
– Right-click on the hidden slide thumbnail and select Show Slide in the context menu.
– Click on Show Slide in the Slide View toolbar.

Custom slide shows
1) Select the slides required for a custom slide show in the Slides pane or Slide Sorter
view in the Workspace.
2) Go to Slide Show > Custom Slide Show on the Menu bar to open the Custom Slide
Shows dialog (Figure 175).
3) Click on New and the Define Custom Slide Show dialog opens (Figure 176).

Figure 175: Custom Slide Shows dialog
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Figure 176: Define Custom Slide Show dialog
4) Type a name for the new custom slide show in the Name text box.
5) In the Existing slides list, select the slides to include in the show.
6) Click the >> button to include the slides in the Selected slides list. Several slides can be
selected and included at the same time. Hold down the Shift key and click the first and
last slide in a group to select that group, or hold down the Ctrl key (macOS ⌘)and click
on individual slides to select them.
7) If required, rearrange the slide order in the Selected slides list. Click on a slide name
and drag it to a new position in the list, then release the mouse button.
8) Click OK to save the custom slide show and return to the Custom Slide Shows dialog.
9) To activate a custom show, select it in the list in the Custom Slide Shows dialog and then
select the Use custom slide show option.
10) Click Start to test the custom slide show or click OK to close the Custom Slide Shows
dialog.

Slide transition
Slide transitions are effects and/or sounds that take place between slides when slides change in
a presentation and can add a professional look to a presentation, smoothing the change over
between slides. For more information on how to setup slide transitions, modify slide transitions,
and to advance slides in a presentation, see the Impress Guide.
1) Click on Slide Transition in the Sidebar to open the Slide Transition deck (Figure 177).
2) In the Slides pane or Slide Sorter view in the Workspace, select the slides where slide
transitions are going to be applied.
3) Click on a transition to apply it to the selected slide.
4) To apply the same transition to all slides in the presentation, click Apply Transition to All
Slides at the bottom of the Slides Transition deck.

Chapter 6, Getting Started with Impress | 215

Figure 177: Slide Transition deck on the
Sidebar
5) To check how the transition looks, click Play at the bottom of the Slides Transition deck.
Alternatively, to automatically preview how the transition looks when it is applied, select
Automatic Preview at the bottom of the Slides Transition deck.
6) In the Advance Slide section, select how the slides change in a presentation.
– On mouse click – each time the mouse is clicked, the presentation advances to the
next slide.
– Automatically after – enter a time in box to elapse before the next slide in the
presentation advances into view.

Playing sounds or music
Sound or music can be played during a presentation as a transition effect. When using music in a
presentation, make sure any copyright or license for the music is not being infringed.
1) Click on Slide Transition on the Sidebar to open the Slide Transition deck.
2) In the Slides pane or Slide Sorter view in the Workspace, select the slide to add sound
or music.
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3) In the Modify Transition section, select a sound in the Sound drop-down list.
4) To play music, use the following steps to select a music file:
a) Select Other sound in the Sound drop-down list.
b) In the file browser window that opens, navigate to where the music file is located.
c) Select the music file required and click Play to check if the music is suitable.
d) If the music is suitable, click Open to add the music to the selected slide and close
the file browser window.
5) To play a sound or music file continuously in the slide show, select the option Loop until
next sound. The sound or music file restarts once it is finished until the next sound or
music file that is inserted in the slide show.

Note
Do not select the Apply Transition to All Slides option, otherwise the selected music
file restarts at every slide.

Note
The sound or music file is linked to a presentation rather than embedded. If the
presentation is going to be displayed on a different computer, remember to make
sure that the music file is available on the computer where the presentation will be
played. The link to the sound or music file must be established before starting the
presentation.

Animation effects
Slide animations are similar to transitions, but they are applied to individual elements in a single
slide, such as title, chart, shape, or individual bullet point. Animations can make a presentation
more lively and memorable. However, as with transitions, heavy use of animations can be
distracting and even annoying for an audience expecting a professional presentation.
Animations are best applied using Normal view in the Workspace so that you can easily select
individual objects on a single slide.
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Figure 178: Animation deck in Sidebar
On a slide, an element such as a graphic or an entire text box has selection handles around it
when selected. If you select only a portion of the text in a text box, any selection handles may not
be visible. For more information on animation effects, see the Impress Guide.
1) Go to View > Normal on the Menu bar to open Normal view in the Workspace.
2) Select an element on a slide for animation.
3) On the Sidebar, select Animation to open the Animation deck (Figure 178).
4) Select a slide in the Animation panel and then click on Add Effect (+ plus sign) in the
Effects panel to open the animation options.
a) Select an animation category in the Category drop-down list.
b) Select an animation effect from the available options in the Effect list.
c) Select how the animation starts in the Start drop-down list.
d) Select the direction of the animation in the Direction drop-down list.
e) Enter a time for the duration of the animation in the Duration box.
f) Enter a time for the delay of when the animation starts in the Delay box.
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5) If required, select Automatic Preview so that how the animation looks can be checked
when applied to a slide element.
6) Click Play to check how the animation looks when applied to a slide element.

Running presentations
1) Open the presentation and start the slide show using one of the following methods:
– Use the keyboard shortcut F5 to start from the first slide or Shift+F5 to start from the
current slide.
– Go to Slide Show > Start from First Slide or Start from Current Slide on the Menu
bar.
– Click on Start from First Slide on the Slide Sorter toolbar.
2) If the slide transition is set to Automatically after x sec, the slide show starts and runs
after the set time has elapsed.
3) If the slide transition is set to On mouse click, click the left mouse button, or press the
down arrow key, the right arrow key, the page down key, or the spacebar.
4) To navigate backwards through a slide show one slide at a time, press the up arrow key,
the left arrow key, or the page up key.
5) To access more navigation options during a slide-show, right-click on a slide and use the
options available in the context menu.
6) When the last slide has displayed, the message Click to exit presentation... is displayed
on screen. Press the Esc key or click the left mouse button to exit the slide show.
7) To exit the slide show and return to the Impress workspace at any time, press the Esc key
during the slide show.

Note
During the presentation, any animations on a slide are run in the specified order as
the slide is displayed.

Presenter Console
The Presenter Console provides extra control over slide shows when using dual displays, such
as a laptop and a large display or projector for an audience. The view seen on a laptop display
includes the current slide that can be seen by the audience, the next slide in the presentation,
any slide notes, and a presentation timer.

Note
The Presenter Console only works with operating systems that support two displays.
When two displays are being used, one display can be a laptop.
The Presenter Console has to be enabled in Impress before use. Go to Tools > Options >
LibreOffice Impress > General (Figure 179) and select Enable Presenter Console in
Presentation.
The Presenter Console provides the following views for making a presentation:
•

Default view – displays the current slide, including any effects and the next slide in the
presentation (Figure 180). Click on the Previous and Next arrows to navigate through the
presentation.

•

Notes view – click on Notes to switch to display any notes that accompany each slide in
the presentation (Figure 181). Click on Notes again to return to the default view.
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•

Slides view – click on Slides to switch to display the slide thumbnails that are being used
for the presentation (Figure 182). Click on Slides again to return to the default view.

•

Exchange – click on this icon to switch the Presenter Console between displays.

Figure 179: Options LibreOffice Impress General dialog

Figure 180: Presenter Console - Default view
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Figure 181: Presenter Console - Notes view

Figure 182: Presenter Console - Slides view
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Getting Started Guide 7.3

Chapter 7,
Getting Started with Draw
Vector Drawing in LibreOffice

What is Draw?
LibreOffice Draw is a vector graphics drawing program. It can also perform some operations on
raster graphics (pixels). Using Draw, a wide variety of graphical images are easily and quickly
created.
Vector graphics store and display an image as an assembly of simple geometric elements such
as lines, circles, and polygons, rather than a collection of pixels (points on the screen). Vector
graphics allow for easier storage and scaling of the image.
Draw is fully integrated into the LibreOffice suite simplifying the exchange of graphics with all
components of the LibreOffice suite. If an image is created in Draw, reusing it in a Writer
document is relatively easy. For example, select and copy the drawing in Draw and then paste
the image directly into a Writer document. Also, drawings can be worked on directly from within
Writer or Impress, using a subset of the functions and tools from Draw.
The functionality of Draw is extensive. Draw was not designed to rival high-end graphics
applications, but it possesses more functionality than the drawing tools that are integrated with
many office productivity suites. A few examples of the drawing functions are as follows:
Layer management
Magnetic grid-point system
Dimensions and measurement display
Connectors for making organization charts and other diagrams
3D functions for creating small three-dimensional drawings
Drawing and page-style integration
Bézier curves
This chapter introduces some features of Draw, but it does not attempt to cover all of the Draw
features. See the Draw Guide and LibreOffice Help for more information.

Figure 183: Draw main window
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Draw main window
Workspace
The large area in the center of the Draw main window (Figure 183) is the Workspace, where
drawings are created. This drawing area can be surrounded with toolbars and information areas.
The number and position of the visible tools vary with the task in hand, user preferences, and
computer setup.
The maximum size of a drawing page in Draw is limited by the computer setup and the page size
that that can be set and used in the printer connected to the computer.

Pages pane
Drawings can be split over several pages. Multi-page drawings are used mainly for
presentations. The Pages pane on the left side of the Draw main window provides an overview of
the pages that are created in a drawing. If the Pages pane is not visible, go to View > Page Pane
on the Menu bar. The Pages pane is also used to make changes to the page order by dragging
and dropping one or more pages.

Layers bar
A layer is a workplace where drawing elements and objects can be inserted. By default, the
Workspace consists of three layers (Layout, Controls, and Dimension Lines). These default
layers cannot be deleted or renamed, but layers can be added when necessary.
Tabs for default and other layers appear in the Layers bar at the bottom of the Workspace. The
Layers bar can be used to navigate between layers, add layers as required, or delete layers that
have been added. For more information, see “Working with layers” on page 251.

Sidebar
The Sidebar in Draw is similar to the Sidebar in the other LibreOffice components. In Draw, it has
five main decks. To open a deck, click on its icon on the right of the Sidebar, or click on the
Sidebar Settings icon at the top of the tab bar and select a deck in the drop-down list. If the
Sidebar is not visible, go to View > Sidebar on the Menu bar.
Properties
Contains panels where properties of a selected object in a drawing can be changed: Page,
Character, Paragraph, Area, Effect, Shadow, Line, Position and Size, Columns, and
Image. Available panels depend on the selected object.
Styles
Provides options to edit and apply one of the available Drawing Styles to objects in a
drawing. When a style is edited or modified, the changes are automatically applied to all of
the elements formatted using that style. In Draw, Presentation Styles are not available.
New drawing styles can be added to a drawing.
Gallery
Objects on the Gallery deck can be inserted into a drawing either as a copy or as a link.
The Gallery is divided into themes: Arrows, BPMN (Business Process Model and
Notation), Bullets, Diagrams, Flowchart, Icons, Network, Shapes, and Sounds. New
themes can be added to the Gallery. See Chapter 11, Images and Graphics, and the Draw
Guide for more information.
Navigator
On the Navigator deck, pages and objects in a drawing can be quickly selected. It is
recommended to give pages and objects meaningful names so they are easily identified
when using the Navigator.
224 | LibreOffice 7.3 Getting Started Guide

Shapes
Provides quick selection of most items that are available on the Drawing toolbar: Lines and
Arrows, Curves and Polygons, Connectors, Basic Shapes, Symbol Shapes, Block
Arrows, Flowchart, Callouts, Stars and Banners, and 3D Objects.

Rulers
Rulers are positioned on the upper and left-hand sides of the Workspace. If the rulers are not
visible, go to View > Rulers on the Menu bar. The rulers show the size of a selected object using
double lines (highlighted in Figure 184). Also the rulers can be used to manage object handles
and guide lines when positioning objects.
The page margins in the drawing area are also represented on the rulers. The margins can be
changed directly on the rulers by dragging the margins with the cursor. The margin areas are
indicated by the grayed-out area on the rulers (Figure 184).
To change the measurement units of the rulers, right-click on a ruler and select the measurement
unit in the drop-down list, as shown in Figure 185 for the horizontal ruler. The horizontal and
vertical rulers can be set to different measurement units.

Figure 184: Rulers showing object size

Figure 185: Ruler measurement units
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Figure 186: Status bar

Status bar
The Status bar (Figure 186) is located at the bottom of the Workspace in all LibreOffice
components. It includes several Draw-specific fields. For details on the contents and use of these
fields, see Chapter 1, Introducing LibreOffice, in this guide and the Draw Guide. To hide the
Status Bar, go to View on the Menu bar and deselect Status Bar.

Note
The measurement units shown on the Status Bar are set by going to Tools >
Options > LibreOffice Draw > General on the Menu bar. These units may be
different to the measurement units set for the rulers.

Toolbars
To display or hide the various Draw toolbars, go to View > Toolbars on the Menu bar and select
them in the drop-down menu. For more information on toolbars, see the Draw Guide.
The icons used for the tools on each toolbar depend on the computer operating system and how
LibreOffice has been set up on a computer. For more information, see Chapter 2, Setting Up
LibreOffice.
The three main toolbars used in Draw are:
•

Standard – this toolbar is similar for all LibreOffice components. By default it is docked at
the top of the Workspace when a Draw document is opened (Figure 187).

Figure 187: Standard toolbar
•

Drawing – this toolbar contains all the necessary functions for drawing various geometric
and freehand shapes, and for organizing them in the drawing. By default, it is locked into
position on the left of the Workspace (Figure 188).

Figure 188: Drawing toolbar
•

Line and Filling – this toolbar is normally docked at the top of the Workspace below the
Standard toolbar. The tools and pull-down lists on this toolbar vary according to the type
of object selected. The Line and Filling toolbar (Figure 189) only becomes active when an
object on the Workspace is selected.
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Figure 189: Line and Filling toolbar

Drawing basic shapes
Draw provides a wide range of shapes, located in palettes accessed on the Drawing toolbar or in
the Shapes deck on the Sidebar (Figure 190). See the Draw Guide for a complete description of
the basic shapes available.
Some of the tool icons on the Drawing toolbar change according to the shape that has been
selected. Also, some tools on a toolbar have extra tool palettes available and these are indicated
by a triangle ▼ to the right of the tool icon.

Note
When drawing a basic shape or selecting one for editing, the Information field in the
Status bar changes to reflect the present action, for example Line created, Text
frame xxyy selected, and so on.

Figure 190: Shapes deck on Sidebar
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Straight lines
1) Use one of the following methods to start drawing a line:
– Click on Insert Line on the Drawing toolbar.
– Click the triangle ▼ on the right of Lines and Arrows on the Drawing toolbar and
select Insert Line in the drop-down list.
– Click on Insert Line in the Lines and Arrows panel of the Shapes deck on the
Sidebar (Figure 190).
2) Place the cursor at the starting point on the drawing, then click and drag the cursor to
draw a straight line.
3) Release the mouse button when the end point is reached and a straight line is created. A
selection handle appears at each end of the line, showing that this object is the currently
selected object. The selection handle at the starting point of the line is slightly larger than
the other selection handle (as shown in Figure 191).

Figure 191: Line starting point

Figure 192: Line panel in Properties deck on
Sidebar
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Tip
To snap the end of a line to the nearest grid point, keep the Ctrl key (macOS ⌘)
pressed while drawing the line. However, if the Snap to Grid option in View > Snap
Guides on the Menu bar has been selected, the Ctrl key (macOS ⌘) deactivates the
snap to grid.
To restrict the drawing angle of a line to a multiple of 45 degrees (0, 45, 90, 135, and
so on), keep the Shift key pressed while drawing the line. However, if the option
When creating or moving objects in the Constrain Objects section of Tools >
Options > LibreOffice Draw > Grid has been selected, the Shift key deactivates
this restriction.
To draw a line symmetrically outwards in both directions from the start point, keep
the Alt key (macOS ⌥) pressed while drawing the line. This draws lines by starting
from the center of the line.
A line is drawn using default attributes. To change line attributes and format a line to the drawing
requirements, select the line by clicking on it and use one of the following methods to access
formatting options for the line:
•

Go to the Properties deck on the Sidebar and open the Line panel (Figure 192).

•

Right-click on a line and select Line in the context menu to open the Line dialog
(Figure 193).

•

Go to Format > Line on the Menu bar to open the Line dialog.

•

Use the tools Line Style, Line Width, and Line Color on the Line and Filling toolbar.

Figure 193: Line dialog - Line page
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Figure 194: Line and Arrows subtoolbar

Arrows
Draw classifies both lines and arrows as lines. Arrows are drawn like straight lines. Hovering the
cursor over each tool in the Lines and Arrows sub-toolbar (Figure 194) indicates what type of line
or arrow each tool will draw. The information field on the Status Bar shows them only as lines.
1) Use one of the following methods to start drawing an arrow:
– Click the triangle ▼ on the right of Lines and Arrows on the Drawing toolbar and
select the type of arrow required from the Lines and Arrows sub-toolbar (Figure 194).
– Click on the type of arrow required in the Lines and Arrows panel of the Shapes
deck on the Sidebar.
2) Place the cursor at the starting point of the arrow, then click and drag the cursor. The
arrowhead is drawn when the mouse button is released.

Note
The tool icon for the Lines and Arrows tool used most recently will be shown on the
Drawing toolbar. This makes it easier to use the same tool again.

Note
After drawing a line or arrow, the line or arrow style can be changed by opening the
Line dialog and using the options available on the Line Styles or Arrow Styles pages.

Rectangles
1) Use one of the following methods to start drawing a rectangle:
– Click on Rectangle on the Drawing toolbar.
– Click the triangle ▼ on the right of Basic Shapes on the Drawing toolbar and select
Rectangle on the Basic Shapes sub-toolbar (Figure 195).
– Click on Rectangle in the Basic Shapes panel of the Shapes deck on the Sidebar.
– Select the type of rectangle on the Legacy Rectangles toolbar (Figure 196). To display
the toolbar, go to View > Toolbars on the Menu bar and select it.
2) Place the cursor at the starting point for the rectangle, then click and drag the cursor until
the required size is drawn. As the rectangle is drawn, the rectangle appears with its
bottom right corner attached to the cursor.
3) To draw a rectangle from its center, position the cursor on the drawing, press the mouse
button and then hold down the Alt key (macOS ⌥) while dragging the cursor. The
rectangle uses the start point as the center of the rectangle.

Figure 195: Basic Shapes sub-toolbar
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Figure 196: Legacy Rectangles
toolbar

Squares
1) Use one of the following methods to start drawing a square:
– Click on Rectangle on the Drawing toolbar, then hold down the Shift key while
dragging the cursor to draw a square.
– Click the triangle ▼ on the right of Basic Shapes on the Drawing toolbar and select
Square on the Basic Shapes sub-toolbar (Figure 195).
– Click on Square in the Basic Shapes panel of the Shapes deck on the Sidebar.
– Select the type of square from the Legacy Rectangles toolbar (Figure 196). To display
the toolbar, go to View > Toolbars on the Menu bar and select it.
2) Place the cursor at the starting point for the square, then click and drag the cursor until
the required size is drawn. As the square is drawn, the square appears with its bottom
right corner attached to the cursor.
3) To draw a square from its center, position the cursor on the drawing, press the mouse
button and then hold down the Alt key (macOS ⌥) while dragging the cursor. The square
uses the start point as the center of the square.

Ellipses (ovals)
1) Use one of the following methods to start drawing an ellipse:
– Click on Ellipse on the Drawing toolbar.
– Click the triangle ▼ on the right of Basic Shapes on the Drawing toolbar and select
Ellipse on the Basic Shapes sub-toolbar (Figure 195).
– Click on Ellipse in the Basic Shapes panel of the Shapes deck on the Sidebar.
– Select the type of ellipse on the Legacy Circles and Ovals toolbar (Figure 197). To
display the toolbar, go to View > Toolbars on the Menu bar and select it.
2) Place the cursor at the starting point for the ellipse, then click and drag the cursor until
the required size is drawn. As the ellipse is drawn, the ellipse appears with its bottom
right corner attached to the cursor.
3) To draw an ellipse from its center, position the cursor on the drawing, press the mouse
button and then hold down the Alt key (macOS ⌥) while dragging with the cursor. The
ellipse uses the start point as the center of the ellipse.

Figure 197: Legacy Circles and Ovals toolbar

Circles
1) Use one of the following methods to start drawing a circle:
– Click on Ellipse on the Drawing toolbar, then hold down the Shift key while dragging
the cursor to draw a circle.
– Click the triangle ▼ on the right of Basic Shapes on the Drawing toolbar and select
Circle on the Basic Shapes sub-toolbar (Figure 195).
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– Click on Circle in the Basic Shapes panel of the Shapes deck on the Sidebar.
– Select the type of circle on the Legacy Circles and Ovals toolbar (Figure 197). To
display the toolbar, go to View > Toolbars on the Menu bar and select it.
2) Place the cursor at the starting point for the circle, then click and drag the cursor until the
required size is drawn. As the circle is drawn, the circle appears with its bottom right
corner attached to the cursor.
3) To draw a circle from its center, position the cursor on the drawing, press the mouse
button and then hold down the Alt key (macOS ⌥) while dragging with the cursor. The
circle uses the start point as the center of the circle.

Tip
To quickly insert a line, rectangle, ellipse, or circle, press and hold down the Ctrl key
(macOS ⌘) and then click on one of the icons for Line, Rectangle, Ellipse, or Circle
and a standard sized object is drawn automatically in the work area. The size, shape,
and Color are all standard values. These attributes can be changed later, if desired.
For more information, see the Draw Guide.

Dimension lines
Dimension lines display a measurement of an object in the drawing (Figure 198). The dimension
line does not belong to the object itself, but it is normally placed close to it.

Figure 198: Example of object
dimension lines
1) Use one of the following methods to start drawing a dimension line:
– Click the triangle ▼ on the right of Lines and Arrows on the Drawing toolbar and
select Dimension Line on the Lines and Arrows sub-toolbar that opens.
– Click on Dimension Line in the Lines and Arrows panel of the Shapes deck on the
Sidebar.
2) Place the cursor close to the object to position the start of the dimension line.
3) Click and drag the cursor to draw the dimension line. As the dimension line is drawn, the
dimension is displayed and automatically calculated. To change the measurement unit
used for dimension lines, go to Tools > Options > LibreOffice Draw > General on the
Menu bar.
4) To change the display of a dimension line and its appearance, right-click on the
dimension line and select Dimensions in the context menu to open the Dimension Line
dialog (Figure 199).
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5) Select the required options in Line and Legend, then click OK to save the changes and
close the Line Dimension dialog.

Figure 199: Dimension Line dialog

Curves
1) Use one of the following methods to start drawing a curve:
– Click the triangle ▼ on the right of Curves and Polygons on the Drawing toolbar and
select the type of curve on the Curves and Polygons sub-toolbar (Figure 200).
– Click on the type of curve required in the Curves and Polygons panel of the Shapes
deck on the Sidebar.
2) Click and hold the left mouse button to create the starting point of the curve, then drag
from the starting point to draw a line. Release the mouse button and continue to drag the
cursor to bend the line into a curve.
3) Double-click to set the end point of the curve and fix the curve on the drawing. A filled
curve automatically joins the last point to the first point, closing the curve and filling it with
the selected fill color. A curve without fill will not be closed at the end of drawing the curve.

Note
A single click fixes the curve to the drawing and allows drawing of straight lines from
the end of the curve. Each single click allows the drawing of another straight line.
Double-click to end drawing a curve with straight lines.

Figure 200: Curves and
Polygons sub-toolbar

Chapter 7, Getting Started with Draw | 233

Polygons
1) Use one of the following methods to start drawing a polygon:
– Click the triangle ▼ on the right of Curves and Polygons on the Drawing toolbar and
select the type of polygon on the Curves and Polygons sub-toolbar (Figure 200).
– Click on the type of polygon required in the Curves and Polygons panel of the
Shapes deck on the Sidebar.
2) Click and hold the left mouse button to create the starting point of the polygon, then drag
from the starting point to draw a line.
3) Release the mouse button and continue to drag the cursor to draw the next line for
polygon, then click to mark the end point of the line and to start drawing another line.
Holding the Shift key down while drawing lines restricts the angles used in the polygon to
45° or 90°.
4) Double-click to set the end point of the polygon and fix the polygon on the drawing. A
filled polygon automatically joins the last point to the first point, closing the polygon and
filling it with the selected fill Color. A polygon without fill will not be closed at the end of
drawing the polygon.

Polygons 45°
A polygon 45° is drawn using the same procedure as polygons, but the angles between lines are
restricted to 45° or 90°. This restriction of angles cannot be changed. However, and if required,
hold down the Shift key as the line is drawn so that the line is drawn at an angle other than 45 or
90 degrees.
A filled polygon 45° automatically joins the last point to the first point, closing the polygon and
filling it with the selected fill color.

Freeform lines
Drawing a freeform line is similar to drawing with a pencil on paper.
1) Use one of the following methods to start drawing a freeform line:
– Click the triangle ▼ on the right of Curves and Polygons on the Drawing toolbar and
select the type of freeform line on the Curves and Polygons sub-toolbar (Figure 200).
– Click on the type of freeform line required in the Curves and Polygons panel of the
Shapes deck on the Sidebar.
2) Click and drag the cursor to create the freeform line shape required.
3) Release the mouse button when satisfied with the freeform line and the drawing is
completed. A filled freeform line automatically joins the last point to the first point, closing
the freeform line and filling it with the selected fill color.

Glue points and connectors
Glue points
All Draw objects have glue points, which are not normally displayed. Glue points (Figure 201)
become visible on an object when a connector is selected on the Drawing toolbar or in the
Shapes deck on the Sidebar.
Most objects have four glue points (Figure 201). More glue points can be added and customized
using the Gluepoints toolbar (Figure 202). If the Gluepoints toolbar is not visible, go to View >
Toolbars > Gluepoints on the Menu bar to open the toolbar. For a more detailed description on
adding and using glue points, see the Draw Guide.
234 | LibreOffice 7.3 Getting Started Guide

Glue points are not the same as the selection handles of an object. Selection handles are for
moving or changing the shape of an object. Glue points are used to fix or glue a connector to an
object so that when the object moves, the connector stays fixed to the object.

Figure 201: Example of object glue points

Figure 202: Gluepoints toolbar

Connectors
Connectors are lines or arrows whose ends automatically snap to a glue point of an object.
Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps.
When objects are moved or reordered, the connectors remain attached to a glue point.
Figure 203 shows an example of using two objects and a connector. For a more detailed
description of the use of connectors, see the Draw Guide.
1) Use one of the following methods to select a connector:
– Click the triangle ▼ on the right of Connectors on the Drawing toolbar and select the
type of connector on the Connectors sub-toolbar (Figure 204).
– Click on the type of connector required in the Connectors panel of the Shapes deck
on the Sidebar.
2) Move the cursor over one of the objects to be connected. Small crosses (the glue points)
appear around the object edges. Click on the required glue point for the start of the
connector, then drag the cursor to drag the connector to another object.
3) When the cursor is over a glue point of the target object, release the mouse button and
the connector is drawn. The connector end point is attached to the glue point.

Figure 203: Example of a connector between two objects

Figure 204: Connectors sub-toolbar
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Geometric shapes
Geometric shapes are similar to basic shapes. They are provided in Draw as a starting point
when creating objects for a drawing. Geometric shapes are located on the Drawing toolbar and in
the Shapes deck on the Sidebar.
The tool icons on the Drawing toolbar always indicate the last geometric shape drawn. This
makes it easier to use the same tool again.
Access geometric shapes using one of the following methods:
•

Click on Shapes on the Sidebar to open the Shapes deck, then choose from the
geometric shapes available.

•

Click the triangle ▼ on the right of a geometric shape on the Drawing toolbar to open a
sub-toolbar giving access to more geometric shape tools.

Using geometric shapes is similar to drawing rectangles, squares, ellipses, or circles as
explained in “Drawing basic shapes” on page 227. Text can be added to all geometric shapes.
See “Adding and formatting text” on page 238 and the Draw Guide.

Basic shapes
The Basic Shapes sub-toolbar (Figure 205) also includes rectangle and ellipse tools that are
identical to the ones displayed on the Drawing toolbar.

Figure 205: Basic Shapes sub-toolbar
Basic shapes from left to right
(1) Rectangle
(9) Circle Pie
(2) Rectangle, Rounded
(10) Circle Segment
(3) Square
(11) Arc
(4) Square, Rounded
(12) Block Arc
(5) Parallelogram
(13) Isosceles Triangle
(6) Trapezoid
(14) Right-angle Triangle
(7) Ellipse
(15) Diamond
(8) Circle
(16) Regular Pentagon

(17) Hexagon
(18) Octagon
(19) Cylinder
(20) Cube
(21) Folded Corner
(22) Cross
(23) Frame
(24) Ring

Symbol shapes

Figure 206: Symbol Shapes sub-toolbar
Symbol shapes from left to right
(1) Smiley Face
(7) Flower
(2) Heart
(8) Prohibited
(3) Sun
(9) Puzzle
(4) Moon
(10) Square Bevel
(5) Cloud
(11) Octagonal Bevel
(6) Lightning Bolt
(12) Diamond Bevel
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(13) Double Bracket
(14) Left Bracket
(15) Right Bracket
(16) Double Brace
(17) Left Brace
(18) Right Brace

Block arrows

Figure 207: Block Arrows sub-toolbar
Block arrows from left to right
(1) Right Arrow
(10) Right or Left Arrow
(2) Left Arrow
(11) 4-way Arrow
(3) Down Arrow
(12) Corner Right Arrow
(4) Up Arrow
(13) Chevron
(5) Left and Right Arrow
(14) Pentagon
(6) Up and Down Arrow
(15) Striped Right Arrow
(7) Circular Arrow
(16) Up, Right and Down Arrow
(8) S-shaped Arrow
(17) Notched Right Arrow
(9) Split Arrow
(18) Up and Right Arrow

(19) Right Arrow Callout
(20) Left Arrow Callout
(21) Down Arrow Callout
(22) Up Arrow Callout
(23) Left and Right Arrow Callout
(24) Up and Down Arrow Callout
(25) 4-way Arrow Callout
(26) Up and Right Arrow Callout

Flowchart

Figure 208: Flowchart sub-toolbar
Flowchart shapes from left to right
(1) Flowchart: Process
(11) Flowchart: Manual Input
(21) Flowchart: Extract
(2) Flowchart: Alternate Process (12) Flowchart: Manual Operation (22) Flowchart: Merge
(3) Flowchart: Decision
(13) Flowchart: Connector
(23) Flowchart: Stored Data
(4) Flowchart: Data
(14) Flowchart: Off-page
(24) Flowchart: Delay
(5) Flowchart: Predefined
Connector
(25) Flowchart: Sequential Access
Process
(15) Flowchart: Card
(26) Flowchart: Magnetic Disc
(6) Flowchart: Internal Process (16) Flowchart: Punched Tape
(27) Flowchart: Direct Access
(7) Flowchart: Document
(17) Flowchart: Summing Junction
Storage
(8) Flowchart: Multidocument
(18) Flowchart: Or
(28) Flowchart: Display
(9) Flowchart: Terminator
(19) Flowchart: Collate
(10) Flowchart: Preparation
(20) Flowchart: Sort

Callout Shapes

Figure 209: Callouts
sub-toolbar
Callout Shapes from left to right
(1) Rectangular Callout
(4) Cloud
(2) Rounded Rectangular Callout (5) Line Callout 1
(3) Round Callout
(6) Line Callout 2

(7) Line Callout 3

Stars and banners

Figure 210: Stars and Banners sub-toolbar
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Stars and banners from left to right
(1) 4-Pointed Star
(5) 12-Pointed Star
(2) 5-Pointed Star
(6) 24-Pointed Star
(3) 6-Pointed Star
(7) Explosion
(4) 8-Pointed Star
(8) Vertical Scroll

(9) Horizontal Scroll
(10) Signet
(11) Door-plate
(12) 6-Point Star, Concave

3D objects

Figure 211: 3-D Objects
sub-toolbar
3D objects from left to right
(1) Cube
(4) Cone
(2) Sphere
(5) Pyramid
(3) Cylinder
(6) Torus

(7) Shell
(8) Hemisphere

Adding and formatting text
Drawings created in Draw are likely to contain some text. This section gives some guidelines on
how to add text and change its appearance. Text added to drawings can be contained in text
boxes, objects, or shapes. For more information on adding and formatting text, see the Draw
Guide.
•

A text box is an independent Draw object that is dynamic and expands as more text is
added within the frame.

•

An object or shape in a drawing is not dynamic, which means that the boundary rectangle
does not expand as text is added. Care must be taken when adding text to prevent the
text from extending outside the object or shape boundaries.

Text mode
Before adding any text to a drawing, text mode has to be activated using one of the following
methods:
•

Click on Insert Text Box on the Standard or Drawing toolbars.

•

Go to Insert > Text Box on the Menu bar.

•

Use the keyboard shortcut F2.

•

Double-click inside an object on the drawing. Text inside an object is not placed into a
text box.

The Text Formatting toolbar (Figure 212) automatically opens when text mode is activated,
replacing the Line and Filling toolbar.

Figure 212: Text Formatting toolbar
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Text boxes
1) Activate text mode as above.
2) Create a text box in the drawing using one of the following methods. The Status bar
indicates Text Edit mode and the position of the cursor (Figure 213).
– Click at the approximate position for the text box and a single line text box is created
containing a flashing cursor. Start typing the text or paste copied text into the text box.
The width of a single line text box increases as text is added.
– Click at the approximate position for the text and drag the cursor to the approximate
width required for the text box creating a multi-line text box. Start typing the text or
paste copied text into the text box. As the horizontal limit of the text box is reached,
the text automatically word wraps inside the text box and the text box expands
vertically as it fills.
– If necessary, create multiple lines of text in a single-line text box by pressing Enter to
create a new paragraph, or using Shift+Enter to create a line break in the text.
3) When adding text is complete, click outside the text box to exit text mode. The Text
Formatting toolbar closes and the Line and Filling toolbar opens in its original position.
4) To format and/or reposition the text box, see the Draw Guide for more information.

Figure 213: Text information in Status bar

Vertical text
By default, Draw is set for horizontal text only. To enable vertical text:
1) Go to Tools > Options > Language Settings > Languages.
2) Under Default Languages for Documents, select Asian and accept the default
language shown.
3) Right-click in a blank area on the Standard and/or Drawing toolbar and select Visible
Buttons in the context menu.
4) Select Insert Vertical Text in the list of available tools to enable vertical text on the
Standard and/or Drawing toolbar.

Note
Formatting vertical text and vertical text boxes is the same as horizontal text and
horizontal text boxes. A vertical text box expands vertically as text is added into the
box. For more information on vertical text, see the Draw Guide.

Text in Draw objects
Text can be added to most Draw objects. The exceptions are control elements, for example
buttons, polygons, curves, or 3D objects.
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By default, an object is not dynamic when created in Draw and does not behave like a text box.
Any text added to an object does not word wrap inside the object. To keep text within the borders
of an object, use word wrap, paragraphs, line breaks, smaller text size, increasing object size, or
a combination of all methods. For more information on adding text to objects, see the Draw
Guide.
1) Create an object in a drawing and make sure the object is selected with the selection
handles displayed.
2) Enter text mode on the selected object using one of the following methods:
– Click on Insert Text Box for horizontal text or Insert Vertical Text for vertical text on
the Standard or Drawing toolbar.
– For horizontal text, double-click on the selected object.
– For vertical text, double-click on the selected object and click on Insert Vertical Text
on the Standard or Drawing toolbar.
3) Type or paste text into the selected object.
4) If the text goes outside the object borders, format the text using the various tools on the
Text Formatting toolbar, the panels in the Properties deck on the Sidebar, the options in
Format on the Menu bar, or the Text page in the Text dialog. For more information on text
formatting, see the Draw Guide.
5) Move the cursor away from the object, then click to deselect the object ending text mode
and saving the changes.

Creating lists
Unordered (bulleted) or ordered (numbered) lists can be created in text boxes or Draw objects.
For more information on lists, see the Draw Guide.
1) Select all of the text required for a list.
2) Create a list using one of the following methods and default settings for lists:
– Click on Toggle Unordered List or Toggle Ordered List on the Text Formatting
toolbar.
– Click on Toggle Unordered List or Toggle Ordered List in the Lists panel in the
Properties deck on the Sidebar.
– Go to Format > Lists > Unordered List or Ordered List on the Menu bar.
3) To change the format of the list, click on the triangle ▼ on the right of the list icons and
select a list style from the options available.

Text columns
Text in a drawing can be formatted into columns inside text boxes and objects. However, columns
cannot be used on separate parts of text inside a text box or object. The whole of the text box or
object has to be used for columns. For more information on text columns, see the Draw Guide.
1) For text boxes – click the border of a text box to select it so that the selection handles are
displayed indicating that the text box is in edit mode.
2) For graphic objects – double-click on a graphic object to select it so that the selection
handles are displayed and the cursor flashes in the center of the object indicating that the
object is in text edit mode.
3) Open the options for text columns using one of the following methods:
– Right-click in the text box or graphic object and select Text Attributes in the context
menu to open the Text dialog, then click on the Text Columns tab to open the Text
Columns page,
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– Click on Columns in Properties on the Sidebar to open the Columns panel.
4) Set the number of columns required in the Number of columns box and the required
spacing between the columns in the Spacing box.
5) Save the changes and deselect the text box or graphic object using one of the following
methods:
– For the Text dialog, click OK to save the changes and close the dialog, then click
outside the text box to deselect it.
– For the Columns panel in the Properties deck on the Sidebar, click outside the text
box or graphic object to deselect it and save the changes.
6) Type in the required text or use copy and paste to enter the required text into the text box
or graphic object. Any text entered will be in column format.
7) If necessary, format the text to the presentation requirements.
8) Click outside the text box or graphic object to deselect it and save the changes.

Note
Any text inside a text box or graphic object automatically flows into column format
when the changes are saved.

Selecting objects
Direct selection
The easiest way to select an object is to click directly on it. For objects that are not filled, click on
the object outline to select it. To select or deselect more than one object, hold the Shift key down
while clicking on each object.

Selection by framing
Several objects can be selected at the same time by clicking and dragging the cursor to draw a
selection rectangle (also known as a marquee) around the objects. Only objects that lie entirely
within this selection rectangle are selected. To select multiple objects by framing, Select on the
Drawing toolbar must be active.

Selecting hidden objects
If objects are located behind others and not visible, they can still be selected. When selecting a
hidden object, its selection handles appear through the objects covering it.
•

Windows, macOS or Linux – press the Tab key to select and cycle through the objects
in a drawing, stopping at the hidden object to select it. To cycle through the objects in
reverse order, press Shift+Tab.

•

Windows or macOS only – select the object in front of a hidden object, then press the
Alt key (macOS ⌥) and click to select the hidden object. If there are several hidden
objects, keep holding down the Alt key (macOS ⌥) and clicking until the object required
is reached. To cycle through the objects in reverse order, hold down the Alt+Shift keys
(macOS ⌥+Shift) and click.
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Arranging objects
In a complex drawing, several objects may be stacked on top of one another. This stacking order
can be rearranged by moving an object forward or backward using one of the following methods:
•

Select an object, go to Shape > Arrange on the Menu bar, or right-click on the object and
select Arrange in the drop-down menu, then choose one of the following options:
– Bring to Front (Ctrl+Shift++) (macOS ⌘+Shift++)
– Bring Forward (Ctrl++) (macOS ⌘++)
– Send Backward (Ctrl+-) (macOS ⌘+–)
– Send to Back (Ctrl+Shift+-) (macOS ⌘+Shift+–)
– In Front of Object
– Behind Object
– Reverse – clicking on this option reverses the order of the selected objects.

•

Select an object, then click on one of the Arrange tools on the Line and Filling toolbar.
When you hover the cursor over a tool, its function is indicated.

Positioning and adjusting objects
When positioning or changing the size of an object, check the information area of the Status bar
at the bottom of the Draw Workspace (Figure 214). From left to right, it shows what object is
selected, its position on the drawing in X/Y coordinates, and the dimensions of the object. The
measurement units are those selected in Tools > Options > LibreOffice Draw > General.
For more information on positioning and adjusting objects, see the Draw Guide.

Using zoom
To help in the positioning and adjustment of objects, Draw has a zoom function that reduces or
enlarges the screen display of the current drawing. For example, zoom in to position objects on a
drawing with greater accuracy; zoom out to see the complete drawing. Zooming is controlled
using the Status bar, Zoom & View Layout dialog, or Zoom toolbar. For more information on using
zoom, see the Draw Guide.

Figure 214: Information on left end of Status Bar when working with objects
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Moving objects
To move an object (or a group of objects), select it and then click within the object borders and
hold down the left mouse button while dragging the mouse. During movement, a ghost image of
the object appears to help with repositioning (Figure 215). To locate the object at its new position,
release the mouse button.

Figure 215: Moving objects

Adjusting object size
To change the size of a selected object (or a group of selected objects), move the cursor to one
of the selection handles. The cursor changes shape to indicate the direction of movement for that
selection handle. As the object size changes, a ghosted outline of the object appears
(Figure 216). When the desired size of the object is reached, release the mouse button.
The results depend on which selection handle is being used. To resize an object along one axis,
use a side, top, or bottom handle. To resize along both axes, use a corner handle.

Figure 216: Adjusting object size

Note
Press and hold the Shift key while resizing an object, the change in size is carried out
symmetrically with respect to the object width and height so that the aspect ratio of
the object remains the same. This Shift key behavior works on all selection handles.

Rotating or slanting objects
To rotate or slant an object (or a group of objects), select it and switch to rotation mode using one
of the following methods:
•

Right-click on the object and select Transformations > Rotate in the context menu.

•

Click on the triangle ▼ on the right of Transformations on the Standard or Line & Filling
toolbars and select Rotate.
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The selection handles change shape and Color and a center of rotation appears in the center of
the object. As the cursor is moved over the handles, the cursor changes shape to indicate the
type of movement.

Rotation
1) Click and hold the mouse button over a corner selection handle, then move the cursor to
rotate the object. A ghost image of the object being rotated appears and the current angle
of rotation is shown in the Status bar (Figure 217).
2) When the object is at the desired rotation angle, release the mouse button.
3) To change the angle of rotation, click on the rotation point and drag it to another position.
This position can be outside the object.

Note
Press the Shift key while rotating or slanting an object and the movement is restricted
to 15°.

Figure 217: Rotating an object

Slanting
1) Click and hold the mouse button over a selection handle at the top, bottom, left side, or
right side of an object.
2) Drag the selection handle to slant the object. A ghost image of the object being slanted
appears (Figure 218) and the current slant angle is shown in the Status bar. The axis
used for slanting an object is fixed to the edge of the object directly opposite the selection
handle being used to slant the object.
3) When the object is at the desired slant angle, release the mouse button.

Figure 218: Slanting an object
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Flipping objects
Select an object so that the selection handles are displayed and flip the object vertically or
horizontally using one of the following methods:
•

Right-click on the object and select Flip > Vertically or Horizontally in the context menu.

•

Go to Shape > Flip > Vertically or Horizontally on the Menu bar.

•

Click on Vertically or Horizontally tool on the Line and Filling toolbar.

•

Use Flip Vertically or Flip Horizontally tool in the Position and Size section on the
Properties deck of the Sidebar.

However, the Flip tool on the Transformations toolbar (Figure 222) provides greater control over
the flipping process. Use the Flip tool to change the position and angle that the object flips over.
See the Draw Guide for more information.

Figure 219: Transformations
toolbar

Object distortion
Three tools on the Transformations toolbar (Figure 219) allow the dragging of the corners and
edges of an object to distort an object.
•

Distort – distorts an object in perspective.

•

Set in Circle (perspective) – creates a pseudo 3D effect.

•

Set to Circle (slant) – creates a pseudo 3D effect. Despite the (slant) in the name of this
tool, it operates differently from the slanting created by rotation.

In all three cases, the object has to be converted into a curve. This is a necessary first step, so
click Yes, then move the object handles to produce the desired effect. See the Draw Guide for
more information on how to distort an object.

Dynamic gradients
Transparency gradients can be controlled the same as Color gradients and both types of gradient
can be used together. With a transparency gradient, the direction and degree of the object fill
Color changes from opaque to transparent. In a Color gradient, the fill changes from one Color to
another, but the degree of transparency remains the same. An example of a dynamic gradient is
shown in Figure 220.
Two tools on the Transformations toolbar are used to dynamically control transparency and Color
gradients – Interactive Transparency and Interactive Gradient. See the Draw Guide for more
information on how to create transparencies and gradients in an object.
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Figure 220: Dynamic gradient example

Duplication
Duplication makes copies of an object while applying a set of changes such as Color or rotation
to the duplicates that are created. An example of duplication is shown in Figure 221. For more
information on duplication, see the Draw Guide.

Figure 221: Duplication example
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Figure 222: Duplicate dialog
1) Click on an object or group of objects and open the Duplicate dialog (Figure 222) using
one of the following methods:
– Go to Edit > Duplicate on the Menu bar.
– Go to Shape > Duplicate on the Menu bar.
– Use the keyboard shortcut Shift+F3.
2) Select the required number of copies, placement, enlargement, and colors.
3) Click OK to duplicate the object and close the Duplicate dialog.

Cross-fading
Cross-fading transforms one object shape to another object shape. The result is a new group of
objects with the first object selected as the start object and the second object selected as the end
object. For example, when the options in the Cross-fading dialog are applied to a diamond and
an ellipse, the cross-fading produces the result shown by the example in Figure 223.
1) Select two differently shaped objects and go to Shape > Cross-fading on the Menu bar
to open the Cross-fading dialog (Figure 224).
2) In Increments enter the number of shapes between the two objects.
3) Select Cross-fading attributes to apply a gradual change of line and fill properties
between the two objects.
4) Select Same orientation to apply a smooth transition between the two objects.
5) Click OK to carry out the cross-fading and close the Cross-fading dialog.
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Figure 223: Cross-fading example of two objects

Figure 224: Cross-fading dialog

Grouping and combining multiple objects
Using Draw, a group of objects can be grouped together allowing multiple objects to be treated
as one object, or combined together to create a new shape, as shown by the example in
Figure 225. For more information on grouping and combining objects, see the Draw Guide.

Grouping
Grouping of objects is similar to putting objects into a container. The objects can be moved as a
group and global changes applied to the objects within the group. A group can always be undone
(ungroup). Objects that make up a group can always be manipulated separately and retain their
own individual properties.

Temporary grouping
A temporary grouping is when several objects are selected using one of the following methods:
•

While holding down the Shift key, click on each object with the cursor to select it for the
temporary group.

•

Using the mouse, click and drag a rectangle (also known as a marquee) around the
objects for the temporary group.
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Figure 225: Example of grouped and combined objects
Any changes to object parameters carried out are applied to all of the objects within the
temporary group. For example, rotating a temporary group of objects in its entirety.
To cancel a temporary grouping of objects, click outside of the selection handles displayed
around the objects.

Permanent grouping
A permanent grouping of objects can be created after selecting objects using one of the following
methods:
•

Go to Shape > Group > Group on the Menu bar.

•

Right-click on the selected objects and select Group in the context menu.

•

Use the keyboard shortcut Ctrl+Shift+G (macOS ⌘+Shift+G)

When deselected, the objects remain grouped together. Any editing operations carried out on the
group are applied to all objects within the group. If one object in the group is clicked, the whole
group is selected.

Editing within groups
Editing an individual within a group can be carried out without ungrouping or breaking the group.
After selecting the group, use one of the following methods to enter the group:
•

Go to Shape > Group > Enter Group on the Menu bar.

•

Right-click on the selected group and select Enter Group in the context menu.

•

Use the keyboard shortcut F3.

•

Double-click on the selected group.

When editing is finished on an individual object within a group, use one of the following methods
to exit the group:
•

Go to Shape > Group > Exit Group on the Menu bar.

•

Right-click and select Exit Group in the context menu.

•

Use the keyboard shortcut Shift+F3.
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Ungrouping
To ungroup or break apart a permanent group of objects, use one of the following methods after
selecting the group:
•

Go to Shape > Group > Ungroup on the Menu bar.

•

Right-click and select Ungroup in the context menu.

•

Use the keyboard shortcut Ctrl+Alt+Shift+G.

Nesting groups
A group of groups, more commonly known as nested groups, can be created. When nested
groups are created, Draw retains the individual group hierarchy and remembers the order in
which groups were selected. That is, the last individual group selected will be on top of all the
other groups within a nested group. Ungrouping and entering a nested group work in the same
way as for individual groups.

Combining objects
Combining is a permanent merging of objects, creating a new object. The original objects are no
longer available as individual entities and cannot be edited as individual objects. Any editing of a
combined object affects all the objects that were used when combination was carried out. For
more information on combining objects, see the Draw Guide.
After selecting the objects for combining, use one of the following methods to create a new
object. An example of combining objects is shown in Figure 225 on page 249.
•

Go to Shape > Combine on the Menu bar.

•

Right-click on the objects and select Shapes > Combine in the context menu.

•

Use the keyboard shortcut Ctrl+Shift+K.

Merging, subtracting, and intersection
After selecting several objects, the Merge, Subtract, and Intersect functions become available.
These functions are similar to combining objects, but allow the creation of a differently shaped
object from the selected objects. The shape of the object depends on which function used. See
the Draw Guide for more information on how to use these functions.

Arranging, aligning, and distributing objects
In Draw, selected objects can be arranged, aligned, and distributed in relation to each other. See
the Draw Guide for more information on arranging and aligning objects.
•

Arrange the position of an object by moving it either forward or backward in relation to the
order of objects.

•

Align objects with respect to each other using Left, Centered, or Right for horizontal
alignment and Top, Center, or Bottom for vertical alignment.

•

Distribute objects so that the space between each of the objects is the same.

Inserting and exporting images
Inserting
Draw contains a number of functions for editing images (also called pictures, raster graphics, or
bitmaps). These functions include the import and export of images, and conversion from one
image format to another. For more information on working with images, see Chapter 11, Images
and Graphics, in this guide and the Draw Guide.
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Draw includes a large range of filters so that it can read and display several image file formats. It
also includes several tools for working with images, but does not have the same functionality as
specialized programs like GIMP or Adobe Photoshop.
Images can be added from several sources:
•

Directly from a scanner (Insert > Media > Scan on the Menu bar).

•

Created by another program, for example photographs from a digital camera (Insert >
Image on the Menu bar).

•

The LibreOffice Gallery; see Chapter 11, Images and Graphics.

Exporting
Draw saves images as drawings in the Open Document Format (ODG). To save an image or the
entire Draw file in another format, go to File > Export on the Menu bar and select a format in the
drop-down list. The image formats that Draw can export in and save to are listed in Appendix B,
Open Source, Open Standards, OpenDocument.
Draw files can also be exported in HTML, XHTML, or PDF format. For more information, see
Chapter 10, Printing, Exporting, Emailing, and Signing.
HTML export uses a conversion wizard that creates as many web pages as there are pages in a
Draw document. Optionally drawing pages can be displayed in frames with a navigator and an
index page. See Chapter 12, Creating HTML Files.

Working with 3D objects
Although Draw does not match the functionality of specialized drawing or image editing
programs, it is capable of producing and editing good 3D drawings. For more information, see the
Draw Guide.
Create a 3D object in Draw using one of the following methods:
•

Select a 3D shape in the 3D Objects section in the Shapes deck on the Sidebar.

•

Right-click on a 2D object and select Convert > To 3D or To 3D Rotation Object in the
context menu.

•

Right-click on a 2D object and select Format > 3D Effects on the Menu bar.

Working with layers
Using layers when creating complex drawings makes a drawing easier to navigate and edit.
Placing a simpler drawing that is part of a complex drawing into its own layer makes editing
easier. Any area of a layer that does not contain a drawing object is transparent and does not
obscure any part of a complex drawing. Any number of layers can be added to a drawing. For
more information on layers, see the Draw Guide.
A drawing in LibreOffice contains three default layers that cannot be deleted or renamed:
•

Layout – is the default Workspace where objects are normally placed when a drawing is
created.

•

Controls – used for form controls that have been assigned an action. Objects on this
layer are always in front of objects on other layers.

•

Dimension Lines – is where the dimension lines are drawn. By switching the layer to
show or hide, dimension lines can be switched on or off.
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A layer can be set to one or all of the following attributes:
•

Visible or hidden.

•

Printable or not printable.

•

Locked or unlocked.

To quickly toggle the attributes for a selected layer, use the following keyboard shortcuts:
•

Shift+click – toggle between a layer being visible or hidden.

•

Ctrl+click (macOS ⌘+click) – toggle between a layer being locked or unlocked.

•

Ctrl+Shift+click (macOS ⌘+Shift+click) – toggle between a layer being printed or not
printed.

Adding layers
1) Use one of the following methods to open the Insert Layer dialog (Figure 226):
– Go to Insert > Layer on the Menu bar.
– Right-click on the layer tabs at the bottom of the Workspace and select Insert Layer
in the context menu.
2) Enter a meaningful Name, Title, and Description for the new layer in the text boxes.
3) Select Visible if the layer is to be visible in a drawing. When Visible is not selected, the
layer is hidden and its name in the layer tab changes Color to blue.
4) Select Printable if the layer is to be printed when a drawing is printed. Not printing is
useful if a draft layer is required for guides or annotations that are used in making a
drawing, but you do not it want to appear in the final output. The name of a layer is
underlined in the layer tab bar when the Printable option is turned off.
5) Select Locked to prevent any objects on this layer from deletion, editing, or moving. No
additional objects can be added to a locked layer. Locking a layer is useful, for example,
when a base plan is to be protected while adding a new layer with other details. The
name of a locked layer is written in Italics in the layer tab bar.
6) Click OK to create the new layer and close the Insert Layer dialog. A new layer
automatically becomes active when added to a drawing.

Figure 226: Insert Layer dialog
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Note
Layers are added to the drawing in the order that they were inserted. The layer order
cannot be changed.

Modifying layers
1) To modify a layer, use one of the following methods to open the Modify Layers dialog,
which is similar in layout and options to the Insert Layers dialog.
– Right-click on the name tab of the layer and select Modify Layer in the context menu.
– Double-click on the layer tab.
– Go to Format > Layer on the Menu bar.
2) Make the required changes to the layer, then click OK to save the changes and close the
Modify Layers dialog.

Selecting colors
Colors are selected using a Color palette, the Area and Line panels on the Properties deck of
the Sidebar, and tools on the Line and Filling, and Drawing toolbars.

Note
For a more detailed description of the options available for Color palettes and
custom colors, as well as more information on the difference between the CMYK and
RGB Color schemes, refer to the Draw Guide.

Color palette
To display the Color Palette (Figure 227), go to View > Color Bar on the Menu bar. To close the
Color Palette, go to View on the Menu bar and deselect Color Bar.
Using the Color Palette, a Color of the area or background, and lines of selected objects in a
drawing can be quickly selected.
•

Left-click on a Color to change the Color of the area or background of a selected object.

•

Right-click on a Color to change the Color of the lines in a selected object.

•

Left-click or right-click on the box with the X at the bottom left of the Color Palette to
select no Color for the area or lines of a selected object.

Figure 227: Color Palette (Color Bar)
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Figure 228: Area and Line panels in
Properties deck on Sidebar

Sidebar Color
In the Area and Line panels in the Properties deck on the Sidebar (Figure 228), the Color of an
area or line of a selected object can be changed.
1) Select an object in a drawing.
2) Click on Properties on the Sidebar. In the Properties deck, open the Area and/or Line
panels by clicking on the triangle ▼ on the panel title bar.
3) Change the Color of an area in the Area panel as follows:
a) Select Color in the Fill drop-down list.
b) Click on the triangle ▼ next to the Fill Color box to open the Color palette.
c) Click on a Color to change the area Color.
d) To change the Color palette, click on the triangle ▼ at the top of the Color palette and
select a Color palette in the drop-down list.
4) Change the Color of a line in the Line panel as follows:
a) Click on the triangle ▼ next to the Line Color box to open the Color palette.
b) Click on a Color to change the line Color.
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c) To change the Color palette, click on the triangle ▼ at the top of the Color palette and
select a Color palette in the drop-down list.

Toolbar Color change
The Line and Filling, and Drawing toolbars have the same two tools that can be used to change
the Color of an area (fill) or line – Fill Color and Line Color. These two tools are used in a
similar way as changing colors using the Area and Line panels on the Properties deck of the
Sidebar, described above.

Adding comments to a drawing
Adding comments to a drawing uses a similar process to the one used in Writer and Calc. For
more about adding, navigating, and replying to comments, see Chapter 4, Getting Started with
Writer.
Before using comments, make sure that name and initials are entered into Tools > Options >
LibreOffice > User Data. The name and initials then appears in the comment marker and in the
Author field of the comment.
If more than one person edits the document, each author is automatically allocated a different
background Color.
1) Go to View > Comments on the Menu bar to show or hide the comment markers.
2) Go to Insert > Comment on the Menu bar. A small box containing the user initials
appears in the upper left-hand corner of the drawing with a larger text box beside it
(Figure 229). Draw automatically adds the name and the date at the bottom of this text
box.
3) Type or paste comments into the text box.
4) If necessary, click and drag the small comment markers to move the comment to a
different position on the drawing. Normally, the comment marker is placed on or near the
object referred to in the comment.
5) Right-click on the comment and choose an option in the context menu to delete the
current comment, all the comments from the same author, or all the comments in the
document.

Figure 229: Inserting a comment
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Getting Started Guide 7.3

Chapter 8,
Getting Started with Base
Relational databases in LibreOffice

Introduction
A data source, or database, is a collection of pieces of information that can be accessed or
managed by LibreOffice. For example, a list of names and addresses is a data source that could
be used for producing a mail merge letter. A business stock list could be a data source managed
through LibreOffice.
Base is the database front-end component of LibreOffice. It can create and store an embedded
database or connect to external databases. This chapter covers creating a database, showing
what is contained in a database, and how the different parts are used by LibreOffice.

Note
LibreOffice uses the terms “Data Source” and “Database” to refer to the same thing,
which could be a database such as MySQL or dBase, a spreadsheet or text
document holding data, or an address book.
A database consists of a number of fields that contain the individual pieces of data. Each table of
the database is a group of fields. When creating a table, you also determine the characteristics of
each field within it. Forms are for data entry into the fields of one or more tables which have been
associated with the form. They can also be used for viewing fields from one or more tables
associated with the form. A query creates a new table from the existing tables based upon how
you create the query. A report organizes the information from the fields of a query or table into a
document according to your requirements.

Caution
Some Base features (most notably, the HSQLDB database engine, and the ability to
create reports) require that a Java Runtime Environment (JRE) is installed.
Please go to Tools > Options > LibreOffice > Advanced to select a JRE from
those installed on your computer.
If a JRE is not already installed, you will need to download and install one. For
Windows and Linux, you can get Java from https://www.java.com/. For Linux, you
can also use the JRE available from the repository of your Linux version. For
macOS, you need to install Oracle’s Java Development Kit (JDK), not just the
Java Runtime Environment (JRE). Download links can be found by selecting the
macOS option at: https://www.oracle.com/java/technologies/downloads/.
Base creates both flat and relational databases. This makes it fairly easy to create a database in
which the fields of the database have relationships with each other.
For example: Consider a database for a library. It will contain a field for the names of the authors
and another field for the names of the books. There is an obvious relationship between the
authors and the books they have written. The library may contain more than one book by the
same author. This is what is known as a one-to-many relationship: one author and more than one
book. Most if not all the relationships in such a database are one-to-many relationships.
Consider an employment database for the same library. One of the fields contains the names of
the employees while other fields contain the social security numbers and other personal data.
The relationship between the names and social security numbers is one-to-one: only one social
security number for each name.
If you are acquainted with mathematical sets, a relational database can easily be explained in
terms of sets: elements, subsets, unions, and intersections. The fields of a database are the
elements. The tables are subsets. Relationships are defined in terms of unions and intersections
of the subsets (tables).
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Planning a database
Instructions for creating a database for automobile expenses will be used as an example of
creating and using a relational database.
The first step in creating a database is to ask yourself many questions. Here are some of the
questions and answers I developed before I created a database for automobile expenses.
What are the user output requirements?
Information is needed on three broad areas: fuel usage, maintenance, and vacation.
What input data is required for the output?
Fuel purchases, maintenance expenses, and vacation expenses.
What fields fit the fuel purchases area?
Date purchased, odometer reading, fuel cost, fuel quantity, and payment method for it.
(Fuel economy need not be included, as it can be calculated using a query.)
What fields fit the maintenance area?
Date of service, odometer reading, type of service, cost of service, and next scheduled
service of this type (for example, for oil changes, list when the next oil change should be). A
field for notes was added to the list.
What fields fit the vacations area?
Date, odometer reading, fuel (including all the fields of the fuel table), food (including meals
and snacks), motel, total tolls, and miscellaneous. These purchases are made by one of
two bank cards or cash; I want a field to state which payment type was used for each item.
What fields fit into the food category?
Breakfast, lunch, supper, and snacks seem to fit. Do I list all the snacks individually or list
the total cost for snacks for the day? I chose to divide snacks into two fields: number of
snacks and total cost of snacks. I also need a payment type for each of these: breakfast,
lunch, supper, and total cost of snacks.
What are the fields that are common to more than one area?
Date appears in multiple areas, as does odometer reading and payment type.
How will I use these fields to get the required information?
While on vacation, I want the expenses for each day to be listed together. The date fields
suggest a relationship between the vacation table and the dates in each of these tables:
fuel and food. The date fields in these tables will be linked as we create the database.
The type of payment includes two bank cards and cash. So we will create a table with a
field for the type of payment and use it in list boxes in the forms.

Tip
While we have listed fields we will create in the tables of the database, there is one
more field that may be needed in a table: the field for the primary key, an identifier
unique to each record. In some tables, a suitable field for the primary key has
already been listed. In other tables such as the payment type, an additional field for
the primary key must be created.
Without the primary key field in a table, any data added, deleted, or modified has to
be done by using the Execute SQL Statement dialog (Tools > SQL…). This takes
much longer than to insert it using the Table Data View dialog. But thereafter, the
data is visible in the table and is available to be used in queries, forms, and reports.

Creating a new database
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To create a new database, select File > New > Database on the Menu bar, or click the arrow
next to the New icon on the Standard toolbar and select Database in the drop-down menu. You
can also click the Base Database button in the Create area of the LibreOffice Start Center. If you
are already working in Base, you can also press Ctrl+N. All of these methods open the Database
Wizard.
On the first page of the Database Wizard (Figure 230), select Create a new database. Be sure
that the HSQLDB Embedded entry is selected in the Embedded database drop-down menu; see
the Base Guide for information about using alternative embedded database engines or existing
external databases. Click Next.

Figure 230: Creating a new database
The second page of the Database Wizard (Figure 231) has two questions. For the first question,
it is advised that the database should be registered. Make sure the choice for the second
question is Open the database for editing. Click Finish. The Database Wizard will prompt you
to select a location to name and save the database.

Figure 231: Registering the new database

Note
In Writer and Calc, selecting View > Data Sources, or pressing the Ctrl+Shift+F4 key
combination, opens and closes the Data Sources window containing the list of
registered databases. If a database is not registered, this window will not contain it
and you cannot access it in Writer or Calc if you need to use data from it.
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Save the new database with the name Automobile. This opens the Automobile.odb – LibreOffice
Base window (Figure 232).

Figure 232: LibreOffice Base window

Tip
Every time the Automobile database is opened, the Automobile.odb – LibreOffice
Base window opens. Changes can then be made to the database. The title for this
window is always <database name> – LibreOffice Base.

Caution
As you create a database, you should save your work regularly. This means more
than saving what you have just created. You must save the whole database as well.
For example, when you create your first table, you must save it before you can close
it. This makes it part of the database in memory. But it is only when you save the
database file that the table is written to disk.

Note
Database files in Open Document Format are stored with the *.odb extension. This
file format is actually a container of all elements of the database, including forms,
reports, tables, and the data itself. The same format can also store a connection to
an external database server instead of the local data, for example, to access a
MySQL or PostgreSQL database server in your network.
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Creating database tables
In a database, a table stores information in a group of things we call fields. For example, a table
might hold an address book, a stock list, a phone book, or a price list. A database must have at
least one table and may have several.
Each field of a table contains information of a single type. For example, the Phone field of an
address book would only contain phone numbers. Similarly, a price list table could contain two
fields: Name and Price. The Name field would contain the names of the items; the Price field
would contain the amount of each item.
To work with tables, click the Tables icon in the Database list, select View > Tables, or press
Alt+A. The tasks that you can perform on a table are in the Tasks list (see Figure 232).

Figure 233: Creating a table using Wizard

Using the Table Wizard to create a table
Wizards are designed to do the basic work. Sometimes this is not sufficient for what we want; in
those cases we can use a wizard as a starting point and then build upon what it produces.
The Table Wizard in Base contains two categories of suggested tables: business and personal.
Each category contains sample tables from which to choose. Each table has a list of available
fields. We can delete some of these fields and add other fields.
A field in a table is one bit of information. For example, a price list table might have one field for
item name, one for the description, and a third for the price.
Since none of the fields we need for our Automobile database are contained in any of the sample
wizard tables, we will create a simple table using the wizard that has nothing to do with our
database. This section is merely an exercise in explaining how the wizard works.
The Table Wizard permits the fields of the table to come from more than one suggested table.
We will create a table with fields from three different suggested tables in the wizard.
Click Use Wizard to Create Table. This opens the Table Wizard (Figure 234).
Step 1: Select fields
We will use the CD-Collection sample table in the Personal category and Employees in the
Business category to select the fields we need.
1) Category: Select Personal. The Sample tables drop-down list changes to a list of
personal sample tables.
2) Sample tables: Select CD-Collection. The Available fields area changes to a list of
available fields for this table.
3) Selected fields: By selecting each field and using the > button, move the following fields
from the Available fields list to the Selected fields list in this order: CollectionID,
AlbumTitle, Artist, DatePurchased, Format, Notes, and NumberofTracks.
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Figure 234: Selecting fields from Personal category
4) To select fields from another sample table, select Business as the Category. Select
Employees in the drop-down list of sample tables. Use the > button to move the Photo
field from the Available fields list to the Selected fields list. It will be at the bottom of the
list, directly below the NumberofTracks field.
5) If you make a mistake in selecting fields, click on the field name in the Selected fields list
and use the < button to move it from the Selected fields list back to the Available fields
list.
6) If you make a mistake in the order of the selected fields, click the field name that is in the
wrong order and use the up and down arrows on the right side of the Selected fields list
to move it to the correct position.
7) Click Next.

Tip
You can double-click a field in the Available fields list to transfer it to the Selected
fields list. Similarly you can double-click a field in the Selected fields list to transfer it
back to the Available fields list.
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Figure 235: Selecting fields for the table
Step 2: Set field types and formats
In this step you give the fields their properties. When you click a field, the information on the right
changes. (See Figure 236.) You can then make changes to meet your needs. Click each field,
one at a time, and make the changes listed below.

Figure 236: Changing field types
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Note
If any of these fields requires a mandatory entry, set Entry required to Yes. A blank
field will then not be allowed. In general, only set Entry required to Yes if something
must always be put in that field. By default, Entry required is set to No. (The Entry
required option is not visible in Figure 236 because AutoValue has been set to Yes.)
•

CollectionID: Change AutoValue from No to Yes. (example of a mandatory entry)

•

AlbumTitle:
– Entry required: Leave Entry required as No, unless all of your music is in albums.
– Length: Unless you have an album title that exceeds 100 characters counting the
spaces, do not change the length.

•

Artist: Use most of the default settings. Since music always has artists, set Entry
Required to Yes.

•

Date Purchased: Field type: default setting. Entry required should be No. (You may not
know the date.)

•

Format: Only change the Entry Required setting: from No to Yes.

•

Notes: No changes are required.

•

NumberofTracks: Change the Field type to Small Integer [SMALLINT], which allows for
32768 tracks.

•

Photo: Use the default settings.

Note
In Base the maximum length of each field must be specified on creation. It is not
easy to change this later, so if in doubt specify a greater length. Base uses
VARCHAR as the field format for text fields. This format uses only the actual number
of characters in a field up to the limit set, so a field containing 20 characters will
occupy only 20 characters even if the limit is set at 100. Two album titles containing
25 and 32 characters respectively will use space for 25 and 32 characters and not
100 characters.
Another text format is CHAR, which has a fixed length. If the limit is set to 100
characters, every entry into this field will have a length of 100 regardless of whether
the actual length is 1 or 100.

Note
Each field has a Field type, which must be specified. Types include text, integer,
date, and decimal. If the field is going to have general information in it (for example,
a name or a description), use text. If the field will always contain a number (for
example, a price), the type should be decimal or another numerical field. The wizard
picks the right field type, so to get an idea of how this works, see what the wizard
has chosen for different fields.

Tip
Up and down arrows are available on this page (not shown in Figure 236) and you
can use these to reorder the list of fields. Also + and – buttons are available and you
can use these to remove fields from the list or to add new fields.
When you have finished, click Next.
264 | LibreOffice 7.3 Getting Started Guide

Step 3: Set primary key
1) Create a primary key should be checked.
2) Select option Use an existing field as a primary key.
3) In the Fieldname drop-down list, select CollectionID.
4) Check Auto value if it is not already checked. Click Next.

Note
A primary key uniquely identifies an item (or record) in the table. For example, you
might know two people called “Randy Herring” or three people living at the same
address and the database needs to distinguish between them.
The simplest method is to assign a unique number to each one: number the first
person 1, the second 2, and so on. Each entry has one number and every number is
different, so it is easy to say “record ID 172”. This option is chosen here: CollectionID
is just a number assigned automatically by Base to each record of this table.
Step 4: Create table
1) If desired, rename the table at this point. If you rename it, make the name meaningful to
you. For this example, make no changes.
2) Leave the option Insert data immediately checked.
3) Click Finish to complete the Table Wizard. Close the Table Data View window created by
the Table Wizard. You are now back to the main window of the database with the listing of
the tables, queries, forms, and reports. Notice that a table named CD-Collection is now
listed in the Tables portion of the window.
4) Click the Save button on the Standard toolbar at the top of the main window.

Creating a table by copying an existing table
If you have a large collection of music, you might want to create a table for each type of music
you have. Rather than creating each table from the wizard, you can make copies of the original
table, naming each according to the type of music contained in it.
1) Click on the Tables icon in the Database area of the LibreOffice Base window to see the
existing tables.
2) Right-click on the CD-Collection table icon. Choose Copy in the context menu.
3) Right-click, and select Paste. The Copy table dialog opens.
4) Change the Table name to CD-Jazz, check Options Definition and data is selected then
click Next.

Figure 237: Creating copies of original table

Tip
Using the four action buttons on this page, you can move selected fields, or all fields,
in either direction. You can also double-click to move a field from one list to the other.
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5) Click the >> button to move all the fields from the left box to the right box and click Next.
6) Since all the fields already have the proper field type, no changes should be needed.
However, this is the time and place to make any changes if they are needed. (See
Caution below for the reason why.) Click Create. The new table is created.
7) Click the Save button on the Standard toolbar at the top of the LibreOffice Base window.

Caution
Once tables have been created using the wizard, and data has been entered, editing
a table should be very limited. You can add or delete fields, but adding a field
requires you to enter the data for that one field for every existing record with an entry
for that field.
Deleting a field deletes all the data once contained in that field. Changing the field
type of a field can lead to data being lost either partially or completely. When creating
a new table, it pays to create the fields with the correct names, length, and format
before you add any data.
Deleting a table removes all of the data contained in every field of the table. Unless
you are sure, do not delete a table.
8) Double-click on the CD-Jazz table icon and visually verify the data before closing the
table
9) Right-click on the CD-Jazz table icon, select Delete and confirm deletion.

Creating tables in Design View
Design View is a more advanced method for creating a new table, in which you directly enter
information about each field in a table. We will use this method for the remaining tables of our
Automobile database.

Note
While the field types and formatting are different in Design View, the concepts are
the same as in the Table Wizard.
The first table to be created is Fuel. Its fields are FuelID, Date, FuelCost, FuelQuantity,
Odometer, and PaymentType.
1) Click Create Table in Design View in the Tasks area of the LibreOffice Base window.
Base opens the LibreOffice Base: Table Design dialog.
2) FuelID field: Type FuelID as the first Field Name entry. Press the Tab key to move to the
Field Type column. Select Integer [INTEGER] as the field type in the drop-down list. (The
default setting is Text [VARCHAR].)

Tip
A shortcut for selecting from the Field Type drop-down list: press the key for the first
letter of the choice. You can cycle through the choices for a given letter by repeatedly
pressing that key.
a) Change the Field Properties in the bottom section of the dialog.
Change AutoValue from No to Yes.
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b) Set FuelID as the primary key.
Click in the Field Name cell directly below FuelID. The dialog automatically sets
FuelID as the primary key and places a key icon in front of FuelID (Figure 238).

Figure 238: Defining the primary key field

Tip
Certain of the integer field types (Integer and BigInt for example) have an AutoValue
field property. When using one of these field types, your selection of Yes for
AutoValue automatically makes the field the primary key.
Primary keys for any other field type must be selected by right-clicking the rectangle
before the field and selecting Primary Key in the context menu.

Note
The primary key serves only one purpose: to identify each record uniquely. Any
name can be used for this field. We have used FuelID for convenience, so we know
to which table it belongs.
3) All other fields (Date, FuelCost, FuelQuantity, Odometer, and PaymentType):
a) Type the next field name in the Field Name column.
b) Select the field type for each field.
– For Date use Date[DATE]. (Press the D key to select it.)
– FuelCost, FuelQuantity, and Odometer use Number [NUMERIC]. (Press the N
key once to select it.)
– PaymentType uses Text [VARCHAR], the default setting.
c) FuelCost, FuelQuantity, and Odometer also need changes in the Field Properties
section (Figure 239).
– FuelCost: Change the Length to 5 and Decimal places to 2. Click the Format
example ellipsis button (...) (Figure 239). This opens the Field Format dialog
(Figure 240). Use Currency as the Category and your currency as the Format. My
currency has two decimal places. Use what is appropriate for yours.
– FuelQuantity: Change Length to 6 and Decimal places to 3. (Many fuel pumps
measure fuel to thousandths of a gallon in the USA.)
– Odometer: Change the Length to 10 and the Decimal places to 1.
d) Repeat steps a) through c) until you have entered all of the fields.
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Figure 239: Changing field properties

Figure 240: Format example options
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4) To save and close the table in the Table Design dialog, select File > Save, or click the
Save icon on the Standard toolbar, or press Ctrl+S. Name the table Fuel.
5) Close the Table Design dialog.
6) In the main database window, select File > Save, click the Save icon on the Standard
toolbar, or Ctrl+S to save the database.
Follow the same steps to create the Vacations table. The fields, field types, and descriptions are
listed in Figure 241.

Figure 241: Fields in Vacations table
7) Make the following changes in the Field Properties area of the window.
a) Odometer: As described in step 3)), bullet c)) for the corresponding field of the Fuel
table.
b) Motel, Tolls, Breakfast, Lunch, Supper, SnCost, and Miscellaneous: Format currency
the same as step 3)), bullet c)) for the FuelCost field of the Fuel table.
8) Making Date the primary key in this table has to be done in a different way because this
field is typed as Date, not Integer.
a) Right-click to the left of the field name Date.
b) Select Primary Key in the context menu.
Following similar steps to those above, you should use Design View to create a much simpler
table entitled Payment Type. This table contains two fields, named Type, with the field type set to
Text[VARCHAR] and PaymentID (field type Integer). Set the PaymentID field as the primary key
for the table.
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Defining relationships
Now that the tables have been created, what are the relationships between our tables? This is
the time to define them based upon the questions we asked and answered in the beginning.
When on vacation, we want to enter all of our expenses at once each day. Most of these
expenses are in the Vacations table, but the fuel we buy is not. So we will link these two tables
using the Date fields. Since the Fuel table may have more than one entry per date, this
relationship between the Vacations and Fuel tables is one to many (it is designated 1:n.)
The Fuel and Maintenance tables do not really have a relationship even though they share
similar fields: Date and Odometer readings. (We are not creating the Maintenance table in these
examples.)

Tip
As you create your own databases, you will also need to determine if tables are
related and if so how.
1) To begin defining relationships, select Tools > Relationships. The Automobile –
LibreOffice Base: Relation Design window opens and the Add Tables dialog pops up.
(You can also open it by clicking the Add Tables icon on the Relation Design window if
you ever need to do so.)
2) In the Add Tables dialog, use either of these ways to add a table to the Relation Design
window:
– Double-click the name of the table. In our case, do this for both Vacations and Fuel.
– Or, for each table, click the name of the table and then click Add.
3) Click Close to close the Add Tables dialog when you have added the tables you want.
4) Define the relationship between the Vacations and Fuel tables: click the New Relation
icon on the Standard toolbar, or select Insert > New Relation. This opens the Relations
dialog (Figure 243). Our two tables are listed in the Tables Involved section.
a) In the Fields Involved section, click the drop-down list under the Fuel label.
b) Select Date in the list.
c) Click in the cell to the right of this drop-down list. This opens a drop-down list for the
Vacations table.
d) Select Date in the list. It should now look like Figure 243.
e) Modify the Update Options and Delete Options section of the Relations dialog (Figure
244).
– Select Update cascade in the Update options area.
– Select Delete cascade in the Delete options area.
f) Click OK.
g) In the Relation Design dialog, click the Save icon or select File > Save.
h) Close the Relation Design dialog.
i) Click the Save button on the Standard toolbar at the top of the main database
window.
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Figure 242: Designation for a 1:n relationship

Figure 243: Selected fields in a relationship

Tip
The primary key can contain more than one field. (Its foreign key2 will contain the
same number of fields.) If this were the case in Figure 243, the other fields of the
primary field for the Fuel table would be listed under Date. The corresponding fields
of the foreign key would be listed under Vacations. Detailed information about this is
in the Base Guide.

Figure 244: Update Options and Delete Options section
While these options are not strictly necessary, they do help. Having them selected permits you to
update a table that has a relationship defined with another table which has been modified. It also
permits you to delete a field from the table without causing inconsistencies.

2

A field in a table that stores values of the primary key of records in another table.
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Creating a database form
Databases are used to store data. But, how is the data put into the database? Forms are used to
do this. In the language of databases, a form is a front end for data entry and editing.
A simple form consists of the fields from a table (Figure 245). More complex forms can contain
much more, including additional text, graphics, selection boxes, and many other elements. Figure
246 is made from the same table with a text label (Fuel Purchases), a list box placed in
PaymentType, and a graphic background.

Tip
A list box is useful when a field contains a fixed number of options. It saves you from
having to type data by hand and having to double-check that the entered data is
correct, and ensures that invalid options are not entered.

Figure 245: Fields of a simple form

Figure 246: Simple form with additions

In our database, payments for food or fuel might be made from one of two credit cards (Dan or
Kevin) or in cash, so these would be the available options for all boxes that contain payments.
To create a list box, we first need to create a small, separate table containing the name of the
options. This is then linked to the corresponding field in the form. See the Base Guide for details.

Using the Form Wizard to create a form
We will use the Form Wizard to create a Vacations form, which will contain a form and a subform.
In the main database window (Figure 232), click the Forms icon in the Database area, select
View > Forms, or press Alt+M. In the Tasks list, click Use Wizard to Create Form to open the
Form Wizard (Figure 247). Base displays the Database Form window and the Form Wizard.
Simple forms require only some of these steps, while more complex forms may use all of them.
Step 1: Select fields
1) On the Form Wizard dialog, under Tables or queries drop-down, select Table: Vacations.
Available fields lists the fields for the Vacations table.
2) Click the >> button to move all of these fields to the Fields in the form list. Click Next.

Tip
Using the four action buttons in the center of this page, you can move selected
fields, or all fields, in either direction. You can also double-click to move a field from
one list to the other. The up and down arrows on the right can be used to re-order
entries in the Fields in the form list.
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Figure 247: Selecting fields in the Form Wizard
Step 2: Set up a subform
Since we have already created a relationship between the Fuel and Vacations tables, we will use
that relationship. If no relationship had been defined, this would need to be done later in the
wizard (Step 4: Get joined fields).
1) Click the box labeled Add Subform.
2) Click Subform based upon existing relation.
3) Fuel is listed as a relation we want to add. So click Fuel to highlight it, as in Figure 248.
Click Next.

Figure 248: Adding a subform
Step 3: Add subform fields
This step is similar to Step 1: Select fields. The only difference is that not all of the fields will be
used in the subform.
1) Fuel is preselected under Tables or queries.
2) Use the >> button to move all the fields to the Fields in the form list.
3) Click the FuelID field to highlight it.
4) Use the < button to move the FuelID back to the Available fields list (Figure 249).
5) Click Next.
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Figure 249: Selecting fields of a subform
Step 4: Get joined fields
This step is for tables or queries for which no relationship has been defined. Because this has
been defined in the relationship, the wizard skips this step.

Note
It is possible to create a relationship between two tables that is based upon more
than one pair of fields. How to do that and why is discussed in the Base Guide.

Caution
When selecting a pair of fields from two tables to use as a relationship, they have to
have the same field type. That is why we used the Date field from both tables: both
their field types are Date[DATE].
Whether a single pair of fields from two tables are chosen as the relationship, or two
or more pairs are chosen, certain requirements must be met for the form to work.
– One of the fields from the main form must be the primary key for its table. (Date would
have to be used.)
– No field from the subform can be the primary key for its table. (FuelID cannot be
used.)
– Each pair of joined fields must have the same field type.
Step 5: Arrange controls
A control in a form consists of two parts: label and field. This step in creating the form determines
where a control’s label and field are placed relative to each other. The four choices from left to
right are Columnar – Labels Left, Columnar – Labels on Top, As Data Sheet, and In Blocks –
Labels Above.
1) Arrangement of the main form: Click the second icon (Columnar – Labels on Top). The
labels will be placed above their field.
2) Arrangement of the subform: Click the third icon (As Data Sheet). (The labels are column
headings and the field entries are in spreadsheet format.) Click Next.
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Figure 250: Arrange controls
Step 6: Set data entry
Unless you have a need for any of these entries to be checked, accept the default settings. Click
Next.
Step 7: Apply styles
1) Select the color you want in the Apply styles list. (I chose the Beige option.)
2) Select the Field border you want. (I prefer the 3D look option. You might want to
experiment with the different possible settings.)
3) Click Next.
Step 8: Set name
1) Enter the name for the form. In this case, it is Vacations.
2) Click Modify the form.
3) Click Finish. The form opens in edit mode, Base displaying the Fuel – LibreOffce Base:
Database Form window.

Figure 251: Basic form created using Wizard
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Modifying a form
The form does not look organized at all. Every control seems to have a different size. The
background is not the best color, nor are all of the labels the way we would want them.
The reason for different sized controls is that they contain different types of field data. There are
three different sized controls: text, formatted, and date. Text controls have their width set to
display a large number of characters. Formatted controls will usually contain numbers or
decimals although they can contain a wide variety of formatting. So, these are likely going to
have a limited number of characters, hence a shorter control. Date controls obviously contain
dates. Most formats for them are fairly short, which is the reason for their width. However, one of
the date formats is day of the week, month day, year (Thursday, October 31, 2020). This needs a
larger width than 10/31/2020 or 31/10/2020 for example.
First, all of the payment type controls need to be modified. The fields need to be replaced with a
list box, and each needs to be related to an existing field in the table, Payment Type. The rest of
the controls require modification based upon the category into which they fall.

Note
The steps that follow assume that the PaymentType table already contains three
single-field records. These might be Cash, Dan, and Kevin. If necessary you could
use the Form Wizard to create a very simple form to input or edit these values.
We will carry out the following steps:
1) Replace fields with list boxes.
2) Modify text controls (label field first and then the data field).
3) Modify date control.
4) Modify formatted controls.
5) Modify fields in the table.
6) Group the controls (food, fuel subform, and miscellaneous).
7) Modify memo control.
8) Add headings (for each group in the form).
9) Change the background to a picture, then modify some of the labels so that they can be
read clearly against this background. Change the font color of the headings.
10) Change tab order of fields.
Figure 252 shows a section of the Form Design toolbar, identifying key icons that will be used
during the following steps. Figure 253 shows the Form Navigator.

1

Design Mode

3

Form Properties

2

Control Properties

4

Form Navigator

Figure 252: Part of Form Design toolbar
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Figure 253: Form Navigator
Step 1): Replace fields with list boxes
1) Use the Control Properties and Form Navigator icons on the Form Design toolbar to
open the corresponding dialogs. (You may need to select a control for the Control
Properties icon to become available)
2) Going down the list of labels and fields in the Form Navigator, click the first text box
whose name contains the word “Payment”.
3) If both the label and text box components of the field are highlighted in the Form
Navigator, double-click the text box so that only it is highlighted.

Tip
In some cases when the Form Navigator does not have the input focus, selecting a
field highlights both components (for example, label and text) of the field. If this
arises, then double-clicking the required component will highlight it, and enable you
to subsequently move from one component to another with a single click.
4) Right-click the text box in the Form Navigator and select Replace with > List Box in the
context menu.
5) In the Properties dialog, the heading becomes Properties: List Box.
6) The General tab is selected, so scroll down to the Dropdown property. Change No to Yes.
7) Click the Data tab.
8) Go to Type of list contents. Change Valuelist to Sql.
9) The line below this becomes List content. Click the ellipsis (…) to the right of this
property.
10) Base opens the SQL Command – LibreOffice Base: Query Design window and the Add
Table or Query dialog. The PaymentType table has the entries that are required.
Click it, and then click the Add button.
Close the Add Table or Query dialog.
11) In the SQL Command – LibreOffice Base: Query Design window, double-click Type in the
table named PaymentType. This places Type in the Field row of the tabular area.
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Figure 254: Selecting PaymentType
12) Save and close this window. The SQL code appears in the List content property. (SELECT
"Type" FROM "PaymentType")
13) Change the Bound field value from 1 to 0.
14) Repeat these steps for each field containing the word “Payment”, six fields in total. (See
Note below before doing this.)

Tip
There are times, as in this example, when 8)) through 12)) produces the same SQL
code. When this happens, copy the code. Paste the code into the Type of list
contents property before doing 13)). It is a nice shortcut.
Step 2): Modifying text controls
These are limited to controls whose fields begin with txt. This is when the labels and fields are
modified if necessary to make them more meaningful. In this example, all but one control
contains the word “Payment”. The content of these are payment types which determines that
name given to them. The other one is named Note.
Next the size of the controls needs to be modified based upon the contents they will contain.
Because it is hard to determine beforehand just how large the Note control needs to be, this will
be done after all of the other controls are arranged in a more compact order. The rest of the
controls with text will have their sizes changed now.
1) Rename the labels.
a) Locate the topmost text control in the Form Navigator.
b) Select the associated the control label (begins with lbl). Make sure that the title of the
Properties dialog has become Label Field.
c) Click the General tab if it is not already selected.
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d) Click the down-arrow at the right end of the Label property to open the drop-down.
Only then rename the label to Payment Type and press Enter.
e) Click on another property to save this change.
f) Adjust the width of the label field if necessary for the new width of the label name.
g) Repeat a)) through f)) for each label field in the form that contains the word Payment.

Note
This database form contains multiple controls with the same label: Payment Type.
When this name has been entered for the first time, it can be copied. In d)) for the
next label, highlight the current label name, paste the name you want, and click
another property.
2) Resize the fields.
a) Make sure that you are in the edit mode, with the Form Navigator and Properties
dialogs open.
b) In the Form Navigator dialog, click the field whose size you want to change.
c) Scroll down to the Width property in the Properties dialog.
d) Estimate the width required based on the set of possible values for this field and
change the Width property to that value. In the case of our Payment Type fields, the
text box should be wide enough for the longest possible payment type value of
“Kevin”.

Figure 255: Modifying listbox properties
e) Click either the PositionY or the Height property to save the change. (These are
adjacent properties, but clicking on any other property will do the same thing.)
f) Use these same steps to change the size for each of the remaining text controls,
including txtSnackNo and all the payment type fields.
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Step 3): Modify date control
1) With the Properties and Form Navigator dialogs open, select the datDate field in the
Form Navigator dialog. The heading of the Properties dialog changes to Properties: Date
Field.
2) In the General tab of the Properties dialog, scroll down to the Date format property. In the
drop-down list, select the date format you desire.
3) Scroll down to the Dropdown property and select Yes.
4) Is the width of the Date field inappropriate for the selected format? If so:
a) The Date field has a border around it.
b) Move the cursor over the middle green marker on the right side of the Date field. It
should become a horizontal double arrow. Drag this to the right to increase the width.
Drag it to the left to reduce the width. (It may take several attempts to get this right.)
Step 4): Modify formatted controls
At each step, instructions have been given for which changes need to be made. With the help of
the Form Navigator, make a list of the formatted fields and their labels. The fields are those with
the prefix, fmt. (There are eight of them.)
One of these fields, Odometer, contains the odometer readings as integers. The rest are
currency fields. Selecting the correct format follows the same steps.
Working with one control at a time perform the following tasks:
1) Check that the label of the control provides the annotation that you require. In the case of
lblSnCost, change it to Snack Cost.
2) Click the label of the control to be modified in the Form Navigator. If the border for the
label is longer or shorter than the text in the label, adjust its width as described for the
Date field above.
3) Click this formatted field in the Form Navigator list.
a) Under the General tab, scroll down to the Formatting property.
b) Click the ellipsis (…) on the right to open the Format Number dialog.
c) For the Odometer field click Number in the Category list, otherwise click Currency.
d) Under Format, select the example to be used.
e) Select the desired number of decimal places (one for Odometer, two otherwise).
f) Select the desired number of leading zeros.
g) Negative numbers red: check if yes, remove the check if no.
h) Thousands separator: check if yes, remove check if no.
i) Click OK.
j) If the width of the field is not correct for the selected format, adjust its width as
described for the Date field above.
4) Repeat these steps for each field name in the Form Navigator that begins with fmt.
Step 5): Modify fields in the table
The labels in these controls form the headings of the columns. The values of the field are in the
column. The Form Navigator does not show any information about them. So modifications must
be done using the Properties dialog.
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The controls in a table control require the same types of modification as have already been
discussed. To change things, click the header to be able to access that particular control’s
properties.
1) Click the Date label (the column named Date).
a) Scroll to the Date format property. In the drop-down list, select the format you desire,
if different from the default setting.
b) Scroll to the Width property. Adjust the width if necessary.
c) Scroll to the Dropdown property. If you want to have a small calendar pop-up window,
select Yes.
2) Click the FuelCost label.
a) Open the drop-down list for the Label property. Add a space between Fuel and Cost.
Press Enter.
b) Scroll to the Formatting property. Click the ellipsis (…) on the right. Select Currency
from the Category column. Uncheck Negative numbers red and Thousands
separator. Click OK.
c) Scroll to the Width property. Adjust the width if necessary.
d) Change the Alignment property if you do not want data to be to the left. Select Center
to put the data in the middle of the cell.
3) Click the FuelQuantity label.
a) Open the drop-down list for the Label property. Add a space between Fuel and
Quantity. Press Enter.
b) Scroll to the Formatting property. Change if needed to show three decimal places.
c) Scroll to the Width property. Adjust the width if necessary.
d) Change the Alignment property if you do not want data to be to the left. Select Center
to put the data in the middle of the cell.
4) Click the Odometer label.
a) Scroll to the Formatting property. Change if needed to show one decimal place.
b) Scroll to the Width property. Adjust the width if necessary.
c) Change the Alignment property if you do not want data to be to the left. Select Center
to put the data in the middle of the cell.
5) Click the PaymentType label.
a) Right-click this label to open a context menu to add a list box. Select Replace with >
List Box in the context menu.
b) Open the drop-down list for the Label property. Add a space between Payment and
Type. Press Enter.
c) On the Data tab, change the Type of list contents property to Sql.
d) Paste the SQL code SELECT "Type" FROM "PaymentType" into the List content
property. (This is a shortcut method – see the Tip on page 278 and the detailed
instructions above it if you want more details).
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Step 6): Group the controls
This is a suggested layout which looks reasonably well organized. Use this one or create one
that appeals to you. The controls may be wider or narrower than yours because of the content
that will be in them. Note that this layout has left space for the additional labels that will be added
later.
1) Three icons need to be activated on the Form Design toolbar: Display Grid, Snap to
Grid, and Helplines While Moving. If this toolbar is on the side of the form, click the
double arrow (») to open a sub toolbar showing them. If the toolbar is on the top or
bottom of the form, they are on the right end of it. If there is a double arrow at the end,
click it to reveal them. Make sure they are highlighted as in this figure.

Figure 256: Help for moving controls

Tip
You can also control the Display Grid, Snap to Grid, and Helplines While Moving
options using the View > Grid and Helplines menu.
2) Some of the controls need to be moved in pairs so the Form Navigator needs to remain
open. Close the Properties dialog now.

Figure 257: Form suggested layout
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Note
When moving a control, it is tempting to use the PositionX and PositionY properties
to place the control exactly where you want it to be. Do not do this. This will place
the control’s label and field on top of each other. These properties can be used to
move a label or field to a specific location, but are not designed to move a control.
Use the Position and Size icon on the Form Design toolbar to move a control or
group of selected controls.
The list in the Form Navigator reveals which controls needed to be grouped based upon their
names:
– lblMotel / fmtMotel with lblMPayment / txtMPayment;
– lblBreakfast / fmtBreakfast with lblBPayment / txtBPayment;
– lblLunch / fmtLunch with lblLPayment / txtLPayment;
– lblSupper / fmtSupper with lblSPayment / txtSPayment;
– lblSnackNo / txtSnackNo with lblSnCost / fmtSnCost and with lblSnPayment /
txtSnPayment (group these three controls together);
– lblMiscellaneous / fmtMiscellaneous with lblMiscPayment / txtMiscPayment.
That is six groups of controls; each one will be moved separately.
The layout shows, for each of these groups, an order as to where each control of a group goes.
For most of them, the first control holds the cost, and the second contains the payment type in a
row. The snacks places the number of snacks followed by the cost and then the payment type.
The miscellaneous controls contains the payment below the cost.
3) Before moving an entire group to a new location, move the controls within the group to
where you want them to be relative to each other, such as the order mentioned in the last
paragraph.
a) Click on the first control, placing a border around it.
b) Place the cursor over the label or field where it changes its shape.
c) Drag it to an open area of the form.
d) Using the same method, move the second control to the correct position relative to
the first control.
As soon as you begin to move it, the helplines will appear. Use them to line up the
edges of the controls before releasing the cursor.
e) If there is a third control, move it to the correct position relative to the second one.
4) Move the controls for the group to where you want them:
a) Click the first component in the Form Navigator list.
b) Use the standard Control+Click and Shift+Click mechanisms until all of the labels and
fields in this group are highlighted.
c) Place the cursor over one of the labels or fields changing the arrow.
d) Drag the group to where you want its controls to be.
5) Repeat for the other controls using these same steps. If a group is going to be below
another group of controls, use the helplines to line up the left end of the two groups (for
example: first control under left control).
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Step 7): Modify memo control
The size of the Note control allows it to be moved into a place on the form that permits the
controls of the form to be organized without changing the size of the Note control. This might not
always be the case. If the size had needed modification, this is done using the same methods as
for other text controls.
The other modification is adding scrollbars. The choices are none, vertical, horizontal, or both.
1) To change the size of this control, follow the same steps for changing the size for any text
control.
2) If necessary, move the control to the required position using the same steps described
above for grouping the controls (Step 6)).
3) Click the Control Properties icon on the Form Design toolbar if the Properties dialog is
not open.
4) Select the txtNotes control in the Form Navigator dialog.
5) On the Properties dialog, click the General tab if it is not selected.
6) Scroll down to the Text type property.
7) Select the Multi-line option in its drop-down list.
8) Scroll down to the Scrollbars property.
9) In its drop-down list, select the option you need (None, Vertical, Horizontal, or Both).
10) Close the Properties dialog.

Figure 258: Scroll bar selections in the Properties dialog
Step 8): Add headings
This task is easier to complete if you have end-of-paragraph markers visible. You should turn
them on by selecting View > Formatting Marks, or by clicking the Toggle Formatting Marks
icon on the Standard toolbar, or by pressing Ctrl+F10.
1) Make sure that the cursor is in the top left hand corner of the Database Form window. If it
is not, click in that corner to move the cursor there.
2) Press the Enter key repeatedly to move the cursor down until it aligns with the gap
between the Date field and the Breakfast field.
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3) Use the Set Paragraph Style drop-down list on the Formatting toolbar to select the
Heading 2 style.
4) Use the space bar to move the input cursor along the empty line to the position where
you want the first heading to appear. Type the heading Meals.
5) Use the space bar to move the input cursor along the same line to the position where you
want the second heading to appear. Type the heading Snacks.
6) Press the Enter key repeatedly to move the cursor down until it aligns with the gap
between the Supper field and the table.
7) If necessary, use the Set Paragraph Style drop-down list on the Formatting toolbar to reselect the Heading 2 style.
8) Use the space bar to move the input cursor along the line to the position where you want
the table’s heading to appear. Type the heading Fuel Data.

Tip
If you have experience in using styles, you can open the Styles deck by selecting
View > Styles, or by pressing F11. Right-clicking the Heading 2 style and selecting
the Modify option in the context menu would allow you to quickly modify the
appearance of all three headings. See the Writer Guide for details.
Step 9): Change the background
The background for a form can be a color, or a graphic (picture). You can use any of the colors in
the color table at Tools > Options > LibreOffice > Application Colors. If you know how to
create custom colors, you can use them. You can also use a picture (graphic file) as the
background.
To add a color to the form background:
1) Right-click the form and select Page Style in the context menu.
2) Base displays the Page Style dialog (Figure 259). Make sure the Area tab is selected.

Figure 259: Page Style dialog
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3) Select Color in the row of buttons near the top of the tab.
4) Select a color from the grid. You can change the color palette to access more choices or
use the RGB or Hex boxes to specify a color, or click Pick for even more choices.
5) Click Apply to see what your selection will look like in your form.
6) Change if necessary.
7) Click OK to accept your color choice and close the dialog.
To add other form backgrounds:
1) Perform steps 1)) and 2)) as for adding color to the background.
2) Select the type of background from the row of buttons: None, Gradient, Bitmap, Pattern,
or Hatch.
3) In the selected type, choose one of the selections provided or create your own. For
details, see Chapter 4, Changing Object Attributes, in the Draw Guide.
4) Click Apply to see what your selection will look like in your form.
5) Click OK to accept your choice and close the dialog.
If you selected a bitmap in the list, the form might look like Figure 260.

Figure 260: Finished form
Step 10): Change the tab order
The Tab key moves the cursor from field to field. This is much easier to do than to click each field
to enter data into it. It also permits us to group our expenses into areas before we begin entering
data. For example, all of our meal receipts can be grouped together as can our snacks and also
our fuel purchases.
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Figure 261: Form Design toolbar with Activation Order icon circled
1) If it is not open already, select View > Toolbar > Form Design to open the Form Design
toolbar.
2) Click the Activation Order icon (circled in Figure 261).
3) Rearrange the order of the fields in the Tab Order dialog.
a) If you click the Automatic Sort button, Base will interpret the structure of your form
and propose what it considers to be a sensible tab order.
b) You can use the Move Up and Move Down buttons to change the position of a
selected control in the list.
c) You can drag a control from one position to another in the Controls list.
d) You may chose to define your own tab order, or you could put the fields in the same
order as that shown in Figure 262.
e) Click OK.
4) Save and close the form.
5) Save the database.

Figure 262: Possible tab order for the Vacations form
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Entering data in a form
Records are used to organize the data we enter into a form. They also organize the data we
enter into a subform.
Different types of fields allow different methods of data entry. In many cases, more than one
method can be used.
The first step to entering data in a form is to open it from the main database window (Figure 232).
1) Click the Forms icon in the Database list, or select View > Database, or press Alt+M.
2) Find the form’s name in the Forms list (Vacations).
3) Double-click the form’s name.

Note
The order in which the following descriptions are presented assume a particular tab
order for the form, and this may not match the tab order that you want to define.
The quickest way to enter a date in the Date field is to click the arrow that opens the drop-down
calendar (Figure 263) and click the day that you want. Then press the Tab key to go to the next
field.

Figure 263: Calendar drop down
The Odometer, Tolls, and Motel fields are numeric fields. Enter values directly into them, or use
the up and down arrows (if you selected to display them during form creation). When the value
has been entered, use the Tab key to go to the next field.
•

Typing the up arrow increases the value, and the down arrow decreases the value by one
unit.

•

The two arrows only change the numerals to the left of the decimal place.

•

Numerals to the right of the decimal place must be changed by deleting them and typing
the desired ones.

The Motel’s Payment Type field is a drop-down list. If, as in my case, all of the elements of the list
start with different letters, typing the first letter selects the desired entry.
•

If two or more elements of the list have the same first letter, repeated typing of the first
letter will cycle through these elements.

•

When the selection is correct, use the Tab key to go to the next field.

The rest of the fields of the main form are either numeric fields or drop-down lists until we reach
the Notes field. It is a text field. Type anything you desire in this field just as you would any simple
text editor.
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Note
The Tab key is used to move between fields. But since text fields do not have tab
positions in them, they can not be used to move from one position in the field to
another one. All spacing must be done by the space bar. The Enter key is a little
more complex. It can be used to move between non-text fields. With a text field, its
action depends upon whether the text field has a single line property. With it,
pressing Enter will move the cursor to the next field. But when the field has a multiline property, pressing Enter moved will only move the cursor down one line. With
this field, the Tab key has to be used to move the cursor to the next field.
If we did not have a subform for fuel data, pressing the Tab key in the last field would
save all of the fields, clear them, and make the form ready to accept data on the
second record.
Since we have a subform, using the Tab key places the cursor in the first Date field of the
subform with the date automatically entered to match the Date field of the main form.
The Fuel Cost, Fuel Quantity, and Odometer fields are numeric fields. The Payment Type field is
a drop-down list. Enter the data just as you did in the main form, and use the Tab key to go to the
next field.
When you use the Tab key to leave the Payment Type field, it goes to the Date field of the next
line and automatically enters the date. Now you can enter your second set of fuel data for this
day.

Figure 264: Sample record of the Vacations form and subform
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To move to another record when the form has a subform, click any of the fields of the main form.
In this case, click the Date field of the main form. Then use the directional arrows at the bottom;
from left to right: First Record, Previous Record, Next Record, and Last Record (all have
keyboard shortcuts identified in their extended tips). To the right of these arrows is the New
Record icon.
To create a new record while in the last record of the main form, click either the Next Record icon
or the New Record icon.

Tip
The number in the Record box is the number of the record whose data is shown in
the form.
If you know the number of the record you want, you can enter it into the record box
and then type Enter to take you to that record.
Figure 264 is a record with data inserted in its fields.

Quickly populate a table with data from a spreadsheet
If you have data in a spreadsheet document that represents the layout of a database table, and
you want to copy it into a table of your database, then it is possible to load the sheet contents
quickly by dragging and dropping the sheet into a database table:
1) Open the database file in the LibreOffice Base window (Figure 232) and select the Table
view.
2) Open the spreadsheet in Calc. Select the sheet you want to insert in the database.
3) Place the two windows side by side on your desktop.
4) Drag the sheet tab in the bottom of the Calc window into the table list of the database file.
The mouse pointer shows a square with a + sign. (Sheet tab: This has the name of the
sheet on it.)
5) Drop the sheet by releasing the mouse button.
6) The Copy table wizard appears to help you migrate the content to the database table.
7) On the first page of the wizard, select the options of the copy operation and name the
database table. Each option is explained in the Help (F1).
8) On the second page of the wizard, select the sheet columns you want to copy into the
table.
9) On the third page of the wizard, define the data type of each column of your table.
10) Click Create to populate the new table with the spreadsheet data.

Note
The Copy table operation copies only values and strings from the Calc spreadsheet.
It does not copy formulas.
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Creating queries
Queries are used to get specific information from a database. Their results are special tables
within the database.
To demonstrate the use of queries, we will use two different methods:
•

Using our CD-Collection table, we will create a list of albums by a particular artist. We will
do this using the Query Wizard.

•

The information we might want from the Fuel table includes what our fuel economy is. We
will do this using Design View. (Queries that require calculations are best created with
Design View.)

Using the Wizard to create a query
Queries created by the Query Wizard provide a list, or lists, of information based upon what one
wants to know. It is possible to obtain a single answer or multiple answers, depending upon the
circumstances.
In the main database window (Figure 232), click the Queries icon in the Database section, select
View > Queries, or press Alt+Q. In the Tasks section, click Use Wizard to Create Query. The
Query Wizard dialog opens (Figure 265). The information we want is which albums are by a
certain musical group or individual (the album’s artist). We can include when each album was
bought.

Note
When working with a query, more than one table can be used. Since different tables
may contain the same field names, the format for naming fields in a query is table
name.field name, with a period (.) between the table name and the field name. For
example, the Lunch field of the Vacations table used in a query has the name
Vacations.Lunch.

Figure 265: First page of the Query Wizard
Step 1: Select the fields
1) Select the Table: CD-Collection option in the Tables drop-down list.
2) Select fields from the CD-Collection table in the Available fields list.
a) Click Artist, and use the > button to move it to the Fields in the Query list.
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b) Move the AlbumTitle and DatePurchased fields in the same manner. You can also
move a single field from one list to the other by double-clicking.
c) If you make a mistake, you can return an unwanted field from the Fields in the Query
list to the Available fields list by selecting it and then typing the < button.
d) In other circumstances, you can use the >> and << buttons to move all fields in one
list to the other list.
3) Click Next.

Tip
To change the order of the fields, select the field you want to move and click the up
or down arrow to the right of the Fields in the Query list.
Step 2: Select the sorting order
Up to four fields can be used to sort the information of our query. A little simple logic helps at this
point. Which field is most important?
In our query, the artist is most important, the album title is less important, and the date purchased
is of least importance. Of course, if we were interested in what music we bought on a given day,
the date purchased would be the most important.

Figure 266: Sorting order page
1) Click the first Sort by drop-down list.
a) Select the CD-Collection.Artist option.
b) To list the artists in alphabetical order (a-z), select Ascending on the right.
2) Click the first Then by drop-down list.
– Select CD-Collection.AlbumTitle and then select Ascending.
3) Click the second Then by drop-down list.
– Select CD-Collection.DatePurchased and then select Ascending.
4) Click Next.
Step 3: Select the search conditions
The search conditions allow us to compare the name we entered with the names of the artist in
our database and decide whether to include a particular artist in our query results or not. The
following options are available:
•

is equal to: the same as

•

is not equal to: not the same as

•

is smaller than: comes before

•

is greater than: comes after

•

is equal or less than: the same as or comes before
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•

is equal or greater than: the same as or comes after

•

like: similar to in some way

•

not like: is not similar to

•

is null:

•

is not null:

Note
These conditions apply to numbers, letters (using alphabetical order), and dates.
1) Since we are only searching for one thing, we will use the default setting of Match all of
the following.
2) We are looking for a particular artist, so select CD-Collection.Artist in the Fields dropdown and is equal to in the Condition drop-down.
3) Type the name of the artist in the Value box.
4) Click Next.
Step 4: Select the type of query
We want simple information, so the default setting: Detailed query is what we want. Click Next.

Note
Since we have a simple query, the Grouping and Grouping conditions are not
needed. Steps 5 and 6 of the wizard are skipped in our query.
Step 7: Assign aliases if desired
The fields, AlbumTitle and DatePurchased, have names made up of two words without
separation. Instead, aliases can be made containing two words each (Album Title and Date
Purchased, respectively).
1) Change the alias for AlbumTitle to Album Title.
2) Change the alias for DatePurchased to Date Purchased.
3) Click Next.
Step 8: Overview
1) Make sure that the query conditions listed in the Overview area are the ones you wanted.
2) If something is wrong, use the Back button to move to the step that contains the error.
3) Then use the Next button to return to this Overview step.
4) Name the query (suggestion: Query_Artists).
5) To the right of this are two choices. Select Display Query.
6) Click Finish.
Base displays the LibreOffice Base: Table Data View query showing any records that match the
query. Close the window when you have finished with it.

Using Design View to create a query
Creating a query using Design View is not as difficult as it may first seem. It may take multiple
steps, but each step is fairly simple.
What fuel economy is our vehicle getting (miles per gallon in the USA)? This question requires us
to create two queries, with the first query used as part of the second query.
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Step 1: Open the first query in Design View
•

Click Create Query in Design View in the Tasks area of the main window. Base displays
the Add Table or query dialog (Figure 267) and the LibreOffice Base: Query Design
window.

Step 2: Add tables to window
1) In the Add Table or query dialog, click Fuel to highlight it.
2) Click Add.
3) Click Close.
4) Base closes the Add Table or Query dialog and includes the Fuel table in the upper area
of the Query Design window.

Figure 267: Add Table or Query dialog

Tip
Move the cursor over the bottom edge of the Fuel table (Figure 268) and drag the
edge to make it longer and easier to see all of the fields in the table.

Figure 268: Fuel table in query
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Step 3: Add fields to the table at the bottom
1) Double-click the FuelID field in the Fuel table.
2) Double-click the Odometer field.
3) Double-click the FuelQuantity field.
4) Double-click the FuelCost field.
The query table at the bottom of the Query Design dialog should now have four columns (Figure
269).

Figure 269: Query table
Step 4: Set the criterion for the query
We want the query to include FuelID values that are greater than 0.
1) Type >0 in the Criterion cell under FuelID in the query table.
2) Click the Run Query icon on the Query Design toolbar(circled in red in Figure 270), or
click View > Run Query, or press F5.

Figure 270: Run Query icon in Query Design toolbar
Base presents the results of the query in the area above the query table.
Figure 271 shows the Fuel table with my entries. The query results based upon the Fuel table are
shown in Figure 272.

Figure 271: Fuel table

Figure 272: Query of Fuel table
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Step 5: Save and close the query
Since this query contains the final odometer reading for our calculations, name it End-Reading
when saving it. Then close the query. Now click the Save icon in the main database window.
Step 6: Create the query to calculate the fuel economy
1) Click Create Query in Design View in the Tasks area of the main window to open a new
query.
2) Base opens the LibreOffice Base: Query Design window and the Add Table or Query
dialog.
3) Add the Fuel table to the query just as you did in Step 2: Add tables to window but do
not close the Add Table or Query dialog.
4) Add the End-Reading query to this query.
a) Click Queries to get the list of queries in the database (Figure 273).
b) Click End-Reading.
c) Click Add, and then click Close.
d) Base closes the Add Table or Query dialog and displays the Fuel table and EndReading query in the upper area of the Query Design window.

Figure 273: Selecting queries to add to another query
Step 7: Add fields to the table at the bottom of the query
We are going to calculate the fuel economy. To do this we need the fuel quantity and distance
traveled. Since the fuel quantity we want to use is the final odometer reading, we will use the
End-Reading query to get it. We will also use the Odometer field from both the Fuel table and
End-Reading query.

Figure 274: Tables in this query
1) Double-click FuelQuantity in the End-Reading query.
2) Double-click Odometer in the End-Reading query.
3) Double-click Odometer in the Fuel table.
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Figure 275: Added fields to the query
Step 8: Enter the FuelID difference field
We want the difference between the FuelID value of the Fuel table and FuelID value of the EndReading query to equal one (1).
1) Type "End-Reading"."FuelID" - "Fuel"."FuelID" in the field to the right of the Odometer field
of the Fuel table (Figure 276).
2) Type = '1' in the Criterion cell of this column.
3) Leave the Visible cell of this column unchecked.
4) Calculate the distance traveled:
– Type in the next empty Field cell (Figure 277):
"End-Reading"."Odometer" - "Fuel"."Odometer"
– In the Alias row, type Distance.
– Type > '0' in the Criterion cell.
5) Calculate fuel economy: Type
("End-Reading"."Odometer" - "Fuel"."Odometer")/"End-Reading"."FuelQuantity"
in the next column to the right of the word Field (Figure 278).
6) Type Fuel Economy as the alias.

Figure 276: Typing in calculation of fields
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Figure 277: Field for distance traveled calculations

Figure 278: Fuel economy calculation field

Note
When entering fields for these calculations, you must follow this format: table or
query name followed by a period followed by the field name. For hyphenated or
multiple-word names (table or query), use double quotes around the table or query
name. The query will then add the rest of the double quotes as in Figure 278.
Use the arithmetical symbol between the two. More than one calculation can be
done by using parentheses to group the arithmetical operations.
Step 9: Run the query and make some modification
After we run the query to make sure it works correctly, we will hide all of the fields that we do not
need.

Figure 279: Result of running the fuel economy query
1) Click the Run Query icon on the Query Design toolbar (Figure 270). The results are
shown in Figure 279.
Two of the column headers are identical. By giving these two headers different aliases,
we can distinguish them.
2) Add Aliases: Type the aliases as they are listed in Figure 280.
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Figure 280: Query table with Odometer aliases added
3) Run the query again. The results are in Figure 281.

Figure 281: Query run with aliases
Step 10: Close, save, and name the query
My suggestion for a name is Fuel Economy.
1) Click the Save icon.
2) Name the query.
3) Close the query.
4) Save the database file.
There are obviously other calculations that can be made in this query such as cost per distance
traveled and how much of the cost belongs to each of the payment types.

Note
To fully use queries requires a knowledge of set operations (unions, intersections,
and, or, complements, or any combinations of these). Having a copy of the RDBMS
manuals, is also extremely useful.

Creating reports
Reports provide information found in the database arranged in a useful way. In this respect, they
are similar to queries. They are different in that they are designed to be distributed to people.
Queries are only designed to answer a question about the database. Reports are generated from
the database’s tables, views, or queries.
All reports are based upon a single table, view, or query, so you need first to decide what fields
you want to use in the report. If you want to use fields from different tables, you must first
combine these fields in a single query or view. Then you can create a report from this.
For example, a report on vacation expenses includes both fuel costs and meal costs. These
values are contained in fields of two different tables: Vacations and Fuel. So this report requires
you to create a query or view.
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Caution
Dynamic reports update only the data that is changed or added to a table or query.
They do not show any modifications made to the table or query itself. For example,
after creating the report below, open the Fuel Economy query created in the
previous section. For the “End-Reading”.“Odometer” – “Fuel”.“Odometer” column,
change the number 1 to the number 3 (see Figure 276). The report will be identical
before and after you make the change. But if you add more data to the query and run
the report again, it will contain the new data. However, all data will be based upon
“End-Reading”.“Odometer” – “Fuel”.“Odometer” having the value 1. No data will be
present in the report for which “End-Reading”.“Odometer” – “Fuel”.“Odometer” has
the value 3.

Creating a report: Example
We will create a report on vacation expenses. Certain questions need to be asked before
creating the report.
•

What information do we want in the report?

•

How do we want the information arranged?

•

What fields are required to provide this information?

•

Will a query or view have to be created because these fields are in different tables?

•

Are any calculations required in the data before being added to the report?

The expenses for our vacation are motel, tolls, miscellaneous, breakfast, lunch, supper, snacks,
and fuel. One possible report could list the totals of each of these expense groups. Another could
list the expense totals for each day of the vacation. A third could list the totals for each expense
group for each type of payment. (This would let us know where the money came from to pay the
expenses.) Once you create a query to do any one of these, you can create a report based upon
the query.
We will create two reports, one listing the expenses each day (other than fuel) and the second
listing fuel statistics. The fields we need for the first report from the Vacations table are: Date,
Motel, Tolls, Breakfast, Lunch, Supper, Snack Cost, and Miscellaneous. This report only requires
the Vacations table. Had the report listed the total expenses for each of these fields, we would
have to create a query to provide us with these totals, which is beyond the scope of this chapter.
The second report involves the Fuel table. Since this table includes fuel purchases at times other
than during the vacation, we need to create a query that contains only the fuel purchased during
vacation periods.

Report Wizard vs Report Design View
1) When you open the Report Wizard, the Report Builder also opens. As you make your
selections in the wizard, these appear in layout in the Report Builder. When you have
finished making your selections, you save the report, name it and then close it.
2) When using Design View to create a report, you open the Report Builder to design the
layout of it. (There is only one layout available when the wizard is used.)

Vacations table report
To create a new report:
1) Click the Reports icon in the Database area of the main Base window (Figure 232), or
select View > Reports, or press Alt+R.
2) In the Tasks list, click Use Wizard to Create Report. The Report Wizard dialog and the
Report Builder window open.
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Step 1: Field selection
1) Select Table: Vacations in the Tables or queries drop-down list.
2) Use the > to move these fields from the Available fields list to the Fields in report list:
Date, Motel, Tolls, Miscellaneous, Breakfast, Lunch, Supper, and SnCost. The other
buttons (<, >>, <<, up arrow, and down arrow) and the double-click action perform similar
functions to the equivalent interactions on other wizard pages as described earlier in this
chapter.
3) Click Next.

Figure 282: Adding fields to a report
Step 2: Labeling fields
Change any field labels you wish. We will shorten Miscellaneous to Misc. and expand SnackCost
into two words.

Figure 283: Giving aliases to fields
1) Shorten Miscellaneous to Misc.
2) Change SnCost into Snack Cost.
3) Click Next.
Step 3: Grouping
1) Since we are grouping by the date, use the > button to move the Date field from the
Fields list to the Groupings list.
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2) You can use the < button to return an entry in the Groupings list to the Fields list. You can
use the up and down arrows to re-order entries in the Groupings list. You can double-click
to move a field from one list to the other.
3) Click Next.

Figure 284: Selecting fields for grouping data
Step 4: Sort options
We do not want to do any additional sorting.
•

Click Next.

Step 5: Choose layout
1) Select Columnar, three columns in the Layout of data list.
2) Layout of headers and footers have no possible selections.
3) Select Landscape as the Orientation for the page layout.
4) Click Next.

Figure 285: Report Builder template determined by the Report Wizard
Figure 285 shows part of the final template that has been built up in the Report Builder as you
reach the end of the wizard.
Step 6: Create report
1) Title the report: Vacation Expenses.
2) Select the Dynamic report option.
3) Select the Create report now option.
4) Click Finish.
5) LibreOffice opens the output report in read-only mode in Writer.
The report (Figure 286) has been created, but it needs some editing. The date could be
formatted better, and all the numbers need to be formatted as currency. It could use a heading
that includes its name, its author, and the date it was prepared. If the report had more than one
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page, the page numbers could be put in a footer of each page, perhaps including the total
number of pages. But to do these things, you must use Report Builder.

Figure 286: Report without modifications

Report Builder: another way to create reports
With Report Builder, you can create complex and stylish database reports. You can define group
and page headers, group and page footers, and calculation fields. Report Builder is installed with
LibreOffice.
When we used the Report Wizard, we created a template in Report Builder for our report. If we
edit our report, we open Report Builder with this template. By modifying the template, we also
modify the report. For example, we can change the Date field’s format, and it will change the
format of all the dates contained in that field in the above report. Similarly, we can change the
field formatting of any of the other fields and change the format everywhere that field appears in
the report.
Report Builder can also create reports by itself. To do this, click Create Report in Design View.
For instructions on how to use the Report Builder, see Chapter 6, Reports, in the Base Guide.

Accessing other data sources
LibreOffice allows data sources to be accessed and then linked into LibreOffice documents. For
example, a mail merge links an external document containing a list of names and addresses into
a letter, with one copy of the letter being generated for each entry.
To access a data source that is not a *.odb file:
1) Select File > New > Database, or click the arrow at the right of the New icon on the
Standard toolbar and select the Database option in the menu, to open the Database
Wizard.
2) Select Connect to an existing database. Select the required database type in the dropdown list. Click Next.
3) The remaining steps in the Database Wizard may vary depending on which database
type you have chosen.
4) At some stage the wizard may prompt you to browse to, and select, the database of
interest. You will normally select to register the database and open the database for
editing.
5) Finally, click Finish to exit the wizard. Name and save the database in the location of
your choice.

Accessing a spreadsheet as a data source
Accessing a spreadsheet is similar to accessing other databases:
1) Select File > New > Database, or click the arrow at the right of the New icon on the
Standard toolbar and select the Database option in the menu, to open the Database
Wizard dialog.
2) Select Connect to an existing database. Select Spreadsheet in the drop-down list.
Click Next.
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3) Click Browse to locate the spreadsheet you want to access. If the spreadsheet is
password protected, check the Password required box. Click Next.
4) Make sure that the Yes, register the database for me and Open the database for
editing options are selected.
5) Click Finish to exit the wizard. Name and save the database in the location of your
choice.

Note
Using this method of accessing a spreadsheet, you cannot change anything in the
spreadsheet using Base. You can only view the contents of the spreadsheet, run
queries, and create reports based upon the data already entered into the
spreadsheet.
All changes in a spreadsheet must be made in the spreadsheet itself, using Calc.
After modifying the spreadsheet and saving it, you will see the changes in the
database. If you create and save an additional sheet in your spreadsheet, the
database will have a new table the next time you access it.

Registering *.odb databases
Databases created by LibreOffice are in the *.odb (OpenDocument Database) format. Other
programs can also produce databases in this format. Registering a *.odb database is simple:
1) Choose Tools > Options > LibreOffice Base > Databases.
2) Under Registered Databases, click New. LibreOffice displays the Create Database Link
dialog.
3) Browse to where the database is located. Make sure the registered name is correct.
4) Click OK.

Note
Sometimes after updating LibreOffice to a newer version, your list of registered
database files disappears. When that happens, you can use these steps to reregister your database files with your latest version of LibreOffice.

Using data sources in LibreOffice
Having registered the data source, whether a spreadsheet, text document, external database or
other accepted data source, you can use it in other LibreOffice components including Writer and
Calc.

Viewing data sources
Open a document in Writer or Calc. To view the data sources available, press Ctrl+Shift+F4 or
select View > Data Sources. This brings up a list of registered databases, which will include
Bibliography and any other registered database, such as the Automobile database created earlier
in this chapter.
To view each database, click the drop-down arrow for the database’s name (Figure 287). This
expands to show Queries and Tables. Click the drop-down arrow for Tables to view the individual
tables created. Now click on a table to see all the records held in it.
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Figure 287: Databases in
Data Sources window

Editing data sources
Some data sources (but not spreadsheets) can be edited in the Data Sources window. A record
can be edited, added, or deleted.
View a table’s data
If you click on a table, its rows and columns of data appear on the right side of the Data Sources
window. Editing this data requires only a click in the cell whose data should be changed, change
the data, and click in the row above or below it to save the new data.
Beneath the records are five small buttons. The first four move the cursor to the beginning, to the
left, to the right, and to the end respectively. The fifth button, with a small star, inserts a new
record.

Figure 288: Data Sources navigation buttons
To delete a record, right-click on the gray box to the left of a row to highlight the entire row, and
select Delete Rows in the context window to remove the selected row.

Figure 289: Deleting a row in the Data Sources window

Launching Base to work on data sources
You can launch LibreOffice Base at any time in the Data Sources window. Just right-click on a
database or its Tables or Queries components and select Edit Database File in the context
menu. Once in Base, you can edit, add, and delete tables, queries, forms, and reports.

Using data sources in Writer and Calc
Data can be placed into Writer and Calc documents from the tables in the Data Sources window.
In Writer, values from individual fields can be inserted. Or a complete table can be created in the
Writer document. One common way to use a data source is to perform a mail merge.

Figure 290: Toolbar for the Data Sources window
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Tip
Choose Tools > Mail Merge Wizard or click on the Mail Merge icon (circled in
Figure 290) in the Data Sources window to start the Mail Merge Wizard, which steps
you through creating a mail merge document. See Chapter 14 in the Writer Guide.

Writer documents
To insert a field from a table opened in the Data Sources window into a Writer document, click on
the field name (the gray square at the top of the field list) and, with the left mouse button held
down, drag the field onto the document. In a Writer document, it will appear as <FIELD> (where
FIELD is the name of the field you dragged).
For example, to enter the cost of meals and who paid for them on a certain date of a vacation:
1) Open the list of data sources (Ctrl+Shift+F4) and select the Vacations table in the
Automobile database.
2) Use this sentence: “On (date), our breakfast cost (amount) paid by (name), our lunch cost
(amount) paid by (name), and our supper cost (amount) paid by (name).” But only type
“On, our breakfast cost paid by, our lunch cost paid by, and our supper cost paid by.”
3) To replace (date), click the field name Date in the Data Sources window and drag it to the
right of the word On. Insert an extra space if necessary. The result: On <Date>. If you
have field shadings turned on (View > Field Shadings), <Date> has a gray background.
Otherwise it does not.
4) To replace first (amount), click the Breakfast field name and drag it to the right of our
breakfast cost. Make sure you have the proper spacing between the field names and the
words before and after them. Result: breakfast cost <Breakfast>.
5) To replace the first (name), click the BPayment field name and drag it to the right of paid
by. Result: paid by <BPayment>.
6) In the same way, fill in the rest of the fields in the sentence.
– Use <Lunch> and <LPayment> for the second set of (amount) and (name) in the
sentence.
– Use <Supper> and <SPayment> for the third set of (amount) and (name) in the
sentence.
7) Final result: On <Date>, our breakfast cost <Breakfast> paid by <BPayment>, our lunch
cost <Lunch> paid by <LPayment>, and our supper cost <Supper> paid by <SPayment>.
8) Add data to the fields of the sentence:
a) Click the gray box to the left of the row of data you want to add. That row should be
highlighted like the second row of Figure 291.
b) Click the Data to Fields icon in the Table Data toolbar (circled in Figure 291). This
should fill the fields with the data from the row you chose.
c) Click another row and then click this icon again. The data in the sentence changes to
reflect this selected row of data.
d) Save the document if you want to use it as an example later.

Figure 291: Selected row in Data Sources window
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Adding data in table format is a little easier and takes perhaps fewer steps. Some of the steps will
be quite similar.
1) Navigate to the place you want to place the table and click the location.
2) Ctrl+Click the gray box to the left of each row of the data source that you want to be a row
in your table if the rows are not consecutive. To select consecutive rows, click the gray
box to the left of the top desired row and Shift+click the bottom desired row.
3) Click the Data to Text icon to open the Insert Database Columns dialog (Figure 292).
(The Data to Text icon is to the left of the Data to Fields icon in Figure 291.)

Figure 292: Insert Database Columns dialog
4) Move the fields you want in your table from the Database columns list to the Table
column(s) list.
– To place the fields in the order you select, click the field and use the single right arrow
to move the fields in the order you desire. You can also limit the fields you use to less
than all of the fields available.
– To use all of the fields, use the double arrow pointing to the right to move all of them at
one time (this icon may have a different appearance in some environments). The
order of the fields in the table you create will be the same as in the data source table.
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– To remove a single field from the Table column(s) list, click the field and use the single
arrow pointing to the left.
– You can double-click a field in one list to move it to the other list.
5) To start over, click the double arrow pointing to the left (this icon may have a different
appearance in some environments).
6) Select the settings for your table. Use the default settings as in Figure 292.
7) Click OK. Save the document.

Calc spreadsheets
There are two ways to transfer data into a Calc spreadsheet. One enters the data into the
spreadsheet cells. The other creates complete new records in the spreadsheet. While you can
directly access the data inserted into the spreadsheet cells, new records created in the
spreadsheet are read-only.
Entering data directly to the spreadsheet cells uses the Data to Text icon as when making a table
in a Writer document. But there are certain differences.
The steps are straightforward.
1) Click the cell of the spreadsheet which you want to be the top left cell of your data,
including the column names.
2) Use Ctrl+Shift+F4 to open the Data Sources window and select the table whose data you
want to use.
3) Select the rows of data you want to add to the spreadsheet:
– Click the gray box to the left of the row (the row header) you want to select if only
selecting one row. That row is highlighted.
– To select multiple rows, hold down the Ctrl key while clicking the gray box of the rows
you need. Those rows are highlighted.
– To select all the rows, click the gray box in the upper left corner. All rows are
highlighted.
4) Click the Data to Text icon to insert the data into the spreadsheet cells.
5) Save the spreadsheet.
Adding records to a spreadsheet is fairly easy. You need to have the Data Sources window open,
your spreadsheet open, and the table you want to use selected.
1) Drag and drop the gray box containing the field name for the table’s ID field (the column
header) to where you want the record to appear in the spreadsheet.
2) Repeat until you have copied all of the fields you need to where you want them in the
spreadsheet.
3) Select File > Save, or click the Save icon on the Standard toolbar, to name and save the
spreadsheet. Close the file.
Next time you open the spreadsheet, the fields will be populated with data from the first record of
the table, and the Form Navigation toolbar will appear at the bottom of the spreadsheet.
Click the arrows on the Form Navigation toolbar to view the different records of the table. (The
arrows are circled in red in Figure 293.) The number in the box changes when you change the
record number by clicking an arrow. The data in the fields changes to reflect the data for that
particular record number.

Figure 293: Navigation arrows of a form
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Getting Started Guide 7.3

Chapter 9,
Getting Started with Math
LibreOffice’s Formula (Equation) Editor

Introduction
Math is a formula editor included with LibreOffice that you can use to create or edit formulas
(equations) in a symbolic form, within LibreOffice documents or as stand-alone objects. Example
formulas are shown below:

df (x)
=ln (x)+tan −1 (x 2) or NH3 +H2 O ⇌NH+4 +OH −
dx
The Formula Editor in Math uses a markup language to represent formulas. This markup
language is designed to be easily read wherever possible. For example, a over b using
markup language produces the fraction

a
when used in a formula.
b

Getting started
Using the Formula Editor, you can create a formula as a separate file for a formula library or
insert formulas directly into a document using LibreOffice Writer, Calc, Impress, or Draw.

Formulas as separate documents or files
To create a formula as a separate document or file, use one of the following methods to open an
empty formula document in LibreOffice Math (Figure 294):
•

On the Menu bar, go to File > New > Formula.

•

On the Standard toolbar, click the triangle to the right of the New icon and select
Formula.

•

In the Start Center, click Math Formula.

•

From within LibreOffice Math, use the keyboard shortcut Ctrl+N.

•

You can also launch Math from the command line using libreoffice --math

Figure 294: An empty formula document in Math
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As you enter the markup language in the Formula Editor, the formula will appear in the Preview
window during and after input of the markup language. The Elements dock to the left of the
Preview window may also appear, if it has been selected in View on the Menu bar (Figure 295).
This dock can be turned into a floating dialog, as shown in Figure 297.
For more information on creating formulas, see “Writer does not have an automated way to do
Title Case, where all words are capitalized except for certain subsets defined by rules that are
not universally standardized. However, you can use Capitalize Every Word and then restore
those words that you do not want capitalized.” on page 104.

Figure 295: Enabling the Elements dock

Formulas in LibreOffice documents
To insert a formula into a LibreOffice document, open the document in Writer, Calc, Draw, or
Impress. The LibreOffice component you are using affects how you position the cursor to insert
the formula.
•

In Writer, click in the paragraph where you want to insert the formula.

•

In Calc, click in the spreadsheet cell where you want to insert the formula.

•

In Draw and Impress, the formula is inserted into the center of the drawing or slide.

Then, go to Insert > Object > Formula Object on the Menu bar to open the Formula Editor.
Alternatively, go to Insert > Object > OLE Object on the Menu bar to open the Insert OLE
Object dialog, then select Create new, choose the Object Type “LibreOffice 7.3 Formula” and
then click OK to open the Formula Editor.
The Elements dock to the left of the Preview window or the Elements dialog as a floating dialog
may also appear, if Elements has been selected in View on the Menu bar.
Figure 296 shows an example Writer document with the formula box selected ready for a formula
to be entered.
When you have completed entering the markup language for the formula, close the Formula
Editor by pressing the Esc key or by clicking an area outside the formula in the document.
Double-click on the formula object in the document to open the Formula Editor again so that you
can edit the formula.
Formulas are inserted as OLE objects into documents. You can change how the object is placed
within the document, as with any OLE object. For more information on OLE objects, see
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“Formulas in Writer” on page 331, “Formulas in Calc, Draw, and Impress” on page 337, and the
user guides for Writer, Calc, Draw, and Impress.

Figure 296: Empty formula in a Writer document
If you frequently insert formulas into documents, it is recommended to add the Formula button to
the Standard toolbar or create a keyboard shortcut. See “Customization” on page 338 for more
information.

Creating formulas
You can create a formula using one of the following methods:
•

In the Elements dock, select a category in the drop-down list, then select a symbol.

•

Right-click in the Formula Editor and select a category, then select a symbol in the
context menu.

•

Enter markup language directly in the Formula Editor.

Note
Using the Elements dock or the context menus to create a formula provides a
convenient way to learn the markup language used by Math.

Tip
When using the Elements dock, it is recommended to have Extended tips selected in
the LibreOffice Options. This will help you identify the categories and symbols you
want to use in the formula. Go to Tools > Options > LibreOffice > General on the
Menu bar and select Extended tips in the Help section.
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Elements dock
The Elements dock (Figure 297) is a visual tool to help you create and edit formulas. It organizes
mathematical symbols and operators using Categories in a drop-down list. The steps below
describe how to enable the Elements dock and navigate its categories and symbols.
1) Go to View > Elements on the Menu bar to open the Elements dock (Figure 297).
2) Select the category you want to use in your formula in the drop-down list at the top of the
Elements dock.
3) Select the symbol you want to use in the formula in the Elements dock. The symbols that
are available change according to the selected category.
4) After choosing one of the symbols in the Elements dock, the Formula Editor will be
updated with the Markup notation of the selected symbol.

Figure 297: Elements dock as a
floating dialog

Note
The Elements dock can either be a floating dialog, as shown in Figure 297, or
positioned to the left of the Formula Editor, as shown in Figure 294 and Figure 296.

Tip
The Elements dock includes an Examples category which provides example
formulas to use as a starting point for your formula or equation.

Context menu
The Formula Editor also provides a context menu to access categories and symbols when
creating a formula. Right-click in the Formula Editor to open the context menu. Select a category
and then select the markup example that you want to use in the sub-context menu. An example
is shown in Figure 298.

Note
The Elements dock and the context menu contain only the most common commands
that are used in formulas. To insert other symbols and commands not listed in the
Elements dock and context menu, you have to enter them manually using the
markup language. For a complete list of commands and symbols available in Math,
see Appendix A, Commands Reference, in the Math Guide.
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Figure 298: Context menu in Formula Editor

Markup language
Markup language is entered directly into the Formula Editor. For example, typing 5 times 4
into the Formula Editor creates the simple formula 5×4 . If you are experienced in using markup
language, it can be the quickest way to enter a formula. Table 4 shows some examples of using
markup language to enter commands. For a full list of commands that can be used in the
Formula Editor, see Appendix A, Commands Reference, in the Math Guide.
Table 4: Example commands using markup language
Display

a=b

Command

Display

Command

a = b

√a

sqrt {a}

a^2

an

a_n

∫ f ( x)dx

int f(x) dx

∑ an

sum a_n

a≤b

a <= b

∞

infinity

a×b

a times b

x⋅y

x cdot y

a

2

Greek characters
Using markup language
Greek characters are commonly used in formulas, but they cannot be entered into a formula
using the Elements dock or the context menu. Use the English names of Greek characters in
markup language when entering Greek characters into a formula. See Appendix A, Commands
Reference, in the Math Guide for a list of characters that can be entered using markup language.
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•

For a lowercase Greek character, type a percentage % sign, then type the character
name in lowercase using the English name. For example, typing %lambda creates the
Greek character λ .

•

For an UPPERCASE Greek character, type a percentage % sign, then type the character
name in UPPERCASE using the English name. For example, typing %LAMBDA creates
the Greek character Λ.

•

For an italic Greek character, type a percentage % sign followed by the i character, then
the English name of the Greek character in lower or UPPER case. For example, typing
%iTHETA creates the italic Greek character Θ .

Symbols dialog
Greek characters can also be entered into a formula using the Symbols dialog.
1) Make sure your cursor is in the correct position in the Formula Editor.
2) Go to Tools > Symbols on the Menu bar, or click the Symbols icon in the Tools toolbar,
to open the Symbols dialog (Figure 299).
3) Select Greek in the Symbol set drop-down list. For italic characters, select iGreek in the
drop-down list.
4) Double-click the Greek character you want to insert or select it and click Insert. When
selected, the name of the character is shown below the symbol list.
5) Click Close when you have finished entering Greek characters into your formula.

Figure 299: Symbols dialog

Formula examples
Example 1
The simple formula

5×4

can be created using LibreOffice Math as follows:

1) Make sure your cursor is flashing in the Formula Editor, then select the category
Unary/Binary Operators and symbol Multiplication using one of the following methods:
– In the Elements dock, select Unary/Binary Operators in the drop-down list and then
select the Multiplication icon
.
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– Right-click in the Formula Editor and select Unary/Binary Operators > a times b in
the context menu.
– Using markup language, enter 5 times 4 in the Formula Editor.
The first two methods place the formula text <?> times <?> in the Formula Editor and
the symbol
appears in the document. For the third method, using markup
language in the Formula Editor places the formula 5×4 directly into the document and
there is no need to carry out the following steps.
2) Select the first placeholder <?> before the word times in the Formula Editor and replace
it with the character 5. The formula in the document updates automatically.
3) Select the second placeholder <?> after the word times in the Formula Editor and
replace it with the character 4. The formula in the document updates automatically.

Tip
To move forward from one placeholder to the next placeholder in a formula, press
the F4 key. To move backward from one placeholder to the previous placeholder in a
formula, use the key combination Shift+F4.

Note
If necessary, you can prevent a formula in a document from updating automatically.
Go to View on the Menu bar and deselect AutoUpdate display. To then manually
update a formula, press the F9 key or select View > Update on the Menu bar.

Example 2
You want to enter the formula π ≃ 3.14159 where the value of pi is rounded to 5 decimal
places. You know the name of the Greek character (pi), but do not know the markup associated
with the Is Similar Or Equal symbol ≃ .
1) Make sure your cursor is flashing in the Formula Editor.
2) Enter %pi in the Formula Editor to enter the Greek character for pi (π).
3) Select the category Relations and symbol Is Similar Or Equal using one of the following
methods:
– In the Elements dock, select Relations in the drop-down list and then select the Is
Similar Or Equal icon
.
– Right-click in the Formula Editor and select Relations > a simeq b in the context
menu.
4) Delete the first placeholder <?> before the word simeq in the Formula Editor.
5) Select the second placeholder <?> after the word simeq in the Formula Editor and
replace it with the characters 3.14159. The formula π ≃ 3.14159 now appears in the
document.

Editing formulas
How you edit a formula and switch into formula editing mode depends on whether the formula is
in Math or another LibreOffice component.
1) In Math, double-click on a formula element in the formula that appears in the Preview
window to select the formula element in the Formula Editor, or directly select a formula
element in the Formula Editor.
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In Writer, Calc, Impress, or Draw, double-click on the formula, or right-click on the formula
and select Edit in the context menu, to open the Formula Editor and enter editing mode.
The cursor is positioned at the start of the formula in the Formula Editor.

Note
If you cannot select a formula element using the cursor, click on the Formula Cursor
icon in the Tools toolbar to activate the formula cursor.
2) Select the formula element you want to change using one of the following methods:
– Click on the formula element in the Preview window, positioning the cursor at the
beginning of the formula element in the Formula Editor, then select the formula
element in the Formula Editor.
– Double-click on the formula element in the Preview window to select the formula
element in the Formula Editor.
– Position the cursor in the Formula Editor at the formula element you want to edit, then
select that formula element.
– Double-click directly on the formula element in the Formula Editor to select it.
3) Make your changes to the formula element you have selected.
4) Go to View > Update on the Menu bar, or press the F9 key, or click on the Update icon
on the Tools toolbar to update the formula in the Preview window or your document.
5) In Math, save your changes to the formula after editing.
In Writer, Calc, Impress, or Draw, click anywhere in the document away from the formula
to leave editing mode, then save the document to save your changes to the formula.

Formula layout
This section provides some advice on how to lay out complex formulas in Math or in your
LibreOffice document.

Using braces
LibreOffice Math knows nothing about order of operations within a formula. You need to use
braces (curly brackets) to define the order of operations. The following examples show how
braces can be used in a formula.
Example 1
2 over x + 1 gives the result

2
+1
x

Math has recognized that the 2 before and the x after the over command as belonging to
the fraction, and has represented them accordingly. If you want x +1 rather than x to
be the denominator, you must bracket them together using braces so that both will be
placed there.
Inserting braces into 2 over {x + 1} gives the result

2
where x +1 is now the
x+1

denominator.
Example 2
– 1 over 2 gives the result

−1
2
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Math has recognized the minus sign as a prefix for the 1 and has therefore placed it in the
numerator of the fraction. If you wish to show that the whole fraction is negative, with the
minus sign in front of the fraction, you must put the fraction in braces to signify to Math that
the characters belong together.
Adding braces into the markup language – {1 over 2} gives the result –
whole fraction is now negative.

1
and the
2

Example 3
When braces are used in markup language, they define the layout of the formula and are
not displayed or printed. If you want to use braces within a formula, use the commands
lbrace and rbrace within the markup language.
x over {–x + 1} gives the result

x
– x+1

Replace the braces using the commands lbrace and rbrace in the markup language.
Write x over lbrace –x + 1 rbrace and the result is

x
{– x +1}

Brackets (parentheses) and matrices
If you want to use a matrix in a formula, you have to use the matrix command. Below is a
simple example of a 2 x 2 matrix.
matrix { a # b ## c # d }

a b
c d

In matrices, rows are separated by two hashes (##) and entries within each row are separated by
one hash (#).
Normally, when you use brackets within a matrix, the brackets do not scale as the matrix
increases in size. The example below shows a formula where the parentheses do not scale to
the size of the resulting matrix.
( matrix { a # b ## c # d } )

(

a b
)
c d

To overcome this problem, Math provides scalable brackets that grow in size to match the size of
the matrix. Use the commands left( and right) to create scalable brackets around a matrix.
The following example shows how to create a matrix with scalable parentheses.

(ac bd )

left( matrix { a # b ## c # d } right)

Scalable brackets can also be used with any element of a formula, such as fraction, square root,
and so on.
To create a matrix where some values are empty, you can use the grave accent (`) so that Math
will put a small space in that position, as shown in the example below.
left( matrix { 1 # 2 # 3 ##
4 # ` # 6 } right)
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( 14

2 3
6

)

Tip
Use the commands left[ and right] to obtain square brackets. A list of all
brackets available within Math can be found in Appendix A, Commands Reference,
of the Math Guide.

Tip
If you want all brackets to be scalable, go to Format > Spacing on the Menu bar to
open the Spacing dialog. Click on Category, select Brackets in the drop-down list,
and then select the option Scale all brackets.

Unpaired brackets
When using brackets in a formula, Math expects that for every opening bracket there will be a
closing one. If you forget to add a closing bracket, Math places an inverted question mark next to
where the closing bracket should have been placed. For example, lbrace a; b will result in
¿ because the right bracket rbrace is missing.
This inverted question mark disappears when all the brackets are paired. The previous example
could be fixed to lbrace a; b rbrace, resulting in {a ; b}. However, there are cases where an
unpaired bracket is necessary and for that you have the following options.

Non scalable brackets
A backslash \ is placed before a non scalable bracket to indicate that the subsequent character
should not be regarded as a bracket, but rather as a literal character.
For example, the unpaired brackets in the formula [ a; b [ would result in an inverted
question mark because Math expects that [ will be closed by ]. To fix the error, use the
backslash and insert \ [ a; b \ [ into the Formula Editor to obtain [a ; b [ as the result.

Scalable brackets
To create unpaired scalable brackets or braces in a formula, the markup commands left,
right, and none can be used.
Example
The following formula uses the stack command to create a two-line formula and adds a
bracket only to the right side of the stack.
abs x = left lbrace stack {x "for" x
>= 0 # -x "for" x < 0} right none

|x|= x for x≥0
−x for x <0

{

This effect can be achieved by using the left lbrace command combined with the
right none command. The first command indicates that the left bracket is a lbrace
whereas the second command tells Math that the right bracket will be none, meaning that
no bracket will be added to the right side of the formula.

Recognizing functions
In the basic installation of Math, Math outputs functions in normal characters and variables in
italic characters. However, if Math fails to recognize a function, you can tell Math that you have
just entered a function. Entering the markup command func before a function forces Math to
recognize any following text as a function and uses normal characters.
For a full list of functions within Math, see Appendix A, Commands Reference, in the Math Guide.
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Some Math functions have to be followed by a number or a variable. If these are missing, Math
places an inverted question mark where the missing number or variable should be. To remove
the inverted question mark and correct the formula, you have to enter a number, a variable, or a
pair of empty brackets as a placeholder.

Tip
You can navigate through errors in a formula using the F3 key to move to the next
error or the key combination Shift+F3 to move to the previous error.

Formulas over multiple lines
Suppose you want to create a formula that requires more than one line, for example x=3 .

y=1

Your first reaction would be to press the Enter key. However, if you do that, the markup language
in the Formula Editor goes to a new line, but the resulting formula does not have two lines. To
add a new line to the formula you need to use the markup command newline.
Example
The examples below illustrate how the markup command newline can be used to add a
new line to a formula. The first one simply adds an Enter to break the line in the markup
language, which does not result in adding a new line. The second example uses the
newline command, yielding a two-line formula.
Markup Language

Resulting Formula

x = 3
y = 1

x=3 y=1

x = 3 newline y = 1

x=3
y=1

It is not possible in Math to create multiple line formulas when a line ends with an equals sign
and you want to continue the formula on a new line without completing the term on the right side
of the equals sign. If you require a multiple line formula to have an equals sign at the end of a line
without a term after the equals sign, then use either empty quotes “” or empty braces {} or the
space characters grave ` or tilde ˜.
By default, a multiple line formula is center aligned. For more information on alignment using the
equals sign, see “Customization” on page 338.

Spacing within formulas
Spacing between the elements in a formula is not set by using space characters in the markup
language. To add spaces into a formula, use one of the following options:
•

Grave ` to add a small space.

•

Tilde ~ for a large space.

•

Add space characters between quotes “ ”. These spaces will be considered as text.

Any spaces at the end of a line in the markup language are ignored by default.
For more information, see “Adjusting formula spacing” on page 326.

Adding limits to sum/integral commands
The sum and int commands, used for summations and integrals respectively, can take the
parameters from and to if you want to set the lower and upper limits. The parameters from and
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to can be used singly or together as shown by the following examples. For more information on
the sum and integral commands, see Appendix A, Commands Reference, in the Math Guide.
Examples
Here are some examples of how to add upper and lower bounds to summations and
integrals. Note that you can use brackets to explicitly define which parts of the formula
correspond to the desired bounds.
Markup Language

Resulting Formula
n

∑ ak

sum from k = 1 to n a_k

k=1
∞

sum to infinity 2^{-n}

∑ 2−n
n

sum from{ i=1 } to{ n } sum
from{ j=1; i <> j } to{ m } x_ij

m

∑ ∑

i=1 j=1 ;i≠ j

x ij

x

∫ f (t) dt

int from 0 to x f(t) dt

0

x

∫0 f (t )dt
∫ℜ f

int_0^x f(t) dt
int from Re f

Writing derivatives
When writing derivatives, you have to tell Math that it is a fraction by using the over command.
The over command is combined with the character d for a total derivative or the partial
command for a partial derivative to achieve the effect of a derivative. Braces {} are used in each
side of the elements to surround them and make the derivative, as shown by the following
examples.
Examples
Below are a few examples of how you can use Math to write derivatives.
Markup Language

Resulting Formula

{df} over {dx}

df
dx

{partial f} over {partial y}

∂f
∂y

{partial^2 f} over {partial t^2}

∂ f
∂t 2

2

Note
To write function names with primes, as is normal in school notation, you must first
add the symbols to the catalog. See “Catalog customization” on page 339 for more
information.
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Markup language characters as normal characters
Characters that are used as controls in markup language cannot be entered directly as normal
characters. These characters are: %, {, }, &, |, _, ^ and ". For example, you cannot write
2% = 0.02 in markup language and expect the same characters to appear in your formula. To
overcome this limitation in markup language, use one of the following methods:
•

Use double quotes to mark that character as text, for example 2"%"= 0.02 will appear
in your formula as 2 %=0.02 . However, this method cannot be used for the doublequote character itself, see “Text in formulas” below.

•

Add the character to the Math Catalog, for example the double quote character.

•

Use commands, for example lbrace and rbrace give you literal braces {} .

Note
The Special Characters dialog used by other LibreOffice components is not available
in Math. If you are going to regularly require special characters in Math, then it is
recommended to add the characters to the Math Catalog; see “Catalog
customization” on page 339 for more information.

Text in formulas
To include text in a formula, you have to enclose any text in double-quotes, for example x "
for " x >= 0 in markup language will create the formula x for x≥0 . All characters, except
double quotes, can be used in text.
However, if you require double quotes in formula text, then you have to create the text with
double quotes in LibreOffice Writer, then copy and paste the text into the Formula Editor, as
shown in Figure 300.

Figure 300: Example of double quotes in formula text
The font used for text in a formula will be the default font that has been set in the Fonts dialog.
For more information on how to change fonts used for in formulas, see “Changing formula
appearance” on page 323.
By default, text alignment is left-justified in formulas. For more information on how to change text
alignment, see “Adjusting formula alignment” on page 328.

Formatting text in formulas
Formatting commands are not interpreted within text used in formulas. If you want to use
formatting commands within formula text, then you must break up the text using double quotes in
the Formula Editor.
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Example
Enter the following in the Formula Editor:
"In " color blue bold "isosceles" "triangles, the base angles are
equal"
creates the following text in a formula In isosceles triangles, the base angles are equal .
This example shows how to use the markup commands color and bold to format the
word “isosceles”. Note that the commands are applied to the immediately subsequent text
within double quotes. Hence, the formatting commands do not apply to the remainder of
the text in the example because it is in a separate quote block.
The command color needs to be followed by the name of the desired color or to its RGB or
hexadecimal value. Refer to Appendix A, Command Reference, in the Math Guide for a list of
predefined color names.

Aligning formulas using equals sign
LibreOffice Math does not have a command for aligning formulas on a particular character.
However, you can use a matrix to align formulas on a character and this character is normally the
equals sign (=). In addition, you can use the markup commands alignr, alignl and alignc
to set the alignment of each value inside the matrix to the right, left or center, respectively.
Example
The example below uses a matrix to align formulas on the equals sign. Notice how the
alignment commands align the contents of each position in the matrix.
matrix{ alignr x+y # {}={} # alignl 2
## alignr x # {}={} # alignl 2-y }

x+ y = 2
x = 2− y

Note
The empty braces each side of the equals sign are necessary because the equals
sign is a binary operator and requires an expression on each side. You can use
spaces, or ` or ~ characters each side of the equals sign, but braces are
recommended as they are easier to see within the markup language.
You can reduce the spacing on each side of the equals sign if you change the inter-column
spacing of the matrix. See “Adjusting formula spacing” on page 326 for more information.

Changing formula appearance
This section describes how to change the font or font size in a selected formula and how to
change the default font or font size.

Note
If you have already inserted formulas into your document and you change the
default font or font size, only formulas inserted after the change in default font or
font size will use the new default settings. You have to individually change the font or
font size of formulas already inserted if you want these formulas to use the same font
or font size as the default settings.
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Tip
The extension “Formatting of all Math formulas” allows you to change font name and
font size for all or only for selected formulas in a document. You can download it and
read the installation and usage instructions here:
https://extensions.libreoffice.org/en/extensions/show/formatting-of-all-math-formulas

Formula font size
Current formula font size
To change the font size used for a formula already inserted in Math or another LibreOffice
component:
1) Click in the markup language in the Formula Editor.
2) Go to Format > Font size on the Menu bar to open the Font Sizes dialog (Figure 301).
3) Select a different font size using the Base size spinner or type a new font size in the Base
Size box.
4) Click OK to save your changes and close the dialog. An example result when you change
font size is shown below.
Example
Default font size 12pt: π ≃ 3.14159
After font size change to 18pt:

π ≃ 3.14159

Figure 301: Font Sizes dialog

Default formula font size
To change the default font size used for all formulas in Math or another LibreOffice component:
1) Before inserting any formulas in your document, go to Format > Font size on the Menu
bar to open the Font Sizes dialog (Figure 301).
2) Select a different font size using the Base size spinner or type a new font size in the Base
size box.
3) Click Default and confirm your changes to the base size font. Any formulas created from
this point on will use the new base size font for formulas.
4) Click OK to save your changes and close the Font Sizes dialog.
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Font size options
The Font Sizes dialog (Figure 301) specifies the font sizes for a formula. Select a base size and
all elements of the formula will be scaled in relation to this base.
•

Base size – all elements of a formula are proportionally scaled to the base size. To
change the base size, select or type in the desired point (pt) size. You can also use other
units of measure or other metrics, which are then automatically converted to points. For
example, if you enter 1in or 1”, Math converts the value to 72 pt.

•

Relative Sizes – in this section, you can determine the relative sizes for each type of
element with reference to the base size.

•

Default – click this button to save any changes as a default for all new formulas. A
confirmation message appears.

Formula fonts
Current formula fonts
To change the fonts used for the current formula in Math or another LibreOffice component:
1) Click in the markup language in the Formula Editor.
2) Go to Format > Fonts on the Menu bar to open the Fonts dialog (Figure 302).

Figure 302: Fonts dialog
3) Select a new font for each of the various options in the drop-down lists.
4) If the font you want to use does not appear in the drop-down list, click Modify and select
the option in the context menu to open a fonts dialog. Select the font you want to use and
click OK to add it to the drop-down list for that option.
5) Click OK to save your changes and close the Fonts dialog.

Default formula fonts
To change the default fonts used for all formulas in Math or another LibreOffice component:
1) Before inserting any formulas in your document, go to Format > Fonts on the Menu bar
to open the Fonts dialog (Figure 302).
2) Select a new font for each of the various options in the drop-down lists.
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3) If the font you want to use does not appear in the drop-down list, click Modify and select
the option in the context menu to open a fonts dialog. Select the font you want to use and
click OK to add it to the drop-down list for that option.
4) Click Default and confirm your changes to the fonts. Any formulas created from this point
on will use the new font for formulas.
5) Click OK to save your changes and close the Fonts dialog.

Formula font options
Defines the fonts that can be applied to formula elements.
•

Formula Fonts – defines the fonts used for the variables, functions, numbers and
inserted text that form the elements of a formula.

•

Custom Fonts – in this section of the Fonts dialog (Figure 302), fonts are defined which
format other text components in a formula. The three basic fonts Serif, Sans, and Fixed
are available. Other fonts can be added to each standard installed basic font using the
Modify button. Every font installed on a computer system is available for use.

•

Modify – click one of the options in the drop-down menu to access the Fonts dialog,
where the font and attributes can be defined for the respective formula and for custom
fonts.

•

Default – click this button to save any changes as a default for all new formulas. A
confirmation message appears.

Note
When a new font is selected for a formula, the old font remains in the list alongside
the new one and can be selected again.

Note
Variables should be written in italics, so make sure that the Italic option is selected
for the font you want to use. For all other elements, use the basic form of a font. The
style can be easily altered in the formula itself by using the commands italic or
bold to set these characteristics and nitalic or nbold to unset them.

Adjusting formula spacing
Use the Spacing dialog (Figure 303) to determine the spacing between formula elements. The
spacing is specified as a percentage in relation to the defined base size for font sizes.

Figure 303: Spacing dialog
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Current formula spacing
To change the spacing used for the current formula in Math or another LibreOffice component:
1) Click in the markup language in the Formula Editor.
2) Go to Format > Spacing on the Menu bar to open the Spacing dialog (Figure 303).
3) Click Category and select one of the options in the drop-down list. The options in the
Spacing dialog change according to the category selected.
4) Enter new values for the spacing category and click OK.
5) Check the result in your formula. If not to your satisfaction, repeat the above steps.

Default formula spacing
To change the default spacing used for all formulas in Math or another LibreOffice component:
1) Before inserting any formulas in your document, go to Format > Spacing on the Menu
bar to open the Spacing dialog (Figure 303).
2) Click Category and select one of the options in the drop-down list. The options in the
Spacing dialog change according to the category selected.
3) Enter new values for the spacing category.
4) Click Default and confirm your changes to the formula spacing. Any formulas created
from this point on will use the new spacing for formulas.
5) Click OK to save your changes and close the Spacing dialog.

Note
If you have already inserted formulas into your document and you change the
spacing, only formulas inserted after the change in spacing will use the new default
settings. You have to individually change the spacing of formulas already inserted if
you want these formulas to use the same spacing as the default settings.

Spacing options
Use Category in the Spacing dialog (Figure 303) to determine the formula element for which you
would like to specify the spacing. The appearance of the dialog depends on the selected
category. A preview window shows you which spacing is modified through the respective boxes.
•

Category – pressing this button allows you to select the category for which you would
like to change the spacing.

•

Spacing – defines the spacing between variables and operators, between lines, and
between root signs and radicals.

•

Indexes – defines the spacing for superscript and subscript indexes.

•

Fractions – defines the spacing between the fraction bar and the numerator or
denominator.

•

Fraction Bars – defines the excess length and line weight of the fraction bar.

•

Limits – defines the spacing between the sum symbol and the limit conditions.

•

Brackets – defines the spacing between brackets and the content.
– Excess size (left/right) – determines the vertical distance between the upper edge of
the contents and the upper end of the brackets.
– Spacing – determines the horizontal distance between the contents and the upper end
of the brackets.
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– Scale all brackets – scales all types of brackets. If you then enter (a over b) in the
Formula Editor, the brackets will surround the whole height of the argument. You
normally achieve this effect by entering left (a over b right).
– Excess size – adjusts the percentage excess size. At 0% the brackets are set so that
they surround the argument at the same height. The higher the entered value is, the
larger the vertical gap between the contents of the brackets and the external border of
the brackets. The field can only be used in combination with Scale all brackets.
•

Matrices – defines the relative spacing for the elements in a matrix.
– Line spacing – determines the spacing between matrix elements in a row.
– Column spacing – determines the spacing between matrix elements in a column.

•

Symbols – defines the spacing of symbols in relation to variables
– Primary height – defines the height of the symbols in relation to the baseline.
– Minimum spacing – determines the minimum distance between a symbol and
variable.

•

Operators – defines the spacing between operators and variables or numbers.
– Excess size – determines the height from the variable to the operator upper edge.
– Spacing – determines the horizontal distance between operators and variables.

•

Borders – adds a border to a formula. This option is particularly useful if you want to
integrate the formula into a text file in Writer. When making settings, make sure that you
do not use 0 as a size as this creates viewing problems for text that surrounds the
insertion point.

•

Preview Field – displays a preview of the current selection.

•

Default – saves any changes as default settings for all new formulas. A confirmation
dialog will appear before saving these changes.

Adjusting formula alignment
The alignment settings determine how formula elements located above one another are aligned
horizontally relative to each other.

Note
It is not possible to align formulas on a particular character and formula alignment
does not apply to text elements. Text elements are always aligned left.

Note
Independent of using formula alignment given below, it is possible to align formulas
using the commands alignl, alignc and alignr. These commands also work for
text elements.

Current formula alignment
To change the alignment used for the current formula in Math or another LibreOffice component:
1) Click in the markup language in the Formula Editor.
2) Go to Format > Alignment on the Menu bar to open the Alignment dialog (Figure 304).
3) Select either Left, Centered, or Right for horizontal alignment.
4) Click OK and check the result in your formula. If not to your satisfaction, repeat the above
steps.
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Figure 304: Alignment dialog

Note
Regardless of the alignment option selected in the Alignment dialog, it is possible to
align sections of a formula using the commands alignl, alignc and alignr. For
example, they can be useful to align formulas in matrices. These commands also
work for text elements.

Default formula alignment
To change the default alignment used for all formulas in Math or another LibreOffice component:
1) Before inserting any formulas in your document, go to Format > Alignment on the Menu
bar to open the Alignment dialog (Figure 304).
2) Select either Left, Centered, or Right for horizontal alignment.
3) Click Default and confirm your changes to the formula alignment. Any formulas created
from this point on will use the new alignment for formulas.
4) Click OK and check the result in your formula. If not to your satisfaction, repeat the above
steps.

Note
If you have already inserted formulas into a document and you change the formula
alignment, only formulas inserted after the change in alignment will use the new
default settings. You have to individually change the alignment of formulas already
inserted if you want these formulas to use the same alignment as the default settings.

Changing formula color
You can change the color of characters used in a formula using markup language: the command
color followed by a color name, RGB value, or HTML hex value.
The color command only works on the formula element immediately after the color name, RGB
value, or hex value. For example, entering the markup language color red 5 times 4 gives
the result 5×4 . Note that only the number 5 was colored red.
To change the color of the whole formula, you have to enclose the whole formula within brackets.
For example, entering the markup language color red {5 times 4} gives the result 5×4 .

Named colors
For information on the named colors available in Math, see Appendix A, Commands Reference,
in the Math Guide. These colors are listed in the Attributes section of the Elements dock (Figure
297 on page 313).
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RGB values
To use custom colors defined by RGB (Red, Green and Blue) values ranging from 0 to 255, use
the color rgb R G B markup command, where R, G, and B correspond to the Red, Green,
and Blue values of the desired color.
Example
In this example, the term “decision variable” uses the color defined by the RGB values 160,
82, 45.
"Let " x_ij " be a " color rgb 160 82 45 "decision variable " "in
the problem under consideration"
Math will create the following output:

Let x ij be a decision variable in the problem under consideration

Hex values
Math now supports HTML colors defined by a hex number. Use the color hex 000000
markup command, where 00000 is the corresponding hex number. For example, the command
color hex FF0000 decision creates the output decision .

Background color
It is not possible to select a background color for formulas in LibreOffice Math. The background
color for a formula is by default the same color as the document or frame that the formula has
been inserted into. In LibreOffice Writer, you can use object properties to change the background
color for a formula. For more information, see “Background and borders” on page 335.

Formula library
If you regularly insert the same formulas into your documents, you can create a formula library
using formulas that you have created using the Formula Editor. Individual formulas can be saved
as separate files using the ODF format for formulas (file type .odf), or in MathML format (file
type .mml).
You can use either LibreOffice Math, Writer, Calc, Draw, or Impress to create formulas and build
up your formula library.

Using Math
1) Create a folder on your computer to contain your formulas and give the folder a
memorable name, for example Formula Library.
2) In LibreOffice, go to File > New > Formula on the Menu bar, or click on Math Formula in
the Start Center to open Math and create your formula using the Formula Editor. See
“Formulas as separate documents or files” on page 310 for more information.
3) Go to File > Save As on the Menu bar or use the keyboard shortcut Ctrl+Shift+S to open
a Save As dialog.
4) Navigate to the folder you have created for your formula library.
5) Type a memorable name for the formula in the File name box.
6) Select in the File type drop-down list either ODF Formula (.odf) or MathML 2.0 (.mml) as
the file type for the formula.
7) Click Save to save the formula and close the Save As dialog.
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Using Writer, Calc, Draw, or Impress
1) Create a folder on your computer to contain your formulas and give the folder a
memorable name, for example Formula Library.
2) Open a document using Writer, Calc, Draw, or Impress.
3) Go to Insert > Object > Formula Object on the Menu bar to open the Formula Editor
and create a formula. See “Formulas in LibreOffice documents” on page 311 for more
information.
4) Right-click on the formula object and select Save Copy as in the context menu to open a
Save As dialog.
5) Navigate to the folder you have created for your formula library.
6) Type a memorable name for the formula in the File name box.
7) Select in the File type drop-down list either ODF Formula (.odf) or MathML 2.0 (.mml) as
the file type for the formula.
8) Click Save to save the formula and close the Save As dialog.

Using your formula library
You cannot insert a formula from your library into a document by dragging and dropping using the
mouse, nor by using Insert > File on the Menu bar. You must insert the formula as an OLE
object.
1) Open the document in Writer, Calc, Draw, or Impress.
2) Go to Insert > Object > OLE Object on the Menu bar to open the Insert OLE Object
dialog.
3) Select the option Create from file.
4) Click Search to open a file browser dialog.
5) Navigate to the folder you have created for your formula library.
6) Select the formula you want to insert and click Open, or double-click on the formula.
7) Click OK to insert the formula as an OLE object in the document and close the dialog.

Formulas in Writer
When a formula is inserted into a document, LibreOffice Writer places the formula in a frame and
treats the formula as an OLE object. Double-click on an inserted formula to open the Formula
Editor in LibreOffice Math, where you can edit the formula.
This section explains what options you can change for each individual formula within a Writer
document. Please refer to the chapters on styles in the Writer Guide for information on how to
change the default settings for frame styles for OLE objects.

Automatic formula numbering
Automatic numbering of formulas for cross-reference purposes can only be carried out in
LibreOffice Writer. The easiest way to add numbered formulas in sequence is to use the AutoText
entry fn (for 'formula numbered').
1) Start a new line in your document.
2) Type fn and then press the F3 key. A two column table with no borders is inserted into
your document with the left column containing a sample formula and the right column
containing a reference number, as shown below.

E=mc

2

(1)
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3) Delete the sample formula and insert your formula as an object in the left column.
4) Alternatively, you can first insert your formula into the document, then carry out Steps 1
and 2 above replacing the sample formula with your formula.

Cross-referencing
1) Click in your document where you want the cross-reference to appear.
2) Go to Insert > Cross-reference on the Menu bar to open the Fields dialog (Figure 305).
3) Click on the Cross-references tab, then select Text in the Type section.
4) In the Selection section, select the formula number you want to refer to.
5) In the Insert reference to section, select Reference and click Insert.
6) When you have finished creating cross-references, click Close to close the Fields dialog.

Figure 305: Fields dialog – Cross-references tab

Tip
To insert the cross-reference number without parentheses, select Numbering instead
of Reference in the Insert reference to section.

Note
If you want to use square parentheses instead of round ones, or if you want the
cross-reference number to be separated from the formula by tabs instead of using a
table, then refer to the Writer Guide.
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Anchoring formulas
A formula is treated as an object within Writer and its default anchoring is To character within a
paragraph when it is inserted into a document. To change the anchoring of a formula object:
1) Right-click on the selected formula object and select Anchor in the context menu.
2) Select a new anchoring option in the context sub-menu. The anchoring positions
available are To Page, To Paragraph, To Character, or As Character.
Alternatively,
1) Right-click on the selected formula object and select Properties in the context menu, or
go to Format > Frame and Object > Properties on the Menu bar, to open the Object
dialog (Figure 306).
2) On the Type tab, select an anchoring position from the Anchor section in the upper right.
3) Click OK to save your changes and close the Object dialog.

Figure 306: Object dialog – Type tab with Anchor options

Note
The anchoring options are not available in the Object dialog when you are making
changes to the options available for frame styles. For more information on how to
modify frame styles, please refer to the chapters on styles in the Writer Guide.

Vertical alignment
The normal default setting for vertical alignment for formula objects is to use the text base line as
a reference. This default setting can be changed by modifying the Formula frame style; see the
chapters on styles in the Writer Guide for more information.
To change the vertical alignment position of an individual formula object (assuming that the As
character anchoring option is selected):
1) Right-click on the selected formula object and select Properties in the context menu, or
go to Format > Frame and Object > Properties to open the Object dialog (Figure 306).
2) Make sure the Type tab is selected and select a new alignment position in the drop-down
list in the Position section. The vertical alignment options available are Top, Bottom,
Center, or From bottom.
3) If necessary, type in the text box a plus or minus value for vertical alignment. This option
is only available if From bottom vertical alignment has been selected.
4) Select the type of text alignment in the drop-down list in the Position section. The text
alignment options available are Base line, Character, and Row.
5) Click OK to save your changes and close the Object dialog.
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Note
If the Position section in the Object dialog is grayed out and not available, then go to
Tools > Options > LibreOffice Writer > Formatting Aids and uncheck the option
Math baseline alignment. This setting is stored with the document and applies to all
formulas within it. Any new documents created will also use this setting for Math
baseline alignment.

Object spacing
A formula object, when inserted into a Writer document, has spacing each side of the formula
object. The default value used for spacing is set within the frame style for formula objects and
can be changed by modifying the Formula frame style. See the chapters on styles in the Writer
Guide for more information.
To individually adjust the spacing for each formula object within a document:
1) Create a formula in a Writer document.
2) Right-click on the selected formula object and select Properties in the context menu, or
go to Format > Frame and Object > Properties to open the Object dialog.
3) Click on the Wrap tab to open the Wrap page in the Object dialog (Figure 307).
4) In the Spacing section, enter the spacing value for Left, Right, Top, and Bottom spacing.
5) Click OK to save your changes and close the Object dialog.

Figure 307: Object dialog – Wrap tab

Text mode
In large formulas placed within a line of text, the formula elements can often be higher than the
text height. Therefore, to make large formulas easier to read, it is recommended to always insert
large formulas into a separate paragraph of their own so that it is separated from text.
However, if it is necessary to place a large formula within a line of text, double-click on the
formula to open the Formula Editor and then go to Format > Text Mode on the Menu bar. The
Formula Editor will try to shrink the formula to fit the text height. The numerators and
denominators of fractions are shrunk, and the limits of integrals and sums are placed beside the
integral/sum sign, as shown in the following example.
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Example
A formula in a separate paragraph:
5

∑ i2
i=2

and the same formula embedded into a line of text using text mode format:

∑5i=2 i 2

Background and borders
The default setting for background (area fill) and borders for formula objects is set by the Formula
frame style. To change the default setting for the Formula frame style, refer to the chapters on
styles in the Writer Guide. However, for individual formulas in your document, you can change
the background and borders.

Note
The size of the frame that a formula is placed in when inserted into a document
cannot be changed. The frame size for a formula object depends on the setting of
the formula font size. See “Formula font size” on page 324 for more information.
Backgrounds
1) In your document, select the formula where you want to change the background.
2) Right-click on the formula and select Properties in the context menu, or go to Format >
Frame and Object > Properties to open the Object dialog.
3) Click on the Area tab and use the buttons at the top to select the type of fill you want to
use for your formula (Figure 308).
4) Select the options you want to use for your formula background. The options change
depending on the type of fill selected.
5) Click OK to save your changes and close the Object dialog.

Figure 308: Object dialog – Area tab
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Borders
1) In your document, select the formula where you want to change the borders.
2) Right-click on the formula and select Properties in the context menu, or go to Format >
Frame and Object > Properties to open the Object dialog.
3) Click on the Borders tab and select the options you want to use for your formula borders
(Figure 309).
4) Click OK to save your changes and close the Object dialog.

Figure 309: Object dialog – Borders tab

Quick insertion of formulas
If you know the markup language for your formula, you can quickly insert it into your Writer
document without opening the Formula Editor:
1) Enter the formula markup language into your document at the position where you want
the formula to be placed.
2) Select the markup language.
3) Go to Insert > Object on the Menu bar and select Formula Object to create a formula
from the selected markup language.
4) Alternatively you can use the key combination Ctrl + Insert to open the Insert OLE Object
dialog and then select Formula.

336 | LibreOffice 7.3 Getting Started Guide

Formulas in Calc, Draw, and Impress
In Calc, Draw, and Impress, formulas are inserted as OLE objects without any background (area
fill) or borders. Each formula object is inserted into a spreadsheet, drawing, or slide as follows:
•

In Calc, formulas are inserted into a selected cell in a spreadsheet with no style assigned
to the formula object.

•

In Draw and Impress, formulas are inserted into a central position on your drawing or
slide and, by default, are assigned the drawing object style Object with no fill and no line.
For more information on how to modify or assign drawing object styles, see the Draw
Guide or the Impress Guide.

Anchoring formulas
Calc
A formula object can be anchored into a spreadsheet as To Page (default setting), or as To Cell.
To change the anchoring type of formulas in a Calc spreadsheet:
1) Select the formula object in the spreadsheet.
2) Right-click on the formula and select Anchor > To Page or To Cell in the context menu.
3) Alternatively, go to Format > Anchor on the Menu bar and select To Page or To Cell.

Tip
If you insert a formula into a Calc spreadsheet and it appears out of scale, you can
fix it by right-clicking the formula object and then selecting the Original Size option
in the context menu.

Draw and Impress
When a formula is inserted into a drawing or slide, it is inserted as a floating OLE object and is
not anchored to any particular position in the drawing or slide.

Formula object properties
Formula objects in Calc, Draw, and Impress can be modified just like any other object that has
been placed in a spreadsheet, drawing, or presentation, with the exception of formula object size
and changing the format of any text within a formula. For more information on how to change
object properties, see the Calc Guide, Draw Guide and Impress Guide.
The following points will help you select which dialog to use if you want to change the properties
of formula objects.
•

For formula backgrounds, use the various options in the tabs of the Area dialog.

•

For formula borders, use the various options in the Line dialog. Note that formula borders
are separate from cell borders in a Calc spreadsheet.

•

To accurately re-position a formula object, use the various options in tabs of the Position
and Size dialog.

•

In Draw and Impress, you can arrange, align, group, flip, convert, break, combine, and
edit points of formula objects.

•

You cannot change the text attributes of a formula object. The text used in a formula is
set when you create the formula in the Formula Editor.

•

Formula object size is set by the formula font size when the formula is created in the
Formula Editor. The formula object size is protected in the Position and Size dialog, but
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this can be deselected if you wish. However, this is not recommended as resizing a
formula object using the Position and Size dialog could lead to distortion of the formula
making it difficult to read.

Formulas in charts
A chart in a Calc spreadsheet is itself an OLE object, therefore, you cannot use the Formula
Editor to create and insert a formula directly into a chart. However, you can create both the Chart
and Math objects separately and later copy and paste the Math formula into the Chart object:
1) Create the chart using LibreOffice Calc. For a complete reference on how to create
charts, see Chapter 3 in the Calc Guide.
2) Click at any cell in your spreadsheet so that the Chart is no longer selected.
3) Insert a Math Formula object by clicking Insert > Object > Formula.
4) Type the desired formula into the Formula Editor.
5) After editing the formula, select the Math Formula object and press Ctrl+C to copy the
Formula object to the clipboard.
6) Double-click the chart object to start editing the chart and press Ctrl+V to paste the
Formula object into the chart.
7) Now you can position the object anywhere you want inside the chart.
To change the formula, you must repeat the whole process of creating, copying, and pasting the
Formula object into the chart.

Chemical formulas
The primary purpose of Math is to create mathematical formulas, but it can also be used to write
chemical formulas. However, in chemical formulas, the chemical symbols are normally written in
uppercase using non-italic characters.
To create chemical formulas using Math, change the font used for variables to a non-italic font.
For more information on how to change fonts in a formula, see “Formula fonts” on page 325.
For reversible reactions in chemical formulas, there is no symbol for a double arrow in Math. If
you have a font available with correct symbols for use in chemical formulas, then you can add
these symbols to the Catalog. See “Catalog customization” on page 339 for more information.

Customization
This section explains how you can customize LibreOffice Math to suit the way you create
formulas for use in LibreOffice documents. Also, refer to Chapter 14, Customizing LibreOffice, for
more general information on how to customize LibreOffice.

Floating dialogs
The Formula Editor and Elements dock can cover a large part of your document. To help create
more space and/or allow you to move either the Formula Editor or Elements dock out of the way,
you can turn both of them into floating dialogs.
1) Position the cursor on the frame.
2) Hold down the Ctrl key and double-click. This turns the Formula Editor into the
Commands dialog (Figure 310) and the Elements dock into the Elements dialog (Figure
311).
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Figure 310: Commands dialog

Figure 311: Elements dialog
To return the Commands dialog and Elements dialog to their default positions:
1) Position the cursor on the frame of the dialog, NOT the title bar at the top of the dialog.
2) Hold down the Ctrl key and double-click.

Adding keyboard shortcuts
You can add keyboard shortcuts to LibreOffice to make creating documents much easier and to
match your workflow. See Chapter 14, Customizing LibreOffice, for instructions.

Catalog customization
If you regularly use a symbol that is not available in Math, you can add it to the Symbols dialog
(Figure 312) by using the Edit Symbols dialog (Figure 313).
You can add symbols to a symbol set, edit symbol sets, or modify symbol notations. You can also
define new symbol sets, assign names to symbols, or modify existing symbol sets.
For details of the fields in the Edit Symbols dialog, please refer to the Math Guide.

Adding symbols
1) Go to Tools > Symbols on the Menu bar or click on the Symbols icon on the Tools
toolbar to open the Symbols dialog.
2) Click the Edit button to open the Edit Symbols dialog.
3) Select a font in the Font drop-down list.
4) Select a symbol character that you want to add in the preview box. You may have to scroll
down in the preview box to locate the symbol you want to use. The small right preview
box displays the new symbol.
5) In the Symbol box, type a memorable name for the symbol you are adding.
6) In the Symbol set box, select a symbol set in the drop-down list to add your new symbol
to, or type a new name to create a new symbol set for your new symbol.
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7) If required, select a font style in the Style drop-down list – Standard, Italic, Bold, or
Bold, Italic.
8) Click Add, then click OK to close the Edit Symbols dialog. The new symbol and, if
created, new symbol set are now available for use.

Figure 312: Symbols dialog

Figure 313: Edit Symbols dialog
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Note
When a new symbol is added to the catalog, you can type a percentage sign (%)
followed by the new name into the markup language in the Formula Editor and your
new symbol will appear in the formula. Remember that symbol names are case
sensitive, for example, %prime is a different symbol to %Prime.

Note
There are numerous free fonts available that contain several symbols if you cannot
find a symbol to use in the fonts already installed on your computer. For example,
the STIX font was developed specially for writing mathematical and technical texts.
Also, the DejaVu and Lucida fonts have a wide range of symbols.

Note
By default, only those user-defined symbols that actually occur in the document are
stored with it. Sometimes it is useful to embed all the user-defined symbols, so that
when the document is transferred to another computer it can be edited by another
person. Go to Tools > Options > LibreOffice Math > Settings on the Menu bar and
uncheck Embed only used symbols (smaller file size) in the Miscellaneous
Options setion.

Editing symbols
Modifying symbol names
To change the name of a symbol:
1) In the Edit Symbols dialog (Figure 313), select the symbol name you want to change in
the Old symbol drop-down list. The symbol appears in the left preview pane at the bottom
of the Edit Symbols dialog (Figure 313).
2) Type a new name for the symbol in the Symbol text box, or select a new name in the
Symbol drop-down list. The new symbol name appears above the right preview pane at
the bottom of the Edit Symbols dialog.
3) Click Modify and the symbol name is changed.
4) Click OK to close the Edit Symbols dialog.

Moving symbols
To move a symbol from one symbol set to another:
1) In the Edit Symbols dialog (Figure 313), in the Old symbol set drop-down list, select the
symbol set where the symbol you want to move is located.
2) Select the symbol name you want move in the Old symbol drop-down list. The symbol
appears in the left preview pane at the bottom of the Edit Symbols dialog (Figure 313).
3) In the Symbol set drop-down list, select the symbol set that you want to move the symbol
to. The new symbol set name appears below the right preview pane at the bottom of the
Edit Symbols dialog.
4) Click Modify and the symbol is moved to the new symbol set.
5) Click OK to close the Edit Symbols dialog.
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Deleting symbols
To delete a symbol from a symbol set:
1) In the Edit Symbols dialog (Figure 313), in the Old symbol set drop-down list, select the
symbol set from which you want to delete the symbol.
2) Select the symbol name you want to delete in the Old symbol drop-down list. The symbol
appears in the left preview pane at the bottom of the Edit Symbols dialog (Figure 313).
3) Click Delete and the symbol is deleted from the symbol set without any confirmation.
4) Click OK to close the Edit Symbols dialog.

Note
The only way you can delete a symbol set is by deleting all of the symbols in that set.
When you delete the last symbol from a set, the set is also deleted.

Formula spacing
The grave accent (`) inserts an additional small space and the tilde (~) inserts an additional large
space into formulas. However, in the basic installation of LibreOffice, these symbols are ignored
when they occur at the end of a formula. If you are working with running text in a formula, it may
be necessary to include spacing at the end of formulas as well. This customization is only
required when you are working with a Math document and is not required when you are inserting
a formula into another LibreOffice component.
To add spacing at the end of formula in Math, go to Tools > Options > LibreOffice Math >
Settings on the Menu bar and uncheck Ignore ~ and ` at the end of the line in the
Miscellaneous Options section.

Note
To customize LibreOffice Math settings, you need to start LibreOffice Math and then
navigate to Tools > Options > LibreOffice Math > Settings.

Scaling of code in the Formula Editor input window
By default, the code in the Formula Editor input window (Figure 294) is scaled to 100%. You can
change the scaling factor by going to Tools > Options > LibreOffice Math > Settings on the
Menu bar and changing the percent in the Scaling code input window box in the Miscellaneous
Options section. For example, if you change the scaling to 150%, the code in the input window
will appear larger. This setting affects the Formula Editor in all LibreOffice components. However,
the LibreOffice Math section in the Options dialog can only be accessed from within the Math
component. It is not available when you are editing a formula in a document in any other
LibreOffice component.

Extensions
If you create formulas frequently in your documents, you can customize LibreOffice by adding
extensions that are designed to help you create formulas. Extensions are easily installed using
the Extension Manager. For more information on how to install extensions, see Chapter 14,
Customizing LibreOffice.
A commonly used extension is Formatting of All Math Formulas. It allows you to format all
Math formulas in a Writer, Calc, Draw, or Impress document. With it you can change the font
names and font sizes of all formulas in the document. For more information on this extension, go
to https://extensions.libreoffice.org/en/extensions/show/formatting-of-all-math-formulas.
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Exporting and Importing
Math ML format
In addition to exporting documents as PDFs, LibreOffice offers the possibility of saving formulas
in the MathML format. This allows you or another person to insert formulas into documents that
were created in other software, for example, Microsoft Office or an internet browser.

Note
Some internet browsers do not fully support the MathML format and your formula
may not display correctly.
If you are working on a Math document, go to File > Save as on the Menu bar or use the
keyboard combination Ctrl+Shift+S to open the Save as dialog. Select MathML in the list of
available file formats in File type to save your formula as MathML.
If you are working in another LibreOffice component, right-click on the formula object and select
Save Copy as in the context menu to open the Save as dialog. Select MathML in the list of
available file formats in File type to save your formula object as MathML.
In Math you can also import MathML formulas. Use Tools > Import MathML from Clipboard on
the Menu bar.

Microsoft file formats
To control how formulas in Microsoft format are imported and exported using LibreOffice, go to
Tools > Options > Load/Save > Microsoft Office on the Menu bar and select or deselect the
options for MathType to LibreOffice Math or reverse.
•

[L]: Load and convert the object

•

[S]: Convert and save the object

[L]: Load and convert the object
Select this option if Microsoft OLE objects are to be converted into the specified LibreOffice OLE
objects when a Microsoft document is opened in LibreOffice. For formulas, any embedded
MathType objects must not exceed the MathType 3.1 specifications to be successfully loaded
and converted. Information on MathType format can be found at
https://docs.wiris.com/en/mathtype/office_tools/microsoft_office.
If a document containing OMML formulas has been saved in .docx format and then converted to
the older .doc format, then any OMML objects are converted into graphics, which will be
displayed in LibreOffice as graphics.

[S]: Convert and save the object
Select this option if LibreOffice OLE objects are to be converted and saved in Microsoft file
format. LibreOffice converts any formulas into a format that can be read and modified by
Microsoft Equation Editor and MathType.
When this option is not selected, the formula is treated as an OLE object on conversion into
a .doc format and remains linked to LibreOffice. A double-click on the object in Microsoft Office
will attempt to launch LibreOffice.
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Getting Started Guide 7.3

Chapter 10,
Printing, Exporting, Emailing
and Signing Documents

Quick printing
If the Print Directly icon is visible on the Standard toolbar, you can click it to print the entire
document using the current default print settings. If the icon is not visible, you can make it visible
it by right-clicking on the toolbar, pointing to Visible Buttons, and selecting Print Directly.

Note
The Print Directly and other printing options are not available when viewing a Base
table or query.

Printer settings
To specify the default printer, go to File > Printer Settings on the Menu bar. The Printer Setup
dialog opens. For further printing options, click the Options button on the Printer Setup dialog to
access them. The same default options are available through Tools > Options > [LibreOffice
Component] > Print, and more general print options through Tools > Options > LibreOffice >
Print. See Chapter 2, Setting Up LibreOffice, for more information.

Controlling printing
For more control over printing, use the Print dialog (File > Print, Ctrl+P (⌘+P for macOS), or the
Print icon on the Standard toolbar).

Note
Unlike most dialogs in LibreOffice, the Print dialog is different on macOS and may
include extra printer controls not described in this chapter.
In Windows and Linux, the Print dialog (Figure 314) has two tabs, from which you can choose a
range of options as described in the following sections. The first tab is General; it is similar in all
LibreOffice, although some of the options available in Writer are unavailable in other
components. The second tab is component-specific.
The components of LibreOffice have different print settings, as summarized in Table 5.
Table 5: Print options in LibreOffice components
Feature

Writer

Calc

Impress Draw

Math

Select pages/sheets/slides to print

Yes

Yes

Yes

Yes

Yes

Print multiple pages/sheets/slides on one
page

Yes

Yes

Yes

Yes

No

Print a brochure

Yes

No

Yes

Yes

No

Print envelopes

Yes

No

No

No

No

Print labels or business cards

Yes

No

No

No

No

Preview pages/sheets before printing

Yes

Yes

No

No

No

Base forms and reports are printed using the Writer version of the Print dialog and hence provide
the facilities in the Writer column of Table 5.
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Figure 314: The Print dialog in Writer (Windows and Linux)

Selecting general printing options
On the General tab of the Print dialog, you can choose:
•

The printer, from the list of available printers

•

Which pages to print, the number of copies to print, and whether to collate multiple
copies (Range and Copies section; “Selecting pages/sheets/slides to print” on page 347)

•

Paper size and print orientation (Page Layout section)

•

How many pages to print on one sheet of paper and whether to draw a border around
each page (Page Layout section)

•

Whether to print a brochure (“Printing a brochure” on page 352)

•

Whether to print in reverse page order (useful on some printers to make the pages come
out in page order)

Selecting printer and print job options
In the Printer section of the General tab, click the Properties button to display the selected
printer’s properties dialog where you can choose portrait or landscape orientation, which paper
tray to use, and the paper size to print on.
Click the More button at the bottom of the Range and Copies section of the General tab to
choose whether to create separate print jobs for collated output, instead of one print job
containing all the collated pages (not relevant if only one copy of a document is printed).
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Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this, in the Page Layout
section of the General tab, click More and select in the Pages per sheet drop-down list the
number of pages to print per sheet of paper. The preview panel on the left of the Print dialog
shows how the printed document will look. This facility is not available in Math.
When printing more than two pages per sheet, you can choose the order in which they are
printed across and down the paper (Figure 315).

Tip
In Writer, to print two pages per sheet in “facing pages” (book layout) style, print from
Print Preview instead. See page 354.

Figure 315: Print order choices

Selecting pages/sheets/slides to print
In addition to printing a full document, in the Range and Copies section of the General tab, you
can choose to print individual pages/sheets/slides, ranges of pages/sheets/slides, or a selection
of a document. The details vary slightly between Writer, Calc, Draw, Impress, and Math, as
described below.

Writer and Math
Printing an individual page:
1) In the Print dialog, in the Range and Copies section, select the Pages option. The text
box shows the current page number.
2) Enter the page number of the page you want to print. The preview box on the left
changes to show the selected page.
Printing a range of pages:
1) In the Print dialog, in the Range and Copies section, select the Pages option.
2) Enter the page numbers of the pages to print (for example, 1–4 or 1,3,7,11 or a
combination).
Printing a selection of text or graphics (Writer only):
1) In the document, select the material to print, then open the Print dialog.
2) In the Range and Copies section of the Print dialog, the Selection option is now active
and selected and the preview box shows the selected material (Figure 316).
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Figure 316: Printing a selection of text

Calc
You can choose individual sheets, ranges of sheets, or selections of sheets for printing.

Figure 317: Choosing what to print in Calc
Printing an individual sheet:
1) In the spreadsheet, click on the sheet tab to select the sheet you want to print.
2) Open the Print dialog and choose the General tab.
3) In the Range and Copies section, click More and choose Print Selected Sheets in the
From which drop-down.
Printing a range of sheets:
1) In the spreadsheet, select the sheets to print.
a) Select the first sheet.
b) Hold down the Control key and click on the additional sheet tabs.
c) Release the Control key when all required sheets are selected.
2) Open the Print dialog and choose the General tab.
3) In the Range and Copies section, click More and choose Print Selected Sheets in the
From which drop-down.
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Caution
After printing, be sure to deselect the extra sheets. If you keep them selected, the
next time you enter data on one sheet, you enter data on all the selected sheets.
This might not be what you want.
Printing a selection of cells:
1) In the document, select the cells to print.
2) Open the Print dialog and choose the General tab.
3) In the Ranges and Copies section, click More and choose Print Selected Cells in the
From which drop-down.

Impress and Draw
You can choose individual slides, ranges of slides, or selections of slides for printing.
To print an individual slide or a range of slides, do one of the following:
•

In the Print dialog, select the Slides option in the Range and Copies section (Figure 318)
and then enter the numbers of the slides to print (for example, 1-4 or 1,3,7,11 or a
combination).

•

Select the slides first and then open the Print dialog, which will show the slide numbers in
the box. See Chapter 6, Getting Started with Impress, for information on selecting slides.

Figure 318: Choosing what to print in Impress and Draw
To print a selection from a slide, or a selection from multiple slides:
1) In the document, select the section of the slide to print.
2) Open the Print dialog.
3) Choose the Selection option in the Range and Copies section.
You can also choose to print only even-numbered slides or only odd-numbered slides.

Choices on the component tabs
Choices on the LibreOffice [Component] tab vary with the component.

Writer
On the LibreOffice Writer tab (Figure 319) you can choose to print a subset of contents (for
example, images or hidden text), print text in black (even if a color is defined for the text),
whether to print automatically inserted blank pages, and whether and where to print any
comments that are in the document (Figure 320).
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Figure 319: LibreOffice Writer tab of Print dialog
Some selections may not be available all the time. For example, if the document contains no
comments, the Comments drop-down list is disabled.

Figure 320: Choosing whether and where to print comments

Calc
The only choice on the LibreOffice Calc tab is whether to suppress the printing of empty pages.

Impress
On the LibreOffice Impress tab (Figure 321), you can choose to print slides, handouts, notes, or
an outline. See Chapter 6, Getting Started with Impress, for more information on these features.
•

Handouts prints the slides in reduced size on the page, from one to nine slides per page.
The slides can be printed horizontally (landscape orientation) or vertically (portrait
orientation) on the page.

•

Notes prints a single slide per page with any notes entered for that slide in Notes View.

•

Outline prints the title and headings of each slide in outline format.
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Figure 321: LibreOffice Impress tab of Print dialog
To print slides, handouts, notes, or outlines:
1) In the Document section, select the required option under Type.
2) For Handouts, you can then choose how many slides to print per page, and the order in
which they are printed (Figure 322).

Figure 322: Handouts
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Draw
On the LibreOffice Draw tab (Figure 323), you can choose print options as shown.

Figure 323: LibreOffice Draw tab of Print dialog

Math
On the LibreOffice Math tab (Figure 324), you can choose print options as shown.

Figure 324 - LibreOffice Math tab of Print dialog

Printing a brochure
In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of
paper, arranged so that when the printed pages are folded in half, the pages are in the correct
order to form a booklet or brochure.

Tip
Plan your document so it will look good when printed half size; choose appropriate
margins, font sizes, and so on. You may need to experiment.
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To print a brochure:
1) In the Page Layout section of the General tab, click more and select the Brochure
option. The preview on the left changes to show the sequence in which the pages will be
printed (Figure 325).

Figure 325: Settings for printing a brochure on a simplex printer
2) If you have Asian or CTL selected in your language settings (Tools > Options >
Language Settings > Languages), the Writer variant of the Print dialog may include a
drop-down menu adjacent to the Brochure button (not shown in Figure 325). This
provides Left-to-right script and Right-to-left script options. Select the required setting.
3) If your printer can print double-sided (duplex) pages automatically, choose All pages in
the Range and Copies section, then click OK to print.
4) If your printer can print only single-sided pages automatically, follow these steps:
a) Select Even pages in the Range and Copies section, then click OK to print.
b) Take the printed pages out of the printer and put them back in the correct orientation
to print on the blank side. You may need to experiment to find the correct
arrangement for your printer.
c) On the Print dialog, in the Range and Copies section, select Odd pages. Click OK.
Chapter 10, Printing, Exporting, Emailing and Signing Documents | 353

Printing envelopes, labels, business cards
Printing envelopes, labels, or business cards using Writer involves two steps: setup and printing.
For details, see Chapter 14, Mail Merge, in the Writer Guide.

Previewing pages/sheets before printing
You can use the previewing options in Writer and Calc to view the document as it will be printed.
Several viewing options are available.

Writer
The normal page view in Writer shows you what each page will look like when printed and you
can edit the pages in that view. If you are designing a document to be printed double-sided, you
may want to see what facing pages look like. Writer provides two ways to do this:
•

View Layout (editable view): use the Book view button on the status bar.

•

Print Preview (read-only view).

To use Print Preview:
1) Choose File > Print Preview on the Menu bar, or click the Toggle Print Preview button
on the Standard toolbar, or press Ctrl+Shift+O (Shift+⌘+O for macOS).
Writer now displays the Print Preview toolbar instead of the Formatting toolbar.

Figure 326: Print Preview toolbar (Writer)
2) Select the required preview icon: Single Page Preview, Two Pages Preview, Book
Preview, or Multiple Pages Preview.
3) To print the document from this view, click the Print icon to open the Print dialog. Choose
the print options and click OK or Print (macOS).

Calc
To preview the sheets in Calc before printing:
1) Choose File > Print Preview on the Menu bar, or click the Toggle Print Preview button
on the Standard toolbar, or press Ctrl+Shift+O (Shift+⌘+O for macOS).
The Calc window now displays the Print Preview toolbar instead of the Formatting toolbar.

Figure 327: Print Preview toolbar (Calc)
2) To print the document from this view, click the Print icon to open the Print dialog.
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Printing in black and white (on a color printer)
You may wish to print documents in black and white on a color printer. Several choices are
available.

Note
Some color printers may print in color regardless of the settings you choose.
For one document, change the printer settings to print in black and white or grayscale:
1) On the Print dialog, click Properties to open the Properties dialog for the printer. The
available choices vary from one printer to another, but you should find options for the
color settings. See your printer’s help or user manual for more information.
2) The choices for color might include black and white or grayscale. Choose grayscale.
3) Click OK to confirm your choice and return to the Print dialog.
4) Click Print to print the document.
To print all color text and images as grayscale, change the LibreOffice settings:
1) Choose Tools > Options > LibreOffice > Print.
2) Select the Convert colors to grayscale option. Click OK to save the change.
In Writer, to print all color text as black, and all images as grayscale, change the LibreOffice
Writer settings
1) Choose Tools > Options > LibreOffice Writer > Print.
2) Under Contents, select the Print text in black option. Click OK to save the change.

Exporting to PDF
LibreOffice can export documents to PDF (Portable Document Format). This standard file format
is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.

Warning
A document in PDF format is not protected against contents tampering or editing by
default. The PDF document contents can be edited by specialized software tools,
including LibreOffice Draw.
The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few minor
differences mentioned in this section.

Tip
Unlike Save As, the Export command writes a copy of the current document in a new
file with the chosen format, but keeps the current document and format open in your
session.

Quick export to PDF
Click the Export Directly as PDF icon on the Standard toolbar to export the entire document
using the PDF settings you most recently selected on the PDF Options dialog (see below). In
Writer, Impress, and Draw, you can also use File > Export As > Export Directly as PDF. You
are asked to enter the file name and location for the PDF file, but you do not get a chance to
choose a page range, the image compression, or other options.
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Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export As >
Export as PDF (Writer, Impress, and Draw) or File > Export as PDF (Calc and Math) on the
Menu bar. The PDF Options dialog opens. This dialog has six tabs (General, Initial View, User
Interface, Links, Security, and Digital Signatures). Select the appropriate settings, and then click
Export. Then you are asked to enter the location and file name of the PDF to be created, and
click Export to export the file.

Note
You can also export to PDF from File > Export (not Math). On the Export dialog,
select the PDF file format, the file name and location, and click Export. The PDF
Options dialog then opens. Select the appropriate settings and then click Export.
The only difference between the two export methods is the sequence in which steps
occur.

General tab of PDF Options dialog
On the General tab, you can choose which pages to include in the PDF, the type of compression
to use for images (which affects the quality of images in the PDF), and other options. Figure 328
shows the Writer variant of the General tab – the corresponding tabs for other LibreOffice
components have minor differences from this figure.

Figure 328: General tab of PDF Options dialog (Writer)
Range section
• All: Exports the entire document to PDF.
•

Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single
pages, use the format 7;9;11 (pages 7, 9 and 11). You can also export a combination of
page ranges and single pages, by using a format like 3-6;8;10;12.

•

Selection: Exports all the selected material.
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•

View PDF after export: Your default PDF viewer will open and display the newly
exported PDF.

Images section
• Lossless compression: Images are stored without any loss of quality. All pixels are
preserved. This setting tends to make large files when used with photographs.
Recommended for other kinds of images or graphics.
•

JPEG compression: In the Quality box, specify a compression level. Higher quality
levels preserve more pixels. A setting of 90% works well with photographs (small file
size, little perceptible loss of quality).

•

Reduce image resolution: Lower DPI (dots per inch) images have lower quality. Lower
resolutions (100 DPI or less) may be sufficient for viewing on a computer screen, but
many modern devices have much higher resolutions; and for printing it is generally
preferable to use at least 300 or 600 DPI, depending on the capability of the printer.
Higher DPI settings increase the size of the exported file.

Note
EPS (Encapsulated PostScript) images with embedded previews are exported only
as previews. EPS images without embedded previews are exported as empty
placeholders.
Watermark section
• Sign with watermark: When this option is selected, a transparent overlay of the text you
type in the Sign with watermark text box will appear on each page of the PDF.
General section
• Hybrid PDF (embed ODF file): Use this setting to export the document as a PDF
containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF
file, and it remains fully editable in LibreOffice.
•

Archive (PDF/A, ISO 19005): PDF/A is an ISO standard for long-term preservation of
documents, by embedding all the information necessary for faithful reproduction (such as
fonts) while forbidding other elements (including forms, security, and encryption). PDF
tags are written. PDF/A-1b refers to the minimum compliance level with PDF/A-1.
PDF/A-2b is recommended for most users, because it allows for layers and transparency
with shapes and images. It also compresses better, usually producing smaller files.
PDF/A-3b is identical to PDF/A-2b, but also accepts embedding of other file formats.

•

Universal Accessibility (PDF/UA): Creates a universal accessibility-complaint PDF file
that follows the requirements of PDF/UA (ISO 14289) specifications. See the Help for
more information.

•

Tagged PDF: Tagged PDF contains information about the structure of the document’s
contents. This can help to display the document on devices with different screens, and
when using screen reader software. Some tags that are exported are table of contents,
hyperlinks, and controls. This option can increase file sizes significantly.

•

Create PDF form – Submit format: Choose the format of submitting forms from within
the PDF file. This setting overrides the control’s URL property that you set in the
document. There is only one common setting valid for the whole PDF document: PDF
(sends the whole document), FDF (sends the control contents), HTML, and XML. Most
often you will choose the PDF format.

•

Allow duplicate field names: If enabled, the same field name can be used for multiple
fields in the generated PDF file. You can enter data in the first occurrence of the named
field in the PDF document and all fields with the same name will carry your entry. If
disabled, field names will be exported using generated unique names.
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Structure section
• Export outlines: Exports headings in Writer documents, and page or slide names in
Impress and Draw documents, as an outline (table of contents list) displayed by most
PDF viewers, including Adobe Reader. In LibreOffice 7.0 and earlier, these were called
bookmarks.
•

Export placeholders: The PDF will include any defined placeholder fields, which can be
filled in by users. This option is only available in Writer.

•

Comments as PDF annotations: If selected, comments are included in the PDF as
annotations.

•

Export automatically inserted blank pages: If selected, automatically inserted blank
pages are exported to the PDF. This is best if you are printing the PDF double-sided. For
example, books usually have chapters set to always start on an odd-numbered (righthand) page. When the previous chapter ends on an odd page, LibreOffice inserts a blank
page between the two odd pages. This option controls whether to export that blank page.

•

Use reference XObjects: Reference XObjects enable one PDF file to import content
from another. More information can be found in section 8.10.4 of the PDF specification,
ISO 32000-2:2017 (https://www.iso.org/standard/63534.html). If you are not familiar with
referenceXObjects, leave this box unchecked.

Initial View tab of PDF Options dialog
On the Initial View tab (Figure 329), you can choose how the PDF opens by default in a PDF
viewer. The selections should be self-explanatory.
If you have Complex Text Layout enabled (in Tools > Options > Language Settings >
Languages), an additional selection is available under the Continuous facing option: First
page is left (normally, the first page is on the right when using the Continuous facing option).

Figure 329: Initial View tab of PDF Options dialog

User Interface tab of PDF Options dialog
On the User Interface tab (Figure 330), you can choose more settings to control how a PDF
viewer displays the file. Some of these choices are particularly useful when you are creating a
PDF to be used as a presentation or a kiosk-type display.
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Figure 330: User Interface tab of PDF Options dialog
Window Options section
• Resize window to initial page: The PDF viewer window will resize to fit the first page of
the PDF.
•

Center window on screen: The PDF viewer window will be centered on the computer
screen.

•

Open in full screen mode: The PDF viewer will open full-screen instead of in a smaller
window.

•

Display document title: The PDF viewer will display the document’s title in the title bar.

User Interface Options section
• Hide menubar: The PDF viewer will hide the menu bar.
•

Hide toolbar: The PDF viewer will hide the toolbar.

•

Hide window controls: The PDF viewer will hide other window controls.

Transitions
In Impress, displays slide transition effects as their respective PDF effects.
Collapse Outlines
Select how many heading levels are displayed in the outline, if Export outlines is selected
on the General tab.

Links tab of PDF Options dialog
On the Links tab (Figure 331), you can choose how links are exported to PDF.
General
• Export outlines as named destinations: Paragraphs defined in Writer’s outline levels,
Impress or Draw slide names, and Calc sheet names are exported as “named
destinations” to which Web pages and PDFs can link.
•

Convert document references to PDF targets: If you have defined links to other
documents with OpenDocument extensions (such as .odt, .ods, and .odp), the file
extensions are converted to .pdf in the exported PDF document.

•

Export URLs relative to file system; If you have defined relative links in a document,
this option exports those links to the PDF.
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Figure 331: Links tab of PDF Options dialog
Cross-document Links
Defines the behavior of links clicked in PDF files. Select one among the following
alternatives:
– Default mode: The PDF links will be handled as specified in your operating system.
– Open with PDF reader application: Use the same application used to display the
PDF document to open linked PDF documents.
– Open with Internet browser: Use the default Internet browser to display linked PDF
documents.

Security tab of PDF Options dialog

Figure 332: Security tab of PDF Options dialog
PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and
apply some digital rights management (DRM) features.
•

With an open password set, the PDF can only be opened with the password. Once
opened, there are no restrictions on what the user can do with the document (for
example, print, copy, or change it).
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•

With a permissions password set, the PDF can be opened by anyone, but its permissions
can be restricted. After you set a password for permissions, the other choices on the
Security page (Figure 332) become available.

•

With both the open password and permission password set, the PDF can only be opened
with the correct password, and its permissions can be restricted.

Note
Permissions settings are effective only if the user’s PDF viewer respects the settings.

Digital Signatures tab of PDF Options dialog
The Digital Signatures tab (Figure 333) contains the options for exporting a digitally signed PDF.

Figure 333: Digital Signatures tab of PDF Options dialog
Digital signatures are used to ensure that the PDF was really created by the original author (that
is, you), and that the document has not been modified since it was signed.
The signed PDF export uses the keys and X.509 certificates already stored in your default key
store location or on a smartcard. The key store to be used can be selected under Tools >
Options > LibreOffice > Security > Certificate (macOS and Linux only). When using a
smartcard, it must already be configured for use by your key store. This is usually done during
installation of the smartcard software. Details about using these features is outside the scope of
this chapter.
•

Use this certificate to digitally sign PDF documents: Click Select to open the Select
Certificate dialog, where all certificates found in your selected key store are displayed. If
the key store is protected by a password, you are prompted for it. When using a
smartcard that is protected by a PIN, you are also prompted for that.

•

Select the certificate to use for digitally signing the exported PDF, then click Sign.

•

All other fields on the Digital Signatures tab are accessible only after a certificate has
been selected.

•

Certificate password: Enter the password used for protecting the private key associated
with the selected certificate. Usually this is the key store password. If the key store
password has already been entered in the Select Certificate dialog, the key store may
already be unlocked and not require the password again.

•

When using a smartcard, enter the PIN here. Some smartcard software will prompt you
for the PIN again before signing.
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•

Location, Contact information, Reason: Optionally enter additional information about
the digital signature that will be applied to the PDF. This information will be embedded in
the appropriate PDF fields and will be visible to anyone viewing the PDF. Each or all of
the three fields may be left blank.

•

Time Stamp Authority: Optionally select a Time Stamping Authority (TSA) URL. During
the PDF signing process, the TSA will be used to obtain a digitally signed timestamp that
is then embedded in the signature. Anyone viewing the PDF can use this timestamp to
verify when the document was signed.

•

The list of TSA URLs that can be selected is maintained under Tools > Options >
LibreOffice > Security > TSAs. If no TSA URL is selected (the default), the signature
will not be timestamped, but will use the current time from your local computer.

Exporting to EPUB format (Writer only)
EPUB format has become popular since mobile devices such as smartphones, tablets, and
e-readers appeared on the market. The EPUB format is implemented as an archive file
consisting of HTML files carrying the content, along with images and other supporting files.
Writer can export a file to EPUB. A text-only document generally exports well, but some contents
(such as illustrations, tables, and cross-references) may not export correctly.

Tip
Other ways to export to EPUB from Writer (.odt) files include Calibre, an open-source
e-book manager that runs on Windows, macOS, and Linux. Calibre provides many
e-book conversion facilities (including PDF to EPUB) and allows editing of the result.
https://calibre-ebook.com/.

Quick export to EPUB
Choose File > Export As > Export Directly as EPUB to export the entire document using the
EPUB settings you most recently selected on the EPUB Export dialog (see below). You are
asked to enter the file name and location for the EPUB file, but you do not get a chance to select
other options.

Controlling export to EPUB
For more control over the content and quality of the resulting EPUB file, use File > Export As >
Export as EPUB. The EPUB Export dialog opens (Figure 334).
The EPUB Export dialog has the following fields:
Version
Choose the EPUB version for the exported file. Values are EPUB 2.0 and EPUB 3.0. Most
new e-readers can read EPUB 3.0.
Split method
Select the method to start a new section. Choose Heading to start the section on a
heading, according to the document’s chapter numbering. Choose Page break to start the
section on a page break.
Layout method
Choose Reflowable to have the ebook display change to fit the screen size and the user’s
preference (so page size and header/footer content is not exported). Choose Fixed to have
the ebook layout remain the same under all conditions.
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Figure 334: EPUB Export dialog
Customize
Cover image
The path to the image file for the cover page. If no image is specified, the EPUB file will
automatically use any image with a name like cover.gif, cover.jpg, cover.png, or cover.svg.
A custom cover image is embedded in the EPUB file.
Media directory
The path to the optional directory for the cover image, metadata, and multimedia files. If
you do not specify a directory, the exporter looks for custom media and custom metadata in
the current document directory inside a folder with the same name as the document file
name.
Metadata
The basic information for the file that provides tags to help searches. These fields provide
another chance to edit metadata that is picked up by default from File > Properties in
Writer.

Exporting to other formats
LibreOffice uses the term “export” for some file operations involving a change of file type. If you
cannot find what you want under File > Save As, look under File > Export (not available in
Math) as well.
LibreOffice can export files to XHTML. In addition, Draw and Impress can export to a range of
image formats.
To export to one of these formats, choose File > Export. On the Export dialog, specify a file
name for the exported document, then select the required file format and click Export.
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Emailing documents
LibreOffice provides several ways to send documents quickly and easily as email attachments in
one of three formats: OpenDocument (LibreOffice’s default format), Microsoft Office formats, or
PDF.
To send the current document in OpenDocument format:
1) Choose File > Send > Email Document. LibreOffice opens your default email program.
The document is attached to a new email. If no email program is installed, LibreOffice
displays a message.
2) In your email program, enter the recipient, subject, and any text you want to add, then
send the email.
File > Send > Email as OpenDocument [Text, Spreadsheet] has the same effect in Writer or
Calc.
If you choose Email as Microsoft [Word, Excel] in Writer or Calc, LibreOffice first creates a file
in one of those formats and then opens your email program with the file attached to a new email.
Similarly, if you choose Email as PDF, LibreOffice opens the PDF Options dialog where you can
select the settings you want, and then opens your email program with the PDF attached to a new
email.

Emailing a document to several recipients
To email a document to several recipients, you can use the features in your email program or you
can use LibreOffice Writer’s mail merge facilities to create the document and send it. See
Chapter 14, Mail Merge, in the Writer Guide for details.

Digital signing of documents
To sign a document digitally, you need a personal key, also known as a certificate. A personal key
is stored on your computer as a combination of a private key, which must be kept secret, and a
public key, which you add to your documents when you sign them. You can get a certificate from
a certification authority, which may be a private company or a governmental institution.
When you apply a digital signature to a document, a checksum is computed from the document’s
content plus your personal key. The checksum and your public key are stored with the document.
When someone later opens the document on any computer with a recent version of LibreOffice,
the program will compute the checksum again and compare it with the stored checksum. If both
are the same, the program will signal that you see the original, unchanged document. In addition,
the program can show you the public key information from the certificate. You can compare the
public key with the public key that is published on the web site of the certificate authority.
Whenever someone changes something in the document, this change breaks the digital
signature.
For a more detailed description of how to get and manage a certificate, and signature validation,
see “Applying Digital Signatures” in the LibreOffice Help.
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Applying a digital signature
The following procedure is an example of how to digitally sign a document. The actual procedure
depends on how your computer is set up and its operating system.
1) Choose File > Digital Signatures > Digital Signatures.
– If you have set LibreOffice to warn you when the document contains comments or
recorded changes (see “Removing personal data” on page 367), you may see a
message box asking whether you want to want to continue signing the document.
Click Yes to continue.
– If you have not saved the document since the last change, a message box appears.
Click Yes twice: once to continue and again to save the file.
2) The Digital Signatures dialog (Figure 335) opens. It lists existing signatures together with
their description (if they have any). Click the Sign Document button to add a new
signature to the document.
3) In the Select Certificate dialog (Figure 336), select your certificate, add an optional
description, and click Sign to return to the Digital Signatures dialog.
The certificate used is displayed in the dialog with an icon next to its name. This icon
indicates the status of the digital signature.
4) Click Close in the Digital Signatures dialog to apply the digital signature.
A signed document shows an icon in the status bar. You can double-click the icon to view the
certificate. More than one signature can be added to a document.
Changing an existing description invalidates the signature. However, multiple signatures from the
same author are allowed, because each signature can have a different description.

Figure 335: Signatures of the document
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Figure 336: Signatures can have a description

Including a signature line (Writer and Calc)
You can generate a graphic box representing a signature line (Figure 338) and you can optionally
sign the signature line using a digital certificate. To open the Signature Line dialog (Figure 337),
select Insert > Signature Line on the Menu bar.

Figure 337: Creating a signature line for a document
366 | LibreOffice 7.3 Getting Started Guide

Figure 338: Signature line example

Removing personal data
You may wish to ensure that personal data, versions, notes, hidden information, or recorded
changes are removed from files before you send them to other people or create PDFs from them.
In Tools > Options > LibreOffice > Security, click the Options button to display a dialog where
you can set LibreOffice to warn you when files contain certain information and/or automatically
remove personal information on saving.
To remove personal and some other data from a file, go to File > Properties. On the General
tab, uncheck Apply user data and click the Reset Properties button. This removes any names
in the created and modified fields, deletes the modification and printing dates, and resets the
editing time to zero, the creation date to the current date and time, and the version number to 1.
To remove version information, either go to File > Versions, select the versions from the list and
click Delete; or use File > Save As and save the file with a different name.

Redaction
You can redact documents to remove or hide sensitive information, to allow the selective
disclosure of information in a document while keeping other parts of the document secret. For
example, when a document is subpoenaed in a court case, information not specifically relevant to
the case at hand is often redacted.
To redact a document:
1) Open the document in LibreOffice.
2) Click Tools > Redact on the Menu bar, and wait for the document to be prepared for
redaction and transferred to Draw. The Redaction toolbar (Figure 339) opens.

Figure 339: Redaction toolbar
3) Do the redaction by using the Rectangle Redaction and Freeform Redaction tools on
the Redaction toolbar. The shapes will be transparent and in gray so you can see what
you are redacting.
4) Optionally use the Export Directly as PDF tool to make an in-redaction copy of the
document in PDF to use as a verbatim copy for review. The redacted items will be in
transparent grey.
5) To finalize the redaction, select the desired option (black or white) on the Redacted
Export tool. The transparent grey shapes are converted to opaque black or white shapes
and the document is exported as a pixellized PDF. There will be no selectable text in it,
and the redacted content will be non-existent.
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Auto-redaction
To partially automate the redaction process, you can define certain words (such as names) to be
redacted wherever they are found in the document. To do this, choose Tools > Auto-Redact on
the Menu bar to open the Automatic Redaction dialog (Figure 340). Here you can load a list of
terms (targets), add targets, delete targets, edit targets, and save a list of targets.
This feature is not available in Draw.

Figure 340: Automatic Redaction dialog
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Getting Started Guide 7.3

Chapter 11,
Images and Graphics
Pictures, Drawing Tools, Gallery, Fontwork

Introduction
You can add graphic and image files, including photos, drawings, and scanned images, to
LibreOffice documents. Images in LibreOffice are of these basic types:
•

Image files, such as photos, drawings, PDF documents, and scanned images

•

Diagrams created using LibreOffice’s drawing tools

•

Artwork created using clip art or Fontwork

•

Charts created using LibreOffice’s Calc component

This chapter covers images, diagrams, and Fontwork. For more detailed instructions on working
with drawing tools, see the Draw Guide and Impress Guide. Instructions on how to create charts
are given in the Calc Guide.

Creating and editing images
You might create images using a graphics program, scan them, or download them from the
Internet (make sure you have permission to use them), or use photos taken with a digital camera.
LibreOffice can import various vector (line drawing) images, and can rotate and flip such images.
LibreOffice also supports raster (bitmap) file formats, the most common of which are GIF, JPG,
PNG, and BMP. See Appendix B for a full list of the graphic formats LibreOffice can import.
LibreOffice can also import SmartArt images from Microsoft Office files. For example, Writer can
open a Microsoft Word file that contains SmartArt, and you can use Writer to edit the images.
To edit photos and other bitmap images, use a bitmap editor. To edit line drawings, use a vector
drawing program. You do not need to buy expensive programs. For many graphics, LibreOffice
Draw is sufficient. Open-source (and usually no-cost) tools such as GIMP (bitmap editor) and
Inkscape (vector drawing program) are excellent. These and many other programs work on
Windows, macOS, and Linux.

Adding images to a document
Images can be added to a document in several ways: by inserting an image file, directly from a
graphics program or a scanner, by dragging them from the clip art internal gallery, or by copying
and pasting from a source being viewed on your computer.

Inserting an image file
When the image is in a file stored on the computer, you can insert it into a LibreOffice document
using one of the following methods:

Drag and drop
This method embeds (saves a copy of) the image file in the document. To link the file instead of
embedding it, hold down the Ctrl+Shift keys while dragging the image.
1) Open a file browser window and locate the image you want to insert.
2) Drag the image into the LibreOffice document and drop it where you want it to appear. A
faint vertical line marks where the image will be dropped.

Insert Image dialog
1) Click in the LibreOffice document where you want the image to appear.
2) Choose Insert > Image on the Menu bar or click the Insert Image icon on the Standard
toolbar.
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3) On the Insert Image dialog, navigate to the file to be inserted, and select it.
4) At the bottom of the dialog (Figure 341) is a Link option. See “Linking an image file” on
page 372 for the use of Link.
5) Click Open.

Note
If you choose the Link option, a message box appears when you click Open. It asks
if you want to embed the graphic instead. Choose Keep Link if you want the link, or
Embed Graphic if you do not. To prevent this message from appearing again,
deselect the option Ask when linking a graphic at the bottom of the message.

Figure 341: Insert Image dialog

Copy and paste
Using the clipboard, you can copy images into a LibreOffice document from another LibreOffice
document and from other programs. To do this:
1) Open both the source document or program and the target LibreOffice document.
2) In the source document, select the image to be copied.
3) Copy the image to the clipboard.
4) Switch to the target document.
5) Click to place the cursor where the image is to be inserted.
6) Press Ctrl+V, or right-click and select Paste in the context menu, or click the Paste icon
on the Standard toolbar, to insert the image.

Caution
If the application from which the image was copied is closed before the image is
pasted into the target, the image stored in the clipboard could be lost.

Chapter 11, Images and Graphics | 371

Linking an image file
If the Link option in the Insert Image dialog is selected, LibreOffice creates a link to the file
containing the image instead of saving a copy of the image in the document. The result is that the
image is displayed in the document, but when the document is saved, it contains only a reference
to the image file, not the image itself. The document and the image remain as two separate files,
and they are merged together only when you open the document again.
Linking an image has two advantages and one disadvantage:
•

Advantage – You can modify the image file separately, and the modified image will
appear when you next open the document. This can be a big advantage if you (or
someone else, perhaps a graphic artist) is updating images.

•

Advantage – Linking can reduce the size of the document when it is saved, because the
image file itself is not included. However, file size is usually not a problem on a modern
computer, and LibreOffice can handle quite large files.

•

Disadvantage – If you send the document to someone else, or move it to a different
computer, you must also send the image files, or the receiver will not be able to see the
linked images. You need to keep track of the location of the images and make sure the
recipient knows where to put them, so that the document can find them. For example,
you might keep images in a subfolder named Images (under the folder containing the
document); the recipient of the file needs to put the images in a subfolder with the same
name and in the same place relative to the document.

Note
When inserting the same image several times in the document, LibreOffice embeds
only one copy of the image file.

Embedding linked images
If you originally linked the images, you can easily embed one or more of them later if you wish.

Figure 342: The Edit Links dialog
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1) Open the document in LibreOffice and choose Edit > Links to External Files.
2) In the Edit Links dialog (Figure 342), select the files you want to change from linked to
embedded.
3) Click the Break Link button and then click Yes to confirm embedding the image.

Inserting an image using a scanner
If a scanner is connected to your computer, LibreOffice can call the scanning application and
insert the scanned item into your document as an image. To start this procedure, choose Insert >
Media > Scan > Select Source on the Menu bar. Select the scan source from the list of
available devices, then click in the document where you want the graphic to be inserted, and
choose Insert > Media > Scan > Request to open the imaging software where you can adjust
settings for image quality, size, and other attributes.
Although this practice is quick and easy, it is unlikely to result in a high-quality image of the
correct size. You may get better results by scanning material into a graphics program and
cleaning it up there before inserting the resulting image into LibreOffice.

Inserting an image from the Gallery
The Gallery (Figure 343) provides a convenient way to group reusable objects such as graphics
and sounds that you can insert into your documents. The Gallery is available in the Writer, Calc,
Impress, and Draw components of LibreOffice. See “Managing the LibreOffice Gallery” on page
377. You can copy or link an object from the Gallery into a document.

Figure 343: The Gallery in Icon View
To insert an object from the Gallery into a document:
1) Click the Gallery icon on the Sidebar.
2) Select a theme in the list provided, and select an object with a single click.
Chapter 11, Images and Graphics | 373

3)

Drag and drop the image into the document, or right-click on the object and choose Insert
in the context menu.

To insert an object as a link, hold down the Shift and Ctrl keys and drag and drop the object into
the document.

Modifying, handling, and positioning images
LibreOffice provides many tools for cropping, resizing, modifying, filtering, and positioning
images; wrapping text around images; and using images as backgrounds and watermarks.
These tools are described in relevant chapters of the other guides. Some sophisticated
adjustments are best done in an image manipulation program and the results brought into
LibreOffice, rather than using LibreOffice’s built-in tools.

Using the Image toolbar
When you insert an image or select one already present in the document, the Image toolbar
appears. Two other toolbars can be opened from this one: the Image Filter toolbar, which can be
torn off and placed elsewhere on the window, and the Color toolbar, which opens as a separate
floating toolbar. From these three toolbars, you can apply small corrections to the image or obtain
special effects: transparency, color adjustment, flipping and rotating, and applying special-effects
filters. For more information, see the Writer Guide.

Cropping images
When you are only interested in a section of the image for the purpose of your document, you
may wish to crop (cut off) parts of it. LibreOffice provides two ways to crop an image: the Crop
tool and the Crop tab of the Image dialog in Writer (accessed by right-clicking on the image and
selecting Properties in the context menu). The Crop tool provides a quick and easy way to crop
an image; but for more control, use the Image dialog. For more information, see the Writer Guide.

Note
If you crop an image in LibreOffice, the image itself is not changed. LibreOffice hides,
but does not cut off, part of the image. If you export the document to HTML, the
original image is exported, not the cropped image. For exporting individual cropped
images, see “Exporting (saving) images” on page 375.

Resizing an image
To fit the image into your document, you may need to resize it. A quick and easy way to resize is
by dragging the image’s sizing handles:
1) Click the image, if necessary, to show the sizing handles.
2) Position the pointer over one of the sizing handles. The pointer changes shape, giving a
graphical representation of the direction of the resizing.
3) Click and drag to resize the image.

Tip
The corner handles resize both the width and the height of the image simultaneously,
while the other four handles resize only one dimension at a time. To retain the
original proportions of the image, hold down the Shift key while dragging one of these
handles.
For more accurate resizing of images, use the Type tab of the Image dialog.
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Rotating or flipping an image
To quickly flip an image vertically or horizontally, or rotate it, right-click the image and select
Rotate or Flip in the context menu, then choose the desired option in the submenu.
Writer provides more rotation options than the other LibreOffice components. See the Writer
Guide for more information.

Other settings
The Image dialog in Writer has ten tabs:
•

Type: define the size and anchor of the image and its position on the page.

•

Options: give the image a descriptive name, define the alternative text to be displayed
when the mouse hovers over the image, and protect some of the image settings from
changes.

•

Wrap: choose how text wraps around the image, and the spacing between the image
and the text.

•

Hyperlink: associate a hyperlink to the image, or create an image map.

•

Image: flip or rotate the image, and display the original location of the file in case the
image is linked rather than embedded.

•

Crop: cut off portions of the image, scale it and set its size.

•

Borders: create borders around the image and add a shadow.

•

Area: change the background (color, bitmap, gradient, pattern, or hatching) of the image.
This setting produces the desired results only for images with a transparent color.

•

Transparency: set the transparency and gradient options for the image.

•

Macro: associate a macro to the image. You can choose among the predefined macros
or write your own.

Exporting (saving) images
To make complex adjustments to the image in another program, or to save the image for use in
another document, you can export it directly from the document. Right-click on the image and
choose Save in the context menu to open the Image Export dialog. LibreOffice will let you save
the picture in several formats. Name the image, select the desired image format in the File type
list, and click Save.
Before the image is saved another dialog opens, where you can choose various image size and
format options. The content of this dialog depends on the output file type selected. If the image
has been modified within Writer, you will also see a confirmation dialog where you can choose to
save the original version or the modified version of the image.

Compressing images
If you insert a large image in a document and resize it to fit into the layout of the page, the
complete full-size original image is stored in the document file to preserve its content, possibly
resulting in a large document file to store or send by mail.
If you can accept some loss of quality of the image rendering or want to resize it, you can
compress or resize the image object to reduce its data volume while preserving its display in the
page layout.
Right-click to select the image and open the context menu. Then choose Compress to open the
Compress Image dialog (Figure 344). Use the Calculate New Size button to update the image
information on the dialog on each parameter set you change.
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Click OK to apply the compression settings. If the resulting image is not acceptable, press Ctrl+Z
to undo and choose another compression setting. For more information, see the Help.

Figure 344: The Compress Image dialog

Positioning images
When you add an image to a document, you need to choose how to position it with respect to the
text and other images. For details, see the relevant component guide (Writer, Calc, and so on).
Positioning is controlled by four settings:
•

Arrangement refers to the placement of an image on an imaginary vertical axis.
Arrangement controls how images are stacked upon each other or relative to the text.

•

Alignment refers to the vertical or horizontal placement of an image in relation to the
chosen anchor point.

•

Anchoring refers to the reference point for the images. This point could be the page, the
frame or cell where the object is, a paragraph, or even a character. An image always has
an anchor point.

•

Text wrapping in a Writer document refers to the relation of images to the surrounding
text, which may wrap around the image on one or both sides, be overprinted behind or in
front of the image, or treat the image as a separate paragraph or character.

In Writer, the settings can be accessed in several ways, depending on the nature of the graphic:
•

In the Format menu: Anchor, Wrap, and Arrange (for images and drawing objects).

•

In the context menu displayed when you right-click the graphic; this menu also includes
an Align Objects option.

•

For images, on the Type and Wrap tabs of the Image dialog. Note that you cannot control
the arrangement using the dialog.

•

For drawing objects, on the Position and Size tab of the Position and Size dialog.

•

For an embedded object (such as a Calc spreadsheet or Draw document), on the OLEObject toolbar.
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Adding captions to images
You can add captions to Writer images in three ways: automatically, by using the Caption dialog,
or manually. See the Writer Guide for details.

Managing the LibreOffice Gallery
Graphics in the Gallery are grouped by themes, such as Arrows, Diagrams, and Icons. You can
create other groups or themes and add your own pictures or find extensions containing more
graphics. Click on a theme to see its contents displayed in the Gallery window.
You can display the Gallery in Icon View (Figure 343) or Detailed View (Figure 345), and you can
hide or show the Gallery by clicking on the Sidebar’s Hide button.

Figure 345: Gallery in Detailed View

Note
The default themes supplied with LibreOffice can not be customized, although new
themes can be added; see “Adding a new theme to the Gallery” below. The locked
themes are easily recognizable by right-clicking on them; the only option in the
context menu is Properties.

Adding a new theme to the Gallery
You may wish to add your own theme to the Gallery to hold any images or other objects that you
use frequently, for example, a company logo. Or you may wish to add several themes, each
holding images for a specific project.
To add a new theme to the Gallery:
1)

Click the New button below the list of themes (Figure 345).
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2) In the Properties of New Theme dialog, click the General tab and type a name for the new
theme.
3) Click the Files tab and add images to the theme, as described below.

Tip
You can also get more gallery themes from the LibreOffice extensions website at
https://extensions.libreoffice.org/, including themes from previous versions of
LibreOffice, that are no longer installed by default with the program. See Chapter 14,
Customizing LibreOffice, for instructions on how to manage extensions.

Adding objects to the Gallery
To add objects to a theme that you have created:
1) Right-click on the name of the theme and select Properties in the context menu.
2) In the theme’s Properties dialog, click the Files tab (Figure 346).

Figure 346: Gallery Properties dialog
To add several files at once:
1) In the Properties dialog, click the Find Files button.
2) The Select Path dialog (not shown) opens. You can enter the path for the file’s directory in
the path text box, or you can navigate to locate the file’s directory.
3) Click the Select button to start the search. A list of files is then displayed in the Properties
dialog. You can use the file type drop-down list to limit the files displayed.
4) To add all of the files shown in the list, click Add All. Otherwise, select the files to add
and then click Add (hold down either the Shift key or the Ctrl key while clicking on the
files).
To add a single file:
1) In the Properties dialog, click Add to open the Gallery dialog.
2) Use the navigation controls to locate the image to add to the theme. Select it and then
click Open to add it to the theme.
3) Click OK on the Properties dialog to close it.
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Deleting images and themes from the Gallery
To delete an image from a theme, right-click on the name of the image file or its thumbnail in the
Gallery, then click Delete in the context menu. A message appears, asking if you want to delete
this object. Click Yes.
To delete a theme from the Gallery, select it from the list of themes, right-click, then click Delete
in the context menu. You cannot delete a theme supplied with LibreOffice.

Note
Deleting the name of a file from the list in the Gallery does not delete the file from the
hard disk or other location.

Location of the Gallery and the objects in it
Graphics and other objects shown in the Gallery can be located anywhere on your computer’s
hard disk, on a network drive, or other removable media. When you add graphics to the Gallery,
the files are not moved or copied; the location of each new object is simply added as a reference.
In a workgroup, you may have access to a shared Gallery (where you cannot change the
contents unless authorized to do so) and a user Gallery, where you can add, change, or delete
objects.
The location of the user Gallery is specified in Tools > Options > LibreOffice > Paths. You can
change this location, and you can copy your gallery files (*.sdv) to other computers.
Gallery contents provided with LibreOffice are stored in a different location. You cannot change
this location.

Note
The locations of Gallery themes distributed through LibreOffice extensions are
determined by the extensions’ settings.

Creating an image map
An image map defines areas of an image (called hotspots) with hyperlinks to web addresses,
other files on the computer, or parts of the same document. Hotspots are the graphic equivalent
of text hyperlinks (described in Chapter 12, Creating HTML Files). Clicking on a hotspot causes
LibreOffice to open the linked page in the appropriate program (for example, the default browser
for an HTML page; LibreOffice Calc for an ODS file; a PDF viewer for a PDF). You can create
hotspots of various shapes and include several hotspots in the same image.
To use the image map editor:
1) In the LibreOffice document, click on the image in which you want to define the hotspots.
2) Choose Tools > ImageMap on the Menu bar. The ImageMap Editor dialog (Figure 347)
opens. The main part of the dialog shows the image on which the hotspots are defined.
3) Use the tools and fields in the dialog (described below) to define the required hotspots
and links. A hotspot is identified by a line indicating its shape. The information needed for
the hotspot includes the address pointed to by the hyperlink and the text you want to be
displayed when the mouse pointer is moved over the hotspot.
4) Click the Apply icon to apply the settings.
5) When done, click the Save icon to save the image map to a file, then close the dialog.
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Figure 347: The dialog to create or edit an image map
The toolbar at the top of the dialog contains the following tools:
•

Apply: applies the changes.

•

Open, Save, Close, and Select.

•

Rectangle, Ellipse, Polygon, and Freeform Polygon: tools for drawing a hotspot
shape. These tools work in the same way as the tools in the Drawing toolbar.

•

Edit, Move, Insert, Delete Points: advanced editing tools to manipulate the shape of a
polygon hotspot. Select the Edit Points tool to activate the other tools.

•

Undo and Redo: cancels the previous action or reapplies the previous canceled action.

•

Active: toggles the status of a selected hotspot between active and inactive.

•

Macro: associates a macro with the hotspot instead of just associating a hyperlink.

•

Properties: sets the hyperlink properties and adds the Name attribute to the hyperlink.

Below the toolbar, specify for the selected hotspot:
•

Address: the address pointed to by the hyperlink. You can also point to an anchor in a
document; to do this, write the address in this format:
file:///<path>/document_name#anchor_name

•

Text: type the text that you want to be displayed when the cursor is moved over the
hotspot.

•

Frame: where the target of the hyperlink will open: pick among _blank (opens in a new
browser window), _self (opens in the active browser window), _top or _parent.

Tip
The value _self for the target frame will work in the vast majority of occasions. It is
therefore not recommended to use the other choices unless absolutely necessary.
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Using LibreOffice’s drawing tools
You can use LibreOffice’s drawing tools to create graphics such as simple diagrams using
rectangles, circles, lines, text, and other predefined shapes. You can also group several drawing
objects to make sure they maintain their relative position and proportion.
You can place the drawing objects directly on a page in the document or insert them into a frame.
You can also use the drawing tools to annotate photographs, screen captures, or other
illustrations produced by other programs, but this is not recommended because:
•

You cannot include images in a group with drawing objects, so they may not remain
aligned in your document.

•

If you convert a document to another format, such as HTML, the drawing objects and the
images will not remain associated; they are saved separately.

In general, if you need to create complex drawings, it is recommended to use LibreOffice Draw,
which includes many more features, such as layers and styles.

Creating drawing objects
To begin using the drawing tools, display the Drawing toolbar (Figure 348) by clicking View >
Toolbars > Drawing or by clicking on the Show Draw Functions icon on the Standard toolbar.

Tip
If you are planning to use the drawing tools repeatedly, you can tear off (undock) this
toolbar and move it to a convenient place as a floating toolbar in the window.

1
2
3
4

Select
Insert Line
Lines and Arrows

7
8
9
10

Rectangle
Rectangle, Rounded
Square
Ellipse

Curves and
Polygons
5 Curve
11 Circle
6 Polygon
12 Isosceles Triangle
Figure 348: The Drawing toolbar (Writer version)
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14
15
16

Right Triangle
Basic Shapes
Symbol Shapes
Block Arrows

19
20
21
22

17
18

Stars & Banners
Callout Shapes

23
24

Flowchart
Callouts
Insert Text Box
Insert Fontwork
Text
Points
Toggle Extrusion

To use a drawing tool:
1) Click in the document where you want the drawing to be anchored. You can change the
anchor later, if necessary.
2) Choose the tool on the Drawing toolbar (Figure 348). The mouse pointer changes to a
drawing-functions pointer and the normal Formatting toolbar changes to Drawing Object
Properties toolbar (Figure 349).
3) Move the cross-hair pointer to the place in the document where you want the graphic to
appear and then click and drag to create the drawing object. Release the mouse button.
The selected drawing function remains active, so that you can draw another object of the
same type.
4) To cancel the selected drawing function, press the Esc key or click on the Select icon (the
arrow at the left-hand end of the Drawing toolbar).
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5) You can now change the properties (fill color, line type and weight, anchoring, and others)
of the drawing object using either the Drawing Object Properties toolbar (Figure 349) or
the choices and dialogs reached by right-clicking on the drawing object.

Setting or changing properties for drawing objects
To set the properties for a drawing object before you draw it:
1) On the Drawing toolbar (Figure 348), click the Select tool.
2) On the Drawing Object Properties toolbar (Figure 349), click on the icon for each property
and select the value you want for that property.
3) For more control, or to define new attributes, you can click on the Area or Line icon on
the toolbar to display detailed dialogs.
The default you set applies to the current document and session. It is not retained when you
close the document or close LibreOffice, and it does not apply to any other document you open.
The defaults apply to all the drawing objects except text objects.
To change the properties for an existing drawing object, select the object and continue as
described above.
You can also specify the position and size, rotation, and slant and corner radius properties of the
drawing object: right-click on the drawing object and then choose Position and Size in the
context menu. Choose any properties, as required.
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Arrow Style

22

Points

2

[Wrap] None

9

Bring to Front
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Line Style
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Group
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[Wrap] Parallel

10

Forward One

17

Line Width

24

Enter Group

4

[Wrap] Optimal

11

Back One

18

Line Color

25

Exit Group

5
6

[Wrap] Before
[Wrap] After

12
13

Send to Back
To Foreground

19
20

Area Style / Filling
Fill Color

26
27

Ungroup
Insert Caption

7

[Wrap] Through

14

To Background

21

Rotate

Figure 349: Drawing Object Properties toolbar

Resizing a drawing object
An object is resized in a similar way to an image. Select the object, click on one of the eight
handles around it and drag it to its new size. The object will be scaled up or down. When you
grab the handle of an object and drag it, LibreOffice will resize disproportionately; if you also
press the Shift key, the resizing will keep object proportions.
For more sophisticated control of the size of the object, right-click on the object and choose
Position and Size in the context menu. Use the Postion and Size tab to set the position and size
independently. If the Keep ratio option is selected, then the two dimensions change so that the
proportion is maintained, resulting in a scaled resizing.
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Grouping drawing objects
Grouping drawing objects makes it easier to handle several objects as a single entity, while
preserving their relative sizes and positions. When objects are grouped, any editing operations
carried out on that group are applied to all members of the group. If you click on one member of
the group, the whole group is selected.
To group drawing objects:
1) Select one object, then hold down the Shift key and select the others you want to include
in the group. The bounding box expands to include all the selected objects.
2) With the objects selected, hover the mouse pointer over one of the objects and choose
Format > Group > Group on the Menu bar, or click the Group icon on the Drawing
Object Properties toolbar, or right-click and choose Group in the context menu.

Note
You cannot include an embedded or linked image in a group with drawing objects.
You can edit an individual member of a group without ungrouping or breaking the group. Select
the group and go to Format > Group > Enter Group on the Menu bar, or right-click and select
Enter Group in the context menu, or click the Enter Group icon on the Drawing Object
Properties toolbar. When you have finished editing an individual member of a group, go to
Format > Group > Exit Group on the Menu bar, or right-click and select Exit Group in the
context menu, or click the Exit Group icon on the Drawing Object Properties toolbar.
To ungroup or break apart a group of objects, select the group then go to Format > Group >
Ungroup on the Menu bar, or right-click and select Ungroup in the context menu, or click the
Unroup icon on the Drawing Object Properties toolbar.

Using Fontwork
With Fontwork you can create graphical text art objects to make your work more attractive. There
are many different settings for text art objects (line, area, position, size, and more), so you have a
large choice.
Fontwork is available with the Writer, Calc, Impress, and Draw components of LibreOffice, but
you will notice small differences in the way that each component displays it.

Creating a Fontwork object
1) On the Fontwork toolbar (View > Toolbars > Fontwork) or the Drawing toolbar (View >
Toolbars > Drawing), click the Fontwork Gallery icon, or choose Insert > Fontwork on
the Menu bar.
2) In the Fontwork Gallery dialog (Figure 350), select a Fontwork style (scroll down to see
more choices), then click OK.
The Fontwork object will appear in your document. Notice the squares around the edge
(indicating that the object is selected) and the differently colored dot; these are discussed
in “Moving and resizing Fontwork objects” on page 386.
3) Resize the object using one of the corner handles (hold down the Shift key to keep the
sides proportional), or right-click and choose Position and Size in the context menu for
more precise sizing.
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Figure 350: The Fontwork Gallery dialog
4) Double-click the object to edit the Fontwork text (Figure 351). Type your own text in place
of the black text that appears over the object.

Figure 351: Editing Fontwork text
5) Click anywhere in a free space or press Esc to apply your changes.

Editing a Fontwork object
Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can
use the Fontwork toolbar, the Fontwork panel on the Properties deck on the Sidebar, the
Formatting toolbar, or menu options as described in this section. If the selected Fontwork object
is a 3-D object, you can also use the 3D-Settings toolbar.

Using the Fontwork toolbar
Make sure that the Fontwork toolbar, shown in Figure 352, is visible. If you do not see it, go to
View > Toolbars > Fontwork. Click on the different icons to edit Fontwork objects. Icons 2–6
also appear in the Fontwork panel on the Properties deck on the Sidebar.

Figure 352: The floating Fontwork toolbar
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1

Insert Fontwork Text: Opens the Fontwork Gallery
(Figure 350).

2

Fontwork Shape: Edits the shape of the selected object.
You can choose from a palette of shapes.

3

Fontwork Same Letter Heights: Changes the height of characters in the object. Toggles
between normal height (some characters taller than others, for example capital letters, d, h,
l and others) and all letters the same height.

Figure 353: Left: normal letters; right: same letter heights

4

Fontwork Alignment: Changes the alignment of characters.
Choices are Left Align, Center, Right Align, Word Justify, and
Stretch Justify. The effects of the text alignment can only be
seen if the text spans over two or more lines. In the Stretch
Justify mode, all the lines are filled completely.

5

Fontwork Character Spacing: Changes the character spacing
and kerning in the object. Select from the choices in the dropdown list. Choices are Very Tight, Tight, Normal, Loose, Very
Loose, and Custom..., which opens a small dialog where you can
specify a percentage.

6

Toggle Extrusion: changes a 2D Fontwork object into a 3D
object or a 3D object into a 2D object.
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Using the Formatting toolbar
You can customize the Fontwork object with several more attributes. Click on the object; the
Formatting toolbar changes to show the options for customizing the object. These choices are
the same as the ones for other drawing objects, described earlier in this chapter. See also the
Draw Guide for details.

Using menu options
You can use some of the choices on the Format menu to anchor, align, arrange, and group
selected Fontwork objects, wrap text around them, and flip them horizontally and vertically.
You can also right-click on a Fontwork object and choose many of the same options in the
context menu. The context menu also provides quick access to the Line, Area, and Position and
Size dialogs. On the Position and Size dialog, you can enter precise values for size and position.
For more information on all of these menu options, see the Draw Guide.

Using the 3D-Settings toolbar
If the selected Fontwork object is a 3-D object, you can also use the options on the 3D-Settings
toolbar. You can also change a 2-D Fontwork object into a 3-D object (or change a 3-D object into
a 2-D object) by clicking the Toggle Extrusion icon on the Fontwork toolbar. For more
information, see the Draw Guide.

Moving and resizing Fontwork objects
When you select a Fontwork object, eight colored squares (known as handles) appear around
the edge of the object, as shown below. You can drag these handles to resize the object.
A dark or colored dot also appears on the object. This dot may be in the same place as a handle,
or it may be somewhere else. If you hover the mouse pointer over this dot, the pointer changes
shape. You can drag the dot in different directions to distort the object.
Hovering the mouse pointer over other parts of the object turns the pointer into the usual symbol
for dragging the object to another part of the page.
For precise control of the location and size of the object, and to rotate the object, use the Position
and Size dialog.

Figure 354: Handles and distortion dot on Fontwork object
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Generating a barcode or QR code
Writer, Calc, Impress, and Draw can generate barcodes and QR codes. Barcodes are used for
many purposes. A QR code (short for Quick Response code) is a type of barcode. QR codes
often contain data that points to a website or application.
1) Choose Insert > Object > QR and Barcode on the Menu bar to open the QR and
Barcode Code dialog (Figure 355).
2) Fill in the URL/Text field, select an error correction factor (the complexity of the graphic
generated), the width of the margin around it, and the type of code, then click OK.
Figure 356 shows the code generated by the input in Figure 355. Figure 358 shows an ISBN
barcode generated by the input in Figure 357.
After the barcode or QR code has been generated, you can edit it by right-clicking in the code
and selecting Edit Barcode.

Figure 355: Generating a QR code

Figure 357: Generating a barcode

Figure 356: QR code example

Figure 358: Barcode
example (ISBN)
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Getting Started Guide 7.3

Chapter 12,
Creating HTML Files
Saving documents as HTML files

Introduction
HTML (Hypertext Markup Language) capabilities in LibreOffice make it possible to save and
export documents in HTML format.
This chapter describes how to do the following in Writer, Calc, Impress, and Draw:
•

Create hyperlinks within a document and to other documents such as web pages, PDFs,
and other files.

•

Save and export documents as HTML files.

•

Create, edit, and save HTML documents using Writer/Web.

When creating a document that you plan to deliver as an HTML file, you need to consider the
following:
•

In an HTML document, hyperlinks are active (clickable), but other cross-references
inserted by LibreOffice are not active links.

•

An object such as an image is saved as a separate file. However, if that object has been
placed in a frame (for example, with an associated caption), it is not saved and does not
appear in the HTML document; instead, the name of the frame appears.

Relative and absolute hyperlinks
Hyperlinks stored within a file can be either relative or absolute.
A relative hyperlink says, Here is how to get there starting from where you are now (meaning
from the folder in which your current document is saved), while an absolute hyperlink says, Here
is how to get there no matter where you start from.
An absolute link will stop working if the target is moved. A relative link will stop working if the start
and target locations change relative to each other. For instance, if you have two spreadsheets in
the same folder linked to each other and you move the entire folder to a new location, an
absolute hyperlink will break but a relative one will not.
To change the way that LibreOffice stores the hyperlinks in your file, select Tools > Options >
Load/Save > General on the Menu bar and choose if you want URLs (Universal Resource
Locators) saved relatively when referencing the file system, or the Internet, or both (Figure 359).
LibreOffice will always display an absolute hyperlink. It does this even when you have saved a
relative hyperlink. This ‘absolute’ target address will be updated if you move the file.

Note
HTML files containing links relative to the file system that will be uploaded to a web
server require the files be in a folder structure matching that of the web server.
Otherwise, the links will point to the wrong folder.

Tip
When you rest the mouse pointer on a hyperlink, a help tip displays the absolute
reference, because LibreOffice uses absolute path names internally. The complete
path and address can only be seen when you view the result of the HTML export (for
example, saving a spreadsheet as an HTML file), by loading the HTML file as text, or
by opening it with a text editor.
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Figure 359: Options for storing hyperlinks

Creating hyperlinks
When you type text (such as a website address or URL) that can be used as a hyperlink, and
then press the Spacebar or the Enter key, LibreOffice automatically creates the hyperlink and
applies formatting to the text (usually a color and underlining). If this does not happen, you can
enable this feature by going to the AutoCorrect dialog (Tools > AutoCorrect > AutoCorrect
Options in Writer or Tools > AutoCorrect Options in Calc, Draw, and Impress) and selecting
URL Recognition on the Options tab (Figure 360). If you do not want automatic hyperlink
creation, you can turn it off by deselecting the URL Recognition option.

Figure 360: AutoCorrect options - URL Recognition
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If you do not want LibreOffice to convert a specific URL to a hyperlink, you can go to Edit > Undo
on the Menu bar, or press Ctrl+Z immediately after the formatting has been applied, or place the
cursor in the hyperlink, right-click, and select Remove Hyperlink in the context menu.

Tip
To change the color of hyperlinks, go to Tools > Options > LibreOffice >
Application Colors, scroll to Unvisited links and/or Visited links, pick the new
colors, and click OK. Caution: This will change the color for all hyperlinks in all
components of LibreOffice; this may not be what you want.
In Writer and Calc (but not Draw or Impress), you can also change the Internet link
character style or define and apply new styles to selected links.

Using the Navigator
You can use the Navigator in Writer or Calc to insert a hyperlink to another part of the same
document or to another document.
1) Open the documents containing the items you want to cross-reference.
2) Click the Navigator icon on the Sidebar, select View > Navigator on the Menu bar, or
press F5.
3) Click the triangle to the right of the Drag Mode icon and select Insert as Hyperlink
(Figure 361). The Drag Mode icon changes shape depending on the type of insert that
was previously selected. The default icon for Drag Mode is to show the Hyperlink icon.

Figure 361: Inserting a hyperlink using the Navigator
4) Select the document in the drop-down list at the bottom of the Navigator that contains the
item that you want to link to.
5) In the Navigator list, select the item that you want to insert as a hyperlink.
6) Drag the item to where you want to insert the hyperlink in the document. The name of the
item is inserted in the document as an active hyperlink.
When using the Navigator to insert a hyperlink to an object such as a graphic, it is recommended
to have the hyperlink show a useful name, for example 2009 Sales Graph. You need to give such

Chapter 12, Creating HTML Files | 391

objects useful names instead of leaving them as the default names, for example Image6, or you
will have to edit the name of the resulting link using the Hyperlink dialog, as described below.
You can also use the Navigator to insert a hyperlink from one document (the source) to a specific
place in another document (the target). Open the Navigator in the target document and drag the
item to the position in the source document where you want the hyperlink to appear.

Using the Hyperlink dialog
You can use the Hyperlink dialog to insert a hyperlink and modify all hyperlinks.
1) Highlight the existing text you want to use as a link.
2) Click the Insert Hyperlink icon on the Standard toolbar or go to Insert > Hyperlink on
the Menu bar, or press Ctrl+K to open the Hyperlink dialog (Figure 362).

Figure 362: Hyperlink dialog showing details for Internet links
3) On the left side, select one of the four categories of hyperlink:
– Internet: the hyperlink points to a web address, normally starting with https://, or
an FTP (File Transfer Protocol) address, normally starting with ftp://.
– Mail: the hyperlink opens an email message that is pre-addressed to a particular
recipient.
– Document: the hyperlink points to another document or to another place in the
current document.
– New document: the hyperlink creates a new document.
4) The Hyperlink dialog changes depending on the type of hyperlink selected. Enter all
necessary details to create the hyperlink, as described below.
5) Click Apply or OK to create the hyperlink. Clicking Apply leaves the dialog open,
allowing you to keep editing the recently created hyperlink or create another hyperlink.
6) Click Close to close the Hyperlink dialog.
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The dialog changes according to the choice made for the hyperlink category in the left panel. A
full description of all the choices and their interactions is beyond the scope of this chapter. Here
is a summary of the most common choices.
•

For an Internet hyperlink (Figure 362), choose the type of hyperlink (Web or FTP), and
enter the required web address (URL). For an FTP address (Figure 363), you can also
define the login name and password if needed. Text is the words that become a hyperlink
in the document.

•

For a Mail hyperlink (Figure 364), specify the address of the receiver and the subject.

•

For a Document hyperlink (Figure 365), specify the document path (click the Open File
icon to open a file browser) or leave this blank to link to a target in the same document.
Optionally specify the target in the document (for example a specific slide). Click the
Target in Document icon to open the Target in Document dialog where you can select
the type of target; or, if you know the name of the target, you can type it into the box.

•

For a New Document hyperlink (Figure 366), specify whether to edit the newly created
document immediately (Edit now) or just create it (Edit later). Enter the file name and
select the type of document to create (text, spreadsheet, and so on). Click the Select
Path icon to open a file browser and choose where to store the file.

Figure 363: Hyperlink dialog showing details for an Internet FTP link

Figure 364: Hyperlink dialog showing details for a Mail link
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Figure 365: Hyperlink dialog showing details for a Document link

Figure 366: Hyperlink dialog showing details for a New Document link
The Further Settings section in the bottom part of the dialog is common to all the hyperlink
categories, although some choices are more relevant to some types of links.
•

Frame determines how the hyperlink will open in a Web browser.

•

Form specifies if the link is to be presented as text or as a button.

•

Text specifies the text that will be visible to the user. If you do not enter anything here,
LibreOffice uses the full URL or path as the link text. Note that if the link is relative and
you move the file, this text will not change, though the target will. [This setting is in the
upper part of the dialog for Internet links (Figure 362).]

•

Name is applicable to HTML documents. It specifies text that will be added as a NAME
attribute in the HTML code behind the hyperlink.

•

Events icon (next to the text box of Form) opens the Assign Macro dialog. Select a macro
to run when the link is clicked. See Chapter 13, Getting Started with Macros, for more
information.

Editing hyperlinks
To edit an existing link:
1) Click anywhere in the hyperlink text.
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2) Click the Insert Hyperlink icon on the Standard toolbar, or go to Edit > Hyperlink on the
Menu bar, or press Ctrl+K, or right-click and select Edit Hyperlink in the context menu.
3) In the Hyperlink dialog, make your changes and click Apply to save the changes. The
Hyperlink dialog remains open, allowing you to continue editing hyperlinks. Click Apply
after editing each hyperlink.
4) When you are finished editing hyperlinks, click Close.
The standard (default) behavior for activating hyperlinks within LibreOffice is to use Ctrl+click.
This behavior can be changed in Tools > Options > LibreOffice > Security > Options by
deselecting the option Ctrl-click required to open hyperlinks. If clicking in your links activates
them, check that page to see if the option has been deselected.

Removing hyperlinks
You can remove the link from hyperlink text and leave just the text by right-clicking on the link
and selecting Remove Hyperlink in the context menu. You may then need to re-apply some
formatting to match the text with the rest of your document.
To remove the link text or button from the document, select it and press the Delete key.

Saving and exporting documents as HTML files
The easiest way to create HTML documents in LibreOffice is to start with an existing document.
In Writer, you can get a good idea of how it will appear as a web page by using View > Web.
However, Web view does not show you which features will or will not be saved correctly in HTML
format. Refer to “Relative and absolute hyperlinks” on page 389 for what to consider before
creating a web page from a document.

Writer documents
Saving a Writer document as HTML
To save a Writer document as HTML, go to File > Save As on the Menu bar and select HTML
Document (Writer) as the file type in the Save As dialog. You may be prompted to confirm that
you wish to continue using the HTML format.
Saving a document as HTML produces a set of files. LibreOffice generates the image files and
the HTML file necessary to create an HTML page in a browser. The number of files generated by
the format conversion depends on the number of images and objects in the original text
document.

Tip
Use an empty folder to save your document as HTML file and images.
The file names are created following a simple rule summarized in Table 6.
Table 6: File types created when saving as HTML format
File

Contents

Myfile.html

The text contents, page layout, text attributes, meta
tags, and styles.

Myfile_html_[random number].gif

GIF images of visible contents of OLE objects.

Myfile_html_[random number].png,
jpg, or bmp

Images inserted in the text document as PNG, BMP,
or JPEG keep their original format.
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Note
The HTML transformation of the text document is limited by the HTML 4.0
Transitional specification. Text documents in office suites have a richer set of
resources that will not appear in HTML, for example page formatting. Do not expect
the same layout fidelity when saving a file in HTML format.
Saving as HTML may require more work directly on the HTML code to adjust the layout of the
web page. See “Creating, editing, and saving HTML files using Writer/Web” on page 401.

Exporting a single web page
Another way to create a HTML file is to use File > Export and specify XHTML (Extensible
Hypertext Markup Language) as the file type. LibreOffice will generate one XHTML 1.1 file per
text document. The image files are embedded in the XHTML file. XHTML files created by
exporting a text document in LibreOffice have significantly better layout rendering but fail to
render objects other than images.

Notes
Writer does not replace multiple spaces in the original document with the HTML code
for non-breaking spaces. If you want to have extra spaces in your HTML file or web
page, you need to insert non-breaking spaces in LibreOffice. To do this, press
Ctrl+Spacebar or Ctrl+Shift+Spacebar (depending on the operating system), instead
of just Spacebar.
The Tab character is not rendered on exporting to XHTML. Instead, use borderless
tables to position contents instead of the Tab character in a line. This also affects
bullet and number lists that insert by default a Tab character between the bullet or
number and the text. Use a list style where the Tab character is replaced by a space.
Objects different from usual image formats are not rendered in LibreOffice XHTML
output. These include drawings, spreadsheets, charts, and OLE object in general. To
render an OLE object in XHTML, first transform its visible contents into an image and
then replace the object in your document with the image.
The use of styles in the text document is strongly recommended for getting the best results when
exporting to HTML or XHTML.

Saving as a series of web pages
Writer can save a large document as a series of web pages (HTML files) with a table of contents
page.
1) Decide which headings in the document should start on a new page and make sure all
those headings have the same paragraph style (for example, Heading 1).
2) Go to File > Send > Create HTML Document on the Menu bar to open the Name and
Path of the HTML Document dialog (Figure 367).
3) Type the file name to save the pages under.
4) Specify which style indicates a new page by using the separated by drop-down list at the
bottom of the dialog (for example, Outline: Level 1).
5) Click Save to create the multi-page HTML document. The resulting HTML files conform to
the HTML 4.0 Transitional standard.
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Figure 367: Creating a series of web pages from one document

Calc spreadsheets
Calc can save files as HTML documents. Go to File > Save As on the Menu bar and select
HTML Document (Calc) as the file type in the Save As dialog.
If the file contains more than one sheet, the additional sheets will follow one another in the HTML
file. Links to each sheet will be placed at the top of the document.
Calc also allows the insertion of links directly into the spreadsheet using the Hyperlink dialog.
See “Creating hyperlinks” on page 390 for more information on hyperlinks.

Impress presentations
Impress presentations cannot be saved in HTML format, but have to be exported as HTML
documents. The HTML files created will then use the default settings that you have not changed.

Notes
Saving in HTML format does not retain animation and slide transitions.
You can click Create on the HTML Export dialog at any step in the following procedure.
1) Go to File > Export on the Menu bar and specify the file name and location of where to
save the web page version of your presentation.
2) Select HTML Document (Impress) as the file type and click Export to open the HTML
Export dialog / wizard (Figure 368).
3) On the Assign Design page, you can choose to create a new design and select or delete
an existing design. Select New design or Existing design and click Next >. If you have
not previously saved a web page design, the Existing design choice is not available.
– New design – creates a new design in the next pages of the wizard.
– Existing design – loads an existing design from the design list to use as a starting
point for the steps that follow. The list box displays all existing designs.
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– Delete Selected Design deletes the design from the list. If you delete a design, you
will only delete the design information. An export file will not be deleted by this action.

Figure 368: HTML Export dialog – Assign Design page
4) Specify the publication type for the web pages (Figure 369), then click Next >. The
publication type defines the basic settings for the intended export. The choices are:
– Standard HTML format – creates standard HTML pages from export pages.
– Standard HTML with frames – creates standard HTML pages with frames. The
exported page will be placed in the main frame and the frame to the left will display a
table of contents in the form of hyperlinks.
– Single-document HTML – creates a single file containing the text of the presentation,
but not the layout or images.
– Automatic – creates a default HTML presentation as a kiosk export in which the slides
are automatically advanced after a specified amount of time.
– WebCast – in a WebCast export, automatic scripts will be generated with Perl or ASP
support. This enables the speaker (for example, a speaker in a telephone conference
using a slide show on the Internet) to change the slides in the web browsers used by
the audience.
Options are also provided to create a title page and to display your notes. For more
information about the options on this page of the HTML Export dialog, click Help.
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Figure 369: HTML Export dialog – publication type and options page
5) Specify the options for saving images, monitor resolution, and effects used for the web
pages (Figure 370), then click Next >. The options on this page are as follows:
– Save Images As – determines the image format. You can also define the compression
value for the export.
– Monitor Resolution – defines the resolution for the target screen. Depending on the
selected resolution, the image will be displayed in a reduced size. You can specify a
reduction of up to 80% from the original size. When selecting a resolution, consider
what the majority of your viewers might be using. If you specify a high resolution, then
a viewer with a medium-resolution monitor will have to scroll sideways to see the
entire slide, which is probably not desirable.
– Effects – specifies whether sound files defined as an effect for slide transitions are
exported and whether any hidden slides are exported.
For more information on the options available for this page of the HTML Export dialog,
click Help to open the help pages.

Figure 370: HTML Export dialog – image format, monitor
resolution, and effects page
6) Specify the Information for the title page to be used with the web version of your
presentation (Figure 371). The title page normally contains the author’s name, an email
address, a home page address, and any additional information you want to include. This
page is only available if you have selected to create a title page (option only applicable to
the Standard HTML format and Standard HTML with frames publication types).
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Figure 371: HTML Export dialog – title page information page
7) Select Link to a copy of the original presentation if you want to create a hyperlink to
download a copy of the presentation file, and then click Next >.
8) Select the button style to be used for the web pages from the designs available (Figure
372) and then click Next >.
If you do not select a button style, LibreOffice will create a text navigator.
This page is not available if you have selected either Automatic or WebCast publication
type.

Figure 372: HTML Export dialog – button style page
9) Select the color scheme to be used for the web pages (Figure 373), including colors for
text, links, and background. This page is not available if you have selected either
Automatic or WebCast publication type.
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Figure 373: HTML Export dialog – color scheme page
10) Click Create.
11) If you have created a new design for your web pages, a small Name HTML design dialog
opens. Type a name for the design and click OK.

Note
Depending on the size of your presentation and the number of graphics it contains,
the HTML export function creates several HTML, JPG, and GIF files. It is
recommended to create a folder to hold all the files created for the web version of
your presentation. If you simply save to your desktop and not in a specific folder,
these separate HTML and graphics files will be placed all over your desktop.

Draw documents
Draw documents cannot be saved in HTML format, but have to be exported as HTML
documents. Exporting drawings from Draw is similar to exporting a presentation from Impress.
Go to File > Export and select HTML Document (Draw) as the file type, then follow the
procedure above for exporting Impress presentations.

Creating, editing, and saving HTML files using Writer/Web
LibreOffice Writer can create, edit, and save files in HTML format using a configuration called
Writer/Web.

Writer/Web display modes
In addition to the Normal and Web display modes for editing (Figure 374), Writer/Web has a third
editing mode called HTML Source mode (Figure 375). You can select this view when creating a
new HTML document or after opening an existing one. With the HTML Source mode, you can
directly edit HTML tags such as <p>, <ul>, <table>, and so on to compose web page elements.
In that mode you must be familiar with the HTML markup language.
You normally add content to an HTML document using the Web display mode, because it will
render the contents as if displayed in a browser. Use the HTML Source editing mode to tweak the
formatting.
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Note
Because HTML markup language has fewer formatting possibilities than a text
document in OpenDocument Format, Writer/Web cannot provide all formatting
features for HTML documents and some formatting dialogs have fewer options
available. For example, a HTML paragraph has no tab settings.

Figure 374: Web display mode for Writer/Web

Figure 375: HTML Source display mode

Creating and editing a HTML document
To create a HTML document, choose File > New > HTML Document. Writer/Web opens a blank
document in Web display mode. You can now add content to the document by typing or pasting
text, images, tables, and other objects. Use all the Writer/Web formatting resources including
styles to format the content. When you have finished, save the document with the HTML file type.
If you need to add HTML content directly into the document, enter HTML Source editing mode by
clicking the HTML Source icon on the Standard toolbar, or choosing View > HTML Source on
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the Menu bar. If you haven’t saved a new document, Writer/Web will ask you to do so before it
switches to HTML Source editing mode. In that mode, Writer/Web turns into a notepad-like text
editor (Figure 375).

Note
The HTML markup content generated by Writer/Web is limited to the production of a
displayable document in a web browser. It does not consider other components of a
website such as external cascading style sheets (CSS), external JavaScript, or other
script languages. Use the HTML Source mode to manually insert links to these
external components into the page.

Checking a web page in a browser
It is important to check your web pages (HTML documents) in a web browser such as Mozilla
Firefox, Google Chrome, Microsoft Edge, or Safari. Not all browsers render HTML files the same
way, so if possible, check the contents in several browsers.
To make LibreOffice open your default web browser and display the contents of an HTML
document, go to File > Preview in Web Browser on the Menu bar, or click the Preview in Web
Browser icon on the Standard toolbar. You can also open any web browser and then open the
HTML file in it.
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Getting Started Guide 7.3

Chapter 13,
Getting Started with Macros
Using the Macro Recorder … and Beyond

Introduction
A macro is a set of commands or keystrokes that are stored for later use. An example of a simple
macro is one that enters your address into an open document. You can use macros to automate
both simple and complex tasks. Macros are very useful when you have to repeat the same task
in the same way.
The simplest way to create a macro is to record a series of actions through LibreOffice’s user
interface. LibreOffice saves recorded macros using the open source LibreOffice Basic scripting
language, which is an implementation of the well-known BASIC programming language. Such
macros can be edited and enhanced after recording using the built-in LibreOffice Basic
Integrated Development Environment (IDE).
The most powerful macros in LibreOffice are created by writing code using one of the four
supported scripting languages (LibreOffice Basic, Python, JavaScript, and BeanShell). This
chapter provides an overview of LibreOffice’s macro facilities, mostly focused on its default macro
scripting language, LibreOffice Basic. Some introductory examples are included for the
BeanShell, JavaScript, and Python scripting languages. However, an in-depth discussion of how
to use these languages for scripting is beyond the scope of this chapter.

Your first macros
Adding a macro
The first step in learning macro programming is to find and use existing macros. This section
assumes that you have a macro that you want to use, which you may have found in a book or on
the internet. For this example, the macro in Listing 1 is used. You should create a library and
module to contain your macro; see “Macro organization” on page 419 for more information.
Listing 1: Simple macro that says hello
Sub HelloMacro
Print "Hello"
End Sub

Use the following steps to create a library that will contain your macro:
1) Open any LibreOffice application.
2) Go to Tools > Macros > Organize Macros > Basic to open the Basic Macros dialog
(Figure 376).
3) Click Organizer to open the Basic Macro Organizer dialog (Figure 377) and select the
Libraries tab.
4) Set the Location drop-down to My Macros & Dialogs, which is the default location.
5) Click New to open the New Library dialog (not shown here).
6) Enter a library name, for example TestLibrary, and click OK.
7) On the Basic Macro Organizer dialog, select the Modules tab (Figure 378).
8) In the Module list, expand My Macros and select your library (in the example,
TestLibrary). A module named Module1 already exists and can contain your macro. If you
wish, you can click New to create another module in the library.
9) Select Module1, or the new module that you created, and click Edit to open the Integrated
Development Environment (IDE) (Figure 379). The IDE is a text editor and associated
facilities that are built into LibreOffice and allow you to create, edit, run, and debug
macros.
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Figure 376: Basic Macros dialog

Figure 377: LibreOffice Basic Macro Organizer dialog, Libraries tab
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Figure 378: Basic Macro Organizer dialog, Modules tab

Figure 379: LibreOffice Basic IDE (Integrated Development Environment) window
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10) When a new module is created, it contains a comment and an empty macro named
Main, which currently does nothing.
11) Add the new macro either before Sub Main or after End Sub. Listing 2 shows the new
macro added before Sub Main.
Listing 2: Module1 after adding the new macro
REM

*****

BASIC

*****

Sub HelloMacro
Print "Hello"
End Sub
Sub Main
End Sub

Tip
If you prefer, you can remove the Sub Main … End Sub code from the Module and
leave only the HelloMacro subroutine.
12) (Optional) To check if the macro is written as expected by the programming language,
click the Compile icon on the Macro toolbar.
13) Double-click the HelloMacro subroutine in the Object Catalog window under TestLibrary
> Module 1 and click the Run icon on the Macro toolbar, or press the F5 key, to run the
HelloMacro subroutine in the module. A small dialog will open with the word “Hello”
displayed (see below).

14) Click OK to close this small dialog.
15) If no subroutine or function is selected, a dialog like the one in Figure 380 will open. Then
select the macro and click Run to execute it.
16) To select and run any macro in the module, click the Select Macro icon on the Standard
toolbar or go to Tools > Macros > Organize Macros > Basic.
17) Select a macro and then click Run.
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Figure 380: Dialog to select and run a macro

Recording a macro
When you record a macro in LibreOffice, you are actually recording the steps to perform a certain
task using programming language. For example, consider that you have to repeatedly enter the
same information into a document. You can copy this information after it has been entered into
the document for the first time, then paste the information into the document each time you want
to use it. However, if something else is copied to the clipboard, the contents of the clipboard are
changed. This means that you have to re-copy this piece of information again to later paste it into
the document. To overcome this problem, you can create a macro that enters this piece of
information without having to copy it every time you need it.

Note
For some cases when you want to repeatedly enter information into a document, it
may be more convenient to create an AutoText. See Chapter 2, Working with Text:
Basics, in the Writer Guide for more information.
Make sure macro recording is enabled by going to Tools > Options > LibreOffice > Advanced
and selecting the option Enable macro recording under Optional Features. By default, this
feature is turned off in LibreOffice.
1) Go to Tools > Macros > Record Macro to start recording a macro. A small dialog with a
Stop Recording button is displayed indicating that LibreOffice is recording a macro.
2) Type the desired text you want to be entered when this macro is run. As an example, type
your name.
3) Click Stop Recording on the small dialog. This will cause Basic Macros dialog to open
(similar to Figure 376 on page 406, but with different action buttons).
4) Open the library container My Macros.
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5) Find the library named Standard in My Macros. Note that every library container has a
library named Standard.
6) Select the Standard library and then choose an existing module in which to save the
macro. Alternatively you can click New Module to create a new module to contain the
newly recorded macro.
7) In the Macro Name text box at the top left section of the dialog, type a name for the
macro you have just recorded, for example EnterMyName.
8) Click Save to save the macro and close the Basic Macros dialog.
If you followed all of the above steps, a macro named EnterMyName will have been created
inside the selected module.

Note
Whenever you create a new module in LibreOffice, a subroutine named Main is
automatically added to the module.

Running a macro
1) Go to Tools > Macros > Run Macro to open the Macro Selector dialog (Figure 381).
2) For example, select your newly created macro EnterMyName and click Run.
3) Alternatively, go to Tools > Macros > Organize Macros > Basic to open the Basic
Macros dialog (Figure 376), select your macro and click Run.

Figure 381: Use the Macro Selector dialog to select and run an existing macro
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Viewing and editing macros
To view and/or edit the macro that you created:
1) Go to Tools > Macros > Organize Macros > Basic to open the Basic Macros dialog.
2) Select your new macro EnterMyName and click Edit. The Basic IDE will open and the
macro EnterMyName will be shown as in Listing 3.
This first macro is not complicated. A little explanation will significantly help you in understanding
macros. The discussion starts with first line of the macro and describes features through the
whole listing.
Listing 3: Code recorded for the EnterMyname macro
sub EnterMyName
rem ------------------------------------------------------------rem define variables
dim document
as object
dim dispatcher as object
rem ------------------------------------------------------------rem get access to the document
document
= ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")
rem ------------------------------------------------------------dim args1(0) as new com.sun.star.beans.PropertyValue
args1(0).Name = "Text"
args1(0).Value = "Your name"
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args1())
end sub

Commenting with REM
All comments in Basic macro coding begin with REM, which stands for remark. All text after REM
on the same line is ignored by the Basic interpreter when the macro is run.

Tip
As a shortcut, you can use the single quote character (') to start a comment.
LibreOffice Basic is not case-sensitive for keywords, so REM, Rem, and rem can all start a
comment. If you use symbolic constants defined by the Application Programming Interface (API),
it is safer to assume that the names are case-sensitive. Symbolic constants are an advanced
topic not covered by this user guide and are not required when using the macro recorder in
LibreOffice.

Defining subroutines with SUB
Individual macros are stored in subroutines and these subroutines begin with the keyword SUB.
The end of a subroutine is indicated by the words END SUB. The code starts by defining the
subroutine named Main, which is empty and does nothing. Note that the code in Listing 3 for the
EnterMyName macro starts with the keyword SUB and ends with END SUB.
There are advanced topics that are beyond the scope of this user guide, but knowing about them
might be of interest:
•

You can write subroutines that accept input values to be used inside the macro. These
values are called arguments. This can only be done when you create subroutines from
scratch. Recorded macros in LibreOffice do not accept arguments.
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•

Another kind of subroutine is called a function, which is a subroutine that can return a
value as a result of its work. Functions are defined by the keyword FUNCTION at the
beginning. Recorded macros in LibreOffice create subroutines only.

Defining variables using DIM
You can write information on a piece of paper so that you can look at it later. A variable, like a
piece of paper, contains information that can be changed and read. The DIM keyword originally
stood for Dimension and was used to define the dimensions of an array. The DIM statement used
in the EnterMyName macro is similar to setting aside a piece of paper to be used to store a
message or note.
In the EnterMyName macro, the variables document and dispatcher are defined as the type
object. Other common variable types include string, integer, and date. A third variable, named
args1, is an array of property values. A variable of type array allows a single variable to contain
multiple values, similar to storing multiple pages in a single book. Values in an array are usually
numbered starting from zero. The number in the parentheses indicates the highest usable
number to access a storage location. In this example, there is only one value, and it is numbered
zero.

Explaining macro code
The following is an explanation of the code used in the EnterMyName macro. You may not
understand all the details, but the explanation of each line of code may give you some idea of
how a macro works.
sub EnterMyName

Defines the start of the EnterMyName macro.
dim document as object

Defines document as an object variable. Objects are a specific variable type with multiple
fields (sometimes they are called properties) and actions (also they are called methods).
The fields can be perceived like variables (including an object) and actions like subroutines
which allow us to operate with the object.

Note
Sometimes the word service is used. A service is supplied by a type of object which
are distinguished in order to point out how they are used.
dim dispatcher as object

Defines dispatcher as an object variable.
document = ThisComponent.CurrentController.Frame

ThisComponent is a runtime object created by LibreOffice that refers to the current
document.
CurrentController is a property referring to a service that controls the document. For
example, when you type, it is the current controller that takes note of what you type.
CurrentController then dispatches the changes to the document frame.
Frame is a controller property that returns the main frame for a document. Therefore, the
variable named document refers to a document’s frame, which receives dispatched
commands.
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dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

Most tasks in LibreOffice are accomplished by dispatching a command. LibreOffice
includes a DispatchHelper service, which provides an easy way to dispatch a URL
using one call instead of multiple ones and does most of the work when using dispatches in
macros. The method CreateUnoService accepts the name of a service and it tries to
create an instance of that service. On completion, the dispatcher variable contains a
reference to a DispatchHelper.
dim args1(0) as new com.sun.star.beans.PropertyValue

Declares the args1 array of properties. Each property has a name and a value. In other
words, it is a name/value pair. The created array has one property at index zero.
The com.sun.star.beans.PropertyValue expression is a Universal Network Objects
(UNO) structure. Structures are special variable types that contain other variables united by
logical basis. They can be convenient to operate with sets of heterogeneous information
that should be treated as a single whole. An explanation of UNO and user structures goes
far beyond the scope of this book. For more information on creating and using structures,
see the LibreOffice Help system and other Basic guides.
args1(0).Name = "Text"
args1(0).Value = "Your name"

Gives the property the name “Text” and the value “Your name”, which is the text that is
inserted when the macro is run.
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args1())

The dispatch helper sends a dispatch to the document frame (stored in the variable
document) with the command .uno:InsertText. The next two arguments, frame name
and search flags, are beyond the scope of this book. The last argument is the array of
property values to be used while executing the command InsertText.
In other words, this line of code executes the UNO command .uno:InsertText passing
the value “Your Name” as the “Text” parameter.
end sub

The last line of the code ends the subroutine.

Creating a macro
When creating a macro, it is important to ask two questions before recording:
1) Can the task be written as a simple set of commands?
2) Can the steps be arranged so that the last command leaves the cursor ready for the next
command or entering text or data into the document?

A more complex example of a macro
A common task is to copy rows and columns of data from a website and format them as a table in
a text document as follows:
1) Copy the data from the website to the clipboard.
2) To avoid strange formatting and fonts, paste the text into a Writer document as
unformatted text.
3) Reformat the text with tabs between columns so that it can be converted into a table
using Table > Convert > Text to Table.
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With the two questions above in mind, inspect the text to see if a macro can be recorded to
format the text. As an example of copied data, consider the text copied from the API website
describing the FontWeight constants (Figure 382). The first column in this example indicates a
constant name and each name is followed by a space and a tab, and each line has two trailing
spaces.
DONTKNOW

The font weight is not specified/known.

THIN

specifies a 50% font weight.

ULTRALIGHT

specifies a 60% font weight.

LIGHT

specifies a 75% font weight.

SEMILIGHT

specifies a 90% font weight.

NORMAL

specifies a normal font weight.

SEMIBOLD

specifies a 110% font weight.

BOLD

specifies a 150% font weight.

ULTRABOLD

specifies a 175% font weight.

BLACK

specifies a 200% font weight.

Figure 382: Example of copied data
Suppose you want the first column in the table to contain the numeric value of the font weight,
the second column the constant name, and the third column the text description. This task can be
accomplished easily for every row except for DONTKNOW and NORMAL, which do not contain a
numeric value.
Below are the steps to record this macro using keystrokes and assuming that the cursor is at the
beginning of the line with the text “THIN”.
1) Make sure macro recording is enabled by going to Tools > Options > LibreOffice >
Advanced and selecting the option Enable macro recording. By default, this feature is
turned off when LibreOffice is installed on your computer.
2) Go to Tools > Macros > Record Macro to start recording.
3) Press Ctrl+Right Arrow to move the cursor to the start of the word “specifies”.
4) Press Backspace twice to remove the tab and the space.
5) Press Tab to add the tab without the space after the constant name.
6) Press Delete to delete the lower case “s” and then press Shift+S to add an upper case
“S”.
7) Press Ctrl+Right Arrow twice to move the cursor to the start of the number.
8) Press Ctrl+Shift+Right Arrow to select and move the cursor before the % sign.
9) Press Ctrl+C to copy the selected text to the clipboard.
10) Press End to move the cursor to the end of the line.
11) Press Backspace twice to remove the two trailing spaces.
12) Press Home to move the cursor to the start of the line.
13) Press Ctrl+V to paste the selected number to the start of the line.
14) Pasting the value also pasted an extra space, so press Backspace to remove the extra
space.
15) Press Tab to insert a tab between the number and the name.
16) Press Home to move to the start of the line.
17) Press Down Arrow to move to the next line.
18) Stop recording the macro and save the macro, see “Recording a macro” on page 409.
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It takes much longer to read and write the steps above than to actually record the macro. Work
slowly and think about the steps as you do them. With practice you will learn how to organize the
steps to create macros that can be used to automate repetitive tasks.
The generated macro code in Listing 4 has been modified to contain the step numbers in the
comments to match the steps discussed above.
Listing 4: Copying numeric value to start of the column
sub CopyNumToCol1
rem ------------------------------------------------------------rem define variables
dim document
as object
dim dispatcher as object
rem ------------------------------------------------------------rem get access to the document
document
= ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")
rem (3) Press Ctrl+Right Arrow to move the cursor to the start of “specifies”.
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())
rem (4) Press Backspace twice to remove the tab and the space.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem ------------------------------------------------------------dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem (5) Press Tab to add the tab without the space after the constant name.
dim args4(0) as new com.sun.star.beans.PropertyValue
args4(0).Name = "Text"
args4(0).Value = CHR$(9)
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args4())
rem (6) Press Delete to delete the lower case s ....
dispatcher.executeDispatch(document, ".uno:Delete", "", 0, Array())
rem (6) ... and then press Shift+S to add an upper case S.
dim args6(0) as new com.sun.star.beans.PropertyValue
args6(0).Name = "Text"
args6(0).Value = "S"
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args6())
rem (7) Press Ctrl+Right Arrow twice to move the cursor to the number.
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())
rem ------------------------------------------------------------dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())
rem (8) Press Ctrl+Shift+Right Arrow to select the number.
dispatcher.executeDispatch(document, ".uno:WordRightSel", "", 0, Array())
rem (9) Press Ctrl+C to copy the selected text to the clipboard.
dispatcher.executeDispatch(document, ".uno:Copy", "", 0, Array())
rem (10) Press End to move the cursor to the end of the line.
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dispatcher.executeDispatch(document, ".uno:GoToEndOfLine", "", 0, Array())
rem (11) Press Backspace twice to remove the two trailing spaces.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem ------------------------------------------------------------dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem (12) Press Home to move the cursor to the start of the line.
dispatcher.executeDispatch(document, ".uno:GoToStartOfLine", "", 0, Array())
rem (13) Press Ctrl+V to paste the selected number to the start of the line.
dispatcher.executeDispatch(document, ".uno:Paste", "", 0, Array())
rem (14) Press Backspace to remove the extra space.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem (15) Press Tab to insert a tab between the number and the name.
dim args17(0) as new com.sun.star.beans.PropertyValue
args17(0).Name = "Text"
args17(0).Value = CHR$(9)
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args17())
rem (16) Press Home to move to the start of the line.
dispatcher.executeDispatch(document, ".uno:GoToStartOfLine", "", 0, Array())
rem (17) Press Down Arrow to move to the next line.
dim args19(1) as new com.sun.star.beans.PropertyValue
args19(0).Name = "Count"
args19(0).Value = 1
args19(1).Name = "Select"
args19(1).Value = false
dispatcher.executeDispatch(document, ".uno:GoDown", "", 0, args19())
end sub

To run this macro, first place the cursor at the beginning of the line to which you want to apply the
recorded steps. Then go to Tools > Macros > Run Macro, select the CopyNumToCol1 macro
and click Run. Figure 383 shows the original line and the resulting line after applying the macro.

Figure 383: Result of applying the recorded macro
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Keep in mind that the steps described above will only work properly if the line follows the format
we assumed while creating the macro. If you run this macro on the “DONTKNOW” and
“NORMAL” lines the results will not be as expected because these two lines have different
formats. Figure 384 shows the original line starting with “DONTKNOW”.

Figure 384: Result of using the macro in a line with a different structure

Running a macro quickly
It is not convenient to repeatedly run macros using Tools > Macros > Run Macro. If you
frequently need to use a certain macro, you can assign a keyboard shortcut to quickly run it. Next
are the steps to assign the shortcut Ctrl+K to the CopyNumToCol1 macro.
1) Go to Tools > Customize. This will open the Customize dialog.
2) Select the Keyboard tab. In the Shortcut Keys section, select the Ctrl+K shortcut.
3) In the Category section, select LibreOffice macros. Navigate this section and select the
CopyNumToCol1 macro.
4) Now click the Modify button to assign the Ctrl+K shortcut to the CopyNumToCol1 macro.
5) Click OK to close the Customize dialog.
Now you can run the CopyNumToCol1 macro using the Ctrl+K shortcut. This is very fast and easy
to configure after you get used to the macro workflow. Figure 385 illustrates the steps involved.

Figure 385: Assigning a shortcut to a macro
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Limitations of the macro recorder
The Macro Recorder has some limitations, which means that some actions may not be recorded.
A deeper knowledge of LibreOffice internal workings helps to understand how and why the macro
recorder will work. The main cause of these limitations is the dispatch framework and its
relationship to the macro recorder.

Dispatch framework
The purpose of the dispatch framework is to provide uniform access to components (documents)
for commands that usually correspond to menu items. Using File > Save, the shortcut keys
Ctrl+S, or clicking the Save icon on the Standard toolbar are all commands that are translated
into the same “dispatch command”.
The dispatch framework can also be used to send “commands” back to the user interface (UI).
For example, after saving a new document, the list of recent files is updated.
A dispatch command is text, for example .uno:InsertObject or .uno:GoToStartOfLine.
The command is sent to the document frame and this passes on the command until an object is
found that can handle the command.

How the macro recorder uses the dispatch framework
The macro recorder records the generated dispatches. The recorder is a relatively simple tool to
use and the same commands that are issued are recorded for later use. The problem is that not
all dispatched commands are complete. For example, inserting an object generates the following
code:
dispatcher.executeDispatch(document, ".uno:InsertObject", "", 0, Array())

It is not possible to specify what kind of object to create or insert. If an object is inserted from a
file, you cannot specify which file to insert.
If while recording a macro you use Tools > Options to open and modify configuration items, the
generated macro does not record any configuration changes. In fact, the generated code is
commented so it will not even be run.
rem dispatcher.executeDispatch(document, ".uno:OptionsTreeDialog", "", 0,
Array())

If a dialog is opened, a command to open the dialog is likely to be generated. Any work done
inside the dialog is not usually recorded. Examples of this include macro organization dialogs,
inserting special characters, and similar types of dialogs. Other possible problems using the
macro recorder include things such as inserting a formula, setting user data, setting filters in
Calc, actions in database forms, and exporting a document to an encrypted PDF file. You never
know for certain what will work unless you try it. For example, the actions from the search dialog
are properly captured.

Other options
When the macro recorder is not able to solve a specific problem, the usual solution is to write
code using the LibreOffice objects. Unfortunately, there is a steep learning curve for these
LibreOffice objects. It is usually best to start with simple examples and then increase the scope of
macros as you learn more. Learning to read generated macros is a good place to start.
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Macro organization
In LibreOffice, macros are grouped in modules, modules are grouped in libraries, and libraries
are grouped in library containers. A library is usually used as a major grouping for either an entire
category of macros, or for an entire application. Modules usually split functionality, such as user
interaction and calculations. Individual macros are subroutines and functions. Figure 386 shows
an example of the hierarchical structure of macro libraries in LibreOffice.

Figure 386: Macro Library hierarchy
Go to Tools > Macros > Organize Macros > Basic to open the Basic Macros dialog (Figure 376
on page 406). All available library containers are shown in the Macro From list. Every document
is a library container, capable of containing multiple libraries. The application itself acts as two
library containers, one container for macros distributed with LibreOffice called LibreOffice
Macros, and one container for personal macros called My Macros.
The LibreOffice Macros are stored with the application runtime code, which may not be editable
to you unless you are an administrator. This helps protect these macros because they should not
be changed and you should not store your own macros in the LibreOffice Macros container.
Unless your macros are applicable to a single document, and only to a single document, your
macros will probably be stored in the My Macros container. The My Macros container is stored in
your user area or home directory.
If a macro is contained in a document, then a recorded macro will attempt to work on that
document, because it primarily uses ThisComponent for its actions.
Every library container contains a library named Standard. It is better to create your own libraries
with meaningful names than to use the Standard library. Not only are meaningful names easier to
manage, but they can also be imported into other library containers whereas the Standard library
cannot.

Caution
LibreOffice allows you to import libraries into a library container, but it will not allow
you to overwrite the library named Standard. Therefore, if you store your macros in
the Standard library, you cannot import them into another library container.
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Just as it makes good sense to give your libraries meaningful names, it is prudent to use
meaningful names for your modules. By default, LibreOffice uses names such as Module1,
Module2, and so on.
As you create your macros, you must decide where to store them. Storing a macro in a document
is useful if the document will be shared and you want the macro to be included with the
document. Macros stored in the application library container named My Macros, however, are
globally available to all documents.
Macros are not available until the library that contains them is loaded. However, in contrast to
other libraries, the Standard and Template libraries are automatically loaded. A loaded library is
displayed differently from a library that is not loaded. To load the library and the modules it
contains, double-click on the library.

Where are macros stored?
LibreOffice stores user-specific data in a folder inside the user’s home directory. The location is
operating system specific. Go to Tools > Options > LibreOffice > Paths to view where other
configuration data are stored. User macros written in Basic are stored in LibreOffice\4\
user\basic. Each library is stored in its own directory inside the basic directory.
For casual use, it is not necessary to understand where macros are stored. If you know where
they are stored, however, you can create a backup, share your macros, or inspect them if there is
an error.

Exporting macros
The LibreOffice Basic Macro Organizer dialog allows you to export macro libraries so that they
can be reused and shared with other people. To export a macro library:
1) Go to Tools > Macros > Organize Macros > Basic and the click the Organizer button.
2) Click the Libraries tab and choose which library you want to export.
3) Click Export and then select Export as BASIC Library (note that you cannot export the
Standard library).
4) Choose where you want to save the library and click Save.
When a library is exported, LibreOffice creates a folder containing all files related to the library.
Figure 387 shows an example of how a library named TestLibrary with a single module called
Module1 would be exported.

Figure 387: Folder containing the exported library

Importing macros
The LibreOffice Basic Macro Organizer dialog allows you to import macro libraries into your
document as well as creating, deleting, and renaming libraries, modules, and dialogs.
1) On the Libraries tab, select the library container to use and then click Import to import
macro libraries.
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2) Navigate to the directory containing the library to import (Figure 388). There are usually
two files from which to choose, dialog.xlb and script.xlb. It does not matter which
of these two files you select; both will be imported. Macros can be stored in libraries
inside LibreOffice documents. Select a document rather than a directory on disk to import
libraries contained in a document.

Figure 388: Navigating to a macro library
3) Select a file and click Open to continue and open the Import Libraries dialog (Figure 389).

Figure 389: Choose library import options
4) Select the following options for importing libraries:
– If no options are selected, the library is copied to your user macro directory. However,
if the library you are importing has the same name and you are importing into the
same location, it will not be copied.
– Select Insert as reference (read-only) if you want to use the library as reference, but
not import it into the document. When a library is used as a reference, it remains in its
current location and is fully functional, but cannot be modified in the Basic IDE.
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– Select Replace existing libraries if the library you want to import has the same name
and you want to replace the existing library.
5) Click OK to import the macro library you selected.

Note
You cannot export/import the library named Standard.

Tip
On Linux, LibreOffice-specific files are stored in the user’s home directory inside the
.config folder. Directories and files with names beginning with a dot may be hidden
and not shown in a normal file selection dialog. When using LibreOffice dialogs, rather
than the operating system’s specific dialogs, type the name of the desired directory in
the Name field.

Downloading macros to import
You can find macros created by the community to download from the internet. Some macros are
contained in documents, some as regular files that you need to import, and some are published
as text and need to be copied and pasted into the Basic IDE. See “Adding a macro” on page 405
on how to add macros to your macro library and “Viewing and editing macros” on page 411 on
how to edit macros using the Basic IDE.
Some macros are available as free downloads on the Internet (see Table 7).
Table 7. Places to find macro examples
Location

Description

https://www.pitonyak.org/oo.php

Reference materials regarding macros.

https://www.pitonyak.org/database/

Reference materials regarding database
macros.

https://wiki.documentfoundation.org/
Macros

Lots of links to macros.

https://forum.openoffice.org/en/forum/

Forums, with many examples and help.

How to run a macro
Although you can use Tools > Macros > Run to run all macros, this is not efficient for frequently
used macros. LibreOffice offers many ways for you to quickly run your macros.
In addition to assigning a shortcut to macros, as seen in “Running a macro” on page 410, you
can also link macros to a toolbar icon, menu item, event, or a button embedded in a document.
When choosing a method, it is also good to ask questions such as:
•

Should the macro be available for only one document or globally for all documents?

•

Is the macro for a specific document type, such as a Calc document?

•

How frequently will the macro be used?

The answers will determine where to store the macro and how to make it available. For example,
you will probably not add a rarely used macro to a toolbar. To help determine your choices, see
Table 8.
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Table 8. Where to store a macro
Where to place
the macro

For all LibreOffice
applications

For a specific LO
application

For a single
document

Toolbar

No

Yes

Yes

Menu

No

Yes

Yes

Shortcut

Yes

Yes

No

Event

Yes

No

Yes

Toolbars, menu items, and keyboard shortcuts
To add a menu item, keyboard shortcut, or toolbar icon that calls a macro, use the Customize
dialog, which contains pages to configure menus, keyboard shortcuts, toolbars, and events. To
open this dialog, go to Tools > Customize. Use of the Menus, Toolbars, Context Menus, and
Keyboard tabs are covered in Chapter 14, Customizing LibreOffice.

Events
Whenever something happens in LibreOffice, it is called an event. For example, opening a
document, changing status of modified, or moving the mouse cursor are all events. LibreOffice
allows events to trigger the execution of a macro; the macro is then called an event handler. Full
coverage of event handlers is well beyond the scope of this chapter, but a little knowledge can
accomplish much.

Caution
Be careful when you configure an event handler. For example, assume that you write
an event handler that is called every time that a document is modified, but you make
a mistake so the event is not properly handled. One possible result is that your event
handler will force you to kill LibreOffice.
1) Go to Tools > Customize to open the Customize dialog and select the Events tab (Figure
390). The events in the Customize dialog are related to the entire application and specific
documents.
2) In the Save In drop-down, select LibreOffice, or a specific document from the menu to
save your event.
3) A common use is to assign the Open Document event to call a specific macro. The macro
then performs certain setup tasks for the document. Select the desired event and click
Macro to open the Macro Selector dialog (similar to Figure 381 on page 410 but with
different action buttons).
4) Select the desired macro and click OK to assign the macro to the event. The Events tab
will show that the event has been assigned to a macro.
Many objects in a document can be set to call macros when events occur. The most common
use is to add a control, such as a button, into a document. Even double-clicking on a graphic
opens a dialog with a Macros tab that allows you to assign a macro to an event.
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Figure 390: Events tab in Customize dialog

Using extensions
An extension is a package that can be installed into LibreOffice to add new functionality.
Extensions can be written in almost any programming language and may be simple or
sophisticated. Extensions can be grouped into types, for example:
•

Calc add-ins, which provide new functionality for Calc, including new functions that act
like normal built-in functions.

•

New components and functionality, which normally include some level of User Interface
(UI) integration such as new menus or toolbars.

•

Chart add-ins with new chart types.

•

Linguistic components such as spelling checkers.

•

Document templates and images.

Although individual extensions can be found in several places, there is currently an extension
repository at: https://extensions.libreoffice.org/ and some documentation at
https://libreplanet.org/wiki/Group:OpenOfficeExtensions/List.
For more about obtaining and installing extensions, see Chapter 14, Customizing LibreOffice.
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Writing macros without the recorder
The examples covered so far in this chapter were created using the macro recorder and the
dispatcher. You can also write macros that directly access the objects that comprise LibreOffice if
you are confident in writing computer code. In other words, you can create a macro that directly
manipulates a document using more advanced programming logic.
Directly manipulating LibreOffice internal objects is an advanced topic that is beyond the scope of
this chapter. A simple example, however, demonstrates how this works.

An example of a macro for Writer
The sample code in Listing 5 is a simple example of a macro created without the recorder that
adds the string “Hello” at the end of a Writer document.
To add this macro to a library, follow the steps below:
1) Go to Tools > Macros > Organize Macros > Basic.
2) In My Macros, navigate to the library where you want the macro to be created. In this
example, consider the library TestLibrary.
3) Select one of the modules already available in the library, for example Module1. If you
want to create a new module, click Organizer and then add the new module.
4) With the module selected, click Edit. This will open the Basic IDE window and show the
code for the macros implemented in the selected module.
5) Enter the code in Listing 5 into the module.
Listing 5: Append the text “Hello” at the end of to the current document
Sub AppendHello
Dim oDoc
Dim sTextService$
Dim oCurs
REM ThisComponent refers to the currently active document.
oDoc = ThisComponent
REM Verify that this is a text document.
sTextService = "com.sun.star.text.TextDocument"
If NOT oDoc.supportsService(sTextService) Then
MsgBox "This macro only works with a text document"
Exit Sub
End If
REM Get the view cursor from the current controller.
oCurs = oDoc.currentController.getViewCursor()
REM Move the cursor to the end of the document.
oCurs.gotoEnd(False)
REM Insert text "Hello" at the end of the document.
oCurs.Text.insertString(oCurs, "Hello", False)
End Sub

An example of a macro for Calc
One powerful way to extend the functionalities of LibreOffice Calc is to write macros that
automate repetitive tasks. You can use the Basic language to write macros that can do tasks
ranging from simple cell handling and formatting to advanced data manipulation.
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As a simple example, consider you want to analyze a range of cells to determine if all values are
between 0 and 100. Additionally, values ranging from 50 to 100 should be marked in light green
whereas cells with values that are greater than or equal to 0 and less then 50 should be marked
in light red. If any values outside the allowed range of 0 to 100 are found, a warning message
should be displayed and cells should be marked in light gray. Listing 6 shows the Basic code for
such a macro.
Listing 6: Calc macro to format ranges based on values
Sub FormatRangeBasedOnValue
'Gets the current selection
Dim oRange as Object, oCell as Object
Set oRange = Thiscomponent.getCurrentSelection()
'Checks if the selected range is a single range
If Not oRange.supportsService("com.sun.star.sheet.SheetCellRange")
Then
MsgBox "This macro applies only to single ranges."
Exit Sub
End If
' Number of columns and rows in selection
Dim nCols as Long : nCols = oRange.Columns.getCount()
Dim nRows as Long : nRows = oRange.Rows.getCount()
Dim col as Long, row as Long
Dim cellValue as Long
Dim isError as Boolean : isError = False
' Iterate over all cells in the range
For col = 0 To nCols - 1
For row = 0 to nRows - 1
Set oCell = oRange.getCellByPosition(col, row)
cellValue = oCell.getValue()
If cellValue >= 50 and cellValue <= 100 Then
' Sets background to light green
oCell.CellBackcolor = RGB(144, 238, 144)
ElseIf cellValue >= 0 and cellValue < 50 Then
' Sets background to light red
oCell.CellBackcolor = RGB(255, 127, 127)
Else
' Sets background to light gray
oCell.CellBackcolor = RGB(220, 220, 220)
isError = True
End If
Next row
Next col
' Displays a message indicating that there were errors
If isError Then
MsgBox "Some cells outside the range 0 to 100 were marked in light
grey"
End If
End Sub
To add this macro to a library, follow the steps described in “An example of a macro for Writer” on
page 425. To run this macro, first create a new Calc sheet and add some numeric values in a
range of cells. Then, select the cells and use one of the methods described in “How to run a
macro” on page 422 to execute it.
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Figure 391 shows an example of the macro being run on a set of cells. Because some of the
cells have values that are not between 0 and 100, the message box in Figure 392 will also be
displayed.

Figure 391: Cell values after being formatted by the macro

Figure 392: Message box presented if some values are
not between 0 and 100

The ScriptForge library
Macro programmers frequently need to perform tasks such as creating and opening files,
accessing form controls, reading data from databases embedded in Base documents, and so
forth. The objective of the ScriptForge library is to make it easier to execute such commands
without having to learn the required LibreOffice APIs (Application Programming Interfaces) and
commands, which may be difficult for casual programmers.
The ScriptForge library is organized into a set of services, each of which provides methods and
properties related to a specific topic. For example, the Dialog service provides access to dialogs
available in script modules and the Database service allows to execute SQL commands in Base
documents. The example in Listing 7 shows a macro written in Basic using the ScriptForge
library that opens a Calc document, creates a new sheet named NewSheet, and inserts the string
“Hello” into cell A1. The macro also saves and closes the document.
Listing 7: Macro using the ScriptForge library
Sub CreateSheetExample
' Loads the ScriptForge library
GlobalScope.BasicLibraries.LoadLibrary("ScriptForge")
' Instantiates the UI service
Dim ui as Object, myDoc as Object
ui = CreateScriptService("UI")
' Opens the file "myfile.ods"
Set myDoc = ui.OpenDocument("/home/user/Documents/myfile.ods")
' Inserts a new sheet named "NewSheet"
myDoc.InsertSheet("NewSheet")
' Inserts the string "Hello" into cell "A1" of the new sheet
myDoc.SetValue("NewSheet.A1", "Hello")
' Shows the sheet "NewSheet"
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myDoc.Activate("NewSheet")
' Saves the document
myDoc.Save()
' Closes the document
myDoc.CloseDocument()
End Sub
As seen in the example, the ScriptForge library provides straightforward commands to execute
commands, which seeks to simplify the creation of macros.

Tip
To learn more about the ScriptForge library, visit LibreOffice’s online Help at
help.libreoffice.org. Each of the 21 supported services have been extensively
documented and examples are provided for both Basic and Python programming
languages.

Caution
The ScriptForge library is available since LibreOffice 7.1 with support for the Basic
language. In LibreOffice 7.2 Python support was added to the library. Currently, most
services, methods, and properties are equally supported in both Basic and Python.

UNO Object Inspector
LibreOffice has an extensive API that can be used by macro programmers to automate almost
any aspect of its applications. However, one of the main challenges for programmers is to
discover object types as well as their supported services, methods, and properties.
The UNO Object Inspector can help macro developers inspect objects and discover how they
can be accessed and used in macros. This feature is available in Writer, Calc, Impress, and
Draw. To enable it, go to Tools > Development Tools. The Object Inspector will be opened at
the bottom of the user interface, as shown in Figure 393.

Figure 393: UNO Object Inspector opened in a Writer document
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The left portion of the Object Inspector consists of the Document Object Model (DOM) navigator,
which allows the user to navigate through all the objects in the document. When an object is
selected, information about the object are shown in the right portion of the Object Inspector
window:
•

The names of all implemented interfaces.

•

The names of all services supported by the object.

•

The names and types of all properties available in the object.

•

The names, arguments and return types of all methods that can be called by the object.

Instead of inspecting objects using the DOM navigator, it is possible to directly inspect the
currently selected object in the document by toggling the Current Selection button.
For example, suppose you want to change the background color of the text selected in a Writer
document. You can select a portion of text, open the Object Inspector and toggle the Current
Selection button. Now, inspect the object properties in search of a property that matches the
desired effect. Figure 394 shows the CharBackColor property selected, which is the property
used to set text background color.

Figure 394: Using the Object Inspector to find a property
Now it is possible to write a macro using this property to change the background color of the
selected text. Listing 8 shows the code for this macro.
Listing 8: Macro that changes the background color of a text range
Sub ChangeTextBGColor
Dim oSel as Object
Set oSel = ThisComponent.getCurrentSelection()
oSel(0).CharBackColor = RGB(255, 127, 127)
End Sub
Note that in Writer it is possible to have multiple ranges selected at once, hence oSel(0)
accesses the first range of text.
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Overview of Python, BeanShell, and JavaScript macros
Many programmers may not be familiar with LibreOffice Basic, so LibreOffice supports macros
written in three other languages that may be more familiar: Python, BeanShell, and JavaScript.
Macros are organized in the same way for all four scripting languages. The LibreOffice Macros
container holds all the macros that are supplied in the LibreOffice installation. The My Macros
library container holds your macros that are available to any of your LibreOffice documents. Each
document can also contain your macros that are not available to any other document.
When you use the recording facility, the macros are created in LibreOffice Basic. To use the other
available scripting languages, you must write the code yourself.
When you select to run a macro using Tools > Macros > Run Macro, LibreOffice displays the
Macro Selector dialog. This dialog enables selection and running of any available macro, coded
in any of the available languages (Figure 395).
When you edit a macro using Tools > Macros > Edit Macros, LibreOffice displays the
LibreOffice Basic IDE. This dialog enables selection and editing of any available LibreOffice
Basic macro, but not macros in other languages.

Figure 395: Macro Selector dialog
The component model used in LibreOffice is known as Universal Network Objects or UNO.
LibreOffice macros in any scripting language use a UNO runtime application programming
interface (API). The XSCRIPTCONTEXT interface is provided to macro scripts in all four
languages, which provides some means of access to the various interfaces which they might
need to perform an action on a document.
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Tip
If you want to learn more about the LibreOffice API as well as UNO objects, refer to
the official API documentation at https://api.libreoffice.org/

Python macros
Python is a high-level, general-purpose programming language that was first released in 1991.
When you select Tools > Macros > Organize Macros > Python, LibreOffice displays the Python
Macros dialog (Figure 396).

Figure 396: Python Macros dialog
Facilities to edit and debug Python scripts are not currently integrated into the standard
LibreOffice user interface. However, you can use any Python editor to create scripts and then
copy these files into the Scripts folder in your home directory. For more information, refer to
“Where are macros stored?” on page 420.
Listing 9 presents an example of a Python macro that writes the text “Hello World from Python”
into cell A1 of the first sheet in a Calc spreadsheet.
Listing 9: Sample Python macro
import uno
def HelloWorld():
doc = XSCRIPTCONTEXT.getDocument()
cell = doc.Sheets[0]['A1']
cell.setString('Hello World from Python')
return
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Tip
The Alternative Python Script Organizer (APSO) extension makes it easier to edit
and organize Python scripts, in particular when embedded in a document. Using
APSO you can configure your preferred source code editor, start the integrated
Python shell and debug Python scripts. Visit https://gitlab.com/jmzambon/apso to
download APSO and learn more about how to use it.

Tip
To learn more about Python scripting in LibreOffice, you can refer to the Wiki
“Macros/Python Basics”, where you will find in-depth explanations and examples on
how to get started with Python scripting. To learn more, visit
https://wiki.documentfoundation.org/Macros/Python_Basics.

BeanShell macros
BeanShell is a Java-like scripting language that was first released in 1999.
When you select Tools > Macros > Organize Macros > BeanShell, LibreOffice displays the
BeanShell Macros dialog (Figure 397).

Figure 397: BeanShell Macros dialog
Click the Edit button on the BeanShell Macros dialog to access the BeanShell Debug Window
(Figure 398).
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Figure 398: BeanShell Debug Window
Listing 10 is an example of a BeanShell macro that inserts the text “Hello World from BeanShell”
in cell A1 of the active Calc spreadsheet.
Listing 10: Sample BeanShell macro
import com.sun.star.uno.UnoRuntime;
import com.sun.star.sheet.XSpreadsheetView;
import com.sun.star.text.XText;
model = XSCRIPTCONTEXT.getDocument();
controller = model.getCurrentController();
view = UnoRuntime.queryInterface(XSpreadsheetView.class, controller);
sheet = view.getActiveSheet();
cell = sheet.getCellByPosition(0, 0);
cellText = UnoRuntime.queryInterface(XText.class, cell);
textCursor = cellText.createTextCursor();
cellText.insertString(textCursor, "Hello World from BeanShell", true);
return 0;
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JavaScript macros
JavaScript is a high-level scripting language that was first released in 1995.
When you select Tools > Macros > Organize Macros > JavaScript, LibreOffice displays the
JavaScript Macros dialog (Figure 399).

Figure 399: JavaScript Macros dialog
Click the Edit button on the JavaScript Macros dialog to access the Rhino JavaScript Debugger
(Figure 400). Detailed instructions for using this tool can be found on Mozilla’s website at
https://developer.mozilla.org/en-US/docs/Mozilla/Projects/Rhino/Debugger.
Listing 11 is an example of a JavaScript macro that inserts the text “Hello World from JavaScript”
in cell A1 of the first sheet in a Calc spreadsheet.
Listing 11: Sample JavaScript macro
importClass(Packages.com.sun.star.uno.UnoRuntime);
importClass(Packages.com.sun.star.sheet.XSpreadsheetDocument);
importClass(Packages.com.sun.star.container.XIndexAccess);
importClass(Packages.com.sun.star.table.XCellRange);
importClass(Packages.com.sun.star.table.XCell);
documentRef = XSCRIPTCONTEXT.getDocument();
spreadsheetInterface = UnoRuntime.queryInterface(XSpreadsheetDocument,
documentRef);
allSheets = UnoRuntime.queryInterface(XIndexAccess,
spreadsheetInterface.getSheets());
theSheet = allSheets.getByIndex(0);
Cells = UnoRuntime.queryInterface(XCellRange,theSheet);
cellA1 = Cells.getCellByPosition(0,0);
theCell = UnoRuntime.queryInterface(XCell,cellA1);
theCell.setFormula("Hello World from JavaScript");
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Figure 400: Rhino JavaScript Debugger

Finding more information
Numerous resources are available that provide help with writing macros. Use Help > LibreOffice
Help, or press the F1 key, to open the LibreOffice help pages. The upper left corner of the
LibreOffice help system contains a drop-down list that determines which help set is displayed. To
view the help for Basic, choose Basic from this list.

Included material
Many excellent macros are included with LibreOffice. Use Tools > Macros > Organize Macros >
Basic to open the LibreOffice Basic Macros dialog. Expand the Tools library in the LibreOffice
library container. Inspect the Debug module; some good examples include WritedbgInfo
(document) and printdbgInfo (sheet).
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Online resources
The following links and references contain information regarding macro programming:
https://wiki.documentfoundation.org/Macros
https://ask.libreoffice.org/ (a Q&A site where volunteers answer questions related to LibreOffice)
https://wiki.documentfoundation.org/Documentation/Other_Documentation_and_Resources (look
in Programmers section for BASIC Programmers’ Guide and Developers’ Guide; the latter
contains a detailed explanation)
http://forum.openoffice.org/en/forum/ (Apache OpenOffice community forum; volunteers answer
questions about LibreOffice as well)

Printed and ebook materials
Andrew Pitonyak published a free online book OpenOffice.org Macros Explained, which is a
great reference for learning the Basic language used in both LibreOffice and OpenOffice. You
can download the PDF version at https://www.pitonyak.org/OOME_3_0.pdf.
Dr. Mark Alexander Bain published the book Learn OpenOffice.org Spreadsheet Macro
Programming. See https://www.packtpub.com/openoffice-ooobasic-calc-automation/book.
Roberto Benitez's Database Programming with OpenOffice.org Base & Basic is also a great
source to learn more about macro programming.
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Chapter 14,
Customizing LibreOffice

Introduction
This chapter describes some common customizations that you may wish to carry out.
You can customize menus, toolbars, keyboard shortcuts, and the tabbed interface in LibreOffice,
add new menus and toolbars, assign macros to events, and choose among several user
interface variants.
Other customizations are made easy by extensions that you can install from the LibreOffice
website or from other providers; see “Adding functionality with extensions” on page 446.

Note
Customized menus and toolbars can be saved in a template. To do so, first save
them in a document and then save the document as a template as described in
Chapter 3, Using Styles and Templates.

Customizing menu content
You can add and rearrange menus on the Menu bar or context (right-click) menus; add,
rearrange, and remove commands on menus, and make other changes.
To customize menus, choose Tools > Customize on the Menu bar. On the Customize dialog, go
to the Menus tab (Figure 401) or the Context Menus tab.

Figure 401: The Menus tab of the Customize dialog
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Modifying an existing menu
In this example, we are customizing a menu in the Calc component of LibreOffice.
1) In the Scope drop-down list in the upper right of the Customize dialog, choose whether to
save this changed menu for Calc or for a selected document.
2) In the Target drop-down list, select the menu that you want to customize. The list includes
all the submenus as well as the main menus. The commands on the selected menu are
shown in the Assigned Commands list.
3) To add a command to the selected menu, click on a command in the Available
Commands list and then click the large right arrow. You can narrow the search by using
the Search box on the top left or selecting the Category in the drop-down list. Use the up
and down arrows on the far right-hand side to move the command into the position where
you want it in the list.
4) To remove a command from the selected menu, click on it in the Assigned Commands list
and then click the large left arrow.
5) To insert a separator or submenu, select the item directly before where you want the
inserted item to appear, and use the commands in the Insert drop-down list.

Figure 402: Insert drop-down
6) To rename a menu item, select it in the Assigned Commands list and choose Rename in
the Modify drop-down list.

Figure 403: Modify drop-down
7) When you have finished making all your changes, click OK to save them.

Creating a new menu
On the Menus tab of the Customize dialog, click the button next to Target and select Add in the
drop-down list (Figure 404), to display the New Menu dialog (Figure 405).
1) Type a name for the new menu in the Menu name box.
2) Use the up and down arrow buttons to move the new menu into the required position on
the Menu bar.
3) Click OK to save and return to the Customize dialog.
The new menu now appears on the list of menus in the Customize dialog. It will appear on the
Menu bar itself after you save your customizations.
After creating a new menu, you need to add some commands to it, as described above for
modifying a menu.
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Figure 404: Location of command to add a new menu

Figure 405: Adding a new menu

Creating an accelerator
You can allocate a letter in a custom menu’s name to be used as a keyboard shortcut. That letter
will become underlined. When you press Alt+that letter, the corresponding menu or command will
be invoked. Existing submenus can also be edited to change the letter which is used to select
them using the keyboard when the menu is open.
To create an accelerator:
1) Select a menu item in the Assigned Commands list on the Customize dialog.
2) Click the Modify button and select Rename.
3) Add a tilde (~) in front of the letter to use as an accelerator.
4) Click OK to save the change.
If for example you put a tilde before the “A” in a menu item Art, the “A” would now be underlined.
Press Alt+A and either the Art submenu will open or the Art menu item will be actioned (as
appropriate).
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Caution
When assigning an accelerator, be careful not to use a letter that is already assigned
to a menu or command associated with a menu item. The same letter-key
combinations can be used for commands associated with different menu items but
not for those associated with the same menu or menu item.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and
locking the position of a docked toolbar (as described in Chapter 1, Introducing LibreOffice), and
adding or deleting icons (commands) in the list of those available on a toolbar. You can also
create new toolbars. This section describes how to create new toolbars and add or delete icons
on existing toolbars.
To get to the Toolbars tab of the Customize dialog (Figure 406), do any of the following:
•

On the toolbar, right-click on the toolbar and choose Customize Toolbar.

•

Choose View > Toolbars > Customize on the Menu bar.

•

Choose Tools > Customize on the Menu bar and click on the Toolbars tab.

Figure 406: The Toolbars tab of the Calc Customize dialog
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Modifying existing toolbars
The procedures for creating and modifying a toolbar are similar to those for menus. In this
example, we are customizing a toolbar in the Calc component of LibreOffice.
To modify an existing toolbar:
1) In the Scope drop-down list on the upper right of the Customize dialog, choose whether
to save this changed toolbar for Calc or for a selected document.
2) In the Target drop-down list, select the toolbar that you want to customize. The current
toolbar content is displayed in the Assigned Commands list.
3) Select a command in the Available Commands list on the left. You can narrow your
search by using the Search box on the top left or choosing a category in the drop-down
list just below.
4) Click on the large right arrow to add the selected command to the Assigned Commands
list for the toolbar (on the right). Use the up and down arrows in the far right to position
the command in the toolbar.
5) To remove a command from a toolbar, select it in the Assigned Commands list on the
right and click the large left arrow.
6) To show or hide a command assigned to a toolbar, mark or clear the checkbox by its icon
in the Assigned Commands list on the right.
7) To insert a separator, select the item directly before where you want the separator to
appear, and use the command in the Insert drop-down list.
8) To rename a toolbar item, select it in the Assigned Commands list and choose Rename in
the Modify drop-down list.
9) When you have finished making all your changes, click OK to save them.

Creating a new toolbar
To create a new toolbar:
1) Choose Tools > Customize on the Menu bar.
2) On the Toolbars page of the Customize dialog, click the button next to Target and select
Add in the list, to display the Name dialog (Figure 407).
3) On the Name dialog, type the new toolbar's name and choose in the Save In drop-down
list where to save this new toolbar: for the component (for example, Writer) or for a
selected document.
The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new
toolbar, you need to add some commands to it, as described above.

Figure 407: Naming a new toolbar

442 | LibreOffice 7.3 Getting Started Guide

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have
associated icons.
To choose an icon for a command, select the command and click Modify > Change Icon. On the
Change Icon dialog (Figure 408), scroll through the available icons, select one, and click OK to
assign it to the command.
To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the
Import button on the Change Icon dialog. For best quality, custom icons should be 24 x 24 pixels
in size; other sizes will be scaled automatically.

Figure 408: Change Icon dialog

Customizing user interface variants
By default, LibreOffice’s commands are grouped in cascading menus and in toolbars filled with
icons. In addition, LibreOffice provides other user interface variants, displaying contextual groups
of commands and contents. (See “User interface variants” on page 449.)
In three variants (Tabbed, Tabbed Compact, and Groupedbar Compact), the area at the top of
the workspace is divided into tabs, where each tab displays a set of icons grouped by context.
The context can change depending on the object selected in the document, for example a table
or an image.
After one of these variants has been selected (using View > User Interface), you can use the
checkboxes on the Notebookbar tab of the Customize dialog (Figure 409) to show and hide the
individual options on the various tabs that are provided in the selected user interface.
Use the Reset button to reset the selected configuration to the default settings.
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Figure 409: The Notebookbar tab of the Customize dialog

Assigning shortcut keys
In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your
own. You can assign shortcuts to standard LibreOffice functions or your own macros and save
them for use with the entire LibreOffice suite.

Caution
Avoid reassigning your operating system’s predefined shortcut keys.
To adapt shortcut keys to your needs, use the Customize dialog, as described below.
1) Select Tools > Customize and then click the Keyboard tab (Figure 410).
2) To have the shortcut key assignment available in all components of LibreOffice, select
LibreOffice in the upper right section of the dialog.
3) Next select the required function in the Category and Function lists.
4) Now select the desired shortcut keys in the Shortcut Keys list and click the Modify button.
5) Click OK to accept the change. Now the chosen shortcut keys will execute the function
chosen in step 3 above whenever they are pressed.
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Note
All existing shortcut keys for the currently selected function are listed in the Keys
selection box. If the Keys list is empty, it indicates that the chosen key combination is
free for use. If it were not, and you wanted to reassign a shortcut key combination
that is already in use, you must first delete the existing key.
Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1,
F6, and F10 in Figure 410, are not available for reassignment.

Figure 410: Customizing a keyboard shortcut

Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at
a later time, thus permitting you to create and apply different configurations as the need arises, or
to create a standard keyboard configuration file to be distributed among many users. To save
keyboard shortcuts to a file:
1) After making your keyboard shortcut assignments, click the Save button at the right side
of the Customize dialog (Figure 410).
2) In the Save Keyboard Configuration dialog, enter a name for the keyboard configuration
file in the File name box, or select an existing file in the list. If you need to, browse to find
a file from another location (the file extension is .cfg for Configuration).
3) Click Save. A confirmation dialog appears if you are about to overwrite an existing file,
otherwise there will be no feedback and the file will be saved.
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Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the
Load button at the right side of the Customize dialog, and then select the configuration file in the
Load Keyboard Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button near the
bottom right of the Customize dialog. Use this feature carefully; no confirmation dialog will be
displayed.

Assigning macros to events
In LibreOffice, when something happens, we say that an event occurred. For example, a
document was opened, a key was pressed, or the mouse moved. You can associate a macro
with an event, so the macro is run when the event occurs. A common use is to assign the “open
document” event to run a macro that performs certain setup tasks for the document.
To associate a macro with an event, use the Events tab of the Customize dialog. For more
information, see Chapter 13, Getting Started with Macros.

Adding functionality with extensions
An extension is a program that can be installed into LibreOffice to add new functionality and
improve your productivity. Template sets, spelling dictionaries, clipart galleries, macros, and
dialog libraries can be packaged as LibreOffice extensions.
Several extensions are bundled with LibreOffice and are installed with the program. These can
only be removed by changing the installation options. Others can be downloaded from various
websites. The official extension repository is located at https://extensions.libreoffice.org/. These
extensions are free of charge.
Some extensions from other sources are free of charge; others are available for a fee. Check the
descriptions to see what licenses and fees apply to the ones that interest you.

Installing extensions
To install an extension that is listed in the repository, follow these steps:
1) In LibreOffice, select Tools > Extension Manager on the Menu bar. In the Extension
Manager dialog (Figure 411), click the Get more extensions online link.
2) A browser window will open. Find the extension you want and download it to your
computer.
3) After the extension is downloaded and saved, return to the Extension Manager dialog and
click Add. Find and select the extension you want to install and click Open. The
extension begins installing. You may be asked to accept a license agreement.
4) When the installation is complete, the extension is listed in the Extension Manager dialog.
To install an extension that is not listed in the repository, download the extension, then continue
with step 3 above.

Updating extensions
Click the Check for Updates button on the Extension Manager dialog to check for updates to
installed extensions.
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Removing and disabling extensions
To remove (uninstall) an extension that you installed, select the extension in the main window of
the Extension Manager dialog and click the Remove button.
To disable an extension without removing (uninstalling) it, select the extension in the Extension
Manager dialog and click the Disable button, which then changes to Enable.

Figure 411: Extension Manager dialog

Tip
Extensions can be installed from some other places in LibreOffice, such as the
Gallery on the Sidebar, the Templates dialog, the Language Settings > Writing Aids
page of the Tools > Options dialog and the Icon Style section in the View page of
the Tools > Options dialog. In each of these places you will find a small button
leading to a filtered view of the items in the Extensions dialog.

Note
In some cases, the Remove and Disable buttons may be unavailable, for example
when you have selected one of the extensions that was bundled with your
LibreOffice installation.
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Adding custom colors
To add custom colors to a color palette, for example to exactly match a corporate color scheme,
follow this procedure:
1) Insert any drawing object, such as a square, into any document.
2) Right-click on the object and choose Area in the context menu.
3) Click on the Color button to display the page shown in Figure 412. In the Palette dropdown list in the Colors area, choose which palette you wish to add the new color to.
Under New, define the new color using RGB or Hex notation, or click the Pick button to
select the color on the Pick a Color dialog (Figure 413).
4) Click Add in the lower left corner, enter a name for the new color in the pop-up dialog,
and click OK to save.
5) Delete the drawing object from the document, if it is not needed.

Figure 412: Defining a new color
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Figure 413: Defining a color by picking it from a color chart

Adding fonts
LibreOffice supports PostScript (.pfb), TrueType (.ttf), and OpenType (.otf) font file formats.
Other font formats exist, and may be supported by your operating system, but these formats may
be limited in selection and quality.
If you have administration privileges, you can install additional fonts through your operating
system; they will then be available for use by all components of LibreOffice.

Finding free-licensed fonts
In addition to proprietary fonts from sources like Adobe, hundreds of free-licensed fonts are
available. You can use, share, and edit free-licensed fonts as you please. Most are available at
no cost. Many are clones or near-variations of classic fonts, but some are original fonts.
Many Linux distributions include a few free-licensed fonts in their package repositories. Other
places where you can find free-licensed fonts include The League of Movable Type
(theleagueofmoveabletype.com), Open Font Library (fontlibrary.org).

User interface variants
By default, commands in LibreOffice are grouped in cascading menus and in toolbars filled with
icons—the standard user interface described in Chapter 1. These menus and toolbars are
described in the chapters that discuss the related tasks and functions.
In addition, LibreOffice Writer, Calc, Draw, and Impress provide other user interface variants,
displaying contextual groups of commands and contents. This section describes these user
interface variants and provides a quick reference to the location of the tools and functions when
using each of the variants. For details, see the user guides for the LibreOffice components.
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Selecting the user interface
When you set up LibreOffice, you can choose one of the user interfaces, and you can switch
between them and the standard interface at any time.
1) Choose View > User Interface on the Menu bar.
2) On the Select Your Preferred User Interface dialog (Figure 414), choose one of the
variants on the left. An example of the variant is shown in the Preview box on the right,
along with a short description.
3) Choose the relevant button to apply your selection to all components of LibreOffice, or
only to the open component. The window changes to match your selection.
4) Click Close to close the dialog.

Figure 414: Selecting a user interface
If you have activated experimental features (Tools > Options > Advanced), several more
choices may appear on the left-hand side. These choices are not described here.

Standard interfaces
Three of the user interface choices in Figure 414 are described in Chapter 1, Introducing
LibreOffice.
Standard toolbar
Classic mode with two visible toolbars: standard and formatting. The sidebar shows only its
tabs.
Single toolbar
Only one toolbar with frequently used features. The sidebar shows only its Show button.
Sidebar
The sidebar is fully opened and only one toolbar (Formatting) is showing.
The elements on each of these standards user interfaces can be modified using the View menu
on the Menu bar.
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Tabbed interface
The Tabbed interface (Figure 415) provides a familiar interface for users coming from proprietary
office suites such as Microsoft Office. It includes a Menu bar, an Icon bar, a Tab bar, icons for the
active tab, one or more tab-specific menus, and a Quick Menu. On Windows and Linux, the
Menu bar can be hidden or displayed by clicking on the Menu Bar icon in the Icon bar (Figure
417).

1 Icon bar

2 Active tab

3 Icons on active tab

4 Tabs

5 Tab menus

6 Quick menu

Figure 415: Tabbed Interface with Menu bar hidden
The Tabbed interface includes fixed tabs and additional tabs that vary depending on the item
selected (for example, a table or image).
Each tab displays a set of icons grouped by context. The context can change depending on the
location of the cursor or the item selected. Each tab also includes one or more tab-specific dropdown menus at the right-hand end. The Quick Menu is the same for all tabs.
The Tabbed interface can be customized using the Notebookbar tab of the Customize dialog to
show and hide the individual icons on the various tabs. See “Customizing user interface variants”
on page 443 for more information.
If the icons on a tab do not fit into the width of the LibreOffice window, >> appears at the end of
the row. Click it to display the other commands (Figure 416).

Figure 416: Displaying more commands on a tab

Icon bar
The icon bar (Figure 417) is located at the top left of the tabs. The sixth icon varies between
components; the illustration shows it for Writer.

Figure 417: Tabs – Icon bar
1 Menu bar – Show / Hide the menu bar.

4 Undo (Ctrl+Z) – Undo the last action.

2 Open (Ctrl+O) – Open a file browser.

5 Redo (Ctrl+Y) – Redo the last undone action.

3 Save (Ctrl+S) – Save the open file.

6 Print (Ctrl+P) – Open the Print dialog.
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Quick menu
At the right-hand end of the tab bar is a Quick menu (Figure 418) containing some commonly
used commands and links. Some of the Quick menu items have submenus, indicated by arrows
on the right.

Figure 418: Quick menu

Example: File tab in Writer
The File tab (Figure 419) includes commands to create new documents; open, save, print, and
close documents; manage templates; export to PDF and EPUB; display document properties;
add a digital signature; and sign an existing PDF.
The illustration shows the left and right ends of the tabs separately so they are large enough to
more easily see the commands.

Figure 419: Tabbed Interface – File tab in Writer
The File tab has two menus (Figure 420): File and Help. The File menu contains the same
commands as the icons on the tab. The Help menu provides links to a variety of resources.
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Figure 420: File tab menus

Tabbed Compact interface
The Tabbed Compact interface has the same tabs as the Tabbed interface, but the commands on
each tab are arranged in a single row of icons, many with drop-down menus of choices.
The Tabbed Compact interface can be customized using the Notebookbar tab of the Customize
dialog to show and hide the individual icons on the various tabs. See “Customizing user interface
variants” on page 443 for more information.

Figure 421: Tabbed Compact interface example: Insert tab in Writer
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Groupedbar Compact interface
The Groupedbar Compact interface (Figure 422) is divided into groups that contain commands
organized as sets of icons and menus.
The Groupedbar Compact interface can be customized using the Notebookbar tab of the
Customize dialog to show and hide the individual icons on the various tabs. See “Customizing
user interface variants” on page 443 for more information.

Figure 422: Groupedbar Compact interface example in Writer
The Groupedbar menu (Figure 423) on the right-hand end of this interface provides a subset of
commands, including a convenient way to change the user interface.

Figure 423: Groupedbar menu in Writer

Contextual Single interface
The Contextual Single interface displays a standard Menu bar and a single toolbar with contextdependent content.
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Appendix A
Keyboard Shortcuts
Using LibreOffice without a mouse

Introduction
LibreOffice can be used without requiring a pointing device, such as a mouse or trackball, by
using the keyboard shortcuts that are available in LibreOffice. Tasks as varied and complex as
docking and un-docking toolbars and windows, or changing the size or position of objects, can all
be accomplished using keyboard shortcuts. Although LibreOffice has an extensive set of
keyboard shortcuts, each LibreOffice module has keyboard shortcuts that are specific to that
module.
This appendix lists some of the more common keyboard shortcuts that apply to multiple
components of LibreOffice. For shortcuts specific to Writer, Calc, Impress, Draw, Math, or Base,
refer to the relevant user guide or search the LibreOffice Help.
To assist the user with identification of useful keyboard shortcuts, shortcuts are indicated by text
next to menu items and as tooltips for some tools on the toolbars. In Writer, for example, some
commonly used keyboard shortcuts are as follows:
•

The menu item File > Open includes text indicating that Ctrl+O (macOS ⌘+O) is a
keyboard shortcut.

•

The Align Left tool in the Formatting toolbar has a tooltip indicating that Ctrl+L
(macOS ⌘+L) is a keyboard shortcut.

LibreOffice provides further information about the keys used and the available keyboard
shortcuts in the list presented on the Keyboard tab of the Customize dialog for Linux/Windows
(Figure 424) or macOS (Figure 425).

Figure 424: Customize dialog – Keyboard tab for Linux (Windows is similar)
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Figure 425: Customize dialog – Keyboard tab in macOS

Note
Some keyboard shortcuts listed may not be available if the operating system uses
the same shortcuts for other tasks. To resolve any conflicts, assign different keys to
these shortcuts by reconfiguring either LibreOffice (see Chapter 14, Customizing
LibreOffice) or the operating system (see operating system documentation or help).

Assistive tools in LibreOffice
In addition to keyboard shortcuts, LibreOffice supports some assistive technology tools like
screen magnification software, screen readers, and on-screen keyboards. Please note that
except for the Windows platform, accessibility support relies on Java technology for
communications with assistive technology tools. This means that the first program startup may
take a few seconds longer, because the Java runtime environment has to be started as well.
A current list of supported assistive tools can be found on the Wiki at
https://wiki.documentfoundation.org/Accessibility.
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Information for macOS users
Some keystrokes and menu items are different in macOS than those used in Windows or Linux.
Table 9 gives the common substitutions that are used in a LibreOffice document. For a more
detailed list, see LibreOffice Help.
Table 9: macOS equivalent keystrokes
Windows or Linux

macOS equivalent

Effect

Tools > Options
menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click or right-click
depending on computer setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

Alt

⌥ (Option) or Alt, depending
on keyboard

Used with other keys

F11

⌘+T

Open Styles deck in Sidebar

Note
Actual keys available on a macOS keyboard depend on the type of keyboard being
used. For example, a macOS laptop keyboard may not have a Delete key, but a
macOS keyboard with a numeric keypad does have a Delete key.

Note
Some keyboard shortcuts are not available for computers using macOS. This is
indicated in the following tables by a blank cell.

Keyboard shortcuts
Note
Some of the shortcut keys may be assigned to the computer operating system and
are not available for LibreOffice. Either assign different keys in LibreOffice using
Tools > Customize > Keyboard on the Menu bar, or in the computer operating
system. For more information, see Chapter 14, Customizing LibreOffice or the
documentation/help for the computer operating system.

Using keyboard shortcuts
LibreOffice functions can easily be used by using keyboard shortcuts. For example, the Ctrl+O
(macOS ⌘+O) keyboard shortcut is shown next to Open in the File menu on the Menu bar. To
use this keyboard shortcut, press and hold down the Ctrl (macOS ⌘) key and then press the O
key. Release both keys together after the dialog box opens.
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Opening menus and menu items
Table 10: Keys for opening menus and menu items
Windows
Linux

macOS

Opens a menu where <?> is an underlined
character of the menu being opened. For example,
Alt+F opens the File menu.
When a menu is opened, there may be submenu
items with underlined characters. Press the
underlined character directly to carry out the action
or option.
Where two menu items have the same underlined
character, press the character key again to move to
the next menu item.
Menu items that have no underlined character have
to be clicked on directly.

Alt+<?>
Windows only

Esc

Effect

Esc

Closes an open menu.
Repeatedly pressing F6 switches the focus through
the following objects:

F6

•

Menu bar

•

Every toolbar from top to bottom and from
left to right

•

Every free window from left to right

•

Document

Repeatedly pressing F6 switches the focus through
the following objects:
F6

•

Each toolbar from top to bottom and from
left to right

•

Sidebar

•

Document

Shift+F6

Shift+F6

Switches focus through objects in the opposite
direction.

Ctrl+F6

⌘+F6

Switches the focus to the document.

F10

Switches focus to the Menu bar and back.

Accessing menu commands
1) Press Alt or F6 or F10 to select the first item on the Menu bar (normally the File menu). In
macOS, selection is the first tool on the Standard toolbar.
2) Press the right or left arrow to move the selection right or left.
3) Press the Home key (macOS Fn+left arrow) or End key (macOS Fn+right arrow) to move
menu selection to the first or last item on the Menu bar.
4) Press the down or up arrow to move the selection down or up the list of menu commands.
5) If necessary, press the right arrow to open any submenus on the selected menu.
Submenus are indicated by a triangle ► next to the name of the selected menu.
6) If necessary, press the down or up arrow to move the selection down or up the list of
submenu commands.
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7) If necessary, press the left arrow to close a submenu.
8) Press Enter to run the selected menu or submenu command.

Accessing toolbar commands
1) Press F6 repeatedly until the first icon on a toolbar is selected.
2) On a horizontal toolbar, press the right or left arrows to move tool selection to the right or
left.
3) On a vertical toolbar, press the up or down arrows to move tool selection upward or
downward.
4) Press the Home key (macOS Fn+left arrow) or End key (macOS Fn+right arrow) to move
tool selection to the first or last tool on a toolbar.
5) Press Enter to action the selected tool on the toolbar.
6) To insert an object into a drawing or presentation after selecting the required object on
the Drawing toolbar, use the key combination Ctrl+Enter (macOS ⌘+Enter) to insert the
object in the center of the drawing page or slide.

Note
If a tool on a toolbar has an editable text field, for example Load URL or Line Width,
the Tab or Shift+Tab keys are then used to move the selection right or left onto the
next tool on the toolbar.

Navigation and selection
Navigate through a document and make selections using the keyboard is as follows:
•

To move the cursor, use one of the keys or key combinations given in the following table.

•

To select any text while moving the cursor, hold down the Shift key as the cursor is
moved.

•

To select a word, position the cursor in the word and double-click.

•

To select a sentence, position the cursor in the sentence and triple-click.

•

To select a paragraph, position the cursor in the paragraph and click four times.

•

To select all of the text or objects in a document, use Ctrl+A (macOS ⌘+A).

•

Use Ctrl+Del (macOS ⌘+Delete) to delete everything from the cursor position to the end
of the word.

Table 11: Keys for navigation and selection
Windows
Linux

macOS

Effect

Left Arrow

Left Arrow
Ctrl+B

Moves the cursor one character to the left.

Right Arrow

Right Arrow
Ctrl+F

Moves the cursor one character to the right.

Ctrl+Left Arrow

⌥+Left Arrow

Moves the cursor one word to the left.

Ctrl+Right
Arrow

⌥+Right Arrow

Moves the cursor one word to the right.

Up Arrow

Up Arrow
Ctrl+P

Moves the cursor up one line.
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Windows
Linux

macOS

Effect

Down Arrow

Down Arrow
Ctrl+N

Moves the cursor down one line.

Ctrl+Up or
Down Arrow

⌥+Up or Down
Arrow

Moves the cursor up or down to the beginning of
the previous or next paragraph.

Home

Fn+Left arrow
Ctrl+A

Moves the cursor to the beginning of the current
line.

Ctrl+Home

⌘+Up Arrow

Moves the cursor to the beginning of the
document.

End

Fn+Right arrow
Ctrl+E

Moves the cursor to the end of the current line.

Ctrl+End

⌘+Down Arrow

Moves the cursor to the end of the document.

Page Up

Fn+Up Arrow

Scrolls up one page.

Ctrl+Page Up

⌘+Fn+Up
Arrow

Moves the cursor to the header.

Page Down

Fn+Down Arrow

Scrolls down one page.

Ctrl+Page
Down

⌘+Fn+Down
Arrow

Moves the cursor to the footer.

Controlling dialogs
When opening any dialog, one element (for example button, option field, entry in a list box, or
checkbox) is highlighted indicating that the element has focus on it. How the element is
highlighted depends on the operating system and how the computer is setup.
Table 12: Keys for controlling dialogs
Shortcut Keys

Result

Enter

Activates selected button.
When no button is selected, Enter is equivalent to clicking OK.

Esc

Closes dialog without saving any changes made while the dialog
was open.
Esc is also equivalent to clicking Cancel.
When a drop-down list is open and selected, Esc closes the list.

Spacebar

Checks or clears an empty checkbox.

Up or Down arrow

Moves focus up and down a list.
Increases or decreases value of a variable.
Moves focus vertically within a section of dialog.

Left or Right arrow

Moves focus horizontally within a section of a dialog.

Tab

Advances focus to the next section or element of a dialog.

Shift+Tab

Returns focus to the previous section or element in a dialog.

Alt+Down arrow
(macOS ⌥+Down
arrow)

Shows items in a drop-down list.
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Controlling documents and windows
Table 13: Keys for controlling documents and windows
Windows
Linux

macOS

Effect

Ctrl+O

⌘+O

Opens the Open dialog to select and open a
document.

Ctrl+S

⌘+S

Saves the current document. If the document is a
previously unsaved file, the shortcut opens the
Save As dialog.

Ctrl+N

⌘+N

Creates a new document.

Shift+Ctrl+N

⌘+Shift+N

Opens the Templates dialog.

Ctrl+P

⌘+P

Opens the Print dialog to print the document.

Ctrl+F

⌘+F

Opens the Find toolbar.

Ctrl+H

⌥+⌘+F

Opens the Find and Replace dialog.

Ctrl+Shift+F

Searches for the last entered search term.

Ctrl+Shift+J

Toggles the view between full-screen mode and
normal mode in Writer or Calc.
⌘+Shift+R

Opens and closes the rulers.

F1

Opens the LibreOffice Help contents in your
default browser. If the local Help package is not
installed, LibreOffice opens the online Help
located at https://help.libreoffice.org.

Shift+F1

Shift+F1

Turns the cursor into a What’s This? question
mark. Shows the tip for an item underneath the
cursor. The shortcut does not work with the online
help.

Shift+F2

Shift+F2

Turns on Extended Tips for the currently selected
command, icon or control. The shortcut does not
work with the online help.

Ctrl+Shift+F10

⌘+Shift+F10

Docks and undocks floating toolbars, Sidebar and
Navigator.

Ctrl+F4 or
Alt+F4

⌘+F4

Closes the current document. Closes LibreOffice
when the last open document is closed.

Ctrl+Q

⌘+Q

Exits LibreOffice.

Ctrl+Shift+R
F1

Editing or formatting documents
Table 14: Keys for editing or formatting documents
Windows
Linux

macOS

Effect

Enter

Enter

When an OLE object is selected, activates the
software used to create the OLE object.
When a drawing object is selected, activates text
mode.

Ctrl+X

⌘+X

Cuts selected text or objects from a document and
places them in the clipboard.
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Windows
Linux

macOS

Effect

Ctrl+C

⌘+C

Copies selected text or objects and places them in
the clipboard.

Ctrl+V

⌘+V

Places text or objects from the clipboard that have
copied or cut into the document.

Ctrl+Alt+Shift
+V

⌘+⌥+Shift+V

Pastes unformatted text from the clipboard. The
text is pasted using the format that exists at the
insertion point.

Ctrl+Shift+V

⌘+Shift+V

Opens the Paste Special dialog.

Ctrl+A

⌘+A

Selects all text and objects in a document.

Ctrl+Z

⌘+Z

Undoes last action.

Ctrl+Y

⌘+Y

Redoes last action.

Ctrl+Shift+Y

⌘+Shift+Y

Repeats last command.

Ctrl+I

⌘+I

Applies the Italic attribute to selected characters
and text.

Ctrl+B

⌘+B

Applies the Bold attribute to selected characters
and text.

Ctrl+U

⌘+U

Applies the Underline attribute to selected
characters and text.

Ctrl+M

⌘+M

Removes direct formatting from selected text or
objects. This command is also available in Format
> Clear Direct Formatting in the Menu bar.

Sidebar keyboard shortcuts
General
Table 15: General keyboard shortcuts for the Sidebar
Windows
Linux

macOS

Effect

Tab

Tab

Moves the focus in the Sidebar.

Shift+Tab

Shift+Tab

Moves the focus in the reverse direction in the
Sidebar.

Shift+F10

Shift+F10

Opens a context menu for the selected element in
the Sidebar.

Home

Fn+Left Arrow

Moves focus to first entry.

End

Fn+Right Arrow

Moves focus to last entry.

Up or Down
Arrow

Up or Down
Arrow

Moves the selection up or down and opens the
panels in the selected deck.

Right Arrow

Right Arrow

Opens any sub-elements in the selected element.

Left Arrow

Left Arrow

Closes any sub-elements in the selected element.

Ctrl+Enter

⌘+Enter

Opens the Properties dialog for the selected
element.

Appendix A Keyboard Shortcuts | 463

Gallery
Table 16: Keyboard shortcuts for Gallery in Sidebar
Windows
Linux

macOS

Opens the Enter Title dialog. Only themes
added to LibreOffice can be renamed. Themes
installed with LibreOffice cannot be renamed.

Ctrl+R

Ctrl+D

Effect

Deletes themes that have been added to
LibreOffice. Themes installed with LibreOffice
cannot be deleted.

⌘+D

Inserts a new theme into the Gallery and
opens the Insert of New Theme dialog.

Insert
Ctrl+Shift+Insert

⌘+Shift+Insert

Inserts the selected object as a linked object
into the current document.

Ctrl+I

Ctrl+I

Inserts a copy of the selected object into the
current document.

Ctrl+P
Spacebar
Enter

Ctrl+P
Spacebar
Enter

Switches between a view of a list of object
previews and a selected object.

Database table keyboard shortcuts
Table 17: Keyboard shortcuts for database tables
Windows
Linux

macOS

Effect

Ctrl+Shift+F4

⌘+Shift+F4

Opens and closes a database table in a
document for editing.

Spacebar

Spacebar

Toggles row selection, except when the row is
in edit mode.

Ctrl+Spacebar

⌘+Spacebar

Toggles row selection.

Shift+Spacebar

Shift+Spacebar

Selects the current column.

Ctrl+Page Up

⌘+⌥ + Fn+ Up
Arrow

Moves the cursor to the first row.

Ctrl+Page Down

⌘+⌥ + Fn+
Down Arrow

Moves the cursor to the last row.

Controlling macros
Table 18: Keys for controlling macros
Windows
Linux

macOS

Effect

Ctrl+* (multiplication sign
on number pad only)

⌘+* (multiplication sign
on number pad only)

Runs a macro field.

Shift+Ctrl+Q

⌘+Ctrl+Q

Stops a running macro.

Note
For more information on macros, see Chapter 13, Getting Started with Macros.
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Entering Unicode numbers
Each character in LibreOffice can be entered into a document by typing its Unicode hexadecimal
number and then pressing Ctrl+Alt+X (mac OS ⌘+⌥+X). For example, to enter the copyright sign
into text, type U+00A9 followed immediately by Ctrl+Alt+X (mac OS ⌘+⌥+X) and the copyright
sign © appears at the cursor position in the text.

Note
Unicode hexadecimal numbers in the range U+0000 to U+0020 are not converted
into characters using the conversion shortcut Ctrl+Alt+X (mac OS ⌘+⌥+X).

Defining keyboard shortcuts
In addition to using the built-in keyboard shortcuts listed in this Appendix, custom keyboard
shortcuts can be defined. For more information, see Chapter 14, Customizing LibreOffice.
To check if a keyboard shortcut is is already in use, open the Keyboard page in the Customize
dialog and scroll though the listed keyboard shortcuts. Go to Tools > Customize on the Menu
bar to open the Customize dialog.

Further reading
For help with keyboard shortcuts, or using LibreOffice with a keyboard only, search the
application Help using the keywords “shortcut keys” or “accessibility”.
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Appendix B,
Open Source,
Open Standards,
OpenDocument

Introduction
LibreOffice is a productivity suite that is compatible with other major office suites and available on
a variety of platforms. It is open source software and therefore free to download, use, and
distribute. If you are new to LibreOffice, this appendix will provide some information regarding its
history, its community, and some of its technical specifications.

A short history of LibreOffice
The OpenOffice.org project began when Sun Microsystems released the source code
(“blueprints”) for its StarOffice® software to the open source community on October 13, 2000.
OpenOffice.org 1.0, the product, was released on April 30, 2002. Major updates to
OpenOffice.org included version 2.0 in October 2005 and version 3.0 in October 2008. On
January 26, 2010, Oracle Corporation acquired Sun Microsystems.
On September 28, 2010, the community of volunteers who develop and promote OpenOffice.org
announced a major change in project structure. After ten years’ successful growth with Sun
Microsystems as founding and principle sponsor, the project launched an independent foundation
called The Document Foundation, to fulfill the promise of independence written in the original
charter. This foundation is the cornerstone of a new ecosystem where individuals and
organizations can contribute to and benefit from the availability of a truly free office suite.
Unable to acquire the trademarked OpenOffice.org name from Oracle Corporation, The
Document Foundation named its product LibreOffice. Continuing the version numbers from
OpenOffice.org, LibreOffice 3.3 was released in January 2011 and version 7.0 was released in
August 2020.
In February 2012, The Document Foundation was incorporated in Berlin as a German Stiftung.
You can read more about The Document Foundation at: www.documentfoundation.org.

The LibreOffice community
The Document Foundation’s mission is:
“...to facilitate the evolution of the OpenOffice.org Community into a new open,
independent, and meritocratic organizational structure within the next few months. An
independent Foundation is a better match to the values of our contributors, users, and
supporters, and will enable a more effective, efficient, transparent, and inclusive
Community. We will protect past investments by building on the solid achievements of our
first decade, encourage wide participation in the Community, and co-ordinate activity
across the Community.”
Some of our corporate supporters include GNOME Foundation, Google, Red Hat, and Collabora.
Additionally, over 450,000 people from nearly every part of the globe have joined this project with
the idea of creating the best possible office suite that all can use. This is the essence of an “open
source” community!
With its open source software license, LibreOffice is key in the drive to provide an office suite that
is available to anyone, anywhere, for commercial or personal use. The software has been
translated into many languages and runs on all major operating systems. New functionality can
be added in the form of extensions.
The LibreOffice community invites contributors in all areas, including translators, software
developers, graphic artists, technical writers, editors, donors, and end-user support. Whatever
you do best, you can make a difference in LibreOffice. The community operates internationally in
all time zones and in many languages, linked through the internet at www.libreoffice.org and
www.documentfoundation.org.
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How is LibreOffice licensed?
LibreOffice is distributed under both the Mozilla Public License (MPL) 2.0
(www.libreoffice.org/about-us/licenses/) and the GNU Lesser General Public License (LGPL)
3.0+ (www.gnu.org/licenses/lgpl-3.0.en.html).

What is open source?
The four essential rights of open-source software are embodied within the Free Software
Foundation’s family of the GNU General Public License (GPL):
•

The right to use the software for any purpose.

•

Freedom to redistribute the software for free or for a fee.

•

Access to the complete source code of the program (that is, the “blueprints”).

•

The right to modify any part of the source, or use portions of it in other programs.

The basic idea behind open source is very simple: When programmers can read, redistribute,
and modify the source code for a piece of software, the software evolves. People improve it,
people adapt it, people fix bugs.
For more information on Free and Open Source software, visit these websites:
•

Open Source Initiative (OSI): www.opensource.org

•

Free Software Foundation (FSF): www.fsf.org

What are open standards?
An open standard provides a means of doing something that is independent of manufacturer or
vendor, thus enabling competing software programs to freely use the same file formats. HTML,
XML, and ODF are examples of open standards for documents.
An open standard meets the following requirements:
•

It is well documented with the complete specification publicly available, either free or at a
nominal charge.

•

It can be freely copied, distributed, and used. The intellectual property of the standard is
made irrevocably available on a royalty-free basis.

•

It is standardized and maintained in an independent, open forum (also called “standards
organization”) using an open process.

What is OpenDocument?
OpenDocument (ODF) is an XML-based file format for office documents (text documents,
spreadsheets, drawings, presentations, and more), developed at OASIS (https://www.oasisopen.org/), an independent, international standards group. OpenDocument version 1.2 was
adopted by the International Standards Organization and named ISO/IEC 26300:2015 standard3.
In December 2019, ODF 1.3 was approved as a committee specification.
Unlike other file formats, ODF (ISO/IEC 26300:2015) is an open standard. It is publicly available,
royalty-free, and without legal or other restrictions; therefore ODF files are not tied to a specific
office suite and anybody can build a program that interprets these files. For this reason ODF is
quickly becoming the preferred file format for government agencies, schools and other
companies who prefer not to be too dependent on any one software supplier.
3

https://www.iso.org/standard/66363.html, https://www.iso.org/standard/66375.html, and
https://www.iso.org/standard/66376.htmll
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LibreOffice 7.3 saves documents in ODF 1.3 Extended by default. LibreOffice can also open and
save in earlier versions of the ODF standard, as well as many other file formats, as summarized
below.
For a full list of file formats that LibreOffice can read and write, see
https://en.wikipedia.org/wiki/LibreOffice#Supported_file_formats

OpenDocument filename extensions
The most common filename extensions used for OpenDocument documents are:
*.odt for word processing (text) documents
*.ods for spreadsheets
*.odp for presentations
*.odb for databases
*.odg for graphics (vector drawings)
*.odc for charts
*.odf for formulas (scientific formulas and equations)

File formats LibreOffice can open
LibreOffice can open a wide variety of file formats in addition to the OpenDocument formats,
including Portable Document Format (PDF).

Opening text documents
In addition to OpenDocument formats (.odt, .ott, .oth, .odm, and .fodt), Writer can open the
following text document formats, and a variety of legacy formats not listed below:
Microsoft Word 6.0/95/97/2000/XP/Mac) (.doc and .dot)
Microsoft Word 2003 XML (.xml)
Microsoft Word 2007/2010 XML (.docx, .docm, .dotx, .dotm)
Microsoft WinWord 5 (.doc)
WordPerfect Document (.wpd)
Microsoft Works (.wps)
Lotus WordPro (.lwp)
Abiword Document (.abw, .zabw)
ClarisWorks/Appleworks Document (.cwk)
MacWrite Document (.mw, .mcw)
Rich Text Format (.rtf)
Text CSV (.csv and .txt)
StarWriter formats (.sdw, .sgl, .vor)
DocBook (.xml)
Unified Office Format text (.uot, .uof)
T602 Document (.602, .txt)
Hangul WP 97 (.hwp)
Apple Pages (.pages)
eBook (.pdb)
HTML Document (.htm, .html)
OpenOffice.org 1.x (.sxw, .stw, and .sxg)
... and many others
Most of these file types are automatically detected by LibreOffice, so they can be opened without
explicitly selecting the document type in the file picker.
When opening .htm or .html files (used for web pages), LibreOffice customizes Writer for working
with these files.
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Opening spreadsheets
In addition to OpenDocument formats (.ods, .ots, and .fods), Calc can open the following
spreadsheet formats:
Microsoft Excel 97/2000/XP (.xls, .xlw, and .xlt)
Microsoft Excel 4.x–5.0/95 (.xls, .xlw, and .xlt)
Microsoft Excel 97-2003 (.xml)
Microsoft Excel 2007-365 (.xlsx, .xlsm, .xltx, .xltm)
Microsoft Excel 2007-2010 binary (.xlsb)
Lotus 1-2-3 (.wk1, .wks, and .123)
Data Interchange Format (.dif)
Rich Text Format (.rtf)
Text CSV (.csv and .txt)
StarCalc (.sdc and .vor)
OpenOffice.org 1.x (.sxc and .stc)
dBASE (.dbf)
SYLK (.slk)
Unified Office Format spreadsheet (.uos, .uof)
HTML Document (.htm and .html files, including Web page queries)
Quattro Pro 6.0 (.wb2)
Apple Numbers 2 (.numbers)
... and many others

Opening presentations
In addition to OpenDocument formats (.odp, .odg, .otp, and .fopd), Impress can open the
following presentation formats:
Microsoft PowerPoint 97/2000/XP (.ppt and .pot)
Microsoft PowerPoint 2007-365 (.pptx, .pptm, .potx, .potm)
StarDraw and StarImpress (.sda, .sdd, .sdp, and .vor)
OpenOffice.org 1.x (.sxi and .sti)
Unified Office Format presentation (.uop, .uof)
CGM – Computer Graphics Metafile (.cgm)
Portable Document Format (.pdf)
Apple Keynote 5 (.key)
... and many others

Opening graphic files
In addition to OpenDocument formats (.odg and .otg) and Portable Document Format (.pdf),
Draw can open the following graphic formats:
Adobe Photoshop (*.psd)
AutoCAD Interchange Format (*.dxf)
Corel Draw (*.cdr)
Corel Presentation Exchange (*.cmx)
Microsoft Publisher 98-2010 (*.pub)
Microsoft Visio 2000-2013 (*.vdx; *.vsd; *.vsdm; *.vsdx)
WordPerfect Graphics (*.wpg)
OpenOffice.org 1.x (.sxd and .std)
BMP
JPEG, JPG
PCX
RAS
TGA
DXF
MET
PGM
SDA
TIF, TIFF
EMF
PBM
PNG
SDD
WMF
EPS
PCD
PPM
SVG
XBM
GIF
PCT
PSD
SVM
XPM
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Opening formula files
In addition to OpenDocument Formula (.odf) files, Math can open the formats used by
OpenOffice.org 1.x (.sxm), StarMath (.smf), and MathML (.mml) files.
When opening a Word document that contains an embedded equation editor object, if the option
MathType to LibreOffice Math or reverse is checked in Tools > Options > Load/Save >
Microsoft Office, the object will be automatically converted to a LibreOffice Math object.

File formats LibreOffice can save to
Saving in an OpenDocument format guarantees the correct rendering of the file when it is
transferred to another person or when the file is reopened with a later version of LibreOffice or
with another program. It is strongly recommended that you use OpenDocument as the default file
formats. However, you can save files in other formats, if you wish.

Tip
When sharing a document that you do not expect the recipient to modify, the
preferred option is to convert the document to PDF. LibreOffice provides a
straightforward way to convert documents to PDF. See Chapter 10, Printing,
Exporting, Emailing, and Signing, in this guide.

Saving text documents
In addition to OpenDocument formats (.odt, .ott, and .fodt), Writer can save in these formats:
Office Open XML Text (.docx)
Microsoft Word 97–2003 (.doc)
Rich Text Format (.rtf)
Text Encoded (.txt)
HTML Document (.html and .htm)

Microsoft Word 2007–365 (.docx, .dotx)
Microsoft Word 2003 XML (.xml)
Text (.txt)
Unified Office Format text (.uot, .uof)
DocBook (.xml)

Encryption support within the Microsoft Word 97/2000/XP filter allows password protected
Microsoft Word documents to be saved.

Note
The .rtf format is a common format for transferring text files between applications,
but you are likely to experience loss of formatting and images. For this reason, other
formats should be used.

Saving spreadsheet files
In addition to OpenDocument formats (.ods, .ots, and .fods), Calc can save in these formats:
Office Open XML Spreadsheet (.xlsx)
Microsoft Excel 2007–365 XML (.xlsx)
Microsoft Excel 97–2003 (.xls and .xlw)
Microsoft Excel 97–2003 Template (.xlt)
Microsoft Excel 2003 XML (.xml)
HTML Document (Calc) (.html and .htm)

Data Interchange Format (.dif)
dBase (.dbf)
SYLK (.slk)
Text CSV (.csv and .txt)
Unified Office Format spreadsheet (.uos)
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Saving presentations
In addition to OpenDocument formats (.odp, .otp, .fodp, and .odg), Impress can save in these
formats:
Microsoft PowerPoint 2007–365 (.pptx, .potm)
Microsoft PowerPoint 2007–365 AutoPlay (.ppsx)
Microsoft PowerPoint 97–2003 (.ppt)
Microsoft PowerPoint 97–2003 Template (.pot)
Microsoft PowerPoint 97–2003 AutoPlay (.pps)
Office Open XML Presentation (.pptx, .potm, .ppsx)
Unified Office Format presentation (.uop)
Impress can also export to any of the graphics formats listed for Draw.

Saving drawings
Draw can save in the OpenDocument Drawing formats (.odg, .otg, and .fodg).
Draw can export to any of the following graphics formats: BMP, EMF, EPS, GIF, JPEG, PNG,
SVG, TIFF, and WMF.

Note
Adobe [Macromedia] Flash (.swf) export has been removed from LibreOffice 7. Flash
Player reached end-of-life in December 2020.

Saving Writer/Web documents
Writer/Web can save to these formats:
HTML document (.html and .htm), as HTML 4.0 Transitional
Text and Text Encoded (LibreOffice Writer/Web) (.txt)

Exporting to other formats
LibreOffice uses the term “export” for some file operations involving a change of file type. If you
cannot find what you want under File > Save As, look under File > Export (not available in
Math) for additional types.
Two popular formats that LibreOffice can export to are PDF (Writer, Calc, Impress, and Draw)
and EPUB (Writer only). See Chapter 10, Printing, Exporting, Emailing, and Signing Documents,
for more information about exporting to those formats.
LibreOffice can also export files to HTML and XHTML. In addition, Draw and Impress can export
to a range of image formats.
To export to one of these formats, choose File > Export. On the Export dialog, specify a file
name for the exported document, then select the desired format in the file format list and click the
Export or Save button as appropriate.
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Getting Started Guide
Introduction to LibreOffice
About this book:
If you have never used LibreOffice before, or you want an introduction to all of its components, this book is
for you. Anyone who wants to get up to speed quickly with LibreOffice will find this book valuable You may
be new to office software, or you may be familiar with another office suite.
This book introduces LibreOffice and its components:
Writer (word processing)
Calc (spreadsheet)
Draw (vector Graphics)
Math (equation editor)

Impress (presentations)
Base (database)

It also covers features common to all components, including:
Styles
Templates
Clip art galleries
Macros
Printing
About the authors:
This book was written by volunteers from the LibreOffice community.
A PDF version of this book can be downloaded free from: https://documentation.libreoffice.org
About LibreOffice:
LibreOffice is the free, libre, and open source personal productivity suite from The Document Foundation.
It runs on Windows, macOS, and GNU/Linux. Support and documentation are free from our large, dedicated
community of users, contributors, and developers.
You too can get involved with volunteer work in many areas: development, quality assurance,
documentation, translation, user support, and more.
You can download the free Community release of LibreOffice from: https://libreoffice.org/download/
For commercial use:
You are encouraged to work with a certified LibreOffice professional for your business needs, from
deployment or conversion from other office suites, staff training, or custom development needs.
For information on professional support services, https://www.libreoffice.org/get-help/professional-support/

