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Introduction

You can use LibreOffice without requiring a pointing device, such as a mouse or touchpad, by 
using its built-in keyboard shortcuts.

This appendix lists some of the most common built-in keyboard shortcuts that apply to multiple 
components of LibreOffice. For shortcuts specific to Writer, Calc, Impress, Draw, Math, or Base, 
read the relevant component guide or search the application Help.

To assist the user with identification of useful keyboard shortcuts, their existence is indicated by 
text on menu items and in the tooltips of toolbar icons. For example, in Writer:

• The menu item File > Open includes text indicating that Ctrl+O is an equivalent shortcut.

• The Underline icon in the Formatting toolbar has a tooltip indicating that Ctrl+U is an 
equivalent shortcut.

• The Paste item in the right-click context menu includes text indicating that Ctrl+V is an 
equivalent shortcut (providing that Tools > Options > LibreOffice > View > Visibility > 
Shortcuts is not set to Hide).

LibreOffice provides further information about the available shortcuts in the list presented on the 
Keyboard tab of the Tools > Customize dialog.

Warning

Some of the shortcuts listed here may not work if your operating system uses the 
same shortcuts for other tasks.

To resolve any conflicts, assign different keys to these shortcuts by reconfiguring 
either LibreOffice (see Chapter 14, Customizing LibreOffice, in this book) or your 
operating system (see system documentation).

Assistive tools in LibreOffice
In addition to keyboard shortcuts, LibreOffice supports some assistive technology tools like 
screen magnification software, screen readers, and on-screen keyboards. Please note that 
except for the Windows platform, accessibility support relies on Java technology for 
communications with assistive technology tools. This means that the first program startup may 
take a few seconds longer, because the Java runtime environment has to be started as well.

A current list of supported assistive tools can be found on the Wiki at 
https://wiki.documentfoundation.org/Accessibility

Tip for Macintosh users
Some keystrokes are different on macOS from those used in Windows and Linux. The following 
table gives some common substitutions for the instructions in this chapter. For a more detailed 
list, see the application Help.

Windows or Linux macOS equivalent Effect

Right-click Control+click and/or right-click 
depending on computer setup

Open a context menu

Ctrl (Control) ⌘ (Command) Used with other keys

F11 +T⌘ Open the Sidebar Styles deck
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Getting help

Shortcut Keys Result

F1
Opens the LibreOffice Help contents in your default browser. If the local 
Help package is not installed, LibreOffice opens the online Help located at 
https://help.libreoffice.org.

Shift+F1
Turns the cursor into the What’s This? question mark. Shows the tip for an item 
underneath the cursor. The shortcut does not work with the online help.

Shift+F2 Shows tip for a selected item. The shortcut does not work with the online help.

General keyboard shortcuts

Opening menus and menu items

Shortcut Keys Result

Alt+<?>

Opens a menu where <?> is the underlined character of the menu you want to 
open. For example, Alt+F opens the menu File.
With the menu open, you will again find underlined characters. You can access 
these menu items directly by pressing the underlined character key. Where two 
menu items have the same underlined character, press the character key again 
to move to the next item.
There may be instances where an item in a menu has no underlined character. 
This will have to be clicked directly.

Esc Closes an open menu.

F6

Repeatedly pressing F6 switches the focus and circles through the following 
objects:

• Menu bar
• Every toolbar from top to bottom and from left to right
• Every free window from left to right
• Document

Shift+F6 Switches focus through objects in the opposite direction.

Ctrl+F6 Switches the focus to the document.

F10 or Alt Switches focus to the Menu bar and back.

Accessing a menu command
Press Alt or F6 or F10 to select the first item on the Menu bar (the File menu). With the 
right-arrow, the next menu to the right is selected; with the left-arrow, the previous menu. The 
Home and End keys select the first and the last item on the Menu bar.

The down-arrow opens a selected menu. An additional down-arrow or up-arrow moves the 
selection through the menu commands. The right-arrow opens any existing submenus.

Press Enter to run the selected menu command.

Running a toolbar command
Press F6 repeatedly until the first icon on the toolbar is selected. Use the right and left arrows to 
select any icon on a horizontal toolbar. Similarly, use the up and down arrows to select any icon 
on a vertical toolbar. The Home key selects the first icon on a toolbar, and the End key the last.
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Note

If the first object in the toolbar has an editable text field, like the Load URL or the 
Paragraph Style, the Home, End, left and right arrow keys work on the text instead. 
In these cases you can use Tab and Shift+Tab to navigate to other objects.

Press Enter to action the selected icon. If the selected icon normally demands a consecutive 
mouse action, such as inserting a rectangle, then pressing the Enter key is not sufficient: in these
cases press Ctrl+Enter.

Press Ctrl+Enter on an icon for creating a draw object. A draw object will be placed into the 
middle of the view, with a predefined size.

Press Ctrl+Enter on the Selection tool to select the first draw object in the document. If you want 
to edit, size, or move the selected draw object, first use Ctrl+F6 to move the focus into the 
document.

Navigating and selecting with the keyboard

You can navigate through a document and make selections with the keyboard.

• To move the cursor, press the key or key combination given in the following table.

• To select the characters under the moving cursor, additionally hold down the Shift key 
when you move the cursor.

Key Function Plus Ctrl key

Right, left arrow
keys

Moves the cursor one character to the left 
or to the right.

Moves the cursor one word to the left or
to the right.

Up, down arrow
keys

Moves the cursor up or down one line. Moves the cursor up or down one 
paragraph.

Home Moves the cursor to the beginning of the 
current line.

Moves the cursor to the beginning of the
document.

End Moves the cursor to the end of the current 
line.

Moves the cursor to the end of the 
document.

PgUp Scrolls up one page. Moves the cursor to the header.

PgDn Scroll down one page. Moves the cursor to the footer.

Controlling dialogs

When you open any dialog, one element (such as a button, an option field, an entry in a list box, 
or a checkbox) is highlighted or indicated by a dotted box around the field or button name. This 
element is said to have the focus on it.

Shortcut Keys Result

Enter Activates selected button. In most cases where no button is selected, 
Enter is equivalent to clicking OK.

Esc
Closes dialog without saving any changes made while it was open. In 
most cases, Esc is equivalent to clicking Cancel. When an open drop-
down list is selected, Esc closes the list.

Spacebar Checks an empty checkbox. Clears a checked checkbox.

Up, down arrow keys 
Moves focus up and down a list. Increases or decreases value of a 
variable. Moves focus vertically within a section of dialog.
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Shortcut Keys Result

Left, right arrow keys Moves focus horizontally within a section of a dialog.

Tab Advances focus to the next section or element of a dialog.

Shift+Tab Returns focus to the previous section or element in a dialog.

Alt+Down Arrow Shows items in a drop-down list.

Controlling macros

Shortcut Keys Result

Ctrl+* (multiplication sign: 
on number pad only)

Runs a macro field. (See Chapter 13 for more about macros.)

Shift+Ctrl+Q Stops a running macro.

Managing documents

Shortcut Keys Result

Ctrl+F4 or Alt+F4
Closes the current document. Closes LibreOffice when the last open document is
closed.

Ctrl+O Launches the Open dialog to open a document.

Ctrl+S
Saves the current document. If you are working on a previously unsaved file, the 
shortcut launches the Save As dialog.

Ctrl+N Creates a new document.

Shift+Ctrl+N Opens the Templates dialog.

Ctrl+P Opens the Print dialog to print the document.

Ctrl+Q Closes the application.

Del
In the Save and Open dialogs, deletes the selected files or folders. Items can be 
retrieved from the Recycle Bin (Trash), if your operating system has one.

Shift+Del
In the Save and Open dialogs, deletes the selected files or folders. Items are 
permanently deleted: they can not be retrieved from the Recycle Bin.

Backspace
In the Save and Open dialogs, shows contents of the current folder’s parent 
folder.

Editing

Shortcut Keys Result

Ctrl+X, Shift+Del Cuts selected items.

Ctrl+C, Ctrl+Ins Copies selected items to the clipboard.

Ctrl+V, Shift+Ins Pastes copied or cut items from the clipboard.

Ctrl+Shift+V Opens the Paste Special dialog.

Ctrl+Alt+Shift+V Pastes unformatted text.

Ctrl+A Selects all.

Ctrl+Z Undoes last action.

Ctrl+Y Redoes last action.

Ctrl+Shift+Y Repeats last command.
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Shortcut Keys Result

Ctrl+F Opens the Find toolbar.

Ctrl+H Opens the Find & Replace dialog.

Ctrl+Shift+F Searches for the last entered search term.

Ctrl+Shift+I Shows or hides the cursor in read-only text.

Selecting rows and columns in a database table

These shortcuts apply after the database table has been opened by Ctrl+Shift+F4.

Shortcut keys Result

Spacebar Toggles row selection, except when the row is in edit mode.

Ctrl+Space bar Toggles row selection.

Shift+Space bar Selects the current column.

Ctrl+Page Up Moves pointer to the first row.

Ctrl+Page Down Moves pointer to the last row.

Shortcut keys for drawing objects

Shortcut keys Result

Select the toolbar with F6. Use the 
Down Arrow and Right Arrow to 
select the desired toolbar icon and 
press Ctrl+Enter.

Inserts a drawing object.

Select the document with Ctrl+F6 and
press Tab.

Selects a drawing object.

Tab Selects the next drawing object.

Shift+Tab Selects the previous drawing object.

Ctrl+Home Selects the first drawing object.

Ctrl+End Selects the last drawing object.

Esc Ends drawing object selection.

Esc (in Handle Selection Mode) Exits Handle Selection Mode and returns to Object Selection 
Mode.

Up/Down/Left/Right Arrow Move the selected point (the snap-to-grid functions are 
temporarily disabled, but end points still snap to each other).

Alt+Up/Down/Left/Right Arrow Moves the selected drawing object one pixel (in Selection 
Mode).
Re-sizes a drawing object (in Handle Selection Mode).
Rotates a drawing object (in Rotation Mode).
Opens the properties dialog for a drawing object.
Activates Point Selection mode for the selected drawing 
object.

Spacebar Selects a point of a drawing object (in Point Selection mode) / 
Cancel selection.
The selected point blinks once per second.

Shift+Spacebar Selects an additional point in Point Selection mode.
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Shortcut keys Result

Ctrl+Tab Selects the next point of the drawing object (Point Selection 
mode).
In Rotation mode, the center of rotation can also be selected.

Ctrl+Shift+Tab Selects the previous point of the drawing object (Point 
Selection mode).

Ctrl+Enter A new drawing object with default size is placed in the center 
of the current view.

Ctrl+Enter at the Selection icon Activates the first drawing object in the document.

Esc Leaves the Point Selection mode. The drawing object is 
selected afterwards.
Edits a point of a drawing object (Point Edit mode).

Any text or numerical key If a drawing object is selected, switches to edit mode and 
places the cursor at the end of the text in the drawing object. A 
printable character is inserted.

Alt key while creating or scaling a 
graphic object

The position of the object’s center is fixed.

Shift key while creating or scaling a 
graphic object

The ratio of the object’s width to height is fixed.

Defining keyboard shortcuts

In addition to using the built-in keyboard shortcuts listed in this Appendix, you can define your 
own. See Chapter 14, Customizing LibreOffice, for instructions.

Further reading

For help with LibreOffice’s keyboard shortcuts, or using LibreOffice with a keyboard only, search 
the application Help using the “shortcut keys” or “accessibility” keywords.

Further reading | 9


	Copyright
	Contributors
	Feedback
	Publication date and software version

	Introduction
	Assistive tools in LibreOffice
	Tip for Macintosh users

	Getting help
	General keyboard shortcuts
	Opening menus and menu items
	Accessing a menu command
	Running a toolbar command

	Navigating and selecting with the keyboard
	Controlling dialogs
	Controlling macros
	Managing documents
	Editing
	Selecting rows and columns in a database table
	Shortcut keys for drawing objects
	Defining keyboard shortcuts
	Further reading

