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What is Draw?

LibreOffice Draw is a vector graphics drawing program, although it can also perform some 
operations on raster graphics (pixels). Using Draw, you can quickly create a wide variety of 
graphical images.

Vector graphics store and display an image as an assembly of simple geometric elements such 
as lines, circles, and polygons, rather than a collection of pixels (points on the screen). Vector 
graphics allow for easier storage and scaling of the image.

Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with 
components of the suite. If you create an image in Draw, reusing it in a Writer document is  
simple. For example, select and copy the drawing in Draw and then paste the image directly into 
your Writer document. You can also work with drawings directly from within Writer or Impress, 
using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive and, even though it was not designed to rival 
high-end graphics applications, it possesses more functionality than the drawing tools that are 
generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, 
dimensions and measurement display, connectors for making organization charts, 3D functions 
that enable small three-dimensional drawings to be created (with texture and lighting effects), 
drawing and page-style integration, and Bézier curves.

This chapter introduces some features of Draw and does not attempt to cover all of the Draw 
features. See the Draw Guide and LibreOffice Help for more information.

Figure 1: Draw main window
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Draw main window

Workspace
The large area in the center of the Draw main window (Figure 1) is the Workspace, where you 
create drawings. This drawing area can be surrounded with toolbars and information areas. The 
number and position of the visible tools vary with the task in hand and user preferences.

The maximum size of a drawing page in LibreOffice Draw is limited by your computer setup and 
the page size that you can set and use in your printer.

Pages pane
In Draw, you can split drawings over several pages. Multi-page drawings are used mainly for 
presentations. The Pages pane, on the left side of the Draw main window, gives an overview of 
the pages that you create in your drawing. If the Pages pane is not visible, go to View > Page 
Pane on the Menu bar. To make changes to the page order, drag and drop one or more pages.

Layers bar
A layer is a workplace where you insert drawing elements and objects. By default, the Workspace
consists of three layers (Layout, Controls, and Dimension Lines). The default layers cannot be 
deleted or renamed, but you can add layers when necessary.

Tabs for these layers appear in the Layers bar at the bottom of the Workspace. The Layers bar 
allows you to navigate between the layers and add layers as required or delete layers that you 
have created. For more information on layers, see “Working with layers“ on page 32.

Sidebar
The Sidebar has five main decks in Draw and is similar to the Sidebar in the other LibreOffice 
modules. To expand a deck, click on its icon on the tab bar on the right, or click on the Sidebar 
Settings icon at the top of the tab bar and select a deck from the drop-down list. If the Sidebar is 
not visible, go to View > Sidebar on the Menu bar.

Properties
Contains sections for object properties: Page, Character, Paragraph, Area, Glow, Shadow, 
Soft Edge, Line, and Position and Size. Available sections depend on the object selected.

Shapes
Provides quick selection of most items that are available on the Drawing toolbar: Lines and 
Arrows, Curves and Polygons, Connectors, Basic Shapes, Symbol Shapes, Block Arrows, 
Flowchart, Callouts, Stars and Banners, and 3D Objects.

Styles
Here you can edit and apply Drawing Styles to objects within your drawing. When you edit 
or modify a style, the changes are automatically applied to all of the elements formatted 
using that style. In Draw, Presentation Styles are not available.

Gallery
On the Gallery deck, you can insert an object into a drawing either as a copy or as a link. 
See the Draw Guide for more information on creating links to objects and files. The Gallery 
is divided into categories: Arrows, BPMN (Business Process Model and Notation), Bullets, 
Diagrams, Flowchart, Icons, Network, Shapes, and Sounds.

Navigator
On the Navigator deck, you can quickly move between pages in your drawing or select an 
object on the drawing. It is recommended to give pages and objects in your drawing 
meaningful names so that you can easily identify them when using the Navigator.
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Rulers
You should see rulers on the upper and left-hand sides of the workspace. If they are not visible, 
go to View > Rulers in the Menu bar. The rulers show the size of a selected object on the page 
using double lines (highlighted in Figure 2). You can also use the rulers to manage object 
handles and guide lines when positioning objects.

The page margins in the drawing area are also represented on the rulers. You can change the 
margins directly on the rulers by dragging them with the mouse. The margin area is indicated by 
the grayed out area on the rulers as shown in Figure 2.

To change the measurement units of the rulers, right-click on a ruler and select the measurement
unit from the drop down list, as shown in Figure 3 for the horizontal ruler. The horizontal and 
vertical rulers can be set to different measurement units.

Figure 2: Rulers showing object size

Figure 3: Ruler measurement units

Status Bar
The Status Bar (Figure 4) is located at the bottom of the Workspace in all LibreOffice modules. It 
includes several Draw-specific fields, which are described where relevant in this chapter. For 
details on the contents and use of these fields, see Chapter 1, Introducing LibreOffice, in this 
guide and the Draw Guide.

Figure 4: Status Bar

To hide the Status Bar, go to View on the Menu bar and deselect Status Bar.
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Note

The measurement units shown on the Status Bar are set by going to Tools > 
Options > LibreOffice Draw > General on the Menu bar. These units may be 
different to the measurement units set for the rulers.

Toolbars
To display or hide the various toolbars used in Draw, go to View > Toolbars on the Menu bar and
select which toolbars you want to display. For more information, see the Draw Guide.

The three main toolbars used in Draw are:

• Standard – this toolbar is normally docked at the top of the Workspace when you open a 
Draw document (Figure 5).

• Line and Filling – this toolbar is normally docked at the top of the Workspace below the 
Standard toolbar. The Line and Filling toolbar (Figure 6) only becomes active when an 
object on the Workspace is selected.

• Drawing –  this toolbar is normally docked on the left side of the Workspace and contains
the tools required to draw objects in the Workspace (Figure 7).

The icons used for the tools on each toolbar depend on the computer operating system and how 
you have setup LibreOffice on your computer. For more information on how to setup LibreOffice, 
see Chapter 2, Setting Up LibreOffice.

Figure 5: Standard toolbar

Figure 6: Line and Filling toolbar

Figure 7: Drawing toolbar

Drawing basic shapes

Draw provides a wide range of shapes, located in palettes accessed from the Drawing toolbar or 
from the Shapes deck in the Sidebar (Figure 8). This section describes only a few of the basic 
shapes, including text, which are treated as objects in Draw. See the Draw Guide for a complete 
description of the basic shapes available.

Some of the icons on the Drawing toolbar will change according to the shape that has been 
selected. Some tools on a toolbar have extra tool palettes available and these are indicated by a 
small downward triangle ▼ to the right of the tool icon.

Note

When you draw a basic shape or select one for editing, the Information field in the 
status bar changes to reflect the present action. For example Line created, Text 
frame xxyy selected, and so on.
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Figure 8: Shapes deck on Sidebar

Figure 9: Line starting point

Straight lines
1) Use one of the following options to start drawing a line:

– Click on Insert Line on the Drawing toolbar (Figure 7 on page 8).

– Click the small downward triangle ▼ on the right of the Lines and Arrows tool on the 
Drawing toolbar and select Insert Line from the drop down list.

– Click on Insert Line in the Lines and Arrows section of the Shapes deck on the 
Sidebar (Figure 8).

2) Place the cursor at the point where you want to start the line and drag the mouse while 
keeping the mouse button pressed.

3) Release the mouse button at the point where you want to end the line. A selection handle 
appears at each end of the line, showing that this object is the currently selected object. 
The selection handle at the starting point of the line is slightly larger than the other 
selection handle as shown in Figure 9.
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Tip

To snap the end of a line to the nearest grid point, keep the Ctrl key pressed while 
drawing the line. However, if the Snap to Grid option on View > Snap Guides on 
the Menu bar has been selected, the Ctrl key deactivates the snap to grid.

To restrict the drawing angle of a line to a multiple of 45 degrees (0, 45, 90, 135, and 
so on), keep the Shift key pressed while drawing the line. However, if the option 
When creating or moving objects in the Constrain Objects section of Tools > 
Options > LibreOffice Draw > Grid has been selected, the Shift key deactivates 
this restriction.

To draw a line symmetrically outwards in both directions from the start point, keep 
the Alt key pressed while drawing the line. This lets you draw lines by starting from 
the middle of the line.

When a line is drawn, it uses default attributes. To change any of these attributes, select the line 
and use one of the following methods:

• Go to the Properties deck on the Sidebar and open the Line section (Figure 10). 

• Right-click on a line and select Line from the context menu to open the Line dialog 
(Figure 11).

• Go to Format > Line on the Menu bar to open the Line dialog.

• Use the tools Line Style, Line Width, and Line Color on the Line and Filling toolbar 
(Figure 6 on page 8).

Figure 10: Line section in Properties 
deck on Sidebar
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Figure 11: Line dialog

Arrows
Arrows are drawn like lines. Draw classifies arrows as a subgroup of lines, that is lines with 
arrowheads. The information field on the Status Bar shows them only as lines.

1) Use one of the following options to start drawing an arrow:

– Click the small downward triangle ▼ on the right of the Lines and Arrows tool on the 
Drawing toolbar (Figure 7 on page 8) and select the type of arrow you require from the
sub-toolbar (Figure 12) that opens.

– Click on the type of arrow you require in the Lines and Arrows section of the Shapes 
deck on the Sidebar (Figure 8 on page 9).

Figure 12: Lines and Arrows
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2) Place the cursor at the point where you want to start an arrow and drag the mouse while 
keeping the mouse button pressed. The arrowhead is drawn at the end point of the arrow 
when you release the mouse button.

Tip

To snap the end of an arrow to the nearest grid point, keep the Ctrl key pressed while
drawing the arrow. However, if the Snap to Grid option on View > Snap Guides on 
the Menu bar has been selected, the Ctrl key deactivates the snap to grid.

To restrict the drawing angle of an arrow to a multiple of 45 degrees (0, 45, 90, 135, 
and so on), keep the Shift key pressed while drawing the arrow. However, if the 
option When creating or moving objects in the Constrain Objects section of Tools 
> Options > LibreOffice Draw > Grid has been selected, the Shift key deactivates 
this restriction.

To draw an arrow symmetrically outwards in both directions from the start point, keep
the Alt key pressed while drawing the arrow. This lets you draw arrows by starting 
from the middle of the arrow.

Note

Hovering the mouse cursor over each of type of line or arrow available will tell you 
the type of line or arrow each tool will draw.

Note

The icon for the Lines and Arrows tool used most recently will already be selected 
on the Drawing toolbar. This makes it easier to use the same tool again.

Note

After drawing a line or arrow, you can change the line or arrow style by opening the 
Line dialog (Figure 11 on page 11) and using the options available on the Line Styles
or Arrow Styles pages.

Rectangles
1) Use one of the following options to start drawing a rectangle:

– Click on Rectangle on the Drawing toolbar (Figure 7 on page 8).

– Click the small downward triangle ▼ on the right of the Basic Shapes tool on the 
Drawing toolbar and select Rectangle from the sub-toolbar (Figure 13) that opens.

– Click on Rectangle in the Basic Shapes section of the Shapes deck on the Sidebar 
(Figure 8).

2) Place the cursor at the point where you want to start drawing the rectangle and drag the 
mouse while keeping the mouse button pressed. As you draw the rectangle with the 
mouse cursor, the rectangle appears with its bottom right corner attached to the cursor.

3) To draw a rectangle from its center, position the cursor on the drawing, press the mouse 
button and then hold down the Alt key while dragging the cursor. The rectangle uses the 
start point where you first clicked the mouse button as its center.

12 | Chapter 7 Getting Started with Draw



Figure 13: Basic Shapes

Squares
1) Use one of the following options to start drawing a square:

– Click on Rectangle on the Drawing toolbar.

– Click the small downward triangle ▼ on the right of the Basic Shapes tool on the 
Drawing toolbar and select Square from the sub-toolbar (Figure 13) that opens.

– Click on Square in the Basic Shapes section of the Shapes deck on the Sidebar.

2) Place the cursor at the point where you want to start drawing the square and drag the 
mouse while keeping the mouse button pressed. If you have selected the Rectangle tool,
hold down the Shift key while you draw a square. As you draw the square, it appears with 
its bottom right corner attached to the cursor.

3) To draw a square from its center, position the cursor on the drawing, press the mouse 
button and then hold down the Alt key while dragging with the cursor. The square uses 
the start point where you first clicked the mouse button as its center.

Ellipses (ovals)
1) Use one of the following options to start drawing an ellipse:

– Click on Ellipse on the Drawing toolbar.

– Click the small downward triangle ▼ on the right of the Basic Shapes tool on the 
Drawing toolbar and select Ellipse from the sub-toolbar (Figure 13) that opens.

– Click on Ellipse in the Basic Shapes section of the Shapes deck on the Sidebar.

2) Place the cursor at the point where you want to start drawing the ellipse and drag the 
mouse while keeping the mouse button pressed. As you draw the ellipse, it appears with 
its bottom right corner attached to the cursor.

3) To draw an ellipse from its center, position the cursor on the drawing, press the mouse 
button and then hold down the Alt key while dragging with the cursor. The ellipse uses the
start point where you first clicked the mouse button as its center.
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Circles
1) Use one of the following options to start drawing a circle:

– Click on Ellipse on the Drawing toolbar.

– Click the small downward triangle ▼ on the right of the Basic Shapes tool on the 
Drawing toolbar and select Circle from the sub-toolbar (Figure 13) that opens.

– Click on Circle in the Basic Shapes section of the Shapes deck on the Sidebar.

2) Place the cursor at the point where you want to start drawing the circle and drag the 
mouse while keeping the mouse button pressed. If you have selected the Ellipse tool, 
hold down the Shift key while you draw a circle. As you draw the circle with the mouse 
cursor, the circle appears with its bottom right corner attached to the cursor.

3) To draw a circle from its center, position the cursor on the drawing, press the mouse 
button and then hold down the Alt key while dragging with the cursor. The circle uses the 
start point where you first clicked the mouse button as its center.

Dimension lines
Dimension lines display a measurement of an object in the drawing (Figure 14). The dimension 
line does not belong to the object itself, but it is usually placed close to it.

1) Use one of the following options to start drawing a dimension line:

– Click the small downward triangle ▼ on the right of the Lines and Arrows tool on the 
Drawing toolbar and select Dimension Line from the sub-toolbar that opens 
(Figure 12 on page 11).

– Click on Dimension Line in the Lines and Arrows section of the Shapes deck on the 
Sidebar).

2) Place the cursor at the point where you want to start the dimension line and drag the 
mouse while keeping the mouse button pressed. The dimension line is drawn and 
automatically calculates and displays the linear dimension.

3) To change the measurement unit used for dimension lines, go to Tools > Options > 
LibreOffice Draw > General on the Menu bar.

4) To change the display of a dimension line and its appearance, right-click on the 
dimension line and select Dimensions from the context menu to open the Dimension 
Line dialog (Figure 15).

5) Select the required options in Line and Legend, then click OK to save the changes and 
close the Line Dimension dialog.

Figure 14: Example of dimension lines
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Figure 15: Dimension Line dialog

Curves
1) Use one of the following options to start drawing a curve:

– Click the small downward triangle ▼ on the right of the Curves and Polygons tool on
the Drawing toolbar and select the type of curve from the sub-toolbar that opens 
(Figure 16).

– Click on the type of curve required in the Curves and Polygons section of the Shapes 
deck on the Sidebar.

Figure 16: Curves and Polygons

2) Click and hold the left mouse button to create the starting point of the curve, then drag 
from the starting point to draw a line. Release the mouse button and continue to drag the 
cursor to bend the line into a curve.
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3) Double-click to set the end point of the curve and fix the curve on the drawing. A filled 
curve automatically joins the last point to the first point, closing the curve and filling it with 
the selected fill color. A curve without fill will not be closed at the end of drawing the curve.

Note

A single click fixes the curve to the drawing and allows you to draw straight lines 
from the end of the curve. Each single click allows you to continue drawing straight 
lines. Double click to end drawing a curve with straight lines.

Polygons
1) Use one of the following options to start drawing a polygon:

– Click the small downward triangle ▼ on the right of the Curves and Polygons tool on
the Drawing toolbar and select the type of polygon from the sub-toolbar that opens 
(Figure 16).

– Click on the type of polygon required in the Curves and Polygons section of the 
Shapes deck on the Sidebar.

2) Click and hold the left mouse button to create the starting point of the polygon, then drag 
from the starting point to draw a line.

3) Release the mouse button and continue to drag the cursor to draw the next line for 
polygon, then click to mark the end point of the line and to start drawing another line. 
Holding the Shift key down while drawing lines, restricts the angles used in the polygon to
45° or 90°. 

4) Double-click to set the end point of the polygon and fix the polygon on the drawing. A 
filled polygon automatically joins the last point to the first point, closing the polygon and 
filling it with the selected fill color. A polygon without fill will not be closed at the end of 
drawing the polygon.

Polygons 45°
A polygon 45° is drawn using the same procedure as polygons, but the angles between lines are 
restricted to 45° or 90°. This restriction of angles cannot be changed.

A filled polygon 45° automatically joins the last point to the first point, closing the polygon and 
filling it with the selected fill color.

Freeform lines
Drawing freeform line tools is similar to drawing with a pencil on paper.

1) Use one of the following options to start drawing a freeform line:

– Click the small downward triangle ▼ on the right of the Curves and Polygons tool on
the Drawing toolbar and select the type of freeform line from the sub-toolbar that 
opens (Figure 16).

– Click on the type of freeform line required in the Curves and Polygons section of the 
Shapes deck on the Sidebar.

2) Click and drag the cursor to create the freeform line shape you require.

3) Release the mouse button when you are satisfied with your freeform line and the drawing 
is completed. A filled freeform line automatically joins the last point to the first point, 
closing the freeform line and filling it with the selected fill color.
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Glue points and connectors

Glue points
All Draw objects have glue points, which are not normally displayed. Object glue points 
(Figure 17) become visible on an object when a connector is selected on the Drawing toolbar or 
in the Shapes deck on the Sidebar.

Most objects have four glue points. You can add more standard glue points and glue points with a
specific purpose using the Glue Points toolbar (Figure 18). If the Glue Points toolbar is not 
visible, go to View > Toolbars > Glue Points on the Menu bar to open the toolbar. For a more 
detailed description on adding and using glue points, see the Draw Guide.

Glue points are not the same as the selection handles of an object. Selection handles are for 
moving or changing the shape of an object. Glue points are used to fix or glue a connector to an 
object so that when the object moves, the connector stays fixed to the object. 

Figure 17: Examples of object glue points

Figure 18: Glue Points toolbar

Connectors
Connectors are lines or arrows whose ends automatically snap to a glue point of an object. 
Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps. 
When objects are moved or reordered, the connectors remain attached to a glue point. Figure 19 
shows an example of using two objects and a connector. For a more detailed description of the 
use of connectors, see the Draw Guide.

Connectors can be accessed using one of the following methods:

• Click the small downward triangle ▼ on the right of the Connectors tool on the Drawing 
toolbar and select the type of connector from the sub-toolbar that opens (Figure 20).

• Click on the type of connector required in the Connectors section of the Shapes deck on 
the Sidebar.
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Figure 19: Example of using connectors

Figure 20: Connectors

Geometric shapes

Geometric shapes are similar to basic shapes and have been provided in Draw as a starting 
point when creating objects for a drawing. Geometric shapes are located on the Drawing toolbar 
and in the Shapes deck on the Sidebar.

Access geometric shapes using one of the following methods:

• Click on Shapes on the Sidebar to open the Shapes deck, then choose from the 
geometric shapes available (Figure 8 on page 9).

• Click the small downward triangle ▼ on the right of a geometric shape on the Drawing 
toolbar to open a sub-toolbar giving access to more geometric shape tools. See below 
for the tools available.

Using geometric shapes is similar to drawing rectangles, squares, ellipses or circles as explained
in “Drawing basic shapes” on page 8. For more information on geometric shapes, see the Draw 
Guide.

Note

The geometric shape displayed on the Drawing toolbar is the last geometric shape 
selected and used to draw an object.

Note

Text can be added to all geometric shapes. For more information, see “Using text” on
page 20 and the Draw Guide.
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Basic shapes

Symbol shapes

Block arrows

Flowchart
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Callouts

Stars and banners

3D objects

Using text

In Draw you can add, insert, and format text to a drawing, objects, and shapes as follows:

• As a dynamic text frame, which is an independent Draw object and expands as you add 
more text within the frame.

• As text within a previously drawn object. This integrates text within the object and is 
placed within the boundary rectangle that surrounds an object. This boundary rectangle 
is not dynamic and care must be taken so that your text does not go outside of the object
boundaries.

For more information on how to add, insert, and format text in a drawing or drawing objects, see 
the Draw Guide.

Text mode
Before any text can be added to a drawing, you need to activeate text mode using one of the 
following methods:

• Click on Insert Text Box on the Standard toolbar (Figure 5 on page 8).

• Choose Insert > Text Box on the Menu bar.

• Use the keyboard shortcut F2.

The Text Formatting toolbar (Figure 21) automatically opens when text mode is activated, 
replacing the Line and Filling toolbar (Figure 6 on page 8).
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Figure 21: Text Formatting toolbar

Adding text
When you add text to a drawing, a text box is automatically created to contain the text.

1) Activate text mode; see “Text mode” above.

2) Create a text box in the drawing using one of the following methods:

– Click at the approximate position where you want to place the text and a single line 
text box is created containing a flashing cursor. Start typing your text or paste copied 
into the text box. The width of a single line text box increases as you add text.

– Click at the approximate position where you want to place the text and drag the cursor
to the approximate width required for the text box creating a multi line text box. Start 
typing your text or paste copied into the text box. As you reach the horizontal limit of 
the text box, the text automatically word wraps inside the text box and the text box 
expands vertically as it fills.

The left corner of the Status Bar indicates that you are in text edit mode and the position 
of the cursor (Figure 22).

Note

When creating single line text boxes, multiple lines of text can be created by creating
a new paragraph inside the text box using the Enter key, or entering a line break in 
the text using Shift+Enter.

3) When you have finished typing text, click outside the text box to exit text mode. The Text 
Formatting toolbar closes and the Line and Filling toolbar opens in its original position.

4) To format and/or reposition the text box, see the Draw Guide for more information.

5) If required, select the text using the various tools on the Text Formatting toolbar 
(Figure 21) or in the Character, Paragraph, and Lists sections in the Properties deck of 
the Sidebar (Figure 23).

Figure 22: Text information on Status Bar
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Figure 23: Character, Paragraph and Lists sections
in Properties deck on Sidebar

Vertical text
By default, Draw is set for horizontal text only. The options for vertical text have to be switched on
and added as follows:

1) Go to Tools > Options > Language Settings > Languages on the Menu bar to open the
Languages page in the Options dialog.

2) In Default Languages for Documents, select the Asian option and Default – Chinese 
(simplified) is displayed in the scroll box.

3) Click Apply, then OK to close the Options dialog and save your changes.

4) Add the Insert Vertical Text tool to the Standard and/or Drawing toolbar as follows:

a) Right click in a blank area on the toolbar and select Visible Buttons from the context 
menu that opens.

b) Select Insert Vertical Text from the list of available tools and it will appear on the 
toolbar.

Formatting vertical and vertical text boxes is the same as horizontal text and horizontal text 
boxes. A vertical text box expands vertically as text is added into the box. For more information 
on vertical text, see the Draw Guide.
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Selecting objects

Direct selection
The easiest way to select an object is to click directly on it. For objects that are not filled, click on 
the object outline to select it. The first click selects an object and a second click deselects the 
selected object. To select or deselect more than one object, hold the Shift key down while 
clicking.

Selection by framing
You can also select several objects at once by dragging the mouse cursor around the objects. 
This draws a rectangle around the objects. Only objects that lie entirely within the rectangle will 
be selected. To select multiple objects by framing, the Select tool on the Drawing toolbar 
(Figure 7 on page 8) must be active.

Note

When you drag the mouse cursor to select multiple objects, the selection rectangle 
being drawn is known as a marquee.

Selecting hidden objects
If objects are located behind others and not visible, they can still be selected. When you select a 
hidden object, its selection handles will appear through the objects covering it.

• Windows or macOS only – select the object in front of the hidden objects, then press the
Alt key and click to select the hidden object. If there are several hidden objects, keep 
holding down the Alt key and click until you reach the object you want. To cycle through 
the objects in reverse order, use the keyboard combination Alt+Shift and click.

• Windows, macOS or Linux – select the object in front of the hidden objects, then press 
the Tab key to cycle the selection through the objects in your drawing, stopping at the 
hidden object you want. To cycle through the objects in reverse order, use the keyboard 
combination Shift+Tab.

Arranging objects
In a complex drawing, several objects may be stacked on top of one another. You can rearrange 
the stacking order by moving an object forward or backward using one of the following methods:

• Select an object, go to Shape > Arrange on the Menu bar, or right-click on the object and
select Arrange from the drop down menu, then use one of the following options:

– Bring to Front (Ctrl+Shift++)

– Bring Forward (Ctrl++)

– Send Backward (Ctrl+-)

– Send to Back (Ctrl+Shift+-)

– In Front of Object

– Behind Object

– Reverse – clicking on this option reverses the order of the selected objects.

• Select an object, then select one of the Arrange tools on left of the Line and Filling 
toolbar (Figure 6 on page 8). When you hover the mouse cursor over one of the tools, its 
function is indicated.
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Positioning and adjusting objects

When positioning or changing the size of an object, check the information area of the Status Bar 
at the bottom of the Draw Workspace (Figure 24). From left to right, it shows what object is 
selected, its position on the drawing in X/Y coordinates and dimensions of the object. The 
measurement units are those selected in Tools > Options > LibreOffice Draw > General.

For more information on positioning and adjusting objects, see the Draw Guide.

Figure 24: Status Bar information when working with objects

Using zoom
To help in the positioning and adjustment of objects, Draw has a zoom function that reduces or 
enlarges the screen display of the current drawing. For example, zoom in when placing objects 
onto your drawing for greater accuracy in positioning, or zoom out to see the complete drawing. 
You can control zooming using the Status Bar, Zoom & View Layout dialog, or Zoom toolbar. For 
more information on using zoom, see the Draw Guide.

Moving objects
To move an object (or a group of objects), select it and then click within the object borders and 
hold down the left mouse button while dragging the mouse. During movement, a ghost image of 
the object appears to help with repositioning (Figure 25). To locate the object at its new location, 
release the mouse button.

Figure 25: Moving objects

Adjusting object size
To change the size of a selected object (or a group of selected objects), move the mouse cursor 
to one of the selection handles. The cursor will change shape to indicate the direction of 
movement for that selection handle. As you change the size of the object, a ghosted outline of 
the object appears (Figure 26). When you have reached the desired size of the object, release 
the mouse button.

The results depend on which selection handle you use. To resize an object along one axis, use a 
side, top, or bottom handle. To resize along both axes, use a corner handle.
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Note

If you press the Shift key while resizing an object, the change in size will be carried 
out symmetrically on the two axes so that the aspect ratio of the object remains the 
same. This Shift key behavior works on all selection handles.

Figure 26: Adjusting object size

Rotating or slanting objects
To rotate or slant an object (or a group of objects), select an object and switch to rotation mode 
using one of the following methods:

• Right-click on the object and select Transformations > Rotate from the context menu.

• Click on the small downward triangle ▼ on the right of the tool icon for Transformations 
on the Standard or Line & Filling toolbar and select Rotate.

The selection handles change shape and color (Figure 27) and a center of rotation appears in the
center of the object. As you move the mouse cursor over the handles, the cursor changes shape 
to indicate the type of movement.

Figure 27: Rotating an object

Rotation
1) Click and hold the mouse button over a corner selection handle, then move the cursor to 

rotate the object. A ghost image of the object being rotated appears and the current angle
of rotation is shown in the Status Bar.

2) When the object is at the desired rotation angle, release the mouse button.

3) To change the angle of rotation, click on the rotation point and drag it to another position. 
This position can be outside of the object.
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Note

Press the Shift key while rotating or slanting an object and the movement is restricted
to 15° of movement.

Slanting
1) Click and hold the mouse button over a selection handle at the top, bottom, left side, or 

right side of an object.

2) Drag the selection handle to slant the object (Figure 28). A ghost image of the object 
being slanted appears and the current slant angle is shown in the Status Bar. The axis 
used for slanting an object is fixed to the edge of the object directly opposite the selection
handle being used to slant the object.

3) When the object is at the desired slant angle, release the mouse button.

Figure 28: Slanting an object

Flipping objects
Select an object so that the selection handles are displayed and flip the object vertically or 
horizontally using one of the following methods:

• Right-click on the object and select Flip > Vertically or Horizontally from the context 
menu.

• Go to Shape > Flip > Vertically or Horizontally on the Menu bar.

• Click on Vertically or Horizontally tool on the Line and Filling toolbar.

• Use Flip Vertically or Flip Horizontally tool in the Position and Size section on the 
Properties deck of the Sidebar.

However, the Flip tool on the Transformations toolbar (Figure 29) provides greater control over 
the flipping process. Use the Flip tool to change the position and angle that the object flips over, 
see the Draw Guide for more information.

Figure 29: Transformation toolbar
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Object distortion
Three tools on the Transformations toolbar (Figure 29) let you drag the corners and edges of an 
object to distort an object.

• Distort – distorts an object in perspective.

• Set in Circle (perspective) – creates a pseudo 3D effect.

• Set to Circle (slant) – creates a pseudo 3D effect. Despite the (slant) in the name of this 
tool, it operates differently to the slanting created by rotation.

In all three cases you are initially asked if you want to transform the object to a curve. This is a 
necessary first step, so click Yes. Then you can move the object handles to produce the desired 
effect. See the Draw Guide for more information on how to distort an object.

Dynamic gradients
You can control transparency gradients in the same manner as color gradients. Both types of 
gradient can be used together. With a transparency gradient, the direction and degree of the 
object fill color changes from opaque to transparent. In a color gradient, the fill changes from one 
color to another, but the degree of transparency remains the same. An example of a dynamic 
gradient is shown in Figure 30.

Two icons are present on the Transformations toolbar (Figure 29) to dynamically control 
transparency and color gradients – Interactive Transparency and Interactive Gradient. See 
the Draw Guide for more information on how to create transparencies and gradients in an object.

Figure 30: Dynamic gradient example

Duplication
Duplication makes copies of an object while applying a set of changes such as color or rotation to
the duplicates that are created. An example of duplication is shown in Figure 31. For more 
information on duplication, see the Draw Guide.

1) Click on an object or group of objects and open the Duplicate dialog (Figure 32) using 
one of the following methods:

– Go to Edit > Duplicate on the Menu bar.

– Go to Shape > Duplicate on the Menu bar.

– Use the keyboard shortcut Shift+F3.

2) Select the required number of copies, placement, enlargement, and colors from the 
options available.

3) Click OK to duplicate the object and close the Duplicate dialog.
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Figure 31: Duplication example

Figure 32: Duplicate dialog

Cross-fading
Cross-fading transforms one object shape to another object shape. Cross-fading only works 
when two objects are selected.

1) Select two differently shaped objects.

2) Go to Shape > Cross-fading on the Menu bar to open the Cross-fading dialog 
(Figure 33).

3) In Increments to determine the number of shapes between the two objects.

4) Select Cross-fading attributes to apply a gradual change of line and fill properties 
between the two objects.

5) Select Same orientation to apply a smooth transition between the two objects.

6) Click OK to carry out the cross-fading and close the Cross-fading dialog.
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The result is a new group of objects with the first object selected as the start object and the 
second object selected as the end object. For example, when the options in the Cross-fading 
dialog are applied to a rectangle and a diamond, the cross-fading produces the result shown in 
Figure 34.

Figure 33: Cross-fading dialog

Figure 34: Cross-fading example of two objects

Combining multiple objects

Using Draw, you can group or combine objects together allowing you to treat multiple objects as 
one object, or merge objects to form a new shape. For more information on grouping and 
combining objects, see the Draw Guide.

Grouping of objects is similar to putting objects into a container. You can move the objects as a 
group and apply global changes to the objects within the group. A group can always be undone 
(ungroup). Objects that make up a group can always be manipulated separately and retain their 
own individual properties.

Combining objects is a permanent merging of objects creating a new object. The original objects 
are no longer available as individual entities and cannot be edited as individual objects. Any 
editing of a combined object affects all the objects that were used when combination was carried 
out.

Grouping

Temporary grouping
A temporary grouping is when several objects are selected using one of the following methods:

• While holding down the Shift key, click on each object with the cursor to select it for the 
temporary group.

• Using the mouse, click and drag a rectangle (also known as a marquee) around the 
objects for the temporary group.
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Any changes to object parameters you carry out are applied to all of the objects within the 
temporary group. For example, you can rotate a temporary group of objects in its entirety.

To cancel a temporary grouping of objects simply click outside of the selection handles displayed 
around the objects.

Permanent grouping
A permanent grouping of objects can be created after selecting objects using one of the following
methods:

• Go to Shape > Group > Group on the Menu bar.

• Right-click on the selected objects and select Group from the context menu.

• Use the keyboard shortcut Ctrl+Shift+G.

When you deselect your selection, the objects remain grouped together. Any editing operations 
carried out on the group are applied to all objects within the group. If you click on one object in 
the group, the whole group is selected.

Editing within groups
You can edit an individual object in a group without ungrouping or breaking the group. After 
selecting the group, use one of the following methods to enter the group:

• Go to Shape > Group > Enter Group on the Menu bar.

• Right-click on the selected group and select Enter Group from the context menu.

• Use the keyboard shortcut F3.

• Double-click on the selected group.

When you have finished editing an individual object within a group, use one of the following 
methods to exit the group:

• Go to Shape > Group > Exit Group on the Menu bar.

• Right-click and select Exit Group from the context menu.

• Use the keyboard shortcut Shift+F3.

Ungrouping
To ungroup or break apart a permanent group of objects, use one of the following methods after 
selecting the group:

• Go to Shape > Group > Ungroup on the Menu bar.

• Right-click and select Ungroup from the context menu.

• Use the keyboard shortcut Ctrl+Alt+Shift+G.

Nesting groups
You can create a group of groups, which are more commonly known as nested groups. When 
you create nested groups, Draw retains the individual group hierarchy and remembers the order 
in which groups were selected. That is, the last individual group selected will be on top of all the 
other groups within a nested group.

Ungrouping and entering a nested group works in the same way as for individual groups.
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Combining objects
Combining objects is a permanent merging of objects, creating a new object. The original objects
are no longer available as individual entities and cannot be edited as individual objects. Any 
editing of a combined object affects all the objects that were used when combination was carried 
out. For more information on combining objects, see the Draw Guide.

After selecting the objects that you want to combine, use one of the following methods to create a
new object:

• Go to Shape > Combine on the Menu bar.

• Right-click on the objects and select Shapes > Combine from the context menu.

• Use the keyboard shortcut Ctrl+Shift+K.

Merging, subtracting, and intersection
After selecting several objects, the Merge, Subtract, and Intersect functions become available. 
These functions are similar to combining objects, but allow you to create a differently shaped 
object from the selected objects. The shape of the object depends on which function you use. 
See the Draw Guide for more information on how to use these functions.

Arranging, aligning, and distributing objects
In Draw you can arrange, align, and distribute selected objects in relation to each other:

• Arrange the position of an object by moving it either forward or backward in relation to the
order of objects.

• Align objects with respect to each other using Left, Centered, or Right for horizontal 
alignment and Top, Center, or Bottom for vertical alignment.

• Distribute objects so that the space between each of the objects is the same.

See the Draw Guide for more information on arranging and aligning objects.

Inserting and exporting images

Inserting
Draw contains a number of functions for editing images (also called pictures, raster graphics, or 
bitmaps). This includes the import and export of images, and conversion from one image format 
to another. For more information on working with images, see Chapter 11, Images and Graphics 
in this guide and the Draw Guide.

Draw includes a large range of filters so that it can read and display several image file formats. It 
also includes several tools for working with images, but does not have the same functionality as 
specialized programs like GIMP or Adobe Photoshop.

You can add images from several sources:

• Directly from a scanner (Insert > Media > Scan on the Menu bar).

• Created by another program, for example photographs from a digital camera (Insert > 
Image on the Menu bar).

• The LibreOffice Gallery; see Chapter 11, Images and Graphics.
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Exporting
Draw saves images as drawings in the Open Document Format (ODG). To save an image or the 
entire Draw file in another format, go to File > Export on the Menu bar and select a format from 
the drop-down list. The image formats that Draw can export in and save to are listed in Appendix 
B, Open Source, Open Standards, OpenDocument in this guide.

You can also export Draw files in HTML, XHTML, or PDF format from LibreOffice. For more 
information, see Chapter 10, Printing, Exporting, Emailing, and Signing.

HTML export uses a conversion wizard that creates as many web pages as there are pages in 
your Draw document. You can optionally choose to display pages in frames with a navigator and 
set an index page. For more information, see Chapter 12, Creating HTML Files.

Working with 3D objects

Although Draw does not match the functionality of specialized drawing or image editing 
programs, it is capable of producing and editing very good 3D drawings. For more information, 
see the Draw Guide.

You can quickly create a 3D object in Draw using one of the following methods:

• Select a 3D shape from the 3D Objects section in the Shapes deck on the Sidebar.

• Right-click on a 2D object and select Convert > To 3D or To 3D Rotation Object from 
the context menu.

• Right-click on a 2D object and select Format > 3D Effects on the Menu bar.

Working with layers

Using layers when creating complex drawings makes a drawing easier to navigate and edit. 
Placing a simpler drawing that is part of a complex drawing into its own layer makes editing 
easier. Any area of a layer that does not contain a drawing object is transparent and does not 
obscure any part of a complex drawing. You can add any number of layers to a drawing 
document. For more information on layers, see the Draw Guide.

A drawing in LibreOffice contains three default layers that you cannot delete or rename:

• Layout – is the default Workspace where objects are normally placed when a drawing is 
created.

• Controls – used for form controls that have been assigned an action. Objects on this 
layer are always in front of objects on other layers.

• Dimension Lines – is where the dimension lines are drawn. By switching the layer to 
show or hide, you can easily switch dimension lines on and off.

A layer can be set to one or all of the following attributes:

• Visible or hidden.

• Printable or not printable.

• Locked or unlocked.

To quickly toggle the attributes for a selected layer, use the following keyboard shortcuts:

• Shift+click – toggle between a layer being visible or hidden.

• Ctrl+click – toggle between a layer being locked or unlocked.

• Ctrl+Shift+click – toggle between a layer being printed or not printed.
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Adding layers
To add a layer to a drawing:

1) Use one of the following methods to open the Insert Layer dialog (Figure 35):

– Go to Insert > Layer on the Menu bar.

– Right click on the layer tabs at the bottom of the Workspace and select Insert Layer 
from the context menu.

Figure 35: Insert Layer dialog

2) Enter a meaningful Name, Title and Description for the new layer in the text boxes.

3) Select Visible if you want the layer to be visible in your drawing. When Visible is not 
selected, the layer is hidden and its name in the layer tab changes color to blue.

4) Select Printable if you want the layer to be printed when you print your drawing. Not 
printing is useful if you want use a draft layer for guides or annotations that you use in 
making the drawing, but do not want to appear in the final output. The name of a layer is 
underlined in the layer tab bar when the Printable option is turned off.

5) Select Locked to prevent any objects on this layer from deletion, editing, or moving. No 
additional objects can be added to a locked layer. Locking a layer is useful, for example, 
when a base plan is to be protected while adding a new layer with other details. The 
name of a locked layer is written in Italics in the layer tab bar.

6) Click OK to create the new layer and close the Insert Layer dialog. A new layer 
automatically becomes active when added to a drawing.

Note

Layers are added to the drawing in the order that they were inserted. The layer order
cannot be changed.
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Modifying layers
1) To modify a layer use one of the following methods and open the Modify Layers dialog. 

The Modify Layers dialog is similar in layout and options to the Insert Layers dialog 
(Figure 35).

– Right-click on the name tab of the layer and select Modify Layer from the context 
menu.

– Double-click on the layer tab.

– Go to Format > Layer on the Menu bar.

2) Make your changes to the layer, then click OK to save the changes and close the Modify 
Layers dialog.

Choosing colors

Note

For a more detailed description of the options available for color palettes and custom
colors, as well as more information on the difference between the CMYK and RGB 
color schemes, refer to the Draw Guide.

Figure 36: Color Palette

Color palette
To display the Color Palette that is currently in use (Figure 36), go to View > Color Bar on the 
Menu bar. To close the Color Palette, go to View on the Menu bar and deselect Color Bar.

Using the Color Palette, you can rapidly choose the color of the area or background, and lines of 
selected objects in your drawing.

• Left click on a color to change the color of the area or background of a selected object.

• Right click on a color to change the color of the lines in a selected object.

• Left-click or right-click on the box with the X at the bottom left of the Color Palette to 
select no color for the area or lines of a selected object.

Sidebar color
In the Area and Line sections in Properties deck on the Sidebar (Figure 37), you can change the 
color of the area or line of a selected object and the color palette as follows:

1) Select an object in your drawing.

2) Click on Properties on the Sidebar to open the Properties deck.

3) Open the Area and/or Line sections by clicking on the down pointing symbol ˅ on the 
section title bar.
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Figure 37: Sidebar Area and Line color

4) Change the color of an area in the Area section as follows:

a) Select Color from the Fill drop down list.

b) Click on the down pointing symbol ▼ next to the Fill Color box to open the color 
palette.

c) Click on a color to change the area color.

d) To change the color palette, click on the down pointing symbol ▼ at the top of the 
color palette and select a color palette from the drop down list.

5) Change the color of a line in the Line section as follows:

a) Click on the down pointing symbol ▼ next to the Line Color box to open the color 
palette.

b) Click on a color to change the area color.

c) To change the color palette, click on the down pointing symbol ▼ at the top of the 
color palette and select a color palette from the drop-down list.
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Toolbar color change
The Line and Filling and Drawing toolbars have the same two tools that can be used to change 
the color of an area (fill) or line – Fill Color and Line Color. These two tools are used in the 
same way as changing colors using the Area and Line sections on the Sidebar. See “Sidebar 
color” above for more information.

Inserting comments

You can insert comments into a drawing in a similar process to the one used in Writer and Calc.

Before using comments, you have to go to Tools > Options > LibreOffice > User Data and 
enter your name and initials. Your name and initials will then appear in the comment marker and 
in the Author field of the comment.

If more than one person edits the document, each author is automatically allocated a different 
background color.

1) Go to View > Comments on the Menu bar to show or hide the comment markers.

2) Go to Insert > Comment on the Menu bar. A small box containing your initials appears in 
the upper left-hand corner of your drawing with a larger text box beside it, as shown in 
Figure 38. Draw automatically adds your name and the date at the bottom of this text box.

3) Type or paste your comment into the text box.

4) If necessary, move the small comment markers to a different position on the drawing. 
Normally, the comment marker is placed on or near the object you refer to in the 
comment.

5) Apply basic formatting to the text by selecting it, right-clicking, and choosing from the 
context menu. On this menu, you can also delete the current comment, all the comments 
from the same author, or all the comments in the document.

Figure 38: Inserting comments
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