
Draw Guide 7.3

Chapter 12, 
User Interface Variants



Copyright

This document is Copyright © 2022 by the LibreOffice Documentation Team. Contributors are 
listed below. You may distribute it and/or modify it under the terms of either the GNU General 
Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative 
Commons Attribution License (https://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
To this edition

Peter Schofield Kees Kriek

To previous editions

Peter Schofield Jean Hollis Weber

Feedback
Please direct any comments or suggestions about this document to the Documentation Team’s 
mailing list: documentation@global.libreoffice.org

Note

Everything you send to a mailing list, including your email address and any other 
personal information that is written in the message, is publicly archived and cannot 
be deleted.

Publication date and software version
Published May 2022. Based on LibreOffice 7.3 Community.
Other versions of LibreOffice may differ in appearance and functionality.

Using LibreOffice on macOS
Some keystrokes and menu items are different on macOS from those used in Windows and 
Linux. The table below gives some common substitutions for the instructions in this document. 
For a detailed list, see the application Help.

Windows or Linux macOS equivalent Effect

Tools > Options on 
Menu bar

LibreOffice > Preferences 
on Menu bar

Access to setup options

Right-click
Ctrl+click and/or right-click 
depending on computer setup

Opens a context menu

Ctrl or Control  and/or ⌘ Cmd or Command Used with other keys

Alt  and/or ⌥ Alt or Option Used with other keys

F11 +⌘ T Open the Styles deck in the Sidebar

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/

https://documentation.libreoffice.org/en/
mailto:documentation@global.libreoffice.org
https://creativecommons.org/licenses/by/4.0/
https://www.gnu.org/licenses/gpl.html


Contents
Copyright............................................................................................................................2

Contributors..............................................................................................................................2

Feedback..................................................................................................................................2

Publication date and software version.......................................................................................2

Using LibreOffice on macOS.....................................................................................................2

Introduction........................................................................................................................4

Selecting user interface....................................................................................................4

Standard Toolbar UI..........................................................................................................5

Tabbed UI............................................................................................................................5
Fixed tabs.................................................................................................................................7

File tab.................................................................................................................................7
Home tab..............................................................................................................................8
Insert tab..............................................................................................................................9
Layout tab............................................................................................................................9
Review tab.........................................................................................................................10
View tab.............................................................................................................................12
Extension tab.....................................................................................................................12
Tools tab.............................................................................................................................12

Additional tabs........................................................................................................................13
Draw tab.............................................................................................................................13
Image tab...........................................................................................................................14
Object tab...........................................................................................................................15
Table tab.............................................................................................................................15
Media tab...........................................................................................................................15

Single Toolbar UI & Sidebar UI.......................................................................................16

Tabbed Compact UI.........................................................................................................16

Groupedbar Compact UI.................................................................................................17

Contextual Single UI........................................................................................................17

Chapter 12, User Interface Variants | 3



Introduction

By default, commands and tools used in LibreOffice Draw are grouped in a user interface 
consisting of cascading menus and toolbars. The functions and use of these cascading menus 
and toolbars are described in previous chapters of this user guide.

This chapter describes the user interface variants that are available for LibreOffice Draw. A user 
then has the option to select the user interface that suits their requirements and methods of 
creating drawings in LibreOffice Draw.

Note

When changing the user interface, the variant can be applied only to LibreOffice 
Draw, or applied to all the modules in LibreOffice.

Selecting user interface

To select a user interface variant or switching between the user interface variants:

1) Go to View > User Interface on the Menu bar to open the Select Your Preferred User 
Interface dialog (Figure 1).

2) In UI variants, select one of the variants. An example of the selected variant is shown in 
the Preview box, along with a short description.

3) Click on Apply to Draw to apply the variant selection to LibreOffice Draw only, or click on
Apply to All to apply the variant to all the LibreOffice modules. The LibreOffice window 
changes to match the selected variant.

4) Click Close to close the dialog.

Figure 1: Select Your User Preferred User Interface dialog

Note

If the option Enable experimental features has been selected in the Tools > 
Options > Advanced dialog, several more variants appear in UI variants. Being 
experimental, these variants are not described in this user guide.
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Figure 2: Standard Toolbar user interface in LibreOffice Draw 7.2

Note

In all the user interface variants, the Sidebar can be hidden or shown by clicking on 
the Hide/Show button on the left of the Sidebar,

Standard Toolbar UI

The Standard Toolbar user interface is the default view when LibreOffice is installed and the 
Workspace opened for the first time. Figure 2 shows an example of the default Workspace view
in LibreOffice Draw, which normally consists of the following.

• Menu bar at the top of the Workspace.

• Standard toolbar positioned below the Menu bar.

• Line and Filling toolbar positioned below the Standard toolbar.

• Drawing toolbar positioned vertically on the left of the Workspace.

• Sidebar positioned on the right of the Workspace.

For more information on the Draw Workspace, see Chapter 1, Introducing Draw.

Tabbed UI

The Tabbed user interface provides a familiar interface for users coming from proprietary office 
suites, for example Microsoft Office. This user interface is divided into tabs, where each tab 
displays a set of tools grouped by context. The context changes depending on the object 
selected and the LibreOffice module being used.

It includes a Menu bar, a Tab bar, and tool icons grouped in context that would be normally used 
in LibreOffice Draw. If the tool icons on a tab page do not fit into the width of the Draw window, a 
double chevron >> appears at the right end of the row. Click the double chevron >> to display 
more commands.
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Figure 3: Quick menu options

Figure 4: Icon bar

Figure 5: Customize dialog - Notebookbar page
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On Windows and Linux operating systems, the Menu bar can be hidden or displayed by clicking 
on Menubar at the left end of the Tab bar.

On the right of the Tab bar, a Quick menu (≡) (Figure 3) is available giving access to some 
commonly used commands and links. Some of the Quick menu items have submenus, indicated 
by a triangle ► on the right. The Quick menu is the same for all tabs.

On the left of the Tab bar, an icon bar (Figure 4) is available giving access to some commonly 
used tools – Menu bar; Open (Ctrl+O); Save (Ctrl+S);Undo (Ctrl+Z); Redo (Ctrl+Y).

The Tabbed user interface can be customized using the Notebookbar page of the Customize 
dialog (Figure 5) to show or hide the individual tools on the various tabs. For more information on
customization of LibreOffice, see the Getting Started Guide and the Writer Guide.

Note

When using the Tabbed user interface, the Draw toolbars are removed from view. If it
is necessary, toolbars can be opened and used by going to View > Toolbars on the 
Menu bar or Quick menu > Toolbars.

Fixed tabs
The fixed tabs in the Tabbed user interface for Draw are described on the following pages. The 
following figures show the left and right ends of the tabs separately so they are large enough to 
more easily see the commands.

File tab
The File tab (Figure 6) is a fixed tab providing commands to create new documents; open, save, 
print, and close documents; manage templates; export to PDF and EPUB; display document 
properties; add a digital signature; and sign an existing PDF. 

The File tab has two menus (Figures 7 and 8): File and Help. The File tab menu contains the 
same commands as the tools available on the tab. The Help tab menu provides links to a variety 
of resources.

Figure 6: Tabbed user interface - File tab
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Figure 7: File tab menu Figure 8: Help tab menu

Home tab
The Home tab (Figure 9) is a fixed tab providing commands to cut, copy, paste, and format text; 
insert common items (for example images, tables, charts); apply, update, and edit drawing styles;
and so on. The Home tab menu (Figure 10) at the right end of the Tab bar provides additional 
commands that are not on the tab.

Figure 9: Tabbed user interface - Home tab

Figure 10: Home tab menu
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Insert tab
The Insert tab (Figure 11) is a fixed tab providing tools to insert many commonly used items. The
Insert tab menu (Figure 12) at the right end of the Tab bar provides some of the same tools.

Figure 11: Tabbed user interface - Insert tab

Figure 12: Insert tab menu

Layout tab
The Layout tab (Figure 13) is a fixed tab providing tools to create a drawing layout. The Layout 
tab menu (Figure 14) at the right end of the Layout tab bar provides some of the same tools.
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Figure 13: Tabbed user interface - Layout tab

Figure 14: Layout tab menu

Review tab
The Review tab (Figure 15) is a fixed tab providing tools for spell checking text; inserting and 
deleting review comments; and redaction. The Review tab menu (Figure 16) provides additional 
text editing commands. Some of these commands appear only if Asian or Complex Text Layout
are selected in Tools > Options > Language Settings > Languages.

Figure 15: Tabbed user interface - Review tab
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Figure 16: Review tab menu

Figure 17: Tabbed user interface - View tab

Figure 18: View tab 
menu
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View tab
The View tab (Figure 17) is a fixed tab providing tools to display a drawing on screen. The View 
tab menu (Figure 18) provides additional tools relating to the display on a drawing on screen.

Extension tab
The Extension tab (Figure 19) is a fixed tab containing only the command to access the 
Extension Manager allowing the installation of extensions that are compatible for use in 
LibreOffice.

Figure 19: Tabbed user interface - 
Extension tab

Tools tab
The Tools tab (Figure 20) is a fixed tab providing several tools for macros; color replacer; media 
player. The Tools tab menu (Figure 21) provides some of the same commands, plus extra tools 
for organizing macros and dialogs; image map; data sources; filter settings; extension manager; 
and options.

Figure 20: Tabbed user interface - Tools tab

Figure 21: Tools tab 
menu
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Additional tabs
Additional tabs appear when an object in Draw is selected and are displayed between the View 
and Extension tabs. The illustrations show the left and right ends of the tabs separately so they 
are large enough to more easily see the commands.

Draw tab
The Draw tab (Figure 22) is only available when a draw object is selected in a drawing. It 
provides commands for editing, transforming, grouping, aligning, and distributing draw objects. 
The Draw tab menu (Figure 23) provides a similar set of commands for editing, transforming and 
converting draw objects.

Figure 22: Tabbed user Interface - Draw tab

Figure 23: Draw tab menu
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Image tab
The Image tab (Figure 24) only becomes available when an image is selected in a drawing such 
as a photograph, Fontwork, OLE object, or QR code. It provides tools for working with these 
images, including captions, cropping, borders and area styles and colors, anchors, wrapping, 
positioning, and filtering. The Image tab menu (Figure 25) provides links to dialogs for working 
with images.

Figure 24: Tabbed user interface - Image tab

Figure 25: Image tab menu

Figure 26: Tabbed user interface - Object tab
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Object tab
The Object tab (Figure 26) only becomes available when an object, such as a chart, is selected. 
It provides tools to position, resize, choose colors and borders for the selected object. The 
Object tab menu (Figure 27) provides extra tools to match the type of object selected.

Figure 27: Object tab 
menu

Table tab
The Table tab (Figure 28) only becomes available when a table is selected in a drawing. It 
provides tools to format a table to the drawing requirements. The Table tab menu (Figure 29) 
includes extra tools for editing a table.

Figure 28: Tabbed user interface - Table tab

Figure 29: Table tab menu

Media tab
The Media tab (Figure 30) only becomes available when a media object is selected in a drawing. 
It provides tools for positioning and running an audio or video file. The Media tab menu 
(Figure 31) includes extra tools for editing a media object.
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Figure 30: Tabbed user interface - Media tab

Figure 31: Media tab 
menu

Single Toolbar UI & Sidebar UI

When selected, the Single Toolbar and Sidebar user interfaces only show the Menu bar with no
toolbars. However, toolbars can be added to either of these user interfaces by going to View > 
Toolbars on the Menu bar and selecting the required toolbar from the options available. For 
more information on toolbars, see Appendix B, Toolbars in this guide and the Getting Started 
Guide.

Tabbed Compact UI

The Tabbed Compact user interface has the same tabs as the Tabbed user interface, but the 
commands on each tab are arranged as a single row of tools. Some of these tools have 
drop-down menus with extra options. Figure 32 shows an example of the File tab in the Tabbed 
Compact user interface.

The tab menu on the right of the Tabbed Compact user interface provides the same options as 
the tab menus in the Tabbed user interface, see “Tabbed UI” on page 5 for more information.

Figure 32: Tabbed Compact user interface - File tab
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Groupedbar Compact UI

The Groupedbar Compact user interface (Figure 33), with a Draw object selected, is divided 
into groups that contain commands organized as sets of tools and menus. The tools and menus 
that are available change to suit the type of object selected. Clicking on the double chevron >> 
displays more tools for editing an object.

The Groupedbar menu (Figure 34) on the right-hand end of this interface provides extra tools for
working with LibreOffice Draw, including convenient ways to change the user interface and 
access toolbars.

Figure 33: Groupedbar user interface with Draw object selected

Figure 34: Groupedbar 
menu

Contextual Single UI

The Contextual Single user interface displays a single toolbar to suit the type of object that has 
been selected. Figure 35 shows an example of Contextual Single user interface when a draw 
object is selected. Clicking on the double chevron >> displays more tools for editing an object.

Figure 35: Contextual Single user interface with Draw object selected
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