Copyright

This document is Copyright © 2012 by its contributors as listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/3.0/), version 3.0 or later. All trademarks in this guide belong to their legitimate owners.

Contributors

Peter Schofield          Martin Fox          John Cleland
Jean Hollis Weber       John A Smith       Hazel Russman

Feedback

Please direct any comments or suggestions about this document to:
documentation@global.libreoffice.org

Acknowledgments

This book is adapted and updated from OpenOffice.org 3.3 Draw Guide. The contributors to that book are listed on page 11.

Publication date and software version

Published 30 October 2012. Based on LibreOffice 3.5.
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copyright</td>
<td>2</td>
</tr>
<tr>
<td>Preface</td>
<td>7</td>
</tr>
<tr>
<td>Who is this book for?</td>
<td>8</td>
</tr>
<tr>
<td>What is in this book?</td>
<td>8</td>
</tr>
<tr>
<td>Where to get more help?</td>
<td>8</td>
</tr>
<tr>
<td>What you see may be different</td>
<td>9</td>
</tr>
<tr>
<td>Using LibreOffice on a Mac</td>
<td>10</td>
</tr>
<tr>
<td>What are all these things called?</td>
<td>10</td>
</tr>
<tr>
<td>Who wrote this book?</td>
<td>11</td>
</tr>
<tr>
<td>Acknowledgements</td>
<td>11</td>
</tr>
<tr>
<td>Frequently asked questions</td>
<td>12</td>
</tr>
</tbody>
</table>

## Chapter 1
### Introducing Draw
- Introduction                                                      | 13   |
- Draw workplace                                                    | 14   |
- Status bar                                                        | 16   |
- Toolbars                                                          | 17   |
- Drawing grid and guides                                           | 20   |
- Floating and moving toolbars                                      | 20   |
- Quick printing                                                    | 22   |
- Controlling printing                                              | 23   |
- Exporting to PDF                                                  | 27   |
- Exporting to other formats                                        | 27   |
- Exporting Draw documents as web pages                             | 28   |
- E-mailing documents                                               | 28   |

## Chapter 2
### Drawing Basic Shapes
- Creating simple drawings                                          | 29   |
- Custom shapes                                                      | 30   |
- Drawing basic shapes                                               | 30   |
- Glue points and connectors                                        | 38   |
- Drawing geometric shapes                                           | 39   |
- Adding text to drawings and objects                                | 41   |

## Chapter 3
### Working with Objects and Object Points
- Introduction                                                      | 43   |
- Selecting objects                                                 | 44   |
- Positioning and adjusting objects                                 | 45   |
- Using grid and snap functions                                    | 52   |
- Using guide lines                                                 | 57   |
- Changing form of regular shapes                                   | 57   |
- Curves and polygons                                               | 58   |
Chapter 4
Changing Object Attributes ................................................................. 67
Toolbars and menus ........................................................................... 68
Formatting lines ................................................................................. 70
Formatting fill area ........................................................................... 75
Creating new area fills ....................................................................... 79
Using styles ....................................................................................... 89
Applying special effects ..................................................................... 92

Chapter 5
Combining Multiple Objects ................................................................. 101
Grouping objects ............................................................................... 102
Combining objects ............................................................................. 103
Merging, subtracting, or intersecting objects ..................................... 105
Duplication and cross fading ............................................................... 107
Positioning objects ............................................................................ 110

Chapter 6
Editing Pictures ................................................................................ 113
Introduction ....................................................................................... 114
Importing graphics ............................................................................ 114
Exporting graphics ............................................................................ 117
Formatting raster objects ................................................................... 118
Picture toolbar .................................................................................. 118
Cropping ............................................................................................ 120
Graphic filter toolbar ......................................................................... 121
Replacing colors ................................................................................ 127
Conversion ........................................................................................ 128
Print options ....................................................................................... 131

Chapter 7
Working with 3D Objects ................................................................ 133
Introduction ....................................................................................... 134
Creating ............................................................................................. 134
Editing 3D objects ............................................................................. 138
Combining 3D objects ....................................................................... 151

Chapter 8
Connections, Flowcharts and Organization Charts ......................... 153
Connectors and glue points ............................................................... 154
Flowcharts ......................................................................................... 159
Organization charts ........................................................................... 161

Chapter 9
Adding and Formatting Text ............................................................... 163
Introduction ....................................................................................... 164
Using the text tool ............................................................................. 164
Using text boxes ................................................................................ 164
Using text with Draw objects ............................................................ 168
Preface
Who is this book for?

Anyone who wants to get up to speed quickly with LibreOffice Draw will find this guide valuable. You may be new to drawing software, or you may be familiar with another program.

What is in this book?

This book introduces the main features of LibreOffice Draw. Draw is a vector graphics drawing tool, although it can also perform some operations on raster graphics (pixels). Using Draw, you can quickly create a wide variety of graphical images.

A few examples of the drawing functions are: layer management, snap functions and grid-point system, dimensions and measurement display, connectors for making organization charts, 3D functions that enable small three-dimensional drawings to be created (with texture and lighting effects), drawing and page-style integration, and Bézier curves.

The Draw Guide is not a course book to be worked through from beginning to end. Rather, it is a reference work in which you can browse for guidance on particular topics.

Where to get more help?

This guide, the other LibreOffice user guides, the built-in Help system, and user support systems assume that you are familiar with your computer and basic functions such as starting a program, opening and saving files.

Help system

LibreOffice comes with an extensive Help system. This is your first line of support for using LibreOffice.

To display the full Help system, press F1 or go to Help > LibreOffice Help on the main menu bar. In addition, you can choose whether to activate Tips, Extended tips, and the Help Agent by going to Tools > Options > LibreOffice > General on the main menu bar.

If Tips are enabled, place the mouse pointer over any of the icons to see a small box (tooltip) with a brief explanation of the icon function. For a more detailed explanation, select Help > What's This? On the main menu bar and hold the pointer over the icon.

Free online support

The LibreOffice community not only develops software, but provides free, volunteer-based support. See Table 1 and this web page: http://www.libreoffice.org/get-help/

Users can get comprehensive online support from the community through mailing lists. Other websites run by users also offer free tips and tutorials. This forum provides community support for LibreOffice and other programs: http://user.services.openoffice.org/en/forum/

Paid support and training

Alternatively, you can pay for support services. Service contracts can be purchased from a vendor or consulting firm specializing in LibreOffice.
Table 1: Free support for LibreOffice users

<table>
<thead>
<tr>
<th>Free LibreOffice support</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>FAQs</td>
<td>Answers to frequently asked questions&lt;br&gt;<a href="http://www.libreoffice.org/get-help/faq/">http://www.libreoffice.org/get-help/faq/</a>&lt;br&gt;<a href="http://wiki.documentfoundation.org/Faq">http://wiki.documentfoundation.org/Faq</a></td>
</tr>
<tr>
<td>Mailing lists</td>
<td>Free community support is provided by a network of experienced users&lt;br&gt;<a href="http://www.libreoffice.org/get-help/mailing-lists/">http://www.libreoffice.org/get-help/mailing-lists/</a></td>
</tr>
<tr>
<td>International support</td>
<td>The LibreOffice website in your language.&lt;br&gt;<a href="http://www.libreoffice.org/international-sites/">http://www.libreoffice.org/international-sites/</a>&lt;br&gt;International mailing lists&lt;br&gt;<a href="http://wiki.documentfoundation.org/Local_Mailing_Lists">http://wiki.documentfoundation.org/Local_Mailing_Lists</a></td>
</tr>
<tr>
<td>Accessibility options</td>
<td>Information about available accessibility options.&lt;br&gt;<a href="http://www.libreoffice.org/get-help/accessibility/">http://www.libreoffice.org/get-help/accessibility/</a></td>
</tr>
</tbody>
</table>

What you see may be different

Illustrations

LibreOffice runs on Windows, Linux, and Mac OS X operating systems, each of which has several versions and can be customized by users (fonts, colors, themes, window managers). The illustrations in this guide were taken from a variety of computers and operating systems. Therefore, some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may be differ because of the settings selected in LibreOffice. You can either use dialogs from your computer system (default) or dialogs provided by LibreOffice. To change to using LibreOffice dialogs:

1) On Linux and Windows operating systems, go to **Tools > Options >LibreOffice > General** on the main menu bar to open the dialog for general options.
2) On a Mac operating system, go to **LibreOffice > Preferences > General** on the main menu bar to open the dialog for general options.
3) Select **Use LibreOffice dialogs in Open/Save dialogs and/or Print dialogs** to display the LibreOffice dialogs on your computer display.
4) Click **OK** to save your settings and close the dialog.

Note

On a Windows computer system there is an option **Show ODMA DMS dialogs first** in Open/Save dialogs. This allows you to use the Open Document Management API (ODMA, a computer industry standard interface) to manage documents allowing users to store, retrieve, and share them with security and version control using a Document Management System (DMS).
Icons

The icons used to illustrate some of the many tools available in LibreOffice may differ from the ones used in this guide. The icons in this guide have been taken from a LibreOffice installation that has been set to display the Galaxy set of icons.

If you wish, you can change your LibreOffice software package to display Galaxy icons as follows:

1) On Linux and Windows operating systems, go to Tools > Options > LibreOffice > View on the main menu bar to open the dialog for view options.
2) On a Mac operating system, go to LibreOffice > Preferences > View on the main menu bar to open the dialog for view options.
3) In User interface > Icon size and style select Galaxy from the options available in the drop down list.
4) Click OK to save your settings and close the dialog.

**Note**

Some Linux operating systems, for example Ubuntu, include LibreOffice as part of the installation and may not include the Galaxy icon. You should be able to download the Galaxy icon set from the software repository for your Linux operating system.

Using LibreOffice on a Mac

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click and/or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>Command</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+Command+F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>Command+T</td>
<td>Open the Styles and Formatting window</td>
</tr>
</tbody>
</table>

What are all these things called?

The terms used in LibreOffice for most parts of the user interface (the parts of the program you see and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for most other programs.

A dialog is a special type of window. Its purpose is to inform you of something, or request input from you, or both. It provides controls for you to use to specify how to carry out an action. The technical names for common controls are shown in Figure 1; not shown is the list box (from which you select an item). In most cases we do not use the technical terms in this book, but it is useful to know them because the Help and other sources of information often use them.
Figure 1: Dialog showing common controls

1) Tabbed page (not strictly speaking a control).
2) Radio buttons (only one can be selected at a time).
3) Checkbox (more than one can be selected at a time).
4) Spin box (click the up and down arrows to change the number shown in the text box next to it, or type in the text box).
5) Thumbnail or preview.
6) Drop-down list from which to select an item.
7) Push buttons.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog remains open. When you close the dialog after use (usually, clicking OK or another button saves your changes and closes the dialog), then you can again work with your document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog and your document. An example of this type is the Find & Replace dialog.

Who wrote this book?

This book was written by volunteers from the LibreOffice community. Profits from sales of the printed edition will be used to benefit the community.

Acknowledgements

This book is adapted and updated from OpenOffice.org 3.3 Draw Guide. The contributors to that book are:

Agnes Belzunce, Daniel Carrera, Martin Fox
Thomas Hackert, Regina Henschel, Peter Hillier-Brook
Jared Kobos, Hazel Russman, Gary Schnabl
Bernd Schukat, Wolfgang Uhlig, Jean Hollis Weber
Claire Wood, Linda Worthington
Frequently asked questions

How is LibreOffice licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Lesser General Public License (LGPL). The LGPL license is available from the LibreOffice website: http://www.libreoffice.org/download/license/

May I distribute LibreOffice to anyone?
Yes.

How many computers may I install it on?
As many as you like.

May I sell it?
Yes.

May I use LibreOffice in my business?
Yes.

Is LibreOffice available in my language?
LibreOffice has been translated (localized) into over 40 languages, so your language probably is supported. Additionally, there are over 70 spelling, hyphenation, and thesaurus dictionaries available for languages, and dialects that do not have a localized program interface. The dictionaries are available from the LibreOffice website at: www.libreoffice.org.

How can you make it for free?
LibreOffice is developed and maintained by volunteers and has the backing of several organizations.

How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you do not need to be a programmer. To start, check out this webpage: http://www.documentfoundation.org/contribution/

May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement at the beginning of this book. You do not have to request special permission. In addition, we request that you share with the project some of the profits you make from sales of books, in consideration of all the work we have put into producing them.
Chapter 1

Introducing Draw
**Introduction**

Draw is a vector graphics drawing tool, although it can also perform some operations on raster graphics (pixels). Using Draw, you can quickly create a wide variety of graphical images.

Vector graphics store and display a picture as simple geometric elements such as lines, circles, and polygons rather than as a collection of pixels (picture elements or points on the screen). This permits simpler storage and supports precise scaling of the picture elements.

Draw is fully integrated into the LibreOffice suite and this simplifies exchanging graphics with all components of the suite. For example, if you create an image in Draw, reusing it in a Writer document is as simple as copying and pasting the image. You can also work with drawings directly from within Writer or Impress using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive and, even though it was not designed to rival high-end graphics applications, it possesses significantly more functionality than the drawing tools that are generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, dimensions and measurement display, connectors for making organization charts, 3D functions that enable small three-dimensional drawings to be created (with texture and lighting effects), drawing and page-style integration, and Bézier curves.

This Draw Guide is not a course book to be worked through from beginning to end. Rather, it is a reference work in which you can browse for guidance on particular topics.

This document describes only the functions associated with Draw. Some concepts, such as file management or the way the LibreOffice environment works, are mentioned only briefly; they are covered in more detail in the Getting Started guide.

**Draw workplace**

The main components of the Draw interface or workspace are shown in Figure 2.

The large area in the center of the window is where you make the drawings. You can surround the drawing area with toolbars and information areas. The number and position of the visible tools vary with the task in hand and user preferences. Therefore your setup may look different. For example, many users put the main Drawing toolbar on the left-hand side of the workspace and not at the bottom, as shown in Figure 2.

You can split drawings in Draw over several pages. Multi-page drawings are used mainly for presentations. The Pages pane, on the left side of the Draw workspace in Figure 2 gives an overview of the pages that you create. If the Pages pane is not visible on your setup, you can enable it by going to View > Page Pane on the main menu bar. To make changes to the page order, just drag and drop one or more pages.

In LibreOffice Draw, the maximum size of a drawing page is 300 cm by 300 cm.

**Rulers**

You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If they are not visible, you can enable them by selecting View > Ruler in the main menu bar.

The rulers show the size of a selected object on the page using double lines (highlighted in Figure 3). When no object is selected, they show the location of the mouse pointer, which helps to position drawing objects more accurately.
You can also use the rulers to manage object handles and guide lines, making it easier to position objects.

The page margins in the drawing area are also represented on the rulers. You can change the margins directly on the rulers by dragging them with the mouse. The margin area is indicated by the grayed out area on the rulers as shown in Figure 3.

To modify the measurement units of the rulers, which can be defined independently, right-click on the desired ruler, as illustrated for the horizontal ruler in Figure 4.
The default position of the zero for each of the rulers is located in the top left corner of the page where the left and top margins start. This zero position can be adjusted by clicking in the top left corner of the workspace where the horizontal and vertical rulers meet and dragging to a new zero position.

**Status bar**

The Status bar is located at the bottom of the Draw window and includes several Draw-specific fields (Figure 5).

- **Information area** shows which action is being carried out, or which object type is selected. **Position** and **Object size** show different information depending on whether objects are selected or not.
  - When no object is selected, the position numbers show the current position (X and Y coordinates) of the mouse cursor.
  - When an object is selected and being resized with the mouse, the object size numbers show the size of the object (width and height).

**Note** The sizes are given in the current measurement unit (not to be confused with the ruler units). This unit is defined in **Tools > Options > LibreOffice Draw > General**.

- If an object is selected, the position numbers shows the X and Y coordinates of the upper-left corner and the object size number pair displays the size of the object. These numbers do not relate to the object itself, but to the selection outline, which is the smallest possible rectangle that can contain the visible part or parts of the object; see **Chapter 3 Working with Objects and Object Points** for more information.
- When an object is selected, a double-click in either of these areas opens the **Position and Size** dialog; see **Chapter 4 Changing Object Attributes** for more information.
• **Unsaved changes** are indicated whenever any change is made to the document but not yet saved to disk.

• **Digital signature** indicates if the document has been digitally signed. A double-click or right-click in this area opens the Digital Signatures dialog. A document must be saved at least once before it can be digitally signed. After a document is digitally signed, an indicator appears in this area.

• **Slide number** shows the sequence number for the current drawing page and the total number of pages created for the drawing. If you select an object, the information enclosed by parentheses indicates on which layer the object is placed within the drawing. In the example shown in Figure 5, the object is on the Layout layer of Slide 1 and there is a total number of one slide in the drawing.

• **Page style** shows which template is being used for the drawing.

• **Zoom slider** changes the zoom percentage of how the drawing appears on the computer display. Clicking on the plus (+) sign increases zoom and on the minus (-) sign decreases zoom. You can also drag the slider to increase or decrease the zoom percentage. The vertical bar in the middle of the **Zoom** slider represents a zoom percentage of 100%.

• **Zoom percentage** shows the level of zoom as a percentage. Double-clicking on the zoom percentage opens the **Zoom & View Layout** dialog. Right clicking on the zoom percentage opens a menu where you can select a zoom level. See *Chapter 3 Working with Objects and Object Points* for more information on working with the zoom functions.

### Toolbars

You can display or hide the various Draw toolbars, according to your needs. To display or hide a toolbar, click **View > Toolbars**. On the menu that appears, choose which toolbars you want to display.

You can also select the icons or buttons that you want to appear on the toolbars. To change the visible icons or buttons on any toolbar, click the arrow at the right-hand end of the toolbar and select **Visible Buttons** from the drop-down menu. Visible icons or buttons are indicated by a shaded outline around the icon. Icons or buttons not visible are indicated by a plain icon as shown by the lower three icons in Figure 6. Click on an icon to hide or show it in the toolbar.

![Figure 6: Selection of visible toolbar icons](image)

*Chapter 1  Introducing Draw* 17
Standard toolbar

The Standard toolbar is the same for all LibreOffice components and is described in detail in the Getting Started Guide.

Figure 7: Standard toolbar

Drawing toolbar

The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary functions for drawing various geometric and freehand shapes, and for organizing them in the drawing. It is described in detail in Chapter 2, Drawing Basic Shapes.

Figure 8: Drawing toolbar

Line and Filling toolbar

The Line and Filling toolbar lets you modify the main properties of a drawing object. The icons and pull-down lists vary, according to the type of object selected. For example, to change the style of a line, click on the up and down arrows for Line Style and select the required style.

The available functions on the Line and Filling toolbar let you to change the color, style, and width of the line drawn, the fill color and style, and other properties of an object. The object must first be selected with a mouse click. If the selected object is a text frame, the Line and Filling toolbar changes to the Text Formatting toolbar (Figure 10).

Figure 9: Line and Filling toolbar

Text Formatting toolbar

The Text Formatting toolbar is very similar to the Formatting toolbar in Writer. A more detailed explanation of the functions on this toolbar can be found in Chapter 4, Changing Object Attributes. For information on adding and formatting text, see Chapter 9 Adding and Formatting Text.

Figure 10: Text Formatting toolbar

Color bar

The Color bar displays the current color palette. It lets you rapidly select the color of the various objects (lines, areas, and 3D effects) in your drawing. The first box in the panel corresponds to invisible (no color). If the Colors bar is not displayed go to View > Toolbars > Color Bar.
Choosing a color palette

You can access several specialized color palettes in Draw, as well as change individual colors to your own taste. This is done using the Area dialog (Figure 12) by selecting Format > Area on the main menu bar or clicking the Area icon on the Line and Filling toolbar (Figure 9). On the Area dialog, select the Colors tab.

To load another palette, click on the Load Color List icon. The file selector dialog asks you to choose one of the standard LibreOffice palettes (files with the file extension *.soc). For example, web.soc is a color palette that is adapted to creating drawings for placing in web pages. These colors will display correctly on workstations with screens capable of at least 256 colors.

A more detailed description of color and their options can be found in Chapter 10 Advanced Draw Techniques.

Options toolbar

The Options toolbar lets you activate or deactivate various drawing aids. The Options toolbar is not one of the toolbars displayed by default. To display it, select View > Toolbars > Options. The options are described briefly in Figure 14 and in greater detail in other chapters of this Draw Guide.
Drawing grid and guides

Draw offers a grid and snap lines as drawing aids and these can be turned on or off by clicking on the Display Grid or the Display Snap Lines icons on the Options toolbar. The grid points and the snap lines are displayed only on the screen and are not shown on a printed drawing or when the drawing is used in another LibreOffice program. The color, spacing, and resolution of the grid points can be individually chosen for each axis. This is described in more detail in Chapter 3 Working with Objects and Object Points.

Help lines when moving objects can be displayed and these are turned on or off by clicking on the Helplines While Moving icon on the Options toolbar. Showing the position of the object while moving it makes positioning the object much easier. If this function is activated, pairs of vertical and horizontal lines enclosing the object are shown while moving the object. These lines extend to the edges of the drawing area. This function is also described in detail in Chapter 3 Working with Objects and Object Points.

Draw also offers several snap functions to help you can position objects exactly in a drawing and these snap functions are described in detail in Chapter 3 Working with Objects and Object Points.

Floating and moving toolbars

Available toolsets

Many icons have a small triangle or arrowhead pointing downward to the right side of the icon. This indicates that this icon has additional tools available. Click on the triangle to display the full set of tools (Figure 15). You can “tear off” this toolset so it becomes a floating toolbar. Click the area at the bottom of the toolset, drag it across the screen to a location you want, and then release the mouse button.

To close a floating toolbar, click on the X on the right of the toolbar title.

| Note | When a toolset is made into a floating toolbar, the icon on the existing toolbar remains in the toolbar and always shows the last command you used. This means that the icon you see on your screen may differ from the icon shown in this guide. |
When you double-click on an icon on a toolbar, the command corresponding to that icon will become active. You can then repeat this action as often as you like. To exit from this mode, press the Esc key or click on another icon. Please note that this may not work for every icon on every toolbar.

**Standard toolbars**

When you open Draw, the default set of toolbars are already docked or fixed in their positions at the top and bottom of the workspace. This default set of toolbars normally are the **Standard**, **Line and Filling**, and **Drawing** toolbars. These toolbars can be undocked and become floating toolbars.

To undock a toolbar, move the mouse cursor to the far left of the toolbar and over the toolbar handle (Figure 16). The cursor will change shape, normally to a grabbing hand, but this is dependent on computer setup and operating system. Click and drag on the toolbar handle to move the toolbar until it becomes a floating toolbar. This floating-toolbar capability is common to all components of LibreOffice.

To dock a floating toolbar at the top of the Draw workspace, press and hold the Ctrl key then double click on the title of the toolbar. The toolbar will move into available space at the top of the Draw workspace.

An alternative method of docking a toolbar is to click in the toolbar title and drag the toolbar to the docked position that you require. This can be the top, bottom or one of the sides of the Draw workspace.

![Figure 16: Toolbar handles](image)
Customizing toolbars

You can customize toolbars in several ways. To show or hide icons defined for a toolbar, see Figure 6 on page 17.

To add functions to a toolbar, move tools between toolbars, or create new toolbars, select View > Toolbars > Customize, then select the Toolbars tab (Figure 17) and the toolbar you want to change. You can then select the desired tools for that toolbar.

Each toolbar has a different list of functions. For details, see the Getting Started Guide, which also describes how to customize menus.

Quick printing

To quickly print a document or drawing, click on the Print File Directly icon to send the entire document to the default printer that is defined for your computer.

Note

You can change the action of the Print File Directly icon to send the document to the printer defined for the document instead of the default printer for the computer. Go to Tools > Options > Load/Save > General and select the Load printer settings with the document option.
Controlling printing

For more control over printing, use the Print dialog (File > Print or Ctrl+P). The Print dialog (Figure 18) has four tabs where you can choose a range of options and these are described in the following sections.

Note

The options selected on the Print dialog apply to this printing of this document only. To specify default print settings for LibreOffice, go to Tools > Options > LibreOffice > Print.

![Figure 18. Print dialog](image)

General printing

On the General tab of the Print dialog (Figure 18), you can select:

- Which printer to use from the printers available in the Printer section.
- Which pages to print, number of copies to print, whether to collate multiple copies, and page order for printing in the Range and copies section.

Printing options

To access more printing options, click on the Options tab of the Print dialog (Figure 19). These printing options are self explanatory.

![Figure 19: Printing Options dialog](image)
Printing multiple pages on a single sheet

You can print multiple pages of a document on one sheet of paper. To do this:

1) Open the Print dialog and select the Page Layout tab (Figure 20).
2) In the Layout section, select from the drop-down list the number of pages to print per sheet. The preview panel on the right shows how the pages will look in the printed document.
3) When printing more than two pages per sheet, you can choose the order in which they are printed across and down the paper from the Order drop down list.
4) To distinguish each page on a sheet, select the Draw a border around each page option.
5) Click the Print button.

Selecting pages to print

In addition to printing a full document, you can choose whether to print individual pages, a range of pages, or a highlighted selection within a document.

To print an individual page:
1) Choose File > Print from the main menu bar or use the Ctrl+P key combination and select the General tab in the Print dialog (Figure 18).
2) In the Ranges and copies section, select the Pages option.
3) Enter the number of the page to print.
4) Click the Print button.

To print a range of pages:
1) Choose File > Print from the main menu bar or use the Ctrl+P key combination and select the General tab in the Print dialog (Figure 18).
2) In the Ranges and copies section, select the Pages option.
3) Enter the number of the pages to print (for example 1-4 or 1,3,7,11), or any combination of the two (for example: 1-4,5-9,10).
4) Click the Print button.

To print a selection from a page or multiple pages:
1) In the document, highlight the section of the page or pages to print.
2) Choose File > Print from the main menu bar or use the Ctrl+P key combination and select the General tab in the Print dialog (Figure 18).
3) In the Ranges and copies section, select the Selection option.
4) Click the Print button.
Printing a brochure or booklet

In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of paper, arranged so that when the printed pages are folded in half, the pages are in the correct order to form a booklet or brochure.

Tip
Plan your document so it will look good when printed half size; choose appropriate margins, font sizes, and so on. You may need to experiment.

Single sided printer

To print a brochure or booklet on a printer only capable of single sided printing:

1) Choose File > Print and in the Print dialog, click on the Properties button to open the Properties dialog (Figure 21).

2) Check the printer is set to the same orientation (portrait or landscape) as specified in the page setup for your document. Usually the orientation does not matter, but it does for brochures and booklets.

3) Click OK to return to the Print dialog.

4) Select the Page layout tab in the Print dialog (Figure 20).

5) Select the Brochure option (Figure 22).

6) In the Page sides section, select Back sides / left pages option from the drop-down list.

7) Click the Print button.

8) Take the printed pages out of the printer, turn the pages over, and put them back into the printer in the correct orientation to print on the blank side. You may need to experiment a bit to find out what the correct arrangement is for your printer.

9) In the Page sides section, select Front sides / right pages option from the drop down list.

10) Click the Print button.
**Double sided or duplex printer**

To print a brochure or booklet on a printer that is capable of double or duplex sided printing:

1. Choose **File > Print** and in the **Print** dialog, click on the **Properties** button to open the **Properties** dialog (Figure 21).
2. Check the printer is set to the same orientation (portrait or landscape) as specified in the page setup for your document. Usually the orientation does not matter, but it does for brochures and booklets.
3. From the **Duplex** drop down list, select **Long Edge** or **Long Side** printing. Actual options available for duplex printing depend on printer model and the computer system being used.
4. Click **OK** to return to the **Print** dialog.
5. Select the **Page layout** tab in the **Print** dialog (Figure 20).
6. Select the **Brochure** option (Figure 22).
7. In the **Page sides** section, select **All pages** option from the drop-down list.
8. Click the **Print** button.

**Printing in black and white or grayscale**

You may wish to print documents in black and white or grayscale on a color printer. However, some color printers may only allow you to print in color regardless of the settings you choose. More details can be found in the information that came with your printer.

![Figure 23: Printer Properties dialog](image)

To change the printer settings to print in black and white or grayscale:

1. Choose **File > Print** to open the **Print** dialog (Figure 18).
2. Click **Properties** to open the **Properties** dialog for the printer. The available choices available depend on printer model and computer operating system, but you should easily find options for the Color settings. An example of what you may see is shown in Figure 23.
3. The choices for color may include **black and white** or **grayscale**. Choose the required setting.
4. Click **OK** to confirm your choice and return to the **Print** dialog,
5. Click the **Print** button to print the document.
Tip

Grayscale is the best option if you have any colored text or graphics in the document. Colors will print in shades of gray giving more detail. When printing color in black and white some of this detail maybe lost.

To change the LibreOffice settings to print all color text and graphics as grayscale:

1) Choose Tools > Options > LibreOffice > Print.
2) Select the Convert colors to grayscale option. Click OK to save the change.
3) Open the Print dialog (File > Print).
4) Click the Print button to print the document.

To change the Draw settings to print all color text and graphics as black and white or grayscale:

1) Choose Tools > Options > LibreOffice Draw > Print.
2) In the Quality section, select either Grayscale or Black & white option.
3) Click OK to save the change.
4) Open the Print dialog (File > Print).
5) Click the Print button to print the document.

Exporting to PDF

LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file format is ideal for sending a file for someone else to view using Adobe Reader or other PDF viewers. The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few minor differences mentioned in this section.

Export directly as PDF

Click on the Export Directly as PDF icon on the Standard toolbar to export the entire document using your default PDF settings. You are asked to enter the file name and location for the PDF file, but you cannot choose page range, image compression, or other options.

Controlling PDF content and quality

For more control over the content and quality of the resulting PDF, go to File > Export as PDF to open the PDF Options dialog. Using this dialog you select the options using different pages for General, Initial View, User Interface, Links, and Security. When you have selected the appropriate settings, click on Export. In the following dialog, enter the location and file name of the PDF to be created, then click Save to export the file. See in the Getting Started guide for more information.

Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. If you cannot find what you want in File > Save As, look in File > Export. LibreOffice can export files in various formats and these are listed in the drop down list for File format. See Chapter 6 Editing Pictures for more information on exporting graphics.

To export a file in another format:

1) Specify a file name for the exported document in the File name text box.
2) Select the required format from the File format drop down list.
3) Click the Export button.
The content of the exported file will depend on the element(s) selected on the page. No selection results in the entire image being exported. For most export formats, only the image on the current page will be exported.

Exporting Draw documents as web pages

To export a multi-page Draw document to a series of web pages, choose **File > Export**, select **HTML Document** as the file type and the HTML Export wizard opens. Follow the prompts to create the web pages. If you wish, the wizard can generate a navigation aid to help in moving from page to page.

E-mailing documents

LibreOffice provides several ways to send documents quickly and easily as an e-mail attachment in OpenDocument format (LibreOffice default format), or as a PDF.

Documents can be sent from the LibreOffice menu only if a mail profile has been set up.

To email the current document in OpenDocument format:

1) Choose **File > Send > Document as E-mail**. LibreOffice opens your default e-mail program with the document attached.

2) In your e-mail program, enter the recipient, subject, and any text you want to add, then send the e-mail.

To email the current document as a PDF, choose **File > Send > E-mail as PDF**. LibreOffice creates a PDF using the default PDF settings and then opens your email program with the PDF file attached.

You can email a document to several recipients. For details, see the *Getting Started* guide.
Chapter 2
Drawing Basic Shapes
Creating simple drawings

You can create 2D and 3D objects in Draw. This chapter shows how to draw simple 2D objects. The following chapters describe how to work with and edit such objects. For more information on 3D objects, see Chapter 7 Working with 3D Objects in this guide.

All shapes, whether they are lines, rectangles, or more complicated shapes, are called objects. This is common notation in vector drawing software.

The drawing tools are found on the Drawing toolbar (Figure 24).

As described in Chapter 1 Introducing Draw, the Drawing toolbar is normally located at the bottom of the window. If you do not see it, you can activate it from the View > Toolbars menu. As with all the components of LibreOffice, you can undock the Drawing toolbar and place it wherever you want to on the Draw window as a floating toolbar. You can also configure toolbars by adding, moving, hiding, or deleting toolbar icons.

When you draw a shape, select one for editing or add text, the Information field in the status bar (Figure 25) changes to reflect the action taken or in progress. See Chapter 1 Introducing Draw for more information on the status bar.

Custom shapes

Draw also offers the ability to create custom shapes, which are the equivalent of Autoshares in Microsoft Office. Custom shapes differ in their properties and are dealt with separately in the relevant chapters of this guide. The main differences relate to the behavior of 3D objects and text handling. Text frames in Draw have their own geometric format.

Drawing basic shapes

Basic shapes, including text, are treated as objects in Draw. The various tools available for drawing basic shapes, from left to right on the Drawing toolbar, are given in Table 2.

Please note that some of the icons on the Drawing toolbar will change according to the shape that has been selected from the choice available. Available tools are indicated by a small triangle or arrow to the right of the icon. See “Drawing geometric shapes” on page 39 for information on the available shapes.
Table 2: Basic drawing tools

<table>
<thead>
<tr>
<th>Tool name</th>
<th>Tool name</th>
<th>Tool name</th>
<th>Tool name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select</td>
<td>Line</td>
<td>Line ends with arrow</td>
<td>Rectangle</td>
</tr>
<tr>
<td>Ellipse</td>
<td>Text</td>
<td>Vertical text</td>
<td>Curve</td>
</tr>
<tr>
<td>Connector</td>
<td>Lines and arrows</td>
<td>Basic shapes</td>
<td>Symbol shapes</td>
</tr>
<tr>
<td>Block arrows</td>
<td>Flowcharts</td>
<td>Callouts</td>
<td>Stars</td>
</tr>
</tbody>
</table>

**Drawing straight lines**

We begin with the drawing of the simplest element—a straight line.

Click on the **Line** icon and place the mouse pointer at the point where you want to start the line (Figure 26). Drag the mouse while keeping the mouse button pressed. Release the mouse button at the point where you want to end the line. A selection handle appears at each end of the line, showing that this object is the currently selected object. The selection handle at the starting point of the line is slightly larger than the other selection handle.

![Figure 26: Drawing a straight line](image)

Keeping the **Shift** key pressed while you draw a line restricts the drawing angle of the line to a multiple of 45 degrees (0, 45, 90, 135, and so on).

---

**Caution**

This is the default behavior of the **Shift** key. However, if the option *When creating or moving objects* in the **Snap position** section of **Tools > Options > LibreOffice Draw > Grid** has been selected, the action of the **Shift** key is the opposite. Lines will automatically be drawn at a multiple of 45 degrees *unless* the **Shift** key is pressed.

Keeping the **Ctrl** key pressed while drawing a line enables the end of the line to snap to the nearest grid point.

---

**Caution**

This is the default behavior of the **Ctrl** key. However, if the **Snap to Grid** option on the **View->Grid** menu has been selected, the **Ctrl** deactivates the snap to grid activity.
The spacing (resolution) of the grid points can be adjusted under Tools > Options > LibreOffice Draw > Grid. See Chapter 3 Working with Objects and Object Points for more information.

Holding down the Alt key while drawing a line results in the line extending outwards symmetrically in both directions from the start point. This lets you draw lines by starting from the middle of the line.

When a line is drawn, it uses default attributes. To change any of these attributes, select the line by clicking on it, then right-click and select Line to open the Line dialog (Figure 27). Line style, line width and line color can also be changed using the controls in the Line and Filling toolbar at the top of the workspace.
While you are working with a line (or any other element), you can use the information field on the Status bar to monitor the activity. A description of the current activity or selection is shown when you are working with elements. Figure 28 shows two examples.

**Drawing arrows**

Arrows are drawn like lines. In fact Draw classifies *arrows* as a subgroup of lines: lines with arrowheads. The information field on the status bar shows them only as lines. Click on the **Line Ends with Arrow** icon to draw an arrow. The arrow head is drawn at the end point of the arrow when you release the mouse button.

**Drawing different types of lines and arrows**

Click on the small triangle or arrow to the right of the **Lines and Arrows** icon on the Drawing toolbar to open a pop-up toolbar with ten tools for drawing lines and arrows. Alternatively, go to **View > Toolbars > Arrows** to open the Arrows toolbar as a floating toolbar (Figure 29 and Table 3). The icon for the tool used most recently will be shown on the Drawing toolbar to make it easier to use the same tool again.

After drawing the line, you can change the arrow style by clicking on the **Arrowheads** icon in the Line and Filling toolbar and select the arrow start and end options.

![Arrows toolbar](image)

*Figure 29: Arrows toolbar*

<table>
<thead>
<tr>
<th>Icon</th>
<th>Tool name</th>
<th>Icon</th>
<th>Tool name</th>
<th>Icon</th>
<th>Tool name</th>
<th>Icon</th>
<th>Tool name</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Line" /></td>
<td>Line</td>
<td><img src="image" alt="Line ends with arrow" /></td>
<td>Line ends with arrow</td>
<td><img src="image" alt="Line with arrow/circle" /></td>
<td>Line with arrow/circle</td>
<td><img src="image" alt="Line with arrow/square" /></td>
<td>Line with arrow/square</td>
</tr>
<tr>
<td><img src="image" alt="Line (45°)" /></td>
<td>Line (45°)</td>
<td><img src="image" alt="Line starts with arrow" /></td>
<td>Line starts with arrow</td>
<td><img src="image" alt="Line with circle/arrow" /></td>
<td>Line with circle/arrow</td>
<td><img src="image" alt="Line with square/arrow" /></td>
<td>Line with square/arrow</td>
</tr>
<tr>
<td><img src="image" alt="Dimension line" /></td>
<td>Dimension line</td>
<td><img src="image" alt="Line with arrows" /></td>
<td>Line with arrows</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Drawing rectangles or squares**

Drawing a rectangle is similar to drawing a straight line. Click on the **Rectangle** icon in the Drawing toolbar. As you draw the rectangle with the mouse cursor, the rectangle appears with the bottom right corner of the rectangle attached to the cursor.

Squares are rectangles with all sides of equal length. To draw a square, click on the **Rectangle** icon and hold down the Shift key whilst you draw a square.

**Note**

If the option *When creating or moving objects* has been selected in **Tools > Options > LibreOffice Draw > General**, the action of the Shift key is reversed. When the Rectangle tool is selected, a square is drawn. To draw a rectangle you have to press the Shift key when drawing. This Shift key reversal also applies when drawing ellipses and circles in “Drawing ellipses and circles” on page 34.
To draw a rectangle or square from its center rather than the bottom right corner, position your cursor on the drawing, press the mouse button and then hold down the Alt key while dragging with the cursor. The rectangle or square uses the start point (where you first clicked the mouse button) as the center.

With the rectangle or square selected, you can quickly change border style, line width, or color, and the type of fill color or fill pattern using the tools on the Line and Filling toolbar. For more information on changing the attributes of a rectangle or square, see Chapter 4 Changing Object Attributes.

**Drawing ellipses and circles**

To draw an ellipse (also called an oval), click on the Ellipse icon on the Drawing toolbar. A circle is an ellipse with both axes the same length. To draw a circle, click on the Ellipse icon and hold down the Shift key whilst you draw a circle.

To draw an ellipse or circle from its center, position your cursor on the drawing, press the mouse button and then hold down the Alt key while dragging with the cursor. The ellipse or circle uses the start point (where you first clicked the mouse button) as the center.

With the ellipse or circle selected, you can quickly change border style, line width, or color, and the type of fill color or fill pattern using the tools on the Line and Filling toolbar. For more information on changing the attributes of an ellipse or circle, see Chapter 4 Changing Object Attributes.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you first press and hold the Ctrl key down and then click on one of the icons for Line, Rectangle, Ellipse or Text, an object is drawn automatically in the center of the workspace area using default values. The object attributes can then be changed using the Line Fill toolbar or the information in Chapter 4 Changing Object Attributes. This only works if the icon has no associated toolbar; that is no triangle or arrow on the right side of the icon.</td>
</tr>
</tbody>
</table>

**Adding arc and segment tools to the Drawing toolbar**

If you have to draw arcs or segments (partial circles or ellipses), then you can add the Circles and Ovals toolbar (Figure 30) to the Drawing toolbar. The Circles and Ovals toolbar is an optional toolbar that requires you to customize the Drawing toolbar.

1) Go to View > Toolbars > Customize to open the Customize dialog (Figure 31). Alternatively, right click on an icon in the Drawing toolbar and select Customize Toolbar.
2) Make sure the Toolbars page of the Customize dialog is open, then select Drawing in the Toolbar field and click on Add.
3) In the Add Commands dialog (Figure 32), select Drawing in the Category list.
4) Select the first Ellipse command in the Commands list. The Description section at the bottom of the dialog will indicate that you have selected the command for the Circles and Ovals toolbar.
5) Click on Add and then click Close.
6) In the Customize dialog, make sure that the checkbox by the new Ellipse command is checked.

![Circles and Ovals toolbar](image-url)
7) Select the new Ellipse command and use the up and down arrow buttons to move it to the desired position on the Drawing toolbar.

8) Click **OK** to save the customized Drawing toolbar.

The new **Ellipse** icon ⬇️ appears on the Drawing toolbar with a small triangle or arrow to the right of it. Click on this triangle or arrow to open the Circles and Ovals toolbar (Figure 30). To make this toolbar into a floating toolbar, drag the toolbar onto the workspace area.
To remove the standard Ellipse icon from the Drawing toolbar, open the Customize dialog and deselect it in the Commands list. Alternatively, select the Ellipse command, click the Modify button and select Delete from the drop-down menu.

To return the Drawing toolbar to its default settings, open the Customize dialog. Click on the Toolbars button, select Restore Default Settings from the drop down list and click on the Yes button to reset the toolbar.

**Drawing arcs or segments**

1) To draw an arc or segment, select the appropriate icon in the Circles and Ovals toolbar (Figure 30).
2) Click and drag with the mouse cursor to create a guide circle or ellipse, then release the mouse button.
3) Move the cursor to the position where you want the arc or segment to start. The status bar indicates the angle in degrees.
4) Single-click on this point to start drawing the arc or segment.
5) Move the cursor to create the arc or segment. The status bar indicates the angle in degrees.
6) When you have drawn the arc or segment you require, single click once more to complete the arc or segment.

**Drawing curves or polygons**

To draw a curve or polygon click the Curve icon on the Drawing toolbar. Click on the triangle or arrow to the right of the icon to open the tools that are available (Figure 33 and Table 4).

<table>
<thead>
<tr>
<th>Icon</th>
<th>Tool name</th>
<th>Icon</th>
<th>Tool name</th>
<th>Icon</th>
<th>Tool name</th>
<th>Icon</th>
<th>Tool name</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Curve" /></td>
<td>Curve filled</td>
<td><img src="image" alt="Polygon" /></td>
<td>Polygon filled</td>
<td><img src="image" alt="Polygon" /></td>
<td>Polygon 45° filled</td>
<td><img src="image" alt="Freeform line" /></td>
<td>Freeform line filled</td>
</tr>
<tr>
<td><img src="image" alt="Curve" /></td>
<td>Curve</td>
<td><img src="image" alt="Polygon" /></td>
<td>Polygon</td>
<td><img src="image" alt="Polygon" /></td>
<td>Polygon 45°</td>
<td><img src="image" alt="Freeform line" /></td>
<td>Freeform line</td>
</tr>
</tbody>
</table>

If you move the mouse cursor over one of the icons, a tooltip pops up with a description of the function. For a more detailed description for handling Bézier curves, see Chapter 10 Advanced Draw Techniques.

**Curves**

Click and hold the left mouse button to create the starting point of your curve, then, while holding down the left mouse button, drag from the starting point to draw a line. Release the left mouse
button and continue to drag the cursor to bend the line into a curve. Click to set the end point of the curve and fix the line on the page. To continue with your line, drag the mouse cursor to draw a straight line. Each mouse click sets a corner point and allows you to continue drawing another straight line from the corner point. A double click ends the drawing of your line.

A filled curve automatically joins the last point to the first point to close off the figure and fills it with the current standard fill color. A curve without filling will not be closed at the end of the drawing.

**Polygons**
Click and draw the first line from the start point with the left mouse button held down. As soon as you release the mouse button, a line between the first and second points is drawn. Move the cursor to draw the next line. Each mouse click sets a corner point and allows you to draw another line. A double-click ends the drawing.

A filled polygon automatically joins the last point to the first point to close off the figure and fills it with the current standard fill color. A polygon without filling will not be closed at the end of the drawing.

**Polygons 45°**
Like ordinary polygons, these are formed from lines, but the angles between lines are restricted to 45 or 90 degrees.

| Note | Holding down the *Shift* key when drawing lines with the Curve or Polygon tools will also restrict the angles between the lines to 45 or 90 degrees. |

**Freeform lines**
Using the Freeform Line tools is similar to drawing with a pencil on paper. Press and hold the left mouse button and drag the cursor to the line shape you require. It is not necessary to end the drawing with a double-click, just release the mouse button and the drawing is completed.

If Freeform Line Filled is selected, the end point is joined automatically to the start point and the object is filled with the appropriate color.

![Figure 34: Gluepoints](image)

![Figure 35: Gluepoints toolbar](image)
Glue points and connectors

Glue points
All Draw objects have glue points, which normally are not displayed. Gluepoints become visible when the Connectors icon on the Drawing toolbar is selected.

Most objects have four gluepoints (Figure 34). You can add more glue points and customize glue points, using the Gluepoints toolbar (Figure 35). Go to View > Toolbars > Gluepoints to open the toolbar.

Glue points are not the same as the selection handles of an object. The handles are for moving or changing the shape of an object, as described in Chapter 3 Working with Objects and Object Points. Glue points are used to fix or glue a connector to an object so that when the object moves, the connector stays fixed to the object. For a more detailed description on the use of glue points, see Chapter 8 Connections, Flowcharts and Organization Charts.

Connectors
Connectors are lines or arrows whose ends automatically snap to a glue point of an object. Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps. When objects are moved or reordered, the connectors remain attached to a glue point. Figure 36 shows an example of two objects and a connector.

![Figure 36: A connector between two objects](image)

Draw offers a range of different connectors and connector functions. Click on the arrow next to the Connector icon to open the Connectors toolbar (Figure 37 and Table 5).

For a more detailed description of the use of connectors, see Chapter 8 Connections, Flowcharts and Organization Charts.

![Figure 37: Connectors toolbar](image)
Table 5: Connector tools

<table>
<thead>
<tr>
<th>Icon</th>
<th>Tool name</th>
<th>Icon</th>
<th>Tool name</th>
<th>Icon</th>
<th>Tool name</th>
<th>Icon</th>
<th>Tool name</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Connector icon]</td>
<td>Connector</td>
<td>![Connector icon]</td>
<td>Connector ends with arrow</td>
<td>![Connector icon]</td>
<td>Connector with arrows</td>
<td>![Line icon]</td>
<td>Line connector</td>
</tr>
<tr>
<td>![Line icon]</td>
<td>Line connector ends with arrow</td>
<td>![Line icon]</td>
<td>Line connector with arrows</td>
<td>![Straight icon]</td>
<td>Straight connector</td>
<td>![Straight icon]</td>
<td>Straight connector ends with arrow</td>
</tr>
<tr>
<td>![Straight icon]</td>
<td>Straight connector with arrows</td>
<td>![Curved icon]</td>
<td>Curved connector</td>
<td>![Curved icon]</td>
<td>Curved connector ends with arrow</td>
<td>![Curved icon]</td>
<td>Curved connector with arrows</td>
</tr>
</tbody>
</table>

**Drawing geometric shapes**

The icons for drawing geometric shapes are located on the Drawing toolbar and each geometric shape is explained in the following sections. Clicking on the triangle or arrow to the right of the icon opens a floating toolbar giving access to the tools for that geometric shape.

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>The use of these tools for geometric shapes is similar to the tool used for drawing rectangles and squares. For more information, see “Drawing rectangles or squares” on page 33.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>The icons for geometric shapes displayed on the Drawing toolbar will change shape according to the last tool selected and used to draw an object.</td>
</tr>
</tbody>
</table>

**Basic shapes**

Click on the triangle or arrow to the right of the **Basic Shapes** icon to open the Basic Shapes toolbar for drawing basic shapes. This toolbar also includes a rectangle tool identical to the one already displayed on the Drawing toolbar.

![Basic Shapes toolbar]

*Figure 38: Basic Shapes toolbar*

**Symbol shapes**

Click on the triangle or arrow to the right of the **Symbol Shapes** icon to open the Symbol Shapes toolbar for drawing symbols.
Block arrows

Click on the triangle or arrow to the right of the Block Arrows icon to open the Block Arrows toolbar for drawing block arrows.

Flowcharts

Click on the triangle or arrow to the right of the Flowcharts icon to open the Flowchart toolbar for symbols used in drawing flowcharts. The creation of flowcharts, organization charts, and similar planning tools are further described in Chapter 9 Organization Charts, Flow Diagrams, and More.

Callouts

Click on the triangle or arrow to the right of the Callouts icon to open the Callouts toolbar for drawing callouts.

Stars and banners

Click on the triangle or arrow to the right of the Stars icon to open the Stars and Banners toolbar for drawing stars and banners.
Adding text to drawings and objects

In Draw you can add, insert and format text to a drawing, objects and shapes as follows:

- As a dynamic text frame, which is an independent Draw object and expands as you add more text within the frame.

- Text within a previously drawn object. This integrates text within the object and is placed within the boundary rectangle that surrounds an object. This boundary rectangle is not dynamic and care must be taken so that your text does not go outside of the object boundaries.

- For more information on how to add, insert and format text in a drawing or drawing objects, see Chapter 9 Adding and Formatting Text.
Chapter 3
Working with Objects and Object Points
**Introduction**

This chapter looks at the tools and functions that let you modify existing drawings. All of the functions apply to a selected object or a group of selected objects, which can be distinguished by selection handles on a rectangular frame that is large enough to contain the object. Where several objects are selected, the frame around the objects corresponds to the smallest rectangle that can contain all of the objects. This frame is called the selection rectangle.

| Note | The color and shape of the selection handles will change depending on the tool and function that has been selected to change the object properties. The color of the selection handles also depends on the computer operating system and how the computer has been set up. |

**Selecting objects**

**Direct selection**

The easiest way to select an object is to click directly on it. For objects that are not filled, click on the object outline to select it. One click selects; a second click deselects. To select or deselect more than one object, hold the shift button down while clicking.

**Selection by framing**

You can also select several objects at once by dragging the mouse cursor around the objects. This draws a rectangle around the objects, and only objects that lie entirely within the rectangle will be selected.

To select multiple objects by framing, the Select icon on the Drawing toolbar must be active.

| Note | When you drag the mouse cursor to select multiple objects, the selection rectangle being drawn is also known as a marquee. |

**Selecting hidden objects**

Even if objects are located behind others and not visible, they can still be selected. Hold down the Alt key and click on the object behind which the hidden object is located, then click again to select the hidden object. If there are several hidden objects, keep holding down the Alt key and clicking until you reach the object you want. To cycle through the objects in reverse order, hold down the Alt+Shift keys and click.

When you click on the selected object, its outline will appear briefly through the objects covering it.

| Note | Using the Alt key method works on computers using a Windows or Mac operating systems. On a computer using a Linux operating system the Tab key method, described below, has to be used. |

To select an object that is covered by another object using the keyboard, use the Tab key to cycle through the objects, stopping at the object you want to select. To cycle through the objects in reverse order, press Shift+Tab. This is a very quick way to reach an object, but it may not be practical if there a large number of objects in a drawing.
Arranging objects

In a complex drawing, several objects may be stacked on top of one another. To rearrange the stacking order by moving an object forward or backward, select an object, click Modify > Arrange on the main menu bar and select Bring Forward or Send Backward. Alternatively, right-click the object, select Arrange from the context menu, then Bring Forward or Send Backward.

The Arrange options are also available by clicking on the small triangle or arrow to the right of the Arrange icon on the Drawing toolbar. This opens the Position toolbar, giving access to the various arrangement options.

Positioning and adjusting objects

Using zoom

To help in the positioning and adjustment of objects, Draw has a zoom function that reduces or enlarges the screen display of the current drawing. For example, zoom in to place objects onto your drawing with greater position; zoom out to see the complete drawing. You can control zooming three ways: using the status bar, the Zoom dialog, or the Zoom toolbar.

Note

Zooming is handled differently on Unix, Linux, and Windows operating systems. A document saved with a 100% zoom factor in Windows is displayed at a larger zoom factor in Unix/Linux.

Status bar

The zoom controls are located on the right side of the status bar (Figure 44); these controls give you quick and easy access to zooming.

Figure 44: Status bar zooming

- Click on the minus sign to reduce the zoom factor.
- Click on the plus sign to increase the zoom factor.
- Click and hold on the slide control and move it to increase or decrease the zoom factor.
- Right-click on the zoom percentage number and select a zoom factor from the context menu that opens.

Figure 45: Zoom & View Layout dialog
• Double-click on the zoom percentage number and select a zoom factor from the Zoom & View Layout dialog (Figure 45) that opens.

**Zoom layout dialog**

Go to View > Zoom on the main menu bar to open the Zoom & View Layout dialog (Figure 45), where you can increase or reduce the zoom factor. The current zoom percentage is displayed on the status bar (Figure 44).

**Zoom factor**

Sets the zoom factor at which to display the current document and all documents of the same type that you open thereafter.

- **Optimal** – resizes the display to fit the width of the text in the document.
- **Fit width and height** – displays the entire page on your screen.
- **Fit width** – displays the complete width of the document page. The top and bottom edges of the page may not be visible.
- **100%** – displays the document at its actual size.
- **Variable** – enter the zoom factor at which you want to display the document. Enter a percentage in the box.

**Zoom toolbar**

Go to View > Toolbars > Zoom to open the Zoom toolbar (Figure 46). The tools available on this toolbar are shown in Figure 47.

- **Zoom In** – displays the slide at two times its current size. Click once on the tool, then move the cursor onto the object and click again. You can also select the Zoom In tool and drag a rectangular frame around the area you want to enlarge.
- **Zoom Out** – displays the drawing at half its current size each time the tool is clicked.
- **Zoom 100%** – displays the drawing at its actual size.
- **Zoom Previous** – returns the display of the drawing to the previous zoom factor you applied. You can also use the keyboard shortcut Ctrl +, (Comma).
- **Zoom Next** – undoes the action of the Previous Zoom command. You can also the keyboard shortcut Ctrl +, (Period).
- **Zoom Page** – displays the whole drawing on your screen.
- **Zoom Page Width** – displays the complete width of the drawing. The top and bottom edges of the slide may not be visible.
- **Optimal** – resizes the display to include all of the objects on the slide.
- **Object Zoom** – resizes the display to fit the object(s) you selected.
- **Shift** – moves the drawing within the Draw workspace. Place the cursor on the drawing and drag to move the drawing. When you release the cursor, the last tool you used is automatically selected.

![Zoom toolbar](image)

*Figure 46: Zoom toolbar*
Moving and adjusting object size

When moving an object or changing its size, check the left-hand area of the status bar at the bottom of the Draw window (Figure 48). The area on the left of the Drawing toolbar, from left to right, shows what object is selected, its position on the drawing in X/Y coordinates and dimensions of the object. The units of measurement are those selected in Tools > Options > LibreOffice Draw > General.

Moving objects

To move an object (or a group of objects), select it and then click within the object borders and hold down the left mouse button while dragging the mouse. During movement, the shape of the object appears as dotted lines to help with repositioning (Figure 49). To locate the object at its new location, release the mouse button.
Adjusting object size
To change the size of a selected object (or a group of selected objects), move the mouse cursor to one of the selection handles. The mouse cursor will change shape to indicate the direction of movement for that selection handle. As you change the size of the object, a ghosted outline of the object appears (Figure 50). When you have reached the desired size of the object, release the mouse button.

The results depend on which selection handle you use. To resize an object along one axis, use a side handle. To resize along both axes, use a corner handle.

![Figure 50: Adjusting object size](image)

Note
If you press the Shift key while resizing an object, the change in size will be carried out symmetrically with respect to the two axes so that the aspect ratio of the object remains the same. This Shift key behavior works on all selection handles. This is the default behavior of the Shift key. However, if When creating or moving objects has been selected in Tools > Options > LibreOffice Draw > Grid, the action of the Shift key is reversed: that is the aspect ratio will be preserved unless the Shift key is pressed.

Modifying an arc
The size of an arc can be changed by adjusting position of the start and end points of an arc.

Select an arc and click on the Points icon on the Drawing toolbar. Two larger handles appear at the start and end of the arc (Figure 51). When the mouse cursor hovers over one of these larger handles, the cursor changes shape, allowing you to adjust the position of either the start or end points of the arc.

![Figure 51: Modifying an arc](image)

Rotating and slanting an object

Rotating an object
To rotate an object (or a group of objects), select the object, then go to rotation mode using one of the following methods:

- Click on the object again. Do not double-click as this will cancel object selection.
To rotate an object:

- Click on the Rotate icon on the Drawing toolbar.
- Go to View > Toolbars > Mode and select the Rotate icon.

The selection handles will change shape and color (Figure 52). Also a center of rotation point will appear in the center of the object. As you move the mouse cursor over the handles, the cursor changes shape. The corner handles are for rotating the object, and the top, bottom and side handles are to shear or slant the object.

Move the mouse cursor to one of the corner handles and it normally changes to an arc with an arrow at each end. Click and hold the mouse button, then start to move the cursor to rotate the object. A dotted outline of the object being rotated appears and the current angle of rotation is shown in the status bar.

Note: Rotation works in a slightly different way for 3D objects because it occurs in a three dimensional space and not in a single plane. See Chapter 7 Working with 3D Objects for more information.

The rotation point is normally located at the center of an object. To change the position of the rotation point, click on the object with the mouse cursor and drag the object until the rotation point is at the desired position. This rotation point can even be outside of the object.

Note: If you press the Shift key while rotating an object, rotation will be restricted to 15° of movement. This is the default behavior of the Shift key. However, if When creating or moving objects has been selected in Tools > Options > LibreOffice Draw > Grid, the action of the Shift key is reversed: that is rotation will be restricted to 15° of movement unless the Shift key is pressed.

Slanting an object
To slant an object, use the handles located at the midpoints on the top, bottom and sides of a selected object. The mouse cursor changes when it hovers over one of these midpoint handles.

The axis used for slanting an object is the object edge directly opposite the midpoint handle being used to slant the object. This axis stays fixed in location while the other sides of the object move in relation to it as you drag the mouse cursor.

Click and hold the mouse button, then start to move the cursor to shear the object. A dotted outline of the object being slanted appears (Figure 53) and the current angle of slanting is shown in the status bar.
Setting exact size and position

You can position and resize objects with the mouse, but this method is not exact. If you want to accurately position and size an object, go to Format > Position and Size on the main menu bar, or right-click on an object and select Position and Size from the context menu, or press the F4 key. This will open the Position and Size dialog (Figure 54).

Position and Size

Open the Position and Size dialog and click on the Position and Size tab (Figure 54) to set the appropriate values.
Position is defined using X/Y coordinates relative to a base point. Change the X/Y coordinates using the text boxes in the Position section.

Width and height of an object are also defined relative to a base point. Change the width and height of an object using the text boxes in the Size section. To keep the ratio of width to height, select the Keep ratio option.

The units of measurement used for X/Y coordinates and the width and height of the object are set by going to Tools > Options > LibreOffice Draw > General.

The default location of the base points for position and size is the upper left corner of the drawing area. You can temporarily change this base point to make positioning or dimensioning simpler by clicking on a radio button corresponding to the location of the base point you want to use. This change in base point is only valid for single use and the base point is reset to the standard position of top left corner when you close the Position and Size dialog.

To prevent either or both size and position from being inadvertently changed, select the appropriate options in the Protect section.

**Rotating objects**
To accurately rotate an object, click on the Rotation tab of the Position and Size dialog (Figure 55). Use this dialog to define the rotation angle and the location of the pivot point.

![Figure 55: Rotating an object](image)

The pivot point is positioned using X/Y coordinates that are relative to the original position of the pivot point. The default setting for the pivot point is the center of an object. To move this pivot point, click on one of the radio buttons in Default settings.

The rotation angle can be accurately set using the text box in the Rotation angle section. To quickly rotate an object in increments of 45 degrees, click on one of the radio buttons in the Default settings. The default setting for rotation is zero degrees.

Changing the pivot point and/or rotation angle of an object is only valid for single use. The pivot point and rotation angle are reset to their default settings when you close the Position and Size dialog.
**Slant and corner radius**

To accurately set the corner radius or slant angle of an object, click on the Slant & Corner Radius tab of the Position and Size dialog (Figure 56).

![Figure 56: Setting slant angle and corner radius](image)

A corner radius can be applied to any object that has sharp corners, such as rectangles, squares, or text boxes. If the Corner radius section is grayed out, then you cannot set a corner radius. The larger the value for corner radius set in the Radius text box, the rounder the corners of an object become.

Slant angle relates to how much an object inclines or slants from its normal vertical position on a drawing. To accurately change the slant angle of an object, enter the number of degrees in the Slant Angle text box.

**Using grid and snap functions**

In Draw, you can also position objects accurately and consistently using grid points, snap points and lines, object frames, individual points on objects, or page edges. This function is known as Snap.

It is easier to use snap functions at the highest practical zoom value for your drawing. You can use two different snap functions at the same time; for example, snapping to a guide line and the page edge. However, it is recommended to activate only those snap functions that you really need.

![Figure 57: LibreOffice Draw Grid dialog](image)
Configuring grid and snap functions

To configure the grid and snap functions in your drawing, go to Tools > Options > LibreOffice Draw > Grid to display the Grid dialog (Figure 57). The grid and snap functions can also be displayed and switched on or off using this dialog, right-clicking on your drawing and using the options in the context menu, or using the icons in the Options toolbar (Figure 58). If the Options toolbar is not open, go to View > Toolbars > Options.

Grid
- **Snap to grid** – specifies whether to move frames, drawing elements, and controls only between grid points. To change the status of the snap grip only for the current action, drag an object while holding down the Control key.
- **Visible grid** – specifies whether to display or turn off the grid. It is also possible to toggle displaying the grid with Grid > Display Grid in the context menu when you right-click on your drawing page. You can also select Grid > Grid to Front in this context menu to display the grid in front of objects.

Resolution
- **Horizontal** – defines the unit of measure for the spacing between grid points on the X-axis.
- **Vertical** – defines the grid points spacing in the desired unit of measurement on the Y-axis.

Subdivision
- **Horizontal** – specify the number of intermediate spaces between grid points on the X-axis.
- **Vertical** – specify the number of intermediate spaces between grid points on the Y-axis.
- **Synchronize axes** – specifies whether to change the current grid settings symmetrically. The resolution and subdivision for the X and Y axes remain the same.

Snap
- **To snap lines** – snaps the edge of a dragged object to the nearest snap line when you release the mouse. You can also define this setting by using the Snap to Snap Lines icon on the Options toolbar.
- **To the page margins** – specifies whether to align the contour of the graphic object to the nearest page margin. The cursor or a contour line of the graphics object must be in the snap range. In a drawing, this function can also be accessed with the Snap to Page Margins icon in the Options toolbar.
- **To object frame** – specifies whether to align the contour of the graphic object to the border of the nearest graphic object. The cursor or a contour line of the graphics object must be in the snap range. In drawing, this function can also be accessed with the Snap to Object Border icon in the Options toolbar.
- **To object points** – specifies whether to align the contour of the graphic object to the points of the nearest graphic object. This only applies if the cursor or a contour line of the graphics
object is in the snap range. In a drawing, this function can also be accessed with the **Snap to Object Points** icon in the Options toolbar.

- **Snap range** – defines the snap distance between the mouse pointer and the object contour. Snaps to a snap point if the mouse pointer is closer than the distance selected.

**Snap position**

- **When creating or moving objects** – specifies that graphic objects are restricted vertically, horizontally or diagonally (45°) when creating or moving them. You can temporarily deactivate this setting by pressing the **Shift** key.
- **Extend edges** – specifies that a square is created based on the longer side of a rectangle when the **Shift** key is pressed before you release the mouse button. This also applies to an ellipse (a circle will be created based on the longest diameter of the ellipse). When **Extend edges** is not selected, a square or a circle will be created based on the shorter side or diameter.
- **When rotating** – specifies that graphic objects can only be rotated within the rotation angle that you selected. If you want to rotate an object outside the defined angle, press the **Shift** key when rotating. Release the key when the desired rotation angle is reached.
- **Point reduction** – defines the angle for point reduction. When working with polygons, you might find it useful to reduce their editing points.

**Snap to grid**

**Using Snap to Grid**

Use the **Snap to Grid** function to move an object exactly onto a grid point in your drawing. This function can be switched on and off using one of three methods:

7) Go to **View > Grid > Snap to Grid**.
8) Right-click on your drawing and selecting **Snap to Grid** from the context menu.
9) Click on the **Snap to Grid** icon on the Options toolbar.

**Displaying the grid**

Displaying or turning off the grid in your drawing can be done using one of four methods:

1) Go to **View > Grid > Display Grid**.
2) Click on the **Display Grid** icon on the Options toolbar.
3) Right-click on your drawing and select **Display Grid** from the context menu.
4) Selecting **Visible grid** option in the Grid dialog (Figure 57 on page 52).

**Changing color of grid points**

By default the grid points are gray and, depending on you display and computer setup, are not always easy to see. Go to **Tools > Options > LibreOffice > Appearance** to open the **Appearance** dialog (Figure 59). In the **Drawing/Presentation** section, change the color of the grid points selecting a more suitable color from the drop down list for you to use.
Snap points and lines

Unlike the grid, snap lines and snap points are inserted by you when you want to position an object in a specific position on your drawing. Snap lines can either be horizontally or vertically and appear as dashed lines. Snap points appear as small crosses with dashed lines. Snap points and snap lines do not appear in printed output.

You can insert snap lines and snap points in two ways:

- Using the Insert Snap Point/Line command.
- Using the vertical and horizontal rulers (snap lines only).

Inserting snap points and snap lines

To insert a snap point or snap line, go to Insert > Insert Snap Point/Line or right-click on your drawing and select Insert Snap Point/Line from the context menu to open the New Snap Object dialog (Figure 60).
• **Position** – sets the position of a selected snap point or line relative to the top left corner of the page.
  - *X axis* – enter the amount of space you want between the snap point or line and the left edge of the page.
  - *Y axis* – enter the amount of space you want between the snap point or line and the top edge of the page.

• **Type** – specifies the type of snap object you want to insert.
  - *Point* – inserts a snap point.
  - *Vertical* – inserts a vertical snap line.
  - *Horizontal* – inserts a horizontal snap line.

**Inserting snap lines using rulers**

Only snap lines can be inserted using the vertical or horizontal rulers. If the rulers are not displayed, go to **Tools > Options** > **LibreOffice Draw** > **View** and select *Rulers visible*.

To insert a snap line, move your cursor to a ruler, then click and drag a snap line to the required position.

**Displaying snap points and lines**

Displaying or turning off snap points and lines in your drawing can be done using one of three methods:

1) Go to **View > Grid > Display Snap Lines**.

2) Click on the **Display Snap Lines** icon on the Options toolbar.

3) Right-click on your drawing and select **Display Snap Lines** from the context menu.

**Editing snap points and lines**

To edit a snap point, right-click on the snap point and select **Edit Snap Point** to open the edit dialog or drag it to a new position on your drawing.

To edit a snap line, right-click on the snap line and select **Edit Snap Line** to open the edit dialog or drag it to a new position on your drawing.

**Deleting snap points and lines**

To delete a snap point, drag it back to a ruler or right-click on the snap point and select **Delete Snap Point**.

To delete a snap line, drag it back to the ruler or right-click on the snap line and select **Delete Snap Line**.

**Configuring snap range**

To configure the snap range of when an object snaps to position, go to **Tools > Options** > **LibreOffice Draw** > **Grid** (Figure 57 on page 52) and enter the number of pixels to set the proximity of when the object will snap into position in the *Snap range* box. The default setting is 5 pixels.
Using guide lines

Guide lines are another function in Draw to help you position objects. Guide lines can be displayed while the object is being moved. They extend from the edges of the object to the rulers at the top and left side of your drawing and do not have a snap function (Figure 61).

![Figure 61: Using guide lines](image)

To use guide lines, go to Tools > Options > LibreOffice Draw > View and select the Snap Lines when moving option or click the Helplines While Moving icon on the Options toolbar.

Changing form of regular shapes

When drawing certain regular shapes, one or more dots are displayed in a different color to the selection handles when an object is selected. When the mouse cursor hovers over one of these dots, it changes shape. Clicking and dragging on one of these dots modifies the shape of the object. For example, you can increase the corner radius of a rounded rectangle or square, change the angles of an arc, and so on.

These dots perform a different function according to the shape selected and these functions are listed in the following sections.

Basic shapes

- Rounded rectangles and squares: use the dot to change the radius of the curve that replaces the angled corners of a rectangle or square.
- Circle pie: use the dots to change the size of the filled sector.
- Isosceles triangle: use the dot to modify the triangle type.
- Trapezoid, parallelogram, hexagon, or octagon: use the dot to change the angle between the sides.
- Cross: use the dot to change the thickness of the four arms of the cross.
- Ring: use the dot to change the internal diameter of the ring.
- Block arc: use the dot to change both internal diameter and size of the filled area.
- Cylinder and cube: use the dot to change the perspective.
- Folded corner: use the dot to change the size of the folded corner.
- Frame: use the dot to change the thickness of the frame.
Symbol shapes

- Smiley face: use the dot to change the smile on the face.
- Sun, moon, heart: use the dot to change the shape of the symbol.
- Prohibited symbol: use the dot to change the thickness of the ring and the diagonal bar.
- Double bracket, left bracket, right bracket, double brace: use the dot to change the curvature of the bracket.
- Left brace, right brace: use the dots to change the curvature of the brace and the position of the point.
- Square bevel, octagon bevel, diamond bevel: use the dot to change the thickness of the bevel.

Block arrows

- Arrows: use the dot to change the shape and thickness of the arrows.
- Pentagon, chevron: use the dot to change the angle between the sides.
- Arrow callouts: use the dots to change the shape and thickness of the callouts.
- Circular arrow: use the dots to change the thickness and area of the arrow.

Callouts

- Callouts: use the dots to change the length, position and angle of the pointer.

Stars

- 4-point star, 8-point star, 24-point star: use the dot to change the thickness and shape of the star points.
- Vertical scroll, horizontal scroll: use the dot to change the width and shape of the scroll.
- Doorplate: use the dot to change the inward curvature of the corners.

Curves and polygons

Bézier curves

The editing of curves depends on the mathematics of Bézier curves. Explaining Bézier curves goes beyond this scope of this guide and only the basics are covered here. See Chapter 9 Advanced Draw Techniques for more information on drawing and manipulating Bézier curves.

The editing of a Bézier curve consists in principle of moving points or tangents passing through these points. Each tangent has one control point at each end and a junction point where it meets the curve. The relative angle and distance between the control points determine the shape of the curve. Figure 62 shows what happens starting from a basic circle and changing only one point on the circle.

You can create many different shapes by moving either the junction point itself, or one or both of the round handle points at either end of the tangent. Draw offers more possibilities when you use the functions on the Edit Points toolbar.

---

1 Bézier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer, who developed the technique in the 1960s. The technology was intended to make modeling the surface of vehicles easier.
Converting to a curve or polygon

Before modifying the points on an object, it must first be converted to a curve or a polygon, depending on what kind of effect you want to produce.

After selecting an object, go to **Modify > Convert** and select either **To Curve** or **To Polygon**. Alternatively, right-click on an object and then select **Convert > To Curve** or **Convert > To Polygon** from the contextual menu that pops up.

After converting an object to a curve or polygon, click on the Points icon on the Drawing toolbar; the Edit Points toolbar opens. You can also open this toolbar using **View > Toolbars > Edit Points** on the main menu bar.

You will notice that after the conversion, the handles located in the corners of the selection rectangle have disappeared. This behavior is normal because the handles used with the tools on the Edit Points toolbar are located along the outline or trace of the object.

**Edit Points toolbar**

Open the Edit Points toolbar (Figure 63) by going to **View > Toolbars > Edit Points** on the main menu bar. It will then appear whenever you select an object that is a curve or polygon and the Edit Points icon on the Drawing toolbar. Available tools on the Edit Points toolbar will depend on the object selected and which object point has been selected.

*Figure 62: Creating different shapes by changing the tangent*

*Figure 63: Edit Points toolbar*
Tangents

Note: Tangents are only used on curves. If an object has been converted to a polygon and a tangent is added, the object is automatically converted to a curve.

Symmetric transition

Click on the Symmetric Transition icon to work with a symmetrical tangent (Figure 64). Any movement of one tangent handle is carried over symmetrically to the other handle.

Smooth transition

Click on the Smooth Transition icon to adjust separately the lengths on each side of a tangent to make a curve flatter or steeper. This creates an asymmetric tangent and the curve is flatter on the longest side of the tangent (Figure 65).

Corner point

It is possible to change independently the angle on each side of a tangent using the central point of the tangent as a corner point. Select a point on the curve, then click on the Corner Point icon to create a corner point from the selected point (Figure 66). When a corner point is created, you can change the angle on each tangent side to create spikes and troughs in curves.

Tangent rotation

You can alter the angle by which a tangent relates to curve by clicking on one of the end points of the tangent and rotating it with the mouse cursor. As you change the angle of the tangent, the shape of the curve changes in response (Figure 67).
Points

Moving points

Click on the Move Points icon to move any of the points when an object has been converted to a curve or polygon. When Move Points is active, the mouse cursor changes shape when it hovers over a point. Moving a point is an easy manipulation to carry out. Figure 68 illustrates how an ovoid or egg shape was created from a circle by dragging the right hand side point to the right.

Inserting points

Click on the Insert Points icon to add an extra point to an existing curve or polygon. Click on the object border at the spot where you want to insert a point. The tangent type associated with the new point depends on where the point has been added to the object border. Figure 69 shows a new point added to the top right of an ovoid shape.
Deleting points

Clicking on the **Delete Points** icon removes a point from the border of an object. The resulting curve automatically changes shape around the remaining points. Figure 70 shows what happens when the right point was deleted from a circle. You can select several points by holding down the *Shift* key, then click on the Delete Points icon. You can also delete selected points by pressing the *Del* key on the keyboard.

If a curve has been converted to a line (see “Converting curves or lines” on page 63) and selected points are deleted, a straight line is formed between the two points on either side of the now deleted points.

![Figure 70: Deleting points](image)

Eliminating points

The **Eliminate Points** icon only functions on lines with multiple points. These lines are created when a curve is converted to a line using the **Convert to Curve** icon on the Edit Points toolbar (see “Converting curves or lines” on page 63).

The process of eliminating points from a line to create a straight line is shown in Figure 71.

1) Select a line with multiple points and click on the Points icon on the Drawing toolbar. The Edit Points toolbar should open. If it does not open, then go to **View > Toolbars > Edit Points** on the main menu bar to open it.

2) Use the mouse cursor to select the point on the line that you want to eliminate. The selected point will be emphasized.

3) Make sure the **Eliminate Points** icon is active. The area around the icon becomes shaded when active. If it is not active, click on the Eliminate Points icon.

4) Accurately position the mouse cursor over the selected point, then click and hold the mouse button and start dragging the selected point. As you drag, a dotted line forms between the two neighboring points.

5) When this dotted line appears to be a straight line between the two neighboring points, release the mouse button. The selected point has been eliminated and a straight line now exists between the two neighboring points.
Converting curves or lines

Curves and lines can be easily converted to each other using the Convert to Curve icon on the Edit Points toolbar. When a curve is converted to a line, a straight line is created between selected points on a curve. When a line is converted to a curve, a curve is created between selected points on a line.

Select a curve or line, then select the points on the curve or line where you want to do the conversion. Click on the Convert to Curve icon and the curve or line is converted (Figure 72).
Splitting curves

Click on the **Split Curve** icon to split or cut a curve at the location of the selected point. If the object is filled, it will be emptied, because the curve that represented the object border is no longer closed (Figure 73).

The point where you split the curve is now larger than the remaining points visible on the curve, (except for the curve start point which is also larger than the other points).

You can separate a curve at several points simultaneously. Keep the **Shift** key pressed down and select all of the points at which the cut should occur, then click on the **Split Curve** icon. Deselect the curve, then drag and drop segments with the mouse to move them away from the original curve.

![Figure 73: Splitting curves](image)

Closing curves

To close an open and existing curve, first select the open curve, then select the start point of the curve. The start point is larger than the other points visible on the curve. Click on the **Close Bézier** icon to close the curve (Figure 74).

If the open curve was originally a closed and filled curve, then when the curve is closed again, the original color will fill the curve.

![Figure 74: Closing curves](image)
Rotating and distorting curves

To rotate and distort a curve, first select the curve then click on the Rotate icon on the Mode toolbar. If the Mode toolbar is not open, go to View > toolbars > Mode or click on the small triangle or arrow to the right of the Rotate icon on the Drawing toolbar. The points on the curve change color and shape (Figure 75).

Select one of the points on the curve and move it by dragging the mouse cursor. Movement will be restricted to the original border of the curve.

Select one of the control points at the end of the tangent line and rotate the distorted curve by dragging the mouse cursor. The distorted curve will rotate about the center of rotation.

Figure 75: Rotating and distorting curves
Chapter 4
Changing Object Attributes
Toolbars and menus

To change object attributes, such as color or border width, and so on, use the Line and Filling toolbar, the Text Formatting toolbar, or the context menu.

Line and Filling toolbar

If the Line and Filling toolbar is not displayed, go to View > Toolbars > Line and Filling to open the toolbar (Figure 76). The most common object attributes can be edited using this toolbar. You can also open the Line dialog by clicking on the Line icon for access to more formatting options.

Text Formatting toolbar

When you select text, the Line and Filling toolbar automatically changes to show the Text Formatting toolbar (Figure 78). You can also open the Text Formatting toolbar by selecting View > Toolbars > Text Formatting. The tools on this toolbar will not become active until text has been selected.
Context menu

When an object is selected and you right-click on the object, a context menu (Figure 80) opens that applies to the selected object. This context menu provides access to the options available and allows you to change object attributes without having to open a dialog. Menu entries with a small arrow on the right-hand side contain a submenu.

Figure 79: Tools available on Text Formatting toolbar

Figure 80: Context menu
Formatting lines

In LibreOffice the term line indicates both a freestanding segment (line), outer edge of a shape (border), or an arrow. In most cases the properties of the line you can modify are its style (solid, dashed, invisible, and so on), its width and its color.

Select the line you need to format and then use the controls on the Line and Filling toolbar to change the most common options highlighted in Figure 81.

Figure 81: Common line properties (style, color, width)

If you need to fine tune the appearance of a line, choose Format > Line from the menu bar, or right-click on the line and select Line from the context menu, or select the Line icon from the Line and Filling toolbar. All of these methods open the Line dialog (Figure 82), where you can set line properties. This dialog consists of four pages: Line, Shadow, Line Styles, and Arrow Styles.

Figure 82: Line properties dialog

Line properties

The Line page is where you can set the basic parameters of the line and is divided into four sections as follows.

Line properties section

The Line Properties section on the left side allows you to set the following parameters:

- **Line style**: several line styles are available from the drop-down list, but more line styles can be defined if necessary.
- **Color**: choose from the predefined colors in the drop down list or create a new color.
• **Width**: specifies the thickness of the line.
• **Transparency**: sets the transparency of a line. Figure 83 shows the effects of different percentages in transparency levels to lines when placed over an object.

![Figure 83: Line transparency effect (0%, 25%, 50%, 75% left to right)](image)

**Arrow styles section**

The Arrow styles section of the Line dialog is only applicable to individual lines and is not used for lines that form the borders of a shape.

• **Style**: sets the style of the two ends of a line. The left drop down menu is for where you start the line and the right drop down menu is for where you end the line.
• **Width**: specifies the thickness of the arrow endings
• **Center**: moves the center of the arrow endings to the end point of the line. Figure 84 shows the effects of selecting this option.
• **Synchronize ends**: makes the two line ends identical.

![Figure 84: Default arrowheads (left) and centered arrowheads (right)](image)

**Arrowheads**

A quick way to set the arrowheads for a selected line is to click on the Arrow Style icon in the Line and Filling toolbar. This opens the Arrowheads menu (Figure 85), where you can select one of the many predefined arrowhead styles for the start and ending of the selected line.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrowheads are only applicable to lines. They have no effect on the border of an object.</td>
</tr>
</tbody>
</table>

---

*Chapter 4  Changing Object Attributes*
Figure 85: Arrowheads menu

**Corner style section**
Corner styles determines how the connection between two segments looks. There are four available options in the drop down menu. To appreciate the difference between corner styles, choose a thick line style and observe how the preview changes.

**Preview section**
The bottom part of the Line page previews the applied style for a line and its corners so that the corner style selection can also be evaluated.

**Line shadows**
Use the Shadow page (Figure 86) of the Line dialog to add and format the line shadow. The settings on this page are the same as those for shadows applied to other objects and are described in “Formatting shadows” on page 86.

Figure 86: Shadow page of Line properties dialog

A quicker way to apply a shadow to a line is using the Shadow icon on the Line and Filling toolbar. The main disadvantage of using the Shadow icon is that the shadow appearance will be constrained by the shadow settings of the default graphics style.
Line styles

Use the Line Styles page (Figure 87) of the Line dialog to create new line styles as well as to load previously saved line styles. It is normally better to create new styles when necessary than modify predefined styles.

Creating line styles

To create a new line style:

1) Choose Format > Line from the menu bar, or right-click on the line and select Line from the pop-up menu, or select the Line icon from the Line and Filling toolbar.

2) Click on the Line Styles tab.

3) Select from the Line style drop-down menu a style similar to the style you want to create.

4) Click Add. On the pop-up dialog, type a name for the new line style and click OK.

5) Now define the new style. Start by selecting the line type for the new style. To alternate two line types (for example, dashes and dots) within a single line, select different types in the two Type boxes.

6) Specify the Number and Length (not available for dot style) of each of the types of line selected.

7) Set the Spacing between the various elements

8) If necessary, select Fit to line width so that the new style fits the width of the selected line.

9) The new line style created is available only in the current document. If you want to use the line style in other documents, click the Save Line Styles icon and type a unique filename in the Save as dialog that opens. Saved styles have the file extension of .sod.

10) To use previously saved line styles, click the Load Line Styles icon and select a style from the list of saved styles. Click Open to load the style into your document.

11) If necessary, click on the Modify button to change the name of the style.Arrow styles
Use the Arrow Styles page (Figure 88) of the Line dialog to create new arrow styles, or modify existing arrow styles, or load previously saved arrow styles.

Figure 88: Creating arrow styles

Creating arrow styles
To create a new arrow style:

1) First draw a curve in the shape you want to use for the arrowhead, or create a shape and convert to a curve. The top of the shape must face upward, as shown in Figure 89, because this becomes the point of the arrow.

Figure 89: Using shapes for arrow styles

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>The arrowhead must be a curve, which is something you can draw without lifting a pencil from the paper. For example, a star ⭐ can be a curve but a smiley face 😊 cannot be a curve.</td>
</tr>
</tbody>
</table>

2) Select the shape and, if necessary, right click and choose Convert > To Curve to convert the shape to a curve. If the shape is already a curve, To Curve will not be available.

3) With the selection handles showing, select Format > Line from the menu bar, or right-click and choose Line from the pop-up menu.

4) Go to the Arrow styles page, click the Add button, type a name for the new arrow style, and click OK. The new arrowhead style will be shown in the preview.
5) Now you can access the new style from the Arrow style list. When you select the name of the new style, it is shown at the bottom of the dialog.

6) The new arrowhead style created is available only in the current document. If you want to use this arrowhead style in other documents, click the **Save Line Styles** icon and type a unique filename in the Save as dialog that opens. Saved styles have the file extension of .sod.

7) To use previously saved arrowhead styles, click the **Load Line Styles** icon and select the style from the saved list of styles. Click **Open** to load the style into your document.

8) If necessary, click on the **Modify** button to change the name of the style.

### Formatting fill area

The term **area fill** refers to the inside of an object, which can be a uniform color, gradient, hatching pattern, or bitmap (Figure 90). An area fill can be made partly or wholly transparent and can throw a shadow.

![Different types of area fill](image)

**Figure 90:** Different types of area fill

The Line and Filling toolbar has the majority of the tools normally used to format graphic objects. If this toolbar is not showing, choose **View > Toolbars > Line and Filling** from the menu bar. You can also use the Area dialog, described in “Using the Area dialog” on page 77.

To format the area of an object, select it so that the selection handles show. A wide number of default fillings are readily available from the Line and Filling toolbar (Figure 91). Select from the Color pull-down menu the type of fill required (Figure 92). If you want no fill at all, select **Invisible**.

Once you have decided on a predefined or custom fill, you can further refine it by adding a shadow or transparency.

![Common fill options highlighted](image)

**Figure 91:** Common fill options highlighted

![Area fill types](image)

**Figure 92:** Area fill types
**Color area fill**

To change the area fill of an object to a color (Figure 93):

1) Select the object you wish to edit.
2) On the Line and Filling toolbar, select **Color** from the drop down list.
3) Select a color from the drop-down list.

![Figure 93: Color area fill](image)

**Gradient area fill**

A gradient fill provides a smooth transition from one color to another. The transition pattern may vary from a simple linear transition to a more complex radial one. To change the area fill of an object to a gradient (Figure 94):

1) Select the object you wish to edit.
2) On the Line and Filling toolbar, select **Gradient** from the drop down list.
3) Select a gradient from the drop-down list.

![Figure 94: Gradient area fill](image)

**Hatching or line pattern area fill**

When a hatching fill is applied it fills the complete area of the selected object. To change the area fill of an object to a hatching (Figure 95):

1) Select the object you wish to edit.
2) On the Line and Filling toolbar, select **Hatching** from the drop down list.
3) Select a hatching fill from the drop-down list.
Bitmap image area fill

You can fill an object only with a bitmap image but not a vector graphic image. To change the area fill of an object to a bitmap image (Figure 96):

1. Select the object you wish to edit.
2. On the Line and Filling toolbar, select Bitmap from the drop-down list.
3. Select a bitmap fill from the drop-down list.

Using the Area dialog

In addition to using the Line and Filling toolbar, you can use the Area dialog to apply existing area fills or create your own area fill. To open it, choose Format > Area from the menu bar, or click on the Area icon on the Line and Filling toolbar, or right-click on the object and select Area. Use the Area tab to apply predefined fills, both those supplied with LibreOffice and those you create yourself.

Use the Colors, Gradients, Hatching, and Bitmaps tabs to define new fills, as described in “Creating new area fills” on page 79. The Transparency tab is discussed in “Transparency formatting” on page 87. To make the object cast a shadow, see “Formatting shadows” on page 86.

To apply an area fill, first select the required fill type in the top left drop-down list. The page changes to show, in the middle section, the list of predefined styles for that fill type.
Note: In the Area dialog, the choice for no fill is None rather than Invisible.

When using the Area tab of the Area dialog, some additional options may become available once you have selected the fill type and one of the available fill styles.

- For color fills, select **Color** from the drop down list and then select your required color from the list of available colors (Figure 97). Click on the OK button and the fill color will appear in the selected shape.

![Figure 97: Area color dialog](image)

- For gradient fills, select **Gradient** from the drop down list and then select your required gradient from the list of available gradients (Figure 98). Click on the OK button and the fill gradient will appear in the selected shape. You can override the number of steps (increments) that should be applied to the gradient transition. To do so, deselect the **Automatic** option under **Increments** and then enter the number of steps required in the box to the right.

![Figure 98: Area gradient dialog](image)

- For hatching fills, select **Hatching** from the drop down list and then select your required hatching from the list of available hatchings (Figure 99). Click on the OK button and the fill hatching will appear in the selected shape. You can apply a different background color by selecting the **Background color** option and choosing a color from the drop down list.

![Figure 99: Area hatching dialog](image)
• For bitmap fills, select **Bitmaps** from the drop down list and then select your required bitmap from the list of available bitmaps (Figure 100). Click on the **OK** button and the fill bitmap will appear in the selected shape. You can customize a large number of parameters. Refer to “Working with bitmap fills” on page 83 for additional information.

![Figure 100: Area bitmap dialog](image)

### Creating new area fills

The following sections describe how to create new fills and how to apply them.

Although you can change the characteristics of an existing fill and then click the **Modify** button, it is recommended that you create new fills, or modify custom fills rather than the predefined ones, as these may be reset when updating LibreOffice.

### Creating custom colors

On the **Colors** page (Figure 101), you can modify existing colors or create your own. You can also specify a new color either as a combination of the three primary colors Red, Green, and Blue, (RGB notation) or by percentages of Cyan, Magenta, Yellow, and Black (CMYK notation).

To create a new color:

1. Enter the name for the color in the **Name** box.
2. Select whether to define the color in RGB or CMYK. For RGB Specify the red (R), green (G) and blue (B) component on a 0 to 255 scale. For CMYK specify the cyan (C), magenta (M), yellow (Y) and black (K) components from 0% to 100%.
3. Click the **Add** button. The color is now added to the **Color** drop down list.
To modify a color:

1) Select the color to modify from the list.
2) Enter the new values that define the color in RGB or CMYK.
3) Modify the name as required.
4) Click the Modify button.

Alternatively, you can edit a color:

1) Click on the Edit button to open the Color Picker dialog (Figure 102).
2) Modify the color components as required using RGB, CMYK or HSB (Hue, Saturation, Brightness).

3) Click **OK** to exit the Color Picker dialog.

4) Click the **Modify** button on the Color dialog then click the **OK** button.

The new color created is available only in the current document. If you want to use this color in other documents, click the **Save Color List** icon and type a unique filename in the **Save as** dialog that opens. The saved colors list has the file extension of .soc.

To use a previously saved color list, click the **Load Color List** icon and select from the file open dialog. Click **Open** to load the saved color list into Draw.

| Tip | You can also add custom colors using **Tools > Options > LibreOffice > Colors**. This method makes the color available to all components of LibreOffice. |

### Creating custom gradients

To create a new gradient or to modify an existing one, select the Gradients tab from the Area dialog (Figure 103). Several types of gradients are predefined and in most cases changing the **From** and **To** colors will be sufficient to obtain the desired result.

It is highly recommended that you create a new gradient even if you just want to change the two colors, rather than modifying the predefined ones, which should be used only as starting points.

![Area Dialog with Gradients Tab Opened](Figure 103: Creating a new gradient)

To create a new gradient:

1) First choose the **From** and **To** colors.

2) Then choose a type of gradient from the drop down list: Linear, Axial, Radial, Ellipsoid, Square or Rectangular.
3) A preview of the gradient type is shown under the available gradients list in the middle of the dialog.

4) Depending on the chosen type, some options will be grayed out. Set all the properties as desired (very often the default values will work well). The properties to set to create a gradient are summarized in Table 6.

5) Click the Add button to add the newly created gradient to the list.

The new gradient created is available only in the current document. If you want to use this gradient in other documents, click the Save Gradients List icon and type a unique filename in the Save as dialog that opens. The saved gradients list has the file extension of .sog.

To use a previously saved gradients list, click the Load Gradients List icon and select from the file open dialog. Click Open to load the saved gradients list into Draw.

**Table 6: Gradient properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center X</td>
<td>For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to set the horizontal offset of the gradient center.</td>
</tr>
<tr>
<td>Center Y</td>
<td>For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to set the vertical offset of the gradient center.</td>
</tr>
<tr>
<td>Angle</td>
<td>For all the gradient types, specifies the angle of the gradient axis.</td>
</tr>
<tr>
<td>Border</td>
<td>Increase this value to make the gradient start further away from the border of the shape.</td>
</tr>
<tr>
<td>From</td>
<td>The start color for the gradient. In the edit box below enter the intensity of the color: 0% corresponds to black, 100% to the full color.</td>
</tr>
<tr>
<td>To</td>
<td>The end color for the gradient. In the edit box below enter the intensity of the color: 0% corresponds to black, 100% to the full color.</td>
</tr>
</tbody>
</table>

**Creating custom hatching patterns**

To create new hatching patterns or modify existing ones, select the Hatching tab of the Area dialog (Figure 104). As with gradients and colors, it is better to create a new hatching pattern rather than modify a predefined one. The properties that can be set for a hatching pattern are shown in Table 7.

To create a new hatching pattern:

1) Select as a starting point a pattern similar to the one that will be created.
2) Modify the properties of the lines forming the pattern. A preview is displayed in the window below the available patterns.
3) Click the Add button and choose a name for the newly created hatching.

The new hatching pattern created is available only in the current document. If you want to use this hatching pattern in other documents, click the Save Hatches List icon and type a unique filename in the Save as dialog that opens. The saved hatches list has the file extension of .soh.

To use a previously saved hatches list, click the Load Hatches List icon and select from the file open dialog. Click Open to load the saved hatches list into Draw.
Figure 104: Creating a new hatching pattern

Table 7: Properties of hatching patterns

<table>
<thead>
<tr>
<th>Property</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spacing</td>
<td>Determines the spacing between two lines of the pattern. As the value is changed the preview window is updated.</td>
</tr>
<tr>
<td>Angle</td>
<td>Use the mini map below the numerical value to quickly set the angle formed by the line to multiples of 45 degrees. If the required angle is not a multiple of 45 degrees, just enter the desired value in the edit box.</td>
</tr>
<tr>
<td>Line type</td>
<td>Set single, double or triple line for the style of the pattern.</td>
</tr>
<tr>
<td>Line color</td>
<td>Use the list to select the color of the lines that will form the pattern.</td>
</tr>
</tbody>
</table>

Working with bitmap fills

On the Area tab, chose *Bitmap* from the drop-down list. Select from the list of bitmaps the one to be used to fill the area. Note that any imported bitmaps will become available in the list.

Set the size, position and offset parameters (as applicable) in the right hand side of the page, and then click **OK** to close the dialog.

As Figure 105 shows, there are quite a number of parameters to be configured when using a bitmap fill. These are described in Table 8.
### Figure 105: Advanced formatting for bitmap fill

### Table 8: Bitmap fill properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size – Original</td>
<td>Select this box to retain the original size of the bitmap.</td>
</tr>
<tr>
<td>Size – Relative</td>
<td>To rescale the object, deselect Original and select Relative. The Width and Height edit boxes are enabled.</td>
</tr>
<tr>
<td>Size – Width</td>
<td>When Relative is selected 100% means that the bitmap original width will be resized to occupy the whole fill area width, 50% means that the width of the bitmap will be half that of the fill area.</td>
</tr>
<tr>
<td>Size – Height</td>
<td>When Relative is selected 100% means that the bitmap original height will be resized to occupy the whole fill area height, 50% means that the height of the bitmap will be half that of the fill area.</td>
</tr>
<tr>
<td>Position – Anchor Map</td>
<td>Select from the map the place within the area to which the bitmap should be anchored.</td>
</tr>
<tr>
<td>Position – Tile</td>
<td>When this option is selected, the bitmap will be tiled to fill the area. The size of the bitmap used for the tiling is determined by the Size settings.</td>
</tr>
<tr>
<td>Position – X offset</td>
<td>When Tile is enabled, enter in this box the offset for the width of the bitmap in percentage values. 50% offset means that Draw will place the middle part of the bitmap at the anchor point and start tiling from there.</td>
</tr>
<tr>
<td>Position – Y offset</td>
<td>This will have a similar effect to the X offset, but will work on the height of the bitmap.</td>
</tr>
<tr>
<td>Position – Autofit</td>
<td>Stretches the bitmap to fill the whole area. Selecting this option disables all the size settings.</td>
</tr>
<tr>
<td>Offset – Row</td>
<td>If Tile is enabled, offsets the rows of tiled bitmaps by the percentage entered in the box so that two subsequent rows are not aligned.</td>
</tr>
<tr>
<td>Offset – Column</td>
<td>If Tile is enabled, offsets the columns of tiled bitmaps by the percentage entered in the box so that two subsequent columns of bitmaps are not aligned.</td>
</tr>
</tbody>
</table>
The best way to acquire understanding of these parameters is to use them. Figure 106 shows some examples of bitmap fills and the parameters used.

Figure 106: Examples of bitmap fill

Creating and importing bitmaps

You can add (import) new bitmap fills or create your own pattern on a 8x8 grid using the Bitmaps tab of the Area dialog (Figure 107).

Figure 107: Creating a new bitmap
To create a bitmap fill:
1) Start with the **Blank** bitmap type on top of the list to activate the **Pattern Editor**.
2) Select the **Foreground** and **Background** colors.
3) Start creating the pattern by clicking with the left mouse button the squares (pixels) that you want in the foreground color. Use the right mouse button to apply the background color. Check the preview window to see if the desired effect is achieved.
4) When done, click **Add** to save the pattern.

To import a bitmap created in another program:
1) Click the **Import** button.
2) A file picker dialog is displayed and shows a list of compatible file types. Browse to the directory containing the bitmap file and select it, then click **Open**.
3) Type a name for the imported bitmap and click **OK**.

The new bitmap created is available only in the current document. If you want to use this bitmap in other documents, click the **Save Bitmap List** icon and type a unique filename in the **Save as** dialog that opens. The saved bitmap list has the file extension of .sob.

To use a previously saved bitmap list, click the **Load Bitmap List** icon and select from the file open dialog. Click **Open** to load the saved bitmap list into Draw.

**Formatting shadows**

Shadowing can be applied to lines, shapes and text.

To quickly apply a shadow to a line or shape only, first select the line or shape and then click on the **Shadow** icon in the Line and Filling toolbar. The shadow applied using this method cannot be customized and is set to default settings.

For a more flexible way to apply a shadow to a line, shape or text, first select the object and then select **Format > Area** to open the Area dialog. Click on the **Shadow** tab to open the Shadow page (Figure 108). This will allow you to set the following properties for the shadow.

- **Position**: selects the point that determines the direction in which the shadow is cast.
- **Distance**: determines the distance between the object and the shadow.
- **Color**: sets the color of the shadow.
- **Transparency**: determines the amount of transparency for the shadow.

![Figure 108: Customizing a shadow](image-url)
Transparency formatting

Transparency is applicable to objects as well as shadows. To apply transparency to lines, refer to “Formatting lines” on page 70; for shadows, refer to “Formatting shadows” on page 86.

To apply transparency to objects, select the object and then select **Format > Area** to open the Area dialog. Click on the **Transparency** tab to open the Transparency page (Figure 109).

Two types of transparency are available: *uniform transparency* and *gradient transparency*.

To create a uniform transparency, select **Transparency** and then select the percentage of transparency required.

To create a gradient transparency (so that the area becomes gradually transparent) select **Gradient** and then set the parameters of the gradient. Refer to Table 9 for a description of the properties.

More information on gradient transparency, including an example of combining color gradient with gradient transparency, can be found in “Advanced gradient controls” on page 88.

![Figure 109: Setting object transparency](image)

**Table 9: Gradient transparency properties**

<table>
<thead>
<tr>
<th><strong>Property</strong></th>
<th><strong>Meaning</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Center X</td>
<td>For Radial, Ellipsoid, Quadratic and Square gradients, modify these values to set the horizontal offset of the gradient center.</td>
</tr>
<tr>
<td>Center Y</td>
<td>For Radial, Ellipsoid, Quadratic and Square gradients, modify these values to set the vertical offset of the gradient center.</td>
</tr>
<tr>
<td>Angle</td>
<td>For Linear, Axial, Ellipsoid, Quadratic and Square gradient, specifies the angle of the gradient axis.</td>
</tr>
<tr>
<td>Border</td>
<td>Increase this value to make the gradient start further away from the border of the object.</td>
</tr>
<tr>
<td>Start value</td>
<td>Value for the starting transparency gradient. 0% is fully opaque, 100% means fully transparent.</td>
</tr>
<tr>
<td>Property</td>
<td>Meaning</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>End value</td>
<td>Value for the ending transparency gradient. 0% is fully opaque, 100% means fully transparent.</td>
</tr>
</tbody>
</table>

**Advanced gradient controls**

As discussed in “Creating custom gradients” on page 81, gradient properties can be configured using the properties given in the dialogs shown in Figure 103 and Table 6.

To use this tool, select an object with a gradient, then click on the **Gradient** icon in the **Mode** toolbar (Figure 110). This displays a dashed line connecting two colored squares. The colors show the **From** and **To** colors that are used for the selected gradient (Figure 111).

- For **linear gradients**: move the square corresponding to the **From** color to change where the gradient starts (border value). Move the square corresponding to the **To** color to change the orientation (angle value).
- For **axial gradients**: you can move only the **To** color to change both the angle and border properties of the gradient.

![Figure 110: Mode toolbar](image)

- For **radial gradients**: move the **From** color to modify the border property to set the width of the gradient circle. Move the **To** color to change the point where the gradient ends (Center X and Center Y values).
- For **ellipsoid gradients**: move the **From** color to modify the border property to set the size of the gradient ellipsoid. Move the **To** color to change the angle of the ellipsoid axis and the axis itself.
- For **square and rectangular gradients**: move the **From** color to modify the border to set the size of the gradient square or rectangle and the angle of the gradient shape. Move the **To** color to change the center of the gradient.

![Figure 111: From Red 4 to Yellow 1 gradient](image)
Moving the squares will have different effects depending on the type of gradient. For example, for a linear gradient, the start and end squares of the gradient will always be situated to either side of the center point of the object.

**Using styles**

Suppose that you want to apply the same area fill, line thickness, and border to a set of objects. This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a formatting template (a style) and then to apply that style to multiple objects. For more information on styles, see Chapter 6 Introduction to Styles in the Writer Guide.

Click on the **Styles and Formatting** icon on the **Line and Filling** toolbar or press the *F11* key to open the Styles and Formatting dialog, then click on the **Graphics Styles** icon in the top left corner of the dialog (Figure 112). This will open a list of styles available for use with graphics.

![Figure 112: Styles and Formatting dialog](image)

**Linked graphics styles**

Graphics styles support inheritance; that is, a style can be linked to another (parent) style so that it inherits all the formatting settings of the parent. You can use this property to create families of styles.
For example, if you need multiple boxes that differ in color but are otherwise identically formatted, the best way to proceed is to define a generic style for the box including borders, area fill, font, and so on. Then create a number of hierarchically dependent styles which differ only in the fill color attribute. If you then need to change the font size or the thickness of the border, it is sufficient to change the parent style and all the other linked styles will change accordingly.

**Creating graphics styles**

You can create a new graphics style in two ways:

- Using the Style and Formatting dialog
- From a selection

**Using Style and Formatting dialog**

Click on the Graphics Styles icon in the top left corner of the Styles and Formatting dialog. To link a new style with an existing style:

1. Select the style you want to use in the Styles and Formatting dialog (Figure 112).

2) Right click and select **New** to open the Graphics Styles dialog (Figure 113).
3) Give your new graphics style a memorable file name.
4) Use the various tabs and text boxes in the Graphics Styles dialog to format and categorize your new style.
5) Click on the **OK** button when finished to save your new graphics style.

The Graphics Styles dialog consists of several pages that may be grouped as follows:

- **Organizer page** contains a summary of the style and its hierarchical position.
- **Font, Font Effects, Indents & Spacing, Alignment, Tabs and Asian typography pages** set the properties of the text inserted in a text box or in a graphic object.
- **Dimensioning page** is used to set the style of dimension lines.
- **Text, Text Animation, Connector, Line, Area, Shadowing, and Transparency pages** determine the formatting of a graphic object.

**Note**

When styles are linked, changing a color for example will change the color in all linked styles. Sometimes this is exactly what you want; at other times you do not want the changes to apply to all linked styles. It pays to plan ahead.
Using a selected object

You can create a new style from an object that has already been formatted. This can be text or graphics:

1) Select the object you want to use to create your new style.
2) Open the Styles and Formatting dialog and click the New Style from Selection icon (highlighted in Figure 114).
3) In the Create Style dialog (Figure 115) type a name for the new style. The list shows existing custom styles of that are available.
4) Click OK to save the new style.

Modifying a graphics style

To modify an existing style, right-click on it in the Styles and Formatting dialog and choose Modify from the pop-up menu. The dialog for the modification of a graphics style is the same as the dialog for creating a new graphics style (Figure 113). Make the required changes to the style and then click OK to save them.

Updating from a selection

To update a style from a select object:

1) Select an object that uses the format you want to adopt as a style.
2) In the Styles and Formatting dialog, select the style you want to update, and then click the Update Style icon (highlighted in Figure 116).
Applying graphics styles

You can apply a graphics style in two ways using the Styles and Formatting dialog. First make sure that the graphics styles are shown (Figure 112), then do one of the following:

- Select the object to which you want to apply a graphics style and double-click on the name of the style you want to apply.

- Click the Fill Format mode icon and the mouse pointer changes to this icon. Position the icon on the graphic object to be styled and click the mouse button. This mode remains active until you turn it off, so you can apply the same style to several objects. To quit Fill Format mode, click the Fill Format mode icon again or press the Esc key.

- When Fill Format mode is active, a right-click anywhere in the document cancels the last Fill Format action. Be careful not to accidentally right-click and thus undo actions you want to keep.

Tip

At the bottom of the Styles and Formatting window is a drop-down list. You can choose to show all styles or groups of styles such as applied styles or (in the case of graphics styles) custom styles.

Deleting graphics styles

You cannot delete any of the predefined styles in Draw, even if you are not using them. You can only delete user-defined (custom) styles. However, before you delete a custom style, make sure the style is not in use. If an unwanted style is in use, replace it with a substitute style.

To delete custom styles, right-click on them (one at a time) in the Styles and Formatting window and click Delete on the pop-up menu. Click Yes in the message box that pops up.

Applying special effects

As well as the basic actions of moving and resizing an object, a number of special effects can also be applied to objects in Draw. Several of these effects are readily available in the Mode toolbar (Figure 117). If the Mode toolbar is not showing, select it from View > Toolbars > Mode.

This section describes how to rotate, flip, or distort an object, and two ways of setting an object in a circle.
The tools are described in the following sections with the exception of the 3D rotation tool, which is described in Chapter 7 Working with 3D Objects.

**Rotating graphic objects**

Rotation of an object can be carried out manually or using a dedicated dialog, just like changing object position and size.

To rotate an object manually:

1. Click on an object and the selection handles will show.
2. Click the **Rotate** icon in the Drawing or Mode toolbar.
3. The selection handles change shape and also change color (Figure 118).
4. Move the mouse over one of the corner handles and the mouse cursor shape will change. Click the mouse and move in the direction in which you want to rotate the object. Only the corner selection handles are active for rotation.
5. When satisfied release the mouse button.

![Figure 118: Object selected for rotation](image)
The icons representing the functions in the toolbars may be different depending on the operating system used and on whether LibreOffice has been customized. When in doubt, hover the mouse over an icon and wait for the tooltip to appear showing the name of the icon.

When the Rotate icon is clicked, a circle appears in the middle of the selected object to indicate the pivot point for rotation. Normally the center of an object will be just fine, but on some occasions you may wish to rotate around a corner or even around a point outside the picture. To move the rotation point, click on the circle and drag it to the desired position.

To restrict the rotation angles to multiples of 15 degrees, press and hold the Shift key while rotating the graphic. This is very handy for rotating pictures through a right angle, for example from portrait to landscape.

Instead of rotating a graphic object manually, you can use the Rotation dialog (Figure 119). To display this dialog, select the graphic object so that the selection handles are shown, then press F4 or select Format > Position and Size and select the Rotation page.

In the upper part of the dialog, select the position of the pivot point relative to the top left corner of the page. The default position of the pivot point is the center of the figure.

In the lower part of the dialog select the angle by which to rotate the graphic object. To the right of the Angle text box, eight default rotation values can be selected.

![Figure 119: Rotation page of Position and Size dialog](image)

Flipping objects

The quickest and easiest method to flip an object horizontally or vertically is as follows:

1) Click on a graphic object and the selection handles will show.
2) Right click and select **Flip > Horizontally** or **Flip > Vertically** and the selected object will be flipped to face the other direction.
The Flip tool on the Drawing or Mode toolbar can also be used. Using this tool also allows you to change the position and angle that the object flips over (Figure 120).

1) Click on a graphic object and the colored selection handles will show.
2) Click on the Flip icon and the axis of symmetry appears as a dashed line through the middle of the object. The object will be flipped about this axis of symmetry.
3) Move one or both ends of the axis of symmetry with your mouse cursor to set the orientation of the axis.
4) Place the mouse cursor over one of the object selection handles until it changes shape.
5) Click and hold, then move your cursor across to the other side of the axis of symmetry. The new position of the figure is shown faintly until the mouse is released.
6) Release the mouse button and the object will appear flipped over. The angle and position of the flip will depend on the angle and position of the axis of symmetry.

**Note**
If you press the *Shift* key while moving the line, the line will rotate in 45-degree increments.
Mirror copies

At the moment there is no mirror command existing in Draw. However, mirroring an object can be emulated by using the **Flip** tool as follows:

![Figure 121: Making a mirror copy of an object](image)

1) Select the object you want to make a mirror copy of (Figure 121).
2) Copy the object to the clipboard.
3) Select the **Flip** tool on the Drawing or Mode toolbar.
4) Move the axis of symmetry to the desired location of the mirror axis.
5) Flip the object.
6) Click on an empty area of the page to deselect the object.
7) Paste from the clipboard to put a copy of the object in its original location and now you have a mirror copy.

Distorting an image

Three tools on the Mode toolbar let you drag the corners and edges of an object to distort the image.

- **Distort tool** distorts an object in perspective.
- **Set to Circle (slant)** creates a pseudo three-dimensional effect.
- **Set in Circle (perspective)** creates a pseudo three-dimensional effect.

In all three cases you are initially asked if you want to transform the object to a curve. This is a necessary first step, so click **Yes**. Then you can move the object handles to produce the desired effect. The results of using these tools are shown in the following figures.

**Distort tool**

Select an object and click on the **Distort** icon on the Mode toolbar. After converting to a curve as requested, move the handles to stretch the object. The corner handles distort the corners, the vertical midpoint handles distort the figure horizontally and the horizontal ones distort it vertically (Figure 122).
Set in circle (perspective)

Select an object and click on the Set in Circle (perspective) icon in the Mode toolbar. After converting to a curve, move the object handles to give a pseudo three-dimensional perspective (Figure 123).

Set to circle (slant) tool

Select an object and click on the Set to Circle (slant) icon in the mode toolbar. After converting to a curve, move the object handles to give a pseudo three-dimensional slant perspective (Figure 124).
**Dynamic gradients**

You can control transparency gradients in the same manner as color gradients. Both types of gradient can be used together. With a transparency gradient, the direction and degree of object fill color changes from opaque to transparent. In a color gradient, the fill changes from one color to another, but the degree of transparency remains the same.

Two icons are present on the Mode toolbar to dynamically control transparency and color gradients. Even if you have not assigned transparency to an object with a color fill, you can control the transparency by clicking on the **Transparency** icon. This defines a transparency gradient and a dashed line connecting two squares appears on the object. Move the two squares to modify the gradient. You can define the direction of the gradient (vertical, horizontal, or at any angle) and the spot at which the transparency begins.

A regular color gradient is defined in the same manner. Select an object, choose a gradient fill from the **Line and Filling** toolbar. The **Gradient** icon is now active on the Mode toolbar. When you click on the gradient icon, a dashed line connecting two squares appears on the object, just as it does for a transparency gradient.

In both transparency gradient and gradient fill, click outside the object to set the gradient.

**Note** Moving the squares will have different effects, depending on the type of gradient. For example, for a linear gradient, the start and end squares of the gradient will always be situated to either side of the center point of the object.
Example 1
A single color object and a transparency gradient, covering part of the underlying object. The gradient can be dynamically adjusted; the direction of transparency by moving the white square or the distance over which it is applied by moving the black square (Figure 125).

Figure 125: Example 1 of a dynamic gradient

Example 2
An object with a color gradient, completely covering another object. The gradient is adjusted dynamically by moving the squares – the color of the square relating to the increase or decrease in that color (Figure 126).

Figure 126: Example 2 of a dynamic gradient

Example 3
An object with both color and transparency gradients, partly covering the underlying object (Figure 127).

Figure 127: Example 3 of a dynamic gradient

Chapter 4  Changing Object Attributes  99
Chapter 5
Combining Multiple Objects
Grouping, Combining, Merging, and Positioning
Grouping objects

Grouping of objects is similar to putting objects into a container. You can move the objects as a group and apply global changes to the objects within the group. A group can always be undone and the objects that make up the group can always be manipulated separately.

Temporary grouping

A temporary grouping is when several objects are selected. Any changes to object parameters that you carry out are applied to all of the objects within the temporary group. For example, you can rotate a temporary group of objects in its entirety.

To cancel a temporary grouping of objects simply click outside of the selection handles displayed around the objects.

Grouping

To group objects together permanently, first select the objects by clicking on each object in turn while holding down the Shift key. You can also use the Select icon on the Drawing toolbar and draw a selection rectangle around the objects using the mouse cursor. Selection handles will then appear around all the objects within the group (Figure 128).

Right-click on the group and select Group from the context menu. You can also select Modify > Group from the main menu bar or use the keyboard shortcut Control+Shift+G.

When objects are grouped, any editing operations carried out on that group are applied to all objects within the group. If you click on one object in the group, the whole group is selected.

The objects within a group also retain their own individual properties and can be edited independently. See “Editing individual objects” on page 102 for more information.

Ungrouping

To undo or ungroup a group of objects, right-click on the group and select Ungroup from the context menu. You can also select Modify > Ungroup from the main menu bar or use the keyboard shortcut Control+Alt+Shift+G.

Editing individual objects

You can individually edit an object within a group without ungrouping the group. To do this, right-click on the group and select Enter group, or press the F3 key, or double-click on the group. When you enter a group, objects outside the group cannot be selected for editing and appear pale (Figure 129).
Once inside the group, click on any object to individually edit it (Figure 130).

To leave a group, right-click on the group and select **Exit group**, or press `Ctrl+F3` key, or double-click outside the group.

**Nesting groups**

You can create a group of groups, which is more commonly known as nesting groups. When you create nested groups, Draw retains the individual group hierarchy and remembers the order in which groups were selected. That is, the last individual group selected will be on top of all the other groups within a nested group.

Ungrouping and entering a nested group works in exactly the same way as for individual groups.

**Combining objects**

Combining objects is a permanent merging of objects that creates a new object. The original objects are no longer available as individual entities and cannot be edited as individual objects. Any editing of a combined object affects all the objects that were used when combination was carried out.

**Combining**

Select the objects you want to combine, then right-click on the selection and select **Combine** from the context menu. You can also select **Modify > Combine** from the main menu bar or use the keyboard shortcut `Control+Alt+Shift+K`. At first glance, the results can seem rather surprising, but once you understand the rules governing combination in Draw, combining objects will become clearer.

- The attributes (for example, area fill) of the resulting object are those of the object furthest back. In Figure 131, it is the circle.
- Where the objects overlap, the overlapping zone is either filled or empty depending on the number of overlaps. When the number of overlaps is even, you get an empty space; when the number is odd, you get a filled area. An example of this is shown in Figure 132.
Figure 131: Combining objects

Figure 132: Area fill on overlapping objects

Tip
You can reorder objects so they are further back or further forward in the arrangement order. Right-click on the object and select Arrangement from the context menu. See also “Positioning objects” on page 110.

Splitting a combination
An object which is a combination of several objects can be split into individual entities by selecting Modify > Split from the main menu bar or using the keyboard shortcut Control+Alt+Shift+K. The original objects will retain the formatting of the combined object and will not revert back to their original formatting (Figure 133).

Figure 133: Splitting a combined object
Breaking a combination

An object which is a combination of several objects can be broken into its constituent parts by selecting **Modify > Break** from the main menu bar. The original objects are broken into their constituent parts; for example, a rectangle will be broken into four separate lines and the area fill will be lost (Figure 134).

![Figure 134: Breaking a combined object](image)

Connecting lines

The constituent parts of an object can be connected together by selecting all the constituent parts of the object and selecting **Modify > Connect** on the main menu bar. This connects the parts together and closes the object resulting in the area becoming filled in the same way as before the object was broken.

Merging, subtracting, or intersecting objects

After you have selected more than one object, the Merge, Subtract, and Intersect functions become available, allowing you to create a new object with a new shape. After selecting several objects, go to **Modify > Shapes** on the main menu bar or right-click and select **Shapes** from the context menu.

Merge

When you merge objects, a new object is created with a shape that follows the shape of the merged objects. The area fill of the merged object is determined by the area fill of the object that is at the rear of all the other objects (Figure 135).

![Figure 135: Merging objects](image)
Subtract

When you subtract objects, the front object is subtracted from the objects behind. This leaves a blank space that the subtracted object occupied (Figure 136).

![Figure 136: Subtracting objects](image)

Intersect

When you intersect objects, the front objects and the exposed area of the object at the rear are removed. This creates a new object from the area of the object at the rear that was covered by the objects at the front (Figure 137).

![Figure 137: Intersecting objects](image)

Practical example

The following example in Table 10 shows how you can use the merge, subtract and intersect functions to create a knife with a wooden handle.

<table>
<thead>
<tr>
<th>Table 10: Creating a knife</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Draw an ellipse and then a rectangle overlapping half of its width.</strong></td>
</tr>
<tr>
<td><strong>Select both shapes, right-click, and select Shapes &gt; Subtract from the context menu.</strong></td>
</tr>
<tr>
<td><strong>Draw another rectangle and put it over the top half of the ellipse.</strong></td>
</tr>
</tbody>
</table>
Select both shapes, right-click, and select **Shapes > Subtract** from the context menu.

Draw a small ellipse covering just the lower right corner.

Select both shapes, right-click, and select **Shapes > Subtract** from the context menu. The knife blade shape is now complete.

To make the handle, draw a rectangle and an ellipse.

Merge the shapes together.

Position the handle on the blade. Select the handle and blade, then group together to create a drawing of the knife.

---

**Duplication and cross fading**

**Duplication**

Duplication makes copies of an object while applying a set of changes (such as color or rotation) to the duplicates. The **Duplicate** dialog (Figure 138) has the following options:

- **Number of copies** – enter the number of copies you want to make.

**Placement** – sets the position and rotation of a duplicate object with respect to the selected object.

  - **X axis** – enter the horizontal distance between the centers of the selected object and the duplicate object. Positive values shift the duplicate object to the right and negative values shift the duplicate object to the left.

![Figure 138: Duplicate dialog](image)

**Chapter 5  Combining Multiple Objects**  107
- **Y axis** – enter the vertical distance between the centers of the selected object and the duplicate object. Positive values shift the duplicate object down and negative values shift the duplicate object up.

- **Angle** – enter the angle (0 to 359 degrees) by which you want to rotate the duplicate object. Positive values rotate the duplicate object in a clockwise direction and negative values in a counterclockwise direction.

- **Enlargement** – sets the size of a duplicate object.
  - **Width** – enter the amount by which you want to enlarge or reduce the width of the duplicate object.
  - **Height** – enter the amount by which you want to enlarge or reduce the height of the duplicate object.

- **Colors** – sets the colors for the selected object and the duplicate object. If you make more than one copy, these colors define the start and end points of a color gradient.
  - **Start** – choose a color for the selected object.
  - **End** – choose a color for the duplicate object. If you are making more than one copy, this color is applied to the last copy.

To duplicate an object or group of objects:

1) Select an object or group of objects.
2) Go to **Edit > Duplicate** or use the keyboard shortcut Shift+F3 to open the **Duplicate** dialog (Figure 138).
3) Select the number of copies, placement, enlargement, and the start and end colors for your duplicate copies.
4) Click **OK** and your duplicate copies are created. An example of a duplication is shown in Figure 139. Each duplicate object is a separate object.
5) To group the duplicate objects into one group, see “Grouping objects” on page 102.
6) To combine the duplicate objects into one object, see “Combining objects” on page 103.

![Figure 139: Duplication example](image)
Cross-fading transforms one object shape into another object shape. The result is a new group of individual objects that includes the start and end objects with the intermediate steps show the transformation from one object shape to another object shape.

The options available in the Cross-fading dialog (Figure 140) are:

- **Increments** – enter the number of shapes you want between the two selected objects.
- **Cross-fade attributes** – applies cross-fading to the line and fill properties of the selected objects. For example, if the selected objects are filled with different colors, a color transition between the two colors is applied.
- **Same orientation** – applies a smooth transition between the selected objects.

To cross-fade two objects:

1. Select two objects and go to Edit > Cross-fading on the main menu bar to open the Cross-fading dialog (Figure 140).
2. Select the number of increments for the transformation.
3. If necessary, select Cross-fade attributes and Same orientation.
4. Click OK to perform the cross-fading. An example of cross-fading is shown in Figure 141. The object created is a group of objects.
5. To ungroup this group of objects so that you can use the individual objects, see “Ungrouping” on page 102.
Positioning objects

Arranging objects

When you combine, merge, subtract or intersect objects, the end result varies depending on which object is at the front and which object is at the back. Each new object that you place on a drawing automatically becomes the front object and all the other objects move backwards in the positioning order. Arranging objects allows you to change the order in which objects are positioned.

First select one or more objects, then click on the Arrange icon on the Drawing toolbar to open the Position toolbar (Figure 142 and Figure 143).

- **Bring to Front** – brings the selected object to the front of the group.
- **Bring Forward** – brings the selected object forward one step.
- **Send Backward** – sends the selected object one step backward.
- **Send to Back** – sends the selected object to the back of the group.
- **In Front of Object** – moves the selected object in front of another selected object.
- **Behind Object** – moves the selected object behind another selected object.
- **Reverse** – reverses the order of the selected objects. This tool is grayed out if only one object is selected.

![Position toolbar](Figure 142: Position toolbar)

Aligning objects

To make your drawing look more professional, you can align objects with each other. Select one or more objects and click on on the Drawing toolbar to open the Align toolbar (Figure 144 and Figure 145).

- **Left** – aligns the left edges of the selected objects. If only one object is selected, the left edge of the object is aligned to the left page margin.
- **Centered** – horizontally centers the selected objects. If only one object is selected, the center of the object is aligned to the horizontal center of the page.
- **Right** – aligns the right edges of the selected objects. If only one object is selected, the right edge of the object is aligned to the right page margin.
**Top** – vertically aligns the top edges of the selected objects. If only one object is selected, the top edge of the object is aligned to the upper page margin.

**Center** – vertically centers the selected objects. If only one object is selected, the center of the object is aligned to the vertical center of the page.

**Bottom** – vertically aligns the bottom edges of the selected objects. If only one object is selected, the bottom edge of the object is aligned to the lower page margin.

### Distributing objects

Distributing objects allows you to space three or more objects evenly along the horizontal axis or the vertical axis. Objects are distributed using the outermost objects in the selection as base points for spacing.

Select at least three objects. To open the Distribution dialog (Figure 146), go to **Modify > Distribution** on the main menu bar or right-click and select **Distribution** from the context menu.

**Horizontal** distribution specifies the horizontal distribution between the selected objects.

- **None** – does not distribute the objects horizontally.
- **Left** – distributes the selected objects so that the left edges of the objects are evenly spaced from one another.
- **Center** – distributes the selected objects so that the horizontal centers of the objects are evenly spaced from one another.
• *Spacing* – distributes the selected objects horizontally so that the objects are evenly spaced from one another.

• *Right* – distributes the selected objects so that the right edges of the objects are evenly spaced from one another.

**Vertical** distribution specifies the vertical distribution between the selected objects.

• *None* – does not distribute the objects vertically.

• *Top* – distributes the selected objects so that the top edges of the objects are evenly spaced from one another.

• *Center* – distributes the selected objects so that the vertical centers of the objects are evenly spaced from one another.

• *Spacing* – distributes the selected objects vertically so that the objects are evenly spaced from one another.

• *Bottom* – distributes the selected objects so that the bottom edges of the objects are evenly spaced from one another.
Chapter 6
Editing Pictures

Raster Graphics
Introduction

Earlier chapters of the Draw Guide have dealt only with vector graphics. However, Draw also contains a number of functions for handling raster graphics (bitmaps) such as photographs and scanned pictures, including import, export, and conversion from one format to another.

Draw can read all the majority of graphic file formats. It has a subset of capabilities similar to raster graphics programs like Adobe Photoshop or Gimp.

Importing graphics

Inserting

To import graphic files into your drawing, go to Insert > Picture > From File on the main menu bar or click the From File icon on the Drawing toolbar to open the Insert Picture dialog (Figure 147).

Draw contains import filters for the majority of graphic formats. If the file you want to import has a graphic format not covered by the import filters, then it is recommended to use one of the many graphic conversion programs that are freely to convert the file into a format that Draw recognizes.

If you select the Preview option in the Insert picture dialog, a preview of the file is shown in the box on the right-hand side. This makes it much easier to choose the file you want and also checks that Draw can import the file format used.

Figure 147: Insert Picture dialog

Embedding

Embedding a graphic into your drawing makes the graphic a permanent part of your drawing. Any changes you make to an embedded graphic will only appear in your drawing and the original graphic file will not affected.

Embedding happens when you import a graphic into your drawing using the Insert File command, copying and pasting, scanning a graphic, or dragging and dropping.
The main advantage of embedding graphics into your drawing is that the graphic is always available no matter what computer is used to open the drawing.

The main disadvantage of embedding graphics is that it creates large file sizes, which may not be desirable if you have limited capacity for storing computer files. Also, if the original graphic is altered, then your drawing will not have an up to date version each time you open your drawing.

**Note** When a raster graphic is embedded into a LibreOffice document or drawing, then the format of that graphic is automatically changed to PNG format.

### Linking

Linking a graphic to your drawing does not insert the graphic into your drawing, but a link is created to where the graphic file is located on your computer. Each time your drawing is opened, any linked graphics will be displayed in your drawing.

The main advantage of linking a graphic file to your drawing is if the original graphic file is altered or replaced by a new graphic with the same filename, then the next time you open your drawing, the latest version of the graphic will also open in your drawing.

The main disadvantage of linking graphics is that the link between your drawing and the graphic file must be maintained for linking to work correctly. If you move your drawing to another computer, then any linked files must also be moved to the same computer and the same folder on that computer.

To link a graphic file to your drawing, select the **Link** option in the Insert Picture dialog (Figure 147) before selecting the file and clicking on the **Open** button.

**Note** When a graphic file is linked to a LibreOffice document or drawing, the format of the linked graphic is not changed.

Any changes made to a linked graphic within your LibreOffice drawing will only apply to your drawing and will not affect the original graphic file that has been linked to your drawing.

Links can be updated, modified or broken by going to **Edit > Links** on the main menu bar to open the **Edit Links** dialog (Figure 148). Select the link to be updated, modified or broken and then click on the appropriate button. If you break a link, then the linked graphic becomes embedded in your drawing and the graphic format is converted to PNG.

---

**Figure 148: Edit Links dialog**
**Scanning**

With most scanners you can directly insert a scanned image into a drawing or document. Scanned images are embedded using PNG format.

Make sure that your scanner is configured for the computer and supported by the SANE system for a Linux operating system, or TWAIN for a Windows or Mac operating system.

To insert an image from the scanner:

1) Place a document, drawing, or photograph in the scanner and make sure that the scanner is ready.

2) Go to **Insert > Picture > Scan > Select Source** on the main menu bar to select the scanner if this is the first time the scanner has been used OR go to **Insert > Picture > Scan > Request** on the main menu bar if the scanner has been used before.

**Note**

If there is more than one scanning device connected to the computer, you will be able to select the device when you select the source. This selection will then become the default source when using scan requests until another device is used as the scanning source.

3) The rest of the procedure depends on the scanner driver, interface and computer operating system. You will normally be required to specify scanning options such as resolution, scan window, and so on. Consult the documentation that came with the scanner for more information.

4) When the image has been scanned, Draw places it in the drawing. At this point it can be edited like any other graphic.

**Copying and pasting**

Copying a graphic and then pasting the graphic is another way of embedding graphics into a drawing (this is also called using the clipboard). The copied graphic can be an image already embedded in another document or drawing, or it can be a graphic file such as a drawing, document or photograph.

After copying you can also choose the format when you paste a graphic into Draw using **Edit > Paste Special** from the main menu bar. Available formats will depend on the type of image copied onto the clipboard.

**Dragging and dropping**

Dragging and dropping is another method of embedding graphics into a drawing and can be used on graphics that have been embedded or linked. The way that dragging and dropping works is determined by the computer operating system. Behavior of dragging and dropping is normally controlled using the Ctrl or Ctrl+Shift keys in combination with the mouse.

Objects and images which are used frequently can be stored in the Draw Gallery. From the Gallery a copy of the object or image can be simply dragged onto the drawing. Working with the Gallery is dealt with in *Chapter 10 Advanced Draw Techniques*.

**File inserting**

On the main menu bar there is an option to insert a file (**Insert > File**). This option allows you to insert from an existing Draw drawing (*.ODG), an Impress presentation (*.ODP), a Writer document (*.ODT), or a document in Rich Text Format (RTF), HTML format or plain text. Any text will be contained within a text frame with paragraph and character formatting options available.

When inserting a file, normally the complete file will be inserted into your drawing.
However, when choosing a Draw or Impress file you can also select individual slides or individual objects for insertion into your drawing.

After selecting a Draw or Impress file and clicking on Insert, the Insert Slides/Objects dialog (Figure 149) opens. To access individual slides or objects, click on the expansion symbol (usually a + or a small triangle, depending operating system) to the left of the file name in the selection area.

Select the slides or objects you want to insert and click OK to insert the selected items into your drawing.

If the inserted object was named in the source document, it keeps its original name unless the name already exists in the current document. If there is a name clash, you must give the object a new name before it is inserted. To rename an inserted object, right-click and choose Name from the context menu. Renaming has the advantage that the object is then listed in the Navigator.

### Exporting graphics

#### Exporting the entire file

By default Draw saves drawings in the *.ODG format and some software programs cannot open these files. To make your drawings available for other programs, you can export the file in various formats.

1) Select your file and go to File > Export on the main menu bar
2) Select the required format from the upper section of the File format drop down list (Figure 150).
3) Click Export.
4) Depending on the format selected, another dialog will open allowing you to select the required options for the selected graphic format.

5) Click on Export, Create or OK and your file will be exported as a new file in its new format.

**Note**
The format options in the upper section of the File format drop down list (EMF, HTML, XHTML, PDF, and SWF) only apply to complete files.

### Exporting objects

To export individual objects from your drawing:

1) Select the objects and then go to **File > Export** on the main menu bar.

2) Select the required graphic format from the lower section of the **File format** drop down list.

3) Select the **Selection** option on the Export dialog (Figure 150).

4) Click **Export**.

5) Depending on the graphic format selected another dialog will open allowing you to select the required options for that graphic format.

6) Click on Export, Create or OK and your selected objects will be exported as a new file in its new format.

### Formatting raster objects

Objects that are raster graphics can be formatted using the Format or context menus. The Picture toolbar is used to add or change filters and adjust the properties of lines, areas and shadows.

The Transparency property in the Format menu does not relate to the transparency of the raster graphic itself but to the background area. To change the transparency of a raster graphic, you must use the Picture toolbar, see “Picture toolbar” on page 118.

Some raster graphics may have a text element and for more information on formatting text, see Chapter 9 Adding and Formatting Text.

You can change position and size or rotate raster graphics and for more information see Chapter 3 Working with Objects and Object Points. Raster graphics can also be flipped (**Modify > Flip** on the main menu bar), but some metafile graphic formats may have problems flipping if they contain text.

Raster graphics included in a group behave like other objects when the properties of the group are modified.

It is recommended to name raster graphics using **Modify > Name** from the main menu bar or the context menu. Only named objects are visible in the Navigator and only named objects can be directly imported from another file.

### Picture toolbar

The Picture toolbar will automatically appears when you select a picture (Figure 151 and Figure 152). This can be in the main menu bar or as a floating toolbar.

![Picture toolbar](https://example.com/figure151.png)

*Figure 151: Picture toolbar*
The tools available from left to right on the **Picture** toolbar are as follows:

- **Filter**: opens the Graphic Filter toolbar which is described in “Graphic filter toolbar” on page 121.
- **Graphics mode**: changes the display of the graphic from color to grayscale, black and white, or a watermark. This setting affects only the display and printing of the picture; the original picture file remains unchanged.
  - *Default*: the graphic is displayed unaltered in color.
  - *Grayscale*: the graphic is displayed in 256 shades of gray.
  - *Black/White*: the graphic is displayed in black and white.
  - *Watermark*: the brightness and contrast of the graphic are reduced to the extent that the graphic can be used as a watermark (background).
- **Color**: opens the Color toolbar (Figure 153) to adjust the values of the three RGB colors, brightness, contrast, and Gamma. These adjustments do not affect the original picture, but the values are stored in Draw as a separate formatting set.
  - *Red, Green, Blue*: select values between -100% (no color) to +100% (full intensity); 0% represents the original color value of the graphic.
  - *Brightness*: select a value between –100% (totally black) and +100% (totally white).
  - *Contrast*: select a value between –100% (minimum) and +100% (maximum).
  - *Gamma*: this affects the brightness of the middle color tones. Select a value between 0.10 (minimum) to 10 (maximum) Try adjusting this value if changing brightness or contrast does not give you the required result.

- **Transparency**: adjust the degree of transparency of the picture between 0% (opaque) and 100% (fully transparent).
- **Line**: opens the Line dialog. In this context, line refers to the outline of the border. See *Chapter 4 Changing Object Attributes* for more information.

![Color toolbar](image)

*Figure 153: Color toolbar*
- **Area**: opens the Area dialog allowing you to edit color, gradient, hatching and fills of the background area that contains the picture — not the picture itself. To see the background, you must set the transparency of the picture to a suitably high value.

- **Shadow**: sets the default shadow effect around the picture.

- **Crop Picture**: crops (trims) a picture. When you click on this tool, crop marks appear around the picture. Drag one or more of these marks to crop the picture to your desired size. For more accurate cropping, see “Cropping” on page 120.

**Cropping**

For more control and accuracy over cropping functions, select the picture and go to Format > Crop Picture, or right-click and select Crop Picture from the context menu to open the Crop dialog (Figure 154).

Any changes made in the Crop dialog change only the display of the graphic. The original graphic file is not changed. If you want to export a cropped graphic, you must do it through File > Export. If you use Save as Picture from the context menu, the changes are not exported.

![Crop dialog](Figure 154: Crop dialog)

**Note**

As an alternative to cropping, the **Position and Size** dialog has an option for keeping the width and height ratio fixed while changing one of the two dimensions. Changing values in one area (Scale or Image Size) will show up correspondingly in the other area.

**Caution**

Take care with cropping operations. In the **Crop** dialog, the width and height are treated as independent values. Changing one without the other can result in significant distortion of the image and this may not be what you want.
Crop

This section of the Crop dialog allows you to trim or scale the selected graphic, or to add white space around the graphic.

- **Keep scale**: – maintains the original scale of the graphic when cropping so that only the size of the graphic changes.
- **Keep image size**: – maintains the original size of the graphic when you crop so that only the scale of the graphic changes. To reduce the scale of the graphic, select this option and enter negative values in the cropping boxes. To increase the scale of the graphic, enter positive values in the cropping boxes.
- **Left** and **Right**: – if Keep Scale is selected, enter a positive amount to trim the left or right edge of the graphic, or a negative amount to add white space to the left or right of the graphic. If Keep image size is selected, enter a positive amount to increase the horizontal scale of the graphic, or a negative amount to decrease the horizontal scale of the graphic.
- **Top** and **Bottom**: – if Keep Scale is selected, enter a positive amount to trim the top or bottom of the graphic, or a negative amount to add white space above or below the graphic. If Keep image size is selected, enter a positive amount to increase the vertical scale of the graphic, or a negative amount to decrease the vertical scale of the graphic.

Scale

This section of the Crop dialog allows you to change the scale of the selected graphic. In the **Width** and **Height** fields enter a value for the width or height of the selected graphic as a percentage.

Image size

This section of the Crop dialog allows you to change the size of the selected graphic. In the **Width** and **Height** fields enter a value for the width or height of the selected graphic.

Above the Original Size button, the original size of the graphic is displayed. Clicking on this button and then clicking OK resets the inserted image to the original image size.

Graphic filter toolbar

After selecting a graphic and the Picture toolbar (Figure 151) has opened, click on the Filter icon to open the Graphic Filter toolbar (Figure 155 and Figure 156). Draw offers eleven filter effects. Filters work on the current view of a graphic and they can be combined. Filters always apply to the entire graphic and it is not possible to use filters to edit only a part of the object.

---

**Figure 155: Graphic Filter toolbar**
Note

If your graphic is linked, any graphic filters used are only applied to the current view. The original graphic is not changed. When you close your drawing, any filtering applied is lost. To keep a copy of your filtered graphic, export the graphic to create a copy with all the filters applied (File > Export).

If your graphic is embedded, all graphic filters are applied directly on the embedded graphic and cannot be undone in a subsequent session. After you save and close your drawing, the graphic filter effects become permanent. If you do not want to retain a graphic filter, you must use Edit > Undo to return to cancel the filter effect.

Invert graphic filter

Inverts or reverses the color values of a color image (similar to a color negative), or the brightness values of a grayscale image. Apply the filter again to revert to the original graphic (Figure 157).

Smooth graphic filter

Softens or blurs the image by applying a low pass filter reducing the contrast between neighboring pixels and produces a slight lack of sharpness. If you use the filter several times, the effect will be strengthened (Figure 158).
Sharpen graphic filter

Sharps the image by applying a high pass filter increasing the contrast between neighboring pixels emphasizing the difference in brightness. This will accentuate the outlines and the effect will be strengthened if you apply the filter several times (Figure 159).

Remove noise graphic filter

Removes noise by applying a median filter by comparing every pixel with its neighbors. It then replaces extreme values of those pixels that deviate in color by a large amount from a mean value by a pixel with a mean color value. The amount of picture information does not increase, but because there are fewer contrast changes resulting in a graphic that looks smoother (Figure 160).

Solarization graphic filter

Solarization is a phenomenon in photography in which the image recorded on a negative or on a photographic print is wholly or partially reversed in tone. Dark areas appear light or light areas appear dark. Solarization was originally a photochemical effect used during photographic film development and is now used in the digital world of computing to create a change or reversal of color (Figure 161 and Figure 162).
Clicking on the **Solarization** tool opens a dialog allowing you to define the threshold value for solarization. Entering a threshold value above 70% reverses the color values (center picture in Figure 161). Selecting the Invert option, all the colors are inverted (right picture in Figure 161).

**Aging graphic filter**

Aging creates a look that resembles photographs developed in the early days of photography. All pixels are set to their gray values and then the green and blue color channels are reduced by the amount specified in the Aging dialog. Red color channel is not changed (Figure 163 and Figure 164).
Posterize graphic filter
Posterizing reduces the number of colors in a graphic making it look flatter. When used on a photograph, posterizing can make the photograph look like a painting. Clicking on the Posterize tool opens a dialog allowing you to define the number of poster colors to produce the effect you want (Figure 165 and Figure 166).

![Posterize graphic filter](image)

Figure 165: Posterize graphic filter

![Posterize dialog](image)

Figure 166: Posterize dialog

Pop art graphic filter
Changes the colors of a graphic to a pop-art format (Figure 167).

![Pop art graphic filter](image)

Figure 167: Pop Art graphic filter

Charcoal sketch graphic filter
Displays the graphic as a charcoal sketch. The contours of the graphic are drawn in black and the original colors are suppressed (Figure 168).
Relief graphic filter

The Relief graphic filter calculates the edges of a graphic in relief as if the graphic is illuminated by a light source. The position of the light source is selectable producing shadows that differ in direction and magnitude (Figure 169 and Figure 170).

Mosaic graphic filter

The Mosaic graphic filter joins groups of pixels and converts them into a rectangular tile in a single color creating a graphic that appears to be a mosaic. The larger the individual rectangles created, the fewer details the mosaic graphic has.

Clicking on the Mosaic tool opens a dialog allowing you to set the number of pixels used to create the width and height of the new tile created. The edges of each tile created can also be enhanced to create a sharper definition (Figure 171 and Figure 172).
Replacing colors

The Color Replacer allows you to replace or change a color in a graphic for another color or set the color as transparent. Up to four colors can be replaced at once. The tool works on the entire graphic and you cannot select an area of the graphic for editing.

The Color Replacer can only be used on embedded graphics. If you try to use the Color Replacer on a linked graphic, you will get the following error message “This graphic is linked to a document. Do you want to unlink the graphic in order to edit it?”.

The selection list for replacement colors shows all the available colors in the current color palette of the drawing. You cannot define any new colors here but you can add colors to the available palette before using the Replace Color tool. For more information on this topic, see Chapter 10 Advanced Draw Techniques.

Replacing colors

A color is replaced in a graphic as follows:

1) Go to Tools > Color Replacer on the main menu bar to open the Color Replacer dialog (Figure 173).
2) Select a graphic to start using the Color Replacer.
3) Click on the pipette icon \( \text{ῳ} \) to activate the color selection mode.
4) Move the cursor over the color you want to replace in the selected graphic and click on the color to be replaced.
5) A check box is now marked and the selected color appears in Source color.
6) Enter the amount of tolerance required for replacing the color in the Tolerance box. The default selection is 10% tolerance.
7) In Replace select a color from the drop down list. Transparent is the default selection.
8) Click on the Replace button to replace the colors in the selected graphic.
9) There is no preview of the effect. If the result is not what you required, select Edit > Undo in the main menu bar and repeat the color replacement.

Replacing transparent areas
It is also possible to replace transparent areas in a graphic with a color.

1) Go to Tools > Color Replacer on the main menu bar to open the Color Replacer dialog. (Figure 173).
2) Make sure the graphic is NOT selected.
3) Select Transparency in the Color Replacer dialog.
4) Select a color from the drop down list next to Transparency.
5) Click Replace to replace the transparent areas with the selected color.

Tolerance parameter
The tolerance parameter is used to set how much of the source color in the graphic is replaced by another color. To replace colors that are similar to the color you are replacing, enter a low value for the tolerance parameter. To replace a wider range of colors, enter a higher value for the tolerance parameter.

Conversion

Convert to a contour
Converts a selected graphic to a contour by creating a polygon, or a group of polygons. If the conversion creates a group of polygons (for example a text object), then press the F3 key to enter the group before selecting an individual polygon.

To convert a graphic to a contour:

1) Select the graphic in your drawing.
2) Go to Modify > Convert > To Contour, or right click on the graphic and select Convert > To Contour.
Note: Make sure you have finished all your editing to your graphic before converting to a contour as the graphic cannot be edited after conversion.

Convert to a polygon

Converts a selected graphic to a collection of polygons filled with color. The graphic also becomes a vector graphic and can be resized with no loss of image quality or distortion of any text. After conversion, you can break your graphic into groups of polygons and then split these groups into individual polygons. Breaking and splitting allows you to edit or delete individual colors within your graphic.

Converting
To convert a graphic to a polygon:

1) Select the graphic in your drawing.
2) Go to Modify > Convert > To Polygon, or right click on the graphic and select Convert > To Polygon and the Convert to Polygon dialog opens (Figure 174).
3) Select the Number of colors and Point reduction in the Settings section.
4) To prevent any blank areas appearing in your graphic, select the Fill holes option and Tile size.
5) Click on the Preview button to check how your converted graphic will look.
6) Make any necessary changes to the settings and check the preview again.
7) If you are satisfied, click OK to convert your graphic to polygons.

![Convert to Polygon dialog]

Figure 174: Convert to Polygon dialog
**Conversion options and controls**

- **Number of colors:** enter the number of colors to be displayed in the converted image. LibreOffice generates a polygon for each occurrence of a color in the image. The range for the number of colors is between 8 and 32.
- **Point reduction:** removes color polygons that are smaller than the pixel value you enter. The range for point reduction is between 0 and 32 pixels.
- **Fill holes:** fills the blank areas in the graphic that can be created when applying a point reduction.
- **Tile size:** enter the size of the rectangle for the background fill. The range of tile sizes is between 8 and 128 pixels.
- **Source picture:** preview of the original image.
- **Vectorized image:** preview of the converted image. Click on the **Preview** button to generate the vectorized image.
- **Progress:** displays a progress bar during conversion.
- **Preview:** Creates a preview of the converted image without applying any changes.
- **OK:** converts your graphic to polygons.

**Breaking**

After converting your graphic to polygons, you can break your graphic into groups of polygons. Each group of polygons consists of one color.

1) Convert your graphic to polygons, see “Converting” on page 129.
2) Make sure your graphic is selected and go to **Modify > Break** on the main menu bar to break your converted graphic into groups of polygons.
3) Click on a color in your graphic then drag the group of polygons filled with that color out of your graphic to create a new graphic OR press the **Delete** key and delete the color from your graphic.

**Splitting**

After converting your graphic to polygons and breaking your graphic into groups of polygons, you can then split these groups into individual polygons.

1) Convert your graphic to polygons, see “Converting” on page 129.
2) Break your graphic into groups of polygons, see “Breaking” on page 130.
3) Make sure your graphic is selected and go to **Modify > Split** on the main menu bar or use the keyboard shortcut `Ctrl+Alt+Shift+K` to split groups of polygons into individual polygons.
4) Click on an individual polygon in your graphic and drag it out of your graphic or a polygon group OR press the **Delete** key and delete the polygon from your graphic.

**Convert to a bitmap**

All drawing objects placed into a LibreOffice drawing are vector graphics and these vector graphics can be converted to a bitmap in PNG format. Any transparency effects in the original vector graphic are lost during conversion even though the PNG format used does support transparencies.

To convert a vector graphic to a bitmap, go to **Modify > Convert > To Bitmap** on the main menu bar or right click on the graphic and select **Convert > To Bitmap** from the context menu.
Print options

If you have only a monochrome (single color) printer or are experiencing problems with printing, then the following settings may help with printing your drawing. You can set up printing so that all text and all graphics are printed either in grayscale or black and white.

The general settings are in Tools > Options > LibreOffice Draw > Print (Figure 175) and will apply to all drawings that you print using LibreOffice Draw.

![Figure 175: Options - LibreOffice Draw - Print](image)

To set printing options for the current document only, go to File > Print and click on the Options tab in the Print dialog (Figure 176).

![Figure 176: Print dialog - Options](image)

To set printing options for all the modules in LibreOffice, go to Tools > Options > LibreOffice > Print (Figure 177). These printing options allow you to reduce print data sent to a printer or file, and to give any printer warnings if the wrong paper size or orientation and transparency is set.
Figure 177: Options - LibreOffice - Print
Chapter 7
Working with 3D Objects
Introduction

Although Draw does not match the functionality of leading drawing or picture editing programs, it is capable of producing and editing 3D drawings and pictures.

Draw offers two different types of 3D objects: 3D bodies and 3D shapes. Depending on which type you choose, there are different possibilities for editing an object (rotation, illumination, perspective). 3D shapes are easier to set up and edit than 3D bodies, but 3D bodies allow for more customization.

Creating

You can create 3D bodies using extrusion, body rotation, and 3D settings on objects and text.

If the 3D icons are not visible on the Drawing toolbar (Figure 178), click on the small triangle to the right of the Drawing toolbar, then select Visible Buttons > To 3D or To 3D Rotation Object from the available list of icons (Figure 179).

Extrusion

1) Draw an object using one of the shape tools on the Drawing toolbar, for example square/rectangle, circle/ellipse, or text.
2) Make sure the object you want to convert to 3D is selected.
3) Click the To 3D icon on the Drawing toolbar, or go to Modify > Convert > To 3D, or right-click on the object and select Convert > To 3D, from the context menu and your selected 2D object is converted to 3D (Figure 180).

Extrusion is a procedure by which parallel surfaces are moved to create a 3D object. It happens when a 2D surface is moved forward out of the drawing level. Then, at the same time, the object is slightly tilted and central projection turned on so that the converted object is better recognized as a 3D object. Draw uses a default value for extrusion (body depth) based on the size of a 2D object. This value can be changed after after carrying out extrusion; see “Editing 3D objects” on page 138 for more information.

Figure 180: Extruding a 3D object from a 2D object
Body rotation

To 3D rotation
To 3D body rotation converts an object into 3D by rotating the object using the left edge of the object as the axis of rotation. Body rotation is best shown by using a thick line as an example object. The actual 3D shape created depends on line thickness, line angle and line shape (Figure 181).

1) Draw a line and make sure it is selected.

2) To convert the line into a 3D object, click on the To 3D Rotation Object icon on the Drawing toolbar or got to Modify > Convert > To 3D Rotation object on the main menu bar.

![Figure 181: To 3D body rotation](image)

In 3D rotation
In 3D body rotation converts an object into 3D by rotating the object using a movable axis of rotation. The default location of this rotation axis is the left edge of the object, but the location and angle of rotation can be adjusted, allowing you to create 3D objects that have different shapes. Body rotation is best shown by using a thick line as an example object. The actual 3D shape created also depends on line thickness, line angle and line shape (Figure 182).

1) Draw a line and make sure it is selected.

2) Click on the small triangle next to the Effects icon on the Drawing toolbar and select the In 3D Rotation Object icon from the popup toolbar.

![Figure 182: In 3D body rotation](image)
3) Alternatively, go to View > Toolbars > Mode on the main menu bar to open the Mode toolbar and select the In 3D Rotation Object icon.

4) If necessary, adjust the position and angle of the rotation axis. This is shown as a dashed line with rotation points at each end.

5) Click anywhere outside the object and it is converted into a 3D shape.

| Note | The shape of the Effects icon on the Drawing toolbar changes depending on the last tool that was used.

If the Effects icon is not visible on the Drawing toolbar, then click the small triangle on the right of the toolbar and click on Visible Buttons, then select Effects.

**Ready-made 3D objects**

LibreOffice has a collection of ready-made 3D objects available for immediate use. To access these 3D objects, go to View > Toolbars > 3D Objects on the main menu bar or click on the 3D Objects icon on the Drawing toolbar to open the 3D-Objects toolbar (Figure 183).

![3D-Objects toolbar](Figure 183: 3D Objects toolbar)

| Note | The shape of the 3D Objects icon on the Drawing toolbar changes depending on the last tool that was used.

If the 3D Objects icon is not visible on the Drawing toolbar, then click the small triangle on the right of the toolbar and click on Visible Buttons, then select 3D Objects.

Drawing 3D objects using this toolbar is exactly the same as drawing basic shapes. See Chapter 2 Drawing Basic Shapes in this guide for more information.

**3D scenes**

When a 3D object is created, it becomes what is known as a 3D scene. Draw treats this 3D scene exactly like a group of objects. Press the F3 key, or right click on a 3D object and select Enter Group, or click on Modify > Enter Group on the main menu bar so that you edit the individual elements of a 3D scene. See Chapter 6 Editing Pictures in this guide for more information.

To exit a 3D scene, press the Ctrl + F3 key combination, or right click on a 3D object and select Exit Group, or click on Modify > Exit Group on the main menu bar.

**3D settings**

A 2D object can be converted to 3D using the Extrusion On/Off icon on the 3D-Settings toolbar (Figure 184 and Figure 185). The tools provided on the 3D-Settings toolbar are then used to edit the 3D object.

1) To open the 3D-Settings toolbar, go to View > Toolbars > 3D-Settings on the main menu bar.

2) Select an object and click on the Extrusion On/Off icon to convert the object to 3D. The tools on the 3D-Settings toolbar then become available for use.
Figure 184: 3D-Settings toolbar

- Extrusion On/Off – switches the 3D effects on or off for the selected object.
- Tilt Down – tilts the selected object downward by 5 degrees each time the icon is used.
- Tilt Up – tilts the selected object upward by 5 degrees each time the icon is used.
- Tilt Left – tilts the selected object left by 5 degrees each time the icon is used.
- Tilt Right – tilts the selected object right by 5 degrees each time the icon is used.
- Depth – opens the extrusion depth dialog allowing you to set the depth from an object.
- Direction – opens the extrusion direction dialog allowing you to set extrusion direction and perspective or parallel extrusion.
- Lighting – opens the extrusion lighting dialog allowing you to set lighting direction and intensity.
- Surface – opens the extrusion surface dialog allowing you to set surface material or wireframe display.
- 3D Color – opens the extrusion color toolbar allowing you to set the color used for the extrusion.

Note

3D settings cannot be used on 2D objects converted to 3D using the To 3D icon on the Drawing toolbar.

Text and Fontwork

Text

Draw treats text like an object which can be converted to 3D as easily as any other object in your drawing.
1) Click on the Text icon \( T \) on the Drawing toolbar.
2) Move the cursor onto your drawing and click once to create a text box, then type your text.
3) Click again on the text box to select it. Selection handles show on the text box.
4) Click the To 3D \( \text{To 3D} \) icon on the Drawing toolbar, or go to Modify > Convert > To 3D, or right-click on the object and select Convert > To 3D from the context menu and your selected text is converted to 3D.
5) See “Editing 3D objects” on page 138 on how to change the 3D effects for your 3D text.

Fontwork
The Fontwork Gallery in Draw contains a set of templates allowing you to create artistic text for your drawings. Click on the Fontwork icon \( \text{Fontwork} \) on the Drawing toolbar to open the Fontwork Gallery (Figure 186). See Chapter 5 Managing Graphic Objects in the Impress Guide for more information on the Fontwork Gallery and its tools. After creating your fontwork, it can be converted to a 3D object using the procedures given in “3D settings” on page 136 and “Text” on this page.

![Figure 186: Fontwork Gallery](image)

Editing 3D objects

Rotation
Rotating 3D objects is similar to rotation for 2D objects (see Chapter 3 Working with Objects and Object Points in this guide for more information) plus rotation about global axes. Click once on a 3D object to select it and then click on it again to go into rotation mode.
The corner selection handles allow you to rotate the 3D object in exactly the same way as rotating a 2D object.

The center selection handles at the sides and top and bottom of a selected object allow you to rotate a 3D object about the vertical and horizontal axes respectively (Figure 187).

When you move your cursor onto a 3D object, it normally changes to a double-headed circular arrow. Press and keep the mouse button pressed and, as you move the cursor, the 3D object is rotated globally about any axes. Release the mouse button when you are satisfied with the effect.

The rotation point in the center of a selected 3D object can be moved to change the center of rotation and create a different effect when you carry out rotation. Move your cursor over the rotation point until it changes (normally a pointed fist), then click and hold. Drag the rotation point to a new position and release the mouse button.

### 3D-Settings rotation

3D objects created using the **Extrusion On/Off** tool on the **3D-Settings** toolbar (see “3D settings” on page 136) are rotated or tilted using the **Tilt** tools on the 3D-Settings toolbar (highlighted in Figure 188). Each time a Tilt tool is clicked, the object is moved 5 degrees down, up, left or right about the horizontal or vertical axes.

Double clicking on this type of 3D object activates the rotation handles with only the corner rotation handles active. When you move your cursor over a corner rotation handle, the cursor normally changes to a circular double-headed arrow allowing you to rotate the 3D object as you move the cursor. This rotation is also carried out on the underlying 2D object.

This type of 3D object can also be rotated using the Position and Size dialog. Select the 3D object and go to **Format > Position and Size**, or right click on the selected object and select **Position and Size** from the context menu, or press the F4 key. Click on the Rotation tab to open the Rotation dialog (Figure 189) where you can set the pivot point and rotation angle.

---

**Figure 187**: Rotating 3D objects

**Figure 188**: Tilt tools on 3D-Settings toolbar
The 3D Effects dialog (Figure 190) offers a wide range of possible settings for 3D objects created using the following methods. This dialog can also be used to convert a 2D object to 3D using the tools in the bottom left corner of the dialog:

- “Extrusion” (see page 134).
• “Body rotation” (see page 135).
• “Ready-made 3D objects” (see page 136).

To open the 3D Effects dialog, select your 3D object and right-click on the object then select 3D Effects from the context menu.

You can add a 3D Effects icon to the Drawing toolbar, or any other toolbar, by going to View > Toolbars > Customize or clicking on the small triangle at the right of the toolbar and selecting Customize Toolbar. When the Customize dialog opens, go to Toolbars, select the toolbar and click on the Add button. This will display the Add Commands dialog. The 3D Effects icon is located in the Options category.

3D Effects dialog
The 3D Effects dialog is divided into five main areas as follows:

• Geometry – adjusts the shape of the selected 3D object; see “3D Effects - Geometry” on page 142 for more information.

• Shading – sets the shading and shadow options for the selected 3D object; see “3D Effects – Shading” on page 144 for more information.

• Illumination – defines the light source for the selected 3D object; see “3D Effects – Illumination” on page 146 for more information.

• Textures – sets the properties of the surface texture of the selected 3D object and is only available after surface textures have been applied to the 3D object; see “3D Effects – Textures” on page 148 for more information.

• Material – changes the coloring of the selected 3D object; see “3D Effects - Material” on page 149 for more information.

Any of these 3D settings that you apply to a 3D object are not carried out until you click on the Assign icon. This allows you to make all the 3D Effects changes first before applying them to your 3D object.

3D conversion
In the bottom left of all the Effects dialogs are tools allowing you to convert a 2D object to a 3D object and to change the projection used in a 3D object.

• Convert to 3D – converts the selected object to 3D using extrusion; see “Extrusion” on page 134 for more information.

• Convert to Lathe Object – converts a 2D object to 3D using body rotation; see “Body rotation” on page 135 for more information.

• Perspective On/Off – switches perspective projection on or off for a 3D object. Perspective projection is where projecting lines from the center of projection pass through an imaginary plane until they meet at a point some distance from an object.
3D Effects - Geometry

On the Geometry page of the Effects dialog (Figure 190 on page 140) you can make changes to the geometry of a 3D object.

- **Geometry** – define the shape properties for the selected 3D object.
  - **Rounded edges** – enter the amount by which you want to round the corners of the selected 3D object. Figure 191 shows an example of a 3D cylinder with the rounded edges increased to 30%.

![Figure 191: Example of increased rounded edges](image)

- **Scaled depth** – enter the amount by which to increase or decrease the frontal area of the selected 3D object. Figure 192 shows an example of a 3D cylinder with the scaled depth increased to 150%. A scaled depth of less than 100% decreases the frontal area.

![Figure 192: Example of increased scaled depth](image)

- **Rotation angle** – enter the angle in degrees to rotate the selected 3D rotation object. This option is only available when a 2D object is converted to 3D using the To 3D Rotation Object tool. Figure 193 shows an example of a 2D circle converted to 3D and the rotation angle changed to 175 degrees.

![Figure 193: Example of rotated 3D object](image)
- **Depth** – enter the extrusion depth for the selected 3D object. This option is not valid for 3D rotation objects. Figure 194 shows an example of a 2D circle converted to a 3D cylinder with the extrusion depth increased to 3 cm.

**Figure 193: Example of a 175 deg rotation angle**

**Figure 194: Example of increased depth**

- **Segments** – changes the number of segments that Draw uses to draw a 3D rotation object. The higher the number of segments, the smoother the object surface will be. However, a high segment number may increase the time it takes to generate the 3D object on your display. Figure 195 shows the difference on a 3D sphere when the segments have been increased from 10 to 30 segments horizontally and vertically.
  - **Horizontal** – enter the number of horizontal segments to use in the selected 3D rotation object.
  - **Vertical** – enter the number of vertical segments to use in the selected 3D rotation object.

**Figure 195: Example of using segments**

- **Normals** – modifies the rendering style of the 3D surface (Figure 196 and Figure 197).
  - **Object-Specific** – renders the 3D surface according to the shape of the object. For example, a circular shape is rendered with a spherical surface.
  - **Flat** – renders the 3D surface as polygons.
  - **Spherical** – renders a smooth 3D surface regardless of the shape of the object.
Invert Normals – inverts or reverses the light source.

Double-sided Illumination – lights an object from the outside and the inside of the object. To use as an ambient light source, click this button, and then click the Invert Normals button.

Double-Sided – closes the shape of a 3D object that was created by extruding a free-form line.

3D Effects – Shading
On the Shading page of the Effects dialog (Figure 198) you can set the shading and shadow options for the selected 3D object.

- **Shading** – specifies the type of shading applied to a 3D object (Figure 199).
  - Mode – selects the shading method used on a 3D object.
  - Flat – assigns a single color of shading to a single segment on the surface of the object.
  - Gouraud – blends shading colors across the segments.
  - Phong – averages the shading color of each pixel in a segment based on the pixels that surround it, and requires the most processing power.

- **Shadow** – adds or removes a shadow from a selected 3D object (Figure 200).
  - 3D Shadowing On/Off – switches the shadowing on or off.
  - Surface angle – enter an angle from 0 to 90 degrees for casting a shadow.
Figure 198: 3D Effects dialog - Shading

Figure 199: Example of using Shading

Figure 200: Example of using Shadow
Figure 201: Example of using Camera

- **Camera** – sets the camera options for a selected 3D object as if you are actually using a camera to take a photograph (Figure 201).
  - **Distance** – enter the distance to leave between the camera and the center of the selected object.
  - **Focal length** – enter the focal length of the camera lens, where a small value corresponds to a fish-eye lens and a large value to a telephoto lens.

![Camera example](image)

Figure 202: 3D Effects dialog - Illumination

**3D Effects – Illumination**

On the Illumination page of the Effects dialog (Figure 202) you define how a 3D object is lit, and the settings apply to all 3D objects in a scene. You can specify the light source for the object, as well as the color of the light source and of the ambient light.

By default one light source is already selected when you open the Illumination page. However, you can select another light source or use more than one light source for illumination. A maximum of eight sources can be used and each light source can use a different color. At least one light source
must be active; otherwise, the rendering and shading functions on 3D Effects will not function
correctly.

1) Double click on a **Light source** icon 🗺️ to turn the light source on, or select a light source
and press the space bar.

2) Select a color for the light from the drop down list for **Light source**. A different color can be
used for each light source selected.

3) If necessary, select a color from the drop down list for **Ambient light** to set the color of the
surrounding light.

4) To deselect a light source, select the light source and click on it again.

The light source location and color are shown in the lower right corner of the Illumination page
(Figure 203). The vertical slider bar adjusts the lighting angle and the horizontal slider bar rotates
the light about the object. Alternatively you can click on the light point and drag the light source to
where you want it.

![Figure 203: Adjusting a light source](image)

![Figure 204: 3D Effects - Textures](image)
To change the preview from a sphere to a cube, click on the small square to the right of the horizontal slider bar and below the vertical slider bar.

Each light source selected is shown as a small colored sphere in the color specified for it. The larger colored sphere indicates the active light source.

3D Effects – Textures

On the Textures page of the Effects dialog (Figure 204) you can set the properties of the surface texture for a selected 3D object. The Textures page is only available after you have set the Area Fill of a 3D object to Gradient, Hatching or Bitmap.

- **Type** – sets the color properties of the texture.
  - *Black & White* – converts the texture to black and white.
  - *Color* – converts the texture to color.

- **Mode** – shows or hides shading.
  - *Only Texture* – applies the texture without shading.
  - *Texture and Shading* – applies the texture with shading. To define the shading options for the texture, use the Shading page of this dialog.

- **Projection X** – sets the options for displaying the texture along the X axis. Only one of the three following options can be selected.
  - *Object-Specific* – automatically adjusts the texture for best fit based on the shape and size of the object. This is the default setting.
  - *Parallel* – applies the texture parallel to the horizontal axis and is mirrored on the rear side of the object.
  - *Circular* – wraps the horizontal axis of the texture pattern around an object.

- **Projection Y** – sets the options for displaying the texture along the Y axis. Only one of the three following options can be selected.
  - *Object-Specific* – automatically adjusts the texture for best fit based on the shape and size of the object. This is the default setting.
  - *Parallel* – applies the texture parallel to the vertical axis and is mirrored on the rear side of the object.
  - *Circular* – wraps the vertical axis of the texture pattern around an object.

- **Filter** – filters out noise that can occur when you apply a texture to a 3D object.
  - *Filtering On/Off* – blurs the texture slightly to remove unwanted speckles.

Before Textures can be used, you must change the area fill of your 3D object. For more information, see Chapter 4 Changing Object Attributes.

1. Select your 3D object.
2. Right click on your 3D object and select *Area* from the context menu or go to Format > Area on the main menu bar to open the *Area* dialog.
3. From the *Fill* drop down list, select *Gradient, Hatching or Bitmap*.
4. Select the fill from the list that appears and then click the OK button. The texture is then applied to your selected 3D object.
3D Effects - Material

On the Materials page of the Effects dialog (Figure 205) you can change the appearance of a 3D object to represent different materials.

- **Material** – assigns a predefined color scheme or lets you create your own color scheme.
  - *Favorites* – select a predefined color scheme, or select a custom color scheme that has been user defined.
  - *Object color* – select the color that you want to apply to a 3D object.
  - *Illumination color* – select the color to illuminate the object and brightening parts of the object which lie in shadow making the object seem more illuminated.

- **Specular** – sets the light reflection properties for the selected object simulating the reflecting capacity of the surface. The position of the illuminated point is determined by the setting of the first light source.
  - *Color* – select the color that you want the object to reflect.
  - *Intensity* – enter the intensity of the specular effect.

- **Color icon** – opens the *Color* dialog allowing you to define your own colors using the two-dimensional graphic and numerical gradient chart.

**Tip**

Do not use a very high brightness values for individual colors. These are all additive and it is easy to end up with a colored area that is white.

When you use individual color parameters additional effects can be produced, which are similar to the color parameters in “3D Effects – Illumination” on page 146.
Materials and textures can be combined with each other and it is a matter of trial and error to achieve the desired result.

| Note | Metallic and glass surfaces do not simulate well because the appearance of these materials is produced using reflection. |

**Illumination example**

When textures are also used, the Illumination color is combined with the white color part of the texture (Figure 206). The left object has black Illumination and the right object bright green.

![Figure 206: Example of material illumination](image)

**Specular example**

For the left object in Figure 207, the specular color is the same as the object color and the illumination intensity is set to a low value to create the impression of a matt object surface.

![Figure 207: Example of using specular illumination](image)

For the right object in Figure 207, the color of the illumination point is the same as the light source color to create a shiny appearance to the object surface.

**3D-Settings toolbar editing**

3D objects created using the **Extrusion On/Off** tool on the **3D-Settings** toolbar (Figure 208) are handled differently from other 3D objects. You have to use the tools on the 3D-Settings toolbar to make any changes to a 3D object created using the Extrusion On/Off tool. These tools are highlighted in Figure 208.

![Figure 208: 3D-Settings toolbar - editing](image)
• **Depth** – sets the extrusion depth and direction from the pop-up options.

• **Direction** – sets a direction and a perspective or parallel extrusion from the pop-up options.

• **Lighting** – sets the lighting direction and lighting intensity from the pop-up options.

• **Surface** – sets the surface material or use a wireframe display from the pop-up options.

• **3D Color** – sets the extrusion color from the pop-up options.

The result of any changes made using these editing tools is applied to the selected 3D object immediately and the effect is displayed.

The **3D Effects** dialog described in “3D effects” on page 140 cannot be used on 3D objects created using the Extrusion On/Off tool because the correct formatting results will not be achieved. If you have used the 3D Effects dialog in error, you can remove any incorrect formatting by going to **Format > Default Formatting** on the main menu bar.

### Combining 3D objects

Multiple 3D objects can be grouped or combined together in the same way as 2D objects. See *Chapter 5 Combining Multiple Objects* for more information.
Chapter 8
Connections, Flowcharts and Organization Charts
Connectors and glue points

Connectors and glue points were briefly introduced in Chapter 2 Drawing Basic Shapes. This section describes them in more detail and how to use them.

Connectors are lines or arrows whose ends automatically dock to a connection or glue point on an object. Connectors are useful when drawing, for example, flowcharts and organization charts. The connecting lines between objects remain intact even when objects are moved or rearranged. Also, if you copy an object with a connector, the connector is also copied.

Connectors

Draw has a comprehensive selection of connectors on a Connectors toolbar (Figure 209) to help you connect objects in, for example, a flowchart or organization chart. To open this toolbar, click on the small triangle to the right of the Connector icon on the Drawing toolbar. Note that this icon changes shape depending on the last connector tool used. This toolbar can become a floating toolbar by clicking on the bottom of the pop-up toolbar and dragging it into your workspace.

Types of connectors

Connectors fall into four type groups:

- **Standard connectors** – the line segments run vertically and horizontally. All angles are right angles when the connector bends around objects (Figure 210).
- **Line connectors** – consist of a line segment with two smaller segments at the ends (Figure 211).
- **Straight connectors** – consist of a single line (Figure 212).
- **Curved connectors** – are based on Bézier curves and curve around objects (Figure 213).
Adding connectors

When you click a connector and move the mouse pointer over a filled object or the edge of an unfilled object, glue points appear. A glue point is a fixed point where you can attach a connector line. You can also add custom glue points to an object. See “Glue points” on page 156 for more information.

To draw a connector, select the connector type and click on a glue point on an object. Drag the cursor to a glue point on another object and then release. Draw creates the connector, avoiding any objects in its path (Figure 214).

You can also drag a connector to an empty part of your document. When you release the mouse button, the unattached end of the connector is locked into place until you drag the end to a different location.

![Figure 214: Connector between two objects](image)

![Figure 215: Connector dialog](image)
**Modifying connectors**

To detach or reposition a connector, drag either end of the connector line to a different location.

To change the connector route or shape between objects, click on a control handle in the middle of a section on the connector line and drag it to a new position. Remember not to drag the connector so that it overlaps or touches any objects and creates a confusing drawing.

To modify a connector, right-click on the connector and select **Connector** from the context menu. A Connector dialog (Figure 215) opens where you can change connector type and its properties (*Line skew* and *Line spacing*). You cannot change the ends of the connector using this dialog. To change the ends, you have to draw a new connector.

**Glue points**

Glue points are not the same as the selection handles of an object. The handles are for moving or changing the shape of an object; see Chapter 3 Working with Objects and Object Points for more information. Glue points are used to fix or glue a connector to an object so that when the object moves, the connector stays fixed to the object.

All Draw objects have glue points, which normally are not displayed. Glue points only become visible when the **Connectors** icon on the Drawing toolbar is selected. Note that the Connectors icon changes shape depending on the last connector tool used.

To add, customize or delete glue points to an object, go to **View > Toolbars > Gluepoints** on the main menu bar to open this toolbar (Figure 216). This toolbar only becomes active after you click on the **Glue Points** icon or select **Edit > Glue Points** on the main menu bar. Figure 214 on page 155 shows an example of active glue points.

![Gluepoints toolbar](image)

*Figure 216: Gluepoints toolbar*

**Types of glue points**

When the **Gluepoints** toolbar opens, only the six tools on the left of the toolbar are active. The remaining six tools on the right of the toolbar only become active when the **Glue Point Relative** icon is deselected.

With reference to Figure 217, the following briefly describes the function of each tool on the **Gluepoint** toolbar.

- **Insert Glue Point** – inserts a glue point where you click in an object.
- **Exit Direction Left** – connector attaches to the left edge of the selected glue point.
- **Exit Direction Top** – connector attaches to the top edge of the selected glue point.
- **Exit Direction Right** – connector attaches to the right edge of the selected glue point.
- **Exit Direction Bottom** – connector attaches to the bottom edge of the selected glue point.
- **Glue Point Relative** – maintains the relative position of a selected glue point when you resize an object. This tool is selected by default when the **Gluepoint** toolbar opens. The following six tools only become active when this tool is deselected.
- **Glue Point Horizontal Left** – when the object is resized, the current glue point remains fixed to the left edge of the object.
- **Glue Point Horizontal Center** – when the object is resized, the current glue point remains fixed to the center of the object.
• **Glue Point Horizontal Right** – when the object is resized, the current glue point remains fixed to the right edge of the object.
• **Glue Point Vertical Top** – when the object is resized, the current glue point remains fixed to the top edge of the object.
• **Glue Point Vertical Center** – when the object is resized, the current glue point remains fixed to the vertical center of the object.
• **Glue Point Vertical Bottom** – when the object is resized, the current glue point remains fixed to the bottom edge of the object.

| Note | Each glue point you have added can have only one horizontal position and one vertical position. Only one of the horizontal position tools and one of the vertical position tools can be selected and used at any one time. |

---

**Adding glue points**

By default, most objects normally have four glue points. To add extra glue points to an object or to an object that does not have glue points, proceed as follows:

5) Make sure no objects are selected and click on the Glue Points icon or select *Edit > Glue Points* on the main menu bar. Glue points will appear as small crosses on objects (Figure 214 on page 155).

6) If the Gluepoints toolbar (Figure 216 on page 156) does not open, go to *View > Toolbars > Gluepoints* on the main menu bar.

7) Select the object and then the Insert Glue Point icon .

8) Move your cursor to a position where you want the glue point on an object and double-click to insert the glue point.

9) To move a glue point to another position, click on the glue point and drag it to its new position. Guide lines automatically appear when moving glue points.

| Tip | When adding, moving or customizing glue points, it is recommended to use the zoom function to make it easier to work with glue points. See Chapter 3 Working with Objects and Object Points for more information. |
**Customizing glue points**

Only glue points that have added to an object can be customized. The default glue points included with an object cannot be customized.

1) Make sure no objects are selected and click on the **Glue Points** icon or select **Edit > Glue Points** on the main menu bar. Glue points will appear as small crosses on objects (Figure 214 on page 155).

2) If the **Gluepoints** toolbar (Figure 216 on page 156) does not open, go to **View > Toolbars > Gluepoints** on the main menu bar.

3) Make sure the object is not selected and double-click on a glue point that you have added to select the glue point.

4) Select the exit directions you want to use for connectors and double-click again on the glue point to customize the glue point.

5) To use horizontal and vertical positioning, click on the **Glue Point Relative** icon or right-click on the glue point and select **Adapt Position to Object** from the context menu to deselect this tool.

6) Select the horizontal and vertical positioning tools you want to use and double-click on the glue point to customize the glue point. Only one horizontal positioning tool and one vertical positioning tool can be used at any one time.

**Deleting glue points**

Only glue points that have added to an object can be deleted. The default glue points included with an object cannot be deleted.

1) Make sure no objects are selected and click on the **Glue Points** icon or select **Edit > Glue Points** on the main menu bar. Glue points will appear as small crosses on objects (Figure 214 on page 155).

2) Make sure the object is not selected and double-click on a glue point that you have added to select the glue point.

3) Right-click on the glue point and select **Cut** from the context menu, or press the **Delete** key on the keyboard, or got to **Edit > Cut** on the main menu bar.

**Connector text**

Text can be easily added to connectors, then formatted or edited to make, for example, your flowchart or organization chart easier to follow. See Chapter 2 Drawing Basic Shapes and Chapter 9 Adding and Formatting Text for more information on working with text.

**Adding text**

1) Double-click on the connector. The control points become active and the familiar flashing text cursor appears (the cursor position is determined by the last used setting). The **Text Formatting** toolbar replaces the **Line and Filling** toolbar under the menu bar.

2) Use the **Text Formatting** toolbar or **Format** and **Tools** on the main menu bar to change the default format of the text.

3) Type the text and, when you have finished typing the text and using the text tools, move the cursor away from the objects and connector and click to end the text mode. The **Line and Filling** toolbar then replaces the **Text Formatting** toolbar.
Figure 218: Text dialog

**Formatting and editing text**

1) Click on the text to enter text editing mode. The *Text Formatting* toolbar replaces the *Line and Filling* toolbar under the menu bar.

2) Perform any changes to the text using the text tools provided on the *Text Formatting* toolbar or *Format* and *Tools* on the main menu bar. You can also right-click on the text and select text tools from the context menu.

3) Right-click on the text and select *Text* from the context menu or go to *Format > Text* to open the *Text* dialog (Figure 218) where you can change the *Text anchor* and *Spacing to borders*.

*Note*  
A connector has an invisible rectangle around it. *Text anchor* will position the text within this invisible rectangle and *Spacing to borders* will create margins between the text and the borders. These options are in addition to the standard text tools.

4) Click on the *Text Animation* tab where you can animate the text. However, this is not recommended unless you are going to display the drawing as part of a presentation. See the *Impress Guide* for more information on text animation.

5) When you have finished formatting and editing your text, move the cursor away from the objects and connector and click to end the text mode. The *Line and Filling* toolbar then replaces the *Text Formatting* toolbar.

**Flowcharts**

For drawing flowcharts (also known as flow diagrams), Draw has a *Flowchart* toolbar that includes a large selection of flowchart tools to help you to easily draw a flowchart (Figure 219 and Figure 220). Click on the small triangle to the right of the *Flowchart* icon on the Drawing toolbar to open the *Flowchart* toolbar. Note that this icon changes shape depending on the last flowchart tool used. This toolbar can become a floating toolbar by clicking on the bottom of the pop-up toolbar and dragging it into your workspace.
1) When adding objects to your flowchart, see Chapter 2 Drawing Basic Shapes for information on how to draw and resize object shapes.

2) Add text to each flowchart shape to make it easily identified in the flowchart. See Chapter 2 Drawing Basic Shapes and Chapter 9 Adding and Formatting Text for more information.

3) Use connections lines in your flowchart. This allows repositioning of an object in your chart while maintaining connections with the other objects in the chart. See “Connectors and glue points” on page 154 for more information.

4) Use the zoom, grid and snap functions to help in positioning objects in your flowchart. See Chapter 3 Working with Objects and Object Points for more information.
5) Use the alignment and distribution functions to give your flowchart a more professional look. See *Chapter 5 Combining Multiple Objects* for more information.

6) Duplicate objects when you require more than one of the same shape and size. See *Chapter 5 Combining Multiple Objects* for more information.

## Organization charts

Draw does not have a toolbar for organization charts, but these charts are easily created using basic shapes, flowchart shapes, connection points and connector lines. Hierarchy in an organization is easily indicated using shading and/or color. When using shading and color in an organization chart, make sure that your choices provide a good contrast between the text and the shading or color to make the chart easy to read on a computer display or in a printed document.

An example of an organization chart is shown in Figure 221. This was drawn using the process shape from the **Flowchart** toolbar and connection lines.

1) When adding objects to your chart, see *Chapter 2 Drawing Basic Shapes* for information on how to draw and resize object shapes.

2) Add text to each object in the organization chart to make it easily identified in the chart. See *Chapter 2 Drawing Basic Shapes* and *Chapter 9 Adding and Formatting Text* for more information.

3) Use connections lines in your organization chart. This allows repositioning of an object in your chart while maintaining connections with the other objects in the chart. See “Connectors and glue points” on page 154 for more information.

4) Use the zoom, grid and snap functions to help in positioning objects in your chart. See *Chapter 3 Working with Objects and Object Points* for more information.

5) Use the alignment and distribution functions to give your organization chart a more professional look. See *Chapter 5 Combining Multiple Objects* for more information.

6) Duplicate objects when you require more than one of the same shape and size. See *Chapter 5 Combining Multiple Objects* for more information.

![Figure 221: Example organization chart](image)

*Figure 221: Example organization chart*
Chapter 9
Adding and Formatting Text
Introduction

When is text used in drawings, it is contained in text boxes. This chapter describes how to create, format, use, and delete text. It also discusses the various types of text that can be inserted into a drawing. Finally, it provides information on how to insert special forms of text such as numbered or bulleted lists, tables, fields, and hyperlinks.

Using the text tool

To activate the text tool, click on the Text icon for horizontal text or the Vertical Text icon for vertical text on the Drawing toolbar. If the Vertical Text icon is not visible, check that the option Enabled for Asian languages has been selected in Tools > Options > Language Settings > Languages.

After activating the text tool, the Text Formatting toolbar (Figure 222) replaces the Line and Filling toolbar at the top of the drawing workspace. Click at the location where you want to position the text and a small text frame appears containing only the cursor.

When the Text icon is selected, you can select font type, font size, and other text properties before you start typing text. As you type the text, the left corner of the status indicates that you are in text edit mode and the position of your cursor (Figure 223).

Once you have finished typing your text and clicked outside the text frame or selected another tool from the Drawing toolbar, the Text Formatting toolbar is replaced by the default Line and Filling toolbar.

Using text boxes

Using text boxes, you can place text anywhere on your drawing; for example, a caption for a shape; an explanatory note; a title block for the drawing similar to those used in engineering drawings.

Creating a text box

1) Click on the Text icon on the Drawing toolbar.
2) Click and drag to draw a text box on the drawing. This sets the width. Do not worry about the height because the text box will expand as you type.

3) Release the mouse button when you have reached the desired width for your text box. The cursor appears in the text box and the text box has a hashed border indicating edit mode (Figure 224).

4) Type or paste your text in the text box. The status bar at the bottom of your drawing workspace will indicate that you are in text edit mode and the cursor position within the text box.

5) Click outside the text box to deselect it.

To reposition the text box to a different part of the drawing, see “Moving a text box” on page 165; to change the width, see “Resizing a text box” on page 166.

Moving a text box

1) Click on the text to switch the text box into edit mode. The text box has a hashed border visible around the edges (Figure 224).

2) Move the cursor over the hashed border. The cursor changes shape to the move symbol for your computer setup (for example, a clenched hand).

3) When the move symbol appears, click once on the hashed border and selection handles appear.

4) With the cursor on the hashed border (but not on a selection handle), click and drag to move the text box to a new position. A semi-transparent copy of the text box shows where your text box will be placed (Figure 225). Also, depending on computer setup, guide lines may appear while you move the text box.

5) Release the mouse button when the text box is in the desired position.
Resizing a text box

1) Click on the text to switch the text box into edit mode. The text box has a hashed border visible around the edges (Figure 224).

2) Move the cursor over the hashed border. The cursor changes shape to the move symbol for your computer setup (for example, a clenched hand).

3) When the move symbol appears, click once on the hashed border and selection handles appear.

4) Move the cursor over one of the selection handles and the cursor changes shape to the resizing symbol for your computer setup (for example, a double headed arrow).

5) Click and drag the border to a new position to resize the text box (Figure 226). Depending on computer setup, guide lines may appear while you move the text box.

6) Release the mouse button when the text box reaches the desired size.

![Figure 226: Resizing a text box](Image)

**Note**

- Use the selection handles at the top and bottom of the text box to resize the text box height.
- Use the selection handles at the left and right side of the text box to resize the text box width.
- Use the corner selection handles to resize the height and width of the text box while maintaining the aspect ratio of the text box.

**Tip**

To maintain the aspect ratio of a text box while resizing, press and hold the Shift key, then click and drag. Make sure to release the mouse button before releasing the Shift key.

Using the Position and Size dialog

For more accurate control over the size and position of a text box you can use the **Position and Size** dialog.

1) Click on the text to switch the text box into edit mode.

2) Press the F4 key or select **Format > Position and Size** from the menu bar to open the Position and Size dialog (Figure 227).

The options available on the **Position and Size** dialog are as follows:

- **Position** – specifies the location of the selected object on the page.
Position and Size dialog

- **Position X** – enter the horizontal distance that you want to move the object relative to the base point selected in the grid.
- **Position Y** – enter the vertical distance that you want to move the object relative to the base point selected in the grid.

- **Base point** – click a base point in the grid and then enter the amount that you want to shift the object relative to the base point that you selected in the Position Y and Position X boxes. The base points correspond to the selection handles on an object.

- **Size** – specifies the amount by which you want to resize the selected object with respect to the selected base point.
  - **Width** – enter a width for the selected object.
  - **Height** – enter a height for the selected object.
  - **Keep ratio** – maintains proportions when you resize the selected object.

- **Base point** – click a base point in the grid and then enter the new size dimensions for the selected object in the Width and Height boxes.

- **Protect** – prevents any editing of an object.
  - **Position** – prevents changes to the position or the size of the selected object.
  - **Size** – prevents you from resizing the object.

- **Adapt** – resizes text in a drawing object with respect to the borders of the selected object.
  - **Fit width to text** – resizes the text to fit the width of the selected object.
  - **Fit height to text** – resizes the text to fit the height of the selected object.

**Deleting a text box**

1) Click on the text to switch the text box into edit mode.
2) Move the cursor over the hashed border. The cursor changes shape to the move symbol for your computer setup (for example, a clenched hand).
3) When the move symbol appears, click once on the hashed border and selection handles appear.
4) Press the **Delete** key.
Tip

Sometimes it is quicker to delete a text box by dragging a selection rectangle around the text box and then hitting the Delete key. Take care to avoid selecting and accidentally deleting other text boxes or shapes.

Using text with Draw objects

Text can be added to most Draw objects. The exceptions are control elements like buttons, list boxes, or 3D objects. An object is not dynamic and does not behave like a text frame. To keep text within the borders of the object, you have to use paragraphs, line breaks, or smaller text size, increase the object size, or combine all four methods.

To add text to an object:

1) Select the object.
2) Select the Text icon on the Drawing toolbar and a text cursor starts flashing in the center of the selected object.
3) Start typing your text (Figure 228). The status bar will indicate that you are editing text, as shown in Figure 223.

![Figure 228: Adding text to an object](image)

Note

If the Double-click to edit Text icon on the Options toolbar is selected, you can start adding text to an object by double-clicking on the object without first selecting it.

Inserting text

Pasting text

Text may be inserted into a text box or object by copying it from another document and pasting it into a text box or object on your drawing. However, pasted text may not match the formatting of the text that has already been included on your drawing. This may be what you want on some occasions, but in most cases it is better to make sure that text format is consistent throughout your drawing.

Pasting unformatted text

It is good practice to paste text without formatting and apply the formatting later so it matches the text already in your drawing or make the text fit within the borders of an object.

1) Copy the text you want to use, then move your cursor into position on your drawing.
2) Go to Edit > Paste Special on the main menu bar or use the keyboard shortcut Control+Shift+V or click on the small triangle next on the right of the Paste icon on the Standard toolbar.

3) Select Unformatted text from the dialog or context menu that appears. The text will be pasted at the cursor position and formatted to the default paragraph style of the text box or object.

**Formatting pasted text**

1) Select the text you have just pasted (see “Selecting text” on page 171 for more information).

2) Use the formatting tools that are available on the Text Formatting toolbar, or go to Format on the main menu bar and select a formatting tool from the drop down menu, or right-click on the text and select a formatting tool from the context menu.

3) Alternatively, go to Format > Styles and Formatting or press the F11 key to open the Styles and Formatting dialog. See “Using styles” on page 171 for more information.

**Inserting special characters**

To insert special characters, such as copyright, math, geometric, or monetary symbols, or characters from another language:

1) Click on the Text icon and then click in the text where you want to insert the character.

2) Go to Insert > Special Character on the main menu bar or right-click and select Special Characters from the context menu to open the Special Characters dialog (Figure 229).

3) Alternatively, click on the Special Character icon on the Text Formatting toolbar to open the Special Characters dialog. If this icon is not visible, click on the small triangle at the right of the toolbar and go to Visible Buttons > Special Character and the icon will be placed on the toolbar.

4) Select the font and character subset from the Font and Subset options in the Special Characters dialog.

5) Select the character you want to insert. You may have to scroll to find the character you want.

6) Click OK.

![Special Characters dialog](Figure 229: Special Characters dialog)
Characters you select will be inserted in the order they were selected, even if you accidentally click on the wrong character. Clicking on another character will only add it to the ones being inserted. Click **Delete** to delete all the characters selected, then click on the correct characters.

**Inserting non-breaking spaces and hyphens**

Where it is not desirable for words that are separated by a space or a hyphen to span over two lines, or where an optional hyphen is desired, you can insert a special formatting mark. Draw supports the following formatting marks:

- **Non-breaking space** – inserts a space that will keep bordering characters together on line breaks.
- **Non-breaking hyphen** – inserts a hyphen that will keep bordering characters together on line breaks.
- **Optional hyphen** – inserts an invisible hyphen within a word that will appear and create a line break once it becomes the last character in a line.
- **No-width optional break** – inserts an invisible space within a word that will insert a line break once it becomes the last character in a line. Only available when complex text layout (CTL) is enabled.
- **No-width no break** – inserts an invisible space within a word that will keep the word together at the end of a line. Only available when complex text layout (CTL) is enabled.
- **Left-to-right mark** – inserts a text direction mark that affects the text direction of any text following the mark. Only available when complex text layout (CTL) is enabled.
- **Right-to-left mark** – inserts a text direction mark that affects the text direction of any text following the mark. Only available when complex text layout (CTL) is enabled.

To insert a non-breaking space, or hyphens, or access the formatting marks:

1) Click on the **Text** icon and place the cursor in the text where you want to use formatting marks.
2) Go to **Insert > Formatting Mark** on the main menu bar.
3) Select the formatting mark you want to use from the context menu that opens. A non-breaking space can be inserted using the keyboard shortcut is **Ctrl+Shift+Space**. A no-width-optional break can be inserted using the keyboard shortcut is **Ctrl+Slash**.

**Formatting text**

The appropriate use of text formatting can give text in a drawing a consistent look, making your drawing look more professional without any distracting elements.

**Tip**

Sometimes it is very useful to re-apply the default style to a selection of text removing any manual formatting applied to it, especially if a mistake has been made and you are not sure how to undo it. To revert back to the default style, select the manually formatted text and then select **Format > Default formatting** from the main menu bar.

Formatting text may require some intervention in three areas:

- Character attributes (for example, font color or emphasis)
- Paragraph attributes (for example, alignment or spacing)
- List attributes (for example, type of bullet or indent spacing)
In some cases it is quicker and more efficient to apply manual formatting; but in situations where you need to perform the same modifications to many different parts of the drawing, the use of styles is recommended.

**Selecting text**

Text must be selected before it can be formatted.

To format all the text in a text box:

1) Click on the **Text** icon and then click once on the text.
2) Click once on the border of the text box. The selection handles are displayed.
3) Any formatting changes will apply to all the text in the text box.

To format only part of the text:

1) Click on the **Text** icon and then click once on the text.
2) Select the text to be formatted by clicking and dragging over it (highlighting). You can also use keyboard combinations to select text: move the cursor where you want to begin your selection, press **Shift** and then use the arrow keys to extend your selection.
3) Any formatting changes will apply only to the selected text.

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>To select text word by word, instead of by character, press the <strong>Control</strong> key and <strong>Shift</strong> key together. To speed up the selection even further, you can combine the <strong>Shift</strong> key with the <strong>Home</strong> key or the <strong>End</strong> key to extend the selection up to the start or end of the line in which the cursor is positioned, respectively.</td>
</tr>
</tbody>
</table>

**Using styles**

Only graphic styles are available in Draw to format text. Each graphic style listed in the **Styles and Formatting** dialog (Figure 230) has default settings for formatting and layout. You can create new styles and modify the styles supplied with Draw.

**Creating a style**

1) Go to **Format > Styles and Formatting** on the main menu bar or press the **F11** key to open the **Styles and Formatting** dialog (Figure 230).
2) Right-click on a style name and select **New** from the context menu to open the **Graphic Styles** dialog (Figure 231).
3) Using the **Graphic Styles** dialog, you can set all the attributes for your text and paragraph by clicking on the various tabbed pages that are available. Click **OK** when finished and your new style is added to the list in the **Styles and Formatting** dialog.
4) Alternatively, select your text and perform all the changes to format, then click on the **New Style from Selection** icon to open the **Create Style** dialog.
5) Type a unique style name and click **OK**. This closes the **Create Style** dialog and your new style is added to the list in the **Styles and Formatting** dialog.

**Modifying a style**

1) Go to **Format > Styles and Formatting** on the main menu bar or press the **F11** key to open the **Styles and Formatting** dialog (Figure 230).
2) Right-click on the style to be modified and select **Modify** from the context menu to open the **Graphic Styles** dialog (Figure 231).
3) Using the **Graphic Styles** dialog, modify all the attributes for your text and paragraph by clicking on the various tabbed pages that are available.

4) Click when finished making changes and the style is saved with the new format attributes.

5) Alternatively, select your text and perform all the changes to format, then select a style in the **Styles and Formatting** dialog.

6) Click on the **Update Style** icon and the style is saved with the new format attributes.
Formatting characters

Text characters can be independently formatted from the format used for a paragraph of text. This character formatting will also override any formatting that has been applied using a graphic style. Note that character styles do not exist in Draw.

1) Click on the Text icon, then select the characters you want to format.

2) Go to Format > Character, or click the Character icon on the Text Formatting toolbar, or right-click on the selected character and select Character to open the Character dialog (Figure 232).

3) Make your changes to the character format using the tabbed pages, then click OK to save your changes.

4) Clicking on the Reset button will cancel any changes you have made to the character format and the character will revert back to the paragraph formatting.

![Character dialog](image)

**Figure 232: Character dialog**

If support for Asian language and Complex Text Layout (CTL) font has been enabled (Tools > Options > Language Settings > Languages), the Font page is divided into three parts for Western, Asian and CTL text fonts allowing you to specify text fonts and their attributes for the majority of font families.

The tabbed pages in the Character dialog are used as follows:

- **Font** – select the desired font type, its base attributes (*Italic, Bold*, etc.) as well as the size. A sample of the font is displayed in the lower part of the dialog. You can also specify the language. This font page is also available when creating or modifying a graphics style.

- **Font Effects** – apply special effects to the text, such as over lining and underlining, color, shadow and so on. A sample of the text is displayed in the lower part of the dialog, providing a quick visual check of the effects applied. This page is also available when creating or modifying a graphics style.

- **Position** – sets the text position relative to the baseline when you need to insert subscripts or superscripts. This page is not available when creating or modifying a graphics style.
– **Scaling** – specifies the percentage of the font width by which to compress or expand the individual characters of the selected text.
– **Spacing** – sets the spacing between the characters of the font, which can be defined in number of points.
– **Pair kerning** – automatically adjusts the spacing between certain pairs of characters to visually improve the appearance.

### Formatting paragraphs

Paragraph formatting will override any formatting that has been applied using a graphic style.

1) Click on the **Text** icon then select the paragraph you want to format.
2) Go to **Format > Character**, or click the **Paragraph** icon on the **Text Formatting** toolbar, or right-click on the selected text and select **Paragraph** to open the **Paragraph** dialog (Figure 233).
3) Make your changes to the character format using the tabbed pages then click **OK** to save your changes.
4) Clicking on the **Reset** button will cancel any changes you have made to the paragraph format and the text will revert back to its original formatting.

![Paragraph dialog](image)

**Figure 233: Paragraph dialog**

The tabbed pages in the **Paragraph** dialog are used as follows:

- **Indents and Spacing** – this page is the default page when the Paragraph dialog.
  - **Indent** – modifies the indentation of the text (before and after) as well as the indentation of the first line.
  - **Spacing** – defines the space before and after each paragraph formatted with the style.
  - **Line spacing** – determines the spacing between two lines formatted with the style. Note that selecting **Proportional** spacing requires specifying the percentage of a line to be used as spacing; 100% single line, 200% double line, 50% half a line. If **Leading** is selected, specify the amount of line spacing in your default unit of measurement.
Setting line spacing to less than 100% is a good method to cram a lot of text into a text box, however care must be taken as too small a value will make the text hard to read.

You can change the default unit of measurement by going to Tools > Options > LibreOffice Impress > General.

• **Alignment** – determines the paragraph alignment: Left, Right, Center, or Justified. A preview shows the effects of the changes. This page is also available in the graphics styles dialog. The same alignment options can be accessed using the paragraph alignment icons on the Text Formatting toolbar.

If you have Complex Text Layout enabled in Tools > Options > Language Settings > Languages, an extra selection — Text Direction — appears at the bottom of the dialog; you can choose Left-to-right or Right-to-left.

• **Tabs** – determines the tab stops. This page is also available in the graphics styles dialog.

• **Asian Typography** – sets the following properties relative to line changes and is only available if Enabled for Asian Languages is selected in Tools > Options > Language Settings > Languages. This page is also available in the graphics styles dialog.
  – Apply list of forbidden characters to the beginning and end of lines.
  – Allow hanging punctuation.
  – Apply spacing between Asian, Latin and Complex text.

### Creating bulleted and numbered lists

Bulleted and numbered lists can be created in text boxes, shapes and objects. When creating lists in shapes and objects, remember that shapes and objects are not dynamic and do not expand as you create a list.

**Creating lists**

1) Click on the **Text** icon then select the text you want to use for a bulleted list.
2) Go to Format > Bullets and Numbering, or right-click on the selected text and select Bullets and Numbering to open the Bullets and Numbering dialog (Figure 234).
3) Select the list style from the Bullets, Numbering or Graphics pages then click OK to save your changes.
4) Alternatively, click the Bullets On/Off icon on the Text Formatting toolbar, This quickly creates a list using the previously selected settings in the Bullets and Numbering dialog.
5) Clicking on the Reset button will cancel any changes you have made and the text will revert back to its original formatting.

**Editing and customizing a list**

You can edit and customize the appearance of a list by changing the bullet type or numbering for the entire list or single entry or the outline level of a list item. All changes are made using the Bullets and Numbering dialog.
Editing a list

1) Click on the Text icon, then select the list or the items in the list that you want to edit and customize.

2) Go to Format > Bullets and Numbering, or right-click on the selected text and select Bullets and Numbering to open the Bullets and Numbering dialog (Figure 234).

3) Select a new list style from the Bullets, Numbering or Graphics pages.

4) Click OK to save your changes.

Changing position

Use the Position page (Figure 235) to adjust the outline level, indentation and spacing of bullet points and the associated text. This page is particularly effective when used in combination with the Customize page.

To set up an outline level:

1) Select an outline level from the list on the left hand side of the page or select levels 1 – 10 to modify all levels simultaneously.

2) Set the Indent, which is the spacing between the bullet or number and the text. If you select the Relative option, the indent value will be measured relative to the previous level and not from the margin.

3) Set the measurement for Width of numbering. This is the space to leave between the numbering or bullet point and the text.

4) Set the Numbering alignment and is normally only used on a numbered list. Setting this option does not set the alignment of the text.

   a) Select Left to align the numbering at the left edge of the alignment space for numbering.
   b) Select Right to align the numbering at the right edge of the alignment space for numbering.
   c) Select Centered to align the numbering in the center of the alignment space for numbering.
5) Click OK to save your changes.
6) To revert back to the default values of the list, click Reset.

**Tip**

To fully appreciate how **Numbering alignment** works, create a numbered list with more than ten elements and making sure there is enough room for a two (or more) numerical characters using the **Width of numbering** field. Select **Right** alignment and the right edge of the numbers will form a neat, straight line next before the text.

**Customizing**

Use the **Customize** page (Figure 236) to customize the style of all the outline levels. The options available on this page depend on the type of marker selected for the list.

Depending on the bullet style selected (bullet, numbering; graphic), some of the following options may not be available on the **Customize** page:

- **Before**: enter any text to appear before the number (for example, Step).
- **After**: enter any text to appear after the number (for example, a punctuation mark).
- **Color**: pick the color for the list marker (number or bullet character).
- **Relative size**: specify the size of the number relative to the size of the characters in the paragraph of the list.
- **Start at**: enter the first value of the list (for example, you might want the list to start at 4 instead of 1).
- **Character button**: click this button to select the special character for the bullet.
- **Graphics**: opens a gallery of available graphics or allows the selection of a graphic file used as a marker.
- **Width** and **Height**: specify the dimensions of the graphic marker.
- **Keep ratio checkbox**: if selected, the ratio between the width and the height of the graphic marker is fixed.
Using tables

Tables are useful when you want to show structured information in your drawing, for example a specification list or drawing title block. You can create tables directly in Draw, eliminating any need to embed a Calc spreadsheet or a Writer text table in your drawing. The tables provided by Draw do have a limited functionality.

Creating a table

When working with tables, it is useful to know the number of rows and columns needed as well as the appearance. Tables are placed on a drawing in a text box and cannot be placed into objects or shapes. Also, unlike text boxes and other graphic objects, tables cannot be rotated.

Figure 236: Bullets and Numbering – Customize page

1) Select first the level you want to modify on the left hand side of the box. To modify all levels at once, select 1 – 10 as the level. With levels being arranged in a hierarchical structure, changing, for example, the font attribute of one of the levels ripples through all the lower levels.

2) Make your changes to your list using the options on this page. The preview on the right hand side of the dialog shows the effect of the changes.

3) Click OK to save your changes.

4) To revert back to the default values of the list, click Reset.

Figure 237: Insert Table dialog
To insert a table, proceed as follows:

1) Go to Insert > Table on the main menu bar to open the Insert Table dialog (Figure 237).
2) Select the number of columns and number of rows for your table.
3) Click OK and a table is placed in the center of your drawing inside its own text box.
4) Move your table into position by dragging it to its new position, or using the method in "Using the Position and Size dialog" on page 166.

Modifying a table

Once the table is added to your drawing, you can control its appearance, size, position and so on using a combination of the tools on the Table toolbar (Figure 238 and Figure 239) and the Format Cells dialog (Figure 243). The Table toolbar is only active when a table has been selected. If the Table toolbar does not display when you select a table, go to View > Toolbars > Table.

Figure 238: Table toolbar

Figure 239: Table tools

Figure 240: Table graphic tool
Table toolbar

The Table toolbar contains the majority of the tools you need to manipulate a table. These tools are shown in Figure 239 and described below.

- **Table** – creates a new table in a drawing. Opens the Insert Table dialog (Figure 237) where you can select the required number of rows and columns. Alternatively, click on the small triangle next to the Table icon to open a graphic representation for creating a table (Figure 240). To use this tool, move the mouse to the right and down in the grid until you have the columns and rows you require and click the left mouse button.

- **Line Style** – changes the line style of the borders of selected cells. Opens a new dialog where you can choose from a range of predefined styles.

- **Line color (of the border)** – opens a color selection dialog where you can choose the color of the borders around selected cells.

- **Borders** – selects predefined border configurations. The borders are applied to the selected cells. If the desired border pattern is not available, you will need to use the Format Cells dialog.

- **Area Style/Filling** – select the cells to be filled, then select the type of fill from the drop down list: Invisible (no color), Color, Gradient, Hatching, or Bitmap. Depending on the fill type selected, the fillings drop-down menu is populated with the available fillings for the fill type selected.

- **Merge Cells** – merges the selected cells into one cell. Note that the contents of the merged cells are also merged. You can also merge cells by right-clicking in the selected cells and using the context menu that opens.

- **Split Cells** – opposite operation of merging cells. Make sure that the cursor is positioned on the cell you want to split, then click to open the Split Cells dialog (Figure 241). Select the number of cells required from the split as well as whether the cell should be split horizontally or vertically. When splitting horizontally, you can select the Into equal proportions option to get all cells of equal size. The contents of the split cell remain in the original cell (the one on the left or top). You can also split cells by right-clicking in the cell and using the context menu that opens.

- **Optimize** – evenly distributes the selected cells either horizontally or vertically. If you want to optimize the whole table, you can evenly distribute columns or rows by clicking on the small triangle next to the icon and selecting Distribute Columns Evenly or Distribute Rows Equally.

- **Top, Center (vertical), Bottom** – you can select the vertical alignment of text in a cell by selecting the required cells and clicking on one of these tools.

- **Insert Row, Insert Column, Delete Row, Delete Column** – select a row or column and use these four tools to insert or delete rows and columns into or from your table. Rows and
columns are inserted/deleted below and to the right of the selected cell. You can also select, insert or delete rows and columns by right-clicking a cell and using the context menu that opens.

- **Select Table, Select Column, Select Row** – Use these tools to select a table, column or row if you want to perform the same change to attributes for a table, column or row.

- **Table Design** – opens the Table Design dialog (Figure 242) where you can select a table style and display options.

![Figure 242: Table Design dialog](image)

- **Table Properties** – opens the Format Cells dialog (Figure 243), which contains the following tabbed pages. You can also open this dialog by right-clicking on the table and selecting **Table** from the context menu.

![Figure 243: Format Cells dialog](image)
– **Font** – use to select the desired font type and family, style (*Italic*, **Bold**, etc.), size and language. A sample of the font is displayed in the lower part of the dialog.
– **Font Effects** – use to apply effects to the text: font color; relief; overlining; strikethrough; underlining and emphasis mark.
– **Borders** – use to set borders and border properties not available when using the **Borders** tool on the **Table** toolbar; line arrangement (default or user defined), line (style, width, and color) and spacing to contents (cell margins).
– **Background** – changes the background of the selected cells and provides the same functions as the **Area Style/Filling** tool on the **Table** toolbar.
– **Reset** – clicking this button resets the table back to default values.

**Position and size**
You can change table position and size on a drawing by using the mouse or, for more accurate control, with the **Position and Size** dialog (Figure 227 on page 167). When the table is selected, right-click on the table and select **Position and Size** from the context menu or go to **Format > Position and Size** on the main menu bar or press the F4 key to open the dialog. See “Using the Position and Size dialog” on page 166 for more information.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unlike text boxes and other graphic objects, tables cannot be rotated.</td>
</tr>
</tbody>
</table>

**Deleting a table**
To delete a table:
1) Click and drag over the table to select it.
2) Click on the text box border around the table.
3) Press the **Delete** key.

**Using fields**
Fields allow the automatic insertion of text into a drawing. You can think of a field as a kind of formula which is calculated when the drawing is loaded or printed and the result is written in the drawing.

**Inserting a field**
To insert a field into a drawing:
1) Move the cursor where the field will be positioned. The text box created when you insert a field can be repositioned just like a text box.
2) Go to **Insert > Fields** on the main menu bar.
3) Select a field from the options shown in the context menu.

The fields available in Draw are as follows:

- **Date (fixed)**: inserts the date at the date of inserting the field.
- **Date (variable)**: inserts a field that is updated with the date at the time of opening the file.
- **Time (fixed)**: inserts a field displaying the time at the time of insertion.
- **Time (variable)**: inserts a field which is updated with the time at the time of opening the file.
• **Author**: inserts the author of the drawing. This information is derived from the value recorded in the general options. To modify this information go to **Tools > Options > LibreOffice > User Data**.

• **Page Number**: inserts the page number of the slide.

• **Page Count**: inserts the total number of slides.

• **File Name**: inserts a field that contains the name of the file.

### Customizing fields

The appearance of fields can be customized as follows. The **Page Number**, **Page Count**, and **File Name** fields cannot be customized.

1) Right-click on the field data to open the **Edit Field** dialog (Figure 244).

2) Select the desired format from the options available.

3) Click **OK**.

### Using hyperlinks

When inserting text (such as a website address or a URL) that can be used as a hyperlink, Draw formats it automatically, creating the hyperlink and applying color and underlining.

To insert a hyperlink, or to customize the appearance of a hyperlink, go to **Insert > Hyperlinks** on the main menu bar or click on the **Hyperlink** icon on the **Standard** toolbar to open the **Hyperlink** dialog (Figure 245).

On the left side, select one of the four types of hyperlinks. The dialog changes according to the type of hyperlink selected.

- **Internet**: choose whether the link is Web or FTP. Enter the required web address (URL).

- **Mail & News**: choose whether the link is an E-mail or news link. Enter the receiver address and for email, also the subject.

- **Document**: creates a hyperlink to another document or to another place in the drawing, commonly referred to as a bookmark. Enter the document path, or click on the **Open File** icon to open a file browser; leave this blank if you want to link to a target in the same
drawing. Optionally, you can specify a target (for example, a specific slide). Click on the Target icon to open the Target in Document dialog, where you can select the target; or, if you know the name of the target, you can type it into the box.

![Hyperlink dialog](image)

**Figure 245: Hyperlink dialog**

- **New Document**: creates a hyperlink to a new document. Choose whether to edit the newly created document immediately (Edit now) or just create it to edit later (Edit later). Choose the type of document to create (text, spreadsheet, etc.). The Select path button opens a file browser so that you can choose the directory for the new document.

**Tips**

To prevent LibreOffice from automatically turning website addresses (URLs) into hyperlinks, go to Tools > AutoCorrect > Options and deselect the URL Recognition checkbox.

To change the color of hyperlinks, go to Tools > Options > LibreOffice > Appearance, scroll to Unvisited links and/or Visited links, select the checkboxes, pick the new colors and click OK. Caution: this will change the color for all hyperlinks in all components of LibreOffice which may not be what you want.

The Further settings section on the Hyperlink dialog is common to all the hyperlink types, although some choices are more relevant to some types of links.

- **Frame** – determines how the hyperlink will open. This applies to documents that open in a Web browser.
- **Form** – specifies if the link is to be presented as text or as a button. See “Working with hyperlink buttons” on page 185 for more information.
- **Text** – specifies the text that will be visible to the user.
- **Name** – applicable to HTML documents. It specifies text that will be added as a NAME attribute in the HTML code behind the hyperlink.

**Editing text hyperlinks**

1) Select the hyperlink by dragging across the text, not clicking on it.
2) Go to Edit > Hyperlink from the main menu bar.
3) Make changes as needed and click Apply when done. If you need to edit several hyperlinks, click Apply after each one.
4) When you are finished editing hyperlinks, click Close.
Working with hyperlink buttons

A hyperlink button is inserted in the center of the current drawing. In most cases, that is not where you want it to appear. To edit the text or size of a hyperlink button, or to move it to another place on the drawing:

1) Go to View > Toolbars > Form Controls on the main menu bar to open the toolbar (Figure 246).
2) Select the Design Mode On/Off icon (highlighted).
3) Now click on the hyperlink button and drag it to another position, or right-click to open a dialog where you can change the text on the button, the size of the button, and other properties.
4) When you have finished editing the button, click the Design Mode On/Off icon again to make the button inactive. For a detailed description of the properties and how to work with Form Controls, refer to the Writer Guide.

Figure 246: Form Control toolbar
Chapter 10
Advanced Draw Techniques
Multi-page documents

Draw documents, like Impress presentation documents, can consist of multiple pages. This allows you to create a drawing that has several sections, but is stored as one file on a computer.

When pages are inserted into a drawing, they are automatically named as Slide 1, Slide 2, and so on. As you change page order, the pages are automatically renumbered. However, if you want to easily identify each page, then it is recommended to give each page a memorable name.

Using the page pane

By default the Page Pane (Figure 247) appears docked on the left of the workspace when you open Draw. It shows every page in a drawing as a thumbnail. If the Page Pane is not displayed, go to View > Page Pane on the main menu bar.

| Note | The Page Pane is called Pages when it is in its docked position on the left of the workspace. |

- Select a thumbnail in the Page Pane and the corresponding page is loaded in the workspace. Click on the page in the workspace to activate it for editing. Alternatively, click on the Navigator icon or press the F5 key or go to View > Navigator on the main menu bar to open the Navigator dialog (Figure 248) and select pages using this dialog.

Figure 247: Page pane and workspace

Figure 248: Navigator dialog
• Select a thumbnail in the Page pane, then drag and drop a thumbnail to change the order of pages in the document.

• Click and drag on the separator line between the Page pane and workspace to change the width of the Page pane.

• Click on the middle of this line to show or hide the Page pane (highlighted in Figure 247).

• Press and hold the Ctrl key, then double-click in the title bar of the Page pane to undock it and turn it into a floating window.

• Press and hold the Ctrl key, then double-click in the title bar of the undocked Page pane to dock it back into its default position on the left of the workspace.

• Right-click in the page pane and, using options in the context menu, you can insert, delete or rename pages and cut, copy and paste pages.

• Go to Insert > Slide on the main menu bar to insert a new page or Insert > Duplicate Slide to insert a duplicate page.

Master pages
A master page is a page that is used as the starting point for other pages in your drawing. It is similar to a page style in Writer: it controls the basic formatting of all pages based on it. A drawing can have more than one master page so that you can assign a different look to other pages in your drawing.

A master page has a defined set of characteristics, including the background color, graphic, or gradient; objects (such as logos, decorative lines, and other graphics) in the background, the formatting of text, blocks of standard text, and insert fields such as page numbering, date and filename.

Note
LibreOffice uses interchangeable terms for one concept: slide master, master slide, and master page. All refer to a page which is used to create other pages. When searching for information in Draw Help, it may be necessary to use alternative search terms.

Master page view
To add objects and fields to a master page, go to View > Master to open the master page view. The Master View toolbar (Figure 249) also opens when you switch to master view. If this toolbar does not appear, go to View > Toolbars > Master View.

To return to normal page mode, click on Close Master View in the Master View toolbar or go to View > Normal on the main menu bar.

Creating master pages
Each drawing you create already has a default master page, but you can create extra master pages to change the look of some of the pages in your multi-page drawing.

Switch to Master View and then click on the New Master icon in the Master View toolbar to create a new master page. The new master page is automatically selected allowing you to add a new set of items to create a new look for your pages.
**Renaming master pages**

Each new master page created has the default name of Default 1, Default 2, and so on. It is recommended to rename your new master page with a more meaningful name. The default master page that was created when you first created your drawing can also be renamed.

Switch to Master View and then right-click on a master page in the Page pane and select **Rename Page** from the context menu or click on the **Rename Master** icon on the Master View toolbar. This opens a dialog where you can type a new name. Click on the **OK** button to save the new name.

**Deleting master pages**

Switch to Master View and then select on the master page you want to delete. Right-click on a master page that you created in the Page pane and select **Delete Page** from the context menu or click on the **Delete Master** icon on the Master View toolbar.

The delete option and delete icon are only available when there is more than master page in your drawing. You cannot delete the default master page that was created when you first created your drawing.

**Inserting fields**

You can insert fields on each master page by going to **Insert > Fields** on the main menu bar and selecting a field from the context menu. The following fields can be inserted into a master page.

- **Date (fixed)** – inserts the current date into your master page as a fixed field. The date is not automatically updated.
- **Date (variable)** – inserts the current date into your master page as a variable field. The date is automatically updated when you reload the file.
- **Time (fixed)** – inserts the current time into your master page as a fixed field. The time is not automatically updated.
- **Time (variable)** – inserts the current time into your master page as a variable field. The time is automatically updated when you reload the file.
- **Author** – inserts the first and last names listed in the LibreOffice user data into the active page.
- **Page Number** – inserts the page number into every page of your drawing. To change the number format, go to **Format > Page** on the main menu bar and select a format from the drop down list in **Layout Settings**.
- **File name** – inserts the name of the active file. The name only appears after you save the file.

**Assigning master pages**

When your drawing has more than one master page, you can assign different master pages to different pages.

1) Make sure you are in normal page view by going to **View > Normal** on the main menu bar and select the page you want to assign a new master page to it.

2) Right-click on the page in the workspace area and select **Page > Slide Design** from the context menu to open the **Slide Design** dialog (Figure 250).

3) Click the **Load** button to open the **Load Slide Design** dialog and use any predefined master pages. All Draw and Impress templates can be used for this purpose.
4) Select the Exchange background page option and the selected master page will be used on all pages of the drawing.

5) Select the Delete unused backgrounds option to delete any master pages shown in the Slide Design dialog that have not been assigned to a page.

6) Click on the OK button to assign the selected master page to your page.

**Multiple layers**

Layers in LibreOffice Draw allow you to assemble elements on a drawing page that are related. Think of layers as individual workspaces that you can hide from view, hide from printing, or lock. Any layers that do not contain any objects are transparent.

| Note | You can lock a layer to protect its contents, or hide a layer and its contents from view or from printing. When you add a new layer, the layer is added to all of the pages in your drawing. However, when you add an object to a layer, it is only added to the current drawing page.  
If you want the object to appear on all of the pages (for example, a company logo), add the object to the master page by going to View > Master. To return to your drawing, go to View > Normal. |

Layers do not determine the stacking order of objects on your drawing page, except for the Controls layer which is always in front of all other layers. The stacking order of objects on your drawing page is determined by the sequence in which you add the objects. You can rearrange the stacking order by going to Modify > Arrange on the main menu bar.

**Default layers**

LibreOffice Draw provides three default layers, which cannot be deleted or renamed.

- **Layout** – is the default workspace and determines the location of title, text and object placeholders on your drawing page.
• **Controls** – used for buttons that have been assigned an action, but should not be printed and the layer properties are set to not printable. Objects on this layer are always in front of objects on other layers.

• **Dimension Lines** – is where the dimension lines are drawn. By switching the layer to show or hide, you can easily switch dimension lines on and off.

**Inserting layers**

1) Right-click the layer tab area at the bottom and select **Insert Layer** from the context menu, or go to **Insert > Layer** on the main menu bar to open the **Insert Layer** dialog (Figure 251).

2) Type a meaningful name for the layer in the **Name** text box.

3) Type a meaningful title for the layer in the **Title** text box.

4) If necessary, type a description for the layer in the **Description** text box.

5) Select **Visible** if you want the layer to be visible in your drawing. When **Visible** is not selected, a layer is hidden and the title in the layer tab changes color to blue.

6) Select **Printable** if you want the layer to print when you print your drawing. Not printing is useful if you want use a draft layer for guides or annotations that you use in making the drawing, but do not want to appear in the final output.

7) Select **Locked** to prevent any objects on this layer from deletion, editing, or moving. No additional objects can be added to a locked layer. Locking a layer is useful, for example, when a base plan is to be protected while adding a new layer with other details.

8) Click **OK** and the new layer automatically becomes active.

![Figure 251: Insert Layer dialog](image)

**Modifying layers**

1) Right-click on the name tab of the layer and select **Modify Layer** from the context menu or double-click on the name tab to open the **Modify Layer** dialog. This dialog is similar to the Insert Layer dialog in Figure 251.

2) Make your changes to the layer, then click **OK** to save the changes and close the dialog.
Working with layers

Selecting a layer
To select a layer, click on the name tab of the layer at the bottom of the drawing workspace.

Hiding layers
1) Select a layer, and right-click on the name tab of the layer and select Modify Layer from the context menu or double-click on the name tab to open the Modify Layer dialog.
2) Clear the Visible check box and click OK. The text for the name tab changes color to blue. Any objects placed on a hidden layer will no longer be visible on the other layers in your drawing.
3) Alternatively, hold down the Shift key and click on the name tab.

Showing hidden layers
1) Select a hidden layer, and right-click on the name tab of the layer and select Modify Layer from the context menu or double-click on the name tab to open the Modify Layer dialog.
2) Check the Visible check box and click OK. The text for the name tab changes to the default color for text for your computer setup. Any objects placed on a hidden layer will now become visible on the other layers in your drawing.
3) Alternatively, hold down the Shift key and click on the name tab.

Locking layers
1) Select a layer, and right-click on the name tab of the layer and select Modify Layer from the context menu or double-click on the name tab to open the Modify Layer dialog.
2) Check the Locked check box and click OK to prevent any modification of the layer.

Unlocking layers
1) Select a layer, and right-click on the name tab of the layer and select Modify Layer from the context menu or double-click on the name tab to open the Modify Layer dialog.
2) Uncheck the Locked check box and click OK to allow modification of the layer.

Renaming layers
To rename a layer that you have added to your drawing:
1) Right-click on the name tab of the layer and select Rename Layer from the context menu.
2) Type a new name for your layer and click outside the tab area to save the change.

Note You can also rename a layer using “Modifying layers” on page 192.

Deleting layers
To delete a layer that you have added to your drawing:
1) Right-click on the name tab of the layer and select Delete Layer from the context menu.
2) Confirm the deletion and the layer and all its objects are deleted.
Dimensioning

Draw allows you to dimension objects and display these dimensions to make your drawing look more like an engineering drawing. When you create dimensions, they are automatically placed on the Dimension Lines layer (see “Default layers” on page 191 for more information).

Configuring dimensioning

Two ways are available to access the options to configure dimensioning. Both methods use a similar dialog to set the dimensioning options where you can change length, measurement and guide properties of a dimension line.

Configuring using graphic styles

1) Go to Format > Styles and Formatting or press the F11 key on your keyboard to open the Styles and Formatting dialog.
2) Select Dimension Line in the Styles and Formatting dialog.
3) Right-click on Dimension Line and select Modify from the context menu to open the Graphics Styles dialog (Figure 252). See the Impress Guide for more information about graphic styles.
4) Click on the Dimensioning tab to open the Dimensioning options page.
5) To reset the dimensioning options to the default properties of the template, click Standard.

![Image of Graphic Styles Dimensioning dialog]

Figure 252: Graphic Styles Dimensioning dialog

Configuring using context menu

1) Draw a dimension line. See “Dimensioning objects” on page 196 for more information.
2) Right-click on the dimension line and select Dimensions from the context menu to open the Dimensioning dialog (Figure 253).
Figure 253: Context menu Dimensioning dialog

**Dimensioning options**

With reference to Figure 252 and Figure 253, the dimensioning options are as follows.

- **Line** – sets the distance properties of the dimension line and the guides with respect to each other and to the baseline.
  - **Line distance** – specifies the distance between the dimension line and the baseline (line distance = 0).
  - **Guide overhang** – specifies the length of the left and right guides starting at the baseline (line distance = 0). Positive values extend the guides above the baseline and negative values extend the guides below the baseline.
  - **Guide distance** – specifies the length of the right and left guides starting at the dimension line. Positive values extend the guides above the dimension line and negative values extend the guides below the dimension line.
  - **Left guide** – specifies the length of the left guide starting at the dimension line. Positive values extend the guide below the dimension line and negative values extend the guide above the dimension line.
  - **Right guide** – specifies the length of the right guide starting at the dimension line. Positive values extend the guide below the dimension line and negative values extend the guide above the dimension line.
  - **Measure below object** – reverses the properties set in the Line options.
  - **Decimal places** – specifies the number of decimal places used for the display of line properties.

- **Legend** – sets the properties of the dimension text.
  - **Text position** – determines the position of the dimension text with respect to the dimension line and the guides. The **AutoVertical** and **AutoHorizontal** checkboxes must be cleared before you can assign a text position.
  - **AutoVertical** – determines the optimal vertical position for the dimension text.
  - **AutoHorizontal** – determines the optimal horizontal position for the dimension text.
  - **Parallel to line** – displays the text parallel to or at 90 degrees to the dimension line.
  - **Show meas. units** – shows or hides the dimension measurement units. You can also select a measurement unit you want to display from the list.
Note: The dimensioning style Dimension Line is always linked and stored with the current work page. All the changes that you make apply only to this page. New drawings are started with the standard properties of Draw. If you want to use the amended style for future drawings, save your drawing as a template.

Tip: When dimensioning objects, it is recommended to use the zoom function, guide lines and snap functions so that you can accurately place dimension lines on an object. See Chapter 3 Working with Objects and Object Points for more information.

**Dimensioning objects**

1) Click on the small triangle next to the **Lines and Arrows** icon on the Drawing toolbar to open the **Arrows** pop-up toolbar. Note that this icon changes depending on the last **Lines and Arrows** tool used. Also, this toolbar can become a floating toolbar by clicking on the bottom of the pop-up toolbar and dragging it into your workspace.

2) Click on the **Dimension Line** icon on the **Arrows** toolbar and the cursor normally changes to a cross.

3) Position the cursor at one corner of your object, then click and drag the cursor to the other corner of your object to draw the dimension line. To restrict drawing your dimension line in the horizontal or vertical direction, press and hold the **Shift** key while dragging the cursor.

4) Release the mouse button when you reached the other corner of your object and the dimension line is drawn with the dimension automatically added. The dimension line is also placed automatically on the **Dimension Lines** layer; see “Default layers” on page 191 for more information.

5) If you want to edit the text of the dimension, double-click on an unselected dimension line to enter text edit mode and make your changes. Click outside the dimension line to save the changes.

6) If you want to configure your dimension line, see “Configuring dimensioning” on page 194.

**Drawing to scale**

In Draw a drawing is made on a predefined drawing area. This is normally Letter or A4 page size depending on your locale, computer setup and the default printer connected to your computer. However, depending on the actual size of the drawn objects, it is often convenient to reduce or enlarge the drawing by scaling (for example 1:10 or 2:1).
You can specify a scale value by going to Tools > Options > LibreOffice Draw > General and selecting a value from the Drawing scale drop down list. The default setting for this option is 1:1. When you make a change to the drawing scale, it is reflected in the rulers at the top and left side of your drawing.

Any change in the drawing scale has no effect on the basic drawing operations. Draw automatically calculates the necessary values (for example, dimension lines). The spacing of the grid points is independent of drawing scale as the grid is an optical drawing aid and not a drawing element.

An increase in scale (for example 1:4) allows you to draw objects that would not fit into the paper size for your drawing. A decrease in drawing scale (for example 4:1) allows you to draw small objects accurately at an increased size to make them easier to understand.

- An example of drawing to scale is shown in Figure 255. All three rectangles are the same size.
- The left rectangle was drawn at the default 1:1 scale and dimensioned.
- The drawing scale was then changed to 1:4 and the dimensions were automatically increased by Draw to reflect the decrease in scale for the center rectangle.
- The drawing scale was then changed to 4:1 and the dimensions were automatically decreased by Draw to reflect the increase in scale for the right rectangle.

![Figure 255: Examples of drawing to scale](image)

**Gallery images**

Draw includes several images in a Gallery which are grouped in themes: Bullets; Rulers; Homepage; Rulers; Sounds. The left pane of the gallery window lists the available themes. Click on a theme to see its images displayed in the right pane of the Gallery dialog (Figure 256).

The default themes are read only; no images can be added to or deleted from these themes. The default themes are easily recognizable by right-clicking on each category and the only available option in the pop-up menu is Properties.

In a default installation of LibreOffice, the My themes is the only category that is customizable and allows you add or delete your own graphics. You can also create new theme categories where you can add or delete your own images and this is explained in “Adding a new theme” on page 199.

**Using the Gallery**

1) Click on the Gallery icon on the Drawing toolbar or go to Tools > Gallery on the main menu bar to open the Gallery dialog.

2) Choose a theme in the left pane of the Gallery dialog.

3) Click on an image in the right pane of the Gallery dialog and drag the image into your drawing.
4) Alternatively, right-click on a gallery image and select Insert > Copy from the context menu.
5) Move to your drawing and paste the gallery image into your drawing.

### Adding images to My themes

You can add images only to My themes or themes that you have created.

1) Right-click on My themes or a theme name that you created in the list of theme categories and choose Properties from the pop-up menu to open the Properties of My Theme dialog (Figure 257).
2) Click on the Files tab.
3) Click on Find Files to open the Select Path dialog (Figure 258).
4) Browse to the folder that contains the images you want to use.
5) Click OK to select the files contained in the folder and the Select Path dialog closes. The list of files contained in the folder now appear in the Theme Properties dialog.
6) Select the files you want to use in My themes and click on Add. The added files will disappear from the file list and the images will appear in the Gallery.
7) If you want to add all the files in the list, then click on Add All. All the files will disappear from the list and the images will appear in the Gallery.
8) Click OK when finished and the Properties of My Theme dialog will close.

![Figure 258. Selecting path for new images in themes](image)

**Deleting graphics**

You can delete images only from My themes or themes that you have created.

1) Right-click on the image in the Gallery window.
2) Choose Delete from the pop-up menu.
3) A confirmation message appears, asking if you want to delete this object. Click Yes.

| Note | The image is a linked file and is deleted from the Gallery only. The original image file is not deleted. |

All the images in a gallery are linked files. From time to time it is beneficial to update the gallery theme to make sure that all the files are still there. To do so, right-click on the theme where you added at least one file and then select Update from the pop-up menu.

**Adding a new theme**

You can add a new theme to the list of theme categories in the gallery as follows:

1) Click the New Theme button above the list of theme categories and the Properties dialog opens.
2) Click the General tab and type a name for the new theme in the text box (Figure 259).
3) Click the **Files** tab and follow Steps 3 through to 8 in “Adding images to My themes” on page 198.

4) The new theme will now be displayed in the list of theme categories in the Gallery.

![Image of Properties of New Theme dialog]

*Figure 259. Adding new theme to the Gallery*

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you wish, you can rename this new theme by manually by right-clicking the theme name and selecting <strong>Rename</strong>.</td>
</tr>
</tbody>
</table>

**Colors and color palettes**

Draw (like all LibreOffice components) uses color palettes for the representation of colors. Also, you can customize the color palette to suit your own needs by modifying colors in a palette, adding other colors, or creating new color palettes.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>LibreOffice uses the RGB color model internally for printing in all of its software modules. The CMYK controls are provided only to ease the input of color values using CMYK notation.</td>
</tr>
</tbody>
</table>

**Using colors**

Two color dialogs are available where you can select, add, modify, edit or delete colors. Go to **Tools > Options > LibreOffice > Colors** (Figure 260) or **Format > Area > Colors** (Figure 261) on the main menu bar to open these color dialogs. Also, if you right-click on a selected object and go to **Area** in the context menu, then click on the **Colors** tab, you will open the **Area** dialog in Figure 261.

Each color value has a numeric value and can be input directly as numbers. The color values for the RGB color model (Red, Green and Blue) can be any integer value between 0 and 255. The color values for the CMYK color model (Cyan, Magenta, Yellow and Black (K)) are percentages. When selecting between the RGB and CMYK color models in both dialogs, the value boxes automatically change to show RGB or CMYK.
When using CMYK values, the conversion to RGB values used in LibreOffice is made automatically. Any modifications made to colors apply only to the active palette in your drawing unless you save the modified color palette for future use.

**Figure 260: Options LibreOffice Colors dialog**

**Figure 261: Format Area Colors dialog**

**Tip**

Selecting colors

1) Go to **Tools > Options > LibreOffice > Colors** (Figure 260) or **Format > Area > Colors** (Figure 261) on the main menu bar to open a color dialog.

2) Alternatively, right-click on a selected object and select **Area** from the context menu, then click on the **Colors** tab to open the color dialog (Figure 261).

3) Select a color from the **Color** drop down list, or select a color from the color table, or enter the RGB or CMYK values if you know these values for the color you want to use.

4) Click **OK** to use the selected color and close the dialog.

Color palettes

Using the **Format > Area Colors** dialog (Figure 261) allows you to load color palettes and create then save color palettes for future use.

- Click on the Load Color List icon 📨 to open a dialog where you can select a color palette to use in Draw.

- If you have made any changes to the color palette, click on the Save Color List icon 📦 to open a dialog where you can save your color palette for future use in Draw. The file format used in LibreOffice for color palettes is .soc.

| Note | The Load Color List and Save Color List icons are only available if you select the color dialog using the **Format > Area > Colors** command or right-clicking on a selected object and selecting **Area** from the context menu. |

Creating colors

**Using color values**

1) Select either RGB or CMYK from the drop down options on the color dialog.

2) Enter integer values or percentage values in each of the RGB or CMYK boxes or use the spinners at the right of each box.

3) The original color is shown the top color sample and the new color is shown in the lower color sample.

4) Either, click **Modify** to apply and store the new setting in the color palette without changing the color name.

5) Or, click **Add** and you will be prompted to give the color a new name. Entering a new name and clicking **OK** will add the new color to the end of the color list and store it in the currently active palette.

6) Click **OK** to use the modified or new color and close the dialog.

| Note | To store your new color in a color palette for future use in Draw, see “Color palettes” on page 202. |

**Using the color picker**

You can define colors using the **Color Picker** dialog (Figure 262).

1) Go to **Format > Area > Colors** on the main menu bar or right-click on a selected object and go to **Area** in the context menu to open the **Area** dialog and then click on the **Colors** tab to open the colors dialog (Figure 261).
2) Click **Edit** to open the **Color Picker** dialog where you will have three ways of selecting a color to create and use.

3) Click on the colored bar to the right of the color sample area to select a color. The values in the RGB, HSB (Hue, Saturation and Brightness) and CMYK boxes will change.

4) Or, enter values in either the RGB, HSB or CMYK boxes to create the color. Entering values in one set of value boxes will change the values in the other two sets of boxes.

5) Or, click on the small circle in the color sample area and drag it to a new position to create a new color.

6) The color bar below the sample color area will show the new color on the left half of this bar so that you can compare it with the original color on the right half of this bar.

7) If you are satisfied with the color created, click **OK** to use the color.

8) See “Using color values” on page 202 to save the color.

**Deleting colors**

1) To delete a color from a color palette, open the color dialog (Figure 260 or Figure 261).

2) Select the color from the **Color** drop down list or the color table and click **Delete**.

3) Click **Yes** to confirm the deletion of the color.

4) Click **OK** to close the color dialog.

**Bézier curves**

In LibreOffice you can use Bézier curves in your drawing. A curve is defined by means of a start point $P_0$, an end point $P_3$, and two control points $P_1$ and $P_2$ (Figure 263). For points on the curve the terms **nodes** or **anchors** are often used. For the mathematical background of Bézier curves, see [http://en.wikipedia.org/wiki/Bezier_curve](http://en.wikipedia.org/wiki/Bezier_curve).

Bézier curves are very useful for experimenting with the shape and form of curves. In point mode you can change the curve alignment by dragging the points with the mouse. The curve leaves the start point $P_0$ in the direction of the control point $P_1$ and arrives at the end point $P_3$ from the direction of the control point $P_2$. The more distant a control is from its start or end point the smaller
the curvature at that point. If a control point lies directly on one of these points, it has no influence on the curve.

![Figure 263: Points in Bézier curves](image)

**Drawing a Bézier curve**

1) Click on the small triangle to the right of the Curve icon on the Drawing toolbar to open the Lines toolbar (Figure 264). The Curve icon will show the last tool selected from the Lines toolbar. To make this toolbar a floating toolbar, click at the bottom of the pop-up toolbar and drag it onto your workspace.

![Figure 264: Lines toolbar](image)

2) Click on the Curve icon on the Lines toolbar. Note that this maybe a different icon to the Curve icon on the Drawing toolbar.

3) Click at the start point where you want to draw the curve and, keeping the mouse button pressed, drag the cursor to the approximate the position of the end point for the curve.

4) Double-click when you have reached the end position of your curve and a curve is drawn. The arc of the curve is determined by the distance you have dragged to create the end point.

**Note**

If you single-click when you have reached the end point of your curve, you will continue drawing straight lines until you double-click to end the drawing of a curve.

5) Click on the Points icon on the Drawing toolbar or press the F8 key to open the Edit Points toolbar (Figure 265).

6) Click once on your curve to display the start and end points. The start point of the curve is larger than the end point.

7) Move cursor over the start or end point and drag the control point to its correct position, if necessary. As you drag a start or end point, a control point appears at the end of a dashed line connected to the point you have selected (Figure 267).

8) When you have the position for your start or end point, release the cursor and the control point remains active.

9) Click on the control point and drag it to change the shape of the curve.

10) When you have finished editing your curve, click anywhere on your workspace to deselect the curve and stop editing points.
With reference to Figure 265 and Figure 266, the tools available on the Edit Points toolbar allow you to edit and change the shape of a Bézier curve and are explained as follows:

- **Points** – allows you to activate or deactivate the edit mode for Bézier objects. In the edit mode, individual points of the drawing object can be selected.

- **Move Points** – activates a mode in which you can move points. The mouse pointer displays a small empty square when resting on a point. Drag that point to another location. The curve on both sides of the point follows the movement; the section of the curve between points changes shape. Point at the curve between two points or within a closed curve and drag the mouse to shift the entire curve without distorting the form.

- **Insert Points** – activates the insert mode and allows you to insert points. You can also move points, just as in the move mode. If, however, you click at the curve between two points and move the mouse a little while holding down the mouse button you insert a new point. The point is a smooth point, and the lines to the control points are parallel and remain so when moved. If you wish to create a corner point you must first insert either a smooth or a symmetrical point which is then converted to a corner point by using **Corner Point**.

**Edit Points tools**

Chapter 10  Advanced Draw Techniques
• **Delete Points** – used to delete one or several selected points. If you wish to select several points click the appropriate points while holding down the *Shift* key. First select the points to be deleted, and then click this icon or press *Delete* key.

• **Split Curve** – this tool splits a curve. Select the point or points where you want to split the curve, then click.

• **Convert To Curve** – converts a curve into a straight line or converts a straight line into a curve. If you select a single point, the curve before the point will be converted. If two points are selected, the curve between both points will be converted. If you select more than two points, each time you click this icon, a different portion of the curve will be converted. If necessary, round points are converted into corner points and corner points are converted into round points. If a section of the curve is straight, the end points of the line have a maximum of one control point each. They cannot be modified to control points unless the straight line is converted back to a curve.

• **Corner Point** – converts the selected point or points into corner points (Figure 268). Corner points have two movable control points, which are independent from each other. A curved line, therefore, does not go straight through a corner point, but forms a corner.

![Figure 268: Corner point](image)

• **Smooth Transition** – converts a corner point or symmetrical point into a smooth point (Figure 269). Both control points of the corner point are aligned in parallel and can only be moved simultaneously. The control points may differentiate in length, allowing you to vary the degree of curvature.

![Figure 269: Smooth transition point](image)

• **Symmetric Transition** – converts a corner point or a smooth point into a symmetrical point (Figure 270). Both control points of the corner point are aligned in parallel and have the same length. They can only be moved simultaneously and the degree of curvature is the same in both directions.

![Figure 270: Symmetric transition point](image)

• **Close Bézier** – closes a line or a curve. A line is closed by connecting the last point with the first point, indicated by an enlarged square.

• **Eliminate Points** – marks the current point or the selected points for deletion. This happens in the event that the point is located on a straight line. If you convert a curve or a polygon with the **Convert to Curve** tool into a straight line or you change a curve with the
mouse so that a point lies on the straight line, it is removed. The angle from which the point
reduction is to take place can be set by going to **Tools > Options > LibreOffice Draw >
Grid**.

### Adding comments to a drawing

Draw supports comments similar to those in Writer and Calc.

1) Go to **Insert > Comment** the main menu bar. A comment box appears with a small marker
box containing your initials in the upper left-hand corner of your drawing. Draw
automatically adds your name and the date at the bottom of the comment (Figure 25).

2) Type or paste your comment into the text box.

3) To apply basic formatting to the text, right-click and select the formatting option from the
context menu.

4) To delete a comment, right-click on the comment or marker box and select an option from
the context menu or click on the small triangle in the bottom right of the comment and
select an option from the context menu.

5) To move a comment, click on the small marker box and drag it to a new position on your
drawing.

6) To show or hide the comments, go to **View > Comments**.

![Comment in a drawing](image)

**Figure 271: Comment in a drawing**

For your initials and name to appear in a comment, you have to enter your user data.
Go to **Tools > Options > LibreOffice > User Data** and enter all the necessary data.
If more than one person edits the document, each author is automatically allocated a
different background color.

### Connecting and breaking lines

It is possible in Draw to connect separate line elements together making one line, break a line that
is composed of separate elements.

Select a number of lines and go to **Modify > Connect**. The lines are converted to curves and
adjacent end points are joined together. The resulting shape is a polyline, not a closed shape.

Select a line that is composed of separate elements and go to **Modify > Break**. Each separate
element is now indicated with start and end points. Click on an element and drag it to a new
position.