Chapter 3
Working with Text
Copyright

This document is Copyright © 2010–2013 by its contributors as listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/3.0/), version 3.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Ron Faile Jr.  John M. Długosz  Hazel Russman
Jean Hollis Weber  John A Smith

Feedback

Please direct any comments or suggestions about this document to: documentation@global.libreoffice.org

Acknowledgments

This chapter is revised and updated from Chapter 3 of the OpenOffice.org 3.3 Writer Guide. The contributors to that chapter are:

Jean Hollis Weber  Agnes Belzunce  Daniel Carrera
Laurent Duperval  Katharina Greif  Peter Hillier-Brook
Michael Kotsarinis  Peter Kupfer  Iain Roberts
Gary Schnabl  Barbara M. Tobias  Michele Zarri
Sharon Whiston

Publication date and software version

Published 26 February 2013. Based on LibreOffice 4.0.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click</td>
<td>Opens a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+⌘+F5</td>
<td>Opens the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Opens the Styles and Formatting window</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
Contents

Copyright .................................................................................................................................................. 2
Contributors ........................................................................................................................................ 2
Feedback ............................................................................................................................................... 2
Acknowledgments ............................................................................................................................... 2
Publication date and software version .............................................................................................. 2
Note for Mac users ............................................................................................................................. 2

Introduction ......................................................................................................................................... 5

Selecting text ....................................................................................................................................... 5
Selecting items that are not consecutive ............................................................................................ 5
Selecting a vertical block of text .......................................................................................................... 6

Cutting, copying, and pasting text ....................................................................................................... 6

Finding and replacing text and formatting ....................................................................................... 7
Using the Find toolbar .......................................................................................................................... 7
Using the Find & Replace dialog ......................................................................................................... 8
Find and replace specific formatting ................................................................................................... 9
Finding and replacing paragraph styles ............................................................................................. 9
Using wildcards and regular expressions .......................................................................................... 9

Inserting special characters ................................................................................................................ 10
Inserting non-breaking spaces and hyphens ....................................................................................... 11
Inserting en and em dashes .................................................................................................................. 11

Formatting paragraphs ....................................................................................................................... 12
Setting tab stops and indents ............................................................................................................... 14
Changing the default tab stop interval ............................................................................................... 15

Formatting characters ....................................................................................................................... 15

Autoformatting .................................................................................................................................. 16

Creating numbered or bulleted lists ................................................................................................. 17
Using the Bullets and Numbering toolbar ......................................................................................... 17
Example: configuring a nested list ...................................................................................................... 18

Using footnotes and endnotes .......................................................................................................... 20
Inserting footnotes/endnotes .............................................................................................................. 20
Defining the format of footnotes/endnotes ......................................................................................... 21
Defining footnote location and separator line .................................................................................... 21

Checking spelling and grammar ....................................................................................................... 23
Spelling ............................................................................................................................................... 23
Spelling and grammar ......................................................................................................................... 24
Grammar ............................................................................................................................................ 25

Using built-in language tools ............................................................................................................. 27
Using paragraph and character styles ................................................................................................. 27
Using Tools > Language ...................................................................................................................... 27
Using language settings in Options.................................................................................................................. 27
Using the status bar.................................................................................................................................................. 28

Using synonyms and the thesaurus...................................................................................................................... 28

Hyphenating words............................................................................................................................................... 30
  Automatic hyphenation........................................................................................................................................ 30
  Manual hyphenation.......................................................................................................................................... 31

Using AutoCorrect................................................................................................................................................ 31

Using word completion......................................................................................................................................... 32

Using AutoText.................................................................................................................................................... 33
  Creating AutoText............................................................................................................................................ 33
  Inserting AutoText.......................................................................................................................................... 34
  Printing a list of AutoText entries.................................................................................................................. 34

Line numbering.................................................................................................................................................... 35

Tracking changes to a document.......................................................................................................................... 36
  Preparing a document for review.................................................................................................................... 36
  Recording changes.......................................................................................................................................... 36
  Accepting or rejecting changes..................................................................................................................... 37
  Merging modified documents........................................................................................................................ 39
  Comparing documents................................................................................................................................... 39

Adding other comments...................................................................................................................................... 39

Linking to another part of a document................................................................................................................. 40
  Using cross-references.................................................................................................................................... 41
  Using bookmarks............................................................................................................................................ 41
  Using hyperlinks............................................................................................................................................ 41
    Inserting hyperlinks using the Navigator................................................................................................. 41
    Inserting hyperlinks using a dialog........................................................................................................... 42
    Editing hyperlinks.................................................................................................................................... 43

Switching between insert and overwrite mode.................................................................................................... 43

Counting the words in a selection....................................................................................................................... 44

Changing the case of selected text....................................................................................................................... 44
Introduction

This chapter covers the basics of working with text in Writer, the word-processing component of LibreOffice. It assumes that you are familiar with the use of a mouse and keyboard and that you have read about Writer’s menus and toolbars and other topics covered in Chapter 1, Introducing Writer.

We recommend that you also follow the suggestions in Chapter 2, Setting up Writer, about displaying formatting aids, such as end-of-paragraph marks, and selecting other setup options.

When you have read this chapter, you should know how to:

- Select, cut, copy, paste, and move text
- Find and replace text
- Insert special characters
- Format paragraphs and characters
- Create numbered or bulleted lists
- Check spelling and grammar, use the thesaurus, and choose hyphenation options
- Use the autocorrection, word completion, autotext, and line numbering features
- Track changes, undo and redo changes, and insert comments
- Link to other parts of a document

Selecting text

Before you can do anything with text, you need to select it. Selecting text in Writer is similar to selecting text in other applications.

In addition to selecting blocks of text, you can select items that are not consecutive, and columns (vertical blocks) of text.

Selecting items that are not consecutive

To select nonconsecutive items (as shown in Figure 1) using the mouse:

1) Select the first piece of text.
2) Hold down the Ctrl key and use the mouse to select the next piece of text.
3) Repeat as often as needed.

Now you can work with the selected text (copy it, delete it, change the style, and so on).

To select nonconsecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection of text, see the topic “Navigating and Selecting with the Keyboard” in the LibreOffice Help (F1).)
2) Press Shift+F8. This puts Writer in “Adding selection” mode.
3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down the Shift key and select the next piece of text.
4) Repeat as often as required.

Now you can work with the selected text.

Press Esc to exit from this mode.
Selecting a vertical block of text

You can select a vertical block or “column” of text that is separated by spaces or tabs (as you might see in text pasted from e-mails, program listings, or other sources), using LibreOffice’s block selection mode. To change to block selection mode, use Edit > Selection Mode > Block Area, or press Ctrl+F8, or click on the Selection icon in the status bar and select Block selection from the list.

Now you can highlight the selection, using mouse or keyboard, as shown in Figure 2.

Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other applications. You can copy or move text within a document, or between documents, by dragging or by using menu selections, icons, or keyboard shortcuts. You can also copy text from other sources such as Web pages and paste it into a Writer document.

To move (drag and drop) selected text using the mouse, drag it to the new location and release it.

To copy selected text, hold down the Ctrl key while dragging. The text retains the formatting it had before dragging.

To move (cut and paste) selected text, use Ctrl+X to cut the text, insert the cursor at the paste-in point and use Ctrl+V to paste. Alternatively, use the icons on the Standard toolbar.
When you paste text, the result depends on the source of the text and how you paste it. If you click on the Paste icon, then the pasted text keeps its original formatting (such as bold or italics). Text pasted from Web sites and other sources may also be placed into frames or tables. If you do not like the results, click the Undo icon or press Ctrl+Z.

To make the pasted text take on the formatting of the text surrounding where it is pasted:

- Choose Edit > Paste Special, or
- Click the triangle to the right of the Paste icon, or
- Click the Paste icon without releasing the left mouse button.

Then select Unformatted text from the resulting menu.

The range of choices on the Paste Special menu varies depending on the origin and formatting of the text (or other object) to be pasted. See Figure 3 for an example with text on the clipboard.

![Figure 3: Paste Special menu](image)

Finding and replacing text and formatting

Writer has two ways to find text within a document: the Find toolbar for fast searching and the Find & Replace dialog. In the dialog, you can:

- Find and replace words and phrases
- Use wildcards and regular expressions to fine-tune a search
- Find and replace specific formatting
- Find and replace paragraph styles

Using the Find toolbar

If the Find toolbar is not visible, you can display it by choosing View > Toolbars > Find from the menu bar or by pressing Ctrl+F. The Find toolbar is shown docked at the bottom of the LibreOffice window (just above the Status Bar) in Figure 4, but you can float it or dock it in another location. For more information on floating and docking toolbars, see Chapter 1, Introducing Writer.

![Figure 4: Docked position of Find toolbar](image)

To use the Find toolbar, click in the box and type your search text, then press Enter to find the next occurrence of that term. Click the Find Next or Find Previous buttons as needed. Selecting the icon next to the arrows opens the Find & Replace dialog and keeps the Find dialog open.
Using the Find & Replace dialog

To display the Find & Replace dialog, use the keyboard shortcut Ctrl+H or choose Edit > Find & Replace from the menu bar. Optionally, click the More Options button to expand the dialog; the button changes to Fewer Options.

To use the Find & Replace dialog:

1) Type the text you want to find in the Search for box.
2) To replace the text with different text, type the new text in the Replace with box.
3) You can select various options, such as matching the case, matching whole words only, or doing a search for similar words. (See below for some other choices.)
4) When you have set up your search, click Find. To replace the found text, click Replace.

Tip

If you click Find All, Writer selects all instances of the search text in the document. Similarly, if you click Replace All, Writer replaces all matches.

Caution

Use Replace All with caution; otherwise, you may end up with some highly embarrassing (and hilarious) mistakes. A mistake with Replace All might require a manual, word-by-word, search to fix.

![Figure 5: Expanded Find & Replace dialog](image)
Find and replace specific formatting

A very powerful use of Find & Replace takes advantage of the Format option. For example, you might want to replace underlined words with italics.

On the Find & Replace dialog (with More Options displayed, as in Figure 5):

1) To search for text with specific formatting, enter the text in the Search for box. To search for specific formatting only, delete any text in the Search for box.

2) Click Format to display the Text Format (Search) dialog. The tabs on this dialog are similar to those on the Paragraph format and Paragraph Style dialog.

3) Choose the formats you want to search for and then click OK. The names of selected formats appear under the Search for box. For example, you might search for all text in 14-point bold Times New Roman.

4) To replace text as well as formatting, type the replacement text in the Replace with box.

To search for specific text with specific formatting (for example, the word hello in bold), specify the formatting, type the text in the Search for box and leave the Replace with box blank.

To remove specific character formatting, click Format, select the Font tab, then select the opposite format (for example, No Bold). The No Format button on the Find & Replace dialog clears all previously selected formats.

5) Click Find, Find All, Replace, or Replace All.

Tip

Unless you plan to search for other text using those same attributes, click No Format to remove the attributes after completing your search. If you forget to do this, you may wonder why your next search fails to find words you know are in the document.

Finding and replacing paragraph styles

If you combine material from several sources, you may discover that lots of unwanted paragraph styles have suddenly shown up in your document. To quickly change all the paragraphs from one (unwanted) style to another (preferred) style:

1) On the expanded Find & Replace dialog (Figure 5), select Search for Styles. (If you have attributes specified, this option is labeled Including Styles.) The Search for and Replace with boxes now contain a list of styles.

2) Select the styles you want to search for and replace.

3) Click Find, Find All, Replace, or Replace All.

Repeat steps 2 and 3 for each style that you want to replace.

Using wildcards and regular expressions

Most users will be familiar with the concept of a wildcard—a special character that represents one or more unspecified characters. Wildcards make text searches more powerful but often less specific. LibreOffice enables you to use combinations of characters known as regular expressions which are more specific than simple wildcards but less so than a literal string. Regular expressions are very powerful but not very intuitive. They can save time and effort by combining multiple finds into one.

Table 1 shows a few of the regular expressions used by LibreOffice.

| Tip | The online help describes many more regular expressions and their uses. |
To use wildcards and regular expressions when searching and replacing:

1) On the Find & Replace dialog, click More Options to see more choices. On this expanded dialog (Figure 5), select the Regular expressions option.

2) Type the search text, including the wildcards, in the Search for box and the replacement text (if any) in the Replace with box. Not all regular expressions work as replacement characters; the line break (\n) is one that does work.

3) Click Find, Find All, Replace, or Replace All (not recommended).

Note: To search for a character that is defined as a wildcard, type a backslash (\) before the character to indicate that you are using it literally. For example, to find the text $5.00, you would conduct a search using \$5\.00.

Table 1. Examples of search wildcards (regular expressions)

<table>
<thead>
<tr>
<th>To find</th>
<th>Use this expression</th>
<th>Examples and comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any single character</td>
<td>.</td>
<td>b.d finds bad, bud, bid, and bed.</td>
</tr>
<tr>
<td>One of the specified characters</td>
<td>[xyz]</td>
<td>b[iu]n finds bin and bun.</td>
</tr>
<tr>
<td>Any single character in this range</td>
<td>[x-y]</td>
<td>[r-t]eed finds reed, seed, and teed; ranges must be in alphabetically ascending order.</td>
</tr>
<tr>
<td>Any single character except the characters inside the brackets</td>
<td>[^x]</td>
<td>p[^a]st finds post and pest, but not past.</td>
</tr>
<tr>
<td>The beginning of a word</td>
<td>&lt;start&gt;</td>
<td>&lt;log finds logbook and logistics, but not catalog.</td>
</tr>
<tr>
<td>The end of a word</td>
<td>\end&gt;</td>
<td>\log finds catalog, but not logistics.</td>
</tr>
<tr>
<td>A paragraph marker</td>
<td>$</td>
<td>Does not work as a replacement character. Use \n instead.</td>
</tr>
<tr>
<td>A line break</td>
<td>\n</td>
<td>Finds a line break that was inserted with Shift+Enter. When used as a replacement character, it inserts a paragraph marker.</td>
</tr>
</tbody>
</table>

Inserting special characters

A special character is one not found on a standard English keyboard. For example, © ¾ æ ç Ł ź ø ś are all special characters. To insert a special character:

1) Place the cursor in your document where you want the character to appear.
2) Click Insert > Special Character to open the Special Characters dialog.
3) Select the characters (from any font or mixture of fonts) you wish to insert, in order; then click OK. The selected characters are shown in the lower left of the dialog. As you select each character, it is shown on the right, along with the numerical code for that character.

Tip: Different fonts include different special characters. If you do not find a particular special character you want, try changing the Font selection.
Inserting non-breaking spaces and hyphens

Non-breaking spaces
To prevent two words from being separated at the end of a line, press Ctrl+Shift when you type the space between the words.

Non-breaking hyphen
You can use a non-breaking hyphen in cases where you do not want the hyphen to appear at the end of a line, for example in a number such as 123-4567. To insert a non-breaking hyphen, press Shift+Ctrl+minus sign.

These are also available through Insert > Formatting Mark.

Inserting en and em dashes
To enter en and em dashes, you can choose the Replace dashes option under Tools > AutoCorrect Options (Figure 15 on page 16). This option replaces two hyphens, under certain conditions, with the corresponding dash.

In Table 2, the A and B represent text consisting of letters A to z or digits 0 to 9.

Another means of inserting en or em dashes is through the Insert > Special Characters menu. Select the U+2013 or U+2014 character (found in the General punctuation subset), respectively.

A third method uses keyboard shortcuts. These shortcuts vary depending on your operating system, as described on the next page.

Tip
You can also record macros to insert en and em dashes and assign those macros to unused key combinations, for example Ctrl+Shift+N and Ctrl+Shift+M. For more information, see Chapter 17, Customizing Writer.
Table 2: Inserting dashes

<table>
<thead>
<tr>
<th>Text that you type</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>A - B (A, space, hyphen, space, B)</td>
<td>A – B (A, space, en-dash, space, B)</td>
</tr>
<tr>
<td>A -- B (A, space, hyphen, hyphen, space, B)</td>
<td>A – B (A, space, en-dash, space, B)</td>
</tr>
<tr>
<td>A--B (A, hyphen, hyphen, B)</td>
<td>A—B (A, em-dash, B)</td>
</tr>
<tr>
<td>A-B (A, hyphen, B)</td>
<td>A-B (unchanged)</td>
</tr>
<tr>
<td>A -B (A, space, hyphen, B)</td>
<td>A -B (unchanged)</td>
</tr>
<tr>
<td>A --B (A, space, hyphen, hyphen, B)</td>
<td>A –B (A, space, en-dash, B)</td>
</tr>
</tbody>
</table>

**Windows**
On most non-Asian installations of Windows, hold down one of the Alt keys and type on the numeric keypad: 0150 for an en dash or 0151 for an em dash. The dash appears when you release the Alt key.

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>On a keyboard with no numeric keypad, use a Fn (Function) key combination to type the numbers. (The Fn key is usually to the right of the left-hand Ctrl key on the keyboard.)</td>
</tr>
<tr>
<td>For example, on a US keyboard layout, the combination for an en dash should be Alt+Fn+miim and for an em dash it should be Alt+Fn+miij.</td>
</tr>
</tbody>
</table>

**Linux**
Hold down the Compose key and type two hyphens and a period for an en dash, or three hyphens for an em dash. The dash appears when you release the Compose key.

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>The key that operates as a Compose key varies with the Linux distribution. It is usually one of the Alt or Win keys, but may be another key, and should be user-selectable.</td>
</tr>
</tbody>
</table>

**Mac OS X**
Hold down the Option (Alt) key and type a hyphen for an en dash. For an em dash, the combination is Shift+Option+Hyphen.

**Formatting paragraphs**
You can apply many formats to paragraphs using the buttons on the Formatting toolbar. Figure 7 shows the Formatting toolbar as a floating toolbar, customized to show only the buttons for paragraph formatting. If you have Asian or Complex Text Layout language support enabled, two additional buttons are available: Left-to-Right and Right-to-Left. The appearance of the icons may vary with your operating system and the selection of icon size and style in Tools > Options > LibreOffice > View.

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>The use of paragraph styles is highly recommended as an alternative to manually formatting paragraphs, especially for long or standardized documents. For information on styles and how to use them, see Chapters 6 and 7 in this book.</td>
</tr>
</tbody>
</table>
Manual formatting (also called direct formatting) overrides styles, and you cannot get rid of the manual formatting by applying a style to it.

To remove manual formatting, select the text, right-click, and choose Clear Direct Formatting from the context menu. Alternatively, use Ctrl+M.

Figure 7: Formatting toolbar, showing icons for paragraph formatting

Figure 8 shows examples of the text alignment options.

![Alignment options](image)

Figure 8: Text alignment options

When using justified text, the last line is by default aligned to the left; however, if so desired, you can also align the last line to the center of the paragraph area or justify it so that spaces are inserted between the words in order to fill the whole line. If you select the Expand single word option, then whenever the last line of a justified paragraph consists of a single word, this word is stretched by inserting spaces between characters so that it occupies the full length of the line. Figure 9 shows an example of the effect obtained when setting each of these options.

![Paragraph examples](image)

Figure 9: Four choices for the last line of a justified paragraph

These options are controlled in the Alignment page of the Paragraph dialog, reached by choosing Format > Paragraph from the menu bar or by right-clicking in the paragraph and selecting Paragraph from the context menu.
Setting tab stops and indents

The horizontal ruler shows both the default tab stops and any tab stops that you have defined. Tab settings affect indentation of full paragraphs (using the Increase Indent and Decrease Indent icons on the Formatting toolbar) as well as indentation of parts of a paragraph (by pressing the Tab key on the keyboard).

Using the default tab spacing can cause formatting problems if you share documents with other people. If you use the default tab spacing and then send the document to someone else who has chosen a different default tab spacing, tabbed material will change to use the other person’s settings. Instead of using the defaults, define your own tab settings, as described in this section.

To define indents and tab settings for one or more selected paragraphs, double-click on a part of the ruler that is not between the left and right indent icons to open the Indents & Spacing page of the Paragraph dialog. Double-click anywhere between the left and right indent icons on the ruler to open the Tabs page of the Paragraph dialog.
A better strategy is to define tabs for the paragraph style. Refer to Chapters 6 and 7 for more about paragraph styles.

**Tip**

Using tabs to space out material on a page is not recommended. Depending on what you are trying to accomplish, a table is usually a better choice.

**Changing the default tab stop interval**

**Note**

Any changes to the default tab setting will affect the existing default tab stops in any document you open afterward, as well as tab stops you insert after making the change.

To set the measurement unit and the spacing of default tab stop intervals, go to **Tools > Options > LibreOffice Writer > General**.

![Figure 12: Selecting a default tab stop interval](image)

You can also set or change the measurement unit for rulers in the current document by right-clicking on the ruler to open a list of units, as shown in Figure 13. Click on one of them to change the ruler to that unit. The selected setting applies only to that ruler.

![Figure 13: Changing the measurement unit for a ruler](image)

**Formatting characters**

You can apply many formats to characters using the buttons on the Formatting toolbar. Figure 14 shows the Formatting toolbar customized to show only the buttons for character formatting. The appearance of the icons may vary with your operating system and the selection of icon size and style in **Tools > Options > LibreOffice > View**.

It is highly recommended that you use character styles rather than manually formatting characters. For information on styles and how to use them, see Chapters 6 and 7.
Figure 14: Formatting toolbar, showing icons for character formatting

Tip
To remove manual formatting, select the text and choose Format > Clear Direct Formatting from the menu bar, or right-click and choose Clear Direct Formatting from the context menu, or use Ctrl+M from the keyboard.

Autoformatting

You can set Writer to automatically format parts of a document according to the choices made on the Options page of the AutoCorrect dialog (Tools > AutoCorrect Options).

Figure 15: Autoformat choices on the Options page of the AutoCorrect dialog
The Help describes each of these choices and how to activate the autoformats. Some common unwanted or unexpected formatting changes include:

- **Horizontal lines.** If you type three or more hyphens (- - -), underscores (_ _ _) or equal signs (===) on a line and then press Enter the paragraph is replaced by a horizontal line as wide as the page. The line is actually the lower border of the preceding paragraph.

- **Bulleted and numbered lists.** A bulleted list is created when you type a hyphen (-), asterisk (*), or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list is created when you type a number followed by a period (.), followed by a space or tab at the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted with the Default, Text body or Text body indent paragraph styles.

  **Tip**

If you notice unexpected formatting changes occurring in your document, this is the first place to look for the cause.

To automatically format the file according to the options you have set, choose **Format > AutoCorrect** and select or deselect the items on the submenu.

**While Typing**

Automatically formats the document while you type.

**Apply**

Automatically formats the document.

**Apply and Edit Changes**

Automatically formats the file and then opens a dialog where you can accept or reject the changes.

**AutoCorrect Options**

Opens the AutoCorrect dialog (Figure 15).

### Creating numbered or bulleted lists

There are several ways to create numbered or bulleted lists:

- Use autoformatting, as described above.
- Use list (numbering) styles, as described in Chapters 6 and 7 in this book.
- Use the **Numbering** and **Bullets** icons on the paragraph formatting toolbar (see Figure 7). This method is described here.

To produce a numbered or bulleted list, select the paragraphs in the list and then click on the appropriate icon on the toolbar.

**Note**

It is a matter of personal preference whether you type your information first, then apply Numbering/Bullets or apply these as you type.

### Using the Bullets and Numbering toolbar

You can create a nested list (where one or more list items has a sub-list under it, as in an outline) by using the buttons on the Bullets and Numbering toolbar (Figure 16). You can move items up or down the list, or create subpoints, and even change the style of bullets. Use **View > Toolbars > Bullets and Numbering** to see the toolbar.
### Tip

To move a list entry up, together with all of its sub-entries, click the **Promote One Level With Subpoints** button.

![Bullets and Numbering toolbar](image)

1. Bullets On/Off
2. Numbering On/Off
3. Numbering Off
4. Promote One Level
5. Demote One Level
6. Promote One Level with Subpoints
7. Demote One Level with Subpoints
8. Insert Unnumbered Entry
9. Move Up
10. Move Down
11. Move Up with Subpoints
12. Move Down with Subpoints
13. Restart Numbering
14. Bullets and Numbering

**Figure 16: Bullets and Numbering toolbar**

If you create a nested list using the buttons on this toolbar, all the levels of the list (up to 10) apply the same numbering (or bullet). However, in many circumstances you will want to use a combination of numbering formats and bullets when creating nested lists. Such lists, with a mixture of numbering formats and bullets, can be easily configured as described in the following example. Additional information on lists, in particular the technique to create your own list style, is described in Chapter 7, Working with Styles.

---

### Tip

When creating nested lists, one option is to enter all the list paragraphs first and apply the levels afterwards. You can use keyboard shortcuts to move paragraphs up or down the outline levels. Place the cursor at the beginning of the numbered paragraph and press:

- **Tab** Down a level
- **Shift+Tab** Up a level

To insert a tab stop at the beginning of a numbered paragraph (that is, after the number but before the text), press **Ctrl+Tab**.

---

### Example: configuring a nested list

We will use a numbering style to produce the following effect:

1. Level-1 list item
   1. Level-2 list item
     1. Level-3 list item
       1. Level-4 list item

This example uses one of the supplied styles, *Numbering 1*. If you intend to reuse this type of nested list, you can also create a new style as illustrated in Chapter 7, Working with Styles.

1) Open the Styles and Formatting window and click the **List Styles** icon at the top. Specify **All** in the drop-down list at the bottom of the window. Right-click on the *Numbering 1* style and choose **Modify** from the pop-up menu.
2) On the Numbering Style dialog, go to the Outline page, where you will find that one style matches our requirements. Click once on that style.

3) To modify the layout of the list, use the Options tab (Figures 19 and 20). Notice that the preview on the right shows the outline selected. In the Level box on the left, select 1, then 2, 3, and 4 and see how the information in the Numbering and After boxes changes.

Use the Options page to set different punctuation; for example, a period (full stop) after “a” on level 4 instead of a parenthesis.

To make the indentation at each level greater or less than the default, change it on the Position page. Select the level, then make any changes in the indentation, spacing, or numbering alignment.

4) Repeat for each level as required, then click OK.
With outline numbering you can define different bullet styles for the different levels of a bullet list. Use the Bullets tab of the Bullets and Numbering dialog (not shown) to select the basic style. Return to the Options tab to customize the bullet for each indent level. Here you can set bullets to any character. See the Graphics tab for more bullets.

Using footnotes and endnotes

Footnotes appear at the bottom of the page on which they are referenced. Endnotes are collected at the end of a document.

To work effectively with footnotes and endnotes, you need to:

- Insert footnotes.
- Define the format of footnotes.
- Define the location of footnotes on the page, and the color and line styles for separator lines.

Inserting footnotes/endnotes

To insert a footnote or an endnote, put the cursor where you want the footnote/endnote marker to appear. Then select Insert > Footnote/Endnote from the menu bar or click the Insert Footnote/Endnote Directly or Insert Endnote Directly icon on the Insert toolbar.

A footnote or endnote marker is inserted in the text and, depending on your choice, the cursor is relocated either to the footnote area at the bottom of the page or to the endnote area at the end of the document. Type the footnote or endnote content in this area.
If you use **Insert > Footnote/Endnote**, the Insert Footnote/Endnote dialog (Figure 22) is displayed. Here you can choose whether to use the automatic numbering sequence specified in the footnote settings and whether to insert the item as a footnote or an endnote.

If you use the **Insert Footnote/Endnote Directly** or **Insert Endnote Directly** icon, the footnote or endnote automatically takes on the attributes previously defined in the Footnote Settings dialog.

You can edit an existing footnote or endnote the same way you edit any other text.

To delete a footnote or endnote, delete the footnote marker. The contents of the footnote or endnote are deleted automatically, and the numbering of other footnotes or endnotes is adjusted automatically.

---

**Defining the format of footnotes/endnotes**

To format the footnotes themselves, click **Tools > Footnotes/Endnotes**. On the Footnotes/Endnotes Settings dialog (Figure 23), choose settings as required.

---

**Defining footnote location and separator line**

The location of footnotes on the page, and the color and style of the line that separates the footnotes from the text, are defined in the page style. If you are using several page styles, and may have footnotes on any of them, you need to define the footnote location and separator line on each of the page styles.

Choose **Format > Page** from the menu bar or right-click on a page and choose **Page** from the context menu, to display the **Page Style** dialog. Go to the **Footnote** tab (Figure 24) and make your selections, then click **OK** to save the changes.
Figure 23: Defining footnote formatting

Figure 24: Defining footnote location and separator line
Checking spelling and grammar

Spelling
Writer provides a spelling checker, which checks to see if each word in the document is in the installed dictionary. This can mean that proper names which are correctly spelled but which do not appear in the dictionary will be flagged as misspelled. Also provided is a grammar checker, which can be used separately or in combination with the spelling checker.

If it is enabled before entering text, AutoSpellcheck checks each word as it is typed. If it is enabled after text is inserted it checks the text already in the document. A wavy red line is displayed under any unrecognized words. It can be enabled from the Standard toolbar by clicking the AutoSpellcheck icon, or from Tools > Options > Language Settings > Writing Aids and selecting it in the Options list.

Right-clicking on an unrecognized word brings up the AutoCorrect context menu.

![AutoCorrect context menu](image)

Figure 25: AutoCorrect context menu

Clicking on one of the suggested words in the top section of the menu replaces the underlined word with the one selected.

The choices in the center section of the menu are:

Ignore
This one instance of the underlined word will be ignored while the document is open. Other instances, if they exist, will still be underlined. This setting is not stored with the document.

Ignore All
All instances of the word in the document will be ignored, and the word will be added to the IgnoreAllList user-defined dictionary.

Add
The word is added to a user-defined dictionary. If only one dictionary is enabled, no choice is offered here, and it is added by default to the Standard dictionary.

AutoCorrect
Selecting this opens the submenu, which repeats the suggestions for the word from the top section listing. Selecting a replacement word here stores the word pair in the replacement table.
under **Tools > AutoCorrect Options > Replacement**. The underlined word is replaced with the selected word.

**Spelling and Grammar**

This opens the **Spelling and Grammar** checker. See the explanations for this which follow.

In the third section of the context menu, language settings for the text can be set. These settings can be applied to the text, or to the paragraph containing the text.

**Spelling and grammar**

To perform a combined spelling and grammar check on the document (or a text selection), click the **Spelling and Grammar** button on the Standard toolbar, or press F7. In order to use this, the appropriate dictionaries must be installed. By default, four dictionaries are installed: a spellchecker, a grammar checker, a hyphenation dictionary, and a thesaurus. In operation the **Spelling and Grammar** tool checks either the document from the cursor point onwards, or the text selection. It opens the **Spelling and Grammar** dialog if any unrecognized words are found, or if any of the built-in grammar rules are broken. The option to restart from the beginning of the document is offered on reaching the end of the document.

![Figure 26: Spelling alert using the Spelling and Grammar dialog](image)

The elements of the Spelling and Grammar dialog are as follows.

**Not in dictionary**

The sentence containing the error is displayed in the pane. If an unrecognized word is found it is highlighted.

If the error is grammatical, then it is indicated in a pale colored bar below the **Text language** setting (Figure 27). The sentence or the word can be edited in the pane.

**Suggestions**

The pane contains suggested replacement words for the highlighted word. Select a word and then select **Change** or **Change All** to replace it.

For grammatical errors there is no multiple choice. Select **Change** to accept the suggestion.
Text language
The language to be used for the spell and grammar checking can be selected from this list. If the spell check is enabled for this language, a check mark is displayed in front of it.

Ignore Once, Ignore All, and Add
Selecting one of these buttons has the same effect as the item in the AutoCorrect context menu detailed above.

Change
Replaces the unknown word with the suggested word. If the sentence was edited, the whole sentence is changed.
For grammar, the suggested replacement is used to correct the text.

Change All
This replaces all instances of the word with the selected replacement word.

AutoCorrect
This behaves in a similar fashion to AutoCorrect described above. However, the word is not replaced and you must select one of the Change buttons.

Undo
This button is enabled when a change has been made to the sentence, in case you wish to reverse the change. The button is not accessible if you use a Change button to replace a word.

Options
Selecting this opens the Options dialogue box where you can select user defined dictionaries and set the spell checking rules.

Note
It is recommended you run the Spelling and Grammar checker twice on your document. A minor software problem may prevent it detecting all the grammar errors in a single pass.

Grammar
By default, Check grammar as you type is enabled in Tools > Options > Language Settings > Writing Aids > Options.
AutoSpellcheck must be enabled for this to work.
If any errors are detected, they are shown underlined by a wavy blue line. Right clicking on this line brings up a context menu which may be similar to one of those those below.
The first entry in the menu informs you of the suspected broken grammatical rule.

The second menu item in the left example is *Explanations*, which if selected opens your browser and takes you to a web page offering more information about the error. This entry is not always present in the context menu, as seen in the right example.

In the second section of the menu is the suggested correction. Clicking this changes the text to the suggestion. The example to the right appears blank, but clicking here removes the extra space causing the error.

In the third section of the menu you can select to ignore the indicated error, or to open the Spelling and Grammar checker. This dialog is shown below. This example displays the URL which will take you to a web site for more information on the error indicated.

![Figure 27: Dialog showing the URL for expanded explanation](image)

In the final section of the menu, you can set the language for the selection or the paragraph. Additional grammar checking rules can be selected through **Tools > Extension Manager > English spelling dictionaries > Options.**

![Figure 28: Additional grammar checking options](image)
Using built-in language tools

Writer provides some tools that make your work easier if you mix multiple languages within the same document or if you write documents in various languages:

- Selection of paragraph and character styles
- The functions in Tools > Language
- The use of language settings in Options
- The functions available on the status bar

The main advantage of changing the language for a text selection is that you can then use the correct dictionaries to check spelling and apply the localized versions of AutoCorrect replacement tables, thesaurus, and hyphenation rules. A grammar checking dictionary may be available for the selected language.

You can also set the language for a paragraph or a group of characters as None (Do not check spelling). This option is especially useful when you insert text such as web addresses or programming language snippets that you do not want to check for spelling.

Using paragraph and character styles

Specifying the language in character and paragraph styles is the preferred method, because styles allow a greater level of control and make changing the language much faster. On the Font tab of the Paragraph Style dialog, you can specify that certain paragraphs be checked in a language that is different from the language of the rest of the document. See Chapter 7, Working with Styles, for information on how to manage the language settings of a style.

Using Tools > Language

You can also set the language for the whole document, for individual paragraphs, or even for individual words and characters, from Tools > Language on the menu bar.

For Selection
- Applies a specified language to the selected text.

For Paragraph
- Applies the specified language to the paragraph where the cursor is located.

For all Text
- Applies the specified language to all of the document, including text inserted after making the change.

Using language settings in Options

Another way to change the language of a whole document is to use Tools > Options > Language Settings > Languages. In the Default languages for documents section (Figure 29), you can choose a different language for all the text that is not explicitly marked as a different language.

Caution

Unlike the menu tool that applies to the individual document, a change in the default language from the Options dialog is a general change of settings of LibreOffice and will therefore apply to all the documents created in the future. If you want to change the language for the current document only, be sure to select the For the current document only option.
The spelling checker works only for those languages in the list which have the symbol next to them. If you do not see this symbol next to your preferred language, you can install the dictionary using **Tools > Language > More dictionaries online.**

### Using the status bar

The language used for checking spelling is also shown in the status bar, next to the page style in use. You can change the language for the paragraph or the entire document; click on the language in the status bar to pop up a menu of choices.

![Language choices on the status bar](image)

Notice the **Reset to Default Language** option on the menu and submenu. This is the fastest way to return a paragraph or the entire document to the default language set in **Tools > Options** (described above).

### Using synonyms and the thesaurus

You can access a short list of synonyms from the context menu (Figure 17):

1) Select a word or phrase, right-click, and point to **Synonyms** on the context menu. A submenu of alternative words and phrases is displayed.
2) Click on a word or phrase to select it and replace the highlighted word or phrase in the document.

The thesaurus gives a more extensive list of alternative words and phrases. To use the thesaurus:

1) Select a word or phrase, and then choose **Tools > Language > Thesaurus,** or press **Ctrl+F7,** or right-click and choose **Thesaurus** from the **Synonyms** submenu.
2) In the dialog, click on a word or phrase within the numbered list of meanings to select it.
3) Click **Replace** to make the substitution.

For example, when given the word *house,* the thesaurus offers several meanings, including *dwelling,* *legislature,* *sign of the zodiac,* and others. Select a replacement word from the list under the relevant meaning, so for *dwelling,* you will see *dwelling,* *home,* *domicile,* *abode,* and other alternatives, as shown in Figure 32.
Figure 31: Synonyms on the context menu

Note

If the current language does not have a thesaurus installed, this feature is disabled.

Figure 32: The thesaurus offers alternatives to words

Using synonyms and the thesaurus
Hyphenating words

You have several choices regarding hyphenation: let Writer do it automatically (using its hyphenation dictionaries), insert conditional hyphens manually where necessary, or don’t hyphenate at all. Each choice has its pros and cons.

Automatic hyphenation

To turn automatic hyphenation of words on or off:

1) Press F11 to open the Styles and Formatting window. On the Paragraph Styles page, right-click on Default and select Modify.

![Figure 33: Modifying a paragraph style](image)

2) On the Paragraph Style dialog, select the Text Flow tab.

![Figure 34: Turning on automatic hyphenation](image)

3) Under Hyphenation, select or deselect the Automatically option.
4) Click OK to save.

| Note | Turning on hyphenation for the Default paragraph style affects all other paragraph styles that are based on Default. You can individually change other styles so that hyphenation is not active; for example, you might not want headings to be hyphenated. Any styles that are not based on Default are not affected. For more on paragraph styles, see Chapters 6 and 7 in this book. |

You can also set hyphenation choices through Tools > Options > Language Settings > Writing Aids. In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.
To change the minimum number of characters for hyphenation, or the minimum number of characters before or after a line break, select the item, and then click the Edit button in the Options section.

**Hyphenate without inquiry**
Specifies that you will never be asked to manually hyphenate words that the hyphenation dictionary does not recognize. If this box is not selected, when a word is not recognized, a dialog will open where you can manually enter hyphens.

**Hyphenate special regions**
Specifies that hyphenation will also be carried out in footnotes, headers, and footers.

Hyphenation options set in the **Writing Aids** dialog are effective only if hyphenation is turned on through paragraph styles.

**Manual hyphenation**
To manually hyphenate words, do not use a normal hyphen, which will remain visible even if the word is no longer at the end of a line when you add or delete text or change margins or font size. Instead, use a **conditional hyphen**, which is visible only when required.

To insert a conditional hyphen inside a word, click where you want the hyphen to appear and press Ctrl+hyphen or use **Insert > Formatting Mark > Optional hyphen**. The word will be hyphenated at this position when it is at the end of the line, even if automatic hyphenation for this paragraph is switched off.

**Using AutoCorrect**
Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it corrects automatically. For example, “hte” will be changed to “the”.

AutoCorrect is turned on when Writer is installed. To turn it off, uncheck **Format > AutoCorrect > While Typing**.

Select **Tools > AutoCorrect Options** to open the AutoCorrect dialog. There you can define what strings of text are corrected and how. In most cases, the defaults are fine.

To stop Writer replacing a specific spelling, go to the **Replace** tab, highlight the word pair, and click **Delete**.

To add a new spelling to the list, type it into the **Replace** and **With** boxes on the Replace tab, and click **New**.

See the different pages of the dialog for the wide variety of other options available to fine-tune AutoCorrect.

**Tip**
AutoCorrect can be used as a quick way to insert special characters. For example, (c) will be autocorrected to ©. You can add your own special characters.
Using word completion

If Word Completion is enabled, Writer tries to guess which word you are typing and offers to complete the word for you. To accept the suggestion, press Enter. Otherwise, continue typing.

To turn off Word Completion, select Tools > AutoCorrect Options > Word Completion and deselect Enable word completion.

You can customize word completion from the Word Completion page of the AutoCorrect dialog.

- Add (append) a space automatically after an accepted word.
- Show the suggested word as a tip (hovering over the word) rather than completing the text as you type.
- Collect words when working on a document, and then either save them for later use in other documents or select the option to remove them from the list when closing the document.
- Change the maximum number of words remembered for word completion and the length of the smallest words to be remembered.
- Delete specific entries from the word completion list.
- Change the key that accepts a suggested entry—the options are right arrow, End key, Enter (Return), Space bar, and Tab.

Note: Automatic word completion only occurs after you type a word for the second time in a document.
Use AutoText to store text, tables, fields, and other items for reuse and assign them to a key combination for easy retrieval. For example, rather than typing “Senior Management” every time you use that phrase, you can set up an AutoText entry to insert those words when you type “sm” and press F3.

AutoText is especially powerful when assigned to fields. See Chapter 14, Working with Fields, for more information.

Creating AutoText

To store some text as AutoText:

1) Type the text into your document.
2) Select the text.
3) Go to Edit > AutoText (or press Ctrl+F3).
4) In the AutoText dialog, type a name for the AutoText in the Name box. Writer will suggest a one-letter shortcut, which you can change.
5) In the large box to the left, choose the category for the AutoText entry, for example My AutoText.
6) Click the AutoText button on the right of the dialog and select from the menu either New (to have the AutoText retain specific formatting, no matter where it is inserted) or New (text only) (to have the AutoText take on the existing formatting around the insertion point).
7) Click Close to return to your document.
To save a table (such as the formatted Tip above) as AutoText:

1) Create a table and format it the way you want.
2) Select the table.
3) Go to Edit > AutoText (or press Ctrl+F3).
4) Type a name for the AutoText, optionally amend the suggested shortcut, and choose the category for the AutoText entry.
5) Click the AutoText button and select New (because you want the formatting of the table preserved).
6) Click Close to return to your document.

**Inserting AutoText**

To insert AutoText, type the shortcut and press F3.

**Printing a list of AutoText entries**

To print a list of AutoText entries:

1) Choose Tools > Macros > Organize Macros > LibreOffice Basic.
2) In the Macro from list, expand LibreOffice Macros > Gimmicks.
3) Select AutoText and then click Run. A list of the current AutoText entries is generated in a separate text document. You can then print this document.
Line numbering

Line numbering puts line numbers in the margin. The line numbers are displayed on screen and are also printed. Figure 39 shows an example with numbering on every line.

Click Tools > Line Numbering and select the Show numbering option in the top left corner of the Line Numbering dialog (Figure 40). Then click OK.

Figure 39: Line numbering example

Figure 40: The Line Numbering dialog
You can choose how many lines are numbered (for example, every line or every tenth line), the numbering type, and whether numbers restart on each page. In addition, a text separator (any text you choose) can be set on a different numbering scheme (one every 12 lines, for example).

**Tracking changes to a document**

You can use several methods to keep track of changes made to a document.

- Make your changes to a copy of the document (stored in a different folder, under a different name, or both), then use Writer to combine the two files and show the changes you made. Click **Edit > Compare Document**. This technique is particularly useful if you are the only person working on the document, as it avoids the increase in file size and complexity caused by the other methods.
- Save versions that are stored as part of the original file. However, this method can cause problems with documents of nontrivial size or complexity, especially if you save a lot of versions. Avoid this method if you can.
- Use Writer’s change marks (often called “redlines” or “revision marks”) to show where you have added or deleted material or changed formatting. Later, you or another person can review and accept or reject each change.

| Note | Not all changes are recorded. For example, changing a tab stop from align left to align right and changes in formulas (equations) or linked graphics are not recorded. |

**Preparing a document for review**

When you send a document to someone else to review or edit, you may want to prepare it first so that the editor or reviewer does not have to remember to turn on the revision marks. After you have protected the document, any user must enter the correct password in order to turn off the function or accept or reject changes.

1) Open the document. To check whether it contains multiple versions, click **File > Versions**. If multiple versions are listed, save the current version as a separate document with a different name and use this new document as the review copy.
2) With the review copy open, make sure that change recording is turned on. The **Edit > Changes > Record** menu item has a check mark next to it when recording is turned on.
3) Click **Edit > Changes > Protect Records**. On the Enter Password dialog, type a password (twice) and click **OK**.

| Tip | An alternative to steps 2 and 3 above is to choose **File > Properties > Security** tab, select the **Record changes** option, then click **Protect** and enter the password. |

**Recording changes**

See Chapter 2, Setting up Writer, for instructions on setting up how your changes will be displayed.

1) To begin tracking (recording) changes, choose **Edit > Changes > Record**. To show or hide the display of changes, click **Edit > Changes > Show**.

| Tip | Hold the mouse pointer over a marked change; you will see a Help Tip showing the type of change, the author, date, and time of day for the change. If Extended Tips are enabled, you will also see any comments recorded for this change. |
2) To enter a comment on a marked change, place the cursor in the area of the change and then click **Edit > Changes > Comment**.
In addition to being displayed as an extended tip, the comment is also displayed in the list in the Accept or Reject Changes dialog (Figure 42).
To move from one marked change to the next, use the arrow buttons. If no comment has been recorded for a change, the Text field is blank.

3) To stop recording changes, click **Edit > Changes > Record** again.

| Tip | See also “Adding other comments” on page 39 for a way to annotate text that is not associated with a recorded change. |

![Figure 41: Inserting a comment during change recording](image)

**Accepting or rejecting changes**

To accept or reject recorded changes, use either of these methods:
- Right-click (context) menu
- Accept or Reject Changes dialog

The results of accepting or rejecting a change are as follows:
- Accepting a change incorporates the alteration into the document and removes the change indication marking.
- Rejecting a change reverts the document to its original state and removes the change indication marking.

**Right-click (context) menu**
1) If recorded changes are not showing, click **Edit > Changes > Show**.
2) Hover the mouse pointer over a recorded change. A box appears with information about the type of change, who made it, and the date and time.
3) Right-click on the changed text. In the context menu, choose **Accept Change** or **Reject Change**.

**Accept or Reject Changes dialog**
1) Click **Edit > Changes > Accept or Reject**. The Accept or Reject Changes dialog (Figure 42) opens, showing changes that have not yet been accepted or rejected.
2) When you select a change in the dialog, the actual change is highlighted in the document, so you can see what the editor changed.

3) Click **Accept** or **Reject** to accept or reject the selected change. You can also click **Accept All** or **Reject All** if you do not want to review the changes individually.

To show only the changes of certain people or only the changes on specific days or various other restrictions, use the **Filter** page (Figure 43) on the Accept or Reject Changes dialog. After specifying the filter criteria, return to the **List** page to see those changes that meet your criteria.

![Figure 42: The List tab of the Accept or Reject Changes dialog](image)

![Figure 43: The Filter page of the Accept or Reject Changes dialog](image)
Merging modified documents

The processes discussed to this point are effective when you have one reviewer at a time. Sometimes, however, multiple reviewers all return edited versions of a document at the same time. In this case, it may be quicker to review all of these changes at once, rather than one review at a time. For this purpose, you can merge documents in Writer.

To merge documents, all of the edited documents need to have recorded changes in them.

1) Open one copy.
2) Click Edit > Changes > Merge Document and select and insert another copy of the document to be merged with the first.
3) After the documents merge, the Accept or Reject Changes dialog opens, as in Figure 42, showing changes by more than one reviewer. If you want to merge more documents, close the dialog and then repeat step 2.
4) Repeat until all copies are merged.

All recorded changes are now included in the open copy. Save this file under another name.

Comparing documents

Sometimes reviewers may forget to record the changes they make. This is not a problem with Writer because you can find the changes if you compare documents.

In order to compare documents, you need to have the original document and the one that is edited. To compare them:

1) Open the edited document. Select Edit > Compare Document.
2) The Insert dialog appears. Select the original document and click Insert.

Writer finds and marks the changes and displays the Accept or Reject Changes dialog. From this point, you can go through and accept or reject changes procedure as described earlier.

Adding other comments

Writer provides another type of comments (formerly called “notes”), which authors and reviewers often use to exchange ideas, ask for suggestions, or brainstorm during the review process.

A block of text may be selected for a comment, or a single point may be selected at which the comment will be inserted. To insert a comment select the text, or place the cursor in the place the comment refers to and choose Insert > Comment or press Ctrl+Alt+C. The anchor point of the comment is connected by a dotted line to a box on the right-hand side of the page where you can type the text of the comment. Writer automatically adds at the bottom of the comment the author’s name and a time stamp indicating when the comment was created. Figure 44 shows an example of text with comments from two different authors.

Click somewhere on the page to show Writer that you have finished your comment. Otherwise, you will not be able to move away from this location.

Select Tools > Options > LibreOffice > User Data to configure the name you want to appear in the Author field of the comment, or to change it.

If more than one person edits the document, each author is automatically allocated a different background color.
Right-clicking on a comment pops up a menu where you can delete the current comment, all the comments from the same author, or all the comments in the document. This part of the menu is also available by clicking the down-arrow in the comment. From this menu, you can also apply some basic formatting to the text of the comment. You can also change font type, size, and alignment from the menu bar.

To navigate from one comment to another, open the Navigator (F5), expand the Comments section, and click on the comment text to move the cursor to the anchor point of the comment in the document. Right-click on the comment to quickly edit or delete it.

You can also navigate the comments using the keyboard. Use Ctrl+Alt+Page Down to move to the next comment and Ctrl+Alt+Page Up to move to the previous comment.

### Linking to another part of a document

If you type in cross-references to other parts of the document, those references can easily get out of date if you reorganize the order of topics, add or remove material, or reword a heading. Writer provides two ways to ensure that your references are up to date, by inserting links to other parts of the same document or to a different document:

- Hyperlinks
- Cross-references

The two methods have the same result if you Ctrl+click the link when the document is open in Writer: you are taken directly to the cross-referenced item. However, they also have major differences:

- The text in a hyperlink does **not** automatically update if you change the text of the linked item (although you can change it manually), but changed text does automatically update in a cross-reference.
- When using a hyperlink, you do not have a choice of the content of the link (for example text or page number), but when using a cross-reference, you have several choices, including bookmarks.
- To hyperlink to an object such as a graphic, and have the hyperlink show useful text such as *Figure 6*, you need to either give such an object a useful name instead of leaving it as the default name (“Graphics6”), or you need to use the Hyperlink dialog to modify the visible text. In contrast, cross-references to figures with captions automatically show useful text, and you have a choice of several variations of the name.
- If you save a Writer document to HTML, hyperlinks remain active but cross-references do not. (Both remain active when the document is exported to PDF.)
Using cross-references
To ensure that references update if you reword a heading, caption, or other linked item, use automatic cross-references. See “Using automatic cross-references” in Chapter 14, Working with Fields, for details.

Using bookmarks
Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse click. In HTML documents, bookmarks are converted to anchors that you can jump to by hyperlink. For more about bookmarks, see “Using bookmarks” in Chapter 14, Working with Fields.

Using hyperlinks
When you type text (such as website addresses or URL) that can be used as a hyperlink, and then press the spacebar or the Enter key, Writer automatically creates the hyperlink and applies formatting to the text (usually a color and underlining).

If this does not happen, you can enable this feature using Tools > AutoCorrect Options > Options and selecting the URL Recognition option.

If you do not want Writer to convert a specific URL to a hyperlink, choose Edit > Undo Insert from the menu bar or press Ctrl+Z immediately after the formatting has been applied.

You can also insert hyperlinks using the Navigator and the Hyperlink dialog, and you can modify all hyperlinks using the Hyperlink dialog, as described in this section.

Note
Hyperlinks between documents can be set as relative or absolute, using the Save URLs relative to option in Tools > Options > Load/Save > General.

Relative linking is only possible when the document you are working on and the link destination are on the same drive, and you need to create the same directory structure on your hard disk as will apply on the destination website.

LibreOffice uses absolute path names internally, so when you move your mouse cursor over a hyperlink, the tooltip displays the absolute reference even when it is set to be a relative link.

Inserting hyperlinks using the Navigator
The easiest way to insert a hyperlink to another part of the same document is by using the Navigator:

1) Open the document containing the items you want to cross-reference.
2) Open the Navigator (by clicking its icon, choosing View > Navigator, or pressing F5).
3) Click the arrow next to the Drag Mode icon, and select Insert as Hyperlink.
4) In the list at the bottom of the Navigator, select the document containing the item that you want to cross-reference.
5) In the Navigator list, select the item that you want to insert as a hyperlink.
6) Drag the item to where you want to insert the hyperlink in the document. The name of the item is inserted in the document as an active hyperlink.
Inserting hyperlinks using a dialog

To display the Hyperlink dialog (Figure 46), click the Hyperlink icon on the Standard toolbar or choose Insert > Hyperlink from the menu bar. To turn existing text into a link, highlight it before opening the dialog.

On the left hand side, select one of the four types of hyperlink:

- **Internet**: a web address, normally starting with http://
- **Mail & News**: for example an email address.
- **Document**: the hyperlink points to another document or to another place in the presentation.
- **New document**: the hyperlink creates a new document.

The top right part of the dialog changes according to your choice for the hyperlink type. A full description of all the choices, and their interactions, is beyond the scope of this chapter. Here is a summary of the most common choices used in presentations.
For an Internet type hyperlink, choose the type of hyperlink (choose between Web, FTP or Telnet), and enter the required web address (URL).

For a Mail and News type hyperlink, specify whether it is a mail or news link, the receiver address and for email, also the subject.

For a Document type hyperlink, specify the document path (the Open File button opens a file browser); leave this blank if you want to link to a target in the same presentation. Optionally specify the target in the document (for example a specific slide). Click on the Target icon to open the Navigator where you can select the target, or if you know the name of the target, you can type it into the box.

For a New Document type hyperlink, specify whether to edit the newly created document immediately or just create it (Edit later) and the type of document to create (text, spreadsheet, and so on). For a text document, Edit now is the more likely choice. The Select path button opens a directory picker.

The Further settings section in the bottom right part of the dialog is common to all the hyperlink types, although some choices are more relevant to some types of links.

- Set the value of Frame to determine how the hyperlink will open. This applies to documents that open in a Web browser.
- Form specifies if the link is to be presented as text or as a button.
- Text specifies the text that will be visible to the user.
- Name is applicable to HTML documents. It specifies text that will be added as a NAME attribute in the HTML code behind the hyperlink.
- Event button: this button will be activated to allow LibreOffice to react to events for which the user has written some code (macro). This function is not covered in this book.

**Editing hyperlinks**

To edit a hyperlink, click anywhere in the link text and then open the Hyperlink dialog by clicking the Hyperlink icon on the Standard toolbar or choosing Edit > Hyperlink from the menu bar. Make your changes and click Apply. If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until you have edited all of them. Be sure to click Apply after each one. When you are finished, click Close.

The standard (default) behavior for activating hyperlinks within LibreOffice is to use Ctrl+click. This behavior can be changed in Tools > Options > LibreOffice > Security > Options, by deselecting the option Ctrl-click required to follow hyperlinks. If clicking in your links activates them, check that page to see if the option has been deselected.

To change the color of hyperlinks, go to Tools > Options > LibreOffice > Appearance, scroll to Unvisited links and/or Visited links, select those options, pick the new colors and click OK. Caution: this will change the color for all hyperlinks in all components of LibreOffice—this may not be what you want.

In Writer and Calc (but not Draw or Impress), you can also change the Internet link character style or define and apply new styles to selected links.

**Switching between insert and overwrite mode**

In insert mode, any text after the cursor position moves forward to make room for the text you type; in overwrite mode, text after the cursor position is replaced by the text you type. Only the Overwrite mode is displayed on the Status Bar. The shape of the cursor does not change.
With the keyboard, press Insert to toggle between overwrite mode and insert mode. With the mouse, click in the area on the Status Bar that indicates the current mode in order to switch to the other mode. Overwrite mode cannot be used with Edit > Changes > Record enabled.

### Counting the words in a selection

Word count for the document, and any selected text, is displayed on the Status bar. Word count and character count can be viewed by choosing Tools > Word Count or double-clicking on the word count field in the Status bar; this information updates as you edit the document. See Chapter 2, Setting up Writer, for information on setting word counting boundaries.

You can also see the number of words and characters (and other information including the number of pages, tables, and graphics) in the entire document in File > Properties > Statistics.

### Changing the case of selected text

To quickly change the case of text, select it, choose Format > Change Case from the menu bar, and then choose one of the following:

- Sentence case, where only the first word is capitalized (together with any proper nouns)
- lower case, where no words (except proper nouns) are capitalized
- UPPER CASE, where all letters are capitalized
- Capitalize Every Word, where every word is capitalized
- tOGGLE cASE, which changes every letter to the opposite case

There are also several options that are used with Asian text. These are not strictly “Case” changes, but are lumped together in the broader sense of replacing characters with different forms of the same letter. These options are hidden when Asian language support is not enabled.

Writer does not have an automated way to do Title Case, where all words are capitalized except for certain subsets defined by rules that are not universally standardized. To achieve this affect, you can use Capitalize Every Word and then restore those words that were incorrectly capitalized.