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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click

Opens a context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Opens the Navigator

F11

z+T

Opens the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Choosing options for all of LibreOffice
This section covers some of the settings that apply to all the components of LibreOffice. For
information on settings not discussed here, see the online help.
Click Tools > Options. The list in the left-hand box of the Options – LibreOffice dialog varies
depending on which component of LibreOffice is open. The illustrations in this chapter show the list
as it appears when a Writer document is open.
Click the marker (+ or triangle) by LibreOffice on the left-hand side. A list of pages drops down.
Selecting an item in the list causes the right-hand side of the dialog to display the relevant page.

Figure 1: LibreOffice options

Note

The Revert button (not shown in the illustration; located in the lower right of the full
Options dialog) has the same effect on all pages of the Options dialog. It resets the
options to the values that were in place when you opened the dialog.

User Data options
Because LibreOffice uses the name or initials stored in the LibreOffice – User Data page for
several things, including document properties (created by and last edited by information) and the
name of the author of comments and changes, you will want to ensure that the correct information
appears here.

Figure 2: Filling in user data
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Fill in the form (shown in Figure 2), or amend or delete any existing incorrect information.
If you are using a version of LibreOffice other than US English, some field labels may be different
from those shown in the illustrations.

General options
The options on the LibreOffice – General page are described below.

Figure 3: Setting general options for LibreOffice
Help - Tips
When Tips is active, one or two words will appear when you hold the mouse pointer over an
icon or field, without clicking.
Help - Extended tips
When Extended tips is active, a brief description of the function of a particular icon or menu
command or a field on a dialog appears when you hold the mouse pointer over that item.
Help Agent
To turn off the Help Agent (similar to Microsoft’s Office Assistant), deselect this option. To
restore the default behavior, click Reset Help Agent.
Open/Save dialogs – Use LibreOffice dialogs
To use the standard Open and Save dialogs for your operating system, deselect the Use
LibreOffice dialogs option. When this option is selected, the Open and Save dialogs supplied
with LibreOffice will be used. See Chapter 1, Introducing LibreOffice, for more about the
LibreOffice Open and Save dialogs. This book uses the LibreOffice Open and Save dialogs in
illustrations.
Print dialogs – Use LibreOffice dialogs
(Mac only) To use the standard Print dialogs for your operating system, deselect the Use
LibreOffice dialogs option. When this option is selected, the Print dialogs supplied with
LibreOffice will be used. This book uses the LibreOffice Print dialogs in illustrations.
Document status – Printing sets “document modified” status
If this option is selected, then the next time you close the document after printing, the print date
is recorded in the document properties as a change and you will be prompted to save the
document again, even if you did not make any other changes.
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Document status – Allow to save document even when the document is not modified
Normally when a document has not been modified, the File > Save menu option and the Save
icon on the Standard toolbar are disabled and the keyboard shortcut Ctrl+S has no effect.
Select this option to allow documents to be saved even when they have not been modified.
Year (two digits)
Specifies how two-digit years are interpreted. For example, if the two-digit year is set to 1930,
and you enter a date of 1/1/30 or later into your document, the date is interpreted as 1/1/1930
or later. An “earlier” date is interpreted as being in the following century; that is, 1/1/20 is
interpreted as 1/1/2020.

Memory options
The options on the LibreOffice – Memory page control how LibreOffice uses your computer’s
memory and how much memory it requires. Before changing them, you may wish to consider the
following points:

• More memory can make LibreOffice faster and more convenient (for example, more undo
steps require more memory); but the trade-off is less memory available for other
applications and you could run out of memory altogether.

• If your documents contain a lot of objects such as images, or the objects are large,
LibreOffice’s performance may improve if you increase the memory for LibreOffice or the
memory per object. If you find that objects seem to disappear from a document that
contains a lot of them, increase the number of objects in the cache. (The objects are still in
the file even if you cannot see them on screen.)

Figure 4: Choosing Memory options for the LibreOffice applications

• To load the Quickstarter (an icon on the desktop or in the system tray) when you start your
computer, select the option near the bottom of the dialog. This makes LibreOffice start
faster; the trade-off is LibreOffice uses some memory even when not being used. This
option (called Enable systray quickstarter on Linux) is not available on Mac OS X or on
systems where the Quickstarter module has not been installed.
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View options
The options on the LibreOffice – View page affect the way the document window looks and
behaves. Some of these options are described below. Set them to suit your personal preferences.

Figure 5: Choosing View options for LibreOffice applications
User Interface – Scaling
If the text in the help files or on the menus of the LibreOffice user interface is too small or too
large, you can change it by specifying a scaling factor. Sometimes a change here can have
unexpected results, depending on the screen fonts available on your system. However, it does
not affect the actual font size of the text in your documents.
User Interface – Icon size and style
The first box specifies the display size of toolbar icons (Automatic, Small, or Large). The
Automatic icon size option uses the setting for your operating system. The second box
specifies the icon style (theme); here the Automatic option uses an icon set compatible with
your operating system and choice of desktop: for example, KDE or Gnome on Linux.
User Interface – Use system font for user interface
If you prefer to use the system font (the default font for your computer and operating system)
instead of the font provided by LibreOffice for the user interface, select this option.
User interface – Screen font anti-aliasing
(Not available in Windows; not shown in Figure 5.) Select this option to smooth the screen
appearance of text. Enter the smallest font size to apply anti-aliasing.
Menu – icons in menus
Causes icons as well as words to be visible in menus.
Font Lists - Show preview of fonts
Causes the font list to look like Figure 6, Left, with the font names shown as an example of the
font; with the option deselected, the font list shows only the font names, not their formatting
(Figure 6, Right). The fonts you will see listed are those that are installed on your system.
Fonts which are tuned for use with a specific script, such as Arabic, Hebrew, Malayalam, and
so on, now show an additional preview of some sample text in the target script.
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Figure 6. Font list (Left) With preview; (Right) Without preview
Font Lists - Show font history
Causes the last five fonts you have assigned to the current document to be displayed at the top
of the font list. Otherwise fonts are shown in alphabetical order.
Graphics output – Use hardware acceleration
Directly accesses hardware features of the graphical display adapter to improve the screen
display. Not supported on all operating systems and LibreOffice distributions.
Graphics output – Use anti-aliasing
Enables and disables anti-aliasing, which makes the display of most graphical objects look
smoother and with fewer artifacts. Not supported on all operating systems and LibreOffice
distributions.

Tip

Press Shift+Ctrl+R to restore or refresh the view of the current document after
changing the anti-aliasing settings, to see the effect.

Mouse positioning
Specifies if and how the mouse pointer will be positioned in newly opened dialogs.
Middle mouse button
Defines the function of the middle mouse button.

• Automatic scrolling – dragging while pressing the middle mouse button shifts the view.
• Paste clipboard – pressing the middle mouse button inserts the contents of the “Selection
clipboard” at the cursor position.
The “Selection clipboard” is independent of the normal clipboard that you use by Edit >
Copy/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard”
can contain different contents at the same time.
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Function

Clipboard

Selection clipboard

Copy content

Edit > Copy Ctrl+C

Select text, table, or object.

Paste content

Edit > Paste Ctrl+V pastes at
the cursor position.

Clicking the middle mouse button
pastes at the mouse pointer position.

Pasting into another
document

No effect on the clipboard
contents.

The last marked selection is the
content of the selection clipboard.

Selection – Transparency
Determines the appearance of selected text or graphics, which appear on a shaded
background. To make the shaded background more or less dark, increase or decrease the
Transparency setting.
If you prefer selected material to appear in reversed color (typically white text on a black
background), deselect this option.

Print options
On the LibreOffice – Print page, set the print options to suit your default printer and your most
common printing method.

Figure 7: Choosing general printing options to apply to all LibreOffice components
In the Printer warnings section near the bottom of the page, you can choose whether to be warned
if the paper size or orientation specified in your document does not match the paper size or
orientation available for your printer. Having these warnings turned on can be quite helpful,
particularly if you work with documents produced by people in other countries where the standard
paper size is different from yours.

Tip

If your printouts are incorrectly placed on the page or chopped off at the top, bottom,
or sides, or the printer is refusing to print, the most likely cause is page size
incompatibility.
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Paths options
On the LibreOffice – Paths page, you can change the location of files associated with, or used by,
LibreOffice to suit your working situation. In a Windows system, for example, you might want to
store documents by default somewhere other than My Documents.
To make changes, select an item in the list shown in Figure 8 and click Edit. On the Select Path
dialog (not shown; may also be titled Edit Paths), add or delete folders as required, and then click
OK to return to the Options dialog. Note that some items can have at least two paths listed: one to
a shared folder (which might be on a network) and one to a user-specific folder (normally on the
user’s personal computer).

Tip

You can use the entries on the LibreOffice – Paths page to compile a list of files,
such as those containing AutoText, that you need to back up or copy to another
computer.

Figure 8: Viewing the paths of files used by LibreOffice

Color options
On the LibreOffice – Colors page, you can specify colors to use in LibreOffice documents. You can
select a color from a color table, edit an existing color, and define new colors. These colors are
stored in your color palette and are then available in all components of LibreOffice.
To modify a color:
1) Select the color to modify from the list or the color table.
2) Enter the new values that define the color. You can choose the RGB (Red, Green, Blue) or
the CMYK (Cyan, Magenta, Yellow, Black) system to specify your color. The changed color
appears in the lower of the two color preview boxes at the top.
3) Modify the Name as required.
4) Click the Modify button. The newly defined color is now listed in the Color table.
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Figure 9: Defining colors to use in color palettes in LibreOffice
Alternatively, click the Edit button to open the Color Picker dialog, shown in Figure 10. Here you
can select a color from the window on the left, or you can enter values on the right using your
choice of RGB, CMYK, or HSB (Hue, Saturation and Brightness) values.

Figure 10: Editing colors
The color window on the left is linked directly with the color input fields on the right; as you choose
a color in the window, the numbers change accordingly. The color field at the lower left shows the
value of the selected color on the left and the currently set value from the color value fields on the
right.
Modify the color components as required and click OK to exit the dialog. The newly defined color
now appears in the lower of the color preview boxes shown in Figure 9. Type a name for this color
Choosing options for all of LibreOffice
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in the Name box, then click the Add button. A small box showing the new color is added to the
Color table.
Another way to define or alter colors is through the Colors page of the Area dialog, where you can
also save and load palettes, a feature that is not possible here. In Calc, draw a temporary draw
object and use the context menu of this object to open the Area dialog. If you load a palette in one
component of LibreOffice, it is only active in that component; the other components keep their own
palettes.

Font options
You can define replacements for any fonts that might appear in your documents. If you receive
from someone else a document containing fonts that you do not have on your system, LibreOffice
will substitute fonts for those it does not find. You might prefer to specify a different font from the
one that the program chooses.

Figure 11: Defining a font to be substituted for another font
On the LibreOffice – Fonts page:
1) Select the Apply Replacement Table option.
2) Select or type the name of the font to be replaced in the Font box. (If you do not have this
font on your system, it will not appear in the drop-down list in this box, so you need to type
it in.)
3) In the Replace with box, select a suitable font from the drop-down list of fonts installed on
your computer.
4) The checkmark to the right of the Replace with box turns green. Click on this checkmark.
A row of information now appears in the larger box below the input boxes. Select Always to
replace the font, even if the original font is installed on your system. Select Screen only to
replace the screen font only and never replace the font for printing. The results of
combining these selections are given in Table 1.
5) In the bottom section of the page, you can change the typeface and size of the font used to
display source code such as HTML and Basic (in macros).
12
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Table 1. Font substitution replacement actions
Always
checkbox
checked

Screen only
checkbox
blank

Replacement action

checked

checked

Font replacement only on screen, whether the font is installed or
not.

blank

checked

Font replacement only on screen, but only if font is not available.

blank

blank

Font replacement on screen and when printing, but only if font is
not available.

Font replacement on screen and when printing, whether the font is
installed or not.

Security options
Use the LibreOffice – Security page to choose security options for saving documents and for
opening documents that contain macros.

Figure 12: Choosing security options for opening and saving documents
Security options and warnings
If you record changes, save multiple versions, or include hidden information or notes in your
documents, and you do not want some of the recipients to see that information, you can set
warnings to remind you to remove it, or you can have LibreOffice remove some of it
automatically. Note that (unless removed) much of this information is retained in a file whether
the file is in LibreOffice’s default OpenDocument format, or has been saved to other formats,
including PDF.
Click the Options button to open a separate dialog with specific choices (Figure 13).
Macro security
Click the Macro Security button to open the Macro Security dialog (not shown here), where
you can adjust the security level for executing macros and specify trusted sources.
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Security options and warnings
The following options are on the Security options and warnings dialog (Figure 13).
Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file. To
manually remove personal information from specific documents, deselect this option and then
use the Delete button under File > Properties > General.
Ctrl-click required to follow hyperlinks
The default behavior in LibreOffice is to Ctrl+click on a hyperlink to open the linked document.
Many people find creation and editing of documents easier when accidental clicks on links do
not activate the links. To set LibreOffice to activate hyperlinks using an ordinary click, deselect
this option.
The other options on this dialog should be self-explanatory.

Figure 13: Security options and warnings dialog

Personalization
Personalization allows you to add a theme to your LibreOffice installation. You can choose to not
use a Persona, to use a pre-installed Persona if one is available, to select a ready-made persona
from the Mozilla Firefox site, or to add your own design. This option defaults to Pre-installed
Persona (if available) at installation time.

Figure 14: Personalization options
To install a persona, click the Select Persona button to open the install dialog, shown in Figure 16.
From here you can install your persona by either entering a local URL to the persona, or by clicking
14
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the Visit Firefox Personas button (an internet connection is required for this choice). Installation
instructions are on the dialog.
Full details about Personas are on the website http://www.getpersonas.com

Figure 15: A Persona installed

Figure 16: Persona installation dialog

Appearance options
Writing, editing, and (especially) page layout are often easier when you can see the page margins
(text boundaries), the boundaries of tables and sections (in Writer documents), page breaks in
Calc, grid lines in Draw or Writer, and other features. In addition, you might prefer to use colors that
are different from LibreOffice’s defaults for such items as comment indicators or field shadings.
On the LibreOffice – Appearance page (Figure 17), you can specify which items are visible and the
colors used to display various items.

• To show or hide items such as text boundaries, select or deselect the options next to the
names of the items.

• To change the default colors for items, click the down-arrow in the Color Setting column by
the name of the item and select a color from the list box. Note that you can change the list
of available colors as described in “Color options” on page 10.

• To save your color changes as a color scheme, click Save, type a name in the Scheme
box, and then click OK.

Choosing options for all of LibreOffice

15

Figure 17: Showing or hiding text, object, and table boundaries

Accessibility options
Accessibility options include whether to allow animated graphics or text, how long help tips remain
visible, some options for high contrast display, and a way to change the font for the user interface
of the LibreOffice program.
Accessibility support relies on the Java Runtime Environment for communication with assistive
technology tools. The Support assistive technology tools option is not shown on all LibreOffice
installations. See Assistive Tools in LibreOffice in the Help for other requirements and information.
Select or deselect the options as required.

Figure 18: Choosing accessibility options
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Advanced
Java options
If you install or update a Java Runtime Environment (JRE) after you install LibreOffice, or if you
have more than one JRE installed on your computer, you can use the LibreOffice – Java
options page to choose the JRE for LibreOffice to use.
If you are a system administrator, programmer, or other person who customizes JRE
installations, you can use the Parameters and Class Path pages (reached from the Java page)
to specify this information.
If you do not see anything listed in the middle of the page, wait a few minutes while LibreOffice
searches for JREs on the hard disk.
If LibreOffice finds one or more JREs, it will display them there. You can then select the Use a
Java runtime environment option and (if necessary) choose one of the JREs listed.

Figure 19: Choosing a Java runtime environment
Optional (unstable) options
Enable experimental features
Selecting this option enables features that are not yet complete or contain known bugs. The list
of these features is different version by version.
Enable macro recording
This option enables macro recording with some limitations. Opening a window, switching
between windows, and recording in a different window to that in which the recording began, is
not supported. Only actions relating to document contents are recordable, so changes in
Options or customizing menus are not supported. For more about macro recording, see
Chapter 13, Getting Started with Macros.

Online update options
On the LibreOffice – Online Update page (Figure 20), you can choose whether and how often to
have the program check the LibreOffice website for program updates. If the Check for updates
automatically option is selected, an icon appears at the right-hand end of the menu bar when an
update is available. Click this icon to open a dialog where you can choose to download the update.
If the Download updates automatically option is selected, the download starts when you click the
icon. To change the download destination, click the Change button and select the required folder in
the file browser window.
Choosing options for all of LibreOffice
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Figure 20: Online update options

Choosing Load/Save options
You can set the Load/Save options for loading and saving documents to suit the way you work.
If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or
triangle) to the left of Load/Save.

General
Most of the choices on the Load/Save – General page are familiar to users of other office suites.
Some items of interest are described below.

Figure 21. Choosing Load and Save options
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Load user-specific settings with the document
A LibreOffice document contains certain settings that are read from the user’s system. When
you save a document, these settings are saved with it.
Select this option so that when a document loads, it ignores the stored settings in favor of the
settings on your computer.
Even if you do not select this option, some settings are taken from your LibreOffice installation:

•
•
•
•
•

Settings available in File > Print > Options
Name of Fax
Spacing options for paragraphs before text tables
Information about automatic updating for links, field functions and charts

Information about working with Asian character formats.
The following settings are always loaded with a document, whether or not this option is
marked:

• Data source linked to the document and its view.
If you deselect this option, the user’s personal settings do not overrule the settings in the
document. For example, your choice (in the options for LibreOffice Writer) of how to update
links is affected by the Load user-specific settings option.
Load printer settings with the document
If enabled, the printer settings will be loaded with the document. This can cause a document to
be printed on a distant printer (perhaps in an office setting), if you do not change the printer
manually in the Print dialog. If disabled, your standard printer will be used to print this
document. The current printer settings will be stored with the document whether or not this
option is selected.
Edit document properties before saving
If you select this option, the Document Properties dialog pops up to prompt you to enter
relevant information the first time you save a new document (or whenever you use Save As).
Always create backup copy
Saves the previous version of a document as a backup copy whenever you save a document.
Every time LibreOffice creates a backup copy, the previous backup copy is replaced. The
backup copy gets the extension BAK. Authors whose work may be very lengthy should always
consider using this option.
Save AutoRecovery information every __ Minutes
Choose whether to enable AutoRecovery and how often to save the information used by the
AutoRecovery process.
AutoRecovery in LibreOffice saves the information needed to restore all open documents in
case of a crash. If you have this option set, recovering your document after a system crash will
be easier.
Save URLs relative to file system / internet
Use this option to select the default for relative addressing of URLs in the file system and on
the Internet. Relative addressing is only possible if the source document and the referenced
document are both on the same drive.
A relative address always starts from the directory in which the current document is located. In
contrast, absolute addressing always starts from a root directory. The following table
demonstrates the difference in syntax between relative and absolute referencing:

Choosing Load/Save options
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Examples

File system

Internet

relative

../images/img.jpg

../images/img.jpg

absolute

file:///c|/work/images/img.jpg

http://myserver.com/work/images/img.jpg

If you choose to save relatively, the references to embedded graphics or other objects in your
document will be saved relative to the location in the file system. In this case, it does not matter
where the referenced directory structure is recorded. The files will be found regardless of
location, as long as the reference remains on the same drive or volume. This is important if you
want to make the document available to other computers that may have a completely different
directory structure, drive or volume names. It is also recommended to save relatively if you
want to create a directory structure on an Internet server.
If you prefer absolute saving, all references to other files will also be defined as absolute,
based on the respective drive, volume or root directory. The advantage is that the document
containing the references can be moved to other directories or folders, and the references
remain valid.
Default file format and ODF settings
ODF format version. LibreOffice by default saves documents in OpenDocument Format
(ODF) version 1.2 Extended. While this allows for improved functionality, there may be
backwards compatibility issues. When a file saved in ODF 1.2 Extended is opened in an editor
that uses earlier versions of ODF (1.0/1.1), some of the advanced features may be lost. Two
notable examples are cross-references to headings and the formatting of numbered lists. If you
plan to share documents with people who use editors that use older versions of ODF, you may
wish to save the document using ODF version 1.0/1.1.
Size optimization for ODF format. LibreOffice documents are XML files. When you select this
option, LibreOffice writes the XML data without indents and line breaks. If you want to be able
to read the XML files in a text editor in a structured form, deselect this option.
Document type. If you routinely share documents with users of Microsoft Office, you might
want to change the Always save as attribute for documents to one of the Microsoft Office
formats. Current versions of Microsoft Word can open ODT files, so this may no longer be
needed.

Note

Although LibreOffice can open and save files in the DOCX and XLSX formats
produced by Microsoft Office 2007 and 2010, it does not yet save in PPTX format.
This capability is planned for a future release.

VBA Properties
On the VBA Properties page, you can choose whether to keep any macros in Microsoft Office
documents that are opened in LibreOffice.
If you choose Load Basic code, you can edit the macros in LibreOffice. The changed code is
saved in an ODF document but is not retained if you save into a Microsoft Office format.
If you choose Save original Basic code, the macros will not work in LibreOffice but are retained
unchanged if you save the file into Microsoft Office format.
If you are importing a Microsoft Word or Excel file containing VBA code, you can select the option
Executable code. Whereas normally the code is preserved but rendered inactive (if you inspect it
with the StarBasic IDE you will notice that it is all commented), with this option the code is ready to
be executed.
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Figure 22: Choosing Load/Save VBA Properties
Save original Basic code takes precedence over Load Basic code. If both options are selected
and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved when
saving in a Microsoft Office format.
To remove any possible macro viruses from the Microsoft Office document, deselect Save original
Basic code. The document will be saved without the Microsoft Basic code.

Microsoft Office
On the Load/Save – Microsoft Office page, you can choose what to do when importing and
exporting Microsoft Office OLE objects (linked or embedded objects or documents such as
spreadsheets or equations).
Select the [L] options to convert Microsoft OLE objects into the corresponding LibreOffice OLE
objects when a Microsoft document is loaded into LibreOffice (mnemonic: “L” for “load”).
Select the [S] options to convert LibreOffice OLE objects into the corresponding Microsoft OLE
objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”).

Figure 23: Choosing Load/Save Microsoft Office options
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HTML compatibility
Choices made on the Load/Save – HTML Compatibility page affect HTML pages imported into
LibreOffice and those exported from LibreOffice. See HTML documents; importing/exporting in the
Help for more information.

Figure 24. Choosing HTML compatibility options
Font sizes
Use these fields to define the respective font sizes for the HTML <font size=1> to <font size=7>
tags, if they are used in the HTML pages. (Many pages no longer use these tags.)
Import - Use 'English (USA)' locale for numbers
When importing numbers from an HTML page, the decimal and thousands separator
characters differ according to the locale of the HTML page. The clipboard, however, contains
no information about the locale. If this option is not selected, numbers will be interpreted
according to the Locale setting in Tools > Options > Language Settings > Languages (see
page Error: Reference source not found). If this option is selected, numbers will be interpreted
as for the English (USA) locale.
Import - Import unknown HTML tags as fields
Select this option if you want tags that are not recognized by LibreOffice to be imported as
fields. For an opening tag, an HTML_ON field will be created with the value of the tag name.
For a closing tag, an HTML_OFF will be created. These fields will be converted to tags in the
HTML export.
Import - Ignore font settings
Select this option to have LibreOffice ignore all font settings when importing. The fonts that
were defined in the HTML Page Style will be used.
Export
To optimize the HTML export, select a browser or HTML standard from the Export box. If
LibreOffice Writer is selected, specific LibreOffice Writer instructions are exported.
Export - LibreOffice Basic
Select this option to include LibreOffice Basic macros (scripts) when exporting to HTML format.
You must activate this option before you create the LibreOffice Basic macro; otherwise the
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script will not be inserted. LibreOffice Basic macros must be located in the header of the HTML
document. Once you have created the macro in the LibreOffice Basic IDE, it appears in the
source text of the HTML document in the header.
If you want the macro to run automatically when the HTML document is opened, choose Tools
> Customize > Events. See Chapter 13, Getting Started with Macros, for more information.
Export - Display warning
When the LibreOffice Basic option (see above) is not selected, the Display warning option
becomes available. If the Display warning option is selected, then when exporting to HTML a
warning is shown that LibreOffice Basic macros will be lost.
Export - Print layout
Select this option to export the print layout of the current document as well. The HTML filter
supports CSS2 (Cascading Style Sheets Level 2) for printing documents. These capabilities
are only effective if print layout export is activated.
Export - Copy local graphics to Internet
Select this option to automatically upload the embedded pictures to the Internet server when
uploading using FTP.
Export - Character set
Select the appropriate character set for the export.

Choosing language settings
There are several options to customize the language setting in LibreOffice:
• Install the required dictionaries
• Change some locale and language settings
• Choose spelling options

Install the required dictionaries
LibreOffice automatically installs several dictionaries with the program. To add other dictionaries,
be sure you are connected to the Internet, and then use Tools > Language > More Dictionaries
Online. LibreOffice will open your default web browser to a page containing links to additional
dictionaries that you can install. Follow the prompts to select and install the ones you want.

Change some locale and language settings
You can change some details of the locale and language settings that LibreOffice uses for all
documents, or for specific documents.
In the Options dialog, click Language Settings > Languages. The exact list shown depends on
the Enhanced language support settings (see Figure 26).

Figure 25: LibreOffice language options, with Asian
language options enabled on the right side
Choosing language settings
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On the right-hand side of the Language Settings – Languages page, change the User interface,
Locale setting, Default currency, and Default languages for documents as required. In the
example, English (USA) has been chosen for all the appropriate settings.

Figure 26: Choosing language options
If you want the language setting to apply to the current document only, instead of being the default
for all new documents, select For the current document only.
If necessary, select the options to enable support for Asian languages (Chinese, Japanese,
Korean) and support for CTL (complex text layout) languages such as Urdu, Thai, Hebrew, and
Arabic. If you choose either of these options, the next time you open this dialog, you will see some
extra choices under Language Settings, as shown in Figure 25. These choices (Searching in
Japanese, Asian Layout, and Complex Text Layout) are not discussed here.

Choose spelling options
To choose the options for checking spelling, click Language Settings > Writing Aids. In the
Options section of the page (Figure 27), choose the settings that are useful for you.
Some considerations:

• If you do not want spelling checked while you type, deselect Check spelling as you type.
This option can also be deselected using the AutoSpellcheck button on the Standard
toolbar.

• If you want grammar to be checked as you type, you must have Check spelling as you
type enabled too.

• If you use a custom dictionary that includes words in all upper case and words with
numbers (for example, AS/400), select Check uppercase words and Check words with
numbers.

• Check special regions includes headers, footers, frames, and tables when checking
spelling.
Here you can also check which user-defined (custom) dictionaries are active by default, and add or
remove user-installed dictionaries, by clicking the New or Delete buttons. Dictionaries installed by
the system cannot be deleted.
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Figure 27: Choosing languages, dictionaries, and options for checking spelling

Choosing Internet options
Use the Internet Options pages to define search engines and save proxy settings for use with
LibreOffice.
If you are using a Mozilla browser (such as Firefox) on Windows or Linux, you can enable the
Browser Plug-in so you can open LibreOffice files in your browser, print them, save them, and work
with them in other ways.
If you are using a Unix- or Linux-based operating system (including Mac OS X), an additional page
of E-mail options is available, where you can specify the e-mail program to use when you send the
current document as e-mail. Under Windows the operating system’s default e-mail program is
always used.

Figure 28: Internet options, showing E-mail page available to Linux users
A MediaWiki publisher is included. To enable it, select MediaWiki in the Internet options, then click
the Add button to open the dialog shown in Figure 29. Here you can specify the address (URL)
and login information for a wiki. You can add several wikis to the list.

Choosing Internet options
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Figure 29: Specifying a MediaWiki server account

Controlling LibreOffice’s AutoCorrect functions
Some people find some or all of the items in LibreOffice’s AutoCorrect function annoying because
they change what you type when you do not want it changed. Many people find some of the
AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find
unexplained changes appearing in your document, this is a good place to look to find the cause.
To open the AutoCorrect dialog, click Tools > AutoCorrect Options. (You need to have a
document open for this menu item to appear.) In Writer, this dialog has five tabs, as shown in
Figure 30. In other components of LibreOffice, the dialog has only four tabs. More details are given
in the component guides.

Figure 30: The AutoCorrect dialog in Writer, showing some of the choices on the Options tab
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