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Quick printing

Click the Print icon  to send the entire document to the default printer defined for your 

computer.

Note

You can change the action of the Print icon to send the document to the printer defined 
for the document instead of the default printer for the computer. Go to Tools > Options
> Load/Save > General and select Load printer settings with the document.

Controlling printing

For more control over printing, use the Print dialog (File > Print or Ctrl+P).

Figure 1: The Print dialog

Note

The options selected on the Print dialog apply to this printing of this document only.

To specify default printing settings for LibreOffice, go to Tools > Options > LibreOffice 
> Print and Tools > Options > LibreOffice Writer > Print. See Chapter 20, Setting Up 
Writer, for more details.

The Print dialog has four pages, from which you can choose a range of options, as described in the
following sections.
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Selecting general printing options
On the General page of the Print dialog, you can choose:

• The printer (from the printers available). The Print to File printer is now always available 
and will generate a PDF file that you save on your disk.

• Which pages to print, the number of copies to print, and whether to collate multiple copies 
(Range and copies section)

• Whether to print any comments that are in the document, and where to print the comments.

Some selections may not be available all the time. For example, if the document contains no 
comments, the Print – Comments drop-down list does not work.

Figure 2: Choosing whether and where to print comments

Click the Properties button to display the selected printer’s properties dialog, where you can 
choose portrait or landscape orientation, which paper tray to use, and the paper size to print on.

On the Options page of the Print dialog, you can choose other options for printing.

Figure 3: General print options

Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this:

 1) In the Print dialog, select the Page Layout tab (Figure 4).

 2) In the Layout section, select from the drop-down list the number of pages to print per sheet.
The preview panel on the left of the Print dialog shows how the printed document will look.

 3) When printing more than two pages per sheet, you can choose the order in which they are 
printed across and down the paper. Figure 5 shows the difference.

 4) In the Page sides section, select whether to print all pages or only some pages.

 5) Click OK.

Tip

To print two pages per sheet in “facing pages” (book layout) style, print from Print 
Preview instead. See page 9.
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Figure 4: Printing multiple page per sheet of paper

Figure 5: Choosing the order in which to print multiple pages

Selecting what to print
In addition to printing a full document, you can choose to print individual pages, ranges of pages, 
or a selection of a document, as described in this section.

Printing an individual page:

 1) Choose File > Print from the Menu bar, or press Ctrl+P.

 2) On the Print dialog, select the page to print.

 3) In the Range and copies section of the General page, select the Pages option.

 4) Enter the sequence number of the page you want to print. This may differ from the page 
number if you have restarted page numbering within the document. The preview box 
changes to show the selected page.

 5) Click OK.
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Printing a range of pages:

 1) Choose File > Print from the Menu bar, or press Ctrl+P.

 2) On the Print dialog, select the range of pages to print.

 3) In the Ranges and copies section of the General page, select the Pages option.

 4) Enter the sequence numbers of the pages to print (for example, 1–4 or 1,3,7,11).

 5) Click OK.

Printing a selection of text:

 1) In the document, select the material (text and images) to print.

 2) Choose File > Print from the menu bar, or press Ctrl+P.

 3) The Ranges and copies section of the Print dialog now includes a Selection option and the 
preview box shows the selected material. See Figure 6.

 4) Click OK.

Figure 6: Printing a selection of text

Printing a brochure
In Writer, you can print a document with two pages on each side of a sheet of paper, arranged so 
that when the printed pages are folded in half, the pages are in the correct order to form a booklet 
or brochure.

Tip

Plan your document so it will look good when printed half size; choose appropriate 
margins, font sizes, and so on. You may need to experiment.

To print a brochure on a single-sided printer:

 1) Choose File > Print, or press Ctrl+P.

 2) On the General page of the Print dialog, click Properties.
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 3) Check that the printer is set to the same orientation (portrait or landscape) as specified in 
the page setup for your document. Usually the orientation does not matter, but it does for 
brochures. Click OK to return to the Print dialog.

 4) Select the Page layout tab in the Print dialog.

 5) Select the Brochure option.

 6) In the Page sides section, select Back sides / left pages from the Include drop-down list. 
(See Figure 7.)

 7) Click OK.

Figure 7: Selecting which pages to print

 8) Take the printed pages out of the printer, turn the pages over, and put them back into the 
printer in the correct orientation to print on the blank side. You may need to experiment a bit
to find out what the correct arrangement is for your printer.

 9) On the Print dialog, in the Page sides section, select Front sides / right pages from the 
Include drop-down box. Click OK.

Tip

If your printer can print double-sided automatically, choose All pages.

Printing in black and white (on a color printer)
You may wish to print documents in black and white on a color printer. Several choices are 
available. Please note that some color printers may print in color regardless of the settings you 
choose.

Change the printer settings to print in black and white or grayscale:

 1) Choose File > Print, or press Ctrl+P, to open the Print dialog.

 2) Click Properties to open the Properties dialog for the printer. The available choices vary 
from one printer to another, but you should find options for the Color settings. See your 
printer’s help or user manual for more information.

 3) The choices for color might include black and white or grayscale. Choose the required 
setting.

 4) Click OK to confirm your choice and return to the Print dialog,

 5) Click OK to print the document.
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Tip

Grayscale is better if you have any images in the document.

Change the LibreOffice settings to print all color text and images as grayscale:

 1) Choose Tools > Options > LibreOffice > Print.

 2) Select the Convert colors to grayscale option. Click OK to save the change.

 3) Open the Print dialog (File > Print or press Ctrl+P).

 4) Click OK to print the document.

Change the LibreOffice Writer settings to print all color text as black, and all images as grayscale:

 1) Choose Tools > Options > LibreOffice Writer > Print.

 2) Under Contents, select the Print text in black option. Click OK to save the change.

 3) Open the Print dialog (File > Print), or press Ctrl+P.

 4) Click OK to print the document.

Previewing pages before printing
The normal page view in Writer shows what each page will look like when printed; you can edit the 
pages in that view. If you are designing a document to be printed double-sided, you may want to 
see what facing pages look like. Writer provides two ways to do this:

• View Layout (editable view): use the Facing Pages (Book View) button on the status bar.

• Print Preview (read-only view).

To use Print Preview:

 1) Choose File > Print Preview (or click the Print Preview button  on the Standard 

toolbar). Writer now displays the Print Preview toolbar instead of the Formatting toolbar.

Figure 8: Page Preview toolbar

 2) Select the required preview button: Two Pages ,  Book Preview , or Multiple Pages

.

 3) To print the document from this view, click the Print button   to open the Print dialog.

 4) Choose the print options and click OK.

Printing envelopes

Printing envelopes involves two steps: setup and printing.

To set up an envelope to be printed by itself or with your document:

 1) Click Insert > Envelope from the Menu bar.

 2) In the Envelope dialog, start with the Envelope tab. Verify, add, or edit the information in the
Addressee and Sender (the “from” on the envelope) boxes.
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Figure 9: Choosing addressee and sender information for an envelope

You can type information directly into the Addressee and Sender boxes, or use the right-
hand drop-down lists to select the database or table from which you can draw the envelope 
information, if desired. See Chapter 15, Mail Merge, for details on how to print envelopes 
from a database.

 3) On the Format page (Figure 10), verify or edit the positioning of the addressee and the 
sender information. The preview area on the lower right shows the effect of your positioning
choices.

 4) To format the text of these blocks, click the Edit buttons to the right. In the drop-down list 
you have two choices for each button: Character and Paragraph.

– Select Character to open a Character dialog, similar to the standard Character dialog, 
but omitting Borders, where you can set the formatting of the text.

– Select Paragraph to open a Paragraph dialog, similar to the standard Paragraph dialog,
but omitting Outline & Numbering, where you to can set the paragraph's attributes.

 5) In the lower left of this page, the Size section, choose the envelope format from the drop-
down list. The width and height of the selected envelope then show in the boxes below the 
selected format. If you chose a pre-existing format, just verify these sizes. If you chose 
User defined in the Format list, then you can edit the sizes.
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Figure 10: Choosing positioning and size of elements for an envelope

 6) After formatting, go to the Printer page (Figure 11) to choose printer options such as 
envelope orientation and shifting. You may need to experiment a bit to see what works best 
for your printer.

You can also choose a different printer or alter printer setup (for example, specify the tray 
that holds envelopes) for this print job by clicking the Setup button and making selections 
on the Printer Setup dialog.

Figure 11: Choosing printer options for an envelope
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 7) When you have finished formatting and are ready to print, click either the New Document 
or Insert button to finish. New Document makes only an envelope or starts a new 
document with the envelope. Insert puts the envelope into your existing document as 
page 1.

To not proceed with this envelope, click Cancel or press the Esc key. You can also click 
Reset to remove your changes and return to the original settings when the dialog opened.

The document now has the envelope in the same file as the document. Save this file before you do
anything else.

To print the envelope:

 1) Choose File > Print from the menu bar.

 2) On the Print dialog, under Print range, choose Pages and type 1 in the box. Click OK to 
print.

Printing labels

Labels are commonly used for printing address lists (where each label shows a different address), 
but they can also be used for making multiple copies of one label only, for example return-address 
stickers. To print labels:

 1) Choose File > New > Labels on the Menu bar. The Labels dialog opens.

 2) On the Labels page, fill in your own label text in the Inscription box, or use the Database 
and Table drop-down lists to choose the required information, as described in Chapter 15, 
Mail Merge.

Figure 12: Labels dialog, Labels page

 3) Select the label stock in the Brand drop-down list. The types for that brand then appear in 
the Type drop-down list. Select the size and type of labels required. You can also select 
User in the Type drop-down list and then make specific selections on the Format page.

 4) On the Format page, choose the pitch, sizes, margins, columns and rows for user-defined 
labels, or just verify with a brand of label stock you have loaded into the printer.
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Figure 13: Labels dialog, Format page

 5) Click Save to save your new format.

 6) On the Options page, choose to print the entire page of labels or one single label, then 
select which one by the column and row. You can also change printer setup.

Figure 14: Labels dialog, Options page

 7) When you have finished formatting, click New Document to create your sheet of labels or 
click Cancel (or press the Esc key). You can also click Reset to remove your changes and 
return to the original settings when the dialog opened.

 8) You can print using the Print File Directly icon on the toolbar or by choosing File > Print 
from the Menu bar, or you can save the file to print later.

Exporting to PDF

LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file 
format is ideal for sending the file to someone else to view using Adobe Reader or other PDF 
viewers.

Tip

Unlike Save As, the Export command writes a copy of the current document in a new 
file with the chosen format, but keeps the current document and format open in your 
session.
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Quick export to PDF

Click the Export as PDF button  to export the entire document using the PDF settings you 

most recently selected in the PDF Options dialog. You are asked to enter the file name and 
location for the PDF, but you do not get a chance to choose a page range, the image compression,
or other options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as PDF. The 
PDF Options dialog opens. This dialog has six pages (General, Initial View, User Interface, Links, 
Security, and Digital Signatures). Select the appropriate settings, and then click Export. Then you 
are asked to enter the location and file name of the PDF to be created, and click Export.

Note

Another choice is to use File > Export. This opens the Export dialog. Select the PDF 
file format, file name and location and click Export. This then opens the PDF Options 
dialog. Click Export when all the selections have been made. The only difference 
between the two export methods is the sequence in which steps occur.

General page of PDF Options dialog
On the General page (Figure 15), you can choose which pages to include in the PDF, the type of 
compression to use for images (which affects the quality of images in the PDF), and other options.

Range section
• All: Exports the entire document.

• Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single 
pages, use the format 7;9;11 (pages 7, 9, and 11). You can also export a combination of 
page ranges and single pages, by using a format like 3-6;8;12.

• Selection: Exports whatever material is selected.

Images section
• Lossless compression: Images are stored without any loss of quality. Tends to make 

large files when used with photographs. Recommended for other kinds of images or 
graphics.

• JPEG compression: Allows for varying degrees of quality. A setting of 90% works well with
photographs (small file size, little perceptible loss of quality).

• Reduce image resolution: Lower-DPI (dots per inch) images have lower quality. For 
viewing on a computer screen generally a resolution of 72dpi (for Windows) or 96dpi 
(GNU/Linux) is sufficient, while for printing it is generally preferable to use at least 300 or 
600 dpi, depending on the capability of the printer. Higher dpi settings greatly increase the 
size of the exported file.

Note

EPS (Encapsulated PostScript) images with embedded previews are exported only as 
previews. EPS images without embedded previews are exported as empty 
placeholders.

Watermark section
• Sign with Watermark: When this option is selected, a transparent overlay of the text you 

enter into the Watermark Text box will appear on each page of the PDF.
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Figure 15: General page of PDF Options dialog 

General section
• Hybrid PDF (embed ODF file): Use this setting to export the document as a PDF file 

containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF 
file, and it remains fully editable in LibreOffice.

• Archive PDF/A-1a (ISO 19005-1): PDF/A is an ISO standard for long-term preservation of 
documents, by embedding all the information necessary for faithful reproduction (such as 
fonts) while forbidding other elements (including forms, security, and encryption). PDF tags 
are written. If you select PDF/A-1a, the forbidden elements are grayed-out (not available).

• Tagged PDF: Tagged PDF contains information about the structure of the document’s 
contents. This can help to display the document on devices with different screens, and 
when using screen reader software. Some tags that are exported are table of contents, 
hyperlinks, and controls. This option can increase file sizes significantly.

• Create PDF form – Submit format: Choose the format of submitting forms from within the 
PDF file. This setting overrides the control’s URL property that you set in the document. 
There is only one common setting valid for the whole PDF document: PDF (sends the 
whole document), FDF (sends the control contents), HTML, and XML. Most often you will 
choose the PDF format.

Allow duplicate field names: If enabled, the same field name can be used for multiple 
fields in the generated PDF file. With this option enabled, you can enter data in the first 
occurrence of the named field in the PDF document and all fields with the same name will 
carry your entry. If disabled, field names will be exported using generated unique names.

• Export bookmarks: Creates PDF bookmarks (a table of contents list displayed by most 
PDF viewers, including Adobe Reader) for all headings in the document.

• Export placeholders: Exports placeholder text instead of a blank placeholder.

• Export comments: Exports comments as PDF notes. You may not want this!
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• Export automatically inserted blank pages: If selected, automatically inserted blank 
pages are exported to the PDF. This is best if you are printing the PDF double-sided. For 
example, books usually have chapters set to always start on an odd-numbered (right-hand)
page. When the previous chapter ends on an odd page, LibreOffice inserts a blank page 
between the two odd pages. This option controls whether to export that blank page.

• View PDF after export: Your default PDF viewer will open and display the newly exported 
PDF.

Initial View page of PDF Options dialog
On the Initial View page, you can choose how the PDF opens by default in a PDF viewer. The 
selections should be self-explanatory.

If you have Complex Text Layout enabled (in Tools > Options > Language settings > 
Languages), an additional selection is available under Continuous facing: First page is left 
(normally, the first page is on the right when using the Continuous facing option).

Figure 16: Initial View page of PDF Options dialog

User Interface page of PDF Options dialog
On the User Interface page, you can choose more settings to control how a PDF viewer displays 
the file. Some of these choices are particularly useful when you are creating a PDF to be used as a
presentation or a kiosk-type display.

Window options section
• Resize window to initial page. Causes the PDF viewer window to resize to fit the first 

page of the PDF.

• Center window on screen. Causes the PDF viewer window to be centered on the 
computer screen.

• Open in full screen mode. Causes the PDF viewer to open full-screen instead of in a 
smaller window.

• Display document title. Causes the PDF viewer to display the document’s title in the title 
bar.
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Figure 17: User Interface page of PDF Options dialog

User interface options section
• Hide menubar. Causes the PDF viewer to hide the menu bar.

• Hide toolbar. Causes the PDF viewer to hide the toolbar.

• Hide window controls. Causes the PDF viewer to hide other window controls.

Bookmarks
Select how many heading levels are displayed as bookmarks, if Export bookmarks is 
selected on the General page.

Links page of PDF Options dialog
On the Links page, you can choose how links in documents are exported to PDF.

Figure 18: Links page of PDF Options dialog

Export bookmarks as named destinations
If you have defined Writer bookmarks, this option exports them as “named destinations” to 
which Web pages and PDF documents can link.

Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such as 
.odt, .ods, and .odp), this option converts the files names to .pdf in the exported PDF 
document.

Export URLs relative to the file system
If you have defined relative links in a document, this option exports those links to the PDF.

Exporting to PDF | 17



Cross-document links
Set up the behavior of the PDF links to other files. Select one among the following alternatives:

• Default mode: The PDF links will be handled as specified in your operating system.

• Open with PDF reader application: Use the same application used to display the PDF 
document to open linked PDF documents.

• Open with Internet browser: Use the default Internet browser to display linked PDF 
documents.

Security page of PDF Options dialog
PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and 
apply some digital rights management (DRM) features.

• With an open password set, the PDF can only be opened with the password. Once opened,
there are no restrictions on what the user can do with the document (for example, print, 
copy, or change it).

• With a permissions password set, the PDF can be opened by anyone, but its permissions 
can be restricted. See Figure 19. After you set a password for permissions, the other 
choices on the Security page become available.

• With both the open password and permission password set, the PDF can only be opened 
with the correct password, and its permissions can be restricted.

Note

Permissions settings are effective only if the user’s PDF viewer respects the settings.

Figure 19: Security page of PDF Options dialog with passwords set
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Figure 20 shows the pop-up dialog displayed when you click the Set passwords button on the 
Security page of the PDF Options dialog.

Figure 20: Setting a password to encrypt a PDF

Digital Signatures page of PDF Options dialog
The Digital Signatures page contains the options related to exporting a digitally signed PDF.

Digital signatures are used to ensure that the PDF was really created by the original author (that is,
you), and that the document has not been modified since it was signed.

The signed PDF export uses the keys and X.509 certificates already stored in your default key 
store location or on a smartcard. The key store to be used can be selected under Tools > Options 
> LibreOffice > Security > Certificate Path. When using a smartcard, it must already be 
configured for use by your key store. This is usually done during installation of the smartcard 
software. Details about using these features is outside the scope of this chapter.

Figure 21: Digital Signatures page of PDF Options dialog

• Use this certificate to digitally sign PDF documents: Click Select to open the Select 
Certificate dialog, where all certificates found in your selected key store are displayed. If the
key store is protected by a password, you are prompted for it. When using a smartcard that 
is protected by a PIN, you are also prompted for that. 

Select the certificate to use for digitally signing the exported PDF, then click OK. All other 
fields on the Digital Signatures tab are accessible only after a certificate has been selected.
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• Certificate password: Enter the password used for protecting the private key associated 
with the selected certificate. Usually this is the key store password. If the key store 
password has already been entered in the Select Certificate dialog, the key store may 
already be unlocked and not require the password again.

When using a smartcard, enter the PIN here. Some smartcard software will prompt you for 
the PIN again before signing.

• Location, Contact information, Reason: Optionally enter additional information about the 
digital signature that will be applied to the PDF. This information will be embedded in the 
appropriate PDF fields and will be visible to anyone viewing the PDF. Each or all of the 
three fields may be left blank.

• Time Stamp Authority: Optionally select a Time Stamping Authority (TSA) URL. During the 
PDF signing process, the TSA will be used to obtain a digitally signed timestamp that is 
then embedded in the signature. Anyone viewing the PDF can use this timestamp to verify 
when the document was signed.

The list of TSA URLs that can be selected is maintained under Tools > Options > 
LibreOffice > Security > TSAs. If no TSA URL is selected (the default), the signature will 
not be timestamped, but will use the current time from your local computer.

Exporting to XHTML
LibreOffice uses the term “export” for some file operations involving a change of file type. 
LibreOffice can export files to XHTML. Other formats may be made available through extensions.

To export to XHTML, choose File > Export. On the Export dialog, specify a file name for the 
exported document, then select the XHTML in the File format list and click the Export button.

Figure 22: Export file formats

E-mailing Writer documents

LibreOffice provides several ways to quickly and easily send a Writer document as an e-mail
attachment in one of three formats: .odt (OpenDocument Text, Writer’s default format), .doc 
(Microsoft Word format), or .pdf.

Note

Documents can be sent from the LibreOffice mail merge wizard only if a mail profile 
has been set up in Tools > Option > LibreOffice Writer > Mail Merge E-mail.

To send the current document in .odt format, choose:

 1) File > Send > E-mail Document, or File > Send > E-mail as OpenDocument Text. Writer
opens your default e-mail program. The document is attached.

 2) In your e-mail program, enter the recipient, subject, and any text you want to add, then 
send the e-mail.
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If you choose E-mail as Microsoft Word, Writer first creates a .doc file and then opens your 
e-mail program with the .doc file attached. Similarly, if you choose E-mail as PDF, Writer opens 
the PDF Options dialog where you can select the settings you want, then creates a PDF, and then 
opens your email program with the .pdf file attached.

E-mailing a document to several recipients
To e-mail a document to several recipients, you can use the features in your e-mail program or you
can use LibreOffice’s mail merge facilities to extract email addresses from an address book.

You can use LibreOffice’s mail merge to send e-mail in two ways:

• Use the Mail Merge Wizard to create the document and send it. See Chapter 15, Mail 
Merge, for details.

• Create the document in Writer without using the Wizard, then use the Wizard to send it. 
This method is described here.

To use the Mail Merge Wizard to send a previously-created Writer document:

 1) Open the document in Writer. Click Tools > Mail Merge Wizard. On the first page of the 
wizard, select Use the current document and click Next.

Figure 23: Select starting document

 2) On the second page, select E-mail message for the type of document and click Next.

Figure 24: Select document type

 3) On the third page, click the Select Address List button. Select the required address list 
(even if only one is shown) and then click OK. (If the address list you need is not shown 
here, you can click Add to find and add it to the list.)
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Figure 25: Selecting an address list

 4) Back on the Select address list page, click Next. On the Create salutation page, deselect 
the checkbox by This document should contain a salutation.

Figure 26: Deselecting a salutation

 5) In the left-hand list, click Step 8. Save, print or send. LibreOffice displays a “Creating 
documents” message and then displays the Save, print or send page of the Wizard.

 6) Select Send merged document as E-Mail. The lower part of the page changes to show 
e-mail settings choices.

 7) Type a subject for your email and click Send documents. LibreOffice sends the e-mails.
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Figure 27: Sending a document as an email message

Sending a fax

To send a fax directly from LibreOffice, you need a fax modem and a fax driver that allows 
applications to communicate with the fax modem.

 1) Open the Print dialog (Figure 1) by choosing File > Print (or Ctrl+P) and select the fax 
driver in the Printer list.

 2) Click OK to open the dialog for your fax driver, where you can select the fax recipient.

You can set up a toolbar button so that a single click sends the current document as a fax. To add 
a button for this purpose to a toolbar, see Chapter 21, Customizing Writer.

Digital signing of documents

To sign a document digitally, you need a personal key, also known as a certificate. A personal key 
is stored on your computer as a combination of a private key, which must be kept secret, and a 
public key, which you add to your documents when you sign them. You can get a certificate from a 
certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a kind of checksum is computed from the 
document’s content plus your personal key. The checksum and your public key are stored together 
with the document. 

When someone later opens the document on any computer with a recent version of LibreOffice, 
the program will compute the checksum again and compare it with the stored checksum. If both 
are the same, the program will signal that you see the original, unchanged document. In addition, 
the program can show you the public key information from the certificate. You can compare the 
public key with the public key that is published on the web site of the certificate authority. 
Whenever someone changes something in the document, this change breaks the digital signature.

On Windows operating systems, the Windows features of validating a signature are used. On Linux
systems, files that are supplied by Thunderbird, Mozilla, or Firefox are used. For a more detailed 
description of how to get and manage a certificate, and signature validation, see “About Digital 
Signatures” in the LibreOffice Help.
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To sign a document:

 1) Choose File > Digital Signatures. If you have set LibreOffice to warn you when the 
document contains comments, you may see a message box asking whether you want to 
continue signing the document.

 2) If you have not saved the document since the last change, a message box appears. Click 
Yes to save the file.

 3) The Digital Signatures dialog opens. Click Sign Document to add a public key to the 
document.

 4) In the Select Certificate dialog, select your certificate and click OK to return to the Digital 
Signatures dialog.

 5) The certificate used is displayed in the dialog with an icon next to its name. This icon 
indicates the status of the digital signature.

– An icon with a red seal  indicates that the document was signed and the certificate 
was validated.

– An icon with a yellow caution triangle overlaying the red seal  indicates that the 
document is signed but that the certificate could not be validated.

– An icon of a yellow caution triangle  indicates an invalid digital signature.

 6) Click Close to apply the digital signature.

A signed document shows an icon in the status bar. You can double-click the icon to view the 
certificate. More than one signature can be added to a document.

Signing multiple times with same signature
In the past, LibreOffice prohibited creating multiple signatures by the same author on a document, 
because there was no semantic meaning of signing the same document multiple times. LibreOffice
now provides a signature description, so multiple signatures from the same author are now 
allowed, because each signature can have a different meaning.

When you select File > Digital Signatures, the dialog (Figure 28) lists existing signatures together
with their description (if they have any).

Figure 28: Signatures of the document

When you click the Sign Document button, the dialog (Figure 29) for certificate selection also asks
for an optional description.
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Changing an existing description invalidates the signature.

Figure 29: Signatures can now have a description

Removing personal data

You may wish to ensure that personal data, versions, comments, hidden information, or recorded 
changes are removed from files before you send them to other people or create PDFs from them.

In Tools > Options > LibreOffice > Security > Options, you can set LibreOffice to remind (warn) 
you automatically when saving files containing certain information and optionally remove personal 
information.

Figure 30: Set security warnings and options

To remove personal and some other data from a file, go to File > Properties. On the General tab, 
uncheck Apply user data and then click the Reset Properties button. This removes any names in
the created and modified fields, deletes the modification and printing dates, and resets the editing 
time to zero, the creation date to the current date and time, and the version number to 1.

To remove version information, either (a) go to File > Versions, select the versions from the list 
and click Delete, or (b) use Save As and save the file with a different name.
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