Chapter 3
Working with Objects and Object Points
Copyright

This document is Copyright © 2011–2014 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
Martin Fox  Jean Hollis Weber  John A Smith  Peter Schofield

Feedback
Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note: Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Acknowledgments
This chapter is based on an original French document written for OpenOffice.org 1.x by Michel Pinquier (translated into English by Alex Thurgood) and previous content revised by Jim Taylor. The chapter was revised for OpenOffice.org 2.0 by Linda Worthington, Daniel Carrera, Jean Hollis Weber, and Agnes Belzunce, and later translated into German by Wolfgang Uhlig. The German revisions were then translated into English and updated for OpenOffice 3.3 by Martin Fox. Other contributors included Hazel Russman, Gary Schnabl, and Claire Wood.

Publication date and software version
Published 7 October 2014. Based on LibreOffice 4.3.

Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>menu selection</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click or right-click depending on computer setup</td>
<td>Opens a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+⌘+F5</td>
<td>Opens the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Opens the Styles and Formatting window</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
Contents

Copyright ........................................................................................................................................... 2
  Contributors ................................................................................................................................. 2
  Feedback ....................................................................................................................................... 2
  Acknowledgments .......................................................................................................................... 2
  Publication date and software version ......................................................................................... 2

Note for Mac users ......................................................................................................................... 2

Introduction ....................................................................................................................................... 1

Selecting objects .............................................................................................................................. 1
  Direct selection .............................................................................................................................. 1
  Selection by framing ...................................................................................................................... 1
  Selecting hidden objects ............................................................................................................... 1
  Arranging objects ......................................................................................................................... 2

Positioning and adjusting objects .................................................................................................. 2
  Using zoom ..................................................................................................................................... 2
  Status bar ....................................................................................................................................... 3
  Zoom layout dialog ....................................................................................................................... 3
  Zoom toolbar .................................................................................................................................. 4
  Moving and adjusting object size ................................................................................................. 5
  Moving objects .............................................................................................................................. 5
  Adjusting object size ...................................................................................................................... 5
  Modifying arcs ............................................................................................................................... 5
  Rotating and slanting objects ......................................................................................................... 6
  Rotating objects ............................................................................................................................ 6
  Slanting objects ............................................................................................................................. 7
  Setting exact size and position ....................................................................................................... 7
  Position and Size ............................................................................................................................ 9
  Rotating objects ............................................................................................................................ 9
  Slant and corner radius ................................................................................................................... 10

Using grid and snap functions ....................................................................................................... 11
  Configuring grid and snap functions ............................................................................................ 11
  Snap to grid ..................................................................................................................................... 13
  Using Snap to Grid ......................................................................................................................... 13
  Displaying grid .............................................................................................................................. 13
  Changing color of grid points ........................................................................................................ 14
  Snap points and lines ..................................................................................................................... 14
    Inserting snap points and snap lines ............................................................................................ 14
    Inserting snap lines using rulers .................................................................................................. 14
    Displaying snap points and lines ................................................................................................. 15
    Editing snap points and lines ....................................................................................................... 15
    Deleting snap points and lines .................................................................................................... 15
    Configuring snap range ............................................................................................................... 15

Using guide lines ............................................................................................................................ 15

Changing form of regular shapes .................................................................................................... 16
  Basic shapes .................................................................................................................................... 16
  Symbol shapes ............................................................................................................................... 16
Introduction

This chapter looks at the tools and functions that let you modify existing drawings. All of the functions apply to a selected object or a group of selected objects, which can be distinguished by selection handles on a rectangular frame that is large enough to contain the object. Where several objects are selected, the frame around the objects corresponds to the smallest rectangle that can contain all of the objects. This frame is called the selection rectangle.

Note

The color and shape of the selection handles will change depending on the tool and function that has been selected to change the object properties. The color of the selection handles also depends on the computer operating system and how the computer has been set up.

Selecting objects

Direct selection

The easiest way to select an object is to click directly on it. For objects that are not filled, click on the object outline to select it. One click selects; a second click deselects. To select or deselect more than one object, hold the Shift key down while clicking.

Selection by framing

You can also select several objects at once by dragging the mouse cursor around the objects. This draws a rectangle around the objects, and only objects that lie entirely within the rectangle will be selected.

To select multiple objects by framing, the Select icon on the Drawing toolbar must be active.

Note

When you drag the mouse cursor to select multiple objects, the selection rectangle being drawn is also known as a marquee.

Selecting hidden objects

If objects are located behind others and not visible, they can still be selected.

• For computers using a Windows or Mac operating system. Select the object in front of the hidden objects, then press the Alt key and click to select the hidden object. If there are several hidden objects, keep holding down the Alt key and clicking until you reach the object you want. To cycle through the objects in reverse order, hold down the Alt+Shift keys and click.

• For computers using a Linux operating system. Press the Tab key to cycle selection through the objects in your drawing, stopping at the hidden object you want to select. To cycle through the objects in reverse order, press Shift+Tab. This is a very quick way to reach an object, but it may not be practical if there a large number of objects in a drawing.

When you select a hidden object, its selection handles will appear through the objects covering it.
**Arranging objects**

In a complex drawing, several objects may be stacked on top of one another. To rearrange the stacking order by moving an object forward or backward using one of the following methods:

- Select an object, go to **Modify > Arrange** on the main menu bar, or right-click on the object and select **Arrange**, then select one of the following:
  - **Bring to Front**
  - **Bring Forward**
  - **Send Backward**
  - **Send to Back**
  - **In Front of Object**
  - **Behind Object**

- Select an object, then use one of the following keyboard shortcuts:
  - `Ctrl+Shift++` (bring to front)
  - `Ctrl++` (bring forward)
  - `Ctrl+-` (send backward)
  - `Ctrl+Shift+-` (send to back)

- Select an object, then click on the small triangle to the right of the **Arrange** icon on the Line and Filling toolbar to open the Position toolbar, giving access to the arrangement options as shown in Figure 1.

![](Figure_1.png)

**Figure 1**: Position toolbar

---

**Positioning and adjusting objects**

**Using zoom**

To help in the positioning and adjustment of objects, Draw has a zoom function that reduces or enlarges the screen display of the current drawing. For example, zoom in to place objects onto your drawing with greater position; zoom out to see the complete drawing. You can control zooming three ways: from the Status bar, Zoom dialog, or Zoom toolbar.

<table>
<thead>
<tr>
<th>Note</th>
<th>Zooming is handled differently on Linux and Windows operating systems. A document saved with a 100% zoom factor in Windows is displayed at a larger zoom factor in Linux.</th>
</tr>
</thead>
</table>

---
**Status bar**

The zoom controls are located on the right side of the status bar (Figure 2); these controls give you quick and easy access to zooming.

- Click on the minus sign to reduce the zoom factor.
- Click on the plus sign to increase the zoom factor.
- Click and hold on the slide control and move it to increase or decrease the zoom factor.
- Right-click on the zoom percentage number and select a zoom factor from the context menu that opens.
- Double-click on the zoom percentage number and select a zoom factor from the Zoom & View Layout dialog (Figure 3) that opens.

**Zoom layout dialog**

Go to View > Zoom > Zoom on the main menu bar or double-click on the zoom percentage figure on the Status bar (Figure 2) to open the Zoom & View Layout dialog (Figure 3), where you can increase or reduce the zoom factor. The current zoom percentage is displayed on the Status bar.

**Zoom factor**

Sets the zoom factor at which to display the current document and all documents of the same type that you open thereafter.

- **Optimal** – resizes the display to fit the width of the text in the document.
- **Fit width and height** – displays the entire page on your screen.
- **Fit width** – displays the complete width of the document page. The top and bottom edges of the page may not be visible.
- **100%** – displays the document at its actual size.
- **Variable** – enter a percentage in the box for the zoom factor at which you want to display the document.

**View layout**

For text documents, you can set the view layout. Reduce the zoom factor to see the effects of different view layout settings.

- **Automatic** – automatic view layout displays pages side by side, as many as the zoom factor allows.
• **Single page** – single page view layout displays pages beneath each other, but never side by side.
• **Columns** – in columns view layout you see pages in a given number of columns side by side. Enter the number of columns.
• **Book mode** – in book mode view layout you see two pages side by side as in an open book. The first page is a right page with an odd page number.

**Zoom toolbar**

Go to View > Toolbars > Zoom to open the **Zoom** toolbar (Figure 4). The tools on this toolbar are as follows:

• **Zoom In** – displays the slide at two times its current size. Click once on the tool, then move the cursor onto the object and click again. You can also select the **Zoom In** tool and drag a rectangular frame around the area you want to enlarge.
• **Zoom Out** – displays the drawing at half its current size each time the tool is clicked.
• **Zoom 100%** – displays the drawing at its actual size.
• **Zoom Previous** – returns the display of the drawing to the previous zoom factor you applied. You can also use the keyboard shortcut Ctrl +, (Comma).
• **Zoom Next** – undoes the action of the **Previous Zoom** command. You can also the keyboard shortcut Ctrl +. (Period).
• **Zoom Page** – displays the whole drawing on your screen.
• **Zoom Page Width** – displays the complete width of the drawing. The top and bottom edges of the slide may not be visible.
• **Optimal** – resizes the display to include all of the objects on the slide.
• **Object Zoom** – resizes the display to fit the object(s) you selected.
• **Shift** – moves the drawing within the Draw workspace. Place the cursor on the drawing and drag to move the drawing. When you release the cursor, the last tool you used is automatically selected.

![Figure 4: Zoom toolbar](image-url)
Moving and adjusting object size

When moving an object or changing its size, check the left-hand area of the status bar at the bottom of the Draw window (Figure 5). From left to right, this area shows what object is selected, its position on the drawing in X/Y coordinates and dimensions of the object. The units of measurement are those selected in Tools > Options > LibreOffice Draw > General.

Moving objects
To move an object (or a group of objects), select it and then click within the object borders and hold down the left mouse button while dragging the mouse. During movement, a ghost image of the object appears to help with repositioning. When the object reaches its new location, release the mouse button.

Adjusting object size
To change the size of a selected object (or a group of selected objects), move the cursor to one of the selection handles. The cursor will change shape to indicate the direction of movement for that selection handle. As you change the size of the object, a ghosted image of the object appears. When you have reached the desired size of the object, release the mouse button.

The results depend on which selection handle you use. To resize an object along one axis, use a selection handle on one of the sides. To resize along both axes, use a corner selection handle.

Note
If you press the *Shift* key while resizing an object, the change in size will be carried out symmetrically with respect to the two axes so that the aspect ratio of the object remains the same. This *Shift* key behavior works on all selection handles.

This is the default behavior of the *Shift* key. However, if *When creating or moving objects* has been selected in Tools > Options > LibreOffice Draw > Grid, the action of the *Shift* key is reversed: that is the aspect ratio will be preserved unless the *Shift* key is pressed.

Modifying arcs
The size of an arc can be changed by adjusting the positions of the start and end points of an arc.

Select an arc and click on the Points icon on the Drawing toolbar. Two handles appear at the start and end of the arc (Figure 6). The start point of the arc is indicated by the larger of the two handles.
Click on one of these handles and drag it to a new position to change the shape of the arc. Also, when click on one of these handles, a control point appears and the end of a dashed line. Click on the end of this control point to also adjust the shape of the arc.

**Rotating and slanting objects**

**Rotating objects**

To rotate an object (or a group of objects), select the object, then go to rotation mode using one of the following methods:

- Click on the Rotate icon on the Line and Filling toolbar.
- Go to View > Toolbars > Mode on the main menu bar and select the Rotate icon on the Mode toolbar.

The selection handles will change shape and color (Figure 7). Also a center of rotation indicator will appear in the center of the object. As you move the cursor over the handles, the cursor changes shape. The corner handles are for rotating the object, and the top, bottom and side handles are to shear or slant the object.

Move the cursor to one of the corner handles, then click and hold the mouse button and start to move the cursor to rotate the object. A ghosted outline of the object being rotated appears and the current angle of rotation is shown in the status bar.

**Note**  
Rotation works in a slightly different way for 3D objects because it occurs in a three dimensional space and not in a single plane. See Chapter 7 Working with 3D Objects for more information.

The rotation center is normally located at the center of an object. To change the position of the rotation center, click on the rotation center and drag until it is at the desired position. This rotation center can even be outside of the object.
If you press the Shift key while rotating an object, rotation will be restricted to 15° of movement.

This is the default behavior of the Shift key. However, if When creating or moving objects has been selected in Tools > Options > LibreOffice Draw > Grid, the action of the Shift key is reversed: that is rotation will be restricted to 15° of movement unless the Shift key is pressed.

**Slanting objects**

To slant an object, click on the Rotate icon, then use the handles located at the midpoints on the top, bottom and sides of a selected object. The cursor changes shape when it hovers over one of these midpoint handles indicating the direction of slanting. The axis used for slanting an object is the object edge directly opposite the midpoint handle being used to slant the object. This axis stays fixed in location while the other sides of the object move in relation to it as you drag the mouse cursor. Figure 8 shows a rectangle slanted using the selection handle at the top of the object.

Click and hold the mouse button, then start to move the cursor to slant the object. A ghosted outline of the object being slanted appears and the current angle of slanting is shown in the status bar.

![Figure 8: Slanting objects](image)

If you press the Shift key while slanting an object, slanting will be restricted to 15° of movement.

This is the default behavior of the Shift key. However, if When creating or moving objects has been selected in Tools > Options > LibreOffice Draw > Grid, the action of the Shift key is reversed: that is slanting will be restricted to 15° of movement unless the Shift key is pressed.

### Setting exact size and position

You can position and resize objects with the mouse, but this method is not exact. If you want to accurately position and size an object, you have to use the Position and Size dialog (Figure 9) or the Position and Size subsection (Figure 10) on the Sidebar.

- To open the Position and Size dialog, select the object, then go to Format > Position and Size on the main menu bar, or right-click on an object and select Position and Size from the context menu, or press the F4 key.
- To open the Position and Size subsection on the Sidebar, select the object, then click on the Properties icon on the Sidebar and click on the plus sign (+) next to the Position and Size title bar to open the subsection.

The options available in the Position and size dialog and the Position and Size subsection are similar. On the Sidebar, you cannot protect the position and size of an object or adapt an object to fit any text or set the base point position for position and size.
Figure 9: Position and Size dialog

Figure 10: Position and Size on the Sidebar
**Position and Size**

- **Position** – specify the location of the selected object on the page.
  - *Position X* – enter the horizontal distance that you want to move the object relative to the base point selected in the grid.
  - *Position Y* – enter the vertical distance that you want to move the object relative to the base point selected in the grid.
  - *Base point* – select a base point in the grid and then enter the amount that you want to shift the object relative to the base point that you selected in the *Position Y* and *Position X* boxes. The base points correspond to the selection handles on an object. This option is only available in the Position and Size dialog.

- **Size** – specify the amount by which you want to resize the selected object with respect to the selected base point.
  - *Width* – enter a width for the selected object.
  - *Height* – enter a height for the selected object.
  - *Keep ratio* – maintains proportions when you resize the selected object.
  - *Base point* – select a base point in the grid, and then enter the new size dimensions for the selected object in the *Width* and *Height* boxes. This option is only available in the Position and Size dialog.

- **Protect** – this option is only available in the Position and Size dialog.
  - *Position* – prevents changes to the position or the size of the selected object.
  - *Size* – prevents you from resizing the object.

- **Adapt** – specifies, if the size of a drawing object should be adjusted to fit the size of entered text. This option is only available in the Position and Size dialog.
  - *Fit width to text* – expands the width of the object to the width of the text, if the object is smaller than the text.
  - *Fit height to text* – expands the height of the object to the height of the text, if the object is smaller than the text.

The units of measurement used for X/Y coordinates and the width and height of the object are set by going to **Tools > Options > LibreOffice Draw > General**.

The default location of the base points for position and size is the upper left corner of the drawing area. You can temporarily change this base point to make positioning or dimensioning simpler by clicking on a position corresponding to the location of the base point you want to use. This change in base point is only valid for single use and the base point is reset to the standard position of top left corner when you close the Position and Size dialog.

**Rotating objects**

To accurately rotate an object, click on the *Rotation* tab of the Position and Size dialog (Figure 11). Use this dialog to define the rotation angle and the location of the pivot point. Alternatively, use the available options on the *Position and Size* subsection (Figure 10) on the Sidebar.

- **Pivot point** – the selected object is rotated around a pivot point that you specify. The default pivot point is at the center of the object. If you set a pivot point too far outside of the object boundaries, the object could be rotated off of the page. This option is only available in the Position and Size dialog.
  - *Position X* – enter the horizontal distance from the left edge of the page to the pivot point.
  - *Position Y* – enter the vertical distance from the top edge of the page to the pivot point.
• **Default settings** – select where you want to place the pivot point. Default position is the center of the object. Changing the rotation pivot point is only valid for single use. The pivot point is reset to default settings when you close the Position and Size dialog.

• **Rotation** – specify the number of degrees that you want to rotate the selected object, or click in the rotation grid.
  - **Angle** – enter the number of degrees that you want to rotate the selected object. This option is only available in the Position and Size dialog.
  - **Default settings** – click on the indicator to rotate the object. The number of degrees is shown in the Angle box as you rotate the indicator. This option is only available in the Position and Size dialog.
  - **Rotation** – click on the indicator to rotate the selected object, or set the angle in the text box, or select a a predetermined angle from the drop down list. This option is only available in the Position and Size subsection on the Sidebar.
  - **Flip** – flip the selected object either vertically or horizontally about its central axis. This option is only available in the Position and Size subsection on the Sidebar.

**Slant and corner radius**

To accurately set the corner radius or slant angle of an object, click on the Slant & Corner Radius tab of the Position and Size dialog (Figure 12). Options for slant and corner radius are only available in the Position and Size dialog.
• **Corner Radius** – you can only round the corners of a rectangular object. If this section is grayed out, then you cannot set a corner radius.
  - *Radius* – enter the radius of the circle that you want to use to round the corners. The larger the value for corner radius set, the rounder the corners of an object become.
• **Slant** – slants the selected object along the bottom edge of the object.
  - *Angle* – enter the angle of the slant axis. The slant angle relates to how much an object inclines or slants from its normal vertical position on a drawing.

### Using grid and snap functions

In Draw, you can also position objects accurately and consistently using grid points, snap points and lines, object frames, individual points on objects, or page edges. This function is known as *Snap*.

It is easier to use snap functions at the highest practical zoom value for your drawing. You can use two different snap functions at the same time; for example, snapping to a guide line and the page edge. However, it is recommended to activate only those snap functions that you really need.

### Configuring grid and snap functions

To configure the grid and snap functions in your drawing, go to **Tools > Options > LibreOffice Draw > Grid** to display the Grid dialog (Figure 13). The grid and snap functions can also be displayed and switched on or off using this dialog, right-clicking on your drawing and using the options in the context menu, or using the icons in the Options toolbar (Figure 14). If the Options toolbar is not open, go to **View > Toolbars > Options**.

![Figure 13: LibreOffice Draw Grid dialog](image)

![Figure 14: Options toolbar](image)
• **Grid** – specifies the settings for the configurable grid on your document pages. This grid helps you determine the exact position of your objects. You can also set this grid in line with the magnetic snap grid. If you have activated the snap grid but wish to move or create individual objects without snap positions, keep the *Shift* key pressed to deactivate this function for as long as needed.
  
  - *Snap to grid* – specifies whether to move frames, drawing elements, and controls only between grid points. To change the status of the snap grip only for the current action, drag an object while holding down the *Ctrl* key.
  
  - *Visible grid* – specifies whether to display the grid.

• **Resolution**
  
  - *Horizontal* – defines the unit of measure for the spacing between grid points on the X-axis.
  
  - *Vertical* – defines the grid points spacing in the desired unit of measurement on the Y-axis.

• **Subdivision**
  
  - *Horizontal* – specify the number of intermediate spaces between grid points on the X-axis.
  
  - *Vertical* – specify the number of intermediate spaces between grid points on the Y-axis.

• **Synchronize axes** – specifies whether to change the current grid settings symmetrically. The resolution and subdivision for the X and Y axes remain the same.

• **Snap**
  
  - *To snap lines* – snaps the edge of a dragged object to the nearest snap line when you release the mouse button. You can also define this setting by using the Snap to Snap Lines icon on the Options toolbar.
  
  - *To the page margins* – specifies whether to align the contour of the graphic object to the nearest page margin. The cursor or a contour line of the graphics object must be in the snap range. In a drawing, this function can also be accessed with the Snap to Page Margins icon in the Options toolbar.
  
  - *To object frame* – specifies whether to align the contour of the graphic object to the border of the nearest graphic object. The cursor or a contour line of the graphics object must be in the snap range. In drawing, this function can also be accessed with the Snap to Object Border icon in the Options toolbar.
  
  - *To object points* – specifies whether to align the contour of the graphic object to the points of the nearest graphic object. This only applies if the cursor or a contour line of the graphics object is in the snap range. In a drawing, this function can also be accessed with the Snap to Object Points icon in the Options toolbar.
  
  - *Snap range* – defines the snap distance between the mouse pointer and the object contour. Snaps to a snap point if the mouse pointer is closer than the distance selected.

• **Snap position**
  
  - *When creating or moving objects* – specifies that graphic objects are restricted vertically, horizontally or diagonally (45°) when creating or moving them. You can temporarily deactivate this setting by pressing the *Shift* key.
  
  - *Extend edges* – specifies that a square is created based on the longer side of a rectangle when the *Shift* key is pressed before you release the mouse button. This also

---

Working with Objects and Object Points
applies to an ellipse (a circle will be created based on the longest diameter of the ellipse). When *Extend edges* is not selected, a square or a circle will be created based on the shorter side or diameter.

- *When rotating* – specifies that graphic objects can only be rotated within the rotation angle that you selected. If you want to rotate an object outside the defined angle, press the *Shift* key when rotating. Release the key when the desired rotation angle is reached.
- *Point reduction* – defines the angle for point reduction. When working with polygons, you might find it useful to reduce their editing points.

**Snap to grid**

**Using Snap to Grid**

Use the *Snap to Grid* function to move an object exactly onto a grid point in your drawing. This function can be switched on and off using one of three methods:

- Go to *View > Grid > Snap to Grid*.
- Right-click on your drawing and selecting *Snap to Grid* from the context menu.
- Click on the *Snap to Grid* icon on the Options toolbar.

**Displaying grid**

Displaying or turning off the grid in your drawing can be done using one of four methods:

- Go to *View > Grid > Display Grid*.
- Click on the *Display Grid* icon on the Options toolbar.
- Right-click on your drawing and select *Display Grid* from the context menu.
- Selecting *Visible grid* option in the Grid dialog (Figure 13 on page 15).

![Figure 15: LibreOffice Appearance dialog](image-url)
Changing color of grid points
By default the grid points are gray and, depending on you display and computer setup, are not always easy to see. To change the color of the grid points, go to **Tools > Options > LibreOffice > Appearance** to open the Appearance dialog (Figure 15). In the **Drawing/Presentation** section, select a more suitable color from the drop-down list.

Snap points and lines
Unlike the grid, snap lines and snap points are inserted by you when you want to position an object in a specific position on your drawing. Snap lines can either be horizontally or vertically and appear as dashed lines. Snap points appear as small crosses with dashed lines. Snap points and snap lines do not appear in printed output.

Inserting snap points and snap lines
To insert a snap point or snap line, go to **Insert > Insert Snap Point/Line** to open the New Snap Object dialog (Figure 16).

![New Snap Object dialog](image)

**Figure 16: New Snap Object dialog**

- **Position** – sets the position of a selected snap point or line relative to the top left corner of the page.
  - **X axis** – enter the amount of space you want between the snap point or line and the left edge of the page.
  - **Y axis** – enter the amount of space you want between the snap point or line and the top edge of the page.
- **Type** – specifies the type of snap object you want to insert.
  - **Point** – inserts a snap point.
  - **Vertical** – inserts a vertical snap line.
  - **Horizontal** – inserts a horizontal snap line.

Inserting snap lines using rulers
Snap lines, but not snap points, can be inserted using the vertical or horizontal rulers. If the rulers are not displayed, go to **Tools > Options > LibreOffice Draw > View** and select **Rulers visible**. To insert a snap line, move the cursor to a ruler, then click and drag a snap line to the required position.
**Displaying snap points and lines**
Displaying or turning off snap points and lines in your drawing can be done using one of these methods:

- Go to View > Grid > Display Snap Lines on the main menu bar.
- Click on the Display Snap Lines icon on the Options toolbar.
- Right-click on your drawing and select Display Snap Lines from the context menu.

**Editing snap points and lines**
To edit a snap point, right-click on the snap point and select Edit Snap Point from the context menu to open the New Snap Object dialog or drag it to a new position on your drawing.

To edit a snap line, right-click on the snap line and select Edit Snap Line from the context menu to open the New Snap Object dialog or drag the snap line to a new position on your drawing.

**Deleting snap points and lines**
To delete a snap point, drag it back to a ruler or right-click on the snap point and select Delete Snap Point from the context menu.

To delete a snap line, drag it back to the ruler or right-click on the snap line and select Delete Snap Line from the context menu.

**Configuring snap range**
To configure the snap range of when an object snaps to position, go to Tools > Options > LibreOffice Draw > Grid (Figure 13 on page 15) and enter the number of pixels to set the proximity of when the object will snap into position in the Snap range box. The default setting is 5 pixels.

**Using guide lines**
Guide lines (also known as help lines) are another function in Draw to help you position objects. Guide lines can be displayed while the object is being moved. They extend from the edges of the object to the rulers at the top and left side of your drawing and do not have a snap function (Figure 17).

To use guide lines, go to Tools > Options > LibreOffice Draw > View and select the Snap Lines when moving option or click the Helplines While Moving icon on the Options toolbar.
Changing form of regular shapes

When drawing certain regular shapes, one or more dots are displayed in a different color to the selection handles when an object is selected. When the cursor hovers over one of these dots, it changes shape. Clicking and dragging on one of these dots modifies the shape of the object. For example, you can increase the corner radius of a rounded rectangle or square, change the angles of an arc, and so on.

These dots perform different functions according to the shape selected. These functions are listed in the following sections.

Basic shapes

- Rounded rectangles and squares – use the dot to change the radius of the curve that replaces the angled corners of a rectangle or square.
- Circle pie – use the dots to change the size of the filled sector.
- Isosceles triangle – use the dot to modify the triangle type.
- Trapezoid, parallelogram, hexagon, or octagon – use the dot to change the angle between the sides.
- Cross – use the dot to change the thickness of the four arms of the cross.
- Ring – use the dot to change the internal diameter of the ring.
- Block arc – use the dot to change both internal diameter and size of the filled area.
- Cylinder and cube – use the dot to change the perspective.
- Folded corner – use the dot to change the size of the folded corner.
- Frame – use the dot to change the thickness of the frame.

Symbol shapes

- Smiley face – use the dot to change the smile on the face.
- Sun, moon, heart – use the dot to change the shape of the symbol.
- Prohibited symbol – use the dot to change the thickness of the ring and the diagonal bar.
- Double bracket, left bracket, right bracket, double brace – use the dot to change the curvature of the bracket.
- Left brace, right brace – use the dots to change the curvature of the brace and the position of the point.
- Square bevel, octagon bevel, diamond bevel – use the dot to change the thickness of the bevel.

Block arrows

- Arrows – use the dot to change the shape and thickness of the arrows.
- Pentagon, chevron – use the dot to change the angle between the sides.
- Arrow callouts – use the dots to change the shape and thickness of the callouts.
- Circular arrow – use the dots to change the thickness and area of the arrow.

Callouts

- Callouts – use the dots to change the length, position and angle of the pointer.
**Stars**

- 4-point star, 8-point star, 24-point star – use the dot to change the thickness and shape of the star points.
- Vertical scroll, horizontal scroll – use the dot to change the width and shape of the scroll.
- Doorplate – use the dot to change the inward curvature of the corners.

**Curves and polygons**

**Bézier curves**

The editing of curves depends on the mathematics of Bézier curves\(^1\). Explaining Bézier curves goes beyond this scope of this chapter. See Chapter 11 Advanced Draw Techniques for more information on drawing and manipulating Bézier curves.

The editing of a Bézier curve consists in principle of moving points or tangents passing through these points. Each tangent has one control point at each end and a junction point where it meets the curve. The relative angle and distance between the control points determine the shape of the curve. Figure 18 shows what happens starting from a basic circle and changing only one point on the circle.

You can create many different shapes by moving either the junction point itself, or one or both of the round handle points at either end of the tangent. Draw offers more possibilities when you use the functions on the Edit Points toolbar.

![Figure 18: Creating different shapes by changing the tangent](image)

**Converting to curve or polygon**

Before modifying the points on an object, you must convert the object to a curve or a polygon, depending on what kind of effect you want to produce.

After selecting an object, go to Modify > Convert on the main menu bar and select either To Curve or To Polygon. Alternatively, right-click on an object and select Convert > To Curve or Convert > To Polygon from the context menu.

After converting an object to a curve or polygon, click on the Points icon on the Drawing toolbar and the Edit Points toolbar opens (Figure 19). You can also open this toolbar using View > Toolbars > Edit Points on the main menu bar.

You will notice that after the conversion, the handles located in the corners of the selection rectangle have disappeared. This behavior is normal because the handles used with the tools on the Edit Points toolbar are located along the outline or trace of the object.

---

1 Bézier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer, who developed the technique in the 1960s. The technology was intended to make modeling the surface of vehicles easier.
**Edit Points toolbar**

Open the Edit Points toolbar (Figure 19) by going to View > Toolbars > Edit Points on the main menu bar. It will then appear whenever you select an object that is a curve or polygon and the Points icon on the Drawing toolbar. Available tools on the Edit Points toolbar will depend on the object selected and which object point has been selected.

![Edit Points toolbar](image)

*Figure 19: Edit Points toolbar*

**Tangents**

Before you can use tangents on an object, you must convert the object to a curve. Go to Modify > Convert > To Curve on the main menu bar or right-click on the object and select Convert > To Curve from the context menu.

**Note**

Tangents are only used on curves. If an object has been converted to a polygon and a tangent is added, the object is automatically converted to a curve.

**Symmetric transition**

Symmetric Transition converts a corner point or a smooth point into a symmetrical point. Both control points of the corner point are aligned in parallel and have the same length. They can only be moved simultaneously and the degree of curvature is the same in both directions.

1) Convert the object to a curve and click on the selection handle where you want to place the tangent.

2) Click on the Symmetric Transition icon on the Edit Points toolbar.

3) Click and drag one of the tangent handles to change the shape of the object. Any movement of one tangent handle is carried over symmetrically to the other handle, as shown in Figure 20.
Smooth transition

Smooth Transition converts a corner point or symmetrical point into a smooth point. Both control points of the corner point are aligned in parallel, and can only be moved simultaneously. The control points may differentiate in length, allowing you to vary the degree of curvature.

1) Convert the object to a curve and click on the selection handle where you want to place the tangent.

2) Click on the Smooth Transition icon on the Edit Points toolbar so you can adjust separately the lengths on each side of a tangent to make a curve flatter or steeper.

3) Click and drag one of the tangent handles to change the shape of the object. This creates an asymmetric tangent; the curve is flatter on the longest side of the tangent (Figure 21).

Corner point

Use Corner Point to convert the selected point or points into corner points. Corner points have two movable control points, which are independent from each other. A curved line, therefore, does not go straight through a corner point, but forms a corner.

It is possible to change independently the angle on each side of a tangent using the central point of the tangent as a corner point.

1) Convert the object to a curve and click on the selection handle where you want to place the corner point.

2) Click on the Corner Point icon on the Edit Points toolbar to create a corner point at the selected point (Figure 22).

3) Click and drag the end of one of the tangents to change its angle. Each tangent can be moved independently to create spikes and troughs in curves.
Tangent rotation
You can alter the angle by which a tangent relates to curve by clicking on one of the end points of the tangent and rotating it with the cursor. As you change the angle of the tangent, the shape of the curve changes in response (Figure 23).

Points

Moving points
Move Points activates a mode in which you can move points. The cursor displays a small empty square when resting on a point. Drag that point to another location. The curve on both sides of the point follows the movement; the section of the curve between the next points changes shape.

Point at the curve between two points or within a closed curve and drag the mouse to shift the entire curve without distorting the form.

1) Make sure the object is converted to a curve.

2) Click on the Move Points icon on the Edit Points toolbar to move any of the points when an object has been converted to a curve or polygon.

3) Hover over a point until the cursor changes shape, then drag the point to create a new shape. Figure 24 illustrates how an ovoid or egg shape was created from a circle by dragging the right hand side point to the right.
Inserting points

Insert Points activates a mode in which you can insert points. You can also move points in this mode, just as in the move mode. If, however, you click on the curve between two points and move the cursor a little while holding down the mouse button, you insert a new point. The point is a smooth point and the lines to the control points are parallel and remain so when moved.

If you wish to create a corner point, you must first insert either a smooth or a symmetrical point which is then converted to a corner point by using Corner Point.

1) Make sure the object is converted to a curve.

2) Click on the Insert Points icon on the Edit Points toolbar to add an extra point to an existing curve or polygon.

3) Click on the object border at the spot where you want to insert a point. The tangent type associated with the new point depends on where the point has been added to the object border. Figure 25 shows a new point added to the top right of an ovoid shape.

Deleting points

Select a point on the border of the object, then use the Delete Points icon on the Edit Points toolbar to delete one or more selected points from the border of the object. To select several points, click on those points while holding down the Shift key. The resulting curve automatically changes shape around the remaining points. You can also delete selected points by pressing the Del key on the keyboard.

Figure 26 shows what happens when the right point was deleted from a circle. The left image is a curve with the right point deleted. The right image is a curve where points have been converted to a line (see “Converting curves or lines” on page 27) and the right point has been deleted. This forms a straight line is formed between the two points on either side of the deleted point.
Eliminating points

The Eliminate Points icon only functions on lines with multiple points. These lines are created when a curve is converted to a line using the Convert to Curve icon on the Edit Points toolbar (see “Converting curves or lines” on page 27). The process of eliminating points from a line to create a straight line is shown in Figure 27.

1) Select a line with multiple points where the points have been converted to a line.
2) Click on the Points icon on the Drawing toolbar. The Edit Points toolbar should open. If it does not open, then go to View > Toolbars > Edit Points on the main menu bar to open it.
3) Use the mouse cursor to select the point on the line that you want to eliminate. The selected point will be emphasized.
4) Make sure the **Eliminate Points** icon is active. The area around the icon becomes shaded when active. If it is not active, click on the Eliminate Points icon.

5) Accurately position the mouse cursor over the selected point, then click and start dragging the selected point. As you drag, a dotted line forms between the two neighboring points. When this dotted line appears to be a straight line between the two neighboring points, release the mouse button. The selected point is eliminated and a straight line now exists between the two neighboring points.

### Converting curves or lines

Curves and lines can be easily converted to each other using the **Convert to Curve** icon on the Edit Points toolbar. When a curve is converted to a line, a straight line is created between selected points on a curve. When a line is converted to a curve, a curve is created between selected points on a line.

1) Select a curve or line and then select the points on the curve or line where you want to do the conversion.

2) Click on the **Convert to Curve** icon and a curve is converted into a line or a line is converted into a curve (Figure 28).

![Figure 28: Converting curves and lines](image)

### Splitting curves

1) Select a point on the curve.

2) Click on the **Split Curve** icon to split or cut a curve at the location of the selected point. If the object is filled, it will be emptied because the curve that represented the object border is no longer closed (Figure 29).

3) To separate a curve at several points simultaneously, keep the *Shift* key pressed down and select all of the points at which the cut should occur, then click on the **Split Curve** icon.

4) Deselect the curve, then drag and drop segments to move them away from the original curve. The point where you split the curve is now larger than the remaining points visible on the curve, except for the curve start point which is also larger than the other points.
Closing curves
1) Select an open and existing curve (Figure 30).

2) Select a point of the curve. Note that the start point of a curve is larger than the other points visible on the curve.

3) Click on the Close Bézier icon to close the curve. If the open curve was originally a closed and filled curve, then the original color will fill the curve when it is closed.

Rotating and distorting curves
1) Select the curve, then click on the Rotate icon on the Line and filling toolbar or the Mode toolbar. The points on the curve change color and shape (Figure 31).

2) Select one of the points on the curve and drag it to a new position to distort the curve. Movement will be restricted to the original border of the curve.

3) Select one of the control points at the end of the tangent line and rotate the distorted curve by dragging the cursor. The distorted curve will rotate about the center of rotation.