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Introduction

This chapter looks at the tools and functions that let you modify existing drawings. All of the 
functions apply to a selected object or a group of selected objects, which can be distinguished by 
selection handles on a rectangular frame that is large enough to contain the object. Where several 
objects are selected, the frame around the objects corresponds to the smallest rectangle that can 
contain all of the objects. This frame is called the selection rectangle.

Note

The color and shape of the selection handles will change depending on the tool and 
function that has been selected to change the object properties. The color of the 
selection handles also depends on the computer operating system and how the 
computer has been set up.

Selecting objects

Direct selection
The easiest way to select an object is to click directly on it. For objects that are not filled, click on 
the object outline to select it. One click selects; a second click deselects. To select or deselect 
more than one object, hold the Shift  key down while clicking.

Selection by framing
You can also select several objects at once by dragging the mouse cursor around the objects. This
draws a rectangle around the objects, and only objects that lie entirely within the rectangle will be 
selected. To select multiple objects by framing, the Select icon on the Drawing toolbar (Figure 1) 
must be active.

Figure 1: Drawing toolbar

Note

When you drag the mouse cursor to select multiple objects, the selection rectangle 
being drawn is also known as a marquee.

Selecting hidden objects
If objects are located behind others and not visible, they can still be selected. When you select a 
hidden object, its selection handles will appear through the objects covering it.

• Windows or Mac operating system – select the object in front of the hidden objects, then 
press the Alt  key and click to select the hidden object. If there are several hidden objects, 
keep holding down the Alt  key and clicking until you reach the object you want. To cycle 
through the objects in reverse order, hold down the Alt+Shift  keys and click.
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• Linux operating system – press the Tab  key to cycle selection through the objects in 
your drawing, stopping at the hidden object you want to select. To cycle through the objects
in reverse order, press Shift+Tab . This is a very quick way to reach an object, but it may 
not be practical if there a large number of objects in a drawing.

Arranging objects
In a complex drawing, several objects may be stacked on top of one another. You can rearrange 
the stacking order by moving an object forward or backward using one of the following methods:

• Select an object, go to Shape > Arrange on the main menu bar, or right-click on the object 
and select Arrange from the drop down menu, then select one of the following options:

• Bring to Front

• Bring Forward

• Send Backward

• Send to Back

• In Front of Object

• Behind Object

• Select an object, then use one of the following keyboard shortcuts:

• Ctrl+Shift++  (bring to front)

• Ctrl++  (bring forward)

• Ctrl+-  (send backward)

• Ctrl+Shift+-  (send to back)

• Select an object, then select one of the Arrange icons (Figure 2) on left of the Line and 
Filling toolbar on the main menu bar. When you hover the mouse cursor over one of the 
icons, its function will be indicated.

Figure 2: Arrange icons on Line and 
Filling toolbar

Positioning and adjusting objects

Using zoom
To help in the positioning and adjustment of objects, Draw has a zoom function that reduces or 
enlarges the screen display of the current drawing. For example, zoom in to place objects onto 
your drawing with greater position; zoom out to see the complete drawing. You can control 
zooming using the Status Bar, Zoom & View Layout dialog, or Zoom toolbar.

Note

Zooming is handled differently on Linux and Windows operating systems. A drawing 
saved with a 100% zoom factor in Windows is displayed at a larger zoom factor in 
Linux.
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Figure 3: Zoom controls on 
Status bar

Figure 4: Zoom & View Layout dialog

Status bar
The zoom controls are located on the right side of the Status Bar (Figure 3) and these controls 
give you quick and easy access to zooming.

• Click on the Fit slide to current window icon to fit your drawing to the open window.

• Click on the minus sign (-) to reduce the zoom factor.

• Click on the plus sign (+) to increase the zoom factor.

• Click and hold on the zoom slider and move it to increase or decrease the zoom factor.

• Right-click on the zoom percentage number and select a zoom factor from the context 
menu that opens.

• Go to View > Zoom > Zoom on the main menu bar or double-click on the zoom percentage
number and select a zoom factor from the Zoom & View Layout dialog (Figure 4).

Zoom & View Layout dialog
The Zoom & View Layout dialog (Figure 4) provides the following options to control how your 
drawing is viewed on your monitor.

• Zoom Factor – sets the zoom factor at which to display the current document and all 
documents of the same type that you open thereafter.

• Optimal – resizes the display to fit the width of the text in the document.

• Fit width and height – displays the entire page on your screen.

• Fit width – displays the complete width of the document page. The top and bottom 
edges of the page may not be visible.

• 100% – displays the document at its actual size.

• Variable – enter a percentage in the box for the zoom factor at which you want to 
display the document.
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• View Layout – used to set the view layout. Reduce the zoom factor to see the effects of 
different view layout settings.

• Automatic – automatic view layout displays pages side by side, as many as the zoom 
factor allows.

• Single page – single page view layout displays pages beneath each other, but never 
side by side.

• Columns – in columns view layout you see pages in a given number of columns side by 
side. Enter the number of columns.

• Book mode – in book mode view layout you see two pages side by side as in an open 
book. The first page is a right page with an odd page number.

Zoom toolbar
Go to View > Toolbars > Zoom on the main menu bar to open the Zoom toolbar (Figure 5). The 
tools available on this toolbar are as follows:

Figure 5: Zoom toolbar

• Zoom In – displays the slide at two times its current size. Click once on the tool, then move
the cursor onto the object and click again. You can also select the Zoom In tool and drag a 
rectangular frame around the area you want to enlarge.

• Zoom Out – displays the drawing at half its current size each time the tool is clicked.

• 100% – displays the drawing at its actual size.

• Zoom Previous – returns the display of the drawing to the previous zoom factor you 
applied. You can also use the keyboard shortcut Ctrl +,  (Comma).

• Zoom Next – undoes the action of the Previous Zoom command. You can also the 
keyboard shortcut Ctrl +.  (period).

• Entire Page – displays the whole drawing on your screen.

• Page Width – displays the complete width of the drawing. The top and bottom edges of the
slide may not be visible.

• Optimal – resizes the display to include all of the objects on the slide.

• Object Zoom – resizes the display to fit the object(s) you selected.
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• Zoom & Pan – zooms in for each mouse click. Ctrl+click  zooms out for each click. 
Shift+click  lets you move (pan) around the drawing.

• Shift – moves the drawing within the Draw workspace. Place the cursor on the drawing and
drag to move the drawing. When you release the cursor, the last tool you used is 
automatically selected.

Moving and adjusting object size
When moving an object or changing its size, check the left-hand area of the Status Bar at the 
bottom of the Draw workspace (Figure 6). From left to right, this area shows that a shape is 
selected, its position on the drawing in X/Y coordinates and dimensions of the object. The units of 
measurement are those selected in Tools > Options > LibreOffice Draw > General on the main 
menu bar.

Figure 6: Left end of Status Bar when working with objects

Moving objects
To move an object (or a group of objects), select it and then click within the object borders and hold
down the left mouse button while dragging the mouse. During movement, a ghost image of the 
object appears to help with repositioning (Figure 7). When the object reaches its new location, 
release the mouse button.

Figure 7: Moving objects

Adjusting object size
To change the size of a selected object (or a group of selected objects), move the mouse cursor to 
one of the selection handles. The mouse cursor will change shape to indicate the direction of 
movement for that selection handle. As you change the size of the object, a ghosted outline of the 
object appears (Figure 8). When you have reached the desired size of the object, release the 
mouse button.

The results depend on which selection handle you use. To resize an object along one axis, use a 
side, top, or bottom handle. To resize along both axes, use a corner handle.
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Figure 8: Adjusting object size

Note

If you press the Shift  key while resizing an object, the change in size will be carried 
out symmetrically with respect to the two axes so that the aspect ratio of the object 
remains the same. This Shift  key behavior works on all selection handles.

This is the default behavior of the Shift  key. However, if When creating or moving 
objects has been selected in the Constrain Objects section of Tools > Options > 
LibreOffice Draw > Grid, the action of the Shift  key is reversed and the aspect ratio 
will be preserved unless the Shift  key is pressed.

Modifying arcs
The size of an arc can be changed by adjusting the positions of the start and end points of an arc. 
Select an arc, then right click on the arc and select Points from the drop down menu or press the 
F8  key. Two handles appear at the start and end of the arc (Figure 9). Click on one of these 
handles and drag it to a new position to change the shape of the arc.

Figure 9: Modifying arcs

Rotating and slanting objects

Rotating objects
To rotate an object (or a group of objects), select the object, then go to rotation mode using one of 
the following methods:

• Click on the triangle on the right of the Transformations icon on the Line and Filling 
toolbar and select the Rotate icon from the pop up menu. The Transformations icon 
displayed on the Line and Filling toolbar will be the last transformations tool used.

• Go to View > Toolbars > Transformations on the main menu bar and select the Rotate 
icon on the Transformations toolbar (Figure 10).
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Figure 10: Transformations 
toolbar

Figure 11: Rotating objects

The object selection handles will change shape and color (Figure 11). Also a center of rotation 
indicator will appear in the center of the object. As you move the cursor over the handles, the 
cursor changes shape. The corner handles are for rotating the object, and the top, bottom and side
handles are to shear or slant the object.

The rotation center is normally located at the center of an object. To change the position of the 
rotation center, click on the rotation center and drag until it is at the desired position. This rotation 
center can even be outside of the object.

Note

Rotation works in a slightly different way for 3D objects because it occurs in a three 
dimensional space and not in a single plane. See Chapter 7 Working with 3D Objects 
for more information.

Note

If you press the Shift  key while rotating an object, rotation will be restricted to 15° of 
movement.

This is the default behavior of the Shift  key. However, if When creating or moving 
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the action 
of the Shift  key is reversed: that is rotation will be restricted to 15° of movement 
unless the Shift  key is pressed.
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Figure 12: Slanting objects

Slanting objects
To slant an object, select the object and click on the Rotate icon (see “Rotating objects” above), 
then use the handles located at the midpoints on the top, bottom and sides of a selected object. 
The cursor changes shape when it hovers over one of these midpoint handles indicating the 
direction of slanting.

The axis used for slanting an object is the object edge directly opposite the midpoint handle being 
used to slant the object. This axis stays fixed in location while the other sides of the object move in 
relation to it as you drag the mouse cursor (Figure 12).

Click and hold the mouse button, then start to move the cursor to slant the object. A ghosted 
outline of the object being slanted appears and the current angle of slanting is shown in the status 
bar.

Note

If you press the Shift  key while slanting an object, slanting will be restricted to 15° of 
movement.

This is the default behavior of the Shift  key. However, if When creating or moving 
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the action 
of the Shift  key is reversed: that is rotation will be restricted to 15° of movement 
unless the Shift  key is pressed.

Setting exact position, size, rotation and slant
You can position and resize objects with the mouse, but this method is not exact. If you want to 
accurately position and size an object, you have to use the Position and Size dialog (Figure 13) or
the Position and Size section (Figure 14) in the Properties deck on the Sidebar.

• To open the Position and Size dialog, select the object, then go to Format > Position and
Size on the main menu bar, or right-click on the object and select Position and Size from 
the context menu, or press the F4  key.

• To open the Position and Size section in the Properties deck on the Sidebar, select the 
object, then click on the Properties icon on the Sidebar and click on the down arrow next to
the Position and Size title bar to open the section.

The options available in the Position and Size dialog and Position and Size section in the 
Properties deck on the Sidebar are similar. However, on the Sidebar, you cannot protect the 
position and size of an object or adapt an object to fit any text or set the base point position for 
position and size.
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Figure 13: Position and Size dialog

Figure 14: Position and Size section
in Properties deck on Sidebar

Position and Size
• Position – specify the location of the selected object on the page.

• Position X – enter the horizontal distance that you want to move the object relative to 
the base point selected in the grid.
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• Position Y – enter the vertical distance that you want to move the object relative to the 
base point selected in the grid.

• Base point – select a base point in the grid and then enter the amount that you want to 
shift the object relative to the base point that you selected in the Position Y and Position
X boxes. The base points correspond to the selection handles on an object. This option 
is only available in the Position and Size dialog (Figure 13 on page 13).

• Size – specify the amount by which you want to resize the selected object with respect to 
the selected base point.

• Width – enter a width for the selected object.

• Height – enter a height for the selected object.

• Keep ratio – maintains proportions when you resize the selected object.

• Base point – select a base point in the grid, and then enter the new size dimensions for 
the selected object in the Width and Height boxes. This option is only available in the 
Position and Size dialog.

• Protect – this option is only available in the Position and Size dialog.

• Position – prevents changes to the position or the size of the selected object.

• Size – prevents you from resizing the object.

• Adapt – specifies, if the size of a drawing object should be adjusted to fit the size of 
entered text. This option is only available in the Position and Size dialog.

• Fit width to text – expands the width of the object to the width of the text, if the object is 
smaller than the text.

• Fit height to text – expands the height of the object to the height of the text, if the object 
is smaller than the text.

The units of measurement used for X//Y coordinates and the width and height of the object are set 
by going to Tools > Options > LibreOffice Draw > General.

The default location of the base points for position and size is the upper left corner of the drawing 
area. You can temporarily change this base point to make positioning or dimensioning simpler by 
clicking on a position corresponding to the location of the base point you want to use. This change 
in base point is only valid for single use and the base point is reset to the standard position of top 
left corner when you close the Position and Size dialog (Figure 13 on page 13).

Rotating objects
To accurately rotate an object, click on the Rotation tab of the Position and Size dialog (Figure
15). Use this dialog to define the rotation angle and the location of the pivot point. Alternatively, use
the available options on the Position and Size section (Figure 14 on page 13) in the Properties 
deck on the Sidebar.

• Pivot point – the selected object is rotated around a pivot point that you specify. The 
default pivot point is at the center of the object. If you set a pivot point too far outside of the 
object boundaries, the object could be rotated off of the page. This option is only available 
in the Position and Size dialog (Figure 15).

• Position X – enter horizontal distance from the left edge of the page to the pivot point.

• Position Y – enter vertical distance from the top edge of the page to the pivot point.

• Default settings – select where you want to place the pivot point. Default position is the 
center of the object. Changing the rotation pivot point is only valid for single use. The 
pivot point is reset to default settings when you close the Position and Size dialog 
(Figure 15).
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Figure 15: Position and Size dialog - Rotation page

• Rotation – specify the number of degrees that you want to rotate the selected object, or 
click in the rotation grid.

• Angle – enter the number of degrees that you want to rotate the selected object. This 
option is only available in the Position and Size dialog.

• Default settings – click on the indicator to rotate the object. The number of degrees is 
shown in the Angle box as you rotate the indicator. This option is only available in the 
Position and Size dialog (Figure 15).

• Rotation – click on the indicator to rotate the selected object, or set the angle in the text 
box, or select a predetermined angle from the drop down list. This option is only 
available in the Position and Size section (Figure 14 on page 13) in the Properties 
deck on the Sidebar.

• Flip – flip the selected object either vertically or horizontally about its central axis. This 
option is only available in the Position and Size section (Figure 14 on page 13) in the 
Properties deck on the Sidebar.

Slant and corner radius
To accurately set the corner radius or slant angle of an object, click on the Slant & Corner Radius 
tab of the Position and Size dialog (Figure 16). Options for slant and corner radius are only 
available in the Position and Size dialog.

• Corner Radius – you can only round the corners of a rectangular object. If this section is 
grayed out, then you cannot set a corner radius.

• Radius – enter the radius of the circle that you want to use to round the corners. The 
larger the value for corner radius set, the rounder the corners of an object become.

• Slant – slants the selected object along the bottom edge of the object.

• Angle – enter the angle of the slant axis. The slant angle relates to how much an object 
inclines or slants from its normal vertical position on a drawing.
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Figure 16: Position and Size dialog - Slant & Corner 
Radius page

• Control Point 1 and 2 – enter a value to set the X and Y coordinates of the top left corner 
of the object. If these sections are grayed out, then you cannot set any coordinates.

Using grid and snap functions

In Draw, you can also position objects accurately and consistently using grid points, snap points 
and lines, object frames, individual points on objects, or page edges. This function is known as 
Snap.

It is easier to use snap functions at the highest practical zoom value for your drawing. You can use 
two different snap functions at the same time. For example, snapping to a guide line and the page 
edge. However, it is recommended to activate only those snap functions that you really need.

Configuring grid and snap functions
To configure the grid and snap functions in your drawing, go to Tools > Options > LibreOffice 
Draw > Grid on the main menu bar to display the Grid dialog (Figure 17). The grid and snap 
functions can also be displayed and switched on or off using this dialog, right-clicking on your 
drawing and using the options in the context menu, or using the icons in the Options toolbar 
(Figure 18). If the Options toolbar is not open, go to View > Toolbars > Options on the main 
menu bar.

Figure 17: LibreOffice Draw Grid and Snap options
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Figure 18: Options toolbar

• Grid – specifies the settings for the configurable grid on your document pages. This grid 
helps you determine the exact position of your objects. You can also set this grid in line with
the magnetic snap grid. If you have activated the snap grid but wish to move or create 
individual objects without snap positions, keep the Shift  key pressed to deactivate this 
function for as long as needed.

• Snap to grid – specifies whether to move frames, drawing elements, and controls only 
between grid points. To change the status of the snap grip only for the current action, 
drag an object while holding down the Ctrl  key.

• Visible grid – specifies whether to display the grid.

• Resolution

• Horizontal – defines the unit of measure for the spacing between grid points on the 
X-axis.

• Vertical – defines the grid points spacing in the desired unit of measurement on the 
Y-axis.

• Subdivision

• Horizontal – specify the number of intermediate spaces between grid points on the 
X-axis.

• Vertical – specify the number of intermediate spaces between grid points on the Y-axis.

• Synchronize axes – specifies whether to change the current grid settings symmetrically. 
The resolution and subdivision for the X and Y axes remain the same.

• Snap

• To snap lines – snaps the edge of a dragged object to the nearest snap line when you 
release the mouse button. You can also define this setting by using the Snap to Snap 
Guides icon on the Options toolbar.

• To the page margins – specifies whether to align the contour of the graphic object to the
nearest page margin. The cursor or a contour line of the graphics object must be in the 
snap range. In a drawing, this function can also be accessed with the Snap to Page 
Margins icon in the Options toolbar.
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• To object frame – specifies whether to align the contour of the graphic object to the 
border of the nearest graphic object. The cursor or a contour line of the graphics object 
must be in the snap range. In drawing, this function can also be accessed with the 
Snap to Object Border icon in the Options toolbar.

• To object points – specifies whether to align the contour of the graphic object to the 
points of the nearest graphic object. This only applies if the cursor or a contour line of 
the graphics object is in the snap range. In a drawing, this function can also be 
accessed with the Snap to Object Points icon in the Options toolbar.

• Snap range – defines the snap distance between the mouse pointer and the object 
contour. Snaps to a snap point if the mouse pointer is closer than the distance selected.

• Constrain Objects

• When creating or moving objects – specifies that graphic objects are restricted 
vertically, horizontally or diagonally (45°) when creating or moving them. You can 
temporarily deactivate this setting by pressing the Shift  key.

• Extend edges – specifies that a square is created based on the longer side of a 
rectangle when the Shift  key is pressed before you release the mouse button. This 
also applies to an ellipse (a circle will be created based on the longest diameter of the 
ellipse). When Extend edges is not selected, a square or a circle will be created based 
on the shorter side or diameter.

• When rotating – specifies that graphic objects can only be rotated within the rotation 
angle that you selected. If you want to rotate an object outside the defined angle, press 
the Shift  key when rotating. Release the key when the desired rotation angle is 
reached.

• Point reduction – defines the angle for point reduction. When working with polygons, 
you might find it useful to reduce their editing points.

Snap to grid

Using Snap to Grid
Use the Snap to Grid function to move an object exactly onto a grid point in your drawing. This 
function can be switched on and off using one of the following methods:

• Go to View > Snap Guides > Snap to Grid on the main menu bar.

• Right-click on your drawing and selecting Snap Guides > Snap to Grid from the context 
menu.

• Click on the Snap to Grid icon on the Options toolbar.

Displaying grid
Displaying or turning off the grid in your drawing can be done using one of the following methods:

• Go to View > Grid and Helplines > Display Grid on the main menu bar.

• Click on the Display Grid icon on the Options toolbar.

• Right-click on your drawing and select Grid and Helplines > Display Grid from the context
menu.

• Selecting Visible grid option in the LibreOffice Draw Grid dialog (Figure 17 on page 16).
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Figure 19: LibreOffice Application Colors dialog

Changing color of grid points
By default and depending on your display and computer setup, the grid points are gray and are not
always easy to see. To change the color of the grid points, go to Tools > Options > LibreOffice > 
Application Colors to open the Application Colors dialog (Figure 19). In the 
Drawing/Presentation section, select a more suitable color for the grid from the drop-down list.

Snap points and lines
Unlike the grid, snap lines and snap points are inserted by you when you want to position an object
to a specific position on your drawing. Snap lines can either be horizontally or vertically and appear
as dashed lines. Snap points appear as small crosses with dashed lines. Snap points and snap 
lines do not appear in printed output.

Inserting snap points and snap lines
To insert a snap point or snap line, go to Insert > Snap Guide on the main menu bar to open the 
New Snap Object dialog (Figure 20).

• Position – sets the position of a selected snap point or line relative to the top left corner of 
the page.

• X axis – enter the amount of space you want between the snap point or line and the left 
edge of the page.

• Y axis – enter the amount of space you want between the snap point or line and the top
edge of the page.
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Figure 20: New Snap Object dialog

• Type – specifies the type of snap object you want to insert.

• Point – inserts a snap point.

• Vertical – inserts a vertical snap line.

• Horizontal – inserts a horizontal snap line.

Displaying snap points and lines
Displaying or turning off snap points and lines in your drawing can be done using one of these 
methods:

• Go to View > Snap Guides > Display Snap Guides on the main menu bar.

• Click on the Display Snap Guides icon on the Options toolbar (Figure 18 on page 17).

• Right-click on your drawing and select Snap Guides > Display Snap Guides from the 
context menu.

Editing snap points and lines
To edit a snap point, right-click on the snap point and select Edit Snap Point from the context 
menu to open the Edit Snap Point dialog (Figure 21). Enter new X and Y coordinate settings for 
the snap point and click OK. Alternatively, drag a snap point to a new position on your drawing.

Figure 21: Edit Snap Point dialog

Figure 22: Edit Snap Line dialog
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To edit a snap line, right-click on the snap line and select Edit Snap Line from the context menu to
open the Edit Snap Line dialog (Figure 22). Enter a new X coordinate setting for vertical snap 
lines or a new Y coordinate setting for horizontal snap lines and click OK. Alternatively, drag a snap
line to a new position on your drawing.

Deleting snap points and lines
To delete a snap point, drag it back to a ruler or right-click on the snap point and select Delete 
Snap Point from the context menu.

To delete a snap line, drag it back to the ruler or right-click on the snap line and select Delete 
Snap Line from the context menu.

Configuring snap range
To configure the snap range of when an object snaps to position

 1) Go to Tools > Options > LibreOffice Draw > Grid on the main menu bar to open the 
Options LibreOffice Grid dialog (Figure 17 on page 16).

 2) Enter the number of pixels to set the proximity of when the object will snap into position in 
the Snap range box. The default setting is 5 pixels.

 3) Click the OK button to set the new snap range and close the dialog.

Using Helplines

Helplines are a function in Draw to help you position objects. Helplines can be displayed while the 
object is being moved. They extend from the edges of the object to the rulers at the top and left 
side of your drawing and do not have a snap function (Figure 23).

Figure 23: Helplines while moving

Figure 24: LibreOffice Draw View dialog
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To use guide lines, go to Tools > Options > LibreOffice Draw > View dialog (Figure 24) on the 
main menu bar and select Helplines when moving option or click the Helplines While Moving 
icon on the Options toolbar (Figure 16 on page 16).

Changing form of regular shapes

When drawing certain regular shapes, one or more dots are displayed in a different color to the 
selection handles when an object is selected. When the cursor hovers over one of these dots, it 
changes shape. Clicking and dragging on one of these dots modifies the shape of the object. For 
example, you can increase the corner radius of a rounded rectangle or square, change the angles 
of an arc, and so on.

These dots perform different functions according to the shape selected. The shapes with form 
changing dots and their functions are listed in the following sections.

Basic shapes
• Rounded rectangles and squares – use the dot to change the radius of the curve that 

replaces the angled corners of a rectangle or square.

• Circle pie – use the dots to change the size of the filled sector.

• Isosceles triangle – use the dot to modify the triangle type.

• Trapezoid, parallelogram, hexagon, octagon – use the dot to change the angle between the
sides.

• Cross – use the dot to change the thickness of the four arms of the cross.

• Ring – use the dot to change the internal diameter of the ring.

• Block arc – use the dot to change both internal diameter and size of the filled area.

• Cylinder, cube – use the dot to change the perspective.

• Folded corner – use the dot to change the size of the folded corner.

• Frame – use the dot to change the thickness of the frame.

Symbol shapes
• Smiley face – use the dot to change the smile on the face.

• Sun, moon, heart – use the dot to change the shape of the symbol.

• Prohibited – use the dot to change the thickness of the ring and the diagonal bar.

• Double bracket, left bracket, right bracket, double brace – use the dot to change the 
curvature of the bracket.

• Left brace, right brace – use the dots to change the curvature of the brace and the position 
of the point.

• Square bevel, octagon bevel, diamond bevel – use the dot to change the thickness of the 
bevel.

Block arrows
• Arrows – use the dot to change the shape and thickness of the arrows.

• Pentagon, chevron – use the dot to change the angle between the sides.

• Arrow callouts – use the dots to change the shape and thickness of the callouts.

• Circular arrow – use the dots to change the thickness and area of the arrow.
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Callouts
• Callouts – use the dots to change the length, position and angle of the pointer.

Stars
• 4-point star, 8-point star, 24-point star – use the dot to change the thickness and shape of 

the star points.

• Vertical scroll, horizontal scroll – use the dot to change the width and shape of the scroll.

• Doorplate – use the dot to change the inward curvature of the corners.

Curves and polygons

Bézier curves
The editing of curves depends on the mathematics of Bézier curves1. Explaining Bézier curves 
goes beyond this scope of this chapter. See Chapter 11 Advanced Draw Techniques for more 
information on drawing and manipulating Bézier curves.

The editing of a Bézier curve consists in principle of moving points or tangents passing through 
these points. Each tangent has one control point at each end and a junction point where it meets 
the curve. The relative angle and distance between the control points determine the shape of the 
curve. Figure 25 shows what happens starting from a basic square and changing only one point on
the square.

You can create many different shapes by moving either the junction point itself, or one or both of 
the round handle points at either end of the tangent. Draw offers more possibilities when you use 
the functions on the Edit Points toolbar (Figure 26).

Figure 25: Creating different shapes by 
changing the tangent

Converting to curve or polygon
Before modifying the points on an object, you must convert the object to a curve or a polygon, 
depending on what kind of effect you want to produce using one of the following methods:

• After selecting an object, go to Shape > Convert on the main menu bar and select either 
To Curve or To Polygon.

• Right click on an object and select Convert > To Curve or Convert > To Polygon from the
context menu.

1 Bézier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer, 
who developed the technique in the 1960s. The technology was intended to make modeling the surface 
of vehicles easier.
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Figure 26: Edit Points toolbar

After converting an object to a curve or polygon, use one of the following methods to edit points on 
the object:

• Go to View > Toolbars > Edit Points on the main menu bar click to open the Edit Points 
toolbar (Figure 26) and click on the Points icon.

• Right click on an object and select Points from the context menu to open the Edit Points 
toolbar.

• Select the object and press the F8  key to open the Edit Points toolbar.

You will notice that after the conversion, the handles located in the corners of the selection 
rectangle have disappeared. This behavior is normal because the handles used with the tools on 
the Edit Points toolbar are located along the outline or trace of the object.

Edit Points toolbar
After the Edit Points toolbar has been opened, each time you select an object that has been 
converted to a curve or polygon, the toolbar will appear. Each time you deselect an object that has 
been converted, the toolbar will close. Available tools on the Edit Points toolbar will depend on the
object selected and which object point has been selected.

Tangents
Before you can use tangents on an object, you must convert the object to a curve. Go to Shape > 
Convert > To Curve on the main menu bar or right-click on the object and select Convert > To 
Curve from the context menu.

Note

Tangents are only used on curves. If an object has been converted to a polygon and a 
tangent is added, the object is automatically converted to a curve.

24 | Working with Objects



Symmetric transition
Symmetric Transition converts a corner point or a smooth point into a symmetrical point. Both 
control points of the corner point are aligned in parallel and have the same length. They can only 
be moved simultaneously and the degree of curvature is the same in both directions.

 1) Convert the object to a curve and click on the selection handle where you want to place the 
tangent.

 2) Click on the Symmetric Transition icon on the Edit Points toolbar (Figure 26).

 3) Click and drag one of the tangent handles to change the shape of the object. Any 
movement of one tangent handle is carried over symmetrically to the other handle, as 
shown in Figure 27.

Figure 27: Symmetric transition

Smooth transition
Smooth Transition converts a corner point or symmetrical point into a smooth point. Both control 
points of the corner point are aligned in parallel, and can only be moved simultaneously. The 
control points may differentiate in length, allowing you to vary the degree of curvature.

 1) Convert the object to a curve and click on the selection handle where you want to place the 
tangent.

 2) Click on the Smooth Transition icon on the Edit Points toolbar (Figure 26 on page 24) so 
you can adjust separately the lengths on each side of a tangent to make a curve flatter or 
steeper. 

 3) Click and drag one of the tangent handles to change the shape of the object. This creates 
an asymmetric tangent with the curve flatter on the longest side of the tangent (Figure 28).

Figure 28: Smooth transition

Corner point
Use Corner Point to convert selected point or points into corner points. Corner points have two 
movable control points, which are independent from each other. A curved line, therefore, does not 
go straight through a corner point, but forms a corner.

It is possible to change independently the angle on each side of a tangent using the central point of
the tangent as a corner point.
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Figure 29: Corner point

 1) Convert the object to a curve and click on the selection handle where you want to place the 
corner point.

 2) Click on the Corner Point icon on the Edit Points toolbar (Figure 26 on page 24) to create 
a corner point at the selected point (Figure 29).

 3) Click and drag the end of one of the tangents to change its angle. Each tangent can be 
moved independently to create spikes and troughs in curves.

Tangent rotation
You can alter the angle by which a tangent relates to curve by clicking on one of the end points of 
the tangent and rotating it with the cursor. As you change the angle of the tangent, the shape of the
curve changes in response (Figure 30).

Figure 30: Tangent rotation

Points

Moving points
Move Points activates a mode allowing you to move points. The mouse pointer displays a small 
empty square when resting on a point. Drag that point to another location. The curve on both sides
of the point follows the movement and the section of the curve between points changes shape.

Point at the curve between two points or within a closed curve and drag the mouse to shift the 
entire curve without distorting the form.

 1) Make sure the object is converted to a curve.

 2) Click on the Move Points icon on the Edit Points toolbar to move any of the points when 
an object has been converted to a curve or polygon.

26 | Working with Objects



Figure 31: Moving points

 3) Hover over a point until the cursor changes shape, then drag the point to create a new 
shape. Figure 31 illustrates how a different shape can be created from a circle by dragging 
the left hand side point to the left.

Inserting points
Insert Points activates a mode in which you can insert points. You can also move points in this 
mode, just as in the move mode. If, however, you click on the curve between two points and move 
the cursor a little while holding down the mouse button, you insert a new point. The point is a 
smooth point and the lines to the control points are parallel and remain so when moved.

If you wish to create a corner point, you must first insert either a smooth or a symmetrical point 
which is then converted to a corner point by using Corner Point.

 1) Make sure the object is converted to a curve.

 2) Click on the Insert Points icon on the Edit Points toolbar (Figure 26 on page 24) to add an
extra point to an existing curve or polygon.

 3) Click on the object border at the spot where you want to insert a point. The tangent type 
associated with the new point depends on where the point has been added to the object 
border. Figure 32 shows a new point added to the right side of a circle then moved to 
create the shape illustrated.

Figure 32: Inserting points

Deleting points
Select a point on the border of the object, then use the Delete Points icon on the Edit Points 
toolbar (Figure 26 on page 24) to delete one or more selected points from the border of the object. 
To select several points, click on those points while holding down the Shift  key. The resulting 
curve automatically changes shape around the remaining points. You can also delete selected 
points by pressing the Del  key on the keyboard.

Figure 33 shows what happens when three points on the left were deleted from a circle. The left 
image is a curve. The right image is a curve where three points have been deleted and the result 
converted to a line (see “Converting curves or lines” on page 29). This forms a straight line is 
formed between the two points on either side of the deleted points.
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Figure 33: Deleting points

Figure 34: Eliminating points

Eliminating points
The Eliminate Points icon only functions on lines with multiple points. These lines are created 
when a curve is converted to a line using the Convert to Curve icon on the Edit Points toolbar. 
The process of eliminating points from a line to create a straight line is shown in Figure 34.

 1) Select a curve with multiple points that has been converted to a line (see “Converting 
curves or lines” on page 29).

 2) Use the mouse cursor to select the point on the line that you want to eliminate. The 
selected point will be emphasized.

 3) Click on the Eliminate Points icon on the Edit Points toolbar (Figure 26 on page 24).

 4) Accurately position the mouse cursor over the selected point, then click and start dragging 
the selected point. As you drag, a dotted line forms between the two neighboring points.

 5) When this dotted line appears to be a straight line between the two neighboring points, 
release the mouse button. The selected point is eliminated and a straight line now exists 
between the two neighboring points.
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Converting curves or lines
Curves and lines can be easily converted to each other using the Convert to Curve icon on the 
Edit Points toolbar. When a curve is converted to a line, a straight line is created between 
selected points on a curve. When a line is converted to a curve, a curve is created between 
selected points on a line.

 1) Select a curve or line and then select the points on the curve or line where you want to do 
the conversion.

 2) Click on the Convert to Curve icon on the Edit Points toolbar (Figure 26 on page 24) and 
a curve is converted into a line or a line is converted into a curve (Figure 35).

Figure 35: Converting curves or lines

Splitting curves
 1) Select the point on the curve where you want to split it. To separate a curve at several 

points simultaneously, keep the Shift  key pressed down and select all of the points where 
the cut will occur.

 2) Click on the Split Curve icon on the Edit Points toolbar (Figure 26 on page 24) to split or 
cut a curve at the location of the selected point. If the object is filled, it will be emptied 
because the curve that represented the object border is no longer closed (Figure 36).

 3) Deselect the curve, then drag and drop segments to move them away from the original 
curve.

Figure 36: Splitting curves

Note

The point where you split the curve is now larger than the remaining points visible on 
the curve, except for the curve start point which is also larger than the other points.
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Closing curves
 1) Select an open and existing curve (Figure 37).

 2) Select a point of the curve. Note that the start point of a curve is larger than the other points
visible on the curve.

 3) Click on the Close Bézier icon on the Edit Points toolbar (Figure 26 on page 24) to close 
the curve. If the open curve was originally a closed and filled curve, then the original color 
will fill the curve when it is closed.

Figure 37: Closing curves

Rotating and distorting curves
 1) Select the curve, then go to View > Toolbars > Transformations on the main menu bar to 

open the Transformations toolbar (Figure 10 on page 11) and select the Rotate icon (see  
“Rotating and slanting objects” on page 10 for more information on rotating objects).

 2) Select one of the points on the curve and drag it to a new position to distort the curve 
(Figure 38).

 3) Select one of the control points at the end of the tangent line and rotate the distorted curve 
by dragging the cursor. The distorted curve will rotate about the center of rotation.

Figure 38: Rotating and distorting curves
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