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Introduction

Draw provides several toolbars to help in creating drawings. Each toolbar has a default set of 
tools and the option to add additional tools.

Note

The icons displayed in the Draw toolbars illustrated in this appendix may differ from 
what is displayed on your computer screen. Toolbar icons depend on the computer 
operating system being used and how LibreOffice has been set up.

Using toolbars

Displaying toolbars
To display a toolbar and make it active, go to View > Toolbars on the Menu bar. A submenu 
opens with a list of available toolbars for Draw. Click on a toolbar name to make it active. Active 
toolbars are indicated by highlighting or a check mark next to the name, as shown in Figure 1.

Figure 1: Draw toolbars

Note

Some toolbars, although selected in View > Toolbars on the Menu bar, will not 
display until an object of the correct type is selected in the drawing. For example, the
Image toolbar only displays when an image is selected.

Closing toolbars
To close a toolbar, use one of the following methods:

• Go to View > Toolbars on the Menu bar and deselect the toolbar.

• Right-click on a tool on a toolbar and select Close Toolbar from the context menu.

• Click on the X in the right corner of the title bar of a floating toolbar.
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Moving toolbars

Docked toolbars

By default, some toolbars are docked into position in the Draw main window. For example, the 
Standard toolbar is docked at the top of the main window. Docked toolbars can be undocked and
moved to a new docked position on the main window or left as a floating toolbar. Before moving a
toolbar, the toolbar must be unlocked.

1) Move the mouse cursor over the small vertical handle at the left end of the toolbar. The 
mouse cursor changes to a moving cursor for the computer system and setup.

2) Click and hold down the mouse button and drag the toolbar to a new location. This can be
a new docked position or a floating toolbar. A hashed border appears around the toolbar 
indicating the toolbar position as it is dragged.

3) Release the mouse button when the required position is reached.

Floating toolbars

To move a floating toolbar, click on its title bar and drag it to a new floating location. Release the 
mouse button when the toolbar is in the requirted position. A floating toolbar does not have to be 
positioned on the Draw main window for it to function.

Docking a floating toolbar

To dock a floating toolbar, use one of the following methods:

• Click on the title bar and drag it to the top, bottom, left side, or right side of the main 
window. When the toolbar reaches a docking position, a hashed border appears at the 
docked position. Release the mouse button and the toolbar is docked.

• Right-click on the toolbar and select Dock Toolbar from the context menu. The toolbar 
moves into a docked position. If the position is not suitable, move the toolbar to a new 
docked position.

• To dock all floating toolbars that are active, right-click on the toolbar and select Dock All 
Toolbars from the context menu.

Locked toolbars

A docked toolbar can also be locked into its position on the Draw main window.

• To lock a toolbar into its docked position, right-click in a blank area on the toolbar and 
click on Lock Toolbar Position in the context menu. A check mark appears against this 
option indicating the toolbar is now locked.

• To unlock a toolbar, right-click in a blank area on the toolbar and click on Lock Toolbar 
Position in the context menu. The check mark next to this option disappears indicating 
the toolbar is now unlocked. Also, a small vertical bar appears at the left end of the 
toolbar and is used to move the toolbar.

Note

Some toolbars cannot be docked or locked into position. This is indicated by the 
options Dock Toolbar and/or Lock Toolbar Position being grayed out, making the 
options unavailable.
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Editing toolbars
When LibreOffice is installed on a computer, it includes a set of toolbars suitable for each 
LibreOffice component. Each toolbar has a default set of visible tools. You can add tools, delete 
tools, and customize toolbars.

Adding tools

1) Right-click in a blank area on a toolbar, or click on the small downward triangle ▼ on the 
right of the toolbar title bar.

2) Select Visible Buttons from the context menu to display a list of available tools.

3) Click on the tool required and the tool appears in the toolbar. The list of available tools 
closes automatically. A highlight or check mark next to the tool indicates that the tool is 
already installed on the toolbar.

Note

When adding tools using Visible Buttons, the tool is added to the toolbar at the 
same position as the tool appears in the Visible Buttons list. That is, the top tool in 
Visible Buttons appears at the left end of the toolbar; the bottom tool in Visible 
Buttons list appears at the right end of the toolbar. Tool positions cannot be changed
using Visible Buttons.

Deleting tools

1) Right-click in a blank area on a toolbar, or click on the small downward triangle ▼ on the 
right of the toolbar title bar.

2) Select Visible Buttons from the context menu to display a list of available tools.

3) Click on the tool no longer required and the tool is removed from the toolbar. The highlight
or check mark next to the tool is also removed. The list of available tools closes 
automatically.

Customizing toolbars

Extra tools and commands that are not available in Visible Buttons can be added to a toolbar 
using customization. Customization also allows the creation of new toolbars if a specific set of 
tools are required for a specific task. For information on customizing toolbars, see the Getting 
Started Guide.

Toolbars

Note

The tools installed on a toolbar are normally indicated in Visible Buttons either by 
the tool icon being highlighted or by a check mark. However, this install indication 
depends on computer setup and computer operating system being used.

Note

On some toolbars, the icons have a small downward pointing triangle ▼ to the right 
of an icon. Click on this triangle to open further options that are available for use.
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Note

Some of the tools in the toolbars also have the option of using a keyboard shortcut 
instead of clicking on the tool. For a full list of keyboard shortcuts that are available in
Draw, see Appendix A, Keyboard Shortcuts.

3D-Objects
The 3D-Objects toolbar (Figure 2) provides tools to create 3D objects in a drawing. It is activated 
either by going to View > Toolbars > 3D-Objects on the Menu bar or by clicking on 3D Objects 
on the Drawing toolbar.

Figure 2: 3D-Objects toolbar

Figure 3: 3D-Settings toolbar

3D-Settings
The 3D-Settings toolbar (Figure 3) and its tools only become active when an object has been 
converted to 3D using the tool Toggle Extrusion and the converted object is then selected. The 
following tools on this toolbar have a small downward pointing triangle ▼ on the right of the icon. 
Click on this triangle to open a drop-down menu giving access to various options as follows:
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• Depth – 3D extrusion depth – 0cm; 1cm; 2.5cm; 5cm; 10cm; Infinity; Custom. The 
measurement unit depends on the settings in Tools > Options > LibreOffice Draw > 
General.

• Direction – 3D extrusion direction and type – Parallel; Perspective.

• Lighting –  lighting direction and lighting level of 3D extrusion – Bright; Normal; Dim.

• Surface – surface type of 3D extrusion – Wire Frame; Matt; Plastic; Metal.

• 3D Color – color of 3D extrusion. Select a color from one of the available color palettes.

Align Objects
The Align Objects toolbar (Figure 4) provides tools for aligning several objects in a drawing to 
improve the visual impact of a drawing.

Figure 4: Align Objects 
toolbar

Comments
The Comments toolbar (Figure 5) provides tool for adding, deletion, and navigation of comments 
in a drawing. To use comments, it is recommended to add your name and initials in Tools > 
Options > LibreOffice > User Data so that comments can be easily identified.

Figure 5: Comments toolbar

Distribute Selection
The Distribute Selection toolbar (Figure 6) provides tools to distribute three or more selected 
objects evenly along the horizontal axis or vertical axis. Also, the spacing between objects can be
evenly distributed.
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Figure 6: Distribute Selection toolbar

Drawing
The Drawing toolbar (Figure 7) provides the majority of the tools normally used to create graphic 
objects in a drawing.

Figure 7: Drawing toolbar
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Some tool shapes on the Drawing toolbar change depending on the last tool that had previously 
been selected and used.

• Click on the small downward pointing triangle ▼ to the right of a tool to open a pop-up 
toolbar. Select the required shapeto add to a drawing.

• To create a sub-toolbar, click and drag at the top of the pop-up toolbar to an empty area 
on the main window. The sub-toolbars for each object type and the various shapes 
available are shown Figures 8 to 17.

Figure 8: Lines and Arrows sub-toolbar

Figure 9: Curves and Polygons 
sub-toolbar
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Figure 10: Connectors sub-toolbar

Figure 11: Basic Shapes sub-toolbar
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Figure 12: Symbol shapes sub-toolbar

Figure 13: Block Arrows sub-toolbar
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Figure 14: Flowchart sub-toolbar

Figure 15: Callouts sub-toolbar

Figure 16: Stars and Banners sub-toolbar
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Figure 17: 3D-Objects sub-toolbar

Edit Points
The Edit Points toolbar (Figure 18) provides tools for editing the points of a curve or an object 
that has been converted to a curve. The toolbar only becomes active when an object is selected 
and one of the following methods is used to open the toolbar:

• Click on Edit Points on the Drawing or Standard toolbar.

• Use the keyboard shortcut F8.

Figure 18: Edit Points toolbar

Find
The Find toolbar (Figure 19) opens by default in the bottom left corner of the Draw main window. 
This toolbar is normally docked at the bottom left of the Draw main window above the Status bar. 
However, it can be undocked and made into a floating toolbar.
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Figure 19: Find toolbar

Fontwork
The Fontwork toolbar (Figure 20) is used to create graphical text objects in a drawing and 
provide the tools for editing the graphical text object. This toolbar only becomes active when a 
Fontwork graphical text object in the drawing has been selected.

Some tools on the Fontwork toolbar have a small downward pointing triangle ▼ to the right of the
tool. Click on the triangle to open a pop-up toolbar or drop-down option list.

• Fontwork Shape – select the required shape for the Fontwork graphical text object from 
the options available.

• Fontwork Alignment – select the paragraph alignment from the options available.

• Fontwork Character Spacing – select the required character spacing from the options 
available.

Figure 20: Fontwork toolbar

Form Controls
The Form Controls toolbar (Figure 21) provides the tools required to create an interactive form. 
This allows controls to be added to a form in a text, drawing, spreadsheet, presentation, or HTML
document (for example a button that runs a macro).
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Figure 21: Form Controls toolbar

Figure 22: Form Design toolbar
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Form Design
The Form Design toolbar (Figure 22) opens a form in Design Mode so that it can be edited. You 
cannot activate the controls of the form or edit its contents when in Design Mode. However, you 
can change the position and size of the controls, edit other properties, and add or delete controls 
in Design Mode.

Form Navigation
The Form Navigation toolbar (Figure 23) provides tools to edit a database table or control the 
data view. The toolbar is normally displayed at the bottom of a document that contains fields that 
are linked to a database. This toolbar is only active when forms are connected to a database; an 
inactivate toolbar is shown in Figure 23.

The Form Navigation toolbar also allows movement within records as well as inserting and 
deleting records. If data is saved in a form, the changes are transferred to the database. This 
toolbar also provides tools providing sort, filter, and search functions for data records.

Figure 23: Form Navigation toolbar

Figure 24: Glue Points toolbar
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Glue Points
The Glue Points toolbar (Figure 24) provides tools to insert a glue point or modify the properties 
of a glue point. A glue point is a point where a connector is attached to an object. By default, 
LibreOffice automatically places a glue point at the center of each side of the bounding rectangle 
for every object created.

Image
The Image toolbar (Figure 25) provides tools to edit, modify, align, reposition and resize images. 
The toolbar only becomes active and available when an image is selected in a drawing. The 
Image toolbar automatically replaces the Line and Filling toolbar when it becomes active.

Figure 25: Image toolbar
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Insert
The Insert toolbar (Figure 26) provides tools to insert different types of objects into a drawing.

Figure 26: Insert toolbar

Legacy Circles and Ovals
The Legacy Circles and Ovals toolbar (Figure 27) provides tools to insert different types of circles
and ovals into a drawing.

Figure 27: Legacy Circles and Ovals toolbar
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Legacy Rectangles
The Legacy Rectangles toolbar (Figure 28) provides tools to insert different types of rectangles 
and squares into a drawing.

Figure 28: Legacy Rectangles toolbar

Line and Filling
The Line and Filling toolbar (Figure 29) provides tools and drop-down lists for editing lines, 
arrows, and object borders. The tools available vary depending on the type of object selected for 
editing.

Figure 29: Line and Filling toolbar
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Master View
The Master View toolbar (Figure 30) provides tools to create a new master page, rename a 
master page, delete a master page, and close master view. This toolbar is only active when Draw
is in master view.

Figure 30: Master View 
toolbar

Media Playback
The Media Playback toolbar (Figure 31) provides the standard tools required to insert, view, play, 
and listen to audio and video files. The toolbar only becomes active when an audio or video file is
selected. Draw supports many different media formats depending on the computer operating 
system being used. The tools available on the toolbar from left to right are as follows:

• Open – opens a movie file or a sound file.

• Play – plays the current file.

• Pause – pauses or resumes the playback of the current file.

• Stop – stops the playback of the current file.

• Repeat – plays the file repeatedly.

• Position – moves to a different position in the file.

• Mute – turns sound off and on.

• Volume – adjusts the volume level.

• View – adjusts the size of the movie playback.

Figure 31: Media Playback toolbar

Options
The Options toolbar (Figure 32) provides tools for editing various settings for newly created 
drawings, for example how objects snap to the grid when being moved or resized.
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Figure 32: Options toolbar

Redaction
The Redaction toolbar (Figure 33) is used to block portions of a drawing protecting sensitive 
information and helps enterprises and organizations to comply with regulations on confidentiality 
or privacy.

When a redacted drawing is exported to a new drawing, any redacted portions are removed from 
the new drawing and replaced by redaction blocks of pixels. This prevents any attempt to restore 
or copy the original contents. A redacted drawing is often exported to PDF for publication or 
sharing.

Figure 33: Redaction toolbar

Standard
The Standard toolbar (Figure 34) is common to all LibreOffice components and provides the most
common tools when creating and editing documents using LibreOffice. The Standard toolbar 
differs between LibreOffice components to allow for different toolsets used in creating the 
different types of documents.
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Figure 34: Standard toolbar

Figure 35: Standard (Viewing Mode) toolbar
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Standard (Viewing Mode)
The Standard (Viewing Mode) toolbar (Figure 35) provides tools to save, edit, and distribute a 
drawing.

Table
The Table toolbar (Figure 36) provides tools and options to edit and format a table placed in a 
drawing. This toolbar only becomes active when a table is selected.

Figure 36: Table toolbar

Text Formatting
The Text Formatting toolbar (Figure 37) provides tools for formatting text and alignment 
commands. This toolbar becomes active when text in a text box or graphic object has been 
selected and it automatically replaces the Line and Filling toolbar.
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Figure 37: Text Formatting toolbar

Figure 38: Transformations toolbar
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Transformations
The Transformations toolbar (Figure 38) provides tools to modify the shape, orientation, or fill of 
selected objects.

Zoom
The Zoom toolbar (Figure 39) provides tools to reduce or enlarge the screen display of the 
current drawing.

Figure 39: Zoom toolbar
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