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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click

Opens a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Opens the Navigator

F11

⌘+T

Opens the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Introduction
This chapter describes some common customizations that you may wish to do. In addition to
selecting options from those provided, you can customize menus, toolbars, and keyboard
shortcuts, add new menus and toolbars, and assign macros to events. However, you cannot
customize context (right-click) menus.
Other customizations are made easy by extensions that you can install from the LibreOffice
website or from other providers.

Note

Changes to menus and toolbars can be saved in a template. First, save the document
that was open when these changes were made. Then, save that document as a
template, as described in Chapter 4, Using Styles and Templates in Calc.

LibreOffice options
This section covers some of the settings that apply to all the components of LibreOffice and are of
particular interest to users of Calc. Other general options are discussed in Chapter 2, Setting Up
LibreOffice, in the Getting Started guide.
1) Choose Tools > Options (LibreOffice > Preferences on a Mac) to open the Options
dialog. The list on the left-hand side of the Options dialog varies depending on which
LibreOffice component is open. The illustrations in this chapter show the list as it appears
when Calc is open.
2) Click the expansion symbol (+ or triangle) by LibreOffice on the left-hand side. A list of
subsections drops down.

Figure 1: Options – LibreOffice – User Data page

Note

The Revert button has the same effect on all pages of the Options dialog. It resets
the options to the values that were in place when you opened LibreOffice.

LibreOffice options
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User Data options
User data is used by templates and Wizards in LibreOffice. For example, Calc uses the first and
last name stored here to fill in the Created and Modified fields in the document properties, the
optional Author field often used in the footer of a printed spreadsheet, and the name associated
with comments. If you want your name to appear, then fill in the form on the LibreOffice – User
Data page (Figure 1). If you are using a version of LibreOffice other than US English, some field
labels may be different from those shown in the illustration.
Some of the user data is included automatically in an internal dictionary so that it is recognized by
the spelling checker. If typing errors are made, the program can use this data to suggest
replacements. Note that changes to data take effect only after LibreOffice is restarted.

Print options
On the LibreOffice – Colors page, you can set the print options to suit your default printer and your
most common printing method. You can change these settings at any time, either through this
dialog or during the printing process (by clicking the Options button on the Print dialog).
See Chapter 6, Printing, Exporting, and E-mailing, in this guide for more about these options.

Color options
On the LibreOffice – Colors page, you can specify colors to use in LibreOffice documents. You can
select a color from a color table, edit an existing color, and define new colors. These colors are
stored in your color selection palette and are then available in all components of LibreOffice.

Figure 2: Defining colors to use in color palettes in LibreOffice
To modify a color:
1) Select the color to modify from the list or the color table.
2) Enter the new values that define the color. If necessary, change the settings from RGB
(Red, Green, Blue) to CMYK (Cyan, Magenta, Yellow, Black) or vice versa. The changed
color appears in the lower of the two color preview boxes at the top.
3) Modify the Name as required.
4) Click the Modify button. The newly defined color is now listed in the Color table.
LibreOffice options
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Alternatively, click the Edit button to open the Color Picker dialog, shown in Figure 3. Here you can
select a color from the window on the left, or you can enter values on the right using your choice of
RGB, CMYK, or HSB (Hue, Saturation and Brightness) values.
The color window on the left is linked directly with the color input fields on the right; as you choose
a color in the window, the numbers change accordingly. The color field at the lower left shows the
value of the selected color on the left and the currently set value from the color value fields on the
right.

Figure 3: Editing colors
Modify the color components as required and click OK to exit the dialog. The newly defined color
now appears in the lower of the color preview boxes shown in Figure 10. Type a name for this color
in the Name box, then click the Add button. A small box showing the new color is added to the
Color table.
Another way to define or alter colors is through the Colors page of the Area dialog, where you can
also save and load palettes, a feature that is not possible here. In Calc, draw a temporary draw
object and use the context menu of this object to open the Area dialog. If you load a palette in one
component of LibreOffice, it is only active in that component; the other components keep their own
palettes.

Security options
Use the LibreOffice – Security page to choose security options for saving documents and for
opening documents that contain macros.
Security options and warnings
If you record changes, save multiple versions, or include hidden information or notes in your
documents, and you do not want some of the recipients to see that information, you can set
warnings to remind you to remove this information, or you can have LibreOffice remove some
information automatically. Note that (unless removed) much of this information is retained in a
file whether the file is in LibreOffice’s default OpenDocument format, or has been saved to
other formats, including PDF.
Click the Options button to open a separate dialog with specific choices (Figure 5).
LibreOffice options
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Figure 4: Choosing security options for opening and saving documents
Passwords for web connections
LibreOffice can save any passwords associated with websites opened by clicking on a
hyperlink. If you choose Persistently save passwords for web connections, LibreOffice will
securely store all passwords that you use to access files from web servers.
If you also set a master password, individual passwords can be accessed only after the master
password has been entered. To set a master password, select the Protected by a master
password option and click the Master Password button.
Macro security
Click the Macro Security button to open the Macro Security dialog (not shown here), where
you can adjust the security level for executing macros and specify trusted sources.
Certificate Path

Note

This option appears only on Linux and Mac systems. On Windows, LibreOffice uses
the default Windows location for storing and retrieving certificates.

Users can digitally sign documents using LibreOffice. A digital signature requires a personal
signing certificate. Most operating systems can generate a self-signed certificate. However, a
personal certificate issued by an outside agency (after verfiying an individual's identity) has a
higher degree of trust associated with it than does a self-signed certificate. LibreOffice does not
provide a secure method of storing these certificates, but it can access certificates that have
been saved using other programs. Click Certificate and select which certificate store to use.

Security options and warnings
The following options are on the Security options and warnings dialog (Figure 18).
Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file. To
manually remove personal information from specific documents, deselect this option and then
use the Delete button under File > Properties > General.

LibreOffice options
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Ctrl-click required to follow hyperlinks
The default behavior in most components of LibreOffice is to Ctrl+click on a hyperlink to open
the linked document, but you can choose to open hyperlinks using a single click. However,
Calc opens hyperlinks using a single click, regardless of the selection for this option.
The other options on this dialog should be self-explanatory.

Figure 5: Security options and warnings dialog

Appearance options
On the LibreOffice – Appearance page, you can specify which items are visible and the colors
used to display various elements of the user interface. These colors are not printed when you print
a spreadsheet.

Figure 6: Changing the color of grid points in Calc

LibreOffice options

8

Scroll down the list until you find the section headed Spreadsheet. To change the default color for
grid lines or other on-screen indicators, click the down-arrow by the color and select a new color
from the drop-down list.
If you wish to save your color changes as a color scheme, click Save, type a name in the Name of
color scheme box in the pop-up dialog, and then click OK.

Loading and saving documents
You can set the Load/Save options to suit the way you work. This chapter describes only a few of
the options, those most relevant to working with Calc. See Chapter 2, Setting Up LibreOffice, in the
Getting Started guide for a description of the other options.
If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or
triangle) by Load/Save on the left-hand side to display the list of load/save options pages.

Figure 7: Load/Save options

General
Many of the choices on the Load/Save – General page (Figure 8) are familiar to users of other
office suites. Those of most interest to Calc users are in the Default file format and ODF settings
section. See Chapter 2, Setting Up LibreOffice, in the Getting Started guide for information about
other options.
ODF format version
LibreOffice by default saves documents in OpenDocument Format (ODF) version 1.2
Extended. While this allows for improved functionality, there may be backwards compatibility
issues. When a file saved in ODF 1.2 Extended is opened in an editor that uses an earlier
version of ODF (1.0/1.1), some of the advanced features may be lost. Two notable examples
are cross-references to headings and the formatting of numbered lists. If you plan to share
documents with people who are use editors that use older versions of ODF, you may wish to
save the document using ODF version 1.0/1.1.
Size optimization for ODF format
LibreOffice documents are XML files. When you select this option, LibreOffice writes the XML
data without indents and line breaks. If you want to be able to read the XML files in a text editor
in a structured form, deselect this option.
Document type
If you routinely share documents with users of Microsoft Excel, you might want to change the
Always save as attribute for spreadsheets to one of the Excel formats.
However, we recommend that you always save a working copy in ODS format and only create
an Excel version if necessary for sharing. Also, note that recent and current versions of
Microsoft Excel can open ODS files, so this may no longer be needed.

Loading and saving documents
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Figure 8: Choosing Load and Save options

Note

LibreOffice can open and save files in the .xlsx format produced by Microsoft
Office 2007, 2010, and later.

VBA Properties
On the Load/Save – VBA Properties page, you can choose whether to keep any VBA (Visual Basic
for Applications) macros in Microsoft Office documents that are opened in LibreOffice.

Figure 9: Choosing Load/Save VBA Properties

Loading and saving documents
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Load Basic code
The original VBA code will be loaded as a disabled LibreOffice Basic module. You can edit the
code. When saving the document in LibreOffice format, the Basic code is saved as well. When
the document is saved in another format, the LibreOffice Basic code is not saved.
Executable code
The VBA code will be loaded ready to be executed. If this option is not selected, the VBA code
will be commented out so it can be inspected, but will not run. As a safety precaution against
viruses and other malicious code, you may wish to disable the executable code option.
Save original Basic code
A backup copy of the original code, written in Basic, is saved with the document.
Save original Basic code takes precedence over Load Basic code. If both options are selected
and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved
when saving in a Microsoft Office format.
To remove any possible macro viruses from the Microsoft Office document, deselect Save
original Basic code. The document will be saved without the Microsoft Basic code.

Microsoft Office
On the Load/Save – Microsoft Office page, you can choose what to do when importing and
exporting Microsoft Office OLE objects (linked or embedded objects or documents such as
spreadsheets or equations).

Figure 10: Choosing Load/Save Microsoft Office options
Select the [L] options to convert Microsoft OLE objects into the corresponding LibreOffice OLE
objects when a Microsoft document is loaded into LibreOffice (mnemonic: “L” for “load”).
Select the [S] options to convert LibreOffice OLE objects into the corresponding Microsoft OLE
objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”).

HTML compatibility
Choices made on the Load/Save – HTML Compatibility page (Figure 11) affect HTML pages
imported into LibreOffice and those exported from LibreOffice. See Chapter 2, Setting up
LibreOffice, in the Getting Started guide, and HTML documents; importing/exporting in the Help, for
more information.
The main items of interest for Calc users are in the Export section: LibreOffice Basic and Display
warning.

Loading and saving documents
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Figure 11: Choosing HTML compatibility options
Export - LibreOffice Basic
Select this option to include LibreOffice Basic macros (scripts) when exporting to HTML format.
You must activate this option before you create the LibreOffice Basic macro; otherwise the
script will not be inserted. LibreOffice Basic macros must be located in the header of the HTML
document. Once you have created the macro in the LibreOffice Basic IDE, it appears in the
source text of the HTML document in the header.
If you want the macro to run automatically when the HTML document is opened, choose Tools
> Customize > Events. See Chapter 12, Calc Macros, for more information.
Export - Display warning
When the LibreOffice Basic option (see above) is not selected, the Display warning option
becomes available. If the Display warning option is selected, then when exporting to HTML a
warning is shown that LibreOffice Basic macros will be lost.

Calc options
Calc must be open in order for the LibreOffice Calc options to be
displayed in the Options dialog. Click the expansion symbol (+ or
triangle) by LibreOffice Calc on the left-hand side. A list of
subsections drops down.

Figure 12: Calc options
Calc options
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General options
In the Options dialog, choose LibreOffice Calc > General.

Figure 13: Selecting general options for Calc

Metrics
Choose the unit of measurement used in spreadsheets and the default tab stops distance.

Updating
Choose whether to update links when opening a document always, only on request, or never.
Regardless of this setting, you can manually update links at any time by selecting Tools > Update
> Links or pressing F9. Spreadsheets that include many or large charts or graphics may load
slowly if this option is set to always.

Input settings section
Press Enter to move selection
Specifies that pressing Enter moves the cursor to another cell. If this option is selected, you
can also choose the direction the cursor moves: up, down, left, or right. If this option is not
selected, pressing Enter places the data into the cell but does not move the cursor.
Press Enter to switch to edit mode
Specifies that pressing Enter puts the selected cell into edit mode. To end Edit mode and move
the cursor in the desired direction, press Enter again.
Expand formatting
Specifies whether to automatically apply the formatting attributes of an inserted cell to empty
adjacent cells. If, for example, an inserted cell has the bold attribute, this attribute will also
apply to empty adjacent cells. However, cells that already have a special format will not be
modified by this function. To see the affected range, press Ctrl+* (multiplication sign on the
number pad). The format will also apply to all new values inserted within this range.

Calc options
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Expand references when new columns/rows are inserted
Specifies whether to expand references when inserting columns or rows adjacent to the
reference range. This is only possible if the reference range, where the column or row is
inserted, originally spanned at least two cells in the desired direction.
Example: If the range A1:B1 is referenced in a formula and you insert a new column after
column B, the reference is expanded to A1:C1. If the range A1:B1 is referenced and a new row
is inserted under row 1, the reference is not expanded, since there is only a single cell in the
vertical direction.
If you insert rows or columns in the middle of a reference area, the reference is always
expanded.
Highlight selection in column/row headings
Specifies whether to highlight column and row headers in the selected columns or rows.
Use printer metrics for text formatting
Select this option to use the properties of the default printer to format the display of a
spreadsheet. Those properties can be found by choosing File > Printer Settings and then
select the Properties button for the default printer. If the printer has options for page setup,
those settings will be applied to Calc documents. If this option is not selected, pages will be
configured for a generic printer.
Show overwrite warning when pasting data
Pasting contents of the clipboard into a cell will replace the contents of that cell with what is in
the clipboard. Select this option to be alerted to a possible loss of data when pasting.

Defaults
Enter the number of worksheets to be opened by default when you start a new spreadsheet and
either accept the default sheet prefix or type a new one. After a spreadsheet has been created, you
can add new sheets and change the label of any tab; see Chapter 1, Introducing Calc, for more
information.

View options
The options on the LibreOffice Calc – View page (Figure 14) affect the way the document window
looks and behaves when viewed onscreen.

Visual aids section
Grid lines
Grid lines are the borders around the cells of a spreadsheet when viewed onscreen. The
options are: Show, Show on colored cells, or Hide. If grid lines are hidden, tables will be
displayed on a solid background with no grid around cells. The color choice overrides the
selection made in Tools > Options > LibreOffice > Appearance > Spreadsheet > Grid lines.

Note

Calc options
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Figure 14: Selecting view options for Calc
Page breaks
Specifies whether to view the page breaks within a defined print area.
Helplines While Moving
Specifies whether to view helplines when moving drawings, frames, graphics, and other
objects. These lines help you align objects.

Figure 15: Helplines visible when moving a graphic
Calc options
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In Figure 15, the graph with the dark background represents the image in its original location.
The lighter area represents the position of the image as it is being moved. Helplines are the
horizontal and vertical dotted lines at the corners of the lighter object.

Objects section
Choose whether to show or hide graphics, charts, and drawing objects.

Zoom section
Select the Synchronize sheets option to apply any selected zoom (magnification) factor to all
sheets in the spreadsheet. If this option is not selected, separate zoom factors can be applied to
individual sheets.

Display section
Select various options for the onscreen display.
Formulas
Display the content of a cell as a formula or as the results of that formula.
Zero values
Display a zero in a cell when the cell has a value of zero, or display an empty cell.
Comment indicator
Select this option to show a small triangle in the top right corner of a cell that contains a
comment. If tips are enabled in Tools > Options > LibreOffice > General, the comment will
become visible when the mouse pointer hovers over the cell. Tips will appear regardless of the
setting of this option.
To always display a comment, right-click on the cell and select Show comment from the
context menu.
Value highlighting
Select this option to highlight all values, or results of formulas, in the sheet. Text is highlighted
in black; numbers in blue; and formulas, logical values, dates, and so on, in green.
When this command is active, any colors assigned in the document are not displayed.
Anchor
If an inserted object, such as a picture, is anchored to a cell, an image of an anchor will appear
in the cell to which the object is anchored.
Text overflow
If a cell contains text that is wider than the width of the cell, the text is displayed over empty
neighboring cells in the same row. If there is no empty neighboring cell, a small triangle at the
cell border indicates that the text continues. If this option is selected, text will wrap inside the
cell and the height of the row will expand to accommodate the hight of the expanded cell.
Show references in color
Select this option to provide a visual aid to assist the editing of a formula. Each reference is
then highlighted in color in the formula, and the referenced cell range is enclosed by a colored
border as soon as the cell containing the reference is selected for editing.

Figure 16: Formula references – visual aids
Calc options
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Window section
The following elements of the spreadsheet window can be made visible or invisible: column and
row headers, horizontal and vertical scroll bars, sheet tabs, and, if an outline has been defined,
outline symbols.
If the Sheet tabs option is not selected, you can only switch between the sheets by using the
Navigator.
Note that there is a slider between the horizontal scrollbar and the sheet tabs that may be set to
one end.

Figure 17: Window options

Calculate options
Use the LibreOffice Calc – Calculate page to define the calculation settings for spreadsheets.

Figure 18: Calc calculation options

Calc options
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Iterative references section
Iterative references are formulas that are continuously repeated until the problem is solved. In this
section you can choose the number of approximation steps carried out during iterative calculations
and the degree of precision of the answer.
Iterations
Select this option to enable iterations. If this options is not selected, an iterative reference
causes an error message.
Steps
Sets the maximum number of iteration steps.
Minimum Change
Specifies the difference between two consecutive iteration step results. If the result of the
iteration is lower than the minimum change value, then the iteration will stop.

Date section
Select the start date for the internal conversion from days to numbers.
12/30/1899 (default) – Sets December 30, 1899 as day zero. In calculations, January 1, 1900 is
used as day one.
01/01/1900 (StarCalc 1.0) – Sets January 1, 1900 as day zero. Use this setting for StarCalc 1.0
spreadsheets containing date entries.
01/01/1904 – Sets January 1, 1904 as day zero. Use this setting for spreadsheets that are
imported from foreign formats.

Other options
Specify a variety of options relevant to spreadsheet calculation.
Case sensitive
Specifies whether to distinguish between upper and lower case in texts when comparing cell
contents. For example: type 'Test' in cell A1; and 'test' in B1. Then type the formula "=A1=B1" in
cell C1. If the Case sensitive option is checked, FALSE will appear in the cell; if the analysis
was case insensitive, TRUE will appear in the cell. This option is not applied to the EXACT text
function, which is always case-sensitive.
Decimal places
Limits the number of decimals to be displayed for numbers with the general number format.
This overrides the setting applied in Format > Cells > Numbers > Number > General. This
setting refers to how numbers are displayed. When decimal places are limited, calculations are
not affected because of rounding.
Precision as shown
The value entered into this field defines the precision used to perform calculations. All numbers
will be rounded to the desired decimal places. Numbers will be displayed according to the
previous setting but calculations will be less precise because rounded numbers are used in the
calculations.
Search criteria = and <> must apply to whole cells
The default search method in Calc is to search for any instance of the target regardless of the
position of the target within a word. For example, when searching for day, Calc will match
Friday, Sunday, and days. Select this option to search an exact occurence of the target. Wild
card symbols can be used to expand the search to match the default condition. That is,
searching for *day* will match Friday, Sunday, and days.

Calc options
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Enable regular expressions in formulas
Specifies that regular expressions (an extended set of wild cards) are enabled when searching
and also for character string comparisons. This relates to the database functions, and to
VLOOKUP, HLOOKUP and SEARCH.
Automatically find column and row labels
Calc will name the range of data, under a column heading or to the right of a row heading,
using the text in those headings.
Example: Cell E5 contains the text Europe. Below, in cell E6, is the value 100 and in cell E7 the
value 200. If the Automatically find column and row labels option is selected, you can write
the following formula in cell A1: =SUM(Europe).

Caution

When calculations involve a range that includes an empty cell, take note of the
setting for Display Zero values in the LibreOffice Calc > View options. If this
option is not selected, a value of zero will display as an empty cell. Empty cells and
the value zero are treated differently by many functions. For example, Count would
not include an empty cell as an item to be counted. The average of eight cells, one
of which contains the value zero, is not the same as the average of seven cells (an
empty cell is not included in determining the average).

Formula options
Use the LibreOffice Calc – Formula options page to specify whether to use Calc or Excel syntax,
as well as choosing which separators you prefer to use in formulas. The separators choices
override the defaults in Calc and Excel syntax.

Figure 19: Formula options

Calc options
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Formula options
Formula syntax
Syntax is the format in which formulas are written. Choose the syntax most appropriate for your
work. If you regularly open or save to Microsoft Excel formats, you may wish to use one of the
Excel syntaxes.
To illustrate the differences between syntaxes, assume a spreadsheet contains two sheets. The
cell C4 can be referenced in three ways:

• Calc A1 =$Sheet2.C4 – the default syntax for Calc.
• Excel A1 =Sheet2!C4 – the default of Microsoft Excel.
• Excel R1C1 =Sheet2!R[3]C[2] – tthe relative row and column addressing used in Excel.
Use English function names
The default names for functions in Calc are those for the user's locale. For English users, the
localized names are the same as the English names. When the language set by locale is not
English, you may wish to express functions in English; if so, select this option to change
formula input and display, function wizard, and formula tips.

Detailed calculation settings
Most users will not need to change the default setting. For custom settings, select Custom and
click Details to choose reference syntax and whether to treat empty strings as zero.

Separators
Separators are used in functions to distinguish points in the range used in the function: the
symbols used between elements. Enter the separator character to be used for functions, row
arrays, and column arrays. For example, a comma can be used as a separator in functions and
instead of writing =SUM(A1;B1;C1) the function would be expressed as =SUM(A1,B1,C1).

Sort Lists
Sort lists are used for more than sorting, for example filling a series of cells during data entry. They
are lists that are sorted in a particular order but not alphabetically or numerically; for example, days
of the week. In addition to the supplied lists, you can define and edit your own lists, as described in
“Defining a fill series” in Chapter 2, Entering, Editing, and Formatting Data.

Figure 20: Defining sorting lists in Calc

Calc options
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Change options
In the Options dialog, choose LibreOffice Calc > Changes.

Figure 21: Calc options for highlighting changes
On this page you can specify options for highlighting recorded changes in spreadsheets. You can
assign specific colors for insertions, deletions, and other changes, or you can let Calc assign colors
based on the author of the change; in the latter case, one color will apply to all changes made by
that author.
The selections made here are applied when change recording is enabled under File > Changes >
Record.

Compatibility options
In the Options dialog, choose LibreOffice Calc > Compatibility. This page provides a quick way
to switch between LibreOffice’s default key bindings and OpenOffice.org’s legacy default key
bindings for Calc. Most of the defaults are identical, but there are some differences.

Figure 22: Compatibility options for Calc key bindings
The actions associated with the two key binding choices are shown in the table below.
Key Binding

Default

OpenOffice.org legacy

Backspace

Opens Delete Contents dialog

Immediately deletes contents

Delete

Immediately deletes contents

Opens Delete Contents dialog

Calc options
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Key Binding

Default

OpenOffice.org legacy

Control+D
(Command+D on Mac)

Fills cell content down within
selection

Opens the Selection List dialog

Alt+DownArrow
(Option+DownArrow on Mac)

select header of range
no action in empty cell

Increases row height

Grid options
The Grid page defines the grid settings for spreadsheets. Using a grid helps you determine the
exact position of any charts or other objects you may add to a spreadsheet. You can also set this
grid in line with the snap grid.
If you have activated the snap grid but wish to move or create individual objects without snap
positions, you can press the Ctrl key to deactivate the snap grid for as long as needed.
In the Options dialog, choose LibreOffice Calc > Grid.

Grid section
Snap to grid activates the snap function.
Visible grid displays grid points on the screen. These points are not printed.

Resolution section
Here you can set the unit of distance for the spacing between horizontal and vertical grid points
and subdivisions (intermediate points) of the grid.
Synchronize axes changes the current grid settings symmetrically.

Figure 23: Calc grid options

Print options
In the Options dialog, choose LibreOffice Calc > Print. See Chapter 6, Printing, Exporting, and Emailing, for more about the options on this page.

Calc options
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Default colors for charts
Use Tools > Options > Charts > Default Colors to change the default colors used for charts or to
add new data series to the list provided.

Figure 24: Defining chart colors
To change the default color for a data series, select it in the left-hand column and then click on the
required color in the color table.
To add another data series, click Add, then select the new series and click on the required color.
To add new colors to the color table, see “Color options” on page 5.

AutoCorrect functions
Some people find some or all of the items in LibreOffice’s AutoCorrect function annoying because
they change what you type when you do not want it changed. Many people find some of the
AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find
unexplained changes appearing in your document, this is a good place to look to find the cause.
To open the AutoCorrect dialog, click Tools > AutoCorrect Options. You need to have a
document open for this menu item to appear.
In Calc, this dialog has four tabs, as shown in Figure 25. Options are described in the Help; many
will be familiar to users of other office suites.

AutoCorrect functions

23

Figure 25: The AutoCorrect dialog in Calc

Customizing the user interface
Menu font
If you want to change the menu font from that supplied by LibreOffice to the system font for your
operating system, do this:
1) Choose Tools > Options > LibreOffice > View.
2) Check Use system font for user interface and click OK.

Menu content
In addition to changing the menu font, you can add and rearrange items on the menu bar, add
items to menus, and make other changes.
To customize menus:
1) Choose Tools > Customize. On the Customize dialog, go to the Menus page (Figure 26).

Figure 26: Customize menus
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2) In the Save In drop-down list (h), choose whether to save this changed menu for Calc or
for a selected document.
3) In the section LibreOffice Calc Menus, select from the Menu drop-down list (b) the menu
that you want to customize. The list includes all the main menus as well as sub-menus,
which are menus that are contained under another menu. For example, in addition to File,
Edit, View, and so on, there is File | Send and File |Templates. The commands available for
the selected menu are shown in the central part of the dialog.
4) To customize the selected menu, click on the Menu (c) or Modify (f) buttons. You can also
add commands to a menu by clicking on the Add button (e). These actions are described in
the following sections.
5) Use the up and down arrows (g) next to the Entries list (d) to move the selected menu item
to a different position.
6) When you have finished making all your changes, click OK (not shown in picture) to save
them.

Creating a new menu
In the Menus page of the Customize dialog, click New (b) to display the dialog shown in Figure 27.
1) Type a name for your new menu in the Menu name box.
2) Use the up and down arrow buttons to move the new menu into the required position in the
list of menu items. Click OK to save and return to the Customize dialog.
The new menu now appears on the list of menus in the Customize dialog. (It will appear on the
menu bar itself after you save your customizations.)
After creating a new menu, you need to add some commands to it, as described in “Adding a
command to a menu” on page 26.

Figure 27: Adding a new menu

Modifying existing menus
To modify an existing menu, select it in the Menu list and click the Menu button (c) to drop down a
list of modifications: Move, Rename, Delete. Not all of these modifications can be applied to all the
entries in the Menu list. For example, Rename and Delete are not available for the supplied
menus.
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To move a menu (such as File), choose Menu > Move. A dialog similar to the one shown in Figure
27 (but without the Menu name box) opens. Use the up and down arrow buttons to move the
menu into the required position.
To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in
the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the
arrow keys to move it up or down in the sequence. Submenus are easily identified in the Entries list
by a small black triangle on the right hand side of the name.

Adding a command to a menu
You can add commands to the supplied menus and to menus you have created. On the Customize
dialog, select the menu in the Menu list and click the Add button in the Menu Content section of
the dialog.

Figure 28: Adding a command to a menu
On the Add Commands dialog, select a category and then the command, and click Add. The
dialog remains open, so you can select several commands. When you have finished adding
commands, click Close. Back on the Customize dialog, you can use the up and down arrow
buttons to arrange the commands in your preferred sequence.

Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus,
rename or delete the entries, and add group separators.
To begin, select the menu or submenu in the Menu list near the top of the Customize page, then
select the entry in the Entries list under Menu Content. Click the Modify button and choose the
required action from the drop-down list of actions.
Most of the actions should be self-explanatory. Begin a group adds a separator line after the
highlighted entry.
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Creating an accelerator
You can allocate a letter in a custom menu’s name to be used as a keyboard shortcut. (That letter
will become underlined.) When you press Alt+ that letter, that menu or command will be invoked.
Existing submenus can also be edited to change the letter which is used to select them using the
keyboard when the menu is open.
To create an accelerator:
1) Select a menu item from Menu or Entry from the Menu Content.
2) Click the Menu button if Menu was selected or the Modify button if an Entry was selected.
3) Select Rename.
4) Add a tilde (~) in front of the letter to use as an accelerator. For example, if you had created
a new menu named Art, you would do this:
a) Select Art from Menu.
b) Select Menu and then Rename.
c) Insert a tilde before the letter A in Art.
d) Click OK to close the Rename and Customize dialogs.
The A in the menu item Art is now underlined. Press Alt+A and the Art menu will open.

Caution

When assigning an accelerator, be careful not to use a letter that is already assigned
to a menu or command associated with a menu item. The same letter-key
combinations can be used for commands associated with different menu items but
not for those associated with the same menu or menu item.

Toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar, as described in Chapter 1, Introducing LibreOffice, of the Getting
Started guide. This section describes how to create new toolbars and add other icons (commands)
to the list of those available on a toolbar.
To get to the toolbar customization dialog, do any of the following:

• On the toolbar, click the arrow at the end of the toolbar and choose Customize Toolbar.
• Choose View > Toolbars > Customize from the menu bar.
• Choose Tools > Customize from the menu bar and pick the Toolbars page (Figure 29).
To customize a toolbar:
1) In the Save In drop-down list, choose whether to save this changed toolbar for Calc or for a
selected document.
2) In the section LibreOffice Calc Toolbars, select from the Toolbar drop-down list the
toolbar that you want to customize.
3) You can create a new toolbar by clicking on the New button, or customize existing toolbars
by clicking on the Toolbar or Modify buttons, and add commands to a toolbar by clicking
on the Add button. These actions are described below.
4) When you have finished making all your changes, click OK to save them.
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Figure 29: The Toolbars page of the Customize dialog

Creating a new toolbar
To create a new toolbar:
1) Choose Tools > Customize > Toolbars from the menu bar.
2) Click New. On the Name dialog, type the new toolbar's name and choose from the Save In
drop-down list where to save this new toolbar: for Calc or for a selected document.
The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new
toolbar, you need to add some commands to it, as described below.

Adding a command to a toolbar
If the list of available buttons for a toolbar does not include all the commands you want on that
toolbar, you can add commands. When you create a new toolbar, you need to add commands to it.
1) On the Toolbars page of the Customize dialog, select the toolbar in the Toolbar list and click
the Add button in the Toolbar Content section of the dialog.
Customizing the user interface
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2) The Add Commands dialog is the same as for adding commands to menus (Figure 28).
Select a category and then the command, and click Add. The dialog remains open, so you
can select several commands. When you have finished adding commands, click Close. If
you insert an item which does not have an associated icon, the toolbar will display the full
name of the item: the next section describes how to choose an icon for a toolbar command.
3) Back on the Customize dialog, you can use the up and down arrow buttons to arrange the
commands in your preferred sequence.
4) When you are done making changes, click OK to save.

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have
associated icons.
To choose an icon for a command, select the command and click Modify > Change icon. On the
Change Icon dialog (Figure 30), scroll through the available icons, select one, and click OK to
assign it to the command.

Figure 30: Change Icon dialog
To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the
Import button on the Change Icon dialog. Custom icons must be 16 x 16 or 26 x 26 pixels in size
and cannot contain more than 256 colors.

Keyboard shortcuts
In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your own.
You can assign shortcuts to standard LibreOffice functions or your own macros and save them for
use with the entire LibreOffice suite or only for Calc.

Caution

Be careful when reassigning your operating system’s or LibreOffice’s predefined
shortcut keys. Many key assignments are universally understood shortcuts, such as
F1 for Help, and are always expected to provide certain results. Although you can
easily reset the shortcut key assignments to the LibreOffice defaults, changing some
common shortcut keys can cause confusion, frustration and possible data loss or
corruption, especially if other users share your computer.
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Note

Shortcut keys that are grayed out in the listing on the Customize dialog, such as F1
and F10, are not available for reassignment.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.
1) Select Tools > Customize > Keyboard. The Keyboard page of the Customize dialog
opens.
2) To have the shortcut key assignment available only with Calc, select Calc in the upper right
corner of the page; otherwise select LibreOffice to make it available to every component.
3) Next select the required function from the Category and Function lists.
4) Now select the desired shortcut keys in the Shortcut keys list and click the Modify button at
the upper right.
5) Click OK to accept the change. Now the chosen shortcut keys will execute the function
chosen in step 3 above whenever they are pressed.

Note

All existing shortcut keys for the currently selected Function are listed in the Keys
selection box. If the Keys list is empty, it indicates that the chosen key combination is
free for use. If it were not, and you wanted to reassign a shortcut key combination
that is already in use, you must first delete the existing key.

Example: Assigning styles to shortcut keys
You can configure shortcut keys to quickly assign styles in your document.
1) On the Keyboard page of the Customize dialog, choose the shortcut keys you want to
assign a style to. In this example, we have chosen Ctrl+3.
2) In the Functions section at the bottom of the dialog, scroll down in the Category list to
Styles. Click the + sign to expand the list of styles.
3) Choose the category of style. (This example uses a cell style, but you can also choose
page styles.) The Function list now displays the names of the available styles for the
selected category. The example shows LibreOffice’s predefined cell styles.
4) To assign Ctrl+3 to be the shortcut key combination for the Heading style, select Heading in
the Function list, and then click Modify. Ctrl+3 now appears in the Keys list on the right,
and Heading appears next to Ctrl+3 in the Shortcut keys box at the top.
5) Make any other required changes, and then click OK to save these settings and close the
dialog.

Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a
later time, thus permitting you to create and apply different configurations as the need arises. To
save keyboard shortcuts to a file:
1) After making your keyboard shortcut assignments, click the Save button on the Customize
dialog.
2) In the Save Keyboard Configuration dialog, select All files from the Save as Type list.
3) Next enter a name for the keyboard configuration file in the File name box, or select an
existing file from the list. If you need to, browse to find a file from another location.
4) Click Save. A confirmation dialog appears if you are about to overwrite an existing file,
otherwise there will be no feedback and the file will be saved.
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Figure 31: Assigning a cell style to a key combination

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load
button near the bottom right of the Customize dialog, and then select the configuration file from the
Load Keyboard Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom
right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed;
the defaults will be set without any further notice or user input.

Running macros from key combinations
You can also define shortcut key combinations that will run macros. These shortcut keys are strictly
user-defined; none are built in. For more information on macros, see Chapter 12, Calc Macros.

Adding functionality with extensions
An extension is a package that can be installed into LibreOffice to add new functionality.
Although individual extensions can be found in different places, the official LibreOffice extension
repository is at http://extensions.libreoffice.org/. Some extensions are free of charge; others are
available for a fee. Check the descriptions to see what licenses and fees apply to the ones that
interest you.
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Installing extensions
To install an extension that is listed in the repository, follow these steps:
1) In LibreOffice, select Tools > Extension Manager from the menu bar. In the Extension
Manager dialog, click the Get more extensions online link.
2) A browser window will open. Find the extension you want and click the Get [extension
name] link.
3) Depending on your operating system and browser settings, you may be able to select
Open with LibreOffice from the download options and install the extenstion automatically.
4) If the extension is downloaded and saved, return to the Extension Manager dialog and click
Add. Find and select the extension you want to install and click Open. The extension
begins installing. You may be asked to accept a license agreement.
5) When the installation is complete, the extension is listed in the Extension Manager dialog.
To install an extension that is not listed in the repository, download the extension, then continue
with step 3 above.

Note

To install a shared extension, you need write access to the LibreOffice installation
directory.

Figure 32: The Extension Manager dialog
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