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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options 
menu selection

LibreOffice > Preferences Access setup options

Right-click Control+click and/or right-click 
depending on computer system

Open a context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open the Styles and Formatting window
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Introduction

Draw is a vector graphics drawing tool, although it can also perform some operations on raster 
graphics (pixels). Using Draw, you can quickly create a wide variety of graphical images.

Vector graphics store and display a picture as simple geometric elements such as lines, circles, 
and polygons rather than as a collection of pixels (picture elements or points on the screen). This 
permits simpler storage and supports precise scaling of the picture elements.

Draw is fully integrated into the LibreOffice suite and this simplifies exchanging graphics with all 
components of the suite. For example, if you create an image in Draw, reusing it in a Writer 
document is as simple as copying and pasting the image. You can also work with drawings directly 
from within Writer or Impress using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive and, even though it was not designed to rival 
high-end graphics applications, it possesses significantly more functionality than the drawing tools 
that are generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, 
dimensions and measurement display, connectors for making organization charts, 3D functions 
that enable small three-dimensional drawings to be created (with texture and lighting effects), 
drawing and page-style integration, and Bézier curves.

This Draw Guide is not a course book to be worked through from beginning to end. Rather, it is a 
reference work in which you can browse for guidance on particular topics.

This document describes only the functions associated with Draw. Some concepts, such as file 
management or the way the LibreOffice environment works, are mentioned only briefly; they are 
covered in more detail in the Getting Started guide.

Draw workplace

The main components of the Draw interface or workspace are shown in Figure 1.

The large area in the center of the window is where you make the drawings. You can surround the 
drawing area with toolbars and information areas. The number and position of the visible tools vary 
with the task in hand and user preferences. Therefore your setup may look different. For example, 
many users put the main Drawing toolbar on the left-hand side of the workspace and not at the 
bottom, as shown in Figure 1.

You can split drawings in Draw over several pages. Multi-page drawings are used mainly for 
presentations. The Pages pane, on the left side of the Draw workspace in Figure 1 gives an 
overview of the pages that you create. If the Pages pane is not visible on your setup, you can 
enable it by going to View > Page Pane on the main menu bar. To make changes to the page 
order, just drag and drop one or more pages.

In LibreOffice Draw, the maximum size of a drawing page is 300 cm by 300 cm.

Rulers
You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If 
they are not visible, you can enable them by selecting View > Ruler in the main menu bar.

The rulers show the size of a selected object on the page using double lines (highlighted in Figure 
2). When no object is selected, they show the location of the mouse pointer, which helps to position 
drawing objects more accurately.
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Figure 1: LibreOffice Draw workspace

Figure 2: Rulers showing size of a selected object

You can also use the rulers to manage object handles and guide lines, making it easier to position 
objects.

The page margins in the drawing area are also represented on the rulers. You can change the 
margins directly on the rulers by dragging them with the mouse. The margin area is indicated by 
the grayed out area on the rulers as shown in Figure 2.

To modify the measurement units of the rulers, which can be defined independently, right-click on 
the desired ruler, as illustrated for the horizontal ruler in Figure 3.
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Figure 3: Ruler units

The default position of the zero for each of the rulers is located in the top left corner of the page 
where the left and top margins start. This zero position can be adjusted by clicking in the top left 
corner of the workspace where the horizontal and vertical rulers meet and dragging to a new zero 
position.

Status bar

The Status bar is located at the bottom of the Draw window and includes several Draw-specific 
fields (Figure 4).

• Information area shows which action is being carried out, or which object type is selected. 
Position and Object size show different information depending on whether objects are 
selected or not.

– When no object is selected, the position numbers show the current position (X and Y 
coordinates) of the mouse cursor.

– When an object is selected and being resized with the mouse, the object size numbers 
show the size of the object (width and height).

Note
The sizes are given in the current measurement unit (not to be confused with the ruler 
units). This unit is defined in Tools > Options > LibreOffice Draw > General.

– If an object is selected, the position numbers shows the X and Y coordinates of the 
upper-left corner and the object size number pair displays the size of the object. These 
numbers do not relate to the object itself, but to the selection outline, which is the 
smallest possible rectangle that can contain the visible part or parts of the object; see 
Chapter 3 Working with Objects and Object Points for more information.

– When an object is selected, a double-click in either of these areas opens the Position 
and Size dialog; see Chapter 4 Changing Object Attributes for more information.

Figure 4: Draw status bar
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• Unsaved changes are indicated whenever any change is made to the document but not yet 
saved to disk.

• Digital signature indicates if the document has been digitally signed. A double-click or right-
click in this area opens the Digital Signatures dialog. A document must be saved at least 
once before it can be digitally signed. After a document is digitally signed, an indicator 
appears in this area.

• Slide number shows the sequence number for the current drawing page and the total 
number of pages created for the drawing. If you select an object, the information enclosed 
by parentheses indicates on which layer the object is placed within the drawing. In the 
example shown in Figure 4, the object is on the Layout layer of Slide 1 and there is a total 
number of one slide in the drawing.

• Page style shows which template is being used for the drawing.

• Zoom slider changes the zoom percentage of how the drawing appears on the computer 
display. Clicking on the plus (+) sign increases zoom and on the minus (-) sign decreases 
zoom. You can also drag the slider to increase or decrease the zoom percentage. The 
vertical bar in the middle of the Zoom slider represents a zoom percentage of 100%.

• Zoom percentage shows the level of zoom as a percentage. Double-clicking on the zoom 
percentage opens the Zoom & View Layout dialog. Right clicking on the zoom percentage 
opens a menu where you can select a zoom level. See Chapter 3 Working with Objects 
and Object Points for more information on working with the zoom functions.

Toolbars

You can display or hide the various Draw toolbars, according to your needs. To display or hide a 
toolbar, click View > Toolbars. On the menu that appears, choose which toolbars you want to 
display.

You can also select the icons or buttons that you want to appear on the toolbars. To change the 
visible icons or buttons on any toolbar, click the arrow at the right-hand end of the toolbar and 
select Visible Buttons from the drop-down menu. Visible icons or buttons are indicated by a 
shaded outline around the icon. Icons or buttons not visible are indicated by a plain icon as shown 
by the lower three icons in Figure 5. Click on an icon to hide or show it in the toolbar.

Figure 5: Selection of visible toolbar icons
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Standard toolbar
The Standard toolbar (Figure 6) is the same for all LibreOffice components and is described in 
detail in the Getting Started Guide.

Figure 6: Standard toolbar

Drawing toolbar
The Drawing toolbar (Figure 7) is the most important toolbar in Draw. It contains all the necessary 
functions for drawing various geometric and freehand shapes, and for organizing them in the 
drawing. It is described in detail in Chapter 2, Drawing Basic Shapes.

Figure 7: Drawing toolbar

Line and Filling toolbar
The Line and Filling toolbar (Figure 8) lets you modify the main properties of a drawing object. 
The icons and pull-down lists vary, according to the type of object selected. For example, to 
change the style of a line, click on the up and down arrows for Line Style and select the required 
style.

The available functions on the Line and Filling toolbar let you to change the color, style, and width 
of the line drawn, the fill color and style, and other properties of an object. The object must first be 
selected with a mouse click. If the selected object is a text frame, the Line and Filling toolbar 
changes to the Text Formatting toolbar (Figure 9).

Figure 8: Line and Filling toolbar

Text Formatting toolbar
The Text Formatting toolbar (Figure 9) is very similar to the Formatting toolbar in Writer. A more 
detailed explanation of the functions on this toolbar can be found in Chapter 4, Changing Object 
Attributes. For information on adding and formatting text, see Chapter 9 Adding and Formatting 
Text.

Figure 9: Text Formatting toolbar

Color bar
The Color bar (Figure 10) displays the current color palette. It lets you rapidly select the color of 
the various objects (lines, areas, and 3D effects) in your drawing. The first box in the panel 
corresponds to invisible (no color). If the Colors bar is not displayed go to View > Toolbars > 
Color Bar.
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Figure 10: Color bar

Figure 11. Changing the color palette

Choosing a color palette
You can access several specialized color palettes in Draw, as well as change individual colors to 
your own taste. This is done using the Area dialog (Figure 11) by selecting Format > Area on the 

main menu bar or clicking the Area icon  on the Line and Filling toolbar (Figure 8). On the 
Area dialog, select the Colors tab.

To load another palette, click on the Load Color List icon . The file selector dialog asks you to 
choose one of the standard LibreOffice palettes (files with the file extension *.soc). For example, 
web.soc is a color palette that is adapted to creating drawings for placing in web pages. These 
colors will display correctly on workstations with screens capable of at least 256 colors.

A more detailed description of color and their options can be found in Chapter 10 Advanced Draw 
Techniques.

Options toolbar
The Options toolbar (Figure 12) lets you activate or deactivate various drawing aids. The Options 
toolbar is not one of the toolbars displayed by default. To display it, select View > Toolbars > 
Options. The options are described briefly in Figure 13 and in greater detail in other chapters of 
this Draw Guide.

Figure 12: Options toolbar
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Figure 13: Tools available in Options toolbar

Drawing grid and guides

Draw offers a grid and snap lines as drawing aids and these can be turned on or off by clicking on 
the Display Grid or the Display Snap Lines icons on the Options toolbar. The grid points and the 
snap lines are displayed only on the screen and are not shown on a printed drawing or when the 
drawing is used in another LibreOffice program. The color, spacing, and resolution of the grid 
points can be individually chosen for each axis. This is described in more detail in Chapter 3 
Working with Objects and Object Points.

Help lines when moving objects can be displayed and these are turned on or off by clicking on the 
Helplines While Moving icon on the Options toolbar. Showing the position of the object while 
moving it makes positioning the object much easier. If this function is activated, pairs of vertical and 
horizontal lines enclosing the object are shown while moving the object. These lines extend to the 
edges of the drawing area. This function is also described in detail in Chapter 3 Working with 
Objects and Object Points.

Draw also offers several snap functions to help you can position objects exactly in a drawing and 
these snap functions are described in detail in Chapter 3 Working with Objects and Object Points.

Floating and moving toolbars

Available toolsets
Many icons have a small triangle or arrowhead pointing downward to the right side of the icon. This 
indicates that this icon has additional tools available. Click on the triangle to display the full set of 
tools (Figure 14). You can “tear off” this toolset so it becomes a floating toolbar. Click the area at 
the bottom of the toolset, drag it across the screen to a location you want, and then release the 
mouse button.

To close a floating toolbar, click on the X on the right of the toolbar title.

Note
When a toolset is made into a floating toolbar, the icon on the existing toolbar 
remains in the toolbar and always shows the last command you used. This means 
that the icon you see on your screen may differ from the icon shown in this guide.
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Figure 14: Available additional tools and floating toolbar

Tip

When you double-click on an icon on a toolbar, the command corresponding to that 
icon will become active. You can then repeat this action as often as you like. To exit 
from this mode, press the Esc key or click on another icon. Please note that this may 
not work for every icon on every toolbar.

Standard toolbars
When you open Draw, the default set of toolbars are already docked or fixed in their positions at 
the top and bottom of the workspace. This default set of toolbars normally are the Standard, Line 
and Filling, and Drawing toolbars. These toolbars can be undocked and become floating toolbars.

To undock a toolbar, move the mouse cursor to the far left of the toolbar and over the toolbar 
handle (Figure 15). The cursor will change shape, normally to a grabbing hand, but this is 
dependent on computer setup and operating system. Click and drag on the toolbar handle to move 
the toolbar until it becomes a floating toolbar. This floating-toolbar capability is common to all 
components of LibreOffice.

To dock a floating toolbar at the top of the Draw workspace, press and hold the Ctrl key then 
double click on the title of the toolbar. The toolbar will move into available space at the top of the 
Draw workspace.

An alternative method of docking a toolbar is to click in the toolbar title and drag the toolbar to the 
docked position that you require. This can be the top, bottom or one of the sides of the Draw 
workspace.

Figure 15: Toolbar handles
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Figure 16: Customizing toolbars

Customizing toolbars
You can customize toolbars in several ways. To show or hide icons defined for a toolbar, see 
Figure 5 on page 7.

To add functions to a toolbar, move tools between toolbars, or create new toolbars., select View > 
Toolbars > Customize, then select the Toolbars tab (Figure 16) and the toolbar you want to 
change. You can then select the desired tools for that toolbar.

Each toolbar has a different list of functions. For details, see the Getting Started Guide, which also 
describes how to customize menus.

Quick printing

To quickly print a document or drawing, click on the Print File Directly icon  to send the entire 
document to the default printer that is defined for your computer.

Note

You can change the action of the Print File Directly icon to send the document to 
the printer defined for the document instead of the default printer for the computer. 
Go to Tools > Options > Load/Save > General and select the Load printer 
settings with the document option.
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Controlling printing

For more control over printing, use the Print dialog (File > Print or Ctrl+P). The Print dialog 
(Figure 17) has four tabs where you can choose a range of options and these are described in the 
following sections.

Note
The options selected on the Print dialog apply to this printing of this document only. 
To specify default print settings for LibreOffice, go to Tools > Options > LibreOffice 
> Print.

Figure 17. Print dialog

General printing
On the General tab of the Print dialog (Figure 17), you can select:

• Which printer to use from the printers available in the Printer section.

• Which pages to print, number of copies to print, whether to collate multiple copies, and 
page order for printing in the Range and copies section.

Printing options
To access more printing options, click on the Options tab of the Print dialog (Figure 18). These 
printing options are self explanatory.

Figure 18: Printing Options dialog
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Figure 19: Page Layout dialog

Printing multiple pages on a single sheet
You can print multiple pages of a document on one sheet of paper. To do this:

1) Open the Print dialog and select the Page Layout tab (Figure 19).

2) In the Layout section, select from the drop-down list the number of pages to print per sheet. 
The preview panel on the right shows how the pages will look in the printed document.

3) When printing more than two pages per sheet, you can choose the order in which they are 
printed across and down the paper from the Order drop down list.

4) To distinguish each page on a sheet, select the Draw a border around each page option.

5) Click the Print button.

Selecting pages to print
In addition to printing a full document, you can choose whether to print individual pages, a range of 
pages, or a highlighted selection within a document.

To print an individual page:

1) Choose File > Print from the main menu bar or use the Ctrl+P key combination and select 
the General tab in the Print dialog (Figure 17).

2) In the Ranges and copies section, select the Pages option.

3) Enter the number of the page to print.

4) Click the Print button.

To print a range of pages:

1) Choose File > Print from the main menu bar or use the Ctrl+P key combination and select 
the General tab in the Print dialog (Figure 17).

2) In the Ranges and copies section, select the Pages option.

3) Enter the number of the pages to print (for example 1-4 or 1,3,7,11), or any combination of 
the two (for example: 1-4,5-9,10).

4) Click the Print button.

To print a selection from a page or multiple pages:

1) In the document, highlight the section of the page or pages to print.

2) Choose File > Print from the main menu bar or use the Ctrl+P key combination and select 
the General tab in the Print dialog (Figure 17).

3) In the Ranges and copies section, select the Selection option.

4) Click the Print button.
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Printing a brochure or booklet
In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of 
paper, arranged so that when the printed pages are folded in half, the pages are in the correct 
order to form a booklet or brochure.

Tip
Plan your document so it will look good when printed half size; choose appropriate 
margins, font sizes, and so on. You may need to experiment.

Single sided printer
To print a brochure or booklet on a printer only capable of single sided printing:

1) Choose File > Print and in the Print dialog, click on the Properties button to open the 
Properties dialog (Figure 20).

Figure 20: Printer Properties dialog

2) Check the printer is set to the same orientation (portrait or landscape) as specified in the 
page setup for your document. Usually the orientation does not matter, but it does for 
brochures and booklets.

3) Click OK to return to the Print dialog.

4) Select the Page layout tab in the Print dialog (Figure 19).

5) Select the Brochure option (Figure 21).

6) In the Page sides section, select Back sides / left pages option from the drop-down list.

7) Click the Print button.

Figure 21: Printing a brochure or booklet

8) Take the printed pages out of the printer, turn the pages over, and put them back into the 
printer in the correct orientation to print on the blank side. You may need to experiment a bit 
to find out what the correct arrangement is for your printer.

9) In the Page sides section, select Front sides / right pages option from the drop down list.

10) Click the Print button.
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Double sided or duplex printer
To print a brochure or booklet on a printer that is capable of double or duplex sided printing:

1) Choose File > Print and in the Print dialog, click on the Properties button to open the 
Properties dialog (Figure 20).

2) Check the printer is set to the same orientation (portrait or landscape) as specified in the 
page setup for your document. Usually the orientation does not matter, but it does for 
brochures and booklets.

3) From the Duplex drop down list, select Long Edge or Long Side printing. Actual options 
available for duplex printing do depend on printer model and the computer system being 
used.

4) Click OK to return to the Print dialog.

5) Select the Page layout tab in the Print dialog (Figure 19).

6) Select the Brochure option (Figure 21).

7) In the Page sides section, select All pages option from the drop-down list.

8) Click the Print button.

Printing in black and white or grayscale
You may wish to print documents in black and white or grayscale on a color printer. However, some 
color printers may only allow you to print in color regardless of the settings you choose. More 
details can be found in the information that came with your printer.

Figure 22: Printer Properties dialog

To change the printer settings to print in black and white or grayscale:

1) Choose File > Print to open the Print dialog (Figure 17).

2) Click Properties to open the Properties dialog for the printer. The available choices 
available depend on printer model and computer operating system, but you should easily 
find options for the Color settings. An example of what you may see is shown in Figure 22.

3) The choices for color may include black and white or grayscale. Choose the required 
setting.

4) Click OK to confirm your choice and return to the Print dialog,
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5) Click the Print button to print the document.

Tip
Grayscale is the best option if you have any colored text or graphics in the document. 
Colors will print in shades of gray giving more detail. When printing color in black and 
white some of this detail maybe lost.

To change the LibreOffice settings to print all color text and graphics as grayscale:

1) Choose Tools > Options > LibreOffice > Print.

2) Select the Convert colors to grayscale option. Click OK to save the change.

3) Open the Print dialog (File > Print).

4) Click the Print button to print the document.

To change the Draw settings to print all color text and graphics as black and white or grayscale:

1) Choose Tools > Options > LibreOffice Draw > Print.

2) In the Quality section, select either Grayscale or Black & white option.

3) Click OK to save the change.

4) Open the Print dialog (File > Print).

5) Click the Print button to print the document.

Exporting to PDF

LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file 
format is ideal for sending a file for someone else to view using Adobe Reader or other PDF 
viewers. The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few 
minor differences mentioned in this section.

Export directly as PDF

Click on the Export Directly as PDF icon  on the Standard toolbar to export the entire 
document using your default PDF settings. You are asked to enter the file name and location for 
the PDF file, but you cannot choose page range, image compression, or other options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, go to File > Export as PDF to 
open the PDF Options dialog. Using this dialog you select the options using different pages for 
General, Initial View, User Interface, Links, and Security. When you have selected the appropriate 
settings, click on Export. In the following dialog, enter the location and file name of the PDF to be 
created, then click Save to export the file. See in the Getting Started guide for more information.

Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. If you 
cannot find what you want in File > Save As, look in File > Export. LibreOffice can export files in 
various formats and these are listed in the drop down list for File format. See Chapter 6 Editing 
Pictures for more information on exporting graphics.

To export a file in another format:

1) Specify a file name for the exported document in the File name text box.

2) Select the required format from the File format drop down list.
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3) Click the Export button.

Note
The content of the exported file will depend on the element(s) selected on the page. 
No selection results in the entire image being exported. For most export formats, 
only the image on the current page will be exported.

Exporting Draw documents as web pages

To export a multi-page Draw document to a series of web pages, choose File > Export,  select 
HTML Document as the file type and the HTML Export wizard opens. Follow the prompts to create 
the web pages. If you wish, the wizard can generate a navigation aid to help in moving from page 
to page.

E-mailing documents

LibreOffice provides several ways to send documents quickly and easily as an e-mail attachment in 
OpenDocument format (LibreOffice default format), or as a PDF.

Note
Documents can only be sent from the LibreOffice menu if a mail profile has been set 
up.

To email the current document in OpenDocument format:

1) Choose File > Send > Document as E-mail. LibreOffice opens your default e-mail 
program with the document attached.

2) In your e-mail program, enter the recipient, subject, and any text you want to add, then 
send the e-mail.

To email the current document as a PDF, choose File > Send >-E-mail as PDF. LibreOffice 
creates a PDF using the default PDF settings and then opens your email program with the PDF file 
attached.

You can email a document to several recipients. For details, see the Getting Started guide.
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