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Who is this book for?

LibreOffice is a feature-rich, free, and open source office suite. It includes several powerful
applications for word processing, spreadsheets, presentations, graphics, databases, and formula
editing. Writer is the word-processing application. It is compatible with a wide range of document
formats including Microsoft Word (.doc, .docx), and you can export your work in several formats
including PDF.

Anyone who wants to get up to speed quickly with Writer will find this book valuable. You may be
new to word processing software, or you may be familiar with another office suite.

What’s in this book?

This book introduces the main features of Writer, the word processor component of LibreOffice,
and provides instructions for their use.

Minimum requirements for using LibreOffice

For a detailed list of requirements and operating systems supported, see the LibreOffice website,
https://www.libreoffice.org/get-help/system-requirements/.

How to get LibreOffice

Versions of LibreOffice Community for Windows, Linux, and macOS are freely available and can
be downloaded from https://www.libreoffice.org/download. Linux users will also find a version of
LibreOffice included by default in the majority of Linux distributions. Portable and other versions
of LibreOffice are listed on the download page. Linux, Enterprise, Online, and other versions may
differ in appearance and functionality from the descriptions in this book.

Installing LibreOffice

Information on installing and setting up LibreOffice on the various supported operating systems is
given here: https://www.libreoffice.org/get-help/install-howto/.

Setting up and customizing LibreOffice

You can change the default settings (options) in LibreOffice to suit your preferences. To change
settings, go to Tools > Options on the Menu bar (LibreOffice > Preferences on macOS).
Settings are described in the Help and in Chapter 2, Setting up LibreOffice, in the Getting Started
Guide. Some settings of particular interest to users of Writer are covered in Chapter 20, Setting
up Writer, in this book.

ﬂTip

Many settings are intended for power users and programmers. If you do not
understand what an option does, we recommend leaving it on the default setting
unless instructions in this book recommend changing the setting.

You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and
toolbars, and assign macros to events. See Chapter 20, Customizing Writer, for details.
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Extensions and add-ons

You can add functionality to LibreOffice with extensions and add-ons. Several extensions are
installed with the program and you can get others from the official extensions repository,
https://extensions.libreoffice.org/ and from other sources. See Chapter 20, Customizing Writer,
for more information on installing extensions and add-ons.

Where to get more help

This book, the other LibreOffice user guides, the Help system, and user support systems assume
that you are familiar with your computer and basic functions such as starting a program, opening
and saving files.

Help system

LibreOffice comes with an extensive online Help system. This is your first line of support.
Windows and Linux users can choose to download and install the offline Help for use when not
connected to the Internet; the offline Help is installed with the program on macOS.

To display the Help system, press F1 or select Help > LibreOffice Help on the Menu bar. If you
do not have the offline help installed on your computer and you are connected to the Internet,
your default browser will open the online Help pages on the LibreOffice website.

The Help menu includes links to other LibreOffice information and support resources. Notice that
options marked with a 1 sign are only accessible if your computer is connected to the Internet.

What's This? For quick tips when a toolbar is visible, place the mouse pointer over any of
the icons to see a small box (“tooltip”) with a brief explanation of the icon’s function. For a
more detailed explanation, select Help > What's This? and hold the pointer over the

icon. In addition, you can choose whether to activate Extended Tips using Tools >
Options > LibreOffice > General.

User Guides * Opens your default browser at the Documentation page of the LibreOffice
website https://documentation.libreoffice.org/en/. There you will find user guides (to
download as free PDFs or buy as printed copies) and other useful information.

Show Tip of the Day Opens a small window with a random tip on how to use LibreOffice.

Search Commands Opens a window where you can type a few letters or the name of a
Menu bar command, to quickly find where the command is located. Clicking on a
command in the resulting list may open a relevant dialog or have other effects.

Get Help Online * Opens your default browser at the Ask LibreOffice forum of questions
and answers from the LibreOffice community https://ask.libreoffice.org/en/questions/.

Send Feedback * Opens your default browser at the Feedback page of the LibreOffice
website https://www.libreoffice.org/get-help/feedback/. From there you can report bugs,
suggest new features and communicate with others in the LibreOffice community.

Restart in Safe Mode Opens a dialog where you can restart LibreOffice and reset the
software to its default settings.

Get Involved * Opens your default browser at the Get Involved page of the LibreOffice
website, https://www.libreoffice.org/community/get-involved/. There you can choose a
topic of interest to help improve the program.

Donate to LibreOffice * Opens your default browser at the Donation page of the
LibreOffice website https://donate.libreoffice.org/.

License Information Outlines the licenses under which LibreOffice is made available.
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« Check for Updates * Opens a dialog and checks the LibreOffice website for updates to
your version of the software.

* About LibreOffice Opens a dialog and displays information about the version of
LibreOffice and the operating system you are using. This information will often be
requested if you ask the community for help or assistance with the software. (On macQOS,
this option is found under LibreOffice on the Menu bar.)

Other free online support

The LibreOffice community not only develops software, but provides free, volunteer-based
support. See Table 1 and this web page: https://www.libreoffice.org/get-help/.

For comprehensive online support from the community, look at mailing lists and the Ask
LibreOffice website, https://ask.libreoffice.org/en/questions/. Other websites run by users also
offer free tips and tutorials.

Table 1: Free support for LibreOffice users

Free LibreOffice support

Answers to frequently asked questions

FAQs https://wiki.documentfoundation.org/Faq

Free community support is provided by a network of
Mailing lists experienced users
https://www.libreoffice.org/get-help/mailing-lists/

Free community assistance is provided in a question & answer
) format. Search similar topics or ask a new question in
Questions & https://ask.libreoffice.org/en/questi
Answers and ps: as. . |.reo |f:e.org. en/questions .
Knowledge Base The service is available in several other languages; just replace
/en/ with de, es, fr, ja, ko, nl, pt, tr, and many others in the web
address above.

The LibreOffice website in various languages
https://www.libreoffice.org/community/nic/

Mailing lists for native languages
https://wiki.documentfoundation.org/Local_Mailing_Lists
Information about social networking

https://wiki.documentfoundation.org/Website/Web_Sites_servic
es

Native language
support

Information about available accessibility options.

Accessibility options https://www.libreoffice.org/get-help/accessibility/

Paid support and training

You can also pay for support through service contracts from a vendor or consulting firm
specializing in LibreOffice. For information about certified professional support, see The
Document Foundation’s website: https://www.documentfoundation.org/gethelp/support/.

For schools, educational and research institutions, and large organizations, see
https://www.libreoffice.org/download/libreoffice-in-business/.
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What you see may be different

lHlustrations

LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several
versions and can be customized by users (fonts, colors, themes, window managers). The
illustrations in this guide were taken from a variety of computers and operating systems.
Therefore, some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may be different because of the settings selected in LibreOffice. You
can either use dialogs from your computer’s operating system or from LibreOffice. The
differences affect mainly Open, Save, and Print dialogs. To change which dialogs are used, go to
Tools > Options > LibreOffice > General and select or deselect the option Use LibreOffice
dialogs.

Icons

The LibreOffice community has created icons for several icon sets: Breeze, Colibre, Elementary,
Karasa Jaga, Sifr, and Sukapura; some are also available in a dark version. As a user, you can
can select your preferred set. The icons in this guide have been taken from a variety of
LibreOffice installations that use different sets of icons. The icons for some of the many tools
available in LibreOffice may differ from the ones used in this guide.

To change the icon set used, go to Tools > Options > LibreOffice > View. In the Icon Style
section, choose from the drop-down list.

Notes

Some Linux distributions include LibreOffice as part of the installation and may not
include all the icon sets mentioned above. You should be able to download other
icon sets from the software repository for your Linux distribution.

The Galaxy, Oxygen, and Tango icon sets are no longer included as part of the
standard installation package for Windows, macOS, or Linux. You can download and
install them as extensions from https://extensions.libreoffice.org/en/extensions/.

In addition, some of the previously included gallery sets are now available only as
extensions; see https://extensions.libreoffice.org/?Tags%5B%5D=49 or search for
specific ones. For example, the People Gallery is available from
https://extensions.libreoffice.org/en/extensions/show/people-gallery

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and
Linux. The table below gives some common substitutions for the instructions in this chapter. For
a more detailed list, see the application Help.

Windows or Linux macOS equivalent Effect

Tools > Options LibreOffice > Preferences Access setup options

menu selection

Right-click Control+click and/or right-click  Opens a context menu
depending on computer setup

Ctrl (Control) 3 (Command) Used with other keys

F11 B+T Open the sidebar Styles deck
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Frequently asked questions

How is LibreOffice licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public
License (MPL). See https://www.libreoffice.org/about-us/licenses/

It is based on code from Apache OpenOffice made available under the Apache License 2.0
but also includes software that differs from version to version under a variety of other Open
Source licenses. New code is available under LGPL 3.0 and MPL 2.0.

May | distribute LibreOffice to anyone? May | sell it? May | use it in my business?
Yes.

How many computers may | install it on?
As many as you like.

Why do | need Java to run LibreOffice? Is it written in Java?
LibreOffice is not written in Java; it is written in the C++ language. Java is one of several
languages that can be used to extend the software. The Java JDK/JRE is only required for
some features. The most notable one is the HSQLDB relational database engine.

Java is available at no cost. More information and download links to the appropriate edition
for your operating system can be found at: https://java.com/en/download/manual.jsp

Note

If you want to use LibreOffice features that require Java, it is important that the
correct 32-bit or 64-bit edition matches the installed version of LibreOffice. See the
Advanced Options in Chapter 2 of this guide. If you do not want to use Java, you can
still use nearly all of the LibreOffice features.

How can | contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you
do not need to be a programmer. To start, check out this web page:
https://www.libreoffice.org/community/get-involved/.

May | distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement
at the beginning of this book. You do not have to request special permission. We request
that you share with the project some of the profits you make from sales of books, in
consideration of all the work we have put into producing them. Visit
https://www.libreoffice.org/donate/ for instructions on how to donate to LibreOffice.

What’s new in this user guide?

LibreOffice 7.2 Community includes many changes not visible in the user interface. These
changes include improved interoperability with Microsoft’s proprietary file formats and
performance improvements in handling large files, opening certain .docx and .xIsx files,
managing font caching, and opening presentations and drawings that contain large images.

More information is in the announcement:
https://blog.documentfoundation.org/blog/2021/08/19/libreoffice-7-2-community/.
Release Notes are here: https://wiki.documentfoundation.org/ReleaseNotes/7.2.

This user guide has been updated from Writer Guide 7.1. It covers changes that are visible in the
user interface, including:

* Added a note about icon sets and Gallery sets in this Preface.
* Added details about the Insert > Formatting Mark submenu (Chapter 2).
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Updated list terminology and changed screenshots in Chapters 4, 8, 9, 11, and anywhere
else lists are mentioned.

Added new gutter margins and choices for page background fills (Chapters 5, 6, and 9).
Updated details about some options on tabs of the PDF Options dialog (Chapter 7).
Added new, advanced features of the Style Inspector (Chapter 9)

Updated details about Templates dialog (Chapter 10).

Added “no registered database” error message in Mail Merge Wizard (Chapter 14).
Added information on classifying document contents (Chapter 17).

Added Basic Fonts options and custom dictionaries (Chapter 20).

New Chapter 21 on user interface variants.

Minor rewording, updates to terminology, and replacement figures in many chapters.
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Introduction — What is Writer?

Writer is the word processor component of LibreOffice, a freely available, fully-featured office
productivity suite. In addition to the usual features of a word processor (text entry, editing, and
formatting; spelling checker, thesaurus, hyphenation, and autocorrect; find and replace; and
others), Writer provides these important features:

* Change tracking during revisions (Chapter 4)

* Page layout methods, including styles, frames, columns, and tables (Chapters 5 and 6)
» Export to PDF and ePub (Chapter 7)

* Document digital signatures (Chapter 7)

+ Templates and styles (Chapters 8, 9, and 10)

* Built-in drawing tools (Chapter 11)

» Lists (Chapter 12)

* Tables of data (Chapter 13)

* Mail merge (Chapter 14)

* Automated tables of contents and indexes (Chapter 15)

* Master documents, to group a collection of documents into a single document (Chapter
16)

* Fields and forms (Chapters 17 and 18)

» Database integration, including a bibliography database (Chapters 14, 15, and 18)
* Embedding or linking of spreadsheets, equations, and other objects (Chapter 19)
* And many more

Parts of the main Writer window

The main Writer window is shown in Figure 1. Its features are described in this section.

Note

By default, LibreOffice Writer's commands are grouped in menus and toolbars, as
described in this section. In addition, Writer provides other user interface variations,
displaying contextual groups of commands and contents. For more information, see
“Notebook bar” in the Help and Chapter 20, Customizing Writer.

Title bar

The Title bar is located at the top of the Writer window. It shows the file name of the current
document. When the document is not yet named, the document name will appear as Untitled X,
where X is a number. Untitled documents are numbered in the order in which they are created.

Menu bar

The Menu bar is located just below the Title bar in Windows and Linux and at the top of the
screen in macOS. When you select one of the menus, a submenu drops down to show further
options, including:

» Commands that directly cause an action, such as Close or Save, in the File menu.

* Commands that open dialogs. These are indicated by three dots following a command,
such as Find... in the Edit menu.
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+ Commands that open further submenus. These are indicated by a right-pointing arrow
following a command, such as Toolbars and Zoom, in the View menu. Moving the
cursor onto one of these items causes its submenu to open.
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Figure 1: Parts of the main Writer window

Sidebar

The Sidebar is normally open by default on the right side of the Writer window, as shown in
Figure 1. If necessary, select View > Sidebar on the Menu bar to display it. The Sidebar also has
a Hide/Show icon, as shown in Figure 2. When the Sidebar is closed, it can be opened by
clicking this icon, which will be on the far right side of the window.

The Writer Sidebar contains six decks by default: Properties, Page, Styles (also shown as Styles
and Formatting in some installations), Gallery, Navigator, and Style Inspector. Each deck can be
opened by clicking its corresponding icon on the Tab bar to the right of the sidebar.

Two additional decks are available when Experimental Features is enabled in Tools > Options
> LibreOffice > Advanced: Manage Changes and Design. These decks are not covered in this
book.

Each deck consists of a title bar and one or more content panels. A panel is like a combination of
toolbar and dialog. Toolbars and Sidebar panels share many functions. For example, the icons
for making text bold or italic exist in both the Formatting toolbar in the main Writer window and
the Character panel of the Properties deck.

Some panels contain a More Options button, which opens a dialog with additional editing
controls. When the dialog is open, the document is locked for other editing.

To adjust the width of the Sidebar, place the cursor on its left edge. When a double-headed arrow
appears, click and drag to right or left. When the Properties deck is open, you cannot make the
Sidebar smaller than a certain width. When any other deck is open, the Sidebar can be collapsed
to the width of its Tab bar.
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To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the drop-down list
in the Sidebar Settings above the Tab bar (see Figure 3). From the same list, you can use the

Customization menu to choose which tabs you want to include in the Sidebar.

Properties

| Sidebar settings

Style
Text Body  Title bar

Character E >

® Tahs
Liberation Sans 8 up 8 0
BI|U-5 S N
) &

« M. AN x x .

A-%- b il More Options

Paragraph

Panel title

Hide/show

button ' Panel contents

| Deck

Figure 2: Properties deck of Sidebar
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Figure 3: Sidebar Settings menu
Sidebar decks
The decks contained in the Sidebar are described below.
Properties deck: Contains tools for directly formatting content.
When text is selected, these panels appear:
— Style: Apply, create, or update a paragraph style.

— Character: Modify text properties such as the font name, size, color, weight, or

character spacing.
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— Paragraph: Modify a paragraph’s alignment, background color, indent, and spacing,
and toggle numbered or bulleted lists.

When the cursor is in a table, this panel appears in addition to the panels for text.

— Table: Modify table properties such as insert or delete rows, merge or split cells,
define row height and column width, background color, and borders.
When a graphic or image is selected, these panels appear:

— Area: Modify the fill mode and transparency of the background.
— Image: Modify the graphic's brightness, contrast, color mode, or transparency.

— Wrap: Modify the position of the graphic relative to surrounding text, where these
modifications are available.

— Position and Size: Modify width, height, rotation, or flip.
When a drawing object is selected, these panels appear:

Area: Modify the fill mode and transparency of the background.
Effect: Add and adjust a Glow or Soft Edge effect to the object.
Line: Modify arrows, line style, width, color, or transparency.
Position and Size: Modify width, height, rotation, or flip.

When a frame is selected, these panels appear:

— Area: Modify the fill mode and transparency of the background.
— Wrap: Modify the position of the graphic relative to surrounding text, where these
modifications are available.

When a video or audio clip is selected, these panels appear:

— Media Playback: Control for play, pause, stop, seek, loop, and volume.
— Position and Size: Modify width and height.
Styles deck: Manage the styles used in the document, apply existing styles, create new styles,

or modify them. For more information, see Chapter 8, Introduction to Styles, and Chapter 9,
Working with Styles.

Gallery deck: Shows images and diagrams included in the Gallery themes. The Gallery has two
sections: the first lists the themes by name (Arrows, Bullets, Diagrams, and so on) and the
second displays the images in the selected theme. For more information on using the Gallery to
add images to a document, create new themes and add your own images, see Chapter 11,
Images and Graphics.

Navigator deck: Browse the document and reorganize its content by selecting content
categories, such as headings, tables, frames, images, and so on. For more information, see
“Using the Navigator” on page 34.
Page deck: Contains tools for directly formatting the page style. It has four panels:
— Format: Modify the size, width, height, orientation, and margins of the page.
— Styles: Maodify the page numbering style, background, layout, and number of columns.
— Header: Activate/deactivate the header and modify its margins, spacing, and contents.
— Footer: Activate/deactivate the footer and modify its margins, spacing, and contents.

Caution

Be aware that by changing the options on the Page deck, you will change the page
style in use, modifying not only the current page but all pages using the same page
style in this document.
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Style Inspector deck: Displays all the attributes of paragraph styles, character styles, and
manual (direct) formatting for selected text. For more information, see Chapter 7, Working with
Styles.

Toolbars

LibreOffice has two types of toolbar locations: docked (fixed in place) or floating. Docked toolbars
can be moved to different locations (for example, top, bottom, or side of the workspace) or made
to float. Floating toolbars can be docked.

Displaying or hiding toolbars
To display or hide toolbars, go to View > Toolbars on the Menu bar, then click the name of a

toolbar in the drop-down list. An active toolbar shows a check mark beside its name. Note that
toolbars created from tool palettes are not listed in the View menu.

To hide a toolbar, go to View > Toolbars on the Menu bar and deselect the toolbar, or right-click
in an empty space between the icons on a toolbar and select Close toolbar in the context menu.

Most-used toolbars

In a default LibreOffice installation (Figure 1), the top toolbar, just under the Menu bar, is called
the Standard toolbar.

The second toolbar at the top is the Formatting toolbar. It is context-sensitive; that is, it shows the
tools relevant to the current position of the cursor or the selected object. For example, when the
cursor is in text, the Formatting toolbar provides tools for formatting text. When the cursor is on a
graphic (image), the tools are for formatting images.

To free more space for the document, you can choose a single-toolbar alternative containing the
most-used commands. To activate it, select View > User Interface > Single Toolbar.

Other toolbars are available at View > Toolbars. They are discussed in the relevant chapters of
this book.

Sub-menus and tool palettes

Toolbar icons with a small triangle to their right will display sub-menus, tool palettes, or other
methods of selecting items, depending on the icon.

Atool palette is a pop-up collection of tools attached to a single tool in a toolbar. The palette can
be made into a floating toolbar, as shown in Figure 4. Once removed from the parent toolbar, it
displays a Title bar. Tool palettes can be floating or docked along an edge of the screen or in one
of the existing toolbar areas.

| ™—___ Click here and drag to create a

|
Q Q Q Q Q g floating toolbar from a tool palette
Basic Shapes v X
o EeNesV
ALOGQOO® 00 0a
SIFFOO0 aneee0
¢-@-=-%-F sIPFEO

Figure 4: Example of tearing off a tool palette
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Moving toolbars

Docked toolbars can be undocked and either moved to a new docked position or left as a floating
toolbar.

To undock a toolbar:

1) Move the mouse cursor over the toolbar handle, which is the small vertical bar to the left
of a docked toolbar, as shown in Figure 5.

2) Hold down the left mouse button and drag the toolbar to a new location.
3) Release the mouse button.

File Edit View |Inset Format
:‘ v [0 »w iq - {f E? qﬂ
4 | Default Style v || (&5

Figure 5: Toolbar handles

To move a floating toolbar, click its title bar and drag it to a new floating location or dock the
toolbar at the top or bottom of the main window.

Note

You can also dock a floating toolbar by holding down the Ctrl key and double-clicking
in the title bar of the toolbar.

O ip
If the toolbar handle is not displayed, its position is locked. To unlock the toolbar,
right-click it and then deselect the option Lock Toolbar Position.

Floating toolbars

Writer includes several toolbars, whose default settings correspond to the current position of the
cursor or selection (when toolbars are made active). For example, when the cursor is in a table,
the Table toolbar appears, and when the cursor is in a numbered or bulleted list, the Bullets and
Numbering toolbar appears. You can reposition or dock these toolbars as described in “Moving
toolbars” above.

Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and
locking the position of a docked toolbar. You can also add icons and create new toolbars, as
described in Chapter 20, Customizing Writer.

To position the toolbar:

— Right-click somewhere in the floating toolbar and click Dock Toolbar, in the context
menu, to dock the selected floating toolbar. By default, a toolbar will dock at the top of
the workspace. You can reposition the toolbar to a different docked position. See
“Moving toolbars” on page 22.

— Click Dock All Toolbars to dock all floating toolbars.

— Click Lock Toolbar Position to lock a docked toolbar into its docked position. Locking
maintains the toolbar’s position even when other toolbars on the same bar change
location.

— Click Close Toolbar to close the selected toolbar.
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You can access a toolbar’s customization options by right-clicking in an empty space between
the icons on the toolbar to open a context menu. Then choose among the following options:

» To show or hide icons defined for the selected toolbar, click Visible Buttons on the
context menu. Visible icons on a toolbar are indicated by an outline around the icon
(Figure 6) or by a check mark beside the icon, depending on your operating system.
Select or deselect icons to hide or show them on the toolbar.

* Click Customize Toolbar to open the Customize dialog. See Chapter 20, Customizing

Writer, for more information.
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Figure 6: Toolbar context menu and selection of visible toolbar icons

Rulers

The harizontal ruler across the top of the workspace is visible by default but the vertical ruler on
the left is hidden by default. To enable the vertical ruler, choose View > Rulers > Vertical Ruler
on the Menu bar, or choose Tools > Options > LibreOffice Writer > View. To quickly show or
hide both rulers, use the key combination Ctr/+Shift+R.

ﬂTip

The horizontal ruler has a comments button on its right end; click this to quickly show
or hide any comments.

Status bar

The Writer Status bar is located at the bottom of the workspace. It provides information about the
document and convenient ways to quickly change some document features. It can be hidden by
deselecting it in the View menu.
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Figure 7: Writer Status bar

Document changes status
This icon changes when the document has been modified but not saved. Clicking this icon
saves the document.

Page nhumber
Shows the sequence number of the current page, the total number of pages in the
document, and the current page number (if different from the sequence number). For
example, if page numbering is restarted at 1 on the third page of a 6-page document, the
sequence number is 3, the total number of pages is 6, and page number is 1, as shown in
Figure 7.

If any bookmarks have been defined in the document, right-clicking this field will show a list
of bookmarks. Click a bookmark to move the cursor to that location in the document.

To jump to a specific page in the document, left-click this field to open the Go to Page
dialog (Figure 8). Type the desired page number and click OK.

Go to Page >

Page: m of 25

OK Cancel

Figure 8: Go to Page dialog

Word and character count
The word and character counts of the document are shown in the Status bar, and are
updated as you edit. If you select a portion of text, the count for that selection will
temporarily replace the document total count.

What now? What now?
Docking a boat. Docking a Hoat.

11 words, 50 characters 3 words, 8 characters selected

By default, the character count includes spaces. To display the character count excluding
spaces, click on the word count in the Status bar, or choose Tools > Word Count.

You can also see the number of words and characters (and other information including the
number of pages, tables, and images) in the entire document in File > Properties >
Statistics.
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Page style
Shows the page style of the current page. To select a different page style, right-click on this
field. A list of page styles pops up; click on one to select it. To edit the attributes of the
current page style, left-click on this field. The Page Style dialog opens.

Caution

Changing the page style here may affect the styles of other pages, depending on
how the page styles are set up. See Chapters 8 and 9 for details about styles.

Text Language
Shows the language and localization used for spelling, hyphenation, and the thesaurus. It
is based on the position of the cursor or the selected text.

Click to open a menu where you can choose another language/localization for the selected
text or for the paragraph where the cursor is located. You can also choose None (Do not
check spelling) to exclude the text from a spelling check or Reset to default language.
Choosing More... opens the Character dialog. See Chapter 3, Working with Text: Basics,
for more information.

Insert mode
This area is blank when in Insert mode. Click to change to Overwrite mode; click again to
return to Insert mode. In Insert mode, any text after the cursor position moves forward to
make room for the text you type; in Overwrite mode, text after the cursor position is
replaced by the text you type. This feature is disabled when Edit > Track Changes >
Record is activated.

Selection mode
Click to cycle between the selection modes (Standard, Extending, Adding, and Block). The
icon does not change, but when you hover the mouse pointer over this field, a tooltip
indicates which mode is active.

When you right-click this field, a context menu displays the available options. See Chapter
3, Working with text: Basic, for details.

Digital signature
If the document has been digitally signed, an icon is displayed here; otherwise, it is blank.
Click here to sign the document or to view the existing certificate. See Chapter 8, Printing,
Exporting, Emailing, for more information.

Section or object information
When the cursor is in a section, heading, or list item, or when an object (such as a picture
or table) is selected, information about that item appears in this field. Clicking in this area
opens a relevant dialog.

Object Information shown Dialog opened
Image Size and position Image
List item Level and list style Bullets and Numbering*
Heading Outline numbering level Bullets and Numbering*
Table Name or number and cell reference of
cursor Table Format
Section Name of section Edit Sections
Other (Blank) Fields

1

If a list style was used with a list item or heading, no dialog appears.

Parts of the main Writer window | 25



View layout
Click the corresponding icon to change between single-page, multiple-page, and book
layout views (Figure 9). You can edit the document in any view. Zoom settings interact with
the selected view layout and the window width to determine how many pages are visible in
the document window.

|..i..-i.|i ._|_|_. .I|..|

1 1 2 1

Figure 9: View layouts: single-page, multiple-page, book

Zoom
To change the view magnification, drag the Zoom slider, or click the + and - signs, or right-
click the zoom level percent to pop up a list of magnification values from which to choose.
Zoom interacts with the selected view layout to determine how many pages are visible in
the document window.

- { + | 100%

Context (right-click) menus

Context menus provide quick access to many menu functions. They are opened by right-clicking
on a paragraph, graphic, or other object. When a context menu opens, the functions or options
available will depend on the object that has been selected. This can be the easiest way to reach
a function, especially if you are not sure where the function is located in the menus or toolbars.

Dialogs

A dialog is a special type of window. Its purpose is to inform you of something, or request input
from you, or both. It provides controls for you to specify how to carry out an action.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog
remains open. When you close the dialog (usually, clicking OK or a similar button saves your
changes and closes the dialog; clicking Cancel closes the dialog without saving any changes),
then you can again work with the document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog
and your document. An example of this type is the Find & Replace dialog.
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Document views

Writer has three ways to view and edit a document: Normal, Web, and Full Screen. To change
the view, go to the View menu and click the required view.

You can also choose View > Zoom > Zoom on the Menu bar to display the Zoom & View Layout
dialog, where you can set the same options as on the Status bar.

You can also use File > Print Preview, or press Ctrl+Shift+O, to view the document, but this view
does not allow editing. See “Previewing pages before printing” in Chapter 7, Printing, Exporting,
Emailing.

Normal view

Normal view is the default view in Writer. It shows how the document will look when you print it or
create a PDF. In this view, you can use the Zoom slider and the View Layout icons on the Status
bar to change the magnification.

In Normal view, you can hide or show the headers and footers and the gap between pages. To
hide them, uncheck View > Show Whitespace on the Menu bar. A check mark beside this option
indicates that whitespace will be shown. When this option is unchecked, white space, headers,
and footers are also hidden in Full Screen view.

Web view

Web view shows how the document will look if viewed in a Web browser; this is useful when you
create HTML documents. In Web view, you can use only the Zoom slider. The View Layout icons
on the Status bar are disabled, and most of the choices on the Zoom & View Layout dialog are
not available.

Full Screen view

In this view, no toolbars or sidebar are displayed; the document takes up the full area available,
using the zoom and layout settings previously selected. To exit Full Screen view and return to
either Normal or Web view, press the Esc key or click the Full Screen icon on the floating toolbar
in the top left-hand corner. You can also use Ctr/+Shift+J to enter or exit Full Screen view.

Creating a new document

You can create a new, blank document in Writer in several ways. If a document is already open in
LibreOffice, the new document is created in a new window.

From the operating system menu

You can open the LibreOffice Start Center or the Writer component from the operating system
menu in the same way that you start other programs. When LibreOffice was installed on your
computer, in most cases a menu entry for each component was added to the system menu. On
macQOS, the LibreOffice icon will be in the Applications folder. When you double-click this icon,
LibreOffice opens at the Start Center (Figure 10).

From the Start Center

When LibreOffice is open but no document is open, the Start Center (Figure 10) is shown. Click
Create: Writer Document to create a new text document, or click Templates and choose a
template to start a new document using a template other than the default template.

Creating a new document | 27



From the Menu bar, toolbar, or keyboard
When Writer is open, you can also start a new Writer document in one of these ways:
* Press the Ctrl+N keys.

¢ Choose File > New > Text Document on the Menu bar.
¢ Click the New icon on the Standard toolbar.

Remote Files

Recent Documents v

C.lmwﬁ
Templates - m;ﬂeifam Here

Create:

N\
X ;
Writer Document
Calc Spreadsheet WG7120-SetUpCustomize-01-JHW LibreOffice_7.x_Template

o ]
Impress Presentation

5] -
Draw Drawing

@ Math Formula

Base Database
Figure 10: LibreOffice Start Center

From a template

Atemplate is a set of predefined styles and settings that is used to create a new document.
Templates enable the easy creation of multiple documents with the same default settings. For
example, all the chapters of the Writer Guide are based on the same template. As a result, all the
chapters look alike; they have the same headers and footers, use the same fonts, and so on.

A new LibreOffice installation may contain only a few templates, but you can create your own or
download more from https://extensions.libreoffice.org/ and other websites. See Chapter 10,
Working with Templates.

To open the Template dialog, where you can choose the template you want to use for creating
your document, do one of the following:

* Press the Ctrl+Shift+N keys.

* Choose File > Templates > Manage Templates on the Menu bar.

* Choose File > New > Templates on the Menu bar.

* Click the arrow next to the New icon on the Standard toolbar and select Templates in the
drop-down list.

The example shown in Figure 11 highlights a template in the Documents folder. Double-click the
desired template to create a new document based on the that template. You can also right-click
one of the templates and then click Open. For more about the Templates dialog, see Chapter 10,
Working with Templates.
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Figure 11: Creating a document from a template

Opening an existing document

You can open an existing document in several ways.

When no document is open:

Click Open File or Remote files in the Start Center.

Choose File > Open or File > Open Remote on the Menu bar.
Press Ctrl+O on the keyboard.

Click the Open icon on the Standard toolbar.

Double-click a thumbnail of recently opened documents displayed in the Start Center.
You can scroll up or down in the Start Center to locate a recently opened document.

If a document is already open:

Click the Open icon on the Standard toolbar and select the additional document to be
opened in the Open dialog.

Click the small triangle to the right of the Open icon and select from a list of recently
opened documents.

Use File > Recent Documents to make a selection.
Choose Open Document on the Quickstarter.

When using the Open dialog, navigate to the folder you want, select the file you want, then click
Open. If a document is already open in LibreOffice, the second document opens in a new
window.

You can reduce the list of files in the Open dialog by selecting the type of file you are looking for.
For example, if you choose Text documents as the file type, you will only see documents Writer
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can open. This method opens Word (.doc and .docx) files and other formats as well as
OpenDocument (.odt).

You can also open an existing Writer document using the same methods you would use to open
any document in your operating system.

If you have associated Microsoft Office file formats with LibreOffice, you can also open these files
by double-clicking on them in the file explorer. See the LibreOffice Help for more about file
associations.

Saving a document

You can save a document using either the Save commands or the Save as command.

Save commands

Save a new file or a previously-saved file
Do one of the following:
* Press Ctrl+S.
* Choose File > Save on the Menu bar.
* Click the Save icon on the Standard toolbar.

If the file has not been saved previously, a Save As dialog appears after selecting one of the
above options. Enter the file name, verify the file type and location, and click Save.

If a previously-saved file is being saved with the same file name, file type, and location, nothing
else needs to be done.

Save to a remote server

Use this command if your document is already stored on a remote server or you want to store it
on a remote server. Choose File > Save Remote. When the Save As dialog appears, enter or
verify the name, type, and location, then click Save.

See “Opening and saving files on remote servers” on page 33 for more information.

Save a copy

Use this command if you want to keep the document open for more editing and also save a
separate copy of the current version.

Choose File > Save a Copy. When the Save As dialog appears, enter or verify the name, type,
and location, then click Save. The copy is not opened and the original file remains open and
active.

Save all
Use this command to save all files open in the current session.

Choose File > Save All. All open files will be saved without changes to name, type, or location.

Save As

Use this command if you want to save the current version as a new document by changing the
file name or file type, or by saving the file in a different location on your computer.

Choose File > Save As, or use Ctrl+Shift+S to open a Save As dialog where you can change the
file name, type, or location, and click Save.

If you want to preserve the original file, first save a copy as described above.
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Note

LibreOffice uses the term “export” for some file operations involving a change of file
type, such as PDF and ePub. See Chapter 7, Printing, Exporting, E-mailing, for more
information.

Saving a document automatically

You can choose to have Writer save your document automatically in a temporary file at regular
intervals. To set up automatic file saving:

1) Select Tools > Options > Load/Save > General. (See also Chapter 20, Setting Up
Writer.)

2) Click Save AutoRecovery information every and set the time interval. The default value
is 10 minutes. Enter the value you want by typing it or by pressing the up or down arrow
keys.

3) You may also wish to select Always create backup copy.

4) Click OK to save the changes.

Saving as a Microsoft Word document

To exchange files with users of Microsoft Word, you can save a document in a format such as
.docx.

1) Important: First save your document in the file format used by LibreOffice Writer, .odt. If
you do not, any changes you made since the last time you saved will only appear in the
Microsoft Word version of the document.

2) Then click File > Save As.

3) On the Save As dialog, in the File type (or Save as type) drop-down menu, select the
type of Microsoft Word format you need. You may also choose to change the file name.

4) Click Save.

From this point on, all changes you make to the document will occur only in the new (Microsoft
Word) document. If you want to go back to working with the .odt version of your document, you
must open it again.

ﬂTip

To set the default file format used by LibreOffice Writer to save files, go to Tools >
Options > Load/Save > General. In the section named Default File Format and
ODF Settings, next to Document type, select Text document, then next to Always
save as, select your preferred file format.

Using password protection and OpenPGP encryption

LibreOffice provides two types of document protection: password protection and OpenPGP
encryption. Files encrypted with the Save password cannot be decrypted without the password,
which must be sent to each user who needs to decrypt the document. With OpenPGP encryption,
the document is encrypted using an algorithm, which requires a key. Each key is used only once
and is sent to the recipient along with the document.

Password protection

Writer provides two levels of password protection: read-protect (file cannot be viewed without a
password) and write-protect (file can be viewed in read-only mode but cannot be changed
without a password). Thus you can make the content available for reading by one group of
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people and for reading and editing by a different group. This behavior is compatible with
Microsoft Word file protection.

To protect a document with passwords:

1) Use File > Save As when saving the document. (You can also use File > Save the first
time you save a new document.)

2) On the Save As dialog, select the Save with password option in the lower left corner
(Figure 12), and then click Save.

File name: WG7101-IntroducingWriter

File type: ODF Text Document (.odt)

Save with password Automatic file name extension
Encrypt with GPG key

Edit filter settings

Figure 12: Save with password and Encrypt with GPG key options
3) The Set Password dialog opens (Figure 13). Here you have several choices:
— To read-protect the document, type a password in the two fields at the top of the
dialog.
— To write-protect the document, click the Options button and select Open file read-
only in the File Sharing Password section.

— To write-protect the document but allow selected people to edit it, select Open file
read-only and type a password in the two boxes at the bottom of the dialog.

] Set Password A *

File Encryption Password
Enter password to open

Confirm password

Mote: After a password has been set, the document will only
open with the password. Should you lose the password,
there will be no way to recover the document. Please also
note that this password is case-sensitive.

= [Options|

File Sharing Password
Open file read-only
Enter password to allow ediking

Confirm password

| QK | Cancel

Figure 13: Two levels of password protection

4) Click OK to save the file. If either pair of passwords does not match, you receive an error
message. Close the message box to return to the Set Password dialog and enter the
password again.
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Caution

LibreOffice uses a very strong encryption mechanism that makes it almost
impossible to recover the contents of a document if you lose the password.

Changing or removing the password for a document

When a document is password-protected, you can change or remove the password while the
document is open. Choose File > Properties > General and click the Change Password button.

OpenPGP encryption

LibreOffice uses the OpenPGP software installed on your computer. If no OpenPGP software is
available, you must download and install one suitable for your operating system before you can
use this option.

You must define a personal pair of cryptography keys with the OpenPGP application. Refer to the
OpenPGP software installed on how to create a pair of keys. For more information on using this
form of encryption, see the supplied Help.

OpenPGP encryption requires the use of the public key of the recipient; this key must be
available in the OpenPGP key chain stored in your computer. To encrypt a document:

1) Choose File > Save As,

2) Inthe Save As dialog, enter a name for the file.

3) Select the Encrypt with GPG key option (see Figure 12).

4) Click Save. The OpenPGP public key selection dialog opens.

5) Choose the public key of the recipient. You can select multiple keys.

6) Click OK to close the dialog and save the file encrypted with the selected public keys.

Opening and saving files on remote servers

LibreOffice can open and save files stored on remote servers (that is, not on your computer or
local area network). This feature enables you to work on a document in the office and still have
access to it from home or elsewhere. Storing files on a remote server also backs up documents,
saving data from computer loss or hard disk failure. Some servers are also able to check files in
and out, thus controlling their usage and access.

LibreOffice supports many document servers that use well-known network protocols such as
FTP, WebDav, Windows share, and SSH. It also supports popular services like Google Drive and
Microsoft OneNote, as well as commercial and open source servers that implement the OASIS
CMIS standard. For more information, see the Getting Started Guide.

Moving quickly through a document

Writer provides ways to move quickly through a document and find specific items by using the
Navigator and other tools.

Using Go to Page

You can jump to a specific page in the document in these ways:

* Use the Go to Page field on the top right of the Navigator (see below).

* Use the Go to Page dialog (Figure 8 on page 24), which shows the current page number
and the number of pages in the document. Type the number of the destination page in
the text box and click OK. To open this dialog, do any of the following:
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— Click on the page number field on the Status Bar.
— Choose Edit > Go to Page on the Menu bar.
— Press Ctrl+G on the keyboard.

Using the Navigator

In a default installation of LibreOffice, the Navigator is part of the Sidebar. It lists all of the
headings, tables, text frames, graphics, bookmarks, and other objects contained in a document.

To open the Navigator (Figure 14), do one of the following:
* Click the Navigator tab in the Tab bar on the right of the Sidebar.
* Click the Navigator icon (if visible) on the Standard toolbar.

* Press F5.
* Choose View > Navigator on the Menu bar.

Click the + sign or triangle to the left of a category or subcategory to display its contents.

Table 2 summarizes the functions of the icons at the top of the Navigator.

0 Note

In a master document, the Navigator has different functions. See Chapter 16, Master
Documents.

Naig ator l X
[ Page ol 22 S [

» Headings
» [ Tables

» L1 Frames
» [ Images 11 12

» |* Bookmarks
» & sections

» & Hyperlinks

» [3 References

Figure 14: The Navigator in the Sidebar
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Table 2: Function of icons in the Navigator

1

2

10

11

12

Navigate By
Header/Footer

Anchor <—> Text
Set Reminder

Previous/Next

Go to Page

Content Navigation
View
List Box On/Off

Heading Levels
Shown

Drag Mode

Promote/Demote
Level
Promote/Demote
Chapter

Opens a drop-down list where you can select the type of
element by which you want to navigate.

Jumps between the text area and the header or footer area
(if the page has them).

Jumps between a footnote anchor and the corresponding
footnote text.

Inserts a reminder. See “Setting reminders” on page 36.

Jumps to the previous/next element of the type selected in
the Navigate By drop-down list.

Jumps to the page number shown in the box. Type a page
number or select it using the + and — signs.

Switches between showing all categories and showing only
the selected category.

Toggles between having the list box shown or hidden.
Choose the number of heading levels to be shown.

Select Insert as Hyperlink, Link, or Copy. See Chapter 3,
Working with Text: Advanced.

Quickly change the level of the selected heading in the
document. See Chapter 3, Working with Text: Advanced..
Move headings and text in the document. See Chapter 3,
Working with Text: Advanced..

The Navigator provides several convenient ways to move around a document and find items in it:

To jump to a specific page in the document, type its sequence number in the box at the
top of the Navigator and press Enter. The sequence number may be different from the
page number if you have restarted numbering at any point.

When a category is opened to show the list of items in it, double-click an item to jump
directly to that item’s location in the document. For example, you can jump directly to a
selected heading, graphic, or comment by using this method.

To see the contents in only one category, highlight that category and click the Content
Navigation View icon. Click the icon again to display all the categories. You can also
change the number of heading levels shown when viewing Headings.

Use the Previous and Next icons to jump to other objects of the type selected in the
Navigate By drop-down list.

In the top left of the Navigator is a Navigate By drop-down list. You can pick a type of
object (such as a bookmark, table, or index entry) and then use the Previous (*) and Next
(v) buttons to jump from one to the next. See Figure 15.

Note

A hidden section (or other hidden object) in a document appears gray in the
Navigator, and displays the word “hidden” as a tooltip. For more about hidden
sections, see Chapter 6, Formatting Pages: Advanced.
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Figure 15: Navigate By list on Navigator

ﬂTip

Objects are much easier to find if you give them identifying names when creating
them. By default, LibreOffice gives objects names such as Imagel, Image2, Tablel,
Table2, and so on. These names are assigned in the order in which the objects were
added to the document, which may not correspond to the location of the object in the
document.

You can rename objects after inserting them. For example, to rename an image,
right-click its name in the Navigator, choose Image in the context menu, then choose
Image > Rename. The view jumps to the image (to show which one itis) and a small
dialog pops up. Type a new name for the image and click OK to save.

You can also right-click the image and select Properties. In the Image dialog, go to
the Options page, edit the name, and click OK.

Setting reminders

Reminders let you mark places in your document that you want to return to later on, for example
to add or correct information or simply mark where you finished editing. The possible uses of
reminders are limited only by your imagination.

To set a reminder at the cursor’s current location, click the Set Reminder icon in the Navigator.
You can set up to 5 reminders in a document; setting a sixth causes the first to be deleted.

Reminders are not highlighted in any way in the document, nor are they listed in the Navigator,
S0 you cannot see where they are, except that when you jump from one to the next, the location
of the cursor shows the location of the reminder.

To jump between reminders, first select the Reminder option in the Navigate By drop-down list.
Then click the Previous and Next icons.

Reminders are not saved with the document.
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Undoing and redoing changes

To undo the most recent change in a document, press Ctrl+Z, choose Edit > Undo on the Menu
bar, or click the Undo icon on the Standard toolbar. To get a list of all the changes that can be
undone, click the small triangle to the right of the Undo icon on the Standard toolbar. You can
select several sequential changes on the list and undo them at the same time.

asllT 56T
j Actions to undo: 6
'| Apply Styles: Caption |
¢ Change style: Framel -
Insert caption: *Sidebar propertie
Paste clipboard
Insert page break

_____________________________________________________

Delete Comments by Cathy

Typing: * "
Delete * "

Figure 16: List of actions that can be undone

After changes have been undone, Redo becomes active. To redo a change, select Edit > Redo,
or press Ctrl+Y or click the Redo icon on the Standard toolbar. As with Undo, click the down
arrow icon of the combination icon to get a list of the changes that can be restored.

Reloading a document

You may want to discard all the changes made in an editing session since the last time you
saved it. Undoing each change or remembering where the changes took place can be difficult. If
you are sure you do not want to keep the changes made since last time the document was
saved, you can reload the document.

To reload a document, go to File > Reload on the Menu bar. A confirmation dialog asks if you
want to cancel all changes; choose Yes to return the document to the version that was last
saved.

Closing a document

If only one document is open and you want to close that document, go to File > Close on the
Menu bar or click the X on the Title bar. The X may be located on either the right or left end of the
Title bar. In Windows and Linux, when you close the last document, then LibreOffice will close
completely. In macOS, you need to use LibreOffice > Quit LibreOffice.

If more than one document is open and you want to close one of them, go to File > Close on the
Menu bar or click the X on the Menu bar of that document’s window. When only the last
document is open, the X on the Menu bar disappears. The X on the Title bar remains.

If the document has not been saved since the last change, a message box is displayed. Choose
whether to save or discard changes.
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Introduction

This chapter covers the basics of working with text in Writer. It assumes that you are familiar with
the use of a mouse and keyboard and that you have read about Writer’'s menus and toolbars and
other topics covered in Chapter 1, Introducing Writer.

We recommend that you also display formatting aids, such as end-of-paragraph marks, tabs,
breaks, and other items in Tools > Options > LibreOffice Writer > Formatting Aids. You can
hide or display these markers by going to View > Formatting Marks. See Chapter 20, Setting up
Writer, for more information.

When you have read this chapter, you should know how to:
* Select, cut, copy, paste, and move text.
* Find and replace text.
* Insert special characters.
* Check spelling and grammar, use the thesaurus, and choose hyphenation options.
* Use the AutoCorrect, Word Completion, AutoText, and case-changing features.

See also Chapter 3, Working with Text: Advanced, and Chapter 4, Formatting Text.

Selecting text

Selecting text in Writer is similar to selecting text in other applications. You can swipe the mouse
cursor over text or use multiple clicks to select a word (double-click), sentence (triple-click), or
paragraph (quadruple-click).

You can also click in the text, press F8 to enter Extending selection mode, and then use the
arrow keys on your keyboard to select a contiguous block of text. Press F8 again after you have
finished selecting the block of text.

In addition, you can select non-contiguous items and vertical blocks of text.

One way to change the selection mode is to use the icon on the Status bar (see Figure 17).
When you right-click the icon, a context menu displays the available options: Standard selection,
Extending selection (F8), Adding selection (Shift+F8), and Block selection (Ctrl+Shift+F8). Left-
clicking cycles through these selections.

— Standard selection
socebon Extending selection
Adding selection
#* Block selection
English (USA) m | [5] |

Figure 17: Changing the selection mode using
the status bar

Selecting items that are not contiguous

To select non-contiguous items (as shown in Figure 18) using the mouse in Standard selection
mode:

1) Select the first piece of text.
2) Hold down the Ctrl key and use the mouse to select the next piece of text.
3) Repeat as often as needed.
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To select non-contiguous items using the keyboard in Adding selection mode:

1) Select the first piece of text. (For more information about keyboard selection of text, see
the topic “Navigating and Selecting with the Keyboard” in the LibreOffice Help (F1).)
2) Press Shift+F8 to enable Adding selection mode.

3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold
down the Shift key and select the next piece of text.

4) Repeat as often as required.

Now you can work with the selected text. After finishing your work with the selected text, press
Esc to exit Adding selection mode.

Around the World in 80 Days - Jules Verne

overspread Passepartout's round face; clearly he had not comprehended his
master.

'Monsieur is going to leave home?"

"Yes," returned Phileas Fogg. "We are going round the world."

Passepartout ppened wide his eyes, raised his eyebrows, held up his hands, and seemed about
to collapse, so overcome was he with stupefied astonishment.

"Round the world!l' he mwmured.

"In eighty days,” responded [Mr/Fogg. "So we haven't a moment to lose."
"But the trunks?" gasped Passepartout, unconsciously swaying his head from right to left.

'we'll have no trunks; only a carpet-bag, with two shirts and three pairs of stockings for me)
and the same for you| We'll buy our clothes on the way. Bring down my mackintosh and
traveling—loak, and some stout shoes, though we shall do little walking. Make haste!"

Figure 18: Selecting non-consecutive pieces of text

Selecting a vertical block of text

You can select a block text that spans through multiple rows using Writer’s Block selection mode.
To change to Block selection mode, use Edit > Selection Mode > Block Area, or press Ctrl+F8,
or click the Selection icon in the status bar and select Block selection in the list. Now you can
highlight the selection, using mouse or keyboard, as shown in Figure 19.

When Mary Lennox was sent to Misselthwaite Manor to live with her uncle
everybody said she was the most disagreeable-looking child ever seen. It was true,
too. She had a little thin face and a little thin body, thin light hair and a sour
expression. Her hair was yellow, and her face was yellow because she had been born
in India and had always been ill in onel way or another. Her father had held a position
under the English Government and had always been busy and ill himself, and het
mother had been a great beauty who kared only to go to| parties and amuse herself
with gay people. She had not wanted a little girl at all, and when Mary was born she
handed her over to the care of an Ayah, who was made to understand that if she
wished to please the Mem Sahib she must keep the child out of sight as much as
possible.

Excerpt from The Secret Garden by Frances Hodgson Burnett

Figure 19: Selecting a block of text
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Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other applications. You
can copy or move text within a document, or between documents, by dragging or by using menu
selections, icons, or keyboard shortcuts. You can also copy text from other sources such as Web
pages and paste it into a Writer document.

* To move (drag and drop) selected text using the mouse, drag it to the new location and
release it; the cursor changes shape while dragging.

* To copy selected text, hold down the Ctrl key while dragging. The text retains the
formatting it had before dragging.

* To move (cut and paste) selected text, use Ctrl+X to cut the text, insert the cursor at the
paste-in point and use Ctr/+V to paste. Alternatively, use the Copy/Paste buttons on the
Standard toolbar.

When you paste text, the result depends on the source of the text and how you paste it. If you
click the Paste button, then the pasted text keeps its original formatting (such as bold or italics).
Text pasted from websites and other sources may be placed automatically into frames or tables
as part of the format when you paste. If you do not like the results, click the Undo button or press
Ctri+Z.

To make the pasted text inherit the paragraph style at the insertion point:

* Choose Edit > Paste Special, or
* Click the arrow on the combination Paste button, or
» Double-click the Paste button without releasing the left mouse button, or
* Press Ctrl+Shift+V
Then select Unformatted text in the resulting menu.
You can also press Ctrl+Alt+Shift+V, which pastes unformatted text directly.

The range of choices on the Paste Special menu varies depending on the origin and formatting of
the text (or other object) to be pasted. See Figure 20 for an example with text on the clipboard.

Al & ©-c - & e[ |
LibreOffice 7.1 Text Document
HyperText Markup Language (HTML)
Rich text formatting (RTF)
Rich text formatting (Richtext)
Unformatted text *
Figure 20: Paste Special menu

Finding and replacing text

Writer has two ways to find text within a document: the Find toolbar for fast searching and the
Find and Replace dialog. In the dialog, you can:

» Find and replace words and phrases.

» Use wildcards and regular expressions to fine-tune a search (see Chapter 3).

* Find and replace specific attributes or formatting (see Chapter 3).

* Find and replace paragraph styles (see Chapter 3).
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Using the Find toolbar

By default, the Find toolbar is shown docked at the bottom of the LibreOffice window (just above
the Status Bar) in Figure 21, but you can float it or dock it in another location. For more
information on floating and docking toolbars, see Chapter 1, Introducing Writer. If the Find toolbar
is not visible, you can display it by choosing View > Toolbars > Find on the Menu bar or by
pressing Ctrl+F.

Previous buttons as needed.q

() Find toolbar B ~ ~ Findal Match Case (2]

Page 7 of 24 5,992 words, 34,825 characters Default Page Style

Figure 21: Docked position of Find toolbar

To use the Find toolbar, click in the text input box and type your search text, then press Enter to
find the next occurrence of that term from the current cursor position. Click the Find Next or Find
Previous buttons as needed.

Click the Find All button to select all instances of the search term within the document. Select
Match Case to find only the instances that exactly match the use of upper and lower case letters
in the search term. Click the icon next to Match Case to open the Find and Replace dialog.

To close the Find toolbar, click the X button on the left, or press Esc on the keyboard when the
text cursor is in the search box.

Using the Find and Replace dialog

To display the Find and Replace dialog (Figure 22), use any of the following methods:

* Use the keyboard shortcut Ctrl+H.
* Choose Edit > Find and Replace on the Menu bar.
* Click the Find and Replace button on the Find toolbar.

] Find and Replace
Find: |
Match case Whole words only
Replace:
Find All Find Previous Find Next Replace Replace All

¥ Other options

Current selection only Replace backwards
Comments Paragraph Styles

I Regular expressions
Similarity search Similarities...

Diacritic-sensitive

Attributes... Format... No Format

Help Close

Figure 22: Expanded Find & Replace dialog
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When the dialog is open, click Other options to expand it.
To use the Find and Replace dialog:

1) Type the text you want to find in the Find box.
2) To replace the text with different text, type the new text in the Replace box.
3) You can select various options, such as matching the case or matching whole words only.

The other options include searching only in selected text, searching from the current
cursor position backwards toward the beginning of the document, searching for similar
words, searching in comments, and using regular expressions (wildcards). The use of
other options is described in Chapter 3, Working with Text: Advanced.

Additional options are shown when CTL or Asian languages have been selected in Tools
> Options > Language Settings > Languages.
4) When you have set up the search, click Find Next. As the document view moves to each

found instance, you can replace the text by clicking Replace or skip that instance by
clicking Find Next again.

O
If you click Find All, Writer selects all instances of the search text in the document.

Similarly, if you click Replace All, Writer replaces all matches, without stopping for
you to accept each instance.

Caution

Use Replace All with caution; otherwise, you may end up with mistakes that you
won't be able to undo later if you save and close the file. (Ctrl+Z works only before
the file is saved.) A mistake with Replace All might require a manual, word-by-word,
search to fix.

Inserting special characters

A special character is one not found on a basic English keyboard. For example, ©3% e ¢t i 0 g
¢ are all special characters.

To insert one or more special characters, place the cursor in the position where you want the
characters to appear. Then do one of the following:

* Click the Special Character icon on the Standard toolbar to open a list of favorite and
recently used characters and click on one to insert it (Figure 23). You can also open the
Special Characters dialog (Figure 24) by clicking the More Characters button in this list.

Q- & L0 R E
-&' Favorites

1
4

€ ¥ |£ |¢ I|Q

< |z |oo |m | T | &
Recent

[ [:[°]

More Characters...

Figure 23: Insert Special
Characters in the standard toolbar
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* Click Insert > Special Character to open the Special Characters dialog (Figure 24).
Double-click the characters (from any font or mixture of fonts) you wish to insert, in order;
they appear in the document as you select them. The selected characters are also added
to the Recent Characters list on the lower left of the dialog.

[ ] [ ] Special Characters
Search: Font: Subset:

Liberation Sans || Latin-1 ||
alalalalale|c|e|éle|le|i|ilT]|i]b |
ilol6lo|lo|o|<|elalalalaly|ply|A é |
alAla|A|lg|C|¢|C|e|C|¢|C|g|D|d|D -
d Ele|/E|& E|e E|le|E|&|G|§|G|]|GC LATIN SMALL LETTERO |
glelalAlp[m[n|T T[T [Y[1]i]i MRS
RN '] j T K k K L i I— l Ll Hexadecimal: U+ F3
Lt N|AIN(n|N|fi|niN|n|O|6|0|b|0 Decimal: 243
6 |E|e|R|F Ri|r RIF|S|s|5]|8 SIS S Add to Favorites
Recent Characters: :

Clear All |

Favarite unaraviers. |

Le v e fle = Jla s iz 0= f= Jl [ ] |
Help . Insert Cancel

Figure 24: The Special Characters dialog

0 Tips

To view details of a character, single-click it; details are shown on the right, along
with its numerical code.

To insert a character and leave the dialog open, double-click the character. To insert
a character and close the dialog, click it and then click the Insert button.

Different fonts include different special characters. If you do not find a particular special character
you want, try changing the Font selection.

Inserting non-breaking spaces, hyphens, and more

You can insert a variety of formatting marks while typing or later. Most of these marks can be
inserted using a keyboard shortcut; all are available in Insert > Formatting Mark on the Menu
bar (Figure 25).

Non-breaking space
To prevent two words from being separated at the end of a line, press Ctr/+Shift when you
type the space between the two words.

Non-breaking hyphen
You can use a hon-breaking hyphen (also called a hard hyphen) in cases where you do not
want the hyphen to appear at the end of a line, for example in the following text “123-4567".
To insert a non-breaking hyphen, press Shift+Ctrl+hyphen.
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2 Hyperlink... Ctrl+K
Bookmark...

Cross-reference...

Q Special Character...

Formatting Mark C Insert non-breaking space Ctrl+Shift+Space
Haorizental Line Insert non-breaking hyphen Ctrl+Shift+-
B Insert soft Hyphen Ctrl+-
1 Footnote and Endnot >
— POEnetE and ENEnets Insert Marrow Mo-break Space Alt+5Shift+Space
] Table of Contents and Index » No-width Optional Break Ctrl+/
[ﬁ Page Number Word Joiner
Field > Left-to-right Mark
D Header and Footer > Right-to-left Mark

Envelope...

Signature Line...

Figure 25: Insert > Formatting Mark submenu

Soft Hyphen
Soft hyphens (also called custom, discretionary, or optional hyphens) specify where words
should be divided at the end of a line. If the word does not occur at the end of a line, the
hyphen does not appear. To insert a soft hyphen, press Ctrl+hyphen.

Narrow No-break Space
If you want a non-breaking space that is not as wide as a normal space, press Alt+Shift
while you type the space.

When complex text layout (CTL) is enabled, these additional formatting marks are active:

No-width Optional Break
Use Ctrl+/ to insert an invisible space in a word that will cause a line break if it is the last
character in the line. Available when complex text layout (CTL) is enabled.

Word Joiner
Inserts an invisible space in a word that will keep the word together at the end of a line. In
earlier versions of Writer, this mark was called No-width no break.

Left-to right Mark
Inserts an invisible mark that affects the text direction of any text following the mark.

Right-to-Left Mark
Inserts an invisible mark that affects the text direction of any text following the mark.

Inserting en and em dashes

To enter en and em dashes as you type, you can use the Replace dashes option on the Options
tab under Tools > AutoCorrect > AutoCorrect Options. This option replaces one or two
hyphens, under certain conditions, with the corresponding dash.

- An en-dash is a dash the width of the letter “n” in the font you are using.
— An em-dash is a dash the width of the letter “m” in the font you are using.

In Table 3, the A and B represent text consisting of letters Ato Z or digits 0 to 9.
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Table 3: Inserting dashes

Text that you type Result

A - B (A, space, hyphen, space, B) A— B (A, space, en dash, space, B)
A -- B (A, space, hyphen, hyphen, space, B) A-—B (A, space, en dash, space, B)
A--B (A, hyphen, hyphen, B) A—B (A, em dash, B)

1--2 (number, hyphen, hyphen, number) 1-2 (number, en dash, number)
A-B (A, hyphen, B) A-B (unchanged)

A -B (A, space, hyphen, B) A -B (unchanged)

A --B (A, space, hyphen, hyphen, B) A-B (A, space, en dash, B)

Another means of inserting en and em dashes is through the Insert > Special Characters menu.
Select the U+2013 or U+2014 character (found in the General punctuation subset), respectively.

A third method uses keyboard shortcuts. These shortcuts vary depending on your operating
system, as described below.

@ Tip
You can also record macros to insert en and em dashes and assign those macros to

unused key combinations, for example Ctrl+Shift+N and Ctrl+Shift+M. For more
information about key combinations, see Chapter 20, Customizing Writer.

macOS
For an en dash, hold down the Option (Alt) key and type a hyphen. For an em dash, the
combination is Shift+Option+Hyphen.

Windows
On most non-Asian installations of Windows, hold down the left Alt key and type on the
numeric keypad: 0150 for an en dash or 0151 for an em dash. The dash appears when you
release the Alt key.

OTip

On a keyboard with no numeric keypad, use a Fn (Function) key combination to type
the numbers. (The Fn key is usually next to the right of the left-hand Ctrl key on the
keyboard.) For example, on a US keyboard layout, the combination for an en dash
should be Alt+Fn+mjim and for an em dash it should be Alt+Fn+myjij.

Linux
Hold down the Compose key and type two hyphens and a period for an en dash, or three
hyphens for an em dash. The dash appears when you release the Compose key.

O ip
The key that operates as a Compose key varies with the Linux distribution. It is

usually one of the Alt or Win keys, but may be another key, and should be user-
selectable.
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Checking spelling and grammar

Writer provides a spelling checker, which checks to see if each word in the document is in the
installed dictionary. Also provided is a grammar checker within the Spelling dialog, which can be
enabled or disabled in the Spelling dialog.

Writer can check spelling and grammar as you type, depending on settings you choose. You can
also choose to check them at any time,

Spelling

To enable automatic checking of spelling, go to Tools on the Menu bar and select Automatic
Spell Checking, or click the Automatic Spell Checking icon (which may not be displayed by
default) on the Standard Toolbar, or go to Tools > Options > Language Settings > Writing Aids
and select Check spelling as you type in the Options list.

Automatic Spell Checking checks each word as it is typed and displays a wavy red line under
any unrecognized words. Right-click an unrecognized word to open a context menu (Figure 26).
You can click one of the suggested words to replace the underlined word with the one selected. If
the list does not contain the word you want, click Spelling to open a dialog. When the word is
corrected, the line disappears. If the word is correct but not in the dictionary, you can chose Add

to dictionary to add it.
Powrfui

Powerful
Potful

lgnore
lgnore All
Add to Dictionary

Ab  spelling...

Always correct to v

AutoCorrect Options...

Set Language for Selection »

Set Language for Paragraph »

Figure 26: Spelling context menu

If the document has change tracking enabled, then the context menu contains extra options
relating to changes in the text.

The choices in the second and third sections of the menu are:

Ignore
This one instance of the underlined word will be ignored while the document is open. Other
instances, if they exist, will still be underlined. This setting is not stored with the document.

Ignore All
All instances of the word in the document will be ignored, and the word will be added to the

IgnoreAllList user-defined dictionary.

Add to Dictionary
The word is added by default to the Standard dictionary.

Spelling
This choice opens the Spelling dialog, which is explained in the next section.
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Always correct to
Selecting this opens the submenu, which repeats the suggestions for the word from the top
section listing. Selecting a replacement word here stores the word pair in the replacement
table under Tools > AutoCorrect > AutoCorrect Options > Replace. The underlined word
is replaced with the selected word.

AutoCorrect Options
Opens the AutoCorrect Options dialog (see page 54), where you can add your own
corrections or change those supplied with LibreOffice.

In the fourth section of the context menu, you can set language settings for the text. These
settings can be applied to the selection or to the paragraph containing the selection.

Spelling and grammar

To perform a combined spelling and grammar check on the document (or a text selection), select
Tools > Spelling or click the Spelling button on the Standard toolbar, or press F7. In order to
use this feature, the appropriate dictionaries must be installed.

The Spelling tool checks either the document from the cursor point onwards, or the text selection.
It opens the Spelling dialog (Figure 27) if any unrecognized words are found or if any of the built-
in grammar rules are broken. You can choose to restart from the beginning of the document
when the check reaches the end of the document.

If you have selected the Check grammar option in the lower left of the dialog, any grammar
errors detected will also be shown. See Figure 29 for an example.

Spelling: English [USA) x

Text language: |A§'5/’ English (USA] = |

Mot in dictionary |_|u__'| Q

powerxful lgnore Once
Ignore All

Add to Dictionary

Suggestions

powerless
Correct Al
Always Correct
Check grammar
Help Options... Undo Close

Figure 27: Spelling alert using the Spelling dialog

Text language
The language to be used for checking spelling can be selected from this drop-down list.

Not in dictionary
The sentence containing the error is displayed in the pane. If an unrecognized word is
found, it is highlighted. If the error is grammatical, it is indicated in a pale colored bar below
the Text language setting (Figure 29). The sentence or the word can be edited in the pane.
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Suggestions
The box contains suggested replacements for the highlighted word. Select a word and then
select Correct or Correct All to replace it.

For grammatical errors there is a single choice. Select Change to accept the suggestion.

Ignore Once, Ignore All, and Add to Dictionary
Clicking one of these buttons has the same effect as the item in the context menu
described above.

Ignore Rule
When checking grammar, you can choose to ignore the suggested change.

Correct
Replaces the unknown word with the suggested word. If the sentence was edited, the
whole sentence is changed.

For grammar, the suggested replacement is used to correct the text.

Correct All
This replaces all instances of the word with the selected replacement word. Not available
for grammar checking.

Always Correct
This behaves in a similar fashion to AutoCorrect.

Undo
This button is enabled when a change has been made to the sentence, so you can reverse
the change. The button is not available if you use a Correct button to replace a word.

Options
Click this button to open the Options dialog where you can select user-defined dictionaries
and set the spell checking rules.

Grammar

By default, Check grammar as you type is enabled in Tools > Options > Language Settings >
Writing Aids > Options. Automatic Spell Checking must be enabled for this to work. You can
also check grammar at any time using the Spelling tool, and you can disable grammar checking
as you type.

When grammar checking as you type is enabled, any errors detected are shown underlined by a
wavy blue line. Right-clicking on this line opens a context menu (Figure 28).

* The first entry in the menu describes the suspected broken grammatical rule.

* The second menu item in the left example is Explanations, which opens your browser to
a web page offering more information about the error. This entry is not always present in
the context menu, as seen in the second example in Figure 28.

A apple a day. Anﬁ]apple a day.
Bad article? Extra space.
Explanations...
Anapple Ignore
Ignore Ignore All
Ignore All Spelling...
Spelling... Set Language for Selection ’
Set Language for Selection 4 Set Language for Paragraph 4
Set Language for Paragraph »

Figure 28: Context menu for grammar errors
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* Inthe second section of the menu is the suggested correction. Clicking this changes the
text to the suggestion. The example to the right appears blank, but clicking here removes
the extra space causing the error.

* In the third section of the menu you can choose to ignore the indicated error, or to open
the Spelling dialog, shown in Figure 29. The example displays the URL that will take you
to more information on the error indicated.

* Inthe final section of the menu, you can set the language for the selection or the
paragraph.

Text language: Ab English (U5A)

Bad article? More...

Mot in dictionae = M
http:/fenwikipedia.org/wiki/English_articles#Distinction_between_a_and_an

A appleis good.

lgnore Once
lgnore Rule

Add to Dictionary

Suggestions

Anspple | Corect

Check grammar

Help Opticns... Undao Close

Figure 29: Spelling dialog showing the URL for expanded explanation

English sentence checking

Additional grammar checking rules can be selected through Tools > Options > Language
Settings > English sentence checking, or through Tools > Extension Manager > English
spelling dictionaries > Options.

Grammar checking

Possible mistakes Capitalization
Word duplication Parentheses
Punctuation
[E) word spacing Em dash
Quotation marks [E] Multiplication sign
Sentence spacing En dash
Apostrophe Ellipsis
More spaces Minus sign
Others

Convert to metric (°C, km/h, m, kg, 1)
Thousand separation of large numbers

Convert to non-metric (°F, mph, ft, Ib, gal)

Figure 30: Additional grammar checking options
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On the English Sentence Checking page (Figure 30), choose which items are checked for,
reported to you, or converted automatically. After selecting the additional grammar checks, you
must restart LibreOffice, or reload the document, for them to take effect.

Grammar checking

Possible mistakes
Checks for errors such as with it's, he don't, this things and so on.

Capitalization
Checks for the capitalization of sentences.

Word duplication
Checks for all word duplication, rather than just the default words 'and', 'or', 'for' and 'the’'.

Parentheses
Checks for correct pairing of parentheses and quotation marks.

Punctuation

Word spacing
This option is selected by default. It checks for single spaces between words, indicating
instances of double or triple spaces. To find and correct longer groups of spaces, you need
to run the checker more than once.

Quotation marks
This checks that double quotation marks are typographically correct, that is, beginning [*]
and ending ["] quotation marks curve in the correct directions.

Sentence spacing
Checks for a single space between sentences, indicating when one or two extra spaces are
found.

Apostrophe
Replaces an apostrophe with the correct (curved) typographical character.

More spaces
Checks word and sentence spacing for more than two extra spaces.

Em dash; En dash
These options force a non-spaced em dash to replace a spaced en dash, or force a spaced
en dash to replace a non-spaced em dash, respectively. This feature provides for different
punctuation conventions.

Multiplication sign
This option is selected by default. It replaces an 'x' used as a multiplication symbol with the
correct typographical symbol.

Ellipsis
Replaces three consecutive periods (full stops) with the correct typographical symbol.

Minus sign
Replaces a hyphen with the correct minus typographical character.

Others

Convert to metric; Convert to non-metric
Converts quantities in a given type of unit to quantities in the other type of unit.

Thousands separation of large humbers
Depending on the locale setting for the document, converts a number with five or more
significant digits to either use a comma as a thousands separator or the ISO format, which
uses a narrow space as a separator.
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Using synonyms and the thesaurus

You can access a short list of synonyms from a context menu (Figure 31).

1) Right-click a word and point to Synonyms on the context menu. A submenu of alternative
words and phrases is displayed.

2) Click a word or phrase in the submenu to have it replace the highlighted word or phrase
in the document.

dhor o - 2veral meanings,
diat  copy acement word fror
Paste
Paste Special »

—  Clone Formatting
85ICS  Clear Direct Formatting

Character >
Paragraph »
Bullets and Numbering »>
Insert Comment
—  Mext E
Previous e
dwelling
home
Page Style... c
abode
: ; : habitation
fwelling, you will see dwelling, Givoclig heuse
building
Thesaurus...

Figure 31: Synonyms on the context menu

The thesaurus gives a more extensive list of alternative words and phrases. To use the
thesaurus:

1) Right-click on a word, point to Synonyms in the context menu, then click Thesaurus in
the Synonyms submenu. See Figure 31.

2) Inthe Thesaurus dialog (shown in Figure 32), click a word or phrase in the list of
meanings to select it.

3) Click Replace to make the substitution.

For example, when given the word house, the thesaurus offers several meanings, including
dwelling, legislature, sign of the zodiac, and others. Select a replacement word from the list under
the relevant meaning, so for dwelling, you will see dwelling, home, domicile, abode, and other
alternatives.

Note

If the current language does not have a thesaurus installed, this feature is disabled.
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]
H

® Thesaurus (English (USA))

Current word;

house [0 English (USA)

T Alternatives:

1. (noun) dwelling (generic term)
dwelling (generic term)
home (generic term)
domicile (generic term})
abode (generic term)
habitation (generic term)
dwelling house (generic term)
building (generic term)
edifice (generic term)

2. (noun) legislature {generic term)
legislature (generic term)
legislative assembly (generic term)
legislative (generic term)
general assembly (generic term)
law-makers (generic term)

2 Ml hnildinn fnanaric tarm

Replace with:

dwelling

Help _ Replace

Figure 32: The thesaurus offers alternatives to words

Hyphenating words

Cancel

You can hyphenate words at the end of a line in two ways: let Writer do it automatically (using
styles and its hyphenation dictionaries), or insert conditional (soft) hyphens manually where
needed. Or, you can choose to not hyphenate at all. Each choice has its pros and cons.

Automatic hyphenation

This option uses styles and over-rides the Tools > Options choices described on the next page.

To turn automatic hyphenation of words on or off:

1)

2)
3)

4)

Note

Turning on hyphenation for the Default Style paragraph style affects all other
paragraph styles that are based on Default Style. You can individually change other
styles so that hyphenation is not active; for example, you might not want headings to
be hyphenated. Any styles that are not based on Default Style are not affected. For
more on paragraph styles, see Chapters 8 and 9 in this book.

Click the Styles tab on the Sidebar to open the Styles deck. On the Paragraph Styles list,
right-click Default Paragraph Style and select Modify.

On the Paragraph Style dialog (Figure 33), go to the Text Flow tab.

Under Hyphenation, select or deselect Automatically. When automatic hyphenation is
on, you can also set the criteria for when it should occur.

Click OK to save.
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Paragraph Style: Default Paragraph Style >

Highlighting Tabs Drop Caps Area Transparency Borders Outline & Numbering
Organizer Indents & Spacing Alignment Text Flow Font Font Effects Position
Breaks
ally, [ nsert

[J Don't hyphenate words in CAPS

2 % Characters at line end
2 Z| Characters at line begin
0 = Maximum number of consecutive hyphens Page

Figure 33: Turning on automatic hyphenation

You can set hyphenation settings in Tools > Options > Language Settings > Writing Aids.
These choices apply when there is no specific setting in a paragraph style. Hyphenation options
set in Writing Aids are effective only if hyphenation is turned on through paragraph styles.

In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.

Minimal number of characters for hyohenation: 5 i Edit
Characters before line break: 2 Ny | =
Characters after line break: 2

H Hyphenate without inguiry
v Hvohenate specal reqions

Dptions

Figure 34: Setting hyphenation options

To change the minimum number of characters for hyphenation, or the minimum number of
characters before or after a line break, select the item, and then click the Edit button in the
Options section.

Hyphenate without inquiry
Specifies that you will never be asked to manually hyphenate words that the hyphenation
dictionary does not recognize. If this box is not selected, when a word is not recognized, a
dialog will open where you can manually enter hyphens.

Hyphenate special regions
Specifies that hyphenation will also be carried out in footnotes, headers, and footers.

Manual hyphenation

To manually hyphenate words, do not use a normal hyphen, which will remain visible even if the
word is no longer at the end of a line when you add or delete text or change margins or font size.
Instead, use a soft hyphen, which is visible only when required.

To insert a soft hyphen inside a word, click where you want the hyphen to appear and press
Ctrl+hyphen (minus sign) or use Insert > Formatting Mark > Insert soft Hyphen. The word will
be hyphenated at this position when it is at the end of the line, even if automatic hyphenation for
this paragraph is switched off.

Using AutoCorrect

Writer's AutoCorrect function includes a long list of common misspellings and typing errors, which
it corrects automatically. It also includes codes for inserting special characters, emojis, and other
symbols. You can add your own special characters.
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AutoCorrect is turned on by default when Writer is installed. You may wish to disable some of its
features, modify others, or turn it off completely. To turn AutoCorrect off, uncheck Tools >
AutoCorrect > While Typing.

You can add your own corrections or special characters or change those supplied with
LibreOffice. Select Tools > AutoCorrect > AutoCorrect Options to open the AutoCorrect dialog.
On the Replace tab, you can define what strings of text are corrected and how.

To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word pair, and
click Delete. To add a new spelling to the list, type it into the Replace and With boxes on the
Replace tab, and click New.

&) & AutoCorrect

Replacements and exceptions for language:  English (Australia) E

Exceptions  Options  Localized Options ~ Waord Completion

Replace With
Text only

*C) © New
*R) ®
tm) ™ Delete
O P
<-- .
. -
L -
1/2 14
1/4 L4
34 %
abotu about
abouta about a
aboutit about it
abscence absence
accesaries accessories
accidant accident
accomodate accommodate
accordingto according to

Help Reset cancel | (KL

Figure 35: Replace tab of AutoCorrect dialog

ﬂTip

LibreOffice has an extensive list of special characters accessible with AutoCorrect.
For example, type :smiling: and AutoCorrect will replace it with ©. Or, (c) will be
changed to ©. You also can add your own special characters.

See “AutoFormatting” in Chapter 4, Formatting Text, for discussion of the Options and Localized
Options tabs of the dialog.
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Using Word Completion

If Word Completion is enabled, Writer tries to guess which word you are typing and offers to
complete the word for you. To accept the suggestion, press Enter. Otherwise, continue typing.

To turn off Word Completion, select Tools > AutoCorrect > AutoCorrect Options > Word
Completion and deselect Enable word completion.

i) & AutoCorrect

Replacements and exceptions for language English (Australia)

Replace  Exceptions  Options  Localized Options

Word Completion Collected Words

Enable word completion Collect words Delete

Append space accepted

Show as tip addition
Additional
Advanced
affected
alternative
Max. entries: 1000 | [7] ARerrin iy
gt alternatives
Apostrophe
application
applications
appropriate
archived
assigned
attributes
Adtribution
AutnCnrrent

When closing a document, remove the words
collected from it from the list

Accept with: + B

Min. word length: 8 Ifl

Figure 36: Customizing word completion

You can customize word completion on the Word Completion page of the AutoCorrect dialog
(Figure 36):

Add (append) a space automatically after an accepted word.

Show the suggested word as a tip (hovering over the word) rather than completing the
text as you type.

Collect words when working on a document, and then either save them for later use in
other documents or select the option to remove them from the list when closing the
document.

Change the key that accepts a suggested entry; the options are right arrow, End key,
Enter (Return), Space bar, and Tab.

Change the maximum number of words remembered for word completion and the length
of the smallest words to be remembered.

Delete specific entries from the word completion list.
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Note

Automatic word completion occurs only after you type a word for the second time in
a document.

Using AutoText

Use AutoText to store text, tables, fields, graphics, and other items for reuse and assign them to
a key combination for easy retrieval. For example, rather than typing “Senior Management” every
time you use that phrase, you can set up an AutoText entry to insert those words when you type
“sm” and press F3.

AutoText is especially powerful when assigned to fields. See Chapter 17, Fields.

Creating AutoText
To store some text as AutoText:
1) Type the text into your document.
2) Select the text.
3) Go to Tools > AutoText (or press Ctrl+F3).
4) In the AutoText dialog (Figure 37), type a name for the AutoText in the Name box. Writer
will suggest a one-letter shortcut, which you can change.
@@ AutoText
) Display remainder of name as suggestion while typing

Name: Chapter Shortcut: Ch

» Business Cards, Work (3 % x 2)
My AutoText

» Only for Templates

> Standard

Save Links Relative To
File system Internet

Help nsert Close | AutoText | =  Categories... Path...

New

Import...

Figure 37: Defining a new AutoText entry

5) Choose the category for the AutoText entry, for example My AutoText.

6) Click the AutoText button at the bottom of the dialog and select from the menu either
New (to have the AutoText retain specific formatting, no matter where it is inserted) or
New (text only) (to have the AutoText take on the formatting around the insertion point).

7) Click Close to return to your document.
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eTip

If the only option under the AutoText button is Import, either you have not entered a
name for your AutoText or there is no text selected in the document.

To save a table as AutoText:

1)
2)
3)
4)

5)

6)

Create a table and format it the way you want.
Select the table.
Go to Tools > AutoText (or press Ctrl+F3).

Type a hame for the AutoText (or amend the suggested shortcut and choose the category
for the AutoText entry).

Click the AutoText button and select New (because you want the formatting of the table
preserved).

Click Close to return to your document.

Inserting AutoText
To insert AutoText, type the shortcut and press F3.

Printing a list of AutoText entries
To print a list of AutoText entries:

1)
2)
3)

Choose Tools > Macros > Organize Macros > Basic.
In the Macro From list, find and expand Gimmicks.

Select AutoText and then click Run. A list of the current AutoText entries is generated in
a separate text document. You can then print this document.

Basic Macros >

Macro Name

InsertString ToCell
Macro From Existing Macros In: AutoText Assign...
E || LibreOffice Macros Main Edit
|25 Access2Base
[&5] Depot Delete
=] Euro
Organizer...

=

=% FormWizard

m

@ Gimmicks

@ ChangeAllChars
W GetTexts

Figure 38: Basic Macros dialog
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Changing the case of selected text

To quickly change the case of text, select it, choose Format > Text on the Menu bar, and then
choose one of the following:

UPPERCASE, where all letters are capitalized.
lowercase, where no words (except proper nouns) are capitalized.

Cycle Case, which cycles the selected words through uppercase, lowercase, and
capitalize every word.

Sentence case, where only the first word is capitalized (together with any proper nouns).
Capitalize Every Word, where every word is capitalized.

tOGGLE cASE, which changes every letter to the opposite case.

Small capitals, which capitalizes all letters in a reduced font size.

Writer does not have an automated way to do Title Case, where all words are capitalized except
for certain subsets defined by rules that are not universally standardized. However, you can use
Capitalize Every Word and then restore those words that you do not want capitalized.

The Format > Text menu also includes several manual formatting options, including bold, italic,
and superscript. If Asian language support has been enabled, there are also several options that
are used with Asian text: half-width, full-width, Hiragana, and Katakana.

You can also change the case of text using the Character dialog or a character style. Choose
Format > Character, click the Font Effects tab (Figure 39), then select the type of capitalization
in the Effects — Case: box.

Font Effects

Font Color
Font color: [ |Automatic v
Transparency: | 0% +

Text Decoration

overlining: (Without) - 1
Strikethrough: | (Without) -
Underlining: (Without) - 1
Effects
Case: (wWithout) - Hidden
Relief: outline [ Shadow
UPPERCASE

lowercase
Capitalize Every Word
small capitals

Help Reset Cancel OK

Figure 39: Changing the case using the Character dialog
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Introduction

This chapter covers the more advanced tools for working with text in Writer:

* The built-in language tools

* Advanced find-and-replace techniques, including wildcards
» Track changes and insert comments

* Footnotes and endnotes

» Linking to other parts of a document

* Line numbering
This chapter assumes that you are familiar with the basic text techniques described in Chapter 2,
Working with Text: Basics. We recommend that you also display formatting aids, such as end-of-

paragraph marks, tabs, breaks, and other items in Tools > Options > LibreOffice Writer >
Formatting Aids. For information on formatting text, see Chapter 4.

Using built-in language tools

Writer provides some tools that make your work easier if you mix multiple languages within the
same document or if you write documents in various languages:

* The functions in Tools > Language

* Language settings in Options

» Paragraph and character styles

* The functions available on the Status bar

The main advantage of changing the language for a text selection is that you can then use the
correct dictionaries to check spelling and apply the localized versions of AutoCorrect replacement
tables, thesaurus, and hyphenation rules. A grammar checking dictionary may also be available
for the selected language.

You can also set the language for a paragraph or a group of characters as None (Do not check
spelling). This option is especially useful when you insert text such as web addresses or
programming language snippets that you do not want to check for spelling.

Using Tools > Language

You can set the language for the whole document, for individual paragraphs, or even for
individual words and characters, from Tools > Language on the Menu bar (Figure 40):

* For Selection applies a specified language to the selected text. If the language you wish
to apply is not listed in the submenu, choose More... to open the Character dialog.

* For Paragraph applies the specified language to the paragraph where the cursor is
located. If the language you wish to apply is not listed in the submenu, choose More... to
open the Character dialog.

* For All Text applies the specified language to all of the document, including text inserted
after making the change. If the language you wish to apply is not listed in the submenu,
choose More... to open the Tools > Language Settings > Languages dialog.

The Reset to Default Language option on the submenu is the fastest way to return a selection,
paragraph, or all text to the default language set in Tools > Options (described below).

The Tools > Language menu options include two that are activated when Asian is selected in
Tools > Options > Language Settings > Languages > Default languages for documents:
Chinese Conversion and Hangul/Hanja Conversion. These options are not covered in this book.
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Window Help

Spelling... {r36; [kingWithText_Z_TFtB_CW_JHW_202006"I4.0dt

Automatic Spell Checking  1tr7 _ = 5]
g~ = -

Thesaurus... $BF7 _ Q B] |:!b L' = @ \ @

Language > For Selection > English (Australia)

Word Count... For Paragraph | 8 / English (USA)

For All Text > MNone (Do not check spelling)
et i Reset to Default Language
AutoText... #HF3 Hyphenation... MG
Redact
Auto-Redact More Dictionaries Online...

Chapter Numbering...
Line Numbering...
Footnotes and Endnotes...

Figure 40: Options available through Tools > Language on the Menu bar

Using language settings in Options

Another way to change the language of a whole document is to use Tools > Options >
Language Settings > Languages. In the Default languages for documents section (Figure 41),
you can choose a different language for all the text that is not explicitly marked as a different
language.

Caution

A change in the default language from the Options dialog is a general change of
settings of LibreOffice and will therefore apply to all the documents created in the
future. If you want to change the language for the current document only, be sure to
select the For the current document only option (Figure 41).

Default Languages for Documents

Western: ab. English (USA) ﬁ
Asian: [None] ﬁ
Complex text layout: [None] ﬁ

For the current document only

Enhanced Language Support

Ignore system input language

Figure 41: Options available in the Languages settings

Q Note

The spelling checker works only for those languages in the list that have a
checkmark symbol next to them. If you do not see this symbol next to your preferred
language, you can install the dictionary using Tools > Language > More
Dictionaries Online.
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Using paragraph and character styles

Changing the language on the Font tab of the Paragraph Styles dialog (Figure 42) will change
the language for all paragraphs that use that paragraph style. If you will have whole paragraphs
in different languages in a single document, you can use a different paragraph style for each
language. For example, you might define Text Body-EN and Text Body-FR in a document
containing paragraphs in both English and French.

See Chapter 9, Working with Styles, for information on how to manage the language settings of a
style.

& - Paragraph Style: Heading 2

Highlighting ~ Outline & Numbering  Tabs  DropCaps = Area  Transparency  Borders
Organizer  Indents & Spacing ~ Alignment  TextFlow JUFant | FontEffects  Position

Family Typeface Size:

Liberation Sans Bold 14 pt

Liberation Sans Regular 10 pt

Liberation Sans Narrow Bold 105 pt

Liberation Serif halic 11 pt

Libian SC Bold Italic 12 pt

LiHei Pro 13 pt

Linux Biolinum G 14 pt

Linux Libertine Display G 15 pt

|  Linux Libertine G 16 pt

LiSong Pro 18 pt

Lucida Grande 20 pt

| 1iminari 27 nr

Language: English (USA) [~

Figure 42: Setting the language for a paragraph style

Using the Status bar

You can set paragraphs to be checked in a language that is different from the language of the
rest of the document by putting the cursor in the paragraph (or selecting more than one
paragraph) and changing the language on the Status bar (Figure 43). This change affects only
the selected paragraphs.

The language used for checking spelling is also shown in the Status bar, next to the page style in
use. You can change the language for the paragraph or the entire document; click the language
in the Status bar to pop up a menu of choices.

an on the men|  English (UK) lastest way to
to the default i ane
® |English (USA) - English (UK)
Mone (Do not chedk spelling) English (USA)
Reset to Default Language None (Do ot check speling)
iIesaurus | Mere.. Reset to Default Language
English (USA) Set Language for Paragraph  » Maore, .. |

Figure 43: Language choices on the Status bar

The Reset to Default Language option on the menu and submenu is the fastest way to return a
paragraph or the entire document to the default language set in Tools > Options (described
above).
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Advanced find and replace techniques

In addition to finding and replacing words and phrases (described in Chapter 2), you can use
Writer’s Find and Replace dialog to find and replace paragraph styles and text formatting.

Find and replace paragraph styles

Combining material from several sources may result in unwanted paragraph styles in your
document. To quickly change all the paragraphs from one style to another (preferred) style:

1) On the Find and Replace dialog with Other Options displayed, select Paragraph Styles.
The Find and Replace boxes now contain a list of paragraph styles in use in the
document.

If you have text formats or attributes specified, this option is labeled Including Styles.
Select No Format to remove any attributes and return the option to Paragraph Styles.

2) Select the styles you want to search for and replace.
3) Click Find, Find All, Replace, or Replace All.
Repeat steps 2 and 3 for each style that you want to replace.

Find and replace text formatting

Unlike Find and Replace for paragraph styles described above, the formats or attributes to be
searched for do not appear inside the Find or Replace box. Instead, the formats or attributes to
be found or replaced appear below the Find and Replace boxes (Figure 44). Clicking on the
down-arrow to the right does not bring up options.

@ Find and Replace
Find: B
Arial, 14 pt, ltalic [t Selections appear below the Find: box
Match case Whole words only
Replace: [~ ]
Find Al Find Previous Find Next Replace Replace All

v  Other options

Current selection only Replace backwards

Comments

Reguler &xpressions Click  here to include formats in

character and paragraph style.
Leave unchecked to limit to
direct (manual) formatting.

No Format

L]

Similarity search

Diacritic-sensitive

Attributes...

Help Close

Figure 44: Find and replace text formatting
To find a type of formatting in the document, follow this procedure:
1) Open the Find and Replace dialog (Figure 44) and select Other options.
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2)

3)

4)

5)
6)
7

8)

To clear any previous format criteria, place the cursor in the Find box and then click the
No Format button. To clear the selected Replace options, place the cursor in the Replace
box and click the No Format button.

Click the Format button to open the Search for Formatting dialog, which looks much like
the Character dialog. Select a format from any of the tabs (for example: bold, 14 pt,
Spacing above paragraph).

To find this format that has been applied only by direct formatting, leave the Including
Styles box unchecked. To find this format also applied inside a character or paragraph
style, select the Including Styles box.

Choose Find All to have all formats found highlighted. Choose Find Previous or Find
Next to find one format instance at a time.

To replace the chosen format, click inside the Replace box, then choose Format and
choose a replacement from the tabbed options.

Replace the formats one at a time using Find Previous > Replace or Find Next >
Replace. Use Replace All to change all formats at once.

To avoid errors the next time you use this dialog, it is a good idea to repeat Step 2 and
clear all the formatting criteria selected.

To change the formatting for a specific word or phrase in a document:

1)
2)

3)

Type the word or phrase in the Find box.

In the Replace box, type in the new text you want to use and choose the formats you
would like to change. However, if you want to keep the same word or phrase and only
change its format, ensure you also type the word or phrase in the Replace box.
Otherwise, Writer will remove the word or phrase from the document.

Replace the words and formats one at a time using Find Previous > Replace or Find
Next > Replace. Use Replace All to change all words and formats at once.

Similarity search

This option finds terms that are similar to the Find: text. For example, a similarity search can find
words that differ by two characters.

Select Similarity search and click the Similarities button to open a dialog where you can modify
the text search by length and number of characters different from the search term (Figure 45).

Find: Once
€] Similarity Search

Exchange characters: || 2]

Replac) Add characters: |2 1)
Find Al Remove characters: 2 =) Replace Replace All
Combine
Other of
Curren Help Cancel = |Qel S lace backwards
Commenvmmmmmmredgraph Styles

Regular expressions

Similarity search Similarities...

Figure 45: Similarity search dialog
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Exchange characters
Enter the number of characters in the search term that can be exchanged. For example, if
you specify 2 exchanged characters, "black" and "crack" are considered similar.

Add characters
Enter the maximum number of characters by which a word can exceed the number of
characters in the search term.

Remove characters
Enter the number of characters by which a word can be shorter than the search term.

Combine
Searches for a term that matches any combination of the similarity search settings.

Search with wildcards and regular expressions

A wildcard is a special character that represents one or more unspecified characters. Wildcards
make text searches more powerful but often less specific. LibreOffice enables you to use
combinations of characters known as regular expressions which are more specific than simple
wildcards but less so than a literal string. Regular expressions are very powerful but not very
intuitive. They can save time and effort by combining multiple finds into one.

Table 4 shows a few of the regular expressions used by LibreOffice. The Help describes many
more regular expressions and their uses.

To use wildcards and regular expressions when searching and replacing:

1) On the Find and Replace dialog, click Other Options to see more choices. On this
expanded dialog, select the Regular expressions option.

2) Type the search text, including the wildcards, in the Search for box and the replacement
text (if any) in the Replace with box. Not all regular expressions work as replacement
characters; the line break (\n) is one that does work.

3) Click Find, Find All, Replace, or Replace All (not recommended).
Table 4: Examples of search wildcards (regular expressions)

To find Use thi S Examples and comments
expression
Any single character . (a period or b.d finds bad. bud. bid. and bed.
full stop) ' T
One of the specified  [xyZ] biu]n finds bin and bun.
characters
Any single character in X-y] [r-t]leed finds reed, seed, and teed; ranges must
this range y be in alphabetically ascending order.

Any single character [*X]
except the characters p[*a]st finds post and pest, but not past.
inside the brackets

The beginning of a

\<start \<log finds logbook and logistics, but not

word catalog.

The end of a word end\> log\> finds catalog, but not logistics.

A paragraph marker $ Does not work as a replacement character. Use
\n instead.

Aline break \n Finds a line break that was inserted with

Shift+Enter. When used as a replacement
character, it inserts a paragraph marker.
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Note

To search for a character that is defined as a wildcard, type a backslash (\) before
the character to indicate that you are using it literally. For example, to find the text
$5.00, you would conduct a search using \$5\ . 00.

Tracking changes to a document

You can use several methods to keep track of changes made to a document.

» Make your changes to a copy of the document (stored in a different folder, under a
different name, or both), then use Writer to compare the two files and show the changes.
This technique is particularly useful if you are the only person working on the document,
as it avoids the increase in file size and complexity caused by the other methods.

* Save versions that are stored as part of the original file. However, this method can cause
problems with large or complex documents, especially if you save a lot of versions. Avoid
this method if you can.

» Use Writer's change marks (often called “redlines” or “revision marks”) to show added or
deleted material or changed formatting. Later, you or another person can review and
accept or reject each change.

Note

Not all changes are recorded. For example, changing a tab stop from align left to
align right, changing a paragraph style, and changes in formulas (equations) or
linked graphics are not recorded.

Preparing a document for review

When you send a document to someone else to review or edit, you may want to prepare it first so
that the editor or reviewer does not have to remember to turn on the revision marks. After you
have protected the document, any subsequent user must enter the correct password in order to
turn off protection or accept or reject changes.

1) Open the document. Check whether it contains multiple versions by clicking File >
Versions. If multiple versions are listed, save the current version as a separate document
with a different name and use this new document as the review copy.

2) With the review copy open, make sure that change recording is turned on. The Edit >
Track Changes > Record menu item is highlighted when recording is turned on.

3) Click Edit > Track Changes > Protect. On the Enter Password dialog, type a password
(twice) and click OK.

OTip

An alternative to steps 2 and 3 above is to choose File > Properties > Security tab,
select the Record changes option, then click Protect and enter the password.

Track Changes menu and toolbar

In addition to the Track Changes menu (Figure 46), Writer provides a convenient toolbar (Figure
47) that includes buttons for the same functions.
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Track Changes | + Record {+3C

Comment P+ Show

Manage...
Reference > Previous

MNext

Accept

Accept and Move to Next
Exchange Database... Accept All
Reject
Reject and Move to Next
Reject All

Direct Cursor Mode
+ Edit Mode {r3EM

Comment...
Protect...

Compare Document...
Merge Document...

Figure 46: Track Changes menu
Track Changes v X
BB < P EERRRBRB|IE B B BE

12345678 910111213141516
Figure 47: Track Changes toolbar

1 Show Changes 5 Accept Change 9 Accept & go to Next 13 Insert Change Comment
2 Record Changes 6 Reject Change 10 Reject & go to Next 14 Protect Changes

3 Previous Change 7 Accept All Changes 11 Manage Changes 15 Compare Documents

4 Next Change 8 Reject All Changes 12 Insert Comment 16 Merge Documents

Recording changes

To modify the default settings, see Chapter 20, Customizing Writer, for instructions on setting up
how changes will be displayed.

1) To begin tracking (recording) changes, click Edit > Track Changes > Record. To show or
hide the display of changes, click Edit > Track Changes > Show.

OTip

Hold the mouse pointer over a tracked change; you will see a Help Tip showing the
type of change, the author, date, and time of day for the change. If Extended Tips
are enabled, you will also see any comments recorded for this change.

2) To enter a comment on a tracked change, place the cursor in the area of the change and
then click Edit > Track Changes > Comment or click the Insert Track Change
Comment button on the Track Changes toolbar.

In addition to being displayed as an extended tip, the comment is also shown in the list in
the Manage Changes dialog (Figure 48).

To move from one tracked change to the next, use the arrow buttons. If no comment has
been recorded for a change, the Text field is blank.

3) To stop recording changes, click Edit > Track Changes > Record again.
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OTip

See also “Adding other comments” on page 71 for a way to annotate text that is not
associated with a tracked change.

Accepting or rejecting changes
To accept or reject recorded changes, use any of these tools:

» Track Changes toolbar (Figure 47)
* Items on the Track Changes menu (Figure 46)
* Right-click (context) menu
* Manage Changes dialog
The results of accepting or rejecting a change are as follows:

* Accept: incorporates the change into the document and removes the change indicator.
* Reject: reverts the change to its original state and removes the change indicator.

Track Changes menu and toolbar
For quick and easy accepting and rejecting of changes, you can use the Track Changes
toolbar (Figure 47), which includes buttons for the same functions as appear on the Edit >
Track Changes submenu (Figure 46). To enable the Track Changes toolbar, click View >
Toolbars > Track Changes on the Menu bar. You can dock this toolbar in a convenient
place or leave it floating.

Right-click (context) menu
1) If tracked changes are not showing, click Edit > Track Changes > Show.

2) Hover the mouse pointer over a recorded change. A box appears with information about
the type of change, who made it, and the date and time.

3) Right-click the changed text. In the context menu, choose Accept Change or Reject
Change.

Manage Changes dialog
1) Click Edit > Track Changes > Manage. The Manage Changes dialog (Figure 48) opens,
showing changes that have not yet been accepted or rejected.

2) When you select a change in the dialog, the change itself is highlighted in the document,
S0 you can see what the editor changed.

3) Click Accept or Reject to accept or reject the selected change. You can also click
Accept All or Reject All if you do not want to review the changes individually.

To show only the changes of certain people or only the changes on specific days or various other
restrictions, use the Filter tab (Figure 49) on the Manage Changes dialog. After specifying the
filter criteria, return to the List tab to see those changes that meet your criteria.
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® @ Manage Changes

ﬁ Filter

! |A-:Iicn |Authcr |Date Comment
8 Jean Hollis Weber 15/06/2020 10:07:42
L Jean Hollis Weber 15/06/2020 10:07:44
% Jean Hollis Weber 15/06/2020 10:07:22 Tab no longer exists.
L Jean Hollis Weber 31/05/2020 11:56:57
|
!
" Accept Reject Accept All Reject All ﬁ
Figure 48: The List tab of the Manage Changes dialog
®0@® Manage Changes
List |LFiller)
Date:
earlier than ﬁ
15/06/2020 ¥ | 10:05 BRES]
and Iérl
' Author: .
Jean Hollis Weber ﬁ
Action:
Insertion E
Comment:

|
Figure 49: The Filter page of the Manage Changes dialog

Comparing documents

Sometimes reviewers may forget to track the changes they make. You can find the changes if
you compare the original document and the one that is edited. To compare them:

1) Open the edited document. Select Edit > Track Changes > Compare Document.
2) Afile browser dialog opens. Select the original document and click Open.
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Writer finds and marks the changes and displays the Manage Changes dialog. From this point,
you can go through and accept or reject changes as described earlier.

Merging modified documents

The processes discussed to this point are effective when you have one reviewer at a time.
Sometimes, however, multiple reviewers all return edited copies of a document. Writer provides a
facility to merge documents containing tracked changes into the original document, but the
condition for making this work is very specific: the edited documents may differ only and
exclusively in the recorded changes — all other original text must be identical.

To merge documents, all of the edited documents (but not the original document) need to have
recorded changes in them.

1) Open the original document into which you want to merge all copies.
2) Click Edit > Track Changes > Merge Document. A file selection dialog opens.

3) Select the edited copy of the document to be merged with the first. If there have been no
subsequent changes to the original document, the copy is merged into the original.

If any changes have been made to the original document, an error dialog appears that
informs you that the merge is unsuccessful.

4) After the documents merge, you will see the recorded changes from the copy in the
original document.

5) Repeat until all copies are merged.
All recorded changes are now included in the open copy. Save this file under another name.

Adding other comments

Writer provides another type of comment, which authors and reviewers can use to exchange
ideas, ask for suggestions, or mark items needing attention.

You can select a block of text, including multiple paragraphs, to be highlighted for a comment, or
you can insert a comment at a single point. To insert a comment, select the text, or place the
cursor in the place the comment refers to. Right-click and choose Insert > Comment or press
Ctrl+Alt+C or click the Insert Comment button (not the same as the Insert Track Change
Comment button) on the Track Changes toolbar.

The anchor point of the comment is connected by a dotted line to a box on the right-hand side of
the page where you can type the text of the comment. A Comments button is also added to the
right of the horizontal ruler (Figure 50); you can click this button to toggle the display of the
comments on and off.

Writer automatically adds the author’s name and a time stamp indicating when the comment was
created. Select Tools > Options > LibreOffice > User Data to enter or change the name you
want to appear in the Author field of the comment.

When you are finished typing the comment, click somewhere else on a page of the document.
Otherwise, you will not be able to move away from the comment box.

If more than one person edits the document, each author is automatically allocated a different
background color. Figure 50 shows an example of text with comments from two different authors.
If an author selects text that overlaps another author’s comments, then the comments from the
second author are nested with those of the first author.

Right-click a comment to open a context menu where you can delete the current comment, all the
comments from the same author, or all the comments in the document. From this menu, you can

also choose Format all comments to open a dialog to apply some basic formatting to the text of
the comment. You can also change font type, size, and alignment from the Menu bar.
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When the document has been reviewed and commented and requires your action, you can mark
each comment Resolved or Unresolved, using options on the comment’s context menu. When
you mark a comment resolved, the word Resolved is inserted under the date in the comment
box. You can toggle the display of all resolved comments in the document by using View >
Resolved Comments on the Menu bar.

This comment is nested due to
overlapping text selection.

multiple paragraphs, or a single point may be selected B

‘a comment select the text, or place e cursorin the Comment on selected text.
= Comment or press Cirl+Alt+C. The anchor point of

box on the right-hand side of the page where you can

lly adds at the bottom of the comment the author's Joe Soap

nment was created. Today, 20:27
A single point comment.

Figure 50: Comments in LibreOffice

To navigate from one comment to another, open the Navigator (F5), scroll to find and expand the
Comments section. Double-click the comment text to move the cursor to the anchor point of the
comment in the document.

You can also navigate the comments by selecting Comment in the Navigate By box at the top of
the Navigator and clicking the Up and Down arrows next to it, to move to the next or previous
comment. You can also navigate use the keyboard: Ctrl+Alt+Page Down moves to the next
comment and Ctrl+Alt+Page Up moves to the previous comment.

To print the comments in a document, choose one of the options from the Comments drop-down
list in the Print dialog (File > Print > LibreOffice Writer tab): Comments only, Place at end of
document, Place at end of page, Place in margins (Figure 51).

General LibreOffice Writer

Contents
Page background
Images and other graphic chjects
[] Hidden text
(] Text placeholders
Form controls

Comments;

Color Meone (document only)
Cormments only

[ Print text i Place at end of document

Place at end of page
Place in margins

Pages:
L] Print auto

Figure 51: Options for printing comments
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Using footnotes and endnotes

Footnotes appear at the bottom of the page on which they are referenced. Endnotes are
collected at the end of a document.

To work effectively with footnotes and endnotes, you need to:

* Insert footnotes and define their format, if the default values do not meet your needs; see
below.

» Define the location of footnotes on the page, and the color and line style for separator
lines, if the defaults to not meet your needs. See Chapter 5, Formatting Pages: Basics.

Inserting footnotes and endnotes
To insert a footnote or an endnote:

1) Position the cursor where you want the footnote or endnote marker to appear.

2) Select Insert > Footnote and Endnote on the Menu bar and choose Footnote or
Endnote, or click the Insert Footnote or Insert Endnote button on the Standard toolbar.

3) Afootnote or endnote marker is inserted in the text and, depending on your choice, the
cursor is relocated either to the footnote area at the bottom of the page or to the endnote
area at the end of the document. Type the footnote or endnote content in this area.

To change the default Footnote/Endnote settings, go to Tools > Footnotes and Endnotes on
the Menu bar.

To choose whether to use the automatic numbering sequence specified in the footnote settings or
specify a custom number, go to Insert > Footnote and Endnote > Footnote or Endnote on the
Menu bar to open the Insert Footnote/Endnote dialog (Figure 52).

You can edit an existing footnote or endnote in the same way you edit any other text.

To delete a footnote or endnote, delete the footnote marker. The contents of the footnote or
endnote are deleted automatically, and the numbering of other footnotes or endnotes is adjusted
automatically.

5] [} Insert Footnote/Endnote

Numbering
O Automatic

Character: Choose...

Type
© Footnote

Endnote

Help Cancel | KIS

Figure 52: Inserting a footnote/endnote

Formatting footnotes and endnotes

To format the footnotes themselves, click Tools > Footnhotes and Endnotes. On the
Footnotes/Endnotes Settings dialog (Figure 53), choose preferred settings.
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Figure 53: Defining footnote formatting

Linking to another part of a document

Typed cross-references to other parts of a document can easily get out of date if you reorganize
the order of topics, add or remove material, or reword a heading. Writer provides two ways to
ensure that references are up to date: hyperlinks and automatic cross-references. Both methods
can be used to link to other parts of the same document or to another document.

Both methods have the same result: if you Ctrl+click the link when the document is open in Writer,
you are taken directly to the cross-referenced item. However, they also have major differences:

* The text in a hyperlink does not automatically update if you change the text of the linked
item (although you can change it manually), but changed text does automatically update
in a cross-reference.

* When using a hyperlink, you do not have a choice of the content of the link (for example
text or page number), but when using a cross-reference, you have several choices.

» To hyperlink to an object such as an image, and have the hyperlink show useful text such
as Figure 6, either give such an object a useful name instead of leaving it as the default
name (“Imagel2”), which may not correspond to the object’s position in the document, or
use the Hyperlink dialog to modify the visible text. In contrast, cross-references to figures
with captions can be set to automatically show useful text, and you have a choice of
several variations of the name.

* If you save a Writer document to HTML, hyperlinks remain active but cross-references do
not. (Both remain active when the document is exported to PDF.)

Using cross-references

To ensure that the text of cross-references update if you reword a heading, caption, or other
linked item, use automatic cross-references. For details, see Chapter 17, Fields.

Using bookmarks

Bookmarks are listed in the Navigator and can be accessed directly from there with a single
mouse click. In HTML documents, bookmarks are converted to anchors that you can jump to by
hyperlink. You can also cross-reference to a bookmark. For more information, see Chapter 17,
Fields.
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Using hyperlinks

When you type text (such as website addresses or URL) that can be used as a hyperlink, and
then press the spacebar or the Enter key, Writer automatically creates the hyperlink and applies
formatting to the text (usually a color and underlining).

If this does not happen, you can enable this feature using Tools > AutoCorrect > AutoCorrect
Options. On the Options tab, select the URL Recognition option.

If you do not want LibreOffice to convert a specific URL to a hyperlink, you can go to Edit > Undo
on the Menu bar, or press Ctrl+Z immediately after the formatting has been applied, or place the
cursor in the hyperlink, right-click, and select Remove Hyperlink in the context menu.

You can also insert hyperlinks to other parts of your document, to other documents or parts of
documents, and to email addresses, using the Navigator and the Hyperlink dialog, and you can
modify all hyperlinks using the Hyperlink dialog. For details, see Chapter 12, Creating HTML
Files, in the Getting Started Guide.

The standard (default) behavior for activating hyperlinks within LibreOffice is to use Ctrl+click. To
change this behavior, go to Tools > Options > LibreOffice > Security, click the Options button
next to Security Options and Warnings, and deselect Ctrl-click required to open hyperlinks.
If clicking in your links activates them, check that page to see if the option has been deselected.

Editing hyperlinks

To edit a hyperlink, click anywhere in the link text and then open the Hyperlink dialog by right-
clicking and choosing Edit Hyperlink in the context menu, or clicking the Hyperlink icon on the
Standard Toolbar, or choosing Edit > Hyperlink from the Menu bar. Make your changes and click
Apply. If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until you
have edited all of them. Be sure to click Apply after each one. When you are finished, click
Close.

To change the color of hyperlinks, go to Tools > Options > LibreOffice > Application Colors,
scroll to Unvisited links and/or Visited links in the General section, select those options, pick
the new colors, and click OK. This will change the color for all hyperlinks in all components of
LibreOffice, which may not be what you want.

Rearranging headings and text using the Navigator

You can use the Navigator (Figure 54) to move headings and their associated text to another
location in a document by doing the following:

1) If necessary, click the expansion symbol (+ sign or arrow) to the left of a heading to
expand the list of subheadings.

2) (Optional) If you have several subheading levels, you can more easily find the headings
you want by changing the Heading Levels Shown selection to show only 1 or 2 levels of
headings.

3) Click the heading of the block of text that you want to move and drag the heading to a
new location on the Navigator. Or, click the heading in the Navigator list, and then click
either the Promote Chapter or Demote Chapter icon. All of the text and subsections
under the selected heading with it move up or down in the document.

To move only the selected heading and not the text associated with the heading, hold
down Ctrl, and then click the Promote Chapter or Demote Chapter icon.
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Figure 54: Promote/Demote in Navigator
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0Tip

The names Promote Chapter and Demote Chapter might be better described as
Move Up or Move Down (within the document, without changing the heading level) to
distinguish them more clearly from Promote Level and Demote Level, which
change the heading level—from Level 1 to Level 2, for example.

To quickly change the outline level of a heading:

* To change the outline level of a heading and its associated subheadings, select the
heading in the Navigator, then click either the Promote Level or Demote Level icon.
This action does not change the location of the headings, only their levels.

* To change the outline level of only the selected heading, but not its associated
subheadings, hold down Citrl, and then click the Promote Level or Demote Level icon.

Inserting material from other documents

You may wish to reuse material from other files in the document you are writing. For example,
you might be writing a set of instructions that include some common paragraphs. You could, of
course, retype or copy and paste the common paragraphs into each document. However, if the
common paragraphs are edited, you may need to update that information in every document
where it occurs.

Writer provides some tools for making these tasks easier:
* The Section dialog, described in Chapter 6, Formatting Pages: Advanced.
* Two items in the Navigator's drag modes, described below.

To use the Navigator tools, first select the item you want to insert from the source document, then
choose Insert as Link or Insert as Copy. You cannot create links or copies of graphics, OLE
objects, references, or indexes using this method.
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Insert as Link
Inserts the selected item as a link where you drag and drop in the current document. Text is
inserted as a protected section, marked as linked to the source document. The contents of
the link are automatically updated when the source is changed. To manually update the
links in a document, choose Tools > Update > Links.

Insert as Copy
Inserts an independent copy of the selected item where you drag and drop in the current
document. Text is in a section, but it is not protected. Copied items are not updated when
the source is changed. You can remove the section, leaving the contents as normal text.

Line numbering

Line numbers in the margin are often used in legal documents, poetry, and lists of programming
code. Writer can insert line numbers in an entire document or for selected paragraphs. Line
numbers are included when you print the document. You can also add a separator between line
numbers. Figure 55 shows an example with numbering on every line.

You can choose how many lines are numbered (for example, every line or every tenth line), the
numbering type, and whether numbers restart on each page. In addition, a text separator (any
text you choose) can be set on a different numbering scheme (one every 12 lines, for example).

To add line numbers to an entire document, click Tools > Line Numbering and select the Show
numbering option in the top left corner of the Line Numbering dialog (Figure 56). Then select
any options you want and click OK.

Line numbering

Line numbering puts line numbers in the ma
also printed. Figure 1 shows an example wit

Click Tools = Line Numbering and select i+
Line Numbering dialog (Figure 2). Then click

You can choose how many lines are numbet
numbering type, and whether numbers resta

[ N T R =N % I L =

Figure 55: Line numbering example
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Show numbering
View Count

Character style: | Line Numbering & Blank lines
Format: 1,2,3, .. E Lines in text frames
= Include header and footer
Paosition: Left ﬁ
Restart every new page
Spacing: 0.50 cm 1]
Interval: 5 |j| lines
Separator
Text:

Every 3 12| lines

Figure 56: Line Numbering dialog
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To disable line numbering for the entire document, you can edit the Default Paragraph Style
(because all paragraph styles are based on the Default Paragraph Style):

1) Inthe Sidebar, go to the Styles pane and click the Paragraph Styles icon.

2) Right-click on the Default Paragraph Style and choose Modify.

3) Click the Outline & List tab (see Figure 57).

4) Inthe Line Numbering area, deselect the Include this paragraph in line numbering

box.
5) Click OK.
' @ [ ] Paragraph Style: Default Paragraph Style
Organizer Indents & Spacing Alignment Text Flow Font Font Effects Position
Highlighting Tabs Drop Caps Area Transparency Borders Qutline & List
Outline
Outline level: Text Body %]
| Apply List Style
List style: No List Edit Style

Line Numbering
8 Include this paragraph in line numbering
Restart at this paragraph

~

art with 1 2

Figure 57: Disabling line numbering for a document

To enable line numbering for specific paragraphs:
1) First disable the feature for the document (as above), then select the paragraphs where
you want to add the line numbers.

2) Choose Format > Paragraph, or right-click and choose Paragraph > Paragraph on the
context menu.

3) Onthe Outline & List tab of the Paragraph dialog, select Include this paragraph in line
numbering.
4) Click OK.

Alternatively, you can disable line numbering for specific paragraphs (while leaving most of them
enabled) by selecting the paragraphs, choosing Format > Paragraph or right-clicking and
choosing Paragraph > Paragraph on the context menu, then going to the Outline & List tab and
deselecting Include this paragraph in line numbering.

You can also create a paragraph style that includes line numbering, and apply it to the
paragraphs that you want to add line numbers to. For example, to number the lines of example
code in a document, you will probably want to use a font or indentation that is different from
normal text.

To specify the starting line number:

1) Click in the paragraph and choose Format > Paragraph or right-click and choose
Paragraph > Paragraph on the context menu.

2) On the Outline & List tab, make sure Include this paragraph in line numbering is
selected.

3) Select Restart at this paragraph and enter a line number in the Start with box.
4) Click OK.
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Introduction

This chapter covers the basics of formatting text in Writer, the word-processing component of
LibreOffice:

* Formatting paragraphs and characters

* Using autoformatting

* Creating bulleted, numbered, and outline lists

It assumes that you are familiar with the text techniques described in Chapter 2, Working with
Text: Basics and Chapter 3, Working with Text: Advanced.

We recommend that you also follow the suggestions in Chapter 20, Customizing Writer, about
displaying formatting aids, such as end-of-paragraph marks, and selecting other setup options.

Page formatting is covered in Chapters 5 and 6.

Formatting: direct (manual) or styles
There are two basic ways to format text:

Direct (or Manual) formatting
Applies formatting directly to specific paragraphs, characters, pages, frames, lists, or
tables. For example, you can select a word, then click on a button on the Formatting
toolbar to format the text as bold or italics.

Styles
Bundles formatting options under one name. For example, a paragraph style defines
numerous settings for options such as font type and size, whether paragraphs should be
indented, the space between lines, how paragraphs should be aligned on the page, and
many others.

Using styles is recommended

Writer is a style-based program. Because styles apply whole groups of formats at the same time,
they enable you to easily format a document consistently and to change the formatting of an
entire document with minimal effort. Therefore, the use of paragraph and character styles is
highly recommended.

In addition, styles are used by LibreOffice for many processes, even if you are not aware of them.
For example, Writer relies on heading styles (or other styles you specify) when it compiles a table
of contents.

For information on styles and how to use them, see Chapters 8 and 9 in this book.

Applying styles is quick and easy using the Styles deck of the Sidebar.

Caution

Manual formatting (also called direct formatting) overrides styles, and you cannot get
rid of the manual formatting by applying a style to it.

Removing manual formatting

To remove manual formatting, select the text and choose Format > Clear Direct Formatting on
the Menu bar, or right-click and choose Clear Direct Formatting on the context menu, or click
the Clear Direct Formatting icon on the Formatting toolbar, or press Ctrl+M on the keyboard.
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Formatting paragraphs using styles

Styles can be applied to paragraphs in several ways; see Chapter 8, Introduction to Styles:

» Set Paragraph Style drop-down list at the left end of the Formatting toolbar and the
Formatting (Styles) toolbar

» Set Paragraph Style drop-down list at the top of the Properties deck of the Sidebar

» Paragraph tab of the Styles deck on the Sidebar

* Styles menu on the Menu Bar (limited to common styles)

» Keyboard shortcuts Ctrl+1 to Ctrl+5 (paragraph styles Heading 1 to Heading 5)

* Formatting (Styles) toolbar using View > Toolbars > Formatting (Styles); see Figure 58.

Formatting (Styles) : v X
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Figure 58: Formatting (Styles) toolbar

Formatting paragraphs directly

You can apply many formats to paragraphs using the icons on the Formatting toolbar and on the
Paragraph panel of the Sidebar’s Properties deck (View > Sidebar) or commands on the Format
menu on the Menu bar. Other formatting options are provided in the Paragraph dialog (page 86).

Formatting toolbar

On the Formatting toolbar, the icons and formats include:
* Set Paragraph Style (drop-down list)
* Align Left, Align Center, Align Right, Justified
* Align Top, Center Vertically, Align Bottom
* Toggle Bulleted List (with a palette of bullet types)
* Toggle Numbered List (with a palette of numbering types)
« Set Outline List Style (with a palette of outline types)
* Set Line Spacing (choose from 1, 1.15, 1.5, 2, or custom spacing)
* Increase Paragraph Spacing, Decrease Paragraph Spacing
* Increase Indent, Decrease Indent, Hanging Indent
» Paragraph (to open the Paragraph dialog)
* Set Line Spacing

Not all toolbar icons are visible in a standard installation, but you can customize the toolbar to
include those you use regularly; see Chapter 1, Introducing Writer.

Sidebar Properties deck

The Sidebar Properties deck (Figure 59) includes panels for applying styles, manually formatting
characters, and manually formatting paragraphs. click the expansion symbol (+ or triangle) to
open the panels if necessary.

Style panel
Includes the Set Paragraph Style drop-down list and icons for Clone Formatting, Update
Selected Style, and New Style from Selection. These tools are described in Chapter 8,
Introduction to Styles.
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Character panel
See Figure 73 on page 91 and the description starting on page 90.

Paragraph panel
Contains most of the formatting controls, including several that are not found on the
Formatting toolbar. Clicking the down-arrow by a button opens the control for further
choices, such as fixed line spacing or color palette.

Each panel's title bar has a More Options button on the right, which opens the relevant dialog
(Paragraph Style, Character, or Paragraph) containing additional settings. Changing the values of
any of these settings affects only the paragraph where the cursor is located, or several
paragraphs if more than one are selected. If you wish to change the values for many paragraphs
of that type, you should use a paragraph style.
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Style ~
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acing: :
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1 Align Left 8 Increase Spacing 15 Indent From Left
2  Align Center 9  Decrease Spacing 16 Indent From Right
3 Align Right 10 Increase Indent 17 Indent First Line
4 Align Justified 11 Decrease Indent 18 Line Spacing
5 Bullets 12 Hanging Indent 19 More Options — opens
6  Numbering 13 Above Paragraph Spacing relevant dialog
7 Background Color 14 Below Paragraph Spacing

Figure 59: Style and Paragraph panels of the Properties deck in the Sidebar

Alignment options

You can use the buttons labelled 1-4 in Figure 59 to choose the alignment of a paragraph: Left,
Right, Centered, or Justified. Figure 60 shows examples of the alignment options applied to text.

Left aligned text.
Center aligned text.
Right aligned text.
Justified text inserts spacing between words to force the text to reach
from margin to margin, if the text is longer than a single line.

Figure 60: Text alignment options

82 | Chapter 4 Formatting Text



When using justified text, the last line is by default aligned to the left. However, you can also align
the last line to the center of the paragraph area or justify it so that spaces are increased between
the words in order to fill the whole line. If you select the Expand single word option, then
whenever the last line of a justified paragraph consists of a single word, this word is stretched by
inserting spaces between characters so that it occupies the full length of the line.

Figure 61 shows an example of the effect obtained when choosing each of these options for a
typical text font. In most cases, leave the setting on the default (left-aligned); but for some

dramatic purposes (such as a very large font on a poster), you might prefer one of the other
choices.

Three options are available for the alignment of the last line of a justified paragraph.
This is an example of a left-aligned last line.

Three options are available for the alignment of the last line of a justified paragraph.
This is an example of a centered last line.

Three options are available for the alignment of the last line of a justified paragraph.
This is an example of a justified last line.

When the last line of a justified paragraph contains a single word, you can stretch the
word to fill the entire line. This is an example with the Expand single word option
S e I e c t e d

Figure 61: Examples of choices for the last line of a justified paragraph

These options are controlled in the Alignment tab of the Paragraph dialog (Figure 62), reached
by choosing Format > Paragraph on the Menu bar, or by right-clicking in the paragraph and
selecting Paragraph in the context menu, or by clicking the More Options button on the
Paragraph panel in the Properties deck of the Sidebar.

[ ] @ Paragraph
Tabs Drop Caps Borders Area Transparency
Indents & Spacing Alignment Text Flow Outline & List
Options
Left
Right
Center
AL usified —
Last line: Justified ]
Siar —
Expalcentered
Snap/|Justified ctive)
Text-to-text
Alignment: Automatic
Properties

Text direction: Use superordinate object settings B3

Figure 62: Options for the last line of a justified paragraph

Line and paragraph spacing

Line spacing (button 18, Figure 59) refers to the distance from one baseline (the imaginary line at
the bottom of a letter like “n” or “m”) to the next baseline. It is determined by the size of the font,
as illustrated in Figure 63.
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The Line Spacing submenu is shown in Figure 64. Here you can choose among standard
spacings or define a custom value: Proportional (for example, 110%), At least (the amount
specified in the Value box), Leading, or Fixed. To see the differences between these choices, do
a few sample paragraphs and change the selections.

baseline n |O re m,lps_LJ,m
line spacin .
baseline i |Ore m- IPSJJ,ED

Figure 63: Line spacing is the distance between two baselines
Note

All options except Fixed or At Least use the font’'s default. These two options allow
you to set your own spacing, which is especially useful at small font sizes to increase

readability.
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Figure 64: Line spacing submenu
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Paragraph spacing refers to the vertical spacing between one paragraph and the paragraphs
above and below it. As shown in Figure 59, the current values are shown in the Above Paragraph
Spacing box (13) and the Below Paragraph Spacing box (14). You can change either or both of
these settings independently.

OTip

Paragraph spacing is often used in computer documentation, such as this book.
Paragraph indentation (see next topic) is more commonly used in other documents.
For good design, use paragraph spacing or paragraph indentation, never both.

Paragraph indentation

You can use the buttons labelled 10, 11, and 12 in Figure 59 to increase the amount of space to
leave between the left and right page margins and the paragraph.

The distances are determined by settings 15 (Before Text Indent; that is, from the left margin), 16
(After Text Indent; that is, from the right margin), and 17 (First Line Indent, which indents the first
line from the left margin, or from the specified indentation from the margin).

Button 12, Switch to Hanging Indent, leaves the first line at the left margin (or the specified
indentation from the margin) and indents all the other lines of the paragraph by the amount
specified by button 17 or in the Paragraph dialog.

This paragraph is an example of a paragraph with a first line indent. 1t is typical of
paragraphs in books.

This paragraph is an example of a paragraph with a hanging indent. 1t is often used
for numbered paragraphs or those with an icon or other image on the left.

Note

In right-to-left languages, the behavior of the Before Text and After Text indents is the
opposite: “before” is on the right margin; “after” is on the left margin.

Paragraph background color

Click the button labelled 7 in Figure 59 to open a palette from which you can choose a color for
the background of the paragraph. From this palette (Figure 65), you can also click Custom Color
to open the Pick a Color dialog, where you can define new colors to be added to the palette.

Note

If the paragraph has been indented from the right or left margin, the background
color is not applied to the area of the indent. To extend the color to the margin, use a
frame, table, or other method; see Chapter 6, Formatting Pages: Advanced.
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Figure 65: Selecting a background color for a paragraph

Settings on the Paragraph dialog

The paragraph dialog includes several more tabs: Tabs (covered in “Setting tab stops and
indents” on page 88), Borders, Drop Caps, Area (more choices than just color), Transparency,
Text Flow, and Outline & Numbering. For more information, see Chapter 8, Introduction to Styles,
and Chapter 9, Working with Styles.

Borders

Borders are useful for setting a paragraph off from the surrounding text, to include digressions
from the main topic. For example, the Tips, Notes, and Cautions in this book use a border below
the text.

Paragraph >

Indents & Spacing Alignment Text Flow Outline & List Tabs Drop Caps Borders Area Transparency

Line Arrangement Padding
Presets: afr)= Left: 0.00 cm =
User-defined: Right: 0.00 cm =
Top: 0.00cm =
Bottorm:  [0.00cm =
Synchronize
Line Shadow Style
Stylee —————————— hd Position: IE” O Ca o
Coler: | Black - Color Gray
Width: |0.05pt = Distance: [0.18cm =

Properties
Merge with next paragraph

Figure 66: Options for paragraph borders
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You can add borders to any combination of top, bottom, and sides of paragraphs. You can
choose the style (solid, dotted, dashed, doubled), width, and color of the lines; these choices
apply to all borders on a paragraph. The spacing from each line to the paragraph’s contents can
be set individually for the top, bottom, left, and right.

On the Borders tab of the Paragraph dialog (Figure 66), you can also choose to apply a shadow
to a paragraph; “distance” refers to the width of the shadow.

Select the Merge with next paragraph option to suppress top or bottom lines when the indent,
border, and shadow styles of the next paragraph are the same as the current paragraph.

Drop caps
Drop capitals are enlarged letters that mark the start of a new chapter or section. To improve

consistency, they are best set up in a paragraph style that you apply to the relevant paragraphs.
See Chapter 9, Working with Styles, for details.

Area

Area (also called “fill” and “background” in some parts of LibreOffice) includes five types of fill
(background): color, gradient, bitmap, pattern, and hatching. Select a fill type to display the
choices available for that type. These choices are covered in more detail in Chapter 5,
Formatting Pages: Basics. You can also create your own fills.

Paragraph X

Indents & Spacing Alignment Text Flow Outline & List Tabs Drop Caps Borders Area Transparency

Color Gradient Bitmap Pattern Hatch

Figure 67: Types of fill for paragraph backgrounds

Transparency

Transparency affects the paragraph’s background. It is useful for creating watermarks and
making colors or images more pale (for more contrast with the text). The available choices are
shown in Chapter 5, Formatting Pages: Basics, and are covered in detail in the Draw Guide.

Text Flow

The Text Flow tab (Figure 68) has several sections. Hyphenation is covered in Chapter 2,
Working with Text: Basics, and breaks are covered in Chapter 5, Formatting Pages: Basics.
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Figure 68: Options for text flow: hyphenation, breaks, and keeping text together
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In the Options section, you can specify how paragraphs are treated at the bottom of a page. Do
not split paragraph and Keep with next paragraph should be self-explanatory. The other options
allow you to avoid a single line at the bottom of a page (called an orphan) or a single line at the
top of a page (a widow).

Outline & List

The Outline & List tab on the Paragraph dialog provides options for choosing the outline level of
the paragraph and its list style (if any). If the paragraph is part of a numbered list, you can specify
that list numbering restarts at the paragraph, and what number to restart with.

This tab does not cover the same functions as the Chapter Numbering dialog (Tools > Chapter
Numbering), but the Outline level selected here is related to the outline defined there. See
Chapter 8, Introduction to Styles, and Chapter 9, Working with Styles, for a discussion of these
features. Line numbering is discussed in Chapter 3, Working with Text: Advanced.

Paragraph x

Indents & Spacing Alignment Text Flow Outline & List Tabs Drop Caps Borders Area Transparency

Outline
Cutline level:

Apply List Style

List style: Mo List = Edit Style

c . -
SLart Wit U -

Line Numbering
Include this paragraph in line numbering

[ Restart at this paragraph

- R -
afart witt -

Figure 69: Selecting outline level, paragraph numbering, and line numbering

Setting tab stops and indents

The horizontal ruler shows the tab stops. Any tab stops that you have defined will overwrite the
default tab stops. Tab settings affect indentation of full paragraphs (using the Increase Indent
and Decrease Indent buttons on the Formatting toolbar or the Paragraph panel of the Properties
deck in the Sidebar) as well as indentation of parts of a paragraph (by pressing the Tab key on
the keyboard).

OTip

Many indents, for example at the beginning of a paragraph, can be set in the
paragraph style, so you don’t need to use the Tab key to activate them.

Using the default tab spacing can cause formatting problems if you share documents with other
people. If you use the default tab spacing and then send the document to someone else who has
chosen a different default tab spacing, tabbed material will change to use the other person’s
settings. Instead of using the defaults, define your own tab settings, as described in this section.

To define indents and tab settings for one or more selected paragraphs, right-click a paragraph
and choose Paragraph to open the Paragraph dialog; then select either the Tabs tab (Figure 70)
or the Indents & Spacing tab of the dialog. Alternatively, you can double-click the horizontal ruler
to open the Indents & Spacing tab of the Paragraph dialog. A better strategy is to define tabs for
the paragraph style. Refer to Chapters 8 and 9 for more about paragraph styles.
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Paragraph X

Indents 8 Spacing Alignment Text Flow Outline & List Tabs Drop Caps Borders Area Transparency

Position Type Fill Character
MNew

5.00cm ® | eft C
O Right , Delete 3l
10,00 cm

(O Centered L Delete

O Character
) Decimal &
Character

Figure 70: Specifying tab stops and fill characters

GTip

Using tabs to space out material on a page is hot recommended. Depending on what
you are trying to accomplish, a table or frame is usually a better choice.

Changing the default tab stop interval

Caution

Any changes to the default tab setting will affect the existing default tab stops in any
document you open afterward, as well as tab stops you insert after making the
change.

To set the measurement unit and the spacing of default tab stop intervals, go to Tools > Options
> LibreOffice Writer > General.

Settings

Measurement unit: | Centimeter ﬂ

Tab stops:  0.64 cm Iil

Figure 71: Selecting a default tab stop interval

Changing measurement units for tab stops and rulers

You can also set or change the measurement unit for rulers in the current document by right-
clicking on the ruler to open a list of units, as shown in Figure 72 for the horizontal ruler. Click one
of them to change the ruler to that unit. The selected setting applies only to that ruler.

1 e 1 2
Millirmeter
v |Centimeter
Inch
Point
Pica
Char

Figure 72: Changing the measurement unit for a ruler
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Formatting characters using styles

To apply a character style, highlight the characters or words and apply the selected character
style from any of the following:

* Character Styles tab of the Styles deck on the Sidebar
* Styles menu on the Menu bar (limited)

* Right-click context menu (limited)

* Formatting (Styles) toolbar (Figure 58)

For more about character styles, refer to Chapter 8, Introduction to Styles, and Chapter 9,
Working with Styles.

Formatting characters directly

You can apply many formats to characters using the buttons on the Formatting toolbar and by
using the Characters panel of the Properties deck of the Sidebar. Not all toolbar buttons are
visible in a standard installation, but you can customize the toolbar to include those you use
regularly; see Chapter 1, Introducing Writer. These formats include:

* Font Name, Font Size

* Bold, Italic, Underline, Double Underline, Overline, Strikethrough, Outline

» Superscript, Subscript

* Uppercase, Lowercase

* |Increase Font Size, Decrease Font Size

* Font Color (with a palette of colors)

* Background Color (with a palette of colors)

* Highlighting (with a palette of colors)
To change the characteristics of an entire paragraph (for example the font name, size, or color),
and for many other purposes, it is highly recommended that you use styles rather than manually

formatting characters. For information on styles and how to use them, see Chapters 8 and 9.
Applying styles is quick and easy using the Styles deck of the Sidebar.

Figure 73 shows the Character panel in the Properties deck of the Sidebar. Clicking the down-
arrow next to a button opens the control for further choices, such as font color or character
spacing. The appearance of the buttons may vary with your operating system and the selection
of icon size and style in Tools > Options > LibreOffice > View.

Click the More Options button (15) to open the Character dialog, which includes more choices
than are available through the Formatting toolbar or the Sidebar.
Note

Just as direct paragraph formatting overrides the current paragraph style, applying
direct character formatting to characters overrides the current character style
formatting.

Font name, size, and effects

To change the font name and size used for selected characters, you can use the drop-down
menus on the Formatting toolbar, the Character panel in the Sidebar, or the Character dialog.

Similarly, you can apply bold, italics, underline, strikethrough, or shadow effects to selected
characters on the Formatting toolbar, the Character panel in the Sidebar, or the Character dialog.
The Underline effect has a drop-down menu of line types (Figure 74). The Formatting toolbar
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includes other effects that are not in the Sidebar: overline and double underline; these buttons
may not be visible in a default installation.

To choose the color of the font or its highlighting, open the appropriate color palette (10 or 11;
similar to the one shown in Figure 65). The highlighting selection over-rides any background
color that has been applied to the paragraph.

To increase or decrease the font size of selected characters, you can click the relevant buttons
on the Formatting toolbar or the Character panel in the Sidebar; however, you have no control
over the amount of the increase or decrease, which is usually 2 points. For finer control, use the
Font Size drop-down list instead.

! Properties X
Style m
Character 16 =
]
Liberation Sans 12 pt ? A
a 581 ) &
A o
1;2 13 141
- AU A w? x,—. @
Paragraph =
1 FontName 6 Strikethrough 11 Highlight Color
2 Font Size 7 Toggle Shadow 12 Clear Direct Formatting
3 Bold 8 Increase Font Size 13 Set Character Spacing
4 ltalic 9 Decrease Font Size 14 Superscript
5 Underline 10 Font Color 15 Subscript

16 More Options — opens Character dialog

Figure 73: Character panel in the Properties deck of the Sidebar

& - 4 lWwikc

Paray

Page

More Options...

Figure 74: Selecting the line
style for the Underline effect
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To change characters into subscripts or superscripts (using the default values for size and
position), select them and click the relevant buttons on the Formatting toolbar or the Character
panel in the Sidebar. For more control, use the Character dialog.

To quickly change the spacing between characters, select them and choose from the
Character Spacing drop-down menu in the Sidebar (Figure 75).

B @a |

AP AP A i
g Fw TH FE
b
=]
=
=
w

Very Loose
- Last Custom Value
Custom Value
0.0 pt 8

—

Figure 75: Changing character spacing

Settings on the Character dialog

The Character dialog has six tabs, described in this section. Most of these tabs are the same as
the tabs on the Character Style dialog (see Chapter 9, Working with Styles).

Font and Font Effects

On the Font tab (Figure 76), you can specify the font’s family, style (choices vary with the font,
but typically include regular, bold, and italic), and size; and the language for the paragraph, if it
differs from the language for the document. The box at the bottom shows a preview of the
selections.

5] B Character

Font Font Effects Pasition Hyperlink Highlighting Borders

Family: Typeface: Size:

Liberation Sans Regular 11 pt

Lao Sangam MN Regular [ 111 pt
Liberation Mono Bold |12 pt
Liberation Sans Italic 113 pt
Liberation Sans Narrow Bold Italic |14 pt
Liberation Serif |15 pt

Linux Biolinum G |16 pt

Linux Libertine Display G |18 pt

Linux Libertine G |20 pt

Lucida Grande 122 pt

Luminari 24 pt
Malavalam MN B | |26 nt
Language: English (USA) [ ] Features...
The same fant will be used on both your printer and your screen.

Figure 76: Font tab of the Character dialog
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On the Font Effects tab (Figure 77), you can choose the color of the font and a range of effects,
many of which are not suitable for formal documents. Figures 78 and 79 show the choices in
some of the drop-down lists.

®C@® Character

Font Position  Hyperlink  Highlighting  Borders
Font Color
Font color: ' Automat

Transparency: 0% 2]

Text Decoration

Overlining: (Without) E Automatic
Strikethrough: | (Without) w
Underlining: (Without) E Automatic
Individual words
Effects
Case: (Without) E Hidden
Relief: (Without) E Outline Shadow

Figure 77: Font Effects tab of the Character dialog

Effects
Case: (Without) E Hidden
(Without)
Relief: UPPERCASE Qutline Shadow
lowercase

Capitalize Every Word
Small capitals .

Figure 78: Choices for Case effect

Strikethrough:  (Without) E Effects
(Without) - , -
Underlining: Single ’ (Aot <
Double Relief: (Without) -
Bold (Without) L

Effects With / Embossed
With X Engraved ]

Figure 79:Choices for strikethrough and relief

Position

The Position tab (Figure 80) collects the options that affect the position of text on the page. This
tab is divided into three sections: Position, Rotation/Scaling, and Spacing.

The Position section controls the appearance of superscripts and subscripts.

The Rotation/Scaling section controls the rotation of the characters. The Scale width box controls
the percentage of the font width by which to compress or stretch the rotated text.

The Spacing section controls the spacing between individual characters. The Pair Kerning option
(selected by default) automatically adjusts the character spacing for specific letter combinations.
Kerning is only available for certain font types and, for printed documents, works only if your
printer supports it.

Formatting characters directly | 93



& [ Character

Font | Font Effects

Hyperlink  Highlighting  Borders
Position
© Normal _
Superscript Raiseflower by 1% (2] v Automatic
Subscript Relative font size  100% |f|
Rotation | Scaling
© 0degrees
90 degrees  Scale width 100% 2] Fit to line
270 degrees
Spacing

Character spacing 0.0 pt |f| Pair kerning

Figure 80: Position tab of the Character dialog

Hyperlink

The Hyperlink tab of the Character dialog is an alternative to using the Hyperlink dialog (Insert >
Hyperlink). It includes fewer choices and is specifically for text (not button) links. Hyperlinks can
be to other parts of the same document, to other documents, or to web pages.

Font  FontEffects  Paosition iy iy Highlighting  Borders
Hyperlink

URL: Browse...
Text:
MName:

Target frame:

Events...

Character Styles
Visited links: Visited Internet Link

Unvisited links: | Internet Link

Figure 81: Hyperlink tab of the Character dialog

When LibreOffice recognizes a string of characters that may be a URL (internet address), it
replaces the characters with a hyperlink and formats the hyperlink as specified in the Internet
Link character style. On this dialog you can choose a different character style (if the style has
been defined previously) or replace the URL with other text. To turn off this feature, choose Tools
> AutoCorrect > AutoCorrect Options, go to the Options tab and deselect URL Recognition.

For more about creating and editing hyperlinks, see the Help system or Chapter 12 in the Getting
Started Guide.
Highlighting

The Highlighting tab controls the background color for selected characters. It is similar to the
Highlighting drop-down palette.
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Borders
The Borders tab is the same as the Borders tab on the Paragraph dialog; see page 86.

Formatting lists using styles

Whenever possible, use paragraph styles for creating unordered (bulleted) and ordered
(numbered) lists. Writer comes with two sets of paragraph styles for this purpose. However, these
styles do not include options for settings such as the type of bullet or position of numbers. Those
settings come from list styles, which are intended to be attached to paragraph styles. It is
recommended to use them together in these ways:

» Use paragraph styles List 1, List 2, List 3, and so on for creating unordered lists. These
styles use Bullet list styles.

* Use paragraph styles Numbering 1, Numbering 2, Numbering 3, etc, for creating ordered
lists. These styles use the list styles called Numbering 1, Numbering 2, etc.

With paragraph styles, you can easily create nested lists, in which list items have sub-items
under them, as in an outline. This requires specifying the settings for the additional levels. Once
you have set up nested lists, you can readily change the hierarchy of an item. To demote an item
one level, position the cursor at the beginning of the line (after the bullet or number) and press
the Tab key. To promote an item one level, press Shift+Tab.

For more about creating lists using styles, see Chapters 8 (Introduction to Styles), 9 (Working
with Styles) and 12 (Lists: Tips and Tricks).

Formatting lists directly

You can directly format numbered or bulleted lists in several ways:

» Use the Bullets and Numbering toolbar (Figure 82).

* Use the Toggle Unordered List and Toggle Ordered List buttons on the Formatting
toolbar, the Formatting (Styles) toolbar, or the Paragraph panel of the Properties deck of
the Sidebar (Figure 83).

* Use the Bullets and Numbering dialog (Figures 84 and 85).

To produce a simple numbered or bulleted list, select the paragraphs in the list and then click the
appropriate icon on the Paragraph panel on the toolbar.

ﬂTip

It is a matter of personal preference whether you type your information first, then
apply numbering/bullets or apply these as you type.

Note

Bullets and numbering applied in these ways cannot be removed with Format >
Clear Direct Formatting on the Menu bar, or with the Clear Direct Formatting icon
on the Formatting toolbar, or with Clear Direct Formatting in the context menu, or
by using Ctrl+M. Rather, they are turned off or removed from selected text by toggling
the relevant buttons on the Formatting toolbar, or on the Sidebar Properties deck.
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Using the Bullets and Numbering toolbar

You can create a nested list (where one or more list items has a sub-list under it, as in an outline)
by using the buttons on the Bullets and Numbering toolbar (Figure 82). You can move items up or
down the list, create subpoints, change the style of bullets, add paragraphs without numbers or
bullets (for list items that include more than one paragraph), and access the Bullets and
Numbering dialog, which contains more detailed controls.

Use View > Toolbars > Bullets and Numbering to display the toolbar.

[ XEZF|iEE o E SIS EE
1 2 3 4 5 6 7 8 9 10 1
1 Demote One Level 5 Move Down 9 Insert Unnumbered Entry
2 Promote One Level 6 Move Up 10 Restart Numbering
3 Demot_e One Level with 7 Move Down with Subpoints 11 Open th_e BuI_Iets and
Subpoints Numbering dialog
4 Promote One Level with 8 Move Up with Subpoints
Subpoints

Figure 82: Bullets and Numbering toolbar

OTip

You can use keyboard shortcuts to move paragraphs up or down the outline levels.
Place the cursor at the beginning of the numbered paragraph and press:

Tab = Down a level
Shift+Tab = Up a level

To insert a tab stop at the beginning of a numbered paragraph (that is, after the
number but before the text), press Ctrl+Tab.

If you create a nested list using the buttons on the Bullets and Numbering toolbar, all the levels of
the list (up to 10) initially apply the same numbering (or bullet) format. If you want to use a
combination of numbering formats and bullets when creating nested lists, you can use these
ways:

* Click in each list item and then select one of the choices in the drop-down palettes under
the Toggle Unordered List and Toggle Ordered List buttons on the Formatting toolbar or
the Properties deck of the Sidebar, as described in “Using the Bullets and Numbering
palettes on the Sidebar” below.

* Use the Bullets and Numbering dialog, as described in “Using the Bullets and Numbering
dialog” on page 97.

However, a much better strategy is to define and apply a list style, as discussed in Chapter 12,
Lists: Tips and Tricks.

Using the Bullets and Numbering palettes on the Sidebar

The Bullets and Numbering palettes on the Paragraph panel on the Properties deck of the
Sidebar can be used to create nested lists and access the Bullets and Numbering dialog. The
Sidebar does not include tools for promoting and demoting items in the list, as found on the
Bullets and Numbering toolbar.
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Figure 83: Bullets and Numbering choices on the Properties deck of the Sidebar

Using the Bullets and Numbering dialog

The Bullets and Numbering dialog has six tabs. Four tabs provide pre-defined symbols and
sequences to choose from: Unordered, Ordered, Outline (choose from eight standard outline
sequences), and Image (choose a bullet image). Two tabs provide detailed options for defining
your own lists: Position (Figure 84) and Customize (Figure 85). These are the same as the tabs
provided for list styles, discussed in Chapter 12, Lists: Tips and Tricks.

Bullets and Mumbering >

Unordered Ordered Outline Image Position Customize

Position and 5 pacing Level

Aligned at: = _

2

Mumbering alignment: |Right ~ | 3

MNumbering followed by: |Tab stop ~ | 4

5

Iab stop at:  [0.00cm = B

Indent at:  [1.27 cm = 7

a

Preview a

=
J—
=]
—_
=]

Default

Help Remove Reset oK Cancel

Figure 84: Position tab of the Bullets and Numbering dialog
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Unordered Ordered Outline Image Position Customize
Level Numbering Preview
MNumber: |'I_. 23 .. e | 1
2
3 Startat: |1 = 1
4 Character style: |Numbering Symbols w | 1
5
A Show sublevels: |1 = 1
7 Separator 1
8 Before:
g Before: .
10 After:
1-10 L
All Levels 1
[] Consecutive numbering

Figure 85: Customize tab of the Bullets and Numbering dialog

Autoformatting

You can set Writer to automatically format parts of a document according to the choices made on
the Options and Localized Options tabs of the AutoCorrect dialog (Tools > AutoCorrect >
AutoCorrect Options). The Help describes each of these choices and how to activate the
autoformats.

eTip

If you notice unexpected formatting changes occurring in your document, this is a
good place to look for the cause.

To automatically format the file according to the options you have set, choose Tools >
AutoCorrect and select or deselect the items on the submenu.

While Typing
Automatically formats the document while you type.

Apply
Automatically formats the document.
Apply and Edit Changes

Automatically formats the file and then opens a dialog where you can accept or reject the
changes.

AutoCorrect Options
Opens the AutoCorrect dialog (Figures 86 and 87), where you can choose the
autoformatting you want.

The Localized Options tab (Figure 86) controls the formatting of quotation marks and
apostrophes (which look like a closing single quote). Most fonts include curly quotation marks
(also known as “smart quotes”), but for some purposes (such as marking minutes and seconds of
latitude and longitude) you may wish to format them as straight quotes.

Straight quotes Smart quotes
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ﬂTip

Most people keep the AutoCorrect setting for smart quotes and use the Special
Characters dialog to insert straight quotes when needed. See Chapter 2, Working

with Text: Basics.

AutoCorrect

lepl

1]

CEMENTS al

nd exceptions for language:  [English (USA)

Replace Exceptions Options Localized Options Word Completion

1 | m |

Format ordinal numbers suffixes (st -> 1"ct)

RIRIRIE
RIRIRIE

Replace << and »> with angle quotes

Add non-breaking space before specific punctuation marks in French text

Transliterate to Old Hungarian if the text direction is from right to left

Figure 86: Autoformatting quotation marks

Replace Exceptions Options Localized Options Word Completion

Single Quotes Double Quotes
Replace Replace
Start quote: ' Default Start quote: Default
End quote: ' Default End quote: " Default
Default Default

M1 | m |

Use replacement table

Correct TWo INitial CApitals

Capitalize first letter of every sentence

Automatic *bold®, fitalic/, -strikeout- and _underline_
URL Recognition

Replace dashes

Delete spaces and tabs at beginning and end of paragraph
Delete spaces and tabs at end and start of line

lgnore double spaces

Correct accidental use of cAPS LOCK key

Bulleted and numbered lists. Bullet symbeol:

RIEIRIRIRIEIR]

ORO0ORORIEEIE R ELE]

Apply border
Create table
Apply Styles
| Remove blank paragraphs
Replace Custom Styles
Replace bullets with: «
Combine single line paragraphs if length greater than 503
= [M]: Replace while modifying existing text
it

[T]: AutoCorrect while typing

Figure 87: Autoformatting choices on the Options tab
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Introduction

Writer provides several ways for you to control page layouts. This chapter describes the use of
page styles and some associated functions:

* Margins

* Page breaks

* Headers and footers

* Page numbering

» Title pages

* Footnotes and endnotes

Chapter 6, Formatting Pages: Advanced covers the use of columns, frames, tables, and sections;
changing page orientation within a document; and the use of borders and backgrounds. Some
other uses of page styles are discussed in Chapter 8, Introduction to Styles. The Page Style
dialog is covered in detail in Chapter 9, Working with Styles.

Note

All pages in a Writer document are based on page styles. The other layout methods
(described in Chapter 6) build upon the underlying page style.

ﬂTip

Page layout is usually easier if you select the options to show text, object, table, and
section boundaries in Tools > Options > LibreOffice > Application Colors and the
options for paragraph ends, tabs, breaks, and other items in Tools > Options >
LibreOffice Writer > Formatting Aids.

Setting up basic page layout using styles

In Writer, page styles define the basic layout of all pages, including page size, margins, the
placement of headers and footers, borders and backgrounds, number of columns, page
numbers, and so on.

Writer comes with several page styles, which you can build on or modify, and you can define new
(custom) page styles. You can have one or many page styles in a single document. If you do not
specify a page style, Writer uses the Default Page Style.

To change the layout of individual pages, either define a new page style or use one of the
techniques (sections, frames, or tables) described in Chapter 6, Formatting Pages: Advanced.

Note

For some documents, all layout changes (such as the position of page numbers and
other elements in a header or footer on facing pages) can be defined in a single
page style.

ﬂTip

Any modifications of page styles, including the Default Page Style, apply only to the
document you are working on. If you want the changes to be the default for all
documents, you need to put the changes into a template and make that template the
default template. See Chapter 10, Working with Templates, for details.
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Changing page margins

You can change page margins in these ways:

* Using the page rulers—quick and easy, but does not have fine control.
* Using the Page Style dialog—can specify margins to two decimal places.
* Using the Page deck in the Sidebar—changes all margins to the same value.

Note

If you change the margins using any of these methods, the new margins are
recorded in the page style and affect all pages that use that style. The new margins
will be shown in the Page Style dialog the next time you open it.

If you want to change the margins on some pages, but not others, you must use
different page styles and switch between them; see “Inserting page breaks” on page
104.

To change margins using the rulers:

1) The shaded sections of the rulers are the margins (Figure 88). Put the mouse cursor over
the line between the gray and white sections. The pointer turns into a double-headed
arrow and displays the current setting in a tooltip.

2) Hold down the left mouse button and drag the mouse to move the margin.

L LA

Figure 88: Moving the margins

Caution

The small arrows on the ruler are used for indenting paragraphs. They are often in
the same place as the page margins, so you need to be careful to move the margin
marker, not the arrows. The double-headed arrows shown in Figure 88 are the
mouse cursors placed in the correct position.

O ip
After making a change, passing the mouse cursor over the new margin will show its
new measurement.

To change margins using the Page Style dialog:

1) Right-click anywhere on the page and select Page Style in the context menu.

2) On the Page tab of the dialog (Figure 89), type the required distances in the Margins
boxes. The Gutter margin is the extra space to leave between the left (or inner) edge of
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the page and the left (or inner) margin. Alternatively, you can leave the Gutter set to zero
and add the gutter margin amount to the left or inner margin value.

3) Click OK to save.

[ ] @ Page Style: Default Page Style

Organizer Page Area Transparency Header Footer Borders Columns Footnote
Paper Format

Format: Ad 1]

Width: 21.00 cm :

Height: 29.70 cm =

Orientation: ) Portrait

Landscape Paper tray: [From printer settings]

Margins Layout Settings

Inner: 2.50 em = Page layout: Mirrored

Quter: 1.80 em C Page numbers: 1,2, 3, ...

Top: 2.00 cm el Reference Style:

Bottom: 2.00 em 2 Use page line-spacing

Caniee: .00 cm C Gutter position:  Left

Gutter on right side of page
Background covers margins

Figure 89: Page tab of Page Style dialog

To change margins using the Page deck in the Sidebar, choose one of the preset margins in the
drop-down list (Figure 90). You can also access the Page Style dialog from the symbol at the top
right of the Format section’s title bar.

! Page =
= Format M= -
Size: |Ad V| ﬁ
Width: |21.00 cm =
Height: |20.70 cm S L
Crientation: |Portrait V| @
S ust.:m-. ............................................. D
Mone
=
S Marrow ’%?
Moderate

Mumber:
Maormal (1.90 crm)

Background: |Mormal (2.54 cm)
Mormal (3.18 crm)
Layout: [aride

Mirrored

Custom

Columns:

Figure 90: Changing margins using the Sidebar

Q Note

Changing the margin on the Sidebar changes all four margins to the same
dimension. Use another method if you want margins of different sizes.
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Inserting page breaks

In many documents (for example, a multi-page report), you want the text to flow from one page to
the next as you add or delete information. Writer does this automatically, unless you override the
text flow using one of the techniques described in this section.

Controlling automatic page breaks
You can control some of the automatic text flow in several ways, including:

* Use the Keep with next paragraph option, for example to prevent the lead-in sentence
to a list from being separated from the list. This option is found on the Text Flow tab of
the Paragraph dialog (right-click and choose Paragraph > Paragraph in the context
menu to open the dialog).

Options
Do not split paragraph
Keep with next paragraph

Orphan control 2 (2] lines

Widow control 2 (2] lines

Figure 91: Keep with next paragraph and Do not
split paragraph options on Paragraph dialog

* Use the Do not split paragraph option on the Text Flow tab of the Paragraph dialog (for
individual paragraphs) or the Paragraph Style dialog (for all paragraphs with that style).

* Use a paragraph style to require a paragraph to start on a new page. A typical use is for
chapter titles to always start on a new right-hand (odd-numbered) page; use the
Paragraph Style dialog to define this (see “Text flow options for paragraph styles” in
Chapter 9, Working with Styles, for more information).

Inserting a page break without changing the page style

If you want a page break in a particular place—for example, to put a heading at the top of a new
page—you can position the cursor at the point where you want to start the new page and select
Insert > Page Break on the Menu bar.

Inserting a page break and changing to a new page style

If you want the new page to have a different page style—for example, to change from a First
Page style to a Left Page style—use either of these methods.
Caution

Do not try to change a page style for a single page without inserting a page break. If
you do, the page style of some or all of the other pages may also change.

Method 1

1) Position the cursor at the point you want to start the next page. Select Insert > More
Breaks > Manual Break.

2) Inthe Type section of the Insert Break dialog (Figure 92), Page break is preselected, and
Style is set at [None]. In the Style drop-down list, select the page style for the next page.
Do not select the Change page number option. Click OK.
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Figure 92: Inserting a manual page break and changing the page style
Method 2

1) Position the cursor in the paragraph you want to be at the start of the next page. Right-
click and choose Paragraph > Paragraph in the context menu.

2) On the Text Flow page of the Paragraph dialog (Figure 93), in the Breaks section, select
Insert and With page style. In the Style drop-down list, select the page style for the next
page. Do not select the Page number option. Click OK to insert the page break.

Breaks
Insert

Type: Page

Position: Before

With page style: Default Page Style E

| -

Page number: 1

Figure 93: Inserting a manual page break
using the Paragraph dialog

ﬂTip

See “Numbering the first page something other than 1“ on page 111 for information
on the use of the page number field in these dialogs.

Creating headers and footers

Headers are portions of a document that appear at the top of every page; footers appear at the
bottom of a page. They typically include a page number and sometimes document information
such as the title. In Writer, headers and footers are specified in page styles; therefore, all the
pages with the same page style will display the same header and footer, although the contents of
the header/footer may vary. For example, the header/footer on the first page of a section,
chapter, or document may contain different information than the rest of the headers and footers in
the document, even though the page style is the same. See “Using one page style” on page 114.

Chapter 9 describes how to format a header as part of the page style formatting. The example
below shows how to insert a header in the Default pages using manual formatting.
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0 Terminology

A heading is a paragraph that introduces a chapter or section of a document; for
example, “Creating headers and footers” above. A header (also known as a running
header) appears on each page and typically displays information about the
document.

There are two ways to insert a header. The simplest method is to click above the top of the text
area, then when the Header marker appears, click the +. (To insert a footer, click below the
bottom of the text area to display the Footer marker, and then click the +.)

Writer provides several ways for you to control page layouts. This chapter describes the use of
page styles and some associated functions:

Figure 94: Header marker at top of text area

You can also select Insert > Header and Footer > Header > [Page Style] on the Menu bar. The
submenu lists the page styles used in your document. In addition, the submenu includes the
entry All, which activates headers on all the pages of the document regardless of their page
style. Similarly, to insert a footer, choose Insert > Header and Footer > Footer > [Page Style].

For our example, select Default Style to activate the headers or footers only on the pages that
use the Default Page Style. An area will appear at the top or bottom of the page (Figure 95).

L 1 &7 1o 2.1 -3 .4 5 6.+ 7 :-8-:-9 0 a1
Page Header
The Old Salt
[ was walking through the Dockyard in a parnic,
Whern I met a matelot old and grey.

Figure 95: A page with a page header

Formatting headers and footers

In Writer, headers and footers are paragraphs; therefore, you can format the header or footer text
using the same techniques you use for formatting text in the main body of the document. See
Chapter 4, Formatting Text.

You can also add images to headers and footers using any of the techniques described in
Chapter 11, Images and Graphics, and you can line up information using tables as described in
Chapter 6, Formatting Pages: Advanced.

OTip

Writer provides paragraph styles for headers and footers, which you can modify and
use in the same way as other paragraph styles. See Chapter 8, Introduction to
Styles, and Chapter 9, Working with Styles.
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To format the layout of headers and footers manually:
Use any of these methods to open the relevant page style dialog:

— Click anywhere on the page and choose Format > Page Style on the Menu bar.
— Right-click anywhere on the page and choose Page Style in the context menu.

— If the page has a header, click in the header area. When the Header marker appears,
click the down arrow and select Format Header.

— If the page has a footer, click in the footer area. When the Footer marker appears,
click the down arrow and select Format Footer.

On the Header or Footer tab of the Page Style dialog (Figure 96), you can change the

1)

2)

3)

margins, spacing, and height.

Click More to open the Border/Background dialog (Figure 97), where you can add
borders, background colors, and background images to the header or footer.

| @ Page Style: Default Style

Organizer = Page Area  Transparency Header | Footer | Borders Columns  Footnote

Footer
~/ Footer on

Same content on left and right pages

7) Same content on first page

Left margin: 0.00em
Right margin: 0.00 cm
Spacing: 0.50 ecm

Use dynamic spacing
Height: 0.50 ecm
] AutoFit height

Mare...
|

Figure 96: Footer tab of Page Style dialog

1)

1)

1)

@] . E:order i Béckgmund
5 W-CLC0 Area  Transparency
' Line Arrangement Padding
| ooz e 0.0scm | [2]
' Mk Rightt  0.05cm ||
| e Top: 0.05cm | [I]
i Bottom: 0.05cm |21

| Synchronize

| Line Shadow Style

| Style: _—— - Position: ’E ’E IE IE

| Color: M Black - Color
| width: | 005pt | [7] Distance

Black

0.10 ecm

[
<

Figure 97: Border / Background page for header or footer
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Using fields in headers and footers

You can type information into headers and footers, but some items such as document titles and
chapter titles are best added as fields. That way, if something changes, the headers and footers
are all updated automatically.

Fields are covered in Chapter 17, Fields, but one example here may be useful. To insert the
document title into the header on a Default page style:

1) Select File > Properties > Description on the Menu bar, enter a title for the document in
the Title area, and click OK to close the dialog.

2) Add a header (Insert > Header and Footer > Header > [Page Style]).
3) Place the cursor in the header part of the page.

4) Select Insert > Field > Title on the Menu bar. The title should appear on a gray
background (which does not show when printed and can be turned off).

5) To change the title of the document, select File > Properties > Description again and
edit.

Note

You must use a field for the page number so it changes from one page to the next.
See “Numbering pages” below.

Numbering pages

When you place a page number field in a header or footer, the number appears on every page
and changes automatically from one page to the next. The page number appears with a gray
background. This gray background denotes a field; although it is visible on screen, it is not
printed.

ﬂTip

If you wish to turn off the gray background, choose View > Field Shadings (or press
CtrI+F8). If you see the words “Page number” instead of a number, press Ctrl+F9.
This toggles Writer between displaying the field name and the contents of the field.

This section describes some technigues to insert page numbers and related information in
headers or footers of a document:

* Simple page numbering

* Defining the number format

* Restarting page numbering and changing numbering format

* Numbering the first page something other than 1

* Combining header text and page number

* Numbering pages by chapter

Simple page nhumbering

The simplest case is to have the page number at the top or bottom of every page and nothing
more (Figure 98). To do this, put the cursor on the header or footer and choose Insert > Page
Number or Insert > Field > Page Number on the Menu bar.
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The Old Salt

[ was walking through the Dockyard in a panic,
When [ met a matelot old and grey.

Upon his back he had his kitbag and his hammock,
- And this is what I heard him say.

Figure 98: Page number inserted in the header

You can align the page number to the left, right, or center. Click in the footer paragraph and then
use one of these methods:

Click on one of the alignment icons on the Formatting toolbar.

Open the Properties deck in the Sidebar. In the Paragraph section, click on one of the
alignment icons (Figure 99).

: Properties
~ Style

~ Character
~ Paragraph
==
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Figure 99: Alignment icons in Properties deck of Sidebar

Right-click and choose Paragraph > Paragraph in the context menu. On the Paragraph
dialog, go to the Alignment tab and choose an alignment option, then click OK.

Paragraph

Indents & Spacing Alignment Text Flow Outline & List Tabs Drop Caps Borders Area Transparency

I
Expand single word I
Snap to text gnid (if active)
ST I
Text-to-text
Alighment: ‘Autu:rmatic W ‘
Properties

Text direction: ‘Use superordinate object settings |~ ‘

Figure 100: Alignment tab of the Paragraph dialog
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Defining the number format

Many more variations are possible. For example, you can set the page number to display in
Roman numerals. One way to do that is to double-click the page number and select the desired
format; a better choice is to specify the format of numbers in the page style as explained here.

Right-click in the text area of the page and select Page Style in the context menu.
On the Page tab of the Page Style dialog, in the Layout Settings section on the right, select
i, ii, iii, .... in the Page numbers: drop-down list to use lowercase Roman numerals (Figure 101).

Layout Settings

Page layout: Mirrored
Page numbers: 1,2, 3, ..
s 123
Reference Style: 15 B, C

ab,c,

1,1, |||,_
Gutter position: i, ii, i,

1st, an, 3rd, ...

One, Two, Three, ...
First, Second, Third, ...

Figure 101: Changing format of page numbers

Caution

Any change in the number format affects the page numbers on all pages using that
page style, regardless of the method used to change the format. To change the
format of page numbers on some pages but not all, you need to use different page
styles; see “Restarting page numbering and changing numbering format” below.

Restarting page nhumbering and changing nhumbering format

You may want to restart the page numbering at 1, for example, on the page following a title page
or a table of contents. In addition, many documents have the front matter (such as the table of
contents) numbered with Roman numerals and the main body of the document numbered in
Arabic numerals, restarting at 1.

First, you need to define the numbering format for two page styles: Front Matter and Default. See
“Using different page styles” on page 114 and “Defining the number format’ above.

Next, in the front matter, insert a page number (see “Simple page numbering” on page 108).
Then, you can restart page numbering as follows:

1) Place the cursor in the first paragraph of the page to have the Default page style. (A
heading is a paragraph.)

2) Choose Format > Paragraph on the Menu bar, or right-click and choose Paragraph >
Paragraph, to display the Paragraph dialog.

3) Onthe Text Flow page of the Paragraph dialog, in the Breaks area (Figure 102):
a) Select Insert.
b) In the Type drop-down list, select Page.
c) Inthe Position drop-down list, select Before.

d) Select With page style and choose from the drop-down list the page style for the
next page.
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e) Select Page number to make the field active. Type 1. Click OK.

Breaks
Insert

Type: Page &
Position: Before a
With page style: Default Page Style &

Page number: 1 =

Figure 102: The Breaks section of the Text
Flow page of the Paragraph Style dialog

Numbering the first page something other than 1

Sometimes you may want to start a document with a page number greater than 1. The
instructions are similar to Step 3 in the previous section.

1) Insert a page number in the header or footer (Insert > Page Number).

2) Click in the first paragraph in the text area. Choose Format > Paragraph (or right-click
and choose Paragraph > Paragraph in the context menu).

3) Inthe Text Flow page of the Paragraph dialog, in the Breaks section (Figure 102), select
Insert and select Page in the Type drop-down list. Select With page style and the page
style you are using for the first page of the document.

4) Select Page number to make the field active. Type the page number you want to start
with. Click OK.

Note

If you set a starting page number that is an even number, you will end up with a
blank page before the first page. LibreOffice adheres to the convention that odd page
numbers go on right-hand pages and even page numbers on left-hand pages.
However, you can suppress this blank page when you print the file or export it as a
PDF. See Chapter 7, Printing, Exporting, Emailing, Signing for more information.

Combining header text and page number
You can apply a lot of interesting variations without further knowledge of page styles. Here are

some

suggestions:

Right-align the header to make the page number appear on the top-right.

Type the word Page (and a space) before the page number field so the header reads
Page 1, Page 2, and so on.

Add the document title so the header includes, for example: Peter’s Favourite Poems (left

aligned) and Page x (right aligned), where x is the value of the Page Number field. Use a
right-aligned tab to separate the title from the page number.

Writer also has a Page Count field (Insert > Field > Page Count). Using it and the page
number field, you could, for example, have a header that reads Page 2 of 12.

These variations are all illustrated in Figure 103.
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Peter's Favourite Poems Page 1 of 4

The Old Salt

[ was walking through the Dockyard in a panic,
When [ met a matelot old and grey.
Upon his back he had his kitbag and his hammock,

Figure 103: Variations on the simple page numbering method

Numbering pages by chapter

Technical documents often include the chapter number with the page number in the header or
footer. For example, 1-1, 1-2, 1-3, ...; 2-1, 2-2, 2-3, ... To set up this type of page numbering in
Writer, you need to do three things:

1) Ensure that your chapter titles are all identified by the same paragraph style, for example,
the Heading 1 style.

2) Use Tools > Chapter Numbering to tell Writer what paragraph style you are using for
Level 1, and specify “1,2,3” in the Number box.

& Chapter Numbering
QHGHBRHRG ~oson
Level Numbering Preview
1 Number: 11,2, 3, ... B 1 Heading 1
2 m Heading 2
3 Start at: 1 8 g
4 Heading 3
5 Paragraph style: |Heading 1 E Heading 4
6
7 Character style: |None B Heading 5
8 Show sublevels: (2] Heading 6
° Headina 7

Figure 104: Specifying paragraph style and numbering for chapter titles
3) Insert the chapter number in the document:

a) Place the cursor in the header or footer just before the page number you inserted
earlier, and choose Insert > Field > More Fields on the Menu bar.

b) On the Fields dialog (Figure 105), go to the Document tab. Select Chapter in the
Type list, Chapter number in the Format list, and 1 in the Level box. Click Insert.

c) Type a hyphen or other punctuation between the chapter number and the page
number.
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Figure 105: Inserting a chapter number field

Defining a different first page for a document

Many documents, such as letters and memos, have a first page that is different from the other
pages in the document. For example, the first page of a letterhead typically has a different
header, as shown in Figure 106, or the first page of a report might have no header or footer, while
the other pages do.

: - D LibreOffice
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Figure 106: Letterhead with different headers for first and following pages
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You can do this in several ways:

» Use the Default (or any other) page style for your document. Deselect the Same content
on first page option on the header/footer tabs in the Page Style dialog, and then add
different headers/footers to the first page and to the other pages of the document. See
“Using one page style” on page 114.

* Use different page styles for the first page and for the following pages. Set the Next Page
attribute for the first page so the next page automatically becomes the style for following
pages. See “Using different page styles” on page 114.

* Add a title page at the beginning of the document. See “Adding title pages” on page 115.

Using one page style
This example uses the Default page style.

1) Right-click anywhere on the page and choose Page Style in the context menu. On the
relevant tab (Header or Footer) of the Page Style dialog, select Header/Footer on and
deselect Same content on first page (Figure 107). Optionally select Same content on
left and right pages.

e Page Style: Default Style
Organizer Page Area  Transparency Header ﬁ Borders  Columns  Footnote

Footer

Footer on
Same content on left and right pages

| Same content on first page

Figure 107: Setting up footers to have different content on different pages

2) Insert a header or footer on any page using the Default page style. See “Creating
headers and footers” on page 103.

3) Add different header and footer content to the first page and to the other pages of the
document. For example, leave the header/footer blank on the first page.

Using different page styles

As an example, we can use the First Page and Default Style page styles that come with
LibreOffice. Figure 108 shows what we want to happen: the first page is to be followed by the
default page, and all the following pages are to be in the default page style.

To do this, open the Page Style dialog for the First Page style, go to the Organizer tab, and
choose Default Style in the Next Style list (Figure 109).

First Default
Page

Figure 108: Flow of page styles
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® @ Page Style: First Page

_ Page Area Transparency Header Footer Borders Columns  Footnote
Style

Mame: |First Page

Next style: |Default Style Edit Style
Inherit from: v Edit Style
Category: Custom Styles >

Figure 109: Setting the next style for a page style

Adding title pages

Writer provides a fast and convenient way to add one or more title pages to a document and
optionally to restart the page number at 1 for the body of the document.

To begin, choose Format > Title Page on the Menu bar to display the Title Page dialog (Figure
110).

] Title Page
Make Title Pages
() Converting existing pages to title pages
Insert new title pages
MNumber of title pages: |1 Iél
Place title pages at: () Document start
Page 14 Ié,l
Page Numbering
[ Reset page numbering after title pages
Page number: 1 Iil
Set page number for first title page
Page number: 1 Iél
Edit Page Properties
Style:  First Page < | Edit...

Help L.OK | Cancel

Figure 110: Adding title pages to a document
On the Title Page dialog, you can make the following choices:

» Convert existing pages to title pages, or insert new title pages.

* How many pages to convert or insert.

* Where those pages are located.

» If and where to restart page numbering, and what humber to start with.
* What page style to use for the title page.
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Using this technique, you can insert several “title pages” at different points in your document, for
example to add decorative pages between chapters as well as title, copyright, and other pages at
the beginning of a book.

Formatting footnotes and endnotes

Footnotes appear at the bottom of the page on which they are referenced. Endnotes are
collected at the end of a document.

To work effectively with footnotes and endnotes, you need to:

* Insert footnotes and define their format, if the default does not meet your needs (see
Chapter 3, Working with Text: Advanced).

» Define the location of footnotes on the page, and the color and line styles for separator
lines, if the defaults do not meet your needs.

Defining footnote location and separator line

The location of footnotes on the page, and the color and style of the line that separates the
footnotes from the text, are defined in the page style. If you are using several page styles, and
may have footnotes on any of them, you need to define the footnote location and separator line
on each of the page styles.

Choose Format > Page on the Menu bar or right-click a page and choose Page in the context
menu, to display the Page Style dialog. Go to the Footnote tab (Figure 111) and make your
selections, then click OK to save the changes.

@ Page Style: Default Style
Organizer | Page | Area | Transparency |
Header | Footer | Borders | Columns . Footnote |
Footnote Area |

{20 Not larger than page area |
Maximum footote height I Ié_l
Space to text 0.10 cm (o

Separator Line

Position Left &
Style — |~
Thickness 0.50 pt 8
Color I Biack ||
Length 250% ]
Spacing to footnote contents 0.10 cm 1<)

Figure 111: Defining footnote location and separator line

Keeping the default setting Not larger than page area, the footnotes area is calculated
automatically on the basis of the number of footnotes. If you prefer to control manually the
maximum space that footnotes can take, select the Maximum footnote height option and enter
the value in the preferred unit of measurement. A footnote higher than the maximum height will
spill over on to the next page. Use the second section of the page to customize the separator
between the footnotes and the main text area.
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Introduction

Writer provides several ways to control page layouts. Chapter 5, Formatting Pages: Basics,
described the use of page styles and some associated functions. This chapter covers the use of:

Columns

Frames

Tables

Sections

Changing page orientation within a document
Borders and backgrounds

Note

All pages in a Writer document are based on page styles. The other layout
methods described in this chapter build upon the underlying page style.

OTip

Page layout is usually easier if you select the options to show text, object, table, and
section boundaries in Tools > Options > LibreOffice > Application Colors and the
options for paragraph ends, tabs, breaks, and other items in Tools > Options >
LibreOffice Writer > Formatting Aids.

Choosing a layout method

The best layout method depends on what the final document should look like, what sort of
information will be in the document, and whether the document will be published in a fixed format
(print, PDF) or a variable format (HTML, ePub) or more than one format. Here are some
examples. The techniques mentioned are all described in this chapter.

For a book similar to this user guide with one column of text, some figures without text
beside them, and some other figures with descriptive text, use page styles for basic
layout, and use tables to place figures beside descriptive text, where necessary.

Use sections (with two or more columns) for an index or other document with two
columns of text where the text continues from the left-hand column to the right-hand
column and then to the next page, all in sequence. If the title of the document (on the first
page) is full-page width, put it in a single-column section.

For a newsletter with a complex layout, two or three columns on the page, and some
articles that continue from one page to some place several pages later, use page styles
for basic layout, then place articles in linked frames. If necessary, anchor graphics to
fixed positions on the page.

eTip

For a document to be published in HTML, EPUB, or another format that is not fixed,
use minimal layout techniques. Some methods (columns, frames, wide tables) often
do not export well to those formats.
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Using columns to define the page layout

It is a good idea to define your basic page style (such as Default Page Style) with the most
common layout to be used in your document, either single-column or multiple-column. You can
then define extra page styles for pages with different numbers of columns.

Note

If you wish to combine different numbers of columns on a single page, you must use
sections, as described in “Using sections for page layout” starting on page 127.

To define the number of columns for a page style:

1) Choose Format > Page Style on the Menu bar, or right-click on the page and choose
Page Style in the context menu, or click the More Options button in the Format section
of the Page deck on the Sidebar, to open the Page Style dialog. Go to the Columns tab
(see Figure 112).

2) Inthe Settings section, choose the number of columns and specify any spacing between
them and whether you want a vertical separator line to appear between the columns. You
can use one of Writer’s predefined column layouts, or you can create a customized
column layout. The preview on the right shows how the column layout will look.

3) Click OK to save the changes.
® . ® Page Style: Default Style .

| Organizer Page Area  Transparency Header Footer  Borders ﬁ Footnote
| Settings

Columns: |2 @ ’%%

Width and Spacing

|| AutoWidth
i Column: 1 2 3
Width: 825cm  |[3| 825em | [Z] (2]
| = B
Spacing: 0.50 cm 12] |2

Separator Line

Style: — v
Width:  0.25pt (]
Color: I Elack -
Height: 100% [c] Position: Top z

Figure 112: Defining the number of columns on a page

Formatting column width and spacing

Select AutoWidth in the Width and Spacing section to create columns of equal or preset width.
To customize the width and spacing of the columns:

1) Inthe Width and Spacing section, deselect the AutoWidth option.
2) Inthe Width selection boxes, enter a width for each column.
3) On the Spacing line, enter the amount of space between each pair of columns.

If you specify more than three columns, use the arrow buttons on the Column line to scroll among
the columns.
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Formatting separator lines
Usually white space is all that is needed between columns, but if you prefer separator lines:

1) Using the Style drop-down list, select the line style from the three styles available.

2) Using the Width control, select the width of line to use, settable from 0.25pt to 9.0pt.
(1 point = 1/12 pica = 1/72 inch = 127/360 mm = 0.3527 mm.)

3) Using the Height control, select the height of line required, as a percentage of the column
height. You can choose from the supplied values or type in measurements.

4) If you entered a height of less than 100%, use the Position drop-down list to select a
vertical alignment for the separator lines. The vertical-positioning options are Top,
Centered, or Bottom.

5) Select the line color from the Color drop-down list.

Distributing text across columns

As you add text to a column, the text flows from one column to the next. The last column may be
shorter than the others.

To distribute text evenly, so that all the columns are approximately the same height, use a multi-
column section instead; see “Formatting a section into columns” on page 130.

eTip

Choose View > Formatting Marks (or press Ctrl+F10) to display end of paragraph
markers (7). Often, unexpected behavior of columns is due to extra paragraphs that
are normally invisible but are taking up space.

Using frames for page layout

Frames can be very useful when producing newsletters or other layout-intensive documents.
Frames can contain text, tables, multiple columns, pictures, and other objects. Use frames to:

* Position something in a particular place on a page, for example, a logo or a “stop press”
news box in one corner of a page.

* Allow text on one page to continue on another page, somewhere more distant than the
next one, by linking the content of one frame to another so the contents flow between
them as you edit the text.

* Wrap text around an object, such as a photograph.

Because LibreOffice does not allow you to define page styles with recurring frames (unless
anchored in a header or footer), consider doing some quick sketches of the basic page layouts
you need, indicating the approximate positions of different frames and their purposes. Keep the
number of different page layouts as low as possible to avoid chaos in your design.

Pay special attention to the positioning of frames. A visually effective way to position a frame is to
align its left margin with that of the paragraph above it. To do this, insert the frame in a blank
paragraph of the same style as the paragraph above. Select Insert > Frame > Frame; in the
Position section of the Type page of the Frame dialog (Figure 113 on page 121), select From
Left in the Horizontal selection box to position the frame exactly where you want it.

Also, think about the type of wrap and the spacing between the frame and text. Instead of placing
a frame close to the text, use the Wrap page to place some white space between them.

You can format frames individually or define and apply frame styles; see Chapter 9, Working with
Styles.
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Creating a frame

You can create a frame in several ways:

* Choose Insert > Frame > Frame to create an empty frame. The Frame dialog (Figure
113) opens. You can set the frame’s characteristics at this stage or click OK and come
back to customize it later.

» Select text and choose Insert > Frame > Frame to open the Frame dialog. Customize
the frame (for example, to add space between the frame and the text) and click OK. The
selected text is removed from the normal text flow and inserted into the frame.

» Choose Insert > Frame > Frame Interactively to quickly draw an empty frame. The
mouse cursor changes shape. Click and drag the mouse to draw an empty frame. To
customize the frame, right-click it and choose Properties in the context menu.

* Insert a formula or OLE object by selecting Insert > Object > [type of object]. The item
is inserted and appears in a frame. To customize the frame, right-click it and choose
Properties in the context menu.

To add content to a frame, first deselect the frame by clicking in an empty space somewhere else
on the page. Then, click inside the frame to place the text cursor there. Now add content as you
would on the main page. When you are done, deselect the frame.

Note

The menu item Insert > Frame > Floating Frame is for use with HTML documents.

o0 ® Frame
- Options  Wrap  Hyperlink  Borders  Area  Transparency Columns  Macro
Size Anchor
Width 2.00 cm (2] ) To page
. To paragraph
Relative to Paragraph area 2 O Toparagmp
. | To character
AutoSize )
As character
Height (at least) 0.50 cm |2
Relative to  Paragraph area =
AutoSize
| Keep ratio
Position
Horizontal  Center B by |0.00cm |f| to |Paragraph area B

Mirror on even pages

Vertical Top B by |0.00cm |5| to |Paragraph text area B

Keep inside text boundaries

Help Reset Cancel -

Figure 113: Frame dialog

Frame toolbar

When you create or select a frame, the Frame toolbar (Figure 114) is displayed. By default, it
replaces the Formatting toolbar. You can also display it by using View > Toolbars > Frame.
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1 Anchor 6 Wrap Right 11 Back One 16 Border Style

2 Wrap Off 7 Wrap Through 12 Send to Back 17 Border Color

3 Page Wrap 8 Align 13 To Foreground 18 Background Color
4 Optimal Page Wrap 9 Bring to Front 14 To Background 19 Link Frames

5 Wrap Left 10 Forward One 15 Borders 20 Unlink Frames

Figure 114: Buttons on the Frame toolbar

Moving, resizing, and changing frame attributes

When an object is added to Writer, it is automatically enclosed in a frame of a predetermined
type. The frame sets how the object is placed on the page, as well as how it interacts with other
elements in the document. You can edit the frame by modifying the frame style it uses or by
manually formatting it when you add it to the document. Frame styles are discussed in Chapter 9,
Working with Styles.

To change the size or location of a frame, first select the frame, then use either the mouse or the
Frame dialog (Figure 113). Using the mouse is faster but less accurate.

ﬂTip

You might want to use the mouse for gross layout and the dialog for fine-tuning.

You can re-size the frame manually in these ways:

» Click on the green squares (sizing handles) and drag to the appropriate size.

* Add content to it (the frame will re-size automatically if, for example, you add a large
picture to it).

* Go back to the Frame dialog and set the size and other characteristics.

To change the location of the frame using the mouse, drag and drop one of the edges or put the
cursor anywhere within the frame. The cursor changes to a four-headed arrow when properly
positioned for a drag-and-drop move.

To change the size of the frame, drag one of the sizing handles. Drag a handle on one of the
sides to enlarge or reduce the text frame in one dimension only; drag a corner handle to enlarge
or reduce it in both dimensions.

These resizing actions distort the proportions of the frame. Holding down the Shift key while
dragging one of the handles makes the frame keep the same proportions.

To open the Frame dialog, select the frame, right-click, and choose Properties in the context
menu.

To add or remove a frame’s border, click the relevant button on the Frame toolbar (Figure 114) to
display some choices; or open the Frame dialog, go to the Borders page (Figure 115), and in the
Line Arrangement section, select the first Preset (Set No Borders); or assign a borderless style
to the frame; see Chapter 9, Working with Styles, for information on frame styles.

Note

Do not confuse a frame’s border with the text boundaries that are made visible using
the View menu (by selecting View > Text Boundaries).
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Type Options  Wrap  Hyperlink |JBOIdEESS| Area  Transparency  Columns  Macro

Line Arrangement Padding
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User-defined: Right: 0.05cm |[7]
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Line Shadow Style
Style: A Position: ’F IF ’F ’F
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Figure 115: Removing the border from a frame

Anchoring frames

To anchor a frame, click on it, then right-click and point to Anchor, or click the Anchor button on
the Frame toolbar and select the type of anchor, or open the Frame dialog to the Type tab.

To Page (available only on Frame dialog, not the toolbar or context menu)
The frame keeps the same position in relation to the page margins. It does not move as
you add or delete text. This method is useful when the frame does not need to be visually
associated with a particular piece of text. It is often used when producing newsletters or
other documents that are very layout-intensive, or to center text vertically on a page.

To Paragraph
The frame is associated with a paragraph and moves with the paragraph. It may be placed
in the margin or another location. It is also used to center text on a page in documents
which will be used in a master document (frames anchored to pages will disappear from
the master document).

To Character
The frame is associated with a character but is not in the text sequence. It moves with the
paragraph but may be placed in the margin or another location. This method is similar to
anchoring to a paragraph.

As Character
The frame is placed in the document like any other character and, therefore, affects the
height of the text line and the line break. The frame moves with the text as you add or
delete text. This method is useful for adding a small icon in sequence in a sentence. It is
also the best method for anchoring an image to an empty paragraph so it does not move
around the page in unexpected ways.

Linking frames

You can link frames to each other even when they are on different pages of a document. The
contents will automatically flow from one to the next. This technique is very useful when
designing newsletters, where articles may need to be continued on a different page.

Note

Text can only flow into a frame from one other frame, and flow on to one other frame.
You can not link from a frame directly to more than one other frame.
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To link one frame to another:

1) Select the frame to be linked from.
2) Click the Link Frames icon on the Frames toolbar.
3) Click the next frame in the series (which must be empty).

When a linked frame is selected, any existing links are indicated by a faint connecting line, as
shown in Figure 116. Frames can be unlinked by selecting the Unlink Frames icon on the
Frames toolbar.

=

]

Figure 116: Linked frames

The height of a frame that is being linked from is fixed; you can change this height manually or by
using the Frame dialog, but it does not automatically adjust to the size of the contents (that is, the
AutoHeight attribute is disabled). Only the last frame of a chain can adapt its height to the
content.

The Options page of the Frame dialog (Figure 117) shows the names of the selected frame and
any frames it is linked to or from. You can change this information here. On this page, you can
also select options to protect the contents, position, and size of the frame.

[ NN ] Frame
Type ﬁ Wrap  Hyperlink  Borders Area  Transparency Columns = Macro
Names
Name: ;Frameiil
Description:
Previous link: | <None> i
Next link: <None> il
| Protect Content Alignment
Contents Vertical alignment | Top ﬁ
Paosition
Size
. Properties

Editable in read-only document
Print

Text direction: | Use superordinate object settings ﬁ

Figure 117: Options page of the Frame dialog

The Wrap, Borders, Area, Columns, Transparency, and Macro pages of the Frame dialog are the
same as those for frame styles. Refer to Chapter 9, Working with Styles, for details.
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Using tables for page layout

Writer’s tables can serve several purposes, such as holding data as you might see it in a
spreadsheet, lining up material, and creating more complex page layouts. For information about
using tables of data, see Chapter 13, Tables of Data.

This topic describes how to achieve some common layouts by using tables.

Positioning information in headers or footers

Instead of using tabs or frames, you can use a table in a header or footer to position different
elements such as page number, document title, author, and so on. These elements are often
inserted using fields, as described in Chapter 17, Fields.

Creating sideheads using tables

Sideheads and marginal notes are commonly used in documents such as resumes and computer
user guides. The main body of the text is offset to leave white space (usually on the left-hand
side) in which the sideheads or notes are placed. The first paragraph is aligned beside the
sidehead, as in Figure 118.

Example of a In some cases you may want to put only one or two paragraphs in the table
sidehead itself and the rest of the text and graphics in ordinary paragraphs (formatted to
line up with the paragraphs in the table) so that text and graphics will flow
more easily from one page to another when you add or delete material.

In other cases, you might put each paragraph in a separate row of the table
and allow the table to break between pages.

Figure 118: Example of a sidehead

Note

Sideheads can also be created by placing text in a frame using the Marginalia frame
style, as described in Chapter 9, Working with Styles.

Example
To create a table for use with a sidehead:

1) Place the cursor where you want the table to appear and choose Table > Insert Table
(CtrI+F12).

2) Inthe Insert Table dialog (Figure 119), define a two-column, one-row table with no
heading. Choose None under Styles so the table will have no border. Click Insert.

3) Right-click the table and choose Table Properties in the context menu. On the Columns
tab of the Table Properties dialog (Figure 120), set the column widths.

4) On the Table tab of the Table Properties dialog (Figure 121), in the Spacing section, make
the Above and Below values the same as the Top and Bottom spacing you have defined
for ordinary paragraphs of text. In the Properties section, optionally give this table a
name. Click OK to save your settings.

ﬂTip

To check the top and bottom spacing for a paragraph: position the cursor in the
paragraph and open the Properties deck in the Sidebar. In the Paragraph section,
look under Spacing for the values.
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| NN ] Insert Table

General
Name: Tablel
Columns: |2 |§| Rows: |1 ,@
Options
| Heading

7| Repeat heading rows on new pages
Heading rows: 1 (2]

| Don't split table over pages

Styles
None
Default Style Jan Feb  Mar Sum
Academic North 6 T 8 21
Box L!st Blue Mid 11 12 13 36
Box List Green — 16 17 18 51
Box List Red ut
Box List Yellow Sum 33 36 39 108
Eleaant

Help Cance! (NS

Figure 119: Defining a two-column borderless table with no heading

) Table Properties
Table Text Flow m Borders  Background
Adapt table width
Adjust columns proportionally
Remaining space: |0.00 cm

Column Width
ab 2 3 4 5 6

330cm |[2] [18.70cm|[2] ] ¢] £ B
Figure 120: Defining a two-column table to line up with text offset at 3.3cm

® Table Properties

“ TextFlow  Columns  Borders  Background

Properties Alignment
Name |Sideheadl (© Automatic
- Left
Width 17.00 cm |2] Relative
i From left
Spacing Right
- N A |£,| Center
Right 0.00 cm |5| Manual
Above 0.30 cm 2]

Below 0.30cm [

Figure 121: Defining the space above and below a table
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You may also want to turn off number recognition so that Writer will not try to format numbers if
you want them to be plain text. To turn number recognition off:

1) Place the cursor in a table, and then select Table > Number Format on the Menu bar.
2) On the Format Number dialog (Figure 122), make sure the Category is set to Text.
3) Click OK.

[ ] Format Number

Category Format Language

Percent @
Currency

Date

Time

Scientific

Fraction

Boolean Value

Default - English (USA) | <]

Figure 122: Setting number format to Text

Oip
If you use this table format often, you may want to save it as a table style, using

Table > AutoFormat Styles. See “Creating table styles” in Chapter 13, Tables of
Data.

Using sections for page layout

A section is a block of text that has special attributes and formatting. You can use sections to:
*  Write-protect text.
* Hide text.
* Dynamically insert the contents of another document.

* Add columns, margin indents, a background color, or a background graphic to a portion
of your document.

* Customize the footnotes and endnotes for a portion of your document.

Creating sections
To create a section:

1) Place the cursor at the point in your document where you want to insert the new section.
Or, select the text that you want to place in the new section.

2) On the Menu bar, choose Insert > Section. The Insert Section dialog (Figure 123) opens.
3) Choose settings for each page of the dialog as described below. Click Insert.
The Insert Section dialog has five tabs:

* Use the Section tab to set the section’s attributes.

* Use the Columns tab to format the section into columns.

* Use the Indents tab to set indents from the right and left margins of the section.

* Use the Area tab to add color or a graphic to the section’s background.

* Use the Footnotes/Endnotes tab to customize the section’s footnotes and endnotes.
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Insert Section e

Section Columns Indents Area Footnotes/Endnotes

Mew Section Link
tSectiom | Link

|
[a]
1]

Write Protection
| Protect

E
[#
=]
[[=1]
5l
i)

Properties
[ editable in read-only document

Figure 123: Inserting a section using the Insert Section dialog

At any time before closing the dialog, you can reset a tabbed page other than the Section page to
its default settings by clicking the Reset button. If you wish to undo changes to the Section page,
you must do so manually.

Naming sections

Writer automatically enters a name for the section in the name box of the New Section list. To
change the name, select it and type over it. The name is displayed in the Sections category of
the Navigator window. Navigation is easier if you give your sections meaningful names.

Linking sections
You can insert the contents of another document into the section and then have Writer update it
whenever the other document is updated.

Note

If you want to insert only a part of the other document, be sure that part exists as a
section in the document.

To link the section to another document, follow these steps:
1) Inthe Link section of the dialog (Figure 124), select the Link option.
2) Click the Browse button to the right of the File name field. The Insert dialog opens.

3) Find and select the required document and click the Insert button. The name of the
selected document appears in the File name field.

4) If you want to insert only a section of the selected document, select the desired section
from the Section drop-down list.
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Link
Link
DDE

File name Browse...

Section
Figure 124: Linking sections
You can update links automatically or manually. See “Updating links” on page 133.

Write-protecting sections

To write-protect the section so that its contents cannot be edited, select Protect in the Write
protection area (Figure 125).

Note

Write-protection protects only the section’s contents, not its attributes or format.

Write Protection

Protect

With password Password...
Figure 125: Write-protecting sections
Password-protecting sections

Caution

Be very careful to remember or safely store the password, because it cannot be
retrieved without advanced tools.

To prevent others from editing the section’s attributes or format, you can additionally protect the
section with a password, as follows:
1) Select Protect and With password.
2) On the Enter Password dialog, type a password in the Password field and again in the
Confirm field.
3) Click OK.

Anyone who tries to edit the section’s attributes or format will be prompted to enter the password.

Hiding sections

You can hide the section so that it will not be displayed on the screen or printed. You can also
specify conditions for hiding the section. For example, you can hide the section only from certain
users. Hiding is very useful for creating a single source document containing students’ and
teachers’ copies of a document such as a test.

Note

You cannot hide a section if it is the only content on the page or if the section is in a
header, footer, footnote, endnote, frame, or table cell.
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To hide a section, select the Hide option in the Hide section of the dialog.

Hide

With Condition

Figure 126: Hiding sections

To hide the section only under certain conditions, enter the desired conditions in the With
Condition field. The syntax and operators that you use to enter conditions are the same ones that
you use to enter formulas. For syntax and a list of operators, see the Help under Conditions. See
also Chapter 17, Fields.

If the section is write-protected with a password, the password must be entered to hide or reveal
the text.

Formatting a section into columns

You can give some parts of a page one column and other parts of the page two or more columns.
For example, you might have a page-width headline over a three-column news story.

ﬂTip

You cannot select text on a multi-column formatted page and change it to a single
column using this method. Instead, you need to define a single-column page style
and then select the text you want to be in a two-column section on that page.

Use the Columns tab of the Insert Section dialog (Figure 127) to format the section into columns.

[ ] Insert Section

Section Columns Indents Area Footnotes/Endnotes

| Settings

<

Columns: 2|

Evenly distribute contents to all columns

Figure 127: Choosing evenly distributed columns

As you add text to the section, the text flows from one column to the next. You can distribute text
across the columns in one of two ways, as shown in Figure 128.

Evenly distribute contents to all columns
When this option is selected, Writer adjusts the length of the columns to the amount of text,
so that all the columns are approximately the same length. As you add or delete text, the
columns readjust.

When this option is not selected, Writer fills the columns newspaper-style: one column at a
time, beginning with the first column. The last column may be shorter than the others.
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Example of evenly distributed columns Example of “snaking” or “newspaper” columns

Lorem ipsum dolor sit amet, clit Donec fermentum lacinia quam, ac Lorem ipsum dolor sit amet, Vivamus pretium dui in arcu porttitor
consectetur adipiscing elit. Proin vitae egestas erat accumsan et consectetur adipiscing elit. Proin vitae sagittis. Vestibulum non magna elit.
odio quis orci placerat faucibus. Cras luctus laoreet turpis, sit amet odio quis orei placerat faucibus. Cras hendrerit nisi a arcu pharetra
Aencan in urna massa. Nam feugiat posucre leo cursus ac. Phasellus ultrices Aenean in urna massa. Nam feugiat accumsan. Proin euismod iaculis sem id
tincidunt massa nec mollis. Morbi non | ¢ommodo quam auetor dictum. Cras tincidunt massa nec mollis. Morbi non | fringilla. Maccenas vitae ligula et nulla
diam id lorem posucre placerat. urna ligula, fringilla id ultricics diam id lorem posuere placerat. scelerisque cuismod. Etiam mattis
Suspendisse potenti. In consectetur rhoncus, venenatis consectetur quam. Suspendisse potenti. In consectetur fringilla pharetra. Aliquam purus nulla,
aliquam libero at laoreet. Pellentesque | Aliquam diam nisi, aliquam sed iaculis aliquam libero at lnoreet. Pellentesque | malesuada quis tincidunt id, scelerisque
‘mattis lobortis consequat. Ut tincidunt iin, tempus eu tortor. Donec eleifend ‘mattis lobortis consequat. Ut tincidunt atipsum. Maecenas urna odio, cursus
nunc leo, at tincidunt quam. Donce phacerat ipsum in suscipit, Etiam at nunc leo. at tincidunt quam. Donec cu faucibus vehicula, fringilla id metus ]
augue massa, vehicula et elementum a, nulla mi, at tincidunt sem. Acnean mi augue massa, vehicula et elementum a, q
facilisis vel odio. Pellentesque habitant| e, adipiscing ac vestibulum id, facilisis vel odio. Pellentesque habitant
‘morbi tristique senectus et netus et porttitor ac ante. morbi tristique senectus et netus et

malesuada fames ac furpis egestas § malesuada fimes ac tumis egestas §

N Vivamus pretium dui in arcu porttitor

Pracsent eu turpis et nunc seelerisque.  sagiris. Vestibulum non magna elit. PrISSENL e MIPIS et nunc soclerisque
fringilla id sit amet arcu. Nunc omare Cras hendrerit nisi a arcu pharetra ?mg;’”ﬂ id sit ﬂmell arcu. Nunc omare
faucibus risus, eget congue ipsum accumsan. Proin cuismod iaculis sem id it e sk v
sollicitudin ac. Curabitur mauris trtor, | fringilla. Maecenas vitae ligula et nulla B ékmennnm s o 3
Fcnselg!m]e" =kmEnNm nfg]n Zeugm scelerisque euismod. Etiam mattis ’mpmm ot Alquam &l i nfn
impendiet lacus. Aliquam felis diam, A g
ph‘;elal alaoreet inf‘mlpllme vitae placerata laoreet in, vulputate vile
wvelit. Morbi rhoncus aliquet nisl, eget wvelit. Morbi rhoncus aliquet nisl, eget
sagittis dolor tristique at. Lorem ipsum Zﬂj::lss:::zIl';s.;:‘qs-;[:;}c];::sﬁzm
dolor sitamet, consectetur adipiscing q Llit. Donee fe;'“enmm Jocinia quam. ac
egestas erat accumsan et.

fringilla pharcira. Aliquam purus nulla,
malesuada quis tincidunt id, scelerisque
at ipsum. Maccenas urna odio, cursus

eu faucibus vehicula, fringilla id metus.§

Cras luctus laoreet mrpis, sit amet
posuere leo cursus ac. Phascllus ultrices
commodo quam auctor dictum. Cras
uma ligula, fringilla id ultricies
rhoncus, venenatis consectetur quam.
Aliquam diam nisi, aliquam sed iaculis
in, tempus eu tortor. Donec eleifend
placerat ipsum in suscipit. Etiam at
nulla mi, at tincidunt sem. Aenean mi
erat, adipiscing ac vestibulum id,
porttitor ac ante.

Figure 128: (Left) Evenly distributed columns; (Right) Newspaper-style columns

Indenting the section from margins
Use the Indents tab (Figure 129), to set indents from the right and left margins of the section.
Enter the desired left-margin indent in the Before section box. Enter the desired right-margin

indent in the After section box. The preview box on the right-hand side of the tab shows you
how the section will look with the indents applied.

Insert Section K

Section Columns Indents Area Footnotes/Endnotes
Indent
Before section |1.00cm =

After section 2,00 cm =

Figure 129: Indenting sections

Changing the background of the section

Use the Area tab to add color or an image to the background of the current section. This page is
similar to the Area tabs for paragraphs, frames, tables, and other objects. For more information,
refer to “Defining borders and backgrounds” on page 139 and the Draw Guide.

Customizing footnotes and endnotes in a section

Use the Footnotes/Endnotes page of the Insert Section dialog (Figure 130) to customize the
current section’s footnotes and endnotes.
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[ ] Insert Section

Section Columns Indents Area Footnotes/Endnotes
Footnotes
Collect at end of text
Restart numbering
Startat: 1 -
Custom format
Before: 1,23,.. B after:
Endnotes
Collect at end of section

Restart numbering
~
1 &

Custom format

Before i, i i After

Figure 130: Setting footnotes and endnotes for sections

Customizing footnotes
To number the section’s footnotes separately from the other footnotes in the document, and
format the numbering, follow these steps:
1) Inthe Footnotes section of the page, make sure that Collect at end of text is selected.
2) Select Restart numbering.

3) To start the section’s footnotes at a number other than 1, enter the desired starting
number in the Start at box.

4) Select the Custom format option. In the drop-down list, select a numbering format for the
footnotes.

To add text to the selected numbering format, use the Before and After boxes. For example, if
you want the footnote numbers to be preceded by the word Note and followed by a colon, fill the
Before and After boxes as shown in Figure 130.

Customizing endnotes
If you want the section’s endnotes to appear at the end of the section rather than at the end of
the document, select the Collect at end of section option in the Endnotes area.

To number the current section’s endnotes separately from the other endnotes in the document,
and format the numbering, apply the procedures described above to the Endnotes settings.

Editing and deleting sections

To edit a section, choose Format > Sections on the Menu bar. In the Edit Sections dialog
(Figure 131), select the section you want to edit by clicking its name in the Section list.

Editing section attributes
To rename the selected section, type over its name in the Section name box.
On the Edit Sections dialog, you can also edit the selected section’s link, write-protect, and hide

attributes. To learn how to edit these attributes, see “Linking sections” on page 128, “Write-
protecting sections” on page 129, and “Hiding sections” on page 129.
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@ @ Edit Sections
Section Link
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Write Protection
Protected

Hide
Hide

Properties

Editable in read-only document

Figure 131: Edit Sections dialog

Editing the format of a section
To edit the format of the selected section, click the Options button.

The Options dialog has four tabs: Columns, Indents, Background, and Footnotes/Endnotes.
These tabs are the same as those in the Insert Section dialog described earlier; the Background
tab on the Options dialog corresponds to the Area tab in the Insert Section dialog.

To reset a tab to the conditions in place when the dialog opened, click the Reset button. To save
the Options settings, click OK. You are returned to the Edit Sections dialog.

Removing sections

To remove the selected section, click the Remove button. This does not delete the contents of
the section; the contents become part of the main document. If the contents were linked, they are
now embedded.

Updating links

You can set Writer to update linked sections automatically, and you can also update links
manually.

Updating links automatically

To set Writer to update links without prompting you, or to turn off automatic updating, follow these
steps:

1) Choose Tools > Options > LibreOffice Writer > General. The dialog displays general
text document settings.

2) In the Update links when loading section of the dialog, select one of the options:

— Always if you want Writer to update links automatically, without prompting you,
whenever you open a document that contains links.

— On request if you want Writer to prompt you before updating links.
— Never if you do not want Writer to update links.
3) Click OK to save your settings.
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Updating links manually
A protected section must first be unprotected before it can be updated.

To update a link manually:

1) Open the document that contains the link.

2) Choose Edit > Links to External Files.

3) The list in the Edit Links dialog (Figure 132) displays the names of all the files that are
linked to the current document. Select the file that corresponds to the link that you want to
update.

4) Click the Update button. The most recently saved contents of the linked file appear in the
current document. To close the Edit Links dialog, click Close.

L JeN | Edit Links
'Source file [Element Type Status
file:/iiUser...ffontwork-toolbar.png~ <Allimages> " lmage  "Manual

Source file file:///Users/jean/Dropbox/LO Writer Guide 7.1/Screenshots/fontwork-toolbar.png
Element:  <All images>

Type: Image
Update: Automatic (=) Manual

Help Modify... Break Link Update [ Close |

Figure 132: Edit Links dialog

Removing links

To remove a link to a file and embed its contents, go to the Edit Links dialog, select the file that
corresponds to the link you want to remove, and click the Break Link button. This action does
not delete the text in the Section; it just breaks the link. If desired, the text must be removed
manually.

Changing page orientation within a document

A document can contain pages in more than one orientation. A common scenario is to have a
landscape page in the middle or end of a document, where the other pages are in portrait
orientation. Here are the steps to achieve it.

Setting up a landscape page style

1)

2)

If you wish to keep the margins the same as on other pages, then note the margin
settings of the current page style. (You can find the margin settings on the Page tab of the
Page Style dialog.)

On the Styles deck of the Sidebar, right-click Landscape in the list of page styles and
choose Modify.

134 | Chapter 6 Formatting Pages: Advanced



3) On the Organizer tab of the Page Style dialog (Figure 133), make sure Next Style is set
to Landscape (to allow for having more than one sequential landscape page).

@] Page Style: Landscape
| Organizer | Page Area  Transparency Header Footer Borders Columns  Footnote

Style
Name: Landscape

Next style: | Landscape )

Edit Style

Custom Styles

Figure 133: Set the next page style to Landscape

4) On the Page tab of the Page Style dialog (Figure 134), make sure Orientation is set to
Landscape. Change the margins so that they correspond with the margins of the portrait
page. That is, the portrait top margin becomes the landscape left margin, and so on.

5) Click OK to save the changes.

Q Page Style: Landscape
Organizer | Page | Area  Transparency Header Footer Borders Columns  Footnote

Paper Format

Format: Ad <

Width: 29.70em | [

Height: 21.00cm | [2]

Crientation: Portrait

" Landscape Paper tray: [From printer settings] [ <]

Margins Layout Settings

Left: 200cm | |7 Page layout: Right and left | ]

Right: 2.00 cm |_§_| Page numbers: 1,23, .. [ <]

Top: 2.00cm | [ Regisier-true

Bottom: 2.00em | |I|

Figure 134: Set orientation and margins for a landscape page

Inserting a landscape page into a portrait document
Now that you have defined the Landscape page style, here is how to apply it:

1) Position the cursor in the paragraph or table at the start of the page that is to be set to
landscape. Right-click and choose Paragraph > Paragraph or Table Properties,
respectively, in the context menu.

2) On the Text Flow page of the Paragraph dialog (Figure 135) or the Table Properties
dialog (Figure 136), select Insert (or Break for a table) and With Page Style. Set the
Page Style property to Landscape. Click OK to apply the new page style.

3) Position the cursor in the paragraph or table where the page is to return to portrait
orientation and change the paragraph properties or table properties so that With Page
Style is the portrait page style that was used before the Landscape page style. Click OK
to return to the portrait page style.

Changing page orientation within a document | 135



[ NON ) Paragraph

Tabs Drop Caps Borders Area Transparency
Indents & Spacing Alignment Text Flow Outline & List
Hyphenation Breaks
[ Automatically Insert
Don't hyphenate words in CAPS Type: Page @
2| Characters at line end Position: Before B
2 =| Characters at line begin With page style: |Landscape
Page number: 1 ]

N ~ Maswimum nomk \ s
0 ~ VIEXIMUMm numoer of consecutive |]y'[J|]f_'Hb

Figure 135: Specifying a page break before a paragraph

[ ] Table Properties
Table Columns  Borders  Background
Text Flow
Break © Page 1 Column
. O Before | After
With Page Style | Landscape ﬁ Page number 1 |é|

Figure 136: Specifying a page break before a table

Portrait headers on landscape pages

When you define a header and footer on a landscape page, they will be aligned with the long
side of the page. If your landscape pages are inserted between portrait pages, you might want
the headers and footers to be on the short sides of the landscape pages, so the final printed
product looks like the contents of the landscape pages have been rotated 90 degrees on portrait
pages.

You can set up portrait headers and footers on landscape pages by using a trick involving
frames. These are a bit tedious to set up, but once you have done so, you can copy and paste
them to other landscape pages. This cannot be made part of the landscape page style. In the
following example we want to insert a landscape page into our printed document, to have the
same header and footer, and margins, as our portrait pages. We will use an A4 page size.

To set up portrait headers and footers on landscape pages:

1) Note the margin settings for the portrait page which is the same as the landscape page
will be, that is to say, for a right landscape page, the settings from a right portrait page
(see the table).

We now need to make the landscape left and right margins 1 cm larger than the portrait
top and bottom margins, respectively. This difference allows for the extra space used by
the portrait header and footer (0.5 cm for the height of the header or footer and a 0.5 cm
gap between the header or footer and the main text).

Portrait page (right page) Landscape page (right page)

Top margin 1.5cm Right margin 2.5cm
Bottom margin 1.5cm Left margin 2.5cm
Left (inner) margin 2.8cm Top margin 2.8cm
Right (outer) margin 1.8cm Bottom margin 1.8 cm
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2) Set the frame for the footer in the same way as for the header. Apply these margin
settings in the Landscape page style.

3) Copy and paste the footer from the portrait page into a blank paragraph in the text. Paste
or move it into the landscape page. This text will then have the Footer style so the
typeface, font size, and tab settings will match.

Instructions on how to set up a footer. Page 1 of 2

Instructions on how to set up a footer. Page 1 of 2

Figure 137: Copy the footer, paste, and select it

4) Select the text (including the fields) you just entered. Choose Format > Character. On
the Character dialog, choose the Position tab and set Rotation | Scaling to 270 degrees

(counterclockwise). Click OK.

& [ ] Character

Font  Font Effects ﬁ Hyperlink  Highlighting  Borders

Position
© Normal _
Superscript Raise/lower by 1% (5] [¥I Automatic
Subscript Relative font size | 100% |é’|
Rotation [ Scaling
| 0 degrees
) 90 degrees  Scale width 100% |é| Fit to line
) 270 degrees
Spacing
Character spacing 0.0 pt |é| Pair kerning

Figure 138: Rotating the footer text 270 degrees

5) With the text still selected, choose Insert > Frame > Frame. In the Frame dialog (Figure
139), select the Type tab and enter the width, height, and horizontal and vertical position
for the footer. Deselect the Automatic options in Width and Height if they are selected.

— The width is the footer height taken from the Footer page of the portrait page style
dialog.

— The frame height is obtained by simple arithmetic. The A4 page-width is 21cm, minus
the sum of the top and bottom margins of 2.8cm and 1.8cm resulting in a frame height
of 16.4cm.

— The horizontal position is the portrait page bottom margin.

— The vertical position is the landscape page top margin.

6) If your footer has a line above the text, as in this book, on the Borders tab, select a right
border and specify the line width and spacing to the frame’s contents.

7) Click OK to save these settings. The footer will now appear in the required position and
orientation. Any fields will update.

8) Because tabs have been removed, insert the cursor in the frame, at the end of the text
where the tab was, and insert as many spaces using the keyboard space bar, as you
require for the layout to match that on the portrait page.
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Repeat these steps (using appropriate settings) to set up a portrait header on the landscape
page.

[ JoN ] Frame
- Options ~ Wrap ' Hyperlink  Borders Area  Transparency Columns  Macro
Size Anchor
Width 0.50 em (2] 1 To page
_ ) To paragraph
Relative to  Paragraph area = © To paragrap
N . | To character —
AutoSize
As character
Height 16.40 cm (2]
Relative to Paragraph area -
| AutoSize
| Keep ratio
Position
Horizontal |Center by | 0.00cm |5| to | Paragraph area

| Mirror on even pages

Vertical Top B by |0.00cm |§J to | Margin

| Keep inside text boundaries

Figure 139: Defining the size and position of the footer frame

| The footer of the portrait page.

’

Irstructions on how o sel up a footar. Pagell oi@

e o S 00 W0l U0 SO

44— |The footer on the landscape page.

£ aleg

Figure 140: Footers in place for both page styles

Caution

Make sure to return to the paragraph in the document from which you rotated the
text, and return it to O degrees, or any text typed in this location will rotate.
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Defining borders and backgrounds

You can apply borders and backgrounds to many elements in Writer. Paragraphs, pages, frames,
sections, page styles, paragraph styles, character styles, and frame styles can include both
borders and backgrounds. The dialog pages for borders and backgrounds are similar in each
case. To illustrate their use, we will define a border and background for a frame.

ﬂTip

You can choose to have page backgrounds fill the entire page (sheet of paper) or
only the area within the margins; see the section on page styles in Chapter 9,
Working with Styles. Page borders surround only the area within the margins,
including the header or footer (if any exist).

Tables of data can also have borders and backgrounds, although the choices for
background are limited to Color or Bitmap. See Chapter 13, Tables of Data.

Adding a border

To begin, select the frame, right-click, and choose Properties in the context menu. Select the
Borders tab (Figure 141).

| JoN ] Frame
Type Options  Wrap  Hyperlink - Area  Transparency Columns  Macro
Line Arrangement Padding
Presets: _’EEE’T Left: 0.00 cm |é|
User-defined: Right: 0.00 cm |é|
Top: 0.00 cm |é|

Bottom: 0.00 cm

|v|
!

Synchronize

Line Shadow Style
Style: — - Position: ’? ’? I? ’?
Color: M Black - Color: Black
Width: 0.05 pt |é| Distance: 0.10 cm |é|

Figure 141: Frame dialog: Borders page

Borders have three components: where they go, what they look like, and how much space is left
around them.

* Line Arrangement specifies where the borders go. Writer provides five default
arrangements but you can click the line you want to customize in the User-defined area
to get exactly what you want. Each line can be individually formatted.

* Line specifies what the border looks like: the style, width, and color. Each parameter has
a number of attributes to choose from. The attributes selected will apply to those borders
highlighted by a pair of black arrows in the User-defined thumbnail on the left side of the
dialog.

* Padding specifies how much space to leave between the border and the contents of the
element. Spaces can be specified to the left, right, top, and bottom. Select Synchronize
to have the same spacing for all four sides.
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* Shadow Style properties always apply to the whole element. A shadow has three
components: where it is (Position), how far from the element it is cast (Distance), and
what color it is.

Adding a color to the background area

To begin, select the frame, right-click, and choose Properties in the context menu. On the Frame
dialog, select the Area tab (Figure 142), then choose Color. Select from the color grid or create a
new color to use for this frame, and then click OK to apply it to the background.

@ Frame

Type | Options Wrap Link Borders | Area | Transparency Columns  Macro

None \ Coler |  Gradient Bitmap Pattern Hatch

Colors Active New

Palette: standard “ -
W AN .

L]

AEEEEEEEEEEN 2 R 114 |[J
OO . -
BTt G [159 |3
EEEEE 1 IO EN -
AENEEEENT SE | B 207 |[J
/AN AN Es
HiEEEE Hex 729fcf
Pick

Recent Colors

HE
Custom Palette
Add

Figure 142: Frame dialog: Area page showing color choices

eTip

For selected words or other characters (right-click, Character > Character), the
“background” is called highlighting. The only choices are Color or None.

Adding a bitmap (image) to the background

“Bitmap” is a term that covers photos and other images that are made up of pixels of color; the
image may be in several formats. To add a bitmap to the background, choose the Area tab, then
choose Bitmap. The tab now displays the bitmap options, as shown in Figure 143.

You can choose one of the supplied bitmaps from the list on the left, or you can add your own.
To use an image, select it from the thumbnails on the left.
1) Inthe Options area, choose the placement for the image:
— Style — custom position/size, tiled, or stretched.

— Size - specify the width and height. Select Scale to stretch or shrink the image to fit
the selected size.

— Position — select where the image is to be displayed.
2) Click OK to apply the image to the background.
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To add an image:

1) Click the Add/Import button. The Import dialog opens.

2) Find the file you want and then click Open. The Import dialog closes, and the selected
bitmap appears in the list of thumbnails on the left and in the preview box on the right of
the Area tab.

[ N Frame

Type Options Wrap  Hyperlink  Borders Transparency  Columns  Macro

None Color Gradient Pattern Hatch
Bitmap Options Preview
Style:
Tiled il
Size:

Width: | 1.00 cm (2]

Height: | 1.00 cm (2]

Scale
Position:
Center a
Tiling Position:
X-Offset: | 0% B
Y-Offset: | 0% B
Tiling Offset:
Row B o% B

Add / Import

Figure 143: Frame dialog: Area page showing bitmap choices

Adding a gradient, pattern, or hatch to the background

To add a gradient, pattern, or hatch to the background, choose the Area tab, then choose the
required background type. The dialog now displays the options for that type, with an example in
the preview pane to the right. Select the required design from the list or create a new design to
use for this frame. Click OK to apply it to the background. See the Draw Guide for more about
defining gradients, patterns, and hatching.

Deleting a color, gradient, bitmap, or other background

To delete a background, select None near the top of the Area tab of the Frame dialog.

Adjusting the transparency of the background

Transparency is useful for creating watermarks (a logo or text in the background of a page,
typically showing the company name or a statement such as Draft) and making colors or images
more pale (for more contrast with the text). Use the Transparency tab (Figure 144) to define the
type of transparency. The choices are covered in detail in the Draw Guide.
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@ Frame

Type | Options Wrap Link Borders Area | Transparency | Columns  Macro
Area Transparency Mode

MNo transparency

Transparency: 50% |é’|
© Gradient
Type: -
Linear
Center X: |Axial
Radial_
Center Y EII|pso|d_
Quadratic
Square
Angle: UF
Border: 0% l;]
Startvalue: 0% | EJ
End value:  100% U

Figure 144: Transparency options
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Quick printing

If the Print Directly icon is visible on the Standard toolbar, you can click it to print the entire
document using the current default print settings. If the icon is not visible, you can make it visible
by right-clicking on the toolbar, pointing to Visible Buttons, and selecting Print Directly.

You can specify the default printer on the Printer Setup dialog; go to File > Printer Settings on
the Menu bar. To access other printing options, click the Options button on the Printer Setup
dialog. The same options are available through Tools > Options > LibreOffice Writer > Print,
and more general print options through Tools > Options > LibreOffice > Print. See Chapter 20,
Customizing Writer, for more information.

Controlling printing

For more control over printing, use the Print dialog (File > Print, Ctr/+P (38 +P for macOS), or the
Print icon on the Standard toolbar). The appearance of the Print dialog is different on macOS
and may include extra printer controls not described in this chapter.

General LibreOffice Writer

Printer
-8.27 in (Ad) Brother HL-3170CDW series Printer j

Status: Default printer Properties...

Range and Copies
@ All Pages
OPages: 1
Selection
Include: IOdd and Even Pages j
+|more

Page Layout
Paper size: ‘A4 8.27in x 11.69in q

Orientation: ‘Portrait ™ ‘

11.69 in

+|more

[V]Preview N |/ 1d |

Help M e Optlois\ Print || Cancel

Figure 145: The Print dialog in Writer

The Print dialog has two tabs, on which you can choose a range of options, as described in the
following sections.
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Selecting general printing options
On the General tab of the Print dialog, you can choose:

* The printer, from the list of available printers.

* Which pages to print, the number of copies to print, and whether to collate multiple
copies (Range and copies section).

» Paper size and print orientation (Page Layout section).

* How many pages to print on one sheet of paper and whether to draw a border around
each page (Page Layout section).

* Whether to print a brochure (see page 146).

* Whether to print in reverse page order (useful on some printers to make the pages come
out in page order).

Selecting printer and print job options

In the Printer section of the General tab, click the Properties button to display the selected
printer’s properties dialog where you can choose portrait or landscape orientation, which paper
tray to use, and the paper size to print on.

Click the More button at the bottom of the Range and Copies section of the General tab to
choose whether to create separate print jobs for collated output, instead of one print job
containing all the collated pages (not relevant if only one copy of a document is printed).

Printing multiple pages on a single sheet of paper

You can print multiple pages of a document on one sheet of paper. To do this, in the Page Layout
section of the General tab, click More and select from the Pages per sheet drop-down list the
number of pages to print per sheet of paper. The preview panel on the left of the Print dialog
shows how the printed document will look.

When printing more than two pages per sheet, you can choose the order in which they are
printed across and down the paper. Figure 146 shows the difference.

GTip

To print two pages per sheet in “facing pages” (book layout) style, print from Print
Preview instead. See page 149.

Page Layout
Papersize A4 827inx 11.68in v]
Orientation: |Automatic v]
5 More
ST— 11 2

WESR ot toright, then down |

Left to ight, then down

Top to bottom, then right
O Brochure Top to bottom, then left
Right to left, then down

Figure 146: Print order choices
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Selecting what to print

In addition to printing a full document, you can choose to print individual pages, a ranges of
pages, or a selection from a document.

Printing an individual page:
1) Inthe Print dialog, in the Range and Copies section, select the Pages option. The text
box shows the current page number.

2) Enter the page number of the page you want to print. The preview box on the left
changes to show the selected page.

Printing a range of pages:
1) Inthe Print dialog, in the Range and Copies section, select the Pages option.

2) Enter the page numbers of the pages to print (for example, 1-4 or 1,3,7,11 or a
combination).

Printing a selection of text or graphics:
1) Inthe document, select the material to print, then open the Print dialog.

2) Inthe Range and Copies section of the Print dialog, the Selection option is now active
and selected and the preview box shows the selected material (Figure 147).

In addition to printing a full dog Print x
can choose to print individual - —
of a document. The details vat General || ueOffice Wilex
described below. Printer
Wn.rer and Marh 8.27in (Ad) Lexmark Universal v2 ~
printing an individual page: T mzoe e Status: Default printer Properties...
1) In the Print dialog, in th I e Range and Copies
box shows the current O All Pages ® Selection
2) Enter the page numbe! O Pages:
Changes to showthe s - Include: |0dd and Even Pages ~ |
Printing a range of pages: 8 More
1) In the Print dialog, in tk Page Layout
2) Enter the page numbe| Paper size: |A48.Z?inx 11.68in V|
Cﬂmbinati(]n). Orientation: |Automatic V|
Printing a selection of text or g More
1) In the document, seled

Figure 147: Printing a selection of text

Choices on the LibreOffice Writer tab

On the LibreOffice Writer tab (Figure 148) you can choose to print a subset of contents (for
example, images or hidden text), print text in black (even if a color is defined for the text),
whether to print automatically inserted blank pages, and whether and where to print any
comments that are in the document.

Some selections may not be available all the time. For example, if the document contains no
comments, the Comments drop-down list is disabled.
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General LibreQffice Writer

Contents
Images and other graphic objects
[ Hidden text
[ Text placeholders
Form controls

Cn:-mments:| one l[gocument on

Color
L] Print text in black
Pages:
Print automatically inserted blank pages

Figure 148: LibreOffice Writer tab of Print dialog

Printing a brochure

In Writer, you can print a document with two pages on each side of a sheet of paper, arranged so
that when the printed pages are folded in half, the pages are in the correct order to form a
booklet or brochure.

eTip

Plan your document so it will look good when printed half size; choose appropriate
margins, font sizes, and so on. You may need to experiment.

To print a brochure on a single-sided printer:

1) Inthe Page Layout section of the General tab of the Print dialog, click more and select
Brochure near the bottom. The preview on the left changes to show the sequence in
which the pages will be printed. (Figure 149.)

2) Depending on your language settings (Tools > Options > Language Settings >
Languages), the Print dialog may include a drop-down menu adjacent to the Brochure
button (not shown in Figure 149). This provides Left-to-right script and Right-to-left script
options. Select the required setting in this menu.

3) Inthe Range and Copies section, select Even pages. Click Print.

4) Take the printed pages out of the printer and put them back into the printer in the correct
orientation to print on the blank side. You may need to experiment to find the correct
arrangement for your printer.

5) On the Print dialog, in the Range and Copies section, select Odd pages. Click Print.

ﬂTip

If your printer can print double-sided (duplex) automatically, choose All pages in
step 3 and skip steps 4 and 5.
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Range and Copies
@ All Pages
OPages: 13
(O selection

Include: [Even Pages

11.69 in (A4)

\E\ more

Paper sides: Print on one side (simplex)

Collate . .ﬁ

Order: [IPrint in reverse order

Number of copies: 1

8.27 in

Page Layout
T Paper size: A4 8.27in x 11.69in

N TR

Orientation: Automatic
[=Imore
(O Pages per sheet: 1 j

Order: Left to right, then down v ‘

[ |Draw a border around each page
(®Brochure

Preview 1 /7N

Figure 149: Settings for printing a brochure on a simplex printer

Printing in black and white (on a color printer)

You may wish to print documents in black and white on a color printer. Several choices are
available.

Note
Some color printers may print in color regardless of the settings you choose.

For one document, change the printer settings to print in black and white or grayscale:

1) On the Print dialog, click Properties to open the Properties dialog for the printer. The
available choices vary from one printer to another, but you should find options for the
color settings. See your printer’s help or user manual for more information.

2) The choices for color might include black and white or grayscale. Choose grayscale.
3) Click OK to confirm your choice and return to the Print dialog.
4) Click Print to print the document.
To print all color text and images as grayscale, change the LibreOffice settings:
1) Choose Tools > Options > LibreOffice > Print.
2) Select the Convert colors to grayscale option. Click OK to save the change.

To print all color text as black, and all images as grayscale, change the LibreOffice Writer
settings:

1) Choose Tools > Options > LibreOffice Writer > Print.
2) Under Contents, select the Print text in black option. Click OK to save the change.

ibm

Ledl<]d

—
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Previewing pages before printing

The normal page view in Writer shows what each page will look like when printed; you can edit
the pages in that view. If you are designing a document to be printed double-sided, you may want
to see what facing pages look like. Writer provides two ways to do this:

* View Layout (editable view): use the Book View button on the status bar and (usually)
zoom out.

O OGO (@ e @ |85%

* Print Preview (read-only view).
To use Print Preview:

1) Choose File > Print Preview on the Menu bar, or click the Toggle Print Preview icon on
the Standard toolbar, or press Ctrl+Shift+O. Writer now displays the Print Preview toolbar
instead of the Formatting toolbar.

D ED [D % | K £ |0 > 2| &% |v| & E‘ E:'rlprirlt Close Preview

2) Select the required preview icon: Single Page Preview, Two Pages Preview, Book
Preview, or Multiple Pages Preview.

3) To print the document from this view, click the Print icon to open the Print dialog. Choose
the print options and click Print.

Printing envelopes

Printing envelopes involves two steps: setup and printing.
To set up an envelope to be printed by itself or with a document:

1) Click Insert > Envelope on the Menu bar.

2) In the Envelope dialog, start with the Envelope tab (Figure 150). Verify, add, or edit the
information in the Addressee and Sender (the “from” on the envelope) boxes. The sender
information is picked up from the User Data page in Tools > Options > LibreOffice.

You can type information directly into the Addressee and Sender boxes, or use the right-
hand drop-down lists to select the database or table from which you can draw the
envelope information. See Chapter 14, Mail Merge, for details on how to print envelopes
from a database.

3) Onthe Format tab (Figure 151), verify or edit the positioning of the addressee and the
sender information. The preview area on the lower right illustrates your choices.

4) To format the text of these blocks, click the Edit button to the right. In the drop-down list
you have two choices: Character and Paragraph.

— Select Character to open a dialog similar to the standard Character dialog, where you
can set the formatting of the text.

— Select Paragraph to open a dialog similar to the standard Paragraph dialog, where
you can set the paragraph's attributes.

5) In the lower left of this tab is the Size section. Choose the envelope format in the drop-
down list. The width and height of the selected envelope show in the boxes below the
selected format. If you chose a pre-existing format, just verify these sizes. If you chose
User Defined in the Format list, then you can edit the sizes.
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& & Envelope

_ Format  Printer |

Addressee Database
Addressesl
Table
€
Database field
Sender

Jean Hollis Weber
123 Any Street

Any town ZZ 0000 - |:|

Australia

Help Insert Reset Cancel _

Figure 150: Choosing addressee and sender information for an envelope

0@ Envelope
Envelope [ Fermat | Printer
Addressee
Position
from It 115 00 cm Format | Edit v
from top 5.50 cm L:J
Sender
Pasition
fromleft 1 1o om (2] Format @ Edit -
fromtop 1 goem | 2]
Size
Format [DL Envelope | 4
Width 22.00cm | [2] T []
Height 11.00cm | (2 -
WNGHDSMED ncet | Cacel | Hep | Rese

Figure 151: Choosing positioning and size of elements for an envelope
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6) After formatting, go to the Printer tab (Figure 152) to choose which printer to use, its
setup (for example, specification of the tray holding envelopes), and other printer options
such as envelope orientation and shifting. You may need to experiment to see what
options work best for your printer, as well as how the envelopes need to be positioned in
the printer.

Envelope Format | Printer |

Envelope Orientation

I EIEA

«  Print from top

Print from bottom

Shift right 0.00 cm B
shift down 0.00 ¢m )
Current Printer @ Printer Setup
Lexmark E232 Printer Setup...
Name: [Lexmark E232 | &

Status: Default printer
Type: Lexmark E232
Location:
Comment:

Help e OK. Cancel
_m_

New Document Insert Cancel Help Reset

Figure 152: Choosing printer options for an envelope

7) When you have finished formatting and are ready to print, click either the New Document
button or the Insert button to finish. New Document makes only an envelope or starts a

new document with the envelope. Insert puts the envelope into your existing document as
page 1.

8) Save this file before you do anything else.
To print the envelope:
1) Choose File > Print on the Menu bar.

2) On the Print dialog (Figure 145 on page 144), under Range and Copies, choose Pages
and type 1 in the box. Choose the required printer (which may be different from the usual
printer). Click Print.

Printing labels

Labels are commonly used for printing address lists (where each label shows a different
address), but they can also be used to make multiple copies of one label, for example return-
address stickers, labels for CDs/DVDs, or other items.

Printing labels, like printing envelopes, has two steps: setup and printing. This topic is covered in
detail in Chapter 14, Mail Merge.
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Exporting to PDF

LibreOffice can export documents to PDF (Portable Document Format). This standard file format
is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.

Warning

A document in PDF format is not protected against contents tampering or editing by
default. The PDF document contents can be edited by specialized software tools,
including LibreOffice Draw.

OTip

Unlike Save As, the Export command writes a copy of the current document in a new
file with the chosen format, but keeps the current document and format open in your
session.

Quick export to PDF

Click the Export Directly as PDF icon on the Standard toolbar, or File > Export As > Export
Directly as PDF, to export the entire document using the PDF settings you most recently
selected in the PDF Options dialog. You are asked to enter the file name and location for the
PDF, but you do not get a chance to choose a page range, the image compression, or other
options.

Controlling PDF content and quality

For more control over the content and quality of the resulting PDF, use File > Export as >
Export as PDF. The PDF Options dialog opens. This dialog has six tabs (General, Initial View,
User Interface, Links, Security, and Digital Signatures). Select the appropriate settings, and then
click Export. Then you are asked to enter the location and file name of the PDF to be created,
and click Save (Windows and Linux) or Export (macOS) to export the file.

Note

You can also export to PDF with File > Export. On the Export dialog, select the PDF
file format, the file name and location, and click Save or Export. The PDF Options
dialog then opens. Select the appropriate settings and then click Export. The only
difference between the two export methods is the sequence in which steps occur.

General tab of PDF Options dialog

On the General tab (Figure 155), you can choose which pages to include in the PDF, the type of
compression to use for images (which affects the quality of images in the PDF), and other
options.

Range section
* All: Exports the entire document to PDF.

* Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single
pages, use the format 7;9;11 (pages 7, 9 and 11). You can also export a combination of
page ranges and single pages, by using a format like 3-6;8;10;12.

+ Selection: Exports whatever material is selected.

* View PDF after export: Your default PDF viewer will open and display the newly
exported PDF.
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PDF Options x

General Initial View User Interface Links Security Digital Signatures

Range General
®) Al [ Hybrid PDF (embed ODF file)
O Pages: [] Archive (PDF/A, 150 19005)
() Selection PDF/A version:
[ view PDF after export ] Universal Accessibility (PDF/UA)
Ol Tagged PDF (add document structure)
Images Create PDF form

() Lossless compression

Submit format:  |FDF w
® JPEG compression Quality: |90%

L3

[ Allow duplicate field names

Reduce image resolution 300 DPI e
Structure
Watermark Export outlines

[ sign with watermark 0 Export placeholders
[l Comments as PDF annotations
[] Export automatically inserted blank pages
[ Use reference XObjects

Help Export Cancel

Figure 153: General tab of PDF Options dialog

Images section

* Lossless compression: Images are stored without any loss of quality. Tends to make
large files when used with photographs. Recommended for other kinds of images or
graphics.

* JPEG compression: Allows for varying degrees of quality. A setting of 90% works well
with photographs (smaller file size, little perceptible loss of quality).

* Reduce image resolution: Lower DPI (dots per inch) images have lower quality. Lower
resolutions (100 dpi or less) may be sufficient for viewing on a computer screen, but
many modern devices have much higher resolutions; and for printing it is generally
preferable to use at least 300 or 600 dpi, depending on the capability of the printer.
Higher DPI settings increase the size of the exported file.

Note

EPS (Encapsulated PostScript) images with embedded previews are exported only
as previews. EPS images without embedded previews are exported as empty
placeholders.

Watermark section

* Sign with Watermark: When this option is selected, a transparent overlay of the text you
enter into the watermark text box will appear on each page of the PDF.

General section
* Hybrid PDF (embed ODF file): Use this setting to export the document as a PDF
containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF
file, and it remains fully editable in LibreOffice.

Exporting to PDF | 153



Archive (PDFIA, ISO 19005): PDF/Ais an ISO standard for long-term preservation of
documents, by embedding all the information necessary for faithful reproduction (such as
fonts) while forbidding other elements (including forms, security, and encryption). PDF
tags are written. PDFIA-1b refers to the minimum compliance level with PDF/A-1.
PDFIA-2b is recommended for most users, because it allows layers and transparency
with shapes and images. It also compresses better, usually producing smaller files.
PDF/A-3b is identical to PDF/A-2b, but also accepts embedding of other file formats.

Universal Accessibility (PDF/UA): Creates a universal accessibility-complaint PDF file
that follows the requirements of PDF/UA (1ISO 14289) specifications. See the Help for
more information.

Tagged PDF: Tagged PDF contains information about the structure of the document’s

contents. This can help to display the document on devices with different screens, and
when using screen reader software. Some tags that are exported are table of contents,
hyperlinks, and controls. This option can increase file sizes significantly.

Create PDF form — Submit format: Choose the format of submitting forms from within
the PDF file. This setting overrides the control’s URL property that you set in the
document. There is only one common setting valid for the whole PDF document: PDF
(sends the whole document), FDF (sends the control contents), HTML, and XML. Most
often you will choose the PDF format.

Allow duplicate field names: If enabled, the same field name can be used for multiple
fields in the generated PDF file. You can enter data in the first occurrence of the named
field in the PDF document and all fields with the same name will carry your entry. If
disabled, field names will be exported using generated unique names.

Structure section

Export outlines: Exports headings as an outline (table of contents list) displayed by
most PDF viewers, including Adobe Reader. In Writer 7.0 and earlier, these were called
bookmarks.

Export placeholders: The PDF will include any defined placeholder fields, which can be
filled in by users.

Comments as PDF annotations: If selected, comments are included in the PDF as
annotations.

Export automatically inserted blank pages: If selected, automatically inserted blank
pages are exported to the PDF. This is best if you are printing the PDF double-sided. For
example, books usually have chapters set to always start on an odd-numbered (right-
hand) page. When the previous chapter ends on an odd page, Writer inserts a blank
page between the two odd pages. This option controls whether to export that blank page.

Use reference XObjects: Reference XObjects enable one PDF file to import content
from another. More information can be found in section 8.10.4 of the PDF specification,
ISO 32000-2:2017 (https://www.iso.org/standard/63534.html). If you are not familiar with
referenceXObjects, leave this box unchecked.

Initial View tab of PDF Options dialog

On the Initial View tab (Figure 154), you can choose how the PDF opens by default in a PDF
viewer. The selections should be self-explanatory.

If you have Complex Text Layout enabled (in Tools > Options > Language settings >
Languages), an additional selection is available under the Continuous facing option: First
page is left (normally, the first page is on the right when using the Continuous facing option).
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PDF Opticns

() Bookmarks and page
(O Thumbnails and page
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Page Layout
(® Default
() Single page
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Magnification
(®) Default
O Fit in window
O Fit width
O Fit visible

-
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Figure 154: Initial View tab of PDF Options dialog

User Interface tab of PDF Options dialog

On the User Interface tab (Figure 155), you can choose more settings to control how a PDF
viewer displays the file. Some of these choices are particularly useful when you are creating a
PDF to be used as a presentation or a kiosk-type display.

PDF Options *

General Initial View User Interface Links Security Digital Signatures

Window Options
[ Resize window to initial paget [ Hide menubar

[ Hide toolbar

O Hide window controls

User Interface Options

[l Center window on screen
[] Open in full screen mode
Display document title

Transitions Collapse Qutlines
® Show Al

() Visible levels: |1 =

Figure 155: User Interface tab of PDF Options dialog

Window options section
* Resize window to initial page. The PDF viewer window will resize to fit the first page of

the PDF.

* Center window on screen. The PDF viewer window will be centered on the computer
screen.

* Openin full screen mode. The PDF viewer will open full-screen instead of in a smaller
window.

* Display document title. The PDF viewer will display the document’s title in the title bar.

User interface options section
 Hide menubar. The PDF viewer will hide the Menu bar.

« Hide toolbar. The PDF viewer will hide the toolbar.
* Hide window controls. The PDF viewer will hide other window controls.
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Transitions
Not available in Writer.
Collapse Outlines
Select how many heading levels are displayed in the outline, if Export Outlines is selected

on the General tab.
Links tab of PDF Options dialog
On the Links tab (Figure 156), you can choose how links in documents are exported to PDF.

Export outlines as nhamed destinations
Paragraphs defined in Writer’s outline levels are exported as “named destinations” to which
Web pages and PDF documents can link.
Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such as .odt,
.0ds, and .odp), the file extensions are converted to .pdf in the exported PDF document.
Export URLSs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF.

Cross-document links
Defines the behavior of links clicked in PDF files. Select one of the alternatives:
— Default mode: The PDF links will be handled as specified in your operating system.

— Open with PDF reader application: Use the same application used to display the PDF
document to open linked PDF documents.

— Open with Internet browser: Use the default Internet browser to display linked PDF
documents.

PDF Opticns *

General Initial View User Interface Links Security Digital Signatures

General

iExport outlines as named destinations;

[] Convert document references to PDF targets
Export URLs relative to file system

Cross-document Links
(O] Default mode

O Open with POF reader application
() Open with Internet browser

Figure 156: Links tab of PDF Options dialog

Security tab of PDF Options dialog

PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and
apply some digital rights management (DRM) features.

* With an open password set, the PDF can only be opened with the password. Once
opened, there are no restrictions on what the user can do with the document (for
example, print, copy, or change it).

* With a permissions password set, the PDF can be opened by anyone, but its permissions
can be restricted. See Figure 157. After you set a password for permissions, the other
choices on the Security page become available.
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* With both the open password and permission password set, the PDF can only be opened
with the correct password, and its permissions can be restricted.

Note

Permissions settings are effective only if the user’s PDF viewer respects the settings.

PDF Opticns x

General Initial View User Interface Links Security Digital Signatures

File Encryption and Permission Printing
(O Mot permitted
)] Low resclution (150 dpi)

Mo open password set {®) High resolution
PDF document will not be encrypted

Changes

Permission password set O Not permitted

PDF document will be restricted
O Inserting, deleting, and rotating pages

() Filling in form fields
(O Commenting, filling in form fields
®) Any except extracting pages

Content
Enable copying of content
Enable text access for accessibility tools

Figure 157: Security tab of PDF Options dialog with passwords set

Digital Signatures tab of PDF Options dialog
The Digital Signatures tab (Figure 158) contains the options for exporting a digitally signed PDF.

PDF Options x

General Initial View User Interface Links Security Digital Signatures

Certificate
Use this certificate to digitally sign PDF documents:

Clear

Certificate password:
Location:
Contact information:

Reason:

Time Stamp Authority: |I-Jcne ‘

Figure 158: Digital Signatures tab of PDF Options dialog

Digital signatures are used to ensure that the PDF was really created by the original author (that
is, you), and that the document has not been modified since it was signed.

The signed PDF export uses the keys and X.509 certificates already stored in your default key
store location or on a smartcard. The key store to be used can be selected under Tools >

Options > LibreOffice > Security > Certificate Path (macOS and Linux only). When using a
smartcard, it must already be configured for use by your key store. This is usually done during
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installation of the smartcard software. Details about using these features is outside the scope of
this chapter.

* Use this certificate to digitally sign PDF documents: Click Select to open the Select
Certificate dialog, where all certificates found in your selected key store are displayed. If
the key store is protected by a password, you are prompted for it. When using a
smartcard that is protected by a PIN, you are also prompted for that.

» Select the certificate to use for digitally signing the exported PDF, then click Sign.

» All other fields on the Digital Signatures tab are accessible only after a certificate has
been selected.

* Certificate password: Enter the password used for protecting the private key associated
with the selected certificate. Usually this is the key store password. If the key store
password has already been entered in the Select Certificate dialog, the key store may
already be unlocked and not require the password again.

* When using a smartcard, enter the PIN here. Some smartcard software will prompt you
for the PIN again before signing.

* Location, Contact information, Reason: Optionally enter additional information about the
digital signature that will be applied to the PDF. This information will be embedded in the
appropriate PDF fields and will be visible to anyone viewing the PDF. Any or all of the
three fields may be left blank.

» Time Stamp Authority: Optionally select a Time Stamping Authority (TSA) URL. During
the PDF signing process, the TSA will be used to obtain a digitally signed timestamp that
is then embedded in the signature. Anyone viewing the PDF can use this timestamp to
verify when the document was signed.

* The list of TSA URLSs that can be selected is maintained under Tools > Options >
LibreOffice > Security > TSAs. If no TSA URL is selected (the default), the signature
will not be timestamped, but will use the current time from your local computer.

Exporting to EPUB format

EPUB format has become popular since mobile devices such as smartphones, tablets, and
e-readers appeared on the market. The EPUB format is implemented as an archive file
consisting of HTML files carrying the content, along with images and other supporting files.

Writer can export a file to EPUB. A text-only document generally exports well, but some contents
(such as illustrations, tables, and cross-references) may not export correctly.

ﬂTip

Other ways to export to EPUB from Writer (.odt) files include Calibre, an open-source
e-book manager that runs on Windows, macOS, and Linux. Calibre provides many
e-book conversion facilities and allows editing of the result.
https://calibre-ebook.com/

Quick export to EPUB

Choose File > Export As > Export Directly as EPUB to export the entire document using the
EPUB settings you most recently selected on the EPUB Export dialog (see below). You are
asked to enter the file name and location for the EPUB file, but you do not get a chance to select
other options.
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Controlling export to EPUB

For more control over the content and quality of the resulting EPUB file, use File > Export As >
Export as EPUB. The EPUB Export dialog opens (Figure 159).

EPUB Export >

General

Version:

Split method: |Heading ~ |

Layout methaod: |Ref|u:uwa|::lle V|

Customize

Cover image: Browse...

Media directory: Browse...

Metadata

|dentifier:

Title: Chapter 10 Printing, Exporting, E-mailing, Sic
Author:

Language:

Date: 0000-00-00TO0:00:00

Help QK Cancel

Figure 159: EPUB Export dialog
The EPUB Export dialog has the following fields:

Version
Choose the EPUB version for the exported file. Values are EPUB 2.0 and EPUB 3.0. Most

new e-readers can read EPUB 3.0.

Split method
Select the method to start a new section. Choose Heading to start the section on a
heading, according to the document’s chapter numbering. Choose Page break to start the
section on a page break.

Layout method
Choose Reflowable to have the ebook display change to fit the screen size and the user’s
preference (so page size and header/footer content is not exported). Choose Fixed to have
the ebook layout remain the same under all conditions.

Customize - Cover image
The path to the image file for the cover page. If no image is specified, the EPUB file will
automatically use any image with a name like cover.gif, cover.jpg, cover.png, or cover.svg.
A custom cover image is embedded in the EPUB file.

Customize - Media directory
The path to the optional directory for the cover image, metadata, and multimedia files. If
you do not specify a directory, the exporter looks for custom media and metadata in the
current document directory inside a folder with the same name as the document file name.
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Metadata
The basic information for the file that provides tags to help searches. These fields provide
another chance to edit metadata that is picked up by default from File > Properties in
Writer.

Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. If you
cannot find what you want under File > Save As, look under File > Export as well. Writer can
export files to XHTML, EPUB and other formats, as shown in Figure 160.

Choose File > Export. On the Export dialog, specify a file name for the exported document, then
select the required file format and click Export.

File name: WG6007-PrintExportEmail_bb_gp L | EBxport.. |
File format: | PNG - Portable Network Graphic (.png) |~ | Cancel
XHTML (.html;.xhtml) Help

% Automati¢ POF - Portable Document Format (.pdf)

n EPUB Document (.epub)
JPEG - Joint Photographic Experts Group (.jpg;.jpeag;.jfif;.jif;.jpe)

Writer Layout XML (.xml)
1PNG - Portable Network Graphic (.png) F

Figure 160: Export file formats

Emailing Writer documents

LibreOffice provides several ways to quickly and easily send a Writer document as an email
attachment in one of three formats: .odt (OpenDocument Text, Writer's default format), .docx
(Microsoft Word format), or .pdf.

To send the current document in .odt format, choose:

1) File > Send > Email Document, or File > Send > Email as OpenDocument Text.
Writer opens your default email program (if installed). The document is attached to a new
email.

2) Inyour email program, enter the recipient, subject, and any text you want to add, then
send the email.

If you choose Email as Microsoft Word, Writer first creates a file in Word format (.docx) and then
opens your email program with the Word file attached to a new email. Similarly, if you choose
Email as PDF, Writer opens the PDF Options dialog where you can select the settings you want,
then creates a PDF, and then opens your email program with the PDF attached to a new email.

Emailing a document to several recipients

To email a document to several recipients, you can use the features in your email program or you
can use Writer's mail merge facilities to extract email addresses from an address book.

You can use Writer’'s mail merge to send email in two ways:

* Use the Mail Merge Wizard to create the document and send it.
* Create the document in Writer without using the Wizard, then use the Wizard to send it.

See Chapter 14, Mail Merge, for details.

160 | Chapter 7 Printing, Exporting, Emailing, Signing



Digital signing of documents

To sign a document digitally, you need a personal key, also known as a certificate. A personal key
is stored on your computer as a combination of a private key, which must be kept secret, and a
public key, which you add to your documents when you sign them. You can get a certificate from
a certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a checksum is computed from the document’s
content plus your personal key. The checksum and your public key are stored with the document.

When someone later opens the document on any computer with a recent version of LibreOffice,
the program will compute the checksum again and compare it with the stored checksum. If both
are the same, the program will signal that you see the original, unchanged document.

In addition, the program can show you the public key information from the certificate. You can
compare the public key with the public key that is published on the web site of the certificate
authority. Whenever someone changes something in the document, this change breaks the
digital signature.

For a more detailed description of how to get and manage a certificate, and signature validation,
see “About Digital Signatures” and “Applying Digital Signatures” in the LibreOffice Help.

A signed document shows an icon in the Status bar. You can double-click the icon to view the
certificate. More than one signature can be added to a document.

Changing an existing description invalidates the signature. However, multiple signatures from the
same author are allowed, because each signature can have a different description.

Applying a digital signature

The following procedure is an example of how to digitally sign a document. The actual procedure
depends on how your computer is set up and its operating system.

1) Choose File > Digital Signatures > Digital Signatures.

— If you have set LibreOffice to warn you when the document contains comments or
recorded changes (see “Removing personal data” on page 163), you may see a
message box asking whether you want to continue signing the document.

— If you have not saved the document since the last change, a message box appears.
Click Yes twice: once to continue and again to save the file.

2) The Digital Signatures dialog (Figure 161) opens. It lists existing signatures together with
their description (if they have any). Click the Sign Document button to add a new
signature to the document.
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Digital Signatures

The following have signed the document content:

Signed by Digital ID issued by Date Description Signature type

Use AdES-compliant signature when there is a choice

§ign Document.... Remove Start Certificate Manager..,

View Certificate...

Help Close

Figure 161: Signatures of the document

3) Inthe Select Certificate dialog (Figure 162), select your certificate, add an optional
description, and click Sign to return to the Digital Signatures dialog. The certificate used
is displayed in the dialog with an icon next to its name. This icon indicates the status of

the digital signature.
4) Click Close in the Digital Signatures dialog to apply the digital signature.

Select Certificate

Select the certificate you want to use for signing:
Issued to Issued by Type Expiration date Certificate usage

View Certificate...
Description:

Help Sign Cancel

Figure 162: Signatures can have a description
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Including a signature line

You can generate a graphic box representing a signature line using Insert > Signature Line (see
Figure 163), and you can optionally sign the signature line using a digital certificate.

Signature Line x

Suggested Signer
Name:  |lohn Doe
Title: Director
Emailk |john.doe@example.org
More
Signer can add comments
Show sign date in signature line

Instructions to the signer:

Help QK Cancel

Figure 163: Creating a signature line for a document

X

Jean Hollis Weber
Editor

Figure 164: Signature line example

Removing personal data

You may wish to ensure that personal data, versions, comments, hidden information, or recorded
changes are removed from files before you send them to other people or create PDFs from them.

In Tools > Options > LibreOffice > Security, click the Options button to display a dialog
(Figure 165) where you can set LibreOffice to warn you when files contain certain information
and/or automatically remove personal information on saving.
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& Security Options and Warnings

Security Warnings
Warn if document contains recorded changes, versions, hidden information or notes:

When saving or sending When signing
When printing When creating PDF files
Security Options
Remowve personal information on saving
Recommend password protection on saving
Ctrl-click required to follow links

Block any links from documents not among the trusted locations (see Macro Security) '

Help SRl  Cance

Figure 165: Set security warnings and options

To remove personal and some other data from a file, go to File > Properties. On the General
tab, uncheck Apply user data and click the Reset Properties button. This removes any names
in the created and modified fields, deletes the maodification and printing dates, and resets the
editing time to zero, the creation date to the current date and time, and the version number to 1.

To remove version information, either (a) go to File > Versions, select the versions from the list
and click Delete, or (b) use Save As and save the file with a different name.

Redaction

You can redact documents to remove or hide sensitive information, to allow the selective
disclosure of information in a document while keeping other parts of the document secret. For
example, when a document is subpoenaed in a court case, information not specifically relevant to
the case at hand is often redacted.

To redact a document:

1) Open the document in Writer.

2) Click Tools > Redact on the Menu bar, and wait for the document to be prepared for
redaction and transferred to Draw. The Redaction toolbar (Figure 166) opens.

Redaction W& x
Ov RE 2

Figure 166: Redaction toolbar

3) Do the redaction by using the Rectangle Redaction and Freeform Redaction tools on
the Redaction toolbar. The shapes will be transparent and in gray so you can see what
you are redacting.

4) Optionally use the Export Directly as PDF tool to make an in-redaction copy of the
document in PDF to use as a verbatim copy for review. The redacted items will be in
transparent grey.

5) To finalize the redaction, select the desired option (black or white) on the Redacted
Export tool. The transparent grey shapes are converted to opaque black or white shapes
and the document is exported as a pixellized PDF. There will be no selectable text in it,
and the redacted content will be non-existent.
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Auto-redaction

To partially automate the redaction process, you can define certain words (such as names) to be
redacted wherever they are found in the document. To do this, choose Tools > Auto-Redact on
the Menu bar to open the Automatic Redaction dialog (Figure 167). Here you can load a list of

terms (targets), add targets, delete targets, edit targets, and save a list of targets.

Redaction Targets

Target Mame |Type |C0r1ter'|t

| Case Sensitive Whole Words

Add Target

Marme: arget 1

X

Type: ‘Text

Content:

[] Case Sensitive

Help

[ Whole Words Only

QK Cancel

Help

Figure 167: Automatic Redaction dialog

Load Targets

Save Targets

Add Target

Edit Target

Delete Target

Cancel
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What are styles?

Most people are used to writing documents according to physical attributes. For example, you
might specify the font family, font size, and weight (for example: Helvetica 12pt, bold). In contrast,
styles are logical attributes. For example, you can define a set of font characteristics and call it
Title or Heading 1. In other words, styles mean that you shift the emphasis from what the text
looks like to what the text is.

Why use styles?

Styles help improve consistency in a document. They also make major formatting changes easy.

For example, you might decide to change the indentation of all paragraphs or change the font of

all titles. For a long document, this simple task could be prohibitive. Styles make the task easy. In
addition, Writer uses styles for other purposes, such as compiling a table of contents; see “Using
paragraph styles to define a hierarchy of headings” on page 185.

Style categories
LibreOffice Writer has six style categories:

* Paragraph styles affect entire paragraphs and are also used for purposes such as
compiling a table of contents.

* Character styles affect a block of text inside a paragraph; they provide exceptions to
paragraph styles.

* Page styles affect page formatting (page size, margin, and the like).

* Frame styles affect frames and images.

» List styles affect outlines, ordered (numbered) lists, and unordered (bulleted) lists.
» Table styles affect the appearance of tables of data.

Paragraphs are the building blocks of every document: headings are paragraphs; headers,
footers, and items in numbered lists are also paragraphs. Paragraph styles are, therefore, the
most frequently used styles and are the ones treated in most detail in this chapter.

Note

Manual formatting (also called direct formatting) overrides styles. You cannot get rid
of manual formatting by applying a style to it.

To remove manual formatting, select the text and choose Format > Clear Direct
Formatting on the Menu bar, or right-click and choose Clear Direct Formatting in
the context menu, or press Ctrl+M.

The Styles deck in the Sidebar

Styles management is primarily available through the Styles deck in the Sidebar (Figure 168).
Here you can apply styles, modify styles, and create new styles.

To begin, do any of the following:

* Click the Styles icon on the Sidebar.
* Choose Styles > Manage Styles on the Menu bar.
* Press F11 (¥+T on Mac).

The first six icons at the top of the Styles deck select the category of styles. Click one of these
icons to display a list of styles in that category, such as paragraph or character styles.
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Select the Show previews option at the bottom of the deck to display the style names as
examples of their formatting.

Styles »

Update Selected style
Load Styles

Fill Format Mode

_| New Style from Selection

Character Styles .

Frame Styles
Page Styles

List Styles

Header
Shows Previews
Al seyles |

Table Styles

Hierarchical

Lizd Styfes

[nides 5tyles
Special Soyles
HTMIL Styles
Conditional Siyles

Figure 168: The Styles deck, showing paragraph styles and filter

Filtering the visible styles

At the bottom of the Styles deck, use the drop-down menu to select a filter for the list of styles.
Normally, you will need only a few styles in any document, so it's useful to have only these styles
shown.

At the beginning of the writing process, you may want to have access to all the available styles
(by selecting All Styles), and then hide some of them (Ctrl+click to select each style to be
excluded and finally right-click one of these styles and select Hide in the context menu). As the
document develops, it is quicker to reduce the list displayed to only the styles already in use (by
selecting Applied Styles). If you work on a document where you want to apply custom styles
only, select instead Custom Styles. The Hierarchical view is most useful when modifying styles
as it reveals which styles are linked together. This topic is discussed in Chapter 9, Working with
Styles.

In the Paragraph Styles view, the drop-down menu contains several more filtering options so
you can view, for example, only Text Styles, Special Styles, and so on.

Applying styles

Styles can be applied easily using the Styles deck on the Sidebar. In addition, you can apply
certain styles using other methods, as explained in this section.

Applying paragraph styles

Paragraph styles can be applied in several ways:

» Paragraph Styles tab of the Styles deck on the Sidebar
* Styles menu on the Menu Bar (limited to common styles)
* Right-click context menu (limited)
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» Set Paragraph Style drop-down list at the left end of the Formatting toolbar and the
Formatting (Styles) toolbar

» Set Paragraph Style drop-down list at the top of the Properties deck of the Sidebar
* Formatting (Styles) toolbar (Figure 172); limited to common styles

* Fill Format Mode icon on the Styles deck on the Sidebar

» Keyboard shortcuts Ctri+1 to Ctrl+5 (Heading 1 to Heading 5)

Using the Styles deck on the Sidebar

Put the cursor in the paragraph and double-click the name of the style in the Paragraph Styles
tab of the Styles deck on the Sidebar. You can select more than one paragraph and apply the
same style to all of them at the same time.

Using the Styles menu

The Styles menu on the Menu bar (Figure 169) provides the most commonly used paragraph,
character, and list styles, plus quick links to create, edit, and manage styles. You can add styles
to the Styles menu; see Chapter 20, Customizing Writer. To apply a paragraph style, put the
cursor in the paragraph and click Styles > [name of paragraph style] on the Menu bar. The
other choices on this menu are described later in this chapter.

Styles Table Form Jools Window  He

Ly Text Body Ctrl=+0
T. Title

T= subtitle

H:. Heading1 Cirl+1
H: Heading2 Cirl+2
H: Heading3 Cirl+3

33 Quotations
<f9 Preformatted Text

h Default Character
E Emphasis

S Strong Emphasis
QO  Cuotation

<%  Source Text

s— Mo List Ctrl+5Shift+F12
-— Bullet - List Style

3= Mumbering 123 List Style

g=— MNumbering ABC List Style

= MNumbering abc List Style

= MNumbering VX List Style

i— Mumbering ivx List Style

A Edit Syle...

}'-::J. Update Selected Style Cirl+Shift+F11
A

New Style from Selection  Shift+F11
Load Styles from Template

,lg‘&' Manage Styles F11

Figure 169: The Styles menu
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Using the context (right-click) menu

Right-click anywhere in a paragraph to open the context menu. Choose Paragraph. The
submenu (Figure 170) includes some commonly used paragraph styles. You can add paragraph
styles to this submenu; see Chapter 20, Customizing Writer.

k:tuln in tha Paranranh Qty|es
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1§ Preformatted Text
Synonyms >
Edit Style...

Page Style...

Figure 170: Context menu, Paragraph submenu

Using the Set Paragraph Style list

When a paragraph style is in use in a document, the style name appears on the Set Paragraph
Style list near the left end of the Formatting toolbar (see Figure 171), the Formatting (Styles)
toolbar, and the top of the Properties deck on the Sidebar.
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23

Contents 1

Contents 2

24

Figure 171: The Set Paragraph
Style list on the Formatting bar

To apply a style from this list, put the cursor in the paragraph to change, and then click the arrow
to drop down the list of styles and click the desired style; or drop down the list and use the up or
down arrow keys to move through the list, then press Enter to apply the highlighted style.

OTip

If the Sidebar Styles deck is not open, you can select Manage Styles at the bottom
of the list to open it.
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Using the Formatting (Styles) toolbar

The Formatting (Styles) toolbar (Figure 172) includes common paragraph, character, and list
styles. If it not visible, use View > Toolbars > Formatting (Styles) on the Menu bar to display it.

To apply a paragraph style, put the cursor in the paragraph and click the relevant button on the
toolbar. You can add styles to the this toolbar; see Chapter 20, Customizing Writer.

Farmatting (Styles) ¥ X
Ay Figure BY YA € HHHWEA Q< E S <> S EEIEEE
Figure 172: Formatting (Styles) toolbar

Using Fill Format Mode

You can use Fill Format Mode to apply a style to many areas quickly without having to go back to
the Styles deck and double-click each time. This method is useful for formatting scattered
paragraphs, words, or other items with the same style, and it may be easier to use than making
multiple selections first and then applying a style to all of them.

1) Open the Styles deck on the Sidebar (Figure 168) and select a style.
2) Select a style to copy, and then click the Fill Format Mode icon.

3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page,
or frame and click. To apply a character style, hold down the mouse button while selecting
the characters. Clicking on a word applies the character style to that word.

4) Repeat step 3 until you have made all the changes for that style.
5) To quit Fill Format mode, click the icon again or press the Esc key.

Using keyboard shortcuts

Some keyboard shortcuts for applying styles are predefined. For example, Ctrl+0 applies the Text
body style, Ctrl+1 applies the Heading 1 style, and Ctrl+2 applies the Heading 2 style. You can
modify these shortcuts and create your own; see Chapter 21, Customizing Writer, for instructions.

Applying character styles

To apply a character style, select the characters or words and apply the character style from any
of the following:

» Styles menu on the Menu bar (limited)

* Character Styles tab of the Styles deck on the Sidebar
* Right-click context menu (limited)

* Formatting (Styles) toolbar (Figure 172)

ﬂTip

You may need to remove direct formatting before applying character styles. Select
the text, then choose Format > Clear Direct Formatting on the Menu bar, or right-
click and choose Clear Direct Formatting from the context menu, or press Ctrl+M.

Using the Styles menu

The Styles menu on the Menu bar (Figure 169) provides the most commonly used paragraph,
character, and list styles, plus quick links to create and edit styles. To apply a character style,
select the characters and click Styles > [name of character style]. You can add styles to the
Styles menu; see Chapter 20, Customizing Writer.
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Using the Styles deck on the Sidebar
Open the Styles deck and click the Character Styles icon at the top. The list of available
character styles is displayed. To apply a character style:
1) Select the block of text, or put the cursor into the single word, where you wish to apply the
style.
2) Double-click the appropriate character style on the Styles deck.

Note

To apply a character style to more than a single word, you need to select all of the
text to be changed. To apply the style to a single word, you only have to place the
cursor in the word. In contrast, paragraph styles are applied to the whole of the
paragraph in which the cursor is placed.

Using the context (right-click) menu

Select the block of text, or put the cursor into the single word, then right-click to open the context
menu. Choose Character. The submenu (Figure 173) includes some commonly used character
styles. You can add character styles to this submenu; see Chapter 20, Customizing Writer.

T‘_ﬁ, Paste Ctrl+W
7| Paste Special C
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I.V__| Insert Comment Ctrl+Ale+C S Strong Emphasis
Synonyms . Q  Quotation
{[> Source Text

[/3 Page Style... ]

Figure 173: Context menu, Character submenu

Using the Formatting (Styles) toolbar

The Formatting (Styles) toolbar (Figure 172) includes common paragraph, character, and list
styles. If it not visible, use View > Toolbars > Formatting (Styles) on the Menu bar to display it.

To apply a character style, select the text or put the cursor in a word and click the relevant icon
on the toolbar. You can add styles to the this toolbar; see Chapter 20, Customizing Writer.

Removing or replacing character styles

To remove the character style formatting from some text, or change the character style to a
different style, do this:

1) Select the text.
2) On the Styles deck in the Sidebar, click the Character Styles icon in the top bar.

3) Double-click the required character style, or double-click No Character Style to remove
the character style.
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Applying frame styles

When you insert an object (such as a graphic) into a document, it will automatically have an
invisible frame around it. Some designers like to add frame styles to introduce variety. For
example, you could have one frame style for photographs and a different frame style for other
graphics such as line drawings. The one for photographs might have a border with a drop
shadow, while the one for drawings might have only a border.

To apply a style to a frame:

1) Select the frame.
2) On the Styles deck in the Sidebar, click the Frame Styles icon in the top bar.
3) Double-click the required frame style.

Having applied a style to a frame, you can now modify the frame to be just how you want it. Most
of a frame’s design can be set in a style, but the following options must be set manually:

* Anchoring: how the frame is positioned in relation to the rest of the page’s contents
(Format > Anchor). See Chapter 11, Images and Graphics, for details on anchoring
images, frames, and other objects.

* Arrangement: the frame’s position in a stack of objects (Format > Arrange). See Chapter
11, Images and Graphics, for details on arranging images, frames, and other objects.

* Adding a hyperlink: so that a click on the frame opens a web page or another document
(Insert > Hyperlink).

When a frame is selected, the Frame toolbar replaces the Formatting toolbar, and the right-click
(context) menu has items for anchoring, arrangement, wrap, and alignment.

Applying page styles

Put the cursor anywhere on the page. The applied page style is shown on the Status bar.

l Page 12 of 28 7,238 words, 41,049 characters f P, English (USA)

Figure 174: The current page style is displayed on the status bar

To apply a different style, either right-click the style on the status bar and select a style from the
context menu, or open the Styles deck, select the Page Style icon at the top (fourth icon), and
then double-click the desired page style.

Caution

Changing a page style may also cause the style of subsequent pages to change.
The results may not be what you want. To change the style of only one page, you
may need to insert a manual page break, as described below.

As discussed in Chapter 9, Working with Styles, a correctly set up page style will, in most cases,
contain information on what the page style of the next page should be. For example, when you
apply a Left Page style to a page, you can indicate in the page style settings that the next page
must have a Right Page style; a First Page style could be followed by either a Left Page style or
a Default Page Style; or any sequence you prefer.

Another way to change the page style is to insert a manual page break and specify the style of

the subsequent page. The idea is simple: you break a sequence of page styles and start a new
sequence. To insert a page break, choose Insert > More Breaks > Manual Break. This section
illustrates two common scenarios where page breaks are useful.
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Example: Chapters

A possible scenario: You are writing a book that is divided into chapters. Each chapter starts with
a page style called First Page. The following pages use the Default Page Style. At the end of

each (except the last) chapter, we return to the First Page style for the next chapter.

Figure 175 illustrates the flow of page styles when using page breaks.

First
Page

h

Default

First
Page

.

| |Default

Figure 175: Dividing a document into chapters using page styles

At some point, you will want to start a new chapter. Follow these steps:

1) Putthe cursor at the end of the chapter, on a blank line (empty paragraph) of its own.
2) Choose Insert > More Breaks > Manual Break. The Insert Break dialog (Figure 176)

opens.

3) Under Type, choose Page break and under Style, select First Page.

0Tip

Figure 176: Choose Page break
and select the First Page style
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You can automate these breaks by defining the paragraph style of the chapter’s title

(usually Heading 1) to include a page break.
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Example: Page with special formatting

Sometimes you may need to insert a page with special formatting, for example a landscape page
or a page with more columns. This can also be done with page breaks. Suppose that the current
page has the Default Page Style.

1) Choose Insert > More Breaks > Manual Break.
2) Select the desired page style (say, Special Page) in the Insert Break dialog.

3) Type something on this page. Then insert another page break, selecting Default Page
Style again.

This concept is illustrated in Figure 177.
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Figure 177: Inserting a page with special formatting

Example: A book chapter sequence of pages

Book chapters typically start on a right-hand page, with the first page of the chapter having a
different layout from the rest of the pages. The other pages in the chapter are “mirrored” for
double-sided printing. For example, page numbers in the header or footer may be positioned on
the outside edge of pages and in this instance a wider margin (allowing for binding) is placed on
the inside edge.

Table 5 shows the properties of two page styles (First Page and Default Page Style) set up for a
typical book chapter’s sequence of pages.

Table 5: Properties of customized page styles for a book chapter

Page Style Desired effect Property: setting

First Page First page always on the right

(an odd-numbered page) Page > Page layout > Only right

No header or footer Header > Header on: Not selected

Top margin of page larger than

on other pages Page > Margins > Top: 6.00cm

Default Page  Mirrored margins Page > Page layout: Mirrored
Style

Header with page number in the  Header > Header on: Selected

center of the page Header > Header > Same content
left/right: Selected

Figure 178 illustrates the transitions from the First Page to Default Page Style, with the change of
header between left and right pages shown by the # symbol.

v

2 #
First _| | Default _| | Default
Page *| |Page | | Page

Figure 178: First Page and then the Default page
style with different headers for alternate pages
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Step 1. Set up the First Page style.

1) On the Styles deck, click the Page Styles icon to display a list of page styles.
2) Right-click First Page and select Modify in the context menu.

3) Onthe Organizer tab of the Page Style: First Page dialog, change Next Style to Default
Page Style.

| JoN | Page.Ster: First Page

Page Area Transparency Header Fooler Borders Columns  Footnote

Style
Name: |First Page
Next style: | Default Page Style a Edit Style
nherit from Edit Style

Category: | Custom Styles

Figure 179: Specifying the next style after the first page of a chapter

4) On the Page tab, specify a larger left margin for binding, and a larger top margin to move
the chapter title down the page.

®@ Page Style: First Page

Organizer [ti-88 Area  Transparency Header Footer Borders  Columns  Footnote
Paper Format

Format: A4 a
Width: 21.00em | [Z]
Height: 29.70em | [Z]
Orientation: @ Portrait

Landscape Paper tray: [From printer settings] ﬂ

Margins Layout Settings

Left: 3.00 cm | E’ | Page layout: Only right E
Right: 2.00 cm |i| Page numbers: 1,2, 3, ... <]
Top: 6.50 cm |i| Reference Style 7
Battom: 250 cm Iil Use page line-spacing

Figure 180: Setting page margins and layout for the First Page style
5) On the Header and Footer tabs, be sure the Header on and Footer on options are not
selected. Click OK to save your changes.
Step 2. Set up the Default Page Style.

1) On the Styles deck, in the list of page styles, right-click Default Page Style and select
Modify in the context menu.

2) On the Organizer tab of the Page Style: Default Page Style dialog, be sure Next Style is
set to Default Page Style.

3) On the Page tab of the Page Style: Default Page Style dialog, select Mirrored for Page
layout and set the Inner and Outer margins to the same width as the Left and Right
margins, respectively, on the First Page style.
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| EoN | Page Style: Default Page Style

Organizer [ Area  Transparency Header Footer Borders Columns  Footnote
Paper Format |

Format: Ad E [
Width: 21.00em | [3 f
Height: 29.70em | [3
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Top: 2.00 cm |é| Reference Style
Bottom: 250 em (=] Use page line-spacing

Figure 181: Setting page margins and layout for the Default page style

4) On the Header tab of the Page Style: Default Page Style dialog, select the Header on
and Same content on left and right pages options. Click OK to save your changes.

®® . Page Style: Default P-a;;a Style-
Organizer Page Area  Transparency |gyCEGEIGS Footer  Borders  Columns  Footnote
Header

Header on
Same content on left and right pages

Same content on first page

Left margin: 0.00 cm |':l|
Right margin: 0.00 cm |f|
Spacing: 0.50 cm |5_|

Use dynamic spacing
Height: 050cm [
AutoFit height

More...

Figure 182: Setting up the header properties for the Default page style

Step 3. Set up the Heading 1 paragraph style to start on a new first page.

1) On the Styles deck, on the Paragraph Styles tab, right-click Heading 1 and select Modify.

2) Onthe Text Flow tab of the Paragraph Style dialog, in the Breaks section, select Insert,
With Page Style, and First Page. Click OK to save your changes.
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Paragraph Style: Heading 1
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Figure 183: Setting a paragraph style to start on a page
of a selected style

Step 4. Start a new chapter.
Apply the Heading 1 paragraph style to the first paragraph, which is the title of the chapter.

Note

By default, the Heading 1 paragraph style is assigned to Outline Level 1. The
assignment of paragraph styles to outline levels is done through Tools > Chapter
Numbering.

Step 5. Set up the page headers.

On any Default Page Style page, put the cursor in the header and insert a page number
field (Insert > Page Number).

Applying list styles

List styles define properties such as indentation, numbering style (for example, 1,2,3; a,b,c; or
bullets), and punctuation after the number, but they do not by themselves define properties such
as font, borders, text flow, and so on. The latter are properties of paragraph styles.

Although you can apply list styles using the Styles menu or the Styles deck in the Sidebar, those
methods are not recommended.

Whenever possible, use paragraph styles for creating bulleted and numbered lists. Writer comes
with two sets of paragraph styles for this purpose. It is recommended to use list styles and
paragraph styles together in these ways:

» Use paragraph styles List 1, List 2, List 3, and so on for creating unordered (bulleted)
lists. These styles use Bullet list styles.

* Use paragraph styles Numbering 1, Numbering 2, Numbering 3, etc, for creating ordered
(numbered) lists. These styles use the list styles called Numbering 1, Numbering 2, etc.

Writer has several predefined list styles, which use different bullet symbols or number sequences
(123, abc, ABC, and so on). As with any style, you can redefine the properties of these styles, for
example the numbering or bullet symbol and the indentation. You can also define other list styles
in these series or create your own series. For more information, see Chapter 9, Working with
Styles. Much more information about list styles is in Chapter 12, Lists: Tips and Tricks.

178 | Chapter 8 Introduction to Styles



Applying table styles

Table styles define properties such as the font, paragraph spacing, number of columns, borders,
and background color.

To apply a table style, position the cursor anywhere in the table, go to the Styles deck on the
Sidebar, choose Table Styles, then double-click the name of a style on the list.

See Chapter 13, Tables of Data, for information on creating a table style.

Creating and modifying styles

Writer provides many predefined styles, which are useful when sharing a document to another
machine, especially one with a different language version of LibreOffice, but you may find that
they do not fit your preferences. You can modify the predefined styles or build your own library of
custom styles to use in addition to or in place of the predefined ones.

Note

New styles you create or changes you make to an existing style are available only
within the document they belong to. Styles always stay with a document.

If you want to reuse modified or new styles in other documents, either save the
styles in a template (see Chapter 10, Working with Templates) or copy the styles into
the other documents, as described in “Load Styles (from a template or document)”
on page 180.

Writer offers these mechanisms to modify both predefined and custom (user-created) styles:

* Create or update a style from a selection

* Load or copy styles from another document or template

» Change a style using the Style dialog

* Use AutoUpdate (paragraph and frame styles only)

» Use AutoFormat (table styles only); see Chapter 13, Tables of Data

Using the Styles actions menu

The last icon at the top of the Styles deck, Styles actions, gives access to three functions: New
Style from Selection, Update Selected Style, and Load Styles from Template.

New Style from Selection

Use New Style from Selection to create a new style from the formatting of an item in the current
document. For example, you can change the formatting of a paragraph until it appears as you
like, and then you can turn that formatting into a new style. This procedure can save time
because you do not have to remember all the formatting settings you want, as is necessary when
creating a new style with the Style dialog. In addition, you can immediately see how the item will
look when formatted with the style you are creating.

Follow these steps to create a new style from a selection:

1) In the document, change the formatting of the object (paragraph, frame, and so on) to
your liking. Select the item you want to save as a style.

2) Open the Styles deck in the Sidebar and choose the category of style to create
(paragraph, character, and so on) from the tabs at the top.

3) Click the Styles actions icon, then select New Style from Selection (Figure 184).
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4) The Create Style dialog opens. Type a name for the new style. The list shows the names
of existing custom styles of the selected type, if any. Click OK to save the new style.

 Styles x =
Chvmzz® 8 |Ale
Caption Mew Style from Selection )95?
Update Selected Style
Complimeny Load Styles from Template L
Contents 1 @
Contents 2 D
Contents 3 e

Figure 184: Styles Actions menu in Sidebar
Update Selected Style
Follow these steps to update a paragraph style from a selection:
1) Create a new paragraph (or select an existing paragraph) and edit all the properties you
want to alter in the style, such as indentation, font properties, alignment, and others.
Caution

Make sure that the properties in this paragraph are uniform. For example, if there are
two different font sizes in the paragraph, that property will not be updated.

2) Click anywhere in the paragraph.

3) Onthe Styles deck of the Sidebar, select the style you want to update (single-click, not
double-click) and then click the Styles actions icon and select Update Selected Style.

The procedure to update another category of style (character, page, or frame styles) is the same:

select the item in question, modify it, select the style you want to update, and choose Update
Selected Style from the Styles actions icon.

Load Styles (from a template or document)

The last option under the Styles actions icon is Load Styles from Template, which is used to
copy styles into the current document by loading them from a template or another document.
Using this method, you can copy all styles, or groups of styles, at one time.

1) Open the document to copy styles into.

2) On the Styles deck, click the Styles actions icon and then Load Styles from Template
(Figure 184).

3) On the Load Styles from Template dialog (Figure 185), find and select the template or
document to copy styles from.

4) Click the From File button if the styles you want are contained in a text document rather
than a template. This opens a standard file browser, where you can select the desired
document.

5) Select the options for the types of styles to be copied: Text (Paragraph and Character
styles), Frame, Pages, Numbering (List styles). If you select Overwrite, the styles being
copied will replace any styles of the same names in the target document.

6) Click OK to copy the styles.
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Figure 185: Loading styles from a template

Drag-and-drop a selection to create a style
Another way to create a new style is to drag-and-drop a text selection into the Styles deck.

1) Open the Styles deck on the Sidebar.

2) Select the style category you are going to create (for example a character style) using
one of the icons near the top of the deck.

3) Select the object on which you want to base the style and drag it to the Styles deck. The
cursor changes to indicate whether the operation is possible.

In the Create Style dialog, type a name for the new style and click OK to save the style.

4)
Q Note

You cannot use the drag-and-drop method to create a new page style or table style.

Changing a style using the Style dialog

To change a style (but not a table style) using the Style dialog, right-click the style in the Styles
deck and select Modify in the context menu.

The dialog displayed depends on the type of style selected. Each style’s dialog has several tabs.
The properties on these dialogs are described in Chapter 9, Working with Styles.

See Chapter 13, Tables of Data, for information on changing a table style.

Using AutoUpdate

On the Organizer tab of the Paragraph Style and Frame Style dialogs is an AutoUpdate option
(marked in Figure 186). If this option is selected, then LibreOffice will apply to the style any
modification made manually to a paragraph formatted with that style.

Caution

If you are in the habit of manually overriding styles in your document, be sure that
AutoUpdate is not enabled, or you may suddenly find whole sections of your
document reformatting unexpectedly.
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Paragraph Style: Heading 1 ) 4

Highlighting Tabs Drop Caps Area Transparency Borders Qutline & List
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Name: |Heading
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Figure 186: The Organizer page of the Paragraph Style dialog

Deleting styles

It is not possible to delete LibreOffice’s predefined styles from a document or template, even if
they are not in use. However, custom styles can be deleted.

To delete any unwanted styles using the Styles deck of the Sidebar, select each one to be
deleted (hold Ctrl while selecting multiple styles), and then right-click and select Delete in the
context menu. If the style is in use, a message appears warning you that the style is in use and
asking you to verify that you really want to delete the style.

If the style is not in use, it is deleted immediately without confirmation.

Caution

If you delete a style that is in use, all objects with that style will return to the style it
was based on (inherited from) but may retain some of the deleted style’s formatting
as manual formatting.

eTip

If an unwanted paragraph style is in use, you can use Find and Replace to replace it
with a substitute style before deleting it. See Chapter 3, Working with Text:
Advanced, for more information.

Example: creating and modifying paragraph styles

This section provides an example of a typical use of custom paragraph styles. We will create a
Poem paragraph style and a Poem Header paragraph style, with the following properties:

* Poem: Centered, with a font size of 10pt.
* Poem Heading: Centered, bold, with a 12pt font size.

In addition, a Poem Heading style is to be followed by a Poem style. In other words, when you
press Enter at the end of a paragraph in the Poem Heading paragraph style, the paragraph style
for the next paragraph in the document changes to Poem.

Note

You may have noticed this behavior already. After you enter a heading using a
Heading paragraph style and press Enter, the next style switches to Text body.
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Creating the Poem paragraph style

We will use the Default Paragraph Style as a starting point.
1) On the Styles deck, click the Paragraph Styles icon.
2) Right-click Default Paragraph Style and choose New.

The Paragraph Style dialog opens, with the Organizer tab selected. To create a custom style, you
need to configure the top three entries.

Style fields Description

Name The name of the style itself, like Heading 1 or Text body.
Type the name Poem.

Next Style The style of a paragraph that follows the paragraph that is in Poem
style. When you press Enter while typing text in the Poem style, this
style is automatically applied to the new paragraph.

Set this value to Poem. When you press Enter, the text of the new
paragraph will remain in the Poem style.

Inherit from If the properties of the Poem style are inherited from another style, say
Default Paragraph Style, then any change in Default will affect Poem.
For our example, this is not the behavior we want. Set this entry to
— None —. This means that Poem is not inherited from any other style.

Select the Custom Styles category for new styles. Do not select the AutoUpdate option.
After making these changes, your dialog should look like Figure 187.

Paragraph Style: Untitled1 X

Highlighting Tabs Drop Caps Area Transparency Borders Condition Outline & List
Organizer Indents & Spacing Alignment Text Flow Font Font Effects Position
Style
Name: | Poem
[ AutoUpdate

Mext st,-le'. Posm -v -
Inherit from: |- None - v

Category: |Custom Styles v]

Figure 187: Initial configuration for the Poem style. Set the first three entries as shown.
The next step is to configure the alignment and font properties of this style.
* On the Alignment page, select the Center option.
* Onthe Font page, select the 12pt font size.
Click OK to save the new Poem style.

Creating the Poem Heading style
To create a new Poem Heading style, use the same procedure as above, with these changes:

* Next Style: Select Poem, not Poem Heading. When you press Enter while typing text in
the PoemHeading style, this Poem style is automatically applied to the new paragraph.

* Inherit from: Heading.
The dialog should look like Figure 188.
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Paragraph Style: Untitled1 *

Highlighting Tabs Drop Caps Area Transparency Borders Condition OCutline & List
Organizer Indents & Spacing Alignment Text Flow Font Font Effects Position
Style
Mame: |PoemHeading
O Autolpdate

Next style: [Poem v| | Editstyle
Inherit from: ~|Heading v EditStyle

Category: |Custom Styles ~ |

Figure 188: Settings for the PoemHeading style

Now set the settings of the new style:
1) On the Alignment page, select Center.
2) On the Font page, select Bold and size 14pt.
3) Click OK to save the new PoemHeading style.

Sample poem

It is a good idea to test out your new styles and see if you are happy with them. Typing a poem
using the styles we have just defined should produce the results in Figure 189.

THE OLD SALT

I was walking through the Dockyard in a panic,
When I met a matelot old and grey.

Upon his back he had his kithag and hammock,
And thisis what I heard him =say.

I wonder, ves [ wonder,

Has= the Jaunty made a blunder,
When he served this draft-chit out for me,
For vears I've been a stanchion,

['m the pride of Jago's mansion.

It's a shame to send me off to sea.

Figure 189: Sample poem

Changing the formatting of your styles

One of the main advantages of styles is that they allow the document formatting to be changed
after the content has been written. For example, suppose you have written a 100-page book of
poetry. Then you (or your publisher) decide you don't like the way the poems look.

To learn about reconfiguring styles, we will add an indentation to the Poem style instead of
centering it.

First, set the Poem style to left alignment:

1) Inthe Styles deck, right-click Poem and select Modify.
2) On the Alignment page, select Left.
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Set the indentation:
1) Select the Indents & Spacing tab.
2) Under Indent, set the indentation before the text to 0.5 in.

Click OK, and you should see the text change. The poem should now look similar to Figure 190.
Note in the figure that a third style has been created for the author of the poem.

THE OLD SALT

I was walking through the Dockyard in a panic,
When I met a matelot old and grey.

Upon his back he had his kithag and hammock,
And this iz what [ heard him =ay.

[ wonder, ves I wonder,

Has the Jaunty made a blunder,

When he served this draft-chit out for me,|
For vears ['ve been a stanchion,

I'm the pride of Jago's mansion.

It's a shame to send me off to sea.

John Bush

Figure 190: Final result, using three custom styles

Using paragraph styles to define a hierarchy of headings

Paragraph styles are the key to Writer’s table of contents feature. Tools > Chapter Numbering
defines the hierarchy of headings in a document. The default paragraph styles assigned to
heading levels are the heading styles supplied with Writer: Heading 1, Heading 2, and so on.
However, you can substitute any styles you wish, including custom (user-defined) styles.

The headings defined using the chapter numbering feature can be used for more than the table
of contents (described in Chapter 15, Tables of Contents, Indexes, Bibliographies). For example,
fields are commonly used to display section headings in headers and footers of pages (see
Chapter 17, Fields).

Choosing paragraph styles for heading levels

If you are using the default heading styles for the headings in your outline, and you do not want
to use heading numbering, you do not need to do anything on the Chapter Numbering dialog.
The default outline numbering scheme uses the default heading styles.

To use custom styles in place of one or more of the default heading styles:

1) Choose Tools > Chapter Numbering to open the Chapter Numbering dialog (Figure
191).

2) On the Numbering tab, click the number in the Level box corresponding to the heading for
which you want to change the paragraph style.

3) Inthe Numbering: Paragraph Style section, choose in the drop-down list the paragraph
style you want to assign to that heading level. In this example, you might choose
My Heading 1 to replace Heading 1 and for Level 2, My Heading 2 to replace Heading 2.

4) Repeat for each numbering level that you want to change. Click OK when done.
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@ Chapter Numbering

NURBSHRGN Positon
Level Numbering Preview
1 Number: None My Heading 1
2 ) Heading 2
3 Start at: 1 2] et
4 _ Heading 3
5 Paragraph style: |Heading 2 Heading 4
6 Heading 9 e
7 Character style:  Heading 10 Heading 5
Heading Caution :
g Show sublevels:  Heading Note Heading 6
Heading Tip Heading 7
10 Separator Index i
1-10 Bafore: " Index Heading Heading 8
’ - List Heading 9
~List1 :
After: 1List 2 Heading 10
LOList 1_TextBody
My Heading 1
Help My Heading 2 ~ Cancel _
My Heading 3

Figure 191: Choosing paragraph styles for numbering levels

Assigning outline levels to other styles

In Writer, you can assign an outline level to any paragraph style. This feature enables you to
create a table of contents that includes those headings along with the headings using styles
listed in the Chapter Numbering dialog. For example, you might use a different sequence of
styles for appendixes, but you want the appendix headings and subheadings to appear in the
table of contents at the same levels as the chapter headings and subheadings.

To assign an outline level to a paragraph style, go to the Outline & List tab for the style, and
select the required outline level from the drop-down list. Click OK to save this change.

Outline
Qutline level:
.ﬂ.PPhF List St}t'.e. Text E:I:'Ij}l.
Level 1
List style: Level 2
Level 3

Line Numbering || o2 4

[ Include this pdlevel 5
Level &
Level 7
Start with: Level &
Level 9
Lewel 10

Restart at this

Figure 192: Specifying an outline level for a
paragraph style
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Setting up heading numbering

If you want one or more heading levels to be numbered, many choices are available; this
example defines a scheme to create headings that look like those in the illustration below.

1 This is a Heading 1

1.1 This is a Heading 2. It has far too many words in it, so it wraps
around to the next line.

1.2 Another Heading 2
1.2.1  This is a Heading 3
1.2.2 Another Heading 3
2 Another Heading 1
2.1 Another Heading 2
2.1.1 Another Heading 3
2.2 Another Heading 2

3 Another Heading 1

Figure 193: The numbering scheme to be set up

Use the Numbering tab of the Chapter Numbering dialog to define the numbering scheme and its
appearance. Figure 194 shows the default settings.

] Chapter Numbering
WiliBeig Fosiion
Level Numbering Preview
1| Number None Heading 1
£ | Heading 2
3 Start at: 1 ] eg
4 Heading 3
5 Paragraph style: Heading 1 Heading 4
6
7 Character style:  None Heading 5
8 Show sublevels: (2] Heading 6
9 Heading 7
10 Separator
) Heading 8
L-10 Before: .
Heading 9
After: Heading 10

Figure 194: Default settings on the Chapter Numbering dialog
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1) Inthe Level list, choose 1. In the Number list, choose 1, 2, 3, .... The result is shown in
the preview box on the right in Figure 195.

@& Chapter Numbering
NUGBSERGN Position

Level Numbering Preview
1 Number: [1,2,3, ... k|1 Heading 1
: ~ Heading 2
3 Start at: 1 (2] ol
4 Heading 3
5 Paragraph style: Heading 1 < Heading 4
6 :
7 Character style: |None Heading 5
8 Show sublevels: (2] Heading 6
9 = | Headina 7

Figure 195: Specifying numbering of Level 1 headings

2) Inthe Level list, choose 2. In the Number list, choose 1, 2, 3, .... The Show sublevels field
is now active; it should show 2 (if not, choose 2). The result is shown in Figure 196.

Level Numbering Preview

1 Number: 1.2: 34 1 Heading 1
2 _ -

3 Start at: |1 | A 1.1 Heading 2
4 Heading 3

: Paragraph style: |Heading 2 Heading 4

2 Character style:  |None Heading 5

8 Show sublevels: 2 (2] Heading 6

9 = | Heardinn 7

Figure 196: Specifying numbering of Level 2 headings

3) Inthe Level list, choose 3. In the Number list, choose 1, 2, 3, .... The Show sublevels field
should show 3 (if not, choose 3). The result is shown in Figure 197.

Level Numbering Preview
1 Number: 1,2, 3, .. 1 Heading 1
2 :
3 Start at: 1 | 1.1 Heading 2
4 1.1.1 Heading 3
5 Paragraph style: Heading 3 Heading 4
B .
; Character style:  None Heading 5
B Show sublevels: | B 18 Heading 6
9 = Uandin~ 7

Figure 197: Specifying numbering of Level 3 headings
These choices produce the layout shown in Figure 198.
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1 This-is-a-Heading-11
1'|'

1.1 This-is-a-‘Heading-2.-lt-has-far-too-many-words-in-it,so-it-wraps
around-to-thenextline.y

\fl'
1.1.1 This-is-a-Heading-37

Figure 198: Results of numbering choices for headings

Setting up the indentation of headings

Whether or not the headings are numbered, you may want to change some of their formatting.
For example, you may want the second-level and third-level headings to be indented from the
margin. For numbered headings, you may also want the second line of long headings to line up
with the first word of the heading, not the number. For these changes, use the Position tab of the
Chapter Numbering dialog.

As an example, we will change the position and wrapping of a Heading 2:

1) Inthe Level list on the left, choose 2. Change the values for Numbering followed by, Tab
stop at and Aligned at, as shown in Figure 199. You may want to use a different value.

& Chapter Numbering
Numbering _|RGSHORN
Level Position and Spacing Preview

1 Mumbering alignment: Left B
3 Aligned at: 0.30 cm (2]

! )
4
5 Numbering followed by: | Tab stop B
6 e
7 Tab stop at: 0.80 cm (2]
8 | (~
g Indent at: |0.30 cm | o]
10 Default
1-10 —

Figure 199: Indenting Level 2 headings

This indents the entire heading but does not affect the way long headings wrap around
(Figure 200).

1 This-is-a-Heading-19
-I'|'

1.1 This-is-a-Heading-2.-lt-has-far-too-many-words-init,-so-it-wraps
around-to-the-next-line.y

Figure 200: Result of changes to indentation of Level 2 headings
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2) To change the wrapping behavior of long headings, change Indent at to a larger value, as
shown in Figure 201. The result is shown in Figure 202.

[ ] Chapter Numbering
_Numbering _[SROSORN
Level Position and Spacing Preview
1 Numbering alignment: Left
2
3 Aligned at: 0.30 cm 2]
4
5 Numbering followed by: |Tab stop v
6 —
= Tab stop at: 0.80 cm (o]
g Indent at: 0.80 cm | (2]
10 Default
1-10

Figure 201: Wrapping long headings

1 This-is-a-Heading-11
1'|'

1.1 This-is-a‘-Heading-2.-lt-has-fartoo-many-words-in-it,"so-it-wraps
around-to-the-nextline.y

Figure 202: Result of changing Indent at value
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Introduction

Chapter 8, Introduction to Styles, describes the basics of how to use, apply, and manage styles.
This chapter gives a more detailed description of how to create or modify some styles, using the
many options available on the various tabs of the Style dialog. It explains how these options
affect the appearance of the style and how to use them efficiently.

The Style dialogs share many of the same tabs as the manual formatting dialogs, so this chapter
can also help you apply manual formatting (though you do not need that if you use styles).

Creating custom (nhew) styles

In addition to using the predefined styles provided by LibreOffice, you can add new custom (user-
defined) styles. In Chapter 8, three methods are given for creating a new style: drag-and-drop,
the New Style from Selection icon on the Styles deck, and the Style dialog.

The first two of these methods are convenient because you can check the visual effects that the
style produces before creating it. However, for full control over the style (and its relationship to
other styles), you need to use the Style dialog, as described in this chapter.

Note

Table styles are created in a different way; see Chapter 13, Tables of Data.

Style dialog

Open the Styles deck on the Sidebar. Select the category of style you want to create by clicking
on the appropriate icon on the top part of the Styles deck.

Right-click in the window and select New in the context menu. The dialog that is displayed
depends on the type of style you selected.

ﬂTip

The dialogs used to create a new style and to modify an existing style are mostly the
same, but with one exception: conditional styles have a different dialog. See “Using
conditional paragraph styles” on page 203.

Organizer tab

The Organizer tab, shown in Figure 203, is common to all style categories (except Table styles),
with only small differences between them. Therefore, it is described only once.

Depending on the style you are creating, you will find the following fields on this tab:

* Name: present on all the categories. Use this field to name the style you are creating.

* AutoUpdate: only present for paragraph and frame styles. If this option is selected, then
Writer will apply any manual modification to a paragraph or frame formatted with that
style to the style itself.

Caution

If you are in the habit of manually overriding styles in your document, be sure that
AutoUpdate is not enabled, or you may suddenly find whole sections of your
document reformatted unexpectedly.
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Paragraph Style: Untitled >

Highlighting Tabs Crop Caps Area Transparency Borders Cendition Cutline & List
Organizer Indents & Spacing Alignment Text Flow Font Font Effects Position
Style
[VEL | ntitled
[ AutoU pdate

Mext style: |Untit|ed'| ~ | Edit Style
Inherit from: [Text Body ~| | Editstyle

Categony: |Cu5tu:>m Styles ~ |

Contains

Figure 203: The Organizer tab displayed when a new Paragraph style is created

* Next Style: only available for paragraph and page styles. Use it to specify which style will
be applied to the next element of the same type. For example, a left page style is usually
followed by a right page style, a first page style followed by a left page style, a heading
followed by a text body, and so on.

* Inherit from: available for paragraph, character, and frame styles; it determines the
position of the style in the hierarchy. All the starting properties of the new style are
inherited (copied) from the style specified here; see below for more information.

* Category: available for all styles; use it to associate the new style with one of the
categories. You cannot change the category of the predefined styles. Setting this field is
useful when filtering the contents of the Styles deck.

* Contains: shows a summary of the properties of the style.

- - Headi

Style inheritance 0

When creating a new paragraph style or a new character style, you Heading 1
can use an existing style as a starting point for its settings. In this _
sense, LibreOffice links the styles together. Heading 2

When style settings are inherited, a change in the parent style
affects every style inherited from it. To see the connections between
styles, switch to the Hierarchical view on the Styles deck filter. For Heading 4
example, every Heading style (such as Heading 1, Heading 2) is
inherited from a style called Heading. This relationship is illustrated
in Figure 204. Figure 204: Hierarchical
view of inheritance in styles

Heading 3

Inheritance is a method to create “families” of styles in which you can change their properties
simultaneously. For example, if you decide that all the headings should be green (such as in this
guide), you only need to change the font color of the parent style to achieve the desired result.
However, changes made to a parameter of the parent style do not override changes previously
made to the same parameter in the child styles. For example, if you change the Heading 2 font
color to green, a change of the font color of the Heading style (the parent style) to red will not
affect the Heading 2 font color.

You can easily check which properties are specific to a style by looking at the Contains section of
the Organizer tab. If you want to reset the properties of a child style to that of the parent style,
click the Standard button located at the bottom of each Paragraph and Character style dialog.
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Example: Changing a property of a parent style
Suppose that you want to change the font of not only Heading 1 or Heading 2, but all headings.

Open the Styles deck, select the Paragraph Styles category, right-click Heading, then select
Modify to open the Paragraph Style dialog for the Heading style.

Select the Font tab, then select a font and click OK. Now the fonts of all the heading styles
(Heading 1 through Heading 10) are changed in a single operation.

] [ Paragraph Style: Heading
Highlighting Tabs Drop Caps Area Transparency Borders Qutline & List
Organizer Indents & Spacing Alignment Text Flow Font Font Effects Position
Family: Typeface: Size:
Liberation Sans Regular 14 pt
|Liberation Sans !Regutar !14 pt
|Liberation Sans Narrow | Bold |15 pt |
Liberation Serif Italic |1e pt |
| Linux Biolinum G Bold Italic 118 pt |
|Linux Libertine Display G |20 pt |
|Linux Libertine G izz pt |

Figure 205: Select the Heading font

Working with paragraph styles

Although this section describes most of the parameters scattered over the tabbed pages shown
in Figure 205, you do not need to configure them all. In most cases, you need to modify only a
few attributes, particularly if you link styles or base the new style on a similar one.

Indents & Spacing tab

On the Indents & Spacing tab (Figure 206), you can set up the indentation of the paragraph and
the spacing between lines and between one paragraph and the paragraphs above and below.

Paragraph Style: Untitled1 x

Highlighting Tabs Crop Caps Area Transparency Borders Condition Outline & List

Organizer Indents & Spacing Alignment Text Flow Font Font Effects Position
Indent

Eefore text: o

After text: 0.00cm =

FEirst line: 0.00cm : I

[l Automatic [
Spacing [ ]

Above paragraph: | 0.00cm

1k 4k

Below paragraph: (011 cm
] Do not add space between paragraphs of the same style

Line Spacing

:

[ Activate page line-spacing

Figure 206: Settings on the Indents and Spacing tab of a paragraph style dialog
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Use the Indent section of the tab to set up the indentation, using these parameters:

» Before text: controls the space in the selected unit of measurement between the left
margin of the page and the leftmost part of the paragraph area. Entering a negative value
results in the text starting on the left of the margin. This may be useful in situations where
your left margin is quite wide, but you want the headings to be centered in the page.

» After text: controls the space in the selected unit of measurement between the right
margin of the page and the rightmost part of the paragraph area. Entering a negative
value results in the text extending into the right margin of the page.

» First line: enter the offset in this box (either positive or negative) of the first line of the
paragraph relative to the paragraph area. A positive value increases the indentation of
the first line, while a negative value makes the first line start to the left of the paragraph
area.

* Automatic: select this box to allow Writer to automatically control the indentation of the
first line. The value is calculated by Writer on the basis of the font size and other
parameters.

Use the Spacing section of the page to determine the amount of vertical space above and below
the paragraph. It is customary to include some “space above” in heading styles so that they are
separated from the text body of the previous section without the need to insert empty
paragraphs. Spacing between paragraphs is also normal in certain types of documents. The
body text style of this guide is configured to leave some space between consecutive paragraphs.
You can select the option to remove space between paragraphs of the same style.

Note

An option in Tools > Options > LibreOffice Writer > Compatibility controls
whether space above and space below are added together (the default) or if the
larger space is the only one that applies. See Chapter 20, Customizing Writer, for
more information.

The spacing between paragraphs does not affect the spacing between lines within a paragraph,
which is controlled in the Line spacing section. You can select one of the following values:

* Single: the default setting—applies a single line spacing to the paragraph. This is
calculated automatically based on the font size.

* 1.15 lines: sets the line spacing to 1.15 lines. This small increase often improves the
appearance of text without using a lot of vertical space.

* 1.5 lines: sets the line spacing to 1.5 lines.
* Double: sets the line spacing to 2 lines.

* Proportional: activates the edit box next to the drop-down list where you can enter a
percentage value. 100% means a single line spacing, 200% double line spacing, and so
on.

* At least: this choice activates the edit box next to the drop-down list, where you can
enter the minimum value (in your selected unit of measurement) to be used for the line
spacing.

* Leading: if this is selected, you can control the height of the vertical space between the
base lines of two successive lines of text, by entering a value, which is summed with the
value of single line spacing, into the edit box.

* Fixed: this choice activates the edit box next to the drop-down list, where you can enter
the exact value of the line spacing.
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OTip

When using different font sizes in the same paragraph, the line spacing may be
uneven. To obtain evenly spaced lines, select Fixed or At least in the drop-down list
and a value that is large enough to create a spacing between the lines sufficient to
account for the largest font size used.

The last parameter on this tab is Activate page line-spacing. When Use page line-spacing is
activated for a page style (see “General settings for the page style” on page 207), selecting this
parameter enables page line-spacing for this paragraph style. To exempt the paragraph style
from this feature, deselect this box.

When you enable a paragraph, paragraph style, or page style for page line-spacing, the base
lines of the affected characters are aligned to an invisible vertical page grid, regardless of font
size or of the presence of graphics. This aligns the baseline of each line of text to a vertical
document grid, so that each line is the same height.

Alignment tab

Use the Alignment tab to modify the horizontal alignment of the text, choosing between Left,
Right, Center, and Justified. The results of the selection are shown in a preview window on the
right-hand side of the page.

When selecting Justified alignment, you can also decide how Writer should treat the last line of
the paragraph. By default, Writer aligns the last line to the left (Start), but you can choose to align
it to the center or to justify it (meaning that the words on the last line will be spaced in order to
occupy it fully). If you have selected to justify the last line and select the Expand single word
option, then when the last line of a justified paragraph consists of a single word, this word is
stretched by inserting spaces between characters so that it occupies the full length of the line.

The alignment page is also used to control the Text to Text vertical alignment, useful when you
have mixed font sizes on the same row. Choose the element of the fonts on the line that will be
aligned between Automatic, Base line, Top, Middle, Bottom. Refer to Figure 207 for a visual
representation of these reference points.

SphinX smine Sphinx. Sphinx
Sphinx "™ Sphinx Sphinx
Sphinx seninx Sphinx Sphinx
SphinX sy Sphinx Sphinx

Figure 207: Text to text vertical alignment: Base line, Top, Middle, Bottom

Text flow options for paragraph styles
The Text Flow tab (Figure 208) has three parts: Hyphenation, Breaks, and Options.
With Automatically selected under Hyphenation, three parameters are available:

« Characters at line end: controls the minimum number of characters to be left on a line
before inserting a hyphen.

* Characters at line begin: controls the minimum number of characters that can be
placed at the beginning of a new line following a hyphen.

* Maximum number of consecutive hyphens: controls the number of consecutive lines
that terminate with a hyphen. The typographical standard is 2.
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Paragraph Style: Untitled1 x

Highlighting Tabs Drop Caps Area Transparency Borders Cendition Outline & List
Organizer Indents & Spacing Alignment Text Flow Font Font Effects Position
Hyphenation Breaks
Automatically Insert
[ Don't hyphenate words in CAPS Type: |Page ~ |
2 = Characters at line end Position: |Befc>re ~ |
2 = Characters at line begin Wlthpage |Default Page Style |~ |
0 +| Maximum number of consecutive hyphens U Page number: | c

Options
O Keep with next paragraph
Orphan contral |2 | lines

Widow control 2 = lines

Figure 208: The options on the Text Flow tab of the Paragraph Style dialog

In the Breaks section, you can require a paragraph to start on a new page or column and specify
the position of the break, the style of the new page, and the page number. A typical use for this
option is to start the first page of a new chapter on a new (usually right-hand) page.

To always start a new page with a particular style, choose the following settings:
* In the Breaks section, select Insert. Make sure that Type is set to Page and Position is
set to Before.
* Select With Page Style and choose the page style from the list.

» To continue page numbering from the previous chapter, do not select the Page number
option. To restart each chapter’s page numbering at 1 (a style used in some technical
documents), select Page number and set it to 1.

Note

If you want the first page of a new chapter to always start on a right-hand page,
make sure that the page style for the first chapter page is set for the right page only
by making this selection in the Layout settings field on the Page tab of the Page
Style dialog (see Figure 219 on page 208).

The Options section of the Text Flow tab provides settings to control what happens when a
paragraph does not fit on the bottom of a page:

* Do not split paragraph: If a paragraph does not fit on the bottom of one page, the entire
paragraph moves to the top of the next page. This could cause a large blank space at the
bottom on the page.

+ Keep with next paragraph: Use for headings or the lead-in sentence to a list, to ensure
that it is not the last paragraph on a page.

* Orphan control and Widow control: Widows and orphans are typographic terms. An
orphan is the first line of a paragraph alone at the bottom of a page or column. A widow is
the last line of a paragraph that appears alone at the top of the next page or column. Use
these options to allow paragraphs to split across pages or columns but require at least
two or more lines to remain together at the bottom or top of a page or column. You can
specify how many lines must remain together.
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Font options for the paragraph style

Three tabs of the Paragraph Style dialog are dedicated to settings controlling the appearance of
the typeface: the Font, Font Effects, and Position pages. The first two tabs are straightforward.
Many of the options are the same as those used when creating a character style, as discussed
on page 205. Options that can be used when creating a paragraph style are described here.

Specifying a relative font size

You can specify a fixed font size (in points or other measurement units). In addition, if you are
creating a style based on another style (linked style), you can specify a font size relative to that
other style either as a percentage or as a plus or minus point value (—2pt or +5pt). Relative font
sizes are commonly used for Web pages.

For example, the Heading 1 paragraph style is based on the Heading style. If the font size of the
Heading style is 14pt, and the font size of the Heading 1 style is specified as 130%, the resultant
font size of text in a paragraph formatted with the Heading 1 style is 14pt times 130% = 18.2pt.

To specify a percentage font size: in the Paragraph Style dialog, select the Font tab. In the Size
box, enter the percentage amount followed by the symbol % (Figure 209). Similarly, you can
enter a plus or minus sign followed by the number of points to be added to or subtracted from the
base font size.

To change from a relative font size back to an absolute font size, enter the desired font size in a
specific measurement, such as points (denoted by the letters pt).

[ ] ] Paragraph Style: Heading 1

Highlighting Tabs Drop Caps Area Transparency Borders Outline & List
Organizer Indents & Spacing Alignment Text Flow Font Font Effects Position

Family: Typeface: Size:

Liberation Sans Bold 13094

Liberation Sans Regular 130%

Liberation Sans Narrow Bold 135%

Liberation Serif Italic [140%

Linux Biolinum G Bold Italic |145%

Linux Libertine Display G 150%

Linux Libertine G 155%

Lucida Grande 160%

Luminari |165%

Malayalam MN 170%

Malayalam Sangam MN 175%

Marker Felt |180%

Menlo 185%

Mirrnenaft Came Carif 1 0N0E

Language: English (USA) [~ ] Features...

Figure 209: Selecting a type size based on a percentage

Selecting a language for a paragraph style

The language selected for a document (on Tools > Options > Language Settings >
Languages) determines the dictionary used for spelling, thesaurus, hyphenation, the decimal
and thousands delimiter used, and the default currency format. You can only use a language
whose dictionary is installed.

Within the document, you can apply a separate language to any paragraph style. This setting has
priority over the language of the whole document.

On the Font page of the Paragraph Style dialog, languages with installed dictionaries are marked
in the Language list by a small icon (Figure 210). When checking spelling, Writer will use the
correct dictionary for paragraphs with this style.
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If you write documents in multiple languages, you can use the linked styles to create two
paragraph styles that differ only in the language option. If you then want to change some of the
other properties of the paragraph style, all you need do is to change the parent style.

To insert occasional words in a different language and avoid their being picked by mistake with
the spelling checker, it is more convenient to use a character style, as discussed in “Creating a

new character style” on page 205.

ﬂTip

The selection [None] after Language is useful when a paragraph includes text you
don’t want checked, like URLs and programming code.

Liberation Mono
Liberation Sans
Liberation Sans Narrow
Liberation Serif

Language:  English (USA) [~ |

“% English (USA)
The same for “% English (Zimbabwe)
English, OED spelling (UK}
Erzya
Esperanto
Estanian
Ewé
Faroese —
Fijian
*#% Finnish
Help *% French (Belgium) pply
“% French (Benin) E——

Figure 210: Selecting a language for a paragraph style

Options for positioning text

The Position tab of the Paragraph Style dialog collects all the options that affect the position of
the text on the screen or printed page.

Paragraph Style: Untitled1 =
Highlighting Tabs Crop Caps Area Transparency Borders Condition Cutline 8 List
Crganizer Indents & Spacing Alignment Text Flow Font Font Effects Position

(O Superscript nalsedlower b
(O Subscript Relative font size

4k 4k

Rotation f Scaling
(@) 0 degrees
O 90 degrees Scale width 100% =
(O 270 degrees
Spacing
Character spacing 0.0 pt > Pair kerning

Figure 211: The Position tab of the Paragraph Style dialog

Use the Position section to control the appearance of superscripts and subscripts (characters
above or below the normal line of type, as in H20 or M2). However, you will normally apply
superscript and subscripts to groups of characters rather than to entire paragraphs. Therefore, it
is strongly recommended to change these parameters only when defining a character style and,
instead, leave the default settings for the paragraph styles.
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The second section of the Position tab controls the rotation of the paragraph area. Two common
uses for rotated paragraphs are to put portrait headers and footers on a landscape page and to fit
headings above narrow table columns (as shown in Figure 212).

OTip

Rotated table headings are usually more readable if they are angled, not vertical. To
produce angled text, you need to create a text object from the Drawing toolbar and
rotate it to any angle you wish. See Chapter 11, Images and Graphics.

Another long heading
A rotated heading
Anolher heading
Another heading
Ancther heading
Another heading

Thisis long

Figure 212: A table with rotated headings

The Scale width box controls the percentage of the font width by which to compress or stretch
the rotated text horizontally; that is, from the first character to the last.

Chapter 6, Formatting Pages: Advanced, describes how to create portrait headers and footers on
landscape pages by rotating characters. You can achieve the same effect by defining a separate
header or footer paragraph style specifically for landscape pages.

Example: Rotating the text in a paragraph style
As an example, we will apply rotated table headings to a pre-existing table.

1) Create a new paragraph style. Name it Table Heading Rotated.

2) On the Position tab of the Paragraph Style dialog, in the Rotation / scaling section, select
90 degrees. Click OK to save the new style.

3) Select the heading row of the table and apply the new style. Any text in the cells of the
heading row is now rotated.

4) If the headings are aligned to the top of the cells, you may want to change the alignment
to the bottom of the cells, as shown in Figure 212. To do this, click the Bottom icon on
the Table toolbar or select Format > Alignment > Bottom on the Menu bar.

Spacing options

Use the Spacing section of the Position tab to control the spacing between individual characters
in the paragraph. When selecting an option other than default in the drop-down menu, use the
edit box to enter the value in points by which you want to expand or condense the text.

The Pair kerning option (selected by default) increases or decreases the amount of space
between certain pairs of letters to improve the overall appearance of the text (Figure 213).
Kerning automatically adjusts the character spacing for specific letter combinations. Kerning is
only available for certain font types and, for printed documents, only works if your printer
supports it.
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Figure 213: Kerning disabled (left) and enabled (right)

Controlling tab stops

Although borderless tables are generally considered a much better solution to space out material
across a page, in some situations tabs are sufficient to do what you need, with the added
advantages of being simpler to manage and quicker to apply.

Caution

If you need to use tabs, and you will be sending a document to other people, do not
use the default tab stops. If the recipients of the document have defined default tab
stops that are not the same as the ones you are using, the paragraph may look very
different on their machines. Instead, define the tab stops explicitly in the paragraph
or the paragraph style; then you can be sure that everyone will see the same layout.

To define tab stops in your paragraph style, use the Tabs page, shown in Figure 214. Here you
can choose the type of tab: Left, Right, Centered, or Decimal; the character to be used as a
decimal point; and the Fill Character—the characters that appear between the end of the text
before the tab and the beginning of the text after the tab. You can also create a custom fill
character by entering it in the corresponding box. Common use of a fill character is adding dots
between a heading and a page number in a table of contents or underscore character when
creating a form to fill in.

Paragraph Style: Untitled2 >
Crganizer Indents & Spacing Alignment Text Flow Font Font Effects Position
Highlighting Tabs Crop Caps Area Transparency Borders Condition Outline & List
Paosition Type Fill Character
B.00 cm @) Left . ®) Mone =
300 cm O Ri O E
Right Delete all

6.00 cm - O -

9,00

o O Centered 4 O Delete
O Character
] Decimal A=

Figure 214: Specifying tab stops for a paragraph style

To create a new tab stop, specify its position relative to the left margin, the type of tab, and the fill
character and click the New button. The new tab stop is then listed in the Position box on the left.
To modify the position of a tab stop, create a new one in the desired position and delete the old
one using the buttons on the right-hand side of the page.

It is not possible to define tabs that exceed the page margin. In the rare cases where that may be
needed, use a borderless table instead.
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Outline & List tab

Use the Outline & List tab to assign an outline level to any paragraph style, as described in
“Assigning outline levels to other styles” in Chapter 8, Introduction to Styles. This feature enables
you to create a table of contents that includes those paragraphs along with the headings using
styles listed in Tools > Chapter Numbering.

You can also use this tab to associate a paragraph style with a list style. Refer to Chapter 12,
Lists: Tips and Tricks, for additional information and an example.

Setting up a drop cap

Drop caps (one or more characters in a larger font at the beginning of a paragraph) are generally
suitable only for a first paragraph style. You can predefine the properties in the Drop Caps tab of
the Paragraph Style dialog. Select the Display drop caps option to enable the other choices: the
number of lines occupied, the number of characters to enlarge (if you want the whole first word,
check the corresponding box), and the space between the drop caps and the text.

: S — —
[ ] & Paragraph Style: First Paragraph
Organizer Indents & Spacing Alignment Text Flow Font Font Effects Position
Highlighting Tabs Drop Caps Area Transparency Borders Outline & List
Settings

Display drop caps

Whole word A

Number of characters: L 2
Lines: 3 2
Spacetotext: 0.00ecm o
Contents
Text A

Character style:  [None]

Figure 215: Options for adding a drop cap to the paragraph style

Drop caps use the same font and have the same properties as the rest of the paragraph;
however, you can easily modify their appearance by creating a specific character style and using
it. For example, you may want the drop caps to be of a different color or apply an outline effect.
Select the character style you want to use in the corresponding drop-down menu.

Background (area), highlighting, and transparency

Adding a background color, gradient, pattern, hatching, or bitmap to a paragraph is an alternative
to using a frame. You can customize the background using the Area tab of the Paragraph Style
dialog. The choices are described in “Defining borders and backgrounds” in Chapter 6,
Formatting Pages: Advanced.

e —
@ [ ] Paragraph Style: Code
Organizer Indents & Spacing Alignment Text Flow Font Font Effects Position
Highlighting Tabs Drop Caps Area Transparency Borders Outline & List

None B  Gradient Bitmap Pattern Hatch

Figure 216: Types of fill for paragraph backgrounds

202 | Chapter 9 Working with Styles



You may want to pay attention to the following points when working with the Area tab:

» If you do not find the desired color in the list of predefined ones, you can define your own
as described in Chapter 20, Customizing Writer.

* You can select different backgrounds for the paragraph area and for the text in the
paragraph. Use the Highlighting page for the text. Figure 217 shows the difference.

» The area treatment is applied only to the paragraph area. If you have defined an indented
paragraph, the space between the paragraph and the margin does not have the
paragraph’s background color.

f all the fishes in the sea the mermaid is the one
for me.

ow is the time for all good men to come to the aid
of the party.

Figure 217: Different Area and Highlighting colors

On the Transparency tab, you can choose the transparency options for the selected background.
Values range from 0% (fully opaque) to +100% (fully transparent).

Borders

Borders are often used to set off paragraphs from the text without using a frame, or to separate
header and footer areas from the main text area (such as in this guide), and to provide decorative
elements in some heading styles. Consider the following points:

* Watch out for the effects that the spacing between borders and paragraph area produces
on indentations and tabulations.

» If you want the border to be drawn around multiple paragraphs, leave the Merge with
next paragraph option at the bottom of the page selected.

* Often, white space can have the same effect.
See Chapter 4, Formatting Text, for more about the Borders tab.

Using conditional paragraph styles

Making a paragraph style conditional means it changes its formatting depending on where it is
used. For example, you may want the style MyTextBody to be black by default but turn white
when inside a frame with a blue background.

Probably the most common use for conditional formatting is with single-style outlining. Single-
style outlining is a type of outline humbering designed with a Numbering List Style. Instead of
using different styles for the various outline levels, it changes the number formatting when you
press the Tab key to create a subordinate heading.

The only trouble with single-style outlining is that all levels look the same. This is where a
conditional paragraph style comes in handy. Assign the paragraph style to an outline style in the
Outline & List tab and then open the Condition tab. There, you can assign the levels of the outline
style to other paragraph styles. Then, when you press the Tab key while using the paragraph
style, each level of the outline takes on different formatting, making single-style outlining even
more convenient than it is on its own.

When you create a conditional style, you are saying “in this condition make this style look like
that other style”. For example, “When typing into a footer, make this style look like the my_footer
paragraph style; when typing into a table, make this style look like the table_text paragraph
style”.
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In addition to setting the normal (unconditional) properties of the style, you need to define which
other style it will look like in different situations. To do this, use the Condition tab.

Note

Predefined styles (other than Text body) such as Default, Heading 1, and Heading 2
cannot be set to be conditional.

Caution

If you want to create a new style and make it conditional, you have to do it while the
Paragraph Style dialog is still open for the first time. After the dialog closes, the
Condition tab no longer appears in the dialog when it is reopened.

[ ] [ ] Paragraph Style: Untitled1 h
Organizer Indents & Spacing Alignment Text Flow Font Font Effects Position
Highlighting Tabs Drop Caps Area Transparency Borders Condition Outline & List
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4th Outline Level List 5 End
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8th Outline Level List Indent

9th Qutline Level | Marginalia

10th Outline Level | New Chapter

1st List Level Numbering 1 | Numbering 1
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Figure 218: Condition tab for paragraph styles

To set up a conditional paragraph style:
1) Define a new paragraph style.
2) Select all the paragraph properties for the style. Do not click OK!
3) Click the Condition tab.

4) Select the first condition in the Context list (left side of the dialog) and select the style you
want for this condition in the Paragraph Styles list on the right-hand side.

5) Click Apply. The name of the paragraph style appears in the middle list.
6) Repeat steps 5 and 6 for each condition you want to have linked to a different style.
7) Click OK.
When the style is selected, you will see that the formatting of your text depends on the context.
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Working with character styles

Character styles over-ride the formatting in a paragraph style. They are applied to groups of
characters, such as words or phrases, rather than whole paragraphs. They are mainly used when
you want to change the appearance or attributes of parts of a paragraph without affecting other
parts. Examples of effects that can be obtained by means of character styles are bold or italic
typeface or colored words.

Other ways of using character styles are described elsewhere in this book. These uses include
making chapter numbers, page numbers, or list numbers larger than the surrounding text and
formatting hyperlinks. When you do not want some words (for example, names, or words in a
different language) to be detected as spelling mistakes, you can define the language (if any) to
be applied in the character style’s properties.

Creating a new character style
The tabs of the Character Styles dialog are similar to those for paragraph styles:

* Use the Organizer tab to name the new character style and set up its hierarchical level (if
needed).

» Use the Font tab to choose the font, style, and size for the new character style. You can
specify the font size as a percentage or a point increase or decease in the size of the font
in the paragraph where the character style is applied. You can also specify the language
of the text to which the character style is applied, so you can insert words in a different
language and have their spelling checked using the correct dictionary.

* Use the Font Effects tab to set up attributes such as font color, underlining, relief, or other
effects. If you frequently use hidden text, for example, it may be convenient to define a
character style where the Hidden option is marked. Relief effects may be appropriate for
a drop cap or to give more emphasis to the chapter number or other parts of the title.

» Use the Highlighting tab to apply a colored background to the text. This yields the same
effect as using the Highlight Color tool on the Standard toolbar.

» Use the Borders tab to apply a border and a shadow to the text, if so desired.

» Use the Position tab to create a subscript or superscript in case you are not satisfied with
the default ones or even a sub-subscript which may be useful for certain scientific
publications. In the same tab, you can create rotated, condensed, or expanded text.

Note

When rotating a group of characters, you also need to specify whether the rotated
text should fit in the line or if, instead, it is allowed to expand above and below the
line. This property is active only for character styles.

Working with frame styles

Frames are often used as containers for text or graphics. To provide consistency in the
appearance of frames used for similar purposes, it is a good idea to define styles for frames. For
example, you might want photographs to be enclosed in a frame with a drop-shadowed border,
line drawings in a frame with a plain border, marginal notes in a frame without a border but with a
shaded background, and so on.

Writer provides several predefined frame styles (see Table 6), which you can modify as needed,
and you can define new frame styles. The technique for defining and applying frame styles is
similar to that for other styles.
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OTip

There is considerable overlap between the uses of frames and sections for some
page layout purposes. You may find Chapter 6, Formatting Pages: Advanced, useful
for information about the use of frames and sections.

Table 6: Predefined frame styles and their uses

Style Comments and Use

Formula The frame style used for formulas. The default includes AutoSize, which
adjusts the size of the frame to the formula.

Frame The default frame style.

Graphics The default frame style for graphics. The defaults include AutoSize to fit

the graphic, no text wrap, and a thin border around the frame.

Labels The default frame style for use with File > New > Labels. It seems to be
used by LibreOffice automatically and is not intended for users.

Marginalia A frame style for placing a frame beside the left margin. This style is
intended for comments added in the margin of text. The style also is
useful for creating sideheads—headings against the left margin, which
often are used in technical documentation. An example is given in
Chapter 8, Introduction to Styles.

OLE The default frame style for OLE objects and floating frames. The default
places the frame at the top and center of a body of text.

Watermark The default frame style for a watermark, a graphic placed as the
background to a body of text. The default is a Through wrap, with text
passing over the frame and anything in it. The graphic should be faint
enough that text still is readable over top of it.

How frame styles work

When an object is added to Writer, it is automatically enclosed in a frame of a predetermined
type. The frame sets how the object is placed on the page, as well as how it interacts with other
elements in the document. You can edit the frame by modifying the frame style it uses or by using
a manual override when a frame is added to the document.

Because frames and objects are used together, it is sometimes easy to forget they are separate
elements. In some cases, such as charts, you can edit the frame and object separately.

Unlike other elements that use styles, frames can be defined only partly by their style because
their use can vary so much. Several elements of frames, such as the anchor and protected
elements, need to be defined manually for individual frames.

To format a frame manually, select Insert > Frame on the Menu bar. The dialog that opens
contains all the settings available when frame styles are set up, as well as some that are only
available when the frame is inserted.

Planning the styles

If you are using a mix of graphics, you may want to define two related styles, one with a border
line for graphics with white backgrounds and one without a border for all other backgrounds. You
also may want to design one or more frames for text only.

Otherwise, the default frame styles (listed in Table 6) cover most users’ needs. The only
significant addition that you might need is one or more styles for text frames.
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Creating new frame styles
You can access frame settings by selecting New or Modify in the Styles deck for a frame style.

* Type tab: sets the size and position of the frame. One of the most useful options here is
AutoSize, which automatically adjusts the frame to the object it contains. If the frame
style is used automatically, then this option should be selected.

* Options tab: sets whether the contents of the frame are printed and able to be edited in a
read-only document. This page also sets the text direction, which is useful if you are
using the frame for contents in a language that uses right-to-left text direction.

*  Wrap tab: sets how text is positioned in relation to the frame and how close text comes to
a frame. If you want the frame contents to stand out from the paragraphs around it, set
the wrap to Wrap Off. This probably is the single most important page for frames.

* Area tab: sets the background color, bitmap, hatching, gradient, or pattern. This page is
useful mostly for text frames in complex page layouts, in which a text frame has an
appearance different from the general background of the page.

» Transparency tab: sets the transparency options for the selected background. Values can
range from 0% (fully opaque) to +100% (fully transparent).

* Borders page: sets the attribute for a line around the frame, if any.

* Columns tab: this page can be ignored unless the frame is being used for text. The page
is the same as is used to set up a page style, as described in Chapter 6, Formatting
Pages: Advanced.

* Macro tab: sets a macro to use with the frame in order to trigger an action when the user
interacts with the frame. These options are useful for on-line Writer or HTML documents.

Working with page styles

Page styles control page properties (margins, page size, header and footer, among others).
However, unlike paragraphs, characters, and frames, pages can not have directly applied
properties. If you change the properties of a page, you are actually changing the underlying page
style, so those changes are applied to all pages that use that page style. To change the
properties of individual pages, you need to create a new page style.

Creating a new page style
To create a new page style, open the Styles deck and click the Page Styles icon. Right-click
anywhere in the window and select New. The Page Style dialog contains nine tabs.

Organizer tab
The Organizer tab is described on page 192.

General settings for the page style

The Page tab of the Page Style dialog is where you can control the general settings of the page.
The tab consists of three sections, plus a preview area in the top right.

In the Paper Format section, you can specify the size of the paper, choosing from one of the
many predefined formats, or select User to define your own paper size using the Width and
Height fields. Select the orientation of the paper: Portrait or Landscape. If your printer has more
than one tray, you can specify the tray from which to print pages in the new page style.
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Figure 219: Page tab of Page Style dialog

In the Margins section, specify the size of the margins in your preferred unit of measurement. If
you select Mirrored for Page layout in the Layout settings section, then the names of the margins
change from Left and Right to Inner and Outer. The Gutter margin is the extra space to leave
between the left (or inner) edge of the page and the left (or inner) margin. (Alternatively, you can
leave the Gutter set to zero and add the gutter margin amount to the left or inner margin value.)
See also the Gutter position setting, which can be Left (the default) or Top.

In the Layout Settings section, choose the desired Page layout in the drop-down list. Decide
whether the page style being defined applies to both left and right pages (default), mirrored
pages, or right or left pages only. Some considerations:

« If you plan to bind the printed pages using this style like a book, select a mirrored layout.

* Acommon practice in page layouts is to have asymmetrical page margins—both for left
and right margins and for top and bottom margins. The most common scheme follows
these two general rules for printed page layouts: (a) The outer margin (right margin on a
right-hand page) would be wider than the inner margin (left margin on a right-hand page);
(b) The bottom margin would be larger than the top margin.

* If you want the first page of a new chapter to always start on a right page, make sure that
the page style for the first chapter page is set for the right page only in the Layout
settings field. The typical procedure for the rest of a chapter is to define a single
“mirrored” page style (perhaps, Default Page Style) for both left and right pages. A
mirrored page can have different headers and footers. If done this way, every chapter will
use two page styles.

* You can choose to define separate page styles for left and right pages, if you want the
pages to be very different in appearance (for example, different margins or columns;
imagine a book with a full-page photograph on the left pages and two columns of text on
the right pages). In that case, make sure that the Next Style field for the first page style is
set for a left-only page, which, in turn, is set to be followed by a right-only page style. If
done this way, every chapter will use three page styles. A hypothetical case might have
these page style names: First Page, Left Page, and Right Page.

Use the Page numbers drop-down list to specify the page numbering style to apply to this page
style.
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If you mark the Use page line-spacing box, Writer will align the base lines of text printed on
adjacent columns, opposite pages, and both sides of a sheet of paper to an invisible vertical grid
on the page with a spacing between grid points that depends on the selected Reference Style.

By default, page backgrounds (colors, images, and so on) fill the entire page, including the area
in the margins. If you want the background to fill only the text area, but not the margin area, then
deselect the Background covers margins option in the lower right of the dialog.

Area and Border tabs

The Area and Border tabs are described in detail in Chapter 6, Formatting Pages: Advanced. Use
the Area tab to apply a background (covers the entire page, including the margins) or the Border
tab to draw a border around the text area of the page (inside the margins). You can also add a
shadow to the text area.

Header and Footer tabs

You can associate a different header or footer with each page style. This property makes it easy
to have different headers on left and right pages, to avoid headers on pages at the start of a new
chapter, and so on. You can also have a different header or footer on the same page style where
it is used for the first page of a document.

If you choose a Mirrored or Right and Left page layout on the Page tab, you can specify a
different header for left or right pages even if you use a single style for both. This option is not
available on the predefined Left Page and Right Page page styles or on any other page style
defined to be a left or right page only.

The Header and Footer tabs are described in detail in Chapter 5, Formatting Pages: Basics.
Fage 2 Left Page Header Right Page Header Paged

Figure 220: Different content on left and right pages

Columns tab

Use the Columns tab to create the column layout for the page style. It has three sections:
Settings, Width and Spacing, and Separator Line. Choose the desired number of columns. If you
select more than one column, the Width and Spacing section and the Separator LIne section
become active. You can use the predefined settings (equally spaced columns) or deselect the
AutoWidth option and enter the parameters manually. When you work with multiple columns per
page, you can also fine tune the position and size of a separator line between the columns.

Footnote tab

Use the Footnote tab to adjust the appearance of the footnotes. See Chapter 5, Formatting
Pages: Basics, for detalils.

Working with list styles

List styles work together with paragraph styles. They define indentation, alignment, and the
numbering or bullet characters used for list items. You can define many list styles, from simple
bulleted lists to complex multi-level (nested) lists.

As with other styles, the main reasons for using list styles are consistency and speeding up your
work. Although you can create simple lists quickly by clicking the Toggle Ordered List or Toggle
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Unordered List icons on the Formatting toolbar, and create quite complex nested lists using the
icons on the Bullets and Numbering toolbar, the appearance of the resulting lists may not be what
you want, and you might want to have more than one style of list. You can use the Bullets and
Numbering choice on the Format menu to manually format the appearance of some or all of the
lists, but if you later need to change their appearance, you will have a lot of manual work to do.

See Chapter 12, Lists: Tips and Tricks, for details on how list styles and paragraph styles work
together.

Creating a new list style

The dialog to create a new list style includes six tabs in addition to the usual Organizer tab
discussed on page 192.

Unordered, Ordered, and Image tabs

The Unordered, Ordered, and Image tabs contain predefined formatting for list item symbols
(bullets or numbers). To use one of them for your style, click the image. A thick border indicates
the selection. The bullets on the Bullets tab are font characters; those on the Image tab are
graphics.

Outline tab

Use the Outline tab to select from eight predefined nested lists. You can also select one and use
it as a starting point for your own style, customizing the list using the Position tab and the
Customize tab, as described below.

Position tab

Use the Position tab (Figure 221) to fine tune the indentation and spacing of the list item symbol
and the text of the list item. This tab is particularly effective when used in combination with the
Customize tab.

You can adjust the following settings for each individual level or all levels at once (to make them
all the same).

* Aligned at: the position of the numbering symbol, measured from the left margin of the
page.

* Numbering alignment: Select Left to align the numbering symbol to start directly at the
Aligned at position. Select Right to align the symbol to end directly before the Aligned at
position. Select Centered to center the symbol around the Aligned at position. This option
does not set the alignment of the paragraph, only the numbering symbol.

* Numbering followed by: the character to follow the numbering symbol (plus any
characters—for example a punctuation mark—chosen on the Customize tab to appear
after the number). Choose between a tab stop, a space, or nothing.

* Tab stop at: If you selected the tab stop above, you can specify the position of the tab.

* Indent at: Specify the distance from the left page margin to the start of all lines in the
numbered or bullet paragraph that follow the first line.

OTip

To fully appreciate how the Numbering alignment and other parameters work, try to
create a numbered list with more than ten elements and make sure that enough
room has been made for numbers with two or more digits. You may also wish to
right-align numbers 10 or greater.
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List Style: Untitled?

Organizer Unordered Ordered Outline Image Position Customize

Position and Spacing

Aligned at: =

Mumbering alignment: |Leﬂ ~ |
Mumbering fellowed by: |Tab stop ~ |
Tab stopat | 1.27cm =

Indentat: |1.27cm -

mmqmmhwwi'g
X

Preview
10
1. 1-10
1.
1.
Default
Help Reset Apply OK Cancel

Figure 221: Position settings for a List style

Customize tab

Use the Customize tab (Figure 222) to define the style of the outline levels. The options available
on this tab depend on the type of marker selected for the list. First, on the left side, select the
level you want to modify. To modify all ten levels at once, select 1 — 10 as the level. If you started
from a predefined outline, some of the levels will already have settings.

List Style: Untitled1 >
Organizer Unordered Ordered Outline Image Position Customize
Level Numbering Preview
MNumber |1, 23 . w | 1. S
5 .
3 Startat |1 = 1.
4
Character style: |None ~
: | T
g Show sublevels: |1 = 1
7 Separator 1
8 Bef .
9 Before: 1
10 After;
1-10 1
All Levels 1
[ Consecutive numbering )
"

Figure 222: The Customize tab for a list style
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Depending on the numbering style selected in the Number box (bullet, graphic, numbering),
some of the following options become available on the tab (not all are shown in the illustration):
» Start at: the first value of the list (for example, to start the list at 4 instead of 1).
* Character Style: the style to be used for the number or bullet.

* Show sublevels: The number of previous levels to include in the numbering style. For
example, if you enter "2" and the previous level uses the "A, B, C..." numbering style, the
numbering scheme for the current level becomes: "A.1".

* Separator — Before: any text to appear before the number (for example, Step).

* Separator — After: any text to appear after the number (for example, a punctuation
mark).

« Character Select button: click to select the character for the bullet.

» Graphics Select button: opens a list of available graphics (Gallery) or allows the
selection of a file to be used as the list marker.

* Width and Height: the dimensions of the graphic marker.
* Keep ratio option: fixes the ratio between the width and the height of the graphic marker.
* Alignment: the alignment of the graphic object.

The right-hand side of the dialog shows a preview of the modifications made.

If you choose the Linked graphics option in the Number list, the graphic object is linked rather
than embedded in the document. The bullet will not be displayed when the document is opened
on a different computer (unless the same graphic file is located in the same location on both
computers) or if the graphic file used is moved to a different location on the computer.

To revert to the default values, click the Reset button in the bottom right corner. Finally, if you
wish to use consecutive numbers regardless of the outline level, select the Consecutive
numbering box at the bottom of the tab.

Using the Style Inspector

The Style Inspector (Figure 223) is located on the Sidebar. It displays all the attributes of the
styles (paragraph and character) and any direct formatting present in the paragraph or word
where the cursor is located. These details can be useful when you are trying to figure out why
some formatting in a document appears to be incorrect or inconsistent.

i Style Inspector ® ol
Properties \Values |
v Paragraph Styles D
» Text Body
v Paragraph Direct Formatting &é’
Para Keep Together true
v Character Styles [
v Strong Emphasis @
Char Font Char Set 76
Char Font Family 5
Char Font Name Liberation Sans
Char Font Pitch 2
Char Faont Style Name Regular
Char Weight bold
Character Direct Formatting

Figure 223: Style Inspector example
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Some features of the Style Inspector are of interest mainly to advanced users:

* The Style Inspector can show any hidden RDF (Resource Description Framework, a
W3C standard) metatdata at the cursor position associated with text spans, paragraphs,
and bookmarks. For annotated text spans, “Nested Text Content” item can show the
boundary of the nested annotated text ranges and metadata fields.

« Custom color metadata field shadings can be set for an annotated text range or a
metadata field, for visualization of metadata categories in the document editor. Use View
> Field Shadings or Ctr/+F8 to disable or enable these field shadings.

For more information, see the Release Notes for LibreOffice 7.1 and 7.2 Community:
https://wiki.documentfoundation.org/ReleaseNotes/7.1#Style_inspector
https://wiki.documentfoundation.org/ReleaseNotes/7.2#RDF_metadata_in_Style_Inspector
https://wiki.documentfoundation.org/ReleaseNotes/7.2#Custom_color_metadata_field_shadings
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Introduction

A template is a model document that you use to create other documents. For example, you can
create a template for business reports that has your company’s logo on the first page. New
documents created from this template will all have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set
of styles, and user-specific setup information such as measurement units, language, the default
printer, and toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create, or download and install, as
many templates as you wish, and you can set a default template for each type of document (text,
spreadsheet, drawing, presentation). If you do not choose a template when you start a new
Writer document, then the document is based on the default template for text documents. If you
have not specified a default template, Writer uses the built-in blank template for text documents
that is installed with LibreOffice. See “Setting a default template” on page 221.

In Writer, you can create templates for master documents as well as for ordinary documents.

This chapter describes the use of LibreOffice’s template management features. You can also use
templates in other ways, but the effects are a bit different. See “Other ways to manage
templates” on page 224 for more information.

Creating a document from a template

A new installation of LibreOffice may not include many templates, but you can create your own
(see “Creating a template” on page 217) or install templates obtained from other sources (see
“Adding templates obtained from other sources” on page 218).

To create a document from a template:

1) Open the Templates dialog (Figure 224) using one of these methods:

— Choose File > New > Templates or File > Templates > Manage Templates on the
Menu bar.

— Press the key combination Ctrl+Shift+N.
— Click the arrow next to the New icon on the Standard toolbar and select Templates.

— Select Templates > Manage Templates in the Start Center (visible in LibreOffice
when no document is open).

2) In the Filter lists at the top of the Templates dialog, you can select the type and category
of template you want to use. The relevant templates are listed on the dialog. Click on the
icons to the right of the Categories list to switch between Thumbnail view (Figure 224)
and List view (Figure 225).

3) Find and double-click the required template, or select the template and click Open. A new
document based on the selected template opens in Writer. You can then edit and save
the new document.

The template the document is based on is listed in File > Properties > General.

OTip

In the Start Center, you can click on the Templates button, or open the drop-down
menu and select a type of template, to view the available templates without opening
the Templates dialog. Click on the required template to create a new document.
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Set as Default
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Move [ Export
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[ Import [ | Extensions

C Open |

Figure 224: Thumbnail view of Templates dialog, showing context menu for a

selected template

Figure 225: List view of Templates dialog

Q Note

The connection between a template and a document remains until the template is
modified and you do not update the document to match the template.

If you copy or move the document to a different computer which does not have a
copy of that template installed, the connection is broken even though it continues to
be listed in the document’s properties. See “Changing the template assigned to a
document” on page 220 for a way to reconnect a template to a document.

[ ] ) Templates
Search... Filter Text Dcr:uments All Categories o :

|Name !Calegory !Application |Modified |Size
LibreOffice_7.x_Template My Templates Document 24/06/2021, 16:19 219.8 KB
Modern business letter sans- Business Correspondence Document 22/06/2021, 17:03 10.8 KB
Modern business letter serif Business Correspondence Document 22/06/2021, 17:03 29.9 KB
Businesscard with logo Other Business Document Document 22/06/2021, 17:03 43.0 KB
Cv Personal Correspondence Document 22/06/2021, 17:03 26.1 KB
Resume Personal Correspondence Document 22/06/2021, 17:03 18.9 KB
Default Styles Document 22/06/2021, 17:03 9249 Bytes
Modern Styles Document 22/06/2021, 17:03 7744 Bytes
Simple Styles Document 22/06/2021, 17:03 14.2 KB
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Creating a template

You can create templates in two ways: by saving a document as a template or by using a wizard.

Creating a template from a document

In addition to formatting, any settings that can be added to or modified in a document can be
saved within a template. For example, printer settings; general behaviors set from Tools >
Options, such as paths and colors; menu and toolbar customizations, described in Chapter 20,
Customizing Writer.

Templates can also contain predefined text, saving you from having to type it every time you
create a new document. For example, a letter template may contain your name, address, and
salutation.

To create a template from a document:

1) Open a new or existing text (Writer) document.

2) Add any content that you want to appear in any document you create from the new
template, for example company logo or a copyright statement.

3) Create or modify any styles that you want to use in the new template.

4) On the Menu bar, choose File > Templates > Save as Template. The Save as Template
dialog (Figure 226) opens, displaying the existing categories and a box for the name for
the new template.

5) Select a category, for example My Templates or Business Correspondence. You can also
set this template as a default template at this time. Click Save.

[ ] [ ] Save As Template

Enter Template Name:

| Select Template Category:

None

My Templates

Business Correspondence

draw

Other Business Documents

Personal Correspondence and Documents
Presentations

Styles

Set as default template

Help Cancel Save

Figure 226: Save as Template dialog

Creating a template using a wizard

You can use wizards to create templates for letters, faxes, and agendas. To create a template
using a wizard:

1) On the Menu bar, choose File > Wizards > [type of template required] (Figure 227).

2) Follow the instructions on the pages of the wizard. This process is slightly different for
each type of template, but the format is similar.
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Figure 227: Choosing a template wizard

3) In the last section of the wizard, you can specify the template name that will show in the
Templates dialog and the file name and location for saving the template. The two names
can be different but this may cause confusion. The default location is your user templates
folder but you can choose a different location.

4) To set the file name or change the folder, click the Path icon (the three dots to the right of
the location). On the Save As dialog, make your selections and click Save to return to the
wizard.

5) Finally, you can choose whether to create a new document from the template immediately
or manually change the template. Click Finish to save the template.

Adding templates obtained from other sources

LibreOffice refers to sources of templates as repositories. A repository can be local (a directory
on your computer to which you have downloaded templates) or remote (a URL from which you
can download templates).

To get to the official LibreOffice template repository, type https://extensions.libreoffice.org/ in your
web browser’s address bar or click the Get more extensions online... link in the Extension
Manager, described in Chapter 14, Customizing Writer. This opens the Extensions web page
(Figure 228). In the Search section, click the Templates tag filter. You can narrow your search by
also choosing other tag filters. such as Writer. After setting the filters, click the Search button. In
the search results, find the required template and click on its name to display a page with detalils;
click the Download button to put the template anywhere on your computer. Proceed to “Installing
templates” below.

Extensions

LibreOffice Extensions, Documentation and Templates repository Extensions

What are you looking for?

SEARCH

Add tag filters: Impress (32) ~ Writer (140)  Draw (32)  Calc (116)  Gallery (32)  Dictionary (108)  Color Palette (13)
Documentation (30)  Base (9) Math (5)  Extensions (205)  Education (97)  Business (102)  Presentations (50)  lcons (6)
Fun (47)  Documents (140)  Spreadsheets (137)  Drawings (26)  Database (11)  Templates (418) PDF (1)  Macro (10)

Figure 228: Searching for templates in the repository
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You can also use the Extensions button in the lower left of the Templates dialog, as shown in
Figure 229, to open an Extensions: Templates dialog, where you can scroll through a list of
extensions. In this version of LibreOffice, there is no easy way to filter this list, so you may prefer
to go directly to the web page, as described above.

%23 [ﬁ Import J Extensions

Help cf

Add more templates via extension

Figure 229: Getting more templates for LibreOffice

On other websites, you may find collections of templates that have been packaged into extension
(.OXT) files.

Installing templates
You can install templates using either the Templates dialog or the Extension Manager.
To install templates using the Templates dialog:

1) Download the template or package and save it anywhere on your computer.
2) Inthe Templates dialog, click the Import button on the bottom right (Figure 224).

3) On the Select Category dialog, select the category where you want to import the template
and click OK. A file browser window opens.

4) Find and select the template that you want to import and click Open. The file browser
window closes and the template is imported and appears in the selected category.

To install templates using the Extension Manager:

1) Download the template or package and save it anywhere on your computer.
2) In LibreOffice, select Tools > Extension Manager on the Menu bar. In the Extension
Manager dialog, click Add to open a file browser window.

3) Find and select the template or package of templates you want to install and click Open.
The package begins installing. You may be asked to accept a license agreement.

4) When the package installation is complete, restart LibreOffice. The templates are
available for use through the Templates dialog and the extension is listed in the Extension
Manager.

See Chapter 20, Customizing Writer, for more about the Extension Manager.

ﬂTip

You can manually copy new templates into the template folders. The location varies
with your computer’s operating system. To learn where the template folders are
stored on your computer, go to Tools > Options > LibreOffice > Paths.

Editing a template

You cannot edit a template that was supplied with LibreOffice. You can only edit templates that
you created or imported.

You can edit a template’s styles and content and then, if you wish, reapply the template’s styles
to documents that were created from that template. You cannot reapply content.
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To edit a template:

1) Open the Templates dialog, as described on page 215.

2) Inthe Templates dialog, find the template that you want to edit. Right-click on it to open
the context menu (see Figure 224), then click Edit. The template opens in Writer.

3) Edit the template as you would edit any other document. To save your changes, choose
File > Save on the Menu bar.

Updating a document from a changed template

If you make any changes to a template and its styles, a confirmation message is displayed the
next time you open a document that was created from the template before the changes.

To update the document:

1) Select Update Styles to apply the changed styles in the template to the document.

2) Select Keep Old Styles if you do not want to apply the changed styles in the template to
the document (but see the Caution notice below).

Caution

If you choose Keep Old Styles, the document is no longer connected to the
template, even though the template is still listed under File > Properties > General.
To reconnect the document to the template, use the procedure described in
“Changing the template assigned to a document” below.

Changing the template assignhed to a document

At times you might want to associate a document with a different template, or perhaps you're
working with a document that did not start from a template or one that has become detached
from its template.

You can change the template assigned to a document, or reconnect a document to a template, in
two ways: manually or by using the Template Changer extension to LibreOffice.

* To change or reassign a template manually, first create a new, blank document from the
required template, as described in “Manually changing the template” below. Then copy
the contents of the old document into the new document.

* To use the Template Changer extension, first you need to download and install it, then
restart LibreOffice to activate it. After that, you can open the document and use File >
Templates > Change template (current document) on the Menu bar.

Note

Changing or updating a template affects only the formatting used in styles. It does
not affect any content. You may also need to manually update content, for example a
logo, copyright notice, or the layout of a copyright page.

Manually changing the template

For best results, the names of styles should be the same in the existing document and the new
template. If they are not, you may need to replace old styles with new ones. See Chapter 2,
Working with Text: Basics, for more about replacing styles.

To manually associate a document with a different template:
1) Open the Templates dialog as described on page 215.
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2)
3)

4)
3)
4)

5)

6)
7

In the Templates dialog, double-click the template you want to use. A new document
opens, containing any text or graphics that were in the template.

Delete any unwanted text or graphics from this new document. Use File > Save As to
save the new document, but leave it open.

Open the document you want to change. (It opens in a new window.)
Use Edit > Select All, or press Ctri+A, to select everything in the old document.

Use Edit > Copy, or press Ctrl+C, to copy the contents of the old document to the
clipboard.

Click in the new document created in step 2. Use Edit > Paste, or press Ctrl+V, to paste
the contents of the old document into the new one.

Update the table of contents if there is one. Save the new document using File > Save.
Close the old file without saving.

Caution

Any changes recorded (tracked) in the old document will be lost during this process.
The resulting document will contain only the changed text.

Setting a default template

If you create a document by choosing File > New > Text Document on the Menu bar, or by
clicking the Text Document button in the Start Center, Writer creates the document from the
default template for text documents. You can, however, set a custom template to be the default.
You can reset the default later, if you choose.

Setting a template as the default

Many default settings, such as page size and margins, font choices, line spacing, and so on, can
be changed, but those changes apply only to the document you are working on. To make the
changes the default settings for that document type, you need to replace the default template
supplied with LibreOffice with a new one that you create.

You can set any template in the Templates dialog to be the default for that document type:

1)
2)

3)

Open the Templates dialog as described on page 215.

In the Templates dialog, open the category containing the template that you want to set
as the default, then select the template.

Right-click the selected template and select Set as Default from the context menu
(Figure 224). An icon marks the template as the default (Figure 230).

The next time that you create a document of that type by choosing File > New, the document will
be created from this template.

3 e

LibreOffice_7.x_Template

Figure 230: Default template icon
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Resetting Writer’s default template as the default
To re-enable Writer’s original default template as the default:
1) Open the Templates dialog as described on page 215.
2) Inthe Templates dialog, click the Settings icon on the bottom left (Figure 231).
3) Point to Reset Default Template in the drop-down menu, and click Text Document.

This choice does not appear unless a custom template had been set as the default, as described
in the previous section.

CHE'? I:{'j,l Move

Mew Category
Delete Category

Refresh |____———

Figure 231: Resetting the default template for text documents

You can also reset the default template as follows:

1) Go to the Templates dialog and open the category containing the template you set as
default. It is indicated by a green check mark.

2) Right-click on this template and select Reset Default in the context menu.

The next time that you create a document by choosing File > New, the document will be created
from the original default template for the document type.

Organizing templates

LibreOffice can manage only those templates that are in its template categories, although you
can create a document from a template that is not in one of these folders. You can create new
template categories and use them to organize your templates. For example, you might have one
category for report templates and another for letter templates. You can also import and export
templates.

To begin, choose File > Templates > Manage Templates to open the Templates dialog.

Creating a template category

To create a template category:
1) Click the Settings icon on the lower left of the Templates dialog.
2) Click New category in the context menu (Figure 232).

3) Inthe pop-up dialog, type a name for the new category and click OK. The new category
now appears in the list of categories.

=

Mew Category

Delete Category
Refresh

Figure 232: Creating a new
template category
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Deleting a template category

You cannot delete template categories supplied with LibreOffice. Nor can you delete categories
added by the Extension Manager unless you first remove the extension that installed them.

However, you can delete a category that you created. Open the Templates dialog, click the
Settings icon, and select Delete Category in the pop-up menu (Figure 232). On the Delete
Category dialog, select the category to be deleted and then click OK. When a message box
appears asking you to confirm the deletion, click Yes. If you attempt to delete a supplied
category, you will receive an error message and the category will not be deleted.

Renaming a template category

You cannot rename template categories supplied with LibreOffice. You can only rename
categories that you created.

Open the Templates dialog, select the category in the Filter list at the top, then click the Settings
icon and select Rename Category in the pop-up menu. In the Rename Category dialog, type the
new name and click OK. If you attempt to rename a supplied category, you will receive an error
message and the category will not be renamed.

Moving a template

To move a template from one template category to another, select it in the Templates dialog, and
click the Move icon near the bottom of the dialog (Figure 233). In the Select Category dialog,
select the destination category and click OK. The selected template is moved to the folder. You
can also create a new category into which to move the template.

[ JON ] Select Category
Select from Existing Category

None
My Templates
Business Correspondence
Modern business letter draw
serif LiibreOffice

Other Business Documents
Personal Correspondence and Documer

or Create a New Category

Help Cancel | L. SN

Move Export Import  © | Extensions
i Al L

Cancel Open
Figure 233: Moving templates to another category

Renaming a template

You cannot rename templates supplied with LibreOffice. You can only rename a template that
you have created or imported.

Open the Templates dialog, find and select the template you want to rename, then right-click the
template and select Rename in the context menu. In the small dialog that opens, type a name in
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the Enter New Name text box and click OK. If you attempt to rename a supplied template, you
will receive an error message and the template will not be renamed.

This action changes the Title on the Description tab of the template’s document properties. It
does not change the file name of the template.

Deleting a template

You cannot delete templates supplied with LibreOffice. Nor can you delete any templates
installed by the Extension Manager except by removing the extension that installed them.

However, you can delete templates that you have created or imported:

1) (Optional) In the Filter drop-down lists at the top of the Templates dialog, select the
category that contains the template you want to delete.
2) Select the template to delete.

3) Right-click to open the context menu of the template and click Delete. A message box
appears and asks you to confirm the deletion. Click Yes. If you attempt to delete a
supplied template, you will receive an error message and the template will not be deleted.

OTip

You can also press the Delete key on the keyboard to delete the selected template
on the Templates dialog.

Exporting a template
To export a template to another location on your computer or network:

1) Inthe Templates dialog, select the template that you want to export.

2) Click the Export icon in the bottom right of the dialog. A file browser window opens.

3) Find the location where you want to export the template and select Select Folder or OK.
4) Click OK on the displayed information dialog.

Note

Exporting a template does not remove it from the Templates dialog. The action
places a copy of the template in the location you specify.

Other ways to manage templates

You can create and use templates stored anywhere on your computer, without using the
Templates dialog. However, some results are different from those described earlier in this
chapter.

Creating a document from a template

You can create a document from a template by double-clicking the template in your computer’s
file browser window.

The resulting document is not associated with (linked to) the template from which it was created.
The template is not listed in the document’s properties and any changes to the template cannot
be directly applied to the document. For many purposes, such as writing a letter, this may be
what you want.
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Creating a template from a document

You can create a template from a document using File > Save As and selecting ODF Text
Document Template (.ott) as the file type, then saving it anywhere you want, for example in a
project folder.

The resulting template will not be visible in the Templates dialog, unless you import it or add the
project folder to the locations shown for templates on the LibreOffice — Paths page of the Tools >
Options dialog (see “Paths” in Chapter 2, Setting up LibreOffice, in the Getting Started Guide).
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Introduction

You can add graphic and image files, including photos, drawings, and scanned images, to Writer
documents. Writer can import various vector (line drawing) and raster (bitmap) file formats.

Images in Writer are of these basic types:
* Image files, such as photos, drawings, and scanned images
» Diagrams created using LibreOffice's drawing tools
* Artwork created using clip art or Fontwork
* Charts created using LibreOffice's Calc component

This chapter covers images, diagrams, and artwork. Instructions on how to create charts are
given in Chapter 19, Spreadsheets, Charts, other Objects. For more detailed descriptions on
working with drawing tools, see the Draw Guide. For more about charts, see the Calc Guide.

Creating and editing images

You might create images using a graphics program, scan them, or download them from the
Internet (make sure you have permission to use them), or use photos taken with a digital camera.
Writer can import various vector (line drawing) images, and can rotate and flip such images.
Writer also supports raster (bitmap) file formats, the most common of which are GIF, JPG, PNG,
and BMP. See the Help for a full list.

Writer can also import SmartArt images from Microsoft Office files. For example, Writer can open
a Microsoft Word file that contains SmartArt, and you can use Writer to edit the images.

Some things to consider when choosing or creating images include image quality and whether
the image will be printed in color or black-and-white (grayscale).

To edit photos and other bitmap images, use a bitmap editor. To edit line drawings, use a vector
drawing program. You do not need to buy expensive programs. For many graphics, LibreOffice
Draw is sufficient. Open-source (and usually no-cost) tools such as GIMP (bitmap editor) and
Inkscape (vector drawing program) are excellent. These and many other programs work on
Windows, macOS, and Linux.

For best results:

» Create images that have the exact dimensions required for the document, or use an
appropriate graphics package to scale photographs and large drawings to the required
dimensions. Do not scale images with Writer, even though Writer has tools for doing this,
because the results might not be as clear as you would like.

* Do any other required image manipulation (brightness and contrast, color balance,
cropping, conversion to grayscale, and so on) in a graphics package, not in Writer, even
though Writer has the tools to do a lot of these things, too.

* If the document is meant for screen use only, there is no need to use high resolution
images of 300 or more dpi (dots per inch). Most computer monitors work at between 72
and 96 dpi; reducing the resolution (and the file size) has no negative impact on what is
displayed.

Preparing images for black-and-white printing

If color images are to be printed in grayscale, check that any adjacent colors have good contrast
and print dark enough. Test by printing on a black-and-white printer using a grayscale setting.
Better still: change the “mode” of the image to grayscale, either in a photo editor or in Writer itself
(see “Image mode” on page 241).
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For example, the following diagram looks good in color. The circle is dark red and the square is
dark blue. In grayscale, the difference between the two is not so clear. A third element in the
diagram is a yellow arrow, which is almost invisible in grayscale.

Original drawing in color Drawing printed in grayscale

Changing the colors of the circle and the arrow improves the contrast and visibility of the resulting
grayscale image.

- =

Original drawing in color Drawing printed in grayscale

If the document will be available in black-and-white print only, a better result can often be
obtained by choosing grayscale fills, not color fills.

Adding images to a document

Images can be added to a document in several ways: by inserting an image file stored on your
computer, directly from a graphics program or a scanner, by dragging them from the clip art
internal gallery, or by copying and pasting from a source being viewed on your computer.

Inserting an image file

When the image is in a file stored on the computer, you can insert it into a LibreOffice document
using any of the following methods.

Drag and drop
This method embeds (saves a copy of) the image file in the Writer document. To link the file
instead of embedding it, hold down the Ctrl+Shift keys while dragging the image.

1) Open a file browser window and locate the image you want to insert.

2) Drag the image into the Writer document and drop it where you want it to appear. A faint
vertical line marks where the image will be dropped.

Insert Image dialog
1) Click in the Writer document where you want the image to appear.

2) Choose Insert > Image on the Menu bar or click the Insert Image icon on the Standard
toolbar.

3) Onthe Insert Image dialog, navigate to the file to be inserted, and select it.

4) At the bottom of the dialog (Figure 234) is a Link option; see page 229. Select Preview
to show a thumbnail of the selected image on the right, as in the example. Click Open.
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Figure 234: Insert Image dialog

Note

If you choose the Link option, a message box appears when you click Open. It asks
if you want to embed the image instead. Choose Keep Link if you want the link, or
Embed Graphic if you do not. To prevent this message from appearing again,
deselect the option Ask when linking a graphic at the bottom of the message.

Copy and paste

Using the clipboard, you can copy images into a LibreOffice document from another LibreOffice
document and from other programs. To do this:

1) Open both the source document or program and the target Writer document.

2) In the source document, select the image to be copied.

3) Copy the image to the clipboard.

4) Switch to the target document.

5) Click to place the cursor where the image is to be inserted.

6) Press Ctrl+V (or right-click and select Paste in the context menu, or click the Paste icon

on the Standard toolbar) to insert the image.
Caution

If the application from which the image was copied is closed before the image is
pasted into the target, the image stored on the clipboard could be lost.

Linking an image file

If the Link option in the Insert Image dialog is selected, Writer creates a link to the file containing
the image instead of saving a copy of the image in the document. The result is that the image is
displayed in the document, but when the document is saved, it contains only a reference to the
image file, not the image itself. The document and the image remain as two separate files, and
they are merged together only when you open the document again.
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Linking an image has two advantages and one disadvantage:

Advantage — You can modify the image file separately, and the modified image will
appear when you next open the document. This can be a big advantage if you (or
someone else, perhaps a graphic artist) are updating images.

Advantage — Linking can reduce the size of the document when it is saved, because the
image file itself is not included. However, file size is usually not a problem on a modern
computer, and LibreOffice can handle quite large files.

Disadvantage — If you send the document to someone else, or move it to a different
computer, you must also include the image files, or the recipient will not be able to see
the linked images. You need to keep track of the location of the images and make sure
the recipient knows where to put them, so the document can find them. For example, you
might keep images in a subfolder named Images (under the folder containing the
document); the recipient of the file needs to put the images in a subfolder with the same
name and in the same place relative to the document.

Note

When inserting the same image several times in a document, LibreOffice embeds
only one copy of the image file.

Embedding linked images

If you originally linked the images, you can easily embed one or more of them later if you wish.
1) Open the document in Writer and choose Edit > Links to External Files on the Menu
bar.
2) The Edit Links dialog (Figure 235) shows all the linked files. In the Source file list, select
the files you want to change from linked to embedded.
3) Click the Break Link button and then click Yes to confirm embedding the image.
@ ) Edit Links
Source file Element Type Status
file:/i{Users/.../GallerylconView.png  <All images> Image Manual

Source file file:/{Users/jean/Dropbox/Screenshots/GallerylconView.png
Element:  <Allimages=>

Type: Image
Update: Automatic Manual
Help Modify... Break Link Update
Figure 235: The Edit Links dialog
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Linking an embedded image
To change an image from embedded to linked, follow this procedure:

1) In the Writer document, select the image. Right-click and choose Properties in the
content menu.

2) Inthe Image dialog, go to the Image tab (Figure 236). This field is empty for an
embedded image.

3) Click the Browse button to the right of the Link File name field. A file browser opens. Find
and select the file to be linked, and then click Open. The path to the selected file now
appears in the File name field.

4) Click OK in the Image dialog. The embedded file is now linked.
0O Image

Type  Options Wrap  Hyperlink Image Crop Borders Area  Transparency  Macro
Flip

Vertically = g
Horizontally - :
gon
© On all pages | [;
On left pages (
On right pages -
Link
File name file:/llUsersfjean/Dropbox/Screenshots/GallerylconView.png

Figure 236: Image tab of Image dialog, showing Link file name

Note

To change an image from linked to embedded is not that easy. You have to remove
all linked images and insert them again as embedded.

Inserting an image using a scanner

If a scanner is connected to your computer, Writer can call the scanning application and insert
the scanned item into your document as an image. To start this procedure, choose Insert >
Media > Scan > Select Source on the Menu bar. Select the scan source from the list of
available devices, then click in the document where you want the image to be inserted and
choose Insert > Media > Scan > Request to open the imaging software where you can adjust
settings for image quality, size, and other attributes.

Although this practice is quick and easy, it is unlikely to result in a high-quality image of the
correct size. You may get better results by scanning material into a graphics program and
cleaning it up there before inserting the resulting image into Writer.

Inserting an image from the Gallery

The Gallery (Figure 237) provides a convenient way to group reusable objects such as graphics
and sounds that you can insert into your documents. The Gallery is available in LibreOffice
Writer, Calc, Impress, and Draw. You can copy or link an object from the Gallery into a document.

For more about the Gallery, see Chapter 11, Images and Graphics, in the Getting Started Guide.
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Figure 237: The Gallery in the Sidebar
To insert an object from the Gallery into a document:
1) Click the Gallery icon on the Sidebar.
2) Select a theme in the list provided.
3) Select an object with a single click.

4) Drag and drop the image into the document, or right-click the object and choose Insert in
the context menu.

5) Adjust the size of the image and position and anchor it as needed; see page 232.

Positioning images within the text

When you add an image to a text document, you need to choose how to position it with respect
to the text and other images. Positioning is controlled by four settings:

* Arrangement refers to the placement of an image on an imaginary vertical axis.
Arrangement controls how images are stacked upon each other or relative to the text.

* Alignment refers to the vertical or horizontal placement of an image in relation to the
chosen anchor point.

* Anchoring refers to the reference point for the images. This point could be the page or

frame where the object is, a paragraph, or even a character. An image always has an
anchor point.

+ Text wrapping refers to the relation of images to the surrounding text, which may wrap
around the image on one or both sides, be overprinted behind or in front of the image, or
treat the image as a separate paragraph or character.
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The settings can be accessed in several ways, depending on the nature of the graphic:

In the Format menu: Anchor, Wrap, and Arrange (for images and drawing objects).

In the context menu displayed when you right-click the image; this menu also includes an
Align submenu.

For images, on the Type and Wrap tabs of the Image dialog. You cannot control the
arrangement or alignment using the dialog.

For drawing objects, on the Position and Size tab of the Position and Size dialog. To open
the dialog, right-click the drawing object and choose Position and Size in the context
menu.

For an embedded object (such as a Calc spreadsheet or Draw document), on the OLE-
Object toolbar.

Note

While all the positioning techniques discussed in this section apply equally to frames,
contour wrapping is not possible for frames.

Arranging images

Arranging an image means to determine its position relative to other images or text. Arranging is
only relevant when objects are overlapping. You can choose between four common settings, plus
a fifth special setting for drawing objects:

Bring to Front

Places the image on top of any other images or text.

Forward One

Brings the image one level up in the stack. Depending on the number of overlapping
objects, you may need to apply this option several times to obtain the desired result.

Back One

Sends the image one level down in the object stack.

Send to Back

Sends the image to the bottom of the stack.

To Background / To Foreground

Only available for drawing objects; moves the drawing object behind or in front of the text
respectively.

OTip

To select an object that is covered by other objects, press the Tab key to move
through the objects until you reach the object you want.

Anchoring images

You can anchor images as a character or to a page, paragraph, or character. You can also place
images in a frame and anchor the frame to a page, paragraph, or character. Which method you
choose depends on what you are trying to achieve.

To Page (available only on Image dialog, not the toolbar or context menu)

The image keeps the same position in relation to the page margins. It does not move as
you add or delete text or other images. This method is useful when producing newsletters
or other documents that are very layout intensive, or for placing logos in letterheads.
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To Paragraph
The image is associated with a paragraph and moves with the paragraph. It may be placed
in the margin or another location. This method is useful as an alternative to a table for
placing icons beside paragraphs.

To Character
The image is associated with a character but is not in the text sequence. It moves with the
paragraph but may be placed in the margin or another location. This method is similar to
anchoring to a paragraph.

As Character
The image is placed in the document like any other character and, therefore, affects the
height of the text line and the line break. The image moves with the text as you add or
delete text before the image. This method is useful for keeping screenshots in sequence in
a procedure (by anchoring them as a character in a blank paragraph) or for adding a small
(inline) icon in sequence in a sentence.

To Frame
If the image has been placed in a frame, you can anchor the image in a fixed position
inside the frame. The frame can then be anchored to page, to paragraph, to character, or
as character.

ﬂTip

You can set a default anchor for images in Tools > Options > LibreOffice Writer >
Formatting Aids (Figure 238).

Spaces . Image
Non-breaking spaces Anchor: To Character M
To Paragraph
o - To Character
Breaks ¢-l As Character

Hidden characters

Bookmarks 1]

Figure 238: Choices for setting a default image anchor

Aligning images

After you have established the anchor point of an image, you can decide the position of the
image relative to its anchor: this is called aligning the image. Choose from six options: three for
aligning the image horizontally (left, center, right) and three for aligning the image vertically (top,
middle, bottom). Horizontal alignment is not available for images anchored As Character.

For finer control of the alignment, use the Position options on the Type page of the Image dialog,
shown in Figure 239.

For both the horizontal and vertical position, start by picking the reference point in the right hand
side drop-down menu, then select in the first drop-down menu among Left, Right, or Center for
Horizontal or Top, Bottom, Center for vertical. If you select From left or From top, you can
specify the distance. In the example in Figure 239, the image was anchored To Page; the upper-
left corner of the image will be placed at 5 cm from the left edge of the page text area and 10 cm
from the top edge of the entire page.
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Position
Horizontal From left ﬂ by 5.00cm Ifl to |Page text area ﬁ
Mirror on even pages

Vertical From top ﬁ by | 10.00 cm 1*| to |Entire page ﬁ

Keep inside text boundaries
Figure 239: Fine tuning the alignment

Wrapping text around images

The Wrap setting determines the relation between the text and the image. It is normally selected
after anchoring and alignment of the image. Several choices are available in the context menu,
depending on the anchoring selection, and additional choices (including spacing from text on one
or more sides of the image) are on the Wrap tab of the Image dialog (Figure 240).

None
Places the object on a separate line in the document. The text is placed above and below
the image but not to either side of it.

Parallel
Wraps text on all four sides of the border frame of the object.

Optimal
The text flows around the image. Moving the image around the page causes the text to be
rearranged to fill the space to the left and right of it. Optimal prevents text from being
placed to the side of the image if the spacing between the image and the margin is less
than 2 cm.

Before
Wraps text on the left side of the object if there is enough space.

After
Wraps text on the right side of the object if there is enough space.

Through
Superimposes the image on the text. That is, the image is in front of the text. This option
should be used with an image-transparency setting in order to make the text under the
image visible.

In Background
Similar to Through, but the image is placed behind the text so there may be no need to
change the transparency to make the text visible. Best used only for images without a lot of
contrast or different colors.

Contour
Wraps text around the shape of the object.

Edit Contour
Opens the Contour Editor; see “Editing the contour” on page 236.

First paragraph
Starts a new paragraph after the image even if the text could still wrap around the image.
Note

When anchoring an image as character, you can adjust the distance between the
image and the text, but no wrapping option is available.
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On the Wrap tab of the Image dialog (Figure 240), you can use the Spacing section to adjust the
spacing between the image and the text.

® 0 Image
Type  Options JEA Hyperlink  Image Crop  Borders  Area  Transparency  Macro
Settings
Wrap Off Before After
Parallel Through Optimal
Spacing Options
Left: 000cm |[2] First paragraph
: . In background
Right  0.00cm (2] Haleiind
) Contour
Top: 0.00 em 1] e
~ Outside only
Bottom:  0.00 cm 2] Allow overlap

Figure 240: Options on the Wrap tab of the Image dialog

Editing the contour

If you select Through wrapping and the Contour option for an image, LibreOffice automatically
creates a contour. To edit the contour, right-click the image and select Wrap > Edit Contour in
the context menu, or open the Contour Editor by selecting Format > Wrap > Edit Contour on
the Menu bar.

The dialog shown in Figure 241 opens with the image loaded in the main window. Use the tools
to draw the region of the image you do not want to be covered by the text; this area will be
shaded.

Contour Editor

B LIe® & (< i o

0.00"f0.00" 234 % 2.34"

Figure 241: The Contour Editor

The tools available in the Contour Editor include Rectangle, Ellipse, Polygon, and AutoContour.
Some familiarity with drawing tools is required to create complex contours; however, in most
circumstances there is no need for high accuracy. You can also select the Edit Points button and
adjust the contour shape point by point. See the Draw Guide for details.
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When you are done, click the Apply button to save the contour.

Figure 242 shows the result of contour wrapping and spacing around an image and a drawing
object.

He heard quiet steps behind him. That didn't bode well. Who could be following him this late
atnight and in this deadbeat part of town? And at this particular moment, just after he
pulled off the big fime anc was making off with the greenbacks. Was there

another crook who'd had the same idea, and was now
watching him and waiting for a chance to grab the frint of his
labor? Or did the steps behind him mean that one of many
law officers in town was on 1o him and just
waiting to pounce and snap those cuffs on his
wrists? He nervously looked all around. Suddenly
he saw the alley, Like lightning he = darted off (o the
left and diszappeared between the two warehouses almost falling over the

trash can lying in the middke of the sidewalk. He tried 1o nervously tap his way along in the
inky darkness and suddenly stifened: it was a dead-end, he would have to go back the way
he had come. The steps got louder and louder, he saw the black outling of a figure coming
around the comer. Is this the end of the line? he thouwght pressing himself back against the
wall rying to make himself invisible in the dark, was all that planning and energy wasted? He

Figure 242: Image and drawing objects with contour wrapping

Adding captions to images

You can add captions to images in three ways: automatically, by using the Caption dialog, or
manually.

Adding captions automatically

You can set up LibreOffice to add captions automatically whenever you insert an image, a table,
or other objects into a document. You can choose which objects are captioned automatically,
what the sequence name is for each caption (for example, Table or Figure), and the position of
the caption.

To set up automatic captions, choose Tools > Options > LibreOffice Writer > AutoCaption. At
the right of the dialog, choose which objects you want to be automatically captioned and specify
the characteristics of the captions.

When you insert an image, if automatic captioning is enabled, the image is placed in a frame
along with a caption containing the default sequence name for images. Position the cursor in the
caption area and type the text for the caption. You can change the sequence name by selecting
one in the drop-down Category list or typing in your own.

If you need a sequence name that is not one of the names provided, you can add any custom
name you wish:

1) Open the AutoCaption dialog, as described above.

2) Inthe Add captions automatically when inserting section, select LibreOffice Writer
Image. This activates the Caption area in the dialog for images.

3) Under the Category drop-down list, enter the name that you want added (say, Photo), by
typing it in the box. (Overwriting a term in the box does not delete it from the list.) You can
also set some options for the number style and for a separator between the name and the
number, if desired. Click OK to save the changes.

Adding captions using the Caption dialog

To add captions using the Caption dialog:

1) Insert the image, then either right-click it and select Insert Caption in the context menu,
or select it and choose Insert > Caption on the Menu bar.
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2) Under Properties on the Caption dialog (Figure 243), make your selections for the
Category, Numbering, and Separator fields [lllustration, Arabic (1 2 3), and a colon (),
respectively, for the example in Figure 243] and type your caption text in the Caption box
at the top. The text you enter for the caption appears in the box at the bottom, after the
sequence name, number, and separator.

3) Click OK. The image and its caption are placed in a frame.

ﬂTip

In the Category box, you can type any name you want (for example, Photo) if the
drop-down list does not include it. Writer will create a numbering sequence using that
name, as it does when using the AutoCaption feature.

5] &) Insert Caption
Caption

An example caption for an image]

Properties
Category: Figure
Numbering: Arabic (12 3) ﬁ

Numbering separator:
Separator:

Position: Below E

Preview

Figure 1: An example caption for an image

Help Auto... Options... Cancel ﬁ

Figure 243: Defining the caption for an illustration

Numbering images by chapter

Additional options for numbering captions are available under the Options button in the Captions
dialog (Figure 244). Some of these settings, which refer to the outline level, will have an effect
only if you are using outline level paragraph styles on the chapter headings within your
document.

When chapter numbering is set up, Writer will restart the caption numbering for each chapter it
encounters. For example, if the last figure caption you create in chapter 1 is Figure 1.15, and the
next figure caption you create is in chapter 2, the numbering will start over at Figure 2.1.

Options for chapter numbering of captions are:

* Use Level to specify the outline level that triggers a restart of the numbering as well as
how many levels of outline numbering are shown before the table number. For example,
if the document uses Heading 1 style for chapters and Heading 2 style for sub-headings,
if you want all the tables in a chapter (that is, between two Heading 1 paragraphs) to be
numbered sequentially independently of the sub-heading they are under, select 1 as
Level. If instead you want to restart the numbering at each sub-heading, select level 2.

* Use the Separator field to establish the separator between the chapter number and
figure number.
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» Use Character style to set a character style for the caption. This is useful if the separator
of your choice is not a symbol included in the default font type of your document or if you
want the caption to have a special color, size and so on.

* The Apply border and shadow option does not apply to table captions. LibreOffice
normally wraps the objects you can add a caption to in a frame, but not for tables.

» Use Caption order to specify whether you want the category or numbering to appear
first in the caption.

Caption
& Caption Options
Numbering Captions by Chapter
Froper
Level: | [None] K |
Cate(
Separator:
MNumt
Category and Frame Format .
NUml - character style:  [None] B

Sepa [@ Apply border and shadow

Positi Caption
: Caption order: | Category first
Previey P gory [
l Figy Help L 8K | Cancel

Help OK Cancel Auto... Options...

Figure 244: Options for numbering figures

Adding captions manually

If you save as or export to other formats, you may find that captions applied as described above
(either automatically or using the Caption dialog) are lost during the export.

To avoid export problems, or as another way to put captions above images or below them (the
usual case), you can add a caption manually, in either of two ways:

* Place the image and its caption in separate paragraphs.

* Use atable.

Place the image and its caption in separate paragraphs

Insert the image and anchor it to its paragraph as a character. Press Enter to create a new
paragraph for the caption.

1) Inthe caption paragraph, type, for example, Figure and add a space.

2) To insert the figure number automatically, click Insert > Field > More Fields (Ctr/+F2) and
select the Variables tab.

3) Select Number range in the Type list. Select Figure in the Select list and choose (for
example) Arabic (1 2 3) in the Format drop-down list. Click the Insert button.

4) A number will appear after the word “Figure” in the caption. Now, type the text of the
caption.
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OTip

If you are manually adding captions to a lot of figures using this method, you might
want to make an AutoText entry containing, for example, Figure and a space, the
figure-number field, and an optional separator and a space after it.

To ensure the image and its caption stay together on the page, create a new
paragraph style, for example Figure. If the image is going above the caption, define
the text flow of the Figure paragraph style as Keep with next paragraph and the
next style as Caption. Conversely, if the caption is going above, define the Caption
paragraph style as Keep with next paragraph and the next style as Figure.

Use a table

Create a one-column, two-row table. Place the image in one row and type the caption in the other
row—or use two or more rows for the caption and other text. This method can be especially
useful for images with numbered legends, such as Figure 253 on page 247.

Modifying images

When you insert a new image, you may need to modify it to suit the document. The placement of
the image relative to the text is discussed in “Positioning images within the text” on page 232.
This section describes the use of the Image toolbar, resizing, cropping, and rotating an image.

Writer provides many tools for working with images. These tools are sufficient for most people’s
everyday requirements. However, for professional results it is generally better to use an image
manipulation program such as GIMP to modify images (for example, to crop, resize, rotate, and
change color values) and then insert the result into Writer.

1 2 3 4 56 7 8 9 10
Image v X
"~ Defaul O SAf IO QA

l’l 121314151617 181920 21

Image Filter v ¥

oAV LER/ER

22 23 24
Color X
Boe 0B o QB o
S [JOow [JEH 10 [

25 26 27
1 Filter 10 Color 19  Charcoal Sketch
2 Image Mode 11 Invert 20 Relief
3 Crop Image 12 Smooth 21  Mosaic
4  Flip Vertically 13 Sharpen 22 Color
5  Flip Horizontally 14 Remove Noise 23  Green
6 Rotate 90° Left 15 Solarization 24  Blue
7 Rotate 90° Right 16 Aging 25  Brightness
8 Rotate 17 Posterize 26  Contrast
9 Transparency 18 Pop Art 27 Gamma

Figure 245: Image toolbar plus Color toolbar and Image Filter toolbar

240 | Chapter 11 Images and Graphics



Using the Image toolbar

When you insert an image or select one already present in the document, the Image toolbar
(Figure 245) appears. You can set it to always be present (View > Toolbars > Image) and
choose whether to float or dock it. Two other toolbars can be opened from this one: the Image
Filter toolbar, which can be torn off and placed elsewhere on the window, and the Color toolbar,
which opens as a separate floating toolbar.

From these three toolbars, you can apply small corrections to the image or obtain special effects:
transparency, color adjustment, flipping and rotating, and applying special-effects filters.

Image filters

Table 7 provides a short description of the available filters. The best way to understand them is to
see them in action. Experiment with the different filters and filter settings, remembering that you
can undo all the changes by pressing Ctrl+Z or Alt+Backspace or by selecting Edit > Undo. See
the Draw Guide for more about image filters.

Table 7: Image filters and their effects

Name Effect
Inverts the color values of a color image or the brightness values of a

Invert .
grayscale image.

Smooth Softens the contrast of an image.

Sharpen Increases the contrast of an image.

Remove noise Removes single pixels from an image.

o Mimics the effects of too much light in an image. A further dialog

Solarization -
opens to adjust the parameters.

Agin Simulates the effects of time on an image. Can be applied several

ging times. A further dialog opens to adjust the aging level.

Posterize Makes an image appear like a painting by reducing the number of
colors used.

Pop Art Modifies the image dramatically.

Charcoal Sketch  Displays the image as a charcoal sketch.

A dialog is displayed to adjust the light source that will create the

Relief shadow and, hence, the relief effect.

Mosaic Joins groups of pixels into a single area of one color.

Image mode

You can change color images to grayscale, to black-and-white, or to a watermark by selecting the
image and then selecting the relevant item from the Image Mode list.

Flip vertically, horizontally or in 90° rotations

To flip an image vertically, horizontally, or rotate it by ninety degrees, select the image, and then
click the relevant button on the image toolbar.

Transparency

Increase the percentage value in the Transparency box on the image toolbar to make the image
more transparent. This is particularly useful when creating a watermark or when placing the
image in the background.
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Color

Use this toolbar to modify the individual RGB color components of the image (red, green, blue)
as well as the brightness, contrast, and gamma of the image. If the result is not satisfactory, you
can press Ctrl+Z to restore the default values.

Using the Formatting toolbar and Image dialog

When an image is selected, you can customize some aspects of its appearance using the tools
available on the Formatting toolbar and in the dialog opened by right-clicking on the image and
selecting Properties. You can, for example, create a border around the image, selecting style
and color; or you can (on the Borders tab of the Image dialog) add a shadow to the image.

Cropping images

When you are only interested in a section of the image for the purpose of your document, you
may wish to crop (cut off) parts of it. Writer provides two ways to crop an image: the Crop tool
and the Crop tab of the Image dialog. The Crop tool provides a quick and easy way to crop an
image; but for more control, use the Image dialog.

Q Note

If you crop an image in Writer, the image itself is not changed. Writer hides, not cuts
off, part of the image. If you export the document to HTML, the original image is
exported, not the cropped image. For exporting individual cropped images, see
“Exporting (saving) images” on page 246.

Using the Crop tool

To use the Crop tool, right-click the image and select Crop in the context menu. Cropping
handles appear at the corners and mid-points of the sides of the image (Figure 246). Drag a
handle to cut off part of the image. Click outside the image to turn off cropping mode.
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Figure 246: Cropping handles on an image
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Using the Crop page of the Image dialog
To use the Image dialog, right-click the image and select Properties in the context menu, then
select the Crop tab of the Image dialog (Figure 247).
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Figure 247: Result on image size of cropping using Keep scale option

The units of measurement shown on the Crop tab are those set in Tools > Options >
LibreOffice Writer > General.

Two options are available in the Crop section: Keep scale and Keep image size. Keep scale
maintains the proportions of the image; Keep image size may result in distortion of the image.

As the values for Left, Right, Top, and Bottom are altered, the boundaries of the image in the
preview box change to show the crop area on the image, and the Width and Height fields under
either Scale or Image size. This results in either an image size change (Figure 247), or a scale
change for a fixed image size (Figure 248).

The original image size is indicated to the left of the Original Size button.

[ EoN ] Image

Type Options Wrap  Hyperlink  Image m Bor