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Preface



Who is this book for?

This book is for beginners to advanced user of Calc, the spreadsheet component of LibreOffice. 
You may be new to spreadsheet software, or you may be familiar with another program. If you 
have never used LibreOffice before, or you want an introduction to all of its components, you might
like to read Getting Started with LibreOffice first. If you have never used spreadsheets before, you 
might also like to read a book or find some tutorials about the use of spreadsheets.

What's in this book?

This book introduces the features and functions of LibreOffice Calc. It is not a tutorial on using 
spreadsheets. Some chapters assume familiarity with basic spreadsheet usage when describing 
how to use Calc.

You can enter data (usually numerical) in a spreadsheet and then manipulate this data to produce 
certain results. Alternatively, you can enter data and then use Calc in a ‘What if...’ manner by 
changing some of the data and observing the results without having to retype all of the data. 
Functions can be used to create formulas to perform complex calculations on data.

Some of the other features provided by Calc include:

• Database functions, to arrange, store, and filter data.

• Dynamic charts: a wide range of 2D and 3D charts.

• Macros, for recording and executing repetitive tasks; scripting languages supported include
LibreOffice Basic, Python, BeanShell, and JavaScript.

• Ability to open, edit, and save Microsoft® Excel® and other spreadsheets.

• Import of spreadsheets from multiple formats, including HTML, CSV, and PostScript.

• Export of spreadsheets into multiple formats, including HTML, CSV, and PDF.

Where to get more help

This guide, the other LibreOffice user guides, the built-in Help system, and user support systems 
assume that you are familiar with your computer and basic functions such as starting a program, 
opening and saving files.

Help system
LibreOffice comes with an extensive Help system. This is your first line of support for using 
LibreOffice Calc.

To display the full Help system, press F1 or go to Help > LibreOffice Help on the main menu bar. 
In addition, you can choose whether to activate Tips, Extended tips, and the Help Agent by going 
to Tools > Options > LibreOffice > General on the main menu bar.

If Tips are enabled, place the mouse pointer over any of the icons to see a small box (tooltip) with 
a brief explanation of the icon function. For a more detailed explanation, select Help > What's 
This? On the main menu bar and hold the pointer over the icon.

Free online support
The LibreOffice community not only develops software, but provides free, volunteer-based support.
See Table 1 and this web page: http://www.libreoffice.org/get-help/ 
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Users can get comprehensive online support from the community through mailing lists and the Ask 
LibreOffice website, http://ask.libreoffice.org/en/questions/. Other websites run by users also offer 
free tips and tutorials.

This forum provides community support for LibreOffice: http://en.libreofficeforum.org/

This site provides support for LibreOffice, among other programs: 
http://forum.openoffice.org/en/forum/ 

Table 1: Free support for LibreOffice users

Free LibreOffice support

Ask LibreOffice
Questions and answers from the LibreOffice community
http://ask.libreoffice.org/en/questions/ 

Documentation
User guides, how-tos, and other documentation 
http://www.libreoffice.org/get-help/documentation/
https://wiki.documentfoundation.org/Documentation/Publications 

FAQs
Answers to frequently asked questions
http://wiki.documentfoundation.org/Faq

Mailing lists
Free community support is provided by a network of experienced users
http://www.libreoffice.org/get-help/mailing-lists/

International support

The LibreOffice website in your language
http://www.libreoffice.org/international-sites/

International mailing lists
http://wiki.documentfoundation.org/Local_Mailing_Lists

Accessibility options
Information about available accessibility options 
http://www.libreoffice.org/get-help/accessibility/

Paid support and training

Alternatively, you can pay for support services. Service contracts can be purchased from a vendor 
or consulting firm specializing in LibreOffice.

What you see may be different

Illustrations
LibreOffice runs on Windows, Linux, and Mac OS X operating systems, each of which has several 
versions and can be customized by users (fonts, colors, themes, window managers). The 
illustrations in this guide were taken from a variety of computers and operating systems. Therefore,
some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may be different because of the settings selected in LibreOffice. You can 
either use dialogs from your computer system (default) or dialogs provided by LibreOffice. To 
change to using LibreOffice dialogs:

1) On Linux and Windows operating systems, go to Tools > Options > LibreOffice > 
General on the main menu bar to open the dialog for general options.

On a Mac operating system, go to LibreOffice > Preferences > General on the main 
menu bar to open the dialog for general options.
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2) Select Use LibreOffice dialogs in Open/Save dialogs and, in Linux and Mac OS X operating
systems only, in Print dialogs to display the LibreOffice dialogs on your computer display.

3) Click OK to save your settings and close the dialog.

Icons
The icons used to illustrate some of the many tools available in LibreOffice may differ from the 
ones used in this guide. The icons in this guide have been taken from a LibreOffice installation that
has been set to display the Galaxy set of icons.

If you wish, you can change your LibreOffice software package to display Galaxy icons as follows:

1) On Linux and Windows operating systems, go to Tools > Options > LibreOffice > View on
the main menu bar to open the dialog for view options.

On a Mac operating system, go to LibreOffice > Preferences > View on the main menu 
bar to open the dialog for view options.

2) In User interface > Icon size and style select Galaxy from the options available in the drop-
down list.

3) Click OK to save your settings and close the dialog.

Note

Some Linux operating systems, for example Ubuntu, include LibreOffice as part of 
the installation and may not include the Galaxy set of icons. You should be able to 
download the Galaxy icon set from the software repository for your Linux operating 
system.

Using LibreOffice on a Mac

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options 
menu selection

LibreOffice > Preferences Access setup options

Right-click Control+click or right-click 
depending on computer setup

Open a context menu

Ctrl (Control) ⌘ (Command) Used with other keys

F5 Shift+⌘+F5 Open the Navigator

F11 ⌘+T Open the Styles and Formatting window

What are all these things called?

The terms used in LibreOffice for most parts of the user interface (the parts of the program you see
and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for
most other programs.

A dialog is a special type of window. Its purpose is to inform you of something, or request input 
from you, or both. It provides controls for you to use to specify how to carry out an action. The 
technical names for common controls are shown in Figure 1. In most cases we do not use the 
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technical terms in this book, but it is useful to know them because the Help and other sources of 
information often use them.

Figure 1: Dialog showing common controls

1) Tabbed page (not strictly speaking a control).

2) Radio buttons (only one can be selected at a time).

3) Checkbox (more than one can be selected at a time).

4) Spin box (click the up and down arrows to change the number shown in the text box next to
it, or type in the text box).

5) Thumbnail or preview.

6) Drop-down list from which to select an item.

7) Push buttons.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog 
remains open. When you close the dialog after use (usually, clicking OK or another button saves 
your changes and closes the dialog), then you can again work with your document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog 
and your document. An example of this type is the Find & Replace dialog.

Who wrote this book?

This book was written by volunteers from the LibreOffice community. Profits from sales of the 
printed edition will be used to benefit the community.

Preface 11



Acknowledgements

This book is adapted from OpenOffice.org 3.3 Calc Guide. The contributors to that book are:

Rick Barnes Peter Kupfer Martin Fox
James Andrew Krishna Aradhi Andy Brown
Stephen Buck Bruce Byfield Nicole Cairns
T. J. Frazier Stigant Fyrwitful Ingrid Halama 
Spencer E. Harpe Regina Henschel Peter Hillier-Brook
John Kane Kirk Abbott Emma Kirsopp
Jared Kobos Sigrid Kronenberger Shelagh Manton
Alexandre Martins Kashmira Patel Anthony Petrillo
Andrew Pitonyak Iain Roberts Hazel Russman
Gary Schnabl Rob Scott Jacob Starr
Sowbhagya Sundaresan Nikita Telang Barbara M Tobias
John Viestenz Jean Hollis Weber Stefan Weigel
Sharon Whiston Claire Wood Linda Worthington
Michele Zarri Magnus Adielsson Sandeep Samuel Medikonda

Frequently asked questions

How is LibreOffice licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Lesser General 
Public License (LGPL). The LGPL license is available from the LibreOffice website: 
http://www.libreoffice.org/download/license/ 

May I distribute LibreOffice to anyone?
Yes.

How many computers may I install it on?
As many as you like.

May I sell it?
Yes.

May I use LibreOffice in my business?
Yes.

Is LibreOffice available in my language?
LibreOffice has been translated (localized) into over 40 languages, so your language probably 
is supported. Additionally, there are over 70 spelling, hyphenation, and thesaurus dictionaries 
available for languages and dialects that do not have a localized program interface. The 
dictionaries are available from the LibreOffice website at www.libreoffice.org.

How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you do 
not need to be a programmer. For example, you can help with producing and maintaining 
written user documentation, producing video tutorials, and other user support services. To start,
see http://www.documentfoundation.org/contribution/ 

You can also contribute by donating money, either when downloading the program or at any 
other time. See http://donate.libreoffice.org/ 
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May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement at 
the beginning of this book. You do not have to request special permission. In addition, we 
request that you share with the project some of the profits you make from sales of books, in 
consideration of all the work we have put into producing them.

What's new in LibreOffice Calc 4.0?

General

• Improved performance of ODS (OpenDocument Spreadsheet) document import.

• When opening ODS and XLSX files, the values of formulas can optionally be shown as 
they were saved in the files without recalculating the formula. This option is found in Tools 
> Options > LibreOffice Calc > Formula > Recalculation on file load. This makes 
opening of larger files faster, and showing the values as they were last edited may be an 
advantage when opening spreadsheets saved in Excel.

• Automatically rotate chart axis labels if they are overlapping. This fix also improves 
detection of overlap while rotating labels

• Save settings of Text Import Dialog for Text to Columns and Paste Unformatted Text from 
Clipboard (in addition to Text File Import). 

• Export color scales and data bars to XLSX (also supports Excel 2010+ extensions for 
databars).

• Increased size limit on (uncompressed) ODF documents from 2Gb to 4Gb.

• Support "type-ahead" search in the autofilter popup. It is now possible to search for specific
entry using key input.

• Enhanced chart visualisation: better quality rendering for printing and PDF export of charts.

• New conditional formats: date formats, top/bottom rules, string rules.

• Improved conditional format dialogs.

• Overlapping conditional formats.

• Exporting a single chart as an image (PNG, JPG).

• XML Source dialog to quickly import arbitrary XML content.

Formula engine

• New configuration option to toggle handling of empty strings when used in arithmetic 
expressions.

• New pricing add-In containing spreadsheet functions for option pricing, in particular barrier 
(OPT_BARRIER(...)) and touch (OPT_TOUCH(...)) options.

• New spreadsheet functions XOR, AVERAGEIF, SUMIFS, AVERAGEIFS and COUNTIFS as
defined in ODF OpenFormula.

• Re-implemented RAND() function with better random number generation algorithm.

• New spreadsheet functions IFERROR and IFNA as defined in ODF OpenFormula.

Pivot table

• Support for multiple selections in the page field of a pivot table.
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What's new in LibreOffice Calc 4.1?

General

• Embedding fonts in a Calc spreadsheet.

• Added a stepped lines type to Line and XY (Scatter) graphs.

• Counting the number of selected cells.

Formula engine

• New spreadsheet function NUMBERVALUE as defined in ODF OpenFormula.

• New spreadsheet function SKEWP as defined in ODF OpenFormula.

• Import/export functions new in Excel 2013 for ODF OpenFormula compatibility.

• The following functions are handled, name specialties are given as (in parentheses the 
Calc en-US UI name) [in brackets the ODFF name]

ACOT, ACOTH, ARABIC, BASE, BINOM.DIST.RANGE (B) [BINOM.DIST.RANGE], 
BITAND, BITLSHIFT, BITOR, BITRSHIFT, BITXOR, COMBINA, COT, COTH, CSC, CSCH, 
DAYS, DECIMAL, FORMULATEXT (FORMULA) [FORMULA], GAMMA, GAUSS, IFNA, 
IMCOSH, IMCOT, IMCSC, IMCSCH, IMSEC, IMSECH, IMSINH, IMTAN, ISFORMULA, 
MUNIT, NUMBERVALUE, PDURATION (DURATION) [PDURATION], PERMUTATIONA, 
PHI, RRI, SEC, SECH, SHEET, SHEETS, SKEW.P (SKEWP) [SKEWP], UNICHAR, 
UNICODE, XOR
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Chapter 1  
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What is Calc?

Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a 
spreadsheet and then manipulate this data to produce certain results.

Alternatively, you can enter data and then use Calc in a ‘What if...’ manner by changing some of 
the data and observing the results without having to retype the entire spreadsheet or sheet.

Other features provided by Calc include:

• Functions, which can be used to create formulas to perform complex calculations on data.

• Database functions to arrange, store, and filter data.

• Dynamic charts giving a wide range of 2D and 3D charts.

• Macros for recording and executing repetitive tasks; scripting languages supported include 
LibreOffice Basic, Python, BeanShell, and JavaScript.

• Ability to open, edit, and save Microsoft Excel spreadsheets.

• Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and 
PostScript.

Note

If you want to use macros written in Microsoft Excel using the VBA macro code in 
LibreOffice, you must first edit the code in the LibreOffice Basic IDE editor. For 
more information, see Chapter 12 Calc Macros in this guide or Getting Started 
Guide Chapter 13 Getting Started with Macros.

Spreadsheets, sheets, and cells

Calc works with elements called spreadsheets. Spreadsheets consist of a number of individual
sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by 
its row number and column letter.

Cells hold the individual elements – text, numbers, formulas, and so on – that make up the data to 
display and manipulate.

Each spreadsheet can have many sheets, and each sheet can have many individual cells. In Calc, 
each sheet can have a maximum of 1,048,576 rows and a maximum of 1024 columns.

Calc main dialog

When Calc is started, the main window opens and the various parts of this dialog are explained 
below (Figure 2).

Note

If any part of the Calc window in Figure 2 is not shown, you can display it using the 
View menu. For example, View > Status Bar on the main menu bar will toggle (show
or hide) the Status Bar. It is not always necessary to display all the parts, as shown; 
you can show or hide any of them as desired.

Title bar
The Title bar, located at the top, shows the name of the current spreadsheet. When the 
spreadsheet is newly created, its name is Untitled X, where X is a number. When you save a 
spreadsheet for the first time, you are prompted to enter a name of your choice.
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Figure 2: Calc main dialog

Menu bar
Under the Title bar is the Menu bar. When you choose one of the menus, a sub-menu appears with
other options. You can also modify Menu bar, see Chapter 14 Setting Up and Customizing Calc in 
this guide and Getting Started Guide Chapter 14 Customizing LibreOffice for more information.

• File – contains commands that apply to the entire document; for example Open, Save, 
Wizards, Export as PDF, Print, Digital Signatures and so on.

• Edit – contains commands for editing the document; for example Undo, Copy, Changes, 
Fill, Plug-in and so on.

• View – contains commands for modifying how the Calc user interface looks; for example 
Toolbars, Column & Row Headers, Full Screen, Zoom and so on.

• Insert – contains commands for inserting elements into a spreadsheet; for example Cells, 
Rows, Columns, Sheets, Picture and so on.

• Format – contains commands for modifying the layout of a spreadsheet; for example Cells,
Page, Styles and Formatting, Alignment and so on.

• Tools – contains various functions to help you check and customize your spreadsheet, for 
example Spelling, Share Document, Gallery, Macros and so on.

• Data – contains commands for manipulating data in your spreadsheet; for example Define 
Range, Sort, Consolidate and so on.

• Window – contains commands for the display window; for example New Window, Split and
so on.

• Help – contains links to the help system included with the software and other 
miscellaneous functions; for example Help, License Information, Check for Updates and so 
on.
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Toolbars
The default setting when Calc opens is for the Standard and Formatting toolbars to be docked at 
the top of the workspace (Figure 2).

Calc toolbars can be either docked and fixed in place, or floating allowing you to move a toolbar 
into a more convenient position on your workspace. Docked toolbars can be undocked and moved 
to different docked position on the workspace or undocked to become a floating toolbar. Toolbars 
that are floating when opened can be docked into a fixed position on your workspace.

To display, hide, move, create floating toolbars and for more information on toolbars, see the 
Getting Started Guide Chapter 1 Introducing LibreOffice.

The default set of icons (sometimes called buttons) on toolbars provide a wide range of common 
commands and functions. You can also remove or add icons to toolbars, see the Chapter 14, 
Setting Up and Customizing Calc in this guide and the Getting Started Guide Chapter 14 
Customizing LibreOffice for more information.

Placing the mouse cursor over any of the icons displays a small box called a tooltip. It gives a brief 
explanation of the icon function. For a more detailed explanation, go to Help > What’s This? on 
the main menu bar and hover the mouse pointer over the icon. To close a tooltip, click once away 
from the icon or press the Esc key. Tips and extended tips can be turned on or off from Tools > 
Options > LibreOffice > General on the main menu bar.

Formula Bar
The Formula Bar is located at the top of the sheet in your Calc workspace. The Formula Bar is 
permanently docked in this position and cannot be used as a floating toolbar. If the Formula Bar is 
not visible, go to View > Formula Bar on the main menu bar.

Figure 3: Formula Bar

Going from left to right and referring to Figure 3, the Formula Bar consists of the following:

• Name Box – gives the cell reference using a combination of a letter and number, for 
example A1. The letter indicates the column and the number indicates the row of the 
selected cell.

• Function Wizard  – opens a dialog from which you can search through a list of 
available functions. This can be very useful because it also shows how the functions are 
formatted.

• Sum  – clicking on the Sum icon totals the numbers in the cells above the selected cell 
and then places the total in the selected cell. If there are no numbers above the selected 
cell, then the cells to the left are totaled.

• Function  – clicking on the Function icon inserts an equals (=) sign into the selected cell 
and the Input line allowing a formula to be entered.

• Input line – displays the contents of the selected cell (data, formula, or function) and 
allows you to edit the cell contents. To edit inside the Input line area, click in the area, then 
type your changes. To edit within the current cell, just double-click in the cell.

• You can also edit the contents of a cell directly in the cell itself by double-clicking on the 
cell. When you enter new data into a cell, the Sum and Function icons change to Cancel 

and Accept icons .
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Note
In a spreadsheet the term function covers much more than just mathematical 
functions. See Chapter 7 Using Formulas and Functions in this guide for more 
information.

Spreadsheet layout

Individual cells
The main section of the screen displays the cells in the form of a grid, with each cell being at the 
intersection of a column and a row.

At the top of the columns and the left end of the rows are a series of header boxes containing 
letters and numbers. The column headers use an alpha character starting at A and go on to the 
right. The row headers use a numerical character starting at 1 and go down.

These column and row headers form the cell references that appear in the Name Box on the 
Formula Bar (Figure 3). If the headers are not visible on your spreadsheet, go to View > Column &
Row Headers on the main menu bar.

Sheet tabs
In Calc you can have more than one sheet in a spreadsheet. At the bottom of the grid of cells in a 
spreadsheet are sheet tabs indicating how many sheets there are in your spreadsheet. Clicking on 
a tab enables access to each individual sheet and displays that sheet. An active sheet is indicated 
with a white tab (default Calc setup). You can also select multiple sheet by holding down the Ctrl 
key while you click on the sheet tabs.

To change the default name for a sheet (Sheet1, Sheet2, and so on):

1) Right-click on the sheet tab and select Rename Sheet from the context menu. A dialog 
opens allowing you to type in a new name for the sheet.

2) Click OK when finished to close the dialog.

To change the color of a sheet tab:

1) Right-click on the sheet tab and select Tab Color from the context menu to open the Tab 
Color dialog (Figure 4).

2) Select your color and click OK when finished to close the dialog.

Figure 4: Tab Color dialog
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3) To add new colors to this color palette, see the Getting Started Guide Chapter 14 
Customizing LibreOffice for more information.

Status bar
The Calc status bar (Figure 5) provides information about the spreadsheet and convenient ways to 
quickly change some of its features. Most of the fields are similar to those in other components of 
LibreOffice; see Chapter 1 Introducing LibreOffice in this guide and the Calc Guide Chapter 1 
Introducing Calc for more information.

Figure 5: Calc status bar

The various fields on the Status Bar, from left to right, are as follows.

Sheet sequence number
Shows the sequence number of the current sheet and the total number of sheets in the 
spreadsheet. The sequence number may not be the same as the name on the sheet tab if 
sheets have been moved. Double-click on this zone to open the Navigator.

Page style
Shows the page style of the current sheet. To edit the page style, double-click on this field and 
the Page Style dialog opens.

Insert mode
Shows the type of insert mode the program is in. Press the Ins key to change modes. This field
is blank if the program is in insert mode and Overwrite shows when in overwrite mode.

Selection mode
Click to open a context menu and toggle between Standard selection, Extended selection, 
Adding selection or Block selection. The icon does not change when different selection modes 
are selected, but the tooltip shows the current status.

• Standard selection – click in text or cell where you want to position the cursor and make the
cell active. Any other selection is then deselected.

• Extend selection – clicking in the text either extends or crops the current selection.

• Adding selection – a new selection is added to an existing selection. The result is a multiple
selection.

• Block selection – a block of text can be selected.

Unsaved changes
This icon indicates if there are any unsaved changes that have not been saved. Double-click 
this icon or use File > Save to save the spreadsheet.

Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon to 
view the certificate. See Chapter 6 Printing, Exporting, and E-mailing in this guide for more 
information about digital signatures. A document can only be digitally signed after it has been 
saved.
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Cell or object information
Displays information relevant to the position of the cursor or the selected element of the 
spreadsheet. When a group of cells is selected, the sum of the contents is displayed by default.
Right-click on this field and select other functions, such as the average value, maximum value, 
minimum value, or count (number of items selected).

Zoom slider
Drag the zoom slider, or click the + and – signs to change the view magnification.

Zoom percentage
Indicates the magnification level of the document. Right-click on the percentage figure to open 
a list of magnification values from which to choose. Double-clicking on this percentage figure 
opens the Zoom & View Layout dialog.

Creating, opening and saving spreadsheets

Creating and opening
Creating and opening spreadsheets is identical to creating and opening documents to the other 
modules within LibreOffice. For more information on creating and opening spreadsheets, see the 
Getting Started Guide Chapter 1 Introducing LibreOffice.

Using templates
Calc documents can also be created from templates. For information on how to create and use 
templates, see the Getting Started Guide Chapter 3 Using Styles and Templates and Chapter 4 
Using Styles and Templates in Calc in this guide.

Opening CSV files
Comma-separated-values (CSV) files are spreadsheet files in a text format where cell contents are
separated by a character, for example comma, semi-colon, and so on. Each line in a CSV text file 
represents a row in a spreadsheet. Text is entered between quotation marks; numbers are entered 
without quotation marks.

To open a CSV file in Calc:

1) Choose File > Open on the main menu bar and locate the CSV file that you want to open.

2) Select the file and click Open. By default, a CSV file has the extension .csv. However, 
some CSV files may have a .txt extension.

3) The Text Import dialog (Figure 6) opens allowing you to select the various options 
available when importing a CSV file into a Calc spreadsheet.

4) Click OK to open and import the file.

The various options for importing CSV files into a Calc spreadsheet are as follows:

• Import

– Character Set – specifies the character set to be used in the imported file.

– Language – determines how the number strings are imported. If Language is set to 
Default for CSV import, Calc will use the globally set language. If Language is set to a 
specific language, that language will be used when importing numbers.

– From Row – specifies the row where you want to start the import. The rows are visible 
in the preview window at the bottom of the dialog.
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Figure 6: Text Import dialog

• Separator Options – specifies whether your data uses separators or fixed widths as 
delimiters.

– Fixed width – separates fixed-width data (equal number of characters) into columns. 
Click on the ruler in the preview window to set the width.

– Separated by – select the separator used in your data to delimit the data into columns. 
When you select Other, you specify the character used to separate data into columns. 
This custom separator must also be contained in your data.

– Merge delimiters – combines consecutive delimiters and removes blank data fields.

– Text delimiter – select a character to delimit text data.

• Other options

– Quoted fields as text – when this option is enabled, fields or cells whose values are 
quoted in their entirety (the first and last characters of the value equal the text delimiter)
are imported as text.

– Detect special numbers – when this option is enabled, Calc will automatically detect all 
number formats, including special number formats such as dates, time, and scientific 
notation.

The selected language also influences how such special numbers are detected, since 
different languages and regions many have different conventions for such special 
numbers.

When this option is disabled, Calc will detect and convert only decimal numbers. The 
rest, including numbers formatted in scientific notation, will be imported as text. A 
decimal number string can have digits 0-9, thousands separators, and a decimal 
separator. Thousands separators and decimal separators may vary with the selected 
language and region.
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• Fields – shows how your data will look when it is separated into columns.

– Column type – select a column in the preview window and select the data type to be 
applied to the imported data.

– Standard – Calc determines the type of data.

– Text – imported data are treated as text.

– US English – numbers formatted in US English are searched for and included 
regardless of the system language. A number format is not applied. If there are no US 
English entries, the Standard format is applied.

– Hide – the data in the column are not imported.

Saving spreadsheets
For information on how to save files manually or automatically, see the Getting Started Guide 
Chapter 1 Introducing LibreOffice. Calc can save spreadsheets in a range of formats and also 
export spreadsheets to PDF, HTML and XHTML file formats; see Chapter 6 Printing, Exporting, 
and E-mailing in this guide for more information.

Saving in other formats
If you need to exchange files with users who are unable to receive spreadsheet files in Open 
Document Format (ODF) (*.ods), which Calc uses as default format, you can save a spreadsheet
in another format.

1) Save your spreadsheet in Calc spreadsheet file format (*.ods).

Figure 7. Save dialog
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2) Select File > Save As on the main menu bar to open the Save dialog (Figure 7).

3) In Name, if you wish, enter a new file name for the spreadsheet and select the folder where
you want to save the file.

4) In drop-down menu below the file browser window, select the type of spreadsheet format 
you want to use and click Save.

5) Each time you click Save when you are saving in a format other than ODF format, the 
Confirm File Format dialog opens (Figure 8). Click Use [xxx] Format to continue saving 
in your selected spreadsheet format or click Use ODF Format to save the spreadsheet in 
Calc ODS format.

6) If you select Text CSV format (*.csv) for your spreadsheet, the Export Text File dialog 
(Figure 9) opens allowing you to select the character set, field delimiter, text delimiter and 
so on to be used for your CSV file.

Note

Once you have saved a spreadsheet in another format, all changes you make to the 
spreadsheet will now occur only in the format you are using because you have 
changed the name and file type of your document. If you want to go back to working 
with an *.ods version, you must open the spreadsheet again.

Figure 8. Confirm File Format dialog

Figure 9. Export Text File dialog

Tip

To have Calc save documents by default in a Microsoft Excel file format, go to 
Tools > Options > Load/Save > General. In the section named Default file format
and ODF settings, under Document type, select Spreadsheet, then under Always 
save as, select your preferred file format.
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Password protection

To protect a spreadsheet and restrict who can open, read, and make changes to a spreadsheet, 
you have to use password protection. Password protection is common to all modules within 
LibreOffice and more information can be found in the Getting Started Guide Chapter 1 Introducing 
LibreOffice.

Navigating within spreadsheets

Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You
can generally use the method you prefer.

Cell navigation
When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is 
selected, the cell area is colored. The color of the cell border emphasis and the color of a group of 
selected cells depends on the operating system being used and how you have set up LibreOffice.

• Using the mouse – place the mouse pointer over the cell and click the left mouse button. 
To move the focus to another cell using the mouse, simply move the mouse pointer to the 
cell where you want the focus to be and click the left mouse button.

• Using a cell reference – highlight or delete the existing cell reference in the Name Box on 
the Formula Bar (Figure 3 on page 18). Type the new cell reference of the cell you want to 
move to and press Enter key. Cell references are case insensitive: for example, typing a3 
or A3 will move the focus to cell A3.

• Using the Navigator – click on the Navigator icon  on the Standard toolbar or press 
the F5 key to open the Navigator dialog (Figure 10). Type the cell reference into the 
Column and Row fields and press the Enter key.

Figure 10: Navigator dialog in Calc

• Using the Enter key – pressing Enter moves the cell focus down in a column to the next 
row. Pressing Shift+Enter moves the focus up in a column to the next row.

• Using the Tab key – pressing Tab moves the cell focus right in a row to the next column. 
Pressing Shift+Tab moves the focus to the left in a row to the next column.

Chapter 1  Introducing Calc 25



• Using the arrow keys – pressing the arrow keys on the keyboard moves the cell focus in 
the direction of the arrow pressed.

• Using Home, End, Page Up and Page Down

– Home moves the cell focus to the start of a row.

– End moves the cell focus to the last cell on the right in the row that contains data.

– Page Down moves the cell focus down one complete screen display.

– Page Up moves the cell focus up one complete screen display.

Sheet navigation
Each sheet in a spreadsheet is independent of the other sheets, though references can be linked 
from one sheet to another. There are three ways to navigate between different sheets in a 
spreadsheet.

• Using the Navigator – when the Navigator is open (Figure 10), double-clicking on any of 
the listed sheets selects the sheet.

• Using the keyboard – using key combinations Ctrl+Page Down moves one sheet to the 
right and Ctrl+Page Up moves one sheet to the left.

• Using the mouse – clicking on one of the sheet tabs at the bottom of the spreadsheet 
selects that sheet.

If there are a lot of sheets in your spreadsheet, then some of the sheet tabs may be hidden behind 
the horizontal scroll bar at the bottom of the screen. If this is the case, using the four buttons to the 
left of the sheet tabs can move the tabs into view (Figure 11).

Figure 11. Navigating sheet tabs

Note
The sheet tab arrows that appear in Figure 11 are only active if there are sheet 
tabs that cannot be seen.

Note

When you insert a new sheet into your spreadsheet, Calc automatically uses the 
next number in the numeric sequence as a name. Depending on which sheet is 
open when you insert a new sheet, your new sheet may not be in numerical order. 
It is recommended to rename sheets in your spreadsheet to make them more 
recognizable.
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Keyboard navigation
Pressing a key or a combination of keys allows you to navigate a spreadsheet using the keyboard. 
A key combination is where you press more than one key together, for example Ctrl+Home key 
combination to move to cell A1. Table 2 lists the keys and key combinations you can use for 
spreadsheet navigation in Calc.

Table 2: Keyboard cell navigation

Keyboard 
shortcut

Cell navigation

→ Moves cell focus right one cell

← Moves cell focus left one cell

↑ Moves cell focus up one cell

↓ Moves cell focus down one cell

Ctrl+→ Moves cell focus to the first column on the right containing data in that row if 
cell focus is on a blank cell.

Moves cell focus to the last column on the right containing data in that row if 
cell focus is on a cell containing data.

Moves cell focus to the last column on the right in the spreadsheet if there are
no more cells containing data.

Ctrl+← Moves cell focus to the last column on the left containing data in that row if 
cell focus is on a blank cell.

Moves cell focus to the first column on the left containing data in the 
spreadsheet if cell focus is on a cell containing data.

Moves cell focus to the first column in that row if there are no more cells 
containing data.

Ctrl+↑ Moves cell focus from a blank cell to the first cell above containing data in the 
same column.

Moves cell focus from a cell containing data to the cell in Row 1 in the same 
column.

Ctrl+↓ Moves cell focus from a blank cell to the first cell below containing data in the 
same column.

Moves cell focus from a cell containing data to the last cell containing data in 
the same column.

Moves cell focus from the last cell containing data to the cell in the same 
column in the last row of the spreadsheet.

Ctrl+Home Moves cell focus from anywhere on the spreadsheet to Cell A1 on the same 
sheet.

Ctrl+End Moves cell focus from anywhere on the spreadsheet to the last cell in the 
lower right-hand corner of the rectangular area of cells containing data on the 
same sheet.

Alt+Page Down Moves cell focus one screen to the right (if possible).

Alt+Page Up Moves cell focus one screen to the left (if possible).

Ctrl+Page Down Moves cell focus to the same cell on the next sheet to the right in sheet tabs if
the spreadsheet has more than on sheet.
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Keyboard 
shortcut

Cell navigation

Ctrl+Page Up Moves cell focus to the same cell on the next sheet to the left in sheet tabs if 
the spreadsheet has more than on sheet.

Tab Moves cell focus to the next cell on the right

Shift+Tab Moves cell focus to the next cell on the left

Enter Down one cell (unless changed by user)

Shift+Enter Up one cell (unless changed by user)

Customizing the Enter key
You can choose the direction in which the Enter key moves the cell focus by going to Tools > 
Options > LibreOffice Calc > General. Select the direction cell focus moves from the drop-down 
list. Depending on the file being used or the type of data being entered, setting a different direction 
can be useful. The Enter key can also be used to switch into and out of editing mode. Use the first 
two options under Input settings in Figure 12 to change the Enter key settings.

Figure 12: Customizing the Enter key

Selecting items in a sheet or spreadsheet

Selecting cells

Single cell
Left-click in the cell. You can verify your selection by looking in the Name Box on the Formula Bar 
(Figure 3 on page 18).

Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse cursor:

1) Click in a cell.

2) Press and hold down the left mouse button.

3) Move the mouse around the screen.

4) Once the desired block of cells is highlighted, release the left mouse button.
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To select a range of cells without dragging the mouse:

1) Click in the cell which is to be one corner of the range of cells.

2) Move the mouse to the opposite corner of the range of cells.

3) Hold down the Shift key and click.

Tip

You can also select a contiguous range of cells by first clicking in the Selection 
mode field on the Status Bar (Figure 5 on page 20) and selecting Extending 
selection before clicking in the opposite corner of the range of cells. Make sure to 
change back to Standard selection or you may find yourself extending a cell 
selection unintentionally.

To select a range of cells without using the mouse:

1) Select the cell that will be one of the corners in the range of cells.

2) While holding down the Shift key, use the cursor arrows to select the rest of the range.

Tip

You can also directly select a range of cells using the Name Box. Click into the 
Name Box on the Formula Bar (Figure 3 on page 18). To select a range of cells, 
enter the cell reference for the upper left-hand cell, followed by a colon (:), and 
then the lower right-hand cell reference. For example, to select the range that 
would go from A3 to C6, you would enter A3:C6.

Range of non-contiguous cells
1) Select the cell or range of cells using one of the methods above.

2) Move the mouse pointer to the start of the next range or single cell.

3) Hold down the Ctrl key and click or click-and-drag to select another range of cells to add to 
the first range.

4) Repeat as necessary.

Selecting columns and rows

Single column or row
To select a single column, click on the column header (Figure 2 on page 17).

To select a single row, click on the row header.

Multiple columns or rows
To select multiple columns or rows that are contiguous:

1) Click on the first column or row in the group.

2) Hold down the Shift key.

3) Click the last column or row in the group.

To select multiple columns or rows that are not contiguous:

1) Click on the first column or row in the group.

2) Hold down the Ctrl key.

3) Click on all of the subsequent columns or rows while holding down the Ctrl key.
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Entire sheet
To select the entire sheet, click on the small box between the column headers and the row headers
(Figure 13), or use the key combination Ctrl+A to select the entire sheet, or go to Edit on the main 
menu bar and select Select All.

Figure 13. Select All box

Selecting sheets
You can select either one or multiple sheets in Calc. It can be advantageous to select multiple 
sheets, especially when you want to make changes to many sheets at once.

Single sheet
Click on the sheet tab for the sheet you want to select. The tab for the selected sheet becomes 
white (default Calc setup).

Multiple contiguous sheets
To select multiple contiguous sheets:

1) Click on the sheet tab for the first desired sheet.

2) Move the mouse pointer over the sheet tab for the last desired sheet.

3) Hold down the Shift key and click on the sheet tab.

4) All tabs between these two selections will turn white (default Calc setup). Any actions that 
you perform will now affect all highlighted sheets.

Multiple non-contiguous sheets
To select multiple non-contiguous sheets:

1) Click on the sheet tab for the first desired sheet.

2) Move the mouse pointer over the sheet tab for the second desired sheet.

3) Hold down the Ctrl key and click on the sheet tab.

4) Repeat as necessary.

5) The selected tabs will turn white (default Calc setup). Any actions that you perform will now 
affect all highlighted sheets.

All sheets
Right-click a sheet tab and choose Select All Sheets from the context menu.
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Working with columns and rows

Inserting columns and rows

Note

When you insert a column, it is inserted to the left of the highlighted column. When
you insert a row, it is inserted above the highlighted row.

When you insert columns or rows, the cells take the formatting of the 
corresponding cells in the next column to left or the row above.

Single column or row
Using the Insert menu:

1) Select a cell, column, or row where you want the new column or row inserted.

2) Go to Insert on the main menu bar and select either Insert > Columns or Insert > Rows.

Using the mouse:

1) Select a column or row where you want the new column or row inserted.

2) Right-click the column or row header.

3) Select Insert Columns Left or Insert Rows Above from the context menu.

Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a time.

1) Highlight the required number of columns or rows by holding down the left mouse button on
the first one and then dragging across the required number of identifiers.

2) Proceed as for inserting a single column or row above.

Deleting columns and rows

Single column or row
To delete a single column or row:

1) Select a cell in the column or row you want to delete,.

2) Go to Edit on the main menu bar and select Delete Cells or right-click and select Delete 
from the context menu.

3) Select the option you require from the Delete Cells dialog (Figure 14).

Figure 14: Delete Cells dialog

Alternatively:

1) Click in the column or header to select the column or row.

2) Go to Edit on the main menu bar and select Delete Cells or right-click and select Delete 
Selected Columns or Delete Selected Rows from the context menu.
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Multiple columns or rows
To delete multiple columns or rows:

1) Select the columns or rows, see “Multiple columns or rows” on page 29 for more 
information.

2) Go to Edit on the main menu bar and select Delete Cells, or right-click and select Delete 
from the context menu, or right-click in the column or row header and select Delete 
Selected Columns or Delete Selected Rows from the context menu.

Working with sheets

Inserting new sheets

Click on the Add Sheet icon . This inserts a new sheet after the last sheet in the spreadsheet 
without opening the Insert Sheet dialog. The following methods open the Insert Sheet dialog 
(Figure 15) where you can position the new sheet, create more than one sheet, name the new 
sheet, or select a sheet from a file.

• Select the sheet where you want to insert a new sheet, then go to Insert > Sheet on the 
main menu bar.

• Right-click on the sheet tab where you want to insert a new sheet and select Insert Sheet 
from the context menu.

• Click in the empty space at the end of the sheet tabs.

• Right-click in the empty space at the end of the sheet tabs and select Insert Sheet from 
the context menu.

Figure 15: Insert Sheet dialog

Moving and copying sheets
You can move or copy sheets within the same spreadsheet by dragging and dropping or using the 
Move/Copy Sheet dialog (Figure 16). To move or copy a sheet into a different spreadsheet; you 
have to use the Move/Copy Sheet dialog.
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Dragging and dropping
To move a sheet to a different position within the same spreadsheet, click on the sheet tab and 
drag it to its new position before releasing the mouse button.

To copy a sheet within the same spreadsheet, hold down the Ctrl key (Option key on Mac) then 
click on the sheet tab and drag it to its new position before releasing the mouse button. The mouse
pointer may change to include a plus sign depending on the setup of your operating system.

Figure 16: Move/Copy Sheet dialog

Using Move/Copy Sheet dialog
The Move/Copy Sheet dialog allows you to specify exactly whether you want the sheet in the 
same or a different spreadsheet, its position within the spreadsheet, the sheet name when you 
move or copy the sheet.

1) In the current document, right-click on the sheet tab you wish to move or copy and select 
Move/Copy Sheet from the context menu or go to Edit > Sheet > Move/Copy on the main
menu bar.

2) Select Move to move the sheet or Copy to copy the sheet.

3) Select the spreadsheet where you want the sheet to be placed from the drop-down list in 
To document. This can be the same spreadsheet, another spreadsheet already open, or 
you can create a new spreadsheet.

4) Select the position in Insert before where you want to place the sheet.

5) Type a name in the New name text box if you want to rename the sheet when it is moved 
or copied. If you do not enter a name, Calc creates a default name (Sheet 1, Sheet 2, and 
so on).

6) Click OK to confirm the move or copy and close the dialog.

Note
When you move or copy to another spreadsheet or a new spreadsheet, a conflict 
may occur with formulas linked to other sheets in the previous location.
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Deleting sheets
To delete a single sheet, right-click on the sheet tab you want to delete and select Delete Sheet 
from the context menu, or go to Edit > Sheet > Delete on the main menu bar. Click Yes to confirm 
the deletion.

To delete multiple sheets, select the sheets (see “Selecting sheets” on page 30), then right-click 
one of the sheet tabs and select Delete Sheet from the context menu, or go to Edit > Sheet > 
Delete on the main menu bar. Click Yes to confirm the deletion.

Renaming sheets
By default, the name for each new sheet added is SheetX, where X is the number of the next sheet
to be added. While this works for a small spreadsheet with only a few sheets, it can become 
difficult to identify sheets when a spreadsheet contains many sheets..

You can rename a sheet using one of the following methods:

• Enter the name in the Name text box when you create the sheet using the Insert Sheet 
dialog (Figure 15 on page 32).

• Right-click on a sheet tab and select Rename Sheet from the context menu to replace the 
existing name with a different one.

• Double-click on a sheet tab to open the Rename Sheet dialog.

Note

Sheet names must start with either a letter or a number; other characters including
spaces are not allowed. Apart from the first character of the sheet name, permitted
characters are letters, numbers, spaces, and the underscore character. Attempting
to rename a sheet with an invalid name will produce an error message.

Viewing Calc

Changing document view
Use the zoom function to show more or fewer cells in the window when you are working on a 
spreadsheet. For more about zoom, see the Getting Started Guide Chapter 1 Introducing 
LibreOffice.

Freezing rows and columns
Freezing locks a number of rows at the top of a spreadsheet or a number of columns on the left of 
a spreadsheet or both rows and columns. Then, when moving around within a sheet, the cells in 
frozen rows and columns always remain in view.

Figure 17 shows some frozen rows and columns. The heavier horizontal line between rows 3 and 
23 and the heavier vertical line between columns F and Q indicate that rows 1 to 3 and columns A 
to F are frozen. The rows between 3 and 23 and the columns between F and Q have been scrolled
off the page.

1) Click on the row header below the rows you want the freeze or click on the column header 
to the right of the columns where you want the freeze.

2) Go to Window on the main menu bar and select Freeze. A heavier line appears between 
the rows or columns indicating where the freeze has been placed.
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Figure 17. Frozen rows and columns

Unfreezing
To unfreeze rows or columns, go to Window on the main menu bar and uncheck Freeze. The 
heavier lines indicating freezing will disappear.

Splitting the screen
Another way to change the view is by splitting the screen your spreadsheet is displayed in (also 
known as splitting the window). The screen can be split horizontally, vertically, or both, giving you 
up to four portions of the spreadsheet in view at any one time. An example of splitting the screen is
shown in Figure 18 where a split is indicated by a black line.

Why would you want to do this? For example, a large spreadsheet in which one cell has a number 
in it that is used by three formulas in other cells. Using the split-screen technique, you can position 
the cell containing the number in one section and each of the cells with formulas in the other 
sections. This allows you to change the number in one cell and watch how it affects each of the 
formulas.

Figure 18. Split screen example

Splitting horizontally or vertically
1) Click on the row header below the rows where you want to split the screen horizontally or 

click on the column header to the right of the columns where you want to split the screen 
vertically.

2) Go to Window on the main menu bar and select Split. A thick line appears between the 
rows or columns indicating where the split has been placed. An example of a split line is 
shown below Row 2 in Figure 18.

3) Alternatively for a horizontal split, click on the thick black line at the top of the vertical scroll 
bar (Figure 19) and drag the split line below the row where you want the horizontal split 
positioned.

4) Alternatively for a vertical split, click on the thick black line at the right of the horizontal 
scroll bar (Figure 19) and drag the split line to the right of the column where you want the 
vertical split positioned.

Chapter 1  Introducing Calc 35



Figure 19. Split screen bars

Splitting horizontally and vertically
1) Click into the cell that is immediately below the rows where you want to split the screen 

horizontally and immediately to the right of the columns where you want to split the screen 
vertically.

2) Go to Window on the main menu bar and select Split. A thick line appears between the 
rows or columns indicating where the split has been placed. An example of a split line is 
shown below Row 2 in Figure 18.

Removing split views
To remove a split view, do any of the following:

• Double-click on each split line.

• Click on and drag the split lines back to their places at the ends of the scroll bars.

• Go to Window on the main menu bar and uncheck Split.

Using the Navigator

The Navigator (Figure 20), that is available in all LibreOffice modules, provides tools and methods 
to move quickly through a spreadsheet and find specific items. The Navigator categorizes and 
groups spreadsheet objects which you can click on to move quickly to that object. If an indicator 
(plus sign or triangle, dependent on computer setup) appears next to a category, at least one 
object in this category exists. To open a category and see the list of items, click on the indicator.

Figure 20: Navigator dialog in Calc
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• When a category is showing the list of objects in it, double-click on an object to jump 
directly to that object location in the spreadsheet.

• Objects are much easier to find if you have given them recognizable names when creating 
them, instead of using the LibreOffice default names, such as Sheet1, Table1, Table2, and 
so on. Note that the default names may not correspond to the actual position of the object 
in the spreadsheet.

• The Navigator in each of the individual LibreOffice modules has a different range of 
functions and these functions are further explained in the appropriate user guides for each 
LibreOffice module.

To open the Navigator, do one of the following:

• Click the Navigator icon  on the Standard toolbar.

• Press the F5 key.

• Go to View > Navigator on the main menu bar.

• Double-click the sheet number at the left end of the Status Bar.

You can dock the Navigator into the main Calc window or leave it as a floating dialog. To dock or 
float the Navigator, hold down the Ctrl key and double-click in an empty area near the icons at the 
top of the dialog.

The controls and tools available in the Navigator are as follows:

• Column – enter the column letter and press the Enter key to reposition the cell cursor to 
the specified column in the same row.

• Row –  enter a row number and press the Enter key to reposition the cell cursor to the 
specified row in the same column.

• Data Range  – specifies the current data range denoted by the position of the cell 
cursor.

• Start  – moves to the cell at the beginning of the current data range, which you can 
highlight using the Data Range icon.

• End  – moves to the cell at the end of the current data range, which you can highlight 
using the Data Range icon.

• Contents  – allows you to show or hide the contents.

• Toggle  – toggles the content view. Only the selected Navigator element and its 
subelements are displayed. Click the icon again to restore all elements for viewing.

• Scenarios  – displays all available scenarios. Double-click a name to apply that 
scenario and the result is shown in the sheet. If the Navigator displays scenarios, you can 
access the following commands when you right-click a scenario entry:

– Delete – deletes the selected scenario.

– Properties – opens the Edit scenario dialog, where you can edit the scenario properties.

• Drag Mode  – opens a submenu for selecting the drag mode. You decide which action 
is performed when dragging and dropping an object from the Navigator into a document. 
Depending on the mode you select, the icon indicates whether a hyperlink, link or a copy is 
created.

– Insert as Hyperlink – inserts a hyperlink when you drag-and-drop an object from the 
Navigator into a document. You can later click the created hyperlink to set the cursor 
and the view to the respective object. If you insert a hyperlink that links to an open 
document, you need to save the document before you can use the hyperlink.
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– Insert as Link – creates a link when you drag-and-drop an object from the Navigator into
a document.

– Insert as Copy – generates a copy when you drag-and-drop an object from the 
Navigator into a document.

Tip

Ranges, scenarios, pictures, and other objects are much easier to find if you have 
given them informative names when creating them, instead of keeping the default 
Calc names, for example Graphics 1, Graphics 2, Object 1, and so on. These default 
names may not correspond to the position of the object in the document.

Using document properties

To open the Properties dialog for a document, go to File > Properties on the main menu bar. The 
Properties dialog allows you to set some of the properties of a spreadsheet and the dialog has six 
tabs and these are described as follows.

General
Contains basic information about the current file.

• The text box at the top of the dialog displays the file name.

• Change Password – opens a dialog where you can change the password and is only 
active if a password has been set for the file.

• Type – displays the file type for the current document.

• Location – displays the path and the name of the directory where the file is stored.

• Size – displays the size of the current document in bytes.

• Created – displays the date and time and author when the file was first saved.

• Modified – displays the date and time and author when the file was last saved in a 
LibreOffice file format.

• Digitally signed – displays the date and the time when the file was last signed as well as 
the name of the author who signed the document.

• Digital Signature – opens the Digital Signatures dialog where you can manage digital 
signatures for the current document.

• Last printed – displays the date and time and user name when the file was last printed.

• Total editing time – displays the amount of time that the file has been open for editing 
since the file was created. The editing time is updated when you save the file.

• Revision number – displays the number of times that the file has been saved.

• Apply user data – saves the full name of the user with the file. You can edit the name by 
going to Tools > Options > LibreOffice > User Data on the main menu bar.

• Reset – resets the editing time to zero, the creation date to the current date and time, and 
the version number to 1. The modification and printing dates are also deleted.

• Template – displays the template that was used to create the file.
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Description
Contains descriptive information about the spreadsheet.

• Title – enter a title for the document.

• Subject – enter a subject for the document. You can use a subject to group documents 
with similar contents.

• Keywords – enter the words that you want to use to index the content of your document. 
Keywords must be separated by commas. A keyword can contain white space characters 
or semicolons.

• Comments – enter comments to help identify the document.

Custom Properties
Allows you to assign custom information fields to your document. You can change the name type 
and contents of each row. The information in the fields will exported as metadata to other file 
formats.

Click Add to add a new now to the custom properties. Click Reset to delete any additional rows 
and reset the default rows.

Security
Sets the password options for the current document.

• Open file read-only – select to allow this document to be opened in read-only mode only. 
This file sharing option protects the document against accidental changes. It is still possible
to edit a copy of the document and save that copy with the same name as the original.

• Record changes – select to enable recording changes. This is the same as Edit > 
Changes > Record on the main menu bar. To protect the recording state with a password, 
click Protect and enter a password. Other users of this document can apply their changes, 
but they cannot disable change recording without knowing the password.

• Protect or Unprotect – protects the change recording state with a password. If change 
recording is protected for the current document, the button is named Unprotect. Click 
Unprotect and type the correct password to disable the protection.

Font
When Embed fonts in the document is selected, any fonts used in the document will be 
embedded into the document. This maybe useful if you are creating a PDF of your spreadsheet 
and want to control how your spreadsheet will look on other computer systems.

Statistics
Displays statistics for the current file.

• Number of sheets – number of sheets in the file. This statistic does not include tables that 
were inserted as OLE objects.

• Number of cells – number of cells with content in the file.

• Number of pages – number of pages in the file.
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Chapter 2  
Entering, Editing, and 
Formatting Data



Introduction

You can enter data into Calc in several ways: using the keyboard, dragging and dropping using the
mouse, the Fill tool, and selection lists. Calc also provides the ability to enter information into 
multiple sheets of the same spreadsheet at the same time. After entering data, you can format and 
display it in various ways.

Using the keyboard

Most data entry in Calc can be accomplished using the keyboard.

Numbers
Click in the cell and type the number using the number keys on either the main keyboard or the 
numeric keypad.

Negative numbers
To enter a negative number, either type a minus (–) sign in front of the number or enclose the 
number in parentheses (), for example (1234). The result for both methods of entry will be the 
same, for example -1234.

Leading zeroes
To retain a minimum number of characters in a cell when entering numbers and retain the number 
format, for example 1234 and 0012, leading zeroes have to be added as follows:

1) With the cell selected, right-click on the cell and select Format Cells from the context 
menu, or go to Format > Cells on the menu bar, or use the keyboard shortcut Ctrl+1 to 
open the Format Cells dialog (Figure 21).

Figure 21: Format Cells dialog – Numbers page

2) Make sure the Numbers page is selected, then select Number in the Category list.
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3) In Options > Leading Zeroes, enter the minimum number of characters required. For 
example, for four characters, enter 4. Any number less than four characters will have 
leading zeroes added, for example 12 becomes 0012.

4) Click OK. The number entered retains its number format and any formula used in the 
spreadsheet will treat the entry as a number in formula functions.

If a number is entered with leading zeroes, for example 01481, by default Calc will automatically 
drop the leading 0. To preserve leading zeroes in a number:

1) Type an apostrophe (') before the number, for example '01481.

2) Move the cell focus to another cell. The apostrophe is automatically removed, the leading 
zeroes are retained and the number is converted to left-aligned text.

Numbers as text
Numbers can also be converted to text as follows:

1) With the cell selected, right-click on the cell and select Format Cells from the context 
menu, or go to Format > Cells on the menu bar, or use the keyboard shortcut Ctrl+1 to 
open the Format Cells dialog (Figure 21).

2) Make sure the Numbers page is selected, then select Text from the Category list.

3) Click OK. The number is converted to text and, by default, is left-aligned. You can change 
the formatting and alignment of any text numbers just as you would with normal text.

Note
Any numbers that have been formatted as text in a spreadsheet will be treated as 
a zero by any formulas used in the spreadsheet. Formula functions will ignore text 
entries.

Text
Click in a cell and type the text. The text is left-aligned by default. Cells can contain several lines of
text. If you want to use paragraphs, press Ctrl+Enter to create another paragraph.

On the Formula Bar, you can extend the Input Line if you are entering several lines of text. Click on

the Extend Formula Bar icon  located on the right of the Formula Bar and the Input Line 
becomes multi-line, as shown in Figure 22. Click the Extend Formula Bar icon again to return to a
single input line.

Figure 22: Extended input line on Formula Bar

Date and time
Select the cell and type the date or time. You can separate the date elements with a slash (/) or a 
hyphen (–) or use text, for example 10 Oct 2012. The date format automatically changes to the 
selected format used by Calc.
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When you enter a time, separate time elements with colons, for example 10:43:45. The time format
automatically changes to the selected format used by Calc.

To change the date or time format used by Calc:

1) With the cell selected, right-click on the cell select Format Cells from the context menu or 
go to Format > Cells on the menu bar or use the keyboard shortcut Ctrl+1 to open the 
Format Cells dialog (Figure 21).

2) Make sure the Numbers page is selected, then select Date or Time from the Category list.

3) Select the date or time format you want to use from the Format list.

4) Click OK to save the changes and close the dialog.

Special characters
A special character is a character not normally found on a standard keyboard, for example, © ¾ æ 
ç ñ ö ø ¢. To insert a special character:

1) Place the cursor in the cell where you want the character to appear.

2) Go to Insert > Special Character… on the menu bar to open the Special Characters 
dialog (Figure 23).

3) Select in order the special characters you want to insert into the cell. The special 
characters selected will appear at the bottom left of the Special Characters dialog. The last 
character selected is shown on the right of the Special Characters dialog along with its 
numerical code.

4) Click OK to close the dialog and the special characters are inserted into the selected cell.

Note
Different fonts include different special characters. If you do not find a particular 
special character you want, try changing the Font and Subset selection.

Figure 23: Special Characters dialog

Autocorrection options
Calc automatically applies many changes during data input using autocorrection, unless you have 
deactivated any autocorrect changes. You can also undo any autocorrection changes by using the 
keyboard shortcut Ctrl+Z or manually by going back to the change and replacing the autocorrection
with what you want to actually see.
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To change the autocorrect options, go to Tools > AutoCorrect Options on the menu bar to open 
the AutoCorrect dialog (Figure 24).

Figure 24: AutoCorrect dialog

• Replace – edits the replacement table for automatically correcting or replacing words or 
abbreviations in your document.

• Exceptions – specify the abbreviations or letter combinations that you do not want 
LibreOffice to correct automatically.

• Options – select the options for automatically correcting errors as you type and then click 
OK.

• Localized Options – specify the AutoCorrect options for quotation marks and for options 
that are specific to the language of the text.

• Reset – resets modified values back to the LibreOffice default values.

Inserting dashes
Calc provides text shortcuts so that you can quickly insert dashes into a cell and these shortcuts 
are shown in Table 3.

Table 3: Inserting dashes

Text that you type Result

A - B (A, space, hyphen, space, B) A – B (A, space, en-dash, space, B)

A -- B (A, space, hyphen, hyphen, space, B) A – B (A, space, en-dash, space, B)

A--B (A, hyphen, hyphen, B) A—B (A, em-dash, B)

A-B (A, hyphen, B) A-B (unchanged)

A -B (A, space, hyphen, B) A -B (unchanged)

A --B (A, space, hyphen, hyphen, B) A –B (A, space, en-dash, B)
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Speeding up data entry

Entering data into a spreadsheet can be very labor-intensive, but Calc provides tools for removing 
some of the drudgery from input. These tools include drag and drop to move or copy contents of 
one cell to another using a mouse, an AutoInput tool, the Fill tool, and selection lists.

The Fill tool and selection lists automate input of repetitive material into cells. Calc also has the 
ability to input information into multiple sheets of the same spreadsheet at the same time.

AutoInput tool
The AutoInput function in Calc automatically completes entries, based on other entries in the 
same column. The column is scanned up to a maximum of 2000 cells or 200 different strings.

When text is highlighted in a cell, AutoInput can be used as follows:

1) To accept the completion, press Enter or F2 or the mouse button.

2) To view more completions, use the key combinations Ctrl+Tab to scroll forward, or 
Ctrl+Shift+Tab to scroll backward.

3) To see a list of all available AutoInput text items for the current column, use the keyboard 
combination Alt+Down Arrow.

When typing formulas using characters that match previous entries, a Help tip will appear listing 
the last ten functions used in the Function Wizard from all defined range names and from the 
content of all label ranges.

AutoInput ignores the case sensitivity of any data you enter. If, for example, you have written 
"Total" in a cell, you cannot then enter "total" in another cell of the same column without first 
deactivating AutoInput.

By default, AutoInput is activated in Calc. To turn off AutoInput, go to Tools > Cell Contents on 
the main menu bar and deselect AutoInput.

Figure 25: Examples of using the Fill tool

Fill tool
You can use the Fill tool in Calc to duplicate existing content or create a series in a range of cells 
in your spreadsheet as shown by the examples in Figure 25.

1) Select the cell containing the contents you want to copy or start the series from.

2) Drag the cursor in any direction or hold down the Shift key and click in the last cell you 
want to fill.
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3) Go to Edit > Fill on the main menu bar and select the direction in which you want to copy 
or create data (Up, Down, Left Right, Sheet or Series). A menu option will be grayed out if
it is not available.

Alternatively, you can use a shortcut to fill cells:

1) Select the cell containing the contents you want to copy or start the series from.

2) Move the cursor over the small selection handle in the bottom right corner of the selected 
cell. The cursor will change shape.

3) Click and drag in the direction you want the cells to be filled, vertical or horizontal. If the 
original cell contained text, then the text will automatically be copied. If the original cell 
contained a number, a series will be created.

Note
When you are selecting cells so you can use the Fill tool, make sure that none of 
the cells contain data, except for the cell data you want to use. When you use the 
Fill tool, any data contained in selected cells is overwritten.

Using a fill series
When you select a series fill from Edit > Fill > Series on the menu bar, the Fill Series dialog 
(Figure 26) opens. Here you can select the type of series you want or create your own list.

Figure 26: Fill Series dialog

• Direction – determines the direction of series creation.

– Down – creates a downward series in the selected cell range for the column using the 
defined increment to the end value.

– Right – creates a series running from left to right within the selected cell range using the
defined increment to the end value.

– Up – creates an upward series in the cell range of the column using the defined 
increment to the end value.

– Left – creates a series running from right to left in the selected cell range using the 
defined increment to the end value.

• Series Type – defines the series type.

– Linear – creates a linear number series using the defined increment and end value.

– Growth – creates a growth series using the defined increment and end value.

– Date – creates a date series using the defined increment and end date.

– AutoFill – forms a series directly in the sheet. The AutoFill function takes account of 
customized lists. For example, by entering January in the first cell, the series is 
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completed using the list defined in LibreOffice > Tools > Options > LibreOffice Calc 
> Sort Lists. AutoFill tries to complete a value series by using a defined pattern. For 
example, a numerical series using 1,3,5 is automatically completed with 7,9,11,13; a 
date and time series using 01.01.99 and 15.01.99, an interval of fourteen days is used.

• Unit of Time – in this area you specify the desired unit of time. This area is only active if 
the Date option has been selected in Series Type.

– Day – use the Date series type and this option to create a series using seven days.

– Weekday – use the Date series type and this option to create a series of five day sets.

– Month – use the Date series type and this option to form a series from the names or 
abbreviations of the months.

– Year – use the Date series type and this option to create a series of years.

• Start Value – determines the start value for the series. Use numbers, dates or times.

• End Value – determines the end value for the series. Use numbers, dates or times.

• Increment – determines the value by which the series of the selected type increases by 
each step. Entries can only be made if the linear, growth or date series types have been 
selected.

Figure 27: Sort Lists dialog

Defining a fill series
To define your own fill series:

1) Go to Tools > Options > LibreOffice Calc > Sort Lists to open the Sort Lists dialog 
(Figure 27). This dialog shows any previously defined series in the Lists box on the left and 
the contents of the highlighted list in the Entries box.

2) Click New and the Entries box is cleared.

3) Type the series for the new list in the Entries box (one entry per line) (Figure 28).

4) Click Add and the new list will now appear in the Lists box.

5) Click OK to save the new list and close the dialog.
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Figure 28: Creating new sort list

Selection lists
Selection lists are available only for text and are limited to using only text that has already been 
entered in the same column.

1) Select a blank cell in a column that contains cells with text entries.

2) Right-click and select Selection Lists from the context menu, or use the keyboard shortcut
Alt+↓. A drop-down list appears listing any cell in the same column that either has at least 
one text character or whose format is defined as text.

3) Click on the text entry you require and it is entered into the selected cell.

Merging and splitting cells

Merging
You can select contiguous cells and merge them into one as follows:

1) Select the range of contiguous cells you want merge.

2) Right click on the selected cells and select Merge Cells from the context menu, or go to 
Format > Merge cells > Merge cells or Merge and Center Cells on the menu bar, or click

on the Merge and Center Cells icon  on the Formatting toolbar. Using Merge and 
Center Cells will center align any contents in the cells.

3) If the cells contain any data, click Yes on the confirmation dialog that opens to move the 
data in the hidden cells into the first cell.

Note
Merging cells can lead to calculation errors if formulas have used in the 
spreadsheet.

Splitting
You can reverse or split only a cell that was created from several cells by merging.

1) Select a merged cell.

2) Go to Format > Merge cells > Split cells on the menu bar, or right-click and select Split 

Cells from the context menu, or click on the Merge and Center Cells icon  on the 
Formatting toolbar.

3) Any data in the cell will remain in the first cell. If the hidden cells did have any contents, 
before the cells were merged, then you have to manually move the contents in to the 
correct cell.
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Sharing content between sheets

You might want to enter the same information in the same cell on multiple sheets, for example to 
set up standard listings for a group of individuals or organizations. Instead of entering the list on 
each sheet individually, you can enter the information in several sheets at the same time.

Figure 29: Select Sheets dialog

1) Go to Edit > Sheet > Select on the menu bar to open the Select Sheets dialog (Figure 
29).

2) Select the individual sheets where you want the information to be repeated.

3) Click OK to select the sheets and the sheet tabs will change color.

4) Enter the information in the cells on the sheet where you want the information to first 
appear and the information will repeated in the selected sheets.

5) Deselect the sheets when you have finished entering the information that you want 
repeated in the sheets.

Note

This technique automatically overwrites, without any warning, any information that 
is already in the cells on the selected sheets. Make sure you deselect the 
additional sheets when you have finished entering the information to be repeated 
before continuing to enter data into your spreadsheet.

Validating cell contents

When creating spreadsheets for other people to use, you may want to make sure they enter data 
that is valid or appropriate for the cell. You can also use validation in your own work as a guide to 
entering data that is either complex or rarely used.

Fill series and selection lists can handle some types of data, but are limited to predefined 
information. For example, a cell may require a date or a whole number with no alphabetic 
characters or decimal points, or a cell may not be left empty.

Depending on how validation is set up, it can also define the range of contents that can be entered,
provide help messages explaining the content rules set up for the cell and what users should do 
when they enter invalid content. You can also set the cell to refuse invalid content, accept it with a 
warning, or start a macro when an error is entered.

Defining validation
To validate any new data entered into a cell:

1) Select a cell and go to Data > Validity on the menu bar to open the Validity dialog.
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Figure 30: Validity dialog – Criteria page

2) Define the type of contents that can be entered in that cell using the options given on the 
tabbed pages for Criteria, Input Help and Error Alert. The options available are explained 
below.

Criteria options
Specify the validation rules for the selected cells using the Criteria page in the Validity dialog as 
shown in Figure 30. For example, you can define criteria such as: Numbers between 1 and 10 or 
Texts that are no more than 20 characters.

The options available on the Criteria page will depend on what has been selected in the Allow 
drop-down list.

• Allow – select a validation option for the selected cells from the drop-down list.

– All values – no limitation.

– Whole number – only whole numbers allowed.

– Decimal – all numbers correspond to decimal format.

– Date – all numbers correspond to date format. The entered values are formatted the 
next time the dialog is called up.

– Time – all numbers correspond to time format. The entered values are formatted the 
next time the dialog is called up.

– Cell range – allow only values that are given in a cell range. The cell range can be 
specified explicitly, or as a named database range, or as a named range. The range 
may consist of one column or one row of cells. If you specify a range of columns and 
rows, only the first column is used.

– List – allow only values or strings specified in a list. Strings and values can be mixed. 
Numbers evaluate to their value, so if you enter the number 1 in the list, the entry 100%
is also valid.

– Text length – entries whose length corresponds to the number of characters that have 
been set.

• Allow blank cells – in conjunction with Tools > Detective > Mark invalid Data, this 
defines that blank cells are shown as invalid data (disabled) or not shown (enabled).

• Show selection list – shows a list of all valid strings or values to select from. The list can 
also be opened by selecting the cell and pressing Ctrl+D.

• Sort entries ascending – sorts the selection list in ascending order and filters duplicates 
from the list. If not checked, the order from the data source is taken.
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• Source – enter the cell range that contains the valid values or text.

• Entries – enter the entries that will be valid values or text strings.

• Data – select the comparative operator that you want to use from the drop-down list. The 
available operators depend on what you have selected in the Allow drop-down list. For 
example, if you select valid range, the Minimum and Maximum input boxes replace the 
Value box.

• Value – enter the value for the data validation option that you selected in the Allow drop-
down list.

• Minimum – enter the minimum value for the data validation option that you selected in the 
Allow drop-down list.

• Maximum – enter the maximum value for the data validation option that you selected in the
Allow drop-down list.

Input Help options
Enter the message to be displayed when the cell or cell range is selected in the spreadsheet 
(Figure 31).

• Show input help when cell is selected – displays the message that you enter in the Title 
and Contents boxes when the cell or cell range is selected in the sheet. If you enter text in 
the Title and Contents boxes and then deselect this option, the text will be lost.

• Title – enter the title to be displayed when the cell or cell range is selected.

• Input help – enter the message to be displayed when the cell or cell range is selected.

Figure 31: Validity dialog – Input Help page

Figure 32: Validity dialog – Error Alert page
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Error Alert options
Define the error message that is displayed when invalid data is entered in a cell (Figure 32).

• Show error message when invalid values are entered – when selected, displays the 
error message that you enter in the Contents area when invalid data is entered in a cell.

• Action – select the action that you want to occur when invalid data is entered in a cell.

– Stop – rejects the invalid entry and displays a dialog that you have to close by clicking 
OK.

– Warning and Information – displays a dialog that can be closed by clicking OK or 
Cancel. The invalid entry is only rejected when you click Cancel.

– Macro – activates the Browse button to open the Macro dialog where you can select a 
macro that is executed when invalid data is entered in a cell. The macro is executed 
after the error message is displayed.

• Title – enter the title of the macro or the error message that you want to display when 
invalid data is entered in a cell.

• Error message – enter the message that you want to display when invalid data is entered 
in a cell.

Calc detective
The Detective is a tool within Calc that you can use to locate any cells in a spreadsheet that 
contain invalid data if the cells are set to accept invalid data with a warning.

1) Go to Tools > Detective > Mark Invalid Data on the menu bar to locate any cells 
containing invalid data. The Detective function marks any cells containing invalid data.

2) Correct the data so that it becomes valid.

3) Go to Tools > Detective > Mark Invalid Data on the menu bar again and any cells that 
were previously marked as containing invalid data have the invalid data mark removed.

Note

A validity rule is considered part of the format for a cell. If you select Delete All from
the Delete Contents dialog (Figure 33), then it is removed. If you want to copy a 
validity rule with the rest of the cell, use Edit > Paste Special > Paste Formats or 
Paste All.

Editing data

Deleting data

Deleting data only
Data can be deleted from a cell without deleting any of the cell formatting. Click in the cell to select 
it and then press the Delete key.

Deleting data and formatting
Data and cell formatting can be deleted from a cell at the same time.

1) Click in the cell to select it.

2) Press the Backspace key, or right-click in the cell and select Delete Contents from the 
context menu, or go to Edit > Delete Contents) on the menu bar to open the Delete 
Contents dialog (Figure 33). Here you can choose to delete the different aspects of the 
data in the cell or delete everything in the cell.
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Figure 33: Delete Contents dialog

3) Select the delete options.

4) Click OK to delete the contents and close the dialog.

Replacing data
To completely replace data in a cell and insert new data, select the cell and type in the new data. 
The new data will replace the data already contained in the cell and will retain the original 
formatting used in the cell.

Alternatively, click in the Input Line on the Formula Bar then double-click on the data to highlight it 
completely and type the new data.

Editing data
Sometimes it is necessary to edit the contents of cell without removing all of the data from the cell. 
For example, changing the phrase “Sales in Qtr. 2”  to “Sales rose in Qtr” can be done as follows.

Using the keyboard
1) Click in the cell to select it.

2) Press the F2 key and the cursor is placed at the end of the cell.

3) Press the Backspace key to delete any data up to the point where you want to enter new 
data.

4) Alternatively, use the keyboard arrow keys to reposition the cursor where you want to start 
entering the new data in the cell, then press the Delete key or Backspace key to delete any
unwanted data before typing the new data.

5) When you have finished editing, press the Enter key to save the changes.

Note
Each time you select a cell, the contents are displayed in the Input Line on the 
Formula Bar. Using the Input Line maybe easier to carry out editing data.

Using the mouse
1) Double-click on the cell to select it and place the cursor in the cell for editing.

2) Reposition the cursor to where you want to start editing the data in the cell.

3) Alternatively, single-click to select the cell, then move the cursor to the Input Line on the 
Formula Bar and click at the position where you want to start editing the data in the cell.

4) When you have finished, click away from the cell to deselect it and your editing changes 
are saved.
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Paste Special function
You can use the Paste Special function to paste into another cell selected parts of the data in the 
original cell or cell range, for example its format or the result of its formula.

Paste Special dialog
1) Select a cell or a cell range.

2) Go to Edit > Copy on the menu bar, right-click and select Copy from the context menu.

3) Select the target cell or cell range.

4) Go to Edit > Paste Special from the menu bar, or use the keyboard shortcut Ctrl+Shift+V, 
or right-click and select Paste Special from the context menu to open the Paste Special 
dialog (Figure 34).

5) Select the options for Selection, Operations, Options and Shift cells. The Paste Special 
options are explained below.

6) Click OK to paste the data into to the target cell or range of cells and close the dialog.

Figure 34: Paste Special dialog

Paste Special options

• Selection – select a format for the clipboard contents that you want to paste.

– Paste all – pastes all cell contents, comments, formats, and objects into the current 
document.

– Text – pastes cells containing text.

– Numbers – pastes cells containing numbers.

– Date & Time – pastes cells containing date and time values.

– Formulas – pastes cells containing formulas.

– Comments – pastes comments that are attached to cells. If you want to add the 
comments to the existing cell content, select the Add operation.

– Formats – pastes cell format attributes.
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– Objects – pastes objects contained within the selected cell range. These can be OLE 
objects, chart objects, or drawing objects.

• Operations – select the operation to apply when you paste cells into your sheet. 

– None – does not apply an operation when you insert the cell range from the clipboard. 
The contents of the clipboard will replace existing cell contents.

– Add – adds the values in the clipboard cells to the values in the target cells. Also, if the 
clipboard only contains comments, adds the comments to the target cells.

– Subtract – subtracts the values in the clipboard cells from the values in the target cells.

– Multiply – multiplies the values in the clipboard cells with the values in the target cells.

– Divide – divides the values in the target cells by the values in the clipboard cells.

• Options – sets the paste options for the clipboard contents.

– Skip empty cells – empty cells from the clipboard do not replace target cells. If you use 
this option in conjunction with the Multiply or the Divide operation, the operation is not 
applied to the target cell of an empty cell in the clipboard. If you select a mathematical 
operation and deselect the Skip empty cells, empty cells in the clipboard are treated as 
zeroes. For example, if you apply the Multiply operation, the target cells are filled with 
zeroes.

– Transpose – the rows of the range in the clipboard are pasted to become columns of the
output range. The columns of the range in the clipboard are pasted to become rows.

– Link – inserts the cell range as a link, so that changes made to the cells in the source 
file are updated in the target file. To ensure that changes made to empty cells in the 
source file are updated in the target file, ensure that the Paste All is also selected. You 
can also link sheets within the same spreadsheet. When you link to other files, a DDE 
link is automatically created. A DDE link is inserted as a matrix formula and can only be 
modified as a whole.

• Shift cells – set the shift options for the target cells when the clipboard content is inserted.

– Don't shift – inserted cells replace the target cells.

– Down – target cells are shifted downward when you insert cells from the clipboard.

– Right – target cells are shifted to the right when you insert cells from the clipboard.

Paste Only options
If you only want to copy text, numbers or formulas to your target cell or cell range:

1) Select the cell or cell range and copy the data.

2) Select the target cell or cell range.

3) Right-click on the target cell or cell range and select Paste Only from the context menu, 
then select Text, Number or Formula.

Insert cell fields
You can insert a field linked to the date, sheet name, or document name in a cell.

1) Select a cell and double-click to activate edit mode.

2) Right-click and select Insert Fields > Date or Sheet Name or Title from the context menu.

Note
The Insert Fields > Title command inserts the name of the spreadsheet and not 
the title defined in the Description page in the Properties dialog for the file.

Chapter 2  Entering, Editing, and Formatting Data 56



Tip
The fields are refreshed when the spreadsheet is saved or recalculated when 
using the Ctrl+Shift+F9 shortcut.

Formatting data

Note
All the settings discussed in this section can also be set as a part of the cell style. 
See Chapter 4 Using Styles and Templates in Calc for more information.

The data in Calc can be formatted in several ways. Formatting can either be defined as part of a 
cell style so that it is automatically applied, or it can be applied manually to the cell. For more 
control and extra options, select a cell or cell range and use the Format Cells dialog. All of the 
format options are discussed below.

Multiple lines of text
Multiple lines of text can be entered into a single cell using automatic wrapping or manual line 
breaks. Each method is useful for different situations.

Automatic wrapping
To automatically wrap multiple lines of text in a cell:

1) Select a cell or cell range.

2) Right-click on the selection and select Format Cells from the context menu, or go to 
Format > Cells on the menu bar, or press Ctrl+1 to open the Format Cells dialog.

3) Click on the Alignment tab (Figure 35).

4) Under Properties, select Wrap text automatically and click OK.

Figure 35: Format Cells dialog – Alignment page
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Manual line breaks
To insert a manual line break while typing in a cell, press Ctrl+Enter. This method does not work 
with the cursor in the input line. When editing text, double-click the cell, then reposition the cursor 
to where you want the line break.

When a manual line break is entered, the cell width does not change and your text may still overlap
the end of the cell. You have to change the cell width manually or reposition your line break so that 
your text does not overlap the end of the cell.

Shrinking text to fit a cell
The font size of the data in a cell can automatically adjust to fit inside cell borders.

1) Select a cell or cell range.

2) Right-click on the selection and select Format Cells from the context menu, or go to 
Format > Cells on the menu bar, or press Ctrl+1 to open the Format Cells dialog.

3) Click on the Alignment tab (Figure 35).

4) Under Properties, select Shrink to fit cell size and click OK.

Formatting numbers
Several different number formats can be applied to cells by using icons on the Formatting toolbar 
(highlighted in Figure 36). Select the cell, then click the relevant icon to change the number format.

For more control or to select other number formats, use the Numbers page of the Format Cells 
dialog (Figure 21 on page 42 and “Numbers” on page 42):

• Apply any of the data types in the Category list to the data.

• Control the number of decimal places and leading zeros in Options.

• Enter a custom format code.

• The Language setting controls the local settings for the different formats such as the date 
format and currency symbol.

Figure 36: Number icons on Formatting toolbar

Formatting fonts
To select a font and format it for use in a cell:

1) Select a cell or cell range.

2) Click the small triangle on the right of the Font Name box on the Formatting toolbar 
(highlighted in Figure 37) and select a font from the drop-down list. The font can also be 
changed using the Font page on the Format Cells dialog.

3) Click on the small triangle on the right of the Font Size box on the Formatting toolbar and 
select a font size from the drop-down list. The font size can also be changed using the Font
page on the Format Cells dialog.

4) To change the character format, click on the Bold, Italic, or Underline icons.

5) To change the paragraph alignment of the font, click on one of the four alignment icons 

(Left, Centre, Right, Justified) .
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Figure 37: Font Name and Size on Formatting toolbar

Note

To specify the language used in the cell, open the Font page on the Format Cells 
dialog. Changing language in a cell allows different languages to exist within the 
same document. For more changes to font characteristics, see “Font effects” 
below for more information.

Tip

To choose whether to show the font names in their font or in plain text, go to Tools
> Options > LibreOffice > View and select or deselect the Show preview of fonts 
option in the Font Lists section. For more information, see Chapter 14 Setting Up 
and Customizing Calc.

Font effects
1) Select a cell or cell range.

2) Right-click on the selection and select Format Cells from the context menu, or go to 
Format > Cells on the menu bar, or press Ctrl+1 to open the Format Cells dialog.

3) Click on the Font Effects tab (Figure 38).

4) Select the font effect you want to use from the options available. The options available are 
described below.

5) Click OK to apply the font effects and close the dialog.

Figure 38: Format Cells dialog – Font Effects page

Any font effect changes are applied to the current selection, or to the entire word that contains the 
cursor, or to any new text that you type.

• Font Color – sets the color for the selected text. If you select Automatic, the text color is 
set to black for light backgrounds and to white for dark backgrounds. Also yo can change 
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the font color by clicking on the triangle to right of the Font Color icon  to display the 
color palette, then select the desired color.

• Relief – select a relief effect to apply to the selected text. The embossed relief makes the 
characters appear as if they are raised above the page. The engraved relief makes the 
characters appear as if they are pressed into the page.

• Outline – displays the outline of the selected characters. This effect does not work with 
every font.

• Shadow – adds a shadow that casts below and to the right of the selected characters.

• Overlining – select the overlining style that you want to apply. To apply overlining to words 
only, select Individual Words.

• Overline color – select the color for the overlining.

• Strikethrough – select a strikethrough style for the selected text. If you save your 
document in MS Word format, all of the strikethrough styles are converted to the single line 
style.

• Underlining – select the underlining style that you want to apply. To apply the underlining 
to words only, select Individual Words. If you apply underlining to a superscript text, the 
underlining is raised to the level of the superscript. If the superscript is contained in a word 
with normal text, the underlining is not raised.

• Underline color – select the color for the underlining.

• Individual words – applies the selected font effect only to words and ignores spaces.

• Emphasis mark – select a character to display over or below the entire length of the 
selected text.

• Position – specify where to display the emphasis marks.

• Preview – displays a preview of the current selection.

Text direction
To change the text direction within a cell, you can use the Alignment page on the Format Cells 
dialog (Figure 35 on page 57) or the icons on the Formatting toolbar.

1) On the Alignment page of the Format Cells dialog, select the Reference edge from which 
to rotate the text as follows:

• Text Extension From Lower Cell Border – writes the rotated text from the bottom cell 
edge outwards.

• Text Extension From Upper Cell Border – writes the rotated text from the top cell edge 
outwards.

• Text Extension Inside Cells – writes the rotated text only within the cell.

2) Click on the small indicator at the edge of the Text orientation dial and rotate it until you 
reach the required degrees.

3) Alternatively, enter the number of degrees to rotate the text in the Degrees box.

4) Select Vertically stacked to make the text appear vertically in the cell. Only select Asian 
layout mode if you are using an Asian language in the cell.

5) The icons on the Formatting toolbar can be used as follows after the cell has been 
selected:

• To change the text direction from horizontal (default direction) to vertical, click on the 

Text direction from top to bottom icon .

Chapter 2  Entering, Editing, and Formatting Data 60



• To change text direction from vertical to horizontal (default), click on the Text direction 

from left to right icon .

• To change text direction from left to right, which is the default direction for Western 
fonts, to a right to left direction used in some fonts, for example Arabic, the click on the 

Right-To-Left icon . This only works if a font has been used that requires a right to 
left direction.

• To change text direction back to the default left to right direction used for Western fonts, 

click on the Left-To-Right icon .

Note
If the text direction icons are not available on the Formatting toolbar, then right-
click in an empty area on the toolbar and select Visible Buttons from the context 
menu. Click on the icon you require and it will be placed on the Formatting toolbar.

Formatting cell borders
To format the borders of a cell or a group of selected cells (see Chapter 4 Using Styles and 
Templates in Calc for more information). The border icons on the Formatting toolbar only apply the 
default styles to borders, but the  Format Cells dialog provides greater control over of how the cell 
borders will look.

Figure 39: Format Cells dialog – Borders page

1) Select a cell or a range of cells.

2) Right-click on the selection and select Format Cells from the context menu, or go to 
Format > Cells on the menu bar, or press Ctrl+1 to open the Format Cells dialog.

3) Click on the Borders tab (Figure 39).

4) Select the options from the Borders page. The options available are given below.

5) Click OK to close the dialog and save your changes.
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6) Alternatively, use the icons on the Formatting to apply default styles to borders.

a) Click on the Borders icon  and select one of the border options displayed in the Borders
palette.

b) Click on the Border Style icon  and select one of the line styles from the Border Style 
palette.

c) Click on the Line Color icon  and select a color from Border Color palette.

Note

Cell border properties apply only to the selected cells and can only be changed if 
you are editing those cells. For example, if cell C3 has a top border, that border 
can only be removed by selecting C3. It cannot be removed in C2 it appears to be 
the bottom border for cell C2.

Note
When entering borders with the Border icons on the Formatting toolbar, you have 
two choices: click the required icon to add a border to the present borders or shift-
click to add a border and remove the present borders.

The border options available in the Format Cells dialog are as follows.

• Line arrangement – select the style of cell borders.

– Default – select a predefined border style to apply.

– User defined – click on the diagram to apply a border to one of the edges or diagonal 
lines across the cell.

• Line – select the line style for the cell borders.

– Style – select the line style to be used for the border.

– Width – enter a width to be used for the border line.

– Color – select a color to be used for the border line.

• Spacing to contents – specify the amount of space that you want to leave between the 
border and the contents of the selection.

– Left – enter the distance between the left border and the contents of the selection.

– Right – enter the distance between the right border and the contents of the selection.

– Top – enter the distance between the top border and the contents of the selection.

– Bottom – enter the distance between the bottom border and the contents of the 
selection.

– Synchronize – applies the same spacing to contents setting to all four borders when 
you enter a new distance.

• Shadow style – applies a shadow effect to borders. For the best results, only apply this 
effect when all four borders are visible.

– Position – select a shadow style for the selected borders.

– Distance – enter the width of the shadow.

– Color – select a color for the shadow.
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Formatting cell backgrounds
To format the background color for a cell or a group of cells (see Chapter 4 Using Styles and 
Templates in Calc for more information):

1) Select a cell or a range of cells.

2) Right-click on the selection and select Format Cells from the context menu, or go to 
Format > Cells on the menu bar, or press Ctrl+1 to open the Format Cells dialog.

3) Click on the Background tab.

4) Select a color from the color palette.

5) Click OK to save your changes and close the dialog.

6) Alternatively, click on the Background Color icon  on the Formatting toolbar and select
a color from the Background color palette.

AutoFormat of cells and sheets

Using AutoFormat
You can use AutoFormat to format a group of cells.

1) Select the cells in at least three columns and rows, including column and row headers, that 
you want to format.

2) Go to Format > AutoFormat on the menu bar to open the AutoFormat dialog (Figure 40).

3) Select the type of format and format color from the list 

4) If necessary, click More to open Formatting if it is not visible.

5) Select the formatting properties to be included in the AutoFormat function.

6) Click OK to apply the changes and close the dialog.

Figure 40: AutoFormat dialog

Defining a new AutoFormat
You can define a new AutoFormat so that it becomes available for use in all spreadsheets.

1) Format the data type, font, font size, cell borders, cell background, and so on for a group of
cells.
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2) Go to Edit > Select All on the menu bar to select the whole spreadsheet.

3) Go to Format > AutoFormat to open the AutoFormat dialog and the Add button is now 
active.

4) Click Add.

5) In the Name box of the Add AutoFormat dialog that opens, type a meaningful name for the 
new format and click OK.

6) Click OK to close the dialog. The new AutoFormat is now available in the Format list in the 
AutoFormat dialog.

Using themes

Calc comes with a predefined set of formatting themes that you can apply to spreadsheets. It is not
possible to add themes to Calc and they cannot be modified. You can modify their styles after you 
apply them to a spreadsheet, but the modified styles are only available for use for that spreadsheet
when you save the spreadsheet.

Figure 41: Theme Selection dialog

To apply a theme to a spreadsheet:

1) Click the Choose Themes icon  in the Tools toolbar to open the Theme Selection 
dialog (Figure 41). If the Tools toolbar is not visible, go to View > Toolbars on the menu bar
and select Tools. The Theme Selection dialog lists the available themes for the whole 
spreadsheet.

2) Select the theme that you want to apply. As soon as you select a theme, the theme styles 
are applied to the spreadsheet and are immediately visible.

3) Click OK.

4) If you wish, you can now open the Styles and Formatting window to modify specific styles. 
These modifications do not modify the theme; they only change the appearance of the style
in the specific spreadsheet you are creating. For more about modifying styles, see Chapter 
4 Using Styles and Templates in Calc.
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Value highlighting

The value highlighting function displays cell contents in different colors, depending on the type of 
content. An example of value highlighting is shown in Figure 42.

• Text is shown in black.

• Formulas are shown in green.

• Numbers are shown in blue.

Figure 42: Example of value highlighting

The value highlighting colors override any colors used in formatting. This color change applies only
to the colors seen on a display. When a spreadsheet is printed, the original colors used for 
formatting are printed.

Go to View > Value Highlighting on the menu bar, or use the keyboard shortcut Ctrl+F8 to turn 
the function on or off. When value highlighting is switched off, the original formatting colors are 
used for display.

You can make value highlighting the default when opening a spreadsheet in Calc, by selecting 
Tools > Options > LibreOffice Calc > View > Value Highlighting. This default mode for value 
highlighting may not be what you want if you are going to format the cells for printing.

Using conditional formatting

You can set up cell formats to change depending on conditions that you specify. Conditional 
formatting is used to highlight data that is outside the specifications that you have set. It is 
recommended not to overuse conditional formatting as this could reduce the impact of data that 
falls outside the specifications that you have set.

See “Conditional formatting example” on page 68 for an example on how to use conditional 
formatting.

Note
Conditional formatting depends upon the use of styles and the AutoCalculate 
feature must be enabled. If you are not familiar with styles, see Chapter 4 Using 
Styles and Templates in Calc for more information.

Setting up conditional formatting
1) Ensure that AutoCalculate is enabled: Tools > Cell Contents > AutoCalculate.

2) Select the cells where you want to apply conditional formatting.

Figure 43: Conditional Formatting dialog – Condition
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3) Go to Format > Conditional Formatting > Condition (Figure 43), Color scale (Figure 44)
or Data Bar (Figure 45) on the menu bar to open the Conditional Formatting dialog. Any 
conditions already defined are displayed.

4) Click Add to create and define a new condition. Repeat this step as necessary.

5) Select a style from the styles already defined in the Apply Style drop-down list. Repeat this 
step as necessary.

6) Alternatively, select New Style to open the Cell Style dialog (Figure 46) and create a new 
cell style. Repeat this step as necessary.

7) Click OK to save the conditions and close the dialog. The selected cells are now set to 
apply a result using conditional formatting.

Figure 44: Conditional Formatting dialog – Color Scale

Figure 45: Conditional Formatting dialog – Data Bar

Figure 46: Cell Style dialog
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Types of conditional formatting

Condition
Condition is the starting point when using conditional formatting. Here you can define what formats 
to use to highlight any data in your spreadsheet that falls outside the specifications that you have 
defined.

Color scale
Use Color scale to set the background color of cells depending on the value of the data in a 
spreadsheet cell. Color scale can only be used when All Cells has been selected for the condition.
You can use either two or three colors for your color scale.

Data bars
Data bars provide a graphical representation of data in your spreadsheet. The graphical 
representation is based on the values of data in a selected range. Click on More Options in the 
Conditional Formatting dialog to define how your data bars will look. Data bars can only be used 
when All Cells has been selected for the condition.

Icon sets
Icon sets display an icon next to your data in each selected cell to give a visual representation of 
where the cell data falls within the defined range that you set. The icons sets available are colored 
arrows, gray arrows, colored flags, colored signs, symbols, bar ratings and quarters. Icon sets can 
only be accessed when the Conditional Formatting dialog has been opened and All Cells has 
been selected for the condition.

Conditional formatting management
To see all the conditional formatting defined in your spreadsheet and any styles used:

1) Go to Format > Conditional Formatting > Manage on the menu bar to open the Manage 
Conditional Formatting dialog (Figure 47).

2) Select a range from the Range list and click Edit to redefine the conditional formatting.

3) Select a range from the Range list and click Remove to delete the conditional formatting. 
The deletion is immediate with no confirmation.

4) Select Add to create a new definition of conditional formatting.

5) Click OK to save your changes and close the dialog.

Figure 47: Manage Conditional Formatting dialog
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Copying cell styles
To apply the style used for conditional formatting to other cells later:

1) Click one of the cells that has been assigned conditional formatting and copy the cell to the 
clipboard.

2) Select the cells that are to receive the same formatting as the copied cell.

3) Go to Edit > Paste Special on the menu bar to open the Paste Special dialog (Figure 34 
on page 55).

4) Make sure that only Formats is selected and click OK to paste the conditional formatting 
into the cell.

Conditional formatting example
With conditional formatting, you can, for example, highlight the totals that exceed the average 
value of all totals. If the totals change, the formatting changes correspondingly, without having to 
apply other styles manually. It is recommended that the Styles and Formatting dialog is open and 
visible before proceeding.

Defining conditions
1) Select the cells where you want to apply a conditional style.

2) Go to Format > Conditional Formatting > Condition, Color scale or Data bar from the 
menu bar to open the Conditional Formatting dialog.

3) Enter the conditions you want to use for conditional formatting.

Generating number values
You may want to give certain values in your tables particular emphasis. For example, in a table of 
turnovers, you can show all the values above the average in green and all those below the average
in red. This is possible with conditional formatting.

1) Create a table in which a few different values occur. For your test you can create tables 
with any random numbers. In one of the cells enter the formula =RAND(), and you will 
obtain a random number between 0 and 1. If you want integers of between 0 and 50, enter 
the formula =INT(RAND()*50).

2) Copy the formula to create a row of random numbers.

3) Click the bottom right corner of the selected cell, and drag to the right and downward until 
the desired cell range is selected.

Defining cell styles
The next step is to apply a cell style to all values that represent above-average turnover and one to
cells that are below the average.

1) Right-click in a blank cell and select Format Cells in the context menu to open the Format 
Cells dialog.

2) Click the Background tab and select a background color, then click OK.

3) In the Conditional Formatting dialog, select New Style from the Apply Style drop-down list 
to open the Cell Style dialog.

4) Enter a name of the new style. For this example, name the style Above.

5) Define a second style, click again in a blank cell and proceed as described above. Assign a
different background color to the cell and assign a name. For this example, name the style 
Below.

Chapter 2  Entering, Editing, and Formatting Data 68



Calculating average
In our particular example, we are calculating the average of the random values. The result is 
placed in a cell:

1) Click in a blank cell, for example, J14, and go to Insert > Function on the menu bar, or 
click the Function Wizard icon on the Formula bar to open the Function Wizard dialog.

2) Select AVERAGE from the Function list.

3) Use the cursor to select all your random numbers.

4) Click OK to the Function Wizard.

Applying cell styles
Now you can apply the conditional formatting to the sheet:

1) Select all cells containing the random numbers.

2) Go to the Format > Conditional Formatting on the menu bar to open the Conditional 
Formatting dialog.

3) Define the condition for each cell as follows: if cell value is less than J14, format with cell 
style Below OR if cell value is greater than or equal to J14, format with cell style Above.

Hiding and showing data

In Calc you can hide elements so that they are neither visible on a computer display nor printed 
when a spreadsheet is printed. However, hidden elements can still be selected for copying if you 
select the elements around them; for example, if column B is hidden, it is copied when you select 
columns A and C. When you require a hidden element again, you can reverse the process and 
show the element.

Hiding data

Sheets, rows, and columns
1) Select the sheet, row, or column you want to hide.

2) Go to Format on the main menu bar and select Sheet, Row or Column.

3) Select Hide from the menu and the sheet, row, or column can no longer viewed or printed. 
Alternatively, right-click on the sheet tab, row header, or column header and select Hide 
from the context menu.

Cells
1) Go to Tools > Protect Document > Sheet on the menu bar to open the Protect Sheet 

dialog dialog (Figure 48).

2) Select Protect this sheet and the contents of protected cells.

3) Create a password and then confirm the password.

4) Select or deselect the options for Allow all users of this sheet to: so users can select 
protected or unprotected cells.

5) Click OK to save the changes and close the dialog.

6) Select the cells you want to hide.

7) Go to Format > Cells on the menu bar, or right-click and select Format Cells from the 
context menu, or use the keyboard shortcut Ctrl+1 to open the Format Cells dialog (Figure
49).

8) Click the Cell Protection tab and select an option for hiding and printing the cells.

9) Click OK to save the changes and close the dialog.
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Figure 48: Protect Sheet dialog

Figure 49: Format Cells dialog – Cell Protection page

Note
When data in cells are hidden, it is only the data contained in the cells that are 
hidden and the protected cells cannot be modified. The blank cells remain visible 
in the spreadsheet.

Note
When data in cells are hidden, it is only the data contained in the cells that are 
hidden and the protected cells cannot be modified. The blank cells remain visible 
in the spreadsheet.

Showing data

Sheets, rows, and columns
1) Select the sheets, rows or columns each side of the hidden sheet, row or column.

2) Go to Format on the menu bar and select Sheet, Row or Column.

3) Select Show from the context menu and the sheet, row or column will be displayed and 
can be printed.

4) Alternatively, right-click on the sheet tabs, row headers or column headers and select 
Show from the context menu.

Cells
1) Go to Tools > Protect Document > Sheet on the menu bar to open the Protect Sheet 

dialog dialog (Figure 48).

2) Enter the password to unprotect the sheet and click OK.
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3) Go to Format > Cells on the menu bar, or right-click and select Format Cells from the 
context menu, or use the keyboard shortcut Ctrl+1 to open the Format Cells dialog (Figure
49).

4) Click the Cell Protection tab and deselect the hide options for the cells.

5) Click OK.

Group and outline
If you are continually hiding and showing the same cells, you can create an outline of your data 
and group rows or columns together so that you can collapse a group to hide it or expand a group 
to show it using a single click.

The basic controls for grouping and outlining show plus (+) or minus (-) signs on the group 
indicator to show or hide rows or columns. However, if there are groups nested within each other, 
the basic controls have numbered buttons so you can hide the different levels of nested groups.

Grouping
To group rows or columns:

1) Select the cells you want to group in your spreadsheet.

2) Go to Data > Group and Outline > Group on the menu bar, or press the F12 key.

3) In the Group dialog that opens, select either Rows or Columns and click OK. A group 
indicator appears to the left of any rows grouped or above any columns grouped. Figure 50 
shows a group indicator on the left of the first two rows of the spreadsheet have been 
grouped.

Figure 50: Group indicator

Hiding details
To hide the details of any group of rows or columns:

1) Click on the minus (-) sign on the group indicator.

2) Alternatively, select a cell within the group and go to Data > Group and Outline > Hide 
Details on the menu bar.

3) The rows or columns are hidden and the minus (-) sign becomes a plus (+) sign on the 
group indicator.

Showing details
To show the details of any hidden groups or rows or columns:

1) Click on the plus (+) sign on the group indicator.

2) Alternatively, select a cell on each side of the hidden group and go to Data > Group and 
Outline > Show Details on the menu bar.
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3) The hidden rows or columns are displayed and the plus (+) sign becomes a minus (-) sign 
on the group indicator.

Ungrouping
To ungroup any groups of rows or columns:

1) Make sure the grouped rows or columns are displayed.

2) Go to Data > Group and Outline > Ungroup on the menu bar, or use the keyboard 
combination Ctrl+F12.

3) Select either Rows or Columns to ungroup and click OK.

Note
Any hidden groups of rows or columns must be displayed. If they are hidden, then 
the grouped rows or columns are deleted from your spreadsheet.

Note
If there are nested groups, only the last group of rows or columns created is 
ungrouped.

AutoOutline
If a selected cell range contains formulas or references, Calc automatically outlines the selection. 
For example, in Figure 51 the cells for the 1st and 2nd quarters each contain a sum formula for the
three cells to their left. If you apply the AutoOutline command, the columns are grouped into two 
quarters.

To apply the AutoOutline function, go to Data > Group and Outline > AutoOutline on the menu 
bar. Calc will then check for cells that contain formulas or references and automatically group the 
cells as necessary.

Figure 51: Example of AutoOutline

Removing
To remove any cell groups of rows or columns, go to Data > Group and Outline > Remove on the
menu bar and any groups are removed.

Any cell group of rows or columns that are hidden, the grouping is removed from the cells and the 
cells are displayed in your spreadsheet.

Filtering
A filter is a list of conditions that each entry has to meet to be displayed. Calc provides three types 
of filter:

• Standard – specifies the logical conditions to filter your data.
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• AutoFilter – filters data according to a specific value or string. Automatically filters the 
selected cell range and creates one-row list boxes where you can choose the items that 
you want to display.

• Advanced –  uses filter criteria from specified cells.

Applying a standard filter
A standard filter is more complex than AutoFilter. You can set as many as eight conditions as a 
filter, combining them with the operators AND or OR. Standard filters are mostly useful for 
numbers, although a few of the conditional operators can also be used for text.

1) Select a cell range in your spreadsheet.

2) Go to Data > Filter > Standard Filter on the menu bar to open the Standard Filter dialog 
(Figure 52).

3) Specify the filter criteria and filtering options that you want to use.

4) Click OK to carry out standard filtering and close the dialog. Any records that match the 
filter criteria and options that you specified are shown.

Figure 52: Standard Filter dialog

The filter criteria used in standard filtering defines a filter by indicating the type of line, the name of 
the field, a logical condition and a value or a combination of arguments.

• Operator – for the following arguments, you can choose between the logical operators 
AND / OR.

• Field name – specifies the field names from the current table to set them in the argument. 
You will see the column identifiers if no text is available for the field names.

• Condition – specifies the comparative operators through which the entries in the Field 
name and Value fields can be linked.

• Value – specifies a value to filter the field. The Value list box contains all possible values 
for the specified Field name. Select a value to be used in the filter, including Empty and 
Not Empty entries.

• Case sensitive – distinguishes between uppercase and lowercase letters when filtering the
data.
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• Range contains column labels – includes the column labels in the first row of a cell 
range.

• Copy results to – select the check box and then select the cell range where you want to 
display the filter results. You can also select a named range from the list.

• Regular expression – select to use wildcards in the filter definition. See LibreOffice Help 
for a list of the regular expressions that LibreOffice supports. If selected, you can use 
regular expressions in the Value field if the Condition list box is set to '=' EQUAL or '<>' 
UNEQUAL. This also applies to the respective cells that you reference for an advanced 
filter.

• No duplication – excludes duplicate rows from the list of filtered data.

• Keep filter criteria – select Copy results to and then specify the destination range where 
you want to display the filtered data. If this box is checked, the destination range remains 
linked to the source range. You must have defined the source range under Data > Define 
range as a database range. You can also reapply the defined filter at any time by clicking 
into the source range and then go to Data > Refresh Range.

Figure 53: AutoFilter example

Applying an AutoFilter
An AutoFilter adds a drop-down list to the top row of one or more data columns which lets you 
select the rows to be displayed. The list includes every unique entry in the selected cells sorted 
into lexical order (see http://sheepsystems.com/bookdog/HelpBook/LexicalOrder.html for an 
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explanation of lexical order). AutoFilter can be used on multiple sheets without first defining a 
database range.

1) Click in a cell range on your spreadsheet. If you want to apply multiple AutoFilters to the 
same sheet, you must first define database ranges, then apply the AutoFilters to the 
database ranges.

2) Go to Data > Filter > AutoFilter on the menu bar. An arrow button is added to the head of 
each column in the database range.

3) Click the arrow or small triangle in the column that contains the value or string that you 
want to set as the filter criteria (shown in Figure 53).

4) Select the value or string that you want to use as the filter criteria. The records that match 
the filter criteria that you selected are then shown.

Applying an advanced filter
An advanced filter has a structure similar to a standard filter. The difference is that the  Advanced 
Filter arguments are not entered in a dialog. Instead, filters can be entered in a blank area of a 
spreadsheet, then referenced by the filter dialog to apply the filters.

1) Select a cell range in your spreadsheet.

2) Go to Data > Filter > Advanced Filter on the menu bar to open the Advanced Filter dialog 
(Figure 54).

3) In Read filter criteria from, select the named range, or enter the cell range that contains the 
filter criteria that you want to use 

4) Click OK to carry out advanced filtering and close the dialog. Any records that match the 
filter criteria and options that you specified are shown.

Figure 54: Advanced Filter dialog

Note
The options for advanced filtering are the same as those used for standard 
filtering, see “Applying a standard filter” on page 73 for more information.

Sorting records

Sorting within Calc arranges the cells in a sheet using the sort criteria that you specify. Several 
criteria can be used and a sort applies each criteria consecutively. Sorts are useful when you are 
searching for a particular item and become even more useful after you have filtered data.

Also, sorting is useful when you add new information to a spreadsheet. When a spreadsheet is 
long, it is usually easier to add new information at the bottom of the sheet, rather than adding rows 
in their correct place. After you have added information, you can then sort the records to update 
the spreadsheet.

Chapter 2  Entering, Editing, and Formatting Data 75



Sort dialog
To sort cells in a spreadsheet using the Sort dialog (Figure 55):

1) Select the cells to be sorted.

2) Go to Data > Sort on the menu bar to open the Sort dialog. Make sure the Sort Criteria 
page is open.

3) Select the sort criteria from the drop-down lists. The selected lists are populated from the 
selected cells.

4) Select either ascending order (A-Z, 1-9) or descending order (Z-A, 9-1).

5) Click OK and the sort is carried out on your spreadsheet.

Figure 55: Sort dialog – Sort Criteria page

Figure 56: Sort dialog – Options page

Sort options
On the Options page of the Sort dialog (Figure 56), you can set additional options:

• Case Sensitivity – sorts first by uppercase letters and then by lowercase letters. For Asian
languages, special handling applies.
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Note

For Asian languages, select Case Sensitivity to apply multi-level collation. With 
multi-level collation, entries are first compared in their primitive forms with their 
cases and diacritics ignored. If they evaluate as the same, their diacritics are taken
into account for the second-level comparison. If they still evaluate as the same, 
their cases, character widths, and Japanese Kana difference are considered for 
the third-level comparison.

• Range contains column/row labels – omits the first row or the first column in the 
selection from the sort. The Direction setting at the bottom of the dialog defines the name 
and function of this check box.

• Include formats – preserves the current cell formatting.

• Enable natural sort – natural sorting is a sort algorithm that sorts string-prefixed numbers 
based on the value of the numerical element in each sorted number, instead of the 
traditional way of sorting them as ordinary strings. For instance, assume you have a series 
of values such as, A1, A2, A3, A4, A5, A6, ..., A19, A20, A21. When you put these values 
into a range of cells and run the sort, it will become A1, A11, A12, A13, ..., A19, A2, A20, 
A21, A3, A4, A5, ..., A9. While this sorting behavior may make sense to those who 
understand the underlying sorting mechanism, to the rest of the population it seems 
completely bizarre, if not outright inconvenient. With natural sorting selected, values such 
as the ones in the above example are sorted correctly, which improves the convenience of 
sorting operations in general.

• Copy sort results to – copies the sorted list to the cell range that you specify. Select a 
named cell range where you want to display the sorted list, or enter a cell range in the input
box.

• Custom sort order – select this option and then select the custom sort order that you want
to apply. To define a custom sort order, go to LibreOffice > Preferences > LibreOffice 
Calc > Sort Lists.

• Language – select the language for the sorting rules.

• Options – select a sorting option for the language. For example, select the "phonebook" 
option for German to include the umlaut special character in the sorting.

• Top to Bottom (Sort Rows) – sorts rows by the values in the active columns of the 
selected range.

• Left to Right (Sort Columns) – sorts columns by the values in the active rows of the 
selected range.

Quick sort
If the columns in your spreadsheet have a header with a text format, you can use a quick sort.

1) Select a cell or a cell range to be sorted.

2) Click the Sort Ascending  or Sort Descending  icons on the Standard toolbar.

Find and replace

Calc has two ways to find text within a document: the Find toolbar and the Find & Replace dialog.

Figure 57: Find toolbar
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Find toolbar
1) Go to View > Toolbars > Find on the menu bar, or go to Edit > Find on the menu bar, or 

use the keyboard shortcut Ctrl+F to open the Find toolbar (Figure 57). By default the Find 
toolbar is docked in the lower left-corner of the Calc window. You can undock the toolbar 
and move it to where you choose.

2) Type a search term in the Find box.

3) Select Match Case to refine your search. For example, Owner is your search term and 
selecting Match Case will only find Owner and will not find owner.

4) Click the Find Next  or Find Previous  icons. To find other occurrences of the same 
term, continue clicking the icon.

Find & Replace dialog

Figure 58: Find & Replace dialog
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Finding
1) Go to Edit > Find & Replace on the menu bar, or use the keyboard shortcut Ctrl+H, or 

select the Find & Replace  icon on the Find toolbar to open the Find & Replace dialog 
(Figure 58).

2) Enter or select the search criteria in the Search for box.

3) If necessary, click on Other Options so that you can increase the number of search filters 
that you can apply to your search.

4) Click Find to locate the first instance of the search criteria you entered.

5) Click Find again to locate the next instance of your search criteria.

6) Click Find All to locate all instances of your search criteria. The instances of your search 
criteria will be highlighted in the spreadsheet.

Replacing
1) Go to Edit > Find & Replace on the menu bar, or use the keyboard shortcut Ctrl+H, or 

select the Find & Replace  icon on the Find toolbar to open the Find & Replace dialog 
(Figure 58).

2) Enter or select the search criteria in the Search for box.

3) Enter or select the replace criteria in the Replace with box.

4) If necessary, click on Other Options so that you can increase the number of search filters 
that you can apply to your find and replace.

5) Click Replace to locate and replace the first instance of the search criteria you entered with
your replacement criteria.

6) Click Replace again to locate and replace the next instance of the search criteria you 
entered with your replacement criteria.

7) Click Replace All to locate and replace all instances of the search criteria you entered with 
your replacement criteria.

Note
Use Replace All with caution; otherwise, you may end up with some highly 
embarrassing mistakes. A mistake with Replace All might require a manual, word-
by-word search to fix, if it is not discovered in time to undo it.

Find & Replace options
The options available to refine your find and replace are as follows:

• Search for – enter the text that you want to search for, or select a previous search from the
list.

• Replace with – enter the replacement text, or select a recent replacement text or style 
from the list.

• Match case – distinguishes between uppercase and lowercase characters.

• Entire Cells – searches for whole words or cells that are identical to the search text.

• Current selection only – searches only the selected text or cells.

• Backwards – search starts at the current cursor position and goes backwards to the 
beginning of the file.

• Regular expressions – select to use wildcards in your search. See LibreOffice Help for 
more information on the use of regular expressions.

• Similarity Search – find terms that are similar to the Search for text. Select this checkbox,
and then click the ... button to define the similarity options.
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• Search for Styles – searches for text formatted with the style that you specify. Select this 
option and then select a style from the Search for list. To specify a replacement style, 
select a style from the Replace with list.

• Match character width – distinguishes between half-width and full-width character forms; 
only available if Asian languages are enabled.

• Sounds like (Japanese) – specify the search options for similar notation used in Japanese
text. Select this option, and then click the ... button to specify the search options. This 
option is only available if Asian languages are enabled.

• Search in – select either Formulas, Values, or Notes to search for the characters that you 
specify in values, in the results of formulas, or in notes.

• Search direction – determines the order for searching the cells. 

• Search in all sheets – searches through all of the sheets in the current spreadsheet file.
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Introduction

Charts and graphs can be powerful ways to convey information to the reader. LibreOffice Calc 
offers a variety of different chart and graph formats for your data.

Using Calc, you can customize charts and graphs to a considerable extent. Many of these options 
enable you to present your information in the best and clearest manner.

For readers who are interested in effective ways to present information graphically, two excellent 
introductions to the topic are William S. Cleveland’s The elements of graphing data, 2nd edition, 
Hobart Press (1994) and Edward R. Tufte’s The Visual Display of Quantitative Information, 2nd 
edition, Graphics Press (2001).

Chart Wizard

Calc uses a Chart Wizard to create charts or graphs from your spreadsheet data. After the chart 
has been created as an object in your spreadsheet, you can then change the chart type, adjust 
data ranges and the edit the chart using the functions available in the Chart Wizard. Each change 
you make using is automatically reflected in the chart object placed onto your spreadsheet. This is 
described in the following sections.

Creating charts and graphs
To demonstrate the process of creating charts and graphs in Calc, we will use example data as 
shown in Figure 59 to create a chart.

Figure 59: Example data for creating a chart

1) Select the cells containing the data to be included in the chart by highlighting (Figure 59). 
The selection does not need to be in a single block as in Figure 59; you can also choose 
individual cells or groups of cells (columns or rows). See Chapter 1 Introducing Calc for 
more information about selecting cells and ranges of cells.

2) Go to Insert > Chart on the main menu bar, or click the Chart icon  on the Standard 
toolbar to open the Chart Wizard dialog (Figure 60). A sample chart is created using the 
selected data and is placed onto the spreadsheet as an object (Figure 61).
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Figure 60: Chart Wizard dialog – selecting chart type

Figure 61: Example chart automatically created using Chart Wizard

Note

If you want to plot any unconnected rows or columns of data, select the first data 
series, then hold down the Ctrl key and select the next series. The two data series 
you are selecting must be in separate columns or rows. Otherwise Calc will assume 
that you are adding to the same data series.

Tip

Before opening the Chart Wizard, place the cursor or select a cell anywhere in the 
area of the data. The Chart Wizard will then guess the range of the data to create a 
sample chart. Just be careful that you have not included the title of your chart when 
you make your selection.
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Selecting chart type
Calc offers a choice of ten basic chart types and the options available vary according to the type of 
chart you select.

The initial chart created using the Chart Wizard is a normal column chart and by default it is a 2D 
chart. This is highlighted with a surrounding border in the preview box in Figure 60 and the chart 
name is shown below the preview.

To change the chart type:

1) Select the type of chart from the list in Choose a chart type (Figure 60).

2) Select a chart icon in the preview box and check to see if it is the chart type you require. 
For more information on chart types, see “Gallery of chart types” on page 108.

3) For Column, Bar, Pie or Area chart types only and if you want to use a 3D chart, select the 
checkbox 3D Look and select the type of 3D view for your chart (Realistic or Simple).

4) Select the options you want to use for your chart. The options available are dependent of 
the type of chart selected.

5) Click Next>> to move onto the next step in creating an example chart and make changes 
to the data range and axes labels (Figure 62).

6) If you are satisfied with your chart, click Finish to close the Chart Wizard and create an 
example chart object on your spreadsheet.

Note
To demonstrate the process of creating charts using the following sections, please 
leave the chart type as 2D column normal.

Figure 62: Chart Wizard dialog – selecting data range

Data range and axes labels
In the Data Range step of the Chart Wizard (Figure 62), you can manually correct any mistakes 
you have made in selecting the data for your chart, how your chart is plotted and how to label your 
chart.

1) If necessary, change the rows and columns used as data for your chart by editing the cell 
references in the Data range text box.

Chapter 3  Creating Charts and Graphs 84



2) Select whether to plot chart data by using either rows or columns as the data series. This is
useful if you use a chart type such as Donut or Pie to display your data.

3) Select whether to use the first row, or first column, or both, as labels for the axes of the 
chart.

4) Click Next>> to move onto the next step in creating an example chart and make changes 
to the data series (Figure 63).

5) If you are satisfied with your chart, click Finish to close the Chart Wizard and create an 
example chart object on your spreadsheet.

Note

A data range may consist of more than one region in a spreadsheet, for example 
"$Sheet1.A1:A5;$Sheet1.D1:D5" is also a valid data range.

If you want a data range of multiple cell areas that are not next to each other, enter 
the first range, then manually add a semicolon at the end of the text box, then enter 
the other ranges. Use a semicolon as delimiter between ranges.

Figure 63: Chart Wizard dialog – selecting data series

Data series
On the Data Series page of the Chart Wizard (Figure 63) you can change the source range of all 
data series separately, including their labels. You can also change the range of the categories and 
remove unnecessary data series or add data series from other cells.

Each named data series has its ranges and its individual Y-values listed. This is useful if you have 
very specific requirements for data in your chart, as you can include or leave out these ranges.

In the Data series list box you see a list of all data series in the current chart.

1) To organize the data series, select an entry in the Data series list.

2) Click Add to add another data series below the selected entry. The new data series has the
same type as the selected entry.

3) Click Remove to remove the selected entry from the Data series list.

4) Use the Up and Down buttons to move the selected entry in the list up or down. This does 
not change the order in the data source table, but changes only the arrangement in the 
chart.
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5) To change the cell reference that is used to name a data series, select an entry in the Data 
series list and edit the cell reference in the Range for Name text box.

6) To change the cell reference that is to give a category in a data series, select an entry in 
the Data series list and edit the cell reference in the Categories text box.

7) Click Next>> to move onto the next step in creating an example chart and make changes 
to the chart elements (Figure 65).

8) If you are satisfied with your chart, click Finish to close the Chart Wizard and create an 
example chart object on your spreadsheet.

Figure 64: Chart elements

Chart elements
The chart elements for 2D and 3D charts are shown in Figure 64.

• The chart wall contains the graphic of the chart displaying the data.

• The chart area is the area surrounding the chart graphic.

• The chart floor is only available for 3D charts.

• The chart title and subtitle, chart legend, axes labels and axes names are in the chart area 
and can be added when using the Chart Wizard to create a chart.

On the Chart Elements page (Figure 65), you can add or change the titles, axes names and grids. 
Use a title that draws the attention of viewers to the purpose of the chart and what you want them 
to see. Figure 64 shows the various chart elements that can be placed onto a chart.

1) Enter a title and subtitle you want to use in the Title and Subtitle text boxes. For example, 
a better title for this example chart might be The Performance of Motor and Other Rental 
Boats.

2) Enter a name you want to use in the X axis and Y axis text boxes, for example, 
Thousands for the Y axis. The Z axis text box is only active if you are creating a 3D chart.

3) Select the Display legend checkbox and where you want the legend displayed on your 
chart – Left, Right, Top or Bottom.

4) In Display grids, select the X axis or Y axis checkboxes to display a grid on your chart. The
Z axis checkbox is only active if you are creating a 3D chart. Grid lines are not available for
pie charts.

Chapter 3  Creating Charts and Graphs 86



5) Click Finish to close the Chart Wizard and create an example chart object on your 
spreadsheet.

Figure 65: Chart Wizard dialog – selecting and changing chart elements

Note
Clicking Finish closes the Chart Wizard, but the chart is still in edit mode and you 
can still modify it. Click outside the chart in any cell or a data series to complete the 
chart creation.

Editing charts and graphs

After you have created a chart, you may find that data has changed or you would like to improve 
the look of the chart. Calc provides tools for changing the chart type, chart elements, data ranges, 
fonts, colors, and many other options, and this is described in the following sections.

Changing chart type
You can change the chart type at any time.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > Chart Type on the main menu bar, or click the Chart Type icon  on the
Formatting toolbar, or right-click on the chart and select Chart Type from the context menu 
to open the Chart Type dialog. This is similar to the Chart Wizard dialog shown in Figure 60
on page 84.

3) Select a replacement chart type you want to use. For more information, see “Selecting 
chart type” on page 84.

4) Click OK to close the dialog.

5) Click outside the chart to leave edit mode.
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Editing data ranges or data series
If the data range or data series has changed in your spreadsheet, you can edit them in your chart.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > Data Ranges on the main menu bar, or right-click on the chart and select 
Data Ranges from the context menu to open the Data Ranges dialog. This dialog has 
similar pages to the Chart Wizard dialogs shown in Figure 62 on page 84 and Figure 63 on 
page 85.

3) To edit the data range used for the chart, click on the Data Range tab. For more 
information, see “Data range and axes labels” on page 84.

4) To edit the data series used for the chart, click on the Data Series tab. For more 
information, see “Data series” on page 85.

5) Click OK to close the dialog.

6) Click outside the chart to leave edit mode.

Basic editing of chart elements
Basic editing of the title, subtitle and axes names in your chart is as follows. For more advanced 
editing, see the following sections.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Insert > Titles on the main menu bar, or right-click in the chart area and select Insert
Titles from the context menu to open the Titles dialog. This dialog is similar to the Chart 
Wizard dialog shown in Figure 65 on page 87.

3) Edit the text shown in the various text boxes.

4) Click OK to close the dialog.

5) Click outside the chart to leave edit mode.

Adding or removing chart elements

Titles, subtitles and axes names
Adding a title, subtitle or axes names to your chart is the same procedure as given in “Basic editing
of chart elements” above. To remove a title, subtitle or axes names from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Open the Titles dialog as above and delete the text from the various text boxes.

3) Click OK to close the dialog.

4) Click outside the chart to leave edit mode.

Legends
To add a legend to your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Insert > Legend on the main menu bar to open the Legend dialog. This dialog is 
similar to the Display legend section on the Chart Wizard dialog shown in Figure 65 on 
page 87.

3) Select the Display legend checkbox and where you want the legend displayed on your 
chart – Left, Right, Top or Bottom.
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4) Click OK to close the dialog.

5) Alternatively, right-click in the chart area and select Insert Legend from the context menu 
to insert a legend in the default position on the right side of the chart.

6) Click outside the chart to leave edit mode.

To remove a legend from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Insert > Legend on the main menu bar to open the Legend dialog.

3) Deselect the Display legend checkbox.

4) Click OK to close the dialog.

5) Alternatively, right-click in the chart area and select Delete Legend from the context menu.

6) Click outside the chart to leave edit mode.

Axes
To add an axis to your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Insert > Axes on the main menu bar, or right-click on the chart and select 
Insert/Delete Axes from the context menu to open the Axes dialog (Figure 66).

3) Select the axes checkboxes that you want to use on your chart. The Z axis checkbox is 
only active if you are creating a 3D chart.

4) Click OK to close the dialog.

5) Click outside the chart to leave edit mode.

To remove an axis from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Open the Axes dialog as above and deselect the checkboxes for the axes you want to 
remove.

3) Click OK to close the dialog.

4) Click outside the chart to leave edit mode.

Figure 66: Axes dialog

Grids
The visible grid lines can help to estimate the data values in the chart. The distance of the grid 
lines corresponds to the interval settings in the Scale tab of the axis properties.
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Grid lines are not available for pie charts.

To add a grid to your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Insert > Grids on the main menu bar to open the Grids dialog. This is the same 
dialog as the Axes dialog (Figure 66), but it is titled Grids.

3) Select the grid checkboxes that you want to use on your chart. The Z axis checkbox is only
active if you are creating a 3D chart.

4) Click OK to close the dialog.

5) Click outside the chart to leave edit mode.

To remove a grid from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Open the Grids dialog as above and deselect the checkboxes for the grids you want to 
remove.

3) Click OK to close the dialog.

4) Click outside the chart to leave edit mode.

Data labels
Data labels put information about each data point on the chart. They can be very useful for 
presenting detailed information, but you need to be careful not to create a chart that is too cluttered
to read.

Figure 67: Data Labels dialog

Note
The text for data labels is taken from the spreadsheet data and it cannot be changed 
here. If the text needs to be abbreviated, or if it did not label your graph as you were 
expecting, you need to change it in the original data table.

To add data labels to your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.
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2) Select the data series on your chart that you want to label. If you do not select a data 
series, then all data series on your chart will be labelled.

3) Go to Insert > Data Labels on the menu bar to open the Data Labels dialog (Figure 67).

4) Select the options that you want to use for data labels. The options available for data labels
are explained below.

5) Click OK to close the dialog.

6) Alternatively, right-click on the selected data series and select Insert Data Labels from the 
context menu. This method uses the default setting for the data labels.

7) Click outside the chart to leave edit mode.

To remove data labels from you chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the data labels on your chart that you want to remove.

3) Go to Insert > Data Labels on the menu bar, or right-click on the data labels and select 
Format Data Labels from the context menu to open the Data Labels dialog (Figure 67).

4) Make sure Data Labels page is selected in the dialog and deselect all the options for the 
data labels that you want to remove.

5) Click OK to close the dialog and remove the data labels.

6) Alternatively, right-click on the data series and select Delete Data Labels from the context 
menu.

7) Repeat the above steps to remove more data labels because you can only remove one 
data series at a time.

8) Click outside the chart to leave edit mode.

The options available for data labels in the Data Labels dialog are as follows.

• Show value as number – displays the numeric values of the data points. When selected, 
this option activates the Number format button.

• Number format – opens the Number Format dialog, where you can select the number 
format. This dialog is very similar to the one for formatting numbers in cells, see Chapter 2 
Entering, Editing, and Formatting Data for more information.

• Show value as percentage – displays the percentage value of the data points in each 
column. When selected, this option activates the Percentage format button.

• Percentage format – opens the Number Format dialog, where you can select the 
percentage format. This dialog is very similar to the one for formatting numbers in cells, see
Chapter 2 Entering, Editing, and Formatting Data for more information.

• Show category – shows the data point text labels.

• Show legend key – displays the legend icons next to each data point label.

• Separator – selects the separator between multiple text strings for the same object (if at 
least two options above are selected).

• Placement – selects the placement of data labels relative to the objects.

• Rotate Text – click in the dial to set the text orientation for the data labels or enter the 
rotation angle for the data labels.

• Text Direction – specify the text direction for a paragraph that uses Complex Text Layout 
(CTL). This feature is only available if CTL support is enabled.

Trend lines
When you have a scattered grouping of points in a graph, you may want to show the relationship of
the points by using a trend line. Calc has a good selection of regression types you can use for 
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trend lines: linear, logarithm, exponential, and power. Choose the type that comes closest to 
passing through all of the points.

Trend lines can be added to all 2D chart types except for pie and stock charts. If a data series is 
selected, a trend line is inserted for that data series only. If no data series are selected, trend lines 
are inserted for all data series.

When inserted, trend lines are automatically shown in the chart legend.

Figure 68: Trend Lines dialog

To insert trend lines to your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the data series on your chart that you want to use to insert trend lines. If you do not 
select a data series, then trend lines for all data series on your chart will be inserted.

3) To insert trend lines for all data series, go to Insert > Trend Lines on the main menu bar to
open the Trend Lines dialog (Figure 68).

4) To insert a trend line for a single data series, select a data series then go to Insert > Trend 
Lines on the main menu bar, or right-click on the data series and select Insert Trend Line 
from the context menu to open the Trend Lines dialog for the selected data series.

Note
The dialog to insert a trend line for a single data series is similar to the dialog for all 
data series (Figure 68), but has a second page called Line where you can select the 
formatting for the trend line (style, color, width, and transparency).

5) Select the type of trend line that you want to insert – Linear, Logarithmic, Exponential, or 
Power.

6) To show the equation or coefficient of determination used to calculate the trend lines, select
the options Show equation and/or Show coefficient of determination (R2).

7) Click OK to close the dialog and the trend lines are placed onto your chart.

8) Click outside the chart to leave edit mode.
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Note
When inserted, a trend line has the same color as the corresponding data series. To 
change the trend line properties, right-click on the trend line and select Format 
Trend Line on the context menu to open the Line page of the Trend Lines dialog.

To show the equation or the coefficient of determination and the equation after a trend line has 
been inserted, right-click on the trend line and select Insert Trend Line Equation or Insert R2 and
Trend Line Equation from the context menu. For more information on the equations, see the topic
Trend Lines in the LibreOffice Calc Help.

When you select a trend line, the information for the trend line is shown in the Status Bar, which is 
normally located at the bottom of the spreadsheet.

To delete trend lines from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) To delete all trend lines, go to Insert > Trend Lines on the main menu bar to open the 
Trend Lines dialog and select None then click OK.

3) To delete a single trend line, right-click on the data series and select Delete Trend line 
from the context menu.

Mean value lines
Mean value lines are special trend lines that show the mean value and can only be used in 2D 
charts. If a data series is selected, a mean value line is inserted for that data series only. If no data 
series are selected, mean value lines are inserted for all data series.

When you insert mean value lines into your chart, Calc calculates the average of each selected 
data series and places a colored line at the correct level in the chart. The colored line uses the 
same color as that used for the data series.

To insert mean value lines on your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the data series on your chart that you want to use to insert mean value lines. If you 
do not select a data series, then mean value lines for all data series on your chart will be 
inserted.

3) To insert mean value lines for all data series, go to Insert > Mean Value Lines on the main
menu bar.

4) To insert a mean value line for a single data series, select a data series then go to Insert > 
Mean Value Lines on the main menu bar, or right-click on the data series and select Insert
Mean Value Line from the context menu.

5) Click outside the chart to leave edit mode.

To delete mean value lines from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the mean value line you want to delete and press the Delete key, or right-click on the
data series and select Delete Mean Value Line from the context menu.

3) Click outside the chart to leave edit mode.

X or Y error bars
Use the X and Y error bars to display error bars for 2D charts only. If a data series is selected, an X
or Y error bar is inserted for that data series only. If no data series are selected, X or Y error bars 
are inserted for all data series.
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If you are presenting data that has a known possibility of error, such as social surveys using a 
particular sampling method, or you want to show the measuring accuracy of the tool you used, you 
may want to show error bars on the chart.

To insert error bars to your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

Figure 69: Error Bars dialog

2) Select the data series on your chart that you want to use to insert error bars. If you do not 
select a data series, then error bars for all data series on your chart will be inserted.

3) To insert error bars for all data series, go to Insert > X Error Bars or Insert > Y Error Bars
on the main menu bar to open the Error Bars dialog (Figure 69).

4) To insert error bars for a single data series, select a data series then go to Insert > X Error 
Bars or Insert > Y Error Bars on the main menu bar, or right-click on the data series and 
select Insert X Error Bars or Insert Y Error Bars from the context menu to open the Error 
Bars dialog.

5) Select the required options in Error Category, Error Indicator or Parameters to use for the 
error bars. More information on the options for error bars is given below.

6) Click OK to close the dialog and insert the error bars onto your chart.

7) Click outside the chart to leave edit mode.

To delete error bars from your chart:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) To delete error bars for all data series, go to Insert > X Error Bars or Insert > Y Error 
Bars on the main menu bar to open the Error Bars dialog (Figure 69) and select None in 
Error Category.

3) Click OK to close the dialog and delete the error bars from your chart.

4) To delete error bars from a single data series, right-click on the data series and select 
Delete X Error Bars or Delete Y Error Bars from the context menu.

5) Click outside the chart to leave edit mode.

Several options are provided on the X or Y Error Bars dialog. You can select only one error 
category at a time. You can also select whether the error indicator shows both positive and 
negative errors, or only positive or only negative.
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• Constant value – you can have separate positive and negative values.

• Percentage – choose the error as a percentage of the data points.

• The drop-down list has four options as follows:

– Standard error

– Variance – shows error calculated on variance

– Standard deviation – shows error calculated on standard deviation

– Error margin – you designate the error

• Cell Range – calculates the error based on cell ranges you select. The Parameters section
at the bottom of the dialog changes to allow selection of the cell ranges.

Formatting charts and graphs

Calc provides many options for formatting and fine-tuning the appearance of your charts. To enter 
formatting mode for your chart:

Selecting chart elements
Depending on the purpose of your document, for example a screen presentation or a printed 
document for a black and white publication, you might wish to have more detailed control over the 
different chart elements to give you what you need.

To select a chart element:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the chart element that you want to format and the chart element will be highlighted 
with selection squares or a border of square selection handles. Each chart element has its 
own formatting options and these are explained below.

3) Go to Format on the main menu bar and select the relevant option, or right-click to display 
a context menu relevant to the selected element to open the relevant formatting dialog.

Note

If your chart has many elements, it is recommended to turn on tooltips in Tools > 
Options > LibreOffice > General. When you hover a cursor over an element, Calc 
will display the element name which will making it easier in selecting the correct 
element. The name of the selected element also appears in the Status Bar.

Formatting options

• Format Selection – opens a dialog where you can specify the area fill, borders, 
transparency, characters, fonts, and other attributes of the selected element on the chart.

• Position and Size – opens the Position and Size dialog (see “Position and Size dialog” on 
page 106).

• Arrangement – provides two options: Bring Forward and Send Backward, of which only 
one may be active for some items. Use these options to arrange overlapping data series.

• Title – formats the titles for the chart and chart axes.

• Legend – formats how the legend appears and positioned on the chart

• Axis – formats the lines that create the chart as well as the font of the text that appears on 
both the X and Y axes.
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• Grid – formats the lines that create a grid for the chart.

• Chart Wall, Chart Floor, or Chart Area – formats how the chart wall, chart floor and chart 
area appear on your chart. Note that the chart floor is available for 3D charts.

• Chart Type – changes what type of chart is displayed and whether it is 2D or 3D chart. 
Note that only column, bar, pie and area charts can be displayed as a 3D chart.

• Data Ranges – explained in “Data range and axes labels” on page 84 and “Editing data 
ranges or data series” on page 88.

• 3D View – formats 3D charts and is only available for 3D charts (see page 97).

Moving chart elements
You may wish to move or resize individual elements of a chart, independent of other chart 
elements. For example, you may wish to reposition the legend from its default position on the right 
of the chart to below the chart. Pie charts also allow moving of individual wedges of the pie as well 
as exploding the entire pie. However, you cannot move an individual point or data series.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Move the cursor over the chart element you want to move, then click and drag to move the 
element. If the element is already selected, then the cursor changes to the move icon 
(normally a small hand), then click and drag to move the element.

3) Release the mouse button when the element is in the desired position.

Note

If your chart is a 3D chart, then round selection handles appear when a 3D chart 
element is selected. These round selection handles control the 3D angle of the 
element. You cannot resize or reposition the element while the round selection 
handles are showing. Use Shift+Click to get the square selection handles and you 
can now resize and reposition your 3D chart graphic.

Changing chart area background
The chart area is the area surrounding the chart graphic, including the main title, subtitle and 
legend.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > Chart Area on the main menu bar or right-click in the chart area and select
Format Chart Area from the context menu to open the Chart Area dialog (Figure 70).

3) Select the desired formatting from the Borders, Area and Transparency pages.

4) Click OK to close the dialog and save your changes.

Changing chart graphic background
The Chart Wall is the area that contains the chart graphic.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > Chart Wall on the main menu bar or right-click in the chart area and select 
Format Chart Area from the context menu to open the Chart Wall dialog. This dialog is 
similar to the Chart Area dialog in Figure 70.

3) Select the desired formatting from the Borders, Area and Transparency pages.

4) Click OK to close the dialog and save your changes.
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Figure 70: Chart Area dialog

Changing colors
If you want to modify the color scheme from the default, or you want to add extra chart colors for 
charts in all your documents, go to Tools > Options > Charts > Default Colors top make the 
changes. Changes made in this dialog affect the default chart colors for any chart you make in the 
future. See the Getting Started Guide for more information on changing colors.

3D charts
The 3D View dialog (Figure 71) has three pages:

• Perspective – where you can change the perspective of the chart.

• Appearance – Select whether to use a simple or realistic scheme for your 3D chart.

• Illumination – controls the light source that illuminates your 3D chart and where the 
shadows will fall.

Figure 71: 3D View dialog – Perspective page
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Rotation and perspective
To rotate a 3D chart or change its perspective view:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > 3D View on the main menu bar or right-click in the chart area and select 
3D View from the context menu to open the 3D View dialog (Figure 71).

3) Click on the Perspective tab to open the page.

4) Enter the required settings for Right angled axes and Perspective.

5) Click OK to close the dialog and save your changes.

Some hints for using the Perspective page:

• Set all angles to 0 for a front view of the chart. Pie charts and donut charts are shown as 
circles.

• With Right-angled axes enabled, you can rotate the chart contents only in the X and Y 
direction; that is, parallel to the chart borders.

• An X value of 90, with Y and Z set to 0, provides a view from the top of the chart. With X set
to –90, the view is from the bottom of the chart.

• Rotation is applied in the following order: X-axis first, then Y-axis, and Z-axis last.

• When shading is enabled and you rotate a chart, the lights are rotated as if they are fixed to
the chart.

• The rotation axes always relate to the page, not to the axes of the chart. This is different 
from some other chart programs.

• Select the Perspective option to view the chart in central perspective as through a camera 
lens instead of using a parallel projection. Set the focus length with the spin button or type 
a number in the box. 100% gives a perspective view where a far edge in the chart looks 
approximately half as big as a near edge.

Rotating 3D charts interactively
In addition to using the Perspective page of the 3D View dialog to rotate 3D charts, you can also 
rotate 3D charts interactively.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the Chart Wall and round selection handles appear.

3) Hover the mouse cursor over a corner handle and the cursor changes to a rotation icon.

4) Press and hold the left mouse button and drag the direction you want. A dashed outline of 
the chart is visible while you drag to help you see how the result will look.

5) Release the mouse button when satisfied.

Appearance
Use the Appearance page to modify some aspects of the appearance of a 3D chart.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > 3D View on the main menu bar or right-click in the chart area and select 
3D View from the context menu to open the 3D View dialog (Figure 72).

3) Click on the Appearance tab to open the page.

4) Select a scheme from the Scheme drop down list box – Realistic (default) or Simple. When 
you select a scheme, the options and the light sources are set accordingly.
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Figure 72: 3D View dialog – Appearance page

5) If necessary, select or deselect a combination of Shading, Object borders, or Rounded 
edges that is not given by the Realistic or Simple schemes to create a Custom scheme.

6) Click OK to close the dialog and save your changes.

Some hints for the Appearance page. Depending on the scheme selected, not all options are 
available.

• Select Shading to use the Gouraud method for rendering the surface. Otherwise, a flat 
method is used. The flat method sets a single color and brightness for each polygon. The 
edges are visible, soft gradients and spot lights are not possible. The Gouraud method 
applies gradients for a smoother, more realistic look. See the Draw Guide for more 
information on the use of shading.

• Select Object borders to draw lines along the edges.

• Select Rounded edges to smooth the edges of box shapes.

Illumination
Use the Illumination page (Figure 73) to set the light sources for the 3D view. See the Draw 
Guide for more information on setting the illumination.

Figure 73: 3D View dialog – Illumination page

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > 3D View on the main menu bar or right-click in the chart area and select 
3D View from the context menu to open the 3D View dialog (Figure 73).

3) Click on the Illumination tab to open the page.
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4) Click any of the eight buttons to switch a directed light source on or off. By default, the 
second light source is switched on. It is the first of seven normal, uniform light sources. The
first light source projects a specular light with highlights.

5) For the selected light source, select a color from the drop down list just below the eight light
source buttons. Note that the brightness values of all lights are added together, so use dark
colors when you enable multiple lights.

6) Each light source always points at the middle of the object initially. If necessary, change the
position of the light source by moving the vertical and/or horizontal sliders to set position of 
the selected light source.

7) Check the small preview on the dialog to see the effect of repositioning the light source.

8) Click the button in the bottom right corner of the preview to switch the internal illumination 
model between a sphere and a cube.

9) Select the ambient light using the Ambient light drop down list to define the ambient light 
which shines with a uniform intensity from all directions.

10) Click OK to close the dialog and save your changes.

Grids
You can divide the axes into sections by assigning gridlines to them. This allows you to get a better
overview of the chart, especially if you are working with large charts. The Y axis major grid is 
activated by default.

Use the Grid dialog to set the formatting options for the lines used as grids in your chart by 
selecting line style, color, width and transparency. The dialog is similar to the Line page in the 
Chart Area dialog shown in Figure 70 on page 97.

Axes
Sometimes you need to have a special scale for one of the axes of your chart, or you need smaller 
grid intervals, or you want to change the formatting of the labels on the axis. After highlighting the 
axis you wish to change, right-click and choose one of the items from the context menu.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Go to Format > Y Axis or X Axis on the main menu bar and select the axis you want to 
format, or right-click in on the chart the axis you want to format and select Format Axis 
from the context menu to open the Axis dialog (Figure 74). The options available in the 
dialog depend on which axis was selected, type of axis used, type of chart and whether the
chart is 2D or 3D.

Figure 74: Y Axis dialog – Scale page
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3) Click on the tab of the page where you to make changes using the available options. The 
options for each page are explained below.

4) Click OK to close the dialog and save your changes.

Scale
You can enter values for subdividing axes on the Scale page (Figure 74).

• Reverse direction – defines where the lower and the higher values are displayed at the 
axis. Deselect this option to use a mathematical direction. That means for Cartesian 
coordinate systems that the X-axis shows the lower values on the left and the Y-axis shows
the lower values at the bottom. For polar coordinate systems, the mathematical angle axis 
direction is counterclockwise and the radial axis is from inner to outer.

• Logarithmic scale – specifies that you want the axis to be subdivided logarithmically. Use 
this option if you are working with values that differ sharply from each other. You can use 
logarithmic scaling to make the grid lines of the axis equidistant but have values that may 
increase or decrease.

• Minimum – defines the minimum value for the beginning of the axis. Automatic must be 
deselected to set this option manually.

• Maximum – defines the maximum value for the end of the axis. Automatic must be 
deselected to set this option manually.

• Major interval – defines the interval for the main division of the axes. The main interval 
cannot be larger than the value area. Automatic must be deselected to set this option 
manually.

• Minor interval count – defines the interval for the subdivision of the axes. Automatic must
be deselected to set this option manually.

• Automatic – you must first deselect this option to modify the values. Disable this option if 
you are working with fixed values, as it does not permit automatic scaling.

• Type – for some types of axes, you can select to format an axis as text or date, or to detect
the type automatically. For a data axis type, you can set the following options.

– Minimum and maximum value to be shown on the ends of the scale.

– Resolution can be set to show days, months, or years as interval steps.

– Major interval can be set to show a certain number of days, months, or years.

– Minor interval can be set to show a certain number of days, months, or years.

Figure 75: Y Axis dialog – Positioning page
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Positioning
The Positioning page (Figure 75) controls the positioning of the axis.

• Axis line – select where Cross other axis at from the drop down list – Start, End, or at a 
specified Value.

• Labels – select where Place labels: is set from the drop down list – Near axis, Near axis 
(other side), Outside start, or Outside end.

• Interval marks

– Major – specifies whether the marks are to be on the inner or outer side of the axis. It is 
possible to combine both: you will then see marks on both sides. Inner – specifies that 
marks are placed on the inner side of the axis. Outer – specifies that marks are placed 
on the outer side of the axis.

– Minor – defines the marking dashes between the axis marks. It is possible to activate 
both fields. This will result in a marking line running from the outside to the inside.

– Inner – specifies that minor interval marks are placed on the inner side of the axis.

– Outer – specifies that minor interval marks are placed on the outer side of the axis.

– Place marks – select where to place the marks from the drop down list – At labels, At 
axis, or At axis and labels.

Line
Use the Line page to set the formatting options for the axis line by selecting line style, color, width, 
and transparency. The dialog is similar to the Chart Area dialog shown in Figure 70 on page 97.

Figure 76: Y Axis dialog – Label page

Label
On the Label page (Figure 76), you can decide whether to show or hide the labels, how to handle 
them when they will not all fit neatly into one row (for example, if the words are too long), and 
whether to have them at an angle to the axis.
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• Show labels – specifies whether to show or hide the axis labels.

• Order – the options on this page are only available for a 2D chart. In this area, you can 
define the alignment of the number labels on the X or Y axis.

– Tile – arranges numbers on the axis side by side.

– Stagger odd – staggers numbers on the axis, even numbers lower than odd numbers.

– Stagger even – stagger numbers on the axes, odd numbers lower than even numbers.

– Automatic – automatically arranges numbers on the axis.

Note
Problems may arise in displaying labels if the size of your chart is too small. You can 
avoid this by either enlarging the view or decreasing the font size.

• Text flow – determines the text flow of the axis label.

– Overlap – specifies that text in axis labels may overlap other axis labels. This can be 
especially useful if there is a lack of space.

– Break – allows a text break.

• Text direction – defines the text direction of labels.

– ABCD wheel – click and drag the indicator on the wheel defines the variable text 
orientation. The characters "ABCD" on the wheel correspond to the new setting.

– Vertically stacked – assigns vertical text orientation for labels. If you define a vertical 
X-axis label, the text may be cut off by the line of the x-axis.

– Degrees – manually enter the orientation angle for the labels.

– Text direction – specify the text direction for any text that uses complex text layout 
(CTL) and is only available if Enhanced language support is enabled In Tools > 
Options > Language Settings.

Numbers
Use the Numbers page to set the attributes for any numbers used on the axis. This page is very 
similar to the one for formatting numbers in cells; see Chapter 2 Entering, Editing, and Formatting 
Data for more information.

Font and Font Effects
Use the Font and Font Effects pages to set the attributes for fonts and the type of font effects used 
for axis labels. These pages are very similar to the ones for fonts and font effects in cells; see 
Chapter 2 Entering, Editing, and Formatting Data for more information.

Asian Typography
Sets the Asian typographic options for axis labels and is only available if Enhanced language 
support is enabled In Tools > Options > Language Settings.

• Apply list of forbidden characters to the beginning and end of line – prevents the 
characters in the list from starting or ending a line. The characters are relocated to either 
the previous or the next line. To edit the list of restricted characters, go to Tools > Options 
> Language Settings > Asian Layout.

• Allow hanging punctuation – prevents commas and periods from breaking the line. 
Instead, these characters are added to the end of the line, even in the page margin.

• Apply spacing between Asian, Latin and Complex text – inserts a space between 
Asian, Latin and complex characters.
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Hierarchical axis labels
Multiple columns of categories can be displayed in a hierarchical manner at the axis on your chart. 
Hierarchical axes labels are created automatically if the first columns (or rows) contain data that is 
text. An example of hierarchical labels is shown in Figure 77 where the first column indicates the 
quarters and the second column shows the months.

Figure 77: Example of hierarchical axes labels

Figure 78: Data Series dialog – Line page
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Selecting and formatting symbols
In line and scatter charts the symbols representing the points can be changed to a different symbol
or color through the object properties dialog.

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be 
surrounded by a gray border.

2) Select the data series you want to change.

3) Go to Format > Format Selection on the main menu bar or right-click and select Format 
Data Series from the context menu to open the Data Series dialog (Figure 78).

4) Open the Line page of the Data Series dialog by clicking on its tab.

5) In the Icon section, open the drop-down list and select an option for your symbol from No 
symbol, Automatic, From file, Gallery or Symbols. A preview of your selection is shown in 
the preview box at the bottom of the dialog.

– From file opens a file browser so you can select a file to use for your symbol.

– Gallery opens a list showing the available graphics you can select for your symbol.

– Symbols opens a list showing the available symbols you can select.

6) Enter the Width and the Height you want to use for your new symbol.

7) Select Keep ratio if you want the width and height of your symbol to maintain its ratio.

Adding drawing objects to charts

As in the other LibreOffice components, you can use the Drawing toolbar to add shapes such as 
lines, rectangles, circles, text objects, or more complex shapes such as symbols or block arrows. 
Use these additional shapes to add explanatory notes and highlight points on your chart, for 
example. For more information on using the Drawing toolbar and drawing shapes, see the Draw 
Guide.

Resizing and moving the chart

You can resize or move all elements of a chart at the same time, in two ways: interactively, or by 
using the Position and Size dialog. You can use a combination of both methods: interactive for a 
quick and easy change, then the Position and Size dialog for precise sizing and positioning.

Interactively
To resize a chart interactively:

1) Click once on the chart to select it and square selection handles appear around the border 
of the chart.

2) To increase or decrease the size of the chart, click and drag one of the markers. The cursor
indicates the direction in which you can increase or decrease the chart size.

To move a chart interactively:

1) Click once on the chart to select it and square selection handles appear around the border 
of the chart.

2) Hover the cursor anywhere over the chart until it changes to a move cursor (shape 
depends on computer setup).

3) Click and drag the chart to its new location.

4) Release the mouse button when the chart is in the required position.
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Position and Size dialog
To resize or move a chart using the Position and Size dialog:

1) Click once on the chart to select it and square selection handles appear around the border 
of the chart.

2) Right-click and select Position and Size from the context menu to open the Position and 
Size dialog (Figure 79).

3) Select the options you want to use ion the Position and Size, Rotation and Slant & corner 
Radius pages on this dialog.

4) Click OK to close the dialog and save your changes.

Position and size of a chart are coordinated relative to a fixed point (the base point) and, by 
default, this base point is located at the upper left of a chart. You can temporarily change this base 
point to make positioning or sizing of a chart simpler. Click one of the points in Base point 
corresponding to the location you want to use for either Position or Size. When you click OK and 
close this dialog, Calc resets the base point to the default position.

Figure 79: Position and Size dialog

Position and Size
The options available on the Position and Size page (Figure 79) are as follows:

• Position – specify the location of the selected object on the page.

– Position X – enter the horizontal distance that you want to move the object relative to 
the base point selected in the grid.

– Position Y – enter the vertical distance that you want to move the object relative to the 
base point selected in the grid.

– Base point – select a base point in the grid, and then enter the amount that you want to 
shift the object relative to the base point that you selected in the Position Y and Position
X boxes. The base points correspond to the selection handles on an object.

• Size – specify the amount by which you want to resize the selected object with respect to 
the selected base point.

– Width – enter a width for the selected object.
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– Height – enter a height for the selected object.

– Keep ratio – maintains proportions between width and height when you resize the 
selected object.

– Base point – select a base point in the grid and then enter the new size dimensions for 
the selected object in the Width and Height boxes.

• Protect – prevents changes to the position or the size of the selected object.

– Position – prevents you from moving the object.

– Size – prevents you from resizing the object.

• Adapt – specifies if the size should be adjusted to fit the size of entered text.

– Fit width to text – expands the width of the object to the width of the text, if the object is 
smaller than the text.

– Fit height to text – expands the height of the object to the height of the text, if the object 
is smaller than the text.

Rotation
The options for the Rotation page (Figure 80) are as follows:

• Pivot point – the selected object is rotated around a pivot point that you specify. The 
default pivot point is at the center of the object. If you set a pivot point too far outside of the 
object boundaries, the object could be rotated off of the page.

– Position X – enter the horizontal distance from the left edge of the page to the pivot 
point.

– Position Y – enter the vertical distance from the top edge of the page to the pivot point.

– Default settings – select where you want to place the pivot point on the object. The 
default setting is the center of the object.

• Rotation angle – specify the number of degrees that you want to rotate the selected 
object, or click in the rotation wheel.

– Angle – enter the number of degrees that you want to rotate the selected object.

– Default settings – click and drag the indicator to specify the rotation angle in degrees. 
The number of degrees rotated is shown in the Angle box.

Figure 80: Position and Size dialog – Rotation page

Chapter 3  Creating Charts and Graphs 107



Slant & Corner Radius
The options for the Slant & Corner Radius page (Figure 81) are as follows:

• Corner Radius – you can only round the corners of a rectangular object.

– Radius – enter the radius of the circle that you want to use to round the corners.

• Slant – slants the selected object along an axis that you specify.

– Angle – enter the angle of the slant axis.

Figure 81: Position and Size dialog – Slant & Corner Radius page

Exporting charts

You can export a chart as a graphic that you can use in other documents.

1) Click once on the chart to select it. Square selection handles appear around the border of 
the chart.

2) Right-click on the selected chart and select Export as graphic from the context menu.

3) In the Graphics Export dialog that opens, type a name for the graphic file, select the 
location where you want to save the file, and select the graphic format you want to use.

4) Click Save and your chart will be exported as a graphic to the location you specified and 
the format you specified.

Gallery of chart types

It is important to remember that while your data can be presented with a number of different charts,
the message you want to convey to your audience should determine what type of chart you use. 
The following sections present examples of the chart types that Calc provides, with some notes on 
the purpose of each chart type.

Column charts
Column charts are commonly used for data that shows trends over time. They are best for charts 
that have a relatively small number of data points. It is the default chart type provided by Calc, as it
is one of the most useful charts and the easiest to understand. If you have a large time series, a 
line chart would be better suited.

A column chart shows vertical bars, with the height of each bar being proportional to its value. The 
X-axis shows categories and the Y-axis shows the value for each category.

• Normal – this subtype shows all data values belonging to a category next to each other. 
The main focus is on the individual absolute values, compared to every other value.

• Stacked – this subtype shows the data values of each category on top of each other. The 
main focus is the overall category value and the individual contribution of each value within 
its category.
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• Percent – this subtype shows the relative percentage of each data value with regard to the 
total of its category. The main focus is the relative contribution of each value to the category
total.

You can enable a 3D view of the data values. A realistic 3D chart tries to give the best 3D look 
while a simple 3D chart tries to mimic the chart view of other products.

For 3D charts, you can select the shape of each data value from Box, Cylinder, Cone, and 
Pyramid.

Bar charts
A bar chart shows horizontal bars. The length of each bar is proportional to its value. The Y-axis 
shows categories and the X-axis shows the value for each category. The subtypes for bar charts 
are the same as for column charts, given above.

Bar charts are excellent for giving an immediate visual impact for data comparison in cases when 
time is not an important factor, for example, when comparing the popularity of a few products in a 
marketplace. In the examples below:

• The first chart is achieved by using the chart wizard with Insert > Grids, deselecting y-axis,
and using Insert > Mean Value Lines.

• The second chart is a 3D chart created with a simple border and the 3D chart area twisted 
around.

• The third chart is an attempt to get rid of the legend and put labels showing the names of 
the companies on the axis instead. We also changed the colors to a hatch pattern.

Figure 82: Bar chart examples

Pie charts
A pie chart shows values as circular sectors of the total circle. The length of the arc, or the area of 
each sector, is proportional to its value.

• Pie – this subtype shows sectors as colored areas of the total pie, for one data column 
only. In the created chart, you can click and drag any sector to separate that sector from 
the remaining pie or to join it back.

• Exploded pie – this subtype shows the sectors already separated from each other. You 
can click and drag any sector to move it along a radial from the pie center.

• Donut – this subtype can show multiple data columns. Each data column is shown as one 
donut shape with a hole inside, where the next data column can be shown. You can click 
and drag an outer sector to move it along a radial from the donut center.
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• Exploded donut – this subtype shows the outer sectors already separated from the 
remaining donut. You can click and drag an outer sector to move it along a radial from the 
donut's center.

Pie charts are excellent when you need to compare proportions. For example, comparisons of 
departmental spending: what the department spent on different items or what different departments
spent. They work best with smaller numbers of values, about half a dozen; more than this and the 
visual impact begins to fade.

As the Chart Wizard guesses the series that you wish to include in your pie chart, you might need 
to adjust this initially on the Data Ranges page of the Wizard if you know you want a pie chart, or 
by using the Format > Data Ranges > Data Series dialog.

You can do some interesting things with a pie chart, especially if you make it into a 3D chart. It can 
then be tilted, given shadows, and generally turned into a work of art. Just do not clutter it so much 
that your message is lost, and be careful that tilting does not distort the relative size of the 
segments.

You can choose in the Chart Wizard to explode the pie chart, but this is an all or nothing option. If 
your aim is to accentuate one piece of the pie, you can separate out one piece by carefully 
highlighting it after you have finished with the Chart Wizard, and dragging it out of the group. When
you do this you might need to enlarge the chart area again to regain the original size of the pieces.

Figure 83: Pie chart examples

The effects achieved in Figure 83 are explained below.

• 2D pie chart with one part of the pie exploded: Select Insert > Legend and deselect the 
Display legend box. Select Insert > Data Labels and select Show value as number. Then 
carefully select the piece you wish to highlight, move the cursor to the edge of the piece 
and click (the piece will have highlight squares to mark it), and then drag it out from the rest
of the pieces. The pieces will decrease in size, so you need to highlight the chart wall and 
drag it at a corner to increase the size.

• 3D pie chart with realistic schema and illumination: Select Format > 3D view > 
Illumination where you can change the direction of the light, the color of the ambient light, 
and the depth of the shade. Also adjusted is the 3D angle of the disc in the Perspective 
dialog on the same set of tabs.

The chart updates as you make changes, so you can immediately see the effects.

If you want to separate out one of the pieces, click on it carefully; you should see a wire 
frame highlight. Drag it out with the mouse and then, if necessary, increase the size of the 
chart wall.

• 3D pie chart with different fill effects in each portion of the pie: Select Insert > Data labels 
and select Show value as percentage. Then carefully select each of the pieces so that it 
has a wire frame highlight and right-click to get the object properties dialog; choose the 
Area tab. For one we selected a bitmap, for another a gradient and for the third we used 
the Transparency tab and adjusted the transparency to 50%.
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• Donut charts shown in Figure 84 are subtypes of the pie chart. To create one, select Pie in 
the Chart Wizard dialog, and select the third or fourth type of pie chart. For more variety, 
use a 3D Look.

Figure 84: Donut chart examples

Area charts
An area chart shows values as points on the Y-axis and the X-axis shows categories. The Y values
of each data series are connected by a line and the area between lines is filled with a color. The 
focus of an area chart is to emphasize the changes from one category to the next.

• Normal – this subtype plots all values as absolute Y values. It first plots the area of the last 
column in the data range, then the next to last, and so on, and finally the first column of 
data is drawn. Thus, if the values in the first column are higher than other values, the last 
drawn area will hide the other areas.

• Stacked – this subtypes plots values cumulatively stacked on each other. It ensures that all
values are visible, and no data set is hidden by others. However, the Y values no longer 
represent absolute values, except for the last column which is drawn at the bottom of the 
stacked areas.

• Percent – this subtype plots values cumulatively stacked on each other and scaled as 
percentage of the category total.

An area chart is a version of a line or column graph. It may be useful where you wish to emphasize
volume of change. Area charts have a greater visual impact than a line chart, but the data you use 
will make a difference.

Figure 85: Area chart examples – the good, the bad, and the ugly

Chapter 3  Creating Charts and Graphs 111



As shown in Figure 85, an area chart is sometimes tricky to use. This may be one good reason to 
use transparency values in an area chart. After setting up the basic chart using the Chart Wizard, 
do this:

1) Right-click on the Y axis and select Delete Major Grid from the context menu. As the data 
overlaps, some of it is missing behind the first data series, as shown in the example on the 
left. This is not what you want. A better solution is shown in the center example.

2) After deselecting the Y axis grid, right-click on each data series in turn and select Format 
Data Series. On the Transparency tab, set Transparency to 50%. The transparency makes 
it easy to see the data hidden behind the first data series. Now, right-click on the X axis and
select Format Axis. On the Label tab, select Tile in the Order section and set the Text 
orientation to 55 degrees. This places the long labels at an angle.

3) To create the example on the right, after doing the steps above, right-click and select Chart
Type. Select the 3D Look option and select Realistic from the drop-down list. We also 
twisted the chart area around and gave the chart wall a picture of the sky. As you can see, 
the legend turns into labels on the z-axis. Overall, although it is visually more appealing, it 
is more difficult to see the point you are trying to make with the data.

Other ways of visualizing the same data series are represented by the stacked area chart or the 
percentage stacked area chart (Figure 86). In the first, each number of each series is added to the 
others so that it shows an overall volume, but not a comparison of the data. The percentage 
stacked chart shows each value in the series as a part of the whole. For example in June all three 
values are added together and that number represents 100%. The individual values are a 
percentage of that. Many charts have varieties which have this option.

Figure 86: Examples of stacked and percentage stacked area charts

Line charts

A line chart is a time series with a progression. It is ideal for raw data and useful for charts with 
plentiful data that show trends or changes over time where you want to emphasize continuity. On 
line charts, the X-axis is ideal to represent time series data.

A line chart shows values as points on the Y-axis and the X-axis shows categories. The Y values of
each data series can be connected by a line.

• Points only – this subtype plots only points.

• Points and lines – this subtype plots points and connects points of the same data series 
by a line.

• Lines only – this subtype plots only lines.

• 3D lines – this subtype connects points of the same data series by a 3D line.
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Select Stack series to arrange the points for Y values cumulative above each other. The Y values 
no longer represent absolute values, except for the first column which is drawn at the bottom of the
stacked points. If you select Percent, the Y values are scaled as percentage of the category total.

Select Smooth lines to draw curves through the points instead of straight lines. Click Properties 
for a dialog to change the curve properties.

Things to do with lines: thicken them, make them 3D, smooth the contours, just use points. 
However, 3D lines can confuse the viewer, so just using a thicker line often works better.

Figure 87: Line chart examples

Scatter or XY charts

XY (Scatter)
An XY chart in its basic form is based on one data series consisting of a name, a list of X-values, 
and a list of Y-values. Each value pair (X & Y) is shown as a point in a coordinate system. The 
name of the data series is associated with the Y-values and shown in the legend.

When creating an XY chart refer to the following example tasks. Your XY chart may have more 
than one data series.

• Scale the X-axis.

• Generate a parameter curve, for example a spiral.

• Draw the graph of a function.

• Explore the statistical association of quantitative variables

XY chart variants
You can select an XY chart variant on the first page of the Chart Wizard, or by choosing Format > 
Chart Type for a chart in edit mode.

The chart is created with default settings. After the chart is finished, you can edit its properties to 
change the appearance. Line styles and icons can be changed on the Line page of the data series
properties dialog.

Double-click any data point to open the Data Series dialog. In this dialog, you can change many 
properties of the data series.

For 2D charts, you can select Insert > Y Error Bars to enable the display of error bars.

You can enable the display of mean value lines and trend lines using commands on the Insert 
menu.
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• Points only – each data point is shown by an icon. Calc uses default icons with different 
forms and colors for each data series. The default colors are set in Tools > Options > 
Charts > Default Colors.

• Lines Only – this variant draws straight lines from one data point to the next. The data 
points are not shown by icons. The drawing order is the same as the order in the data 
series. Mark Sort by X Values to draw the lines in the order of the X values. This sorting 
applies only to the chart, not to the data in the table.

• Points and Lines – this variant shows points and lines at the same time.

• 3D Lines – the lines are shown like tapes. The data points are not shown by icons. In the 
finished chart select 3D View to set properties like illumination and angle of view.

• Smooth Lines

– Mark Smooth Lines to draw curves instead of straight line segments.

– Click Properties to set details for the curves.

– Cubic Spline interpolates your data points with polynomials of degree 3. The 
transitions between the polynomial pieces are smooth, having the same slope and 
curvature.

– The Resolution determines how many line segments are calculated to draw a piece of 
polynomial between two data points. You can see the intermediate points if you click 
any data point.

– B-Spline uses a parametric, interpolating B-spline curve. Those curves are built 
piecewise from polynomials. The Degree of polynomials sets the degree of these 
polynomials.

Example of XY chart
Scatter charts are great for visualizing data that you have not had time to analyze and they may be
the best for data when you have a constant value against which to compare the data; for example, 
weather data, reactions under different acidity levels, conditions at altitude, or any data which 
matches two series of numeric data. In contrast to line charts, the X-axis are the left to right labels, 
which usually indicate a time series.

Figure 88: XY (Scatter) chart example
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Scatter charts may surprise those unfamiliar with how they work. While constructing the 
chart, if you choose Data Range > Data series in rows, the first row of data represents 
the X-axis. The rest of the rows of data are then compared against the first row data.
Figure 88 shows a comparison of three currencies with the Japanese Yen. Even though 
the table presents the monthly series, the chart does not. In fact the Japanese Yen does 
not appear; it is merely used as the constant series that all the other data series are 
compared against.

Bubble charts
A bubble chart is a specific variation of a scatter chart in which the data points are replaced with 
bubbles showing the relations of three variables. Bubble charts are often used to present financial 
data or social/demographic data. It shows the relations of three variables in two dimensions. Two 
variables are used for the position on the X-axis and Y-axis, while the third is shown as the relative 
size of each bubble. One or more data series can be included in a single chart.

The data series dialog for a bubble chart has an entry to define the data range for the bubbles and 
their sizes. 

It is sometimes easier to build a bubble chart manually in the data range entry section of the chart 
wizard. In the example chart shown in Figure 89, the range including the dates and the three series
was highlighted before starting the chart wizard. If you do not include the top row with the dates, 
there is no way to include this data as a category later. 

The names of the series were added manually, as were the ranges for the second and third series. 

Each data series was highlighted and the data points added and formatted to be in the center of 
the data point. In this case the number (which is the “dimension”) was deselected and category 
(the year) selected. The data points are formatted using the transparency tab with a radial gradient.

Figure 89: Bubble chart example

Note
If the data series for X-axis contains text, an order number will be displayed in the 
labels of this axis. Otherwise, the data of the series will be used for the X-axis, which 
can lead to irregularly arranged bubbles.
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Net charts
A net chart is similar to a polar or radar chart and displays data values as points connected by 
some lines in a grid net that resembles a spider net or a radar tube display.

For each row of chart data, a radial is shown on which the data is plotted. All data values are 
shown with the same scale, so all data values should have about the same magnitude.

A net chart is useful for comparing data that are not time series, but show different circumstances, 
such as variables in a scientific experiment or direction. The poles of the net chart are equivalent to
the Y-axes of other charts. Generally, between three and eight axes are best; any more and this 
type of chart becomes confusing. Before and after values can be plotted on the same chart, or 
perhaps expected and real results, so that differences can be compared.

Figure 90: Net chart examples

Figure 91: Example of filled net or radar chart

Figure 90 shows example of two types of net charts:

• The left example is a plain net chart without grids and with just points, no lines.

• The right example is a net chart with lines, points and grid. Axes colors and labels changed.
Chart area color = gradient. Points changed to 3D ones.

Other varieties of net chart show the data series as stacked numbers or stacked percentages. The 
series can also be filled with a color as shown in Figure 91. Partial transparency is often best for 
showing all the series.
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Stock charts
A stock chart illustrates the market trend for stock and shares by giving opening price, bottom 
price, top price and closing price. The transaction volume can also be shown and the X-axis can 
represent a time series.

When you set up a stock chart in the Chart Wizard, the Data Series dialog is very important. The 
data should be arranged as shown in the example table below because you need to tell it which 
series is for the opening price, closing price, high and low price of the stock, and so on.

Transaction
volume

Opening price
Low (bottom

price)
High (top price) Closing price

Monday 2500 20 15 25 17

Tuesday 3500 32 22 37 30

Wednesday 1000 15 15 17 17

Thursday 2200 40 30 47 35

Friday 4600 27 20 32 31

The open, low, high, and closing values of a row build together one data unit in the chart. A stock 
price data series consists of several rows containing such data units. The column containing the 
transaction volume builds an optional second data series.

Depending on the chosen variant, you may not need all columns.

Stock chart variants
Select a stock chart type on the first page of the Chart wizard and then select one of the four 
variants.

• Type 1 – based on low and high column, Type 1 shows the distance between bottom price 
(low) and top price (high) by a vertical line. Based on the low, high, and close columns, 
Type 1 shows an additional horizontal mark for the closing price.

• Type 2 – based on the open, low, high, and close columns, Type 2 generates the traditional
candle stick chart. Type 2 draws the vertical line between the bottom and top price and 
adds a rectangle in front, which visualizes the range between the opening and closing 
price. If you click on the rectangle, you see more information in the status bar. Calc uses 
different fill colors for rising values (the opening price is lower than the closing price) and 
falling values.

• Type 3 – based on the volume, low, high, and close columns, Type 3 draws a chart like 
Type 1 with additional columns for the transaction volume.

• Type 4 – based on all five data columns (volume, open, low, high, and close), Type 4 
combines a chart of Type 2 with a column chart for the transaction volume.

Note
If measurement for transaction volume is in units, a second Y axis is introduced in 
chart Type 3 and Type 4. The price axis is shown on the right side and the volume 
axis on the left side.

Setting data source
You can select or alter a data range on the second page of the Chart wizard or in the Data Range 
dialog. For fine tuning use the Data Series dialog.
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To specify a data range do one of the following:

• Enter the data range in the text box.

An example data range would be "$Sheet1.$B$3:$B$14". Note that a data range may 
consist of more than one region in a spreadsheet, for example 
"$Sheet1.A1:A5;$Sheet1.D1:D5" is also a valid data range.

If the syntax is not correct, Calc shows the text in red.

• Click Select data range to minimize the dialog, then drag to select the data range. When 
you release the mouse, the data are entered. Click Select data range again to add a data 
range. In the input field of the minimized dialog, click after the entry and type a semicolon. 
Then drag to select the next range.

• Click one of the options for data series in rows or in columns.

Your stock chart data are in columns, if the information in a row belongs to the same candle stick.

Organize data series
In the data series area on the left side of the dialog, you can organize the data series of the actual 
chart. A stock chart has at least one data series containing the prices. It might have a second data 
series for transaction volume.

If you have more than one price data series, use the Up and Down arrow buttons to order them. 
The order determines the arrangement in the chart. Do the same for volume data series. You 
cannot switch price and volume data series.

To remove a data series, select the data series in the list and click Remove.

To add a data series, select one of the existing data series and click Add. You get an empty entry 
below the selected one, which has the same type. If you have no price data series or no volume 
data series, you must first select a range for these series in the Data Range dialog.

Setting data ranges
In the Data Ranges dialog you can set or change the data range of each component of the 
selected data series.

The upper list shows the role name of the components and the current values. When you have 
selected a role, you can change the value in the text box below the list. The label shows the 
selected role.

Enter the range into the text box or click on Select data range to minimize the dialog and select 
the range with the mouse.

Select Open Values, Close Values, High Values, and Low Values in any order. Specify only the 
ranges for those roles which you need for the chosen variant of the stock chart. The ranges need 
not be next to each other in the table.

Legend
The legend displays the labels from the first row or column or from the special range that you have 
set in the Data Series dialog. If your chart does not contain labels, the legend displays text like 
"Row 1, Row 2, ...", or "Column A, Column B, ..." according to the row number or column letter of 
the chart data.

The legend shows the value from the range, which you entered in the Range for Name field in the 
Data Range dialog. The default entry is the column header of the closing price column.

Select one of the position options. When the chart is finished, you can specify other positions using
the Format menu.
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Column and line charts
A column and line chart is a combination of two other chart types. It is useful for combining two 
distinct but related data series, for example sales over time (column) and the profit margin trends 
(line).

• Columns and Lines – the rectangles of the column data series are drawn side by side so 
that you can easily compare their values.

• Stacked Columns and Lines – the rectangles of the column data series are drawn 
stacked above each other, so that the height of a column visualizes the sum of the data 
values.

The example chart in Figure 92 has manufacturing cost and profit data for two products over a 
period of time (six months in 2007). To create this chart, first highlight the table of data and start the
Chart Wizard. Choose the Column and Line chart type with two lines and the data series in rows. 
Then give it a title to highlight the aspect you want to show. The lines are different colors at this 
stage and do not reflect the product relationships. When you finish with the Chart Wizard, highlight 
the chart, click on the line, right-click and select Format Data Series.

There are a few things to change: The colors should match the products. So both Ark 
Manufacturing and profit are blue and Prall is red. The lines need to be more noticeable, so make 
the lines thicker by increasing the width to 0.08.

For the background, highlight the chart wall, right-click and select Format Wall. On the Area page, 
change the drop-down box to show Gradient. Choose one of the preset gradient patterns and 
make it lighter by going to the Transparency tab and making the gradient 50% transparent.

To make the chart look cleaner without the grid, go to Insert > Grids and deselect the X-axis 
option.

Figure 92: Column and line chart example
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Chapter 4  
Using Styles and Templates in
Calc
Bringing uniformity to your spreadsheets



What is a template?

A template is a model that you use to create other documents in a standard format. For example, 
you can create a template for invoices that has your company logo and address at the top of the 
page. This means that any new spreadsheets (invoices) created from this template will then have 
your company logo and address on the first page of the spreadsheet.

Templates can contain anything that regular documents can contain, such as text, graphics, styles, 
and user-specific setup information such as measurement units, language, default printer, and 
toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create, or download and install, as 
many templates as you wish. If you do not specify a template when you start a new spreadsheet, 
any new spreadsheet is then based on the default template for spreadsheets that is included with 
LibreOffice Calc. This default template consists of a blank spreadsheet which you can customize to
your needs and then, if you wish, use as a basis to create a custom default template. See “Setting 
default template” on page 138.

What are styles?

A style is a set or group of formats that you can apply to selected elements in a document to 
quickly change their appearance. When you apply a style, you apply a whole group of formats at 
the same time.

Many people manually format spreadsheet cells and pages without paying any attention to styles 
and are used to formatting documents according to physical attributes. For example, for the 
contents of a cell you might specify the font family, font size, and any character formatting such as 
bold or italic.

Styles are logical attributes. Using styles means that you stop applying attributes and 
characteristics individually (for example, font size 14pt, Times New Roman, bold, centered) and 
start using a style, for example Title. Applying attributes and characteristics is time consuming and 
prone to errors. In contrast, using a style, which has been defined to include the attributes and 
characteristics you want to use, will save you time and give greater consistency in formatting.

Styles also make major formatting changes easy. For example, you may decide to change the 
appearance of all subtotals in your spreadsheet to be 10 pt Arial instead of 8 pt Times New Roman 
after you have created a 15-page spreadsheet. You can change all of the subtotals in the 
document by simply changing the properties for the subtotal style.

Another type of style is a page style. Page styles allow you to define page margins, headers and 
footers, and other printing attributes giving you consistency each time you print a spreadsheet.

Styles

Calc style types
While some components of LibreOffice offer many style types, Calc offers only two: cell styles and 
page styles. These style types are explained in the following sections.

Cell styles
Cell styles are similar to paragraph styles used in LibreOffice Writer and are the most basic type of 
style in Calc. Cell styles are used for applying fonts, alignment, borders, background, number 
formats (for example, currency, date, number), and cell protection to format the data contained 
within the cells.
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A basic range of cell styles is supplied with LibreOffice. These styles are shown in Figure 93.

Initially, the basic styles are configured so that if you change the font family of Default, then all of 
the other styles will change to match. Creating, modifying, and accessing styles is explained in the 
following sections.

Figure 93: Examples of basic cell styles

Page styles
Page styles in Calc are applied to sheets. Although one sheet may print on several pages, only one
page style can be applied to a sheet. If a spreadsheet file contains more than one sheet, then a 
different page style can be applied to each sheet. For example, a spreadsheet might contain one 
sheet to be printed in landscape orientation and the other sheets in the spreadsheet are printed in 
portrait orientation.

Two page styles are supplied with Calc: Default and Report. You can adjust many settings using 
page styles and you can also define as many page styles as you require.

Spreadsheets are primarily used onscreen and not printed, therefore Calc does not display the 
page style on the screen. If you want a spreadsheet to fit on a certain page size, you have to 
carefully control the column width and row height using File > Page Preview and View > Page 
breaks preview on the main menu bar to guide you.

Despite this limitation, it is recommended to define page styles for any spreadsheets that you are 
likely to print. This will help prevent any lost time or paper wastage due to trial and error.

Page styles allow you to set page size and orientation, page margins, headers and footers, borders
and backgrounds, and the sequence for printing sheets.

Applying cell styles
To apply cell styles in Calc, you can use the Styles and Formatting dialog, Fill Format mode, the 
Apply Style list, or assign styles to shortcut keys.

Styles and Formatting dialog
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or 

click the Styles and Formatting icon  on the Formatting toolbar to open the Styles and 
Formatting dialog (Figure 94).
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Figure 94: Styles and Formatting dialog

2) Click on the Cell Styles icon  in the Styles and Formatting dialog to open the list of cell 
styles.

3) Highlight the cell or group of cells where you want to apply a cell style.

4) Double-click on the cell style name in the Styles and Formatting dialog and the formatting 
attributes for that style are applied to the data contained in the cell or group of cells.

Note

The Styles and Formatting dialog can be docked into the main Calc workspace. To 
dock or undock the window, hold down the Ctrl key and double-click on the icon bar
at the top of the dialog, or click anywhere in the dialog and use the keyboard 
combination Ctrl+Shift+F10.

Fill Format mode
The Fill Format mode is useful when you want to apply the same style to many scattered cells.

1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or 

click the Styles and Formatting icon  on the Formatting toolbar to open the Styles and 
Formatting dialog (Figure 94).

2) Select the style you want to apply.

3) Click on the Fill Format mode icon  in the Styles and Formatting dialog and the cursor 
changes to a similar shape as the Fill Format Mode icon.

4) Click in each cell where you want to apply the formatting attributes.

5) When you have finished formatting cells, click the Fill Format Mode icon again or close the 
Styles and Formatting dialog.

Note
When this mode is active, a right-click anywhere in the document cancels the last 
Fill Format action. Be careful not to accidentally right-click and thus cancel any 
formatting actions you want to keep.

Apply Style list
The Apply Style drop-down list used to select a style for selected cells is not normally included on 
the Formatting toolbar in Calc and has to be added as follows:

1) Right-click in a blank space on the Formatting toolbar and select Visible Buttons from the 
context menu (Figure 95).

2) Click on Apply Style and the context menus close. The Apply Style list now appears at the 
left end of the Formatting toolbar.
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Figure 95: Adding an Apply Style list to the Formatting toolbar

Apply a style using the Apply Styles drop-down list as follows:

1) Select a cell or a group of cells in your spreadsheet.

2) Click the small triangle to open the drop-down list for Apply Styles.

3) Select the style you require and the formatting attributes of the selected style are applied to
the selected cells.

4) Each style in the drop-down menu is displayed with its preview, but only few styles are 
available. Click on More to go to the Styles and Formatting dialog where all cell styles are 
available.

Assigning shortcut keys
You can create keyboard shortcuts to apply commonly-used cell or page styles, including any 
custom styles that you have created. See Chapter 14 Setting up and Customizing Calc for more 
information.

Applying page styles
When a page style has been applied to a sheet within a spreadsheet, the page style being used is 
indicated on the Status Bar as shown in Figure 96.

Figure 96: Page style indicated on Status Bar

1) Select the sheet to be styled by clicking on its sheet tab at the bottom of the displayed 
spreadsheet.

2) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or 

click the Styles and Formatting icon  on the Formatting toolbar to open the Styles and 
Formatting dialog (Figure 94).

3) In the Styles and Formatting dialog, click on the Page Styles icon .

4) Double-click on the required page style.
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Creating new or custom styles
You can create new or custom styles using the Styles and Formatting dialog or creating a new 
style from a selection.

Note
Any new or custom styles apply only to your spreadsheet and are not saved in the
template. To save new styles in a template, see “Templates” on page 137 for more
information.

New style from styles and Formatting dialog
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or 

click the Styles and Formatting icon  on the Formatting toolbar to open the Styles and 
Formatting dialog (Figure 94).

2) To create a new cell style, click on the Cell Styles icon  in the Styles and Formatting 
dialog to open the list of cell styles.

3) To create a new page style, click on the Page Styles icon  in the Styles and Formatting 
dialog to open the list of page styles.

4) Right-click in the Styles and Formatting dialog and select New from the context menu to 
open either the Cell Style dialog (Figure 97) or the Page Style dialog (Figure 98).

5) Use the various tabbed pages in the dialogs to set the attributes for your new style. See 
“Cell style attributes” on page 127 and “Page style attributes” on page 131 for more 
information.

6) Click OK to close the dialog and save your new style.

Figure 97: Cell Style dialog – Organizer page

Figure 98: Page Style dialog – Organizer page
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New style from a selection
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or 

click the Styles and Formatting icon  on the Formatting toolbar to open the Styles and 
Formatting dialog (Figure 94).

2) To create a new cell style, click on the Cell Styles icon  in the Styles and Formatting 
dialog to open the list of cell styles.

3) To create a new page style, click on the Page Styles icon  in the Styles and Formatting 
dialog to open the list of page styles.

4) Select the style you want to use as a base for your new style.

5) Click the New Style from Selection icon  to open the Create Style dialog (Figure 99).

6) Type a name for the new style. The list box displays the names of any existing custom 
styles used in the spreadsheet.

7) Click OK to save the new style.

8) Right-click on the new style and select Modify from the context menu to open a dialog 
where you can change the style attributes. See “Cell style attributes” on page 127 and 
“Page style attributes” on page 131 for more information.

Figure 99: Create Style dialog

Note
Style names are case sensitive. You can define, for example, a style called red 
and another style called Red. Make sure all style names are sufficiently different 
to prevent any confusion.

Cell style attributes
The following attributes are available on the tabbed pages of the Cell Style dialog (Figure 97).

Organizer

• Name – displays the name of the selected style. If you are creating or modifying a custom 
style, enter a name for the style. You cannot change the name of a predefined style.

• Linked with – select an existing style that you want to base the new style on, or select 
none to define your own style.

• Category – displays the category for the current style. If you are creating or modifying a 
new style, select Custom Style from the list. You cannot change the category for a 
predefined style.

• Contains – describes the relevant formatting used in the current style.

Numbers

• Category – select a category from the list and then select a formatting style in the Format 
box. 

• Format – select how you want the contents of the selected cell(s) to be displayed. The 
code for the selected option is displayed in the Format Code box.
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When you select Currency as a category, you have to select a currency from the drop-down
list and then select the format to use from the available options for that currency.

The format code for currencies uses the form [$xxx-nnn], where xxx is the currency symbol,
and nnn the country code. Special banking symbols, such as EUR (for Euro), do not 
require the country code. The currency format is not dependent on the language that you 
select in the Language box.

The default currency format for a cell is determined by the regional settings of your 
operating system.

• Language – specifies the language setting for the selected cells. With the language set to 
Automatic, LibreOffice automatically applies the number formats associated with the 
system default language. Select any language to fix the settings for the selected cells. The 
language setting ensures that date and currency formats are preserved even when the 
document is opened in an operating system that uses a different default language setting.

• Options – specify the options for the selected format.

– Decimal places – enter the number of decimal places that you want to display.

– Leading zeroes – enter the maximum number of zeroes to display in front of the 
decimal point.

– Negative numbers in red – changes the font color of negative numbers to red.

– Use thousands separator – inserts a separator between thousands. The type of 
separator that is used depends on your language settings.

• Format code – displays the number format code for the selected format. You can also 
enter a custom format. The following options are only available for user-defined number 
formats.

• Preview Field – displays a preview of the current selection.

Font
The changes are applied to the current selection, to the entire word that contains the cursor, or to 
the new text that you type. Depending on your language settings, you can change the formatting 
for the following font types:

• Western text font – Latin character sets

• Asian text font – Chinese, Japanese, or Korean character sets

• Complex text layout font – right-to-left text direction

Note
To enable support for complex text layout and Asian character sets, go to Tools > 
Options > Language Settings > Languages and select Enabled.

• Font – enter the name of an installed font family that you want to use, or select a font from 
the list.

• Style – select the formatting you want to apply: Bold or Italic.

• Size – enter or select the font size that you want to apply. For scalable fonts, you can also 
enter decimal values. If you are creating a style that is based on another style, you can 
enter a percentage value or a point value (for example, –2pt or +5pt).

• Language – sets the language that the spelling checker uses for the selected text or the 
text that you type. The spelling checker for the selected language only functions when you 
have installed the corresponding language module. A language entry has a check mark in 
front of it if the spelling checker is activated for that language.

• Preview – displays a preview of the current selection.
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Font Effects
The changes are applied to the current selection, to the entire word that contains the cursor, or to 
the new text that you type.

• Font Color – sets the color for the selected text. If you select Automatic, the text color is 
set to black for light backgrounds and to white for dark backgrounds.

• Relief – select a relief effect to apply to the selected text. The Embossed relief makes the 
characters appear as if they are raised above the page. The Engraved relief makes the 
characters appear as if they are pressed into the page.

• Outline – displays the outline of the selected characters. This effect does not work with 
every font.

• Shadow – adds a shadow that casts below and to the right of the selected characters.

• Overlining – select the overlining style that you want to apply. To apply the overlining to 
words only, select Individual words.

• Overline color – select the color for the overlining.

• Strikethrough – select a strikethrough style for the selected text.

Note
If you save your document in MS Word format, all of the strikethrough styles are 
converted to the single line style.

• Underlining – select the underlining style that you want to apply. To apply the underlining 
to words only, select Individual words.

If you apply underlining to a superscript text, the underlining is raised to the level of the 
superscript. If the superscript is contained in a word with normal text, the underlining is not 
raised.

• Underline color – select the color for the underlining.

• Individual words – applies the selected effect only to words and ignores spaces.

• Preview – displays a preview of the current selection.

Alignment

• Text alignment – sets the alignment options for the contents of the current cell, or the 
selected cells.

– Horizontal – select the horizontal alignment option that you want to apply to the cell 
contents.

– Default – aligns numbers to the right and text to the left.

– Left – aligns the contents of the cell to the left.

– Right – aligns the contents of the cell to the right.

– Center – horizontally centers the contents of the cell.

– Justified – aligns the contents of the cell to the left and to the right cell borders.

– Filled – repeats the cell contents (number and text) until the visible area of the cell is 
filled. This feature does not work on text that contains line breaks.

– Distributed – aligns contents evenly across the whole cell. Unlike Justified, it also 
justifies the very last line of text.

– Indent – indents from the left edge of the cell by the amount that you enter.

– Vertical – select the vertical alignment option that you want to apply to the cell contents.

– Default – aligns the cell contents to the bottom of the cell.
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– Top – aligns the contents of the cell to the upper edge of the cell.

– Bottom – aligns the contents of the cell to the lower edge of the cell.

– Middle – vertically centers the contents of the cell.

– Justified – aligns the contents of the cell to the top and to the bottom cell borders.

– Distributed – aligns contents evenly across the whole cell. Unlike Justified, it also 
justifies the very last line of text.

• Text orientation – defines the text direction of cell contents.

– ABCD wheel – click anywhere in the wheel to define the text orientation. The characters
"ABCD" on the wheel correspond to the new setting.

– Vertically stacked – assigns vertical text orientation for cell contents.

– Degrees – allows you to manually enter the orientation angle. A positive number rotates
the text to the left and a negative number rotates the text to the right.

– Reference edge – specify the cell edge from which to write the rotated text.

Text Extension From Lower Cell Border – writes the rotated text from the bottom cell 
edge outwards.

Text Extension From Upper Cell Border – writes the rotated text from the top cell edge
outwards.

Text Extension Inside Cells – writes the rotated text only within the cell.

• Properties – determine the text flow in a cell.

– Wrap text automatically – wraps text onto another line at the cell border. The number of 
lines depends on the width of the cell. To enter a manual line break, press Ctrl+Enter in 
the cell.

– Hyphenation active – enables word hyphenation for text wrapping to the next line.

– Shrink to fit cell size – reduces the apparent size of the font so that the contents of the 
cell fit into the current cell width. You cannot apply this command to a cell that contains 
line breaks.

Borders
Sets the border attributes for the selected cells.

• Line arrangement – select a predefined border style to apply. In a spreadsheet, you can 
also add or remove predefined borders with the Borders icon on the Table toolbar.

• Line – select the border style, width, and color that you want to apply. The style is applied 
to the borders selected in the preview.

• Spacing to contents – specify the amount of space that you want to leave between the 
border and the contents of the selection.

– Left – enter the distance between the left border and the contents of the selection.

– Right – enter the distance between the right border and the contents of the selection.

– Top – enter the distance between the top border and the contents of the selection.

– Bottom – enter the distance that between the bottom border and the contents of the 
selection.

– Synchronize – applies the same spacing to contents setting to all four borders when 
you enter a new distance.

• Shadow style – applies a shadow effect to borders. For the best results, only apply this 
effect when all four borders are visible. Graphics or objects that are anchored to a frame in 
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the document cannot exceed the size of the frame. If you apply a shadow to the borders of 
an object that fills an entire frame, the size of the object is reduced to display the shadows.

– Position – select a shadow style for the selected borders.

– Distance – enter the distance the shadow extends from the object.

– Color – select a color for the shadow.

Background
Select a color that you want to use as a background for your selected cells. To remove a 
background color, select No Fill.

Cell protection

• Hide all – hides formulas and contents of the selected cells.

• Protected – prevents the selected cells from being modified. This cell protection only takes
effect if you also protect the sheet.

• Hide formula – hides formulas in the selected cells.

• Hide when printing – prevents the selected cells from being printed.

Page style attributes
The following attributes are available on the various tabbed pages of the Pages Style dialog 
(Figure 98).

Organizer

• Name – displays the name of the selected style. If you are creating or modifying a custom 
style, enter a name for the style. You cannot change the name of a predefined style.

• Linked with – select an existing style that you want to base the new style on, or select 
none to define your own style.

• Category – displays the category for the current style. If you are creating or modifying a 
new style, select Custom Style from the list. You cannot change the category for a 
predefined style.

• Contains – describes the relevant formatting used in the current style.

Page
You can define page layouts for single and multiple-page documents, as well as page numbering 
and paper formats.

• Paper format – select from a list of predefined paper sizes, or define a custom paper 
format.

– Format – select a predefined paper size, or create a custom format by entering the 
dimensions for the paper in the Height and Width boxes.

– Width – displays the width of the selected paper format. To define a custom format, 
enter a width here.

– Height – displays the height of the selected paper format. To define a custom format, 
enter a height here.

– Orientation: Portrait – displays and prints the current document with the paper oriented 
vertically.
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– Orientation: Landscape – displays and prints the current document with the paper 
oriented horizontally.

– Paper tray – select the paper source for your printer. If you want, you can assign 
different paper trays to different page styles. For example, you can assign a different 
tray for the first page style in your spreadsheet and load the tray with your company 
letterhead paper.

• Margins – specify the amount of space to leave between the edges of the page and the 
document text.

– Left/Inner – enter the amount of space to leave between the left edge of the page and 
the document text. If you are using Mirrored page layout, enter the amount of space to 
leave between the inner text margin and the inner edge of the page.

– Right/Outer – enter the amount of space to leave between the right edge of the page 
and the document text. If you are using Mirrored page layout, enter the amount of 
space to leave between the outer text margin and the outer edge of the page.

– Top – enter the amount of space to leave between the upper edge of the page and the 
document text.

– Bottom – enter the amount of space to leave between the lower edge of the page and 
the document text.

• Layout settings – select the page layout style to use in the current document.

– Page layout: Right and left – shows both odd and even pages with left and right 
margins as specified.

– Page layout: Mirrored – shows both odd and even pages with inner and outer margins 
as specified. Use this layout if you want to bind the printed pages like a book. Enter the 
binding space as the Inner margin.

– Page layout: Only right – shows only odd (right) pages. Even pages are shown as blank
pages.

– Page layout: Only left – shows only even (left) pages. Odd pages are shown as blank 
pages.

– Format – select the page numbering format to use for the page style.

– Table alignment: Horizontal – centers the cells horizontally on the printed page.

– Table alignment: Vertical – centers the cells vertically on the printed page.

Borders and Background
See “Borders” and “Background” in “Cell style attributes” above for information on how to set the 
borders and background for page styles.

Header
Adds a header to the page style. A header is an area in the top page margin where you can add 
text or graphics.

• Header on – adds a header to the page style.

• Same content left/right – even and odd pages share the same content. To assign a 
different header to even and odd pages, deselect this option and then select Edit.

• Left margin – enter the amount of space to leave between the left edge of the page and 
the left edge of the header.

• Right margin – enter the amount of space to leave between the right edge of the page and
the right edge of the header.

Chapter 4  Using Styles and Templates in Calc 132



• Spacing – enter the amount of space to maintain between the bottom edge of the header 
and the top edge of the document text.

• Height – enter the height that you want for the header.

• AutoFit height – automatically adjusts the height of the header to fit the content.

• Preview – displays a preview of the current selection.

• More – defines a border, background color, or background pattern for the header.

• Edit – allows you to add or edit header text.

Footer
Adds a footer to the page style. A footer is an area in the bottom page margin where you can add 
text or graphics. See “Header” above for information on the available options you can use for a 
footer.

Sheet
Specifies the elements to be included in the printout of all sheets with the page style. Additionally, 
you can set the print order, the first page number, and the page scale.

• Page Order – defines the order in which data in a sheet is numbered and printed when it 
does not fit on one printed page.

– Top to bottom, then right – prints vertically from the left column to the bottom of the 
sheet.

– Left to right, then down – prints horizontally from the top row of the sheet to the right 
column.

– First page number – select this option if you want the first page to start with a number 
other than 1.

• Print – defines which elements of the spreadsheet are to be printed.

– Column and row headers – specifies whether you want the column and row headers to 
be printed.

– Grid – prints the borders of the individual cells as a grid. For the view on screen, make 
your selection in Tools > Options ->LibreOffice Calc ->View > Grid lines.

– Comments – prints the comments defined in your spreadsheet. They will be printed on 
a separate page along with the corresponding cell reference.

– Objects/graphics – includes all inserted objects (if printable) and graphics with the 
printed document.

– Charts – prints the charts that have been inserted into your spreadsheet.

– Drawing objects – includes all drawing objects in the printed document.

– Formulas – prints the formulas contained in the cells, instead of the results.

– Zero values – specifies that cells with a zero value are printed.

• Scale – defines a page scale for the printed spreadsheet.

– Scaling mode – select a scaling mode from the drop-down list. Appropriate controls will 
be shown below this option.

– Reduce/enlarge printout – specifies a scaling factor to scale all printed pages.

– Scaling factor – enter a percentage figure for scaling your spreadsheet for printing. The 
default setting is 100%.
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– Fit print range(s) to width/height – specifies the maximum number of pages horizontally 
(width) and vertically (height) on which every sheet with the same page style is to be 
printed.

The print ranges are always scaled proportionally, so the resulting number of pages 
may be less than specified.

You may deselect one of the options, then the unspecified dimension will use as many
pages as necessary.

If you deselect both options, this will result in a scaling factor of 100%.

– Width in pages – enter the maximum number of pages to be printed horizontally across.

– Height in pages – enter the maximum number of pages to be printed vertically stacked.

– Fit print range(s) on number of pages – specifies the maximum number of pages on 
which every sheet with the same page style is to be printed. The scale will be reduced 
as necessary to fit the defined number of pages.

– Number of pages – enter the maximum number of pages to be printed.

Modifying and updating styles

Modifying styles
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or 

click the Styles and Formatting icon  on the Formatting toolbar to open the Styles and 
Formatting dialog (Figure 94).

2) To modify a cell style, click on the Cell Styles icon  in the Styles and Formatting dialog 
to open the list of cell styles.

3) To modify a page style, click on the Page Styles icon  in the Styles and Formatting 
dialog to open the list of page styles.

4) Right-click on the style name you want to modify and select Modify from the context menu 
to open either the Cell Style dialog (Figure 97) or the Page Style dialog (Figure 98).

5) Make the necessary changes to the style attributes. For more information on style 
attributes, see “Cell style attributes” on page 127 and “Page style attributes” on page 131.

6) Click OK to save the changes and close the dialog.

Note
The Modify command is unavailable if one or more sheets are protected, even if 
the style to be modified is being used in an unprotected sheet.

Updating styles
Updating styles can only be carried out on cell styles as follows:

1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or 

click the Styles and Formatting icon  on the Formatting toolbar to open the Styles and 
Formatting dialog (Figure 94).

2) Click on the Cell Styles icon  in the Styles and Formatting dialog to open the list of cell 
styles.

3) Select a cell on the spreadsheet that is using the cell style you want to update and highlight
the data in the cell. The cell style name will be highlighted in the Styles and Formatting 
dialog.

4) Make the necessary format changes to the data.
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5) Click on the Update Style icon  and the cell style attributes will be updated with your 
changes. Any other cells using the same cell style will also be updated to with your 
changes.

Hiding, showing and displaying styles

Hiding styles
Hiding styles can only be carried out on cell styles as follows. Only styles that are not being used in
the spreadsheet can be hidden.

1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or 

click the Styles and Formatting icon  on the Formatting toolbar to open the Styles and 
Formatting dialog (Figure 94).

2) Click on the Cell Styles icon  in the Styles and Formatting dialog to open the list of cell 
styles.

3) Right click on an unused cell style and select Hide from the context menu. The style is then
moved to the Hidden Styles category in the Styles and Formatting dialog.

Showing styles
1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or 

click the Styles and Formatting icon  on the Formatting toolbar to open the Styles and 
Formatting dialog (Figure 94).

2) Click on the drop-down list at the bottom of the Styles and Formatting dialog and select 
Hidden Styles from the list.

3) Right click on the hidden style you want to show and select Show from the context menu. 
The style will then be displayed in the Styles and Formatting dialog.

Displaying styles
The Styles and Formatting dialog can display different categories of styles as follows:

1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or 

click the Styles and Formatting icon  on the Formatting toolbar to open the Styles and 
Formatting dialog (Figure 94).

2) Click on the drop-down list at the bottom of the Styles and Formatting dialog.

3) Select the style category you want displayed in the Styles and Formatting dialog. The 
categories are as follows:

– Hierarchical – lists the styles used in an outline and normally only applies to documents 
that use a hierarchical outline.

– All Styles – lists all the styles that are available in Calc and in your spreadsheet, except 
for Hidden Styles.

– Hidden Styles – lists all the styles that have been hidden in a spreadsheet.

– Applied Styles – lists only the styles that have been applied to the spreadsheet.

– Custom Styles – lists only the styles that you have created for use in a spreadsheet or a
template.
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Copying cell styles
To copy a cell style already in use to another cell in your spreadsheet or into a cell in another 
spreadsheet:

1) Click one of the cells that has been assigned the style you want to copy, and then copy the 
cell to the clipboard.

2) Select the cells that are to receive the same formatting as the copied cell.

3) Go to Edit > Paste Special on the menu bar to open the Paste Special dialog (Figure 100).

4) Make sure that only Formats is selected and click OK to paste the style formatting 
attributes into the cell.

Figure 100: Paste Special dialog

Deleting styles
You can only delete styles that you have created. The styles that are included with LibreOffice as 
part of the software installation cannot be deleted.

1) Go to Format > Styles and Formatting on the main menu bar, or press the F11 key, or 

click the Styles and Formatting icon  on the Formatting toolbar to open the Styles and 
Formatting dialog (Figure 94).

2) To delete a cell style, click on the Cell Styles icon  in the Styles and Formatting dialog 
to open the list of cell styles.

3) To delete a page style, click on the Page Styles icon  in the Styles and Formatting 
dialog to open the list of page styles.

4) Right-click on the style you want to delete and select Delete from the context menu.

5) Select Yes on the warning message that opens to delete the style. Any data in a cell or a 
sheet in the spreadsheet that used the deleted style will revert to the Default style included 
with Calc.
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Templates

Creating templates
Templates are created from a new or existing spreadsheet as follows:

1) Open a new or existing spreadsheet that you want to use as a base for a template.

2) Add any necessary pre-defined content that you want to appear in a spreadsheet each time
you use the new template. For example, company logo and name, company information, 
page numbers, and so on.

3) Create all the cell and page styles that you want to use in your new template.

4) Go to File > Save as Template on the main menu bar, or use the keyboard combination 
Shift+F11 to open the Template Manager dialog (Figure 101).

5) Double-click to open the folder where you want to save your template or create a new 
folder for spreadsheet templates. It is recommended to use the My Templates folder for all 
your LibreOffice templates.

6) Click the Save icon  and type a memorable name for your template.

7) Click OK to save the new template.

Figure 101: Template Manager dialog

Note
When you create and save a spreadsheet template, it will be automatically saved in
the Spreadsheets section in the Template Manager.

Editing templates
1) Go to File > New > Templates on the main menu bar, or click on the Templates button on 

the LibreOffice opening dialog to open the Template Manager dialog. By default, the 
Template Manager opens in the My Templates folder.

2) Click on the Spreadsheets tab or navigate to the folder where you have saved your 
spreadsheet templates.

3) Select the template that you want to edit. When you do this, a row of icons appears above 
the templates (see Figure 102).

4) Click the Edit icon  and the spreadsheet template opens in Calc.

5) Make all necessary to the template content, cell styles, and page styles just as you would 
with a spreadsheet.

6) Go to File > Save on the menu bar to save your changes, or go to File > Save As 
Template on the main menu bar to save the edited template as a new template.
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Figure 102: Template Manager dialog – Editing templates

Creating spreadsheets from templates
To create a spreadsheet from a template:

1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 102).

2) Select the Spreadsheets tab and navigate to the folder where the template is located. The 
default folder for templates is My Templates.

3) Select the template you want to use and click on the Open icon , or double-click on the
template to open it. The Template Manager closes and a new spreadsheet opens in Calc.

4) Go to File > Save As on the main menu bar, or use the keyboard combination Ctrl+Shift+S 
and save your new spreadsheet with the filename you want to use.

Updating styles from a changed template
If you make any changes to a template and its styles, the next time you open a spreadsheet that 
was created before you changed the template, a confirmation message is displayed.

1) Click Update Styles to apply the changed styles in the template to the spreadsheet.

2) Click Keep Old Styles if you do not want to apply the changed styles in the template to the
spreadsheet.

Note
If you select Keep Old Styles, the confirmation message will not appear again the 
next time you open the spreadsheet using the same changed template.

Setting default template
If you create a new spreadsheet using File > New > Spreadsheet on the main menu bar, Calc 
creates the document from the default template for spreadsheets. You can, however, set any 
template as the default template. You can also reset the default template to the Calc default 
template at a later date if you want to.
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Setting a template as default
You can set any template to be the default, but the template must be located in one of the folders 
displayed in the Template Manager dialog.

1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 102).

2) Navigate to the folder containing the template that you want to set as the default.

3) Select the template.

4) Click on the Set As Default icon . The next time that you create a new spreadsheet, it 
will be created from this template.

Resetting default template
To set the default spreadsheet template back to the default template supplied with Calc:

1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 102).

2) Click on the Action Menu icon.

3) Select Reset Default Template > Spreadsheet from the context menu. The next time that 
you create a new spreadsheet, it will be created using the Calc default template.

Note
Resetting the default template back to the Calc default template is only available if the
default has been changed previously.

Associating spreadsheets with a different template
At times you might want to use or associate a spreadsheet with a different template. The main 
advantage of associating a spreadsheet with a different template is that it makes it easier to update
the styles if the requirement arises.

For best results when associating spreadsheets with another template is to make sure that the 
style names in the spreadsheet and in the template are the same. If the names are not the same, 
you will need to use Search and Replace function in Calc to replace the old styles with new ones. 
See Chapter 2 Entering, Editing, and Formatting Data for more information about finding and 
replacing styles.

1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 102).

2) Navigate to the folder containing the template that you want to use.

3) Double click on the template and a new blank spreadsheet is created.

4) Open the spreadsheet you want to associate with the template.

5) Go to Edit > Select All on the main menu bar, or use the keyboard combination Ctrl+A to 
select everything in the spreadsheet you want to change.

6) Go to Edit > Copy on the main menu bar, or use the keyboard combination Ctrl+C to copy 
the spreadsheet data to the clipboard.

7) Close the old spreadsheet without saving.

8) In the new blank spreadsheet, go to Edit > Paste on the main menu bar, or use the 
keyboard combination Ctrl+V to paste the data into the spreadsheet.

9) Go to File > Save As on the main menu bar, or use the keyboard combination Ctrl+Shift+S 
to save this new spreadsheet with the filename as the old spreadsheet.

10) When asked, confirm that you want to overwrite the old file.
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Organizing templates
LibreOffice can only use templates that are in its template folders. You can create new template 
folders and use them to organize your templates and import templates into these folders. For 
example, you might have one template folder for sales templates and another for invoice 
templates. You can also export templates.

Tip
The location of template folders in LibreOffice depends on the operating system of 
your computer. If you want to know where the template folders are located, go to 
Tools > Options > LibreOffice > Paths.

Creating template folders
1) Go to File > New > Templates on the main menu bar to open the Template Manager 

dialog. If necessary, click on All Templates to display the view shown in Figure 101.

2) Click the New Folder icon .

3) In the pop-up dialog, type a name for the new folder and click OK. The new folder now 
appears in the list of folders.

Deleting template folders
You cannot delete template folders supplied with LibreOffice. You can only delete template folders 
that you have created.

1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 102).

2) Select the folder that you want to delete.

3) Click the Delete icon .

4) Click Yes to confirm the deletion and the folder and templates inside the folder are deleted.

Moving templates
To move a template from one template folder to another template folder:

1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 102).

2) Navigate to the folder containing the template that you want to move to another folder.

3) Select the template you want to move.

4) Click the Move to folder icon  and select the folder you want to use from the context 
menu. The selected template is moved to the folder.

Deleting templates
You cannot delete templates supplied with LibreOffice. You can only delete templates that you 
have created or imported.

1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 102).

2) Select the folder that you want to delete.

3) Click the Delete icon .

4) Click Yes to confirm the deletion and the folder and templates inside the folder are deleted.
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Importing templates
You can import and add templates to your collection as follows:

1) Open your browser software and locate the web page where the template is located. It is 
recommended to use the link http://templates.libreoffice.org/template-center which will take 
you to the LibreOffice Template Center where you will find several templates that are fully 
compatible with LibreOffice.

2) Download the template you want to use.

3) In Calc, go to File > New > Templates to open the Template Manager dialog (Figure 103).

4) Click on the Import icon  and navigate to the folder where the downloaded template is 
located on your computer.

5) Select the template and click Open. After import, the template becomes available in the 
Template Manager.

Figure 103: Template Manager dialog – Importing templates

Note
It is recommended to import templates using the above procedure as this places 
the templates into the correct location for LibreOffice to locate the templates.

Exporting templates
To export a template from a template folder to another location:

1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 102).

2) Navigate to the folder containing the template that you want to export.

3) Select the template that you want to export.

4) Click the Export icon and the Save As dialog opens.

Navigate to the location where you want to export the template and click Save. If necessary, you 
can also rename the template.
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Graphics in Calc

Calc is often used to present data, and to make forecasts and predictions. Graphics can turn an 
average spreadsheet into a more professional and memorable spreadsheet. Calc can import 
various vector (line drawing) and raster (bitmap) file formats. The most commonly used graphic 
formats are GIF, JPG, PNG, and BMP. See LibreOffice Help for a full list of the formats that Calc 
can import.

Graphics in Calc are of three basic types:

• Image files, such as photographs, drawings, and scanned images

• Diagrams created using LibreOffice drawing tools

• Charts and graphs created using LibreOffice Chart facility, see Chapter 3 Creating Charts 
and Graphs for more information

Although using graphics in Calc is very similar to using graphics in any other component of 
LibreOffice, this chapter explains some of the differences in their use. It also covers some of the 
more advanced graphics functions and how they can further enhance your spreadsheet.

Note
The term graphics refers to both pictures and drawing objects. Often the word 
images is used when referring to pictures and other graphics that are not drawing 
objects.

Adding graphics (images)

Graphics or images (sometimes called pictures in LibreOffice), such as corporate logos and 
photographs, are probably the most common types of graphics added to a Calc spreadsheet. They
may be, for example, downloaded from the Internet, scanned, created with a graphics program; or 
photographs taken with a digital camera.

Images can be inserted in three ways:

• Using the Insert Picture dialog

• From the gallery

• From the clipboard by copying and pasting

Inserting image files
The most common source of graphics is existing files and to insert an image from a file as follows:

1) Click in the cell in the spreadsheet where you want the image to appear. Do not worry too 
much about the position of the file as positioning can be changed, see “Positioning, resizing
and arranging images” on page 155 for more information.

2) Go to Insert > Picture > From File on the main menu bar, or click the From File icon  
on the Insert toolbar to open the Insert Picture dialog (Figure 104). If the Insert toolbar is 
not open, go to View > Toolbars > Insert on the main menu bar.

3) On the Insert Picture dialog, navigate to the file to be inserted and select it.

4) If required, select Preview to view a thumbnail of the selected image on the right of the 
dialog so you can verify that you have the correct file.

5) Click Insert as Link or Link (depending on computer setup) if you want to link the file to 
the original file (see “Linking files” below for more information). If you do not select Insert 
as Link or Link, the file is embedded into the spreadsheet (see “Embedding image files” 
below for more information).
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Figure 104: Insert Picture dialog

6) Click Open and the file is inserted into the spreadsheet as a floating image and is anchored
to the cell in which the cursor was placed.

Note
The Insert Picture dialog may look different from the one shown in Figure 104, 
depending on your operating system and whether you have selected to use the 
LibreOffice Open/Save dialogs in Tools > Options > LibreOffice > General.

Linking files
To create a link to a file containing an image instead of embedding the image into a spreadsheet, 
use the Insert picture dialog and select the Insert as Link or Link option. When you click Open, a 
warning dialog (Figure 105) opens informing you of the hazards of linking a file and asks you to 
confirm whether you want to Keep Link or change to Embed Graphic.

Figure 105: Linking warning dialog
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Click Keep Link and the image is displayed in the document, but when the document is saved, it 
contains only a reference to the image file and not the image itself. The document and the image 
remain as two separate files, which are temporarily merged only when you open the spreadsheet 
again.

Click Embed Graphic and the image is displayed in the spreadsheet. The image file is embedded 
into the spreadsheet and the two files become one file. See “Embedding image files” below for 
more information.

• Advantage – you can modify the image file separately without changing the spreadsheet 
because the link to the file remains valid and the modified image will appear when you next
open the spreadsheet. This can be a big advantage if you (or someone else, perhaps a 
graphic artist) is updating images.

• Advantage – linking can reduce the file size of the spreadsheet when it is saved, because 
the image file itself is not included. However, file size is usually not a problem on modern 
computers with a reasonable amount of memory, unless the spreadsheet includes many 
large graphics files. Calc can easily handle large files.

• Disadvantage – if you send the document to someone else, or move it to a different 
computer, you must also send the image files and keep the same file structure. This 
prevents the link from being broken and blank areas appearing in the spreadsheet because
Calc cannot find the linked file. For example, you might keep image files in a subfolder 
named Images inside the same folder containing the Calc document. Any recipient of the 
Calc spreadsheet needs to put the image files in a subfolder with the same name in the 
same named folder as the Calc spreadsheet.

Note

When inserting the same image several times in the document, it might appear 
beneficial to create links. However, this is not necessary, as LibreOffice embeds 
only one copy of the image file in the document. Deleting one or more of the 
copies does not affect the other copies of the same file.

Embedding image files
Embedding a image into your spreadsheet makes the image a permanent part of your 
spreadsheet. Any changes you make to an embedded image will only appear in your spreadsheet 
and the original image file will not affected.

Embedding happens when you insert an image into your spreadsheet using copying and pasting, 
or clicking Embed Graphic when inserting files with the Insert Picture dialog.

• Advantage – embedding graphics into your spreadsheet is that the graphic is always 
available no matter what computer is used to open the spreadsheet.

• Disadvantage – embedding graphics is that it creates large file sizes, which may not be 
desirable if you have limited capacity for storing computer files. Also, if the original graphic 
is altered, then your drawing will not have an up to date version each time you open your 
drawing.

Note
When a raster graphic is embedded into a LibreOffice spreadsheet, the format of that 
graphic is automatically changed to PNG format.
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Embedding linked image files
If you originally linked the image files, you can easily embed and save in a Calc spreadsheet at a 
later time if you so wish.

1) Open the spreadsheet in Calc.

2) Go to Edit > Links on the main menu bar to open the Edit Links dialog (Figure 106) shows 
all the linked files.

Figure 106: Edit Links dialog

3) Select the files you want to change from linked to embedded.

4) Click Break Link and confirm you want to remove the selected link. The file then becomes 
embedded into the spreadsheet.

Note
Going from embedded to linked files is not so easy. You must delete each 
embedded file and, one at a time, selecting the Insert as Link or Link option when
you reinsert each file.

Copying and pasting
Using the clipboard, you can copy and paste images from one Calc spreadsheet into another Calc 
spreadsheet, or from another component of LibreOffice (Writer, Draw, and so on) into a 
spreadsheet, or from other programs into a Calc spreadsheet. Copying and pasting embeds the 
image file 

1) Open both the source document and the Calc spreadsheet into which you want to copy the 
image.

2) In the source document, select the image to be copied.

3) Go to Edit > Copy on the main menu bar, or click the Copy icon  on the Standard 
toolbar, or use the keyboard shortcut Ctrl+C to copy the image to the clipboard.

4) Switch to the Calc spreadsheet and click in the cell where the image is to be inserted.

5) Go to Edit > Paste on the main menu bar, or click the Paste icon  on the Standard 
toolbar, or use the keyboard shortcut Ctrl+V to paste the image into the spreadsheet.
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Note

You can also right-click and select Copy from the context menu to copy the image 
to the clipboard. You then right-click in the cell you want to use for an anchor and 
select Paste from the context menu to embed the image into your spreadsheet. 
However, this method only works for image files when you are copying and pasting
between modules of LibreOffice.

Using the Gallery
The Gallery (Figure 107) provides a convenient way to make available reusable objects such as 
images and sounds that you can insert into your documents. The Gallery is available in all 
components of LibreOffice and has several images grouped together in collections or themes, for 
example Finance, Computer, People and so on. However, you can add your own images by using 
My Theme or creating a theme. The Gallery is explained in more detail in the Getting Started 
Guide Chapter 11 Graphics, the Gallery, and Fontwork.

Figure 107: Gallery dialog

1) Click on the Gallery icon  on the Standard toolbar or go to Tools > Gallery on the main
menu bar to open the Gallery.

2) Navigate through the Gallery to find the required image.

3) Right-click on the required image and select Insert > Copy from the context menu or click 
and drag the image from the Gallery into the Calc spreadsheet.

By default, the Gallery is docked above the Calc spreadsheet. To expand the Gallery, position the 
cursor over the line that divides it from the top of the spreadsheet. When the cursor changes to 
parallel lines with arrows, click and drag downward. The spreadsheet automatically re-sizes in 
response.

To expand the Gallery without affecting the workspace, undock it so it floats over the workspace. 
Hold down the Ctrl key and double-click on the Gallery title bar, or use the keyboard shortcut 
Ctrl+Shift+F10. The Gallery then becomes a floating dialog on top of the spreadsheet.

To dock the Gallery in its default position above the spreadsheet, hold down the Ctrl key and 
double-click on the Gallery title bar.

When the Gallery is docked, you can hide it and view the full Calc spreadsheet. Click the 
Hide/Show button (highlighted in Figure 107) in the bar separating the Gallery from the 
spreadsheet. To show the Gallery again, click the Hide/Show button again. To close the Gallery, go
to Tools > Gallery on the main menu bar and uncheck Gallery, or click on the Gallery icon again.
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Modifying images

When you insert a new image, you may need to modify it to suit the document. This section 
describes how to resize, crop, rotate and adjust an image in Calc. Any changes made in Calc do 
not affect the original image, whether it is an embedded or linked image file.

Calc provides several tools for working with images and these tools are sufficient for most 
requirements. However, for professional results it is generally better to use a software designed to 
modify image files, for example GIMP, and then insert the result into Calc. GIMP is an open-source
graphics program that can be downloaded from http://www.gimp.org/downloads/.

Figure 108: Picture toolbar and available tools

Using the Picture toolbar
When you insert an image or select one already present in your spreadsheet, the Picture toolbar 
opens (Figure 108). If it does not open, go to View > Toolbars > Picture on the main menu bar. 
The tools available from left to right on the Picture toolbar are as follows:

• Filter – opens the Graphic Filter toolbar, which is described in “Using graphic filters” on 
page 151.

• Graphics mode – changes the display of the graphic from color to grayscale, black and 
white, or a watermark. This setting affects only the display and printing of the picture; the 
original picture file remains unchanged.

– Default – the graphic is displayed unaltered in color.

– Grayscale – the graphic is displayed in 256 shades of gray.

– Black/White – the graphic is displayed in black and white.

– Watermark – the brightness and contrast of the graphic are reduced to the extent that 
the graphic can be used as a watermark (background).
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• Color – opens the Color toolbar (Figure 109) to adjust the values of the RGB colors, 
brightness, contrast and Gamma. These adjustments do not affect the original picture, but 
the values are stored in LibreOffice as a separate formatting set.

– Red, Green, Blue – select values between -100% (no color) to +100% (full intensity); 
0% represents the original color value of the graphic.

– Brightness – select a value between –100% (totally black) and +100% (totally white).

– Contrast – select a value between –100% (minimum) and +100% (maximum).

– Gamma – this affects the brightness of the middle color tones. Select a value between 
0.10 (minimum) to 10 (maximum) Try adjusting this value if changing brightness or 
contrast does not give you the required result.

Figure 109: Color toolbar

• Transparency – adjust the degree of transparency of the picture between 0% (opaque) 
and 100% (fully transparent).

• Line – opens the Line dialog so you can adjust the border style of the selected image. See 
the Draw Guide for more information on how to modify lines.

• Area – opens the Area dialog allowing you to edit color, gradient, hatching and fills of the 
background area that contains the image — not the image itself. To see the background, 
you must set the transparency of the image to a suitably high value. See the Draw Guide 
for more information on how to modify areas.

• Shadow – sets the default shadow effect around the image. To adjust the shadow effect, 
open the Area dialog and click on the Shadow tab. See the Draw Guide for more 
information on how to modify shadows.

• Crop Picture – opens the Crop dialog and allows you to crops or trims the selected image.
For more information, see “Cropping images” on page 152.

• Anchor – allows you to toggle between anchoring the image to a cell or to a page. For 
more information, see “Anchoring images” on page 158.

• Bring to Front – brings the selected image to the front of the stack when there is more 
than one image in the spreadsheet. For more information, see “Arranging images” on page
158.

• Send to Back – sends the selected image to the rear of the stack when there is more than 
one image in the spreadsheet. For more information, see “Arranging images” on page 158.

• To Foreground – allows the image to float in front of the spreadsheet cells. For more 
information, see “Arranging images” on page 158.

• To Background – moves the selected image into the background so that appears behind 
the spreadsheet cells. For more information, see “Arranging images” on page 158.

• Display Grid – displays or hides grid lines that you can use to align images on a page.

• Snap to Grid – automatically aligns images to vertical and horizontal grid lines. To override
this feature, hold down the Alt key when you drag an object.

• Helplines While Moving – displays guides or helplines when dragging an image to a new 
position.

• Alignment – if two or more images are selected, adjusts the horizontal and vertical 
alignment of the images in relation to each other. For more information, see “Aligning 
images” on page 159.
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Using graphic filters

Note

Applying graphic filters to any image consecutively will progressively degrade the 
quality of the image. The graphic filters used in Calc utilize what is known as a 
destructive editing algorithm, whereby each filter is applied to the image 
immediately, changing the original data of the image. Successive transformations 
result in less and less original data remaining, thus compromising the quality of the
inserted picture. While this might be acceptable for use in simple documents, it is 
still recommended that dedicated photo or image editing software be used to 
perform anything but the simplest of manipulations.

Figure 110: Graphic Filter toolbar and tools

After selecting an image and the Picture toolbar (Figure 108) has opened, click on the Filter icon

 to open the Graphic Filter toolbar (Figure 110). Filters work on the current view of a graphic 
and they can be combined. Filters always apply to the entire graphic and it is not possible to use 
filters to edit only a part of the object.

• Invert – inverts or reverses the color values of a color image (similar to a color negative), 
or the brightness values of a grayscale image. Apply the filter again to revert to the original 
image.

• Smooth – softens or blurs the image by applying a low pass filter reducing the contrast 
between neighboring pixels and produces a slight lack of sharpness. Also opens the 
Smooth dialog where you can set the Smooth Radius parameter used for the Smooth filter 
when you click OK.

• Sharpen – sharpens the image by applying a high pass filter increasing the contrast 
between neighboring pixels emphasizing the difference in brightness. This will accentuate 
the outlines and the effect will be strengthened if you apply the filter several times.

• Remove Noise – removes noise by applying a median filter by comparing every pixel with 
its neighbors. It then replaces extreme values of those pixels that deviate in color by a large
amount from a mean value by a pixel with a mean color value. The amount of picture 
information does not increase, but because there are fewer contrast changes resulting in a 
graphic that looks smoother.
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• Solarization – solarization is a phenomenon in photography in which the image recorded 
on a negative or on a photographic print is wholly or partially reversed in tone. Dark areas 
appear light or light areas appear dark. Solarization was originally a photochemical effect 
used during photographic film development and is now used in the digital world of 
computing to create a change or reversal of color.

Clicking Solarization opens the Solarization dialog allowing you to define the threshold 
value for solarization. Entering a Threshold value above 70% reverses the color values. 
Selecting the Invert option, all the colors are inverted.

• Aging – aging creates a look that resembles photographs developed in the early days of 
photography. All pixels are set to their gray values and then the green and blue color 
channels are reduced by the amount specified in the Aging dialog while the red color 
channel is not changed. Clicking Aging opens the Aging dialog allowing you to define the 
Aging degree and create an old look for your graphic.

• Posterize – posterizing reduces the number of colors in a graphic making it look flatter. 
When used on a photograph, posterizing can make the photograph look like a painting. 
Clicking Posterize opens the Posterize dialog allowing you to define the number of Poster 
colors to produce the effect you want.

• Pop Art – changes the colors of an image to a pop-art format.

• Charcoal Sketch – displays the image as a charcoal sketch. The contours of the graphic 
are drawn in black and the original colors are suppressed.

• Relief – this filter calculates the edges of an image in relief as if the image is illuminated by 
a light source. Clicking Relief opens the Relief dialog where you can select the position of 
the Light source producing shadows that differ in direction and magnitude.

• Mosaic – this filter joins groups of pixels and converts them into a rectangular tile in a 
single color creating an image that appears to be a mosaic. The larger the individual 
rectangles created, the fewer details the mosaic graphic has.

Clicking Mosaic opens the Mosaic dialog allowing you to set the number of pixels used to 
create the Width and Height of each tile created. Selecting Enhanced edges will enhance 
the edges of each tile to create a sharper definition.

Cropping images
When you only want to display a section of an image in your spreadsheet, you may can crop or 
hide parts of an image. If you want to remove or delete areas of an image then it is recommended 
to use LibreOffice Draw or another graphics package before inserting the image into your 
spreadsheet.

1) Select the image in your spreadsheet.

2) Click the Crop Picture icon  on the Picture toolbar to open the Crop dialog (Figure 111).

3) Using the options available in the Crop dialog and described below, specify how the image 
is cropped. It is not possible to use the mouse for cropping an image in Calc. The thumbnail
shown in the dialog preview displays the image area that will remain after cropping with an 
inner rectangle.

4) Click OK to close the dialog and your cropped image is displayed in your spreadsheet.

Note
If you crop an image in Calc, the original image file is not affected. However, if you 
export the spreadsheet to HTML format, the full original image is exported, not the 
cropped image.
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Figure 111: Crop dialog

Note
The cropped shape is always a rectangle. More complex cropped shapes are not 
possible in Calc. To create more complex shapes when cropping, use a dedicated 
photograph or image editing software, then import the resulting image into Calc.

The options available in the Crop dialog are as follows:

• Crop – allows you to trim or scale the selected image, or to add white space around the 
image.

– Keep scale – maintains the original scale of the image when cropping so that only the 
size of the image changes.

– Keep image size – maintains the original size of the image when you crop so that only 
the scale of the image changes. To reduce the scale of the image, select this option and
enter negative values in the cropping boxes. To increase the scale of the image, enter 
positive values in the cropping boxes.

– Left and Right – if Keep Scale is selected, enter a positive amount to trim the left or 
right edge of the image, or a negative amount to add white space to the left or right of 
the image. If Keep image size is selected, enter a positive amount to increase the 
horizontal scale of the image, or a negative amount to decrease the horizontal scale of 
the image.

– Top and Bottom – if Keep Scale is selected, enter a positive amount to trim the top or 
bottom of the image, or a negative amount to add white space above or below the 
image. If Keep image size is selected, enter a positive amount to increase the vertical 
scale of the image, or a negative amount to decrease the vertical scale of the image.

• Scale – allows you to change the scale of the selected image. In the Width and Height 
fields enter a value for the width or height of the selected image as a percentage.

• Image size – allows you to change the size of the selected image. In the Width and Height 
fields enter a value for the width or height of the selected image.

• Preview field – displays a preview of the selected image.

• Original Size – returns the selected image to its original image size which is indicated 
above the Original Size button. The bitmap image density is shown alongside the original 
size of the image.
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Adding text
To add text to an image you have inserted into your spreadsheet. Any text added to an image 
becomes an integral part of that image and will move with the image when the image is 
repositioned. For more information on adding text to images, see the Draw Guide.

1) Select the image you want to add text to.

2) Double-click on the image and the text cursor flashes in the center of the image. The Text 
Formatting toolbar automatically opens at the top of the spreadsheet.

3) Enter your text and make any formatting adjustments to the text using the tools on the Text 
Formatting toolbar.

4) When finished, click outside the image to cancel the text editing mode and your text will 
appear in the default position at the center of the image.

Figure 112: Text dialog

5) To adjust the position of the text or how it appears in the image, right-click on the image 
and select Text from the context to open the Text dialog (Figure 112).

6) Make any necessary changes and click OK to close the dialog. The various options 
available are described below. If an option is grayed out in the Text dialog, then it is not 
available for use in Calc.

The options in the Text dialog are as follows:

• Text – sets the layout and anchoring properties for text in the selected image. The text is 
positioned relative to the edges of the image.

– Fit width to text – expands the width of the image to the width of the text, if the image is 
smaller than the text.

– Fit height to text – expands the height of the object to the height of the text, if the object 
is smaller than the text.

– Fit to frame – resizes the text to fit the entire area of the image.

– Adjust to contour – adapts the text flow so that it matches the contours of the selected 
image.

– Word wrap text in shape – wraps the text that you add after double-clicking a custom 
shape to fit inside the shape.
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– Resize shape to fit text – resizes a custom shape to fit the text that you enter after 
double-clicking the shape.

• Spacing to borders – specify the amount of space to leave between the edges of the 
image and the borders of the text.

– Left – enter the amount of space to leave between the left edge of the image and the 
left border of the text.

– Right – enter the amount of space to leave between the right edge of the image and the
right border of the text.

– Top – enter the amount of space to leave between the top edge of the image and the 
upper border of the text.

– Bottom – enter the amount of space to leave between the bottom edge of the image 
and the lower border of the text.

• Text anchor – set the anchor position. Click where you want to place the anchor for the 
text.

• Full width – anchors the text to the full width of the image.

Positioning, resizing and arranging images

Using the mouse

Positioning
To move an image to a new position in your spreadsheet, click on the image and drag it to a new 
position. Release the mouse button when you are satisfied. The image will still be anchored to the 
cell or page the image was originally anchored to.

Resizing
1) Click on the image to display the colored selection handles.

2) Position the cursor over one of the colored selection handles. The cursor changes shape 
giving a graphical representation of the direction of the resizing. The corner handles resize 
both the width and the height of the image simultaneously. The top, bottom, left and right 
handles only resize one dimension at a time.

3) Click and drag to resize the image.

4) Release the mouse button when satisfied with the new size.

Tip To retain the original proportions of the image, Shift+click one of the corner handles,
then drag.

Position and Size dialog
If you want to accurately position and size an image in your spreadsheet, go to Format > Graphic 
> Position and Size on the main menu bar, or right-click on an image and select Position and 
Size from the context menu (Figure 113).

Position and Size
Open the Position and Size dialog and click on the Position and Size tab (Figure 113) to set the 
appropriate values.
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• Position – specify the location of the selected image on the spreadsheet.

– Position X – enter the horizontal distance that you want to move the object relative to 
the base point selected in the grid.

– Position Y – enter the vertical distance that you want to move the object relative to the 
base point selected in the grid.

– Base point – select a base point in the grid and then enter the amount that you want to 
shift the image relative to the base point that you selected in the Position Y and 
Position X boxes. The base points correspond to the selection handles on an image.

Figure 113: Position and Size dialog

• Size – specify the amount by which you want to resize the selected image with respect to 
the selected base point.

– Width – enter a width for the selected image.

– Height – enter a height for the selected image.

– Keep ratio – maintains proportions when you resize the selected image.

– Base point – select a base point in the grid, and then enter the new size dimensions for 
the selected image in the Width and Height boxes.

• Protect

– Position – prevents changes to the position or the size of the selected image.

– Size – prevents you from resizing the image.

• Adapt – specifies, if the size of a drawing image should be adjusted to fit the size of 
entered text.

– Fit width to text – expands the width of the image to the width of the text, if the image is 
smaller than the text.

– Fit height to text – expands the height of the image to the height of the text, if the image
is smaller than the text.

The units of measurement used for X//Y coordinates and the width and height of the image are set 
by going to Tools > Options > LibreOffice Draw > General.
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The default location of the base points for position and size is the upper left corner of the 
spreadsheet. You can temporarily change this base point to make positioning or dimensioning 
simpler by clicking on a position corresponding to the location of the base point you want to use. 
This change in base point is only valid for single use and the base point is reset to the standard 
position of top left corner when you close the Position and Size dialog.

Rotating images
To accurately rotate an image, click on the Rotation tab of the Position and Size dialog (Figure 
114). Use this dialog to define the rotation angle and the location of the pivot point.

Figure 114: Position and Size dialog – Rotation page

• Pivot point – the selected image is rotated around a pivot point that you specify. The 
default pivot point is at the center of the image. If you set a pivot point too far outside of the 
image boundaries, the image could be rotated off the page.

– Position X – enter the horizontal distance from the left edge of the page to the pivot 
point.

– Position Y – enter the vertical distance from the top edge of the page to the pivot point.

– Default settings – select where you want to place the pivot point. Default position is the 
center of the image. Changing the rotation pivot point is only valid for single use. The 
pivot point is reset to default settings when you close the Position and Size dialog.

• Rotation angle – specify the number of degrees that you want to rotate the selected 
image, or click in the rotation grid.

– Angle – enter the number of degrees that you want to rotate the selected image.

– Default settings – click on the indicator to rotate the image. The number of degrees is 
shown in the Angle box as you rotate the indicator.

Slant and corner radius
To accurately set the corner radius or slant angle of an image, click on the Slant & Corner Radius 
tab of the Position and Size dialog (Figure 115).
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Figure 115: Position and Size dialog – Slant & Corner Radius page

• Corner Radius – you can only round the corners of a rectangular image. If this section is 
grayed out, then you cannot set a corner radius.

– Radius – enter the radius of the circle that you want to use to round the corners. The 
larger the value for corner radius set, the rounder the corners of an image become.

• Slant – slants the selected image along the bottom edge of the image.

– Angle – enter the angle of the slant axis. The slant angle relates to how much an image
inclines or slants from its normal vertical position on a drawing.

Arranging images
Each image that you place in your spreadsheet is successively stacked on the preceding image. 
Use the arrange commands to change the stacking order of images in your spreadsheet. You 
cannot change the stacking order of text.

1) Select the image you want to rearrange.

2) Go to Format > Arrange on the main menu bar, or right-click on the image and select one 
of the arrange options described below.

3) Alternatively, click on the Bring to Front icon  or the Send to Back icon  on the 
Picture toolbar to quickly move your image to the front or rear of the stack.

The options available for arranging images are as follows:

• Bring to Front – moves the selected image to the top of the stacking order, so that it is in 
front of other images.

• Bring Forward – moves the selected image up one level, so that it is closer to top of the 
stacking order. Not available on the Picture toolbar.

• Send Backward – moves the selected image down one level, so that it is closer to the 
bottom of the stacking order. Not available on the Picture toolbar.

• Send to Back – moves the selected image to the bottom of the stacking order, so that it is 
behind the other images.

• To Foreground – moves the selected image in front of text.

• To Background – moves the selected image behind text. To select a background image so
that you can modify or replace it, you have to use the Navigator. Other methods of 
selection, such as clicking or double-clicking, do not work.

Anchoring images
To anchor an image or change the type of anchor used:

1) Go to Format > Anchor > To Page or To Cell on the main menu bar, or right click on the 
image and select To Page or To Cell from the context menu.
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2) Alternatively, click on the Change Anchor icon  on the Picture toolbar and the anchor 
type will toggle between To Page or To Cell.

Anchors are used for images so that they stay in their position in relation to other items.

• To Page – anchoring an image to the page allows it to be positioned in a specific place on 
the page. The image does not move when cells are added or deleted and is equivalent to 
an absolute reference. The image will always stay in the same position on the page where 
it is placed.

• To Cell – anchoring an image to a cell ensures that the graphic always stays with the 
content it is originally anchored to. If an image is anchored to cell B10, and a new row is 
inserted, the graphic will then be anchored to cell B11 and is equivalent to a relative 
reference.

Aligning images
When you have more than one image in your spreadsheet, you can align these images to give 
your spreadsheet a more professional look.

1) Select all of the graphics to be aligned.

2) Go to Format > Alignment on the main menu bar, or right click on the image and select 
Alignment from the context menu, or click on the Alignment icon on the Picture toolbar.

3) Select one of the six options available for alignment and your images will be aligned.

The six options include three for aligning the images horizontally (left, centered, right) and three for
aligning the images vertically (top, center, bottom).

• Left – horizontally aligns the left edges of the selected images.

• Centered – horizontally centers the selected images.

• Right – horizontally aligns the right edges of the selected images.

• Top – vertically aligns the top edges of the selected images.

• Center – vertically centers the selected images.

• Bottom – vertically aligns the bottom edges of the selected images.

Grouping and ungrouping images

Grouping
You can group several images so that they become object in your spreadsheet.

1) Select the images you want to group.

2) Go to Format > Group > Group on the main menu bar, or right-click on the selected 
images and select Group > Group from the context menu.

Ungrouping
1) Select the image group you want to ungroup.

2) Go to Format > Group > Ungroup on the main menu bar, or right-click on the selected 
images and select Group > Ungroup from the context menu.

Editing grouped images
1) Select the image group where you want to edit an image within the group.

2) Go to Format > Group > Enter Group on the main menu bar, or right-click on the selected 
images and select Group > Edit Group from the context menu.
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3) Select the image you want to make changes to and carry out those changes.

4) Go to Format > Group > Exit Group on the main menu bar, or right-click on the selected 
images and select Group > Exit Group from the context menu.

Calc drawing tools

Calc, like all other components of LibreOffice, has a range of tools to create drawings and this 
chapter covers the default options in Calc. For a more detailed explanation of the drawing tools 
and their uses, see the Draw Guide. However, if you need to create complex drawings for your 
spreadsheet, it is recommended to use LibreOffice Draw or another drawing program and then 
insert the drawing into your spreadsheet.

Drawing toolbar
To begin using the drawing tools, go to View > Toolbars > Drawing to open the Drawing toolbar, 
which appears in its default position at the bottom of the spreadsheet. You can make this toolbar a 
floating toolbar and move it to a convenient position. When the Drawing toolbar opens, it opens 
with a default set of tools as shown in Figure 116.

Figure 116: Drawing toolbar

The drawing tools available for use when the Drawing toolbar is opened are shown in and these 
are indicated by a border around the tool icon. Any not on the Drawing toolbar does not have a 
border around the tool icon. To add tools to the Drawing toolbar, right-click in an empty area on the 
toolbar and select Visible Buttons from the context menu.

Drawing tools
Referring to Figure 117, the drawing tools are explained as follows:

• Selection – when selected, lets you select objects in the current document. To select more 
than one object, drag a selection frame around the objects. To add an object to a selection, 
press Shift and then click the object.

Figure 117: Available drawing tools

Chapter 5  Using Graphics in Calc 160



• Line – draws a straight line where you drag in the current spreadsheet. To constrain the 
line to 45 degrees, hold down Shift while you drag.

To enter text on a line, double-click the line and type or paste your text. The text direction 
corresponds to the direction you dragged to draw the line. To hide the line, select None 
from the drop-down list for Line Style on the Drawing Object Properties toolbar (Figure 118 
on page 163).

• Rectangle – draws a rectangle in the current spreadsheet. Click where you want to place a
corner of the rectangle, and drag to the size you want. To draw a square, hold down Shift 
while you drag.

• Ellipse – draws an oval in the current spreadsheet. Click where you want to draw the oval, 
and drag to the size you want. To draw a circle, hold down Shift while you drag.

• Polygon – draws a line composed of a series of straight line segments. Drag to draw a line
segment, click to define the endpoint of the line segment, and then drag to draw a new line 
segment. Double-click to finish drawing the line. To create a closed shape, double-click the 
starting point of the line. Hold the Shift key while drawing a polygon to position new points 
at 45 degree angles.

The Edit Points mode enables you to interactively modify the individual points of the 
polygon.

• Curve – draws a smooth Bezier curve. Click where you want the curve to start, drag, 
release, and then move the pointer to where you want the curve to end and click. Move the 
pointer and click again to add a straight line segment to the curve. Double-click to finish 
drawing the curve. To create a closed shape, double click the starting point of the curve. 
The arc of the curve is determined by the distance you drag.

• Freeform Line – draws a freeform line where you drag in the current spreadsheet. To end 
the line, release the mouse button. To draw a closed shape, release the mouse button near
the starting point of the line.

• Arc – draws an arc in the current spreadsheet. To draw an arc, drag an oval to the size you
want, and then click to define the starting point of the arc. Move the cursor to where you 
want to place the endpoint and click. You do not need to click on the oval. To draw an arc 
that is based on a circle, hold down Shift while you drag.

• Ellipse Pie – draws a filled shape that is defined by the arc of an oval and two radius lines 
in the current spreadsheet. To draw an ellipse pie, drag an oval to the size you want, and 
then click to define the first radius line. Move the cursor to where you want to place the 
second radius line and click. You do not need to click on the oval. To draw a circle pie, hold 
down Shift while you drag.

• Circle Segment – draws a filled shape that is defined by the arc of a circle and a diameter 
line in the current spreadsheet. To draw a circle segment, drag a circle to the size you want,
and then click to define the starting point of the diameter line. Move the cursor to where you
want to place the endpoint of the diameter line and click. You do not need to click on the 
circle. To draw an ellipse segment, hold down Shift while you drag.

• Text – draws a text box with horizontal text direction where you drag in the current 
spreadsheet. Drag a text box to the size you want anywhere in the spreadsheet and then 
type or paste your text. Rotate the text box to get rotated text.

• Vertical Text – draws a text box with vertical text direction where you click or drag in the 
current spreadsheet. Drag a text box to the size you want anywhere in the spreadsheet and
then type or paste your text. Only available when Asian language support is enabled in 
Tools > Options > Language Settings > Languages.

• Text Animation – inserts animated text with horizontal text direction into the current 
spreadsheet.
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• Callouts – draws a line that ends in a rectangular callout with horizontal text direction from 
where you drag in the current spreadsheet. Drag a handle of the callout to resize the 
callout. To add text, click the edge of the callout and then type or paste your text. To change
a rectangular callout to a rounded callout, drag the largest corner handle when the cursor 
changes shape.

• Vertical Callouts – draws a line that ends in a rectangular callout with vertical text direction
from where you drag in the current spreadsheet. Drag a handle of the callout to resize the 
callout. To add text, click the edge of the callout, and then type or paste your text. To 
change a rectangular callout to a rounded callout, drag the largest corner handle when the 
pointer changes shape. Only available when Asian language support is enabled in Tools > 
Options > Language Settings > Languages.

• Basic Shapes – opens the Basic Shapes toolbar which you can use to insert shapes into 
your spreadsheet.

• Symbol Shapes – opens the Symbol Shapes toolbar from which you can insert symbols 
into your spreadsheet.

• Block Arrows – opens the Block Arrows toolbar from which you can insert block arrows 
into your spreadsheet.

• Flowchart – opens the Flowchart toolbar from which you can insert flowchart symbols into 
your spreadsheet.

• Callouts – opens the Callouts toolbar from which you can insert callout shapes into your 
spreadsheet.

• Stars and Banners – opens the Stars and Banners toolbar from which you can insert star 
and banner shapes into your spreadsheet.

• Points – enables you to edit points on the drawing you are creating in your spreadsheet.

• Fontwork Gallery – opens the Fontwork Gallery from which you can insert graphical text 
art into your spreadsheet.

• From File – inserts a picture or image into the current spreadsheet.

• Extrusion On/Off – switches the 3D effects on and off for selected objects.

Using drawing tools
1) Click in the spreadsheet where you want the drawing to be anchored. You can change the 

anchor type later, if necessary.

2) Select the tool from the Drawing toolbar (Figure 116 on page 160).

3) Move the cursor to where you want the graphic to appear, then click-and-drag to create the 
drawing object. Some tools have other requirements; see the Help or the Draw Guide for 
details. The selected drawing function remains active, so you can draw another object of 
the same type.

4) To cancel the selected drawing function, press the Esc key or click on the Select icon on 
the Drawing toolbar.

Drawing object properties
For more information on the properties of drawing objects, see the Draw Guide.
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Setting properties
You can set the default properties for a drawing object before you draw an object. These default 
properties are applied only to the current spreadsheet and are are not retained when you close the 
spreadsheet. The properties only apply to drawing objects.

1) Click Select on the Drawing toolbar (Figure 116 on page 160).

2) On the Drawing Object Properties toolbar (Figure 118), set the values or options you want 
to use for each property. When you select area or line properties, dialogs open where you 
can set the values used for area or line

Figure 118: Drawing Object Properties toolbar

Changing properties
You can change the properties of an existing drawing object (fill color, line type and weight, 
anchoring, and so on) using either the Drawing Object Properties toolbar (Figure 118), or the 
options available on the main menu bar or the context menu when you right-click on the drawing 
object.

Resizing drawing objects
Select the object and click on one of the selection handles then drag the object to its new size. For 
a scaled resizing, select one of the corner handles and keep the Shift key pressed while dragging 
the handle. For more information, see “Positioning, resizing and arranging images” on page 155.

Grouping and ungrouping drawing objects
Grouping, ungrouping and editing grouped drawing objects, see “Grouping and ungrouping 
images” on page 159 for more information.

Additional tools

Some additional tools are only available for images or graphics when the you right click on an 
image or graphic and open the context menu.

Description
You can add metadata in the form of a title and description to an image. This information is used by
accessibility tools (such as screen reader software) and as ALT (alternative) attributes if you export
the document to HTML.

Name
You can add a custom name to be assigned to an image and this will make an image easier to find 
in the Navigator. Also, assigning names to an image allows it to be easily identified when teams of 
personnel are working on the same multi page spreadsheet.

Flip
Flips the image either horizontally or vertically. Any text added to the image also changes 
orientation with the image, but only when the image is flipped vertically.
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Assign Macro
Opens the Assign Macro dialog (Figure 119) so you can add programmable functionality to the 
graphic. Calc has a very good macro functionality and more information on macros can be found in
Chapter 12 Calc Macros.

Figure 119: Assign Macro dialog

Hyperlink
For images and graphics, you can define a hyperlink at another location in your spreadsheet, 
another document or web page. To do this, select the graphic, right-click and select Hyperlink from
the context menu to open the Hyperlink dialog (Figure 120). See Chapter 10 Linking Calc Data for 
more information on hyperlinks.

Figure 120: Hyperlink dialog
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Compress graphic
You can compress a graphic to reduce the file size of your spreadsheet. To do this, select the 
graphic, right-click and select Compress Graphic from the context menu to open a dialog (Figure 
121) where you can set the compression options. The dialog shows the type, original size, view 
size, rand image capacity of the graphic.

Use the dialog to select the type of compression and the resolution of the reduced image. When 
you have made your changes, click Calculate and the size of the compressed graphic is displayed
in New Capacity. If you are satisfied with the new capacity, click OK and the graphic is 
compressed.

Figure 121: Compress Graphic dialog

Edit with external tool
You can edit a graphic with an external tool to use more advanced tools. To do this, select the 
graphic, right-click and select Edit with External Tool from the context menu. The dialog that 
opens will depend on your computer setup.

Image maps

An image map is a reference-sensitive graphic or text frame. In Calc, you Ctrl+click on defined 
areas (also known as hotspots) in the graphic or text frame to go to a target or linked reference 
such as a URL. The reference areas, along with any linked URLs and corresponding text are 
displayed when resting the cursor on these areas that have been defined in the ImageMap Editor.
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Image map types
There are two types of ImageMaps.

• Server Side ImageMap – is evaluated on the server computer and appear for the reader 
as a picture or frame on the page. Click on the ImageMap with the mouse, and the 
coordinates of the relative position are sent to the server. The server then determines the 
next step to take. There are several incompatible methods to define this process, the two 
most common being W3C (CERN) HTTP Server (Format type: MAP – CERN) and NCSA 
HTTP Server (Format type: MAP – NCSA)

LibreOffice creates ImageMaps for both methods. Select the format from the File type list in
the Save As dialog in the ImageMap Editor. Separate map files are created which you must
upload to the server. You will need to ask your provider or network administrator which type
of ImageMaps are supported by the server and how to access the evaluation program.

• Client Side ImageMap – is evaluated on the client computer. The area of the picture or 
frame where the reader can click is indicated by the appearance of a linked URL when the 
cursor passes over the area. The ImageMap is stored in a layer below the picture and 
contains information about the referenced regions. The only disadvantage of Client Side 
ImageMaps is that older Web browsers cannot read them; a disadvantage that will, 
however, resolve itself in time.

When saving the ImageMap, select the file type SIP – StarView ImageMap. This saves the 
ImageMap directly in a format which can be applied to every active picture or frame in your 
document. However, if you just want to use the ImageMap on the current picture or text 
frame, you do not have to save it in any special format. After defining the regions, simply 
click Apply. Client Side ImageMaps saved in HTML format are inserted directly into the 
page in HTML code.

Creating image maps
1) Position the cursor where you want the ImageMap in your spreadsheet.

2) Insert an image or graphic you want to use into your spreadsheet.

3) Make sure the image or graphic is selected and go to Edit-> ImageMap on the main menu 
bar to open the ImageMap Editor (Figure 122). The ImageMap Editor displays the image or
graphic as a background.

4) Use the tools in the ImageMap Editor to draw a hotspot shape, for example a rectangle, 
over the image at the background. A hotspot is highlighted in Figure 122.

5) Enter the URL in the Address text box that will open a web browser when the user clicks 
the hotspot.

6) Optionally, enter text in the Text box that will show as a tip when the user hovers the cursor 
over the hotspot.

7) Click the Apply icon to apply your changes to the hotspot.

8) If necessary, click the Save icon to save the image or graphic for future use in ImageMap 
file format in the file location that you want to use.

9) To check if the hotspot works correctly, deselect the graphic or image in Calc and then 
Ctrl+click on the hotspot to open your browser at the correct webpage or file location.

10) Save the spreadsheet before closing the spreadsheet and LibreOffice.

Notes
It is recommended not to use the whole image or graphic as a hotspot when defining 
a single link. If you have to use the whole image or graphic, then right-click on the 
image or graphic and select Hyperlink from the context menu.
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Figure 122: ImageMap Editor dialog

ImageMap tools
The toolbar at the top of the ImageMap Editor dialog contains the following tools and boxes. 
Depending on the type of hotspot being added to the image map, some tools will not become 
active until you change the type of hotspot being added.

• Apply – applies the changes that you made to the image map.

• Open – loads and existing image map in the MAP-CERN, MAP-NCSA or SIP StarView file 
format.

• Save – saves the image map in the MAP-CERN, MAP-NCSA or SIP StarView file format.

• Select – selects a hotspot in the image map so you can edit it.

• Rectangle – draws a rectangular hotspot on the selected image or graphic. Hold the Shift 
key down to draw a square hotspot.

• Ellipse – draws an elliptical hotspot on the selected image or graphic. Hold the Shift key 
down to draw a circular hotspot.

• Polygon – draws a polygonal hotspot on the selected image or graphic. Click and drag in 
the image or graphic and then click to define one side of the polygon. Move the cursor to 
where you want to place the end of the next side of the polygon and then click. Repeat until
you have drawn all the sides of the polygon. When you are finished, double click to close 
the polygon.

• Freeform Polygon – draws a hotspot that is based on a freeform polygon. Select and 
move the cursor to where you want to draw the hotspot. Drag a freeform line and release to
close the shape.

• Edit Points – lets you change the shape of the selected hotspot by editing the anchor 
points.

• Move Points – lets you move individual anchor points of the selected hotspot.

• Insert Points – inserts an anchor point where you click on the outline of the selected 
hotspot.

• Delete Points – deletes the selected anchor point from the outline of the selected hotspot
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• Undo – reverses the last command or last entry you typed.

• Redo – reverses the last Undo command.

• Active – disable or enables the hyperlink for the selected hotspot. A disabled hotspot is 
transparent.

• Macro... – assigns a macro that runs when click the selected hotspot.

• Properties... allows you to define the properties of the selected hotspot.

• Address – enter the URL for the file that you want to open when you click the selected 
hotspot.

• Text – enter the text that you want to display when the cursor rests on the hotspot.

• Frame – enter the name of the target frame that you want to open the URL in. You can also
select a standard frame name from the list. The value _self for the target frame will work in 
the vast majority of occasions. It is not recommended to use the other types of frames 
unless absolutely necessary.

– _self – file opens in the current frame.

– _blank – file opens in a new page.

– _parent – file opens in the parent frame of the current frame. If there is no parent frame,
the current frame is used.

– _top – file opens in the topmost frame in the hierarchy.

Editing image maps
1) Select the image or graphic and go to Edit-> ImageMap on the main menu bar to open the 

ImageMap Editor (Figure 122). The ImageMap Editor displays the image or graphic as a 
background.

2) Select the hotspot you want to edit. A hotspot is highlighted in Figure 122.

3) Click on the Properties icon to open the Properties dialog (Figure 123).

Figure 123: Properties dialog for ImageMap Editor

4) Make the necessary changes in the text boxes for URL, Frame, Name, Alternative text and 
Description.

5) Click OK to save the changes and close the dialog.

6) Click the Apply icon to apply your changes to the hotspot in the selected graphic or image.
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7) If necessary, click the Save icon to save the image or graphic for future use in ImageMap 
file format in the file location that you want to use.

8) To check if the hotspot works correctly, deselect the graphic or image in Calc and then 
Ctrl+click on the hotspot to open your browser at the correct webpage or file location.

9) Save the spreadsheet before closing the spreadsheet and LibreOffice.
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Quick printing

Click the Print File Directly icon to send the entire document to the default printer defined for your 
computer.

Note

You can change the action of the Print File Directly icon, to send the document to
the printer defined for the document, instead of the default printer for the computer.
Choose Tools > Options > Load/Save > General and select the Load printer 
settings with the document option.

Controlling printing

For more control over printing, use the Print dialog (File > Print or Ctrl+P).

Figure 124. The Print dialog

The Print dialog has four tabs, from which you can choose a range of options, as described in the 
following sections.

Note

The options selected on the Print dialog apply to this printing of this document only.

To specify default printing settings for LibreOffice, go to Tools > Options > 
LibreOffice – Print and Tools > Options > LibreOffice Calc – Print. For details, 
see Chapter 14 Setting Up and Customizing Calc.
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Selecting general printing options
On the General tab of the Print dialog (Figure 124), you can choose:

• The printer (from the printers available)

• Which sheets and pages to print, the number of copies to print, whether to print in reverse 
page order and whether to collate multiple copies (Range and copies section)

Click the Properties button to display a printer-specific dialog where you can choose portrait or 
landscape orientation, which paper tray to use, and the paper size to print on.

To print a range of pages, separate the range with a hyphen; for example, enter 3-6 to print pages 
3 to 6. To print single pages, use a semi-colon to separate the pages; for example, enter 7;9;11 to 
print pages 7, 9, and 11. You can also print a combination of page ranges and single pages by 
combining these methods; for example, enter 3-6;8;10;12 to print pages 3, 4, 5, 6, 8, 10, and 12.

On the Options tab of the Print dialog (Figure 125), you can choose to print to a file (instead of to a 
printer) and to create a single print job containing several copies of the document (instead of a 
separate print job for each copy).

Figure 125: General print options

Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this:

1) In the Print dialog, select the Page Layout tab (Figure 126).

Figure 126: Printing multiple page per sheet of paper

2) In the Layout section, select the number of pages to print per sheet. The preview panel on 
the left of the Print dialog shows how the printed document will look.

When printing more than 2 pages per sheet, you can choose the order in which they are 
printed across and down the paper. The pictures above and below show the difference.
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3) You can choose to draw a border around each page.

4) In the From which print choices on the General tab (Figure 127), select whether to print all 
pages or only some pages.

5) Click the OK button to print.

Selecting sheets to print
In addition to printing a full document, you can choose to print individual sheets, ranges of sheets, 
or a selection of cells in a document.

Figure 127: Choosing what to print in Calc

Printing an individual sheet:

1) In the spreadsheet, click on the sheet tab to select the sheet you want to print.

2) Choose File > Print from the menu bar.

3) In the Ranges and copies section of the Print dialog, choose the Selected sheets option.

4) Click the OK button.

Printing a range of sheets:

1) In the spreadsheet, select the sheets to print.

a) Select the first sheet.

b) Hold down the Ctrl key.

c) Click on the additional sheet tabs.

d) Release the Ctrl key when all required sheets are selected.

2) Choose File > Print from the menu bar.

3) In the Ranges and copies section of the Print dialog, choose the Selected sheets option.

4) Click the OK button.

Printing a selection of cells:

1) In the document, select the section of cells to print.

2) Choose File > Print from the menu.

3) In the Ranges and copies section of the Print dialog, select the Selected cells option.

4) Click the OK button.

The Print in reverse page order option can be selected with any of the above options.

Caution After printing, be sure to deselect the extra sheets. If you keep them selected, the 
next time you enter data on one sheet, you enter data on all the selected sheets. 
This might not be what you want.
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Using print ranges

Print ranges have several uses, including printing only a specific part of the data or printing 
selected rows or columns on every page.

Defining a print range
To set a user-defined print range, which will replace any existing defined print range:

1) Highlight the range of cells that are to comprise the print range.

2) Choose Format > Print Ranges > Define from the menu bar.

The automatic page break lines are then displayed on the screen.

Tip

You can check the print range by using File > Page Preview in the menu bar, or 
by clicking the Page Preview icon in the Standard toolbar. Calc will only display 
the cells in the print range.

You can also use the View > Page break preview mode to see the print range 
without going to the page preview. See “Viewing print ranges” on page 176.

Adding to the print range
After defining a print range, you can add more cells to it. This allows multiple, separate areas of the
same sheet to be printed, while not printing the whole sheet. After you have defined a print range:

1) Highlight the range of cells to be added to the print range.

2) Choose Format > Print Ranges > Add from the menu bar. This adds the extra cells to the 
print range.

The page break lines display on the screen around this new addition.

Note
The additional print range will print as a separate page, even if both ranges are on 
the same sheet.

Removing print ranges
It may become necessary to remove a user-defined print range, for example if the whole sheet 
needs to be printed later, or you no longer wish to print some of the added ranges.

Choose Format > Print Ranges > Remove from the menu bar. This removes all defined print 
ranges on the sheet, except those in named ranges. After the print range is removed, the default 
page break lines will appear on the screen.

To remove only certain print ranges, see “Editing a print range” below.

Editing a print range
At any time, you can directly edit the print range, for example to add to, remove, or resize part of 
the print range. Choose Format > Print Ranges > Edit from the menu bar. If you have already 
selected a print range, the Edit Print Ranges dialog looks something like Figure 128.

In this example, three rectangles are selected, each separated by a comma. The first is bounded 
by cell A3 ($A$3) in the top left and cell C9 ($C$9) in the bottom right corner. The others being 
D12:F23 and H24:I25.
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If only a single range is defined, then clicking anywhere in the text entry box shows the selected 
print range on the screen, bounded in blue, as shown in Figure 129.

To directly add new cells to the print range:

1) Type a comma in the text box as the separator for the ranges.

2) Select the cell range using the mouse cursor, or directly type in the cell references using 
the format of the selection already in the text box. Remember to separate the cell 
references with a colon.

To remove a print range, select the range in the text box and delete it. Make sure the remaining 
ranges only have a single comma as a separator and that there is not a comma at the end of the 
sequence.

To resize a print range, edit the data in the text box for the range.

Figure 128: Edit a print range

Figure 129: Print range marked by colored box; page break lines visible around the 
selection

Viewing print ranges
Because defined print ranges are formatted with automatic page breaks, they can be viewed by 
using the Page Break Preview screen, select View > Page Break Preview from the menu bar.
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igure 130: The defined print range

igure 131: The preview screen for the defined print range.

The print ranges are outlined by default with a blue border, and contain a centered page number in 
gray. The nonprinting area has a gray background.

To exit the Page Break Preview screen, select View > Normal from the menu bar.

Printing rows or columns on every page
If a sheet is printed on multiple pages, you can set up certain rows or columns to repeat on each 
printed page.

For example, if the top two rows of the sheet as well as column A need to be printed on all pages, 
do the following:

1) Choose Format > Print Ranges > Edit from the menu bar. On the Edit Print Ranges 
dialog, type the rows in the text entry box under Rows to repeat. For example, to repeat 
rows 1, 2 and 3, type $1:$3. This automatically changes Rows to repeat from - none - to 
- user defined -.

2) To repeat columns, type the columns in the text entry box under Columns to repeat. For 
example, to repeat column A, type $A. This automatically changes Columns to repeat from 
- none - to - user defined -.

3) Click OK.

Note

You can also use the mouse to select the rows or columns to repeat. To do this, 
click the corresponding text entry box and select the desired cell range in the 
sheet. You do not need to select the entire range of the rows to be repeated; 
simply select one cell in each row.
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Figure 132: Specifying repeating rows

Rows to repeat and Columns to repeat can also be defined as named ranges using the method 
described below, but by selecting Repeat column or Repeat row, instead of selecting Print range
(see Figure 133). These may then be selected from the list box entries in the Edit Print Ranges 
dialog shown in Figure 132.

Defining a named print range
In addition to highlighting a print range for each print job, you can define a range of cells to be used
repeatedly. This may be useful if different areas of a large spreadsheet need to be printed for 
different reports. Several named print ranges can be defined to meet this need.

1) To define a named print range, highlight the cells you want to define as a print range and 
select Insert > Names > Define from the menu bar, to open the Define Names dialog 
(Figure 133). Alternatively the cells can be highlighted after opening the Define Names 
dialog.

2) Type a name for the range in the Name box. The name of the range cannot contain any 
spaces.

3) Edit or set the cell selection range for the print range in the Range box if needed.

4) Ensure Document (Global) is selected in the Scope box.

Figure 133: Define Names dialog

5) Click the plus symbol by Range Options to show more choices. Select the Print range 
option to define the settings as a print range. Click the Add button to accept the data and 
close the dialog.
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To select this range to print:

1) Choose Format > Print Ranges > Edit from the menu bar (Figure 128). The previously 
defined name now appears in the Print range list box.

2) Select the defined print range and click OK.

This method can be useful to quickly change the print range without highlighting a large area of 
cells every time.

Deleting a named print range
To delete a named print range if it is no longer required:

1) Select Insert > Names > Manage from the menu bar or use Ctrl+F3.

2) In the Manage Names dialog which opens, select the named range you want to delete.

3) Click the Delete button.

4) Click OK to close the dialog.

You can click the Range Options button in the Manage Names dialog to confirm that the selected 
name is a print range before clicking Delete.

Page breaks

While defining a print range can be a powerful tool, it may sometimes be necessary to manually 
adjust Calc’s printout. To do this, you can use a manual break. A manual break helps to ensure that
your data prints properly. 

You can insert a horizontal page break above, or a vertical page break to the left of, the active cell.

Inserting a page break
To insert a page break:

1) Navigate to the cell where the page break will begin.

2) Select Insert > Page Break from the menu bar.

3) Select Row Break or Column Break depending on your need.

The break is now set.

Row break

Selecting Row Break creates a page break above the selected cell. For example, if the active cell 
is H15, then the break is created between rows 14 and 15.

Column break

Selecting Column Break creates a page break to the left of the selected cell. For example, if the 
active cell is H15, then the break is created between columns G and H.

Tip
To see page break lines more easily on screen, you can change their color. 
Choose Tools > Options > LibreOffice > Appearance and scroll down to the 
Spreadsheet section.
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Deleting a page break
To remove a page break:

1) Navigate to a cell that is next to the break you want to remove.

2) Select Edit > Delete Manual Break.

3) Select Row Break or Column Break depending on your need.

The break is removed.

Removing multiple page breaks
Multiple manual row and column breaks can exist on the same page. When you want to remove all
of them, do as follows:

1) On the menu bar, select View > Page Break Preview.

2) Right-click in the document and select Delete All Manual Breaks from the context menu.

All manual breaks are removed.

3) Select View > Normal to return to the standard document view.

Printing options setup in page styles

Several printing options are set in the page style for sheets. These include the page order, details, 
and scale to be printed, Because these options are set in the page style, different page styles can 
be set up to quickly change the print properties of the sheets in the spreadsheet. See Chapter 4 
Using Styles and Templates in Calc for more about page styles.

The Sheet tab of the Page Style dialog (Figure 134) provides the following options.

Figure 134. The Sheet tab of the Page Style dialog
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Page Order
You can set the order in which pages print. This is especially useful in a large document; for 
example, controlling the print order can save time if you have to collate the document a certain 
way.

Where a sheet prints to more than one piece of paper, it can be printed either by column, 
where the first column of pages prints, and then the second column and so on, or by row as 
shown in the graphic on the top right of the dialog in Figure 134.

Print
You can specify which details to print. These details include:

• Row and column headers

• Sheet grid—prints the borders of the cells as a grid

• Comments—prints the comments defined in your spreadsheet on a separate page, 
along with the corresponding cell reference

• Objects and graphics

• Charts

• Drawing objects

• Formulas—prints the formulas contained in the cells, instead of the results

• Zero values—prints cells with a zero value

Scale
Use the scale features to control the number of pages the data will print on.

• Reduce/Enlarge printout—scales the data in the printout either larger or smaller. For
example, if a sheet would normally print out as four pages (two high and two wide), a 
scaling of 50% would print as one page (both width and height are halved).

• Fit print range(s) on number of pages—defines exactly how many pages the 
printout will take up. This option will only reduce a printout; it will not enlarge it. To 
enlarge a printout, the reduce/enlarge option must be used.

• Fit print range(s) to width/height—defines how high and wide the printout will be, in 
number of pages.

Headers and footers

Headers and footers are predefined pieces of text that are printed at the top or bottom of a sheet 
outside of the sheet area. Headers are set the same way as footers.

You can choose to have different content on left and right pages of the same page style.

Headers and footers are assigned to a page style. You can define more than one page style for a 
spreadsheet and assign different page styles to different sheets. For more about page styles, see 
Chapter 4.

Setting a header or a footer
To set a header or footer:

1) Navigate to the sheet for which you want to set the header or footer. Select Format > Page
from the menu bar.

2) Select the Header (or Footer) tab.

3) Select the Header on option.

4) Make other selections according to your requirements, using the More button to reveal 
other options. Click OK.
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Figure 135: Header dialog

You can set the margins, the spacing, and height for the header or footer. To automatically adjust 
the height of the header or footer, select the AutoFit height box. You can also select to have 
different content for left and right pages.

Margin
Changing the size of the left or right margin adjusts how far the header or footer is from that 
side of the page.

Spacing
Spacing affects how far above or below the sheet the header or footer will print. So, if spacing 
is set to 1.00", then there will be 1 inch between the header or footer and the sheet.

Height
Height affects how big the header or footer will be.

Header or footer appearance
To change the appearance of the header or footer, click the More button in the dialog. This opens 
the Border/Background dialog.

From this dialog you can set the background and border style of the header or footer. See 
Chapter 4 Using Styles and Templates in Calc for more information.
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Figure 136: Header/Footer Border/Background dialog

Setting the contents of the header or footer
The header or footer of a Calc spreadsheet has three columns for text. Each column can be empty 
or have different contents.

To set the contents of the header or footer, click the Edit button in the header or footer dialog 
shown in Figure 135 to display the dialog shown in Figure 137.

Figure 137: Edit contents of header or footer

Areas
Each area in the header or footer is independent and can have different information in it.

Header
You can select from several preset choices in the Header drop-down list, or specify a custom 
header using the buttons below the area boxes. (To format a footer, the choices are the same.)
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Custom header
Click in the area (Left, Center, Right) that you want to customize, then use the buttons to add 
elements or change text attributes.

 Opens the Text Attributes dialog.

 Inserts the File Name field.

 Inserts the Sheet Name field.

 Inserts the current page number.

 Inserts the total number of pages.

 Inserts the Date field.

 Inserts the Time field.

Exporting to PDF

Calc can export documents to PDF (Portable Document Format). This industry-standard file format
is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.

Quick export to PDF

Click the Export Directly as PDF icon  to export the entire document using your default PDF 
settings. You are asked to enter the file name and location for the PDF file, but you do not get a 
chance to choose a page range, the image compression, or other options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as PDF from 
the menu bar. The PDF Options dialog opens. This dialog has five pages (General, Initial View, 
User Interface, Links, and Security). Select the appropriate settings on each page, and then click 
Export. You are then asked to enter the location and file name of the PDF to be created. Click 
Save to export the file.

General page of PDF Options dialog
On the General page, you can choose which pages to include in the PDF, the type of compression 
to use for images (which affects the quality of images in the PDF), and other options.

Range section
• All: Exports the entire document if no print range has been defined or otherwise the print 

range content.

• Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single 
pages, use the format 7;9;11 (pages 7, 9, and 11). You can also export a combination of 
page ranges and single pages, by using a format like 3-6;8;10;12.

Caution The numbers used above are related to the page numbers and not the sheet 
numbers in your spreadsheet. To find these page numbers, select all the sheets in 
your spreadsheet and click the Preview button.

• Selection: Exports whatever content is selected.
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Figure 138: General page of PDF Options dialog

Images section
• Lossless compression: Images are stored without any loss of quality. Tends to make 

large files when used with photographs. 

• JPEG compression: Allows for varying degrees of quality. A setting of 90% works well with
photographs (small file size, little perceptible loss).

• Reduce image resolution: Lower DPI (dots per inch) images have lower quality. Higher 
DPI settings greatly increase the size of the exported file. The end-purpose of the file will 
dictate the resolution you find acceptable.

Note
EPS (Encapsulated PostScript) images with embedded previews are exported only 
as previews. EPS images without embedded previews are exported as empty 
placeholders.

Watermark section
• Sign with Watermark: When this option is selected, a transparent overlay of the text you 

enter into the Watermark Text box will appear on each page of the PDF file.

General section
• Embed OpenDocument file: This setting enables you to export the document as a PDF 

file containing two file formats: .pdf and .odf. In PDF viewers it behaves like a normal .pdf 
file and it remains fully editable in LibreOffice. Selecting this option inhibits the use of the 
Range options and grays them out.

• PDF/A-1a: PDF/A is an ISO standard for long-term preservation of documents, by 
embedding all the information necessary for faithful reproduction (such as fonts) while 
forbidding other elements (including forms, security, and encryption). PDF tags are written. 
If you select PDF/A-1a, the forbidden elements are grayed-out (not available).

• Tagged PDF: Tagged PDF contains information about the structure of the document’s 
contents. This can help to display the document on devices with different screens, and 
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when using screen reader software. Some tags that are exported are table of contents, 
hyperlinks, and controls. This option can increase file sizes significantly.

• Create PDF form - Submit format: Choose the format for submitting forms from within the
PDF file. This setting overrides the control’s URL property that you set in the document. 
There is only one common setting valid for the whole PDF document: PDF (sends the 
whole document), FDF (sends the control contents), HTML, and XML. Most often you will 
choose the PDF format.

• Export bookmarks: Exports sheet names in Calc documents as “bookmarks” (a table of 
contents list displayed by most PDF readers, including Adobe Reader).

• Export comments: Exports comments in Calc documents as PDF notes. You may not 
want this.

• Export automatically inserted blank pages: Not available in Calc.

• Embed standard fonts: Enable this option to embed the standard fonts that are installed 
on your system and that are used in the document. Use this option if you expect to have a 
better looking or more useful standard font than the font that is available in the recipients' 
PDF reader software.

• View PDF after Export:  When this option is selected, the exported PDF document will be 
opened in a PDF viewer.

Initial View page of PDF Options dialog
On the Initial View page (Figure 139), you can choose how the PDF opens by default in a PDF 
viewer. The selections are self-explanatory.

Figure 139: Initial View page of PDF Options dialog

User Interface page of PDF Options dialog
On the User Interface page (Figure 140), you can choose more settings to control how a PDF 
viewer displays the file. Some of these choices are particularly useful when you are creating a PDF
to be used as a presentation or a kiosk-type display.

Window options section
• Resize window to initial page: Causes the PDF viewer window to resize to fit the first 

page of the PDF.

• Center window on screen: Causes the PDF viewer window to be centered on the 
computer screen.
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• Open in full screen mode: Causes the PDF viewer to open full-screen instead of in a 
smaller window.

• Display document title: Causes the PDF viewer to display the document’s title in the title 
bar.

Figure 140: User Interface page of PDF Options dialog

User interface options section
• Hide menubar: Causes the PDF viewer to hide the menu bar.

• Hide toolbar: Causes the PDF viewer to hide the toolbar.

• Hide window controls: Causes the PDF viewer to hide other window controls.

Transitions
• Not available in Calc.

Bookmarks
Only one bookmark level (sheet names) is available in Calc, regardless of the setting selected 
here.

Links page of PDF Options dialog
On this page you can choose how links are exported to PDF.

Figure 141: Links page of PDF Options dialog

Export bookmarks as named destinations
If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet names, this 
option exports them as “named destinations” to which Web pages and PDF documents can 
link.

Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (for example,  
.odt, .ods, and .odp), this option converts the extensions of file names to .pdf in the exported 
PDF document.
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Export URLs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF.

Cross-document links
Defines the behavior of links clicked in PDF files.

Security page of PDF Options dialog
PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and 
apply some digital rights management (DRM) features.

• With an open password set, the PDF can only be opened with the password. Once opened,
there are no restrictions on what the user can do with the document (for example, print, 
copy, or change it).

• With a permissions password set, the PDF can be opened by anyone, but its permissions 
can be restricted. See Figure 142. After you set a password for permissions, the other 
choices on the Security page become available.

• With both the open password and permission password set, the PDF can only be opened 
with the correct password, and its permissions can be restricted.

Note
Permissions settings are effective only if the user’s PDF viewer respects the 
settings.

Figure 143 shows the dialog displayed when you click the Set passwords button on the Security 
page of the PDF Options dialog.

Figure 142: Security page of PDF Options dialog
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Figure 143: Setting a password to encrypt a PDF

Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. Select 
File > Save As from the menu bar, look in the File type list box in the Save As dialog for a wide 
range of file types.

Exporting to XHTML
Calc can export spreadsheets to XHTML. Choose File > Export from the menu bar. On the Export 
dialog, specify a file name for the exported document, then select the XHTML in the File format list 
and click the Export button.

E-mailing spreadsheets

LibreOffice provides several quick and easy ways to send spreadsheets as an e-mail attachment in
one of three formats: OpenDocument Spreadsheet (LibreOffice’s default format), Microsoft Excel, 
or PDF.

To send the current document in OpenDocument format:

1) Choose File > Send > Document as E-mail from the menu bar. LibreOffice opens your 
default e-mail program with the spreadsheet (*.ods) document attached.

2) In your e-mail program, enter the recipient, subject, and any text you want to add, then 
send the e-mail.

File > Send > E-mail as OpenDocument Spreadsheet has the same result.

If you choose E-mail as Microsoft Excel, LibreOffice first creates a file in Excel format and then 
opens your e-mail program with the (*.xls) file attached.

If you choose E-mail as PDF, LibreOffice opens the PDF Options dialog for you to select the 
parameters you want, as previously described for exporting to PDF, clicking Send on the dialog 
then opens your email program with the PDF file attached.

E-mailing a spreadsheet to several recipients
To e-mail a document to several recipients, you can use the features in your e-mail program or you
can use LibreOffice Writer’s mail merge facilities to extract email addresses from an address book.

For details, see Chapter 10 Printing, Exporting, and E-mailing in the Getting Started guide.
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Digital signing of documents

To sign a document digitally, you need a personal key, also known as a certificate. A personal key 
is stored on your computer as a combination of a private key, which must be kept secret, and a 
public key, which you add to your documents when you sign them. You can get a certificate from a 
certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a checksum is computed from the document’s 
content plus your personal key. The checksum and your public key are stored together with the 
document. 

When someone later opens the document on any computer with a recent version of LibreOffice, 
the program will compute the checksum again and compare it with the stored checksum. If both 
are the same, the program will signal that you see the original, unchanged document. In addition, 
the program can show you the public key information from the certificate. You can compare this 
key with the public key that is published on the web site of the certificate authority.

Whenever someone changes something in the document, this change breaks the digital signature.

On Windows operating systems, the Windows features of validating a signature are used. On Linux
systems, files that are supplied by Mozilla Thunderbird or Firefox are used. For a more detailed 
description of how to get and manage a certificate, and signature validation, see “Using Digital 
Signatures” in the LibreOffice Help.

To sign a document:

1) Choose File > Digital Signatures.

2) If the document contains comments, a warning dialog appears stating this and asking if you
wish to continue. Click Yes if you wish to continue, or click No to exit and take appropriate 
action to remove them and restart this procedure from step 1.

3) If you have not saved the document since the last change, a message box appears. Click 
Yes to save the file. If you click No, the procedure exits.

4) After saving, you see the Digital Signatures dialog. Click Add to add a public key to the 
document.

5) In the Select Certificate dialog, select your certificate and click OK. 

6) You see again the Digital Signatures dialog, where you can add more certificates if you 
want. Click OK to add the public key to the saved file.

A signed document shows an icon  in the status bar. You can double-click the icon to view the 
certificate.

Removing personal data

You may wish to ensure that personal data, versions, notes, hidden information, or recorded 
changes are removed from files before you send them to other people or create PDFs from them.

In Tools > Options > LibreOffice > Security > Options, you can set Calc to remind (warn) you 
when files contain certain information and remove personal information automatically on saving.

To remove personal and some other data from a file, go to File > Properties. On the General tab, 
uncheck Apply user data and then click the Reset button. This removes any names in the created
and modified fields, deletes the modification and printing dates, and resets the editing time to zero, 
the creation date to the current date and time, and the version number to 1.

To remove version information, either go to File > Versions, select the versions from the list and 
click Delete, or use Save As and save the file with a different name.
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Introduction

In previous chapters, we have been entering one of two basic types of data into each cell: numbers
and text. However, we will not always know what the contents should be. Often the contents of one
cell depends on the contents of other cells. To handle this situation, we use a third type of data: the
formula. Formulas are equations using numbers and variables to get a result. In a spreadsheet, the
variables are cell locations that hold the data needed for the equation to be completed.

A function is a predefined calculation entered in a cell to help you analyze or manipulate data in a 
spreadsheet. All you have to do is add the arguments, and the calculation is automatically made for
you. Functions help you create the formulas needed to get the results that you are looking for.

Setting up a spreadsheet

If you are setting up more than a simple one-worksheet system in Calc, it is worth planning ahead 
a little. Avoid the following traps:

• Typing fixed values into formulas

• Not including notes and comments describing what the system does, including what input 
is required and where the formulas come from (if not created from scratch)

• Not incorporating a system of checking to verify that the formulas do what is intended

The trap of fixed values
Many users set up long and complex formulas with fixed values typed directly into the formula.

For example, conversion from one currency to another requires knowledge of the current 
conversion rate. If you input a formula in cell C1 of =0.75*B1 (for example to calculate the value 
in Euros of the USD dollar amount in cell B1), you will have to edit the formula when the exchange 
rate changes from 0.75 to some other value. It is much easier to set up an input cell with the 
exchange rate and reference that cell in any formula needing the exchange rate. What-if type 
calculations are also simplified: what if the exchange rate varies from 0.75 to 0.70 or 0.80? No 
formula editing is needed and it is clear what rate is used in the calculations. Breaking complex 
formulas down into more manageable parts, described below, also helps to minimize errors and aid
troubleshooting.

Lack of documentation
Lack of documentation is a very common failing. Many users prepare a simple worksheet which 
then develops into something much more complicated over time. Without documentation, the 
original purpose and methodology is often unclear and difficult to decipher. In this case it is usually 
easier to start again from the beginning, wasting the work done previously. If you insert comments 
in cells, and use labels and headings, a spreadsheet can later be modified by you or others and 
much time and effort will be saved.

Error-checking formulas
Adding up columns of data or selections of cells from a worksheet often results in errors due to 
omitting cells, wrongly specifying a range, or double-counting cells. It is useful to institute checks in
your spreadsheets. For example, set up a spreadsheet to calculate columns of figures, and use 
SUM to calculate the individual column totals. You can check the result by including (in a non-
printing column) a set of row totals and adding these together. The two figures—row total and 
column total—must agree. If they do not, you have an error somewhere. 
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Figure 144: Error checking of formulas

You can even set up a formula to calculate the difference between the two totals and report an 
error in case a non-zero result is returned (see Figure 144).

Creating formulas

You can enter formulas in two ways, either by using the Function Wizard, or by typing directly into 
the cell or into the input line. A formula must begin with an = symbol, so when typing in directly, you
need to start a formula with one of the following symbols: =, + or –. Calc automatically adds the = 
symbol for the formula, when starting with the + or _ character. Starting with anything else causes 
the formula to be treated as if it were text.

Operators in formulas
Each cell on the worksheet can be used as a data holder or a place for data calculations. Entering 
data is accomplished simply by typing in the cell and moving to the next cell or pressing Enter. 
With formulas, the equals sign indicates that the cell will be used for a calculation. A mathematical 
calculation like 15 + 46 can be accomplished as shown in Figure 145.

While the calculation on the left was accomplished in only one cell, the real power is shown on the 
right where the data is placed in cells and the calculation is performed using references back to the
cells. In this case, cells B3 and B4 were the data holders, with B5 the cell where the calculation 
was performed. Notice that the formula was shown as =B3+B4. The plus sign indicates that the 
contents of cells B3 and B4 are to be added together and then have the result in the cell holding 
the formula. All formulas build upon this concept. Other ways of using formulas are shown in Table 
4.

These cell references allow formulas to use data from anywhere in the worksheet being worked on 
or from any other worksheet in the workbook that is opened. If the data needed was in different 
worksheets, they would be referenced by referring to the name of the worksheet, for example 
=SUM(Sheet2.B12+Sheet3.A11).

Chapter 7  Using Formulas and Functions 193



Note

To enter the = symbol for a purpose other than creating a formula as described in this
chapter, type an apostrophe or single quotation mark before the =. For example, in 
the entry '= means different things to different people, Calc treats everything after the
single quotation mark—including the = sign—as text.

Simple Calculation in 1 Cell Calculation by Reference

Figure 145: A simple calculation

Table 4: Common ways to use formulas

Formula Description

=A1+10 Displays the contents of cell A1 plus 10.

=A1*16% Displays 16% of the contents of A1.

=A1*A2 Displays the result of multiplying the contents of A1 and A2.

=ROUND(A1,1) Displays the contents of cell A1 rounded to one decimal place.

=EFFECTIVE(5%,12) Calculates the effective interest for 5% annual nominal interest with
12 payments a year.

=B8-SUM(B10:B14) Calculates B8 minus the sum of the cells B10 to B14.

=SUM(B8,SUM(B10:B14)) Calculates the sum of cells B10 to B14 and adds the value to B8.

=SUM(B1:B1048576) Sums all numbers in column B.
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Formula Description

=AVERAGE(BloodSugar) Displays the average of a named range defined under the name 
BloodSugar.

=IF(C31>140, "HIGH", "OK") Displays the results of a conditional analysis of data from two 
sources. If the contents of C31 is greater than 140, then HIGH is 
displayed, otherwise OK is displayed.

Note

Users of Lotus 1-2-3, Quattro Pro and other spreadsheet software may be familiar 
with formulas that begin with +, -, =, (, @, ., $, or #. A mathematical formula would 
look like +D2+C2 or +2*3. Functions begin with the @ symbol such as 
@SUM(D2..D7), @COS(@DEGTORAD(30)) and @IRR(GUESS,CASHFLOWS). 
Ranges are identified such as A1..D3.

Functions can be identified in Table 4 by a word, for example ROUND, followed by parentheses 
enclosing references or numbers.

It is also possible to establish ranges for inclusion by naming them using Insert > Names, for 
example BloodSugar representing a range such as B3:B10. Logical functions can also be 
performed as represented by the IF statement which results in a conditional response based upon 
the data in the identified cell, for example

=IF(A2>=0,"Positive","Negative")
A value of 3 in cell A2 would return the result Positive, a value of –9 the result Negative.

Operator types
You can use the following operator types in LibreOffice Calc: arithmetic, comparative, text, and 
reference.

Arithmetic operators
The addition, subtraction, multiplication and division operators return numerical results. The 
Negation and Percent operators identify a characteristic of the number found in the cell, for 
example -37. The example for Exponentiation illustrates how to enter a number that is being 
multiplied by itself a certain number of times, for example 23 = 2*2*2.

Table 5: Arithmetical operators

Operator Name Example

+ (Plus) Addition =1+1

– (Minus) Subtraction =2–1

– (Minus) Negation –5

* (asterisk) Multiplication =2*2

/ (Slash) Division =10/5

% (Percent) Percent 15%

^ (Caret) Exponentiation 2^3
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Comparative operators
Comparative operators are found in formulas that use the IF function and return either a true or 
false answer; for example, =IF(B6>G12, 127, 0) which, loosely translated, means if the 
contents of cell B6 are greater than the contents of cell G12, then return the number 127, 
otherwise return the number 0.

A direct answer of TRUE or FALSE can be obtained by entering a formula such as =B6>B12. If the
numbers found in the referenced cells are accurately represented, the answer TRUE is returned, 
otherwise FALSE is returned.

Table 6: Comparative operators

Operator Name Example

= Equal A1=B1

> Greater than A1>B1

< Less than A1<B1

>= Greater than or equal to A1>=B1

<= Less than or equal to A1<=B1

<> Inequality A1<>B1

If cell A1 contains the numerical value 4 and cell B1 the numerical value 5, the above examples 
would yield results of FALSE, FALSE, TRUE, FALSE, TRUE, and TRUE.

Text operators
It is common for users to place text in spreadsheets. To provide for variability in what and how this 
type of data is displayed, text can be joined together in pieces coming from different places on the 
spreadsheet. Figure 146 shows an example.

Figure 146: Text concatenation

In this example, specific pieces of the text were found in three different cells. To join these 
segments together, the formula also adds required spaces and punctuation enclosed within 
quotation marks, resulting in a formula of =B2 & " " & C2 & ", " & D2. The result is the 
concatenation into a date formatted in a particular sequence.

Calc has a CONCATENATE function which performs the same operation.
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Taking this example further, if the result cell is defined as a name, then text concatenation is 
performed using this defined name. This process is demonstrated in Figures 147, 148, and 149 
where the cell with the date is named “WizardDay” and subsequently used in a formula in another 
cell.

Figure 147: Defining a name for a range of cells

Chapter 7  Using Formulas and Functions 197



Figure 148: Naming a cell or range of cells for inclusion in a formula

  

The defined name WizardDay in D2.

  

Text entered into A4, the formula into A6.

  

The result displayed in A6.

Figure 149: Using Names in a formula

Reference operators
An individual cell is identified by the column identifier (letter) located along the top of the columns 
and a row identifier (number) found along the left-hand side of the spreadsheet. On spreadsheets 
read from left to right, the reference for the upper left cell is A1.

Thus in its simplest form a reference refers to a single cell, but references can also refer to a 
rectangle or cuboid range or a reference in a list of references. To build such references you need 
reference operators.
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Range operator
The range operator is written as a colon. An expression using the range operator has the following 
syntax: 

reference upper left : reference lower right

The range operator builds a reference to the smallest range including both the cells referenced 
with the left reference and the cells referenced with the right reference.

Figure 150: Reference Operator for a range

In the upper left corner of Figure 150 the reference A1:D12 is shown, corresponding to the cells 
included in the drag operation with the mouse to highlight the range.

Examples 

A2:B4 Reference to a rectangle range with 6 cells, 2 column width × 3 row
height. When you click on the reference in the formula in the input 
line, a border indicates the rectangle.

(A2:B4):C9 Reference to a rectangle range with cell A2 top left and cell C9 
bottom right. So the range contains 24 cells, 3 column width × 8 
row height. This method of addressing extends the initial range 
from A2:B4 to A2:C9.

Sheet1.A3:Sheet3.D4 Reference to a cuboid range with 24 cells, 4 column width × 2 row 
height × 3 sheets depth.

When you enter B4:A2 or A4:B2 directly, then Calc will turn it to A2:B4. So the left top cell of the 
range is left of the colon and the bottom right cell is right of the colon. But if you name the cell B4 
for example with _start and A2 with _end, you can use _start:_end without any error.

Calc can not reference a whole column of unspecified length using A:A or a whole row using 1:1 
which you might be familiar with in other spreadsheet programs.

Reference concatenation operator
The concatenation operator is written as a tilde. An expression using the concatenation operator 
has the following syntax:

reference left ~ reference right

The result of such an expression is a reference list, which is an ordered list of references. Some 
functions can take a reference list as an argument, SUM, MAX or INDEX for example.
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The reference concatenation is sometimes called 'union'. But it is not the union of the two sets 
'reference left' and 'reference right' as normally understood in set theory. COUNT(A1:C3~B2:D2) 
returns 12 (=9+3), but it has only 10 cells when considered as the union of the two sets of cells.

Notice that SUM(A1:C3,B2:D2) is different from SUM(A1:C3~B2:D2) although they give the same 
result. The first is a function call with 2 parameters, each of them is reference to a range. The 
second is a function call with 1 parameter, which is a reference list.

Intersection operator
The intersection operator is written as an exclamation mark. An expression using the intersection 
operator has the following syntax:

reference left ! reference right

If the references refer to single ranges, the result is a reference to a single range, containing all 
cells, which are both in the left reference and in the right reference. 

If the references are reference lists, then each list item from the left is intersected with each one 
from the right and these results are concatenated to a reference list. The order is to first intersect 
the first item from the left with all items from the right, then intersect the second item from the left 
with all items from the right, and so on.

Examples 

A2:B4 ! B3:D6

This results in a reference to the range B3:B4, because these cells are inside A2:B4 and inside 
B3:D4.

(A2:B4~B1:C2) ! (B2:C6~C1:D3)

First the intersections A2:B4!B2:C6, A2:B4!C1:D3, B1:C2!B2:C6 and B1:C2!C1:D3 are 
calculated. This results in B2:B4, empty, B2:C2, and C1:C2. Then these results are 
concatenated, dropping empty parts. So the final result is the reference list B2:B4 ~ B2:C2 ~ 
C1:C2. 

You can use the intersection operator to refer a cell in a cross tabulation in an understandable way.
If you have columns labeled 'Temperature' and 'Precipitation' and the rows labeled 'January', 
'February', 'March', and so on, then the following expression

'February' ! 'Temperature' 

will reference to the cell containing the temperature in February.

The intersection operator (!) has a higher precedence than the concatenation operator (~), but do 
not rely on precedence.

Tip Always put in parentheses the part that is to be calculated first.

Relative and absolute references
References are the way that we refer to the location of a particular cell in Calc and can be either 
relative (to the current cell) or absolute (a fixed amount).

Relative referencing
An example of a relative reference will illustrate the difference between a relative reference and 
absolute reference using the spreadsheet from Figure 151.

1) Type the numbers 4 and 11 into cells C3 and C4 respectively of that spreadsheet.
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2) Copy the formula in cell B5 (=B3+B4) to cell C5. You can do this by using a simple copy 
and paste or click and drag B5 to C5 as shown below. The formula in B5 calculates the 
sum of values in the two cells B3 and B4.

3) Click in cell C5. The formula bar shows =C3+C4 rather than =B3+B4 and the value in C5 is 
15, the sum of 4 and 11 which are the values in C3 and C4.

In cell B5 the references to cells B3 and B4 are relative references. This means that Calc interprets
the formula in B5, applies it to the cells in the B column, and puts the result in the cell holding the 
formula. When you copied the formula to another cell, the same procedure was used to calculate 
the value to put in that cell. This time the formula in cell C5 referred to cells C3 and C4.

Figure 151: Relative references

You can think of a relative address as a pair of offsets to the current cell. Cell B1 is 1 column to the 
left of Cell C5 and 4 rows above. The address could be written as R[-1]C[-4]. In fact earlier 
spreadsheets allowed this notation method to be used in formulas.

Whenever you copy this formula from cell B5 to another cell the result will always be the sum of the
two numbers taken from the two cells one and two rows above the cell containing the formula.

Relative addressing is the default method of referring to addresses in Calc.

Absolute referencing
You may want to multiply a column of numbers by a fixed amount. A column of figures might show 
amounts in US Dollars. To convert these amounts to Euros it is necessary to multiply each dollar 
amount by the exchange rate. $US10.00 would be multiplied by 0.75 to convert to Euros, in this 
case Eur7.50. The following example shows how to input an exchange rate and use that rate to 
convert amounts in a column form USD to Euros.

1) Input the exchange rate Eur:USD (0.75) in cell D1. Enter amounts (in USD) into cells D2, 
D3 and D4, for example 10, 20, and 30. 

2) In cell E2 type the formula =D2*D1. The result is 7.5, correctly shown. 

3) Copy the formula in cell E2 to cell E3. The result is 200, clearly wrong! Calc has copied the 
formula using relative addressing: the formula in E3 is =D3*D2 and not what we want, 
which is =D3*D1.

4) In cell E2 edit the formula to be =D2*$D$1. Copy it to cells E3 and E4. The results are now 
15 and 22.5 which are correct.

The $ signs before the D and the 1 convert the reference to cell D1 from relative to absolute or 
fixed. If the formula is copied to another cell the second part will always show $D$1. The 
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interpretation of this formula is “take the value in the cell one column to the left in the same row 
and multiply it by the value in cell D1”.

Entering the conversion formula into E2, correct result, then copying it to E3.

E3 result is clearly wrong, change the formula in E2 to read absolute reference.

Applying the correct formula from E2 to E3 to get the correct answer.

Figure 152: Absolute references

Cell references can be shown in four ways.

Reference Explanation

D1 Relative, from cell E3 it is the cell one column to the left and two rows above

$D$1 Absolute, from cell E3 it is the cell D1

$D1 Partially absolute, from cell E3 it is the cell in column D and two rows above

D$1 Partially absolute, from cell E3 it is the cell one column to the left and in row 1

Tip
To change references in formulas, highlight the cell and press Shift-F4 to cycle 
through the four types of references. This method is of limited value in more 
complicated formulas; it is usually quicker to edit the formula by hand.

Knowledge of the use of relative and absolute references is essential if you want to copy and paste
formulas and to link spreadsheets.
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Order of calculation
Order of calculation refers to the sequence in which numerical operations are performed. Division 
and multiplication are performed before addition or subtraction. There is a common tendency to 
expect calculations to be made from left to right as the equation would be read in English. Calc 
evaluates the entire formula, then based upon programming precedence breaks the formula down 
executing multiplication and division operations before other operations. Therefore, when creating 
formulas you should test your formula to make sure that the correct result is being obtained. 
Following is an example of the order of calculation in operation.

Table 7: Order of Calculation

Left To Right Calculation Ordered Calculation

1+3*2+3 = 11

1+3 = 4, then 4 X 2 = 8, then 8+3 = 11

=1+3*2+3 result 10

3*2 = 6, then 1+6+3 = 10

Another possible intention could be:

1+3*2+3 = 20

1+3 = 4, then 2+3 = 5, then 4 X 5=20

The program resolves the multiplication of 
3 X 2 before dealing with the numbers 
being added.

If you intend for the result to be either of the two possible solutions on the left, the way to achieve 
these results would be to order the formula as:

((1+3) * 2)+3 = 11 (1+3) * (2+3) = 20

Note
Use parentheses to group operations in the order you intend; for example,  
=B4+G12*C4/M12 might become =((B4+G12)*C4)/M12.

Calculations linking sheets
Another powerful feature of Calc is the ability to link data through several worksheets. The naming 
of worksheets can be helpful to identify where specific data may be found. A name such as Payroll 
or Boise Sales is much more meaningful than Sheet1. The function named SHEET() returns the 
sheet number (position) in the collection of worksheets. There may be several worksheets in each 
book and they may be numbered from the left: Sheet1, Sheet2, and so forth. If you drag the 
worksheets around to different locations among the tabs, the function returns the number referring 
to the current position of this worksheet. In a new instance of Calc, the default is a single 
worksheet.

For example, if the formula =SHEET() is put into A1 on Sheet 1 it returns the value 1. If you drag 
Sheet 1 to be positioned between sheets 2 and 3 then the value changes to 2, it is now the second
sheet in the order.

An example of calculations obtaining data from other work can be seen in a business setting where
a business combines revenues and costs of each of its branch operations into a single combined 
worksheet.
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Sheet containing data for 
Branch 1.

Sheet containing data for 
Branch 2.
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Sheet containing data for 
Branch 3.

Sheet containing combined 
data for all branches.

Figure 153: Combining data from several sheets into a single sheet

The spreadsheets have been set up with identical structures. The easiest way to do this is to open 
a new spreadsheet, set up the first Branch spreadsheet, input data, format cells, and prepare the 
formulas for the various sums of rows and columns.

1) On the worksheet tab, right-click and select Rename Sheet. Type Branch1. Right-click on 
the tab again and select Move/Copy Sheet.

2) In the Move/Copy Sheet dialog, select the Copy option (automatically selected if there is 
only one sheet in the spreadsheet) and select -move to end position- in the Insert before 
window. Change the entry in New name to Branch2. Click OK. Repeat to produce the 
Branch3 and Combined worksheets.
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Figure 154: Copying a worksheet

3) Enter the data for Branch 2 and Branch 3 into the respective sheets. Each sheet stands 
alone and reports the results for the individual branches.

4) In the Combined worksheet, click on cell K7. Type =, click on the tab Branch1, click on cell 
K7, press +, repeat for sheets Branch2 and Branch3 and press Enter. You now have a 
formula in cell K7 which adds the revenue from Greenery Sales for the 3 Branches.

Figure 155: Combined worksheet showing linking between branch sheets
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5) Copy the formula, highlight the range K7:N17, click Edit > Paste Special, uncheck the 
Paste all and Formats boxes in the Selection area of the dialog box and click OK. You will 
see the following message:

Figure 156: Linking sheets: pasting a formula to a 
cell range

6) Click Yes. You have now copied the formulas into each cell while maintaining the format 
you set up in the original worksheet. Of course, in this example you would have to tidy the 
worksheet up by removing the zeros in the non-formatted rows.

Figure 157: Linking Sheets: Copy Paste Special from K7:N17

Note
LibreOffice default is to paste all the attributes of the original cell(s) - formats, notes, 
objects, text strings and numbers.

The Function Wizard can also be used to accomplish the linking. Use of this Wizard is described in
detail in the section on Functions.

Understanding functions

Calc includes over 350 functions to help you analyze and reference data. Many of these functions 
are for use with numbers, but many others are used with dates and times, or even text. A function 
may be as simple as adding two numbers together, or finding the average of a list of numbers. 
Alternatively, it may be as complex as calculating the standard deviation of a sample, or a 
hyperbolic tangent of a number.

Typically, the name of a function is an abbreviated description of what the function does. For 
instance, the FV function gives the future value of an investment, while BIN2HEX converts a binary
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number to a hexadecimal number. By tradition, functions are entered entirely in upper case letters, 
although Calc will read them correctly if they are in lower or mixed case, too.

A few basic functions are somewhat similar to operators. Examples:

+ This operator adds two numbers together for a result. SUM() on the other hand adds groups 
of contiguous ranges of numbers together.

* This operator multiplies two numbers together for a result. PRODUCT() does the same for 
multiplying that SUM() does for adding.

Each function has a number of arguments used in the calculations. These arguments may or may 
not have their own name. Your task is to enter the arguments needed to run the function. In some 
cases, the arguments have predefined choices, and you may need to refer to the online help or 
Appendix B (Description of Functions) in this book to understand them. More often, however, an 
argument is a value that you enter manually, or one already entered in a cell or range of cells on 
the spreadsheet. In Calc, you can enter values from other cells by typing in their name or range, or
—unlike the case in some spreadsheets—by selecting cells with the mouse. If the values in the 
cells change, then the result of the function is automatically updated.

For compatibility, functions and their arguments in Calc have almost identical names to their 
counterparts in Microsoft Excel. However, both Excel and Calc have functions that the other lacks. 
Occasionally, functions with the same names in Calc and Excel have different arguments, or 
slightly different names for the same argument—neither of which can be imported to the other. 
However, the majority of functions can be used in both Calc and Excel without any change. A 
comparison list may be found on the LibreOffice wiki, linked from the Documentation/Publications 
page.

Understanding the structure of functions
All functions have a similar structure. If you use the right tool for entering a function, you can 
escape learning this structure, but it is still worth knowing for troubleshooting.

To give a typical example, the structure of a function to find cells that match entered search criteria 
is:

= DCOUNT (Database,Database field,Search_criteria)

Since a function cannot exist on its own, it must always be part of a formula. Consequently, even if 
the function represents the entire formula, there must be an = sign at the start of the formula. 
Regardless of where in the formula a function is, the function will start with its name, such as 
DCOUNT in the example above. After the name of the function comes its arguments. All arguments
are required, unless specifically listed as optional.

Arguments are added within the parentheses and are separated by commas, with no space 
between the arguments and the commas. 

Many arguments are numbers. A Calc function can take up to thirty numbers as an argument. That 
may not sound like much at first. However, when you realize that the number can be not only a 
number or a single cell, but also an array or range of cells that contain several or even hundreds of
cells, then the apparent limitation vanishes.

Depending on the nature of the function, arguments may be entered as follows:

"text data" The quotes indicate text or string data is being entered.

9 The number nine is being entered as a number.

"9" The number nine is being entered as text 

A1 The address for whatever is in Cell A1 is being entered 
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Nested functions
Functions can also be used as arguments within other functions. These are called nested 
functions.

=SUM(2,PRODUCT(5,7))

To get an idea of what nested functions can do, imagine that you are designing a self-directed 
learning module. During the module, students do three quizzes, and enter the results in cells A1, 
A2, and A3. In A4, you can create a nested formula that begins by averaging the results of the 
quizzes with the formula =AVERAGE(A1:A3). The formula then uses the IF function to give the 
student feedback that depends upon the average grade on the quizzes. The entire formula would 
read:

=IF(AVERAGE(A1:A3) >85, "Congratulations! You are ready to advance to 
the next module", "Failed. Please review the material again. If 
necessary, contact your instructor for help")

Depending on the average, the student would receive the message for either congratulations or 
failure.

Notice that the nested formula for the average does not require its own equal sign. The one at the 
start of the equation is enough for both formulas.

If you are new to spreadsheets, the best way to think of functions is as a scripting language. We've
used simple examples to explain the concept more clearly, but, through nesting of functions, a Calc
formula can quickly become complex.

Note
Calc keeps the syntax of a formula displayed in a tool tip next to the cell as a 
handy memory aid as you type.

A more reliable method is to use the Function List (Figure 158).

Available from the Insert menu, the Function List automatically docks as a pane on the right side 
of the Calc editing window. If you wish, you can Control+double-click on a blank space at the top of
the pane to undock this pane and make it a floating window.

The Function List includes a brief description of each function and its arguments; highlight the 
function and look at the bottom of the pane to see the description. If necessary, hover the cursor 
over the division between the list and the description; when the cursor becomes a two-headed 
arrow, drag it upwards to increase the space for the description. Double-click on a function’s name 
to add it to the current cell, together with placeholders for each of the function’s arguments.

Clicking on the bar where the 5 dots and arrows are shown (shown by the ellipse in Figure 158) will
hide the list on the right hand side of the screen. Clicking this area again will show the list, making 
it easy to keep the list available for easy reference.

Using the Function List is almost as fast as manual entry, and has the advantage of not requiring 
that you memorize a formula that you want to use. In theory, it should also be less error-prone. In 
practice, though, some users may fumble when replacing the placeholders with values. Another 
feature is the ability to display the last formulas used.
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Figure 158: Function List docked to right side of Calc window

Function Wizard
The most commonly used input method is the Function Wizard (Figure 160). To open the Function 
Wizard, choose Insert > Function, or click the fx button on the Formula bar, or press Ctrl+F2. 
Once open, the Function Wizard provides the same help features as the Function List, but adds 
fields in which you can see the result of a completed function, as well as the result of any larger 
formula of which it is part.

Select a category of functions to shorten the list, then scroll down through the named functions and
select the required one by double-clicking on it. When you select a function its description appears 
on the right-hand side of the dialog.

The Wizard now displays an area to the right where you can enter data manually in text boxes or 

click the Shrink button to shrink the wizard so you can select cells from the worksheet.

Figure 159: Function Wizard after shrinking
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Figure 160: Functions page of Function Wizard.

To select cells, either click directly upon the cell or hold down the left mouse button and drag to 
select the required area.

When the area has been selected, click the Shrink button again to return to the wizard.

If multiple arguments are needed select the next text box below the first and repeat the selection 
process for the next cell or range of cells. Repeat this process as often as required. The Wizard will
accept up to 30 ranges or arguments in the SUM function.

Click OK to accept the function and add it to the cell and get the result.

Caution

If you select a function by double-clicking it in the list, and then change your mind 
and select a different one by double-clicking again, then the second choice formula 
is added into the first choice formula in the Formula text box. You must clear the 
formula box and then double-click the function to add it to the box.

This additive facility allows you to create complex formulas by building them up in 
the Formula box.

You can also select the Structure tab (Figure 161) to see a tree view of the parts of the formula. 
The main advantage over the Function List is that each argument is entered in its own field, 
making it easier to manage. The price of this reliability is slower input, but this is often a small price
to pay, since precision is generally more important than speed when creating a spreadsheet.

Caution
Pressing the dialog Help button after selecting certain functions with either a single- 
or double-click will cause LibreOffice to crash. This early bug may be corrected for 
later releases in the Version 4.1. series. Affected functions are:

AVERAGEIF; AVERAGEIFS; SUMIFS; COUNTIFS; IFERROR; IFNA; XOR; 
NUMBERVALUE; SKEWP
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Figure 161: Structure page of Function Wizard

Functions can be entered into the Input line. After you enter a function on the Input line, press the 
Enter key or click the Accept button on the Formula toolbar to add the function to the cell and get 
its result. 

1 Name Box showing list of common functions
2 Function Wizard 4 Accept
3 Cancel 5 Input Line

Figure 162: The Function toolbar

If you see the formula in the cell instead of the result, then Formulas are selected for display in 
Tools > Options > LibreOffice Calc > View > Display. Deselect Formulas, and the result will 
display. However, you can still see the formula in the Input line.

Strategies for creating formulas and functions

Formulas that do more than a simple calculation or summation of rows or columns of values 
usually take a number of arguments. For example, the classic equation of motion s = s0+ vt -
½at2 calculates the position of a body knowing its original position, its final velocity, its 
acceleration, and the time taken to move from the initial state to the final state.

For ease of presentation, it is good practice to set up a spreadsheet in a manner similar to that 
shown in Figure 163. In this example, the individual variables are input into cells on the sheet and 
no editing of the formula (in cell B9) is required.
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Figure 163: Setting up a formula with arguments

You can take several broad approaches when creating a formula. In deciding which approach to 
take, consider how many other people will need to use the worksheets, the life of the worksheets, 
and the variations that could be encountered in use of the formula.

If people other than yourself will use the spreadsheet, make sure that it is easy to see what input is
required and where. Explanation of the purpose of the spreadsheet, basis of calculation, input 
required and output(s) generated are often placed on the first worksheet.

A spreadsheet that you build today, with many complicated formulas, may not be quite so obvious 
in its function and operation in 6 or 12 months time. Use comments and notes liberally to document
your work.

You might be aware that you cannot use negative values or zero values for a particular argument, 
but if someone else inputs such a value will your formula be robust or simply return a standard 
(and often not too helpful) Err: message? It is a good idea to trap errors using some form of logic 
statements or with conditional formatting.

Place a unique formula in each cell
The most basic strategy is to view whatever formulas are needed as simple and with a limited 
useful life. The strategy is then to place a unique formula in each appropriate cell. This can be 
recommended only for very simple or “throw away” (single use) spreadsheets.

Break formulas into parts and combine the parts
The second strategy is similar to the first, but instead you break down longer formulas into smaller 
parts and then combine the parts into the whole. Many examples of this type exist in complex 
scientific and engineering calculations where interim results are used in a number of places in the 
worksheet. The result of calculating the flow velocity of water in a pipe may be used in estimating 
losses due to friction, whether the pipe is flowing full or partially empty, and in optimizing the 
diameter for the given flow regime.

In all cases you should adopt the basic principles of formula creation described previously.
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Use the Basic editor to create functions
A third strategy is to use the Basic editor and create your own functions and macros. This 
approach would be used where the result would greatly simplify the use of the spreadsheet by the 
end user and keep the formulas simple with a better chance of avoiding errors. This approach also 
can make the maintenance easier by having corrections or updates kept in one central location. 
The use of macros is described in Chapter 12 of this book and is a specialized topic in itself. The 
danger of overusing macros and custom functions is that the principles upon which the 
spreadsheet is based become much more difficult to see by a user other than the original author 
(and sometimes even by the author!).

Finding and fixing errors

It is common to find situations where errors are displayed. Even with all the tools available in Calc 
to help you to enter formulas, making mistakes is easy. Many people find inputting numbers difficult
and many may make a mistake about the kind of entry that a function’s argument needs. In 
addition to correcting errors, you may want to find the cells used in a formula to change their 
values or to check the answer.

Calc provides three tools for investigating formulas and the cells that they reference: error 
messages, color coding, and the Detective.

Error messages
The most basic tool is error messages. Error messages display in a formula’s cell or in the 
Function Wizard instead of the result.

An error message for a formula is usually a three-digit number from 501 to 527, or sometimes an 
unhelpful piece of text such as #NAME?, #REF, or #VALUE. The error number appears in the cell, 
and a brief explanation of the error on the right side of the status bar.

Most error messages indicate a problem with how the formula was input, although several indicate 
that you have run up against a limitation of either Calc or its current settings.

Error messages are not user-friendly, and may intimidate new users. However, they are valuable 
clues to correcting mistakes. You can find detailed explanations of them in the help, by searching 
for Error codes in LibreOffice Calc. A few of the most common are shown in the following table.

#NAME? Instead of displaying Err:525. No valid reference exists for the argument.

#REF Instead of displaying Err:524. The column, row, or sheet for the referenced 
cell is missing.

#VALUE Instead of displaying Err:519. The value for one of the arguments is not the 
type that the argument requires. The value may be entered incorrectly; for 
example, double-quotation marks may be missing around the value. At other 
times, a cell or range used may have the wrong format, such as text instead of
numbers.

#DIV0! Instead of displaying Err:532. Division by zero

#NUM! A calculation results in an overflow of the defined value range.

509 An operator such as an equals sign is missing from the formula.

510 A variable is missing from the formula.
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Examples of common errors

#DIV/0! Division by zero
This error is the result of dividing a number by either the number zero (0) or a blank cell. There is 
an easy way to avoid this type of problem. When you have a zero or blank cell displayed, use a 
conditional function. Figure 164 depicts division of column B by column C yielding 2 errors arising 
from a zero and a blank cell showing in column C.

Figure 164: Examples of #DIV/0!, Division by zero error

It is very common to find an error such as this arising from a situation where data was not reported 
or reported incorrectly. When such an occurrence is possible, an IF function can be used to display
the data correctly. The formula =IF(C3>0, B3/C3, "No Report") can be entered. The 
formula is then copied over the remainder of Column D. The meaning of this formula roughly would
be:  “If C3 is greater than 0, then compute B3 divided by C3, otherwise enter ‘No Report’”.

It is also possible for the last parameter to use double quotes for a blank (no value) to be entered, 
or a different formula with a standardized number being substituted for the lower number. An 
example is shown in Figure 165.

Figure 165: Division by zero solution
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#VALUE No result and #REF Incorrect references
The #Value error is also very common. 

Figure 166: Incorrect entry causing #VALUE error

A common occurrence of this error arises when a cell contains an incorrect value type. In the 
example of Figure 23, text “None” has been entered in C8, where our formula in column D is 
expecting a number.

The #REF error is caused by a missing reference. In the example below, the formula references a 
sheet which has been deleted.

Color coding for input
Another useful tool when reviewing a formula is the color coding for input. When you select a 
formula that has already been entered, the cells or ranges used for each argument in the formula 
are outlined in color.

Calc uses eight colors for outlining referenced cells, starting with blue for the first cell, and 
continuing with red, magenta, green, dark blue, brown, purple and yellow before cycling through 
the sequence again.
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The Detective
In a long or complicated spreadsheet, color coding becomes less useful. In these cases, consider 
using the submenu under Tools > Detective. The Detective is a tool for checking which cells are 
used as arguments by a formula (precedents) and which other formulas it is nested in 
(dependents), and tracking errors. It can also be used for tracing errors, marking invalid data (that 
is, information in cells that is not in the proper format for a function’s argument), or even for 
removing precedents and dependents.

To use the Detective, select a cell with a formula, then start the Detective. On the spreadsheet, you
will see lines ending in circles to indicate precedents, and lines ending in arrows for dependents. 
The lines show the flow of information.

Use the Detective to assist in following the precedents referred to in a formula in a cell. By tracing 
these precedents, you frequently can find the source of the errors. Place the cursor in the cell in 
question and then choose Tools > Detective > Trace Precedents from the menu bar or press 
Shift+F7. Figure 167 shows a simple example of tracing precedents.

This allows us to check the source cells (which may be a range) for any errors which have caused 
us to query the calculation result. If a source is a range, then that range is highlighted in blue.

In other instances we may have to trace an error. For this we use the Trace Error function, found 
under Tools > Detective > Trace Error, to find the cells that caused the error.

a) Cell containing formula selected.

Figure 167: Tracing precedents using the Detective
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b) Initiate trace by clicking Trace Precedents

c) Source cells indicated with blue dots, with arrow pointing to the calculation cell

(continued): Tracing precedents using the Detective

Examples of functions

For novices, functions are one of the most intimidating features of LibreOffice's Calc. New users 
quickly learn that functions are an important feature of spreadsheets, but there are hundreds, and 
many require input that assumes specialized knowledge. Fortunately, Calc includes dozens of 
functions that anyone can use.
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Basic arithmetic and statistics
The most basic functions create formulas for basic arithmetic or for evaluating numbers in a range 
of cells.

Basic arithmetic
The simple arithmetic functions are addition, subtraction, multiplication, and division.

Except for subtraction, each of these operations has its own function:

• SUM for addition

• PRODUCT for multiplication

• QUOTIENT for division

Traditionally, subtraction does not have a function.

SUM, PRODUCT, and QUOTIENT are useful for entering ranges of cells in the same way as any 
other function, with arguments in brackets after the function name.

However, for basic equations, many users prefer the time-honored computer symbols for these 
operations, using the plus sign (+) for addition, the hyphen (–) for subtraction, the asterisk (*) for 
multiplication and the forward slash (/) for division. These symbols are quick to enter without 
requiring your hands to stray from the keyboard.

A similar choice is also available if you want to raise a number by the power of another. Instead of 
entering =POWER(A1,2), you can enter =A1^2.

Moreover, they have the advantage that you enter formulas with them in an order that more closely
approximates human readable format than the spreadsheet-readable format used by the 
equivalent function. For instance, instead of entering =SUM (A1:A2), or possibly =SUM (A1,A2), 
you enter =A1+A2. This almost-human readable format is especially useful for compound 
operations, where writing =A1*(A2+A3) is briefer and easier to read than 
=PRODUCT(A1,SUM(A2:A3)).

The main disadvantage of using arithmetical operators is that you cannot directly use a range of 
cells. In other words, to enter the equivalent of =SUM (A1:A3), you would need to type 
=A1+A2+A3. 

Otherwise, whether you use a function or an operator is largely up to you—except, of course, when
you are subtracting. However, if you use spreadsheets regularly in a group setting such as a class 
or an office, you might want to standardize on an entry format so that everyone who handles a 
spreadsheet becomes accustomed to a standard input.

Simple statistics
Another common use for spreadsheet functions is to pull useful information out of a list, such as a 
series of test scores in a class, or a summary of earnings per quarter for a company.

You can, of course, scan a list of figures if you want basic information such as the highest or lowest
entry or the average. The only trouble is, the longer the list, the more time you waste and the more 
likely you are to miss what you are looking for. Instead, it is usually quicker and more efficient to 
enter a function. Such reasons explain the existence of a function like COUNT, which does no 
more than give the total number of entries in the designated cell range.

Similarly, to find the highest or lowest entry, you can use MIN or MAX. For each of these formulas, 
all arguments are either a range of cells, or a series of cells entered individually.

Each also has a related function, MINA or MAXA, which performs the same function, but also 
treats a cell formatted for text as having a value of 0 (The same treatment of text occurs in any 
variation of another function that adds an "A" to the end). Either function gives the same result, and
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could be useful if you used a text notation to indicate, for example, if any student were absent 
when a test was written, and you wanted to check whether you needed to schedule a makeup 
exam.

For more flexibility in similar operations, you could use LARGE or SMALL, both of which add a 
specialized argument of rank. If the rank is 1 used with LARGE, you get the same result as you 
would with MAX. However, if the rank is 2, then the result is the second largest result. Similarly, a 
rank of 2 used with SMALL gives you the second smallest number. Both LARGE and SMALL are 
handy as a permanent control, since, by changing the rank argument, you can quickly scan 
multiple results.

You would need to be an expert to want to find the Poisson Distribution of a sample, or to find the 
skew or negative binomial of a distribution (and, if you are, you will find functions in Calc for such 
things). However, for the rest of us, there are simpler statistical functions that you can quickly learn 
to use.

In particular, if you need an average, you have a number of functions to choose from. You can find 
the arithmetical mean—that is, the result when you add all entries in a list then divided by the 
number of entries, by entering a range of numbers when using AVERAGE, or AVERAGE A to 
include text entries and to give them a value of zero.

In addition, you can get other information about the data set:

• MEDIAN: The entry that is exactly half way between the highest and lowest number in a 
list.

• MODE: The most common entry in a list of numbers.

• QUARTILE: The entry at a set position in the array of numbers. Besides the cell range, you 
enter the type of Quartile: 0 for the lowest entry, 1 for the value of 25%, 2 for the value of 
50%, 3 for 75%, and 4 for the highest entry. Note that the result for types 1 through 3 may 
not represent an actual item entered.

• RANK: The position of a given entry in the entire list, measured either from top to bottom or
bottom to top. You need to enter the cell address for the entry, the range of entries, and the 
type of rank (0 for the rank from the highest, or 1 for the rank from the bottom.

Some of these functions overlap; for example, MIN and MAX are both covered by QUARTILE. In 
other cases, a custom sort or filter might give much the same result. Which you use depends on 
your temperament and your needs. Some might prefer to use MIN and MAX because they are 
easy to remember, while others might prefer QUARTILE because it is more versatile.

Using these functions
In some cases, you may be able to get similar results to some of these functions by setting up a 
filter or a custom sort. However, in general, functions are more easily adjusted than filters or sorts, 
and provide a wide range of possibilities.

At times, you may just want to enter one or more formulas temporarily in a convenient blank cell, 
and delete it once you have finished. However, if you find yourself using the same functions 
constantly, you should consider creating a template and including space for all the functions you 
use, with the cell to their left used as a label for them. Once you have created the template, you 
can easily update each formula as entries change, either automatically and on-the-fly or pressing 
the F9 key to update all selected cells.

No matter how you use these functions, you will probably find them simple to use and adaptable 
for many purposes. By the time you have mastered this handful, you will be ready to try more 
complex functions.
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Rounding off numbers
For statistical and mathematical purposes, Calc includes a variety of ways to round off numbers. If 
you are a programmer, you may also be familiar with some of these methods. However, you do not
need to be a specialist to find some of these methods useful. You may want to round off for billing 
purposes, or because decimal places do not translate well into the physical world—for instance, if 
the parts you need come in packages of 100, then the fact you only need 66 is irrelevant to you; 
you need to round up for ordering. By learning the options for rounding up or down, you can make 
your spreadsheets more immediately useful.

When you use a rounding function, you have two choices about how to set up your formulas. If you
choose, you can nest a calculation within one of the rounding functions. For instance, the formula 
=ROUND((SUM(A1,A2)) adds the figures in cells A1 and A2, then rounds them off to the nearest 
whole number. However, even though you do not need to work with exact figures every day, you 
may still want to refer to them occasionally. If that is the case, then you are probably better off 
separating the two functions, placing =SUM(A1,A2) in cell A3, and =ROUND (A3) in A4, and clearly
labeling each function.

Rounding methods
The most basic function for rounding numbers in Calc is ROUND. This function will round off a 
number according to the usual rules of symmetric arithmetic rounding: a decimal value of .4 or less
gets rounded down, while one of .5 or more gets rounded up. However, at times, you may not want
to follow these rules. For instance, if you are one of those contractors who bills a full hour for any 
fraction of an hour you work, you would want to always round up so you did not lose any money. 
Conversely, you might choose to round down to give a slight discount to a long-established 
customer. In these cases, you might prefer to use ROUNDUP or ROUNDDOWN, which, as their 
names suggest, round a number to the nearest integer above or below it.

All three of these functions require the single argument of number—the cell or number to be 
rounded. Used with only this argument, all three functions round to the nearest whole number, so 
that 46.5 would round to 47 with ROUND or ROUNDUP and 46 with ROUNDDOWN. However, if 
you use the optional count argument, you can specify the number of decimal places to include. For
instance, if number was set to 1, then 48.65 would round to 48.7 with ROUND or ROUNDUP and 
to 48.6 with ROUNDDOWN. 

As an alternative to ROUNDDOWN when working with decimals, you can use TRUNC (short for 
truncate). It takes exactly the same arguments as ROUNDDOWN, so which function you use is a 
matter of choice. If you are not working with decimals, you might choose to use INT (short for 
integer), which takes only the number argument.

Another option is the ODD and EVEN pair of functions. ODD rounds up to the nearest odd number 
if what is entered in the number argument is a positive number, and rounds down if it is a negative 
number, while EVEN does the same for an even number.

Further options are the CEILING and FLOOR functions. As you can guess from the names, 
CEILING rounds up and FLOOR rounds down. For both functions, the number that they round to is
determined by the closest multiple of the number that you enter as the significance argument which
is above or below the value being tested. For instance, if your business insurance is billed by the 
work week, the fact that you were only open three days one week would be irrelevant to your 
costs; you would still be charged for an entire week, and therefore might want to use CEILING in 
your monthly expenses.

If cell E1 contains the value 46.7, =CEILING(E1,7) will return the value 49, this being the closest 
multiple of 7 above the value.

Conversely, if you are building customized computers and completed 4.5 in a day, your client 
would only be interested in the number ready to ship, so you might use FLOOR in a report of your 
progress.
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If cell E1 contains the value 46.7, =FLOOR(E1,7) will return the value 42, this being the closest 
multiple of 7 below the value.

Besides number and significance, both CEILING and FLOOR include an optional argument called 
mode, which takes a value of 0 or 1. If mode is set to 0, and both the number and the significance 
are negative numbers, then the result of either function is rounded up; if it is set to 1, and both the 
number and the significance are negative numbers, then the results are rounded down. In other 
words, if the number is -11 and the significance is -5, then the result is -10 when the mode is set to 
0, but -15 when set to 1.

However, if you are exchanging spreadsheets between Calc and MS Excel, remember that the 
mode argument is not supported by Excel. If you want the answers to be consistent between the 
two spreadsheets, leave the optional mode argument out of your formulas.

A function somewhat similar to CEILING and FLOOR is MROUND. Like CEILING AND FLOOR, 
MROUND requires two arguments, although, somewhat confusingly, the second one is called 
multiple rather than significance, even though the two are identical. The difference between 
MROUND and CEILING and FLOOR is that MROUND rounds up or down using symmetric 
arithmetic rounding. For example, if the number is 77 and the multiple is 5, then MROUND gives a 
result of 75. However, if the multiple is changed to 7, then the result of MROUND becomes 77.

Once you become familiar with Calc’s long, undifferentiated list of functions, you can start to decide
which is most useful for your purposes.

However, one last point is worth mentioning: If you are working with more than two decimal places,
do not be surprised if you do not see the same number of decimal places on the spreadsheet in 
unformatted cells, as you do on the function wizard. If you do not, the reason may be that Tools > 
Options > LibreOffice Calc > Calculate > Limit decimals for general number format has been 
enabled and the default changed from 0. Either deselect this option to return it to the default 
setting, or change the number of decimal places, and, if necessary, uncheck the Precision as 
shown box on the same page, and the spreadsheet will display as expected.

Using regular expressions in functions

A number of functions in Calc allow the use of regular expressions: SUMIF, COUNTIF, MATCH, 
SEARCH, LOOKUP, HLOOKUP, VLOOKUP, DCOUNT, DCOUNTA, DSUM, DPRODUCT, DMAX, 
DMIN, DAVERAGE, DSTDEV, DSTDEVP, DVAR, DVARP, DGET. 

Whether or not regular expressions are used is selected on the Tools > Options > LibreOffice 
Calc > Calculate dialog. It is enabled in a default installation.
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Figure 168: Default settings for Calculate page

For example =COUNTIF(A1:A6,"r.d") with Enable regular expressions in formulas selected will 
count cells in A1:A6 which contain red and ROD.

Additionally if Search criteria = and <> must apply to whole cells is not selected, then Fred, 
bride, and Ridge will also be counted. If that setting is selected, then it can be overcome by 
wrapping the expression thus: =COUNTIF(A1:A6,".*r.d.*").

Figure 169: Using the COUNTIF function

Regular expression searches within functions are always case insensitive, irrespective of the 
setting of the Case sensitive checkbox on the dialog in Figure 168—so red and ROD will always 
be matched in the above example. This case-insensitivity also applies to the regular expression 
structures ([:lower:]) and ([:upper:]), which match characters irrespective of case.

Regular expressions will not work in simple comparisons. For example: A1="r.d" will always return 
FALSE if A1 contains red, even if regular expressions are enabled. It will only return TRUE if A1 
contains r.d (r then a dot then d). If you wish to test using regular expressions, try the COUNTIF 
function: COUNTIF(A1,"r.d") will return 1 or 0, interpreted as TRUE or FALSE in formulas like 
=IF(COUNTIF(A1,"r.d"),"hooray","boo").
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Activating the Enable regular expressions in formulas option means all the above functions will 
require any regular expression special characters (such as parentheses) used in strings within 
formulas, to be preceded by a backslash, despite not being part of a regular expression. These 
backslashes will need to be removed if the setting is later deactivated.

Advanced functions

As is common with other spreadsheet programs, LibreOffice Calc can be enhanced by user-
defined functions or add-ins. Setting up user-defined functions can be done either by using the 
Basic IDE or by writing separate add-ins or extensions.

The basics of writing and running macros is covered in Chapter 12, Calc Macros. Macros can be 
linked to menus or toolbars for ease of operation or stored in template modules to make the 
functions available in other documents.

Calc Add-ins are specialized office extensions which can extend the functionality of LibreOffice with
new built-in Calc functions. Writing Add-ins requires knowledge of the C++ language, the 
LibreOffice SDK, and is for experienced programmers. A number of extensions for Calc have been 
written and these can be found on the extensions site at http://extensions.libreoffice.org/. Refer to 
Chapter 14, Setting up and Customizing Calc, for more details.
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Introduction

Many requests for spreadsheet support are the result of using complicated formulas and solutions 
to solve simple day-to-day problems. More efficient and effective solutions use the Pivot Table, a 
tool for combining, comparing, and analyzing large amounts of data easily. Using Pivot Tables, you 
can view different summaries of the source data, display the details of areas of interest, and create
reports, whether you are a beginner or an intermediate or advanced user.

Database preconditions
The first thing needed to work with the Pivot Table is a list of raw data, similar to a database table, 
consisting of rows (data sets) and columns (data fields). The field names are in the first row above 
the list.

The data source could be an external file or database. For the simplest case, where data is 
contained in a Calc spreadsheet, Calc offers sorting functions that do not require the Pivot Table.

For processing data in lists, the program needs to know where in the spreadsheet the table is. The 
table can be anywhere in the sheet, in any position. A spreadsheet can contains several unrelated 
tables.

Calc recognizes your lists automatically. It uses the following logic: Starting from the cell you have 
selected (which must be within the list), Calc checks the surrounding cells in all 4 directions (left, 
right, above, below). The border is recognized if the program discovers an empty row or column, or
if it hits the left or upper border of the spreadsheet.

This means that the described functions can only work correctly if there are no empty rows or 
columns in your list. Avoid empty lines (for example for formatting). You can format your list by 
using cell formats.

Rule No empty rows or empty columns are allowed within lists.

If you select more than one single cell before you start sorting, filtering, or calling the Pivot Table, 
then the automatic list recognition is switched off. Calc assumes that the list matches exactly the 
cells you have selected.

Rule For sorting, filtering, or using the Pivot Table, always select only one cell.

A relatively common source of errors is to inadvertently declare a list by mistake and then to sort 
that list. If you select multiple cells—for example, a whole column—then the sorting mixes up the 
data that should be together in one row.

In addition to these formal aspects, the logical structure of your table is also very important.

Rule
Calc lists must have the normal form; that is, they must have a simple linear 
structure.

When entering the data, do not add outlines, groups, or summaries. Here are some mistakes 
commonly made by inexperienced spreadsheet users:

1) You made several unnecessary sheets; for example, a sheet for each group of articles. In 
this case, analyses are then possible only within each group.

2) In a Sales list, instead of only one column for the amount, you made a column for the 
amounts for each employee. In this case, the system will have difficulty grouping data from 
the various columns together. Thus, an analysis with the Pivot Table would no longer be 

Chapter 8  Using Pivot Tables 226



possible. All data must be entered into the same column for the Pivot Table to be able to 
analyze it.

3) You entered the amounts in chronological order. At the end of each month, you made a 
sum total. In this case, sorting the list for different criteria is not possible because the Pivot 
Table will treat the sum totals the same as any other figure. Getting monthly results is one 
of the very fast and easy features of the Pivot Table.

Data sources
At this time, the possible data sources for the Pivot Table are a Calc spreadsheet or an external 
data source that is registered in LibreOffice.

Calc spreadsheet
Analyzing a list in a Calc spreadsheet is the simplest and most often used case. Lists might be 
updated regularly, or the data might be imported from a different application.

The behavior of Calc while inserting data from a different application depends on the format of the 
data. If the data is in a common spreadsheet format, it is copied directly into Calc. However, if the 
data is in plain text format, the Text Import dialog (Figure 171) appears after you select the file 
containing the data; see Chapter 1, Introducing Calc, for more more information about this dialog.

Figure 170: Text Import dialog

Calc is able to import data from a huge number of foreign data formats, such as other 
spreadsheets (Excel, Lotus 1, 2, 3); from databases (like dBase); and from simple text files, 
including CSV formats. However, in Calc, imported foreign data will not update automatically if 
changes are made to the source file.

In LibreOffice Calc, you can use up to 1,048,576 rows.
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Registered data source
A registered data source is a connection to data held in a database outside of LibreOffice. When 
using a registered data source, the data to be analyzed will not be saved in Calc; Calc always uses
the data from the original source. Calc is able to use many different data sources in addition to 
databases that are created and maintained with LibreOffice Base. For more information, see 
Chapter 10, Linking Calc Data.

Creating a Pivot Table
Create the Pivot Table using Data > Pivot Table > Create from the menu bar. If the list to be 
analyzed is in a spreadsheet table, select only one cell within this list. Calc recognizes and selects 
the list automatically for use with the Pivot Table (Figure 171).

Figure 171: Selecting the source data for the Pivot Table

The Pivot Table dialog

The function of the Pivot Table is managed in two places: first, in the Pivot Table dialog, and 
second, through manipulations of the result in the spreadsheet. This section describes the dialog in
detail.

Basic layout
In the Pivot Table dialog (Figure 172) are four white areas that show the layout of the result. Beside
these white areas are buttons with the names of the fields in your data source. To choose a layout, 
drag and drop the field buttons into the white areas.

The Data Fields area in the middle must contain at least one field. Advanced users can use more 
than one field here. For the Data Field an aggregate function is used. For example, if you move the
sales field into the Data Fields area, it appears there as Sum – sales.
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Figure 172: Pivot Table dialog

Row Fields and Column Fields indicate from which groups the result will be sorted. Often more 
than one field is used at a time to get partial sums for rows or columns. The order of the fields 
gives the order of the sums from overall to specific.

For example, if you drag region and employee into the Row Fields area, the sum will be divided 
into the employees. Within the employees will be the listing for the different regions (see Figure 
173).

Figure 173: Pivot Table field order for analysis, and resulting layout in pivot table

Fields that are placed into the Page Fields area appear in the result above as a drop down list. The
summary in your result takes only that part of your base data into account that you have selected. 
For example, if you use employee as a Page Field, you can filter the result shown for each 
employee.

To remove a field from the white layout area, just drag it past the border and drop it (the cursor will 
change to a crossed symbol), or select it and click the Remove button.

More options
To expand the Pivot Table dialog and show more options, click More.
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Figure 174: Expanded dialog of the Pivot Table

Selection from
Shows the sheet name and the range of cells used for the Pivot Table.

Results to
Results to defines where your result will be shown. Setting Results to as – undefined – and 
then entering a cell reference tells the Pivot Table where to show the results.1  An error dialog 
is displayed if you fail to enter a cell reference. Selecting Results to as - new sheet –  adds a 
new sheet to the spreadsheet file and places the results there. The new sheet is named using 
the format Pivot Table_sheetname_X; where X is the number of the table created, 1 for first, 2
for second and so on. For the source shown in Figure 3, the new sheet for the first table 
produced would be named Pivot Table_sheetname_1. Each new sheet is inserted next to the 
source sheet.

Ignore empty rows
If the source data is not in the recommended form, this option tells the Pivot Table to ignore 
empty rows.

Identify categories
With this option selected, if the source data has missing entries in a list and does not meet the 
recommended data structure (see Figure 175), the Pivot Table adds it to the listed category 
above it. If this option is not chosen, then the Pivot Table inserts (empty) (see Figure 177).

Figure 175: Example of data with missing entries in Column A

The option Identify categories ensures that in this example rows 3 and 4 are included for the 
product Apples and that row 6 is included for Pears (see Figure 176).

Figure 176: Pivot Table result with Identify categories selected

1 In this case the word - undefined – is misleading because the output position is in fact defined.
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Without category recognition, the Pivot Table shows an (empty) category (Figure 177).

Figure 177: Pivot Table result without Identify categories selected

Logically, the behavior with category recognition is better. A list showing missing entries is also 
less useful, because you cannot use functions such as sorting or filtering.

Total columns, Total rows
With these options you can decide if the Pivot Table shows an extra row with the sums of each 
column, or if it adds on the very right a column with the sums of each row. In some cases, an 
added total sum is meaningless, for example if your entries are accumulated or the result of 
comparisons.

Add filter
Use this option to add or hide the cell labeled Filter above the Pivot Table results. This cell is a 
convenient button for additional filtering options within the Pivot Table.

Enable drill to details
With this option enabled, if you double-click on a single data cell, including a cell produced from
Total columns or Total rows, in the Pivot Table result, a new sheet opens giving a detailed 
listing of the individual entry. If you double-click on a cell in either the Row Fields or the Column
Fields, then the Show Detail dialog open (see “Drilling (showing details)” on page 242). Taking 
Figure 173 as an example, if a pivot table uses more than one field (region and employee) and 
you double-click a left-most field (say, east), then this collapses the row, combining the totals 
for employees for that field and displaying the totals for east. If this function is disabled, the 
double-click will keep its usual edit function within a spreadsheet.

More settings for the fields: Field options
The options discussed in the previous section are valid for the Pivot Table in general. You can also 
change settings for every field that you have added to the Pivot Table layout. To do this,either 
select a field and click on the Options button in the Pivot Table dialog, or double-click on the 
appropriate field.

The options available for fields when put into the Data Fields differ from those when put into the 
Row, Column, and Page Fields of the Pivot Table.

Options for Data Fields
In the Options dialog of a Data Field, you can select the Sum function to accumulate the values 
from your data source. While you will often use the sum function, other functions (like standard 
distribution or a counting function) are also available. For example, the counting function can be 
useful for non-numerical data fields.

On the Data Field dialog, click More to see the Displayed value section.
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Figure 178: Expanded dialog for a Data Field

In the Displayed value section, you can choose other possibilities for analysis by using the 
aggregate function. Depending on the setting for Type, you may have to choose definitions for 
Base field and Base item.

Figure 179: Example choices for Base field and item

The table below lists the possible types of displayed value and associated base field and item, 
together with a note on usage.

Type Base field Base item Analysis

Normal — — Simple use of the chosen 
aggregate function (for example, 
sum).

Difference
from 

Selection of a field 
from the data source
of the Pivot Table 
(for example, 
employee).

Selection of an 
element from the 
selected base field 
(for example, Brigitte)

The result is the difference between
the result of the Base field and the 
Base item (for example, sales 
volume of the employees against 
the sales volume of Brigitte; see
Figure 180).
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Type Base field Base item Analysis

% of Selection of  a field 
from the data source
of the Pivot Table 
(for example, 
employee)

Selection of an 
element from the 
selected base field 
(for example, Brigitte)

The result is a percentage ratio of 
the value of the base field to the 
base item (for example, sales result
of the employee relative to the 
sales result of Brigitte; see Figure 
181).

% 
difference
from

Selection of a field 
from the data source
of the Pivot Table 
(for example, 
employee)

Selection of an 
element from the 
selected base field 
(for example. Brigitte)

From each result, its reference 
value is subtracted, and the 
difference is divided by the 
reference value (for example, sales 
of the employees as relative 
difference from the sales of Brigitte;
see Figure 182).

Running 
total in

Selection of a field 
from the data source
of the Pivot Table 
(for example, date)

— Each result is added to the sum of 
the results for preceding items in 
the base field, in the base field’s 
sort order, and the total sum is 
shown.

Results are always summed, even 
if a different summary function was 
used to get each result.

% of row — — The result is a percentage of the 
value of the whole row (for 
example, the row sum).

% of 
column

— — The result is a percentage of the 
total column value (for example, the
column sum).

% of total — — The result is a percentage of the 
overall result (for example, the total 
sum).

Index — — (Default result x total result) / (row 
total x column total)

Figure 180: Original Pivot Table (top) and a Difference from example (below)
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Figure 181: Example of a % of analysis

Figure 182: Example of % difference from analysis

Options for Row and Column Fields
In the Options dialog for the Row or Column Fields, you can choose to show subtotals for each 
category. Subtotals are deactivated by default. Subtotals are useful only if the values in one row or 
column field can be divided into subtotals for another (sub)field.

Some examples are shown in the next three figures.

Figure 183: No subdivision with only one row or column field

Figure 184: Division of the regions for employees (two row fields) without subtotals
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Figure 185: Division of the regions for employees with subtotals (by region)

To calculate subtotals that can also be used for the data fields (see above), select the Automatic 
option in the Subtotals section of the Data Field dialog.

You can choose the type of subtotal to use by selecting User-defined and then clicking the type of 
subtotal you want to calculate from the list. Functions are only available when User-defined is 
selected.

Figure 186: Preferences dialog of a row or column field
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Normally, the Pivot Table does not show a row or column for categories that have no entries in the 
underlying database. By choosing the Show items with no data option, you can force this.

For illustration purposes, the data was manipulated in such a way that the employee Brigitte has 
no sales values for the category golfing.

Figure 187: Default setting

Figure 188: Setting “Show Items with no data”

Options for Page Fields
The Options dialog for Page Fields is the same as for Row and Column fields, even though it 
appears to be useless to have the same settings as described for the Row and Column fields. With
the flexibility of the Pivot Table, you can switch the different fields between pages, columns, or 
rows. The fields keep the settings that you made for them. The Page Field has the same properties
as a Row or Column field. These settings only take effect when you use the field not as a Page 
Field but as Row or Column field.

Working with the results of the Pivot Table

As mentioned above, the Pivot Table dialog is very flexible. A Pivot Table can be totally restructured
with only a few mouse clicks. Some functions of the Pivot Table dialog can only be used with the 
Pivot Table.

Changing the layout
The layout of the Pivot Table can be changed quickly and easily by using drag-and-drop. With the 
Pivot Table open, fields can be dragged around from row, column, page and the Data Fields areas 
to any position you want to put them, and then dropped. Unused fields can also be added, and 
fields removed in error can be replaced by dragging and dropping them into the positions required.

Some manipulation can also be carried out in the pivot table view. Within the results table of the 
Pivot Table, move one of the page, column, or row fields to a different position. The cursor will 
change shape from its starting shape (horizontal or vertical block on the arrow head) to the 
opposite if moving to a different field, such as from row to column, and it is OK to drop.
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Figure 189: Drag a column field. Note 
the cursor shape

     
Figure 190: Drag a row field. Note the 
cursor shape

You can remove a column, row, or page field from the Pivot Table by clicking on it and dragging it 
out of the table. The cursor changes to that shown in Figure 191. A field removed in error cannot 
be recovered, and it is necessary to return to the Pivot Table to replace it.

Figure 191: Field dragged out 
of the Pivot Table

Grouping rows or columns
For many analyses or summaries, the categories have to be grouped. You can merge the results in
classes. You can only carry out grouping on an ungrouped Pivot Table.

You can access grouping by selecting Data > Group and Outline > Group from the menu bar, or 
by pressing F12 after selecting the correct cell area. The type of values that have to be grouped is 
what mainly determines how the grouping function works. You need to distinguish between scalar 
values, or other values, such as text, that you want grouped.

Note

Before you can group, you have to produce a Pivot Table with ungrouped data. The 
time needed for creating a Pivot Table depends mostly on the number of columns 
and rows and not on the size of the basic data. Through grouping you can produce 
the Pivot Table with a small number of rows and columns. The Pivot Table can 
contain a lot of categories, depending on your data source.

Grouping of categories with scalar values
For grouping scalar values, select a single cell in the row or column of the category to be grouped. 
Choose Data > Group and Outline > Group from the menu bar or press F12; you get the 
Grouping dialog shown in Figure 192.

You can define in which value range (start/end) the grouping should take place. The default setting 
is the whole range, from the smallest to the largest value. In the field Group by, you can enter the 
class size, also known as the interval size (in the example shown in Figures 193 and 194, groups 
of 10 km/h each).
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Figure 192: Grouping dialog with scalar categories

Figure 193: Pivot Table without grouping (frequency 
of the km/h values of a radar control)

Figure 194: Pivot Table with grouping
(classes of 10 km/h each)

Grouping without automatic creation of intervals
Categories containing text fields cannot create intervals. You can define for each field (for example,
Department) which values you want to put together in one group.

With more than one cell selected, choose Data > Group and Outline > Group from the menu bar, 
or press F12, to group those cells. See Figures 195 and 196.

For grouping of non-scalar categories, select in the result of the Pivot Table all the individual field 
values that you want to put in the one group.

Tip
You can select several non-contiguous cells in one step by pressing and holding the 
Control key while left-clicking with the mouse.

Given the input data shown in Figure 195, execute the Pivot Table with Department in the Row 
Field and Sum (Sick Days) in the Data Field. The output should look like that in Figure 196. With 
the mouse, select the Departments Accounting, Purchasing and Sales.
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Figure 195: Database with non-scalar categories 
(departments)

Figure 196: Pivot Table 
with non-scalar 
categories 

Choose the Data > Group and Outline > Group from the Menu bar or press F12. The output 
should now look like that in Figure 197. Repeat this for all groups that you want to create from the 
different categories (Select Assembly, Production and Warehouse and Group again. The output 
should look like Figure 198.

Figure 197: Summary of single categories in one 
group Figure 198: Grouping finished

You can change the default names for the groups and the newly created group field by editing the 
name in the input field (for example changing 'Group2' to 'Technical'). The Pivot Table will 
remember these settings, even if you change the layout later on. For the following pictures, the 
dialog was called again (right-click, Edit Layout) and by selecting the icon “Department 2”, then 
Options, and finally from the preferences menu  Automatic was selected. This generated the 
partial sum results shown in Figure 199. Double clicking Group 1 and Technical collapses the 
entries, as shown in Figure 200.

Figure 199: Renamed groups and partial results

 Figure 200: Reduced to the new 
groups 
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Note

A well-structured database makes manual sorting within the Pivot Table obsolete. In 
the example shown, you could add another column with the name Department, that 
has the correct entry for each person based on whether the employee’s department 
belongs to the group Office or Technical. The mapping for this (1:n relationship) can 
be done easily with the VLOOKUP function from Calc.

Sorting the result
The result of any Pivot Table is sorted (categories) in columns and rows in ascending order. You 
can change the sorting in three ways:

• Select sort order from drop-down menus on each column heading.

• Sort manually by using drag and drop.

• Sort automatically by choosing the options in the preferences dialog of the row or column 
field.

Select sort order from drop-down menus on each column heading
The simplest way to sort entries is to click the arrow on the right side of the heading and check the 
box(es) for the desired sort order. The custom sorting dialog is shown in Figure 202. Additional 
options exist to show all, show only the current item, or hide only the current item.

Once sorting has been carried out using the drop-down list, the color of the arrow changes and a 
small square of matching color is added to the bottom right of the arrow button.

Figure 201: Arrow color change and indicator square on button

Figure 202: Custom sorting
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Sort manually by using drag and drop
You can change the order within the categories by moving the cells with the category values in the 
result table of the Pivot Table. The cell will be inserted above the cell on which you drop it.

Be aware that in Calc, a cell must be selected. It is not enough that the cursor is in the cell. The 
background of a selected cell is marked with a different color. To select several cells, click in one 
cell with no extra key pressed, then press the Shift or Ctrl key while clicking in other cells. Another 
possibility is to keep the mouse button pressed on the cell you want to select, move the mouse to a
neighbor cell, and then move back to the original cell before you release the mouse button.

Sort automatically
To sort automatically, right-click within the Pivot Table and choose Edit Layout. This will open the 
Pivot Table (Figure 172). Within the Layout area of the Pivot Table, double-click the row or column 
field you want to sort. In the Data Field dialog which opens (Figure 186), click Options to display 
the Data Field Options dialog.

For Sort by, choose either Ascending or Descending. On the left side is a drop-down list where you
can choose the field this setting should apply to. With this method, you can specify that sorting 
does not happen according to the categories but according to the results of the data field.

Figure 203: Options for a row or column field
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Drilling (showing details)
Drill allows you to show the related detailed data for a single, compressed value in the Pivot Table 
result. To activate a drill, double-click on the cell or choose Data > Group and Outline > Show 
Details. There are two possibilities:

1) The active cell is a row or column field.

In this case, drill means an additional breakdown into the categories of another field.

For example, double-click on the cell with the value golfing. In this instance the values that 
are aggregated within golfing can be subdivided using another field.

Figure 204: Before the drill down for the category golfing

A dialog appears allowing you to select the field to use for further subdivision. In this 
example, employee.

Figure 205: Selecting the field for the subdivision

Figure 206: After the drill down

To hide the details again, double-click on the cell golfing or choose Data > Group and 
Outline > Hide Details.
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The Pivot Table remembers your selection (in our example the field employee) by adding 
and hiding the selected field, so that for the next drill down for a category in the field 
category the dialog does not appear. To remove the selection employee, open the Pivot 
Table dialog by right-clicking and choosing Edit Layout, then delete the unwanted 
selection in the row or column field.

2) The active cell is a value of the Data Field.

In this case, drill down results in a listing of all data entries of the data source that 
aggregates to this value.

In our example, if we were to double-click on the cell with the value $18,741 from Figure
204, we would now have a new list of all data sets that are included in this value. This list is
displayed in a new sheet.

Figure 207: New table sheet after the drill down for a value in a data field

Filtering
To limit the Pivot Table analysis to a subset of the information that is contained in the data basis, 
you can filter with the Pivot Table.

Note
An Autofilter or default filter used on the sheet has no effect on the Pivot Table 
analysis process. The Pivot Table always uses the complete list that was selected 
when it was started.

To do this, click Filter on the top left side above the results.

Figure 208: Filter field in the upper left area of the Pivot Table

In the Filter dialog, you can define up to 3 filter options that are used in the same way as Calc’s 
default filter.

Note
Even if they are not called a filter, page fields are a practical way to filter the results. 
The advantage is that the filtering criteria used are clearly visible.
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Figure 209: Dialog for defining the filter

Updating (refreshing) changed values
After you have created the Pivot Table, changes in the source data do not cause an automatic 
update in the resulting table. You must update (refresh) the Pivot Table manually after changing 
any of the underlying data values.

Changes in the source data could appear in two ways:

1) The content of existing data sets has been changed.

For example, you might have changed a sales value afterward. To update the Pivot Table, 
right-click in the result area and choose Refresh (or choose Data > Pivot Table > Refresh 
from the menu bar).

2) You have added or deleted data sets in the original list.

In this case the change means that the Pivot Table has to use a different area of the 
spreadsheet for its analysis. Fundamental changes to the data set collection means you 
must redo the Pivot Table from the beginning.

Cell formatting
The cells in the results area of the Pivot Table are automatically formatted in a simple format by 
Calc. You can change this formatting using all the tools in Calc, but note that if you make any 
change in the design of the Pivot Table or any updates, the formatting will return to the format 
applied automatically by Calc.

For the number format in the data field, Calc uses the number format that is used in the 
corresponding cell in the source list. In most cases, this is useful (for example, if the values are in 
the currency format, then the corresponding cell in the result area is also formatted as currency). 
However, if the result is a fraction or a percentage, the Pivot Table does not recognize that this 
might be a problem; such results must either be without a unit or be displayed as a percentage. 
Although you can correct the number format manually, the correction stays in effect only until the 
next update.

Using shortcuts
If you use the Pivot Table very often, you might find the frequent use of the menu paths (Data > 
Pivot Table > Create and Data > Group and Outline > Group) inconvenient.

For grouping, a shortcut is already defined: F12. For starting the Pivot Table, you can define your 
own keyboard shortcut. If you prefer to have toolbar icons instead of keyboard shortcuts, you can 
create a user-defined symbol and add it to either your own custom made toolbar or the Standard 
toolbar.

For an explanation how to create keyboard shortcuts or add icons to toolbars, see Chapter 14, 
Setting Up and Customizing Calc.
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Using Pivot Table results elsewhere

The problem
Normally, you create a reference to a value by entering the address of the cell that contains the 
value. For example, the formula =C6*2 creates a reference to cell C6 and returns the doubled 
value.

If this cell is located in the results area of the Pivot Table, it contains the result that was calculated 
by referencing specific categories of the row and column fields. In Figure 210, the cell C6 contains 
the sum of the sales values of the employee Hans in the category Sailing. The formula in the cell 
C12 uses this value.

Figure 210: Formula reference to a cell of the Pivot Table

If the underlying data or the layout of the Pivot Table changes, then you must take into account that
the sales value for Hans might appear in a different cell. Your formula still references the cell C6 
and therefore uses a wrong value. The correct value is in a different location. For example, in
Figure 211, the location is now C7.

Figure 211: The value that you really want to use can be found now in a 
different location.
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The solution: Function GETPIVOTDATA
Use the function GETPIVOTDATA to have a reference to a value inside the Pivot Table by using 
the specific identifying categories for this value. This function can be used with formulas in Calc if 
you want to reuse the results from the Pivot Table elsewhere in your spreadsheet.

Syntax
The syntax has two variations:

GETPIVOTDATA(target field, Pivot Table, [ Field name / Element, ... ])

GETPIVOTDATA(Pivot Table, specification)

First syntax variation
The target field specifies which data field of the Pivot Table is used within the function. If your 
Pivot Table has only one data field, this entry is ignored, but you must enter it anyway.

If your Pivot Table has more than one data field, then you have to enter the field name from the 
underlying data source (for example “sales”) or the field name of the data field itself (for example 
“sum – sales”).

The argument Pivot Table specifies the Pivot Table that you want to use. It is possible that your 
document contains more than one Pivot Table. Enter here a cell reference that is inside the area of 
your Pivot Table. It might be a good idea to always use the upper left corner cell of your Pivot 
Table, so you can be sure that the cell will always be within your Pivot Table, even if the layout 
changes.

Example: GETPIVOTDATA("sales",A1)

If you enter only the first two arguments, then the function returns the total result of the Pivot Table 
(“Sum – sales” entered as the field, will return a value of 408,765).

You can add more arguments as pairs with field name and item to retrieve specific partial sums. 
In the example in Figure 210, where we want to get the partial sum of Hans for sailing, the formula 
in cell C12 would look like this: 

=GETPIVOTDATA("sales",A1,"employee","Hans","category","sailing")

Figure 212: First syntax variation
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Second syntax variation
The argument Pivot Table has to be given in the same way as for the first syntax variation.

For the specifications, enter a list separated by spaces to specify the value you want from the 
Pivot Table. This list must contain the name of the data field, if there is more than one data field; 
otherwise it is not required. To select a specific partial result, add more entries in the form of 
Field name[item].

In the example in Figure 210, where we want to get the partial sum of Hans for Sailing, the formula 
in cell C12 would look like this: 

=GETPIVOTDATA(A1,"sales employee[Hans] category[sailing]")

Figure 213: Second syntax variation

When working with data sets containing date information, you must take care if you use the date 
information in the GETPIVOTDATA function. The function will only recognize the date entry if it is 
entered into the formula in exactly the same way that it appears in the data set from which the pivot
table is produced. In the example of Figure 214, an error is returned when the date format does not
match that of the data. Only with the correct format is the result returned.

Figure 214: Error produced if date information is not entered correctly

Caution By using GETPIVOTDATA function with the second syntax variation, not that 
which is used in the Function Wizard, the function can return a #REF error.
Bug 71234

Chapter 8  Using Pivot Tables 247

https://bugs.freedesktop.org/show_bug.cgi?id=71234




Chapter 9  
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Introduction

Once you are familiar with functions and formulas, the next step is to learn how to use Calc’s 
automated processes to perform useful analysis of your data quickly.

Calc includes several tools to help you manipulate the information in your spreadsheets, ranging 
from features for copying and reusing data, to creating subtotals automatically, to varying 
information to help you find the answers you need. These tools are divided between the Tools and 
Data menus.

If you are a newcomer to spreadsheets, these tools can be overwhelming at first. However, they 
become simpler if you remember that they all depend on input from either a cell or a range of cells 
that contain the data with which you are working.

You can always enter the cells or range manually, but in many cases it is easier to select the cells 
with the mouse. Click the Shrink/Maximize icon beside a field to temporarily reduce the size of the 
tool’s window, so you can see the spreadsheet underneath and select the cells required.

Sometimes, you may have to experiment to find out which data goes into which field, but then you 
can set a selection of options, many of which can be ignored in any given case. Just keep the 
basic purpose of each tool in mind, and you should have little trouble with Calc’s function tools.

You don’t need to learn them, especially if your spreadsheet use is simple, but as your 
manipulation of data becomes more sophisticated, they can save time in making calculations, 
especially as you start to deal with hypothetical situations. Just as importantly, they can allow you 
to preserve your work and to share it with other people—or yourself at a later session.

One function tool not mentioned here is Pivot Table, but it is a topic that is sufficiently complex that 
it requires a separate chapter: see Chapter 8 in this book.

Consolidating data

Data > Consolidate provides a way to combine data from two or more ranges of cells into a new 
range while running one of several functions (such as Sum or Average) on the data. During 
consolidation, the contents of cells from several sheets can be combined into one place. The effect
is that copies of the identified ranges are stacked with their top left corners at the specified result 
position, and the selected operation is used in each cell to calculate the result value.

1) Open the document containing the cell ranges to be consolidated.

2) Choose Data > Consolidate to open the Consolidate dialog. Figure 215 shows this dialog 
after making the changes described below.

3) The Source data range list contains any existing named ranges (created using Data > 
Define Range) so you can quickly select one to consolidate with other areas.

If the source range is not named, click in the field to the right of the drop-down list and 
either type a reference for the first source data range or use the mouse to select the range 
on the sheet. (You may need to move the Consolidate dialog or click on the Shrink icon to 
reach the required cells.)

4) Click Add. The selected range is added to the Consolidation ranges list.

5) Select additional ranges and click Add after each selection.

6) Specify where you want to display the result by selecting a target range from the Copy 
results to drop-down list.

If the target range is not named, click in the field next to Copy results to and enter the 
reference of the target range or select the range using the mouse or position the cursor in 
the top left cell of the target range. Copy results to takes only the first cell of the target 
range instead of the entire range as is the case for Source data range.
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Figure 215: Defining the data to be consolidated

7) Select a function from the Function list. This specifies how the values of the consolidation 
ranges will be calculated. The default setting is Sum, which adds the corresponding cell 
values of the Source data range and gives the result in the target range.

Most of the available functions are statistical (such as Average, Min, Max, Stdev), and the 
tool is most useful when you are working with the same data over and over.

8) At this point you can click More in the Consolidate dialog to access the following additional 
settings:

• In the Options section, select Link to source data to insert the formulas that generate
the results into the target range, rather than the actual results. If you link the data, any
values modified in the source range are automatically updated in the target range.

Caution The corresponding cell references in the target range are inserted in consecutive 
rows, which are automatically ordered and then hidden from view. Only the final 
result, based on the selected function, is displayed.

• In the Consolidate by section, select either Row labels or Column labels if the cells of 
the source data range are not to be consolidated corresponding to the identical 
position of the cell in the range, but instead according to a matching row label or 
column label. To consolidate by row labels or column labels, the label must be 
contained in the selected source ranges. The text in the labels must be identical, so 
that rows or columns can be accurately matched. If the row or column label of one 
source data range does not match any that exist in other source data ranges, it is 
added to the target range as a new row or column.

9) Click OK to consolidate the ranges.

Tip
If you are continually working with the same range, then you probably want to use 
Data > Define Range to give it a name.

The consolidation ranges and target range are saved as part of the document. If you later open a 
document in which consolidation has been defined, this data is still available.
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Creating subtotals

Subtotals are implemented in two ways:

• The SUBTOTAL function 

• Data > Subtotals from the menu bar.

Using the SUBTOTAL function
SUBTOTAL is listed under the Mathematical category when you use the Function Wizard (Insert > 
Function or press Ctrl+F2). This function is a relatively limited method for generating a subtotal. To
obtain a subtotal for our sales information for the employee Brigitte, we must first implement an 
AutoFilter on the data (Data > Filter > AutoFilter). This displays the selection arrows to the right of
each column header; select Brigitte in the Employee field as shown in Figure 216.

Figure 216: AutoFilter applied and Brigitte selected in the Employee column

1) Select the location for the subtotal to be displayed by clicking in the chosen cell.

2) Select Insert > Function from the Menu bar, or click the Function Wizard button on the 
Function Bar, or press Ctrl+F2 to open the Function Wizard.

3) Select SUBTOTAL from the function list in the Function Wizard dialog and click Next>> at 
the bottom of the dialog.

4) Enter the required information into the two input boxes as shown in Figure 217. The range 
is selected from the filtered data, and the function is selected from the list of available 
possible functions as shown in the Help file extract of Figure 218. In our example we select 
the sales figures (column B) and we require the sum total (function index 9).

5) Click OK to return the summed values of Brigitte’s sales (Figure 219).
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Figure 217: Enter the information into the two input boxes

Figure 218: Function indexes for available functions

Figure 219: SUBTOTAL result for Brigitte's sales

Chapter 9  Data Analysis 253



You will appreciate that this is a tedious and time consuming exercise for a sales report if you want 
to subtotal for more than a couple of categories.

Using Data > Subtotals
A more comprehensive solution is to create subtotals using Data > Subtotals from the Menu bar, 
which opens the Subtotals dialog. Subtotal creates totals for data arranged in an array—that is, a 
group of cells with labels for columns. Using the Subtotals dialog, you can select up to three 
arrays, then choose a statistical function to apply to them. When you click OK, Calc adds subtotal 
and grand total rows to the selected arrays, using the Result and Result2 cell styles to differentiate 
those entries. By default, matching items throughout your array will be gathered together as a 
single group above a subtotal.

To insert subtotal values into a sheet:

1) Ensure that the columns have labels (we will use our sales data example again).

2) Select, or click in a single cell in the range of cells that you want to calculate subtotals for, 
and then choose Data > Subtotals.

3) In the Subtotals dialog (Figure 220), in the Group by list, select the column by which the 
subtotals need to be grouped. A subtotal will be calculated for each distinct value in this 
column.

4) In the Calculate subtotals for box, select the columns containing the values that you want
to create subtotals for. If the contents of the selected columns change later, the subtotals 
are automatically recalculated.

5) In the Use function box, select the function that you want to use to calculate the subtotals.

6) You can create a further two Group by subtotals using the 2nd Group and 3rd Group tabs 
and repeating steps 3 to 5.

7) Click OK.

Figure 220: Setting up subtotals

A partial view of the results using our example data is shown in Figure 221. Subtotals for Sales by 
Employee and Category were used

Calc inserts, to the left of the row numbering labels, an outline area that graphically represents the 
structure of the subtotals. Number 1 represents the highest level of grouping, the Grand Total. 
Numbers 2 to 4 show reducing grouping levels, with number 4 showing individual entries. The 
number of levels depends on the number of groupings in the subtotals.
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Figure 221: Subtotals are calculated for each employee (partial 
view) using the 1st Group and 2nd Group

Clicking on a number at the top of the column shrinks the structure of that element of the subtotal. 
For column 1, this changes the minus button in the column to one with a plus symbol, indicating 
that it is expandable. For column 2 and others with content, each element of the column shrinks, 
and each button changes to a plus. For our example subtotal displayed in Figure 221, the structure
which is displayed is Column 1 is the Grand Total, column 2 is the Employee subtotal, and column 
3 is the Category subtotal.

For column 2, and for others if you have more groups, you can also click each individual minus 
button to shrink only that subtotal. If you click on the numbered button at the top, you must then 
click on the resultant plus buttons to expand the structure again (see Figure 222). Shrinking any 
element, temporarily hides any element contained in a column to its right. In Figure 222 Individual 
entries are hidden by shrinking the Category subtotals for Brigitte.

To turn off outlines, select Data > Group and Outline > Remove from the Menu bar. Select 
AutoOutline to reinstate the outlines.

Figure 222: Click the plus buttons to expand the elements again
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Further choices are available in the Options page of the Subtotals dialog.

In the Groups section:

• Selecting Page break between groups inserts a new page after each group of subtotaled 
data.

• Selecting Case sensitive recalculates subtotals when you change the case of a data label.

• Selecting the Pre-sort area according to groups option sorts the area that you selected in 
the Group by box of the Group tabs according to the columns that you selected.

In the Sort section:

• Selecting Ascending or Descending, sorts beginning with the lowest or the highest value. 
You can define the sort rules on Data > Sort > Options.

• Selecting Include formats option gives consideration to the formatting attributes when 
sorting.

• Selecting Custom sort order sorts according to one of the predefined custom sorts defined 
in Tools > Options > LibreOffice Calc > Sort Lists.

Figure 223: Choosing options for subtotals

Using “what if” scenarios

The Scenario is a tool to test “what-if” questions. Each scenario is named, and can be edited and 
formatted separately. When you print the spreadsheet, only the contents of the currently active 
scenario are printed.

A scenario is essentially a saved set of cell values for your calculations. You can easily switch 
between these sets using the Navigator or  a drop-down list which can be shown beside the 
changing cells. For example, if you wanted to calculate the effect of different interest rates on an 
investment, you could add a scenario for each interest rate, and quickly view the results. Formulas 
that rely on the values changed by your scenario are updated when the scenario is opened. If all 
your sources of income used scenarios, you could efficiently build a complex model of your 
possible income.
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Creating scenarios
Tools > Scenarios opens a dialog with options for creating a scenario.

To create a new scenario:

1) Select the cells that contain the values that will change between scenarios. To select 
multiple ranges, hold down the Ctrl key as you click. You must select at least two cells.

2) Choose Tools > Scenarios.

3) On the Create Scenario dialog (Figure 224), enter a name for the new scenario. It’s best to 
use a name that clearly identifies the scenario, not the default name as shown in the 
illustration. This name is displayed in the Navigator and in the title bar of the border around 
the scenario on the sheet itself.

Figure 224: Creating a scenario

4) Optionally add some information to the Comment box. The example shows the default 
comment. This information is displayed in the Navigator when you click the Scenarios icon 
and select the desired scenario.

5) Optionally select or deselect the options in the Settings section.  See below for more 
information about these options.

6) Click OK to close the dialog. The new scenario is automatically activated.

You can create several scenarios for any given range of cells.

Settings
The lower portion of the Create Scenario dialog contains several options. The default settings (as 
shown in Figure 224) are likely to be suitable in most situations.

Display border
Places a border around the range of cells that your scenario alters. To choose the color of the 
border, use the field to the right of this option. The border has a title bar displaying the name of 
the active scenario. Click the arrow button to the right of the scenario name to open a drop-
down list of all the scenarios that have been defined for the cells within the border. You can 
choose any of the scenarios from this list at any time.
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Copy back
Copies any changes you make to the values of scenario cells back into the active scenario. If 
you do not select this option, the saved scenario values are never changed when you make 
changes. The actual behavior of the Copy back setting depends on the cell protection, the 
sheet protection, and the Prevent changes setting (see Table 8 on page 258).

Caution

If you are viewing a scenario which has Copy back enabled and  then create a new 
scenario by changing the values and selecting Tools > Scenarios, you also 
inadvertently overwrite the values in the first scenario.

This is easily avoided if you leave the current values alone, create a new scenario 
with Copy back enabled, and then change the values only when you are viewing the 
new scenario.

Copy entire sheet
Adds to your document a sheet that permanently displays the new scenario in full. This is in 
addition to creating the scenario and making it selectable on the original sheet as normal.

Prevent changes
Prevents changes to a scenario enabled as a Copy back, when the sheet is protected but the 
cells are not. Also prevents changes to the settings described in this section while the sheet is 
protected. A fuller explanation of the effect this option has in different situations is given below.

Changing scenarios
Scenarios have two aspects that can be altered independently:

• Scenario properties (the settings described above)

• Scenario cell values (the entries within the scenario border)

The extent to which either of these aspects can be changed is dependent upon both the existing 
properties of the scenario and the current protection state of the sheet and cells.

Changing scenario properties
If the sheet is protected (Tools > Protect Document > Sheet), and Prevent changes is selected 
then scenario properties cannot be changed.

If the sheet is protected, and Prevent changes is not selected, then all scenario properties can be 
changed except Prevent changes and Copy entire sheet, which are disabled.

If the sheet is not protected, then Prevent changes does not have any effect, and all scenario 
properties can be changed.

Changing scenario cell values
Table 8 summarizes the interaction of various settings in preventing or allowing changes in 
scenario cell values.

Table 8: Prevent changes behavior for scenario cell value changes

Settings Change allowed

Sheet protection ON

Scenario cell protection OFF

Prevent changes ON

Copy back ON

Scenario cell values cannot be changed.
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Settings Change allowed

Sheet protection ON

Scenario cell protection OFF

Prevent changes OFF

Copy back ON

Scenario cell values can be changed, and the 
scenario is updated.

Sheet protection ON

Scenario cell protection OFF

Prevent changes ON or OFF

Copy back OFF

Scenario cell values can be changed, but the 
scenario is not updated due to the Copy back 
setting.

Sheet protection ON

Scenario cell protection ON

Prevent changes ANY SETTING

Copy back ANY SETTING

Scenario cell values cannot be changed.

Sheet protection OFF

Scenario cell protection ANY SETTING

Prevent changes ANY SETTING

Copy back ANY SETTING

Scenario cell values can be changed and the 
scenario is updated or not, depending on the Copy 
back setting.

Working with scenarios using the Navigator
After scenarios are added to a spreadsheet, you can jump to a particular scenario by selecting it 
from the list in the Navigator.

Click the Scenarios icon in the Navigator (see Figure 225). The defined scenarios are listed, along
with the comments that were entered when the scenarios were created.

Figure 225: Scenarios in the Navigator

To apply a scenario to the current sheet, double-click the scenario name in the Navigator.

To delete a scenario, right-click the name in the Navigator and choose Delete.

To edit a scenario, including its name and comments, right-click the name in the Navigator and 
choose Properties. The Edit Properties dialog is the same as the Create Scenario dialog 
(Figure 224).
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Tracking values in scenarios
To learn which values in the scenario affect other values, choose Tools > Detective > 
Trace Dependents. Arrows point to the cells that are directly dependent on the current cell.

Using other “what if” tools

Like scenarios, Data > Multiple Operations is a planning tool for “what if” questions. Unlike a 
scenario, the Multiple Operations tool does not present the alternate versions in the same cells or 
with a drop-down list. Instead, the Multiple Operations tool creates a formula array: a separate set 
of cells showing the results of applying the formula to a list of alternative values for the variables 
used by the formula. Although this tool is not listed among the functions, it is really a function that 
acts on other functions, allowing you to calculate different results without having to enter and run 
them separately.

To use the Multiple Operations tool, you need two arrays of cells. The first array contains the 
original or default values and the formulas applied to them. The formulas must be in a range.

The second array is the formula array. It is created by entering a list of alternative values for one or
two of the original values.

Once the alternative values are created, you use the Multiple Operations tool to specify which 
formulas you are using, as well as the original values used by the formulas. The second array is 
then filled with the results of using each alternative value in place of the original values.

The Multiple Operations tool can use any number of formulas, but only one or two variables. With 
one variable, the formula array of alternative values for the variables will be in a single column or 
row. With two variables, you should outline a table of cells such that the alternative values for one 
variable are arranged as column headings, and the alternative values for the other variable act as 
row headings.

Setting up multiple operations can be confusing at first. For example, when using two variables, 
you need to select them carefully, so that they form a meaningful table. Not every pair of variables 
is useful to add to the same formula array. Yet, even when working with a single variable, a new 
user can easily make mistakes or forget the relationships between cells in the original array and 
cells in the formula array. In these situations, Tools > Detective can help to clarify the relations.

You can also make formula arrays easier to work with if you apply some simple design logic. Place 
the original and the formula array close together on the same sheet, and use labels for the rows 
and columns in both. These small exercises in organizational design make working with the 
formula array much less painful, particularly when you are correcting mistakes or adjusting results.

Note
If you export a spreadsheet containing multiple operations to Microsoft Excel, the 
location of the cells containing the formula must be fully defined relative to the data 
range.

Multiple operations in columns or rows
In your spreadsheet, enter a formula to calculate a result from values that are stored in other cells. 
Then, set up a cell range containing a list of alternatives for one of the values used in the formula. 
The Multiple Operations command produces a list of results adjacent to your alternative values 
by running the formula against each of these alternatives.
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Note
Before you choose the Data > Multiple Operations option, be sure to select not only
your list of alternative values but also the adjacent cells into which the results should 
be placed.

In the Formulas field of the Multiple Operations dialog, enter the cell reference to the formula that 
you wish to use.

The arrangement of your alternative values dictates how you should complete the rest of the 
dialog. If you have listed them in a single column, you should complete the field for Column input 
cell. If they are along a single row, complete the Row input cell field. You may also use both in 
more advanced cases. Both single and double-variable versions are explained below.

The above can be explained best by examples. Cell references correspond to those in the 
following figures.

Let’s say you produce toys that you sell for $10 each (cell B1). Each toy costs $2 to make (cell B2),
in addition to which you have fixed costs of $10,000 per year (cell B3). How much profit will you 
make in a year if you sell a particular number of toys?

Calculating with one formula and one variable
1) To calculate the profit, first enter any number as the quantity (items sold); in this example, 

2000 (cell B4). The profit is found from the formula Profit=Quantity * (Selling price – Direct 
costs) – Fixed costs. Enter this formula in B5: =B4*(B1-B2)-B3.

2) In column D enter a variety of alternative annual sales figures, one below the other; for 
example, 500 to 5000, in steps of 500.

3) Select the range D2:E11, and thus the values in column D and the empty cells (which will 
receive the results of the calculations) alongside in column E.

4) Choose Data > Multiple Operations.

5) With the cursor in the Formulas field of the Multiple operations dialog, click cell B5.

6) Set the cursor in the Column input cell field and click cell B4. This means that B4, the 
quantity, is the variable in the formula, which is to be replaced by the column of alternative 
values. Figure 226 shows the worksheet and the Multiple operations dialog.

7) Click OK. The profits for the different quantities are now shown in column E. See Figure 
227.

Tip

You may find it easier to mark the required reference in the sheet if you click the 
Shrink icon to reduce the Multiple operations dialog to the size of the input field. The 
icon then changes to the Maximize icon; click it to restore the dialog to its original 
size.
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Figure 226: Sheet and Multiple operations dialog showing input

Figure 227: Sheet showing results of multiple operations calculations

Calculating with several formulas simultaneously
1) In the sheet from the previous example, delete the contents of column E.

2) Enter the following formula in C5: =B5/B4. You are now calculating the annual profit per 
item sold.

3) Select the range D2:F11, thus three columns.

4) Choose Data > Multiple Operations.
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5) With the cursor in the Formulas field of the Multiple operations dialog, select cells B5 and 
C5.

6) Set the cursor in the Column input cell field and click cell B4.  Figure 228 shows the 
worksheet and the Multiple operations dialog.

Figure 228: Sheet and dialog showing input

7) Click OK. Now the profits are listed in column E and the annual profit per item in column F.

Figure 229: Results of multiple operations calculations

Multiple operations across rows and columns
You can carry out multiple operations simultaneously for both columns and rows in so-called cross-
tables. The formula must use at least two variables, the alternative values for which should be 
arranged so that one set is along a single row and the other set appears in a single column. These 
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two sets of alternative values will form column and row headings for the results table produced by 
the Multiple Operations procedure.

Select the range defined by both data ranges (thus including all of the blank cells that are to 
contain the results) and choose Data > Multiple operations. Enter the cell reference to the 
formula in the Formulas field. The Row input cell and the Column input cell fields are used to enter 
the reference to the corresponding cells of the formula.

Caution Beware of entering the cell reference of a variable into the wrong field. The Row input
cell field should contain not the cell reference of the variable which changes down the
rows of your results table, but that of the variable whose alternative values have been
entered along a single row.

Calculating with two variables
You now want to vary not just the quantity produced annually, but also the selling price, and you 
are interested in the profit in each case.

Expand the table shown in Figure 228. D2 thru D11 already contain the numbers 500, 1000 and so
on, up to 5000. In E1 through H1 enter the numbers 8, 10, 15 and 20.

1) Select the range D1:H11.

2) Choose Data > Multiple Operations.

Figure 230: Sheet and dialog showing input

3) With the cursor in the Formulas field of the Multiple operations dialog, click cell B5 (profit).

4) Set the cursor in the Row input cell field and click cell B1. This means that B1, the selling 
price, is the horizontally entered variable (with the values 8, 10, 15 and 20).

5) Set the cursor in the Column input cell field and click cell B4. This means that B4, the 
quantity, is the vertically entered variable.

6) Click OK. The profits for the different selling prices are now shown in the range E2:H11 
(See Figure 231).
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Figure 231: Results of multiple operations calculations

Working backwards using Goal Seek

Usually, you create a formula to calculate a result based upon existing values. By contrast, using 
Tools > Goal Seek you can discover what values will produce the result that you want.

To take a simple example, imagine that the Chief Financial Officer of a company is developing 
sales projections for each quarter of the forthcoming year. She knows what the company’s total 
income must be for the year to satisfy stockholders. She also has a good idea of the company’s 
income in the first three quarters, because of the contracts that are already signed. For the fourth 
quarter, however, no definite income is available. So how much must the company earn in Q4 to 
reach its goal? The CFO can enter the projected earnings for each of the other three quarters 
along with a formula that totals all four quarters. Then she runs a goal seek on the empty cell for 
Q4 sales, and receives her answer.

Other uses of goal seek may be more complicated, but the method remains the same. Only one 
argument can be altered in a single goal seek.

Goal Seek example
To calculate annual interest (I), create a table with the values for the capital (C), number of years 
(n), and interest rate (i). The formula is I = C*n*i.

Let us assume that the interest rate i of 7.5% and the number of years n (1) will remain constant. 
However, you want to know how much the investment capital C would have to be modified in order 
to attain a particular return I. For this example, calculate how much capital C would be required if 
you want an annual return of $15,000.

Enter each of the values mentioned above into adjacent cells (for Capital, C, an arbitrary value like 
$100,000 or it can be left blank; for number of years, n, 1; for interest rate, i, 7.5%). Enter the 
formula to calculate the interest, I, in another cell. Instead of C, n, and i, use the reference to the 
cell with the corresponding value. In our example (Figure 232), this would be =B1*B2*B3.

1) Place the cursor in the formula cell (B4), and choose Tools > Goal Seek.

2) In the Goal Seek dialog, the correct cell is already entered in the Formula cell field.

3) Place the cursor in the Variable cell field. In the sheet, click in the cell that contains the 
value to be changed, in this example it is B1.

4) Enter the desired result of the formula in the Target value field. In this example, the value is
15000. Figure 232 shows the cells and fields.
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Figure 232: Example setup for goal seek

5) Click OK. A dialog appears informing you that the Goal Seek was successful. Click Yes to 
enter the goal value into the variable cell. The result is shown below indicating a capital 
requirement of $200,000 is needed to achieve $15,000 annual return.

Figure 233: Result of goal seek operation

Using the Solver

Tools > Solver amounts to a more elaborate form of Goal Seek. The difference is that the Solver 
deals with equations with multiple unknown variables. It is specifically designed to minimize or 
maximize the result according to a set of rules that you define.

Each of these rules defines whether an argument in the formula should be greater than, less than, 
or equal to the figure you enter. If you want the argument to remain unchanged, you must enter a 
rule that specifically states that the cell should be equal to its current entry. For arguments that you 
would like to change, you need to add two rules to define a range of possible values: the limiting 
conditions. For example, you can set the constraint that one of the variables or cells must not be 
bigger than another variable, or not bigger than a given value. You can also define the constraint 
that one or more variables must be integers (values without decimals), or binary values (where 
only 0 and 1 are allowed).

Once you have finished setting up the rules, click the Solve button to begin the automatic process 
of adjusting values and calculating results. Depending on the complexity of the task, this may take 
some time.
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Solver example
Let’s say you have $10,000 that you want to invest in two mutual funds for one year. Fund X is a 
low risk fund with 8% interest rate and Fund Y is a higher risk fund with 12% interest rate. How 
much money should be invested in each fund to earn a total interest of $1000?

To find the answer using Solver:

1) Enter labels and data:

• Row labels: Fund X, Fund Y, and total, in cells A2 thru A4.

• Column labels: interest earned, amount invested, interest rate, and 
time period, in cells B1 thru E1.

• Interest rates: 8 and 12, in cells D2 and D3.

• Time period: 1, in cells E2 and E3.

• Total amount invested: 10000, in cell C4.

• Enter an arbitrary value (0 or leave blank) in cell C2 as amount invested in Fund X.

2) Enter formulas:

• In cell C3, enter the formula C4–C2 (total amount – amount invested in Fund X) as the
amount invested in Fund Y. 

• In cells B2 and B3, enter the formula for calculating the interest earned (see Figure 
234).

• In cell B4, enter the formula B2+B3 as the total interest earned.

Figure 234: Example setup for Solver

3) Choose Tools > Solver. The Solver dialog (Figure 235) opens.

4) Click in the Target cell field. In the sheet, click in the cell that contains the target value. In 
this example it is cell B4 containing total interest value.

5) Select Value of and enter 1000 in the field next to it. In this example, the target cell value is
1000 because your target is a total interest earned of $1000. Select Maximum or Minimum 
if the target cell value needs to be one of those extremes.

6) Click in the By changing cells field and click on cell C2 in the sheet. In this example, you 
need to find the amount invested in Fund X (cell C2).

7) Enter limiting conditions for the variables by selecting the Cell reference, Operator and 
Value fields. In this example, the amount invested in Fund X (cell C2) should not be greater
than the total amount available (cell C4) and should not be less than 0.

8) Click OK. A dialog appears informing you that the Solving successfully finished. Click Keep
Result to enter the result in the cell with the variable value. The result is shown in Figure 
236.
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Figure 235: The Solver dialog

Figure 236: Result of Solver operation
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Chapter 10  
Linking Calc Data
Sharing data in and out of Calc



Why use multiple sheets?

Chapter 1 introduced the concept of multiple sheets (also called worksheets) in a spreadsheet. 
Multiple sheets help keep information organized; once you link those sheets together, you unleash 
the full power of Calc. Consider this case.

John is having trouble keeping track of his personal finances. He has several bank 
accounts and the information is scattered and disorganized. He can’t get a good grasp 
on his finances until he can see everything at once. 

To resolve this, John decided to track his finances in LibreOffice Calc. John knows Calc
can do simple mathematical computations to help him keep a running tab of his 
accounts, and he wants to set up a summary sheet so that he can see all of his account
balances at once.

This can be accomplished easily.

Note
For users with experience using Microsoft Excel: what Excel calls a workbook, Calc 
calls a spreadsheet (the whole document). Both Excel and Calc use the terms sheet 
and worksheet.

Setting up multiple sheets

Chapter 1 gives a detailed explanation of how to set up multiple sheets in a spreadsheet. Here is a 
quick review.

Identifying sheets
When you open a new spreadsheet it has, by default, one sheet named Sheet1, unless you have 
specified a different number of sheets or a different Prefix name for worksheets in Tools > Options
> LibreOffice Calc > Defaults.

Worksheets in Calc are managed using tabs at the bottom of the spreadsheet.

Inserting new sheets
There are several ways to insert a new sheet. The fastest method is to click on the Add Sheet 

button . This inserts one new sheet at that point, without opening the Insert Sheet dialog.

Use one of these other methods to insert more than one sheet, to rename the sheet at the same 
time, or to insert the sheet somewhere else in the sequence. The first step for these methods is to 
select the sheet that the new sheet will be inserted next to. Then do any one of the following:

• Select Insert > Sheet from the menu bar.
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• Right-click on the tab and select Insert Sheet.

• Click in an empty space at the end of the line of sheet tabs.

Figure 237: Creating a new sheet

Each method opens the Insert Sheet dialog. Here you can choose to put the new sheet before or 
after the selected sheet, how many sheets to insert, and what to name a single sheet. (For the 
From file option, see the next section.)

Figure 238. Insert Sheet dialog

We need six sheets, one for each of the five accounts and one as a summary sheet, so we will add
three more. We also want to name each of these sheets for the account they represent: Summary, 
Checking Account, Savings Account, Credit Card 1, Credit Card 2, and Car Loan.

We have two choices: insert three new sheets and rename all six sheets afterwards; or rename the
existing sheets, then insert the three new sheets one at a time, renaming each new sheet during 
the insert step.

To insert sheets and rename afterwards:

1) In the Insert Sheet dialog, choose the position for the new sheets (in this example, we use 
After current sheet).

2) Choose New sheet and 3 as the No. of sheets. (Three sheets are already provided by 
default.) Because you are inserting more than one sheet, the Name box is not available.

3) Click OK to insert the sheets.

4) For the next steps, go to “Renaming sheets” below.
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To insert sheets and name them at the same time:

1) Rename the existing sheets Summary, Checking Account, and Savings Account, as 
described in “Renaming sheets” below.

2) In the Insert Sheet dialog, choose the position for the first new sheet.

3) Choose New sheet and 1 as the No. of sheets. The Name box is now available.

4) In the Name box, type a name for this new sheet, for example Credit Card 1.

5) Click OK to insert the sheet.

6) Repeat steps 1–4 for each new sheet, giving them the names Credit Card 2 and Car Loan.

Inserting sheets from a different spreadsheet
On the Insert Sheet dialog, you can also add a sheet from a different spreadsheet file (for example,
another Calc or Excel spreadsheet), by choosing the From file option. Click Browse and select 
the file; a list of the available sheets appears in the box. Select the sheet to import. If, after you 
select the file, no sheets appear, you probably selected an invalid file type (not a spreadsheet, for 
example).

Tip
For a shortcut to inserting a sheet from another file, choose Insert > Sheet from file 
from the menu bar. The Insert Sheet dialog opens with the From file option 
preselected, and then the Insert dialog opens on top of it.

If you prefer, select the Link option to insert the external sheet as a link instead as a copy. This is 
one of several ways to include “live” data from another spreadsheet. (See also “Linking to external 
data” on page 279.) The links can be updated manually to show the current contents of the 
external file; or, depending on the options you have selected in Tools > Options > LibreOffice 
Calc > General > Updating, whenever the file is opened.

Renaming sheets
Sheets can be renamed at any time. To give a sheet a more meaningful name:

• Enter the name in the name box when you create the sheet, or

• Double click on the sheet tab, or

• Right-click on a sheet tab, select Rename Sheet from the context menu and replace the 
existing name.

Note
If you want to save the spreadsheet to Microsoft Excel format, the following 
characters are not allowed in sheet names: \ / ? * [ ] : and ' as the first or last 
character of the name.

Your sheet tab area should now look like this.

Figure 239: Six renamed sheets

Now we will set up the account ledgers. This is just a simple summary that includes the previous 
balance plus the amount of the current transaction. For withdrawals, we enter the current 
transaction as a negative number so the balance gets smaller. A basic ledger is shown in Figure 
240.
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This ledger is set up in the sheet named Checking Account. The total balance is added up in cell 
F3. You can see the equation for it in the formula bar. It is the summary of the opening balance, cell
C3, and all of the subsequent transactions.

Figure 240: Checking ledger

Referencing other sheets

On the Summary sheet we display the balance from each of the other sheets. If you copy the 
example in Figure 240 onto each account, the current balances will be in cell F3 of each sheet.

There are two ways to reference cells in other sheets: by entering the formula directly using the 
keyboard or by using the mouse. We will look at the mouse method first.

Creating the reference with the mouse
On the Summary sheet, set up a place for all five account balances, so we know where to put the 
cell reference. Figure 241 shows a summary sheet with a blank Balance column. We want to place
the reference for the checking account balance in cell B3.

Figure 241: Blank summary

To make the cell reference in cell B3, select the cell and follow these steps:

1) Click on the = icon next to the input line. The icons change and an equals sign appears in 
the input line as in Figure 242.
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Figure 242: Equal sign in input line

2) Now, click on the sheet tab for the sheet containing the cell to be referenced. In this case, 
that is the Checking Account sheet as shown in Figure 243.

Figure 243: Click on the checking account tab

3) Click on cell F3 (where the balance is) in the Checking Account sheet. The phrase 
'Checking Account'.F3 should appear in the input line as in Figure 244 and the 
selected cell is bordered in red.

Figure 244: Cell reference selected

4) Click the green checkmark in the input line, or press the keyboard Enter key to finish.

5) The Summary sheet should now look like Figure 245.

Figure 245: Finished checking account reference
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Creating the reference with the keyboard
From Figure 245, you can deduce how the cell reference is constructed. The reference has two 
parts: the sheet name (‘Checking Account’) and the cell reference (F3). Notice that they are 
separated by a period.

Note
The sheet name is in single quotes because it contains a space, and the mandatory 
period (.) always falls outside any quotes.

So, you can fill in the Savings Account cell reference by just typing it in. Assuming that the balance 
is in the same cell (F3) in the Savings Account sheet, the cell reference should be 
='Savings Account'.F3 (see Figure 246).

Figure 246: Savings account reference

Referencing other documents

John decides to keep his family account information in a different spreadsheet file from his own 
summary. Fortunately Calc can link different files together. The process is the same as described 
for different sheets in a single spreadsheet, but we add one more step to indicate which file the 
sheet is in.

Creating the reference with the mouse
To create the reference with the mouse, both spreadsheets need to be open. Select the cell in 
which the formula is going to be entered.

1) Click the = icon next to the input line.

2) Switch to the other spreadsheet (the process to do this will vary depending on which 
operating system you are using).

3) Select the sheet (Savings Account) and then the reference cell (F3). See Figure 247. The 
keyboard Enter key can be pressed at this point, or continue with steps 4 and 5.

4) Switch back to the original spreadsheet.

5) Click on the green check mark on the input line.

Your spreadsheet should now resemble Figure 248.
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Figure 247: Selecting the savings account reference cell

Figure 248: Linked files

You will get a good feel for the format of the reference if you look closely at the input line. Based on
this line you can create the reference using the keyboard.

Creating the reference with the keyboard
Typing the reference is simple once you know the format the reference takes. The reference has 
three parts to it:

• Path and file name

• Sheet name

• Cell

From Figure 248, you can see the the general format for the reference is 

='file:///Path & File Name'#$SheetName.CellName

Note
The reference for a file has three forward slashes /// and the reference for a 
hyperlink has two forward slashes //.

Hyperlinks and URLs

Hyperlinks can be used in Calc to jump to a different location from within a spreadsheet and can 
lead to other parts of the current file, to different files or even to web sites.

Relative and absolute hyperlinks
Hyperlinks can be stored within your file as either relative or absolute.

A relative hyperlink says, Here is how to get there starting from where you are now (meaning from 
the folder in which your current document is saved) while an absolute hyperlink says, Here is how 
to get there no matter where you start from.

Chapter 10  Linking Calc Data 276



An absolute link will stop working only if the target is moved. A relative link will stop working only if 
the start and target locations change relative to each other. For instance, if you have two 
spreadsheets in the same folder linked to each other and you move the entire folder to a new 
location, a relative hyperlink will not break.

To change the way that LibreOffice stores the hyperlinks in your file, select Tools > Options > 
Load/Save > General and choose if you want URLs saved relatively when referencing the File 
System, or the Internet, or both.

Calc will always display an absolute hyperlink. Don’t be alarmed when it does this even when you 
have saved a relative hyperlink—this ‘absolute’ target address will be updated if you move the file.

Note
Make sure that the folder structure on your computer is the same as the file 
structure on your web server if you save your links as relative to the file system and
you are going to upload pages to the Internet.

Tip

When you rest the mouse pointer on a hyperlink, a help tip displays the absolute 
reference, since LibreOffice uses absolute path names internally. The complete 
path and address can only be seen when you view the result of the HTML export 
(saving the spreadsheet as an HTML file), by loading the HTML file as Text, or by 
opening it with a text editor.

Creating hyperlinks
When you type text that can be used as a hyperlink (such as a website address or URL), Calc 
formats it automatically, creating the hyperlink and applying to the text a color and background 
shading. If this does not happen, you can enable this feature using Tools > AutoCorrect Options 
> Options and selecting URL Recognition.

Tips

To change the color of hyperlinks, go to Tools > Options > LibreOffice > 
Appearance, scroll to Unvisited links and/or Visited links, pick the new colors and 
click OK. Caution: this will change the color for all hyperlinks in all components of 
LibreOffice—this may not be what you want.

You can also insert and modify links using the Hyperlink dialog. To display the dialog, click the 

Hyperlink icon  on the Standard toolbar or choose Insert > Hyperlink from the menu bar. To 
turn existing text into a link, highlight it before opening the dialog.

On the left side, select one of the four categories of hyperlinks:

• Internet: the hyperlink points to a web address, normally starting with http://

• Mail & News: the hyperlink opens an email message that is pre-addressed to a particular 
recipient.

• Document: the hyperlink points to a place in either the current document or another 
existing document.

• New document: the hyperlink creates a new document.

The top section of the dialog changes according to the choice made for the hyperlink category from
the left panel. A full description of all the choices, and their interactions, is beyond the scope of this 
chapter. Here is a summary of the most common choices used in spreadsheets.
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Figure 249: Hyperlink dialog showing details for Internet links

For an Internet hyperlink, choose the type of hyperlink (Web or FTP,), and enter the required web 
address (URL).

For a Mail and News hyperlink, specify whether it is a mail or news link, the receiver address and 
for email, also the subject.

For a Document hyperlink, specify the document path (the Open File button opens a file browser);
leave this blank if you want to link to a target in the same spreadsheet. Optionally specify the target
in the document (for example a specific sheet). Click on the Target in document icon to open the 
Navigator where you can select the target, or if you know the name of the target, you can type it 
into the box.

For a New Document hyperlink, specify whether to edit the newly created document immediately 
(Edit now) or just create it (Edit later), and enter the file name and the type of document to create 
(text, spreadsheet, etc.). The Select path button opens a directory picker dialog.

The Further settings section at the bottom of the dialog is common to all the hyperlink categories, 
although some choices are more relevant to some types of links.

• Set the value of Frame to determine how the hyperlink will open. This applies to documents
that open in a Web browser.

• Form specifies if the link is to be presented as text or as a button. Figure 250 shows a link 
formatted as a button.

Figure 250: Hyperlink as button

• Text specifies the text that will be visible to the user. If you do not enter anything here, Calc
will use the full URL or path as the link text. Note that if the link is relative and you move the
file, this text will not change, though the target will.
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• Name is applicable to HTML documents. It specifies text that will be added as a NAME 
attribute in the HTML code behind the hyperlink.

• Events button: this button will be activated to allow Calc to react to events for which the 
user has written some code (macro). This function is not covered in this chapter.

Note

A hyperlink button is a type of form control. As with all form controls, it can be 
anchored or positioned by right-clicking on the button in design mode. More 
information about forms can be found in Chapter 15 of the Writer Guide.

For the button to work , the spreadsheet must not be in design mode. To toggle design
mode on and off, view the Form Controls toolbar (View > Toolbars > Form Controls) 

and click the Design Mode On/Off button .

Editing hyperlinks

To edit an existing link, place the cursor anywhere in the link and click the Hyperlink icon  on 
the Standard toolbar or select Edit > Hyperlink from the menu bar. The Hyperlink dialog (Figure 
249) opens. If the Hyperlink is in button form, the spreadsheet must have Design Mode on in order 
to edit the Hyperlink. Make your changes and click Apply. If you need to edit several hyperlinks, 
you can leave the Hyperlink dialog open until you have edited all of them. Be sure to click Apply 
after each one. When you are finished, click Close.

Removing hyperlinks
You can remove the clickable link from hyperlink text—leaving just the text—by right-clicking on the
link and selecting Default Formatting. This option is also available from the Format menu. You 
may then need to re-apply some formatting in order for it to match the rest of your document.

To erase the link text or button from the document completely, select it and press the Backspace or
Delete key.

Linking to external data

With the help of the Web Page Query import filter, you can insert tables from HTML documents into
Calc.

You can use the same method to insert data located within named ranges from a LibreOffice Calc 
or Microsoft Excel spreadsheet, into a Calc spreadsheet. (To use other data sources, including 
database files in LibreOffice Base, see “Linking to registered data sources” on page 284.)

You can do this in two ways: using the External Data dialog or using the Navigator. If your file has 
named ranges or named tables, and you know the name of the range or table you want to link to, 
using the External Data dialog method is quick and easy. However, if the file has several tables, 
and you want to pick only one of them, you may not be able to easily determine which is which; in 
that case, the Navigator method may be easier.

Using the External Data dialog
1) Open the Calc document where the external data is to be inserted. This is the target 

document.

2) Select the cell where the upper left-hand cell of the external data is to be inserted.

3) Choose Insert > Link to External Data.
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4) On the External Data dialog, type the URL of the source document or select it from the 
drop-down list if it is listed.

• For entries typed in, press Enter on completion.

• File selections from the drop-down list will load automatically.

5) You can also click the [...] button to open the Insert (file selection) dialog. Selecting a file 
and then clicking Insert loads the list of available tables. If the source document is a Web 
page, choose Web Page Query (Calc) as the file type (see Figure 251). Enter the URL as 
the file name. Click Insert.

Figure 251: Using a Web Query to link data directly to a web page

6) For URLs to HTML (web) documents, pressing Enter at step 4, or Insert at step 5, opens 
the Import Options dialog where you can choose the import language of the site. Select 
Automatic to let Calc import the data directly, or select Custom and choose from the drop-
down list of languages available. You can also select the option to have Calc recognise 
special numbers such as dates on import.

Figure 252: Import Options dialog

7) Click OK and Calc loads the list of available tables/ranges (Figure 253). The filter can 
create names for cell ranges as they are imported. As much formatting as possible is 
retained while the filter intentionally does not import any images. The filter additionally 
creates two entries to the list: HTML_all to permit selection of the entire document, and 
HTML_tables to permit selection of all the tables.

8) In the Available tables/range list, select the named ranges or tables you want to insert (hold
Ctrl to select multiple entries). The OK button then becomes available. You can also specify
that the ranges or tables are updated every (number of) seconds.

9) Click OK to close the dialog and insert the linked data.
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Figure 253: Selecting a table or range in a source document from the Web

Using the Navigator
1) Open the Calc spreadsheet in which the external data is to be inserted (target document).

2) Open the document from which the external data is to be taken (source document). The 
source document can be a Web page, created by choosing Web Page Query (Calc) as the
file type, and entering the URL into the File name box, before clicking OK (see Figure 251).

3) In the target document, press F5 to open the Navigator.

Figure 254: Selecting a data range in a source 
document, to be inserted as a link
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4) At the bottom of the Navigator, select the source document. (In Figure 254, the source is 
named actives.)

The Navigator now shows the range names or the tables contained in the source document
(the example contains range names; other documents have a list of tables). Click on the + 
next to Range names to display the list.

5) In the Navigator, select the Insert as Link drag mode, as shown in Figure 254.

6) Select the required range or table and drag it from the Navigator into the target document, 
to the cell where you want the upper left-hand cell of the data range to be.

7) Reselect the target document in the box at the bottom of the Navigator. Instead of a + 
symbol next to Range names, it shows a + symbol next to Linked areas. Click the + symbol
to see the range name (see Figure 255) dragged across from the source document.

Figure 255: Linked areas in target spreadsheet

How to find the required data range or table
The examples above show that the import filter gave names to the data ranges (tables) in the 
sample web page starting from HTML_1. It also created two additional range names (not visible in 
the illustration):

• HTML_all – designates the entire document

• HTML_tables – designates all HTML tables in the document

If the data tables in the source HTML document have been given names (using the ID attribute on 
the TABLE tag), or the external spreadsheet includes named ranges, those names appear in the 
list along with the ranges Calc has sequentially numbered.

If the data range or table you want is not named, how can you tell which one to select? 

Go to the source document, which you opened in Calc. In the Navigator, double-click on a range 
name: that range is highlighted on the sheet (see Figure 256).

If the Formula Bar is visible, the range name is also displayed in the Name box at the left-hand end
(see Figure 257). The range name can also be selected from this drop-down list to highlight it on 
the page.
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Figure 256: Using the Navigator to find a data range name

Figure 257: Using the Name box to find a data range name
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Linking to registered data sources

You can access a variety of databases and other data sources and link them into Calc documents.

First you need to register the data source with LibreOffice. (To register means to tell LibreOffice 
what type of data source it is and where the file is located.) The way to do this depends on whether
or not the data source is a database in *.odb format.

To register a data source that is in *.odb format:

1) Choose Tools > Options > LibreOffice Base > Databases.

2) Click the New button (below the list of registered databases) to open the Create Database 
Link dialog (Figure 258).

Figure 258: Registering databases

3) Enter the location of the database file, or click Browse to open a file browser and select the
database file.

4) Type a name to use as the registered name for the database and click OK. The database is
added to the list of registered databases. The OK button is enabled only when both fields 
are filled in.

To register a data source that is not in *.odb format:

1) Choose File > New > Database to open the Database Wizard.

2) Select Connect to an existing database. The choices for database type depend on your 
operating system. For example, Microsoft Access and other Microsoft products are not 
among the choices if you are using Linux. In our example, we chose dBASE.

3) Click Next. Type the path to the database file or click Browse and use the Open dialog to 
navigate to and select the database file before clicking Open.

4) Click Next. Select Yes, register the database for me, but clear the checkbox marked Open 
the database for editing.

5) Click Finish. Name and save the database in the location of your choice. Note: changes 
made to the *.odb do not affect the original dBASE file.

Once a data source has been registered, it can be used by any LibreOffice component (for 
example Calc).
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Figure 259: Registering a database using the Database Wizard

Viewing data sources
Open a document in Calc. To view the data sources available, press F4 or select View > Data 
Sources from the menu bar. The Data Source View pane opens above the spreadsheet. A list of 
registered databases is in the Data Explorer area on the left. (The built-in Bibliography database is 
included in the list.)

To view each database, click on the + symbol to the left of the name of the database. (This has 
been done for the Automobile database in Figure 260.) Click on the + symbol next to Tables to 
view the individual tables.

Figure 260: Databases

Now click on a table to see all the records held in it. The data records are displayed on the right 
side of the Data Source View pane. To see more columns, you can click the Explorer On/Off 
button to hide the Data Explorer area.
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At the top of the Data Source View pane, below the Calc toolbars, is the Table Data bar. This 
toolbar includes buttons for saving records, editing data, finding records, sorting, filtering, and other
functions. For more details about this toolbar, see the Help for data source browser.

Below the records is the Form Navigation bar, which shows which record is selected and the total 
number of records. To the right are five small buttons; the first four move backwards or forwards 
through the records, or to the beginning or end. The last is for adding new records.

Figure 261: Data Source View navigation buttons

Editing data sources
Some data sources (such as spreadsheets) cannot be edited in the data source view.

In editable data sources, records can be edited, added, or deleted. If you cannot save your edits, 
you need to open  the database in Base and edit it there; see “Launching Base to work on data 
sources”. You can also hide columns and make other changes to the display.

Launching Base to work on data sources
You can launch LibreOffice Base at any time from the Data Source View pane. Right-click on a 
database or the Tables or Queries icons and select Edit Database File. Once in Base, you can 
edit, add, and delete tables, queries, forms, and reports.

For more about using Base, see Chapter 8, Getting Started with Base, in the Getting Started guide.

Using data sources in Calc spreadsheets
Data from the tables in the data source pane can be placed into Calc documents in a variety of 
ways.

You can select a cell or an entire row in the data source pane and drag and drop the data into the 
spreadsheet. The data is inserted at the place where you release the mouse button.

An alternative method uses the Data to Text icon and will include the column headings above the 
data you insert:

1) Click the cell of the spreadsheet which you want to be the top left of your data including the
column names.

2) Press F4 to open the database source window and select the table containing the data you 
want to use.

3) Select the rows of data you want to add to the spreadsheet:

• Click the gray box to the left of the row you want to select if only selecting one row. 
That row is highlighted.

• To select multiple adjacent rows, hold down the Shift key while clicking the gray box of
the rows you need. 

• To select multiple separate rows, hold down the Control key while selecting the rows. 
The selected rows are highlighted.

• To select all the rows, click the gray box in the upper left corner. All rows are 
highlighted.

4) Click the Data to text icon  to insert the data into the spreadsheet cells.
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You can also drag the data source column headings (field names) onto your spreadsheet to create 
a form for viewing and editing individual records one at a time. Follow these steps:

1) Click the gray box at the top of the column (containing the field name you wish to use) to 
highlight it.

2) Drag and drop the gray box to where you want the record to appear in the spreadsheet.

3) Repeat until you have moved all of the fields you need to where you want them.

4) Close the Data Source window by pressing F4.

5) Save the spreadsheet and click the Edit File button  on the Standard toolbar, to make 
the spreadsheet read-only. All of the fields will show the value for the data of the first record
you selected.

6) Add the Form Navigation toolbar: View > Toolbars > Form Navigation. By default, this 
toolbar opens at the bottom of the Calc window, just above the status bar.

7) Click the arrows on the Form Navigation toolbar to view the different records of the table. 
The number in the Record box changes as you move through the records. The data in the 
fields changes to correspond to the data for that particular record number. You can also 
search for a specific record, sort and filter records, and do other tasks using this toolbar.

Embedding spreadsheets

Spreadsheets can be embedded in other LibreOffice files. This is often used in Writer or Impress 
documents so that Calc data can be used in a text document. You can embed the spreadsheet as 
either an OLE or DDE object. The difference between a DDE object and a Linked OLE object is 
that a Linked OLE object can be edited from the document in which it is added as a link, but a DDE
object cannot.

For example, if a Calc spreadsheet is pasted into a Writer document as a DDE object, then the 
spreadsheet cannot be edited in the Writer document. But if the original Calc spreadsheet is 
updated, the changes are automatically made in the Writer document. If the spreadsheet is 
inserted as a Linked OLE object into the Writer document, then the spreadsheet can be edited in 
the Writer as well as in the Calc document and both documents are in sync with each other.

Object Linking and Embedding (OLE)
The major benefit of an OLE (Object Linking and Embedding) object is that it is quick and easy to 
edit its contents just by double-clicking on it. You can also insert a link to the object that will appear 
as an icon rather than an area showing the contents itself.

OLE objects can be linked to a target document or be embedded in the target document. Linking 
inserts information which will be updated with any subsequent changes to the original file, while 
embedding inserts a static copy of the data. If you want to edit the embedded spreadsheet, double-
click on the object.

To embed a spreadsheet as an OLE object in a presentation:

1) Place the cursor in the document and location you want the OLE object to be.

2) Select Insert > Object > OLE Object. The dialog in Figure 262 opens.
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Figure 262: Insert OLE object dialog

You can either create a new OLE object or create from a file.

To create a new object:

1) Select Create new and select the object type among the available options.

2) Click OK. An empty container is placed in the slide.

3) Double-click on the OLE object to enter the edit mode of the object. The application 
devoted to handling that type of file will open the object.

Note

If the object inserted is handled by LibreOffice, then the transition to the program to 
manipulate the object will be seamless; in other cases the object opens in a new 
window and an option in the File menu becomes available to update the object you 
inserted.

To insert an existing object:

1) To create from a file, select Create from file. The dialog changes to look like Figure 263.

2) To insert the object as a link, select the Link to file option. Otherwise, the object will be 
embedded.

3) Click Search, select the required file in the Open dialog, then click Open. A section of the 
inserted file is shown in the document.

Figure 263: Inserting an object as a link
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Other OLE objects
Under Windows, the Insert OLE Object dialog has an extra entry, Further objects.

1) Double-click on the entry Further objects to open the dialog shown below.

Figure 264: Inserting an OLE object under Windows  

2) Select Create New to insert a new object of the type selected in the Object Type list, or 
select Create from File to create a new object from a file.

3) If you choose Create from File, the dialog shown in Figure 261 opens. Click Browse and 
choose the file to insert. The inserted file object is editable by the Windows program that 
created it.

If instead of inserting an object, you want to insert a link to an object, select the Display As
Icon option.

Figure 265: Insert object from a file

Non-linked OLE object
If the OLE object is not linked, it can be edited in the new document. For instance, if you insert a 
spreadsheet into a Writer document, you can essentially treat it as a Writer table (with a little more 
power). To edit it, double-click on it.
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Linked OLE object
When the spreadsheet OLE object is linked, if you change it in Writer it will change in Calc; if you 
change it in Calc, it will change in Writer. This can be a very powerful tool if you create reports in 
Writer using Calc data, and want to make a quick change without opening Calc.

Note
You can only edit one copy of a spreadsheet at a time. If you have a linked OLE 
spreadsheet object in an open Writer document and then open the same 
spreadsheet in Calc, the Calc spreadsheet will be a read-only copy.

Dynamic Data Exchange (DDE)
DDE is an acronym for Dynamic Data Exchange, a mechanism whereby selected data in 
document A can be pasted into document B as a linked, ‘live’ copy of the original. It would be used,
for example, in a report written in Writer containing time-varying data, such as sales results 
sourced from a Calc spreadsheet. The DDE link ensures that, as the source spreadsheet is 
updated so is the report, thus reducing the scope for error and reducing the work involved in 
keeping the Writer document up to date.

DDE is a predecessor of OLE. With DDE, objects are linked through file reference, but not 
embedded. You can create DDE links either within Calc cells in a Calc sheet, or in Calc cells in 
another LibreOffice doc such as in Writer.

DDE link in Calc
Creating a DDE link in Calc is similar to creating a cell reference. The process is a little different, 
but the result is the same.

1) In Calc, select the cells that you want to make the DDE link to.

2) Copy them: Edit > Copy or Ctrl+C.

3) Go to the place in the spreadsheet where you want the link to be.

4) Select Edit > Paste Special.

5) When the Paste Special dialog opens, select the Link option on the bottom left of the 
dialog (Figure 266). Click OK.

The cells now reference the copied data, and the formula bar shows a reference beginning with 
{=DDE.

If you now edit the original cells, the linked cells will update.

Figure 266: Location of Link option on Paste Special dialog in Calc

DDE link in Writer
The process for creating a DDE link from Calc to Writer is similar to creating a link within Calc.

1) In Calc, select the cells to make the DDE link to. Copy them.

2) Go to the place in your Writer document where you want the DDE link. Select Edit > Paste 
Special.

3) Select DDE Link (Figure 267). Click OK.
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Now the link has been created in Writer. When the Calc spreadsheet is updated, the table in Writer
is automatically updated.

Figure 267: Paste Special dialog in Writer, with DDE link selected
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Introduction

This chapter covers methods for editing shared documents: sharing (collaboration), recording 
changes, adding comments, reviewing changes, merging and comparing documents, and saving 
and using document versions. Basic editing techniques are discussed in Chapter 2, Entering, 
Editing, and Formatting Data.

Sharing documents (collaboration)

In LibreOffice Writer, Impress, and Draw, only one user at a time can open any document for 
editing. In Calc, many users can open the same spreadsheet for writing at the same time.

Each user who wants to collaborate should be sure to enter a name on the Tools > Options > 
LibreOffice > User Data page.

Some menu commands are not available (grayed out) when change tracking or document sharing 
is activated.

Setting up a spreadsheet for sharing
At any time, you can set up a spreadsheet for sharing with others. With the spreadsheet document 
open, choose Tools > Share Document to activate the collaboration features for this document. A 
dialog opens where you can enable or disable sharing.

Figure 268: Choosing to share a spreadsheet

To enable sharing, check the box at the top of the dialog, and then click OK. If the spreadsheet has
been saved previously, a message appears stating that you must save it to activate shared mode; 
click Yes to continue. If the spreadsheet has not been saved previously, the Save dialog appears. 
After saving, the word (shared) is shown on the title bar after the document’s title.

The Tools > Share Document command can be used to switch the mode for a document from 
unshared to shared. However, if you want to use a shared document in unshared mode, you need 
to save the shared document using another name or path. This creates a copy of the spreadsheet 
that is not shared.
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Opening a shared spreadsheet
When you open a spreadsheet document that is in shared mode, a message appears stating that 
the document is in shared mode and that some features are not available in this mode. After 
clicking OK, the document is opened in shared mode. You can select the option to not show the 
warning again.

The following features are disabled in a shared spreadsheet document:

Edit > Changes, except for Merge Document
Edit > Compare Document
Edit > Sheet > Move/Copy & Delete

Insert > Cells > Shift Cells Down & Shift Cells Right
Insert > Sheet from file
Insert > Names
Insert > Comment
Insert > Picture > From File
Insert > Movie and Sound
Insert > Object
Insert > Chart
Insert > Floating Frame

Format > Sheet > Rename, Tab Color
Format > Merge Cells > Merge and Center, Merge Cells, Split Cells
Format > Print Ranges

Tools > Protect Document

Data > Define Range
Data > Sort
Data > Subtotals
Data > Validity
Data > Multiple Operations
Data > Consolidate
Data > Group and Outline (all)
Data > Pivot Table

Saving a shared spreadsheet
When you save a shared spreadsheet, one of several situations may occur:

• If the document was not modified and saved by another user since you opened it, the 
document is saved.

• If the document was modified and saved by another user since you opened it, one of the 
following events will occur:

– If the changes do not conflict, the document is saved, the message below appears, 
and any cells modified by the other user are shown with a red border.

Figure 269: Update message after saving

– If the changes conflict, the Resolve Conflicts dialog is shown. You must decide for 
each conflict which version to keep, yours or the other person’s. When all conflicts are 
resolved, the document is saved. While you are resolving the conflicts, no other user 
can save the shared document.
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Figure 270: Resolve Conflicts dialog

• If another user is trying to save the shared document and resolve conflicts, you see a 
message that the shared spreadsheet file is locked due to a merge-in in progress. You can 
choose to cancel the Save command for now, or retry saving later.

When you successfully save a shared spreadsheet, the document shows the latest version of all 
changes saved by all users.

Recording changes

You can use several methods to record changes that you or others make to a document:

• You can use change marks to show added material, deleted material, and changes to 
formatting. Later, you or another person can review the document and accept or reject 
each change. Not available in shared files.

• If you are not using file sharing, you can make changes to a copy of the document (stored 
in a different folder, under a different name, or both), then use Calc to compare the files and
show the changes. See page 303.

• You can save versions that are stored as part of the original file. See page 304.

Reviewers can leave comments in the document, either attached to specific changes or 
standalone.

Preparing a document for review (optional)
This feature is not available in shared documents. When you send a document to someone else to 
review or edit, you may want to set it up so that the editor or reviewer does not have to remember 
to turn on the revision marks.

After you have turned on revision marks, you can optionally password protect the document so that
any user must enter the correct password in order to turn off protection and accept or reject 
changes. It is not necessary to password protect the document while preparing it for review.

1) Open the document and make sure that the Edit > Changes > Record menu item has a 
check mark next to it, indicating that change recording is active. You can also use File > 
Properties > Security and select Record changes.
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2) (Optional) Click Edit > Changes > Protect Records. On the Enter Password dialog, type a
password (twice) and click OK. You can also use File > Properties > Security and click 
the Protect button to open the Enter Password dialog.

Identifying copies of spreadsheets
When not using the document sharing feature, it is important to keep track of the different copies of
the document. This can be done either in the file name or in the file title. If you have not provided a 
file title in the spreadsheet’s properties, the spreadsheet’s file name is displayed in the title bar. To 
set the title of the spreadsheet, select File > Properties > Description.

Recording changes (tutorial)
For this chapter we will work with a budget proposal for a baseball team.

You are the sponsor of a youth baseball team. The coach has submitted a budget to 
you for the season and you need to edit the costs and return it to her.

You are concerned that if you just make the changes, then the coach will not see the 
changes you made. You decide to use Calc with the record changes feature turned on, 
so that the coach can easily see the change you have made.

Figure 271 shows the budget spreadsheet your coach submitted.

Figure 271: Baseball budget spreadsheet

Looking over the figures, you see a few places where money could be saved:

• Post-game snacks can be bought by parents.

• New uniforms can wait; only buy 10 to replace damaged ones.

• Buy cheaper baseballs.

• Only buy 2 spare gloves.

To make these changes, use the record changes feature in Calc. To start recording changes:

1) Open the Budget Spreadsheet.

2) Select Edit > Changes > Record from the menu bar.

3) Begin editing the document.
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A colored border, with a dot in the upper left-hand corner, appears around a cell where changes 
were made (Figure 272). Other reviewers then quickly know which cells were edited. A deleted 
column or row is marked by a heavy colored bar.

Figure 272: Edited document with red border on changed cells

Note Some changes, for example cell formatting, are not recorded and marked.

Tip
To change the color that indicates changes, select Tools > Options > LibreOffice 
Calc > Changes.

When you finish editing the document, you can send it to your coach.

You may want to explain your rationale for the changes. You can share your insight in two ways: by
adding comments to the changes you made, or by adding general comments to the spreadsheet.

Adding comments to changes

Calc automatically adds to any recorded change a comment that describes what was changed (for 
example, Cell B4 changed from ‘9’ to ‘4’). Reviewers and authors can add their own comments to 
explain their reasons for the changes.

To add a comment to a change:

1) Make the change to the spreadsheet.

2) Select the cell with the change.

3) Choose Edit > Changes > Comments. The dialog shown in Figure 273 appears.

Figure 273: Insert Comment dialog
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4) Type your comment and click OK. The automatically-added comment provided by Calc 
cannot be edited.

After you have added a comment to a changed cell, you can see it by hovering the mouse pointer 
over the cell, as shown in Figure 274.

Figure 274: Comment added to cell B3

The comment also appears in the dialog when you are accepting and rejecting changes, as shown 
in the first line of Figure 279 on page 302.

Editing change comments
1) Select the cell with the change comment that you want to edit.

2) Select Edit > Changes > Comments.

3) Edit the comment and click OK.

Adding other comments

Calc provides another type of comments (formerly called “notes”), which authors and reviewers 
often use to exchange ideas, ask for suggestions, or brainstorm in the document.

To add a comment:

1) Select the cell that the comment applies to.

2) Select Insert > Comment or right-click and select Insert Comment. (The latter method 
does not work if the automatic spelling checker is active and the cell contains a misspelled 
word.) The box shown in Figure 275 appears.

Figure 275: Inserting a comment

3) Type the text of your comment in the box, then click outside the box to close it.

Now the cell to which you added the comment has a colored dot in the upper right-hand corner, as 
shown in Figure 276. It does not have a colored border, unless the cell was also changed.
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Figure 276: Colored dot in cell containing a comment

Tip
You can change the colors Calc uses for notes by selecting Tools > Options > 
LibreOffice > Appearance.

To view the comment you just added, hover the mouse pointer over the cell that has a comment; 
the comment appears, as shown below.

Figure 277: Viewing a comment

Editing comments
You can edit and format the text of a comment, just as you do for any other text.

1) Right-click on the cell containing the comment marker and choose Show comment from 
the context menu.

2) Select the comment, then double-click on it. The cursor changes to the usual blinking text-
entry cursor, and the Formatting toolbar changes to show text attributes.

3) When done, click outside the comment to deselect it. To hide the comment again, right-click
on the cell and deselect Show Comment on the context menu.

Formatting comments
You can change the background color, border style, transparency, and other attributes of a 
comment.

1) Right-click on the cell containing the comment marker, and choose Show comment from 
the context menu.

2) Click on the comment itself. The Formatting toolbar changes to show many of the comment
formatting options. These are the same as the options for formatting graphics; see Chapter 
5, Using Graphics in Calc, for more information.

You can also right-click on the comment to see a menu of choices, some of which lead to 
dialogs in which you can fine-tune the formatting; these dialogs are also discussed in 
Chapter 5.

3) When done, click outside the comment to deselect it. To hide the comment again, right-click
on the cell and deselect Show Comment on the context menu.

Finding comments using the Navigator
The small comment markers in the corners of cells can be difficult to see, so Calc provides another
way to find them, by using the Navigator. If any comments are in the spreadsheet, the Navigator 
shows a mark (usually a + or an arrow) next to the word Comments. Click on this mark to display a
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list of comments. Double-click on the comment you want to jump directly to the cell it is associated 
with.

Reviewing changes

At this point, we are going to change our perspective from the point of view of the team sponsor to 
that of the coach, so we can see how to review and accept or reject the changes to the document 
the coach originally wrote.

You are the coach of a youth baseball team and you submitted a potential budget 
created in Calc to your team sponsor.

Your sponsor has reviewed the document using the record changes feature of Calc. 
Now, you want to review those changes and accept or reject the counter proposal.

Because the sponsor recorded changes in Calc, you can easily see what changes were 
made and decide how to act.

Viewing changes
You have some control over what changes you see when reviewing a document. Select Edit > 
Changes > Show from the Menu bar. The Show Changes dialog Figure 278) opens.

Figure 278: Show changes dialog

Accepting or rejecting changes
When you receive a document back with changes, the beauty of the recording changes system 
becomes evident. Now, as the original author, you can step through each change and decide how 
to proceed. To begin this process:

1) Open the edited document.

2) Select Edit > Changes > Accept or Reject. The dialog shown in Figure 279 appears.

3) You can step through the changes one at a time, choosing to accept or reject each change 
as you go through. You can also accept or reject all changes at one time.
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Figure 279: Accept or Reject changes dialog

The Comment column by default contains an explanation of the change that was made. If the 
reviewer added a comment to the change, it is displayed, followed by the description of the 
change, as in the first line of Figure 279.

If a change has been superceded by later change (by either the same person or another person), 
the changes are hierarchically arranged with a plus sign for opening up the hierarchy.

Below the list of changes to be accepted or rejected are shown any changes that have previously 
been dealt with.

On the Filter tab of this dialog (Figure 280), you can choose how to filter the list of changes: by 
date, author, cell range, or comments containing specific terms. After selecting the filter criteria, 
switch back to the List tab to see the results.

Figure 280: Filters set here affect the list of changes shown on the List tab
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Merging documents

You submitted your budget proposal to your sponsor, but you sent it to one of 
your assistant coaches as well. Both of them returned their revised budget to 
you at the same time.

You could review each document and the changes separately, but to save time, 
you want to see both of their revisions simultaneously.

To do this, you can use Calc’s merge document feature.

The processes discussed to this point are effective when you have one reviewer at a time. 
Sometimes, however, multiple reviewers all return edited versions of a document at the same time.
In this case, it may be quicker to review all of these changes at once, rather than one review at a 
time. For this purpose, you can merge documents in Calc.

To merge documents, all of the edited documents need to have recorded changes in them.

1) Open the original document.

2) Select Edit > Changes > Merge Document.

3) A file selection dialog opens. Select a file you want to merge and click OK.

4) After the documents merge, the Accept or Reject Changes dialog opens, showing changes 
by more than one reviewer. If you want to merge more documents, close the dialog and 
then repeat steps 2 and 3.

Now all of the changes are combined into one document and you can accept or reject the changes.
Changes from different authors appear in cells outlined in different colors, as shown in Figure 281. 
In this example, all of the changes from Robert are outlined in blue and the changes from Mia are 
outlined in red.

Figure 281: Merged documents with different author colors

Comparing documents

Sometimes when sharing documents, reviewers may forget to record the changes they make. This 
is not a problem with Calc, because Calc can find the changes by comparing documents.

In order to compare documents you need to have the original document and the one that is edited. 
To compare them:

1) Open the edited document that you want to compare with the original document.

2) Select Edit > Compare Document.
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3) An open document dialog appears. Select the original document and click Insert.

Calc finds and marks the changes as follows:

• All data that occurs in the edited document but not in the original is identified as inserted.

• All data that is in your original document but is not in the edited document is identified as 
deleted.

• All data that is changed, is marked as changed.

From this point you can go through and accept or reject changes as you could normally.

Saving versions

Most documents go through many drafts. It is often useful to save new versions of a document. 
You can do this by saving a copy of the document (under a different name) after each revision, or 
by using Calc’s version feature. 

Caution

 

If you do a Save As... of a document with different versions stored in it, the old 
versions are not saved in the new file.

To use version management in Calc:

1) Choose File > Versions. The Versions dialog opens.

Figure 282: Version management dialog

2) Click the Save New Version button to save a new version.

3) A dialog opens where you can enter comments about this version.
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Figure 283: Version comment dialog

4) After you enter your comment and click OK, the new version is included in the version list.

Figure 284: Updated version list

Now when you save the file, both versions are saved in the same file. From this point you can:

• Open an old version – Select the version and click the Open button and a read-only copy 
of a previous version opens.

• Compare all versions – Clicking the Compare button performs an action similar to merging 
documents together. An Accept or Reject Changes dialog opens showing all of the changes
through the different versions.

• Review the comments – Select a version and click the Show button to display the full 
comments made by yourself or other reviewers.

Note The new file is larger, as if two spreadsheets were saved together.
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Introduction

A macro is a saved sequence of commands or keystrokes that are stored for later use. An example
of a simple macro is one that “types” your address. The LibreOffice macro language is very 
flexible, allowing automation of both simple and complex tasks. Macros are especially useful to 
repeat a task the same way over and over again. This chapter briefly discusses common problems 
related to macro programming using Calc.

Using the macro recorder

Chapter 13 of the Getting Started guide, Getting Started with Macros, provides a basis for 
understanding the general macro capabilities in LibreOffice using the macro recorder. An example 
is shown here without the explanations in the Getting Started guide. The following steps create a 
macro that performs paste special with multiply.

Tip
Use Tools > Options > LibreOffice > Advanced and select the Enable  macro 
recording option to enable the macro recorder.

1) Open a new spreadsheet.

2) Enter numbers into a sheet.

Figure 285: Enter numbers

3) Select cell A3, which contains the number 3, and copy the value to the clipboard.

4) Select the range A1:C3.

5) Use Tools > Macros > Record Macro to start the macro recorder. The Record Macro 
dialog is displayed with a stop recording button.

Figure 286: Stop recording button

6) Use Edit > Paste Special to open the Paste Special dialog (Figure 287).

Figure 287: Paste Special dialog
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7) Set the operation to Multiply and click OK. The cells are now multiplied by 3 (Figure 288).

Figure 288: Cells multiplied by 3

8) Click Stop Recording to stop the macro recorder. The LibreOffice Basic Macros dialog 
(Figure 289) opens.

1 My Macros 5 Create new module in library

2 LibreOffice Macros 6 Macros in selected library

3 Open documents 7 Current document

4 Create new library 8 Expand/collapse list

Figure 289: Parts of the LibreOffice Basic Macros dialog

9) Select the current document. For this example, it is Untitled 1. Existing documents show a 
library named Standard. This library is not created until the document is saved or the library
is needed, so at this point your new document does not contain a library. You can create a 
new library to contain the macro, but this is not necessary.

10) Click New Module. If no libraries exist, then the Standard library is automatically created 
and used. In the New Module dialog, type a name for the new module or leave the name as
Module1.

Chapter 12  Calc Macros 309



Note

The libraries, modules and macro names must follow some strict rules. Following 
the main rules, the names must:

• Begin with a letter

• Not contain spaces

• Not contain special caracters, accents included, except for _ (underscore)

11) Click OK to create a new module named Module1. Select the newly created Module1, type 
PasteMultiply in the Macro name box at the upper left, and click Save. (See Figure 
290.)

Figure 290: Select the module and name the macro

The created macro is saved in Module1 of the Standard library in the Untitled 1 document. Listing 1 
shows the contents of the macro.

Listing 1. Paste special with multiply.

sub PasteMultiply
rem --------------------------------------------------------------
rem define variables
dim document   as object
dim dispatcher as object
rem --------------------------------------------------------------
rem get access to the document
document   = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

rem --------------------------------------------------------------
dim args1(5) as new com.sun.star.beans.PropertyValue
args1(0).Name = "Flags"
args1(0).Value = "A"
args1(1).Name = "FormulaCommand"
args1(1).Value = 3
args1(2).Name = "SkipEmptyCells"
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args1(2).Value = false
args1(3).Name = "Transpose"
args1(3).Value = false
args1(4).Name = "AsLink"
args1(4).Value = false
args1(5).Name = "MoveMode"
args1(5).Value = 4

dispatcher.executeDispatch(document, ".uno:InsertContents", "", 0, args1())
end sub

More detail on recording macros is provided in Chapter 13, Getting Started with Macros, in the 
Getting Started guide; we recommend you read it if you have not already done so. More detail is 
also provided in the following sections, but not as related to recording macros.

Write your own functions

Calc can call macros as Calc functions. Use the following steps to create a simple macro:

1) Create a new Calc document named CalcTestMacros.ods.

2) Use Tools > Macros > Organize Macros > LibreOffice Basic to open the LibreOffice 
Basic Macros dialog. The Macro from box lists available macro library containers including 
currently open LibreOffice documents. My Macros contains macros that you write or add to 
LibreOffice. LibreOffice Macros contains macros included with LibreOffice and should not 
be changed.

Figure 291: LibreOffice Basic Macros dialog
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3) Click Manage to open the LibreOffice Basic Macro Organizer dialog (Figure 292). On the 
Libraries tab, select the document to contain the macro.

Figure 292: LibreOffice Basic Macro Organizer

4) Click New to open the New Library dialog.

Figure 293: New Library dialog

5) Enter a descriptive library name (such as AuthorsCalcMacros) and click OK to create the 
library. The new library name is shown in the library list, but the dialog may show only a 
portion of the name.

Figure 294: The library is shown in the organizer
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6) Select AuthorsCalcMacros and click Edit to edit the library. Calc automatically creates a 
module named Module1 and a macro named Main.

Figure 295: Basic Integrated Development Environment (IDE)

7) Modify the code so that it is the same as that shown in Listing 2.The important addition is 
the creation of the NumberFive function, which returns the number five. The Option 
Explicit statement forces all variables to be declared before they are used. If Option 
Explicit is omitted, variables are automatically defined at first use as type Variant.

8) Save the modified Module1.

Listing 2. Function that returns five.

REM  *****  BASIC  *****
Option Explicit

Sub Main

End Sub

Function NumberFive()
  NumberFive = 5
End Function 

Using a macro as a function
Using the newly created Calc document CalcTestMacros.ods, enter the formula 
=NumberFive() (see Figure 296). Calc finds the macro and calls it.
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Figure 296: Use the NumberFive() Macro as a Calc function

Tip
Function names are not case sensitive. In Figure 296, you can enter 
=NumberFive() and Calc clearly shows =NUMBERFIVE().

Save the Calc document, close it, and open it again. Depending on your settings in Tools > 
Options > LibreOffice > Security > Macro Security, Calc will display the warning shown in
Figure 297 or the one shown in Figure 298. You will need to click Enable Macros, or Calc will not 
allow any macros to be run inside the document. If you do not expect a document to contain a 
macro, it is safer to click Disable Macros in case the macro is a virus.

Figure 297: LibreOffice warns you that a document contains macros

Figure 298: Warning if macros are disabled

If you choose to disable macros, then when the document loads, Calc can no longer find the 
function.
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Figure 299: The function is gone

When a document is created and saved, it automatically contains a library named Standard. The 
Standard library is automatically loaded when the document is opened. No other library is 
automatically loaded.

Calc does not contain a function named NumberFive(), so it checks all opened and visible macro 
libraries for the function. Libraries in LibreOffice Macros, My Macros, and the Calc document are 
checked for an appropriately named function (see Figure 291). The NumberFive() function is 
stored in the AuthorsCalcMacros library, which is not automatically loaded when the document is 
opened.

Use Tools > Macros > Organize Macros > LibreOffice Basic to open the LibreOffice Basic 
Macros dialog (see Figure 300). Expand CalcTestMacros and find AuthorsCalcMacros. The icon for
a loaded library is a different color from the icon for a library that is not loaded.

Click the expansion symbol (usually a plus or a triangle) next to AuthorsCalcMacros to load the 
library. The icon changes color to indicate that the library is now loaded. Click Close to close the 
dialog.

Unfortunately, the cells containing =NumberFive() are in error. Calc does not recalculate cells in 
error unless you edit them or somehow change them. The usual solution is to store macros used 
as functions in the Standard library. If the macro is large or if there are many macros, a stub with 
the desired name is stored in the Standard library. The stub macro loads the library containing the 
implementation and then calls the implementation.

1) Use Tools > Macros > Organize Macros > LibreOffice Basic to open the LibreOffice 
Basic Macros dialog. Select the NumberFive macro and click Edit to open the macro for 
editing.

Figure 300: Select a macro and click Edit

2) Change the name of NumberFive to NumberFive_Implementation (Listing 3).

Listing 3. Change the name of NumberFive to NumberFive_Implementation

Function NumberFive_Implementation()
  NumberFive_Implementation() = 5
End Function
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3) In the Basic IDE (see Figure 295), hover the mouse cursor over the toolbar buttons to 
display the tool tips. Click the Select Macro button to open the LibreOffice Basic Macros 
dialog (see Figure 300).

4) Select the Standard library in the CalcTestMacros document and click New to create a new
module. Enter a meaningful name such as CalcFunctions and click OK. LibreOffice 
automatically creates a macro named Main and opens the module for editing.

5) Create a macro in the Standard library that calls the implementation function (see Listing 
4). The new macro loads the AuthorsCalcMacros library if it is not already loaded, and then 
calls the implementation function.

6) Save, close, and reopen the Calc document. This time, the NumberFive() function works.

Listing 4. Change the name of NumberFive to NumberFive_Implementation.

Function NumberFive()
  If NOT BasicLibraries.isLibraryLoaded("AuthorsCalcMacros") Then
    BasicLibraries.LoadLibrary("AuthorsCalcMacros")
  End If
  NumberFive = NumberFive_Implementation()
End Function

Passing arguments to a macro
To illustrate a function that accepts arguments, we will write a macro that calculates the sum of its 
arguments that are positive —it will ignore arguments that are less than zero (see Listing 5).

Listing 5. PositiveSum calculates the sum of the positive arguments.

Function PositiveSum(Optional x)
  Dim TheSum As Double
  Dim iRow As Integer
  Dim iCol As Integer
  
  TheSum = 0.0
  If NOT IsMissing(x) Then
    If NOT IsArray(x) Then
      If x > 0 Then TheSum = x
    Else
      For iRow = LBound(x, 1) To UBound(x, 1)
        For iCol = LBound(x, 2) To UBound(x, 2)
          If x(iRow, iCol) > 0 Then TheSum = TheSum + x(iRow, iCol)
        Next
      Next
    End If
  End If
  PositiveSum = TheSum
End Function

The macro in Listing 5 demonstrates some important techniques:

1) The argument x is optional. When an argument is not optional and the function is called 
without it, LibreOffice prints a warning message every time the macro is called. If Calc calls 
the function many times, then the error is displayed many times.

2) IsMissing checks that an argument was passed before the argument is used.

3) IsArray checks to see if the argument is a single value, or an array. For example, 
=PositiveSum(7) or =PositiveSum(A4). In the first case, the number 7 is passed as 
an argument, and in the second case, the value of cell A4 is passed to the function.

4) If a range is passed to the function, it is passed as a two-dimensional array of values; for 
example, =PositiveSum(A2:B5). LBound and UBound are used to determine the 
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array bounds that are used. Although the lower bound is one, it is considered safer to use 
LBound in case it changes in the future.

Tip

The macro in Listing 5 is careful and checks to see if the argument is an array or a 
single argument. The macro does not verify that each value is numeric. You may be as
careful as you like. The more things you check, the more robust the macro is, and the 
slower it runs.

Passing one argument is as easy as passing two: add another argument to the function definition 
(see Listing 6). When calling a function with two arguments, separate the arguments with a 
semicolon; for example, =TestMax(3; -4).

Listing 6. TestMax accepts two arguments and returns the larger of the two.

Function TestMax(x, y)
  If x >= y Then
    TestMax = x
  Else
    TestMax = y
  End If
End Function 

Arguments are passed as values
Arguments passed to a macro from Calc are always values. It is not possible to know what cells, if 
any, are used. For example, =PositiveSum(A3) passes the value of cell A3, and PositiveSum 
has no way of knowing that cell A3 was used. If you must know which cells are referenced rather 
than the values in the cells, pass the range as a string, parse the string, and obtain the values in 
the referenced cells.

Writing macros that act like built-in functions
Although Calc finds and calls macros as normal functions, they do not really behave as built-in 
functions. For example, macros do not appear in the function lists. It is possible to write functions 
that behave as regular functions by writing an Add-In. However, this is an advanced topic that is 
not covered here.

Accessing cells directly

You can access the LibreOffice internal objects directly to manipulate a Calc document. For 
example, the macro in Listing 7 adds the values in cell A2 from every sheet in the current 
document. ThisComponent is set by StarBasic when the macro starts to reference the current 
document. A Calc document contains sheets: ThisComponent.getSheets(). Use 
getCellByPosition(col, row) to return a cell at a specific row and column.

Listing 7. Add cell A2 in every sheet.

Function SumCellsAllSheets()
  Dim TheSum As Double
  Dim i As integer
  Dim oSheets
  Dim oSheet
  Dim oCell
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  oSheets = ThisComponent.getSheets()
  For i = 0 To oSheets.getCount() - 1
    oSheet = oSheets.getByIndex(i)
    oCell = oSheet.getCellByPosition(0, 1) ' GetCell A2
    TheSum = TheSum + oCell.getValue()
  Next
  SumCellsAllSheets = TheSum
End Function 

Tip
A cell object supports the methods getValue(), getString(), and 
getFormula() to get the numerical value, the string value, or the formula used in a 
cell. Use the corresponding set functions to set appropriate values.

Use oSheet.getCellRangeByName("A2") to return a range of cells by name. If a single cell is 
referenced, then a cell object is returned. If a cell range is given, then an entire range of cells is 
returned (see Listing 8). Notice that a cell range returns data as an array of arrays, which is more 
cumbersome than treating it as an array with two dimensions as is done in Listing 5.

Listing 8. Add cell A2:C5 in every sheet

Function SumCellsAllSheets()
  Dim TheSum As Double
  Dim iRow As Integer, iCol As Integer, i As Integer
  Dim oSheets, oSheet, oCells
  Dim oRow(), oRows()

  oSheets = ThisComponent.getSheets()
  For i = 0 To oSheets.getCount() - 1
    oSheet = oSheets.getByIndex(i)
    oCells = oSheet.getCellRangeByName("A2:C5")
    REM getDataArray() returns the data as variant so strings
    REM are also returned.
    REM getData() returns data data as type Double, so only 
    REM numbers are returned.
    oRows() = oCells.getData()
    For iRow = LBound(oRows()) To UBound(oRows())
      oRow() = oRows(iRow)
      For iCol = LBound(oRow()) To UBound(oRow())
        TheSum = TheSum + oRow(iCol)
      Next
    Next
  Next
  SumCellsAllSheets = TheSum
End Function 

Tip
When a macro is called as a Calc function, the macro cannot modify any value in the 
sheet from which the macro was called, except the value of the cell that contains the 
function.
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Sorting

Consider sorting the data in Figure 301. First, sort on column B descending and then column A 
ascending.

Figure 301: Sort column B descending and column A ascending

The example in Listing 9, however, demonstrates how to sort on two columns.

Listing 9. Sort cells A1:C5 on Sheet 1.

Sub SortRange
  Dim oSheet        ' Calc sheet containing data to sort.
  Dim oCellRange    ' Data range to sort.

  REM An array of sort fields determines the columns that are
  REM sorted. This is an array with two elements, 0 and 1.
  REM To sort on only one column, use:
  REM Dim oSortFields(0) As New com.sun.star.util.SortField
  Dim oSortFields(1) As New com.sun.star.util.SortField

  REM The sort descriptor is an array of properties.
  REM The primary property contains the sort fields.
  Dim oSortDesc(0) As New com.sun.star.beans.PropertyValue

  REM Get the sheet named "Sheet1"
  oSheet = ThisComponent.Sheets.getByName("Sheet1")

  REM Get the cell range to sort
  oCellRange = oSheet.getCellRangeByName("A1:C5")

  REM Select the range to sort.
  REM The only purpose would be to emphasize the sorted data.
  'ThisComponent.getCurrentController.select(oCellRange)

  REM The columns are numbered starting with 0, so
  REM column A is 0, column B is 1, etc.
  REM Sort column B (column 1) descending.
  oSortFields(0).Field = 1
  oSortFields(0).SortAscending = FALSE

  REM If column B has two cells with the same value,
  REM then use column A ascending to decide the order.
  oSortFields(1).Field = 0
  oSortFields(1).SortAscending = True

  REM Setup the sort descriptor.
  oSortDesc(0).Name = "SortFields"
  oSortDesc(0).Value = oSortFields()

  REM Sort the range.
  oCellRange.Sort(oSortDesc())
End Sub 
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Conclusion

This chapter provides a brief overview on how to create libraries and modules, using the macro 
recorder, using macros as Calc functions, and writing your own macros without the macro recorder.
Each topic deserves at least one chapter, and writing your own macros for Calc could easily fill an 
entire book. In other words, this is just the beginning of what you can learn!
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Chapter 13  
Calc as a Simple Database
A guide for users and macro programmers



Introduction

A Calc document is a very capable database, providing sufficient functionality to satisfy the needs 
of many users. This chapter presents the capabilities of a Calc document that make it suitable as a
database tool. Where applicable, the functionality is explained using both the GUI (Graphical User 
Interface) and macros.

Note

Although this document was initially created for macro programmers, the content 
should be accessible to all users. If you do not use macros, then skip those portions 
that deal with macros. On the other hand, if you want to learn more about macros, be 
sure to check out Andrew Pitonyak’s book OpenOffice.org Macros Explained.

In a database, a record is a group of related data items treated as a single unit of information. Each
item in the record is called a field. A table consists of records. Each record in a table has the same 
structure. A table can be visualized as a series of rows and columns. Each row in the table 
corresponds to a single record and each column corresponds to the fields. A spreadsheet in a Calc
document is similar in structure to a database table. Each cell corresponds to a single field in a 
database record. For many people, Calc implements sufficient database functionality that no other 
database program or functionality is required.

While teaching, a spreadsheet might be used as a grading program. Each row represents a single 
student. The columns represent the grades received on homework, labs, and tests (see Table 9). 
The strong calculation capability provided in a spreadsheet makes this an excellent choice.

Table 9. Simple grading spreadsheet

A B C D E F G

1 Name Test 1 Test 2 Quiz 1 Quiz 2 Average Grade

2 Andy 95 93 93 92 93.25

3 Betty 87 92 65 73 79.25

4 Bob 95 93 93 92 93.25

5 Brandy 45 65 92 85 71.75

6 Frank 95 93 85 92 91.25

7 Fred 87 92 65 73 79.25

8 Ilsub 70 85 97 79 82.75

9 James 45 65 97 85 73

10 Lisa 100 97 100 93 97.5

11 Michelle 100 97 100 65 90.5

12 Ravi 87 92 86 93 89.5

13 Sal 45 65 100 92 75.5

14 Ted 100 97 100 85 95.5

15 Tom 70 85 93 65 78.25

16 Whil 70 85 93 97 86.25

Tip
Although the choice to associate a row with a record rather than a column is arbitrary, 
it is almost universal. In other words, you are not likely to hear someone refer to a 
column of data as a single database record.

Chapter 13  Calc as a Simple Database 322



Associating a range with a name

In a Calc document, a range refers to a contiguous group of cells containing at least one cell. You 
can associate a meaningful name to a range, which allows you to refer to the range using the 
meaningful name. You can create either a database range, which has some database-like 
functionality, or a named range, which does not. A name is usually associated with a range for one 
of three reasons:

1) Associating a range with a name enhances readability by using a meaningful name.

2) If a range is referenced by name in multiple locations, you can point the name to another 
location and all references point to the new location.

3) Ranges associated to a name are shown in the Navigator, which is available by pressing 

the F5 key or clicking on the  icon. The Navigator allows for quick navigation to the 
associated ranges.

Named range
The most common usage of a named range is, as its name implies, to associate a range of cells 
with a meaningful name. For example, create a range named Scores, and then use the following 
equation: =SUM(Scores). To create a named range, select the range to define. Use Insert > 
Names > Define to open the Define Names dialog. Use the Define Names dialog to add and 
modify one named range at a time.

Figure 302: Define a named range

In a macro, a named range is accessed, created, and deleted using the NamedRanges property of 
a Calc document. Use the methods hasByName(name) and getByName(name) to verify and 
retrieve a named range. The method getElementNames() returns an array containing the names of
all named ranges. The NamedRanges object supports the method addNewByname, which accepts
four arguments; the name, content, position, and type. The macro in Listing 10 creates a named 
range, if it does not exist, that references a range of cells.
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Listing 10. Create a named range that references $Sheet1.$B$3:$D$6.

Sub AddNamedRange()
  Dim oRange     ' The created range.
  Dim oRanges    ' All named ranges.
  Dim sName$     ' Name of the named range to create.
  Dim oCell      ' Cell object.
  Dim s$

  sName$ = "MyNRange"
  oRanges = ThisComponent.NamedRanges
  If NOT oRanges.hasByName(sName$) Then
    REM Obtain the cell address by obtaining the cell
    REM and then extracting the address from the cell.
    Dim oCellAddress As new com.sun.star.table.CellAddress
    oCellAddress.Sheet = 0     'The first sheet.
    oCellAddress.Column = 1    'Column B.
    oCellAddress.Row = 2       'Row 3.

    REM The first argument is the range name.
    REM The second argument is the formula or expression to use.
    REM The second argument is usually a string that
    REM defines a range.
    REM The third argument specifies the base address for
    REM relative cell references.
    REM The fourth argument is a set of flags that define
    REM how the range is used, but most ranges use 0.
    REM The fourth argument uses values from the
    REM NamedRangeFlag constants (see Table 10).
    s$ = "$Sheet1.$B$3:$D$6"
    oRanges.addNewByName(sName$, s$, oCellAddress, 0)
  End If
  REM Get a range using the created named range.
  oRange = ThisComponent.NamedRanges.getByName(sName$)

  REM Print the string contained in cell $Sheet1.$B$3
  oCell = oRange.getReferredCells().getCellByPosition(0,0)
  Print oCell.getString()
End Sub

The method addNewByname() accepts four arguments; the name, content, position, and type. The
fourth argument to the method addNewByName() is a combination of flags that specify how the 
named range will be used (see Table 10). The most common value is 0, which is not a defined 
constant value.
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Table 10: com.sun.star.sheet.NamedRangeFlag constants.

Value Name Description

1 FILTER_CRITERIA The range contains filter criteria.

2 PRINT_AREA The range can be used as a print range.

4 COLUMN_HEADER The range can be used as column headers for printing.

8 ROW_HEADER The range can be used as row headers for printing.

The third argument, a cell address, acts as the base address for cells referenced in a relative way. 
If the cell range is not specified as an absolute address, the referenced range will be different 
based on where in the spreadsheet the range is used. The relative behavior is illustrated in Listing 
11, which also illustrates another usage of a named range—defining an equation. The macro in
Listing 11 creates the named range AddLeft, which refers to the equation A3+B3 with C3 as the 
reference cell. The cells A3 and B3 are the two cells directly to the left of C3, so, the equation 
=AddLeft() calculates the sum of the two cells directly to the left of the cell that contains the 
equation. Changing the reference cell to C4, which is below A3 and B3, causes the AddLeft 
equation to calculate the sum of the two cells that are to the left on the previous row.

Listing 11. Create the AddLeft named range.

Sub AddNamedFunction()
  Dim oSheet          'Sheet that contains the named range.
  Dim oCellAddress    'Address for relative references.
  Dim oRanges         'The NamedRanges property.
  Dim oRange          'Single cell range.
  Dim sName As String 'Name of the equation to create.

  sName = "AddLeft"
  oRanges = ThisComponent.NamedRanges
  If NOT oRanges.hasByName(sName) Then
    oSheet = ThisComponent.getSheets().getByIndex(0)
    oRange = oSheet.getCellRangeByName("C3")
    oCellAddress = oRange.getCellAddress()
    oRanges.addNewByName(sName, "A3+B3", oCellAddress, 0)
  End If
End Sub

Tip
Listing 11 illustrates two capabilities that are not widely known. A named range can 
define a function. Also, the third argument acts as the base address for cells 
referenced in a relative way.

Select the range containing the headers and the data and then use Insert > Names > Create to 
open the Create Names dialog (see Figure 303), which allows you to simultaneously create 
multiple named ranges based on the top row, bottom row, right column or left column. If you 
choose to create ranges based on the top row, one named range is created for each column 
header—the header is not included in the named range. Although the header is not included in the 
range, the text in the header is used to name the range.
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Figure 303: Create a named range

The macro in Listing 12 creates three named ranges based on the top row of a named range.

Listing 12. Create many named ranges.

Sub AddManyNamedRanges()
  Dim oSheet    'Sheet that contains the named range.
  Dim oAddress  'Range address.
  Dim oRanges   'The NamedRanges property.
  Dim oRange    'Single cell range.

  oRanges = ThisComponent.NamedRanges
  oSheet = ThisComponent.getSheets().getByIndex(0)
  oRange = oSheet.getCellRangeByName("A1:C20")
  oAddress = oRange.getRangeAddress()
  oRanges.addNewFromTitles(oAddress, _
                     com.sun.star.sheet.Border.TOP)
End Sub

The constants in Table 11 determine the location of the headers when multiple ranges are created 
using the method addNewFromTitles().

Table 11: com.sun.star.sheet.Border constants.

Value Name Description

0 TOP Select the top border.

1 BOTTOM Select the bottom border.

2 RIGHT Select the right border.

3 LEFT Select the left border.

Caution It is possible to create multiple named ranges with the same name. Creating 
multiple ranges with a single command increases the likelihood that multiple 
ranges will be created with the same name—avoid this if possible.

Database range
Although a database range can be used as a regular named range, a database range also defines 
a range of cells in a spreadsheet to be used as a database. Each row in a range corresponds to a 
record and each cell corresponds to a field. You can sort, group, search, and perform calculations 
on the range as if it were a database.
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A database range provides behavior that is useful when performing database related activities. For 
example, you can mark the first row as headings. To create, modify, or delete a database range, 
use Data > Define Range to open the Define Data Range dialog (see Figure 304). When you first 
define a range, the Modify button shown in the example is labeled New.

Figure 304: Define a database range

In a macro, a database range is accessed, created, and deleted from the DatabaseRanges 
property. The macro in Listing 13 creates a database range named MyName and sets the range to 
be used as an auto filter.

Listing 13. Create a database range and an auto filter.

Sub AddNewDatabaseRange()
  Dim oRange 'DatabaseRange object.
  Dim oAddr  'Cell address range for the database range.
  Dim oSheet 'First sheet, which will contain the range.
  Dim oDoc   'Reference ThisComponent with a shorter name.

  oDoc = ThisComponent
  If NOT oDoc.DatabaseRanges.hasByName("MyName") Then
    oSheet = ThisComponent.getSheets().getByIndex(0)
    oRange = oSheet.getCellRangeByName("A1:F10")
    oAddr = oRange.getRangeAddress()
    oDoc.DatabaseRanges.addNewByName("MyName", oAddr)
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  End If
  oRange = oDoc.DatabaseRanges.getByName("MyName")
  oRange.AutoFilter = True
End Sub

Sorting

The sorting mechanism in a Calc document rearranges the data in the sheet. The first step in 
sorting data is to select the data that you want to sort. To sort the data in Table 9, select the cells 
from A1 to G16—if you include the column headers, indicate this in the sort dialog (see Figure 
306). Use Data > Sort to open the Sort dialog (see Figure 305). You can sort by up to three 
columns or rows at a time.

Figure 305: Sort by the Name column

Click on the Options tab (see Figure 306) to set the sort options. Check the Range contains 
column labels checkbox to prevent column headers from being sorted with the rest of the data. 
The Sort by list box in Figure 305 displays the columns using the column headers if the Range 
contains column labels checkbox in Figure 306 is checked. If the Range contains column 
labels checkbox is not checked, however, then the columns are identified by their column name; 
Column A, for example.

Normally, sorting the data causes the existing data to be replaced by the newly sorted data. The 
Copy sort results to checkbox, however, causes the selected data to be left unchanged and a 
copy of the sorted data is copied to the specified location. You can either directly enter a target 
address (Sheet3.A1, for example) or select a predefined range.

Check the Custom sort order checkbox to sort based on a predefined list of values. To set your 
own predefined lists, use Tools > Options > LibreOffice Calc > Sort Lists and then enter your 
own sort lists. Predefined sort lists are useful for sorting lists of data that should not be sorted 
alphabetically or numerically. For example, sorting days based on their name.
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Caution 

When a cell is moved during a sort operation, external references to that cell are 
not updated. If a cell that contains a relative reference to another cell is moved, the
reference is relative to the new position when sorting is finished. Know the 
behavior of references during sorting and do not be alarmed; this is almost always 
what you want—because the reference is to the right or left in the same row. Also, 
we have not found a spreadsheet program that exhibits a different behavior for 
references while sorting.

Figure 306: Set sort options

Filters

Use filters to limit the visible rows in a spreadsheet. Generic filters, common to all sorts of data 
manipulations, are automatically provided by the auto filter capability. You can also define your own
filters.

Caution 
After applying a filter, some rows are visible and some rows are not. If you select 
multiple rows in one operation, you will also select the invisible rows contained 
between the selected visible rows. Operations, such as delete, act on all of the 
selected rows. To avoid this problem, you must individually select each of the 
filtered rows using the control key.
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Auto filters
Use auto filters to quickly create easily accessible filters commonly used in many different types of 
applications. After creating an auto filter for a specific column, a combo box is added to the column.
The combo box provides quick access to each of the auto filter types.

• The All auto filter causes all rows to be visible.

• The Standard auto filter opens the Standard Filter dialog and is the same as the standard 
filter.

• The Top 10 auto filter displays the ten rows with the largest value. If the value 70 is in the 
top ten values, then all rows containing the value 70 in the filtered column are displayed. In 
other words, more than ten rows may be displayed.

• An auto filter entry is created for each unique entry in the column.

To create an auto filter, first select the columns to filter. For example, using the data in Table 9, 
select data in columns B and C. If you do not select the title rows, Calc asks if the title row or the 
current row should be used. Although you can place the auto filter in any row, only the rows below 
the auto filter are filtered. Use Data > Filter > AutoFilter to insert the auto filter combo box in the 
appropriate cell. Finally, use the drop-down arrow to choose an appropriate auto filter (Figure 307).

Figure 307: Use an auto filter with column C

Remove an auto filter by repeating the steps to create the auto filter—in other words, the menu 
option acts as a toggle to turn the auto filter on and off. When an auto filter is removed, the combo 
box is removed from the cell. The macro in Listing 13 demonstrates creating an auto filter for a 
range.

Standard filters
Use Data > Filter > Standard Filter to open Standard Filter dialog (see Figure 308) and limit the 
view based on 1 to 3 filter conditions. Use Data > Filter > Remove Filter to turn off the filter.
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Figure 308: Use the standard filter

The macro in Listing 14 creates a simple filter for the first sheet.

Listing 14. Create a simple sheet filter.

Sub SimpleSheetFilter()
  Dim oSheet       ' Sheet that will contain the filter.
  Dim oFilterDesc  ' Filter descriptor.
  Dim oFields(0) As New com.sun.star.sheet.TableFilterField
  
  oSheet = ThisComponent.getSheets().getByIndex(0)
  
  REM If argument is True, creates an empty filter
  REM descriptor. If argument is False, create a 
  REM descriptor with the previous settings.
  oFilterDesc = oSheet.createFilterDescriptor(True)
  
  With oFields(0)
    REM You could use the Connection property to indicate
    REM how to connect to the previous field. This is
    REM the first field, so this is not required.
    '.Connection = com.sun.star.sheet.FilterConnection.AND
    '.Connection = com.sun.star.sheet.FilterConnection.OR

    REM The Field property is the zero based column
    REM number to filter. If you have the cell, you
    REM can use .Field = oCell.CellAddress.Column.
    .Field = 5

    REM Compare using a numeric or a string?
    .IsNumeric = True
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    REM The NumericValue property is used 
    REM because .IsNumeric = True from above.
    .NumericValue = 80

    REM If IsNumeric was False, then the 
    REM StringValue property would be used.
    REM .StringValue = "what ever"

    REM Valid operators include EMPTY, NOT_EMPTY, EQUAL,
    REM NOT_EQUAL, GREATER, GREATER_EQUAL, LESS,
    REM LESS_EQUAL, TOP_VALUES, TOP_PERCENT,
    REM BOTTOM_VALUES, and BOTTOM_PERCENT
    .Operator = com.sun.star.sheet.FilterOperator.GREATER_EQUAL
  End With
  
  REM The filter descriptor supports the following
  REM properties: IsCaseSensitive, SkipDuplicates,
  REM UseRegularExpressions, 
  REM SaveOutputPosition, Orientation, ContainsHeader, 
  REM CopyOutputData, OutputPosition, and MaxFieldCount.
  oFilterDesc.setFilterFields(oFields())
  oFilterDesc.ContainsHeader = True
  oSheet.filter(oFilterDesc)
End Sub

When a filter is applied to a sheet, it replaces any existing filter for the sheet. Setting an empty filter
in a sheet will therefore remove all filters for that sheet (see Listing 15).

Listing 15. Remove the current sheet filter.

Sub RemoveSheetFilter()
  Dim oSheet          ' Sheet to filter.
  Dim oFilterDesc     ' Filter descriptor.
  
  oSheet = ThisComponent.getSheets().getByIndex(0)
  oFilterDesc = oSheet.createFilterDescriptor(True)
  oSheet.filter(oFilterDesc)
End Sub

Listing 16 demonstrates a more advanced filter that filters two columns and uses regular 
expressions. Some unexpected behavior occurred while working with Listing 16. Although you can 
create a filter descriptor using any sheet cell range, the filter applies to the entire  sheet.

Listing 16. A simple sheet filter using two columns.

Sub SimpleSheetFilter_2()
  Dim oSheet          ' Sheet to filter.
  Dim oRange          ' Range to be filtered.
  Dim oFilterDesc     ' Filter descriptor.
  Dim oFields(1) As New com.sun.star.sheet.TableFilterField
  
  oSheet = ThisComponent.getSheets().getByIndex(0)
  oRange = oSheet.getCellRangeByName("E12:G19")
  
  REM If argument is True, creates an 
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  REM empty filter descriptor.
  oFilterDesc = oRange.createFilterDescriptor(True)

  REM Setup a field to view cells with content that 
  REM start with the letter b.
  With oFields(0)   
    .Field = 0              ' Filter column A.
    .IsNumeric = False      ' Use a string, not a number.
    .StringValue = "b.*"    ' Everything starting with b.
    .Operator = com.sun.star.sheet.FilterOperator.EQUAL
  End With
  REM Setup a field that requires both conditions and
  REM this new condition requires a value greater or 
  REM equal to 70.
  With oFields(1)
    .Connection = com.sun.star.sheet.FilterConnection.AND
    .Field = 5              ' Filter column F.
    .IsNumeric = True       ' Use a number
    .NumericValue = 70      ' Values greater than 70
    .Operator = com.sun.star.sheet.FilterOperator.GREATER_EQUAL
  End With

  oFilterDesc.setFilterFields(oFields())
  oFilterDesc.ContainsHeader = False
  oFilterDesc.UseRegularExpressions = True
  oSheet.filter(oFilterDesc)
End Sub

Advanced filters
An advanced filter supports up to eight filter conditions, as opposed to the three supported by the 
simple filter. The criteria for an advanced filter is stored in a sheet. The first step in creating an 
advanced filter is entering the filter criteria into the spreadsheet.

1) Select an empty space in the Calc document. The empty space may reside in any sheet in 
any location in the Calc document.

2) Duplicate the column headings from the area to be filtered into the area that will contain the
filter criteria.

3) Enter the filter criteria underneath the column headings (see Table 12). The criterion in 
each column of a row is connected with AND. The criteria from each row are connected 
with OR.

Table 12: Example advanced filter criteria

Name Test 1 Test 2 Quiz 1 Quiz 2 Average Grade

="Andy" >80

<80

Tip
Define named ranges to reference your advanced filter criteria and any destination 
ranges for filtered data (see Figure 302). Each appropriately configured named range 
is available in drop down list boxes in the Advanced Filter dialog (see Figure 309).
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After creating one or more sets of filter criteria, apply an advanced filter as follows:

1) Select the sheet ranges that contain the data to filter.

2) Use Data > Filter > Advanced Filter to open the Advanced Filter dialog (see Figure 309).

3) Select the range containing the filter criteria and any other relevant options. Click OK.

Applying an advanced filter using a macro is simple (see Listing 17). The cell range containing the 
filter criteria is used to create a filter descriptor, which is then used to filter the range containing the 
data.

Figure 309. Apply an advanced filter using a previously defined named range

Listing 17. Use an advanced filter.

Sub UseAnAdvancedFilter()
  Dim oSheet     'A sheet from the Calc document.
  Dim oRanges    'The NamedRanges property.
  Dim oCritRange 'Range that contains the filter criteria.
  Dim oDataRange 'Range that contains the data to filter.
  Dim oFiltDesc  'Filter descriptor.

  REM Range that contains the filter criteria
  oSheet = ThisComponent.getSheets().getByIndex(1)
  oCritRange = oSheet.getCellRangeByName("A1:G3")

  REM You can also obtain the range containing the 
  REM filter criteria from a named range.
  REM oRanges = ThisComponent.NamedRanges
  REM oRange = oRanges.getByName("AverageLess80")
  REM oCritRange = oRange.getReferredCells()

  REM The data that you want to filter
  oSheet = ThisComponent.getSheets().getByIndex(0)
  oDataRange = oSheet.getCellRangeByName("A1:G16")

  oFiltDesc = oCritRange.createFilterDescriptorByObject(oDataRange)
  oDataRange.filter(oFiltDesc)
End Sub

Change properties on the filter descriptor to change the behavior of the filter (see Table 13).
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The filter created in Listing 17 filters the data in place. Modify the OutputPosition property to 
specify a different output position (see Listing 18). The filter descriptor must be modified before the 
filter is applied.

Table 13: Advanced filter properties.

Property Comment

ContainsHeader
Boolean (true or false) that specifies if the first row (or column) 
contains headers which should not be filtered.

CopyOutputData
Boolean that specifies if the filtered data should be copied to another 
position in the document.

IsCaseSensitive
Boolean that specifies if the case of letters is important when 
comparing entries.

Orientation
Specifies if columns 
(com.sun.star.table.TableOrientation.COLUMNS) or rows 
(com.sun.star.table.TableOrientation.ROWS) are filtered.

OutputPosition
If if CopyOutputData is True , specifies the position where filtered 
data are to be copied.

SaveOutputPosition
Boolean that specifies if the OutputPosition position is saved for 
future calls.

SkipDuplicates Boolean that specifies if duplicate entries are left out of the result.

UseRegularExpressions
Boolean that specifies if the filter strings are interpreted as regular 
expressions.

Listing 18. Copy filtered results to a different location.

  REM Copy the output data rather than filter in place.
  oFiltDesc.CopyOutputData = True

  REM Create a CellAddress and set it for Sheet3,
  REM Column B, Row 4 (remember, start counting with 0)
  Dim x As New com.sun.star.table.CellAddress
  x.Sheet = 2
  x.Column = 1
  x.Row = 3
  oFiltDesc.OutputPosition = x

(Advanced material.) The OutputPosition property returns a copy of a struct. Because a copy is 
returned, it is not possible to set the individual values directly. For example, 
oFiltDesc.OutputPosition.Row = 2 does not work (because you set the Row on the copy to 2, but 
do not change the original).

Manipulating filtered data
Filtered data copied to a new location may be selected, modified, and deleted at will. Data that is 
not copied, however, requires special attention because rows that do not match the filter criteria 
are simply hidden. LibreOffice behaves differently depending on how the cells became hidden and 
what operation is done.

Cells may be hidden using an outline, data filter, or the hide command. When data is moved by 
dragging or using cut and paste, all of the cells are moved—including the hidden cells. When 
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copying data, however, filtered data includes only the visible cells and data hidden using an outline 
or the hide command copies all of the data.

Calc functions similar to database functions

Although every Calc function can be used for database manipulation, the functions in Table 14 are 
more commonly used as such. Some functions’ names differ only by the letter appended at the 
end; AVERAGE and AVERAGEA, for example. Functions that do not end with the letter A operate 
only on numeric values and cells that contain text or are empty are ignored. The corresponding 
function whose name ends with the letter A, treats text values as a number with the value of zero; 
blank cells are still ignored.

Table 14: Functions frequently used as database functions.

Function Description

AVERAGE Return the average. Ignore empty cells and cells that contain text.

AVERAGEA Return the average. The value of text is 0 and empty cells are ignored.

COUNT Count the number of numeric entries; text entries are ignored.

COUNTA Count the number of non-empty entries.

COUNTBLANK Return the number of empty cells. 

COUNTIF Return the number of cells that meet the search criteria.

HLOOKUP Search for a specific value across the columns in the first row of an array. 
Return the value from a different row in the same column.

INDEX Return the content of a cell, specified by row and column number or an 
optional range name.

INDIRECT Return the reference specified by a text string.

LOOKUP Return the contents of a cell either from a one-row or one-column range or 
from an array.

MATCH Search an array and return the relative position of the found item.

MAX Return the maximum numeric value in a list of arguments.

MAXA Return the maximum numeric value in a list of arguments. The value of text 
is 0.

MIN Return the minimum numeric value in a list of arguments.

MINA Return the minimum numeric value in a list of arguments. The value of text 
is 0.

MEDIAN Return the median of a set of numbers.

MODE Return the most common value in a data set. If there are several values with
the same frequency, it returns the smallest value. An error occurs when a 
value doesn’t appear twice.

OFFSET Return the value of a cell offset by a certain number of rows and columns 
from a given reference point.

PRODUCT Return the product of the cells.

STDEV Estimate the standard deviation based on a sample.
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Function Description

STDEVA Estimate the standard deviation based on a sample. The value of text is 0.

STDEVP Calculate the standard deviation based on the entire population.

STDEVPA Calculate the standard deviation based on the entire population. The value 
of text is 0.

SUBTOTAL Calculate a specified function based on a subset created using AutoFilters.

SUM Return the sum of the cells.

SUMIF Calculate the sum for the cells that meet the search criteria.

VAR Estimate the variance based on a sample.

VARA Estimate the variance based on a sample. The value of text is 0.

VARP Estimate the variance based on the entire population.

VARPA Estimate the variance based on the entire population. The value of text is 0.

VLOOKUP Search for a specific value across the rows in the first column of an array. 
Returns the value from a different column in the same row.

Most of the functions in Table 14 require no explanation, either because they are well understood 
(SUM, for example) or because if you need to use them then you know what they are (STDEV, for 
example). Unfortunately, some of the more useful functions are infrequently used because they are
not well understood.

Count and sum cells that match conditions: COUNTIF and SUMIF
The COUNTIF and SUMIF functions calculate their values based on search criteria. The search 
criteria can be a number, expression, text string, or even a regular expression. The search criteria 
can be contained in a referenced cell or it can be included directly in the function call.

The COUNTIF function counts the number of cells in a range that match specified criteria. The first 
argument to COUNTIF specifies the range to search and second argument is the search criteria.
Table 15 illustrates different search criteria using the COUNTIF function referencing the data 
shown in Table 9.

The first two arguments for SUMIF serve the same purpose as the arguments for COUNTIF; the 
range that contains the cells to search and the search criteria. The third and final argument for 
SUMIF specifies the range to sum. For each cell in the search range that matches the search 
criteria, the corresponding cell in the sum range is added into the sum.

Table 15: Examples of search criteria for the COUNTIF and SUMIF functions.

Criteria Type Function Result Description

Number =COUNTIF(B1:C16; 95) 3 Finds numeric values of 95.

Text =COUNTIF(B1:C16; "95") 3 Finds numeric or text values
of 95.

Expression =COUNTIF(B1:C16; ">95") 6 Finds numeric values 
greater than 95.

Expression =COUNTIF(B1:C16; 2*45+5) 3 Finds only numeric values 
of 95.
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Criteria Type Function Result Description

Regular 
expression

=COUNTIF(B1:C16; "9.*") 12 Finds numbers or text that 
start with 9.

Reference a cell =COUNTIF(B1:C16; B3) 3 Finds a number or number 
and text depending on the 
data type in cell B3.

Regular 
expression

=SUMIF(A1:A16; "B.*"; B1:B16) 227 Sum Column B for names in
Col. A  starting with the 
letter B.

Ignore filtered cells using SUBTOTAL
The SUBTOTAL function applies a function (see Table 16) to a range of data, but it ignores cells 
hidden by a filter and cells that already contain a SUBTOTAL. For example, =SUBTOTAL(2, 
"B2:B16") counts the number of cells in B2:B16 that are not hidden by a filter. 

Table 16: Function index for the SUBTOTAL function.

Function index Function

1 AVERAGE

2 COUNT

3 COUNTA

4 MAX

5 MIN

6 PRODUCT

7 STDEV

8 STDEVP

9 SUM

10 VAR

11 VARP

Tip

Do not forget that the SUBTOTAL function ignores cells that use the SUBTOTAL 
function. Say you have a spreadsheet that tracks investments. The retirement 
investments are grouped together with a subtotal. The same is true of regular 
investments. You can use a single subtotal that includes the entire range without 
worrying about the subtotal cells.

Using formulas to find data
Calc offers numerous methods to find data in a sheet. For example, after setting up a simple or 
advanced search in Edit > Find & Replace, you can click on Find repeatedly to move the display 
cursor to the next instance. To limit what is displayed rather than simply moving the cursor, use 
Data > Filter. Calc also offers lookup functions used in formulas, for example a formula to look up 
a student’s grade based on their test score.
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Search a block of data using VLOOKUP
Use VLOOKUP to search the first column (columns are vertical) of a block of data and return the 
value from another column in the same row. For example, search the first column for the name 
“Fred” and then return the value in the cell two columns to the right. VLOOKUP supports two 
forms:

VLOOKUP(search_value; search_range; return_column_index)
VLOOKUP(search_value; search_range; return_column_index; sort_order)

The first argument, search_value, identifies the value to find. The search value can be text, a 
number, or a regular expression. For example, Fred searches for the text Fred, 4 searches for the 
number 4, and F.* is the regular expression for finding something that starts with the letter F.

The second argument, search_range, identifies the cells to search; only the first column is 
searched. For example, B3:G10 searches the same sheet containing the VLOOKUP formula and 
Sheet2.B3:G10 searches the range B3:G10 on the sheet named Sheet2.

The return_column_index identifies the column to return; a value of 1 returns the first column 
in the range. The statement =VLOOKUP("Bob"; A1:G9; 1) finds the first row in A1:G9 
containing the text Bob, and returns the value in the first column. The first column is the searched 
column, so the text Bob is returned. If the column index is 2, then the value in the cell to the right 
of Bob is returned: column B.

The final column, sort_order, is optional. The default value for sort_order is 1, which 
specifies that the first column is sorted in ascending order; a value of 0 specifies that the data is 
not sorted. A non-sorted list is searched by sequentially checking every cell in the first column for 
an exact match. If an exact match is not found, the text #N/A is returned.

A more efficient search routine is used if the data is sorted in ascending order. If one exact match 
exists, the returned value is the same as for a non-sorted list; but it is faster. If a match does not 
exist, the largest value in the column that is less than or equal to the search value is returned. For 
example, searching for 7 in (3, 5, 10) returns 5 because 7 is between 5 and 10. Searching for 27 
returns 10, and searching for 2 returns #N/A because there is no match and no value less than 2.

Use VLOOKUP when:

• The data is arranged in rows and you want to return data from the same row. For example, 
student names with test and quiz scores to the right of the student’s name.

• Searching the first column of a range of data.

Search a block of data using HLOOKUP
Use HLOOKUP to search the first row (rows are horizontal) of a block of data and return the value 
from a row in the same column. HLOOKUP supports the same form and arguments as VLOOKUP:

HLOOKUP(search_value; search_range; return_row_index)
HLOOKUP(search_value; search_range; return_row_index; sort_order)

Use HLOOKUP when:

• The data is arranged in columns and you want to return data from the same column. For 
example, student names with test and quiz scores underneath the student’s name.

• Searching the first row of a range of data.

Search a row or column using LOOKUP
LOOKUP is similar to HLOOKUP and VLOOKUP. The search range for the LOOKUP function is a 
single sorted row or column. LOOKUP has two forms:

LOOKUP(search_value; search_range)
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LOOKUP(search_value; search_range; return_range)

The search value is the same as HLOOKUP and VLOOKUP. The search range, however, must be 
a single row or a single column; for example, A7:A12 (values in column A) or C5:Q5 (values in row 
5). If the return_range is omitted, the matched value is returned.  Using LOOKUP without a return 
range is the same as using HLOOKUP or VLOOKUP with a column index of 1.

The return range must be a single row or column containing the same number of elements as the 
search range. If the search value is found in the fourth cell in the search range, then the value in 
the fourth cell in the return range is returned. The return range can have a different orientation than
the search range. In other words, the search range can be a row and the return range may be a 
column.

Use LOOKUP when:

• The search data is sorted in ascending order.

• The search data is not stored in the same row, column, or orientation as the return data.

Use MATCH to find the index of a value in a range
Use MATCH to search a single row or column and return the position that matches the search 
value. Use MATCH to find the index of a value in a range. The supported forms for MATCH are as 
follows:

=MATCH(search_value; search_range)
=MATCH(search_value; search_range; search_type)

The search value and search range are the same as for LOOKUP. The final argument, search 
type, controls how the search is performed. A search type of 1, sorted in ascending order, is the 
default. A search type of -1 indicates that the list is sorted in descending order. A search type of 0 
indicates that the list is not sorted. Regular expressions can only be used on an unsorted list.

Use MATCH when:

• You need an index into the range rather than the value.

• The search data is in descending order and the data is large enough that the data must be 
searched assuming that it is sorted; because it is faster to sort a sorted list.

Examples
Consider the data in Table 9. Each student’s information is stored in a single row. Write a formula 
to return the average grade for Fred. The problem can be restated as Search column A in the 
range A1:G16 for Fred and return the value in column F (column F is the sixth column). The 
obvious solution is =VLOOKUP("Fred"; A2:G16; 6). Equally obvious is 
=LOOKUP("Fred"; A2:A16; F2:F16).

It is common for the first row in a range to contain column headers. All of the search functions 
check the first row to see if there is a match and then ignore it if it does not contain a match, in 
case the first row is a header.

What if the column heading Average is known, but not the column containing the average? Find 
the column containing Average rather than hard coding the value 6. A slight modification using 
MATCH to find the column yields  
=VLOOKUP("Fred"; A2:G16; MATCH("Average"; A1:G1; 0)); notice that the heading is 
not sorted. As an exercise, use HLOOKUP to find Average and then MATCH to find the row 
containing Fred.

As a final example, write a formula to assign grades based on a student’s average score. Assume 
that a score less than 51 is an F, less than 61 is an E, less than 71 is a D, less than 81 is a C, less 
than 91 is a B, and 91 to 100 is an A. Assume that the values in Table 17 are in Sheet2.
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The formula =VLOOKUP(83; $Sheet2.$A$2:$B$7; 2) is an obvious solution. Dollar signs are 
used so that the formula can be copied and pasted to a different location and it will still reference 
the same values in Table 17.

Table 17: Associate scores to a grade.

A B

1 Score Grade

2 0 F

3 51 E

4 61 D

5 71 C

6 81 B

7 91 A

ADDRESS returns a string with a cell’s address
Use ADDRESS to return a text representation of a cell address based on the row, column, and 
sheet; ADDRESS is frequently used with MATCH. The supported forms for ADDRESS are as 
follows:

ADDRESS(row; column)
ADDRESS(row; column; abs)
ADDRESS(row; column; abs; sheet)

The row and column are integer values where ADDRESS(1; 1) returns $A$1. The abs argument 
specifies which portion is considered absolute and which portion is considered relative (see Table 
18); an absolute address is specified using the $ character. The sheet is  included as part of the 
address only if the sheet argument is used. The sheet argument is treated as a string. Using 
ADDRESS(MATCH("Bob";A1:A5 ; 0); 2) with the data in Table 17 returns $B$2.

Tip
Calc supports numerous powerful functions that are not discussed here. For example, 
the ROW, COLUMN, ROWS, and COLUMNS statements are not discussed; a curious 
person would investigate these functions.

Table 18: Values supported by the abs argument to ADDRESS.

Value Description

1 Use absolute addressing. This is the default value if the argument is missing or an 
invalid value is used. ADDRESS(2; 5; 1) returns $E$2.

2 Use an absolute row reference and a relative column reference. ADDRESS(2; 5; 2;
"Blah") returns Blah.E$2.

3
Use a relative row reference and an absolute column reference. ADDRESS(2; 5; 3) 
returns $E2.

4 Use relative addressing. ADDRESS(2; 5; 4) returns E2.
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INDIRECT converts a string to a cell or range
Use INDIRECT to convert a string representation of a cell or range address to a reference to the 
cell or range. Table 19 contains examples accessing data as shown in Table 17.

Table 19: Examples using INDIRECT.

Example Comment

INDIRECT("A2") Returns cell A2, which contains Bob.

INDIRECT(G1) If Cell G1 contains the text A2, then this returns Bob.

SUM(INDIRECT("B1:B5")) Returns the sum of the range B1:B5, which is 194.

INDIRECT(ADDRESS(2; 1)) Returns the contents of cell $A$2, which is Bob.

OFFSET returns a cell or range offset from another
Use OFFSET to return a cell or range offset by a specified number of rows and columns from a 
given reference point. The first argument, specifies the reference point. The second and third 
arguments specify the number of rows and columns to move from the reference point; in other 
words, where the new range starts. The OFFSET function has the following syntax:

OFFSET(reference; rows; columns)
OFFSET(reference; rows; columns; height)
OFFSET(reference; rows; columns; height; width)

Tip
If the width or height is included, the OFFSET function returns a range. If both the 
width and height are missing, a cell reference is returned.

If the height or width are missing, they default to 1. If the height is present, then a range reference 
is returned rather than a cell reference. Using values from Table 9, Listing 19 uses OFFSET to 
obtain the quiz scores for the student named Bob.

Listing 19. Complex example of OFFSET.

=SUM(OFFSET(INDIRECT(ADDRESS(MATCH("Bob";A1:A16; 0); 4)); 0; 0; 1; 2))

In its entirety, Listing 19 is complex and difficult to understand. Table 20 isolates each function in
Listing 19, providing an easy to understand explanation of how the example works.

Table 20: Breakdown of Listing 19.

Function Description

MATCH("Bob";A1:A16; 0) Return 4 because Bob is the fourth entry in column A.

ADDRESS(4; 4) Return $D$4.

INDIRECT("$D$4") Convert $D$4 into a reference to the cell D4.

OFFSET($D$4; 0; 0; 1; 2) Return the range D4:E4.

SUM(D4:E4) Return the sum of Bob’s quiz scores.

Although Listing 19 works as intended, it breaks easily and unexpectedly. Consider, for example, 
what happens if the range is changed to A2:A16. MATCH returns an offset into the provided range,
so MATCH("Bob";A2:A16 ; 0) returns 3 rather than 4. ADDRESS(3; 4) returns $D$3 rather 
than $D$4 and Betty’s quiz scores are returned instead of Bob’s. Listing 20 uses a slightly different 
method to obtain Bob’s quiz scores.
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Listing 20. Better use of OFFSET.

=SUM(OFFSET(A1; MATCH("Bob"; A1:A16; 0)-1; 3; 1; 2))

Table 21 contains a description of each function used in Listing 20. To help convince yourself that
Listing 20 is better than Listing 19, replace A1 with A2 in both Listing 20 and Table 21 and notice 
that you still obtain Bob’s quiz scores.

Table 21: Breakdown of Listing 20.

Function Description

MATCH("Bob";A1:A16; 0)-1 Return 3 because Bob is the fourth entry in column A.

OFFSET(A1; 3; 3; 1; 2) Return the range D4:E4.

SUM(D4:E4) Return the sum of Bob’s quiz scores.

Tip The first argument to OFFSET can be a range so you can use a defined range name.

INDEX returns cells inside a specified range
INDEX returns the cells specified by a row and column number. The row and column number are 
relative to the upper left corner of the specified reference range. For example, using  
=INDEX(B2:D3; 1; 1) returns the cell B2. Table 22 lists shows the syntax for using the INDEX 
function.

Table 22: Syntax for INDEX.

Syntax Description

INDEX(reference) Return the entire range.

INDEX(reference; row) Return the specified row in the range.

INDEX(reference; row; column) Return the cell specified by row and column. A row and 
column of 1 returns the cell in the upper left corner of the 
range.

INDEX(reference; row; column; 
range)

A reference range can contain multiple ranges. The range 
argument specifies which range to use.

The INDEX function can return an entire range, a row, or a single column (see Table 22). The 
ability to index based on the start of the reference range provides some interesting uses. Using the
values shown in Table 9, Listing 21 finds and returns Bob’s quiz scores. Table 23 contains a listing 
of each function used in Listing 21.

Listing 21. Return Bob’s quiz scores.

=SUM(OFFSET(INDEX(A2:G16; MATCH("Bob"; A2:A16; 0)); 0; 3; 1; 2))

Table 23: Breakdown of Listing 21.

Function Description

MATCH("Bob";A2:A16; 0) Return 3 because Bob is the third entry in column A2:A16.

INDEX(A2:A16; 3) Return A4:G4—the row containing Bob’s quiz scores.

OFFSET(A4:G4; 0; 3; 1; 2) Return the range D4:E4.

SUM(D4:E4) Return the sum of Bob’s quiz scores.
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Tip
A simple range contains one contiguous rectangular region of cells. It is possible to 
define a multi-range that contains multiple simple ranges. If the reference consists of 
multiple ranges, you must enclose the reference or range name in parentheses.

If reference argument to the INDEX function is a multi-range, then the range argument specifies 
which simple range to use (see Table 24).

Table 24: Using INDEX with a multi-range.

Function Returns

=INDEX(B2:G2; 1; 2) 93

=INDEX(B5:G5; 1; 2) 65

=INDEX((B2:G2;B5:G5); 1; 2) 93

=INDEX((B2:G2;B5:G5); 1; 2; 1) 93

=INDEX((B2:G2;B5:G5); 1; 2; 2) 65

Database-specific functions

Although every Calc function can be used for database manipulation, the functions in Table 25 are 
specifically designed for use as a database. The descriptions in Table 25 use the following terms 
interchangeably: row and record, cell and field, and database and all rows.

Table 25: Database functions in a Calc document.

Function Description

DAVERAGE Return the average of all fields that matches the search criteria.

DCOUNT Count the number of records containing numeric data that match the search 
criteria.

DCOUNTA Count the number of records containing text data that match the search criteria.

DGET Return the contents of a field that matches the search criteria.

DMAX Return the maximum content of a field that matches the search criteria.

DMIN Return the minimum content of a field that matches the search criteria.

DPRODUCT Return the product of the fields that matches the search criteria.

DSTDEV Calculate the standard deviation using the fields that match the search criteria. 
The fields are treated as a sample.

DSTDEVP Calculate the standard deviation using the fields that match the search criteria. 
The fields are treated as the entire population.

DSUM Return the sum of all fields that matches the search criteria.

DVAR Calculate the variance using the fields that match the search criteria. The fields 
are treated as a sample.

DVARP Calculatesthe variance using the fields that match the search criteria. The fields 
are treated as the entire population.

The syntax for the database functions are identical.

DCOUNT(database; database field; search criteria)
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The database argument is the cell range that defines the database. The cell range should contain 
the column labels (see Listing 22). The following examples, assume that the data from Table 9 is 
placed in Sheet 1 and the filter criteria in Table 12 is placed in  Sheet 2.

Listing 22. The database argument includes the headers.

=DCOUNT(A1:G16; "Test 2"; Sheet2.A1:G3)

The database field specifies the column on which the function operates after the search criteria is 
applied and the data rows are selected. The database field can be specified using the column 
header name or as an integer. If the column is specified as an integer, 0 specifies the entire data 
range, 1 specifies the first column, 2 specifies the second column, and so on. Listing 23 calculates 
the average test score for the rows that match the search criteria.

Listing 23. “Test 2” is column 3.

=DAVERAGE(A1:G16; "Test 2"; Sheet2.A1:G3)
=DAVERAGE(A1:G16; 3; Sheet2.A1:G3)

The search criteria is the cell range containing search criteria. The search criteria is identical to the 
advanced filters; criteria in the same row is connected by AND and criteria in different rows is 
connected by OR.

Conclusion

A Calc document provides sufficient database functionality to satisfy the needs of most people. The
infrequently used database functions, such as OFFSET and INDEX, are worth the time to learn 
and they can save yourself time in the long run.

Chapter 13  Calc as a Simple Database 345





Chapter 14  
Setting up and Customizing 
Calc



Introduction

This chapter describes some common customizations that you may wish to do. In addition to 
selecting options from those provided, you can customize menus, toolbars, and keyboard 
shortcuts, add new menus and toolbars, and assign macros to events. However, you cannot 
customize context (right-click) menus.

Other customizations are made easy by extensions that you can install from the LibreOffice 
website or from other providers.

Note
Changes to menus and toolbars can be saved in a template. First, save the document 
that was open when these changes were made. Then, save that document as a 
template, as described in Chapter 4, Using Styles and Templates in Calc.

LibreOffice options

This section covers some of the settings that apply to all the components of LibreOffice and are of 
particular interest to users of Calc. Other general options are discussed in Chapter 2, Setting Up 
LibreOffice, in the Getting Started guide.

1) Choose Tools > Options (LibreOffice > Preferences on a Mac) to open the Options 
dialog. The list on the left-hand side of the Options dialog varies depending on which 
LibreOffice component is open. The illustrations in this chapter show the list as it appears 
when Calc is open.

2) Click the expansion symbol (+ or triangle) by LibreOffice on the left-hand side. A list of 
subsections drops down.

Figure 310: Options – LibreOffice – User Data page

Note
The Revert button has the same effect on all pages of the Options dialog. It resets 
the options to the values that were in place when you opened LibreOffice.
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User Data options
User data is used by templates and Wizards in LibreOffice. For example, Calc uses the first and 
last name stored here to fill in the Created and Modified fields in the document properties, the 
optional Author field often used in the footer of a printed spreadsheet, and the name associated 
with comments. If you want your name to appear, then fill in the form on the LibreOffice – User 
Data page (Figure 310). If you are using a version of LibreOffice other than US English, some field 
labels may be different from those shown in the illustration.

Some of the user data is included automatically in an internal dictionary so that it is recognized by 
the spelling checker. If typing errors are made, the program can use this data to suggest 
replacements. Note that changes to data take effect only after LibreOffice is restarted.

Print options
On the LibreOffice – Colors page, you can set the print options to suit your default printer and your 
most common printing method. You can change these settings at any time, either through this 
dialog or during the printing process (by clicking the Options button on the Print dialog).

See Chapter 6, Printing, Exporting, and E-mailing, in this guide for more about these options.

Color options
On the LibreOffice – Colors page, you can specify colors to use in LibreOffice documents. You can 
select a color from a color table, edit an existing color, and define new colors. These colors are 
stored in your color selection palette and are then available in all components of LibreOffice.

Figure 311: Defining colors to use in color palettes in LibreOffice

To modify a color:

1) Select the color to modify from the list or the color table.

2) Enter the new values that define the color. If necessary, change the settings from RGB 
(Red, Green, Blue) to CMYK (Cyan, Magenta, Yellow, Black) or vice versa. The changed 
color appears in the lower of the two color preview boxes at the top.

3) Modify the Name as required.

4) Click the Modify button. The newly defined color is now listed in the Color table.
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Alternatively, click the Edit button to open the Color Picker dialog, shown in Figure 312. Here you 
can select a color from the window on the left, or you can enter values on the right using your 
choice of RGB, CMYK, or HSB (Hue, Saturation and Brightness) values.

The color window on the left is linked directly with the color input fields on the right; as you choose 
a color in the window, the numbers change accordingly. The color field at the lower left shows the 
value of the selected color on the left and the currently set value from the color value fields on the 
right.

Figure 312: Editing colors

Modify the color components as required and click OK to exit the dialog. The newly defined color 
now appears in the lower of the color preview boxes shown in Figure 319. Type a name for this 
color in the Name box, then click the Add button. A small box showing the new color is added to 
the Color table.

Another way to define or alter colors is through the Colors page of the Area dialog, where you can 
also save and load palettes, a feature that is not possible here. In Calc, draw a temporary draw 
object and use the context menu of this object to open the Area dialog. If you load a palette in one 
component of LibreOffice, it is only active in that component; the other components keep their own 
palettes.

Security options
Use the LibreOffice – Security page to choose security options for saving documents and for 
opening documents that contain macros.

Security options and warnings
If you record changes, save multiple versions, or include hidden information or notes in your 
documents, and you do not want some of the recipients to see that information, you can set 
warnings to remind you to remove this information, or you can have LibreOffice remove some 
information automatically. Note that (unless removed) much of this information is retained in a 
file whether the file is in LibreOffice’s default OpenDocument format, or has been saved to 
other formats, including PDF.

Click the Options button to open a separate dialog with specific choices (Figure 314).
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Figure 313: Choosing security options for opening and saving documents

Passwords for web connections
LibreOffice can save any passwords associated with websites opened by clicking on a 
hyperlink. If you choose Persistently save passwords for web connections, LibreOffice will 
securely store all passwords that you use to access files from web servers. 

If you also set a master password, individual passwords can be accessed only after the master 
password has been entered. To set a master password, select the Protected by a master 
password option and click the Master Password button.

Macro security
Click the Macro Security button to open the Macro Security dialog (not shown here), where 
you can adjust the security level for executing macros and specify trusted sources.

Certificate Path

Note
This option appears only on Linux and Mac systems. On Windows, LibreOffice uses 
the default Windows location for storing and retrieving certificates.

Users can digitally sign documents using LibreOffice. A digital signature requires a personal 
signing certificate. Most operating systems can generate a self-signed certificate. However, a 
personal certificate issued by an outside agency (after verfiying an individual's identity) has a 
higher degree of trust associated with it than does a self-signed certificate. LibreOffice does not
provide a secure method of storing these certificates, but it can access certificates that have 
been saved using other programs. Click Certificate and select which certificate store to use.

Security options and warnings
The following options are on the Security options and warnings dialog (Figure 327).

Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file. To 
manually remove personal information from specific documents, deselect this option and then 
use the Delete button under File > Properties > General.
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Ctrl-click required to follow hyperlinks
The default behavior in most components of LibreOffice is to Ctrl+click on a hyperlink to open 
the linked document, but you can choose to open hyperlinks using a single click. However, 
Calc opens hyperlinks using a single click, regardless of the selection for this option.

The other options on this dialog should be self-explanatory.

Figure 314: Security options and warnings dialog

Appearance options
On the LibreOffice – Appearance page, you can specify which items are visible and the colors 
used to display various elements of the user interface. These colors are not printed when you print
a spreadsheet.

Figure 315: Changing the color of grid points in Calc
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Scroll down the list until you find the section headed Spreadsheet. To change the default color for 
grid lines or other on-screen indicators, click the down-arrow by the color and select a new color 
from the drop-down list.

If you wish to save your color changes as a color scheme, click Save, type a name in the Name of 
color scheme box in the pop-up dialog, and then click OK.

Loading and saving documents

You can set the Load/Save options to suit the way you work. This chapter describes only a few of 
the options, those most relevant to working with Calc. See Chapter 2, Setting Up LibreOffice, in the
Getting Started guide for a description of the other options.

If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or 
triangle) by Load/Save on the left-hand side to display the list of load/save options pages.

Figure 316: Load/Save options

General
Many of the choices on the Load/Save – General page (Figure 317) are familiar to users of other 
office suites. Those of most interest to Calc users are in the Default file format and ODF settings 
section. See Chapter 2, Setting Up LibreOffice, in the Getting Started guide for information about 
other options.

ODF format version
LibreOffice by default saves documents in OpenDocument Format (ODF) version 1.2 
Extended. While this allows for improved functionality, there may be backwards compatibility 
issues. When a file saved in ODF 1.2 Extended is opened in an editor that uses an earlier 
version of ODF (1.0/1.1), some of the advanced features may be lost. Two notable examples 
are cross-references to headings and the formatting of numbered lists. If you plan to share 
documents with people who are use editors that use older versions of ODF, you may wish to 
save the document using ODF version 1.0/1.1.

Size optimization for ODF format
LibreOffice documents are XML files. When you select this option, LibreOffice writes the XML 
data without indents and line breaks. If you want to be able to read the XML files in a text editor
in a structured form, deselect this option.

Document type
If you routinely share documents with users of Microsoft Excel, you might want to change the 
Always save as attribute for spreadsheets to one of the Excel formats.

However, we recommend that you always save a working copy in ODS format and only create 
an Excel version if necessary for sharing. Also, note that recent and current versions of 
Microsoft Excel can open ODS files, so this may no longer be needed.
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Figure 317: Choosing Load and Save options

Note
LibreOffice can open and save files in the .xlsx format produced by Microsoft 
Office 2007, 2010, and later.

VBA Properties
On the Load/Save – VBA Properties page, you can choose whether to keep any VBA (Visual Basic
for Applications) macros in Microsoft Office documents that are opened in LibreOffice.

Figure 318: Choosing Load/Save VBA Properties
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Load Basic code 
The original VBA code will be loaded as a disabled LibreOffice Basic module. You can edit the 
code. When saving the document in LibreOffice format, the Basic code is saved as well. When 
the document is saved in another format, the LibreOffice Basic code is not saved.

Executable code
The VBA code will be loaded ready to be executed. If this option is not selected, the VBA code 
will be commented out so it can be inspected, but will not run. As a safety precaution against 
viruses and other malicious code, you may wish to disable the executable code option.

Save original Basic code
A backup copy of the original code, written in Basic, is saved with the document.

Save original Basic code takes precedence over Load Basic code. If both options are selected 
and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved 
when saving in a Microsoft Office format.

To remove any possible macro viruses from the Microsoft Office document, deselect Save 
original Basic code. The document will be saved without the Microsoft Basic code.

Microsoft Office
On the Load/Save – Microsoft Office page, you can choose what to do when importing and 
exporting Microsoft Office OLE objects (linked or embedded objects or documents such as 
spreadsheets or equations).

Figure 319: Choosing Load/Save Microsoft Office options

Select the [L] options to convert Microsoft OLE objects into the corresponding LibreOffice OLE 
objects when a Microsoft document is loaded into LibreOffice (mnemonic: “L” for “load”).

Select the [S] options to convert LibreOffice OLE objects into the corresponding Microsoft OLE 
objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”).

HTML compatibility
Choices made on the Load/Save – HTML Compatibility page (Figure 320) affect HTML pages 
imported into LibreOffice and those exported from LibreOffice. See Chapter 2, Setting up 
LibreOffice, in the Getting Started guide, and HTML documents; importing/exporting in the Help, for
more information.

The main items of interest for Calc users are in the Export section: LibreOffice Basic and Display 
warning.
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Figure 320: Choosing HTML compatibility options

Export - LibreOffice Basic
Select this option to include LibreOffice Basic macros (scripts) when exporting to HTML format. 
You must activate this option before you create the LibreOffice Basic macro; otherwise the 
script will not be inserted. LibreOffice Basic macros must be located in the header of the HTML 
document. Once you have created the macro in the LibreOffice Basic IDE, it appears in the 
source text of the HTML document in the header.

If you want the macro to run automatically when the HTML document is opened, choose Tools 
> Customize > Events. See Chapter 12, Calc Macros, for more information.

Export - Display warning
When the LibreOffice Basic option (see above) is not selected, the Display warning option 
becomes available. If the Display warning option is selected, then when exporting to HTML a 
warning is shown that LibreOffice Basic macros will be lost.

Calc options

Calc must be open in order for the LibreOffice Calc options to be
displayed in the Options dialog. Click the expansion symbol (+ or
triangle) by LibreOffice Calc on the left-hand side. A list of
subsections drops down.
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General options
In the Options dialog, choose LibreOffice Calc > General.

Figure 322: Selecting general options for Calc

Metrics
Choose the unit of measurement used in spreadsheets and the default tab stops distance.

Updating
Choose whether to update links when opening a document always, only on request, or never. 
Regardless of this setting, you can manually update links at any time by selecting Tools > Update 
> Links or pressing F9. Spreadsheets that include many or large charts or graphics may load 
slowly if this option is set to always.

Input settings section

Press Enter to move selection
Specifies that pressing Enter moves the cursor to another cell. If this option is selected, you 
can also choose the direction the cursor moves: up, down, left, or right. If this option is not 
selected, pressing Enter places the data into the cell but does not move the cursor.

Press Enter to switch to edit mode
Specifies that pressing Enter puts the selected cell into edit mode. To end Edit mode and move
the cursor in the desired direction, press Enter again.

Expand formatting
Specifies whether to automatically apply the formatting attributes of an inserted cell to empty 
adjacent cells. If, for example, an inserted cell has the bold attribute, this attribute will also 
apply to empty adjacent cells. However, cells that already have a special format will not be 
modified by this function. To see the affected range, press Ctrl+* (multiplication sign on the 
number pad). The format will also apply to all new values inserted within this range.
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Expand references when new columns/rows are inserted
Specifies whether to expand references when inserting columns or rows adjacent to the 
reference range. This is only possible if the reference range, where the column or row is 
inserted, originally spanned at least two cells in the desired direction.

Example: If the range A1:B1 is referenced in a formula and you insert a new column after 
column B, the reference is expanded to A1:C1. If the range A1:B1 is referenced and a new row 
is inserted under row 1, the reference is not expanded, since there is only a single cell in the 
vertical direction.

If you insert rows or columns in the middle of a reference area, the reference is always 
expanded.

Highlight selection in column/row headings
Specifies whether to highlight column and row headers in the selected columns or rows.

Use printer metrics for text formatting
Select this option to use the properties of the default printer to format the display of a 
spreadsheet. Those properties can be found by choosing File > Printer Settings and then 
select the Properties button for the default printer. If the printer has options for page setup, 
those settings will be applied to Calc documents. If this option is not selected, pages will be 
configured for a generic printer.

Show overwrite warning when pasting data
Pasting contents of the clipboard into a cell will replace the contents of that cell with what is in 
the clipboard. Select this option to be alerted to a possible loss of data when pasting.

Defaults
Enter the number of worksheets to be opened by default when you start a new spreadsheet and 
either accept the default sheet prefix or type a new one. After a spreadsheet has been created, you
can add new sheets and change the label of any tab; see Chapter 1, Introducing Calc, for more 
information.

View options
The options on the LibreOffice Calc – View page (Figure 323) affect the way the document window
looks and behaves when viewed onscreen.

Visual aids section

Grid lines
Grid lines are the borders around the cells of a spreadsheet when viewed onscreen. The 
options are: Show, Show on colored cells, or Hide. If grid lines are hidden, tables will be 
displayed on a solid background with no grid around cells. The color choice overrides the 
selection made in Tools > Options > LibreOffice > Appearance > Spreadsheet > Grid lines.

Note To print grid lines, choose Format > Page > Sheet > Print > Grid.
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Figure 323: Selecting view options for Calc

Page breaks
Specifies whether to view the page breaks within a defined print area.

Helplines While Moving
Specifies whether to view helplines when moving drawings, frames, graphics, and other 
objects. These lines help you align objects.

Figure 324: Helplines visible when moving a graphic
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In Figure 324, the graph with the dark background represents the image in its original location. 
The lighter area represents the position of the image as it is being moved. Helplines are the 
horizontal and vertical dotted lines at the corners of the lighter object.

Objects section
Choose whether to show or hide graphics, charts, and drawing objects.

Zoom section
Select the Synchronize sheets option to apply any selected zoom (magnification) factor to all 
sheets in the spreadsheet. If this option is not selected, separate zoom factors can be applied to 
individual sheets.

Display section
Select various options for the onscreen display.

Formulas
Display the content of a cell as a formula or as the results of that formula.

Zero values
Display a zero in a cell when the cell has a value of zero, or display an empty cell.

Comment indicator
Select this option to show a small triangle in the top right corner of a cell that contains a 
comment. If tips are enabled in Tools > Options > LibreOffice > General, the comment will 
become visible when the mouse pointer hovers over the cell. Tips will appear regardless of the 
setting of this option.

To always display a comment, right-click on the cell and select Show comment from the 
context menu.

Value highlighting
Select this option to highlight all values, or results of formulas, in the sheet. Text is highlighted 
in black; numbers in blue; and formulas, logical values, dates, and so on, in green.

When this command is active, any colors assigned in the document are not displayed.

Anchor
If an inserted object, such as a picture, is anchored to a cell, an image of an anchor will appear 
in the cell to which the object is anchored. 

Text overflow
If a cell contains text that is wider than the width of the cell, the text is displayed over empty 
neighboring cells in the same row. If there is no empty neighboring cell, a small triangle at the 
cell border indicates that the text continues. If this option is selected, text will wrap inside the 
cell and the height of the row will expand to accommodate the hight of the expanded cell.

Show references in color
Select this option to provide a visual aid to assist the editing of a formula. Each reference is 
then highlighted in color in the formula, and the referenced cell range is enclosed by a colored 
border as soon as the cell containing the reference is selected for editing.

Figure 325: Formula references – visual aids
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Window section
The following elements of the spreadsheet window can be made visible or invisible: column and 
row headers, horizontal and vertical scroll bars, sheet tabs, and, if an outline has been defined, 
outline symbols.

If the Sheet tabs option is not selected, you can only switch between the sheets by using the 
Navigator.

Note that there is a slider between the horizontal scrollbar and the sheet tabs that may be set to 
one end.

Figure 326: Window options

Calculate options
Use the LibreOffice Calc – Calculate page to define the calculation settings for spreadsheets.

Figure 327: Calc calculation options
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Iterative references section
Iterative references are formulas that are continuously repeated until the problem is solved. In this 
section you can choose the number of approximation steps carried out during iterative calculations 
and the degree of precision of the answer.

Iterations
Select this option to enable iterations. If this options is not selected, an iterative reference 
causes an error message.

Steps
Sets the maximum number of iteration steps.

Minimum Change
Specifies the difference between two consecutive iteration step results. If the result of the 
iteration is lower than the minimum change value, then the iteration will stop.

Date section
Select the start date for the internal conversion from days to numbers.

12/30/1899 (default) – Sets December 30, 1899 as day zero. In calculations, January 1, 1900 is 
used as day one.

01/01/1900 (StarCalc 1.0) – Sets January 1, 1900 as day zero. Use this setting for StarCalc 1.0 
spreadsheets containing date entries.

01/01/1904 – Sets January 1, 1904 as day zero. Use this setting for spreadsheets that are 
imported from foreign formats.

Other options
Specify a variety of options relevant to spreadsheet calculation.

Case sensitive
Specifies whether to distinguish between upper and lower case in texts when comparing cell 
contents. For example: type 'Test' in cell A1; and 'test' in B1. Then type the formula "=A1=B1" in
cell C1. If the Case sensitive option is checked, FALSE will appear in the cell; if the analysis 
was case insensitive, TRUE will appear in the cell. This option is not applied to the EXACT text 
function, which is always case-sensitive.

Decimal places
Limits the number of decimals to be displayed for numbers with the general number format. 
This overrides the setting applied in Format > Cells > Numbers > Number > General. This 
setting refers to how numbers are displayed. When decimal places are limited, calculations are 
not affected because of rounding.

Precision as shown
The value entered into this field defines the precision used to perform calculations. All numbers
will be rounded to the desired decimal places. Numbers will be displayed according to the 
previous setting but calculations will be less precise because rounded numbers are used in the 
calculations.

Search criteria = and <> must apply to whole cells
The default search method in Calc is to search for any instance of the target regardless of the 
position of the target within a word. For example, when searching for day, Calc will match 
Friday, Sunday, and days. Select this option to search an exact occurence of the target. Wild 
card symbols can be used to expand the search to match the default condition. That is, 
searching for *day* will match Friday, Sunday, and days.
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Enable regular expressions in formulas
Specifies that regular expressions (an extended set of wild cards) are enabled when searching 
and also for character string comparisons. This relates to the database functions, and to 
VLOOKUP, HLOOKUP and SEARCH.

Automatically find column and row labels
Calc will name the range of data, under a column heading or to the right of a row heading, 
using the text in those headings.

Example: Cell E5 contains the text Europe. Below, in cell E6, is the value 100 and in cell E7 the
value 200. If the Automatically find column and row labels option is selected, you can write 
the following formula in cell A1: =SUM(Europe).

Caution

When calculations involve a range that includes an empty cell, take note of the 
setting for Display Zero values in the LibreOffice Calc > View options. If this 
option is not selected, a value of zero will display as an empty cell. Empty cells and 
the value zero are treated differently by many functions. For example, Count would 
not include an empty cell as an item to be counted. The average of eight cells, one 
of which contains the value zero, is not the same as the average of seven cells (an 
empty cell is not included in determining the average).

Formula options
Use the LibreOffice Calc – Formula options page to specify whether to use Calc or Excel syntax, 
as well as choosing which separators you prefer to use in formulas. The separators choices 
override the defaults in Calc and Excel syntax.

Figure 328: Formula options
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Formula options

Formula syntax
Syntax is the format in which formulas are written. Choose the syntax most appropriate for your
work. If you regularly open or save to Microsoft Excel formats, you may wish to use one of the 
Excel syntaxes.

To illustrate the differences between syntaxes, assume a spreadsheet contains two sheets. The
cell C4 can be referenced in three ways:

• Calc A1   =$Sheet2.C4 – the default syntax for Calc.

• Excel A1  =Sheet2!C4 – the default of Microsoft Excel.

• Excel R1C1  =Sheet2!R[3]C[2] – tthe relative row and column addressing used in Excel.

Use English function names
The default names for functions in Calc are those for the user's locale. For English users, the 
localized names are the same as the English names. When the language set by locale is not 
English, you may wish to express functions in English; if so, select this option to change 
formula input and display, function wizard, and formula tips.

Detailed calculation settings
Most users will not need to change the default setting. For custom settings, select Custom and 
click Details to choose reference syntax and whether to treat empty strings as zero.

Separators
Separators are used in functions to distinguish points in the range used in the function: the 
symbols used between elements. Enter the separator character to be used for functions, row 
arrays, and column arrays. For example, a comma can be used as a separator in functions and 
instead of writing =SUM(A1;B1;C1) the function would be expressed as =SUM(A1,B1,C1).

Sort Lists
Sort lists are used for more than sorting, for example filling a series of cells during data entry. They 
are lists that are sorted in a particular order but not alphabetically or numerically; for example, days
of the week. In addition to the supplied lists, you can define and edit your own lists, as described in
“Defining a fill series” in Chapter 2, Entering, Editing, and Formatting Data.

Figure 329: Defining sorting lists in Calc
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Change options
In the Options dialog, choose LibreOffice Calc > Changes.

Figure 330: Calc options for highlighting changes

On this page you can specify options for highlighting recorded changes in spreadsheets. You can 
assign specific colors for insertions, deletions, and other changes, or you can let Calc assign colors
based on the author of the change; in the latter case, one color will apply to all changes made by 
that author.

The selections made here are applied when change recording is enabled under File > Changes > 
Record.

Compatibility options
In the Options dialog, choose LibreOffice Calc > Compatibility. This page provides a quick way 
to switch between LibreOffice’s default key bindings and OpenOffice.org’s legacy default key 
bindings for Calc. Most of the defaults are identical, but there are some differences.

Figure 331: Compatibility options for Calc key bindings

The actions associated with the two key binding choices are shown in Table .
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Table 26: Key bindings

Key Binding Default OpenOffice.org legacy

Backspace Opens Delete Contents dialog Immediately deletes contents

Delete Immediately deletes contents Opens Delete Contents dialog

Control+D
(Command+D on Mac)

Fills cell content down within 
selection

Opens the Selection List dialog

Alt+DownArrow
(Option+DownArrow on Mac)

select header of range

no action in empty cell

Increases row height

Grid options
The Grid page defines the grid settings for spreadsheets. Using a grid helps you determine the 
exact position of any charts or other objects you may add to a spreadsheet. You can also set this 
grid in line with the snap grid.

If you have activated the snap grid but wish to move or create individual objects without snap 
positions, you can press the Ctrl key to deactivate the snap grid for as long as needed.

In the Options dialog, choose LibreOffice Calc > Grid.

Grid section
Snap to grid activates the snap function.

Visible grid displays grid points on the screen. These points are not printed.

Resolution section
Here you can set the unit of distance for the spacing between horizontal and vertical grid points 
and subdivisions (intermediate points) of the grid.

Synchronize axes changes the current grid settings symmetrically.

Figure 332: Calc grid options

Print options
In the Options dialog, choose LibreOffice Calc > Print. See Chapter 6, Printing, Exporting, and E-
mailing, for more about the options on this page.
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Default colors for charts

Use Tools > Options > Charts > Default Colors to change the default colors used for charts or to
add new data series to the list provided.

Figure 333: Defining chart colors

To change the default color for a data series, select it in the left-hand column and then click on the 
required color in the color table.

To add another data series, click Add, then select the new series and click on the required color.

To add new colors to the color table, see “Color options” on page 349.

AutoCorrect functions

Some people find some or all of the items in LibreOffice’s AutoCorrect function annoying because 
they change what you type when you do not want it changed. Many people find some of the 
AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find 
unexplained changes appearing in your document, this is a good place to look to find the cause.

To open the AutoCorrect dialog, click Tools > AutoCorrect Options. You need to have a 
document open for this menu item to appear.

In Calc, this dialog has four tabs, as shown in Figure 334. Options are described in the Help; many 
will be familiar to users of other office suites.
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Figure 334: The AutoCorrect dialog in Calc

Customizing the user interface

Menu font
If you want to change the menu font from that supplied by LibreOffice to the system font for your 
operating system, do this:

1) Choose Tools > Options > LibreOffice > View.

2) Check Use system font for user interface and click OK.

Menu content
In addition to changing the menu font, you can add and rearrange items on the menu bar, add 
items to menus, and make other changes.

To customize menus:

1) Choose Tools > Customize. On the Customize dialog, go to the Menus page (Figure 335).

Figure 335: Customize menus
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2) In the Save In drop-down list (h), choose whether to save this changed menu for Calc or 
for a selected document.

3) In the section LibreOffice Calc Menus, select from the Menu drop-down list (b) the menu 
that you want to customize. The list includes all the main menus as well as sub-menus, 
which are menus that are contained under another menu. For example, in addition to File, 
Edit, View, and so on, there is File | Send and File |Templates. The commands available for
the selected menu are shown in the central part of the dialog.

4) To customize the selected menu, click on the Menu (c) or Modify (f) buttons. You can also 
add commands to a menu by clicking on the Add button (e). These actions are described in
the following sections.

5) Use the up and down arrows (g) next to the Entries list (d) to move the selected menu item 
to a different position.

6) When you have finished making all your changes, click OK (not shown in picture) to save 
them.

Creating a new menu
In the Menus page of the Customize dialog, click New (b) to display the dialog shown in Figure 
336.

1) Type a name for your new menu in the Menu name box.

2) Use the up and down arrow buttons to move the new menu into the required position in the 
list of menu items. Click OK to save and return to the Customize dialog.

The new menu now appears on the list of menus in the Customize dialog. (It will appear on the 
menu bar itself after you save your customizations.)

After creating a new menu, you need to add some commands to it, as described in “Adding a 
command to a menu” on page 370.

Figure 336: Adding a new menu

Modifying existing menus
To modify an existing menu, select it in the Menu list and click the Menu button (c) to drop down a 
list of modifications: Move, Rename, Delete. Not all of these modifications can be applied to all the
entries in the Menu list. For example, Rename and Delete are not available for the supplied 
menus.
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To move a menu (such as File), choose Menu > Move. A dialog similar to the one shown in Figure 
336 (but without the Menu name box) opens. Use the up and down arrow buttons to move the 
menu into the required position.

To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in 
the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the 
arrow keys to move it up or down in the sequence. Submenus are easily identified in the Entries list
by a small black triangle on the right hand side of the name.

Adding a command to a menu
You can add commands to the supplied menus and to menus you have created. On the Customize
dialog, select the menu in the Menu list and click the Add button in the Menu Content section of 
the dialog.

Figure 337: Adding a command to a menu

On the Add Commands dialog, select a category and then the command, and click Add. The 
dialog remains open, so you can select several commands. When you have finished adding 
commands, click Close. Back on the Customize dialog, you can use the up and down arrow 
buttons to arrange the commands in your preferred sequence.

Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus, 
rename or delete the entries, and add group separators.

To begin, select the menu or submenu in the Menu list near the top of the Customize page, then 
select the entry in the Entries list under Menu Content. Click the Modify button and choose the 
required action from the drop-down list of actions.

Most of the actions should be self-explanatory. Begin a group adds a separator line after the 
highlighted entry.
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Creating an accelerator
You can allocate a letter in a custom menu’s name to be used as a keyboard shortcut. (That letter 
will become underlined.) When you press Alt+ that letter, that menu or command will be invoked. 
Existing submenus can also be edited to change the letter which is used to select them using the 
keyboard when the menu is open.

To create an accelerator:

1) Select a menu item from Menu or Entry from the Menu Content.

2) Click the Menu button if Menu was selected or the Modify button if an Entry was selected.

3) Select Rename.

4) Add a tilde (~) in front of the letter to use as an accelerator. For example, if you had created
a new menu named Art, you would do this:

a) Select Art from Menu.

b) Select Menu and then Rename.

c) Insert a tilde before the letter A in Art.

d) Click OK to close the Rename and Customize dialogs.

The A in the menu item Art is now underlined. Press Alt+A and the Art menu will open.

Caution When assigning an accelerator, be careful not to use a letter that is already assigned
to a menu or command associated with a menu item. The same letter-key 
combinations can be used for commands associated with different menu items but 
not for those associated with the same menu or menu item.

Toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar, as described in Chapter 1, Introducing LibreOffice, of the Getting 
Started guide. This section describes how to create new toolbars and add other icons (commands) 
to the list of those available on a toolbar.

To get to the toolbar customization dialog, do any of the following:

• On the toolbar, click the arrow at the end of the toolbar and choose Customize Toolbar.

• Choose View > Toolbars > Customize from the menu bar.

• Choose Tools > Customize from the menu bar and pick the Toolbars page (Figure 338).

To customize a toolbar:

1) In the Save In drop-down list, choose whether to save this changed toolbar for Calc or for a
selected document.

2) In the section LibreOffice Calc Toolbars, select from the Toolbar drop-down list the 
toolbar that you want to customize.

3) You can create a new toolbar by clicking on the New button, or customize existing toolbars 
by clicking on the Toolbar or Modify buttons, and add commands to a toolbar by clicking 
on the Add button. These actions are described below.

4) When you have finished making all your changes, click OK to save them.
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Figure 338: The Toolbars page of the Customize dialog

Creating a new toolbar
To create a new toolbar:

1) Choose Tools > Customize > Toolbars from the menu bar.

2) Click New. On the Name dialog, type the new toolbar's name and choose from the Save In 
drop-down list where to save this new toolbar: for Calc or for a selected document.

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new 
toolbar, you need to add some commands to it, as described below.

Adding a command to a toolbar
If the list of available buttons for a toolbar does not include all the commands you want on that 
toolbar, you can add commands. When you create a new toolbar, you need to add commands to it.

1) On the Toolbars page of the Customize dialog, select the toolbar in the Toolbar list and click
the Add button in the Toolbar Content section of the dialog.
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2) The Add Commands dialog is the same as for adding commands to menus (Figure 337). 
Select a category and then the command, and click Add. The dialog remains open, so you 
can select several commands. When you have finished adding commands, click Close. If 
you insert an item which does not have an associated icon, the toolbar will display the full 
name of the item: the next section describes how to choose an icon for a toolbar command.

3) Back on the Customize dialog, you can use the up and down arrow buttons to arrange the 
commands in your preferred sequence.

4) When you are done making changes, click OK to save.

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have 
associated icons.

To choose an icon for a command, select the command and click Modify > Change icon. On the 
Change Icon dialog (Figure 339), scroll through the available icons, select one, and click OK to 
assign it to the command.

Figure 339: Change Icon dialog

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the 
Import button on the Change Icon dialog. Custom icons must be 16 x 16 or 26 x 26 pixels in size 
and cannot contain more than 256 colors.

Keyboard shortcuts
In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your own. 
You can assign shortcuts to standard LibreOffice functions or your own macros and save them for 
use with the entire LibreOffice suite or only for Calc.

Caution

Be careful when reassigning your operating system’s or LibreOffice’s predefined 
shortcut keys. Many key assignments are universally understood shortcuts, such as 
F1 for Help, and are always expected to provide certain results. Although you can 
easily reset the shortcut key assignments to the LibreOffice defaults, changing some 
common shortcut keys can cause confusion, frustration and possible data loss or 
corruption, especially if other users share your computer.
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Note
Shortcut keys that are grayed out in the listing on the Customize dialog, such as F1 
and F10, are not available for reassignment.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.

1) Select Tools > Customize > Keyboard. The Keyboard page of the Customize dialog 
opens.

2) To have the shortcut key assignment available only with Calc, select Calc in the upper right
corner of the page; otherwise select LibreOffice to make it available to every component.

3) Next select the required function from the Category and Function lists.

4) Now select the desired shortcut keys in the Shortcut keys list and click the Modify button at
the upper right.

5) Click OK to accept the change. Now the chosen shortcut keys will execute the function 
chosen in step 3 above whenever they are pressed.

Note

All existing shortcut keys for the currently selected Function are listed in the Keys 
selection box. If the Keys list is empty, it indicates that the chosen key combination is 
free for use. If it were not, and you wanted to reassign a shortcut key combination 
that is already in use, you must first delete the existing key.

Example: Assigning styles to shortcut keys
You can configure shortcut keys to quickly assign styles in your document.

1) On the Keyboard page of the Customize dialog, choose the shortcut keys you want to 
assign a style to. In this example, we have chosen Ctrl+3.

2) In the Functions section at the bottom of the dialog, scroll down in the Category list to 
Styles. Click the + sign to expand the list of styles.

3) Choose the category of style. (This example uses a cell style, but you can also choose 
page styles.) The Function list now displays the names of the available styles for the 
selected category. The example shows LibreOffice’s predefined cell styles.

4) To assign Ctrl+3 to be the shortcut key combination for the Heading style, select Heading in
the Function list, and then click Modify. Ctrl+3 now appears in the Keys list on the right, 
and Heading appears next to Ctrl+3 in the Shortcut keys box at the top.

5) Make any other required changes, and then click OK to save these settings and close the 
dialog.

Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a
later time, thus permitting you to create and apply different configurations as the need arises. To 
save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button on the Customize 
dialog.

2) In the Save Keyboard Configuration dialog, select All files from the Save as Type list.

3) Next enter a name for the keyboard configuration file in the File name box, or select an 
existing file from the list. If you need to, browse to find a file from another location.

4) Click Save. A confirmation dialog appears if you are about to overwrite an existing file, 
otherwise there will be no feedback and the file will be saved.
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Figure 340: Assigning a cell style to a key combination

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load 
button near the bottom right of the Customize dialog, and then select the configuration file from the 
Load Keyboard Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom
right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed;
the defaults will be set without any further notice or user input.

Running macros from key combinations
You can also define shortcut key combinations that will run macros. These shortcut keys are strictly
user-defined; none are built in. For more information on macros, see Chapter 12, Calc Macros.

Adding functionality with extensions

An extension is a package that can be installed into LibreOffice to add new functionality.

Although individual extensions can be found in different places, the official LibreOffice extension 
repository is at http://extensions.libreoffice.org/. Some extensions are free of charge; others are 
available for a fee. Check the descriptions to see what licenses and fees apply to the ones that 
interest you.
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Installing extensions
To install an extension that is listed in the repository, follow these steps:

1) In LibreOffice, select Tools >  Extension Manager from the menu bar. In the Extension 
Manager dialog, click the Get more extensions online link.

2) A browser window will open. Find the extension you want and click the Get [extension 
name] link.

3) Depending on your operating system and browser settings, you may be able to select 
Open with LibreOffice from the download options and install the extenstion automatically.

4) If the extension is downloaded and saved, return to the Extension Manager dialog and click
Add. Find and select the extension you want to install and click Open. The extension 
begins installing. You may be asked to accept a license agreement.

5) When the installation is complete, the extension is listed in the Extension Manager dialog.

To install an extension that is not listed in the repository, download the extension, then continue 
with step 3 above.

Note
To install a shared extension, you need write access to the LibreOffice installation 
directory. 

Figure 341: The Extension Manager dialog
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Introduction

You can use Calc without a pointing device such as a mouse or trackball, by using its built-in 
keyboard shortcuts.

LibreOffice has a general set of keyboard shortcuts, available in all components, and a component-
specific set directly related to the work of that component.

For help with LibreOffice’s keyboard shortcuts or using LibreOffice with a keyboard only, search the
Help supplied with LibreOffice (also available online at http://help.libreoffice.org) using the 
“shortcut” or “accessibility” keywords.

In addition to using the built-in keyboard shortcuts listed in this Appendix, you can define your own.
See Chapter 14, Setting Up and Customizing Calc, for instructions.

Formatting and editing shortcuts are described in Chapter 2, Entering, Editing, and Formatting 
Data.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options menu
selection

LibreOffice > Preferences Access setup options

Right-click Control+click Opens a context menu

Ctrl (Control) ⌘ (Command) Used with other keys

F5 Shift+⌘+F5 Opens the Navigator

F11 ⌘+T Opens the Styles and Formatting window

Navigation and selection shortcuts

Table 27: Spreadsheet navigation shortcuts

Shortcut Keys Effect 

Ctrl+Home Moves the cursor to the first cell in the sheet (cell A1).

Ctrl+End Moves the cursor to the last cell on the sheet that contains data.

Home Moves the cursor to the first cell of the current row.

End Moves the cursor to the last cell of the current row in a column 
containing data.

Ctrl+Left Arrow Moves the cursor to the left edge of the current data range. If the 
column to the left of the cell that contains the cursor is empty, the cursor
moves to the next column to the left that contains data.

Ctrl+Right Arrow Moves the cursor to the right edge of the current data range. If the 
column to the right of the cell that contains the cursor is empty, the 
cursor moves to the next column to the right that contains data.
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Shortcut Keys Effect 

Ctrl+Up Arrow Moves the cursor to the top edge of the current data range. If the row 
above the cell that contains the cursor is empty, the cursor moves up to 
the next row that contains data.

Ctrl+Down Arrow Moves the cursor to the bottom edge of the current data range. If the 
row below the cell that contains the cursor is empty, the cursor moves 
down to the next row that contains data.

Ctrl+Shift+Arrow Selects all cells containing data from the current cell to the end of the 
continuous range of data cells, in the direction of the arrow pressed. If 
used to select rows and columns together, a rectangular cell range is 
selected.

Ctrl+Page Up Moves one sheet to the left. In the page preview it moves to the 
previous print page.

Ctrl+Page Down Moves one sheet to the right. In the page preview it moves to the next 
print page.

Page Up Moves the viewable rows up one screen.

Page Down Moves the viewable rows down one screen.

Alt+Page Up Moves the viewable columns one screen to the left.

Alt+Page Down Moves the viewable columns one screen to the right.

Shift+Ctrl+Page Up Adds the previous sheet to the current selection of sheets. If all the 
sheets in a spreadsheet are selected, this combination only selects the 
previous sheet. Makes the previous sheet the current sheet.

Shift+Ctrl+Page Down Adds the next sheet to the current selection of sheets. If all the sheets in
a spreadsheet are selected, this combination only selects the next 
sheet. Makes the next sheet the current sheet.

Ctrl+* Selects the data range that contains the cursor. A range is a contiguous 
cell range that contains data and is bounded by empty rows and 
columns. The “*” key is the multiplication sign on the numeric key pad.

Ctrl+/ Selects the matrix formula range that contains the cursor. The “/” key is 
the division sign on the numeric key pad.

Enter — in a selected 
range

By default, moves the cursor down one cell in a selected range. To 
specify the direction that the cursor moves, choose Tools > Options > 
LibreOffice Calc > General.
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Function key shortcuts

Table 28: Function key shortcuts

Shortcut Keys Effect 

F1 Displays the LibreOffice help browser. When the help browser is already
open F1 jumps to the main help page.

Shift+F1 Displays context help.

Ctrl+F1 Displays the comment that is attached to the current cell.

F2 Switches to Edit mode and places the cursor at the end of the contents 
of the current cell. If the cursor is in an input box in a dialog that has a 
minimize button, the dialog is hidden and the input box remains visible. 
Press F2 again to show the whole dialog.

Ctrl+F2 Opens the Function Wizard.

Shift+Ctrl+F2 Moves the cursor to the input line where you can enter a formula for the 
current cell.

Ctrl+F3 Opens the Manage Names dialog.

Shift+F3 Switches between Upper Initials, UPPER and lower cases modes.

F4 Shows or hides the Database Sources pane.

Shift+F4 Rearranges the relative or absolute references (for example, A1, $A$1, 
$A1, A$1) in the input field.

F5 Shows or hides the Navigator.

Shift+F5 Traces dependents.

Shift+Ctrl+F5 Moves the cursor to the Name box.

F7 Checks spelling in the current sheet.

Ctrl+F7 Opens the Thesaurus if the current cell contains text.

Shift+F7 Traces precedents.

F8 Switches between the standard and extended selection modes. In this 
mode, you can use the arrow keys to extend the selection. You can also
click in another cell to extend the selection.

Shift+F8 Switches between the standard and add selection modes. In this mode, 
you can easily add individual cells to a range.

Ctrl+F8 Highlights cells containing numeric values (not text) blue, and formulas 
(text or number) green, or stop this highlight.

F9 Recalculates all of the formulas in the sheet.

Ctrl+F9 Updates the selected chart.

F11
(Command+T on Mac)

Opens the Styles and Formatting window where you can apply a 
formatting style to the contents of the cell or to the current sheet.

F12 Groups the selected data range.

Ctrl+F12 Ungroups the selected data range.
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Arrow key shortcuts

Table 29. Arrow key shortcuts

Shortcut Keys Effect 

Alt+Down Arrow Increases the height of current row.

Alt+Up Arrow Decreases the height of current row.

Alt+Shift+Arrow Key Optimizes the column width or row height based on the current cell.

Alt+Arrow Key – on a 
selected object

Moves with one pixel a selected object (chart, image, drawing, form 
control) towards the pressed arrow (a pressed arrow without Alt will 
move it less accurately).

Cell formatting shortcuts

Ctrl+1 opens the Format Cells dialog.

Note

The shortcuts listed in Table Table 30 do not work under any Linux desktop tested. If
you would like to have the functionality described in this table, you must create 
custom key sequences as explained in Chapter 14, Setting Up and Customizing 
Calc.

Note
The shortcut keys shown in Table Table 30 do not use the number keys on the 
number pad. They use the number keys above the letter keys on the main keyboard.

Table 30: Cell formatting shortcut keys

Shortcut Keys Effect 

Ctrl+Shift+1 Two decimal places, thousands separator

Ctrl+Shift+2 Standard exponential format

Ctrl+Shift+3 Standard date format

Ctrl+Shift+4 Standard currency format

Ctrl+Shift+5 Standard percentage format (two decimal places)

Ctrl+Shift+6 Standard format
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Pivot table shortcuts

Table 31: Pivot table shortcut keys

Shortcut Keys Effect 

Tab Changes the focus by moving forward through the areas and buttons of 
the dialog.

Shift+Tab Changes the focus by moving backward through the areas and buttons 
of the dialog.

Up arrow Moves the focus up one item in the current dialog area.

Down arrow Moves the focus down one item in the current dialog area.

Left arrow Moves the focus one item to the left in the current dialog area.

Right arrow Moves the focus one item to the right in the current dialog area.

Home Selects the first field in the current layout area.

End Selects the last field in the current layout area.

Alt+R Copies or moves the current field into the “Row” area.

Alt+C Copies or moves the current field into the “Column” area.

Alt+D Copies or moves the current field into the “Data” area.

Ctrl+Up Arrow Moves the current field up one place.

Ctrl+Down Arrow Moves the current field down one place.

Ctrl+Left Arrow Moves the current field one place to the left.

Ctrl+Right Arrow Moves the current field one place to the right.

Ctrl+Home Moves the current field to the first place.

Ctrl+End Move the current field to the last place.

Alt+O Displays the options for the current field.

Delete Removes the current field from the area.
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Chart shortcuts

Table 32: Chart shortcut keys

Shortcut Keys Effect 

Tab Selects next object.

Shift+Tab Selects previous object.

Home Selects first object.

End Selects last object.

Esc Cancels selection.

Arrow keys Moves the object in the direction of the arrow.

Arrow keys in pie charts Moves the selected pie segment in the direction of the arrow.

F2 in titles Enters text input mode.

F3 Opens group so you can edit the individual components (in legend and 
data series).

Ctrl+F3 Exits group (in legend and data series).

+/– Enlarges or reduces the chart.

+/– in pie charts Moves the selected pie segment off or into the pie chart.
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Functions available in Calc

Calc provides all of the commonly used functions found in modern spreadsheet applications. Since
many of Calc’s functions require very specific and carefully calculated input arguments, the 
descriptions in this appendix should not be considered complete references for each function. 
Refer to the application Help or the LibreOffice wiki for details and examples of all functions. On 
the wiki, start with http://help.libreoffice.org/Calc/Functions_by_Category

Over 300 standard functions are available in Calc. More can be added through extensions to Calc 
(see Chapter 14). The following tables list Calc’s functions organized into eleven categories.

Note

Functions whose names end with _ADD are provided for compatibility with Microsoft 
Excel functions. They return the same results as the corresponding functions in Excel 
(without the suffix), which though they may be correct, are not based on international 
standards. Calc automatically changes the function to _ADD for relevant functions in 
imported Excel spreadsheets.

Terminology: numbers and arguments
Some of the descriptions in this appendix define limitations on the number of values or arguments 
that can be passed to the function. Specifically, functions that refer to the following arguments may 
lead to confusion:

• Number_1, number_2, ... number_30

• Number 1 to 30

• a list of up to 30 numbers

There is a significant difference between a list of numbers (or integers) and the number of 
arguments a function will accept. For, example the SUM function will only accept a maximum of 30 
arguments. This limit does NOT mean that you can only sum 30 numbers, but that you can only 
pass 30 separate arguments to the function.

Arguments are values separated by commas, and can include ranges which often refer to multiple 
values. Therefore one argument can refer to several values, and a function that limits input to 30 
arguments may in fact accept more then 30 separate numerical values.

This appendix attempts to clarify this situation by using the term arguments, rather than any of the
other phrases.

In the LibreOffice Calc functions, parameters marked as "optional" can be left out only when no 
parameter follows. For example, in a function with four parameters, where the last two parameters 
are marked as "optional", you can leave out parameter 4 or parameters 3 and 4, but you cannot 
leave out parameter 3 alone.

Note
In the tables of functions in this Appendix, several bugs are listed; if you wish to check 
on the progress of fixing those bugs, you can visit http://bugs.libreoffice.org/ and enter 
the bug number.
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Mathematical functions

Table 33: Mathematical functions

Syntax Description

ABS(Number) Returns the absolute value of the given Number.

ACOS(Number) Returns the inverse cosine of the given Number in radians.

ACOSH(Number) Returns the inverse hyperbolic cosine of the given Number in 
radians.

ACOT(Number) Returns the inverse cotangent of the given Number in radians.

ACOTH(Number) Returns the inverse hyperbolic cotangent of the given Number 
in radians.

ASIN(Number) Returns the inverse sine of the given Number in radians. 

ASINH(Number) Returns the inverse hyperbolic sine of the given Number in 
radians.

ATAN(Number) Returns the inverse tangent of the given Number in radians.

ATAN2(number_x, number_y) Returns the inverse tangent of the specified x and y coordinates
in radians. number_x is the value for the x coordinate. 
number_y is the value for the y coordinate.

ATANH(Number) Returns the inverse hyperbolic tangent of the given Number.  
(Angle is returned in radians.)

BITAND(Number, Number) This is the bitwise “AND” of two positive integers whose values 
are less than 2˄48. Both parameters are required.

Bug 71810, concerning parameter names in BITAND, BITOR, 
and BITXOR.

BITLSHIFT(Number, Shift) The bitwise left shift of an integer value. Both parameters are 
required. Number is an integer less than 2˄48. Shift is the 
number of bits to move by.

BITOR(Number, Number) This is the bitwise “OR” of two positive integers whose values 
are less than 2˄48. Both parameters are required.

BITRSHIFT(Number, Shift) The bitwise right shift of an integer value. Both parameters are 
required. Number is an integer less than 2˄48. Shift is the 
number of bits to move by.

BITXOR(number, number) This is the bitwise “exclusive OR” of two positive integers whose
values are less than 2˄48. Both parameters are required.

CEILING(Number, Significance,
Mode)

Rounds up the given Number to the nearest multiple of the 
value of Significance. Mode is an optional value. If the mode 
value is given and not equal to zero, and if number and 
significance are negative, then rounding is done based on the 
absolute value of number. Omit this value for Excel 
compatibility.

COMBIN(count_1, count_2) Returns the number of combinations for elements without 
repetition. count_1 is the total number of elements. count_2 is 
the number to be combined from the elements. This is the same
as the nCr function on a calculator.
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COMBINA(count_1, count_2) Returns the number of combinations for a given number of 
objects (repetition included). count_1 is the total number of 
elements. count_2 is the number to choose from the elements.

CONVERT(value, text, text) Converts a value from one unit of measurement to another. 
value is the quantity to be converted. The first text is the official 
abbreviation for the measurement in question (for example, "mi"
for miles). The second text parameter gives the unit to which it 
is to be converted. Both text arguments must be within quotes 
and are case sensitive. The conversion is done according to a 
table in the configuration (main.xcd).

Bug 69539: This function does not work.

COS(Number) Returns the cosine of the Number (the angle in radians).

COSH(Number) Returns the hyperbolic cosine of the Number (the angle in 
radians).

COT(Number) Returns the cotangent of the Number (the angle in radians).

COTH(Number) Returns the hyperbolic cotangent of the Number (the angle in 
radians). 

COUNTBLANK(range) Returns the number of empty cells. range is the cell range in 
which the empty cells are counted.

COUNTIF(range, criteria) Returns the number of cells that meet the criteria within a cell 
range. range is the range to which the criteria are to be applied.
criteria indicates the criteria in the form of a number, a regular 
expression, or a character string by which the cells are counted.

COUNTIFS(range 1, criteria 1, 
range 2, criteria 2, …,)

Returns the number of cells that meet multiple criteria in multiple
cell ranges. range 1 (required), range 2, …, are the ranges to 
which the criteria are to be applied. criteria 1 (required), criteria
2, …, indicate the criteria in the form of a number, a regular 
expression, or a character string by which the cells are 
evaluated. All ranges must have the same dimension and size.

CSC(Angle) Returns the cosecant of an angle given in radians (1/SIN(X)).

CSCH(Angle) Returns the hyperbolic cosecant of a hyperbolic angle 
(1/SINH(X)).

DEGREES(Number) Converts the given Number in radians to degrees.

EUROCONVERT(value, 
from_currency, to_currency, 
full_precision, 
triangulation_precision)

Converts from one pre-Euro currency to another. value is the 
value to be converted. The from_currency is the ISO 4217 
code of the currency from which value is to be converted. The 
to_currency is the ISO 4217 code of the currency to which 
value is to be converted. The entries are not case sensitive. 
The above parameters are required. The optional 
full_precision parameter, if omitted, is 0 or FALSE rounds the 
result to the decimals of the to_currency. If full_precision is 
TRUE, the result is not rounded. triangulation_precision is 
optional. If triangulation_precision is given and >=3, the 
intermediate result of a triangular conversion (currency1, 
EURO, currency2) is rounded to that precision. If 
triangulation_precision is omitted, the intermediate result is 
not rounded. Also if to_currency is "EUR", 
triangulation_precision is used as if triangulation was needed 
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and conversion from Euro to Euro was applied. Conversion 
rates and currency codes can be found here: 
http://ec.europa.eu/economy_finance/euro/adoption/conversion/
index_en.htm

The Cyprus pound has been omitted from this list but is “CYP”.

Bug 71850: These are NOT case sensitive as stated in the 
Function Wizard.

EVEN(Number) Rounds the given Number up to the nearest even integer, and a
negative number down to the next even number.

EXP(Number) Returns e raised to the power of the given Number.

FACT(Number) Returns the factorial of the given Number.

FLOOR(Number, Significance, 
Mode)

Rounds the given Number down to the nearest multiple of 
Significance. Significance is the value to whose multiple the 
number is to be rounded down. Mode is an optional value. If it is
indicated and non-zero and if the number and significance are 
negative, rounding is done based on the absolute value of the 
number. Note: Many application user interfaces have a FLOOR 
function with only two parameters, and somewhat different 
semantics than given here (e.g., they operate as if there was a 
non-zero mode value). These FLOOR functions are inconsistent
with the standard mathematical definition of FLOOR. 

GCD(Integer 1, Integer 2, …, 
Integer 30))

Returns the greatest common divisor of one or more positive 
integers. Integers x is a list of up to 30 integers, at least one of 
which must be greater than zero, whose greatest common 
divisor is to be calculated. This gives a result based on 
international standards.

GCD_ADD(Number(s), 
Number(s)1, …, Number(s)30)

Returns the greatest common divisor of a list of numbers. 
Number(s) X is a list of up to 30 numbers, additional to 
Number(s) separated by commas. This gives the same results 
as MS Excel.

INT(Number) Rounds the given Number down to the nearest integer.

LCM(Integer 1, Integer 2, …, 
Integer 30)

Returns the least common multiple of one or more integers. 
Integer 1, Integer 2, …, Integer 30 are integers whose lowest 
common multiple is to be calculated.

LCM_ADD(Number(s), 
Number(s)1, …, Number(s)30)

Number(s) X is a list of up to 30 numbers, additional to 
Number(s), separated by commas. The result is the lowest 
common multiple of a list of numbers.

LN(Number) Returns the natural logarithm, based on the constant e, of the 
given Number.

LOG(Number, Base) Returns the logarithm of the given Number (value >0) to the 
specified base. Base is the base for the logarithm calculation. If 
omitted, 10 is assumed.

LOG10(Number) Returns the base-10 logarithm of a Number >0.

MOD(Dividend, Divisor) Returns the remainder after a number is divided by a divisor. 
Dividend is the number to be divided. Divisor is the number by 
which the dividend is divided.

Appendix B  Description of Functions 389

http://ec.europa.eu/economy_finance/euro/adoption/conversion/index_en.htm
http://ec.europa.eu/economy_finance/euro/adoption/conversion/index_en.htm


Syntax Description

MROUND(Number, Multiple) Returns Number rounded to the nearest multiple of Multiple.

MULTINOMIAL (Number(s), 
Number(s)1, …, Number(s)30)

Returns the factorial of the sum of the arguments divided by the 
product of the factorials of the arguments. Number(s) X is a list 
of up to 30 numbers, additional to Number(s), separated by 
commas.

ODD(Number) Rounds Number up if positive and down if negative, to the 
nearest odd integer. 

PI() Returns the value of PI to fourteen decimal places.

POWER(Base, Exponent) Returns the result of a number raised to a power. Base is the 
number that is to be raised to the given power. Exponent is the 
exponent by which the base is to be raised.

PRODUCT(Number 1, Number 
2, …, Number 30)

Multiplies all the numbers given as arguments and returns the 
product. Number 1 to Number 30 are up to 30 arguments 
whose product is to be calculated, separated by commas.

QUOTIENT(Numerator, 
Denominator)

Returns the integer result of a division operation. Numerator is 
the number that will be divided. Denominator is the number the
numerator will be divided by.

RADIANS(Number) Converts the given Number in degrees to radians.

RAND() Returns a random number between 0 and 1. This number will 
recalculate every time data is entered, Ctrl+Shift+F9 or F9 is 
pressed.

RANDBETWEEN (Bottom, Top) Returns an integer random number between Bottom and Top 
(inclusive). This number will recalculate when the Ctrl+Shift+F9 
key combination is pressed (not F9 alone).

ROUND(number, count) Rounds the given number to count (optional) decimal places. If
the count parameter is omitted or zero, number rounds to the 
nearest integer. If count is negative, the function rounds to the 
nearest 10, 100, 1000 and so on.

ROUNDDOWN(number, count) Rounds the given number down, to count (optional) decimal 
places. If the count parameter is omitted or zero, number 
rounds down to the nearest integer. If count is negative, the 
function rounds down to the nearest 10, 100, 1000 and so on. 
Number rounds toward zero.

ROUNDUP(number, count) Rounds the given number up to count (optional) decimal 
places.  If the count parameter is omitted or zero, number 
rounds up to the nearest integer. If count is negative, the 
function rounds up to the nearest 10, 100, 1000 and so on. 
Number rounds away from zero.

SEC(Angle) Returns the secant of an Angle given in radians. 
SEC(x)=1/COS(x).

SECH(Angle) Returns the hyperbolic secant of an Angle given in radians. 
SECH(x)=1/COSH(x).
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SERIESSUM(X, N, M, 
Coefficients)

Returns the sum of a powers series.

SERIESSUM(X, N, M, Coefficients) = coefficient_1*x^n + 
coefficient_2*x^(n+m) + coefficient_3*x^(n+2m) +...+ 
coefficient_i*x^(n+(i-1)m).

X is the number as an independent variable. N is the starting 
power. M is the increment. Coefficients is a series of 
coefficients. For each coefficient the series sum is extended by 
one section. You can only enter coefficients using a cell range.

SIGN(Number) Returns the sign of the given Number. The function returns the 
result 1 for a positive sign, –1 for a negative sign, and 0 for zero.

SIN(number) Returns the sine of the given number (angle in radians).

SINH(number) Returns the hyperbolic sine of the given number (angle in 
radians).

SQRT(number) Returns the positive square root of the given number. The 
value of the number must be positive.

SQRTPI(Number) Returns the square root of the product of the given Number and
PI.

SUBTOTAL(Function, range) Calculates subtotals. If a range already contains subtotals, 
these are not used for further calculations. Function is a value 
that stands for another function such as Average, Count, Min, 
Sum, Var. range is the range whose cells are included.

SUM(number 1, number 2, …, 
number 30)

Adds all the numbers in a range of cells. Number 1, number 2, 
…, number 30 are up to 30 arguments whose sum is to be 
calculated. You can also enter a range using cell references.

SUMIF(range, criteria, 
sum_range)

Adds the cells specified by the given criteria. The search 
supports regular expressions. range is the range to which the 
criteria are to be applied. criteria is the cell in which the search 
criterion is shown, or the search criterion itself. sum_range 
(optional) is the range from which values are summed; if it has 
not been entered, the values found in the range are summed. If 
supplied, sum_range must be the same size and shape as 
range.

SUMIFS(sum_range, range 1, 
criteria 1, range 2, criteria 2, 
…,)

Totals the values of cells in a range that meet multiple criteria in 
multiple ranges. sum_range (required) is the cell range from 
which the values are to be totaled. range 1 (required) is the cell 
range to be evaluated by criteria 1 (required), range 2 by 
criteria 2 and so on. All ranges must have the same size and 
shape.

SUMSQ(number 1, number 2, 
…, number 30)

Calculates the sum of the squares of numbers (totaling up of the
squares of the arguments)  number 1, number 2, …, number 
30 are up to 30 arguments, the sum of whose squares is to be 
calculated.

TAN(number) Returns the tangent of the given number (angle in radians).

TANH(number) Returns the hyperbolic tangent of the given number (angle in 
radians).
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TRUNC(number, count) Truncates a number by removing decimal places. number is the
number whose decimal places are to be trimmed. count 
(optional) is the number of decimal places which are retained. If 
count is missing or zero, it effectively truncates to a decimal 
integer. If count is negative, it truncates to the left of the 
decimal point.

Financial analysis functions

A note about dates
Date values used as parameters for Calc’s financial functions must comply with ISO8601 and be 
entered surrounded by double quotes. For example, a date representing August 6, 2004, must be 
entered “2004-08-06”, single digits are padded with leading zeroes. If you do not enter the date 
values as required by the function, you will not get the correct results. Date formats are locale 
specific and will allow other formats to be used. Among others, the en_US locale allows 
“2004/08/06” and “08/06/2004” for example. Check the Help for the acceptable formatting.

A note about interest rates
You can enter interest rates in either of two ways:

• As a decimal. To enter an interest rate as a decimal, divide it by 100 before entering it into a
function. For example, to compute a loan with a 3.25% interest rate, enter .0325 into the 
function.

• As a percentage. To enter an interest rate as a percentage, type in the interest rate 
followed by the % key. For example, to compute a loan with a 3.25% interest rate, enter 
3.25% into the function.

If you enter it as 3.25, the function will treat it as a 325% interest rate.

Accounting systems vary in the number of days in a month or a year used in calculations. The 
following table gives the integers used for the basis parameter used in some of the financial 
analysis functions.

Table 34: Basis calculation types

Basis Calculation

0 or missing US method (NASD), 12 months of 30 days each.

1 Exact number of days in months, exact number of days in year.

2 Exact number of days in month, year has 360 days.

3 Exact number of days in month, year has 365 days.

4 European method, 12 months of 30 days each.
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Table 35: Financial analysis functions

Syntax Description

ACCRINT(Issue, First interest, 
Settlement, Rate, Par, Frequency, 
Basis)

Calculates the accrued interest of a security in the case of 
periodic payments. Issue is the issue date of the security. 
First interest is the first interest date of the security. 
Settlement is the maturity date. Rate is the annual nominal 
rate of interest (coupon interest rate). Par is the par value of 
the security. Frequency is the number of interest payments 
per year (1, 2 or 4). Basis indicates how the year is to be 
calculated.

ACCRINTM(Issue, Settlement, 
Rate, Par, Basis)

Calculates the accrued interest of a security in the case of 
one-off payment at the settlement date. Issue is the issue 
date of the security. Settlement is the maturity date. Rate is 
the annual nominal rate of interest (coupon interest rate). Par
is the par value of the security. Basis indicates how the year 
is to be calculated.

AMORDEGRC(Cost, Date 
purchased, First period, Salvage, 
Period, Rate, Basis)

Calculates the amount of depreciation for a settlement period
as degressive amortization. Unlike AMORLINC, a 
depreciation coefficient that is independent of the depreciable
life is used here. Cost is the acquisition cost. Date 
purchased is the date of acquisition. First period is the end 
date of the first settlement period. Salvage is the salvage 
value of the capital asset at the end of the depreciable life. 
Period is the settlement period to be considered. Rate is the 
rate of depreciation. Basis indicates how the year is to be 
calculated.

AMORLINC(Cost, Date 
purchased, First period, Salvage, 
Period, Rate, Basis)

Calculates the amount of depreciation for a settlement period
as linear amortization. If the capital asset is purchased during
the settlement period, the proportional amount of 
depreciation is considered. Cost is the acquisition cost. Date 
purchased is the date of acquisition. First period is the end 
date of the first settlement period. Salvage is the salvage 
value of the capital asset at the end of the depreciable life. 
Period is the settlement period to be considered. Rate is the 
rate of depreciation. Basis indicates how the year is to be 
calculated.

COUPDAYBS(Settlement, 
Maturity, Frequency, Basis)

Returns the number of days from the first day of interest 
payment on a security until the settlement date. Settlement 
is the date of purchase of the security. Maturity is the date 
on which the security matures (expires). Frequency is the 
number of interest payments per year (1, 2 or 4). Basis 
indicates how the year is to be calculated.

COUPDAYS(Settlement, Maturity, 
Frequency, Basis)

Returns the number of days in the current interest period in 
which the settlement date falls. Settlement is the date of 
purchase of the security. Maturity is the date on which the 
security matures (expires). Frequency is the number of 
interest payments per year (1, 2 or 4). Basis indicates how 
the year is to be calculated.
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COUPDAYSNC(Settlement, 
Maturity, Frequency, Basis)

Returns the number of days from the settlement date until the
next interest date. Settlement is the date of purchase of the 
security. Maturity is the date on which the security matures 
(expires). Frequency is the number of interest payments per 
year (1, 2 or 4). Basis indicates how the year is to be 
calculated.

COUPNCD(Settlement, Maturity, 
Frequency, Basis)

Returns the date of the first interest date after the settlement 
date, and formats the result as a date. Settlement is the date
of purchase of the security. Maturity is the date on which the 
security matures (expires). Frequency is the number of 
interest payments per year (1, 2 or 4). Basis indicates how 
the year is to be calculated.

COUPNUM(Settlement, Maturity, 
Frequency, Basis)

Returns the number of coupons (interest payments) between 
the settlement date and the maturity date. Settlement is the 
date of purchase of the security. Maturity is the date on 
which the security matures (expires). Frequency is the 
number of interest payments per year (1, 2 or 4). Basis 
indicates how the year is to be calculated.

COUPPCD(Settlement, Maturity, 
Frequency, Basis)

Returns the date of the interest date prior to the settlement 
date, and formats the result as a date. Settlement is the date
of purchase of the security. Maturity is the date on which the 
security matures (expires). Frequency is the number of 
interest payments per year (1, 2 or 4). Basis indicates how 
the year is to be calculated.

CUMIPMT(Rate, NPER, pv, S, E, 
Type)

Calculates the cumulative interest payments (the total 
interest) for an investment based on a constant interest rate. 
Rate is the periodic interest rate. NPER is the payment 
period with the total number of periods. NPER can also be a 
non-integer value. The Rate and NPER must refer to the 
same unit, and thus both must be calculated annually or 
monthly. pv is the current value in the sequence of 
payments. S is the first period. E is the last period. Type is 
the due date of the payment at the beginning (1) or end (0) of
each period.

CUMIPMT_ADD(Rate, Nper, Pv, 
Start period, End period, Type)

Calculates the accumulated interest for a period. Rate is the 
interest rate for each period. Nper is the total number of 
payment periods. The Rate and Nper must refer to the same 
unit, and thus both must be calculated annually or monthly. 
Pv is the current value. Start period the first payment period 
for the calculation. End period the last payment period for 
the calculation. Type is the due date of the payment at the 
beginning (1) or end (0) of each period.

CUMPRINC(Rate, NPER, PV, S, 
E, Type)

Returns the cumulative interest paid for an investment period
with a constant interest rate. Rate is the periodic interest 
rate. NPER is the payment period with the total number of 
periods. NPER can also be a non-integer value. The Rate 
and NPER must refer to the same unit, and thus both must 
be calculated annually or monthly. PV is the current value in 
the sequence of payments. S is the first period. E is the last 
period. Type is the due date of the payment at the beginning 
(1) or end (0) of each period.
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CUMPRINC_ADD(Rate, Nper, Pv, 
Start period, End period, Type)

Calculates the cumulative redemption of a loan in a period. 
Rate is the interest rate for each period. Nper is the total 
number of payment periods. The Rate and Nper must refer 
to the same unit, and thus both must be calculated annually 
or monthly. Pv is the current value. Start period is the first 
payment period for the calculation. End period is the last 
payment period for the calculation. Type is the due date of 
the payment at the beginning (1) or end (0) of each period.

DB(Cost, Salvage, Life, Period, 
month)

Returns the depreciation of an asset for a specified period 
using the fixed-declining balance method. Cost is the initial 
cost of an asset. Salvage is the value of an asset at the end 
of the depreciation. Life defines the period over which an 
asset is depreciated. Period is the length of each period. The
life must be entered in the same date unit as the depreciation
period. month (optional) denotes the number of months for 
the first year of depreciation.

DDB(Cost, Salvage, Life, Period, 
Factor)

Returns the depreciation of an asset for a specified period 
using the arithmetic-declining method. Note that the book 
value will never reach zero under this calculation type. Cost 
fixes the initial cost of an asset. Salvage fixes the value of an
asset at the end of its life. Life is the number of periods 
defining how long the asset is to be used. Period defines the 
length of the period. The period must be entered in the same 
time unit as the life. Factor (optional) is the factor by which 
depreciation decreases. If no value is entered, a value of 2 is 
assumed, making this double declining.

DISC(Settlement, Maturity, Price, 
Redemption, Basis)

Calculates the allowance (discount) of a security as a 
percentage. Settlement is the date of purchase of the 
security. Maturity is the date on which the security matures 
(expires). Price is the price of the security per 100 currency 
units of par value. Redemption is the redemption value of 
the security per 100 currency units of par value. Basis 
indicates how the year is to be calculated.

DOLLARDE(Fractional dollar, 
Fraction)

Converts a quotation that has been given as a decimal 
fraction into a decimal number. Fractional dollar is a number
given as a decimal fraction. (In this number, the decimal 
value is the numerator of the fraction.) Fraction is a whole 
number that is used as the denominator of the decimal 
fraction.

DOLLARFR(Decimal dollar, 
Fraction)

Converts a quotation that has been given as a decimal 
number into a mixed decimal fraction. The decimal of the 
result is the numerator of the fraction that would have 
Fraction as the denominator. Decimal dollar is a decimal 
number. Fraction is a whole number that is used as the 
denominator of the decimal fraction.

DURATION(RATE, pv, FV) Calculates the number of periods required by an investment 
to attain the desired value. RATE (a constant) is the interest 
rate to be calculated for the entire duration. Entering the 
interest rate divided by the periods per year, can calculate 
the interest after each period. pv is the present value. FV is 
the desired future value of the investment.
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DURATION_ADD (Settlement, 
Maturity, Coupon, Yield, 
Frequency, Basis)

Calculates the duration of a fixed interest security in years. 
Settlement is the date of purchase of the security. Maturity 
is the date on which the security matures (expires). Coupon 
is the annual coupon interest rate (nominal rate of interest). 
Yield is the annual yield of the security. Frequency is the 
number of interest payments per year (1, 2 or 4). Basis 
indicates how the year is to be calculated.

EFFECT_ADD(Nominal rate, 
Npery)

Calculates the effective annual rate of interest on the basis of
the nominal interest rate and the number of interest 
payments per annum. Nominal interest refers to the amount 
of interest due at the end of a calculation period. Nominal 
rate is the annual nominal rate of interest. Npery is the 
number of interest payments per year.

EFFECTIVE(NOM, P) Calculates the effective annual rate of interest on the basis of
the nominal interest rate and the number of interest 
payments per annum. Nominal interest refers to the amount 
of interest due at the end of a calculation period. NOM is the 
nominal interest. P is the number of interest payment periods
per year.

FV(Rate, NPER, PMT, PV, Type) Returns the future value of an investment based on periodic, 
constant payments and a constant interest rate. Rate is the 
periodic interest rate. NPER is the total number of periods. 
PMT is the annuity paid regularly per period. PV (optional) is 
the present cash value of an investment. Type (optional) 
defines whether the payment is due at the beginning (1) or 
the end (0) of a period.

FVSCHEDULE(Principal, 
Schedule)

Calculates the accumulated value of the starting capital for a 
series of periodically varying interest rates. Principal is the 
starting capital. Schedule is a series of interest rates. 
Schedule has to be entered with cell references, or with a 
list.

INTRATE(Settlement, Maturity, 
Investment, Redemption, Basis)

Calculates the annual interest rate that results when a 
security (or other item) is purchased at an investment value 
and sold at a redemption value with no interest being paid. 
Settlement is the date of purchase of the security. Maturity 
is the date on which the security is sold. Investment is the 
purchase price. Redemption is the selling price. Basis 
indicates how the year is to be calculated.

IPMT(Rate, Period, NPER, pv, FV, 
Type)

Calculates the periodic amortization for an investment with 
regular payments and a constant interest rate. Rate is the 
periodic interest rate. Period is the period for which the 
compound interest is calculated. NPER is the total number of
periods during which annuity is paid. Period=NPER, if 
compound interest for the last period is calculated. pv is the 
present cash value in sequence of payments. FV (optional) is
the desired value (future value) at the end of the periods. 
Type (optional) defines whether the payment is due at the 
beginning (1) or the end (0) of a period.
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IRR(Values, Guess) Calculates the internal rate of return for an investment. The 
values represent cash flow values at regular intervals; at 
least one value must be negative (payments), and at least 
one value must be positive (income). Values is an array or 
cell range containing the values. Guess (optional) is the 
estimated value. If you can provide only a few values, you 
should provide an initial guess to enable the iteration.

ISPMT(rate, Period, total_periods, 
invest)

Calculates the level of interest for unchanged amortization 
installments. rate sets the periodic interest rate. Period is the
number of installments for calculation of interest. 
total_periods is the total number of installment periods. 
invest is the amount of the investment.

MDURATION(Settlement, Maturity,
Coupon, Yield, Frequency, Basis)

Calculates the modified Macauley duration for a security with 
an assumed par value of 100 currency units. Settlement is 
the date of purchase of the security. Maturity is the date on 
which the security matures (expires). Coupon is the annual 
nominal rate of interest (coupon interest rate) Yield is the 
annual yield of the security. Frequency is the number of 
interest payments per year (1, 2 or 4). Basis indicates how 
the year is to be calculated.

MIRR(Values, investment, 
reinvest_rate)

Calculates the modified internal rate of return of a series of 
investments. Values corresponds to the array or the cell 
reference for cells whose content corresponds to the 
payments. investment is the rate of interest of the 
investments (the negative values of the array) reinvest_rate 
is the rate of interest of the reinvestment (the positive values 
of the array).

NOMINAL(effect_rate, npery) Calculates the yearly nominal interest rate, given the 
effective rate and the number of compounding periods per 
year. effect_rate is the effective interest rate. npery is the 
number of periodic interest payments per year. Returns a 
percentage.

NOMINAL_ADD(Effective_rate, 
Npery)

Calculates the yearly nominal rate of interest, given the 
effective rate and the number of compounding periods per 
year. Effective_rate is the effective annual rate of interest. 
Npery is the number of interest payments per year. Returns 
a number.

NPER(Rate, PMT, PV, FV, Type) Returns the number of periods for an investment based on 
periodic, constant payments and a constant interest rate. 
Rate is the periodic interest rate. PMT is the constant annuity
paid in each period. PV is the present value (cash value) in a 
sequence of payments. FV (optional) is the future value, 
which is reached at the end of the last period. If FV is omitted
it is assumed to be zero. Type (optional) defines whether the 
payment is due at the beginning (1) or the end (0) of a 
period.

NPV(Rate, value 1, value 2, …, 
value 30)

Returns the net present value of an investment based on a 
series of periodic cash flows and a discount rate. Rate is the 
discount rate for a period. value 1, value 2, ..., value 30 are 
values representing deposits or withdrawals.

Appendix B  Description of Functions 397



Syntax Description

ODDFPRICE(Settlement, Maturity,
Issue, First coupon, Rate, Yield, 
Redemption, Frequency, Basis)

Calculates the price per 100 currency units par value of a 
security, having an odd (short or long) first period. Settlement 
is the date of purchase of the security. Maturity is the date on 
which the security matures (expires). Issue is the date of issue
of the security. First coupon is the first interest date of the 
security. Rate is the annual rate of interest. Yield is the annual
yield of the security. Redemption is the redemption value per 
100 currency units of par value. Frequency is the number of 
interest payments per year (1, 2 or 4). Basis indicates how the
year is to be calculated.

ODDFYIELD(Settlement, Maturity, 
Issue, First coupon, Rate, Price, 
Redemption, Frequency, Basis)

Calculates the yield of a security that has an odd (short or 
long) first period.

Settlement is the date of purchase of the security. Maturity 
is the date on which the security matures (expires). Issue is 
the date of issue of the security. First coupon is the first 
interest date of the security. Rate is the annual rate of 
interest. Price is the price of the security. Redemption is the 
redemption value per 100 currency units of par value. 
Frequency is the number of interest payments per year (1, 2 
or 4). Basis is chosen from a list of options and indicates 
how the year is to be calculated.

ODDLPRICE(Settlement, Maturity, 
Last interest, Rate, Yield, 
Redemption, Frequency, Basis)

Calculates the price per 100 currency units par value of a 
security, that has an odd (short or long) last period. 
Settlement is the date of purchase of the security. Maturity 
is the date on which the security matures (expires). Last 
interest is the last interest date of the security. Rate is the 
annual rate of interest. Yield is the annual yield of the 
security. Redemption is the redemption value per 100 
currency units of par value. Frequency is the number of 
interest payments per year (1, 2 or 4). Basis indicates how 
the year is to be calculated.

ODDLYIELD(Settlement, Maturity, 
Last interest, Rate, Price, 
Redemption, Frequency, Basis)

Calculates the yield of a security that has an odd (short or 
long) last period. Settlement is the date of purchase of the 
security. Maturity is the date on which the security matures 
(expires). Last interest is the last interest date of the 
security. Rate is the annual rate of interest. Price is the price 
of the security. Redemption is the redemption value per 100 
currency units of par value. Frequency is the number of 
interest payments per year (1, 2 or 4). Basis indicates how 
the year is to be calculated.

OPT_BARRIER(spot, vol, r, rf, T, 
strike, barrier_low, barrier_up, 
rebate, put/call, knock in/out, 
barrier_type, greek)

A function following the Black Scholes formula. It calculates 
the pricing of a barrier option. spot (required) is the 
price/value of the asset. vol (required) is the annual volatility 
of the asset. rebate (required) is the amount of money paid 
at maturity if the barrier was hit. put/call (required) is a string 
to define if the option is a (p)ut/ or a (c)all. knock (required) 
(i)n/(o)ut is a string to define if the option is of type knock-(i)n 
or knock-(o)ut. barrier_type (required) is a string to define 
whether the barrier is observed (c)ontinuosly or only at the 
(e)nd/maturity. greek is an optional parameter, which if left 
out causes the function to return the option price. If included, 
the function returns price sensitivities (Greeks) to one of the 
input parameters, such as “vega” for sensitivity to volatility.
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OPT_PROB_HIT(spot, vol, drift, T, 
barrier_low, barrier_up)

Returns the probability that an asset hits a barrier assuming it

follows
dS
S

=μdt+vol dW

spot is the price/value S of the underlying asset. vol is the 
annual volatility of the underlying asset. drift is the μ value of
the formula. T is the time to maturity. barrier_low is the lower
barrier and set to zero if there is no lower barrier. barrier_up 
is the upper barrier and is set to zero if there is no upper 
barrier. All parameters are required.

OPT_PROB_INMONEY(spot, vol, 
drift, T, barrier_low, barrier_up, 
put/call, strike)

Returns the probability that an asset will at maturity end up 
between two barrier levels, assuming it follows
dS
S

=μdt+vol dW . (If the last two optional parameters, 

put/call and strike, are specified, the probability of S_T in 
[strike, upper barrier] for a call, and S_T in [lower barrier, 
strike] for a put will be returned). S_T is the spot at maturity 
and ignores the possibility of knock-out before maturity.

spot (required) is the price/value of the asset. vol (required) 
is the annual volatility of the asset. drift (required) is the 
parameter μ from the formula above. T is the time to maturity
in years. barrier_low (required) is the lower barrier and set 
to zero if there is no lower barrier. barrier_up (required) is 
the upper barrier and is set to zero if there is no upper 
barrier. put/call (optional) is the (p)ut/(c)all indicator. strike 
(optional) is the strike level.

OPT_TOUCH(spot, vol, r, rf, T, 
barrier_low, barrier_up, 
foreign/domestic, knock in/out, 
barrier_type, greek)

Returns the pricing of a touch/no-touch option.

spot (required) is the price/value of the asset. vol (required) 
is the annual volatility of the asset. r (required) is the interest 
rate continuously compounded. rf (required) is the foreign 
interest rate continuously compounded. T (required) is the 
time to maturity entered in years. strike (required) is the 
strike level of the option. barrier_low (required) is the lower 
barrier and set to zero if there is no lower barrier. barrier_up 
(required) is the upper barrier and is set to zero if there is no 
upper barrier. foreign/domestic (required) is a string to 
define if the option pays one unit of (d)omestic currency 
(cash or nothing) or (f)oreign currency (asset or nothing). 
knock (required) (i)n/(o)ut is a string to define if the option is 
of type knock-(i)n (touch) or knock-(o)ut (no touch). 
barrier_type (required) is a string to define whether the 
barrier is observed (c)ontinuously or only at the 
(e)nd/maturity. greek is an optional parameter, which if left 
out causes the function to return the option price. If included, 
the function returns price sensitivities (Greeks) to one of the 
input parameters, such as “theta” for time sensitivity.
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PMT(Rate, NPER, PV, FV, Type) Returns the periodic payment for an annuity with constant 
interest rates. Rate is the periodic interest rate. NPER is the 
number of periods in which annuity is paid. PV is the present 
value (cash value) in a sequence of payments. FV (optional) 
is the desired value (future value) to be reached at the end of
the periodic payments. Type (optional) defines whether the 
payment is due at the beginning (1) or the end (0) of a 
period.

PPMT(Rate, Period, NPER, PV, 
FV, Type)

Returns for a given period the payment on the principal for an
investment that is based on periodic and constant payments 
and a constant interest rate. Rate is the periodic interest rate.
Period is the amortization period. NPER is the total number 
of periods during which annuity is paid. PV is the present 
value in the sequence of payments. FV (optional) is the 
desired (future) value. Type (optional) defines whether the 
payment is due at the beginning (1) or the end (0) of a 
period.

PRICE(Settlement, Maturity, Rate, 
Yield, Redemption, Frequency, 
Basis)

Calculates the price per 100 currency units of par value of an
interest-bearing security. Settlement is the date of purchase 
of the security. Maturity is the date on which the security 
matures (expires). Rate is the annual nominal rate of interest 
(coupon interest rate). Yield is the annual yield of the 
security. Redemption is the redemption value per 100 
currency units of par value. Frequency is the number of 
interest payments per year (1, 2 or 4). Basis indicates how 
the year is to be calculated.

PRICEDISC(Settlement, Maturity, 
Discount, Redemption, Basis)

Calculates the price per 100 currency units of par value of a 
discounted security. Settlement is the date of purchase of 
the security. Maturity is the date on which the security 
matures (expires). Discount is the discount of a security as a
percentage. Redemption is the redemption value per 100 
currency units of par value. Basis indicates how the year is 
to be calculated.

PRICEMAT(Settlement, Maturity, 
Issue, Rate, Yield, Basis)

Calculates the price per 100 currency units of par value of a 
security, that pays interest on the maturity date. Settlement 
is the date of purchase of the security. Maturity is the date 
on which the security matures (expires). Issue is the date of 
issue of the security. Rate is the interest rate of the security 
on the issue date. Yield is the annual yield of the security. 
Basis indicates how the year is to be calculated.

PV(Rate, NPER, PMT, FV, Type) Returns the present value of an investment resulting from a 
series of regular payments. Rate defines the interest rate per
period. NPER is the total number of payment periods. PMT is
the regular payment made per period. FV (optional) defines 
the future value remaining after the final installment has been
made. Type (optional) defines whether the payment is due at
the beginning (1) or the end (0) of a period.
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RATE(NPER, PMT, PV, FV, Type, 
Guess)

Returns the constant interest rate per period of an annuity. 
NPER is the total number of periods, during which payments 
are made (payment period). PMT is the constant payment 
(annuity) paid during each period. PV is the cash value in the
sequence of payments. FV (optional) is the future value, 
which is reached at the end of the periodic payments. Type 
(optional) defines whether the payment is due at the 
beginning (1) or the end (0) of a period. Guess (optional) 
determines the estimated value of the interest with iterative 
calculation.

RECEIVED(Settlement, Maturity, 
Investment, Discount, Basis)

Calculates the amount paid out at maturity for a fully invested
security. Settlement is the date of purchase of the security. 
Maturity is the date on which the security matures. 
Investment is the purchase sum. Discount is the 
percentage discount on acquisition of the security. Basis 
indicates how the year is to be calculated.

RRI(P, pv, FV) Calculates the interest rate resulting from the profit (return) of
an investment. P is the number of periods used for 
calculating the interest rate. pv is the present value (must be 
>0).  FV is the final value of the security.

SLN(Cost, Salvage, Life) Returns the straight-line depreciation of an asset for one 
period. The amount of the depreciation is constant during the
depreciation period. Cost is the initial cost of an asset. 
Salvage is the value of an asset at the end of the 
depreciation. Life is the number of periods in the useful life of
the asset.

SYD(Cost, Salvage, Life, Period) Returns the arithmetically declining value of an asset 
(depreciation) for a specified period. It uses the Sum-of-
Years'-Digits method. Cost is the initial cost of an asset. 
Salvage is the value of an asset after depreciation. Life is 
the period fixing the time span over which an asset is 
depreciated. Period defines the period for which the 
depreciation is to be calculated. Must use the same units as 
life.

TBILLEQ(Settlement, Maturity, 
Discount)

Calculates the bond equivalent yield for a treasury bill.   
Settlement is the date of purchase of the security. Maturity 
is the date on which the security matures (expires). The 
settlement and maturity date must be within a year of each 
other. Discount is the percentage discount on acquisition of 
the security. Calculated using the 360 days in a year basis 
(basis 2).

TBILLPRICE(Settlement, Maturity, 
Discount)

Calculates the price per 100 currency units face value of a 
treasury bill. Settlement is the date of purchase of the 
security. Maturity is the date on which the security matures 
(expires). The settlement and maturity date must be within a 
year of each other. Discount is the percentage discount 
upon acquisition of the security.
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TBILLYIELD(Settlement, Maturity, 
Price)

Calculates the yield of a treasury bill. Settlement is the date 
of purchase of the security. Maturity is the date on which the 
security matures (expires). The settlement and maturity date 
must be within a year of each other. Price is the price 
(purchase price) of the treasury bill per 100 currency units of 
par value.

VDB(Cost, Salvage, Life, S, end, 
Factor, Type)

Returns the depreciation of an asset for a specified or partial 
period using a variable declining balance method. Cost is the
initial value of an asset. Salvage is the value of an asset at 
the end of the depreciation. Life is the depreciation duration 
of the asset. S is the start period of the depreciation, entered 
in the same date unit as Life. end is the last period of the 
depreciation, entered in the same date unit as Life. Factor 
(optional) is the depreciation factor. If factor is omitted, a 
factor of two is assumed (the double-declining balance 
method). Type is an optional parameter. Type = 1 means a 
switch to linear depreciation. In Type = 0, no switch is made.

XIRR(Values, dDates, Guess) Calculates the internal rate of return for a list of payments 
which take place on different dates. The calculation is based 
on a 365 days per year basis, ignoring leap years. If the 
payments take place at regular intervals, use the IRR 
function. Values and Dates are a series of payments and the
series of associated date values entered as cell references. 
Values shall include at least one negative value and one 
positive value. Guess (optional) is a guess for the internal 
rate of return. If omitted, the value 10% is assumed.

XNPV(Rate, Values, Dates) Calculates the capital value (net present value) for a list of 
payments which take place on different dates. The 
calculation is based on a 365 days per year basis, ignoring 
leap years. If the payments take place at regular intervals, 
use the NPV function. Rate is the internal rate of return for 
the payments. Values and Dates are a series of payments 
and the series of associated date values entered as cell 
references. The first value-date pair indicates the start of the 
payments, other dates can be in any order. Values shall 
include at least one negative value and one positive value.

YIELD(Settlement, Maturity, Rate, 
Price, Redemption, Frequency, 
Basis)

Calculates the yield of a security that pays periodic interest. 
Settlement is the date of purchase of the security. Maturity 
is the date on which the security matures (expires). Rate is 
the annual rate of interest. Price is the price (purchase price)
of the security per 100 currency units of par value. 
Redemption is the redemption value per 100 currency units 
of par value. Frequency is the number of interest payments 
per year (1, 2 or 4). Basis indicates how the year is to be 
calculated.

YIELDDISC(Settlement, Maturity, 
Price, Redemption, Basis)

Calculates the annual yield of a non-interest-bearing security.
Settlement is the date of purchase of the security. Maturity 
is the date on which the security matures (expires). Price is 
the price (purchase price) of the security per 100 currency 
units of par value. Redemption is the redemption value per 
100 currency units of par value. Basis indicates how the year
is to be calculated.
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YIELDMAT(Settlement, Maturity, 
Issue, Rate, Price, Basis)

Calculates the annual yield of a security, the interest of which
is paid on the date of maturity. Settlement is the date of 
purchase of the security. Maturity is the date on which the 
security matures (expires). Issue is the date of issue of the 
security. Rate is the interest rate of the security on the issue 
date. Price is the price (purchase price) of the security per 
100 currency units of par value. Basis indicates how the year
is to be calculated.

Statistical analysis functions

Calc includes over 70 statistical functions which enable the evaluation of data from simple 
arithmetic calculations, such as averaging, to advanced distribution and probability computations. 
Several other statistics-based functions are available through the Add-ins which are noted at the 
end of this appendix.

Table 36: Statistical analysis functions

Syntax Description

AVEDEV(number 1, number 2, …,
number 30)

Returns the average of the absolute deviations of data points 
from their mean. Displays the diffusion in a data set. number 
1, number 2, …, number 30 are values or ranges that 
represent a sample. Each number can also be replaced by a 
reference.

AVERAGE(number 1, number 2, 
…, number 30)

Returns the average of the arguments. number 1, number 2,
…, number 30 are numerical values or ranges. Text is 
ignored.

AVERAGEA(value 1, value 2, …, 
value 30)

Returns the average of the arguments. The value of text is 
taken to be 0. value 1, value 2, …, value 30 are values or 
ranges.

AVERAGEIF(range, criteria, 
average_range)

Averages the arguments that meet the conditions. If the 
optional average_range is omitted, range, which is required, 
is the range of cells that will be averaged. criteria is a 
required value which determines which cells in range are 
averaged. If the optional average_range is used, it averages 
the values of cells of a range that is constructed using the top 
left cell of range and applying the dimensions, shape and 
size, of average_range. If no cell in range matches the 
criteria value, an Error is returned. If no numbers are in the 
range to be averaged, an Error is returned.

AVERAGEIFS(average_range, 
range 1, criteria 1, range 2, criteria
2, …, range 30, criteria 30)

Averages the values of the cells in a range that meet multiple 
criteria in multiple ranges.  average_range, range 1 and 
criteria 1 are required values. Averages the values of cells in 
average_range that meet the criteria 1 in range 1 and the 
criteria 2 in range 2, and so on. All ranges must have the 
same dimension and size, else an Error is returned. A logical 
AND is applied between each array result of each selection; a
cell of average_range is evaluated only if the same position 
in each array is the result of a criteria match. If no numbers 
are in the result set to be averaged, an Error is returned.
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B(trials, SP, T_1, T_2) Returns the probability of a sample with binomial distribution. 
trials is the number of independent trials. SP is the probability
of success on each trial. T_1 defines the lower limit for the 
number of trials. T_2 (optional) defines the upper limit for the 
number of trials.

BETADIST(number, alpha, beta, 
Start, End, Cumulative)

Returns the value of the probability density function or the 
cumulative distribution function for the beta distribution. 

number is the value between Start and End at which to 
evaluate the function. alpha is a parameter to the distribution.
beta is a parameter to the distribution. Start (optional) is the 
lower bound for number. End (optional) is the upper bound 
for number. Cumulative (optional) can be 0 or False to 
calculate the probability density function. It can be any other 
value or True or omitted to calculate the cumulative 
distribution function.

BETAINV(number; alpha, beta, 
Start, End)

Returns the inverse of the cumulative beta probability density 
function. number is the value between Start and End at 
which to evaluate the function. alpha is a parameter to the 
distribution. beta is a parameter to the distribution. Start 
(optional) is the lower bound for number. End (optional) is 
the upper bound for number.

BINOMDIST(X, trials, SP, C) Returns the individual term binomial distribution probability. X 
is the number of successes in a set of trials. trials is the 
number of independent trials. SP is the probability of success 
on each trial. C = 0 calculates the probability of a single event
and C = 1 calculates the cumulative probability.

CHIDIST(Number, 
degrees_freedom)

Returns the probability value that a hypothesis will be 
confirmed from the indicated chi square. The probability 
determined by CHIDIST can also be determined by CHITEST.
Number is the chi-square value of the random sample used 
to determine the error probability. degrees_freedom is the 
degrees of freedom of the experiment.

This function is defined by the ODF as LEGACY.CHIDIST. 
Use CHISQDIST for possible greater accuracy.

CHIINV(number, 
degrees_freedom)

Returns the inverse of the one-tailed probability of the chi-
squared distribution. number is the value of the error 
probability. degrees_freedom is the degrees of freedom of 
the experiment.

This function is defined by the ODF as LEGACY.CHIINV. Use 
CHISQINV for possible greater accuracy.

CHISQDIST(Number, Degrees of 
Freedom, Cumulative)

Returns the value of the probability density function or the 
cumulative distribution function for the chi-square distribution.
Number is the value at which you want to evaluate the 
distribution. Degrees of Freedom is the number of degrees of 
freedom. Cumulative (optional) is a logical value that determines
the form of the function. If cumulative is TRUE, CHISQDIST 
returns the cumulative distribution function; if FALSE, it returns 
the probability density function. If omitted, it is assumed TRUE.
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CHISQINV(Probability, Degrees of
Freedom)

Returns the inverse of CHISQDIST(x, Degrees of Freedom, 
TRUE()). 
Probability is the probability value for which the inverse of the 
chi square distribution is to be calculated. Degrees of Freedom 
is the number of degrees of freedom.

CHITEST(Data_B, data_E) Returns the chi-square distribution from a random distribution 
of two test series based on the chi-square test for 
independence. The probability determined by CHITEST can 
also be determined with CHIDIST, in which case the chi 
square of the random sample must then be passed as a 
parameter instead of the data row. Data_B is the array of the 
observations. data_E is the range of the expected values.

This function is defined by the ODF as LEGACY.CHITEST.

CONFIDENCE(alpha, STDEV, 
size)

Returns the (1-alpha) confidence interval for a normal 
distribution. alpha is the level of the confidence interval. 
STDEV is the standard deviation for the total population. size 
is the size of the total population.

CORREL(Data_1, Data_2) Returns the correlation coefficient between two data sets. 
Data_1 is the first data set. Data_2 is the second data set. 
Both arrays shall be the same size and shape. Any empty 
element or non-numeric value in an element will cause the 
corresponding element to be ignored.

COUNT(value 1, value 2, …, 
value 30)

Counts how many numbers are in the list of arguments. Text 
entries are ignored. value 1, value 2, …, value 30 are values
or ranges which are to be counted.

COUNTA(value 1, value 2, …, 
value 30)

Counts how many values are in the list of arguments. Text 
entries are also counted, even when they contain an empty 
string of length 0. If an argument is an array or reference, 
empty cells within the array or reference are ignored. value 1,
value 2, …, value 30 are up to 30 arguments representing 
the values to be counted.

COVAR(Data_1, Data_2) Returns the covariance of the product of paired deviations. 
Data_1 is the first data set. Data_2 is the second data set. 
Any empty element or non-numeric value in an element will 
cause the corresponding element to be ignored.

CRITBINOM(trials, SP, alpha) Returns the smallest value for which the cumulative binomial 
distribution is less than or equal to a criterion value. trials is 
the total number of trials. SP is the probability of success for 
one trial. alpha is the threshold probability to be reached or 
exceeded.

DEVSQ(number 1, number 2, …, 
number 30)

Returns the sum of squares of deviations based on a sample 
mean. number  1, number 2, …, number 30 are numerical 
values or ranges representing a sample.

EXPONDIST(Number; lambda, C) Returns the value of the probability density function or the 
cumulative distribution function for the exponential 
distribution.  Number is the value of the function. lambda is 
the parameter value. C is a logical value that determines the 
form of the function. C = 0 calculates the density function, and
C = 1 calculates the distribution function.
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FDIST(Number, 
degrees_freedom_1, 
degrees_freedom_2)

Calculates the values of an F probability distribution. Number 
is the value for which the F distribution is to be calculated. 
degrees_freedom_1 is the degrees of freedom in the 
numerator in the F distribution. degrees_freedom_2 is the 
degrees of freedom in the denominator in the F distribution. In
the ODF specification this is named LEGACY.FDIST and a 
new FDIST has been defined which has yet to be 
implemented in Calc.

FINV(number, 
degrees_freedom_1, 
degrees_freedom_2)

Returns the inverse of the F probability distribution.  number 
is the probability value for which the inverse F distribution is to
be calculated. degrees_freedom_1 is the number of degrees
of freedom in the numerator of the F distribution. 
degrees_freedom_2 is the number of degrees of freedom in 
the denominator of the F distribution. In the ODF specification
this is named LEGACY.FINV and a new FINV has been 
defined which has yet to be implemented in Calc.

FISHER(Number) Returns the Fisher transformation for the given Number. 
FISHER is a synonym for ATANH. 

FISHERINV(Number) Returns the inverse of the Fisher transformation for the given 
Number. FISHERINV is a synonym for TANH. 

FORECAST(value, data_Y, 
data_X)

Extrapolates future values based on existing x and y values. 
value is the x value, for which the y value of the linear 
regression is to be returned. data_Y is the array or range of 
known Y-values. data_X is the array or range of known X-
values. Does not work for exponential functions. Both arrays 
must be the same size and shape. A non-numeric value in an 
element causes the corresponding element to be ignored.

FTEST(data_1, data_2) Returns the result of an F test. data_1 is the first record array.
data_2 is the second record array.

GAMMA(Number) Returns the value of the Gamma function. Number is the 
value for which the Gamma function is to be calculated.

GAMMADIST(Number, alpha, 
beta, Cumulative)

Returns the value of the probability density function or the 
cumulative distribution function for the Gamma distribution.  
Number is the value for which the Gamma distribution is to 
be calculated. alpha is the parameter Alpha of the Gamma 
distribution. beta is the parameter Beta of the Gamma 
distribution. Cumulative = 0 calculates the density function, 
and Cumulative = 1 calculates the distribution.

GAMMAINV(Number, alpha, beta) Returns the inverse of the GAMMADIST(Number, alpha, beta,
TRUE()). This function allows you to search for variables with 
different distribution.

Number is the probability value for which the inverse Gamma
distribution is to be calculated. alpha is the parameter Alpha 
of the Gamma distribution. beta is the parameter Beta of the 
Gamma distribution.

GAMMALN(Number) Returns the natural logarithm of the Gamma function for the 
given Number.

GAUSS(Number) Returns 0.5 less than the standard normal cumulative 
distribution for the given Number.
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GEOMEAN(number 1, number 2, 
…, number 30)

Returns the geometric mean of a sample. number 1, number
2, …, number 30 are numerical arguments or ranges that 
represent the sample.

HARMEAN(number 1, number 2, 
…, number 30)

Returns the harmonic mean of a data set. The harmonic 
mean is the reciprocal of the arithmetic mean of reciprocals.  
number 1, number 2, …, number 30 are values or ranges 
for which you want to calculate the harmonic mean.

HYPGEOMDIST(X, n_sample, 
successes, n_population)

Returns the hypergeometric distribution. X is the number of 
successes achieved in the random sample. n_sample is the 
size of the random sample. successes is the number of 
successes in the total population. n_population is the size of 
the total population. This function does not fully comply with 
the ODF v1.2 specification, having no logical Cumulative 
parameter.

INTERCEPT(data_Y, data_X) Calculates the y-value at which a line will intersect the y-axis 
by using known x-values and y-values. data_Y is the array of 
Y-values. data_X is the array of X-values

Numbers or names, arrays or references containing numbers 
must be used here.

KURT(number 1, number 2, …, 
number 30)

Returns the kurtosis of a data set (at least 4 values required). 
number 1, number 2, …, number 30 are numerical 
arguments or ranges representing a random sample of 
distribution.

Kurtosis characterizes the relative peakedness or flatness of 
a distribution compared with the normal distribution. Positive 
kurtosis indicates a relatively peaked distribution (compared 
to the normal distribution), while negative kurtosis indicates a 
relatively flat distribution.

LARGE(data, Rank_c) Returns the Rank_c-th largest value in a data set. data is the 
cell range of data. Rank_c is the ranking of the value (2nd 
largest, 3rd largest, etc.) written as an integer.

LOGINV(number; mean, STDEV) Returns the inverse of the lognormal distribution for the given 
number, a probability value. mean is the arithmetic mean of 
the standard logarithmic distribution. STDEV is the standard 
deviation of the standard logarithmic distribution.

LOGNORMDIST(Number, mean, 
STDEV, Cumulative)

Returns the value of the probability density function or the 
cumulative distribution function for the lognormal distribution 
with the mean and standard deviation given.  Number, a 
probability value. mean is the mean value of the standard 
logarithmic distribution. STDEV is the standard deviation of 
the standard logarithmic distribution. Cumulative (optional) = 
0 calculates the density function, Cumulative = 1 calculates 
the distribution.

MAX(number 1, number 2, …, 
number 30)

Returns the maximum value in a list of arguments. number 1,
number_2, …, number 30 are numerical values or ranges. 
None-numbers are ignored.
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MAXA(value 1, value 2, …,  value 
30)

Returns the maximum value in a list of arguments. Unlike 
MAX, text and logical values can be entered. Text is 
evaluated as 0, logical True is treated as 1 and logical False 
as 0. value 1, value 2, …, value 30 are values or ranges.

MEDIAN(number 1, number 2, …,
number 30)

Returns the median of a set of numbers. number 1, number 
2, …, number 30 are values or ranges, which represent a 
sample. Each number can also be replaced by a reference.

MEDIAN logically ranks the numbers (lowest to highest). If 
given an odd number of values, MEDIAN returns the middle 
value. If given an even number of values, MEDIAN returns the
arithmetic average of the two middle values. 

MIN(number 1, number 2, …, 
number 30)

Returns the minimum value in a list of arguments. number 1, 
number 2, …, number 30 are numerical values or ranges.

MINA(value 1, value 2, …, value 
30)

Returns the minimum value in a list of arguments. Text and 
logical values are evaluated. Text is evaluated as 0, logical 
True is treated as 1 and logical False as 0. value 1, value 2, 
…, value 30 are values or ranges.

MODE(number 1, number 2, …, 
number 30)

Returns the most common value in a data set. number 1, 
number 2, …, number 30 are numerical values or ranges.  If 
several values have the same frequency, it returns the 
smallest value. An error occurs if a value does not appear 
more than once.

NEGBINOMDIST(X, R, SP) Returns the negative binomial distribution. X is the value 
returned for unsuccessful tests. R is the value returned for 
successful tests. SP is the probability of the success of an 
attempt.

NEGBINOMDIST returns the probability that there will be x 
failures before the r-th success, when the constant probability 
of a success is sp.

NORMDIST(Number, Mean, 
STDEV, C)

Returns the value of the probability density function or the 
cumulative distribution function for the normal distribution with
the mean and standard deviation given. 

Number is the value for which the normal distribution is to be 
calculated. Mean is the mean value of the normal distribution.
STDEV is the standard deviation of the normal distribution. C 
= 0 or FALSE it calculates the probability density function, and
C = 1, TRUE or omitted, it calculates the cumulative 
distribution function.

NORMINV(number, mean, 
STDEV)

Returns the inverse of the normal distribution for the given 
probability value, number, in the distribution. mean is the 
mean value in the normal distribution. STDEV is the standard 
deviation of the normal distribution.

NORMSDIST(Number) Returns the standard normal cumulative distribution for the 
given Number. This function is defined as 
LEGACY.NORMSDIST in the ODF v1.2 specification. This is 
exactly NORMDIST(x,0,1,TRUE()).
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NORMSINV(number) Returns the inverse of the standard normal distribution for the 
given probability value, number. number must be 0 < number
< 1. This function is defined as LEGACY.NORMSINV in the 
ODF v1.2 specification.

PEARSON(Data_1, Data_2) Returns the Pearson correlation coefficient, r, of two data 
sets. Data_1 is the array of the first data set. Data_2 is the 
array of the second data set. For an empty element or an 
element of type Text or Boolean in Data_1 the element at the 
corresponding position of Data_2 is ignored, and vice versa. 
Both arrays must be the same size and shape.

PERCENTILE(data, Alpha) Returns the alpha-percentile of data values in an array. data 
is the array of data. Alpha is the percentile value between 0 
and 1. If Alpha is not a multiple of 1/(n - 1), PERCENTILE 
interpolates to determine the value between two data points.

PERCENTRANK(data, value) Returns the percentage rank (percentile) of the given value in
a sample. data is the array of data in the sample. 

PERMUT(Count_1, Count_2) Returns the number of permutations for a given number of 
objects without repetition. Count_1 is the total number of 
objects. Count_2 is the number of objects in each 
permutation.

PERMUTATIONA(Count_1, 
Count_2)

Returns the number of permutations for a given number of 
objects (repetition allowed, meaning an object can combine 
with itself). Count_1 is the total number of objects. Count_2 
is the number of objects in each permutation.

PHI(number) Returns the values of the distribution function for a standard 
normal distribution for the given number. PHI(number) is a 
synonym for NORMDIST(number,0,1,FALSE()).

POISSON(Number, mean, 
Cumulative)

Returns the probability, or the cumulative distribution function 
for the Poisson distribution of Number. mean is the middle 
value of the Poisson distribution. Cumulative = 0 calculates 
the probability density function, and Cumulative = 1 
calculates the distribution.

PROB(data, probability, Start, 
End)

Returns the probability that values in a range are between 
two limits. data is the array or range of data in the sample. 
probability is the array or range of the corresponding 
probabilities. Start is the start value of the interval whose 
probabilities are to be summed. End (optional) is the end 
value of the interval whose probabilities are to be summed. If 
this parameter is missing, then End = Start value is assumed.

QUARTILE(data, Type) Returns the quartile of a data set. data is the array of data in 
the sample. Type is the number of the quartile to return. (0 = 
Min, 1 = 25%, 2 = 50% (Median), 3 = 75% and 4 = Max). 
Based on the statistical rank of the data points in data, 
QUARTILE returns the percentile value indicated by Type. 
The percentile is calculated as Type divided by 4. The same 
algorithm used in PERCENTILE is used here to interpolate 
between two data points.
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RANK(value, Data, Type) Returns the rank of the given value in a sample. Data is the 
array or range of data in the sample. Type (optional) is the 
ranking order, if omitted or 0 data is ranked in ascending 
order, if not 0 data is ranked in descending order.

RSQ(data_Y, data_X) Returns the square of the Pearson product moment 
correlation coefficient based on the given values. data_Y is 
an array of data points. data_X is an array of data points. The
arguments shall be either numbers or names, arrays, or 
references that contain numbers.

If an array or reference argument contains Text, Logical 
values, or empty cells, those values are ignored; however, 
cells with the value zero are included. Both arrays must have 
the same size and shape.

SKEW(number 1, number 2, …, 
number 30)

Returns the skewness of a distribution. number 1, number 2,
…, number 30 are numerical values or ranges. There must 
be a minimum of three numbers.

SKEWP(number 1, number 2, …, 
number 30)

Calculates the skewness of a distribution using the population
of a random variable. number 1, number 2, …, number 30 
are numerical values or ranges. There must be a minimum of 
three numbers.

SLOPE(data_Y, data_X) Returns the slope of the linear regression line.  data_Y is the 
array or matrix of Y data. data_X is the array or matrix of X 
data. Both arrays must have the same size and shape. For an
empty element or an element of type Text or Boolean in y the 
element at the corresponding position of x is ignored, and 
vice versa.

SMALL(data, Rank_c) Returns the Rank_c-th smallest value in a data set. data is 
the cell range of data. Rank_c is the rank of the value (2nd 
smallest, 3rd smallest, etc.) written as an integer.

STANDARDIZE(Number, mean, 
STDEV)

Converts a random variable to a normalized value. Number is
the value to be standardized. mean is the arithmetic mean of 
the distribution. STDEV is the standard deviation of the 
distribution.

STDEV(number 1, number 2, …, 
number 30)

Computes the sample standard deviation of a set of numbers.

 number 1, number 2, …, number 30 are numerical values 
or ranges representing a sample based on an entire 
population.

STDEVA(value 1, value 2, …, 
value 30)

Calculates the standard deviation using a sample set of 
values, including values of type Text and Logical. 

 value 1, value 2, …, value 30 are values or ranges 
representing a sample derived from an entire population. Text 
has the value 0.

STDEVP(number 1, number 2, …,
number 30)

Calculates the standard deviation using the population of a 
random variable, including values of type Text and Logical. 

 number 1, number 2, …, number 30 are numerical values 
or ranges representing a sample based on an entire 
population.
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STDEVPA(value 1, value 2, …, 
value 30)

Calculates the standard deviation based on the entire 
population. value 1, value 2, …, value 30 are values or 
ranges representing a sample derived from an entire 
population. Text has the value 0. Logical FALSE is 0 and 
logical TRUE is 1.

STEYX(data_Y, data_X) Returns the standard error of the predicted y value for each x 
in the regression. data_Y is the array or matrix of Y data. 
data_X is the array or matrix of X data. Both arrays must 
have the same size and shape and contain at least three 
numbers.

TDIST(Number, 
degrees_freedom, mode)

Returns the t-distribution for the given Number. 
degrees_freedom is the number of degrees of freedom for 
the t-distribution. mode = 1 returns the one-tailed test, mode 
= 2 returns the two-tailed test. This function is named 
LEGACY.TDIST in the ODF v1.2 specification.

TINV(number, degrees_freedom) Returns the inverse of the t-distribution, for the given number 
associated with the two-tailed t-distribution. 
degrees_freedom is the number of degrees of freedom for 
the t-distribution.

TRIMMEAN(data, Alpha) Returns the mean of a data set, ignoring a proportion of high 
and low values. data (required) is the array of data in the 
sample. Alpha (required) is the fractional number of data 
points to exclude from the calculation. For example, if Alpha 
= 0.2, 4 points are trimmed from a data set of 20 points (20 x 
0.2): 2 from the top and 2 from the bottom of the set. 

TTEST(data_1, data_2, mode, 
Type)

Returns the probability associated with a Student’s t-Test. 
data_1 is the dependent array or range of data for the first 
record. data_2 is the dependent array or range of data for the
second record. mode = 1 calculates the one-tailed 
distribution, mode = 2 the two- tailed distribution. Type of t-
test to perform: paired (1), equal variance (homoscedastic) 
(2), or unequal variance (heteroscedastic) (3).

VAR(number 1, number 2, …, 
number 30)

Calculates the variance based on a sample. number 1, 
number 2, …, number 30 are numerical values or ranges 
representing a sample based on an entire population. 
Requires at least two numbers.

VARA(value 1, value 2, …, value 
30)

Estimates a variance based on a sample. value 1, value 2, …,
value 30 are values or ranges representing a sample derived 
from an entire population. Text is evaluated as 0. Logical 
TRUE is evaluated as 1 and FALSE as 0.

VARP(number 1, number 2, …, 
number 30)

Calculates a variance based on the entire population. 
number 1, number 2, …, number 30 are numerical values or
ranges representing an entire population.

VARPA(value 1, value 2, …, value
30)

Calculates the variance based on the entire population. The 
value of text is 0. value 1, value 2, …, value 30 are values or
ranges representing an entire population. Text is evaluated as
0. Logical TRUE is evaluated as 1 and FALSE as 0.
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WEIBULL(Number, Alpha, beta, 
C)

Returns the values of the Weibull distribution at the given 
Number. Alpha is the alpha parameter of the Weibull 
distribution. beta is the beta parameter of the Weibull 
distribution. C indicates the type of function: C= 0 the 
probability density function is calculated, C=1 the cumulative 
distribution function is calculated.

ZTEST(data, mu, sigma) Returns the two-tailed P value of a z test with standard 
distribution. data is the array of the data. mu is the value to 
be tested. sigma (optional) is the standard deviation of the 
total population. If this argument is missing, the standard 
deviation of the sample is processed.

Date and time functions

Use these functions for inserting, editing, and manipulating dates and times. LibreOffice handles 
and computes a date/time value as a number. When you assign the number format “Number” to a 
date or time value, it is displayed as a number. For example, 01/01/2000 12:00 PM, converts to 
36526.5. This is just a matter of formatting; the actual value is always stored and manipulated as a 
number. To see the date or time displayed in a standard format, change the number format (date or
time) accordingly.

To set the default date format used by Calc, go to Tools > Options > LibreOffice Calc > 
Calculate.

Caution When entering dates, slashes or dashes used as date separators may be interpreted
as arithmetic operators. To keep dates from being interpreted as parts of formulas, 
and thus returning erroneous results, always place them in quotation marks, for 
example, "12/08/52". See also A note about dates on page 392.

Table 37: Data and time functions

Syntax Description

DATE(year, month, day) Converts a date written as year, month, day to an internal 
serial number and displays it in the cell’s formatting. year is 
an integer between 1583 and 9956 or 0 and 99. month is an 
integer between 1 and 12. day is an integer between 1 and 
31.

DATEDIF(Start date, End date, 
Interval)

Returns the difference in years, months, or days of two date 
numbers, Start date and End date. Interval is entered as “y”,
“m” or “d”, to return the value in years, months or days or as 
“ym”, “md” or “yd” for months ignoring the years value; days 
ignoring the months and years values; or days ignoring the 
months and years values. Start date and End date must be 
entered using double quotes.

DATEVALUE(text) Returns the date serial number for text in double quotes using
the current locale. text is a valid date expression.

DAY(Number) Returns the day, as an integer, of the given date value. 
Number is the date serial number (a negative date/time value
can be entered) or a date value entered in double quotes.
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DAYS(Date_2, Date_1) Calculates the difference, in days, between two date values. 
Date_1 is the start date. Date_2 is the end date. If Date_2 is 
an earlier date than Date_1, the result is a negative number. 
Dates can be entered as numbers or text.

DAYS360(Date_1, Date_2, Type) Returns the difference between two dates based on the 360 
day year used in interest calculations. If Date_2 is earlier than
Date_1, the function will return a negative number. Type 
(optional) determines the type of difference calculation: the 
US method (0) or the European method (≠0). Dates can be 
entered as numbers or text.

DAYSINMONTH(Date) Calculates the number of days in the month of the given Date.
Date can be entered as a number or text. 

DAYSINYEAR(Date) Calculates the number of days in the year of the given Date. 
Date can be entered as a number or text.

EASTERSUNDAY(year) Returns the date of Easter Sunday for the entered year. year 
is an integer between 1583 and 9956 or 0 and 99 (19xx or 
20xx depending on the option set)..

EDATE(Start date, Months) Returns the serial number of the date a number of Months 
away from the given Start date. Only months are considered; 
days are not used for calculation. Months is the number of 
months before (negative) or after (positive) the start date. 
Start date may be entered as text or a number.

EOMONTH(Start date, Months) Returns the serial number date of the last day of a month 
which falls Months away from the given Start date. Months 
is the number of months before (negative) or after (positive) 
the start date. Start date may be entered as text or a number.

HOUR(Number) Returns the hour, as an integer, for the given time value. 
Number is a time value and can be either text or a number.

ISLEAPYEAR(Date) Determines whether a given Date falls within a leap year. 
Returns either 1 (TRUE) or 0 (FALSE). Date must be a full 
date for text, a reference to a date value or a serial number.

MINUTE(Number) Returns the minute, as an integer, for the given time value. 
Number is a time value.

MONTH(Number) Returns the month, as an integer, for the given date value. 
Number is a time value.

MONTHS(Start date, End date, 
Type)

Calculates the difference, in months, between two date 
values. Start date is the start (earlier) date. End date is the 
end date. Type determines the type of calculation and is one 
of two possible values; 1 returns the difference between the 
calendar month values in the two dates, disregarding the day 
values; 0 returns the number of months that separate the 
dates taking into account the day values of the two dates. If 
End date is an earlier date than Start date, the result is a 
negative number.
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NETWORKDAYS(Start date, End 
date, Holidays)

Returns the number of workdays between Start date and 
End date. Holidays can be deducted. Start date is the date 
from which the calculation is carried out. End date is the date 
up to which the calculation is carried out. If the start or end 
date is a workday, the day is included in the calculation. 
Holidays (optional) is a list of holidays. Enter a cell range in 
which the holidays are listed individually. Saturdays and 
Sundays are considered non-workdays.

NOW() Returns the computer system date and time. The value is 
updated when your document recalculates. NOW() is a 
function without arguments.

SECOND(Number) Returns the second, as an integer, for the given time value. 
Number is a time value.

TIME(hour, minute, second) Returns the time value from values for hours, minutes and 
seconds. This function can be used to convert a time based 
on these three elements to a decimal time value. hour, 
minute and second must all be integers.

TIMEVALUE(text) Returns the time serial number value from text enclosed by 
quotes in a time entry format. The value of the decimal 
number returned is the result of the date system used under 
LibreOffice to calculate date entries.

TODAY() Returns the current computer system date. The value is 
updated when your document recalculates. TODAY() is a 
function without arguments.

WEEKDAY(Number, Type) Returns the day of the week for the given Number (date 
value). The day is returned as an integer based on the type. 
Type determines the type of calculation: Type = 1 (assumed if
Type is omitted), the weekdays are counted (1-7) starting 
from Sunday (Monday = 2); Type = 2, the weekdays are 
counted (1-7) starting from Monday (Monday = 1); Type = 3, 
the weekdays are counted (0-6) starting from Monday 
(Monday = 0).

WEEKNUM(Number, mode) Calculates the number of the calendar week of the year for 
the given date Number. mode sets the start of the week and 
the calculation type: 1 = Sunday, any other value = Monday.

WEEKNUM_ADD(Date, Return 
type)

Calculates the calendar week of the year for a Date. Date is 
the date within the calendar week. Return type sets the start 
of the week and the calculation type: 1 = Sunday, 2 = 
Monday. This function returns the same results as the 
WEEKNUM function in Excel.

WEEKS(Start date, End date, 
Type)

Calculates the difference in weeks between two dates, Start 
date and End date. Type is one of two possible values, 0 
(number of whole weeks in the interval) or 1 (returns the 
number of different weeks in which the two dates appear). 
This function uses the ISO weeknumber.

WEEKSINYEAR(Date) Calculates the number of weeks in a year for a given Date. A 
week that spans two years is added to the year in which most 
days of that week occur (so any week containing four or more
days in the calendar year of Date is counted).
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WORKDAY(Start date, Days, 
Holidays) 

Returns a date serial number which is a specified number of 
work days (Days) before or after an input date, Start date. 
Holidays (optional) is a list of holidays. Enter a cell range in 
which the holidays are listed individually. Work days exclude 
Saturdays and Sundays. This function does not fully 
implement the ODFv1.2 specification which allows you to set 
the non-work days.

YEAR(Number) Returns the calendar year as an integer according to the 
internal calculation rules. Number is the date value in date 
serial number format or as a text date, for which the year is to 
be returned.

YEARFRAC(Start date, End date, 
Basis)

Extracts the number of years (including fractional part) 
between two date values, Start date and End date. Basis is 
a value either omitted or between 0 and 4, chosen from a list 
of options and indicates how the year is to be calculated (see 
Help files). If omitted it is evaluated as 0.

YEARS(Start date, End date, 
Type)

Calculates the difference in years between two dates: the 
Start date and the End date. Type calculates the type of 
difference. Possible values are 0 (interval) and 1 (in calendar 
years).

Logical functions

Use the logical functions to test values and produce results based on the result of the test. These 
functions are conditional and provide the ability to write longer formulas based on input or output.

Table 38: Logical functions

Syntax Description

AND(Logical value 1, Logical 
value 2, …, Logical value 30)

Returns TRUE if all arguments are TRUE. If any element is 
FALSE, this function returns the FALSE value. Logical value 1, 
Logical value 2, …, Logical value 30 are conditions to be 
checked. All conditions can be either TRUE or FALSE. If a range is
entered as a parameter, only logical values in the range are 
evaluated. The result is TRUE if the logical value in all cells within 
the cell range is TRUE.

Bug 70632: Concerning range statement given in Help.

FALSE() Set the logical value to FALSE. The FALSE() function does not 
require any arguments.

IF(Test; Then_value, 
Otherwise_value)

Specifies a logical test to be performed. Test is any value or 
expression that can be TRUE or FALSE. Then_value (optional) is 
the value that is returned if the logical test is TRUE. 
Otherwise_value (optional) is the value that is returned if the 
logical test is FALSE.

IFERROR(value, alternative 
value)

Evaluates value; if it is not an error it returns the result for value, 
or else it returns the alternative value. If value evaluates to a 
logical value, then either 1 (for TRUE), or 0 (for FALSE) is 
returned.
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IFNA(value, alternative 
value)

Evaluates value; if it is not a #N/A error it returns the result for 
value, or else it returns the alternative value. If value evaluates 
to a logical value, then either 1 (for TRUE), or 0 (for FALSE) is 
returned.

NOT(Logical value) Reverses the logical value. Logical value is the TRUE or FALSE 
value to be reversed.

OR(Logical value 1, Logical 
value 2, …, Logical value 30)

Returns TRUE if at least one argument is TRUE. Returns the value
FALSE if all the arguments have the logical value FALSE. Logical 
value 1, Logical value 2, …, Logical value 30 are conditions to 
be checked. All conditions can be either TRUE or FALSE.

TRUE() Sets the logical value to TRUE. The TRUE() function does not 
require any arguments.

XOR(Logical value 1, Logical
value 2, …, Logical value 30)

Computes the logical XOR of the parameters. If an even number 
of parameters is TRUE it returns FALSE, if an odd number of 
parameters is TRUE it returns TRUE.

Information functions

These functions provide information (or feedback) regarding the results of a test for a specific 
condition, or a test for the type of data or content a cell contains.

Table 39: Informational functions

Syntax Description

CELL(info_type, Reference) Returns information on a cell such as its address, formatting or 
contents of a cell based on the value of the info_type argument.
info_type specifies the type of information to be returned and 
comes from a predefined list of arguments. See Help files for 
complete listing. info_type is not case sensitive, but it must be 
enclosed within quotes. Reference is the address of the cell to 
be examined. If Reference is a range, the cell reference moves
to the top left of the range. If Reference is missing, Calc uses 
the position of the cell in which this formula is located.

CURRENT() Calculates the current value of a formula at the actual position.

FORMULA(Reference) Displays in the current location, the formula contained in a cell 
cell at Reference position. If no formula at Reference can be 
found, or if the presented argument is not a reference, returns 
the error value #N/A.

INFO(Text) Returns information about the working environment. Text is a 
string constant entered in double quotes taken from a list of 
arguments. See the Help files for the listing.

ISBLANK(value) Returns TRUE if the referenced cell is blank, else returns 
FALSE. If value is of type Number, Text, or Logical, return 
FALSE. If value is a reference to a cell, examine the cell; if it is 
blank (has no value), return TRUE, but if it has a value, return 
FALSE. A cell with the empty string is not considered blank. 
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ISERR(value) Returns TRUE if the value refers to any error value except 
#N/A. You can use this function to control error values in certain
cells. If an error occurs, the function returns a logical or 
numerical value. value is any value or expression in which a 
test is performed to determine whether an error value not equal 
to #N/A is present.

ISERROR(value) The ISERROR tests if the cells contain general error values. 
ISERROR recognizes the #N/A error value. If an error occurs, 
the function returns a logical or numerical value. value is any 
value where a test is performed to determine whether it is an 
error value.

ISEVEN(value) Returns TRUE if the given value is an even integer, or FALSE if
the value is odd. If the value is not an integer, the function 
evaluates only the integer part of the value.

ISEVEN_ADD(Number) Tests for even numbers. Returns TRUE (1) if the integer part of 
Number returns a whole number when divided by 2.

ISFORMULA(reference) Returns TRUE if a cell is a formula cell. If an error occurs, the 
function returns a logical or numerical value. reference 
indicates the reference to a cell in which the test will be 
performed.

ISLOGICAL(value) Returns TRUE if the cell contains a logical number format. The 
function is used in order to check for both TRUE and FALSE 
values in certain cells. If an error occurs, the function returns a 
logical or numerical value. value is the cell reference to be 
tested for logical number format.

ISNA(value) Returns TRUE if value contains the #N/A (value not available) 
error value. If an error occurs, the function returns a logical or 
numerical value. value is the cell, value or expression to be 
tested.

ISNONTEXT(value) Return TRUE if the parameter does not have type Text, else 
return FALSE. If an error occurs, the function returns a logical 
or numerical value. value is any value or expression where a 
test is performed to determine whether it is a text or numbers or
a Boolean value. Empty cells are considered non-text and will 
return TRUE.

ISNUMBER(value) Returns TRUE if value evaluates to a number. If an error 
occurs, the function returns a logical or numerical value. value 
is any expression to be tested to determine whether it is a 
number or text. TRUE (1) and FALSE (0) are evaluated as 
numbers.

ISODD(value) Returns TRUE if value evaluates as an odd integer, else 
FALSE. value is truncated to an integer before evaluation. 
TRUE (1) and FALSE (0) are evaluated as numbers. Text 
returns an error. Zero is evaluated FALSE.

ISODD_ADD(Number) Returns 1 if Number does not return a whole number when 
divided by 2, else 0. Number is the number to be tested.

Does not return logical type TRUE/FALSE like ISODD; returns 
number.
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ISREF(value) Returns TRUE if value is of type reference (including a 
reference list), else return FALSE. If an error occurs, the 
function returns a logical or numerical value. It does not 
evaluate the content of the reference.

ISTEXT(value) Returns TRUE if value is of type text, else FALSE. If an error 
occurs, the function returns a logical or numerical value. Value 
is a value, number, Boolean value, or error value to be tested. If
value is a reference, the content of the reference is evaluated.

N(value) Return the number of value. If value is a reference the 
reference content is evaluated. If value is a logical value, 1 is 
returned for TRUE, else 0. If value is an error it is returned. 
Text returns a 0.

NA() Returns the error value #N/A.

TYPE(value) Evaluates value and returns a number indicating its type. If an 
error occurs, the function returns the error. The numerical value
from which the data type is determined is; 1 = number, 2 = text, 
4 = Boolean value, 8 = formula, 16 = error value. If value 
references an empty cell, an error is returned. The results of a 
formula in a reference are not evaluated.

Database functions

This section deals with functions used with data organized as one row of data for one record. The 
Database category should not be confused with the Base database component in LibreOffice. A 
Calc database is simply a range of cells that comprises a block of related data where each row 
contains a separate record. There is no connection between a database in LibreOffice and the 
Database category in LibreOffice Calc.

The database functions use the following common arguments:

• Database is a range of cells which define the database.

• Database field specifies the column which the function operates on after the search 
criteria of the first parameter is applied and the data rows are selected. It is not related to 
the search criteria itself. The number 0 specifies the whole data range. To reference a 
column by using the column header name, place quotation marks around the header name.

• Search criteria is a cell range containing the search criteria.. Empty cells in the search 
criteria range will be ignored.

Note

All of the search criteria arguments for the database functions support regular 
expressions. For example, “all.*” can be entered to find the first location of “all” 
followed by any characters. To search for text that is also a regular expression, 
precede every character with a \ character. You can switch the automatic evaluation of
regular expressions on and off in Tools > Options > LibreOffice Calc > Calculate.
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Table 40: Database average

Syntax Description

DAVERAGE(Database, 
Database field, Search 
criteria)

Returns the average of the values in a given database field from 
the records (rows) in a database that match the search criteria. 
Database field cannot be 0 or empty.

DCOUNT(Database, 
Database field, Search 
criteria)

Counts the number of records (rows) in a database that match the
search criteria and contain numerical values. Database field can 
be empty or 0.

DCOUNTA(Database, 
Database field, Search 
criteria)

Counts the number of rows (records) in a database that match the
specified search criteria and contain numeric or alphanumeric 
values. Database field can be empty or 0.

DGET(Database, Database 
field, Search criteria)

Returns the field value from a record in a database, which 
matches the search criteria. The search criteria must return a 
single value. In case of an error, the function returns either 
#VALUE! for no record or field values found, or Err502 for more 
than one cell in the search criteria. 

DMAX(Database, Database 
field, Search criteria)

Returns the maximum value of a field in a database (all records) 
that matches the specified Search criteria. The search supports 
regular expressions.

DMIN(Database, Database 
field, Search criteria)

Returns the minimum value of a field in a database that matches 
the specified Search criteria. The search supports regular 
expressions. 

DPRODUCT(Database, 
Database field, Search 
criteria)

Multiplies all cells of a data range where the cell contents match 
the Search criteria. The search supports regular expressions.

DSTDEV(Database, 
Database field, Search 
criteria)

Finds the sample standard deviation in a given field from the 
records (rows) in a database that match a search criteria.

DSTDEVP(Database, 
Database field, Search 
criteria)

Finds the population standard deviation in a given field from the 
records (rows) in a database that match a search criteria.

DSUM(Database, Database 
field, Search criteria)

Finds the sum of values in a given field from the records (rows) in 
a database that match a search criteria. The search supports 
regular expressions.

DVAR(Database, Database 
field, Search criteria)

Finds the sample variance in a given field from the records (rows) 
in a database that match a search criteria.

DVARP(Database, Database 
field, Search criteria)

Finds the population variance in a given field from the records 
(rows) in a database that match a search criteria.
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Array functions

When using the Function Wizard for Array functions, those returning an array result have the Array 
check-box automatically selected.

Table 41: Array functions

Syntax Description

FREQUENCY(data, classes) Categorizes values into intervals and counts the number of values
in each interval. Returns the results as a vertical array containing 
one more result than the number of classes. data is the data that 
should be categorized and counted according to the given 
intervals.  classes is the array containing the upper boundaries 
determining the intervals the values in data should be grouped by. 

GROWTH(data_Y, data_X, 
new_data_X, Function_type)

Calculates predicted exponential growth by using existing data.  
data_Y is the Y data array. data_X (optional) is the X data array. 
new_data_X (optional) is the X data array, for which the values 
are to be calculated. If new_data_X is omitted it is assumed to be 
the same size as data_X. If both arrays are omitted, they are 
assumed to be the array {1,2,3,...} that is the same size as the Y 
data array. Function_type is optional. If Function_type = 1 or 
omitted, functions in the form y = b*m^x are calculated, else y = 
m^x functions are calculated.

LINEST(data_Y, data_X, 
Linear_type, stats)

Returns the parameters of the (simple or multiple) linear 
regression equation for the given data and, optionally, statistics on
this regression. The equation for the line is y = mx + c, or y = 
m1x1 + m2x2 + … + c for multiple ranges of x-values, where the 
dependent y-values are a function of the independent x-values. 
The m-values are coefficients corresponding to each x-value, and 
c is a constant value. data_Y is a single row or column range 
specifying the y coordinates in a set of data points. data_X 
(optional) is a corresponding single row or column range 
specifying the x coordinates. If data_X is omitted it defaults to 
{1,2,3,..., n}. If there is more than one set of variables data_X may
be a range with corresponding multiple rows or columns. 
Linear_type (optional): if FALSE the straight line found is forced 
to pass through the origin (the constant c is zero; y = mx). If 
omitted, Linear_type defaults to TRUE (the line is not forced 
through the origin). stats (optional): If stats = 0, only the 
regression coefficient is calculated. Otherwise, other statistics will 
be returned, see the Help file for full information.

LOGEST(data_Y, data_X, 
Function_type, stats)

Calculates the adjustment of the entered data as an exponential 
regression curve (y=b*m^x). data_Y is the Y Data array. data_X 
(optional) is the X data array. Function_type (optional): If 
Function_type = 0, functions in the form y = m^x are calculated. 
Otherwise, y = b*m^x functions are calculated. stats (optional). If 
stats = 0, only the regression coefficient is calculated; if stats = 1 
other statistics will be returned, see the Help file for full 
information.

MDETERM(array) Returns the determinant of a square array. This function returns a 
value in the current cell; it is not necessary to define a range for 
the results. array is an array in which the determinants are 
defined. The Array check-box is not automatically selected.

Appendix B  Description of Functions 420



Syntax Description

MINVERSE(array) Returns the inverse array. array is a square array that is to be 
inverted.

MMULT(array, array) Calculates the array product of two arrays. The number of 
columns for array 1 must equal the number of rows for array 2. 
array at first place is the first array used in the array product. 
array at second place is the second array with the same number 
of rows as the first array has columns.

Bug 71128: Same name for two variables.

MUNIT(Dimensions) Returns the unitary square array of a certain size. The unitary 
array is a square array where the main diagonal (top left to bottom
right) elements are set to 1 and all other array elements are set to 
0. Dimensions refers to the column and row size of the array.

SUMPRODUCT(Array 1, 
Array 2, …, Array 30)

Multiplies corresponding elements in the given arrays, and returns
the sum of those products. Array 1, Array 2, …, Array 30 are 
arrays whose corresponding elements are to be multiplied. At 
least one array must be part of the argument list. If only one array 
is given, the array elements are summed. Arrays must have the 
same size and shape. Non numeric elements are treated as 0. 
The Array check-box is not automatically selected.

SUMX2MY2(array_x, 
array_y)

Returns the sum of the difference of the squares of corresponding 
values in two arrays. array_x is the first array whose elements are
to be squared and added. array_y is the second array whose 
elements are to be squared and subtracted. Arrays must have the 
same size and shape. The Array check-box is not automatically 
selected.

SUMX2PY2(array_x, array_y) Returns the sum of the sum of the squares of the individual values
in each array. array_x is the first array whose arguments are to be
squared and summed. array_y is the second array, whose 
arguments are to be squared and summed and then summed with
the result from the first array. Arrays must have the same size and 
shape. The Array check-box is not automatically selected.

SUMXMY2(array_x, array_y) Adds the squares of the difference between corresponding values 
in two arrays. array_x is the first array from whose elements the 
corresponding elements of array_y are to be subtracted. The 
results of each subtraction are summed and the results squared. 
Arrays must have the same size and shape. The Array check-box 
is not automatically selected.

TRANSPOSE(array) Transposes the rows and columns of an array. array is the array in
the spreadsheet that is to be transposed.

TREND(data_Y, data_X, 
new_data_X, Linear_type)

Returns values along a linear trend. data_Y is the Y data array. 
data_X (optional) is the X data array. new_data_X (optional) is 
the array of the X data, which are used for recalculating values. If 
new_data_X is omitted it is assumed to be the same size as 
data_X. If both arrays are omitted, they are assumed to be the 
array {1,2,3,...} that is the same size as the Y data array. 
Linear_type is optional. If Linear_type = 1 or omitted, functions 
in the form y = mx + c are calculated, else y = mx functions are 
calculated.
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Spreadsheet functions

Use spreadsheet functions to search and address cell ranges and provide feedback regarding the 
contents of a cell or range of cells. You can use functions such as HYPERLINK() and DDE() to 
connect to other documents or data sources.

Table 42: Spreadsheet functions

Syntax Description

ADDRESS(row, column, ABS, A1, 
sheet)

Returns a cell address (reference) as text, according to the
specified row and column numbers. Optionally, whether the
address is interpreted as an absolute address (for 
example, $A$1) or as a relative address (as A1) or in a 
mixed form (A$1 or $A1) can be determined. The name of 
the sheet can also be specified. row (required) is the row 
number for the cell reference. column (required) is the 
column number for the cell reference (the number, not the 
letter). ABS (optional) determines the type of reference 
and is a value between 1 and 4. See the Help files for 
explanation of list numbers. Optional A1 if set to 0 uses the
R1C1 notation, else it uses the A1 notation. Optional sheet
is the name of the sheet entered in double quotes. If using 
R1C1 notation, ADDRESS returns address strings using 
the exclamation mark '!' as the sheet name separator. The 
function still uses the dot '.' sheet name separator with A1 
notation.

When opening documents from ODF 1.0/1.1 format, the 
ADDRESS functions that show a sheet name as the fourth 
parameter will shift that sheet name to become the fifth 
parameter. A new fourth parameter with the value 1 will be 
inserted.

When saving a document in ODF 1.0/1.1 format, if the 
ADDRESS function has a fourth parameter, that parameter
will be removed. A spreadsheet should not be saved in the 
old ODF 1.0/1.1 format if A1 is set to 0.

AREAS(reference) Returns the number of individual ranges that belong to a 
multiple range. A range can consist of contiguous cells or a
single cell. reference is a reference list of the ranges. The 
function expects a single argument. Multiple ranges can be
entered using the tilde (~) (Union) operator or a semicolon 
(;) as the divider, but the semicolon gets automatically 
converted to the tilde operator after the function is entered 
into the spreadsheet. If you state multiple ranges and you 
use the semicolon separator, you must enclose them in 
additional parentheses. The tilde is the union range 
operator. See Chapter 7 for range operators.

Multiple ranges can be entered into the reference input 
box in two ways. Firstly they can be be typed directly into 
the argument's input box, noting the parentheses 
constraint mentioned above for the semicolon. Secondly, 
by clicking the Shrink button to the right of the input box 
and then clicking and dragging in the sheet to select cell 
ranges. Add the range operator between selections. Note 
the parentheses constraint above for use of the semicolon.

Bug 71225 concerning problems inputting data.
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CHOOSE(Index, value1, …, 
value30)

Returns a value from a list of up to 30 values. Index is a 
reference or number between 1 and 30 indicating which 
value is to be taken from the list. value1, …, value30 is the
list of values entered as any number type, reference, or 
formula expression. Only the selected value from the list is 
evaluated, any other formulas in the list are not checked for
validity.

COLUMN(reference) Returns the column number of a reference. If the 
reference is a single cell, the column number of the cell is 
returned; if the parameter is a cell range containing more 
than one column, the corresponding column numbers are 
returned in a single-row array, if the formula is entered as 
an array formula. If the cell range is not entered as an 
array formula, only the column number of the first cell 
within the range is determined. If no reference is entered, 
the column number of the cell in which the formula is 
entered is returned as Calc automatically sets the 
reference to the current cell.

COLUMNS(array) Returns the number of columns in the given reference. 
array is the reference to a cell range whose total number 
of columns is to be found. The argument can also be a 
single cell.

DDE(server, File, range, mode) Dynamic Data Exchange. Returns the result of a DDE 
request. If the contents of the linked range or section 
changes, the returned value will also change. The 
spreadsheet can be reloaded, or Edit > Links selected, to 
see the updated links. Cross-platform links, for example 
from an LibreOffice installation running on a Windows 
machine to a document created on a Linux machine, are 
not supported. server is the name of a server application. 
LibreOffice applications have the server name “Soffice”. 
File is the complete file name, including path. range is the 
area containing the data to be evaluated. mode is an 
optional parameter that controls the method by which the 
DDE server converts its data into numbers. See the Help 
files for information on choices.

An earlier bug that caused this function to crash LibreOffice
has been fixed in v4.1.4 and later releases.

ERRORTYPE(reference) Evaluates the cell value at reference location. If the cell 
contains an error then a logical or numerical value is 
returned else it returns #N/A. The numerical value is the 
error number (see Help for full listing). For a cell containing
the #N/A error, a value of 32767 is returned.
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GETPIVOTDATA(Data Field, Pivot 
Table, Field Name/Item1, Field 
Name/Item2, …, Field 
Name/Item30)

This is the syntax used in the 
Function Wizard.

The GETPIVOTDATA function returns a calculated result 
value from a pivot table. The value is addressed using field
and item names, so it remains valid if the layout of the pivot
table changes.

Two different syntax definitions can be used: the syntax 
shown on the left and

GETPIVOTDATA(Pivot Table, Constraints)

For syntax 1, Data Field is a string that selects one of the 
pivot table's data fields. The string can be the name of the 
source column, or the data field name as shown in the 
table (like "Sum – Sales"). Pivot Table is a reference to a 
cell or cell range that is positioned within a pivot table or 
contains a pivot table. If the cell range contains several 
pivot tables, the table that was created last is used. If no 
Field Name /ItemX pairs are given, the grand total is 
returned. Otherwise, each pair adds a constraint that the 
result must satisfy. Field Name is the name of a field from 
the pivot table. ItemX is the name of an item from that field.
A maximum of 30 Field Name/ItemX pairs can be entered.

The second syntax is assumed if exactly two parameters 
are given, Pivot Table has the same meaning as in the 
first syntax. Constraints is a space-separated list. Entries 
can be quoted (single quotes). The whole string must be 
enclosed in quotes (double quotes), unless you reference 
the string from another cell. See the Help file for detailed 
information.

In some versions of LibreOffice, the second syntax 
variation returns a #REF error. See Bug 71234.

HLOOKUP(search_criteria, array, 
Index, sorted)

Searches for a value given in search_criteria in the first 
row of the given array, and returns the value from the row 
given in Index for the column in which the search item was
found. If sorted is 0 or FALSE the first row of array need 
not be sorted, else the first row of array must be sorted in 
alpha-numerical and logical order. The search supports 
regular expressions.

HYPERLINK(URL, CellText) When the text in a cell that contains the HYPERLINK 
function is Ctrl-clicked (the cursor becomes a pointing hand
when correctly positioned), the hyperlink opens. URL 
specifies the link target. The optional CellText argument is 
the text displayed in the cell. If either argument is a text 
string, it must be entered in double quotes. If the CellText 
parameter is not specified, the URL text is displayed.
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INDEX(reference, row, column, 
range)

Given a reference, returns the value at the given row and 
column intersection (starting numbering at 1, relative to 
the top left of the reference) of the given area range. If 
range is not given, it is assumed to be 1 (the first and 
possibly only area).

If row is omitted or empty or 0, an entire column of the 
given area range in reference is returned. If column is 
omitted or empty or 0, an entire row of the given area 
range in reference is returned. If both, row and column, 
are omitted or empty or 0, the entire given area range is 
returned.

If reference is a one-dimensional column vector, column 
is optional or can be omitted. If reference is a one-
dimensional row vector, row is optional, which effectively 
makes row act as the column offset into the vector, or can 
be omitted.

If row or column have a value greater than the dimension 
of the corresponding given area range, an Error is 
returned.

The Array checkbox must be selected in this function 
unless row and column are both included.

Bug 71325: Returns #VALUE error when optional 
arguments are omitted.

INDIRECT(ref, A1) Returns a reference given a string representation of a 
reference as ref. This function can also be used to return 
the area of a corresponding string. ref is a reference to a 
cell or an area (in text form) from which to return the 
contents. Unless ref refers to a cell containing a reference, 
ref must be entered in double quotes. A1 (optional) - if set 
to 0, the R1C1 notation is used. If this parameter is absent 
or set to another value than 0, the A1 notation is used.

LOOKUP(Search criterion, Search 
vector, result_vector)

Returns the contents of a cell either from a one-row or one-
column range or from an array. Optionally, the assigned 
value (of the same index) is returned in a different column 
and row. As opposed to VLOOKUP and HLOOKUP, search
and result vectors may be at different positions; they do not
have to be adjacent. Additionally, the search vector for the 
LOOKUP must be sorted ascending, otherwise the search 
will not return any usable results. The search supports 
regular expressions. Search criterion is the value to be 
searched for; entered either directly or as a reference. 
Search vector is the single-row or single-column area to 
be searched. result_vector is another single-row or single-
column range from which the result of the function is taken.
The result is the cell of the result vector with the same 
index as the instance found in the search vector.

When given two parameters, Search vector is first 
examined: If Search vector is square or is taller than it is 
wide (more rows than columns), LOOKUP searches in the 
first column (similar to VLOOKUP), and returns the 
corresponding value in the last column. If Search vector 
covers an area that is wider than it is tall (more columns 
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than rows), LOOKUP searches in the first row (similar to 
HLOOKUP), and returns the corresponding value in the 
last row.

Bug 71589: This fails if an alphabetic character is used for 
the search criterion.

MATCH(Search criterion, 
lookup_array, Type)

Returns the relative position of an item in an array that 
matches a specified value. The function returns the 
position of the value found in lookup_array as a number. 
Search criterion is the value which is to be searched for. 
lookup_array is the vector to be searched. A lookup array 
can be a single row or column, or part of a single row or 
column. Type may take the values 1, 0, –1 or be omitted.

If Type is value 1 or omitted, lookup_array must be sorted
ascending and the function finds the largest value that is 
less than or equal to Search criterion.

If Type is of value 0 the function finds the largest value that
is less than or equal to Search criterion. Values in 
lookup_array do not need to be sorted.

If Type is of value -1, the function returns the smallest 
value that is greater than or equal to Search criterion in a 
lookup_array where values are sorted in descending 
order.  The search supports regular expressions.

OFFSET(reference, rows, columns, 
height, width)

Returns the value of a cell offset by a certain number of 
rows and columns from a given reference point. reference 
is the cell from which the function searches for the new 
reference. rows is the number of cells by which the 
reference was corrected up (negative value) or down. 
columns is the number of columns by which the reference 
was corrected to the left (negative value) or to the right. 
height is the optional vertical height for an area that starts 
at the new reference position. width is the optional 
horizontal width for an area that starts at the new reference
position.

ROW(reference) Returns the row number of a cell reference. If the reference
is a cell, it returns the row number of the cell. If the 
reference is a cell range, it returns the corresponding row 
numbers in a one-column array if the formula is entered as 
an array formula. If the ROW function with a range 
reference is not used in an array formula, only the row 
number of the first range cell will be returned. reference is 
a cell, an area, or the name of an area. If a reference is not
indicated, Calc automatically sets the reference to the 
current cell.

ROWS(array) Returns the number of rows in a reference or array. array 
is the reference or named area whose total number of rows
is to be determined.

SHEET(reference) Returns the sheet number of a reference or a string 
representing a sheet name. If no parameters are entered, 
the result is the sheet number of the spreadsheet 
containing the formula. reference (optional) is the 
reference to a cell, an area, or a sheet name string.
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SHEETS(reference) Determines the number of sheets in a reference. If no 
parameters are entered, the result is the number of sheets 
in the current document. reference (optional) is the 
reference to a sheet or an area.

STYLE(Style, Time, Style2) Applies a style Style to the cell containing the formula for a
length of time Time, after which the final style Style2 is 
applied. Styles are listed (and may be created) in the 
Format > Styles and Formatting (F11) menu and are text
entries entered in double quotes.

The initial style is applied for Time seconds after the cell 
itself is recalculated. Please note that a manual 
recalculation (F9 key or Tools > Cell Contents > 
Recalculate) will not trigger the initial style.

Time and Style2 may together be omitted; Style is then 
applied permanently.

This function always returns the value 0, allowing it to be 
added to another function without changing the value.

VLOOKUP(Search criterion, array, 
Index, sort order)

Searches the first column of an array for the value given 
by Search criterion and if found returns the cell value at 
the intersection of the row in which it is found and the 
column index given by Index. The search supports regular 
expressions. Search criterion is the value searched for in 
the first column of the array. If text, it must be entered in 
double quotes. array is the reference, which must include 
at least two columns. Index is the number of the column in 
the array that contains the value to be returned. The first 
column has the number 1. If the sort order parameter is 
omitted or set to TRUE or not 0, it is assumed that the data
is sorted in ascending order. If the exact Search criterion 
is not found, the last value that is smaller than the criterion 
will be returned. If the sort order parameter is set to 
FALSE or zero, an exact match must be found, otherwise 
the error Error: Value Not Available will be the result. Thus 
with a value of zero the data does not need to be sorted in 
ascending order.

Text functions

Use Calc’s text functions to search and manipulate text strings or character codes.

Table 43: Text functions

Syntax Description

ARABIC(Text) Calculates the value of a Roman numeral. The value range 
must be between 0 and 3999 (“MMMIM”). Text is the text that 
represents a Roman numeral. It is not case sensitive and is 
entered in double quotes.

ASC(text) The ASC function converts full-width to half-width ASCII and 
katakana characters. Returns a text string. text is the text that 
contains characters to be converted.
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BAHTTEXT(Number) Converts a number to Thai text, including the Thai currency 
names. Number is any number. "Baht" is appended to the 
integral part of the number, and "Satang" is appended to the 
decimal part of the number.

BASE(number, radix, Minimum 
length)

Converts a positive integer to a specified base then into text 
using the characters from the base’s numbering system 
(decimal, binary, hexadecimal, etc.). Only the digits 0-9 and the 
letters A-Z are used. number is the positive integer to be 
converted. radix is the base of the number system. It may be 
any positive integer between 2 and 36. Minimum length 
(optional) is the minimum length of the character sequence that 
has been created. If the text is shorter than the indicated 
minimum length, zeros are added to the left of the string.

CHAR(number) Converts a number into a character according to the current 
code table. The number can be a two-digit or three-digit integer 
number. number is a number between 1 and 255 representing 
the code value for the character.

CLEAN(text) Removes all non-printing characters from the string entered into
text. Text is entered using double quotes.

CODE(text) Returns a numeric code for the first character in a text string. 
text is the text for which the code of the first character is to be 
found and is entered in double quotes.

CONCATENATE(text 1, text 2, 
…, text 30)

Combines several text strings into one string. text 1, text 2, …, 
text 30 are text passages that are to be combined into one string.

DECIMAL(text, radix) Converts text with characters from a number system to a 
positive integer in the decimal system. The radix value defines 
the number system to which the text belongs. Any characters 
not in the number system defined are ignored. text is the text to 
be converted and must be entered using double quotes. The 
text field is not case-sensitive. radix is the base of the number 
system from which the conversion is to take place. It may be 
any positive integer between 2 and 36.

DOLLAR(value, decimals) Converts a number to text in the locale currency format, 
rounded to a specified decimal place. value is the number to be 
converted; it can be a number, a reference to a cell containing a 
number, or a formula which returns a number. decimals 
(optional) is the number of decimal places to be used. If no 
decimals value is specified, all numbers in currency format will 
be displayed with two decimal places. The currency format is 
set in the system settings.

EXACT(text_1, text_2) Compares two text strings and returns TRUE if they are 
identical. This function is case-sensitive. text_1 is the first text 
to compare. text_2 is the second text to compare. Both 
arguments if entered directly must be in double quotes.
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FIND(find_text, text, position) Looks for a string of text within another string and returns the 
position in the searched text where the searched-for text begins.
Where to begin the search can also be defined. The search 
term can be a number or any string of characters. The search is 
case-sensitive. find_text is the text to be found. text is the text 
which is being searched. position (optional) is the position in 
the text from which the search starts. Text must be entered in 
double quotes.

FIXED(number, Decimals, No 
thousands separator)

Returns a number, displayed as text, with a fixed number of 
decimal places and with or without a thousands separator. This 
function can be used to apply a uniform format to a column of 
numbers. number is the number to be formatted. Decimals is 
the number of decimal places to be displayed. If Decimals is 
negative, the number is rounded to ABS(number) Decimals 
places to the left from the decimal point.  No thousands 
separator (optional) determines whether the thousands 
separator is used or not. If the parameter is equal to 0 or 
omitted, the thousands separators of the current locale setting 
are displayed, else the separators are suppressed.

JIS(text) The JIS function converts half-width to full-width ASCII and 
katakana characters. Returns a text string. text is the text that 
contains characters to be converted. This is the complementary 
function to ASC.

LEFT(text, number) Returns the number of characters from the left of a text string 
text determined by number. If this parameter is omitted, one 
character is returned. If number is greater than the length of the
string, the whole string is returned.

LEN(text) Returns the length of a string including spaces. text is the text 
whose length is to be determined.

LOWER(text) Converts all uppercase letters in a text string to lowercase. text 
is the text to be converted.

MID(text, start, number) Returns a text segment of a character string. The parameters 
specify the starting position and the number of characters to 
return. text is the text containing the characters from which to 
extract. start is the position marking the beginning of the text to 
extract. number is the number of characters from that point on 
to be returned. If number is greater than LEN(text) minus start, 
then the text from start to the end of text is returned.

NUMBERVALUE(text, 
decimal_separator, 
group_separator)

Convert text to number, in a locale-independent way. Converts 
given text value text into a number. If text is a reference, it is 
first dereferenced. decimal_separator and group_separator 
are optional parameters. If text contains a separator, then that 
separator must be entered into the relevant optional parameter. 
All parameters are entered in double quotes.

Text is transformed according to the following rules: 

1) Starting from the beginning, remove all occurrences of the 
group_separator before any decimal_separator.

2) Starting from the beginning, replace the first occurrence in 
the text of the decimal_separator character with the FULL 
STOP (U+002E) character.
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3) Remove all whitespace characters (5.14).

4) If the first character of the resulting string is a period FULL 
STOP (U+002E) then prepend a zero.

5) If the string ends in one or more instances of PERCENT 
SIGN (U+0025), remove the percent sign(s).

If percent signs were removed in step 5, divide the value of the 
returned number by 100 for each percent sign removed. 

PROPER(text) Capitalizes the first letter in all words of a text string. text is the 
text to be converted.

REPLACE(Text, position, 
length, new text)

Replaces part of a text string with a different text string. This 
function can be used to replace both characters and numbers 
(which are automatically converted to text). The result of the 
function is always displayed as text. To perform further 
calculations with a number which has been replaced by text, 
convert it back to a number using the VALUE function. Any text 
containing numbers must be enclosed in quotation marks so it is
not interpreted as a number and automatically converted to text.
Text is text, a part of which will be replaced. position is the 
position within the text where the replacement will begin. length 
is the number of characters in text to be replaced. new text is 
the text which replaces text..

REPT(text, number) Repeats a character string by the given number of copies. text 
is the text to be repeated. number is the number of repetitions. 
The result can be a maximum of 255 characters.

RIGHT(text, number) Returns the right-most number of characters of a text string. If 
optional number is omitted, 1 is assumed and the right-most 
character is returned. If number is greater than the length of 
text, the whole text is returned.

ROMAN(Number, Mode) Converts a number into a Roman numeral. The value range 
must be between 0 and 3999; the modes can be integers from 0
to 4. Number is the number that is to be converted into a 
Roman numeral. Mode (optional) indicates the degree of 
simplification. The higher the value, the greater is the 
simplification of the Roman numeral.

ROT13(Text) Encrypts a character string by moving the characters 13 
positions in the alphabet. After the letter Z, the alphabet begins 
again (Rotation). Entering text encrypted by this method, into 
the function decrypts the text. Text is the character string to be 
encrypted/decrypted.

SEARCH(find_text, text, 
position)

Returns the start position of a text string within a larger string. 
The start position for the search can be set as an option. The 
search text can be a number or any sequence of characters. 
The search is not case-sensitive. The search supports regular 
expressions. find_text is the text to be searched for. text is the 
text where the search will take place. position (optional) is the 
position in the text where the search is to start.
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SUBSTITUTE(text, search_text,
new text, occurrence)

Substitutes new text for old text in a string. text is the text in 
which text segments are to be exchanged. search_text is the 
text segment that is to be replaced (a number of times). new 
text is the text that is to replace the text segment. occurrence 
(optional) indicates how many occurrences of the search text 
are to be replaced. If this parameter is missing, the search text 
is replaced throughout.

T(value) Returns value if text, else returns a blank text string. value is 
the value to be evaluated. A reference can be used as a 
parameter. If the dereferenced value is not of type text, the 
result will be an empty string.

TEXT(number, Format) Converts a number into text according to a given format. 
number is the numerical value to be converted. Format is the 
text which defines the format and can be found on the Numbers
tab in the Format Cells dialog. Use decimal and thousands 
separators according to the language set in the cell format.

TRIM(text) Returns a text string from which leading and trailing spaces 
have been removed, and replaces all internal multiple spaces 
with a single space. text is the text from which spaces are to be 
removed.

UNICHAR(number) Returns the character represented by the given number 
according to the [UNICODE] Standard. number is a decimal 
integer value between 0 and 1114111.

UNICODE(text) Returns the [UNICODE] code point corresponding to the first 
character of the text value. text is a string from which the code 
number is returned.

UPPER(text) Converts the string specified in the text parameter to uppercase
characters.

VALUE(text) Converts a text string into a number. text is the text to be 
converted to a number.

Add-in functions

Table 44: Add-in functions

Syntax Description

BESSELI(X, N) Calculates the modified Bessel function In(x). X is the value 
on which the function will be calculated. N is the order of the
Bessel function.

BESSELJ(X, N) Calculates the Bessel function Jn(x) (cylinder function). X is 
the value on which the function will be calculated. N is the 
order of the Bessel function.

BESSELK(X, N) Calculates the modified Bessel function Kn(x). X is the 
value on which the function will be calculated. N is the order
of the Bessel function.
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BESSELY(X, N) Calculates the modified Bessel function Yn(x), also known 
as the Weber or Neumann function. X is the value on which 
the function will be calculated. N is the order of the Bessel 
function.

BIN2DEC(Number) Returns the decimal number for the binary number entered. 
Number is the binary value entered as a number or as text.

BIN2HEX(Number, Places) Returns a string representing the hexadecimal number for 
the binary number entered. Number is the binary value 
entered as a number or text. Places (optional) is the 
number of places to be output.

BIN2OCT(Number, Places) Returns the octal number for the binary number entered. 
Number is the binary value entered as a number or text.. 
Places is the number of places to be output.

COMPLEX(Real num, I num, Suffix) Returns a complex number from a real coefficient and an 
imaginary coefficient. Real num is the real coefficient of the 
complex number. I num is the imaginary coefficient of the 
complex number. Suffix is optional, and may be "i” or "j”. If 
omitted “i” is assumed. Suffix must be lowercase.

CONVERT_ADD(Number, From 
unit, To unit)

Converts a value from one unit of measure to the 
corresponding value in another unit of measure. Number is 
the value to be converted. From unit is the unit from which 
conversion is taking place. To unit is the unit to which 
conversion is taking place. A list of abbreviations for units 
can be found in the Help files. Do not enter the full-stop.

DEC2BIN(Number, Places) Returns the binary number for the decimal number entered 
between –512 and 511. Number is the decimal number. 
Places is the number of places to be output.

DEC2HEX(Number, Places) Returns the hexadecimal number for the decimal number 
entered. Number is the decimal number. Places is the 
number of places to be output.

DEC2OCT(Number, Places) Returns the octal number for the decimal number entered. 
Number is the decimal number. Places is the number of 
places to be output.

DELTA(Number 1, Number 2) Returns TRUE (1) if both numbers are equal, otherwise 
returns FALSE (0). Number 2 is optional and assumes a 
value of 0 if omitted.

ERF(Lower limit, Upper limit) Calculates the error function. Lower limit is the lower limit 
of integral. Upper limit (optional) is the upper limit of the 
integral. If this value is missing, the calculation takes places 
between 0 and the lower limit.

ERFC(Lower limit) Calculates the complementary error function between x and
infinity. Lower limit is the lower limit of integral (x).

FACTDOUBLE(Number) Returns the factorial of Number with increments of 2. If 
Number is even, the following factorial is calculated: n*(N-
2)*(n-4)*...*4*2. If Number is odd, the following factorial is 
calculated: n*(N-2)*(n-4)*...*3*1.

GESTEP(Number, Step) Returns 1 if Number is greater than or equal to Step.
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HEX2BIN(Number, Places) Returns the binary number for the hexadecimal number 
entered. Number is the hexadecimal number. Places is the 
number of places to be output.

HEX2DEC(Number) Returns the decimal number for the hexadecimal number 
entered. Number is the hexadecimal number.

HEX2OCT(Number, Places) Returns the octal number for the hexadecimal number 
entered. Number is the hexadecimal number. Places is the 
number of places to be output.

IMABS(Complex number) Returns the absolute value (modulus) of the entered 
Complex number. The complex number is entered in the 
form "x + yi" or "x + yj".

IMAGINARY(Complex number) Returns the imaginary coefficient of the entered Complex 
number. The complex number is entered in the form "x + yi"
or "x + yj".

IMARGUMENT(Complex number) Returns the argument (the phi angle) of the entered 
Complex number. The complex number is entered in the 
form "x + yi" or "x + yj".

IMCONJUGATE(Complex number) Returns the conjugated complex complement to the entered
Complex number. The complex number is entered in the 
form "x + yi" or "x + yj".

IMCOS(Complex number) Returns the cosine of the entered Complex number. The 
complex number is entered in the form "x + yi" or "x + yj".

IMCOSH(Complex number) Returns the hyperbolic cosine of the entered Complex 
number. The complex number is entered in the form "x + yi"
or "x + yj".

IMCOT(Complex number) Returns the cotangent of the entered Complex number. 
The complex number is entered in the form "x + yi" or "x + 
yj".

IMCSC(Complex number) Returns the cosecant of the entered Complex number. The
complex number is entered in the form "x + yi" or "x + yj".

IMCSCH(Complex number) Returns the hyperbolic cosecant of the entered Complex 
number. The complex number is entered in the form "x + yi"
or "x + yj".

IMDIV(Numerator, Denominator) Returns the division of two complex numbers. Numerator 
and Denominator are entered in the form "x + yi" or "x + 
yj".

IMEXP(Complex number) Returns the power of e (the Eulerian number) and the 
complex number. Complex number is entered in the form 
"x + yi" or "x + yj".

IMLN(Complex number) Returns the natural logarithm of the entered Complex 
number. The complex number is entered in the form "x + yi"
or "x + yj”.

IMLOG10(Complex number) Returns the common logarithm of the entered Complex 
number. The complex number is entered in the form "x + yi"
or "x + yj".
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IMLOG2(Complex number) Returns the binary logarithm of the entered Complex 
number. The complex number is entered in the form "x + yi"
or "x + yj".

IMPOWER(Complex number, 
Number)

Returns the entered Complex number raised to the power 
Number. The complex number is entered in the form "x + 
yi" or "x + yj".

IMPRODUCT(Complex number, 
Complex number1, …, Complex 
number30)

Returns the product of the entered Complex number with 
up to 30 other Complex numbers. The complex numbers 
are entered in the form "x + yi" or "x + yj".

IMREAL(Complex number) Returns the real coefficient of the entered Complex 
number. The complex number is entered in the form "x + yi"
or "x + yj".

IMSIN(Complex number) Returns the sine of the entered Complex number. The 
complex number is entered in the form "x + yi" or "x + yj".

IMSINH(Complex number) Returns the hyperbolic sine of the entered Complex 
number. The complex number is entered in the form "x + yi"
or "x + yj".

IMSQRT(Complex number) Returns the square root of the entered Complex number. 
The complex numbers are entered in the form "x + yi" or "x 
+ yj".

IMSUB(Complex number 1, 
Complex number 2)

Returns the difference of two complex numbers. The 
complex numbers are entered in the form "x + yi" or "x + yj".

IMSUM(Complex number, Complex 
number 1, …, Complex number30)

Returns the sum of the entered Complex number with up 
to 30 other complex numbers. The complex_numbers are 
entered in the form "x + yi" or "x + yj".

IMTAN(Complex number) Returns the tangent of the entered Complex number. The 
complex number is entered in the form "x + yi" or "x + yj".

OCT2BIN(Number, Places) Returns the binary number for the octal value entered. 
Number is the octal number. Places is the number of 
places to be output. Number may be entered as text or a 
number.

OCT2DEC(Number) Returns the decimal number for the octal value entered. 
Number is the octal number. Number may be entered as 
text or a number.

OCT2HEX(Number, Places) Returns the hexadecimal number for the octal value 
entered. Number is the octal number. Places is the number
of places to be output. Number may be entered as text or a 
number.

Appendix B  Description of Functions 434



Appendix C  
Calc Error Codes



Introduction to Calc error codes

Calc provides feedback for errors of miscalculation, incorrect use of functions, invalid cell 
references and values, and other user initiated mistakes. The feedback may be displayed within 
the cell that contains the error (Figure 342) or on the status bar (Figure 343) or in both, depending 
on the type of error. Generally speaking, if the error occurs in the cell that is selected (or contains 
the cursor), the error message is displayed on the status bar.

As an example, Figure 342 shows the error code returned when a column is too narrow to display 
the entire formatted date. The date displayed within the input line, 04/05/1998, would fit within the 
cell without a problem, but the format used by the cell produces the date value Sunday, April 05, 
1998.

Figure 342: Error codes displayed within cells

When the cell displaying the #REF error code in Figure 342 is selected, the status bar displays the 
error message as shown in Figure 343. This message is more descriptive than the message 
displayed in the cell, but it still may not provide enough information to correctly diagnose the 
problem. For fuller explanations, consult the following tables and the Help topic, Error Codes in 
LibreOffice Calc.

Figure 343: An error message displayed in the status bar

This appendix presents error codes in two tables. This first table explains error messages which 
are displayed within the cell that actually contains the error. Except in the case of the ### error, 
they all correspond to a Calc error code number. The second table explains all of the error codes, 
listed by code number, including those errors codes in the first table.
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Cell error Code Explanation of the error

### N/A The column is too narrow to display the complete formatted 
contents of the cell. This is not really an error value, so there is no 
corresponding numerical error code. The solutions to this problem 
are to increase the width of the column. or select Format > Cells > 
Alignment and click either Wrap text automatically or Shrink to fit 
cell size to make the text match the current column width.

Err502 502 Function argument is not valid, or more than one matching cell is 
found by the DGET function.

#NUM! 503 A calculation resulted in an overflow of the defined value range.

#VALUE 519 The formula within the cell returns a value that does not correspond
to the definition of the formula or functions used. This error could 
also mean that the cell referenced by the formula contains text 
instead of a number.

#REF! 524 The formula within the cell uses a reference that does not exist. 
Either a column or row description name could not be resolved, or 
the column, row, or sheet that contains a referenced cell is missing.

#NAME? 525 An identifier could not be evaluated: no valid reference, no valid 
domain name, no column/row label, no macro, incorrect decimal 
divider, add-in not found.  For example, entering in a cell 
=sum(bob*5) where there is no cell named “bob” or containing the 
text “bob” generates this error.

#DIV/0! 532 Division operator / if the denominator is 0.

Some more functions return this error; see next table for details.
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General error codes

The following table is an overview of the most common error messages for LibreOffice Calc.

Note
Errors described as Internal errors should not be encountered by users under normal 
conditions. Errors listed as Not used are not currently assigned to any error condition 
and will not occur.

Code Message Explanation of the error

501 Invalid character Character in a formula is not valid. This error is the same as 
the Invalid Name error (525) except that it occurs within a 
formula. The cell containing the error will display the 
#NAME? error reference.

502 Invalid argument Function argument is not valid; for example, a negative 
number for the root function. This error also occurs if more 
than one matching cell is found by the DGET function.

503 Invalid floating point 
operation (cell 
displays #NUM!)

Division by 0, or another calculation that results in an 
overflow of the defined value range (a value too big or too 
small).

504 Parameter list error Function parameter is not valid; for example, text instead of 
a number, or a domain reference instead of a cell reference.

505 Internal syntax error Not used.

506 Invalid semicolon Not used.

507 Pair missing Not used.

508 Pair missing Missing bracket or parenthesis; for example, closing 
brackets but no opening brackets.

509 Missing operator Operator is missing; for example, 
"=2(3+4) * ", where the operator between "2" and "(" is 
missing.

510 Missing variable Variable is missing; for example, when two operators are 
together "=1+*2".

511 Missing variable Function requires more variables than are provided; for 
example, AND() and OR().

512 Formula overflow The total number of internal tokens (that is, operators, 
variables, brackets) in the formula exceeds 512, or the total 
number of matrices the formula creates exceeds 150. This 
includes basic functions that receive too large an array as a 
parameter.

513 String overflow An identifier in the formula exceeds 64 KB in size, or a result
of a string operation exceeds 64 KB in size.

514 Internal overflow Sort operation attempted on too much numerical data (max. 
100000) or a calculation stack overflow.
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515 Internal syntax error Not used.

516 Internal syntax error Matrix is expected on the calculation stack, but is not 
available.

517 Internal syntax error Unknown error; for example, a document with a newer 
function is loaded in an older version of Calc that does not 
contain the function.

518 Internal syntax error Variable is not available.

519 No result (cell 
displays #VALUE)

Formula yields a value that does not correspond to the 
definition, or a cell that is referenced in the formula contains 
text instead of a number.

520 Internal syntax error Compiler creates an unknown compiler code.

521 Internal syntax error No result.

522 Circular reference Formula refers directly or indirectly to itself and the 
Iterations option is not selected under Tools > Options > 
LibreOffice  Calc > Calculate.

523 The calculation 
procedure does not 
converge

Financial statistics function missed a targeted value, or 
iterations of circular references do not reach the minimum 
change within the maximum steps that are set.

524 Invalid references 
(cell displays #REF!)

A column or row description name could not be resolved, or 
the column, row, or sheet that contains a referenced cell is 
missing.

525 Invalid names (cell 
displays #NAME?)

An identifier could not be evaluated; for example, no valid 
reference, no valid domain name, no column/row label, no 
macro, incorrect decimal divider, add-in not found.

526 Internal syntax error Obsolete, no longer used, but could come from old 
documents if the result is a formula from a domain.

527 Internal overflow References, such as when a cell references a cell, are too 
encapsulated or deeply nested. This is an internal error and 
should not be displayed in LibreOffice.

528–
531

— Not used.

532 Division by zero Division operator / if the denominator is 0.

Some more functions return this error; for example:

VARP with less than 1 argument
STDEVP with less than 1 argument
VAR with less than 2 arguments
STDEV with less than 2 arguments
STANDARDIZE with stdev=0
NORMDIST with stdev=0
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3  
3D chart  

appearance  98
area chart  112
bar chart  109
illumination  99
line chart  113
pie chart  110
rotation and perspective  98
rotation, interactive  98

A  
absolute reference  193
advanced functions  216
anchor, visible  352
anchoring of objects  159
appearance of 3D chart  98
appearance options  344
Apply Style list  124
area charts  111
arguments  378
arguments in functions  200
arithmetic operators  187
array functions  412
arrow keys  

navigating within spreadsheets  26
assign styles to shortcut keys  125
auto filters  322
AutoCorrect  

options  359
axes labels  84

B  
bar charts  109
Base  

editing data sources  278
bubble charts  115

C  
Calc  

sorting records  75
Calc options  

case sensitive  354
changes  357
dates  354
grid  358
grid lines, viewing  350
input settings  349
iterative references  354
page breaks, visible  351
screen display  352
unit of measurement  349
updating links  349
Zoom  352

calculation options  353

calculation order  195
calculations  

linking sheets  195
cell styles  

applying  123
description  122
Fill Format mode  124

cells  
description  16, 19
information on status bar  21
range  28
selecting  28
validating contents  50

changes  
accepting or rejecting  293
adding comments  290
editing comments  291
options  357
recording  289
reviewing  293
viewing  293

chart  
appearance of 3D  98
area background  96
colors  97
creating  82
data labels  90
editing  87
formatting  95
formatting 3D  97
graphic background  96
grids  86
illumination of 3D  99
interactive 3D rotation  98
mean value lines  93
moving elements  96
perspective  98
Position and Size dialog  106
resizing  105
rotation  98
titles  86
trend lines  92
types  108
X or Y error bars  93

chart elements  88
chart type  84, 87
Chart Wizard  82
collaboration  286
color coding for input  208
color options  341
Color toolbar  151
column and line charts  119
column charts  108
columns  

deleting  31
inserting  31
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columns, in Calc  
freezing  34
selecting  29

comma separated values (CSV)  21
comments  

adding  291
editing  292
finding  292
formatting  292

comments on changes  
adding  290
editing  291

comparative operators  188
comparing documents  295
concatenation operator  191
consolidating data  242
create document from template  138
creating new spreadsheets  21
cropping  151
CSV file  

open  21
CSV files  21
customizing  

Enter key  28
keyboard shortcuts  365
menus  360
toolbars  363

D  
data analysis  

consolidating data  242
Goal Seek  257
introduction  242
Multiple Operations tool  252
scenarios  248
Solver  258
subtotals  244

data editing, Calc  
changing data in a cell  54
removing data from a cell  53
replacing all data in a cell  54

data entry  
keyboard  42
speeding up  46

Data range  84
Data series  85
data source  

data to text  278
editing  278
editing using Base  278
linking  276
registering  276
using in OOo documents  278
viewing  277

data to text  278
database functions  410
database range  318
DataPilot  

cell formatting  236
data fields  223
data sources  219
filter  235
group rows or columns  229
group scalar values  229
group without intervals  230
preconditions  218
refresh  236
shortcuts  236
sort results  232

date functions  404
dates and times, entry  43
DDE link  

description  282
in Calc  282
in Writer  282

default template  138
deleting  

columns and rows  31
sheets  34

Detective  209
digital rights management (DRM)  180
digital signature  182

status bar indicator  20
Documentation  9
documents  

comparing  295
merging  295

Drawing Object Properties toolbar  157
drawing objects  

grouping  158
properties  157
resizing  158

Drawing toolbar  157
drawing tools  155
Dynamic Data Exchange (DDE)  282

E  
e-mailing  

Calc document as attachment  181
several recipients  181

Enter key  28
EPS images in PDF  177
error codes  

common messages  432
displayed within cells  431
introduction  430

error messages  206, 211
error-checking formulas  184
errors, finding and fixing  206
export directly as PDF  176
Exporting  181
exporting to PDF  176
extensions  

installing  368
introduction  367

External Data dialog  271
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F  
FDF  178
features  8, 16
file sharing options  342
Fill Format mode  124
fill series  

adding  47
defining  48

Fill tool  46
filled net charts  116
filtering  321
filters  

advanced  325
auto  322
standard  322

financial analysis functions  384
fixed values  184
formatting  

chart  95
symbols  105

formatting  
cell borders  61
conditional  65

formatting data  
Font effects  59
fonts  58
Manual line breaks  58
multiple lines of text  57
numbers  58
shrinking data to fit cell  58

formula bar  18
formulas  

absolute reference  193
breaking into parts  205
calculation examples  185
concatenation operator  191
definition  184
intersection operator  192
operator types  187
operators in  185
range operator  191
relative reference  192
strategies for creating  204
using the Basic editor to create  206

Function List  201
Function Wizard  18, 202
functions  

add-in  424
ADDRESS  333
arguments  200, 309, 378
array  412
basic arithmetic  211
CEILING  213
CONCATENATE  188
COUNTIF  215, 329
database  328, 410
date and time  404
date formats  384

definition  184
description  184
entering  185
examples  211
financial analysis  384
FLOOR  213
HLOOKUP  331
INDEX  335
INDIRECT  334
informational  408
logical  407
LOOKUP  331
macros  303
MATCH  332
mathematical  379
MROUND  214
nested  201
OFFSET  334
overview  199
ROUND  213
ROUNDDOWN  213
ROUNDUP  213
simple statistics  211
spreadsheet  414
statistical analysis  395
structure  200
SUBTOTAL  330
SUMIF  329
terminology  378
text  420
VLOOKUP  331

G  
Gallery  

Hide/Show button  147
opening  147

GETPIVOTDATA function  238
Goal Seek  257
graphic filters  150
graphics  

adding  144
anchoring  159
arrangement  158
linking  145
positioning  158
resizing  152
transparency  151

graphics mode  150
grid options  358
grid lines, viewing  350

H  
Help system  8
Hide/Show button  147
hiding and showing data  69
HTML compatibility  347
hyperlinks  

absolute  268
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creating  269
Ctrl-click to activate  344
editing  271
relative  268
removing  271

I  
illumination of 3D chart  99
image map  161
images  

adding  144
context menu  153
cropping  151
embedding  146
inserting from file  144
inserting from the clipboard  147
inserting from the Gallery  147
linking  145
modifying  148
resizing  152
rotating  153

informational functions  408
input settings options  349
insert mode  20
Insert Picture dialog  144
inserting  

columns and rows  31
sheets  32

interest rates  384
International Support  9
intersection operator  192

K  
keyboard data entry  42
keyboard keys  

navigating within spreadsheets  26
keyboard shortcuts  

arrow keys  373
assigning  365
cell formatting  373
customizing  366
function keys  372
introduction  370
loading from a file  367
navigation  370
resetting to default values  367
saving to a file  366
selection  370

L  
lexical  74
licensing of LibreOffice  12
line charts  112
linking to external data  

External Data dialog  271
find required range  274
Navigator  273

load Basic code to edit  347

load/save options  345
logical functions  407

M  
macro recorder  300
macro security options  343
macros  367

accessing cells directly  309
arguments  308
arguments in functions  309
as Calc functions  303
introduction  300
organizing  303
recording  300
sorting data  311

Manual line breaks  58
mean value lines  93
menu bar  17
menu font, customizing  360
menus  

adding commands  362
creating  361
customizing  360
modifying  361
modifying entries  362

merging documents  295
Microsoft Office file conversion  347
moving chart elements  96
moving from sheet to sheet  26
Multiple Operations tool  252
multiple sheets  

introduction  262
setting up  262

N  
named range  315
Navigator  25, 36

scenarios  251
nested functions  201
net charts  116
numbers  

entering in spreadsheet cell  42
numbers, data entry  43

O  
Object Linking and Embedding (OLE)  279
OLE object  

linked  282
non-linked  281
other (Windows)  281

Open Source Initiative (OSI)  12
OpenDocument Format  345
opening spreadsheets  21
order of calculation  195
outline group controls  71

P  
page breaks, visible  351
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page style on status bar  20
page styles  

applying  125
description  123

password protection  25
password-protect PDF  180
PDF  

blank page export  178
digital rights management (DRM)  180
embed standard fonts  178
encrypt  180
EPS  177
export documents to  176
form  178
image compression and resolution  177
initial view selection  178
pages to export  176
password-protect  180
security settings  180
tagged  177
user interface settings  178

PDF Options dialog  176
PDF/A-1  177
perspective of chart  98
picture context menu  153
Picture toolbar  148
pictures  

linking  145
resizing  152
transparency  151

pie charts  109
Position and Size dialog for chart  106
Position and Size of graphics  154
precision  354
prepare document for review  288
print file directly  164
print options  341
printer metrics  350
printing  

general options  165
multiple pages per sheet  165
page orientation  165
Print dialog  164
selecting what to print  166

Properties  38
protect a document  288

R  
range  

database  318
named  315

range operators  191
record changes  288
reference operators  190
references in color  352
referencing  

other spreadsheets  267
sheets  265

regular expressions  
enable in formulas  355
in functions  214

relative reference  192
remove personal information on saving  343
renaming  

sheets  34
resolution options  358
rotating images  153
rotation  

chart  98
rounding methods  213
rounding off numbers  213
rows  

deleting  31
inserting  31

rows, in Calc  
freezing  34
selecting  29

S  
saving spreadsheets  

methods  23
scatter charts  113
scenarios  248
security  25
Selection list  49
selection mode indicator  20
selection, in Calc  

cells  28
sheets  30

send document as e-mail  181
shared extension  368
shared spreadsheet  

introduction  286
opening  287
saving  287
setting up  286

sheet tabs  19
sheets  

copying sheets  32
description  16
identifying  262
inserting  32, 262
inserting from other spreadsheets  264
navigating  26
referencing  265
renaming  34, 264
sequence number  20
sharing content  50

sheets, in Calc  
selecting  30

shrinking data to fit cell  58
size optimization  345
snap grid  358
Solver  258
sorting  320

using macros  311
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sorting records, Calc  75
special characters  44
spreadsheet  

create from template  138
update from changed template  138

spreadsheet functions  414
spreadsheets  

comparing  295
creating new  21
description  16
documentation, internal  184
embedding  279
identifying copies  289
merging  295
navigate  25
opening shared spreadsheet  287
saving  23
saving as Microsoft Excel  23
saving shared  287
setting up sharing  286
sharing  286

statistical analysis functions  395
status bar  20
stock charts  117
styles  

assign to shortcut keys  125
assigning to shortcut keys  366
cell  122
create from selection  127
create using Style dialog  126
delete  136
description  122
modifying  134
page  123, 125
types supported  122

Styles and Formatting dialog  123
subtotals  244
support  9
synchronize axes  358
system font  360

T  
template  

associate spreadsheet with different template  
139
create spreadsheet from  138
delete  140
delete folder  140
description  122
edit  137
export  141
folder  140

move  140
organize  140
reset default  139

text functions  420
text operators  188
text overflow  352
time functions  404
title bar  16
titles of charts  86
toolbars  18

adding commands  364
choosing icons for commands  365
creating  364

tooltip  18
track changes  288
transparency  151
trend lines  92

U  
unsaved changes indicator  20
URL Recognition  269
user data options  341
User guides  9
user interface, customizing  360
user interface, parts of  10

V  
validating cell contents  50
value highlighting  352
VBA properties load/save options  346
versions  

saving  296
viewing Calc  34
viewing data  

filtering  72
hiding and showing  69
outline group controls  71

visible grid  358

X  
X or Y error bars  93
XML  345
XY charts  113

Z  
zoom  34

#  
#DIV/0! Division by zero  207
#REF Incorrect references  208
#VALUE No result  208
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