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Grouping objects

Grouping of objects is similar to putting objects into a container. Objects within a group are 
moved together as one object and any changes made are applied globally to the objects within 
the group. A group can always be undone and the objects that make up the group can always be 
manipulated separately.

Temporary grouping
A temporary grouping is when several objects are selected. Any changes to object parameters 
are applied to all of the objects within the temporary group. For example, a temporary group of 
objects can be rotated in its entirety and is created using one of the following methods:

• Click and drag the cursor over several objects surrounding the objects with a selection 
rectangle. This selection rectangle is also known as a marquee. Release the cursor when
all the objects required for a temporary group are selected.

• Click the first object, then hold down the Shift key and click on the remaining objects 
for the temporary group.

To cancel a temporary group of objects, simply click outside of the selection handles displayed 
around the objects.

Grouping
When objects are grouped, any editing operations carried out on the group are applied to all 
objects within the group. Click on one object in a group, and the whole group is selected.

The objects within a group retain their own individual properties and can be edited independently.
See “Editing individual group objects” on page 5 for more information.

1) Select the objects for a group using one of the following methods. Selection handles 
appear around all the objects selected for the group (Figure 1).

– Click on each object in turn while holding down the Shift key.

– Make sure Select on the Drawing toolbar is selected and draw a selection rectangle 
around the objects required for the group using the cursor.

– To select all the objects in a drawing, go to Edit > Select All on the Menu bar or use 
the keyboard shortcut Ctrl+A (macOS +⌘ A).

Figure 1: Example of grouping objects
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2) Create the group of selected objects using one of the following methods:

– Right-click on an object within the selected group and select Group from the context 
menu.

– Go to Shape > Group > Group on the Menu bar.

– Use the keyboard shortcut Ctrl+Shift+G (macOS +⌘ Shift+G).

Ungrouping
1) Select the group of objects and selection handles appear around the objects within the 

group (Figure 1).

2) Ungroup the group of objects using one of the following methods:

– Right-click on the selected group and select Ungroup from the context menu.

– Go to Shape > Group > Ungroup on the Menu bar.

– Use the keyboard shortcut Ctrl+Alt+Shift+G (macOS + +⌘ ⌥ Shift+G).

Editing individual group objects
An object within a group can be edited individually without ungrouping the objects.

1) Select a group, then enter the group using one of the following methods.

– Right-click on the group and select Enter Group from the context menu.

– Go to Shape > Group > Enter Group on the Menu bar.

– Use the keyboard shortcut F3.

– Double-click on the selected group.

2) Once inside the group, click on any object to select and individually edit it, as shown by 
the example in Figure 2.

Note

After entering a group, any other objects outside the group cannot be selected for
editing until exiting from the selected group.

Figure 2: Example of editing individual object in a group
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3) After making and saving changes to an individual object within a group, exit the group 
using one of the following methods:

– Right-click on the group and select Exit Group from the context menu.

– Go to Shape > Group > Exit Group on the Menu bar

– Use the keyboard combination Ctrl+F3 (macOS +⌘ F3).

– Double-click outside the group.

Nesting groups
A group of groups can be created and this is commonly known as nesting groups. When nested 
groups are created, Draw retains the individual group hierarchy and remembers the order in 
which groups were selected. That is, the last individual group selected will be on top of all the 
other groups within a nested group. Ungrouping and entering a nested group works in exactly the
same way as for individual groups.

Tip

If group and ungroup commands are regularly used, or any other command, tools
can be added to a toolbar so that they are readily available. See Appendix B, 
Toolbars and the Getting Started Guide for more information on customizing 
toolbars.

Combining, splitting, breaking, and connecting

Combining objects
Combining objects is a permanent merging of objects creating a new object. The original objects 
are no longer available as individual objects and cannot be edited as individual objects.

1) Select several objects for combining.

2) Combine the selected objects into a single object using one of the following methods:

– Right-click on the selection and select Shapes > Combine from the context menu.

– Go to Shape > Combine on the Menu bar.

– Use the keyboard combination Ctrl+Shift+K (macOS +⌘ Shift+K).

At first glance, the results can seem rather surprising, but the following explains how combining 
objects works.

• The attributes (for example, area fill) of the resulting object are those of the object 
furthest back.

– In Figure 3, it is the ellipse.

– Figure 4 it is the yellow rectangle.

• Where the objects overlap, the overlapping zone is either filled or empty depending on 
whether the overlap is even numbered or odd numbered. Figure 4 shows that where the 
overlap number is even, an empty space is created and where the overlap number is 
odd, a filled area is created.
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Figure 3: Example of combing objects
1) Grouped objects 2) Combined objects

Figure 4: Example of area fill when combining overlapping objects
1) Overlapping objects 2) Combined overlapping objects

Figure 5: Example of splitting combined objects
1) Overlapping objects before combining 2) Split result of combined overlapping objects
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Figure 6: Example of breaking objects
1) Original object
2) Object broken

3) Individual parts edited

Splitting combined objects
An object which has been combined from several objects can be split into individual objects. 
However, the original objects retain the formatting of the combined object and do not revert back 
to their original formatting.

Select the combined object and use one of the following methods to split the combined object:

• Go to Shape > Split on the Menu bar.

• Use the keyboard shortcut Ctrl+Alt+Shift+K (macOS + +⌘ ⌥ Shift+K).

In Figure 5, the left graphic is the original example of overlapping area fills before combining. The
right graphic is the result of splitting the combined object. The individual overlapping objects have
taken the formatting of the object (Rectangle 1) at the back of the overlapping objects.

Breaking objects
An object that consists of more than one part can be broken into its individual parts as follows. 
For example, a star is broken into separate lines and the area fill is lost, as shown by the center 
graphic in Figure 6.

1) Select an object that consists of more than one part.

2) Convert the object to a curve or polygon using one of the following methods:

– Go to Shape > Convert > To Curve or To Polygon on the Menu bar.

– Right-click on the object and select Convert > To Curve or To Polygon on the 
context menu.

3) Go to Shape > Break on the Menu bar and the object is broken into individual parts.

4) Move, format or delete the individual parts as necessary, as shown by the right object in 
Figure 6.

Connecting lines
The individual parts of an object or more than one line can be connected together as follows:

1) Select all the objects that are going to be connected.

2) Go to Shape > Connect on the Menu bar. Individual lines or lines in a border are 
converted to curves and the end points of each line connected.
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Note

The shape created when connecting individual parts or lines is not a closed 
shape. The new shape has to be closed using “Closing objects” to create an area 
fill.

Closing objects
Closing objects creates an object that can use an area fill.

1) Select an object that has a gap in its border.

2) Right-click on the selected object and select Close Object from the context menu to 
close the gap.

3) Format the area fill created to requirements. See Chapter 4, Changing Object Attributes 
for more information on working with area fills.

Merging, subtracting, or intersecting objects

After selecting more than one object, the merge, subtract, and intersect functions become 
available. This allows creation of a new object with a new shape.

Merge
When merging objects, a new object is created with a shape that follows the shape of the merged
objects. The area fill of the merged object is determined by the area fill of the object that is at the 
rear of all the other objects, as shown in Figure 7.

After selecting several objects, use one of the following methods to merge the objects:

• Go to Shape > Merge on the Menu bar.

• Right-click on the selected objects and select Shapes > Merge from the context menu.

Figure 7: Example of merging objects

Figure 8: Example of subtracting objects
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Figure 9: Example of intersecting objects

Subtract
When subtracting objects, the objects at the front are subtracted from the object behind. This 
leaves a blank space that the subtracted objects occupied creating a new shape, as shown in 
Figure 8. After selecting several objects that overlap each other, use one of the following 
methods to subtract objects:

• Go to Shape > Subtract on the Menu bar.

• Right-click on the selected objects and select Shapes > Subtract from the context menu.

Intersect
When intersecting objects, the front objects and the exposed area of the object at the rear are 
removed. This creates a new object from the area of the object at the rear that was covered by 
the objects at the front, as shown in Figure 9.

After selecting several objects that overlap each other, use one of the following methods to 
intersect objects:

• Go to Shape > Intersect on the Menu bar.

• Right-click on the selected objects and select Shapes > Intersect from the context 
menu.

Practical example
The following example shows how to use the merge, subtract, and intersect functions to create a 
knife with a wooden handle.

Draw an ellipse and then a rectangle overlapping 
half of its width.

Select both shapes, right-click, and select Shapes 
> Subtract from the context menu.

Draw another rectangle and put it over the top half 
of the ellipse.
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Select both shapes, right-click, and select Shapes 
> Subtract from the context menu.

Draw a small ellipse covering just the lower right 
corner.

Select both shapes, right-click, and select Shapes 
> Subtract from the context menu. The knife blade
shape is now complete.

To make the handle, draw a rectangle and an 
ellipse.

Merge the shapes together.

Position the handle on the blade. Select the 
handle and blade, then group together to create a 
drawing of the knife.

Duplication and cross-fading

Duplication
Duplication makes copies of an object while applying a set of changes (such as color or rotation) 
to the duplicates.

1) Select an object or group of objects, then use one of the following methods to open the 
Duplicate dialog (Figure 10):

– Go to Edit > Duplicate on the Menu bar.

– Go to Shape > Duplicate on the Menu bar.

– Use the keyboard shortcut Shift+F3.

2) Select the number of copies, placement, enlargement, and the start and end colors for 
duplicate copies.

3) Click OK and duplicate copies are created. An example of a duplication is shown in 
Figure 11. Each duplicate object is a separate object.

4) To group the duplicate objects into one group, see “Grouping objects” on page 4.

5) To combine the duplicate objects into one object, see “Combining, splitting, breaking, and 
connecting” on page 6.

The following options are available when using the Duplicate dialog:

Number of copies
Enter the number of copies required.
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Figure 10: Duplicate dialog

Figure 11: Example of duplication

Placement 
Sets the position and rotation of duplicated objects in relation to the original object.

X axis
Enter the horizontal distance between the centers of the selected object and the 
duplicate objects. Positive values shift the duplicate object to the right and negative 
values shift the duplicate object to the left.
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Y axis
Enter the vertical distance between the centers of the selected object and the duplicate
objects. Positive values shift the duplicate object down and negative values shift the 
duplicate object up.

Angle
Enter the angle (0 to 359 degrees) required for rotating the duplicate object. Positive 
values rotate the duplicate objects in a clockwise direction and negative values in a 
counterclockwise direction.

Enlargement
Sets the size of the duplicate objects.

Width
Enter the amount to enlarge or reduce the width of the duplicate objects.

Height
Enter the amount to enlarge or reduce the height of the duplicate objects.

Colors
Sets the colors for the selected object and the duplicate objects. For more than one copy, 
these colors define the start and end points of a color gradient.

Start
Select a color for the selected object.

End
Select a color for the duplicate object. If making more than one copy, this color is 
applied to the last copy.

Cross-fading
Cross-fading transforms one object shape into another object shape. The result is a new group of
individual objects that includes the start and end objects. The intermediate steps show the 
transformation from one object shape to another object shape. The cross-fading is carried out 
from the first object selected to the second object selected.

1) Select two objects and go to Shape > Cross-fading on the Menu bar to open the 
Cross-fading dialog (Figure 12).

2) In Settings, select the number of Increments for the transformation.

3) If necessary, in Settings, select Cross-fade attributes and Same orientation.

Figure 12: Cross-fading dialog
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Figure 13: Example of cross-fading

4) Click OK to cross-fade the selected objects and close the Cross-fading dialog. An 
example of cross-fading is shown in Figure 13 with Same orientation deselected. The 
object created is a group of objects.

5) To ungroup this group of objects and use the individual objects, see “Ungrouping” on 
page 5.

The following options are available in the Cross-fading dialog:

Increments
Enter the number of steps to be created between the selected objects.

Cross-fade attributes
Applies cross-fading to the line and fill properties of the selected objects. For example, if 
the selected objects are filled with different colors, a color transition between the two 
colors is applied.

Same orientation
Applies a smooth transition between the selected objects.

Positioning objects

Arranging objects
When combining, merging, subtracting, or intersecting objects, the end result varies depending 
on which object is at the front and which object is at the back. Each new object placed on a 
drawing automatically becomes the front object and all the other objects move backwards in 
positioning order. Arranging objects changes the order of a group of objects.

To change the arrangement position of an object, select one or more objects and then use one of
the following methods 

• Right-click on the selected object(s), then select Arrange from the context menu and one
of the available options.

• Click on the triangle ▼ to the right of Arrange on the Standard toolbar to open the 
Position sub-toolbar (Figure 14) and select one of the available tools.

• Click one of the arrangement tools on the Line and Filling toolbar.
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Figure 14: Position sub-toolbar

• Click on Shape > Arrange on the Menu bar and select an arrangement option.

• Use the Arrange tools in Position and Size panel in the Properties deck on the Sidebar.

• Use a keyboard shortcut given below.

The arrangement options available are as follows:

Bring to Front
Brings the selected object to the front of a group of objects (Shift+Ctrl++) 
(macOS  +⌘ Shift++).

Bring Forward
Brings the selected object forward one step (Ctrl++) (macOS ⌘++).

Send Backward
Sends the selected object one step backward (Ctrl+–) (macOS ⌘+–).

Send to Back
Sends the selected object to the back of a group of objects (Shift+Ctrl+–) 
(macOS ⌘+Shift+–).

In Front of Object
Moves the selected object in front of another selected object.

Behind Object
Moves the selected object behind another selected object.

Reverse
Reverses the order of the selected objects. This tool is grayed out if only one object is 
selected.

Aligning objects
To make a drawing look more professional, objects can be aligned with each other. Select one or 
more objects and use one of the following methods to align objects:

• Right-click on the selected object(s), then select Align Objects from the context menu 
and one of the available options.

• Click on one of the alignment tools on the Line and Filling toolbar.

• Go to Shape > Align Objects on the Menu bar and select the alignment required.

• Use the Align tools in the Position and Size panel in the Properties deck on the Sidebar.

• Go to View > Toolbars on the Menu bar and select Align Objects to open the Align 
Objects toolbar (Figure 15).

Figure 15: Align Objects toolbar
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The alignment tools available are as follows:

Left
Aligns the left edges of the selected objects. If only one object is selected, the left edge of
the object is aligned to the left page margin.

Centered
Horizontally centers the selected objects. If only one object is selected, the center of the 
object is aligned to the horizontal center of the page.

Right
Aligns the right edges of the selected objects. If only one object is selected, the right edge
of the object is aligned to the right page margin.

Top
Vertically aligns the top edges of the selected objects. If only one object is selected, the 
top edge of the object is aligned to the top page margin.

Center
Vertically centers the selected objects. If only one object is selected, the center of the 
object is aligned to the vertical center of the page.

Bottom
Vertically aligns the bottom edges of the selected objects. If only one object is selected, 
the bottom edge of the object is aligned to the bottom page margin.

Distributing objects
Distributing objects allows three or more objects to be evenly spaced along a horizontal axis or 
vertical axis. Objects are distributed using the outermost objects in the selection as base points 
for spacing.

Select at least three objects, then use one of the following methods to distribute the objects:

• Right-click on the selected objects, then select Distribute Selection from the context 
menu and one of the available options.

• Go to View > Toolbars on the Menu bar and select Distribute Selection to open the 
Distribute Selection toolbar (Figure 16).

• Go to Shape > Distribute Selection on the Menu bar and select a distribution option.

• Right-click on the selected objects and select Distribute Selection from the context 
menu, then select a distribution option.

The distribution options available are as follow:

Horizontal Left
Distributes the selected objects so that the left edges of the objects are evenly spaced 
from one another.

Horizontal Center
Distributes the selected objects so that the horizontal centers of the objects are evenly 
spaced from one another.

Figure 16: Distribute Selection toolbar
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Horizontal Spacing
Distributes the selected objects horizontally so that the objects are evenly spaced from 
one another.

Horizontal Right
Distributes the selected objects so that the right edges of the objects are evenly spaced 
from one another.

Vertical Top
Distributes the selected objects so that the top edges of the objects are evenly spaced 
from one another.

Vertical Center
Distributes the selected objects so that the vertical centers of the objects are evenly 
spaced from one another.

Vertical Spacing
Distributes the selected objects vertically so that the objects are evenly spaced from one 
another.

Vertical Bottom
Distributes the selected objects so that the bottom edges of the objects are evenly spaced
from one another.
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