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Introduction

This chapter covers the basics of formatting text in Writer, the word-processing component of 
LibreOffice:

• Formatting paragraphs and characters

• Using autoformatting

• Creating bulleted, numbered, and outline lists

It assumes that you are familiar with the text techniques described in Chapter 2, Working with Text:
Basics and Chapter 3, Working with Text: Advanced.

We recommend that you also follow the suggestions in Chapter 20, Setting up Writer, about 
displaying formatting aids, such as end-of-paragraph marks, and selecting other setup options.

Page formatting is covered in Chapters 5 and 6.

Using styles is recommended

Styles are central to using Writer. Styles enable you to easily format your documents consistently, 
and to change the format with minimal effort. A style is a named set of formatting options. When 
you apply a style, you apply a whole group of formats at the same time. 

In addition, styles are used by LibreOffice for many processes, even if you are not aware of them. 
For example, Writer relies on heading styles (or other styles you specify) when it compiles a table 
of contents. Therefore, the use of paragraph styles is highly recommended as an alternative to 
manually formatting paragraphs, especially for long or standardized documents. The use of 
character styles instead of manually formatting individual words is also highly recommended.

For information on styles and how to use them, see Chapters 8 and 9 in this book.

Applying styles is quick and easy using the Styles and Formatting deck of the Sidebar.

Caution

Manual formatting (also called direct formatting) overrides styles, and you cannot get 
rid of the manual formatting by applying a style to it.

Removing manual formatting
To remove manual formatting, select the text and choose Format > Clear Direct Formatting from 
the Menu bar, or click the Clear Direct Formatting button on the Formatting toolbar, or use Ctrl+M
from the keyboard.

Note

When clearing direct formatting, the text format returns to the applied paragraph style 
and not the default paragraph style.

Formatting paragraphs

You can apply many formats to paragraphs using the buttons on the Formatting toolbar and on the 
Paragraph panel of the Sidebar’s Properties deck (View > Sidebar). Not all toolbar buttons are 
visible in a standard installation, but you can customize the toolbar to include those you use 
regularly (see Chapter 1, Introducing Writer). Other formatting options are provided in the 
Paragraph dialog (see page 8).

4 | Formatting paragraphs



On the Formatting toolbar, the buttons and formats include:

• Apply Paragraph Style (Styles drop-down on the Properties deck of the Sidebar)

• Bullets On/Off (with a palette of bullet styles) —see page 19 

• Numbering On/Off (with a palette of numbering styles) —see page 19 

• Align Left, Center Horizontally, Align Right, or Justified

• Align Top, Center Vertically, Align Bottom

• Line Spacing (choose from 1, 1.15, 1.5, 2, or custom spacing

• Increase Paragraph Spacing, Decrease Paragraph Spacing

• Increase Indent, Decrease Indent

• Paragraph (to open the Paragraph dialog)

The Sidebar opens with the Properties deck selected by default. Click the expansion symbol (+ or 
triangle) to open the panels if necessary.

The Paragraph panel of the Properties deck (Figure 1) contains most of the formatting controls, 
including several that are not found on the Formatting toolbar. Clicking the down-arrow by a button 
opens the control for further choices, such as fixed line spacing or color palette.

Click the More Options button to open the Paragraph dialog, where other settings are available 
(see page 8). Changing the values of any of these settings affects only the paragraph where the 
insertion point (cursor) is located, or several paragraphs if more than one are selected. If you wish 
to change the values for many paragraphs of that type, you should use a paragraph style.

1 Align Left 8 Increase Spacing 15 Indent From Left
2 Align Center 9 Decrease Spacing 16 Indent From Right
3 Align Right 10 Increase Indent 17 Indent First Line
4 Align Justified 11 Decrease Indent 18 Line Spacing
5 Bullets 12 Hanging Indent 19 More Options – opens 

Paragraph dialog6 Numbering 13 Above Paragraph Spacing
7 Background Color 14 Below Paragraph Spacing

Figure 1: Paragraph panel of the Properties deck in the Sidebar
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Alignment options
You can use the buttons labelled 1–4 in Figure 1 to choose the alignment of a paragraph: Left, 
Right, Centered, or Justified. Figure 2 shows examples of the alignment options applied to text.

Left aligned text.
Center aligned text.

Right aligned text.
Justified text inserts spacing between words to force the text to reach
from margin to margin, if the text is longer than a single line.

Figure 2: Text alignment options

When using justified text, the last line is by default aligned to the left. However, you can also align 
the last line to the center of the paragraph area or justify it so that spaces are inserted between the
words in order to fill the whole line. If you select the Expand single word option, then whenever 
the last line of a justified paragraph consists of a single word, this word is stretched by inserting 
spaces between characters so that it occupies the full length of the line.

Figure 3 shows an example of the effect obtained when choosing each of these options for a 
typical text font. In most cases, you would leave the setting on the default (left-aligned)’ but for 
some dramatic purposes (such as a very large font on a poster), you might prefer one of the other 
choices.

Three options are available for the alignment of the last line of a justified paragraph. This
is an example of a left-aligned last line.

Three options are available for the alignment of the last line of a justified paragraph. This
is an example of a centered last line.

Three options are available for the alignment of the last line of a justified paragraph. This
is  an  example  of  a   justified last  line.

When the last line of a justified paragraph contains a single word, you can stretch the
word to fill  the entire line.  This  is  an example with the  Expand single word option
s e l e c t e d .

Figure 3: Examples of choices for the last line of a justified paragraph

These options are controlled in the Alignment page of the Paragraph dialog (Figure 4), reached by 
choosing Format > Paragraph from the Menu bar, or by right-clicking in the paragraph and 
selecting Paragraph from the context menu, or by clicking the More Options button on the 
Paragraph panel in the Properties deck of the Sidebar.

Figure 4: Options for the last line of a justified paragraph
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Line and paragraph spacing
Line spacing (button 18, Figure 1) refers to the distance from one baseline (the imaginary line at 
the bottom of a letter like “n” or “m”) to the next baseline. It is determined by the size of the font.

Figure 5: Line spacing is the distance between two baselines

The Line Spacing submenu is shown in Figure 6. Here you can choose among standard spacings 
or define a custom value: Proportional (for example, 110%), At least (the amount specified in the 
Value box), Leading, or Fixed. To see the differences between these choices, do a few sample 
paragraphs and change the selections.

   

Figure 6: Line spacing submenu

Paragraph spacing refers to the vertical spacing between one paragraph and the paragraphs 
above and below it. As shown in Figure 1, the current values are shown in the Above Paragraph 
Spacing box (13) and the Below Paragraph Spacing box (14). You can change either or both of 
these settings independently.

Paragraph indentation
You can use the buttons labelled 10, 11, and 12 in Figure 1 to increase the amount of space to 
leave between the left and right page margins and the paragraph.

The distances are determined by settings 15 (Before Text Indent; that is, from the left margin), 16 
(After Text Indent; that is, from the right margin), and 17 (First Line Indent, which indents the first 
line from the left margin, or from the specified indentation from the margin).

Button 12, Switch to Hanging Indent, leaves the first line at the left margin (or the specified 
indentation from the margin) and indents all the other lines of the paragraph by the amount 
specified by button 17 or in the Paragraph dialog.
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This paragraph is an example of a paragraph with a first line indent. It is typical of
paragraphs in books.

This paragraph is an example of a paragraph with a hanging indent. It is often used 
for numbered paragraphs or those with an icon or other image on the left.

Note

In right-to-left languages, the behavior of the Before Text and After Text indents is the 
opposite: “before” is on the right margin; “after” is on the left margin.

Paragraph background color
Click the button labelled 7 in Figure 1 to open a palette from which you can choose a color for the 
background of the paragraph. From this palette, you can also click Custom Color to open the Pick
a Color dialog, where you can define new colors to be added to the palette.

Figure 7: Selecting a background color for a paragraph

Note

If the paragraph has been indented from the right or left margin, the background color 
is not applied to the area of the indent. If you wish to extend the color to the margin, 
you will need to use a frame, table, or other method; see Chapter 6, Formatting Pages:
Advanced.

Settings on the Paragraph dialog
The paragraph dialog includes several more pages: Tabs (covered in next section, “Setting tab 
stops and indents”), Borders, Drop Caps, Area (more choices than just color), Transparency, Text 
Flow, and Outline & Numbering. For more information, see Chapter 8, Introduction to Styles, and 
Chapter 9, Working with Styles.

Borders
You can add borders to any combination of top, bottom, and sides of paragraphs. You can choose 
the style (solid, dotted, dashed, doubled), width, and color of the lines; these choices apply to all 
borders on a paragraph. The spacing from each line to the paragraph’s contents can be set 
individually for the top, bottom, left, and right.
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On this dialog you can also choose to apply a shadow to a paragraph; “distance” refers to the width
of the shadow.

Select the Merge with next paragraph option to suppress top or bottom lines when the indent, 
border, and shadow styles of the next paragraph are the same as the current paragraph. 

Figure 8: Options for paragraph borders

Drop caps
Drop capitals are enlarged letters that mark the start of a new chapter or section. To improve 
consistency, they are best set up in a paragraph style that you apply to the relevant paragraphs. 
See Chapter 9, Working with Styles, for details.

Area
Area (also called “fill” and “background” in some parts of LibreOffice) includes five types of fill 
(background): color, gradient, bitmap, pattern, and hatching. Select a fill type to display the choices
available for that type. These choices are covered in more detail in Chapter 5, Formatting Pages: 
Basics. You can also create your own fills.

Figure 9: Types of fill for paragraph backgrounds

Transparency
Transparency affects the paragraph’s background. It is useful for creating watermarks and making 
colors or images more pale (for more contrast with the text). The available choices are shown in 
Chapter 5, Formatting Pages: Basics, and are covered in detail in the Draw Guide.

Text Flow
TheText Flow page (Figure 10) has several sections. Hyphenation is covered in Chapter 2, 
Working with Text: Basics, and breaks are covered in Chapter 5, Formatting Pages: Basics.
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In the Options section, you can specify how paragraphs are treated at the bottom of a page. Do 
not split paragraph and Keep with next paragraph should be self-explanatory. The other options 
allow you to avoid a single line at the bottom of a page (called an orphan) or a single line at the top
of a page (a widow).

Figure 10: Options for text flow: hyphenation, breaks, and keeping text together

Outline & Numbering
The Outline & Numbering page on the Paragraph dialog provides options for choosing the outline 
level of the paragraph and its numbering style. If the paragraph is part of a numbered list, you can 
specify that list numbering restarts at the paragraph, and what number to restart with.

Figure 11: Selecting outline level, paragraph numbering, and line numbering
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This page does not cover the same functions as the Outline Numbering dialog (Tools > Outline 
Numbering), but the Outline level selected here is related to the outline defined there. See 
Chapter 8, Introduction to Styles, and Chapter 9, Working with Styles, for a discussion of these 
features. Line numbering is discussed in Chapter 3, Working with Text: Advanced.

Setting tab stops and indents

The horizontal ruler shows the tab stops. Any tab stops that you have defined will overwrite the 
default tab stops. Tab settings affect indentation of full paragraphs (using the Increase Indent and 
Decrease Indent buttons on the Formatting toolbar or the Paragraph panel of the Properties deck 
in the Sidebar) as well as indentation of parts of a paragraph (by pressing the Tab key on the 
keyboard).

Changing the default tab spacing can cause formatting problems if you share documents with other
people. If you use the default tab spacing and then send the document to someone else who has 
chosen a different default tab spacing, tabbed material will change to use the other person’s 
settings. Instead of using the defaults, define your own tab settings, as described in this section.

Figure 12: Specifying tab stops and fill characters

To define indents and tab settings for one or more selected paragraphs, right-click on a paragraph 
and choose Paragraph... to open the Paragraph dialog; then select either the Tabs page (Figure
12) or the Indents & Spacing page of the dialog. Alternatively, you can double-click on the 
horizontal ruler to open the Indents & Spacing page of the Paragraph dialog.

A better strategy is to define tabs for the paragraph style. Refer to Chapters 8 and 9 for more about
paragraph styles.

Tip

Using tabs to space out material on a page is not recommended. Depending on what 
you are trying to accomplish, a table is usually a better choice.

Changing the default tab stop interval

Caution

Any changes to the default tab setting will affect the existing default tab stops in any 
document you open afterward, as well as tab stops you insert after making the change.

To set the measurement unit and the spacing of default tab stop intervals, go to Tools > Options >
LibreOffice Writer > General.
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Figure 13: Selecting a default tab stop interval

You can also set or change the measurement unit for rulers in the current document by right-
clicking on the ruler to open a list of units, as shown in Figure 14 for the horizontal ruler. Click on 
one of them to change the ruler to that unit. The selected setting applies only to that ruler.

Figure 14: Changing the measurement unit for a ruler

Formatting characters

You can apply many formats to characters using the buttons on the Formatting toolbar and by 
using the Characters panel of the Properties deck of the Sidebar. Not all toolbar buttons are visible 
in a standard installation, but you can customize the toolbar to include those you use regularly; see
Chapter 1, Introducing Writer. These formats include:

• Font Name, Font Size (in points)

• Bold, Italic, Underline, Double Underline, Overline, Strikethrough, Outline

• Superscript, Subscript

• Uppercase, Lowercase

• Increase Font Size, Decrease Font Size

• Font Color (with a palette of colors)

• Background Color (with a palette of colors)

• Highlighting (with a palette of colors)

• Character (to open the Character dialog)

To change the characteristics of an entire paragraph (for example the font name, size, or color), 
and for many other purposes, it is highly recommended that you use styles rather than manually 
formatting characters. For information on styles and how to use them, see Chapters 8 and 9. 
Applying styles is quick and easy using the Styles and Formatting deck of the Sidebar.

Figure 15 shows the Character panel in the Properties deck of the Sidebar. Clicking the down-
arrow next to a button opens the control for further choices, such as font color or character 
spacing. The appearance of the buttons may vary with your operating system and the selection of 
icon size and style in Tools > Options > LibreOffice > View.

Click the More Options button (15) to open the Character dialog, which includes more choices 
than are available through the Formatting toolbar or the Sidebar.
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Font name, size, and effects
To change the font name and size used for selected characters, you can use the drop-down 
menus on the Formatting toolbar, the Character panel in the Sidebar, or the Character dialog.

Similarly, you can apply bold, italics, underline, strikethrough, or shadow effects to selected 
characters from the Formatting toolbar, the Character panel in the Sidebar, or the Character dialog.
The Underline effect has a drop-down menu of line types (Figure 16). The Formatting toolbar 
includes other effects that are not in the Sidebar: overline and double underline; these buttons 
may not be visible in a default installation.

1 Font Name 6 Strikethrough 11 Highlight Color
2 Font Size 7 Shadow 12 Character Spacing 
3 Bold 8 Increase Font Size 13 Superscript
4 Italic 9 Decrease Font Size 14 Subscript
5 Underline 10 Font Color 15 More Options – opens Character dialog

Figure 15: Character panel in the Properties deck of the Sidebar

Figure 16: Selecting the line 
style for the Underline effect
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To choose the color of the font or its highlighting, open the appropriate color palette (10 or 11; 
similar to the one shown in Figure 7). The highlighting selection over-rides any background color 
that has been applied to the paragraph.

To quickly increase or decrease the font size of selected characters, you can click the relevant 
buttons on the Formatting toolbar or the Character panel in the Sidebar; however, you have no 
control over the amount of the increase or decrease, which is usually 2 points. For finer control, 
use the Font Size drop-down list instead.

To change characters into subscripts or superscripts (using the default values for size and 
position), select them and click the relevant buttons on the Formatting toolbar or the Character 
panel in the Sidebar. For more control, use the Character dialog.

To quickly change the spacing between characters, select them and choose from the Character 
Spacing drop-down menu in the Sidebar (Figure 17).

Figure 17: Changing character spacing

Settings on the Character dialog
The Character dialog has six pages, shown in this section. Most of these pages are the same as 
the pages on the Character Style dialog (see Chapter 9, Working with Styles).

Figure 18: Font page of the Character dialog
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Font and Font Effects
On the Font page (Figure 18), you can specify the font’s family, typeface (choices vary with the 
font, but typically include regular, bold, and italic), and size; and the language for the paragraph, if 
it differs from the language for the document. The box at the bottom shows a preview of the 
selections.

On the Font Effects page (Figure 19), you can choose the color of the font and a range of effects, 
many of which are not suitable for formal documents. Figures 20 and 21 show the choices in some 
of the drop-down lists.

Figure 19: Font Effects page of the Character dialog

    

Figure 20:Choices for capitalization, relief, and strikethrough effects

Figure 21: Choices for overlining and underlining are the same
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Position
The Position page collects the options that affect the position of text on the page. This page is 
divided into three sections: Position, Rotation/Scaling, and Spacing.

Figure 22: Position page of the Character dialog

The Position section controls the appearance of superscripts and subscripts.

The Rotation/Scaling section controls the rotation of the characters. The Scale width box controls 
the percentage of the font width by which to compress or stretch the rotated text.

The Spacing section controls the spacing between individual characters. The Pair Kerning option 
(selected by default) automatically adjusts the character spacing for specific letter combinations. 
Kerning is only available for certain font types and, for printed documents, works only if your printer
supports it.

Hyperlink
The Hyperlink page of the Character dialog is an alternative to using the Hyperlink dialog (Insert > 
Hyperlink). It includes fewer choices and is specifically for text (not button) links. Hyperlinks can 
be to other parts of the same document, to other documents, or to web pages.

Figure 23: Hyperlink page of the Character dialog

When LibreOffice recognizes a string of characters that may be a URL (internet address), it 
replaces the characters with a hyperlink and formats the hyperlink as specified in the Internet Link 
character style. On this dialog you can choose a different character style (if the style has been 
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defined previously) or replace the URL with other text. To turn off this feature, choose Tools > 
AutoCorrect > AutoCorrect Options > Options page and deselect URL Recognition.

For more about creating and editing hyperlinks, see the Help system or Chapter 12 in the Getting 
Started Guide.

Highlighting
The Highlighting page controls the background color for selected characters. It is similar to the 
Highlighting drop-down palette.

Borders
The Borders page is the same as the Borders page on the Paragraph dialog; see page 8.

Autoformatting

You can set Writer to automatically format parts of a document according to the choices made on 
the Options and Localized Options pages of the AutoCorrect dialog (Tools > AutoCorrect > 
AutoCorrect Options).

Tip

If you notice unexpected formatting changes occurring in your document, this is the 
first place to look for the cause.

The Help describes each of these choices and how to activate the autoformats. Some common 
unwanted or unexpected formatting changes include:

• Horizontal lines. If you type three or more hyphens (---), underscores (_ _ _) or equal signs 
(===) on a line and then press Enter the paragraph is replaced by a horizontal line as wide 
as the page. The line is actually the lower border of the preceding paragraph.

• Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), asterisk 
(*), or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered
list is created when you type a number followed by a period (.), followed by a space or tab 
at the beginning of a paragraph. Automatic numbering is only applied to paragraphs 
formatted with the Default, Text body or Text body indent paragraph styles.

To automatically format the file according to the options you have set, choose Tools > 
AutoCorrect and select or deselect the items on the submenu.

While Typing
Automatically formats the document while you type.

Apply
Automatically formats the document.

Apply and Edit Changes
Automatically formats the file and then opens a dialog where you can accept or reject the 
changes.

AutoCorrect Options
Opens the AutoCorrect dialog (Figures 24 and 25).
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Figure 24: Autoformat choices on the Options page of the AutoCorrect dialog

The Localized Options page (Figure 25) controls the formatting of quotation marks and 
apostrophes (which look like a closing single quote). Most fonts include curly quotation marks (also
known as “smart quotes”), but for some purposes (such as marking minutes and seconds of 
latitude and longitude) you may wish to format them as straight quotes.

Straight quotes Smart quotes

  ' '  " "  ‘ ’  “ ”

Figure 25: Autoformatting quotation marks
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Tip

Most people keep the AutoCorrect setting for smart quotes and use the Special 
Characters dialog to insert straight quotes when needed. See Chapter 2, Working with 
Text: Basics.

Formatting numbered or bulleted lists

You can format numbered or bulleted lists in several ways:

• Use autoformatting, as described above.

• Use list (numbering) styles, as described in Chapters 8, 9, and 12 in this book.

• Use the Bullets and Numbering toolbar (see Figure 26).

• Use the Numbering and Bullets buttons on the Formatting toolbar or on the Paragraph 
panel of the Properties deck of the Sidebar (see Figure 27).

• Use the Bullets and Numbering dialog (see Figures 28 and 29).

To produce a simple numbered or bulleted list, select the paragraphs in the list and then click on 
the appropriate button on the Paragraph panel on the toolbar.

Notes

It is a matter of personal preference whether you type your information first, then apply
numbering/bullets or apply these as you type.

If numbering or bullets are being applied automatically in a way that you find 
inappropriate, you can switch them off temporarily by unchecking Format > 
AutoCorrect > While Typing.

Using the Bullets and Numbering toolbar
You can create a nested list (where one or more list items has a sub-list under it, as in an outline) 
by using the buttons on the Bullets and Numbering toolbar (Figure 26). You can move items up or 
down the list, create subpoints, change the style of bullets, add paragraphs without numbers or 
bullets (for list items that include more than one paragraph), and access the Bullets and Numbering
dialog, which contains more detailed controls. 

Use View > Toolbars > Bullets and Numbering to display the toolbar.

1 Demote One Level 5 Move Down 9 Insert Unnumbered Entry 

2 Promote One Level 6 Move Up 10 Restart Numbering

3 Demote One Level with Subpoints 7 Move Down with Subpoints 11 Open the Bullets and 
Numbering dialog4 Promote One Level with Subpoints 8 Move Up with Subpoints

Figure 26: Bullets and Numbering toolbar
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Tip
You can use keyboard shortcuts to move paragraphs up or down the outline levels. 
Place the cursor at the beginning of the numbered paragraph and press:

Tab  = Down a level
Shift+Tab  = Up a level

To insert a tab stop at the beginning of a numbered paragraph (that is, after the 
number but before the text), press Ctrl+Tab.

If you create a nested list using the buttons on the Bullets and Numbering toolbar, all the levels of 
the list (up to 10) initially apply the same numbering (or bullet) format. However, often you will want
to use a combination of numbering formats and bullets when creating nested lists. Such lists can 
be configured in these ways:

• Click in each list item and then select one of the choices in the drop-down palettes under 
the Bullets and Numbering buttons on the Formatting toolbar or the Properties deck of the 
Sidebar, as described in “Using the Bullets and Numbering palettes on the Sidebar” below.

• Use the Bullets and Numbering dialog, as described in “Using the Bullets and Numbering 
dialog” below. 

However, a much better strategy is to define and apply a list style, as discussed in Chapter 12, 
Lists.

Using the Bullets and Numbering palettes on the Sidebar
The Bullets and Numbering palettes on the Paragraph panel on the Properties deck of the Sidebar 
can be used to create nested lists and access the Bullets and Numbering dialog. The Sidebar does
not include tools for promoting and demoting items in the list, as found on the Bullets and 
Numbering toolbar.

  
Figure 27: Bullets and Numbering choices on the Properties deck of the Sidebar

Using the Bullets and Numbering dialog
The Bullets and Numbering dialog has six pages. Four pages provide pre-defined symbols and 
sequences to choose from: Bullets, Numbering Type, Outline (choose from eight standard outline 
sequences), and Image (choose a bullet image). Two pages provide detailed options for defining 
your own lists: Position (Figure 28) and Options (Figure 29). These are the same as the pages 
provided for list styles, discussed in Chapter 12, Lists.
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More information

For more information about topics in this chapter and the next chapter, you may find this book 
useful: Designing with LibreOffice, by Bruce Byfield. You can download a PDF free from 
http://designingwithlibreoffice.com or buy a printed copy.

Figure 28: Position page of the Bullets and Numbering dialog

Figure 29: Options page of the Bullets and Numbering dialog
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