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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click

Opens a context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Opens the Navigator

F11

z+T

Opens the Styles and Formatting window

Documentation for LibreOffice is available at www.libreoffice.org
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OLE objects
Object Linking and Embedding (OLE) is a software technology that allows embedding and linking
of the following types of files or documents into an Impress presentation. The major benefit of
using OLE objects is that it provides a quick and easy method of editing the object using tools from
the software used to create the object.

•
•
•
•
•

LibreOffice spreadsheets
LibreOffice harts
LibreOffice drawings
LibreOffice formula
LibreOffice text

These file types can all be created using the various modules included in LibreOffice software.
Two types of OLE objects can be created: new and from a file.

Inserting a new OLE object
When you insert a new OLE object into your presentation, it is only available in your presentation
and can only be edited using Impress.
To add a new OLE object into your presentation:
1) Go to the slide where you want to insert the OLE object.
2) Select Insert > Object > OLE Object from the menu bar.
3) On the Insert OLE Object dialog box (Figure 1), select Create new.

Figure 1: Inserting a new OLE object
4) Select the type of OLE object you want to create and then click OK.
5) A new OLE object is inserted in the center of the slide in edit mode. The toolbars displayed
in Impress will change providing the necessary tools for you to create the new OLE object.

Note

For computers operating Microsoft Windows there is an additional option of Further
objects. Clicking on this option opens an Insert Object dialog allowing you to create
an OLE object using other software that is compatible with OLE. This option is
available for new OLE objects and OLE objects from a file.

Inserting a OLE object from a file
When you insert an existing file into your slide as an OLE object, by default any subsequent
changes that are made to the original file do not affect the copy of the file inserted into your
presentation. Similarly, changes to the file copy in your presentation do not change the original file.
If you want any changes made to the file, either in the original or your presentation, to appear in
both versions you have to link the original file with your presentation when it is inserted.
4
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Figure 2: Inserting a spreadsheet file
To insert a file into your presentation as an OLE object:
1) Go to the slide where you want to insert the spreadsheet.
2) Choose Insert > Object > OLE Object from the menu bar.
3) On the Insert OLE Object dialog box, select Create from file . The dialog box changes to
show a File text box (Figure 2).
4) Click Search.and the Open dialog box is displayed.
5) Locate the file you want to insert and click on Open.
6) Select the Link to file option if you wish to insert the file as a live link so that any changes
made are synchronized in both the original file and your presentation.
7) Click on OK to insert the file as an OLE object.

Editing an OLE object
To edit an OLE object after it has been created or inserted from a file, double click on the OLE
object to open edit mode (Figure 3). The toolbars displayed in Impress will change providing the
necessary tools for you to edit the OLE object.

Figure 3: OLE object in edit mode

Spreadsheets
To include a spreadsheet in an Impress slide, you can either insert an existing spreadsheet file or
insert a new spreadsheet as an OLE object. See OLE objects on page 4 for more information.
Embedding a spreadsheet into Impress includes most of the functionality of a Calc spreadsheet
and is therefore capable of performing complex calculations and data analysis. However, if you
plan to use complex data or formulas, it is better to perform complex operations in a separate Calc
spreadsheet and use Impress only to display the embedded spreadsheet with the results.
You maybe tempted to use spreadsheets in Impress for creating complex tables or presenting data
in a tabular format. However, the Table Design feature (described in Chapter 3) is often more
suitable and faster, depending on the complexity of your data.
The entire spreadsheet is inserted into your slide. If the spreadsheet contains more than one sheet
and the one you want is not visible, double-click the spreadsheet and then select a different sheet
from the row of sheet tabs at the bottom.
Spreadsheets
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Editing a spreadsheet
When a spreadsheet is inserted in slide, it is in edit mode ready for inserting or modifying data or
modifying the format (Figure 3). Note the active cell and the small resizing handles on the border.
See Entering data on page 7 and Formatting spreadsheet cells on page 8 for more information.
When editing a spreadsheet, some of the toolbars change so that you can easily edit the
spreadsheet (Figure 4). One of the most important changes is the presence of the Formula toolbar,
just below the Formatting toolbar. The Formula toolbar contains (from left to right):

• The active cell reference or the name of the selected range
• The Formula Wizard button
• The Sum and Function buttons or the Cancel and Accept buttons (depending on the
contents of the cell)

• A long edit box to enter or review the contents of a cell
If you are familiar with Calc, you will immediately recognize the tools and the menu items as they
are similar.

Figure 4: Toolbars for spreadsheet editing mode

Resizing and moving a spreadsheet
When resizing or moving a spreadsheet, ignore the first row and the first column (easily
recognizable because of their light background color) and the horizontal and vertical scroll bars.
They are only used for editing purposes and will not be included in the visible area of the
spreadsheet on the slide.
To resize the area occupied by the spreadsheet:
1) Double-click to enter edit mode, if it is not already active. Note the selection handles found
in the border surrounding the spreadsheet (Figure 3).
2) Move the mouse over one of the handles. The cursor changes shape to give a visual
representation of the effects applied to the area.
3) Click and hold the left mouse button and drag the handle. The corner handles move the two
adjacent sides simultaneously, while the handles at the midpoint of the sides modify one
dimension at a time.
You can move the spreadsheet (change its position within the slide) whether in edit mode or not. In
both cases:
1) Move the mouse over the border until the cursor changes to a hand (actual cursor depends
on your computer setup).
2) Click and hold the left mouse button and drag the spreadsheet to the desired position.
3) Release the mouse button.
When selected, the spreadsheet object is treated like any other object; therefore resizing it
changes the scale rather than the spreadsheet area. This is not recommended, because it may
distort the fonts and picture shapes.
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Navigating the spreadsheet
How a spreadsheet is organized
A spreadsheet consists of multiple tables called sheets, which in turn contain cells. However, in
Impress only one of these sheets can be shown at any given time on a slide.
The default for a spreadsheet embedded in Impress is one single sheet called Sheet 1, unless the
sheet has been renamed. The name of the sheet is shown at the bottom of the spreadsheet area
(Figure 3).
If required, you can add other sheets by a right mouse click on the bottom area near the existing
tab and selecting Insert > Sheet from the pop-up menu. Alternatively, click on the plus sign to the
right of the tabs.
Just as in Calc, you can rename a sheet or move it to a different position using the same pop-up
menu or the Insert menu on the main menu bar.

Note

Even if you have many sheets in your embedded spreadsheet, only one sheet - the
one which is active when leaving the spreadsheet edit mode - is shown on the slide.

Each sheet is organized into cells. Cells are the elementary units of the spreadsheet. They are
identified by a row number (shown on the left hand side) and a column letter (shown in the top
row). For example, the top left cell is identified as A1, while the third cell in the second row is C2.
All data elements, whether text, numbers or formulas, are entered into a cell.

Moving the cursor to a cell
To move around the spreadsheet and select an active cell, you can:

• Use the arrow keys.
• Left-click with the mouse on the desired cell.
• Use the combinations Enter and Shift+Enter to move one cell down or one cell up
respectively; Tab key and Shift+Tab key to move one cell to the right or to the left
respectively.
Other keyboard shortcuts are available to move quickly to certain cells of the spreadsheet. Refer to
Chapter 5, Getting Started with Calc, in the Getting Started guide for further information.

Entering data
Keyboard input into a cell can only be done when the cell is active. An active cell is identified by a
thick border. The cell reference (or coordinates) is also shown on the left hand end of the formula
toolbar.
To insert data, first select the cell to make it active, then start typing . Note that the input is also
added to the main part of the formula toolbar where it may be easier to read.
Impress will try to automatically recognize the type of contents (text, number, date, time, and so on)
entered into a cell and apply default formatting to it. Note how the formula toolbar icons change
according to the type of input, displaying Accept ( ) and Reject ( ) icons whenever the input is
not a formula. Use Accept to confirm an input made in a cell or simply select a different cell, or
press the Enter key.

Spreadsheets
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Figure 5: Formatting cells in a spreadsheet
If Impress wrongly recognizes the type of input, select the cell then change format using Format >
Cells in the main menu bar, or right-click on the cell and choose Format Cells from the pop-up
menu to open the Format Cells dialog (Figure 5).

Tip

Sometimes it is useful to treat numbers as text (for example, telephone numbers) and
to prevent Impress from removing the leading zeros or right align them in a cell. To
force Impress to treat the input as text, type a single quotation mark (') before
entering the number.

Formatting spreadsheet cells
Often, for the purposes of a presentation, it may be necessary to increase the size of the font
considerably or to match it to the style used in the presentation.
The easiest way to format the embedded spreadsheet is to make use of styles. When working on
an embedded spreadsheet, you can access the cell styles created in Calc and use them. However,
a better approach is to create specific cell styles for presentation spreadsheets, as the Calc cell
styles are likely to be unsuitable when working within Impress.
To apply a style to a cell or group of cells simultaneously (or manually format their cell attributes),
first select a cell or a range of cells to which the changes will apply. A range of cells is indicated by
a rectangular area with all its cells shaded. To select a multiple-cell range:
1) Click on the first cell belonging to the range (either the left top cell or the right bottom cell of
the rectangular area).
2) Keep the left mouse button pressed and move the mouse to the opposite corner of the
rectangular area which will form the selected range.
3) Release the mouse button.
To add further cells to the selection, hold down the Control key and repeat the steps 1 to 3 above.

8

Including Spreadsheets, Charts, and Other Objects

Tip

You can also click on the first cell in the range, hold down the Shift key, and click in
the cell in the opposite corner. Refer to Chapter 5, Getting Started with Calc, in the
Getting Started book for further information on selecting ranges of cells.

Some shortcuts are very useful to speed up selection and are listed below:

• To select the whole visible sheet, click on the blank cell between the row and column
indexes, or press Control+A.

• To select a column, click on the column index at the top of the spreadsheet.
• To select a row, click on the row index on the left hand side of the spreadsheet.
Once a range is selected, you can modify the formatting, such as font size, alignment (including
vertical alignment), font color, number formats, borders, background and so on. To access these
settings, choose Format > Cells from the main menu bar or right-click and choose Format Cells
from the pop-up menu to open the Format Cells dialog (Figure 5).
If the text does not fit the width of the cell, you can increase the width by hovering the mouse over
the line separating two columns in the header row until the mouse cursor changes to a doubleheaded arrow; then click the left button and drag the separating line to the new position. A similar
procedure can be used to modify the height of a cell (or group of cells).
To insert rows and columns in a spreadsheet, use the Insert menu or right-click on the row and
column headers and select the appropriate option from the pop-up menu. To merge multiple cells,
select the cells to be merged and select Format > Merge cells from the main menu bar. To split a
group of cells, select the group and deselect Format > Merge Cells (which will now have a
checkmark next to it).
When you are satisfied with the formatting and the appearance of the table, exit edit mode by
clicking outside the spreadsheet area. Note that Impress will display exactly the section of the
spreadsheet that was on the screen before leaving edit mode. This allows you to hide additional
data from view, but it may cause the apparent loss of rows and columns. Therefore, take care that
the desired part of the spreadsheet is showing on the screen before leaving edit mode.

Tip

To get back into edit mode, right click and select Edit.

Charts
The use of charts is described in detail in Chapter 3, Creating Charts and Graphs, of the Calc
Guide.
You can insert a chart to your presentation using the tools within Impress or as an OLE object. See
OLE objects on page 4 for more information on inserting a chart as an OLE object.
To insert a chart using Impress tools, select the Insert Chart icon on the slide layout (Figure 6), or
use Insert > Chart, or click the Insert Chart icon
on the Standard toolbar. A chart appears
containing sample data (Figure 7). To enter your own data into the chart, see Entering chart data
on page 12.

Charts

9

Figure 6: Inserting objects into a slide

Figure 7: Chart with sample data

Selecting a chart type
Your data can be presented using a variety of different charts; choose a chart type that best suits
the message you want to convey to your audience (see Chart types on page 11).
To choose a chart type:
1) Make sure that your chart is selected.
2) Click the Chart Type icon
or select Format > Chart Type, or right-click on the chart
and choose Chart Type to open Chart Type dialog (Figure 8).
3) As you change selections in the left-hand list, the chart examples on the right change. If
you move the Chart Type dialog box to one side, you can see the effect in your chart.
4) As you change chart types, other selections become available on the right-hand side. For
example, some chart types have both three-dimensional and two-dimensional variants; 3D
charts have further selections of shape for the columns or bars.
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Figure 8: Chart Type dialog showing two-dimensional charts
5) Choose the chart characteristics you want, and then click OK. The Chart Type dialog box
closes and you return to the edit window.
Now you can continue to format the chart, add data to the chart, or click outside the chart to return
to normal view.

Chart types
The following summary of the chart types available will help you choose a type suitable for your
data. For more detail, see Chapter 3, Creating Charts and Graphs, in the Calc Guide. Column, bar,
pie and area charts are available in 2D and 3D types.
Column charts
Column charts displays data that shows trends over time. They are best for charts that have a
relatively small number of data points (for large time series, a line chart would be better.) This is
the default chart type.
Bar charts
Bar charts give an immediate visual impact for data comparison where time is not important,
such as comparing the popularity of products in a marketplace.
Pie charts
Pie charts give a comparison of proportions, for example, comparisons of departmental
spending: what the department spent on different items or what different departments spent.
They work best with a small range of values, for example six or less; more than this and the
visual impact begins to fade.
Area charts
Area charts are versions of line or column charts. They are useful where you wish to
emphasize volume of change. Area charts have a greater visual impact than a line chart, but
the data you use will make a difference. You may need to use transparency values in an area
chart.
Line charts
Line charts are time series with a progression. Ideal for raw data and useful for charts with data
showing trends or changes over time where you want to emphasize continuity. On line charts,
Charts
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the x-axis is ideal for representing time series data. 3D lines confuse the viewer, so just using a
thicker line often works better.
Scatter or XY charts
Scatter charts are great for visualizing data that you have not had time to analyze and may be
best for data where you have a constant value for comparison: for example weather data,
reactions under different acidity levels, conditions at altitude, or any data which matches two
numeric series. The x-axis usually plots the independent variable or control parameter (often a
time series).
Bubble charts
Bubble charts are used to represent three variables: two identify the position of the center of a
bubble on a Cartesian graph, while the third variable indicates the radius of the bubble.
Net charts
Net charts are similar to polar or radar graphs and are useful for comparing data not in time
series, but show different circumstances, such as variables in a scientific experiment. The
poles of the net chart are the y-axes of other charts. Generally, between three and eight axes
are best; any more and this type of chart becomes confusing.
Stock charts
Stock charts are specialized column graphs specifically for stocks and shares. You can choose
traditional lines, candlestick, and two-column charts. The data required for these charts is
specialized with series for opening price, closing price, and high and low prices. The x-axis
represents a time series.
Column and line charts
Column and line charts are a combination of two other chart types. It is useful for combining
two distinct, but related data series, for example sales over time (column) and the profit margin
trends (line).

Entering chart data
Opening a chart data window
1) Make sure that your chart is selected and you have selected your chart type.
2) Click on the Chart Data icon
, or select View > Chart Data Table, or right-click on the
chart and choose Chart Data Table to open the Data Table dialog (Figure 9).

Tip

If you drag the Data Table dialog box so that your chart is visible, you can then
immediately see the results of each change after clicking in a different cell.

Figure 9: Chart Data Table dialog
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Entering data
Type or paste information into the cells within the desired rows and columns to enter data into the
Data Table dialog.
You can use the icons in the top left corner for large-scale editing:

• The three Insert icons insert rows, column (series) and text columns.
• The two Delete icons remove a selected row or column (series) with its data.
• The two Move icons move the contents of the selected column to the right, or the contents
of the selected row down.

Adding or removing elements from a chart
The default chart includes only two elements: the chart wall and the legend (also known as the
key). You can add other elements on your selected chart using the Insert menu (Figure 10). Each
selection of a menu item opens a dialog where you can specify your requirements.

Figure 10: Chart insert menu

Formatting a chart
The format of your selected chart can be changed by clicking on Format in the main menu bar
(Figure 11) where you can select several options to change the format of your chart.
The formatting options available will depend on which part of your chart has been selected and
are as follows:

• Format Selection opens a dialog where you can specify area fill, borders, transparency,
characters, font effects, and position of the selected element of the chart.

• Position and Size opens the Position and Size dialog (see Resizing and moving a chart).
• Arrangement provides two choices: Bring Forward and Send Backward, only one may be
active for specific items. Use these choices to arrange overlapping data series.

• Title formats the titles of the chart and its axes.
• Legend formats the location, borders, background, and type of the legend.
• Axis formats the lines that create the chart as well as the font of the text that appears on
both the X and Y axes.

• Grid formats the lines that create a grid for the chart.

Charts
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Figure 11: Chart format menu

• Chart Wall, Chart Floor, and Chart Area are described in the following sections.
• Chart Type changes what kind of chart is displayed and whether it is 2D or 3D.
• 3D View formats the various viewing angles of 3D chart.
Note

Chart Floor and 3D View are available only for 3D charts. These options are
unavailable (grayed out) if a 2D chart is selected.

A chart has two main areas: the chart wall and the chart area. These control different settings and
attributes for the chart. Knowing the difference is helpful when formatting a chart.

• Chart wall contains the graphic of the chart displaying the data.
• Chart area is the area surrounding the chart graphic. The (optional) chart title and the
legend (key) are in the chart area.

Figure 12: Chart wall and Chart area
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Note

Format > Chart Floor is only available for 3D charts and has the same formatting
options as Chart Area and Chart Wall.

Resizing and moving a chart
You can resize or move all elements of a chart at the same time, interactively, or by using the
Position and Size dialog box. You may wish to use a combination of both methods.
To resize a chart interactively:
1) Click on the chart to select it and selection handles appear around the chart.
2) To increase or decrease the size of the chart, click and drag one of the corner handles. To
maintain the correct aspect ratio, hold the Shift key down while you click and drag.
To move a chart interactively:
1) Click on the chart to select it and selection handles appear around the chart.
2) Hover the mouse pointer anywhere over the chart other than on a handle. When it changes
shape, click and drag the chart to its new location.
3) Release the mouse button when the element is in the desired position.
To resize or move a chart using the Position and Size dialog box:
1) Double-click the chart so that it is in edit mode.
2) Select Format > Position and Size from the menu bar, or right-click and select Position
and Size from the pop-up menu, or press F4 key to open the Position and Size dialog
(Figure 13) For more about the use of this dialog box, see Chapter 6, Formatting Graphic
Objects.

Figure 13: Position and Size dialog

Charts
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Moving chart elements
You can move or resize individual elements of a chart independently of other chart elements. For
example, moving the chart legend to a different position. Pie charts allow individual wedges of the
pie to be moved as well as “exploding” the entire pie.
1) Double-click the chart so that it is in edit mode.
2) Click any of the elements - title, legend, or chart graphic - to select it and resizing handles
appear.
3) Move the pointer over the selected element. When it changes shape, click and drag to
move the element.
4) Release the mouse button when the element is in the desired position.

Note

If your chart is 3D, round selection handles appear which control the threedimensional angle of the chart. You cannot resize or reposition the chart while the
round selection handles are showing. Shift + Click to get back to the square resizing
handles. You can now resize and reposition your 3D chart.

Tip

You can resize the chart using its square resizing handles (Shift + Click, then drag a
corner handle to maintain proportions). However, you cannot resize the title or key.

Changing chart area background
The chart area is the area surrounding the chart graphic and includes the (optional) main title and
key.
1) Double-click the chart so that it is in edit mode.
2) Select Format > Format Selection and select the Area tab from the dialog that opens, or
right click in the chart area and select Format Chart Area, or double click in the chart area
to open the Chart Area dialog (Figure 14).
3) Select from the Fill drop down list the type of background fill you want to use.

Figure 14: Chart Area dialog
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Changing chart wall background
The chart wall is the area that contains the chart graphic.
1) Double-click the chart so that it is in edit mode.
2) Select Format > Format Selection and select the Area tab from the dialog that opens, or
right click in the chart wall and select Format Wall, or double click in the chart wall to open
the Chart Wall dialog. This dialog has the same formatting options as described in
Changing chart area background on page 16.
3) Choose your settings and click OK.

Changing chart elements
When the chart is selected and is in edit mode, individual elements within the chart graphic can be
changed and reformatted. Right click on a chart element to open the appropriate formatting dialog.
For more information on changing and formatting a chart, see the Calc Guide.

Movies and sound
To insert a movie clip or a sound file into your presentation:
1) Click the Insert Movie icon on the slide layout (Figure 6) or select Insert > Movie and
Sound from the menu bar to open the Insert Movie and Sound dialog (Figure 15).
2) Select the media file to insert and click Open to place the object on the slide.

Figure 15: Insert Movie and Sound dialog

Tip

To see a list of audio and video file types supported by Impress, open the drop-down
list of file types. This list defaults to All movie and sound files, enabling you to choose
an unsupported type such as .MOV.

To insert media clips directly from the Gallery:
1) If the Gallery is not already open, choose Tools > Gallery from the menu bar.
2) Browse to a theme containing media files (for example Sounds).
3) Click on the movie or sound to be inserted and drag it into the slide area.

Movies and sound
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Figure 16: Media playback toolbar
The Media Playback toolbar (Figure 16) is automatically opened when a media file is selected. The
default position of the toolbar is at the bottom of the screen, just above the Drawing toolbar.
However, this toolbar can be undocked from its fixed position and allowed to float on screen. If the
toolbar does not open, select View > Toolbars > Media Playback.
The Media Playback toolbar contains the following tools from left to right:

• Movie and Sound: opens the Insert Movie and Sound dialog where you can select a
media file to be inserted.

•
•
•
•
•
•
•

Play, Pause, Stop: controls media playback.
Repeat: if pressed, media will continuously repeat playing until this tool is de-selected.
Playback slider: selects the position within the media file.
Timer: displays current position of the media clip/length of media file.
Mute: when selected, the sound will be suppressed.
Volume slider: adjusts the volume of the media file.
Scaling drop-down menu: (only available for movies) allows scaling of the movie clip.

The movie will start playing as soon as the slide is shown during the presentation.
Note that Impress will only link the media clip, not embed it. Therefore if the presentation is moved
to a different computer, the link will be broken and the media clip will not play. To prevent this from
happening:
1) Place the media file which is to be included in the presentation in the same folder where
the presentation is stored.
2) Insert the media file in the presentation.
3) Send both the presentation and the the media file to the computer which is to be used for
the presentation and place both files in the same folder on that computer.
Impress has a media player to allow previewing of media files that are to be inserted into a
presentation. To open it select Tools > Media Player and its toolbar is the same as that of the
Media Playback toolbar (Figure 16).

Formulas
Use Insert > Object > Formula to create a Math object in a slide. A formula can also be included
into a presentation as an OLE object; see OLE objects on page 4 for more information.
When editing a formula, the Math menu becomes available to allow you to create or edit a
formula..
Care should be taken about the font sizes used to make them compatible with the font size used in
the presentation. To change the font attributes of the Math object, select Format > Font Size from
the main menu bar. To change the font type, select Format > Fonts from the main menu bar.
For additional information on how to create formulas, refer to Chapter 9, Getting Started with Math,
in the Getting Started guide, or the Math Guide.

Note
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Unlike formulas in Writer, a formula in Impress is treated as an object; therefore it
will not be automatically aligned with the rest of the text. The formula can be
however moved around (but not resized) like any other object.
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Drawings, text files, HTML files and other objects
You can insert into an Impress presentation such as drawings, text files and HTML files. Select
Insert > File from the main menu to open a file selection dialog. Only file types acceptable by
Impress will be inserted into a presentation.
Drawings, text files, HTML files and other objects can also be included in a presentation as OLE
objects; see OLE objects on page 4 for more information.
For computers operating Microsoft Windows there is an additional option of Further objects.
Clicking on this option opens an Insert Object dialog allowing you to create an OLE object using
other software that is compatible with OLE.

Drawings, text files, HTML files and other objects
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