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Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and
Linux. The table below gives some common substitutions for the instructions in this document.
For a detailed list, see the application Help.

Windows or Linux macOS equivalent Effect
Tools > Opt.lons LibreOffice > Preferences Access setup options
menu selection
Right-click Control+click or right-click

) Open a context menu

depending on computer setup

Ctrl (Control) ¥ (Command) Used with other keys
Fi11 HE+T Open the Styles deck in the Sidebar

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/
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Introduction

This chapter briefly describes some of the setup options found under Tools > Options on the
Menu bar in Writer. Additional options, and more details about the ones given here, are covered
in the Help and in Chapter 2, Setting up LibreOffice, in the Getting Started Guide. Several of the
most relevant options are discussed in other chapters of this book, in the context of tasks where
they are most applicable.

This chapter also briefly describes some common customizations that you may wish to do. You
can customize menus, toolbars, and keyboard shortcuts, add new menus and toolbars, and
assign macros to events. Other customizations are made easy by extensions that you can install
from the LibreOffice website or from other providers. You may also choose to activate and use
some experimental features; see page 33.

OTip

Many options are intended for power users and programmers. If you don’t
understand what an option does, it's usually best to leave it on the default setting
unless instructions in this book recommend changing the setting.

Note

Customizations to menus and toolbars can be saved in a template. To do so, first
save them in a document and then save the document as a template as described in
Chapter 10, Working with Templates. If you work on more than one project, you may
find that having different menus and toolbars can be useful.

Choosing options for all of LibreOffice

This section covers some of the settings that apply to all the components of LibreOffice (Writer,
Calc, Impress, Draw, Math, and Base) and that are particularly important when using Writer.

To navigate to options that govern all LibreOffice components, click Tools > Options and then
click the marker (+ or triangle) by LibreOffice on the left-hand side. A list of pages drops down.
Select an item in the list to display the relevant page on the right-hand side of the dialog.

ﬂTip

The Reset button (located in the lower part of any page of the Options dialog) resets
the values on that page to the values that were in place when you opened the dialog.

If you are using a version of LibreOffice other than US English, some field labels may be different
from those shown in the illustrations.

User data

Because Writer can use the name or initials stored in the LibreOffice — User Data page for
several things, including document properties (‘created by’ and ‘last edited by’ information), the
name of the author of comments and changes, and the sender address in mailing lists, you will
want to ensure that the correct information appears here. If you do not want user data to be part
of the document’s properties, deselect Use data for document properties.
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View options
The options on the LibreOffice — View page affect how the document window looks and behaves.

Set them to suit your personal preferences. For details, see the Help or Chapter 2, Setting up
LibreOffice, in the Getting Started Guide.

Print options

On the LibreOffice — Print page, set the print options to suit your default printer and your most
common printing method.

In the Warnings section on the right side of the page, you can choose whether to be warned if the
paper size or orientation specified in your document does not match the paper size or orientation
available for your printer. Having these warnings turned on can be quite helpful, particularly if you
work with documents produced by people in other countries where the standard paper size is
different from yours.

Settings for

O Printer
Print to file
Defaults Warnings
PDF as standard print job format Paper size
Convert colors to grayscale Paper orientation
& Transparency
Reduce Bitmaps Reduce Gradient
Reduce bitmaps Reduce gradient
Reduce Transparency
Reduce transparency
Reset Apply Cancel OK

Figure 1: Choosing general printing options to apply to all LibreOffice components

OTip

If your printouts are incorrectly placed on the page or chopped off at the top, bottom,
or sides, or the printer is refusing to print, a likely cause is incorrect page size in
printer settings.

Paths options

On the LibreOffice — Paths page, you can change the location of files associated with, or used by,
LibreOffice to suit your needs. For example, you might want to store documents by default
somewhere other than My Documents. Multiple paths are possible.
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Fonts options

If you receive a document containing fonts that you do not have on your system, LibreOffice will
use substitute fonts for those it does not find. On the LibreOffice — Fonts page, you can specify a
font different from the one the program chooses.

OTip

Liberation fonts (Serif, Sans, and Mono) are often good choices to substitute for
Times, Arial, and Couirier.

Note

The Font Options choices do not affect the default fonts for your documents. To
change them, you need to create a new default template for Writer documents, as
described in Chapter 10, Working with Templates.

Security options

Use the LibreOffice — Security page to choose security options for saving documents and for
opening documents that contain macros. For information on the options not mentioned here,
refer to the Help or to the Getting Started Guide.

Security Options and Warnings
If you record changes, save multiple versions, or include hidden information or notes in
your documents, and you do not want some recipients to see that information, you can set
warnings to remind you to remove it, or you can have LibreOffice remove some of it
automatically. Note that unless the information is removed, much of it is retained even
when the file has been saved to other formats, including PDF.

Click the Options button to open a separate dialog with several options, including:

Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file.
To save personal information with documents and still be able to manually remove personal
information only from specific documents, do not select this option.

Ctrl-click required to open hyperlinks
The default behavior in LibreOffice is that using Ctrl+click a hyperlink opens the linked
document or website. This is because many people find writing and editing documents
easier when accidental clicks on links do not activate the links. To set LibreOffice to activate
hyperlinks using just an ordinary click, deselect this option.

Application colors

Writing, editing, and (especially) page layout are often easier when you can see the page
margins (text boundaries), the boundaries of tables and sections, grid lines, and other features.
In addition, you might prefer to use colors that are different from LibreOffice’s defaults.

On the LibreOffice — Application colors page (Figure 2), you can specify which user interface
elements are visible and the colors used to display them.

* To show or hide items such as text boundaries, select or deselect the boxes in the On
column next to the names of the elements.

» To change the default colors for a specific element, click the down-arrow in the Color
setting column by the name of the element and select a color from the drop-down list.

» To save your color changes as a color scheme, click Save, type a name in the Scheme
box, and then click OK.
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Note

To change the color settings used in Track Changes mode, go to Tools > Options >
LibreOffice Writer > Changes.

Color Scheme

Scheme: LibreOfficeDev - Save Delete

Custom Colors

On User interface elements Color setting
General
Document background [ JAutomatic v
& Text boundaries [~ ]Automatic -
Application background [ ]Automatic v
Object boundaries [ ]Automatic -
& Table boundaries [ ]Automatic v
Font color I A utomatic v
Unvisited links I Automatic -
Visited links I Automatic v
AutoSpellcheck I Automatic v
Smart Tags I Automatic -

Figure 2: Showing or hiding text, object, and table boundaries

Choosing options for loading and saving documents

You can set the options for loading and saving documents to suit the way you work.

If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or
triangle) to the left of Load/Save.

General

Most of the choices on the Load/Save — General page (Figure 3) are familiar to users of other
office suites. Some items of interest are described below.

Load user-specific settings with the document
When a LibreOffice document is saved, certain settings from the user's system are saved
with it. When the document is opened on another user’s system, it will use the settings
saved from the previous user’s system. Deselecting this option causes the current user’s
settings to override the settings previously saved with the document.

Even if you deselect this option, some settings are always loaded with the document:

Settings available in File > Print > Options.

Spacing options for paragraphs before text tables.

Information about automatic updating for links, field functions, and charts.
Information about working with Asian character formats.
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Help

Extended tips
Show "No offline help installed" popup
Show "Tip of the Day" dialog on start-up

Open/Save Dialogs
Use LibreOfficeDev dialogs

Document Status
Printing sets "document modified" status

Year (Two Digits)
Interpret as years between | 1930 - + and 2029

Help Improve LibreOfficeDev
Collect usage data and send it to The Document Foundation

Figure 3: Choosing Load and Save options

Note

The settings for any data sources linked to a document are always loaded with the
document, whether or not Load user-specific settings with the document is selected.

Load printer settings with the document
If this option is enabled, the printer settings of the previous user will be loaded with the
document. In an office setting, this may cause a document to be printed on a distant
network printer unless the printer is manually changed in the Print dialog. If disabled, the
current user’s default printer will be used to print the document. The current printer settings
will be stored with the document whether or not this option is selected.

Save AutoRecovery information every __ minutes
Choose whether to enable AutoRecovery and how often to save the information used by
the AutoRecovery process. AutoRecovery in LibreOffice saves the information needed to
restore all open documents in case of a crash. If you have this option set, recovering your
document after a system crash will be easier.

Edit document properties before saving
If this option is selected, the document’s Properties dialog pops up to prompt you to enter
relevant information the first time you save a new document (or whenever you use Save
As).

Always create backup copy
Saves the previously-saved version of a document as a backup copy in a separate folder
whenever you save a document. When LibreOffice creates a new backup copy, the
previous backup copy is replaced. The backup copy gets the extension BAK. To see or
change the backup folder, go to Tools > Options > LibreOffice > Paths. When opening a
backup file, you will be prompted to specify the program to open it with; choose LibreOffice.

OTip

Authors whose work may be very lengthy should always consider enabling
LibreOffice to create an automatic backup copy.
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Save URLs relative to file system / to internet
Use these options to select the default for relative addressing of URLSs in the file system
and on the Internet. For details, see Chapter 2, Setting up LibreOffice, in the Getting
Started Guide.

Default File Format and ODF Settings
ODF format version: LibreOffice by default saves documents in OpenDocument Format
(ODF) version 1.3 Extended. While this allows for improved functionality, there may be
backwards compatibility issues. When a file saved in ODF 1.3 Extended is opened in an
editor that uses an earlier version of ODF, some of the advanced features may be lost. If
you plan to share documents with people who use editors that use older versions of ODF,
you may wish to save the document using ODF 1.2 Extended (compatibility mode).

Document type: If you routinely share documents with users of Microsoft Word, you might
want to change the Always save as option to one of the Word formats. However, you can
choose a Word format when you save any individual file.

VBA properties

On the VBA Properties page, you can choose whether to keep any macros in Microsoft Office
documents that are opened in LibreOffice. For details, see Chapter 2, Setting up LibreOffice, in
the Getting Started Guide.

Microsoft Office

On the Load/Save — Microsoft Office page, you can choose what to do when importing and
exporting Microsoft Office OLE objects (linked or embedded objects or documents such as
equations or spreadsheets): convert them into or from the corresponding LibreOffice OLE object
or load and save them in their original format. For details, see Chapter 2 in the Getting Started
Guide.

HTML compatibility

Choices made on the Load/Save — HTML Compatibility page (not shown) affect HTML pages
imported into LibreOffice and those exported from LibreOffice. See HTML documents; HTML
import and export in the Help, and Chapter 2 in the Getting Started Guide, for more information.

Choosing Writer-specific options

Settings chosen in the LibreOffice Writer section of the Options dialog determine how Writer
documents look and behave while you are working on them.

If the Options dialog is not already open, choose Tools > Options. Click the marker (+ or
triangle) by LibreOffice Writer on the left side of the dialog.

General options

The choices on the LibreOffice Writer — General page affect the updating of links and fields, the
units used for rulers and other measurements, and the default tab stop positions.

Automatically Update [Fields and Charts]
You may not want fields or charts to update automatically while you are working, because
that slows down performance. Alternatively, you may want automatic updates if you are
referring to information in the fields or charts.

Update Links when Loading
Depending on your work patterns, you may not want links to be updated when you load a
document. For example, if your file links to other files on a network, you won't want those
links to try to update when you are not connected to the network.
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Automatically Update
Fields
Charts

Update Links when Loading
Always
© On request

Never
Settings

Measurement unit: = Inch -

Tab stops: = 0.49” -+
Enable char unit Use square page mode for text grid
Word Count
Additional separators: = —-
Show standardized page count

Characters per standardized page:

Figure 4: Choosing general options for Writer

Settings — Measurement unit
Document designers recommend using points as the default measurement because you
can easily relate things like font size to things like indents and tabs.

Settings - Tab stops
The Tab stops setting specifies the distance the cursor travels for each press of the Tab
key. This setting is also used for the indent distance applied by the Increase Indent and
Decrease Indent buttons on the Formatting Toolbar, which affect the indentation of entire
paragraphs.

ﬂTip

To avoid unwanted changes, do not rely on default tab settings. Rather, define your
own tabs in paragraph styles or individual paragraphs (see “Setting tab stops and
indents” in Chapter 4, Formatting Text).

Word Count - Additional separators
For counting words, specifies the characters that are considered to separate words, in
addition to spaces, tabs, line breaks, and paragraph breaks.

Word Count - Show standardized page count
Editors and publishers often define a “standard” page as containing a specified number of
characters or words; this field allows quick calculation of the number of these pages.

View options

Two pages of options set the defaults for viewing Writer documents: View (described here) and
Formatting Aids (described below). View is a good page to check if, for example, you cannot see
graphics on the screen.

Guides - Helplines While Moving
Helplines assist with precisely position a frame or drawing object on a page. When
enabled, horizontal and vertical lines appear that are the height and width of a selected
object. These lines extend across the complete working area as the object is moved.
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Display Fields — Hidden text
Display text that is hidden by Conditional Text or Hidden Text fields.

Display Fields - Hidden paragraphs
Display paragraphs that contain a Hidden Paragraph field. This option has the same
function as the menu command View > Field Hidden Paragraphs.

Display tracked changes
Tracked deletions in margin: By default, deletions are shown in the text with a
strikethrough font. To show deletions in the margin, not in the text, select this option.

Tooltips on tracked changes: When this option is selected, hold the mouse pointer over a
tracked change to show the type of change, the author, date, and time of day for the
change. To hide these tooltips, deselect this option.

Outline mode
If you have activated experimental features, an option (Show outline content visibility
button) is available under this heading. See “Using experimental features” on page 33.

The other options should be self-explanatory. If not, please refer to the Help.

Guides View
kel allies Bl Uit Horizontal ruler = Centimeter -
Displa
. Vertical ruler | Centimeter -
Images and objects
® Tables Right-aligned
Drawings and controls Smooth scroll
Comments Outline Folding

RESo|vedleommente Show outline-folding buttons

Display Fields
Hidden text
Hidden paragraphs
Display tracked changes
Tracked deletions in margin

® Tooltips on tracked changes

Figure 5: Choosing default View options for Writer

Formatting Aids options
On the LibreOffice Writer — Formatting Aids page (Figure 6), select the desired options.

Layout Assistance — Math baseline alignment
To set the default vertical alignment for formula (Math) objects to use the text base line as a
reference, select this option. To enable changing the vertical positioning of objects, deselect
this option; you can then set the position for individual objects. See the Math Guide for
more information.

Display Formatting
The Display Formatting options determine which symbols show when you select View >
Formatting Marks on the Menu bar or the Formatting Marks icon on the Standard
toolbar. Symbols such as paragraph ends and tabs can help in writing, editing, and page
layout. For example, they can show if there are any blank paragraphs or if any tables or
graphics are too wide and intrude into the margins of the page.
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Direct Cursor

Direct Cursor lets you enter text, images, tables, frames, and other objects in any blank
area in your document. Writer then inserts your choice of tabs, spaces, indents, and so on
to position the text or objects. For details on these choices, please see the Help.

Note

The direct cursor feature can lead to many formatting oddities and is incompatible

with rigorous use of styles.

Image - Anchor

You can choose the default anchor for newly added images: To Paragraph, To Character,
or As Character. For more about anchoring images, see Chapter 11, Images and Graphics.

Layout Assistance
Math baseline alignment

Display Formatting

Paragraph end 1
Soft hyphens

Spaces

Non-breaking spaces

@ Tabs -
Breaks «

Hidden characters

Bookmarks [ T[]

Protected Areas
Enable cursor

Direct Cursor
Direct cursor

Insert: = Spaces -
Image
Anchor:  To Character -

Figure 6: Choosing default Formatting Aids options

Grid options

Snap to grid automatically moves an object to the nearest gridlines. This can be very helpful
when you are trying to align several objects such as graphics or tables.

On the LibreOffice Writer — Grid page, you can choose whether to enable this feature and what
grid intervals to use. If the grid intervals (subdivisions) are too large, you may find that you do not
have enough control in placing the objects.

Print options

On the LibreOffice Writer — Print page, you can choose which items are printed with a Writer
document by default. These options are in addition to the general options for all LibreOffice
components on the LibreOffice — Print page (see page 6).

ﬂTip

You can override any of these defaults when printing a specific document. Click File
> Print, then use the options on the various pages of the Print dialog.
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Contents Comments
Images and objects @ None

Form controls Comments only

Page background End of document
Print text in black End of page
Hidden text In margins

Text placeholder
Pages
Left pages
Right pages
Brochure

Other
Print automatically inserted blank pages

Paper tray from printer settings

Fax: [None] v

Figure 7: Choosing default Print options for Writer

Some considerations:

When you are working on drafts and you want to save printer ink or toner, you might want
to deselect some of the items in the Contents section.

The Print text in black option causes color text (but not graphics) to print as black on a
color printer; on a black-and-white printer, this option causes color text to print as solid
black instead of shades of gray (dithered).

By comparison, the Convert colors to grayscale option on the Options — LibreOffice —
Print page (Figure 1), prints all text and graphics as grayscale on color printers. (On
black-and-white printers, color in graphics normally prints as grayscale.)

If you are printing double-sided on a non-duplexing printer, you might choose to print only
left or right pages, then turn the stack over and print the other pages.

Table options

On the LibreOffice Writer — Table page (Figure 8), you can specify the default behavior of tables.
See the Help or Chapter 13, Tables of Data, for more information.

Some considerations:

If most of your tables will require borders or headings, you may wish to select those
options. If most of your tables are used for page layout, deselect Border and Heading.

Select Do not split to prevent tables from being split across pages. Number recognition
can be very useful if most of your tables contain numerical data. Writer will recognize
dates or currency, for example, and format the numbers appropriately. However, if you
want the numbers to remain as ordinary text, this feature can be quite irritating, so you
may want to deselect it.

The Keyboard Handling section specifies the distances that cells move when you use
keyboard shortcuts to move them and the size of rows and columns inserted using
keyboard shortcuts. If you don’t use keyboard shortcuts for this purpose, you can ignore
these settings. See the Help for more information.
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* The Behavior of rows/columns section specifies the effects that changes to rows or
columns have on adjacent rows or columns and the entire table. You might need to test
these selections to fully understand the effects.

New Table Defaults Input in Tables
Heading Number recognition
Do not split
Border
Keyboard Handling
Move cells Insert cell
Row: 0.200 — + Row: 0.20" - +
Column: | 0.20” -+ Column:  0.98” -+

Behavior of rows/columns
Fixed Changes affect the adjacent area only
Fixed, proportional Changes affect the entire table

© Variable Changes affect the table size

Figure 8: Choosing default Table options

Changes options

If you plan to use the change-tracking feature of Writer (described in Chapter 3, Working with
Text: Advanced), use the LibreOffice Writer — Changes page to choose the way changes to text
and formatting are marked. Change bars can show wherever a change has been made to a line
of text and are formatted under Lines Changed.
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Insertions

Attributes: = Underlined -
Insert

Color: [ By author -
Deletions
Attributes: | Strikethrough v
Belete
Color: [ IBy author -
Changed Attributes
Attributes: = Bold v
Attributes
Color: [ IBy author -

Lines Changed

Mark: Left margin -
Color: I Black -

Reset Apply Cancel OK

Figure 9: Choosing options for tracking changes

Comparison options

The options on the LibreOffice Writer — Comparison page determine the level of detail used by
the Compare Document feature (Edit > Track Changes > Compare Document), described in
Chapter 3, Working with Text: Advanced.

Compare Documents
O Auto

By word

By character

Random number to improve accuracy of document comparison

Store it when changing the document

Figure 10: Choosing options for comparing documents

Compatibility options

The settings on the LibreOffice Writer — Compatibility page (Figure 11) are used mainly when
importing documents from Microsoft Word. If you are not sure about the effects of these settings,
leave them as the defaults provided by LibreOffice. For information about settings that are not
described below, see the Help. All settings selected will apply only to the current document,
unless you select the Use as Default button at the bottom.
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Global Compatibility Options

Reorganize Form menu to have it MS compatible

Compatibility options for “Untitled 1”

B Use printer metrics for document formatting

Add spacing between paragraphs and tables
Add paragraph and table spacing at tops of pages
Use OpenOffice.org 1.1 tabstop formatting
Do not add leading (extra space) between lines of text
Use OpenOffice.org 1.1 line spacing
Add paragraph and table spacing at bottom of table cells
Use OpenOffice.org 1.1 object positioning
Use OpenOffice.org 1.1 text wrapping around objects
Consider wrapping style when positioning objects
Expand word space on lines with manual line breaks in justified paragraphs
Protect form (no longer protects whole document. Insert write protected section instead)
Word-compatible trailing blanks
Tolerate white lines of PDF page backgrounds for compatibility with old documents
Hide paragraphs of database fields (e.g., mail merge) with an empty value

Use as Default

Figure 11: Choosing compatibility options

Use printer metrics for document formatting
If this option is selected, the printer specified for the document determines how the
document is formatted for viewing on screen. The line breaks and paragraph breaks you
see on screen match those that apply when the document is printed on that printer. If this
option is not selected, a printer-independent layout will be used for screen display and
printing.

This setting can be useful when several people are reviewing a document that will
eventually be printed on a specific printer or when the document is exported to PDF. It is
most useful with PostScript printers.

Add spacing between paragraphs and tables
Paragraph spacing is treated differently in LibreOffice Writer than it is in Microsoft Word. If
you have defined spacing between paragraphs or tables in LibreOffice, this spacing is
added to the spacing defined in Microsoft Word. This only affects the current document.

If this option is selected, Microsoft Word-compatible spacing is added between paragraphs
and tables in LibreOffice Writer documents.

Add paragraph and table spacing at tops of pages
You can define paragraphs and tables to have space appear before (above) them. If this
option is selected, any space above a paragraph will also appear if the paragraph is at the
beginning of a page or column, or if the paragraph is positioned on the first page of the
document, or after a manual page break. This only affects the current document.

If you import a Microsoft Word document, the spaces are automatically added during the
conversion.

Add paragraph and table spacing at bottom of table cells
Specifies that the bottom spacing is added to a paragraph, even when it is the last
paragraph in a table cell.

Use as Default
Click this button to use the settings on this page as the default in Writer.
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AutoCaption options

LibreOffice can automatically insert captions for tables, pictures, frames, and OLE objects in a
Writer document. To set this up, use the options on the LibreOffice Writer > AutoCaption page.
Select the object you want to be automatically captioned (LibreOffice Writer Image in Figure 12).
With the item highlighted, specify the characteristics of the caption.

The categories supplied for captions are Drawing, lllustration, Table, and Text. To use another
name (for example, Figure) for the caption label, type the required term in the Category box.

Note

You may not want captions for every table, for example if you use tables for layout as
well as for tables of data. You can always add captions to individual tables, graphics,
or other objects (right-click > Insert Caption).

Information about numbering captions by chapter, character styles, frame styles, and other items
on the AutoCaption page is given in other chapters in this book.

Add captions automatically Caption
when inserting:
Category: Table -
LibreOfficeDev Writer Table
LibreOfficeDev Writer Frame
) ) ) Numbering: Arabic (1 2 3) v
LibreOfficeDev Writer Image
LibreOfficeDev Spreadsheet
LibreOfficeDev Drawing
LibreOfficeDev Formula Separator:
LibreOfficeDev Chart
LibreOfficeDev Presentation Position: Below v
Caption Order Numbering Captions by Chapter
Category first - Level: 1 =
Table 1: Separator:

Category and Frame Format

Character style: None -

Figure 12: Setting up automatic captions

Mail Merge E-mail options

Using a data source such as an address book, Writer can insert personal, address, and other
information into form letters. These documents can be printed for mailing or they can be e-mailed
through Writer. (See Chapter 14, Mail Merge, for details.)

Use the LibreOffice Writer — Mail Merge E-mail page to set up the user and server information for
sending form letters by e-mail. If you are not sure what information to put in any of the fields,
consult your e-mail program or your internet service provider.
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User Information

Your name:

Email address:

Send replies to different email address

Outgoing Server (SMTP) Settings

Server name:

Port: 587 -+
Use secure connection (SSL)

Server Authentication... Test Settings
Figure 13: Specifying settings for use when emailing mail-merged form letters

Choosing language settings

You may need to do several things to get the language settings you want:

* Install the required dictionaries.
» Change some locale and language settings.
* Choose spelling and grammar options.

Install the required dictionaries

LibreOffice automatically installs many language modules with the program. A language module
can contain up to three submodules: spelling dictionary, hyphenation dictionary, and thesaurus.
These are usually referred to as “dictionaries” in Writer.

To add other dictionaries, be sure you are connected to the Internet, and then choose Tools >
Language > More Dictionaries Online on the Menu bar. LibreOffice will open your default web
browser to a page containing links to additional dictionaries that you can install. Follow the
prompts to select and install the ones you want.

Change some locale and language settings

You can change some details of the locale and language settings that LibreOffice uses for all
documents or for specific documents. See the Help for details on all these options.

In the Options dialog, click the expansion symbol (+ sign or triangle) by Language Settings and
choose Languages.

On the right-hand side of the Language Settings — Languages page (Figure 14), change the
settings as required. In the example, English (USA) has been chosen for all the appropriate
settings, but you could choose a mixture of languages. For example, if you were working in
Germany, you might prefer the user interface to be in English (USA), but German (Germany) for
the Locale setting, which influences settings for numbering, currency, and units of measure.
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Language Of

User interface: Default - English (USA) -
Formats

Locale setting: English (USA) v

Default currency: Default - USD -

Decimal separator key: Same as locale setting ( . )

Date acceptance patterns:  M/D/Y;M/D

Default Languages for Documents

Western: ab, Default - English (USA) -
4 Asian: Default - Chinese (simplified) v
Complex text layout: Default - Hindi v

For the current document only

Enhanced Language Support
Ignore system input language

Figure 14: Choosing language options

If you want the language setting to apply to the current document only, instead of being the
default for all new documents, select For the current document only.

Changes to the system input language/keyboard normally affect text typed into a document after
the change. If you do not want this to happen, select Ignhore system input language; new text
will then continue to follow the language of the document or the paragraph, not the system
language.

If necessary, select the options to enable support for Asian languages (Chinese, Japanese,
Korean) and support for CTL (complex text layout) languages such as Hindi, Thai, Hebrew, and
Arabic. If you choose either of these options, the next time you open the Options dialog, you will
see some extra pages under Language Settings. These pages are not discussed here.

Choose spelling and grammar options

To change the options for checking spelling and grammar, use the Language Settings > Writing
Aids page (Figure 15).
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Available Language Modules

~ Hunspell SpellChecker Edit...
Libhyphen Hyphenator

MyThes Thesaurus

User-defined Dictionaries
v en-US [English (USA)] New...
sl [{sl}]
; Edit...
technical [All]
en-GB [English (UK)]
Régi helyesiras (AkH. 11.) [Hungarian]
List of Ignored Words [All]

Delete

Options
Check grammar as you type
Check uppercase words
Check words with numbers
Check special regions
Minimal number of characters for hyphenation: 5

Get more dictionaries online...

Figure 15: Choosing languages, dictionaries, and options for checking spelling

Some considerations:

* If you do not want spelling checked while you type, deselect Check spelling as you
type. (You can over-ride this setting in a document using Tools > Automatic Spell

Checking on the Menu bar or the Toggle Automatic Spell Checking icon on the
Standard toolbar.)

» If you want grammar to be checked as you type, you must have Check spelling as you
type enabled too.

* Check special regions means that text in headers, footers, frames, and tables are also
checked when checking spelling.

Here you can also select which of the user-defined (custom) dictionaries are active, add a new

custom dictionary, edit dictionaries, and delete custom dictionaries. Dictionaries installed by the
system cannot be deleted.

@ Tip
When checking spelling, words marked “Add to Dictionary” are added by default to

the Standard dictionary. Words marked “Ignore All” are added to the IgnoreAllList
dictionary. See Chapter 2, Working with Text: Basics.

Sentence checking

LibreOffice can check sentences in many languages. These checkers are enabled by default if
the language is the computer’s default language, and others can be added using the Extension
Manager (see page 30). The set of rules available for the sentence checkers depends on the

language.
English sentence checking

On the Language Settings > English Sentence Checking page (Figure 16), you can choose
which items are checked for, reported to you, or converted automatically. This menu is also found
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in the English dictionaries extension installed by default by LibreOffice (select Tools > Extension
Manager, select English spelling dictionaries and click the Options button to reveal the
menu). Select which of the optional features you wish to check. These are described in Chapter
2, Working with Text: Basics.

After selecting the additional grammar checks, you must restart LibreOffice, or reload the
document, for them to take effect.

Grammar checking

Possible mistakes Capitalization
Word duplication Parentheses
Punctuation
Word spacing Em dash
Quotation marks Multiplication sign
Sentence spacing En dash
Apostrophe Ellipsis
More spaces Minus sign
Others

Convert to metric (°C, km/h, m, kg, [)
Thousand separation of large numbers
Convert to non-metric (°F, mph, ft, lb, gal)

Figure 16: Choosing options for checking sentences in English

Selecting the user interface

By default, LibreOffice Writer's commands are grouped in cascading menus and in toolbars filled
with icons—the standard user interface described in Chapter 1. In addition, Writer provides other
user interface variations, displaying contextual groups of commands and contents.

When you set up Writer, you can choose one of these user interfaces, and you can switch
between them and the standard interface at any time.

1) Choose View > User Interface on the Menu bar.

2) On the Select Your Preferred User Interface dialog (Figure 17), choose one of the
variants on the left. An example of the variant is shown in the Preview box on the right,
along with a short description.

3) Choose the relevant button to apply your selection to all components of LibreOffice, or
only to Writer.

4) Click Close to close the dialog and apply your selection. The Writer window changes to
match your selection.
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Ul variants Preview
© Standard Toolbar

Tabbed File Edit Insert
Single Toolbar EEOQ(XDB|55C
Sidebar v Styles B ! U §|x
Tabbed Compact

Groupedbar Standard user interface with menu, toolbar, and

collapsed sidebar. Intended for users who are familiar

Groupedbar Compact ’ -d
with the classic interface.

Contextual Single
Contextual Groups

Apply to All Apply to Writer Close

Figure 17: Selecting a user interface

ﬂ Tips

Several of the Ul variants are collectively known as the Notebook bar. You can find
more information about these variations in the Help system, by searching for
“notebook bar” in the index.

If you have activated experimental features (see page 33), several more choices
appear on the left-hand side.

Customizing menus

You can add to and rearrange menus on the Menu bar, add commands to menus, and make
other changes. You can also modify context (right-click) menus in a similar way.

To customize a menu, choose Tools > Customize. On the Customize dialog, go to the Menus
tab (Figure 18) or the Context Menus tab.

Modifying an existing menu

1)

2)

3)

4)

In the Scope drop-down list in the upper right of the Customize dialog, choose whether to
apply the customized menu to all of LibreOffice Writer or only to a specific document.

In the Target drop-down list, select the menu that you want to customize. The list includes
the main menus and submenus. The commands on the selected menu are shown in the
Assigned Commands list.

To add a command to the selected menu, click on a command in the Available
Commands list and then click the large right arrow. You can narrow the search by using
the Search box on the top left or selecting the Category in the drop-down list. Use the up
and down arrows on the right-hand side to move the command into the position where
you want it in the list.

To remove a command from the selected menu, click on it in the Assigned Commands list
and then click the large left arrow.
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Menus
Search
Type to search
Category
All commands -

Available Commands

Scope

LibreOfficeDev Writer

Target

File

Assigned Commands

150% Open...
200% - Open Remote...
Ej 3D Color %) Recent Documents
50% g Close
75%
About LibreOfficeDev \ Wizards
I/@ Absolute Record | Templates
=& Accept .
5o Accept All € Reload
ag) Accept and Move to Next ||| Versions...
4, Activation Order
= Add Field ¥ Save
AB Add Text Box ¥| Save As...
= Add to List [¥| Save Remote...
Additions L Save a Copy...
E Address Book Source 7y Save All
Description Customize
Label: 100%
Command: .uno:Zoom100Percent Insert ~

Tooltip: 100%

Help

Reset Cancel

Figure 18: The Menus tab of the Customize dialog

OK

5) To insert a separator or submenu, select the item directly before where you want the
inserted item to appear, and use the commands in the Insert drop-down.

Customize

Insert ™ Meodify Defaults

Insert Separator

Insert Submenu

Figure 19: Insert drop-down

6) To rename a menu item, select it in the Assigned Commands list and choose Rename
from the Modify drop-down.

Customize

Inset ™ Modify Defaults

Rename...

Figure 20: Modify drop-down

7) When you have finished making all your changes, click OK to save them.

24 | Chapter 20 Customizing Writer



Creating a new menu

You might find a “Favorites” menu useful, or a menu collecting tools for a specific project. To
create a new menu:

1) On the Menus tab of the Customize dialog, click the symbol next to Target and select
Add from the drop-down list (Figure 21) to display the New Menu dialog (Figure 22).

Target

File v “
Assigned Commands Add...
|| Mew Move...
= open.. |

Figure 21: Location of command to add a new menu

2) Type a name for the new menu in the Menu name box.

3) Use the up and down arrow buttons to move the new menu into the required position on
the Menu bar.

4) Click OK to save and return to the Customize dialog.

The new menu now appears on the list of menus in the Customize dialog. It will appear on the
Menu bar itself after you save your customizations.

After creating a new menu, you need to add some commands to it, as described above for
modifying a menu.

Menu name:

New Menu 1

Menu position:
File

Edit
View
Insert
Format
Styles
Table
Form
Tools
Window
Help

Help Cancel oK

Figure 22: Adding a new menu
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Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and
locking the position of a docked toolbar (as described in Chapter 1, Introducing Writer), and
adding or deleting icons (commands) in the list of those available on a toolbar. You can also

create new toolbars.

Modifying existing toolbars

The procedures for creating and modifying a toolbar are similar to those for menus.

1) Choose Tools > Customize on the Menu bar.

2) On the Toolbars tab of the Customize dialog (Figure 23), in the Scope drop-down list on
the upper right, choose whether to save this changed toolbar for Writer or for a selected

document.

Toolbars
Search

Type to search

Category
All commands -

Available Commands
100%
200%
L1 3D Color
50%
75%
About LibreOfficeDev
"@ Absolute Record
= Accept
&5 Accept All
&/ Accept and Move to Next
&5, Activation Order
= Add Field
AB Add Text Box
<= Add to List
Additions
E Address Book Source
Description

Label: 150%
Command: .uno:Zoom150Percent
Tooltip: 150%

Help

Scope

LibreOfficeDev Writer v

Target
Standard -

Assigned Commands
@ Load URL
New
& Templates
Open
- Open Remote
4+ Save
¥| Save As
7 Email

# Edit Mode
Read Only Mode

Export Directly as PDF

i2 epus
= Print
= Print Directly
\| Print Preview
Customize
Insert - Defaults
Reset Cancel OK

Figure 23: The Toolbars tab of the Customize dialog

3) Inthe Target drop-down list, select the toolbar that you want to customize. The current
toolbar content is displayed in the Assigned Commands list.

4) Select a command in the Available Commands list on the left. You can narrow your
search by using the Search box on the top left or choosing a category in the drop-down

list just below.

5) Click on the large right arrow to add the selected command to the Assigned Commands
list for the toolbar (on the right). Use the up and down arrows in the far right to position

the command in the toolbar.

6) To remove a command from a toolbar, select it in the Assigned Commands list on the

right and click the large left arrow.
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7) To show or hide a command assigned to a toolbar, select or clear the checkbox by its icon
in the Assigned Commands list on the right.

8) To insert a separator, select the item directly before where you want the separator to
appear, and use the command in the Insert drop-down.

9) To rename a toolbar item, select it in the Assigned Commands list and choose Rename
from the Modify drop-down.

When you have finished making all your changes, click OK to save them.

Creating a new toolbar
To create a new toolbar:

1) Choose Tools > Customize on the Menu bar.

2) On the Toolbars tab of the Customize dialog, click the symbol next to Target and select
Add in the list, to display the Name dialog.

3) On the Name dialog, type the new toolbar's name and choose in the Save /In drop-down
list where to save this new toolbar: for Writer or for a selected document.

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new
toolbar, you need to add some commands to it, as described above.

Choosing icons for toolbar commands

Toolbar buttons usually have icons, not words, on them, but not all of the commands have
associated icons. If the command does not have an icon, you can choose an icon for it. To
choose an icon, select the command in the list on the right, and click Modify > Change Icon. On
the Change Icon dialog (Figure 24), scroll through the available icons, select one, and click OK to
assign it to the command.

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the
Import button on the Change Icon dialog. Custom icons should be 16x16 pixels in size to
achieve the best quality and should not contain more than 256 colors.

Icons Import...
AR E =
o8 E B &N E =
g \

e E99C R L AT %)
Note:
The size of an icon should be 24x24 pixel to achieve best quality.
Different sized icons will be scaled automatically.

Help Cancel (0] ¢

Figure 24: Change Icon dialog
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Customizing the Tabbed user interface

As mentioned in “Selecting the user interface” on page 22, one of the choices is Tabbed. In this
mode, the area at the top of the workspace is divided into tabs, where each tab displays a set of
icons grouped by context. The context can change depending on the object selected in the
document, for example a table or an image.

Use the checkboxes on the Notebookbar tab of the Customize dialog (Figure 25) to show and
hide the individual options on the various tabs that are provided in the Tabbed mode user
interface.

Notebookbar
Scope
LibreOfficeDev Writer - Tabbed -
Target
All Commands -

Assigned Commands
File Tab | File
New
! Templates
Save as Template

(<N <J<]

Open
<) Recent Documents

(< <H<

Open Remote

Save
Save As

(< <M <]

¥
¥
¥| Save Remote
==

= Export
Export Directly as PDF

(<<
|

Help Reset Cancel OK

Figure 25: The Notebookbar tab of the Customize dialog

Use the Reset button to reset the Tabbed mode of the notebook bar configuration to the default
settings.

Note

LibreOffice has three notebook bar modes that can be selected through the View >
User Interface dialog — Tabbed, Tabbed Compact, and Groupedbar Compact.
However, only the Tabbed mode can be modified.
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Assigning shortcut keys

In addition to using the built-in keyboard shortcuts, you can define others. You can assign
shortcuts to standard LibreOffice functions or your own macros and save them for use with Writer
or with the entire LibreOffice suite.

To adapt shortcut keys to your needs, use the Keyboard tab of the Customize dialog (Figure 26).

Menus Toolbars Notebookbar Context Menus Keyboard Events

Shortcut Keys LibreOfficeDev
N © iier

F2 Text Formula Modify
F3 Run AutoText Entry

F4 Image Properties Delete
F5 Navigator

F6

F7 Spelling

F8 Select Cycle

Fo Fields Load...
F10 Save...
F11 Styles

F12 Ordered List Reset
Functions

Type to search

Category Function Keys
Application 150%
View 200%
Templates 3D Color
Options 50%
BASIC 75%
Special Functions About LibreOfficeDev
Insert Absolute Record
Documents Accept
Format Accept All
Help Reset Cancel OK

Figure 26: Defining keyboard shortcuts for applying styles

1) Choose whether to have the shortcut key assignment available in all components of
LibreOffice or only in Writer.

2) Select the desired shortcut key in the Shortcut Keys list at the top of the page.
3) Select the required function from the Category and Function lists.
4) Click the Modify button. The selection now appears in the Keys list on the lower right.
5) Click OK to accept the change.
Repeat as required.

Caution

Avoid reassigning your operating system’s predefined shortcut keys.

Q Note

Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1
and F10, are not available for reassignment.
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Saving changes to a file

Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at
a later time, so you can create and apply different configurations as needed. To save keyboard
shortcuts to a file:

1) After making keyboard shortcut assignments, click the Save button at the right of the
Customize dialog (Figure 26).

2) On the Save Keyboard Configuration dialog, type a name for the keyboard configuration
file in the File name box, or select an existing file from the list. Browse to the location
where you want to save the file. (The file extension is .cfg for Configuration.)

3) Click Save. A confirmation dialog appears if you are about to overwrite an existing file,
otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration

To load a saved keyboard configuration file and replace your existing configuration, click the Load
button on the Customize dialog, and then select the configuration file on the Load Keyboard
Configuration dialog.

Resetting the shortcut keys

To reset all of the keyboard shortcuts to their default values, click the Reset button on the
Customize dialog. Use this feature with care; no confirmation dialog will be displayed.

Assighing macros to events

In LibreOffice, when something happens, we say that an event occurred. For example, a
document is opened, a key is pressed, or the mouse moved. You can associate a macro with an
event, so the macro is run when the event occurs. For example, a common use is to assign the
“open document” event to run a macro that performs certain setup tasks for the document.

To associate a macro with an event, use the Events tab of the Customize dialog. For more
information, see Chapter 13, Getting Started with Macros, in the Getting Started Guide.

Adding functionality with extensions

An extension is a package that can be installed into LibreOffice to add new functionality.
Template sets, spelling dictionaries, clipart galleries, macros, and dialog libraries can be
packaged as LibreOffice extensions. They can add new top-level menus, submenus or toolbar
icons. Extensions may also have their own settings, available from the extension manager.

Several extensions are shipped bundled with LibreOffice and are installed with the program.
These can only be removed by changing the installation options. Others can be downloaded from
various websites. The official extension repository is located at http://extensions.libreoffice.org/.
These extensions are free of charge.

Some extensions from other sources are free of charge; others are available for a fee. Check the
descriptions to see what licenses and fees apply to the ones that interest you.

Download the extension to your computer in any folder that you want (usually folder Download).

Installing extensions
To install an extension that is listed in the repository, follow these steps:

1) In LibreOffice, select Tools > Extension Manager on the Menu bar.
2) In the Extension Manager dialog (Figure 27), click Get more extensions online.
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3) Abrowser window opens. Find and select the extension you want to install and click
Open.

4) Users with administrator or root privileges will see a dialog where they can choose to
install extensions "for all users" (shared) or "only for me" (user). Users without those
privileges can install, remove, or modify extensions only for their own use.

5) The extension begins installing. You may be asked to accept a license agreement.
6) When the installation is complete, the extension is listed in the Extension Manager dialog.
To install an extension that is not listed in the repository, download the extension, then continue
with step 3 above.
Display Extensions
Bundled with LibreOfficeDev Installed for all users Installed for current user

R Complex Toolbar Controls Demo 0.0.1
" o

| English spelling, hyphenation dictiona... 2020.11.01 Marco A.G.Pinto =g
English dictionaries for OpenOffice/LibreOffice 4.0+. It includes: - en_AU (Aus...

Check for Updates Add

Get more extensions online...

Help Close

Figure 27: Using the Extension Manager

Removing and disabling extensions

To remove (uninstall) an extension that you installed, select the extension in the main window of
the Extension Manager dialog and click the Remove button.

To disable an extension without removing (uninstalling) it, select the extension in the main
window of the Extension Manager dialog and click the Disable button, which then changes to
Enable.

Adding fonts

LibreOffice supports PostScript (.pfb), TrueType (.ttf), and OpenType (.otf) font file formats. Other
font formats exist, and may be supported by your operating system, but these formats may be
limited in selection and quality.

If you have administration privileges, you can install additional fonts through your operating
system; they will then be available for use by LibreOffice and will appear in Writer’s font lists.
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Finding free-licensed fonts

In addition to proprietary fonts from sources like Adobe, hundreds of free-licensed fonts are
available. You can use, share, and edit free-licensed fonts as you please. Most are available at
no cost. Many are clones or near-variations of classic fonts, but some are original fonts.

Many Linux distributions include a few free-licensed fonts in their package repositories. Other
places where you can find free-licensed fonts include The League of Moveable Type
(https://lwww.theleagueofmoveabletype.com/) and the Font Library (https://fontlibrary.org/).

Adding custom colors

To add custom colors to a color palette, for example to exactly match a corporate color scheme,
follow this procedure:

1) Insert any drawing object, such as a square, into any document.
2) Right-click on the object and choose Area on the context menu.

3) Go to the Color tab (Figure 28). Under Colors > Palette, choose which palette you wish
to add the new color to. Under New, define the new color using RGB or Hex notation, or
click the Pick button to select the color on the Pick a Color dialog (Figure 29).

Area Shadow Transparency

None Color Gradient Bitmap Pattern Hatch
Colors Active New
AEEEEEEEE
H R | 114 R 114 -+
EEEN
.....lg‘.. G | 159 G 159 -+
AEEEEEEEEN
EEEEEEEEEEN B 207 B 207 - +
EENEEEEENEEE
Recent Colors Pick ¢
|
Custom Palette Please enter a name for the new color:
Add Delete Color 2
Help Cancel OK
Help Reset Cancel OK

Figure 28: Defining a new color

4) Click Add in the lower left corner, enter a name for the new color in the pop-up dialog,
and click OK to save.

5) Delete the drawing object from the document, if it is not needed.
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RGB

Red: 5 -+
Green: 163 -+
Blue: 70 -+
Hex #: 05a346
HSB
© Hue: 145° -+
Saturation:  97% -+
Brightness:  64% -+
CMYK
Cyan: 97% -+
Magenta: 0% +
Yellow: 57% -+
Key: 36% -+
Help Cancel OK

Figure 29: Defining a color by picking it from a color chart

Using experimental features

On the Tools > Options > LibreOffice > Advanced dialog, in the Optional Features section near
the bottom, is Enable experimental features (may be unstable). Experimental features may
not yet be complete or may contain known bugs. These features may be different in each version
of LibreOffice.

Optional Features
Enable experimental features (may be unstable)

Enable macro recording (may be limited)

Figure 30: Bottom section of Tools > Options > LibreOffice > Advanced dialog

Some experimental features that may be of interest to users of Writer are:

* On the Sidebar, two additional decks are available: Manage Changes and Design. These
decks are not covered in this book.

» Outline folding mode: An extra option (Show outline content visibility button) is available
in Tools > Options > LibreOffice Writer > View. When this option is selected, a button
with an arrow is visible near any selected heading in your document. Click on it to fold all
text from the current heading to next heading. Right-click on it to fold all text from current
heading to next the same level heading with all its subheadings.
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