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Starting LibreOffice

In general, you start LibreOffice the same way you start any other program on your computer.

On Windows and Linux, entries for LibreOffice and each of its components appear in the system 
menu of your computer. On macOS, only an entry for LibreOffice is added to the Applications 
menu. You can make a desktop icon for LibreOffice or a component in the same way you can 
make a desktop icon for any other program; see your operating system’s help for how to do this.

Clicking on the LibreOffice menu entry, desktop icon, or tile opens the LibreOffice Start Center 
(Figure 1) from where you can select the individual components of LibreOffice. You can also 
open an existing file, use a template, or access Help and extensions. The thumbnails in the Start 
Center include an icon showing the type of file (text, spreadsheet, drawing, presentation).

Figure 1: LibreOffice Start Center

You can also start LibreOffice by double-clicking the filename of an ODF document on the 
desktop, or in a file manager such as Windows Explorer or macOS Finder. The appropriate 
component of LibreOffice will start and the document will be loaded.

For information on opening files, see “Opening existing documents” on page 13.

Closing LibreOffice
To close LibreOffice completely, go to File > Exit LibreOffice on the Menu bar in Windows and 
Linux. In macOS, go to LibreOffice > Quit LibreOffice on the Menu bar.

In Windows and Linux, when you close the last document using the X on the title bar of the 
window, then LibreOffice will close completely. In macOS, you need to use LibreOffice > Quit 
LibreOffice.

You can also use a keyboard shortcut:

• In Windows and Linux – Ctrl+Q
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• In macOS – +Q⌘

If any documents have not been saved since the last change, a message box is displayed. 
Choose whether to save or discard your changes.

Parts of the main window

The main window is similar for each component of LibreOffice, although some details vary. See 
the relevant chapters in this guide about Writer, Calc, Draw, Impress, Base, and Math for 
descriptions of those details.

Common features include the Title bar, Menu bar, Standard toolbar, and Formatting toolbar 
(Writer and Calc only) at the top of the window and the Status bar at the bottom.

Note

By default, LibreOffice’s commands are grouped in menus and toolbars, as 
described in this section. You can choose other user interface variants, displaying
contextual groups of commands and contents (View > User Interface) For more 
information, see Chapter 13, Customizing LibreOffice.

Title bar
The Title bar is located at the top of the LibreOffice window. It shows the file name of the current 
document. When the document is not yet named, the document name will appear as Untitled X, 
where X is a number. Untitled documents are numbered in the order in which they are created.

Menu bar
The Menu bar is located just below the Title bar in Windows and Linux and at the top of the 
screen in macOS. When you select one of the menus, a submenu drops down to show further 
options, including:

• Commands that directly cause an action, such as Close or Save in the File menu.

• Commands that open dialogs. These are indicated by three dots following a command, 
such as Find and Replace... in the Edit menu.

• Commands that open further submenus. These are indicated by a right-pointing arrow 
following a command, such as Toolbars and Zoom, in the View menu. Moving the 
mouse pointer onto one of these items causes its submenu to open.

As an example, the default Menu bar for Writer contains the following:

• File – commands that apply to the entire document such as Open, Save, and Print.

• Edit – commands for editing the document such as Undo, Find and Replace, Cut, 
Copy, Paste, and Track Changes.

• View – commands for controlling the display of the document such as User Interface, 
Toolbars, Text Boundaries, Rulers, and Zoom.

• Insert – commands for inserting elements into your document such as Image, 
Comment, Header and Footer, and Table of Contents and Index.

• Format – commands for formatting the layout of your document.

• Styles – commands for quickly applying common styles; for editing, loading, and creating
styles; and for managing styles.

• Table – commands to insert and edit a table in a text document.
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• Form – commands to create fill-in forms.

• Tools – functions such as Spelling, AutoCorrect, Customize, and Options.

• Window – commands for the display window.

• Help – links to the LibreOffice Help, What’s This?, and information about the program.

Toolbars
LibreOffice has two types of toolbars: docked (fixed in place) and floating. Docked toolbars can 
be moved to different locations or made to float, and floating toolbars can be docked.

In a default LibreOffice installation, the top docked toolbar, just under the Menu bar, is called the 
Standard toolbar. It is consistent across the LibreOffice applications.

The second toolbar at the top for Writer and Calc, in a default LibreOffice installation, is the 
Formatting toolbar. It is context-sensitive; that is, it shows the tools relevant to the current 
position of the cursor or the object selected. For example, when the cursor is on a graphic, the 
Formatting toolbar provides tools for formatting graphics; when the cursor is in text, the tools are 
for formatting text.

In some cases it is convenient to reduce the number of toolbars displayed and get more space 
for the document. LibreOffice provides a single-toolbar alternative to the default double-toolbar 
setup. It contains the most-used commands. To activate it, enable View > User Interface > 
Single Toolbar.

Displaying or hiding toolbars
To display or hide toolbars in a standard setup, go to View > Toolbars on the Menu bar, then 
click on the name of a toolbar in the submenu. An active toolbar shows a check mark beside its 
name. Toolbars created from tool palettes are not listed in the View menu.

To close a toolbar, go to View > Toolbars on the Menu bar and deselect the toolbar, or right-click
in an empty space between the icons on a toolbar and select Close Toolbar in the context menu.

Sub-menus and tool palettes
Toolbar icons with a small triangle to the right will display sub-menus, tool palettes, and 
alternative methods of selecting items, depending on the icon.

A tool palette is a pop-up collection of tools attached to a single tool in a toolbar. Tool palettes can
be made into floating toolbars. Figure 2 shows an example of a tool palette from the Drawing 
toolbar made into a floating toolbar. Once removed from the parent toolbar, the palette displays a 
Title bar. Floating tool palettes can be left floating or docked along an edge of the screen or in 
one of the existing toolbar areas. See “Moving toolbars” and “Floating toolbars” below for more 
information.

  

Figure 2: Example of tearing off a tool palette: click on 
the dots and drag to form a floating toolbar
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Tip

If you cannot see the dots at the top of the tool palette, you need to unlock the 
toolbar before you can float the palette. See “Locking and unlocking toolbars”
below.

Locking and unlocking toolbars
You can lock all toolbars, or individual toolbars, into place so they cannot be moved. When all 
toolbars are locked, you cannot unlock individual ones.

To lock all toolbars in place, go to View > Toolbars on the Menu bar and select Lock Toolbars 
at the bottom of the submenu. You will need to restart LibreOffice for this change to take effect. 
To unlock all toolbars, click on Lock Toolbars again.

To lock an individual toolbar into place, be sure Lock Toolbars is not selected on View > Toolbars,
then right-click on the toolbar and select Lock Toolbar Position on the context menu.

Moving toolbars
Docked toolbars are not locked in place. They are indicated by dotted handles on the left end 
(Figure 3). Docked toolbars can be undocked and moved to a new docked position or left as a 
floating toolbar.

1) Move the mouse pointer over the toolbar handle, which is the small vertical bar of dots to 
the left of a docked toolbar, highlighted in Figure 3.

2) Hold down the left mouse button and drag the toolbar to the new location.

3) Release the mouse button.

To move a floating toolbar, click on its title bar and drag it to a new floating location or dock the 
toolbar at the top or bottom of the main window.

Figure 3: Toolbar handles

Floating toolbars
LibreOffice includes several additional toolbars, whose default settings have them appear as 
floating toolbars in response to the current position of the cursor or selection. You can dock these
toolbars to the top or bottom of the main window, or reposition them on your computer display 
(see “Moving toolbars” above).

Some of these additional toolbars are context sensitive and will automatically appear depending 
on the position of the cursor. For example, when the cursor is in a table, a Table toolbar appears, 
and when the cursor is in a numbered or bullet list, the Bullets and Numbering toolbar appears.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and 
locking the position of a docked toolbar. You can also add icons and create new toolbars, as 
described in Chapter 13, Customizing LibreOffice. To access the customization options for a 
toolbar, right-click in an empty space between the icons on a toolbar to open a context menu.
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• To show or hide icons defined for the selected toolbar, point to Visible Buttons (in the 
context menu). Visible icons on a toolbar are indicated by an outline around the icon 
(Figure 4) or by a check mark beside the icon, depending on your operating system. 
Select or deselect icons to hide or show them on the toolbar.

• Click Customize Toolbar to open the Customize dialog; See Chapter 13, Customizing 
LibreOffice, for more information.

• Click Dock Toolbar to dock the selected floating toolbar. You can reposition the toolbar to
a different docked position.

• Click Dock All Toolbars to dock all floating toolbars. You can reposition the toolbars to 
different docked positions.

• Click Lock Toolbar Position to lock a docked toolbar into its docked position.

• Click Close Toolbar to close the selected toolbar.

Figure 4: Toolbar context menu and selection of visible toolbar icons:
1) Right-click anywhere on the toolbar; 2) Point to Visible Buttons; 
3) Visible icons are marked.
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Context menus
Context menus provide quick access to many menu functions. They are opened by right-clicking 
on a paragraph, graphic, or other object. When a context menu opens, the functions or options 
available will depend on the object that has been selected. A context menu can be the easiest 
way to reach a function, especially if you are not sure where the function is located in the menus 
or toolbars. Context menus may display an applicable keyboard shortcut if one has been set; you
can toggle this visibility off or on in Tools > Options > LibreOffice > View > Visibility.

Status bar
The Status bar is located at the bottom of the workspace. It provides information about the 
document and convenient ways to change some features quickly. It is similar in Writer, Calc, 
Impress, and Draw, but each LibreOffice component includes some component-specific items. An
example of the Writer Status bar is shown in Figures 5 and 6.

Figure 5: Writer Status bar, left end

Figure 6: Writer Status bar, right end

Document changes status
This icon changes color to indicate whether the document has no unsaved changes or it 
has been modified but not been saved. In other components of LibreOffice, this icon is 
located to the right of Selection Mode. Click this icon to save the document.

Page, sheet, or slide number and page count
Shows the current page, sheet, or slide number and the total number of pages, sheets, or
slides in the document. Click on this field to open the Go to Page dialog. Other uses of 
this field depend on the LibreOffice component.

Word & character count
Shows the total number of words and characters in the document or in the selection.

Page style or slide design
Shows the current page style or slide design. To edit the current page style or slide 
design, double-click on this field. To choose a different page style or slide design, right-
click on this field and select from the list that pops up.

Language
Shows the current language of the text at the current cursor position.

Insert mode
Shows the type of insert mode the program is in. Each time the Ins key is pressed, or this 
field is clicked, the mode toggles between Insert and Overwrite. When Track Changes is 
on, Overwrite mode is inactivated.

Selection mode
Click to choose different selection modes. The icon does not change, but when you hover 
the mouse pointer over this field, a tooltip indicates which mode is active.
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Digital signature
If the document has been digitally signed, an icon shows here. You can click the icon to 
sign the document, or to view the existing certificate.

Object information
Displays information relevant to the position of the cursor or the selected element of the 
document.

View layout
Select between Single-page view, Multiple-page view, and Book view to change how your
document is displayed.

Zoom slider
Drag the Zoom slider, or click on the + and – signs to change the view magnification of 
your document.

Zoom percentage
Indicates the magnification level of the document. Right-click on the percentage figure to 
open a list of magnification values from which to choose. Clicking on this percentage 
figure opens the Zoom & View Layout dialog.

Sidebar
The Sidebar (Figure 7) is normally open by default on the right side of the workspace in Writer, 
Calc, Impress, and Draw. Select View > Sidebar on the Menu bar to display or hide it. It contains
one or more decks, based on the current document context. Decks are organized into panels. A 
tab bar on the right side of the sidebar allows you to switch between different decks.

All four components contain the Properties, Styles, Gallery, and Navigator decks. Some 
components have additional decks, such as Page and Style Inspector for Writer; Master Slides, 
Animation, Shapes, and Slide Transition for Impress; Shapes for Draw; and Functions for Calc.

Toolbars and Sidebar panels share many functions. For example, the buttons for making text 
bold or italic exist in both the Formatting toolbar and the Properties panel. Some panels contain a
More Options button, which opens a dialog with additional editing controls.

For more detail, see the Sidebar explanation in the relevant LibreOffice component’s user guide.

To hide the Sidebar, click on the gray Hide button on the left. Click on the same button to show 
the Sidebar again.

To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the choices on 
the Sidebar Settings drop-down list at the top of the tab bar.
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Figure 7: Properties panel of the Sidebar in Writer

Working with documents

Starting new documents
You can start a new, blank document in LibreOffice in several ways.

• When LibreOffice is running but no document is open, the Start Center (Figure 1 on page
5) is shown. Click one of the icons to open a new document of that type, or click the 
Templates icon to start a new document using a template.

• Use File > New on the Menu bar and select the type of document in the sub menu.

• Use the keyboard shortcut Ctrl+N to create a new document. The type of document 
created depends on which LibreOffice component is open and active. For example, if 
Calc is open and active, a new spreadsheet is created.

• Use File > Wizards on the Menu bar and select the type of document in the context 
menu.

• If a document is already open in LibreOffice, click the New icon on the Standard toolbar 
and a new document of the type shown on the icon is created in a new window. The New
icon changes depending on which component of LibreOffice was last created.

• If a document is already open in LibreOffice, click on the small triangle to the right of the 
New icon on the Standard toolbar and select the type of document in the context menu.

Note

If all documents are closed without exiting from LibreOffice, then the Start Center 
will be displayed.
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Opening existing documents
You can open an existing document in several ways.

When no document is open:

• Click Open File in the Start Center.

• Go to File > Open on the Menu bar.

• Use the keyboard shortcut Ctrl+O.

• Click on a thumbnail in the list of recently opened documents displayed in the Start 
Center. You can scroll up or down in the Start Center to locate a recently opened 
document.

Note

Renamed or relocated documents can still be listed in the Start Center. Selecting 
one gives an error message that the file does not exist. To remove the thumbnail 
from the Start Center, hover the mouse pointer over the thumbnail until an X 
appears in the upper right corner, and then click on the X.

If a document is already open:

• Click the Open icon on the Standard toolbar.

• Click the small triangle to the right of the Open icon and select from a list of recently 
opened documents.

• Use File > Recent Documents to make a selection from the submenu.

When using the Open dialog, navigate to the folder you want, select the file, and then click Open.
If a document is already open in LibreOffice, the second document opens in a new window.

In the Open dialog, you can reduce the list of files by selecting the type of file you are looking for. 
For example, if you choose Text documents as the file type, you will only see documents Writer 
can open (including .odt, .doc, .txt); if you choose Spreadsheets, you will see .ods, .xls, and other
files that Calc opens.

Note

To work with files on remote servers, see Chapter 10, Working with File Formats, 
Security, and Exporting.

Opening files not in an OpenDocument format
You can also open an existing document that is in a format that LibreOffice recognizes by double-
clicking on the file icon on the desktop or in a file manager such as Windows Explorer or macOS 
Finder. LibreOffice may need to be associated with file types that are not ODF files for the 
appropriate LibreOffice component to open.

For example, on a Windows computer, if you do not have Microsoft Office installed or if Microsoft 
Office is installed but you have associated Microsoft Office file types with LibreOffice, then when 
you double-click on the following files, they open in LibreOffice:

• A Word file (*.doc or *.docx) opens in Writer.

• An Excel file (*.xls or *.xlsx) opens in Calc.

• A PowerPoint file (*.ppt or *.pptx) opens in Impress.
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If you did not associate the file types with LibreOffice, and Microsoft Office is installed on your 
computer, then when you double-click on a Microsoft Office file, it opens using the appropriate 
Microsoft Office component.

On macOS, if Microsoft Office is not installed and you have not associated those file types with 
LibreOffice, the files may open in Apple’s Pages, Numbers, or Keynote applications.

See Chapter 10, Working with File Formats, Security and Exporting, for more about working with 
different file types.

Saving documents
You can save documents as follows:

• Save – use if you are keeping the document, its current filename and location.

• Save As – use to create a new document, or change the filename and/or file format, or 
save the file in a different location on your computer.

• Save a Copy – use to save a copy of your current document and keep it open for more 
editing.

• Save All – use to save all the files open in your current session.

Save command
To save a document if you are keeping the document’s current filename and location, do one of 
the following:

• Use the menu option File > Save.

• Use the keyboard shortcut Ctrl+S.

• Click the Save icon on the Standard toolbar.

• Use the menu option File > Save All.

• Use the menu option File > Save a Copy (similar to the Save As command).

Using the Save command will immediately overwrite the last saved version of the file.

Save As command
If you want to create a new document file, change the filename and/or file format, or save the file 
in a different location on your computer:

• Use the keyboard shortcut Ctrl+Shift+S.

• Use the menu option File > Save As.

• Click the arrow to the right of the Save icon and select Save As from the context menu.

When the Save As dialog or Save dialog opens, enter the file name, change the file type (if 
applicable; for example, to a Microsoft Office format), navigate to a new location (if applicable), 
and click Save.

Saving documents automatically
LibreOffice can save files automatically as part of the AutoRecovery feature. Automatic saving, 
like manual saving, overwrites the last saved state of the file.

To set up automatic file saving:

1) Go to Tools > Options > Load/Save > General on the Menu bar.

2) Select Save AutoRecovery information every and set the time interval.
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3) Click OK.

Using the Navigator
The Navigator lists objects contained in a document, collected into categories. For example, in 
Writer it shows Headings, Tables, Frames, Comments, Images, Bookmarks, and other items, as 
shown in Figure 8. In Calc it shows Sheets, Range names, Database ranges, Images, Drawing 
objects, and other items. In Impress and Draw it shows Slides, Pages, and other items.

In a default installation of LibreOffice, the Navigator is a Sidebar deck. If necessary, press the F5 
key, or go to View > Navigator on the Menu bar, or click the Navigator icon on the Sidebar, to 
open it.

Figure 8: Navigator in Writer

Click the marker (+ or triangle) by any of the categories to display the list of objects in that 
category.

The Navigator provides several convenient ways to move around a document and find items in it:

• When a category is showing the list of objects in it, double-click on an object to jump 
directly to that object’s location in the document.

• Objects are much easier to find if you have given them recognizable names when 
creating them, instead of keeping the default names such as Sheet1, Table1, or Table2. 
The default names may not correspond to the actual position of the object in the 
document.

• Navigator also provides the facility to move, promote, demote items within a document.

• Each Navigator in the individual LibreOffice components has a different range of 
functions. These functions are further explained in the user guide for each LibreOffice 
component.

Displaying multiple view of a document
You can open, view, and edit several views of the same document in LibreOffice at the same 
time. These views are displayed in windows that can display different pages or use different 
zoom levels or other settings. A change to the document in one window is immediately reflected 
in the other windows. In Writer, for example, you might find this useful for copying or moving 
information from one page to another.
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To open a new window showing the document, go to Window > New Window on the Menu bar. 
In each window opened, the filename in the title bar is automatically numbered as shown by the 
example in Figure 9. If other LibreOffice documents are open at the same time, the list of 
windows also includes them. The active window has a marker by its filename in the list. You can 
switch between windows by clicking on a name in the list, or by clicking on the window itself if it is
visible on the display.

To close a window, go to Window > Close Window on the Menu bar, or use the keyboard 
shortcut Ctrl+W, or click the Close icon on the Menu bar or Title bar of the window.

Figure 9: List of open windows

Undoing and redoing changes
To undo the most recent unsaved change in a document, use the keyboard shortcut Ctrl+Z, or 
click the Undo icon on the Standard toolbar, or go to Edit > Undo on the Menu bar. Click the 
small triangle to the right of the Undo icon to get a list of all the changes that can be undone. You
can select multiple changes and undo them at the same time.

After changes have been undone, you can redo changes. To redo a change use the keyboard 
shortcut Ctrl+Y, or click the Redo icon, or go to Edit > Redo on the Menu bar. As with Undo, 
click on the triangle to the right of the Redo icon to get a list of the changes that can be 
reapplied.

To repeat the last command applied to your document, use the shortcut Ctrl+Shift+Y or go to 
Edit > Repeat on the Menu bar. This can save several repetitive menu navigation clicks or 
keyboard shortcuts, especially when the command is taken from a secondary menu.

Reloading a document
Reloading is useful in two situations.

• You may want to discard all the changes made in an editing session after the last 
document save.

• You may have made some formatting changes that do not show until the document has 
been closed and reopened; reloading has the same result.

To reload a document, go to File > Reload on the Menu bar. If you have made changes to a file 
since the last save, a confirmation dialog will warn you that reloading will discard your last 
changes. Choose whether to save or discard the changes.

On reloading the document, the File dialog does not open, because the file is already selected.

Closing a document
If only one document is open and you want to close that document, go to File > Close on the 
Menu bar or click on the X on the right or left end of the Menu bar. On Windows and Linux, the 
document closes and the LibreOffice Start Center opens. On macOS, the document closes and 
only the Menu bar remains at the top of the screen.
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If more than one document is open and you want to close one of them, go to File > Close on the 
Menu bar or click on the X on the right or left end of the title bar of that document’s window.

If the document has not been saved since the last change, a message box is displayed. Choose 
whether to save or discard your changes.

Printing

Quick printing
If the Print Directly icon is visible on the Standard toolbar, you can click it to print the entire 
document using the current default print settings. If the icon is not visible, you can make it visible 
it by right-clicking on the toolbar, pointing to Visible Buttons, and selecting Print Directly.

Note

The Print Directly and other printing options are not available when viewing a 
Base table or query.

Printer settings
To specify the default printer, go to File > Printer Settings on the Menu bar. The Printer Setup 
dialog opens. For further printing options, click the Options button on the Printer Setup dialog to 
access them. The same default options are available through Tools > Options > [LibreOffice 
Component] > Print, and more general print options through Tools > Options > LibreOffice > 
Print. See Chapter 12, Configuring LibreOffice, for more information.

Controlling printing
For more control over printing, use the Print dialog (File > Print, Ctrl+P ( +P⌘  for macOS), or 
the Print icon on the Standard toolbar).

Note

Unlike most dialogs in LibreOffice, the Print dialog is different on macOS and may
include extra printer controls not described in this chapter.

In Windows and Linux, the Print dialog (Figure 10) has two tabs, from which you can choose a 
range of options as described in the following sections. The first tab is General; it is similar in all 
LibreOffice, although some of the options available in Writer are unavailable in other 
components. The second tab is component-specific.

The components of LibreOffice have different print settings, as summarized in Table 1.

Table 1: Print options in LibreOffice components

Feature Writer Calc Impress Draw Math

Select pages/sheets/slides to print Yes Yes Yes Yes Yes

Print multiple pages/sheets/slides on one 
page

Yes Yes Yes Yes No

Print a brochure Yes No Yes Yes No

Print envelopes Yes No No No No

Print labels or business cards Yes No No No No

Preview pages/sheets before printing Yes Yes No No No
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Base forms and reports are printed using the Writer version of the Print dialog and hence provide
the facilities in the Writer column of Table 1.

Figure 10: The Print dialog in Writer (Windows and Linux)

Selecting general printing options
On the General tab of the Print dialog, you can choose:

• The printer, from the list of available printers

• Which pages to print, the number of copies to print, and whether to collate multiple 
copies (Range and Copies section; “Selecting pages/sheets/slides to print” on page 19)

• Paper size and print orientation (Page Layout section)

• How many pages to print on one sheet of paper and whether to draw a border around 
each page (Page Layout section)

• Whether to print a brochure (“Printing a brochure” on page 24)

• Whether to print in reverse page order (useful on some printers to make the pages come 
out in page order)

Selecting printer and print job options
In the Printer section of the General tab, click the Properties button to display the selected 
printer’s properties dialog where you can choose portrait or landscape orientation, which paper 
tray to use, and the paper size to print on.
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Click the More button at the bottom of the Range and Copies section of the General tab to 
choose whether to create separate print jobs for collated output, instead of one print job 
containing all the collated pages (not relevant if only one copy of a document is printed).

Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this, in the Page Layout
section of the General tab, click More and select in the Pages per sheet drop-down list the 
number of pages to print per sheet of paper. The preview panel on the left of the Print dialog 
shows how the printed document will look. This facility is not available in Math.

When printing more than two pages per sheet, you can choose the order in which they are 
printed across and down the paper (Figure 11).

Tip

In Writer, to print two pages per sheet in “facing pages” (book layout) style, print 
from Print Preview instead. See “Writer” on page 26.

Figure 11: Print order choices

Selecting pages/sheets/slides to print
In addition to printing a full document, in the Range and Copies section of the General tab, you 
can choose to print individual pages/sheets/slides, ranges of pages/sheets/slides, or a selection 
of a document. The details vary slightly between Writer, Calc, Draw, Impress, and Math, as 
described below.

Writer and Math

Printing an individual page:

1) In the Print dialog, in the Range and Copies section, select the Pages option. The text 
box shows the current page number.

2) Enter the page number of the page you want to print. The preview box on the left changes
to show the selected page.

Printing a range of pages:

1) In the Print dialog, in the Range and Copies section, select the Pages option.

2) Enter the page numbers of the pages to print (for example, 1–4 or 1,3,7,11 or a 
combination).

Printing a selection of text or graphics (Writer only):

1) In the document, select the material to print, then open the Print dialog.
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2) In the Range and Copies section of the Print dialog, the Selection option is now active 
and selected and the preview box shows the selected material (Figure 12).

Figure 12: Printing a selection of text

Calc

You can choose individual sheets, ranges of sheets, or selections of sheets for printing.

Figure 13: Choosing what to print in Calc

Printing an individual sheet:

1) In the spreadsheet, click on the sheet tab to select the sheet you want to print.

2) Open the Print dialog and choose the General tab.

3) In the Range and Copies section, click More and choose Print Selected Sheets in the 
From which drop-down.

Printing a range of sheets:

1) In the spreadsheet, select the sheets to print.

a) Select the first sheet.

b) Hold down the Control key and click on the additional sheet tabs.
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c) Release the Control key when all required sheets are selected.

2) Open the Print dialog and choose the General tab.

3) In the Range and Copies section, click More and choose Print Selected Sheets in the 
From which drop-down.

Caution

After printing, be sure to deselect the extra sheets. If you keep them selected, the
next time you enter data on one sheet, you enter data on all the selected sheets. 
This might not be what you want.

Printing a selection of cells:

1) In the document, select the cells to print.

2) Open the Print dialog and choose the General tab.

3) In the Ranges and Copies section, click More and choose Print Selected Cells in the 
From which drop-down.

Impress and Draw

You can choose individual slides, ranges of slides, or selections of slides for printing.

To print an individual slide or a range of slides, do one of the following:

• In the Print dialog, select the Slides option in the Range and Copies section (Figure 14) 
and then enter the numbers of the slides to print (for example, 1-4 or 1,3,7,11 or a 
combination).

• Select the slides first and then open the Print dialog, which will show the slide numbers in
the box. See Chapter 6, Getting Started with Impress, for information on selecting slides.

Figure 14: Choosing what to print in Impress and Draw

To print a selection from a slide, or a selection from multiple slides:

1) In the document, select the section of the slide to print.

2) Open the Print dialog.

3) Choose the Selection option in the Range and Copies section.

You can also choose to print only even-numbered slides or only odd-numbered slides.

Choices on the component tabs
Choices on the LibreOffice [Component] tab vary with the component.

Writer

On the LibreOffice Writer tab (Figure 15) you can choose to print a subset of contents (for 
example, images or hidden text), print text in black (even if a color is defined for the text), 
whether to print automatically inserted blank pages, and whether and where to print any 
comments that are in the document (Figure 16).
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Figure 15: LibreOffice Writer tab of Print dialog

Some selections may not be available all the time. For example, if the document contains no 
comments, the Comments drop-down list is disabled.

Figure 16: Choosing whether and where to print comments

Calc

The only choice on the LibreOffice Calc tab is whether to suppress the printing of empty pages.

Impress

On the LibreOffice Impress tab (Figure 17), you can choose to print slides, handouts, notes, or an
outline. See Chapter 6, Getting Started with Impress, for more information on these features.

• Handouts prints the slides in reduced size on the page, from one to nine slides per page.
The slides can be printed horizontally (landscape orientation) or vertically (portrait 
orientation) on the page.

• Notes prints a single slide per page with any notes entered for that slide in Notes View.

• Outline prints the title and headings of each slide in outline format.
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Figure 17: LibreOffice Impress tab of Print dialog

To print slides, handouts, notes, or outlines:

1) In the Document section, select the required option under Type.

2) For Handouts, you can then choose how many slides to print per page, and the order in 
which they are printed (Figure 18).

Figure 18: Handouts
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Draw

On the LibreOffice Draw tab (Figure 19), you can choose print options as shown.

Figure 19: LibreOffice Draw tab of Print dialog

Math

On the LibreOffice Math tab (Figure 20), you can choose print options as shown.

Figure 20 - LibreOffice Math tab of Print dialog

Printing a brochure
In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of
paper, arranged so that when the printed pages are folded in half, the pages are in the correct 
order to form a booklet or brochure.

Tip

Plan your document so it will look good when printed half size; choose 
appropriate margins, font sizes, and so on. You may need to experiment.
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To print a brochure:

1) In the Page Layout section of the General tab, click more and select the Brochure 
option. The preview on the left changes to show the sequence in which the pages will be 
printed (Figure 21).

Figure 21: Settings for printing a brochure on a simplex printer

2) If you have Asian or CTL selected in your language settings (Tools > Options > 
Language Settings > Languages), the Writer variant of the Print dialog may include a 
drop-down menu adjacent to the Brochure button (not shown in Figure 21). This provides
Left-to-right script and Right-to-left script options. Select the required setting.

3) If your printer can print double-sided (duplex) pages automatically, choose All pages in 
the Range and Copies section, then click OK to print.

4) If your printer can print only single-sided pages automatically, follow these steps:

a) Select Even pages in the Range and Copies section, then click OK to print.

b) Take the printed pages out of the printer and put them back in the correct orientation to
print on the blank side. You may need to experiment to find the correct arrangement 
for your printer.
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c) On the Print dialog, in the Range and Copies section, select Odd pages. Click OK.

Printing envelopes, labels, business cards
Printing envelopes, labels, or business cards using Writer involves two steps: setup and printing. 
For details, see Chapter 14, Mail Merge, in the Writer Guide.

Previewing pages/sheets before printing
You can use the previewing options in Writer and Calc to view the document as it will be printed. 
Several viewing options are available.

Writer
The normal page view in Writer shows you what each page will look like when printed and you 
can edit the pages in that view. If you are designing a document to be printed double-sided, you 
may want to see what facing pages look like. Writer provides two ways to do this:

• View Layout (editable view): use the Book view button on the status bar.

• Print Preview (read-only view).

To use Print Preview:

1) Choose File > Print Preview on the Menu bar, or click the Toggle Print Preview button 
on the Standard toolbar, or press Ctrl+Shift+O (Shift+ +O⌘  for macOS).

Writer now displays the Print Preview toolbar instead of the Formatting toolbar.

Figure 22: Print Preview toolbar (Writer)

2) Select the required preview icon: Single Page Preview, Two Pages Preview,  Book 
Preview, or Multiple Pages Preview.

3) To print the document from this view, click the Print icon to open the Print dialog. Choose 
the print options and click OK or Print (macOS).

Calc
To preview the sheets in Calc before printing:

1) Choose File > Print Preview on the Menu bar, or click the Toggle Print Preview button 
on the Standard toolbar, or press Ctrl+Shift+O (Shift+ +O⌘  for macOS).

The Calc window now displays the Print Preview toolbar instead of the Formatting toolbar.

Figure 23: Print Preview toolbar (Calc)

2) To print the document from this view, click the Print icon to open the Print dialog.
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Printing in black and white (on a color printer)
You may wish to print documents in black and white on a color printer. Several choices are 
available.

Note

Some color printers may print in color regardless of the settings you choose.

For one document, change the printer settings to print in black and white or grayscale:

1) On the Print dialog, click Properties to open the Properties dialog for the printer. The 
available choices vary from one printer to another, but you should find options for the 
color settings. See your printer’s help or user manual for more information.

2) The choices for color might include black and white or grayscale. Choose grayscale.

3) Click OK to confirm your choice and return to the Print dialog.

4) Click Print to print the document.

To print all color text and images as grayscale, change the LibreOffice settings:

1) Choose Tools > Options > LibreOffice > Print.

2) Select the Convert colors to grayscale option. Click OK to save the change.

In Writer, to print all color text as black, and all images as grayscale, change the LibreOffice 
Writer settings 

1) Choose Tools > Options > LibreOffice Writer > Print.

2) Under Contents, select the Print text in black option. Click OK to save the change.

Basic LibreOffice Configuration

This section highlights some of the important settings that for LibreOffice. For a fuller discussion 
of LibreOffice Configuration, see Chapter 12, Configuring LibreOffice.

LibreOffice Options
Click Tools > Options. The list in the left-hand box of the Options – LibreOffice dialog varies 
depending on which component of LibreOffice is open. 

Click the expansion symbol (+ or triangle) next to LibreOffice. Select an item in the drop-down 
list to display the relevant page on the right-hand side of the dialog.

Basic LibreOffice Configuration | 27



Figure 24: LibreOffice options

User data

User data settings that are used for several things including, document properties (“created by” 
and “last edited by” information), author name in comments and changes, and the sender 
address in mailing lists.

General

General settings for help tips, use reporting (Linux only), crash reporting (Windows only), and 
including:

• The LibreOffice Quickstarter option that shortens startup time for LibreOffice components 
(not available for Mac OS)

• Default file association options (Windows only)

View

View options affect how the document window looks and behaves.  The options include the ability
to adjust:

• Icon Style and Size

• Visibility of menu icons and Shortcuts

• Mouse behavior – including middle button function

Print

Most printing options here should be self-explanatory. In the Warnings section, you can choose 
whether to be warned if the paper size or orientation specified in your document does not match 
the paper size or orientation available for your printer. 

Paths

Change the location of files associated with LibreOffice. For example, storing documents 
somewhere other than My Documents by default.
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Some items can have at least two paths listed: the User Path is to a user-specific folder (normally
on the user’s personal computer) and the Internal Path is to a shared folder where LibreOffice is 
installed (which might be on a network).

Fonts

Define font substitutions for fonts found missing in documents you open. This does not affect the 
default font for your documents, which are set in the default template – see Chapter 4, Working 
with Styles, Templates, and Hyperlinks.

Security

Set options for saving documents, opening documents that contain macros, and removing 
personal information on saving.

Personalization

Apply a preinstalled color theme.

Application colors

Specify visibility and the colors used to display various user interface and document properties.

Accessibility

Set accessibility options including, whether to allow animated graphics or text, some options for 
high contrast display, and a way to change the font for the LibreOffice user interface.

Advanced

LibreOffice needs Java to run several wizards, and here you will find options to enable Java use 
and select the Java Runtime Engine you are using.

Online update

Choose whether and how often to have the program check the LibreOffice website for program 
updates.

OpenCL

With OpenCL enabled, LibreOffice can perform very fast numerical calculations useful in very 
large spreadsheets with extensive calculations.

Options for Loading and Saving
You can set the options for loading and saving documents to suit the way you work.

Click Tools > Options. Click the expansion symbol (+ or triangle) to the left of Load/Save.

General

Here you can set file loading and saving properties including:

• AutoRecovery save frequency

• Automatic creation of a separate backup copy when saving

• Default file format and document type when saving

VBA properties

Choose whether to keep any macros in Microsoft Office documents that are opened in 
LibreOffice.

Microsoft Office

Decide what to do when importing and exporting Microsoft Office OLE objects (linked or 
embedded objects or documents such as spreadsheets or equations).
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HTML compatibility

Choose how HTML pages are imported into LibreOffice and are exported from LibreOffice. See 
HTML documents; importing/exporting in the Help for more information.

Language Settings
You can change some details of the locale, language, and spell check settings that LibreOffice 
uses.

Click Tools > Options. Click the expansion symbol (+ or triangle) to the left of Language 
Settings. The exact list shown depends on the language support settings.

Languages

Set important language and locale options including:

• User interface language and Locale

• Default currency and decimal separator

• Date acceptance patterns – in addition to locale default patterns

• Document default language (for current or all documents)

Writing Aids

Select which language modules and dictionaries to use, and set key spell check options 
including:

• Checking spelling/grammar as you type

• Spell checking words in upper case or containing numbers

• Inclusion of headers and footers in spell checks

LibreOffice comes with many language modules installed. To add other language modules click 
the Get more dictionaries online link.

English Sentence Checking

Set grammar checking specifics (Figure 25), to identify what grammar issues are reviewed or 
ignored, or converted automatically. Changing some items will require, a restart of LibreOffice or 
reloading of the document, for them to take effect.

Figure 25: Choosing options for checking sentences in English
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Note

LibreOffice can check sentences in many languages. These checkers are 
enabled by default if the language is the computer’s default language, and others 
can be added using the Extension Manager. The set of rules available for these 
sentence checkers depends on the language.

Problem solving using Safe Mode

You can use Safe Mode (Figure 26) to help restore an instance of LibreOffice that has become 
corrupted and stopped working, fails to launch, or crashes in some situations.

To access Safe Mode, do one of the following:

• Choose Help > Restart in Safe Mode on the Menu bar.

• Start LibreOffice from the command line with the --safe-mode option.

• In Windows only, choose LibreOffice (Safe Mode) from the Start Menu.

Figure 26: LibreOffice Safe Mode

The following Safe Mode options get more extreme from the top down, so it is recommended that
you try them successively. 

• Restore from backup – LibreOffice keeps backups of previous configurations and 
activated extensions. Use this option to restore the user configuration, installed 
extensions, or both, to a previous known working state if you suspect that your problems 
were caused by recent changes to either.

• Configure – Use this option to disable all user extensions, hardware acceleration, or 
both. This is a good choice if you are experiencing crashes on startup or visual glitches 
that are often related to hardware acceleration.
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• Extensions – If you suspect that a corrupted extension is blocking or causing LibreOffice
to crash, you can use this option to uninstall all user extensions and reset the state of 
any shared or bundled extensions. In the case of shared or bundled extensions, the 
option will only work if you have the proper system access rights. It should be exercised 
with caution.

• Reset to factory settings – If all of the above fails, you can reset your settings and your 
user interface modifications, or your entire profile, back to factory defaults.

• Reset settings and user interface modifications – this will reset your User Interface 
and configuration changes, but keep things like your personal dictionary, templates, etc.

• Reset entire user profile – this will erase all customized options and return your user 
profile to the factory default state.

• Continue in Safe Mode – Continuing in Safe Mode will allow you to work in LibreOffice, 
using a temporary profile that was created on startup. Any extensions or configuration 
options you had set up previously will have to be reconfigured in order to be used, 
bearing in mind that any changes made to the temporary user profile will be lost after any
restart.

• Restart in Normal Mode – If you arrived in Safe Mode accidentally, this option will 
discard any changes, terminate Safe Mode, and restart LibreOffice normally.

• Apply Changes and Restart – Choose this option to apply any of the above changes 
and restart LibreOffice.

Note

If you are unable to solve your problem using Safe Mode, the Advanced tab 
provides instructions on receiving further aid.

In the Advanced tab you can also create a .zip file of your corrupted user profile 
which can then be uploaded to the bug tracking system where it can be further 
investigated by the developers.

However, be aware that your uploaded user profile may contain sensitive 
information such as installed extensions, personal dictionaries, and settings.
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