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Introduction

Earlier chapters of the Draw Guide have dealt only with vector graphics. However, Draw also 
contains a number of functions for handling raster graphics (bitmaps) such as photographs and 
scanned pictures, including import, export, and conversion from one format to another.

Draw can read all the majority of graphic file formats. It has a subset of capabilities similar to raster 
graphics programs like Adobe Photoshop or Gimp.

Importing graphics

Inserting
To import graphic files into your drawing, go to Insert > Picture > From File on the main menu bar 

or click the From File icon  on the Drawing toolbar to open the Insert Picture dialog (Figure 1).

Draw contains import filters for the majority of graphic formats. If the file you want to import has a 
graphic format not covered by the import filters, then it is recommended to use one of the many 
graphic conversion programs that are freely to convert the file into a format that Draw recognizes.

If you select the Preview option in the Insert picture dialog, a preview of the file is shown in the box 
on the right-hand side. This makes it much easier to choose the file you want and also checks that 
Draw can import the file format used .

Figure 1: Insert Picture dialog

Embedding
Embedding a graphic into your drawing makes the graphic a permanent part of your drawing. Any 
changes you make to an embedded graphic will only appear in your drawing and the original 
graphic file will not affected.

Embedding happens when you import a graphic into your drawing using the Insert File command, 
copying and pasting, scanning a graphic, or dragging and dropping.

The main advantage of embedding graphics into your drawing is that the graphic is always 
available no matter what computer is used to open the drawing.
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The main disadvantage of embedding graphics is that it creates large file sizes, which may not be 
desirable if you have limited capacity for storing computer files. Also, if the original graphic is 
altered, then your drawing will not have an up to date version each time you open your drawing.

Note
When a raster graphic is embedded into a LibreOffice document or drawing, then the 
format of that graphic is automatically changed to PNG format.

Linking
Linking a graphic to your drawing does not insert the graphic into your drawing, but a link is created 
to where the graphic file is located on your computer. Each time your drawing is opened, any linked 
graphics will be displayed in your drawing.

The main advantage of linking a graphic file to your drawing is if the original graphic file is altered 
or replaced by a new graphic with the same filename, then the next time you open your drawing, 
the latest version of the graphic will also open in your drawing.

The main disadvantage of linking graphics is that the link between your drawing and the graphic 
file must be maintained for linking to work correctly. If you move your drawing to another computer, 
then any linked files must also be moved to the same computer and the same folder on that 
computer.

To link a graphic file to your drawing, select the Link option in the Insert Picture dialog (Figure 1) 
before selecting the file and clicking on the Open button.

Note
When a graphic file is linked to a LibreOffice document or drawing, the format of the 
linked graphic is not changed.

Any changes made to a linked graphic within your LibreOffice drawing will only apply to your 
drawing and will not affect the original graphic file that has been linked to your drawing.

Links can be updated, modified or broken by going to Edit > Links on the main menu bar to open 
the Edit Links dialog (Figure 2). Select the link to be updated, modified or broken and then click on 
the appropriate button. If you break a link, then the linked graphic becomes embedded in your 
drawing and the graphic format is converted to PNG.

Figure 2: Edit Links dialog
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Scanning
With most scanners you can directly insert a scanned image into a drawing or document. Scanned 
images are embedded using PNG format.

Make sure that your scanner is configured for the computer and supported by the SANE system for 
a Linux operating system, or TWAIN for a Windows or Mac operating system.

To insert an image from the scanner:

1) Place a document, drawing, or photograph in the scanner and make sure that the scanner 
is ready.

2) Go to Insert > Picture > Scan > Select Source on the main menu bar to select the 
scanner if this is the first time the scanner has been used OR go to Insert > Picture > 
Scan > Request on the main menu bar is the scanner has been used before.

Note

If there is more than one scanning device connected to the computer, you will be able 
to select the device when you select the source. This selection will then become the 
default source when using scan requests until another device is used as the scanning 
source.

3) The rest of the procedure depends on the scanner driver, interface and computer operating 
system. You will normally be required to specify scanning options such as resolution, scan 
window, and so on. Consult the documentation that came with the scanner for more 
information.

4) When the image has been scanned, Draw places it in the drawing. At this point it can be 
edited like any other graphic.

Copying and pasting
Copying a graphic and then pasting the graphic is another way of embedding graphics into a 
drawing (this is also called using the clipboard). The copied graphic can be an image already 
embedded in another document or drawing, or it can be a graphic file such as a drawing, document 
or photograph.

After copying you can also choose the format when you paste a graphic into Draw using Edit > 
Paste Special from the main menu bar. Available formats will depend on the type of image copied 
onto the clipboard.

Dragging and dropping
Dragging and dropping is another method of embedding graphics into a drawing and can be used 
on graphics that have been embedded or linked. The way that dragging and dropping works is 
determined by the computer operating system. Behavior of dragging and dropping is normally 
controlled using the Ctrl or Ctrl+Shift keys in combination with the mouse.

Objects and images which are used frequently can be stored in the Draw Gallery. From the Gallery 
a copy of the object or image can be simply dragged onto the drawing. Working with the Gallery is 
dealt with in Chapter 10 Advanced Draw Techniques.

File inserting
On the main menu bar there is an option to insert a file (Insert > File). This option allows you to 
insert from an existing Draw drawing (*.ODG), an Impress presentation (*.ODP), a Writer 
document (*.ODT), or a document in Rich Text Format (RTF), HTML format or plain text. Any text 
will be contained within a text frame with paragraph and character formatting options available. 
When inserting a file, normally the complete file will be inserted into your drawing.
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Figure 3: Inserting slides or objects

However, when choosing a Draw or Impress file you can also select individual slides or individual 
objects for insertion into your drawing.

After selecting a Draw or Impress file and clicking on Insert, the Insert Slides/Objects dialog 
(Figure 3) opens. To access individual slides or objects, click on the expansion symbol (usually a + 
or a small triangle, depending operating system) to the left of the file name in the selection area.

Select the slides or objects you want to insert and click OK to insert the selected items into your 
drawing.

If the inserted object was named in the source document, it keeps its original name unless the 
name already exists in the current document. If there is a name clash, you must give the object a 
new name before it is inserted. To rename an inserted object, right-click and choose Name from 
the context menu. Renaming has the advantage that the object is then listed in the Navigator.

Exporting graphics

Exporting the entire file
By default Draw saves drawings in the *.ODG format and some software programs cannot open 
these files. To make your drawings available for other programs, you can export the file in various 
formats.

1) Select your file and go to File > Export on the main menu bar

2) Select the required format from the upper section of the File format drop down list (Figure 
4).

3) Click Export.

Figure 4: Exporting graphics

8 Editing Pictures (Raster Graphics)



4) Depending on the format selected, another dialog will open allowing you to select the 
required options for the selected graphic format.

5) Click on Export, Create or OK and your file will be exported as a new file in its new format.

Note
The format options in the upper section of the File format drop down list (EMF, HTML, 
XHTML, PDF, and SWF) only apply to complete files.

Exporting objects
To export individual objects from your drawing:

1) Select the objects and then go to File > Export on the main menu bar.

2) Select the required graphic format from the lower section of the File format drop down list.

3) Select the Selection option on the Export dialog (Figure 4).

4) Click Export.

5) Depending on the graphic format selected another dialog will open allowing you to select 
the required options for that graphic format.

6) Click on Export, Create or OK and your selected objects will be exported as a new file in 
its new format.

Formatting raster objects

Objects that are raster graphics can be formatted using the Format or context menus. The Picture 
toolbar is used to add or change filters and adjust the properties of lines, areas and shadows.

The Transparency property in the Format menu does not relate to the transparency of the raster 
graphic itself but to the background area. To change the transparency of a raster graphic, you must 
use the Picture toolbar, see “Picture toolbar” on page 9.

Some raster graphics may have a text element and for more information on formatting text, see 
Chapter 9 Adding and Formatting Text.

You can change position and size or rotate rotate raster graphics and for more information see 
Chapter 3 Working with Objects and Object Points. Raster graphics can also be flipped (Modify > 
Flip on the main menu bar), but some metafile graphic formats may have problems flipping if they 
contain text.

Raster graphics included in a group behave like other objects when the properties of the group are 
modified.

It is recommended to name raster graphics using Modify > Name from the main menu bar or the 
context menu. Only named objects are visible in the Navigator and only named objects can be 
directly imported from another file.

Picture toolbar

The Picture toolbar will automatically appears when you select a picture (Figure 5 and Figure 6). 
This can be in the main menu bar or as a floating toolbar.

Figure 5: Picture toolbar
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Figure 6: Tools on Picture toolbar

The tools available from left to right on the Picture toolbar are as follows:

• Filter: opens the Graphic Filter toolbar which is described in “Graphic filter toolbar” on page 
12.

• Graphics mode: changes the display of the graphic from color to grayscale, black and 
white, or a watermark. This setting affects only the display and printing of the picture; the 
original picture file remains unchanged.

– Default: the graphic is displayed unaltered in color.

– Grayscale: the graphic is displayed in 256 shades of gray.

– Black/White: the graphic is displayed in black and white.

– Watermark: the brightness and contrast of the graphic are reduced to the extent that 
the graphic can be used as a watermark (background).

• Color: opens the Color toolbar (Figure 7) to adjust the values of the three RGB colors, 
brightness, contrast and Gamma. These adjustments do not affect the original picture, but 
the values are stored in Draw as a separate formatting set.

– Red, Green, Blue: select values between -100% (no color) to +100% (full intensity); 0% 
represents the original color value of the graphic.

– Brightness: select a value between –100% (totally black) and +100% (totally white).

– Contrast: select a value between –100% (minimum) and +100% (maximum).

– Gamma: this affects the brightness of the middle color tones. Select a value between 
0.10 (minimum) to 10 (maximum) Try adjusting this value if changing brightness or 
contrast does not give you the required result.

Figure 7: Color toolbar

• Transparency: adjust the degree of transparency of the picture between 0% (opaque) and 
100% (fully transparent).

• Line: opens the Line dialog. In this context, line refers to the outline of the border. See 
Chapter 4 Changing Object Attributes for more information.
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• Area: opens the Area dialog allowing you to edit color, gradient, hatching and fills of the 
background area that contains the picture — not the picture itself. To see the background, 
you must set the transparency of the picture to a suitably high value.

• Shadow: sets the default shadow effect around the picture.

• Crop Picture: crops (trims) a picture. When you click on this tool, crop marks appear 
around the picture. Drag one or more of these marks to crop the picture to your desired 
size. For more accurate cropping, see “Cropping” on page 11.

Cropping

For more control and accuracy over cropping functions, select the picture and go to Format > 
Crop Picture, or right-click and select Crop Picture from the context menu to open the Crop 
dialog (Figure 8).

Any changes made in the Crop dialog change only the display of the graphic. The original graphic 
file is not changed. If you want to export a cropped graphic, you must do it through File > Export. If 
you use Save as Picture from the context menu, the changes are not exported.

Figure 8: Crop dialog

Note
As an alternative to cropping, the Position and Size dialog has an option for keeping the 
width and height ratio fixed while changing one of the two dimensions. Changing values 
in one area (Scale or Image Size) will show up correspondingly in the other area.

Caution Take care with cropping operations. In the Crop dialog, the width and height are 
treated as independent values. Changing one without the other can result in 
significant distortion of the image and this may not be what you want.
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Crop
This section of the Crop dialog allows you to trim or scale the selected graphic, or to add white 
space around the graphic.

• Keep scale: – maintains the original scale of the graphic when cropping so that only the 
size of the graphic changes.

• Keep image size: – maintains the original size of the graphic when you crop so that only 
the scale of the graphic changes. To reduce the scale of the graphic, select this option and 
enter negative values in the cropping boxes. To increase the scale of the graphic, enter 
positive values in the cropping boxes.

• Left and Right: – if Keep Scale is selected, enter a positive amount to trim the left or right 
edge of the graphic, or a negative amount to add white space to the left or right of the 
graphic. If Keep image size is selected, enter a positive amount to increase the horizontal 
scale of the graphic, or a negative amount to decrease the horizontal scale of the graphic.

• Top and Bottom: – if Keep Scale is selected, enter a positive amount to trim the top or 
bottom of the graphic, or a negative amount to add white space above or below the 
graphic. If Keep image size is selected, enter a positive amount to increase the vertical 
scale of the graphic, or a negative amount to decrease the vertical scale of the graphic.

Scale
This section of the Crop dialog allows you to change the scale of the selected graphic. In the 
Width and Height fields enter a value for the width or height of the selected graphic as a 
percentage.

Image size
This section of the Crop dialog allows you to change the size of the selected graphic. In the Width 
and Height fields enter a value for the width or height of the selected graphic.

Above the Original Size button, the original size of the graphic is displayed. Clicking on this button 
and then clicking OK resets the inserted image to the original image size.

Graphic filter toolbar

After selecting a graphic and the Picture toolbar (Figure 5) has opened, click on the Filter icon to 
open the Graphic Filter toolbar (Figure 9 and Figure 10). Draw offers eleven filter effects. Filters 
work on the current view of a graphic and they can be combined. Filters always apply to the entire 
graphic and it is not possible to use filters to edit only a part of the object.

Figure 9: Graphic Filter toolbar
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Figure 10: Tools on Graphic Filter toolbar

Note

If your graphic is linked, any graphic filters used are only applied to the current view. 
The original graphic is not changed. When you close your drawing, any filtering 
applied is lost. To keep a copy of your filtered graphic, export the graphic to create a 
copy with all the filters applied (File > Export).

If your graphic is embedded, all graphic filters are applied directly on the embedded 
graphic and cannot be undone in a subsequent session. After you save and close 
your drawing, the graphic filter effects become permanent. If you do not want to 
retain a graphic filter, you must use Edit > Undo to return to cancel the filter effect.

Invert graphic filter
Inverts or reverses the color values of a color image (similar to a color negative), or the brightness 
values of a grayscale image. Apply the filter again to revert to the original graphic (Figure 11).

Figure 11: Invert graphic filter

Smooth graphic filter
Softens or blurs the image by applying a low pass filter reducing the contrast between neighboring 
pixels and produces a slight lack of sharpness. If you use the filter several times, the effect will be 
strengthened (Figure 12).
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Figure 12: Smooth graphic filter

Sharpen graphic filter
Sharpens the image by applying a high pass filter increasing the contrast between neighboring 
pixels emphasizing the difference in brightness. This will accentuate the outlines and the effect will 
be strengthened if you apply the filter several times (Figure 13).

Figure 13: Sharpen graphic filter

Remove noise graphic filter
Removes noise by applying a median filter by comparing every pixel with its neighbors. It then 
replaces extreme values of those pixels that deviate in color by a large amount from a mean value 
by a pixel with a mean color value. The amount of picture information does not increase, but 
because there are fewer contrast changes resulting in a graphic that looks smoother (Figure 14).

Figure 14: Remove Noise graphic filter

Solarization graphic filter
Solarization is a phenomenon in photography in which the image recorded on a negative or on a 
photographic print is wholly or partially reversed in tone. Dark areas appear light or light areas 
appear dark. Solarization was originally a photochemical effect used during photographic film 
development and is now used in the digital world of computing to create a change or reversal of 
color (Figure 15 and Figure 16).
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Figure 15: Solarization graphic filter

Figure 16: Solarization dialog

Clicking on the Solarization tool opens a dialog allowing you to define the threshold value for 
solarization. Entering a threshold value above 70% reverses the color values (center picture in 
Figure 15). Selecting the Invert option, all the colors are inverted (right picture in Figure 15).

Aging graphic filter
Aging creates a look that resembles photographs developed in the early days of photography. All 
pixels are set to their gray values and then the green and blue color channels are reduced by the 
amount specified in the Aging dialog. Red color channel is not changed (Figure 17 and Figure 18).

Figure 17: Aging graphic filter

Figure 18: Aging dialog
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Posterize graphic filter
Posterizing reduces the number of colors in a graphic making it look flatter. When used on a 
photograph, posterizing can make the photograph look like a painting. Clicking on the Posterize 
tool opens a dialog allowing you to define the number of poster colors to produce the effect you 
want (Figure 19 and Figure 20).

Figure 19: Posterize graphic filter

Figure 20: Posterize dialog

Pop art graphic filter
Changes the colors of a graphic to a pop-art format (Figure 21).

Figure 21: Pop Art graphic filter

Charcoal sketch graphic filter
Displays the graphic as a charcoal sketch. The contours of the graphic are drawn in black and the 
original colors are suppressed (Figure 22).
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Figure 22: Charcoal Sketch graphic filter

Relief graphic filter
The Relief graphic filter calculates the edges of a graphic in relief as if the graphic is illuminated by 
a light source. The position of the light source is selectable producing shadows that differ in 
direction and magnitude (Figure 23 and Figure 24).

Figure 23: Relief graphic filter

Figure 24: Relief dialog

Mosaic graphic filter
The Mosaic graphic filter joins groups of pixels and converts them into a rectangular tile in a single 
color creating a graphic that appears to be a mosaic. The larger the individual rectangles created, 
the fewer details the mosaic graphic has.

Clicking on the Mosaic tool opens a dialog allowing you to set the number of pixels used to create 
the width and height of the new tile created. The edges of each tile created can also be enhanced 
to create a sharper definition (Figure 25 and Figure 26).
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Figure 25: Mosaic graphic filter

Figure 26: Mosaic dialog

Replacing colors

The Color Replacer allows you to replace or change a color in a graphic for another color or set 
the color as transparent. Up to four colors can be replaced at once. The tool works on the entire 
graphic and you cannot select an area of the graphic for editing.

The Color Replacer can only be used on embedded graphics. If you try to use the Color 
Replacer on a linked graphic, you will get the following error message “This graphic is linked to a 
document. Do you want to unlink the graphic in order to edit it?”.

The selection list for replacement colors shows all the available colors in the current color palette of 
the drawing. You cannot define any new colors here but you can add colors to the available palette 
before using the Replace Color tool. For more information on this topic, see Chapter 10 Advanced 
Draw Techniques.

Replacing colors
A color is replaced in a graphic as follows:

1) Go to Tools > Color Replacer on the main menu bar to open the Color Replacer dialog 
(Figure 27).

2) Select a graphic to start using the Color Replacer.

3) Click on the pipette icon  to activate the color selection mode.

4) Move the cursor over the color you want to replace in the selected graphic and click on the 
color to be replaced.

5) A check box is now marked and the selected color appears in Source color.

6) Enter the amount of tolerance required for replacing the color in the Tolerance box. The 
default selection is 10% tolerance.

7) In Replace select a color from the drop down list. Transparent is the default selection.

8) Click on the Replace button to replace the colors in the selected graphic.
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Figure 27: Color Replacer dialog

9) There is no preview of the effect. If the result is not what you required, select Edit > Undo 
in the main menu bar and repeat the color replacement.

Replacing transparent areas
It is also possible to replace transparent areas in a graphic with a color.

1) Go to Tools > Color Replacer on the main menu bar to open the Color Replacer dialog. 
(Figure 27).

2) Make sure the graphic is NOT selected.

3) Select Transparency in the Color Replacer dialog.

4) Select a color from the drop down list next to Transparency.

5) Click Replace to replace the transparent areas with the selected color.

Tolerance parameter
The tolerance parameter is used to set how much of the source color in the graphic is replaced by 
another color. To replace colors that are similar to the color you are replacing, enter a low value for 
the tolerance parameter. To replace a wider range of colors, enter a higher value for the tolerance 
parameter.

Conversion

Convert to a contour
Converts a selected graphic to a contour by creating a polygon, or a group of polygons. If the 
conversion creates a group of polygons (for example a text object), then press the F3 key to enter 
the group before selecting an individual polygon.

To convert a graphic to a contour:

1) Select the graphic in your drawing.

2) Go to Modify > Convert > To Contour, or right click on the graphic and select Convert > 
To Contour.
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Note
Make sure you have finished all your editing to your graphic before converting to a 
contour as the graphic cannot be edited after conversion.

Convert to a polygon

Converts a selected graphic to a collection of polygons filled with color. The graphic also becomes 
a vector graphic and can be resized with no loss of image quality or distortion of any text. After 
conversion, you can break your graphic into groups of polygons and then split these groups into 
individual polygons. Breaking and splitting allows you to edit or delete individual colors within your 
graphic.

Converting
To convert a graphic to a polygon:

1) Select the graphic in your drawing.

2) Go to Modify > Convert > To Polygon, or right click on the graphic and select Convert > 
To Polygon and the Convert to Polygon dialog opens (Figure 28).

3) Select the Number of colors and Point reduction in the Settings section.

4) To prevent any blank areas appearing in your graphic, select the Fill holes option and Tile 
size.

5) Click on the Preview button to check how your converted graphic will look.

6) Make any necessary changes to the settings and check the preview again.

7) If you are satisfied, click OK to convert your graphic to polygons.

Figure 28: Convert to Polygon dialog
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Conversion options and controls

• Number of colors: enter the number of colors to be displayed in the converted image. 
LibreOffice generates a polygon for each occurrence of a color in the image. The range for 
the number of colors is between 8 and 32.

• Point reduction: removes color polygons that are smaller than the pixel value you enter. 
The range for point reduction is between 0 and 32 pixels.

• Fill holes: fills the blank areas in the graphic that can be created when applying a point 
reduction.

• Tile size: enter the size of the rectangle for the background fill. The range of tile sizes is 
between 8 and 128 pixels.

• Source picture: preview of the original image.

• Vectorized image: preview of the converted image. Click on the Preview button to 
generate the vectorized image.

• Progress: displays a progress bar during conversion.

• Preview: Creates a preview of the converted image without applying any changes.

• OK: converts your graphic to polygons.

Breaking
After converting your graphic to polygons, you can break your graphic into groups of polygons. 
Each group of polygons consists of one color.

1) Convert your graphic to polygons, see “Converting” on page 20.

2) Make sure your graphic is selected and go to Modify > Break on the main menu bar to 
break your converted graphic into groups of polygons.

3) Click on a color in your graphic then drag the group of polygons filled with that color out of 
your graphic to create a new graphic OR press the Delete key and delete the color from 
your graphic.

Splitting
After converting your graphic to polygons and breaking your graphic into groups of polygons, you 
can then split these groups into individual polygons.

1) Convert your graphic to polygons, see “Converting” on page 20.

2) Break your graphic into groups of polygons, see “Breaking” on page 21.

3) Make sure your graphic is selected and go to Modify > Split on the main menu bar or use 
the keyboard shortcut Ctrl+Alt+Shift+K to split groups of polygons into individual polygons.

4) Click on an individual polygon in your graphic and drag it out of your graphic or a polygon 
group OR press the Delete key and delete the polygon from your graphic.

Convert to a bitmap
All drawing objects placed into a LibreOffice drawing are vector graphics and these vector graphics 
can be converted to a bitmap in PNG format. Any transparency effects in the original vector graphic 
are lost during conversion even though the PNG format used does support transparencies.

To convert a vector graphic to a bitmap, go to Modify > Convert > To Bitmap on the main menu 
bar or right click on the graphic and select Convert > To Bitmap from the context menu.
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Print options

If you have only a monochrome (single color) printer or are experiencing problems with printing, 
then the following settings may help with printing your drawing. You can set up printing so that all 
text and all graphics are printed either in grayscale or black and white.

The general settings are in Tools > Options > LibreOffice Draw > Print (Figure 29) and will apply 
to all drawings that you print using LibreOffice Draw.

Figure 29: Options - LibreOffice Draw - Print

To set printing options for the current document only, go to File > Print and click on the Options 
tab in the Print dialog (Figure 30).

Figure 30: Print dialog - Options

To set printing options for all the modules in LibreOffice, go to Tools > Options > LibreOffice > 
Print (Figure 31). These printing options allow you to reduce print data sent to a printer or file, and 
to give any printer warnings if the wrong paper size or orientation and transparency is set.
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Figure 31: Options - LibreOffice - Print
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