What is Writer?

Writer is the word processor component of LibreOffice. In addition to the usual features of a word
processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic
generation of tables of contents and indexes, mail merge and others), Writer provides these
important features:

Templates and styles (see Chapter 3)

Page layout methods, including frames, columns, and tables

Embedding or linking of graphics, spreadsheets, and other objects

Built-in drawing tools

Master documents—to group a collection of documents into a single document
Change tracking during revisions

Database integration, including a bibliography database

Export to PDF, including bookmarks (see Chapter 10)

And many more

These features are covered in detail in the Writer Guide.

The Writer interface

The main Writer workspace is shown in Figure 63. The menus and toolbars are described in
Chapter 1, Introducing LibreOffice.

Some other features of the Writer interface are covered in this chapter.
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Figure 63: The main Writer workspace in Print Layout view

76 | Chapter 4 Getting Started with Writer



Status bar

The Writer status bar provides information about the document and convenient ways to quickly
change some document features.
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Figure 64: Left end of status bar

Page number
Shows the current page number, the sequence number of the current page (if different), and
the total number of pages in the document. For example, if you restarted page numbering at 1
on the third page, its page number is 1 and its sequence number is 3.

If any bookmarks have been defined in the document, a right-click on this field pops up a list of
bookmarks; click on the required one.

To jump to a specific page in the document, double-click on this field. The Navigator opens.
Click in the Page Number field and type the sequence number of the required page. After a
brief delay, the display jumps to the selected page.

Page style
Shows the style of the current page. To change the page style, right-click on this field. A list of
page styles pops up; choose a different style by clicking on it.

To edit the current page style, double-click on this field. The Page Style dialog opens.

Language
Shows the language for the selected text.
Click to open a menu where you can choose another language for the selected text or for the
paragraph where the cursor is located. You can also choose None (Do not check spelling) to
exclude the text from a spelling check or choose More... to open the Character dialog.

Insert mode
Click to toggle between Insert and Overwrite modes when typing.

Selection mode
Click to toggle between STD (Standard), EXT (Extend), ADD (Add) and BLK (Block) selection.
EXT is an alternative to Shift+click when selecting text. See “Working with text” on page 81 for
more information about ADD and BLK.

Unsaved ches
This icon E replaces the default icon here if changes to the document have not been saved.
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Figure 65: Right end of status bar
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Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon to
view the certificate.

Section or object information
When the cursor is on a section, heading, or list item, or when an object (such as a picture or
table) is selected, information about that item appears in this field. Double-clicking in this area
opens a relevant dialog. For details, consult the Help or the Writer Guide.

View layout
Click an icon to change between single page, side-by-side, and book layout views. The effect
varies with the combination of window width and zoom factor in use. You can edit the document

In any view.
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Figure 66: View layouts: single, side-by-side, book.

Zoom
To change the view magnification, drag the Zoom slider, or click on the + and — signs, or right-
click on the zoom level percent to pop up a list of magnification values from which to choose.
Zoom interacts with the selected view layout to determine how many pages are visible in the
document window.
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Changing document views

Writer has several ways to view a document: Print Layout, Web Layout, and Full Screen. To access
these and other choices, go to the View menu and click on the required view. (When in Full Screen
view, press the Esc key to return to either Print or Web Layout view.)

When in Print Layout, you can use both the Zoom slider and the View Layout icons on the status
bar. In Web Layout, you can use only the Zoom slider.
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You can also choose View > Zoom from the menu bar to display the Zoom & View Layout dialog,
where you can set the same options as on the Status bar. In Web Layout view, most of the choices

are not available.
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Figure 67: Choosing Zoom and View Layout options.

Moving quickly through a document

In addition to the navigation features of the Status bar (described above), you can use the main
Navigator window and the Navigation toolbar as described in Chapter 1, Introducing LibreOffice.

In Writer, you can also display the Navigation toolbar by clicking on the small Navigation icon near
the lower right-hand corner of the window below the vertical scroll bar, as shown in Figure 68.
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Figure 68: Navigation icons

The Navigation toolbar (Figure 69) shows icons for all the object types shown in the Navigator, plus
some extras (for example, the results of a Find command).
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Figure 69: Navigation toolbar

Click an icon to select that object type. Now all the Previous and Next icons (in the Navigator
itself, in the Navigation Toolbar, and on the scroll bar) will jump to the next object of the selected
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type. This is particularly helpful for finding items like index entries, which can be difficult to see in
the text. The names of the icons (shown in the tooltips) change to match the selected category; for
example, Next Graphic, Next Bookmark, or Continue search forward.

For more uses of the Navigator in Writer, see the Writer Guide.

Working with documents

Chapter 1, Introducing LibreOffice, includes instructions on starting new documents, opening
existing documents, saving documents, and password-protecting documents. Chapter 3, Using
Styles and Templates, covers how to create a document from a template.

Saving as a Microsoft Word file

If you need to exchange documents with users of Microsoft Word who are unwilling or unable to
receive *.odt files, you can save a document as a Microsoft Word file.

1) Important—First save your document in the file format used by LibreOffice Writer (.odt). If
you do not, any changes you made since the last time you saved will appear only in the
Microsoft Word version of the document.

2) Then choose File > Save As. On the Save As dialog, in the File type (or Save as type)
drop-down menu, select the type of Word format you need. Click Save.
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Figure 70. Saving a file in Microsoft Word format

From this point on, all changes you make to the document will occur only in the new document.
You have changed the name and file type of your document. If you want to go back to working with
the .odt version of your document, you must open it again.
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To have Writer save documents by default in the Microsoft Word file format, go to
Tools > Options > Load/Save > General. In the section named Default file format
and ODF settings, under Document type, select Text document, then under
Always save as, select your preferred file format.

Tip

Working with text

Working with text (selecting, copying, pasting, moving) in Writer is similar to working with text in
any other program. LibreOffice also has some convenient ways to select items that are not next to
each other, select a vertical block of text, and paste unformatted text.

Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 71) using the mouse:

1) Select the first piece of text.
2) Hold down the Ctrl key and use the mouse to select the next piece of text.
3) Repeat as often as needed.

Now you can work with the selected text (copy it, delete it, change the style, or whatever).

Macintosh users: substitute the Command key when instructions in this chapter

Note say to use the Ctrl key.

Around the World in 80 Days - Jules Verne

overspread Passepartout's round face; clearly he had not comprehended his

master.
"Monsieur is going to leave home?"
"Yes," returned Phileas Fogg. "We are goinground the world."

Passepartout jopened wide his eyed, raised his eyebrows, held up his hands, and seemed about
to collapse, so overcome was he with stupefied astonishment.

"Round the world![' he muwrmured.
"In eighty days," responded [Mr. Fogg. "So we haven't a moment to lose."
"But the trunks?" gasped Passepartout, unconsciously swaying his head from rightto left.

"We'll have no trunks; only a carpet—bag, with two shirts and three pairs of stockings for me|
and the same for you] We'll buy our clothes on the way. Bring down my mackintosh and
travelmg-cloak and some stout shoes, though we shall do little walking. Malke haste!"

Figure 71: Selecting items that are not next to each other

To select nonconsecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection of text, see the
topic “Navigating and selecting with the keyboard” in the Help.)

2) Press Shift+F8. This puts Writer in “Add” mode. The word ADD appears on the status bar,
replacing STD.

3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down
the Shift key and select the next piece of text.

4) Repeat as often as needed.
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Now you can work with the selected text.

Press Esc to exit from this mode.

Selecting a vertical block of text

You can select a vertical block or “column” of text that is separated by spaces or tabs (as you might
see in text pasted from e-mails, program listings, or other sources), using LibreOffice’s block
selection mode. To change to block selection mode, use Edit > Selection Mode > Block Area, or
press Ctrl+F8, or click several times in the status bar on STD until it changes to BLK.
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Figure 72: Selecting a vertical block of text

Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other applications. You
can use the mouse or the keyboard for these operations. You can copy or move text within a
document, or between documents, by dragging or by using menu selections, icons, or keyboard
shortcuts. You can also copy text from other sources such as Web pages and paste it into a Writer
document.

To move (cut and paste) selected text using the mouse, drag it to the new location and release it.
To copy selected text, hold down the Ctrl key while dragging. The text retains the formatting it had
before dragging.

When you paste text, the result depends on the source of the text and how you paste it. If you click
on the Paste icon, any formatting the text has (such as bold or italics) is retained. Text pasted from
Web sites and other sources may also be placed into frames or tables. If you do not like the
results, click the Undo icon or press Ctrl+Z.

To make the pasted text take on the formatting of the surrounding text where it is being pasted:
* Choose Edit > Paste Special, or
* Click the triangle to the right of the Paste icon, or
* Click the Paste icon without releasing the left mouse button.

Then select Unformatted text from the resulting menu.

The range of choices on the Paste Special menu varies depending on the origin and formatting of
the text (or other object) to be pasted. See Figure 73 for an example with text on the clipboard.
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Figure 73: Paste Special menu

Finding and replacing text and formatting

Writer has two ways to find text within a document: the Find toolbar for fast searching and the Find
& Replace dialog. In the dialog, you can:

* Find and replace words and phrases

* Use wildcards and regular expressions to fine-tune a search

* Find and replace specific formatting

* Find and replace paragraph styles

Using the Find toolbar

If the Find toolbar is not visible, you can display it by choosing View > Toolbars > Find from the
menu bar or by pressing Ctr/+F. The Find toolbar is shown docked at the bottom of the LibreOffice
window (just above the Status Bar) in Figure 74, but you can float it or dock it in another location.
For more information on floating and docking toolbars, see Chapter 1, Introducing LibreOffice.
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Figure 74: Docked position of Find toolbar

To use the Find toolbar, click in the box and type your search text, then press Enter to find the next
occurrence of that term. Click the Find Next or Find Previous buttons as needed.

Using the Find & Replace dialog
To display the Find & Replace dialog (Figure 75), use the keyboard shortcut Ctrl+Alt+F or choose
Edit > Find & Replace from the menu bar. Optionally, click the More Options button to expand
the dialog; the button changes to Fewer Options.
To use the Find & Replace dialog:

1) Type the text you want to find in the Search for box.

2) To replace the text with different text, type the new text in the Replace with box.

3) You can select various options such as matching the case, matching whole words only, or
doing a search for similar words.

4) When you have set up your search, click Find. To replace the found text, click Replace.

For more information on using Find & Replace, see the Writer Guide.

If you click Find All, LibreOffice selects all instances of the search text in the

Tip document. Similarly, if you click Replace All, LibreOffice replaces all matches.

Working with text | 83



Caution Use Replace All with caution; otherwise, you may end up with some hilarious (and
highly embarrassing) mistakes. A mistake with Replace All might require a
manual, word-by-word, search to fix.
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Figure 75: Expanded Find & Replace dialog

Inserting special characters
A special character is one not found on a standard English keyboard. For example, ©3% s ¢fi 0 g
¢ are all special characters. To insert a special character:

1) Place the cursor where you want the character to appear.

2) Choose Insert > Special Character to open the Special Characters dialog.

3) Select the characters (from any font or mixture of fonts) you wish to insert, in order, then
click OK. The selected characters are shown in the lower left of the dialog. As you select a
character, it is shown on the lower right, along with its numerical code.

Different fonts include different special characters. If you do not find a particular

Note special character, try changing the Font selection.
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Special Characters
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Figure 76: The Special Characters dialog, where you can insert special characters

Inserting dashes and non-breaking spaces and hyphens

To prevent two words from being separated at the end of a line, press Ctrl+Shift when you type the
space between the two words.

In cases where you do not want the hyphen to appear at the end of a line, for example in a number
such as 123-4567, you can press Shift+Ctrl+minus sign to insert a non-breaking hyphen.

To enter en and em dashes, you can use the Replace dashes option on the Options tab under
Tools > AutoCorrect Options. This option replaces two hyphens, under certain conditions, with
the corresponding dash.

— is an en-dash; that is, a dash the width of the letter “n” in the font you are using. Type at
least one character, a space, one or two hyphens, another space, and at least one more
letter, then a space. The one or two hyphens will be replaced by an en-dash.

— is an em-dash; that is, a dash the width of the letter “m” in the font you are using. Type at
least one character, two hyphens, and at least one more character, then a space. The two
hyphens will be replaced by an em-dash.

See the Help for more details. For other methods of inserting dashes, see the Writer Guide.

Setting tab stops and indents

The horizontal ruler shows both the default tab stops and any tab stops that you have defined. Tab
settings affect indentation of full paragraphs (using the Increase Indent and Decrease Indent
icons on the Formatting toolbar) as well as indentation of parts of a paragraph (by pressing the Tab
key on the keyboard).

Using the default tab spacing can cause formatting problems if you share documents with other
people. If you use the default tab spacing and then send the document to someone else who has
chosen a different default tab spacing, tabbed material will change to use the other person’s
settings. Instead of using the defaults, define your own tab settings, as described in this section.

To define indents and tab settings for one or more selected paragraphs, double-click on a part of
the ruler that is not between the left and right indent icons to open the Indents & Spacing page of
the Paragraph dialog. Double-click anywhere between the left and right indent icons on the ruler to
open the Tabs page of the Paragraph dialog.
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