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Introduction

When text is used in drawings, it is placed inside an object or inside a text box. This chapter 
describes how to create, format, use, and delete text. It also discusses the various types of text 
that can be inserted into a drawing. Finally, it provides information on how to insert special forms of
text such as numbered or bulleted lists, tables, fields, hyperlinks, and Fontwork.

Text

Text mode
Before any text can be typed in a drawing, text mode has to be activated. Click on the Insert Text 
icon for horizontal text or the Insert Vertical Text icon for vertical text on the Standard toolbar 
(Figure 1) or Drawing toolbar (Figure 2). The Text Formatting toolbar (Figure 3) automatically 
opens replacing the Line and Filling toolbar.

Figure 1: Standard toolbar - text tools highlighted

Figure 2: Drawing toolbar - text tools highlighted

Figure 3: Text Formatting toolbar

If the Insert Vertical Text icon is not visible on the Standard or Drawing toolbars, it can be 
activated as follows:

 1) Go to Tools > Options > Language Settings > Languages on the main menu bar to open
the Languages page in the Options dialog.

 2) In Default Languages for Documents, select the Asian option and Default – Chinese 
(simplified) is displayed in the scroll box.

 3) Click Apply then OK to close the Options dialog and save your changes.

 4) Restart LibreOffice to activate vertical text.

Adding text
When you add text to a drawing, a text box is automatically created to contain the text. By default, 
the text box expands horizontally to accommodate a single line of text. To change the default 
setting, you have to format the text box, see “Formatting text boxes” on page 10 for more 
information.

 1) Activate text mode, see “Text mode” above for information.

 2) Click in your drawing at the approximate position where you want to place the text. A text 
box is created containing a flashing cursor.

 3) Start typing your text. As you type the text box automatically expands horizontally to 
accommodate a single line of text. Also, the left corner of the Status Bar indicates that you 
are in text edit mode and the position of your cursor (Figure 4).
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Figure 4: Text information in Status Bar

Figure 5: Character and Paragraph 
sections in Sidebar Properties

 4) To create multiple lines in the text box being created use one of the following methods:

— Use the Enter key to create single line paragraphs inside the text box. The text box 
expands vertically to accommodate more lines of text.

— Create a text box before typing text, see “” below for more information. As you reach the
horizontal limit of the text box, the text will automatically word wrap inside the text box 
and the text box expands vertically as it fills.

 5) When you have finished typing text, click outside the text box to exit text mode. The Text 
Formatting toolbar closes and the Line and Filling toolbar opens in its original position.

 6) To format and/or reposition this text box, see “Moving, resizing, rotating and formatting text 
boxes” below and Chapter 3 Working with Objects and Object Points for more information.

 7) If required, format the text, select the text using the various tools on the Text Formatting 
toolbar (Figure 1 on page 5) or in the Character and Paragraph sections in the Properties 
deck of the Sidebar (Figure 5). For more information on text formatting, see “Formatting 
text” on page 13.
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Creating text boxes
It is recommended to create a text box before before entering any text in your drawing. This will 
give you an opportunity to create, for example, a caption for a shape, an explanatory note, or a 
drawing title block similar to those used in engineering drawings.

 1) Activate text mode, see “Text mode” on page 5 for information.

 2) Click and drag to create a text box on the drawing setting the width of the text box. The 
height of the text box automatically increases as you type or add text.

 3) Release the mouse button when you have reached the desired width for your text box. A 
flashing cursor appears in the text box and the text box, depending on your computer 
system, has a border indicating edit mode.

 4) Type or paste your text in the text box. The status bar at the bottom of the drawing 
workspace indicates that you are in text edit mode and the cursor position within the text 
box (Figure 4 on page 6).

 5) Click outside the text box to deselect and cancel text mode. The Text Formatting toolbar 
closes and the default Line and Filling toolbar opens in its original position.

 6) If required, format the text using the various tools on the Text Formatting toolbar (Figure 1 
on page 5) or in the Character and Paragraph sections in the Properties deck of the 
Sidebar (Figure 5 on page 6). For more information on text formatting, see “Formatting text”
on page 13.

Note

Text boxes use a simplified edit engine and are designed for text only. Text boxes 
cannot contain illustrations, inline pictures, formulas, tables or shapes.

Moving, resizing, rotating and formatting text boxes
You can format, move, resize and rotate a text box just like any other object in your drawing. For 
more information, see Chapter 3 Working with Objects.

Moving text boxes
 1) Click on the text in a text box to switch the text into edit mode and the text box border is 

displayed.

 2) Move the cursor over the border. The cursor changes shape to the move symbol for your 
computer setup (for example, a clenched hand).

 3) Click and drag the text box to a new position in your drawing. A semi-transparent copy of 
the text box shows where your text box will be placed (Figure 6).

 4) Release the mouse button when the text box is in the required position.

Figure 6: Moving a text box
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 5) To accurately position a text box, use the Position and Size dialog or the Position and 
Size section on the Sidebar. See Chapter 3 Working with Objects and Object Points for 
more information on the Position and Size dialog or the Position and Size section on the 
Sidebar.

Resizing text boxes
 1) Click on the text in a text box to switch the text into edit mode. If the text box does not have

a border defined, then a border is displayed depending on your computer setup.

 2) Move the cursor over one of the selection handles and the cursor changes shape to the 
resizing symbol for your computer setup (for example, a double-headed arrow).

 3) Click and drag the border to a new position to resize the text box.  A semi-transparent copy 
of the text box shows is displayed as you resize (Figure 7).

 4) Release the mouse button when the text box reaches the desired size.

 5) If necessary, adjust the height or width of the text box using the selection handles.

 6) To accurately resize a text box, use the Position and Size dialog or the Position and Size 
section on the Sidebar. See Chapter 3 Working with Objects and Object Points for more 
information on the Position and Size dialog or the Position and Size section on the 
Sidebar.

Figure 7: Resizing a text box .

Rotating text boxes
 1) Click on the text in a text box to switch the text into edit mode. If the text box does not have

a border defined, then a border is displayed depending on your computer setup.

 2) Click on the text box border so that the selection handles are visible indicating that the text 
box is now edit mode.

 3) Click again on the text border or select the Rotation tool on the Transformations toolbar. 
The selection handles change shape and color.

 4) Click and drag on a corner handle to rotate the test box. A ghosted outline of the text box 
being rotated appears and the current angle of rotation is shown in the status bar (Figure
8).

Figure 8: Rotating text boxes
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 5) Release the mouse button when the text box is at the desired rotation angle.

 6) To accurately rotate a text box, use the Rotation page in Position and Size dialog or the 
Position and Size section on the Sidebar. See Chapter 3 Working with Objects and Object
Points for more information on the Position and Size dialog or the Position and Size 
section on the Sidebar.

Note

When in rotation mode, the top, bottom, and side handles though visible, are not 
available for use on a text box. Also, text boxes can not be sheared, slanted, flipped 
vertically or flipped horizontally.

Figure 9: Text dialog

Figure 10: Text dialog - Text Animation

Text | 9



Formatting text boxes
Text boxes can be treated just like other basic shapes in your drawing when you want to format the
area or border (line) of a text box. See Chapter 3 Working with Objects and Object Points for more 
information on formatting text boxes.

Note

Make sure you click on the Text… icon to open the Text dialog and NOT the Text ► 
icon. The Text ► icon opens a context menu allowing you to format text and not the 
text box.

Formatting how text appears inside a text box is as follows:

 1) Select a text box and use one of the following methods to open the Text dialog (Figure 9).

— Right click on the text box and select Text… from the context menu.

— Go to Format > Text… on the main menu bar.The Text icon opens a context menu 
allowing you to format text and not the text box.

 2) On the Text page (Figure 9), select the options required in Drawing Object Text and 
Spacing to Borders.

 3) On the Text Animation page (Figure 10), select the options required in Effect and 
Properties. However, this is not recommended unless you are going to display the drawing
as part of a presentation. See the Impress Guide for more information on text animation.

 4) Click on OK to save your selected options and close the dialog.

Deleting text boxes
 1) Click on the text in a text box to switch the text into edit mode and the text box border is 

displayed.

 2) Click on the text box border so that the selection handles are visible indicating that the text 
box is now edit mode.

 3) Press the Delete key and the text box is deleted without any warning.

Using text with Draw objects

Text can be added to most Draw objects. The exceptions are control elements like buttons, 
polygons, curves or 3D objects.

By default, a Draw object is not dynamic when it is first created and does not behave like a text 
box. Text does not word wrap and to keep text within the borders of the object, you have to use 
paragraphs, line breaks, smaller text size, increasing the object size, or a combination of all four 
methods.

To create text in a Draw object (Figure 11) and use word wrap in a Draw object is as follows:

 1) Create an object in your drawing and make sure the object is selected with the selection 
handles displayed.

 2) Click on the Insert Text icon for horizontal text or Insert Vertical Text icon for vertical text 
on the Standard or Drawing toolbar and a text cursor starts flashing in the center of the 
selected object. Also, the Text Formatting toolbar (Figure 1 on page 5) automatically 
opens replacing the Line and Filling toolbar.

 3) Alternatively, double-click on an object to automatically enter horizontal text editing mode.
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Figure 11: Example of object word wrap

Figure 12: Text dialog - Word wrap text to shape 
selected

 4) To change to vertical text after double clicking on an object, click on the Insert Vertical 
Text icon for vertical text on the Standard or Drawing toolbar.

 5) Start typing your text. If your text text goes outside the object borders, use paragraphs, line 
breaks, smaller text size, increasing the object size, or a combination of all four methods to 
keep the text within object borders.

 6)  Alternatively, to make sure your text word wraps staying within the borders of an object, 
proceed as follows:

a) Right-click on the text inside the object and select Text… from the context menu to 
open the Text dialog (Figure 12).

b) Click on the Text tab to open the Text page.

c) In Custom Shape Text select the option Word wrap text in shape.

d) Click OK to close the dialog and save your changes.

e) When finished typing text, click outside of the object to cancel text mode and save your 
changes. The text inside the object will now word wrap, as shown in Figure 11.

 7) To format how the text appears inside an object, see “Formatting text” on page 13.
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Note

If double-clicking does not work, then go to View > Toolbars on the main menu bar 
and open the Options toolbar. Select the Double-click to edit Text option or press 
the F2  key.

Inserting text

Pasting text
Text may be inserted into a text box or object by copying text from another document and pasting 
into the text box or object on your drawing. However, pasted text may not match the formatting of 
the text that has already been included on your drawing. This may be what you want on some 
occasions, but in most cases it is better to make sure that text format is consistent throughout your
drawing.

Note

If you paste copied text directly into a drawing and not into an object using Format > 
Paste on the main menu bar or the keyboard short cut Ctrl+V , the text is pasted in as
an OLE object and not as a Draw object. It is recommended to paste text into Draw as 
unformatted text to create a text object in Draw.

Pasting unformatted text
It is good practice to paste text without formatting and apply the formatting later so it matches the 
text already in your drawing.

 1) Copy the text you want to use, then move your cursor into position on the drawing.

 2) Paste your copied text using one of the following methods:

— Go to Edit > Paste Special > Paste Unformatted Text on the main menu bar.

— Go to Edit > Paste Special > Paste Special on the main menu bar and the Paste 
Special dialog (Figure 13) opens. Select Unformatted text and click OK to close the 
dialog.

— Use the keyboard shortcut Control+Shift+V and the Paste Special dialog (Figure 13) 
opens. Select Unformatted text and click OK to close the dialog.

Figure 13: Paste Special dialog
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— Click on the small triangle next on the right of the Paste icon on the Standard toolbar 
and select Unformatted text from the context menu.

 3) The copied text will be pasted into a text box at the cursor position and formatted to the 
default paragraph style of the object.

Pasting PDF text
PDF text is pasted into a text box at the center of your drawing or into a selected object.

 1) Select the text in a PDF file you want to use and copy to the clipboard.

 2) Click in your LibreOffice drawing and paste the copied PDF text into your drawing using 
one of the following methods. The PDF text is copied into your drawing and the text retains 
some of the formatting from the PDF file.

a) Go to Edit > Paste on the main menu bar.

b) Use the keyboard shortcut Ctrl+V .

c) Right click in your drawing and select Paste from the context menu.

 3) If required, see “Pasting unformatted text” above to paste unformatted text into your 
drawing. The PDF text is pasted using the default text formatting for your drawing.

Formatting pasted text
 1) Select the text you have just pasted (see “Selecting text” below for more information). The 

Text Formatting toolbar (Figure 1 on page 5) automatically opens replacing the Line and 
Filling toolbar.

 2) Use the formatting tools that are available on the Text Formatting toolbar, or go to Format 
on the main menu bar and select a formatting tool from the drop-down menu.

 3) Alternatively, go to Format > Styles on the main menu bar and select an option from the 
context menu or use one of the options available on the Styles deck on the Sidebar. See 
“Using graphic styles” on page 18 for more information.

Inserting special characters, non-breaking spaces and hyphens
For information on how to insert special characters, non-breaking spaces and hyphens into a 
drawing, see the Getting Started Guide and the Writer Guide for information.

Formatting text

The appropriate use of text formatting can give text in a drawing a consistent look, making your 
drawing look more professional without any distracting elements. Formatting text may require 
some intervention in character attributes (for example, font color), paragraph attributes (for 
example, alignment) or list attributes (for example, type of bullet).

Selecting text
Before formatting any text, the text must be selected in a text box or object:

 1) Make sure the text box or object is selected where you want to select text.

 2) Click in the text you want to select to position the cursor.

 3) Select the text to be formatted using one of the following methods:

— Use the keyboard shortcut Ctrl+A  to select all the text.

— Click and drag the cursor over the text.
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— Press Shift then use the left or right arrow keys to select characters.

— Press Shift+Ctrl then use the left or right arrow keys to select whole words.

— Press Shift+Home to select text to the beginning of the line.

— Press Shift+End to select text to the end of the line.

Direct text formatting
Direct text formatting is normally carried out on text in LibreOffice Draw. However, in situations 
where you need to perform the same formatting to several paragraphs of text, then the use of 
paragraph styles is recommended.

Tip

Sometimes it is very useful to re-apply the default style to a selection of text removing 
any manual formatting applied to it, especially if a mistake has been made and you are
not sure how to undo it. To revert back to the default style, select the manually 
formatted text and select Format > Clear Direct Formatting on the main menu bar.

Direct character formatting
Characters can be formatted independently from the format used for a paragraph. This character 
formatting overrides any paragraph formatting applied directly or using a paragraph style. There 
are no character styles available for text in LibreOffice Draw. Any character formatting must be 
applied directly.

Note

If a text box or object has been selected, but the text is NOT selected, any character 
formatting will be applied to all of the text contained within the text box or object.

 1) Click on text where you want to format characters. The Text Formatting toolbar (Figure 1 
on page 5) automatically opens replacing the Line and Filling toolbar.

 2) Select the characters you want to format. See “Selecting text” above for information on how
to select text.

 3) Use one of the following methods to open the Character dialog (Figure 14):

— Go to Format > Character on the main menu bar.

— Right-click on the selected characters and select Character from the context menu.

 4) Make your formatting changes to the selected characters using the options available in the 
tabbed pages of the Character dialog.

 5) Click OK to save your changes and close the dialog.

 6) Alternatively, use the tools available on the Text Formatting toolbar (Figure 1 on page 5) or
the Character section in the Properties deck on the Sidebar to format the characters.

 7) To cancel any changes you have made to the character format, click Reset in the 
Character dialog or go to Format > Clear Direct Formatting on the main menu bar and 
the characters revert back to the original paragraph formatting.

14 | Adding and Formatting Text



Figure 14: Character dialog

Character formatting options
The formatting options in the tabbed pages of the Character dialog are used as follows:

• Font – select the desired font type, its base attributes (Italic, Bold, Language, and so on) as
well as the size. A sample of the font is displayed in the lower part of the dialog. This font 
page is also available when creating or modifying a graphics style.

If support for Asian language and Complex Text Layout (CTL) has been enabled (Tools > 
Options > Language Settings > Languages), then the Font page is divided into three 
parts for Western, Asian, and CTL text fonts allowing you to specify text fonts and their 
attributes for the majority of font families.

• Font Effects – apply special effects to the text (Font Color, Text Decoration and Effects). A 
sample of the text is displayed in the lower part of the dialog as a quick visual check of the 
effects applied. This page is also available when creating or modifying a graphics style.

• Position – select the type of position, scaling and spacing applied to text. This page is not 
available when creating or modifying a graphics style.

— Position – sets the text position relative to the baseline when you need to insert 
subscripts or superscripts. 

— Scaling – specifies the percentage of the Scale width (font width) by which to compress 
or expand the individual characters of the selected text.

— Spacing – sets the spacing between the characters of the font, which can be defined in 
number of points.
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— Pair kerning – automatically adjusts the spacing between certain pairs of characters to 
visually improve the appearance.

• Highlighting – sets the color used when you highlight text.

Direct paragraph formatting
Any individual or direct paragraph formatting will override any formatting that has been applied 
using a drawing object style.

 1) Click on text where you want to format paragraphs. The Text Formatting toolbar (Figure 1 
on page 5) automatically opens replacing the Line and Filling toolbar.

 2) Select the paragraph you want to format. For more information about selecting text, see 
“Selecting text” on page 13.

 3) Use one of the following methods to open the Paragraph dialog (Figure 15):

— Go to Format > Paragraph on the main menu bar.

— Click the Paragraph icon on the Text Formatting toolbar (Figure 1 on page 5).

— Right-click on the selected text and select Paragraph from the context menu.

 4) Make your formatting changes to the selected paragraph using the options available in the 
tabbed pages of the Paragraph dialog.

 5) Click OK to save your changes and close the dialog.

 6) To cancel any changes you have made to the paragraph format, click Reset in the 
Paragraph dialog and the paragraph revert back to the original formatting.

 7) Alternatively, use the tools available on the Text Formatting toolbar (Figure 1 on page 5) or
the Paragraph section in the Properties deck on the Sidebar to format the paragraphs.

Figure 15: Paragraph dialog - Indents & Spacing page
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Paragraph formatting options
The formatting options for the tabbed pages of the Paragraph dialog (Figure 15) are as follows:

• Indents and Spacing (Figure 15) – determines the indents and spacing used in a 
paragraph.

— Indent – modifies the indentation of the text (before and after) as well as the indentation
of the first line.

— Spacing – defines the space before and after each paragraph formatted with the style.

— Line spacing – determines the spacing between two lines formatted with the style. Note 
that selecting Proportional spacing requires specifying the percentage of a line to be 
used as spacing; 100% single line, 200% double line, 50% half a line. If Leading is 
selected, specify the amount of line spacing in your default unit of measurement.

Tip

You can change the default unit of measurement by going to Tools > Options > 
LibreOffice Draw > General on the main menu bar.

• Asian Typography (Figure 16) – sets the following properties relative to line changes and 
is only available if the Asian option is selected in Tools > Options > Language Settings > 
Languages on the main menu bar.

— Apply list of forbidden characters to the beginning and end of lines.

— Allow hanging punctuation.

— Apply spacing between Asian and non-Asian text.

• Tabs (Figure 17) – determines the Position, Type and Fill Character of tab stops. This page 
is also available in the Graphics Styles dialog.

• Alignment (Figure 18) – determines paragraph alignment.  A preview shows the effects of 
the changes. Paragraph alignment can also be carried out using the alignment icons on the
Text Formatting toolbar and the Paragraph section on the Properties deck of the Sidebar.

• Options – sets the paragraph alignment depending on the option selected.

• Text-to-text – sets vertical alignment of text when there is a mix of font sizes on the same 
line of text. The options are Automatic, Base line, Top, Middle and Bottom.

• Properties – sets the text direction. Left-to-right (LTR) and Right-to-left (RTL) are only 
available if Complex text layout language has been selected.

Figure 16: Paragraph dialog - Asian Typography page

Formatting text | 17



Figure 17: Paragraph dialog - Tabs page

Figure 18: Paragraph dialog - Alignment page

Using graphic styles

Applying the same format options to a Draw object or text is a repetitive process that can be 
greatly simplified by the use of styles. Graphic styles in Draw allow you to define a formatting 
template (a style) and then apply that style to several graphic or text objects.

For more information on graphic styles for graphic settings such as area or border lines, see 
Chapter 4 Changing Object Attributes in this guide. For more information on text styles see the 
Writer Guide.

Draw has several styles readily available for use with objects and text. These default styles cannot 
be deleted or renamed, but can be modified using the various options available in the Graphic 
Styles dialog (Figure 19).
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Figure 19: Graphic Styles dialog - Organizer page

Figure 20: Styles deck in Sidebar

Linked styles
The styles in Draw support inheritance. This means that a style can be linked to another (parent) 
style so that it inherits all the formatting settings of the parent. You can use this property to create 
hierarchical  or families of styles. Figure 20 shows an example of linked or hierarchical styles used 
in Draw.

For example, if you need multiple blocks of text that differ in size, but are otherwise identically 
formatted, it is recommended to create a generic style for the type of font, style of font, and so on. 
You then create a number of hierarchically dependent styles which differ only in the font size. If you
then need to change the font style, it is sufficient to change the parent style and all the other linked 
styles will change accordingly.
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Note

When styles are linked, changing a font attribute will change the font attribute in all 
descendant linked styles. Sometimes this is exactly what you want; at other times you 
do not want the changes to apply to all linked styles. It pays to plan ahead.

Creating new styles
After creating a new style, it will be placed All Styles and Custom Styles in the Styles deck of the 
Sidebar (Figure 20). When your new style is applied to an object or text, the new style will also 
appear in Applied Styles.

 1) Carry out all the formatting changes to the selected text, then use one of the following 
methods to create a new style:

— Go to Format > Styles > New Style from Selection on the main menu bar to open the
Graphic Styles dialog (Figure 19 on page 19).

— Right click on a style name in the Styles deck on the Sidebar (Figure 20) and select 
New from the context menu.

— Click on the New Style from Selection icon on the Styles deck in the Sidebar (Figure
20) to open the Graphic Styles dialog (Figure 19 on page 19).

 2) If using the Graphics Style dialog, proceed as follows:

a) Click on the Organizer tab to open the Organizer page (Figure 19 on page 19).

b) Enter a unique name for your style in Name.

c) If you are NOT linking the new style to another style in your drawing, select None from 
the drop down list in Inherit from.

d) If you are linking the new style already created in your drawing, select the style name 
from the drop down list in Inherit from.

e) Click OK to save your changes and close the dialog.

 3) If you have clicked on the New Style from Selection icon on the Styles deck in the 
Sidebar (Figure 20), enter a style name in the Create Style dialog (Figure 21) that has 
opened. Click OK to close this dialog and save your changes.

Figure 21: Create Style dialog
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Modifying or editing styles
It is recommended to only modify or edit styles that you have created.

 1) Select text or an object with text in your drawing. The Text Formatting toolbar (Figure 1 on 
page 5) automatically opens replacing the Line and Filling toolbar.

 2) Open the Graphic Styles dialog (Figure 19 on page 19) using one of the following 
methods:

— Go to Format > Styles > Edit Style on the main menu bar.

— Right click on the object and select Edit Style from the context menu.

— Right click on the object style in the Styles deck on the Sidebar (Figure 20 on page 19) 
and select Modify from the context menu.

 3) Use the various pages and available options in the Graphic Styles dialog to modify and 
edit the style as follows:

— Organizer – shows the style name, the style name where settings have been inherited 
from, style category and the settings for the style it contains.

— Font, Font Effects, Indents & Spacing, Alignment, and Tabs – set the properties of the 
text inserted in a text box or in a graphic object.

— Dimensioning – used to set the style of dimension lines.

— Text, Text Animation, Connector, Line, Area, Shadowing, Highlighting and Transparency
– determines the formatting of an object.

 4) Click OK when finished to save your changes and close the Graphic Styles dialog.

 5) Alternatively, select your text and perform all the formatting changes, then proceed as 
follows:

a) Select a style in Styles deck on the Sidebar (Figure 20 on page 19).

b) Click on the Update Style icon and the style is saved with the new format attributes.

Editing linked styles
If you have an object in your document that uses linked styles then it is possible to edit the linked 
styles that have been applied to the object using the Graphic Styles dialog as follows:

 1) Select text or an object with text in your drawing that uses linked styles. The Text 
Formatting toolbar (Figure 1 on page 5) automatically opens replacing the Line and 
Filling toolbar.

 2) Open the Graphic Styles dialog (Figure 19 on page 19) using one of the following 
methods:

— Go to Format > Styles > Edit Style on the main menu bar.

— Right click on the object and select Edit Style from the context menu.

— Right click on the object style in the Styles deck on the Sidebar (Figure 20 on page 19) 
and select Modify from the context menu.

 3) Click on the Organizer tab to open the Organizer page in the Graphic Styles dialog.

 4) Check that the style name in the Inherit from text box is the linked style you want to edit.

— If the linked style is the one you want to edit, use the various pages in the Graphic 
Styles dialog to edit the style.

— If the linked style is NOT the one you want to edit, click on Edit Style to the right of the 
Inherit from text box until the name of the linked is displayed. Use the various pages in 
the Graphic Styles dialog to edit the style.
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 5) Click OK when finished to save your changes and close the Graphic Styles dialog.

Applying styles
You can apply a style to text in a text box or in an object as follows:

 1) Select the text where you want to apply a style. The Text Formatting toolbar (Figure 1 on 
page 5) automatically opens replacing the Line and Filling toolbar.

 2) Click on the Styles icon on the Sidebar to open the Styles deck (Figure 20 on page 19).

 3) Select the style name you want to use in the Styles deck on the Sidebar.

 4) Double click on the style name in the Styles deck on the Sidebar to apply the style to the 
selected object.

Tip

At the bottom of the Styles deck on the Sidebar there is a drop-down list. Choose to 
show all styles or groups of styles such as Applied Styles or Custom Styles.

Deleting styles
You cannot delete any of the predefined styles in LibreOffice, even if you are not using them. You 
can only delete user-defined (custom) styles. However, before you delete a custom style, make 
sure the style is not in use. To see which styles are in use, choose Applied Styles from the drop-
down list at the bottom of the Styles deck on the Sidebar.

Delete a custom style as follows:

 1) Click on the Styles icon on the Sidebar to open the Styles deck (Figure 20 on page 19).

 2) Select Applied Styles or Custom Styles from the drop down list at the bottom of the Styles 
deck on the Sidebar to display the styles in use.

 3) Right click on the style name in the styles list and select Delete from the context menu.

 4) If the style is in use, a warning message will appear. Click Yes to delete the style. If the 
style is not in use, no confirmation message appears.

Creating bulleted and numbered lists

Bulleted and numbered lists can be created in text boxes, shapes, and objects. However, when 
creating lists in shapes and objects, remember that shapes and objects are not dynamic and do 
not automatically expand as you create a list.

Note

Creating bulleted or numbered lists in Draw is similar to LibreOffice Writer, but the 
functionality in Draw has been reduced.

Creating lists
Bulleted or numbered lists can be created using text boxes or Draw objects as follows:

 1) Click on text where you want to create a bulleted list. The Text Formatting toolbar (Figure
1 on page 5) automatically opens replacing the Line and Filling toolbar.

 2) Select all of the text you want to use in a bulleted or numbered list.

22 | Adding and Formatting Text



 3) A bulleted or numbered list is created using one of the following methods and default 
settings for lists:

— Click on Toggle Bullet List or Toggle Numbered List icons on the Text Formatting 
toolbar.

— Click on Toggle Bullet List or Toggle Numbered List icons in the Lists section on the 
Properties deck of the Sidebar.

— Go to Format > Lists > Bulleted List or Numbered List on the main menu bar.

 4) To change the format of the list as you create it, click on the small triangle on the right of 
the list icons and select a list style from an option in the pop up window (Figures 22 and
23).

Figure 22: More bullet lists Figure 23: More number lists

Adjusting list item levels
Each list item in a bulleted or numbered list can have its level adjusted within a list as follows:

 1) Click at the beginning of a list item to position the flashing cursor at the correct position. 
The flashing cursor must be at the beginning of the list item to demote or promote the list 
item in a list.

 2) To demote the position of the list item, press the Tab  key. Each press of the Tab key will 
demote the list item down one more level in the list.

 3) To promote the position of the list item, press use the key combination Shift+Tab . Each 
press of the Shift+Tab  key combination will promote the list item up one more level in the 
list.

Editing and customizing a list
You can edit and customize the appearance of a list by changing the bullet type or numbering for 
the entire list or a single entry or the outline level of a list item. All changes are made using the 
Bullets and Numbering dialog.

 1) Select the list items you want to edit and customize. The Text Formatting toolbar (Figure 1
on page 5) automatically opens replacing the Line and Filling toolbar.

 2) To open the Bullets and Numbering dialog (Figure 24), go to Format > Bullets and 
Numbering on the main menu bar, or right-click on the selected text and select Bullets 
and Numbering from the context menu.

 3) Select the Level you want to edit and customize.

 4) Change various options in Properties, Separator, Size, Position, and Scope to format the
list style for each level in the list. The Preview box shows how your list will look as you 
make a selection.
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Figure 24: Bullets and Numbering dialog

 5) To cancel any changes you have made, click Reset. The list reverts back to its original 
formatting.

 6) When you are satisfied with your list, click on OK to save your changes and close the 
dialog.

List format options
The following options are available in the Bullets and Numbering dialog (Figure 24).

• Level – sets the outline level of list items from the left hand side of the page. Each level 
can be set to a different type of list. Select Levels 1 – 10 to modify simultaneously all levels
in a list.

• Properties – sets how each list item looks in the list.

— Type – sets the type of list marker used (alpha, numeric or image).

— Color – selects the color used for the list marker so that it stands out from the text in the
list item.

— Start at – enter the first value of the list marker (for example, you might want the list to 
start at 4 instead of 1).

• Separator – allows you to set what characters are used to separate the list marker from the
text in the list item.

— Before – enter any text to appear before the list marker (for example, Step)

— After – enter any text to appear after the list marker (for example, a punctuation mark)
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• Size – specifies the size (Rel. size) of the list marker relative to the size of the characters in
the list item. This can be larger or smaller than the text size used for the list item. In case of
a graphic as bullet, the size is the absolute size of the graphic. The checkbox “Keep ratio” 
connects width and height, so entering one value calculates the other automatically.

• Position – allows you to set the indentation and spacing of list markers and the list items.

— Indent – sets the indentation of the list marker from the left side of the text box or 
object.

— Width – sets the indentation distance of the text from the list marker creating a hanging 
indent, which is normal for bulleted or numbered lists.

— Relative – if checked, the indent of the list item is measured relative to the settings of 
the parent level when linked styles are used.

— Alignment – sets the alignment (left, center or right) of a list marker inside the area, 
which is defined by Width. This is useful when using a numeric list marker that will 
consist of two or more characters to maintain correct spacing between the list marker 
and list item.

• Scope

— Slide – applies any changes to all items in your drawing.

— Selection – applies any changes only to the selected items in your drawing.

— Apply to Master – applies any changes to any items in the master page of your drawing,
if you have created a master page.

Adjusting list item levels
Each list item in a bulleted or numbered list can have its level adjusted within a list as follows:

 1) Click at the beginning of a list item to position the flashing cursor at the correct position. 
The flashing cursor must be at the beginning of the list item to demote or promote the list 
item in a list.

 2) To demote the position of the list item, press the Tab  key. Each press of the Tab key will 
demote the list item down one more level in the list.

 3) To promote the position of the list item, press use the key combination Shift+Tab . Each 
press of the Shift+Tab  key combination will promote the list item up one more level in the 
list.

Using tables

Tables are useful when you want to show structured information in your drawing, for example a 
specification list or drawing title block. You can create tables directly in Draw, eliminating any need 
to embed a Calc spreadsheet or a Writer text table in your drawing. The tables provided by Draw 
do have a limited functionality.

Creating tables
When working with tables, it is useful to know the number of rows and columns required as well as 
the appearance. Tables are placed at the center of a drawing and cannot be placed into objects or 
shapes. Also, unlike text boxes and other objects, tables cannot be rotated.

 1) Go to Insert > Table on the main menu bar to open the Insert Table dialog (Figure 25).

 2) Select the required number of columns and rows for the table.
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Figure 25: Insert Table dialog

Figure 26: Insert table 
grid

 3) Click OK to place a table in the center of your drawing and close the dialog.

 4) Alternatively, click on the Table icon on the Standard toolbar to open the Table grid (Figure
26).

 5) Click and drag the cursor until you have the required number of columns and rows, then 
click again. A table is placed at the center of your drawing and the Table grid closes.

 6) Move the table into position by dragging it to its new position, see “Moving text boxes” on 
page 7 for more information.

Table toolbar
The Table toolbar (Figure 27) contains the majority of the tools you need to edit a table and is only 
active and visible when a table is selected. If the Table toolbar does not display when you select a 
table, go to View > Toolbars > Table on the main menu bar.

Normally, the Table toolbar is docked at the top or bottom of your workspace. To make the toolbar 
into a floating toolbar:

• If the toolbar is docked in a horizontal position, click at the left end of the toolbar and drag 
the toolbar onto the workspace.

• If the toolbar is docked in a vertical position, click at the top of the toolbar and drag the 
toolbar onto the workspace.
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Figure 27: Table toolbar and Visible Buttons

Modifying tables
Once the table is added to your drawing, you can control its appearance, size, position, and so on 
using a combination of the tools that are available in Draw.

• Table – creates a new table in a drawing. Opens the Insert Table dialog (Figure 25 on 
page 26) where you can select the required number of rows and columns.

Alternatively, click on the small triangle next to the Table icon to open a graphic 
representation for creating a table (Figure 27). To use this tool, move the mouse to the right
and down in the grid until you have the columns and rows you require and click the left 
mouse button. Clicking on More Options opens the Insert Table dialog.

• Border Style – changes the line style of the borders of selected cells. Click on the small 
triangle next to the Border Style icon to open a drop down list where you can choose from 
a range of predefined styles.

• Border Color – changes the color of the borders of selected cells. Click on the small 
triangle next to the Border Color icon to open a drop down list where you can choose a 
color from a range of predefined palettes or create a custom color.

• Borders – selects predefined border configurations of selected cells. Click on the small 
triangle next to the Borders icon to open a drop down list where you can choose the border
configuration.

• Area Style/Filling – select the cells to be filled, then select the type of fill from the drop-
down list: None, Color, Gradient, Hatching, or Bitmap. The fillings drop-down menu then 
shows the available fillings for the selected area fill type.
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• Merge Cells – merges the selected cells into one cell. Note that the contents of the merged
cells are also merged. You can also merge cells by right-clicking in the selected cells and 
selecting Merge Cells from the context menu that opens.

• Split Cells – make sure that the cursor is positioned on a cell you want to split, then click to
open the Split Cells dialog (Figure 28). Select the number of cells required from the split as
well as whether the cell should be split horizontally or vertically. When splitting horizontally, 
you can select the Into equal proportions option to get cells of equal size. The contents of 
the split cell remain in the original cell (the one on the left or top).

• Optimize – evenly distributes the selected cells either horizontally or vertically. Click on the 
small triangle next to the Optimize icon to open a drop down list where you can choose 
from a range of predefined options to optimize the selected cells.

• Align Top, Center Vertically, Align Bottom – you can select the vertical alignment of text 
in a cell by selecting the required cells and clicking on one of these tools.

Figure 28: Split Cells dialog

Figure 29: Table Design section in 
Sidebar Properties
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• Insert Row Above, Insert Row Below, Insert Column Before, Insert Column After –  
select a row or column and use these four tools to insert a row or column.

• Delete Row, Delete Column – select rows or columns and use these tools to delete 
selected rows and columns from your table.

• Select Table, Select Column, Select Row – select a table, column, or row if you want to 
perform the same change to attributes for a table, column, or row.

• Table Design – opens the Table Design section (Figure 29) in the Properties deck on the 
Sidebar where you can select design and display options for your table.

• Table Properties – opens the Table Properties dialog, which contains the following tabbed
pages. You can also open this dialog by right-clicking on the table and selecting Table 
Properties from the context menu.

— Font (Figure 30) – select the desired font type and family, style (Italic, Bold, etc.), size, 
and language. A sample of the font is displayed in the lower part of the dialog.

— Font Effects (Figure 31) – use to apply options in Font Color, Text Decoration and 
Effects to text.

— Borders (Figure 32) – use to apply options in Line Arrangement (presets and user 
defined for borders), Padding (cell margins for contents) and Line (style, color and 
width of borders).

— Background (Figure 33) – changes the background of selected cells and provides the 
same functions as the Area dialog (see Chapter 4 Changing Object Attributes for more 
information).

— Reset – clicking this button resets the Table Properties dialog back to its original 
options.

Figure 30: Table Properties dialog - Font page
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Figure 31: Table Properties dialog - Font Effects page

Figure 32: Table Properties dialog - Borders page
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Figure 33: Table Properties dialog - Background page

Position and size
On a drawing, you can change position and size of  a table. However, the  table cannot be rotated 
or sheared. See “Moving, resizing, rotating and formatting text boxes” on page 7 for more 
information.

Deleting tables

Whole table
Make sure the whole table is selected and the selection handles are visible, then delete the whole 
table using one of the following methods:

• Select Delete Row or Delete Column on the Table toolbar (Figure 27 on page 27).

• Right click and select Delete > Delete Row or Delete Column in the context menu.

Row or column
Click in a table cell, then delete the table row or column using one of the following methods. The 
table selection handles will not be displayed.

• Select Delete Row on the Table toolbar (Figure 27 on page 27) to delete the row that is 
selected.

• Right click and select Delete > Delete Row in the context menu to delete the row that is 
selected.

• Select Delete Column on the Table toolbar (Figure 27 on page 27) to delete the column 
that is selected.

• Right click and select Delete Column in the context menu to delete the column that is 
selected.

Cell contents
Delete cell contents in a table as follows:

 1) Select the cell (or cells) contents.

 2) Press the Delete  or Backspace  key on the keyboard.
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Using fields

Fields allow the automatic insertion of text into a drawing. You can think of a field as a kind of 
formula which is calculated when the drawing is loaded or printed and the result is displayed in the 
drawing.

Inserting fields
A text box is created when you insert a field and can be repositioned just like any other text box. 
See “Text” on page 5 for more information.

 1) Move the cursor where the field will be positioned.

 2) Go to Insert > Field on the main menu bar.

 3) Select a field from the options shown in the context menu.

The fields available in Draw are as follows:

• Date (fixed) – inserts the current date when the field was inserted.

• Date (variable) – inserts a field that is updated with the date each time the file is opened.

• Time (fixed) – inserts a field displaying the current time when the field was inserted.

• Time (variable) – inserts a field which is updated with the time each time the file is opened.

• Author – inserts the author of the drawing. This information is derived from the value 
recorded in the general options. To modify this information go to Tools > Options > 
LibreOffice > User Data on the main menu bar.

• Page Number – inserts the page number for each page in a multi page drawing.

• Page Title – inserts a page name for each page in a drawing.

• Page Count – inserts the total number of pages in a drawing.

• File Name – inserts a field that contains the name of the file.

Customizing fields
The appearance of fields can be customized as follows. Page Number, Page Count and Page 
Title fields cannot be customized.

 1) Place the cursor at the start of the field data and go to Edit > Fields on the main menu bar 
to open the Edit Field dialog (Figure 34).

 2) Select the desired format from the available options.

 3) Click OK to save the changes and close the dialog.

 4) Alternatively, right-click on the field and select the required options from the context menu.

Figure 34: Edit Field dialog
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Figure 35: Hyperlink dialog

Using hyperlinks

When inserting text that can be used as a hyperlink (for example website address or URL), Draw 
formats it automatically, creating the hyperlink and applying color and underlining.

Inserting hyperlinks
 1) Click in the text box at the position where you want to insert a hyperlink.

 2) Go to Insert > Hyperlink on the main menu bar, or use the keyboard shortcut Ctrl+K to 
open Hyperlink dialog (Figure 35).

 3) Select the type of hyperlink you want to insert and the options you want to use.

 4) Click Apply to insert the hyperlink and save your selections. If you are creating several 
hyperlinks, click Apply after each one.

 5) Click Close or OK to save your changes and close the Hyperlink dialog.

On the left side, select one of the four types of hyperlinks. The dialog changes according to the 
type of hyperlink selected.

• Internet – select whether the link is Web or FTP. Enter the required web address (URL).

• Mail – enter the details for the email, also the subject.

• Document – creates a hyperlink to another document or to another place in the drawing, 
commonly referred to as a bookmark.

— Enter the document path, or click on the Open File icon to open a file browser. Leave 
this blank if you want to link to a target in the same drawing.

— Optionally, you can specify a target (for example. a specific slide). Click on the Target 
icon to open the Target in Document dialog, where you can select the target, or, if you 
know the name of the target, you can type it into the box.
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• New Document – creates a hyperlink to a new document.

— Select Edit now to edit the newly created document immediately or Edit later to create 
a new document and edit it later.

— Choose the type of document to create (text, spreadsheet, etc.).

— The Select path icon opens a file browser so that you can choose the directory for the 
new document.

Tips

To prevent LibreOffice from automatically turning website addresses (URLs) into 
hyperlinks, go to Tools > AutoCorrect > Options and deselect the URL Recognition 
checkbox.

To change the color of hyperlinks, go to Tools > Options > LibreOffice > Application
Colors. In Custom Colors scroll to Unvisited links and/or Visited links, select the 
checkboxes, pick the new colors and click OK. Caution: this will change the color for 
all hyperlinks in all components of LibreOffice which may not be what you want.

The Further Settings section on the Hyperlink dialog is common to all the hyperlink types, 
although some choices are more relevant to some types of links.

• Frame – determines how the hyperlink will open. This applies to documents that open in a 
Web browser.

• Form – specifies if the link is to be presented as text or as a button. See “Working with 
hyperlink buttons” on page 28 for more information.

• Text – specifies the text that will be visible to the user.

• Name – applicable to HTML documents. It specifies text that will be added as a NAME 
attribute in the HTML code behind the hyperlink.

Editing text hyperlinks
 1) Select the hyperlink.

 2) Go to Edit > Hyperlink on the main menu bar to open the Insert Hyperlink dialog (Figure
35).

 3) Make your editing changes from the available options, then click Apply when done. If you 
need to edit several hyperlinks, click Apply after each one. 

 4) Click Close or OK to save your changes and close the dialog.

Image maps
An image map defines areas of an image (called hotspots) with hyperlinks to web addresses, other
files on the computer, or parts of the same document. Hotspots are the graphic equivalent of text 
hyperlinks. Clicking on a hotspot causes LibreOffice to open the linked page in the appropriate 
program (for example, the default browser for an HTML page; LibreOffice Calc for a ODS file; a 
PDF viewer for a PDF file). You can create hotspots of various shapes and include several 
hotspots in the same image.

To use the ImageMap Editor (Figure 36):

 1) In your Draw document, select an image in which you want to create a hotspot.
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Figure 36: ImageMap Editor

 2) Go to Tools > ImageMap on the main menu bar to open the ImageMap Editor.

 3) Select the type of hotspot area you want use from the icons at the top of the ImageMap 
Editor – Rectangle, Ellipse, Polygon, Freeform Polygon.

 4) Draw the hotspot area onto the selected image.

 5) Enter the address pointed by the hyperlink in the Address: text box using the address 
format: file:///<path>/document_name#anchor_name.

 6) Click the Apply icon to apply the settings.

 7) When done, click the Save icon to save the image map to a file, then close the ImageMap 
Editor.

The main part of the ImageMap Editor shows the image on which the hotspot is defined. A hotspot
is indicated by an outline of the type of hotspot shape used.

The ImageMap Editor contains the following tools:

• Apply icon – applies the changes.

• Open, Save, and Select icons.

• Hotspot shapes: Rectangle, Ellipse, Polygon, Freeform Polygon.

• Edit Points, Move Points, Insert Points and Delete Points icons: advanced editing tools 
to manipulate the shape of a polygon hotspot. Select Edit Points to activate the other 
icons.

• Undo and Redo icons 

• Active icon – toggles the status of a selected hotspot between active and inactive.

• Macro icon – associates a macro with the hotspot instead of just associating a hyperlink.

• Properties icon – sets the hyperlink properties and adds the Name attribute to the 
hyperlink.

• Address: text box – address pointed to by the hyperlink. You can also point to an anchor in
a document.
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• Text: text box – type the text that you want to be displayed when the mouse pointer is 
moved over the hotspot.

• Frame: – where the target of the hyperlink will open and the option available is _self (opens
in the active browser window).

Fontwork

With Fontwork you can create graphical text art objects to make your work more attractive. There 
are many different settings for text art objects (line, area, position, size, and more), so you have a 
large choice.

Fontwork is also available with the Writer, Calc, and Impress modules of LibreOffice, but you will 
notice small differences in the way that each component displays it.

Figure 37: Fontwork Gallery dialog

Figure 38: Editing Fontwork text
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Creating Fontwork
 1) Click on the Fontwork icon on the Drawing or Standard toolbar or go to Insert > 

Fontwork on the main menu bar to open the Fontwork Gallery dialog (Figure 37).

 2) Select a Fontwork style from the dialog and click OK. The selected Fontwork appears in 
your drawing and the dialog closes.

 3) Double-click on the word Fontwork to switch on editing mode.

 4) Type your own text to replace the word Fontwork and your text appears over the word 
Fontwork as shown in Figure 38.

 5) Press the Esc  key or click outside the selected area and your text replaces the word 
Fontwork.

Fontwork toolbar
The Fontwork toolbar (Figure 39) becomes visible and active on the workspace when you select a
Fontwork object. If the toolbar is not visible, go to View > Toolbars > Fontwork on the main menu 
bar.

Figure 39: Fontwork toolbar and 
Visible Buttons

The Fontwork toolbar contains the following tools:

• Fontwork Style – opens the Fontwork Gallery dialog (Figure 37).

• Fontwork Shape – changes the shape of the selected object. Shapes available are shown 
in Figure 40.

• Fontwork Same Letter Heights – changes the height of characters in the selected 
Fontwork object. Toggles between normal height where the characters have different 
heights to where all characters have the same height.

• Fontwork Alignment – specifies the text alignment within the frame. Options available are 
left align, center, right align, word justify, and stretch justify. The effects of the text alignment
can only be seen if the text spans over two or more lines. In the stretch justify mode, all 
lines are filled completely.

• Fontwork Character Spacing – selects the spacing between characters and whether 
kerning pairs should be used. Options available are very tight, tight, normal, loose, very 
loose and custom spacing. For custom spacing, input a percentage value: 100% is normal 
character spacing, less than 100% character spacing is tighter, and more than 100% 
character spacing is looser.

• Toggle Extrusion – converts the Fontwork object into a 3D shape using extrusion. See 
Chapter 7 – 3D Objects for more information.
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Figure 40: Fontwork shapes

Modifying Fontwork
A Fontwork object can be treated like any other object in Draw. It can be resized, rotated, skewed, 
slanted, flipped, and so on. For more information on modifying a Fontwork object, see Chapter 3 – 
Working With Objects, Chapter 4 – Changing Object Attributes and Chapter 5 – Combining 
Multiple Objects.

It is possible to treat Fontwork text as an object and apply all the formatting that has been 
described in this chapter. Assign line properties only to Fontwork which does not have a 3D effect, 
otherwise the changes will not be visible.

You can modify some of the Fontwork shapes just as you modify the angles of trapezoid and 
parallelogram basic shapes by moving the dot that is displayed along with the selection handles.
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