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Introduction

This chapter describes how to create and maintain a table of contents (TOC), an index, and a 
bibliography for a text document using LibreOffice Writer. To understand the instructions, you need 
to have a basic familiarity with Writer and styles (see Chapters 8 and 9). Some common usage 
examples are given.

Tables of contents

Writer’s table of contents feature lets you build an automated TOC from the headings in a 
document. These entries are automatically generated as hyperlinks in the table. Whenever 
changes are made to the text of a heading in the body of the document or the page on which the 
heading appears, those changes automatically appear in the table of contents when it is next 
updated.

Before you start, make sure that the headings are styled consistently. For example, you can use 
the Heading 1 style for chapter titles and the Heading 2 and Heading 3 styles for chapter 
subheadings.

This section shows you how to:

• Create a table of contents quickly, using the defaults.

• Customize a table of contents.

Note

You can use any style you want for the different levels to appear in the table of 
contents; however, for simplicity, most of this chapter uses the default Heading [x] 
styles.

Creating a table of contents quickly
Most of the time you will probably find the default table of contents (TOC) to be what you need. 
Inserting a default TOC is simple:

 1) When you create a document, use the following paragraph styles for different heading 
levels (such as chapter and section headings): Heading 1, Heading 2, and Heading 3. 
These are what will appear in your TOC. Writer can evaluate up to ten levels of headings.

 2) Click in the document where you want the TOC to appear.

 3) Choose Insert > Table of Contents and Index > Table of Contents, Index or 
Bibliography.

 4) Click OK. The result will be a typical table of contents with the entries generated as 
hyperlinks.

Some tips you may find useful:

• If some of your headings do not show up in the table of contents, check that the headings 
have been tagged with the correct paragraph style. If a whole level of headings does not 
show up, check the settings in Tools > Chapter Numbering. See “Defining a hierarchy of 
headings” in Chapter 8, Introduction to Styles, for more information.

• The TOC appears with a gray background. This background is there to remind you that the 
text is generated automatically. It is not printed and does not appear if the document is 
converted to a PDF. To turn off this gray background, go to Tools > Options > LibreOffice 
> Application Colors, then scroll down to the Text Document section and deselect the 
option for Index and table shadings.
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This change may leave a gray background showing behind the dots between the headings 
and the page numbers, because the dots are part of a tab. To turn that shading off, go to 
Tools > Options > LibreOffice Writer > Formatting Aids and deselect the option for 
Tabs.

• If you cannot place the cursor in the TOC, choose Tools > Options > LibreOffice Writer >
Formatting Aids, and then select Enable cursor in the Protected Areas section.

If you add or delete text (so that headings move to different pages) or you add, delete, or change 
headings, you need to update the table of contents. To do this: Right-click anywhere in the TOC 
and select Update Index from the context menu.

Caution

If you have Edit > Track Changes > Show enabled when editing a document and you
update the TOC, then errors may occur, as the TOC will still include any deleted 
headings and you may find that deleted text causes page numbering in the TOC to be 
wrong. To avoid this problem, be sure this option is deselected before updating a TOC.

Customizing a table of contents
Almost every aspect of the table of contents can be customized to suit the style and requirements 
of your document. However, with this flexibility also comes some complexity, so it is good to have 
in mind the desired end result.

Start by clicking in the document where you want the table of contents to appear and choose 
Insert > Table of Contents and Index > Table of Contents, Index or Bibliography to open the 
Table of Contents, Index or Bibliography dialog shown in Figure 1.

Figure 1: Type page of Table of Contents, Index or Bibliography dialog

You can also access this dialog at any time by right-clicking anywhere in an existing table of 
contents and choosing Edit Index from the context menu.
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The Table of Contents, Index or Bibliography dialog has five pages. Each of them covers a different
aspect of the TOC structure and appearance:

• Use the Type page to set the attributes of the TOC.

• Use the Entries and Styles pages to format the entries in the TOC.

• Use the Columns page to put the TOC into more than one column.

• Use the Background page to add color or an image to the background of the TOC.

You can display a preview box, located on the left-hand side of each page, to show as you work 
how the TOC will look: select the Preview option in the lower left-hand corner of the dialog. The 
illustrations in this chapter show the dialog as it appears with the preview box hidden.

Note

The preview box only shows the appearance from settings made on the Type, Entries, 
and Styles pages. The other pages have their own preview panes.

After making all your changes, click OK to apply them. To revert to the default settings for the 
Columns and Background pages, select each page in turn and click the Reset button. The settings
on the Entries and Styles pages must be reset manually; the Reset button has no effect.

Type page
Use the Type page, pictured in Figure 1, to set the attributes of the TOC.

Changing the title
To give the table of contents a different title, type it in the Title field. To delete the title, clear 
the Title field.

Setting the type 
Be sure the Type is set to Table of Contents. See “Alphabetic indexes” on page 14 and 
“Other types of indexes” on page 22 for more about creating other types of indexes.

Note

You can change the type of index only when you first create it. Once you define an 
index type (for example, make a table of contents) you cannot change the type.

Protecting against manual changes
By default, to prevent the TOC from being changed accidentally, the Protected against 
manual changes option is selected; the TOC can only be changed by using the right-click 
menu or the dialog. If the option is not selected, the TOC can be changed directly on the 
document page, just like other text. However, any manual changes will be lost when you 
update it.

Choosing the scope of the table of contents
In the For drop-down list in the Create from area, you can select whether the TOC will cover 
all the headings of the document (Entire document) or just the headings of the chapter where
it is inserted. Writer identifies a “chapter” as all the headings between two first level outline 
headings (normally Heading 1).

Changing the number of levels included
Writer uses 10 levels of headings when it builds the table of contents (or the number of levels
used in the document, whichever is smaller). To change the number of levels included, enter 
the required number in the Evaluate up to level box. For example, the TOC in this book 
includes only the first four heading levels.
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Creating a table of contents from an outline
The third section of the Type page determines what Writer should use to create the TOC. The
choices (not mutually exclusive) are:

– Outline

– Additional styles

– Index marks

By default Writer uses the outline levels; that is, paragraphs formatted with the paragraph 
styles associated with outline levels in Tools > Chapter Numbering. 

You can change the paragraph styles included in the outline as described in “Using 
paragraph styles to define a hierarchy of headings” in Chapter 8, Introduction to Styles, and 
you can include other paragraph styles in the TOC by assigning an outline level to those 
styles. To do this, modify the paragraph style definition: go to the Outline & Numbering page 
for the style, and select the required outline level. Click OK to save the change.

Figure 2: Specifying an outline level on the Outline & Numbering page for a paragraph style

Creating from additional styles
By selecting the Additional Styles option on the Type page, you can add more paragraph 
styles to the TOC. This can be useful when you want to include in the TOC the heading of an 
annex (appendix). If the Outline option is also selected, the additional styles will be included 
in the table of contents together with the ones defined in the outline numbering.

Creating from index marks
This selection adds any index entries that you have inserted into the document by using 
Insert > Indexes and Tables > Entry. Normally you would not use this selection for a table 
of contents. However, if you do wish to use it, be sure to select Table of Contents from the 
drop-down list in the Insert Index Entry dialog (see Figure 8) when you are entering the index
entries for use in a TOC, so that Writer can distinguish between them and any index entries 
intended for inclusion in an alphabetic index.

Entries page
Use the Entries page (see Figure 3) to define and format the entries in the TOC. Each outline level 
can be styled independently from the other levels by adding and deleting elements.

Figure 3: Entries page of Insert Index/Table dialog
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Click on a number in the Level column to select the outline level whose elements you want to 
format. The Structure line contains the elements included in the entries for that level. Elements that
can be added to the structure line are displayed just below the structure line, and are grayed out if 
they cannot be included:

• The E# icon represents the “chapter number”, which means the heading number value 
assigned in Tools > Chapter Numbering to a heading style, not just for chapters but also 
for other levels of headings. See “Setting up heading numbering” in Chapter 8, Introduction 
to Styles.

• The E icon represents the chapter (or sub-chapter) text: That is the text formatted with the 
paragraph style used for each level. In Figure Error: Reference source not found, Heading 
1 is used for Level 1, Heading 2 for Level 2.

• The T icon represents a tab stop.

• The # icon represents the page number.

• The LS icon represents the start of a hyperlink.

• The LE icon represents the end of a hyperlink.

• Each white field on the Structure line represents a blank space where you can add custom 
text or another element.

Caution

In the Chapter Numbering dialog (covered in Chapter 8), if you have included any text 
in the Separator Before or After boxes for any given level, then that text will be part 
of the E# field for that level. Take care when building the structure line not to create 
any unwanted effects in the appearance of the TOC.

Adding elements

To add an element to the Structure line:

 1) Click in the white field where you want to insert the element.

 2) Click one of the active buttons just below the Structure line. For example, to add a tab, click
the Tab Stop button. An icon representing the new element appears on the Structure line.

 3) To add custom text, such as the word Chapter, type the text in the white field. Don't forget a
trailing space.

Changing elements

To change an element in the Structure line, click the icon representing that element and then click 
a non-grayed out element in the row of buttons just below the Structure line. For example, to 
change a chapter number to a tab stop, click the E# icon on the Structure line (it shows then as 
being pressed) and then click the Tab stop button in the row of available elements. To cancel 
before swapping an element, click in one of the white spaces.

Applying changes to all outline levels

To apply the displayed structure and formatting to all outline levels, click the All button on the right.

Deleting elements

To delete an element from the Structure line, click the button representing that element and then 
press the Delete key on your keyboard. For example, to delete the default hyperlink setting, click 
the LS icon and then press the Delete key. Repeat this for the LE icon.
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Applying character styles

You might want an element to be a bit different from the rest of the line. For example, you might 
want the page number to be bold. To apply a character style to an element:

 1) Be sure you have previously defined a suitable character style.

 2) On the Structure line, click the button representing the element to which you want to apply 
a style.

 3) From the Character Style drop-down list, select the desired style.

To view or edit the attributes of a character style, select the style from the Character Style drop-
down list and then click the Edit button.

Tip

The default character style for hyperlinks is Internet Link (such as those inserted by 
Insert > Hyperlink), which by default is underlined and shown in blue.

The default hyperlinks of TOC entries are set to the Index Link character style, which 
may be different in appearance from the Internet Link style. If you want them to appear
the same as internet links, you can select the LS icon on the Structure line and change
the character style selection for TOC entries to Internet Link. 

You can also change the attributes for Index Link to what you want.

Tab parameters

Click on the Tab stop icon on the structure line to bring up two controls:

• Fill character: select from the three options the tab leader you wish to use.

• Tab stop position: Enter the distance to leave between the left page margin and the tab 
stop.

Tab position relative to paragraph style indent

When this option is selected, entries are indented according to the settings of their individual 
formats. Where a paragraph style specifies an indent on the left, tab stops are relative to this 
indent. If this option is not selected, tab stops are relative to the left margin position.

Styles page
Use the Styles page (Figure 4) to change which paragraph style is assigned to display the text of 
each level in the table of contents. In most cases, the best strategy is to keep the assigned styles 
but change their settings as needed to make the TOC appear the way you want.

To apply a custom paragraph style to an outline level:

 1) In the Levels list, select the outline level.

 2) In the Paragraph Styles list, click the desired paragraph style.

 3) Click the < button to apply the selected paragraph style to the selected outline level.

The style assigned to each level appears in square brackets in the Levels list.

To remove paragraph styling from an outline level, select the outline level in the Levels list, and 
then click the Default button.

To view or edit the attributes of a paragraph style, click the style in the Paragraph Styles list, and 
then click the Edit button.
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Figure 4: Styles page of the Table of Contents, Index or Bibliography dialog

Note

Changes to a paragraph style will affect any text in the document that is formatted 
using this style, not just the format of the table of contents.

Columns page
Use the Columns page to change the number of columns for the TOC. Multiple columns are more 
likely to be used in an index than in a TOC, so this page is described in the section on indexes. 
See Figure 12.

Background page
Use the Background page (Figure 5) to add color or an image to the background of the TOC.

Figure 5: Background page, showing Color choices
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Adding color

To add color to the background of the table of contents, select from the color grid.

Note

By default, the background to the TOC is shaded gray. This setting is in Tools > 
Options > LibreOffice > Application Colors > Text Document > Index and table 
shadings. Deselect this option to remove the gray background.

Adding an image

To add an image to the background of the table of contents:

 1) From the As drop-down list, select Image. The Background page now displays the image 
options, as shown in Figure 6.

 2) Click the Browse button. The Find images dialog opens.

 3) Find the image file you want and then click the Open button. The selected image appears 
in the preview box. (If you do not see the image, select the Preview option.)

 4) To embed the image in your document, clear the Link option. To link the image to the 
document but not embed it, select the Link option.

 5) In the Type area, choose how you want the background image to appear:

– To position the image in a specific location, select Position and then click the desired 
location in the position grid.

– To stretch the image to fill the entire background area, select Area.

– To repeat the image across the entire background area, select Tile.

Figure 6: Image options on the Background page

Deleting a color or an image

To delete color or an image from the table background:

 1) From the As drop-down list, select Color.

 2) Click No Fill on the color grid.
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Maintaining a table of contents
This section shows you how to:

• Edit an existing TOC.

• Update a TOC when changes are made to the document.

• Delete a TOC.

Editing a table of contents
To edit an existing TOC:

 1) Right-click anywhere in the TOC.

 2) From the context menu, choose Edit Index. The Table of Contents, Index or Bibliography 
dialog (Figure 1 on page 6) opens. You can edit and save the table as described in the 
previous section.

Tip

If you cannot click in the TOC, it is probably protected. To disable this protection, 
choose Tools > Options > LibreOffice Writer > Formatting Aids, and then select 
Enable Cursor in the Protected areas section. If you wish to edit the TOC without 
enabling the cursor, you can access it from the Navigator.

You can also access the Table of Contents, Index or Bibliography dialog from the Navigator.

 1) Open the Navigator (press F5).

 2) Click the expansion symbol (+ sign or triangle) next to Indexes.

 3) Right-click on Table of Contents1 and choose Index > Edit.

Figure 7: Access a TOC from the Navigator
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Updating a table of contents
Writer does not update the TOC automatically, so after any changes to the headings, you must 
update it manually:

 1) Right-click anywhere in the TOC.

 2) From the context menu, choose Update Index. Writer updates the TOC to reflect the 
changes in the document.

You can also update the index from the Navigator by expanding Indexes, right-clicking on Table of 
Contents1, and choosing Index > Update.

Deleting a table of contents
To delete the TOC from a document:

 1) Right-click anywhere in the TOC.

 2) From the context menu, choose Delete Index. Writer deletes the TOC.

Caution

Writer will not prompt you to confirm the deletion.

You can also delete the index from the Navigator by selecting Index > Delete from the menu 
shown in Figure 7.

Alphabetic indexes

An alphabetical index (referred to as an index) is a list of keywords or phrases used throughout a 
document that, if listed in order with page numbers, may help the reader find information quickly. 
Generally an index is found in the back of a book or document.

This section describes how to:

• Add index entries

• Create an alphabetic index quickly

• Customize the display of index entries

• Customize the appearance of the index

• View and edit existing index entries

Adding index entries
Before you can create an index, you must create some index entries.

 1) To add a word to the index, place the cursor anywhere in that word. If you want to add 
multiple words as one entry, select the entire phrase.

 2) Choose Insert > Table of Contents and Index > Index Entry to display a dialog similar to 
that shown in Figure 8. When the dialog opens, the selected text appears in the Entry text 
input box. You can accept the word or phrase shown, or change it to whatever you want.

 3) Click Insert to create the entry.

You may of course open the dialog before selecting text, and then select the text required. After 
selecting the text, click on the dialog to enter the text into the Entry text input box.

Note

A cursor placed immediately before the first character of a word, or immediately after 
the last character of a word if it is followed by a space, counts as being in that word.
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See “Customizing index entries” below for an explanation of the fields on this dialog.

You can create multiple entries without closing the dialog. For each one:

 1) Click at the location in the document that you want to index.

 2) Click again on the dialog.

 3) Change the entry if needed, and click Insert.

 4) Repeat steps 1–3 until you have finished with the entries, then click Close.

Figure 8: Inserting an index entry

Note

If field shading is active (Tools > Options > LibreOffice > Application Colors > Text 
Document > Field shadings), when a selected word or phrase has been added to the
index, it is shown in the text with a gray background. If the text of an index entry has 
been changed from the text of the word selected, the index entry is marked by a small 
gray rectangle at the start of that word.

Tip

You can also open the Insert Index Entry dialog by clicking the Entry icon on the Insert
toolbar, as shown in Figure 9.

Figure 9: Index Entry icon on Insert toolbar

Creating an alphabetic index quickly
Now that you have some index entries, you can create the index.

Although indexes can be customized extensively in Writer, most of the time you need to make only 
a few choices.

To create an index quickly:

 1) Click in the document where you want to add the index and click Insert > Table of 
Contents and Index > Table of Contents, Index or Bibliography to open the Table of 
Contents, Index or Bibliography dialog.
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 2) In the Type box on the Type page (Figure 10), select Alphabetical Index.

 3) In the Options section, you may want to uncheck Case sensitive (so that capitalized and 
lower-case words are treated as the same word) and uncheck Combine identical entries 
with p or pp.

 4) Click OK. The result will be a typical index.

Writer does not update an index automatically. If you add, delete, or change the text of index 
entries, you need to update the index. To do this, follow the steps outlined in “Updating a table of 
contents” on page 14.

Customizing index entries
Below is a brief explanation of the fields in the Insert Index Entry dialog and how to use them.

Index 
The type of index this entry is for. The default is Alphabetical Index, but you can use this field 
to create extra entries for a table of contents or user-defined indexes or lists of almost 
anything. For example, you might want an index containing only the scientific names of 
species mentioned in the text, and a separate index containing only the common names of 
species. See “Other types of indexes” on page 22.

Entry
The word or phrase to be added to the selected index. This word or phrase does not need to 
be in the document itself; you can add synonyms and other terms that you want to appear in 
the index.

1st key
An index key is an entry that has no associated page number and has several subentries 
that do have page numbers. Using keys is a useful way of grouping related topics. (See 
“Example of using an index key” below.)

2nd key
You can have up to a three-level index, where some of the first-level keys have level-2 
entries that are also keys (without page numbers). This degree of index complexity is not 
often necessary.

Main entry
When the same term is indexed on several pages, often one of those pages has more 
important or detailed information on that topic, so you want it to be the main entry. To make 
the page number for the main, or most important, entry stand out, select this option and then 
define the character style for the page number of a main index entry to be bold, for example.

Apply to all similar texts
Select this option to have Writer automatically identify and mark any other word or phrase 
that matches the current selection. The Match case and Whole words only options become 
available if this option is selected. Use this option with care, as it may result in many 
unwanted page numbers (for minor uses of a word) being listed in the index.

Example of using an index key
An index key is a primary entry under which subentries are grouped. For example, you might want 
to create a grouping similar to this:

LibreOffice
Calc,  10
Impress,  15
Writer,  5
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In this example, LibreOffice is the 1st key. The subentries (with the page numbers showing) are the
indexed entries. To insert an index entry for the topic Writer, on the Insert Index Entry dialog  
(Figure 8 on page 15), type Writer in the Entry box and LibreOffice in the 1st key box.

Customizing the appearance of an index
To customize an existing index, right-click anywhere in the index and choose Edit Index/Entry from 
the context menu.

The Table of Contents, Index or Bibliography dialog (Figure 10) has five pages. Any or all of them 
can be used to customize the appearance of an index.

• Use the Type page to set the attributes of the index.

• Use the Entries and Styles pages to format the entries in the index.

• Use the Columns page to put the index into more than one column.

• Use the Background page to add color or an image to the background of the index.

The preview box, located on the left-hand side of the dialog, shows as you work how the index will 
look. (If you do not see the preview box, select Preview in the lower right-hand corner of the 
dialog.)

After making your changes, click OK to save the index so it appears in your document.

Note

The preview box only shows the appearance from settings made on the Type, Entries, 
and Styles pages. The other pages have their own preview panes.

Type page
Use the Type page to set the basic attributes of the index.

Figure 10: Type page for an alphabetic index

 1) To give the Index a different title, type it in the Title field. To delete the title, clear the Title 
field.

 2) Be sure the type of index is set to Alphabetical Index.
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 3) To prevent the index from being changed accidentally, select Protected against manual 
changes. If this option is selected, the index can only be changed using the right-click menu
or the Table of Contents, Index or Bibliography dialog. If the option is not selected, the 
index can be changed directly on the document page, just like other text, but any manual 
changes to an index are lost when you update it.

 4) From the drop-down list in the Create Index or Table of COntents section, select Entire 
document. You can also choose to create an index for just the current chapter.

 5) Various other options determine how the index handles entries:

– Combine identical entries. Defines how identical entries are dealt with. Normally each 
page number of an indexed word or phrase will be shown in the index; however, these 
can be combined using the Combine identical entries with p or pp. If you want a page 
range displayed, select Combine with – (which will produce something similar to 23–
31). If you want different entries based on what letters are capitalized, select Case 
sensitive.

– AutoCapitalize entries. Automatically capitalizes the first letter of each entry regardless 
of how they show within the document itself.

– Keys as separate entries. For the keys to have their own page numbers, select this 
option.

– Concordance file. Enables a list of words in an external file to be imported (select using 
the File button) and then used within the index. The concordance file has a special file 
format; for further information, refer to concordance file in Help > LibreOffice Help. 
Using a concordance file can speed up production of an index, but unless the words are
very carefully selected and you edit the index afterwards, the resulting index can be full 
of entries for minor mentions of a term, making it less useful than a more selective 
index.

– Sort. Defines how the entries are sorted when displayed. The only option is 
alphanumeric, but you can define which language alphabet will be used.

Entries page
Use the Entries page to set exactly how and what will be displayed for each of the entries. The 
page is similar to Figure 11. Note that hyperlinking from the index to the location of entries in the 
text is not available.

Figure 11: Entries page for an alphabetical index
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To begin, in the Level column select the index level whose elements you want to format. Level “S” 
refers to the single letter headings that divide the index entries alphabetically when the 
Alphabetical delimiter option is selected in the Format section. (You will be able to apply your 
changes to all index levels later.) The Structure line displays the elements for entries in that level. 
Each button on the Structure line represents one element:

• The E icon represents the entry text.

• The T icon represents a tab stop.

• The # icon represents the page number.

• The CI icon represents chapter information. This is not present by default, but can be 
added by selecting the Chapter info button.

Each white field on the Structure line represents a blank space. You can add custom text if you 
desire.

Adding elements

To add an element to the Structure line:

 1) Place the cursor in the white field to the left of where you want to insert the element.

 2) Click one of the active buttons below the Structure line. (For example, to add a tab stop, 
click the Tab stop button.) An icon representing the new element appears on the Structure 
line.

 3) To add custom text, click in the white space at the position you want to insert it, and type 
the text. Don't forget a trailing space.

Changing elements

To change an element in the Structure line, click the icon representing that element and then click 
the element that you want to substitute it for in the row of buttons just below the Structure line. For 
example, to change entry text to a tab stop, click the E icon on the Structure line (it shows then as 
being pressed) and then click the Tab stop button in the row of available elements.

Deleting elements

To delete an element from the Structure line, click the button that represents that element and then 
press the Delete key on your keyboard. For example, to delete a tab stop, click the T icon and then
press the Delete key.

Chapter Info

This button inserts chapter information, such as the chapter heading and number. The information 
to be displayed is selected from the Chapter entry box menu. This data is determined in the 
Chapter Numbering dialog (Tools > Chapter Numbering).

Applying character styles

Each of the items that can be added to the Structure line may be given additional formatting. For 
example, you may want the page number to be a different size from the rest of the index text. To 
do this, apply a character style to one of the elements in the Structure line.

To apply a character style to an element:

 1) On the Structure line, click the icon representing the element to which you want to apply a 
style.

 2) Select the desired style from the Character Style drop-down list. Writer applies the style to 
the selected element.

To view or edit the attributes of a character style, select the style from the Character Style drop-
down list and then click the Edit button.
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Formatting entries

Apply additional formatting using the options in the Format section.

• Alphabetical delimiter. This separates the index entries into blocks that start with the same 
first letter, using that letter as a header. For example, if your index begins:

apple,  4
author, 10
break,  2
bus, 4

Then selecting this option will give you:

A

apple,  4
author, 10

B

break,  2
bus, 4

• Key separated by commas. Arranges the entries in the index on the same line but 
separated by commas.

• Tab position relative to Paragraph Style indent. When checked, entries are indented 
according to the settings of their individual formats. Where a paragraph style with an indent 
on the left is in use, tab stops will be relative to this indent. If this option is not selected, tab 
stops will be relative to the left margin position.

Styles, Columns and Background pages
Refer to “Styles page” on page 10 and “Background page” on page 11 for detailed information on 
these pages.

Columns page
Use the Columns page (Figure 12) to change the number of columns for the index.

Figure 12: Columns page of the Insert Index/Table dialog
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Adding multiple columns

To display the index in more than one column:

 1) Either enter the number of columns desired in the box labeled Columns or select the icon 
representing the number of columns.

 2) To evenly distribute the columns according to the page width, check the AutoWidth box. If it 
is unchecked, you can manually set each of the following:

– Width of each of the columns

– Spacing between the columns

 3) You can choose to have a separator line between the columns:

– Style: The default is None, or select from three choices of line style.

– Width: The width (thickness) of the line. The default is 0.25pt.

– Height: The height of the line, as a percentage of the full column height. The default is 
100%

– Position: Position of the line relative to the columns (top, centered, or bottom) if the 
height is less than 100%.

– Color: Allows the color of the separator line to be set.

Maintaining an index
To modify the appearance of an index:

 1) Right-click anywhere in the index.

 2) From the context menu, choose Edit Index. The Table of Contents, Index or Bibliography 
dialog opens and you can edit and save the index using the five tabs described in the 
previous section.

To update or delete an index, right-click anywhere in the index and select Update Index or Delete 
Index.

Viewing and editing existing index entries
Once you have added the initial entries, you can make some amendments. You can view and edit 
these using the following steps:

 1) Ensure that field shading is active (View > Field Shadings or Ctrl+F8), so you can locate 
index entries more easily.

 2) Place the cursor in the field shading of an existing index entry in the body of the document, 
right-click, and select Index Entry from the content menu.In the case of a changed-text 
entry, the field shading is immediately before the word. Placing the cursor immediately 
before a word marked as a text entry will satisfy both selection criteria.

 3) A dialog similar to Figure 13 appears. You can move through the various index entries using
the forward and back arrow buttons. If there is more than one entry for a single word or 
phrase, a second row of buttons with a vertical bar at the point of the arrow head is 
displayed allowing you to scroll through each of these entries.

 4) Make the necessary modifications or additions to the index entries, and then click OK.
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Figure 13: Viewing and editing index entries

Other types of indexes
An alphabetical index is not the only type of index that you can build with Writer. Other types of 
indexes supplied with Writer include those for illustrations, tables, and objects, and you can even 
create a user-defined index. This chapter does not give examples of all the possibilities.

To create other indexes:

 1) Place the cursor where you want the index created.

 2) Select Insert > Table of Contents and Index > Table of Contents, Index or 
Bibliography from the Menu bar.

 3) On the Table of Contents, Index or Bibliography dialog, in the Type drop-down list, select 
the index wanted.

 4) Modify the various pages, which are similar to those discussed in previous sections.

 5) Select OK when everything has been set.

Example: Creating an index of figures
Creating an index (list) of figures or tables is easy if the figure captions were created using Insert > 
Caption or manually using a number range variable as described in Chapter 17, Fields.

 1) On the Table of Contents, Index or Bibliography dialog, in the Type drop-down list, choose 
Illustration Index. You can change the title of the index to something else; we have used 
Table of Figures as our title.

 2) Be sure Captions is selected in the Create from section, and choose the category of 
caption. The default for Category is Illustration; in our example we have used Figure for the 
figure captions.

(The category Figure is not supplied with LibreOffice; however, if you have defined it when 
creating a caption in your document, it will appear on this list. See Chapter 11, Images and 
Graphics, for more about creating captions.)

 3) Under Display, you can choose References (to include the category, number, and caption 
text), Category and Number, or Caption Text. We have chosen References.

 4) The other pages of this dialog are similar to those described for tables of contents.
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Figure 14: Creating other types of indexes

 5) Click OK. The result is shown below.

Figure 15: Resulting index of illustrations

Bibliographies

A bibliography is a list for displaying references used throughout a document. These references 
are either stored in a bibliographic database or within the document itself.

This section shows you how to:

• Create a bibliographic database; add and maintain entries.

• Add a reference into a document.

• Format the bibliography.

• Update and edit an existing bibliography.

Creating a bibliographic database
For most of this section, the database table used is the sample one that comes with Writer. For 
information on creating a new table in the bibliographic database, see Chapter 8, Getting Started 
with Base, in the Getting Started Guide.
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Although you can create references within the document itself, creating a bibliographic database 
allows reuse in other documents and saves a lot of time.

Select Tools > Bibliography Database. The Bibliography Database window, similar to that in 
Figure 16, opens. The upper part of the page shows all of the records, in a table layout similar to 
that of a spreadsheet. The lower part of the page shows all the fields of the selected record.

Figure 16: Bibliography Database main window

Filtering records
To set up a filter for specific records within the bibliographic database, select Tools > Filter from 
the Bibliographic Database Menu bar, or click the Standard Filter button on the toolbar near the top
of the window. On the Standard Filter dialog (Figure 17), choose the fields, conditions, and values 
for the filter and click OK.

Figure 17: Setting up a filter for the bibliographic database
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Changing column details
To change the details of columns in the bibliographic database, select Edit > Column 
Arrangement from the Menu bar, or click the Column Arrangement button on the tolbar near the 
top of the window (see Figure 16). On the Column Layout for Table biblio dialog (Figure 18), you 
can change which fields are allocated to which columns. As an example, you can select to have 
Author data go into the Identifier column, by changing the destination in the drop-down list. The 
Short name data column destination sets to None automatically, as you can't set duplicate 
destinations for data.

Figure 18: Changing column layout for bibliographic database

Changing the data source
To change the data source in use (for example, if you have more than one bibliographic database 
for different purposes), select Edit > Choose Data Source from the menu bar, or click the Data 
Source button on the toolbar near the top of the window. On the Choose Data Source dialog, 
select a data source and click OK.

Changing field details
You can make changes to the bibliography database (for example, rename fields or change the 
length of fields) by doing the following:

 1) In the main document (not the Bibliography Database window), press F4 or click View > 
Data Sources to open the data source window, similar to Figure 19.

Figure 19: Data Source view of Bibliography database

 2) Make sure that the Bibliography database is selected as well as the correct table. You may 
have to expand some levels to be able to select the correct ones.
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 3) Right-click on the table entry (biblio in the example) and select Edit Database File from the
context menu. This opens a window similar to Figure 20, which is the main menu for Base, 
the database component of LibreOffice.

Figure 20: Main window for working with databases

 4) If Tables (in the Database section on the left) is not selected, select it now.

 5) Right-click on the biblio table name in the Tables section and select Edit from the context 
menu to display a window similar to that shown in Figure 21.

Figure 21: Modify table properties window
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 6) You can now select each of the fields. You can select the text in the Field Name cell and 
change the entry as required. Clicking in the Field Type cell, allows you to open a selection 
menu to change the data type in that cell. In the Field Properties section, the data 
properties can be modified. For each data field selected, an explanation of that field 
appears in a window to the right of the section.

 7) When finished, you will be asked to confirm that you want the changes saved.

Note

For more information on how to use LibreOffice’s database features, see Chapter 8, 
Getting Started with Base, in the Getting Started Guide.

Adding entries to the database
Use the Bibliography Database dialog (Tools > Bibliography Database) to add entries to the 
database:

 1) You can add records directly into the database using the fields in the lower section of the 
dialog shown in Figure 16 on page 24.

 2) Select Insert > Record from the Menu bar of the Bibliography Database dialog, or click the 
Insert Record icon to the left of the horizontal scroll bar.

 3) Enter a name for the entry in the Short Name box. Complete other fields as required. Use 
the Tab key to move between fields.

It is best to use a unique name in the Short name field. This field is used when inserting 
entries into documents.

 4) To complete the entry, move to the last field and press Tab once more.

If your document requires [Author, date] style citations, use the Short name field of the database to 
record the information in the required format.

Maintaining entries in the database
To maintain entries in the database, use the Bibliography Database dialog (Tools > Bibliography 
Database). Click on the appropriate record and modify the fields as appropriate.

Modified entries are saved automatically to the database when the cursor moves off the record.

Adding references (citations) into a document
Writer supports two methods of adding references to your document:

• From a bibliography database, such as the one built into Writer.

• Directly from the keyboard.

Entering references from a database
To add references from the bibliographic database into a document:

 1) Place the cursor where you want the reference to appear.

 2) From the main menu, choose Insert > Table of Contents and Index > Bibliography 
Entry.

 3) In the Insert Bibliographic Entry dialog, choose From bibliography database at the top of 
the dialog.
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Figure 22: Inserting bibliographic entries into a document

 4) Select the reference from the Short name drop-down list near the bottom of the dialog. The 
Author and Title of the selected reference are shown in the middle of the dialog, to help you
verify that it is the reference you want.

 5) To insert the reference into the document, click Insert.

 6) You can keep the dialog open and insert another reference into the document; you don’t 
need to close and reopen it.

 7) When you have finished inserting all the references, click Close.

Entering references from documents
You may choose to enter your bibliographic entries directly into the document, instead of from an 
external database. For example, you may not be working on your own computer.

Click in the document where you want to add the entry.

 1) Select Insert > Table of Contents and Index > Bibliography Entry.

 2) In the dialog that opens, select the From document content option.

– Select New.

– In the Define Bibliography Entry dialog, complete all the fields which are relevant to your
entry. Type a unique name in the Short name text entry box, because the Insert 
Bibliography Entry dialog uses this entry for the citation.

– Select a choice from the menu in the Type box to enable the OK button.

– Click OK when all the fields wanted are completed.

– Click Insert to add the Short name field to the document

– Click in each location you wish to add an entry and repeat this sequence

 3) Click Close.

To re-use an entry in your document, restart the sequence above, and then select the Short name 
required from the current list of entries, instead of selecting to add a new entry.

Editing a reference
To edit a reference:

 1) Right-click on the entry (the cursor then displays to the left of the entry).

 2) From the context menu, select Bibliography Entry. The Edit Bibliography Entry dialog 
opens.
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Figure 23: Edit a bibliography entry

 3) To quickly edit only the Short name, click on the text box, alter the entry and then click 
Apply. 

 4) To edit more of the entry, click Edit to open the Define Bibliography Entry dialog.

Make any changes required and then click OK to return to the dialog of Figure 23.

 5) If you are satisfied with your changes, click Apply to accept the changes and exit the 
dialog.

Whatever the source of the citation, the modified references are stored in the document. If the 
source was a bibliography database, that database remains unmodified.

Creating the bibliography
To create the bibliography:

 1) Place the cursor at the point where you wish to insert the bibliography.

 2) Select  Insert > Table of Contents and Index > Table of Contents, Index or 
Bibliography and change the Type to Bibliography, to display a dialog similar to that 
shown in Figure 24.

The Insert Index/Table dialog has five pages.

Index/Table page
Writer supports two ways of displaying references (citations) in the text of a document:

• Using the text recorded in the Short name field of each bibliographic entry, for example 
[GUR00].

• By numbering the referenced documents in the sequence they occur in the text, for 
example [1].

Tip

To specify which citation style is used in the document, use the Type page on the 
Table of Contents, Index or Bibliography dialog (Figure 24).

Formatting the bibliography involves choices made in two places:

• Table of Contents, Index or Bibliography dialog, covered in this section.

• Bibliography 1 paragraph style (see page 31).

The basic settings are selected on this page.

 1) To give the bibliography a title, enter it in the Title field. (A title is not required.)
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 2) You can protect the bibliography from being changed accidentally, by checking Protected 
against manual changes. If this option is selected, the bibliography can only be changed 
using the right-click menu or the Table of Contents, Index or Bibliography dialog. If the 
option is not selected, the bibliography can be changed directly on the document page, just 
like other text, but any manual changes will be lost when you update the bibliography.

Figure 24: Inserting a bibliography

 3) To have the bibliographic entries (citations) numbered within the body of the document (for 
example, [1], [2]...), select Number entries. If, however, you wish to have the Short name 
field contents (from the database) appear in the document, deselect this option.

 4) Select the type of brackets that you want for the referenced entries shown within the body 
of the document.

 5) Define the sorting you require. Currently only alphanumeric sorting is supported. Sorting by 
the sequence that entries appear in the text is done on the Entries page.

Entries page
The structure of this page (see Figure 25) is similar to that for tables of contents and for indexes.

Each type of source that you use when creating your document will have its own unique works 
cited format. You can define how the entry will appear, based on its source, by selecting from the 
Type list of entries, or simply apply the same format to all entries by selecting the All button.

Each entry in the Type list has a default structure format.

The Structure of the entry is based on the fields available in the bibliographic database. The ones 
shown by default for Article in the Type list are:

Sh – Short name

Au – Author

Ti – Title

Ye – Year 

To remove elements from the Structure line, click the element then click the Remove button.

To add an element, click in the Structure line where it is to be inserted. Select either the Tab stop, 
or an element in the drop-down list to the left of the Insert button, and then click Insert. The 
elements in the drop-down list are those fields found in the Bibliography Database.

All the elements on the Structure line can be formatted using the Character Style selection list.
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To determine how entries are sorted, modify the Sort by options. To sort by the sequence that 
entries appear in the text, choose Document position. To sort alphanumerically, choose Content. 
Use Sort keys to group similar references.

Figure 25: Entries page for bibliographies

Styles, Columns and Background pages
Refer to “Styles page” on page 10, “Columns page” on page 20 and “Background page” on page
11 for detailed information on these pages.

Generating the bibliography
To generate the bibliography so that it appears in your document, click OK. The dialog closes and 
the bibliography appears in your document.

Defining the paragraph style for the bibliography

You can modify the Bibliography 1 paragraph style to suit your requirements. For example, to 
number the entries in the bibliography list, you need to define a numbering style and link that 
numbering style to the Bibliography 1 paragraph style. To do this:

 1) On the Styles and Formatting window, click on the List Styles icon. You can either define a 
new list style or modify one of those supplied. In this example, we will modify the 
Numbering 5 style. Right-click on Numbering 5 and choose Modify from the context menu.

 2) On the Numbering Style dialog, go to the Customize page. In our example we want to have 
the numbers enclosed in square brackets. To do this, type [ in the Before box and ] in the 
After box, as shown in Figure 26.
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Figure 26: Specifying square brackets before and after the number in a list

 3) Now go to the Position page of the Numbering style dialog (Figure 27). In the Spacing to 
text box, specify how much indentation you want for the second and following lines of any 
item in the bibliography list of your document. Often you will need to experiment a bit to see
what is the best setting. In our example, we have chosen 1 cm.

Figure 27: Setting the spacing between the margin and the text

 4) Click OK to save these settings and close the Numbering Style dialog. Return to the Styles 
and Formatting window, click on the Paragraph Styles icon, choose All Styles from the list 
at the bottom of that window, then right-click on Bibliography 1 and choose Modify.

 5) On the Paragraph Style dialog, go to the Outline & Numbering tab and select Numbering 5 
from the drop-down list. (See Figure 28.) Click OK to save this change to the Bibliography 1
paragraph style.
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Figure 28: Applying a numbering style to a paragraph style

Now when you generate the bibliography, the list will look something like the one shown below for 
a book after removing elements from the structure line (the Short name and colon, for example).

Figure 29: Result of changing settings for Bibliography 1 paragraph style

Updating, editing, and deleting an existing bibliography
Right-click anywhere in the bibliography. From the context menu, select:

• Update Index to update the bibliography.

• Edit Index to open the Table of Contents, Index or Bibliography dialog so you can edit and 
save the table.

• Delete Index to delete the table without a confirmation request.

Tip

If you find Writer’s bibliography feature too limited, you may wish to try Zotero, which is
free and open source, available for Mac, Windows, and Linux. It is reported to work 
well with Writer (http://www.zotero.org/).
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