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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options
menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click and/or right-click
depending on computer system

Opens a context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Opens the Navigator

F11

z+T

Opens the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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What is LibreOffice?
LibreOffice is a freely available, fully-featured office productivity suite. Its native file format is Open
Document Format (ODF), an open standard format that is being adopted by governments
worldwide as a required file format for publishing and accepting documents. LibreOffice can also
open and save documents in many other formats, including those used by several versions of
Microsoft Office.
LibreOffice includes the following components.

Writer (word processor)
Writer is a feature-rich tool for creating letters, books, reports, newsletters, brochures, and other
documents. You can insert graphics and objects from other components into Writer documents.
Writer can export files to HTML, XHTML, XML, Adobe Portable Document Format (PDF), and
several versions of Microsoft Word files. It also connects to your email client.

Calc (spreadsheet)
Calc has all of the advanced analysis, charting, and decision making features expected from a
high-end spreadsheet. It includes over 300 functions for financial, statistical, and mathematical
operations, among others. The Scenario Manager provides “what if” analysis. Calc generates 2D
and 3D charts, which can be integrated into other LibreOffice documents. You can also open and
work with Microsoft Excel workbooks and save them in Excel format. Calc can also export
spreadsheets in several formats, including for example Comma Separated Value (CSV), Adobe
PDF and HTML formats.

Impress (presentations)
Impress provides all the common multimedia presentation tools, such as special effects, animation,
and drawing tools. It is integrated with the advanced graphics capabilities of LibreOffice Draw and
Math components. Slideshows can be further enhanced using Fontwork special effects text, as
well as sound and video clips. Impress is compatible with Microsoft PowerPoint file format and can
also save your work in numerous graphics formats, including Macromedia Flash (SWF).

Draw (vector graphics)
Draw is a vector drawing tool that can produce everything from simple diagrams or flowcharts to
3D artwork. Its Smart Connectors feature allows you to define your own connection points. You can
use Draw to create drawings for use in any of the LibreOffice components, and you can create
your own clip art then add it to the Gallery. Draw can import graphics from many common formats
and save them in over 20 formats, including PNG, HTML, PDF, and Flash.

Base (database)
Base provides tools for day-to-day database work within a simple interface. It can create and edit
forms, reports, queries, tables, views, and relations, so that managing a relational database is
much the same as in other popular database applications. Base provides many new features, such
as the ability to analyze and edit relationships from a diagram view. Base incorporates HSQLDB as
its default relational database engine. It can also use dBASE, Microsoft Access, MySQL, or Oracle,
or any ODBC compliant or JDBC compliant database. Base also provides support for a subset of
ANSI-92 SQL.

What is LibreOffice?
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Math (formula editor)
Math is the LibreOffice formula or equation editor. You can use it to create complex equations that
include symbols or characters not available in standard font sets. While it is most commonly used
to create formulae in other documents, such as Writer and Impress files, Math can also work as a
standalone tool. You can save formulae in the standard Mathematical Markup Language (MathML)
format for inclusion in web pages and other documents not created by LibreOffice.

Advantages of LibreOffice
Here are some of the advantages of LibreOffice over other office suites:

• No licensing fees. LibreOffice is free for anyone to use and distribute at no cost. Many
features that are available as extra cost add-ins in other office suites (like PDF export) are
free with LibreOffice. There are no hidden charges now or in the future.

• Open source. You can distribute, copy, and modify the software as much as you wish, in
accordance with either of the LibreOffice Open Source licenses.

• Cross-platform. LibreOffice runs on several hardware architectures and under multiple
operating systems, such as Microsoft Windows, Mac OS X and Linux.

• Extensive language support. The LibreOffice user interface is available in over 40
languages and the LibreOffice project provides spelling, hyphenation, and thesaurus
dictionaries in over 70 languages and dialects. LibreOffice also provides support for both
Complex Text Layout (CTL) and Right to Left (RTL) layout languages (such as Urdu,
Hebrew, and Arabic).

• Consistent user interface. All the components have a similar “look and feel,” making them
easy to use and master.

• Integration. The components of LibreOffice are well integrated with one another.
–
All the components share a common spelling checker and other tools, which are used
consistently across the suite. For example, the drawing tools available in Writer are
also found in Calc, with similar but enhanced versions in Impress and Draw.

–

You do not need to know which application was used to create a particular file. For
example, you can open a Draw file from Writer.

• Granularity. Usually, if you change an option, it affects all components. However,
LibreOffice options can be set at a component level or even at document level.

• File compatibility. In addition to its native OpenDocument formats, LibreOffice includes
PDF and Flash export capabilities, as well as support for opening and saving files in many
common formats including Microsoft Office, HTML, XML, WordPerfect, and Lotus 1-2-3
formats. An extension (included) provides the ability to import and edit some PDF files.

• No vendor lock-in. LibreOffice uses OpenDocument, an XML (eXtensible Markup
Language) file format developed as an industry standard by OASIS (Organization for the
Advancement of Structured Information Standards). These files can easily be unzipped and
read by any text editor, and their framework is open and published.

• You have a voice. Enhancements, software fixes, and release dates are communitydriven. You can join the community and affect the course of the product you use.
You can read more about LibreOffice and The Document Foundation on their websites at
http://www.libreoffice.org/ and http://www.documentfoundation.org/.
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Minimum requirements
LibreOffice 3.0 requires one of the following operating systems:

• Microsoft Windows XP, Vista, Windows 7, or Windows 8
• GNU/Linux Kernel version 2.6.18, glibc2 v2.5 or higher, and gtk v2.10.4 or higher
• Mac OS X 10.4 (Tiger) or higher
Administrator rights are needed for the installation process.
Some LibreOffice features (wizards and the HSQLDB database engine) require that the Java
Runtime Environment (JRE) is installed on your computer. Although LibreOffice will work without
Java support, some features will not be available.
For a more detailed listing of requirements, see the LibreOffice website,
http://www.libreoffice.org/download/system-requirements/.

How to get the software
The software can be downloaded from http://www.libreoffice.org/. You can also download the
software by using a Peer-to-Peer client, such as BitTorrent, at the same address.
Linux users will find LibreOffice included in many of the latest Linux distributions; Ubuntu is just
one example.

How to install the software
Information on installing and setting up LibreOffice on the various supported operating systems is
given here: http://www.libreoffice.org/get-help/installation/.

Extensions and add-ons
Extensions and add ons are available to enhance LibreOffice. Several extensions are installed with
the program and others are available from the official extensions repository,
http://extensions.libreoffice.org/. See Chapter 14 Customizing LibreOffice for more information on
installing extensions and add ons.

Starting LibreOffice
The most common way to launch any component of LibreOffice is by using the system menu, the
standard menu from which most applications are started. On Windows, it is called the Start menu.
On GNOME, it is called the Applications menu. On KDE it is identified by the KDE logo. On Mac
OS X, it is the Applications menu.
When LibreOffice was installed on your computer, a menu entry for LibreOffice and each
LibreOffice component was added to your system menu if your computer uses a Windows or Linux
operating system. On computers operating Mac OS X, only a menu entry for LibreOffice is added
to the Applications menu.
Clicking on the LibreOffice menu entry opens the LibreOffice Start Center (Figure 1) from where
you can select the individual components of LibreOffice. You can also select to open an existing file
or use a template.

Starting LibreOffice

7

Figure 1: LibreOffice Start Center

Starting from an existing document
You can start LibreOffice by double-clicking the filename that is an ODF document in a file
manager such as Windows Explorer. The appropriate component of LibreOffice will start and the
document will be loaded.
If Microsoft Office is installed on your computer and you have associated Microsoft Office file types
with LibreOffice, when you double-click on the file:

• For a Word file (*.doc or *.docx), it opens in Writer.
• For an Excel file (*.xls or *.xlsx), it opens in Calc.
• For a PowerPoint file (*.ppt or *.pptx), it opens in Impress.
If you did not associate the file types and Microsoft Office is installed on your computer, then when
you double-click on a Microsoft Office file, it opens using the appropriate Microsoft Office
component.
For more information on opening files, see “Opening existing documents” on page 14.

Quickstarter for Windows
The LibreOffice installation process installs Quickstarter on computers using the Windows
operating system. Quickstarter is installed in the Windows system tray and is automatically loaded
during system startup. It loads *.DLL library files required by LibreOffice, resulting in a shorter
startup time for LibreOffice components. If Quickstarter has been disabled, see “Reactivating
Quickstarter” on page 9 to enable it.

Using Quickstarter
Right-click the Quickstarter icon in the system tray to open a pop-up menu (Figure 2) from which
you can open a new document, or open the Templates Manager, or choose an existing document
to open. You can also double-click the Quickstarter icon to open the Templates Manager.
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Figure 2: Quickstarter menu in Windows

Disabling Quickstarter
To close Quickstarter, right-click on the icon in the system tray, and then click Exit Quickstarter in
the pop-up menu. The next time the computer is restarted, Quickstarter will be loaded again.
To prevent LibreOffice from loading Quickstarter during system startup, deselect the Load
LibreOffice during system start-up item on the pop-up menu. You might want to do this if your
computer has insufficient memory, for example.

Reactivating Quickstarter
If Quickstarter has been disabled, you can reactivate it by selecting the Load LibreOffice during
system start-up check box in Tools > Options > LibreOffice > Memory.

Linux and Mac OS X
Computers operating Linux and Mac OS X do not have a Quickstarter module. To launch
LibreOffice you have to click on the LibreOffice icon in Applications. This opens the LibreOffice
startup screen (Figure 1) from where you can select the various LibreOffice components or select
to open an existing file or use a template.

Parts of the main window
The main window is similar for each component of LibreOffice, although some details vary. See the
relevant chapters in this guide about Writer, Calc, Draw, and Impress for descriptions of those
details.
Common features include the main menu bar, standard toolbar, and formatting toolbar at the top of
the window and the status bar at the bottom.

Main menu bar
The Main menu bar is located across the top of the LibreOffice window, just below the Title bar.
When you select one of the menus listed below, a sub-menu drops down to show commands.

• File – contains commands that apply to the entire document such as Open, Save, and
Export as PDF.

Parts of the main window
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• Edit – contains commands for editing the document such as Undo: xxx (where xxx is the
command to undo) and Find & Replace. It also contains commands to cut, copy, and paste
selected parts of your document.

• View – contains commands for controlling the display of the document such as Zoom and
Web Layout.

• Insert – contains commands for inserting elements into your document such as Header,
Footer, and Picture.

• Format – contains commands, such as Styles and Formatting and AutoCorrect, for
formatting the layout of your document.

•
•
•
•

Table – contains all commands to insert and edit a table in a text document.
Tools – contains functions such as Spelling and Grammar, Customize, and Options.
Window – contains commands for the display window.
Help – contains links to the LibreOffice Help file, What’s This?, and information about the
program.

Toolbars
LibreOffice has two types of toolbars: docked (fixed in place) and floating. Docked toolbars can be
moved to different locations or made to float, and floating toolbars can be docked.
In a default LibreOffice installation, the top docked toolbar, just under the Main menu bar, is called
the Standard toolbar. It is consistent across the LibreOffice applications.
The second toolbar at the top, in a default LibreOffice installation, is the Formatting bar. It is
context-sensitive; that is, it shows the tools relevant to the current position of the cursor or the
object selected. For example, when the cursor is on a graphic, the Formatting bar provides tools
for formatting graphics; when the cursor is in text, the tools are for formatting text.

Displaying or hiding toolbars
To display or hide toolbars, go to View > Toolbars on the main menu bar, then click on the name
of a toolbar from the drop-down list. An active toolbar shows a check-mark beside its name.
Toolbars created from tool palettes are not listed in the View menu.
To close a toolbar, click on the X on the right of the toolbar title or go to View > Toolbars on the
main menu bar and deselect the toolbar.

Figure 3: Example of tearing off a tool palette
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Sub-menus and tool palettes
Toolbar icons with a small triangle to the right will display sub-menus, tool palettes, and other ways
of selecting things, depending on the icon.
Tool palettes can be made into a floating toolbar and Figure 3 shows an example of a tool palette
from the Drawing toolbar made into a floating toolbar. See “Moving toolbars” and “Floating
toolbars” below for more information on moving and floating these toolbars created from tool
palettes.

Moving toolbars
Docked toolbars can be undocked and moved to a new docked position or left as a floating toolbar.
1) Move the mouse cursor over the toolbar handle, which is the small vertical bar to the left of
a docked toolbar and highlighted in Figure 4.
2) Hold down the left mouse button and drag the toolbar to the new location. The toolbar can
be docked in a new position at the top, sides or bottom of the main window, or left as a
floating toolbar.
3) Release the mouse button.
4) To move a floating toolbar, click on its title bar and drag it to a new floating location or dock
the toolbar at the top or bottom of the main window.

Figure 4: Toolbar handles

Note

You can also dock a floating toolbar by holding down the Ctrl key and clicking in the
title bar of the toolbar.

Floating toolbars
LibreOffice includes several additional toolbars, whose default setting appear as floating toolbars in
response to the current position of the cursor or selection. You can dock these toolbars to the top
or bottom of the main window, or reposition them on your computer display (see “Moving toolbars”
above).
Some of these additional toolbars are context sensitive and will automatically appear depending on
the position of the cursor. For example, when the cursor is in a table, a Table toolbar appears, and
when the cursor is in a numbered or bullet list, the Bullets and Numbering toolbar appears.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar. You can also add icons and create new toolbars, as described in
Chapter 14 Customizing LibreOffice. To access the customization options for a toolbar, right-click
between the icons on a toolbar. A context menu opens.

• To show or hide icons defined for the selected toolbar, click Visible Buttons. Visible icons
on a toolbar are indicated by an outline around the icon (Figure 5) or by a check mark
beside the icon, depending on your operating system. Select or deselect icons to hide or
show them on the toolbar.

Parts of the main window
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Figure 5: Selection of visible toolbar icons

• Click Customise Toolbar to open the Customise dialog, see Chapter 14 Customizing
LibreOffice for more information.

• Click Dock Toolbar to dock the selected toolbar. By default, a toolbar will dock at the top of
the workspace. You can reposition the toolbar to a different docked position, see “Moving
toolbars” on page 11.

• Click Dock All Toolbars to dock all floating toolbars. By default, toolbars will dock at the
top of the workspace. You can reposition the toolbars to different docked positions, see
“Moving toolbars” on page 11.

• Click Lock Toolbar Position to lock a docked toolbar into its docked position.
• Click Close Toolbar to close the selected toolbar.

Docking/floating dialogs
When dialogs open, they are floating dialogs, unless they have been docked when LibreOffice was
last opened. These floating dialogs can be docked by holding down the Ctrl key and doubleclicking in a vacant area near the icons at the top of the floating dialog. The dialog will then dock in
its last docked position on the workspace. After docking, you can resize the docked dialog and
reposition in a new docked position.
To undock a docked dialog and make it floating, hold down the Ctrl key and double-click in a
vacant area near the icons at the top of the docked dialog. Alternatively, click and hold in a vacant
area near the icons at the top of the docked dialog and drag it to a floating position.
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Context menus
Context menus are a quick access to many menu functions and are opened by right-clicking on a
paragraph, graphic, or other object. When a context menu opens, the functions or options available
will be dependent on the object that has been selected. A context menu can be the easiest way to
reach a function, especially if you are not sure where a function is located in the menus or toolbars.

Status bar
The status bar is located at the bottom of the workspace. It provides information about the
document and convenient ways to quickly change some features. It is similar in Writer, Calc,
Impress, and Draw, but each LibreOffice component includes some component-specific items. An
example of the Writer status bar is shown in Figure 6.

Figure 6: Example status bar from Writer
Page, sheet, or slide number
Shows the current page, sheet, or slide number and the total number of pages and words,
sheets, or slides in the document. Double-click on this field to open the Navigator. Other uses
of this field depend on the LibreOffice component.
Page style or slide design
Shows the current page style or slide design. To edit the current page style or slide design,
double-click on this field.
Language
Shows the current language of the whole document.
Insert mode
Shows the type of insert mode the program is in. This field is blank if the program is in Insert
mode. Press the Ins key to change modes.
Unsaved changes
An icon appears here if changes to the document have not been saved.
Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon to
view the certificate.
Object information
Displays information relevant to the position of the cursor or the selected element of the
document. Double-clicking in this area usually opens a relevant dialog.
Zoom slider and percent
Drag the Zoom slider, or click on the + and – signs to change the view magnification.

Parts of the main window
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Zoom percentage
Indicates the magnification level of the document. Right-click on the percentage figure to open
a list of magnification values from which to choose. Double-clicking on this percentage figure
opens the Zoom & View Layout dialog.

Starting new documents
You can start a new, blank document in LibreOffice in several ways.
When LibreOffice is open but no document is open, the Start Centre (Figure 1 on page 8) is
shown. Click one of the icons to open a new document of that type, or click the Templates icon to
start a new document using a template.
You can also start a new document in one of the following ways:

• Use File > New on the main menu bar and select the type of document from the context
menu.

• Use Ctrl+N on the keyboard to start a new text document.
• Use File > Wizards on the main menu bar and select the type of document from the
context menu.

• If a document is already open in LibreOffice, click the New icon on the Standard toolbar
and a new document of the same type opens in a new window. For example, if Calc is
open, a new spreadsheet is opened. The New icon changes depending on which
component of LibreOffice is open.

Note

If all documents are closed without closing LibreOffice, then the Start Centre will be
displayed.

Opening existing documents
You can also open an existing document in one of the following ways:

• When no document is open, click the Open icon

on the Start Centre and select from a

list of available documents.

• Click the small triangle to the right of the Open icon and select from a list of recently
opened documents.

• Go to File > Open on the main menu bar
• Click the Open icon
on the Standard toolbar if there is a document already open.
• Press Control+O on the keyboard.
In each case above, an Open dialog opens. Navigate to the folder you want and select the file you
want, and then click Open. If a document is already open in LibreOffice, the second document
opens in a new window.
In the Open dialog, you can reduce the list of files by selecting the type of file you are looking for.
For example, if you choose Text documents as the file type, you will only see documents Writer
can open (including... .odt, .doc, .txt); if you choose Spreadsheets, you will see .ods, .xls,
and other files that Calc opens.
You can also open an existing document that is in a format that LibreOffice recognizes by doubleclicking on the file icon on the desktop or in a file manager such as Windows Explorer. LibreOffice
has to be associated with file types that are not ODF files for the appropriate LibreOffice
component to open.
14
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On computers operating Microsoft Windows or Mac OS X, you can select to use the
LibreOffice Open/Save dialogs or the ones provided by the computer operating
system. See “Open and Save As dialogs” on page 18 for more information.

Note

Saving documents
You can save documents as follows:

• Using the Save command if you are keeping the document, its current filename and
location.

• Using the Save As command if you want to create a new document, or change the
filename and/or file format, or save the file in a different location on your computer.

• Using password protection if you want to restrict who can open and read the document, or
open and edit the document.

Save command
To save a document if you are keeping the document, its current filename and location, do one of
the following:

• Use the keyboard shortcut Ctrl+S.
• Go to File > Save on the main menu bar.
• Click the Save icon

on the standard toolbar.

Using the Save command will overwrite the last saved version of the file.

Save As command
To save a document if you want to create a new document, or change the filename and/or file
format, or save the file in a different location on your computer:

• Use the keyboard shortcut Ctrl+Shift+S.
• Go to File > Save As on the main menu bar.

Figure 7: Example of LibreOffice Save As dialog
Saving documents
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Figure 8: Example of an operating system Save dialog
When the Save As dialog (Figure 7) or Save dialog (Figure 8) opens, enter the file name, change
the file format (if applicable), navigate to a new location (if applicable), and click Save.
The dialog that opens when using the Save As command depends on the options that have been
set in LibreOffice. See “Open and Save As dialogs” on page 18 for more information.

Password protection
To protect a document and restrict who can open and read the document, or open and edit the
document, you have to use password protection.
1) Using the Save As command above, select the Save with password option in the Save As
dialog or Save dialog.
2) Click Save and the Set Password dialog opens (Figure 9).
3) In File encryption password, enter a password to open the document and then enter the
same password as confirmation.
4) To restrict who can edit the document, click the More Options button. This button changes
to Fewer Options when clicked.
5) In File sharing password, select Open file read only and enter a password to allow editing
and then enter the same password as confirmation.
6) Click OK and the dialog closes. If the passwords match, the document is saved password
protected. If the passwords do not match, you receive an error message.
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Figure 9: Set Password dialog

Caution

LibreOffice uses a very strong encryption mechanism that makes it almost
impossible to recover the contents of a document if you lose or forget the password.

Changing password
When a document is password-protected, you can change the password while the document is
open. Go to File > Properties > General on the main menu bar and click the Change Password
button in the Properties dialog. This opens the Set Password dialog where you can enter a new
password.

Saving documents automatically
LibreOffice can save files automatically, which is part of the AutoRecovery feature included in
LibreOffice. Automatic saving, like manual saving, overwrites the last saved state of the file. To set
up automatic file saving:
1) Go to Tools > Options > Load/Save > General on the main menu bar.
2) Select Save AutoRecovery information every and set the time interval.
3) Click OK.

Saving documents
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Renaming and deleting files
You can rename or delete files within the LibreOffice dialogs, just as you can in a file manager.
Select a file and then right click to open a context menu. Select either Delete or Rename, as
appropriate. However, you cannot copy or paste files within the dialogs.

Open and Save As dialogs
You can choose whether to use the LibreOffice Open and Save As dialogs or the ones provided by
your operating system.

• To use LibreOffice dialogs for saving or opening files, go to Tools > Options > LibreOffice
> General and check the option Use LibreOffice dialog boxes. An example of a
LibreOffice dialog is shown in Figure 7 on page 15.

• To use the operating system dialogs for saving or opening files, go to Tools > Options >
LibreOffice > General and uncheck the option Use LibreOffice dialog boxes. An
example of an operating system dialog is shown in Figure 8 on page 16.
The three icons in the top right of the LibreOffice Open and Save As dialogs are as follows:

• Connect To Server

– a dialog opens allowing you to connect to a network server if
the file you want is not located on your computer.

• Up One Level

– moves up one folder in the folder hierarchy. Click and hold the
mouse button on this icon to display a drop down a list of higher level folders. Move the
cursor over a higher level folder and release the mouse button to navigate to that folder

• Create New Folder

– creates a new sub-folder in the folder that is displayed in the
dialog.
Use the File type field to specify the type of file to be opened or the format of the file to be saved.
The Read-only option on the Open dialog opens the file for reading and printing only. Most of the
icons and most menu options are disabled on the toolbars. The Edit File icon
on the Standard toolbar. Click on this icon to open the file for editing.

becomes active

Using the Navigator
The LibreOffice Navigator lists objects contained within a document, collected into categories. For
example, in Writer it shows Headings, Tables, Text frames, Comments, Graphics, Bookmarks, and
other items, as shown in Figure 10. In Calc it shows Sheets, Range Names, Database Ranges,
Graphics, Drawing Objects, and other items. In Impress and Draw it shows Slides, Pictures, and
other items. An example of the Navigator used in Calc is shown in Figure 10.
To open the Navigator, click the Navigator icon
or go to View > Navigator on the main menu bar.

on the Standard toolbar, or press the F5 key,

You can dock the Navigator to either side of the main LibreOffice window or leave it floating (see
“Docking/floating dialogs“ on page 12 for more information).
Click the marker (+ or triangle) by any of the categories to display the list of objects in that
category.
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Figure 10: Navigator in Calc
The Navigator provides several convenient ways to move around a document and find items in it:

• When a category is showing the list of objects in it, double-click on an object to jump
directly to that object location in the document.

• Objects are much easier to find if you have given them recognisable names when creating
them, instead of keeping the LibreOffice default names, for example Sheet1, Table1,
Table2, and so on. The default names may not correspond to the actual position of the
object in the document.

• Each Navigator in the individual LibreOffice components has a different range of functions
and these functions are further explained in the appropriate user guides for each
LibreOffice component.

Undoing and redoing changes
To undo the most recent change in a document, use the keyboard shortcut Ctrl+Z, or click the
Undo icon
on the Standard toolbar, or go to Edit > Undo on the main menu bar. Click the
small triangle to the right of the Undo icon to get a list of all the changes that can be undone. You
can select multiple changes and undo them at the same time.
After changes have been undone, you can redo changes. To redo a change use the keyboard
shortcut Ctrl+Y, or click the Redo icon
, or go to Edit > Redo on the main menu bar. As with
Undo, click on the triangle to the right of the arrow to get a list of the changes that can be
reapplied.
To modify the number of changes LibreOffice remembers, go to Tools > Options > LibreOffice >
Memory on the main menu bar. In the Undo section increase or decrease the Number of steps.
Be aware that asking LibreOffice to remember more changes consumes more computer memory.

Undoing and redoing changes
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Closing a document
If there is only one document open and you want to close the document, go to File > Close on the
menu bar or click on the X on the menu bar.
If more than one document is open, go to File > Close on the menu bar or click on the X on the
title bar of the window. The X may be located on either the right or left end of the title bar. When the
last document is open, the X on the menu bar appears.
If the document has not been saved since the last change, a message box is displayed. Choose
whether to save or discard your changes.

Caution

Not saving your document could result in the loss of recently made changes, or
worse still, your entire file.

Closing LibreOffice
To close LibreOffice completely, go to File > Exit on the Menu bar in Windows and Linux operating
systems. In a Mac operating system, go to LibreOffice > Quit LibreOffice on the menu bar.
When you close the last document using the X on the title bar of the window, then LibreOffice will
close completely. A Mac operating system does not have this function; instead, you need to go to
LibreOffice > Quit LibreOffice on the menu bar.
You can also use a keyboard shortcut as follows:

• In Windows and Linux – Ctrl+Q
• In Mac OS X – Command +Q
If any documents have not been saved since the last change, a message box is displayed. Choose
whether to save or discard your changes.
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