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What is Draw?
LibreOffice Draw is a vector graphics drawing program. It can also perform some operations on
raster graphics (pixels). Using Draw, a wide variety of graphical images are easily and quickly
created.
Vector graphics store and display an image as an assembly of simple geometric elements such
as lines, circles, and polygons, rather than a collection of pixels (points on the screen). Vector
graphics allow for easier storage and scaling of the image.
Draw is fully integrated into the LibreOffice suite simplifying the exchange of graphics with all
components of the LibreOffice suite. If an image is created in Draw, reusing it in a Writer
document is relatively easy. For example, select and copy the drawing in Draw and then paste
the image directly into a Writer document. Also, drawings can be worked on directly from within
Writer or Impress, using a subset of the functions and tools from Draw.
The functionality of Draw is extensive. Draw was not designed to rival high-end graphics
applications, but it possesses more functionality than the drawing tools that are integrated with
many office productivity suites. A few examples of the drawing functions are as follows:
Layer management
Magnetic grid-point system
Dimensions and measurement display
Connectors for making organization charts and other diagrams
3D functions for creating small three-dimensional drawings
Drawing and page-style integration
Bézier curves
This chapter introduces some features of Draw, but it does not attempt to cover all of the Draw
features. See the Draw Guide and LibreOffice Help for more information.

Figure 1: Draw main window
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Draw main window
Workspace
The large area in the center of the Draw main window (Figure 1) is the Workspace, where
drawings are created. This drawing area can be surrounded with toolbars and information areas.
The number and position of the visible tools vary with the task in hand, user preferences, and
computer setup.
The maximum size of a drawing page in Draw is limited by the computer setup and the page size
that that can be set and used in the printer connected to the computer.

Pages pane
Drawings can be split over several pages. Multi-page drawings are used mainly for
presentations. The Pages pane on the left side of the Draw main window provides an overview of
the pages that are created in a drawing. If the Pages pane is not visible, go to View > Page Pane
on the Menu bar. The Pages pane is also used to make changes to the page order by dragging
and dropping one or more pages.

Layers bar
A layer is a workplace where drawing elements and objects can be inserted. By default, the
Workspace consists of three layers (Layout, Controls, and Dimension Lines). These default
layers cannot be deleted or renamed, but layers can be added when necessary.
Tabs for default and other layers appear in the Layers bar at the bottom of the Workspace. The
Layers bar can be used to navigate between layers, add layers as required, or delete layers that
have been added. For more information, see “Working with layers” on page 33.

Sidebar
The Sidebar in Draw is similar to the Sidebar in the other LibreOffice components. In Draw, it has
five main decks. To open a deck, click on its icon on the right of the Sidebar, or click on the
Sidebar Settings icon at the top of the tab bar and select a deck in the drop-down list. If the
Sidebar is not visible, go to View > Sidebar on the Menu bar.
Properties
Contains panels where properties of a selected object in a drawing can be changed: Page,
Character, Paragraph, Area, Effect, Shadow, Line, Position and Size, Columns, and
Image. Available panels depend on the selected object.
Styles
Provides options to edit and apply one of the available Drawing Styles to objects in a
drawing. When a style is edited or modified, the changes are automatically applied to all of
the elements formatted using that style. In Draw, Presentation Styles are not available.
New drawing styles can be added to a drawing.
Gallery
Objects on the Gallery deck can be inserted into a drawing either as a copy or as a link.
The Gallery is divided into themes: Arrows, BPMN (Business Process Model and
Notation), Bullets, Diagrams, Flowchart, Icons, Network, Shapes, and Sounds. New
themes can be added to the Gallery. See Chapter 11, Images and Graphics, and the Draw
Guide for more information.
Navigator
On the Navigator deck, pages and objects in a drawing can be quickly selected. It is
recommended to give pages and objects meaningful names so they are easily identified
when using the Navigator.
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Shapes
Provides quick selection of most items that are available on the Drawing toolbar: Lines and
Arrows, Curves and Polygons, Connectors, Basic Shapes, Symbol Shapes, Block
Arrows, Flowchart, Callouts, Stars and Banners, and 3D Objects.

Rulers
Rulers are positioned on the upper and left-hand sides of the Workspace. If the rulers are not
visible, go to View > Rulers on the Menu bar. The rulers show the size of a selected object using
double lines (highlighted in Figure 2). Also the rulers can be used to manage object handles and
guide lines when positioning objects.
The page margins in the drawing area are also represented on the rulers. The margins can be
changed directly on the rulers by dragging the margins with the cursor. The margin areas are
indicated by the grayed-out area on the rulers (Figure 2).
To change the measurement units of the rulers, right-click on a ruler and select the measurement
unit in the drop-down list, as shown in Figure 3 for the horizontal ruler. The horizontal and vertical
rulers can be set to different measurement units.

Figure 2: Rulers showing object size

Figure 3: Ruler measurement units
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Figure 4: Status bar

Status bar
The Status bar (Figure 4) is located at the bottom of the Workspace in all LibreOffice
components. It includes several Draw-specific fields. For details on the contents and use of these
fields, see Chapter 1, Introducing LibreOffice, in this guide and the Draw Guide. To hide the
Status Bar, go to View on the Menu bar and deselect Status Bar.

Note
The measurement units shown on the Status Bar are set by going to Tools >
Options > LibreOffice Draw > General on the Menu bar. These units may be
different to the measurement units set for the rulers.

Toolbars
To display or hide the various Draw toolbars, go to View > Toolbars on the Menu bar and select
them in the drop-down menu. For more information on toolbars, see the Draw Guide.
The icons used for the tools on each toolbar depend on the computer operating system and how
LibreOffice has been set up on a computer. For more information, see Chapter 2, Setting Up
LibreOffice.
The three main toolbars used in Draw are:
•

Standard – this toolbar is similar for all LibreOffice components. By default it is docked at
the top of the Workspace when a Draw document is opened (Figure 5).

Figure 5: Standard toolbar
•

Drawing – this toolbar contains all the necessary functions for drawing various geometric
and freehand shapes, and for organizing them in the drawing. By default, it is locked into
position on the left of the Workspace (Figure 6).

Figure 6: Drawing toolbar
•

Line and Filling – this toolbar is normally docked at the top of the Workspace below the
Standard toolbar. The tools and pull-down lists on this toolbar vary according to the type
of object selected. The Line and Filling toolbar (Figure 7) only becomes active when an
object on the Workspace is selected.
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Figure 7: Line and Filling toolbar

Drawing basic shapes
Draw provides a wide range of shapes, located in palettes accessed on the Drawing toolbar or in
the Shapes deck on the Sidebar (Figure 8). See the Draw Guide for a complete description of the
basic shapes available.
Some of the tool icons on the Drawing toolbar change according to the shape that has been
selected. Also, some tools on a toolbar have extra tool palettes available and these are indicated
by a triangle ▼ to the right of the tool icon.

Note
When drawing a basic shape or selecting one for editing, the Information field in the
Status bar changes to reflect the present action, for example Line created, Text
frame xxyy selected, and so on.

Figure 8: Shapes deck on Sidebar
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Straight lines
1) Use one of the following methods to start drawing a line:
– Click on Insert Line on the Drawing toolbar.
– Click the triangle ▼ on the right of Lines and Arrows on the Drawing toolbar and
select Insert Line in the drop-down list.
– Click on Insert Line in the Lines and Arrows panel of the Shapes deck on the
Sidebar (Figure 8).
2) Place the cursor at the starting point on the drawing, then click and drag the cursor to
draw a straight line.
3) Release the mouse button when the end point is reached and a straight line is created. A
selection handle appears at each end of the line, showing that this object is the currently
selected object. The selection handle at the starting point of the line is slightly larger than
the other selection handle (as shown in Figure 9).

Figure 9: Line starting point

Figure 10: Line panel in Properties deck on
Sidebar
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Tip
To snap the end of a line to the nearest grid point, keep the Ctrl key (macOS ⌘)
pressed while drawing the line. However, if the Snap to Grid option in View > Snap
Guides on the Menu bar has been selected, the Ctrl key (macOS ⌘) deactivates the
snap to grid.
To restrict the drawing angle of a line to a multiple of 45 degrees (0, 45, 90, 135, and
so on), keep the Shift key pressed while drawing the line. However, if the option
When creating or moving objects in the Constrain Objects section of Tools >
Options > LibreOffice Draw > Grid has been selected, the Shift key deactivates
this restriction.
To draw a line symmetrically outwards in both directions from the start point, keep
the Alt key (macOS ⌥) pressed while drawing the line. This draws lines by starting
from the center of the line.
A line is drawn using default attributes. To change line attributes and format a line to the drawing
requirements, select the line by clicking on it and use one of the following methods to access
formatting options for the line:
•

Go to the Properties deck on the Sidebar and open the Line panel (Figure 10).

•

Right-click on a line and select Line in the context menu to open the Line dialog
(Figure 11).

•

Go to Format > Line on the Menu bar to open the Line dialog.

•

Use the tools Line Style, Line Width, and Line Color on the Line and Filling toolbar.

Figure 11: Line dialog - Line page
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Figure 12: Line and Arrows sub-toolbar

Arrows
Draw classifies both lines and arrows as lines. Arrows are drawn like straight lines. Hovering the
cursor over each tool in the Lines and Arrows sub-toolbar (Figure 12) indicates what type of line
or arrow each tool will draw. The information field on the Status Bar shows them only as lines.
1) Use one of the following methods to start drawing an arrow:
– Click the triangle ▼ on the right of Lines and Arrows on the Drawing toolbar and
select the type of arrow required from the Lines and Arrows sub-toolbar (Figure 12).
– Click on the type of arrow required in the Lines and Arrows panel of the Shapes
deck on the Sidebar.
2) Place the cursor at the starting point of the arrow, then click and drag the cursor. The
arrowhead is drawn when the mouse button is released.

Note
The tool icon for the Lines and Arrows tool used most recently will be shown on the
Drawing toolbar. This makes it easier to use the same tool again.

Note
After drawing a line or arrow, the line or arrow style can be changed by opening the
Line dialog and using the options available on the Line Styles or Arrow Styles pages.

Rectangles
1) Use one of the following methods to start drawing a rectangle:
– Click on Rectangle on the Drawing toolbar.
– Click the triangle ▼ on the right of Basic Shapes on the Drawing toolbar and select
Rectangle on the Basic Shapes sub-toolbar (Figure 13).
– Click on Rectangle in the Basic Shapes panel of the Shapes deck on the Sidebar.
– Select the type of rectangle on the Legacy Rectangles toolbar (Figure 14). To display
the toolbar, go to View > Toolbars on the Menu bar and select it.
2) Place the cursor at the starting point for the rectangle, then click and drag the cursor until
the required size is drawn. As the rectangle is drawn, the rectangle appears with its
bottom right corner attached to the cursor.
3) To draw a rectangle from its center, position the cursor on the drawing, press the mouse
button and then hold down the Alt key (macOS ⌥) while dragging the cursor. The
rectangle uses the start point as the center of the rectangle.

Figure 13: Basic Shapes sub-toolbar
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Figure 14: Legacy Rectangles
toolbar

Squares
1) Use one of the following methods to start drawing a square:
– Click on Rectangle on the Drawing toolbar, then hold down the Shift key while
dragging the cursor to draw a square.
– Click the triangle ▼ on the right of Basic Shapes on the Drawing toolbar and select
Square on the Basic Shapes sub-toolbar (Figure 13).
– Click on Square in the Basic Shapes panel of the Shapes deck on the Sidebar.
– Select the type of square from the Legacy Rectangles toolbar (Figure 14). To display
the toolbar, go to View > Toolbars on the Menu bar and select it.
2) Place the cursor at the starting point for the square, then click and drag the cursor until
the required size is drawn. As the square is drawn, the square appears with its bottom
right corner attached to the cursor.
3) To draw a square from its center, position the cursor on the drawing, press the mouse
button and then hold down the Alt key (macOS ⌥) while dragging the cursor. The square
uses the start point as the center of the square.

Ellipses (ovals)
1) Use one of the following methods to start drawing an ellipse:
– Click on Ellipse on the Drawing toolbar.
– Click the triangle ▼ on the right of Basic Shapes on the Drawing toolbar and select
Ellipse on the Basic Shapes sub-toolbar (Figure 13).
– Click on Ellipse in the Basic Shapes panel of the Shapes deck on the Sidebar.
– Select the type of ellipse on the Legacy Circles and Ovals toolbar (Figure 15). To
display the toolbar, go to View > Toolbars on the Menu bar and select it.
2) Place the cursor at the starting point for the ellipse, then click and drag the cursor until
the required size is drawn. As the ellipse is drawn, the ellipse appears with its bottom
right corner attached to the cursor.
3) To draw an ellipse from its center, position the cursor on the drawing, press the mouse
button and then hold down the Alt key (macOS ⌥) while dragging with the cursor. The
ellipse uses the start point as the center of the ellipse.

Figure 15: Legacy Circles and Ovals toolbar

Circles
1) Use one of the following methods to start drawing a circle:
– Click on Ellipse on the Drawing toolbar, then hold down the Shift key while dragging
the cursor to draw a circle.
– Click the triangle ▼ on the right of Basic Shapes on the Drawing toolbar and select
Circle on the Basic Shapes sub-toolbar (Figure 13).
Drawing basic shapes | 13

– Click on Circle in the Basic Shapes panel of the Shapes deck on the Sidebar.
– Select the type of circle on the Legacy Circles and Ovals toolbar (Figure 15). To
display the toolbar, go to View > Toolbars on the Menu bar and select it.
2) Place the cursor at the starting point for the circle, then click and drag the cursor until the
required size is drawn. As the circle is drawn, the circle appears with its bottom right
corner attached to the cursor.
3) To draw a circle from its center, position the cursor on the drawing, press the mouse
button and then hold down the Alt key (macOS ⌥) while dragging with the cursor. The
circle uses the start point as the center of the circle.

Tip
To quickly insert a line, rectangle, ellipse, or circle, press and hold down the Ctrl key
(macOS ⌘) and then click on one of the icons for Line, Rectangle, Ellipse, or Circle
and a standard sized object is drawn automatically in the work area. The size, shape,
and Color are all standard values. These attributes can be changed later, if desired.
For more information, see the Draw Guide.

Dimension lines
Dimension lines display a measurement of an object in the drawing (Figure 16). The dimension
line does not belong to the object itself, but it is normally placed close to it.

Figure 16: Example of object
dimension lines
1) Use one of the following methods to start drawing a dimension line:
– Click the triangle ▼ on the right of Lines and Arrows on the Drawing toolbar and
select Dimension Line on the Lines and Arrows sub-toolbar that opens.
– Click on Dimension Line in the Lines and Arrows panel of the Shapes deck on the
Sidebar.
2) Place the cursor close to the object to position the start of the dimension line.
3) Click and drag the cursor to draw the dimension line. As the dimension line is drawn, the
dimension is displayed and automatically calculated. To change the measurement unit
used for dimension lines, go to Tools > Options > LibreOffice Draw > General on the
Menu bar.
4) To change the display of a dimension line and its appearance, right-click on the
dimension line and select Dimensions in the context menu to open the Dimension Line
dialog (Figure 17).
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5) Select the required options in Line and Legend, then click OK to save the changes and
close the Line Dimension dialog.

Figure 17: Dimension Line dialog

Curves
1) Use one of the following methods to start drawing a curve:
– Click the triangle ▼ on the right of Curves and Polygons on the Drawing toolbar and
select the type of curve on the Curves and Polygons sub-toolbar (Figure 18).
– Click on the type of curve required in the Curves and Polygons panel of the Shapes
deck on the Sidebar.
2) Click and hold the left mouse button to create the starting point of the curve, then drag
from the starting point to draw a line. Release the mouse button and continue to drag the
cursor to bend the line into a curve.
3) Double-click to set the end point of the curve and fix the curve on the drawing. A filled
curve automatically joins the last point to the first point, closing the curve and filling it with
the selected fill color. A curve without fill will not be closed at the end of drawing the curve.

Note
A single click fixes the curve to the drawing and allows drawing of straight lines from
the end of the curve. Each single click allows the drawing of another straight line.
Double-click to end drawing a curve with straight lines.

Figure 18: Curves and
Polygons sub-toolbar
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Polygons
1) Use one of the following methods to start drawing a polygon:
– Click the triangle ▼ on the right of Curves and Polygons on the Drawing toolbar and
select the type of polygon on the Curves and Polygons sub-toolbar (Figure 18).
– Click on the type of polygon required in the Curves and Polygons panel of the
Shapes deck on the Sidebar.
2) Click and hold the left mouse button to create the starting point of the polygon, then drag
from the starting point to draw a line.
3) Release the mouse button and continue to drag the cursor to draw the next line for
polygon, then click to mark the end point of the line and to start drawing another line.
Holding the Shift key down while drawing lines restricts the angles used in the polygon to
45° or 90°.
4) Double-click to set the end point of the polygon and fix the polygon on the drawing. A
filled polygon automatically joins the last point to the first point, closing the polygon and
filling it with the selected fill Color. A polygon without fill will not be closed at the end of
drawing the polygon.

Polygons 45°
A polygon 45° is drawn using the same procedure as polygons, but the angles between lines are
restricted to 45° or 90°. This restriction of angles cannot be changed. However, and if required,
hold down the Shift key as the line is drawn so that the line is drawn at an angle other than 45 or
90 degrees.
A filled polygon 45° automatically joins the last point to the first point, closing the polygon and
filling it with the selected fill color.

Freeform lines
Drawing a freeform line is similar to drawing with a pencil on paper.
1) Use one of the following methods to start drawing a freeform line:
– Click the triangle ▼ on the right of Curves and Polygons on the Drawing toolbar and
select the type of freeform line on the Curves and Polygons sub-toolbar (Figure 18).
– Click on the type of freeform line required in the Curves and Polygons panel of the
Shapes deck on the Sidebar.
2) Click and drag the cursor to create the freeform line shape required.
3) Release the mouse button when satisfied with the freeform line and the drawing is
completed. A filled freeform line automatically joins the last point to the first point, closing
the freeform line and filling it with the selected fill color.

Glue points and connectors
Glue points
All Draw objects have glue points, which are not normally displayed. Glue points (Figure 19)
become visible on an object when a connector is selected on the Drawing toolbar or in the
Shapes deck on the Sidebar.
Most objects have four glue points (Figure 19). More glue points can be added and customized
using the Gluepoints toolbar (Figure 20). If the Gluepoints toolbar is not visible, go to View >
Toolbars > Gluepoints on the Menu bar to open the toolbar. For a more detailed description on
adding and using glue points, see the Draw Guide.
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Glue points are not the same as the selection handles of an object. Selection handles are for
moving or changing the shape of an object. Glue points are used to fix or glue a connector to an
object so that when the object moves, the connector stays fixed to the object.

Figure 19: Example of object glue points

Figure 20: Gluepoints toolbar

Connectors
Connectors are lines or arrows whose ends automatically snap to a glue point of an object.
Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps.
When objects are moved or reordered, the connectors remain attached to a glue point. Figure 21
shows an example of using two objects and a connector. For a more detailed description of the
use of connectors, see the Draw Guide.
1) Use one of the following methods to select a connector:
– Click the triangle ▼ on the right of Connectors on the Drawing toolbar and select the
type of connector on the Connectors sub-toolbar (Figure 22).
– Click on the type of connector required in the Connectors panel of the Shapes deck
on the Sidebar.
2) Move the cursor over one of the objects to be connected. Small crosses (the glue points)
appear around the object edges. Click on the required glue point for the start of the
connector, then drag the cursor to drag the connector to another object.
3) When the cursor is over a glue point of the target object, release the mouse button and
the connector is drawn. The connector end point is attached to the glue point.

Figure 21: Example of a connector between two objects

Figure 22: Connectors sub-toolbar
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Geometric shapes
Geometric shapes are similar to basic shapes. They are provided in Draw as a starting point
when creating objects for a drawing. Geometric shapes are located on the Drawing toolbar and in
the Shapes deck on the Sidebar.
The tool icons on the Drawing toolbar always indicate the last geometric shape drawn. This
makes it easier to use the same tool again.
Access geometric shapes using one of the following methods:
•

Click on Shapes on the Sidebar to open the Shapes deck, then choose from the
geometric shapes available.

•

Click the triangle ▼ on the right of a geometric shape on the Drawing toolbar to open a
sub-toolbar giving access to more geometric shape tools.

Using geometric shapes is similar to drawing rectangles, squares, ellipses, or circles as
explained in “Drawing basic shapes” on page 9. Text can be added to all geometric shapes. See
“Adding and formatting text” on page 20 and the Draw Guide.

Basic shapes
The Basic Shapes sub-toolbar (Figure 23) also includes rectangle and ellipse tools that are
identical to the ones displayed on the Drawing toolbar.

Figure 23: Basic Shapes sub-toolbar
Basic shapes from left to right
(1) Rectangle
(9) Circle Pie
(2) Rectangle, Rounded
(10) Circle Segment
(3) Square
(11) Arc
(4) Square, Rounded
(12) Block Arc
(5) Parallelogram
(13) Isosceles Triangle
(6) Trapezoid
(14) Right-angle Triangle
(7) Ellipse
(15) Diamond
(8) Circle
(16) Regular Pentagon

(17) Hexagon
(18) Octagon
(19) Cylinder
(20) Cube
(21) Folded Corner
(22) Cross
(23) Frame
(24) Ring

Symbol shapes

Figure 24: Symbol Shapes sub-toolbar
Symbol shapes from left to right
(1) Smiley Face
(7) Flower
(2) Heart
(8) Prohibited
(3) Sun
(9) Puzzle
(4) Moon
(10) Square Bevel
(5) Cloud
(11) Octagonal Bevel
(6) Lightning Bolt
(12) Diamond Bevel
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(13) Double Bracket
(14) Left Bracket
(15) Right Bracket
(16) Double Brace
(17) Left Brace
(18) Right Brace

Block arrows

Figure 25: Block Arrows sub-toolbar
Block arrows from left to right
(1) Right Arrow
(10) Right or Left Arrow
(2) Left Arrow
(11) 4-way Arrow
(3) Down Arrow
(12) Corner Right Arrow
(4) Up Arrow
(13) Chevron
(5) Left and Right Arrow
(14) Pentagon
(6) Up and Down Arrow
(15) Striped Right Arrow
(7) Circular Arrow
(16) Up, Right and Down Arrow
(8) S-shaped Arrow
(17) Notched Right Arrow
(9) Split Arrow
(18) Up and Right Arrow

(19) Right Arrow Callout
(20) Left Arrow Callout
(21) Down Arrow Callout
(22) Up Arrow Callout
(23) Left and Right Arrow Callout
(24) Up and Down Arrow Callout
(25) 4-way Arrow Callout
(26) Up and Right Arrow Callout

Flowchart

Figure 26: Flowchart sub-toolbar
Flowchart shapes from left to right
(1) Flowchart: Process
(11) Flowchart: Manual Input
(21) Flowchart: Extract
(2) Flowchart: Alternate Process (12) Flowchart: Manual Operation (22) Flowchart: Merge
(3) Flowchart: Decision
(13) Flowchart: Connector
(23) Flowchart: Stored Data
(4) Flowchart: Data
(14) Flowchart: Off-page
(24) Flowchart: Delay
(5) Flowchart: Predefined
Connector
(25) Flowchart: Sequential Access
Process
(15) Flowchart: Card
(26) Flowchart: Magnetic Disc
(6) Flowchart: Internal Process (16) Flowchart: Punched Tape
(27) Flowchart: Direct Access
(7) Flowchart: Document
(17) Flowchart: Summing Junction
Storage
(8) Flowchart: Multidocument
(18) Flowchart: Or
(28) Flowchart: Display
(9) Flowchart: Terminator
(19) Flowchart: Collate
(10) Flowchart: Preparation
(20) Flowchart: Sort

Callout Shapes

Figure 27: Callouts
sub-toolbar
Callout Shapes from left to right
(1) Rectangular Callout
(4) Cloud
(2) Rounded Rectangular Callout (5) Line Callout 1
(3) Round Callout
(6) Line Callout 2

(7) Line Callout 3

Stars and banners

Figure 28: Stars and Banners sub-toolbar
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Stars and banners from left to right
(1) 4-Pointed Star
(5) 12-Pointed Star
(2) 5-Pointed Star
(6) 24-Pointed Star
(3) 6-Pointed Star
(7) Explosion
(4) 8-Pointed Star
(8) Vertical Scroll

(9) Horizontal Scroll
(10) Signet
(11) Door-plate
(12) 6-Point Star, Concave

3D objects

Figure 29: 3-D Objects
sub-toolbar
3D objects from left to right
(1) Cube
(4) Cone
(2) Sphere
(5) Pyramid
(3) Cylinder
(6) Torus

(7) Shell
(8) Hemisphere

Adding and formatting text
Drawings created in Draw are likely to contain some text. This section gives some guidelines on
how to add text and change its appearance. Text added to drawings can be contained in text
boxes, objects, or shapes. For more information on adding and formatting text, see the Draw
Guide.
•

A text box is an independent Draw object that is dynamic and expands as more text is
added within the frame.

•

An object or shape in a drawing is not dynamic, which means that the boundary rectangle
does not expand as text is added. Care must be taken when adding text to prevent the
text from extending outside the object or shape boundaries.

Text mode
Before adding any text to a drawing, text mode has to be activated using one of the following
methods:
•

Click on Insert Text Box on the Standard or Drawing toolbars.

•

Go to Insert > Text Box on the Menu bar.

•

Use the keyboard shortcut F2.

•

Double-click inside an object on the drawing. Text inside an object is not placed into a
text box.

The Text Formatting toolbar (Figure 30) automatically opens when text mode is activated,
replacing the Line and Filling toolbar.

Figure 30: Text Formatting toolbar
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Text boxes
1) Activate text mode as above.
2) Create a text box in the drawing using one of the following methods. The Status bar
indicates Text Edit mode and the position of the cursor (Figure 31).
– Click at the approximate position for the text box and a single line text box is created
containing a flashing cursor. Start typing the text or paste copied text into the text box.
The width of a single line text box increases as text is added.
– Click at the approximate position for the text and drag the cursor to the approximate
width required for the text box creating a multi-line text box. Start typing the text or
paste copied text into the text box. As the horizontal limit of the text box is reached,
the text automatically word wraps inside the text box and the text box expands
vertically as it fills.
– If necessary, create multiple lines of text in a single-line text box by pressing Enter to
create a new paragraph, or using Shift+Enter to create a line break in the text.
3) When adding text is complete, click outside the text box to exit text mode. The Text
Formatting toolbar closes and the Line and Filling toolbar opens in its original position.
4) To format and/or reposition the text box, see the Draw Guide for more information.

Figure 31: Text information in Status bar

Vertical text
By default, Draw is set for horizontal text only. To enable vertical text:
1) Go to Tools > Options > Language Settings > Languages.
2) Under Default Languages for Documents, select Asian and accept the default
language shown.
3) Right-click in a blank area on the Standard and/or Drawing toolbar and select Visible
Buttons in the context menu.
4) Select Insert Vertical Text in the list of available tools to enable vertical text on the
Standard and/or Drawing toolbar.

Note
Formatting vertical text and vertical text boxes is the same as horizontal text and
horizontal text boxes. A vertical text box expands vertically as text is added into the
box. For more information on vertical text, see the Draw Guide.

Text in Draw objects
Text can be added to most Draw objects. The exceptions are control elements, for example
buttons, polygons, curves, or 3D objects.

Adding and formatting text | 21

By default, an object is not dynamic when created in Draw and does not behave like a text box.
Any text added to an object does not word wrap inside the object. To keep text within the borders
of an object, use word wrap, paragraphs, line breaks, smaller text size, increasing object size, or
a combination of all methods. For more information on adding text to objects, see the Draw
Guide.
1) Create an object in a drawing and make sure the object is selected with the selection
handles displayed.
2) Enter text mode on the selected object using one of the following methods:
– Click on Insert Text Box for horizontal text or Insert Vertical Text for vertical text on
the Standard or Drawing toolbar.
– For horizontal text, double-click on the selected object.
– For vertical text, double-click on the selected object and click on Insert Vertical Text
on the Standard or Drawing toolbar.
3) Type or paste text into the selected object.
4) If the text goes outside the object borders, format the text using the various tools on the
Text Formatting toolbar, the panels in the Properties deck on the Sidebar, the options in
Format on the Menu bar, or the Text page in the Text dialog. For more information on text
formatting, see the Draw Guide.
5) Move the cursor away from the object, then click to deselect the object ending text mode
and saving the changes.

Creating lists
Unordered (bulleted) or ordered (numbered) lists can be created in text boxes or Draw objects.
For more information on lists, see the Draw Guide.
1) Select all of the text required for a list.
2) Create a list using one of the following methods and default settings for lists:
– Click on Toggle Unordered List or Toggle Ordered List on the Text Formatting
toolbar.
– Click on Toggle Unordered List or Toggle Ordered List in the Lists panel in the
Properties deck on the Sidebar.
– Go to Format > Lists > Unordered List or Ordered List on the Menu bar.
3) To change the format of the list, click on the triangle ▼ on the right of the list icons and
select a list style from the options available.

Text columns
Text in a drawing can be formatted into columns inside text boxes and objects. However, columns
cannot be used on separate parts of text inside a text box or object. The whole of the text box or
object has to be used for columns. For more information on text columns, see the Draw Guide.
1) For text boxes – click the border of a text box to select it so that the selection handles are
displayed indicating that the text box is in edit mode.
2) For graphic objects – double-click on a graphic object to select it so that the selection
handles are displayed and the cursor flashes in the center of the object indicating that the
object is in text edit mode.
3) Open the options for text columns using one of the following methods:
– Right-click in the text box or graphic object and select Text Attributes in the context
menu to open the Text dialog, then click on the Text Columns tab to open the Text
Columns page,
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– Click on Columns in Properties on the Sidebar to open the Columns panel.
4) Set the number of columns required in the Number of columns box and the required
spacing between the columns in the Spacing box.
5) Save the changes and deselect the text box or graphic object using one of the following
methods:
– For the Text dialog, click OK to save the changes and close the dialog, then click
outside the text box to deselect it.
– For the Columns panel in the Properties deck on the Sidebar, click outside the text
box or graphic object to deselect it and save the changes.
6) Type in the required text or use copy and paste to enter the required text into the text box
or graphic object. Any text entered will be in column format.
7) If necessary, format the text to the presentation requirements.
8) Click outside the text box or graphic object to deselect it and save the changes.

Note
Any text inside a text box or graphic object automatically flows into column format
when the changes are saved.

Selecting objects
Direct selection
The easiest way to select an object is to click directly on it. For objects that are not filled, click on
the object outline to select it. To select or deselect more than one object, hold the Shift key down
while clicking on each object.

Selection by framing
Several objects can be selected at the same time by clicking and dragging the cursor to draw a
selection rectangle (also known as a marquee) around the objects. Only objects that lie entirely
within this selection rectangle are selected. To select multiple objects by framing, Select on the
Drawing toolbar must be active.

Selecting hidden objects
If objects are located behind others and not visible, they can still be selected. When selecting a
hidden object, its selection handles appear through the objects covering it.
•

Windows, macOS or Linux – press the Tab key to select and cycle through the objects
in a drawing, stopping at the hidden object to select it. To cycle through the objects in
reverse order, press Shift+Tab.

•

Windows or macOS only – select the object in front of a hidden object, then press the
Alt key (macOS ⌥) and click to select the hidden object. If there are several hidden
objects, keep holding down the Alt key (macOS ⌥) and clicking until the object required
is reached. To cycle through the objects in reverse order, hold down the Alt+Shift keys
(macOS ⌥+Shift) and click.
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Arranging objects
In a complex drawing, several objects may be stacked on top of one another. This stacking order
can be rearranged by moving an object forward or backward using one of the following methods:
•

Select an object, go to Shape > Arrange on the Menu bar, or right-click on the object and
select Arrange in the drop-down menu, then choose one of the following options:
– Bring to Front (Ctrl+Shift++) (macOS ⌘+Shift++)
– Bring Forward (Ctrl++) (macOS ⌘++)
– Send Backward (Ctrl+-) (macOS ⌘+–)
– Send to Back (Ctrl+Shift+-) (macOS ⌘+Shift+–)
– In Front of Object
– Behind Object
– Reverse – clicking on this option reverses the order of the selected objects.

•

Select an object, then click on one of the Arrange tools on the Line and Filling toolbar.
When you hover the cursor over a tool, its function is indicated.

Positioning and adjusting objects
When positioning or changing the size of an object, check the information area of the Status bar
at the bottom of the Draw Workspace (Figure 32). From left to right, it shows what object is
selected, its position on the drawing in X/Y coordinates, and the dimensions of the object. The
measurement units are those selected in Tools > Options > LibreOffice Draw > General.
For more information on positioning and adjusting objects, see the Draw Guide.

Using zoom
To help in the positioning and adjustment of objects, Draw has a zoom function that reduces or
enlarges the screen display of the current drawing. For example, zoom in to position objects on a
drawing with greater accuracy; zoom out to see the complete drawing. Zooming is controlled
using the Status bar, Zoom & View Layout dialog, or Zoom toolbar. For more information on using
zoom, see the Draw Guide.

Figure 32: Information on left end of Status Bar when working with objects
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Moving objects
To move an object (or a group of objects), select it and then click within the object borders and
hold down the left mouse button while dragging the mouse. During movement, a ghost image of
the object appears to help with repositioning (Figure 33). To locate the object at its new position,
release the mouse button.

Figure 33: Moving objects

Adjusting object size
To change the size of a selected object (or a group of selected objects), move the cursor to one
of the selection handles. The cursor changes shape to indicate the direction of movement for that
selection handle. As the object size changes, a ghosted outline of the object appears (Figure 34).
When the desired size of the object is reached, release the mouse button.
The results depend on which selection handle is being used. To resize an object along one axis,
use a side, top, or bottom handle. To resize along both axes, use a corner handle.

Figure 34: Adjusting object size

Note
Press and hold the Shift key while resizing an object, the change in size is carried out
symmetrically with respect to the object width and height so that the aspect ratio of
the object remains the same. This Shift key behavior works on all selection handles.

Rotating or slanting objects
To rotate or slant an object (or a group of objects), select it and switch to rotation mode using one
of the following methods:
•

Right-click on the object and select Transformations > Rotate in the context menu.

•

Click on the triangle ▼ on the right of Transformations on the Standard or Line & Filling
toolbars and select Rotate.
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The selection handles change shape and Color and a center of rotation appears in the center of
the object. As the cursor is moved over the handles, the cursor changes shape to indicate the
type of movement.

Rotation
1) Click and hold the mouse button over a corner selection handle, then move the cursor to
rotate the object. A ghost image of the object being rotated appears and the current angle
of rotation is shown in the Status bar (Figure 35).
2) When the object is at the desired rotation angle, release the mouse button.
3) To change the angle of rotation, click on the rotation point and drag it to another position.
This position can be outside the object.

Note
Press the Shift key while rotating or slanting an object and the movement is restricted
to 15°.

Figure 35: Rotating an object

Slanting
1) Click and hold the mouse button over a selection handle at the top, bottom, left side, or
right side of an object.
2) Drag the selection handle to slant the object. A ghost image of the object being slanted
appears (Figure 36) and the current slant angle is shown in the Status bar. The axis used
for slanting an object is fixed to the edge of the object directly opposite the selection
handle being used to slant the object.
3) When the object is at the desired slant angle, release the mouse button.

Figure 36: Slanting an object
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Flipping objects
Select an object so that the selection handles are displayed and flip the object vertically or
horizontally using one of the following methods:
•

Right-click on the object and select Flip > Vertically or Horizontally in the context menu.

•

Go to Shape > Flip > Vertically or Horizontally on the Menu bar.

•

Click on Vertically or Horizontally tool on the Line and Filling toolbar.

•

Use Flip Vertically or Flip Horizontally tool in the Position and Size section on the
Properties deck of the Sidebar.

However, the Flip tool on the Transformations toolbar (Figure 40) provides greater control over
the flipping process. Use the Flip tool to change the position and angle that the object flips over.
See the Draw Guide for more information.

Figure 37: Transformations
toolbar

Object distortion
Three tools on the Transformations toolbar (Figure 37) allow the dragging of the corners and
edges of an object to distort an object.
•

Distort – distorts an object in perspective.

•

Set in Circle (perspective) – creates a pseudo 3D effect.

•

Set to Circle (slant) – creates a pseudo 3D effect. Despite the (slant) in the name of this
tool, it operates differently from the slanting created by rotation.

In all three cases, the object has to be converted into a curve. This is a necessary first step, so
click Yes, then move the object handles to produce the desired effect. See the Draw Guide for
more information on how to distort an object.

Dynamic gradients
Transparency gradients can be controlled the same as Color gradients and both types of gradient
can be used together. With a transparency gradient, the direction and degree of the object fill
Color changes from opaque to transparent. In a Color gradient, the fill changes from one Color to
another, but the degree of transparency remains the same. An example of a dynamic gradient is
shown in Figure 38.
Two tools on the Transformations toolbar are used to dynamically control transparency and Color
gradients – Interactive Transparency and Interactive Gradient. See the Draw Guide for more
information on how to create transparencies and gradients in an object.
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Figure 38: Dynamic gradient example

Duplication
Duplication makes copies of an object while applying a set of changes such as Color or rotation
to the duplicates that are created. An example of duplication is shown in Figure 39. For more
information on duplication, see the Draw Guide.

Figure 39: Duplication example
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Figure 40: Duplicate dialog
1) Click on an object or group of objects and open the Duplicate dialog (Figure 40) using
one of the following methods:
– Go to Edit > Duplicate on the Menu bar.
– Go to Shape > Duplicate on the Menu bar.
– Use the keyboard shortcut Shift+F3.
2) Select the required number of copies, placement, enlargement, and colors.
3) Click OK to duplicate the object and close the Duplicate dialog.

Cross-fading
Cross-fading transforms one object shape to another object shape. The result is a new group of
objects with the first object selected as the start object and the second object selected as the end
object. For example, when the options in the Cross-fading dialog are applied to a diamond and
an ellipse, the cross-fading produces the result shown by the example in Figure 41.
1) Select two differently shaped objects and go to Shape > Cross-fading on the Menu bar
to open the Cross-fading dialog (Figure 42).
2) In Increments enter the number of shapes between the two objects.
3) Select Cross-fading attributes to apply a gradual change of line and fill properties
between the two objects.
4) Select Same orientation to apply a smooth transition between the two objects.
5) Click OK to carry out the cross-fading and close the Cross-fading dialog.
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Figure 41: Cross-fading example of two objects

Figure 42: Cross-fading dialog

Grouping and combining multiple objects
Using Draw, a group of objects can be grouped together allowing multiple objects to be treated
as one object, or combined together to create a new shape, as shown by the example in
Figure 43. For more information on grouping and combining objects, see the Draw Guide.

Grouping
Grouping of objects is similar to putting objects into a container. The objects can be moved as a
group and global changes applied to the objects within the group. A group can always be undone
(ungroup). Objects that make up a group can always be manipulated separately and retain their
own individual properties.

Temporary grouping
A temporary grouping is when several objects are selected using one of the following methods:
•

While holding down the Shift key, click on each object with the cursor to select it for the
temporary group.

•

Using the mouse, click and drag a rectangle (also known as a marquee) around the
objects for the temporary group.
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Figure 43: Example of grouped and combined objects
Any changes to object parameters carried out are applied to all of the objects within the
temporary group. For example, rotating a temporary group of objects in its entirety.
To cancel a temporary grouping of objects, click outside of the selection handles displayed
around the objects.

Permanent grouping
A permanent grouping of objects can be created after selecting objects using one of the following
methods:
•

Go to Shape > Group > Group on the Menu bar.

•

Right-click on the selected objects and select Group in the context menu.

•

Use the keyboard shortcut Ctrl+Shift+G (macOS ⌘+Shift+G)

When deselected, the objects remain grouped together. Any editing operations carried out on the
group are applied to all objects within the group. If one object in the group is clicked, the whole
group is selected.

Editing within groups
Editing an individual within a group can be carried out without ungrouping or breaking the group.
After selecting the group, use one of the following methods to enter the group:
•

Go to Shape > Group > Enter Group on the Menu bar.

•

Right-click on the selected group and select Enter Group in the context menu.

•

Use the keyboard shortcut F3.

•

Double-click on the selected group.

When editing is finished on an individual object within a group, use one of the following methods
to exit the group:
•

Go to Shape > Group > Exit Group on the Menu bar.

•

Right-click and select Exit Group in the context menu.

•

Use the keyboard shortcut Shift+F3.
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Ungrouping
To ungroup or break apart a permanent group of objects, use one of the following methods after
selecting the group:
•

Go to Shape > Group > Ungroup on the Menu bar.

•

Right-click and select Ungroup in the context menu.

•

Use the keyboard shortcut Ctrl+Alt+Shift+G.

Nesting groups
A group of groups, more commonly known as nested groups, can be created. When nested
groups are created, Draw retains the individual group hierarchy and remembers the order in
which groups were selected. That is, the last individual group selected will be on top of all the
other groups within a nested group. Ungrouping and entering a nested group work in the same
way as for individual groups.

Combining objects
Combining is a permanent merging of objects, creating a new object. The original objects are no
longer available as individual entities and cannot be edited as individual objects. Any editing of a
combined object affects all the objects that were used when combination was carried out. For
more information on combining objects, see the Draw Guide.
After selecting the objects for combining, use one of the following methods to create a new
object. An example of combining objects is shown in Figure 43 on page 31.
•

Go to Shape > Combine on the Menu bar.

•

Right-click on the objects and select Shapes > Combine in the context menu.

•

Use the keyboard shortcut Ctrl+Shift+K.

Merging, subtracting, and intersection
After selecting several objects, the Merge, Subtract, and Intersect functions become available.
These functions are similar to combining objects, but allow the creation of a differently shaped
object from the selected objects. The shape of the object depends on which function used. See
the Draw Guide for more information on how to use these functions.

Arranging, aligning, and distributing objects
In Draw, selected objects can be arranged, aligned, and distributed in relation to each other. See
the Draw Guide for more information on arranging and aligning objects.
•

Arrange the position of an object by moving it either forward or backward in relation to the
order of objects.

•

Align objects with respect to each other using Left, Centered, or Right for horizontal
alignment and Top, Center, or Bottom for vertical alignment.

•

Distribute objects so that the space between each of the objects is the same.

Inserting and exporting images
Inserting
Draw contains a number of functions for editing images (also called pictures, raster graphics, or
bitmaps). These functions include the import and export of images, and conversion from one
image format to another. For more information on working with images, see Chapter 11, Images
and Graphics, in this guide and the Draw Guide.
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Draw includes a large range of filters so that it can read and display several image file formats. It
also includes several tools for working with images, but does not have the same functionality as
specialized programs like GIMP or Adobe Photoshop.
Images can be added from several sources:
•

Directly from a scanner (Insert > Media > Scan on the Menu bar).

•

Created by another program, for example photographs from a digital camera (Insert >
Image on the Menu bar).

•

The LibreOffice Gallery; see Chapter 11, Images and Graphics.

Exporting
Draw saves images as drawings in the Open Document Format (ODG). To save an image or the
entire Draw file in another format, go to File > Export on the Menu bar and select a format in the
drop-down list. The image formats that Draw can export in and save to are listed in Appendix B,
Open Source, Open Standards, OpenDocument.
Draw files can also be exported in HTML, XHTML, or PDF format. For more information, see
Chapter 10, Printing, Exporting, Emailing, and Signing.
HTML export uses a conversion wizard that creates as many web pages as there are pages in a
Draw document. Optionally drawing pages can be displayed in frames with a navigator and an
index page. See Chapter 12, Creating HTML Files.

Working with 3D objects
Although Draw does not match the functionality of specialized drawing or image editing
programs, it is capable of producing and editing good 3D drawings. For more information, see the
Draw Guide.
Create a 3D object in Draw using one of the following methods:
•

Select a 3D shape in the 3D Objects section in the Shapes deck on the Sidebar.

•

Right-click on a 2D object and select Convert > To 3D or To 3D Rotation Object in the
context menu.

•

Right-click on a 2D object and select Format > 3D Effects on the Menu bar.

Working with layers
Using layers when creating complex drawings makes a drawing easier to navigate and edit.
Placing a simpler drawing that is part of a complex drawing into its own layer makes editing
easier. Any area of a layer that does not contain a drawing object is transparent and does not
obscure any part of a complex drawing. Any number of layers can be added to a drawing. For
more information on layers, see the Draw Guide.
A drawing in LibreOffice contains three default layers that cannot be deleted or renamed:
•

Layout – is the default Workspace where objects are normally placed when a drawing is
created.

•

Controls – used for form controls that have been assigned an action. Objects on this
layer are always in front of objects on other layers.

•

Dimension Lines – is where the dimension lines are drawn. By switching the layer to
show or hide, dimension lines can be switched on or off.
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A layer can be set to one or all of the following attributes:
•

Visible or hidden.

•

Printable or not printable.

•

Locked or unlocked.

To quickly toggle the attributes for a selected layer, use the following keyboard shortcuts:
•

Shift+click – toggle between a layer being visible or hidden.

•

Ctrl+click (macOS ⌘+click) – toggle between a layer being locked or unlocked.

•

Ctrl+Shift+click (macOS ⌘+Shift+click) – toggle between a layer being printed or not
printed.

Adding layers
1) Use one of the following methods to open the Insert Layer dialog (Figure 44):
– Go to Insert > Layer on the Menu bar.
– Right-click on the layer tabs at the bottom of the Workspace and select Insert Layer
in the context menu.
2) Enter a meaningful Name, Title, and Description for the new layer in the text boxes.
3) Select Visible if the layer is to be visible in a drawing. When Visible is not selected, the
layer is hidden and its name in the layer tab changes Color to blue.
4) Select Printable if the layer is to be printed when a drawing is printed. Not printing is
useful if a draft layer is required for guides or annotations that are used in making a
drawing, but you do not it want to appear in the final output. The name of a layer is
underlined in the layer tab bar when the Printable option is turned off.
5) Select Locked to prevent any objects on this layer from deletion, editing, or moving. No
additional objects can be added to a locked layer. Locking a layer is useful, for example,
when a base plan is to be protected while adding a new layer with other details. The
name of a locked layer is written in Italics in the layer tab bar.
6) Click OK to create the new layer and close the Insert Layer dialog. A new layer
automatically becomes active when added to a drawing.

Figure 44: Insert Layer dialog
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Note
Layers are added to the drawing in the order that they were inserted. The layer order
cannot be changed.

Modifying layers
1) To modify a layer, use one of the following methods to open the Modify Layers dialog,
which is similar in layout and options to the Insert Layers dialog.
– Right-click on the name tab of the layer and select Modify Layer in the context menu.
– Double-click on the layer tab.
– Go to Format > Layer on the Menu bar.
2) Make the required changes to the layer, then click OK to save the changes and close the
Modify Layers dialog.

Selecting colors
Colors are selected using a Color palette, the Area and Line panels on the Properties deck of
the Sidebar, and tools on the Line and Filling, and Drawing toolbars.

Note
For a more detailed description of the options available for Color palettes and
custom colors, as well as more information on the difference between the CMYK and
RGB Color schemes, refer to the Draw Guide.

Color palette
To display the Color Palette (Figure 45), go to View > Color Bar on the Menu bar. To close the
Color Palette, go to View on the Menu bar and deselect Color Bar.
Using the Color Palette, a Color of the area or background, and lines of selected objects in a
drawing can be quickly selected.
•

Left-click on a Color to change the Color of the area or background of a selected object.

•

Right-click on a Color to change the Color of the lines in a selected object.

•

Left-click or right-click on the box with the X at the bottom left of the Color Palette to
select no Color for the area or lines of a selected object.

Figure 45: Color Palette (Color Bar)
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Figure 46: Area and Line panels in Properties
deck on Sidebar

Sidebar Color
In the Area and Line panels in the Properties deck on the Sidebar (Figure 46), the Color of an
area or line of a selected object can be changed.
1) Select an object in a drawing.
2) Click on Properties on the Sidebar. In the Properties deck, open the Area and/or Line
panels by clicking on the triangle ▼ on the panel title bar.
3) Change the Color of an area in the Area panel as follows:
a) Select Color in the Fill drop-down list.
b) Click on the triangle ▼ next to the Fill Color box to open the Color palette.
c) Click on a Color to change the area Color.
d) To change the Color palette, click on the triangle ▼ at the top of the Color palette and
select a Color palette in the drop-down list.
4) Change the Color of a line in the Line panel as follows:
a) Click on the triangle ▼ next to the Line Color box to open the Color palette.
b) Click on a Color to change the line Color.
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c) To change the Color palette, click on the triangle ▼ at the top of the Color palette and
select a Color palette in the drop-down list.

Toolbar Color change
The Line and Filling, and Drawing toolbars have the same two tools that can be used to change
the Color of an area (fill) or line – Fill Color and Line Color. These two tools are used in a
similar way as changing colors using the Area and Line panels on the Properties deck of the
Sidebar, described above.

Adding comments to a drawing
Adding comments to a drawing uses a similar process to the one used in Writer and Calc. For
more about adding, navigating, and replying to comments, see Chapter 4, Getting Started with
Writer.
Before using comments, make sure that name and initials are entered into Tools > Options >
LibreOffice > User Data. The name and initials then appears in the comment marker and in the
Author field of the comment.
If more than one person edits the document, each author is automatically allocated a different
background Color.
1) Go to View > Comments on the Menu bar to show or hide the comment markers.
2) Go to Insert > Comment on the Menu bar. A small box containing the user initials
appears in the upper left-hand corner of the drawing with a larger text box beside it
(Figure 47). Draw automatically adds the name and the date at the bottom of this text
box.
3) Type or paste comments into the text box.
4) If necessary, click and drag the small comment markers to move the comment to a
different position on the drawing. Normally, the comment marker is placed on or near the
object referred to in the comment.
5) Right-click on the comment and choose an option in the context menu to delete the
current comment, all the comments from the same author, or all the comments in the
document.

Figure 47: Inserting a comment
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