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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options menu  LibreOffice > Preferences Access setup options
selection

Right-click Control+click Open a context menu

Ctrl (Control) ¥ (Command) Used with other keys

F5 Shift+3&+F5 Open the Navigator

Fi1 #+T Open the Styles and Formatting window

Documentation for LibreOffice is available at http.//www.libreoffice.org/get-help/documentation
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Why use LibreOffice Calc for your budget?

There are many reasons why you might want to create a budget. Maybe you need to track your
expenses to "find" some money that's gone missing, or perhaps your debt is growing and you
realize that the more you understand the fine details of your financial life, the easier it will be to
gradually change your habits and improve it.

Now here's the problem: for most of us, whenever lots of numbers get involved, two bad things
happen:

* We make mistakes with our calculations, and
* We find it difficult to absorb the real significance of all those rows and rows of figures.

Either way, a budget's many benefits can be lost through simple human limitations. But computers
were built just for this kind of work. A properly designed spreadsheet document can both eliminate
errors and intelligently display your data in a way that focuses your attention on just the details you
need to know. And, like everything else associated with LibreOffice, Calc spreadsheets are
absolutely free!

What is a spreadsheet?

A spreadsheet is simply a document that is particularly good at storing and displaying combinations
of numbers and words while performing automated calculations on the numbers. The trick (and it's
not nearly so complicated as you might think) is to arrange your numbers in ways that allow
LibreOffice Calc to get its work done as quietly and efficiently as possible.

Designing the layout for a new Calc spreadsheet

To get started, you'll need to create a new Calc spreadsheet. On the top menu bar, click on File >
New > Spreadsheet.

Untitled 2 - LibreOffice Writer
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Figure 1: The Open New File menu
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Formatting cells

The first thing you see when you open a new spreadsheet is an empty grid surrounded by the
menu bars specific to Calc. Don't be fooled by the uniform size of all the boxes (or cells, as they're
called); they can all be changed. So, for instance, you might prefer the second column from the left
(known as column B) to be a bit wider. Simply move your mouse until it's hovering above the right
wall of the title cell at the top of the column (the one with the letter B in it), click and, while you're
still holding the mouse button down, drag to the right. You can increase the height of a row of cells
by similarly dragging down on the bottom of a row in the far left column.

If you add more than a word or two of text to a cell, Calc will automatically extend the
cell to include the space of the one to its right...and the one to its right if necessary.

It's good to remember that editing the text spread through a number of cells in this
way requires that you first click on the master cell: the one where the text begins.

Tip

You can also edit the color of a cell's background or text by clicking on a cell (or highlighting a
group of cells by dragging the mouse across them) and then clicking on the small arrow to the right
of either the Background Color or Font Color icons on the top menu bar.

& - A -

Figure 2: Background and font color icons

In addition, you can edit the text contained within a cell much the same way you would in a word
processor: highlight the text you'd like changed and apply style, size, and font attributes as you
normally would via the Format > Character menu dialog.

For the kind of project we're creating, it's important to get our design all finished before we actually
add any data. You will soon see why all these details are so important.

Now is a good time to give your document a name and save it. Click on File > Save
As to display the save dialog, which will prompt you to enter a name and a save
location and to choose a file type. We'll stick with the default file type (ODF
) Spreadsheet) which will append a .ods suffix to the filename.
Tip Remember to regularly save any document you're working on because you really
can never predict when a software or system crash might strike, destroying any work
you might have done since the last backup. Saving by pressing Ctr/+S is a quick

shortcut that needn't interrupt your workflow.

So let's see what we can do at the design stage to help make the spreadsheet data more readable.

Type the words Household Budget Worksheet in the top left column of the spreadsheet. You
will notice that the text spills over into the adjoining cells to the right. Now, press Ctrl+A to select all
the text in the current cell, and increase its size to 14 (you can use the pull-down font size menu
towards the left of the top menu bar). While the text is still highlighted, click on the Background
Color icon and select a new color. Red, perhaps. Click next on the Font Color icon to change the
text color to something that will show up a bit better against a deep red background. Maybe white.
You might now have to select the adjacent cells to change their background color to match the one
to their left. When you're done, there is a clearly visible document title.

Now add row headings to column A (starting with line 3 to allow for the column headings we'll soon
add). You can, of course, choose some other method, but we've divided the row headings into
major sections (Income and Expenses), leaving enough rows in between for sub-headings.
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Ti You can add or remove rows or columns at any time by right-clicking on the
P appropriate row or column heading and choosing Insert or Delete.

Since some of the text is longer than a single cell (especially once we've made it bold), you might
want to expand column A by dragging the vertical line between the headers of column A and B.

We've also created column headers for each month, plus for your estimated monthly expenses
and, at the far right, for year-to-date totals.

A [ B | C | D | E

Estimate January February March /

Income:
[Employment income
_|Rental income
_|[Tax credits

[Expenses:

_|Mortgage/Rent

_|Groceries

11 |Line of Credit

12 |Credit Card #1

13 |Credit Card #2

14 |Car Payment

15 |Home Insurance

16 |Car Insurance
Health Insurance

18 |Telephone/internet

19 |Mobile Phone

20 |Daycare

21 |Utilities &

22 |[Travel

23 |Entertainment

"Q" Wl |~ b wn| -

25 |Total Income:

27 |Total Expenses:

2o Difference:

Figure 3: Section of the spreadsheet's text fields

Now we can add some visual cues to make it easier to read our data. A simple left-click on the
number 2 of row two will highlight the entire row. We can then click on the arrow to the right of the
Background Color icon to select a color. We chose a light gray. Changing the color of other areas
is only slightly more involved: left-click the heading of the first cell below Income (cell A4 in our
case) and, without releasing the mouse button, drag your mouse to the December cell of the last of
the income rows (N6). You can now choose a background color for these selected cells. Do the
same for the rows of expenses. You might also want to emphasize the connection between the
Income items and Total Income and between Expenses and Total Expenses by matching their
colors.

When you change the background color of a group of cells, you may find that the cell
. border lines strangely disappear. To fix this, press Ctrl+A to select all the cells in the
Tip spreadsheet and, from the menu at the top of your screen, click on Format > Cells
where you can choose the button that will set the outer border and all inner lines.

Figure 4 shows how our spreadsheet now looks.
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Total Income:
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29

Difference:
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31

Figure 4: Section of the spreadsheet's text fields with color added

Working with data

We're now ready to begin inputting our numbers. Cells C4 — E23 contain some sample figures we
manually entered for the first three months of the year. The totals in rows 25, 27, and 29 on the
other hand, were generated automatically by Calc: Row 25 is the sum of rows 4—6 (income), row
27 is the sum of the expenses of rows 9-23, and row 29 is row 25 minus row 27 (the monthly

surplus or deficit).

= A e | e [ D
(M Household Budget Worksheet
__2_ j Estimate January February March
3 |Income:
4 |Employment income 4500 4800 5100
5 |Rental Income 750) 750 500
6 [Tax credits 245 245 245
7
8 |Expenses:
_ 9 |Mortgage/Rent 1150 1150 1150
10 |Groceries 975 1034 989
11 _|Line of Credit 290 200 250
12 |Credit Card #1 890 987 800
13 _[Credit Card #2 355 232 259
14 |Car Payment 410 410 410
15 |Home Insurance 145 145 145
_ 16 _|Car Insurance 187| 187 187
17 |Health Insurance 420 420 420
18 |Telephone/internet 90 90 90,
_ 19 |Mobile Phone 04 94 o4
20 |Daycare 320 320) 240
21 |utilities 210 202 218
22 [Travel 450 100] 85
23 |Entertainment 190 110) 109
_2a |
25 [Total Income: 5405 5795 5845
26
27 |Total Expenses: 6176 5681 5442
28
29 |Difference: 681 114 403

Figure 5: Data inputs with calculated totals

Working with data



Let's see how those calculations were made. Choose a cell within which the result of a calculation
should appear, click on that cell and click once on the formula icon on the menu bar above.

T =

Figure 6: Formula icon

Calc will try to anticipate what you would like calculated and insert its best guess into the input field
to the right of the formula icon. If you're after something different, simply edit what appears in the
input field (the characters you enter will also temporarily appear in the highlighted cell).

In our case, the formula for cell C25 (the sum of all income items) should be:
=SUM(C4:C6)
Let's translate that:

= The value that will be displayed in cell C25 should equal

SUM the sum of the values
(C4:Co) between cell C4 and cell C6
Cc25 | fx E = |=SUM(C4Ce)
i A | B <R
il Household Budget Wo
_2_ Estimate January F
3 |Income:
4 |Employment Income 4500
= Rental income 750
6 |Tax credits 245
7
2 |Expenses:
9 |Mortgage/Rent 1150
10 |Groceries 975
11 |Line of Credit 200
12 |Credit Card #1 890
13 |Credit Card #2 355
14 |Car Payment 410
15 |Home Insurance 145
16 |Car Insurance 187
17 |Health Insurance 420
18 |Telephone/lnternet 90
19 |Mobile Phone 94
20 |Daycare 320
21 |Utilities 210
22 |Travel 4350
23 |Entertainment 190
24
~ Total Income: 549

Ffdure 7: Entering a formula
Similarly, the formula for cell C27 would, in our case, be:
=SUM(C9:C23)
Finally, the formula for cell C29 (C25 minus C27) would be:
=C25-C27

Copying a formula to other cells

Now at this point, in order to complete our spreadsheet we seem to be faced with a rather
unpleasant task. We would like the same formulas used for each of the twelve months included in
our chart. But that would require typing in variations of each formula (there were three, remember)
twelve different times [=SUM(D9:D24), =SUM(E9:E24) and so on]! There must be an easier way.

There is.
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Click on one of your formula cells, say C25. You will notice a small black square at the bottom-right
corner. When you hover your mouse over that square, the cursor turns into a cross hairs. Click on
that and drag it over as many cells as you'd like the formula to be copied. In our case that would be
eleven more cells. Now click on one of the new cells and take a look at the formula displayed in the
input field next to the Formula icon. It won't be =SUM(C4:C6), but =SUM(D4:D6) (or whatever the
correct value would be for the cell you clicked on). Calc automatically applied the correct values to
each cell. Smart, no?

Better yet, the moment you finish entering a new numeric value into any cell (and tab or click your
way out of that cell), any associated cell that contains a formula will automatically update itself. Try
it yourself: add some numbers to any of the Income or Expense cells and watch to see what
happens to the numbers in rows 25, 27, and 29.

It gets better. Our sample spreadsheet has more calculated cells at the far right after the last month
(December). You could have Calc calculate a year-to-date total for each sub-item in your income
and expenses. In our example however, we've simply inserted formulas in cells 025, 027, and
029 to keep track of the total income, total expenses and difference as they build through the year.

Now try changing the value in any of the value cells and watch as many as six formula cells update
instantly!

ZE = |=5UM(C25:N25)

| k| L | M N

September  |October November December Year to Date
] 4] ] 0 171
0 0 O 0 0 17299
0 0 0 ] ﬂl -164

Figure 8: Secondary calculations
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