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Printing

Quick printing
To quickly print a spreadsheet, click on the Print Directly icon on the Standard toolbar to send the 
entire spreadsheet to the default printer that is defined for your computer.

Note

You can change the action of the Print Directly icon to send a document to the printer 
defined for the document instead of the default printer for the computer. Go to Tools > 
Options > Load/Save > General and select the Load printer settings with the 
document option.

Tip

If the Print Directly icon is not shown on the toolbar, you can add it. See Chapter 14, 
Setting Up and Customizing Calc.

Controlling printing
For more control over printing, use File > Print or Ctrl+P to open the Print dialog (Figure 1).

Figure 1: Print dialog – General page

Note

The options selected on the Print dialog apply to this printing of this document only. 

To specify default printing settings for LibreOffice, go to Tools > Options > LibreOffice 
> Print and Tools > Options > LibreOffice Calc > Print. For details, see Chapter 14, 
Setting Up and Customizing Calc.
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The Print dialog has four tabs where you can choose a range of options, as described in the 
following sections. 

Depending on your computer’s operating system, the layout of these tabs may look different from 
the illustrations shown in this chapter.

General page
On the General page of the Print dialog (Figure 1), you can choose:

• The printer to use from the list printers available in the Printer section.

• Which sheets and pages to print, the number of copies to print, whether to collate multiple 
copies, and the page order for printing in the Range and Copies section. (See “Selecting 
what to print“ on page 7.)

• Printer-specific properties such as paper size, portrait or landscape orientation, duplex 
printing if available, and which paper tray to use.

LibreOffice Calc page
On the LibreOffice Calc page of the Print dialog (Figure 2), you can select whether to suppress the 
output of empty pages when you print the spreadsheet.

Figure 2: Print dialog – LibreOffice Calc page

Page Layout page
On the Page Layout page of the Print dialog (Figure 3), you can select how many pages are 
printed per sheet of paper, the order in which the pages are printed on a sheet, and whether a 
border is drawn around each page.

Figure 3: Print dialog – Page Layout page

Options page
On the Options page of the Print dialog (Figure 4), you can choose whether to create separate 
print jobs for collated output, or use only the paper size specified in the printer preferences.

Figure 4: Print dialog – Options page
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Printing multiple pages on a single piece of paper
To print multiple pages of a spreadsheet on one piece of paper:

 1) Use File > Print or Ctrl+P to open the Print dialog and then select the Page Layout page 
(Figure 5).

 2) In the Layout section, select from the Pages per sheet drop-down list the number of 
spreadsheet pages to print per sheet of paper. The preview panel on the right shows how 
the pages will look in the printed document.

 3) When printing more than two pages per sheet, select the order in which the pages are 
printed on a sheet from the Order drop-down list.

 4) To distinguish each page on a sheet, select Draw a border around each page.

 5) Click OK.

Figure 5: Printing more than one spreadsheet page per sheet of paper

Selecting what to print
In addition to printing a full spreadsheet document, you can choose single sheets, multiple sheets, 
and selections of cells for printing.

To print an individual sheet:

 1) In the spreadsheet, click on the sheet tab to select the sheet you want to print.

 2) Choose File > Print from the Menu bar, or press Ctrl+P.

 3) In the Range and copies section of the Print dialog, choose Selected sheets.

 4) Click OK.

To print a range of sheets:

 1) In the spreadsheet, select the sheets to print.

 2) Choose File > Print from the Menu bar, or press Ctrl+P.

 3) In the Range and copies section of the Print dialog, choose Selected sheets.

 4) Click OK.

To print a selection of cells:

 1) In the spreadsheet, select the cells to print.

 2) Choose File > Print from the Menu bar, or press Ctrl+P.

 3) In the Ranges and copies section of the Print dialog, choose Selected cells.

 4) In the sub-section From which print, choose Pages and type 1 in the box.

 5) Click OK.
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Printing in grayscale on a color printer
You may wish to print a spreadsheet in grayscale on a color printer. You can do this in two ways.

Note

Some color printers may print in color regardless of the settings you choose.

For an individual file, you can change the printer settings to print in black and white or grayscale:

 1) Choose File > Print, or press Ctrl+P, to open the Print dialog.

 2) Click Properties to open the Properties dialog for the printer. The available choices vary 
from one printer to another, but you should find options for the Color settings. See your 
printer’s help or user manual for more information.

 3) The choices for color might include black and white or grayscale. Choose grayscale.

 4) Click OK to confirm your choice and return to the Print dialog,

 5) Click OK to print the document.

You can change the LibreOffice settings to print all color text and graphics as grayscale:

 1) Choose Tools > Options > LibreOffice > Print.

 2) Select Convert colors to grayscale. Click OK to save the change.

Caution

This changes the print settings for all components of LibreOffice, not just Calc

Previewing pages/sheets before printing
To preview the sheets in Calc before printing:

 1) Choose File > Print Preview or click the Toggle Print Preview icon on the Standard 
toolbar.

The Calc window now displays the Print Preview toolbar instead of the Formatting toolbar.

Figure 6: Print Preview toolbar (Calc)

 2) To print the document from this view, click the Print icon (on the Standard toolbar) to open 
the Print dialog.

 3) Choose the print options and click the OK button.

 4) Click the Toggle Print Preview icon again to return to the normal spreadsheet view.

Using print ranges

You can define which range of cells on a spreadsheet are to be printed or exported to a PDF. The 
cells on the sheet that are not part of the defined print range are not printed or exported. Also, any 
sheets without a defined print range are not printed or exported.

Defining and printing a print range
To set a user-defined print range, which will replace any existing defined print range:

 1) Select the range of cells that are to be used in the print range.

 2) Go to Format > Print Ranges > Define on the Menu bar. Automatic page break lines are 
then displayed on the screen, defining the cells that are included in the print range.
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 3) Click on the Print Directly icon on the Standard toolbar to print the defined print range, or 
open the Print dialog and click OK to print the defined print range.

Tip

You can check the print range by using Toggle Print Preview or the Preview pane in 
the Print dialog. Calc will display only the cells in the print range. See “Viewing print 
ranges” on page 10.

Editing a print range
At any time, you can edit the print range, for example to add or remove cells, or define rows and 
columns to repeat (such as column or row headings).

Figure 7: Edit Print Ranges dialog

 1) Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges dialog
(Figure 7).

 2) If only a single range is defined, then clicking anywhere in the Print Range box displays the 
defined print range bounded in blue, as shown in Figure 8.

Figure 8: Single print range marked by a bounding box

3) To add new cells to the defined print ranges, type a comma at the end of the displayed data
in the Print range text box as the separator for the print range to be added. Select the cell 
range using the cursor, or type in the cell references using the same format of the print 
ranges already defined in the Print range text box. Remember to separate the cell 
references with a colon.

4) To remove a print range, select the print range in the Print range text box and delete it. 
Make sure the remaining print ranges only have a single comma as a separator and that 
there is not a comma at the end of the sequence.

5) Click OK to save your changes and close the dialog.
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Viewing print ranges
After print ranges have been defined, they are formatted with automatic page breaks. To view the 
page breaks, go to View > Page Break on the Menu bar to open the preview (Figure 9). 

Figure 9: Page break preview

The print ranges are outlined by default with a blue border and contain a pale gray page number in 
the center of each page. The nonprinting area of the spreadsheet normally has a gray background.

To exit Page Break preview, go to View > Normal on the Menu bar.

Named print ranges
In addition to defining a print range for each print job, you can also define a range of cells to be 
used repeatedly, without having to select a range of cells every time. This is useful if different areas
of a large spreadsheet have to be printed for different reports; several named print ranges can be 
defined to meet this need.

Figure 10: Define Names dialog

Defining and naming
 1) Select the cells you want to define and name as a print range, then go to Sheet > Named 

Ranges and Expressions > Define on the Menu bar to open the Define Names dialog 
(Figure 10). The selected cells are displayed in the Range or formula expression box.

Alternatively, open the Define Names dialog, then select the cells you want to define and 
name. The selected cells are then displayed in the Range or formula expression box.
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 2) Type a name for the range in the Name box. Use only letters, numbers, and underscores in 
the name; no spaces, hyphens, or other characters are allowed.

 3) If necessary, you can edit or set the range of selected cells for the print range in the Range 
or formula expression box. See “Editing a print range” on page 9 for more information.

 4) Make sure Document (Global) is selected from the Scope drop-down list.

 5) Select Print range from Range Options to define the settings as a print range.

 6) Click Add to accept the data and close the dialog.

Printing a named range
To select a named range for printing:

 1) Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges dialog
(Figure 11).

 2) Select the defined and named print range from the Print range drop-down list.

 3) Click OK to close the dialog.

 4) Open the Print dialog, which will show only the named range in the Preview. Click OK.

Figure 11: Choosing a named range for printing

Deleting a named print range
To delete a named print range if it is no longer required:

 1) Go to Sheet > Named Ranges and Expressions > Manage on the Menu bar to open the 
Manage Names dialog (Figure 12).

 2) Select the named print range you want to delete and confirm it is a print range by checking 
the options in Range Options.

 3) Click Delete and then click OK to close the dialog.

Removing print ranges
It may become necessary to remove a defined print range, for example if the whole sheet needs to 
be printed later, or you no longer want to print some of the added ranges.

Go to Format > Print Ranges > Clear on the Menu bar to remove all of the defined print ranges in
the spreadsheet, except for named print ranges. After the print range is removed, the default page 
break lines for the selected paper size will appear on the screen.

To remove named print ranges, see “Deleting a named print range” above.
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Figure 12: Manage Names dialog

Repeat printing of rows or columns
If a spreadsheet is printed on multiple pages, you can define specific rows or columns (for 
example, headings) to repeat print on each printed page.

Using print ranges
 1) Go to Format > Print Ranges > Edit to open the Edit Print Ranges dialog (Figure 13).

Figure 13: Repeat printing of rows and columns

 2) In the Rows to repeat box, type the references for the rows to be repeat printed. For 
example, to repeat rows 1, 2 and 3, type $1:$3. This automatically changes Rows to 
repeat from - none - to - user defined -.
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You can also place the cursor in the Rows to repeat box and then, using the mouse, select 
a cell in each row you want to be repeat printed. It is not necessary to select the whole row.

 3) In the Columns to repeat box, type the references for the columns to be repeat printed. For 
example, to repeat column A, type $A. This automatically changes Columns to repeat 
from - none - to - user defined -.

You can also place the cursor in the Columns to repeat box and then, using the mouse, 
select a cell in each column you want to be repeat printed.

 4) Click OK to save your changes and close the dialog.

Using named print ranges
You can also define named print ranges to use for repeat printing of rows or columns as follows:

 1) Define and name the rows and/or columns you want to repeat print. See “Named print 
ranges” on page 10 for more information.

 2) Select Repeat column and/or Repeat row from Range Options to define the columns and/
or rows for repeat printing in the Define Names dialog (Figure 10 on page 10).

 3) Click Add to accept the data and close the dialog.

 4) Go to Format > Print Ranges > Edit to open the Edit Print Ranges dialog (Figure 13).

 5) Select the defined and named print ranges from the Rows to repeat and/or Columns to 
repeat drop-down lists.

 6) Click OK to save your changes and close the dialog.

Page breaks

While defining a print range can be a powerful tool, you may sometimes need to manually adjust 
the page breaks to make sure the spreadsheet prints the way you want it to look. You can insert 
two types of page breaks into a spreadsheet:

• Row break – is a horizontal page break inserted above a selected cell in a row. For 
example, if the selected cell is H15, then a row break is created between rows 14 and 15.

• Column break – is a vertical page break inserted to the left of the selected cell in a 
column. For example, if the selected cell is H15, then a column break is created between 
columns G and H.

When a manual break is inserted, it appears as a blue line or as a bold line between the rows or 
columns on the display. The actual appearance depends on your computer setup. To see manual 
break lines more easily on your display, you can change their appearance. Go to Tools > Options 
> LibreOffice > Application Colors and scroll down to the Spreadsheet section where you can 
change how page breaks appear.

Inserting page breaks
 1) Select the cell where you want to insert a manual break in the spreadsheet.

 2) Go to Sheet > Insert Page Break on the Menu bar.

 3) Select Row Break to insert a row break above the cell or Column Break to insert a column
break to the left of the cell.

Alternatively, go to View > Page Break on the Menu bar, right-click in the spreadsheet and select 
Row Break or Column Break from the context menu. Remember to go to View > Normal on the 
Menu bar and return to the standard spreadsheet view.
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Deleting page breaks
 1) Select the cell where you want to delete a manual break from the spreadsheet.

 2) Go to Sheet > Delete Page Break on the Menu bar.

 3) Select Row Break to delete a row break from above the cell or Column Break to delete a 
column break from the left of the cell.

Deleting multiple page breaks
Multiple manual row and column breaks can exist in the same spreadsheet. If you want to remove 
all breaks from the spreadsheet:

 1) Go to View > Page Break on the Menu bar.

 2) Right-click in the spreadsheet and select Delete Page Breaks from the context menu to 
remove all manual breaks from your spreadsheet.

 3) Go to View > Normal on the Menu bar to return to the standard spreadsheet view.

Printing options for page styles

When using page styles for your spreadsheets, you can include printing options within the page 
style; for example, page order, details, scale to be printed, and so on. Using page styles allows you
to quickly set up and change the printing options of different sheets within your spreadsheet. See 
Chapter 4, Using Styles and Templates, for more information about page styles.

Figure 14. Page Style dialog – Sheet page

Make sure you have selected the correct sheet within the spreadsheet before setting the print 
options. Go to Format > Page on the Menu bar to open the Page Style dialog, then click on the 
Sheet tab (Figure 14) to set the printing options for a page style. The dialog indicates which page 
style you are about to change.
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• Page Order – defines the order in which data in a sheet is numbered and printed when it 
does not fit on one printed page. A preview of the page order is shown in the graphic on the
top right of the dialog in Figure 14.

• Top to bottom, then right – prints vertically from the left column to the bottom of the 
sheet.

• Left to right, then down – prints horizontally from the top row of the sheet to the right 
column.

• First page number – select this option if you want the first page to start with a number 
other than 1. Enter the number of the first page in the box.

• Print – defines which elements of the spreadsheet are to be printed.

• Column and row headers – prints the column and row headers.

• Grid – prints the borders of the individual cells as a grid. For the view on screen, make 
your selection under LibreOffice > Preferences > LibreOffice Calc > View > Grid lines.

• Comments – prints the comments defined in the spreadsheet. Comments will be printed
on a separate page, along with the corresponding cell reference.

• Objects/Images – includes all inserted objects (if printable) and graphics with the printed
spreadsheet.

• Charts – prints the charts that have been inserted into your spreadsheet.

• Drawing Objects – includes all drawing objects in the printed spreadsheet.

• Formulas – prints the formulas contained in the cells, instead of the results of any 
formulas used in the spreadsheet.

• Zero Values – specifies that cells with a zero value are printed with a zero (0) in the cell.

• Scale – defines a page scale for the printed spreadsheet.

• Scaling mode – select a scaling mode from the drop-down list. Appropriate controls for 
the scaling mode selected will be shown below the drop-down list box.

• Reduce/enlarge printout – specifies a scaling factor to scale all printed pages. Enter the 
scaling factor as a percentage in the box.

• Fit print range(s) to width/height – specifies the maximum number of pages horizontally 
(width) and vertically (height) on which every sheet with the current Page Style is to be 
printed.

The print ranges are always scaled proportionally, so the resulting number of pages may be
less than specified.

You may clear one of the boxes; then the unspecified dimension will use as many pages as
necessary.

If you clear both boxes, the scaling factor will be 100%.

• Width in pages – enter the maximum number of pages to be printed horizontally across.

• Height in pages – enter the maximum number of pages to be printed vertically stacked.

• Fit print range(s) on number of pages – specifies the maximum number of pages to be 
printed for each sheet that uses the same Page Style. The scale will be reduced as 
necessary to fit the defined number of pages.

• Number of pages – enter the maximum number of pages to be printed.
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Headers and footers

Headers and footers are predefined pieces of text that are printed at the top or bottom of a sheet 
outside of the sheet area. Headers and footers are set the same way and you can have different 
content on left and right pages that use the same page style.

Setting headers and footers
To turn the headers or footers on in your spreadsheet:

 1) Select the sheet where you want to turn on the header or footer.

 2) Go to Format > Page on the Menu bar to open the Page Style dialog and select the 
Header (or Footer) tab (Figure 15). The Header and Footer pages in the Page Style dialog 
are identical.

 3) Select the Header on or Footer on option.

 4) Enter the values for the other options according to your requirements. These options are 
described below.

 5) Click OK to save your changes and close the dialog.

Figure 15: Page Style dialog – Header page

• Header on or Footer on – adds a header or footer to the current page style.

• Same content on left and right pages – causes left and right pages to share the same 
header or footer content. To assign a different header or footer to left and right pages, 
deselect this option and then click Edit. See “Header or footer contents” on page 17 for 
more information.

• Left margin – enter the amount of space to leave between the left page margin and the left
edge of the header or footer.

• Right margin – enter the amount of space to leave between the right page margin and the 
right edge of the header or footer.

• Spacing – enter the amount of space to maintain between the bottom edge of the header 
or footer and the top edge of the spreadsheet.

• Height – enter the height for the header or footer.

• AutoFit height – automatically adjusts the height of the header or footer to fit the content.

• Preview – displays a preview of the current selection.
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• More – opens the Border/Background dialog, where you can define the appearance of 
borders and background colors or images for headers or footers. See Chapter 4, Using 
Styles and Templates in Calc, for more information.

• Edit – opens the Header or Footer dialog where you can add, edit, or format text that is 
placed in the header or footer. See “Header or footer contents” below for more information.

Figure 16: Header dialog

Header or footer contents
The headers and footers in a Calc spreadsheet have three columns for text. Each column can 
either be empty or have different contents from the other columns.

 1) Select the sheet where you want to turn on the header or footer.

 2) Open the Page Style dialog (Figure 15), then select Header on or Footer on and the options
for the header or footer. See “Setting headers and footers” above.

 3) Click Edit to open the Header or Footer dialog (Figure 16). If Same content on left and 
right pages is deselected in the Page Style dialog, the Header or Footer dialog will have 
tabbed pages where you can set the header or footer contents for right and left pages.

 4) To enter standard contents into the header or footer, select an option from the Header or 
Footer drop-down list.

 5) To enter customized contents into the header or footer, click in one the area boxes and type
your text, or click in one of the area boxes and click one of the Custom header or Custom 
footer icons. These icons are explained below.

 6) To change the appearance of the text in the header or footer, click the Text Attributes icon 
to open the Text Attributes dialog, where you can set the font, font effects and font position.

 7) Click OK to save the changes to text attributes and close the Text Attributes dialog.

 8) Click OK to save the changes to the contents of the header or footer and close the Header 
or Footer dialog.

 9) Click OK to save the changes to your header or footer and close the Page Style dialog.

The options available for a Custom header or Custom footer are as follows:

• Text Attributes – opens a Text Attributes dialog where you can assign formats to new or 
selected text. The Text Attributes dialog contains tabbed pages for Font, Font Effects, and 
Position.
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• Title – inserts a file name placeholder in the selected area. Click to insert the title. Click and
hold to select either Title, File Name or Path/File Name from the context menu that opens.
If a title has not be assigned to the spreadsheet, the file name for the spreadsheet will be 
inserted instead.

• Sheet Name – inserts a placeholder in the selected area for the sheet name of the selected
sheet in the spreadsheet.

• Page – inserts a placeholder in the selected area for the page number. This allows 
continuous page numbering in a spreadsheet.

• Pages – inserts a placeholder in the selected area for the total number of pages in the 
spreadsheet.

• Date – inserts a placeholder in the selected area for the current date which will be repeated
in the header/footer on each page of the spreadsheet.

• Time – inserts a placeholder in the selected area for the current time which will be repeated
in the header/footer on each page of the spreadsheet.

Exporting to PDF

LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file 
format is ideal for sending a file for someone else to view using Adobe Reader or other PDF 
viewers. 

Warning

A document in PDF format is not protected against contents tampering or editing by 
default. The PDF document contents can be edited by specialized software tools, 
including LibreOffice Draw.

Tip

Unlike Save As, the Export command writes a copy of the current document in a new 
file with the chosen format, but keeps the current document and format open in your 
session.

Quick export to PDF
Click the Export as PDF icon on the Standard toolbar to export the entire spreadsheet using the 
PDF settings most recently selected on the PDF Options dialog (see below). You are asked to 
enter the file name and location for the PDF, but you do not get a chance to choose a page range, 
image compression, or other options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as PDF. The 
PDF Options dialog opens. This dialog has six pages (General, Initial View, User Interface, Links, 
Security, and Digital Signatures). Select the appropriate settings, and then click Export. Then 
enter the location and file name of the PDF to be created, and click Save to export the file.

General page of PDF Options dialog
On the General page (Figure 13), you can choose which pages to include in the PDF, the type of 
compression to use for images (which affects the quality of images in the PDF), and other options. 
For more information, see the Getting Started guide or the Help. In most cases, the defaults will be 
what you need.
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Figure 17: PDF Options dialog – General page

Range section
• All: Exports the entire document to PDF.

• Pages: To export a range of pages within a selected sheet, use the format 3-6 (pages 3 to 
6). To export single pages, use the format 7;9;11 (pages 7, 9, and 11), or a combination of 
the two formats.

• Selection/Selected sheet(s): Exports the selected material (a sheet or part of a sheet).

Images section
• Lossless compression: Images are stored without any loss of quality. Tends to make large 

files when used with photographs. Recommended for other kinds of images or graphics.

• JPEG compression: Allows for varying degrees of quality. A setting of 90% works well with 
photographs (small file size, little perceptible loss of quality).

• Reduce image resolution: Lower DPI (dots per inch) images have lower quality. Higher DPI 
settings can greatly increase the size of the exported file.

Watermark section
• Sign with Watermark: When this option is selected, a transparent overlay of the text you 

enter into the Text box will appear on each page of the PDF.

General section
• Hybrid PDF (embed ODF file): Use this setting to export the document as a PDF file 

containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF 
file, and it remains fully editable in LibreOffice.

• Archive PDF/A-1a (ISO 19005-1): PDF/A is an ISO standard for long-term preservation of 
documents, by embedding all the information necessary for faithful reproduction (such as 
fonts) while forbidding other elements (including forms, security, and encryption). PDF tags 
are written.

• Tagged PDF: Tagged PDF contains information about the structure of the document’s 
contents. This can help to display the document on devices with different screens, and 
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when using screen reader software. Some tags that are exported are table of contents, 
hyperlinks, and controls. This option can increase file sizes significantly.

• Create PDF form – Submit format: Choose the format of submitting forms from within the 
PDF file.

• Allow duplicate field names – If enabled, the same field name can be used for multiple 
fields in the generated PDF file. If disabled, field names will be exported using generated 
unique names.

• Export bookmarks: Generally not used in Calc.

• Export comments: Exports comments as PDF notes. You may not want this!

• Export automatically inserted blank pages: Not available in Calc.

• View PDF after export: If selected, your default PDF viewer will open and display the newly 
exported PDF.

• Use reference XObjects: If you don’t know what this means, leave this box unchecked.

Initial View page of PDF Options dialog
On the Initial View page (Figure 18), you can select how the PDF file opens by default in a PDF 
viewer. The options should be self-explanatory.

Figure 18: PDF Options dialog – Initial View page

User Interface page of PDF Options dialog
On the User Interface page (Figure 19), you can select options to control how a PDF viewer 
displays the file. Some of these options are useful when you are creating a PDF to be used as a 
presentation or a kiosk-type display.

Figure 19: PDF Options dialog –  User Interface page
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Window options
• Resize window to initial page: the PDF reader window displays the whole first page.

• Center window on screen: the PDF is shown in a reader window centered on screen.

• Open in full screen mode: the PDF reader window is in front of all other windows.

• Display document title:– the PDF is shown with the document title in the reader title bar.

Transitions – not used in Calc.

User interface options
• Hide menu bar: hides the reader menu bar when the document is active.

• Hide toolbar: hides the reader toolbar when the document is active.

• Hide window controls: hides the reader controls when the document is active.

Bookmarks
• All bookmark levels: shows all bookmark levels when the reader opens the PDF.

• Visible bookmark levels: shows bookmark levels down to the selected level when the 
reader opens the PDF.

Links page of PDF Options dialog
On the Links page (Figure 20) you can select how bookmarks and hyperlinks are exported to PDF.

Figure 20: PDF Options dialog –  Links page

Export bookmarks as named destinations
If you have defined Calc sheet names, this option exports them as “named destinations” to 
which Web pages and PDF documents can link.

Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such 
as .odt, .ods, and .odp), this option converts the files’ extensions to .pdf in the exported PDF 
document.

Export URLs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF. 
See Relative hyperlinks in the Calc Help for more information.

Cross-document links
Defines the behavior of links clicked in PDF files. Select one among the following 
alternatives:

• Default mode: The PDF links will be handled as specified in your operating system.

• Open with PDF reader application: Use the same application used to display the PDF 
document to open linked PDF documents.

• Open with Internet browser: Use the default Internet browser to display linked PDF 
documents.
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Security page of PDF Options dialog
Use the Security page (Figure 21) to encrypt and set passwords when you export your 
spreadsheet and create the PDF file. Setting encryption and passwords also allows you to apply 
restrictions on printing and if changes or copying can be carried out on the PDF file.

Click the Set passwords button to open the Set Passwords dialog (Figure 22) where you enter the
passwords. You can enter a password (Set open password) to open the file and an optional 
password (Set permission password) to restrict what readers can do with the PDF file.

• With an open password set, the PDF can only be opened with the password. Once opened,
there are no restrictions on what the user can do with the document (for example, print, 
copy, or change it).

• With a permission password set, the PDF can be opened by anyone, but its permissions 
can be restricted. See Figure 21. After you set a password for permissions, the other 
choices on the Security page become available.

• With both the open password and permission password set, the PDF can only be opened 
with the correct password, and its permissions can be restricted.

The options on the Security page become available only when passwords have been set.

Note

Permissions settings are effective only if the user’s PDF viewer respects the settings.

Figure 21: PDF Options dialog –  Security page
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Figure 22: Set passwords dialog

Digital Signatures page of PDF Options dialog
This page contains the options related to exporting a digitally signed PDF.

Digital signatures are used to ensure that the PDF was really created by the original author (that is,
you), and that the document has not been modified since it was signed.

The signed PDF export uses the keys and X.509 certificates already stored in your default key 
store location or on a smartcard. The key store to be used can be selected under Tools > Options 
> LibreOffice > Security > Certificate Path. (Not available on Microsoft Windows systems, where
LibreOffice will access the system certificate storage.) When using a smartcard, it must already be 
configured for use by your key store. This is usually done during installation of the smartcard 
software. Details about using these features is outside the scope of this chapter.

Figure 23: Digital signature page for PDF

• Use this certificate to digitally sign PDF documents: Click Select to open the Select 
Certificate dialog, where all certificates found in your selected key store are displayed. If the
key store is protected by a password, you are prompted for it. When using a smartcard that 
is protected by a PIN, you are also prompted for that.

Select the certificate to use for digitally signing the exported PDF, then click OK.

All other fields on the Digital Signatures tab are accessible only after a certificate has been 
selected.

• Certificate password: Enter the password used for protecting the private key associated 
with the selected certificate. Usually this is the key store password. If the key store 
password has already been entered in the Select Certificate dialog, the key store may 
already be unlocked and not require the password again.

Exporting to PDF | 23



When using a smartcard, enter the PIN here. Some smartcard software will prompt you for 
the PIN again before signing.

• Location, Contact information, Reason: Optionally enter additional information about the 
digital signature that will be applied to the PDF. This information will be embedded in the 
appropriate PDF fields and will be visible to anyone viewing the PDF. Each or all of the 
three fields may be left blank.

• Time Stamp Authority: Optionally select a Time Stamping Authority (TSA) URL. During 
the PDF signing process, the TSA will be used to obtain a digitally signed timestamp that is 
then embedded in the signature. Anyone viewing the PDF can use this timestamp to verify 
when the document was signed.

The list of TSA URLs that can be selected is maintained under Tools > Options > 
LibreOffice > Security > TSAs. If no TSA URL is selected (the default), the signature will 
not be timestamped, but will use the current time from your local computer.

Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. If you 
want to use another spreadsheet file format (for example, Microsoft Excel), use File > Save As. If 
you want to create web pages from your spreadsheet, use File > Export.

E-mailing spreadsheets

LibreOffice provides several ways to send documents quickly and easily as an e-mail attachment in
OpenDocument format (LibreOffice default format), other spreadsheet formats, or as a PDF file. 
You can also email a document to several recipients. For more information, see the Getting Started
Guide.

To send the spreadsheet as an email:

 1) Go to File > Send on the Menu bar and select from the following options. LibreOffice opens
your default e-mail program with the spreadsheet attached in the selected format.

• Email Document: the spreadsheet is sent in the default ODF format.

• E-mail as OpenDocument Spreadsheet: the spreadsheet is sent in the ODF format.

• E-mail as Microsoft Excel: the spreadsheet is sent in the Excel format.

• E-mail as PDF: The PDF Options dialog opens. Select the parameters to be used for 
the PDF file. See “Controlling PDF content and quality” on page 18.

 2) In your e-mail program, enter the recipient, subject, and any text you want to add, then 
send the e-mail.

Digital signing of documents

To sign a document digitally, you need a personal key, also known as a certificate. A personal key 
is stored on your computer as a combination of a private key, which must be kept secret, and a 
public key, which you add to your documents when you sign them. You can get a certificate from a 
certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a checksum is computed from the document’s 
content plus your personal key. The checksum and your public key are stored together with the 
document.

When someone later opens the document on any computer with a recent version of LibreOffice, 
the program will compute the checksum again and compare it with the stored checksum. If both 
are the same, the program will signal that you see the original, unchanged document. In addition, 
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the program can show you the public key information from the certificate. You can compare the 
public key with the public key that is published on the web site of the certificate authority.

Whenever someone changes something in the document, the change breaks the digital signature.

On Windows operating systems, the Windows features for validating a signature are used. On 
Linux systems, files that are supplied by Mozilla Thunderbird or Firefox are used to validate the 
signature. For a more detailed description of how to get and manage a certificate, and signature 
validation, see About Digital Signatures in the LibreOffice Help.

Applying digital signatures
The following procedure is only an example of how to digitally sign a document. The actual 
procedure depends on how your computer is set up and the computer operating system.

 1) Open the file that you want to digitally sign.

 2) Go to File > Digital Signatures > Digital Signatures on the Menu bar.

• If you have set LibreOffice to warn you when the document contains comments (see 
“Removing personal data” on page 27), you may see a message box asking whether 
you want to want to continue signing the document.

• If the document contains comments, a warning dialog opens asking if you wish to 
continue. Click Yes to continue, or click No to exit and take appropriate action to 
remove the comments and restart this procedure.

• If you have not saved the document since the last change, a message box appears. 
Click Yes to save the file. When you have saved the file, the Digital Signatures dialog 
opens (Figure 24).

 3) Click Sign Document to open the Select Certificate dialog (Figure 25).

Select the certificate you want to use and click OK to close the Select Certificate dialog.

The certificate used is displayed in the Digital Certificates dialog with an icon next to its 
name. This icon indicates the status of the digital signature.

• An icon with a red seal ( ) indicates that the document was signed and the certificate 
was validated.

• An icon with a yellow caution triangle overlaying the red seal ( ) indicates that the 
document is signed but that the certificate could not be validated.

• An icon with a yellow caution triangle by itself ( ) indicates an invalid digital signature.

 4) Click Close to close the Digital Signatures dialog and digitally sign your file.

A signed document shows an icon in the status bar. You can double-click the icon to view the 
certificate. More than one signature can be added to a document.

Note

If you make any changes to the document after digitally signing, the digital signature is
removed automatically and you have to repeat the above procedure to digitally sign it 
again.
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Figure 24: Digital Signatures dialog

Figure 25: Select Certificate dialog

Signing multiple times with same signature
In the past, LibreOffice prohibited creating multiple signatures by the same author on a document, 
because there was no semantic meaning of signing the same document multiple times. LibreOffice
now provides a signature description, so multiple signatures from the same author are now 
allowed, because each signature can have a different meaning.

When you select File > Digital Signatures > Digital Signatures, the dialog (Figure 24) lists 
existing signatures together with their description (if they have any).

When you click the Sign Document button, the dialog (Figure 25) for certificate selection now also
asks for an optional description.

Changing the value of an existing description invalidates the signature.
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Digitally signing macros
Normally, macros are part of a document. If you sign a document, the macros inside the document 
are signed automatically. If you want to sign only the macros, but not the document, go to Tools > 
Macros > Digital Signature on the Menu bar and apply the signature as described above.

Removing personal data

You may wish to ensure that personal data, versions, notes, hidden information, or recorded 
changes are removed from files before you send them to other people or create PDFs from them.

• In Tools > Options > LibreOffice > Security > Options, you can set Calc to remind you 
when files contain certain information and to remove personal information automatically on 
saving.

• To remove personal and some other data from a file, go to File > Properties. On the 
General page, deselect Apply user data and then click Reset Properties. This removes 
any names in the created and modified fields, deletes the modification and printing dates, 
and resets the Total editing time to zero, the creation date to the current date and time, and 
the Revision number to 1.

• To remove version information, either go to File > Versions on the Menu bar, select the 
versions from the list and click Delete, or go to File > Save As and save the file with a 
different name.
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