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Utiliser LibreOffice sur un Mac

Sur Mac, certaines touches et certains éléments de menu sont différents de ceux utilisés sous
Windows ou Linux. Le tableau ci-dessous donne quelgues substitutions courantes pour les instruc-
tions de ce chapitre. Pour une liste plus détaillée, voyez I'Aide de I'application.

Windows ou Linux | Equivalent Mac Effet

Sélection du menu LibreOffice > Préférences Acceés aux options de configuration
Outils > Options

Clic droit Control+clicouclic Ouvre un menu contextuel
droit selon la configuration
de l'ordinateur

Ctrl (Control) (Command) Utilisé avec d’'autres touches
F5 Shift+®)+F5 Ouvre le Navigateur
F11 Gg)+T Ouvre la fenétre Styles et Formatage
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Introduction

Ce chapitre présente les bases du travail avec le texte dans Writer, le module de traitement de
texte de LibreOffice. Il suppose que vous étes familiarisé avec I'utilisation de la souris et du clavier
et que vous avez lu dans le Chapitre 1, Introduction & Writer ce qui concerne les menus, les barres
d’outils et les autres sujets présenteés.

Nous vous recommandons aussi d’'activer les aides a la mise en forme, telles que les marques de
fin de paragraphe, les tabulations, les sauts et autres éléments dans Outils > Options >
LibreOffice Writer > Aides au formatage.

Quand vous aurez lu ce chapitre, vous devriez savoir comment :
*  Sélectionner, couper, copier, coller et déplacer du texte.
*  Chercher et remplacer du texte.
* Insérer des caracteres spéciaux.

«  Vérifier 'orthographe et la grammaire, utiliser le dictionnaire des synonymes et choisir les op-
tions de coupure de mots.

e Utiliser l'autocorrection, l'insertion automatique, I'autotexte et les fonctions de numérotation
de lignes.

Voyez le Chapitre 3 pour d’autres outils et techniques relatifs au travail avec le texte et le Chapitre
4 pour les méthodes de mise en forme du texte.

Sélectionner du texte

Avant que vous ne puissiez faire quoi que ce soit avec du texte, vous devez le sélectionner. Sélec-
tionner du texte dans Writer est similaire a sélectionner n'importe quoi dans les autres applications.
Vous pouvez le faire en tirant le pointeur de la souris sur le texte ou par des clics multiples pour sé-
lectionner un mot (double clic), une phrase (triple clic) ou un paragraphe (quadruple clic).

Vous pouvez aussi cliquer dans le texte, appuyer sur la touche F8 pour entrer en mode « Sélection
étendue » puis utiliser les touches fléchées du clavier pour sélectionner un bloc contigu de texte.

En plus de sélectionner des blocs de textes, vous pouvez sélectionner des éléments qui ne sont
pas consécutifs et des colonnes (bloc vertical) de texte.

Une facon de changer le mode de sélection consiste a utiliser I'icone de la barre d’état (voir le
Chapitre 1). Quand vous cliquez sur celle-ci, un menu contextuel affiche les options disponibles :
sélection Standard, sélection Etendue (F8), Ajout a la sélection (Maj+F8) et Sélection par bloc
(Ctrl+Maj+F8).
Sélectionner des éléments disjoints

Pour sélectionner des éléments disjoints (voir Figure 1) en utilisant le clavier et la souris :

1) Sélectionnez le premier morceau de texte.

2) Maintenez la touche Ctr1 enfoncée et utilisez la souris pour sélectionner le morceau de
texte suivant.

3) Répétez I'opération autant de fois que nécessaire.
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Vous pouvez travailler avec le texte sélectionné (le copier, le supprimer, en changer le style, etc.).

Pour sélectionner des éléments disjoints en utilisant uniguement le clavier :

1)

2)

3)

4)

Sélectionnez le premier morceau de texte. Pour sélectionner du texte a I'aide du clavier,
maintenez la touche Maj enfoncée et utilisez les fleches de direction. (Pour plus d’'informa-

tions sur la sélection de texte au clavier, voir I'article « Navigation et sélection a I'aide du cla-
vier » dans I'Aide de LibreOffice (F1)).

Appuyez sur les touches Maj+F8 de votre clavier afin d’activer le mode Ajout a la sélection
de Writer.

Utilisez les touches de direction de votre clavier pour vous déplacer au début du morceau de
texte suivant a sélectionner. Maintenez la touche Maj enfoncée et sélectionnez le morceau

de texte suivant.

Répétez I'opération autant de fois que nécessaire.

Pour quitter le mode Ajout a la sélection, appuyez sur les touches Maj+F8 ou la touche Echap de
votre clavier.

Le tour du monde en quatre vingts jours — Jules Verne

L3, Passepartout attendait son maitre, armé d’une demi-douzaine de
revolvers-poignards & six coups et & inflammation centrale.|Quand il apercut |
Fix en compagnie de Mr. Fogg, son front s’obscurcit| Mais Mrs. Aouda,
ayant fait en quelques mots le récit de ce qui s’était passé, Passepartout se
rasséréna.

Evidemment Fix n’était plus un ennemi, ¢’était un allié. Il tenait sa parole.

Le diner terminé, un coach fut amené, qui devait conduire a la gare les
voyageurs et leurs colis./Au moment de monter en voiture, Mr. Fogg dita |
« Vous n’avez pas revu ce colonel Proctor ?

— Non, répondit Fix.

— Je reviendrai en Amérique pour le retrouver, dit

froidement Phileas Fogg. Il ne serait pas convenable qu’uncitoyen anglais se

laissat traiter de cette facon. »
Figure 1 : Sélectionner des éléments qui ne sont pas proches les uns des autres

Sélectionner un bloc de texte vertical

En utilisant le mode Sélection par bloc, vous pouvez sélectionner un bloc vertical ou une “colonne”
de texte qui est séparée par des espaces ou des tabulations (comme on peut le rencontrer dans le
texte collé depuis des courriels, des listings ou d’autres sources). Pour activer le mode Sélection
par bloc, cliquez sur le menu Edition > Mode sélection > Zone de bloc, ou sur I'icone Sélection
dans la barre d’état (voir Figure 2). Vous pouvez également appuyer sur les touches
Ctrl+Maj+F8 de votre clavier.
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Mode de

P Sélection standard
selection

@ Sélection étendue
Ajout a la sélection
Sélection par bloc

Figure 2 : Activer le mode de sélection par bloc grace a la barre d’Etat

Vous pouvez maintenant mettre en surbrillance la sélection en utilisant la souris ou le clavier (voir
Figure 3).

Janvier Février Mars

Ayl Mai Juin

Juillet Aot Septembre
Octobre  Novembre [Décembre

Figure 3 : Sélectionner un bloc de texte vertical

Couper, copier et coller du texte

Couper et coller du texte dans Writer est similaire a couper et copier du texte dans d’autres pro-
grammes. Vous pouvez copier/déplacer du texte a l'intérieur d’'un méme document, ou d'un docu-
ment vers un autre document, en glissant le texte, en utilisant les sélections du menu, les icones
ou les raccourcis clavier. Vous pouvez également copier du texte provenant d’autres sources,
telles que des pages Web, et les coller dans un document Writer.

Pour déplacer (couper et coller) le texte sélectionné en utilisant la souris, cliquez-glissez le texte
sélectionné vers son nouvel emplacement. Pour copier le texte sélectionné en utilisant la souris,
maintenez enfoncée la touche Ctrl de votre clavier pendant que vous cliquez-glissez le texte vers

son nouvel emplacement. Le formatage du texte copié est préservé.

Apres avoir sélectionné du texte, vous pouvez également le couper, le copier et coller du texte de
'une des maniéres suivantes :

Couper : utilisez le menu Edition > Couper ou le raccourci clavier Ctrl+X ou licone
% Couper de la barre d’outils Standard.

Copier : utilisez le menu Edition > Copier ou le raccourci clavier Ctr1+C ou licéne Co-
=l pier de la barre d’'outils Standard.

Coller : utilisez le menu Edition > Coller ou le raccourci clavier Ctr1+V ou l'icone Coller
= de la barre d’outils Standard.

Le résultat d’'une opération de collage dépend de la source du texte a coller. Si vous cliquez sim-
plement sur 'icone Coller, quel que soit le formatage du texte (tel que gras ou italique), il est pré-
servé. Le texte collé des sites Web ou d’autres sources peut également étre placé dans des
cadres ou dans des tableaux. Si le résultat ne vous parait pas satisfaisant, cliquez sur I'icbne An-
nuler ou appuyez sur Ctri+2).

Pour que le texte collé hérite du style du paragraphe au point d’insertion :
+ cliquez sur le menu Edition > Collage spécial ou

* cliquez sur le triangle situé a droite de l'icbne Coller dans la barre d’'outils Standard ou
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* cliquez sur l'icone Coller sans relacher le bouton gauche de la souris ou
e appuyez sur les touches Ctrl+Maj+V de votre clavier.
Cliquez ensuite sur Texte non formaté dans la boite de dialogue ou le menu déroulant.

L'étendue des choix dans le menu Collage spécial varie en fonction de I'origine et du formatage
du texte (ou des autres objets) a coller. Voir la Figure 1 pour un exemple de texte du presse-pa-
piers.

IIII'{}

& G/ S-

LibreOffice Writer

Lien DDE

HTML (HyperText Markup Language)
Texte formaté [RTF]

Texte non formaté

Collage spécial
file:///Z:/Mes documents/LibreOffice/Guide de Writer5-
S : OK
ource 4/Finalisés/WG5402FR-TravaillerAvecTexte-Bases.odt -

Sélection Annuler

e
Texte formaté [RTF]
HTML (HyperText Markup Language)

Aide

Texte non formaté
Lien DDE

Figure 4 : Menu et boite de dialogue Collage spécial.

Rechercher et remplacer du texte et du formatage

Writer propose deux méthodes pour trouver du texte dans un document : la barre d'outils Recher-
cher pour une recherche rapide et la boite de dialogue Rechercher & Remplacer. Dans la boite de
dialogue Rechercher & Remplacer, vous pouvez :

e trouver et remplacer des mots ainsi que des phrases ;

» utiliser les caractéres génériques et les expressions régulieres pour affiner la recherche (voir
le Chapitre 3) ;

» rechercher et remplacer des formatages spécifiques (voir le Chapitre 3) ;

» rechercher et remplacer des styles de paragraphe (voir le Chapitre 3).

Utiliser la barre d’outils Rechercher

Si la barre d’outils Rechercher n'est pas visible, vous pouvez I'afficher en cliquant sur le menu Affi-
chage > Barres d’outils > Rechercher ou en appuyant sur les touches Ctr1+F de votre clavier.
Par défaut, la barre d’'outils Rechercher est ancrée au bas de la fenétre de LibreOffice, juste au-
dessus de la barre d'état (voir Figure 5). Vous pouvez également la rendre flottante ou I'ancrer a
un autre endroit. Pour plus d’information sur les barres d’outils flottantes et ancrées, référez-vous
au chapitre 1, Introduction a Writer, de ce guide.
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Utiliser la barre d’outils Rechercher

Sila barre d'outils Rechercher n'est pas visible, vous pouvez |'afficher en dliquant sur le menu
Aﬁlchage :- Earr&s d I:H.Itl|5 > Rechercher ouen appuyant sur Iestouches CfrHF de \.rotre clavier.

oS

x |Rechercher ~ |@ @ Tout rechercher [ ] Respecter la casse H MNaviguer par @ @

Page 16 de 43 13 097 mots, 81 268 caracteres Chapltre1 ] A 8

F/gure 5 : La barre d'outil Rechercher en position ancrée par défaut

Pour utiliser la barre d’'outils Rechercher, cliquez dans le champ et saisissez le texte a rechercher.
Appuyez ensuite sur la touche Entrée de votre clavier pour trouver I'occurrence suivante du texte
saisi. Cliquez sur les boutons Rechercher le suivant ou Rechercher le précédent en fonction de
VOs besoins.

Cliquez sur le bouton Tout rechercher pour sélectionner toutes les occurrences de texte conte-
nues dans le document. Cochez I'option Respecter la casse pour rechercher uniqguement les oc-
currences qui correspondent strictement au terme recherché en termes de majuscules et de mi-
nuscules. Cliquez sur le bouton Rechercher & remplacer a droite de I'option Respecter la casse
pour ouvrir la boite de dialogue Rechercher & remplacer.

Cliquez sur le bouton Naviguer par pour ouvrir le Navigateur et la barre d’outils Navigation décrits
dans le chapitre 1, Introduction a Writer.

La barre d’outils Rechercher peut étre fermée en cliquant sur la croix rouge a gauche ou en ap-
puyant sur la touche Echap de votre clavier lorsque le curseur se trouve dans la zone de re-
cherche. Le raccourci Ctr1+F affiche et masque alternativement la barre d’outils.

Utiliser la boite de dialogue Rechercher & remplacer

Pour afficher la boite de dialogue Rechercher & remplacer, cliquez sur le menu Edition > Recher-
cher & remplacer, appuyez sur les touches Ctr1+H de votre clavier ou cliquez sur le bouton Re-
chercher & remplacer (H) dans la barre d'outils Rechercher. Pour obtenir plus d’options, cliquez
sur le bouton Plus d’options de la boite de dialogue (voir Figure 6). Des options supplémentaires
s'affichent quand les options Asiatique et Mise en page de texte complexe ont été cochées dans
Outils > Options > Parameétre linguistiques > Langues.

Rechercher & remplacer X

Recherche |icone ~

[J Respecter la casse [ Mots entiers uniguement

Remplacer |bouton o

Tout rechercher Rechercher le précédent Rechercher le suivant Remplacer Tout remplacer

Sélection active seulement [1Remplacer en arriére
[ Expressions réguliéres [ Styles de paragraphe
[ Rechercher des similarités Similarités...

[J Commentaires

Attributs... Format... Aucun format

Aide Fermer

Figure 6 : La boite de dialogue Rechercher & remplacer avec les options supplémentaires.
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Pour utiliser la boite de dialogue Rechercher & remplacer :

1)
2)

3)

4)

ny

Saisissez le texte que vous souhaitez trouver dans le champ Rechercher.

Pour remplacer le texte recherché avec un texte différent, saisissez le nouveau texte dans le
champ Remplacer.

Vous pouvez sélectionner des options telles que Respecter la casse, Mots entiers unique-
ment ou Rechercher des similarités.

L'utilisation des autres options est décrite au chapitre 3.

Lorsque vous avez défini votre recherche, cliquez sur le bouton Rechercher le suivant.
Pour remplacer le texte, cliquez sur le bouton Remplacer.

Astuce

Si vous cliquez sur le bouton Tout rechercher, Writer sélectionne toutes les occurrences du
texte recherché dans le document. De la méme facgon, si vous cliquez sur le bouton Tout
remplacer, Writer remplace toutes les occurrences, sans vous en demander confirmation a
chaque fois.

Attention

Utilisez le bouton Tout remplacer avec précaution ; vous pourriez provoquer des erreurs
embarrassantes. Une erreur avec le bouton Tout remplacer peut nécessiter une recherche
manuelle, mot par mot, pour la corriger si elle n'est pas découverte a temps pour I'annuler.

Insérer des caractéres spéciaux

Un Caractere spécial est un caractére qui n'est pas présent sur un clavier standard de votre
langue. Par exemple, © 3% @ ¢ £ i 0 @ ¢ sont des caractéres spéciaux. Pour insérer un caractere
spécial :

1)

2)

3)

Placez le curseur de la souris a I'endroit ou vous souhaitez insérer le caractére spécial dans
votre document.

Cliquez sur le menu Insertion > Caractéres spéciaux ou sur I'icbne Insérer un caractére

spécial (%) dans la barre d’outil principale pour ouvrir la boite de dialogue Caractéres spé-
ciaux (voir Figure 7).

Sélectionnez dans l'ordre les caractéeres (de n’importe quelle police ou sous-ensemble) que
vous souhaitez insérer. Le caractére sélectionné (et son code numérique) est affiché a droite
de la boite de dialogue, en dessous des boutons. Vous pouvez également visualiser tous les
caractéres choisis en bas a gauche de la boite de dialogue (voir Figure 7). Cliguez ensuite
sur le bouton OK pour insérer le(s) caractére(s) dans votre document.

Astuces

Différentes polices incluent différents caractéres spéciaux. Si vous ne trouvez pas un carac-
tére spécial particulier, essayez de changer la Police.
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La commande Rechercher & Remplacer permet I'acces aux caractéres spéciaux par un clic
droit dans les zones Rechercher et Remplacer par.

Caractéres spéciaux

Police: ‘Liberation Sans V‘ Sous-ensemble : ‘Opérateurs mathématiques w2
E|lm N |Ps|Rs|®¥W|Wm|¢d | €| K|F|D|J|P|G|A "

g|C | F|% |t N |®| ™| Q| e |8 |4d|%|2|%|%

% | % |0 || 1 || ||t |a]lalnN -1/ Z

Ve |l |nlfl=]lgl=lcs|2|o|l~|[]|]]-

| r |1 L|J |' -I T + + = ” F F |3 Hexadecimal :

o e S| 3[R (A= U+ 2211
Fl= A EF (" - (BT B = Décimal :

O = O | mm | AP | ¥ | 4| $ | O e (O ° @ 8721

Caractéres: |3

Aide Insérer Annuler

Figure 7 : La boite de dialogue Caractéres spéciaux

Insérer des espaces et des tirets insécables
Espaces insécables

Afin d’éviter que deux mots ne soient séparés a la fin d’'une ligne, appuyez sur les touches
Ctrl+Maj de votre clavier lorsque vous saisissez lI'espace entre les deux mots.

Tirets insécables

Vous pouvez utiliser un tiret insécable dans le cas ou vous ne souhaitez pas que le trait
d’union apparaisse a la fin d’'une ligne (par exemple : dans un nombre tel que 123-4567).
Pour insérer un tiret insécable, appuyez sur les touches Ctrl+Maj+signe moins de votre
clavier numérique.

Les espaces et les tirets insécables peuvent également étre insérés via le menu Insertion >
Marque de formatage.

Insérer des tirets cadratins et demi-cadratins

Pour saisir des tirets cadratins (tirets longs) et demi-cadratins (tirets), vous pouvez utiliser I'option

Remplacer les tirets (active par défaut) dans le menu Outils > Options d’AutoCorrection (voir

Figure 16 en page 19). Cette option remplace deux tirets sous certaines conditions par le tiret cor-
respondant.

— est un tiret demi-cadratin qui a la largeur de la lettre « n » dans la po-
lice utilisée. Tapez au moins un caractere, un espace, un ou deux signes moins, un deuxieme es-
pace et au moins une lettre supplémentaire. Le(s) signe(s) moins sera (seront) remplacé(s) par un
tiret demi-cadratin.

— est un tiret cadratin qui a la largeur de la lettre « m » dans la police
utilisée. Tapez au moins un caractére, deux signes moins et au moins un caractére supplémen-
taire. Les signes moins seront remplacés par un tiret cadratin. Exception : si les caractéres sont
des chiffres, comme dans un intervalle de dates ou de temps, les deux signes moins sont rempla-
cés par un tiret demi-cadratin.
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Dans le Tableau 1 ci-aprés, A et B représentent du texte en lettres de A a Z ou des chiffres de 0 &
9.

Tableau 1 : Insérer des tirets
Texte que vous saisissez Résultat

A - B (A, espace, signe moins, espace, B) A — B (A, espace, tiret demi-cadratin, espace, B)

A -- B (A, espace, signe moins, signe moins, es- | A— B (A, espace, tiret demi-cadratin, espace, B)
pace, B)

A--B (A, signe moins, signe moins, B) A—B (A, tiret cadratin, B)

1--2 (chiffre, signe moins, signe moins, chiffre) |1-2 (chiffre, tiret demi-cadratin, chiffre)
A-B (A, signe moins, B) A-B (inchangé)

A — B (A, espace, signe moins, B) A — B (inchangé)

A --B (A, espace, sighe moins, signe moins, B) |A— B (A, espace, tiret demi-cadratin, B)

Il est également possible d’'insérer des tirets cadratins ou demi-cadratins a partir du menu Inser-
tion > Caractéres spéciaux. Sélectionnez-y le caractére U+2013 ou U+2014 (dans le sous-en-
semble Ponctuation générale).

Une troisieme méthode utilise les raccourcis claviers. Ces raccourcis varient suivant votre systeme
d’exploitation.

> Astuce

Vous pouvez aussi enregistrer des macros pour insérer des tirets demi-cadratins et cadra-
tins et assigner ces macros a des combinaisons de touches non utilisées, par exemple
Ctrl+Maj+N et Ctrl+Maj+M. Pour plus d'informations sur les macros, référez-vous au
chapitre 21, Personnaliser Writer, de ce guide.

Windows

Sur la plupart des versions non asiatiques de Windows, maintenez enfoncée 'une des
touches A1t de votre clavier et tapez sur le clavier numérique 0150 pour un tiret demi-cadra-
tin ou 0151 pour un tiret cadratin. Le tiret apparait quand vous relachez la touche A1t.

> Astuce

Sur un clavier sans pavé numeérique, utilisez la touche Fn (Fonction) en combinaison pour
taper les chiffres (la touche Fn est habituellement a la droite de la touche Ctrl gauche du cla-
vier).

Par exemple, sur un clavier francais, la combinaison pour un tiret demi-cadratin serait
Alt+Fn+, ji, et pour un tiret cadratin AIt+Fn+, jij.

Linux

Maintenez enfoncée la touche Compose de votre clavier et tapez deux tirets et un point pour
un tiret demi-cadratin ou trois tirets pour un tiret cadratin. Le tiret apparait lorsque vous rela-
chez la touche Compose.

14 | Travailler avec le texte : les bases



> Astuce

La touche qui opére comme Compose varie suivant les distributions Linux. Elle est habituel-
lement I'une des touches Alt ou Win, mais peut étre une autre touche choisie par I'utilisateur.

Mac OS X

Maintenez la touche Option (Alt) et tapez un tiret pour un tiret demi-cadratin. Pour un tiret
cadratin utilisez Maj+Option+tiret.

Vérification orthographique et grammaticale

Orthographe

Writer fournit un vérificateur orthographique qui contréle chaque mot du document par rapport a
ceux enregistrés dans le dictionnaire. Cela signifie que certains mots (par exemple, les noms
propres), méme s'ils sont correctement orthographiés, peuvent étre signalés comme mal écrits, car
ils ne sont pas disponibles dans le dictionnaire. Writer fournit également un vérificateur grammati-
cal qui peut étre utilisé séparément ou en combinaison avec le vérificateur orthographique (voir les
sections « Orthographe et grammaire » et « Grammaire » en pages 16 et 18).

Si elle est activée avant de commencer la saisie, la fonction Vérification automatique vérifie
chaque mot pendant la frappe. Si la fonction est activée aprés la saisie, tout le texte déja présent
dans le document est vérifié. Les mots non reconnus sont soulignés par des vagues rouges.

La fonction Vérification automatique peut étre activée en cliquant sur I'icéne 225 dans la barre

d’outils Standard, ou via le menu Outils > Options > Paramétres linguistiques > Linguistique
puis en cochant I'option Vérifier I'orthographe au cours de la frappe dans la liste Options.

Faites un clic droit sur un mot non reconnu pour ouvrir un menu contextuel (voir Figure 8). Cliquez
ensuite sur I'une des suggestions dans le haut du menu pour remplacer le mot souligné par celui
que vous avez choisi.

Si le suivi des modifications est activeé, ce menu contextuel offre des options supplémentaires en
rapport avec les modifications du texte.

dans la liste Oém‘on

Option

Optimisation

Ignorer

Tout ignorer

Ajouter au dictionnaire

¥ Orthographe et grammaire...

Toujours corriger en »
Options d'AutoCorrection...

Définir la langue de la sélection »

Définir la langue pour le paragraphe »

Optiion : inconnu du dictionnaire

Rechercher "Optiion” »

Figure 8 : Le menu contextuel de correction orthographique
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Plusieurs choix sont disponibles dans le centre du menu contextuel dédié a la correction orthogra-
phique.

Ignorer

Le mot souligné sera ignoré tant que le document sera ouvert. Si le méme mot est présent
ailleurs dans le document, il demeurera souligné. Ce paramétre n’est pas stocké avec le do-
cument.

Tout ignorer

Tous les mots identiques & celui souligné seront ignorés et le mot sera ajouté a la liste Tout
ignorer du dictionnaire personnalisé de ['utilisateur.

Ajouter au dictionnaire

Le mot est ajouté au dictionnaire personnalisé de l'utilisateur. Si un seul dictionnaire est acti-
vé, aucun choix n'est possible et le mot est par défaut ajouté au dictionnaire Standard.

Orthographe et grammaire

Cette fonction ouvre la boite de dialogue Orthographe et Grammaire. Pour plus d’informa-
tions sur cette boite de dialogue, consultez la section suivante « Orthographe et gram-
maire » en page 16.

e Remarque

Si aucun dictionnaire grammatical n’est installé sur votre ordinateur, la boite de dialogue Or-
thographe et Grammaire s'intitulera Orthographe. Vous pouvez installer un dictionnaire
grammatical via le menu Outils > Langue > Dictionnaires supplémentaires en ligne.
Pour plus d’'informations sur I'installation de dictionnaires ou d’extensions, référez-vous au
chapitre 20, Paramétrer Writer, de ce guide.

Toujours corriger en

Ouvre un sous-menu qui reprend les suggestions du haut du menu. Le fait de sélectionner
un mot de remplacement dans ce sous-menu stocke le mot en question dans la table de
remplacement (disponible via le menu Outils > AutoCorrection > Options d’AutoCorrec-
tion > Remplacer). Par conséquent, lorsque vous saisirez le mot mal orthographié dans
n'importe quel document, il sera automatiqguement remplacé, car le mot mal orthographié et
son équivalence correcte seront enregistrés dans la table de remplacement. Par exemple, si
vous saisissez le mot “voulior”, il sera automatiquement remplacé par “vouloir”.

Options d’Autocorrection

Ouvre la boite de dialogue AutoCorrection (voir page 23), oU VOUS pouvez ajouter vos
propres corrections et modifier celles proposées par LibreOffice.

Dans la troisieme partie du menu contextuel dédié a la correction orthographique, vous pouvez dé-
terminer les parametres linguistiques. Ces derniers peuvent s’appliquer au texte sélectionné, au
paragraphe ou au document entier.

Orthographe et grammaire

Pour effectuer une vérification du document (ou d’une sélection) combinant I'orthographe et la
grammaire, cliquez sur l'icbne Orthographe et grammaire de la barre d’outils Standard ou ap-
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puyez sur la touche F7 de votre clavier. Afin de procéder a cette vérification, les dictionnaires ap-
propriés doivent étre installés. Par défaut, quatre dictionnaires sont installés : un vérificateur ortho-
graphique, un vérificateur grammatical, un dictionnaire de césure et un dictionnaire des syno-
nymes.

Pour le francais, I'extension Grammalecte prend en charge la vérification grammaticale. Cette ex-
tension est disponible a cette adresse : https://extensions.libreoffice.org/extensions/grammalecte.

Si aucun texte n’est sélectionné, la vérification orthographique et grammaticale commence a l'en-
droit ou le curseur est placé Si des mots non reconnus par le(s) dictionnaire(s) sont trouvés ou
gu’une regle grammaticale n’est pas respectée, la boite de dialogue Orthographe et grammaire
s'ouvre (voir Figure 9). Lorsque la vérification est terminée, un message s’affiche pour vous propo-
ser de recommencer la vérification depuis le début du document

Orthographe et grammaire : Frangais (France)

Langue du texte : ‘*@? Francais (France) =z ‘

Absent du dictionnaire W8

Pour effectuer une vérification du document (ou d'une sélection) “

combinant I'orthographe et la grammeére, cliquez sur l'icéne Orthographe
et grammaire de la barre d’outils Standard ou appuyez sur la touche F7
de votre clavier.

Ignorer une fois
Tout ignorer

Ajouter au dictionnaire

Suggestions

| Corriger
gram mere
gram-mere Tout corriger

Toujours corriger

I Veérifier la grammaire

Aide Options... Annuler Fermer

Figure 9 : La boite de dialogue Orthographe et grammaire
Les éléments de la boite de dialogue Orthographe et grammaire sont décrits ci-apres.
Langue du texte

La langue a utiliser pour la vérification orthographique et grammaticale peut étre définie de-
puis cette liste. Si la vérification orthographique est disponible pour cette langue, une coche
est affichée en face du nom de la langue.

Absent du dictionnaire

La phrase contenant I'erreur est affichée dans le champ. Le mot nhon reconnu par le diction-
naire est affiché en rouge.

Si une erreur grammaticale est remarquée, elle est indiquée en bleu (voir Figure 10). La
phrase ou le mot peut étre directement modifié dans le champ.

Suggestions

Ce champ contient les suggestions permettant de remplacer le mot mal orthographié. Sélec-
tionnez un mot et cliquez ensuite sur Modifier ou Tout modifier pour le remplacer.
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Pour les erreurs grammaticales, il n’existe pas de choix multiple. Cliquez, si possible, sur
Modifier pour accepter la suggestion.

Ignorer une fois, Tout ignorer et Ajouter au dictionnaire

Cliquer sur I'un de ces boutons a le méme effet que de cliquer sur I'option AutoCorrection
dans le menu contextuel dédié a la correction orthographique (voir la section « Ortho-
graphe » en page 15).

Ignhorer la régle

Pendant la vérification de la grammaire, vous pouvez choisir d’ignorer la modification propo-
see.

Corriger

,,,,,

phrase est modifiée.
Pour la grammaire, le remplacement proposé est utilisé pour corriger le texte.
Tout corriger

Remplace dans le document tous les mots identiques a celui en rouge par le mot choisi dans
les suggestions.

Toujours corriger

Le bouton Toujours corriger de la boite de dialogue Orthographe et grammaire se comporte
de facon similaire a I'option Toujours corriger en du menu contextuel dédié a la correction
orthographique (voir la section « Orthographe » en page 16). Cependant, le mot n’est pas
remplacé dans le document et vous devez donc recourir au bouton Corriger ou au bouton
Tout corriger.

Annuler

Ce bouton devient actif lorsqu’une maodification a été effectuée dans la phrase, ce qui vous
permet d’annuler le changement. Ce bouton n’est pas disponible si vous utilisez le bouton
Corriger ou le bouton Tout corriger pour remplacer un mot.

Options

Ouvre la boite de dialogue Options dans laquelle vous pouvez sélectionner les dictionnaires
et définir les paramétres de vérification orthographique et grammaticale.

e Remarque

Il est conseillé d’exécuter deux fois pour le méme document la vérification orthographique et
grammaticale. Un probléme mineur du logiciel peut empécher la détection de toutes les er-
reurs grammaticales en un seul passage.

Grammaire

Par défaut, la fonction Vérifier la grammaire au cours de la frappe est activée dans le menu Outils
> Options > Parameétres linguistiques > Options. La vérification orthographique doit étre activée
et un vérificateur grammatical doit étre installé (voir page 17) pour que la vérification grammaticale
fonctionne.
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Si des erreurs sont détectées, elles sont soulignées par des vagues bleues. Effectuez un clic droit
sur I'erreur afin d’ouvrir un menu contextuel semblable a celui affiché a la Figure 10 et a la Figure
11.

La pomme qu’elle a mangé.

® Si«la pomme... » est bien le COD du participe passé « mangé », celui-ci devrait étre au féminin singulier.

Explications...
mangée
Ignorer

Tout ignorer
¥ Orthographe et grammaire..

Définir la langue de la sélection »

Définir la langue pour le paragraphe »
mangé : verbe (1% gr.), participe passé, adjectif, présent interr. 1% p. sg., masculin singulier [manger]

Conjuguer “manger”...

Rechercher "mangé” 4

Figure 10 : Correction d’'une erreur grammaticale

La premiére entrée du menu vous renseigne sur la regle grammaticale suspectée de ne pas étre
respectée.

Dans I'exemple de la Figure 10, la seconde entrée du menu Explications ouvre votre navigateur
internet et vous présente un site web qui vous donne de plus amples informations sur I'erreur com-
mise.

La deuxiéme section du menu vous suggere des corrections possibles. Cliquez sur I'une de ces
suggestions pour modifier I'erreur par ladite suggestion. Dans I'exemple de la Figure 11, cette sec-
tion est vide, mais vous pouvez cliquer sur cette ligne vide pour supprimer le double espace res-
ponsable de I'erreur.

Ced:L:u rhre_ect flevri

@ Espace(s) surnuméraire(s) a supprimer.

Ignorer
Tout ignorer
¥ Orthographe et grammaire...

Définir la langue de la sélection »

Définir la langue pour le paragraphe >
Cet : déterminant démonstratif, masculin singulier

Rechercher * ” »

Figure 11 : Correction d’'une erreur typographique

Dans la troisiéme section du menu, vous pouvez choisir d’ignorer I'erreur indiquée ou ouvrir le véri-
ficateur orthographique et grammatical. La Figure 12 montre la boite de dialogue Orthographe et
grammaire expliquant I'erreur grammaticale commise.

Dans la section suivante du menu, vous pouvez paramétrer la langue pour la sélection ou le para-
graphe.

Vous pouvez également ajouter des correcteurs grammaticaux supplémentaires en ajoutant des
extensions via le Gestionnaire des extensions (via le menu Outils > Gestionnaire des exten-
sions).
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Orthographe et grammaire : Frangais (France)

Langue du texte : ¥ Francais (France)

Accord de genre erroné : « vérification » est féminin.

Absent du dictionnaire B8
Pour effectuer un vérification du document {ou d'une sélection) combinant ~
I'orthographe et la grammaire, cliquez sur I'icdne Orthographe et grammaire de Ignorer une fois

la barre d’outils Standard ou appuyez sur la touche F7 de votre clavier. Afin de

procéder a cette vérification, les dictionnaires appropriés doivent étre installes.

Par défaut, quatre dictionnaires sont installés : un vérificateur orthographique, un Ignorer la régle
v

varificataiir arammatical un dictiannaira Ada cdenira at 1in dictiannaira dac

Suggestions

M Vérifier la grammaire

Aide Options... Annuler Fermer

Figure 12 : La boite de dialogue Orthographe et grammaire donnant des informations sur I'erreur
grammaticale commise.

Utiliser le dictionnaire des synonymes

Vous pouvez obtenir une courte liste des synonymes possibles via le menu contextuel (voir Figure
13):

1) Effectuez un clic droit sur un mot ou une phrase sélectionnée afin d’ouvrir le menu contex-
tuel. Placez le curseur de la souris sur Synonymes dans le menu contextuel pour dévelop-
per le sous-menu dans lequel s’affichent des propositions alternatives au mot ou a la phrase.

2) Cliguez sur un mot ou une phrase pour remplacer le mot ou la phrase concerné dans votre
document.

légal '~ Nictinnnaira dac cvmamumac nroposera de nombreuses
ternal Couper Ctrl+X e
Copier Ctrl+C ’

Coller Ctrl+V
Collage spécial 4

&

Caractere...

Paragraphe...

- @ g

¥¥ Puces et numérotation...
Page...

Styles 4

Synonymes 3 authentique

légal : adjectif, masculin singulier kel

vrai
constitutionnel
inné
réglementaire

juridique

Dictionnaire des synonymes...

Figure 13 : Synonymes disponibles dans le menu contextuel.
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Le Dictionnaire des synonymes fournit une liste plus étoffée de mots et de phrases alternatifs.
Pour utiliser le Dictionnaire des synonymes :

1) Sélectionnez un mot ou une phrase dans votre document. Cliquez ensuite sur le menu Ou-
tils > Langue > Dictionnaire des synonymes, ou appuyez sur les touches Ctrl+F7 de

votre clavier, ou faites un clic droit sur la sélection et choisissez Synonymes > Dictionnaire
des synonymes dans le menu contextuel.

2) La boite de dialogue Dictionnaire des synonymes s’affiche. Cliquez sur un mot ou une
phrase dans la liste des alternatives pour la sélectionner.

3) Cliquez sur le bouton Remplacer pour effectuer la substitution.

Par exemple, si vous souhaitez remplacer le mot /égal, le Dictionnaire des synonymes proposera
de nombreuses significations et alternatives dont vrai, inné et authentique (voir Figure 14).

Dictionnaire des synonymes (Francais (France))

Mot actif :

légal ~ ‘Frangais (France) V‘

Alternatives :

1. (Ad'iectif) authentiiue

original
vrai
constitutionnel

~

inné

réglementaire

Jjuridique

prescrit y
Remplacer par:

authentique

Aide Annuler

Figure 14 : La boite de dialogue Dictionnaire des synonymes.

e Remarque

Si un Dictionnaire des synonymes n’est pas installé pour la langue active, cette fonction est
désactivée.

Coupure des mots

Vous avez plusieurs choix en ce qui concerne la coupure des mots : laisser Writer le faire automa-
tiguement (grace a son dictionnaire de coupure des mots), insérer manuellement des tirets condi-
tionnels ou vous le souhaitez, ou ne pas couper les mots du tout. Chaque choix présente des
avantages et des inconvénients.

Coupure des mots automatique

Pour (dés)activer la coupure des mots automatique :
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1) Cliquez sur l'onglet Style et formatage du Volet latéral pour ouvrir la page Style et formatage.
Dans la page Styles de paragraphe, faites un clic droit sur le Style par défaut pour ouvrir un
menu contextuel. Cliquez ensuite sur Modifier.

Styles et formatage =
@& O EEEE @ -

Sous-titre

Nouveau...

Table des matiére Modifier..

Table des matiér
Table des matiéres niveau 3
Table des matiéres niveau 4

Figure 15 : Modifier un style de paragraphe.

2) Dans la boite de dialogue Style de paragraphe, ouvrez la page Enchainements.

Style de paragraphe: Style par défaut

Surlignage  Plan & numérotation  Tabulations  Lettrines  Arrie

Gestionnaire  Retraits et espacement ~ Alignement = Enchainements

Coupure des mots

|§Agt0matiquement§|

2 - Caracteres en fin de ligne
2 - Caracteres en début de ligne
0 - Nombre maximum de coupures consécutives

Figure 16 : Activer la coupure des mots automatique.
3) Sous la section Coupure des mots, (dé)cochez 'option Automatiquement.

4) Cliguez sur le bouton OK pour enregistrer les modifications.

6 Remarque

Activer la coupure des mots pour le style de paragraphe par défaut affecte tous les para-
graphes basés sur le Style par défaut. Les styles non basés sur le style par défaut, un style
de titre par exemple, ne sera pas affecté par cette modification, a moins que vous ne para-
métriez également son style de paragraphe. Pour plus d’informations sur les styles de para-
graphe, référez-vous aux chapitres 8 et 9 de ce guide.

Vous pouvez configurer les parametres de coupure des mots via le menu Outils > Options > Pa-
rametres linguistiques > Linguistique. Dans la section Options, recherchez les parametres re-
latifs a la coupure des mots.

Pour modifier le nombre minimum de caractéres pour la coupure des mots ou le nombre minimum
de caracteres avant/apres la séparation, sélectionnez I'élément concerné puis cliquez sur le bou-
ton Editer.

Coupure automatique

Indique qu'il ne vous sera jamais demandé de couper manuellement les mots non reconnus
par le dictionnaire de coupure des mots. Si cette case n’est pas cochée, lorsqu’un mot ne
sera pas reconnu, une boite de dialogue s’ouvrira afin que vous réalisiez la coupure manuel-
lement.
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Options :

Vérifier les mots en majuscules A Edire

L1 Vérifier les mots comportant des chiffres

Vérifier les zones spéciales

Nombre minimum de caractéres
Caracteéres avant le saut: 2
Caractéres aprés le saut: 2

L Coupure automatique

Coupure des zones spéciales

pour la coupure des mots: 5

W

Figure 17 : Parameétres relatifs a la coupure des mots.
Coupure des zones spéciales

Indique que la coupure des mots sera également réalisée dans les notes de bas de page, les
en-tétes et les bas de page.

Les options inhérentes a la coupure des mots paramétrées dans le menu Outils > Options > Pa-
ramétres linguistiques > Linguistique sont effectives uniquement si la coupure des mots est ac-
tivée dans les styles de paragraphe.

Coupure des mots manuelle

Lors d'une coupure des mots manuelle, n'utilisez pas un tiret normal. Ce dernier resterait visible
méme si le mot coupé n’est plus trop long en raison d’un ajout ou d’'une suppression de texte,
d’'une modification des marges ou de la taille de la police. Utilisez plutét un Tiret conditionnel.

Pour insérer un Tiret conditionnel a l'intérieur d’un mot, cliguez dans le mot a I'endroit ol vous sou-
haitez que celui-ci apparaisse et enfoncez ensuite les touches Ctr1+Signe moins (du pavé numé-
rique) de votre clavier ou cliquez sur le menu Insertion > Marque de formatage > Tiret condi-
tionnel. Le mot sera coupé a I'endroit choisi lorsqu’il se retrouvera a la fin d’'une ligne, méme si la
coupure des mots automatique est désactivée pour le paragraphe.

Utiliser I’ AutoCorrection

Les options d’AutoCorrection de Writer constituent une longue liste de fautes d’orthographe ou de
frappe courantes et d’erreurs typiques qui peuvent étre corrigées automatiguement. Par exemple,
“dse” sera remplacé par “des”. Elles comportent aussi des codes qui permettent d’'insérer des ca-
ractéres spéciaux, des émojis ou d’'autres symboles.

Les options d’AutoCorrection sont activées par défaut. Pour les désactiver, décochez I'option via le
menu Outils > AutoCorrection > Pendant la frappe.

Pour ouvrir la boite de dialogue AutoCorrection, cliquez sur le menu Outils > AutoCorrection >
Options d’AutoCorrection. Vous pouvez y définir quels sont les mots a corriger, le texte de rem-
placement et le format & utiliser. A noter que de nombreuses entrées sont déja disponibles.

Afin que Writer arréte de remplacer un mot mal orthographié, cliquez sur I'onglet Remplacer de la
boite de dialogue AutoCorrection. Sélectionnez le mot mal orthographié et son remplagant, puis
cliguez sur le bouton Supprimer.

Pour ajouter un nouveau mot a la liste, saisissez sa version mal orthographiée dans le champ
Remplacer ainsi que son remplacant dans le champ Par. Cliquez ensuite sur le bouton Nouveau.
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N’hésitez pas a également consulter les autres onglets de la boite de dialogue AutoCorrection afin
de découvrir toutes les autres options disponibles et, éventuellement, de les régler a votre conve-
nance.

AutoCorrection

Remplacements et exceptions pour la langue : |Frangais (France) 2

Remplacer Exceptions Options Options linguistiques Insertion automatique

Remplacer Par: Texte seulement
Nouveau
> < x Supprimer
>= >
>
1//2 s
1//3 /3
1//4 a
1//8 a
2//3 24
3//4 3/
3//8 3
5//8 %8
1//8 Vs
at'elle a-t-elle
atil a-t-il
at'on a-t-on
a-t'elle a-t-elle
a-t'il a-t-il 4

Aide Annuler Réinitialiser

Figure 18 : L'onglet Remplacer de la boite de dialogue AutoCorrection.

> Astuce

L'AutoCorrection peut étre utilisée comme un moyen rapide d’insérer des caractéeres spé-
ciaux. Par exemple, (c) sera remplacé automatiguement par ©. Vous pouvez également
ajouter d’autres caractéres spéciaux a la liste.

Un clic droit dans les champs Remplacer et Par permet d’accéder aux caractéres spéciaux.

Voir le chapitre 4, Mettre le texte en forme, pour une présentation des pages Options et Options
linguistiques de cette boite de dialogue.

Utiliser lI'insertion automatique

Si I'lnsertion automatique est activée, Writer tente de déterminer quel est le mot que vous saisis-
sez et vous propose de compléter le mot pour vous. Pour accepter la suggestion du logiciel, ap-
puyez sur la touche Entrée de votre clavier. Si la suggestion ne vous convient pas, continuez a sai-
sir le mot.

Pour désactiver I'Insertion automatique, cliquez sur le menu Outils > AutoCorrection > Options
d’AutoCorrection puis décochez 'option Activer l'insertion automatique dans I'onglet Insertion au-
tomatique.
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AutoCorrection

Remplacements et exceptions pour la langue : |Francais (France)

Remplacer Exceptions Options Options Iinguistiquesé\nsertion automatique

L Activer I'insertion automatique abaisser ~
Ajouter un espace abandonner
Afficher sous forme d'infobulle about-us
accepter
M Collecter les mots p. .
accessibility
Lors de la fermeture d'un document, accessible
Usupprime de la liste les mots collectés a  |activées
partir du document actuelle
Accepter avec : Adielsson
adresser
affectent
Longueur de mot min. : affecter
3 - Afﬂchage
Afficher
Maximum d'entrées : affichée
1000 = affichées
affichés
ailleurs
ajoutant v

Supprimer I'entrée

Aide Annuler Réinitialiser

Figure 19 : L'onglet Insertion automatique de la boite de dialogue AutoCorrection

Il est possible de personnaliser l'insertion automatique via I'onglet de méme nom de la boite de
dialogue AutoCorrection.

Ajouter un espace automatiquement apres le mot que vous venez d'accepter.

Afficher sous forme d’infobulle la suggestion plutét que de I'afficher dans le texte que vous
saisissez.

Collecter les mots lorsque vous travaillez dans un document et les garder en mémoire afin

de les utiliser dans d’autres documents. Toutefois, vous pouvez décider de supprimer la liste
des mots lorsque vous fermerez le document.

Modifier le maximum d’entrées a enregistrer pour l'insertion automatique ainsi que la lon-
gueur minimum et maximum des mots a sauvegarder.

Supprimer certaines entrées de la liste des mots disponibles pour la complétion.

Modifier la touche qui vous permet d’accepter la suggestion. Les touches possibles sont :
Fléche vers la droite, Fin, Entrée, Barre espace et Tabulation.

Remarque

L'insertion automatique s’active si vous avez saisi au moins deux fois le méme mot dans un
méme document.
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Utiliser I’'AutoTexte

Les AutoTextes permettent d’enregistrer du texte, des tableaux, des champs ainsi que d’autres élé-
ments que vous utilisez de manieres récurrentes. Vous pourrez les lier a des raccourcis qui facilite-
ront leur récupération.

Par exemple, au lieu de chaque fois saisir la formule de politesse “Je vous prie d’agréer, Madame,
Monsieur, mes salutations distinguées.” dans un courrier, vous pouvez paramétrer un AutoTexte
afin de simplement saisir le raccourci “sd” et appuyer sur la touche F3 pour insérer la phrase com-

pléte dans votre document.

Les AutoTextes sont particuliérement utiles lorsqu’ils sont assignés a des champs. Pour plus d'in-
formation sur les champs, référez-vous au chapitre 17, Travailler avec les champs, de ce guide.
Créer un AutoTexte

Pour enregistrer du texte comme AutoTexte :

1) Saisissez le texte dans votre document.

2) Sélectionnez le texte.

3) Cliquez sur le menu Outils > AutoTexte (ou appuyez sur les touches Ctr1+F3 de votre cla-
vier).
4) Dans la boite de dialogue AutoTexte, saisissez un nom pour I'’AutoTexte dans le champ Nom.

Dans le champ Raccourci, Writer vous suggérera un raccourci que vous pourrez éventuelle-
ment modifier.

5) Dans la liste en dessous des champs Nom et Raccourci, choisissez la catégorie dans la-
quelle enregistrer I'’AutoTexte. Par exemple, optez pour la catégorie Mes AutoTextes.

AutoTexte

LlLors de la saisie, afficher le nom complet sous forme d'infobulle

Nom : Chapitre Raccourci: |CH

# Cartes de visite professionnelles (85 x 50)
Mes AutoTextes

% Standard

% Uniguement pour les modéles

Enregistrer des liens relatifs

L Systéme de fichier Ulnternet

Aide Insérer Fermer AutoTexte ¥ || Catégories.. Chemin...

Nouveau

Nouveau (texte seulement)

Importer...

Figure 20 : Définir une nouvelle entrée d’AutoTexte.
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6) En bas de la boite de dialogue, cliquez sur le bouton AutoTexte et sélectionnez, dans le
sous-menu, soit Nouveau (si vous souhaitez que votre AutoTexte conserve son formatage,
peu importe I'endroit ou il sera inséré), soit Nouveau (texte seulement) (si vous souhaitez
que votre AutoTexte s'impregne du formatage de 'emplacement ou il sera inséré).

7) Cliquez sur le bouton Fermer pour retourner au document.

> Astuce

Si la seule option possible dans le sous-menu du bouton AutoTexte est Importer, soit vous
n'avez pas donné un nom a I’AutoTexte, soit aucun texte n'a été sélectionné dans le docu-
ment.

Pour enregistrer un tableau comme AutoTexte :
1) Créez un tableau et formatez-le comme vous le souhaitez.
2) Sélectionnez le tableau.

3) Cliguez sur le menu Outils > AutoTexte (ou appuyez sur les touches Ctr1+F3 de votre cla-
vier).

4) Dans la boite de dialogue AutoTexte, saisissez un nom pour I'’AutoTexte dans le champ Nom.
Dans le champ Raccourci, Writer vous suggérera un raccourci que vous pourrez éventuelle-
ment modifier.

5) En bas de la boite de dialogue, cliqguez sur le bouton AutoTexte et sélectionnez, dans le
sous-menu, I'option Nouveau, car vous souhaitez préserver le formatage du tableau.

6) Cliquez sur le bouton Fermer pour retourner au document.

Insérer un AutoTexte

Pour insérer un AutoTexte, saisissez le raccourci dans votre document et appuyez ensuite sur la
touche F3 de votre clavier.

Si, lors de la création de votre AutoTexte, vous avez coché I'option Lors de la saisie, afficher le
nom complet sous forme d’infobulle (voir Figure 20), saisissez le nom de I'’AutoTexte et une info-
bulle fera son apparition. Dés que vous la verrez, appuyez sur la touche Entrée de votre clavier

pour insérer I'AutoTexte.

> Astuce

Il est possible d'insérer une image dans une entrée d'Autotexte, a la condition que celle-ci
soit précédée et suivie d'un caractére, une espace, par exemple.

Imprimer une liste des entrées d’AutoTexte
Pour imprimer une liste des entrées d’AutoTexte :

1) Cliquez sur le menu Outils > Macros > Gérer les macros > LibreOffice Basic.

2) Dans la liste Macro de, cliquez sur Macros LibreOffice > Gimmicks > AutoTexte.

3) Cliquez sur le bouton Exécuter. Une liste des entrées d’AutoTexte disponibles sera générée
dans un nouveau document que vous pourrez ensuite imprimer.
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Macros LibreOffice Basic

Nom de la macro )
Exécuter
Main
Macro de Macros existantes dans : AutoText Fermer
@ = Mes macros ~
= & Macros LibreOffice InsertStringToCell
15l Access2Base Assigner...
W (@ AltSearch
* & Depot Editer
# =l Euro
® [s) FormWizard Supprimer
= & Gimmicks
& ChangeAllChars y ,
P s Aide

Figure 21 : Imprimer une liste des entrées d’AutoTexte via les macros.

Modifier la casse du texte sélectionné

Pour modifier rapidement la casse d'un texte, sélectionnez-le, puis cliquez sur le menu Format >
Texte. Choisissez ensuite I'une des possibilités suivantes :

« MAJUSCULES pour que toutes les lettres soient écrites en majuscules ;
* minuscule pour qu'aucun mot (sauf les noms propres) ne soit écrit en majuscule ;

* Changer de casse en boucle (Maj+F3) qui met successivement en boucle les mots sélec-
tionnés en majuscules, en minuscules ou avec une majuscule a chaque mot.

* Casse de phrase pour que seule la premiere lettre du premier mot de la phrase (en plus des
noms propres) soit en majuscule ;

+  Majuscule A Chaque Mot pour que la premiére lettre de chaque mot du texte sélectionné
soit en majuscule ;

* bASCULER LA CASSE pour que chaque lettre soit écrite dans la casse opposée.

Dautres options sont disponibles uniquement lorsque la prise en charge pour les langues asia-
tiques est activée. Dans ce cas, il ne s'agit pas vraiment de modification de la casse, mais plutdt
de remplacer les caractéeres par des formes légerement différentes des mémes lettres.

Writer n’offre aucune méthode automatique pour obtenir une « Casse de titre » ou tous les mots
sont en majuscules sauf certains sous-ensembles définis par des régles qui ne sont pas recon-
nues universellement. Pour obtenir cet effet, vous pouvez utiliser Majuscule A Chaque Mot puis
rétablir les mots qui n'ont pas été correctement mis en majuscules.

Vous pouvez aussi modifier la casse du texte grace a la boite de dialogue Caractéeres ou a un style
de caractere. Choisissez Format > Caracteére, cliquez sur I'onglet Effets de caractére puis choisis-
sez le type de casse quand la liste déroulante Effets. Majuscules mets toutes les lettres en majus-
cules. Minuscules les met toutes en minuscules. Petites majuscules les met toutes en majus-
cules mais en réduit la taille.
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Caractére

Police Effets de caractére Position Hyperlien Surlignage Bordures

Couleur de palice : Surlignage : Couleur de surlignage
|:| Automatique ¥ (Sans) = E Automatique
Effets : Barré:
............. : (sans) ]

Soulignage : Couleur de soulignage
Minuscules (Sans) b |:| Automatique
Titre Mot par mot

Petites majuscules

Figure 22 : Choix de la casse dans la boite de dialogue Caractére
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