Appendix B, Toolbars
Copyright

This document is Copyright © 2022 by the LibreOffice Documentation Team. Contributors are listed below. This document maybe distributed and/or modified under the terms of either the GNU General Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (https://creativecommons.org/licenses/by/4.0/), version 4.0 or later. All trademarks within this guide belong to their legitimate owners.

Contributors

Contributors for this edition:
Peter Schofield       Kees Kriek

Contributors for previous editions:
Peter Schofield       Kees Kriek       Dave Barton       Felipe Viggiano

Feedback

Please direct any comments or suggestions about this document to the Documentation Team mailing list: loguides@community.documentfoundation.org.

Note

Everything sent to a mailing list, including email addresses and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version

Published October 2022. Based on LibreOffice 7.4 Community. Other versions of LibreOffice may differ in appearance and functionality.

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions used in this document. For a detailed list, see LibreOffice Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click, Ctrl+click, or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl or Control</td>
<td>⌘ and/or Cmd or Command, depending on keyboard</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>Alt</td>
<td>Option depending on keyboard</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open the Styles deck in the Sidebar</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/
## Contents

**Copyright** ................................................................................................................................. 2  
  Contributors..................................................................................................................................... 2  
  Feedback........................................................................................................................................... 2  
  Publication date and software version............................................................................................... 2  
  Using LibreOffice on macOS........................................................................................................... 2  

**Introduction** ................................................................................................................................. 5  

**Using toolbars** ............................................................................................................................... 5  
  Displaying toolbars............................................................................................................................ 5  
  Closing toolbars................................................................................................................................. 5  
  Moving toolbars............................................................................................................................... 6  
  Docked toolbars................................................................................................................................ 6  
  Floating toolbars............................................................................................................................... 6  
  Floating sub-toolbars........................................................................................................................ 6  
  Docking toolbar................................................................................................................................ 7  
  Locking toolbars............................................................................................................................... 7  
  Docked toolbars............................................................................................................................... 7  
  Locking sub-toolbars........................................................................................................................ 7  
  Editing toolbars............................................................................................................................... 8  
  Adding tools...................................................................................................................................... 8  
  Deleting tools................................................................................................................................... 8  
  Customizing toolbars......................................................................................................................... 8  

**Toolbars** ......................................................................................................................................... 9  
  3D-Objects...................................................................................................................................... 9  
  3D-Settings...................................................................................................................................... 9  
  Align Objects................................................................................................................................. 10  
  Comments....................................................................................................................................... 10  
  Distribute Selection......................................................................................................................... 10  
  Drawing.......................................................................................................................................... 11  
  Edit Points...................................................................................................................................... 13  
  Find.................................................................................................................................................. 13  
  Fontwork........................................................................................................................................ 13  
  Form Controls................................................................................................................................. 14  
  Form Design.................................................................................................................................. 14  
  Form Navigation.............................................................................................................................. 14  
  Glue Points..................................................................................................................................... 15  
  Image.............................................................................................................................................. 15  
  Insert.............................................................................................................................................. 16  
  Legacy Circles and Ovals.................................................................................................................. 16  
  Legacy Rectangles.......................................................................................................................... 16  
  Line and Filling............................................................................................................................... 17  
  Master View................................................................................................................................. 17  
  Media Playback.............................................................................................................................. 17  
  Options......................................................................................................................................... 18
Introduction

In Impress there are several toolbars available to help in creating a presentation. Each toolbar has a default set of tools and the option to add additional tools to a toolbar.

**Note**

The icons displayed in the Impress toolbars illustrated in this appendix may differ from what is displayed on a computer screen. Toolbar icons depend on the computer operating system being used and how LibreOffice has been set up. For more information on customizing LibreOffice and the toolbars, see the *Getting Started Guide*.

Using toolbars

Displaying toolbars

To display and make a toolbar active, go to **View > Toolbars** on the Menu bar. A submenu opens with an alphabetical list of toolbars available for creating presentations in LibreOffice Impress. Click on a toolbar name to display it and make it active. Active toolbars are indicated by highlighting or a check mark next to the toolbar name.

### Impress toolbars available

<table>
<thead>
<tr>
<th>3D-Objects</th>
<th>Glue Points</th>
<th>Slide View</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D-Settings</td>
<td>Image</td>
<td>Standard</td>
</tr>
<tr>
<td>Align Objects</td>
<td>Insert</td>
<td>Standard (Single Mode)</td>
</tr>
<tr>
<td>Comments</td>
<td>Legacy Circles and Ovals</td>
<td>Standard (Viewing Mode)</td>
</tr>
<tr>
<td>Distribute Selection</td>
<td>Legacy Rectangles</td>
<td>Table</td>
</tr>
<tr>
<td>Drawing</td>
<td>Line and Filling</td>
<td>Text</td>
</tr>
<tr>
<td>Edit Points</td>
<td>Master View</td>
<td>Text Formatting</td>
</tr>
<tr>
<td>Find</td>
<td>Media Playback</td>
<td>Transformations</td>
</tr>
<tr>
<td>Fontwork</td>
<td>Options</td>
<td>TSCP Classification</td>
</tr>
<tr>
<td>Form Controls</td>
<td>Outline</td>
<td>Zoom</td>
</tr>
<tr>
<td>Form Design</td>
<td>Presentation</td>
<td></td>
</tr>
<tr>
<td>Form Navigation</td>
<td>Slide Sorter</td>
<td></td>
</tr>
</tbody>
</table>

**Note**

Some toolbars when selected in **View > Toolbars** on the Menu bar do not display until an object of the correct type is selected in a presentation. For example, the Image toolbar only displays when an image is selected.

Closing toolbars

To close a toolbar, use one of the following methods:

- Go to **View > Toolbars** on the Menu bar and deselect the toolbar.
- Right-click in a blank area on a toolbar and select **Close Toolbar** from the context menu.
- Click on the X in the right corner of the title bar of a floating toolbar.
Moving toolbars

Docked toolbars
By default, some toolbars are docked into position in the Impress main window. For example, the Standard toolbar is docked at the top of the main window. Docked toolbars can be undocked and moved to a new docked position on the main window or left as a floating toolbar.

1) Move the cursor over the small vertical handle at the left end of the toolbar, as shown in Figure 1. The cursor changes to the moving cursor used for the computer system and setup.
2) Click and drag the toolbar to a new location. This can be a new docked position or a floating toolbar. A hashed border appears around the toolbar indicating the toolbar position as it is dragged.
3) Release the cursor when the required position is reached.

Note
If the small vertical bar is not visible at the left end of a docked toolbar, then the toolbar is locked into position. A docked toolbar must be unlocked before it can be moved to a new position in the Impress main window. See “Locking toolbars” on page 7 for more information.

Floating toolbars
1) To move a floating toolbar, click on its title bar and drag it to a new floating location.
2) Release the cursor when the toolbar is in the required position.

Note
A floating toolbar does not have to be positioned on the Impress main window for it to function.

Floating sub-toolbars
Some tools on a toolbar have a triangle ▼ to the right of the tool indicating that more tools are available on a sub-toolbar, for example Basic Shapes on the Drawing toolbar. Sub-toolbars can be turned into floating toolbars and moved into a new position as follows:

1) Move the cursor over the horizontal handle at the top of the toolbar, as shown in Figure 2. The cursor changes to the moving cursor used for the computer system and setup.
2) Click and drag the toolbar to a new location to create a floating sub-toolbar.
3) Release the cursor when the required position is reached.
4) To close the floating sub-toolbar, right-click on the triangle ▼ in the sub-toolbar title bar and select Close Toolbar from the context menu, or click on the X at the right end of the sub-toolbar title bar.
Docking toolbar
To dock a floating toolbar, use one of the following methods:

- Click on the title bar and drag it to the top, bottom, left side, or right side of the main window. When the toolbar reaches a docking position, a hashed border appears at the docked position. Release the cursor and the toolbar is docked.
- Right-click on the toolbar and select Dock Toolbar from the context menu. The toolbar moves into a docked position. If the position is not suitable, move the toolbar to a new docked position.
- To dock all floating toolbars that are active, right-click on the toolbar and select Dock All Toolbars from the context menu.

Locking toolbars
Docked toolbars
When a toolbar has been docked into position on the Impress main window, the toolbar can also be locked into position preventing the toolbar from becoming a floating toolbar.

- To lock a toolbar into a docked position, right-click in a blank area on the toolbar and select Lock Toolbar Position from the context menu. A check mark appears against this option indicating the toolbar is now locked.
- To unlock a toolbar, right-click in a blank area on the toolbar and click on Lock Toolbar Position in the context menu. The check mark next to this option disappears indicating the toolbar is now unlocked. A small vertical or horizontal bar appears at the left end or top of the toolbar indicating that the toolbar is unlocked. This bar is also is used to move the toolbar.

Note
Some toolbars cannot be docked or locked into position. This is indicated by the options Dock Toolbar and/or Lock Toolbar Position being grayed out, making the options unavailable.

Locking sub-toolbars
To prevent sub-toolbars from becoming floating sub-toolbars, sub-toolbars have to be locked as follows:

1) Save the presentation that is open in Impress.
2) Go to View > Toolbars on the Menu bar and select Lock Toolbars from the submenu.
3) Select **Restart Now** in the Restart LibreOffice dialog that opens to activate the **Lock Toolbars** option.

4) To unlock sub-toolbars so they can become floating sub-toolbars, repeat Steps 1 thru 3. The **Lock Toolbars** option is an on/off switch.

---

**Note**

Using the **Lock Toolbars** option affects ALL toolbars and sub-toolbars available in all LibreOffice modules.

---

**Editing toolbars**

When LibreOffice is installed on a computer, it includes a set of toolbars suitable for each LibreOffice component. Each toolbar has a default set of visible tools. Tools can be added or deleted, and toolbars can be customized.

**Adding tools**

1) Right-click in a blank area on a toolbar, or click on the triangle ▼ on the right of the toolbar title bar.

2) Select **Visible Buttons** from the context menu to display a list of available tools.

3) Click on the tool required and the tool appears in the toolbar. The list of available tools closes automatically. If there is a highlight or check mark next to the tool, then that tool is already installed on the toolbar.

---

**Note**

When adding tools using **Visible Buttons**, the tool is added to the toolbar at the same position as the tool appears in the **Visible Buttons** list. That is, the top tool in **Visible Buttons** appears at the left end of the toolbar and the bottom tool appears at the right end of the toolbar. Tool positions cannot be changed using **Visible Buttons**.

---

**Deleting tools**

1) Right-click in a blank area on a toolbar, or click on the triangle ▼ on the right of the toolbar title bar.

2) Select **Visible Buttons** from the context menu to display a list of available tools.

3) Click on the tool no longer required and the tool is removed from the toolbar. The highlight or check mark next to the tool is also removed. The list of available tools closes automatically.

---

**Customizing toolbars**

Extra tools and commands that are not available in **Visible Buttons** can be added to a toolbar using customization. Customization also allows the creation of new toolbars if a specific set of tools are required for a specific task. For information on customizing toolbars, see the *Getting Started Guide*.
**Toolbars**

**Notes**

The available tools listed for each toolbar below are all available for installation on a toolbar when **Visible Buttons** is opened in the context menu for each toolbar. The tools already installed on a toolbar are indicated in **Visible Buttons** either by the tool icon being highlighted or by a check mark. This install indication depends on computer setup and computer operating system being used.

On some toolbars, the icons have a triangle ▼ to the right of an icon. Click on this triangle to open further options that are available for use.

Some of the tools in the toolbars also have the option of using a keyboard shortcut instead of clicking on the tool. For a full list of keyboard shortcuts that are available in Impress, see Appendix A, Keyboard Shortcuts.

**3D-Objects**

The 3D-Objects toolbar (Figure 3) provides tools to create 3D objects in a slide. It is activated by going to View > Toolbars > 3D-Objects on the Menu bar. Alternatively, click on the triangle ▼ next to the 3D-Objects icon displayed on the Drawing toolbar to open a submenu giving access to the available 3D objects.

![3D-Objects toolbar](image)

*Figure 3: 3D-Objects toolbar*

Available tools numbered from left to right

1) Cube  
2) Sphere  
3) Cylinder  
4) Cone  
5) Pyramid  
6) Torus  
7) Shell  
8) Half Sphere

**Note**

The 3D-Objects toolbar is also available as a sub-toolbar on the Drawing toolbar. See “Drawing” on page 11 for more information.

**3D-Settings**

The 3D-Settings toolbar (Figure 4) and its tools only become active when an object has been converted to 3D using the tool **Toggle Extrusion** and the converted object is selected.

![3D-Settings toolbar](image)

*Figure 4: 3D-Settings toolbar*

Available tools numbered from left to right

1) Toggle Extrusion  
2) Tilt Down  
3) Tilt Up  
4) Tilt Left  
5) Tilt Right  
6) Depth  
7) Direction  
8) Lighting  
9) Surface  
10) 3D Color
The following tools on the 3D-Settings toolbar have a triangle ▼ on the right of the icon. Click on this triangle to open a drop-down menu giving access to various options as follows:

**Depth**
3D extrusion depth — 0cm; 1cm; 2.5cm; 5cm; 10cm; Infinity; Custom. The measurement unit depends on the ruler settings in Tools > Options > LibreOffice Impress > General (macOS LibreOffice > Preferences > LibreOffice Impress > General).

**Direction**
3D extrusion direction and type — Parallel; Perspective.

**Lighting**
Lighting direction and lighting level of 3D extrusion — Bright; Normal; Dim.

**Surface**
Surface type of 3D extrusion — Wire Frame; Matt; Plastic; Metal.

**3D Color**
Color of 3D extrusion. Select a color from one of the available color palettes.

**Align Objects**
The Align Objects toolbar (Figure 5) provides tools for aligning several objects in a slide to improve the visual impact of objects on a slide.

![Align Objects toolbar](image)

*Figure 5: Align Objects toolbar*

**Available tools numbered from left to right**
1) Left  2) Centered  3) Right  4) Top  5) Center  6) Bottom

**Comments**
The Comments toolbar (Figure 6) provides tools for adding, deletion, and navigation of comments in a presentation. To use comments, it is recommended to add the name and initials of all users in Tools > Options > LibreOffice > User Data (macOS LibreOffice > Preferences > LibreOffice > User Data) so that comments can be easily identified.

![Comments toolbar](image)

*Figure 6: Comments toolbar*

**Available tools numbered from left to right**
1) Comment  2) Previous Comment  3) Next Comment  4) Delete Comment  5) Delete All Comments

**Distribute Selection**
The Distribute Selection toolbar (Figure 7) provides tools to distribute three or more selected objects evenly along the horizontal axis or vertical axis. Also, the spacing between objects can be evenly distributed.
Figure 7: Distribute Selection toolbar

Available tools numbered from left to right
1) Horizontally Left 4) Horizontally Right 7) Vertically Spacing
2) Horizontally Center 5) Vertically Top 8) Vertically Bottom
3) Horizontally Spacing 6) Vertically Center

Drawing

The Drawing toolbar (Figure 8) provides the majority of the tools normally used to create graphic objects on slides in a presentation. By default, this toolbar is normally docked on the left side of the Workspace.

Figure 8: Drawing toolbar

Available tools numbered from left to right
1) Select 18) Block Arrows (Arrow Shapes in Visible Buttons)) 29) Shadow
2) Zoom & Pan 19) Flowchart (Flowchart Shapes in Visible Buttons) 30) Crop Image (Crop in Visible Buttons)
3) Zoom 20) Callouts (Callout Shapes in Visible Buttons) 31) Filter
4) Text Box 21) Stars and Banners (Star Shapes in Visible Buttons) 32) Points F8 (Edit Points in Visible Buttons)
5) Vertical Text 22) 3D Objects 33) Show Glue Points Function (Glue Points in Visible Buttons)
6) Insert Fontwork 23) Position and Size 34) To Curve
7) Line Color 24) Rotate 35) To Polygon
8) Fill Color 25) Flip 36) To 3D
9) Line 26) Align Objects 37) T0 3D Rotation Object
10) Rectangle 27) Arrange 38) Toggle Extrusion
11) Ellipse 28) Select at least three objects to distribute 39) Insert
12) Line Ends with Arrow 29) 3D Objects 40) Controls
13) Lines and Arrows 30) Position and Size 31) Filter
14) Curves and Polygons 32) Points F8 (Edit Points in Visible Buttons)
15) Connectors 33) Show Glue Points Function (Glue Points in Visible Buttons)
16) Basic Shapes 34) To Curve
17) Symbol Shapes 35) To Polygon

Some tool shapes on the Drawing toolbar change depending on the last tool that was previously selected and used.

- Click on the triangle ▼ to the right of a tool to open a sub-toolbar. Select the required shape to add to a drawing.
- To create a floating sub-toolbar, click and drag at the top of the pop-up toolbar to an empty area on the main window. The sub-toolbars for these object types and the various shapes available are shown in Figures 9 to 16.
Figure 9: Lines and Arrows sub-toolbar

Figure 10: Curves and Polygons sub-toolbar

Figure 11: Basic Shapes sub-toolbar

Figure 12: Symbol Shapes sub-toolbar

Figure 13: Block Arrows sub-toolbar

Figure 14: Flowchart sub-toolbar

Figure 15: Stars and Banners sub-toolbar

Figure 16: 3D-Objects sub-toolbar

Note
The 3D-Objects sub-toolbar is the same as the 3D-Objects toolbar, which is available at View > Toolbars on the Menu bar.
**Edit Points**

The Edit Points toolbar (Figure 17) provides tools for editing the points of a curve or an object that has been converted to a curve. The toolbar only becomes active when an object is selected and one of the following methods is used to open the toolbar:

- Click on **Edit Points** on the Drawing or Standard toolbar.
- Use the keyboard shortcut **F8**.

![Edit Points toolbar](image)

*Figure 17: Edit Points toolbar*

**Available tools numbered from left to right**

1) Edit Points  
2) Move Points  
3) Insert Points  
4) Delete Points  
5) Convert to Curve  
6) Close Bezier  
7) Split Curve  
8) Corner Point  
9) Smooth Transition  
10) Symmetric Transition  
11) Eliminate Points

**Find**

The Find toolbar (Figure 18) opens by default and is docked in the bottom left corner of the Impress main window above the Status bar. However, it can be undocked and made into a floating toolbar.

![Find toolbar](image)

*Figure 18: Find toolbar*

**Available tools numbered from left to right**

1) Close Find Bar  
2) Find Text  
3) Find Previous  
4) Find Next  
5) Find All  
6) Match Case  
7) Find and Replace

**Fontwork**

The Fontwork toolbar (Figure 19) is used to create graphical text objects in a slide and provide the tools for editing the graphical text object. This toolbar only becomes active when a Fontwork graphical text object in a slide has been selected.

![Fontwork toolbar](image)

*Figure 19: Fontwork toolbar*

**Available tools numbered from left to right**

1) Insert Fontwork Text  
2) Fontwork Shape  
3) Fontwork Same Letter Heights  
4) Fontwork Alignment  
5) Fontwork Character Spacing  
6) Toggle Extrusion  
7) Fontwork Character Spacing

Some tools on the Fontwork toolbar have a triangle ▼ to the right of the tool. Click on the triangle to open a pop-up toolbar or drop-down option list.

**Fontwork Shape**

Select the required shape for the Fontwork graphical text object from the options available.
Fontwork Alignment
Select the paragraph alignment from the options available.

Fontwork Character Spacing
Select the required character spacing from the options available.

Form Controls
The Form Controls toolbar (Figure 20) provides the tools required to create an interactive form. This allows controls to be added to a form in a text, drawing, spreadsheet, presentation, or HTML document (for example a button that opens another presentation or slide).

Figure 20: Form Controls toolbar

Available tools numbered from left to right
1) Select   10) Option Button   20) Currency Field
2) Design Mode  11) List Box   21) Pattern Field
3) Toggle Form Control Wizards  12) Combo Box   22) Table Control
4) Form Design   13) Push Button   23) Navigation Bar
5) Control Properties   14) Image Button   24) Image Control
6) Form Properties   15) Formatted Field   25) File Selection
7) Label   16) Date Field   26) Spin Button
8) Text Box   17) Numerical Field   27) Scrollbar
9) Check Box   18) Group Box

Form Design
The Form Design toolbar (Figure 21) opens a form in Design Mode so that it can be edited. Controls of the form cannot be activated or its contents edited when in Design Mode. However, the position and size of the controls can be changed, other properties edited, and added or deleted controls in Design Mode.

Figure 21: Form Design toolbar

Available tools numbered from left to right
1) Select   8) Automatic Control Focus   15) Align Objects
2) Control Properties  9) Bring to Front   16) Open in Design Mode
3) Form Properties   10) Send to Back   17) Display Grid
4) Position and Size   11) Group   18) Snap to Grid
5) Form Navigator   12) Ungroup   19) Helplines While Moving
6) Activation Order   13) Enter Group
7) Add Field   14) Exit Group

Form Navigation
The Form Navigation toolbar (Figure 22) provides tools to edit a database table or control the data view. The toolbar is normally displayed at the bottom of a document that contains fields that are linked to a database. This toolbar is only active when forms are connected to a database, which is why an inactivate toolbar is shown in Figure 22.
The Form Navigation toolbar also allows movement within records as well as inserting and deleting records. If data is saved in a form, the changes are transferred to the database. This toolbar also provides tools providing sort, filter, and search functions for data records.

**Figure 22: Form Navigation toolbar**

**Available tools numbered from left to right**

1) Find Record 9) Last Record 17) Sort Ascending
2) Record 10) New Record 18) Sort Descending
3) Absolute Record 11) Save Record 19) AutoFilter
4) Text -> Record 12) Undo: Data entry 20) Apply Filter
5) Total No. of Records 13) Delete Record 21) Form-Based Filters
6) First Record 14) Refresh 22) Reset Filter/Sort
7) Previous Record 15) Refresh Control 23) Data source as Table
8) Next Record 16) Sort

**Glue Points**

The Gluepoints toolbar (Figure 23) provides tools to insert a glue point or modify the properties of a glue point. A glue point is a point where a connector is attached to an object. By default, LibreOffice automatically places a glue point at the center of each side of the bounding rectangle for every object created.

**Figure 23: Gluepoints toolbar**

**Available tools numbered from left to right**

1) Insert Glue Point 6) Glue Point Relative 10) Glue Point Vertical Top
2) Exit Direction Left 7) Glue Point Horizontal Left 11) Glue Point Vertical Center
3) Exit Direction Top 8) Glue Point Horizontal Center 12) Glue Point Vertical Bottom
4) Exit Direction Right 9) Glue Point Horizontal Right
5) Exit Direction Bottom

**Image**

The Image toolbar (Figure 24) provides tools to edit, modify, align, reposition and resize images. The toolbar only becomes active and available when an image is selected in a presentation. The Image toolbar automatically replaces the Line and Filling toolbar when it becomes active.

**Figure 24: Image toolbar**

**Available tools numbered from left to right**

1) Position and Size 6) Top 11) Bring Forward
2) Align Objects 7) Center 12) Send Backward
3) Left 8) Bottom 13) Send to Back
4) Centered 9) Arrange 14) In Front of Object
5) Right 10) Bring to Front 15) Behind Object
The Insert toolbar (Figure 25) provides tools to insert different types of objects into a slide.

Available tools numbered from left to right
1) New Page 5) Image 8) Chart
2) Floating Frame 6) Insert Audio or Video (Media in Visible Buttons) 9) OLE Object
3) Insert Page from File 7) Formula Object
4) Table

Legacy Circles and Ovals
The Legacy Circles and Ovals toolbar (Figure 26) provides tools to insert different types of circles and ovals into a drawing.

Available tools numbered from left to right
1) Insert Ellipse 6) Circle Segment 11) Ellipse Segment, Unfilled
2) Circle 7) Ellipse, Unfilled 12) Circle Segment, Unfilled
3) Ellipse Pie 8) Circle, Unfilled 13) Arc
4) Circle Pie 9) Ellipse Pie, Unfilled 14) Circle Arc
5) Ellipse Segment 10) Circle Pie, Unfilled

Legacy Rectangles
The Legacy Rectangles toolbar (Figure 27) provides tools to insert different types of rectangles and squares into a slide.

Available tools numbered from left to right
1) Insert Rectangle 4) Rounded Square 7) Rounded Rectangle, Unfilled
2) Square 5) Rectangle, Unfilled
3) Rectangle, Rounded 6) Square, Unfilled 8) Rounded Square, Unfilled
Line and Filling

The Line and Filling toolbar (Figure 28) provides tools and drop-down lists for editing lines, arrows, and object borders. The tools available vary depending on the type of object selected for editing.

Figure 28: Line and Filling toolbar

Available tools numbered from left to right
1) Position and Size 13) Send to Back 25) Horizontally
2) Align Objects 14) In Front of Object 26) Transformations
3) Left 15) Behind Object 27) Line
4) Centered 16) Reverse 28) Area
5) Right 17) Line Style 29) 3D Effects
6) Top 18) Line Width 30) Image Map
7) Center 19) Line Color 31) Animation
8) Bottom 20) Area Style/Filling 32) Interaction
9) Arrange 21) Fill Color 33) Show the Styles Sidebar
10) Bring to Front 22) Shadow 34) Display Grid
11) Bring Forward 23) Arrow Style 35) Helplines While Moving
12) Send Backward 24) Vertically

Master View

The Master View toolbar (Figure 29) provides tools to create a new master slide, rename a master slide, delete a master slide, and close master view. This toolbar is only active when Impress is in master view.

Figure 29: Master View toolbar

Available tools numbered from left to right
1) New Master 3) Delete Master
2) Rename Master 4) Close Master View

Media Playback

The Media Playback toolbar (Figure 30) provides the tools required to insert, view, play, and listen to audio and video files. The toolbar only becomes active when an audio or video file is selected. Impress supports many different media formats depending on the computer operating system being used.
**Media Playback toolbar**

**Available tools numbered from left to right**
1) Insert Audio or Video
2) Play
3) Pause
4) Stop
5) Repeat
6) Position
7) Mute
8) Volume
9) View

**Options**

The Options toolbar (Figure 31) provides tools for editing various settings for newly created presentations, for example how objects snap to the grid when being moved or resized.

**Outline**

The Outline toolbar (Figure 32) provides tools for working with outlines.

**Presentation**

The Presentation toolbar (Figure 33) provides tools for working with presentations.
Available tools numbered from left to right
1) New Slide 6) Change Slide Master 11) Go to Last Slide
2) Duplicate Slide 7) Expand Slide 12) Move Slide to Start
3) Rename Slide 8) Go to First Slide 13) Move Slide Up
4) Delete Slide 9) Go to Previous Slide 14) Move Slide Down
5) Slide Layout 10) Go to Next Slide 15) Move Slide to End

Slide Sorter
The Slide Sorter toolbar (Figure 34) allows selection of slides in the current presentation and start a presentation from the first slide.

Figure 34: Slide Sorter toolbar

Available tools numbered from left to right
1) Select 2) Start from First Slide

Slide View
The Slide View toolbar (Figure 35) opens with the Slide Sorter view and provides tools to rehearse timings of a slide show; hide and show slides, and change the number of slides displayed in Slide Sorter view.

Figure 35: Slide View toolbar

Available tools numbered from left to right
1) Rehearse Timings 3) Hide Slide
2) Show Slide 4) Slides per Row

Standard
The Standard toolbar (Figure 36) is common to all LibreOffice modules and provides tools for creating and editing documents using LibreOffice. The Standard toolbar differs between different LO modules to allow for different toolsets used in creating the different types of documents.

Figure 36: Standard toolbar

Available tools numbered from left to right
1) Load URL 12) Print 22) Auto Spellcheck
2) New 13) Cut 23) Zoom & Pan
3) Templates 14) Copy 24) Zoom
4) Open 15) Paste 25) Display Grid (Grid in Visible Buttons)
5) Open Remote 16) Clone Formatting (Clone in Visible Buttons) 26) Helplines While Moving
6) Save 17) Clear 27) Display Views
7) Save As 18) Undo 28) Views Tab Bar
8) Email 19) Redo 29) Format Slide
9) Edit Mode 20) Find and Replace 30) Master Slide
10) Export Directly as PDF 21) Spelling) 31) Start from First Slide
Standard (Single Mode)

The Standard (Single Mode) toolbar (Figure 37) can be used instead of the Standard toolbar if necessary. The Standard (Single Mode) toolbar is normally used when the user interface is switched to single mode. For more information on selecting and using user interface variants, see Chapter 12, User Interface Variants.

![Standard (Single Mode) toolbar](image)

**Figure 37: Standard (Single Mode) toolbar**

<table>
<thead>
<tr>
<th>Available tools numbered from left to right</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1) New</td>
<td>26) Insert Line (Line in visible Buttons)</td>
</tr>
<tr>
<td>2) Open</td>
<td>27) Rectangle</td>
</tr>
<tr>
<td>3) Save</td>
<td>28) Lines and Arrows</td>
</tr>
<tr>
<td>4) Export Directly as PDF</td>
<td>29) Curves and Polygons</td>
</tr>
<tr>
<td>5) Print</td>
<td>30) Connectors</td>
</tr>
<tr>
<td>6) Print Preview</td>
<td>31) Basic Shapes</td>
</tr>
<tr>
<td>7) Undo</td>
<td>32) Ellipse</td>
</tr>
<tr>
<td>8) Redo</td>
<td>33) Insertions</td>
</tr>
<tr>
<td>9) Find and Replace</td>
<td>34) Rectangle</td>
</tr>
<tr>
<td>10) Clone Formatting (Clone in Visible Buttons)</td>
<td>35) Lines and Arrows</td>
</tr>
<tr>
<td>11) Spelling</td>
<td>36) Callouts (Callout Shapes in Visible Buttons)</td>
</tr>
<tr>
<td>12) Entire Page</td>
<td>37) Shapes in Visible Buttons</td>
</tr>
<tr>
<td>13) New Slide</td>
<td>38) 3D Objects</td>
</tr>
<tr>
<td>14) Duplicate Slide</td>
<td>39) Flip</td>
</tr>
<tr>
<td>15) Rename Slide</td>
<td>40) Arrange</td>
</tr>
<tr>
<td>16) Delete Slide</td>
<td>41) Select at least three objects to distribute</td>
</tr>
<tr>
<td>17) Slide Layout</td>
<td>42) Arrange</td>
</tr>
<tr>
<td>18) Display Views</td>
<td>43) Select at least three objects to distribute</td>
</tr>
<tr>
<td>19) Text Box</td>
<td>44) Rotate</td>
</tr>
<tr>
<td>20) Vertical Text</td>
<td>45) Group</td>
</tr>
<tr>
<td>21) Insert Image (Image in Visible Buttons)</td>
<td>46) Ungroup</td>
</tr>
<tr>
<td>22) Insert Audio or Video (Media in visible Buttons)</td>
<td>47) Enter Group</td>
</tr>
<tr>
<td>23) Insert Chart (Chart in Visible Buttons)</td>
<td>48) Exit Group</td>
</tr>
<tr>
<td>24) Table</td>
<td>49) Select</td>
</tr>
<tr>
<td>25) Insert Fontwork</td>
<td>50) Entire Page</td>
</tr>
<tr>
<td>26) Insert Special Characters (Symbol in Visible Buttons)</td>
<td>51) Zoom &amp; Pan</td>
</tr>
<tr>
<td>27) Insert Fontwork Text</td>
<td>52) Start from First Slide</td>
</tr>
<tr>
<td>28) Insert Hyperlink (Hyperlink in Visible Buttons)</td>
<td>53) Start from Current Slide</td>
</tr>
<tr>
<td>29) Text Box</td>
<td>54) Standard (Viewing Mode)</td>
</tr>
<tr>
<td>30) Insert Chart (Chart in Visible Buttons)</td>
<td>55) The Standard (Viewing Mode) toolbar (Figure 40)</td>
</tr>
<tr>
<td>31) Vertical Text</td>
<td>56) The Standard (Viewing Mode) toolbar (Figure 40) provides tools to save, edit and distribute a document.</td>
</tr>
<tr>
<td>32) Show Draw Functions</td>
<td>57) Available tools numbered from left to right</td>
</tr>
<tr>
<td>33) Table</td>
<td>58) Save As</td>
</tr>
<tr>
<td>34) Insert Special Characters (Symbol in Visible Buttons)</td>
<td>59) Edit Mode</td>
</tr>
<tr>
<td>35) Insert Fontwork Text</td>
<td>60) Read Only Mode</td>
</tr>
<tr>
<td>36) Insert Hyperlink (Hyperlink in Visible Buttons)</td>
<td>61) Attach to Email (Email in Visible Buttons)</td>
</tr>
<tr>
<td>37) Text Box</td>
<td>62) Export Directly as PDF</td>
</tr>
<tr>
<td>38) Insert Chart (Chart in Visible Buttons)</td>
<td>63) EPUB</td>
</tr>
<tr>
<td>39) Vertical Text</td>
<td>64) Print Directly</td>
</tr>
<tr>
<td>40) Insert Fontwork</td>
<td>65) Print</td>
</tr>
<tr>
<td>41) Insert Image (Image in Visible Buttons)</td>
<td>66) Copy</td>
</tr>
<tr>
<td>42) Insert Special Characters (Symbol in Visible Buttons)</td>
<td>67) Find and Replace</td>
</tr>
<tr>
<td>43) Insert Chart (Chart in Visible Buttons)</td>
<td>68) Zoom</td>
</tr>
</tbody>
</table>

### Appendix B, Toolbars
Standard (Viewing Mode)

The Standard (Viewing Mode) toolbar (Figure 38) provides tools to save, edit and distribute a document.

Figure 38: Standard (Viewing Mode) toolbar

Available tools from left to right
1) Save As 5) Export Directly as PDF 10) Find and Replace
2) Edit Mode 6) EPUB 11) Zoom
3) Read Only Mode 7) Print Directly 12) Start from First Slide
4) Attach to Email (Email in Visible Buttons) 8) Print 9) Copy

Table

The Table toolbar (Figure 39) provides tools and options to edit and format a table placed on a slide. This toolbar only becomes active when a table is selected.

Figure 39: Table toolbar

Available tools numbered from left to right
1) Table 10) Align Top (Top in Visible Buttons) 16) Insert Column After
2) Border Style 11) Center Vertically (Center in Visible Buttons)
3) Border Color 17) Delete Row
4) Borders (Shift to overwrite) 18) Delete Column
5) Area Style/Filling 19) Delete Table
6) Fill Color 20) Select Table
7) Merge Cells 21) Select Column
8) Split Cells 22) Select Row
9) Optimize 23) Table Design
15) Insert Column Before 24) Table Properties

Text

The Text toolbar (Figure 40) provides tools to insert text boxes and callouts into a slide.

Figure 40: Text toolbar

Available tools numbered from left to right
1) Insert Text Box (Text Box in Visible Buttons) 3) Callouts 5) Fit Vertical Text to Frame
2) Fit Text in Textbox Size 4) Insert Vertical Text (Vertical Text in Visible Buttons) 6) Vertical Callouts
Text Formatting

The Text Formatting toolbar (Figure 41) provides tools for formatting text and alignment commands. This toolbar becomes active when text in a text box or graphic object has been selected and it automatically replaces the Line and Filling toolbar.

Available tools numbered from left to right
1) Font Name
2) Font Size
3) Increase Font Size (Increase in Visible Buttons)
4) Decrease Font Size (Decrease in Visible Buttons)
5) Bold
6) Italic
7) Underline
8) Double Underline
9) Strikethrough
10) Overline
11) Superscript
12) Subscript
13) Toggle Shadow (Shadow in Visible Buttons)
14) Apply outline attribute to font (Outline Font Effect in Visible Buttons)
15) Clear Direct Formatting (Clear in Visible Buttons)
16) lowercase
17) UPPERCASE
18) small capitals
19) Font Color
20) Character Highlighting Color
21) Toggle Unordered List (Unordered List in Visible Buttons)
22) Toggle Ordered List (Ordered List in Visible Buttons)
23) Outline Format
24) Align Left (Left in Visible Buttons)
25) Align Center (Center in Visible Buttons)
26) Align Right (Right in Visible Buttons)
27) Justified
28) Align Top (Top in Visible Buttons)
29) Center Vertically (Center in Visible Buttons)
30) Align Bottom (Bottom in Visible Buttons)
31) Set Line Spacing (Line Spacing in Visible Buttons)
32) Character Spacing
33) Increase Paragraph Spacing (Increase in Visible Buttons)
34) Decrease Paragraph Spacing (Decrease in Visible Buttons)
35) Text direction from left to right
36) Text direction from top to bottom
37) Left-To-Right
38) Right-To-Left
39) Select All
40) Character
41) Paragraph

Transformations

The Transformations toolbar (Figure 42) provides tools to modify the shape, orientation, or fill of selected objects.

Available tools numbered from left to right
1) Rotate
2) Flip
3) In 3D Rotation Object
4) Set in Circle (perspective)
5) Set to circle (slant)
6) Distort
7) Interactive transparency tool (Transparency tool in Visible Buttons)
8) Interactive gradient tool (Gradient tool in Visible Buttons)
TSCP Classification

The TSCP Classification toolbar (Figure 43) provides tools to help in selecting the security of a document. LibreOffice adds custom fields in the document properties (File > Properties > Custom Properties on the Menu bar) to store the classification policy as document metadata. TSCP stands for Transglobal Secure Collaboration Participation.

![TSCP Classification toolbar](image)

*Figure 43: TSCP Classification toolbar*

**Available tools numbered from left to right**
1) Apply document classification (Level)  
2) Manage Document Classification

Zoom

The Zoom toolbar (Figure 44) provides tools to reduce or enlarge the screen display of the current presentation.

![Zoom toolbar](image)

*Figure 44: Zoom toolbar*

**Available tools numbered from left to right**
1) Zoom In  
2) Zoom Out  
3) 100%  
4) Zoom Previous  
5) Zoom Next  
6) Entire Page  
7) Page Width  
8) Optimal View (Optimal in Visible Buttons)  
9) Object Zoom  
10) Zoom & Pan  
11) Shift