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What is Impress?
Impress is the presentation (slide show) program included in LibreOffice. Impress creates 
presentations in the Open Document Presentation (ODP) format, which can be opened by other 
presentation software or can be exported in different presentation formats.

Slides can be created that contain many different elements, including text, bulleted and 
numbered lists, tables, charts, and a wide range of graphic objects such as clipart, drawings and 
photographs. Impress also includes a spelling checker, a thesaurus, text styles, and background 
styles.

This chapter introduces the Impress user interface. The remaining chapters in this user guide 
explain all the features available in Impress that can be used to create more sophisticated slide 
shows.

To use Impress for more than very simple presentations, requires some knowledge of the slide 
elements. Slides containing text use styles to determine the appearance of that text. Creating 
drawings in Impress is similar to using the Draw program included in LibreOffice. See the Draw 
Guide for more details on how to use the drawing tools.

Starting Impress
Impress can be started in several ways:

• From the LibreOffice Start Center that opens when LibreOffice is opened and no other 
LibreOffice module is open.

– Click on Impress Presentation to create a new presentation;
– Click on Open File and navigate to the folder where there is an existing presentation.

• From the system menu using the standard menu from which most applications are 
started. Details vary with the operating system. See the Getting Started Guide for more 
information, some examples are listed below:

– Start menu in Windows.
– Applications menu in Linux with a Gnome desktop.
– Applications menu in macOS.

• From any open module of LibreOffice, go to File > New > Presentation on the Menu bar,
or click on New on the Standard toolbar and select Presentation from the drop-down 
menu.
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Note
When LibreOffice is installed on a computer, a menu entry for each component is 
normally added to the system menu. The exact name and location of these menu 
entries depend on the operating system and graphical user interface.

Note
The New icon displayed on the Standard toolbar depends on which LibreOffice 
module is open when creating a new presentation.

Figure 1: Impress main window

When starting Impress for the first time, the main Impress window (Figure 1) opens, as default, 
with the Select a Template dialog displayed (Figure 2). Templates included with Impress are 
designed to fit the two standard sizes of presentation slides: 4:3 and 16:9 ratios. However, 
templates will adapt to other sizes that are available and can be selected by going to Slide > 
Slide Properties > Slide on the Menu bar or the Slide panel in the Properties deck on the 
Sidebar.

Tip
To start Impress without the Select a Template dialog (Figure 2) opening, deselect 
Show this dialog at startup in the lower left of the dialog.

In Windows or Linux, go to Tools > Options > LibreOffice Impress > General on 
the Menu bar and deselect Start with Template Selection under New Document.

In macOS, go to LibreOffice > Preferences > LibreOffice Impress > General on 
the Menu bar and deselect Start with Template Selection under New Document.
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Main Impress window
The main Impress window (Figure 1) has three main sections: Slide Pane, Workspace, and 
Sidebar. At the top of the main window is the Menu bar and toolbars. Toolbars can be displayed 
or hidden during the creation of a presentation.

Tip
The Slide Pane and/or Sidebar can be closed by clicking the X in the upper right 
corner of each pane or going to View > Slide Pane or View > Sidebar on the Menu 
bar to deselect the pane. To reopen a pane, select View > Slide Pane or View > 
Sidebar on the Menu bar.

Figure 2: Select a Template dialog

Tip
To maximize the Workspace area click on the Hide/Show marker in the middle of the
vertical separator line (highlighted in Figure 1). Using one or both of these markers 
hides, but does not close, the Slide Pane or Sidebar. To restore a pane, click again 
on its Hide/Show marker.

Menu bar
The Impress Menu bar, at the top of the main window, provides several menus common to all 
LibreOffice modules. The commands may differ between the modules for File, Edit, View, Insert,
Format, Tools, Window, and Help. Impress has two extra menus for Slide and Slide Show. 
When one of the menus is selected, a submenu drops down to show commands. The Menu bar 
can be customized and for more information, see the Getting Started Guide.
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Workspace
The Workspace (normally the center of the main window) opens in the Normal view. It has four 
standard views selected using tabs: Normal, Outline, Notes, and Slide Sorter (Figure  3). For 
more information on workspace views, see “Workspace views” page 13.

Figure 3: Workspace view tabs

If master slides are being used, then master views become available: Master Slide, Master 
Notes and Master Handout. There are no tabs for master views and are selected by going to 
View on the Menu bar. For more information on master slides, see Chapter 2, Using Slide 
Masters, Styles, and Templates.

Slide Pane
The Slide Pane contains thumbnail images of slides in a presentation in the order in which the 
slides will be shown. The slide show order can be changed and is described in Chapter 9, Slide 
Shows & Photo Albums. Clicking on a slide image in the Slide Pane selects it and places the 
slide in the Workspace where changes are made to the displayed slide.

• To display or close the Slide Pane, go to View > Slide Pane on the Menu bar.
• To close the Slide Pane, click on the X in the right top corner of the Slide Pane.
• To display or hide the Slide Pane, use the Hide/Show marker on the left of the 

Workspace (Figure 1 on page 5).

Note
The Slide Pane is labelled Slides in the Impress main window.

Several additional operations can be carried out on one or more slides in the Slide Pane. Also, 
these additional operations are available from a context menu when right clicking on a slide in the
Slide Pane.

• Add new slides to a presentation.
• Hide a slide so that it will not show in a presentation.
• Delete a slide from a presentation.
• Rename a slide.
• Duplicate a slide.
• Move a slide to another position in the slide order by dragging and dropping it to the 

desired position.

Also the following operations can be carried out, although there are more efficient methods than 
using the Slide Pane:

• Change the slide transition following the selected slide or after each slide in a group.
• Change the sequence of slides in the presentation.
• Change the slide design.
• Change slide layout for a group of slides simultaneously.
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Sidebar
The Impress Sidebar, normally located on the right side of the Workspace, is similar to the 
Sidebar in the other LibreOffice modules. It consists of eight decks, as described below. To open 
a deck, use one of the following methods:

• Click on its icon on the right side of the Sidebar.
• Click on Sidebar Settings at the top of the Sidebar and select a deck from the 

drop-down list.
• Go to View on the Menu bar and select the deck required from the submenu.

To display or hide the Sidebar, use one of the following methods:

• Go to View > Sidebar on the Menu bar.
• Use the keyboard shortcut Ctrl+F5.
• Use the Hide/Show marker on the right of the Workspace (Figure 1 on page 5).
• To close the Sidebar, click on the X in the right top corner of the Sidebar.
• To display the Sidebar, click on one of the Sidebar icons to open a deck.

Properties
The Properties deck has ten panels, allowing the slide layout to be changed and the formatting of
any objects on a slide.

• When a slide is selected and appears in the Workspace, the Properties deck opens with 
the Slide and Layouts panels available.

• When an object on a slide is selected, the Properties deck has the following panels 
available: Character, Lists, Paragraph, Area, Shadow, Line, Position and Size, Columns, 
Effect, and Image. Actual panels displayed depends on the type of object selected.

Styles
On the Styles deck, drawing and presentation styles can be applied to a selected object, new 
styles created for drawing and presentation, and both types of styles can be modified. When 
saving changes to a style, the changes are applied to all of the elements formatted with that style
in the presentation. For more information on styles, see Chapter 2, Using Slide Masters, Styles, 
and Templates.

Gallery
On the Gallery deck, an object can be inserted into a presentation either as a copy or as a link. A 
copy of an object is independent of the original object. Changes to the original object have no 
effect on the copy. A link remains dependent on the original object. Changes to the original object
are also reflected in the link.

Navigator
The Navigator deck displays all objects contained in a presentation. It provides a convenient way 
to move between slides in a presentation or select an object on a slide. It is recommended to 
give slides and objects in a presentation meaningful names so that they are easily identified 
when using the Navigator. For more information, see “Navigator” on page 11.

Shapes
The Shapes deck provides quick selection of most items that are available on the Drawing 
toolbar: Lines and Arrows, Curves and Polygons, Connectors, Basic Shapes, Symbol Shapes, 
Block Arrows, Flowchart, Callouts, Stars and Banners, and 3D Objects.
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Slide transition
The Slide Transition deck provides a selection of slide transitions available in Impress, also 
controls to adjust transition speed, automatic or manual transition, and how long a selected slide 
is shown (automatic transition only). For more information on transitions, see Chapter 9, Slide 
Shows & Photo Albums.

Animation
The Animation deck provides an easy way to add, change, or remove animations for different 
elements or objects on a slide and adjust how they appear during a slide show. For more 
information on transitions, see Chapter 9, Slide Shows & Photo Albums.

Master slides
Using the Master Slides deck, the slide design can be selected for a presentation. Impress 
includes several designs of master slides. The default master slide is blank, but the remaining 
master slides have backgrounds and styled text. For more information on master slides, see 
Chapter 2, Using Slide Masters, Styles, and Templates.

Rulers
Rulers are positioned on the upper and left-hand sides of the Workspace. If they are not visible, 
go to View > Rulers in the Menu bar. The rulers show the size of a selected object on the slide 
using double lines (highlighted in Figure 4). Rulers are also used to manage object handles and 
guide lines when positioning objects.

To change the measurement units of the rulers, right-click on a ruler and select the measurement
unit from the drop-down list, as shown in Figure 5 for the horizontal ruler. The horizontal and 
vertical rulers can be set to different measurement units.

The page margins in the drawing area are also represented on the rulers. The margins can be 
changed directly on the rulers by dragging them with the mouse. The margin area is indicated by 
either a grayed out area on the rulers or borders around the unused area of the ruler. This margin
indication depends on computer setup and operating system.

Figure 4: Rulers showing object size
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Figure 5: Changing ruler units

Figure 6: Status Bar

Note
The sizes are given in the current measurement unit and might not be the same as 
the ruler units. The measurement unit on the Status bar is defined in Tools > 
Options > LibreOffice Impress > General.

Status bar
The Status Bar (Figure 6), located at the bottom of the Impress main window, contains 
information that may be useful when working on a presentation. To hide the Status Bar, go to 
View on the Menu bar and deselect Status Bar.

Slide number
The slide number currently displayed in the Workspace and the total number of slides in the
presentation.

Information area
This changes depending on the object selected on the slide. Examples of the information 
displayed are shown in Table 1.

Table 1: Examples of information on Status Bar
Example selection Examples of information shown
Text area Text Edit: Paragraph x, Row y, Column z

Charts, spreadsheets Embedded object (OLE) “ObjectName” selected

Graphics Bitmap with transparency selected
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Master slide
The master slide associated with the slide or notes page currently displayed in the 
Workspace. Right-click to open a list of available master slides and select one to apply it to 
the selected slide. Double-click to open the Available Master Slides dialog. For more 
information, see Chapter 2, Using Slide Masters, Styles and Templates.

Cursor position/Object size
Shows different information depending on whether objects are selected or not.

– When no object is selected, the position numbers show the current position (X and Y 
coordinates) of the mouse cursor.

– When an object is selected and being resized with the mouse, the object size 
numbers show the size of the object (width and height).

– If an object is selected, the position numbers shows X and Y coordinates of the upper-
left corner and the object size number pair displays the size of the object. These 
numbers do not relate to the object itself, but to the selection outline, which is the 
smallest possible rectangle that can contain the visible part or parts of the object.

– When an object is selected, clicking in either of these areas opens the Position and 
Size dialog.

Unsaved changes
Indicates if there are any unsaved changes in the presentation. Clicking this icon saves the 
document. If the presentation has not been saved before, the Save As dialog opens giving 
the opportunity to save the presentation.

Digital signatures
Indicates if your presentation has a digital signature.

Text language
Indicates the language used for any text on a presentation.

Fit slide
When this icon is clicked on, the slide in the Workspace zooms to fit in the Workspace.

Zoom slider
When moved, the slide changes its viewing zoom in the Workspace.

Zoom percentage
Indicates the zoom level of the slide displayed in the Workspace. Clicking on zoom 
percentage opens the Zoom & View Layout dialog where the settings for zoom factor and 
view layout are adjusted.

Navigator
The Navigator displays all objects contained in a presentation. It provides another convenient 
way to move around a presentation and find items in it.

To open the Navigator dialog (Figure 7) go to View > Navigator on the Menu bar, or use the 
keyboard shortcut Ctrl+Shift+F5. Alternatively, click on Navigator in the Sidebar to open the 
Navigator deck that is similar in appearance and function as the Navigator dialog.

The Navigator is more useful if slides and objects (pictures, spreadsheets, and so on) are given 
meaningful names, instead of leaving them with default names, such as “Slide 1” and “Shape 1” 
and so on (as shown in Figure 7). This will allows for a slide or object to be easily located in a 
presentation.
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Figure 7: Navigator dialog

Toolbars
Many toolbars can be used during slide creation. To display or hide the various toolbars in 
Impress, go to View > Toolbars on the Menu bar and select the required toolbar from the drop 
down menu that appears. For example, the Standard and Drawing toolbars are displayed by 
default, but the Line and Filling, and Text Formatting toolbars are not shown.

To change the tools available on any toolbar, right-click in an empty area on the toolbar and 
select Visible Buttons from the context menu. The installed tools are indicated by a check mark 
next to the tool name, or the tool icon is highlighted, depending on the computer operating 
system. Click on a tool name to hide or show it in the toolbar. For more information, see Chapter 
11, Setting Up and Customizing Impress, Appendix B, Toolbars, and the Getting Started Guide.

The following toolbars are widely used when creating a presentation:

Standard
The Standard toolbar (Figure 8) is the same for all LibreOffice modules and is not 
described in detail in this user guide. By default, it is docked and located just under the 
Menu bar at the top of the Workspace.

Figure 8: Standard toolbar

Drawing toolbar
The Drawing toolbar (Figure 9) contains all the necessary functions for drawing various 
geometric and freehand shapes, and for organizing them in a slide. By default, it is docked 
and located on the left of the Workspace. More information on the Drawing toolbar can be 
found in Chapter 5, Managing Graphic Objects.
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Figure 9: Drawing toolbar

Line and Filling toolbar
The Line and Filling toolbar (Figure 10) provides the tools for modifying the properties of an
object, for example line color, line style, line width, fill color and style, and other properties 
of a selected object. If the selected object is a text frame, the Line and Filling toolbar is 
automatically replaced by the Text Formatting toolbar (Figure 11).

Figure 10: Line and Filling toolbar

Text Formatting toolbar
The Text Formatting toolbar (Figure 11) is similar to the Formatting toolbar in LibreOffice 
Writer and only appears when a text object has been selected in a presentation, 
automatically replacing the Line and Filling toolbar (Figure 10).

Figure 11: Text Formatting toolbar

Note
The appearance of the toolbar icons varies depending on the computer operating 
system, and the selection of icon size and style in Tools > Options > LibreOffice > 
View. For more information about working with toolbars, see Appendix B, Toolbars 
and the Getting Started Guide.

Workspace views
The Impress workspace has four standard views selected using tabs: Normal, Outline, Notes, 
and Slide Sorter. These tabs are normally displayed the top of the Workspace. If the tabs are 
not displayed, then go to View > Views Tab Bar on the Menu bar. Each of the workspace views 
is designed to ease the completion of certain tasks.

Master views only become available in the Workspace when Master Slide, Master Notes or 
Master Handout are selected. There are no tabs for master views and can only be selected by 
going to View on the Menu bar. For more information on master slides, see Chapter 2, Using 
Slide Masters, Styles, and Templates.
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Normal view
Normal view is the main standard view for creating individual slides in a presentation. In Normal 
view slides are designed, text or graphics added and formatted, and any animation effects added
to text or graphics.

To place a slide in Normal view of the Workspace, either click on the slide thumbnail in the Slide 
Pane or click on the slide name in the Navigator.

Figure 12: Example Outline view in Workspace

Figure 13: Outline toolbar

Outline view
Outline view in the Workspace (Figure 12) contains all of the slides of the presentation in a 
numbered sequence. It shows topic titles, bulleted lists, and numbered lists for each slide in 
outline format. Only the text contained in the default text boxes in each slide is shown. If text 
boxes or graphic objects have been added to the slides, then these objects are not displayed. 
Slide names are not included.

Outline view can be used for the following:

• Making changes in the text of a slide.
• Adding or deleting text in a slide as in Normal view.
• Moving a paragraph in a slide up or down by using the movement arrows on the Outline 

toolbar (Figure 13).
• Changing the outline level of a paragraph in a slide using the left and right arrow buttons 

on the Outline toolbar.
• Comparing slides with an outline, if an outline has been prepared in advance. If another 

slide is required, it can be created directly in Outline view, or Normal view.

Notes view
Use Notes view in the Workspace (Figure 14) to add notes to a slide. These notes are not seen 
when the presentation is shown to an audience using an external display connected to a 
computer.
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1) Click on Notes in the Workspace to open Notes view.
2) Click a slide in the Slide Pane so that the slide appears in the Workspace.
3) In the text box below the slide, click on the words Click to add notes and begin typing the 

required notes for the selected slide.

Figure 14: Example Notes view in Workspace

Figure 15: Example Slide Sorter view in Workspace

Figure 16: Slide View toolbar

The Click to add notes text box can be resized using the resizing handles which appear when the
edge of the notes box is selected. Move or change the size of the box by clicking and dragging 
on the box border.

When text is inserted in the Click to add notes text box, it is automatically formatted using the 
predefined Notes style in Presentation Styles in the Styles deck on the Sidebar. The Notes style
can be formatted to the presentation requirements. For more information, see Chapter 8, Adding 
and Formatting Slides, and Notes.
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Slide Sorter view
The Slide Sorter view in the Workspace (Figure 15) contains all the thumbnails of slides used in 
a presentation. Use this view to work with one slide or a group of slides.

Customizing Slide Sorter view
To change the number of slides per row in Slide Sorter view:

1) Go to View > Toolbars > Slide View on the Menu bar to show the Slide View toolbar 
(Figure 16)

2) Adjust the number of slides, up to a maximum of 15, in the Slides per Row box.

Changing slide order
To change the slide order in a presentation of a single slide or a group of slides using Slide 
Sorter view is as follows:

1) Select a slide or a group of slides.
2) Drag and drop the slide or group of slides at the new position in the presentation.

Selecting a group of slides
To select a group of slides in Slide Sorter view, use one of the following methods:

• Ctrl key – click on the first slide and, while holding the Ctrl key, select the required slides. 
The selected slides do not have to be next to each other.

• Shift key – click on the first slide, and while pressing the Shift key, select the final slide for 
the group. This selects all of the slides between the first and the last slide selected.

• Mouse – position the cursor slightly to one side and outside the first slide, then click and 
hold the left mouse button and drag the cursor until all of the slides required for the group
are selected.

Working in Slide Sorter view
Working with slides in Slide Sorter view is similar to working with slides in the Slide Pane. To 
make changes, right-click on a slide in Slide Sorter view and choose one of the following from 
the context menu:

• Cut – removes the selected slide and saves it to the clipboard.
• Copy – copies the selected slide to the clipboard without removing it.
• Paste – inserts a slide from the clipboard after the selected slide.
• New Slide – adds a new slide after the selected slide.
• Duplicate Slide – creates a duplicate of the selected slide and places the new slide 

immediately after the selected slide.
• Rename Slide – renames the selected slide.
• Hide Slide – any slides that are hidden are not shown in the presentation.
• Delete Slide – deletes the selected slide.
• Layout – allows changes to the layout of the selected slide.
• Move – allows moving or repositioning of the slide in the presentation order.
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Creating presentations
By default, Impress opens with the Select a Template dialog displayed (Figure 2 on page 6) 
where a template can be selected to use in a presentation. To create a new presentation without 
using a template, click on Cancel in the Select a Template dialog and a blank slide appears in 
the Workspace and Slide Pane.

Tip
The first thing to do is decide on the purpose of a presentation and plan accordingly. 
Having an idea of who the audience will be, the structure, the content, and how the 
presentation will be delivered, will save a lot of time from the start.

Figure 17: Options LibreOffice Impress General dialog

To prevent the Select a Template dialog from opening when creating a new presentation, go to 
Tools > Options > LibreOffice Impress > General on the Menu bar to open Options LibreOffice
Impress General dialog (Figure 17) and deselect the option Start with New Template Selection.

For more information on creating presentations, slide show options, and presentation settings, 
see Chapter 9, Slide Shows & Photo Albums and Chapter 11, Setting Up and Customizing 
Impress.

New presentation
When creating a new presentation, Impress shows only one slide in the Slide Pane and 
Workspace. New or duplicate slides can be added to a presentation as follows.

Inserting new slide
A new slide is inserted into a presentation using one of the following methods.

• Go to Slide >  New Slide on the Menu bar.
• Right-click in the Slide Pane and select New Slide from the context menu.
• Use the keyboard shortcut Ctrl+M.
• Go to Slide Sorter view in the Workspace, right-click on a slide and select New Slide 

from the context menu.
• Click on New Slide in the Presentation toolbar (Figure 18). If the Presentation toolbar is 

not visible, go to View > Toolbars on the Menu bar and select Presentation from the 
drop-down list.
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Figure 18: 
Presentation toolbar

Note
A new slide is inserted after the selected slide in the presentation. If a slide is not 
selected, then the new slide is inserted as the last slide in the presentation.

Duplicate slide
To duplicate a slide, select the slide for duplication in the Slide Pane and use one of the following 
methods. A duplicate slide is inserted after the selected slide in the presentation.

• Right-click on a slide in the Slide Pane and select Duplicate Slide from the context 
menu.

• Go to Slide Sorter view in the Workspace, right-click on a slide and select Duplicate 
Slide from the context menu.

• Go to Slide >  Duplicate Slide on the Menu bar.
• Click on Duplicate Slide in the Presentation toolbar (Figure 18).

Slide format
Click on Properties on the Sidebar and open the Page panel (Figure 19) to display the format 
options available for a presentation. The Page panel allows for quick formatting of all slides 
included in a presentation and selecting master slides for a presentation. For more information on
formatting slides and using master slides, see Chapter 2, Using Slide Masters, Styles, and 
Templates and Chapter 8, Adding and Formatting Slides and Notes.

Slide layout
By default in Impress, the Title Slide layout is used for the first slide when a new presentation is 
created. The layouts included in Impress range from a blank slide to a slide with six contents 
boxes and a title. For more information on slide layouts, see Chapter 8, Adding and Formatting 
Slides, and Notes.

The first slide in a presentation is normally a title slide. The layouts Title Slide, which also 
contains a section for a subtitle, or Title Only are the most suitable layouts for the first slide in a 
presentation. For the remaining slides, the Title, Contents layout is used.

Impress does not have the functionality to create custom layouts. However, the different 
elements in a slide layout can be resized and moved. For more information, see “Modifying slide 
elements” on page 20.

Tip
To view the names for slide layouts, use the tooltip feature. Position the cursor on an 
icon in the Layout panel (or on any other tool icon) in the Properties deck on the 
Sidebar and its name is displayed in a small rectangle.
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Figure 19: Page and Layouts panels in Properties 
deck on Sidebar

Changing slide layout
After selecting a slide in a presentation, change the slide layout using one of the following 
methods:

• Click on the required layout in Layouts panel of the Properties deck in the Sidebar 
(Figure 19).

• Go to Slide > Layout on the Menu bar and select the required layout from the drop-down
list.

• Right-click on a slide in the Slide Pane, select Layout from the context menu and select 
the required layout from the drop-down list.

• Click on Slide Layout on the Presentation toolbar (Figure 18 on page 18) ands select a 
layout from the options available.

Slide contents
Several layouts contain one or more content boxes. Each of these boxes can be configured to 
contain one of the following elements: slide title, text, table, chart, image or audio/video.
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• Slide title – click on Click to add Title and type a title in the text box. Impress enters text 
editing mode and the Text Formatting toolbar automatically opens. For more information 
on formatting text, see Chapter 3, Adding and Formatting Text.

• Text – click on Click to add Text and type the contents into the text box. Impress enters 
text editing mode and the Text Formatting toolbar automatically opens. For more 
information on formatting text, see Chapter 3, Adding and Formatting Text.

• Table – go to Insert > Table on the Menu bar and the Insert Table dialog opens. Enter 
the number of columns and rows, then click OK. The dialog closes and a table is inserted
into the slide. Impress enters text editing mode and the Text Formatting toolbar 
automatically opens. For more information on using tables, see Chapter 3, Adding and 
Formatting Text.

• Chart – go to Insert > Chart on the Menu bar and the Impress default chart is placed in 
the slide. The Chart Type panel opens in the Properties deck on the Sidebar allowing 
editing of the chart to the presentation requirements. For more information on using 
charts, see Chapter 7, OLE, Spreadsheets, Charts, and Other Objects.

• Image – go to Insert > Image on the Menu bar and a file browser opens. Navigate to 
where the required image is located. Select the file and click on Open. The image is 
placed into the slide and the file browser closes. The Image panel opens in the 
Properties deck on the Sidebar allowing editing of the image file. For more information on
using images, see Chapter 4, Adding and Formatting Images, and Chapter 7, OLE, 
Spreadsheets, Charts, and Other Objects.

• Audio or video – go to Insert > Audio or Video on the Menu bar and a file browser 
opens. Navigate to where the required audio or video file is located. Select the file and 
click on Open. The audio or video file is placed into the slide and the file browser closes. 
The Media Playback toolbar opens allowing operation of the audio or video file. For more
information on using audio and video, see Chapter 7, OLE, Spreadsheets, Charts, and 
Other Objects.

Modifying slide elements
When a slide is inserted into a presentation, it contains elements that were included in the 
selected slide layout. However, it is unlikely that the predefined layouts will suit all requirements 
for a presentation. Elements required maybe removed or objects inserted such as text and/or 
graphics.

Although Impress does not have the functionality to create new layouts, it allows for the resizing 
and moving of the slide elements. It is also possible to add slide elements without being limited to
the size and position of content boxes.

Note
It is recommended that changes to slide elements in the layouts included in Impress 
are only made using normal view, which is the default. Attempting any changes to a 
slide element when in master view is possible, but may result in unpredictable results
and requires extra care as well as a certain amount of trial and error.

Moving contents box
1) Click on the outer frame so that the selection handles are displayed.
2) Place the cursor on the frame so that the cursor changes shape. This is normally a 

clenched hand, but depends on the computer setup.
3) Click and drag the contents box to its new position on the slide, then release the mouse 

button.
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Resizing contents box
1) Click on the outer frame so that the selection handles are displayed.
2) Place the cursor on a selection handle the frame so that the cursor changes shape.
3) Click and drag the selection handle on the frame to resize the contents box, then release 

the mouse button.
– Top and bottom selection handles change the height of a contents box.
– Left and right selection handles change the width of a contents box.
– Corner selection handles change width and height of a contents box.

Removing elements
1) Click a contents box or an element to highlight it and the selection handles are displayed.
2) Press the Delete or Backspace key to remove the contents box or element.

Adding text
There are two ways of adding text to a slide – contents box or text box. For more information on 
text, see Chapter 3, Adding and Formatting Text.

• Contents box – click Click to add Text in the contents box and type the text. Outline 
styles are automatically applied to the text as it is inserted. If required, change the outline
level of each paragraph as well as its position within the contents box by using the arrow 
buttons on the Outline toolbar and Workspace Outline view.

• Text box – click on Insert Text Box on the Standard toolbar or Drawing toolbar to select 
text mode, then click on the slide. A text box is created and the Text Formatting toolbar 
automatically opens. Type the text and click outside the text box to end text mode.

Adding images or objects
To add images or objects to a slide, for example a picture, clipart, drawing, photograph, or 
spreadsheet, click on Insert on the Menu bar and select from the submenu the image or object 
type required. For more information on adding objects, see the following chapters:

• Chapter 4, Adding and Formatting Images
• Chapter 5, Managing Graphic Objects
• Chapter 6, Formatting Graphic Objects
• Chapter 7, OLE, Spreadsheets, Charts, and Other Objects

Modifying slide appearance
To change the background and other characteristics of all slides in the presentation, the master 
slide has to be modified or a different master slide selected. A master slide is a slide with a 
specified set of characteristics that acts as a template and is used as the starting point for 
creating other slides. These characteristics include the background, objects in the background, 
formatting of any text used, and any background graphics.

Impress has included a range of master slides, found in the Master Slide panel on the Properties 
deck in the Sidebar. Additional master slides can be created or and saved, or added from other 
sources. See Chapter 2, Using Slide Masters, Styles, and Templates for information on creating 
and modifying master slides.

For example, to change the background of an individual slide or a master slide: 

1) Right click on a slide or master slide and select Properties from the context menu to 
open the Slide Setup dialog (Figure 20).
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2) Select Background and then select the type of background to use from None, Color, 
Gradient, Bitmap, Pattern and Hatch.

3) Make a selection from the various properties that are available for each type of 
background.

4) Click OK to apply save the changes and close the dialog.

Note
Inserting and correctly formatting background is beyond the scope of this chapter. 
For more information, see Chapter 6, Formatting Graphic Objects.

Figure 20: Slide Properties dialog - Background page

Modifying presentations
By default, a presentation displays all the slides in the same order as they appear in Slide Sorter
view on the Workspace. It is recommended to review the entire presentation and answer some 
questions. Run the presentation at least once (see “Running a presentation” on page 23), then 
answer the following questions. Also there maybe more questions after running a presentation for
the first time.

• Are the slides in the correct order? If not, some of the slides have to be moved.
• Is the information well spaced and visible to members of an audience at the back of a 

large room? The audience may not be able to see information at the bottom of a slide, so
redesign the presentation to fit the top three-quarters of a screen.

• Would an additional slide make a particular point clearer? If so, create another slide.
• Are some of the slides unnecessary? Hide or delete the slides not required.
• Would animations help some of the slides? This is considered an advanced technique.
• Should some of the slides have a different slide transition than others? The transition of 

those slides should be changed.
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Once the questions have been answered, make the necessary changes. Making changes can be
carried out in Slide Sorter view on the Workspace.

Tip
If one or more slides seem to be unnecessary, hide the slide or slides, and view the 
slide show a few more times to make sure they are not required. To hide a slide, 
right-click the slide in the Slide Pane and select Hide Slide from the context menu. 
Do not delete a slide until this is done or the slide may have to be created again.

Slide order
Change the slide order in a presentation using one of the following methods:

• In Slide Sorter view, click on the slide that has to be moved and drag it to its new 
position in the presentation.

• In the Slide Pane, click on the slide that has to be moved and drag it to its new position in
the presentation.

Animations
If animations are going to be added to slides in a presentation, click on Animation on the 
Sidebar to open the Animation deck giving access to the various animation options as follows:

• Animation category.
• Animation effect.
• How the animation starts.
• Animation direction, duration and delay.
• Automatic preview.

Animation is an advanced technique and is beyond the scope of this chapter. For more 
information on animation, see Chapter 9, Slide Shows & Photo Albums.

Slide transitions
To give a presentation a professional look, it is recommended to add transitions between each 
slide in a presentation. Click on Slide Transition on the Sidebar to open the Slide Transition 
deck giving access to the various transition options as follows:

• Transition type.
• Modify the transition.
• How the slide advances in the presentation.
• Automatic preview

Adding slide transitions is an advanced technique and is beyond the scope of this chapter. For 
more information on slide transitions, see Chapter 9, Slide Shows & Photo Albums.

Running a presentation
When a presentation is completed, it is recommended to test run the presentation and make sure
that everything is correct. For more information and details about running a presentation, see 
Chapter 9, Slide Shows & Photo Albums.

1) To run a slide show after completing your presentation, use one of the following methods:
– Go to Slide Show on the Menu bar and select Start from First Slide from the 

submenu or use the keyboard shortcut F5. The Presenter Console (Figure 21) 
automatically opens.
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– Go to Slide Show on the Menu bar and select Start from Current Slide from the 
submenu or use the keyboard shortcut Shift + F5. The Presenter Console 
automatically opens.

Figure 21: Impress Presenter Console

2) If the option Automatically after X seconds has been selected, the slide show 
automatically starts after the selected time has elapsed.

3) If the option On mouse click has been selected, use one of the following methods to 
move to the next slide.
– Click the mouse button to advance to the next slide.
– Use the arrow keys on the keyboard to go to the next slide or back to the previous 

one.
– Press the Spacebar on the keyboard to advance to the next slide.
– Click on the arrows displayed at the bottom of the Presenter Console to move to the 

next slide or back to the previous one.
4) When the slide show has ended or to exit the slide show before it has finished, press the 

Esc key to close the Presenter Console and return to the presentation in Impress.

Presenter Console
The Presenter Console in LibreOffice Impress is also used when an extra display for presentation
has been connected a computer providing extra control over slide shows:

• On an external display the audience sees the current slide in the presentation.
• On a computer display, the current slide, the next slide in the presentation, any slide 

notes, and a presentation timer are displayed.
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For more information and details about using the Presenter Console, see Chapter 9 Slide Shows 
& Photo Albums.
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