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What is Draw?

LibreOffice Draw is a vector graphics drawing program, although it can also perform some 
operations on raster graphics (pixels). Using Draw, you can easily and quickly create a wide 
variety of graphical images.

Vector graphics store and display an image as an assembly of simple geometric elements such 
as lines, circles, and polygons, rather than a collection of pixels (points on the screen). Vector 
graphics allow for easier storage and scaling of the image.

Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with all 
components of the suite. If an image is created in Draw, reusing it in a Writer document is 
relatively easy. For example, select and copy the drawing in Draw and then paste the image 
directly into a Writer document. Also, drawings can be worked on directly from within Writer or 
Impress, using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive. Draw was not designed to rival high-end 
graphics applications, but it possesses more functionality than the drawing tools that are 
generally integrated with the majority of office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, 
dimensions and measurement display, connectors for making organization charts, 3D functions 
that enable small three-dimensional drawings to be created (with texture and lighting effects), 
drawing and page-style integration, and Bézier curves.

This chapter introduces some features of Draw, but it does not attempt to cover all of the Draw 
features. See the Draw Guide and LibreOffice Help for more information.

Draw main window

Workspace
The large area in the center of the Draw main window (Figure 1) is the Workspace, where 
drawings are created. This drawing area can be surrounded with toolbars and information areas. 
The number and position of the visible tools vary with the task in hand, user preferences, and 
computer setup.

The maximum size of a drawing page in LibreOffice Draw is limited by the computer setup and 
the page size that that can be set and used in the printer connected to the computer.

Pages pane
Drawings in Draw can be split over several pages. Multi-page drawings are used mainly for 
presentations. The Pages pane, on the left side of the Draw main window, gives an overview of 
the pages that are created in a drawing. If the Pages pane is not visible, go to View > Page Pane
on the Menu bar. To make changes to the page order, drag and drop one or more pages.

Layers bar
A layer is a workplace where you can insert drawing elements and objects. By default, the 
Workspace consists of three layers (Layout, Controls, and Dimension Lines). The default 
layers cannot be deleted or renamed, but you can add layers when necessary.

Tabs for default and other layers appear in the Layers bar at the bottom of the Workspace. You 
can use the Layers bar for navigation between layers, adding layers as required, or deleting 
layers that have been created. For more information on layers, see “Working with layers” on 
page 35.
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Figure 1: Draw main window

Sidebar
The Sidebar has five main decks in Draw and is similar to the Sidebar in the other LibreOffice 
modules. To open a deck, click on its icon on the right of the Sidebar, or click on the Sidebar 
Settings icon at the top of the tab bar and select a deck from the drop-down list. If the Sidebar is 
not visible, go to View > Sidebar on the Menu bar.

Properties
Contains panels for object properties, for example Page, Character, Paragraph, Area, 
Effect, Shadow, Image, Line, and Position and Size. Available panels depend on the object 
selected.

Shapes
Provides quick selection of most items that are available on the Drawing toolbar: Lines and 
Arrows, Curves and Polygons, Connectors, Basic Shapes, Symbol Shapes, Block Arrows, 
Flowchart, Callouts, Stars and Banners, and 3D Objects.

Styles
Provides options to edit and apply Drawing Styles to objects within a drawing. When a style
is edited or modified, the changes are automatically applied to all of the elements formatted
using that style. In Draw, Presentation Styles are not available.

Gallery
From the Gallery deck, objects can be inserted into a drawing either as a copy or as a link. 
The Gallery is divided into categories: Arrows, BPMN (Business Process Model and 
Notation), Bullets, Diagrams, Flowchart, Icons, Network, Shapes, and Sounds. See the 
Draw Guide for more information on creating links to objects and files.
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Navigator
On the Navigator deck, you can quickly select pages and objects in a drawing. It is 
recommended to give pages and objects in a drawing meaningful names so that they are 
easily identified when using the Navigator.

Rulers
Rulers are positioned on the upper and left-hand sides of the Workspace. If they are not visible, 
go to View > Rulers on the Menu bar. The rulers show the size of a selected object on the page 
using double lines (highlighted in Figure 2). You can also use the rulers to manage object 
handles and guide lines when positioning objects.

The page margins in the drawing area are also represented on the rulers. You can change the 
margins directly on the rulers by dragging them with the cursor. The margin areas are indicated 
by the grayed out area on the rulers as shown in Figure 2.

To change the measurement units of the rulers, right-click on a ruler and select the measurement
unit from the drop-down list, as shown in Figure 3 for the horizontal ruler. The horizontal and 
vertical rulers can be set to different measurement units.

Figure 2: Rulers showing object size

Figure 3: Ruler measurement units
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Status bar
The Status bar (Figure 4) is located at the bottom of the Workspace in all LibreOffice modules. It 
includes several Draw-specific fields, which are described where relevant in this chapter. For 
details on the contents and use of these fields, see Chapter 1, Introducing LibreOffice, in this 
guide and the Draw Guide. To hide the Status Bar, go to View on the Menu bar and deselect 
Status Bar.

Figure 4: Status bar

Note

The measurement units shown on the Status Bar are set by going to Tools > 
Options > LibreOffice Draw > General on the Menu bar. These units may be 
different to the measurement units set for the rulers.

Toolbars
To display or hide the various Draw toolbars, go to View > Toolbars on the Menu bar and select 
from the drop-down menu. For more information on toolbars, see the Draw Guide.

The icons used for the tools on each toolbar depend on the computer operating system and how 
LibreOffice has been setup on a computer. For more information on how to setup LibreOffice, see
Chapter 2, Setting Up LibreOffice.

The three main toolbars used in Draw are:

• Standard – this toolbar is the same for all LibreOffice components. By default it is docked
at the top of the Workspace when a Draw document Is opened (Figure 5).

Figure 5: Standard toolbar

• Drawing – this toolbar contains all the necessary functions for drawing various geometric
and freehand shapes, and for organizing them in the drawing. By default, it is locked into 
position on the left of the Workspace (Figure 6).

Figure 6: Drawing toolbar

• Line and Filling – this toolbar is normally docked at the top of the Workspace below the 
Standard toolbar. The tools and pull-down lists on this toolbar vary according to the type 
of object selected. The Line and Filling toolbar (Figure 7) only becomes active when an 
object on the Workspace is selected.
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Figure 7: Line and Filling toolbar

Drawing basic shapes

Draw provides a wide range of shapes, located in palettes accessed from the Drawing toolbar or 
from the Shapes deck on the Sidebar (Figure 8). This section describes only a few of the basic 
shapes, including text, which are treated as objects in Draw. See the Draw Guide for a complete 
description of the basic shapes available.

Some of the tool icons on the Drawing toolbar change according to the shape that has been 
selected. Some tools on a toolbar have extra tool palettes available and these are indicated by a 
small downward triangle ▼ to the right of the tool icon.

Note

When you draw a basic shape or select one for editing, the Information field in the 
Status bar changes to reflect the present action. For example Line created, Text 
frame xxyy selected, and so on.

Figure 8: Shapes deck on Sidebar
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Straight lines
1) Use one of the following methods to start drawing a line:

– Click on Insert Line on the Drawing toolbar.

– Click the small downward triangle ▼ on the right of the Lines and Arrows tool on the 
Drawing toolbar and select Insert Line from the drop down list.

– Click on Insert Line in the Lines and Arrows section of the Shapes deck on the 
Sidebar (Figure 8).

2) Place the cursor at the starting point on the drawing, then click and drag the cursor to 
draw a straight line.

3) Release the mouse button when the end point is reached and a straight line is created. A 
selection handle appears at each end of the line, showing that this object is the currently 
selected object. The selection handle at the starting point of the line is slightly larger than 
the other selection handle as shown in Figure 9.

Figure 9: Line starting point

Tip

To snap the end of a line to the nearest grid point, keep the Ctrl key pressed while 
drawing the line. However, if the Snap to Grid option in View > Snap Guides on the
Menu bar has been selected, the Ctrl key deactivates the snap to grid.

To restrict the drawing angle of a line to a multiple of 45 degrees (0, 45, 90, 135, and 
so on), keep the Shift key pressed while drawing the line. However, if the option 
When creating or moving objects in the Constrain Objects section of Tools > 
Options > LibreOffice Draw > Grid has been selected, the Shift key deactivates 
this restriction.

To draw a line symmetrically outwards in both directions from the start point, keep 
the Alt key pressed while drawing the line. This draws lines by starting from the 
center of the line.

When a line is drawn, it uses default attributes. To change any of these attributes and format a 
line to the drawing requirements, select a line by clicking on it and use one of the following 
methods to access formatting options for the line:

• Go to the Properties deck on the Sidebar and open the Line panel (Figure 10).

• Right-click on a line and select Line in the context menu to open the Line dialog 
(Figure 11).

• Go to Format > Line on the Menu bar to open the Line dialog.

• Use the tools Line Style, Line Width, and Line Color on the Line and Filling toolbar.
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Figure 10: Line panel in Properties deck on Sidebar

Figure 11: Line dialog - Line page
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Arrows
Draw classifies both lines and arrows as lines and are drawn like straight lines. Hovering the 
cursor over each tool in the Lines and Arrows sub-toolbar (Figure 12) indicates what type of line 
or arrow each tool will draw. The information field on the Status Bar shows them only as lines.

Figure 12: Lines and Arrows sub-toolbar

1) Use one of the following methods to start drawing an arrow:

– Click the small downward triangle ▼ on the right of the Lines and Arrows tool on the 
Drawing toolbar and select the type of arrow required from the Lines and Arrows 
sub-toolbar (Figure 12) that opens.

– Click on the type of arrow required in the Lines and Arrows section of the Shapes 
deck on the Sidebar.

2) Place the cursor at the starting point of the arrow, then click and drag the cursor. The 
arrowhead is drawn at the end point of the arrow when the mouse button is released.

Tip

To snap the end of an arrow to the nearest grid point, keep the Ctrl key pressed while
drawing the arrow. However, if the Snap to Grid option in View > Snap Guides on 
the Menu bar has been selected, the Ctrl key deactivates the snap to grid.

To restrict the drawing angle of an arrow to a multiple of 45 degrees (0, 45, 90, 135, 
and so on), keep the Shift key pressed while drawing the arrow. However, if the 
option When creating or moving objects in the Constrain Objects section of Tools 
> Options > LibreOffice Draw > Grid has been selected, the Shift key deactivates 
this restriction.

To draw an arrow symmetrically outwards in both directions from the start point, keep
the Alt key pressed while drawing the arrow. This draws arrows by starting from the 
center of the line.

Note

Hovering the cursor over each type of line or arrow available indicates the type of 
line or arrow each tool draws.

Note

The tool icon for the Lines and Arrows tool used most recently will already be 
selected on the Drawing toolbar. This makes it easier to use the same tool again.
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Note

After drawing a line or arrow, the line or arrow style can be changed by opening the 
Line dialog and using the options available on the Line Styles or Arrow Styles pages.

Rectangles
1) Use one of the following methods to start drawing a rectangle:

– Click on Rectangle on the Drawing toolbar.

– Click the small downward triangle ▼ on the right of the Basic Shapes tool on the 
Drawing toolbar and select Rectangle from the Basic Shapes sub-toolbar (Figure 13).

– Click on Rectangle in the Basic Shapes section of the Shapes deck on the Sidebar.

– Select the type of rectangle from the Legacy Rectangles toolbar (Figure 14). To 
display the toolbar, go to View > Toolbars on the Menu bar and select it.

2) Place the cursor at the starting point for the rectangle, then click and drag the cursor until 
the required size is drawn. As the rectangle is drawn, the rectangle appears with its 
bottom right corner attached to the cursor.

3) To draw a rectangle from its center, position the cursor on the drawing, press the mouse 
button and then hold down the Alt key while dragging the cursor. The rectangle uses the 
start point as the center of the rectangle.

Figure 13: Basic Shapes sub-toolbar

Figure 14: Legacy Rectangles toolbar
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Squares
1) Use one of the following methods to start drawing a square:

– Click on Rectangle on the Drawing toolbar, then hold down the Shift key while 
dragging the cursor to draw a square.

– Click the small downward triangle ▼ on the right of the Basic Shapes tool on the 
Drawing toolbar and select Square from the Basic Shapes sub-toolbar (Figure 13).

– Click on Square in the Basic Shapes section of the Shapes deck on the Sidebar.

– Select the type of square from the Legacy Rectangles toolbar (Figure 14). To display 
the toolbar, go to View > Toolbars on the Menu bar and select it.

2) Place the cursor at the starting point for the square, then click and drag the cursor until 
the required size is drawn. As the square is drawn, the square appears with its bottom 
right corner attached to the cursor.

3) To draw a square from its center, position the cursor on the drawing, press the mouse 
button and then hold down the Alt key while dragging the cursor. The square uses the 
start point as the center of the square.

Ellipses (ovals)
1) Use one of the following methods to start drawing an ellipse:

– Click on Ellipse on the Drawing toolbar.

– Click the small downward triangle ▼ on the right of the Basic Shapes tool on the 
Drawing toolbar and select Ellipse from the Basic Shapes sub-toolbar (Figure 13).

– Click on Ellipse in the Basic Shapes section of the Shapes deck on the Sidebar.

– Select the type of ellipse from the Legacy Circles and Ovals toolbar (Figure 15). To 
display the toolbar, go to View > Toolbars on the Menu bar and select it.

2) Place the cursor at the starting point for the ellipse, then click and drag the cursor until 
the required size is drawn. As the ellipse is drawn, the ellipse appears with its bottom 
right corner attached to the cursor.

3) To draw an ellipse from its center, position the cursor on the drawing, press the mouse 
button and then hold down the Alt key while dragging with the cursor. The ellipse uses the
start point as the center of the ellipse.

Figure 15: Legacy Circles and Ovals toolbar
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Circles
1) Use one of the following methods to start drawing a circle:

– Click on Ellipse on the Drawing toolbar, then hold down the Shift key while dragging 
the cursor to draw a circle.

– Click the small downward triangle ▼ on the right of the Basic Shapes tool on the 
Drawing toolbar and select Circle from the Basic Shapes sub-toolbar (Figure 13).

– Click on Circle in the Basic Shapes section of the Shapes deck on the Sidebar.

– Select the type of circle from the Legacy Circles and Ovals toolbar. To display the 
toolbar, go to View > Toolbars on the Menu bar and select it.

2) Place the cursor at the starting point for the circle, then click and drag the cursor until the 
required size is drawn. As the circle is drawn, the circle appears with its bottom right 
corner attached to the cursor.

3) To draw a circle from its center, position the cursor on the drawing, press the mouse 
button and then hold down the Alt key while dragging with the cursor. The circle uses the 
start point as the center of the circle.

Tip

To quickly insert a line, rectangle, ellipse, or circle, press and hold down the Ctrl key 
and then click on one of the icons for Line, Rectangle, Ellipse, or Circle and a 
standard sized object is drawn automatically in the work area. The size, shape, and 
color are all standard values. These attributes can be changed later, if desired. For 
more information, see the Draw Guide.

Dimension lines
Dimension lines display a measurement of an object in the drawing (Figure 16). The dimension 
line does not belong to the object itself, but it is normally placed close to it.

1) Use one of the following methods to start drawing a dimension line:

– Click the small downward triangle ▼ on the right of the Lines and Arrows tool on the 
Drawing toolbar and select Dimension Line from the Lines and Arrows sub-toolbar 
that opens.

– Click on Dimension Line in the Lines and Arrows section of the Shapes deck on the 
Sidebar.

2) Place the cursor at the point close to the object to position the start of the dimension line.

3) Click and drag the cursor to draw the dimension line. As the dimension line is drawn, the 
dimension is displayed and automatically calculated.

4) To change the measurement unit used for dimension lines, go to Tools > Options > 
LibreOffice Draw > General on the Menu bar.

5) To change the display of a dimension line and its appearance, right-click on the 
dimension line and select Dimensions in the context menu to open the Dimension Line 
dialog (Figure 17).

6) Select the required options in Line and Legend, then click OK to save the changes and 
close the Line Dimension dialog.
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Figure 16: Example of dimension lines on an object

Figure 17: Dimension Line dialog
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Figure 18: Curves and Polygons sub-toolbar

Curves
1) Use one of the following methods to start drawing a curve:

– Click the small downward triangle ▼ on the right of the Curves and Polygons tool on
the Drawing toolbar and select the type of curve from the Curves and Polygons 
sub-toolbar (Figure 18).

– Click on the type of curve required in the Curves and Polygons section of the Shapes 
deck on the Sidebar.

2) Click and hold the left mouse button to create the starting point of the curve, then drag 
from the starting point to draw a line. Release the mouse button and continue to drag the 
cursor to bend the line into a curve.

3) Double-click to set the end point of the curve and fix the curve on the drawing. A filled 
curve automatically joins the last point to the first point, closing the curve and filling it with 
the selected fill color. A curve without fill will not be closed at the end of drawing the curve.

Note

A single click fixes the curve to the drawing and allows drawing of straight lines from 
the end of the curve. Each single click allows the drawing of straight lines to 
continue. Double-click to end drawing a curve with straight lines.

Polygons
1) Use one of the following methods to start drawing a polygon:

– Click the small downward triangle ▼ on the right of the Curves and Polygons tool on
the Drawing toolbar and select the type of polygon from the Curves and Polygons 
sub-toolbar (Figure 18).

– Click on the type of polygon required in the Curves and Polygons section of the 
Shapes deck on the Sidebar.

2) Click and hold the left mouse button to create the starting point of the polygon, then drag 
from the starting point to draw a line.

3) Release the mouse button and continue to drag the cursor to draw the next line for 
polygon, then click to mark the end point of the line and to start drawing another line. 
Holding the Shift key down while drawing lines, restricts the angles used in the polygon to
45° or 90°.

4) Double-click to set the end point of the polygon and fix the polygon on the drawing. A 
filled polygon automatically joins the last point to the first point, closing the polygon and 
filling it with the selected fill color. A polygon without fill will not be closed at the end of 
drawing the polygon.
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Polygons 45°
A polygon 45° is drawn using the same procedure as polygons, but the angles between lines are 
restricted to 45° or 90°. This restriction of angles cannot be changed. However, and if required, 
hold down the Shift key as the line is drawn so that the line is drawn at an angle other than 45 or 
90 degrees.

A filled polygon 45° automatically joins the last point to the first point, closing the polygon and 
filling it with the selected fill color.

Freeform lines
Drawing a freeform line is similar to drawing with a pencil on paper.

1) Use one of the following methods to start drawing a freeform line:

– Click the small downward triangle ▼ on the right of the Curves and Polygons tool on
the Drawing toolbar and select the type of freeform line from the Curves and Polygons
sub-toolbar (Figure 18).

– Click on the type of freeform line required in the Curves and Polygons section of the 
Shapes deck on the Sidebar.

2) Click and drag the cursor to create the freeform line shape required.

3) Release the mouse button when satisfied with the freeform line and the drawing is 
completed. A filled freeform line automatically joins the last point to the first point, closing 
the freeform line and filling it with the selected fill color.

Glue points and connectors

Glue points
All Draw objects have glue points, which are not normally displayed. Glue points (Figure 19) 
become visible on an object when a connector is selected on the Drawing toolbar or in the 
Shapes deck on the Sidebar.

Most objects have four glue points (Figure 19). More glue points can be added and customized 
using the Glue Points toolbar (Figure 20). If the Glue Points toolbar is not visible, go to View > 
Toolbars > Glue Points on the Menu bar to open the toolbar. For a more detailed description on 
adding and using glue points, see the Draw Guide.

Glue points are not the same as the selection handles of an object. Selection handles are for 
moving or changing the shape of an object. Glue points are used to fix or glue a connector to an 
object so that when the object moves, the connector stays fixed to the object.

Figure 19: Example of object glue points
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Figure 20: Glue Points toolbar

Connectors
Connectors are lines or arrows whose ends automatically snap to a glue point of an object. 
Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps. 
When objects are moved or reordered, the connectors remain attached to a glue point. Figure 21 
shows an example of using two objects and a connector. For a more detailed description of the 
use of connectors, see the Draw Guide.

Figure 21: Example of a connector between two objects

Use one of the following methods to access connectors:

• Click the small downward triangle ▼ on the right of the Connectors tool on the Drawing 
toolbar and select the type of connector from the Connector sub-toolbar (Figure 22).

• Click on the type of connector required in the Connectors section of the Shapes deck on 
the Sidebar.

Figure 22: Connectors sub-toolbar
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Geometric shapes

Geometric shapes are similar to basic shapes. They are provided in Draw as a starting point 
when creating objects for a drawing. Geometric shapes are located on the Drawing toolbar and in
the Shapes deck on the Sidebar.

The tool icons on the Drawing toolbar, used for drawing geometric shapes, always indicate the 
last geometric shape drawn and may not be the same as the tool icons shown on the Drawing 
toolbar in this chapter. This makes it easier to use the same tool again.

Access geometric shapes using one of the following methods:

• Click on Shapes on the Sidebar to open the Shapes deck, then choose from the 
geometric shapes available.

• Click the small downward triangle ▼ on the right of a geometric shape on the Drawing 
toolbar to open a drop-down or sub-toolbar giving access to more geometric shape tools.
See below for the tools available.

Using geometric shapes is similar to drawing rectangles, squares, ellipses, or circles as 
explained in “Drawing basic shapes” on page 9. For more information on geometric shapes, see 
the Draw Guide.

Note

Text can be added to all geometric shapes. For more information, see “Using text” on
page 22 and the Draw Guide.

Basic shapes
The Basic Shapes sub-toolbar (Figure 23) also includes rectangle and ellipse tools that are 
identical to the ones displayed on the Drawing toolbar.

Figure 23: Basic Shapes sub-toolbar
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Symbol shapes

Figure 24: Symbol Shapes sub-toolbar

Block arrows

Figure 25: Block Arrows sub-toolbar

Flowchart

Figure 26: Flowchart sub-toolbar
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Callouts

Figure 27: Callouts sub-toolbar

Stars and banners

Figure 28: Stars and Banners sub-toolbar

3D objects

Figure 29: 3D-Objects sub-toolbar

Using text

In Draw you can add, insert, and format text in a drawing, object, or shape, as follows. For more 
information, see the Draw Guide.

• As a dynamic text frame, which is an independent Draw object that expands as more text
is added within the frame.

• As text within a previously drawn object. This integrates the text within the object and is 
placed within the boundary rectangle that surrounds an object. This boundary rectangle 
is not dynamic and care must be taken so that the text does not go outside the object 
boundaries.
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Text mode
Before you can add any text to a drawing, you need to activate text mode, using one of the 
following methods:

• Click on Insert Text Box on the Standard or Drawing toolbars.

• Go to Insert > Text Box on the Menu bar.

• Use the keyboard shortcut F2.

• Double-click inside the boundary rectangle that surrounds an object on the drawing. Text 
inside an object is not placed into a text box.

The Text Formatting toolbar (Figure 30) automatically opens when text mode is activated, 
replacing the Line and Filling toolbar.

Figure 30: Text Formatting toolbar

Adding text
When you add text to a drawing, a text box is automatically created to contain the text.

1) Activate text mode as above.

2) Create a text box in the drawing using one of the following methods:

– Click at the approximate position for the text box and a single line text box is created 
containing a flashing cursor. Start typing the text or paste copied text into the text box.
The width of a single line text box increases as text is added.

– Click at the approximate position for the text and drag the cursor to the approximate 
width required for the text box creating a multi-line text box. Start typing the text or 
paste copied text into the text box. As the horizontal limit of the text box is reached, 
the text automatically word wraps inside the text box and the text box expands 
vertically as it fills.

The Status bar indicates text edit mode and the position of the cursor (Figure 31).

Note

You can create multiple lines of text in a single-line text box by pressing Enter to 
create a new paragraph, or using Shift+Enter to create a line break in the tex.
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Figure 31: Text information in Status bar

3) When you have finished adding text, click outside the text box to exit text mode. The Text 
Formatting toolbar closes and the Line and Filling toolbar opens in its original position.

4) To format and/or reposition the text box, see the Draw Guide for more information.

5) If required, select the text using the various tools on the Text Formatting toolbar 
(Figure 30) or in the Character, Paragraph, and Lists panels on the Properties deck of the
Sidebar (Figure 32).

Figure 32: Character, Lists, and Paragraph panels in 
the Properties deck on Sidebar
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Vertical text
By default, Draw is set for horizontal text only. The options for vertical text have to be switched on
and added as follows:

1) Go to Tools > Options > Language Settings > Languages on the Menu bar to open the
Languages page in the Options dialog.

2) In Default Languages for Documents, select the Asian option and the default language 
displayed in the scroll box.

3) Click Apply, then OK to close the Options dialog and save the changes.

4) Add the Insert Vertical Text tool to the Standard and/or Drawing toolbar as follows:

a) Right-click in a blank area on the toolbar and select Visible Buttons in the context 
menu.

b) Select Insert Vertical Text from the list of available tools and the icon will appear on 
the toolbar.

Note

Formatting vertical and vertical text boxes is the same as horizontal text and 
horizontal text boxes. A vertical text box expands vertically as text is added into the 
box. For more information on vertical text, see the Draw Guide.

Selecting objects

Direct selection
The easiest way to select an object is to click directly on it. For objects that are not filled, click on 
the object outline to select it. The first click selects an object and a second click deselects the 
selected object. To select or deselect more than one object, hold the Shift key down while 
clicking.

Selection by framing
You can several objects once by clicking and dragging the cursor around the objects, drawing a 
selection rectangle around the objects. Only objects that lie entirely within this selection rectangle
are selected. To select multiple objects by framing, Select on the Drawing toolbar must be active.

Note

When you drag the cursor to select multiple objects, the selection rectangle being 
created is also known as a marquee.

Selecting hidden objects
If objects are located behind others and not visible, they can still be selected. When you select a 
hidden object, its selection handles appear through the objects covering it.

• Windows, macOS or Linux – press the Tab key to select and cycle through the objects 
in a drawing, stopping at the hidden object to select it. To cycle through the objects in 
reverse order, press Shift+Tab.

• Windows or macOS only – select the object in front of a hidden object, then press the 
Alt key and click to select the hidden object. If there are several hidden objects, keep 
holding down the Alt key and clicking until the object required is reached. To cycle 
through the objects in reverse order, hold down the Alt+Shift keys and click.
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Arranging objects
In a complex drawing, several objects may be stacked on top of one another. This stacking order 
can be rearranged by moving an object forward or backward using one of the following methods:

• Select an object, go to Shape > Arrange on the Menu bar, or right-click on the object and
select Arrange from the drop-down menu, then use one of the following options:

– Bring to Front (Ctrl+Shift++)

– Bring Forward (Ctrl++)

– Send Backward (Ctrl+-)

– Send to Back (Ctrl+Shift+-)

– In Front of Object

– Behind Object

– Reverse – clicking on this option reverses the order of the selected objects.

• Select an object, then click on one of the Arrange tools on the Line and Filling toolbar. 
When you hover the cursor over a tool, its function is indicated.

Positioning and adjusting objects

When positioning or changing the size of an object, check the information area of the Status bar 
at the bottom of the Draw Workspace (Figure 33). From left to right, it shows what object is 
selected, its position on the drawing in X/Y coordinates, and the dimensions of the object. The 
measurement units are those selected in Tools > Options > LibreOffice Draw > General.

For more information on positioning and adjusting objects, see the Draw Guide.

Figure 33: Information on left end of Status Bar when working with objects

Using zoom
To help in the positioning and adjustment of objects, Draw has a zoom function that reduces or 
enlarges the screen display of the current drawing. For example, zoom in to position objects on a
drawing with greater accuracy; zoom out to see the complete drawing. Zooming is controlled 
using the Status bar, Zoom & View Layout dialog, or Zoom toolbar. For more information on using
zoom, see the Draw Guide.
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Moving objects
To move an object (or a group of objects), select it and then click within the object borders and 
hold down the left mouse button while dragging the mouse. During movement, a ghost image of 
the object appears to help with repositioning (Figure 34). To locate the object at its new location, 
release the mouse button.

Figure 34: Moving objects

Adjusting object size
To change the size of a selected object (or a group of selected objects), move the mouse cursor 
to one of the selection handles.  The cursor changes shape to indicate the direction of movement
for that selection handle. As the object size changes, a ghosted outline of the object appears 
(Figure 35). When the desired size of the object is reached, release the mouse button.

The results depend on which selection handle you use. To resize an object along one axis, use a 
side, top, or bottom handle. To resize along both axes, use a corner handle.

Figure 35: Adjusting object size

Note

If you press and hold the Shift key while resizing an object, the change in size will be 
carried out symmetrically with respect to the object width and height so that the 
aspect ratio of the object remains the same. This Shift key behavior works on all 
selection handles.

Rotating or slanting objects
To rotate or slant an object (or a group of objects), select an object and switch to rotation mode 
using one of the following methods:

• Right-click on the object and select Transformations > Rotate in the context menu.

• Click on the small downward triangle ▼ on the right of the tool icon for Transformations 
on the Standard or Line & Filling toolbar and select Rotate.
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The selection handles change shape and color and a center of rotation appears in the center of 
the object. As the cursor is moved over the handles, the cursor changes shape to indicate the 
type of movement.

Figure 36: Rotating an object

Rotation
1) Click and hold the mouse button over a corner selection handle, then move the cursor to 

rotate the object. A ghost image of the object being rotated appears and the current angle
of rotation is shown in the Status bar, as shown in Figure 36.

2) When the object is at the desired rotation angle, release the mouse button.

3) To change the angle of rotation, click on the rotation point and drag it to another position. 
This position can be outside the object.

Note

Press the Shift key while rotating or slanting an object and the movement is restricted
to 15°.

Slanting
1) Click and hold the mouse button over a selection handle at the top, bottom, left side, or 

right side of an object.

2) Drag the selection handle to slant the object. A ghost image of the object being slanted 
appears (as shown in Figure 37) and the current slant angle is shown in the Status bar. 
The axis used for slanting an object is fixed to the edge of the object directly opposite the 
selection handle being used to slant the object.

3) When the object is at the desired slant angle, release the mouse button.

Figure 37: Slanting an object
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Flipping objects
Select an object so that the selection handles are displayed and flip the object vertically or 
horizontally using one of the following methods:

• Right-click on the object and select Flip > Vertically or Horizontally in the context menu.

• Go to Shape > Flip > Vertically or Horizontally on the Menu bar.

• Click on Vertically or Horizontally tool on the Line and Filling toolbar.

• Use Flip Vertically or Flip Horizontally tool in the Position and Size section on the 
Properties deck of the Sidebar.

However, the Flip tool on the Transformations toolbar (Figure 38) provides greater control over 
the flipping process. Use the Flip tool to change the position and angle that the object flips over. 
See the Draw Guide for more information.

Figure 38: Transformations toolbar

Object distortion
Three tools on the Transformations toolbar (Figure 38) let you drag the corners and edges of an 
object to distort an object.

• Distort – distorts an object in perspective.

• Set in Circle (perspective) – creates a pseudo 3D effect.

• Set to Circle (slant) – creates a pseudo 3D effect. Despite the (slant) in the name of this 
tool, it operates differently from the slanting created by rotation.

In all three cases, you are asked if you want to convert the object into a curve. This is a 
necessary first step, so click Yes. Then you can move the object handles to produce the desired 
effect. See the Draw Guide for more information on how to distort an object.

Dynamic gradients
Transparency gradients can be controlled the same as color gradients. Both types of gradient 
can be used together. With a transparency gradient, the direction and degree of the object fill 
color changes from opaque to transparent. In a color gradient, the fill changes from one color to 
another, but the degree of transparency remains the same. An example of a dynamic gradient is 
shown in Figure 39.

Two tools on the Transformations toolbar are used to dynamically control transparency and color 
gradients – Interactive Transparency and Interactive Gradient. See the Draw Guide for more 
information on how to create transparencies and gradients in an object.
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Figure 39: Dynamic gradient example

Duplication
Duplication makes copies of an object while applying a set of changes such as color or rotation to
the duplicates that are created. An example of duplication is shown in Figure 40. For more 
information on duplication, see the Draw Guide.

Figure 40: Duplication example

1) Click on an object or group of objects and open the Duplicate dialog (Figure 41) using 
one of the following methods:

– Go to Edit > Duplicate on the Menu bar.

– Go to Shape > Duplicate on the Menu bar.

– Use the keyboard shortcut Shift+F3.

2) Select the required number of copies, placement, enlargement, and colors from the 
options available.

3) Click OK to duplicate the object and close the Duplicate dialog.
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Figure 41: Duplicate dialog

Cross-fading
Cross-fading transforms one object shape to another object shape. Cross-fading only works 
when two objects are selected.

1) Select two differently shaped objects and go to Shape > Cross-fading on the Menu bar 
to open the Cross-fading dialog (Figure 42).

2) In Increments enter the number of shapes between the two objects.

3) Select Cross-fading attributes to apply a gradual change of line and fill properties 
between the two objects.

4) Select Same orientation to apply a smooth transition between the two objects.

5) Click OK to carry out the cross-fading and close the Cross-fading dialog.

Figure 42: Cross-fading dialog
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The result is a new group of objects with the first object selected as the start object and the 
second object selected as the end object. For example, when the options in the Cross-fading 
dialog are applied to a diamond and an ellipse, the cross-fading produces the result shown in 
Figure 43.

Figure 43: Cross-fading example of two objects

Grouping and combining multiple objects

Using Draw, a group of objects can be grouped together allowing multiple objects to be treated 
as one object, or combined together to create a new shape, as shown by the example in 
Figure 44. For more information on grouping and combining objects, see the Draw Guide.

Grouping
Grouping of objects is similar to putting objects into a container. The objects can be moved as a 
group and global changes applied to the objects within the group. A group can always be undone 
(ungroup). Objects that make up a group can always be manipulated separately and retain their 
own individual properties.

Figure 44: Example of grouped and combined objects
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Temporary grouping
A temporary grouping is when several objects are selected using one of the following methods:

• While holding down the Shift key, click on each object with the cursor to select it for the 
temporary group.

• Using the mouse, click and drag a rectangle (also known as a marquee) around the 
objects for the temporary group.

Any changes to object parameters carried out are applied to all of the objects within the 
temporary group. For example, rotating a temporary group of objects in its entirety.

To cancel a temporary grouping of objects, click outside of the selection handles displayed 
around the objects.

Permanent grouping
A permanent grouping of objects can be created after selecting objects using one of the following
methods:

• Go to Shape > Group > Group on the Menu bar.

• Right-click on the selected objects and select Group in the context menu.

• Use the keyboard shortcut Ctrl+Shift+G.

When deselected, the objects remain grouped together. Any editing operations carried out on the 
group are applied to all objects within the group. If one object in the group is clicked, the whole 
group is selected.

Editing within groups
You can edit an individual within a group without ungrouping or breaking the group. After 
selecting the group, use one of the following methods to enter the group:

• Go to Shape > Group > Enter Group on the Menu bar.

• Right-click on the selected group and select Enter Group in the context menu.

• Use the keyboard shortcut F3.

• Double-click on the selected group.

When you have finished editing an individual object within a group, use one of the following 
methods to exit the group:

• Go to Shape > Group > Exit Group on the Menu bar.

• Right-click and select Exit Group in the context menu.

• Use the keyboard shortcut Shift+F3.

Ungrouping
To ungroup or break apart a permanent group of objects, use one of the following methods after 
selecting the group:

• Go to Shape > Group > Ungroup on the Menu bar.

• Right-click and select Ungroup in the context menu.

• Use the keyboard shortcut Ctrl+Alt+Shift+G.

Nesting groups
You can create a group of groups, more commonly known as nested groups. When nested 
groups are created, Draw retains the individual group hierarchy and remembers the order in 
which groups were selected. That is, the last individual group selected will be on top of all the 
other groups within a nested group. Ungrouping and entering a nested group work in the same 
way as for individual groups.
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Combining objects
Combining is a permanent merging of objects, creating a new object. The original objects are no 
longer available as individual entities and cannot be edited as individual objects. Any editing of a 
combined object affects all the objects that were used when combination was carried out. For 
more information on combining objects, see the Draw Guide.

After selecting the objects for combining, use one of the following methods to create a new 
object:

• Go to Shape > Combine on the Menu bar.

• Right-click on the objects and select Shapes > Combine in the context menu.

• Use the keyboard shortcut Ctrl+Shift+K.

Merging, subtracting, and intersection
After selecting several objects, the Merge, Subtract, and Intersect functions become available. 
These functions are similar to combining objects, but allow the creation of a differently shaped 
object from the selected objects. The shape of the object depends on which function used. See 
the Draw Guide for more information on how to use these functions.

Arranging, aligning, and distributing objects
In Draw, selected objects can be arranged, aligned, and distributed in relation to each other:

• Arrange the position of an object by moving it either forward or backward in relation to the
order of objects.

• Align objects with respect to each other using Left, Centered, or Right for horizontal 
alignment and Top, Center, or Bottom for vertical alignment.

• Distribute objects so that the space between each of the objects is the same.

See the Draw Guide for more information on arranging and aligning objects.

Inserting and exporting images

Inserting
Draw contains a number of functions for editing images (also called pictures, raster graphics, or 
bitmaps). These functions include the import and export of images, and conversion from one 
image format to another. For more information on working with images, see Chapter 11, Images 
and Graphics in this guide and the Draw Guide.

Draw includes a large range of filters so that it can read and display several image file formats. It 
also includes several tools for working with images, but does not have the same functionality as 
specialized programs like GIMP or Adobe Photoshop.

Images can be added from several sources:

• Directly from a scanner (Insert > Media > Scan on the Menu bar).

• Created by another program, for example photographs from a digital camera (Insert > 
Image on the Menu bar).

• The LibreOffice Gallery; see Chapter 11, Images and Graphics.
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Exporting
Draw saves images as drawings in the Open Document Format (ODG). To save an image or the 
entire Draw file in another format, go to File > Export on the Menu bar and select a format from 
the drop-down list. The image formats that Draw can export in and save to are listed in Appendix 
B, Open Source, Open Standards, OpenDocument in this guide.

Draw files can also be exported in HTML, XHTML, or PDF format from LibreOffice. For more 
information, see Chapter 10, Printing, Exporting, Emailing, and Signing.

HTML export uses a conversion wizard that creates as many web pages as there are pages in a 
Draw document. You can optionally choose to dispaly drawing pages in frames with a navigator 
and set an index page. For more information, see Chapter 12, Creating HTML Files.

Working with 3D objects

Although Draw does not match the functionality of specialized drawing or image editing 
programs, it is capable of producing and editing very good 3D drawings. For more information, 
see the Draw Guide.

You can create a 3D object in Draw using one of the following methods:

• Select a 3D shape from the 3D Objects section in the Shapes deck on the Sidebar.

• Right-click on a 2D object and select Convert > To 3D or To 3D Rotation Object in the 
context menu.

• Right-click on a 2D object and select Format > 3D Effects on the Menu bar.

Working with layers

Using layers when creating complex drawings makes a drawing easier to navigate and edit. 
Placing a simpler drawing that is part of a complex drawing into its own layer makes editing 
easier. Any area of a layer that does not contain a drawing object is transparent and does not 
obscure any part of a complex drawing. Any number of layers can be added to a drawing. For 
more information on layers, see the Draw Guide.

A drawing in LibreOffice contains three default layers that cannot be deleted or renamed:

• Layout – is the default Workspace where objects are normally placed when a drawing is 
created.

• Controls – used for form controls that have been assigned an action. Objects on this 
layer are always in front of objects on other layers.

• Dimension Lines – is where the dimension lines are drawn. By switching the layer to 
show or hide, dimension lines can be switched on or off.

A layer can be set to one or all of the following attributes:

• Visible or hidden.

• Printable or not printable.

• Locked or unlocked.

To quickly toggle the attributes for a selected layer, use the following keyboard shortcuts:

• Shift+click – toggle between a layer being visible or hidden.

• Ctrl+click – toggle between a layer being locked or unlocked.

• Ctrl+Shift+click – toggle between a layer being printed or not printed.
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Adding layers
To add a layer to a drawing:

1) Use one of the following methods to open the Insert Layer dialog (Figure 45):

– Go to Insert > Layer on the Menu bar.

– Right-click on the layer tabs at the bottom of the Workspace and select Insert Layer 
in the context menu.

Figure 45: Insert Layer dialog

2) Enter a meaningful Name, Title, and Description for the new layer in the text boxes.

3) Select Visible if the layer is to be visible in a drawing. When Visible is not selected, the 
layer is hidden and its name in the layer tab changes color to blue.

4) Select Printable if the layer is to be printed when a drawing is printed. Not printing is 
useful if a draft layer is required for guides or annotations that are used in making a 
drawing, but you do not it want to appear in the final output. The name of a layer is 
underlined in the layer tab bar when the Printable option is turned off.

5) Select Locked to prevent any objects on this layer from deletion, editing, or moving. No 
additional objects can be added to a locked layer. Locking a layer is useful, for example, 
when a base plan is to be protected while adding a new layer with other details. The 
name of a locked layer is written in Italics in the layer tab bar.

6) Click OK to create the new layer and close the Insert Layer dialog. A new layer 
automatically becomes active when added to a drawing.

Note

Layers are added to the drawing in the order that they were inserted. The layer order
cannot be changed.
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Modifying layers
1) To modify a layer, use one of the following methods to open the Modify Layers dialog, 

which is similar in layout and options to the Insert Layers dialog.

– Right-click on the name tab of the layer and select Modify Layer in the context menu.

– Double-click on the layer tab.

– Go to Format > Layer on the Menu bar.

2) Make the required changes to the layer, then click OK to save the changes and close the 
Modify Layers dialog.

Choosing colors

You can choose colors using a color palette, the Area and Line panels on the Properties deck of 
the Sidebar, and tools on the Line and Filling and Drawing toolbars, as described below.

Note

For a more detailed description of the options available for color palettes and custom
colors, as well as more information on the difference between the CMYK and RGB 
color schemes, refer to the Draw Guide.

Color palette
To display the Color Palette that is currently in use (Figure 46), go to View > Color Bar on the 
Menu bar. To close the Color Palette, go to View on the Menu bar and deselect Color Bar.

Using the Color Palette, you can rapidly choose the color of the area or background, and lines of 
selected objects in your drawing.

• Left-click on a color to change the color of the area or background of a selected object.

• Right-click on a color to change the color of the lines in a selected object.

• Left-click or right-click on the box with the X at the bottom left of the Color Palette to 
select no color for the area or lines of a selected object.

Figure 46: Color Palette (Color Bar)

Choosing colors | 37



Sidebar color
In the Area and Line panels in the Properties deck on the Sidebar (Figure 47), you can change 
the color of an area or line of a selected object as follows:

1) Select an object in a drawing.

2) Click on Properties on the Sidebar to open the Properties deck.

3) Open the Area and/or Line panels by clicking on the down-pointing symbol ▼ on the 
panel’s title bar.

Figure 47: Area and Line panels in Properties deck on the
Sidebar

4) Change the color of an area in the Area panel as follows:

a) Select Color from the Fill drop-down list.

b) Click on the down-pointing symbol ▼ next to the Fill Color box to open the color 
palette.

c) Click on a color to change the area color.

d) To change the color palette, click on the down pointing symbol ▼ at the top of the 
color palette and select a color palette from the drop-down list.
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5) Change the color of a line in the Line panel as follows:

a) Click on the down-pointing symbol ▼ next to the Line Color box to open the color 
palette.

b) Click on a color to change the line color.

c) To change the color palette, click on the down pointing symbol ▼ at the top of the 
color palette and select a color palette from the drop-down list.

Toolbar color change
The Line and Filling and Drawing toolbars have the same two tools that can be used to change 
the color of an area (fill) or line – Fill Color and Line Color. These two tools are used in the 
same way as changing colors using the Area and Line panels on the Properties deck of the 
Sidebar, described above.

Adding comments to a drawing
You can add comments to a drawing using a similar process to the one used in Writer and Calc. 
For more about adding, navigating, and replying to comments, see Chapter 4, Getting Started 
with Writer.

Before using comments, make sure that your name and initials are entered into Tools > Options 
> LibreOffice > User Data. The name and initials then appear in the comment marker and in the 
Author field of the comment.

If more than one person edits the document, each author is automatically allocated a different 
background color.

1) Go to View > Comments on the Menu bar to show or hide the comment markers.

2) Go to Insert > Comment on the Menu bar. A small box containing your initials appears in 
the upper left-hand corner of the drawing with a larger text box beside it (Figure 48). Draw
automatically adds your name and the date at the bottom of this text box.

3) Type or paste your comment into the text box.

Figure 48: Inserting a comment

4) If necessary, click and drag the small comment markers to move the comment to a 
different position on the drawing. Normally, the comment marker is placed on or near the 
object you refer to in the comment.

5) Right-click on the comment and choose an option in the context menu to delete the 
current comment, all the comments from the same author, or all the comments in the 
document.
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