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Toolbars and menus

To change object attributes, such as color or border width, and so on, use the Line and Filling 
toolbar, the Text Formatting toolbar, or the context menus.

Line and Filling toolbar
If the Line and Filling toolbar is not displayed, go to View > Toolbars > Line and Filling to open 
the toolbar (Figure 1). The most common object attributes can be edited using this toolbar. For 

example, you can open the Line dialog by clicking on the Line icon  and the Area dialog by 

clicking on the Area icon  for access to more formatting options. The tools available from left to 
right on the Line and Filling toolbar are also shown in Figure 1.

Figure 1: Line and Filling toolbar and available tools

Figure 2: Text Formatting toolbar and available tools
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Text Formatting toolbar
When you select text, the Line and Filling toolbar automatically changes to show the Text 
Formatting toolbar (Figure 2). You can also open the Text Formatting toolbar by selecting View > 
Toolbars > Text Formatting. The tools on this toolbar will not become active until text has been 
selected. The tools available from left to right on the Text Formatting toolbar are also shown in
Figure 2.

Context menu
When an object is selected and you right-click on the object, a context menu (Figure 3) opens that 
applies to the selected object. This context menu provides access to the options available and 
allows you to change object attributes without having to open a dialog. Menu entries with a small 
triangle on the right-hand side contain a submenu with more menu options.

Figure 3: Example of a Context menu

Formatting lines

In LibreOffice the term line indicates both a freestanding segment (line), the outer edge of a shape 
(border), or an arrow. In most cases the properties of the line you can modify are its style (solid, 
dashed, invisible, and so on), its width, and its color.

To quickly format a line, first select the line then use the highlighted controls in Figure 4 on the Line
and Filling toolbar to change the style, width, and color of the line.

Figure 4: Common line properties (style, width and color)
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If you want to fully change the appearance of a line, then you need to use the Line dialog.

1) Select the line on your drawing.

2) Go to Format > Line on the main menu bar, or right-click on the line and select Line from 

the context menu, or select the Line icon  from the Line and Filling toolbar to open the 
Line dialog (Figure 5) where you can set line properties. This dialog consists of four pages: 
Line, Shadow, Line Styles, and Arrow Styles, as explained in the following sections.

3) Click OK to close the dialog and save your changes. The preview box at the bottom of the 
dialog shows the effect of your changes on a line.

Figure 5: Line properties dialog – Line page

Line properties
The Line page is where you can set the basic parameters of the line and is divided into four 
sections as follows.

Line properties section
Use the Line Properties section on the left side to set the following parameters:

• Line style – several line styles are available from the drop-down list, but more line styles 
can be defined if necessary.

• Color – choose from the predefined colors in the drop down list or create a new color.

• Width – specifies the thickness of the line.

• Transparency – sets the transparency of a line. Figure 6 shows the effects of different 
percentages in transparency levels to lines when placed over an object.
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Figure 6: Line transparency effect (0%, 25%, 50%, 75% left to right)

Arrow styles section
The Arrow styles section of the Line dialog is only applicable to individual lines and is not used for 
lines that form the borders of a shape.

• Style – sets the style of the two ends of a line. The left drop down menu is for where you 
start the line and the right drop down menu is for where you end the line.

• Width – specifies the thickness of the arrow endings

• Center – moves the center of the arrow endings to the end point of the line. Figure 7 shows
the effects of selecting this option.

• Synchronize ends – makes the two line ends identical.

Figure 7: Default arrowheads (left) and centered arrowheads (right)

Corner and cap styles section
Corner and cap styles determine how the connection between two segments looks. To appreciate 
the difference between these styles, choose a thick line style and observe how the preview 
changes.

• Corner style – select the shape to be used at the corners of the line. In case of a small 
angle between lines, a mitered shape is replaced with a beveled shape.

• Cap style – select the style of the line end caps. The caps are added to inner dashes as 
well.

Arrowheads

A quick way to set the arrowheads for a selected line is to click on the Arrow Style icon  in the 
Line and Filling toolbar to open the Arrowheads menu (Figure 8). Here you can select one of the 
many predefined arrowhead styles for the start and ending of the selected line.

8 Changing Object Attributes



Note
Arrowheads are only applicable to lines. They have no effect on the border of an 
object.

Figure 8: Arrowheads menu

Line shadows
Use the Shadow page (Figure 9) of the Line dialog to add and format the line shadow. The settings
on this page are the same as those for shadows applied to other objects and are described in 
“Formatting shadows” on page 26.

A quicker way to apply a shadow to a line is using the Shadow icon  on the Line and Filling 
toolbar. The main disadvantage of using the Shadow icon is that the shadow appearance will be 
constrained by the shadow settings of the default graphics style.

Figure 9: Line properties dialog – Shadow page
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Line styles
Use the Line Styles page (Figure 10) of the Line dialog to create new line styles as well as to load 
previously saved line styles. It is normally better to create new styles when necessary than modify 
predefined styles.

Figure 10: Line dialog – Line Styles page

Creating line styles
To create a new line style:

1) Choose Format > Line on the main menu bar, or right-click on the line and select Line 

from the context menu, or select the Line icon  on the Line and Filling toolbar to open the
Line dialog.

2) Click on the Line Styles tab.

3) Select from the Line style drop-down menu a style similar to the style you want to create.

4) Click Add and type a name for the new line style in the dialog that opens, then click OK.

5) Now define the new style. Start by selecting the line type for the new style. To alternate two 
line types (for example, dashes and dots) within a single line, select different types in the 
two Type boxes.

6) Specify the Number and Length (not available for dot style) of each of the types of line 
selected.

7) Set the Spacing between the various elements

8) If necessary, select Fit to line width so that the new style fits the width of the selected line.

9) The new line style created is available only in the current document. If you want to use the 

line style in other documents, click the Save Line Styles icon  and type a unique 
filename in the Save as dialog that opens. Saved styles have the file extension of .sod.

10) To use previously saved line styles, click the Load Line Styles icon  and select a style 
from the list of saved styles. Click Open to load the style into your document.

11) If necessary, click on the Modify button to change the name of the style.

12) Click OK to close the dialog and save any changes you have made.
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Arrow styles
Use the Arrow Styles page (Figure 11) of the Line dialog to create new arrow styles, or modify 
existing arrow styles, or load previously saved arrow styles.

Figure 11: Line dialog – Arrow Styles page

Figure 12: Using shapes for arrow styles

Creating arrow styles
To create a new arrow style:

1) First draw a curve in the shape you want to use for the arrowhead, or create a shape and 
convert to a curve. The top of the shape must face upward, as shown in Figure 12, 
because this becomes the point of the arrow.

Note

The arrowhead must be a curve, which is something you can draw without lifting a 
pencil from the paper. For example, a star can be a curve, but a smiley face cannot 
be a curve because you have to reposition the pencil on the paper to draw eyes and
a mouth on the face.

2) Select the shape and, if necessary, right-click and choose Convert > To Curve to convert 
the shape to a curve. If the shape is already a curve, To Curve will not be available.

3) With the selection handles showing, select Format > Line from the menu bar, or right-click 
and choose Line from the pop-up menu.

4) Go to the Arrow styles page, click the Add button, type a name for the new arrow style, and
click OK. The new arrowhead style will be shown in the preview.
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5) Now you can access the new style from the Arrow style list. When you select the name of 
the new style, it is shown at the bottom of the dialog.

6) The new arrowhead style created is available only in the current document. If you want to 

use this arrowhead style in other documents, click the Save Line Styles icon  and type 
a unique filename in the Save as dialog that opens. Saved styles have the file extension 
of .sod.

7) To use previously saved arrowhead styles, click the Load Line Styles icon  and select 
the style from the saved list of styles. Click Open to load the style into your document.

8) If necessary. click on the Modify button to change the name of the style.

9) Click OK to close the dialog and save any changes you have made.

Formatting fill area

The term area fill refers to the inside of an object, which can be a uniform color, gradient, hatching 
pattern, or bitmap as shown in Figure 13. An area fill can be made partly or wholly transparent and 
can throw a shadow.

Figure 13: Different types of area fill

The Line and Filling toolbar has the majority of the tools normally used to format graphic objects. If 
this toolbar is not showing, go to View > Toolbars > Line and Filling on the main menu bar. You 
can also use the Area dialog, described in “Using the Area dialog” on page 14.

To format the area of an object, select it so that the selection handles show. A wide number of 
default fillings are readily available from the Line and Filling toolbar (Figure 14). Select on the Area 
Style/Filling drop-down menus the type of fill required (Figure 15) from None, Color, Gradient, 
Hatching, or Bitmap and then select the style of fill to be used. Once you have decided on a 
predefined or custom fill, you can further refine it by adding a shadow or transparency.

Figure 14: Common fill options highlighted

Figure 15: Area fill types
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Color area fill
To change the area fill of an object to a color (Figure 16):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Color from the Area Style/Filling drop down list.

3) Select a color from the drop-down list.

Figure 16: Color area fill

Gradient area fill
A gradient fill provides a smooth transition from one color to another. The transition pattern may 
vary from a simple linear transition to a more complex radial one. To change the area fill of an 
object to a gradient (Figure 17):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Gradient from the Area Style/Filling drop down list.

3) Select a gradient from the drop-down list.

Figure 17: Gradient area fill

Hatching area fill
When a hatching fill is applied it fills the complete area of the selected object. To change the area 
fill of an object to a hatching (Figure 18):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Hatching from the Area Style/Filling drop down list.

3) Select a hatching fill from the drop-down list.
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Figure 18: Hatching area fill

Bitmap image area fill
You can fill an object only with a bitmap image but not a vector graphic image. To change the area 
fill of an object to a bitmap image (Figure 19):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Bitmap from the drop down list.

3) Select a bitmap fill from the drop-down list.

Figure 19: Bitmap image area fill

Using the Area dialog
In addition to using the Line and Filling toolbar, you can use the Area dialog to apply existing area 
fills with greater control or create your own area fill.

1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Area tab to open the Area page and to apply an area fill. LibreOffice includes 
several area fills already defined, but you can create area fills yourself. See “Creating new 
area fills” on page 16 for more information.

4) Select the type of area fill from the drop-down list: None, Color, Gradient, Hatching, or 
Bitmap. Types of area fill are explained below.

5) Select the style of area fill from the options that become available. The number of available 
options will depend on the type of area fill selected above.

6) Click OK to close the dialog and save your changes. The area fill will then appear in your 
selected object.
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Types of area fill
• Color fills – select Color from the Fill drop down list and then select your required color 

from the list of available colors (Figure 20). A preview of the selected color appears at the 
bottom of the dialog.

Figure 20: Area color dialog

• Gradient fills – select Gradient from the drop down list and then select your required 
gradient from the list of available gradients (Figure 21). You can override the number of 
steps (increments) that should be applied to the gradient transition. To do so, deselect the 
Automatic option under Increments and then enter the number of steps required in the box
to the right. A preview of the selected gradient appears at the bottom of the dialog.

Figure 21: Area gradient dialog

• Hatching fills – select Hatching from the drop down list and then select your required 
hatching from the list of available hatchings (Figure 22). You can apply a different 
background color by selecting the Background color option and choosing a color from the
drop down list. A preview of the selected hatching appears at the bottom of the dialog.

Figure 22: Area hatching dialog

• Bitmap fills – select Bitmaps from the drop down list and then select your required bitmap
from the list of available bitmaps (Figure 23). You can customize a large number of 
parameters. A preview of the selected bitmap appears at the bottom of the dialog.
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Figure 23: Area bitmap dialog

Creating new area fills

The following sections describe how to create new fills and how to apply them.

Although you can change the characteristics of an existing fill and then click the Modify button, it is
recommended that you create new fills, or modify custom fills rather than the predefined ones, as 
these may be reset when updating LibreOffice.

Creating custom colors
On the Colors page (Figure 24), you can modify existing colors or create your own. You can also 
specify a new color either as a combination of the three primary colors Red, Green, and Blue, 
(RGB notation) or by percentages of Cyan, Magenta, Yellow, and Black (CMYK notation).

Creating new color
1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Colors tab to open the Colors page.

4) Enter a name for the new color in the Name box.

5) Select whether to define the color in RGB or CMYK. For RGB, specify the red (R), green 
(G) and blue (B) component on a 0 to 255 scale. For CMYK, specify the cyan (C), magenta
(M), yellow (Y) and black (K) components from 0% to 100%.

6) Click the Add button. The color is now added to the Color drop down list.

7) Click OK to save your changes and close the dialog.
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Figure 24: Creating a new color

Modifying colors
1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Colors tab to open the Colors page.

4) Select the color to modify from the list.

5) Enter the new values that define the color in RGB or CMYK.

6) Modify the name as required.

7) Click Modify to save your changes.

8) Click OK to close the dialog.

Editing colors
1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Colors tab to open the Colors page.

4) Select the color to edit from the list.

5) Click on the Edit button to open the Color Picker dialog (Figure 25).

6) Modify the color components as required using RGB, CMYK or HSB (Hue, Saturation, 
Brightness).

7) Click OK to exit the Color Picker dialog.

8) Modify the name as required.
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Figure 25: Editing a color

9) Click Modify on the Color dialog to save your changes.

10) Click OK to close the dialog.

Saving and using new colors
Any new color created is available only in the current document. If you want to use this color in 

other documents, click the Save Color List icon  and type a unique filename in the Save as 
dialog that opens. The saved colors list has the file extension of .soc.

To use a previously saved color list, click the Load Color List icon  and select from the file 
open dialog. Click Open to load the saved color list into Draw.

Tip
You can also add custom colors using Tools > Options > LibreOffice > Colors. This
method makes the color available to all components of LibreOffice.

Creating custom gradients
To create a new gradient or to modify an existing one, select the Gradients tab from the Area dialog
(Figure 26). Several types of gradients are predefined and in most cases changing the From and 
To colors will be sufficient to obtain the desired result.

It is highly recommended that you create a new gradient even if you just want to change the two 
colors, rather than modifying the predefined ones, which should only be used as starting points.
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Figure 26: Creating a new gradient

Creating new gradients
1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Gradients tab to open the Gradients page.

4) Select the From and To colors from the drop down lists.

5) Select the type of gradient from the drop down list: Linear, Axial, Radial, Ellipsoid, Square 
or Rectangular. A preview of the gradient type is shown in the dialog.

6) Set all the properties as desired (very often the default values will work well). The 
properties used to create a gradient are summarized in Table 1. Depending on the type of 
gradient selected, some properties may be grayed out.

7) Click Add to add the newly created gradient to the list.

8) Type a name for the new gradient in the dialog that opens and click OK.

9) Click OK to close the dialog.

Table 1: Gradient properties

Property Meaning

Center X
For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to 
set the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to 
set the vertical offset of the gradient center.

Angle For all the gradient types, specifies the angle of the gradient axis.
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Property Meaning

Border
Increase this value to make the gradient start further away from the border of the 
shape.

From
The start color for the gradient. In the edit box below enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.

To
The end color for the gradient. In the edit box below enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.

Modifying gradients
1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Gradients tab to open the Gradients page.

4) Select the gradient to modify from the list.

5) Enter the new values for the properties that become available for change. See Table 1 for 
more information on gradient properties.

6) Click Modify to save your changes.

7) Click OK to close the dialog.

Saving and using new gradients
The new gradient created is available only in the current document. If you want to use this gradient

in other documents, click the Save Gradients List icon  and type a unique filename in the 
Save as dialog that opens. The saved gradients list has the file extension of .sog.

To use a previously saved gradients list, click the Load Gradients List icon  and select from 
the file open dialog. Click Open to load the saved gradients list into Draw.

Advanced gradient controls
As discussed in “Creating custom gradients” on page 18, gradient properties can be configured 
using the properties given in the dialogs shown in Figure 26 and Table 1. However, LibreOffice 
provides advanced controls for gradients as follows.

1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Gradients tab to open the Gradients page (Figure 26).

4) Select the type of gradient you want to use for your object from the Type drop down list. 
Properties you can adjust will depend on the gradient type you have selected and these are
explained below.

5) Go to View > Toolbars > Mode on the main menu bar, click on the Effects icon  on the
Line and Filling toolbar to open the Mode toolbar.

6) Click on the Gradient icon  in the Mode toolbar (Figure 27). This displays a dashed 
line connecting two colored squares. The colors show the From and To colors that are used
for the selected gradient (Figure 28).
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Figure 27: Mode toolbar

Figure 28: From Red 4 to Yellow 1 gradient

7) For linear gradients – move the square corresponding to the From color to change where 
the gradient starts (border value). Move the square corresponding to the To color to change
the orientation (angle value).

8) For axial gradients – move the To color to change both the angle and border properties of 
the gradient. Only the square corresponding to the To color can be moved.

9) For radial gradients – move the From color to modify the border property to set the width 
of the gradient circle. Move the To color to change the point where the gradient ends 
(Center X and Center Y values).

10) For ellipsoid gradients – move the From color to modify the border property to set the 
size of the gradient ellipsoid. Move the To color to change the angle of the ellipsoid axis 
and the axis itself.

11) For square and rectangular gradients – move the From color to modify the border to set 
the size of the gradient square or rectangle and the angle of the gradient shape. Move the 
To color to change the center of the gradient.

12) Click OK to save your changes and close the Area dialog.

Note
Moving the squares will have different effects depending on the type of gradient. For 
example, for a linear gradient, the start and end squares of the gradient will always 
be situated to either side of the center point of the object.

Creating custom hatching patterns
To create new hatching patterns or modify existing ones, select the Hatching tab of the Area dialog 
(Figure 29). As with gradients and colors, it is better to create a new hatching pattern rather than 
modify a predefined one. The properties that can be set for a hatching pattern are shown in Table 
2.

Creating new area fills 21



Figure 29: Creating a new hatching pattern

Table 2: Hatching pattern properties

Property Meaning

Spacing Determines the spacing between two lines of the pattern. As the value is 
changed the preview window is updated.

Angle Use the mini map below the numerical value to quickly set the angle formed 
by the line to multiples of 45 degrees. If the required angle is not a multiple of 
45 degrees, just enter the desired value in the edit box.

Line type Set single, double or triple line for the style of the pattern.

Line color Use the list to select the color of the lines that will form the pattern.

Creating new hatching patterns
1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Hatching tab to open the Hatching page.

4) Select as a starting point a pattern similar to the one that will be created.

5) Modify the properties of the lines forming the pattern. A preview is displayed in the window 
below the available patterns. More information on hatching properties is shown Table 2.

6) Click Add and type a name for the new gradient in the dialog that opens, then click OK.

7) Click OK to close the dialog.
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Modifying hatching patterns
1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Hatching tab to open the Hatching page.

4) Select the hatching pattern to modify from the list.

5) Enter the new values for the properties that become available for change. See Table 2 for 
more information on gradient properties.

6) Click Modify to save your changes.

7) Click OK to close the dialog.

Saving and using new hatching patterns
The new hatching pattern created is available only in the current document. If you want to use this 

hatching pattern in other documents, click the Save Hatches List icon  and type a unique 
filename in the Save as dialog that opens. The saved hatches list has the file extension of .soh.

To use a previously saved hatches list, click the Load Hatches List icon  and select from the 
file open dialog. Click Open to load the saved hatches list into Draw.

Figure 30: Advanced formatting for bitmap fill

Working with bitmap fills
1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Area tab to open the Area page.

4) Select Bitmap from the Fill drop down list (Figure 30).
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5) Select from the list of bitmaps the one to be used to fill the area. Note that any imported 
bitmaps will become available in the list.

6) Set the size, position and offset parameters (as applicable). See Table 3 for more 
information on bitmap properties. The best way to acquire understanding of these 
parameters is to use them. Figure 31 shows some examples of bitmap fills and the 
parameters used.

7) Click OK to close the dialog.

Figure 31: Examples of bitmap fill

Table 3: Bitmap fill properties

Property Meaning

Size – Original Select this box to retain the original size of the bitmap.

Size – Relative To rescale the object, deselect Original and select Relative. The Width and 
Height edit boxes are enabled.

Size – Width When Relative is selected 100% means that the bitmap original width will be 
resized to occupy the whole fill area width, 50% means that the width of the 
bitmap will be half that of the fill area.

Size – Height When Relative is selected 100% means that the bitmap original height will be
resized to occupy the whole fill area height, 50% means that the height of the
bitmap will be half that of the fill area.

Position – Anchor 
Map

Select from the map the place within the area to which the bitmap should be 
anchored.

Position – Tile When this option is selected, the bitmap will be tiled to fill the area. The size 
of the bitmap used for the tiling is determined by the Size settings.

Position – X offset When Tile is enabled, enter in this box the offset for the width of the bitmap in
percentage values. 50% offset means that Draw will place the middle part of 
the bitmap at the anchor point and start tiling from there.

Position – Y offset This will have a similar effect to the X offset, but will work on the height of the 
bitmap.
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Property Meaning

Position – Autofit Stretches the bitmap to fill the whole area. Selecting this option disables all 
the size settings.

Offset – Row If Tile is enabled, offsets the rows of tiled bitmaps by the percentage entered 
in the box so that two subsequent rows are not aligned.

Offset – Column If Tile is enabled, offsets the columns of tiled bitmaps by the percentage 
entered in the box so that two subsequent columns of bitmaps are not aligned.

Creating and importing bitmaps
You can add (import) new bitmap fills or create your own pattern on an 8x8 grid using the Bitmaps 
tab of the Area dialog (Figure 32).

Figure 32: Creating a new bitmap

Creating bitmap fills
1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Bitmap tab to open the Bitmap page.

4) Select Blank as the bitmap type to activate the Pattern Editor.

5) Select the Foreground and Background colors.

6) Start creating the pattern by clicking with the left mouse button the squares (pixels) that you
want in the foreground color. Use the right mouse button to apply the background color. 
Check the preview window to see if the desired effect is achieved.
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7) Click Add to save the pattern and type a name for the new gradient in the dialog that 
opens, then click OK.

8) Click OK to close the dialog.

Note
You only modify bitmaps that you have created in LibreOffice. The bitmaps supplied 
with LibreOffice or imported bitmaps cannot be changed or modified using 
LibreOffice.

Modifying bitmaps
1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Bitmap tab to open the Bitmap page.

4) Select a bitmap that you have created from the list.

5) Make the changes to your bitmap using the Pattern Editor and the color drop down lists.

6) Click Modify to save your changes.

7) If necessary, type a new name in the dialog that opens and click OK.

8) Click OK to close the dialog.

Importing bitmaps
To import a bitmap created in another program:

1) Click Import and a file browser dialog opens.

2) Browse to the directory containing the bitmap file and select it, then click Open.

3) Type a name for the imported bitmap and click OK.

Saving and using new bitmaps
The new bitmap created is available only in the current document. If you want to use this bitmap in 

other documents, click the Save Bitmap List icon  and type a unique filename in the Save as 
dialog that opens. The saved bitmap list has the file extension of .sob.

To use a previously saved bitmap list, click the Load Bitmap List icon  and select from the file 
open dialog. Click Open to load the saved bitmap list into Draw.

Formatting shadows
Shadowing can be applied to lines, shapes and text.

To quickly apply a shadow to a line or shape only, first select the object and then click on the 

Shadow icon  in the Line and Filling toolbar. The shadow applied using this method cannot be 
customized and is set to default settings.

For a more control when adding shadows to an object, you have to use the Shadow page on the 
Area dialog (Figure 33) as follows:

1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.
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Figure 33: Area dialog – Shadow page

3) Click on the Shadow tab to open the Shadow page.

4) Select Use shadow and the shadow options become active.

5) In Position select the direction in which the shadow is cast.

6) In Distance enter a distance in the text box to set spacing between the object and the 
shadow.

7) In Color select a color form the drop down list to determine the color of the shadow.

8) In Transparency enter a percentage in the text box to determine the amount of 
transparency for the shadow.

9) Click OK to save your changes and close the dialog.

Transparency formatting
Transparency is applicable to objects as well as shadows. To apply transparency to lines, refer to 
“Formatting lines” on page 6; for shadows, refer to “Formatting shadows” on page 26.

To apply transparency to objects using the Transparency page on the Area dialog (Figure 34):

1) Select the object you wish to edit.

2) Go to Format > Area on the main menu bar, or click on the Area icon  on the Line and 
Filling toolbar, or right-click on the object and select Area to open the Area dialog.

3) Click on the Transparency tab to open the Transparency page.

4) To create a uniform transparency, select Transparency and enter a percentage in the text 
box.

5) To create a gradient transparency (so that the area becomes gradually transparent) select 
Gradient and select the type of gradient transparency from the drop down list: Linear, 
Axial, Radial, Ellipsoid, Quadratic or Square.

6) Set the parameters for the type of the gradient transparency you selected above. Refer to
Table 4 for a description of the properties. The available parameters will depend on the type
of gradient transparency selected above.

7) Click OK to save your changes and close the dialog.
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Figure 34: Area dialog – Transparency page

Table 4: Gradient transparency properties

Property Meaning

Center X
For Radial, Ellipsoid, Quadratic and Square gradients, modify these values to set
the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Quadratic and Square gradients, modify these values to set
the vertical offset of the gradient center.

Angle
For Linear, Axial, Ellipsoid, Quadratic and Square gradient, specifies the angle of 
the gradient axis.

Border
Increase this value to make the gradient start further away from the border of the 
object.

Start value
Value for the starting transparency gradient. 0% is fully opaque, 100% means 
fully transparent.

End value
Value for the ending transparency gradient. 0% is fully opaque, 100% means fully
transparent.

Using styles

Suppose that you want to apply the same area fill, line thickness, and border to a set of objects. 
This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a 
formatting template (a style) and then to apply that style to multiple objects. For more information 
on styles, see the Writer Guide Chapter 6 Introduction to Styles.

28 Changing Object Attributes



Linked graphics styles
Graphics styles support inheritance; that is, a style can be linked to another (parent) style so that it 
inherits all the formatting settings of the parent. You can use this property to create families of 
styles.

For example, if you need multiple boxes that differ in color but are otherwise identically formatted, 
the best way to proceed is to define a generic style for the box including borders, area fill, font, and
so on. Then create a number of hierarchically dependent styles which differ only in the fill color 
attribute. If you then need to change the font size or the thickness of the border, it is sufficient to 
change the parent style and all the other linked styles will change accordingly.

Creating graphics styles
You can create a new graphics style in two ways:

• Using the Style and Formatting dialog.

• From a selected object.

Figure 35: Styles and Formatting dialog

Using Styles and Formatting dialog

1) Click on the Styles and Formatting  icon on the Line and Filling toolbar or press the 
F11 key to open the Styles and Formatting dialog (Figure 35). 

2) Click on the Graphics Styles icon  in the top left corner of the Styles and Formatting 
dialog. This will open a list of styles available for use with graphics.

3) Select the style you want to use in the Styles and Formatting dialog.

4) Right-click and select New to open the Graphics Styles dialog (Figure 36).

5) Click on the Organizer tab to the Organizer page.

6) Give your new graphics style a memorable file name.

7) Use the various pages and available options in the Graphics Styles dialog to format and 
categorize your new style.

8) Click OK when finished to save your new graphics style and close the dialog.
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Figure 36: Graphics Styles dialog – Organizer page

The Graphics Styles dialog consists of several pages that may be grouped as follows:

• Organizer – contains a summary of the style and its hierarchical position.

• Font, Font Effects, Indents & Spacing, Alignment, Tabs and Asian Typography – set the 
properties of the text inserted in a text box or in a graphic object.

• Dimensioning – used to set the style of dimension lines.

• Text, Text Animation, Connector, Line, Area, Shadowing, and Transparency – determine 
the formatting of a graphic object.

Note
When styles are linked, changing a color for example will change the color in all linked
styles. Sometimes this is exactly what you want; at other times you do not want the 
changes to apply to all linked styles. It pays to plan ahead.

Using a selected object
You can create a new style from an object that has already been formatted. This can be text or 
graphics:

1) Select the object you want to use to create your new style.

2) Open the Styles and Formatting dialog and click the New Style from Selection icon .

3) In the Create Style dialog that opens, type a name for the new style. This dialog also shows
existing custom styles of that are available.

4) Click OK to save the new style.

Modifying a graphics style
To modify an existing style:

1) Right-click on the style in the Styles and Formatting dialog.

2) Select Modify from the context menu to open the Graphic styles dialog and is the same 
dialog used when creating a new graphics style (Figure 36).

3) Make the required changes to the style.

4) Click OK to save your changes and close the dialog.

Updating from a selection
To update a style from a select object:

1) Select an object that uses the format you want to adopt as a style.

2) In the Styles and Formatting dialog, select the style you want to update and then click the 

Update Style icon .
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Applying graphics styles
You can apply a graphics style using the Styles and Formatting dialog. First make sure that the 
graphics styles are shown (Figure 35), then do one of the following:

• Select the object to which you want to apply a graphics style and double-click on the name 
of the style you want to apply.

• Click the Fill Format mode icon , position the cursor on the object to be styled and 
click the mouse button. This mode remains active until you turn it off, so you can apply the 
same style to several objects. To quit Fill Format mode, click the Fill Format mode icon 
again or press the Esc key.

• When Fill Format mode is active, a right-click anywhere in the document cancels the last 
Fill Format action. Be careful not to accidentally right-click and thus undo actions you want 
to keep.

Tip
At the bottom of the Styles and Formatting window is a drop-down list. You can 
choose to show all styles or groups of styles such as applied styles or custom styles.

Deleting graphics styles
You cannot delete any of the predefined styles in LibreOffice, even if you are not using them. You 
can only delete user-defined (custom) styles. However, before you delete a custom style, make 
sure the style is not in use. If an unwanted style is in use, replace it with a substitute style.

To delete custom styles, right-click on a style in the Styles and Formatting dialog and click Delete 
on the context menu. Click Yes in the confirmation box that opens and the style is deleted.

Applying special effects

As well as the basic actions of moving and resizing an object, a number of special effects can also 
be applied to objects in Draw. Several of these effects are readily available in the Mode toolbar 
(Figure 37). If the Mode toolbar is not showing, select it from View > Toolbars > Mode.

This section describes how to rotate, flip, or distort an object, and two ways of setting an object in a
circle.

The tools are described in the following sections with the exception of the 3D rotation tool, which is 
described in Chapter 7 Working with 3D Objects.

Figure 37: Mode toolbar and available tools
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Figure 38: Object selected for rotation

Rotating graphic objects
Rotation of an object can be carried out manually or using a dedicated dialog, just like changing 
object position and size.

Manual rotation
1) Click on an object and the selection handles will show.

2) Click the Rotate icon  in the Line and Filling or Mode toolbars. The selection handles 
change shape and color (Figure 38).

3) If necessary, click and drag the pivot point for rotation to change the way an object is 
rotated. The pivot point is a circle and appears, by default, in the middle of the selected 
object. Normally the center of an object will be just fine, but on some occasions you may 
wish to rotate around a corner or even around a point outside the object.

4) Move the mouse over one of the corner handles and the cursor changes shape.

5) Click the mouse and move in the direction in which you want to rotate the object. Only the 
corner selection handles are active for rotation.

6) To restrict the rotation angles to multiples of 15 degrees, press and hold the Shift key while 
rotating the object. This is very handy for rotating objects through a right angle, for example
from portrait to landscape.

7) When satisfied release the mouse button.

Using the Rotation dialog
Instead of rotating a graphic object manually, you can use the Rotation dialog (Figure 39) for more 
precise control when rotating an object.

1) Select the object so that the selection handles are displayed.

2) Press F4 key, or select Format > Position and Size on the main menu bar, or right-click 
on the object and select Position and Size from the context menu to the Position and Size 
dialog.

3) Click on the Rotation tab to open the Rotation page.

4) In the Pivot point section, enter a figure in Position X and/or Position Y boxes to 
reposition the pivot point relative to the top left corner of the drawing, or select a position for
the pivot point in Default settings. The default position for the pivot point is the center of 
the object.
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Figure 39: Position and Size dialog – Rotation page

5) In the Rotation angle section, enter an angle in the Angle box by which to rotate the 
object, or click and drag the Rotation Angle indicator in Default settings until you reach 
the required angle. As you click and drag, the angle is shown in the Angle box.

6) Click OK to save your changes and close the dialog.

Flipping objects

Quick flipping
The quickest and easiest method to flip an object horizontally or vertically is as follows:

1) Select an object and the selection handles will be displayed.

2) Go to Modify > Flip and select Horizontally or Vertically on the main menu bar, or right-
click and select Flip > Horizontally or Flip > Vertically from the context menu and the 
selected object will be flipped to face the other direction.

Using the Flip tool
The Flip tool on the Mode or Line and Filling toolbars can also be used to flip an object. Using this 
tool, you can also change the position and angle that the object flips over (Figure 40).

1) Select an object and the selection handles will be displayed.

2) Click on the Flip icon  and the axis of symmetry appears as a dashed line through the 
middle of the object. The object will be flipped about this axis of symmetry.

3) Click and drag one or both ends of the axis of symmetry to set the orientation of the axis.

4) Place the cursor over one of the object selection handles until it changes shape.

5) Click and drag the object across to the other side of the axis of symmetry until the object 
will appears flipped over. The angle and position of the flip will depend on the angle and 
position of the axis of symmetry.

6) Release the mouse button and your object is flipped.
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Figure 40: Using the Flip tool

Note
If you press the Shift key while moving the axis of symmetry, it will rotate in 45 degree
increments.

Mirror copies
At the moment there is no mirror command existing in Draw. However, mirroring an object can be 
emulated by using the Flip tool as follows:

1) Select the object you want to make a mirror copy of and copy the object to the clipboard.

2) Select the Flip tool on the Mode or Line and Filling toolbars.

3) Move the axis of symmetry to the desired location of the mirror axis, then flip the object.

4) Click on an empty area of the page to deselect the object.

5) Paste from the clipboard to put a copy of the object back into its original location and now 
you have a mirror copy.

6) If necessary, select both objects and realign them by going to Modify>Alignment on the 
main menu bar, or right-click and select Alignment from the context menu and then select 
the type of alignment.

Distorting images
Three tools on the Mode toolbar let you drag the corners and edges of an object to distort the 
image.

• Distort  distorts an object in perspective.

• Set to Circle (slant)  creates a pseudo three-dimensional effect.
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• Set in Circle (perspective)  creates a pseudo three-dimensional effect.

In all three cases you are initially asked if you want to transform the object to a curve. This is a 
necessary first step, so click Yes. Then you can move the object handles to produce the desired 
effect. The results of using these tools are shown in the following figures.

Distorting

Select an object and click on the Distort icon  on the Mode toolbar. After converting to a curve 
as requested, move the handles to stretch the object. The corner handles distort the corners, the 
vertical midpoint handles distort the figure horizontally and the horizontal ones distort it vertically 
(Figure 41).

Figure 41: Distorting an image

Figure 42: Setting an image to a circle with perspective
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Setting in circle (perspective)

Select an object and click on the Set in Circle (perspective) icon  in the Mode toolbar. After 
converting to a curve, move the object handles to give a pseudo three-dimensional perspective) 
(Figure 42).

Setting to circle (slant)

Select an object and click on the Set to Circle (slant) icon  in the mode toolbar. After 
converting to a curve, move the object handles to give a pseudo three-dimensional slant 
perspective (Figure 43).

Figure 43: Setting an image to a circle with slant

Note
Transforming an object into a curve is a safe operation, but it cannot be reversed 
other than by clicking the Undo button.

Dynamic gradients
You can control transparency gradients in the same manner as color gradients and both types of 
gradient can be used together. With a transparency gradient, the direction and degree of object fill 
color changes from opaque to transparent. In a color gradient, the fill changes from one color to 
another, but the degree of transparency remains the same.

Two icons are present on the Mode toolbar to dynamically control transparency and color 
gradients. Even if you have not assigned transparency to an object with a color fill, you can control 

the transparency by clicking on the Transparency icon . This defines a transparency gradient 
and a dashed line connecting two squares appears on the object. Move the two squares to modify 
the gradient. You can define the direction of the gradient (vertical, horizontal, or at any angle) and 
the spot at which the transparency begins.

A regular color gradient is defined in the same manner. Select an object, then select a gradient fill 

from the Gradients page of the Area dialog (Figure 26 on page 19). The Gradient icon  is now
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active on the Mode toolbar. When you click on the gradient icon, a dashed line connecting two 
squares appears on the object, just as it does for a transparency gradient.

In both transparency gradient and gradient fill, click outside the object to set the gradient.

Note
Moving the squares will have different effects, depending on the type of gradient. For 
example, for a linear gradient, the start and end squares of the gradient will always 
be situated to either side of the center point of the object.

Example 1
A single color object and a transparency gradient, covering part of the underlying object. The 
gradient can be dynamically adjusted; the direction of transparency by moving the white square or 
the distance over which it is applied by moving the black square (Figure 44).

Figure 44: Example 1 of a dynamic gradient

Example 2
An object with a color gradient, completely covering another object. The gradient is adjusted 
dynamically by moving the squares – the color of the square relating to the increase or decrease in
that color (Figure 45).

Figure 45: Example 2 of a dynamic gradient

Example 3
An object with both color and transparency gradients, partly covering the underlying object (Figure 
46).
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Figure 46: Example 3 of a dynamic gradient
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