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Introduction

Connectors and glue points were briefly introduced in Chapter 2 Drawing Basic Shapes. This 
section describes them in more detail and how to use them.

Connectors are lines or arrows whose ends automatically dock to a connection or glue point on an 
object. Connectors are useful when drawing, for example, flowcharts and organization charts. The 
connecting lines between objects remain intact even when objects are moved or rearranged. Also, 
if you copy an object with a connector, the connector is also copied.

Connectors and glue points

Connectors
Draw has a comprehensive selection of connectors to help you connect objects in, for example, a 
flowchart or organization chart. The default set of connectors can be accessed using one of the 
following methods:

• Click the small triangle to the right of the Connector icon on the Drawing toolbar 
(highlighted in Figure 1). The icon changes shape depending on the last connector used.

• Select a connector from Shapes > Default > Connectors on the Sidebar (Figure 2).

The connectors on the Drawing toolbar (Figure 1) can be displayed as a floating toolbar as 
follows:

 1) Click on the small triangle on the right of the Connector icon on the Drawing toolbar.

 2) Click at the top of the pop up toolbar and drag it on to the Workspace.

 3) Release the mouse button and the pop up toolbar becomes a floating toolbar (Figure 3).

Figure 1: Drawing toolbar

Figure 2: Connectors section in 
Shapes deck on Sidebar
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Figure 3: Connectors toolbar

Figure 4: Connectors toolbar - 
Visible Buttons

Connector types
The full range of predefined connectors can be accessed by clicking on the small downward facing 
triangle on the Connectors toolbar and selecting Visible Buttons (Figure 4). The connectors 
available on the toolbar are indicated by a check mark against the name.

Connectors fall into four type groups:

• Standard connectors – connector name starts with Connector. Line segments run 
vertically and horizontally. Draws a connector with one or more 90-degree angle bends. 
Click on an object glue point on an object, drag to a glue point on another object, then 
release.
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• Line connectors – connector name starts with Line. Consists of a line segment with two 
smaller segments at the ends and draws a connector that bends near a glue point. Click on
an object glue point, drag to a glue point on another object, then release. To adjust the 
length of the line segment between a bend point and a glue point, click the connector and 
drag the bend point.

• Straight connectors – connector name starts with Straight. Consists of a single line and 
draws a straight line connector. Click on an object glue point, drag to a glue point on 
another object, then release.

• Curved connectors – connector name starts with Curved. Based on Bézier curves and 
curve around objects. Draws a curved line connector. Click on an object glue point, drag to 
a glue point on another object, then release.

Adding connectors
When you select a connector and move the mouse pointer over a filled object or the edge of an 
unfilled object, glue points appear. A glue point is a fixed point where you can attach a connector 
line. You can also add custom glue points to an object, see “Glue points” on page 7 for more 
information.

To draw a connector, select the connector type and click on a glue point on an object. Drag the 
cursor to a glue point on another object and then release. Figure 5 shows a standard connector 
drawn between two objects. Remember not to drag the connector so that it overlaps or touches 
any objects and creates a confusing drawing. If this does happen, see “Modifying connectors” 
below on how to change the connector route to avoid any objects the connector crosses over.

You can also drag a connector to an empty part of your document. When you release the mouse 
button, the unattached end of the connector is locked into place until you drag the end to a 
different location.

Figure 5: Connector between two objects

Modifying connectors
To detach or reposition a connector, click and drag either end of the connector line to a different 
location.

To change the connector route between objects avoiding any objects on the route, click on a 
control point on the connector line and drag it to a new position. In Figure 5, the control points are 
shown as small red squares.

To modify a connector, right-click on the connector and select Connector from the context menu to
open the Connector dialog (Figure 6). Use this dialog to change connector type and its properties.

• Line skew – defines the skew of the line and the dialog preview displays the result.

• Line spacing – sets the spacing for the connectors.

— Begin horizontal – enter the amount of horizontal space you want at the beginning of 
the connector.
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Figure 6: Connector dialog

— Begin vertical – enter the amount of vertical space you want at the beginning of the 
connector.

— End horizontal – enter the amount of horizontal space you want at the end of the 
connector.

— End vertical – enter the amount of vertical space you want at the end of the connector

• Preview window – a left click zooms in on the preview and a right click zooms out..

Note

You cannot swap the ends of the connector using the Connector dialog, that is start 
point becomes the end point and the end point becomes the start point. To swap the 
ends of a connector, you have to draw a new connector in the opposite direction.

Glue points
Glue points are not the same as the selection handles of an object. The selection handles are for 
moving or changing the shape of an object (see Chapter 3 Working with Objects and Object Points
for more information). Glue points are used to fix or glue a connector to an object so that when the 
object moves, the connector stays fixed to that object.

All Draw objects have glue points, which normally are not displayed and only become visible when 
the Connectors icon on the Drawing toolbar (Figure 1 on page 4) is selected. Note that the 
Connectors icon changes shape depending on the last connector tool used.

To add, customize or delete glue points to an object, go to View > Toolbars > Glue Points on the 
main menu bar to activate the Glue Points toolbar (Figure 7). This toolbar only becomes visible 
after using one of the following methods:

• Click on the Show Glue Point Functions icon on the Standard or Drawing toolbars.

• Select Edit > Glue Points on the main menu bar.
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Figure 7: Glue Points toolbar and Visible 
Buttons

Note

The Show Glue Point Functions icon on the Drawing toolbar is not part of the 
default set of tools for the Drawing toolbar. To add this icon, right click in an empty on 
the Drawing toolbar and select Visible Buttons > Glue Points from the context 
menu.

Glue point types
When the Glue Points toolbar (Figure 7) opens, only the six tools on the left of the toolbar are 
active. The remaining six tools on the right of the toolbar only become active when the Glue Point 
Relative icon is deselected.

The following briefly describes the function of each tool on the Glue Points toolbar (Figure 7).

• Insert Glue Point – inserts a glue point where you click in an object.

• Exit Direction Left – connector attaches to the left edge of the selected glue point.

• Exit Direction Top – connector attaches to the top edge of the selected glue point.

• Exit Direction Right – connector attaches to the right edge of the selected glue point.

• Exit Direction Bottom – connector attaches to the bottom edge of the selected glue point.

• Glue Point Relative – maintains the relative position of a selected glue point when you 
resize an object. This tool is selected by default when the Glue Point toolbar opens.

The following six tools only become active when the Glue Point Relative tool is deselected.

• Glue Point Horizontal Left – when the object is resized, the current glue point remains 
fixed at the left edge of the object.

• Glue Point Horizontal Center – when the object is resized, the current glue point remains 
fixed at the center of the object.

• Glue Point Horizontal Right – when the object is resized, the current glue point remains 
fixed at the right edge of the object.

• Glue Point Vertical Top – when the object is resized, the current glue point remains fixed 
at the top edge of the object.
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• Glue Point Vertical Center – when the object is resized, the current glue point remains 
fixed at the vertical center of the object.

• Glue Point Vertical Bottom – when the object is resized, the current glue point remains 
fixed at the bottom edge of the object.

Note

Each glue point you have added can have only one horizontal position and one vertical
position. Only one of the horizontal position tools and one of the vertical position tools 
can be selected and used at any one time.

Adding glue points
By default, most objects normally have four glue points. Add additional glue points to an object as 
follows:

 1) Make sure no objects are selected and use one of the following methods to open the Glue 
Points toolbar:

— Click on the Show Glue Point Functions icon on the Standard or Drawing toolbars.

— Select Edit > Glue Points on the main menu bar.

 2) If the Glue Points toolbar does not open, go to View > Toolbars > Glue Points on the 
main menu bar.

 3) Select the object and then the Insert Glue Point icon, or right click on a glue point you 
have previously inserted and select Insert Glue Point from the context menu.

 4) Move your cursor to a position where you want the glue point on an object and click to 
insert the glue point.

 5) To move a glue point to another position, click on the glue point and drag it to its new 
position.

Tip

When adding, moving or customizing glue points, it is recommended to use the zoom 
function to make it easier to work with glue points. See Chapter 3 Working with 
Objects and Object Points for more information. Also, glue points snap to the grid 
making it easier to position a glue point.

Customizing glue points
Only glue points that have been added to an object can be customized. The default glue points 
included with an object cannot be customized.

Customize the exit direction for the added glue point as follow:

 1) Make sure no objects are selected and use one of the following methods to activate glue 
points that have been added to an object:

— Click on the Show Glue Point Functions icon on the Standard or Drawing toolbars.

— Select Edit > Glue Points on the main menu bar

 2) If the Glue Points toolbar does not open, go to View > Toolbars > Glue Points on the 
main menu bar.

 3) Double-click on a glue point that you have added to select the glue point for customization.
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 4) Select an exit direction you want to use for the connector you will be attaching to the glue 
point from the Glue Points toolbar (Figure 7 on page 8), or right click on the glue point and 
select the exit direction from the context menu.

Customize the horizontal and vertical positioning for the added glue point as follow:

 1) Make sure no objects are selected and use one of the following methods to activate glue 
points that have been added to an object:

— Click on the Show Glue Point Functions icon on the Standard or Drawing toolbars.

— Select Edit > Glue Points on the main menu bar

 2) If the Glue Points toolbar does not open, go to View > Toolbars > Glue Points on the 
main menu bar.

 3) Double-click on a glue point that you have added to select the glue point for customization.

 4) Click on the Glue Point Relative icon on the Glue Points toolbar (Figure 7 on page 8) to 
deselect this tool, or right-click on the glue point and deselect Glue Point Relative from the
context menu.

 5) Select the horizontal and vertical positioning tools you want to use for the glue point. Only 
one horizontal positioning tool and one vertical positioning tool can be used at any one 
time.

Deleting glue points
Only glue points that have been added to an object can be deleted. The default glue points 
included with an object cannot be deleted.

 1) Select the glue point you have previously added and now want to delete.

 2) Press the Delete key or go to Edit > Cut on the main menu bar.

Connector text
Text can be easily added to connectors, then formatted or edited to make, for example, your 
flowchart or organization chart easier to follow. See Chapter 2 Drawing Basic Shapes and Chapter 
9 Adding and Formatting Text for more information on working with text.

Figure 8: Text Formatting toolbar

Adding text
 1) Select the connector and the control points become active.

 2) Click on the Text icon or Text Vertical icon (if active) on the Standard toolbar. A flashing 
text cursor appears close to the connector and the Text Formatting toolbar (Figure 8) 
opens.

 3) If necessary, use the tools available on the Text Formatting toolbar or go to Format > Text
on the main menu bar to change the text format.

 4) Type the text and, when you have finished typing your text, move the cursor away from the 
text and connector and click to end the text mode. This also closes the Text Formatting 
toolbar.
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Figure 9: Text dialog – Text page

Figure 10: Text dialog – Text Animation page

Formatting and editing text
 1) Select the connector and the control points become active.

 2) Click on the Text icon or Text Vertical icon (if active) on the Standard toolbar and the Text 
Formatting toolbar (Figure 8) opens.

 3) Use the tools available on the Text Formatting toolbar or go to Format > Text on the main 
menu bar to change the text format.

 4) Right-click on the connector text and select Text from the context menu to open the Text 
dialog (Figure 9) allowing you to change how the text appears next to the connector:

— Drawing Object Text – allows you to fit the text to the connector rectangle (frame) or 
allow the text to follow the contour of the connector.

— Spacing to Borders – creates margins around the text within the connector rectangle.

— Text Anchor – positions the text within the connector rectangle.
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 5) If required, click on the Text Animation tab (Figure 10) where you can select options to 
animate the text. However, this is not recommended unless you are going to display the 
drawing as part of a presentation. See the Impress Guide for more information on text 
animation.

 6) When you have finished editing the text, move the cursor away from text and connector 
and click to end the text mode. This also closes the Text Formatting toolbar.

Flowcharts

For drawing flowcharts (also known as flow diagrams), Draw has a Flowchart toolbar (Figure 11) 
that includes a large selection of flowchart tools to help you to easily draw a flowchart. To open the 
Flowchart toolbar:

 1) Click on the small triangle to the right of the Flowchart icon on the Drawing toolbar to 
open the Flowchart pop up menu. Note that this icon changes shape depending on the last
flowchart tool used.

 2) Click at the top of the Flowchart menu and drag it into your workspace.

 3) Release the mouse button and the Flowchart menu becomes a floating Flowchart toolbar.

Figure 11: Flowchart toolbar and Visible Buttons
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Recommended basic steps to follow when creating a flowchart:

 1) When adding objects to your flowchart, see Chapter 2 Drawing Basic Shapes for 
information on how to draw and resize object shapes.

 2) Add text to each flowchart shape to make it easily identified in the flowchart. See Chapter 2
Drawing Basic Shapes and Chapter 11 Advanced Draw Techniques for more information.

 3) Use connections lines in your flowchart. This allows repositioning of an object in your chart 
while maintaining connections with the other objects in the chart. See “Connectors and glue
points” on page 4 for more information.

 4) Use the zoom, grid and snap functions to help in positioning objects in your flowchart. See 
Chapter 3 Working with Objects and Object Points for more information.

 5) Use the alignment and distribution functions to give your flowchart a more professional 
look. See Chapter 5 Combining Multiple Objects for more information.

 6) Duplicate objects when you require more than one of the same shape and size. See 
Chapter 5 Combining Multiple Objects for more information.

Organization charts

Draw does not have a toolbar for organization charts, but these charts are easily created using 
basic shapes, flowchart shapes, connection points and connector lines. Hierarchy in an 
organization is easily indicated using shading and/or color. When using shading and color in an 
organization chart, make sure that your selection provides a good contrast between the text and 
the shading or color to make the chart easy to read on a computer display or in a printed 
document.

Figure 12: Example organization chart

An example of an organization chart is shown in Figure 12. This was drawn using the process 
shape from the Flowchart toolbar and connection lines.

 1) When adding objects to your chart, see Chapter 2 Drawing Basic Shapes for information on
how to draw and resize object shapes.

 2) Add text to each object in the organization chart to make it easily identified in the chart. See
Chapter 2 Drawing Basic Shapes and Chapter 11 Advanced Draw Techniques for more 
information.

 3) Use connections lines in your organization chart. This allows repositioning of an object in 
your chart while maintaining connections with the other objects in the chart. See 
“Connectors and glue points” on page 4 for more information.

 4) Use the zoom, grid and snap functions to help in positioning objects in your chart. See 
Chapter 3 Working with Objects and Object Points for more information.

 5) Use the alignment and distribution functions to give your organization chart a more 
professional look. See Chapter 5 Combining Multiple Objects for more information.

 6) Duplicate objects when you require more than one of the same shape and size. See 
Chapter 5 Combining Multiple Objects for more information.
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