
Draw Guide

Chapter 1,
Introducing Draw



Copyright

This document is Copyright © 2021 by the LibreOffice Documentation Team. Contributors are 
listed below. This document maybe distributed and/or modified under the terms of either the GNU
General Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative
Commons Attribution License (https://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

To this edition.

Peter Schofield Regina Henschel Elzett Kotze

To previous editions.

Martin Fox John Cleland Jean Hollis Weber
John A Smith Peter Schofield Vipul Gupta
Kees Kriek

Feedback

Please direct any comments or suggestions about this document to the Documentation Team 
mailing list: documentation@global.libreoffice.org

Note

Everything sent to a mailing list, including email addresses and any other personal 
information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version

Published July 2021. Based on LibreOffice 7.1 Community. Other versions of LibreOffice may 
differ in appearance and functionality.

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and 
Linux. Table 1 below gives some common substitutions for the instructions in this user guide. For 
a more detailed list, see the application Help.

Table 1: Using LibreOffice on macOS

Windows or Linux macOS equivalent Effect
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Open a context menu

Ctrl (Control) ⌘ (Command) Used with other keys
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Introduction

LibreOffice Draw is a vector graphics drawing program, although it can also perform some 
operations on raster graphics (pixels). Using Draw, a wide variety of graphical images can easily 
and quickly created.

Vector graphics store and display an image as an assembly of simple geometric elements such 
as lines, circles, and polygons, rather than a collection of pixels (points on the screen). Vector 
graphics allow for easier storage and scaling of the image.

Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with all 
components of the suite. If an image is created in Draw, reusing it in a Writer document is 
relatively easy, for example, select and copy the drawing in Draw and then paste the image 
directly into a Writer document. Also, drawings can be worked on directly from within Writer or 
Impress, using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive. Draw was not designed to rival high-end 
graphics applications, but it possesses more functionality than the drawing tools that are 
generally integrated with the majority of office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, 
dimensions and measurement display, connectors for making organization charts, 3D functions 
that enable small three-dimensional drawings to be created (with texture and lighting effects), 
drawing and page-style integration, and Bézier curves.

This Draw Guide is not a course book to be worked through from beginning to end. Rather, it is a 
reference work in which can be browsed for guidance on particular topics.

This document describes only the functions associated with Draw. Some concepts, such as file 
management or the way the LibreOffice environment works, are mentioned only briefly and are 
covered in more detail in the Getting Started Guide.

Draw main window

Workspace

The large area in the center of the Draw main window is the Workspace (Figure 1) where 
drawings are created. This drawing area can be surrounded with toolbars and information areas. 
The number and position of the visible tools vary with the task in hand, user preferences, and 
computer setup.

The maximum size of a drawing page in LibreOffice Draw is limited by the computer setup and 
the page size that that can be set and used in the printer connected to the computer.

Pages pane

Drawings in Draw can be split over several pages. Multi-page drawings are used mainly for 
presentations. The Pages pane, on the left side of the Draw main window, gives an overview of 
the pages that created in a drawing. If the Pages pane is not visible, go to View > Page Pane on 
the Menu bar. To make changes to the page order, drag and drop one or more pages.
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Figure 1: Draw main window

Layers bar

By default, the Workspace consists of three layers (Layout, Controls and Dimension Lines) 
and the tabs for these default layers appear at the bottom of the Workspace. The default layers 
cannot be deleted or renamed, but layers can be added as and when necessary. A layer is a 
workspace where drawing elements and objects can be inserted.

The Layers bar is located on the bottom of the Workplace and contains three default layers called
Layout, Controls and Dimensions. The default layers cannot be deleted or renamed, but layers
can be added when necessary.

Tabs for layers appear in the Layers bar at the bottom of the Workspace, which is located at the 
bottom of the Workplace. The Layers bar allows for navigation between layers, adding layers as 
required, or deleting layers that have been created. For more information on layers, see 
Chapter 11, Advanced Draw Techniques.

Sidebar

The Sidebar has five main decks in Draw and is similar to the Sidebar in the other LibreOffice 
modules. To open a deck, click on its icon on the right of the Sidebar, or click on Sidebar 
Settings icon at the top of the tab bar and select a deck from the drop-down list. If the Sidebar is 
not visible, go to View > Sidebar on the Menu bar.

Properties
Contains sections for object properties, for example, Page, Character, Paragraph, Area, 
Effect, Shadow, Image, Line, and Position and Size. Available sections depends on the 
object selected.

Shapes
Provides quick selection of most items that are available on the Drawing toolbar: Lines and 
Arrows, Curves and Polygons, Connectors, Basic Shapes, Symbol Shapes, Block Arrows, 
Flowchart, Callouts, Stars and Banners, and 3D Objects.
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Styles
Provides options to edit and apply Drawing Styles to objects within a drawing. When a style
is edited or modified, the changes are automatically applied to all of the elements formatted
using that style. In Draw, Presentation Styles are not available.

Gallery
From the Gallery deck, objects can be inserted into a drawing either as a copy or as a link. 
The Gallery is divided into categories: Arrows, BPMN (Business Process Model and 
Notation), Bullets, Diagrams, Flowchart, Icons, Network, Shapes, and Sounds. See 
Chapter 11, Advanced Draw Techniques for more information on using the Gallery.

Navigator
On the Navigator deck, pages and objects in a drawing can be quickly selected. It is 
recommended to give pages and objects in a drawing meaningful names so that they are 
easily identified when using the Navigator.

Rulers

Rulers are positioned on the upper and left-hand sides of the Workspace. If they are not visible, 
go to View > Rulers in the Menu bar. The rulers show the size of a selected object on the page 
using double lines (highlighted in Figure 2). Also, rulers can be used to manage object handles 
and guide lines when positioning objects.

The page margins in the drawing area are also represented on the rulers. Change the margins 
directly on the rulers by dragging them with the cursor. The margin areas are indicated by the 
grayed out area on the rulers as shown in Figure 2.

To change the measurement units of the rulers, right-click on a ruler and select the measurement
unit from the drop down list, as shown in Figure 3 for the horizontal ruler. Measurement units for 
the horizontal and vertical rulers can be set to different measurement units.

Status bar

The Status Bar (Figure 4) is located at the bottom of the Workspace in all LibreOffice modules. 
To hide the Status Bar, go to View on the Menu bar and deselect Status Bar.

Note

The measurement units shown on the Status Bar are set by going to Tools > 
Options > LibreOffice Draw > General on the Menu bar. These measurement units
can be different to the measurement units set for the rulers.

Figure 2: Rulers showing object size
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Figure 3: Ruler measurement units

Figure 4: Status bar

• Slide number – shows the number of the drawing pane that is selected.

• Information area – shows which action is being carried out, or object type selected.

• Cursor position and Object size – shows different information depending on whether 
objects are selected or not.

– When no object is selected, the position numbers show the current position (X and Y 
coordinates) of the mouse cursor.

– When an object is selected and being resized with the mouse, the object size 
numbers show the size of the object (width and height).

– If an object is selected, the position numbers shows the X and Y coordinates of the 
upper-left corner and the object size number pair displays the size of the object. 
These numbers do not relate to the object itself, but to the selection outline, which is 
the smallest possible rectangle that can contain the visible part or parts of the object; 
see Chapter 3, Working with Objects and Object Points for more information.

– When an object is selected, clicking in either of these areas opens the Position and 
Size dialog. See Chapter 4, Changing Object Attributes for more information.

• Unsaved changes – indicates that the file needs saving and the icon depends on 
computer setup. Clicking on this icon opens the Save as dialog if the file is new and has 
not been saved before. If the file has been saved before any changes, then clicking on 
this icon after any changes automatically saves the file.

• Digital signature – indicates if the document is digitally signed. The icon only appears if 
the drawing has a digital signature certificate. After the file has been saved, double-
clicking on this icon opens the digital signatures dialog. See LibreOffice Help for more 
information on digital signature certificates.

• Fit drawing – resizes the drawing so that the whole drawing appears in the Workspace.

• Zoom slider and Zoom percentage – adjusts and indicates the zoom percentage of the 
Workspace displayed. Double-clicking on zoom percentage opens the Zoom & View 
Layout dialog.
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Figure 5: Visible buttons on a toolbar

Toolbars

To display or hide the various Draw toolbars, go to View > Toolbars on the Menu bar and select 
from the drop down menu the toolbar required. For example, the Standard and Drawing toolbars 
are shown by default, but the Line and Filling, Text Formatting, and Options toolbars are not 
shown.

The appearance of the tool icons on toolbars depends on the computer operating system and the
selection of icon style and size in Tools > Options > LibreOffice > View. 

The tools available on a toolbar are indicated by a shaded outline around the tool icon or a check
mark as shown by the example in Figure 5. For more information about working with toolbars, 
see the Getting Started Guide.

The four main toolbars used in Draw are as follows:

Standard toolbar
The Standard toolbar (Figure 6) is the same for all LibreOffice components and is not 
described in detail in this chapter. By default, it is locked into position at the top of the Draw 
main window.

Figure 6: Standard toolbar

Drawing toolbar
The Drawing toolbar (Figure 7) contains all the necessary functions for drawing various 
geometric and freehand shapes, and for organizing them in the drawing. By default, it is 
locked into position on the left of the Draw main window. It is described in detail in 
Chapter 2, Drawing Basic Shapes.
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Figure 7: Drawing toolbar

Line and Filling toolbar
The Line and Filling toolbar (Figure 8) is used to modify the main properties of a drawing 
object. The tools and pull-down lists vary according to the type of object selected. For 
example, to change the style of a line, click on the up and down arrows for Line Style and 
select the required style.

The functions on the Line and Filling toolbar are used to change the color, style, and width 
of the line drawn, the fill color and style, and other properties of a selected object. If the 
selected object is a text frame, the Line and Filling toolbar is replaced by the Text 
Formatting toolbar. For more information, see Chapter, 4 Changing Object Attributes.

Figure 8: Line and Filling toolbar

Text Formatting toolbar
The Text Formatting toolbar (Figure 9) is similar to the Formatting toolbar in Writer. It is only
available when a text object has been selected in a drawing, replacing the Line and Filling 
toolbar. For more information, see Chapter, 4 Changing Object Attributes, and Chapter 9 
Adding and Formatting Text.

Figure 9: Text Formatting toolbar

Adding and removing tools

The default set of tools on each toolbar can be modified using Visible Buttons. Add or remove a
tool to or from a toolbar as follows:

1) Either, right-click in an empty area on the toolbar, or click on the downward pointing 
triangle ▼ in the toolbar title and select Visible Buttons from the context menu.

2) Click on a tool name to add or remove the tool to or from the toolbar.

Note

For more information on the available tools that can be added to a toolbar, see 
Appendix B, Toolbars and the Getting Started Guide. When a tool is added to a 
toolbar, its position on the toolbar (from left to right) is the same as its position in the 
Visible Buttons context menu.
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Available toolsets

Some tools on a toolbar have a downward pointing triangle ▼ to the right side of the tool icon. 
This indicates that the tool has additional tools available. Click on the downward pointing 
triangle ▼ to display the full set of tools (Figure 10).

This toolset can be turned into a floating toolbar. Click the area at the top of the toolset as shown 
in Figure 10, drag it across the screen to a convenient location and release the mouse button. To 
close a floating toolbar, click on the X on the right of the toolbar title.

Figure 10: Available tools and floating toolbar

Note

When a toolset is made into a floating toolbar, the tool on the existing toolbar 
remains in the toolbar and always shows the last tool used. This means that the tool 
icon on a screen may differ from the tool icon shown in this guide.

Tip

When double-clicking on a tool, the command corresponding to that tool becomes 
active and remains active. The tool command can be repeated as often as required. 
To exit from this mode, press the Esc key or click on another tool. Please note that 
this may not work for every tool on every toolbar.

Docked and floating toolbars

When Draw is opened, the Standard and Drawing toolbars, by default, are already locked and 
docked into their positions on the main Draw window. These toolbars can be undocked creating 
floating toolbars. To undock a toolbar and create a floating toolbar:

1) Move the mouse cursor to the far left of the toolbar and over the toolbar handle 
(Figure 11). The cursor changes shape, normally a grabbing hand, depending on 
computer setup and operating system.

2) Click and drag on the toolbar handle to move the toolbar until it becomes a floating 
toolbar. This floating toolbar capability is common to all components of LibreOffice.

Figure 11: Toolbar handles
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To dock a floating toolbar, press and hold the Ctrl key, then double click on the title of the toolbar. 
The toolbar moves into available space at the top of the Draw main window.

An alternative method of docking a toolbar is to click in the toolbar title and drag the toolbar to the
docked position that required. This can be the top, bottom or one of the sides of the Draw main 
window.

Unlocking and locking toolbars

By default when Draw is opened, any docked toolbars are locked into position and have to be 
unlocked before they can become floating toolbars or repositioned on the Draw main window.

To unlock a toolbar, right-click in a blank area on the toolbar and deselect Lock Toolbar Position
from the context menu. A toolbar handle, as shown in Figure 11, appears at the left end of the 
toolbar, indicating that the toolbar is unlocked and can be moved.

To lock a toolbar into position, dock the toolbar into position, then right-click in a blank area on 
the toolbar and select Lock Toolbar Position from the context menu. The toolbar handle 
disappears from the left end of the toolbar.

Customizing toolbars

Draw toolbars can be customized by adding or removing commands to or from a toolbar. Also, 
customization allows the creation of toolbars for specific purposes. Customizing toolbars is in 
addition to using “Adding and removing tools” above.

For more information when adding a new commands, modifying toolbars, or creating toolbars, 
see Appendix B, Toolbars and the Getting Started Guide.

Choosing and defining colors

Color palette

The Color Palette (Figure 12) provides quick access to a standard set of colors to use for 
selected objects and text in a drawing.

1) Go to View on the Menu bar and select Color Bar to open the Color Palette.

2) Select an object or text where to change the color.

3) Left click on the color required for the area fill or text and change the color of the object or
text.

4) Right click on the color required for the object or text box border and change the color of 
the border.

5)  Go to View on the Menu bar and deselect Color Bar to close the Color Palette.

Figure 12: Color Palette (Color Bar)
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Note

The box with the X at the bottom left of the Color Palette corresponds to none (no 
color).

Note

The colors available in the Color Palette depend on the color palette that had been 
previously used when changing color on an object. For example, Figure 12 shows 
the Standard color palette that had been used previously when changing color to an 
object using a properties dialog.

Specialized color palettes

In addition to the standard Color Palette, Draw has several specialized color palettes available, 
giving a greater choice of color: for example, chart-palettes, material, html, and so on. After 
selecting an object or text in a drawing, use one of the following to access the specialized color 
palettes.

• Area or fill color – Color page in the Area dialog, Fill Color on the Drawing or Line and 
Filling toolbar, or Fill in the Area section in the Properties deck on the Sidebar.

• Line color – Line page in the Line dialog, Line Color on the Drawing or Line and Filling 
toolbar, or Color in the Line section in the Properties deck on the Sidebar

• Text color – Font Color tool on the Text Formatting toolbar, or Font Color in the 
Character section in the Properties deck on the Sidebar.

For more information on selecting a color and a color palette for an object or text, see Chapter 4, 
Changing Object Attributes, Chapter 9, Adding and Formatting Text and Chapter 11, Advanced 
Draw Techniques.

Custom colors

In Draw, custom colors can be created using the Color Picker dialog, specific CMYK values, or 
specific RGB values to match the color schemes used in a company. For more detailed 
information on creating custom colors and color palettes, as well as more information on CMYK 
and RGB color schemes, refer to Chapter 11, Advanced Draw Techniques.

Grid, snap, and help lines

The grid and snap lines in Draw act as drawing aids and these can be turned on or off by clicking
on Display Grid or Display Snap Guides on the Line and Filling or Options toolbars. The grid 
and snap lines are displayed only on the screen and are not shown on a printed drawing or when
the drawing is used in another LibreOffice module. The color, spacing and resolution of the grid 
points can be individually chosen for each axis.

Help lines when moving objects can be displayed and these are turned on or off by clicking on 
Helplines While Moving on the Line and Filling or Options toolbars. Showing the position of the 
object while moving makes positioning the object much easier. If this function is activated, pairs 
of vertical and horizontal lines enclosing the object are shown while moving the object. These 
lines extend to the edges of the drawing area.

Draw also offers several snap functions to positioning of objects exactly in a drawing.

For more information on the grid, snap lines, snap functions, and help lines, see Chapter 3, 
Working with Objects and Object Points.
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