Chapter 3
Working with Objects
Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this document. For a detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control +click and/or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open the Styles deck in the Sidebar</td>
</tr>
</tbody>
</table>
# Contents

Copyright................................................................................................................................................. 2  
Contributors................................................................................................................................................ 2  
Feedback.................................................................................................................................................... 2  
Publication date and software version.................................................................................................................. 2  
Using LibreOffice on macOS.................................................................................................................................. 2  

## Introduction.................................................................................................................................................. 5  

## Selecting objects....................................................................................................................................... 5  
Direct selection.................................................................................................................................................. 5  
Selection by framing......................................................................................................................................... 5  
Selecting hidden objects................................................................................................................................... 5  
Arranging objects................................................................................................................................................ 6  

## Positioning and adjusting objects............................................................................................................ 6  
Using zoom...................................................................................................................................................... 6  
Status bar.......................................................................................................................................................... 7  
Zoom & View Layout dialog............................................................................................................................... 7  
Zoom toolbar.................................................................................................................................................... 8  
Moving and adjusting object size....................................................................................................................... 9  
Moving objects.................................................................................................................................................. 9  
Adjusting object size....................................................................................................................................... 9  
Modifying arcs................................................................................................................................................ 10  
Rotating and slanting objects............................................................................................................................ 10  
Rotating objects............................................................................................................................................... 10  
Slanting objects............................................................................................................................................... 11  
Setting exact position, size, rotation and slant.................................................................................................. 12  
Position and Size.............................................................................................................................................. 13  
Rotating objects............................................................................................................................................... 15  
Slant and corner radius................................................................................................................................... 15  

## Using grid and snap functions.................................................................................................................. 16  
Configuring grid and snap functions................................................................................................................ 17  
Snap to grid..................................................................................................................................................... 18  
Using Snap to Grid........................................................................................................................................ 18  
Displaying grid............................................................................................................................................... 18  
Changing color of grid points.......................................................................................................................... 18  
Snap points and lines....................................................................................................................................... 18  
Inserting snap points and snap lines................................................................................................................ 19  
Displaying snap points and lines...................................................................................................................... 20  
Editing snap points and lines.......................................................................................................................... 20  
Deleting snap points and lines......................................................................................................................... 21  
Configuring snap range................................................................................................................................... 21  

## Using Helplines.......................................................................................................................................... 22  

## Changing object shape.............................................................................................................................. 22  
Regular shapes.............................................................................................................................................. 22  
Basic shapes................................................................................................................................................... 22  
Symbol Shapes............................................................................................................................................... 23  
Block Arrows.................................................................................................................................................. 23  
Callouts............................................................................................................................................................ 24
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stars and Banners</td>
<td>24</td>
</tr>
<tr>
<td>Curves and polygons</td>
<td>25</td>
</tr>
<tr>
<td>Bézier curves</td>
<td>25</td>
</tr>
<tr>
<td>Converting objects to curve or polygon</td>
<td>25</td>
</tr>
<tr>
<td>Editing points</td>
<td>25</td>
</tr>
<tr>
<td>Point types</td>
<td>26</td>
</tr>
<tr>
<td>Tangents</td>
<td>27</td>
</tr>
<tr>
<td>Symmetric transition</td>
<td>27</td>
</tr>
<tr>
<td>Smooth transition</td>
<td>28</td>
</tr>
<tr>
<td>Corner point</td>
<td>28</td>
</tr>
<tr>
<td>Points</td>
<td>29</td>
</tr>
<tr>
<td>Moving points</td>
<td>29</td>
</tr>
<tr>
<td>Inserting points</td>
<td>29</td>
</tr>
<tr>
<td>Deleting points</td>
<td>30</td>
</tr>
<tr>
<td>Eliminating points</td>
<td>31</td>
</tr>
<tr>
<td>Converting curves or lines</td>
<td>31</td>
</tr>
<tr>
<td>Splitting objects</td>
<td>31</td>
</tr>
<tr>
<td>Closing objects</td>
<td>32</td>
</tr>
<tr>
<td>Distorting objects</td>
<td>33</td>
</tr>
</tbody>
</table>
Introduction

This chapter looks at the tools and functions to modify existing drawings. All of the functions apply to a selected object or a group of selected objects, which can be distinguished by selection handles on a rectangular frame that is large enough to contain the object. Where several objects are selected, the frame around the objects corresponds to the smallest rectangle that can contain all of the objects. This frame is called the selection rectangle.

Note

The color and shape of the selection handles changes depending on the tool and function that has been selected to change the object properties. The color of the selection handles also depends on the computer operating system and how the computer has been set up.

Selecting objects

Direct selection

The easiest way to select an object is to click directly on it. For objects that are not filled, click on the object border to select it. To select more than one object, hold the Shift key down while clicking on objects. To deselect an object, move the cursor into a blank space on the drawing and click.

Selection by framing

Several objects can be selected at once by clicking and dragging the cursor around the objects drawing a selection rectangle around the objects. Only objects that lie entirely within this selection rectangle are selected. To select multiple objects by framing, Select on the Drawing toolbar must be active, as shown in Figure 1.

Figure 1: Drawing toolbar

Note

When a cursor is dragged to select multiple objects, the selection rectangle being created is also known as a marquee.

Selecting hidden objects

If objects are located behind others and not visible, they can still be selected. When a hidden object is selected, its selection handles appear through the objects covering it.

- Windows, Mac or Linux – press the Tab key to select and cycle through the selection of objects in a drawing, stopping at the hidden object to select it. To cycle through the objects in reverse order, press Shift+Tab.
• **Windows or Mac only** – select the object in front of a hidden object, then press the *Alt* key and click to select the hidden object. If there are several hidden objects, keep holding down the *Alt* key and clicking until the object required is reached. To cycle through the objects in reverse order, hold down the *Alt+Shift* keys and click.

### Arranging objects

In a complex drawing, several objects may be stacked on top of one another. This stacking order can be rearranged by moving an object forward or backward using one of the following methods:

- Select an object, go to **Shape > Arrange** on the Menu bar, or right-click on the object and select **Arrange** from the drop down menu, then select one of the following options:
  - Bring to Front (*Ctrl+Shift++*)
  - Bring Forward (*Ctrl++*)
  - Send Backward (*Ctrl+-*)
  - Send to Back (*Ctrl+Shift+-*)
  - In Front of Object
  - Behind Object

- Select an object, then select one of the **Arrange** tools at the left end of the Line and Filling toolbar (Figure 2). When the cursor is hovered over a tool, its function is indicated.

![Line and Filling toolbar](image)

*Figure 2: Line and Filling toolbar*

**Note**

The Line and Filling toolbar is not visible in the default installation of LibreOffice. To make this toolbar visible, go to **View > Toolbars > Line and Filling** on the Menu bar.

### Positioning and adjusting objects

#### Using zoom

To help in the positioning and adjustment of objects, Draw has a zoom function that reduces or enlarges the screen display of the current drawing. For example, zoom in to position objects on a drawing with greater accuracy; zoom out to see the complete drawing. Zooming is controlled using the Status Bar, Zoom & View Layout dialog, or Zoom1 toolbar.

**Note**

Zooming is handled differently in Linux and Windows operating systems. A drawing saved with a 100% zoom factor in Windows is displayed at a larger zoom factor in Linux.
The zoom controls are located on the right side of the Status Bar (Figure 3) and these controls give quick and easy access to zooming.

- **Fit slide to current window** – fits the drawing to the open window.
- **Minus sign (-)** – reduces the zoom factor
- **Plus sign (+)** – increases the zoom factor.
- **Click and drag the zoom slider to increase or decrease the zoom factor.**
- **Right-click on the zoom percentage number and select a zoom factor from the context menu that opens.**
- **Go to View > Zoom > Zoom on the Menu bar to open the Zoom & View Layout dialog (Figure 4) or double-click on the zoom percentage number and select a zoom factor from the Zoom & View Layout dialog.**

### Zoom & View Layout dialog

The Zoom & View Layout dialog provides the following options to control how a drawing is viewed on a monitor.

- **Zoom Factor** – sets the zoom factor at which to display the current document and all documents of the same type that are subsequently opened.
  - **Optimal** – resizes the display to fit the width of the text in the document.
  - **Fit width and height** – displays the entire page on the screen.
– **Fit width** – displays the complete width of the document page. The top and bottom edges of the page may not be visible.
– **100%** – displays the document at its actual size.
– **Variable** – enter a percentage in the box for the zoom factor to display the document.

- **View Layout** – used to set the view layout and is not available for drawings. View layout is normally used in text documents to see the effects of different layout settings.

**Zoom toolbar**

Go to **View > Toolbars > Zoom** on the Menu bar to open the Zoom toolbar (Figure 5). The tools available on this toolbar, from left to right, are as follows:

- **Zoom In** – displays the drawing at two times its current size each time the tool is selected.
- **Zoom Out** – displays the drawing at half its current size each time the tool is selected.
- **100%** – displays the drawing at its actual size.
- **Zoom Previous** – returns the display of the drawing to the previous zoom factor applied.
- **Zoom Next** – undoes the action of the previous zoom command.
- **Entire Page** – displays the whole drawing in the Workspace.
- **Page Width** – displays the complete width of the drawing. The top and bottom edges of the slide may not be visible.
- **Optimal** – resizes the display to include all of the objects on the slide.
- **Object Zoom** – resizes the display to fit the selected object(s).
- **Zoom & Pan** – zooms in for each mouse click. *Ctrl+click* zooms out for each click. *Shift+click* allows panning of the drawing.
- **Shift** – moves the drawing within the Draw workspace. Place the cursor on the drawing and drag to move the drawing.

![Zoom toolbar](image)

*Figure 5: Zoom toolbar*

![Left end of Status Bar](image)

*Figure 6: Left end of Status Bar when working with objects*
Moving and adjusting object size

When moving an object or changing its size, check the left-hand area of the Status Bar at the bottom of the Workspace (Figure 6). From left to right, this area shows that a shape is selected, its position on the drawing in X/Y coordinates and dimensions of the object. The measurement units are those selected in **Tools > Options > LibreOffice Draw > General**.

Moving objects

To move an object (or a group of objects), select it and then click and drag within the object borders. During movement, a ghost image of the object appears to help with repositioning (Figure 7). When the object reaches its new location, release the mouse button.

Adjusting object size

To change the size of a selected object (or a group of selected objects), move the mouse cursor to one of the selection handles. The cursor changes shape to indicate the direction of movement for that selection handle. As the object size changes, a ghosted outline of the object appears (Figure 8). When the desired size of the object is reached, release the mouse button.

The results depend on which selection handle is used. To resize an object along one axis, use a side, top, or bottom handle. To resize along both axes, use a corner handle.

**Note**

Press and hold the **Shift** key while resizing an object, the change in size will be carried out symmetrically with respect to the object width and height so that the aspect ratio of the object remains the same. This **Shift** key behavior works on all selection handles.
Modifying arcs

The size of an arc can be changed by adjusting the positions of the start and end points of an arc. Select an arc, then right click on the arc and select **Points** from the drop down menu or press the *F8* key. Two handles appear at the start and end of the arc (Figure 9). Click on one of these handles and drag it to a new position to change the shape of the arc.

Rotating and slanting objects

Rotating objects

To rotate an object (or a group of objects), select the object, then go to rotation mode using one of the following methods.

1) Select or click on an object

2) Use one of the following methods to switch to rotation mode. The selection handles change shape and color and a center of rotation indicator appears in the center of the object, as shown in Figure 10.
   - Click again on a selected object.
   - Click on the triangle ▼ on the right of **Transformations** on the Line and Filling toolbar and select **Rotate** from the pop up menu.
   - Go to **View > Toolbars > Transformations** on the Menu bar to open the Transformations toolbar (Figure 11) and select **Rotate**.

![Figure 9: Modifying arcs](image)

![Figure 10: Rotating objects](image)
3) Move the cursor over the handles and the cursor changes shape. The corner handles are for rotating the object, and the top, bottom and side handles are to shear or slant the object.

Note

The rotation center is normally located at the center of an object. To change the position of the rotation center, click on the rotation center and drag until it is at the desired position. This rotation center can even be outside of the object.

Note

Rotation works in a slightly different way for 3D objects because it occurs in a three dimensional space and not in a single plane. See Chapter 7, Working with 3D Objects for more information.

Slanting objects

To slant an object, select the object and switch on rotation mode (see “Rotating objects” above). Click on the handles located at the midpoints on the top, bottom and sides of a selected object. The cursor changes shape when it hovers over one of these midpoint handles indicating the direction of slanting.

The axis used for slanting an object is the object edge directly opposite the midpoint handle being used to slant the object. This axis stays fixed in location while the other sides of the object move in relation to it as the selection is dragged (Figure 12). Click and drag the cursor to slant the object. A ghosted outline of the object being slanted appears and the current angle of slanting is shown in the status bar.

Note

Press and hold the Shift key while rotating or slanting an object, movement is restricted to 15°. This is the default behavior of the Shift key. However, if When creating or moving objects has been selected in Tools > Options > LibreOffice Draw > Grid, the action of the Shift key is reversed and rotation or slanting is restricted to 15° of movement unless the Shift key is pressed.
Figure 13: Position and Size dialog

Setting exact position, size, rotation and slant

Using the mouse to position and resize objects is not exact. If greater accuracy is required to position and size an object, it is recommended to use the Position and Size dialog (Figure 13) or the Position and Size section (Figure 14) in the Properties deck on the Sidebar.

- To open the Position and Size dialog, select the object and use one of the following methods:
  - Go to Format > Position and Size on the Menu bar.
  - Right-click on the object and select Position and Size from the context menu.
  - Use the keyboard shortcut F4.

- To open the Position and Size section in the Properties deck on the Sidebar, select the object, then click on Properties on the Sidebar and click on the down arrow next to the Position and Size title bar to open the section.

The options available in the Position and Size dialog and Position and Size section in the Properties deck on the Sidebar are similar. However, on the Sidebar, the position and size of an object cannot be protected, or an object adapted to fit any text, or set the base point position for position and size.
Position and Size

- **Position** – specify the location of the selected object on the page.
  - *Position X* – enter the horizontal distance required to move the object relative to the base point selected in the grid.
  - *Position Y* – enter the vertical distance required to move the object relative to the base point selected in the grid.
  - *Base point* – select a base point in the grid and then enter the amount required to shift the object relative to the base point that is selected in the *Position Y* and *Position X* boxes. The base points correspond to the selection handles on an object. This option is only available in the Position and Size dialog.

- **Size** – specify the amount required to resize the selected object with respect to the selected base point.
  - *Width* – enter a width for the selected object.
  - *Height* – enter a height for the selected object.
  - *Keep ratio* – maintains proportions when resizing the selected object.
  - *Base point* – select a base point in the grid, and then enter the new size dimensions for the selected object in the *Width* and *Height* boxes. This option is only available in the Position and Size dialog.

- **Protect** – this option is only available in the Position and Size dialog.
- **Position** – prevents changes to the position or the size of the selected object.
- **Size** – prevents resizing of the object.

  - **Adapt** – specifies, if the size of a text box should be adjusted to fit the size of entered text. This option is only available for text boxes.
    - **Fit width to text** – expands the width of the object to the width of the text, if the object is smaller than the text.
    - **Fit height to text** – expands the height of the object to the height of the text, if the object is smaller than the text.

The units of measurement used for X/Y coordinates and the width and height of the object are set by going to **Tools > Options > LibreOffice Draw > General**.

The default location of the base points for position and size is the upper left corner of the drawing area. This base point can be temporarily change to make positioning or dimensioning simpler by clicking on a position corresponding to the location of the base point required. This change in base point is only valid for single use and the base point is reset to the standard position of top left corner when the Position and Size dialog is closed.

---

**Figure 15: Position and Size dialog - Rotation page**
Rotating objects

To accurately rotate an object, click on the Rotation tab of the Position and Size dialog (Figure 15). The options available allow the rotation angle and the location of the pivot point to be defined. Alternatively, use the available options for rotation in the Position and Size section in the Properties deck on the Sidebar.

- **Pivot Point** – the selected object is rotated around a specified pivot point. The default pivot point is at the center of the object. If a pivot point is set too far outside of the object boundaries, the object could be rotated off of the page. This option is only available in the Position and Size dialog.
  - Position X – enter horizontal distance from the left edge of the page to the pivot point.
  - Position Y – enter vertical distance from the top edge of the page to the pivot point.
  - Default settings – select the position of the pivot point. Default position is the center of the object. Changing the rotation pivot point is only valid for single use. The pivot point is reset to default settings when the Position and Size dialog is closed.

- **Rotation** – specify the number of degrees that required to rotate the selected object, or click in the rotation grid.
  - Angle – enter the number of degrees that required to rotate the selected object. This option is only available in the Position and Size dialog.
  - Default settings – click on the indicator to rotate the object. The number of degrees is shown in the Angle box as the indicator is rotated. This option is only available in the Position and Size dialog.
  - Rotation – click on the indicator to rotate the selected object, or set the angle in the text box, or select a predetermined angle from the drop down list. This option is only available in the Position and Size section in the Properties deck on the Sidebar.

Slant and corner radius

To accurately set the corner radius or slant angle of an object, click on the Slant & Corner Radius tab of the Position and Size dialog (Figure 16). Options for slant and corner radius are only available in the Position and Size dialog.

![Figure 16: Position and Size dialog - Slant & Corner Radius page](image)
Note

To set the **Corner Radius**, rectangles and squares available on the Legacy Rectangles have to be used. This toolbar is optional and is opened by going to **View > Toolbars > Legacy Rectangles** on the Menu bar.

- **Corner Radius** – this option is only available for the corners of a rectangular or square object that has been created using the Legacy Rectangles toolbar. If this section is grayed out, the corner radius cannot be set.
  - **Radius** – enter the radius of the circle that is to be used to round the corners. The larger the value for corner radius set, the rounder corners of a rectangle or square become.

- **Slant** – slants the selected object along the bottom edge of the object.
  - **Angle** – enter the angle of the slant axis. The slant angle relates to how much an object inclines or slants from its normal vertical position on a drawing.

- **Control Point 1 and 2** – enter a value to set the X and Y coordinates of the top left corner of the object. If these sections are grayed out, then coordinates cannot be set.

**Using grid and snap functions**

In Draw, objects can be positioned accurately and consistently using grid points, snap points and lines, object frames, individual points on objects, or page edges. This function is known as Snap.

It is easier to use snap functions at the highest practical zoom value for a drawing. Two different snap functions can be used at the same time. For example, snapping to a guide line and the page edge. However, it is recommended to activate only those snap functions that are really required.

![Figure 17: Options LibreOffice Draw Grid dialog](image)

![Figure 18: Options toolbar](image)
Configuring grid and snap functions

To configure the grid and snap functions in a drawing, go to Tools > Options > LibreOffice Draw > Grid on the Menu bar to display the Grid dialog (Figure 17). The grid and snap functions can also be displayed and switched on or off using this dialog, right-clicking on a drawing and using the options in the context menu, or using the icons in the Options toolbar (Figure 18). If the Options toolbar is not open, go to View > Toolbars > Options on the Menu bar.

- **Grid** – specifies the settings for the configurable grid on document pages. This grid helps to determine the exact position of objects. Also, this grid can be set in line with the magnetic snap grid. If the snap grid is activated, but want to move or create individual objects without snap positions, keep the Shift key pressed to deactivate this function.
  - **Snap to grid** – specifies whether to move frames, drawing elements, and controls only between grid points. To change the status of the snap grip only for the current action, drag an object while holding down the Ctrl key.
  - **Visible grid** – specifies whether to display the grid.

- **Resolution**
  - **Horizontal** – defines the unit of measure for the spacing between grid points on the X-axis.
  - **Vertical** – defines the grid points spacing in the desired unit of measurement on the Y-axis.

- **Subdivision**
  - **Horizontal** – specify the number of intermediate spaces between grid points on the X-axis.
  - **Vertical** – specify the number of intermediate spaces between grid points on the Y-axis.

- **Synchronize axes** – specifies whether to change the current grid settings symmetrically. The resolution and subdivision for the X and Y axes remain the same.

- **Snap**
  - **To snap lines** – snaps the edge of a dragged object to the nearest snap line when the mouse button is released. This setting can also be defined using Snap to Snap Guides on the Options toolbar.
  - **To the page margins** – specifies whether to align the contour of the graphic object to the nearest page margin. The cursor or a contour line of the graphics object must be in the snap range. This function can also be accessed using Snap to Page Margins in the Options toolbar.
  - **To object frame** – specifies whether to align the contour of the graphic object to the border of the nearest graphic object. The cursor or a contour line of the graphics object must be in the snap range. This function can also be accessed with Snap to Object Border in the Options toolbar.
  - **To object points** – specifies whether to align the contour of the graphic object to the points of the nearest graphic object. This only applies if the cursor or a contour line of the graphics object is in the snap range. This function can also be accessed with Snap to Object Points in the Options toolbar.
  - **Snap range** – defines the snap distance between the mouse pointer and the object contour. Snaps to a snap point if the cursor is closer than the distance selected.
• **Constrain Objects**
  – *When creating or moving objects* – specifies that graphic objects are restricted vertically, horizontally or diagonally (45°) when creating or moving them. This setting can be temporarily deactivated by pressing the *Shift* key.
  – *Extend edges* – specifies that a square is created based on the longer side of a rectangle when the *Shift* key is pressed before releasing the mouse button. This also applies to an ellipse (a circle is created based on the longest diameter of the ellipse). When *Extend edges* is not selected, a square or a circle is created based on the shorter side or diameter.
  – *When rotating* – specifies that graphic objects can only be rotated within the rotation angle that is selected. To rotate an object outside the defined angle, press the *Shift* key when rotating. Release the key when the desired rotation angle is reached.
  – *Point reduction* – defines the angle for point reduction. When working with polygons, this maybe useful in reducing the editing points.

**Snap to grid**

*Using Snap to Grid*

Using **Snap to Grid** moves an object exactly onto a grid point in a drawing. This function can be switched on and off using one of the following methods:

• Go to **View > Snap Guides > Snap to Grid** on the Menu bar.
• Right-click on a drawing and select **Snap Guides > Snap to Grid** from the context menu.
• Click on **Snap to Grid** on the Options toolbar.

*Displaying grid*

Displaying or turning off the grid in a drawing is done using one of the following methods:

• Go to **View > Grid and Helplines > Display Grid** on the Menu bar.
• Click on **Display Grid** on the Options toolbar.
• Right-click on a drawing and select **Grid and Helplines > Display Grid** from the context menu.
• Select **Visible grid** in the Options LibreOffice Draw Grid dialog.

*Changing color of grid points*

By default and depending on the display and computer setup, the grid points are gray and are not always easy to see. To change the color of the grid points, go to **Tools > Options > LibreOffice > Application Colors** to open the Application Colors dialog (Figure 19). In the **Drawing/Presentation** section, select a more suitable color for the grid from the drop-down list.

**Snap points and lines**

Unlike the grid, snap lines and snap points can be inserted when to position an object to a specific position on a drawing. Snap lines can either be horizontally or vertically and appear as dashed lines. Snap points appear as small crosses with dashed lines. Snap points and snap lines do not appear in printed output.
To insert a snap point or snap line, go to **Insert > Snap Guide** on the Menu bar to open the New Snap Object dialog (Figure 20).

- **Position** – sets the position of a selected snap point or line relative to the top left corner of the page.
  - **X axis** – enter the amount of space required between the snap point or line and the left edge of the page.
  - **Y axis** – enter the amount of space required between the snap point or line and the top edge of the page.
- **Type** – specifies the type of snap object being inserted.
– *Point* – inserts a snap point.
– *Vertical* – inserts a vertical snap line.
– *Horizontal* – inserts a horizontal snap line.

**Displaying snap points and lines**
Displaying or turning off snap points and lines in a drawing can be done using one of these methods:

- Go to View > Snap Guides > Display Snap Guides on the Menu bar.
- Click on Display Snap Guides in the Options toolbar.
- Right-click on a drawing and select Snap Guides > Display Snap Guides from the context menu.

**Editing snap points and lines**
To edit a snap point, right-click on the snap point and select *Edit Snap Point* from the context menu to open the Edit Snap Point dialog (Figure 21). Enter new X and Y coordinate settings for the snap point and click OK. Alternatively, drag a snap point to a new position on a drawing.

To edit a snap line, right-click on the snap line and select *Edit Snap Line* from the context menu to open the Edit Snap Line dialog (Figure 22). Enter a new X coordinate setting for vertical snap lines or a new Y coordinate setting for horizontal snap lines and click OK. Alternatively, drag a snap line to a new position on a drawing.

![Figure 21: Edit Snap Point dialog](image1.png)

![Figure 22: Edit Snap Line dialog](image2.png)
Deleting snap points and lines

To delete a snap point, drag it back to a ruler or right-click on the snap point and select Delete Snap Point from the context menu. To delete a snap line, drag it back to the ruler or right-click on the snap line and select Delete Snap Line from the context menu.

Configuring snap range

To configure the snap range of when an object snaps to position

1) Go to Tools > Options > LibreOffice Draw > Grid on the Menu bar to open the Options LibreOffice Grid dialog.

2) Enter the number of pixels to set the proximity of when the object will snap into position in the Snap range box. The default setting is 5 pixels.

3) Click OK to set the new snap range and close the dialog.
Using Helplines

Helplines are a function in Draw to help in positioning of objects. Helplines can be displayed while the object is being moved. They extend from the edges of the object to the rulers at the top and left side of a drawing and do not have a snap function (Figure 23).

To use guide lines, go to Tools > Options > LibreOffice Draw > View on the Menu bar to open the Options LibreOffice Draw View dialog (Figure 24) and select Helplines when moving option or click Helplines While Moving in the Options toolbar.

Changing object shape

Regular shapes

When drawing certain regular shapes, one or more dots are displayed in a different color to the selection handles when an object is selected. When the cursor hovers over one of these dots, it changes shape. Clicking and dragging on one of these dots modifies the shape of the object. For example, increasing the corner radius of a rounded rectangle or square, changes the angles of an arc, and so on.

These dots perform different functions according to the shape selected. The shapes with form changing dots and their functions are listed in the following sections.

Note

Regular shapes can also be changed after conversion to a curve or polygon and editing the points. See “Curves and polygons” on page 25 and “Editing points” on page 25 for more information.

Basic shapes

Refer to Figure 25 to identify the following shapes with adjustment dots.

- Rectangle, Rounded – use the dot to change the radius of the curve that replaces the angled corners of a rectangle or square.
- Square, Rounded – use the dot to change the radius of the curve that replaces the angled corners of a rectangle or square.
- Parallelogram – use the dot to change the internal angles between the sides.
- Trapezoid – use the dot to change the internal angles between the sides.
- Circle Pie – use the dots to change the size of the filled sector.
- Block Arc – use the dot to change both internal diameter and size of the filled area.
- Isosceles Triangle – use the dot to modify the shape and type of the triangle.
- Hexagon – use the dot to change the internal angles between the sides.
- Octagon – use the dot to change the internal angles between the sides.
- Cylinder – use the dot to change the perspective.
• **Cube** – use the dot to change the perspective.
• **Folded Corner** – use the dot to change the size of the folded corner.
• **Cross** – use the dot to change the thickness of the four arms of the cross.
• **Frame** – use the dot to change the thickness of the frame.
• **Ring** – use the dot to change the internal diameter of the ring.

**Symbol Shapes**

Refer to Figure 26 to identify the following shapes with adjustment dots.

• **Smiley Face** – use the dot to change the smile on the face.
• **Heart** – use the dot to change the shape of the symbol.
• **Sun** – use the dot to change the shape of the symbol.
• **Moon** – use the dot to change the shape of the symbol.
• **Prohibited** – use the dot to change the thickness of the ring and the diagonal bar.
• **Square Bevel** – use the dot to change the thickness of the bevel.
• **Octagon Bevel** – use the dot to change the thickness of the bevel.
• **Diamond Bevel** – use the dot to change the thickness of the bevel.
• **Double Bracket** – use the dot to change the curvature of the bracket.
• **Left Bracket** – use the dot to change the curvature of the bracket.
• **Right Bracket** – use the dot to change the curvature of the bracket.
• **Double Brace** – use the dot to change the curvature of the bracket.
• **Left Brace** – use the dots to change the curvature of the brace and the position of the point.
• **Right Brace** – use the dots to change the curvature of the brace and the position of the point.

**Block Arrows**

Refer to Figure 27 to identify the following shapes with adjustment dots.

• **Right Arrow** – use the dot to change the shape and thickness of the arrow.
• **Left Arrow** – use the dot to change the shape and thickness of the arrow.
• **Down Arrow** – use the dot to change the shape and thickness of the arrow.
• **Up Arrow** – use the dot to change the shape and thickness of the arrow.
• **Left and Right Arrow** – use the dot to change the shape and thickness of the arrow.
• **Up and Down Arrow** – use the dot to change the shape and thickness of the arrow.
• **Circular Arrow** – use the dot to change the shape and thickness of the arrow.
• **4-way Arrow** – use the dots to change the shape and thickness of the arrow.
• **Chevron** – use the dot to change the angle between the sides and the shape.
• **Pentagon** – use the dot to change the angle between the sides and the shape.
• **Striped Right Arrow** – use the dot to change the shape and thickness of the arrow.
• **Up, Right and Down Arrow** – use the dots to change the shape and thickness of the arrow.
• **Notched Right Arrow** – use the dot to change the shape and thickness of the arrow.
• **Up and Right Arrow** – use the dots to change the shape and thickness of the arrow.
• **Right Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **Left Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **Down Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **Up Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **Left and Right Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **Up and Down Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **4-way Arrow Callout** – use the dots to change the shape and thickness of the callout.
• **Up and Right Arrow Callout** – use the dots to change the shape and thickness of the callout.

**Callouts**

![Callouts sub-toolbar](image)

*Figure 28: Callouts sub-toolbar*

For all callouts (Figure 28) use the adjustment dots to change the length, position and angle of the pointer.

**Stars and Banners**

![Stars and Banners sub-toolbar](image)

*Figure 29: Stars and Banners sub-toolbar*

Refer to Figure 29 to identify the following shapes with adjustment dots.

• **4-Point Star** – use the dot to change the thickness and shape of the star points.
• **8-Point Star** – use the dot to change the thickness and shape of the star points.
• **24-Point Star** – use the dot to change the thickness and shape of the star points.
• **Vertical Scroll** – use the dot to change the width and shape of the scroll.
• **Horizontal Scroll** – use the dot to change the width and shape of the scroll.
• **Doorplate** – use the dot to change the inward curvature of the corners.

### Curves and polygons

#### Bézier curves

The editing of curves and polygons depends on the mathematics of Bézier curves\(^1\). Explaining Bézier curves goes beyond this scope of this chapter. See Chapter 11, Advanced Draw Techniques for more information on drawing and manipulating Bézier curves.

The editing a Bézier curve consists in principle of moving points or tangents passing through these points. Each tangent has one control point at each end and a junction point where it meets the curve. The relative angle and distance between the control points determine the shape of the curve. Figure 30 shows what happens to a basic square and changing only one point on the square.

![Figure 30: Creating different shapes by changing the tangent](image)

#### Converting objects to curve or polygon

When changing the shape of an object and before modifying the points on an object, it must be converted to a curve or a polygon. Depending on what kind of shape and effect required to produce using one of the following methods to create a curve or a polygon:

- After selecting an object, go to **Shape > Convert** on the Menu bar and select either **To Curve** or **To Polygon**.
- Right click on an object and select **Convert > To Curve** or **To Polygon** from the context menu.

#### Editing points

Many different shapes can be created by moving either the point itself, or one or both of the round handle points at either end of the tangent, as shown in Figure 30. Points can be added, deleted, or the points type changed using the tools available on the Edit Points toolbar (Figure 31). After converting a shape to a curve or polygon, object points are edited as follows:

---

1 Bézier curves were invented by Pierre Bézier, who developed the technique in the 1960s and was an engineer working with the Renault car manufacturer. The technology was intended to make modeling the surface of vehicles easier.
1) Select the object and switch to points editing mode using one of the following methods.
   – Go to **Edit > Points** on the Menu bar.
   – Click on the **Points** tool on the Standard toolbar.
   – Right click on the converted object and select **Points** from the context menu.
   – Use the keyboard shortcut **F8**.

   **Note**

   After switching to points editing mode, the selection handles become points. The number of points may increase or reduce in number. This change in number depends on the shape of the object and is normal behavior.

2) Click on an object point to change the object shape. The Edits Points toolbar opens and the tools become active when a point is selected. Tangents also appear attached to the selected point.

3) Use the various tools on the Edit Points toolbar to add, delete, or change the point type.

4) Click on and drag the point to move the point and change the object shape.

5) If the selected object is a curve, click on and drag the round points at the end of a tangent to make further changes to the object shape.

6) When satisfied with the shape, click outside of the object to cancel points editing mode and close the Edit Points toolbar.

**Point types**

The available tools on the Edit Points toolbar depend on the object and type of object point that has been selected.

- **Move Points** – activates a mode allowing movement of points. Click and drag the selected point to another location. The object border follows the movement on both sides of the selected point to the next point on each side of the selected point.

- **Insert Points** – activates the insert mode and allows points to be inserted. Points can also be moved. A point is inserted onto the selected object each time the mouse button is clicked and the object changes shape to include the new point into the border of the object. The inserted point is a smooth point.

- **Delete Points** – used to delete points from the selected object. Select **Delete Points** and then click on a point to delete it. To delete several points, hold down the **Shift** key as each point is selected for deletion, then click on **Delete Points**.

- **Convert To Curve** – converts a curve into a straight line or a straight line into a curve. If a single point is selected, the curve before the point will be converted. If two points are selected, the curve between both points will be converted. If more than two points are selected and each time this icon is clicked, a different portion of the curve will be converted. If necessary, round points are converted into corner points and corner points are converted into round points.
If a section of the curve is a straight line, the end points of the line have a maximum of one control point each. They cannot be modified to round points unless the straight line is converted back to a curve.

- **Close Bézier** – closes a line or a curve. A line is closed by connecting the last point with the first point, indicated by an enlarged square.

- **Split Curve** – select the point or points where the curve will be split, then click on **Split Curve**.

- **Corner Point** – converts the selected point or points into corner points. Corner points have two movable control points, which are independent from each other. A curved line, therefore, does not go straight through a corner point, but forms a corner.
  
  To create a corner point, a smooth or a symmetrical point must be inserted first and then converted to a corner point by clicking on **Corner Point**.

- **Smooth Transition** -- converts a corner point or symmetrical point into a smooth point. Both control points of the corner point are aligned in parallel, and can only be moved simultaneously. The control points may differentiate in length, allowing variation in the degree of curvature.

- **Symmetric Transition** -- converts a corner point or a smooth point into a symmetrical point. Both control points of the corner point are aligned in parallel and have the same length. They can only be moved simultaneously and the degree of curvature is the same in both directions.

- **Eliminate Points** – marks selected points for deletion. This happens if the point is located on a straight line. If converting a curve or a polygon using **Convert to Curve** into a straight line or alter a curve using the cursor so that a point lies on the straight line, the selected point is removed. The angle from which the point reduction is to take place is 15° by default.

**Tangents**

Before using tangents on an object, the object must be converted to a curve. Tangents are only used on curves. If an object has been converted to a polygon and a tangent is added, the object is automatically converted to a curve.

**Note**

The angle that a tangent relates to an object shape can be changed by clicking on one of the tangent control points at the end of a tangent and moving it with the cursor. As the tangent angle is changed, the shape of the object changes in response.

**Symmetric transition**

Symmetric transition converts a corner point or a smooth point into a symmetrical point. The tangents have the same length and are aligned in a straight line, as shown in Figure 32. The tangents can only be moved simultaneously and the degree of curvature is the same in both directions.

1) Convert the object to a curve or polygon.

2) Switch the selected object into editing points mode and open the Edit Points toolbar.

3) Select the point to be changed to a symmetrical point.
4) Click on **Symmetric Transition** in the Edit Points toolbar. The straight line on each side of the symmetric transition point is converted to a curve.

5) Click and drag one of the tangent control handles to change the curvature and shape of the object. Any change to one tangent is carried over symmetrically to the other tangent.

**Smooth transition**

Smooth transition converts a corner point or symmetrical point into a smooth point. The tangents are aligned in a straight line and can only be moved simultaneously. The tangents can have different lengths with the curvature controlled by the longest tangent being the largest curvature, as shown in Figure 33.

1) Convert the object to a curve or polygon.

2) Switch the selected object into editing points mode and open the Edit Points toolbar.

3) Select the point to be changed to a symmetrical point.

4) Click on **Smooth Transition** on the Edit Points toolbar.

5) Click and drag one of the tangent control handles to change the shape of the object. This creates an asymmetric tangent with the largest curvature on the longest side of the tangent.

**Corner point**

Converts a selected point or points into corner points. Corner points have two movable control points, which are independent from each other. It is possible to independently change the angle on each side of a tangent using the central point of the tangent as a corner point, as shown in Figure 34.
1) Convert the object to a curve or a polygon.
2) Switch the selected object into editing points mode and open the Edit Points toolbar.
3) Select the point to be changed to a symmetrical point.
4) Click on **Corner Point** on the Edit Points toolbar.
5) Click and drag the end of one of the tangents to change its angle. Each tangent can be moved independently to create spikes and troughs in an object shape.

### Points

#### Moving points

When moving points, the object border on both sides of the point follows the movement of the point changing the object shape.

1) Convert the object to a curve or a polygon.
2) Switch the selected object into editing points mode and open the Edit Points toolbar.
3) Select the point to be changed to a symmetrical point.
4) Click on **Move Points** on the Edit Points toolbar.
5) Place the cursor on the selected point, then click and drag the point to create a new shape. Figure 35 illustrates how a different shape can be created from a circle by dragging the left hand side point to the left.

### Inserting points

A point is inserted onto the selected object each time the mouse button is clicked. Clicking inside the border of the object, the object changes shape to include the new point into the border of the object, as shown in Figure 36. The inserted point is a smooth point.

Points can also be moved in insert point mode. Hover the cursor over the point until it changes shape, then click and drag the point to change the object shape.
Figure 36: Inserting points

1) Convert the object to a curve or a polygon.
2) Switch the selected object into editing points mode and open the Edit Points toolbar.
3) Click on Insert Points on the Edit Points toolbar.
4) Click on the object border to insert a point at the required position on the border.
5) Alternatively, click inside the object border to insert a point. The object automatically changes shape to include the new point into the object border.

Deleting points

Figure 37 shows what happens when three points on the left were deleted from a circle. The left image is a the full circle and the right image is where three points have been deleted creating a new shape.

Figure 37: Deleting points

1) Convert the object to a curve or a polygon.
2) Switch the selected object into editing points mode and open the Edit Points toolbar.
3) To delete a single point, proceed as follows
   a) Select the point for deletion.
   b) Click on Delete Points on the Edit Points toolbar.
4) To delete several points at the same time, proceed as follows:
   a) Hold down the Shift key.
   b) Select all the points for deletion.
   c) Click on Delete Points on the Edit Points toolbar
Eliminating points

The **Eliminate Points** tool on the Edit Points toolbar only functions on lines with multiple points. These lines are created when a curve is converted to a line using the **Convert to Curve** tool. An example of creating a straight line and eliminating points is shown in Figure 38.

1) Convert the curve to a curve or a polygon.
2) Switch the curve into editing points mode and open the Edit Points toolbar.
3) Select the curve with multiple points and convert to a line, see “Converting curves or lines” below.
4) Select the point or points on the line for elimination. The selected point is emphasized.
5) Select the **Eliminate Points** tool on the Edit Points toolbar.
6) Accurately position the cursor over the selected point, then click and drag the selected point. As the cursor is dragged, a dotted line forms between the neighboring points.
7) When this dotted line appears to be a straight line between the neighboring points, release the mouse button. The selected point is eliminated and a straight line now exists between the neighboring points.

Converting curves or lines

Curves and lines are easily converted using the **Convert to Curve** tool on the Edit Points toolbar. When a curve is converted to a line, a straight line is created between selected points on a curve. When a line is converted to a curve, a curve is created between selected points on a line. An example of converting a curve to a line is shown in Figure 38.

1) Convert the object to a curve or a polygon.
2) Switch the object into editing points mode and open the Edit Points toolbar.
3) Select the points for converting from curve to line or from line to curve.
4) Click on **Convert to Curve** on the Edit Points toolbar. Between the selected points, a curve is converted into a line or a line is converted into a curve.

Splitting objects

1) Convert the object to a curve or a polygon.
2) Switch the object into editing points mode and open the Edit Points toolbar.
3) Select the point or points on the object where it is to be split. Keep the Shift key pressed down when selecting more than one point.

4) Click on Split Curve on the Edit Points toolbar to split or cut the object border at the selected point. If the object is filled, it will be emptied because the object border is no longer closed, as shown in Figure 39.

5) Deselect the object, then drag the cut segment and move it away from the original object.

**Note**

The point where the object was split is now larger than the remaining points visible on the object.

**Closing objects**

1) Select an open object (Figure 40).

2) Switch the object into editing points mode and open the Edit Points toolbar.

3) Select a point where the object has been split. Note that the start point of an object is larger than the other points visible on the object.

4) Click on Close Bézier in the Edit Points toolbar to close the object. If the open object was originally a closed and filled object, then the original color fills the object when it is closed.
Distorting objects

1) Select the object and switch into editing points mode to display the points on the object. This also opens the Edit Points toolbar.

2) Select one of the points on the object and drag it to a new position to distort the object (Figure 41).

Figure 41: Distorting objects