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Introduction

This chapter describes how to add new slides to a presentation, how to format slides, and how to
format notes. Notes are generally used as prompts for the person giving the presentation.

Inserting, renaming, and removing slides

A new slide is inserted into a presentation after the selected slide which is displayed in the 
Workspace. If slide masters have been used in the presentation, the inserted slide will use the 
master slide of the selected slide displayed in the Workspace.

Inserting new slides

1) Open the presentation where you want to add a new slide, or create a new presentation.

2) Make sure Normal view is selected in the Workspace.

3) Select the slide in the presentation where you want to insert a new slide after the selected
slide, then use one of the following methods to insert a new slide:

– Go to Slide > New Slide on the Menu bar.
– Right-click on the selected slide in the Slides pane and select New Slide from the 

context menu.
– Right-click on the selected slide in the Slide Sorter view and select New Slide from 

the context menu.
– Use the keyboard shortcut Ctrl+M.

4) To insert a new slide at the end of a presentation make sure there are no slides selected 
in the Slides pane, then use one of the following methods:

– Go to Slide > New Slide on the Menu bar.
– Right-click in an empty area in the Slides pane and select New Slide from the context

menu.

Inserting slides from a file

1) Open the presentation where you want to insert a slide, or create a new presentation.

2) Make sure Normal view is selected in the Workspace.

3) Select the slide in the presentation where you want to insert a slide after the selected 
slide. Alternatively, to insert a slide at the end of the presentation, make sure that there 
are no slides selected in the Slides pane.

4) Go to Slide > Insert Slide from File on the Menu bar to open the Insert File dialog 
(Figure 1).

5) Navigate to the presentation file where you want to insert a slide from and click on Open 
to open the Insert Slides/Objects dialog (Figure 2).

6) Click on the small triangle next to the filename to expand the list of slides.

7) Select the slides you want to insert into your presentation.

8) If required, select the Link option to embed the slide as an OLE object.

9) Click OK to insert the slide into in the presentation and close the dialog.
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Figure 1: Insert File dialog

Figure 2: Insert Slides/Objects dialog

Note

When inserting a slide from a file, you can optionally link the slide instead of copying.
This embeds the slide into your presentation using OLE. See Chapter 7, OLE, 
Spreadsheets, Charts, and Other Objects for more information about OLE.

Tip

Figure 2 shows the importance of giving descriptive names to slides in a 
presentation. Refer to “Renaming slides” on page 7 for more information.
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Copying and pasting between presentations

1) Open the presentation that you want to copy a slide from and the presentation where you 
want to paste the copied slide.

2) In the presentation where you want to copy from, make sure that the Slide Sorter view is 
open in the Workspace so that you can easily locate the slides you want to copy.

3) Select the required slide and copy using one of the following methods:

– Go to Edit > Copy on the Menu bar.
– Right-click and select Copy from the context menu.
– Click on Copy in the Standard toolbar.
– Use the keyboard shortcut Ctrl+C.

4) Go to the presentation where you want to paste the slide into.

5) Make sure that Slide Sorter view is open in the Workspace.

6) Select the slide at the point where you want to insert the copied slide after the selected 
slide. Alternatively, to paste a slide at the end of the presentation, make sure that there 
are no slides selected in the Slides pane.

7) Paste the copied slide into the presentation using one of the following methods:

– Go to Edit > Paste on the Menu bar.
– Right-click and select Paste from the context menu.
– Click on Paste in the Standard toolbar.
– Use the keyboard shortcut Ctrl+V.

Dragging and dropping between presentations

1) Open both presentations that you want to use to move or copy slides between.

2) For both presentations, open the Slide Sorter view in the Workspace.

3) In the target presentation, select the slide at the point where you want to insert the copied
slide after the selected slide. Alternatively, to paste a slide at the end of the target 
presentation, make sure that there are no slides selected in the Slides pane.

4) In the donor presentation, select the required slides that you want to move or copy.

5) To move the slides to the target presentation, click on the selected slides then drag and 
drop the selected slides into the target presentation.

6) To copy the slides to the target presentation, click on the selected slides then hold down 
the Ctrl key while dragging and dropping into the target presentation.

Duplicating slides

Duplicating a slide is an easy method of adding slides to a presentation if you want a new slide to
inherit formatting, layout, and animations from a selected slide.

1) Open Normal or Slide Sorter views in the Workspace.

2) Select the slide or slides you want to duplicate in the Slide Sorter view or the Slides 
pane.

3) Go to Slide > Duplicate Slide on the Menu bar, or right click on the selected slide and 
select Duplicate Slide on the context menu. The duplicated slides are placed in the 
presentation after the selected slides,
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Tip

Duplicating a slide is a good way of preventing slides from being shown with too 
much information, which can make it difficult for your audience to understand. If a 
slide becomes crowded with information, try duplicating the slide then split the 
information points over two or more slides. All the formatting, backgrounds, and so 
on will be preserved in each duplicated slide.

Figure 3: Rename Slide dialog

Renaming slides

1) Open Normal or Slide Sorter view in the Workspace.

2) Select a slide and open the Rename Slide dialog (Figure 3) using one of the following 
methods:

– Go to Slide > Rename Slide on the Menu bar.
– Right-click on the selected slide and select Rename Slide from the context menu.

3) In the Rename Slide dialog, type a new name for the slide in the Name text box.

4) Click OK to save the change and close the Rename Slide dialog.

Expanding slides

Occasionally there may be a slide with too many points to fit in the space available. Instead of 
reducing the font size or using other methods to squeeze more text onto the slide, it is better to 
subdivide the contents of the slide into two or more slides.

1) If necessary, duplicate the slide in case of error and you want to redo expansion of the 
slide.

2) Select the slide you want to expand in the Slide pane.

3) Go to Slide > Expand Slide on the Menu bar. This creates new slides from the first 
outline level on the original slide. The first outline level becomes the title of each new 
slide. Outline levels below each first level on the original slide are moved up one outline 
level in the new slides. An example of expanded slides is shown in Figure 4.

4) If necessary, rearrange the new slides in the presentation order.

Creating summary slides

Summary slides are useful for creating an agenda for a presentation.

1) Select the slide that will be the first slide to appear in the summary.
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Figure 4: Example of expanding slides

Figure 5: Example summary slide

2) Go to Slide > Summary Slide on the Menu bar to create a summary slide (Figure 5) at 
the end of the presentation. Bullet points are created using the titles of the slides in the 
presentation.

3) If necessary, move the summary slide to the position where you want it to appear in the 
presentation.

Deleting slides

Select a slide or slides in the Slides pane or in Normal or Slide Sorter view in the Workspace, 
then use one of the following methods to delete slides:

• Go to Slide > Delete Slide on the Menu bar.

• Right-click on a selected slide and select Delete Slide from the context menu.

• Press the Delete or Backspace key.

8 | Chapter 8, Adding and Formatting Slides, and Notes



Figure 6: Example outline from Writer file

Figure 7: Create AutoAbstract dialog

Figure 8: Outline toolbar

Creating slides from an outline

When planning a presentation it may be useful to develop an outline from a LibreOffice Writer 
file. Once the outline is created, you can create one or more separate slides for each of the top 
level outline elements.

Using a Writer text document

The Writer document must contain headings formatted using heading paragraph styles.

1) Open the file in Writer that you want to use as a base to create a presentation outline.

2) Go to File > Send > Outline to Presentation on the Writer Menu bar. A new presentation
is created and opens in Impress Outline view (Figure 6) and the heading paragraph styles
are converted into the outline styles used in Impress.

3) If necessary, duplicate or expand slides and manually change slide contents to create a 
simpler presentation that your audience will have a better understanding. For more 
information, see “Duplicating slides” on page 6 and “Expanding slides” on page 7.
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Using AutoAbstract

To create a presentation using AutoAbstract and send content from Writer to Impress, the text 
must contain headings formatted with the heading paragraph styles. When using AutoAbstract to 
copy the headings and subsequent paragraphs to a new presentation, you can specify the 
number of outline levels as well as the number of paragraphs to be displayed.

1) Open the file in Writer that you want to use as a base to create a presentation outline.

2) Go to File > Send > AutoAbstract to Presentation on the Writer Menu bar to open the 
Create AutoAbstract dialog (Figure 7).

3) Select the number of outline levels to be created in the presentation in the Include outline 
levels box. For example, if you choose three levels, all paragraphs formatted with 
Heading 1 to 3 styles are included.

4) Select the number of paragraphs for each outline level to be created in the presentation in
the Paragraphs per level box.

5) Click OK to close the Create AutoAbstract dialog and create an outline in a new Impress
presentation.

6) Some outline levels may have too many points to fit on one slide. If necessary, duplicate 
or expand slides and manually change slide contents to create a simpler presentation that
your audience will have a better understanding. For more information, see “Duplicating 
slides” on page 6 and “Expanding slides” on page 7.

7) When the presentation is created, some hierarchical structure of the outline may be lost. 
If necessary, use Promote/Demote tools on the Outline toolbar (Figure 8) to move the 
outline points to the correct level.

Copying and pasting an outline

1) In Writer, open the file containing the outline you want to use in your presentation.

2) Highlight the outline and select Edit > Copy on the Menu bar, or right click on the outline 
and select Copy from the context menu.

3) Create a new presentation in Impress or create a new slide in an existing presentation 
that you want to use.

4) Select the layout you want to use for the slides. For more information, Chapter 1, 
Introducing Impress.

5) Paste the copied outline into the text area of the slide. Do not worry if the text does not fit 
the space on the slide.

6) If the slide contains too much text, duplicate or expand slides and manually change slide 
contents to create a simpler presentation that your audience will have a better 
understanding. For more information, see “Duplicating slides” on page 6 and “Expanding 
slides” on page 7.

7) When the presentation is created, some hierarchical structure of the outline may be lost. 
If necessary, use Promote/Demote tools on the Outline toolbar to move the outline points 
to the correct level.
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Figure 9: Slide Setup dialog - Slide page

Formatting slides

Use master slides to give your presentation a professional look and avoid manually modifying the
formatting of each individual slide. Multiple master slides can be used in a single presentation to 
provide the same look to groups of slides or individual slides. See Chapter 2, Master Slides, 
Styles, and Templates for more information about using master slides.

Slide setup

Individual slides can be formatted separately in a presentation using the Slide Setup dialog 
(Figure 9) or the Slide section in the Properties deck on the Sidebar (Figure 10).

Slide Setup dialog

1) Make sure you are in Normal or Notes view in the Workspace.

2) Open the Slide Setup dialog using one of the following methods:

– Go to Slide > Properties on the Menu bar.
– Right-click in an empty area on the slide and select Properties from the context 

menu.

3) Use the various options available in the Slide, Background, and Transparency pages in
the Slide Setup dialog to setup the slide. See Chapter 2, Master Slides, Styles and 
Templates for more information on the various options available in the Slide Setup dialog.

4) Click OK to save your changes and close the Slide Setup dialog.

Sidebar Slide section

Options selected in the Slide section are applied immediately to the slide.

1) Make sure you are in Normal or Notes view in the Workspace.

2) Click on Properties in the Sidebar to open the Properties deck.

3) Click on Slide to open the Slide section in the Properties deck.

4) Select the slide size to use from the predefined sizes in the Format drop down list.

5) Select the slide orientation to use from the Orientation drop down list.
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Figure 10: Slide section in Properties 
deck on Sidebar

Figure 11: Master Slides section in 
Properties on Sidebar

6) Select the slide background to use from the Background drop down list. The background 
type selected changes the options available. For more information on slide backgrounds, 
see Chapter 2, Master Slides, Styles and Templates.

7) If necessary, select the master slide to use from the Master Slide drop down list.

8) If necessary, select to use or deselect not to use Master Background or Master Objects 
on the slide. Only available if a master slide has been used for the slide.

9) If necessary, click on Master View to check on how the master slide selected looks and if 
it matches your requirements.

Selecting master slides

You can apply a master slide to all the slides in a presentation or only to selected slides in a 
presentation. This allows the use of more than one master slide in a presentation. For more 
information on master slides, see Chapter 2, Master Slides, Styles and Templates.

1) Make sure you are in Normal or Notes view in the Workspace.
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2) In the Sidebar, click on Master Slides to open the Master Slides deck (Figure 11) and 
display the available master slides for use.

3) Select a master slide from the options available in the sections for Used in This 
Presentation, Recently Used, or Available for Use.

4) Apply the selected master slide to slides using one of the following methods:

– For all slides in the presentation, right-click on the selected master slide and select 
Apply to All Slides from the context menu.

– For selected slides only, right-click on the selected master slide and select Apply to 
Selected Slides from the context menu.

Changing master slides

1) Make sure you are in Normal or Notes view in the Workspace.

2) Select the slide in the Slides Pane so that it appears in the Workspace.

3) Right-click in a blank area on the slide in the Workspace and select Change Slide 
Master in the context menu to open the Available Master Slides dialog (Figure 12).

4) Navigate the master slides displayed in the Select a Slide Design preview box to the 
required master slide. If the required master slide is not displayed, then click on Load to 
open the Load Master Slide dialog (Figure 13).

a) Select the category of master slide required in the Categories list.

b) Select the template required in the Templates list and a preview of the template 
appears in the Preview box.

c) Click OK to close the Load Master Slide dialog and the master slide templates appear
in the Select a Slide Design preview box in the Available Master Slides dialog.

5) Select the required master slide from the master slides displayed and click OK. The slide 
changes to show the new master slide and the Available Master Slides dialog closes.

Figure 12: Available Master Slides dialog
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Figure 13: Load Master Slide dialog

Figure 14: Slide Setup dialog - Background page

Changing slide background

1) Make sure you are in Normal view in the Workspace.

2) Select a slide in your presentation.

3) Open the Slide Setup dialog (Figure 14) using one of the following methods:

– Go to Slide > Properties on the Menu bar.
– Right-click in an empty area on the slide and select Properties from the context 

menu.

4) Click on the Background tab to open the Background page and select the type of 
background you want to use. For more information on background types, see Chapter 2, 
Master Slides, Styles, and Templates, and Chapter 6, Formatting Graphic Objects.
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5) Select from the various options offered by the different background types the background 
effect for your selected slide.

6) Click OK to save the changes to the background and close the Slide Setup dialog.

Note

Only the background for one slide in a presentation can be changed at a time. To 
change the background on more than one slide at a time, you have to use master 
slides. For more information on slide backgrounds, see Chapter 2, Master Slides, 
Styles and Templates.

Choosing slide layout

After creating a new slide, you can then decide on which layout is suitable for the slide contents 
and your presentation. Impress offers various predefined layouts that can be applied as a starting
point for a slide. Figure 15 shows the predefined layouts that are available in Impress. If the 
layouts available in Impress do not fit your requirements, layout elements can be rearranged, 
duplicated, resized, or deleted as necessary.

Note

If the layout is changed on a slide that already contains text and objects, Impress 
does not delete these elements, but repositions the elements according to the 
selected layout. This may result in some elements overlapping or being out of 
position.

Note

Custom defined layouts cannot be created and saved in Impress for use on several 
slides. It is recommended to create a master slide or template that uses a custom 
layout and can be used on several slides. For more information on master slides and
templates, see Chapter 2, Master Slides, Styles, and Templates.

1) Make sure you are in Normal or Slide Sorter view in the Workspace.

2) Select a slide in your presentation.

Figure 15: Layouts section in Properties 
on Sidebar
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3) Change the slide layout using one of the following methods:

– Select a layout in the Layouts section in the Properties deck on the Sidebar.
– Go to Slide > Layout in the Menu bar and select a layout from the list in the context 

menu.
– Right-click on the slide in the Slides Pane and select Layout from the context menu, 

then select a layout from the list in the context menu.
– Right-click on the slide in Slide Sorter view in the Workspace and select Layout from

the context menu, then select a layout from the list in the context menu.
– Right-click in an empty area on the slide in Normal view in the Workspace and select 

Layout from the context menu, then select a layout from the list in the context menu.

4) When the slide layout has changed, make the necessary formatting, resizing, and 
repositioning adjustments to the elements on the slide. For more information on 
adjustments of slide elements, refer to the other chapters in this guide.

Note

Hovering the cursor over a layout in the Layouts section in the Properties deck on 
the Sidebar will display the layout type. These layout types match the layout list that 
is displayed in the context menu.

Presentation notes

Notes provide a convenient way to create reminders or add extra information to slides in a 
presentation. Notes are not displayed during a slide show. However, using dual displays, you can
display notes on the second display as a presentation cue.

Note

When using a second display, it is recommended to use the Presenter Console. The 
Presenter Console allows you to display on your screen the slide notes, the next 
slide, and other useful information while only the slide is shown on the second 
display. For more information on the Presenter Console, see Chapter 1, Introducing 
Impress and Chapter 9, Slide Shows.

Adding notes

1) Select a slide where you want to add notes.

2) Open the Notes view (Figure 16) using one of the following methods:

– Click on the Notes tab at the top of the Workspace.
– Go to View > Notes on the Menu bar.
– Click on Display Views and select Notes in Edit Modes on the Standard toolbar.

3) Click on Click to add notes below the slide then type or paste text or graphics as 
required into the notes box.

4) To add notes to another slide, repeat Steps 1 thru 3.

5) When you have finished adding notes, return to Normal view in the Workspace.
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Note

The notes text box and slide image can be moved and resized on the Notes page. 
Also, more text boxes can be added to the Notes page. Refer to the other chapters in
this guide for more information.

Figure 16: Notes view in Workspace

Figure 17: Master Notes view in Workspace

Presentation notes | 17



Figure 18: Slide Setup dialog

Formatting notes

It is recommended to use the Master Notes to format the appearance of notes, rather than 
formatting notes individually for each slide.

1) Select a slide that has notes added.

2) Open Master Notes view (Figure 17) using one of the following methods:

– Go to View > Master Notes on the Menu bar.
– Click on Master on the Standard toolbar, then click on the Notes tab at the top of the 

Workspace.
– Click on Display Views and select Master Notes in Master Modes on the Standard 

toolbar.

3) Open the Slide Setup dialog for master notes (Figure 18) using one of the following 
methods:

– Go to Slide > Properties on the Menu bar.
– Right-click in an empty area on the master note and select Properties from the 

context menu.

4) Use the various options available in the Slide Setup dialog to setup the master note. See 
Chapter 2, Master Slides, Styles and Templates for more information on the various 
options available in the Slide Setup dialog.

5) Click OK save the formatting changes and close the Slide Setup dialog.

Adding text

When text is inserted in the Notes text box, it is automatically formatted using the predefined 
Notes style that is in the Presentation Styles section in the Styles deck on the Sidebar. The 
Notes style cannot be deleted, but can be modified to match your requirements.
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Figure 19: Notes dialog

1) Click on Styles in the Sidebar to open the Styles deck.

2) Click on Presentation Styles at the top of the Styles deck to open the Presentation 
Styles section.

3) Right click on Notes presentation style and select Modify from the context menu. This 
opens the Notes dialog (Figure 19).

4) Use the various pages in the Notes dialog to modify the Notes style to your requirements.

5) Click OK to save your changes and close the Notes dialog.

Text boxes can also be added to the notes page and then modified to suit your requirements. 
Also, text styles for any text in a text box can be created to suit your text requirements. Any text 
styles created are placed in the Custom category. These custom styles can be deleted when you 
have no further requirement for the custom style.

For more information on creating styles, adding text, and formatting text, see Chapter 2, Slide 
Masters, Styles and Templates, or Chapter 3, Adding and Formatting Text.

Header and Footers

In Notes, information can be entered into the header and footer areas on the notes page. The 
header and footer areas are similar to the header and footer areas used in the master slides. The
header and footer areas are as follows:

    • Header text

    • Date and time – fixed or variable

    • Footer text

    • Page number
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Figure 20: Header and Footer dialog - Notes and Handouts page

1) Select a slide that has notes added.

2) Open the Notes view. See “Adding notes” on page 16.

3) Open Master Notes view. See “Formatting notes” on page 18.

4) Go to Insert > Header and Footer on the Menu bar to open the Header and Footer 
dialog (Figure 20).

5) Click on the Notes and Handouts tab to open the header and footer options for Notes.

6) To add header text to the notes page, check the Header option and enter the text for the 
header in the Header text text box.

7) To add the date and time to the notes page, check the Date and time option and enter a 
fixed or variable date and time as follows:

a) If the date and time is fixed, select the Fixed option and enter the date and time 
required in the Fixed text box.

b) If the date and time is variable, select the Variable option then select the date and 
time format from the Format drop down list and select the language used from the 
Language drop down list. The language selected will affect the date and time formats
that are available.

8) To add footer text to the notes page, check the Footer option and enter the text for the 
footer in the Footer text text box.

9) To add page numbers to the notes page, select the Page Number option so that the page
number appears on each notes page in a presentation.

10) Click on Apply to All to save the changes and close the Header and Footer dialog.
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Figure 21: Print dialog - LibreOffice Impress Notes page

Printing notes

Printing presentation notes gives you the opportunity to use the notes pages as handouts to the 
attendees of your presentation. For more information on printing slides and notes, see Chapter 
10, Printing, E-mailing, Exporting, and Saving Slide Shows.

1) Select a slide that has notes added.

2) Open the Notes view. See “Adding notes” on page 16.

3) Go to File > Print on the Menu bar, or use the keyboard shortcut Ctrl+P to open the Print 
dialog (Figure 21).

4) Select LibreOffice Impress to open the options for printing notes.

5) In Type, select Notes from the drop down list.

6) Select all other required options for printing, for example number of copies required and 
number of pages.

7) Click OK to print and close the Print dialog.

Exporting notes as PDF

1) Select a slide that has notes added.

2) Open the Notes view. See “Adding notes” on page 16.

3) Go to File > Export As > Export as PDF on the Menu bar to open the PDF Options 
dialog (Figure 22).

4) In Structure on the General page, make sure that the option Export notes pages is 
selected.

5) If necessary, select the option Export only notes pages to create a PDF file for the 
presentation notes only.
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Figure 22: PDF Options dialog

6) If required, select the other pages in the PDF Options dialog and select the various 
options you want to use when creating a PDF file.

7) Click on Export to open a file browser window.

8) Navigate to the folder where you want to save the PDF file.

9) Enter a filename, click on Save to save the file in the designated folder and close the file 
browser window and PDF Options dialog.

Note

If the presentation has 10 slides for example, the PDF will contain 20 pages 
consisting of 10 pages of individual slides followed by 10 pages of notes formatted 
for the paper size selected.

Adding comments

Impress supports comments similar to those in Writer and Calc.

1) Select Tools > Options > LibreOffice > User Data to configure the name and initials you
want to appear in the comment. This is necessary so that your initials appear in 
comments and identify you as the comment author.

2) In Normal View, go to Insert > Comment on the Menu bar or use the keyboard shortcut 
Ctrl+Alt+C to open a blank comment (Figure 23).

– A small box containing your initials appears in the upper left-hand corner of the slide, 
with a larger text box beside it. Impress automatically adds your name and the current
date at the bottom of the text box.

– If more than one person edits the document, each person is automatically allocated a 
different background color.

3) Type or paste your text into the comment.
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Figure 23: Adding comments

4) Move the small comment markers anywhere you wish on the slide. Typically you might 
place it on or near an object you refer to in the comment.

5) To show or hide the comment markers, choose View > Comments on the Menu bar.

Printing handouts

Handouts are used when you want to distribute a copy of the presentation slides to each member
of your audience. Handouts are only available in View > Master Handout on the Menu bar and 
are printed using the printing options in Impress.

Note

The printing of handouts depends on the printer, computer operating system, and 
how a computer is setup. The following printing procedure for handouts is only an 
example of how to print handouts.

1) Go to View > Master Handout on the Menu bar to set up the layout of slides for printing 
handouts. An example handout is displayed in the Workspace (Figure 24).

2) Go to Insert > Header and Footer on the Menu bar to open the Header and Footer 
dialog (Figure 20 on page 20).

3) Click on Notes and Handouts tab to open the page for notes and handouts in the 
Header and Footer dialog.

4) Select the required header and footer options from the default options. See “Header and 
Footers” on page 19 for more information.

5) Click on Apply to All to save your options for the handouts and close the Header and 
Footer dialog.

6) Go to File > Print on the Menu bar or use the keyboard shortcut Ctrl+P to open the Print 
dialog (Figure 21 on page 21).

7) Click on LibreOffice Impress to open the page for printing options of handouts.

8) In Document, select the required options from the drop down lists as follows:

– Type: – select Handouts from the drop down list.
– Slides per page: – select how many slides are printed on a sheet of paper.
– Order: – select the order in which the slides are printed on a sheet of paper.

9) In Contents, select Slide name, Date and time, or Hidden pages if you want one or all of 
these items printed on the handouts.
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Figure 24: Example handout in Workspace

10) In Color, select one option on how the handouts are printed.

11) In Size, select one option for size on how the handouts are printed.

12) Click on Print to print the handouts and close the Print dialog.
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