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Introduction

When is text used in drawings, it is contained in text boxes. This chapter describes how to create, 
format, use, and delete text. It also discusses the various types of text that can be inserted into a 
drawing. Finally, it provides information on how to insert special forms of text such as numbered or 
bulleted lists, tables, fields, and hyperlinks.

Using the text tool

To activate the text tool, click on the Text icon  for horizontal text or the Vertical Text icon  for 
vertical text on the Drawing toolbar. If the Vertical Text icon is not visible, check that the option 
Enabled for Asian languages has been selected in Tools > Options > Language Settings > 
Languages.

After activating the text tool, the Text Formatting toolbar (Figure 1) replaces the Line and Filling 
toolbar at the top of the drawing workspace. Click at the location where you want to position the 
text and a small text frame appears containing only the cursor.

When the Text icon is selected, you can select font type, font size, and other text properties before 
you start typing text. As you type the text, the left corner of the status indicates that you are in text 
edit mode and the position of your cursor (Figure 2).

Once you have finished typing your text and clicked outside the text frame or selected another tool 
from the Drawing toolbar, the Text Formatting toolbar is replaced by the default Line and Filling 
toolbar.

Figure 1: Text Formatting toolbar

Figure 2: Text information on the status bar

Using text boxes

Using text boxes, you can place text anywhere on your drawing; for example, a caption for a 
shape; an explanatory note; a title block for the drawing similar to those used in engineering 
drawings.

Creating a text box

1) Click on the Text icon  on the Drawing toolbar.
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2) Click and drag to draw a text box on the drawing. This sets the width. Do not worry about 
the height because the text box will expand as you type.

3) Release the mouse button when you have reached the desired width for your text box. The 
cursor appears in the text box and the text box has a hashed border indicating edit mode 
(Figure 3).

Figure 3: Text box in edit mode

4) Type or paste your text in the text box. The status bar at the bottom of your drawing 
workspace will indicate that you are in text edit mode and the cursor position within the text 
box.

5) Click outside the text box to deselect it.

To reposition the text box to a different part of the drawing, see “Moving a text box” on page 5; to 
change the width, see “Resizing a text box” on page 6.

Moving a text box
1) Click on the text to switch the text box into edit mode. The text box has a hashed border 

visible around the edges (Figure 3).

2) Move the cursor over the hashed border. The cursor changes shape to the move symbol 
for your computer setup (for example, a clenched hand).

3) When the move symbol appears, click once on the hashed border and selection handles 
appear.

4) With the cursor on the hashed border (but not on a selection handle), click and drag to 
move the text box to a new position. A semi-transparent copy of the text box shows where 
your text box will be placed (Figure 4). Also, depending on computer setup, guide lines may 
appear while you move the text box.

5) Release the mouse button when the text box is in the desired position.

Figure 4: Moving a text box
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Resizing a text box
1) Click on the text to switch the text box into edit mode. The text box has a hashed border 

visible around the edges (Figure 3).

2) Move the cursor over the hashed border. The cursor changes shape to the move symbol 
for your computer setup (for example, a clenched hand).

3) When the move symbol appears, click once on the hashed border and selection handles 
appear.

4) Move the cursor over one of the selection handles and the cursor changes shape to the 
resizing symbol for your computer setup (for example, a double headed arrow).

5) Click and drag the border to a new position to resize the text box (Figure 5). Depending on 
computer setup, guide lines may appear while you move the text box.

6) Release the mouse button when the text box reaches the desired size.

Figure 5: Resizing a text box

Note

Use the selection handles at the top and bottom of the text box to resize the text box 
height.

Use the selection handles at the left and right side of the text box to resize the text 
box width.

Use the corner selection handles to resize the height and width of the text box while 
maintaining the aspect ratio of the text box.

Tip
To maintain the aspect ratio of a text box while resizing, press and hold the Shift key, 
then click and drag. Make sure to release the mouse button before releasing the 
Shift key.

Using the Position and Size dialog
For more accurate control over the size and position of a text box you can use the Position and 
Size dialog.

1) Click on the text to switch the text box into edit mode.

2) Press the F4 key or select Format > Position and Size from the menu bar to open the 
Position and Size dialog (Figure 6).

The options available on the Position and Size dialog are as follows:

• Position – specifies the location of the selected object on the page.
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Figure 6: Position and Size dialog

– Position X – enter the horizontal distance that you want to move the object relative to 
the base point selected in the grid.

– Position Y – enter the vertical distance that you want to move the object relative to the 
base point selected in the grid.

• Base point – click a base point in the grid and then enter the amount that you want to shift 
the object relative to the base point that you selected in the Position Y and Position X 
boxes. The base points correspond to the selection handles on an object.

• Size – specifies the amount by which you want to resize the selected object with respect to 
the selected base point.
– Width – enter a width for the selected object.

– Height – enter a height for the selected object.

– Keep ratio – maintains proportions when you resize the selected object.

• Base point – click a base point in the grid and then enter the new size dimensions for the 
selected object in the Width and Height boxes.

• Protect – prevents any editing of an object.
– Position – prevents changes to the position or the size of the selected object.

– Size – prevents you from resizing the object.

• Adapt – resizes text in a drawing object with respect to the borders of the selected object.
– Fit width to text – resizes the text to fit the width of the selected object.

– Fit height to text – resizes the text to fit the height of the selected object.

Deleting a text box
1) Click on the text to switch the text box into edit mode.

2) Move the cursor over the hashed border. The cursor changes shape to the move symbol 
for your computer setup (for example, a clenched hand).

3) When the move symbol appears, click once on the hashed border and selection handles 
appear.

4) Press the Delete key.

Using text boxes 7



Tip
Sometimes it is quicker to to delete a text box by dragging a selection rectangle 
around the text box and then hitting the Delete key. Take care to avoid selecting and 
accidentally deleting other text boxes or shapes.

Using text with Draw objects

Text can be added to most Draw objects. The exceptions are control elements like buttons, list 
boxes, or 3D objects. An object is not dynamic and does not behave like a text frame. To keep text 
within the borders of the object, you have to use paragraphs, line breaks, or smaller text size, 
increase the object size, or combine all four methods.

To add text to an object:

1) Select the object.

2) Select the Text icon on the Drawing toolbar and a text cursor starts flashing in the center 
of the selected object.

3) Start typing your text (Figure 7). The status bar will indicate that you are editing text, as 
shown in Figure 2.

Figure 7: Adding text to an object

Note If the Double-click to edit Text icon  on the Options toolbar is selected, you 
can start adding text to an object by double-clicking on the object without first 
selecting it.

Inserting text

Pasting text
Text may be inserted into a text box or object by copying it from another document and pasting it 
into a text box or object on your drawing. However, pasted text may not match the formatting of the 
text that has already been included on your drawing. This may be what you want on some 
occasions, but in most cases it is better to make sure that text format is consistent throughout your 
drawing.

Pasting unformatted text
It is good practice to paste text without formatting and apply the formatting later so it matches the 
text already in your drawing or make the text fit within the borders of an object.

1) Copy the text you want to use, then move your cursor into position on your drawing.
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2) Go to Edit > Paste Special on the main menu bar or use the keyboard shortcut 

Control+Shift+V or click on the small triangle next on the right of the Paste icon  on the 
Standard toolbar.

3) Select Unformatted text from the dialog or context menu that appears. The text will be 
pasted at the cursor position and formatted to the default paragraph style of the text box or 
object.

Formatting pasted text
1) Select the text you have just pasted (see “Selecting text” on page 11 for more information).

2) Use the formatting tools that are available on the Text Formatting toolbar, or go to Format 
on the main menu bar and select a formatting tool from the drop down menu, or right-click 
on the text and select a formatting tool from the context menu.

3) Alternatively, go to Format > Styles and Formatting or press the F11 key to open the 
Styles and Formatting dialog. See “Using styles” on page 11 for more information.

Inserting special characters
To insert special characters, such as copyright, math, geometric, or monetary symbols, or 
characters from another language:

1) Click on the Text icon  and then click in the text where you want to insert the character.

2) Go to Insert > Special Character on the main menu bar or right-click and select Special 
Characters from the context menu to open the Special Characters dialog (Figure 8).

3) Alternatively, click on the Special Character icon  on the Text Formatting toolbar to 
open the Special Characters dialog. If this icon is not visible, click on the small triangle at 
the right of the toolbar and go to Visible Buttons > Special Character and the icon will be 
placed on the toolbar.

4) Select the font and character subset from the Font and Subset options in the Special 
Characters dialog.

5) Select the character you want to insert. You may have to scroll to find the character you 
want.

6) Click OK.

Figure 8: Special Characters dialog
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Note

Characters you select will be inserted in the order they were selected, even if you 
accidentally click on the wrong character. Clicking on another character will only add 
it to the ones being inserted. Click Delete to delete all the characters selected, then 
click on the correct characters.

Inserting non-breaking spaces and hyphens
Where it is not desirable for words that are separated by a space or a hyphen to span over two 
lines, or where an optional hyphen is desired, you can insert a special formatting mark. Draw 
supports the following formatting marks:

• Non-breaking space – inserts a space that will keep bordering characters together on line 
breaks.

• Non-breaking hyphen – inserts a hyphen that will keep bordering characters together on 
line breaks.

• Optional hyphen – inserts an invisible hyphen within a word that will appear and create a 
line break once it becomes the last character in a line.

• No-width optional break – inserts an invisible space within a word that will insert a line 
break once it becomes the last character in a line. Only available when complex text layout 
(CTL) is enabled.

• No-width no break – inserts an invisible space within a word that will keep the word 
together at the end of a line. Only available when complex text layout (CTL) is enabled.

• Left-to-right mark – inserts a text direction mark that affects the text direction of any text 
following the mark. Only available when complex text layout (CTL) is enabled.

• Right-to-left mark – inserts a text direction mark that affects the text direction of any text 
following the mark. Only available when complex text layout (CTL) is enabled.

To insert a non-breaking space, or hyphens, or access the formatting marks:

1) Click on the Text icon and place the cursor in the text where you want to use formatting 
marks.

2) Go to Insert > Formatting Mark on the main menu bar.

3) Select the formatting mark you want to use from the context menu that opens. A 
non-breaking space can be inserted using the keyboard shortcut is Ctrl+Shift+Space. A 
no-width-optional break can be inserted using the keyboard shortcut is Ctrl+Slash.

Formatting text

The appropriate use of text formatting can give text in a drawing a consistent look, making your 
drawing look more professional without any distracting elements.

Tip

Sometimes it is very useful to re-apply the default style to a selection of text removing 
any manual formatting applied to it, especially if a mistake has been made and you 
are not sure how to undo it. To revert back to the default style, select the manually 
formatted text and then select Format > Default formatting from the main menu bar.

Formatting text may require some intervention in three areas:

• Character attributes (for example, font color or emphasis)

• Paragraph attributes (for example, alignment or spacing)

• List attributes (for example, type of bullet or indent spacing)
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In some cases it is quicker and more efficient to apply manual formatting; but in situations where 
you need to perform the same modifications to many different parts of the drawing, the use of 
styles is recommended.

Selecting text
Text must be selected before it can be formatted.

To format all the text in a text box:

1) Click on the Text icon and then click once on the text.

2) Click once on the border of the text box. The selection handles are displayed.

3) Any formatting changes will apply to all the text in the text box.

To format only part of the text:

1) Click on the Text icon and then click once on the text.

2) Select the text to be formatted by clicking and dragging over it (highlighting). You can also 
use keyboard combinations to select text: move the cursor where you want to begin your 
selection, press Shift and then use the arrow keys to extend your selection.

3) Any formatting changes will apply only to the selected text.

Tip

To select text word by word, instead of by character, press the Control key and Shift 
key together. To speed up the selection even further, you can combine the Shift key 
with the Home key or the End key to extend the selection up to the start or end of the 
line in which the cursor is positioned, respectively.

Using styles
Only graphic styles are available in Draw to format text. Each graphic style listed in the Styles and 
Formatting dialog (Figure 9) has default settings for formatting and layout. You can create new 
styles and modify the styles supplied with Draw.

Creating a style
1) Go to Format > Styles and Formatting on the main menu bar or press the F11 key to 

open the Styles and Formatting dialog (Figure 9).

2) Right-click on a style name and select New from the context menu to open the Graphic 
Styles dialog (Figure 10).

3) Using the Graphic Styles dialog, you can set all the attributes for your text and paragraph 
by clicking on the various tabbed pages that are available. Click OK when finished and 
your new style is added to the list in the Styles and Formatting dialog.

4) Alternatively, select your text and perform all the changes to format, then click on the New 

Style from Selection icon  to open the Create Style dialog.

5) Type a unique style name and click OK. This closes the Create Style dialog and your new 
style is added to the list in the Styles and Formatting dialog.

Modifying a style
1) Go to Format > Styles and Formatting on the main menu bar or press the F11 key to 

open the Styles and Formatting dialog (Figure 9).

2) Right-click on the style to be modified and select Modify from the context menu to open the 
Graphic Styles dialog (Figure 10).
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Figure 9: Styles and Formatting dialog

Figure 10: Graphic Styles dialog

3) Using the Graphic Styles dialog, modify all the attributes for your text and paragraph by 
clicking on the various tabbed pages that are available.

4) Click when finished making changes and the style is saved with the new format attributes.

5) Alternatively, select your text and perform all the changes to format, then select a style in 
the Styles and Formatting dialog.

6) Click on the Update Style icon  and the style is saved with the new format attributes.
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Formatting characters

Text characters can be independently formatted from the format used for a paragraph of text. This 
character formatting will also override any formatting that has been applied using a graphic style. 
Note that character styles do not exist in Draw.

1) Click on the Text icon, then select the characters you want to format.

2) Go to Format > Character, or click the Character icon  on the Text Formatting 
toolbar, or right-click on the selected character and select Character to open the 
Character dialog (Figure 11).

3) Make your changes to the character format using the tabbed pages, then click OK to save 
your changes.

4) Clicking on the Reset button will cancel any changes you have made to the character 
format and the character will revert back to the paragraph formatting.

Figure 11: Character dialog

If support for Asian language and Complex Text Layout (CTL) font has been enabled (Tools > 
Options > Language Settings > Languages), the Font page is divided into three parts for 
Western, Asian and CTL text fonts allowing you to specify text fonts and their attributes for the 
majority of font families.

The tabbed pages in the Character dialog are used as follows:

• Font – select the desired font type, its base attributes (Italic, Bold, etc.) as well as the size. 
A sample of the font is displayed in the lower part of the dialog. You can also specify the 
language. This font page is also available when creating or modifying a graphics style.

• Font Effects – apply special effects to the text, such as over lining and underlining, color, 
shadow and so on. A sample of the text is displayed in the lower part of the dialog, 
providing a quick visual check of the effects applied. This page is also available when 
creating or modifying a graphics style.

• Position – sets the text position relative to the baseline when you need to insert subscripts 
or superscripts. This page is not available when creating or modifying a graphics style.
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– Scaling – specifies the percentage of the font width by which to compress or expand 
the individual characters of the selected text.

– Spacing – sets the spacing between the characters of the font, which can be defined in 
number of points.

– Pair kerning – automatically adjusts the spacing between certain pairs of characters to 
visually improve the appearance.

Formatting paragraphs

Paragraph formatting will override any formatting that has been applied using a graphic style.

1) Click on the Text icon then select the paragraph you want to format.

2) Go to Format > Character, or click the Paragraph icon  on the Text Formatting 
toolbar, or right-click on the selected text and select Paragraph to open the Paragraph 
dialog (Figure 12).

3) Make your changes to the character format using the tabbed pages then click OK to save 
your changes.

4) Clicking on the Reset button will cancel any changes you have made to the paragraph 
format and the text will revert back to its original formatting.

Figure 12: Paragraph dialog

The tabbed pages in the Paragraph dialog are used as follows:

• Indents and Spacing – this page is the default page when the Paragraph dialog.

– Indent – modifies the indentation of the text (before and after) as well as the indentation 
of the first line.

– Spacing – defines the space before and after each paragraph formatted with the style.

– Line spacing – determines the spacing between two lines formatted with the style. Note 
that selecting Proportional spacing requires specifying the percentage of a line to be 
used as spacing; 100% single line, 200% double line, 50% half a line. If Leading is 
selected, specify the amount of line spacing in your default unit of measurement.
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Tip
Setting line spacing to less than 100% is a good method to cram a lot of text into a 
text box, however care must be taken as too small a value will make the text hard to 
read.

Tip
You can change the default unit of measurement by going to Tools > Options > 
LibreOffice Impress > General.

• Alignment – determines the paragraph alignment: Left, Right, Center, or Justified. A 
preview shows the effects of the changes. This page is also available in the graphics styles 
dialog. The same alignment options can be accessed using the paragraph alignment icons 

 on the Text Formatting toolbar.

Note
If you have Complex Text Layout enabled in Tools > Options > Language Settings 
> Languages, an extra selection — Text Direction — appears at the bottom of the 
dialog; you can choose Left-to-right or Right-to-left.

• Tabs – determines the tab stops. This page is also available in the graphics styles dialog.

• Asian Typography – sets the following properties relative to line changes and is only 
available if Enabled for Asian Languages is selected in Tools > Options > Language 
Settings > Languages. This page is also available in the graphics styles dialog.

– Apply list of forbidden characters to the beginning and end of lines.

– Allow hanging punctuation.

– Apply spacing between Asian, Latin and Complex text.

Creating bulleted and numbered lists

Bulleted and numbered lists can be created in text boxes, shapes and objects. When creating lists 
in shapes and objects, remember that shapes and objects are not dynamic and do not expand as 
you create a list.

Creating lists
1) Click on the Text icon then select the text you want to use for a bulleted list.

2) Go to Format > Bullets and Numbering, or right-click on the selected text and select 
Bullets and Numbering to open the Bullets and Numbering dialog (Figure 13).

3) Select the list style from the Bullets, Numbering or Graphics pages then click OK to save 
your changes.

4) Alternatively, click the Bullets On/Off icon  on the Text Formatting toolbar, This quickly 
creates a list using the previously selected settings in the Bullets and Numbering dialog.

5) Clicking on the Reset button will cancel any changes you have made and the text will 
revert back to its original formatting.

Editing and customizing a list
You can edit and customize the appearance of a list by changing the bullet type or numbering for 
the entire list or single entry or the outline level of a list item. All changes are made using the 
Bullets and Numbering dialog.
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Figure 13: Bullets and Numbering dialog

Editing a list
1) Click on the Text icon, then select the list or the items in the list that you want to edit and 

customize.

2) Go to Format > Bullets and Numbering, or right-click on the selected text and select 
Bullets and Numbering to open the Bullets and Numbering dialog (Figure 13).

3) Select a new list style from the Bullets, Numbering or Graphics pages.

4) Click OK to save your changes.

Changing position
Use the Position page (Figure 14) to adjust the outline level, indentation and spacing of bullet 
points and the associated text. This page is particularly effective when used in combination with 
the Customize page.

To set up an outline level:

1) Select an outline level from the list on the left hand side of the page or select levels 1 – 10 
to modify all levels simultaneously.

2) Set the Indent, which is the spacing between the bullet or number and the text. If you 
select the Relative option, the indent value will be measured relative to the previous level 
and not from the margin.

3) Set the measurement for Width of numbering. This is the space to leave between the 
numbering or bullet point and the text.

4) Set the Numbering alignment and is normally only used on a numbered list. Setting this 
option does not set the alignment of the text.

a) Select Left to align the numbering at the left edge of the alignment space for numbering.

b) Select Right to align the numbering at the right edge of the alignment space for numbering.

c) Select Centered to align the numbering in the center of the alignment space for numbering.
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Figure 14: Bullets and Numbering – Position page

5) Click OK to save your changes.

6) To revert back to the default values of the list, click Reset.

Tip

To fully appreciate how Numbering alignment works, create a numbered list with 
more than ten elements and making sure there is enough room for a two (or more) 
numerical characters using the Width of numbering field. Select Right alignment and 
the right edge of the numbers will form a neat, straight line next before the text.

Customizing
Use the Customize page (Figure 15) to customize the style of all the outline levels. The options 
available on this page depend on the type of marker selected for the list.

Depending on the bullet style selected (bullet, numbering; graphic), some of the following options 
may not be available on the Customize page:

• Before: enter any text to appear before the number (for example, Step).

• After: enter any text to appear after the number (for example, a punctuation mark).

• Color: pick the color for the list marker (number or bullet character).

• Relative size: specify the size of the number relative to the size of the characters in the 
paragraph of the list.

• Start at: enter the first value of the list (for example, you might want the list to start at 4 
instead of 1).

• Character button: click this button to select the special character for the bullet.

• Graphics: opens a gallery of available graphics or allows the selection of a graphic file 
used as a marker. 

• Width and Height: specify the dimensions of the graphic marker.

• Keep ratio checkbox: if selected, the ratio between the width and the height of the graphic 
marker is fixed.
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Figure 15: Bullets and Numbering – Customize page

1) Select first the level you want to modify on the left hand side of the box. To modify all levels 
at once, select 1 – 10 as the level. With levels being arranged in a hierarchical structure, 
changing, for example, the font attribute of one of the levels ripples through all the lower 
levels.

2) Make your changes to your list using the options on this page. The preview on the right 
hand side of the dialog shows the effect of the changes.

3) Click OK to save your changes.

4) To revert back to the default values of the list, click Reset.

Using tables

Tables are useful when you want to show structured information in your drawing, for example a 
specification list or drawing title block. You can create tables directly in Draw, eliminating any need 
to embed a Calc spreadsheet or a Writer text table in your drawing. The tables provided by Draw 
do have a limited functionality.

Creating a table
When working with tables, it is useful to know the number of rows and columns needed as well as 
the appearance. Tables are placed on a drawing in a text box and cannot be placed into objects or 
shapes. Also, unlike text boxes and other graphic objects, tables cannot be rotated.

Figure 16: Insert Table dialog
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To insert a table, proceed as follows:

1) Go to Insert > Table on the main menu bar to open the Insert Table dialog (Figure 16).

2) Select the number of columns and number of rows for your table.

3) Click OK and a table is placed in the center of your drawing inside its own text box.

4) Move your table into position by dragging it to its new position, or using the method in 
“Using the Position and Size dialog” on page 6.

Modifying a table
Once the table is added to your drawing, you can control its appearance, size, position and so on 
using a combination of the tools on the Table toolbar (Figure 17 and Figure 18) and the Format 
Cells dialog (Figure 22). The Table toolbar is only active when a table has been selected. If the 
Table toolbar does not display when you select a table, go to View > Toolbars > Table.

Figure 17: Table toolbar

Figure 18: Table tools

Figure 19: Table graphic tool
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Table toolbar
The Table toolbar contains the majority of the tools you need to manipulate a table. These tools 
are shown in Figure 18 and described below.

• Table – creates a new table in a drawing. Opens the Insert Table dialog (Figure 16) where 
you can select the required number of rows and columns. Alternatively, click on the small 
triangle next to the Table icon to open a graphic representation for creating a table (Figure 
19). To use this tool, move the mouse to the right and down in the grid until you have the 
columns and rows you require and click the left mouse button.

• Line Style – changes the line style of the borders of selected cells. Opens a new dialog 
where you can choose from a range of predefined styles.

• Line color (of the border) – opens a color selection dialog where you can choose the 
color of the borders around selected cells.

• Borders – selects predefined border configurations. The borders are applied to the 
selected cells. If the desired border pattern is not available, you will need to use the 
Format Cells dialog.

• Area Style/Filling – select the cells to be filled, then select the type of fill from the drop 
down list: Invisible (no color), Color, Gradient, Hatching, or Bitmap. Depending on the fill 
type selected, the fillings drop-down menu is populated with the available fillings for the fill 
type selected.

• Merge Cells – merges the selected cells into one cell. Note that the contents of the merged 
cells are also merged. You can also merge cells by right-clicking in the selected cells and 
using the context menu that opens.

• Split Cells – opposite operation of merging cells. Make sure that the cursor is positioned 
on the cell you want to split, then click to open the Split Cells dialog (Figure 20). Select the 
number of cells required from the split as well as whether the cell should be split 
horizontally or vertically. When splitting horizontally, you can select the Into equal 
proportions option to get all cells of equal size. The contents of the split cell remain in the 
original cell (the one on the left or top). You can also split cells by right-clicking in the cell 
and using the context menu that opens.

Figure 20: Split Cells dialog

• Optimize – evenly distributes the selected cells either horizontally or vertically. If you want 
to optimize the whole table, you can evenly distribute columns or rows by clicking on the 
small triangle next to the icon and selecting Distribute Columns Evenly or Distribute 
Rows Equally.

• Top, Center (vertical), Bottom– you can select the vertical alignment of text in a cell by 
selecting the required cells and clicking on one of these tools.

• Insert Row, Insert Column, Delete Row, Delete Column – select a row or column and 
use these four tools to insert or delete rows and columns into or from your table. Rows and 
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columns are inserted/deleted below and to the right of the selected cell. You can also 
select, insert or delete rows and columns by right-clicking a cell and using the context 
menu that opens.

• Select Table, Select Column, Select Row – Use these tools to select a table, column or 
row if you want to perform the same change to attributes for a table, column or row.

• Table Design – opens the Table Design dialog (Figure 21) where you can select a table 
style and display options.

Figure 21: Table Design dialog

• Table Properties – opens the Format Cells dialog (Figure 22), which contains the 
following tabbed pages. You can also open this dialog by right-clicking on the table and 
selecting Table from the context menu.

Figure 22: Format Cells dialog
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– Font – use to select the desired font type and family, style (Italic, Bold, etc.), size and 
language. A sample of the font is displayed in the lower part of the dialog.

– Font Effects – use to apply effects to the text: font color; relief; overlining; strikethrough; 
underlining and emphasis mark.

– Borders – use to set borders and border properties not available when using the 
Borders tool on the Table toolbar; line arrangement (default or user defined), line 
(style, width, and color) and spacing to contents (cell margins).

– Background – changes the background of the selected cells and provides the same 
functions as the Area Style/Filling tool on the Table toolbar.

– Reset – clicking this button resets the table back to default values.

Position and size
You can change table position and size on a drawing by using the mouse or, for more accurate 
control, with the Position and Size dialog (Figure 6 on page 7). When the table is selected, right-
click on the table and select Position and Size from the context menu or go to Format > Position 
and Size on the main menu bar or press the F4 key to open the dialog. See “Using the Position 
and Size dialog” on page 6 for more information.

Note Unlike text boxes and other graphic objects, tables cannot be rotated.

Deleting a table
To delete a table:

1) Click and drag over the table to select it.

2) Click on the text box border around the table.

3) Press the Delete key.

Using fields

Fields allow the automatic insertion of text into a drawing. You can think of a field as a kind of 
formula which is calculated when the drawing is loaded or printed and the result is written in the 
drawing.

Inserting a field
To insert a field into a drawing:

1) Move the cursor where the field will be positioned. The text box created when you insert a 
field can be repositioned just like a text box.

2) Go to Insert > Fields on the main menu bar.

3) Select a field from the options shown in the context menu.

The fields available in Draw are as follows:

• Date (fixed): inserts the date at the date of inserting the field.

• Date (variable): inserts a field that is updated with the date at the time of opening the file.

• Time (fixed): inserts a field displaying the time at the time of insertion.

• Time (variable): inserts a field which is updated with the time at the time of opening the 
file.
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• Author: inserts the author of the drawing. This information is derived from the value 
recorded in the general options. To modify this information go to Tools > Options > 
LibreOffice > User Data.

• Page Number: inserts the page number of the slide.

• Page Count: inserts the total number of slides.

• File Name: inserts a field that contains the name of the file.

Customizing fields
The appearance of fields can be customized as follows. The Page Number, Page Count, and File 
Name fields cannot be customized.

Figure 23: Edit Field dialog

1) Right-click on the field data to open the Edit Field dialog (Figure 23).

2) Select the desired format from the options available.

3) Click OK.

Using hyperlinks

When inserting text (such as a website address or a URL) that can be used as a hyperlink, Draw 
formats it automatically, creating the hyperlink and applying color and underlining.

To insert a hyperlink, or to customize the appearance of a hyperlink, go to Insert > Hyperlinks on 

the main menu bar or click on the Hyperlink icon  on the Standard toolbar to open Hyperlink 
dialog (Figure 24).

On the left side, select one of the four types of hyperlinks. The dialog changes according to the 
type of hyperlink selected.

• Internet: choose whether the link is Web or FTP. Enter the required web address (URL).

• Mail & News: choose whether the link is an E-mail or news link. Enter the receiver address 
and for email, also the subject.

• Document: creates a hyperlink to another document or to another place in the drawing, 
commonly referred to as a bookmark. Enter the document path, or click on the Open File 
icon to open a file browser; leave this blank if you want to link to a target in the same 
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drawing. Optionally, you can specify a target (for example. a specific slide). Click on the 
Target icon to open the Target in Document dialog, where you can select the target; or, if 
you know the name of the target, you can type it into the box.

Figure 24: Hyperlink dialog

• New Document: creates a hyperlink to a new document. Choose whether to edit the newly 
created document immediately (Edit now) or just create it to edit later (Edit later). Choose 
the type of document to create (text, spreadsheet, etc.). The Select path button opens a 
file browser so that you can choose the directory for the new document.

Tips

To prevent LibreOffice from automatically turning website addresses (URLs) into 
hyperlinks, go to Tools > AutoCorrect > Options and deselect the URL Recognition 
checkbox.

To change the color of hyperlinks, go to Tools > Options > LibreOffice > 
Appearance, scroll to Unvisited links and/or Visited links, select the checkboxes, 
pick the new colors and click OK. Caution: this will change the color for all hyperlinks 
in all components of LibreOffice which may not be what you want.

The Further settings section on the Hyperlink dialog is common to all the hyperlink types, although 
some choices are more relevant to some types of links.

• Frame – determines how the hyperlink will open. This applies to documents that open in a 
Web browser.

• Form – specifies if the link is to be presented as text or as a button. See “Working with 
hyperlink buttons” on page 25 for more information.

• Text – specifies the text that will be visible to the user.

• Name – applicable to HTML documents. It specifies text that will be added as a NAME 
attribute in the HTML code behind the hyperlink.

Editing text hyperlinks
1) Select the hyperlink by dragging across the text, not clicking on it.

2) Go to Edit > Hyperlink from the main menu bar.

3) Make changes as needed and click Apply when done. If you need to edit several 
hyperlinks, click Apply after each one. 

4) When you are finished editing hyperlinks, click Close.

24 Adding and Formatting Text



Working with hyperlink buttons
A hyperlink button is inserted in the center of the current drawing. In most cases, that is not where 
you want it to appear. To edit the text or size of a hyperlink button, or to move it to another place on 
the drawing:

1) Go to View > Toolbars > Form Controls on the main menu bar to open the toolbar (Figure 
25).

2) Select the Design Mode On/Off icon (highlighted).

3) Now click on the hyperlink button and drag it to another position, or right-click to open a 
dialog where you can change the text on the button, the size of the button, and other 
properties.

4) When you have finished editing the button, click the Design Mode On/Off icon again to 
make the button inactive. For a detailed description of the properties and how to work with 
Form Controls, refer to the Writer Guide.

Figure 25: Form Control toolbar
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