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What is Writer?
Writer is the word processor component of LibreOffice, a freely available, fully-featured office
productivity suite. In addition to the usual features of a word processor (text entry, editing, and
formatting; spelling checker, thesaurus, hyphenation, and autocorrect; find and replace; and
others), Writer provides these important features:
•

Change tracking during revisions (Chapter 4)

•

Page layout methods, including styles, frames, columns, and tables (Chapters 5 and 6)

•

Export to PDF and ePub (Chapter 7)

•

Document digital signatures (Chapter 7)

•

Templates and styles (Chapters 8, 9, and 10)

•

Built-in drawing tools (Chapter 11)

•

Lists (Chapter 12)

•

Tables of data (Chapter 13)

•

Mail merge (Chapter 14)

•

Automated tables of contents and indexes (Chapter 15)

•

Master documents, to group a collection of documents into a single document (Chapter 16)

•

Fields and forms (Chapters 17 and 18)

•

Database integration, including a bibliography database (Chapters 14, 15, and 18)

•

Embedding or linking of spreadsheets, equations, and other objects (Chapter 19)

•

And many more

Parts of the main Writer window
The main Writer window is shown in Figure 1. Its features are described in this section.

Title bar
The Title bar is located at the top of the Writer window. It shows the file name of the current
document. When the document is not yet named, the document name will appear as Untitled X,
where X is a number. Untitled documents are numbered in the order in which they are created.

Menu bar
The Menu bar is located just below the Title bar in Windows and Linux and at the top of the screen
in macOS. When you select one of the menus, a submenu drops down to show further options,
including:
•

Commands that directly cause an action, such as Close or Save, in the File menu.

•

Commands that open dialogs. These are indicated by an ellipsis (…) following a command,
such as Find or Paste Special, in the Edit menu.

•

Commands that open further submenus. These are indicated by a right-pointing arrow
following a command, such as Toolbars and Zoom, in the View menu. Moving the cursor
onto one of these items causes its submenu to open.
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Figure 1: Parts of the main Writer window

Sidebar
The Sidebar is normally open by default on the right side of the Writer window, as shown in Figure
1. If necessary, select View > Sidebar from the Menu bar to display it. The Sidebar also has a
Hide/Show icon, as shown in Figure 2. When the Sidebar is closed, it can be opened by clicking
this icon, which will be on the far right side of the window.
The Writer Sidebar contains five decks by default: Properties, Page, Styles (shown as Styles and
Formatting in some installations), Gallery, and Navigator. Each deck can be opened by clicking its
corresponding icon on the Tab bar to the right of the sidebar.
Two additional decks are available: Manage Changes and Design. By default, they are not
enabled. See further information on page 8.
Each deck consists of a title bar and one or more content panels. A panel is like a combination of
toolbar and dialog. Toolbars and Sidebar panels share many functions. For example, the icons for
making text bold or italic exist in both the Formatting toolbar in the main Writer window and the
Character panel of the Properties deck.
Some panels contain a More Options button, which opens a dialog with additional editing controls.
When the dialog is open, the document is locked for other editing.
To adjust the width of the Sidebar, place the cursor on its left edge. When a double-headed arrow
appears, click and drag to right or left. When the Properties deck is open, you cannot make the
Sidebar smaller than a certain width. When any other deck is open, the Sidebar can be collapsed
to the width of its Tab bar.
To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the drop-down list
in the Sidebar Settings above the Tab bar (see Figure 2). From the same list, you can choose
which tabs to include in the Sidebar.
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Sidebar settings
Title bar

Tabs

Hide/show
button

Panel title
Panel contents

Deck

More Options button
Figure 2: Properties deck of Sidebar

Sidebar
Settings

Figure 3: Sidebar Settings menu

Sidebar decks
The decks contained in the Sidebar are described below.
Properties deck: Contains tools for directly formatting content.
When text is selected, these panels appear:
–

Styles: Apply, create, or update a paragraph style.

–

Character: Modify text by the font type, size, color, weight, or spacing.

–

Paragraph: Modify a paragraph by alignment, lists or bullets, background color, indent,
or spacing.

Parts of the main Writer window | 7

When a graphic is selected, these panels appear:
–

Area: Modify the fill mode and transparency of the background.

–

Graphic: Modify the graphic's brightness, contrast, color mode, or transparency.

–

Wrap: Modify the position of the graphic relative to surrounding text, where these
modifications are available.

–

Position and Size: Modify width and height.

When a drawing object is selected, these panels appear:
–

Area: Modify the fill mode and transparency of the background.

–

Line: Modify line style, width, color, or arrows.

–

Position and Size: Modify width, height, rotation, or flip.

When a frame is selected, the wrap panel opens but may be grayed out if frame wrap is not
available.
Page deck: Contains tools for directly formatting the page. It has four panels:
–

Format: Modify the size, width, height, orientation, and margins of the page.

–

Styles: Modify the page numbering style, background, layout, and number of columns.

–

Header: Activate/deactivate the header and modify its margins, spacing, and contents.

–

Footer: Activate/deactivate the footer and modify its margins, spacing, and contents.

Caution
Be aware that by changing the options on the Page deck, you will change the page
style in use, modifying not only the current page but all pages using the same page
style in this document.
Styles deck: (Titled Styles and Formatting on some installations.) Manage the styles used in the
document, apply existing styles, create new styles, or modify them. For more information, see
Chapter 8, Introduction to Styles, and Chapter 9, Working with Styles.
Gallery deck: Add images and diagrams included in the Gallery themes. The Gallery has two
sections: the first lists the themes by name (Arrows, Background, Diagrams, etc.) and the second
displays the images in the selected theme. Select the New Theme button to create new themes.
To insert an image into a document, or add a new image to the Gallery, drag and drop the selected
image. For more information, see Chapter 11, Images and Graphics.
Navigator deck: Browse the document and reorganize its content by selecting content categories,
such as headings, tables, frames, graphics, and so on. For more information, see “Using the
Navigator” on page 21.
Manage Changes deck: When changes have been recorded in a document, you can view, accept,
or reject them in this deck. It provides the same functions as the floating Manage Changes window.
This deck is available only when Experimental Features is enabled in Tools > Options >
LibreOffice > Advanced. For more information on managing changes, see Chapter 3, Working
with Text: Basics.
Design deck: Provides quick access to document design themes (fonts and colors) and style
presets. This deck is available only when Experimental Features is enabled.
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Toolbars
LibreOffice has two types of toolbar locations: docked (fixed in place) or floating. Docked toolbars
can be moved to different locations (for example, top, bottom, or side of the workspace) or made to
float. Floating toolbars can be docked.

Displaying or hiding toolbars
To display or hide toolbars, go to View > Toolbars on the Menu bar, then click the name of a
toolbar in the drop-down list. An active toolbar shows a checkmark beside its name. Note that
toolbars created from tool palettes are not listed in the View menu.
To hide a toolbar, go to View > Toolbars on the Menu bar and deselect the toolbar, or right-click in
an empty space between the icons on a toolbar and select Close toolbar from the context menu.

Most-used toolbars
In a default LibreOffice installation (see Figure 1), the top toolbar, just under the Menu bar, is called
the Standard toolbar.
The second toolbar at the top is the Formatting toolbar. It is context-sensitive; that is, it shows the
tools relevant to the current position of the cursor or the selected object. For example, when the
cursor is in text, the Formatting toolbar provides tools for formatting text. When the cursor is on a
graphic (image), the tools are for formatting images.
To free more space for the document, you can choose a single-toolbar alternative containing the
most-used commands. To activate it, enable View > Toolbars > Standard (Single Mode) and also
disable View > Toolbars > Standard and View > Toolbars > Formatting.
Other toolbars are available at View > Toolbars. They are discussed in the relevant chapters of
this book.

Sub-menus and tool palettes
Toolbar icons with a small triangle to their right will display sub-menus, tool palettes, or other
methods of selecting items, depending on the icon.
A tool palette is a pop-up collection of tools attached to a single tool in a toolbar. The palette can be
made into a floating toolbar, as shown in Figure 4. Once removed from the parent toolbar, it
displays a Title bar. Tool palettes can be floating or docked along an edge of the screen or in one of
the existing toolbar areas.

Figure 4: Example of tearing off a tool palette

Moving toolbars
Docked toolbars can be undocked and either moved to a new docked position or left as a floating
toolbar.
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To undock a toolbar:
1)

Move the mouse cursor over the toolbar handle, which is the small vertical bar to the left of
a docked toolbar and highlighted in Figure 5.

2)

Hold down the left mouse button and drag the toolbar to the new location.

3)

Release the mouse button.

Figure 5: Toolbar handles
To move a floating toolbar, click its title bar and drag it to a new floating location or dock the toolbar
at the top or bottom of the main window.

Note
You can also dock a floating toolbar by holding down the Ctrl key and double-clicking
in the title bar of the toolbar.

Floating toolbars
Writer includes several toolbars, whose default settings are floating in response to the current
position of the cursor or selection. For example, when the cursor is in a table, a Table toolbar
appears, and when the cursor is in a numbered or bullet list, the Bullets and Numbering toolbar
appears. You can reposition or dock these toolbars as described in “Moving toolbars” above.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar. You can also add icons and create new toolbars, as described in
Chapter 21, Customizing Writer.
To position the toolbar:
•

Click Dock Toolbar to dock the selected floating toolbar. By default, a toolbar will dock at
the top of the workspace. You can reposition the toolbar to a different docked position. See
“Moving toolbars” on page 9.

•

Click Dock All Toolbars to dock all floating toolbars.

•

Click Lock Toolbar Position to lock a docked toolbar into its docked position. Locking
maintains the toolbar’s position even when other toolbars on the same bar change location.

•

Click Close Toolbar to close the selected toolbar.

Access a toolbar’s customization options by right-clicking in an empty space between the icons on
the toolbar to open a context menu. Then choose among the following options:
•

To show or hide icons defined for the selected toolbar, click Visible Buttons on the context
menu. Visible icons on a toolbar are indicated by an outline around the icon (Figure 6) or by
a check mark beside the icon, depending on your operating system. Select or deselect
icons to hide or show them on the toolbar.

•

Click Customize Toolbar to open the Customize dialog. See Chapter 21, Customizing
Writer, for more information.
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Figure 6: Toolbar context menu and selection of visible toolbar icons

Rulers
The horizontal ruler across the top of the workspace is visible by default but the vertical ruler on the
left is hidden by default. To enable the vertical ruler, choose View > Rulers > Vertical Ruler from
the Menu bar, or choose Tools > Options > LibreOffice Writer > View. To quickly show or hide
both rulers, use the key combination Ctrl+Shift+R.

Tip
The horizontal ruler has a comments button on its right end; click this to quickly show
or hide any comments.

Status bar
The Writer status bar is located at the bottom of the workspace. It provides information about the
document and convenient ways to quickly change some document features. It can be hidden by
deselecting it in the View menu.

Figure 7: Left end of Status bar

Figure 8: Right end of Status bar
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Page number
Shows the sequence number of the current page, the total number of pages in the document,
and the current page number (if different from the sequence number). For example, if page
numbering is restarted at 1 on the third page of a 6-page document, the sequence number is
3, the total number of pages is 6, and page number is 1, as shown in Figure 7.
If any bookmarks have been defined in the document, a right-click this field pops up a list of
bookmarks. Click a bookmark to be taken to that location in the document.
To jump to a specific page in the document, click this field. The Navigator opens (see “Using
the Navigator” on page 21). Click in the Page Number field in the Navigator, type the
sequence number of the required page, and press Enter.
Word and character count
The word and character counts of the document are shown in the status bar, and are
updated as you edit. If specific text is selected, the count for that selection will temporarily
replace the document total count.

By default, the character count includes spaces. To display the character count excluding
spaces, double-click the word count in the status bar, or choose Tools > Word Count.
You can also see the number of words and characters (and other information including the
number of pages, tables, and graphics) in the entire document in File > Properties >
Statistics.
Page style
Shows the page style of the current page. To change the page style, right-click this field. A list
of page styles pops up. Click one to select a different style. To edit the attributes of the
current page style, double-click this field. The Page Style dialog opens.

Caution
Changing the page style here may affect the styles of following pages, depending on
how the page styles are set up. See Chapters 8 and 9 for details about styles.
Text Language
Shows the language and localization used for spelling, hyphenation, and the thesaurus. It is
based on the position of the cursor or the selected text.
Click to open a menu where you can choose another language/localization for the selected
text or for the paragraph where the cursor is located. You can also choose None (Do not
check spelling) to exclude the text from a spelling check or Reset to default language.
Choosing More... opens the Character dialog. See Chapter 3, Working with Text: Basics, for
more information.
Insert mode
This area is blank when in Insert mode. Click to change to Overwrite mode; click again to
return to Insert mode. In Insert mode, any text after the cursor position moves forward to
make room for the text you type; in Overwrite mode, text after the cursor position is replaced
by the text you type. This feature is disabled when using Record Changes mode.
Selection mode
Click to choose different selection modes. The icon does not change, but when you hover the
mouse pointer over this field, a tooltip indicates which mode is active.
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When you click in the field, a context menu displays the available options. See Chapter 3,
Working with text: Basic, for details.
Document changes status
This icon
shows when the document has no unsaved changes. This icon
one shows when it has been edited and the changes have not been saved.

or a similar

Digital signature
If the document has been digitally signed, an icon is displayed here; otherwise, it is blank.
Click here to sign the document or to view the existing certificate. See Chapter 8, Printing,
Exporting, E-Mailing, for more information.
Section or object information
When the cursor is in a section, heading, or list item, or when an object (such as a picture or
table) is selected, information about that item appears in this field. Double-clicking in this
area opens a relevant dialog.
Object

Information shown

Dialog opened

Image

Size and position

Image

List item

Level and list style

Bullets and Numbering1

Heading

Outline numbering level

Bullets and Numbering1

Table

Name or number and cell reference of cursor

Table Format

Section

Name of section

Edit Sections

Other

(Blank)

Fields

View layout
Click the corresponding icon to change between single page, side-by-side, and book layout
views (see Figure 9). You can edit the document in any view. Zoom settings interact with the
selected view layout and the window width to determine how many pages are visible in the
document window.

Figure 9: View layouts: single, side-by-side, book
Zoom
To change the view magnification, drag the Zoom slider, or click the + and − signs, or rightclick the zoom level percent to pop up a list of magnification values from which to choose.
Zoom interacts with the selected view layout to determine how many pages are visible in the
document window.
1

If a list style was used with a list item or heading, no dialog appears.
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Context (right-click) menus
Context menus provide quick access to many menu functions. They are opened by right-clicking
on a paragraph, graphic, or other object. When a context menu opens, the functions or options
available will depend on the object that has been selected. This can be the easiest way to reach a
function, especially if you are not sure where the function is located in the menus or toolbars.

Dialogs
A dialog is a special type of window. Its purpose is to inform you of something, or request input
from you, or both. It provides controls for you to specify how to carry out an action.
In most cases, you can interact only with the dialog (not the document itself) as long as the dialog
remains open. When you close the dialog (usually, clicking OK or a similar button saves your
changes and closes the dialog; clicking Cancel closes the dialog without saving any changes),
then you can again work with the document.
Some dialogs can be left open as you work, so you can switch back and forth between the dialog
and your document. An example of this type is the Find & Replace dialog.

Document views
Writer has three ways to view and edit a document: Normal, Web, and Full Screen. To change the
view, go to the View menu and click the required view.
You can also choose View > Zoom > Zoom from the Menu bar to display the Zoom & View Layout
dialog, where you can set the same options as on the Status bar.
You can also use File > Print Preview to view the document, but this view does not allow editing.
See “Previewing pages before printing” in Chapter 7, Printing, Exporting, E-mailing.

Normal view
Normal view is the default view in Writer. It shows how the document will look when you print it or
create a PDF. In this view, you can use the Zoom slider and the View Layout icons on the Status
bar to change the magnification.
In Normal view, you can hide or show the headers and footers and the gap between pages. To hide
them, choose View > Hide Whitespace from the Menu bar. A check mark will appear next to the
option. When this option is activated, white space, headers, and footers are also hidden in Full
Screen view.

Web view
Web view shows how the document will look if viewed in a Web browser; this is useful when you
create HTML documents. In Web view, you can use only the Zoom slider. The View Layout icons
on the Status bar are disabled, and most of the choices on the Zoom & View Layout dialog are not
available.

Full Screen view
In this view, no toolbars or sidebar are displayed; the document takes up the full area available,
using the zoom and layout settings previously selected. To exit Full Screen view and return to
either Normal or Web view, press the Esc key or click the Full Screen icon on the floating toolbar
in the top left-hand corner. You can also use Ctrl+Shift+J to enter or exit Full Screen view.
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Starting a new document
You can start a new, blank document in Writer in several ways. If a document is already open in
LibreOffice, the new document opens in a new window.

From the Start Center
When LibreOffice is open but no document is open, the Start Center is shown. Click the Create:
Writer Document button to create a new text document, or click the Templates button to start a
new document using a template other than the default template.

Figure 10: LibreOffice Start Center

From the Quickstarter
When LibreOffice is installed on computers running Windows or Linux, a Quickstarter feature may
also be installed. Computers running macOS do not have a Quickstarter.
To use Quickstarter, right-click its icon in the system tray to open a pop-up menu (Figure 11). From
here, you can open an existing document, create a new document, or open the Templates dialog.
The default installation of LibreOffice does not set the Quickstarter to load automatically. To
activate it, go to Tools > Options > LibreOffice > Memory on the Menu bar and select Load
LibreOffice during system start-up (if using Windows) or Enable systray Quickstarter (if using
Linux). Close and restart LibreOffice to have Quickstarter appear.
You can prevent Quickstarter from appearing by reversing this procedure, or by deselecting Load
LibreOffice during system start-up on the pop-up menu. To temporarily close Quickstarter, rightclick its icon in the system tray and select Exit Quickstarter.
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Figure 11: Quickstarter pop-up menu

From the operating system menu
You can open the LibreOffice Start Center or the Writer component from the operating system
menu in the same way that you start other programs. When LibreOffice was installed on your
computer, in most cases a menu entry for each component was added to the system menu. On
macOS, the LibreOffice icon will be in the Applications folder. When you double-click this icon,
LibreOffice opens at the Start Center (Figure 10).

From the Menu bar, toolbar, or keyboard
When LibreOffice is open, you can also start a new Writer document in one of these ways.
•

Press the Ctrl+N keys.

•

Choose File > New > Text Document on the Menu bar.

•

Click the New icon on the Standard toolbar.

From a template
A template is a set of predefined styles and settings that is used to create a new document.
Templates enable the easy creation of multiple documents with the same default settings. For
example, all the chapters of the Writer Guide are based on the same template. As a result, all the
chapters look alike; they have the same headers and footers, use the same fonts, and so on.
A new LibreOffice installation may contain only a few templates, but you can create your own or
download more from http://templates.libreoffice.org/ and other websites. See Chapter 10, Working
with Templates.
To open the Template dialog, where you can choose the template you want to use for creating your
document, do one of the following:
•

Press the Ctrl+Shift+N keys.

•

Choose File > Templates > Manage on the Menu bar.

•

Choose File > New > Templates on the Menu bar.

•

Click the arrow next to the New icon on the Standard toolbar and select Templates from
the drop-down list.
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The example shown in Figure 12 highlights a template in the Documents > My Templates folder.
Double-click the desired template to create a new document based on the that template. For more
about the Templates dialog, see Chapter 10, Working with Templates.

Figure 12: Creating a document from a template

Opening an existing document
You can open an existing document in several ways.
When no document is open:
•

Click Open File or Remote files in the Start Center.

•

Choose File > Open or File > Open Remote File on the Menu bar.

•

Press Ctrl+O on the keyboard.

•

Click the Open icon on the Standard toolbar.

•

Double-click a thumbnail of recently opened documents displayed in the Start Center. You
can scroll up or down in the Start Center to locate a recently opened document.

If a document is already open:
•

Click the Open icon on the Standard toolbar and select the additional document to be
opened from the Open dialog.

•

Click the small triangle to the right of the Open icon and select from a list of recently
opened documents.

•

Use File > Recent Documents to make a selection.

•

Choose Open Document on the Quickstarter.

When using the Open dialog, navigate to the folder you want, select the file you want, then click
Open. If a document is already open in LibreOffice, the second document opens in a new window.
You can reduce the list of files in the Open dialog by selecting the type of file you are looking for.
For example, if you choose Text documents as the file type, you will only see documents Writer
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can open (including .odt, .doc, .txt). This method opens Word (.doc and .docx) files as well as
LibreOffice files and other formats.
You can also open an existing Writer document using the same methods you would use to open
any document in your operating system.
If you have associated Microsoft Office file formats with LibreOffice, you can also open these files
by double-clicking on them. See the Help for more about file associations.

Saving a document
You can save a documents using either the Save commands or the Save as command.

Save commands
Save a new file or a previously-saved file
Do one of the following:
•

Press Ctrl+S.

•

Choose File > Save on the Menu bar.

•

Click the Save icon on the Standard toolbar.

If the file has not been saved previously, a Save As dialog appears after selecting one of the above
options. Enter the file name, verify the file type and location, and click Save.
If a previously-saved file is being saved with the same file name, file type, and location, nothing
else needs to be done.

Save to a remote server
Use if your document is already stored on a remote server or you want to store it on a remote
server. Choose File > Save to Remote Server. When the Save As dialog appears, enter or verify
the name, type, and location, then click Save.
See “Opening and saving files on remote servers” on page 21 for more information.

Save a copy
Use if you want to keep the document open for more editing and also save a separate copy of the
current version.
Choose File > Save a Copy. When the Save As dialog appears, enter or verify the name, type,
and location, then click Save. The copy is not opened and the original file remains open and active.

Save all
Use to save all files open in the current session.
Choose File > Save All. All open files will be saved without changes to name, type, or location.

Save As command
Use if you want to save the current version as a new document by changing the file name or file
type, or by saving the file in a different location on your computer.
Choose File > Save As, or use Ctrl+Shift+S to open a Save As dialog where you can change the
file name, type, or location, and click Save.
If you want to preserve the original file, first save a copy as described above.
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Note
LibreOffice uses the term “export” for some file operations involving a change of file
type, such as PDF and ePub. See Chapter 7, Printing, Exporting, E-mailing, for more
information.

Saving a document automatically
You can choose to have Writer save your document automatically in a temporary file at regular
intervals. To set up automatic file saving:
1)

Select Tools > Options > Load/Save > General. (See also Chapter 2, Setting up Writer.)

2)

Click Save AutoRecovery information every and set the time interval. The default value
is 15 minutes. Enter the value you want by typing it or by pressing the up or down arrow
keys.

3)

You may also wish to select Always create backup copy.

4)

Click OK to save the changes.

Saving as a Microsoft Word document
To exchange files with users of Microsoft Word, you can save a document in a format such
as .DOCX.
1)

Important: First save your document in the file format used by LibreOffice Writer, .odt. If you
do not, any changes you made since the last time you saved will only appear in the
Microsoft Word version of the document.

2)

Then click File > Save As.

3)

On the Save As dialog, in the File type (or Save as type) drop-down menu, select the type
of Word format you need. You may also choose to change the file name.

4)

Click Save.

From this point on, all changes you make to the document will occur only in the new (Microsoft
Word) document. If you want to go back to working with the .odt version of your document, you
must open it again.

Tip
To have Writer save documents by default in the Microsoft Word file format, go to
Tools > Options > Load/Save > General. In the section named Default File Format
and ODF Settings, under Document type, select Text document, then under Always
save as, select your preferred file format.

Password protection
Writer provides two levels of document protection: read-protect (file cannot be viewed without a
password) and write-protect (file can be viewed in read-only mode but cannot be changed without
a password). Thus you can make the content available for reading by one group of people and for
reading and editing by a different group. This behavior is compatible with Microsoft Word file
protection.
To protect a document with passwords:
1)

Use File > Save As when saving the document. (You can also use File > Save the first
time you save a new document.)

2)

On the Save As dialog, select the Save with password option in the lower left corner, and
then click Save.
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3)

The Set Password dialog opens (Figure 13).

Figure 13: Two levels of password protection
Here you have several choices:

4)

–

To read-protect the document, type a password in the two fields at the top of the dialog.

–

To write-protect the document, click the Options button and select Open file read-only
in the File Sharing Password section.

–

To write-protect the document but allow selected people to edit it, select Open file readonly and type a password in the two boxes at the bottom of the dialog.

Click OK to save the file. If either pair of passwords does not match, you receive an error
message. Close the message box to return to the Set Password dialog and enter the
password again.

Caution
LibreOffice uses a very strong encryption mechanism that makes it almost impossible
to recover the contents of a document if you lose the password.

Changing or removing the password for a document
When a document is password-protected, you can change or remove the password while the
document is open. Choose File > Properties > General and click the Change Password button.
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Opening and saving files on remote servers
LibreOffice can open and save files stored on remote servers (that is, not on your computer or local
area network). This feature enables you to work on a document in the office and still have access
to it from home or elsewhere. Storing files on a remote server also backs up documents, saving
data from computer loss or hard disk failure. Some servers are also able to check files in and out,
thus controlling their usage and access.
LibreOffice supports many document servers that use well-known network protocols such as FTP,
WebDav, Windows share, and SSH. It also supports popular services like Google Drive and
Microsoft OneNote, as well as commercial and open source servers that implement the OASIS
CMIS standard. For more information, see the Getting Started Guide.

Using the Navigator
Writer provides ways to move quickly through a document and find specific items by using the
many features of the Navigator, the Navigation toolbar, and related icons.
In the default installation of LibreOffice, the Navigator is part of the Sidebar. It lists all of the
headings, tables, text frames, graphics, bookmarks, and other objects contained in a document.

Figure 14: The Navigator in the Sidebar
To open the Navigator (Figure 14), do one of the following:
•

Click the Navigator tab in the Tab bar on the right of the Sidebar.

•

Double-click the Page number field on the status bar.

•

Click the Navigator icon (if visible) on the Standard toolbar.

•

Press F5.

•

Choose View > Navigator on the Menu bar.
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Click the + sign or triangle to the left of a category or subcategory to display the contents.
Table 1 summarizes the functions of the icons at the top of the Navigator.

Note
In a master document, the Navigator has different functions. See Chapter 16, Master
Documents.
Table 1: Function of icons in the Navigator
1

Navigation

Opens the Navigation toolbar (see page 23).

2

Previous, Next

Jumps to the previous or next item in the selected category (page,
graphic, hyperlink, comment, and so on). To select the category of
items, see “Using the Navigation toolbar” on page 23.

3

Page number

Jumps to the page sequence number shown in the box. Type the
required page number or select it using the up and down arrows.

4

Drag Mode

Select Insert as Hyperlink, Link, or Copy. See “Choosing drag modes”
on page 25.

5

Promote/Demote Chapter

Move headings and text in the document. See “Rearranging
headings and text using the Navigator” on page 24.

6

Content Navigation View

Switches between showing all categories and showing only the
selected category.

7

Set Reminder

Inserts a reminder. See “Setting reminders” on page 24.

8

Header/Footer

Jumps between the text area and the header or footer area (if the
page has them).

9

Anchor <–> Text

Jumps between a footnote anchor and the corresponding footnote
text.

10

Heading Levels Shown

Choose the number of heading levels to be shown.

11

Promote/Demote Level

Quickly change heading levels in the document. See “Rearranging
headings and text using the Navigator” on page 24.

Moving quickly through a document
The Navigator provides several convenient ways to move around a document and find items in it:
•

To jump to a specific page in the document, type its sequence number in the box at the top
of the Navigator and press Enter. The sequence number may be different from the page
number if you have restarted numbering at any point.

•

When a category is opened to show the list of items in it, double-click an item to jump
directly to that item’s location in the document. For example, you can jump directly to a
selected heading, graphic, or comment by using this method.

•

To see the content in only one category, highlight that category and click the Content View
icon. Click the icon again to display all the categories. You can also change the number of
heading levels shown when viewing Headings.

•

Use the Previous and Next icons to jump to other objects of the type selected in the
Navigation toolbar. (See next page for details.)
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Note
A hidden section (or other hidden object) in a document appears gray in the Navigator,
and displays the word “hidden” as a tooltip. For more about hidden sections, see
Chapter 6, Formatting Pages: Advanced.

Tip
Objects are much easier to find if you give them identifying names when creating
them. By default, LibreOffice gives objects names such as Image1, Image2, Table1,
Table2, and so on. These names are assigned in the order in which the objects were
added to the document, which may not correspond to the location of the object in the
document.
You can rename objects after inserting them. For example, to rename an image, rightclick its name in the Navigator, choose Image from the context menu, then choose
Rename. The view jumps to the image (to show which one it is) and a small dialog
pops up. Type a new name for the image and click OK to save.
You can also right-click the image and select Properties. In the Image dialog, go to
the Options page, edit the name, and click OK.

Using the Navigation toolbar
To display the Navigation toolbar (Figure 15), click the Navigation icon (top left icon on the
Navigator, Figure 14) or the Navigate by icon on the Find toolbar.
The Navigation toolbar has icons for all the object types shown in the Navigator, plus some extras
(for example, the results of a Find command). See Table 2.

Figure 15: Navigation toolbar
Table 2: Icons in Navigation toolbar
1
2
3
4
5

Table
Text Frame
Graphics
OLE Object
Page

6
7
8
9
10

Headings
Reminder
Drawing
[Form] Control
Previous [Object]

11
12
13
14
15

Section
Bookmark
Selection
Footnote
Comment

16
17
18
19
20

Repeat search
Index entry
Table formula
Wrong table formula
Next [Object]

Click an icon to select that category of object (such as an image). Now the Previous and Next
icons (in the Navigator itself, in the Navigation toolbar, and on the Find toolbar) will jump to the
previous or next occurrence of the selected type of object. This is particularly helpful for finding
items like index entries, which can be difficult to see in the text. The names of the Previous and
Next icons (shown in the tooltips) change to match the selected category; for example, Next
Graphic, Next Bookmark, or Continue search forward.
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Rearranging headings and text using the Navigator
You can move headings and their associated text to another location in the document by doing the
following:
1)

If necessary, click the expansion symbol (+ sign or arrow) to the left of a heading to expand
the list of subheadings.

2)

(Optional) If you have several subheading levels, you can more easily find the headings
you want by changing the Heading Levels Shown selection to show only 1 or 2 levels of
headings.

3)

Click the heading of the block of text that you want to move and drag the heading to a new
location on the Navigator. Or, click the heading in the Navigator list, and then click either the
Promote Chapter or Demote Chapter icon. All of the text and subsections under the
selected heading with it move up or down in the document.

To move only the selected heading and not the text associated with the heading, hold down Ctrl,
and then click the Promote Chapter or Demote Chapter icon.

Tip
The names Promote Chapter and Demote Chapter can be misleading. They might
be better described as Move Up or Move Down (within the document, without
changing the heading level) to distinguish them more clearly from Promote Level and
Demote Level, which change the heading level—from Level 1 to Level 2, for example.
To quickly change the outline level of a heading:
•

To change the outline level of a heading and its associated subheadings, select the heading
in the Navigator, then click either the Promote Level or Demote Level icon. This action
does not change the location of the headings, only their levels.

•

To change the outline level of only the selected heading, but not its associated
subheadings, hold down Ctrl, and then click the Promote Level or Demote Level button.

Note
Users of Microsoft Word will notice the similarity between this functionality and Word's
Outline View.

Setting reminders
Reminders let you mark places in your document that you want to return to later on, for example to
add or correct information or simply mark where you finished editing. The possible uses of
reminders are limited only by your imagination.
To set a reminder at the cursor’s current location, click the Set Reminder icon in the Navigator.
You can set up to 5 reminders in a document; setting a sixth causes the first to be deleted.
Reminders are not highlighted in any way in the document, nor are they listed in the Navigator, so
you cannot see where they are, except that when you jump from one to the next, the location of the
cursor shows the location of the reminder.
To jump between reminders, first select the Reminder icon on the Navigation toolbar. Then click
the Previous and Next icons. Reminders are not saved with the document.
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Choosing drag modes
You can insert items such as other documents and images using the Navigator’s drag and drop
modes. Choose one of the following from the drop-down menu of the Drag Mode icon. Then select
the item and move it to where it should be inserted.
Insert As Hyperlink
Hyperlinks the entire item.
Insert As Link
Links the copied item to the original item so that when the original item is changed, that
change will be reflected in the current document. By contrast, the copied item is protected
and cannot be changed directly in the document. Note that you cannot create links for
graphics, OLE objects, references, or indexes using this method.
Insert As Copy
Inserts a copy of the selected item.

Undoing and redoing changes
To undo the most recent change in a document, press Ctrl+Z, choose Edit > Undo on the Menu
bar, or click the Undo icon on the Standard toolbar. To get a list of all the changes that can be
undone, click the small triangle to the right of the Undo icon on the Standard toolbar. You can
select several sequential changes on the list and undo them at the same time.

Figure 16: List of actions that can be undone
After changes have been undone, Redo becomes active. To redo a change, select Edit > Redo, or
press Ctrl+Y or click the Redo icon
on the Standard toolbar. As with Undo, click the down
arrow icon of the combination icon to get a list of the changes that can be restored.

Reloading a document
You may want to discard all the changes made in an editing session since the last time you saved
it. Undoing each change or remembering where the changes took place can be difficult. If you are
sure you do not want to keep the changes from the last time the document was saved, you can
reload the document.
To reload a document, go to File > Reload on the Menu bar. A confirmation dialog asks if you want
to cancel all changes; choose Yes to return the document to the version that was last saved.
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Closing a document
If only one document is open and you want to close that document, go to File > Close on the
Menu bar or click the X on the Title bar. The X may be located on either the right or left end of the
Title bar.
If more than one document is open and you want to close one of them, go to File > Close on the
Menu bar or click the X on the Menu bar of that document’s window. When only the last document
is open, the X on the Menu bar disappears.
If the document has not been saved since the last change, a message box is displayed. Choose
whether to save or discard changes.

Closing LibreOffice
To close LibreOffice completely, go to File > Exit on the menu bar in Windows and Linux operating
systems. In a macOS operating system, go to LibreOffice > Quit LibreOffice on the Menu bar.
In Windows and Linux, when you close the last document using the X on the Title bar of the
window, then LibreOffice will close completely. MacOS does not have this function.
You can also use a keyboard shortcut:
•

In Windows and Linux – Ctrl+Q

•

In macOS – Command ⌘ (+Q

If any documents have not been saved since the last change, a message box is displayed. Choose
whether to save or discard your changes.
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