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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options
menu selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click and/or right-click
depending on computer setup

Opens a context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Opens the Navigator

F11

z+T

Opens the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Introduction
This chapter looks at the tools and functions that let you modify existing drawings. All of the
functions apply to a selected object or a group of selected objects, which can be distinguished by
selection handles on a rectangular frame that is large enough to contain the object. Where several
objects are selected, the frame around the objects corresponds to the smallest rectangle that can
contain all of the objects. This frame is called the selection rectangle.

Note

The color and shape of the selection handles will change depending on the tool and
function that has been selected to change the object properties. The color of the
selection handles also depends on the computer operating system and how the
computer has been set up.

Selecting objects
Direct selection
The easiest way to select an object is to click directly on it. For objects that are not filled, click on
the object outline to select it. One click selects; a second click deselects. To select or deselect
more than one object, hold the shift button down while clicking.

Selection by framing
You can also select several objects at once by dragging the mouse cursor around the objects. This
draws a rectangle around the objects, and only objects that lie entirely within the rectangle will be
selected.
To select multiple objects by framing, the Select icon

Note

on the Drawing toolbar must be active.

When you drag the mouse cursor to select multiple objects, the selection rectangle
being drawn is also known as a marquee.

Selecting hidden objects
Even if objects are located behind others and not visible, they can still be selected. Hold down the
Alt key and click on the object behind which the hidden object is located, then click again to select
the hidden object. If there are several hidden objects, keep holding down the Alt key and clicking
until you reach the object you want. To cycle through the objects in reverse order, hold down the
Alt+Shift keys and click.
When you click on the selected object, its outline will appear briefly through the objects covering it.

Note

Using the Alt key method works on computers using a Windows or Mac operating
systems. On a computer using a Linux operating system the Tab key method,
described below, has to be used.

To select an object that is covered by another object using the keyboard, use the Tab key to cycle
through the objects, stopping at the object you want to select. To cycle through the objects in
reverse order, press Shift+Tab. This is a very quick way to reach an object, but it may not be
practical if there a large number of objects in a drawing.
Selecting objects
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Arranging objects
In a complex drawing, several objects may be stacked on top of one another. To rearrange the
stacking order by moving an object forward or backward, select an object, click Modify > Arrange
on the main menu bar and select Bring Forward or Send Backward. Alternatively, right-click the
object, select Arrange from the context menu, then Bring Forward or Send Backward.
The Arrange options are also available by clicking on the small triangle or arrow to the right of the
Arrange icon
on the Drawing toolbar. This opens the Position toolbar, giving access to the
various arrangement options.

Positioning and adjusting objects
Using zoom
To help in the positioning and adjustment of objects, Draw has a zoom function that reduces or
enlarges the screen display of the current drawing. For example, zoom in to place objects onto
your drawing with greater position; zoom out to see the complete drawing. You can control
zooming three ways: using the status bar, the Zoom dialog, or the Zoom toolbar.

Note

Zooming is handled differently on Unix, Linux, and Windows operating systems. A
document saved with a 100% zoom factor in Windows is displayed at a larger zoom
factor in Unix/Linux.

Status bar
The zoom controls are located on the right side of the status bar (Figure 1); these controls give
you quick and easy access to zooming.

Figure 1: Status bar zooming

•
•
•
•

Click on the minus sign to reduce the zoom factor.
Click on the plus sign to increase the zoom factor.
Click and hold on the slide control and move it to increase or decrease the zoom factor.
Right-click on the zoom percentage number and select a zoom factor from the context
menu that opens.

Figure 2: Zoom & View Layout dialog
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• Double-click on the zoom percentage number and select a zoom factor from the Zoom &
View Layout dialog (Figure 2) that opens.

Zoom layout dialog
Go to View > Zoom on the main menu bar to open the Zoom & View Layout dialog (Figure 2),
where you can increase or reduce the zoom factor. The current zoom percentage is displayed on
the status bar (Figure 1).
Zoom factor
Sets the zoom factor at which to display the current document and all documents of the same
type that you open thereafter.

• Optimal – resizes the display to fit the width of the text in the document.
• Fit width and height – displays the entire page on your screen.
• Fit width – displays the complete width of the document page. The top and bottom edges of
the page may not be visible.

• 100% – displays the document at its actual size.
• Variable – enter the zoom factor at which you want to display the document. Enter a
percentage in the box.

Zoom toolbar
Go to View > Toolbars > Zoom to open the Zoom toolbar (Figure 3). The tools available on this
toolbar are shown in Figure 4.

• Zoom In – displays the slide at two times its current size. Click once on the tool, then move
the cursor onto the object and click again. You can also select the Zoom In tool and drag a
rectangular frame around the area you want to enlarge.

• Zoom Out – displays the drawing at half its current size each time the tool is clicked.
• Zoom 100% – displays the drawing at its actual size.
• Zoom Previous – returns the display of the drawing to the previous zoom factor you
applied. You can also use the keyboard shortcut Ctrl +, (Comma).

• Zoom Next – undoes the action of the Previous Zoom command. You can also the
keyboard shortcut Ctrl +. (Period).

• Zoom Page – displays the whole drawing on your screen.
• Zoom Page Width – displays the complete width of the drawing. The top and bottom
edges of the slide may not be visible.

• Optimal – resizes the display to include all of the objects on the slide.
• Object Zoom – resizes the display to fit the object(s) you selected.
• Shift – moves the drawing within the Draw workspace. Place the cursor on the drawing
and drag to move the drawing. When you release the cursor, the last tool you used is
automatically selected.

Figure 3: Zoom toolbar

Positioning and adjusting objects
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Figure 4: Zoom tools

Moving and adjusting object size
When moving an object or changing its size, check the left-hand area of the status bar at the
bottom of the Draw window (Figure 5). The area on the left of the Drawing toolbar, from left to right,
shows what object is selected, its position on the drawing in X/Y coordinates and dimensions of the
object. The units of measurement are those selected in Tools > Options > LibreOffice Draw >
General.

Figure 5: Left end of status bar when moving or adjusting an object

Moving objects
To move an object (or a group of objects), select it and then click within the object borders and hold
down the left mouse button while dragging the mouse. During movement, the shape of the object
appears as dotted lines to help with repositioning (Figure 6). To locate the object at its new
location, release the mouse button.

Figure 6: Moving an object
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Adjusting object size
To change the size of a selected object (or a group of selected objects), move the mouse cursor to
one of the selection handles. The mouse cursor will change shape to indicate the direction of
movement for that selection handle. As you change the size of the object, a ghosted outline of the
object appears (Figure 7). When you have reached the desired size of the object, release the
mouse button.
The results depend on which selection handle you use. To resize an object along one axis, use a
side handle. To resize along both axes, use a corner handle.

Figure 7: Adjusting object size
If you press the Shift key while resizing an object, the change in size will be carried
out symmetrically with respect to the two axes so that the aspect ratio of the object
remains the same. This Shift key behavior works on all selection handles.

Note

This is the default behavior of the Shift key. However, if When creating or moving
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the
action of the Shift key is reversed: that is the aspect ratio will be preserved unless
the Shift key is pressed.

Modifying an arc
The size of an arc can be changed by adjusting position of the start and end points of an arc.
Select an arc and click on the Points icon
on the Drawing toolbar. Two larger handles appear
at the start and end of the arc (Figure 8). When the mouse cursor hovers over one of these larger
handles, the cursor changes shape, allowing you to adjust the position of either the start or end
points of the arc.

Figure 8: Modifying an arc

Rotating and slanting an object
Rotating an object
To rotate an object (or a group of objects), select the object, then go to rotation mode using one of
the following methods:

• Click on the object again. Do not double-click as this will cancel object selection.

Positioning and adjusting objects
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Figure 9: Rotating an object

• Click on the Rotate icon

on the Drawing toolbar.

• Go to View > Toolbars > Mode and select the Rotate icon

.

The selection handles will change shape and color (Figure 9). Also a center of rotation point will
appear in the center of the object. As you move the mouse cursor over the handles, the cursor
changes shape. The corner handles are for rotating the object, and the top, bottom and side
handles are to shear or slant the object.
Move the mouse cursor to one of the corner handles and it normally changes to an arc with an
arrow at each end. Click and hold the mouse button, then start to move the cursor to rotate the
object. A dotted outline of the object being rotated appears and the current angle of rotation is
shown in the status bar.

Note

Rotation works in a slightly different way for 3D objects because it occurs in a three
dimensional space and not in a single plane. See Chapter 7 Working with 3D Objects
for more information.

The rotation point is normally located at the center of an object. To change the position of the
rotation point, click on the object with the mouse cursor and drag the object until the rotation point
is at the desired position. This rotation point can even be outside of the object.
If you press the Shift key while rotating an object, rotation will be restricted to 15° of
movement.

Note

This is the default behavior of the Shift key. However, if When creating or moving
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the
action of the Shift key is reversed: that is rotation will be restricted to 15° of
movement unless the Shift key is pressed.

Slanting an object
To slant an object, use the handles located at the midpoints on the top, bottom and sides of a
selected object. The mouse cursor changes when it hovers over one of these midpoint handles.
The axis used for slanting an object is the object edge directly opposite the midpoint handle being
used to slant the object. This axis stays fixed in location while the other sides of the object move in
relation to it as you drag the mouse cursor.
Click and hold the mouse button, then start to move the cursor to shear the object. A dotted outline
of the object being slanted appears (Figure 10) and the current angle of slanting is shown in the
status bar.
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Figure 10: Shearing an object
If you press the Shift key while slanting an object, slanting will be restricted to 15° of
movement.

Note

This is the default behavior of the Shift key. However, if When creating or moving
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the
action of the Shift key is reversed: that is slanting will be restricted to 15° of
movement unless the Shift key is pressed.

Setting exact size and position
You can position and resize objects with the mouse, but this method is not exact. If you want to
accurately position and size an object, go to Format > Position and Size on the main menu bar,
or right-click on an object and select Position and Size from the context menu, or press the F4
key. This will open the Position and Size dialog (Figure 11).

Figure 11: Position and Size dialog

Position and Size
Open the Position and Size dialog and click on the Position and Size tab (Figure 11) to set the
appropriate values.

Positioning and adjusting objects
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Position is defined using X/Y coordinates relative to a base point. Change the X/Y coordinates
using the text boxes in the Position section.
Width and height of an object are also defined relative to a base point. Change the width and
height of an object using the text boxes in the Size section. To keep the ratio of width to height,
select the Keep ratio option.
The units of measurement used for X//Y coordinates and the width and height of the object are set
by going to Tools > Options > LibreOffice Draw > General.
The default location of the base points for position and size is the upper left corner of the drawing
area. You can temporarily change this base point to make positioning or dimensioning simpler by
clicking on a radio button corresponding to the location of the base point you want to use. This
change in base point is only valid for single use and the base point is reset to the standard position
of top left corner when you close the Position and Size dialog.
To prevent either or both size and position from being inadvertently changed, select the appropriate
options in the Protect section.

Rotating objects
To accurately rotate an object, click on the Rotation tab of the Position and Size dialog (Figure
12). Use this dialog to define the rotation angle and the location of the pivot point.

Figure 12: Rotating an object
The pivot point is positioned using X/Y coordinates that are relative to the original position of the
pivot point. The default setting for the pivot point is the center of an object. To mocw rhis pivot
point, click on one of the radio buttons in Default settings.
The rotation angle can be accurately set using the text box in the Rotation angle section. To quickly
rotate an object in increments of 45 degrees, click on one of the radio buttons in the Default
settings. The default setting for rotation is zero degrees.
Changing the pivot point and/or rotation angle of an object is only valid for single use. The pivot
point and rotation angle are reset to their default settings when you close the Position and Size
dialog.
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Slant and corner radius
To accurately set the corner radius or slant angle of an object, click on the Slant & Corner Radius
tab of the Position and Size dialog (Figure 13).

Figure 13: Setting slant angle and corner radius
A corner radius can be applied to any object that has sharp corners, such as rectangles, squares,
or text boxes. If the Corner radius section is grayed out, then you cannot set a corner radius. The
larger the value for corner radius set in the Radius text box, the rounder the corners of an object
become.
Slant angle relates to how much an object inclines or slants from its normal vertical position on a
drawing. To accurately change the slant angle of an object, enter the number of degrees in the
Slant Angle text box.

Using grid and snap functions
In Draw, you can also position objects accurately and consistently using grid points, snap points
and lines, object frames, individual points on objects, or page edges. This function is known as
Snap.
It is easier to use snap functions at the highest practical zoom value for your drawing. You can use
two different snap functions at the same time; for example, snapping to a guide line and the page
edge. However, it is recommended to activate only those snap functions that you really need.

Figure 14: LibreOffice Draw Grid dialog

Using grid and snap functions
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Figure 15: Options toolbar

Configuring grid and snap functions
To configure the grid and snap functions in your drawing, go to Tools > Options > LibreOffice
Draw > Grid to display the Grid dialog (Figure 14). The grid and snap functions can also be
displayed and switched on or off using this dialog, right-clicking on your drawing and using the
options in the context menu, or using the icons in the Options toolbar (Figure 15). If the Options
toolbar is not open, go to View > Toolbars > Options.
Grid

• Snap to grid – specifies whether to move frames, drawing elements, and controls only
between grid points. To change the status of the snap grip only for the current action, drag
an object while holding down the Control key.

• Visible grid – specifies whether to display or turn off the grid. It is also possible to toggle
displaying the grid with Grid > Display Grid in the context menu when you right-click on
your drawing page. You can also select Grid > Grid to Front in this context menu to
display the grid in front of objects.
Resolution

• Horizontal – defines the unit of measure for the spacing between grid points on the X-axis.
• Vertical – defines the grid points spacing in the desired unit of measurement on the Y-axis.
Subdivision

• Horizontal – specify the number of intermediate spaces between grid points on the X-axis.
• Vertical – specify the number of intermediate spaces between grid points on the Y-axis.
• Synchronize axes – specifies whether to change the current grid settings symmetrically.
The resolution and subdivision for the X and Y axes remain the same.
Snap

• To snap lines – snaps the edge of a dragged object to the nearest snap line when you
release the mouse. You can also define this setting by using the Snap to Snap Lines icon
on the Options toolbar.

• To the page margins – specifies whether to align the contour of the graphic object to the
nearest page margin. The cursor or a contour line of the graphics object must be in the
snap range. In a drawing, this function can also be accessed with the Snap to Page
Margins icon

in the Options toolbar.

• To object frame – specifies whether to align the contour of the graphic object to the border
of the nearest graphic object. The cursor or a contour line of the graphics object must be in
the snap range. In drawing, this function can also be accessed with the Snap to Object
Border icon

in the Options toolbar.

• To object points – specifies whether to align the contour of the graphic object to the points
of the nearest graphic object. This only applies if the cursor or a contour line of the graphics
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object is in the snap range. In a drawing, this function can also be accessed with the Snap
to Object Points icon

in the Options toolbar.

• Snap range – defines the snap distance between the mouse pointer and the object contour.
Snaps to a snap point if the mouse pointer is closer than the distance selected.
Snap position

• When creating or moving objects – specifies that graphic objects are restricted vertically,
horizontally or diagonally (45°) when creating or moving them. You can temporarily
deactivate this setting by pressing the Shift key.

• Extend edges – specifies that a square is created based on the longer side of a rectangle
when the Shift key is pressed before you release the mouse button. This also applies to an
ellipse (a circle will be created based on the longest diameter of the ellipse). When Extend
edges is not selected, a square or a circle will be created based on the shorter side or
diameter.

• When rotating – specifies that graphic objects can only be rotated within the rotation angle
that you selected. If you want to rotate an object outside the defined angle, press the Shift
key when rotating. Release the key when the desired rotation angle is reached.

• Point reduction – defines the angle for point reduction. When working with polygons, you
might find it useful to reduce their editing points.

Snap to grid
Using Snap to Grid
Use the Snap to Grid function to move an object exactly onto a grid point in your drawing. This
function can be switched on and off using one of three methods:
1) Go to View > Grid > Snap to Grid.
2) Right-click on your drawing and selecting Snap to Grid from the context menu.
3) Click on the Snap to Grid icon

on the Options toolbar.

Displaying the grid
Displaying or turning off the grid in your drawing can be done using one of four methods:
1) Go to View > Grid > Display Grid.
2) Click on the Display Grid icon
on the Options toolbar.
3) Right-click on your drawing and select Display Grid from the context menu.
4) Selecting Visible grid option in the Grid dialog (Figure 14 on page 9).

Changing color of grid points
By default the grid points are gray and, depending on you display and computer setup, are not
always easy to see. Go to Tools > Options > LibreOffice > Appearance to open the Appearance
dialog (Figure 16). In the Drawing/Presentation section, change the color of the grid points
selecting a more suitable color from the drop down list for you to use.

Using grid and snap functions
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Figure 16: LibreOffice Appearance dialog

Snap points and lines
Unlike the grid, snap lines and snap points are inserted by you when you want to position an object
in a specific position on your drawing. Snap lines can either be horizontally or vertically and appear
as dashed lines. Snap points appear as small crosses with dashed lines. Snap points and snap
lines do not appear in printed output.
You can insert snap lines and snap points in two ways:

• Using the Insert Snap Point/Line command.
• Using the vertical and horizontal rulers (snap lines only).
Inserting snap points and snap lines
To insert a snap point or snap line, go to Insert > Insert Snap Point/Line or right-click on your
drawing and select Insert Snap Point/Line from the context menu to open the New Snap Object
dialog (Figure 17).

Figure 17: New Snap Object dialog
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• Position – sets the position of a selected snap point or line relative to the top left corner of
the page.

–

X axis – enter the amount of space you want between the snap point or line and the left
edge of the page.

–

Y axis – enter the amount of space you want between the snap point or line and the top
edge of the page.

• Type – specifies the type of snap object you want to insert.
– Point – inserts a snap point.
– Vertical – inserts a vertical snap line.
– Horizontal – inserts a horizontal snap line.
Inserting snap lines using rulers
Only snap lines can be inserted using the vertical or horizontal rulers. If the rulers are not
displayed, go to Tools > Options > LibreOffice Draw > View and select Rulers visible.
To insert a snap line, move your cursor to a ruler, then click and drag a snap line to the required
position.

Displaying snap points and lines
Displaying or turning off snap points and lines in your drawing can be done using one of three
methods:
1) Go to View > Grid > Display Snap Lines.
2) Click on the Display Snap Lines icon
on the Options toolbar.
3) Right-click on your drawing and select Display Snap Lines from the context menu.

Editing snap points and lines
To edit a snap point, right-click on the snap point and select Edit Snap Point to open the edit
dialog or drag it to a new position on your drawing.
To edit a snap line, right-click on the snap line and select Edit Snap Line to open the edit dialog or
drag it to a new position on your drawing.

Deleting snap points and lines
To delete a snap point, drag it back to a ruler or right-click on the snap point and select Delete
Snap Point.
To delete a snap line, drag it back to the ruler or right-click on the snap line and select Delete Snap
Line.

Configuring snap range
To configure the snap range of when an object snaps to position, go to Tools > Options >
LibreOffice Draw > Grid (Figure 14 on page 9) and enter the number of pixels to set the proximity
of when the object will snap into position in the Snap range box. The default setting is 5 pixels.

Using grid and snap functions
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Using guide lines
Guide lines are another function in Draw to help you position objects. Guide lines can be displayed
while the object is being moved. They extend from the edges of the object to the rulers at the top
and left side of your drawing and do not have a snap function (Figure 18).

Figure 18: Using guide lines
To use guide lines, go to Tools > Options > LibreOffice Draw > View and select the Snap Lines
when moving option or click the Helplines While Moving icon

on the Options toolbar.

Changing form of regular shapes
When drawing certain regular shapes, one or more dots are displayed in a different color to the
selection handles when an object is selected. When the mouse cursor hovers over one of these
dots, it changes shape. Clicking and dragging on one of these dots modifies the shape of the
object. For example, you can increase the corner radius of a rounded rectangle or square, change
the angles of an arc, and so on.
These dots perform a different function according to the shape selected and these functions are
listed in the following sections.

Basic shapes
• Rounded rectangles and squares: use the dot to change the radius of the curve that
replaces the angled corners of a rectangle or square.

• Circle pie: use the dots to change the size of the filled sector.
• Isosceles triangle: use the dot to modify the triangle type.
• Trapezoid, parallelogram, hexagon, or octagon: use the dot to change the angle between
the sides.

•
•
•
•
•
•
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Cross: use the dot to change the thickness of the four arms of the cross.
Ring: use the dot to change the internal diameter of the ring.
Block arc: use the dot to change both internal diameter and size of the filled area.
Cylinder and cube: use the dot to change the perspective.
Folded corner: use the dot to change the size of the folded corner.
Frame: use the dot to change the thickness of the frame.

Working with Objects and Object Points

Symbol shapes
•
•
•
•

Smiley face: use the dot to change the smile on the face.
Sun, moon, heart: use the dot to change the shape of the symbol.
Prohibited symbol: use the do to change the thickness of the ring and the diagonal bar.
Double bracket, left bracket, right bracket, double brace: use the dot to change the
curvature of the bracket.

• Left brace, right brace: use the dots to change the curvature of the brace and the position
of the point.

• Square bevel, octagon bevel, diamond bevel: use the dot to change the thickness of the
bevel.

Block arrows
•
•
•
•

Arrows: use the dot to change the shape and thickness of the arrows.
Pentagon, chevron: use the dot to change the angle between the sides.
Arrow callouts: use the dots to change the shape and thickness of the callouts.
Circular arrow: use the dots to change the thickness and area of the arrow.

Callouts
• Callouts: use the dots to change the length, position and angle of the pointer.

Stars
• 4-point star, 8-point star, 24-point star: use the dot to change the thickness and shape of
the star points.

• Vertical scroll, horizontal scroll: use the dot to change the width and shape of the scroll.
• Doorplate: use the dot to change the inward curvature of the corners.

Curves and polygons
Bézier curves
The editing of curves depends on the mathematics of Bézier curves1. Explaining Bézier curves
goes beyond this scope of this guide and only the basics are covered here. See Chapter 9
Advanced Draw Techniques for more information on drawing and manipulating Bézier curves.
The editing of a Bézier curve consists in principle of moving points or tangents passing through
these points. Each tangent has one control point at each end and a junction point where it meets
the curve. The relative angle and distance between the control points determine the shape of the
curve. Figure 19 shows what happens starting from a basic circle and changing only one point on
the circle.
You can create many different shapes by moving either the junction point itself, or one or both of
the round handle points at either end of the tangent. Draw offers more possibilities when you use
the functions on the Edit Points toolbar.
1 Bézier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer,
who developed the technique in the 1960s. The technology was intended to make modeling the surface
of vehicles easier.
Curves and polygons
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Figure 19: Creating different shapes by changing the tangent

Converting to a curve or polygon
Before modifying the points on an object, it must first be converted to a curve or a polygon,
depending on what kind of effect you want to produce.
After selecting an object, go to Modify > Convert and select either To Curve or To Polygon.
Alternatively, right-click on an object and then select Convert > To Curve or Convert > To
Polygon from the contextual menu that pops up.
After converting an object to a curve or polygon, click on the Points icon
on the Drawing
toolbar; the Edit Points toolbar opens. You can also open this toolbar using View > Toolbars >
Edit Points on the main menu bar.
You will notice that after the conversion, the handles located in the corners of the selection
rectangle have disappeared. This behavior is normal because the handles used with the tools on
the Edit Points toolbar are located along the outline or trace of the object.

Edit Points toolbar
Open the Edit Points toolbar (Figure 20) by going to View > Toolbars > Edit Points on the main
menu bar. It will then appear whenever you select an object that is a curve or polygon and the Edit
Points icon on the Drawing toolbar. Available tools on the Edit Points toolbar will depend on the
object selected and which object point has been selected.

Figure 20: Edit Points toolbar
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Tangents
Note

Tangents are only used on curves. If an object has been converted to a polygon and
a tangent is added, the object is automatically converted to a curve.

Symmetric transition
Click on the Symmetric Transition icon
to work with a symmetrical tangent (Figure 21). Any
movement of one tangent handle is carried over symmetrically to the other handle.

Figure 21: Symmetric transition

Smooth transition
Click on the Smooth Transition icon
to adjust separately the lengths on each side of a
tangent to make a curve flatter or steeper. This creates an asymmetric tangent and the curve is
flatter on the longest side of the tangent (Figure 22).

Figure 22: Smooth transition

Corner point
It is possible to change independently the angle on each side of a tangent using the central point of
the tangent as a corner point. Select a point on the curve, then click on the Corner Point icon
to create a corner point from the selected point (Figure 23). When a corner point is created, you
can change the angle on each tangent side to create spikes and troughs in curves.

Figure 23: Corner point

Tangent rotation
You can alter the angle by which a tangent relates to curve by clicking on one of the end points of
the tangent and rotating it with the mouse cursor. As you change the angle of the tangent, the
shape of the curve changes in response (Figure 24).

Curves and polygons
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Figure 24: Tangent rotation

Points
Moving points
Click on the Move Points icon
to move any of the points when an object has been converted
to a curve or polygon. When Move Points is active, the mouse cursor changes shape when it
hovers over a point. Moving a point is an easy manipulation to carry out. Figure 25 illustrates how
an ovoid or egg shape was created from a circle by dragging the right hand side point to the right.

Figure 25: Moving points

Inserting points
Click on the Insert Points icon
to add an extra point to an existing curve or polygon. Click on
the object border at the spot where you want to insert a point. The tangent type associated with the
new point depends on where the point has been added to the object border. Figure 26 shows a
new point added to the top right of an ovoid shape.

Figure 26: Inserting points
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Deleting points
Clicking on the Delete Points icon
removes a point from the border of an object. The resulting
curve automatically changes shape around the remaining points. Figure 27 shows what happens
when the right point was deleted from a circle. You can select several points by holding down the
Shift key, then click on the Delete Points icon. You can also delete selected points by pressing the
Del key on the keyboard.
If a curve has been converted to a line (see “Converting curves or lines” on page 20) and selected
points are deleted, a straight line is formed between the two points on either side of the now
deleted points.

Figure 27: Deleting points

Eliminating points
The Eliminate Points icon

only functions on lines with multiple points. These lines are created

when a curve is converted to a line using the Convert to Curve icon
(see “Converting curves or lines” on page 20).

on the Edit Points toolbar

The process of eliminating points from a line to create a straight line is shown in Figure 28.
1) Select a line with multiple points and click on the Points icon on the Drawing toolbar. The
Edit Points toolbar should open. If it does not open, then go to View > Toolbars > Edit
Points on the main menu bar to open it.
2) Use the mouse cursor to select the point on the line that you want to eliminate. The
selected point will be emphasized.
3) Make sure the Eliminate Points icon is active. The area around the icon becomes shaded
when active. If it is not active, click on the Eliminate Points icon.
4) Accurately position the mouse cursor over the selected point, then click and hold the
mouse button and start dragging the selected point. As you drag, a dotted line forms
between the two neighboring points.
5) When this dotted line appears to be a straight line between the two neighboring points,
release the mouse button. The selected point has been eliminated and a straight line now
exists between the two neighboring points.

Curves and polygons
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Figure 28: Eliminating points

Converting curves or lines
Curves and lines can be easily converted to each otherusing the Convert to Curve icon
on
the Edit Points toolbar. When a curve is converted to a line, a straight line is created between
selected points on a curve. When a line is converted to a curve, a curve is created between
selected points on a line.
Select a curve or line, then select the points on the curve or line where you want to do the
conversion. Click on the Convert to Curve icon and the curve or line is converted (Figure 29).

Figure 29: Converting curves and lines

20

Working with Objects and Object Points

Splitting curves
Click on the Split Curve icon
to split or cut a curve at the location of the selected point. If the
object is filled, it will be emptied, because the curve that represented the object border is no longer
closed (Figure 30).
The point where you split the curve is now larger than the remaining points visible on the curve,
(except for the curve start point which is also larger than the other points).
You can separate a curve at several points simultaneously. Keep the Shift key pressed down and
select all of the points at which the cut should occur, then click on the Split Curve icon. Deselect
the curve, then drag and drop segments with the mouse to move them away from the original
curve.

Figure 30: Splitting curves

Closing curves
To close an open and existing curve, first select the open curve, then select the start point of the
curve. The start point is larger than the other points visible on the curve. Click on the Close Bézier
icon

to close the curve (Figure 31).

If the open curve was originally a closed and filled curve, then when the curve is closed again, the
original color will fill the curve.

Figure 31: Closing curves

Curves and polygons

21

Rotating and distorting curves
To rotate and distort a curve, first select the curve then click on the Rotate icon
on the Mode
toolbar. If the Mode toolbar is not open, go to View > toolbars > Mode or click on the small
triangle or arrow to the right of the Rotate icon on the Drawing toolbar. The points on the curve
change color and shape (Figure 32).
Select one of the points on the curve and move it by dragging the mouse cursor. Movement will be
restricted to the original border of the curve.
Select one of the control points at the end of the tangent line and rotate the distorted curve by
dragging the mouse cursor. The distorted curve will rotate about the center of rotation.

Figure 32: Rotating and distorting curves
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