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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click or right-click
depending on computer setup

Opens a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Open the Navigator

F11

⌘+T

Open the Styles and Formatting window
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Introduction
A template is a document model that you use to create other documents. For example, you can
create a template for business reports that has your company’s logo on the first page. New
documents created from this template will all have your company’s logo on the first page.
Templates can contain anything that regular documents can contain, such as text, graphics, a set
of styles, and user-specific setup information such as measurement units, language, the default
printer, and toolbar and menu customization.
All documents in LibreOffice are based on templates. If you do not specify a template when you
start a new Writer document, then the document is based on the default template for text
documents. If you have not specified a default template, Writer uses the blank template for text
documents that is installed with LibreOffice. See “Setting a default template” on page 8.
LibreOffice supplies only a few user-selectable templates. You can add templates from other
sources (see page 7) as well as creating your own templates (see page 5).

Using a template to create a document
Creating a document from the Templates dialog
To use a template to create a document:
1)

From the Menu bar, choose File > New > Templates, or click on the small arrow next to
the New icon on the Standard toolbar and select Templates.

Figure 1: Templates dialog
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2)

From the Filters list at the top of the Templates dialog, select Documents. You can also
choose a category. Templates in that folder are shown on the page.

3)

Double-click on the required template. A new document based on the selected template
opens in Writer. You can then edit and save the new document just as you would any other
document.

The template the document is based upon is listed in File > Properties > General. The connection
between the template and the document remains until the template is modified and, the next time
that the document is opened, you choose not to update it to match the template. Or, if you copy or
move the document to a different computer, which does not have a copy of that template installed,
the connection is broken.

Creating a document from a template in the Start Center
You can create a document from the template view of the Start Center, which is visible when no
other document is open.
To open the Templates dialog from the Start Center, click on the Templates button in the left pane.
The button is also a drop-down list to select the templates of a given type of document. The
Manage Templates option on the list opens the Templates dialog.

Creating a template
You can create templates in two ways: by saving a document as a template or by using a wizard.

Creating a template from a document
In addition to formatting, any settings that can be added to or modified in a document can be saved
within a template. For example, you can also save printer settings, and general behaviors set from
Tools > Options, such as Paths and Colors.
Templates can also contain predefined text, saving you from having to type it every time you create
a new document. For example, a letter template may contain your name, address, and salutation.
You can also save menu and toolbar customizations in templates; see Chapter 21, Customizing
Writer, for more information.
To create a template from a document and save it to My Templates:
1)

Open a new or existing document of the type you want to make into a template (text
document, spreadsheet, drawing, or presentation).

2)

Add any content that you want to appear in any document you create from the new
template, for example company logo, copyright statement, and so on.

3)

Create or modify any styles that you want to use in the new template.

4)

From the Menu bar, choose File > Templates > Save as Template. The Save as Template
dialog (Figure 2) displays the existing categories and a textbox to enter a name for the new
template.

5)

Select the My Templates folder.

6)

Click Save. The template is saved and the dialog closes.
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Figure 2: Save as Template dialog

Creating a template using a wizard
You can use wizards to create templates for letters, faxes, and agendas, and to create
presentations and Web pages.
For example, the Fax Wizard guides you through the following choices:
•

Type of fax (business or personal)

•

Document elements like the date, subject line (business fax), salutation, and complimentary
close

•

Options for sender and recipient information (business fax)

•

Text to include in the footer (business fax)

To create a template using a wizard:
1)

From the Menu bar, choose File > Wizards > [type of template required].

2)

Follow the instructions on the pages of the wizard. This process is slightly different for each
type of template, but the format is very similar.

3)

In the last section of the wizard, you can specify the template name which will show in the
Templates dialog, and also the name and location for saving the template. The two names
can be different but this may later cause confusion. The default location is your user
templates folder, but you can choose a different location.

4)

To set the file name or change the folder, select the Path button (the three dots to the right
of the location). On the Save As dialog, make your selections and click Save.

5)

Finally, you can choose whether to create a new document from the template immediately,
or manually change the template, and then click Finish to save the template. For future
documents, you can re-use the template created by the wizard, just like any other template.

You may need to open the Templates dialog and click Refresh on the Action menu to have any new
templates appear in the listings.

Editing a template
You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s
styles to documents that were created from that template. You cannot reapply content.
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To edit a template:
1)

From the Menu bar, choose File > Templates > Manage Templates or press Ctrl+Shift+N.
The Templates dialog opens. You can also open the Templates dialog from the Start Center.

2)

Navigate to the template that you want to edit. Click once on it to activate the file handling
controls. Right-click to open the context menu and click Edit. The template opens in
LibreOffice.

3)

Edit the template as you would edit any other document. To save your changes, choose
File > Save from the Menu bar.

Updating a document from a changed template
If you make any changes to a template and its styles, the next time you open a document that was
created from the template before the changes, a confirmation message is displayed.
To update the document:
1)

Select Update Styles to apply the changed styles in the template to the document.

2)

Select Keep Old Styles if you do not want to apply the changed styles in the template to
the document (but see the Caution notice below).

Caution
If you choose Keep Old Styles, the document is no longer connected to the template,
even though the template is still listed under File > Properties > General. You can still
import styles manually from the template, but to reconnect it to the template, you will
have to copy it into an empty document based on the template.

Adding templates obtained from other sources
LibreOffice refers to sources for templates as repositories. A repository can be local (a directory on
your computer to which you have downloaded templates) or remote (a URL from which you can
download templates).
You can get to the official template repository by using the Browse online templates button at the
right-hand end of the Templates dialog, as shown in Figure 3, or by typing
https://extensions.libreoffice.org/templates in your browser’s address bar.
On other websites you may find collections of templates that have been packaged into extension
(.oxt) files. These are installed a little differently, as described below.

Figure 3: Getting more templates for LibreOffice

Installing individual templates
To install individual templates:
1)

Download the template and save it anywhere on your computer.

2)

Import the template into a template folder by following the instructions in “Importing a
template” on page 11.
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Tip
(For advanced users) You can manually copy new templates into the template folders.
The location varies with your computer’s operating system. To learn where the template
folders are stored on your computer, go to Tools > Options > LibreOffice > Paths.

Installing collections of templates
The Extension Manager provides an easy way to install collections of templates that have been
packaged as extensions. Follow these steps:
1)

Download the extension package (.oxt file) and save it anywhere on your computer. If the
package is in a .zip file, extract the .oxt file.

2)

In LibreOffice, select Tools > Extension Manager from the Menu bar. In the Extension
Manager dialog, click Add to open a file browser window.

3)

Find and select the package of templates you want to install and click Open. The package
begins installing. You may be asked to accept a license agreement.

4)

When the package installation is complete, restart LibreOffice. The templates are available
for use through File > Templates > Manage Templates and File > New > Templates and
the extension is listed in the Extension Manager.

See Chapter 21, Customizing Writer, for more about the Extension Manager.

Setting a default template
If you create a document by choosing File > New > Text Document from the Menu bar, Writer
creates the document from the default template for text documents. You can, however, set a
custom template to be the default. You can reset the default later, if you choose.

Setting a template as the default
Most default settings, such as page size and page margins, can be changed in Tools > Options,
but those changes apply only to the document you are working on. To make those changes the
default settings for that document type, you need to replace the default template with a new one.
You can set any template in the Templates dialog to be the default for that document type:
1)

From the Menu bar, choose File > Templates > Manage Templates.

2)

In the Templates dialog, open the category containing the template that you want to set as
the default, then select the template.

3)

Right-click on the selected template and click the Set as default button (see Figure 4).

Figure 4: Setting a template as the default template for documents
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The next time that you create a document of that type by choosing File > New, the document will
be created from this template.

Resetting Writer’s default template as the default
To re-enable Writer’s default template as the default:
1)

In the Templates dialog (Figure 5), click the Settings icon

on the right.

2)

Point to Reset Default Template on the drop-down menu, and click Text Document.
This choice does not appear unless a custom template had been set as the default, as
described in the previous section.

Figure 5: Resetting the default template for text documents
The next time that you create a document by choosing File > New > Text Document, the
document will be created from Writer’s default template.

Associating a document with a different template
At times you might want to associate a document with a different template, or perhaps you’re
working with a document that did not start from a template.
One of the major advantages of using templates is the ease of updating styles in more than one
document, as described in Chapter 9, Working with Styles. If you update styles in a document by
loading a new set of styles from a different template (as described in Chapter 9), the document has
no association with the template from which the styles were loaded—so you cannot use this
method. What you need to do is associate the document with the different template.
For best results, the names of styles should be the same in the existing document and the new
template. If they are not, you will need to use Edit > Find & Replace to replace old styles with new
ones. See Chapter 2, Working with Text: Basics, for more about replacing styles.
1)

Use File > New > Templates. In the Templates dialog, double-click the template you want
to use. A new document opens, containing any text or graphics that were in the template.

2)

Delete any unwanted text or graphics from this new document.

3)

Open the document you want to change. (It opens in a new window.)

4)

Use Edit > Select All, or press Ctrl+A, to select everything in the document.

5)

Click in the blank document created in step 1. Use Edit > Paste, or press Ctrl+V, to paste
the contents from the old document into the new one.

6)

Update the table of contents, if there is one. Close the old file without saving. Use File >
Save As to save this new file with the name of the file from which content was taken. When
asked, confirm you wish to overwrite the old file. Or, you may prefer to save the new file
under a new name and preserve the old file under its original name.
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Caution
Any changes recorded (tracked) in the document will be lost during this process. The
resulting document will contain only the changed text.

Organizing templates
Writer can only use templates that are in LibreOffice template folders. You can, however, create
new LibreOffice template folders and use them to organize your templates. For example, you might
have one template folder for report templates and another for letter templates. You can also import
and export templates.
To begin, choose File > Templates > Manage Templates from the Menu bar to open the
Templates dialog.

Creating a template category
To create a template category:
1)

Click the Settings button of the Templates dialog.

2)

Click New category on the context menu (see Figure 6).

3)

In the pop-up dialog, type a name for the new category and click OK.

Note
You cannot create a sub-category inside a template category in LibreOffice.

Figure 6: Creating a new category

Deleting a template category
You cannot delete template categories supplied with LibreOffice. Nor can you delete any
categories added by the Extension Manager unless you first delete the extension that installed
them.
However, you can delete a category that you created. Select it and click the Delete button. When a
message box appears asking you to confirm the deletion, click Yes.

Moving a template
To move a template from one template category to another, select it in the Templates dialog, and
click the Move button in the bottom center of the dialog (see Figure 7). In the popup dialog, select
the required category and click OK.
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Figure 7: Moving templates to another category

Deleting a template
You cannot delete templates supplied with LibreOffice. Nor can you delete any templates installed
by the Extension Manager except by deleting the extension that installed them.
However, you can delete templates that you have created or imported:
1)

In the Templates dialog, select the category that contains the template you want to delete.

2)

Select the template to delete.

3)

Right-click to open the context menu of the template and click Delete. A message box
appears and asks you to confirm the deletion. Click Yes.

Importing a template
Before you can use a template in LibreOffice, it must be in one of the folders listed for the Template
path in Tools > Options > LibreOffice > Paths:
1)

In the Templates dialog, click the Import button on the bottom right. The Select Category
dialog appears.

2)

Find and select the category where you want to import the template and click OK. A
standard file browser window opens.

3)

Find and select the template that you want to import and click Open. The file browser
window closes and the template appears in the selected category.

Exporting a template
To export a template from a template category to another location in your computer or network:
1)

In the Templates dialog, locate the category that contains the template to export.

2)

Select the template that you want to export.

3)

Click the Export button in the bottom right of the dialog. The Save As window opens.

4)

Find the folder into which you want to export the template and select Save.
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