
Draw Guide

Chapter 6 
Editing Pictures
Raster Graphics



Copyright

This document is Copyright © 2020 by the LibreOffice Documentation Team. Contributors are 
listed below. You may distribute it and/or modify it under the terms of either the GNU General 
Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons 
Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

To This Edition

Peter Schofield Claire Wood Regina Henschel

To Previous Editions

Martin Fox John Cleland Jean Hollis Weber

John A Smith Peter Schofield

Feedback
Please direct any comments or suggestions about this document to the Documentation Team’s 
mailing list: documentation@global.libreoffice.org

Note

Everything sent to a mailing list, including your email address and any other personal 
information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version
Published June 2020. Based on LibreOffice 6.4.

Using LibreOffice on macOS
Some keystrokes and menu items are different on macOS from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this document. For a 
more detailed list, see the application Help.

Windows or Linux macOS equivalent Effect

Tools > Options menu LibreOffice > Preferences Access setup options

Right-click Control +click or right-click 
depending on computer setup

Open a context menu

Ctrl  (Control) ⌘   (Command) Used with other keys

F5 Shift + ⌘ + F5 Open the Navigator

F11 ⌘ + T Open the sidebar Styles deck

Documentation for LibreOffice is available at http://documentation.libreoffice.org/en/

http://documentation.libreoffice.org/en/
mailto:documentation@global.libreoffice.org
http://creativecommons.org/licenses/by/4.0/
http://www.gnu.org/licenses/gpl.html


Contents

Copyright..............................................................................................................................2
Contributors.................................................................................................................................2

To This Edition.........................................................................................................................2
To Previous Editions................................................................................................................2

Feedback.....................................................................................................................................2

Publication date and software version.........................................................................................2

Using LibreOffice on macOS........................................................................................................2

Introduction..........................................................................................................................4

Importing graphics...............................................................................................................4
Inserting.......................................................................................................................................4

Embedding...................................................................................................................................4

Linking.........................................................................................................................................5

Scanning......................................................................................................................................6

Copying and pasting....................................................................................................................7

Dragging and dropping................................................................................................................8

Exporting graphics..............................................................................................................8
Exporting files..............................................................................................................................8

Exporting objects.........................................................................................................................9

Formatting raster objects....................................................................................................9
Naming raster graphics................................................................................................................9

Image toolbar.............................................................................................................................10

Shadow and Images sections on Sidebar..................................................................................11

Cropping.............................................................................................................................12
Quick cropping...........................................................................................................................13

Crop dialog................................................................................................................................13

Image filter toolbar.............................................................................................................15

Replacing colors................................................................................................................20
Replacing colors........................................................................................................................20

Replacing transparent areas......................................................................................................21

Tolerance parameter..................................................................................................................21

Conversion.........................................................................................................................22
Contour conversion....................................................................................................................22

Polygon conversion....................................................................................................................22
Converting.............................................................................................................................23
Conversion options and controls...........................................................................................23
Breaking................................................................................................................................23
Splitting.................................................................................................................................24

Bitmap conversion.....................................................................................................................24

Print options.......................................................................................................................24

Editing Pictures | 3



Introduction

Earlier chapters of the Draw Guide have dealt only with vector graphics. The most common types 
of vector graphics in use are as follows:

• SVG – Scalable Vector Graphics. An Extensible Markup Language (XML) based vector 
image format for two-dimensional graphics with support for interactivity and animation.

• EPS – Encapsulated PostScript. A PostScript document format usable as a graphics file 
format. EPS files are more-or-less self-contained, reasonably predictable PostScript 
documents that describe an image or drawing and can be placed within another PostScript 
document.

• AI – Adobe Illustrator. A proprietary file format developed by Adobe Systems for 
representing single-page vector-based drawings in either the EPS or PDF formats.

However, Draw also contains a number of functions for handling raster graphics (bitmaps) such as 
photographs and scanned pictures, including import, export, and conversion from one format to 
another.

Draw can read all the majority of graphic file formats. It has a subset of capabilities similar to raster
graphics programs like Adobe Photoshop or Gimp. Raster graphics are generally images or 
pictures that use one of the following formats, which are the most common formats in use:

• JPG/JPEG – acronym for Joint Photographic Experts Group which created the format. It is 
the most common image format on World Wide Web and most digital cameras produce 
JPEG images as default.

• GIF – Graphics Interchange Format. GIF is a bitmap image format that is popular because 
of its wide support and portability.

• PNG – Portable Network Graphics. PNG is a raster image format which supports lossless 
data compression and also background transparency.

• TIF/TIFF – Tagged Image File Format. TIFF is flexible, adaptable, and capable of storing 
image data in a lossless format.

• BMP – BitMaP. It is also known as bitmap image file, which is a dot matrix data structure.

Importing graphics

Inserting
To import graphic files into your drawing, go to Insert > Image on the main menu bar or click on 
the Insert Image icon on the Standard toolbar to open the Insert Image dialog (Figure 1).

Draw contains import filters for the majority of graphic formats. If the file you want to import has a 
graphic format not covered by the import filters, then it is recommended to use one of the many 
free graphic conversion programs to convert the file into a format that Draw recognizes.

If you select the Preview option in the Insert Image dialog, a preview of the file is shown in the 
box on the right-hand side. This makes it much easier to select the file you want and also checks 
that Draw can import the file format used.

Embedding
Embedding a graphic into a drawing makes the graphic a permanent part of the drawing. Any 
changes you make to an embedded graphic will only appear in the drawing. The original graphic 
file will not be affected.
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Figure 1: Insert Image dialog

Embedding happens when you import a graphic into a drawing using the Insert Image dialog 
(Figure 1), copying and pasting, scanning a graphic, or dragging and dropping.

The main advantage of embedding graphics into your drawing is that the graphic is always 
available no matter what computer is used to open the drawing.

The main disadvantage of embedding graphics is that it creates large file sizes, which may not be 
desirable if you have limited capacity for storing computer files. Also, if the original graphic is 
altered, then your drawing will not have an up to date version each time you open your document.

Note

When you embed a graphic into a LibreOffice document or drawing, you must make 
sure that the Link option is not selected in the Insert Image dialog.

Linking
Linking a graphic to a drawing does not insert the graphic into the drawing, but a link is created to 
where the graphic file is located on your computer. Each time the drawing is opened, any linked 
graphics will be displayed in the drawing.

The main advantage of linking a graphic file to a drawing is if the original graphic file is altered or 
replaced by a new graphic with the same filename. The next time you open the drawing, the latest 
version of the graphic will also open in the drawing. Also the drawing file size is much smaller and 
the original graphic can easily be edited with specialized external applications.

The main disadvantage of linking graphics is that the link between the drawing and the graphic file 
must be maintained for linking to work correctly. If you move the drawing to another computer, then
any linked files must also be moved to the same computer and the same folder on that computer.

To link a graphic file to your drawing, select the Link option in the Insert Image dialog (Figure 1) 
before selecting the file and clicking on the Open button. This opens a confirmation dialog to 
inform you that the graphic file will not be stored with your drawing, but only referenced as a link.

• Click on Link to link the file and close the confirmation dialog.

• Click on Embed Graphic if you do not want the file to be linked and embed the file. This 
will also close the confirmation dialog.
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Figure 2: Edit Links dialog

Note

When a graphic file is linked to a LibreOffice document or drawing, the format of the 
linked graphic is not changed.

Changes made in your LibreOffice drawing to a linked graphic will apply only to the linked graphic 
placed into your the drawing. The original graphic file will not be affected when it has been linked to
your drawing.

Links can be updated, modified, or broken as follows:

 1) Go to Edit > Links to External File on the main menu bar to open the Edit Links dialog 
(Figure 2).

 2) Select the link to be edited.

 3) Click on Modify, Break Link, or Update as appropriate.

• Modify – changes the source file for the selected link.

• Break Link – breaks the link between the source file and the current document. The 
most recently updated contents of the source file are kept in the current document.

• Update – updates the selected link so that the most recently saved version of the linked
file is displayed in the current document.

 4) Click Close to close the Edit Links dialog when you have finished editing the link.

Note

If you click Break Link, then the linked graphic becomes embedded in your drawing.

Scanning
With most scanners you can directly insert a scanned image into a drawing or document. Scanned 
images are embedded using PNG format. Make sure that your scanner is configured for the 
computer and supported by the SANE system for a Linux operating system, or TWAIN for a 
Windows or Mac operating system.
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To insert an image from the scanner:

 1) Place a document, drawing, or photograph in the scanner and make sure that the scanner 
is switched on and ready.

 2) If this is the first time the scanner has been used, go to Insert > Media > Scan > Select 
Source on the main menu bar to select the scanner. If the scanner has been used before, 
go to Insert > Image > Scan > Request on the main menu bar.

 3) The rest of the procedure depends on the scanner driver, interface, and computer operating
system. You will normally be required to specify scanning options such as resolution, scan 
window, and so on. Consult the documentation that came with the scanner for more 
information.

 4) When the image has been scanned, Draw places it in the drawing. At this point it can be 
edited like any other graphic.

Note

If there is more than one scanning device connected to the computer, you will be able 
to select the device when you select the source. This selection will then become the 
default source when using scan requests until another device is used as the scanning 
source.

Copying and pasting
Copying a graphic and then pasting the graphic into another drawing is another way of embedding 
graphics into a drawing (this is also called using the clipboard). The copied graphic can be an 
image already embedded in another document or drawing, or it can be a graphic file such as a 
drawing, document or photograph.

After copying you can also choose the format when you paste a graphic into Draw using Edit > 
Paste Special > Paste Special on the main menu bar to open the Paste Special dialog (Figure
3). Available formats will depend on the type of image copied onto the clipboard.

Figure 3: Paste Special dialog

Note

When copying and pasting images into your drawing, please respect the copyright and
license of the image you have copied.
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Dragging and dropping
Dragging and dropping is another method of embedding graphics into a drawing and can be used 
on graphics that have been embedded or linked. The way that dragging and dropping works is 
determined by the computer operating system. Behavior of dragging and dropping is normally 
controlled using the Ctrl  or Ctrl+Shift  keys in combination with the mouse.

Objects and images which are used frequently can be stored in the Draw Gallery. From the Gallery,
a copy of the object or image can be simply dragged onto the drawing. Working with the Gallery is 
dealt with in Chapter 10 Advanced Draw Techniques.

Exporting graphics

Exporting files
By default Draw saves drawings in the *.ODG format. Some software programs cannot open these
files. To make your drawings available for other programs, you can export the file in various 
formats.

 1) Open the ODG file you want to export.

 2) Go to File > Export on the main menu bar and the Export dialog (Figure 4) opens.

Figure 4: Export dialog
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Figure 5: Example export options

 3) If required, enter a new filename for the exported file in File name and navigate to the folder
where you want to place the exported file.

 4) Select the required format from the drop down list in File format.

 5) Click Export and your file will be exported as a new file in its new format.

 6) Depending on the format selected, another dialog may open allowing you to select the 
required options for the selected format. An example dialog for WMF export options is 
shown in Figure 5.

 7) Depending on the additional dialog that may open, click on Export, Create, or OK and your
file will be exported as a new file in its new format.

Exporting objects
Exporting individual objects from a drawing file is similar to “Exporting files” above. You have to 
open your drawing file and then select the object or objects you want to export from your drawing 
file.

Formatting raster objects

Raster graphics can be edited and formatted using one of the following methods to add or change 
filters and adjust the properties of color, lines, areas, and shadows:

• Go to Format > Image on the main menu bar and use one of the tools in the context menu 
that opens.

• Use the tools on the Image toolbar. See “Image toolbar” on page 10 for more information.

• Use the tools available in the Shadow and Image sections on the Properties deck of the 
Sidebar. See “Shadow and Images sections on Sidebar” on page 11 for more information.

• Some raster graphics may have a text element. For more information on formatting text see
Chapter 9 Adding and Formatting Text.

Raster graphics included in a group behave like other objects when the properties of the group are 
edited and formatted.

Naming raster graphics
It is recommended to name any objects that are raster graphics in your drawing. This will make the
named raster graphics visible and available in the LibreOffice Navigator. Use of one of the 
following methods to open the Name dialog (Figure 6) allowing you to enter a name for the 
selected raster graphic:
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Figure 6: Name dialog

• Go to Format > Name on the main menu bar.

• Right click on the raster graphic and select Name from the context menu.

Image toolbar
The Image toolbar (Figure 7) normally appears when you select an image or picture that is a raster
graphic. The Image toolbar can be fixed at the top of your drawing or as a floating toolbar. The 
default set of tools on the Image toolbar are as follows and are indicated by a tick mark in Figure 7:

• Position and Size (F4) – opens the Position and Size dialog. See Chapter 3 Working with
Objects and Object Points for more information.

• Align – opens the Align Objects toolbar where you align an object in relation to other 
objects in the drawing. See Chapter 5 Combining Multiple Objects for more information.

• Arrange tools – a set of seven tools that are used to move a selected object either forward 
or backward in relation to other objects in the drawing. See Chapter 5 Combining Multiple 
Objects for more information.

• Line Style – opens a drop down list with different line styles. In this context, line refers to 
the outline of the border. See Chapter 4 Changing Object Attributes for more information.

• Line Width – allows you to change the width of a line. See Chapter 4 Changing Object 
Attributes for more information.

• Line Color – allows you to change the color of a line. See Chapter 4 Changing Object 
Attributes for more information.

• Area Style/Filling – allows you to change the type of filling used in a shape. See Chapter 4
Changing Object Attributes for more information.

Figure 7: Image toolbar and Visible Buttons
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• Shadow – sets the default shadow effect around the picture. See Chapter 4 Changing 
Object Attributes for more information.

• Filter – opens the Image Filter toolbar which is described in “Image filter toolbar” on page
15.

• Image mode – changes the display of the graphic from color to grayscale, black and white,
or a watermark. This setting affects only the display and printing of the picture; the original 
picture file remains unchanged.

• Default – the graphic is displayed unaltered in color.

• Grayscale – the graphic is displayed in 256 shades of gray.

• Black/White – the graphic is displayed in black and white.

• Watermark – the color, brightness, contrast and gamma settings are reduced so that 
the graphic can be used as a watermark (background). These default settings can be 
adjusted using the Color toolbar (Figure 8).

• Crop Image – crops or trims a picture. When you click on this tool, crop marks appear 
around the picture. Drag one or more of these marks to crop the picture to your desired 
size. For more information on cropping, see “Cropping” on page 12.

• Vertically – flips the selected object vertically. See Chapter 4 Changing Object Attributes 
for more information.

• Horizontally – flips the selected object horizontally. See Chapter 4 Changing Object 
Attributes for more information.

• Transformations – opens the Transformations toolbar. See Chapter 4 Changing Object 
Attributes for more information.

• Transparency – adjust the degree of transparency of the picture between 0% (opaque) 
and 100% (fully transparent).

• Color – opens the Color toolbar (Figure 8) so you can adjust the values of the RGB colors,
brightness, contrast, and Gamma. These adjustments do not affect the original picture, but 
the values are stored in Draw as a separate formatting set.

• Red, Green, Blue – select values between –100% (no color) to +100% (full intensity); 
0% represents the original color value of the graphic.

• Brightness – select a value between –100% (totally black) and +100% (totally white).

• Contrast – select a value between –100% (minimum) and +100% (maximum).

• Gamma – this affects the brightness of the middle color tones. Select a value between 
0.10 (minimum) to 10 (maximum) Try adjusting this value if changing brightness or 
contrast does not give you the required result.

Figure 8: Color toolbar

Shadow and Images sections on Sidebar
The Shadow and Image sections (Figure 9) in the Properties deck on the Sidebar are as follows:

• Shadow – sets the default shadow effect around a raster graphic. See Chapter 4 Changing
Object Attributes for more information.

• Image – changes the display of a raster graphic from color to grayscale, black and white, or
a watermark and also allows you to adjust the RGB color settings of a raster graphic. For 
more information see “Image toolbar” on page 10.
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Figure 9: Shadow and Image 
sections in Properties deck on the 
Sidebar

Cropping

Cropping is a method of hiding unwanted areas of an image or changing the size of an image in 
your drawing.

Changes made when cropping an image only change the display of the graphic in your drawing 
and not the original graphic file. If you want to use a cropped graphic in another drawing, you must 
use one of the following methods after selecting the cropped graphic:

• Go to File > Export on the main menu bar to open the Export dialog. Navigate to the folder
you want to use, then enter a filename and click on Export. See “Exporting graphics” on 
page 8 for more information.

• Go to Format > Image > Save on the main menu bar or right click on the cropped graphic 
and select Save from the context menu. Click on Yes to save the modified image and open 
the Image Export dialog (Figure 10). Select the file format you want to use, navigate to the 
folder you want to use, then enter a filename and click on Save.
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Figure 10: Image Export dialog

Quick cropping
After selecting an image, it can be cropped quickly using one of the following methods:

• Click on the Crop tool on the Standard toolbar.

• Click on the Crop tool on the Image toolbar (if displayed).

• Go to Format > Image > Crop on the main menu bar.

• Right-click on the image and select Crop from the context menu.

Selection handles will appear around the selected image and are used as follows:

• Top, bottom, left and right selection handles crop the image in one direction only.

• Corner selection handles crop the image in two directions. For example, top right corner will
crop the image from the top and from the right.

Crop dialog
For more control and accuracy over the cropping functions, it is recommended to use the Crop 
dialog (Figure 11). After selecting an image, go to Format > Image > Crop Dialog on the main 
menu bar to open the Crop dialog.

• Crop – use this section to trim or scale the selected graphic, or to add white space around 
the graphic.

• Keep scale – maintains the original scale of the graphic when cropping so that only the 
size of the graphic changes.
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Figure 11: Crop dialog

• Keep image size – maintains the original size of the graphic when you crop so that only 
the scale of the graphic changes. To reduce the scale of the graphic, select this option 
and enter negative values in the cropping boxes. To increase the scale of the graphic, 
enter positive values in the cropping boxes.

• Left and Right – if Keep scale is selected, enter a positive amount to trim the left or right
edge of the graphic, or a negative amount to add white space to the left or right of the 
graphic. If Keep image size is selected, enter a positive amount to increase the 
horizontal scale of the graphic, or a negative amount to decrease the horizontal scale of
the graphic.

• Top and Bottom – if Keep scale is selected, enter a positive amount to trim the top or 
bottom of the graphic, or a negative amount to add white space above or below the 
graphic. If Keep image size is selected, enter a positive amount to increase the vertical 
scale of the graphic, or a negative amount to decrease the vertical scale of the graphic.

• Scale – this section is used to change the scale of the selected graphic as it appears in a 
drawing.

• Width – enter a percentage value to change the width of a selected graphic.

• Height – enter a percentage value to change the height of a selected graphic.

• Image Size – this section is used to change the size of the selected graphic.

• Width – enter a value for the width of the selected graphic

• Height – enter a value for the height of the selected graphic.

• Original Size – the original size of the graphic is displayed above the button. Clicking on
this button and then clicking OK resets the selected graphic to its original size.

Note

In the Crop dialog, the Width and Height are treated as independent values. Changing
one without the other can result in significant distortion of the image and this may not 
be what you want.
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Image filter toolbar

Draw offers eleven filter effects that work on the current view of a graphic and they can be 
combined. Filters always apply to the entire graphic and it is not possible to use filters to edit only a
part of the graphic.

Select a raster graphic to open the Image toolbar (Figure 7 on page 10), then click on the Filter 
icon to open the Image Filter toolbar (Figure 12). 

Figure 12: Image Filter toolbar

Note

If your graphic is embedded, all graphic filters are applied directly to the graphic that is 
displayed in your drawing and cannot be undone in a subsequent session. The original
graphic is not changed. Save your drawing to keep any filter effects applied to the 
graphic in your drawing.

After you save and close the drawing, the graphic filter effects become permanent. If 
you do not want to retain a graphic filter, you must use Edit > Undo on the main menu
bar to cancel the filter effect before saving the file.

The filters available on the Image Filter toolbar are as follows:

• Invert image filter – inverts or reverses the color values of a color image (similar to a color 
negative), or the brightness values of a grayscale image. Apply the filter again to revert to 
the original graphic (Figure 13).

Figure 13: Invert image filter
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• Smooth image filter – softens or blurs the image by applying a low pass filter reducing the 
contrast between neighboring pixels and produces a slight lack of sharpness (Figure 14). 
Selecting this filter opens the Smooth dialog (Figure 15) where you can set and use the 
smooth radius parameter when you click OK.

Figure 14: Smooth image filter

Figure 15: Smooth dialog

• Sharpen image filter – sharpens the image by applying a high pass filter, increasing the 
contrast between neighboring pixels emphasizing the difference in brightness. This will 
accentuate the outlines and the effect will be strengthened if you apply the filter several 
times (Figure 16).

Figure 16: Sharpen image filter

• Remove Noise image filter – removes noise by applying a median filter comparing every 
pixel with its neighbor. It then replaces any pixel with extreme values that deviate in color by
a large amount from the mean value with a pixel that has a mean color value. The amount 
of picture information does not increase, but because there are fewer contrast changes 
resulting in an image that looks smoother (Figure 17).

Figure 17: Remove Noise image filter
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• Solarization image filter – solarization is a phenomenon in photography where an image 
recorded on a negative or on a photographic print is wholly or partially reversed in tone. 
Dark areas appear light or light areas appear dark. Solarization was originally a 
photochemical effect used during photographic film development and is now used in the 
digital world of computing to create a change or reversal of color (Figure 18). Selecting the 
Solarization filter opens the Solarization dialog (Figure 19), where you can define the 
Threshold value for solarization. Entering a Threshold value above 70% reverses the color 
values. Selecting the Invert option causes all the colors to be inverted.

Figure 18:  Solarization image filter

Figure 19: Solarization dialog

• Aging image filter – aging creates a look that resembles photographs developed in the 
early days of photography. All pixels are set to their gray values and then the green and 
blue color channels are reduced by the amount specified in Aging degree in the Aging 
dialog. Red color channel is not changed (Figure 20). Selecting the Aging image filter 
opens the Aging dialog(Figure 21), where you can define the Aging degree and create an 
old look for your graphic as shown in the right picture in Figure 20.

Figure 20: Aging image filter
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Figure 21: Aging dialog

• Posterize image filter – posterizing reduces the number of colors in an image making it 
look flatter. When used on a photograph, posterizing can make the photograph look like a 
painting. Selecting the Posterize image filter opens the Posterize dialog, where you can 
define the number of poster colors to produce the effect you want (Figure 22 and Figure
23).

Figure 22: Posterize image filter

Figure 23: Posterize dialog

• Pop Art image filter – select the Pop Art image filter to change the colors of an image to a 
pop-art format (Figure 24).
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Figure 24: Pop Art image filter

• Charcoal Sketch image filter – selecting the Charcoal Sketch image filter displays an 
image as a charcoal sketch. The contours of the image are drawn in black and the original 
colors are suppressed (Figure 25).

Figure 25: Charcoal Sketch 
image filter

• Relief image filter – this image filter calculates the edges of an image in relief as if the 
image is illuminated by a light source. Selecting the Relief image filter opens the Emboss 
dialog where you can select the position of the Light source producing shadows that differ 
in direction and magnitude (Figure 26 and Figure 27).

Figure 26: Relief image filter

Figure 27: Emboss dialog

• Mosaic image filter – this image filter joins groups of pixels and converts them into a 
rectangular tile in a single color creating an image that appears to be a mosaic. The larger 
the individual rectangles created, the fewer details the mosaic graphic has. Selecting this 
image filter opens the Mosaic dialog, where you can set the number of pixels used to 
create the Width and Height of each tile created. Selecting Enhanced edges will enhance 
the edges of each tile to create a sharper definition (Figure 28 and Figure 29).
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Figure 28: Mosaic image filter

Figure 29: Mosaic dialog

Replacing colors

The Color Replacer only allows you to replace or change a color in embedded graphics for 
another color or set a color as transparent. Up to four colors can be replaced at once. The tool 
works on the entire graphic and you cannot select an area of the graphic for editing.

The selection list for replacement colors shows all the available colors in the current color palette of
the drawing. You cannot define any new colors here, but you can add colors to the available palette
before using the Replace Color tool. For more information, see Chapter 10 Advanced Draw 
Techniques.

Note

The Color Replacer can only be used on embedded graphics. If you try to use the 
Color Replacer on a linked graphic, you will get the following error message “This 
image is linked to a document. Do you want to unlink the image in order to edit it?”

Replacing colors
Replace colors in an embedded image as follows:

 1) Go to Tools > Color Replacer on the main menu bar to open the Color Replacer dialog 
(Figure 30).

 2) Select an embedded image to start using the Color Replacer.

 3) Click on the Pipette icon at the top of the Color Replacer dialog to activate the color 
selection mode.

 4) Move the cursor over the color you want to replace in the selected image and click on the 
color to be replaced. A check box is now marked and the selected color appears in Source 
color.
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Figure 30: Color Replacer dialog

 5) If necessary, select another three colors in the selected image. Only a maximum of four 
colors can be selected.

 6) Enter the amount of tolerance required for replacing the color in the Tolerance box. The 
default selection is 10% tolerance.

 7) In Replace with, select a color from the drop-down list for each color selected. Transparent 
is the default selection.

 8) After selecting up to four colors for replacement, click Replace to replace the colors in the 
selected graphic.

 9) There is no preview of the effect. If the result is not what you required, select Edit > Undo 
in the main menu bar and repeat the color replacement.

Replacing transparent areas
It is also possible to replace transparent areas in an embedded image with a color.

 1) Go to Tools > Color Replacer on the main menu bar to open the Color Replacer dialog 
(Figure 30).

 2) Make sure the embedded image is NOT selected.

 3) Select Transparency in the Color Replacer dialog.

 4) Select a color from the drop-down list next to Transparency.

 5) Click Replace to replace the transparent areas with the selected color.

 6) There is no preview of the effect. If the result is not what you required, select Edit > Undo 
in the main menu bar and repeat the transparency replacement.

Tolerance parameter
The Tolerance parameter is used to set how much of the source color in an embedded image is 
replaced by another color.

• Replacing colors that are similar to the color you are replacing, enter a low value for the 
tolerance parameter.

• Replacing a wider range of colors, enter a higher value for the tolerance parameter.
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Conversion

Contour conversion
Contour conversion converts an image creating, from the original image, a polygon or group of 
polygons with four corner points with the image set as a background graphic. Any editing must be 
completed before carrying out a contour conversion because you can not carry out any further 
editing on the image.

 1) Make sure that all editing has been completed to the image you are going to convert and it 
is selected in your drawing.

 2) Go to Shape > Convert > To Contour on the main menu bar, or right-click on the image 
and select Convert > To Contour.

If the conversion creates a group of polygons (for example a text object), then you must enter the 
group using one of the following methods before selecting an individual polygon:

• Go to Shape > Enter Group on the main menu bar.

• Right-click on the converted image and select Enter Group from the context menu.

• Press the F3  key.

Polygon conversion
Polygon conversion is used to convert a selected image to a group of polygons filled with color. 
The image is also converted to a vector graphic and can be resized with no loss of image quality or
distortion of any text.

After conversion, you can break the graphic into groups of polygons and then split these groups 
into individual polygons. Breaking and splitting allows you to edit or delete individual colors within 
the graphic.

Figure 31: Convert to Polygon dialog
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Converting
 1) Select the image in your drawing.

 2) Convert the image into a polygon using one of the following methods and the Convert to 
Polygon dialog opens (Figure 31):

• Go to Shape > Convert > To Polygon on the main menu bar.

• Right-click on the image and select Convert > To Polygon from the context menu that 
opens.

 3) Select the Number of colors and Point reduction to be used in the conversion.

 4) Select Fill holes to prevent any blank areas appearing in your image.

 5) Enter the number of pixels to use for Tile size.

 6) Click Preview to check how your converted graphic will look.

 7) Make any necessary changes to the settings and check the preview again.

 8) If you are satisfied, click OK to convert your image to a polygon and close the Convert to 
Polygon dialog.

Conversion options and controls
• Number of colors – enter the number of colors to be displayed in the converted image. 

LibreOffice generates a polygon for each occurrence of a color in the image. The range for 
the number of colors is between 8 and 32.

• Point reduction – removes color polygons that are smaller than the pixel value you enter. 
The range for point reduction is between 0 and 32 pixels.

• Fill holes – fills the blank areas in the graphic that can be created when applying a point 
reduction.

• Tile size – enter the size of the rectangle for the background fill. The range of tile sizes is 
between 8 and 128 pixels.

• Source image – preview of the original image.

• Vectorized image – preview of the converted image.

• Preview – creates a preview of the converted image without applying any changes.

• OK – converts the image to a vector graphic consisting of polygons. The result is a metafile
in SVM format (StarView Metafile) used by LibreOffice and allows transfer of the converted 
image to other LibreOffice documents. 

Breaking
After converting an image to polygons, you can break the vectorized image into groups of 
polygons. Each group of polygons consists of one color and becomes an object that can be used in
another drawing.

 1) Convert your image to polygons, see “Converting” above.

 2) Select your image is selected, then use one of the following methods to break the image 
into a group of polygons:

• Go to Shape > Break on the main menu bar.

• Right-click on the image and select Break from the context menu.

 3) Click on a color in your image then drag the group of polygons filled with that color out of 
your image to create a new image OR press the Delete  key and delete the color from your
image.
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Splitting
After converting an image to polygons and breaking the image into groups of polygons, you can 
then split these polygon groups into individual polygons.

 1) Convert your image to polygons, see “Converting” above.

 2) Break your image into groups of polygons, see “Breaking” above.

 3) Select your image, then use one of the following methods to split the groups of polygons 
into individual polygons:

• Go to Shape > Split on the main menu bar.

• Right-click on the image and select Shapes > Split from the context menu.

• Use the keyboard combination Ctrl+Alt+Shift+K .

 4) Select an individual polygon (or several polygons) in your image and drag it out of your 
image to create new images in your drawing.

 5) Alternatively, press the Delete  key to delete the selected polygon(s) from your image.

Bitmap conversion
All drawing objects placed into a LibreOffice drawing are vector graphics and these vector graphics
can be converted to a bitmap (raster graphic)in PNG format. Any transparency effects in the 
original vector graphic are lost during conversion even though the PNG format used LO Draw 
supports transparencies.

Use one of the following methods to convert a vector graphic to a bitmap:

• Go to Shape > Convert > To Bitmap on the main menu bar.

• Right-click on the graphic and select Convert > To Bitmap from the context menu.

Print options

If you have only a monochrome (single color) printer or are experiencing problems with printing, 
then the following settings may help with printing your drawing. You can set up printing so that all 
text and all graphics are printed either in grayscale or black and white.

Figure 32: LO Draw Print Options dialog
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The general settings are in Tools > Options > LibreOffice Draw > Print on the main menu bar to 
open the Options – LibreOffice Draw – Print dialog (Figure 32). These options apply to all 
drawings that you print using LibreOffice Draw.

To set printing options for the current document only, go to File > Print on the main menu bar or 
use the keyboard combination Ctrl+P  and click on the LibreOffice Draw tab in the Print dialog 
(Figure 33).

To set printing options for all the modules in LibreOffice, go to Tools > Options > LibreOffice > 
Print (Figure 34). These printing options allow you to reduce the amount of print data sent to a 
printer or file. Also printer warnings can be given if the wrong paper size or orientation and 
transparency is used.

Figure 33: LibreOffice Draw Print dialog for current 
document

Figure 34: LibreOffice Print Options dialog
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