Appendix B, Toolbars
Copyright

This document is Copyright © 2022 by the LibreOffice Documentation Team. Contributors are listed below. This document maybe distributed and/or modify it under the terms of either the GNU General Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (https://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

To this edition

Peter Schofield

To previous editions

Peter Schofield  
Dave Barton  
Jean Hollis Weber

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note

Everything sent to a mailing list, including email addresses and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version

Published January 2022. Based on LibreOffice 7.2 Community.  
Other versions of LibreOffice may differ in appearance and functionality.

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this document.  
For a detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open the Styles deck in the Sidebar</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/
Contents

Copyright........................................................................................................................................2
  Contributors................................................................................................................................2
  Feedback..................................................................................................................................2
  Publication date and software version...................................................................................2
  Using LibreOffice on macOS.................................................................................................2

Introduction................................................................................................................................5

Using toolbars.............................................................................................................................5
  Displaying toolbars.................................................................................................................5
  Closing toolbars......................................................................................................................5
  Moving toolbars....................................................................................................................6
    Docked toolbars....................................................................................................................6
    Floating toolbars..................................................................................................................6
    Floating sub-toolbars..........................................................................................................6
    Docking a floating toolbar.....................................................................................................7
  Locking toolbars....................................................................................................................7
    Docked toolbars....................................................................................................................7
    Locking sub-toolbars............................................................................................................7
  Editing toolbars.....................................................................................................................8
    Adding tools.........................................................................................................................8
    Deleting tools.....................................................................................................................8
    Customizing toolbars..........................................................................................................8

Toolbars......................................................................................................................................9
  3D-Objects...............................................................................................................................9
  3D-Settings..............................................................................................................................9
  Align Objects..........................................................................................................................10
  Comments..............................................................................................................................10
  Distribute Selection................................................................................................................10
  Drawing...................................................................................................................................11
  Edit Points..............................................................................................................................13
  Find.........................................................................................................................................13
  Fontwork..................................................................................................................................13
  Form Controls........................................................................................................................14
  Form Design...........................................................................................................................14
  Form Navigation.....................................................................................................................15
  Glue Points..............................................................................................................................15
  Image.......................................................................................................................................16
  Insert.......................................................................................................................................16
  Legacy Circles and Ovals.........................................................................................................16
  Legacy Rectangles..................................................................................................................17
  Line and Filling.......................................................................................................................17
  Master View...........................................................................................................................18
  Media Playback.......................................................................................................................18
  Options...................................................................................................................................18
  Redaction................................................................................................................................19

Appendix B, Toolbars | 3
Appendix B, Toolbars
Introduction

Draw provides several toolbars to help in creating drawings. Each toolbar has a default set of tools and the option to add additional tools.

Note

The icons displayed in the Draw toolbars illustrated in this appendix may differ from what is displayed on a computer screen. Toolbar icons depend on the computer operating system being used and how LibreOffice has been set up. For more information on customizing LibreOffice and the toolbars, see the Getting Started Guide.

Using toolbars

Displaying toolbars

To display a toolbar and make it active, go to View > Toolbars on the Menu bar. A submenu opens with a list of available toolbars for Draw. Click on a toolbar name to display it and make it active. Active toolbars are indicated by highlighting or a check mark next to the name.

Impress toolbars available

1) 3D-Objects
2) 3D-Settings
3) Align Objects
4) Comments
5) Distribute Selection
6) Drawing
7) Edit Points
8) Find
9) Fontwork
10) Form Controls
11) Form Design
12) Form Navigation
13) Glue Points
14) Image
15) Insert
16) Legacy Circles and Ovals
17) Legacy Rectangles
18) Line and Filling
19) Master View
20) Media Playback
21) Options
22) Redaction
23) Standard
24) Standard (Single Mode)
25) Standard (Viewing Mode)
26) Table
27) Text Formatting
28) Transformations
29) Zoom

Note

Some toolbars, although selected in View > Toolbars on the Menu bar, will not display until an object of the correct type is selected in the drawing. For example, the Image toolbar only displays when an image is selected.

Closing toolbars

To close a toolbar, use one of the following methods:

• Go to View > Toolbars on the Menu bar and deselect the toolbar.
• Right-click on a tool on a toolbar and select Close Toolbar from the context menu.
• Click on the X in the right corner of the title bar of a floating toolbar.
Moving toolbars

Docked toolbars
By default, some toolbars are docked into position in the Draw main window. For example, the Standard toolbar is docked at the top of the main window. Docked toolbars can be undocked and moved to a new docked position on the main window or left as a floating toolbar. Before moving a toolbar, the toolbar must be unlocked.

1) Move the mouse cursor over the small vertical handle at the left end of the toolbar as shown in Figure 1. The mouse cursor changes to a moving cursor for the computer system and setup.
2) Click and hold down the mouse button and drag the toolbar to a new location. This can be a new docked position or a floating toolbar. A hashed border appears around the toolbar indicating the toolbar position as it is dragged.
3) Release the mouse button when the required position is reached.

**Note**
If the small vertical bar is not visible at the left end of a docked toolbar, then the toolbar is locked into position. A docked toolbar must be unlocked before it can be moved to a new position in the Draw main window.

Floating toolbars
To move a floating toolbar, click on its title bar and drag it to a new floating location. Release the mouse button when the toolbar is in the required position. A floating toolbar does not have to be positioned on the Draw main window for it to function.

Floating sub-toolbars
Some tools on a toolbar have a triangle ▼ to the right of the tool indicating that more tools are available on a sub-toolbar, for example Basic Shapes on the Drawing toolbar. Sub-toolbars can be turned into floating toolbars and moved into a new position as follows:

1) Move the mouse cursor over the horizontal handle at the top of the toolbar, as shown in Figure 2. The cursor changes to the moving cursor used for the computer system and setup.
2) Click and hold down the mouse button and drag the toolbar to a new location to create a floating sub-toolbar.
3) Release the mouse button when the required position is reached.
4) To close the floating sub-toolbar, right-click on the triangle ▼ in the sub-toolbar title bar and select Close Toolbar from the context menu.
To dock a floating toolbar, use one of the following methods:

- Click on the title bar and drag it to the top, bottom, left side, or right side of the main window. When the toolbar reaches a docking position, a hashed border appears at the docked position. Release the mouse button and the toolbar is docked.
- Right-click on the toolbar and select Dock Toolbar from the context menu. The toolbar moves into a docked position. If the position is not suitable, move the toolbar to a new docked position.
- To dock all floating toolbars that are active, right-click on the toolbar and select Dock All Toolbars from the context menu.

Docking a floating toolbar

Locked toolbars

When a toolbar has been docked into position on the Draw main window, the toolbar can also be locked into position preventing the toolbar from becoming a floating toolbar.

- To lock a toolbar into a docked position, right-click in a blank area on the toolbar and select Lock Toolbar Position in the context menu. A check mark appears against this option indicating the toolbar is now locked.
- To unlock a toolbar, right-click in a blank area on the toolbar and click on Lock Toolbar Position in the context menu. The check mark next to this option disappears indicating the toolbar is now unlocked. A small vertical or horizontal bar appears at the left end or top of the toolbar indicating that the toolbar is unlocked. This bar is also used to move the toolbar.

Note

Some toolbars cannot be docked or locked into position. This is indicated by the options Dock Toolbar and/or Lock Toolbar Position being grayed out, making the options unavailable.

Locking sub-toolbars

To prevent sub-toolbars from becoming floating sub-toolbars, sub-toolbars have to be locked as follows:

1) Save any drawing that is open in Draw.
2) Go to View > Toolbars on the Menu bar and select Lock Toolbars from the context menu.

3) Select Restart Now in the Restart LibreOffice dialog that opens to activate the Lock Toolbars option.

4) To unlock sub-toolbars so they can become floating sub-toolbars, repeat Steps 1 thru 3. The Lock Toolbars option is an on/off switch.

![Note]

Using Lock Toolbars option affects all sub-toolbars available in LibreOffice modules.

**Editing toolbars**

When LibreOffice is installed on a computer, it includes a set of toolbars suitable for each LibreOffice component. Each toolbar has a default set of visible tools. You can add tools, delete tools, and customize toolbars.

**Adding tools**

1) Right-click in a blank area on a toolbar, or click on the triangle ▼ on the right of the toolbar title bar.

2) Select Visible Buttons from the context menu to display a list of available tools.

3) Click on the tool required and the tool appears in the toolbar. The list of available tools closes automatically. A highlight or check mark next to the tool indicates that the tool is already installed on the toolbar.

![Note]

When adding tools using Visible Buttons, the tool is added to the toolbar at the same position as the tool appears in the Visible Buttons list. That is, the top tool in Visible Buttons appears at the left end of the toolbar and the bottom tool appears at the right end of the toolbar. Tool positions cannot be changed using Visible Buttons.

**Deleting tools**

1) Right-click in a blank area on a toolbar, or click on the triangle ▼ on the right of the toolbar title bar.

2) Select Visible Buttons from the context menu to display a list of available tools.

3) Click on the tool no longer required and the tool is removed from the toolbar. The highlight or check mark next to the tool is also removed. The list of available tools closes automatically.

**Customizing toolbars**

Extra tools and commands that are not available in Visible Buttons can be added to a toolbar using customization. Customization also allows the creation of new toolbars if a specific set of tools are required for a specific task. For information on customizing toolbars, see the Getting Started Guide.
**Toolbars**

**Note**

The tools installed on a toolbar are normally indicated in *Visible Buttons* either by the tool icon being highlighted or by a check mark. However, this install indication depends on computer setup and computer operating system being used.

**Note**

On some toolbars, the icons have a small downward pointing triangle ▼ to the right of an icon. Click on this triangle to open further options that are available for use.

**Note**

Some of the tools in the toolbars also have the option of using a keyboard shortcut instead of clicking on the tool. For a full list of keyboard shortcuts that are available in Draw, see Appendix A, Keyboard Shortcuts.

**3D-Objects**

The 3D-Objects toolbar (Figure 3) provides tools to create 3D objects in a slide. It is activated by going to *View > Toolbars > 3D-Objects* on the Menu bar. Alternatively, click on the triangle ▼ next to the *3D-Objects* icon displayed on the Drawing toolbar to open a submenu giving access to the available 3D objects.

**Available tools from left to right**

1) Cube  
2) Sphere  
3) Cylinder  
4) Cone  
5) Pyramid  
6) Torus  
7) Shell  
8) Half Sphere

![Figure 3: 3D-Objects toolbar](image)

**3D-Settings**

The 3D-Settings toolbar (Figure 4) and its tools only become active when an object has been converted to 3D using the tool *Toggle Extrusion* and the converted object is then selected.

**Available tools from left to right**

1) Toggle Extrusion  
2) Tilt Down  
3) Tilt Up  
4) Tilt Left  
5) Tilt Right  
6) Depth  
7) Direction  
8) Lighting  
9) Surface  
10) 3D Color

![Figure 4: 3D-Settings toolbar](image)
The following tools on this toolbar have a triangle ▼ on the right of the icon. Click on this triangle to open a drop-down menu giving access to various options as follows:

- **Depth** – 3D extrusion depth – 0cm; 1cm; 2.5cm; 5cm; 10cm; Infinity; Custom. The measurement unit depends on the settings in **Tools > Options > LibreOffice Draw > General**.
- **Direction** – 3D extrusion direction and type – Parallel; Perspective.
- **Lighting** – lighting direction and lighting level of 3D extrusion – Bright; Normal; Dim.
- **Surface** – surface type of 3D extrusion – Wire Frame; Matt; Plastic; Metal.
- **3D Color** – color of 3D extrusion. Select a color from one of the available color palettes.

### Align Objects

The Align Objects toolbar (Figure 5) provides tools for aligning several objects in a drawing to improve the visual impact of a drawing.

**Available tools from left to right**

1. Left
2. Centered
3. Right
4. Top
5. Center
6. Bottom

![Align Objects toolbar](image)

*Figure 5: Align Objects toolbar*

### Comments

The Comments toolbar (Figure 6) provides tool for adding, deletion, and navigation of comments in a drawing. To use comments, it is recommended to add the name and initials of all users in **Tools > Options > LibreOffice > User Data** so that comments can be easily identified.

**Available tools from left to right**

1. Comment (Ctrl+Alt+C) (macOS ⌘ + ⌥ + C)
2. Previous Comment
3. Next Comment
4. Delete Comment
5. Delete All Comments

![Comments toolbar](image)

*Figure 6: Comments toolbar*

### Distribute Selection

The Distribute Selection toolbar (Figure 7) provides tools to distribute three or more selected objects evenly along the horizontal axis or vertical axis. Also, the spacing between objects can be evenly distributed.

**Available tools from left to right**

1. Horizontally Left
2. Horizontally Center
3. Horizontally Spacing
4. Horizontally Right
5. Vertically Top
6. Vertically Center
7. Vertically Spacing
8. Vertically Bottom

![Distribute Selection toolbar](image)
**Drawing**

The Drawing toolbar (Figure 8) provides the majority of the tools normally used to create graphic objects in a drawing.

**Available tools from left to right**

1) Select  
2) Zoom & Pan  
3) Zoom  
4) Text Box (F2)  
5) Vertical Text  
6) Insert Fontwork  
7) Line Color  
8) Fill Color  
9) Line  
10) Rectangle  
11) Ellipse  
12) Line Ends with Arrow  
13) Lines and Arrows  
14) Curves and Polygons  
15) Connectors  
16) Basic Shapes  
17) Symbol Shapes  
18) Block Arrows (Arrow Shapes in Visible Buttons))  
19) Flowchart (Flowchart Shapes in Visible Buttons)  
20) Callouts (Callout Shapes in Visible Buttons)  
21) Stars and Banners (Star Shapes in Visible Buttons)  
22) 3D Objects  
23) Rotate  
24) Flip  
25) Align Objects  
26) Arrange  
27) Select at least three objects to distribute (Distribution in visible Buttons)  
28) Shadow  
29) Crop Image (Crop in Visible Buttons)  
30) Filter  
31) Points F8 (Edit Points (F8) in Visible Buttons)  
32) Show Glue Points Function (Glue Points in Visible Buttons)  
33) To Curve  
34) To Polygon  
35) To 3D  
36) T0 3D Rotation Object  
37) Toggle Extrusion  
38) Insert  
39) Controls

**Figure 8: Drawing toolbar**

Some tool shapes on the Drawing toolbar change depending on the last tool that had previously been selected and used.

- Click on the triangle ▼ to the right of a tool to open a pop-up toolbar. Select the required shape to add to a drawing.
- To create a sub-toolbar, click and drag at the top of the pop-up toolbar to an empty area on the main window. The sub-toolbars for each object type and the various shapes available are shown Figures 9 to 18.
Appendix B, Toolbars

Figure 10: Curves and Polygons sub-toolbar

Figure 11: Connectors sub-toolbar

Figure 12: Basic Shapes sub-toolbar

Figure 13: Symbol Shapes sub-toolbar

Figure 14: Block Arrows sub-toolbar

Figure 15: Flowchart sub-toolbar

Figure 16: Callouts sub-toolbar

Figure 17: Stars and Banners sub-toolbar

Figure 18: 3D-Objects sub-toolbar
**Edit Points**

The Edit Points toolbar (Figure 19) provides tools for editing the points of a curve or an object that has been converted to a curve. The toolbar only becomes active when an object is selected and one of the following methods is used to open the toolbar:

- Click on **Edit Points** on the Drawing or Standard toolbar.
- Use the keyboard shortcut **F8**.

**Available tools from left to right**

1) Edit Points (**F8**)  
2) Move Points  
3) Insert Points  
4) Delete Points  
5) Convert to Curve  
6) Close Bezier  
7) Split Curve  
8) Corner Point  
9) Smooth Transition  
10) Symmetric Transition  
11) Eliminate Points

![Figure 19: Edit Points toolbar](image)

**Find**

The Find toolbar (Figure 20) opens by default in the bottom left corner of the Draw main window. This toolbar is normally docked at the bottom left of the Draw main window above the Status bar. However, it can be undocked and made into a floating toolbar.

**Available tools from left to right**

1) Close Find Bar  
2) Find Text  
3) Find Previous  
4) Find Next  
5) Find All  
6) Match Case  
7) Find and Replace (**Ctrl+H**) (**macOS** **⌘+F**)

![Figure 20: Find toolbar](image)

**Fontwork**

The Fontwork toolbar (Figure 21) is used to create graphical text objects in a drawing and provide the tools for editing the graphical text object. This toolbar only becomes active when a Fontwork graphical text object in the drawing has been selected.

**Available tools from left to right**

1) Insert Fontwork Text  
2) Fontwork Shape  
3) Fontwork Same Letter Heights  
4) Fontwork Alignment  
5) Fontwork Character Spacing  
6) Toggle Extrusion

![Figure 21: Fontwork toolbar](image)
Some tools on the Fontwork toolbar have a triangle ▼ to the right of the tool. Click on the triangle to open a pop-up toolbar or drop-down option list.

- **Fontwork Shape** – select the required shape for the Fontwork graphical text object from the options available.
- **Fontwork Alignment** – select the paragraph alignment from the options available.
- **Fontwork Character Spacing** – select the required character spacing from the options available.

## Form Controls

The Form Controls toolbar (Figure 22) provides the tools required to create an interactive form. This allows controls to be added to a form in a text, drawing, spreadsheet, presentation, or HTML document (for example a button that opens another drawing or document).

**Available tools from left to right**

1. Select
2. Design Mode
3. Toggle Form Control Wizards
4. Form Design
5. Control Properties
6. Form Properties
7. Label
8. Text Box
9. Check Box
10. Option Button
11. List Box
12. Combo Box
13. Push Button
14. Image Button
15. Formatted Field
16. Date Field
17. Numerical Field
18. Group Box
19. Time Field
20. Currency Field
21. Pattern Field
22. Table Control
23. Navigation Bar
24. Image Control
25. File Selection
26. Spin Button
27. Scrollbar

![Form Controls toolbar](image)

*Figure 22: Form Control toolbar*

## Form Design

The Form Design toolbar (Figure 23) opens a form in **Design Mode** so that it can be edited. Controls of the form cannot be activated or its contents edited when in **Design Mode**. However, the position and size of the controls can be changed, other properties edited, and added or deleted controls in **Design Mode**.

**Available tools from left to right**

1. Select
2. Control Properties
3. Form Properties
4. Position and Size (F4)
5. Form Navigator
6. Activation Order
7. Add Field
8. Automatic Control Focus
9. Bring to Front (Ctrl+Shift++) (macOS ⌘+Shift++)
10. Send to Back (Ctrl+Shift+-) (macOS ⌘+Shift+-)
11. Group (Ctrl+Shift+G) (macOS ⌘+Shift+G)
12. Ungroup (Ctrl+Alt+Shift+G) (macOS ⌘+⌥+Shift+G)
13. Enter Group (F3)
14. Exit Group (Ctrl+F3) (macOS ⌘+F3)
15. Align Objects
16. Open in Design Mode
17. Display Grid
18. Snap to Grid
19. Helplines While Moving

---

14 | Appendix B, Toolbars
Form Navigation

The Form Navigation toolbar (Figure 24) provides tools to edit a database table or control the data view. The toolbar is normally displayed at the bottom of a document that contains fields that are linked to a database. This toolbar is only active when forms are connected to a database; an inactivate toolbar is shown in Figure 24.

The Form Navigation toolbar also allows movement within records as well as inserting and deleting records. If data is saved in a form, the changes are transferred to the database. This toolbar also provides tools providing sort, filter, and search functions for data records.

**Available tools from left to right**

1) Find Record  
2) Record  
3) Absolute Record  
4) Text -> Record  
5) Total No. of Records  
6) First Record  
7) Previous Record  
8) Next Record  
9) Last Record  
10) New Record  
11) Save Record  
12) Undo: Data entry  
13) Delete Record  
14) Refresh  
15) Refresh Control  
16) Sort  
17) Sort Ascending  
18) Sort Descending  
19) AutoFilter  
20) Apply Filter  
21) Form-Based Filters  
22) Reset Filter/Sort  
23) Data source as Table

Glue Points

The Glue Points toolbar (Figure 25) provides tools to insert a glue point or modify the properties of a glue point. A glue point is a point where a connector is attached to an object. By default, LibreOffice automatically places a glue point at the center of each side of the bounding rectangle for every object created.

**Available tools from left to right**

1) Insert Glue Point  
2) Exit Direction Left  
3) Exit Direction Top  
4) Exit Direction Right  
5) Exit Direction Bottom  
6) Glue Point Relative  
7) Glue Point Horizontal Left  
8) Glue Point Horizontal Center  
9) Glue Point Horizontal Right  
10) Glue Point Vertical Top  
11) Glue Point Vertical Center  
12) Glue Point Vertical Bottom
Image

The Image toolbar (Figure 26) provides tools to edit, modify, align, reposition and resize images. The toolbar only becomes active and available when an image is selected in a drawing. The Image toolbar automatically replaces the Line and Filling toolbar when it becomes active.

Available tools from left to right
1) Position and Size (F4)  17) Line Style
2) Align Objects  18) Line Width
3) Left  19) Line Color
4) Centered  20) Area Style/Filling
5) Top  21) Fill Color
6) Bottom  22) Shadow
7) Centered  23) Filter
8) Top  24) Image Mode
9) Bottom  25) Crop
10) Bring to Front (Ctrl+Shift++) (macOS +Shift++)  26) Vertically
11) Bring Forward (Ctrl++) (macOS +++)  27) Horizontally
12) Send Backward (Ctrl+-) (macOS +-)  28) Transformations
13) Send to Back (Ctrl+Shift+-) (macOS +Shift+-)  29) Transparency
14) In Front of Object  30) Color
15) Behind Object  31) Line
16) Reverse  32) Area
17) Area

Figure 26: Image toolbar

Insert

The Insert toolbar (Figure 27) provides tools to insert different types of objects into a drawing.

Available tools from left to right
1) New Page (Ctrl+M)  6) Insert Audio or Video (Media in Visible
2) Floating Frame  Buttons)
3) Insert Page from File  7) Formula Object (Ctrl+Alt+=) (macOS ++=)
4) Table  8) Chart
5) Image  9) OLE Object

Figure 27: Insert toolbar

Legacy Circles and Ovals

The Legacy Circles and Ovals toolbar (Figure 28) provides tools to insert different types of circles and ovals into a drawing.

Available tools from left to right
1) Insert Ellipse  3) Ellipse Pie
2) Circle  4) Circle Pie

16 | Appendix B, Toolbars
5) Ellipse Segment 10) Circle Pie, Unfilled
6) Circle Segment 11) Ellipse Segment, Unfilled
7) Ellipse, Unfilled 12) Circle Segment, Unfilled
8) Circle, Unfilled 13) Arc
9) Ellipse Pie, Unfilled 14) Circle Arc

![Legacy Circles and Ovals toolbar]

**Legacy Rectangles**

The Legacy Rectangles toolbar (Figure 29) provides tools to insert different types of rectangles and squares into a drawing.

**Available tools from left to right**

1) Insert Rectangle 5) Rectangle, Unfilled 2) Square 6) Square, Unfilled 3) Rectangle, Rounded 7) Rounded Rectangle, Unfilled 4) Rounded Square 8) Rounded Square, Unfilled

![Legacy Rectangles toolbar]

**Line and Filling**

The Line and Filling toolbar (Figure 30) provides tools and drop-down lists for editing lines, arrows, and object borders. The tools available vary depending on the type of object selected for editing.

**Available tools from left to right**


10) Bring to Front (Ctrl+Shift++) (macOS ⌘+Shift++) 11) Bring Forward (Ctrl+) (macOS ⌘+) 12) Send Backward (Ctrl-) (macOS ⌘-) 13) Send to Back (Ctrl+Shift-) (macOS ⌘+Shift-)

14) In Front of Object 15) Behind Object 16) Reverse 17) Line Style
Master View

The Master View toolbar (Figure 31) provides tools to create a new master page, rename a master page, delete a master page, and close master view. This toolbar is only active when Draw is in master view.

Available tools from left to right
1) New Master
2) Rename Master
3) Delete Master
4) Close Master View

Media Playback

The Media Playback toolbar (Figure 32) provides the standard tools required to insert, view, play, and listen to audio and video files. The toolbar only becomes active when an audio or video file is selected. Draw supports many different media formats depending on the computer operating system being used.

Available tools from left to right
1) Insert Audio or Video
2) Play
3) Pause
4) Stop
5) Repeat
6) Position
7) Mute
8) Volume
9) View

Options

The Options toolbar (Figure 33) provides tools for editing various settings for newly created drawings, for example how objects snap to the grid when being moved or resized.

Available tools from left to right
1) Rotation Mode after Clicking Object
2) Display Grid
3) Display Snap Guides
4) Helplines While Moving
5) Snap to Grid
6) Snap to Snap Guides
7) Snap to Page Margins
8) Snap to Object Borders
9) Snap to Object Points
10) Allow Quick Editing
11) Select Text Area Only
12) Double-click to edit Text
13) Modify Object with Attributes
14) Exit All Groups

Figure 33: Options toolbar

Redaction

The Redaction toolbar (Figure 34) is used to block portions of a drawing protecting sensitive information and helps enterprises and organizations to comply with regulations on confidentiality or privacy.

When a redacted drawing is exported to a new drawing, any redacted portions are removed from the new drawing and replaced by redaction blocks of pixels. This prevents any attempt to restore or copy the original contents. A redacted drawing is often exported to PDF for publication or sharing.

Available tools from left to right
1) Rectangle
2) Freeform
3) Redacted Export (White)
4) Redacted Export (Black)
5) PDF

Figure 34: Redaction toolbar

Standard

The Standard toolbar (Figure 35) is common to all LibreOffice components and provides the most common tools when creating and editing documents using LibreOffice. The Standard toolbar differs between LibreOffice components to allow for different toolsets used in creating the different types of documents.

Available tools from left to right
1) Load URL
2) New (Ctrl+N) (macOS ⇧ N)
3) Templates (Ctrl+Shift+N) (macOS ⇧ +Shift+N)
4) Open (Ctrl+O) (macOS ⇧ +O)
5) Open Remote
6) Save (Ctrl+S) (macOS ⇧ +S)
7) Save As (Ctrl+Shift+S) (macOS ⇧ +Shift+S)
8) Email
9) Edit Mode (Ctrl+Shift+M) (macOS ⇧ +Shift+M)
10) Export
11) Export Directly as PDF
12) Print Directly
13) Print (Ctrl+P) (macOS ⇧ +P)
14) Cut (Ctrl+X) (macOS ⇧ +X)
15) Copy (Ctrl+C) (macOS ⇧ +C)
16) Paste (Ctrl+V) (macOS ⇧ +V)
17) Clone Formatting (Clone in Visible Buttons)
18) Clear (Ctrl+Shift+M) (macOS Shift+M)
19) Undo (Ctrl+Z) (macOS ⇧ +Z)
20) Redo (Ctrl+Y) (macOS ⇧ +Y)
21) Spelling (F7)
22) Auto Spellcheck (Shift+F7)
23) Display Grid (Grid in Visible Buttons)
24) Helplines While Moving
25) Zoom & Pan
26) Object Zoom
27) Zoom
28) Table
29) Insert Image (Image in Visible Buttons)
30) Insert Chart (Chart in Visible Buttons)
31) Insert Text Box (F2) (Text Box in Visible Buttons)
32) Insert Special Characters (Symbol in Visible Buttons)
33) Vertical Text
34) Insert Fontwork Text
35) Insert Hyperlink (\textit{Ctrl+K}) (macOS +K) (Hyperlink in Visible Buttons)
36) Transformations
37) Flip
38) Position and Size (F4)
39) Align Objects
40) Distribution
41) Shadow
42) Crop
43) Filter
44) 3D Effects
45) Edit Points (F8)
46) Glue Points
47) Toggle Extrusion
48) Show Draw Functions (Draw Functions in Visible Buttons)
49) LibreOffice Help
50) What’s That
51) Go to First Page
52) Go to Previous Page
53) Go to Next Page
54) Go to Last Page
55) Move Page to Start
56) Move Page Up
57) Move Page Down
58) Move Page to End

Figure 35: Standard toolbar

\textbf{Standard (Viewing Mode)}

The Standard (Viewing Mode) toolbar (Figure 36) provides tools to save, edit, and distribute a drawing.

\textbf{Available tools from left to right}
1) \textit{Save As} (Ctrl+Shift+S) (macOS +S)
2) \textit{Edit Mode} (Ctrl+Shift+M) (macOS +Shift+M)
3) \textit{Read Only Mode}
4) \textit{Attach to Email} (Email in Visible Buttons)
5) \textit{Export Directly as PDF}
6) EPUB
7) \textit{Print Directly}
8) \textit{Print} (Ctrl+P) (macOS +P)
9) Copy (Ctrl+C) (macOS +C)
10) \textit{Find and Replace} (Ctrl+H) (macOS +⌥+F)
11) \textit{Zoom}
12) \textit{Start from First Slide} (F5)

Figure 36: Standard (Viewing Mode) toolbar

\textbf{Table}

The Table toolbar (Figure 37) provides tools and options to edit and format a table placed in a drawing. This toolbar only becomes active when a table is selected.

\textbf{Available tools from left to right}
1) \textit{Table}
2) \textit{Border Style}
3) \textit{Border Color}
4) \textit{Borders} (Shift to overwrite)
5) \textit{Area Style/Filling}
6) \textit{Fill Color}
7) \textit{Merge Cells}
8) \textit{Split Cells}
9) \textit{Optimize}
10) \textit{Align Top} (Top in Visible Buttons)
11) \textit{Center Vertically} (Center in Visible Buttons)
12) \textit{Align Bottom} (Bottom in Visible Buttons)
13) \textit{Insert Row Above}
14) \textit{Insert Row Below}

20 | Appendix B, Toolbars
15) Insert Column Before  
16) Insert Column After  
17) Delete Row  
18) Delete Column  
19) Delete Table  
20) Select Table  
21) Select Column  
22) Select Row  
23) Table Design  
24) Table Properties

Figure 37: Table toolbar

Text Formatting

The Text Formatting toolbar (Figure 38) provides tools for formatting text and alignment commands. This toolbar becomes active when text in a text box or graphic object has been selected and it automatically replaces the Line and Filling toolbar.

Available tools from left to right

1) Font Name  
2) Font Size  
3) Increase Font Size \((Ctrl+\rangle\) (macOS \(\langle\rangle\)) (Increase in Visible Buttons)  
4) Decrease Font Size \((Ctrl+\rangle\) (macOS \(\langle\rangle\)) (Decrease in Visible Buttons)  
5) Bold \((Ctrl+B)\) (macOS \(\langle\rangle\+B)\)  
6) Italic \((Ctrl+I)\) (macOS \(\langle\rangle\+I)\)  
7) Underline \((Ctrl+U)\) (macOS \(\langle\rangle\+U)\)  
8) Double Underline  
9) Strikethrough  
10) Overline  
11) Superscript \((Ctrl+Shift+\rangle)\) (macOS \(\langle\rangle+Shift+\rangle)\)  
12) Subscript \((Ctrl+Shift+B)\) (macOS \(\langle\rangle+Shift+B)\)  
13) Toggle Shadow (Shadow in Visible Buttons)  
14) Apply outline attribute to font (Outline Font Effect in Visible Buttons)  
15) Clear \((Ctrl+Shift+M)\) (macOS \(\langle\rangle+Shift+M)\)  
16) Lowercase  
17) UPPERCASE  
18) SMALL CAPITALS  
19) Font Color  
20) Character Highlighting Color  
21) Toggle Unordered List (Unordered List in Visible Buttons)  
22) Toggle Ordered List (Ordered List in Visible Buttons)  
23) Outline Format  
24) Align Left \((Ctrl+L)\) (macOS \(\langle\rangle+L)\) (Left in Visible Buttons)  
25) Align Center \((Ctrl+E)\) (macOS \(\langle\rangle+E)\) (Center in Visible Buttons)  
26) Align Right \((Ctrl+R)\) (macOS \(\langle\rangle+R)\) (Right in Visible Buttons)  
27) Justified \((Ctrl+J)\) (macOS \(\langle\rangle+J)\)  
28) Align Top (Top in Visible Buttons)  
29) Center Vertically (Center in Visible Buttons)  
30) Align Bottom (Bottom in Visible Buttons)  
31) Set Line Spacing (Line Spacing in Visible Buttons)  
32) Character Spacing  
33) Increase Paragraph Spacing (Increase in Visible Buttons)  
34) Decrease Paragraph Spacing (Decrease in Visible Buttons)  
35) Text direction from left to right  
36) Text direction from top to bottom  
37) Left-To-Right  
38) Right-To-Left  
39) Select All \((Ctrl+A)\) (macOS \(\langle\rangle+A)\)  
40) Character  
41) Paragraph
Transformations
The Transformations toolbar (Figure 39) provides tools to modify the shape, orientation, or fill of selected objects.

**Available tools from left to right**
1) Rotate
2) Flip
3) In 3D Rotation Object
4) Set in Circle (perspective)
5) Set to circle (slant)
6) Distort
7) Interactive transparency tool (Transparency tool in Visible Buttons)
8) Interactive gradient tool (Gradient tool in Visible Buttons)

Zoom
The Zoom toolbar (Figure 40) provides tools to reduce or enlarge the screen display of the current drawing.

**Available tools from left to right**
1) Zoom In
2) Zoom Out
3) 100%
4) Zoom Previous
5) Zoom Next
6) Entire Page
7) Page Width
8) Optimal View (Optimal in Visible Buttons)
9) Object Zoom
10) Zoom & Pan
11) Shift